TIBCO ActiveMatrix® Adapter for IBM i

Examples

Software Release 6.0
March 2010
Important Information

SOME TIBCO SOFTWARE EMBEDS OR BUNDLES OTHER TIBCO SOFTWARE. USE OF SUCH EMBEDDED OR BUNDLED TIBCO SOFTWARE IS SOLELY TO ENABLE THE FUNCTIONALITY (OR PROVIDE LIMITED ADD-ON FUNCTIONALITY) OF THE LICENSED TIBCO SOFTWARE. THE EMBEDDED OR BUNDLED SOFTWARE IS NOT LICENSED TO BE USED OR ACCESSED BY ANY OTHER TIBCO SOFTWARE OR FOR ANY OTHER PURPOSE.

USE OF TIBCO SOFTWARE AND THIS DOCUMENT IS SUBJECT TO THE TERMS AND CONDITIONS OF A LICENSE AGREEMENT FOUND IN EITHER A SEPARATELY EXECUTED SOFTWARE LICENSE AGREEMENT, OR, IF THERE IS NO SUCH SEPARATE AGREEMENT, THE CLICKWRAP END USER LICENSE AGREEMENT WHICH IS DISPLAYED DURING DOWNLOAD OR INSTALLATION OF THE SOFTWARE (AND WHICH IS DUPLICATED IN LICENSE.PDF) OR IF THERE IS NO SUCH SOFTWARE LICENSE AGREEMENT OR CLICKWRAP END USER LICENSE AGREEMENT, THE LICENSE(S) LOCATED IN THE “LICENSE” FILE(S) OF THE SOFTWARE. USE OF THIS DOCUMENT IS SUBJECT TO THOSE TERMS AND CONDITIONS, AND YOUR USE HEREOF SHALL CONSTITUTE ACCEPTANCE OF AND AN AGREEMENT TO BE BOUND BY THE SAME.

This document contains confidential information that is subject to U.S. and international copyright laws and treaties. No part of this document may be reproduced in any form without the written authorization of TIBCO Software Inc.


EJB, Java EE, J2EE, and all Java-based trademarks and logos are trademarks or registered trademarks of Sun Microsystems, Inc. in the U.S. and other countries.

All other product and company names and marks mentioned in this document are the property of their respective owners and are mentioned for identification purposes only.

THIS SOFTWARE MAY BE AVAILABLE ON MULTIPLE OPERATING SYSTEMS. HOWEVER, NOT ALL OPERATING SYSTEM PLATFORMS FOR A SPECIFIC SOFTWARE VERSION ARE RELEASED AT THE SAME TIME. SEE THE README.TXT FILE FOR THE AVAILABILITY OF THIS SOFTWARE VERSION ON A SPECIFIC OPERATING SYSTEM PLATFORM.

THIS DOCUMENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

THIS DOCUMENT COULD INCLUDE TECHNICAL INACCURACIES OR TYPOGRAPHICAL ERRORS. CHANGES ARE PERIODICALLY ADDED TO THE INFORMATION HERIN; THESE CHANGES WILL BE INCORPORATED IN NEW EDITIONS OF THIS DOCUMENT. TIBCO SOFTWARE INC. MAY MAKE IMPROVEMENTS AND/OR CHANGES IN THE PRODUCT(S) AND/OR THE PROGRAM(S) DESCRIBED IN THIS DOCUMENT AT ANY TIME.

THE CONTENTS OF THIS DOCUMENT MAY BE MODIFIED AND/OR QUALIFIED, DIRECTLY OR INDIRECTLY, BY OTHER DOCUMENTATION WHICH ACCOMPANIES THIS SOFTWARE, INCLUDING BUT NOT LIMITED TO ANY RELEASE NOTES AND "READ ME" FILES.

Copyright © 1998-2010 TIBCO Software Inc. ALL RIGHTS RESERVED.

TIBCO Software Inc. Confidential Information
Contents

Figures ................................................................. vii

Preface .................................................................... ix

Related Documentation ......................................................... x
  TIBCO ActiveMatrix Adapter for IBM i Documentation ..................................... x
  Other TIBCO Product Documentation ............................................................. x
  Third-Party Documentation ................................................................ xi

Typographical Conventions ......................................................... xii

How to Contact TIBCO Support ............................................................ xv

Chapter 1 Introduction............................................................... 1
  Overview ........................................................................ 2
  Prerequisites .................................................................... 4

Chapter 2 Publication Service Example ................................................... 5
  Example Description ............................................................ 6
  Setting Up the Example ........................................................ 7
  Running the Example ........................................................... 10
  Expected Results ................................................................. 11

Chapter 3 Publication Service (Publisher Key) Example .................................. 13
  Example Description ............................................................ 14
  Setting Up the Example ........................................................ 15
  Running the Example ........................................................... 18
  Expected Results ................................................................. 19

Chapter 4 Request-Response Invocation Service Example .................................. 21
  Example Description ............................................................ 22
  Setting Up the Example ........................................................ 23
  Running the Example ........................................................... 27
  Expected Results ................................................................. 28

TIBCO ActiveMatrix Adapter for IBM i Examples
Figures

Figure 1  Message Schema of the Publication Service Example ....................................................... 8
Figure 2  Published Message ............................................................................................................. 11
Figure 3  Message Schema of the Publication Service (Publisher Key) Example ............................ 16
Figure 4  Published Keyed Message ................................................................................................. 19
Figure 5  Message Schema of the Request-Response Invocation Service ...................................... 24
Figure 6  Fields in the Reply Message .............................................................................................. 26
Figure 7  Request Message ............................................................................................................... 28
Figure 8  Received Customer Information ....................................................................................... 29
Figure 9  Message Schema of the Request-Response Service (Data Queue Write) ..................... 34
Figure 10 Activity Input of Invoke Customer_Inquiry_Server .............................................................. 36
Figure 11 Reply Message ................................................................................................................... 38
Figure 12 Program Schema of the Request-Response Service ......................................................... 42
Figure 13 Input of the Reply to CPA5305 Activity .......................................................................... 43
Figure 14 Input of the Reply to Other Messages Activity .................................................................. 44
Figure 15 Set the XPath for Transition CPA5305 ........................................................................... 45
Figure 16 Input of the Call CUSTMR_ADD Activity ....................................................................... 46
Figure 17 New Customer Record ..................................................................................................... 48
Figure 18 QSYSOPR Message ......................................................................................................... 49
Figure 19 Input of the Invoke SpooledFilesList_Server Activity ................................................... 54
Figure 20 Spooled Files List ............................................................................................................. 56
Figure 21 Input of the Invoke SpooledFileToPDF_Server Activity ................................................... 60
Figure 22 Input of the Write File Resource ...................................................................................... 61
Figure 23 Program Schema of the Request-Response Service (Sequence) Example .................. 68
Figure 24 Read File ............................................................................................................................ 68
Figure 25 Customer Number Value Sequence .................................................................................. 70
Figure 26 Message Schema of the Subscription Service (Data Queue Write) ............................... 74
Figure 27 Input of the Publish to Customer_DQUpdate_Subscriber Activity ................................ 75
Figure 28 Program Schema of the Subscription Service (Program Call) ....................................... 82
Figure 29 Input of the Call CUSTMR_UPD Activity. ................................. 83
Preface

TIBCO ActiveMatrix Adapter for IBM i allows one-way (publish or subscribe) or two-way (request-response) message exchange between TIBCO applications and applications running on IBM System i machines.

This manual presents examples that demonstrate key adapter features. Work through these examples to get a hands-on understanding of how the adapter works.

Topics

- Related Documentation, page x
- Typographical Conventions, page xii
- How to Contact TIBCO Support, page xv
Related Documentation

This section lists documentation resources you may find useful.

**TIBCO ActiveMatrix Adapter for IBM i Documentation**

The following documents form the TIBCO ActiveMatrix Adapter for IBM i documentation set:

- *TIBCO ActiveMatrix Adapter for IBM i Concepts*  Read this manual before reading any other book in the documentation set to familiarize yourself with the product and its uses.
- *TIBCO ActiveMatrix Adapter for IBM i Installation*  Read this manual for instructions on site preparation and installation.
- *TIBCO ActiveMatrix Adapter for IBM i Configuration and Deployment*  Read this manual for instructions on creating and configuring standalone adapter projects. Information on deploying adapter projects is also included.
- *TIBCO ActiveMatrix Adapter for IBM i Examples*  Read this manual to work through the examples provided with the adapter.
- *TIBCO ActiveMatrix Adapter for IBM i Release Notes*  Read the release notes for a list of new and changed features. This document also contains lists of closed and known issues for this release.

**Other TIBCO Product Documentation**

You may find it useful to read the documentation for the following TIBCO products:

- TIBCO ActiveMatrix BusinessWorks™
- TIBCO Adapter™ SDK
- TIBCO Administrator™
- TIBCO Designer™
- TIBCO Enterprise Message Service™
- TIBCO Hawk®
- TIBCO Rendezvous®
- TIBCO Runtime Agent™
- TIBCO ActiveEnterprise™
Third-Party Documentation

You may also find it useful to read the IBM documentation on the following websites:

- [http://jt400.sourceforge.net/](http://jt400.sourceforge.net/)
## Typographical Conventions

The following typographical conventions are used in this manual.

### Table 1 General Typographical Conventions

<table>
<thead>
<tr>
<th>Convention</th>
<th>Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>TIBCO_HOME</td>
<td>Many TIBCO products must be installed within the same home directory. This directory is referenced in documentation as TIBCO_HOME. The value of TIBCO_HOME depends on the operating system. For example, on Windows systems, the default value is C:\tibco.</td>
</tr>
<tr>
<td>ENV_HOME</td>
<td>Other TIBCO products are installed into an installation environment. Incompatible products and multiple instances of the same product are installed into different installation environments. The directory into which such products are installed is referenced in documentation as ENV_HOME. The value of ENV_HOME depends on the operating system. For example, on Windows systems the default value is C:\tibco.</td>
</tr>
<tr>
<td>ADAS400_HOME</td>
<td>TIBCO ActiveMatrix Adapter for IBM i installs into a directory within TIBCO_HOME. This directory is referenced in documentation as ADAS400_HOME. The value of ADAS400_HOME depends on the operating system. For example on Windows systems, the default value is C:\tibco\adapter\adas400\6.0.</td>
</tr>
</tbody>
</table>

**Bold code font**

Bold code font is used in the following ways:

- In procedures, to indicate what a user types. For example: Type `admin`.
- In large code samples, to indicate the parts of the sample that are of particular interest.
- In command syntax, to indicate the default parameter for a command. For example, if no parameter is specified, `MyCommand` is enabled: `MyCommand [enable | disable]`.
### Table 1  General Typographical Conventions (Cont’d)

<table>
<thead>
<tr>
<th>Convention</th>
<th>Use</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>italic font</em></td>
<td>Italic font is used in the following ways:</td>
</tr>
<tr>
<td></td>
<td>• To indicate a document title. For example: See <em>TIBCO ActiveMatrix BusinessWorks Concepts</em>.</td>
</tr>
<tr>
<td></td>
<td>• To introduce new terms For example: A portal page may contain several portlets. <em>Portlets</em> are mini-applications that run in a portal.</td>
</tr>
<tr>
<td></td>
<td>• To indicate a variable in a command or code syntax that you must replace. For example: <em>MyCommand PathName</em></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Key combinations</th>
<th>Use</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Key name separated by a plus sign indicate keys pressed simultaneously. For example: Ctrl+C.</td>
</tr>
<tr>
<td></td>
<td>Key names separated by a comma and space indicate keys pressed one after the other. For example: Esc, Ctrl+Q.</td>
</tr>
</tbody>
</table>

| ![Note Icon]     | The note icon indicates information that is of special interest or importance, for example, an additional action required only in certain circumstances. |
| ![Tip Icon]      | The tip icon indicates an idea that could be useful, for example, a way to apply the information provided in the current section to achieve a specific result. |
| ![Warning Icon]  | The warning icon indicates the potential for a damaging situation, for example, data loss or corruption if certain steps are taken or not taken. |

### Table 2  Syntax Typographical Conventions

<table>
<thead>
<tr>
<th>Convention</th>
<th>Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>[ ]</td>
<td>An optional item in a command or code syntax.</td>
</tr>
<tr>
<td></td>
<td>For example:</td>
</tr>
<tr>
<td></td>
<td><em>MyCommand [optional_parameter] required_parameter</em></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>For example, you can select only one of the following parameters:</td>
</tr>
</tbody>
</table>
|            | *MyCommand para1 | param2 | param3*
Table 2  Syntax Typographical Conventions (Cont’d)

<table>
<thead>
<tr>
<th>Convention</th>
<th>Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>{ }</td>
<td>A logical group of items in a command. Other syntax notations may appear within each logical group.</td>
</tr>
<tr>
<td></td>
<td>For example, the following command requires two parameters, which can be either the pair param1 and param2, or the pair param3 and param4.</td>
</tr>
<tr>
<td></td>
<td>MyCommand {param1 param2}</td>
</tr>
<tr>
<td></td>
<td>In the next example, the command requires two parameters. The first parameter can be either param1 or param2 and the second can be either param3 or param4:</td>
</tr>
<tr>
<td></td>
<td>MyCommand {param1</td>
</tr>
<tr>
<td></td>
<td>In the next example, the command can accept either two or three parameters. The first parameter must be param1. You can optionally include param2 as the second parameter. And the last parameter is either param3 or param4:</td>
</tr>
<tr>
<td></td>
<td>MyCommand param1 [param2] {param3</td>
</tr>
</tbody>
</table>
How to Contact TIBCO Support

For comments or problems with this manual or the software it addresses, please contact TIBCO Support as follows.

- For an overview of TIBCO Support, and information about getting started with TIBCO Support, visit this site:
  http://www.tibco.com/services/support
- If you already have a valid maintenance or support contract, visit this site:
  https://support.tibco.com

Entry to this site requires a user name and password. If you do not have a user name, you can request one.
Chapter 1  Introduction

This chapter contains an overview of and the prerequisites for the examples. Details about how to use the examples are explained in later chapters of this book.

Topics

- Overview, page 2
- Prerequisites, page 4
Overview

The examples shipped with the installation package demonstrate how to configure the adapter with Publication Service, Request-Response Invocation Service, Request-Response Service, and Subscription Services.

- Though all of the examples demonstrate adapter functionality in support of customer needs, they are not related. Each example should be considered separately.
- Do not change the names given in the examples when trying the example scenarios. Changing names may result in example scenarios not working correctly.

Details for the examples are as follows:

- **Chapter 2, Publication Service Example** demonstrates a Publication Service that publishes a message from an application program running on an IBM System i machine.
- **Chapter 3, Publication Service (Publisher Key) Example** demonstrates a Publication Service that publishes a message by key from an application program running on an IBM System i machine.
- **Chapter 4, Request-Response Invocation Service Example** demonstrates a Request-Response Invocation Service that sends a request for customer information and receives the reply.
- **Chapter 5, Request-Response Service (Data Queue Write) Example** demonstrates a Request-Response Service that writes a message to a request data queue to query a customer record and receives the reply with customer details.
- **Chapter 6, Request-Response Service (Program Call) Example** demonstrates a Request-Response Service that invokes an application program in synchronous mode to create a new customer record. This example also has a Request-Response Invocation Service to monitor for error messages generated by the invoked application program.
- **Chapter 7, Request-Response Service (Spooled Files List) Example** demonstrates a Request-Response Service that allows you to specify selection criteria and retrieve a list of spooled files from an IBM System i machine.
- **Chapter 8, Request-Response Service (Spooled File to PDF) Example** demonstrates a Request-Response Service that converts a spooled file to PDF format.
• Chapter 9, Request-Response Service (Sequence) Example demonstrates a Request-Response Service that sets sequence 5 as a property of the data attribute in its program schema.

• Chapter 10, Subscription Service (Data Queue Write) Example demonstrates a Subscription Service that writes a message to a data queue on an IBM System i machine to update a customer record.

• Chapter 11, Subscription Service (Program Call) Example demonstrates a Subscription Service that calls an application program on an IBM System i machine to update a customer record.
Prerequisites

The examples are located in the `ADAS400_HOME\examples` directory. The repository is `Samples.dat`.

An IBM System i save file containing an example library is also included in this directory. To load this library on an IBM System i machine:

1. On the machine where the adapter is installed, start a command session. Change the directory of the command session to `ADAS400_HOME\examples`.
2. Start an FTP session in the command session to connect to an IBM System i machine.
3. In the FTP session, change transfer mode to binary using command `bin`.
4. Transfer `ADAS400.SAVF` from the `ADAS400_HOME\examples` directory to the save file on the IBM System i machine by entering the following command:
   
   ```sh
   put ADAS400.SAVF library_name/ADAS400
   ```

   where `library_name` is the name of the library where the save file ADAS400 exists.

5. After the transfer is complete, sign on to the IBM System i machine and restore the example library `ADAS400` by entering the following the command:

   ```sh
   RSTLIB SAVLIB(ADAS400) DEV(*SAVF) SAVF(library_name/ADAS400)
   ```

   where `library_name` is name of the library where the save file ADAS400 exists.

The example library is compatible with IBM i operating system version V5R4 or higher.
Chapter 2 Publication Service Example

This example demonstrates a Publication Service that publishes a message from an application program running on an IBM System i machine.

Topics

- Example Description, page 6
- Setting Up the Example, page 7
- Running the Example, page 10
- Expected Results, page 11
Example Description

This example consists of a Publication Service named CustomerMessage_Publisher and a TIBCO ActiveMatrix BusinessWorks process named Receive CustomerMessage process.

In this examples:

1. An application program named PUBLISH_PGM sets the values of message data structure elements and invokes a data queue writer program named PUBLISHER on an IBM System i machine.
2. The data queue writer program named PUBLISHER writes the message to the outbound data queue.
3. The adapter gets the message and the Publication Service publishes the message to the TIBCO environment.
4. The TIBCO ActiveMatrix BusinessWorks process receives the message.
Setting Up the Example

To set up the example, you need to complete the following configurations.

**Task A  Import the Project**

In TIBCO Designer:

1. Start TIBCO Designer and select **New empty project**.
2. From the Project menu, select **Import Full Project**.
3. In the Local Repository tab, browse to locate the `Samples.dat` file. The file is located in the `ADAS400_HOME/examples` folder.
4. Import the `Samples.dat` file with the default options.
   All the pre configured instances of the adapter and the corresponding processes are included in the new project.
   Click **OK** when an error pops up indicating *Server server_name* not found.
5. Select the adapter instance named `IBMiAdapterConfiguration`. Change the configuration as necessary.
   For example, you may need to change the values of the Server Name field, User field, and Password field in the Design-time Connection tab. Click **Apply**. Then click **Test Connection** to ensure that the adapter can connect to the IBM System i application.
6. Save the project.

**Task B  Configure the Publication Service**

1. In the Project panel, select the `CustomerMessage_Publisher` adapter service.
2. Click the **Queue Configuration** tab.
   The queues and sources are configured as follows:
   — Data Queue for Publish: `ADAS400/ADAS400PUB`
   — Generate in Source File: `ADAS400/ADAS400SRC`
   — Generate Member of Name: `DS_CUSTMSG`
3. Click the **Message Schema** tab to check the data attributes for the message to be sent.
4. Click **Upload** to generate an ILE RPG source for the schema on the IBM System i machine. Click **Apply**.

5. Save the project.

Saving the adapter configuration will generate the data queue writer program named **PUBLISHER** on the IBM System i machine.

**Task C  Create an ILE RPG Application to Publish Messages**

An application program on the IBM System i machine will use the ILE RPG schema source to set the values of various message fields, as well as publish the message by calling the data queue writer program **PUBLISHER**, which is also generated by the adapter palette.

A sample application program named **PUBLSH_PGM** is provided in the examples library **ADAS400** on the IBM System i machine, as follows:

```
*************** Beginning of data *************************************
D/Copy ADAS400/ADAS400SRC,DS_CUSTMSG
**---------------------------------------------------------------------
* Move values to message variables
C                     Eval      Entry.Customer_Id = 4245
C                     Eval      Entry.Customer_Name = 'Test from HAWK400'
C                     Eval      Contact_Info.Tel_No = '1-800-GET-TIBCO'
C                     Eval      Contact_Info.Email = 'getTIBCO@tibco.com'
C                     Eval      Address.Line1 = '3303 HillView Ave.'
C                     Eval      Address.Line2 = *Blanks
C                     Eval      Address.City = 'Palo Alto'
C                     Eval      Address.State = 'CA'
C                     Eval      Address.ZipCode = 94304
```

---

**Figure 1  Message Schema of the Publication Service Example**

![Message Schema](image)

**CustomerMessage_Publisher (Publication Service)**

<table>
<thead>
<tr>
<th>Schema</th>
<th>Use Attribute</th>
<th>Description</th>
<th>AG400 Type</th>
<th>Adapter Type</th>
<th>Sequence</th>
</tr>
</thead>
<tbody>
<tr>
<td>Entry</td>
<td></td>
<td></td>
<td>Packed Decimal fixed 9.0</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Customer_Id</td>
<td></td>
<td>Character</td>
<td>char.50</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Customer_Name</td>
<td></td>
<td>Character</td>
<td>char.50</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Contact_Info</td>
<td></td>
<td>Character</td>
<td>char.20</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Tel_No</td>
<td></td>
<td>Character</td>
<td>char.40</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Email</td>
<td></td>
<td>Character</td>
<td>char.40</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Address</td>
<td></td>
<td>Character</td>
<td>char.50</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Line1</td>
<td></td>
<td>Character</td>
<td>char.50</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Line2</td>
<td></td>
<td>Character</td>
<td>char.60</td>
<td></td>
<td></td>
</tr>
<tr>
<td>City</td>
<td></td>
<td>Character</td>
<td>char.30</td>
<td></td>
<td></td>
</tr>
<tr>
<td>State</td>
<td></td>
<td>Character</td>
<td>char.3</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ZipCode</td>
<td></td>
<td>Zoned Decimal fixed 5.0</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
* Call 'PUBLISHER' program generated by TIBCO Adapter for IBM AS/400
* message to external applications
C                   Call      'PUBLISHER'
C                   Parm                    MessageHeader
C                   Parm                    EntryBuffer
C                   Move      *On           *InLR
****************** End of data ****************************************

**Task D  Configure the TIBCO ActiveMatrix BusinessWorks Process**

A TIBCO ActiveMatrix BusinessWorks process named Receive CustomerMessage process is defined for this example.

1. In the Project panel, select **BW Processes > Receive CustomerMessage Process**.
2. In the Design panel, select the activity named **Receive CustomerMessage**.
3. In the Configuration tab, click the **Refresh Adapter Service** button.
4. Save the project.
Running the Example

To run this example, you need to start the adapter and run the TIBCO ActiveMatrix BusinessWorks process in TIBCO Designer, and then invoke the ILE RPG application program to publish a message from the IBM System i machine.

**Task A  Start the Adapter**

In TIBCO Designer:

1. From the Tools menu, select Show Adapter Tester.
2. Select the adapter instance named IBMiAdapterConfiguration.
3. Click the Run Settings tab. In the Working Directory field, enter a temporary directory to place running files in.
4. In the Adapter Executable field, select the executable. For example, TIBCO ActiveMatrix Adapter for IBM i 6.0 (adas400.exe). Click Apply.
5. Click Start. To view the status messages, go to the Console tab.

**Task B  Run the TIBCO ActiveMatrix BusinessWorks Process**

In TIBCO Designer:

1. Click the Tester tab, then click the Start testing viewed process button.
3. Click Load Selected.

**Task C  Publish a Message**

Run the following command from the command line of the IBM System i machine:

```
CALL ADAS400/PUBLSH_PGM
```
Expected Results

After starting the Publisher ILE RPG program, a message is sent to the output queue on the IBM System i machine. The adapter gets the message from the queue and sends it to the TIBCO environment. The Receive_CustomMessage activity in the TIBCO ActiveMatrix BusinessWorks process gets the message.

You can view the message in TIBCO Designer:
1. In the TIBCO ActiveMatrix BusinessWorks tester, click the Output tab.
2. Expand the body tag to view the message.

Figure 2   Published Message
This example demonstrates a Publication Service that publishes a message by key from an application program running on an IBM System i machine.

Topics

- Example Description, page 14
- Setting Up the Example, page 15
- Running the Example, page 18
- Expected Results, page 19
Example Description

This example consists of a Publication Service named Key_Publisher and a TIBCO ActiveMatrix BusinessWorks process named Key_pub_receiver.

In this examples:

1. An application program named PUBLSH_KEY sets the values of message data structure elements and invokes a data queue writer program named PUBLISHER on an IBM System i machine.

2. The data queue writer program named PUBLISHER writes the message to the outbound data queue, which is a keyed data queue.

3. The adapter gets the message and the Publication Service publishes the keyed message to TIBCO environment.

4. The TIBCO ActiveMatrix BusinessWorks process receives the message.
Setting Up the Example

To set up the example, you need to complete the following configurations.

**Task A  Import the Project**

In TIBCO Designer:

1. Start TIBCO Designer and select *New empty project*.
2. Click *Project > Import Full Project*.
3. In the Local Repository tab, browse to locate the *Samples.dat* file. The file is located in the `ADAS400_HOME/examples` folder.
4. Import the *Samples.dat* file with the default options.
   
   All the pre configured instances of the adapter and the corresponding processes are included in the new project.

   Click *OK* when an error pops up indicating Server *server_name* not found.

5. Select the adapter instance named *IBMiAdapterConfiguration*. Change the configuration as necessary.

   For example, you may need to change the values of the Server Name field, User field, and Password field in the Design-time Connection tab. Click *Apply*. Then click *Test Connection* to ensure that the adapter can connect to the IBM System i application.

6. Save the project.

**Task B  Configure the Publication Service**

1. In the Project panel, select the *CustomerMessage_Publisher* adapter service.
2. Click the *Queue Configuration* tab.
   
   The queues and sources are configured as follows:
   
   — Data Queue for Publish: `ADAS400/ADAS400KPUB`
   
   — select the *Is Publisher Key Used?* checkbox
   
   — Publisher Key: 12345
   
   — Generate in Source File: `ADAS400/ADAS400SRC`
   
   — Generate Member of Name: `DS_CUSTMSK`

3. Click the *Message Schema* tab to check the data attributes for the message to be sent.
4. Click **Upload** to generate an ILE RPG source for the schema on the IBM System i machine. Click **Apply**.

5. Save the project.

**Task C  Create an ILE RPG Application to Publish Messages**

An application program on the IBM System i machine will use the ILE RPG schema source to set the values of various message fields, as well as publish the message by calling the data queue writer program `PUBLISHER`, which is also generated by the adapter palette.

A sample application program named `PUBLSH_KEY` is provided in the examples library `ADAS400` on the IBM System i machine, as follows:

```
********** Beginning of data ******************************************************
D/Copy ADAS400/ADAS400SRC,DS_CUSTMSK
*******************************************************************************
* Move values to message variables
C Eval Key.PubKey='12345'
C Eval Entry.Customer_Id = 4245
C Eval Entry.Customer_Name = 'Test from HAW
C Eval Contact_Info.Tel_No = '1-800-GET-TIB
C Eval Contact_Info.Email = 'getTIBCO@tibco
C Eval Address.Line1 = '3303 HillView Ave.'
C Eval Address.Line2 = *Blanks
C Eval Address.City = 'Palo Alto'
C Eval Address.State = 'CA'
C Eval Address.ZipCode = 94304
```
Task D  Configure the TIBCO ActiveMatrix BusinessWorks Process

A TIBCO ActiveMatrix BusinessWorks process named Key pub receiver is defined for this example.

1. In the Project panel, select BW Processes > Key pub receiver.
2. In the Design panel, select the activity named Receive CustomerMessage.
3. In the Configuration tab, click the Refresh Adapter Service button.
4. Save the project.
Running the Example

To run this example, you need to start the adapter and run the TIBCO ActiveMatrix BusinessWorks process in TIBCO Designer, and then invoke the ILE RPG application program in to publish a message from the IBM System i machine.

Task A  Start the Adapter

In TIBCO Designer:

1. From the Tools menu, select **Show Adapter Tester**.
2. Select the adapter instance named **IBMiAdapterConfiguration**.
3. Click the **Run Settings** tab. In the Working Directory field, enter a temporary directory to place running files in.
4. In the Adapter Executable field, select the executable. For example, **TIBCO ActiveMatrix Adapter for IBM i 6.0 (adas400.exe)**. Click **Apply**.
5. Click **Start**. To view the status messages, go to the **Console** tab.

Task B  Run the TIBCO ActiveMatrix BusinessWorks Process

In TIBCO Designer:

1. Click the **Tester** tab, then click the **Start testing viewed process** button.
2. Select the process named **Key pub receiver**.
3. Click **Load Selected**.

Task C  Publish a Message

Run the following command from the command line of the IBM System i machine:

**CALL ADAS400/PUBLISH_KEY**
Expected Results

After starting the ILE RPG program, a message is sent to the output queue on the IBM System i machine. The adapter gets the message from the queue and sends it to the TIBCO environment. The Receive CustomMessage activity in the TIBCO ActiveMatrix BusinessWorks process gets the message.

You can view the message in TIBCO Designer:

1. In the TIBCO ActiveMatrix BusinessWorks tester, click the Output tab.
2. Expand the body tag.

Figure 4  Published Keyed Message
Chapter 4  Request-Response Invocation Service Example

This example demonstrates a Request-Response Invocation Service that sends a request from an application running on an IBM System i machine and receives a reply with the requested information.

Topics

- Example Description, page 22
- Setting Up the Example, page 23
- Running the Example, page 27
- Expected Results, page 28
Example Description

This example consists a Request-Response Invocation Service named CustomerInformation_Client and a TIBCO ActiveMatrix BusinessWorks process named Receive Customer Information Request from IBM System i.

In this example:

1. An application program running on the IBM System i machine invokes the data queue writer/reader program.
2. The data queue writer/reader program writes a message with key information to the outbound data queue.
3. The Request-Response Invocation Service gets the message and sends it to the TIBCO environment.
4. The TIBCO ActiveMatrix BusinessWorks process receives the message and sends the requested customer information back.
5. The Request-Response Invocation Service receives the response and writes the response to the inbound data queue with the message key.
6. The data queue writer/reader program receives the response and sets the return parameter values.
Setting Up the Example

To set up the example, you need to complete the following configurations.

**Task A  Import the Project**

In TIBCO Designer:

1. Start TIBCO Designer and select **New empty project**.
2. Click **Project > Import Full Project**.
3. In the Local Repository tab, browse to locate the `Samples.dat` file. The file is located in the `ADAS400_HOME/examples` folder.
4. Import the `Samples.dat` file with the default options.
   All the pre configured instances of the adapter and the corresponding processes are included in the new project.
5. Change the configuration as necessary.
   For example, you may need to change the values of the Server Name field, User field, and Password field in the Design-time Connection tab. Click **Apply**. Then click **Test Connection** to ensure that the adapter can connect to the IBM System i application.
6. Save the project.

**Task B  Configure the Request-Response Invocation Service**

1. In the Project panel, select the `CustomerInformation_Client` adapter service.
2. Click the **Queue Configuration** tab.
   The queue configuration of this example is as follows:
   — Service Type: Outbound Message
   — Request Data Queue: `ADAS400/ADAS400RQS`
   — Reply Data Queue: `ADAS400/ADAS400RPY`
   — Generate Member of Name: `DS_CUSTINF`
3. Click the **Message Schema** tab to check the data attributes for the message to be sent.
4. Click **Upload** to generate an ILE RPG source for the schema on the IBM System i machine. Click **Apply**.

5. Save the project.

**Task C  Create the Request-Response ILE RPG Program**

An application program on the IBM System will use the ILE RPG schema source generated in **Task B** to set the values of various message fields, send the message, and receive a reply message by calling the data queue writer/reader program `RPCCLIENT`, which is also generated by the adapter palette in **Task B**.

A sample application program `REQRPY_PGM` is available in the adapter example library `ADAS400` on the IBM System i machine, as follows:

```
*************** Beginning of data *************************************
D/Copy ADAS400/ADAS400SRC,DS_CUSTINF
*---------------------------------------------------------------------*
* Move customer number to message data structure                      *
*                                                             *
C     Eval             Request.Customer_Id = 1234
*     Call 'RPCCLIENT' program generated by TIBCO Adapter for IBM AS/400 to
*     retrieve customer details from external systems
C     Call             'RPCCLIENT'
```

---

**Figure 5  Message Schema of the Request-Response Invocation Service**

![Message Schema](image-url)
Task D  Configure the TIBCO ActiveMatrix BusinessWorks Process

1. In the Project panel, select **BW Processes > Receive Customer Information Request from IBM System i**.

2. In the Design panel, select the activity named **Receive Customer Information Request from IBM System i**.

3. Click the **Refresh Adapter Service** button in the Configuration tab.

4. In the Design panel, select the activity named **Send Customer Information to IBM System i**.

5. In the Configuration tab, ensure that the Reply For field is set to **Receive Customer Information Request from IBM System i**.

6. Click the **Input** tab in the Configuration panel. The values for various fields in the message that will be sent back to the request application are specified here.
### Figure 6  Fields in the Reply Message

![Image of Send Customer Information to IBM System i (Respond to Adapter Request)](image-url)

<table>
<thead>
<tr>
<th>Process Data</th>
<th>Activity Input</th>
</tr>
</thead>
<tbody>
<tr>
<td>$globalVariables</td>
<td>$Receive_Customer Information</td>
</tr>
<tr>
<td>$processContext</td>
<td>$Receive_Customer Information</td>
</tr>
<tr>
<td>$tenant</td>
<td>$Receive_Customer Information</td>
</tr>
</tbody>
</table>

**Fields in the Reply Message**

- **businessKey**
- **customerID**
- **customer_email**
- **customer_name**
- **customer_phone**
- **contact_information**
- **telephone_number**
- **email_address**
- **mailing_address**
- **shipping_address**
- **city**
- **state**
- **zip_code**

7. Save the project.
Running the Example

To run this example, you need to start the adapter and run the TIBCO ActiveMatrix BusinessWorks process in TIBCO Designer, and then send a request from the IBM System i machine.

Task A  Start the Adapter

In TIBCO Designer:

1. From the Tools menu, select Show Adapter Tester.
2. Select the adapter instance named IBMiAdapterConfiguration.
3. Click the Run Settings tab. In the Working Directory field, enter a temporary directory to place running files in.
4. In the Adapter Executable field, select the executable. For example, TIBCO ActiveMatrix Adapter for IBM i 6.0 (adas400.exe). Click Apply.
5. Click Start. To view the status messages, go to the Console tab.

Task B  Run the TIBCO ActiveMatrix BusinessWorks Process

In TIBCO Designer:

1. Click the Tester tab, then click the Start testing viewed process button.
2. Select the process named Receive Customer Information Request from IBM System i.
3. Click Load Selected.

Task C  Start the Request-Response ILE RPG Program

To send a request and receive a reply, invoke the ILE RPG application program. Run the following command from the command line of the IBM System i machine:

CALL ADAS400/REQRPY_PGM
# Expected Results

After starting the Request-Response ILE RPG program:

1. A request message is sent to the output queue on the IBM System i machine.
2. The adapter gets the request message and sends it to the TIBCO environment.
3. The **Receive Customer Information Request from IBM System i** activity receives the request message and processes it.
4. The **Send Customer Information to IBM system i** activity replies to the received message after setting required data values.

You can view the request message in the Output tab of the **Receive Customer Information Request from IBM System i** activity.

![Request Message](image)

---

**Figure 7 Request Message**
Sign-on to the IBM System i machine where the ILE RPG request-response program is located.

1. Browse for all the spool files for the user profile used in the adapter runtime connection.

2. Display the last created spool file QPRINT and confirm that the values printed are the values set in Receive Customer Information Request from IBM System i process. Refer to Figure 6 on page 26 for these values.

Figure 8  Received Customer Information
Chapter 5  Request-Response Service (Data Queue Write) Example

This example explains how to configure the adapter to write a message to a data queue on an IBM System i machine in synchronous mode.

Topics

- Example Description, page 32
- Setting Up the Example, page 33
- Running the Example, page 37
- Expected Results, page 38
Example Description

This example consists of a Request-Response Service named Customer_Inquiry_Server and a TIBCO ActiveMatrix BusinessWorks process named Invoke Server to Inquire Customer.

In this example:
1. The TIBCO ActiveMatrix BusinessWorks process sends a request message to query a customer record.
2. The Request-Response Service receives the request, writes a message to a request data queue on the IBM System i machine.
3. The Request-Response Service receives a reply message from another data queue on an IBM System i machine.
Setting Up the Example

To set up the example, you need to complete the following configurations.

**Task A  Import the Project**

In TIBCO Designer:

1. Start TIBCO Designer and select **New empty project**.
2. Click **Project > Import Full Project**.
3. In the Local Repository tab, browse to locate the `Samples.dat` file. The file is located in the `ADAS400_HOME/examples` folder.
4. Import the `Samples.dat` file with the default options.
   All the pre configured instances of the adapter and the corresponding processes are included in the new project.
5. Change the configuration as necessary.
   For example, you may need to change the values of the Server Name field, User field, and Password field in the Design-time Connection tab. Click **Apply**. Then click **Test Connection** to ensure that the adapter can connect to the IBM System i application.
6. Save the project.

**Task B  Configure the Request-Response Service**

This section explains how to configure a Request-Response Service with the Data Queue Write service type.

1. In the Project panel, select the **Customer_Inquiry_Server** adapter service.
2. Click the **Service Options** tab.
   The service configuration of this example is as follows:
   — Service Type: Data Queue Write
   — Request Data Queue: `ADAS400/ADAS400SRQ`
   — Reply Data Queue: `ADAS400/ADAS400SPY`
   — Generate in Source File: `ADAS400/ADAS400SRC`
   — Generate Member of Name: `DS_CUSTINQ`
3. Click the **Message Schema** tab to check the data attributes for the message to be sent.
4. Click **Upload** to generate an ILE RPG source for the schema on the IBM System i machine. Click **Apply**.

5. Save the project.

**Task C  Create the Request-Response ILE RPG Program**

An application program on the IBM System i machine will do the following:

- use the ILE RPG schema source generated in **Task B**
- receive a request by calling the data queue reader/writer program named `RPCSERVER`, which is generated by the adapter in **Task B**
- set the values of various message fields in the reply message
- write a reply message to the reply data queue by calling the data queue reader/writer program named `RPCSERVER`

A sample application program `CUSTMR_INQ` is available in the adapter example library `ADAS400` on the IBM System i machine, as follows:

```
*************** Beginning of data ********************************************
D/Copy ADAS400/ADAS400SRC,DS_CUSTINQ

* Call 'RPCSERVER' program generated by TIBCO Adapter for IBM AS/400 to
* receive a request from a 'Data Queue Write' type request-response service
* Call 'RPCSERVER'
```

TIBCO ActiveMatrix Adapter for IBM i Examples
C Parm KeyBuffer
C Parm MessageHeader
C Parm RequestBuffer

* Set values to retrieved message fields here. Address variables as -
* Customer_Inquiry_Server.Customer_Name
* Customer_Address.Address_Line_1
  :
  :
* Call 'RPCSERVER' program generated by TIBCO Adapter for IBM AS/400 to
* send reply for received request back to request-response service of
* 'Data Queue Write' type. In this call, data queue key will have value
* that was set when request message was read.
*
C Call 'RPCSERVER'
C Parm KeyBuffer
C Parm MessageHeader
C Parm RequestBuffer
*
C Move *On *InLR

***************************** End of data ************************************

Task D Configure the TIBCO ActiveMatrix BusinessWorks Process

1. In the Project panel, select BW Processes > Invoke Server to Inquire Customer.

2. In the Design panel, select the activity named Invoke Customer_Inquiry_Server.

3. Click the Refresh Adapter Service button in the Configuration tab.

4. Click the Input tab in the Configuration panel. The values for the schema fields are specified here.

TIBCO ActiveMatrix Adapter for IBM i Examples

Task D Configure the TIBCO ActiveMatrix BusinessWorks Process

1. In the Project panel, select BW Processes > Invoke Server to Inquire Customer.

2. In the Design panel, select the activity named Invoke Customer_Inquiry_Server.

3. Click the Refresh Adapter Service button in the Configuration tab.

4. Click the Input tab in the Configuration panel. The values for the schema fields are specified here.
5. Save the project.
Running the Example

To run this example, you need to start the adapter and TIBCO ActiveMatrix BusinessWorks process, and then send a request from the IBM System i machine.

**Task A  Start the Adapter**

In TIBCO Designer:

1. From the Tools menu, select **Show Adapter Tester**.

2. Select the adapter instance named **IBMiAdapterConfiguration**.

3. Click the **Run Settings** tab. In the Working Directory field, enter a temporary directory to place running files in.

4. In the Adapter Executable field, select the executable. For example, **TIBCO ActiveMatrix Adapter for IBM i 6.0 (adas400.exe)**. Click **Apply**.

5. Click **Start**. To view the status messages, go to the **Console** tab.

**Task B  Run the TIBCO ActiveMatrix BusinessWorks Process**

In TIBCO Designer:

1. Click the **Tester** tab, then click the **Start testing viewed process** button.

2. Select the process named **Invoke Server to Inquire Customer**.

3. Click **Load Selected**.

**Task C  Start the Request-Response ILE RPG Program**

To receive a request and send a reply, invoke the ILE RPG application program by entering the following command:

```
CALL ADAS400/CUSTMR_INQ
```
**Expected Results**

After starting the **Invoke Server to Inquire Customer** process:

1. A message is written to the request data queue on the IBM System i machine.
2. The ILE RPG program running on IBM System i machine reads the request message from the request data queue, sets values in the message, and writes a reply message to the reply data queue.
3. The adapter service reads the reply message from the reply data queue and sends it as a reply to the TIBCO ActiveMatrix BusinessWorks process.

You can view the reply message in the Output tab of the **Invoke Customer_Inquiry_Server** activity.

*Figure 11  Reply Message*
Chapter 6 Request-Response Service (Program Call) Example

This example demonstrates a Request-Response Service that invokes an application program (*PGM type object) on an IBM System i machine in synchronous mode to create a new customer record.

Topics

- Example Description, page 40
- Setting Up the Example, page 41
- Running the Example, page 47
- Expected Results, page 48
Example Description

The example consists of the following components:

- a Request-Response Service named Customer_Add_Server
- a TIBCO ActiveMatrix BusinessWorks process named Call Program to Add Customer
- a Request-Response Invocation Service named QSYSOPR_MessageMonitor
- a TIBCO ActiveMatrix BusinessWorks process named Process QSYSOPR Messages

In this example:

1. The process Call Program to Add Customer sends a request to create a customer record.
2. The Request-Response Service receives the request and invokes an application program on the IBM System i machine.
3. The application program tries to add a record to a table that is full. An error message is generated in the QSYSOPR message queue.
4. The Request-Response Invocation Service receives the error message from the QSYSOPR message queue.
5. The TIBCO ActiveMatrix BusinessWorks process named Process QSYSOPR Messages receives the error message and sends a reply.
6. The Request-Response Invocation Service receives the response from the TIBCO BusinessWorks process and replies to the QSYSOPR message.
Setting Up the Example

To set up the example, you need to complete the following configurations.

Task A  Import the Project

In TIBCO Designer:
1. Start TIBCO Designer and select **New empty project**.
2. Click **Project > Import Full Project**.
3. In the Local Repository tab, browse to locate the `Samples.dat` file. The file is located in the `ADAS400_HOME/examples` folder.
4. Import the `Samples.dat` file with the default options.
   All the pre configured instances of the adapter and the corresponding processes are included in the new project.
5. Change the configuration as necessary.
   For example, you may need to change the values of the Server Name field, User field, and Password field in the Design-time Connection tab. Click **Apply**. Then click **Test Connection** to ensure that the adapter can connect to the IBM System i application.
6. Save the project.

Task B  Configure the Message Monitor Service

In this example, a message monitor Request-Response Invocation Service is defined.

1. In the Project panel, select the `QSYS0PR_MessageMonitor` adapter service.
2. Click the **Queue Configuration** tab.
   The queue configuration of the service is as follows:
   — Service Type: Monitor Message
   — Message Queue: `QSYS/QSYS0PR`
3. Save the project.
Task C  Configure the Request-Response Service

The Request-Response Service is used to call an application program on the IBM System i machine. This service is configured for the CUSTMR_ADD program in ADAS400 library.

1. In the Project panel, select the Customer_Add_Server adapter service.

2. Click the Service Options tab.

   The program and its resource are configured as follows:
   - Service Type: Program Call
   - Program Object: ADAS400/CUSTMR_ADD
   - Source File: ADAS400/ADAS400SRC
   - Source Member: CUSTMR_ADD

3. Click the Load Parameters button to parse the program source, retrieve the list of parameters for the program and display the list as a schema in the Program Schema tab.

   Figure 12  Program Schema of the Request-Response Service

```
<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
<th>AS/400 Type</th>
<th>Adapter Type</th>
<th>Sequence</th>
</tr>
</thead>
<tbody>
<tr>
<td>NAME</td>
<td>Character</td>
<td>char 50</td>
<td></td>
<td></td>
</tr>
<tr>
<td>TELA</td>
<td>Character</td>
<td>char 20</td>
<td></td>
<td></td>
</tr>
<tr>
<td>EMAIL</td>
<td>Character</td>
<td>char 10</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ADDR</td>
<td>Character</td>
<td>char 50</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ADDR</td>
<td>Character</td>
<td>char 50</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ADDR</td>
<td>Character</td>
<td>char 30</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ADDR</td>
<td>Character</td>
<td>char 3</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ADDR</td>
<td>Packed Decl</td>
<td>fixed 5.0</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ADDR</td>
<td>Packed Decl</td>
<td>fixed 3.0</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CUST</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
```

4. Click the Message Monitor tab.

   Ensure that the service named QSYSOPR_MessageMonitor is selected.

5. Save the project.
Task D  Configure the TIBCO ActiveMatrix BusinessWorks Process for the Message Monitor Service

1. In the Project panel, select BW Processes > Process QSYSOPR Messages.
2. In the Design panel, select the activity named Receive QSYSOPR Message.
3. Click the Refresh Adapter Service button in the Configuration tab. Click Apply.
4. In the Design panel, select the activity named Reply to CPA5305.
   — Ensure that the Reply For field is set to Receive QSYSOPR Message.
   — Click the Input tab. The _caret_returnValue_caret_ field should be ’1’.

   **Figure 13**  Input of the Reply to CPA5305 Activity

5. In the Design panel, select the activity named Reply to Other Messages.
   — Ensure that the Reply For field is set to Receive QSYSOPR Message.
   — Click the Input tab. The _caret_returnValue_caret_ field should be ’C’.
6. Select the line connecting the Receive QSYSOPR Message activity and the Reply to Other Messages activity. Ensure that the Condition Type field is set to **Success with no matching condition**.

7. Select the line connecting the Receive QSYSOPR Message activity and the Reply to CPA5305 activity. Ensure that the Condition Type field is set to **Success with condition**.

The XPath should be:

$Receive-QSYSOPR-Message/ProcessStarterOutput/pfx:__caret_request_caret_MonitorMessage_caret_MonitorMessage/MsgId='CPA5305'.

If the XPath is not correct, change it as follows:

a. Click the button next to the XPath field.

b. In the XPath Formula Builder window, click the Data tab.

c. Expand the nodes for $Receive QSYSOPR Message > ProcessStarterOutput > __caret_request_caret_MonitorMessage_caret_MonitorMessage

d. Drag the **MsgId** field to the **XPath Formula** panel.

e. Type = 'CPA5305' at the end of the **MsgId** expression.

f. Click OK.
Task E  Configure the TIBCO ActiveMatrix BusinessWorks Process for the Request-Response Service

1. In the Project panel, select BW Processes > Call Program to Add Customer.
2. In the Design panel, select the activity named Call CUSTMR_ADD.
3. Click the Refresh Adapter Service button in the Configuration tab. Click Apply.
4. Click the Input tab, check the values of the fields.
5. Save the project.
Running the Example

To run this example, you need to start the adapter and run the TIBCO ActiveMatrix BusinessWorks process in TIBCO Designer.

The TIBCO ActiveMatrix BusinessWorks process then sends a request to the adapter to invoke the program named CUSTMR_ADD in library ADAS400.

**Task A  Start the Adapter**

In TIBCO Designer:

1. From the Tools menu, select **Show Adapter Tester**.
2. Select the adapter instance named IBMiAdapterConfiguration.
3. Click the **Run Settings** tab. In the Working Directory field, enter a temporary directory to place running files in.
4. In the Adapter Executable field, select the executable. For example, TIBCO ActiveMatrix Adapter for IBM i 6.0 (adas400.exe). Click **Apply**.
5. Click **Start**. To view the status messages, go to the **Console** tab.

**Task B  Run the TIBCO ActiveMatrix BusinessWorks Process**

In TIBCO Designer:

1. Click the **Tester** tab, then click the **Start testing viewed process** button.
2. Select the processes named Process QSYSOPR Messages and Call Program to Add Customer.
3. Click **Load Selected**.
4. In the Tester panel, select BW/Processes/Call Program to Add Customer.process, and then click the **Create a job** button 📋.
Expected Results

The program named CUSTMR_ADD adds a new record to table CUSTMR_TBL in library ADAS400.

- If the table already has two records, adding a new record the program will generate a message in the QSYSOPR message queue.
- When a QSYSOPR message is generated on the IBM System i machine, the TIBCO ActiveMatrix Adapter for IBM i will receive this message.
- Once the message is received, a new job will be visible under the process named Process QSYSOPR Messages in the TIBCO ActiveMatrix BusinessWorks tester.

You can view the new customer number value that was returned by the CUSTMR_ADD program in the Output tab of the Call CUSTMR_ADD activity.

Figure 17  New Customer Record
Sign-on to the IBM System i machine where the program named CUSTMR_ADD and the table named CUSTMR_TBL are located.

1. Start an interactive SQL session and run the SELECT command on CUSTMR_TBL in the ADAS400 library.

2. Confirm that the record was added correctly and that it contains the values set in the Call Program to Add Customer process. Refer to the figure on page 45 for these values.

If a QSYSOPR message was generated by the invocation of this program, select the job displayed under the process named Process QSYSOPR Messages in TIBCO ActiveMatrix BusinessWorks tester.

1. Click the Receive QSYSOPR Message activity.

2. Select the Output tab and expand all the nodes to view the details of the QSYSOPR message that was received by the adapter.

Figure 18  QSYSOPR Message
This example demonstrates a Request-Response Service that allows you specify selection criteria and retrieve a list of spooled files from an IBM System i machine.

Topics

- Example Description, page 52
- Setting Up the Example, page 53
- Running the Example, page 55
- Expected Results, page 56
Example Description

This example explains how to configure a Request-Response Service to retrieve a list of spooled files from the IBM System i machine in synchronous mode.

This example consists of the following components:

- a Request-Response Service named SpooledFileList_Server
- a TIBCO ActiveMatrix BusinessWorks process named Invoke Server for Spooled Files List, which sends a message to the adapter to request a list of spooled files from the IBM System i machine as per selection criteria, and then receives the list from the adapter
Setting Up the Example

To set up the example, you need to complete the following configurations.

**Task A  Import the Project**

In TIBCO Designer:

1. Start TIBCO Designer and select **New empty project**.
2. Click **Project > Import Full Project**.
3. In the Local Repository tab, browse to locate the `Samples.dat` file. The file is located in the `ADAS400_HOME/examples` folder.
4. Import the `Samples.dat` file with the default options. All the pre configured instances of the adapter and the corresponding processes are included in the new project.
5. Change the configuration as necessary. For example, you may need to change the values of the Server Name field, User field, and Password field in the Design-time Connection tab. Click **Apply**. Then click **Test Connection** to ensure that the adapter can connect to the IBM System i application.
6. Save the project.

**Task B  Configure the Request-Response Service**

1. In the Project panel, select the adapter service named `SpooledFileList_Server`.
2. Click the **Service Options** tab. Ensure that the Service Type is set to Spooled Files List.

**Task C  Configure the TIBCO ActiveMatrix BusinessWorks Process**

1. In the Project panel, select **BW Processes > Invoke Server for Spooled Files List**.
2. In the Design panel, select the activity named `Invoke SpooledFilesList_server`.
3. Click the **Refresh Adapter Service** button in the Configuration tab. Click **Apply**.
4. Click the **Input** tab, check the values of the schema fields.
Figure 19  Input of the Invoke SpooledFilesList_Server Activity

5. Save the project.
Running the Example

To run this example, you need to start the adapter and run the TIBCO ActiveMatrix BusinessWorks process in TIBCO Designer.

Task A  Start the Adapter

In TIBCO Designer:
1. From the Tools menu, select Show Adapter Tester.
2. Select the adapter instance named IBMiAdapterConfiguration.
3. Click the Run Settings tab. In the Working Directory field, enter a temporary directory to place running files in.
4. In the Adapter Executable field, select the executable. For example, TIBCO ActiveMatrix Adapter for IBM i 6.0 (adas400.exe). Click Apply.
5. Click Start. To view the status messages, go to the Console tab.

Task B  Run the TIBCO ActiveMatrix BusinessWorks Process

In TIBCO Designer:
1. Click the Tester tab, then click the Start testing viewed process button.
2. Select the process named Invoke Server for Spooled Files List.
3. Click Load Selected.
Expected Results

After starting the process named Invoke Server for Spooled Files List, a message is sent to the Request-Response Service. The service then retrieves list of spooled files as per selection criteria specified in the TIBCO ActiveMatrix BusinessWorks process and returns the list.

To display the list of spooled files:

1. In the TIBCO ActiveMatrix BusinessWorks tester, select the **Invoke SpooledFilesList_Server** activity and click the **Output** tab.
2. Expand the schema tree.

*Figure 20   Spooled Files List*

3. Sign-on to the IBM System i machine. Confirm the results using the **Work with Spooled Files (WRKSPLF)** command.
Chapter 8  Request-Response Service (Spooled File to PDF) Example

This example demonstrates a Request-Response Service that converts a spooled file from an IBM System i machine to PDF format.

Topics

- Example Description, page 58
- Setting Up the Example, page 59
- Running the Example, page 62
- Expected Results, page 63
Example Description

This example explains how to configure the adapter to retrieve a spooled file in PDF format from the IBM System i machine in synchronous mode.

This example consists of a request-Response Service named `SpooledFileToPDF_Server` and a TIBCO ActiveMatrix BusinessWorks process named `Invoke Server for Spooled File to PDF`.

In this example:

1. The TIBCO ActiveMatrix BusinessWorks process sends a message to the Request-Response Service.
2. The Request-Response Service receives the message and retrieves the selected spooled file from the IBM System i machine.
3. The Request-Response Service sends the spooled file as a PDF binary stream back to the TIBCO ActiveMatrix BusinessWorks process.
Setting Up the Example

To set up the example, you need to complete the following configurations.

**Task A  Import the Project**

In TIBCO Designer:

1. Start TIBCO Designer and select **New empty project**.
2. Click **Project > Import Full Project**.
3. In the Local Repository tab, browse to locate the `Samples.dat` file. The file is located in the `ADAS400_HOME/examples` folder.
4. Import the `Samples.dat` file with the default options.
   All the pre configured instances of the adapter and the corresponding processes are included in the new project.
5. Change the configuration as necessary.
   For example, you may need to change the values of the Server Name field, User field, and Password field in the Design-time Connection tab. Click **Apply.** Then click **Test Connection** to ensure that the adapter can connect to the IBM System i application.
6. Save the project.

**Task B  Configure the Request-Response Service**

1. In the project panel, select the adapter service named `SpooledFileToPDF_Server`.
2. Click the **Service Options** tab. Ensure that the Service Type is set to Spooled File to PDF.

**Task C  Configure the TIBCO ActiveMatrix BusinessWorks Process**

1. In the Project panel, select **BW Processes > Invoke Server for Spooled File to PDF**.
2. In the Design panel, select the activity named **Invoke SpooledFileToPDF_Server**.
3. Click the **Refresh Adapter Service** button in the Configuration tab. Click **Apply.**
4. Click the **Input** tab, the values of the schema fields specified in this tab are used in the conversion of the valid spooled file in the IBM System i machine.

*Figure 21  Input of the Invoke SpooledFileToPDF_Server Activity*

5. In the Design panel, select the resource named **Write File**. Ensure that the **Write as** field is set to **binary**.

6. Click the **Input** tab, the values of schema fields are set as follows.
Figure 22  Input of the Write File Resource
Running the Example

To run this example, you need to start the adapter and TIBCO ActiveMatrix BusinessWorks process in TIBCO Designer.

Task A  Start the Adapter

In TIBCO Designer:
1. From the Tools menu, select Show Adapter Tester.
2. Select the adapter instance named IBMiAdapterConfiguration.
3. Click the Run Settings tab. In the Working Directory field, enter a temporary directory to place running files in.
4. In the Adapter Executable field, select the executable. For example, TIBCO ActiveMatrix Adapter for IBM i 6.0 (adas400.exe). Click Apply.
5. Click Start. To view the status messages, go to the Console tab.

Task B  Run the TIBCO ActiveMatrix BusinessWorks Process

In TIBCO Designer:
1. Click the Tester tab, then click the Start testing viewed process button.
2. Select the process named Invoke Server for Spooled File to PDF.
3. Click Load Selected.
Expected Results

After starting the *Invoke Server for Spooled File to PDF* process, a message is sent to the request-response service. The adapter then retrieves the selected spooled file and sends it as a binary PDF stream back to the TIBCO ActiveMatrix BusinessWorks process.

To display the spooled file:

1. Open the PDF file written by the TIBCO ActiveMatrix BusinessWorks process.
2. Sign-on to the IBM System i machine. Confirm the results using the *Work with Spooled Files (WRKSPLF)* command.
Chapter 9  
Request-Response Service (Sequence)  
Example

This example demonstrates a Request-Response Service that sets sequence 5 as a property of the data attribute in its program schema.

Topics

- Example Description, page 66
- Setting Up the Example, page 67
- Running the Example, page 69
- Expected Results, page 70
Example Description

This example consists of a Request-Response Service named RequestResponseService-sequence and a TIBCO ActiveMatrix BusinessWorks process named Sequence.
Setting Up the Example

To set up the example, you need to complete the following configurations.

**Task A  Import the Project**

In TIBCO Designer:

1. Start TIBCO Designer and select **New empty project**.
2. Click **Project > Import Full Project**.
3. In the Local Repository tab, browse to locate the `Samples.dat` file. The file is located in the `ADAS400_HOME/examples` folder.
4. Import the `Samples.dat` file with the default options.
   
   All the pre configured instances of the adapter and the corresponding processes are included in the new project.
5. Change the configuration as necessary.
   
   For example, you may need to change the values of the Server Name field, User field, and Password field in the Design-time Connection tab. Click **Apply**. Then click **Test Connection** to ensure that the adapter can connect to the IBM System i application.
6. Save the project.

**Task B  Configure the Request-Response Service**

1. In the Project panel, select the adapter service named `RequestResponseService-sequence`.
2. Click the **Service Options** tab.
   
   The configuration is as follows:
   
   — Service Type: Program Call
   — Program Object: `ADAS400/CUSTMR_AD3`
   — Source File: `ADAS400/ADAS400SRC`
   — Source Member: `CUSTMR_AD3`
3. Click the **Program Schema** tab. The sequence of data attribute `VALUE` is set to 5.
Task C  Configure the TIBCO ActiveMatrix BusinessWorks Process

1. In the Project panel, select BW Processes > Sequence.
2. In the Design panel, select the activity named Read File.
3. In the Input tab, change the value of the fileName field to the location of the instance.xml file. Click Apply. You can find this file in your project directory.
Running the Example

To run this example, you need to start the adapter and TIBCO ActiveMatrix BusinessWorks process in TIBCO Designer.

Task A  Start the Adapter

In TIBCO Designer:
1. From the Tools menu, select Show Adapter Tester.
2. Select the adapter instance named IBMiAdapterConfiguration.
3. Click the Run Settings tab. In the Working Directory field, enter a temporary directory to place running files in.
4. In the Adapter Executable field, select the executable. For example, TIBCO ActiveMatrix Adapter for IBM i 6.0 (adas400.exe). Click Apply.
5. Click Start. To view the status messages, go to the Console tab.

Task B  Run the TIBCO ActiveMatrix BusinessWorks Process

In TIBCO Designer:
1. Click the Tester tab, then click the Start testing viewed process button.
2. Select the process named Sequence.
3. Click Load Selected.
Expected Results

You can view the new customer number value in the Output tab of the `custmr_add_3` activity. There are five items in the VALUE section, and the last entry is null.

*Figure 25  Customer Number Value Sequence*
Chapter 10  Subscription Service (Data Queue Write) Example

This example demonstrates a Subscription Service that writes a message to a data queue on an IBM System i machine to update a customer record.

Topics

- Example Description, page 72
- Setting Up the Example, page 73
- Running the Example, page 76
- Expected Results, page 77
Example Description

This example explains how to configure the adapter to write a message to a data queue on the IBM System i machine in asynchronous mode with Subscription Service.

This example consists of a Subscription Service named Customer_DQUpdate_Subscriber and a TIBCO ActiveMatrix BusinessWorks process named Publish to Subscriber for DataQueue Customer Update.

In this example:

1. The TIBCO ActiveMatrix BusinessWorks process sends a message to the Subscription Service.

2. The Subscription Service receives the message and writes a message to a data queue on an IBM System i machine.

3. The ILE RPG program running on the IBM System i machine reads this message, retrieves the necessary values from the message and updates the customer record.
Setting Up the Example

To set up the example, you need to complete the following configurations.

**Task A  Import the Project**

In TIBCO Designer:

1. Start TIBCO Designer and select **New empty project**.
2. Click **Project > Import Full Project**.
3. In the Local Repository tab, browse to locate the **Samples.dat** file. The file is located in the `ADAS400_HOME/examples` folder.
4. Import the **Samples.dat** file with the default options.
   
   All the pre configured instances of the adapter and the corresponding processes are included in the new project.
5. Change the configuration as necessary.

   For example, you may need to change the values of the Server Name field, User field, and Password field in the Design-time Connection tab. Click **Apply**. Then click **Test Connection** to ensure that the adapter can connect to the IBM System i application.

6. Save the project.

**Task B  Configure the Subscription Service**

1. In the project panel, select the adapter service named **Customer_DQUpdate_Subscriber**.
2. Click the **Service Options** tab.

   The configuration is as follows:
   
   — Service Type: Data Queue Write
   — Data Queue Name: `ADAS400/ADAS400SUB`
   — Generate Source Type: ILE RPG
   — Generate in Source File: `ADAS400/ADAS400SRC`
   — Generate Member of Name: `DS_CUSTUDQ`
3. Click the **Message Schema** tab. The data attributes for the message to be sent is as follows.
4. Click **Upload** to generate an ILE RPG source for the schema on the IBM System i machine. Click **Apply**.

**Task C  Create an ILE RPG Program for Message Subscription**

An application program is required on the IBM System i machine. This program will:

- Use the ILE RPG schema source generated in **Task B**
- Receive a message by calling the data queue reader program **SUBSCRIBER** (also generated by the adapter palette in **Task B**)  
- Read the values of various message fields in the message

A sample application program named **CUSTMR_UDQ** is available in the adapter example library **ADAS400** on the IBM System i machine:

```
*************** Beginning of data ******************************************************
D/Copy ADAS400/ADAS400SRC,DS_CUSTUDQ

* Call 'SUBSCRIBER' program generated by TIBCO Adapter for IBM AS/400 to receive a
* message from inbound data queue.
* 
C Call 'SUBSCRIBER'
C Parm MessageHeader
C Parm EntryBuffer

* Use values to retrieved message fields here to update Customer.
* Address variables as -
* Entry.Customer_Name
```
Task D Configure the TIBCO ActiveMatrix BusinessWorks Process

This step explains how to configure a TIBCO ActiveMatrix BusinessWorks process for the Subscription Service to call an application program on the IBM System i machine.

1. In the Project panel, select **BW Processes > Publish to Subscriber for DataQueue Customer Update**.

2. In the Design panel, select the activity named **Publish to Customer_DQUpdate_Subscriber**.

3. In the Configuration tab, click the **Refresh Adapter Service** button.

4. Click the **Input** tab, check the values of the schema fields.

*Figure 27  Input of the Publish to Customer_DQUpdate_Subscriber Activity*
Running the Example

To run this example, you need to start the adapter in TIBCO Designer, start the ILE RPG program on IBM System i machine, and then run the TIBCO ActiveMatrix BusinessWorks process in TIBCO Designer.

**Task A  Start the Adapter**

In TIBCO Designer:

1. From the Tools menu, select **Show Adapter Tester**.
2. Select the adapter instance named **IBMAdapterConfiguration**.
3. Click the **Run Settings** tab. In the Working Directory field, enter a temporary directory to place running files in.
4. In the Adapter Executable field, select the executable. For example, **TIBCO ActiveMatrix Adapter for IBM i 6.0 (adas400.exe)**. Click **Apply**.
5. Click **Start**. To view the status messages, go to the **Console** tab.

**Task B  Start the ILE RPG Program for Message Subscription**

The ILE RPG program running on IBM System i machine needs to be started before it can receive the request message, retrieve the necessary values in the message, and update the customer record.

Run the following command from the command line menu of the IBM System i machine.

```
CALL ADAS400/CUSTMR_UDQ
```

**Task C  Run the TIBCO ActiveMatrix BusinessWorks Process**

Once the adapter and the ILE RPG program are started, run the TIBCO ActiveMatrix BusinessWorks process to send a message to the Subscription Service.

In TIBCO Designer:

1. Click the **Tester** tab, then click the **Start testing viewed process** button.
2. Select the process named **Publish to Subscriber for DataQueue Customer Update**.
3. Click **Load Selected**.
Expected Results

After starting the TIBCO ActiveMatrix BusinessWorks process, a message is written to the data queue on the IBM System i machine. The ILE RPG program running on IBM System i machine reads this message, retrieves the necessary values from the message and updates customer record.

To display the message, sign-on to the IBM System i machine. Confirm the results of the update by running SQL queries on the Customer table. Run the following commands from the command line menu of the IBM System i machine.

`STRSQL
SELECT * FROM ADAS400/CUSTMR_TBL`
Chapter 11  Subscription Service (Program Call)  Example

This example demonstrates a Subscription Service that calls an application program on an IBM System i machine to update a customer record.

Topics

• Example Description, page 80
• Setting Up the Example, page 81
• Running the Example, page 84
• Expected Results, page 85
Example Description

This example explains how to configure the adapter for calling an application program (*PGM type object) on the IBM System i machine in asynchronous mode.

This example consists of a Subscription Service named Customer_Update_Subscriber and a TIBCO ActiveMatrix BusinessWorks process named Call Program to Update Customer.

In this example:

1. A process for program invocation starts in TIBCO ActiveMatrix BusinessWorks.

2. Subscription Service receives the request from the process and asynchronously invokes an application running on an IBM System i machine.
Setting Up the Example

To set up the example, you need to complete the following configurations.

**Task A  Import the Project**

In TIBCO Designer:

1. Start TIBCO Designer and select New empty project.
2. Click Project > Import Full Project.
3. In the Local Repository tab, browse to locate the Samples.dat file. The file is located in the ADAS400_HOME/examples folder.
4. Import the Samples.dat file with the default options.
   All the pre configured instances of the adapter and the corresponding processes are included in the new project.
5. Change the configuration as necessary.
   For example, you may need to change the values of the Server Name field, User field, and Password field in the Design-time Connection tab. Click Apply. Then click Test Connection to ensure that the adapter can connect to the IBM System i application.
6. Save the project.

**Task B  Configure a Subscription Service**

The Subscription Service is configured for the CUSTMR_UPD program in the ADAS400 library.

1. In the Project panel, select the adapter service named Customer_Update_Subscriber.
2. Click the Service Options tab.
   The program and its source are configured as follows:
   - Service Type: Program Call
   - Program Object: ADAS400/CUSTMR_UPD
   - Source File: ADAS400/ADAS400SRC
   - Source Member: CUSTMR_UPD
   CUSTMR_UPD is an ILE RPG program and the source information cannot be retrieved from *PGM object.
3. Click the **Load Parameters** button to parse the program source, retrieve the list of parameters for the program and display the list as a schema in the Program Schema tab.

**Figure 28  Program Schema of the Subscription Service (Program Call)**

---

**Task C  Configure a TIBCO ActiveMatrix BusinessWorks Process**

1. In the Project panel, select **BW Processes > Call Program to Update Customer.**

2. In the Design panel, select the activity named **Call CUSTMR_UPD.**

3. In the Configuration tab, click the **Refresh Adapter Service** button.

4. Click the **Input** tab. To update the values specified here in the customer record on the IBM System i machine.

   The customer row to be updated is identified by the field NBR, which is the customer number.
Figure 29  Input of the Call CUSTMR_UPD Activity
Running the Example

To run this example, you need to start the adapter and run the TIBCO ActiveMatrix BusinessWorks process in TIBCO Designer.

Task A  Start the Adapter

In TIBCO Designer:
1. From the Tools menu, select Show Adapter Tester.
2. Select the adapter instance named IBMiAdapterConfiguration.
3. Click the Run Settings tab. In the Working Directory field, enter a temporary directory to place running files in.
4. In the Adapter Executable field, select the executable. For example, TIBCO ActiveMatrix Adapter for IBM i 6.0 (adas400.exe). Click Apply.
5. Click Start. To view the status messages, go to the Console tab.

Task B  Run the TIBCO ActiveMatrix BusinessWorks Process

In TIBCO Designer:
1. Click the Tester tab, then click the Start testing viewed process button.
2. Select the process named Call Program to Update Customer.
3. Click Load Selected.
Expected Results

When you start the process named Call Program to Update Customer, the CUSTMR_UPD program is called. This program updates an existing customer row in the table CUSTMR_TBL in library ADAS400.

To view the results of the activities:

1. Sign-on to the IBM System i machine where the program and table in this example are located.

2. Start an interactive SQL session and run the SELECT command on CUSTMR_TBL in the ADAS400 library. Run the following commands from the command line menu of the IBM System i machine.

   **STRSQL**

   ```sql
   SELECT * FROM ADAS400/CUSTMR_TBL
   ```

3. Confirm that the record got updated correctly with the values set in the TIBCO ActiveMatrix BusinessWorks process. Refer to Figure 29 on page 83 for the values.
Index

A
ADAS400_HOME xii

C
customer support xv
Customer_Add_Server 40
Customer_DQUpdate_Subscriber 72
Customer_Inquiry_Server 32
Customer_Update_Subscriber 80
CustomerInformation_Client 22
CustomerMessage_Publisher 6

D
Data Queue Write
  Request-Response Service 31
  Subscription Service 71

K
Key_Publisher 14

O
overview 2

P
prerequisites 4
Program Call
  Request-Response Service 39
  Subscription Service 79
Publication Service 5
Publisher Key 13
PUBLSH_KEY 16
PUBLSH_PGM 6, 8

Q
QSYSOPR_MessageMonitor 40

R
REQRPY_PGM 24
Request-Response Invocation Service 21
Request-Response Service
  Data Queue Write 31
  Program Call 39
  Sequence 65
  Spooled File to PDF 57
  Spooled Files List 51
RequestResponseService-sequence 66

S
Sequence 65
Spooled File to PDF 57
Spooled Files List 51
SpooledFileList_Server 52
SpooledFileToPDF_Server 58
Subscription Service
  Data Queue Write 71
  Program Call 79
support, contacting xv

t
  technical support xv
TIBCO_HOME xii