Copyright © Cloud Software Group, Inc. All Rights Reserved
Copyright © Cloud Software Group, Inc. All Rights Reserved


Appendix C Troubleshooting : Data processing caused a GetComponent() API message error

Data processing caused a GetComponent() API message error
Symptom
While a message was being processed by the adapter, the following error message occurred:
  2001 Sep 20 18:36:37:889 ps8Adapter.inst Info [Application]   AEPS8-4003033 Caught Base Error TPESVCFAIL - application level service   failure
  com.tibco.sdk.MException: An Error has Occured while invoking API   GetComponent() on CI PRODUCT
     at com.tibco.adapter.ps.AdapterException.<init>
     (AdapterException.java:24)
     at com.tibco.adapter.ps.ComponentInterfaceAgent.getCIObject
     (ComponentInterfaceAgent.java:201)
     at com.tibco.adapter.ps.PSEventProcessor.processMessage
     (PSEventProcessor.java:840)
Probable Cause
Most likely permission has not been granted for the adapter to use the required Component Interface. Another probable cause is that the Component Interface does not exist in the database.
Solution
Use the PeopleTools Maintain Security function to grant the operator class the permission to use the Component Interface, in this case PRODUCT. Make sure full access is granted. The operator class should be the one the operator ID belongs to. For example, the operator class for VP1 is ALLPNLS.

Copyright © Cloud Software Group, Inc. All Rights Reserved
Copyright © Cloud Software Group, Inc. All Rights Reserved