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TIBCO ActiveMatrix BusinessWorks™ 
Getting Started
This document steps you through the process of designing and testing a simple 
ActiveMatrix BusinessWorks™ project. 

For more information about designing and testing ActiveMatrix BusinessWorks 
processes, see TIBCO ActiveMatrix BusinessWorks™ Process Design.

Introduction
This tutorial steps you through the creation of a simple ActiveMatrix BusinessWorks 
project. The goal of this tutorial is to introduce you to the ActiveMatrix BusinessWorks 
project lifecycle. The phases of the project lifecycle are similar to standard project 
phases:

Procedure 

 1. Design — determining the requirements of the system, developing a prototype 
solution to your business needs.

 2. Testing — running the system to determine that it works properly and meets the 
project’s requirements. 

The project in this tutorial is fairly simple so that you can focus on how to use 
ActiveMatrix BusinessWorks within each phase of the project lifecycle. Once you 
complete the tutorial, you should be more comfortable applying the methodology to your 
own projects. 

Before starting this tutorial, you should become familiar with ActiveMatrix 
BusinessWorks terminology and basic concepts. It is not necessary to learn all aspects 
of ActiveMatrix BusinessWorks, but you should at least read the "Business Integration" 
section of TIBCO ActiveMatrix BusinessWorks™ Concepts. That topic introduces much 
of the terminology that will be used in this tutorial. TIBCO Designer Main Window is a 
summary of key concepts you should be familiar with.
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Note: Once a project has been developed and tested, you can deploy it using 
TIBCO Administrator™. The TIBCO Administrator User’s Guide describes 
deployment and includes a tutorial that uses the project created in this 
manual.

Overview of Example Process
The project you will create watches a directory for a specific file. When the file changes, 
a new file is created that contains the contents of the original file plus the time the 
change was made to the original file. The new file is named after the change that 
occurred (create.txt, modify.txt, or remove.txt). If you modify the file multiple times, the new file 
overwrites the existing modify.txt. 

With this simple project, you will perform many of the same tasks that are required for 
larger, more complex projects. This tutorial is not intended to illustrate every aspect of 
ActiveMatrix BusinessWorks, so only a small subset of the available activities will be 
used. 

The tutorial steps you through the following tasks:

• Starting TIBCO Designer and Saving Your Project

• Creating the FileTest Process

• Testing the FileTest Process

Activation
TIBCO ActiveMatrix BusinessWorks requires activation via a license in order to start.  
Licenses can be generated in the TIBCO Software Downloads site at 
https://www.tibco.com/downloads.  For complete details on activating TIBCO products, 
see the TIBCO Activation Service documentation at 
https://docs.tibco.com/products/tibco-activation-service.

https://www.tibco.com/downloads
https://docs.tibco.com/products/tibco-activation-service
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Important: TIBCO ActiveMatrix BusinessWorks will shut down when you 
reach the end date of your entitlement to the product, and will not restart until 
you replace your license file with one that contains a new entitlement end 
date.  It is recommended that you do so well in advance of your entitlement 
end date to avoid business disruption.

Activation is configured during the installation of TIBCO ActiveMatrix BusinessWorks™ 
or as a post-installation step.      See  TIBCO ActiveMatrix BusinessWorks™ Installation 
Guide  for details.

Prerequisites
To perform the tasks in this tutorial, you must have installed and configured the 
ActiveMatrix BusinessWorks software properly. 

Procedure 

 1. Install all components of TIBCO Runtime Agent™ on your system.

 2. Install all components of ActiveMatrix BusinessWorks on your system. 

Starting TIBCO Designer and Saving Your 
Project
To start TIBCO Designer and save your project, follow these steps: 

Procedure 

 1. From the Start menu, choose All 
Programs > TIBCO > TIBCO Designer <version> > Designer <version>.

The TIBCO Designer Startup window appears.

 2. Choose New Empty Project.

The TIBCO Designer main window appears, with the Save Project dialog on top.

 3. In the Save Project dialog, make sure that the Multi-File Project tab is selected.

 4. In the Project Directory field, click the Browse button to locate the directory in 
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which you wish to save the project. Locate the ActiveMatrix BusinessWorks 
installation directory, and create a new subdirectory named tutorial. Click OK to 
return to the Save Project dialog.

 5. Click OK to create the new project. 

You are now ready to create a process definition using TIBCO Designer. The next 
section gives an overview of TIBCO Designer. If you would like to start process design 
right away, skip the overview and start with Creating the FileTest Process.

For more information about TIBCO Designer, see TIBCO Designer Main Window. The 
TIBCO Designer™ User’s Guide, available from the Help > Designer Help menu, gives 
additional information, including an introduction to the display preferences. 

TIBCO Designer Main Window
The TIBCO Designer main window has these components:

 l Menu bar and menus.

 l Toolbar icons.

 l Four panels, which are (starting in the top left corner and continuing clockwise):

 o Project tree panel
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 o Design panel

 o Configuration panel

 o Palette panel

The following sections explain each panel.

Projects

A project consists of objects that contain the functionality needed for your enterprise 
integration. This includes services (producers and consumers of information), any 
business logic that may be applied to that information, and deployment information. 

Each TIBCO Designer window contains one and only one project, which is represented 
as the top-level folder in the window. 

The ProcessNewComputer project, shown below in the project tree panel, includes two 
process definitions, a PeopleSoft adapter (PSoft_ReqRep), a Siebel adapter (SBLAccount), 
and several other resources.
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Resources

Resources are the components of a project. A TIBCO Designer resource corresponds to 
an object in a TIBCO application, such as FTP Put activity, a process definition, or a 
specific adapter instance. 

Resources can be complex and contain other resources, much like a folder can contain 
other folders on your computer's file system. For example, an adapter instance may 
contain multiple folders with multiple publisher or subscriber resources. A process 
definition contains multiple activities. 

Resources can also be simple. In the illustration above, PSoft_OrderEntry is a simple 
resource. 

Activities

Resources used in process design are called activities. You can create a process flow 
linking activities with transitions. You can have multiple transitions from one activity to 
others, and each transition can be conditional. 

Palettes

A palette provides access to resources. You drag and drop resources from the palette in 
the palette panel into the design panel to add them to your project.
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TIBCO Designer contains a number of native palettes. In addition, each TIBCO 
application you install adds one or more palettes to ActiveMatrix BusinessWorks during 
installation. 

Which palette is displayed depends on the resource selected in the project tree and on 
your preferences.

Creating the FileTest Process
This section guides you through creating a simple process definition. The process, which 
will be named FileTest, polls a directory for a specified file and writes a new file to the 
same directory each time the file changes. The new file’s name includes the type of 
change that occurred to the original file (create, modify, or remove). The new file’s 
content is the same as the polled file’s content, but the time of the change in the file is 
appended to the end of the file. The time of the file change is represented as the number 
of milliseconds since January 1, 1970. 

The tutorial uses a variable file name to illustrate how to use the ActiveMatrix 
BusinessWorks mapping capabilities. 

Note: Before you start to design the process, create a directory. Then create 
text file with some simple content (for example, "The cherry blossoms are 
beautiful.") in the directory. The file will be needed by the File Poller activity. 
This example uses the directory c:\tibco\test and the file PolledFileTest.txt

To create the FileTest process, follow these steps: 

Procedure 

 1. In TIBCO Designer, select the project name (for example tutorial) in the project 
panel.

 2. In the palette panel, select the Process palette.

If no palettes are in the palette panel, click the Switch Palette Mode  icon to 
display the palettes. 

 3. From the palette panel, drag a Process Definition resource into the design panel.

 4. In the configuration panel, type the name FileTest in the Name field to rename the 
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process. Then click Apply.

 5. Save your project by choosing Project > Save from the menu. 

For more information about processes, see TIBCO ActiveMatrix BusinessWorks™ 
Concepts and TIBCO ActiveMatrix BusinessWorks™ Process Design. 

To add activities to the process, follow these steps: 

Procedure 

 1. Select FileTest process in the project tree.

The Start and End activities should be displayed in the design panel.

 2. Find the File palette in the palette panel and select it. 

Tip: If the File palette is not one of the available palettes, choose 
Palettes > Activities > File to make the palette available.

 3. Drag a File Poller activity into the design panel (but not on top of the Start activity).

The Start activity is replaced by the File Poller activity.

 4. With the File Poller still selected, enter the following values in the configuration 
panel: 

 a. Name the File Poller TestFilePoller.

 b. Click the Browse button to the right of the File Name field and select the file 
you want to poll. Use the Select File dialog to locate the directory and file you 
created.

 c. Leave the Polling Interval, Include Existing Files, and Exclude File Content 
fields as they are. Select text in the drop-down list in the Content as field, and 
select the appropriate encoding for your operating system in the Encoding 
field.
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 d. Click the Apply button.

 5. Drag a Create File activity into the design panel and place it to the right of 
TestFilePoller.

 6. Name the Create File activity CreateTestFile, and select the Overwrite check box, 
then click the Apply button. 

 7. Drag a Write File activity into the design panel and place it to the right of the 
CreateTestFile activity (before the End activity).

 8. Name the Write File activity WriteToTestFile, then click the Apply button. 

 9. In the toolbar, select the Transition icon .

 10. Select the TestFilePoller process starter and drag a transition to the 
CreateTestFile activity. Connect the CreateTestFile and WriteToTestFile and the 
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WriteToTestFile and End activities in the same manner.

The result should appear as follows:

 11. Choose Project > Save from the menu. 

The process now includes appropriately connected activities. However, no information 
about the name and content of the files is included. To set those, you use the TIBCO 
Designer mapping facilities. 

The goal in this exercise is to create a file that has the name File<changeType>.txt, where 
<changeType> is the type of change that occurred to the original file (create, modify, or 
remove). The contents of the changed file is then written to the new file, and the time the 
change in the file occurred is appended to the end of the contents. For example, if the 
text in the changed file is "The cherry blossoms are beautiful." the content of the new file 
will be "The cherry blossoms are beautiful. 1017163931036"

To map the data flow between activities, follow these steps:

Procedure 

 1. Choose the Select icon  in the toolbar, if it is not already selected.

 2. Select the CreateTestFile activity and choose the Input tab in the configuration 
panel. Expand the CreateActivityInputClass item in the activity input tree by 
clicking on the plus sign (+) to the left of the item. 

Each activity’s output is available to subsequent activities in the process definition. 
You can use data from previous activities to specify the input of the current activity. 
For example, you can use the content of the original text file as the content of the 
new text file. 
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The left panel of the Input tab contains a list of data from all activities preceding the 
current activity in the process diagram. Each activity’s name appears with a dollar 
sign ($) in front of it to indicate that this is a process variable. 

The right panel of the Input tab lists the current activity’s input.

 3. Click the plus (+) sign next to the process variable $TestFilePoller in the Process 
Data panel and expand the schema tree containing the output of the TestFilePoller 
process starter.

 4. In the right panel, select the fileName element in the Activity Input pane, then click 
the XPath Formula Builder (pencil) icon.

 5. In the XPath Formula Builder dialog that appears, follow these steps:

 a. Select the Functions tab, open the String folder, select concat, and drag it 
into the XPath Formula panel.

The display in the right panel changes to display a concat XPath expression.

 b. Replace << string1 >> with "c:\tibco\test\File" (include the quotes). 

 c. In the left panel, select the Data tab, choose the 
$TestFilePoller/EventSourceOutputTextClass/action element and drag it 
over << string2 >>. A red box appears over << string2 >> indicating you can 
release the data over this item and the correct XPath expression will appear. 

 d. Add a comma after $TestFilePoller/EventSourceOutputTextClass/action, then add the 
string ".txt" (include the quotes). 

The expression should look like the following: 

      concat("c:\tibco\test\File",
      $TestFilePoller/EventSourceOutputTextClass/action, ".txt")

 6. Click the Apply button to accept the formula and dismiss the XPath Formula 
Builder by clicking Close. Then click the Apply button in the Input tab of the 
activity.

 7. Select the WriteToTestFile activity, then click the Input tab in the configuration 
panel.

 8. Map the data as follows: 

 a. Select $CreateTestFile/CreateActivityOutputClass/fileInfo/fullName and drag it to the 
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fileName item in the Activity Input pane.

You do not need to use the XPath Formula Builder to map this item because 
you do not need to use XPath functions. The content of the field is exactly the 
same as the value of the 
$CreateTestFile/CreateActivityOutputClass/fileInfo/fullName process 
variable. 

 b. In the right panel, select the textContent field and click the XPath Formula 
Builder icon. 

 c. In the XPath Formula Builder, drag a concat function into the XPath formula 
panel. 

 d. Add " ", between <<string1>> and <<string2>> so that there is a space between 
the two strings in the concat function. 

 e. Click the Data tab and drag. 
$TestFilePoller/EventSourceOutputTextClass/fileContent/textContent over <<string1>>.

 f. Drag $TestFilePoller/EventSourceOutputTextClass/timeOccurred over <<string2>>. 

The formula should look like this: 

 concat($TestFilePoller/EventSourceOutputTextClass/
      fileContent/textContent," ",$TestFilePoller/
      EventSourceOutputTextClass/timeOccurred )

 g. Click the Apply button to accept the formula and dismiss the XPath Formula 
Builder by clicking Close.

 9. Click the Apply button on the activity’s Input tab, then choose Project > Save to 
save your project. 

You are now ready to test the project. 

Testing the FileTest Process
You can test the FileTest process directly from TIBCO Designer. This allows you to 
make sure the process works correctly before you deploy it. Follow these steps: 

Procedure 

 1. Click the Set Breakpoints icon 
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.

 2. In the window that appears, choose Select All, then click OK.

Breakpoints allow you to step through the process. Stepping helps you see what 
happens when each activity executes.

 3. Click the Tester tab to the left of the project panel. The test panel replaces the 
project tree.

 4. Click the Start testing viewed process button. 

 5. In the process selection window that appears, the FileTest process is selected by 
default. Click Load and Start Current.

The process is now in Test mode.

 6. Make a change to the polled file to start the process.

 7. Once the TestFilePoller process starter is highlighted (indicating a process has 
started), click the Step to next activity icon  to step through the process.

ActiveMatrix BusinessWorks creates an output file named Filemodify.txt after you 
have stepped into the WriteToTestFile activity and writes the appropriate text to 
the file.

The text should be the text of PolledFileTest.txt and, in a new line, the time, in 
milliseconds, since January 1, 1970.

You can click on each activity in the process definition as you step through it. If you 
click on the Process Data or Output tabs for the activity, you will see the actual 
process data and output of the activity as the process executes.

 8. Next, delete PolledFileTest.txt.

 9. Step through the process once more.

 ActiveMatrix BusinessWorks creates a file Fileremove.txt. The content of Fileremove.txt 
is just the time of modification, because the polled file no longer exists.

 10. Click the Stop Test Mode icon  to return to design mode. 

For more information about using test mode, see  TIBCO ActiveMatrix 
BusinessWorks™ Process Design. 
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Using ActiveMatrix BusinessWorks Engine 
Command Line to Run a ActiveMatrix 
BusinessWorks Project 
In the absence of a GUI environment or a TIBCO Administrator to deploy a ActiveMatrix 
BusinessWorks project, you can test your project by using command line to run the 
ActiveMatrix BusinessWorks Engine and view the test results.

Note: To run a ActiveMatrix BusinessWorks project using the ActiveMatrix 
BusinessWorks Engine command line, provide an absolute path of your 
project location such as, <BW_HOME>/bin/bwengine<root directory of the BW project>.

Replace the following with the appropriate values as per your environment:

 l -propFile to use a different .tra file instead of bwengine.tra.

 l -name to provide name for the engine.

 l -p to specify props.cfg file which contains the engine properties.

Note: Use option "-name <descriptive name>" in the command line for providing 
each engine a descriptive name, when starting the ActiveMatrix 
BusinessWorks Engine using the command line.       For example, if the 
descriptive name is "myproject", then a message "Engine myproject started" appears 
after the engine is started.

The commands to start the ActiveMatrix BusinessWorks Engine with the name option 
are:

 l bwengine <absolute path of the project> -name <name>

 l bwengine -propFile <tra file> <absolute path of the project> -name <name>

 l bwengine -propFile <tra file> -p <properties file> <absolute path of the project> -name <name>
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TIBCO Product Documentation and Support 
Services
For information about this product, you can read the documentation, contact TIBCO 
Support, and join TIBCO Community.

How to Access TIBCO Documentation

Documentation for TIBCO products is available on the Product Documentation website, 
mainly in HTML and PDF formats.    

The Product Documentation website is updated frequently and is more current than any 
other documentation included with the product.

Product-Specific Documentation

The following documentation for this product is available on the TIBCO ActiveMatrix 
BusinessWorks™ Product Documentation page:    

 l TIBCO ActiveMatrix BusinessWorks™ Release Notes

 l TIBCO ActiveMatrix BusinessWorks™ Administration

 l TIBCO ActiveMatrix BusinessWorks™ Concepts

 l TIBCO ActiveMatrix BusinessWorks™ Error Codes

 l TIBCO ActiveMatrix BusinessWorks™ Getting Started

 l TIBCO ActiveMatrix BusinessWorks™ Installation

 l TIBCO ActiveMatrix BusinessWorks™ Palette Reference

 l TIBCO ActiveMatrix BusinessWorks™ Process Design

To directly access documentation for this product, double-click the following file:    

TIBCO_HOME/release_notes/TIB_<productID>_version_docinfo.html 

where      TIBCO_HOME is the top-level directory in which TIBCO products are installed. 
On Windows, the default      TIBCO_HOME is      C:\tibco. On UNIX systems, the default      
TIBCO_HOME is      /opt/tibco.    

https://docs.tibco.com/
https://docs.tibco.com/
http://docs.tibco.com/
http://docs.tibco.com/
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Other TIBCO Product Documentation 

When working with ActiveMatrix BusinessWorks, you may find it useful to read the 
documentation of the following TIBCO products:

 l TIBCO Designer™: TIBCO Designer is an easy to use graphical user interface for 
design-time configuration of TIBCO applications. TIBCO Designer includes online 
help for each palette.

 l TIBCO Runtime Agent™: TRA supplies a number of TIBCO and third-party libraries 
used by ActiveMatrix BusinessWorks.

 l TIBCO Administrator™: TIBCO Administrator is the monitoring and managing 
interface for new-generation TIBCO products such as ActiveMatrix 
BusinessWorks.

 l TIBCO Rendezvous® : TIBCO Rendezvous software uses messages to enable 
distributed application programs to communicate across a wide variety of 
hardware platforms and programming languages.

How to Access Related Third-Party Documentation 

When working with ActiveMatrix BusinessWorks, you may find it useful to read the 
documentation of the following third-party products:

How to Contact Support for TIBCO Products

You can contact the Support team in the following ways:    

 l To access the Support Knowledge Base and getting personalized content about 
products you are interested in, visit our product Support website.     

 l To create a Support case, you must have a valid maintenance or support contract 
with a Cloud Software Group entity. You also need a username and password to 
log in to the product Support website. If you do not have a username, you can 
request one by clicking Register on the website.      

How to Join TIBCO Community

TIBCO Community is the official channel for TIBCO customers, partners, and employee 
subject matter experts to share and access their collective experience. TIBCO 
Community offers access to Q&A forums, product wikis, and best practices. It also offers 
access to extensions, adapters, solution accelerators, and tools that extend and enable 
customers to gain full value from TIBCO products. In addition, users can submit and vote 

https://support.tibco.com/
https://support.tibco.com/
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on feature requests from within the      TIBCO Ideas Portal. For a free registration, go to      
TIBCO Community.    

https://ideas.tibco.com/
https://community.tibco.com/
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Legal and Third-Party Notices
SOME CLOUD SOFTWARE GROUP, INC. (“CLOUD SG”) SOFTWARE AND CLOUD SERVICES 
EMBED, BUNDLE, OR OTHERWISE INCLUDE OTHER SOFTWARE, INCLUDING OTHER 
CLOUD SG SOFTWARE (COLLECTIVELY, “INCLUDED SOFTWARE”). USE OF INCLUDED 
SOFTWARE IS SOLELY TO ENABLE THE FUNCTIONALITY (OR PROVIDE LIMITED ADD-ON 
FUNCTIONALITY) OF THE LICENSED CLOUD SG SOFTWARE AND/OR CLOUD SERVICES. 
THE INCLUDED  SOFTWARE IS NOT LICENSED TO BE USED OR ACCESSED BY ANY 
OTHER CLOUD SG SOFTWARE AND/OR CLOUD SERVICES OR FOR ANY OTHER 
PURPOSE.

USE OF CLOUD SG SOFTWARE AND CLOUD SERVICES IS SUBJECT TO THE TERMS AND 
CONDITIONS OF AN AGREEMENT FOUND IN EITHER A SEPARATELY EXECUTED 
AGREEMENT, OR, IF THERE IS NO SUCH SEPARATE AGREEMENT, THE CLICKWRAP END 
USER AGREEMENT WHICH IS DISPLAYED WHEN ACCESSING, DOWNLOADING, OR 
INSTALLING THE SOFTWARE OR CLOUD SERVICES (AND WHICH IS DUPLICATED IN THE 
LICENSE FILE) OR IF THERE IS NO SUCH LICENSE AGREEMENT OR CLICKWRAP END 
USER AGREEMENT, THE LICENSE(S) LOCATED IN THE “LICENSE” FILE(S) OF THE 
SOFTWARE. USE OF THIS DOCUMENT IS SUBJECT TO THOSE SAME TERMS AND 
CONDITIONS, AND YOUR USE HEREOF SHALL CONSTITUTE ACCEPTANCE OF AND AN 
AGREEMENT TO BE BOUND BY THE SAME.

This document is subject to U.S. and international copyright laws and treaties. No part of this 
document may be reproduced in any form without the written authorization of Cloud Software 
Group, Inc.

TIBCO, the TIBCO logo, the TIBCO O logo, and  are either registered trademarks or trademarks of 
Cloud Software Group, Inc. in the United States and/or other countries.

Java and all Java based trademarks and logos are trademarks or registered trademarks of Oracle 
and/or its affiliates.

All other product and company names and marks mentioned in this document are the property of 
their respective owners and are mentioned for identification purposes only. You acknowledge that 
all rights to these third party marks are the exclusive property of their respective owners. Please 
refer to Cloud SG’s Third Party Trademark Notices (https://www.cloud.com/legal) for more 
information.

This document includes fonts that are licensed under the SIL Open Font License, Version 1.1, 
which is available at: https://scripts.sil.org/OFL

Copyright (c) Paul D. Hunt, with Reserved Font Name Source Sans Pro and Source Code Pro.

https://www.cloud.com/legal
https://scripts.sil.org/OFL
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Cloud SG software may be available on multiple operating systems. However, not all operating 
system platforms for a specific software version are released at the same time. See the “readme” 
file for the availability of a specific version of Cloud SG software on a specific operating system 
platform.

THIS DOCUMENT IS PROVIDED “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER 
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF 
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

THIS DOCUMENT COULD INCLUDE TECHNICAL INACCURACIES OR TYPOGRAPHICAL 
ERRORS. CHANGES ARE PERIODICALLY ADDED TO THE INFORMATION HEREIN; THESE 
CHANGES WILL BE INCORPORATED IN NEW EDITIONS OF THIS DOCUMENT. CLOUD SG 
MAY MAKE IMPROVEMENTS AND/OR CHANGES IN THE PRODUCT(S), THE PROGRAM(S),  
AND/OR THE SERVICES DESCRIBED IN THIS DOCUMENT AT ANY TIME WITHOUT NOTICE.

THE CONTENTS OF THIS DOCUMENT MAY BE MODIFIED AND/OR QUALIFIED, DIRECTLY 
OR INDIRECTLY, BY OTHER DOCUMENTATION WHICH ACCOMPANIES THIS SOFTWARE, 
INCLUDING BUT NOT LIMITED TO ANY RELEASE NOTES AND "README" FILES.

This and other products of Cloud SG may be covered by registered patents. For details, please 
refer to the Virtual Patent Marking document located at https://www.cloud.com/legal.

Copyright © 2001-2025. Cloud Software Group, Inc. All Rights Reserved.

https://www.cloud.com/legal
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