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Changing Help Preferences
By default, documentation access from TIBCO Business Studio™ for BusinessWorks™ is
online, through the TIBCO Product Documentation website that contains the latest version
of the documentation. Check the website frequently for updates. To access the product
documentation offline, download the documentation to a local directory or an internal web
server and then change the help preferences in TIBCO Business Studio for BusinessWorks.

Before you begin
Before changing the help preferences to access documentation locally or from an internal
web server, download the documentation.

1. Go to https://docs.tibco.com/

2. In the Search field, enter TIBCO ActiveMatrix BusinessWorks™ and press Enter.

3. Select the TIBCO ActiveMatrix BusinessWorks™ product from the list. This opens the
product documentation page for the latest version.

4. Click Download All.

5. A compressed .zip file containing the latest documentation is downloaded to your
web browser's default download location.

6. Copy the .zip file to a local directory or to an internal web server and unzip the file.

To point to a custom location:

Procedure
1. Perform one of the following steps in TIBCO Business Studio for BusinessWorks based

on your operating system:

l On Windows OS: Click Window > Preferences

l On macOS: Click TIBCO Business Studio > Preferences.

2. In the Preferences dialog, click BusinessWorks > Help.

3. Click Custom Location, and then browse to the html directory in the folder where
you extracted the documentation or provide the URL to the html directory on your

https://docs.tibco.com/
https://docs.tibco.com/
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internal web server.

4. Click Apply, and then click OK.
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Refactoring REST Services
The following refactoring options are possible for a REST Service.

Updating a REST Service Path Name
A REST Service path name can be updated only if it is created using the REST Service
wizard.

Procedure
1. Navigate to the Bindings panel on the General tab and select

ComponentResource/resource - RestService.

The Components panels is displayed.

2. In the Component Configurations panel select RestService.

The Bindings tab for the REST service is displayed.

3. On the Bindings tab, update the name of the service in the Resource Service Path
field.
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Click the on the right side of the Resource Service Path to update the REST
Service path name.

Updating Rest Service Path Name using Path and
Query Parameters
The service path names can be configured by adding the path and query parameters in
Resource Service Path field on the Bindings tab in the following formats:

/resource1/{pathparam}?q1={queryparam} or /resource1/{pathparam}?{queryparam}&
{queryparam2}

The path parameters are reflected in the Path Parameters table and the query parameters
are reflected in the Query and Header Parameters table for are all the operations.



TIBCO ActiveMatrix BusinessWorks™ Refactoring Best Practices

10 | Refactoring REST Services

Note: To reflect the above changes in the REST Reference Binding, a new
Reference Binding should be created using the swagger file.

Renaming a REST Service

Before you begin
You can rename a REST service only if it is created using the REST Service wizard.

Procedure
1. Right-click the created REST service and select Refactor > Rename Service.
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The Rename PartnerLink wizard is displayed.

2. In the Rename PartnerLink wizard, provide a new name and click OK.

By default, the Update references to the PartnerLink checkbox is already selected.

Important: TIBCO recommends to keep the Update references to the
PartnerLink checkbox selected when performing the refactoring
operations.
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Updating Request and Response Schemas

Before you begin
You can update a REST service only if it is created using the REST Service wizard.

Procedure

1. Click the OnMessage Start of the constructor for any of the operations. For
example, POST operation.

2. On the Input tab, select Complex Element under Operation Input.

The Schema Element with its corresponding elements is visible.

Note: To update the schema elements, add or remove the elements.

The changes for all the operations on REST service are reflected if the same schema
is used in the Request and Response Schemas.
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Adding Operations

Procedure
1. Click the down arrow of the REST service and select Create REST Operation.

The REST Service Wizard is displayed.

2. In the REST Service Wizard, select the operation and the schema element for any
Request or Response schemas.

3. Click Finish.

To reflect the changes in the REST reference binding, a new reference binding must
be created using the Swagger file.

Deleting Operations from REST Service

Procedure
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1. Select an operation in a REST service. Right-click the operation and select Refactor
> Delete Operation

If you created a REST service using wizard, the Delete Operation dialog is displayed.

If you created a REST service using external swagger file, the following dialog is
displayed:

Note: It is recommended to keep the Generate Implementation
Specification checkbox selected to generate a swagger file.

2. Optional. To see the changes that are performed, click Preview.
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3. Once you delete an operation, remove the constructor implementation by selecting
the Remove OnMessage.
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Important: If you created a REST service using external swagger file, then
to reflect the changes in the REST reference binding, a new reference
binding should be created using the newly generated swagger file.
However, if you created a REST service using wizard, then create a new
reference binding with an existing swagger file only.

The operation is deleted.

Deleting an HTTP Connector from REST Service

Procedure
1. Click the REST service in the process and navigate to the Bindings panel on the

General tab and select ComponentResource/resource - RestService.

The Components tab is displayed.

2. On the Bindings tab of the REST service, click button at the end of the HTTP
Connector Name field.

The existing HTTP Connector is deleted.
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Adding Query Parameters

Procedure
1. Click the REST service in process and navigate to the Bindings panel on the General

tab and select ComponentResource/resource - RestService.

The Components tab is displayed.

2. Query Parameters can be added in the Resource Service Path field. Adding query
parameters from the Resource Service Path field applies query to all operations.

3. Query Parameters can also be added by selecting the button from the Query
and Header Parameters table for a particular operation of the Request tab of the
Operation Details panel in the Bindings tab.

Adding Request Header Parameters

Procedure
1. Click the REST service in the process and navigate to the Bindings panel on the

General tab and select ComponentResource/resource - RestService.

The Components tab opens.

2. To add the Request Header Parameters, select the
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button from the Query and Header Parameters table for a particular operation
of the Request tab of the Operation Details panel in the Bindings tab.

Header Parameters can also be added in Response tab.

3. In the Response tab of the Operations Details panel, select the Use HTTP Headers
checkbox.

After selecting the Use HTTP Headers checkbox, the button gets activated in
the Header Parameters table to add header parameters.
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Deleting Parameters

Select the parameter to delete and click the red cross icon.

Note: To reflect the above changes in the REST Reference Binding, a new
Reference Binding should be created using the swagger file.

Updating an HTTP Connector Name

Procedure
1. Navigate to the Resources section in application module and open the HTTP

Connector shared resource.

2. To update the HTTP Connector Name click the green bulb.

The Rename Resource Template wizard is displayed.

3. In the Rename Resource Template wizard, update the name of the HTTP Connector
in the New name field and click OK.

By default, the Update references checkbox is already selected.

Important: TIBCO recommends to keep the Update references checkbox
selected when performing the refactoring operations.

The new name reflects in the HTTP Connector shared resource of the REST service
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bindings.

Deleting a REST Service

Procedure
1. Right-click the REST service and select Refactor > Delete Service option.

2. Click OK

Caution: Once the REST service is deleted, it is not possible to add it
again.

Refactoring Swagger Files
The following refactoring operations are possible for swagger files.
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Copying and Pasting Swagger files
When you create a BusinessWorks REST Resource, by default, the swagger files are present
in the Service Descriptors folder.
You can copy and paste swagger files in another application module, other folders in the
same application module, and in a shared module in the other project.

Follow the steps to copy and paste the swagger file

Procedure
1. In an application module, navigate to the Service Descriptors folder and select the

swagger file.

2. Right-click the swagger file and select the Copy option.

3. Select the folder in which you want to paste the swagger file. Right-click and select
the Paste BW option.

The swagger file is copied to the selected folder.
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Note: Do not copy and paste the swagger file from an application module
to the shared module on which the source application module is
dependent, you get the following error:

Duplicate Resource Problems : Duplicate file name {JSON file name}, in
Service Descriptors Folder, is not permitted in this project and/or its
referenced project set.

Renaming Swagger Files

Procedure
1. Select the swagger file to rename. Right-click and select the Rename option.
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2. Change the swagger file name in the Rename Resource dialog.

The new file name should have the <new_file>.json format.

3. Optional. To see the changes that are performed, click the Preview button.
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Important: It is recommended to keep all the checkboxes in the Rename
Resource dialog selected.

4. Click OK.

Note: If you change the default swagger file name from <Module_
Name>.Resource-Resource.json to <Module_Name>.Resource-<New_File_
Name>.json, the default swagger file remains unchanged, and a new file
<Module_Name>.Resource-<New_File_Name>.json is created in the same
folder.

Moving Swagger Files
Follow the steps to move swagger file from one module to another module.

Procedure
1. Navigate to the folder with swagger files. Select the swagger file.
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2. Right-click the swagger file and select the Move option.

The Move Resources dialog appears.

3. Select the Service Descriptors folder to move the swagger file.

4. Optional. To see the changes that are performed, click Preview.
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Important: TIBCO recommends to keep all the checkboxes in the Move
Resources dialog selected.

5. Click Ok.

The swagger file is moved to a new location.
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Refactoring REST References
The Reference Binding created with a Swagger document cannot be modified.

Renaming a REST Reference

Before you begin
You can rename a REST reference only if it is created using the REST Reference wizard.

Procedure
1. Select and right-click the created REST service and select Refactor > Rename

Reference.

The Rename PartnerLink wizard is displayed.

2. In the Rename PartnerLink wizard, add a new name in the New Name field for the
Rest reference and click OK.

By default, the Update references to the PartnerLink checkbox is already selected.
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Important: TIBCO recommends to keep the Update references to the
PartnerLink checkbox selected when performing the refactoring
operations.

Deleting a REST Reference

Procedure
1. Right-click the Rest reference and select Refactor > Delete Reference and

2. Click OK.

The REST reference is deleted.
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Deleting Operations from REST Reference

Procedure
1. Select a REST reference operation to delete. Right-click the operation and select

Refactor > Delete Operation.

The Delete Operation dialog is displayed.

2. Optional. To see the changes that are performed, click Preview.

3. Click OK.

4. Delete the corresponding implemented operation manually.
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The REST operation is deleted.

5. If necessary, reconfigure the mapping of the other activities.
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Refactoring SOAP Binding
SOAP Binding is used to create service providers and consumers based on the SOAP
Protocol.

Refactoring a SOAP Service
The following refactoring options are supported for a SOAP Service

Renaming a SOAP Service

Procedure
1. Select and right-click the created SOAP Service and select Refactor > Rename

Service.
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The Rename PartnerLink wizard is displayed.

2. In the Rename PartnerLink wizard, add a new name in the New Name field for the
SOAP Service and click OK.

By default, the Update references to the PartnerLink checkbox is already selected.

Important:
TIBCO recommends to keep the Update references to the PartnerLink
checkbox selected when performing the refactoring operations.

Deleting a SOAP Service Binding

Procedure
1. Right-click the SOAP Service and select Refactor > Delete Service option.
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2. Click OK.

The selected SOAP Service Binding is deleted.

Caution: Once the SOAP Service Binding is deleted for the same process, it
cannot be added again. In that case, a completely new SOAP Service
Binding is created.

Adding Operations for a SOAP Service

Procedure
1. Right-click the SOAP service. Select Refactor > Create Operation option.
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The Create Operation dialog is displayed.

2. In the Create Operation dialog, add an operation name in the Operation Name field
and select an Operation Type for the SOAP Service and click OK.

3. Generate a new concrete WSDL so that the new operation is incorporated in it.
Create a new SOAP reference binding if not present or update the existing SOAP
Reference by removing the binding and add new binding for the updated concrete
WSDL.
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Renaming Operations of a SOAP Service

Procedure
1. Right-click the operation and select Refactor > Rename Operation option.

The Rename Operation wizard is displayed.

2. In the Rename Operation wizard, add a new name in the New Name field for the
operation and click OK.

By default, the Update references to the Operation checkbox is already selected.
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Important: TIBCO recommends keeping the checkbox checked while
performing the refactoring operations.

Deleting Operations of a SOAP Service

Procedure
1. Right-click the created SOAP Service operation and select Refactor > Delete

Operation option.

2. Click OK.
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The selected SOAP Service operation is deleted.

Renaming an HTTP Connector for SOAP Service

Procedure
1. Navigate to Resources section in application module and open the HTTP Connector

shared resource.

2. To update the HTTP Connector Name click the green bulb icon.

The Rename Resource Template wizard is displayed.

3. In the Rename Resource Template wizard, update the name of the HTTP Connector
in the New name field and click OK.

The new name reflects in the HTTP Connector shared resource of the SOAP service
bindings.

Deleting an HTTP Connector for SOAP Service
You cannot delete an HTTP Connector for SOAP Service Bindings. A different HTTP
Connector can be selected by using the option available for the HTTP Connector Name
field.
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Renaming a JMS Connector for SOAP Service

Procedure
1. Navigate to Resources section in application module and open a JMS Connection

shared resource.

2. To update the JMS Connection Name click the green bulb icon.

The Rename Resource Template wizard is displayed.

3. In the Rename Resource Template wizard, update the name of the JMS Connection in
the New name field and click OK.

By default, the Update references checkbox is already selected.
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Important: TIBCO recommends to keep the Update references checkbox
selected when performing the refactoring operations.

The new name reflects in the JMS Connection name of the SOAP Service Bindings.

Deleting a JMS Connector for SOAP Service
You cannot delete a JMS Connector for SOAP Service Bindings. A different JMS Connector
can be selected by using the option available for the JMS Connector Name field.

Refactoring SOAP Reference
The following refactoring options are possible for a SOAP Reference.
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Renaming a SOAP Reference

Procedure
1. Select and right-click the created SOAP Reference and select Refactor > Rename

Reference.

The Rename PartnerLink wizard is displayed.

2. In the Rename PartnerLink wizard, add a new name in the New Name field for the
SOAP Reference and click OK.

By default, the Update references to the PartnerLink checkbox is already selected.
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Important: TIBCO recommends to keep the checkbox selected when
performing the refactoring operations.

Deleting a SOAP Reference

Procedure
1. Right-click the SOAP Reference and select Refactor > Delete Reference option.

2. Click OK.

The selected SOAP Reference Binding is deleted.

Adding Operations for a SOAP Reference

Procedure
1. Right-click the SOAP Reference. Select Refactor > Create Operation option.
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The Create Operation wizard is displayed.

2. In the Create Operation wizard, add an operation name in the Operation Name field
and select an Operation Type for the SOAP reference.

3. Click OK.

Result
Recreate the SOAP reference binding after the operation is added.

Renaming Operations of a SOAP Reference

Procedure
1. Right-click the operation and select Refactor > Rename Operation.
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The Rename Operation wizard is displayed.

2. In the Rename Operation wizard, add a new name in the New Name field for the
operation and click OK.

By default, the Update references to the Operation checkbox is already selected.

Important: TIBCO recommends to keep the Update references to the
Operation checkbox selected when performing the refactoring operations.

Note: If the created operation is renamed on the SOAP reference side, the
operation name on the SOAP service binding must be renamed. The Client
and Service should be in two different application modules.
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Deleting Operations of a SOAP Reference

Procedure
1. Right-click the created SOAP Reference operation and select Refactor > Delete

Operation option.

2. Click OK.

The selected SOAP Reference operation is deleted.

Renaming an HTTP Client for SOAP Reference
Follow the steps to rename an HTTP Client for SOAP Reference in TIBCO Business Studio
for BusinessWorks.

Procedure
1. Navigate to Resources section in application module and open the HTTP Connector

shared resource

The HTTP Client Resource opens.

2. To update the HTTP Client Name click the green bulb icon.

The Rename Resource Template wizard is displayed.

3. In the Rename Resource Template wizard, update the name of the HTTP Client in the
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Name field and click OK.

By default, the Update References checkbox is already selected.

Important: TIBCO recommends to keep the Update References checkbox
selected when performing the refactoring operations.

The new name reflects in the HTTP Client of the SOAP Reference Bindings.

Deleting an HTTP Client for SOAP Reference
Follow the steps to delete an HTTP Client for SOAP Reference from TIBCO Business Studio
for BusinessWorks.

Procedure
1. On the Components tab, select Bindings.

2. On the Bindings tab, click the for the HTTP Client Name field from the
Transport Configuration panel.
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Refactoring WSDL
The following refactoring operations are supported for WSDL.

Updating WSDL NameSpace
Follow the steps to update a WSDL namespace into TIBCO Business Studio for
BusinessWorks

Procedure
1. In the Project Explorer view, select and right-click the abstract WSDL and select

Refactor > Rename WSDL Definition namespace
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The Change WSDL Namespace wizard is displayed.

2. In the Change WSDL Namespace wizard, add a new namespace in the New
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namespace field and click OK.

By default the Update references to the WSDL namespace checkbox is already
selected.

Important: TIBCO recommends to keep the Update references to the
WSDL namespace check box selected while performing the refactoring
operations.

The changes are reflected in the SOAP Services.

Updating WSDL PortType
Follow the steps to update a WSDL PortType into TIBCO Business Studio for
BusinessWorks.

Procedure
1. In the Project Explorer view, expand the abstract WSDL, select the WSDL PortType,

right-click and select Refactor > Rename WSDL PortType
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The Rename PortType wizard opens.

2. In the Rename PortType wizard, add a new name in the New name field and click
OK.

By default, the Update references to the PortType checkbox is already selected.

Caution: TIBCO recommends to keep the Update references to the
PortType checkbox selected when performing refactoring operations.
Otherwise, you have to update port type references manually.

The changes are reflected in the SOAP Services.

Updating WSDL Operation Name
Follow the steps to update a WSDL operation name into TIBCO Business Studio for
BusinessWorks.
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Procedure
1. In the Project Explorer view, expand the abstract WSDL and right-click the

operation and select Refactor > Rename WSDL operation

The Rename Operation wizard is displayed.

2. In the Rename Operation wizard, add a new name in the New name field and click
OK.

By default, the Update references to the Operation checkbox is already selected.

Important: TIBCO recommends to keep the Update references to the
Operation checkbox selected while performing the refactoring operations.

The changes are reflected in the SOAP Services.

The same refactoring of WSDL can be performed for a concrete WSDL which has the
abstract WSDL and a schema embedded in it.
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Copying and Pasting a WSDL File
Follow the steps to copy and paste a WSDL file.

Before you begin
Ensure that the dependent .xsd schema file is available in the application module, where
you want to copy the WSDL file. If the dependent .xsd schema file is present in a shared
module, ensure that the required application module is dependent on the shared module.

Procedure
1. In an application module, navigate to the Service Descriptor folder, and select a

WSDL file.

2. Right-Click the WSDL file and select Copy option.

3. Right-click the Service Descriptors folder of the required application module, and
select Paste BW option.

The WSDL file is copied in the required application module.

Renaming a WSDL File
Follow the steps to rename a WSDL file.
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Procedure
1. In an application module, navigate to the Service Descriptors folder and select

the WSDL file to be renamed.

2. Right-click the WSDL file and select the Rename option.

The Rename Resource dialog is displayed.

3. Provide a new name in the Rename Resource dialog.

4. Optional. To see the changes that are performed, click Preview.
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Important: TIBCO recommends to keep all the checkboxes in the Rename
Resource dialog selected.

5. Click Ok.

The WSDL file is renamed.

The WSDL Location field of a reference is also updated.
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Refactoring Activities
The following refactoring operations are possible for activities.

l Copying and Pasting an Activity

l Deleting an Activity

l Moving and Activity

l Renaming an Activity

Copying an Activity
You can copy an activity within a same process or within a same module in a different
process.

Within Same Process
Follow the steps to copy an activity within a same process.

Procedure
1. Select an activity to copy.

2. Right-click the activity and select Edit > Copy
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3. Right-click the empty space in a process and select Edit > Paste

The activity is pasted with the same properties as of the source activity. The pasted
activity has the Copy_1_ prefix.

Within Same Module
Follow the steps to copy activities within a same module.

Procedure
1. Select an activity to copy.

2. Right-click the activity and select Edit > Copy

3. In the Process Editor, open the destination process to copy the activity.
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4. Right-click in the empty space in a process and select Edit > Paste

The activity is copied with the same properties as that of the source activity.

Deleting an Activity

Follow the steps to delete an activity in a process.

Procedure
1. Select an activity to delete.

2. Right-click the activity and select the Delete option.

The selected activity is now deleted.

3. Reconfigure the activities that were connected to the deleted activity.

Moving an Activity
Follow the steps to cut and paste an activity from one process to another process within a
same module:

Procedure
1. Select an activity to move.
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2. Right-click the activity and select Edit > Cut

3. Open another process in the Process Editor. Right-click and select Edit > Paste.

The activity is displayed in the process.



TIBCO ActiveMatrix BusinessWorks™ Refactoring Best Practices

58 | Refactoring Activities

Renaming an Activity
Follow the steps to rename an activity:

Procedure
1. Select an activity to rename.

2. On the General tab in the Properties view, change the name.

The new name is reflected in the Process Editor.
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Refactoring Groups
The following refactoring operations are supported for groups.

l Copying and Pasting Groups

l Deleting a Group

l Moving a Group

Copying Groups
You can copy a group from a process to a location within the same process or to another
process in the same package.

Within Same Process
Follow the steps to copy a group within the same process.

Procedure
1. Select a group in a process. Right-click the group and select Edit > Copy

2. Click at the empty space in a same process.

3. Right-click in the Process Editor and select Edit > Paste
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The group is copied on the source group. Use arrow keys to place the group at
appropriate position. The group name and all activities within the group have Copy_
1_ prefix.

4. To remove configuration related errors, configure the group.

To Another Process Within the Same Package
Follow the steps to copy a group to another process in the same package.

Procedure
1. Select a group in a process. Right-click the group and select Edit > Copy

2. Click at the empty space in another process within a same package.

3. Right-click in the Process Editor and select Edit > Paste

The group is copied at same co-ordinates of the source group.
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4. To get the group within process editor's boundaries, change dimensions of the
process editor.

Name of the group and the activities within the group have same name as that of the
source group.

5. To remove configuration related errors, configure the group.

Removing a Group
Follow the steps to delete a group from a process.

Deleting a Group Along With the Activities in the
Group

Procedure
1. Select a group. Right-click the group and select the Delete menu.
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The group is deleted along with all activities within the group.

2. Reconfigure the remaining activities in a process.

Ungrouping the Activities Within the Group

Procedure
1. Select a group. Select the Menu button on the group and select the Ungroup menu.

The group is deleted without removing activities within that group.
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2. If you get any configuration related errors, reconfigure the activities in a process.

Moving a Group
Follow the steps to move a group from one process to another within same package.

Procedure
1. Select a group. Right-click the group in a process and select Edit > Cut

The group is cut from the process.

2. Open another process from a same package in a process editor. Right-click in a
process editor and select Edit > Paste.
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The group is copied to the other process.

3. Reconfigure the process to avoid configuration-related errors.
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Refactoring Shared Resources
The following refactoring operations are supported for shared resources.

l Copying and pasting a shared resource

l Deleting a shared resource

Copying and Pasting a Shared Resource
Follow the steps to copy and paste a shared resource.

Procedure
1. Select a shared resource to copy.

2. Right-click the shared resource and select Copy menu.

3. Select a special folder. Right-click the special folder and select the Paste BW menu.
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The shared resource is copied in the special folder.

Important: TIBCO recommends to copy a shared resource in special
folders only.

Deleting a Shared Resource
Follow the steps to delete a shared resource.

Procedure
1. Select a shared resource to delete.

2. Right-click the shared resource and select the Delete option.
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The Delete Resources dialog is displayed.

3. Optional. To see the changes that are performed, click Preview.

Important: TIBCO recommends to keep all the check boxes in the Delete
Resources dialog selected.
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4. Click Ok.

The shared resource is deleted.
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Refactoring Packages
The following refactoring operations are possible for packages:

l Copying and Pasting Packages

l Deleting Packages

l Renaming Packages

Copying and Pasting Packages
Follow the steps to copy and paste a package within same application module.

Procedure
1. Select the package to copy.

2. Right-click the package and select the Copy option.

3. Right-click the Processes and select the Paste BW option.
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The package is displayed under Processes section.

After you copy the package, all processes within that package are also copied.

However, depending on your process configuration, TIBCO Business Studio for
BusinessWorks displays some errors.

Follow the steps to resolve Process import error configuration errors.
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a. Right-click the error in Process import error configuration section and select
the Quick Fix menu.

b. In the Problems section, to select all checkboxes click on the Select All button.

Click Finish.

The Process import error configuration errors are resolved.

c. To resolve other types of errors, re-configure the activities within the processes.

Deleting Packages
Follow the steps to delete a package.

Procedure
1. Select a package to delete.

2. Right-click the package and select the Delete option.
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3. In the Confirm Resource Delete dialog, click Yes.

The package is deleted.

Renaming Packages
Follow the steps to rename a package

Procedure
1. Select a package to rename.

2. Right-click the package and select Refactor > Rename Process Package.
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3. In the Rename Package dialog, change a name of the package.

4. Optional. To see the changes that are performed, click Preview.

Important: TIBCO recommends to keep all the check boxes in the Rename
Package dialog selected.
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5. Click Ok.

The new package name is displayed in the Project Explorer view.
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Refactoring Processes
The following refactoring operations are supported for processes.

l Copying and pasting processes

l Renaming processes

l Deleting processes

l Moving processes

Copying and Pasting Processes
Follow the steps to copy and paste processes within a same module

Procedure
1. Select a process in a package. Right-click the process and select the Copy menu.

2. Select a package to copy the process. Right-click the package and select the Paste
BW menu.
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The process is copied in the package.

TIBCO recommends to copy a process in a package.

Note: If you select a same package to paste a process, the Name Conflict
dialog is displayed.
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Similarly, you can copy processes

l Outside a package

l inside any folder

l At an application module level.

Renaming Processes
Follow the steps to rename a process

Procedure
1. Select a process. Right-click the process and select the Rename option.

The Rename Process dialog is displayed.

2. In the Rename Process dialog, change the name of the process.
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3. Optional. To see the changes that are performed, click Preview.

Important: TIBCO recommends to keep all the check boxes in the Rename
Process dialog selected.

4. Click Ok.

The name of the process is changed.

Deleting Processes
Follow the steps to delete a process.

Procedure
1. Select a process to delete. Right-click the process and select the Delete menu.
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The Confirm Resource Delete dialog is displayed.

2. In the Confirm Resource Delete dialog, click Yes.

The process is deleted from a package.

Moving Processes
Follow the steps to move a process.

Procedure
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1. Select a process. Right-click the process and select the Move option.

The Move Resources dialog is displayed.

2. In the Move Resources dialog, select a folder in a module.

3. Optional. To see the changes that are performed, click Preview.
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Important: TIBCO recommends to keep all the check boxes in the Move
Resources dialog selected.

4. Click OK.

The process is moved to the selected package.
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Refactoring Policies
The following refactoring operations are possible for policies.

l Copying and Pasting policies

l Renaming policies

l Deleting policies

l Moving policies

Copying and Pasting Policies
Follow the steps to copy and paste policies.

Procedure
1. In an application module, navigate to the Policies folder and select the policy in

the package.

2. Right-click the policy and select the Copy option.

3. Navigate to the package in which you want to paste the policy.

4. Right-click the package and select Paste BW option.
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A policy is pasted in the new package.

Renaming a Policy
You can rename a policy by:

l Using the Rename Menu

l Using Rename Policy Wizard

Using the Rename Menu

Procedure
1. Select the policy to rename. Right-click the policy and select the Rename option.

2. In the Rename Resource dialog, provide a new name to the policy in the form <new_
name>.policy
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3. Optional. To see the changes that are performed, click Preview.

Important: TIBCO recommends to keep all the check boxes in the Rename
Resource dialog selected.

4. Click OK.
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Using the Rename Policy Wizard

Procedure
1. Navigate to the Policies folder of the application module and select the policy to

rename.

2. In the Policies folder of the application module select the green bulb icon of
the Name field.

The Rename Policy Template dialog is displayed.

3. In the Rename Policy Template dialog, change the name of the policy.

By default, the Update references checkbox is already selected.

Important: TIBCO recommends to keep the checkbox selected while
performing the refactoring operations.
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4. Optional. To see the changes that are performed, click Preview.

5. Click OK.

The policy name is updated on the Rest or SOAP Service or Reference Bindings.

Deleting Policies
Follow the steps to delete a policy:

Procedure
1. Select a policy to delete.

2. Right-click the policy and select the Delete option.

The Delete Resources dialog is displayed.

3. Optional. To see the changes that are performed, click Preview.
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Important: TIBCO recommends to keep all the checkboxes in the Delete
Resources dialog selected.

4. Click OK.

The policy is deleted.

Moving Policies
Follow the steps to move a policy.

Procedure
1. Select a policy to move.

2. Right-click the policy and select the Move option.
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The Move Resources dialog is displayed.

3. In the Move Resources dialog, select the folder to move the policy.

Important: TIBCO recommends to move a policy in a special folder only.

4. Optional. To see the changes that are performed, click Preview.
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Important: TIBCO recommends to keep all the checkboxes in the Move
Resources dialog selected

5. Click OK.

The policy is moved to the specified special folder.

Refactoring Policies with SOAP and REST
Binding
The following refactoring operations are supported for the policies using the SOAP and
REST Binding Services.
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Adding a Policy
Follow the steps to add a policy into TIBCO Business Studio for BusinessWorks

Procedure
1. Navigate to the Components > Bindings tab and click the Add Policy button on the

service.

If a policy is present for the module, it is listed in the available policies. Otherwise, a
new policy is created.

Deleting a Policy
Follow the steps to delete the policy of a SOAP Service or Reference Binding from TIBCO
Business Studio for BusinessWorks.

Procedure
1. Navigate to the Components > Bindings tab of the SOAP Service or Reference

Bindings.

2. Click the red cross icon of the policy name to be deleted.
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Result
The policy is removed from the bindings.
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Refactoring Properties
Refactoring of the following properties is possible.

l Process properties

l Module properties

l Application properties

Refactoring Process Properties
The following refactoring options are supported for Process Properties.

l Renaming a Process Property

l Deleting a Process Property

l Renaming a Shared Resource Reference in Process Property

l Deleting a Shared Resource Reference in a Process Property

Renaming a Process Property

Follow the steps to rename a process property into TIBCO Business Studio for
BusinessWorks.

Procedure
1. Select the process property to rename.

2. On the Process Properties tab, select the Property Name column and edit the name
in the column.
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The Process Property is renamed successfully.

Deleting a Process Property
Follow the steps to delete a process property from TIBCO Business Studio for
BusinessWorks.

Procedure
1. Select the process property to delete and click the delete variable icon.

The selected process property is deleted.
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Renaming a Shared Resource Reference in Process
Property
Follow the steps to rename a shared resource reference in a process property for TIBCO
Business Studio for BusinessWorks.

Procedure
1. Select the process property which is referencing the shared resource.

2. On the Process Properties tab, select the Property Name column and edit the name
in the column.
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All the name references are updated.

Deleting a Shared Resource Reference in a Process
Property
Follow the steps to delete a shared resource reference in a process property from TIBCO
Business Studio for BusinessWorks.

Procedure
1. Select the property from the shared resource and click the delete variable icon.

The shared resource reference property is deleted.

Refactoring Module Properties
The following refactoring options are supported for Module Properties.

l Renaming a Module Property

l Deleting a Module Property

l Renaming a Module Property Group

l Moving a Module Property to a Group
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l Deleting Module Property Group

Renaming a Module Property
Follow the steps to rename a module property.

Procedure
1. In the Project Explorer view, navigate to the Module Properties section and

double-click it.

2. In the Module Properties view, select the property to rename.

3. On the General tab of the Module Property section, click the Rename Properties

Configuration Group icon

The Rename Module Configuration Property dialog is displayed.

4. In the Rename Module Configuration Property dialog, change the name of the
module property.

5. Optional. To see the changes that are performed, click Preview.

6. Click OK.

The name of the module property is changed.
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Deleting a Module Property
Follow the steps to delete a module property.

Procedure
1. In the Project Explorer view, navigate to the Module Properties section and

double-click it.

2. In the Module Properties view, select the module property to delete. On the right
hand side panel click Delete.

The Remove Process Property dialog is displayed.

3. Optional. To see the changes that are performed, click Preview.

4. Click OK.

The module property is deleted.

Renaming a Module Property Group
Follow the steps to rename a module property group.
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Procedure
1. In the Project Explorer view, navigate to the Module Properties section and

double-click it.

The Module Properties view is displayed.

2. In the Module Properties view, select the module property group to rename.

3. On the General tab of the Module Property Group section, click the Rename
Properties Configuration Group icon.

The Rename Module Configuration Property Group dialog is displayed.

4. In the Rename Module Configuration Property Group dialog, change the name of the
module property group.

Note: If a module property group is renamed as "Application", a validation
error message occurs, because if you try to promote that property with the
name "Application", the group falls into an infinite loop since the name of
the application property section is also "Application".

5. Optional. To see the changes that are performed, click Preview.

6. Click OK.
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The name of the module property group is changed.

Moving a Module Property to a Group
Follow the steps to move a module property to a group.

Procedure
1. In the Project Explorer view, navigate to the Module Properties section and

double-click it.

The Module Properties view is displayed.

2. In the Module Properties view, select the module property to move into a group.

3. Drag and drop the selected module property to the group.

The module property is moved to the specified group.

Deleting Module Property Group
Follow the steps to delete a module property group.

Procedure
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1. In the Project Explorer view, navigate to the Module Properties section and
double-click it.

The Module Properties view is displayed.

2. In the Module Properties view, select the module property group to delete. On the
right hand side panel, click Delete.

The Remove Process Property dialog is displayed.

3. Optional. To see the changes that are performed, click Preview.

Important: TIBCO recommends to keep all the check boxes in the Remove
Process Property dialog selected.

4. Click OK.

The module property group is deleted.

Refactoring Application Properties
The following refactoring options are supported for Application Properties.
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l Renaming an Application Property

l Deleting an Application Property

Renaming an Application Property
Follow the steps to rename an application property into TIBCO Business Studio for
BusinessWorks.

Before you begin
To rename an application property, it first needs to get promoted.

Procedure
1. In the Properties view, select the application property and click the arrow to

promote it.

2. In the Property section, add a new name in the Name field of the promoted
application property and save the application.

Note: If an application property group is renamed as "Application", a
validation error message occurs, because if you try to promote that
property with the name "Application", the group falls into an infinite loop
since the name of the application property section is also "Application".
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Deleting an Application Property
Follow the steps to delete an application property from TIBCO Business Studio for
BusinessWorks.

Procedure
1. Select the promoted application property and click the Delete button on the right

hand side panel.

The application property is deleted.
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Refactoring Modules
The following refactoring operations are possible for modules:

l Copying and Pasting Modules

l Renaming Modules

l Deleting Modules

Copying and Pasting Application Modules
Follow the steps to copy and paste an application module into the same workspace in
TIBCO Business Studio for BusinessWorks

Procedure
1. Select an application module to copy.

2. Right-click on the application module and select the Copy option.

3. Right-click and select Paste BW option.
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The Use default location checkbox is selected by default. You can select the location
where you want to paste the copied application module.

If you want to select a different location other than the default location, disable the
Use default location checkbox, browse and select a new location from the Browse
for Folder window.

The application module is copied to the desired location.

Renaming Modules
Follow the steps to rename an application module.

Procedure
1. Select an application module to rename.

2. Right-click on the application module and select the Rename option.
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The Rename Project dialog is displayed.

3. In the Rename Project dialog, change the name of the application module.

4. Optional. To see the changes that are performed, click Preview.
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Important: TIBCO recommends to keep all the checkboxes in the Rename
Project dialog selected.

5. Click OK.

The new application module name is displayed in the Project Explorer view.

Note: The package name remains unchanged.

Renaming a Shared Module
Follow the steps to rename a shared module.

Procedure
1. Select a shared module to rename.

2. Right-click on the application module and select the Rename option.

The Rename Project dialog is displayed.

3. In the Rename Project dialog, change the name of the shared module.
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4. Optional. To see the changes that are performed, click Preview.

Important: TIBCO recommends to keep all the check boxes in the Rename
Project dialog selected.

5. Click OK.

The new name is displayed in the Project Explorer view.
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If any application module has dependency on the shared module, the new name of
the shared module is also reflected in the Dependencies section of the application
module.

Deleting an Application Module
Follow the steps to delete an application module from TIBCO Business Studio for
BusinessWorks
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Procedure
1. Select an application module to delete.

2. Right-click on the application module and select the Delete option.

The Confirm Project Delete dialog is displayed.

3. Click Yes.

The selected application module is deleted.

Delete the corresponding .application as well. Otherwise, you get the following
validation error:

Application configuration error. The Application [Test_Application_
Module.application] must include at-most one BusinessWorks Application Module.

Deleting a Shared Module
Follow the steps to delete a shared module:

Procedure
1. Select a shared module to delete.

2. Right-click on the shared module and select the Delete option.
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The Confirm Project Delete dialog is displayed.

3. In the Confirm Project Delete dialog, click Yes.

The selected shared module is deleted. If the shared module was referenced by other
shared or application modules, you get dependency related errors.

Import the deleted shared module to resolve dependency related errors.
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TIBCO Documentation and Support Services
For information about this product, you can read the documentation, contact TIBCO
Support, and join TIBCO Community.

How to Access TIBCO Documentation

Documentation for TIBCO products is available on the Product Documentation website,
mainly in HTML and PDF formats.

The Product Documentation website is updated frequently and is more current than any
other documentation included with the product.

Product-Specific Documentation

The following documentation for this product is available on the TIBCO ActiveMatrix
BusinessWorks™ page:

l TIBCO ActiveMatrix BusinessWorks™ Release Notes

l TIBCO ActiveMatrix BusinessWorks™ Installation

l TIBCO ActiveMatrix BusinessWorks™ Application Development

l TIBCO ActiveMatrix BusinessWorks™ Bindings and Palettes Reference

l TIBCO ActiveMatrix BusinessWorks™ Concepts

l TIBCO ActiveMatrix BusinessWorks™ Error Codes

l TIBCO ActiveMatrix BusinessWorks™ Getting Started

l TIBCO ActiveMatrix BusinessWorks™ Migration

l TIBCO ActiveMatrix BusinessWorks™ Performance Benchmarking and Tuning

l TIBCO ActiveMatrix BusinessWorks™ REST Implementation

l TIBCO ActiveMatrix BusinessWorks™ Refactoring Best Practices

l TIBCO ActiveMatrix BusinessWorks™ Samples

https://docs.tibco.com/
https://docs.tibco.com/
https://docs.tibco.com/products/tibco-activematrix-businessworks
https://docs.tibco.com/products/tibco-activematrix-businessworks
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How to Contact Support for TIBCO Products

You can contact the Support team in the following ways:

l To access the Support Knowledge Base and getting personalized content about
products you are interested in, visit our product Support website.

l To create a Support case, you must have a valid maintenance or support contract
with a Cloud Software Group entity. You also need a username and password to log
in to the product Support website. If you do not have a username, you can request
one by clicking Register on the website.

How to Join TIBCO Community

TIBCO Community is the official channel for TIBCO customers, partners, and employee
subject matter experts to share and access their collective experience. TIBCO Community
offers access to Q&A forums, product wikis, and best practices. It also offers access to
extensions, adapters, solution accelerators, and tools that extend and enable customers to
gain full value from TIBCO products. In addition, users can submit and vote on feature
requests from within the TIBCO Ideas Portal. For a free registration, go to
TIBCO Community.

https://support.tibco.com/s/
https://support.tibco.com/s/
https://ideas.tibco.com/
https://community.tibco.com/
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Legal and Third-Party Notices
SOME CLOUD SOFTWARE GROUP, INC. (“CLOUD SG”) SOFTWARE AND CLOUD SERVICES EMBED,
BUNDLE, OR OTHERWISE INCLUDE OTHER SOFTWARE, INCLUDING OTHER CLOUD SG SOFTWARE
(COLLECTIVELY, “INCLUDED SOFTWARE”). USE OF INCLUDED SOFTWARE IS SOLELY TO ENABLE THE
FUNCTIONALITY (OR PROVIDE LIMITED ADD-ON FUNCTIONALITY) OF THE LICENSED CLOUD SG
SOFTWARE AND/OR CLOUD SERVICES. THE INCLUDED SOFTWARE IS NOT LICENSED TO BE USED OR
ACCESSED BY ANY OTHER CLOUD SG SOFTWARE AND/OR CLOUD SERVICES OR FOR ANY OTHER
PURPOSE.

USE OF CLOUD SG SOFTWARE AND CLOUD SERVICES IS SUBJECT TO THE TERMS AND CONDITIONS
OF AN AGREEMENT FOUND IN EITHER A SEPARATELY EXECUTED AGREEMENT, OR, IF THERE IS NO
SUCH SEPARATE AGREEMENT, THE CLICKWRAP END USER AGREEMENT WHICH IS DISPLAYED WHEN
ACCESSING, DOWNLOADING, OR INSTALLING THE SOFTWARE OR CLOUD SERVICES (AND WHICH IS
DUPLICATED IN THE LICENSE FILE) OR IF THERE IS NO SUCH LICENSE AGREEMENT OR CLICKWRAP
END USER AGREEMENT, THE LICENSE(S) LOCATED IN THE “LICENSE” FILE(S) OF THE SOFTWARE. USE
OF THIS DOCUMENT IS SUBJECT TO THOSE SAME TERMS AND CONDITIONS, AND YOUR USE HEREOF
SHALL CONSTITUTE ACCEPTANCE OF AND AN AGREEMENT TO BE BOUND BY THE SAME.

This document contains confidential information that is subject to U.S. and international copyright
laws and treaties. No part of this document may be reproduced in any form without the written
authorization of Cloud Software Group, Inc.

TIBCO, the TIBCO logo, the TIBCO O logo, ActiveMatrix BusinessWorks, ActiveSpaces, Business Studio,
TIBCO Business Studio, TIBCO Designer, TIBCO Enterprise Administrator, Enterprise Message Service,
Rendezvous, and TIBCO Runtime Agent are either registered trademarks or trademarks of Cloud
Software Group, Inc. in the United States and/or other countries.

Java and all Java based trademarks and logos are trademarks or registered trademarks of Oracle
and/or its affiliates.

All other product and company names and marks mentioned in this document are the property of
their respective owners and are mentioned for identification purposes only. You acknowledge that all
rights to these third party marks are the exclusive property of their respective owners. Please refer to
Cloud SG’s Third Party Trademark Notices (https://www.cloud.com/legal) for more information.

This document includes fonts that are licensed under the SIL Open Font License, Version 1.1, which is
available at: https://scripts.sil.org/OFL

Copyright (c) Paul D. Hunt, with Reserved Font Name Source Sans Pro and Source Code Pro.

https://www.cloud.com/legal
https://scripts.sil.org/OFL
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Cloud SG software may be available on multiple operating systems. However, not all operating
system platforms for a specific software version are released at the same time. See the “readme” file
for the availability of a specific version of Cloud SG software on a specific operating system platform.

THIS DOCUMENT IS PROVIDED “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR
IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

THIS DOCUMENT COULD INCLUDE TECHNICAL INACCURACIES OR TYPOGRAPHICAL ERRORS. CHANGES
ARE PERIODICALLY ADDED TO THE INFORMATION HEREIN; THESE CHANGES WILL BE INCORPORATED
IN NEW EDITIONS OF THIS DOCUMENT. CLOUD SG MAY MAKE IMPROVEMENTS AND/OR CHANGES IN
THE PRODUCT(S), THE PROGRAM(S), AND/OR THE SERVICES DESCRIBED IN THIS DOCUMENT AT ANY
TIME WITHOUT NOTICE.

THE CONTENTS OF THIS DOCUMENT MAY BE MODIFIED AND/OR QUALIFIED, DIRECTLY OR
INDIRECTLY, BY OTHER DOCUMENTATION WHICH ACCOMPANIES THIS SOFTWARE, INCLUDING BUT
NOT LIMITED TO ANY RELEASE NOTES AND "README" FILES.

This and other products of Cloud SG may be covered by registered patents. For details, please refer
to the Virtual Patent Marking document located at https://www.tibco.com/patents.

Copyright © 2019-2023. Cloud Software Group, Inc. All Rights Reserved. Confidential & Proprietary.

https://www.tibco.com/patents
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