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Changing Help Preferences

By default, documentation access from TIBCO Business Studio™ for BusinessWorks™ is
online, through the TIBCO Product Documentation website that contains the latest version
of the documentation. Check the website frequently for updates. To access the product
documentation offline, download the documentation to a local directory or an internal web
server and then change the help preferences in TIBCO Business Studio for BusinessWorks.

Before you begin
Before changing the help preferences to access documentation locally or from an internal
web server, download the documentation.

1.
2.

6.

Go to https://docs.tibco.com/
In the Search field, enter TIBCO ActiveMatrix BusinessWorks™ and press Enter.

Select the TIBCO ActiveMatrix BusinessWorks™ product from the list. This opens the
product documentation page for the latest version.

Click Download All.

A compressed .zip file containing the latest documentation is downloaded to your
web browser's default download location.

Copy the .zip file to a local directory or to an internal web server and unzip the file.

To point to a custom location:

Procedure

1.

2.

Perform one of the following steps in TIBCO Business Studio for BusinessWorks based
on your operating system:

e On Windows OS: Click Window > Preferences

e On macOS: Click TIBCO Business Studio > Preferences.

In the Preferences dialog, click BusinessWorks > Help.

3. Click Custom Location, and then browse to the html directory in the folder where

you extracted the documentation or provide the URL to the html directory on your

TIBCO ActiveMatrix BusinessWorks™ Samples
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internal web server.

4. Click Apply, and then click OK.
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Accessing Samples

You can access the samples in TIBCO Business Studio™ for BusinessWorks™ from the File

Explorer view.

Procedure

1. Open TIBCO Business Studio™ for BusinessWorks™ from $TIBCO_
HOME\studio\<version>\eclipse\TIBCOBusinessStudio.exe.

By default, TIBCO Business Studio™ for BusinessWorks™ opens the Design

perspective.

2. Click Help > BusinessWorks Samples.

The Welcome screen is displayed with various available samples, for example, REST
Bookstore - Basic, REST Bookstore - Database, Order Processing.

@ Welcome 2

0

First Steps

Samples

TIBCO Business Studio for
BusinessWorks(TM)

Click a sample below to import the project into your
workspace. See the Reference page for information about
the sample and instructions on how to run it

@ REST Bookstore - Basic

) Demonstrates how to use REST AP1
methods to add and retrieve book
data that is stored in a file

REST Bookstore - Database
\

) Demonstrates how to use REST API
methods to add, retrieve, update,
and delete book data that is stored
in a database

"1% REST Authorization Policy

Demonstrates how to use an
authorization policy with a REST
sarvice.

)

[‘2.-“ Invoke Java

b 3 Demonstrates how to call custom
Java code from a BW process.

% Quick Start
Go through Quick Start guide

(Cheatsheets) to leam to use TIBCO
Busingss Studio for Businessworks
quickly

| g

[ 5 ~
Workbench

Order Processing

Demaonstrates a simple order
processing service with File and XML
adivities.

Call Process

Demonstrates how to invoke one
BW process from another.

Fault Handling

Demenstrates how to catch faults
using scopes and fault handlers.

More Samples...

Installing New Plugins...

Enable Guided User
Experience...

TIBCO ActiveMatrix BusinessWorks™ Samples
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3. Select the required sample.

The File Explorer view displays a top-level listing of all the samples.

o Note: If the workspace is from an older version, you need to locate the

samples manually using the Open Directory to Browse button available
on the File Explorer view. TIBCO Business Studio™ for BusinessWorks™
stores the samples at tibco-home/bw/6.6/samples.

4. Navigate to the directory containing the sample that you want to access and do the
following:

2= Outline = API Explorer ®5 Cloud Applications & Deployment Servers & Module | File Explorer &

» & C\Program Files\TIBCO\BW6_HOME\bw\6.6\samples
¥ = AppSpace
v & binding

= Container
& TibcoCloud

HE@E

v & rest
¥ = Basic
books.json
readme.link
L tibcobw.sample binding.rest.Basic.zip
& BookStore
& spap
= bw5s
& core
= palette
= policy
& scenario

“= 50urce

Double-click the archive file, <sample_name>.z1ip, to import the sample
application to your workspace. For example, double-click
tibco.bw.sample.binding.rest.Basic.zip to import the application and the
application module to your workspace. Alternatively, you can right-click the
required project folder and click Import Selected Projects option to import the
required application.

Click readme.link to open the sample Help page in the Reference - online
view. For example, by clicking binding > rest > Basic > readme.link you can
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access the help page for a Basic REST Sample application. You can access the
help page of all samples by following the same procedure.
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Guided User Experience in TIBCO Business
Studio for BusinessWorks

TIBCO Business Studio for BusinessWorks introduces a new feature, guided user
experience, wherein you can see notifications, pop-up messages, tooltips, or suggestions
while performing an operation.

To enable the guided user experience option, navigate to Window > Preferences >
BusinessWorks > Guided User Experience and select the Enable Guided User Experience
check box on the Preferences window.

# Preferences

type filter text Guided User Experience

General " | Enable Guided User Experience to help you learn more about TIBCO Business Studio for BusinessWorks

Ant []Enable Guided User Experience
Bpel Diagram

~ BusinessWorks
Bindings
Deployment
Deployment Profile
Guided User Experience
Help
Namespace Registry
Palettes
Process Diagram
Project Defaults
Project Export
Run/Debug
Service Registry
Team Development

Validation v Restore Defaults Apply
@ Cancel
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Or click Enable Guided User Experience... on the Welcome screen and select the Enable
Guided User Experience check box on the Preferences window.

+# Design - TIBCO Business Studio for BusinessWorks(TM) - C:\Users\workspace

File Edit Navigate Search Project Run Window Help
7 & Welcome & ] s
2]

)

First Steps . Workbench

Samples

TIBCO Business Studio for BusinessWorks(TM)

Click a sample below to import the project into your workspace See the Reference page for
information about the sample and instructions on how to run it

Order Processing
REST Bookstore - Basic . . . y
Demonstrates a simple order processing service with File and
Demonstrates how to use REST API methods to add and retrieve XML activities.
book data that is stored in a file.
a Call Process
REST Bookstore - Database
Demonstrates how to invoke one BW process from another.

Demonstrates how to use REST API methods to add, retrieve,
update, and delete book data that is stored in a database.

.'i Fault Handling

REST Authorization Policy Demonstrates how to catch faults using scopes and fault

handlers.
Demonstrates how to use an authorization policy with a REST
service.
Invoke Java More Samples...

Demonstrates how to call custom Java code from a BW process.

Open Cheatsheets Installing New Plugins...

£ o 9 9 9

Display Cheatsheets to learn to use Tibco Business Studio for
Businessworks quickly.

Enable Guided User Experience...

For example, while developing an application, when you click Generating EAR, the Create
Application Archive (EAR) window is displayed. If you have already enabled guided user
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experience, the Exclude Unused Resources check box is visible and selected by default.

Q Create Application Archive (EAR) O X
EAR Export

Warning: an EAR file with same name already exists in the directory.
EAR Location: ‘ k::\Users\Documents Browse...
Use Default EAR file name

EAR File Name tibco.bw.sample.palette.jms.QueueReceiver.application_1.0.0

[] Export EAR without profiles
Exclude Unused Resources

@ < Back Next > Finish Cancel
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Setting the Default Application Profile

Procedure
1. Before executing the sample, ensure to update the default application profile
according to the OS Platform you are using.

2. Click the<Project>.application, expand Package Unit folder and open the
Properties file.

= Eqiﬁlliii Explorer 3 AT Adal=)
13 tibco.bw.sample.palette.file.OrderProcessing

vﬁtibcn.bw.EampIe.palette.ﬁle.DrderFrGCEEsing.applicatiun
v %&; Package Unit
4k Overview
%IncludEE
iE|Properties

3. If you are using Unix based system, then select UnixProfile column header to enable
Set as Default button. Click the Set as Default button to set it as the default
application profile. The default profile is indicated by the straight brackets [ ] around
the profile name.

% tiboo.bw.sarmple.paliette. file. OrderProcessing application 33 =0
@ Properties

Froparties
Property Configurations

Mew Property Mew Croup Mew Prafile a1 as Default
Properies WimizcProfis Fafindown Frofile)
W Application Delete
B tiboo. b sample.palett..
BB _new_order_file  ftmp/BW_new_order.xml \trnp BW_new_order.xml Skl
BEBW_cuitomer_motific.., fimpfOvdeProcessing FBW_customer_Rotification et e\Impl DrderProceding | BW_tuitemer_notifcation txn T —
BEBW_appeoval Ml ferap ) BW_spprove_cader,txt e\ep | BW_approve_ondes,tx
BELEW_shapping_costs ferp ) BW_skipping_costs.xml e\ BN, shippireg_costs, wml
BELEW_new_ordler_src .'nm:Ini.'palnn-jhlo.'drdlrﬁ-o-uﬂ-nq.'BW rorw_order, xml '\umplﬂ'Lpﬂlun.',ﬂll\-D(ﬂrrFmaﬂingW_mw_wﬂrr.uml
BELEW_approwal_sro {samples/paletoe) file/ OrderProcessingiapprove. ta isamphes, paberte’ fil e\ OvderProcessing iapprove et

Bl EW_shipping_cost_src fsamples/paletie)file/OrderProcessing/BW_shipping_costs.aml  ysamples' palettet file’ OrderProcessing | BW_shipping_costs.xml

Dilete Profile

Reset Value

Symc Values

rervidv | Includes Proparties MAMNIFEST.MF

If you are using Windows system, then ensure the WindowsProfile is set as default
before running or debugging this application in TIBCO Business Studio™ for
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BusinessWorks™.

4. Save your project.
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Creating a ActiveMatrix BusinessWorks

Project from Template

You can use an existing ActiveMatrix BusinessWorks project template to create a new

project.

Before you begin

TIBCO Enterprise Message Service must be running.

Procedure

1. Navigate to File > New > Project > BusinessWorks and click the BusinessWorks

Project from Template option. Click Next.

Or click the & icon on the toolbar.

The Create Project from template dialog box is displayed.

#/ Create Project from template

Create Project from template
Create Project from a template file
(® Select Template File: ‘ | Browse
Projects:
Select All
Deselect All
Refresh
@ < Back Next > Finish Cancel
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10.

11.

12.
13.

In the Select Template File field, provide the template file location from the samples
directory, bwTemplate >
tibco.bw.sample.Template.TemplateSample.1.0.0.bwtemplate. The project in the
template is displayed.

To see information about template, click Next.

To rename the project, click Next. In the Existing Name column, select the project
and provide the name in the New Name column.

Click Finish. On successful project creation, you can see the template project in the
Project Explorer pane.

In the Project Explorer view, expand the
tibco.bw.sample.Template.TemplateSample project.

Verify your TIBCO Enterprise Message Service connection.
a. Fully expand the Resources directory.
b. Double-click JMSConnectionResource.jmsConnResource.

c. In the Basic Configuration pane, click the Test Connection button to verify the
connection.

Fully expand the Processes directory and double-click Process.bwp.
Click Run > Debug Configurations.

At the left of the Debug Configurations wizard, expand BusinessWorks Application
and select BWApplication.

In the Applications tab, click the Deselect All button if you have multiple
applications. Select the check box next to the
tibco.bw.sample.Template.TemplateSample.application option.

Click Debug. This runs the sample in the Debug mode.

Click the ® (Terminate) icon to stop the process.

Result
The Console displays messages similar to the following:

13:11:42.211 INFO [bwEngThread:In-Memory Process Worker-1]
com.tibco.bw.palette.generalactivities.Log.tibco.bw.sample.Template.Temp
lateSample.Log - Sending JIMS Message

TIBCO ActiveMatrix BusinessWorks™ Samples



20 | Creating a ActiveMatrix BusinessWorks Project from Template

13:11:42.243 INFO [bwEngThread:In-Memory Process Worker-1]
com.tibco.bw.palette.generalactivities.Log.tibco.bw.sample.Template.Temp
lateSample.Logl - IMS Message sent successfully

13:11:42.337 INFO [bwEngThread:In-Memory Process Worker-2]
com.tibco.bw.palette.generalactivities.Log.tibco.bw.sample.Template.Temp
lateSample.Log2 - Message received IMS Message sent

Understanding the Configuration

The JMS Send Message activity sends the messages with the message style set to Queue.
The Get JMS Queue Message activity receives the JMS messages from a Queue.

TIBCO ActiveMatrix BusinessWorks™ Samples
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Unit Testing

Unit testing in ActiveMatrix BusinessWorks consists of verifying whether individual activities
in a process are working as expected. While you can run the unit tests on processes any
time during the development cycle, testing the processes before you push the application
to the production environment may help you to identify issues earlier.

This section explains how to use the Maven plugin and its features to achieve unit testing
of ActiveMatrix BusinessWorks projects.

Following are the sample projects provided with the ActiveMatrix BusinessWorks
application:

e MainProcessWithUnitTestDemo.zip: Sample to show the assertion or mocking
support of main processes, mocking support of process starters, and REST and SOAP
Service binding

* UnitTestDemoProject.zip: Sample to show the assertion or mocking support of
subprocesses

Following are the details of the processes in the sample projects:
MainProcessWithUnitTestDemo:

e MainProcessWithProcessStarterMocked: Shows assertion support in the main process
along with mocking support on process starter

e RESTServicBindingeMocked: Shows mocking support on the REST Service binding
» SOAPServiceBindingMocked: Shows mocking support on the SOAP Service binding
UnitTestDemoProject:

* SubProcesswithActivityAssertion.bwp: Shows mocking support and Activity Assertion
in a subprocess

e SubProcessWithPrimitiveAssertion.bwp: Shows mocking support and Primitive
Assertion in a subprocess

TIBCO ActiveMatrix BusinessWorks™ Samples
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Maven Test Sample of Main Process

This sample covers mocking for activities in process, service binding, starter activity and
types of activity assertions.

Before you begin
e Ensure that Maven is installed on your system.

» Ensure that the Maven plugin is installed correctly in your bw studio by verifying the
Maven folder present under tibco_home\bw\6.8 directory.

Procedure
1. In the samples directory, select AppSpace > UnitTesting and double-click
MainProcessWithUnitTestDemo.zip. For more information, see Accessing Samples.

2. Mavenize the project by right-clicking MainProcessWithUnitTestDemo.application
and selecting the Generate POM for Application option. The POM Generation
window is displayed.

3. Enter the Parent POM details such as Group Id, Parent Artifact Id, and so on, and
click Finish.

Note: The workspace is indexed after generating the POM files for the first
time and may take some time. You can continue with the following steps
and allow the indexing to run in the background.

4. MainProcessWithUnitTestDemo.application.parent is generated and the project is
converted to Maven (Eclipse project) nature.

5. Right-click MainProcessWithUnitTestDemo.application.parent and select Run as >
Maven test.

6. Check the console to see the result.

Result
The console displays messages similar to the following:

TIBCO ActiveMatrix BusinessWorks™ Samples
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[INFO]

Tests for mainprocesswithunittestdemo.MainProcesshithProcessStarterMocked
Tests run @ 1 Success @ 1 Failure :
Tests for mainprocesswithunittestdemo.RESTServicBindingeMocked

Tests run : 1 Success : 1 Failure : @ Errors : @
Tests for mainprocesswithunittestdemo.SOAPServiceBindingMocked
Tests run : 1 Success : 1 Failure : @ Errors : @
Results

Success : 3 Failure : 2 Errors

2 Errors : @

o Note: Here we have covered 3 positive scenarios and 2 negative scenarios by

giving incorrect value to assertions. If you want to see the result in the html
form, use Maven “site” goal, while running the application.

¥ MainProcessWithUnitTestDemo [3We
~ @ MainProcessWithUnit TestDemo.applicat
% Package Unit
~ & target
& bwtest
~ & site
B css
& images
@ bwcoverage html
@ bwtest.htral
@ dependency-info.html
@ index html
@ plugin-management htrnl
@ plugins html
@ project-info.html
@ project-reports html
@ surnmary.html
< >

ED 2A HC LF s @M BDp 7

i palette

& policy

& Profile Encrypticn

& scenario

= source

~ & UnitTesting
& MainProcesswithUnitTestDem
L MainProcessWithUnitTestDeme
& UnitTestDemoProject.applicatic
1 UnitTastDemoProject 7ip
< >

T

-

B v filed VG RutujaO HiceWork/Sprint/V13/Maven SenityWS3/MainProcessWithUnitTest Demo application/target/site/bwiest html

Paren
M. thUnitTestDen
P ion
3
bratest

Built by .

maven

< >

&

MainProcessWithUnitTestDemo.application

Last Published: 2022-04-20 | Version: 1.0.0-5NAFSHOT

> H

MainProcessWithUnitTestDemeo. application

BW Test Report

Summary

[Summary] [Package List] [Test Cases] [Failure Details]

3 ] 1 0 66.67%

Package List

[Summary] [Package List] [Test Cases] [Failure Details]

[ MainProcesswithunitTestDemo || mainprocesswithunittestdemo || 3 [0 [1 [o

le6.67%

@
~ [

Understanding the Configuration

The project contains the following processes.

¢ MainProcessWithProcessStarterMocked.bwp:

This process has JMSReceiver as a starter activity. Whenever a message is published
on JMS queue, this process gets triggered. From the JMS message content, input for

“GetBooks By author” SOAP call is constructed using mapper activity. Later in the

process,“GetBooks By Author” SOAP call is made, which returns corresponding book
details, and then using a mapper, the output response is converted in required

format.

This process shows assertion support in the main process along with mocking
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support on process starter.

@ MainProcessWithProcessStarterMocked.bwp &

iS| i i i i ithProressStarterMacked
= O o
i >GetBooks...
#] GetBooks
81 _ I @1 w! .
f-lbl ol T T
& e E R iod
JMSReceiveMes Log Mapper  GetBooks Mapperl Lofrl
7
Mapper2

e RESTServicBindingeMocked.bwp:

This process is triggered by the POST endpoint call, which requires book details like
isbn, name, description, and author name in the post body. First this process
publishes the book name, which it received in the POST body, as JMS message body
and author name as dynamic property to a JMS queue. Later using mapper activity
output for the REST endpoint is constructed and then using mapper the output is
mapped to the postOut (reply activity).

This process shows mocking support on the REST Service binding.
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@ RESTServicBindingeMocked.bwp

» 0 @

s ¥ wiFo 2o

resource (2] recource/oost =
3 —e——8
= .
JMSSendMessa Mapper postOut

e SOAPServiceBindingMocked.bwp:

This process is triggered by the Get Books SOAP call, which receives ‘author’ as an
input. After accepting author as input, depending on the author, the required output
is constructed using mapper activity and then using GetBooksOut (Reply activity) the
response like title, author, date isbn, and publisher is returned in the response.

This process shows mocking support on the SOAP Service binding.

@ SOAPServiceBindingMocked .bwp =

mainnrocesswithunittestdemao SOAPServiceRindinaMacked

GetBook...
2] GetBooks &1 »

=l
g—= B
- _

GetBooksIn Mapper GetBooksOut

Troubleshooting
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If you find the application = null error in the console then check the Maven version by
navigating to Window > Preferences > Maven Defaults. The BW6 Maven Plugin Version
should be the same as the plugin version you installed while installing TIBCO Business
Studio for BusinessWorks. Similarly, check Maven version in the pom.xml file.

Refer the Troubleshooting guide for any issues.

Maven Sample of Unit Test Demo Project

This sample covers mocking for activities in process, subprocess, service binding, starter-
end activity, and types of activity assertion.

Before you begin
e Ensure that Maven is installed in your system.

e Ensure that the Maven plugin is installed correctly in your bw studio by verifying the
Maven folder present under tibco_home\bw\6.8 directory.

Procedure

1. In the samples directory, select AppSpace > UnitTesting and double-click
UnitTestDemoProject.zip. For more information, see Accessing Samples.

2. In the Project Explorer, right-click UnitTestDemoProject.application and select
Generate POM for Application. The POM Generation window is displayed.

3. Enter the Parent POM details such as Group Id, Parent Artifact Id, and so on, and
click Finish.

Note: The workspace is indexed after generating the POM files for the first
time and may take some time. You can continue with the following steps
and allow the indexing to run in the background.

4. UnitTestDemoProject.application.parent is generated and the project is converted
to Maven (Eclipse project) nature.

5. Right-click UnitTestDemoProject.application.parent and select Run as > Maven
test.

6. Check the console to see the result.
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Result
The console displays messages similar to the following:

Tests for unittestdemoproject.SubProcesswithActivityAssertion
Tests run : 2 Success : 2 Failure : @ Errors : @
Tests for unittestdemoproject.SubProcessWithPrimitiveAssertion
Tests run : 1 Success @ 1 Failure : @ Errors : @
Results

Success : 3 Failure : @ Errors : @

Note: Here we have covered 3 positive scenarios. If you want to see the result in
the html form, use maven “site” goal, while running the application.

& UnitTestDemoPraject [BWE AppSpace] Lost Published: 2022-04-21 | Version: 1,0,0-SNAPSHOT UnitTestDemoProject.application
¥ # UnitTestDemoProject application [BW6 AppSpace]
% Package Unit Parent Project

> = target
@ bwtest

v e site

< BW Test Report

> 055

Built by " —

maven
@ bweoverage.html @ > ‘ Su m m a l‘y

& images

@ bwtesthtm <

@ dependency-info_html [Summary] [Package List] [Test Cases] [Failure Details]
@ index html

@ plugin-management.html

@ plugins.html
@ project-info html v (3 0 0 0 100%
% Outline = APIEx_. ¥HCloud . = File Ex.. 2 @ Module B Deploy.. ~ 7

=)

& palette S

& policy Package List

& Profile Encryption

@ seenario

& source [Summary] [Package List] [Test Cases] [Failure Details]

“ @ Unitlesting

& MainProcessWithUnitTestDemo.application parent
L MainProgessWithUnitTestDemo.zip

& UnitTestDemoProject.application.parent

[UnitTestDemoProject |[unittestdemoproject |[3 [0 ) o [100%

L UnitTestDemaProject.zip

Understanding the Configuration
The project contains the following processes.

¢ MainProcess.bwp:

This process has a timer as a starter activity, which is executed only once. Later this
process makes a subprocess call to another subprocess,
SubProcessWithPrimitiveAssertion.bwp.
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@ MainProcessWithProcessStarterMocked.bwp &

[i=] o - - o - |
- wmmmmmmﬁ —
GetBooks...

#l GetBooks
B _ OJ_.\ . @ o .
B e — 0 — 00—

JMSReceiveMes Log Mapper GetBooks Mapperl LOF‘I
o

Mapper2

e SubProcessWithPrimitiveAssertion.bwp:

This process does not accept any input. First, it sends a request to a JMS destination,
queue in this case, using the JMS Request Reply activity. Later, the JMS Request
Reply activity body is logged and the reply message is mapped to the required
format using the mapper activity. The output of the mapper is mapped with the end
activity.

This process shows mocking support and Primitive Assertion in a subprocess.

@ RESTServicBindingeMocked.bwp

=] mainnracesswithunittestdema RESTServicRindinaeMacked

resource ] recource/nost =g
' B
- - — a
JMSSendMessa Mapper postOut

* SubProcesswithActivityAssertion.bwp:
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This process accepts authorlID as an input of the Start activity. The book details
corresponding to the the authorlD are displayed in the mapper. The GetBooks SOAP
call is invoked by the author as an input. The GetBooks response is logged using the
log activity.

This process shows mocking support and Activity Assertion in a subprocess.

i@ SOAPServiceBindingMocked bwp &

| mainnrocesswithunittestdemo SOAPServiceRindinaMocked

GetBook... )

2] GetBooks #1 »

GetBooksIn Mapper GetBooksOut

* JMSReceiver.bwp:

This process has a JMS Message receiver as a starter activity which gets triggered
when a message is received on a queue (queue.sample). Later this process replies to
the JMS message received using the Reply to JMS Message activity and then log the
message.

¢ SOAPService.bwp:

This process implements SOAP Getbooks by author operation, which accepts author
as an input and replies the corresponding book details of that author in the
response. The response is hard-coded.

Troubleshooting

If you find the application = null error in the console then check the Maven version by
navigating to Window > Preferences > Maven Defaults. The BW6 Maven Plugin Version
should be the same as the plugin version you installed while installing TIBCO Business
Studio for BusinessWorks. Similarly, check Maven version in the pom.xml file.

Refer Troubleshooting guide for any issue
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Binding Features

Endpoints expose the location of the service to the service partner. An endpoint binding
specifies the transport to use for the endpointany transport-specific properties. This section
includes samples that show how to use bindings correctly.

Using Basic REST Binding

In this REST Bookstore sample you can use the RESTful service to add, and retrieve books
from a Bookstore (in this sample, Bookstore is files as a datastore). This sample uses two
REST methods: POST and GET.

Before you begin
Install the latest Google Chrome version in the standard default location.

Note: If you are accessing the sample from the Welcome page of TIBCO
Business Studio™ for BusinessWorks™, go directly to Step 3.

Procedure

1. In the samples directory, select binding > rest > Basic and double-click
tibco.bw.sample.binding.rest.Basic. For more information, see the Accessing
Samples section.

2. In the Project Explorer, expand the tibco.bw.sample.binding.rest.Basic project.

3. Set the default application profile to match the OS you are running on. For more
information, see Setting the Default Application Profile.

4. Fully expand the Processes directory and double-click books.bwp.
5. Click Run > Debug Configurations.

6. At the left hand tree of the Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.
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7. Click the Applications tab, and then click the Deselect All button, if you have
multiple applications. Select the check box next to
tibco.bw.sample.binding.rest.Basic.application.

8. Click Debug. This executes the sample in Debug mode.

The console window shows engine messages similar to: Started BW Application
[tibco.bw.sample.binding.rest.Basic.application:1.0].

The OSGI command to list REST and Swagger URLs is lrestdoc, which lists the
following discovery URL:

[Application Name]: tibco.bw.sample.binding.rest.Basic.application [Discovery Url]:
http://localhost:7777/tibco.bw.sample.binding.rest.Basic.application.

9. Launch Google Chrome browser and open
http://localhost:7777/tibco.bw.sample.binding.rest.Basic.application.

Result
The Swagger API Page displays:

2] Sﬂgﬂﬂr hipcimachinename-t440:77 T Titiboo bw sample binding rest Ba _ Explorne

tibco.bw.sample.binding.rest.Basic.application

books Shoa'tide List Operations  Expand Operations

Click POST and provide the JSON payload.

You can use the books.json payload provided with the sample present at Bw_
HOME\samples\binding\rest\Basic\books.json. On successful POST of Data, the
books. log file is created in the c:/tmp/RestBasic folder (or /tmp/RestBasic on Unix
Platform), with the data you just posted.

Click Get > Try it out to view all the books that you have just posted. You can see the data
similar as the following:
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Request URL
ey leealhase o 1 b Meaoks

Response Body

"Beak™s [

={gbn": “14%31648337",

"name": "iteve Jeba™,

“descriptien”y “Blagrephy of Apple Co-Foender Steve Jobs™,
“sathorfiisse™; “Halter Iiascion™,

"releasebate™: "3Eil-16.34",

“wintage™: Talss,

“slgned”; false,

"prlce™: ¥

"Laba": "aNEYIITELN",

"nase”: "Inferna”,

“description”s “Robert Lesgdon retures in Den Brown's latest fast paced scilon thirllee®,
"suthorfisss™: "Den Brown”,

"releasebate™s "DE15.05.147,

“vintage™1 false,

Response Code
£

Response Headers

.. “Content-Type™: “spplicetlon/{scn™

You can also change the output file location.

To change the output file location, go to tibco.bw.sample.binding.rest.Basic.application
> Package Unit, and open Properties file for editing. Depending on your Operating System
under test, edit the output file location in either the UnixProfile column or
WindowsProfile column.

The Books_Invoke.log file is generated at c:\tmp\RestBasic\. This file contains POST
Books and GET Books output from the Client process.

Understanding the Configuration

The project contains the following processes.

* Books Process: In this process, a REST service is created that performs two
operations, POST and GET. The POST operation posts one or more books to the
bookstore or books collection (in this case a file) and the GET operation retrieves all
the books from the Bookstore (file). In the Books/post operation, a sub process is
called to add books to the file. The PostBooksToFile operation is implemented in
the BooksFile subprocess. In the Books/get operation, a sub process is called to
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retrieve books from the file. The GetBooksFromFile operation is implemented in the
BooksFile subprocess. The following diagram depicts the Books process.

tibco.bw.sample.binding.rest.basic.Books |
D 2 @ B, vi) M)
(2] Books/post] wlE = BooksFileSe...
2] PostBooksToFile
2] get ® a 0 |2l GetBooksFromFile
PostBooksToFile postOut
2] Books/get| =k
‘ B8 -
GetBooksFromFile getOut
N J

BooksFile Subprocess: File handling is managed using the BooksFile sub process,
which adds and retrieves books from the file. The BooksFileService service
implements the operations to add and get books from the file. In
BooksFileService/PostBooksToFile, Render JSON activity is used to render data that
the user has posted, write it to a file, read the file, parse the data, and then post the
data back to the user. In BooksFileService/GetBooksFromFile, the file previously
created is read, parsed, and then the data is returned to the user.

B okt b e ey rd B ool e

a5
B F dtatn
_‘__M_. T ol irleo=a PoalachiTolde
P Pranilezinlolie
T et rpemdim ® = f—* e E o
- 1 S jol = -

e ] fenpbocad se Fapdloanisg Fararldd Fritlagay Tl selZogl
o R e L
[ i 2 it
R a—

LIPS Epmnriing Vafcd Wl gt dplid

Client Process: This is a REST Client process which uses Invoke REST API activity to
retrieve data from the REST Server. This process is used to invoke the POST and GET
operations on the REST resource.

For example, in POST_Books, we provide HTTP Client Resource that listens to the
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same host and port as that of the server. The Resource Path is " /books", HTTP
Method is "POST", and Request and Response type is JSON. In the Message Body, we
provide the JSON payload which is read from the file present at Bw_
HOME\samples\binding\rest\BookStore\samplejson\books.json.

This JSON payload is then posted to the output file.

|- tibco.bw.sample. binding.rest basic. Client
— & . — =,
—_— —_— E:?R —_— 4 /
Timner ReadFile POST Books  Parsel 30N Render)S0N WrithFile

Dm0

WriteFilel Render)50M1 Parsel S0M1 GET_Books

Troubleshooting
* If you do not see the REST Swagger API page, verify whether the application has

started.

 If you see any problem markers in the project, clean the project by invoking Project
> Clean or try switching to a clean new workspace.

* If you get any File was not found exception, verify whether the books.json file is
present at the location as described in the Input_File Module Property.

Using REST to Manage Books for a Bookstore

This REST Bookstore Sample Using a Database shows how to use the RESTful service to
add, delete, update, and retrieve books from Bookstore.

The sample uses the following HTTP methods for the Books REST resource:
» POST: Add books to the bookstore

e GET: Get books from the bookstore
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e PUT: Updates books to the bookstore

e DELETE: Deletes books from the bookstore

Before you begin
Install the latest Google Chrome version at the standard default location.

Install the PostgreSQL Database:

=

> W

Download and install PostgreSQL from http://www.postgresql.org/download/.
Go to SQL Shell (psql) from the installed program.
The PostgreSQL command line window starts.

Open the DB and table creation script, dbsetup.sql from the scripts folder under
TIBCO_HOME/bw/n.n/samples/binding/rest/BookStore/scripts.

Run the script from the command line as per the instructions given in the readme file
present under the scripts folder.

You see the database and the tables created from the pgAdmin Ul from the installed
program.

Note: If you are accessing the sample from the Welcome page of TIBCO Business
Studio™ for BusinessWorks™, go directly to Step 3.

Procedure

1.

In the samples directory, select binding > rest > Bookstore and double-click
tibco.bw.sample.binding.rest.BookStore. For more information, see Accessing
Samples.

. In Project Explorer expand the tibco.bw.sample.binding.rest.BookStore project.

Set the default application profile to match the OS you are running on. For more
information, see Setting the Default Application Profile.
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4.

5.

10.

11.

[ b brw. samplle bindew.nent Book Storeapplcation [0 =0
[ Properties
Froperties
Property Configunataons.
[ ocm Property | | tiew Growp | | Mow Profie | 5t s Detit
W Applerston
Bl HOST oy o st iy
T @Paivased  sssees -
123 PORT 0 B 0
Bt Outpent_Fie AmpRetockitcrn bockilog e mpRertflock oy Bocka log
Bt Ingt,_File 1 Mg Berdeh g M BooiReny . amplel bandeny nHLUBookSon . [LameleL Bt reil Bock e L
[0 1518537 1451688537 1451548537 Diaictx Prafie
M eDercer wr poatgresyl Desar ety pereit gl Dvrcd oy poatgiesgl Disoer .
Bl deertieme By [ [ b
Bt Ingeat_Fide St bedeng et Bockiore . Aumplen et et Bk Store’ Msemplen/ berdeng rest Bocifare’ Ty Vot
M2 UL Hbcpotgresgh! focaot MILD pbcpostgregh erahort M. b postgresghlocbeost ML
121 ec_Servscelingvadable 01 03 03

Expand tibco.bw.sample.binding.rest.Bookstore.application > Package Unit
folder. Provide valid values for the application properties. Provide a valid username,
password and database URL to connect to your PostgreSQL database in the module
properties, if different from the default setting.

Verify your JDBC connection.
a. Fully expand the Resources directory.
b. Double-click JDBCConnectionResource.jdbcResource.
c. In JDBC Driver, click Click Here to Set Preferences.

d. Set the JDBC driver folder directory preference to the folder where you have
downloaded PostgreSQL JDBC Driver as mentioned in the Prerequisites section.
Click Apply and then click OK.

e. Click the Test Connection button to verify the connection.
Click File > Save.
Fully expand the Processes directory and double-click Books.bwp.
Click Run > Debug Configurations.

At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

Click Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to tibco.bw.sample.binding.rest.BookStore.

Click Debug.
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The sample runs in Debug mode. The console window shows engine messages
similar to: Started BW Application
[tibco.bw.sample.binding.rest.BookStore.application:1.0]. The OSGI command to list
REST and Swagger URLs is lrestdoc, which lists the discovery URL: [Application
Name]: tibco.bw.sample.binding.rest.BookStore.application [Discovery Url]:
http://localhost:7777/tibco.bw.sample.binding.rest.BookStore.application.

12. Launch Google Chrome browser and open
http://localhost:7777/tibco.bw.sample.binding.rest.BookStore.application. The Google
Chrome page displays as follows.

tibco.bw.sample.binding.rest.BookStore.application

Books ShowlHide  List Operatiens  Expand Operatices

EBER mookqissn
R reoxisen
Il vookisen

ﬂ Ibeok{ISBNyevents.

o

rosT WG

Maoksbyprico This senvico refuma all the bools whose price ks greater than the amoent spediied

Events ShowlMide  List Oporatisres  Esxpand Openatiors

m levenU{EventiD)
levent{EventiD}
I3 revenuiEvento)
fevants

[Tl evants

101

13. Click on any of the operations, such as POST, GET, PUT, and DELETE displayed on
the web page.

14. After you have finished with the operations on the page, in TIBCO Business Studio for
BusinessWorks, click the Terminatel® icon to stop the process.

Result
The web page lists the following operations for Books and Events:

Books
e Post books

e GET books

TIBCO ActiveMatrix BusinessWorks™ Samples


http://localhost:7777/tibco.bw.sample.binding.rest.BookStore.application

38 | Binding Features

GET book by ISBN

PUT book by ISBN

DELETE book by ISBN

GET book by Price
Events

e POST Events

GET Events

GET Event by EventID

PUT Event by EventID

DELETE Event by EventID

GET books returns an output similar to the following:

{
"Book": [
{
"isbn": "0061122416",
"name": "The Alchemist",
"description": "Every few decades a book is published that changes
the lives of its readers forever. The Alchemist is such a book",
"authorName": "Paul Coelho",
"releaseDate": "2006-04-25",
"vintage": true,
"signed": true,
"price": 11.9
b
{
"isbn": "0071450149",

"name": "The Power to Predict",

"description": "How Real Time Businesses Anticipate Customer
Needs, Create Opportunities, and Beat the Competition",

"authorName": '"Vivek Ranadive",

"releaseDate": "2006-01-26",

"vintage": false,

"signed": true,

"price": 15.999
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GET books by ISBN returns an output similar to the following for the ISBN 0061122416:

{
"Jsbn": "0061122416",
"name": "The Alchemist",
"description": "Every few decades a book is published that changes
the lives of its readers forever. The Alchemist is such a book",
"authorName": "Paul Coelho",

"releaseDate": "2006-04-25",
"vintage": true,

"signed": true,

"price": 11.9

The books. log file is generated with the following information:

POST Books—-——----- >{"Book":[{"isbn":"1451648537","name" :"Steve
Jobs","description":"Biography of Apple Co-Founder Steve
Jobs","authorName":"Walter Isaacson",'"releaseDate":"2012-10-

24" "vintage":false,"signed":false,"price":21},
{"isbn":"0385537859","name" :"Inferno","description":"Robert Langdon
returns in Dan Brown's latest fast paced action
thirller","authorName":"Dan Brown","releaseDate":"2013-05-

14" ,"vintage":false,"signed":true,"price":14.09},
{"isbn":"0399103421" ,"name" :"The Godfather","description":"The Godfather
is an epic story of a New York's top mafia family, loyalty, and how men
of honor 1live in their own world, and die by their own
laws.","authorName":"Mario Puzo","releaseDate":"1969-03-
10","vintage":true,"signed":true,"price":5
0}]}**************************************************************

GET Books—--——---- >{"Book":[{"isbn":"1451648537","name" :"Steve
Jobs","description":"Biography of Apple Co-Founder Steve
Jobs","authorName":"Walter Isaacson",'"releaseDate":"2012-10-
24+05:30","vintage":false,"signed": false,"price":21},
{"4isbn":"0385537859","name" :"Inferno","description":"Robert Langdon
returns in Dan Brown's latest fast paced action
thirller","authorName":"Dan Brown","releaseDate":"2013-05-
14+05:30","vintage":false,"signed":true,"price":14.09},
{"isbn":"0399103421","name" :"The Godfather","description":"The Godfather
is an epic story of a New York's top mafia family, loyalty, and how men
of honor live in their own world, and die by their own
laws.","authorName":"Mario Puzo","releaseDate":"1969-03-
10+05:30","vintage":true,"signed":true,"price":5
G}]}**************************************************************
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GET Book By ISBN------- >{"4isbn":"1451648537","name" :"Steve
Jobs","description":"Biography of Apple Co-Founder Steve
Jobs","authorName":"Walter Isaacson","releaseDate":"2012-10-
24+05:30","vintage":false,"signed":false,"price":2
l}**************************************************************

DELETE Book By ISBN-------- >"Deleted book with ISBN -

145164853
AR R T R R L R S R S S S S L L T T T

GET Events By ISBN---->
{}**************************************************************

GET Books By Price More than 10---->{"Book":
[{"isbn":"0385537859","name" :"Inferno","description":"Robert Langdon
returns in Dan Brown's latest fast paced action
thirller","authorName":"Dan Brown","releaseDate":"2013-05-
14+05:30","vintage":false,"signed":true,"price":14.09},
{"isbn":"0399103421","name" :"The Godfather","description":"The Godfather
is an epic story of a New York's top mafia family, loyalty, and how men
of honor 1live in their own world, and die by their own
laws.","authorName":"Mario Puzo","releaseDate":"1969-03-
10+05:30","vintage":true,"signed":true,"price":50},
{"4isbn":"0385537829","name" :"Angels and Demons","description":"Robert
Langdon returns in Dan Brown's fast paced action
thirller","authorName":"Dan Brown","releaseDate":"2013-05-
14+05:30","vintage":false,"signed":true,"price":15.09},
{"isbn":"0399103439","name":"The Godfatherl","description":"The
Godfather is an epic story of a New York's top mafia family, loyalty,
and how men of honor live 1in their own world, and die by their own
laws.","authorName":"Mario Puzo","releaseDate":"1969-03-
10+05:30","vintage":true,"signed":true,"price":5
O}]}**************************************************************

GET Books By Price More than 50---->{"Book":
[NUTTLT J 5k ok ok ok sk ok sk ok ok sk ok ok ok ok ok ok ok ok ok ok ok ok ok ok ok ok ok ok ok ok ok ok ok ok ok ok ok ok ok ok ok ok ok ok ok ok ok ok ok ok ok ok ok ok ok ok ok ok ok ok ok

Understanding the Configuration

The project contains three processes: Books, Events, Invoke_Client, RESTInvoke.bwp and
two subprocesses; BooksDB and EventsDB.

Books Process: In this process, the Book REST service performs the post, get, put, delete
operations. It posts one or more books to the bookstore and retrieves all the books from
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the bookstore. For the post operation, a sub process is called to add books to the
database. The addBooks operation is implemented in the BooksDB subprocess. The Book
REST service performs three operations: getting a book from the bookstore by ISBN,
updating a book in the bookstore using ISBN, and deleting a specific book from the
bookstore using ISBN. ISBN is passed as a parameter to these operations. The
booksbyprice service gets books from the bookstore using price, which is passed as a query
parameter to the GET operation. This service responds with an array of Books if there are
books whose price is greater than the provided input (price). If there are no such books,
the service returns a Null array.

tibcoubw. sam ple.binding.rest bookstore. Books
& — Ll TR
| =} 2] Books/post = Service
(® Books/get | wE= = 2] addBooks
; . o 2] gethliBooks
a 2] getBackBylSaN
ey
@ ] t) 2] updateBook
getliBooks 2] deleteBaok
2] getRecentBooks
2] getBooksByPrice
2] get 2] getillEvents
o 7] addEvents
booksbyprice é : : 7] getEventBylD
"’]9!1—] — [} Exception [+l } : 7] updateEvent
- \
T %] Book/get =) ] deletebvent
= 2] Book/put =) Z] getEventByISBN
[ Z 2] Book/delets &)
| & 2] Bookl/get )
| | 2] booksbypricerget (Y]

BooksDB Subprocess: The subprocess handles deletes, updates, retrievals of books from
the database. The BooksPersist service implements the following operations: adding books
to database, getting all books from database, getting a book by ISBN, updating a book by
ISBN, deleting a book by ISBN and getting a book by price. Using BooksPersist/addBooks,
books are added to the database.
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E t'b_rk_'_ la imolie _=_I.n_' Ak B I_m
=)
=2 0 . s
BooksPersist P =
| acddBooks ®
2] getAllBooks ® S
2] getBackBylSBN ® 0
2] updateBaok ™
2] deleteBaok ®
2] getRecentBooks @ adelBocksOut
2] getBooksByPrice 2
[ % %] BooksPersist/getAliBooks &)
(= 7] BooksPersist/getBookByISEN [+
| 5 2] BooksPersist/updateBook [#)
[ 7} 2] BacksPersist/deleteBank =)
(= ® BaoksPersist/getRecentBooks )
{ =1 2] BooksPersistigetBooksByPrice )

Events Process: It is similar to the Books process and is used to add, delete, update, and
retrieve events.

‘b bw sample b
& o
2| Bventy/post o] =
=
8 8
‘ addivents ottt o
|l Escecbor ®}
_.'-_ 2] Everits/get h:J_
W 2] Brtigat 5]
& 2] Eventipat &
= 2] Bvenitidelete 152

EventsDB Process: It is similar to the BooksDB process and is used to add, delete, update,
and retrieve events from the database.
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m tibco. bw.sample binding.rest bockstore. db EventsDE
FrentsPert 2] EventsPersist/getAlEvents ol =

2] getAllEvents a -

2] sddEvents o B .

#] getEvenaByiD o a o

2] updateEvent a getAllEvents getANEventsOut

2] deletebvent ®

£] getEventBy 15BN o
:-'-'.' 2] EventsPersist/addEvents qﬂ:
& 2] BventsPersist/getEventBylD |52
E B EventsPersist/updatebvent =
A #] EventsPersist/deleteEvent =
% 2] EventsPersist/getEventByiSEN &2

Invoke_Client Process: This is a REST Client process which uses Invoke REST API activity
to retrieve data from the REST Server. It is similar to Swagger Ul. Using this process, you
can POST, GET, PUT, and DELETE books by specifying the HTTP Client, Resource Path,
HTTP Method, Request Type, and Response Type in the Invoke REST API activity.

For example, in POST_Books, we provide HTTP Client Resource which listens to the same
host and port as that of server. The Resource Path is "/books", HTTP Method is "POST",
and Request and Response type is JSON. In the Message Body, we provide the JSON

payload which is read from the file

present at BW_

HOME\samples\binding\rest\BookStore\samplejson\books.json. This posts books from
the books.json payload into the database and you can view the data posted into the

output file.
[1m] tiboo b Cliend
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RESTInvoke Process: This is a REST Client process which uses the REST Invoke activity to
retrieve data from the REST Server. In addition to invoking the existing services, it invokes
the service getBooksByPrice which demonstrates null and array responses.

E fibco.bw.s ample binding rest bookstore Restinvoke
| 2 0
"8
s EED o | D 2] post
— R —B— B—= = Som
" ; G 52 . al
Timer Sleep ReadFile Parse]SON POST_Books RenderJSON Wnt[Fale 'amok T
: - i abook—ISBN-evenrs
1=k Y XML En
B2 B "
) =] | ison | z
ReadFila1 WriteFile2 RenderJSONZ  GET_Book_By_ISBN  WiriteFile1 RenderJSON1 GET_Books Y
abooksbypnce
: (2 get )
N * ;:; »  u » - —_— —_—
oo ] | v i £
ParseJSON1 PUT_Book_By_ISEN  RenderJSON3 WriteFile3 DELETE_Book_BYy_IS WriteFiled GET_EmnI_By_ISBN
BM
N | 'l = u
=0 (B e B0 | | Jzon |
Rended'SOMNE GET_Books By_Price_M  \WriteFile6 Render]SONS GET_Books By Price_ M WriteFile5 RenderJSON4
oreThan 30 oreThan 10
‘WiriteFile?
| bleshooti

If you are unable to insert rows into the database using the dbsetup.sql script in the
scripts folder, use the sample json payload from the samplejson folder to post the
data.

If you do not see the REST Swagger API page, verify whether the application has
started.

If you see any problem markers in the project, clean the project by invoking Project
> Clean or try switching to a clean new workspace.

If you get any File was not found exception, verify whether books.json and book_
put.json file is present at the location as specified in the Input_File and Input_File_
1 Module Property.

If you get an error about unregistered user, open the pgAdmin Ul and select all check
boxes under the Role Privileges tab for the bwuser.
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-- DROP ROLE bwuser;

CREATE ROLE bwuser LOGIN
ENCRYPTED PASSWORD 'md552d2e758923202£8d82faefbedfcidbs’
NOSUPERUSER INHERIT NOCREATEDB NOCREATEROLE:

Implementing a REST Service Using a JSON File
with "allOf" Keyword

This REST sample shows how to use the OpenAPISpecification 3.0 JSON file with "allOf"

keyword to create a RESTful service for adding, updating, and retrieving pets data from a
pet store.

The sample uses the following HTTP methods for the Pets REST resource:
e GET: Get details of dog from the petstore
e PATCH: Update dog data to the petstore
e POST: Add cat details to the petstore

Implementing a REST Service Using a JSON File with "allOf" Keyword:

Before you begin
Install the latest version of the Google Chrome browser on your system.
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Note: If you are accessing the sample from the Welcome page of TIBCO Business
Studio for BusinessWorks, navigate to Step 3 directly.

Procedure

1.

In the samples directory, select binding > rest > allOf and double-click
tibco.bw.sample.binding.rest.allOf. For more information, see the Accessing
Samples section.

In the Project Explorer, expand the tibco.bw.sample.binding.rest.allOf project.

Set the default application profile to match the operating system you are using. For
more information, see Setting the Default Application Profile.

Fully expand the Processes directory and double-click Pets_Service.bwp.
Click Run > Debug Configurations.

At the left side pane of the Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

Click the Applications tab and then click the Deselect All button, if you have
multiple applications. Select the check box next to
tibco.bw.sample.binding.rest.allOf.application.

Click Debug. This executes the sample in the debug mode.

The console window shows engine messages similar to:

Started BW Application
[tibco.bw.sample.binding.rest.allOf.application:1.0].

The OSGI command to list REST and Swagger URLs is lrestdoc, which lists the
following discovery URL:

[Application Name]:
tibco.bw.sample.binding.rest.allOf.applicationl.o

[Discovery Url]: http://bwin2kl6-
67:7777/tibco.bw.sample.binding.rest.allOf.application

Launch the Google Chrome browser and open http://bwin2k16-
67:7777/tibco.bw.sample.binding.rest.allOf.application.
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The Swagger API Page displays as follows:

http:/fbwin2k16-87.7777/tibco.bw.sample.binding.rest allOf.application/swagger json

tibco.bw.sample.binding.rest.allOf.application ® “*

P k16-6 co.bw.sample binding rest allOf.application/swagger json

[ http:/lbwin2k16-67.apac.tibco.com:6574

PetDogs ~
E /petDogs getResource o
/petDogs patchResource o
|2+ B8 /petCats postResource <
Schemas ~
Dog »
Cat »

10. Click any of the operations, such as GET, PATCH or POST, displayed on the web page.

11. After completing the operations on the page, in TIBCO Business Studio for
BusinessWorks, click the Terminate icon (®l) to stop the application.

Result
The web page lists the following operations for dogs and cats:
PetDogs

e GET dog details
* PATCH dog details

PetCats
e POST cat details

GET dogs returns an output similar to the following :

{"4id":10,"name" :"Oreo" ,"status":"Available","bark":false,"breed":"Husk
y"}

POST cats returns an output similar to the following:
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{"4id":110,"name" :"Kitty","status":"Sold","hunts":true,"age":"12"}

The PetData.log file generated with the following information:

***********Output of Pets Datax*xxxxkxkkxxx*

GET Dog having allOof Pet-->
{"4id":10,"name" :"Oreo" ,"status":"Available","bark":false,"breed":"Husk
y"}**************************************************************

PATCH Dog having allOf Pet-->
{"i1d":20,"name" :"Jasper","status":"Sold","bark":true,"breed":"Shepher
d"}**************************************************************

POST Cat having allOf Pet-->
{"4id":110,"name" :"Kitty","status":"Sold","hunts":true,"age":1
2}**************************************************************

Understanding the Configuration
The project contains two processes, Pets_Service.bwp and Client.bwp.

Pets_Service Process: In this process, the Pets REST service performs the post, get, and
patch operations. It updates details of a dog to the petstore and retrieves the dog details
from the petstore. The cat details are added using the post operation. This service is
created using the Petstore_allOf.json file. The file has Dog, Cat, and Pet objects. The Dog
and Cat objects use the "allOf" keyword to combine the main 'Pet' schema with 'Dog-
specific' and 'Cat-specific' properties respectively.
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Client Process: This is a REST Client process, which uses the REST Invoke activity to
retrieve data from the REST Server.
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Troubleshooting

 If you do not see the REST Swagger API page, verify whether the application has
started.

* If you see any problem markers in the project, clean the project by clicking Project >
Clean or try switching to a clean new workspace.

Implementing a REST Service Using a JSON File
with "anyOf" Keyword

This REST sample shows how to use the OpenAPISpecification 3.0 JSON file with "anyOf"
keyword to create a RESTful service for adding pets data from a pet store.

The sample uses the following HTTP POST method for the Pets REST resource:

Before you begin
Install the latest version of the Google Chrome browser on your system.

Note: If you are accessing the sample from the Welcome page of TIBCO Business
Studio for BusinessWorks, navigate to Step 3 directly.

Procedure

1. In the samples directory, select binding > rest > anyOf and double-click
tibco.bw.sample.binding.rest.anyOf. For more information, see the Accessing
Samples section.

2. In the Project Explorer, expand the tibco.bw.sample.binding.rest.anyOf project.

3. Set the default application profile to match the operating system you are using. For
more information, see Setting the Default Application Profile.

4. Fully expand the Processes directory and double-click PetsService.bwp.
5. Click Run > Debug Configurations.

6. At the left side pane of the Debug Configuration wizard, expand BusinessWorks
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Application and select BWApplication.

7. Click the Applications tab and then click the Deselect All button, if you have
multiple applications. Select the check box next to
tibco.bw.sample.binding.rest.anyOf.application.

8. Click Debug. This executes the sample in the debug mode.

The console window shows engine messages similar to:

Started BW Application
[tibco.bw.sample.binding.rest.anyOf.application:1.0].

The OSGI command to list REST and Swagger URLs is lrestdoc, which lists the
following discovery URL:

[Application Name]:
tibco.bw.sample.binding.rest.anyOf.applicationl.0

[Discovery Url]: http://bwin2kl6-
67:7777/tibco.bw.sample.binding.rest.any0f.application

9. Launch the Google Chrome browser and open http://bwin2k16-
67:7777/tibco.bw.sample.binding.rest.anyOf.application.

The Swagger API Page displays as follows:

NUPIIOCAINOSLEST4 v

Pets-allPets S~

m fpets/allPets paictResource ~
Schemas ~
Pet »
Dog »

Cat »
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10. Click any of the operations, such as GET, PATCH or POST, displayed on the web page.

11. After completing the operations on the page, in TIBCO Business Studio for
BusinessWorks, click the Terminate icon (®l) to stop the application.

Result

The web page lists the following operations for dogs and cats:
Pets-allPets

e POST pets details

POST pets return an output similar to the following :

{"name": "Oliver","bark": true,"breed": "Shepherd","id": "CTOO1","age":

6}

The PetData.log file generated with the following information:

xxkkxkxkkkxkk0Uutput of Pets Dataxk xxkkkxkkk

POST having anyOf Pet> {"anyOf_Dog":
{"name":"0Oliver","bark":true,"breed":"Husky"},"anyOf_Cat":
{"id":"CTO014","age":4}}

AR KA AR KA AR A A AR AR AR A AR A A A A A A kA hAk A kA Ak Ak Ak hkhkkhkhkkkhkhkkkhkhkkkhhkkkhkhkhkkkhhxk

Understanding the Configuration
The project contains two processes, PetsService.bwp and Client.bwp.

PetsService Process: In this process, the Pets REST service performs the post operation. It
adds the details of pets to the petstore and responds with the Pets details. This service is
created using the Petstore_anyOf.json file. The file has Dog, Cat, and Pet objects. The Pet
objects use the "anyOf " keyword to validate against either the 'Dog' or the 'Cat' schema or
both the schemas depending on the configuration provided on the Input tab of the postOut
(reply) activity.
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Client Process: This is a REST Client process, which uses the REST Invoke activity to call
the REST Server. The request can contain a combination of properties which are valid
against either one or both the Dog and Cat sub-schemas.
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Troubleshooting

 If you do not see the REST Swagger API page, verify whether the application has
started.

* If you see any problem markers in the project, clean the project by clicking Project >
Clean or try switching to a clean new workspace.

Implementing a REST Service Using a JSON File
with "oneOf'" Keyword

This REST sample shows how to use the OpenAPISpecification 3.0 JSON file with "oneOf"
keyword to create a RESTful service for updating pets data from a pet store.

The sample uses the HTTP PATCH method for the Pets REST resource.

Before you begin
Install the latest version of the Google Chrome browser on your system.

Note: If you are accessing the sample from the Welcome page of TIBCO Business
Studio for BusinessWorks, navigate to Step 3 directly.

Procedure

1. In the samples directory, select binding > rest > oneOf and double-click
tibco.bw.sample.binding.rest.oneOf. For more information, see the Accessing
Samples section.

2. In the Project Explorer, expand the tibco.bw.sample.binding.rest.oneOf project.

3. Set the default application profile to match the operating system you are using. For
more information, see Setting the Default Application Profile.

4. Fully expand the Processes directory and double-click PetsService.bwp.
5. Click Run > Debug Configurations.

6. At the left side pane of the Debug Configuration wizard, expand BusinessWorks
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Application and select BWApplication.

7. Click the Applications tab and then click the Deselect All button, if you have
multiple applications. Select the check box next to
tibco.bw.sample.binding.rest.oneOf.application.

8. Click Debug. This executes the sample in the debug mode.

The console window shows engine messages similar to:

Started BW Application
[tibco.bw.sample.binding.rest.oneOf.application:1.0].

The OSGI command to list REST and Swagger URLs is lrestdoc, which lists the
following discovery URL:

[Application Name]:
tibco.bw.sample.binding.rest.one0f.applicationl.0

[Discovery Url]: http://bwin2kl6-
67:7777/tibco.bw.sample.binding.rest.one0f.application

9. Launch the Google Chrome browser and open http://bwin2k16-
67:7777/tibco.bw.sample.binding.rest.one0f.application.

The Swagger API Page displays as follows:
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tibco.bw.sample.binding.rest.oneOf.application ® <

httpillecalhostesTd  «

Pets -~

pets patchRasouca >

Schemas -~

Pat 3

Dog >

Cat >

10. Click on the PATCH operation displayed on the web page.

11. After completing the operations on the page, in TIBCO Business Studio for
BusinessWorks, click the Terminate icon (®l) to stop the application.

Result

The web page lists the following operations for dogs and cats:
Pets

o PATCH pets details

PATCH pets return an output similar to the following

{"name" :"Rusty","bark":true,"breed":"Shepherd"}

The PetData.log file generated with the following information:

***********Output of Pets Datax*xxxxkxkkxxx%

PATCH Pet having oneOf-->

{"oneOf_Dog":

{"name" :"Rusty","bark":true,"breed":"Shepher
d"}}**************************************************************
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x%kkKkKkkkxxxx0utput of Pets Dataxxxxxkkkkkx

PATCH Pet having oneOf-->

{"oneOf_Cat":
{"id":"CTO11","hunts":false,"age":
3}}**************************************************************

Understanding the Configuration

The project contains two processes, PetsService.bwp and Client.bwp.

PetsService Process: In this process, the Pets REST service performs the patch operation.
It updates the details of the pet to the petstore and retrieves the dog details from the
petstore. This service is created using the Petstore_oneOf.json file. The file has Dog, Cat,
and Pet objects. The Pet objects use the "oneOf "' keyword to validate against either the
'Dog' or the 'Cat' schema depending on the condition provided on the Input tab of the
patchOut (reply) activity.
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Input Editor
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tihen hw camnle hindina_rest nnenf PetService
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p #l pets/patch
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XPath Expression

$patchfitem/tns1:Pet/tns1:0neQf_Dog

$patch/itemy/tns1:Pet/tns1:aneOf Cat

Client Process:This is a REST Client process, which uses the REST Invoke activity to call
the REST Server.

Process contains a ForEach loop to demonstrate that the change in the mapping to input
schemas (Either Dog Or Cat) will affect the response received from the server.
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The first iteration of the loop will send the input which is of Type Dog. The second iteration
of the loop will send the input of type Cat.

=] tihco.bw.samnle hindina.rest.aneof Client |

ﬁ ets
2l patch

=al [
R ]

jﬁ " F }

patch Render)]SON WriteFile

S

Timer AT

Troubleshooting

 If you do not see the REST Swagger API page, verify whether the application has
started.

* If you see any problem markers in the project, clean the project by clicking Project >
Clean or try switching to a clean new workspace.

Implementing Multiple Response based
REST Service using a JSON file

This REST Sample shows how to use the OAS 3.0 JSON file to create a RESTful service
which has operations configured with multiple responses.

The sample uses the POST HTTP method for the REST resource.

Before you begin
Install the latest version of the Google Chrome verison in the standard default location
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Note: If you are accessing the sample from the Welcome page of TIBCO Business
Studio for BusinessWorks, navigate to Step 3 directly.

Procedure

1.

9.

In the samples directory, select binding > rest > MultipleResponse and double-click
tibco.bw.sample.binding.rest.MultipleResponse. For more information, see the
Accessing Samples section.

In the Project Explorer, expand the tibco.bw.sample.binding.rest.MultipleResponse
project.

Set the default application profile to match the operating system you are using. For
more information, see Setting the Default Application Profile.

Fully expand the Processes directory and double-click Service.bwp.
Click Run > Debug Configurations.

At the left side pane of the Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

Click the Applications tab and then click the Deselect All button, if you have
multiple applications. Select the check box next to
tibco.bw.sample.binding.rest.MultipleResponse.application.

Click Debug. This executes the sample in the debug mode.

The console window shows engine messages similar to:

Started BW Application
[tibco.bw.sample.binding.rest.MultipleResponse.application:1.0].

The OSGI command to list REST and Swagger URLs is lrestdoc, which lists the
following discovery URL:

[Application Name]:
tibco.bw.sample.binding.rest.MultipleResponse.applicationl.®

[Discovery Url]: http://TIBCO-
PF372WXP:7777/tibco.bw.sample.binding.rest.MultipleResponse.applica
tion

Launch the Google Chrome browser and open http://TIBCO-
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PF372WXP:7777/tibco.bw.sample.binding.rest.MultipleResponse.application..

The Swagger API Page displays as follows:

bin_file

Responses

503

Sample Description

. Choose File | No file chosen
nary)

string($bil

Send empty value

Descri iption Links

No links
Sample Description

Media type

image/jpeg v

image/jpeg

No links
Sample Description

Media type
application/xml ~

Example Value | Schema

No links

10. Click on the POST operation displayed on the web page.

11. After completing the operations on the page, in TIBCO Business Studio for
BusinessWorks, click the Terminate icon (®l) to stop the application.

Result

The web page lists the following response Media Types for POST operation:

e 200 Status Code with an image/jpeg and text/plain format.

e 400 Status Code with application/xml format.

» 503 Status Code with application/json format.

We have to select the Response Media Type from the dropdown for the 200 status code.

On selecting image/jpeg, we can receive the image file which was sent in the request as a
form parameter. The Image file will be displayed in Swagger Ul.

On selecting text/plain, we receive a string response similar to the following :

Successful

response with simple string
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For fault status codes, we have to use the Postman client, since the Accept headers can be
controlled only by the 200 response media types in the Swagger Ul.

In Postman we can pass the Accept header value corresponding to the content-type which
we are expecting in response. In our sample, if we want to receive a response in XML
format, we can pass the Accept header value as application/xml or application/json for
JSON format.

« For application/json Accept header we receive a response similar to the following :

{"msgCode" :503,"message":"Replying with custom fault as file not
found."}

« For application/xml Accept header we receive a response similar to the following :

<client-400-application-xml>Sending 400 fault as file not
found.</client-400-application-xml>

The output.log file is generated with the following information :

*xkkkkkxkkxMultiple Response OQutputxxkxkxkxkx

Output of POST with text/plain Content-Type --> Successful response with
simple str'ing************

Caught 503 fault with application/json Content-Type —-->
{"msgCode":503,"message" :"Replying with custom fault as file not
found. "} xxkkxkkxkkxk

Caught 400 fault with application/xml Content-Type --> Sending 400 fault
as file not found.**xxxx**k*x*

Understanding the Configuration
The project contains two processes: Service and Client.bwp.

Service Process : In this process, the REST service performs the post operation. It uploads
an image file and fetches it in response for image/jpeg content-type. This service is created
using the MultipleResponse_Swagger.json file. The response to be sent to the client is
decided if the condition on Transition is satisfied. The condition checks the Accept header
sent by the client. If it matches image/jpeg or text/plain then service responds with the 200
status code. If this condition is not satisfied i.e we pass application/json or application/xml
Accept header, then the invalid file is not found and the corresponding fault reply is sent
from the Catch block based on transition check for Accept header.
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Client Process : This is a REST Client process which uses the REST Invoke activity to
retrieve data from the REST Server. An image file is uploaded using the form parameter
and the Accept header value is changed on each iteration of the For Each loop. The Accept
header takes the value from the loop Variables. Once the 503 fault is caught in the Catch
block, we have an Invoke which passes the application/xml Accept header and its
corresponding 400 fault is caught by another Catch block.
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Troubleshooting

 If you do not see the REST Swagger API page, verify whether the application has
started.

* If you see any problem markers in the project, clean the project by clicking Project >
Clean or try switching to a clean new workspace.

 If you get any File was not found exception, verify whether the input_image.jpg file
is present at the location as described in the Input_file Module Property.

Using a SOAP Web Service to Make a Query to a
Bookstore

Using a SOAP binding, a web service WSDL operation queries for information from a data
source. The web service has one operation, GetBooksByAuthor, that is implemented in the
process, QueryBooksByAuthorProvider. At run-time, a request containing an author name
returns details about the author's books.

Before you begin
Copy the BookStore.xml file to C:\tmp location.

Procedure
1. In the samples directory, select binding > soap > http > BookStore and double-
click tibco.bw.sample.binding.soap.http.BookStore. For more information, see
Accessing Samples.

2. In Project Explorer, expand the tibco.bw.sample.binding.soap.http.BookStore
project.

3. Fully expand the Processes directory and double-click
QueryBooksByAuthorProvider.bwp.

4. Click Run > Debug Configurations.

5. At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

6. Click the Applications tab and then click the Deselect All button if you have multiple
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applications.

7. Select the check box next to
tibco.bw.sample.binding.soap.http.BookStore.BookStore.application.

8. Click Debug.

This executes the sample in Debug mode.

9. Click the Terminatel®l icon to stop the process.

Result
The query sends a request for "Vivek Ranadive" and returns the following book details:

17:58:24.807 [PVM:In-Memory STWorkProcessor:2] INFO c.t.b.g.L.t.b.b.s.h.BookStore.Log -
Message=Book Title: The Power of Now, Author is Vivek Ranadive, Date: 1999, ISBN 0-06-
566778-9, Publisher is Tibco Software Inc

Understanding the Configuration

The following processes are defined in the project:

» BookStoreServiceClient.bwp: The process implements the GetBooksByAuthor
operation using BooksInterface.wsdl, and then invokes the
QueryBooksByAuthorProvider process. The reply containing the query results is made
by mapping to the output of the Query service. A Timer activity triggers the client
and then triggers a SOAP Invoke activity, which is the actual web service client.

* QueryBooksByAuthorProvider.bwp: The process definition representing the
service's business logic. The service Receive activity implements the
GetBooksByAuthor operation based on the BooksInterface.wsdl file. The Read File
activity reads the bookstore (an XML file in this sample).

o Note: The file must be on the machine that is used to run the sample.

The Parse XML activity then parses the XML document. Finally, the filter is executed
at the end of the process flow in the Reply (see Reply activity's Input tab).

The following resources are defined in the project:
* Resources\BookStore.xml. The file representing the bookstore database.

e HTTPConnector.httpConnResource: The HTTP shared resource to use. If you want
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the web service to access a different host machine or port, edit the Host and Port
properties, and then regenerate the concrete WSDL from the component binding.

For more information, see TIBCO ActiveMatrix BusinessWorks™ Application
Development.

The following schemas and service descriptors are defined in the project:

* Schemas\Books.xsd: The schema file containing the type definitions used by the
web service interface.

e Service Descriptors\BooksService.wsdl: The WSDL file that describes the
Bookstore web service.

Reconfiguring a Web Service by Changing the
Transport

This sample documentation describes the way to convert a transport for a Web Service

Before you begin
TIBCO Enterprise Message Service™ must be running.

Sample Description
Converting a transport for a Web Service:
e From SOAP over HTTP to SOAP over JMS

e From SOAP over JMS to SOAP over HTTP
For more information, see Accessing Samples.

Before performing the following steps, import the SOAP over HTTP
ZipCodeServiceProvider.zip project from the File Explorer view by double-clicking the
project zip file in TIBCO Business Studio™ for BusinessWorks™.

Converting the Transport from SOAP over HTTP to SOAP over JMS

Procedure
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10.

11.

12.
13.

14.
15.

Create and configure a JMS Connection shared configuration resource.
Navigate to the Module Descriptors > Components tab and select ZipPort service.

Click the Bindings tab, and in the Transport Configuration section, change the
Transport Type from HTTP to JMS.

Create the JMS Connection shared resource with default or custom values using the
JMS Connection wizard after changing the Transport Type to JMS.

Change the Messaging Style to Queue in the JMS Connection shared resource.
Create JNDI Configuration shared resource with default or custom values.
Test the connection using the Test Connection button.

Click Bindings > Transport Configuration and specify the JMS Destination value as
queue.sample Or a custom queue name.

In the TIBCO Enterprise Message Service server, create a queue with queue.sample
name, if a queue was not created earlier, using the TIBCO Enterprise Message Service
Administration option.

Click the Generate Concrete WSDL for SOAPServiceBinding binding link in the
Binding configuration. Use the Generate WSDL wizard to generate a new concrete
WSDL.

Delete the previous concrete WSDL, to avoid WSDL cache exceptions, located under
Service Descriptors > Special Folders that contains HTTP transport details.

Specify the folder location where you want to generate the concrete WSDL file.

Clear the Embed options (Abstract WSDL and Schema) check boxes, if both Service
and Client are under the same project module.

Click OK in the WSDL generated successfully confirmation dialog box.

Click Transport Connection to test the connection status.

Result
The Client and Server are executed.
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Converting the Transport from SOAP over JMS
to SOAP over HTTP

Before performing the following steps, import the ZipCodeLookup.zip project from the File
Explorer view by double-clicking the project zip in TIBCO Business Studio for
BusinessWorks.

Procedure
1. Create an HTTP Connection shared configuration resource, and configure the HTTP
Host and Port details.
2. Navigate to the Module Descriptors > Components tab and select ZipPort service.
3. Click the Bindings tab, and in the Transport Configuration section, change the
Transport Type from JMS to HTTP.
4. Create the HTTP Connection shared resource with default or custom values using the
HTTP Connection wizard after changing the Transport Type to HTTP.
5. Click the Generate WSDL for SOAPReferenceBinding binding link in the Binding
configuration. Use the Generate WSDL wizard to generate a new concrete WSDL.
6. Clear the Embed options (Abstract WSDL and Schema) check boxes, if both Service
and Client are under same project module.
If required, overwrite with the existing Client concrete WSDL file.
7. Click OK in the WSDL generated successfully confirmation dialog box.
8. Navigate to Module Descriptors > Components tab and select ZipPort Reference.
9. Delete the previous SOAPReferenceBinding configured with JMS transport.
10. Optionally, configure the HTTP Client shared resource to override the custom
configurations.
11. To avoid WSDL cache exceptions, delete the previous concrete WSDL located under

Service Descriptors > Special Folders that contains JMS transport details.

Important: If the previous concrete WSDL is not removed or deleted, you see
two portTypes. Choose the default selected portType, which is HTTP.
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Note: If you are using Context mappings on Client binding, you must reconfigure
the Context mappings.

Result: The Client and Server are executed successfully.

Using a SOAP Connection to Publish Messages
to Multiple Endpoints

This sample shows how to publish messages to multiple endpoints over HTTP and JMS.

Before you begin
TIBCO Enterprise Message Service must be running.

Procedure
1. In the samples directory, select binding > soap > http > HTTPJMSMultiEndpoint
and double-click tibco.bw.sample.binding.soap.http.HTTPJMSMultiEndpoint. For
more information, see Accessing Samples.

2. In Project Explorer expand the
tibco.bw.sample.binding.soap.http.HTTPJMSMultiEndpoint project.

3. Verify your TIBCO Enterprise Message Service connection. To verify:

a. Fully expand the Resources directory.

b. Double-click JMSConnectionResource.jmsConnResource.

c. Click the Test Connection button to verify the connection.
4. Fully expand the Processes directory and double-click TestService.bwp.
5. Click Run > Debug Configurations.

6. At the left hand tree of the Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

7. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.binding.soap.http.HTTPJMSMultiEndpoint.application.
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8.
9. Click Debug.
This executes the sample in Debug mode.

10. Click the Terminatel® icon to stop the process.

Result
The file provided for the OUTPUT_FILE property is written with the following content:

JMS : Output of getCitylnfo : 61801 Urbana Illinois Urbana, Illinois, United States 40.11
88.207

JMS : Output of getCityDistance : Distance between two cities is : 4 miles. 61801 61820
Urbana Champaign Illinois Illinois Urbana, Illinois, United States Champaign, Illinois, United
States

HTTP : Output of getCitylnfo : 61801 Urbana Illinois Urbana, Illinois, United States 40.11
88.207

HTTP : Output of getCityDistance : Distance between two cities is : 4 miles. 61801 61820
Urbana Champaign Illinois Illinois Urbana, Illinois, United States Champaign, Illinois, United
States

Sending and Receiving a SOAP Bound
Attachment

A client process sends Text and GIF files as attachments for the In-Band attachments to the
server process. The server process receives these attachments, and returns them as its
response. The client process captures the sent and received attachments' size.

o Note: It is a Bound Attachment when one part of the Input or Output WSDL
message is of type "base64binary" and that part is mapped with an attachment.
In a concrete WSDL, the attachment is described as a mime part of the Multipart
message.

TIBCO ActiveMatrix BusinessWorks™ Samples



70 | Binding Features

Before you begin

Copy the Attachment.txt and tibcologo.gif files from TIBCO_
HOME\bwx\n.n\samples\binding\soap\http\BoundAttachments to the directory specified
for the AttachmentBaseDir property.

Procedure

1.

In the samples directory, select binding > soap > HTTP > BoundAttachments and
double-click tibco.bw.sample.binding.soap.http.BoundAttachments. For more
information, see Accessing Samples.

2. In Project Explorer expand the
tibco.bw.sample.binding.soap.http.BoundAttachments project.

3. Fully expand the Processes directory and double-click ClientProcess.bwp.

4. Click Run > Debug Configurations.

5. At the left hand tree of the Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

6. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.binding.soap.http.BoundAttachments.application.

7. Click Debug.

This executes the sample in Debug mode.

8. In TIBCO Business Studio™ for BusinessWorks™, click the Terminatel®| icon to stop

the process.
Result

Sent binary file size : 2878 bytes. Received binary file size : 2878 bytes. Sent text file size :
35 Received text file size : 35

Understanding the Configuration

The ServerProcess implements the getsetAttachments operation. It receives the Client
request that has WSDL message parts defined as base64Binary type and has Binary and
Text attachments. Service reply mechanism sends back the same attachments to the
ClientProcess.
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The ClientProcess invokes the ServerProcess with input attachments (Binary and Text).
Consumer (Client) reads the input files and sends them to Producer (Server)process.
Attachments received from Server are written to the disk on the Client side.

Finally, the Sent and Received file size information for Binary and Text attachments is
written at the location specified in OUTPUT_FILE module property.

These attachments' size matches and also depicts that attachments can be sent or
received between the Producer and Consumer where they are defined as part of the WSDL
definition.

Interoperability of Using JAX-WS Client to
Invoke Service

This example illustrates the interoperability of using JAX-WS client to invoke service
exposed on TIBCO ActiveMatrix BusinessWorks™.

Before you begin

Copy the jaxws_sample.wsdl from TIBCO_
HOME\bw\n.n\samples\binding\soap\http\JAXWSInterop to the directory specified for
“CONCRETE_WSDL_LOCATION_URL” property.

Procedure

1. In the samples directory, select binding > soap > http > JAXWSInterop and double-
click tibco.bw.sample.binding.soap.http.JAXWSInterop. For more information, see
Accessing Samples.

2. In the Project Explorer, expand tibco.bw.sample.binding.soap.http.JAXWSInterop
project.

3. Fully expand the Processes directory and double-click Client.bwp.

4. Place the jaxws_sample.wsdl at the location of Module Property value “CONCRETE_
WSDL_LOCATION_URL”.

5. Click Run > Debug Configurations.

6. At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.
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7. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to tibco.bw.sample.binding.soap.http.
JAXWSInterop.application.

8. Click Debug.

This executes the sample in Debug mode.

9. In TIBCO Business Studio™ for BusinessWorks™, click the Terminate icon to stop
the process.

Result
The result shows the following response in the console:

Response for : Sending JAX-WS client request...

Understanding the Configuration

The sample consists of two processes:
 tibco.bw.sample.binding.soap.http.jaxwsinterop.Client
e tibco.bw.sample.binding.soap.http.jaxwsinterop.ServerProcess

Service process exposes an operation to accept an input string and returns string as part of
response.

Client process uses a concrete WSDL generated from service to send a request with input
parameters and then writes the response to file.

Client process uses a Java Invoke activity that passes the concrete WSDL location to the
Java invoke (tibco.bw.sample.binding.soap.http.jaxwsinterop.Client.java) , and JAX-WS
client code sets value ("Sending JAX-WS client request...") as input and then sends the
request.

Invoking a SOAP over HTTP Web Service Using
Different SOAP Versions

This sample shows implementation of a service for determining zip code information. This
includes getting information for the city for the specific zip code and calculating distance
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between two cites defined by their zip codes.
The process provides city information based on a zip code, using HTTP as the transport.
The service represents a simple HTTP based service using SOAP 1.1 and SOAP 1.2.

Procedure
Configure the Server
1. In the samples directory, select binding > soap > http > MixedSOAPVersions and
double-click tibco.bw.sample.binding.soap.http.MixedSOAPVersions. For more
information, see Accessing Samples.

2. In Project Explorer, expand the
tibco.bw.sample.binding.soap.http.MixedSOAPVersions project.

3. Fully expand the Processes directory and double-click Process.bwp.
4. Click Run > Debug Configurations.

5. At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

6. Click the Applications tab, and then click the Deselect All button if you have
multiple applications. Select the check box next to
tibco.bw.sample.binding.soap.http.MixedSOAPVersions.application.

7. Click Debug.
The sample runs in Debug mode.

Configure the Client

8. Unzip the TIBCO_
HOME\bw\n.n\samples\bindings\soap\http\MixedSOAPVersions\bw5\tibco.bw.bin
ding.soap.http.MixedSOAPVersionsClient.z1ip file to a directory.

9. Start TIBCO Designer and open the unzipped project in the directory.

a. In TIBCO Designer, click Global Variables and verify whether the variables are
set correctly.

b. Click the Tester tab and then click the green button. Select the check box next
to the process and then select Load & Start Current.

c. After the process completes, click the Stop Testing [Bl icon to stop the process.

10. In TIBCO Business Studio for BusinessWorks, click the Terminate 8 icon to stop the
process.
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Result
e For getCityInfoTest, the zip code defined in the zip field returns information about
Urbana IL.

» For getCityDistanceTest, the distance between two zip codes is returned.
The following output is visible in the console:

12:37:20.751 INFO [bwThread:In-Memory STWorkProcessor-3] c.t.b.p.g.L.t.b.s.b.s.h.M.Log -
Invoked cityinfo

12:37:20.774 INFO [bwThread:In-Memory STWorkProcessor-4] c.t.b.p.g.L.t.b.s.b.s.h.M.Log -
getCitylnfo:

city: Urbanastate: Illinois

location: Urbana, Illinois, United States
latitude: 44.11

longitude: 88.207

zip: 61801

12:37:22.642 INFO [bwThread:In-Memory STWorkProcessor-6] c.t.b.p.g.L.t.b.s.b.s.h.M.Log1 -
Invoked cityDistance

12:37:22.650 INFO [bwThread:In-Memory STWorkProcessor-7] c.t.b.p.g.L.t.b.s.b.s.h.M.Log -
getCityDistance: 4

Understanding the Configuration

The server process has two operations implemented: getCitylnfo and getCityDistance are
used to return information, based on zip codes.

The operations implemented in the server process are invoked using the
getCityDistanceTest and getCitylnfoTest test processes from the client project.

» The endpoint ConcreteZipIinfo_SOAP1.1 using SOAP 1.1 implements getCitylnfoTest.
e The endpoint, ConcreteZipinfo_SOAP1.2 using SOAP 1.2 implements getCityDistance.
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Invoking a SOAP over HTTP Web Service Using
Different Binding Styles

This sample shows the creation and invocation of a SOAP over HTTP web service. It
demonstrates how to use two different binding styles, RPC and DOC Literal for the same
service on two different endpoints.

Procedure
Configure the Server
1. In the samples directory, select binding > soap > http > MixedStyles and double-
click tibco_bw_sample_binding_soap_http_mixedstylesprovider. For more
information, see Accessing Samples.

2. In Project Explorer, expand the tibco_bw_sample_binding_soap_http_
mixedstylesprovider project.

3. Fully expand the Processes directory and double-click Process.bwp.
4. Click Run > Debug Configurations.

5. At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

6. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to tibco_bw_sample_binding_soap_http_
mixedstylesprovider.

7. Click Debug.
This executes the sample in Debug mode.

Configure the Client

8. Unzip the TIBCO_
HOME\bwx\n.n\samples\bindings\soap\http\MixedStyles\bw5\tibco.bw.binding.

soap.http.MixedStylesClient.zip file to a directory.
9. Start TIBCO Designer and open the project unzipped in the directory.

a. In TIBCO Designer, click Global Variables and verify the variables are set
correctly.

b. Click Tester and then click the green button. Select the check box next to the
process and then click Load & Start Current.
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c. After the process completes, click the Stop Testing [®l icon to stop the process

10. In TIBCO Business Studio™ for BusinessWorks™, click the Terminate [ icon to stop
the process.

Result
The Service has the following two different endpoint bindings:

e The Document/Literal is the endpoint for ZipPortEndpointl.
e The RPC/Literal is the endpoint for ZipPortEndpoint2.

For the getCitylnfoTest operation, you can view the information corresponding to the zip
code that is defined in the zip field. Its default value is 60801. This should return
information about Urbana, IL.

For the getCityDistanceTest operation, you can view the information corresponding to the
distance between two zip codes. The default values are:

e 60801: Urbana, IL
e 61820: Champaign, IL
The console shows the following output:

15:24:51.971 INFO [bwThread:In-Memory STWorkProcessor-3] c.t.b.p.g.L.t.b.s.b.s.h.M.Log -
Invoked cityinfo

15:24:51.992 INFO [bwThread:In-Memory STWorkProcessor-4] c.t.b.p.g.L.t.b.s.b.s.h.M.Log -
getCitylnfo-DOC:

city: Urbana

state: Illinois

location: Urbana, Illinois, United States
latitude: 40.11

longitude: 88.207

zip: 61801

15:24:53.857 INFO [bwThread:In-Memory STWorkProcessor-6] c.t.b.p.g.L.t.b.s.b.s.h.M.Log1 -
Invoked cityDistance

15:24:53.865 INFO [bwThread:In-Memory STWorkProcessor-7] c.t.b.p.g.L.t.b.s.b.s.h.M.Log -
getCityDistance-RPC: 4
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Understanding the Configuration

At run-time for the first operation, the client sends a SOAP request comprising a zip code
and receives a city information of that zip code. For the second operation, the client sends
a SOAP request comprising two zip codes and returns the distance between the two cities
defined by their zip codes.

The following shared resources are defined in the project:

e HTTPConnectorResource.httpConnResource: The HTTP Connection Shared
Resource containing the transport configuration.

e CitySchema.xsd: The XSD Schema file containing the definition of the types used by
the web service interface.

e ZipInfo.wsdl: The WSDL file that describes the web service.

Implementing a Service with a Service Binding
and a Client with a Reference Binding

In this sample, a service implements a simplified online mortgage broker application. The
borrower requests a loan through a broker. The broker processes the loan request using
one of the third-party partner services. The borrower can either specify the preferred third-
party provider or allow the broker to default to one. The third-party partner services
request credit rating of the borrower from a credit check service and in turn approves or
rejects the loan application based on the credit rating.

Procedure
1. In the samples directory, select binding > soap > http >
MortgageBrokerServiceClient and double-click
tibco.bw.sample.binding.soap.http.MortgageBrokerServiceClient. For more
information, see Accessing Samples.

2. In Project Explorer, expand the
tibco.bw.sample.binding.soap.http.MortgageBrokerServiceClient project.

3. You can modify the values specified for the Name, Amount, and Preferred bank fields
by clicking on the Input tab of the Invoke activity Client in the
borrower.LoanRequestProcess process.
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[ Project Explorer 2 B%| % & ° = O|[@ *LoanRequestProcess.bwp £
& tibco bw.sample.binding.soap.http.MortgageBrokerServiceClient y
=] borrowerLoanRequestProcess |
9 Processes =
» [
# banksbank A B lling Mortage Broker through "Pr Ref 3 vi)
p orrower calling Mortage Broker through Pracess Reference
@ Bank_A_Processbuip 9 Mortag 9 Mortgage.
 BankSubProcessForCreditCheckbwp #l requestLoanOper.

& banks.bank C ‘ 5 ‘ #] operation

@ Bank C_Processowp @in @
# borrower requéstLoanOperhtion
& * LoanRequestProcessbwp Timer T r Log WriteFile
# creditCheck —
@ CreditCheckbwp BEeE
# mortgageBroker
@ MortgageBrokerLoanRequestProcess.bwp
8 mortgageBroker.partnerProcesses
 Bank_A_PartnerProcess.owp
 Bank_C_PartnerProcess.bwp
B Default_PartnerProcess.bwp
[Z Service Descriptors
1 Resources
1@ Schemas
§ Module Descriptors
& build.properties © Properties 2
 tibco.ow.sample.binding.soap htip.MortgageBrokerServiceClient.|| E requestLoanOperation (Invoke)

<

General

Description Data Source| Functions| Constants| XPath Expression
T $* §_processContext ¢ requestLoanOperation-i
$ SOUTPUT_FILE ~— [ BrokerMessageln
Input $% STimer s«—— [F loanRequest
Output E BrokerLoanReq
8 Name *John"
123 Amount 23453
8¢ PreferredBar "Bank A"

4. Click Run > Debug Configurations.

5. At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

6. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.binding.soap.http.MortgageBrokerServiceClient.application.

7. Click Debug.
This executes the sample in Debug mode.

8. Click the Terminate |8l icon to stop the process.

Result

The response is printed to the console. The response contents are either response from
Mortgage Broker:Name: John: Status: REJECTED, or response from Mortgage Broker:Name:
John : Status: APPROVED.

» When a preferred bank is specified, the corresponding bank service is invoked. If not,
Bank_A service is invoked.

e When the Bank_A and Bank_C services are invoked, either an Approved or Rejected
message is returned, depending on the (random) credit score for the applicant.
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Understanding the Configuration

This sample illustrates various features of the Process Reference. These features are
present as options of Reference Type available on the General tab of the properties view

of the Process Reference.

95 *LoanRequestProcess.owp 2

=] borrower.LoanRequestProcess |

L1 ]

> 0
Borrower calling Mortage Broker through "Process Reference” 7 E »Mortgage...

£] requestLoanOper...
m k
T ot ——

%] operation
) requestloanOperation
Timer Log WriteFile

4

& Properties &

MortgageBrokerLoanRequestProcess (Reference)
I

General Name: MortgageBrokerLoanRequestProcess
Context Reference Type: | Process Reference
[C1nline : Binding Reference

Binding Reference - External
Process Reference
Process Reference - Dynamic

~ Wire to Proceg

Process:

The available options are:
e Binding Reference
» Binding Reference - External
» Process Reference
» Process Reference - Dynamic

The following processes defined in this sample explain their features in the processes.
borrower.LoanRequestProcess
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This process acts as a Consumer and allows the borrower to issue a loan request to the
Mortgage Broker Service. The borrower specifies the values of the following fields in the
requestLoanOperation activity in the borrower.LoanRequestProcess process.

e Borrower name

e Loan amount requested

e Preferred bank. Specify one of the available banks "Bank_A" and "Bank_C". By
default, the broker service calls bank A, if no preferred bank is specified.

o Note: Add an empty string "", for not specifying a preferred bank.

[t Project Explorer i Bg|&6#°°8

33 *LoanRequestProcess.bwp &

[ tibco.bw.sample.binding soap.http MortgageBrokerServiceClient
3 Processes
## banks.bank A
& Bank_A_Process.bwp
@ BankSubProcessForCreditCheck bwp
# banks.bank C
& Bank_C_Process.bwp
# borrower
@ * LoanRequestProcess.owp
# creditCheck
@ CreditCheck bwp
8 mortgageBroker
& MortgageBrokerLoanRequestProcess.owp
B mortgageBroker.partnerProcesses
2 Bank_A_PartnerProcess.bwp
# Bank_C_PartnerProcessbwp
@ Default_PartnerProcess.owp
& Service Descriptors
4 Resources
4 Schemas
& Module Descriptors
[& build.properties

(=] borrower, LoanRequestProcess ‘

1) (1]
Borrower calling Mortage Broker through "Process Reference” - £>Mﬂngage_

2] requestLoanOper...
‘H| %] operation

& tibco.bw.sample.binding.soap.http.MartgageBrokerServiceClient.,

ol ——
requ stLoanOpergtion
T'mer Log WriteFile
BESE
]
= Properties &
B req LoanOperation (I
General
B Data Source| Functions| Constants XPath Expression
Description
5 $% §_processContext £ requestLoanOperation-i
Conversations N
$* SOUTPUT_FILE =— [ BrokerMessageln
Input 3% §Timer «—— [ loanRequest
Qutput «——— [E BrokerLoanReq
Bt Name "John"
123 Amount 23433
0Bt PreferredBar "Bank A"

This process uses Process Reference option to invoke the Mortgage broker process. This
options statically map the two Processes together.

TIBCO ActiveMatrix BusinessWorks™ Samples



81 | Binding Features

[ Project Explorer 53
& tibco.bw.sample.binding.soap.http.MortgageBrokerServiceClient
4@ Processes
# banks.bank A
@ Bank_A_Process.bwp
(2 BankSubProcessForCreditCheck.bwp
£ banks.bank_C
@ Bank_C_Process.bwp
& borrower
@ * LoanRequestProcess.bwp
# creditCheck
£ CreditCheck bwp
£ mortgageBroker
@ MortgageBrokerLoanRequestProcess.bwp
# mortgageBroker.partnerProcesses
@ Bank_A_PartnerProcess.owp
5 Bank_C_PartnerProcess. bwp
i@ Default_PartnerProcess.bwp
I3 Service Descriptors
{4 Resources
1@ Schemas
* Module Descriptors
[5 build.properties
& tibco.bw.sample binding soap.http.MortgageBrokerServiceClient.

5514 ¥ 7 7 0 B loaRequestProcessonp i,

> 0

<

=] borrower, LoanRequestProcess |
] 8 5

=
MortgageBr..

2] requestLoanOper.
#] operation

Borrower calling Mortage Broker through "Process Reference”

D
Q=B o
requestLoanOperation

Timer Log WiteFile

= Properties 2

MortgageBrokerLoanRequestProcess (Reference)

General

Context

Name: MortgageBrokerLoanRequestProcess

Reference Type: ‘ Process Reference
[ nline

~ Wire to Process

Process: B mortt Mort oanRequestProcess

Service Name: ‘ BrokerPT

~ WSDL Interface

© BrokerPT - http://xmIns.example.com/BrokerWSDL
‘WSDL Location /tibco.bw.sample.binding soap.http.MortgageBrokerServiceClient/Service Descriptors/mortgageBroker/BrokerWSDLwsdl

PortType:

mortgageBroker.LoanRequestProcess

This process receives the request from the borrower and calls the available SOAP Service
Providers through subprocess calls.

Depending on the value of "Preferred bank" request field, this process either uses Process
Reference -Dynamic option with Set EPR activity to dynamically call Bank_A_
PartnerProcess or Bank_C_PartnerProcess sub process OR uses the Process Reference
option to statically invoke the Default_PartnerProcess sub process.

B T e D e T L L

g e e rarfage i B

B ¢ g B R g P s
=

B e —

Each subprocess uses the Binding Reference option on the Process Reference to act as a

SOAP Service Consumer, of an available Bank Service.
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banks.bank_A.Bank_A_Process

This process acts as both a SOAP Service Provider for the mortgage broker and a SOAP
Service Consumer for the Credit Check Service.

o Note: SOAP Service Provider configuration is specified at the Component level.

mﬁmmmg (80 Bank_ & ParteerProces  (8) Bank_C_PenerPreces @ LeanfequenProcen | (5 Bank & Pre
& Components

fomponent Confqurations
Conifugure that It of components lod the appleation module
| “CWW:MWH:

+ i Bank A FT
a4} ComponenBank_C_Provess | basks bank C Bank_C_Precess
+ B Bank € FT
+ B CeedaChaddT
‘ L omprsentl ode bt roress | Boreewer LosnPequestProoes:
# 4 ComponentCrediCheni | credtCheck CrediCheck
« B CredChackPT

Dhvprvipw Modole Propertes Dependencies | Componants. Shaned Variakles| MANFESTMF module bem.
0 Pocgeties ©1 B Duta Source Explner| T Cal birarchy () Comacle | T3 Type Moararchy| @) rvoe Log | 4 Saarch| ) History | [£. Prolems

Bank_a_PT
= & S0APSereeBndesg Bank_4 & - e
B lesndpprovailperation
1 BariMessageCut
& BarkMessagef pull Dasclption:
+ Cortot Mappings Targed Namespace: e v Tebe g oo o Tl P340 al del ceTe
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= SOAF Default Configuration
FOAR Varion i =

Bank_A_Process invokes the credit check service through "BankSubProcessForCreditCheck"
sub process. This subprocess uses Binding Reference option, on the Process Reference, to
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act as a SOAP Service Consumer.
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banks.bank_C.Bank_C_Process

This process receives the details of the borrower from the mortgage broker and queries a
credit check services to validate the borrower credentials. The bank can specify the
borrower name. The process exposes services to the mortgage broker.

This process acts as both a SOAP Service Provider for the mortgage broker and a SOAP
Service Consumer for the Credit Check Service.

o Note: SOAP Service Provider configuration is specified at the Component level.

Bank_C_Process uses Binding Reference-external option on the Process Reference, to act
as a SOAP Service Consumer of the Credit check Service.

Note: Configuration of Binding Reference-external is specified at the
Component Level.
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creditCheck.CreditCheck

This process acts as a SOAP Service Provider for credit check functionality. It processes the
request returns the credit rating for a customer.

o Note: SOAP Service Provider is configured at the Component level.

Implementing a Mortgage Loan Application
with Fault

This sample shows a service implementation that invokes fault using a service and
reference binding.

In this sample, the service implements a simplified online mortgage broker application. The
borrower requests a loan through a broker and the broker processes the loan request using
one of the third-party partner services. The borrower can specify the preferred third-party
provider. The third-party partner services request credit rating of the borrower from a
credit check service and in turn replies with fault message if requested loan amount is not
valid.

Procedure
1. In the samples directory, select binding > soap > http > MortgageLoanClientFault
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and double-click tibco_bw_sample_binding_soap_http_mortgagebrokerservice.
For more information, see Accessing Samples.

2. In Project Explorer, expand the tibco_bw_sample_binding_soap_http_
. .
mortgagebrokerservice project.
3. Fully expand the Processes directory and double-click LoanRequestProcess.bwp.
4. Double-click the requestLoanOperation activity.
2 *Project Explorer 32 _ EEI Y A PE® htte
4 B tibe ap.http.

4 € Processes >0 ‘ ess ‘ )
e T e
o (e 8 —
» 8 creditCheck ® requestloanOperationOut ~ —

* B mongebcer estomonsion ™ il foenhpprersCperston )tk coT
+ @ * LoanRequestProcess.bwp Log (&l loanApprovalOpe..)
® BrokerPT
 # mortgageBroker.SubProcesses Operation B3AE. a

» E& Service Descriptors. C

© @ Resources requestLoanOperationOut.

» @ Schemas FromBankC

» & Module Descriptors
& build.properties

» € tibe ap.http.
2. Problems| = Properties %3 @ Reference - online| & Console|
Operation
1 Operation Input i
s g
Input  loanRequest 1 BrokerMessageln
Qutpul - @ (Element
Fault it Name ~ BrokerLoanRequest (sequence in order)
123 Amount
B¢ PreferredBank

5. Click the Input tab and modify the values for the Name, Amount and Preferred bank
fields. Enter amount less than or equal to 25000 or greater than equal to 100000 in

the Amount field.

B Properties £

gl Problems} 8 Data Source ExploreF]

| %

Fing &) =32 |

requestLoanOperation (CallProcess)

General

Data Sourcel Functions| Constants|

Description

$% §_processContext

Conversations L
$% SOUTPUT FILE

= requestLoanOperation-input
=[] BrokerMessageln

Input $L $Timer «——— [ loanRequest
Output [l BrokerLoanRequest
ABL Name "Nishant”
123 Amount xsd:int(20000)
=Bl PreferredBank "Bank_C"

XPath Expression

Click Run > Debug Configurations.

At the left hand tree of Debug Configuration wizard, expand BusinessWorks

Application and select BWApplication.
Click the Applications tab and then click the Deselect All button if you have multiple
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9.

10.

applications. Select the check box next to tibco_bw_sample_binding_soap_http_
mortgagebrokerservice_application.

Click Debug.

This executes the sample in Debug mode.

Click the Terminate [H icon to stop the process.

Result
When a preferred bank is specified, the corresponding bank service is invoked.

Bank_A and Bank_C, when invoked, returns fault message Requested Loan Amount is not
valid. Loan amount should be more than 25000 and less than 100000.

Understanding the Configuration

The following shared resources are defined in the project:

HTTPConnectorResource.httpConnResource: The HTTP Connection Shared
Resource that contains the transport configuration.

BankLoanSchema.xsd: The XSD Schema file that contains the definition of the types
used by the Bank web service's interface.

BrokerSchema.xsd: The XSD Schema file that contains the definition of the types
used by the Broker web service's interface.

CreditCheckSchema.xsd: The XSD Schema file that contains the definition of the
types used by the Credit Check web service's interface.

BankWSDLAbstract.wsdl: Common service interface to request for a loan from a
bank.

CreditCheckWSDL.wsdl: The WSDL file that describes the Credit Check web service.

BrokerWSDL.wsdl: The WSDL file that describes the Mortgage Broker web service.

The example consists of the following:

CreditCheckService: Provides services for loan approvals. In this example, the
borrowers can choose one of the two banks, Bank A and Bank C. These services call
CreditCheckService to approve or reject a loan request or to verify if the requested
loan amount is not valid.
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e Bank_A_Process [ Bank_C_Process: Provides service to get the credit rating for a
customer by calling a process that generates a credit score or reply with a fault
message if the requested loan amount is invalid.

» mortgageBroker.LoanRequestProcess: Provides service to request for a loan
through the Mortgage Broker. The broker in turn checks with the preferred bank for
the loan.

* LoanRequestProcess: Allows the borrower to issue a loan request. The borrower can
specify Name, Amount, and Preferred Bank. Depending on the Preferred Bank value
the respective Bank Process is invoked.

Sending and Receiving a SOAP Unbound
Attachment

A client sends Text and GIF files as attachments for unbound attachments to the server
process. The Server process receives these attachments and returns them as its response.
The Client process captures the sent and received attachments size.

Before you begin

Copy the Attachment.txt and Client.gif files from TIBCO_
HOME\bwx\n.n\samples\binding\soap\http\UnboundAttachments to the directory given
for the AttachmentBaseDir property.

o Note: It is an Unbound Attachment when no part of the Input or Output WSDL
message is mapped to an attachment. In the concrete WSDL there is no
indication whether an attachment is required in the Input or Output. You can
map an attachment in the mimePart config at Binding level only at design time.

Procedure
1. In the samples directory, select binding > soap > HTTP > UnboundAttachments
and double-click tibco.bw.sample.binding.soap.http.UnboundAttachments. For
more information, see Accessing Samples.

2. In the Project Explorer view, expand the
tibco.bw.sample.binding.soap.http.UnboundAttachments project.
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3. Click Run > Debug Configurations.

4. At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

5. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.binding.soap.http.UnboundAttachments.application.

6. Click Debug.

This executes the sample in Debug mode.

7. In TIBCO Business Studio™ for BusinessWorks™, click the Terminatel®| icon to stop
the process.

Result

Sent binary file size : 3587 bytes. Received binary file size : 3587 bytes. Sent text file size :
37 Received text file size : 37

Understanding the Configuration

The ServerProcess implements the getsetAttachments operation along with Context
activities. It receives the client request that has WSDL message parts defined as Element of
Complex type. Binary and Text attachments are retrieved using Get Context activity.
Service reply mechanism sends back the same attachments to the ClientProcess using the
Set Context activity.

The ClientProcess invokes the ServerProcess with input attachments (Binary and Text)
using Set Context activity. The Consumer (Client) reads the input files and sends them to
the Producer (Server) process using the context mechanism. Attachments received from
the server through Get Context activity are written to disk on the client side.

Finally, the Sent and Received file size information for Binary and Text attachments is
written at the location specified in the OUTPUT_FILE module property.

These attachments' size matches and also depicts that attachments can be sent or
received between the Producer and Consumer where they are defined using the context
mechanism outside of WSDL definition.
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Managing a Purchase Order

A purchase order moves through a set of operations including submission, verifying status,
calculating price, and managing faults. This sample shows the processes used to manage
these operations.

Before you begin

Note: To run the sample you can either use TIBCO ActiveMatrix BusinessWorks™
6.x client or ActiveMatrix BusinessWorks™ 5.x as a client.

Procedure
Configure the Server
1. In the samples directory, select binding > soap > http > PurchaseOrder and
double-click tibco.bw.sample.binding.soap.http.PurchaseOrder. For more
information, see Accessing Samples.

2. In Project Explorer expand the tibco.bw.sample.binding.soap.http.PurchaseOrder
project.

3. Copy the ShippingCosts.xml and PriceBook.xml files from TIBCO_
HOME\bwx\n.n\samples\binding\soap\http\PurchaseOrder to the directory given
for the INPUT_DIRECTORY property.

4. Click Run > Debug Configurations.

5. At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

6. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.binding.soap.http.PurchaseOrder.application.

7. Click Debug.
This executes the sample in Debug mode.

Configure the ActiveMatrix BusinessWorks 5.x Client

8. Extract the ActiveMatrix BusinessWorks 5.x client project
bw5\tibco.bw.sample.binding.soap.http.PurchaseOrder.Client.zip into a
temporary directory.
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9. Start TIBCO Designer and import the ActiveMatrix BusinessWorks 5.x client project
from the temporary directory.

10. In TIBCO Designer verify the output file, Host, and Port global variables.

o Note: If you change the module properties in the project, you must
regenerate the concrete WSDL and import it into the 5.x client project.

11. In TIBCO Designer, click Tools > Tester > Start.

12. In TIBCO Business Studio™ for BusinessWorks™, click the Terminate 8 icon to stop
the process.

Result
See the following output:

Purchase ID 1234 is not valid
Submit PurchaseOrder Successful
Status PurchaseOrder :Pending

Status PurchaseOrder: Processed

Understanding the Configuration

The SellerService main process implements the submitPurchaseOrder and
checkStatusPurchaseOrder operations. The submitPurchaseOrder operation returns a
purchase order ID. A buyer uses this ID to check status when invoking the
checkStatusPurchaseOrder operation. Each operation calls subprocesses:

e The SubmitPOExecute subprocess is called from the submitPurchaseOrder
operation and initiates the purchase order submission by calling the
SubmitProcessOrder subprocess and then generates the purchase order ID.

e The SubmitProcessOrder subprocess calls the GetPriceForltem and
CalculateShippingCosts subprocesses to calculate item prices and shipping costs
respectively. After these calculations complete, the purchase order changes to
processed status, from pending status.

e The GetPriceForltem subprocess reads data from PriceBook.xml and returns the
price for an item.
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e The CalculateShippingCosts subprocess reads data from ShippingCosts.xml and

returns the shipping costs based on region.

* The CheckStatus subprocess is called from the checkStatusPurchaseOrder

operation and returns the status of purchase order, either pending or processed.

Using SOAP Bound Headers

This sample shows how to use SOAP Bound Headers by passing any data or control
information in the SOAP envelope. In this sample the Input WSDL message part is
configured as a Header in the WSDL definition.

Procedure

1.

In the samples directory, select binding > soap > http > SOAPBoundHeaders and
double-click tibco.bw.sample.binding.soap.http.SOAPBoundHeaders. For more
information, see Accessing Samples .

In the Project Explorer expand the
tibco.bw.sample.binding.soap.http.SOAPBoundHeaders project.

Fully expand the Processes directory and double-click Client.bwp.
Click Run > Debug Configurations.

At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.binding.soap.http.SOAPBoundHeaders.application

Click Debug.

This runs the sample in the Debug mode.

In TIBCO Business Studio™, click the Terminate [8 icon to stop the process.

Result

The expected outcome for the file identified in the OUTPUT_FILE property is similar to the
following console output:
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10:41:08.248 INFO [bwThread:In-Memory STWorkProcessor-2] c.t.b.p.g.L.t.b.s.b.s.h.S.Log -
Invoked cityinfo

10:41:08.273 INFO [bwThread:In-Memory STWorkProcessor-3] c.t.b.p.g.L.t.b.s.b.s.h.S.Log -
CityInfo response:

city: Urbana

state: Illinois

location: Urbana, Illinois, United States
latitude: 40.11

longitude: 88.207

zip: 61801

10:41:10.299 INFO [bwThread:In-Memory STWorkProcessor-5] c.t.b.p.g.L.t.b.s.b.s.h.S.Log1 -
Invoked cityDistance

10:41:10.306 INFO [bwThread:In-Memory STWorkProcessor-6] c.t.b.p.g.L.t.b.s.b.s.h.S.Log1 -
CityDistance response:

Distance from cityUrbana to city Champaign is 4

Understanding the Configuration

This sample implements a service for determining information about the zip codes. This
includes getting information for the city at the specified zip code, and for getting the
distance between two cites (defined by their zip codes). Citylnfo operation input message
is configured as SOAP Header data whereas the CityDistance operation input message is
configured as SOAP Body data.

Two operations are implemented in the server process. The service operations getCitylnfo
and getCityDistance provide a means for getting the city information about a zip code and
distance between the cities. Both operations are invoked from the client side with a small
sleep between invocations.
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Using SOAP UnBound Headers

SOAP Unbound headers can pass any Out-of-Band data or control information in the SOAP
envelope. In this sample a simple getBook operation based on the specified interface WSDL
file is implemented showing the use of SOAP Unbound Headers.

Procedure

1.

In the samples directory, select binding > soap > HTTP > SOAPHeaders and double-
click tibco.bw.sample.binding.soap.http.SOAPUnboundHeaders. For more
information, see Accessing Samples.

In the Project Explorer expand the
tibco.bw.sample.binding.soap.http.SOAPUnboundHeaders project.

Fully expand the Processes directory and double-click ClientProcess.bwp.
Click Run > Debug Configurations.

At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

Click Applications and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.binding.soap.http.SOAPUnboundHeaders.application.

Click Debug.
This runs the sample in Debug mode.

In TIBCO Business Studio™ for BusinessWorks™, click the Terminate 8 icon to stop
the process.

Result

Expected captchalD : CID007

Received captchalD : CID007

Understanding the Configuration

This sample shows the use of SOAP unbound headers on service and reference.

TIBCO ActiveMatrix BusinessWorks™ Samples



94 | Binding Features

The service exposes a login method that accepts a username and password, and expects a
captcha string to be passed using SOAP unbound headers. Verification of the received
username and password returns a captchalD to caller.

The ClientProcess sends a username and password as part of request message and sends
the captcha string using headers.

The ServerProcess receives the username and password and, on successful verification of
credentials, returns a captchalID as part of the headers and returns a Boolean indicating
login success or failure.

Using SOAP HTTP Transport Headers

This sample shows how to use SOAP Transport headers received on the service side. The
service publishes the transport header elements for two operations.

Procedure

1. In the samples directory, select binding > soap > HTTP > TransportHeaders and
double-click tibco.bw.sample.binding.soap.http.TransportHeaders. For more
information, see Accessing Samples.

2. In Project Explorer expand the
tibco.bw.sample.binding.soap.http.TransportHeaders project.

3. Fully expand the Processes directory and double-click Client.bwp.
4. Click Run > Debug Configurations.

5. At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

6. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.binding.soap.http.TransportHeaders.application.

7. Click Debug.

This runs the sample in Debug mode.

8. In TIBCO Business Studio™, click the Terminate® icon to stop the process.
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Result

For getCitylnfoTest, you see the information corresponding to the zip code that is defined
in the zip field. Its default value is 61801, which returns information about Urbana IL.

For getCitylnfoTestHeaders, you see the information corresponding to the distance
between two zip codes. The default values are 61801 for Urbana IL and 61820 for
Champaign IL.

HTTP Transport Headers from the client side are captured along with input data on the
service side. Transport Headers parameters are saved on service side.

The file specified for the OUTPUT_FILE property is written with the following contents:
HTTP Transport Header elements for operation Citylnfo:

method: POST

requesturi: /SOAPServiceBinding/zipPort/

httpversion: 1.1

querystring:

protocol: HTTP/1.1

port: 11005

Header->accept:

Header->accept-charset:

Header->accept-encoding: Header->content-type: text/xml; charset=UTF-8
content-length: 167

connection:

cookie:

pragma:

HTTP Transport Header elements for operation CityDistance:

method: POST

requesturi: /SOAPServiceBinding/zipPort/

httpversion: 1.1
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querystring:

protocol: HTTP/1.1

port: 11005

Header->accept:

Header->accept-charset:

Header->accept-encoding: Header->content-type: text/xml; charset=UTF-8
content-length: 360

connection:

cookie:

pragma:

Understanding the Configuration

This sample implements a service to determine the information about the zip codes along
with passing the HTTP Transport parameters using the context resource. This includes
getting information for the city at the specified zip code, and for getting the distance
between two cites (defined by their zip codes).

Two operations are implemented in the server process. The service operations getCitylnfo
and getCityDistance provide a means for getting the city information about a zip code and
distance between the cities. HTTP Transport Headers are captured on the service side
using the Context activities.

Both operations are invoked from the client side with a small sleep between invocations.
HTTP Transport Headers details from client side are captured as an output on the service
side.

Sending a SOAP Request and Receiving a SOAP
Reply

A SOAP client is configured to send messages to a SOAP server, which processes the
requests and sends the responses back to the SOAP client.
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Before you begin

Note: To run the sample you can either use TIBCO ActiveMatrix BusinessWorks
6.x client or TIBCO ActiveMatrix BusinessWorks 5.x as a client.

Procedure

10.
11.

Configure the Server

In the samples directory, select binding > soap > http > WSDLImportWSDLand
double-click tibco.bw.sample.binding.soap.http.WSDLImportWSDL. For more
information, see Accessing Samples.

In Project Explorer expand the
tibco.bw.sample.binding.soap.http.WSDLImportWSDL project.

Fully expand the Processes directory and double-click QueryBooksByAuthor.bwp.
Click Run > Debug Configurations.

At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.binding.soap.http.WSDLImportWSDL.application.

Click Debug.
This runs the sample in Debug mode.

Configure the ActiveMatrix BusinessWorks 5.x Client
In TIBCO Designer, import the client project,
bw5\tibco.bw.sample.binding.soap.http.WSDLImportWSDL.client.

Update the HTTP shared resource configuration and verify the Host and Port values
and OUTPUT_FILE global variable.

If you updated HTTPConnector.httpConnResource in the project, you must
regenerate the concrete WSDL and import it into the 5.x client project.

In TIBCO Designer, click Tools > Tester > Start.

In TIBCO Business Studio™, click the Terminatel® icon to stop the process.
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Result
The output of the SOAP Request Reply activity shows the book values returned by the
server, Advanced Java John Doe March, 2002 0596002111 O'Connelly.

Understanding the Configuration

This sample shows how to generate a concrete WSDL, when an abstract WSDL imports
another WSDL, and how it is exposed by a service using a SOAP over HTTP binding. The
server side is implemented in ActiveMatrix BusinessWorks 6.x and the client side is
implemented in ActiveMatrix BusinessWorks 5.x. The client side shows a SOAP palette
resource named SOAP Request Reply, which is used to send a SOAP request to the server
and receive a SOAP response.

The abstract WSDL is named BooksInterface.wsdl:

e The BooksInterface.wsdl abstract file imports the BooksMessage.wsd1 file, which
contains messages used by the operations in BooksInterface.wsdl.

e The BooksMessage.wsdl file imports the Books.xsd schema file, which contains
elements used by the messages in the BooksMessage.wsd1 file.

e The Books.xsd schema file includes the BooksType.xsd schema file, which contains
the types used by the elements in the Books. xsd file.

e The SOAP over HTTP binding is used in the process service.

tibco.bw.sample.binding.soap.http.WSDLImportWSDL in ActiveMatrix BusinessWorks 6.x
contains the QueryBooksByAuthor process, which shows how to receive a SOAP request
from the SOAP client and process the request. This process executes as follows:

1. The service exposed via SOAP over HTTP receives a SOAP request.

2. The Reply activity from the Basic Activities palette sends a response back to the
client.

tibco.bw.sample.binding.soap.http.WSDLImportWSDL.client in ActiveMatrix
BusinessWorks 5.x contains the QueryBooksByAuthor process, which shows how to send a
SOAP request to the SOAP server and process the response. This process definition
executes as follows:

1. The Timer activity starts a job.
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2. The SOAP Request Reply activity sends a SOAP request to the SOAP server and
receives the response from the server and writes the response to OUTPUT_FILE
location.

Implementing a HTTP Service That Returns
Information Based on ZIP Codes

The HTTP service returns information about a city, given a ZIP code. It also provides the
distance between two cities as defined by their ZIP codes.

Before you begin

Note: To run the sample you can either use TIBCO ActiveMatrix BusinessWorks™
6.x client or ActiveMatrix BusinessWorks™ 5.x as a client.

Procedure
Configure the Server
1. In the samples directory, select binding > soap > http > ZipCodeServiceProvider
and double-click tibco.bw.sample.binding.soap.http.ZipCodeServiceProvider. For
more information, see Accessing Samples.

2. In Project Explorer expand the
tibco.bw.sample.binding.soap.http.ZipCodeServiceProvider project.

3. Fully expand the Processes directory and double-click ZipCodeService.bwp.
4. Click Run > Debug Configurations.

5. At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

6. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.binding.soap.http.ZipCodeServiceProvider.application.

7. Click Debug.

This runs the sample in Debug mode.
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Configure the ActiveMatrix BusinessWorks 5.x Client
8. In TIBCO Designer, import the client project,
bw5\tibco.bw.sample.binding.soap.http.ZipCodeServiceProvider.client.

9. Update the HTTP shared resource configuration and verify the Host and Port values
and OUTPUT_FILE global variable.

If you updated HTTPConnector.httpConnResource in the project, you must
regenerate the concrete WSDL and import it into the 5.x client project.

10. In TIBCO Designer, click Tools > Tester > Start.

11. In TIBCO Business Studio™, click the Terminate [E icon to stop the process.

Result

For the getCityInfo service, information corresponding to the zip code defined in the ZIP
field is returned. The default value is 61801, which returns information about Urbana, IL.

For the getCityDistance service, information corresponding to the distance between two
ZIP codes is returned. The default values are 61801 for Urbana IL and 61820 for Champaign
IL.

Understanding the Configuration

The project contains the ZipCodeService process that provides city information about a
ZIP code. HTTP is used for the transport. The project represents a simple HTTP based
service using SOAP. The getCityDistance and getCityIlnfo operations are implemented in
the ZipCodeService process.

Implementing a JMS Service That Writes
Attachment to File

This sample reads a GIF file as a binary data on the Consumer (client) and sends the
request over JMS transport with attachment configured in Set Context activity. The
message format is a RPC-literal element. The SOAP Service receives the message and writes
it to the disk. The Service process then reads the file from the disk and sends it back to the
SOAP Consumer (client). Finally, the SOAP Consumer (Reference binding) writes the same
file to the disk.
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Before you begin
TIBCO Enterprise Message Service must be running.

Copy the ImageInputl.gif file from the TIBCO_
HOME\bw\n.n\samples\binding\soap\jms\AttachmentWriteToFile location to the c:\tmp
folder on Windows or /tmp on UNIX. This file is used as an input attachment.

In TIBCO EMS administration, create queue.sample before executing the sample.

Procedure

1.

In the samples directory, select binding > soap > jms > AttachmentWriteToFile and
double-click tibco.bw.sample.binding.soap.jms.AttachmentWriteToFile. For more
information, see Accessing Samples.

In Project Explorer expand the
tibco.bw.sample.binding.soap.jms.AttachmentWriteToFile project.

Fully expand the Processes directory and double-click Server.bwp.
Verify your TIBCO Enterprise Message Service connection.

a. Fully expand the Resources directory.

b. Double-click JMSConnectionResource.jmsConnResource.

c. In the Basic Configuration dialog box, click Test Connection to verify the
connection.

Click Run > Debug Configurations.

At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.binding.soap.jms.AttachmentWriteToFile.application.

Click Debug.

This runs the sample in Debug mode.

In TIBCO Business Studio™, click the Terminate icon to stop the process.

Result
the following information:
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Sent file size : 2514 bytes. Received file size : 2514 bytes.

Understanding the Configuration

SOAP Consumer (Client) sends the binary data using context over JMS transport. Service
receives the attachment data and writes the attachment to the disk at location specified in
SENT_RECV_FILES_WTF property. Threshold size WRITE_THRESHOLD and WriteToFile
Directory is set on both Service and Reference binding.

The Consumer (Client) receives the attachment data from the Service using context and
writes the content to disk. Both Service Provider and Consumer (Client) write data to the
disk based on the Binding Persistence Configuration.

o Note: Generated attachment files, that is, printServer.gif and
printClient.gif on Service Provider and Consumer (client) must be identical to
the provided INPUT_FILE that is specified in the Module Properties.

Sending a One Way Message over JMS

The SOAP Invoke activity is used to send a one way message over JMS. The message
format is a doc-literal element. Because this is a one way message, no response is expected
from the server.

Before you begin
TIBCO Enterprise Message Service must be running.

Procedure
1. In the samples directory, select binding > soap > jms > OneWayDocLiteral and
double-click tibco.bw.sample.binding.soap.jms.OneWayDocLiteral. For more
information, see Accessing Samples.

2. In Project Explorer expand the
tibco.bw.sample.binding.soap.jms.OneWayDocLiteral project.

3. Fully expand the Processes directory and double-click JMSClient.bwp.
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4. Verify your TIBCO Enterprise Message Service connection.
a. Fully expand the Resources directory.
b. Double-click JMSConnectionResource.jmsConnResource.

c. In the Basic Configuration dialog, click the Test Connection button to verify
the connection.

5. Click Run > Debug Configurations.

6. At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

7. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.binding.soap.jms.OneWayDocLiteral.application.

8. Click Debug.

This runs the sample in Debug mode.

9. In TIBCO Business Studio™, click the Terminatel® icon to stop the process.

Result
The console displays messages similar to the following:

16:11:19.386 INFO [bwThread:In-Memory STWorkProcessor-2] c.t.b.p.g.L.t.b.s.b.s.j.0.Log -
[Server] Received Request :: date=2016-04-21+05:30 boolean=true double=1.1 int=22
string=testStr byte=33 short=44

The expected outcome is:

[Server] Received Request :: date=2016-04-21+05:30 boolean=true double=1.1 int=22
string=testStr byte=33 short=44

Understanding the Configuration

The project comprises the following two processes:
e JMSClient
e JMSServiceProcess

The JMSClient process sends a one way request to the JMSServiceProcess through a SOAP
doc-literal message.
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Using JMS Destination Bridges

This sample illustrates the support of JMS destination bridges in TIBCO ActiveMatrix
BusinessWorks™.

Before you begin

TIBCO Enterprise Message Service must be running.

In TIBCO EMS administration, create queue.sample and topic.sample before
executing the sample.

In TIBCO EMS administration, create the GenericConnectionFactory factory before
executing the sample.

A bridge must be created between Topic to Queue, that is, between topic.sample
and queue.sample.

Create a queue replyQueue.

Procedure

1.

In the samples directory, select binding > soap > jms > TopicQueueBridge and
double-click tibco.bw.sample.binding.soap.jms.TopicQueueBridge. For more
information, see Accessing Samples.

In Project Explorer expand the
tibco.bw.sample.binding.soap.jms.TopicQueueBridge project.

Verify your TIBCO Enterprise Message Service connection.
a. Fully expand the Resources directory.
b. Double-click JMSConnectionResource.jmsConnResource.

c. In the Basic Configuration dialog, click the Test Connection button to verify
the connection.

Fully expand the Processes directory and double-click client.bwp.
Click Run > Debug Configurations.

At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
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tibco.bw.sample.binding.soap.jms.TopicQueueBridge.application.

8. Click Debug.

This runs the sample in Debug mode.

9. Click the Terminatel®l icon to stop the process.

Result

The Console shows the following response:
Request Received.

Response received with value :0.5

Understanding the Configuration

The process sends a message to the Topic and is receives from the Queue using SOAP over
JMS.

This process executes as follows:
e Client sends a request.

e WS Service receives the request and calls the Service process. The Service process
processes the data and returns the response.

Implementing a JMS Service that Returns
Information Based on Zip Codes

The JMS service returns information about a city, given a zip code. It also provides the
distance between two cities as defined by their zip codes.

Before you begin
TIBCO Enterprise Message Service must be running.

Procedure
1. In the samples directory, select binding > soap > jms > ZipCodeLookup and
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double-click tibco.bw.sample.binding.soap.jms.ZipCodeLookup. For more
information, see Accessing Samples.

2. In Project Explorer expand the tibco.bw.sample.binding.soap.jms.ZipCodeLookup
project.

3. Fully expand the Processes directory and double-click ZiplnfoService.bwp.
4. Verify your TIBCO Enterprise Message Service connection.

a. Fully expand the Resources directory.

b. Double-click JMSConnectionResource.jmsConnResource.

c. In the Basic Configuration dialog box, click the Test Connection button to
verify the connection.

5. Click Run > Debug Configurations.

6. At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

7. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.binding.soap.jms.ZipCodeLookup.application.

8. Click Debug.

This runs the sample in Debug mode.

9. In TIBCO Business Studio™, click the Terminate [H icon to stop the process.

Result

For the getCityInfo service, information corresponding to the zip code defined in the zip
field is returned. The default value is 61801, which returns information about Urbana, IL.

For the getCityDistance service, information corresponding to the distance between two
zip codes is returned. The default values are 61801 for Urbana IL and 61820 for
Champaign IL.

Understanding the Configuration

The project contains the ZipInfoService process that provides city information about a zip
code. JMS is used for the transport. The project represents a simple JMS based service

TIBCO ActiveMatrix BusinessWorks™ Samples



107 | Binding Features

using SOAP. The getCityDistance and getCitylnfo operations are implemented in the
ZipInfoService process.

Implementing a JMS Service That Returns an
Attachment

The JMS service returns information about a city, given a zip code as an attachment.

Before you begin
TIBCO Enterprise Message Service must be running.

Copy the CityInfo.xml from TIBCO_
HOME\bwx\n.n\samples\binding\soap\jms\\ZipCodeLookupWithAttachment file to the
c:\tmp folder. The file has city information and is used to send as the attachment.

In TIBCO EMS administration, create queue.sample and topic.sample before executing the
sample.

Procedure

1. In the samples directory, select binding > soap > jms >
ZipCodeLookupWithAttachment and double-click
tibco.bw.sample.binding.soap.jms.ZipCodeLookupWithAttachment. For more
information, see Accessing Samples.

2. In Project Explorer expand the
tibco.bw.sample.binding.soap.jms.ZipCodeLookupWithAttachment project.

3. Fully expand the Processes directory and double-click ZipInfoService.bwp.
4. Verify your TIBCO Enterprise Message Service connection.

a. Fully expand the Resources directory.

b. Double-click JMSConnectionResource.jmsConnResource.

c. In the Basic Configuration dialog box, click Test Connection to verify the
connection.

5. Click Run > Debug Configurations.

o

At the left hand tree of Debug Configuration wizard, expand BusinessWorks
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Application and select BWApplication.

7. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.binding.soap.jms.ZipCodeLookupWithAttachment.application.

8. Click Debug.

This runs the sample in Debug mode.

9. In TIBCO Business Studio™, click the Terminate 8 icon to stop the process.

Result
the following output:

Zip Code : 94086
City : SUNNYVALE

State : CA
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Core Features

This section includes a set of samples that demonstrate core features, including using
shared modules, managing faults, invoking subprocesses and so on.

Using Process and Module Properties

This sample demonstrates the use of process and module properties.

Procedure

1.

In the samples directory, select core > config > BasicPropertyConfiguration and
double-click tibco_bw_sample_core_config_processandmoduleproperties.zip. For
more information, see Accessing Samples.

2. In Project Explorer, expand the tibco_bw_sample_core_config_
processandmoduleproperties project.

3. Click Run > Debug Configurations.

4. At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

5. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to tibco_bw_sample_core_config_
processandmoduleproperties_application.

6. Click Debug. This runs the sample in Debug mode.

The WriteFileMProp activity writes to the file name that is defined in the MP_
FileNamel Module Property. The WriteFilePProp activity writes to the file name that
is defined in the PP_FileName2 Process Property. By default, this value is set to
C:\tmp\BasicPropertyConfiguration\fileProcessPropDefault.log.

7. Click the Terminate® icon to stop the process.

Result

The console prints a message similar to the following:
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INFO [bwThread:In-Memory STWorkProcessor-1] c.t.b.p.g.L.t.b.s.c.c.b.p.Log - -->Completed
WriteToFileProcessA Job: bw0a100

Using a Process Conversation to Correlate JMS
Message Jobs

JMS client and server processes correlate with each other by sending and receiving JMS
messages through the process conversation mechanism.

Before you begin
Use TIBCO ActiveMatrix BusinessWorks™ 6.x server. However, if you want to run
ActiveMatrix BusinessWorks™ 5.x server, install ActiveMatrix BusinessWorks 5.x.

TIBCO Enterprise Message Service must be running.

Procedure
1. In the samples directory, select core > conversation > MultiJobsCorrelation and
double-click tibco.bw.sample.core.conversation.MultiJobsCorrelation. For more
information, see Accessing Samples.

2. In the Project Explorer, expand the
tibco.bw.sample.core.conversation.MultiJobsCorrelation project.

3. Fully expand tibco.bw.sample.core.conversation.MultiJobsCorrelation.application
and double-click Properties. The output file location defined for the application is
displayed in the dialog.

4. Ensure that the TIBCO Enterprise Message Service server is up and running.
5. Click Run > Debug Configurations.

6. At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

7. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.core.conversation.MultiJobsCorrelation.application.

8. Click Debug.

TIBCO ActiveMatrix BusinessWorks™ Samples



111 | Core Features

This runs the sample in Debug mode.
9. Click the Terminatel®l icon to stop the process.
10. For the server created in ActiveMatrix BusinessWorks 5.x:

a. In TIBCO Business Studio™ for BusinessWorks™, select Module Descriptors >
Components and remove Receiver.bwp.

b. Repeat steps 6 through 8 from above.

c. Unzip, open, and run
bw5/tibco.bw.sample.core.conversation.MultiJobsCorrelation.Server in the

TIBCO Designer 5.x Tester.

Result

From the Debugger, expand BWNode to see the jobs created. Jobs are completed in the
order of server side reply and not in the order of their creation. The following image shows
the resulting console screen.

On UNIX, you can also verify the expected result by tailing the client output to the file
/tmp/MultiJobsCorrelation/MultiJobsCorrelation. log.

The MultiJobsCorrelation.log at the C:\tmp\MultiJobsCorrelation location shows
requests 1 to 10 when sent in order with the corresponding correlation IDs. The server
response is received out of order and the runtime engine correlates each reply to the
corresponding request correctly. You see the following output.

B 0o L trp — bash — 79«24
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Understanding the Configuration

A conversation is configured with an Initiator and a Joiner. Click the WaitForServerReply
activity (a JMS Signal-In activity).

Click the Conversations tab. In this case, WaitForServerReply is both the Initiator and
Joiner for this conversation.
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The WaitForServerReply activity's Initiate action is configured with
SReceiveLaunchMsg/JMSHeader/ns:JMSCorrelationID where SendRequestToServer activity
Input is also configured with the same JMSCorrelationID. See the following.

» SendRequestToSorver (JMS Send Message)
Gararad
Omcripiion | 0#ts Source Funcions £ontants AP uth Eaprenson
Adopnced R # i Seregunt Tolerer - st
4 L LausaCHIR O 2 B Riteayleges
Jopd oo $4 TS CUTRUT_FLE BE desinstisn?
Ingurt ARTTRT T ——
g Sh s oo g L} BeEspuptan?
Pt $ hacenml manchidhg 13) PLPrcraty
i ehgeneed L
W L vl SEp vl wums by B sden, ms B complstonll)
M 5T !
Py ——
M AT
12 Mg’
B Bt (LT LIPS . 8

The reason for this configuration is on the ActiveMatrix BusinessWorks 5.x
JMSServerProcess side. The Reply To Client activity is configured to send back the same
JMSCorrelationID, for the Reply to match with the correct Server Request job.

Using Modularity with the Java Palette

Three application modules and one shared module demonstrate calling from a Java Invoke
activity and an Invoke activity through a Call Process.
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Before you begin
1. For the Java invoke to work, create a new application on https://apps.twitter.com/
and generate Access Token, Access Token Secret, Consumer Key, Consumer Secret
for the app created, and use it in the parameters for SearchTwitter activity.

2. To create a token:
a. Login to https://apps.twitter.com/ with your Twitter account.
b. Click Create New App.

c. Provide Name and Description and create your Twitter application. Your
application is successfully created.

d. Go to the API Keys tab and click Create my access token. Your application
access token is successfully generated.

e. Click Test OAuth. The OAuth Settings page is generated with the following
tokens:

e Consumer key
e Consumer secret
e Access token

e Access token secret

Procedure
1. In the samples directory, select core > modularity >
ProcessAndJavaCodeModularity. The following projects are visible:

e tibco.bw.sample.core.modularity.ProcessAndJavaCodeModularity.app

e tibco.bw.sample.core.modularity.ProcessAndJavaCodeModularity.importpa
ckage

o tibco.bw.sample.core.modularity.ProcessAndJavaCodeModularity.shared

e tibco.bw.sample.core.modularity.ProcessAndJavaCodeModularity.subproce
sscall

2. First click on
tibco.bw.sample.core.modularity.ProcessAndJavaCodeModularity.shared and
then click on the remaining three projects.

3. In Project Explorer, expand the
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tibco.bw.sample.core.modularity.ProcessAndJavaCodeModularity.app project.
For more information, see Accessing Samples.

4. Fully expand the Processes directory and double-click Process.bwp.
5. Click Run > Debug Configurations.

6. At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

7. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.core.modularity.ProcessAndJavaCodeModularity.app.applicatio
n.

8. Click Debug. This runs the sample in Debug mode.

The console window shows the log messages such as application module started
successfully and application started successfully.

9. Run
tibco.bw.sample.core.modularity.ProcessAndJavaCodeModularity.importpackag
e.application and
tibco.bw.sample.core.modularity.ProcessAndJavaCodeModularity.subprocesscall
.application in a similar way, one after the other.

Understanding the Configuration

The sample has three Application Modules and one Shared Module:

e tibco.bw.sample.core.modularity.ProcessAndJavaCodeModularity.app: This is an
application module that contains the TIBCO BusinessWorks ™ Processes. It uses the
Java invoke in the shared module
tibco.bw.sample.core.modularity.ProcessAndJavaCodeModularity.shared. The
application module refers to the shared module using the Require-Bundle Manifest
header. The sample Java Invoke activity uses the Java invoke to connect to Twitter
to search for the string "Lady Gaga". Twitter returns a payload of tweets matching
the search string, which the Write To File activity then writes to a file in a temporary
directory.

e tibco.bw.sample.core.modularity.ProcessAndJavaCodeModularity.importpackage
: This is similar to the
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tibco.bw.sample.core.modularity.ProcessAndJavaCodeModularity.app module,
except here the application module uses Imported Packages instead of Required
Modules in Module Descriptors > Dependencies.

e tibco.bw.sample.core.modularity.ProcessAndJavaCodeModularity.subprocesscall
: This is an application module that calls the web service hosted in the shared
module.

o tibco.bw.sample.core.modularity.ProcessAndJavaCodeModularity.shared: This is
a shared module that contains code to make a REST call to Twitter to search for a
specified search term. Since this is a shared module it cannot be executed by itself.
However, it can be called from an application module such as
tibco.bw.sample.core.modularity.ProcessAndJavaCodeModularity.app,
tibco.bw.sample.core.modularity.ProcessAndJavaCodeModularity.importpackag
e, and
tibco.bw.sample.core.modularity.ProcessAndJavaCodeModularity.subprocessca
11. This functionality is exposed by the shared module both as a Java class and a
web service, which can be invoked by an Invoke activity.

Process

Scenario 1

Modules Executed
e tibco.bw.sample.core.modularity.ProcessAndJavaCodeModularity.shared
e tibco.bw.sample.core.modularity.ProcessAndJavaCodeModularity.app

This scenario demonstrates calling Java invoke (in a Shared Module) from a Java Invoke
activity in an Application module. The dependency on the Java package in the Shared
Module is modeled using Required Modules in Module Descriptors > Dependencies.

Scenario 2
Modules Executed
» tibco.bw.sample.core.modularity.ProcessAndJavaCodeModularity.shared
e tibco.bw.sample.core.modularity.ProcessAndJavaCodeModularity.importpackage

This scenario shows how to call the Java invoke (in a shared module) from a Java Invoke
activity in an application module. The dependency on the Java package in the shared
module is modeled using Import-Package in Module Descriptors > Dependencies.
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Scenario 3
Modules Executed

e tibco.bw.sample.core.modularity.ProcessAndJavaCodeModularity.shared

tibco.bw.sample.core.modularity.ProcessAndJavaCodeModularity.subprocesscall

This scenario shows how to call the Java invoke (in a shared module) from an Invoke
activity in the application module through a Call Process. There is no Java package or
bundle dependency on the shared module.

The following sub process is in the shared module:

TwitterSearch SubProcess: This subprocess is invoked from
tibco.bw.sample.core.modularity.ProcessAndJavaCodeModularity.subprocesscall. In
this subprocess, there are two Javalnvoke Activities - OpenTwitterConnection and
SearchTwitter. The source code for these activities is located under src directory under
com.example.TwitterConnection package in the same project.

OpenTwitterConnection activity creates a TwitterConnection object which is then passed to
SearchTwitter activity. SearchTwitter activity requires the following 5 input parameters:

e SearchString

AccessToken

AccessTokenSecret

ConsumerKey

e ConsumerSecret

SearchString signifies the string used by the user to search tweets. In this project, the
SearchString is "Lady Gaga". This SearchString is passed from the main process in
tibco.bw.sample.core.modularity.ProcessAndJavaCodeModularity.subprocesscall.

AccessToken, AccessTokenSecret, ConsumerKey, and ConsumerSecret are required for
authentication to the Twitter Account.

The steps to generate these are described in the Prerequisites section. You can change the
values of these module properties from Module Descriptors > Module Properties.

Note: The Java invoke uses Twitter APl v1.1 which requires the request to be
authenticated using OAuth.
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The process for Scenario 1 and Scenario 2 is very similar to the subprocess of Scenario 3,
except that Scenario 1 and 2 have a Timer activity as a process starter instead of a service.

Troubleshooting

o Note: If you open Application Modules especially subprocesscall application
module before the shared module, then you may encounter errors such as
Import Configuration Error, Process Reference configuration Error, Application
configuration Error, and so on.

* If you receive the following error message:
"401:Authentication credentials (https://dev.twitter.com/docs/auth) were
missing or incorrect. Ensure that you have set valid consumer key/secret,
access token/secret, and the system clock 1is in sync."

make sure you have generated Access Token, Access Token Secret, Consumer Key,
Consumer Secret as per the steps specified in the Prerequisites section

* If you see any problem markers in the project, ensure
tibco.bw.sample.core.modularity.ProcessAndJavaCodeModularity.shared is
imported into the workspace as all other application modules depend on this shared
module.
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Configuring a Conversation to Join a Wait for
File Change Activity

The Wait For File Change activity initiates and joins conversation with a File Poller activity
to implement a process conversation.

Procedure

1.

In the samples directory, select core > conversation > WaitForFileChange and
double-click tibco.bw.sample.core.conversation.WaitForFileChange. For more
information, see Accessing Samples .

In the Project Explorer view, expand the
tibco.bw.sample.core.conversation.WaitForFileChange project.

Fully expand tibco.bw.sample.core.conversation.WaitForFileChange.application
and double-click Properties. The output file locations defined for the application
displays in the dialog.

Click Run > Debug Configurations.

At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.core.conversation.WaitForFileChange.application.

Click Debug.
This runs the sample in Debug mode.

After completing the Scenariol and 2, click the Terminate [l icon to stop the
process.

Result
The request is Approved.
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Understanding the Configuration

Procedure
1. Trigger.bwp process creates Trigger.log and this triggers a job.

2. Trigger.bwp process creates Req.log and writes "Approved" in the same file. This
triggers event for the "Wait For File Change".

3. When the Wait for File Change activity executes, the process instance suspends and
waits for the specified change to occur before resuming.

Output file gets created at: c:\tmp\WaitForFileChange\WaitForFileChange.log
with content: "The request is Approved."

4. The RemoveApprovalFile activity removes the Req. log file from
c:\tmp\WaitForFileChange.

5. TriggerAnotherJob: This activity triggers another job and process execution waits at
Wait For File Change activity for matching the correlation keys.

6. |If the user creates Req. log file at location c:\tmp\WaitForFileChange with content
"Rejected", then conversation gets executed successfully and the output file at
c:\tmp\WaitForFileChange\WaitForFileChange.log gets updated as mentioned
below:

The request is Approved.

The request is Rejected.

Using an Asynchronous Event Handler to
Implement a Simple Mortgage Workflow

Mortgage application consumer and provider processes interact with each other through
the message correlation mechanism. The event handler invocation allows for asynchronous
event processing and executes the logic parallel to the main business logic of the process.

Procedure
1. In the samples directory, select core > event > AsyncEventHandler and double-click
tibco.bw.sample.core.event.AsyncEventHandler. For more information, see
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Accessing Samples.

2. In Project Explorer, expand the tibco.bw.sample.core.event.AsyncEventHandler

project.

3. Fully expand the Processes directory and double-click the
MortgageAppConsumer.bwp and the MortgageAppProvider.bwp processes.

4. Click Run > Debug Configurations.

5. At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

6. Click the Applications tab and then click the Deselect All button if you have multiple

applications. Select the check box next to
tibco.bw.sample.core.event.AsyncEventHandler.application.

7. Click Debug.
This runs the sample in Debug mode.

8. Click the Terminatel®l icon to stop the process.

Result
On the console, the log messages are displayed similar to the following:

12:19:45.639 [bwThread:In-Memory STWorkProcessor-2] INFO
c.t.b.p.g.L.t.b.s.c.e.A.LogSubmitMortgage - ### Received SubmitMortgageApp()

12:19:45.670 [bwThread:In-Memory STWorkProcessor-4] INFO c.t.b.p.g.L.t.b.s.c.e.A.Log -
Cancel Application F54734546

12:19:45.685 [bwThread:In-Memory STWorkProcessor-4] INFO c.t.b.p.g.L.t.b.s.c.e.A.Log -
Cancel Application F54734546

12:19:45.685 [bwThread:In-Memory STWorkProcessor-4] INFO c.t.b.p.g.L.t.b.s.c.e.A.Log -
Cancel Application F54734546

12:19:45.701 [bwThread:In-Memory STWorkProcessor-8] INFO c.t.b.p.g.L.t.b.s.c.e.A.Log - ###

Done, get Mortgage Rate: 9.1
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Understanding the Configuration

There are two processes in the supplied project:

» MortgageAppProvider: This is a Mortgage service with three operations, the
SubmitMortgageApp, SubmitFinDoc and the CancelMortgageApp operations
defined in the event handler container. Both the CancelMortgageApp and
SubmitFinDoc operations have a correlation key obtained from the response to the
operation SubmitMortgageApp.

e MortgageAppConsumer: The consumer invokes the CancelMortgageApp operation
before the operation SubmitFinDoc: This way, the service calls CancelMortgageApp
after receiving the correlation message key, mortgageAppID: The
CancelMortgageApp activity has the input properties configured as shown in the
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Using a Cross Process Conversation to
Determine the Mortgage Rate

The process conversation mechanism is demonstrated using a mortgage rate calculation
scenario that performs the following:

» A user passes the customer's name and credit profile information.

* If the credit profile value of the customer is A, the mortgage lending rate is 3.5 and if
the credit profile is B, the lending rate is 2.0.

» Depending on the mortgage lending rate calculated, the lending institution decides
either to accept or to reject the application. This particular lender decides to lend
money only with the 3.5 mortgage rate. If the calculated rate is lower for any credit
profile, the application is rejected by the lender.

Procedure
1. In the samples directory, select core > conversation > CrossProcessConversation
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and double-click tibco.bw.sample.core.conversation.CrossProcessConversation.
For more information, see Accessing Samples.

2. In the Project Explorer view, expand the
tibco.bw.sample.core.conversation.CrossProcessConversation project.

3. Set the default ApplicationProfile to match the OS you are running on. For more
information, see Setting the Default Application Profile.

4. Fully expand the Processes directory and double-click MortgageAppConsumer.bwp.
5. Click Run > Debug Configurations.

6. At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

7. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.core.conversation.CrossProcessConversation.application.

8. Click Debug.

This runs the sample in Debug mode.

9. Click the Terminatel®l icon to stop the process.

Result
The CrossProcessConversation.log output file at C:\tmp\CrossProcessConversation is
created with the following content:

Received application from BWUser user with credit profile B
Mortgage Cancelled

### DONE

The console displays the following log message:

12:20:42.735 INFO [bwEngThread:In-Memory STWorkProcessor-1]
c.t.b.p.g.L.t.b.s.c.c.C.SubmitMortgageAppLog - Received application from BWUser user with
credit profile B

12:20:42.779 INFO [bwEngThread:In-Memory STWorkProcessor-4]
c.t.b.p.g.L.t.b.s.c.c.C.CancelMortgageAppLog - Mortgage Cancelled

12:20:42.818 INFO [bwEngThread:In-Memory STWorkProcessor-5] c.t.b.p.g.L.t.b.s.c.c.C.Log -
DONE
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Understanding the Configuration

Operations implemented in the Service Provider process are invoked from the Consumer
process. The following processes are implemented:

* The MortgageAppConsumer process invokes different operations implemented in
the MortgageServiceProvider process. The SubmitFinDoc or CancelMortgage
operation is called, based on the mortgage rate returned by the
SubmitMortgageApp operation for a customer.

* The MortgageServiceProvicer process implements the SubmitMortgageApp,
SubmitFinDoc, or CancelMortgage operation. The SubmitMortgageApp operation
generates and returns the mortgage app id and tentative mortgage rate, based on
the customer's credit profile. The SubmitFinDoc operation submits the final
mortgage documents. The CancelMortgage operation cancels the mortgage request.

For details about the conversation, select the Conversation tab for each of the following:
e The SubmitMortgageAppOut Reply activity for initiating the conversation.
e The SubmitFinDocln Receive activity for joining the conversation.
» The onEvent Event Handler for joining the conversation.

A conversation is evaluated to true if the value in Join matches the mortgageAppID
generated by the SubmitMortgageApp operation for each mortgage request. This way, the
mortgageApplID is used as a key to process a mortgage request for a customer.

Catching Activity Faults with Scope and Fault
Handlers

A scope and fault handler is defined for activities within a process. The handler catches
faults that have been triggered within the scope.

If accessing the sample from the Welcome page of TIBCO Business Studio™ for
BusinessWorks™, go directly to Step 3.

Procedure
1. In the samples directory, select core > fault > ScopeAndFaultHandler and double-
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click tibco.bw.sample.core.fault.ScopeAndFaultHandler.zip. For more information,
see Accessing Samples.

2. In the Project Explorer, expand the
tibco.bw.sample.core.fault.ScopeAndFaultHandler project.

3. Set the default ApplicationProfile to match the OS you are running on. For more
information, see Setting the Default Application Profile.

4. Fully expand the Processes directory and double-click ScopeFault.bwp.
5. Click Run > Debug Configurations.

6. At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication

7. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.core.fault.ScopeAndFaultHandler.application.

8. Click Debug.
This runs the sample in Debug mode.

9. Click the Terminatel®l icon to stop the process.

Result

The console displays the messages based on the value specified in "INPUT_XML_FILE"
Module Property.

o If the correct location is specified for the MortgageRatesDB.xm1 file in "INPUT_XML_
FILE" Module Property property, the message, The mortgage rate is 3.5 displays.

 If an incorrect location is specified for the MortgageRatesDB. xml file in "INPUT_XML_
FILE" Module Property, the following error message displays:

Caught FNF: < User_Defined_File_Location >\MortgageRatesDB.xml was not found.

The same message is written in a output.log file at C:\tmp\ScopeAndFaultHandler
location.
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Modularity Among Applications with a Shared
Module Project

This sample shows how modularity can be achieved among two application module
projects and a shared module project.

Two scenarios in this sample show how a process in a shared module can be used by other
application modules, without requiring changes to the contents of the shared module. The
scenarios are demonstrated in the following projects:

Application Module Projects
e tibco.bw.sample.core.modularity.AppsWithSharedModule.App.HelloWorldConsumer

e tibco.bw.sample.core.modularity.AppsWithSharedModule.App.TimerEventComponent
Shared Module Project

¢ tibco.bw.sample.core.modularity.AppsWithSharedModule.SharedModule

Procedure
Scenario 1
1. In the samples directory, select core > modularity > AppsWithSharedModule and
double-click
tibco.bw.sample.core.modularity.AppsWithSharedModule.SharedModule. For
more information, see Accessing Samples.

2. In Project Explorer, expand the
tibco.bw.sample.core.modularity.AppsWithSharedModule.App.HelloWorldConsu
mer.

3. Set the default ApplicationProfile to match the OS you are running on. For more
information, see Setting the Default Application Profile.

4. Fully expand the Processes directory and click MainProcess.bwp.
5. Click Run > Debug Configurations.

6. At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication

7. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
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10.

11.
12.

13.

14.

15.

tibco.bw.sample.core.modularity.AppsWithSharedModule.App.HelloWorldConsu
mer.application.

Click Debug.
This runs the sample in Debug mode.

Click the Terminate® icon to stop the process.

Scenario 2

In the AppsWithSharedModule directory, double-click the
tibco.bw.sample.core.modularity.AppsWithSharedModule.App.TimerEventCompo
nent project.

Click Run > Debug Configurations.

At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication

Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.core.modularity.AppsWithSharedModule.App.TimerEventCompo
nent.application.

Click Debug.

This runs the sample in Debug mode.

Click the Terminate® icon to stop the process.

Result
Scenario 1

The following messages are written by the shared module and application module to the
helloWorldServiceConsumer.log file at c:\tmp\AppsWithSharedModule location.

--> LogMessage from HelloWorldServiceProcess for John

e ——> Hello John from HelloWorldServiceProcess

Scenario 2

The following messages are written by the shared module and application module to the
timerEvent. log file at c:\tmp\AppsWithSharedModule location.

e --> LogMessage from TimerEventProcessTimerEventProcess

e --> Hello TimerEventProcess--> from LogMessage from TimerEventProcess
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Understanding the Configuration

Scenario 1: The MainProcess included in the
tibco.bw.sample.core.modularity.AppsWithSharedModule.App.HelloWorldConsumer
application module, invokes the HelloWorldServiceProcess in the
tibco.bw.sample.core.modularity.AppsWithSharedModule.SharedModule. The Write To
File activity logs the output from the calling process, HelloWorldServiceProcess.

Scenario 2: The Process included in the
tibco.bw.sample.core.modularity.AppsWithSharedModule.App.TimerEventComponent
application module invokes the TimerEventProcess in the
tibco.bw.sample.core.modularity.AppsWithSharedModule.SharedModule.

Load Balancing an Application Using an
AppSpace

This process demonstrates the concept of an AppSpace for scaling an application.

Before you begin
e TIBCO Enterprise Message must be running.

e To run this sample, you can either use TIBCO ActiveMatrix BusinessWorks™ 6.x client
or ActiveMatrix BusinessWorks™ 5.x as a client.

» PostgreSQL Database should be installed and running on the machine. Create tables
by using the related scripts for the engine database.

e Sample uses default queue - 'queue.sample’ of EMS server running on localhost.

Procedure
Setup the Domain
1. In a terminal, navigate to TIBCO_HOME\bw\n.n\bin and type bwadmin.

2. Create a Domain, AppSpace and AppNode:

bwadmin[admin]> create domain MyDomain
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bwadmin[admin]> cd MyDomain

bwadmin[admin@MyDomain]> create appspace MyAppSpace
bwadmin[admin@MyDomain]> cd MyAppSpace
bwadmin[admin@MyDomain/MyAppSpace]> create -httpPort 9999 appnode
MyAppNode

Create the config.ini File

3. Copy TIBCO_HOME\bw\n.n\config\appspace_config.ini_template to a temporary
location.

4. Rename the appspace_config.ini_template file to config.ini.

a. Uncomment the following property and change the value to group.

bw.engine.persistenceMode=group

b. Set the datastore configuration with values similar to:

# BW Engine Database Driver.
bw.engine.db.jdbcDriver=org.postgresql.Driver

# BW Engine Database URL.
bw.engine.db.url=jdbc:postgresql://localhost:5432/postgresl

# BW Engine Database User Name.
bw.engine.db.userName=postgres

# BW Engine Database User Password.
bw.engine.db.password=root

# BW Engine Database Connection Pool Size.
bw.engine.db.maxConnections=10

c. Save the config.ini file.

For the JMS Receive Message activity, load balancing is done by setting Max
Jobs limit and the flow limit. If one instance is down, the other instance
processes the messages. Thus avoiding any outage. For the HTTP Receiver
activity, load balancing is done at the external load balancer level. If one
instance is down, all requests are sent to the other instance. However, when
you use load balancing with fault tolerance, a database is required.

5. Push the configuration to the AppSpace running the following command in the
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6.

10.
11.

12.

bwadmin terminal:

bwadmin[admin@MyDomain/MyAppSpace]> config -cf <temporary_
location>/config.ini

In the bwadmin terminal, upload and deploy the EAR file into the AppSpace:

bwadmin[admin@MyDomain/MyAppSpace]>upload

TIBCO_

HOME\bw\ x .x\samples\AppSpace\core\admin\ears\samples\tibco.bw.sampl
e.core.scalability.LoadBalancingUsingAppSpace.application_1.0.0.ear

bwadmin[admin@MyDomain/MyAppSpace]> deploy -as

tibco.bw.sample.core.scalability.LoadBalancingUsingAppSpace.applica
tion_1.0.0.ear

Start the AppSpace using the following command:

bwadmin[admin@MyDomain/MyAppSpace]> start appspace MyAppSpace

Configure and Start the Client
Start TIBCO Designer and click New Empty Project.

Click Project > Import and import the client project, TIBCO_
HOME\bw\n.n\samples\core\scalability\LoadBalancingUsingAppSpace\bw5\tibco

.bw.sample.core.scalability.LoadBalancingUsingAppSpace.client.
Update the JMS shared resource configuration and verify the Host and Port values.

In TIBCO Designer, click Tools > Tester > Start. Wait for 30 seconds before
completing the next steps.

Create a Second AppNode

In the bwadmin terminal, create a second AppNode in MyAppSpace. Execute the
create command to create the AppNode and then the start command to start the
AppNode:

The TIBCO ActiveMatrix BusinessWorks™ JMS application should be deployed to
MySecondAppNode automatically by the AppSpace.
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bwadmin[admin@MyDomain/MyAppSpace]> create -httpPort 9996 appnode
MySecondAppNode
bwadmin[admin@MyDomain/MyAppSpace]> start appnode MySecondAppNode

13. Open the bwappnode. log files on each node located under
<DomainLocation>/<appnodes>/<appspace>/<nodename>/log [Example:

<DomainlLocation>/appnodes/betaappspace/betaappnodel/log] and monitor the
messages flow.

14. Stop the second AppNode using the following command:

bwadmin[admin@MyDomain/MyAppSpace]> stop appnode MySecondAppNode

Result

Before stopping the second AppNode, the application is active on both the nodes. After
stopping the second AppNode, the application is active only on the first AppNode. See the
bwappnode. log file to monitor the messages processed by AppNodel.

Invoking Subprocesses

In this sample, the MakeNoise process calls the Invoke subprocess multiple times which in
turn calls another subprocess Log.

Note: If accessing the sample from the Welcome page of TIBCO Business
Studio™ for BusinessWorks™, go directly to Step 3.

Procedure

1. In the samples directory, select core > soa > CallProcessAndinvoke and double-
click tibco.bw.sample.core.soa.CallProcessAndinvoke. For more information, see
Accessing Samples.

2. In the Project Explorer, expand the
tibco.bw.sample.core.soa.CallProcessAndInvoke project.

3. Set the default application profile to match the OS you are running on. For more
information, see Setting the Default Application Profile.
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>

Fully expand the Processes directory and double-click MakeNoise.bwp.
5. Click Run > Debug Configurations.

6. At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

7. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.core.soa.CallProcessAndinvoke.

8. Click Debug.

This runs the sample in Debug mode.

9. Click the Terminate icon to stop the process.

Result

The output.log file is generated in the C:\tmp\CallProcessAndInvoke directory. This file
contains output from MakeNoise process and Log sub process.

The Console shows the following response:
ECHO: 1:41:56 PM

Echo
ECHO: 1:41:59 PM
Echo
ECHO: 1:42:02 PM

Echo

Understanding the Configuration

This is a hands-on and simple demonstration for the Design time experience with simple
Invoke services. The MakeNoise process calls the Invoke process with a single operation
and a simple string message. The Invoke process simply returns the Input as the Output.
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Dynamically Invoking Subprocesses Using
SetEPR Activity

This sample illustrates the Dynamic Invocation of the Subprocess using Set EPR activity.
The Set EPR activity generates the Endpoint Reference and determines the service to be
invoked at runtime. In this sample, the Service Consumer and Service provider reside in
different applications.

Setup

Import the sample project into the workspace. Ensure that both applications are in the
workspace. For more information, see Accessing Samples.

Description of the Project

This sample comprises two applications. Service Provider (Provider.bwp) and Service
Consumer (Consumer.bwp).

» The Service Consumer invokes the service using Dynamic Process Reference, which is
located in the Service Provider application.

e Service Consumer has one process, Consumer.bwp. This process has the Dynamic
Reference to the Service. The Consumer process contains a Sleep activity which
ensures that consumer waits to invoke the service, till the service gets deployed and
is ready to process the request.

e Service Provider has one process, Provider.bwp. This process uses the Hello.wsdl
file to implement the service and sends a response message to the incoming request.

o Note: Every application requires at least one component to deploy the
application. In this sample, the Activator.bwp process is used in the service
provider application for the Provider.bwp to be deployed without configuring
the binding.

The following image shows the configuration details of the Set EPR activity in the
Consumer.bwp.
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The following image shows the details of consumer using the Dynamic Process Reference
as the Reference Type.
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Procedure

1.

In the samples directory, select core > dynamic > processinvocation and double-
click tibco.bw.sample.core.dynamic.processinvocation.ServiceConsumer.

In Project Explorer, expand the
tibco.bw.sample.core.dynamic.processinvocation.ServiceConsumer project.

Fully expand the Processes directory and click Consumer.bwp.
Click Run > Debug Configurations.

At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication

Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select
tibco.bw.sample.core.dynamic.processinvocation.ServiceConsumer and
tibco.bw.sample.core.dynamic.processinvocation.ServiceProvider applications.

Click Debug.
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8.

This runs the sample in a Debug mode.

Click the Terminate [® icon to stop the process.

Troubleshooting

If the service consumer starts before the service provider, then increase the value in the
Sleep activity in the Consumer.bwp.

Calling a Direct Subprocess

In this sample, the MainProcess process uses the call Process activity to call two direct
subprocesses. One subprocess creates a list of movies, and the other subprocess either
uses the genre of the movie to determine how to log it, or returns the name of the current
movie.

Note: If accessing the sample from the Welcome page of TIBCO Business
Studio™ for BusinessWorks™, go directly to Step 3.

Procedure

1.

In the samples directory, select core > soa > DirectCallProcess and double-click
tibco.bw.sample.core.soa.DirectCallProcess. For more information, see Accessing
Samples.

In the Project Explorer view, expand the
tibco.bw.sample.core.soa.DirectCallProcess.readme project.

Set the default ApplicationProfile to match the OS you are running on. For more
information, see Setting the Default Application Profile.

Fully expand the Processes directory and double-click MainProcess.bwp.
Click Run > Debug Configurations.

At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
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tibco.bw.sample.core.soa.DirectCallProcess.
8. Click Debug.

This runs the sample in Debug mode.

9. Click the Terminat icon to stop the process.

Result

The output. log file is generated in the C:\tmp\CallProcess\ActionMovie. txt directory.
This file contains output from the ActionMovielList direct subprocess and OtherMoviesList
direct subprocess.

Understanding the Configuration

This is a hands-on and simple demonstration for the design time experience with the direct
subprocess. The MainProcess.bwp process creates a list of movies, then according to the
movie genres, calls a direct subprocess to either log outputs to a text file, or to return the
name of the current movie.

Collecting Process, Activity, and Transition
Statistics

In this sample, use the tibco.bw.sample.application.execution.event.subscribe sample
to collect statistics for process instances, activity instances, and transitions in the
tibco.bw.sample.palette.http.RequestResponse sample project.

When working this sample, any of the following application statistics can be collected.

Process Instance Statistics

Statistic Description
Application Name of the application.
Name
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Statistic

Application
Version

Module Name

Module
Version

Component
Process Name

Job ID

Parent
Process Name

Parent
Process ID

Process Name

Process
Instance ID

Start Time
End Time

Elapsed Time

Description

Version of the application.

Name of the module.

Version of the module.

Name of process configured to a component. If the process is a non in-lined
sub process, this could be empty.

Job ID of the process.

If the process is an in-lined sub process, the name of the parent process.

If the process is an in-lined sub process, the instance ID of the parent
process.

Name of the process.

Instance ID of the process.

Process instance start time.
Process instance end time.

Elapsed time of an activity is the time difference (in milliseconds) between
start time and end time of the activity. Between the start and end time,
control may get switched with other activities from the other jobs. This is the
time taken to execute an activity plus all the delays in acquiring resources
like engine threads, JDBC connections, network, and so on.

The elapsed time includes the execution time plus time taken for evaluating
all the forward transitions from that particular activity and getting the next
activity ready to execute, which includes executing its input mapping if all
dependencies are met.
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Statistic

Eval Time

Status

Description
The Eval Time for an activity is the actual time (in milliseconds) used by the
activity itself to complete while using the engine thread. Asynchronous

activities may use other threads not included in this time.

Status of process instance, for example: Completed or Faulted.

Activity Instance Statistics

Statistic

Application
Name

Application
Version

Module Name

Module
Version

Activity Name
Process Name

Process
Instance ID

Start Time
End Time

Eval Time

Description

Name of the application.

Version of the application.

Name of the module.

Version of the module.

Name of the activity.
Name of the process.

Instance ID of the process.

When the activity instance started.

When the activity instance ended.

The time between the beginning and end of the evaluation period for the
activity. If the activity completes in one step, the evalTime and elapsedTime

would be the same. However, some activities, such as Request, Reply, or
Wait for... activities typically do not complete in one step.
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Statistic

Elapsed Time

Status

Description

Elapsed time of an activity is the time difference (in milliseconds) between
start time and end time of the activity. Between the start and end time,
control may get switched with other activities from other jobs.

This is the time taken to execute an activity plus all the delays in acquiring
resources like engine threads, JDBC connections, network, and so on.

The elapsed time is Eval Time plus the time taken for evaluating all the
forward transitions from that particular activity.

Status of activity, for example: Completed, Faulted or Canceled.

Transition Statistics

Statistic

Description

Application Name Name of the application.

Application
Version

Module Name
Module Version
Transition Name
Process Name

Process Instance
ID

Component
Process Name

Target Activity
Name

Version of the application.

Name of the module.

Version of the module.

Name of the transition

Name of the process.

Instance ID of the process.

Name of process configured to a component. If the process is a non in-
lined subprocess, this could be empty.

Name of the activity the transition targets.
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Procedure

1.

10.

11.

12.

Import the sample into TIBCO Business Studio™ for BusinessWorks™ by right-clicking
in the Project Explorer pane, and selecting Import > Existing Studio Projects into
Workspace.

In the Import Projects window, ensure the option Select root director field is
selected, and specify the location of the
tibco.bw.sample.application.execution.event.subscribe sample. The sample is
located at BwW_HOME /samples/source/event-
subscriber/tibco.bw.sample.application.execution.event.subscriber.

Click Finish to import the sample project.

In the samples directory, select palette > http > RequestResponse and double-click
tibco.bw.sample.palette.http.RequestResponse.zip. For more information, see
Accessing Samples.

In Project Explorer expand the tibco.bw.sample.palette.http.RequestResponse
project.

Fully expand the Processes directory and double-click HTTP_Request_Response_
Example.bwp.

Click Run > Debug Configurations.

At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.palette.http.RequestResponse.application.

Click the Bundles tab and ensure the following bundles in your workspace are
selected:

o tibco.bw.sample.application.execution.event.subscriber (1.0.0.qualifer)

¢ tibco.bw.sample.palette.http.RequestResponse (1.0.0.qualifer)

o tibco.bw.sample.palette.http.RequestResponse.application (1.0.0.qualifer)
Click Debug.

This runs the sample in Debug mode.

Run lendpoints at the prompt in the Console tab to obtain the endpoint for the
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application.
13. Copy the endpoint URL of the application.
14. Open a browser window, and paste the endpoint URL into the address bar.

15. Click the Terminatel® icon to stop the process.

Result

Details about process instances, activity instances, and transitions in
tibco.bw.sample.palette.http.RequestResponse are displayed on the Console tab in
TIBCO Business Studio for BusinessWorks.

<>@BWEclipseAppNode>
ProcessInstance Auditing Event {
Application
Name:tibco.bw.sample.palette.http.RequestResponse.application
Application Version:1.0
Module Name:tibco.bw.sample.palette.http.RequestResponse
Module Version:1.0.0.qualifier
ProcessInstanceId:bw0aloo
Process Name:tibco.bw.sample.palette.http.requestresponse.HTTP_Request_
Response_Example
State:SCHEDULED
}

ProcessInstance Auditing Event {
Application
Name:tibco.bw.sample.palette.http.RequestResponse.application
Application Version:1.0
Module Name:tibco.bw.sample.palette.http.RequestResponse
Module Version:1.0.0.qualifier
ProcessInstanceId:bw0aloo
Process Name:tibco.bw.sample.palette.http.requestresponse.HTTP_Request_
Response_Example
State:STARTED
}

Activity Auditing Event {

Application
Name:tibco.bw.sample.palette.http.RequestResponse.application

Application Version:1.0

Module Name:tibco.bw.sample.palette.http.RequestResponse

Module Version:1.0.0.qualifier

ProcessInstanceId:bw0aloo

Process Name:tibco.bw.sample.palette.http.requestresponse.HTTP_Request_
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Response_Example
Activity Name:Incoming_HTTP_Request
State:STARTED

}

Transition Auditing Event {

Application
Name:tibco.bw.sample.palette.http.RequestResponse.application

Application Version:1.0

Module Name:tibco.bw.sample.palette.http.RequestResponse

Module Version:1.0.0.qualifier

ProcessInstanceId:bw0aleo

Process Name:tibco.bw.sample.palette.http.requestresponse.HTTP_Request_
Response_Example

Activity Auditing Event {

Application
Name:tibco.bw.sample.palette.http.RequestResponse.application

Application Version:1.0

Module Name:tibco.bw.sample.palette.http.RequestResponse

Module Version:1.0.0.qualifier

ProcessInstanceId:bw0aloo

Process Name:tibco.bw.sample.palette.http.requestresponse.HTTP_Request_
Response_Example

Activity Name:Incoming_HTTP_Request

State:COMPLETED

}

Activity Auditing Event {
Application
Name:tibco.bw.sample.palette.http.RequestResponse.application
Application Version:1.0
Module Name:tibco.bw.sample.palette.http.RequestResponse
Module Version:1.0.0.qualifier
ProcessInstanceId:bw0aleo
Process Name:tibco.bw.sample.palette.http.requestresponse.HTTP_Request_
Response_Example
Activity Name:Logl
State:STARTED
}
22:25:19.463 INFO [bwEngThread:In-Memory Process Worker-1]
c.t.b.p.g.L.t.b.s.p.h.R.Logl - No matching 'NEWS' source found.

Activity Auditing Event {
Application
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Name:tibco.bw.sample.palette.http.RequestResponse.application

Application Version:1.0

Module Name:tibco.bw.sample.palette.http.RequestResponse

Module Version:1.0.0.qualifier

ProcessInstanceId:bw0aleo

Process Name:tibco.bw.sample.palette.http.requestresponse.HTTP_Request_
Response_Example

Activity Name:lLogl

State:COMPLETED
}

ProcessInstance Auditing Event {

Application
Name:tibco.bw.sample.palette.http.RequestResponse.application

Application Version:1.0

Module Name:tibco.bw.sample.palette.http.RequestResponse

Module Version:1.0.0.qualifier

ProcessInstanceId:bw0aloo

Process Name:tibco.bw.sample.palette.http.requestresponse.HTTP_Request_
Response_Example

State:COMPLETED
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Tip: You can use this sample to build your own application statistics collection
tool. Follow these steps to do this:

1. From the Project Explorer tab, select
tibco.bw.sample.application.execution.event.subscriber > src >
tibco.bw.sample.application.execution.event.subscriber >
BWEventSubscriber.java.

2. Update handleEvent(Event event) method based on your use case.
3. Save your changes to the project.

4. Export the project as a plug-in by right-clicking on
tibco.bw.sample.application.execution.event.subscriber and selecting
export > Export > Plug-in Development > Deployable plug-ins and
fragments.

5. In the Export wizard, ensure the
tibco.bw.sample.application.execution.event.subscriber project is
selected, and specify a location to export the plug-in.

6. After the project has been exported as a JAR file to the location you
specified, locate the JAR file in the plugins folder, and copy and paste it to
the shared folder at BW_HOME /system/hotfix/shared.

7. To load this plug-in into runtime, restart any running AppNodes.

Your application statistics collection tool has been added to your runtime
environment.
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Policy Feature

This section includes a set of samples that demonstrate how to enforce security policies to
services and bindings.

Enforcing Basic Authentication with LDAP
Authentication

This sample describes how access to an HTTP service can be managed by enforcing Basic
Authentication on a process starter activity. In this sample, the Basic Authentication Policy
is associated with the HTTP Receiver Activity and configured to verify user credentials
using LDAP authentication.

Before you begin
You must be connected to an LDAP server and have user and group information stored in
that server.

Procedure
1. In the samples directory, select policy > basicauthentication > HTTPReceiver and
double-click tibco.bw.sample.policy.basicauthentication.HttpReceiver.zip. For
more information, see Accessing Samples.

2. In the Project Explorer view, expand the
tibco.bw.sample.policy.basicauthentication.HttpReceiver.zip project.

3. In the Project Explorer view, click Resources >
tibco.bw.sample.policy.basicauthentication.httpReceiver >
defaultLdapProvider.ldapResource.

4. Fully expand the Processes directory and double-click HttpReceiverProcess.bwp.

5. In the Resource Editor, configure the following properties in the LDAP
Authentication section under the Connection tab:
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e Server URL: LDAP Server Location, such as, 1dap://localhost:389

» User Search Expression: search expression for the user, such as (&(cn={0])
(objectclass=user))

e User DN Template: user distinguished name template, such as cn=
{0},cn=users,dc=na,DC=tibco,DC=com

6. Set the default ApplicationProfile to match the OS you are running on. For more
information, see Setting the Default Application Profile.

7. Fully expand the Processes directory and double-click HttpReceiverProcess.bwp.
8. Click Run > Debug Configurations.

9. At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

10. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.policy.basicauthentication.HttpReceiver.application.

11. Click Debug.
This runs the sample in Debug mode.

12. Launch Google Chrome browser and enter the following URL
http://localhost:9393/request.

The Google Chrome page displays a window asking you to enter your user name and

password.

Authentication Required - u
@_. Enter username and password for http://localhost:9393
User Marne: |

Passwaord:
[ 0K ] ’ Cancel I

13. Enter your LDAP user name and password and click OK.

Result

After the request is authenticated successfully, the following message displays in the
browser:

This is from HTTP Receiver Process. The request is successful.
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Understanding the Configuration

In the HttpReceiverProcess.bwp process, the Basic Authentication policy is configured to
verify user credentials using LDAP Authentication and is associated with the HTTP Receiver
activity.

Enforcing Basic Authentication on a REST
Service Binding

In this sample, the Basic Authentication policy is enforced on a REST service. The REST
service uses the GET method to retrieve information from a file stored on your local
machine.

Procedure

1.

In the samples directory, select policy > basicauthentication > RestBinding and
double-click tibco.bw.sample.policy.basicauthentication.RestBinding.zip. For
more information, see Accessing Samples.

In Project Explorer expand the
tibco.bw.sample.policy.basicauthentication.restbinding project.

Fully expand the Processes directory and double-click RestBindingProcess.bwp.

Set the default ApplicationProfile to match the OS you are running on. For more
information, see Setting the Default Application Profile.

Click Run > Debug Configurations.

At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.policy.basicauthentication.RestBinding.application.

Click Debug.

This runs the sample in Debug mode.

Launch a REST client, such as Postman Extension, on Chrome, and enter the request
URL, for example http://localhost:7777/resources, in the Enter request URL here
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10.
11.
12.
13.

field.

Builder (Y “ @ smin | £

No environment » e

Authorization Headers (0} Pre-request script Tests </ 5

New tab

Basic Auth v

Username : The authorization header viill be

Password

show Password

Save helper data to request

Click the GET operation.
Enter your user name and password under the BasicAuth section.
Click Update Request.

Click Send to test your application.

Result
GET books returns an output similar to the following:

<?xml version="1.0"?>
<purchaseOrder xmlns="http://tempuri.org/po.xsd" orderDate="1999-10-20">

<shipTo country="US">
<name>Alice Smith</name>
<street>123 Maple Street</street>
<city>Mill Valley</city>
<state>CA</state>
<zip>90952</zip>
</shipTo>
<billTo country="US">
<name>Robert Smith</name>
<street>8 0ak Avenue</street>
<city>0ld Town</city>
<state>PA</state>
<zip>95819</zip>
</billTo>
<comment>Hurry, my lawn is going wild!</comment>
<items>
<item partNum="872-AA">
<productName>Lawnmower</productName>
<quantity>1</quantity>
<USPrice>148.95</USPrice>
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<comment>Confirm this is electric</comment>

</item>

<item partNum="926-AA">
<productName>Baby Monitor</productName>
<quantity>1</quantity>
<USPrice>39.98</USPrice>
<shipDate>1999-05-21</shipDate>

</ditem>

</items>
</purchaseOrder>

Understanding the Configuration

In this sample, a Basic Authentication policy is associated with the REST service binding
and configured to verify user credentials using an XML Authentication resource.

The XML Authentication resource references an XML file that contains information about
users, groups, and roles. A user is a person with an authenticated credentials. A group is a
collection of users. Roles can be assigned to users to grant them permission to perform a
collection of tasks. Authorization, or permission, to access services can be assigned to both
users and groups.

In this sample, an XML file is within workspace. The content of the XML file used by the XML
Authentication resource is shown below.

<?xml version="1.0" encoding="UTF-8"?7>

<realm xmlns="http://xsd.tns.tibco.com/trinity/realm/2013"
hashAlgorithm="PBKDF2WithHmacSHA256" repetitionCount="10240"
xsi:schemalLocation="http://xsd.tns.tibco.com/trinity/realm/2013
Realm.xsd" xmlns:xsi="http://www.w3.0rg/2001/XMLSchema-instance">

<users>

<user>
<name>john</name>
<plaintext>password</plaintext>
<!-- attributes are optional -->
<attribute name="some-name" oid="some:thing">some-
value</attribute>
</user>
<user>
<name>alex</name>
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<plaintext>password</plaintext>
</user>

</users>

<group-mapping>
<group-name>managers</group—name>
<user-name>alex</user—-name>

</group-mapping>

<group-mapping>

<group-name>administrators</group-name>

<user-name>alex</user-name>

<user-name>john</user—-name>
</group-mapping>

</realm>

Enforcing Basic Credential Mapping on an
Outbound Request

In this sample, basic credential mapping is enforced when InvokeRestApiProcess.bwp
process makes a client call to the RestBindingProcess.bwp process.

Procedure

1

In the samples directory, select policy > basiccredentialmapping > InvokeRestAPI
and double-click
tibco.bw.sample.policy.basiccredentialmapping.InvokeRestAPl.zip. For more
information, see Accessing Samples.

In Project Explorer expand the
tibco.bw.sample.policy.basiccredentialmapping.InvokeRestAPI project.

Fully expand the Processes directory and double-click InvokeRestApiProcess.bwp
and RestBindingProcess.bwp.

Set the default ApplicationProfile to match the OS you are running on. For more
information, see Setting the Default Application Profile.

Click Run > Debug Configurations.
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6. At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

7. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.policy.basiccredentialmapping.InvokeRestAPl.application.

8. Click Debug.

This runs the sample in Debug mode.

Result
The client is successfully invoked and the file invokeRest.log is generated at C:\tmp\policy
on a Windows system, or at /tmp/policy on a Unix system.

Understanding the Configuration

The following processes interact with each other in this project:

» RestBindingProcess.bwp: To ensure the message received from
InvokeRestApiProcess is sent by an authenticated user, the service side of this
process is associated with a Basic Authentication policy that is configured with XML
file authentication. The XML file is included in the sample project and stored in your
workspace.

* InvokeRestApiProcess.bwp: To ensure credentials are provided in the request
message sent to RestBindingProcess, a Basic Credential Mapping policy configured
for fixed credential mapping is associated with the InvokeRESTAPI activity in this
process.

Enforcing SOAP Security to Enable
Confidentiality and Integrity on Message
Exchanges

This sample describes how WSS Provider and WSS Consumer policies can be enforced on
SOAP/HTTP message exchanges to ensure confidentiality and integrity.
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In this sample, the following processes communicate with each other:
e ServiceProvider.bwp: Provides a SOAP service.

e ServiceConsumer.bwp: Consumes the SOAP service provided by the ServiceProvider
process.

Also service provider asks to decrypt message from consumer and verify signature of
consumer.

Before you begin

Procedure
1. In the samples directory, select policy > confidentialityintegrity > SoapHttp and
double-click tibco.bw.sample.policy.confidentialityintegrity.SoapHttp.zip. For
more information, see Accessing Samples.

2. In Project Explorer expand the
tibco.bw.sample.policy.confidentialityintegrity.SoapHttp project.

3. Set the default ApplicationProfile to match the OS you are running on. For more
information, see Setting the Default Application Profile.

4. Click Run > Debug Configurations.

5. At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

6. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.policy.confidentialityintegrity.SoapHttp.

7. Click Debug.

This runs the sample in Debug mode.

Result
The ServiceConsumer process successfully calls the ServiceProvider process.

The file ConfidentialityIntegrity.txt is generated in the C:\tmp\policy directory on Windows
platform, or /tmp/policy directory on Unix platform.
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Open the ConfidentialityIntegrity.txt file in a text editor. The default contents of the
file are outlined below.

The Request From Service Consumer: Bob The Response from Service
Provider:
Welcome you Bob

Understanding the Configuration

The following processes interact with each other in this project:

» ServiceProvider.bwp: To ensure decryption and signature verification on the
incoming request message, a WSS Provider policy configured for confidentiality and
integrity is associated with the service side of this process.

» ServiceConsumer.bwp: To ensure the outbound request message to ServiceProvider
is encrypted and signed, a WSS Consumer policy configured for confidentiality and
integrity is associated with the reference side of this process.

Enforcing SOAP Security to Enable SAML
Authentication and SAML Credential Mapping

In this sample, SOAP message exchanges are secured with SAML Credential Mapping, user
name token-based authentication, and SAML authentication.
The following processes communicate with each other in this sample:

» ClientProcess.bwp: Simulates a client call to Process1 to request a response from
Processl

¢ Processl.bwp: Calls Process2

e Process2.bwp: Returns a response to Processl

Procedure

1. In the samples directory, select policy > samlcredentialmapping > SoapHttp and
double-click tibco.bw.sample.policy.samlcredentialmapping.SoapHttpBinding.zip.
For more information, see Accessing Samples.
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2. In Project Explorer expand the
tibco.bw.sample.policy.samlcredentialmapping.SoapHttpBinding project.

3. Set the default ApplicationProfile to match the OS you are running on. For more
information, see Setting the Default Application Profile.

4. Click Run > Debug Configurations.

5. At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

6. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
ttibco.bw.sample.policy.samlcredentialmapping.SoapHttpBinding.application.

7. Click Debug.

This runs the sample in Debug mode.

Result
Processl call Process2 successfully

The file SamlCredentialMapping.txt is generated in the C:\tmp\policy directory on Windows
platform, or /tmp/policy directory on Unix platform.

Open the SamlCredentialMapping.txt file in a text editor. The default contents of the file
are outlined below.

Congratulations! This 1is response from Process2. SAML request is
successful!

Understanding the Configuration

The following processes interact with each other in this project:

e Process2.bwp: The service side of Process2 is associated with a WSS provider policy
configured for SAML authentication.

* Processl.bwp: To ensure the outbound request to Process2 contains the credentials
authenticated in Processl, the following policies are enforced on Process1:

°© A WSS Consumer policy configured for SAML credential mapping is associated
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on the reference side.

° A WSS Provider policy configured for user name token authentication is
associated with the service side.

» ClientProcess.bwp: To simulate a client call to Process1, a WSS Consumer policy,
configured for user name token credential mapping, is associated with the reference
side of ClientProcess.

Exposing Security Context

This sample describes how to expose the security context on SOAP/HTTP. In this sample,
the following processes communicate with each other:

e Provider.bwp: Provides a SOAP service.

e Consumer.bwp: Consumes the SOAP service provided by the Provider process.

The service provider verifies the signature on request.

Procedure

1. In the samples directory, select policy > exposesecuritycontext > SoapHttp and
double-click tibco.bw.sample.policy.soap.exposesecuritycontext.module.zip. For
more information, see Accessing Samples.

2. In the Project Explorer pane, expand the
tibco.bw.sample.policy.soap.exposesecuritycontext.module.

3. Set the default application profile to match the OS you are using. For more
information, see Setting the Default Application Profile.

4. Click Run > Debug Configurations.

5. At the left tree of Debug Configuration wizard, expand BusinessWorks Application
and select BWApplication.

6. Click the Applications tab and click the Deselect All button if you have multiple
applications.

7. Select the check box next to
tibco.bw.sample.policy.soap.exposesecuritycontext.module.application.

8. Click Debug. This runs the sample in the Debug mode.
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Result
The ServiceConsumer process successfully calls the ServiceProvider process.

The file exposeSecurityContext.txt is generated in the c:\tmp\policy directory on the
Windows platform, or /tmp/policy directory on the Unix platform.

Open the exposeSecurityContext.txt file in a text editor. The default contents of the file
are outlined below:

The Response from Service Provider:

Welcome you Bob

Understanding the Configuration

The following processes interact with each other in this project:

» Provider.bwp: To ensure the signature verification in the incoming request message,
a WSS Provider policy configured for integrity is associated with the service side of
this process. Get Context Activity is used to expose Security (WSSE) context
parameters.
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{3 Consumer.bwp [@ Provider.bwp 2

tibco.bw.sample.policy.soap.exposesecuritycontext. module. Provider

Q 3 -8

operationin GetContext operationOut

e Consumer.bwp: To ensure the outbound request message to Provider is signed, a
WSS Consumer policy configured for integrity is associated with the reference side of
this process.
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£33 Consumerbwp 52 |@ Provider.bwp |
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Palettes Features

This section shows the use of palette activities by providing samples for using JAVA HTTP.

Creating an Order Processing Service

This sample describes a simple order processing service where a File Poller activity waits
for the BW_new_order.xml file to be updated. After an update is detected, the process
creates an empty approval file and calls a sub process to calculate the shipping costs. The
process then waits for the empty approval file to be updated. Finally, the BW_customer_
notification.txt file with data in XML format is created in the c:\tmp\OrderProcessing
folder of the default location, or the path you specified earlier that gives the customer the
relevant shipping information.

In a real system, tasks such as database queries, email acknowledgment, and so on would
be used to implement this scenario. However, we have chosen to use files for this service
to highlight the use of the activities in the file palette.
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Note: If you are accessing the sample from the Welcome page of TIBCO
Business Studio™ for BusinessWorks™, go directly to Step 3.

TIBCO ActiveMatrix BusinessWorks™ Samples



160 | Palettes Features

Procedure
1. In the samples directory, select palette > file > OrderProcessing and double-click
tibco.bw.sample.palette.file.orderprocessing. For more information, see Accessing
Samples.

2. In the Project Explorer view, expand the
tibco.bw.sample.palette.file.orderprocessing project.

3. Set the default ApplicationProfile to match the OS you are running on. For more
information, see Setting the Default Application Profile.

4. Fully expand the Processes directory and double-click ProcessOrder.bwp.
5. Click Run > Debug Configurations.

6. At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

7. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.palette.file.orderprocessing.application.

8. Click Debug.

This runs the sample in Debug mode.

9. Click the Terminatel icon to stop the process.

Result
The BW_customer_notification.txt output file at C:\tmp\OrderProcessing should have
the following content:

Hank Hill,
Your order has been approved
The cost is as follows,
Purchase cost : $123
Shipping costs : $40
Total Cost : $163Hank Hill,
Your order has been delayed due to problems
We will contact you at your Arlen address with further
Regards,
TIBCO Software Inc.

The BW_approve_order. txt file is deleted.
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Understanding the Configuration

The following file names are defined as Module Properties and can be changed in the
Module Properties dialog.

e BW_new_order.xml points to the XML file that contains the new order details and
triggers the process initially as Include Existing Files check box option is selected.
For consecutive triggers, the file must be updated (overwritten or modified) each
time for the sample process to run or the process does not start.

e BW_shipping_costs.xml contains shipping cost information.

e BW_customer_notification.txt is created by the process to notify the customer of
the complete shipping details.

* BW_approve_order.txt is created by the process. The file is deleted during process
execution.

Using FTP to Put and Get Files

This sample service invokes the FTP put and get commands. The service reads a file and
places it on the specified FTP server. The FTP get command is issued after a short pause
and the file contents are written back to the local storage.

1=l tibcobw.samplepalette fip putandget.FTP_Put_and_Get

i My 5 [T Iy b
— FTP3 —» .-j. e 5'?5 e

FilePoller FTPPut Slttp FTPGet WriteFile

Before you begin

Copy the ftp_put_file.log file included in this sample to the c:\tmp directory. If the
directory is not available, see the steps listed in the Understanding the Configuration
section.

Ensure that the following FTP server information is available:
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FTP server name or IP address

FTP server port (default is 21)

FTP username

FTP user password

Procedure
1. In the samples directory, select palette > ftp > PutAndGet and double-click
tibco.bw.sample.palette.ftp.PutAndGet. For more information, see Accessing
Samples.

2. In Project Explorer expand the tibco.bw.sample.palette.ftp.PutAndGet project.

3. Set the default ApplicationProfile to match the OS you are running on. For more
information, see Setting the Default Application Profile.

4. Copy the ftp_put_file.log file to c:\tmp.

5. Fully expand the Resources directory and then double-click
FTPConnectionResource.ftpResource. Specify valid values for your FTP connection
in the Host, Port, User Name, and Password fields. Click Test Connection to verify
your FTP connection.
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6. Click File > Save.

7. Fully expand the Processes directory and double-click FTP_Put_and_Get.bwp.
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8. Click Run > Debug Configurations.

9. At left hand tree of Debug Configuration wizard, expand BusinessWorks Application
and select BWApplication.

10. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.palette.ftp.PutAndGet.application.

11. Click Debug.

This runs the sample in Debug mode.

12. Monitor the log/trace and after a minute, verify whether the PutAndGet. log file has
been created at c:\tmp\PutAndGet.

13. Click the Terminate® icon to stop the process.

Result

e The file specified by the module property BW_ftp_put_file is copied to the FTP
server.

* The file specified by the module property BW_ftp_get_file is written to
c:\tmp\PutAndGet by the FTP server. The default name is PutAndGet. log.

Understanding the Configuration

The sample project has default values for the file names. You can change the defaults, if
needed for your environment.

1. Under Module Descriptors, click the configuration file.
2. Modify BW_ftp_put_file to point to the input file.

3. Modify BW_ftp_get_file to point to the output file that is written to on disk.
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Using HTTP to Send and Receive Dynamic
Headers

A request is sent to the server by the client. The server accepts the request and the HTTP
connection is then closed by the response activity. Dynamic headers are added on both the
client request and server's response.

The server process listens for requests and sends a response from the server.

[i]

tibco bw.sample.palette. http.dynamicheaders.ynamicHeadersServerProcess

0

HTTPRecenver WriteFile SendHTTPResponse

The client process sends a request to the server.

i

tibco.bw.sample.palette.http.dynamicheaders.DynamicHeadersClientProcess

Q—e -7

Timer SendHTTPRequest WriteFile

Procedure

1.

o

In the samples directory, select palette > http > DynamicHeaders and double-click
tibco.bw.sample.palette.http.DynamicHeaders. For more information, see
Accessing Samples.

In Project Explorer expand the tibco.bw.sample.palette.http.DynamicHeaders
project.

Fully expand the Processes directory and double-click
DynamicHeadersClientProcess.bwp.

Click Run > Debug Configurations.

At the left hand tree of Debug Configuration wizard, expand BusinessWorks
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Application and select BWApplication.

6. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.palette.http.DynamicHeaders.application.

7. Click Debug.

This runs the sample in Debug mode.

8. Click the Terminatel®l icon to stop the process.

Result
the following output:

Headers Received at the Server Side are:
content-type:text/plain
content-typelfound_ContentTypel_firstTime
content-typelfound_ContentTypel_SecondTime
arraydata2

arraydatal

arraydata3

Headers Received at the Client Side are:
HTTP/1.1 200 OK

Content-Type: text/plain

Content-Length: 12

server: Jetty(8.1.16.v20140903)
testing-mydata: Done Setting data
testing-mydata: Done Setting Dynamic Value
company: TIBCO India Pvt Ltd

company: TIBCO Inc, USA
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Understanding the Configuration

The ListeningHTTPConnection and RequestingHTTPConnection connections are defined
to listen on port 13009. To change the port, specify a new Port value in the Module
Properties dialog. You can also change the default location of the OUTPUT_FILE file, by
specifying it in the Module Properties dialog.

The Incoming HTTP Request process starter listens on the connection specified by the
ListeningHTTPConnection shared resource.

In the DynamicHeadersClientProcess, the ArrayData element in the Input Editor of the
Send HTTP Request activity has Cardinality defined as Repeating. The dynamic header
value for the same is provided from the Input tab under the DynamicHeaders element.

The dynamic headers Content-Typel and Content-Type are defined under the same.

In DynamicHeadersServerProcess, the Testing-MyData element in the Input Editor of the
Send HTTP Response activity has Cardinality defined as Repeating. The dynamic header
value for the same is provided from the Input tab under the DynamicHeaders element.
The dynamic headers StatusLine and Company are defined under the same.

The Send HTTP Request activity sends the request to the server. The HTTP Receiver
activity accepts the request. The Send HTTP Response activity closes the HTTP connection
that has been established by the Incoming HTTP Request process starter.

HTTP Sending and Receiving MIMEAttachments

This sample shows how the HTTP Receiver, HTTP Response, and HTTP Request activities
can be used to send MIME attachments over HTTP.

The sample proceeds as follows:
e The Client process sends a HTTP Request with three attachments.

e The Server process responds with a HTTP Response with two attachments.

Before you begin
Copy the TIBCO_HOME\bw\n.n\samples\palette\http\MIMEAttachment\attachmentl.gif
file to the c:\tmp folder on Windows or the /tmp folder on UNIX.

Procedure
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1. In the samples directory, select palette > http > MIMEAttachment and double-click
tibco.bw.sample.palette.http.MIMEAttachment. For more information, see
Accessing Samples.

2. In Project Explorer expand the tibco.bw.sample.palette.http.MIMEAttachment
project.

3. Fully expand the Processes directory and double-click Client.bwp.
4. Click Run > Debug Configurations.

5. At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

6. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.palette.http.MIMEAttachment.application.

7. Click Debug.

This runs the sample in the Debug mode.

8. Click the Terminatel®l icon to stop the process.

Result
[Server] Received attachment of content-type: application/octet-stream

[Server] Received attachment of content-type: image/gif
[Server] Received attachment of content-type: text/plain
[Server] Received attachment of content-type: image/gif
Reply sent with attachment

[Client] Received attachment of content-type=: text/plain

[Client] Received attachment of content-type=: image/gif

Understanding the Configuration

The client process sends a HTTP Request with following three attachments:
o textContent

e binaryContent
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 fileName
The server process responds with a HTTP Response with following two attachments:

e textContent

e binaryContent

Using HTTP or SOAP to Get Information from
MySQL

Several processes are defined that show how to get information from MySQL and Sakila,
which is a sample database (included with MySQL) that has default schemas and tables.

Before you begin
Ensure to install JDBC Drivers for Design time and Run time.

For more information about a JDBC Connection shared resource, see the "JDBC
Connection" section in the TIBCO ActiveMatrix BusinessWorks™ Bindings and Palettes
Reference guide.

Procedure
1. In the samples directory, select palette > http > MultiEndpointApp and double-click
tibco.bw.sample.palette.http.MultiEndpointApp. For more information, see
Accessing Samples.

2. In Project Explorer expand the tibco.bw.sample.palette.http.MultiEndpointApp
project.

3. Fully expand the Resources directory and then double-click
HTTPConnectorResource.httpConnResource. Verify that the Host and Port values
are correct.

4. Double-click JDBCConnectionResource.jdbcResource and verify the database
connection properties. Click the Test Connection button to verify your database
configuration.

5. Fully expand the Processes directory and double-click ActorService.bwp,
FilmService.bwp, or SakilaService.bwp.

TIBCO ActiveMatrix BusinessWorks™ Samples



169 | Palettes Features

6. Click Run > Debug Configurations.

7. At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

8. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.palette.http.MultiEndpointApp.application.

9. Click Debug.

This runs the sample in Debug mode.

10. Click the Terminatel® icon to stop the process.

Result
Actor Name: CUBA OLIVIER

Film Title: ALIEN CENTERDescription: A Brilliant Drama of a Cat And a Mad Scientist who
must Battle a Feminist in A MySQL Convention CUBA OLIVIER

Understanding the Configuration

Three processes are defined:

e ActorService Process: contains the HTTP Receiver requests the input query to
retrieve actor information using JDBC Query Activity. The response is provided back
to HTTP Response activity.

» FilmService Process: this process has logic similar to the ActorServer process to
fetch film information using the JDBC Query activity.

» SakilaService Process: returns the actor information using the SOAP service, which
invokes a JDBC Query and returns the result.

Using the HTTP Persistent Connection Feature

The PersistentConnectionClientProcess sends five simultaneous HTTP requests. Each
SendHttpRequest activity in the PersistentConnectionClientProcess is configured with a
ClientPCMConnection shared resource. The HttpReceiver in ServerProcess listens on
connection specified by ServerConnection shared resource.
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Procedure

1. In the samples directory, select palette > http > PersistentConnection and double-
click tibco.bw.sample.palette.http.PersistentConnection. For more information,
see Accessing Samples .

2. In Project Explorer expand the
tibco.bw.sample.palette.http.PersistentConnection project.

3. Fully expand the Processes directory and double-click
PersistentConnectionClientProcess.bwp.

4. Click Run > Debug Configurations.

5. At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

6. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.palette.http.PersistentConnection.application.

7. Click Debug.

This runs the sample in Debug mode.

8. Click the Terminatel®l icon to stop the process.

Result
is similar to the following:

Response received for Request2 at Wed, 11 Jun 2014 20:56:06 GMT
Response received for Requestl at Wed, 11 Jun 2014 20:56:06 GMT
Response received for Request4 at Wed, 11 Jun 2014 20:56:16 GMT
Response received for Request3 at Wed, 11 Jun 2014 20:56:16 GMT

Response received for Request3 at Wed, 11 Jun 2014 20:56:26 GMT
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Sending a Request and Getting a Response
from a Website

Using the HTTP palette activities, you can configure requests to a web server and manage
the response.

Before you begin
Your computer must be connected to the Internet.

tibco.bw.sample.palette.http .requestresponse HTTP_Request_Response_Example

destination="google"

Send_Request_to_Wiki_ Send_Response_from_Wiki_
MNews MNews

Incoming_HTTP_Request Mo matching news source

Logl

Procedure

1.

In the samples directory in the File Explorer view, expand palette > http >
RequestResponse and double-click . For more information, see Accessing Samples.

In the Project Explorer view, expand the .
Expand the folder.

Fully expand the Processes directory and double-click to open it in the Process
Editor pane.

Click Run > Debug Configurations.

At the left-hand tree of the Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

TIBCO ActiveMatrix BusinessWorks™ Samples



172 | Palettes Features

7. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the checkbox next to .

8. Click Debug.

This runs the sample in Debug mode.

9. Run lendpoints at the prompt in the Console to obtain the endpoint for the
application.

10. Copy the hostname from the endpoint.

11. In File Explorer, right-click on the RequestResponse folder and select Open
Location to access the RequestResponse folder in your file system.

12. Right-click request_news.html in your file system's folder and open it in a text
editor.

13. Replace <hostname> with the actual hostname of your machine that you copied from
the endpoint and save the file.

14. In File Explorer, under samples\palette\http\RequestResponse, double-click the
request_news.html file to open it in TIBCO Business Studio™ for BusinessWorks™.

15. Click the Get News from Google! button to request headlines from the associated
web page.

16. Click the Terminate [H icon to stop the process.

The Google News web page displays in your default browser. The Response sent
successfully! Message appears in the TIBCO Business Studio™ for BusinessWorks™
console.

Understanding the Configuration

The Incoming HTTP Request process starter listens on the connection specified in
ListeningHTTPConnection.httpConnResource. The request_news.html file contains a
form and clicking the Get News from Google! button sends the corresponding text string
(Google) to the Incoming HTTP Request activity.

The conditional transition routes the request to the Send HTTP Request activity, which
sends the request to the host using ListeningHTTPConnection. Finally, when the response
comes from the remote site, the Send HTTP Response activity closes the HTTP connection
established by the Incoming HTTP request process starter.

An internet connection is required for the sample to connect to Google News. The
ListeningHTTPConnection listens on port 13008. Change the LISTENING_PORT value in the
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Module Properties dialog. Also change the Port defined in the request_news.html file to
the same value.

Sending a Secured Request and Getting a
Secured Response from a Web Site

A secured HTTP request is sent to a web server. Mutual authentication takes place between
the web server and client. After the authentication is successful, the web server sends valid
response to the client completing the handshake.

Before you begin
Your computer must be connected to the Internet.

Copy the certificates to the c:/tmp folder on Windows and /tmp folder on Unix by
unzipping the JKS folder packaged with the sample.

Procedure
1. In the samples directory, select palette > http > SecuredRequestResponse and
double-click tibco.bw.sample.palette.http.SecuredRequestResponse. For more
information, see Accessing Samples.

2. In the Project Explorer view, expand the
tibco.bw.sample.palette.http.SecuredRequestResponse project.

3. Fully expand the Processes directory and double-click ClientRequest.bwp.
4. Click Run > Debug Configurations.

5. At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

6. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.palette.http.SecuredRequestResponse.application.

7. Click Debug.

This runs the sample in Debug mode.

8. Click the Terminatel®l icon to stop the process.
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Result

The following is the expected output:

Response received from BW HTTPS Server!!!

Understanding the Configuration

The HttpClientResource and the HttpConnectorResource is defined to listen on port
13003. To change the port, specify a new Port value in the Module Property dialog. If you
want to change the default location of the OUTPUT_FILE, KEYSTORE_URL_CLIENT,
KEYSTORE_URL_SERVER and HOST, specify it in the Module Property dialog box.

The HTTP Receiver process starter listens on the connection specified by the
HTTPConnectorResource shared resource. Verify the path of the client and server
certificates defined in the Module Properties dialog box.
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Invoking Custom Code to Complete a Purchase
Order

The Java Invoke activity can be used to write custom code to get information from a legacy
system, retrieve binary data, and so on.

Assume, for example, information from an ERP system is sent to a business partner using a
B2B XML protocol such as CXML or RosettaNet. If some fields required by the protocol are
not available from the ERP system, the missing information can be retrieved using the Java
Invoke activity. The activity can access, for example, a CSV file. You can then combine the
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information coming from the ERP system and the CSV file and send it to the business
partner.

B

tibco.bw.palette.java.invokecode JavaProcess

Replaces the Renders the XML
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with their specified into a byte stream
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Note: If you are accessing the sample from the Welcome page of TIBCO Business
Studio™ for BusinessWorks™, go directly to Step 3.

Procedure

1.

In the samples directory, select palette > java > InvokeCode and double-click
tibco.bw.sample.palette.java.InvokeCode. For more information, see Accessing
Samples.

In the Project Explorer view, expand the tibco.bw.sample.palette.java.lnvokeCode
project.

Set the default ApplicationProfile to match the OS you are running on. For more
information, see Setting the Default Application Profile.

Fully expand the Processes directory and double-click JavaProcess.bwp.
Click Run > Debug Configurations.

At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

Click the Applications tab and then click the Deselect All button. Select the check
box next to tibco.bw.sample.palette.java.InvokeCode.application.

Click Debug.
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This runs the sample in Debug mode.

9. Click the Terminate [®l icon to stop the process.

Result

The process combines the purchase order information in the PO.xml file and customer
information in csvFile. log file present in BW_HOME\samples\palette\java\InvokeCode
folder and writes it to the C:\tmp\InvokeCode\CompletePo.xml file.

Understanding the Configuration

The sample uses the Read File activity to read and parse an XML file into an XML tree. The
Java Invoke activity gets customer information from the csvFile.log file and makes it
available to the process. A Map activity combines the Read File and Java Invoke output to
build a complete schema, which contains the purchase order and customer information.
The combined information is passed to the RenderPOXML activity that converts the
information to XML string, using the specified schema. The process then publishes the XML
string by writing it to the CompletePo.xml file in C:\tmp\InvokeCode.

The example requires the following schema files:
e PurchaseOrderSchema used by ParsePO XML, which parses the PO.
e CustomerSchema referenced by CompletePO, which contains customer information.

e CompletePO used by Render PO XML and has information on both the purchase
order and the customer. CompletePO is a combination of PurchaseOrderSchema
and CustomerSchema.

To view the Java source, fully expand the src directory and double-click
JavaProcessJavaCode.java.

Troubleshooting

If any problem markers are visible in the project, close and re-open the project or import
the project in a clean new workspace.
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Using Java Activities to Publish Information

Using several Java activities, you can invoke a method on a Java object and translate the
resulting data into an XML document. The data can then be made available to other
activities.

Procedure
1. In the samples directory of the File Explorer view, expand palette > java >
InvokeMethod and double-click to expand it in the Project Explorer. For more
information, see Accessing Samples.

2. In Project Explorer expand the project.

3. Fully expand the Processes directory and double-click PublishAllBalances.bwp to
open it in the Process Editor pane.

4. Click Run > Debug Configurations.

5. At the left-hand tree of the Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

6. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the checkbox next to .

7. Click Debug.

This runs the sample in Debug mode.
8. Click the Terminatel®l icon to stop the process.
A log is displayed in the Console view.
Understanding the Configuration
The following three Java activities are used in this sample.
e The Java Invoke activity invokes a method on a Java object.

e The Java To XML activity translates data from a Java object into an XML document
that can be later used in other activities.

e The XML To Java activity supplies data to an XML schema to construct an instance of
the desired Java object.

The source code for the Java objects, LocalBank, Account, Balance, and SystemProperties
are in the src directory in the project.
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This project has the following three processes:

e PublishBalance

e PublishAllBalances

e PublishJavalnfo

The PublishBalance process runs as follows:

1.

The CreateLocalBank activity is a Java Invoke activity that constructs an instance of
the LocalBank object. This object contains the getBalance(...) method that the
process later invokes to retrieve the balance.

The CreateAccount activity is an XML To Java activity that creates an instance of the
Account object and sets the object's data using an XML schema.

The getBalance activity is a Java Invoke activity that invokes the getBalance(...)
method on the LocalBank object created by the CreateLocalBank activity. The
Account object created by the CreateAccount activity is also passed as a parameter
to the getBalance(...) method. The method returns an instance of the Balance
object that contains the balances for the specified account.

If the getBalance activity returns an exception, the error is published by the
PublishException (if the exception is InvalidAccount) or PublishError activity (in the
event of any other exceptions).

If the getBalance activity runs without any exception, the Balance activity is a Java
To XML activity that takes the Balance object produced by the getBalance activity
and converts the object's data to an XML document.

The PublishBalance activity takes the data produced by the Balance activity and
publishes the account and balance information by writing it to

The PublishAllBalances process runs as follows:

1.

The getAllBalance activity is a Java Invoke activity that constructs an instance of
the LocalBank object and invokes the getAl1Balance() method on that object. The
output of the method is an instance of the java.util.ArrayList class that contains
a collection of all balances.

The CollectionToArray activity invokes the toArray method of java.util.ArraylList
to convert the collection to an array of objects.

The group then iterates over each object in the array. The Balance activity takes the
current object in the array and converts its data to an XML document. The
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PublishBalance activity publishes the data from the output of the Balance activity.

The PublishJavalnfo process allows a Java To XML activity to make the well-known Java
system properties available as well as the host name and address. This process runs as
follows:

1. The SystemProperties activity is a Java To XML activity that constructs an instance
of the SystemProperties object and provides the data in the class as an XML schema.

2. The PublishJavalnfo activity uses the data produced by the SystemProperties
activity and publishes the Java information by writing it to

Troubleshooting

o If the Output tab of Java To XML activity is not populated, then press the Reload
button next to the Class Name in Java To XML activity.

 If any problem markers are visible in the project, close and reopen the project or
import the project in a clean new workspace.

Using Java Invoke that Makes a REST call to
Search Twitter

In this sample, Java Invoke makes a REST call to Twitter to search for a specified term. The
application module contains the user-written code, user jars, and processes. There is no
dependency on a Shared Module.

Before you begin
1. Create new app on - https://apps.twitter.com/ and generate Access Token, Access
Token Secret, Consumer Key, Consumer Secret for the app created and use it in the
parameters for SearchTwitter Activity.

2. To create a token:
a. Login to https://apps.twitter.com/ with your Twitter account.
b. Click Create New App.

c. Provide Name and Description and create your Twitter application. Your
application is successfully created.
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d. Go to API Keys Tab and click Create my access token. Your application access
token is successfully generated.

e. Click Test OAuth. You should see the OAuth Settings page which has the
following tokens generated - Consumer key, Consumer secret, Access token,
Access token secret.

Procedure

1.

> W

Browse the samples directory in File Explorer and select palette > java >
RESTInvokeToTwitter. Double-click to import the sample to your workspace. For
more information, see Accessing Samples.

In the Project Explorer view, expand the project.
Fully expand the Processes directory and double-click RESTInvokeToTwitter.bwp.
Click Run > Debug Configurations.

At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to .

Click Debug.

This runs the sample in Debug mode.

Click the Terminate® icon to stop the process.

Understanding the Configuration

The project contains the following process:

RESTInvokeToTwitter Process: This process has two Java Invoke activities:
OpenTwitterConnection and SearchTwitter. The source code for these activities is
located under src directory under com.example.TwitterConnection package in the same
project. OpenTwitterConnection activity creates a TwitterConnection object which is then
passed to SearchTwitter activity.

SearchTwitter activity requires the following 5 input parameters:

e SearchString
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e AccessToken
e AccessTokenSecret
e ConsumerKey

e ConsumerSecret

SearchString is the string for which user wants to search tweets. In this project the
SearchString is "Lady Gaga".

AccessToken, AccessTokenSecret, ConsumerKey, and ConsumerSecretarerequkedfor
authentication to the Twitter Account. The steps to generate these are mentioned in the
Prerequisite section.

The Java invoke uses Twitter API v1.1 which requires this request to be authenticated using
OAuth.

=Y

b b sarmple.palette jeva restencietobwithe BES Theoke ToTwather

Conate ebw pp 66 - BEtpEsappritwitbie com/
Generate diccest Token, Acoess Token Secret, Convermres Key, Consumer Secret for the app crested and wne it nthe panseaten for Sesech Twatter dctnaty

Q— =

Tener CpenTwiterConnechon SaarchTwitter Leg

Troubleshooting

If you receive an error message such as:

401:Authentication credentials (https://dev.twitter.com/pages/auth) were missing or
incorrect. Ensure that you have set valid consumer key/secret, access token/secret, and the
system clock is in sync.

Then, ensure that you have generated Access Token, Access Token Secret, Consumer Key,
and Consumer Secret as per the steps specified in Prerequisites section.
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Using a Custom Process Starter in a Project
That Gets Information about a Checking
Account

Java Event Source allows you to create a custom process starter written in Java.

Before you begin

Copy the AccountInformation.txt file from TIBCO_
HOME\bw\n.n\samples\palette\java\JavaEventSource to c:\tmp directory on Windows
and /tmp on UNIX.

Procedure

1.

In the samples directory, select palette > java > JavaEventSource and double-click
tibco.bw.sample.palette.java.JavaEventSource. For more information, see
Accessing Samples.

In Project Explorer expand the tibco.bw.sample.palette.java.JavaEventSource
project.

Set the default ApplicationProfile to match the OS you are running on. For more
information, see Setting the Default Application Profile.

Fully expand the Processes directory and double-click PublishAllBalances.bwp.
Click Run > Debug Configurations.

At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.palette.java.JavaEventSource.application.

Click Debug.

This runs the sample in Debug mode.

Click the Terminate® icon to stop the process.
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Result
The process writes the customer last name, account ID, and checking balance to the
PublishEvnSourceBalance. log file at c:\tmp\JavaEventSource.

Understanding the Configuration

This sample uses the Java objects such as, LocalBank, Account, Balance, and
SystemProperties. The source for these objects is in the src directory.

The process executes as follows:

1.

The Java Event Source activity reads balances from the AccountInformation.txt
and outputs an instance of the java.util.LinkedList class that contains a
collection of all balances.

The CollectionToArray activity invokes the java.util.LinkedListtoArray method
to convert the collection to an array of objects.

The group then iterates over each object in the array.

The Balance activity takes the current object in the array and converts its data to an
XML document.

The PublishBalance activity publishes the data from the output of the Balance
activity.

Troubleshooting

 If the Output tab of Java To XML activity is not populated, then press the Reload

button next to the Class Name in Java To XML activity.

 If any problem markers are visible in the project, close and re-open the project or

import the project in a clean new workspace.

TIBCO ActiveMatrix BusinessWorks™ Samples



185 | Palettes Features

Using JDBC Query - Process in Subsets and
JDBC Update - Batch Updates

This sample shows how to use the Advanced tab options of JDBC Query and JDBC
Update activities.

Before you begin
Install the PostgreSQL Database:

1.

Run createTestTables.sql on the PostgreSQL database to create test tables. The script is

located in the samples directory under the path TIBCO_
HOME\bw\n.n\sample\palette\jdbc\Advanced

Procedure
1. In the samples directory, select palette > jdbc > Advanced and double-click
tibco.bw.sample.palette.jdbc.Advanced. For more information, see Accessing
Samples.

2. In the Project Explorer view, expand the tibco.bw.sample.palette.jdbc.Advanced
project.

3. Fully expand Module Descriptors under tibco.bw.sample.palette.jdbc.Advanced
and double-click Module Properties. The JDBC properties defined for the application
are defined in the dialog. Provide a valid username, password, and database URL to
connect to your PostgreSQL database.

I Properties
Properties
Property Configurations

Mew Property | | Mew Geoup | | Mew Profie |

Propertues UnecProfile [WandewiPrefie]
% Apphiaticn
» T oo b sample palette pibe
BEL JDBC_DRINER org.postgrergl.Drrer ong.pottgreigl.Dmeer
123 SUBSET_SIZE 5 5

BEL BATCH_URDATES QUTPY Amp/ DBC_AdvancedBatchlpda..  otmp/IDBL_Advanced butchUpd..
BBt PROCESS IN_SUBSETS OU ftep/BDBC_Advanced/processing..  otmp/IDBC_Advanced/processlin...

BB USERMAME portgnes postgres
it IDBC_URL pbopostgresgh /10971062853  bopostgresgh 1057 106 28:-543...
] PASSWORD  weeeeees

B DB ConnectionResource tibcobw.sample.palette jdbc.sdva_  tibcobw.sample palette jdbe adva..

Sync Valoes
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4. Update the values under Module properties and save your project.

The values in Advanded.application properties are updated and the connection to
the database is successful.

5. Verify your JDBC connection.

10.

a. Fully expand the Resources directory.
b. Double-click JDBCConnection_PostgreSQL.jdbcResource.
c. In JDBC Driver, click Click here to set preferences.
d. Set the JDBC driver folder directory preference and click Apply. Click OK.
e. Click the Test Connection button to verify the connection.
Paclage Bibao bw Lampls pabethe (s sdvansed ¥ Mama  DBCConmechon Podgratll
Ihery are § referenry 19 S Prgsrcs
Biescrptan
M e o
Corwapction Type: Drarwat

Losges Crpdirsteal @ Labenant = Pirigmeted

Ureename: M4 -2 eDD
Pusecen |y - aebE
= BB Dwbeer
Dhataburne Drbverr: b D8 DRIVER erg petipeig Drms - @ e
Dt UKL 1 - _h?c.""
Losgen Fompget o]
Tut Comnactaon Punk 16 bt Comnecteon
Cheih borg 10 St Peglrpnd o

Click File > Save to save the project.

Fully expand the Processes directory and double-click ProcessinSubsets.bwp and
BatchUpdates.bwp.

Click Run > Debug Configurations.

At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.palette.jdbc.Advanced.application.
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11. Click Debug.

The sample runs in Debug mode.

12. Click the Terminate M icon to stop the process.

Understanding the Configuration

This sample shows:

e JDBC Query - Process in Subsets: This activity allows users to process the result set
in smaller subsets, rather than processing the entire result set at once. It uses the
ProcessInSubsets process.

» JDBC Update - Batch Updates: This activity is configured to perform multiple
statements in one batch. It uses the BatchUpdates process.

The ProcessinSubsets process is configured to process query in subsets.

tibco.bw.sample.palette.jdbc.advanced.ProcessinSubsets
& o Ehe
@ l = .
Timer @ ﬁ @ — ? —ho °
QuerySrcOrderTab WriteFile

The BatchUpdates process is configured to perform multiple insert statements in one
batch.

| bt e Lbmpia paletie it sdvanond Babchipdetn

@1 8—8 rd .
—3 - f—J L—+ 7

Gy G Gt Tl TshabioCiipdoin Targilnclayord
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ProcessIinSubsets executes as follows:

e QuerySrcOrderTab is a JDBC Query activity configured to retrieve subsets of the
result set of SRC_ORDER_TABLE table

e Check the Process In Subsets field on the Advanced tab.

» Set the subsetSize input item to the number of records you want to process for each
execution. In this sample, it is set as a module property named SUBSET_SIZE.

To retrieve subsets of the result set, you must use a Repeat group to iterate until the entire
result set is processed. For this, both QuerySrcOrderTab and ProcessSubsets are grouped
into processinSubsets Repeat group with the exit condition:
$QuerySrcOrderTab/lastSubset = true().

BatchUpdates executes as follows:

* QuerySrcOrderTab is a JDBC Query activity to retrieve the entire result set of SRC_
ORDER_TABLE table in one batch.

* The DeleteRecordslfAlreadyExists activity deletes the records that are already in the
database.

» BatchUpdates is a JDBC Update activity configured to perform multiple insertions in
one batch. It inserts all the records of the SRC_ORDER_TABLE table to the DEST_
ORDER_TABLE table.

° Check the Batch Update field on the Advanced tab.
°© Map the $QuerySrcOrderTab/Record to the Record input repeating element.

¢ QueryDestOrderTab retrieves the entire result set of DEST_ORDER_TABLE table at
once.

Setting Up a JDBC Connection to Query and
Update Tables

After setting up a JDBC connection, a process executes the SELECT and UPDATE queries.

Before you begin
Install the PostgreSQL database:
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1.

Run JDBC.sql on the PostgreSQL database to create test tables. The script is located in the
samples directory under the path TIBCO_HOME\bwx\n.n\samples\palette\jdbc\Basic.

Procedure

1. In the samples directory, select palette > jdbc > Basic and double-click
tibco.bw.sample.palette.jdbc.Basic. For more information, see Accessing Samples.

2. In the Project Explorer view, expand the tibco.bw.sample.palette.jdbc.Basic
project.

3. Fully expand Module Descriptors under tibco.bw.sample.palette.jdbc.Basic and
double-click Module Properties. The JDBC properties defined for the application are
defined in the dialog. Provide a valid username, password, and database URL to
connect to your PostgreSQL database.

Properties

Property Configurstions

[ wser xﬁm.

Groups / Properties Type default [ MNew Graup
[T QUTPUT_FILE BEE String c/ftmp/ IDBC_Basic/IDBC_Basic.log 'wa
1 IDBC Connectsonfesource [T JDBC Connection tibeo.bw.sarnple.palette pdbe. badic_.
T JD8C_DRIVER BEE Stiing org.postgresql.Driver Delete
T JDBC_URL REL String Jdbc:postgresql/10.97 106.28:543... i
[T PASSWORD [T Passwerd
T USERMAME Bt String postgres Do
[T ORDER_ID 123 Integes 142
Onerview Module Properties  Dependencies Components Shared Vanables| MANIFEST.MF | module.bwm

4. Fully expand the Processes directory and double-click JDBC_TEST.bwp.

1} tiboo e sample palette jdbe basie JDBC_TEST
& go - & d
Tamar DB Query B Lipdate WiteF de

5. Verify your JDBC connection.
a. Fully expand the Resources directory.
b. Double-click JDBCConnection_PostgreSQL.jdbcResource.
c. In JDBC Driver, click Click Here to Set Preferences.

d. Set the JDBC driver folder directory preference and click Apply. Click OK.
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e. Click the Test Connection button to verify the connection.

o

@ DBCTESThwp | B JDBCConnection PostgreSOiljdbchesource L1

Genedal @
Package bl v sarnple. palette pibe. basic W Mame  OBCConeection_PostgreSQL
Thete ol tef e 8 the MESSSECE
Description:
JOBC Conmection
Connecton Type Deresct
Wlanimiem Lo T 18

Logem Credentish: @ Lhiername « Pasvanced

Usernaree: MELE - ,,ﬂ*@’-j
Password: |} - @ e ER
= JDBL Drtver
Distabune Drives: _JIDEC_DEILR ceg postgresgl Drnves - aedE
Distabase URL: s -l AR
Login Timesut: 2000 -
:Tlﬂ l:mm Purih to test Conmaction
Llck Here bo Set Preferences

6. Click File > Save to save the project.
7. Click Run > Debug Configurations.

8. At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

9. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.palette.jdbc.Basic.application.

10. Click Debug.

This runs the sample in Debug mode.

11. Click the Terminate® icon to stop the process.

Result

e The order_description record in the sub_order table is updated to TESTING JDBC
CONNECTION.
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Understanding the Configuration

The JDBC_TEST.bwp process uses the JDBC Connection in the Resources folder to
establish a connection to the database and execute SELECT and UPDATE queries. First it
queries the table for a specific record using the JDBC_Query activity and then it updates
another table using the JDBC_Update activity. Finally it updates a file indicating the
number of records written.

Both activities use prepared parameters as input. This shows the ability to execute the
same statement with multiple values by caching the statement at runtime.

Using Oracle Objects and Collections in JDBC
Call Procedure and JDBC Query Activities

The JDBC Call Procedure activity calls a database procedure. The JDBC Query activity
performs the specified SQL SELECT statement.

This sample has the following processes:

e The CreateCustomer and SelectCustomer processes show how to use Oracle
Objects.

e The CreateCustomerMultiAddress and SelectCustomerMultiAddress processes
show how to use Oracle Collections.

Before you begin
* You must have credentials that allow you to run scripts against your Oracle database.

* Run the jdbc_object_collection.sql file against your Oracle database to create the
test objects. The file is located in the samples directory under the path TIBCO_
HOME\bwx\n.n\samples\palette\jdbc\Collection.

e Ensure to install Drivers for Design time and Run time.

Note: For more information about installing Drivers, see "JDBC
Connection" section in the TIBCO ActiveMatrix BusinessWorks™ Bindings and
Palettes Reference guide.
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Procedure

1.

In the samples directory, select palette > jdbc > Collection and double-click
tibco.bw.sample.palette.jdbc.Collection. For more information, see Accessing
Samples.

In the Project Explorer view, expand the tibco.bw.sample.palette.jdbc.Collection
project.

Fully expand tibco.bw.sample.palette.jdbc.Collection.application and double-click
Properties. The JDBC properties defined for the application are shown next. Provide
a valid username, password, and database URL to connect to the Oracle database in
your environment.

_,_.Pqﬁﬂhh ] B %% F 7 O|| G sboobw.saple pabime it Collection applation 1
# U sboo by comvgls paletie miter. Colactes =
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4 3 bboo e phe paliSe b collechion r
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@ Crmteluitemetbdns s g Frapasty Configurtions
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1 e el b bag o Progenty] | Commp ""' =

[3 Soreste Deicripaeni Fropeta WP de [WindowesPealie]
il Resource %
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4. Verify your JDBC connection:

a. Fully expand the Resources directory.
b. Double-click OracleConnection-OracleThinDriver.jdbcResource.
c. In JDBC Driver, click Click Here to Set Preferences.
d. Set the JDBC driver folder directory preference and click Apply. Click OK.
e. Click the Test Connection button to verify the connection.
Click File > Save to save the project.
Click Run > Debug Configurations.

At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.palette.jdbc.Collection.application.
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9. Click Debug.

This runs the sample in Debug mode.

10. Click the Terminatel® icon to stop the process.

Result
¢ On successful completion, the CreateCustomer and CreateCustomerMultiAddress
processes insert a row each in the database.

e On successful completion, the SelectCustomer and SelectCustomerMultiAddress
processes display the data that was inserted by each process in the Output tab.

Understanding the Configuration

The sample consists of the following processes:

e CreateCustomer: In this process, the JDBCCallProcedure activity ADD_SINGLE_
ADDRESS_CUSTOMER inserts a record containing Oracle Objects into the database.

» CreateCustomerMultiAddress: In this process, the JDBCCallProcedure activity ADD_
MULTI_ADDRESS_CUSTOMER inserts a record containing Oracle Collections into the
database.

o SelectCustomer: In this process, the JDBCQuery activity queries the database for
the record added using the CreateCustomer process and displays the record in the
Output tab.

e SelectCustomerMultiAddress: In this process, the JDBCQuery activity queries the
database for the record added using the CreateCustomerMultiAddress process and
displays the record in the Output tab.

Setting Up and Executing JDBC Activities with
Eclipse Using DTP

Using JDBC palette activities, you can setup JDBC connections and execute JDBC activities
to run queries and display the results. This sample shows how to execute SQL calls and
edit data with Eclipse DTP at Design time.
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Before you begin
Install the Sakila Sample Database.

e Download and install the Sakila sample database from
http://dev.mysql.com/doc/index-other.html.

« Installation information is available at http://dev.mysql.com/doc/sakila/en/sakila-
installation.html.

e Ensure to install Drivers for Design time and Run time.

For more information about installing drivers, see the "JDBC Connection" section of
TIBCO ActiveMatrix BusinessWorks™ Bindings and Palettes Reference guide.

Procedure

1. In the samples directory, select palette > jdbc > EclipseDTPIntegration and double-
click tibco.bw.sample.palette.jdbc.EclipseDTPIntegration. For more information,
see Accessing Samples.

2. In the Project Explorer view, expand the
tibco.bw.sample.palette.jdbc.EclipseDTPIntegration project.

3. Verify your JDBC connection.

a.
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4. Fully expand the Processes directory and double-click EclipseDTP.bwp.
5. In the Process Editor, click JDBCQuery and then click Properties > Statement tab.

6. Click SQL. This launches the SQL Query Builder. In SQL Query Builder, update or edit
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the statement, execute it, and view the result.

a. Modify the statement by removing "where title=?" and click Execute the
query to execute the statement at Design time by using DTP.

= Properties E'._\ Problems r,m Data Source Explorer (ﬁ SOL Results 2

Type query expression here Status | Resultl
Status Operation Date Connectio... SELECT film_id

FROM “sakila"FILM
+ Succee SELECT film... Sep28,201.. BWProfileti.. saa

Executing Query...
Operation Succeeded

In the SQL Results tab, the history for all operations displays at the left and
Status, Result, and Parameters display at the right.

b. Click the Data Source Explorer tab to view the connected database,
BWProfiletibco.bw.palette.jdbc.eclipsedtpintegration.JDBCConnectionReso
urce. Right-click on the table and select Data > Edit to edit the data.
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= Properties (E_l. Problems (m Data Scurce Explorer 22

4 [= Databaze Connections
£4 BIRT Classic Models Sample Database
4 &4 BWProfiletibco.bw.palette jdbe.eclipsedtpintegration.JDBCConnectionResource (MySQL v. 5.5.0)

a [] sakila
- [ Authorization IDs
4 [ Schemas
4 55 cakila
Dat, 3 Edit
: [0 Depen — :
> [ Stored ?;.'.D Generate DDL... Load...
4 [ Tables Refrech s Extract...
> | acto 5 Sample Contents
» [ actor_info

[ address

@ *Process.bwp ra JDBCConnectionResource.jdbcResource (@ tibco.bw.palette.jdbc.EclipseDTPIntegration

actor_id [SMALLINT UMSIGMED]  first_name [VARCHAR(45)] last_name [VARCHAR(45)] last_update [TIMESTAMP]

179 ED GUINESS 2006-02-15 04:34:33.0
130 JEFF SILVERSTOME 2006-02-15 04:34:33.0
181 MATTHEW CARREY 2006-02-15 04:34:33.0
1582 DEBBIE AKROYD 2006-02-1504:34:33.0
183 RUSSELL CLOSE 2006-02-15 04:34:33.0
134 HUMPHREY GARLAND 2006-02-15 04:34:33.0
185 MICHAEL BOLGER 2006-02-15 04:34:33.0
186 JULLIA JELLWEGER 2006-02-1504:24:33.0
187 REMEE BALL 2006-02-15 04:34:33.0
188 ROCK DUKAKIS 2006-02-15 04:34:33.0
1589 CUBA BIRCH 2006-02-15 04:34:33.0
190 AUDREY BAILEY 2006-02-15 04:34:33.0
191 GREGORY GOODING 2006-02-1504:34:33.0
192 JOHN SUVARI 2006-02-15 04:34:33.0
193 BURT TEMPLE 2006-02-15 04:34:33.0
194 MERYL ALLEM 2006-02-15 04:34:33.0
195 JAYMNE SILVERSTOME 2006-02-1504:24:33.0
196 BELA WALKEN 2006-02-15 04:34:33.0
197 REESE WEST 2006-02-15 04:34:33.0
198 MARY KEITEL 2006-02-15 04:34:33.0
199 JULIA FAWCETT 2006-02-15 04:34:33.0
200 THORA TEMPLE 2006-02-1504:34:33.0
<new row: s

c. Open the scrapbook to edit and run the SQL statements by clicking the icon
available in the Data Source Explorer view.

d. The entry for any SQL for default tables is available in the Sakila schema. Right-
click and select Execute All. See the results in the SQL Results view.
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Connection profile

Type: [Mysqls =] Name: bw.palette.jdbe.eclipsedtpintegration JDBCC ~ | Datapase: [sakila | Status: Connected, Auto Commit

% select * from film

= Properties [[£1, Problems [{R4 Data Source Explorer | B SQL Resuts &3 L TEETEN
Type query expression here Status |Resultl
Status Operation  Date Connectio... filmid title description release year languageid original language_id rental_duration rental_rate
+/ Succee select *fro... Sep28,20L.. BWProfileti.. . AfpicDr. 20060101 1
. Adsoun.. 20060101 1
. Adstoun.. 20060101 1
Afancifu.. 2006-0101 1
ct-Pa. 20060101 1 NULL
Alntrepi..  2006-0101 1
. ATouchi.. 20060101 1
. AfpicTs. 20060101 1
AThoug.. 2006-0101 1
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>
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e. Double-click JDBCQuery. Click Statement in the Properties tab. Modify the
statement by adding "where title=?" at the end in statement.

7. Click File > Save to save the project.
8. Click Run > Debug Configurations.

9. At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

10. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.palette.jdbc.EclipseDTPIntegration.application.

11. Click Debug.

This runs the sample in Debug mode.

12. Click the Terminate® icon to stop the process.

Result

The console log contains messages similar to: INFO c.t.b.p.g.L.t.b.s.p.j.E.Log - FILM_ID-
10001: Inventory of film id [17] in store id = [1] is 2.

Understanding the Configuration

The EclipseDTP.bwp process uses the JDBC Connection in the Resources folder to
establish a connection to the database and executes SELECT and STORED PROCEDURE
queries.

It queries the table for a specific record using the JDBC Query activity and then returns the
available copies of a specified film in stock using the JDBC Call Procedure activity.

Finally it displays a number of records with MessagelD in console.
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Both activities use prepared parameters as Input. This shows the ability to execute the
same statement with multiple values by caching the statement at runtime.

Sending and Getting JMS Messages

A process can send JMS messages and get JMS messages from a queue in a loop.

[ e e R R L e TR T et LTI

Before you begin
TIBCO Enterprise Message Service must be running.

Procedure

1.

In the samples directory, select palette > jms > GetQueueMessage and double-click
tibco.bw.sample.palette.jms.GetQueueMessage. For more information, see
Accessing Samples.

In the Project Explorer view, expand the
tibco.bw.sample.palette.jms.GetQueueMessage project.

Verify your TIBCO Enterprise Message Service connection.
a. Fully expand the Resources directory.
b. Double-click JMSConnectionResource.jmsConnResource.

c. In the Basic Configuration dialog box, click the Test Connection button to
verify the connection.

Fully expand the Processes directory and double-click GetQueueMessage.bwp.
Click Run > Debug Configurations.

At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

Click the Applications tab and then click the Deselect All button if you have multiple
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applications. Select the check box next to
tibco.bw.sample.palette.jms.GetQueueMessage.application.

8. Click Debug.

This runs the sample in Debug mode.

9. Click the Terminatel®l icon to stop the process.

Result
The Console displays messages similar to the following:

16:08:26.242 [PVM:In-Memory STWorkProcessor:1] INFO c.t.b.p.g.L.t.b.p.j.G.Log -
Message=Sending 5 Queue Messages

16:08:26.292 [PVM:In-Memory STWorkProcessor:1] INFO c.t.b.p.g.L.t.b.p.j.G.Log1 -
Message=Finished sending 5 Queue messages. Getting 5 Queue messages...

16:08:26.303 [PVM:In-Memory STWorkProcessor:3] INFO c.t.b.p.g.L.t.b.p.j.G.Log2 -
Message=Received message number 1. Message = This is message number 1

16:08:26.307 [PVM:In-Memory STWorkProcessor:5] INFO c.t.b.p.g.L.t.b.p.j.G.Log2 -
Message=Received message number 2. Message = This is message number 2

16:08:26.311 [PVM:In-Memory STWorkProcessor:1] INFO c.t.b.p.g.L.t.b.p.j.G.Log2 -
Message=Received message number 3. Message = This is message number 3

16:08:26.315 [PVM:In-Memory STWorkProcessor:3] INFO c.t.b.p.g.L.t.b.p.j.G.Log2 -
Message=Received message number 4. Message = This is message number 4

16:08:26.318 [PVM:In-Memory STWorkProcessor:5] INFO c.t.b.p.g.L.t.b.p.j.G.Log2 -
Message=Received message number 5. Message = This is message number 5

Understanding the Configuration

The JMS Send Message activity sends the messages with the message style set to Queue.

The Get JMS Queue Message activity receives the JMS messages from a Queue in a loop.
The activity is placed in a group and the group action is set to Repeat.

The condition loops five times and receives five messages.
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Using JMS Message Selector

The JMS Send Message activity sends five queue messages and sets an application
property with the index. The Get JMS Queue Message activity selects the third message
using message selector.

Before you begin
TIBCO Enterprise Message Service must be running.

Procedure

1.

In the samples directory, select palette > jms > MessageSelector and double-click
tibco.bw.sample.palette.jms.MessageSelector. For more information, see Accessing
Samples.

In the Project Explorer view, expand the
tibco.bw.sample.palette.jms.MessageSelector project.

Verify your TIBCO Enterprise Message Service connection.
a. Fully expand the Resources directory.
b. Double-click JMSConnectionResource.jmsConnResource.

c. In the Basic Configuration dialog box, click the Test Connection button to
verify the connection.

Fully expand the Processes directory and double-click MessageSelector.bwp.
Click Run > Debug Configurations.

At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.palette.jms.MessageSelector.application.

Click Debug.

This runs the sample in Debug mode.

Click the Terminatel® icon to stop the process.
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Result
The Console displays a message similar to the following:

11:54:01.283 INFO [bwThread:In-Memory STWorkProcessor-1] c.t.b.p.g.L.t.b.s.p.j.M.Log -
Sending 5 Queue Messages

11:54:01.409 INFO [bwThread:In-Memory STWorkProcessor-1] c.t.b.p.g.L.t.b.s.p.j.M.Log1 -
Finished sending 5 Queue messages. Selecting 3rd Message...

11:54:01.475 INFO [bwThread:In-Memory STWorkProcessor-2] c.t.b.p.g.L.t.b.s.p.j.M.Log?2 -
Selected 3rd message,. Message = This is message number 3

Understanding the Configuration

The process sends five Queue messages and selects one message using the selectors. This
process definition executes as follows:

» The JMS Send Message activity sends five messages in a loop. It also sets the index
of the loop to an application property called myselector.

* The Get JMS Queue Message activity uses the message selector myselector='3' to
pick the third message.

Receiving a JMS Message from a Queue and
Responding to the Message

The JMS Queue Receiver and Reply to JMS Message activities can be configured to
receive and respond to JMS messages.

Before you begin
TIBCO Enterprise Message Service must be running.

Procedure
1. In the samples directory, select palette > jms > QueueReceiver and double-click
tibco.bw.sample.palette.jms.QueueReceiver. For more information, see Accessing
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Samples.

2. In the Project Explorer view, expand the
tibco.bw.sample.palette.jms.QueueReceiver project.

3. Verify your TIBCO Enterprise Message Service connection.

a. Fully expand the Resources directory.

b. Double-click JMSConnectionResource.jmsConnResource.

c. In the Basic Configuration dialog box, click the Test Connection button to
verify the connection.

4. Fully expand the Processes directory and double-click QueueReceiver.bwp.

5. Click Run > Debug Configurations.

6. At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

7. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.palette.jms.QueueReceiver.application.

8. Trigger the application by sending a request. You can use the
tibco.bw.sample.palette.jms.SenderAndSignalin sample to send the request. For
more information, see Sending a JMS Message to a Queue and Waiting for a
Response). The applications can run in the same or separate TIBCO Business Studio™
for BusinessWorks™ instance. If you run the applications in the same instance, load
the application before clicking Debug.

9. Click Debug.

This runs the sample in Debug mode.
10. Click the Terminate® icon to stop the process.
Result

When both applications are running in the same TIBCO Business Studio for BusinessWorks
instance, information similar to the following is displayed in the console:

14:32:46.402 [bwThread:In-Memory STWorkProcessor-2] INFO c.t.b.p.g.L.t.b.s.p.j.Q.Log -
Received a Queue Message. Request = This is a test request. JMSMessagelD = ID:EMS-
SERVER.25FC52F2890A46:6. Jobld [bw0al101], Processinstanceld [bw0al01], Activity [Log],
Process [tibco.bw.sample.palette.jms.queuereceiver.Process], Module
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[tibco.bw.sample.palette.jms.QueueReceiver:1.0.0.qualifier], Application
[tibco.bw.sample.palette.jms.QueueReceiver.application:1.0].

14:32:46.419 [bwThread:In-Memory STWorkProcessor-3] INFO c.t.b.p.g.L.t.b.s.p.j.S.Log1l -
Received the response. Response = This is a test response. JMSCorrelationID = ID:EMS-
SERVER.25FC52F2890A46:6. Jobld [bw0a100], Processinstanceld [bw0a100], Activity [Logl],
Process [tibco.bw.sample.palette.jms.senderandsignalin.Process], Module
[tibco.bw.sample.palette.jms.SenderAndSignalln:1.0.0.qualifier], Application
[tibco.bw.sample.palette.jms.SenderAndSignalln.application:1.0].

Understanding the Configuration

The sample uses the JMS Queue Receiver activity to get messages off the queue. The
Reply to JMS Message activity responds to the incoming JMS message and automatically
uses the JMSReplyTo header to get the reply destination.

Sending a JMS Message and Receiving a
Response in a Process

The JMS Request Reply activity sends a request to a JMS queue and waits for the
response. After receiving the response, the activity makes the output available.

Before you begin
TIBCO Enterprise Message Service must be running.

Procedure
1. In the samples directory, select palette > jms > RequestReply and double-click
tibco.bw.sample.palette.jms.RequestReply. For more information, see Accessing
Samples.

2. In the Project Explorer view, expand the
tibco.bw.sample.palette.jms.RequestReply project.

3. Verify your TIBCO Enterprise Message Service connection.

a. Fully expand the Resources directory.
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b. Double-click JMSConnectionResource.jmsConnResource.

c. In the Basic Configuration dialog box, click the Test Connection button to
verify the connection.

4. Fully expand the Processes directory and double-click RequestReply.bwp.
5. Click Run > Debug Configurations.

6. At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

7. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.palette.jms.RequestReply.application.

8. Trigger the application by sending a request. You can use the
tibco.bw.sample.palette.jms.QueueReceiver sample to send the request. For more
information, see Receiving a JMS Message from a Queue and Responding to the
Message. The applications can run in the same or separate TIBCO Business Studio™
for BusinessWorks™ instance. If you run the applications in the same instance, load
the application before clicking Debug.

9. Click Debug.

This runs the sample in Debug mode.

10. Click the Terminate® icon to stop the process.

Result

When both applications are run in the same TIBCO Business Studio for BusinessWorks
instance, information similar to the following is displayed in the console:

14:41:00.532 [bwThread:In-Memory STWorkProcessor-2] INFO c.t.b.p.g.L.t.b.s.p.j.Q.Log -
Received a Queue Message. Request = This is a test request. JMSMessagelD = ID:EMS-
SERVER.25FC52F2890A4F:5. Jobld [bw0al101], Processinstanceld [bw0al01], Activity [Log],
Process [tibco.bw.sample.palette.jms.queuereceiver.Process], Module
[tibco.bw.sample.palette.jms.QueueReceiver:1.0.0.qualifier], Application
[tibco.bw.sample.palette.jms.QueueReceiver.application:1.0].

14:41:00.548 [bwThread:In-Memory STWorkProcessor-3] INFO c.t.b.p.g.L.t.b.s.p.j.R.Log1 -
Received the response. Response = This is a test response. Jobld [bw0a100],
Processinstanceld [bw0al100], Activity [Logl], Process
[tibco.bw.sample.palette.jms.requestreply.Process], Module
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[tibco.bw.sample.palette.jms.RequestReply:1.0.0.qualifier], Application
[tibco.bw.sample.palette.jms.RequestReply.application:1.0].

Sending a JMS Message to a Queue and Waiting
for a Response

After sending a JMS message, the JMSSignalln activity gets the response and filters it as
required.

Before you begin
TIBCO Enterprise Message Service must be running.

Procedure
1. In the samples directory, select palette > jms > SenderAndSignalln and double-
click tibco.bw.sample.palette.jms.SenderAndSignalin. For more information, see
Accessing Samples.

2. In the Project Explorer view, expand the
tibco.bw.sample.palette.jms.SenderAndSignalin project.

3. Verify your TIBCO Enterprise Message Service connection.
a. Fully expand the Resources directory.
b. Double-click JMSConnectionResource.jmsConnResource.

c. In the Basic Configuration dialog, click the Test Connection button to verify
the connection.

4. Fully expand the Processes directory and double-click QueueSenderWait.bwp.
5. Click Run > Debug Configurations.

6. At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

7. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.palette.jms.SenderAndSignalin.application.

8. Trigger the application by sending a request. You can use the
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tibco.bw.sample.palette.jms.QueueReceiver sample to send the request. The
applications can run in the same or separate TIBCO Business Studio™ for
BusinessWorks™ instance. If you run the applications in the same instance, load the
application before clicking Debug.

9. Click Debug.

This runs the sample in Debug mode.

10. Click the Terminate® icon to stop the process.

Result

When running both applications in the same TIBCO Business Studio for BusinessWorks
instance, the Console view displays the information similar to the following:

14:46:23.347 [bwThread:In-Memory STWorkProcessor-2] INFO c.t.b.p.g.L.t.b.s.p.j.Q.Log -
Received a Queue Message. Request = This is a test request. JMSMessagelD = ID:EMS-
SERVER.25FC52F2890A57:6. Jobld [bw0a101], Processinstanceld [bw0al01], Activity [Log],
Process [tibco.bw.sample.palette.jms.queuereceiver.QueueReceiver], Module
[tibco.bw.sample.palette.jms.QueueReceiver:1.0.0.qualifier], Application
[tibco.bw.sample.palette.jms.QueueReceiver.application:1.0].

14:46:23.365 [bwThread:In-Memory STWorkProcessor-3] INFO c.t.b.p.g.L.t.b.s.p.j.S.Log1l -
Received the response. Response = This is a test response. JMSCorrelationID = ID:EMS-
SERVER.25FC52F2890A57:6. Jobld [bw0a100], Processinstanceld [bw0a100], Activity [Logl],
Process [tibco.bw.sample.palette.jms.SenderAndSignalln.QueueSenderWait], Module
[tibco.bw.sample.palette.jms.SenderAndSignalln:1.0.0.qualifier], Application
[tibco.bw.sample.palette.jms.SenderAndSignalln.application:1.0].

Understanding the Configuration

The QueueSenderWait process sends a Queue message and listens for a response. This
process definition executes as follows:

1. The JMS Send Message activity sends a Queue message. It also sets a static reply
destination in the advanced tab. The responder uses this reply destination to reply
the message.

2. The JMS Signalln activity uses Conversation mechanism wherein a conversation is
initiated by the Correlation Key, which is JMSMessagelD sent by the JMS Queue
Sender activity. Conversation "Join" uses JMSCorrelationID to filter the correct
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response with the correct job.

Sending a JMS Message and Receiving a
Durable Response

The JMS Receiver Event Source activity can be configured as a Durable Subscriber. If the
subscriber is offline, the subscriber's messages are stored by the JMS server and delivered
when the subscriber is online.

Before you begin
TIBCO Enterprise Message Service must be running.

Procedure
1. In the samples directory, select palette > jms > TopicDurableSubscriber and
double-click tibco.bw.sample.palette.jms.TopicDurableSubscriber. For more
information, see Accessing Samples.

2. In the Project Explorer view, expand the
tibco.bw.sample.palette.jms.TopicDurableSubscriber project.

3. Verify your TIBCO Enterprise Message Service connection.
a. Fully expand the Resources directory.
b. Double-click JMSConnectionResource.jmsConnResource.

c. In the Basic Configuration dialog box, click the Test Connection button to
verify the connection.

4. Fully expand the Processes directory and double-click TopicPublisher.bwp.
5. Click Run > Debug Configurations.

6. At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

7. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.palette.jms.TopicDurableSubscriber.application.

8. Click Debug.
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The sample runs in Debug mode.

9. Click the Terminatel®l icon to stop the process.

Result
The Console displays a message similar to the following:

15:46:34.903 [PVM:In-Memory STWorkProcessor:1] INFO c.t.b.p.g.L.t.b.p.j.D.Log -
Message=Publishing a Topic Message, Messageld=

15:46:35.043 [PVM:In-Memory STWorkProcessor:2] INFO c.t.b.p.g.L.t.b.p.j.D.Log -
Message=Received a Topic Message. Message = This is a test Topic Message, Messageld=.

Understanding the Configuration

The JMS Send Message activity sends a message to the topic.sample topic. The JMS
Receive Message activity subscribes to the topic.sample topic. Additionally, the JMS
Receive Message activity is configured as durable, allowing messages to be received later
if the receiver is offline.

Sending Mail Using HTML

A process sends an email formatted in HTML and includes embedded images as an
attachment.

Before you begin
You must have the account settings for your mail server.

Procedure
1. In the samples directory, select palette > mail > HtmlMailWithimage and double-
click . For more information, see Accessing Samples.

2. In the Project Explorer view, expand the project.
3. Fully expand the Processes directory and double-click Sender.bwp.

4. Click Run > Debug Configurations.
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5. At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

applications. Select the check

Click Debug.

Click the Applications tab and then click the Deselect All button if you have multiple

box next to .

This runs the sample in Debug mode.

Click the Terminate® icon to

Result

Your mail client receives an email sh
formatted message.

stop the process.

owing the attachments, embedded in an HTML

Sending Mail Using MIME

This sample shows how to send mail with attachments using MIME format.

The MailSender.bwp process sends
process receives the mail.

MailSender Process

mail with attachments and the MailReceiver.bwp

D
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Before you begin
You must have the account settings for your mail server.

On Windows, copy the -input folder from $TIBCO_
HOME\bwx\n.n\samples\palette\mail\attachment_files folder to C:\tmp.

On UNIX, copy the -input folder to /tmp.

Procedure

1.

In the samples directory, select palette > mail > MIMEAttachment and double-click
tibco.bw.sample.palette.mail.MIMEAttachment. For more information, see
Accessing Samples.

In the Project Explorer view, expand the
tibco.bw.sample.palette.mail.MIMEAttachment project.

Set the default ApplicationProfile to match the OS you are running on. For more
information, see Setting the Default Application Profile.

Fully expand the Processes directory and double-click MailSender.bwp and
MailReceiver.bwp.

Click Run > Debug Configurations.

At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.palette.mail.MIMEAttachment.application.
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8. Click Debug.

This runs the sample in Debug mode.

9. Click the Terminatel®l icon to stop the process.

Result
The MailSender process sends the mail and the MailReceiver process receives the mail.

On Windows, the MIMEAttachment. log output file is created at c: /tmp/MIMEAttachment.
On UNIX, the output file is created at \tmp\MIMEAttachment.
The Console view shows the messages similar to:

13:25:01.277 INFO [bwThread:In-Memory STWorkProcessor-1] c.t.b.p.g.L.t.b.s.p.m.M.Log -
Sending the mail with attachment

13:25:03.984 INFO [bwThread:In-Memory STWorkProcessor-1] c.t.b.p.g.L.t.b.s.p.m.M.Log1 -
Mail has been sent with attachment

13:25:13.471 INFO [bwThread:In-Memory STWorkProcessor-2] c.t.b.p.g.L.t.b.s.p.m.M.Log -
Received Mail with subject: Test Mail With Attachment

13:25:13.476 INFO [bwThread:In-Memory STWorkProcessor-2] c.t.b.p.g.L.t.b.s.p.m.M.Log1 -
Mail Body: Hello World

13:25:13.538 INFO [bwThread:In-Memory STWorkProcessor-2] c.t.b.p.g.L.t.b.s.p.m.M.Log?2 -
Attachment [1] data:

13:25:13.591 INFO [bwThread:In-Memory STWorkProcessor-2] c.t.b.p.g.L.t.b.s.p.m.M.Log3 -
Test Attachment Data

13:25:13.631 INFO [bwThread:In-Memory STWorkProcessor-2] c.t.b.p.g.L.t.b.s.p.m.M.Log?2 -
Attachment [2] data:

13:25:13.656 INFO [bwThread:In-Memory STWorkProcessor-2] c.t.b.p.g.L.t.b.s.p.m.M.Log4 -
ROIGODIheQA2APCAAAAAAP///wBtpQ8KCXALDBMODXYREhcSExoVFhAMDRMPEBQQERgUFRK
VFhoWFXANDhEODxUSEXYTFBcUFRkWFx0aGyAdHiMgISYjJCUilykmJxgTFRURExsXGSOrLDAuL
2g2NzQyMz89Pjw600hGRORCQOINTIxaWyckJionKSlel TIwMjAuMDg20DUzNfr2+jY1NIRTVEJB
QIxbXGlnajMyNEhHSUVERKRDRUNCRFJRU1BPUUpJS2NiZGBfYV5dX1hXWbSztXRzdu3r8z8/Qk
INUEdHSVJSVPX1+pKSIV5eYFpaXFIZW1VVV3Z2eHJydGlpa2ZmaGVIZ5mZm5GRk4qgKjleHiYWF
h4KChIGBg35+gHFxcm1tbmFhYldXWP39/vv7/Pré+/n5+vb29/X19u/v8Nzc3dHROpiYmerro03u9
unr82tsh4GChZSVmLu8v93i7uPn8evu9ebg8ltcXmFiZHd4enR1d3NOdmb5vcY20kliJi7Tq7vbOO0tq
2usKytremqrKipg6Slp6KjpaCho56foZydn5ucnsTFx7/AwszX6JianfHz9pavOL704qe/2XScxISoy
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46uzo6QkouNj4WHiYKEhpaYmkhJSq+xs19gYXx9fnl6e2prbKeoqZmam5WWI5SVIoyNjoWGh/X
29/Hy8/Dx8uvs7enq6+bn60Xm5+Pk5eLj5N/g4d7f4AN3e39zd3trb3Nna29fY2dbX2NTV1tPU1dLT
1M/Q0c7POM30z8rLzMjJysbHyMPExcLDxLu8vbm6éu7ed4uba3uLKztLCxsqusra3F3KC+2GKXwW
aawmmcw4200ZS300mLuVeXwHuqy40OwzwBjnwBfnSJ4rC58rzqGtVOTvQBnogBoogBooQBm
0QBloANpogVgqow5vpxFwpxdzqSl+sABspQBrpABqo7y+v7S2t97g4drc3cflygBxqO/x8f7///z9/fv
8/Pj5+ff4+PT19fPO9PDx8e3u7ujp6czNzfj6+fHy8QWICPT+/v7+/Pz8+vr6////yH5SBAEAAPSALAAA gFhr4wl0UOokBNNAg5+hAC+D
1P7TwgYw7UQBpysIEMOHyDHCcqGbhetD6D/MICOGCHQLZAAB+QYiHCGIAH/3aRKFIw4QFWOEi
00BQNNV;jjVcnJhjNecl1tWMd8AOHf8NRXAnkUhAxdGADDBJKKHDxgE6NLiDugQAAekLAgX+BE
AVxgwdqZKBkvelbulkONODwCfFdk4AxBI4NStMMdpXhFMXago1YQ5B4jUMAR+MA+gYCBFv0IQ
Cow8QAbCOMdBLkFFAyggWFsZFrz4lYzKACNwuyFG82QAzW2kRdaHQQU+hijQYKhgMcJJBYqu
IAJdMACGXhgAg5gwiwMIgsmMKADNSjCJwoxBSsO0gQWxCYAsgGAABSRAD4ARAQycwkIAQIIEj4
hAHNZwhBOVUI53wplYyAiAJasTzEQgRhAeSgP+QX9TgDgNxRQ5GAAMXuGAEOTrjCL+CBkHjwQ
QorUIEDJNABFXwACvUYyBg80QMMVEACDrjACPbwR0o2kYQ1zYEQ71BCHOazhpSh9wRdcCtM5I
AEh+UBHRg8yhlYUSCBhYMUghsoKe4CKle50BS+GUQxh8KIVRyWIPGxhjmIMYxenollWtRgP6m
01APuoBSqOWohLINUQpkgE2RpShkK4IRA7TJckUelAlgryCEBItBeog4gtB5M8ixRIECEKRCTIMgw
sGlog70jqQW+DAE1GIwIHfAUqwHmMQflgzsQPhhkC9EdQwxICJBzgEBSgRAGCQYyD44a9mD5I|
SbriEly0SBk3/1BEYR6BEJ/Y6Cy1sYVMEyUUUAAALI8DrD3nIgylZMQkxrKITtgiAG85FjCc8IX/zqlld
QIGQXzyBC4UIwDuSEAI2611gfVhCD1hhDhMI5B5PYEMS3gGGKtAIAFqQSh/8cIZJDGIRsLjIPGaQD
oHwYQSy+MURyuCOJQRCFUzoBUFoUQJRNKFniLCBK2hhhHu8QwmulAYRCNGPGNjDFUuQhT
nowl8ywAANNBPIKOjwilM0QSqvOEEwfjgQY2QhEENAXA4CQI8mM+IEUUaCTFQphCjrglQBPCEYA
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ggEIPmBkwAUOwDlooEkmpMlelrhCEvLWLIHQ4gaTMEY+AhAKJwgE/wpoCIAoLjEJQGghE2RLR
BHcQAK70MMfR5jtQIShBM50ArHXxmEFOCWIMJ7QDCpU4wQU1URpjMCEAIMhCH/5ACV/YoUxf6
EdcBAyEWAikD4hdRRNUEQ8eZCIAZRBDcH3AUIEM4whkKMMOpMwLHrShHpw4wi8gpANHIsk
eQNAKQWzBAT7BFgZ/yAMIZCgll+gVjBRSzRxPepAXTnCIPUmMiFMehwiY7IYwuzTUQWNMKGeAG;|
BO6whLgCQIs7IEYg/BAFGzoxhbjEgwmGCIAgiAVWKvRgC+H9dkkFMogobCELMSTDESY52iR+AQ
9SEEgxevCEO+xKFHXQ5g0k/NWSm/zkKBtPucpXzvKWu/zIMI+52Gd085rb/0Y4zzIHAgIAOwW==

Sending and Receiving Mail

A process sends an email to a user and another process receives the email, by either
sending a response to the sender, or writing it to a log in the console.

This process contains Send Mail and Receive Mail activities.

tibco.bw.sample.palette.sendandreceive.EmailExample

Success with Condition * \/%3 *

SendMail Log

ReceiveMail

d

WriteFile

j _

SendMaill

Success with no matching condition

Logl

d

WriteFilel

Before you begin

You must have the account settings for your mail server.

Procedure

1. In the samples directory, select palette > mail > SendAndReceive and double-click
tibco.bw.sample.palette.mail.SendAndReceive. For more information, see

Accessing Samples.

2. In the Project Explorer view, expand the

tibco.bw.sample.palette.mail.SendAndReceive project.

3. Set the default ApplicationProfile to match the OS you are running on. For more
information, see Setting the Default Application Profile.
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4. Fully expand the Processes directory and double-click EmailExample.bwp and
MailSendReceive.bwp.

5. Click Run > Debug Configurations.

6. At left hand tree of Debug Configuration wizard, expand BusinessWorks Application
and select BWApplication.

7. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.palette.mail.SendAndReceive.application.

8. Click Debug.

This runs the sample in the Debug mode.

9. Click the Terminatel®l icon to stop the process.

Result
The SendAndReceive. log output file is created in SendAndReceive folder at c:/tmp

Depending on your actions:

 If userA sends an email to the user configured in the Receive Incoming Email task
with the subject "Send Response from BW", the mail account specified by the reply_
email_address module property receives an email and the following message is
visible in the console:

13:49:35.053 INFO [bwThread:In-Memory STWorkProcessor-2] c.t.b.p.g.L.t.b.s.p.m.S.Log

e Mail sent to user. 13:49:39.613 INFO [bwThread:In-Memory STWorkProcessor-3]
c.t.b.p.g.L.t.b.s.p.m.S.Log

e Response sent to userl.

o If userA sends an email to the user configured in the Receive Incoming Email task
with another subject, the console shows the following message:

13:49:35.053 INFO [bwThread:In-Memory STWorkProcessor-2] c.t.b.p.g.L.t.b.s.p.m.S.Log

e Mail sent to user. 13:49:39.613 INFO [bwThread:In-Memory STWorkProcessor-3]
c.t.b.p.g.L.t.b.s.p.m.S.Log -No subject match
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Troubleshooting

If the process does not receive the mail, verify the following whether:
* The email server and user information are correctly configured for your system.

e The reply_email_address module property refers to the mail account you are
checking.

If the process after receiving the mail did not send a response, verify the following whether:

e The subject used in the email matches the incoming_email_subject module property.
If it does not match, then find an appropriate message in the console.

* You have specified the Host correctly. If not, then it generates an error.

Publishing and Subscribing to TIBCO
Rendezvous Messages

Rendezvous programs use messages as the common currency to exchange data. The
Rendezvous palette includes activities that allow you to easily setup subjects to send and
receive messages. This sample shows how to use Rendezvous activities.

Before you begin
TIBCO Rendezvous™ must be running on the machine.

To run this sample you can either use TIBCO ActiveMatrix BusinessWorks™ 6.x client or
ActiveMatrix BusinessWorks™ 5.x as a client.

For more information about how to configure client in TIBCO ActiveMatrix BusinessWorks
5.x, see Configure the Client in TIBCO Designer section.

Procedure

1. In the samples directory, select palette > rendezvous > RPC and double-click
tibco.bw.sample.palette.rendezvous.RPC. For more information, see Accessing
Samples.

2. In the Project Explorer view, expand the tibco.bw.sample.palette.rendezvous.RPC
project.
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3. Set the default ApplicationProfile to match the OS you are running on. For more
information, see Setting the Default Application Profile.

4. Fully expand the Processes directory and double-click
PublishRVmessageProcess.bwp, RendezvousRPC.bwp, and
SubscribeRVMessageProcess.bwp.

5. Click Run > Debug Configurations.

6. At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

7. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.palette.rendezvous.rpc.application.

8. Click Debug.

This runs the sample in Debug mode.
Configure the Client in TIBCO Designer

9. In TIBCO Designer, import the client project, TIBCO_
HOME\bwx\n.n\samples\palette\rv\RPC\bw5\tibco.bw.sample.palette.rendezvou
s.RPCClient.

10. Click Global Variables and select the OUTPUT_FILE variables to get the location of
the output file.
11. Click Tools > Tester > Start.
12. In TIBCO Business Studio™ for BusinessWorks™, click the Terminatel® icon to stop
the process.
Result

The Console view displays the message similar to the following:

10:49:55.611 INFO [bwThread:In-Memory STWorkProcessor-1] c.t.b.p.g.L.t.b.s.p.r.rpc.Log -
Message Published to BW.Start

10:49:57.745 INFO [bwThread:In-Memory STWorkProcessor-7] c.t.b.p.g.L.t.b.s.p.r.rpc.Log -
TestCase Completed

10:50:02.759 INFO [bwThread:In-Memory STWorkProcessor-5] c.t.b.p.g.L.t.b.s.p.r.rpc.Log -
Recieved Response HELLO WORLD

The output.log file is generated at C:\tmp\RPC that contains the following data:
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Message Published to BW.Start
Subscriber to Bw.Start invoked and Message Published on BW.Results

Process completed.Final output is--->>HELLO WORLD

Understanding the Configuration

The Subscribe to BW.Start Rendezvous Subscriber activity listens on the BW.Start
subject. On receiving the message on that subject, the process starts the:

» Wait_for_BW.Request activity that is listening to the BW.Request subject.

e Reply_to_BW.Request activity that is listening on the BW.Request subject and
BW.Reply subject.

The Wait for Rendezvous Request activity receives the message from the Send
Rendezvous Request activity and sends a reply message to the Rendezvous Request
activity. A final result message is delivered by the publisher on the subject BW.Result.

Managing TCP Connections

The TCP activities are designed to work with custom applications that communicate with
other applications via TCP. This sample shows how to perform common tasks, such as
opening a connection, writing data to it, and closing the connection.

Procedure

1. In the samples directory, select palette > tcp > Basic and double-click
tibco.bw.sample.palette.tcp.Basic. For more information, see Accessing Samples.

2. In the Project Explorer view, expand the tibco.bw.sample.palette.tcp.Basic
project.

3. Set the default ApplicationProfile to match the OS you are running on. For more
information, see Setting the Default Application Profile.

4. Fully expand the Processes directory. See multiple sample sub packages, each
comprising a Client.bwp and Server.bwp process. Double-click each process to view
the activities defined.
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5. Click Run > Debug Configurations.

o

At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

7. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.palette.tcp.Basic.application.

8. Click Debug.

This runs the sample in Debug mode.

9. Click the Terminate [® icon to stop the process.

Result
The TCP_Basic. log file is generated at C:\tmp\TCP_Basic contains the following data.

Test Request Data by iterationLoop- 1
Test Request Data by iterationLoop- 2
Test Request Data by iterationLoop- 3

Test Request Data by iterationLoop- 4

Test Request Data by noSeparator

Test Reply Data by noSeparator

Test Request Data by preDefinedSeparator
Test Reply Data by preDefinedSeparator
Test Request Data by userDefinedSeparator
Test Reply Data by userDefinedSeparator
Test Request Data by binarySeparator
Test Reply Data by binarySeparator

The Console view displays the output similar to the following.

10:40:20.505 INFO [bwThread:In-Memory STWorkProcessor-1]
c.t.b.p.g.L.t.b.s.p.t.B.PrintRequest - Test Request Data by iterationLoop- 1

10:40:20.545 INFO [bwThread:In-Memory STWorkProcessor-5]
c.t.b.p.g.L.t.b.s.p.t.B.PrintRequest - Test Request Data by iterationLoop- 2
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10:40:20.568 INFO [bwThread:In-Memory STWorkProcessor-7]
c.t.b.p.g.L.t.b.s.p.t.B.PrintRequest - Test Request Data by iterationLoop- 3

10:40:20.593 INFO [bwThread:In-Memory STWorkProcessor-8]
c.t.b.p.g.L.t.b.s.p.t.B.PrintRequest - Test Request Data by iterationLoop- 4

10:40:20.618 INFO [bwThread:In-Memory STWorkProcessor-2]
c.t.b.p.g.L.t.b.s.p.t.B.PrintRequest -

10:40:21.447 INFO [bwThread:In-Memory STWorkProcessor-1]
c.t.b.p.g.L.t.b.s.p.t.B.PrintRequest - Test Request Data by noSeparator

10:40:21.491 INFO [bwThread:In-Memory STWorkProcessor-7]
c.t.b.p.g.L.t.b.s.p.t.B.PrintReply - Test Reply Data by noSeparator

10:40:22.428 INFO [bwThread:In-Memory STWorkProcessor-4]
c.t.b.p.g.L.t.b.s.p.t.B.PrintRequest - Test Request Data by preDefinedSeparator

10:40:22.460 INFO [bwThread:In-Memory STWorkProcessor-3]
c.t.b.p.g.L.t.b.s.p.t.B.PrintReply - Test Reply Data by preDefinedSeparator

10:40:23.429 INFO [bwThread:In-Memory STWorkProcessor-2]
c.t.b.p.g.L.t.b.s.p.t.B.PrintRequest - Test Request Data by userDefinedSeparator

10:40:23.445 INFO [bwThread:In-Memory STWorkProcessor-6]
c.t.b.p.g.L.t.b.s.p.t.B.PrintReply - Test Reply Data by userDefinedSeparator

10:40:24.429 INFO [bwThread:In-Memory STWorkProcessor-7]
c.t.b.p.g.L.t.b.s.p.t.B.PrintRequest - Test Request Data by binarySeparator

10:40:24.467 INFO [bwThread:In-Memory STWorkProcessor-8]
c.t.b.p.g.L.t.b.s.p.t.B.PrintReply - Test Reply Data by binarySeparator

Understanding the Configuration

The following TCP palette activities are used in this sample:

e TCP Receiver: The process starter starts a new process, when a client requests a TCP
connection.

» Wait for TCP Request: The activity waits for a TCP client connection request.

* TCP Open Connection: The activity opens a connection to a TCP server.
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e TCP Close Connection: The activity closes a TCP connection opened by a previously
executed activity or process starter.

» Write TCP Data: The activity sends data on the specified TCP connection.
» Read TCP Data: The activity reads data from an open TCP connection.
The processes show the use of Binary and Text modes.
Binary mode:

» The binarySeparator sub-package shows the use of user-defined binary separator in
binary mode.

e The iterationLoop sub-package shows the use of an iteration loop.
» The noSeparator sub-package shows the use of no separator in binary mode.
Text mode:

* The preDefinedSeparator sub-package shows the use of a pre-defined text separator
in text mode.

» The userDefinedSeparator sub-package shows the use of a user-defined text
separator in text mode.

Sharing a TCP Connection across Multiple
Processes

A TCP connection can be shared across multiple processes or jobs. This simple sample
shows the connection sharing across jobs. In a real-world scenario, the application
implementation would handle the ordering or synchronization of request and responses
when the connection is shared.

The process contains:
» Server: Receives multiple requests from the client processes and logs the request.

* Initialize Connection: Opens a TCP Connection to the server and sets the connection
to a Shared variable.

e Client A/Client B/Client C: Client processes that use the shared connection to send
requests.
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Procedure

1.

In the samples directory, select palette > tcp > SharedTCPConnection and double-
click tibco.bw.sample.palette.tcp.SharedTCPConnection. For more information,
see Accessing Samples.

In the Project Explorer view, expand the
tibco.bw.sample.palette.tcp.SharedTCPConnection project.

Set the default ApplicationProfile to match the OS you are running on. For more
information, see Setting the Default Application Profile.

Fully expand the Processes directory. Two sub-packages are available, one
containing the server and another containing three client processes and the initialize
TCP connection process. Explore each process by double-clicking it.

Click Run > Debug Configurations.

At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.palette.tcp.SharedTCPConnection.application.

Click Debug.

This runs the sample in Debug mode.

Click the Terminate® icon to stop the process.

Result

The result, similar to the following, is written to the SharedTCPConnection. log file at
C:\tmp\SharedTCPConnectiion.

Text 1 from Client A

Text 2 from Client B

Text 3 from Client C

Understanding the Configuration

The following properties are defined and the default values can be changed:
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e The TCPConnectionProperty that points to the TCP shared resource connection.

* The FilenameProperty that points to the Output_File. This file is created by the
sample process and contains the output. The default value is
C:\tmp\SharedTCPConnection\SharedTCPConnection. log.

Inter Process Communication using Wait for
Notification and Notify Activities

This sample explains inter-process communication using the Notify and the Wait for
Notification activities in different processes. One process notifies the other waiting process
using these activities. These activities are co-related using the key configured on the
General tab and the same Notify Configuration resource configured for both the
activities.

Procedure
1. In the samples directory, select palette > generalactivities > WaitNotify and
double-click tibco.bw.sample.palette.generalactivities.WaitNotify. For more
information, see Accessing Samples.

2. In the Project Explorer view, expand the
tibco.bw.sample.palette.generalactivities.WaitNotify project.

3. Set the default ApplicationProfile to match the OS you are running on. For more
information, see Setting the Default Application Profile.

4. Fully expand the Processes directory.
5. Click Run > Debug Configurations.

6. At the left hand tree of Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.

7. Click the Applications tab and then click the Deselect All button if you have multiple
applications. Select the check box next to
tibco.bw.sample.palette.generalactivities.WaitNotify.application.

8. Click Debug.

This runs the sample in Debug mode.

9. Click the Terminate 8 icon to stop the process.
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Result
A waitnotify.log fileis created in the C:\tmp\WaitNotify folder of the default location,
or the path you specified earlier. This file contains the information similar to the following:

Main Process: Started the main process

Main Process: Spawning non-inline sub process

Main Process: Activity Waiting for the notification

Sub Process : Non-inline sub process started

Sub Process : Notification sent for the waiting activity

Main Process: Notification Received from the other process with Data: Results sent from the
notifying process

Understanding the Configuration

The scenario depicts a simple inter process communication use case.
e The main process is triggered through a Timer activity.
e The main process spawns a non-inline sub process.
e The main process then starts waiting, using a Wait for Notification activity.

e The spawned sub process sends the notification for the waiting activity using a
Notify activity and proceeds further.

» The Wait for Notification activity in the main process receives the notification and
proceeds further.
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Migrating Projects

ActiveMatrix BusinessWorks 6.x provides an easy way to migrate ActiveMatrix
BusinessWorks 5.x projects by using the Migrate BW Projects menu option in TIBCO
Business Studio for BusinessWorks. You can also use the Eclipse import mechanism to
migrate the projects.

Migrating the Project Using TIBCO Business Studio for BusinessWorks

Procedure
1. In TIBCO Business Studio for BusinessWorks, go to Project > Migrate BW Projects....

Project | Fun  Window Help

Open Project

Close Project

Build All Ctrl+B
Build Project

Build Working Set 2
Clean...

v | Build Automatically
%) Generate Javadoc...
Properties

m Migrate EW Projects...

2. In the BusinessWorks Migration Tool wizard, specify the relevant information in the
following fields.

a. Click Browse in the BusinessWorks 5 Project Folder field and provide the
location of the ActiveMatrix BusinessWorks 5.x project that you want to
migrate. The tool scans the ActiveMatrix BusinessWorks 5.x projects in the
specified folder location and displays the list of projects.

b. In the Migrated Project Folder field, click Browse and provide the location
where you want to migrate the project.
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c. Select the Add External JARs check box if the ActiveMatrix BusinessWorks 5.x
project is using external JAR files in context with Java activities.

It is a best practice to place the external JAR files in a single location. These
JAR files can then be in-lined in the migrated ActiveMatrix BusinessWorks 6.x
project.

d. Click Browse in the Jar Location field and provide the location of the JAR files
on disk.

3. In the BusinessWorks 5 Projects area, select the projects you want to migrate and
click Migrate.

The migrated projects are visible in the Migration Output area.

4. Click Close after the migration is complete.

Note: You can alternatively migrate the projects using the File > Import menu
option. Select Migrate BW Projects... > Next in the Import dialog.

Manual Task during Migration

Some of the samples require certain manual steps to be performed while migrating the
samples. You can refer to the steps mentioned in the listed samples.

HTTP Basic Sample

This section describes how to migrate an HTTP Basic sample.

Before you begin
Migrate the ActiveMatrix BusinessWorks 5.x project.

Procedure
1. Click the Incoming-HTTP-request (HTTP Receiver) activity.

2. Click the General tab.

3. In the Parameter table, change the Parameter Cardinality from Required to
Optional.
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= Properties 1 |[2] Problems| &) BW Help| @ Console| #&[@® ~=18
9, HTTPReceiver (HTTP Receiver)
-
General Name: [ HTTPReceiver |
Description | HTTP € | httpConnectorResource | [3 - No Default Value Set - | =
Advanced Context Path [ i3
Tags -
S Path Spec: [ i3
Output Editor
= Output Style: | string v
Conversations
Parse Post Method Data: ]
Output
lPoicy | Parameter Name Parameter Type Parameter Cardinality E
Parameters E
Expose Security Context: O
Default Encoding: |1508859_1 V&

4. Click the Send-Request-to-Wiki-News (Send HTTP Request) activity and specify the
following three values on the Input tab.

—
= Properties % |[£] Problems|  BW Help| & Console| ?lo|l@% =AW =8
@& SendHTTPRequest (Send HTTP Request)

General

- Data Source Functions| Constants| XPath Expression @
Description
> $*$_processContext ~ 52 SendHTTPRequest-inpu
Advanced y
ABE SA =~ Bl RequestActivitylnput
Tags 8¢ $8 RBE Host?
Input Editor 123 Port?
Output Editor A8t Method?
Input A8t RequestURI?
ABC ?
Output PostData?
= BBE QueryString?
ault 123 Timeout?
Policy ~ [E Headers?

ARt Accept?
A8t Accept-Charset
RBt Accept-Encodin
A3t Content-Type?
hB¢ Cookie?
A8t Pragma?
~ [E DynamicHeaders?
» Bl Header

Input Type Values
RequestURI "/wiki/Main_Page"
Accept-Encoding  "text/*, text/html, text/html;level=1"

Content-Type "text/html;charset=UTF-8"

5. Click the Send-Response-from-Wiki-News (Send HTTP Response) activity and
specify the value for Content-Type on the Input tab.
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[ Properties &2 l'm',' Prublems‘ @ BW Help| =] CDHSD|E‘ Ml&® Y= 0
© SendHTTPResponse (Send HTTP Response)

|

General Name: ‘ ﬁendHWPRespuhse

Description Reply For: v
Tags Flush Response: [}

Input Editor Close Connection:

Conversations

Input

Fault

HTTP Persistent Connection

This topic describes migrating this project from ActiveMatrix BusinessWorks 5.x to
ActiveMatrix BusinessWorks 6.x.

Before you begin
Migrate the ActiveMatrix BusinessWorks 5.x project.

Procedure
1. In the HTTP Client shared resource, Client.ClientProcess-Send-HTTP-Request-
HttpClientResource, provide the specified details in the following fields.

Field Value
Maximum Total Connections 3
Maximum Total Connections Per Host 2

Connection Timeout (ms) 20000

2. Provide the same HTTP Client shared resource Client.ClientProcess-Send-HTTP-
Request-HttpClientResource to the following activities in the process,
ClientProcess.bwp.

a. Send-HTTP-Request-1
b. Send-HTTP-Request-1-1
c. Send-HTTP-Request-1-2
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d. Send-HTTP-Request-1-3

JAVA Method Project

This topic describes migrating this project from ActiveMatrix BusinessWorks 5.x to
ActiveMatrix BusinessWorks 6.x.

Before you begin
Migrate the ActiveMatrix BusinessWorks project.

Procedure
1. Go to PublishBalance.bwp and perform Check and Repair for the InvalidAcctExp
and PublishException activities.

2. In the Mapper Check and Repair wizard, check for
jmexample.InvalidAccountException.

5 | Mapper Check and Repair HE-
s Fix  Severity Detals
FTNE Mo matching rs 1 jmexamphe brvalidAccount Exception
[ O . Cancel

3. Run the sample.

JMS Message Selector Project

This topic describes migrating this project from ActiveMatrix BusinessWorks 5.x to
ActiveMatrix BusinessWorks 6.x.

Before you begin
Migrate the ActiveMatrix BusinessWorks 5.x project.

Procedure
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then click the Advanced tab.

and select JMSApplicationProperties.

Open QueueMessageSelector.bwp, click on the JMS-Queue-Sender activity and

Click Application Properties Type, open the Select Schema Type Definition wizard

Bi|A~®~ g==x=|
@ Gurwlesssgeidectorbwp 11

| B~ i~ e~ 1|

q

B = |[200%

O Preperties &1 .
* JM5-Queve-Sender (JMS
[ rov Eeply To Destingtion:
Dmcrption  Drinary Mode
s -
Input Edos
Pragrity
Input |
owpa o
Fasslt Illwkmhw-'hn‘fm
| {wvemde Transaction Behavion
T Prepetion =5 | 51 Postilaren | () P Wip | B Comacia #lhe@ne|8es ~-d
2 IMS-Cuene-Sender (JMS Send  Message)
Ganesl | ] ;
[Denergption imm_'-m | Conitpaty NPk Eaprr s n
Advanced| || & & 525 pecsiCem a 5= INS-Quouc-Soader-ingut
Ingua Linga R kgt mend v & B hethisrieput
e ME Dk odgr M driraanion”
kegwt B, 4T rage e
Dutp | Mt 10cevain 123 MTLpiatan?
Fo L TrlpakTrslied 2N piPeomry?
i S SEUECTOR [T T
Bt $ire Pegnd it ibE S CormelationiDF
L e S e A M A Tpe?
g et ke Daesien a B APeopartan?
M1 18 Lpemen il GO
[ i 128 ML EGeatea?
it P3derdicn 8 Body concetl Thes & mesuige sumber . 8
Pt SRt 2 B DysamcPrpet?
Mt Eakort # B property”
L STEHesADemes it rare
Mt STkt e [
it TR Sarice o e
BE R DEPLOVMENTLRIT, TR — a [ Cthefrapetie
G W ASFHODE MANE [ &
A DEFLCYIVENTLRIT il
Mt S8V HOST RALE
Bt SR DOLLAR BT
Mt S POV NTUN T VRS
WL B AP AL NAME
Mt SO VIR
¥ S DDLU NN
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3. Run the process.

HTML Mail with Image

Migrating this project from ActiveMatrix BusinessWorks 5.x to ActiveMatrix BusinessWorks
6.x involves certain manual steps to be performed. This topic provides information about
the manual steps involved for a successful migration.

Before you begin
Migrate the ActiveMatrix BusinessWorks 5.x project.

Procedure
1. Go to Sender.bwp and click on Send-Mail activity.

2. Do Check and Repair.

) Mapper Charck s Rarpair o |
& | Fu SEwlty Dretashs |
- | A Expected hat "elarnent sentdite?” bedcne Bl elerent
+= Pth o risteng. Peevde XPsth o wie Bomene Mappesy comenand
) Chype rpmespace 1o nall
+ Uninpacted cutpat, "bert e dndendh mimmaurm g4dutird
B Unexporied sutpal, “Bedyflerment”; entendi manmunm ooouminte

Mail with Simple Attachment

This topic describes migrating this project from ActiveMatrix BusinessWorks 5.x to
ActiveMatrix BusinessWorks 6.x.

Before you begin
Migrate the ActiveMatrix BusinessWorks 5.x project.

Procedure
1. After migrating the project, select the Sender.bwp process.
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E Sender

o -

Log Send-Mail Log-1

2. Select the Receiver.bwp process.

| Receives

L

Receive-Mail

_ j
& ‘

sz-lm-lmd\mem-
content

- 12
m m 4J—> Nu“ Winite-| hlnwy
Wiite-body-1 Write-body T Log attachment-content o
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TIBCO Documentation and Support Services

For information about this product, you can read the documentation, contact TIBCO
Support, and join TIBCO Community.

How to Access TIBCO Documentation

Documentation for TIBCO products is available on the TIBCO Product Documentation
website, mainly in HTML and PDF formats.

The TIBCO Product Documentation website is updated frequently and is more current than
any other documentation included with the product.

Product-Specific Documentation

The following documentation for this product is available on the TIBCO ActiveMatrix
BusinessWorks™ page:

e TIBCO ActiveMatrix BusinessWorks™ Release Notes

e TIBCO ActiveMatrix BusinessWorks™ Installation

e TIBCO ActiveMatrix BusinessWorks™ Application Development

e TIBCO ActiveMatrix BusinessWorks™ Bindings and Palettes Reference
e TIBCO ActiveMatrix BusinessWorks™ Concepts

e TIBCO ActiveMatrix BusinessWorks™ Error Codes

e TIBCO ActiveMatrix BusinessWorks™ Getting Started

e TIBCO ActiveMatrix BusinessWorks™ Migration

» TIBCO ActiveMatrix BusinessWorks™ Performance Benchmarking and Tuning
e TIBCO ActiveMatrix BusinessWorks™ REST Implementation

e TIBCO ActiveMatrix BusinessWorks™ Refactoring Best Practices

e TIBCO ActiveMatrix BusinessWorks™ Samples
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How to Contact TIBCO Support
Get an overview of TIBCO Support. You can contact TIBCO Support in the following ways:

e For accessing the Support Knowledge Base and getting personalized content about
products you are interested in, visit the TIBCO Support website.

 For creating a Support case, you must have a valid maintenance or support contract
with TIBCO. You also need a user name and password to log in to TIBCO Support
website. If you do not have a user name, you can request one by clicking Register on
the website.

How to Join TIBCO Community

TIBCO Community is the official channel for TIBCO customers, partners, and employee
subject matter experts to share and access their collective experience. TIBCO Community
offers access to Q&A forums, product wikis, and best practices. It also offers access to
extensions, adapters, solution accelerators, and tools that extend and enable customers to
gain full value from TIBCO products. In addition, users can submit and vote on feature
requests from within the TIBCO Ideas Portal. For a free registration, go to

TIBCO Community.
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Legal and Third-Party Notices

SOME TIBCO SOFTWARE EMBEDS OR BUNDLES OTHER TIBCO SOFTWARE. USE OF SUCH EMBEDDED
OR BUNDLED TIBCO SOFTWARE IS SOLELY TO ENABLE THE FUNCTIONALITY (OR PROVIDE LIMITED
ADD-ON FUNCTIONALITY) OF THE LICENSED TIBCO SOFTWARE. THE EMBEDDED OR BUNDLED
SOFTWARE IS NOT LICENSED TO BE USED OR ACCESSED BY ANY OTHER TIBCO SOFTWARE OR FOR
ANY OTHER PURPOSE.

USE OF TIBCO SOFTWARE AND THIS DOCUMENT IS SUBJECT TO THE TERMS AND CONDITIONS OF A
LICENSE AGREEMENT FOUND IN EITHER A SEPARATELY EXECUTED SOFTWARE LICENSE AGREEMENT,
OR, IF THERE IS NO SUCH SEPARATE AGREEMENT, THE CLICKWRAP END USER LICENSE AGREEMENT
WHICH IS DISPLAYED DURING DOWNLOAD OR INSTALLATION OF THE SOFTWARE (AND WHICH IS
DUPLICATED IN THE LICENSE FILE) OR IF THERE IS NO SUCH SOFTWARE LICENSE AGREEMENT OR
CLICKWRAP END USER LICENSE AGREEMENT, THE LICENSE(S) LOCATED IN THE “LICENSE” FILE(S) OF
THE SOFTWARE. USE OF THIS DOCUMENT IS SUBJECT TO THOSE TERMS AND CONDITIONS, AND
YOUR USE HEREOF SHALL CONSTITUTE ACCEPTANCE OF AND AN AGREEMENT TO BE BOUND BY THE
SAME.

This document is subject to U.S. and international copyright laws and treaties. No part of this
document may be reproduced in any form without the written authorization of Cloud Software
Group, Inc.

TIBCO, the TIBCO logo, the TIBCO O logo, ActiveMatrix BusinessWorks, ActiveSpaces, Business Studio,
TIBCO Business Studio, TIBCO Designer, TIBCO Enterprise Administrator, Enterprise Message Service,
Rendezvous, and TIBCO Runtime Agent are either registered trademarks or trademarks of Cloud
Software Group, Inc. in the United States and/or other countries.

Java and all Java based trademarks and logos are trademarks or registered trademarks of Oracle
and/or its affiliates.

This document includes fonts that are licensed under the SIL Open Font License, Version 1.1, which is
available at: https://scripts.sil.org/OFL

Copyright (c) Paul D. Hunt, with Reserved Font Name Source Sans Pro and Source Code Pro.

All other product and company names and marks mentioned in this document are the property of
their respective owners and are mentioned for identification purposes only.

This software may be available on multiple operating systems. However, not all operating system
platforms for a specific software version are released at the same time. See the readme file for the
availability of this software version on a specific operating system platform.
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THIS DOCUMENT IS PROVIDED “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR
IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

THIS DOCUMENT COULD INCLUDE TECHNICAL INACCURACIES OR TYPOGRAPHICAL ERRORS. CHANGES
ARE PERIODICALLY ADDED TO THE INFORMATION HEREIN; THESE CHANGES WILL BE INCORPORATED
IN NEW EDITIONS OF THIS DOCUMENT. CLOUD SOFTWARE GROUP, INC. MAY MAKE IMPROVEMENTS
AND/OR CHANGES IN THE PRODUCT(S) AND/OR THE PROGRAM(S) DESCRIBED IN THIS DOCUMENT AT
ANY TIME.

THE CONTENTS OF THIS DOCUMENT MAY BE MODIFIED AND/OR QUALIFIED, DIRECTLY OR
INDIRECTLY, BY OTHER DOCUMENTATION WHICH ACCOMPANIES THIS SOFTWARE, INCLUDING BUT
NOT LIMITED TO ANY RELEASE NOTES AND "READ ME" FILES.

This and other products of Cloud Software Group, Inc. may be covered by registered patents. Please
refer to TIBCO's Virtual Patent Marking document (https://www.tibco.com/patents) for details.

Copyright © 2023. Cloud Software Group, Inc. All Rights Reserved.

TIBCO ActiveMatrix BusinessWorks™ Samples


https://www.tibco.com/patents

	Contents
	Changing Help Preferences
	Accessing Samples
	Guided User Experience in TIBCO Business Studio for BusinessWorks
	Setting the Default Application Profile
	Creating a ActiveMatrix BusinessWorks Project from Template
	Unit Testing
	Maven Test Sample of Main Process
	Understanding the Configuration

	Maven Sample of Unit Test Demo Project
	Understanding the Configuration


	Binding Features
	Using Basic REST Binding
	Understanding the Configuration
	Troubleshooting

	Using REST to Manage Books for a Bookstore
	Understanding the Configuration
	Troubleshooting

	Implementing a REST Service Using a JSON File with allOf Keyword
	Understanding the Configuration
	Troubleshooting

	Implementing a REST Service Using a JSON File with anyOf Keyword
	Understanding the Configuration
	Troubleshooting

	Implementing a REST Service Using a JSON File with oneOf Keyword
	Understanding the Configuration
	Troubleshooting

	Implementing Multiple Response based REST Service using a JSON file
	Understanding the Configuration
	Troubleshooting

	Using a SOAP Web Service to Make a Query to a Bookstore
	Understanding the Configuration

	Reconfiguring a Web Service by Changing the Transport
	Converting the Transport from SOAP over JMS to SOAP over HTTP
	Using a SOAP Connection to Publish Messages to Multiple Endpoints
	Sending and Receiving a SOAP Bound Attachment
	Understanding the Configuration

	Interoperability of Using JAX-WS Client to Invoke Service
	Understanding the Configuration

	Invoking a SOAP over HTTP Web Service Using Different SOAP Versions
	Understanding the Configuration

	Invoking a SOAP over HTTP Web Service Using Different Binding Styles
	Understanding the Configuration

	Implementing a Service with a Service Binding and a Client with a Reference B...
	Understanding the Configuration

	Implementing a Mortgage Loan Application with Fault
	Understanding the Configuration

	Sending and Receiving a SOAP Unbound Attachment
	Understanding the Configuration

	Managing a Purchase Order
	Understanding the Configuration

	Using SOAP Bound Headers
	Understanding the Configuration

	Using SOAP UnBound Headers
	Understanding the Configuration

	Using SOAP HTTP Transport Headers
	Understanding the Configuration

	Sending a SOAP Request and Receiving a SOAP Reply
	Understanding the Configuration

	Implementing a HTTP Service That Returns Information Based on ZIP Codes
	Understanding the Configuration

	Implementing a JMS Service That Writes Attachment to File
	Understanding the Configuration

	Sending a One Way Message over JMS
	Understanding the Configuration

	Using JMS Destination Bridges
	Understanding the Configuration

	Implementing a JMS Service that Returns Information Based on Zip Codes
	Understanding the Configuration

	Implementing a JMS Service That Returns an Attachment

	Core Features
	Using Process and Module Properties
	Using a Process Conversation to Correlate JMS Message Jobs
	Understanding the Configuration

	Using Modularity with the Java Palette
	Understanding the Configuration
	Process
	Troubleshooting

	Configuring a Conversation to Join a Wait for File Change Activity
	Understanding the Configuration
	Using an Asynchronous Event Handler to Implement a Simple Mortgage Workflow
	Understanding the Configuration

	Using a Cross Process Conversation to Determine the Mortgage Rate
	Understanding the Configuration

	Catching Activity Faults with Scope and Fault Handlers
	Modularity Among Applications with a Shared Module Project
	Understanding the Configuration

	Load Balancing an Application Using an AppSpace
	Invoking Subprocesses
	Understanding the Configuration

	Dynamically Invoking Subprocesses Using SetEPR Activity
	Troubleshooting

	Calling a Direct Subprocess
	Understanding the Configuration

	Collecting Process, Activity, and Transition Statistics

	Policy Feature
	Enforcing Basic Authentication with LDAP Authentication
	Understanding the Configuration

	Enforcing Basic Authentication on a REST Service Binding
	Understanding the Configuration

	Enforcing Basic Credential Mapping on an Outbound Request
	Understanding the Configuration

	Enforcing SOAP Security to Enable Confidentiality and Integrity on Message Ex...
	Understanding the Configuration

	Enforcing SOAP Security to Enable SAML Authentication and SAML Credential Map...
	Understanding the Configuration

	Exposing Security Context
	Understanding the Configuration


	Palettes Features
	Creating an Order Processing Service
	Understanding the Configuration

	Using FTP to Put and Get Files
	EXAMPLE_6AA1D9E5B3EC4EB7A815AD4BEF1EEF8C

	Using HTTP to Send and Receive Dynamic Headers
	Understanding the Configuration

	HTTP Sending and Receiving MIMEAttachments
	Understanding the Configuration

	Using HTTP or SOAP to Get Information from MySQL
	Understanding the Configuration

	Using the HTTP Persistent Connection Feature
	Sending a Request and Getting a Response from a Website
	Sending a Secured Request and Getting a Secured Response from a Web Site
	Understanding the Configuration

	Invoking Custom Code to Complete a Purchase Order
	Understanding the Configuration
	Troubleshooting

	Using Java Activities to Publish Information
	Using Java Invoke that Makes a REST call to Search Twitter
	Understanding the Configuration
	Troubleshooting

	Using a Custom Process Starter in a Project That Gets Information about a Che...
	Understanding the Configuration
	Troubleshooting

	Using JDBC Query - Process in Subsets and JDBC Update - Batch Updates
	Understanding the Configuration

	Setting Up a JDBC Connection to Query and Update Tables
	Understanding the Configuration

	Using Oracle Objects and Collections in JDBC Call Procedure and JDBC Query Ac...
	Understanding the Configuration

	Setting Up and Executing JDBC Activities with Eclipse Using DTP
	Understanding the Configuration

	Sending and Getting JMS Messages
	Understanding the Configuration

	Using JMS Message Selector
	Understanding the Configuration

	Receiving a JMS Message from a Queue and Responding to the Message
	Understanding the Configuration

	Sending a JMS Message and Receiving a Response in a Process
	Sending a JMS Message to a Queue and Waiting for a Response
	Understanding the Configuration

	Sending a JMS Message and Receiving a Durable Response
	Understanding the Configuration

	Sending Mail Using HTML
	Sending Mail Using MIME
	Sending and Receiving Mail
	Troubleshooting

	Publishing and Subscribing to TIBCO Rendezvous Messages
	Understanding the Configuration

	Managing TCP Connections
	Understanding the Configuration

	Sharing a TCP Connection across Multiple Processes
	Understanding the Configuration

	Inter Process Communication using Wait for Notification and Notify Activities
	Understanding the Configuration


	Migrating Projects
	HTTP Basic Sample
	HTTP Persistent Connection
	JAVA Method Project
	JMS Message Selector Project
	HTML Mail with Image
	Mail with Simple Attachment

	TIBCO Documentation and Support Services
	Legal and Third-Party Notices

