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TIBCO Documentation and Support Services

Documentation for this and other TIBCO products is available on the TIBCO Documentation site. This
site is updated more frequently than any documentation that might be included with the product. To
ensure that you are accessing the latest available help topics, please visit:

https://docs.tibco.com

Product-Specific Documentation

Documentation for TIBCO products is not bundled with the software. Instead, it is available on the
TIBCO Documentation site. To directly access documentation for this product, double-click the
following file:

TIBCO_HOME/release_notes/TIB_adr3bs_version_number_docinfo.html

where TIBCO_HOME is the top-level directory in which TIBCO products are installed. On Windows,
the default TIBCO_HOME is C:\Program Files\tibco. On UNIX systems, the default TIBCO_HOME
is /opt/tibco.

The following documents for this product can be found on the TIBCO Documentation site:

● TIBCO ActiveMatrix Adapter for SAP (TIBCO Business Studio) Installation
● TIBCO ActiveMatrix Adapter for SAP (TIBCO Business Studio) User's Guide
● TIBCO ActiveMatrix Adapter for SAP (TIBCO Business Studio) Examples
● TIBCO ActiveMatrix Adapter for SAP (TIBCO Business Studio) Release Notes

How to Contact TIBCO Support

For comments or problems with this manual or the software it addresses, contact TIBCO Support:

● For an overview of TIBCO Support, and information about getting started with TIBCO Support,
visit this site:

http://www.tibco.com/services/support

● If you already have a valid maintenance or support contract, visit this site:

https://support.tibco.com

Entry to this site requires a user name and password. If you do not have a user name, you can
request one.

How to Join TIBCOmmunity

TIBCOmmunity is an online destination for TIBCO customers, partners, and resident experts. It is a
place to share and access the collective experience of the TIBCO community. TIBCOmmunity offers
forums, blogs, and access to a variety of resources. To register, go to the following web address:

https://www.tibcommunity.com

4

TIBCO ActiveMatrix® Adapter for SAP (TIBCO Business Studio™) Examples

https://docs.tibco.com
http://www.tibco.com/services/support
https://support.tibco.com
https://www.tibcommunity.com


Examples Overview

TIBCO ActiveMatrix® Adapter for SAP (TIBCO Business Studio™) provides seven examples to show
how the adapter interacts with the SAP system.

After installing TIBCO ActiveMatrix® Adapter for SAP, navigate to the TIBCO_HOME\adapter
\adr3\version_number\examples directory. You can find two example folders. The ActiveMatrix
BusinessWorks 5 examples are in the BusinessWorks5 folder. And the ActiveMatrix BusinessWorks 6
examples are in the BusinessWorks6 folder.

Because TIBCO Business Studio™ does not support the concatenation of strings and module properties,
you have to check the module properties in the Module Properties editor when configuring the
example. Ensure that the value of a module property is comprised of either strings or other module
properties, but not the concatenation.

BusinessWorks 5 Examples

You can find the following examples in the BusinessWorks5 folder:

● DynamicLogonExternalCommit

This example shows how to use the dynamic logon and the Inbound BAPI transaction support
features provided by the adapter.

● InboundIDocWithInboundBAPI

This example shows how to use the Subscription Service and the Request-Response Service services.
● OutboundIDocWithRemoteTIDManager

This example shows how to use the remote TIDmanagement and how to randomly use the
Publication Service services in different adapter configurations.

● OutboundRFCWithInboundBAPI

This example shows how to use the Request-Response Invocation Service and the Request-Response
Service services.

● IDoc Format Publishing Mode

This example shows how to use the adapter for sending and receiving IDocs without any significant
mapping, and the usage of JMS properties for the Publication Service service and the IDoc
confirmation.

● Salesforce

— SalesforceOpportunityToSAPOrder

This example shows how to set up communication between the SAP system and Salesforce.com
by using the adapter.

Both the BusinessWorks5 folder and BusinessWorks6 folder contain an example
named as SalesforceOpportunityToSAPOrder. Although the names of the processes in
the SalesforceOpportunityToSAPOrder examples are different, the configurations of
the processes are same. Therefore, if you want to run the
SalesforceOpportunityToSAPOrder example in TIBCO Business Studio, you can just
import the SalesforceOpportunityToSAPOrder example in the BusinessWorks6
folder.

The examples in the BusinessWorks5 folder are created in TIBCO Designer™. If you want to run these
examples in TIBCO Business Studio, first you have to migrate the example projects into TIBCO
Business Studio. See Migrating an Example to TIBCO Business Studio for more details.
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BusinessWorks 6 Example

You can find the following example in the BusinessWorks6 folder:

● Salesforce

— SalesforceOpportunityToSAPOrder

This example shows how to set up communication between the SAP system and Salesforce.com
by using the adapter.

The example in the BusinessWorks6 folder is created in TIBCO Business Studio. Before running this
example, first you have to import the example project into TIBCO Business Studio. See Importing an
Example to TIBCO Business Studio for more details.
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Prerequisites of Running Examples

Before running the examples, you have to install the required software, migrate or import the example
projects, and start the EMS server and the adapter configuration.

Required Software
You have to install the required software to run the example projects.

The following are the required software:

● TIBCO Enterprise Message Service™

● TIBCO Runtime Agent™

● TIBCO ActiveMatrix Adapter for SAP
● TIBCO ActiveMatrix BusinessWorks™

● TIBCO ActiveMatrix® Adapter Framework

● TIBCO® Enterprise Administrator

TIBCO Enterprise Administrator is required only when you want to manage and monitor examples
at run time.

● TIBCO ActiveMatrix BusinessWorks™ Plug-in for Salesforce.com
TIBCO ActiveMatrix BusinessWorks Plug-in for Salesforce.com is required for the 
SalesforceOpportunityToSAPOrder example and the version must be 6.1.0 or later.

For details about the supported version of the software, see Readme file.

Migrating an Example to TIBCO Business Studio
To run an ActiveMatrix BusinessWorks 5 example project in TIBCO Business Studio, first you have to
migrate the example project to TIBCO Business Studio.
The example file is in the TIBCO_HOME\adapter\adr3\version_number\examples
\BusinessWorks5\Example_Name directory.

Prerequisites

Ensure that you have extracted the BusinessWorks 5 example zip file.

Procedure

1. In TIBCO Business Studio, choose one of the following two ways to open the BusinessWorks
Migration Tool dialog:

● From the menu, click Project > Migrate BW Projects.
● From the menu, click File > Import. In the Import wizard, select Migrate BW Projects >

Migrate BW Projects, and then click Next.

2. In the BusinessWorks Migration Tool dialog, click Browse next to the BusinessWorks 5 Projects
Folder field to select the ActiveMatrix BusinessWorks 5 example folder containing the example
project that you want to migrate.

3. Click Browse next to the Migrated Projects Folder field to select a directory where you want to
stored the migrated project.

4. In the BusinessWorks 5 Projects panel, click the project that you want to migrate.
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5. Click Migrate to start the migration process.

6. After the migration is finished, click Close.

Result

The migrated example project is displayed in the Project Explorer view.

Importing an Example to TIBCO Business Studio
To run an ActiveMatrix BusinessWorks 6 example project, first you have to import the example project
to TIBCO Business Studio.
The example file is in the TIBCO_HOME\adapter\adr3\version_number\examples
\BusinessWorks6\Salesforce\Example_Name directory.

Procedure

1. From the menu, click File > Import to open the Import wizard.

2. Select General > Existing Studio Projects into Workspace, and then click Next.

3. In the Import Projects dialog, click Select archive file.

4. Click Browse next to the Select archive file field to select the ActiveMatrix BusinessWorks 6
example zip file containing the example project that you want to import.

5. Click Finish.

Result

The imported example project is displayed in the Project Explorer view.

Starting the EMS Server
All of the examples use the JMS transport type. Before starting the adapter configuration, you have to
start the TIBCO Enterprise Message Service server.

Start the EMS server in one of the following ways:

● On Microsoft Windows, click Start > All Programs > TIBCO > TIBCO_HOME > TIBCO EMS
[version_number] > Start EMS Server

● On UNIX, complete the following steps:

1. On the command line, navigate to the TIBCO_HOME/ems/version_number/bin directory.

2. Enter the following command: ./tibemsd64 -config ~/TIBCO_HOME/tibco/cfgmgmt/ems/
data/tibemsd.conf

Starting an Adapter Configuration
Before running an example project, you have to start the adapter configuration in the example project
to enable data exchange between the adapter and the SAP system.

Prerequisites

Ensure that you have configured the example project accordingly.
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Procedure

1. From the menu, click Run > Run Configurations to open the Run Configuration window.

2. Double-click Adapter Launcher to create an adapter launcher to run the adapter configuration.

3. In the Adapter Configuration tab, click Browse next to the Adapter Configuration field to select
the adapter configuration in the example project.
After you select the adapter configuration, the adapter launcher name displayed in the Name field
is changed to Project_Name-AdapterConfiguration_Name.

4. Optional: Click Browse next to the Working Directory field to select a new directory to store the
runtime information and support files.
The default directory is Work_Space/.metadata/.plugins/com.tibco.adr3.ui.

5. If you want to store the configuration information in this adapter launcher, click Apply.

6. Click Run to start the adapter configuration.
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Dynamic Logon and External Commit

The DynamicLogonExternalCommit example shows how to use the dynamic logon and the inbound
BAPI transaction support features provided by the adapter.

This example contains two processes, Create-SalesOrder and Create-SaleOrder-with-Auto-Commit.

Both of the processes are configured with the Request-Response Service services. When running the
processes, the adapter creates a dynamic connection to create sales orders in the SAP system.

The adapter packages the Create_SalesOrder_Send_Template.xml file in the TIBCO_HOME\adapter
\adr3\version_number\examples\BusinessWorks5\DynamicLogonExternalCommit directory. The
Create_SalesOrder_Send_Template.xml file contains the input data of these two processes.

The adapter invokes the BAPI_SALESORDER_CREATEFROMDAT1 function module to create a sales
order in the SAP system based on the input data in the Create_SalesOrder_Send_Template.xml file.

If an error occurs when the adapter invokes the BAPI_SALESORDER_CREATEFROMDAT1 function
module, the error is written to the OrderStatus.xml file.

However, these two processes use different function models and mechanisms to commit and roll back a
sales order in the SAP system:

● In the Create-SalesOrder process, if the adapter fails to create a sales order, the adapter invokes the
BAPI_TRANSACTION_ROLLBACK function module to roll back the sales order.

Otherwise, the adapter invokes the BAPI_TRANSACTION_COMMIT function module to commit
the created sales order.

● In the Create-SaleOrder-with-Auto-Commit process, if the adapter fails to create a sales order, the
sales order is automatically rolled back without the invocation of any function module.

Otherwise, the BAPI_TRANSACTION_COMMIT function module is automatically invoked to
commit the created sales order.

Configuring the Example
After migrating the example project to TIBCO Business Studio, you have to configure the project to
ensure that the adapter can access to the SAP system.

Prerequisites

Ensure that you have migrated the example project to TIBCO Business Studio and started the EMS
server.

Procedure

1. In the Project Explorer view, expand DynamicLogonExternalCommit > Module Descriptors, and
then double-click the Module Properties resource.

2. In the Module Properties editor, enter values for the following properties:

● UDConnection\AppServer

● UDConnection\Client

● UDConnection\ConnectionType

● UDConnection\GroupName

● UDConnection\Language

● UDConnection\MsgServer
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● UDConnection\Password

● UDConnection\SNC_lib

● UDConnection\SNC_mode

● UDConnection\SNC_partnername

● UDConnection\SNC_qop

● UDConnection\SNC_bSSO

● UDConnection\SNC_ssoSend

● UDConnection\SNC_x509

● UDConnection\SystemName

● UDConnection\SystemNumber

● UDConnection\UserName

● JMSProviderUrl

● ASAP_HOME

ASAP_HOME is the home directory where you install the adapter. For example, E:\TIBCO_HOME
\adapter\adr3\7.2.

● ASAP_HOME-1

3. Click Save.

4. In the Adapter for SAP Configuration editor, click Test Connection in the Default Client
Connection panel to validate the connection.

Running the Example
After configuring the example project, you can run the processes in the example project to see how to
use the dynamic logon and the inbound BAPI transaction support features provided by the adapter.

Prerequisites

Ensure that you have configured the example project and started the adapter configuration.

Procedure

1. From the menu, click Run > Run Configurations to open the Run Configuration window.

2. Double-click BusinessWorks Application to create an application launcher to run the processes in
the project.

3. In the Applications tab, keep the example project application selected and deselect the other
applications.

4. If you want to store the configuration information in this application launcher, specify a unique
name for it in the Name field and click Apply.

5. Click Run.

6. Navigate to the TIBCO_HOME\adapter\adr3\version_number\examples
\BusinessWorks5\DynamicLogonExternalCommit directory and update the
Create_SalesOrder_Send_Template.xml file.
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Expected Results
You can view the example results in the TIBCO_HOME\adapter\adr3\version_number\examples
\BusinessWorks5\DynamicLogonWithExternalCommit directory.

When the process is finished, all the results of creating a sales order are written to the output file named
OrderStatus.xml. If the process is successful, you can also check the sales order information in the
SAP system.

You can also check the symbolic destination of the active connection in the SAP server or check the
adapter log file to get the dynamic connection result.

The log file is located in the TIBCO_HOME\adapter\adr3\version_number\logs directory.
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Inbound IDoc with Inbound BAPI

The InboundIDocWithInboundBAPI example shows how to use the Subscription and the Request-
Response Service services.

This example contains the Vendor process.

Once you update the VendorInputFile.xml file, the Vendor process is triggered. The Request-
Response Service service invokes the BAPI_GL_ACC_EXISTENCECHECK functional module to
validate the G/L account in the VendorInputFile.xml file.

You can find the VendorInputFile.xml file in the TIBCO_HOME\adapter\adr3\version_number
\examples\BusinessWorks5\InboundIDocWithInboundBAPI directory.

If the G/L account in the VendorInputFile.xml file is valid, the Vendor process publishes a message to
the adapter to create a vender based on the information in the VendorInputFile.xml file. Once the
Subscription Service service receives the message as a CREMAS05 IDoc, the CREMAS05 IDoc is used to
create a vendor in the SAP system.

If the G/L account is invalid, an error message is written to the output file.

Configuring the Example
After migrating the example project to TIBCO Business Studio, you have to configure the project to
ensure that the adapter can access to the SAP system.

Prerequisites

Ensure that you have migrated the example project to TIBCO Business Studio and started the EMS
server.

Procedure

1. In the Project Explorer view, expand InboundIDocWithInboundBAPI > Module Descriptors, and
then double-click the Module Properties resource.

2. In the Module Properties editor, enter values for the following properties:

● AppServer

● Client

● GatewayService

● Password

● SystemNumber

● UserName

● JMSProviderUrl

● GatwayHost

● ProgramID

● ASAP_HOME

ASAP_HOME is the home directory where you install the adapter. For example, E:\TIBCO_HOME
\adapter\adr3\7.2.

● ASAP_HOME-1
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3. Click Save.

4. If you want to enable the TIDManagement for the adapter configuration, change the inbound
TIDManagement mode in the Advanced tab of the Adapter for SAP Configuration editor.

Ensure that the TIDManager clients in the adapter configuration matches the TIDManager
server in the TIDManager configuration, when you select the remote TIDManagement
mode.

5. In the Adapter for SAP Configuration editor, click Test Connection in the Default Client
Connection panel to validate the connection.

Running the Example
After configuring the example project, you can run the processes in the example project to see how to
use the Subscription Service and the Request-Response Service services.

Prerequisites

Ensure that you have configured the example project and started the adapter configuration. Beside this,
you also have to add the name space, InboundIDocWithInboundBAPII/VendorInputFile.xsd, to the
VENDOR_INPUT root element in the VendorInputFile.xml file.

If you have configured the adapter configuration with the remote inbound TIDManagement, you have
to start the TIDManager configuration before starting the adapter configuration. The procedure to start
a TIDManager configuration is the same as an adapter configuration.

Procedure

1. From the menu, click Run > Run Configurations to open the Run Configuration window.

2. Double-click BusinessWorks Application to create an application launcher to run the processes in
the project.

3. In the Applications tab, keep the example project application selected and deselect the other
applications.

4. If you want to store the configuration information in this application launcher, specify a unique
name for it in the Name field and click Apply.

5. Click Run.

6. Navigate to the TIBCO_HOME\adapter\adr3\version_number\examples
\BusinessWorks5\InboundIDocWithInboundBAPI directory and update the
VendorInputFile.xml file.

Expected Results
You can view the example results in the TIBCO_HOME\adapter\adr3\version_number\examples
\BusinessWorks5\InboundIDocWithInboundBAPI directory.

If the G/L account is valid, a vendor is created in the SAP system. You can check the vendor
information in the SAP system.

If the G/L account is invalid, the error is written to the error.xml file.
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Outbound IDoc with Remote TIDManager

The OutboundIDocWithRemoteTIDManager example shows how to use the remote TIDManagement
mode and how to randomly use the Publication Service services in different adapter configurations.

This example contains the following three processes:

● CREMAS-Process Process

Receives a message from the Publication Service service and saves the message containing SAP
Vendor Master Data to an output file.

● DEBMAS-Process Process

Receives a message from the Publication Service service and saves the message containing SAP
Customer Master Data to an input file.

● MATMAS-Process Process

Receives a message from the Publication Service service and saves the message containing SAP
Material Master Data to an input file.

Configuring the Example
After migrating the example project to TIBCO Business Studio, you have to configure the project to
ensure that the adapter can access to the SAP system.

Prerequisites

Ensure that you have migrated the example project to TIBCO Business Studio and started the EMS
server.

Procedure

1. In the Project Explorer view, expand OutboundIDocWithRemoteTIDManager > Module
Descriptors, and then double-click the Module Properties resource.

2. In the Module Properties editor, enter values for the following properties:

● AppServer

● Client

● GatewayService

● Password

● SystemNumber

● UserName

● JMSProviderUrl

● GatewayHost

● ProgramID

● ASAP_HOME

ASAP_HOME is the home directory where you install the adapter. For example, E:\TIBCO_HOME
\adapter\adr3\7.2.

3. Click Save.

4. In the Adapter for SAP Configuration editor, click Test Connection in the Default Client
Connection panel to validate the connection.
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Running the Example
After configuring the example project, you can run the processes in the example project to see how to
use the remote TIDManagement and how to use the Publication Service service in multiple adapter
configurations.

Prerequisites

Ensure that you have configured the example project and started the adapter configuration and the
TIDManager configuration.

You have to start the TIDManager configuration before starting the adapter configuration. The
procedure to start a TIDManager configuration is the same as an adapter configuration.

Procedure

1. From the menu, click Run > Run Configurations to open the Run Configuration window.

2. Double-click BusinessWorks Application to create an application launcher to run the processes in
the project.

3. In the Applications tab, keep the example project application selected and deselect the other
applications.

4. If you want to store the configuration information in this application launcher, specify a unique
name for it in the Name field and click Apply.

5. Click Run.

6. To start the MATMAS process, log on to the SAP system, send a MATMAS01 IDoc using ALE/IDoc
messaging, and execute the SAP transaction BD10.

7. To start the DEBMAS process, log on to the SAP system, send a DEBMAS01 IDoc using ALE/IDoc
messaging, and execute the SAP transaction BD12.

8. To start the CREMAS process, log on to the SAP system, send a CREMAS01 IDoc using ALE/IDoc
messaging, and execute the SAP transaction BD14.

Expected Results
You can find the example results in the TIBCO_HOME\adapter\adr3\version_number\examples
\BusinessWorks5\OutboundIDocWithRemoteTIDManager directory.

The CREMASIDocNumber.xml file that contains the Vendor Master Data is created, when the CREMAS-
Process process is completed.

The DEBMASIDocNumber.xml file that contains the Customer Master Data is created, when the
DEBMAS-Process process is completed.

The MATMASIDocNumber.xml file that contains the Material Master Data is created, when the MATMAS-
Process process is completed.
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Outbound RFC with Inbound BAPI

The OutboundRFCWithInboundBAPI example shows how to use the Request-Response Invocation
Service and the Request-Response Service services.

This example contains two processes. The only difference between the two processes is that the Using-
JMS process uses the JMS transport but the Using-RV process uses the Rendezvous transport.

The Using-JMS and the Using-RV processes receive an event from the SAP system by invoking the
BAPI_XBP_EVENT_RAISE function module. The Request-Response Invocation Service service
forwards this event to the Request-Response Service service.

● When the value of the EVENTID parameter in the incoming event is CUSTOMER, the adapter invokes
the BAPI_CUSTOMER_GETDETAIL2 function module to check if the customer number provided
for the EVENTPARAM parameter is valid.

If the customer number is valid, the process writes the customer information to an output file.
Otherwise, the Request-Response Invocation Service service receives an error message.

● When the value of the EVENTID parameter in the incoming event is VENDOR, the adapter invokes the
BAPI_VENDOR_GETDETAIL function module to check if the customer number provided for the
EVENTPARAM parameter is valid.

If the customer number is valid, the process writes the customer information to an output file.
Otherwise, the Request-Response Invocation Service service receives an error message.

Configuring the Example
After migrating the example project to TIBCO Business Studio, you have to configure the project to
ensure that the adapter can access to the SAP system.

Prerequisites

Ensure that you have migrated the example project to TIBCO Business Studio and started the EMS
server.

Procedure

1. In the Project Explorer view, expand OutboundRFCWithInboundBAPI > Module Descriptors, and
then double-click the Module Properties resource.

2. In the Module Properties editor, enter values for the following properties:

● AppServer

● Client

● GatewayService

● Password

● GatewayHost

● ProgramID

● SystemNumber

● UserName

● JMSProviderUrl

● ASAP_HOME
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ASAP_HOME is the home directory where you install the adapter. For example, E:\TIBCO_HOME
\adapter\adr3\7.2.

3. Click Save.

4. In the Adapter for SAP Configuration editor, click Test Connection in the Default Client
Connection panel to validate the connection.

Running the Example
After configuring the example project, you can run the processes in the example project to see how to
use the Request-Response Invocation Service and the Request-Response Service services.

Prerequisites

Ensure that you have configured the example project and started the adapter configuration.

Procedure

1. From the menu, click Run > Run Configurations to open the Run Configuration window.

2. Double-click BusinessWorks Application to create an application launcher to run the processes in
the project.

3. In the Applications tab, keep the example project application selected and deselect the other
applications.

4. If you want to store the configuration information in this application launcher, specify a unique
name for it in the Name field and click Apply.

5. Click Run.

6. Log on to the SAP system and execute the SAP transaction SE37.

7. Execute the BAPI_XBP_EVENT_RAISE function module.

8. Enter the RFC Destination based on the configuration in the project.

9. Configure the customer and vendor information according to events to be tested:
a) To validate a customer master record, set the EVENTID parameter to CUSTOMER and enter a

customer number for the EVENTPARAM parameter.
b) To validate a vendor master record, set the EVENTID parameter to VENDOR and enter a vendor

number for the EVENTPARAM parameter.
c) To test an invalid event, enter a value for the EVENTID parameter that is neither CUSTOMER nor

VENDOR.

Expected Results
You can view the example results in the TIBCO_HOME\adapter\adr3\version_number\examples
\BusinessWorks5\OutboundRFCWithInboundBAPI directory.

The vendor.xml file is created when the value of the EVENTID parameter is VENDOR.

The customer.xml file is created when the value of the EVENTID parameter is CUSTOMER.

The SAP system receives an error message when the value of the EVENTID parameter is neither VENDOR
nor CUSTOMER.
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IDocFormat Publishing Mode

The IDocFormatPublishingMode example shows how to use the adapter for sending and receiving
IDocs without any significant mapping. This is useful in cases where there are systems or applications
that understand the SAP IDoc format.

In addition to demonstrating the usage of the IDocFormat publish mode, this example also shows the
usage of JMS properties for the Publication Service service and the IDoc confirmation for the
Subscription Service service.

This example contains four processes, ReceiveIDocFromSAP, SendCREMASToSAP,
SendDEBMASToSAP, WaitIDocConfirmation. The configurations of the SendCREMASToSAP and
SendDEBMASToSAP processes are the same except for the IDoc type.

The ReceiveIDocFromSAP process is triggered when the Publication Service service publishes an IDoc
from the SAP system. After the IDoc is received, it is written to the .idoc file. The adapter passes the
control fields of IDocs as JMS properties. You can check the control fields in the JMS Application
Properties resource.

The SAPIDOC_MESTYP property has been defined in the JMS Application Properties resource. You can
also define the JMS properties that you want in this resource.

Then, the SendCREMASToSAP or SendDEBMASToSAP process is triggered. The received IDoc is
published back to the SAP system.

Finally, the WaitIDocConfirmation process is triggered to wait for the IDoc confirmation message
report after the Subscription Service service receives the IDoc.

Configuring the Example
After migrating the example project to TIBCO Business Studio, you have to configure the project to
ensure that the adapter can access to the SAP system.

Prerequisites

Ensure that you have migrated the example project to TIBCO Business Studio and started the EMS
server.

Procedure

1. In the Project Explorer view, expand IDocFormatPublishingMode > Module Descriptors, and then
double-click the Module Properties resource.

2. In the Module Properties editor, enter values for the following properties:

● AppServer

● Client

● GatewayService

● Password

● GatewayHost

● ProgramID

● SystemNumber

● UserName

● ASAP_HOME
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ASAP_HOME is the home directory where you install the adapter. For example, E:\TIBCO_HOME
\adapter\adr3\7.2.

3. Click Save.

4. In the Adapter for SAP Configuration editor, click Test Connection in the Default Client
Connection panel to validate the connection.

5. In the ReceiveIDocFromSAP process, click the ReceiveIDocFromSAP activity.

6. In the General tab, click  next to the Adapter Service field to select a Publication Service service
according to the IDoc type.

7. Click Save.

Running the Example
After configuring the example project, you can run the processes in the example project to see how to
send IDocs in the IDocFormat publish mode and pass control fields of IDoc as JMS properties.

Prerequisites

Ensure that you have configured the example project and started the adapter configuration.

Procedure

1. From the menu, click Run > Run Configurations to open the Run Configuration window.

2. Double-click BusinessWorks Application to create an application launcher to run the processes in
the project.

3. In the Applications tab, keep the example project application selected and deselect the other
applications.

4. If you want to store the configuration information in this application launcher, specify a unique
name for it in the Name field and click Apply.

5. Click Run.

6. Log on to the SAP system and publish a DEBMAS01 IDoc or a CREMAS01 IDoc.

Expected Results
You can view the example results in the TIBCO_HOME\adapter\adr3\version_number\examples
\BusinessWorks5\IDocFormatPublishingMode directory.

When the IDoc confirmation report message from the SAP system is received, the message is written to
the idoc_confirmation.txt file.

The IDoc published from the SAP system is also written to the debmas.idoc or cremas.idoc file. The
following figure is a debmas.idoc file example.
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Salesforce Opportunity to SAP Order

The SalesforceOpportunityToSAPOrder example shows how to set up communication between the
SAP system and Salesforce.com by using the adapter.

● SyncOpportunity_OutboundListener and SyncOpportunityProcess processes

The workflow action is triggered to send outbound messages to the
SyncOpportunity_OutboundListener process when you create a record of the Opportunity object
with the stage of Closed Won or edit a record of the Opportunity object by setting the stage to
Closed Won in Salesforce.com.

After the SyncOpportunity_OutboundListener process receives the messages, the
SyncOpportunityProcess processes is triggered. The adapter invokes the
BAPI_SALESORDER_CREATEFROMDAT1 function module to create a sales order in the SAP
system based on the outbound messages. In the the BusinessWorks 5 example, when an error occurs
in the invocation, this error is written to the OrderStatus.xml file. In the BusinessWorks 6 example,
there is no output for the invocation error.

If the adapter configuration fails to create the sales order, the adapter invokes the
BAPI_TRANSACTION_ROLLBACK function module to roll back the sales order.

Otherwise, the adapter invokes BAPI_TRANSACTION_COMMIT function module to commit the
created sales order. Then update the opportunity object in Salesforce.com with the sales order
number.

● UpdateOpportunityFromSAPDelivery process

This process is triggered when the Publication Service service named as DELVERY05Publisher
publishes a DESADV IDoc containing the Opportunity ID. This process updates the Opportunity
object in Salesforce.com with the SAP delivery number as the tracking number.

Configuring the Example
After importing the example project to TIBCO Business Studio, you have to configure the project to
ensure that the adapter can access to the SAP system and Salesforce.com.

Prerequisites

Ensure that you have imported the example project to TIBCO Business Studio, and started the EMS
server.

Procedure

1. In the Project Explorer view, expand SalesforceOpportunityToSAPOrder > Module Descriptors or
salesforce_opportunity_to_sap_orderProject > Module Descriptors, and then double-click the
Module Properties resource.

2. In the Module Properties editor, enter values for the following properties:

● SAPAppServer

● SAPClient

● GatewayService

● SAPPassword

● SAPGatewayHost

● SAPProgramID
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● SAPSystemNumber

● SAPUserName

● salesforce_password

● salesforce_username

● SAPOrderFile

● ASAP_HOME

ASAP_HOME is the home directory where you install the adapter. For example, E:\TIBCO_HOME
\adapter\adr3\7.2.

3. Click Save.

4. In the Adapter for SAP Configuration editor, click Test Connection in the Default Client
Connection panel to validate the connection.

Running the Example
After configuring the example project, you can run the processes in the example project to see how to
set up communication between the SAP system and Salesforce.com by using the adapter.

Prerequisites

Ensure that you have configured the example project and started the adapter configuration.

Procedure

1. From the menu, click Run > Run Configurations to open the Run Configuration window.

2. Double-click BusinessWorks Application to create an application launcher to run the processes in
the project.

3. In the Applications tab, keep the example project application selected and deselect the other
applications.

4. If you want to store the configuration information in this application launcher, specify a unique
name for it in the Name field and click Apply.

5. Click Run.

6. To start the SyncOpportunity_OutboundListener process, create a record of the a Opportunity
object with the stage of Closed Won or edit a record of the a Opportunity object by setting the stage
to Closed Won.

7. To start the UpdateOpportunityFromSAPDelivery process, publish a DESADV05 IDoc, after
creating a delivery of a sales order in the SAP system. You can create the delivery in the SAP system
either by executing SAP transaction VL01N and referencing the sales order or by executing the SAP
Delivery Due List report.

Expected Results
The processes in the SalesforceOpportunityToSAPOrder example project do not generate any output
files.

You can refresh Salesforce.com to check the sales order number or the the tracking number, when the
processes are finished.
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