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Important Information

SOME TIBCO SOFTWARE EMBEDS OR BUNDLES OTHER TIBCO SOFTWARE. USE OF SUCH
EMBEDDED OR BUNDLED TIBCO SOFTWARE IS SOLELY TO ENABLE THE FUNCTIONALITY (OR
PROVIDE LIMITED ADD-ON FUNCTIONALITY) OF THE LICENSED TIBCO SOFTWARE. THE
EMBEDDED OR BUNDLED SOFTWARE IS NOT LICENSED TO BE USED OR ACCESSED BY ANY
OTHER TIBCO SOFTWARE OR FOR ANY OTHER PURPOSE.

USE OF TIBCO SOFTWARE AND THIS DOCUMENT IS SUBJECT TO THE TERMS AND
CONDITIONS OF A LICENSE AGREEMENT FOUND IN EITHER A SEPARATELY EXECUTED
SOFTWARE LICENSE AGREEMENT, OR, IF THERE IS NO SUCH SEPARATE AGREEMENT, THE
CLICKWRAP END USER LICENSE AGREEMENT WHICH IS DISPLAYED DURING DOWNLOAD
OR INSTALLATION OF THE SOFTWARE (AND WHICH IS DUPLICATED IN THE LICENSE FILE)
OR IF THERE IS NO SUCH SOFTWARE LICENSE AGREEMENT OR CLICKWRAP END USER
LICENSE AGREEMENT, THE LICENSE(S) LOCATED IN THE “LICENSE” FILE(S) OF THE
SOFTWARE. USE OF THIS DOCUMENT IS SUBJECT TO THOSE TERMS AND CONDITIONS, AND
YOUR USE HEREOF SHALL CONSTITUTE ACCEPTANCE OF AND AN AGREEMENT TO BE
BOUND BY THE SAME.

This document contains confidential information that is subject to U.S. and international copyright laws
and treaties. No part of this document may be reproduced in any form without the written
authorization of TIBCO Software Inc.

TIBCO, Two-Second Advantage, TIBCO ActiveMatrix BPM, TIBCO Administrator, TIBCO Business
Studio, TIBCO Enterprise Message Service, TIBCO General Interface, TIBCO Hawk, TIBCO iProcess,
TIBCO JasperReports, TIBCO Spottfire, TIBCO Spotfire Server, and TIBCO Spotfire Web Player are
either registered trademarks or trademarks of TIBCO Software Inc. in the United States and/or other
countries.

Enterprise Java Beans (EJB), Java Platform Enterprise Edition (Java EE), Java 2 Platform Enterprise
Edition (J2EE), and all Java-based trademarks and logos are trademarks or registered trademarks of
Oracle Corporation in the U.S. and other countries.

All other product and company names and marks mentioned in this document are the property of their
respective owners and are mentioned for identification purposes only.

THIS SOFTWARE MAY BE AVAILABLE ON MULTIPLE OPERATING SYSTEMS. HOWEVER, NOT
ALL OPERATING SYSTEM PLATFORMS FOR A SPECIFIC SOFTWARE VERSION ARE RELEASED
AT THE SAME TIME. SEE THE README FILE FOR THE AVAILABILITY OF THIS SOFTWARE
VERSION ON A SPECIFIC OPERATING SYSTEM PLATFORM.

THIS DOCUMENT IS PROVIDED “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS
OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

THIS DOCUMENT COULD INCLUDE TECHNICAL INACCURACIES OR TYPOGRAPHICAL
ERRORS. CHANGES ARE PERIODICALLY ADDED TO THE INFORMATION HEREIN; THESE
CHANGES WILL BE INCORPORATED IN NEW EDITIONS OF THIS DOCUMENT. TIBCO
SOFTWARE INC. MAY MAKE IMPROVEMENTS AND/OR CHANGES IN THE PRODUCT(S)
AND/OR THE PROGRAM(S) DESCRIBED IN THIS DOCUMENT AT ANY TIME.

THE CONTENTS OF THIS DOCUMENT MAY BE MODIFIED AND/OR QUALIFIED, DIRECTLY OR
INDIRECTLY, BY OTHER DOCUMENTATION WHICH ACCOMPANIES THIS SOFTWARE,
INCLUDING BUT NOT LIMITED TO ANY RELEASE NOTES AND "READ ME" FILES.

Copyright © 2005-2017 TIBCO Software Inc. All rights reserved.
TIBCO Software Inc. Confidential Information
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TIBCO Documentation and Support Services

Documentation for this and other TIBCO products is available on the TIBCO Documentation site. This
site is updated more frequently than any documentation that might be included with the product. To
ensure that you are accessing the latest available help topics, visit:

https://docs.tibco.com

Product-Specific Documentation

Documentation for TIBCO products is not bundled with the software. Instead, it is available on the
TIBCO Documentation site. To directly access documentation for this product, double-click the
following file:

TIBCO_HOME/release_notes/TIB_amx-bpm_version_docinfo.html

where TIBCO_HOME is the top-level directory in which TIBCO products are installed. On Windows,
the default TIBCO_HOME is C:\tibco. On UNIX systems, the default TIBCO_HOME is /opt/tibco.

The following documents for this product can be found on the TIBCO Documentation site:

o TIBCO ActiveMatrix BPM SOA Concepts

e TIBCO ActiveMatrix BPM Concepts

o TIBCO ActiveMatrix BPM Developer's Guide

o TIBCO ActiveMatrix BPM Web Client Developer's Guide

o TIBCO ActiveMatrix BPM Tutorials

e TIBCO ActiveMatrix BPM Business Data Services Developer Guide

o TIBCO ActiveMatrix BPM Case Data User Guide

o TIBCO ActiveMatrix BPM Event Collector Schema Reference

o TIBCO ActiveMatrix BPM - Integration with Content Management Systems
o TIBCO ActiveMatrix BPM SOA Composite Development

o TIBCO ActiveMatrix BPM Java Component Development

o TIBCO ActiveMatrix BPM Mediation Component Development

o TIBCO ActiveMatrix BPM Mediation API Reference

e TIBCO ActiveMatrix BPM WebApp Component Development

o TIBCO ActiveMatrix BPM Administration

e TIBCO ActiveMatrix BPM Performance Tuning Guide

o TIBCO ActiveMatrix BPM SOA Administration

o TIBCO ActiveMatrix BPM SOA Administration Tutorials

e TIBCO ActiveMatrix BPM SOA Development Tutorials

o TIBCO ActiveMatrix BPM Client Application Management Guide

o TIBCO ActiveMatrix BPM Client Application Developer's Guide

o TIBCO Openspace User's Guide

o TIBCO Openspace Customization Guide

o TIBCO ActiveMatrix BPM Organization Browser User's Guide (Openspace)
o TIBCO ActiveMatrix BPM Organization Browser User's Guide (Workspace)
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o TIBCO ActiveMatrix BPM Spotfire Visualizations

o TIBCO Workspace User's Guide

» TIBCO Workspace Configuration and Customization

o TIBCO Workspace Components Developer Guide

o TIBCO ActiveMatrix BPM Troubleshooting Guide

o TIBCO ActiveMatrix BPM Deployment

e TIBCO ActiveMatrix BPM Hawk Plug-in User's Guide

o TIBCO ActiveMatrix BPM Installation: Developer Server
o TIBCO ActiveMatrix BPM Installation and Configuration
o TIBCO ActiveMatrix BPM Log Viewer

o TIBCO ActiveMatrix BPM Single Sign-On

o Using TIBCO JasperReports for ActiveMatrix BPM

How to Contact TIBCO Support

For comments or problems with this manual or the software it addresses, contact TIBCO Support:

e For an overview of TIBCO Support, and information about getting started with TIBCO Support,
visit this site:

http://www.tibco.com/services/support

» If you already have a valid maintenance or support contract, visit this site:
https://support.tibco.com

Entry to this site requires a user name and password. If you do not have a user name, you can
request one.

How to Join TIBCO Community

TIBCO Community is an online destination for TIBCO customers, partners, and resident experts. It is a
place to share and access the collective experience of the TIBCO community. TIBCO Community offers
forums, blogs, and access to a variety of resources. To register, go to the following web address:

https://community.tibco.com
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BPM Spotfire Visualizations

TIBCO Spotfire enables you to take data from the BPM database and create visualizations, for example,
bar charts and scatter plots, based on the data. This enables you to quickly and easily identify trends,
patterns and relationships in your data. You can use, either the BPM Spotfire Analysis file or, the BPM
Spotfire Information Library to access template Spotfire visualizations that have been created based on
data from TIBCO ActiveMatrix BPM.

BPM Spotfire Visualizations and Event Collector

The BPM Spotfire template visualizations use the Event Collector tables of the BPM database schema.
The Event Collector is a component of TIBCO ActiveMatrix BPM. It collects and correlates data on
business process events. The two tables that are used by the BPM Spotfire Template visualizations are:

e ec_wi_status table

» ec_pe_status table

In the BPM Spotfire Templates, these tables are called something different.
%} e The ec_wi_status table is called WI_STATUS_IL.

o The ec_pe_status table is called PE_STATUS_IL.

For more information about the data contained in these tables, see TIBCO ActiveMatrix BPM Event
Collector Schema Reference.

BPM Spotfire Analysis File

You can use the BPM Spotfire analysis file to access the BPM Spotfire template visualizations. The BPM
Spotfire Analysis file contain the analysis material, information links, and data sources, for the BPM
template visualizations.

The BPM Analysis file uses embedded data and the information link for direct connection to the BPM
database. Using information link you can fetch latest data from the BPM database to the analysis file.
See Replacing Data in the BPM Spottfire Analysis File for more details on how to create the information
link and replace the data in the analysis file.

Pre-requisites for Using BPM Spotfire Template Visualizations

Before using the BPM Spotfire analysis file or BPM Spotfire Information Library, you must install the
correct software.

You must have:
e installed:

— TIBCO Spotfire Professional
— TIBCO Spotfire Server

o created some user accounts on your TIBCO Spotfire Server. See the TIBCO Spotfire Deployment and
Administration Guide for more information.
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Opening the BPM Spotfire Analysis File

To load the template visualizations from the BPM Spotfire Analysis file, you must open the file in
TIBCO Spotfire.

Procedure

1. Copy spotfire.zip from the location where you installed TIBCO ActiveMatrix BPM (for example,
C:\Program Files (x86)\tibco\amx-bpm\bpm\n.n\samples where n.n is the version number of
the BPM runtime you installed) and extract the TIBCO AMXBPM Template EMBEDDED.dxp file that it
contains.

2. Depending on the type of database you are using for your BPM database, configure the machine
where TIBCO Spotfire is installed to connect to your BPM database. The following table describes

this:
Database Description
DB2 You must install an IBM DB2 ODBC Driver.
Oracle You must:
» install an Oracle 11g Release 2 Client.
e configure a service name in Oracle Net Manager. Refer to your Oracle
documentation for information on how to do this.
SQL Server No extra configuration is required.

3. To open the BPM Spotfire analysis file, do the following:
a) Login to your TIBCO Spottfire Client.
b) Click File > Open . The Open File dialog displays.
c) Browse to the location of your BPM Spotfire Analysis File. For example, c: \temp\

d) Select the TIBCO AMXBPM Template EMBEDDED.dxp file and click Open. The BPM Spotfire
template visualizations display.

Replacing Data in the BPM Spotfire Analysis File

&

You can replace the embedded data in the BPM visualizations in the BPM Spotfire analysis file with
new data from the BPM database using the information link. This enables you to update the
visualizations with current data. You can only update one table at a time so you need to repeat these
steps for each table you want to update.

‘ The new data must be structured in the same way as the tables in the existing visualization.
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(Only applies if you are using DB2) The ec_wi_status table contains columns of type clob. However,
the DB2 ODBC Driver does not support clobs. Therefore, you must set the following CLI Parameter
values on the Advanced Settings tab of the DB2 CLI/ODBC Driver Settings dialog to replace data in the
ec_wi_status table:

LongDataCompat=1

LOBMaxColumnSize=1073741823

" DataSource  Sdvanced Settings |

Select a parameter to change it value.
CLI Parameter | alue I FPending Valuel Typel Description Add
Part 50000
Database am=bpm Hemove |
Hostname 10.100.87.1...
Pratacal TCRIP Fil..  Pratacal for file DI Change |
LongD ataCompat 1 [Da.. FReport large object
LOBMaxColurnnSize 1073741823 Da.. Overide default CC
| | i

Hint

QK I Cancel Lpply | Help |

Procedure

Create an information link in Spotfire.

1.

Click Tools > Information Designer.
The Information Designer window is displayed.

In the Information Designer window select New > Datasource.

In the new datasource, populate the database connection details based on your database and save
the datasource.

Locate the EC Table in the created datasource, select either ec_pe_status (for process instance
data) or ec_wi_status (for work item data). Right-click the table and select Create Default
Information Model. Click OK on all the subsequent screens.

The information link for the table is created.

Repeat the step above for the other table.

From your TIBCO Spotfire Client, open the TIBCO AMX BPM Template EMBEDDED.dxp file.

Click File > Replace Data Table..., then on the Replace Data Table - Select Data Table dialog select
either:

o  WISTATUSIL to replace work item data

o PESTATUSIL to replace process instance data

You must now add a Transformation to transform any currency values to the correct type. The next
steps depend on the database you are using.

For Oracle/MSSQL.:

a) Select Show transformations.

b) Select Add.

¢) Select ATTRIBUTEI6 in Available columns.

d) From the New data type drop-down list, select Real. In the Preview pane, you will see that the
data type for the columns have changed to Real.
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10.

11.

12.
13.
14.
15.
16.

e) Select the first column in the list of Available Columns that has a data type of Currency.

f) From the New data type drop-down list, select Long Integer. In the preview pane, you will see
that the data type for the column you selected has changed to Long Integer.

g) Repeat this step for all columns with a data type of Currency.
For DB2:

a) Select Show transformations.

b) Select Add.

c) Select ATTRIBUTES in Available columns.

d) From the New data type drop-down list, select Real. In the Preview pane, you will see that the
data type for the columns have changed to Real.

e) Click Show transformations. The transformations part of the dialog displays.
f) From the Transformations drop-down list, select Change data types.

g) Click Add. The Change Data Types dialog displays. The Change Data Types dialog displays the
columns that make up the table.

Click the Select drop-down icon, select the information link created for the table and click OK.
The data is then reloaded from the database connection.

Open the visualizations to check that the data has been updated.

& You can only update one table at a time so you need to repeat these steps each time you
want to update a table with new data.

Click File > Save As to save your updated table to a new . dxp file.

% You could save the new . dxp file to a shared location so that all teams can have access to
the new updated template.

The Save dialog is displayed.

Click Override these settings and embed all data.

Click OK to close the dialog.

On the Save Document As, browse to the location where you want to save your new .dxp file.

In the File name: box, type in the name of your new . dxp file and click OK to close the dialog.

Displaying Work Item Facade Display Labels in BPM Spotfire Visualizations
When defining your BPM process in TIBCO Business Studio, you can specify display labels for your
work item attributes. You can configure your BPM Spotfire visualizations to show the display labels for
your work item attributes rather than their default names (attributel, attribute 2 and so on).

Procedure

® N Ol Db =

Open your BPM Spotfire visualizations in TIBCO Spotfire.
Click Edit > Column Properties.

From the Data Table drop-down list, select WI STATUS IL.
Select the work item column whose name you want to change.
Click the General tab.

In the Name box, enter the new name.

Click Apply.

Click OK.
When you go back to the visualization, the new column name displays.
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BPM Spotfire Operational Visualizations

The BPM Spotfire template visualizations illustrate a typical use case scenario for a bank. Typically, a
bank wants information about its current operations. For example, what work is there to do and how
do they prioritize and organize resources for that work.

There are two visualizations you can use to analyze operations.

Operational Monitoring

This visualization allows you to select a process, a task within that process, and its priority and
then view how long it has been outstanding, whether there are any approaching SLAs (service
level agreements), and what resources are working on it.

Operational Summary

This visualization displays a summary of all tasks from all processes. It shows the outstanding
tasks, their average duration and their first SLA.

BPM Spotfire Performance Visualizations

The BPM Spotfire template visualizations illustrate a typical use case scenario for a bank. Typically, a
bank wants information about ts performance over time. For example, how do their processes perform
end to end and how much time is spent on each task. This, in turn, helps the bank to address issues
such as what activities are taking the most time and how can that time be shortened.

There are three visualizations that you can use to analyze performance.

Performance Tasks
This template allows you to select a task and then displays:
e asummary of its duration.

o asummary of its execution by resource and priority.

Performance Resources

This template allows you to select one or more resources and a time period. It then displays what
tasks those resources have been working on and the duration of those tasks.

Process Analysis

This template allows you to select a process. It then displays how many process instances there
have been for that process and their duration.

TIBCO ActiveMatrix® BPM Spotfire Visualizations



	Contents
	TIBCO Documentation and Support Services
	BPM Spotfire Visualizations
	BPM Spotfire Visualizations and Event Collector
	BPM Spotfire Analysis File
	Pre-requisites for Using BPM Spotfire Template Visualizations
	Opening the BPM Spotfire Analysis File
	Replacing Data in the BPM Spotfire Analysis File
	Displaying Work Item Facade Display Labels in BPM Spotfire Visualizations

	BPM Spotfire Operational Visualizations
	BPM Spotfire Performance Visualizations


