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Preface

TIBCO BusinessConnect™ EDI Protocol powered by Instream® is the TIBCO 
business-to-business (B2B) solution for transferring EDI documents between trading 
partners. This manual describes how to use the TEXT protocol.

Topics

• Related Documentation, page xii

• Typographical Conventions, page xiv

• TIBCO Product Documentation and Support Services, page xvi
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Related Documentation

This section lists documentation resources you may find useful.

TIBCO BusinessConnect EDI Protocol powered by Instream Documentation

The following documents form the TIBCO BusinessConnect EDI Protocol powered by 
Instream documentation set:

• TIBCO BusinessConnect EDI Protocol powered by Instream Installation Read this 
manual to learn about installing and deploying TIBCO BusinessConnect EDI Protocol 
powered by Instream. 

• TIBCO BusinessConnect EDI Protocol powered by Instream User’s Guide Read this 
manual for instructions on using the product to configure all the EDI protocols.

• TIBCO BusinessConnect EDI Protocol powered by Instream EDIFACT 
Configuration Read this manual for instructions on configuring the EDIFACT 
protocol.

• TIBCO BusinessConnect EDI Protocol powered by Instream Gateway 
Configuration Read this manual for instructions on configuring the Gateway 
protocol.

• TIBCO BusinessConnect EDI Protocol powered by Instream Service 
Configuration Read this manual for instructions on configuring the Service protocol.

• TIBCO BusinessConnect EDI Protocol powered by Instream TEXT 
Configuration Read this manual for instructions on configuring the TEXT protocol.

• TIBCO BusinessConnect EDI Protocol powered by Instream TRADACOMS 
Configuration Read this manual for instructions on configuring the TRADACOMS 
protocol.

• TIBCO BusinessConnect EDI Protocol powered by Instream X12 Configuration Read 
this manual for instructions on configuring the X12 protocol.

• TIBCO BusinessConnect EDI Protocol powered by Instream Release Notes Read the 
release notes for a list of new and changed features. This document also contains lists 
of known issues and closed issues for this release.
TIBCO BusinessConnect EDI Protocol powered by Instream TEXT Configuration



Preface | xiii
Other TIBCO Product Documentation

You may find it useful to read the documentation for the following TIBCO products:

• TIBCO ActiveMatrix BusinessWorks™

• TIBCO ActiveMatrix BusinessWorks™ Plug-in for BusinessConnect™

• TIBCO Administrator™

• TIBCO BusinessConnect™

• TIBCO BusinessConnect™ Palette

• TIBCO Business Studio™

• TIBCO Designer™
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Typographical Conventions

The following typographical conventions are used in this manual.

Table 1   General Typographical Conventions

Convention Use

ENV_HOME

TIBCO_HOME

TIBCO products are installed into an installation environment. A product installed into 
an installation environment does not access components in other installation 
environments. Incompatible products and multiple instances of the same product must be 
installed into different installation environments.

An installation environment consists of the following properties:

• Name Identifies the installation environment. This name is referenced in 
documentation as ENV_NAME. On Microsoft Windows, the name is appended to the 
name of Windows services created by the installer and is a component of the path to 
the product shortcut in the Windows Start > All Programs menu. 

• Path The folder into which the product is installed. This folder is referenced in 
documentation as TIBCO_HOME. 

TIBEDI_HOME TIBCO BusinessConnect EDI Protocol powered by Instream installs into a directory 
within a TIBCO_HOME. This directory is referenced in documentation as 
TIBEDI_HOME. The default value of TIBEDI_HOME depends on the operating system. 
For example, on Windows systems, the default value is C:\tibco\bc\version\protocols\tibedi.

code font Code font identifies commands, code examples, filenames, pathnames, and output 
displayed in a command window. For example:

Use MyCommand to start the foo process.

bold code font Bold code font is used in the following ways:

• In procedures, to indicate what a user types. For example: Type admin. 

• In large code samples, to indicate the parts of the sample that are of particular 
interest.

• In command syntax, to indicate the default parameter for a command. For example, 
if no parameter is specified, MyCommand is enabled: 
MyCommand [enable | disable]
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italic font Italic font is used in the following ways: 

• To indicate a document title. For example: See TIBCO BusinessConnect EDI 
Protocol powered by Instream Installation.

• To introduce new terms. For example: A portal page may contain several portlets. 
Portlets are mini-applications that run in a portal.

• To indicate a variable in a command or code syntax that you must replace. For 
example: MyCommand PathName.

Key 
combinations

Key names separated by a plus sign indicate keys pressed simultaneously. For example: 
Ctrl+C.

Key names separated by a comma and space indicate keys pressed one after the other. 
For example: Esc, Ctrl+Q.

The note icon indicates information that is of special interest or importance, for example, 
an additional action required only in certain circumstances.

The tip icon indicates an idea that could be useful, for example, a way to apply the 
information provided in the current section to achieve a specific result.

The warning icon indicates the potential for a damaging situation, for example, data loss 
or corruption if certain steps are taken or not taken.

Table 1   General Typographical Conventions (Cont’d)

Convention Use
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TIBCO Product Documentation and Support Services

For information about this product, you can read the documentation, contact TIBCO 
Support, or join TIBCO Community.

How to Access TIBCO Documentation

Documentation for TIBCO products is available on the TIBCO Product Documentation 
website mainly in the HTML and PDF formats.

The TIBCO Product Documentation website is updated frequently and is more current 
than any other documentation included with the product. To access the latest 
documentation, visit https://docs.tibco.com. 

Documentation for TIBCO BusinessConnect EDI Protocol powered by Instream is 
available on the 
https://docs.tibco.com/products/tibco-businessconnect-edi-protocol-powered-by-instream
Product Documentation page.

How to Contact TIBCO Support

You can contact TIBCO Support in the following ways:

• For an overview of TIBCO Support, and information about getting started with 
TIBCO Support, visit http://www.tibco.com/services/support

• For accessing the Support Knowledge Base and getting personalized content about 
products you are interested in, visit the TIBCO Support portal at 
https://support.tibco.com.

• For creating a Support case, you must have a valid maintenance or support contract 
with TIBCO. You also need a user name and password to log in to 
https://support.tibco.com. If you do not have a user name, you can request one by 
clicking Register on the website.

How to Join TIBCO Community

TIBCO Community is the official channel for TIBCO customers, partners, and employee 
subject matter experts to share and access their collective experience. TIBCO Community 
offers access to Q&A forums, product wikis, and best practices. It also offers access to 
extensions, adapters, solution accelerators, and tools that extend and enable customers to 
gain full value from TIBCO products. In addition, users can submit and vote on feature 
requests from within the TIBCO Ideas Portal. For a free registration, go to 
https://community.tibco.com.
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Chapter 1 Overview

This chapter describes the TEXT protocol of TIBCO BusinessConnect EDI Protocol 
powered by Instream, and its use for Electronic Data Interchange (EDI).

Topics

• Product Overview, page 2

• Initial Detection of the TEXT Process, page 3

• Support for File Conversion, page 5
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Product Overview

TIBCO BusinessConnect EDI Protocol powered by Instream provides support for 
delimited and positional files.

• Delimited Files These files are defined as files that contain a consistent delimiter all 
throughout the file, such as an Excel exported .csv file or a tab separated field value. 

Guidelines need to be designed based on the structure of the Delimited file. 

• Positional Files These files are defined as files that have a defined position (or size) 
for each field in the file. 
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Initial Detection of the TEXT Process

TIBCO BusinessConnect EDI Protocol powered by Instream uses the file 
FlatFileInitialDetector.csv, present in the EDI_HOME/config directory, for initial detection of a 
TEXT file to associate certain characteristics with the guideline as well as with trading 
partner information defined in the BusinessConnect configuration. 

The file FlatFileInitialDetector.csv provides general structural information for the incoming 
document; for example, it defines the key elements that are required, as well as optional 
elements such as MessageGroup, MessageType, Sender and Receiver ID/Qualifiers that are used 
to  match the operation defined for the TEXT protocol, as well as for trading partner 
configuration. You will create a new entry  in the file FlatFileInitialDetector.csv if there is a new 
definition associated with the TEXT guidelines and your TEXT document.

Each entry in the file FlatFileInitialDetector.csv is associated with a TEXT document by 
matching the key entry value and any other optional element values entered in the file 
FlatFileInitialDetector.csv . The runtime engine goes through the list of entries mentioned in the 
file FlatFileInitialDetector.csv and checks if any one of its entries matches the TEXT document. 
The matching entry from the file FlatFileInitialDetector.csv is then used to give information to 
the BusinessConnect  engine about:

• The operation information, based on the MessageGroup and MessageType values

• Trading Partner  information, based on Sender/Receiver ID and/or Sender/Receiver 
Qualifier present as part of the fields.

For more details about the file FlatFileInitialDetector.csv and its use, see Chapter 7, Type 
Detection, on page 83.

TEXT Process Detection Runtime Sequence

The following sequence happens at runtime:

1. A proprietary TEXT file is received on a transport. This file is then sent to the 
Instream conversion engine, which will try to scan the file FlatFileInitialDetector.csv.

2. The Instream conversion engine compares the contents of the TEXT file with each 
entry in the file FlatFileInitialDetector.csv and tries to find a match.

3. Checking the key value: First it checks to see if the data file matches the key value 
defined in the file FlatFileInitialDetector.csv .

4. Checking the optional values: If the key value matches, the engine checks other 
optional field values if they exist, and matches against them. 

— If the entry is a match, then the engine enters an appropriate value for MessageGroup 
and MessageType to identify the operation of the TEXT document, and tries to see if 
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a value for Sender/Receiver ID and/or Sender/Receiver Qualifier is defined in any 
of the Field columns to match the trading partner identity. 

— If there is no match, it will fail to get the MessageGroup and MessageType identification; 
identifying the operations would not be possible, and the right guidelines would not 
be matched. 

— If MessageGroup and MessageType values are matched, but the Sender/Receiver 
ID/Qualifier values are not matched, then the BusinessConnect runtime engine 
would use the partner’s or host's default ID/Qualifier to match and the validation 
would try to proceed.

5. Checking the configuration fields: The configuration fields are SenderId, SenderDomain, 
ReceiverId, ReceiverDomain, MessageType, and MessageGroup. If MessageGroup is not identified, it 
is assumed to be TEXT. 

The configuration fields can be identified through the FlatFileInitialDetector.csv file.

6. Checking the configuration validation: The Preprocess process checks the 
configuration validation information against the Sender and Receiver configurations 
created in the repository using the TIBCO BusinessConnect console. Either the host or 
the trading partner could act as a sender or as a receiver. 

For more information on configuring hosts and trading partners, see Chapter 4, Setting 
Up Trading Hosts, on page 55, and Chapter 5, Setting Up Trading Partners, on 
page 61.
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Support for File Conversion 

The TEXT protocol supports these conversions:

• TEXT to XML and XML to TEXT both for the delimited and positional files.

• Validation of X12 or EDIFACT documents and their conversion to TEXT files, either 
delimited or positional, based on the TEXT guidelines developed in TIBCO 
Foresight® EDISIM® and mapped using the Translator tool. 

• Conversion of the TEXT files to EDI for the Notify operation, where TEXT files are 
converted to X12 or to EDIFACT protocol. To perform this conversion, the trading 
partner must enable both the TEXT and the X12 or EDIFACT protocol.

• TEXT data can also be converted to X12 using the synchronous request response 
transactions.

To learn more about TEXT to EDI conversion, see TIBCO BusinessConnect EDI Protocol 
powered by Instream, User’s Guide, "TEXT to EDI Conversion"
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Chapter 2 Tutorials — Getting Started

This chapter gives an overview of how to use TIBCO ActiveMatrix BusinessWorks with 
TIBCO BusinessConnect EDI Protocol powered by Instream. 

In the tutorials you will configure trading partner information, configure a private process 
to communicate with TIBCO BusinessConnect EDI Protocol powered by Instreaml, and 
run the tutorials.

Topics

• Overview, page 8

• Prerequisites, page 10

• Using EDI Guidelines, page 11

• TEXT_DATA Tutorial, page 14

• TEXT_to_EDI Tutorials, page 28
 TIBCO BusinessConnect EDI Protocol powered by Instream TEXT Configuration



8 | Chapter 2  Tutorials — Getting Started
Overview

In the three tutorials presented in this chapter, you will use ActiveMatrix BusinessWorks 
and TIBCO BusinessConnect EDI Protocol powered by Instream running on one machine 
to send a TEXT message to a trading partner. 

The tutorial TEXT_DATA describes sending a TEXT message, while the TEXT_to_EDI 
describes sending a TEXT message that gets converted either in EDIFACT or in X12 
format.

Normally the trading partner is represented by another BusinessConnect engine running 
on another machine. However, this tutorial is run on a single machine (Initiator) and when 
the TEXT is sent to the trading partner or converted to EDI, the transport properties are 
defined to store the request in a directory on the local file system.

The following sections describe how to set up and run the tutorials. The steps involved in 
setting up TIBCO BusinessConnect EDI Protocol powered by Instream to run the tutorials 
are the same steps that have been discussed in TIBCO BusinessConnect EDI Protocol 
powered by Instream User’s Guide, Chapter 2, "Managing EDI Guidelines" and Chapter 3, 
"Exchanging Documents.".

• EDI Guideline Authoring

• Trading Partner Setup

• TIBCO ActiveMatrix BusinessWorks Process Assembly

TEXT_DATA Tutorial

When you run the tutorial, the following steps occur:

1. TIBCO Designer/TIBCO Business Studio reads an XML file which contains the data 
for TEXT.

2. TIBCO Designer/TIBCO Business Studio sends the XML file to TIBCO 
BusinessConnect EDI Protocol powered by Instream.

3. TIBCO BusinessConnect EDI Protocol powered by Instream translates the XML to 
TEXT based on the xsd, TEXT guideline and the translation maps provided in the 
Operation Editor and validates the message against the guideline for this operation.

4. FILE transport is used to simulate sending the interchange to the trading partner. By 
using FILE transport, the interchange is written to a file on the local file system when 
it is sent to the trading partner.

TEXT_to_EDI Tutorials

When you run these tutorials, the following steps occur:
TIBCO BusinessConnect EDI Protocol powered by Instream TEXT Configuration
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1. TIBCO Designer/TIBCO Business Studio reads the sample TEXT file located in 

— BC_HOME/protocols/tibedi/samples/sampleDocs/ Delimited_D99A_ORDERS.dat (for EDIFACT)

— BC_HOME/protocols/tibedi/samples/sampleDocs/ Positional_4040_850.dat (for X12)

2. Constructs a message containing the TEXT data and sends it to TIBCO 
BusinessConnect EDI Protocol powered by Instream.

3. Converts a TEXT message to the EDIFACT (or X12) format and sends it out via the 
EDIFACT (or X12) protocol.

The converted EDI data is sent by the EDIFACT (or X12) primary transport; the 
TEXT protocol’s primary transport has no effect on this transaction.

TIBCO BusinessConnect EDI Protocol powered by Instream translates TEXT to EDI 
based on the TEXT .xsd, TEXT guidelines, and the TEXT translation maps provided 
in the Operations Editor. Then it validates TEXT data and EDI data converted from 
TEXT against the guideline for this operation.
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Prerequisites

Before starting the tutorial, perform the following steps:

1. Install the following software packages:

a. TIBCO BusinessConnect (Server)

b. TIBCO BusinessConnect Palette or TIBCO ActiveMatrix BusinessWorks Plug-in 
for BusinessConnect

c. TIBCO Foresight® Instream® Standard Edition

d. TIBCO Foresight® Translator

e. TIBCO BusinessConnect EDI Protocol powered by Instream

f. TIBCO Foresight EDISIM. Since TIBCO BusinessConnect EDI Protocol 
powered by Instream contains all guidelines needed by the tutorial, it is not 
necessary to use EDISIM to create and customize the guidelines. However, if you 
wish to view the contents of any of the guidelines used in the tutorial, you need to 
install TIBCO Foresight EDISIM.

g. Certain guidelines (.csx files) will have to be imported in order to work with the 
tutorials TEXT_DATA and TEXT_to_EDI. They are listed in Load Guidelines, 
page 12.

2. If you are unfamiliar with the TEXT protocol, read Chapter 1, Overview, on page 1.

3. See TIBCO BusinessConnect Interior Server Administration and the TIBCO 
BusinessConnect Trading Partner Administration for complete information on setting 
up and running TIBCO BusinessConnect.

4. Review "Setting Up Trading Partners" in TIBCO BusinessConnect EDI Protocol 
powered by Instream, User’s Guide.

5. Activate TIBCO BusinessConnect EDI Protocol powered by Instream.
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Using EDI Guidelines

The guidelines used for this tutorial can be found in the directory 
BC_HOME\protocols\tibedi\samples\sampleDocs\guidelines. The guideline file name for the TEXT 
protocol is POINBOUNDARV.std.

View a Guideline

This section explains how to view the guideline used in the tutorial.

To import a guideline:

1. Select EDISIM > Standards Editor.

2. Select File > Import > Import Single .SEF and Open.

3. Go to BC_HOME\protocols\tibedi\samples\sampleDocs\guidelines and select the file 
Positional_4040_850.sef.

4. Click Open.

5. In the Import Standard dialog, keep or change the Standard name into which this 
guideline will be imported.

Figure 1   Import a Standard

6. For this tutorial, keep the standard name and click OK.

7. Click on the + signs on the left to display the guideline.
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Figure 2   Elements of the TEXT Standard

As you expand and highlight elements in the Guideline panel, the properties of each 
element display in the Details View panel.

Load Guidelines

This section describes how to load the guidelines and XSDs for the TEXT messages. 
TIBCO BusinessConnect EDI Protocol powered by Instream contains a sample 
configuration file for this tutorial. You will import the configuration file into the 
Operations Editor as follows: 

1. Using TIBCO Administrator, select BusinessConnect > Operations Editor.

2. In the Operations Editor dialog, click Import.

3. Click change.

4. Click Browse.

5. Select BC_HOME\protocols\tibedi\samples\interfaces.

The files to import are: 

— TEXT.csx

— X12_PO(TEXT_TO_EDI).csx

— EDIFACT_ORDERS(TEXT_TO_EDI).csx

— TEXT_PO(TEXT_TO_EDI).csx
TIBCO BusinessConnect EDI Protocol powered by Instream TEXT Configuration
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6. After selecting each of .csx files, click Open. 

7. Click OK.

8. Supply your password (optional) and click Import.

Review the Guidelines

To review the guidelines: 

1. In the Operations Editor, click the TEXT link.

2. Click on the topmost + (plus) sign on the left.

Figure 3   TEXT Operations

3. Click the transaction link, such as TEXT/PO.

4. Click the Guideline tab.

Notice that Positional_4040_850.sef is displayed in the Message Guideline (.sef or .std) 
field. 

5. Click Save and Done.
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TEXT_DATA Tutorial

This section steps you through the activities you need to perform to configure the host and 
trading partner on the Initiator machine for the TEXT_DATA tutorial.

As explained before, this tutorial is run on a single (Initiator) machine and when the 
POINBOUNDARV transaction is sent to the trading partner, the transport properties are 
defined to store the request in a directory on the local file system.

To proceed with the tutorial, perform the following steps:

• Load Guidelines, page 12

• Set Up a Host for TEXT Protocol, page 14

• Set Up a Partner for the TEXT Protocol, page 16

• Configure the Business Agreement for the TEXT Protocol, page 17

• Set Up the Initiator Server for the TEXT_DATA Tutorial, page 18

• Configuring the Private Process for the TEXT_DATA Tutorial, page 18

Set Up a Host for TEXT Protocol

If this is the first time you are configuring a host on this machine after installing EDI 
protocols, follow the following steps: 

1. Start Creating a New Host, page 14

2. Set the Domain Identity for the Host, page 15

3. Activate the Host

Start Creating a New Host

To create and set up the default host, perform the following steps:

1. Using TIBCO Administrator, select BusinessConnect > Participants. 

2. Click the New button in the right panel.

3. Type Company1 in the Name field.

4. Select Host from the Type list.

5. Click OK. 

6. Click Apply.
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Enable the TEXT Protocol for the New Host

All EDI protocols are enabled by default after installation. In order to configure and 
activate any of the protocols, you must disable all other unconfigured protocols. Once the 
protocols are configured, they can be enabled or disabled at any time: this procedure is 
needed only when configuring protocols for the first time.

1. Select the new Host and click the Protocols tab.

a. Select the check boxes next all other protocols except for TEXT. 

b. Click Disable.

If protocols have not been enabled:

a. Click Enable.

b. Select the check box next to TEXT and click OK.

Set the Domain Identity for the Host

1. Click the TEXT link.

2. In the Edit Enabled Protocol dialog, click the Add New link next to the Default 
Domain Identity field.

3. In the Domain Identity List dialog, click the Add New button.

4. From the Domain list, select 01.

5. In the Identity field, type a name, such as 123456789.

6. Click Save.

7. Click OK.

8. In the Default Domain Identity, select 01-123456789.

9. Click Save. 

Activate the Host

1. Select BusinessConnect > Participants again.

Verify that the host, Company 1, has the Domain Identity you defined in the step Set 
the Domain Identity for the Host: (01)123456789.

2. Click on the Company1 link.

3. In the Edit Host Participant dialog, select the Active check box.
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4. Click Save.

5. Select BusinessConnect > System Settings > General and verify that Company1 is 
selected as the default host. 

Set Up a Partner for the TEXT Protocol

The trading partner setup consists of the following steps:

• Create a Partner, page 16

• Enable the TEXT Protocol, page 16

• Set the Domain Identity, page 17

• Set the Transport, page 17

Create a Partner 

If you already have set up a Responder trading partner Company2, continue to the section 
Enable the TEXT Protocol.

To set up the Responder trading partner, perform the following steps:

1. Click the BusinessConnect > Participants link in the left panel. 

2. Click the New button in the right panel.

3. Type Company2 in the Name field.

4. Select Partner from the Type list.

5. Click OK.

6. Select the Active check box.

7. Click Save. The new partner Company2 appears on the Participants list, with no 
identity defined. 

Enable the TEXT Protocol

1. Click the link Company2.

2. Click the Protocols tab.

3. Click Enable.

4. Select the TEXT check box.

Saving of the trading host will succeed only if the protocol is properly configured: 
protocol is binded and a qualifier/ID is provided
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5. Click OK.

Set the Domain Identity

1. Click the TEXT link.

2. Click the Add New link next to the Default Domain Identity field.

3. Click the Add New button.

4. From the Domain list, select 01.

5. In the Identity field, type 987654321.

6. Click Save.

7. Click OK.

8. From the Default Domain Identity list, select 01-987654321.

9. Click Save.

Set the Transport

To set the transport:

1. Click the TEXT link.

2. Click the Transports tab.

3. Click Add.

4. Provide the transport name as FILE and select FILE from the Type list.

5. Click OK.

6. In the URL field, type C:/testEDI/out.

7. Click Save three times.

Configure the Business Agreement for the TEXT Protocol

1. Click the BusinessConnect > Business Agreements link in the left panel. 

2. Click the New button in the right panel.

Forward slashes are used in the path as opposed to the Windows backslash. This is 
because the fields of the TIBCO BusinessConnect console are HTML user interface 
text components. As with any HTML user interface text component, the backslash (\) 
is treated as an escape character.
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3. Select the Company1 radio button in the Host Party area and the Company2 radio 
button in the Partner Party area.

4. Click OK.

5. Click the Add Protocol Binding button.

6. Select the TEXT check box.

7. Click OK.

8. Click the TEXT link.

9. Click the Transports tab.

10. Make sure that FILE is selected in the Primary Transport list in the Outbound 
Transports for Host ‘Company1’ area.

11. Click Save twice.

The new agreement between Company1 and Company2 with the enabled protocol 
TEXT appears.

Set Up the Initiator Server for the TEXT_DATA Tutorial

The Initiator server must be set up to communicate with its trading partners. To do so, 
follow the following steps:

• Create the deployment configuration. See TIBCO BusinessConnect Interior Server 
Administration for information on deployment configurations.

• Deploy BusinessConnect and start the server.

Configuring the Private Process for the TEXT_DATA Tutorial

This section describes how to configure private processes in the following ways: 

• Configuring Private Processes in TIBCO Designer, page 18

• Configuring Private Processes in TIBCO Business Studio, page 21

Configuring Private Processes in TIBCO Designer

To configure private processes in TIBCO Designer:

1. Opening the TIBCO ActiveMatrix BusinessWorks Project, page 19

2. Configuring Connection to BusinessConnect, page 20
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Opening the TIBCO ActiveMatrix BusinessWorks Project

To open one of the sample projects:

1. Start TIBCO Designer and select New empty project.

2. In the Save Project dialog, click Cancel.

3. Select Project > Import Full Project.

4. Click the ZIP Archive tab. 

5. Navigate to BC_HOME\protocols\tibedi\samples\bw\TEXT_Data. 

6. Select Text_Data.zip and click Open. 

7. Click OK. 

The Import - Options dialog appears.

8. In the Options tab, select the Try rename in case of name conflict radio button. 

9. Click Apply.

10. Select Project > Save As.

11. In the Project Directory file chooser, navigate to 
BC_HOME\protocols\tibedi\samples\bw\TEXT_Data.

12. Click OK.

13. When a dialog appears asking to use the directory as a project directory, click Yes. The 
zip archive file is deleted.

14. The window shown in  Figure 4 is displayed.
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Figure 4   Text_DATA project

15. Click the Global Variables tab.

16. Set BCHome to your TIBCO BusinessConnect installation directory.

17. If you made any changes, save the project but do not exit TIBCO Designer.

Configuring Connection to BusinessConnect

To configure connections to BusinessConnect, perform the following steps:

1. In TIBCO Designer, click the Project tab.

2. Expand the Text_Data folder.

3. In the EDI Server Connections folder, double-click BCServerConfigTEXT.

4. Click the BusinessConnect Server Access tab.

a. Select the JDBC driver you use to communicate with the BusinessConnect 
configuration store from the JDBC Driver Type list.

b. Type the URL for the configuration store in the JDBC URL field.

c. Type the configuration store user name and password in the DB User and DB 
Password fields.

d. Click the Apply button.

5. Click the Configuration tab.
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6. Click the Update from Configuration Store button. If you chose TIBCO 
Rendezvous as the transport for private communication, the software displays a 
TIBCO Rendezvous tab.

7. Select TEXT from the Protocol Name list.

8. Click the Import Selected Business Protocol button. 

ActiveMatrix BusinessWorks retrieves schema information from the BusinessConnect 
configuration store and puts it in the project folder. 

9. Click Apply and Save.

Configuring Private Processes in TIBCO Business Studio

To configure a private process in TIBCO Business Studio:

1. Opening the TIBCO ActiveMatrix BusinessWorks Project, page 21

2. Configuring Connections to TIBCO BusinessConnect, page 21

Opening the TIBCO ActiveMatrix BusinessWorks Project

To open the TIBCO ActiveMatrix BusinessWorks project in TIBCO Business Studio:

1. Start TIBCO Business Studio.

2. Click File > Import. 

3. On the Import page, expand the General folder and select Existing Studio Projects 
into Workspace. Click Next. 

4. Click Browse next to the Select archive file field to navigate to the 
BC_HOME/protocols/tibedi/samples/bw/TEXT_Data directory, and select the Text_Data_for_bw6.zip 
file. Click Open.

5. Click Finish.

After importing the sample, you also need to perform the following steps:

1. Expand Text_Data > Module Descriptors in the Project Explorer view.

2. Double-click Module Properties.

3. Change the default values of the properties according to your environment: BCHome, 
TPName, and DataFile.

Configuring Connections to TIBCO BusinessConnect

To configure connections to TIBCO BusinessConnect:

1. In the Project Explorer view, expand Resources and double-click 
BCServerConfigTEXT.bcResource.
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2. Click the Server Access tab.

3. Enter information as explained in step 4.

4. Click the Configuration tab, and click Update from Configuration Store.

5. Select TEXT from the Protocol Name list.

If you select the Select Operations check box, you can select any of the 
configured/imported operations. For this tutorial, select all operations and click OK.

6. Click Import Selected Business Protocol. 

When you import the protocol, TIBCO ActiveMatrix BusinessWorks retrieves 
information from the TIBCO BusinessConnect configuration store and puts them in 
the project folder.

7. Click Save.

Run the TEXT_DATA Tutorial

To run the tutorial, follow the following steps:

1. Set the Input Data, page 22

2. Send Outbound EDI-TEXT Message, page 23.

3. Check the results of sending the message. See Expected Results on page 25 and 
Viewing the Audit Log on page 25.

Set the Input Data 

1. Expand the TEXT_Data > EDI Outbound folder.

2. Select the process inside the folder and press the F12 key.

3. Type the following input data:

BCHOME: BC_HOME (such as C:\tibco\bc\x.x)

DataFile: POINBOUNDARV.xml

TPName: Company2

4. Click OK.

The steps of how to load and run private processes in TIBCO Business Studio are similar 
to TIBCO Designer. See TIBCO ActiveMatrix BusinessWorks Documentation for more 
details.
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Send Outbound EDI-TEXT Message

The Send EDI-TEXT Message process is shown in Figure 5.

Figure 5   Send EDI-TEXT Message

This process performs the following operations:

1. Reads a file containing data for TEXT.

2. Constructs a message containing the data and sends it to TIBCO BusinessConnect 
EDI Protocol powered by Instream.

To run the process:

1. Click the Tester tab.

2. Click Start testing viewed process .

Figure 6   Select Process to Load
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3. Select the check box next to Send EDI-TEXT Message in the EDI Outbound folder.

4. Click Load Selected.

5. Select the Send TEXT Message process in the Jobs list.

6. Click on the green Job icon  to start the job.

If everything was configured and run properly, you will get the result shown in 
Figure 7, TEXT Transaction, Read from a File.

Figure 7   TEXT Transaction, Read from a File

Expected Results

Once the TEXT is received by TIBCO BusinessConnect EDI Protocol powered by 
Instream:

1. The TEXT data is bundled into an interchange for sending to the trading partner.

2. The TEXT message is written to a file on the local file system when it simulates 
sending the interchange to the trading partner.

What you can observe:

• The TEXT Request activity of the Send TEXT Message process should contain output 
that indicates the TEXT was successfully sent to the trading partner.

• The directory c:\testEDI\out should contain a file which contains the that was sent to the 
trading partner by TIBCO BusinessConnect EDI Protocol powered by Instream.
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• The audit log should contain entries that for each processing state that occurred in 
TIBCO BusinessConnect. 

See Viewing the Audit Log.

Viewing the Audit Log

To view the audit log on the Initiator machine, perform the following steps:

1. Using TIBCO Administrator, click the BusinessConnect > Log Viewer link in the 
left panel. 

2. Click the TEXT link in the right panel.

3. Select items from the following lists: Status, Connection, and Date Range.

4. Click Search.

Figure 8   Search Audit Logs for TEXT

5. Click the Details icon  in the Search Results area for a specific operation to view 
details of the transaction.
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Figure 9   Transaction Details

6. Click on the icon  next to the specific transaction to see more details.

Figure 10   RECEIVED_FROM_PP
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TEXT_to_EDI Tutorials

This section steps you through the activities you need to perform to configure the host and 
trading partner on the Initiator machine.

As explained before, this tutorial is run on a single (Initiator) machine and when the 
Delimited_D99A_ORDERS (or Positional_4040_850) transaction is sent to the trading partner, the 
transport properties are defined to store the request in a directory on the local file system.

To proceed with the tutorial, perform the following steps:

• Load Guidelines, page 12

• Set Up a Host for TEXT Protocol, page 14

• Set Up a Host for the EDIFACT (or X12) Protocol, page 28

• Set Up a Partner for the TEXT Protocol, page 16

• Set Up a Partner for the EDIFACT (or X12) Protocol, page 29

• Configure the Business Agreement for the TEXT_to_EDI Tutorial, page 29

• Set Up the Initiator Server for the TEXT_to_EDI Tutorial, page 30

• Configuring Private Processes for the TEXT_to_EDI Tutorial, page 30

Set Up a Host for the EDIFACT (or X12) Protocol

If this is the first time you are configuring a host on this machine after installing EDI 
protocols, follow the following steps: 

For the EDIFACT Protocol:

See TIBCO BusinessConnect EDI Protocol powered by Instream EDIFACT 
Configuration, "Set Up a Host for the EDIFACT Protocol."

For the X12 Protocol:

See TIBCO BusinessConnect EDI Protocol powered by Instream X12 Configuration, 
"Setting Up a Host."
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Set Up a Partner for the EDIFACT (or X12) Protocol

If this is the first time you are configuring a partner on this machine after installing EDI 
protocols, follow the following steps: 

For the EDIFACT Protocol:

See TIBCO BusinessConnect EDI Protocol powered by Instream EDIFACT 
Configuration, "Set Up a Partner."

For the X12 Protocol:

See TIBCO BusinessConnect EDI Protocol powered by Instream X12 Configuration, 
"Setting Up a Partner."

Configure the Business Agreement for the TEXT_to_EDI Tutorial

1. Click the BusinessConnect > Business Agreements link in the left panel. 

2. Click the New button in the right panel.

3. Select the Company1 radio button in the Host Party area and the Company2 radio 
button in the Partner Party area.

4. Click OK.

5. Click the Add Protocol Binding button.

6. Select the TEXT and EDIFACT (or X12) check box.

7. Click OK.

8. While converting TEXT to EDI, the TEXT protocol primary transport does not take 
effect. Only the primary transport on the EDIFACT or X12 protocol side has to be set 
up. 

Click the EDIFACT or X12 link, and then the Transports tab to set up the transport.

9. Make sure that FILE is selected from the Primary Transport list in the Outbound 
Transports for Host ‘Company1’ area.

10. Click Save twice.

The new agreement between Company1 and Company2 with the enabled protocol 
TEXT and EDIFAXCT (or X12) appears.
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Set Up the Initiator Server for the TEXT_to_EDI Tutorial

The Initiator server must be set up to communicate with its trading partners. To do so, 
follow the following steps:

• Create the deployment configuration. See TIBCO BusinessConnect Interior Server 
Administration for information on deployment configurations.

• Deploy BusinessConnect and start the server.

Configuring Private Processes for the TEXT_to_EDI Tutorial

This section describes how to configure private processes in the following ways: 

• Configuring Private Processes in TIBCO Designer, page 30

• Configuring Private Processes in TIBCO Business Studio, page 32

Configuring Private Processes in TIBCO Designer

1. Opening the TIBCO ActiveMatrix BusinessWorks Project, page 30

2. Configuring Connection to BusinessConnect, page 31

Opening the TIBCO ActiveMatrix BusinessWorks Project

To open the sample project:

1. Start TIBCO Designer and select New empty project.

2. In the Save Project dialog, click Cancel.

3. Select Project > Import Full Project.

4. Click the ZIP Archive tab. 

5. Navigate to BC_HOME\protocols\tibedi\samples\bw\TEXT_Data. 

6. Select TEXT_to_EDI.zip and click Open. 

7. Click OK. 

The Import - Options dialog appears.

8. In the Options tab, select the Try rename in case of name conflict radio button. 

9. Click Apply.

10. Select Project > Save As.

11. In the Project Directory file chooser, navigate to 
BC_HOME\protocols\tibedi\samples\bw\TEXT_Data\TEXT_to_EDI.

12. Click OK.
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13. When a dialog appears asking to use the directory as a project directory, click Yes. The 
zip archive file is deleted.

14. The window shown in  Figure 11 is displayed.

Figure 11   TEXT_to_EDI Project

15. If you made any changes, save the project but do not exit TIBCO Designer.

Configuring Connection to BusinessConnect

To configure connections to BusinessConnect, perform the following steps:

1. In TIBCO Designer, click the Project tab.

2. Expand the TEXT_to_EDI folder.

3. In the EDI Server Connections folder, double-click BCServerConfigTEXT.
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4. Click the BusinessConnect Server Access tab.

a. Select the JDBC driver you use to communicate with the BusinessConnect 
configuration store from the JDBC Driver list.

b. Type the URL for the configuration store in the JDBC URL field.

c. Type the configuration store user name and password in the DB User and DB 
Password fields.

d. Click the Apply button.

5. Click the Configuration tab.

6. Click the Update from Configuration Store button. If you chose TIBCO 
Rendezvous as the transport for private communication, the software displays a 
TIBCO Rendezvous tab.

7. Select TEXT from the Protocol Name list.

8. Click the Import Selected Business Protocol button. 

ActiveMatrix BusinessWorks retrieves schema information from the BusinessConnect 
configuration store and puts it in the project folder. 

9. Click Apply.

10. Click the Save icon to save the project.

Configuring Private Processes in TIBCO Business Studio

To configure a private process in TIBCO Business Studio:

1. Opening the TIBCO ActiveMatrix BusinessWorks Project, page 32

2. Configuring Connections to TIBCO BusinessConnect, page 33

Opening the TIBCO ActiveMatrix BusinessWorks Project

To open the TIBCO ActiveMatrix BusinessWorks project in TIBCO Business Studio:

1. Start TIBCO Business Studio.

2. Click File > Import. 

3. On the Import page, expand the General folder and select Existing Studio Projects 
into Workspace. Click Next. 

4. Click Browse next to the Select archive file field to navigate to the 
BC_HOME/protocols/tibedi/samples/bw/TEXT_Data directory, and select the 
TEXT_to_EDI_for_bw6.zip file. Click Open.

5. Click Finish.
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After importing the sample, you also need to perform the following steps:

1. Expand TEXT_to_EDI > Module Descriptors in the Project Explorer view.

2. Double-click Module Properties.

3. Change the default values of the properties according to your environment: BCHome, 
and TPName.

Configuring Connections to TIBCO BusinessConnect

To configure connections to TIBCO BusinessConnect:

1. In the Project Explorer view, expand Resources and double-click 
BCServerConfigTEXT.bcResource.

2. Click the Server Access tab.

3. Enter information as explained in step 4.

4. Click the Configuration tab, and click Update from Configuration Store.

5. Select TEXT from the Protocol Name list.

If you select the Select Operations check box, you can select any of the 
configured/imported operations. For this tutorial, select all operations and click OK.

6. Click Import Selected Business Protocol. 

When you import the protocol, TIBCO ActiveMatrix BusinessWorks retrieves 
information from the TIBCO BusinessConnect configuration store and puts them in 
the project folder.

7. Click Save.

Run the TEXT_to_EDI Tutorials

To run the tutorials, follow the following steps:

1. Set the Input Data, page 34

2. Send TEXT Message (convert to EDIFACT), page 35

3. Send TEXT Message (convert to X12) on page 40

Set the Input Data 

1. Expand the TEXT_to_EDI > TEXT message process folder.

The steps of how to load and run private processes in TIBCO Business Studio are similar 
to TIBCO Designer. See TIBCO ActiveMatrix BusinessWorks Documentation for more 
details.
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2. Select one of the processes inside the folder:

— Send TEXT message (convert to EDIFACT) 

— Send TEXT message (convert to X12)

and press the F12 key.

3. Type the following input data:

BCHOME: BC_HOME (such as C:\tibco\bc\x.x)

TPName: Company2

4. Click OK.
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Send TEXT Message (convert to EDIFACT)

The Send TEXT Message (convert to EDIFACT) process is shown in Figure 12.

Figure 12   Send TEXT Message (convert to EDIFACT)

This process performs the following operations:

1. Reads the sample TEXT file located in BC_HOME/ /protocols/tibedi/ 

samples/sampleDocs/Delimited_D99A_ORDERS.dat

2. Constructs a message containing the TEXT data and sends it to TIBCO 
BusinessConnect EDI Protocol powered by Instream.

To run the process:

1. Click the Tester tab.

2. Click Start testing viewed process .

3. Select the process to load, in this case Send TEXT Message (convert to EDIFACT). 
Select also both Error Advisories.

Figure 13   Select Process to Load
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4. Click Load & Start Current.

Expected Results

Once the TEXT is received by TIBCO BusinessConnect EDI Protocol powered by 
Instream:

1. TIBCO BusinessConnect EDI Protocol powered by Instream converts the TEXT data 
into EDIFACT data.

2. The converted EDIFACT message is written to a file on the local file system to 
simulate sending the interchange to the trading partner.

What You Can Observe

• The TEXT Request activity of the Send TEXT Message process should contain output 
that indicates the TEXT was converted to EDI.

• The directory c:\testEDI\out must contain a file which contains converted EDIFACT 
data that was sent to the trading partner by TIBCO BusinessConnect EDI Protocol 
powered by Instream

• The audit log should contain entries both in TEXT and EDIFACT protocols.

After 24 hours, TIBCO BusinessConnect EDI Protocol powered by Instream will send 
an acknowledgment timeout error advisory to TIBCO ActiveMatrix BusinessWorks. 
However, for the purposes of this tutorial, it is not necessary to wait for this advisory 
message to arrive..

Viewing the Audit Log

The audit log for this transaction will have two parts:

• First part for the TEXT protocol and it shows TEXT data being converted to 
EDIFACT data. 

• Second part is for the EDIFACT protocol and it shows the converted EDIFACT data 
being validated and sent to the trading partner.

Audit Log for TEXT

To view the TEXT audit log on the Initiator machine, perform the following steps:

1. Using TIBCO Administrator, click the BusinessConnect > Log Viewer link in the 
left panel. 

In the Input tab of the Send Request activity, certain fields cannot take effect for 
TEXT_to_EDI conversion: transactionID, encoding, perMessage, txnGroupingID, destinationFileName, 
and controlNuminfo.
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2. Click the TEXT link in the right panel.

3. Select items from the following lists: Status, Connection, and Date Range.

4. Click Search.

Figure 14   Audit Log: TEXT

5. Click the Details icon  in the Search Results area for a specific operation to view 
details of the transaction, such as EDI/Outbound to check whether TEXT date has 
been successfully convert to EDIFACT.
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Figure 15   Transaction Details: TEXT_to_EDI

6. Since the TEXT to EDIFACT transfer occurred successfully, we can further check the 
details.

Click on the icon next to the specific transaction to see more details.

Figure 16   Transaction Details
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Audit Log for EDIFACT

To view the EDIFACT audit log, perform the following steps:

1. Using TIBCO Administrator, click the BusinessConnect > Log Viewer link in the 
left panel. 

2. Click the EDIFACT link in the right panel.

3. Select items from the following lists: Status, Connection, and Date Range.

4. Click Search.

Figure 17   Audit Log for EDIFACT

5. Click the Details icon  in the Search Results area for a specific operation to view 
details of the transaction, such as 3/D99A/ORDERS.

Figure 18   Transaction Details: EDI Document sent to the Trading Partner
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Send TEXT Message (convert to X12)

The Send TEXT Message (convert to X12) process is shown in Figure 19.

Figure 19   Send TEXT Message (convert to X12)

This process performs the following operations:

1. Reads the sample TEXT file located in BC_HOME/ /protocols/tibedi/ 

samples/sampleDocs/Positional_4040_850.dat

2. Constructs a message containing the TEXT data and sends it to TIBCO 
BusinessConnect EDI Protocol powered by Instream.

To run the process:

1. Click the Tester tab.

2. Click Start testing viewed process .

3. Select the process to load, in this case Send TEXT Message (convert to X12). Select 
also both Error Advisories.

4. Click Load & Start Current.

Expected Results

Once the TEXT is received by TIBCO BusinessConnect EDI Protocol powered by 
Instream:

1. TIBCO BusinessConnect EDI Protocol powered by Instream converts the TEXT data 
into X12 data.

2. The converted X12 message is written to a file on the local file system to simulate 
sending the interchange to the trading partner.

What you Can Observe

• The TEXT Request activity of the Send TEXT Message process contains output that 
indicates the TEXT was converted to EDI.
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• The directory c:\testEDI\out should contain a file which contains converted X12 data 
that was sent to the trading partner by TIBCO BusinessConnect EDI Protocol 
powered by Instream.

• The audit log should contain entries both in TEXT and X12 protocols.

After 24 hours, TIBCO BusinessConnect EDI Protocol powered by Instream will send 
an ack timeout error advisory to TIBCO ActiveMatrix BusinessWorks. However, for 
the purposes of this tutorial, it is not necessary to wait for this advisory message to 
arrive.

Viewing the Audit Log

The audit log for this transaction will have two parts:

• First part for the TEXT protocol and it shows TEXT data being converted to X12 data. 

• Second part is for the X12 protocol and it shows the converted X12 data being 
validated and sent to the private process.

Audit Log for TEXT

To view the TEXT audit log on the Initiator machine, perform the following steps:

1. Using TIBCO Administrator, click the BusinessConnect > Log Viewer link in the 
left panel. 

2. Click the TEXT link in the right panel.

3. Select items from the following lists: Status, Connection, and Date Range.

4. Click Search.

In the Input tab of the Send Request activity, certain fields cannot take effect for 
TEXT_to_EDI conversion: transactionID, encoding, perMessage, txnGroupingID, destinationFileName, 
and controlNuminfo.
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Figure 20   Audit Log: TEXT

5. Click the Details icon  in the Search Results area for a specific operation to view 
details of the transaction, such as EDI/Outbound to check whether TEXT date has 
been successfully convert to X12.

Figure 21   Transaction Details: TEXT_to_EDI
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6. Since the TEXT to X12 transfer was successful, check the details. Click on the icon 
next to the specific transaction to see more details.

Figure 22   Transaction Details

Audit Log for X12

To view the X12 audit log on the Initiator machine, perform the following steps:

1. Using TIBCO Administrator, click the BusinessConnect > Log Viewer link in the 
left panel. 

2. Click the X12 link in the right panel.

3. Select items from the following lists: Status, Connection, and Date Range.

4. Click Search.
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Figure 23   Audit Log for X12

5. Click the Details icon  in the Search Results area for a specific operation to view 
details of the transaction, such as 00403/004040/850.

Figure 24   Transaction Details: EDI Document sent to the Trading Partner
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Chapter 3 Managing TEXT Messages

This chapter describes how to manage TEXT messages. 

Topics

• Overview, page 46

• Adding a Message Group, page 47

• Adding a Message Type to a Message Group, page 48

• Importing a Message Group, page 53

• Exporting Message Groups and Types, page 54
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Overview

TIBCO BusinessConnect EDI Protocol powered by Instream TEXT Protocol uses 
message groups to categorize text messages. Each message defines an action and its 
related communication parameters. For example, the definition of an message would 
include the following:

• The message’s description and type (notify in TIBCO BusinessConnect EDI Protocol 
powered by Instream).

• The guidelines used by the message.

You later use the message groups when you set up communications with your trading 
partners. 
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Adding a Message Group

Before you can create new message types, you must create a message group. To add a 
message group, perform the following steps:

1. Click the BusinessConnect > Operations Editor link in the left panel. 

2. Click on the TEXT link.

3. Click New Message Group.

4. Enter a new message group name.

5. Enter a description (optional).

6. Click Save.
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Adding a Message Type to a Message Group

To add a message type to a message group, perform the following steps:

1. Click the radio button next to a message group.

2. Click New Message Type.

The Operation Type list is displayed with Notification selected. The Type selection 
cannot be modified because only Notification transactions are supported. 

Synchronous request-response transactions are not supported by the TEXT protocol. 

3. Click OK.

You can configure the new massage type with the following tabs:

• Notification Message Type, page 48

• Outbound Action, page 51

• Inbound Action, page 52

Notification Message Type

To configure the message type, enter information into the following tabs, then click Save:

• General Tab, page 48

• Guideline Tab, page 49

• Schema Tab, page 51

General Tab

This tab allows you to configure the message type format on inbound and the raw data 
included in the message:

Table 2   Notification Message: General Tab

Field Description

Name Name of the new message type

Description Description of the new message type
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Guideline Tab

This tab allows you to configure message guidelines and validator profiles. Click change 
to select the guideline file associated with this message type. 

You can select the file type: File Reference or Uploaded File.

• For File Reference, enter the whole path including the file reference name.

• For Uploaded File, click Browse to select a configuration file from the local file 
system.

Inbound

Message Type 
Format

The message type format can be as follows: 

• Delimited This format defines files that contain a consistent delimiter all 
throughout the file.

• Positional This format defines files that have a defined position (or size) for 
each field in the file

Raw Data

Include in Private 
Process Request

When checked, includes the raw document in the message to the private process.

Extra Message Type 
Info

Optional inbound routing information that the private process can use to route this 
kind of message. 

Table 2   Notification Message: General Tab (Cont’d)

Field Description

Table 3   Notification Message: Guideline Tab

Field Description

Message Guideline (.sef or 
.std)

This field shows the current message guideline. It allows you also to 
change/add or to remove the existing message guideline.

Load a guideline file, such as Positional_4040_850.sef.

Validator Profile file (.apf) This field shows the current validator profile file (the default is no file). It 
allows you also to change/add or to remove the existing validator profile file.
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Outbound
Type of Translation

Outbound TEXT to EDI 
Translation Type

Select one outbound TEXT to EDI translation type from the list.

• None Select when this type of translation is not used

• TEXT to EDI Select for the TEXT files to be converted to X12 or to 
EDIFACT protocol. To perform this conversion, the trading partner must 
enable both the TEXT and the X12 or EDIFACT protocol. 

See also TIBCO BusinessConnect EDI Protocol powered by Instream 
User’s Guide, "TEXT to EDI Conversion."

Operation ID of EDI 
transaction (e.g. 
00403/004040/850)

Enter the Notify or a Synchronous Request Response ID.

• For TEXT to EDIFACT conversion, only the Notify operation is 
supported.

• For TEXT to X12 conversion, both the Notify and Synchronous Request 
Response operations are supported. Therefore, both IDs are valid for this 
field. 

If the Notify operation ID is used, the converted X12 data will be sent as 
a Notify transaction; if the Synchronous Request Response operation ID 
is used, the converted X12 data will be sent as a Synchronous Request 
Response transaction.

Note For any request that is being sent from the private process to TIBCO 
BusinessConnect for TEXT documents, an appropriate OperationID must be 
specified instead of EDI/Outbound.

EDI Translation Guideline

Guideline File used for 
translating TEXT to EDI 
(.sef or .std)

Select a guideline file, such as X12_4040_850.sef.

Table 3   Notification Message: Guideline Tab (Cont’d)

Field Description
TIBCO BusinessConnect EDI Protocol powered by Instream TEXT Configuration



Adding a Message Type to a Message Group | 51
Schema Tab

Message schemas are used to integrate TIBCO BusinessConnect EDI Protocol powered 
by Instream with back office systems. If the back office systems are implemented with 
TIBCO ActiveMatrix BusinessWorks, these message schemas can also be loaded into 
TIBCO Designer/TIBCO Business Studio at design-time to generate process definitions 
that send messages defined in TIBCO BusinessConnect EDI Protocol powered by 
Instream. This tab allows you to configure schemas and map files.

Click change to select the schema file associated with this message type. You can select 
the file type: File Reference or Uploaded File.

• For File Reference, enter the whole path including the file reference name.

• For Uploaded File, click Browse to select a configuration file from the local file 
system.

Outbound Action

Name the new message type for the outbound action. Direction: Initiator to Responder 
(preset).

Inbound Action

Name the new message type for the inbound action. Direction: Responder to Initiator 
(preset).

Table 4   Notification Message: Schema Tab

Field Description

Message Schema (.xsd) Load a message schema, such as Positional_4040_850.xsd.

Request Root Element 
Name

The fixed value T-LAYOUT is used since all TEXT guidelines use LAYOUT 
as the root element in EDISIM Standards Editor.

Message to XML translation 
Map file (.map)

Load a map file, such as Positional_4040_850_FX.map.

XML to Message translation 
Map file (.map)

Load a map file, such as Positional_4040_850_XF.map.

Outbound
EDI Translation Map

TEXT to EDI translation 
Map file (.map)

Load a map file, such as PO_Positional_X12_4040_850.map.
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Importing a Message Group

To import message groups, perform the following steps:

1. Click the BusinessConnect > Operations Editor link in the left panel. 

2. Click Import.

3. Click change.

4. Click Browse.

5. Navigate to BC_HOME\protocols\tibedi\samples\interfaces and select one of the sample 
message groups for TEXT. Example: TEXT.csx. 

6. Click Open.

7. Click OK.

8. Enter a password (optional).

9. Click Import.

TIBCO BusinessConnect EDI Protocol powered by Instream comes with a sample 
message group that can be imported into the TIBCO BusinessConnect configuration store:

BC_HOME\protocols\tibedi\samples\interfaces\TEXT.csx
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Exporting Message Groups and Types

To export message group and types, perform the following steps:

1. Click the BusinessConnect > Operations Editor link in the left panel. 

2. Select the TEXT link.

3. In the Edit Operations: TEXT dialog, click the topmost plus (+) sign to display all 
TEXT groups and types.

4. Click the radio button next to the group or type you wish to export.

5. Click Export XXX where XXX is Group or Type, depending on what you selected in 
step 4.

6. Set a password (optional), and click Export Data.

7. The Save As dialog displays with operations.csx as the suggested file name.

8. Click Done.
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Chapter 4 Setting Up Trading Hosts

This chapter describes setting up trading hosts in TIBCO BusinessConnect EDI Protocol 
powered by Instream for the TEXT protocol.

Topics

• Configuring the TEXT Protocol for a Host, page 56

• General Tab, page 57

• Logging Tab, page 58

• Advanced Tab, page 59
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Configuring the TEXT Protocol for a Host

To enable the TEXT protocol:

1. Click the BusinessConnect > Participants link in the left panel. 

2. Click a host participant link in the right panel.

3. Click the Protocols tab.

4. If TEXT does not appear in the list of protocols:

a. Click Enable.

b. Select the TEXT check box.

c. Click OK.

5. Click the TEXT link. 

The following configuration options are available:

— General Tab, page 57.

— Logging Tab, page 58.

— Advanced Tab, page 59.

6. Click Save.
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General Tab

Use the General tab to set host general properties for TEXT.

Adding a Default Domain Identity

To add a default domain identity:

1. Click the Add New link.

2. Click the Add New button.

Select a domain from the Domain list. For example, specify 01 for a D-U-N-S 
number. For outbound documents, the domain is not validated for the sender of a 
document. 

3. Enter the mandatory identity for the host in the ID field. This is mapped to the host’s 
identity. For example, Interchange Sen is the fictitious D-U-N-S number used in the 
tutorial. For outbound documents, the identity is not validated for the sender of a 
document.

4. Click Save and OK.

Table 5   Setting Up Host: General tab

Field Description

Default Domain 
Identity

The domain and ID to use for this trading host. 

• For outbound documents, the qualifier and ID are specified as the sender domain 
and ID. 

• For inbound documents, the domain and ID are matched against this field’s values 
to ensure that the inbound document was intended for this host.

See Adding a Default Domain Identity on page 57 to add or edit a transmission code 
and name.

AS2 Identifier An identifier to use in the AS2-To header field of the HTTP message. It should be 
mutually agreed upon between trading partners and can be an interchange ID. This only 
applies when using AS2 transport.

Valid Email 
Address List

The identifier to use in the From header field of the SMTP MIME message. This email 
address list can be a list of email addresses. For an outbound document sent to the 
trading partner through SMTP transport, the first email address is used in the From 
header. For incoming emails from the mail server, the To email address from the email 
is matched to one of the email addresses in this list. This only applies when using AS1 
or AS2 transport.
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Logging Tab

Use the Logging tab to configure EDI-specific logging options available with EDI. For 
further information, see TIBCO BusinessConnect EDI Protocol powered by Instream, 
User’s Guide, "TEXT to EDI Conversion"

Table 6   Setting Up Host: Logging Tab

Field Description

Inbound

Log Raw TEXT 
Request to File

Log the original, intact and unconverted EDI documents.

Store Location The original inbound EDI documents are stored in a directory whose name is derived 
from the specified location. 

For information on how the files are named, see TIBCO BusinessConnect EDI Protocol 
powered by Instream User’s Guide, "Document Archiving."

Include Date 
Folder 

Creates a file reference in a folder created based on the current date.

Outbound

Log Raw TEXT 
Request to File

Log the original, intact and unconverted EDI documents.

Store Location The original outbound EDI documents are stored in a directory whose name is derived 
from the specified location. 

For information on how the files are named, see TIBCO BusinessConnect EDI Protocol 
powered by Instream User’s Guide, "Document Archiving."

Include Date 
Folder

If checked, the date folder is added to the document path. 

If unchecked, the date folder is omitted and the document is stored under the tpName 
directory.
TIBCO BusinessConnect EDI Protocol powered by Instream TEXT Configuration



Advanced Tab | 59
Advanced Tab

Use the Advanced tab to specify advanced settings for the handling of inbound and 
outbound XML documents.

Many of these properties impact memory usage, thereby impacting performance. Read the 
description for each field for information about memory tuning.

Table 7   Setting Up Host: Advanced Tab

Field Description

Inbound

Publish XML 
Request as File 
Reference

Write the converted XML to a file for each inbound transaction and publish the file 
reference in the requestFile attribute of the ResponderRequest message to the private process. 
Use of this option can decrease memory usage, improving performance. The 
Threshold property determines how large the XML must be before BusinessConnect 
writes the request to a file.

Threshold (bytes) Specify a file size in bytes. Default is 0.

BusinessConnect writes XML requests that are this size and larger to a file and sends a 
reference to that file instead of the request itself. A value of 1000 is often appropriate. 
This can decrease memory usage within the EDI processing component, improving 
performance.

Include Date 
Folder

Default is checked.

• If checked, the date folder is added to the document path. 

• If unchecked, the date folder is omitted and the document is stored under the 
tpName directory.

Store Location Identify the directory in which BusinessConnect should store the files.

If this field is empty or the directory specified is not valid, BusinessConnect behaves 
as if Publish XML Request as File Reference is not checked; it does not store a file; it sends the 
XML request.
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Output XML 
Request in UTF-8 
and Remove 
Empty Elements

Selecting this check box instructs BusinessConnect to perform these tasks:

• Convert the XML that is in UTF-16 format to UTF-8. 

• Delete XML elements in the request that contain no values. This reduces the file 
size. Reducing the request size is especially important when you are using the 
XML for back-end processing.

Note: Converting the XML from UTF-16 to UTF-8 in this way increases memory 
usage. Consider converting the XML to UTF-8 in a separate JVM process instead of 
using this option.

Table 7   Setting Up Host: Advanced Tab (Cont’d)

Field Description
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Chapter 5 Setting Up Trading Partners

This chapter describes setting up trading partners for TEXT.

Topics

• Configuring the TEXT Protocol for a Partner, page 62

• General Tab, page 63

• Logging Tab, page 65

• Delimiters Tab, page 66

• Transports Tab, page 68
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Configuring the TEXT Protocol for a Partner

To configure the TEXT protocol:

1. Click the BusinessConnect > Participants link in the left panel. 

2. Click a partner participant link in the right panel.

3. Click the Protocols tab.

4. If TEXT does not appear in the list of protocols:

a. Click Enable.

b. Select the TEXT check box.

c. Click OK.

5. Click the TEXT link. The following configuration options are available:

— General Tab, page 63

— Logging Tab, page 65

— Delimiters Tab, page 66

— Transports Tab, page 68
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General Tab

To configure the General tab and set the partner general properties for TEXT use Table 8.

Table 8   Setting Up a Partner: General Tab

Field Description

Default Domain 
Identity

The domain and ID to use for this trading partner. 

• For outbound documents, the domain and ID will be specified as the receiver 
domain and ID. 

• For inbound documents, the sender domain and ID are used to identify the sender.

See Adding a Default Domain Identity on page 57 to add or edit a domain and ID.

AS2 Identifier An identifier to use in the AS2-To header field of the HTTP message. This identifier 
should be mutually agreed upon between trading partners. This identifier can be an 
interchange ID. This only applies when using AS2 transport.

Valid Email 
Address List

The email address that is used to match against the incoming email from the mail 
server. If the incoming email From address matches to any email address in this list, 
then this trading partner is picked as the receiving party. This only applies when using 
AS1 or AS2 transport.

Inbound

Enable 
Transaction 
Duplicate 
Detection

Enable checking for duplicate transactions. Default is unchecked.

When this check box is selected, all inbound transactions that are received from the 
trading partner are selected to see if a duplicate has been received and appropriately 
marked in the RESPONDER.REQUEST PP message. The duplicate attribute in ResponderRequest 
is marked as true if the same message is received from the trading partner.

TEXT has the following attributes: Trading Partner Name, operationID, transactionName, 
whole transaction, host initiates flag.

Extra Info in 
Private Process 
Request 

Data included in the message to the private process for each message received from 
this trading partner. For example, you could use this field to pass routing information 
based upon the trading partner. 
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Inbound EDI Data 
Encoding

Specify the type of encoding for inbound EDI data.

• If inbound EDI data contains the BOM header, such as UTF-8 and UTF-16 
encoding, TIBCO BusinessConnect EDI Protocol powered by Instream gets the 
encoding from the BOM header regardless of what value you set in this field.

• If inbound EDI data does not contain the BOM header, such as ISO-8859-1 and 
US-ASCII encoding, TIBCO BusinessConnect EDI Protocol powered by Instream 
checks whether the value in this field is set.

— If you set a value in this field, TIBCO BusinessConnect EDI Protocol powered 
by Instream uses the specified encoding type to process inbound EDI data.

— If no value is set in this field, TIBCO BusinessConnect EDI Protocol powered 
by Instream uses the system encoding of the TIBCO BusinessConnect Interior 
Server engine to process inbound EDI data.

Outbound

Transaction Level 
Duplicate 
Detection

Indicate how duplicate documents from private processes should be handled:

• None No outbound duplicate detection will be performed.

• Allow to TP If a duplicate document is sent, then the message is marked as 
duplicate and returned to the private process through an attribute in the 
InitiatorResponse message. The message is sent to the trading partner.

• Deny to TP If a duplicate document is sent, then the message is marked as 
duplicate and returned to the private process through an attribute in the 
InitiatorResponse message. The message is not sent to the trading partner.

Enable EDI 
Validation

Default is unchecked.

When checked, it will validate the outbound messages in TEXT format.

Outbound XML 
to EDI Data 
Encoding *

Specify the type of encoding for outbound XML to EDI data.

This field is required.

• The default value is US-ASCII.

Table 8   Setting Up a Partner: General Tab (Cont’d)

Field Description
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Logging Tab

Use the Logging tab to configure EDI-specific logging options available with EDI. For 
further information, see in TIBCO BusinessConnect EDI Protocol powered by Instream, 
User’s Guide, "TEXT to EDI Conversion"

Table 9   Setting Up Partner: Logging Tab

Field Description

Inbound

Log Raw EDI 
Segments to File

Default is unchecked.

Store each raw inbound TEXT document to the specified Store Location.

Store Location The original inbound EDI documents are stored in a directory whose name is derived 
from the specified location. 
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Delimiters Tab

The Delimiters tab allows you to configure record and field delimiters for the EDI TEXT 
protocol. 

The private process sends an XML document for the TEXT protocol in XML format 
corresponding to the XML schema that was generated from the guideline that defines the 
structure of the TEXT document. TIBCO BusinessConnect EDI Protocol powered by 
Instream protocol converts XML to TEXT before publishing the same to the trading 
partner.

The private process can use either the tpName or the qualifier/ID pairs in the 
perMessage/interchange/sender and perMessage/interchange/receiver message (both part 
of INITIATOR.REQUEST) to indicate the trading partner based on the delimiter settings 
that will be picked up. 

The controlNumInfo parameter is completely ignored in the case of the TEXT protocol.

To configure the Delimiters tab, see Table 10.

Only one character per delimiter can be used for TEXT Protocol.

Table 10   Setting Up Partner: Delimiters Tab

Field Description

Outbound When data is converted from XML to EDI, the delimiters listed under Outbound 
will be used.

Wrap Data Checked or 
unchecked

This option is checked by default.

When segments are converted to the TEXT data, they are 
formatted as follows:

• When checked, no additional LF/CRLF breaks will be 
added at the end of each segment.

• When unchecked, each segment will be on a new line.

Delimited

Segment Delimiter * ’
(apostrophe)

Delimiting between segments

Element Delimiter * ,
(comma)

Delimiting between elements
TIBCO BusinessConnect EDI Protocol powered by Instream TEXT Configuration



Delimiters Tab | 67
Customizing Delimiter Settings for an Operation

If you change a delimiter setting, you must modify the file FlatFileInitialDetector.csv, 
which is located in the folder BC_HOME/protocols/tibedi/config.

You also must add a new row in this .csv file after adding a new transaction in the 
Operations Editor. This is required in case you want to validate the TEXT document that is 
translated before sending it to the trading partner.

The Instream engine uses a set of criteria to identify or detect the entries in the file 
FlatFileInitialDetector.csv, as described in Chapter 1, Overview and Chapter 7, Type Detection.

Positional

Record Delimiter * ’
(apostrophe)

Delimiting between records

Inbound When data is converted from TEXT to XML, the delimiters listed under Inbound 
will be used.

Delimited

Segment Delimiter * ’
(apostrophe)

Delimiting between segments

Element Delimiter * ,
(comma)

Delimiting between elements

Positional

Record Delimiter * ’
(apostrophe)

Delimiting between records

If you are going to conduct a TEXT to EDIFACT transaction (that is, a transaction in 
which a flat .dat file containing the TEXT message is converted into the EDIFACT 
format), you must ensure that the delimiter used in the source .dat file containing the 
TEXT message is the same delimiter defined for the trading partner in the 
BusinessConnect Administrator GUI and in FlatFileInitialDetector.csv.

Table 10   Setting Up Partner: Delimiters Tab (Cont’d)

Field Description
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Transports Tab

Use the Transports tab to configure outbound transport settings for this trading partner. To 
add an outbound transport, click Add in the Transports tab. The following transports are 
available for use with this protocol:

• FTP/S

• FILE

• AS2-HTTP/S

• SSHFTP

• Inbox

Inbox option is available in order to allow for document exchange between partners 
running TIBCO BusinessConnect EDI Protocol powered by Instream and one of these 
products: 

— TIBCO BusinessConnect Plug-in for SSH Server

— TIBCO BusinessConnect Plug-in for FTP Server

— TIBCO PartnerExpress

For more information, see TIBCO BusinessConnect EDI Protocol powered by 
Instream, User’s Guide, "Set Up Trading Partner Transport via Inbox."

The steps required for configuring transports are essentially the same for all protocols. 
Refer to the transports chapters in TIBCO BusinessConnect Trading Partner 
Administration Guide. 

For EDI-specific transport configuration, see TIBCO BusinessConnect EDI Protocol 
powered by Instream User’s Guide, Chapter 6, "File Masks."

The transports you configure serve as the default transports for all business agreements 
associated with this partner. You can override the default transport settings as part of the 
business agreement.
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Chapter 6 Configuring Agreement Protocol Bindings

This chapter explains how to configure protocol bindings for business agreements.

Topics

• Overview, page 70

• Operation Bindings Tab, page 71

• Document Security Tab, page 74

• Transports Tab, page 76

• Scheduled Transmission Tab, page 79

• Overriding Participant Settings, page 81
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Overview

An agreement protocol binding is contained within a business agreement. For information 
on business agreements, see TIBCO BusinessConnect Trading Partner Administration.

Add Protocol Binding

To add an agreement protocol binding:

1. Click the BusinessConnect > Business Agreements link in the left panel. 

2. Click a business agreement link in the right panel.

3. Click the Add Protocol Bindings button. 

4. Check TEXT.

5. Click OK.

6. Click the TEXT agreement protocol binding link.

The following configuration options are available:

— Operation Bindings Tab, page 71

— Document Security Tab, page 74

— Transports Tab, page 76

— Scheduled Transmission Tab, page 79

— Overriding Participant Settings, page 81
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Operation Bindings Tab

Use the Operation Bindings tab to configure the TEXT messages that each participant in 
a business agreement can initiate and respond to. 

The following properties apply to all the messages that you import in the Operations 
Editor:

• Allow All Operations Enables participants to initiate all operations configured in 
BusinessConnect. You can modify the behavior of one or more operations by binding 
the operations in the Partner ’Y’ Can Initiate area.

If unchecked, operations must be explicitly bound in the Host ’X’ Can Initiate and 
Partner ’Y’ Can Initiate areas. 

• Non Repudiation Logging Enables logging of all operations in the non-repudiation log.

Binding an Operation

The Host ’X’ Can Initiate area (where X is the host participant in the business agreement) 
lists the transactions that the host can initiate and the partner can respond to. The Partner 
’Y’ Can Initiate area (where Y is the partner participant in the business agreement) lists the 
transactions that the partner can initiate and the host can respond to. 

To bind a transaction in either area, perform the following steps:

1. Click Add Operation Bindings.

2. Click the topmost + to expand the transaction tree.

3. Check the transaction.

4. Click OK.

Editing an Operation Binding

To edit an operation binding, perform the following steps:

1. Click an operation binding link. The following options are available:

— Operation Settings Tab, page 72

— Transports Tab, page 73

2. Click Save.
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Operation Settings Tab

To override the settings for a message, select the Override Operation Settings check box 
and then select one of the following from the list:

• General, to override the general settings for a TEXT message type

• Guideline, to override the guideline settings for a TEXT message type

General Option 

Overrides the same settings made in the Operations Editor. 

See General Tab on page 48. 

Configurable options include the following:

Guideline Option

Changing the settings in this dialog overrides all the same settings made in the Operations 
Editor. 

See Guideline Tab on page 49.

Schema Option

Overrides the same settings made in the Operations Editor. 

See Schema Tab on page 51. 

When no guidelines are given for the operation binding with the Override Operation 
Settings enabled and with Allow all Operation check box selected, the guideline in the 
operations editor will take effect.

Table 11   Configuring Business Agreement: General Option

Field Description

Inbound
Raw Data

Include in Private 
Process Request

Default is unchecked.

When checked, overrides the same settings made in the Operations Editor. See 
General Tab on page 48.

Extra Message Type 
Info

Add information about the message type
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Configurable options include the following::

Transports Tab

This tab is used for overriding of outbound transport settings:

Table 12   Configuring Business Agreement: Schema Option

Field Description

Message to XML 
translation Map 
file (.map)

If needed, change or remove the previously selected map file.

XML to Message 
translation Map 
file (.map)

If needed, change or remove the previously selected map file.

Outbound
EDI Translation Map

TEXT to EDI 
Translation Map 
file (.map)

If needed, change or remove the previously selected map file.

Table 13   Configuring Business Agreement: Transports Tab

Field Description

Override 
Transports

When checked, overrides the transports set in participant’s configuration.

Override Outbound Transports

Primary 
Transport

Select the primary transport from the list.

• Current transport (such as FILE, FTP, FTPS, AS2-HTTP, AS2-HTTPS, SSHFTP, or 
Inbox)

• None

Backup 
Transport

Select the backup transport from the list.

• Current transport (such as FILE, FTP, FTPS, AS2-HTTP, AS2-HTTPS, SSHFTP, or 
Inbox)

• None
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Document Security Tab

Use the Document Security tab to specify security information for trading partners. The 
keys and certificates selected in the tab are set in the host and partner participant’s 
Credentials tabs. See TIBCO BusinessConnect Trading Partner Administration for 
information on how to set credentials. 

The properties listed in Table 14 can be set for inbound and outbound document exchange.

Table 14   Configuring Business Agreement: Document Security Tab

Field Description

Outbound Doc Exchange
Signing Info Settings

Signing Key The key the host uses to sign a message in order to identify itself to a partner. The 
partner uses the host’s certificates file to authenticate the host by verifying the digital 
signature of the host.

Digest Algorithm The algorithm used to create the digest.

Selection are: SHA1, MD5, SHA256, SHA384, and SHA512.

PGP Signing 
Private Key

The PGP key the host uses to sign a message in order to identify itself to a partner. 

PGP Hash 
Algorithm

The PGP algorithm used to create the digest to be used for digital signatures:

MD5, SHA1, RIPEMD160, MD2

Encryption Info Settings

Encryption 
Certificate

The certificates file the host uses to encrypt a document before sending it to the 
partner. The partner uses its own host key identity file to decrypt the document.

Encryption 
Algorithm

The algorithm used to encrypt documents: DES3, RC2-40, RC2-128, AES-128, 
AES-192, AES-256

PGP Encryption 
Public Key

The PGP public key the host uses to encrypt a document before sending it to the 
partner. 

PGP Encryption 
Algorithm

The PGP algorithm used to encrypt documents:

DES3, BLOWFISGH, CAST5, AES-128, AES-192, AES-256.

Inbound Doc Exchange
Signing Info Settings
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Verification 
Certificate

The partner identifies itself by signing a document with its own host identity file. The 
host uses this certificate to authenticate a partner by verifying the digital signature of 
the partner. You must obtain this certificate from the host in advance.

PGP Signing 
Verification Public 
Key

The host uses this PGP public key to authenticate a partner by verifying the digital 
signature of the partner.

Encryption Info Settings

Decryption Key The host uses part of the host key identity file to decrypt a document that the partner 
encrypted using the host’s certificates file.

PGP Decryption 
Private Key

The host uses this PGP private key to decrypt the document.

Table 14   Configuring Business Agreement: Document Security Tab (Cont’d)

Field Description
 TIBCO BusinessConnect EDI Protocol powered by Instream TEXT Configuration



76 | Chapter 6  Configuring Agreement Protocol Bindings
Transports Tab

Use the Transports tab to set transport information for a transporting Gateway. 

A transporting Gateway can be shared by multiple EDIFACT and X12 trading partners, 
while it is not supported for partners using the TEXT protocol.

The top section of the tab is used for selecting transports for the outbound, or host to 
trading partner, direction. The bottom section of the tab is used for selecting and 
configuring transports for the inbound, or trading partner to host, direction.

See Transports Tab, page 68.

Table 15   Outbound Transport for the Host

Field Description

Primary Transport  Outbound transport is supported only in the passthrough mode. That is, there is no 
validation available, and no conversion from TEXT to XML. Choose the primary 
transport from the list of transports previously configured in a trading partner’s 
Protocols > Transports tab (Transports Tab on page 68): FTP, FILE, FTPS, 
AS2-HTTP, AS2-HTTPS, SSHFTP

See the Transports chapters in the TIBCO BusinessConnect Trading Partner 
Administration. 

Backup Transport TIBCO BusinessConnect EDI Protocol powered by Instream supports a backup 
outbound transport for sending XML files to the trading partner. This backup 
transport is used if the file could not be sent via the primary transport configured in 
the business agreement. Such situation may happen if the trading partner’s server 
is not available or has a wrong URL during the time the file is being sent: the file 
still needs to reach the server via some other means even after the primary 
transport retry was exhausted.

Backup transports are configured at the business agreement level and can be one of 
the supported BusinessConnect transports. The same rules apply for choosing a 
backup transport as for a primary transport.
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Setting the Inbound Transport

What displays in this area depends on the transports that are selected in the Transport 
Type area of the Public Process Configuration tab. 

For further information, see the section on Deployment Configuration in the TIBCO 
BusinessConnect Trading Partner Administration.

AS2 Async MDN 
Reply Transport

Same as for TIBCO BusinessConnect: select any of the configured transports. The 
settings from the specified AS2 MDN Async Reply Transport field are used for 
sending async MDN responses back to your trading partner. Configuring the AS2 
MDN Async Reply Transport is not necessary unless you would like to specify 
different values for the following HTTP transmission related settings: 

• Retry Count – default is 3

• Retry Interval – default is 60 seconds

• Socket Timeout – default is 300 seconds (5 minutes)

Any other settings specified in the AS2 MDN Async Reply Transport are ignored. 
The most common case for which you would specify this transport is when your 
trading partner is not acknowledging the receipt of your async MDNs within the 
default socket timeout period.

AS2 Async MDN 
Remote Server 
Certificate

Same as for TIBCO BusinessConnect.

The Remote Server Certificate for the AS2 HTTPS transport is a SSL certificate 
that should be used for encrypting the data sent using HTTPS. This dropdown list 
contains all of the certificates that have been configured for the Trading Partner. 
You can select the one that was configured to be used for SSL encryption.

Note The server certificate configuration is only required for Async MDNs via 
AS2 HTTPS transport. 

Client Authentication 
Identity for HTTPS, 
FTPS, HTTPSCA

Choose between the transport that was set up as Client Authentication Identity for 
HTTPS, FTPS, HTTPSCA, or None.

Client Authentication 
Identity for SSHFTP

Choose between the transport that was set up as Client Authentication Identity for 
SSHFTP, or None.

Table 15   Outbound Transport for the Host (Cont’d)

Field Description
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Table 16   Inbound Transport Fields

Field Description

HTTP/S Allow HTTP/S connections from this partner directly or from a VAN. This also applies 
when the inbound connection is using the AS2 transport. 

HTTPSCA/AS2 See TIBCO BusinessConnect Trading Partner Administration, Chapter 11, HTTP, 
HTTPS, and HTTPSCA Transports.

FTP/S Allow the host to perform FTP/S connections with this partner. The host is the Initiator 
of the FTP process. Click Edit Settings to configure FTP/S. See TIBCO 
BusinessConnect Trading Partner Administration Guide for more information on how a 
host uses FTP.

FILE Allow FILE connections from this partner. FILE is normally used for file exchange 
within an enterprise. 

If your partner uses FILE and a transporting Gateway to send EDI documents back to 
you through a VAN, you need to configure FTP transport. You must use FTP to get your 
partner’s documents from the VAN Gateway site. This is because a VAN receives 
documents for multiple trading partners, but does not forward those documents to the 
recipients.

SSHFTP See TIBCO BusinessConnect Trading Partner Administration, Chapter 15, SSHFTP 
Transport.
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Scheduled Transmission Tab

Use the Scheduled Transmission tab to specify when transactions should be transmitted 
to this trading partner. 

By default, transactions are transmitted to your trading partners immediately after they are 
processed by TIBCO BusinessConnect EDI Protocol powered by Instream. Using the 
options in the Scheduled Transmission tab, transactions can be scheduled to be sent:

• Only during a specified time period

• Only on certain days of the week

• Only on certain dates

If you use this tab to control when messages are transmitted, you can use the Log Viewer 
to view, submit manually, and delete queued messages. 

See TIBCO BusinessConnect EDI Protocol powered by Instream User’s Guide, Chapter 7, 
"Viewing Logs."

Table 17   Configuring Business Agreement: Scheduled Transmission Tab

Field Description

Enable Default is unchecked. 

Transmission 
Mode

The type of the transmission schedule: Everyday, Day of the Week, Specific Dates. The 
selection determines which of the other fields on the tab are used. 

Start Time Defines the start of the transmission window.

End Time Defines the end of the transmission window.

Days of the Week The days of the week that messages will be transmitted. Used when the mode is Day of 
the Week.

Frequency The wait time between transmissions within the transmission window. 
BusinessConnect sends the first set of transmissions at the scheduled transmission start 
time and waits for the time specified in the Frequency field before sending the next set 
of transmissions. It continues sending transmissions at regular intervals based on the 
value in the Frequency field until the transmission window closes. 

For example, if the start time is 9 AM. and the frequency is Every 30 minutes, then the 
first transmission will occur at 9 AM., the next transmission will occur at 9:30 AM., 
and so forth. This is not used for batched transmissions.
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Transaction 
Count Threshold

This value is always 1. 

TEXT transmissions can only be scheduled; they cannot be batched.

Scheduled Dates List of dates when transmission occurs (if transmission mode is Specific Dates).

Table 17   Configuring Business Agreement: Scheduled Transmission Tab (Cont’d)

Field Description
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Overriding Participant Settings

Use the participant configuration tabs to override the general settings for a participant per 
agreement protocol binding. 

Hide Advanced

To hide the participant configuration tabs and skip overriding the participant settings, click 
the Hide Advanced button.

Show Advanced

To use the participant configuration tabs, click the Show Advanced button. 

The Configuration GUI displays two tabs labeled ParticipantA’s Configuration and 
ParticipantB’s Configuration, where ParticipantA and ParticipantB are the participants in 
the business agreement for which you are overriding the settings. 

To override a general setting, perform the following steps:

1. Click a participant configuration tab.

2. Select the Override Settings check box.

3. The available settings are the same as those specified for the host in General Tab on 
page 57, or the trading partner in General Tab on page 63. Modify the desired setting.

4. Click Save twice.
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Chapter 7 Type Detection

This chapter explains the criteria used by the Instream engine to identify or detect an entry 
in the file FlatFileInitialDetector.csv.

Topics

• Identifying and Detecting Entries in FlatFileInitialDetector.csv, page 84
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Identifying and Detecting Entries in FlatFileInitialDetector.csv

The FlatFileInitialDetector.csv file is available in the directory BC_HOME/protocols/tibedi/config. It 
is used for TEXT data validation, which includes Flat file support for Delimited and Fixed 
length using the EDISIM Flat file guideline support.

Identification and initial detection of key fields and other fields is performed by the 
Instream engine using the file FlatFileInitialDetector.csv and is based on the set criteria. 
Delimiters configured in this file must be in hex format (such as 0x27). The values 
described in the "Value Required" column are the values taken from the file 
FlatFileInitialDetector.csv to show the usage as an example.

Table 18   Identification and Initial Detection of Fields in the File FlatFileInitialDetector.csv

Column Name Syntax Value Required Description

FileType F<HeaderLength RecordDelimiter> Yes Fixed length files

D<ElementDelimiter SegmentDelimiter> Delimited text files

Key <StartPosition RecordLength Key Value> 

(Value must be specified)

Yes. For example,

<1 2 Key S1> where S1 is the 
key value

For Fixed length files

<FieldNumber Key Value> (Value must be 

specified)

Yes. For example,

<1 Key POINBOUNDARV> 

where POINBOUNDARV is 
the key value.

For Delimited text files

messageGroup This identifies the message Group defined in the Operations Editor for TEXT

<startpositon,record length MessageGroup> Optional. For example,

<16 4 MessageGroup TEXT> 
where TEXT is an optional 
value.

For Fixed length files

<field number MessageGroup> Optional. For example,

<3 MessageGroup 

DELIMITED> DELIMITED is 
a value and is optional.

For Delimited text files
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messageType This identifies the message Type defined in the Operations Editor for TEXT

<startpositon,record length MessageType> Optional. For example,

<81 12 MessageType 

PEDIDOAUTEXT> where 
PEDIDOAUTEXT is an 
optional value.

For Fixed length files

<field number MessageType> Optional. For example,

<7 MessageType 

POINBOUNDARV> where 
POINBOUNDARV is the 
value.

For Delimited text files

Field{n} This can be any field defined in the header portion of the guideline, such as SenderId, 
SenderDomain, or ReceiverId, ReceiverDomain. 

See the FlatFileInitialDetector.csv for an example.

If MessageGroup, MessageType, SenderId, SenderDomain, ReceiverId, and ReceiverDomain are not 
contained in the TEXT data, you can set default values. If the value of start position or field 

number is -1, the following value is default value. 

For example: 

Fixed length file: <-1 0 MessageGroup TEXT>

Delimited text file: <-1 MessageGroup TEXT>

If spaces are included in the default values, use single quotation marks, such as 'ABC 123'.

Table 18   Identification and Initial Detection of Fields in the File FlatFileInitialDetector.csv (Cont’d)

Column Name Syntax Value Required Description
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