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Preface

TIBCO BusinessConnect™ EDI Protocol powered by Instream® is the TIBCO 
business-to-business (B2B) solution for transferring EDI documents between trading 
partners. This manual describes how to use the TRADACOMS protocol.

Topics

• Related Documentation, page xii

• Typographical Conventions, page xiv

• TIBCO Product Documentation and Support Services, page xvi
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Related Documentation

This section lists documentation resources you may find useful.

TIBCO BusinessConnect EDI Protocol powered by Instream Documentation

The following documents form the TIBCO BusinessConnect EDI Protocol powered by 
Instream documentation set:

• TIBCO BusinessConnect EDI Protocol powered by Instream Installation Read this 
manual to learn about installing and deploying TIBCO BusinessConnect EDI Protocol 
powered by Instream. 

• TIBCO BusinessConnect EDI Protocol powered by Instream User’s Guide Read this 
manual for instructions on using the product to configure all the EDI protocols.

• TIBCO BusinessConnect EDI Protocol powered by Instream EDIFACT 
Configuration Read this manual for instructions on configuring the EDIFACT 
protocol.

• TIBCO BusinessConnect EDI Protocol powered by Instream Gateway 
Configuration Read this manual for instructions on configuring the Gateway 
protocol.

• TIBCO BusinessConnect EDI Protocol powered by Instream Service 
Configuration Read this manual for instructions on configuring the Service protocol.

• TIBCO BusinessConnect EDI Protocol powered by Instream TEXT 
Configuration Read this manual for instructions on configuring the TEXT protocol.

• TIBCO BusinessConnect EDI Protocol powered by Instream TRADACOMS 
Configuration Read this manual for instructions on configuring the TRADACOMS 
protocol.

• TIBCO BusinessConnect EDI Protocol powered by Instream X12 Configuration Read 
this manual for instructions on configuring the X12 protocol.

• TIBCO BusinessConnect EDI Protocol powered by Instream Release Notes Read the 
release notes for a list of new and changed features. This document also contains lists 
of known issues and closed issues for this release.
TIBCO BusinessConnect EDI Protocol powered by Instream TRADACOMS Configuration



Preface | xiii
Other TIBCO Product Documentation

You may find it useful to read the documentation for the following TIBCO products:

• TIBCO ActiveMatrix BusinessWorks™

• TIBCO ActiveMatrix BusinessWorks™ Plug-in for BusinessConnect™

• TIBCO Administrator™

• TIBCO BusinessConnect™

• TIBCO BusinessConnect™ Palette

• TIBCO Business Studio™

• TIBCO Designer™
 TIBCO BusinessConnect EDI Protocol powered by Instream TRADACOMS Configuration



xiv | Typographical Conventions
Typographical Conventions

The following typographical conventions are used in this manual.

Table 1   General Typographical Conventions

Convention Use

ENV_HOME

TIBCO_HOME

TIBCO products are installed into an installation environment. A product installed into 
an installation environment does not access components in other installation 
environments. Incompatible products and multiple instances of the same product must be 
installed into different installation environments.

An installation environment consists of the following properties:

• Name Identifies the installation environment. This name is referenced in 
documentation as ENV_NAME. On Microsoft Windows, the name is appended to the 
name of Windows services created by the installer and is a component of the path to 
the product shortcut in the Windows Start > All Programs menu. 

• Path The folder into which the product is installed. This folder is referenced in 
documentation as TIBCO_HOME. 

TIBEDI_HOME TIBCO BusinessConnect EDI Protocol powered by Instream installs into a directory 
within a TIBCO_HOME. This directory is referenced in documentation as 
TIBEDI_HOME. The default value of TIBEDI_HOME depends on the operating system. 
For example, on Windows systems, the default value is C:\tibco\bc\version\protocols\tibedi.

code font Code font identifies commands, code examples, filenames, pathnames, and output 
displayed in a command window. For example:

Use MyCommand to start the foo process.

bold code font Bold code font is used in the following ways:

• In procedures, to indicate what a user types. For example: Type admin. 

• In large code samples, to indicate the parts of the sample that are of particular 
interest.

• In command syntax, to indicate the default parameter for a command. For example, 
if no parameter is specified, MyCommand is enabled: 
MyCommand [enable | disable]
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italic font Italic font is used in the following ways: 

• To indicate a document title. For example: See TIBCO BusinessConnect EDI 
Protocol powered by Instream Installation.

• To introduce new terms. For example: A portal page may contain several portlets. 
Portlets are mini-applications that run in a portal.

• To indicate a variable in a command or code syntax that you must replace. For 
example: MyCommand PathName.

Key 
combinations

Key names separated by a plus sign indicate keys pressed simultaneously. For example: 
Ctrl+C.

Key names separated by a comma and space indicate keys pressed one after the other. 
For example: Esc, Ctrl+Q.

The note icon indicates information that is of special interest or importance, for example, 
an additional action required only in certain circumstances.

The tip icon indicates an idea that could be useful, for example, a way to apply the 
information provided in the current section to achieve a specific result.

The warning icon indicates the potential for a damaging situation, for example, data loss 
or corruption if certain steps are taken or not taken.

Table 1   General Typographical Conventions (Cont’d)

Convention Use
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TIBCO Product Documentation and Support Services

For information about this product, you can read the documentation, contact TIBCO 
Support, or join TIBCO Community.

How to Access TIBCO Documentation

Documentation for TIBCO products is available on the TIBCO Product Documentation 
website mainly in the HTML and PDF formats.

The TIBCO Product Documentation website is updated frequently and is more current 
than any other documentation included with the product. To access the latest 
documentation, visit https://docs.tibco.com. 

Documentation for TIBCO BusinessConnect EDI Protocol powered by Instream is 
available on the 
https://docs.tibco.com/products/tibco-businessconnect-edi-protocol-powered-by-instream
Product Documentation page.

How to Contact TIBCO Support

You can contact TIBCO Support in the following ways:

• For an overview of TIBCO Support, and information about getting started with 
TIBCO Support, visit http://www.tibco.com/services/support

• For accessing the Support Knowledge Base and getting personalized content about 
products you are interested in, visit the TIBCO Support portal at 
https://support.tibco.com.

• For creating a Support case, you must have a valid maintenance or support contract 
with TIBCO. You also need a user name and password to log in to 
https://support.tibco.com. If you do not have a user name, you can request one by 
clicking Register on the website.

How to Join TIBCO Community

TIBCO Community is the official channel for TIBCO customers, partners, and 
employee subject matter experts to share and access their collective experience. 
TIBCO Community offers access to Q&A forums, product wikis, and best practices. It 
also offers access to extensions, adapters, solution accelerators, and tools that extend 
and enable customers to gain full value from TIBCO products. In addition, users can 
submit and vote on feature requests from within the TIBCO Ideas Portal. For a free 
registration, go to https://community.tibco.com.
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Chapter 1 TRADACOMS Overview

This chapter briefly describes the TRADACOMS standard and its use for electronic data 
interchange. 

Topics

• Product Overview, page 2

• TRADACOMS Messages, page 3
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Product Overview

EDI (Electronic Data Interchange) is the exchange of information between trading 
partners where the information is formatted according to a set of common data format 
standards developed in the U.S. and Western Europe during the late 1970s. EDI standards 
describe the format of the data that is to be exchanged. These standards are independent of 
the transport. 

TRADACOMS is a UK based standard, designed for domestic trade. The first 
TRADACOMS standard was released in 1982, a number of years before EDIFACT 
appeared. There are a few similarities between the two, but also some significant 
differences.

TRADACOMS to XML

For inbound transfers, TIBCO BusinessConnect EDI Protocol powered by Instream 
validates TRADACOMS data from the trading partner and converts it to XML data.

For outbound transfers, TIBCO BusinessConnect EDI Protocol powered by Instream 
converts XML data to the TRADACOMS format and sends it to trading partner, or 
directly sends TRADACOMS data to the trading partner.

Introducing “Allow All” for a Transmission Name

The trading partner lookup for TRADACOMS document is based on transmission 
code/name pair, which may not be preferable for users who connect to the same trading 
partner with a different transmission name. For example, a transmission name for one 
company subsidiary may have different transmission names for the same company, such 
as: ABC Inc., Abc Inc., and ABC INC. In some cases, there may be many instances of the 
different transmission names pointing to the same trading partner with one transmission 
code. In such situations, it becomes cumbersome for users to maintain information for 
their trading partners. TRADACOMS rules also define that when a transmission code is 
present and is matched, it can be used to identify the trading partner.

To help manage transmission names for trading partners, the concept of using an * 
(asterisk) field with the meaning of “allow all” has been introduced. It allows all 
transmission names for a single transmission code.
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TRADACOMS Messages

The TRADACOMS standard encompasses 26 messages. Each message is laid out in a 
hierarchical structure. Unlike EDIFACT, TRADACOMS does not use a single message 
format, but instead uses multiple messages. 

A single order message could comprise an Order Header Message (ORDHDR), multiple 
Orders Messages (ORDERS), Order Trailer Message (ORDTLR). Multiple individual order 
message can repeat between the ORDHDR and the ORDTLR. 

In the general case, a TRADACOMS transmission consists of:

• A Start of Transmission Segment (STX)

• One or more files

• A Reconciliation Message (RSGRSG)

• An End of Transmission Segment (END)

A TRADACOMS file consists of a series of messages. Each message has a similar overall 
structure, beginning with a Message Header Segment (MHD) and ending with a Message 
Trailer Segment (MTR). The contents, however, are different for each transaction type or 
File Format (for example, Orders, Invoices).
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Chapter 2 Tutorial — Getting Started

This chapter gives an overview of how to use TIBCO ActiveMatrix BusinessWorks with 
TIBCO BusinessConnect EDI Protocol powered by Instream. 

In this tutorial, you can configure trading partner information, configure a private process 
to communicate with TIBCO BusinessConnect EDI Protocol powered by Instreaml, and 
run the tutorial.

Topics

• Overview, page 6

• Prerequisites, page 7

• Using EDI Guidelines, page 8

• Configuring the Initiator, page 11

• Configuring the Responder, page 17

• Configuring Private Processes, page 22

• Running the Tutorial, page 27
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Overview

In this tutorial, you can use TIBCO ActiveMatrix BusinessWorks and TIBCO 
BusinessConnect EDI Protocol powered by Instream running on one machine to send a 
message to a trading partner. 

When you run the tutorial, the following steps occur:

1. TIBCO Designer/TIBCO Business Studio reads a file that contains the data for 
ORDHDR.

2. TIBCO Designer/TIBCO Business Studio sends the EDI data to TIBCO 
BusinessConnect EDI Protocol powered by Instream.

3. TIBCO BusinessConnect EDI Protocol powered by Instream sends the document to 
the trading partner using HTTP transport. 

The following sections describe how to set up and run the tutorial. The steps involved in 
setting up TIBCO BusinessConnect EDI Protocol powered by Instream to run the tutorial 
are the same steps that have been discussed in TIBCO BusinessConnect EDI Protocol 
powered by Instream User’s Guide, Managing EDI Guidelines and Setting Up Trading 
Hosts: 

• Trading Partner Setup

• TIBCO ActiveMatrix BusinessWorks Process Assembly
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Prerequisites

Before starting the tutorial, perform the following steps:

1. Install the following software packages:

a. TIBCO BusinessConnect (Server)

b. TIBCO BusinessConnect Palette or TIBCO ActiveMatrix BusinessWorks Plug-in 
for BusinessConnect

c. TIBCO Foresight® Instream® Standard Edition

d. TIBCO Foresight® Translator Standard Edition

e. TIBCO BusinessConnect EDI Protocol powered by Instream

2. If you are unfamiliar with the TRADACOMS standard, read Chapter 1, 
TRADACOMS Overview, on page 1.

3. See TIBCO BusinessConnect Interior Server Administration and the TIBCO 
BusinessConnect Trading Partner Administration for complete information on setting 
up and running TIBCO BusinessConnect.

4. Review "Setting Up Trading Partners" in TIBCO BusinessConnect EDI Protocol 
powered by Instream, User’s Guide.

5. Activate TIBCO BusinessConnect EDI Protocol powered by Instream.
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Using EDI Guidelines

The guidelines used for this tutorial is BC_HOME\protocols\tibedi\samples\ 

sampleDocs\guidelines\TRADACOMS_ORDHDR.std.

View the Guideline

To import a guideline:

1. Select EDISIM > Standards Editor.

2. Select File > Import > Import Single .SEF and Open.

3. Go to BC_HOME\protocols\tibedi\samples\sampleDocs\guidelines and select the file 
TRADACOMS_ORDHDR.std and click Open.

4. In the Import Standard dialog, keep or change the Standard name into which this 
guideline will be imported. For this tutorial, enter the standard name as 
TRADACOMS_ORDHDR and click OK.

Figure 1   Import a Standard

5. Click the + signs on the left to display the order guideline.
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Figure 2   Elements of the TRADACOMS Standard

Properties of each element are displayed in the Details View panel.

Load Guidelines to the TRADACOMS Protocol

This section describes how to load the guidelines and XSDs for the TEXT messages. 

TIBCO BusinessConnect EDI Protocol powered by Instream contains a sample 
configuration file for this tutorial. You will import the configuration file into the 
Operations Editor as follows: 

1. Using TIBCO Administrator, select BusinessConnect > Operations Editor.

2. In the Operations Editor dialog, click Import.

3. Click change.

4. Click Browse.

5. Select BC_HOME\protocols\tibedi\samples\interfaces\TRADACOMS.csx.

6. Click Open. 

7. Click OK.

8. Supply your password (optional) and click Import.
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Review the Guidelines

To review the guideline loaded for the TRADACOMS transaction: 

1. In the Operations Editor dialog, click the TRADACOMS link.

2. Click the top-most + to display all the TRADACOMS operations.

Figure 3   TRADACOMS OPERATIONS

3. Click the transaction link, such as ORDHDR.

4. Click the Guideline tab.

Notice that TRADACOMS_ORDHDR.std is displayed in the Transmission Guideline (.sef or 
.std) field. 

5. Click Save and Done.
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Configuring the Initiator 

This section steps you through the activities you need to perform to configure the host and 
trading partner on the Initiator machine.

To proceed with the tutorial, perform the following steps:

• Load Guidelines to the TRADACOMS Protocol, page 9

• Set Up a Host, page 11

• Deploy the Initiator Server, page 16

• Set Up a Partner, page 13

• Configure the Business Agreement, page 15

Set Up a Host

If this is the first time you are configuring a host on this machine after installing EDI 
protocols, follow these steps: 

1. Start Creating a New Trading Host, page 11

2. Set a Custom Transmission Code for the Host, page 12

3. Activate the Trading Host, page 13

Start Creating a New Trading Host

To create your trading host and set it as the default host, perform the following steps:

1. Click the BusinessConnect > Participants link in the left panel. 

2. Click the New button in the right panel.

3. Type Company1 in the Name field.

4. Select Host in the Type list.

5. Click OK. 

6. Click Apply.

Enable the TRADACOMS Protocol for the New Host

All EDI protocols are enabled by default after installation. In order to configure and 
activate any of the protocols, disable all other unconfigured protocols. Once the protocols 
are configured, they can be enabled or disabled at any time: this procedure is needed only 
when configuring protocols for the first time.
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If no protocols have been enabled:

1. Select the new Host and click the Protocols tab.

2. Select the check boxes next to EDI protocols other than TRADACOMS. 

3. Click Disable.

If enabling an additional protocol:

1. Click Enable.

2. Select the check box next to TRADACOMS.

3. Click OK and Save.

Set a Custom Transmission Code for the Host

1. Select BusinessConnect>SystemSettings>Metadata Type Configuration> 
Domains.

2. Click the New button.

3. Add the required name (5013546000000) and the description.

4. Click Save and Done.

5. Click BusinessConnect>Participants>Company1.

6. Select Protocols and Enable.

7. Select the check box next to TRADACOMS and click OK.

8. Select the TRADACOMS link.

9. In the Edit Enabled Protocol dialog, click the Add New link next to the Default 
Transmission Code Name field.

10. In the Transmission Code Name List dialog, click the Add New button.

11. In the Transmission Code list, select 5013546000000 (you may need to scroll through the 
list to find it).

12. In the Name field, type a name, such as TRANSMISSION SENDER.

13. Click Save.

14. Click OK.

15. In the Default Transmission Code Name list, select 5013546000000-TRANSMISSION 

SENDER.

16. Click Save.
TIBCO BusinessConnect EDI Protocol powered by Instream TRADACOMS Configuration
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Activate the Trading Host

1. Select BusinessConnect > Participants again.

Verify that the new host, Company 1, has the Domain Identity you defined in the step 
Set the Default Transmission Code and Name: 5013546000000-TRANSMISSION SENDER.

2. Click the Company1 link.

3. In the Edit Host Participant dialog, select the Active check box in the General tab.

4. Click Save. 

5. Select BusinessConnect > System Settings > General and verify that Company1 is 
selected as the default host. 

Set Up a Partner

The trading partner setup consists of these steps:

• Create a Partner, page 13

• Enable the TRADACOMS Protocol, page 14

• Set the Default Transmission Code and Name, page 14

• Set the Transport, page 15

Create a Partner 

To set up the trading partner, perform the following steps:

1. Click the BusinessConnect > Participants link in the left panel. 

2. Click the New button in the right panel.

3. Type  Company2 in the Name field.

4. Select Partner in the Type list.

5. Click OK.

6. Select the Active check box.

7. Click Save.

Company2 appears on the Participants list, with no identity defined. 

Saving of the trading host will succeed only if the protocol is properly configured: 
protocol is binded and a qualifier provided
 TIBCO BusinessConnect EDI Protocol powered by Instream TRADACOMS Configuration
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Enable the TRADACOMS Protocol

1. Click the Company2 link.

2. Click the Protocols tab.

3. Click the Enable button.

4. Select the TRADACOMS check box.

5. Click OK.

Set the Default Transmission Code and Name

1. Click the TRADACOMS link.

2. Click the Add New link next to the Default Transmission Code Name field.

3. In the Transmission Code Name List dialog, click the Add New button.

4. In the Transmission Code list, select 5013546000000.

5. In the Name field, type TRANSMISSION RECEIVER.

6. Click Save.

7. Click OK.

8. In the Default Transmission Code Name list, select 5013546000000-TRANSMISSION 

RECEIVER.

9. Click Save.

Enable Outbound EDI Validation

This feature allows users to either enable or disable outbound EDI validation.

To enable outbound EDI validation:

1. Click the TRADACOMS link.

2. In the Outbound area, select the Enable EDI Validation check box.

3. Click Save.

Set the Transport

To set the transport:

1. Click the TRADACOMS link.

2. Click the Transports tab.

3. Click the Add button.
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4. Select HTTP from the Type list.

5. Click OK.

6. In the URL field, type hostname:6700/TRADACOMS, where hostname is the name of the 
machine hosting the Responder trading partner, and 6700 is the HTTP port set in the 
deployment configuration on the Responder’s server.

7. Click Save three times.

Configure the Business Agreement 

1. Click the BusinessConnect > Business Agreements link in the left panel. 

2. Click the New button in the right panel.

3. Select the Company1 radio button in the Host Party area and the Company2 radio 
button in the Partner Party area.

4. Click OK.

5. In the New Agreement dialog, click the Add Protocol Binding button.

6. Select the TRADACOMS check box.

7. Click OK.

8. Click the TRADACOMS link.

9. Select the transports.

a. Click the Transports tab.

b. In the Outbound Transports for Host 'Company1' area, select HTTP from the 
Primary Transport list.

10. Click Save twice.

The new agreement between Company1 and Company2 with the enabled protocol 
TRADACOMS appears.

Deploy the Initiator Server

The Initiator server must be set up to communicate with its trading partners. To do so, 
follow these steps

• Create the deployment configuration. See TIBCO BusinessConnect Interior Server 
Administration for information on deployment configurations.

• Deploy BusinessConnect and start the server.
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Configuring the Responder 

This section steps you through the activities you need to perform to configure the host and 
trading partner on the Responder machine.

To proceed with the tutorial, perform the following steps:

• Load Guidelines to the TRADACOMS Protocol on page 9

• Set Up a Host, page 17

• Deploy the Responder Server, page 21

• Set Up a Trading Partner, page 19

• Configure the Business Agreement, page 21

Set Up a Host

If this is the first time you are configuring a host on this machine after installing EDI 
protocols, follow these steps: 

1. Start Creating a New Trading Host, page 17

2. Activate the Trading Host, page 18

Start Creating a New Trading Host

To create your trading host and set it as the default host, perform the following steps:

1. Click the BusinessConnect > Participants link in the left panel. 

2. Click the New button in the right panel.

3. Type Company2 in the Name field.

4. Select Host in the Type list.

5. Click OK. 

6. Click Apply.

If no protocols have been enabled:

1. Select the new Host and click the Protocols tab.

a. Select the check boxes next to EDI protocols other than TRADACOMS. 

b. Click Disable.
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If enabling an additional protocol:

a. Click Enable. 

b. Select the check box next to TRADACOMS and click OK.

Set a Custom Transmission Code for the Host

1. Select BusinessConnect > System Settings > Metadata Type Configuration > 
Domains.

2. Click the New button.

3. Add the required name (5013546000000) and the description.

4. Click Save and Done.

5. Click BusinessConnect > Participants > Company2.

6. Select Protocols and Enable.

7. Select the check box next to TRADACOMS and click OK.

8. Select the TRADACOMS link.

9. In the Edit Enabled Protocol dialog, click the Add New link next to the Default 
Transmission Code Name field.

10. In the Transmission Code Name List dialog, click the Add New button.

11. In the Transmission Code list, select 5013546000000 (you may need to scroll through the 
list to find it).

12. In the Name field type a name, such as TRANSMISSION RECEIVER.

13. Click Save.

14. Click OK.

15. In the Default Transmission Code Name list, select 5013546000000-TRANSMISSION 

RECIVER.

16. Click Save.

Activate the Trading Host

1. Select BusinessConnect > Participants again.

Verify that the new host, Company2, has the Domain Identity you defined in the step 
Set the Default Transmission Code and Name: 5013546000000-TRANSMISSION RECEIVER.

2. Click the Company2 link.

3. In the Edit Host Participant dialog, select the Active check box.
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4. Click Save. 

5. Select BusinessConnect > System Setting > General and verify that Company2 is 
selected as the default host. 

Set Up a Trading Partner

The Responder trading partner setup consists of these steps:

• Configure a Trading Partner, page 19

• Enable the TRADACOMS Protocol, page 19

• Set the Default Transmission Code and Name, page 20

• Set the Transport, page 20

Configure a Trading Partner 

To set up the Responder trading partner, perform the following steps:

1. Click the BusinessConnect > Participants link in the left panel. 

2. Click the New button in the right panel.

3. Type  Company1 in the Name field.

4. Select Partner in the Type list.

5. Click OK.

6. Select the Active check box.

7. Click Save.

Company1 appears on the Participants list, with no identity defined. 

Enable the TRADACOMS Protocol

1. Click the Company1 link.

2. Click the Protocols tab.

3. Click the Enable button.

4. Select the TRADACOMS check box.

5. Click OK.

Saving of the trading host will succeed only if the protocol is properly configured: 
protocol is binded and a qualifier provided
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Set the Default Transmission Code and Name

1. Click the TRADACOMS link.

2. Click the Add New link next to the Default Transmission Code Name field.

3. In the Transmission Code Name List dialog, click the Add New button.

4. In the Transmission Code list, select 5013546000000.

5. In the Name field, type TRANSMISSION SENDER.

6. Click Save.

7. Click OK.

8. In the Default Transmission Code Name list, select 5013546000000-TRANSMISSION 

SENDER.

9. Click Save.

Enable Outbound EDI Validation

This feature allows users to either enable or disable outbound EDI validation.

To enable outbound EDI validation:

1. Click the TRADACOMS link.

2. In the Outbound area, select the Enable EDI Validation check box.

3. Click Save.

Set the Transport

To set the transport:

1. Click the TRADACOMS link.

2. Click the Transports tab.

3. Click the Add button.

4. Select HTTP from the Type list.

5. Click OK.

6. In the URL field, type hostname:6700/TRADACOMS, where hostname is the name of the 
machine hosting the Responder trading partner, and 6700 is the HTTP port set in the 
deployment configuration on the Responder’s server.

7. Click Save three times.
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Configure the Business Agreement 

1. Click the BusinessConnect > Business Agreements link in the left panel. 

2. Click the New button in the right panel.

3. Select the Company2 radio button in the Host Party area and the Company1 radio 
button in the Partner Party area.

4. Click OK.

5. In the New Agreement dialog, click the Add Protocol Binding button.

6. Select the TRADACOMS check box.

7. Click OK.

8. Click the TRADACOMS link.

9. Select the transports.

a. Click the Transports tab.

b. In the Outbound Transports for Host 'Company2' area, select HTTP from the 
Primary Transport list.

c. In the Allowed Inbound Transports for Partner 'Company1' area, ensure that the 
HTTP check box is selected.

10. Click Save twice.

The new agreement between Company2 and Company1 with the enabled protocol 
TRADACOMS appears.

Deploy the Responder Server

The Responder server must be set up to communicate with its trading partners. To do so, 
follow these steps

• Create the deployment configuration. See TIBCO BusinessConnect Interior Server 
Administration for information on deployment configurations.

• Deploy BusinessConnect and start the server.
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Configuring Private Processes

TIBCO BusinessConnect EDI Protocol powered by Instream contains an example TIBCO 
ActiveMatrix BusinessWorks project which reads a TRADACOMS sample file and sends 
a TRADACOMS request. 

This section contains the following parts:

• Processes Overview, page 22

• Configuring Private Processes in TIBCO Designer, page 22

• Configuring Private Processes in TIBCO Business Studio, page 25

Processes Overview

The TRADACOMS project contains processes in three folders:

• EDI Inbound This folder contains the Receive TRADACOMS ORDHDR process. 
This process is activated when TIBCO BusinessConnect publishes a ResponderRequest 
message containing the XML document. 

• EDI Outbound This folder contains the Send TRADACOMS Request process, which 
reads a TRADACOMS sample file and send a TRADACOMS request.

• Error Advisories The EDI Error Advisories folder contains the Validation Error 
Advisory process which is activated when TIBCO BusinessConnect sends an advisory 
indicating that there was a validation error on the original message.

Configuring Private Processes in TIBCO Designer

To configure private processes in TIBCO Designer:

1. Opening the TIBCO ActiveMatrix BusinessWorks Project, page 23

2. Configuring Connections to BusinessConnect, page 24

Opening the TIBCO ActiveMatrix BusinessWorks Project

To open the example TIBCO ActiveMatrix BusinessWorks project in TIBCO Designer, 
perform the following steps:

Process names are different in TIBCO Designer and TIBCO Business Studio. For 
example, the Receive TRADACOMS ORDHDR process in TIBCO Designer equals the 
Receive_TRADACOMS_ORDHDR process in TIBCO Business Studio. The following description 
takes processes in TIBCO Designer as an example.
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1. Start TIBCO Designer and select New empty project.

2. In the Save Project dialog, click Cancel.

3. Select Project > Import Full Project.

4. Click the ZIP Archive tab. 

5. Navigate to BC_HOME\protocols\tibedi\samples\bw\TRADACOMS.

6. Select TRADACOMS.zip and click Open. 

7. Click OK. 

The Import - Options dialog appears.

8. In the Options tab, select the Try rename in case of name conflict radio button. 

9. Click Apply.

10. Select Project > Save As.

11. In the Project Directory file chooser, navigate to 
BC_HOME\protocols\tibedi\samples\bw\TRADACOMS.

12. Click OK.

13. When a dialog appears asking to use the directory as a project directory, click Yes. The 
zip archive file is deleted.

14. The window shown in  Figure 4 is displayed.
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Figure 4   TIBCO ActiveMatrix BusinessWorks Project

15. If you made any changes, save the project but do not exit TIBCO Designer.

Configuring Connections to BusinessConnect

To configure connections to BusinessConnect, perform the following steps:

1. Click the Project tab.

2. Expand the EDI Server Connections folder.

3. Click the BCServerConfigTradacoms.

4. Click the BusinessConnect Server Access tab and enter the following information for 
the Responder:

a. Select the JDBC driver you use to communicate with the BusinessConnect 
configuration store from the JDBC Driver list.

b. Type the URL for the configuration store in the JDBC URL field.

c. Type the configuration store user name and password in the DB User and DB 
Password fields.

d. Click the Apply button.

5. Click the Configuration tab.
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6. Click the Update from Configuration Store button.

7. Select TRADACOMS from the Protocol Name list.

8. Click the Import Selected Business Protocol button. When you import the protocol, 
TIBCO ActiveMatrix BusinessWorks retrieves schema information from the TIBCO 
BusinessConnect configuration store and puts it in the BCSchemas project folder. 

9. Click Apply.

10. Click the Save icon to save the project.

Configuring Private Processes in TIBCO Business Studio

To configure a private process in TIBCO Business Studio:

1. Opening the TIBCO ActiveMatrix BusinessWorks Project, page 25

2. Configuring Connections to TIBCO BusinessConnect, page 25

Opening the TIBCO ActiveMatrix BusinessWorks Project

To open the TIBCO ActiveMatrix BusinessWorks project in TIBCO Business Studio:

1. Start TIBCO Business Studio.

2. Click File > Import. 

3. On the Import page, expand the General folder and select Existing Studio Projects 
into Workspace. Click Next. 

4. Click Browse next to the Select archive file field to navigate to the 
BC_HOME/protocols/tibedi/samples/bw/TRADACOMS directory, and select the 
TRADACOMS_for_bw6.zip file. Click Open.

5. Click Finish.

After importing the sample, you also need to perform the following steps:

1. Expand TRADACOMS > Module Descriptors in the Project Explorer view.

2. Double-click Module Properties.

3. Change the default values of the BCHome, TPName, and DataFile properties according to 
your environment.

Configuring Connections to TIBCO BusinessConnect

To configure connections to TIBCO BusinessConnect:

1. In the Project Explorer view, expand Resources and double-click 
BCServerConfigTradacoms.bcResource.
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2. Click the Server Access tab.

3. Enter information as explained in step 4.

4. Click the Configuration tab, and click Update from Configuration Store.

5. Select TRADACOMS from the Protocol Name list.

If you select the Select Operations check box, you can select any of the 
configured/imported operations. For this tutorial, select all operations and click OK.

6. Click Import Selected Business Protocol. 

When you import the protocol, TIBCO ActiveMatrix BusinessWorks retrieves 
information from the TIBCO BusinessConnect configuration store and puts them in 
the project folder.

7. Click Save.
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Running the Tutorial

To run the tutorial, follow these steps:

1. Set the Input Data on the Initiator, page 27.

2. Send an Outbound TRADACOMS Message, page 27

3. Receive TRADACOMS ORDHDR, page 28.

4. Start the Receive TRADACOMS - ORDHDR Process on the Responder, page 28

5. Check the results of sending the message in Expected Results, page 29.

6. At the end, look at the logs in the section View the Audit Log on page 29.

Set the Input Data on the Initiator

1. Expand the TRADACOMS > EDI Outbound folder.

2. Select the process Send TRADACOMS Request and press the F12 key.

3. Type the following input data:

BCHOME: BC_HOME , such as C:\tibco\bc\version

DataFile: tradacoms.ordhdr.dat 

TPName: Company2

4. Click OK.

Send an Outbound TRADACOMS Message

This process does the following:

• Reads a TRADACOMS sample file

• Sends a TRADACOMS request

The steps of how to load and run private processes in TIBCO Business Studio are similar 
to TIBCO Designer. See TIBCO ActiveMatrix BusinessWorks Documentation for more 
details.
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Figure 5   Send TRADACOMS Request

Receive TRADACOMS ORDHDR 

The Receive TRADACOMS - ORDHDR process is shown in Figure 6. This process does 
the following:

• Receives the TRADACOMS request and send a notification

Figure 6   Receive TRADACOMS - ORDHDR Process

Start the Receive TRADACOMS - ORDHDR Process on the Responder

To start the process:

1. Click the Tester tab.

2. Click Start testing viewed process .

3. Select the EDI Inbound > Receive TRADACOMS - ORDHDR check box.

4. Click Load Selected.
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Expected Results

On the Initiator Side

Once the TRADACOMS data is received by TIBCO BusinessConnect EDI Protocol 
powered by Instream:

1. TIBCO BusinessConnect EDI Protocol powered by Instream validates the 
TRADACOMS data.

2. The TRADACOMS message is sent to trading partner using HTTP transport.

The activity of the Receive process should contain output that indicates it received the 
message from the trading partner.

The audit log should contain entries that for each processing state that occurred in TIBCO 
BusinessConnect. See View the Audit Log.

View the Audit Log

To view the audit log on the Initiator machine, perform the following steps:

1. Using TIBCO Administrator, click the BusinessConnect > Log Viewer link in the 
left panel.

2. Click the TRADACOMS link in the right panel.

3. Select items from the following lists: Status, Connection, and Date Range.

4. Click Search.

5. Click the Details icon  in the Search Results area for a specific operation to view 
details of the transaction.

6. Repeat the steps 1-5 on the Responder machine.

Compare the audit log entries on your Initiator in Figure 7 and on the Responder in 
Figure 9, and the figures contain a detailed successful transaction for the Initiator and 
Responder.
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Figure 7   Initiator Transaction Details

Figure 8   Responder Transaction 
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Figure 9   Responder Transaction Details

Figure 10   Responder Transaction Details II
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Chapter 3 Managing Syntax Rules Identifiers and 
Transmissions

This chapter describes how to use the Operations Editor to manage syntax rules identifiers 
and transmissions for TRADACOMS.

Topics

• Overview, page 34

• Adding a Syntax Rules Identifier, page 35

• Adding a Transmission to a Syntax Rules Identifier, page 36

• Importing and Exporting Syntax Rules Identifiers, page 38
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Overview 

TIBCO BusinessConnect EDI Protocol powered by Instream TRADACOMS Protocol 
uses syntax rules identifiers to organize transmissions. A transmission might be ORDRSP, 
which is an order response. 

Each transmission defines an action and its related communication parameters. For 
example, the definition of a transmission would include the following:

• The transmission description and transmission type

• The guidelines used by the transmission

You later use the transmission when you set up communications with your trading 
partners. 
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Adding a Syntax Rules Identifier

Before you can create new transmissions, you must create a syntax rules identifier. To add 
a syntax rules identifier, perform the following steps:

1. Click the BusinessConnect > Operations Editor link in the left panel. 

2. Click the TRADACOMS link.

3. Click New STDS - Syntax Rules Identifier.

4. In the Name field, enter a name that corresponds to the TRADACOMS syntax 
version.

5. Click Save.
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Adding a Transmission to a Syntax Rules Identifier

To add a transmission to a syntax rules identifier, perform the following steps:

1. Click the radio button next to a syntax rules identifier.

2. Click New Transmission. 

The Operation Type list appears with APRF-Application Reference selected. 

3. Click OK.

Configure the Transmission

To configure the transmission, enter information into the following tabs, then click Save:

• General Tab, page 36

• Guideline Tab, page 37

• Schema Tab, page 37

General Tab

Table 2   General Tab

Field Description

Name Name for the transmission

Description Description for the transmission

Inbound
Raw EDI Segments

Include in Private 
Process Request

If unchecked, when an EDI document arrives, TIBCO BusinessConnect sends an XML 
form of the transaction to the private process for every transaction. If checked, each 
TIBCO Rendezvous/JMS message also contains the following:

The raw EDI of the messages with the transmission (for TRADACOMS, all message 
segments between the STX/END transmission header and the trailer). The raw EDI for 
the transmission header and trailer (STX/END)

Extra 
Transmission 
Info

Optional inbound routing information that the private process can use to route this kind 
of message. Note that a partner-level routing field is also available. See General Tab on 
page 41.
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Guideline Tab

Schema Tab

Table 3   Guideline Tab

Field Description

Transmission Guideline 
(.sef or .std)

This field shows the current message guideline. It allows you also to 
change/add or to remove the existing message guideline.

Load a guideline file, such as TRADACOMS_ORDHDR.std.

Validator Profile file (.apf) This field shows the current validator profile file (the default is no file). It 
allows you also to change/add or to remove the existing validator profile file.

Table 4   Schema Tab

Field Description

Transmission Schema (.xsd) Load a transmission schema, such as TRADACOMS_ORDHDR.xsd.

Request Root Element 
Name

Enter the name of the root element.

Transmission to XML 
translation Map file (.map)

Load a map file, such as TRADACOMS_ORDHDR_EX.map.

XML to Transmission 
translation Map file (.map)

Load a map file, such as TRADACOMS_ORDHDR_XE.map.
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Importing and Exporting Syntax Rules Identifiers

Import a Syntax Rule Identifier

To import a syntax rules identifier, perform the following steps:

1. Click the BusinessConnect > Operations Editor link in the left panel. 

2. Click Import.

3. Click change.

4. Click Browse..

5. Navigate to BC_HOME\protocols\tibedi\samples\interfaces and select one of the sample 
message groups for TRADACOMS. Example: TRADACOMS.csx. 

6. Click Open.

7. Click OK.

8. Enter a password (optional).

9. Click Import and Done.

Export all Syntax Rules Identifiers

To export syntax rules identifiers, perform the following steps:

1. Click the BusinessConnect > Operations Editor link in the left panel. 

2. Select the TRADACOMS link.

3. In the Edit Operations: TRADACOMS dialog, click the topmost plus (+) sign to 
display all TRADACOMS syntax rules identifiers and transmissions.

Select the radio button next to the syntax rule identifier or transmission you wish to 
export.

4. Click Export XXX, where XXX is STDS-Syntax Rules Identifier or Transmission, 
depending on what you selected in the previous step.

5. Set a password (optional), and click Export Data.

6. The Save As dialog displays with operations.csx as the suggested file name.

7. Click Done.
TIBCO BusinessConnect EDI Protocol powered by Instream TRADACOMS Configuration



| 37
Chapter 4 Setting Up Trading Hosts

This chapter describes setting up trading hosts in TIBCO BusinessConnect EDI Protocol 
powered by Instream for the TRADACOMS protocol.

Topics

• Configuring the TRADACOMS Protocol, page 40

• General Tab, page 41

• Preprocessing Tab, page 42

• Logging Tab, page 43

• Advanced Tab, page 44
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Configuring the TRADACOMS Protocol

To enable the TRADACOMS protocol:

1. Click the BusinessConnect > Participants link in the left panel. 

2. Click a host participant link in the right panel.

3. Click the Protocols tab.

4. If TRADACOMS does not appear in the list of protocols:

a. Click Enable.

b. Select the TRADACOMS check box.

c. Click OK.

5. Click the TRADACOMS link. 

The following configuration options are available:

— General Tab, page 41.

— Preprocessing Tab, page 42.

— Logging Tab, page 43.

— Advanced Tab, page 44.

6. Click Save.
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General Tab

Use the General tab to set host general properties for TRADACOMS.

Table 5   General Fields

Field Description

Default 
Transmission 
Code Name 

The transmission code and name to use for this trading host. 

For outbound documents, the code and name will be specified as the sender code and 
name. For inbound documents, the code and name will be matched against the values 
of this field to ensure that the inbound document was intended for this host.

Add a Default Transmission Code Name

To add a default transmission code and name:

1. Click the Add New link.

2. Click the Add New button.

Select a transmission code from the Transmission Code list. This is mapped to the 
transmission code used by the host; for example, specify 1 for a D-U-N-S number. 
For outbound documents, the transmission code is validated and converted in case 
of XML-EDI conversion when sending it to the partner.

3. Enter the mandatory name for the partner in the Name field. For example, 
123456789 is the fictitious D-U-N-S number used in the tutorial. For outbound 
documents, the name is validated and converted in case of XML to EDI conversion 
when sending it to the partner. Either code or name must be present. Both cannot be 
null.

4. Click Save and OK.

AS2 Identifier The identifier to use in the AS2-To header field of the HTTP message, which should be 
mutually agreed upon between trading partners. This identifier can be an interchange 
ID. This only applies when using AS1 or AS2 transport.

Valid Email 
Address List

The identifier to use in the From header field of the SMTP MIME message. This email 
address list can be a list of email addresses. For an outbound document sent to the 
trading partner through SMTP transport, the first email address is used in the From 
header. For incoming email from the mail server, the To email address from the email is 
matched to one of the email addresses in this list. This only applies when using AS1 or 
AS2 transport.
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Preprocessing Tab

Use the Preprocessing tab to configure preprocessing for inbound and outbound 
TRADACOMS documents. 

Preprocessing is necessary if the TRADACOMS documents you exchange with your 
trading partner are formatted in any way. For example, you need to preprocess if the 
TRADACOMS document is blocked at 80 characters per line.

Table 6   Preprocessing Fields

Field Description

Inbound and Outbound

Characters To 
Strip

Specifies formatting characters that you want to strip from outbound and inbound EDI 
files. This allows you to convert outbound and inbound EDI files with unnecessary 
formatting into valid EDI files.

Strip Chars 
Between 
Segments 
Boundaries

Will cause any extraneous characters between segments to be removed from the EDI file 
regardless of what has been specified in the Characters To Strip field. 

Characters To Strip must also be used if the EDI document has been blocked into lines 
of equal length because blocked documents will contain carriage returns inside of 
segments. Strip Chars Between Segment Boundaries only works between segments. 
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Logging Tab

Use the Logging tab to configure EDI-specific logging options available with TIBCO 
BusinessConnect EDI Protocol. 

For further information, see TIBCO BusinessConnect EDI Protocol User’s Guide, 
"Document Archiving."

Table 7   Logging Fields

Field Description

Inbound

Log Raw EDI 
Request to File

For inbound documents, log the original, intact, and unconverted EDI document.

Store Location The original inbound EDI documents are stored in a directory whose name is 
derived from the specified location.

For information on how the files are named, see TIBCO BusinessConnect EDI 
Protocol powered by Instream User’s Guide, "Document Archiving."

Include Date Folder Creates a file reference in a folder created based on the current date.

Outbound

Log Raw EDI 
Request to File

Log the original, intact and unconverted EDI documents.

Store Location The original outbound EDI documents are stored in a directory whose name is 
derived from the specified location. 

For information on how the files are named, see TIBCO BusinessConnect EDI 
Protocol powered by Instream User’s Guide, "Document Archiving."

Include Date Folder If checked, the date folder is added to the document path. 

If unchecked, the date folder is omitted and the document is stored under the tpName 
directory.
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Advanced Tab

Use the Advanced tab to specify advanced settings for the handling of inbound and 
outbound XML documents.

Many of these properties impact memory usage, thereby impacting performance. Read the 
description for each field for information about memory tuning.

Table 8   Host Record Advanced Fields

Field Description

Inbound

Publish XML 
Request as File 
Reference

Write the converted XML to a file for each inbound transaction and publish the file 
reference in the requestFile attribute of the ResponderRequest message to the private 
process. Use of this option can decrease memory usage, improving performance. 
The Threshold property determines how large the XML must be before 
BusinessConnect writes the request to a file.

Threshold (bytes) Specify a file size in bytes. BusinessConnect writes XML requests that are this size 
and larger to a file and sends a reference to that file instead of the request itself. A 
value of 1000 is often appropriate. This can decrease memory usage within the EDI 
processing component, improving performance.

Include Date Folder If selected, the date folder is added to the document path. 

If cleared, the date folder is omitted and the document is stored under the tpName 
directory.

Store Location An existing directory under the TIBCO installation directory. Within this directory, 
BusinessConnect creates an In and an Out directory for inbound and outbound XML 
files. BusinessConnect stores the XML files in a subdirectory named for the trading 
partner.

Example: Store Location = XML_Request, trading partner name = Addis Coffee 
Haven

BusinessConnect stores the documents in /tibco/bc/XML_Request/In/AddisCoffeeHaven or

/tibco/bc/XML_Request/Out/AddisCoffeeHaven

If this field is empty or the directory specified is not valid, BusinessConnect behaves 
as if Publish XML Request as File Reference is not selected; it does not store a file; it sends the 
XML request.
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Output XML 
Request in UTF-8 
and Remove Empty 
Elements

Select this check box to instruct BusinessConnect to perform these tasks:

• Convert the XML that is in UTF-16 format to UTF-8. 

• Delete XML elements in the request that contain no values. This reduces the file 
size. Reducing the request size is especially important when you are using the 
XML for back-end processing.

Note: Converting the XML from UTF-16 to UTF-8 in this way increases memory 
usage. Consider converting the XML to UTF-8 in a separate JVM process instead of 
using this option.

Audit Report Logging

Audit Report 
Location

Location for saving audit reports.

Include Date Folder Select this check box to include the date folder in an audit report.

Table 8   Host Record Advanced Fields (Cont’d)

Field Description
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Chapter 5 Setting Up Trading Partners

This chapter describes setting up trading partners for TRADACOMS. 

Topics

• Configuring the TRADACOMS Protocol for a Partner, page 48

• General Tab, page 49

• Logging Tab, page 53

• Control Numbers Tab, page 54

• Transports Tab, page 55
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Configuring the TRADACOMS Protocol for a Partner

To configure the TRADACOMS protocol:

1. Click the BusinessConnect > Participants link in the left panel. 

2. Click a partner participant link in the right panel.

3. Click the Protocols tab.

4. If TRADACOMS does not appear in the list of protocols:

a. Click Enable.

b. Select the TRADACOMS check box.

c. Click OK.

5. Click the TRADACOMS link. The following configuration options are available:

— General Tab, page 49

— Logging Tab, page 53

— Control Numbers Tab, page 54

— Transports Tab, page 55
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General Tab

To configure the General tab and set the partner general properties for TRADACOMS use 
Table 9.

Table 9   Setting Up a Partner: General Tab (Sheet 1 of 4)

Field Description

Default 
Transmission 
Code Name

The transmission code name to use for this trading partner. 

For outbound documents, the transmission code name will be specified as the receiver 
transmission code name. For inbound documents, the transmission code name is used to 
identify the sender.

Add a Default Transmission Code Name

To add a default transmission code name:

1. Click the Add New link associated with the Default Transmission Code Name.

2. Click the Add New button.

3. Select a transmission code from the Transmission Code list. This is mapped to the 
transmission code used by the host. For example, specify 1 for a D-U-N-S number. 

4. Enter the mandatory name for the partner in the Name field. For example, 
123456789 is the fictitious D-U-N-S number used in the tutorial. 

5. Click Save.

AS2 Identifier The identifier to use in the AS2-To header field of the HTTP message. This identifier 
should be mutually agreed upon between trading partners. This identifier can be an 
interchange ID. This only applies when using AS2 transport.

Valid Email 
Address List

The email address that is used to match against incoming email from the mail server. If 
the incoming email From address matches to any email address in this list, then this 
trading partner is picked as the receiving party. This only applies when using AS1 or 
AS2 transport.

Inbound

Enable EDI 
Validation

Validate inbound EDI documents before TIBCO BusinessConnect EDI Protocol 
powered by Instream converts and forwards them to the private process. This involves 
using the guidelines configured in the configuration store to validate inbound EDI data.
 TIBCO BusinessConnect EDI Protocol powered by Instream TRADACOMS Configuration



48 | Chapter 5  Setting Up Trading Partners
Disable EDI to 
XML Conversion

Disable EDI to XML conversion of inbound documents. Validation of inbound 
TRADACOMS documents might still occur depending on the setting above. However 
the XML corresponding to the inbound TRADACOMS data will not be generated.

When EDI to XML conversion is disabled, the ResponderRequest message is still sent to the 
private process. However the request attribute of the ResponderRequest message is not 
populated.

This option should be used when XML conversion of the EDI data is not required. 
Using this option reduces memory usage and improves performance.

Enable 
Transaction 
Duplicate 
Detection

Enable checking for duplicate inbound transactions. 

By default, the duplicate detection for inbound transaction is disabled.

When this check box is selected, all inbound transactions that are received from the 
trading partner are checked to see if a duplicate has been received and appropriately 
marked in the RESPONDER.REQUEST PP message. The duplicate attribute in ResponderRequest 
is marked as true if the same message is received from the trading partner.

TRADACOMS has the following attributes: Trading Partner Name, operationID, 
transactionName, whole transaction, host initiates flag, interchange control number.

Extra Info in 
Private Process 
Request 

Data included in the message to the private process for each message received from this 
trading partner. For example, you could use this field to pass routing information based 
upon the trading partner. 

Enable 
Interchange 
Complete 
Message

Selecting this option causes the BusinessConnect engine to send a RVCM or a JMS 
queue message to the private process after the interchange processing is completed.

Enable Audit 
Report Logging

When checked, enables audit report logging for the complete inbound interchanges.

Table 9   Setting Up a Partner: General Tab (Sheet 2 of 4)

Field Description
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Inbound EDI 
Data Encoding

Specify the type of encoding for inbound EDI data.

• If inbound EDI data contains the BOM header, such as UTF-8 and UTF-16 
encoding, TIBCO BusinessConnect EDI Protocol powered by Instream gets the 
encoding from the BOM header regardless of what value you set in this field.

• If inbound EDI data does not contain the BOM header, such as ISO-8859-1 and 
US-ASCII encoding, TIBCO BusinessConnect EDI Protocol powered by Instream 
checks whether the value in this field is set.

— If you set a value in this field, TIBCO BusinessConnect EDI Protocol powered 
by Instream uses the specified encoding type to process inbound EDI data.

— If no value is set in this field, TIBCO BusinessConnect EDI Protocol powered by 
Instream uses the system encoding of the TIBCO BusinessConnect Interior 
Server engine to process inbound EDI data.

Outbound

Enable EDI 
validation 

If selected, validates the XML against guidelines.

The default is disabled (check box is cleared).

When this option is enabled, the following will happen:

For the XML payload sent from private processes, only transaction values are validated 
and the envelope information is not validated. 

For EDI payload sent from private processes, the whole EDI document (with envelope) 
is validated.

Transaction 
Level Duplicate 
Detection

Indicate how duplicate documents from private processes should be handled:

• None No outbound duplicate detection is performed.

• Allow to TP If a duplicate document is sent from the private process, then the 
message would be marked as duplicate and returned to the private process through 
an attribute in the InitiatorResponse message. The message is sent to the trading partner.

• Deny to TP If a duplicate document is sent from the private process, then the 
message would be marked as duplicate and returned to the private process through 
an attribute in the InitiatorResponse message. The message is not sent to the trading 
partner.

Table 9   Setting Up a Partner: General Tab (Sheet 3 of 4)

Field Description
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Outbound XML 
to EDI Data 
Encoding *

Specify the type of encoding for outbound XML to EDI data.

This field is required.

The default value is US-ASCII.

Table 9   Setting Up a Partner: General Tab (Sheet 4 of 4)

Field Description
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Logging Tab

Use the Logging tab to configure EDI-specific logging options available with TIBCO 
BusinessConnect EDI Protocol powered by Instream.

Table 10   Logging Fields

Field Description

Inbound
Transmission Level

Log Raw EDI 
Segments to File

Default is unchecked.

Store each raw inbound TRADACOMS document to the specified Store Location.

Store Location The original inbound EDI documents are stored in a directory whose name is derived 
from the specified location. 
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Control Numbers Tab

Use the Control Numbers tab to specify settings which affect the validation or generation 
of control numbers for this trading partner. 

The outbound settings affect the generation of control numbers to be included in 
documents sent to this trading partner.

For more information on control numbers, see TIBCO BusinessConnect EDI Protocol 
powered by Instream, User’s Guide, "Control Number Management."

Table 11   Control Numbers Fields

Field Description

Outbound

Transmission Control 
Number Seed

The transmission control number starting point.

Reset on Save Force recycling of control numbers on demand. This applies to control numbers for 
inbound and outbound. On outbound documents, the resetting of the control 
numbers would force the outbound control numbers for a trading partner to start 
from the seeding value again before reaching the ending value. As a result, the 
control number of the next outbound document would be generated based on the 
seeding value.
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Transports Tab

Use the Transports tab to configure outbound transport settings for this trading partner. 

To add an outbound transport, click Add in the Transports tab. The following transports 
are available for use with this protocol:

• HTTP

• FTP/S

• FILE

• AS2-HTTP/S

• AS1-EMAIL

• EMAIL

• SSHFTP

• Inbox

Inbox option is available in order to allow for document exchange between partners 
running TIBCO BusinessConnect EDI Protocol powered by Instream and one of these 
products: 

— TIBCO BusinessConnect Plug-in for SSH Server

— TIBCO BusinessConnect Plug-in for FTP Server

— TIBCO PartnerExpress

For more information, see TIBCO BusinessConnect EDI Protocol powered by 
Instream, User’s Guide, "Set Up Trading Partner Transport via Inbox."

The steps required for configuring transports are the same for all protocols. Refer to the 
Transports chapters in TIBCO BusinessConnect Trading Partner Administration Guide.

The transports you configure serve as the default transports for all business agreements 
associated with this partner. You can override the default transport settings as part of the 
business agreement. 
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Chapter 6 Configuring Agreement Protocol Bindings

This chapter explains how to configure protocol bindings for business agreements.

Topics

• Overview, page 58

• Operation Bindings, page 59

• Document Security Tab, page 63

• Transports Tab, page 65

• Scheduled Transmission Tab, page 68

• Overriding Participant Settings, page 70
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Overview

An agreement protocol binding is contained within a business agreement. For information 
on business agreements, see TIBCO BusinessConnect Trading Partner Administration.

Add Protocol Binding

To add an agreement protocol binding:

1. Click the BusinessConnect > Business Agreements link in the left panel. 

2. Click a business agreement link in the right panel.

3. Click the Add Protocol Bindings button. 

4. Check TRADACOMS.

5. Click OK. 

6. Click the TRADACOMS agreement protocol binding link. 

The following configuration options are available:

— Operation Bindings on page 59

— Document Security Tab on page 63

— Transports Tab on page 65

— Scheduled Transmission Tab on page 68

— Overriding Participant Settings on page 70
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Operation Bindings

Use the Operation Bindings tab to configure the TRADACOMS transactions that each 
participant in a business agreement can initiate and respond to.

The following properties apply to all the transactions that you import in the Operations 
Editor:

• Allow All Operations Enables participants to initiate all operations configured in 
BusinessConnect. You can modify the behavior of one or more operations by binding 
the operations in the Host ’X’ Can Initiate and Partner ’Y’ Can Initiate areas. If 
unchecked, operations must be explicitly bound in the Host ’X’ Can Initiate and 
Partner ’Y’ Can Initiate areas. 

• Non Repudiation Logging Enables logging of all operations in the non-repudiation log.

Bind an Operation

The Host ’X’ Can Initiate area (where X is the host participant in the business agreement) 
lists the transactions that the host can initiate and the partner can respond to. The Partner 
’Y’ Can Initiate area (where Y is the partner participant in the business agreement) lists the 
transactions that the partner can initiate and the host can respond to. 

To bind a transaction in either area, perform the following steps:

1. Click Add Operation Bindings.

2. Click the topmost + to expand the transaction tree.

3. Check the transaction.

4. Click OK.
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Edit an Operation

To edit an TRADACOMS operation, click an operation binding link. 

The following options are available:

• Operation Settings Tab, page 60

• Transports Tab, page 61

Operation Settings Tab

To override the settings for a message, select the Override Operation Settings check box 
and then select one of the following from the drop-down list:

• General, to override the general settings for a TRADACOMS transmission.

• Guideline, to override the guideline settings for TRADACOMS transmission.

• Schema, to override the schema settings for TRADACOMS transmission.

General Option

Overrides the same settings made in the Operations Editor. 

See General Tab on page 36. 

Configurable options include the following:

When no guidelines are given for the operation binding with the Override Operation 
Settings enabled and with Allow all Operation check box selected, the guideline in the 
operations editor will take effect.

Table 12   Configuring Business Agreement: General Option

Field Description

Inbound
Raw EDI Segments

Include in Private 
Process Request

Default is unchecked.

When checked, overrides the same settings made in the Operations Editor. See General 
Tab on page 36.

Extra 
Transmission Info

Add information about the message type
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Guideline Option

Changing the settings in this dialog overrides all the same settings made in the Operations 
Editor. 

See Guideline Tab, page 37.

Schema Option

Changing the settings in this dialog overrides all the same settings made in the Operations 
Editor. 

Configurable options include the following:

Transports Tab

This tab is used for overriding of outbound transport settings:

Table 13   Configuring Business Agreement: Schema Option

Field Description

Transmission to XML 
translation Map file (.map)

Click change to overrides the same settings made in the Operations 
Editor. 

See Schema Tab on page 37.

XML to Transmission 
translation Map file (.map)

Click change to overrides the same settings made in the Operations 
Editor. 

See Schema Tab on page 37.

Table 14   Configuring Business Agreement: Transports Tab

Field Description

Override 
Transports

When checked, overrides the transports set in participant’s configuration.

Override Outbound Transports

Primary 
Transport

Select from the dropdown list:

• Current transport (such as HTTP, Email, AS1, AS2-HTTP, AS2-HTTPS, 
AS2HTTPSCA, FILE, FTP, FTPS, SSHFTP, or Inbox)

• None
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Backup 
Transport

Select from the dropdown list:

• Current transport (such as HTTP, Email, AS1, AS2-HTTP, AS2-HTTPS, 
AS2HTTPSCA, FILE, FTP, FTPS, SSHFTP, or Inbox)

• None

Table 14   Configuring Business Agreement: Transports Tab (Cont’d)

Field Description
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Document Security Tab

Use the Document Security tab to specify security information for trading partners. 

The keys and certificates selected in the tab are set in the host and partner participant’s 
Credentials tabs. See TIBCO BusinessConnect Trading Partner Administration Guide for 
information on how to set credentials. The properties listed in Table 15 can be set for 
inbound and outbound document exchange.

The document security settings you configure in the business agreement are the default 
values. You can override these values only for outbound documents.

Table 15   Document Security Fields

Field Description

Outbound Doc Exchange

Signing Key The key the host uses to sign a message in order to identify itself to a partner. The 
partner uses the host’s certificates file to authenticate the host by verifying the digital 
signature of the host.

Digest Algorithm The algorithm used to create the digest used for the signature.

Selection are: SHA1, MD5, SHA256,SHA384 and SHA512.

PGP Signing 
Private Key

The PGP key the host uses to sign a message in order to identify itself to a partner. 

PGP Hash 
Algorithm

The PGP algorithm used to create the digest to be used for digital signatures:

MD5, SHA1, RIPEMD160, MD2

Encryption Info Settings

Encryption 
Certificate

The certificates file the host uses to encrypt a document before sending it to the partner. 
The partner uses its own host key identity file to decrypt the document.

Encryption 
Algorithm

The algorithm used to encrypt documents.

PGP Encryption 
Public Key

The PGP public key the host uses to encrypt a document before sending it to the partner. 

PGP Encryption 
Algorithm

The PGP algorithm used to encrypt documents:

DES3, BLOWFISGH, CAST5, AES-128, AES-192, AES-256.
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Inbound Doc Exchange
Signing Info Settings

Verification 
Certificate

The partner identifies itself by signing a document with its own host identity file. The 
host uses this certificate to authenticate a partner by verifying the digital signature of the 
partner. You must obtain this certificate from the host in advance.

PGP Signing 
Verification 
Public Key

The host uses this PGP public key to authenticate a partner by verifying the digital 
signature of the partner.

Encryption Info Settings

Decryption Key The host uses part of the host key identity file to decrypt a document that the partner 
encrypted using the host’s certificates file.

PGP Decryption 
Private Key

The host uses this PGP private key to decrypt the document.

Table 15   Document Security Fields (Cont’d)

Field Description
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Transports Tab

Use the Transports tab to set transport information for a transporting Gateway. A 
transporting Gateway can be shared by multiple EDIFACT and X12 trading partners, 
while it is not supported for partners using the TEXT protocol.

The top section of the tab is used for selecting transports for the outbound, or host to 
trading partner, direction. The bottom section of the tab is used for selecting and 
configuring transports for the inbound, or trading partner to host, direction.

Set the Outbound Transport for the Host

Select an outbound primary and backup transport. The transports are configured in a 
trading partner Protocols > Transports tab. 

See Transports Tab, page 55.

Table 16   Outbound Transport for the Host

Field Description

Primary Transport See the Transports chapters in the TIBCO BusinessConnect Trading Partner 
Administration. 

Backup Transport TIBCO BusinessConnect EDI Protocol powered by Instream supports a backup 
outbound transport for sending XML files to the trading partner. This backup 
transport is used if the file could not be sent via the primary transport configured 
in the business agreement. Such situation may happen if the trading partner’s 
server is not available or has a wrong URL during the time the file is being sent: 
the file still needs to reach the server via some other means even after the primary 
transport retry was exhausted.

Backup transports are configured at the business agreement level and can be one 
of the supported BusinessConnect transports. The same rules apply for choosing a 
backup transport as for a primary transport.
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AS2 Async MDN 
Reply Transport

Same as for TIBCO BusinessConnect: select any of the configured transports. The 
settings from the specified AS2 MDN Async Reply Transport field are used for 
sending async MDN responses back to your trading partner. Configuring the AS2 
MDN Async Reply Transport is not necessary unless you would like to specify 
different values for the following HTTP transmission related settings: 

• Retry Count – default is 3

• Retry Interval – default is 60 seconds

• Socket Timeout – default is 300 seconds (5 minutes)

Any other settings specified in the AS2 MDN Async Reply Transport are ignored. 
The most common case for which you would specify this transport is when your 
trading partner is not acknowledging the receipt of your async MDNs within the 
default socket timeout period.

AS2 Async MDN 
Remote Server 
Certificate

Same as for TIBCO BusinessConnect.

The Remote Server Certificate for the AS2 HTTPS transport is a SSL certificate 
that should be used for encrypting the data sent using HTTPS. This dropdown list 
contains all of the certificates that have been configured for the Trading Partner. 
You can select the one that was configured to be used for SSL encryption.

Note The server certificate configuration is only required for Async MDNs via 
AS2 HTTPS transport. 

Client Authentication 
Identity for HTTPS, 
FTPS, HTTPSCA

Choose between the transport that was set up as Client Authentication Identity for 
HTTPS, FTPS, HTTPSCA, or None.

Client Authentication 
Identity for SSHFTP

Choose between the transport that was set up as Client Authentication Identity for 
SSHFTP, or None.

Table 16   Outbound Transport for the Host (Cont’d)

Field Description
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Set the Inbound Transport for the Host

What displays in this area depends on the transports that are selected in the Transport 
Type area of the Public Process Configuration tab. 

For further information, see the section on Deployment Configuration in the TIBCO 
BusinessConnect Trading Partner Administration.

Table 17   Inbound Transport Fields

Field Description

HTTP/S Allow HTTP/S connections from this partner directly or from a VAN. This also applies 
when the inbound connection is using the AS2 transport. 

HTTPSCA/AS2 See TIBCO BusinessConnect Trading Partner Administration, Chapter 11, HTTP, 
HTTPS, and HTTPSCA Transports.

FTP/S Allow the host to perform FTP/S connections with this partner. The host is the Initiator 
of the FTP process. Click Edit Settings to configure FTP/S. See TIBCO BusinessConnect 
Trading Partner Administration Guide for more information on how a host uses FTP.

EMAIL Allow email from this partner or from a VAN. This also applies when the inbound 
connection is using the AS1 transport. If your partner uses EMAIL and a transporting 
Gateway to send EDI documents back to you through a VAN, you need to configure the 
FTP transport. You must use FTP to get your partner’s documents from the VAN site. 
This is because a VAN receives documents for multiple trading partners, but does not 
forward those documents to the recipients.

FILE Allow FILE connections from this partner. FILE is normally used for file exchange 
within an enterprise. 

If your partner uses FILE and a transporting Gateway to send EDI documents back to 
you through a VAN, you need to configure FTP transport. You must use FTP to get your 
partner’s documents from the VAN Gateway site. This is because a VAN receives 
documents for multiple trading partners, but does not forward those documents to the 
recipients.

SSHFTP See TIBCO BusinessConnect Trading Partner Administration, Chapter 15, SSHFTP 
Transport.
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Scheduled Transmission Tab

Use the Scheduled Transmission tab to specify when transactions should be transmitted 
to this trading partner. By default, transactions are transmitted to your trading partners 
immediately after they are processed by BusinessConnect EDI Protocol. Using the options 
in the Scheduled Transmission tab, transactions can be scheduled to be sent:

• Only during a specified time period

• Only on certain days of the week

• Only on certain dates

If you use this tab to control when messages are transmitted, you can use the Log Viewer 
to view, submit manually, and delete queued messages.

See TIBCO BusinessConnect EDI Protocol powered by Instream User’s Guide, Chapter 7, 
"Viewing Logs."

Table 18   Scheduled Transmission Fields

Field Description

Enable Enable this configuration.

Mode of 
Transmission

The type of the transmission schedule: Everyday, Day of the Week, Specific Dates. The 
selection determines which of the other fields on the tab are used. 

Start Time Defines the start of the transmission window.

End Time Defines the end of the transmission window.

Days of the Week The days of the week that messages will be transmitted. Used when the transmission 
mode is Day of the Week.

Frequency The wait time between transmissions within the transmission window. 
BusinessConnect sends the first set of transmissions at the scheduled transmission start 
time and waits for the time specified in the Frequency field before sending the next set 
of transmissions. It continues sending transmissions at regular intervals based on the 
value in the Frequency field until the transmission window closes. 

For example, if the start time is 9 AM. and the frequency is every 30 minutes, then the 
first transmission will occur at 9 AM., the next transmission will occur at 9:30 AM., 
and so forth.

Transaction 
Count Threshold

This value is always 1. 

TRADACOMS transmissions can only be scheduled; they cannot be batched.
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Scheduled Dates List of dates when transmission occurs (if transmission mode is Specific Dates).

Table 18   Scheduled Transmission Fields (Cont’d)

Field Description
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Overriding Participant Settings

Use the participant configuration tabs to override the general settings for a participant per 
agreement protocol binding. 

Hide Advanced

To hide the participant configuration tabs and skip overriding the participant settings, click 
the Hide Advanced button.

Show Advanced

To use the participant configuration tabs, click the Show Advanced button. 

Configuration GUI displays two tabs labeled ParticipantA’s Configuration and 
ParticipantB’s Configuration, where ParticipantA and ParticipantB are the participants in 
the business agreement for which you are overriding the settings. 

To override a general setting, perform the following steps:

1. Click a participant configuration tab.

2. Select the Override Settings check box.

3. The available settings are the same as those specified for the host in General Tab on 
page 41 or the trading partner in General Tab on page 49. Modify the desired setting.

4. Click Save twice.
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