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TIBCO Documentation and Support Services

Documentation for this and other TIBCO products is available on the TIBCO Documentation site. This
site is updated more frequently than any documentation that might be included with the product. To
ensure that you are accessing the latest available help topics, visit:

https://docs.tibco.com

Product-Specific Documentation

Documentation for TIBCO products is not bundled with the software. Instead, it is available on the
TIBCO Documentation site. To directly access documentation for this product, double-click the
following file:

TIBCO_HOME/release_notes/TIB_bstudio-mdm_5.1.0_docinfo.html

where TIBCO_HOME is the top-level directory in which TIBCO products are installed. On Windows,
the default TIBCO_HOME is C:\tibco. On UNIX systems, the default TIBCO_HOME is /opt/tibco.

The following documents for this product can be found on the TIBCO Documentation site:

» TIBCO MDM Studio Release Notes

o TIBCO MDM Studio Installation Guide

o TIBCO MDM Studio Process Designer Tutorial

o TIBCO MDM Studio Process Designer User’s Guide

o TIBCO MDM Studio Repository Designer Tutorial

o TIBCO MDM Studio Repository Designer User’s Guide
« TIBCO MDM Studio Rulebase Designer Tutorial

o TIBCO MDM Studio Rulebase Designer User’s Guide

o TIBCO MDM Studio Ul Builder Tutorial

o TIBCO MDM Studio Ul Builder User’s Guide

How to Contact TIBCO Support

For comments or problems with this manual or the software it addresses, contact TIBCO Support:

e For an overview of TIBCO Support, and information about getting started with TIBCO Support,
visit this site:

http://www.tibco.com/services/support

» If you already have a valid maintenance or support contract, visit this site:
https://support.tibco.com
Entry to this site requires a user name and password. If you do not have a user name, you can

request one.

How to Join TIBCO Community

TIBCO Community is an online destination for TIBCO customers, partners, and resident experts. It is a
place to share and access the collective experience of the TIBCO community. TIBCO Community offers
forums, blogs, and access to a variety of resources including product wikis that provide in-depth
information, white papers, and video tutorials. In addition, users can submit and vote on feature
requests via the Ideas portal. For a free registration, go to https://community.tibco.com.
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Tutorial Overview

This tutorial walks you through the process of:

Procedure

1. Creating a repository model that contains the following:

. Three Repositories: Customer, Account, and Address.

e A CustomerDetails Attribute Group within the Customer Repository containing FirstName,
LastName, DateOfBirth, SSN, and EmailAddress as attributes.

*  An AddressDetails Attribute Group within the Address Repository containing Street, City,
Country, as attributes.

¢ An AccountDetails Attribute Group within the Account Repository containing
AccountNumber, AccountHolderPhoto, AccountOpenDate, and CurrentBalance as attributes.

e A Relationship between Customer and Address with HomeAddress (Boolean),
AddressSince(Date), and NoOfPersons(Integer) as Relationship Attributes.

e A Relationship between Customer and Account with AccountType (String), MinimumBalance
(Amount), NoOfAccounts (Integer), and NewCustomer (Boolean) as Relationship Attributes.

1 1

8 Customer = Ef acccount
L) k ountToCustomer
&7 Unassigned o CLSIDMEr TOACCONt | gt accountType {] &7 Unassigned
REL 1D % MinirmumBalance [:2300]
RBE IDEXT 1 123 NoOfAccounts ABLIDEXT
ABLCONTAINS o CustomerToAddress 140 NewCustomer ABS CONTAINS
o’ Systemn ) System
E‘. W0 Homeaddress

&’ CustomerDetails F addressSince & sccountDetails
RBE FirstName 1 123No0fPersons ABL Accounthurnber
ABE Lastharme e+ addressToCustamer [& accounterholderPhoto
) Dateofeirth EE addrecs ] AccountOpenDate
ABESSN 0.0 CurrentBalance
RBEEmail I’ Unassigned

ABLID

RBEIDEXT

ABECONTAINS

o) System

2. Validating your repository model.
3. Exporting your respository model.

4. Importing the repository model into MDM.

Creating a Project
First, create a new Project to hold the Repository Model.

Procedure

1. Go to File > New > Project .The Create New MDM Developer Project wizard is displayed.
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M New Project

Select a wizard

Create Mew MDM Developer Project

@ Analysis Project
@ BPM Developer Project
@ Java Praject
# lava Project from Existing Ant BuildFile
@ MDM Developer Project
@; openarchitectureWare Project
l{fﬁ Plug-in Project
B Quality Process Project
@; Hrext Project
= General
(= Business Inteligence and Reporting Tools
(= Business Modeling
= Eclipse Modeling Framewark
= EXB

2

Cancel

2. Select MDM Developer Project and click Next.

3. Provide a name for the Project: RepositoryTutorial. Clear the Use default location checkbox if you
want to provide a different location for the project (by default, the current workspace). Select

Destination Environment as MDM. Click Next.

P New CIM Developer Project

Project

Create a new project resource,

Project name: [l

Uss default location

Id: |

Wersion: | 1.0.0.qualifier |
[ cm
[ simulation

Destination

Enwironments:

Cancel

4. The Asset Type Selection dialog is displayed - select Repository Models and click Next.
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T New CIM Developer Project

Asset Type Selection

Select the asset bypes to configure Far the project.

Assebs: ‘&‘ Description:
=3 Brm
[ © Business Assets
i ~[¥] © Business Processes
1= [{] £ Business Objects
; [ Business Object Model
i O CIM miEL Model
[ crganization Mol
1= [7] 3 Datasources
P [#C Datasources
= [#] (4 Repostory Madels
[][E) Repositary Madel
= [#] L5 Rulsbass Models
 ~[YIE Rulebase Model
=-[7] 3 services
i © CIM Activity WSDL
© Service Descripkors

Select All || Deselect Al

@ < Back Dext > Finish Cancel
5. The folder for the Repository Model is displayed. Click Finish.

7 New CIh Developer Project

Set Special Folders

Set the Following special Folders

Repositary Madel

(8 Falder: Repository Models

®

This creates a new special folder Repository Models. Expand the project in the Project Explorer to
see it.

Fin Project Explorer X

SR
! Repository Model Samples

Eg RepositoryTutorial

: -{#| Repositary Models

Creating New Repository Model in the Repository Models Folder

Procedure

1. Right click the Repository Models folder in the Project Explorer and select New > Repository
Model.
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[ *Project Explarer 53 =0

SR
E| @ Repository Tutorial
_ N = pros
G Test £ Project...
|| Copy Chrl+C ._<.> File:
Faste G|+ [ Folder
3 Delete Delete [ 5L File
Special Folders
Move...
Renare. .. Fz L=<j Example. ..
S -
g Import... 4 Other.., Chrb+N
Export 4 T

2. Accept the name and location for the repository model (. rep extension) and click Finish.

P New Repository Model

Repository Model

Create a new Repository Model

Enter or select the parent folder:

| Mew/Repository Models

1=F bsProject
= New

(= Repository Madels

File name:

@ [ Finish H Cancel ]

In the Project Explorer, double click RepositoryModel.rep (under the newly created Repository
Tutorial project) to open up the drawing pane in the Process Editor.

[7 Project Explorer 53 =0
ERSN AN
1 Repository Model Samples
E‘ Ig RepositoryTutorial
E-{8) Repository Models
B- RepositoryModel rep
E‘T‘ Data Damain

Creating Repositories

First, create 3 repositories.

Procedure

1. Click the E&Repository  joon in the Palette and then click in the main drawing pane to insert the
Repository. Call the Repository Customer.

2. Create a second repository Account and place it to the right of the Customer Repository.
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3. Create a third repository Address and place it the below the Customer and Account Repositories.

g customer Ff Acccount.
97 Unassigned &’ Unassigned
RBL 1D ABLID
RBL IDEXT ABL IDEXT
RBL CONTAINS ABC CONTAINS
&’ System &’ System
9 CustomerDetails B address & accountDetalls
BBt Frrsthiame Bl sscnsd B¢ Accounthumber
AL LagtName RBCID [5 AccounterholderPhoto
EE DatenfBirth ABLIDEXT EH AccountOperDats
BBL SSN RBL CONTAINS 0.0 CurrentBalance
RBCEmail & Systemn
9 addressDetails
ABLCity

RBL Street
RS Country

Create Attribute Groups and Attributes

Next, create attribute groups for each repository and add some attributes.

Creating Customer Repository

Procedure

1. Select the & attribute croup icon from the Palette and click in the Customer repository (either at the
top or bottom of the Repository) to add an Attribute Group. Call the group CustomerDetails.

2. Selectthe g auribute icon in the Palette and click within the newly created CustomerDetails attribute
group. Call the attribute FirstName and keep the default string attribute type.

3. Similarly, create the following additional attributes within the CustomerDetails attribute group:

o  FirstName, type String

o LastName, type String

o  DateofBirth, type Date

e  SSN, type String

e  EmailAddress, type String

Your Customer repository should look as follows:

B customer
27 Unassigned 1
ARt ID
ABC IDEXT
ABL COMTAINS
27 System

27 CustomerDetails

ABL Firsthame
RBL Lasthame
FH DateafBirth
ABE 55N

ABL Ernail
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Setting EmailAddress as Multivalue attribute
Procedure

1. Click the EmailAddress attribute in the repository.

2. In the Properties window, set Multi Value to true. This indicates that this attribute can hold more
than one value.

Creating Account Repository

Procedure

1. Select the & attribute aroup icon from the Palette and click in the Account repository to add an
attribute group called AccountDetails.

2. Selectthe g aribute icon in the Palette and click within the newly created AccountDetails attribute
group. Call the attribute AccountNumber and keep the default string attribute type.

3. Create a second attribute AccountHolderPhoto.Change the attribute type to image by selecting the
attribute in the drawing pane, and changing the Type to File in the Properties window, General tab.

=1 Properties 2 {51 Problems| O Fragments| 148 Data Source Explorer| B Console | GEm T =0

© AccountholderPhoto

General | property Value

Name = AccountholderPhoto
Display Name "= AccountholderPhoto
Description "= AccountholderPhoto
Type

Length
Position
Column Name

Association Map "=|Date

Help =
Searchable "= false
Display In Record List = false
Quick Viewzble =

Category Attribute = false
Multi Value = false
Use Common Table "= false
Multi Value Table Name =

Partition Key = false

« M B

4. Create a third attribute AccountOpenDate and change Type to Date.
5. Create a fourth attribute CurrentBalance and change Type to Decimal.

Your Account repository should looks as follows:

2 Account
& Unassigned
ABL 1D
ABEIDEXT
ABE CONTAINS
& system

& AccountDetails

ABE AccountNumber
BAcccuntholderPhoto
[ AcoountopenDate
0.0 CurrentBalance
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Creating Address Repository

Procedure

1. Select the & attribute aroup icon from the Palette and click in the Address repository to add an
attribute group called AddressDetails.

2. Selectthe g auribute icon in the Palette and click within the newly created AddressDetails
attribute group. Call the attribute Street and keep the default String attribute type.

3. Similarly, create the following additional attributes within the AddressDetails attribute group:

Attribute Name Type

City String (default)

Country String (default)

Your Address repository should look as follows:

B addrass
@ Unassigned

ABLID
ABL IDEXT
ABL COMTAINS

@ System

@ addressDetails
AR City

ABL Street

ABL Country

Create Relationships

Next, create relationships between the Customer and Account repositories and the Customer and
Address repositories.

Setting Relationship between Customer and Account

Procedure

1. Select the s+ Relationship  jcon from the Palette; click on the outer edge of the Customer
repository and drag to the outer end of the Account repository to define a relationship.
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When attempting to draw a relationship from a source repository, ensure that you see an
arrow as indicated below.

E Customer

signed

N

Once you correctly touch the edge of a repository, you will see the arrow icon. When
dragging to define the relationship, the cursor changes to a hand icon; release the cursor
only when you touch the outer edge of the target repository and once you see the cursor
change to an arrow again.

2. Provide a forward and reverse relationship name. By default, the focus is on the forward
relationship (indicated by a forward arrow icon).

a) Enter CustomerToAccount as forward relationship name.
b) Click on the reverse arrow icon and provide AccountToCustomer as the reverse relationship

name.

The multiplicity icons on the relationships (*) do not influence the model since MDM does
not support it, they are simply indicative of multiplicity on the main model diagram.

1 1
Ecuammer EAE[EUW[
048 ArCountToCUstomer,
& Unassigned

O Unassigned w0 Customer ToAccount

RBC ID RECID

RBC IDEXT 1 RBCIDEXT

AR CONTAINS ABLCONTAINS
O Systern o System

Setting Relationship between Customer and Address

Procedure

1. Select the w&+oRelationship

icon from the Palette; click on the outer edge of the Customer

repository and drag to the outer end of the Address repository to define a relationship.

2. Provide CustomerToAddress as forward relationship name and AddressToCustomer as reverse

relationship name.

EE Customer
27 Unassigned
ABL 1D
ABEIDEXT 1
ABE CONTAINS
27 System

fro Costomer ToAddresd

27 CustormerDetails

RBL Firstharme
REBE LastMame
B DatenfBirth
ABLSSH

RBE Ernail

o pddressToCdstomer

B address
2 Unassigned
ABL 1D
ABLIDEXT
BBL CONTAINS

Y Svsterm
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Define Relationship Attributes
Next, define some relationship attributes for the defined relationships.

You first need to create Relationship Attribute Groups to hold the attributes and then add the actual
attributes.

Creating Relationship Attributes for CustomerToAccount

Procedure

Select the ﬁﬁfﬂﬂﬂﬂ?ﬂ'ﬁm icon from the Palette and click in the canvas above or close to the

CustomerToAccount relationship to place the attribute group.

—_

%) Relationship o . . .
2. Select the “ Atetﬁﬁﬂtn: " icon from the Palette and click in the relationship attribute group.

3. Call the new attribute AccountType and keep the default String type.

4. Create a second relationship attribute MinimumBalance. Double click the attribute and change the
Type to Amount in the Properties window.

5. Create a third relationship attribute NoOfAccounts of type Integer.

6. Create a fourth relationship attribute NewCustomer of type Boolean.

Creating Relationship Attributes for CustomerToAddress
Procedure

1. Select the Relationship Attribute Group icon from the Palette and click in the canvas close to the
CustomerToAddress Relationship to place the relationship attribute group.

2. Add the following relationship attributes:

 HomeAddress, type Boolean.
e AddressSince, type Date.
»  NoOfPersons, type Integer.

Connecting the Relationship attribute groups to the relationships
Procedure
1. Click the &-oGroup Conmector icon in the Palette. Click the outer border of the Relationship Attribute

Group (for the CustomerToAccount relationship) and drag to connect the relationship. This
connects the relationship attribute group to the relationship.

2. Repeat the same process to connect the relationship attribute group created for
CustomerToAddress.

Create a Perspective

Next, create a perspective to define the subset of the relationships of the root repository.
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Creating Perspective for Subset of Relationship

Procedure

1. Right click on Customer Repository and select New > Perspective Creation .

2. The Perspective Generator Wizard is displayed. Enter the Perspective name in the Name field and
enter the description in the Description field and click Next.

Wy Perspective Generator | El RS |

Perspective Generation Wizard

Select Repositories/Relationship. For each relationship chosen, you must also choose
the source and the target repositories.

& E& Vehicle
| oo VehicleToCustomer_Fwd
@ E& Customer
| oo VehicleToCustomer_Bwd
[ B Vehicle
[¥]*8 IsType
[7] & Unassigned
[7] & System
&7 CustomerDeatils
2 MName
2 Telephone | 4
2 Address
[¥]*8 IsType
[ e+a VehicleSelf
[ e+ VehicleRev
[Tl ase Ineuranceletaile Vehicle Pl

»

m

'@:‘ MNext = [ FEinish ] ’ Cancel ]
3. Select the relationships which you want to view in the perspective and click Finish. The Perspective
Editor with the newly defined perspective is displayed.

4. You can also view the perspective editor by clicking on the perspective link in the Properties section

of the Repository model.
= Properties &3 . [ Problems| @] Error Log Data Source Explorer = | kS ¥ =08
B8 Vehicle
General MName Description Root Repository Name
Attributes iVehiclePerspective i VehiclePerspective ekicie
Group Sequence
Input Maps
Output Maps

Classification Schemes
Perspectives
Configuration

Appearance

Validate the Repository Model

At this point, if you have followed all the steps in the tutorial so far, there should be no validation
errors.

If you omitted to perform any of the steps, it may result in a validation error. For instance, if you create
a relationship attribute group but leave it empty (without adding any relationship attributes). Or if you
fail to connect a relationship attribute group to a relationship. Or if you forget to provide a reverse
relationship name for a relationship.
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Check the Problems tab for any errors.

Exporting the Repository Model
Next, export your repository model.
The Export Wizard is used to export the graphically designed repository to MDM metadata format
(.xml file).

Procedure

1. Select the RepositoryTutorial Project in the Project Explorer and click File > Export or right click the
project and select Export.

2. Select MDM Metadata Format under MDM Repository Designer. Click Next.

- -
wyf Export u_lé |l

Select A

/
Export Metadata E E

Select an export destination:

type filter text
I . = General -
[ - [= Business Object Modeler
l - [= Business Process Management
> 2= Install
= Java

- = MDM Data Source
- [= MDM PatternsIndexerConfiguration
» = MDM Process Designer
= MDM Repository Designer
| 4% MDM Metadata Format
E-1 MDM Presentation Forms
» = MDM Rulebase Designer
» = MDM Synchronization Format
- [= Plug-in Development
. 3. RundMehon

m

[

@:‘ < Back Next = Finish Cancel

3. Select the RepositoryModel.rep file for export by selecting the checkbox. The default location to
which the file will get exported is displayed in the Destination section under Project (/Exports/
MDMExportFolder). You can change the path if required. Click Finish.
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T ™
iy MDM Repository Designer Export Wizard E@I&J

MDM Repository Designer Export Wizard
Select Repository Models for Export to MDM Metadata Format

[ B2BDataModel
[ Demo
[ Insurance
[¥] 12 RepositoryTutorial
[¥]() Repository Models
[7] £, RepositoryModel.rep
[ UBuilderTutorial

|
|
|
|

Destination
@ Project (Location: /Exports/MDMExportFolder)

) Path: Browse...

MNext = ’ FEinish ] ’ Cancel ]

In the Project Explorer, you will see a new folder Exports created which contains the XML file
generated.

> 124 B2BDataModel
> T@ Demo
> T@ Insurance
> @7‘1 repositoryl_webservice
4 T@ RepositoryTutorial
» [ Business Objects
SO} Configurations
5 Datasources
E Presentation Resources
- [78 Process Packages
> [E) Repository Models
> [ Rulebase Models
> @ Service Descriptors
[ Sync Formats
& Ul Builder
4 [= Exports
4 [= MDMExportFolder
|%| RepositoryModelxml
> 124 UBuilderTutorial

Importing the Repository Model into MDM

You can now import the repository meta data into MDM.

Procedure

1. Start the MDM application
2. Go to System Operations > Import Meta Data.

3. Browse to select the RepositoryModel.xml file, exported from the Repository Designer.
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TIBC2" MDM

Inbox  Administration -  System Operations » Master Data » Browse and Search Business Processes Event Log Custom Pages w

Import Metadata

Specify metadata file ( jar/.zip) for upload.

File Details

File to Upload Choose File | Mo file chosen

4. You will see details of the file you selected for upload. You can click the Check Progress link to see
the status.

Import Metadata Request Status

File Name Repositorviodel xml
File Size 11.74KB / 12025bytes

Meta data management request accepted and submitted to workflow. Monitor the progress by clicking here: Check Progress

5. You can check the status of the process from the Event Log. If the Event shows as complete without
any error, it means the repository model was successfully imported in MDM.

& If you have already have repositories with same name, the metadata import will overwrite
the existing metadata.

6. Go to the Repositories page to check if your repositories have got added. You should see the
Customer, Account, and Address repositories here along with the custom attributes, relationships,
and relationship attributes defined in the Repository Designer.

Result

You can now continue refining your repository, adding records and attributes, and so on.

Generating the WSDL

You can now Generate WSDL for Person Account.

Procedure

1. Import repository designer sample into your current workspace. Select Help-Welcome. Click the
samples icon.

2. From Solution Designer-Available sample project, click the Repository Model sample.

3. Follow the wizard to import the Person-Account-Email-Phone-Address repository structure. Switch
to workbench.
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4. Using the WSDL Generator Wizard, generate wsdl for Customer repository. Follow the wizard to
complete the webservice project creation.

5. Go to File > New > Other.

- Modeling - TIBCO Business Studio - E:\workspace
dit Wavigate Search Project Run Window Help
SN = quality Process Project
Open File... [# Analysis Project
[F¥) BPM Developer Project
[ MDM Developer Project.

Select a wizard —"

Wizards:

|type filker text ‘

[ Project...
[ Folder [= Plug-in Development ~
[ File (= Server
8 Data Source Madel [ service Redistry
[ Reposiory Model (= 50L Development
Rename. . 2 s Rulebase Model (= 5N
&) Refresh F5 Business Object Model g Llse‘; Assistance
Convert Line Delimiters To +| [ Process Package el
Organization Model (= Web Services
. = (& WSDL Generator
Switch Workspace o| [ Eamele.. DV317DM WSDL Generator
Restart - Ctrl+ (= ML
i -
£y Impart... (= Htext DAL Wizards
P (= Other =
£y Export...
= Examples v
Properties Al+Enter

1 CIM Sub Process (CIMSubProcess) [De...]
2 Demoz2.bom [Demoz{Business Objects]
3 Product.rep [DemojRepository Models]

4 ProductToCustomer [resourcefDemof...] = e e

Exit

6. Select WSDL Generator from the WSDL Generator tree node and click Next. The New Project
screen is displayed

e T e

New Web Service Project Selection

Project name is optional. Default project name is
<RepositoryMName>_webservice.

Project Name:  person_webservice

®  emeime ][ e

7. Enter the appropriate project name in the Project Name field. By default, the project name is
<repository name_webservice.

8. Click Next. The New Project screen is displayed.
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M WSDL Generator |:_.@®

Generation Options

Select Generation options from the list

Package Mame: | com, tibco, mdm.integration.webservice, email_webservice

Mext = [ Finish H Cancel ]

9. Select the relationship depth, multilevel relationship is supported.
10. Click Next. The Generation Options screen is displayed.

Generation Options

Select Generation options from the list

Package Name: com.tibco.mdm.dynservices.person_webservice

Next » [ Enish || Concel |

11. Enter the appropriate package name in Package Name field. By default, a package name is
provided. The package name convention is

com.tibco.mdm.integration.webservice.<repository name>_webservice.You can modify the
package name.

12. Click Finish. The person_webservice project is created in MDM Studio.
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M- EHRE M- QA E e o s (R Wiading)
~ = =
BE|&LT

I 4 |'E"J person_webservice|

-

sunec.jar - D:\Sudhir Cimstudic

4
3 rtjar - DA\Sudhir\Cimstudio\d.1[ ]
> = JRE System Library [1.7.0]
[ resources.jar - D\ Sudhir, Cimst
3 jeegjar - DASudhir Cimstudio'd,
3 axis2-adb-1.5.1.jar - 0" 5udhirty
3 jssejar - DASudhin Cimstudio®d| 2
3 charsets.jar - D\ Sudhir Cirmstul I
3 sunmscapi,jar - 0 5udhirt Cirms
3 dnsns.jar - O:\Sudhir Cimstudi
b (s axiom-dom-1.2.7 jar - D:\Sudhi
3 sunjce_providerjar - D\ 5udhir,
3 axiom-impl-1.2.7 jar - D Sudhil—
3 axis2-adb-codegen-1.51jar - D
3 jaccess,jar - D\Sudhirt Cimstud
3 gson-1.7.1.jar - D:\SudhirWork
3 axis2-kernel-1.5.1.jar - D\ 5udhi
3 axis2-1.5.1 jar - D:\Sudhir/Work
3 activation-1.1jar - D:\5udhir\V = Properties (g._( Problems (08 Fragments (w Data Source Explorer &2 <fg> | | ‘@| m E:ﬂ 7=
[ access-bridge-64.jar - D0\ Sudhin + (= Database Connections
4 LI 4 E3 BIRT Classic Models Sample Database
o= Outline | [{9 Deployment &2 =0 £ New SQU Server
= ODA Data Sources
<'===D - == Classic Models Inc, Sample Database

[f3 Deployment Servers (== Flat File Data Source

== Hive Data Source

= JDBC Data Source

== Web Services Data Source

== XML Data Source

o* }gp‘l person_webservice

13. Using network deployment, deploy the whole repository and relationship structure from the
Repository Model Samples project onto your MDM Server.

14. In SOAP UI, create a new project and import < your workspace name>\person_webservice
\services\PersonService.wsdl as the initial wsdl.
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File Tools Desktop Help
RAE0a20XE0 Search For.. i @
. == | 3 ]
l |i it Req oo [
[E7] Projects
o (= =@ 0 ii W |http://localhost:B080/eml/dynservices/PersonService %+ @
L f—]@ Person_webservice
=X § PersonHttpBinding g [l <scapenv:Envelope xmlns:scapenv="http://schemas.xmls{& ; g Elksnapenvﬂnvelﬂpe xmlns :soapenv="http:|~|
ri-__‘ 2 addPerson 4 <soapenv:Headerz/> > |E <socapenv:Body>
32 Requestl z = <soapenv:Body> 3 =] <spapenv:Fault>
2 buildRelationship = |F <ns:AddPersonRequest> = <faultcodersoapenv:Server</ £y
e <!--Optional:-—> <faultstring>in walid string
5 copyPerson El <ns:UserInfo> <detail/>
+ deletePerson <ns:UserName>john</ns:UserName> </soapenv:Fault>
'25 findPerson <ns:Password>john</ns:Password> </soapenv:Body>
- updatePerson <ns:Enterprisertechpubs</ns:Enterprise> </scapenv:Envelope>
-5 validatePerson </ns:Userlnfo>
% Sample <!—Optional:——>
B4 Tutorial =] <ns:Context>
=l «!--¥ou may enter the following 13 items

<!-—Optienal:-->»
<ns:WValidation>?</ns:Validation>

<!-—Optienal:-->»
<ns:Process>?</ns:Process>
<!-—Optienal:-->»
<ns:SystemAttributeReturn>?</ns:SystemAt
<!-—Optienal:-->»
<ns:ReturnFilelsRttachment>?</ns:Returnk.
<!-—Optienal:-->»
<ns:EffectiveDateSearchOption»?</na:Effe
<!-—Optienal:-->»
<ns:DeleteRllRelatedRecords>?</na:Delete
<!-—Optienal:-->»
<ns:Perspectivelame>?</ns:Perspectivelam
<!-—Optienal:-->»
<n3:FindCnlyRootRecord>?</ns:FindOnlyRoo

<!-—Optienal:-->»

Request Properties N o e ar .
Popery | vaoe | | | L I D K s

Mame Request 1 -

Description

Message Size 6019 response time: 590ms (302 bytes)

Header... Attachmen... = Headers ... Attachments...

soapUlleg http log  jettylog  errorlog  wsrmlog  memory log

16. You will see PersonHttpBinding with addPerson, buildRelationship, copyPerson, deletePerson,
findPerson, updatePerson, and validatePerson services along with their sample request skeletons in
your project.

17. Change the endpoint URL to point to your MDM Server instance.

18. Change the enterprise credentials inside each request before execution through SOAP UL

The optional <context> section can be used as follows in case of Record Add request:

<ns:Context>
<!--Optional: Set this to true if you want to validate each
attribute value against schema. -->
<ns:Validation>false</ns:Validation>
<!--Optional: Set this to true if you want to process the record as
soon as it is added. If this value is false, the record remains in
%> "unconfirmed" state and the record add event remains in progress-->
<ns:Process>true</ns:Process>
<!--Optional: Set this to true if you want to see the system
attribute values in response. -->
<ns:SystemAttributeReturn>true</ns:SystemAttributeReturn>
<!-Optional: The following is used when File type attribute values
have to be sent as a part of the request.->
<ns:ReturnFileAsAttachment>false</ns:ReturnFileAsAttachment>
</ns:Context>
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