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Introduction to TIBCO Business Studio

TIBCO Business Studio can be installed using two separate installations (Studio for Analysts and Studio
for Designers), each of which is appropriate to a different type of user.

See the TIBCO Business Studio Installation Guide and the TIBCO Business Studio for Analysts Installation Guide
for more information.

Studio for Analysts

Studio for Analysts enables the business analyst to model the business processes and access all the artifacts
from a single file. This installation is suited to users doing high level or abstract modeling. The ribbon-
based toolbar provides a familiar, easy to use interface that supports this type of modeling.

To launch TIBCO Business Studio For Analysts, go to Start > Programs > TIBCO > environment_name >
TIBCO Business Studio 3.7 Analyst Edition > Studio for Analysts. For more information on working with
Studio for Analysts, see the TIBCO Business Studio for Analysts User Guide.

Studio for Designers

Studio for Designers provides a project based view and enables the solution designer to add details to and
manage the processes at a project level. This installation is suited to users who are more comfortable with
developer tools, and who need access to all files related to the project.

To launch TIBCO Business Studio as a solution designer, go to Start > Programs > TIBCO >
environment_name > TIBCO Business Studio 3.8 BPM Edition > Studio for Designers .

Creating a Project Package and Process
You can create a new TIBCO Business Studio project, package and process are part of the same procedure
using a template.

● If you have processes that you created using previous versions of TIBCO Business Studio, you must
migrate them to the current version as described in Migration of Projects Created in Previous Versions

● This topic describes how to create a project, and at the same time create a package and process using a
template. You can however, perform each operation separately.

Procedure

1. Select File > New > Analysis Project .

2. Complete the New Analysis Project dialog as follows:

Field Description

Project name Enter a descriptive name for the project.

Location Either accept the default location for the project (your workspace) or de-select
the Use default location checkbox and click Browse to select a different
location.
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Field Description

Version Either accept the default version (1.0.0.qualifier) or enter a version for the
project in the standard Eclipse format:
      major.minor.micro.qualifier

The specified version will be the default for project artifacts such as process
packages and organization models, and can be used to track revisions to the
project. The version can be changed later as described in Changing Project
Lifecycle Settings .

Status Package life cycle status for informational purposes. How or whether you use
life cycle statuses is up to you, but they are typically used as follows:

● Under revision - for packages in development

● Under test - for packages in User Acceptance Testing (UAT)

● Released - for packages in production

Destination
Environments

Select the Destination Environment (optional). This specifies the intended
runtime environment for project artifacts.

For example, for processes, TIBCO Business Studio performs validation
according to the selected destination environments. Other artifacts (for example,
organization models) are not affected by project destination settings.

For processes:

● All processes are validated for BPMN - additionally, other destinations can
be selected to validate processes for use in specific environments

● If you select BPM, the Process will be validated against BPM.

● If you select Simulation, processes created under this project will be
validated for simulation in TIBCO Business Studio as well as for BPMN
correctness.

● If you do not select a destination environment, basic BPMN validation will
be performed.

● To set a default destination which will then be ticked already in this dialog, select Window
> Preferences > User Profile, and select the required destination from the dropdown next
to the Project Destination field.

● The exact destination environments that are displayed depend on the edition of TIBCO
Business Studio and any addins that you have installed.

The specific destination components that make up a destination environment can be
viewed by selecting Window > Preferences, and selecting Destination Environments.

● To avoid error messages and warnings associated with modeling constructs that cannot be
executed in the runtime environment, set the appropriate destination environment on the
process.

● You can change or select the destination environment after the Process has been completed
on the Destinations tab of the Process Properties .

Click Finish on this dialog (or on any of the subsequent dialogs) to create a project with the settings you
have made to that point. Click Next to modify the default project settings and create a process using a
template.
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3. The Asset Type Selection dialog displays the types of assets that you can include in your project. For a
full description of the different types of assets, see Assets. Select the types of assets you want to include
in your project and click Finish if you are done, or Next to specify more options.

4. In the Business Assets dialog, enter the name of the folder that you want to designate for business assets
files. Click Finish if you are done, or Next to specify more options.

5. In the Select quality process project dialog, select the name of the quality process project that you want
to use. If you have not already created a Quality Process project in your workspace, you will receive a
message telling you that there are no Quality Process projects in the current workspace, but you can add
them later using the New Quality Process wizard. Click Finish if you are done, or Next to specify more
options.

6. In the Organization Model dialog, enter the name of the folder that you want to designate for the
organization model.

Select the checkbox under Model Details if you want to create an initial organization model.

Give the Organization Model you want to create a filename, or use the default one provided. The
filename will automatically have a prefix of the domain name, as set in Window > Preferences > User
Profile, and will end with .om.

Select the Default Schema Types checkbox unless you want to define different schema types.

You can also select to apply the default organization type to the Organization model you are creating.

Click Finish if you are done, or Next to specify more options.

7. In the Business Object Model dialog, enter the name of the folder that you want to designate for the
Business Object Model.

Select the checkbox under Model Details if you want to create an initial Business Object Model.

Give the Business Object Model you want to create a filename or use the default one provided. The
filename will automatically have a prefix of the domain name, as set in Window > Preferences > User
Profile, and will end with .bom.

Select a Type for the Business Object Model. 3 types are provided for you to select from: the Business
Object Model (no profile), Concept Model or Persistent Business Object Model.

Click Finish if you are done, or Next to specify more options.

8. In the Emulations dialog, enter the name of the folder that you want to designate for Emulations.

Click Finish if you are done, or Next to specify more options.

9. In the Business Processes dialog, enter the name of the folder that you want to designate for Business
Processes.

Under Package Details, you can accept the pre-selected checkbox and either enter a filename or accept
the default filename.

By default when you create a project, TIBCO Business Studio creates a package and process as well. The
default packages Folder is called Process Packages and the default packages file is
ProcessPackage.xpdl. Either accept the default names or rename the packages file and folder. Click
Finish if you are done, or Next to specify more options.

10. The Package Information dialog is displayed. Either accept the default properties of the package, or
modify them as necessary and click Finish if you are done, or Next to specify more options.

● Package Label
 Descriptive label for the package. Defaults to the same name as the filename of the package and is
used for purposes such as simulation reports.

● Author
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 Username of the user who created the package.

The name of the author can be defined in the User Name: field on Window >
Preferences > User Profile. If no user is defined there, it uses the default user system
property.

● Created
  Displays the date/time that the package was created.

● Description
 Text description of the package.

● Documentation Location
 URL or filename of any supporting documentation.

● Status
 Package life cycle status for informational purposes. How or whether you use life cycle statuses is
up to you, but they are typically used as follows:

Under revision - for packages in development

Under test - for packages in User Acceptance Testing (UAT)

Released - for packages in production

● Business Version
 Version information about the package (this is inherited from the setting in the New Analysis
Project dialog in step 2).

The version you specify in this field is unrelated to any source control system and their
use is entirely user-defined.

● Cost Unit
 Three-letter currency code that provides context for the costs reported in Simulation. For
example, there is a Cost Per Unit for Participants in Simulation, that displays an integer with no
currency. For example, use this informational field to specify to anyone using the process that a
Cost Per Unit of 50 is intended to be read 50 USD. GBP is the default.

Both Cost Unit and Language provide content assist. Press Ctrl+Space to see a list of
allowed values for these fields.

● Language
 Provides context for user-visible language in processes. For example, annotations in a process
may be in a language or character set unfamiliar to the user of the process. Use this field to specify
the language used. Note that this field is informational; it does not change any system or TIBCO
Business Studio-specific language settings.

11. The Select Template dialog allows you to create a process using a template. Select a template from those
available and click Finish if you are done, or Next to specify more options.

12. The Set Special Folders dialog displays the default special folders for each asset type that you selected in
the previous step. Either accept the default names or enter your own names and click Finish.

The newly-created package, process, and project are displayed in the Project Explorer. For more
information about the Project Explorer, see Project Explorer View.

16

TIBCO Business Studio™ Modeling Guide



Process Creation
There are a number of common tasks and shortcuts to help you use the Process Editor to create processes.

See Gadgets for an Object

See Adding Objects Using the Palette

See Using an Object’s Gadget to Connect Objects

See Using Connection Tools on the Palette to Connect Objects

See Selecting Objects

See Tools for Finding Objects in a Diagram

See Customizing Palette Favorites

For additional information, see Tips and Tricks.

Gadgets for an Object
A gadget is a user interface aid that allows you to easily create sequence flows or other links between
objects.

When an object is selected, initially one gadget of each applicable type is displayed, and if multiple gadgets
of a particular type are available, these are displayed when the mouse cursor is moved over the first.

For example, if a task is selected, the Create Connection gadget is visible to the lower right of the task:

Gadgets that can be used to designate references to other objects can be used to designate a reference (drag-
drop gadget onto target object) or go-to a currently referenced object.

These gadgets are provided:

●  Cycle Object Type Gadget  Change the activity type by cycling through the different types.

●  Create Connection Gadget  Create sequence flows to existing object or create and connect to new
object.

●  Link Event Gadget  Designate a throw and catch link event pair.

●  Signal Event Gadget  Designate a throw and catch signal event pair.

●  Reply Activity Gadget  Specify a request - reply relationship (with throw and catch message events or
send and receive tasks).

●  Reference Task Gadget  Select the task that the current task will reference.
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You can control the display of gadgets using the toolbar tool, or the Show Click/Drag Gadgets
drop-down list from the Diagram toolbar:

A gadget is a user interface aid that allows you to easily create sequence flows or other links between
objects.

● To add an object, click the Create Connection gadget, and drag and drop it in a lane content area or
embedded sub-process content area.

A popup menu is displayed showing a selection of applicable main object types that can be created
(available types governed by the source object and drop location).

You can also drag onto an existing sequence flow, and the object is inserted onto the sequence flow. If the
target flow is not to or from the selected object then a new flow added to the new object.

Adding Objects Using the Palette
You can use the palette to add objects (for example, a task).

When you first start TIBCO Business Studio, if the palette is not visible, expand it by clicking the Show
Palette button to the right of the window:

Procedure

1. Click the appropriate tool in the palette. If an object has more than one type (for example, a task can be a
service task, or user task, and so on), each type has a tool on the palette. For example:
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Click another tool to display the available sub-types. For example, click the Gateway tool to see the
different types of gateways; this closes the currently open tool drawer if more space is required to open
the new tool drawer. To change this behavior and cause the available tasks to remain open, click the Pin

Open button ( ).

● To add more than one object of the same type, hold down the Ctrl key.

● You can customize certain palette preferences by selecting Customize from the right-click
menu on the palette. This allows you to define preferences such as the default tool drawer
states on editor startup. There is also a Favorites drawer that you can customize (see 
Customizing Palette Favorites ).

Position the pointer on the process at the place where you want to place the object. The pointer changes

shape: 

2. Click the process to add the object.

Result

You can also drag and drop from the palette. So select an item on the palette and drag and drop it to where
you require it in the process.
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Using an Object’s Gadget to Connect Objects
You can connect objects in the process by creating a sequence flow using the Create Connection gadget, but
a similar procedure applies to all connection types.

Procedure

1. Select the object. For example:

2. Drag the Create Connection gadget to connect to another object. For example:

3. If you add more connections or references, additional gadgets are added. These are only visible if you
position the mouse over the visible gadget. For example:

In this example, there is a Create Connection gadget for each outgoing sequence flow. Clicking a gadget
selects the referenced or connected object in the Process Editor (for example, clicking the gadget
attached to a reference task selects the referenced task).

Using Connection Tools on the Palette to Connect Objects
To connect two objects with sequence flow, use the Sequence Flow tool.

Procedure

1. Click the Sequence Flow tool.

2. Position the pointer over the object that will be the source of the sequence flow.

The pointer changes shape: 

3. Draw the sequence flow using one of these methods:

● Click the source object, then position the pointer over the target of the sequence flow. If you are
satisfied with the shape of the flow, click the target.
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● Click the source object, holding down the mouse button, drag the pointer to the target object and
release the mouse button.

While drawing the sequence flow, you can add bendpoints by right-clicking or pressing
the spacebar as you create the flow.

You can also drag and drop from the palette. So select an item on the palette and drag and
drop it to where you require it in the process.

When you connect objects, as the default the sequence flows use Multi Entry/Exit Point
connection routing (meaning that there will be multiple separate lines from the entry or
exit point to those objects they are connected to. You can tailor this behavior, by selecting
the process, and from the Properties tab, select the Appearance tab. You can then select
from these connection routing styles:

● Multi Entry/Exit Point

● Single Entry/Exit Point

● Uncentered on tasks

Once you have selected a different connection routing style, the diagram will be
reformatted to use this selection.

Selecting Objects
You can select objects using the Select tool on the palette or the Marquee tool.

● Using the Select tool on the palette. Hold down Ctrl to add single objects to the selection or Shift to
select a range of objects.

● Using the Marquee tool. This allows you to drag a rectangle around all the objects that you want to
select.

Tools for Finding Objects in a Diagram
TIBCO Business Studio provides different tools to find objects in a diagram.

● To find an object on a process, press Ctrl+F or click the  icon on the toolbar. In the resulting dialog
enter the name or partial name of the object you are looking for. For example:

In this example the only task that starts with "c" is a script task called coreLogic. Clicking on the task
displays it in the Process Editor.

● You can find workspace elements such as processes, package names, and process interfaces by pressing
Ctrl+F or the search toolbar button in the Project Explorer view. For example:
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● You can also find a business object model package, class, primitive types and enumerations, as well as
organization models, by pressing Ctrl+F or the Find toolbar button in the Project Explorer view.

● You can also find items using the first characters from the start of each capitalized word (CamelCase
searching). For example, "BP" returns a file called BankPayment.wsdl.

The wildcard ? returns all elements. Use the * wildcard to restrict the results (for example, *2 to return all
matches ending in 2). Note that the wildcard * by itself does not return any results; it only works in
conjunction with a string.

Customizing Palette Favorites
The palette contains a drawer labelled Favorites that contains some of the most commonly used objects.,
which you can customize by adding or removing objects.

Procedure

1. Right-click in the Favorites drawer, and select Customize.
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2. Expand the Favorites item in the Customize Palette dialog.

3. Select an object and use the Hide check box to display or hide the object in the favorites drawer:
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Projects Packages and Processes

This section describes how to work with projects, packages, and processes in TIBCO Business Studio.

Migration of Projects Created in Previous Versions
Projects created in previous versions of TIBCO Business Studio may need to be migrated to the current
version before they can be opened, depending on how you import them.

● If you are migrating a project created in a previous version using File > Import > Existing Studio
Projects into Workspace, migration will happen automatically.

If you are importing a project from SVN, then you may be unable to access all files in the imported
project until you have reviewed the Problems view and resolved the problem covering migration using
the Quick Fix provided.

Alternatively, if there is a problem marker on the project in the Project Explorer view, press Ctrl+1 and
look for the Problem

"Project 'xxx' is of an older version and needs to be migrated."

Select the "Migrate the Project" quick fix in the popup.

● If you are importing a single file (for example, an XPDL) then you may need to migrate this file using
the Quick Fix available.

● If you are importing a project created in a newer version of TIBCO Business Studio, you will see a
problem marker (for example, "Project 'xxx' was created by (or migrated to) a newer version of the
product and should not be used with this version"). Install a newer version of TIBCO Business Studio if
that is appropriate or return to an earlier version of the product/project.

Creating a Package
You can create a package as part of creating a project or independent of project creation.

See Creating a Project Package and Process).

Procedure

1. Right-click the Process Package folder under which you want to create the package and select New >
Process Package .

2. If you want to change the Packages Folder under which the package is created, click Browse or enter an
existing folder name.

3. Enter the name of the File or accept the default filename. The filename must have .xpdl as the
extension. Click Next.

4. The Package Information dialog shows the name of the package and its default properties (for a full
explanation, see step 10 in Creating a Project Package and Process).

Either accept the default properties of the package, or modify them as necessary. Then, click Finish to
create a process using the default template, or click Next to create a process using a different template.

5. By default a process will be created with start and end event connected by sequence flow. The Select
Template dialog allows you to create a process using a different template. Select a template from those
available and click Finish.

Result

The newly-created packages and any processes that you elected to create are displayed in the Project
Explorer.
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To avoid error messages and warnings associated with modeling constructs that cannot be executed in the
runtime environment, set the appropriate destination environment on the process (see Correcting
Validation Errors ).

TIBCO Business Studio restricts the number of open editors to 8 by default to avoid adverse performance
issues. To edit this setting, select Window > Preferences > General > Editors and under Close editors
automatically, edit the value for Number of opened editors before closing.

Pre-Compiling Projects
Pre-compiling projects enables projects to be compiled without having to regenerate the derived artifacts
that are required for the deployment and run-time execution of business object models.

If your BPM application has multiple business object models (for example, projects that have WSDLs with
multiple schemas) then it can take a long time to generate the derived artifacts. Every time a project is
imported into a workspace, the derived artifacts are regenerated. When multiple users are working on a
BPM application, each user incurs this overhead.

By setting a project to pre-compile, all the WSDL and BOM related derived artifacts are preserved internally
in a project. When a pre-compiled project is exported, all the derived artifacts in the project are also
exported. When a pre-compiled project is imported, the artifacts are not generated again but are accessed
from the project.

There are some restrictions for pre-compiled projects.

● You can pre-compile any project that has the right asset types. The following assets can be pre-compiled:

— Business object models

— Imported WSDL files for services

In other words, you only have the option of pre-compilation on a project that contains business object
models and imported WSDL files for services.

● You must not change any of the assets, for example, the business object model or WSDL files in a pre-
compiled project. In other words, you must not add, update, copy/paste or delete WSDL, XSD or BOM
related files. Business Studio validates this, so any changes to the files causes error messages in the
Problems view. If you want to make any changes, you must disable pre-compile, make the changes and
then set the project to pre-compile again. Business Studio enforces this so that the pre-compiled derived
artifacts remain consistent with their source files.

● All projects that are referenced from a pre-compiled project must also be set to pre-compiled to ensure
the consistency of the derived artifacts when projects depend upon each other. Business Studio
automatically includes the appropriate referenced projects when enabling/disabling pre-compilation.

● You must ensure that the internal pre-compilation folders (projectname\.precompiled) are not listed
under Ignored Resources. Select Window > Preferences > Team > Ignored Resources for a list of
resources that are ignored.

Setting Your BPM Project to Pre-Compilation
If you want to enable projects to be compiled without having to regenerate the derived artifacts, you must
enable the BPM destination project to pre-compile.

Once you have set a project to pre-compile, you must not change any of the assets, for example, the
business object model or WSDL files in the project. In other words, you must not add, update, copy/paste or
delete files. Business Studio validates this, so any changes to the WSDL, XSD or BOM related files causes
error messages in the Problems view. If you want to make any changes, you must disable pre-compile,
make the changes and then set the project to pre-compile again.

25

TIBCO Business Studio™ Modeling Guide



Prerequisites

● Pre-compile is only available for projects with pre-compilable assets (WSDLs and BOMs).

● All referenced projects that have pre-compilable assets must also be pre-compiled. This can be done
when setting your BPM project to pre-compile, as described below.

● To enable pre-compilation, a project must have no problem markers or unsaved changes.

Procedure

1. From Project Explorer, right-click the project you want to pre-compile and select Pre-compile Project >
Enable.
The Enable Pre-Compile on Project dialog displays.

2. If there are referenced projects, the Enable Pre-Compile on Project dialog, you must select the Enable
pre-compilation on referenced projects check box. This enables pre-compile on all the referenced
projects.

3. If any of the referenced projects cannot be set to pre-compile (for example, the project contains the
wrong asset types), an error displays. You must resolve the errors on the reference projects before trying
to set your project to pre-compile again.

4. Select Finish.

The project is displayed with the pre-compilation icon ( ).

Disabling Pre-Compilation Your BPM Project
If you no longer want to pre-compile a BPM destination project, because, for example, you want to modify
some pre-compiled files, you must disable pre-compilation on the BPM project.

Procedure

1. From Project Explorer, right-click the project that you want to disable from pre-compiling and select
Pre-compile Project > Disable.
The Disable Pre-Compile on Project dialog displays.

2. If there are referencing projects, you must select the Disable pre-compilation on referencing projects
check box. This disables pre-compilation on all the referencing projects.

3. Select Finish.

The project is no longer displayed with the pre-compilation icon ( ).

Copying a Package
You can copy a package into the same project, or into a different project in your workspace.

Procedure

1. In the Project Explorer, highlight the package file you want to copy.

2. Press Ctrl+C to copy the package.

3. Open the project into which you want to copy the package.

4. Select the folder into which you want to copy the package (for example, the Process Packages folder).

5. Press Ctrl+V to paste the package. If copying the package within the same project, you are prompted to
enter a new name. If copying the package to a different project when a package of that name already
exists, you are prompted to overwrite the file.
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After copying a package, errors similar to this are displayed in the Problems view:

To correct this, right-click the problem, and select Quick Fix. Accept the suggested fix for this
problem to resolve the duplicate IDs.

Creating a Business Process
You can create a Process and its containing package and Project in one operation or you can create a
business process.

See Creating a Project Package and Process.

Procedure

1. Before creating a process, you must create a project and a package to contain your process.

2. In the Project Explorer, select the package you created, right-click and select New > Business Process .

3. The New Business Process wizard is displayed.

If you start this wizard from the File > New menu, the first dialog is the Project and Package
dialog, where you must specify a valid project and package. This dialog is not displayed if you
right-click at the package level to start the dialog; however you can click Back to display it if
necessary.

4. Enter the Label of the process. To use a template to create the process, select the template and click
Next. This example shows one of the basic templates (a task sequence).
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In addition to the process templates, you can select a process interface as the basis for your new process.
This creates a process with the necessary events, parameters that are specified in the process interface.

5. In the Description dialog, add optional text that describes the process, an optional URL that links to
documentation about the process, and click Next.

6. In the Destinations dialog, select the Destination Environment (optional). This controls the validation
that TIBCO Business Studio performs when you save the process:

● The exact destination environments that are displayed depend on the edition of TIBCO
Business Studio that you have installed.

● The specific destination components that make up a destination environment can be
viewed by selecting Window > Preferences, and selecting Destinations.

● All processes are validated for BPMN - additionally, other destinations can be selected to validate
processes for use in specific environments

● If you select BPM, the Process will be validated against TIBCO ActiveMatrix BPM 3.x.

● If you select Simulation, the Process will be validated for simulation in TIBCO Business Studio as
well as for BPMN correctness.

You can change or select the destination environment after the Process has been completed on the
Destinations tab of the Process Properties

7. The Extended dialog is displayed. This allows you to add optional supplemental information to the
XPDL for the process. For more information see Creating Extended Attributes.
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8. Click Finish.

9. The process that you created is displayed in the Process Editor. When you first start the Process Editor,
the palette (on the right side of the diagram) might be collapsed; if so, expand it:

You can expand this window to fill your screen by double-clicking the title bar (in this example, the area
labeled Process2).

The Process Editor provides a Pool and Lane that you can rename if you plan on using pools and lanes
(see Controlling Flow in a Process). You add elements of your business process using the Palette.

Creating a Pageflow Process
You can create a Process and its containing package and Project in one operation or create a pageflow
process.

See Creating a Project Package and Process.

Procedure

1. Before creating a pageflow process, you must create a project and a package to contain your process.

2. In the Project Explorer, select the package you created, right-click and select New > Pageflow Process .

3. The New Pageflow Process wizard is displayed.

If you start this wizard from the File > New menu, the first dialog is the Project and Package
dialog, where you must specify a valid project and package. This dialog is not displayed if you
right-click at the package level to start the dialog; however you can click Back to display it if
necessary.

Enter the Label of the process. If you want to use a template to create the process, select the template
and click Next.

In addition to the process templates, you can select a process interface as the basis for your new
pageflow process. This creates a process with events and parameters that are specified in the process
interface.
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4. In the Description dialog, add optional text that describes the process, an optional URL that links to
documentation about the process, and click Next.

The Documentation Url field is intended for design-time collaboration; it is not displayed in
the runtime environment.

5. In the Destinations dialog, select the Destination Environment (optional). This controls the validation
that TIBCO Business Studio performs when you save the process:

● The exact destination environments that are displayed depend on the edition of TIBCO
Business Studio that you have installed.

● The specific destination components that make up a destination environment can be
viewed by selecting Window > Preferences, and selecting Destinations.

If you do not select a destination environment, basic BPMN validation will be performed.

To avoid error messages and warnings associated with modeling constructs that cannot be
executed in the runtime environment, set the appropriate destination environment on the
process.

You can change or select the destination environment after the Process has been completed on the
Destinations tab of the Process Properties.

6. The Extended dialog is displayed. This allows you to add optional supplemental information to the
XPDL for the process .

7. Click Finish.

8. The process that you created is displayed in the Process Editor:

When you first start the Process Editor, the palette (on the right side of the diagram) might be collapsed;
if so, expand it. You can expand this window to fill your screen by double-clicking the title bar. A
pageflow process has a different default color scheme from a business process.
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Pageflows do not contain pools or lanes.

Creating a Case Action Process
You can either create a new case action or generate one directly from a case class. Template case action
processes are provided that allow you to view or update the contents of a case object, but you can modify
these templates to provide whatever functionality you need for a particular case class.

You can generate a Case Action from a Case Class definition in the BOM editor. See Generating Case
Actions (to View or Update Case Data) From Case Classes and the TIBCO ActiveMatrix BPM Case Data User
Guide for more information.

Prerequisites

Before creating a case action, you must create/import a business data project with a case class and add a
case state attribute to that case class. You must also create/import a BPM project and have a package to
contain your case action.

Procedure

1. In the Project Explorer, select the package you created, right-click and select New > Case Action .
You can also create a case action from context menus on the case class in the BOM. See Generating a
Case Action to View or Update Case Data in TIBCO ActiveMatrix BPM Case Data User's Guide.

2. The Case Action wizard is displayed. Enter a Label and Name for the Case Action.

3. (optional) On the Case Class selector, Select a Case Class type from a Business Object Model to select
the Case Class that this action applies to.
If you do not set this here, you can set it from the Properties for the Case Action when you have created
the case action using the wizard.

4. Select a template for the case action from View Case Action Process or Update Case Action Process.

5. Set the Destination to BPM and other properties as required.

6. Click Finish.

7. The case action that you created is displayed in the Process Editor. For example, View Case Action
process:

Generating Case Actions From Case Classes
You can generate a Case Action from a Case Class definition in the BOM editor.

Procedure

1. Right-click on a Case Class in the BOM and select Generate Case Action.

2. Select one of the following actions:
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● To View Case Data : Fetches the data for the case reference provided by Openspace and shows that
data to the user in a form.

● To Update Case Data : Fetches the data for the case reference provided by Openspace and shows
that data to the user in a form. The user can change that data and the case object is subsequently
updated.

3. From the Generate Case Action dialog, open the project and Process Packages where you want to place
the xpdl. You can also select an existing xpdl. Click Finish.
The case action will be generated with the appropriate template (View Case Data or Update Case Data)
and you can edit it to meet your needs.

View Case Data:

Update Case Data:

Creating a Service Process
You can create a service process and its containing package and project in one operation or create a service
process only and add it to existing package/project.

See Creating a Project Package and Process.

A video called Modeling a Service Process is available that shows how to model a typical service process.

As service processes should be of short duration and have only one function, some activity types are not
supported in service processes.

Activity Type Description

User tasks No direct user interaction with a service process is supported.

Manual ad-hoc activities No direct user interaction with a service process is supported.
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Activity Type Description

Inbound message events and
receive tasks that require
correlation

Outbound message events are supported.

Event sub-processes responding to
externally sourced signals/
messages and inter-process signals

This could result in unacceptably long pauses and, as service
processes can be invoked from both pageflows and business
services, this feature is disabled for service processes. Event sub-
processes for internal process signals are supported.

Attached Sub-process calls to non-
service process types

Service processes can only synchronously invoke other service
processes. However, they can asynchronously invoke
conventional stateful business processes.

Non-boundary timers Timers that pause rather than monitor the execution of a thread of
a service process are not supported.

When modeling a service process, you must specify a deployment target. You can deploy service processes
to either:

● the process engine

● the pageflow engine

The deployment target you choose depends on whether you are invoking your service processes from
business processes or pageflow processes. When you create a service process, the service process is set to
deploy to the process engine by default.

Procedure

1. Before creating a service process, you must create a project and a package to contain your process.

2. In the Project Explorer, under Process Packages, select the package you created, or Processes within an
existing package, right-click and select New > Service Process.
The New Service Process wizard is displayed.

3. Enter the Label of the process. You can change the label on the General tab in the Properties view if
necessary. If you want to use a pre-defined template to create the service process, select the template
and select Next.
In addition to the service process templates, you can select a service process interface as the basis for
your new service process. This creates a service process with the deployment target, events and
parameters that are specified in the service process interface. Specifying a service process interface
allows the dynamic selection of service processes at runtime. See Service Process Interfaces.

4. In the Description dialog, add optional text that describes the process, an optional URL that links to
documentation about the process, and click Next.

The Documentation URL field is intended for design-time collaboration; it is not displayed in
the runtime environment.

5. (Optional) In the Destinations dialog, select a destination environment. This controls the validation that
TIBCO Business Studio performs when you save the process.
You must set an appropriate destination environment on the process if you want to avoid error
messages and warnings associated with modeling constructs that cannot be executed in your runtime
environment.
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● The exact destination environments that are displayed depend on the edition of TIBCO
Business Studio that you have installed.

● The specific destination components that make up a destination environment can be
viewed by selecting Window > Preferences, and selecting Destinations.

● If you select BPM, the Process will be validated against TIBCO ActiveMatrix BPM 3.x.

● If you select Simulation, processes created under this project will be validated for
simulation in TIBCO Business Studio as well as for BPMN correctness.

If you do not select a destination environment, basic BPMN validation is performed.

You can change or select the destination environment after the process is completed on the Destinations
tab of the Process Properties.

6. The Extended dialog is displayed. This allows you to add optional supplemental information to the
XPDL for the process.

7. Select Finish.

The service process that you created is displayed in the Process Editor.

When you first start the Process Editor, the palette (on the right side of the diagram) might be collapsed;
if so, expand it. You can expand this window to fill your screen by double-clicking the title bar. A
service process has a different default color scheme from other processes.

Service processes do not contain pools or lanes.

8. Once you have created your service process, you must configure the deployment target that you want
the service process to be deployed to.
When you create a service process, the deployment target is automatically set to Deploy to Process
Run-time so, if you want your service process to deploy to the pageflow engine, you must select
Deploy to Pageflow Run-time in the General tab of the Properties view.

There are other tabs available in the Properties view for service processes. See Process
Properties for more information.

Refactoring Service Processes and Service Process Interfaces
You can convert an existing business, pageflow or sub-process into a service process or, alternatively, a
service process into a business, pageflow or sub-process. You can also refactor a service process interface
into a process interface, and vice versa.
There are some activities that are not supported in a service process or service process interface. If the
business process or pageflow process you want to convert to a service process contains any of the
unsupported activities, validation errors occur. To avoid validation errors, you must remove any of the
unsupported activities before conversion.

The following activity types cannot be used:

Activity Type Description

User Tasks No direct user interaction with a service process is supported.

Manual ad-hoc activities No direct user interaction with a service process is supported.

Inbound message events and
receive tasks that require
correlation

Outbound message events are supported.
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Activity Type Description

Event sub-processes responding to
externally sourced signals/
messages and inter process signals

This could result in unacceptably long pauses and, as service
processes can be invoked from both pageflows and business
services, this feature is disabled for service processes. Event sub-
processes for internal process signals are supported.

Attached sub-process calls to non-
service process types

Service processes can only synchronously invoke other service
processes. However, they can asynchronously invoke
conventional stateful business processes.

Non-boundary timers Timers that pause rather than monitor the execution of a thread of
the service process are not supported.

Right-click the business, pageflow or sub-process you want to convert and select Convert to service
process. In the same way, you can convert a service process to a business process or pageflow process.

You can also refactor a service process interface into a process interface by right-clicking a service process
interface and selecting Convert to Process Interface. Similarly, you can convert a process interface into a
service process interface by selecting a process interface and selecting Convert to Service Process
Interface . When you convert a process interface into a service process interface, the deployment target is
automatically set to Deploy to Process Run-time so, if you want your converted service process interface to
implement service processes deployed to the pageflow engine, you must go back and configure this in the
service process interface after conversion.

Creating a Work List Facade
The Work List Facade allows you to optionally declare the design-time definition of a set of display labels
for the predefined work item attribute set. The display label set is contained in the Work List Facade.
See "Work Item Attributes" in the TIBCO Business Studio Concepts Guide.

Procedure

1. Select File > New > Work List Facade Project.
2. Enter the project name.
3. Click Finish.

If you have deleted the Work List Facade file for any reason, you can add a new Work List
Facade file. From the Work List Facade Special Folder select New > Work List Facade.
However, multiple Work List Facade files are not allowed.

What to do next

Now go to the work list facade editor to define the display names of your work list attributes. See Seting the
Display Label for Work Item Attributes.

Setting the Display Label for Work Item Attributes
The work list facade editor is a table editor that allows you to optionally set the display label for any of the
predefined set of 40 work item attributes.

Display labels are used throughout the organization.

Procedure

1. When you create a Work List Facade project, the Work Item Attributes table opens. If it is not already
open, select WorkListFacade.wlf from your Work List Facade project.

35

TIBCO Business Studio™ Modeling Guide



2. Add values to the Display Label column.

You can add as many or as few display values as you want. When you use the Work List Facade Editor
as described in "Work Item Attributes" in the TIBCO Business Studio Concepts Guide, to add values, the
attributes with display values appear at the top of the list of attributes wherever they appear in the user
interface.

The attribute name and type column are read-only. Only the Display Label can be edited. The Display
Labels have length restriction of 64 characters.

The Work List Facade file will look like the example below, based on the information in the Display
Label column entries in the previous graphic.

What to do next

When you have completed your display labels, deploy the Work List Facade project.

If you need to change your display labels at any time, edit them as described and redeploy the Work List
Facade project.

Mapping Process Data to Work Item Attributes
You can map process data to work item attributes to allow automatic work item attribute assignment on all
user tasks which implicitly or explicitly reference the mapped process data. This can be done to avoid the
use of scripts to achieve the same result.
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Procedure

1. On the Work Resource tab of the Business Process, expand Work Item Attribute Mappings.
The left column shows all data fields defined for the process. The right column lists the 40 work item
attributes available, with those with defined display labels at the top of the list. When there is no Work
List Facade file in the Workspace scope, the Work Item Attributes are sorted by the numeric values in
their name. See Seting the Display Label for Work Item Attributes

2. Map a data field to an attribute.
For example, Field could be mapped to the Name attribute. Do this for all data fields you would like to
map to attributes.

Each user task in the process, with the mapped process data associated, contains the script equivalent to
the mappings defined here.

If you use the Work Manager script from the Scripts tab for a user task, you will only be able
to use the physical attribute names (attribute1, attribute 2, etc) which appear in content assist
and not the display names.

Creating a Global Signal Definition Project
You define a Global Signal Definition project to define global signals, which can be referenced from
multiple projects.
You can define more than one Global Signal Definition project if desired.

Procedure

1. Select File > New > Global Signal Definition Project.
2. Enter the project name and select theBPM destination environment. Click Next.
3. Accept the default settings (including the selection of Create initial Global Signal Definition and click

Finish.
The Global Signal Definition project is created, with an initial GlobalSignal. You can then define the
payload data to be associated with the global signal. See Creating Payload Data for Global Signals.
On the Properties tab for the Global Signal, define the correlation timeout setting. The default setting is
Correlate Immediately. You can change this to Timeout Signal After: n seconds.

It is possible to deploy a process with global signal events without deploying the Global Signal
Definition project. However, if you do this, then the process will halt with an error at runtime.
You should deploy the Global Signal Definition Project before you deploy processes which
contain global signal events.

Creating Payload Data for Global Signals
You can define either normal or correlation payload data for global signals.
Normal payload data is simply process data that is passed from the throw signal event to the catch signal
event.

Correlation payload data is used to match waiting catch signal event process instances to specified process
instances. For example, a catch global signal might have a correlation payload parameter of 'Invoice
Number'. When the catch is initiated, the current value of 'Invoice Number' for that process instance

37

TIBCO Business Studio™ Modeling Guide



becomes the 'key' on which the signals are matched. The throw global signal maps a value to the 'Invoice
Number' correlation payload parameter, and the system finds the corresponding process instance for the
catch global signal that was initiated with that same value.

After defining the payload data in your global signal definition project using the procedure below, the
global signal throw and catch events in your process will map to this payload data. On the throw signal
event, use Map To Signal to map process data to the defined payload data. On the catch signal event, use
Map From Signal to map from the defined payload data to process data. For more information, see Throw
and Catch Signal Events.

Correlation data payload changes are not permitted on global signal definition project upgrade. Therefore
signal correlation parameters cannot be changed unless the major version is changed. You must take care to
ensure that only valid changes are made. If you upgrade a global signal definition project, any changes you
have made to a BOM class referenced by a payload data parameter are not validated against.

Procedure

1. On the Global Signals panel, select the global signal you want to add payload data for.

2. On the Payload Data panel, select PayloadData.

3. On the Properties pane General tab, use the Use for Signal Correlation selection to specify whether
you are defining normal or correlation payload data, as follows:

● Select Use for Signal Correlation to define correlation payload data.

● Unselect Use for Signal Correlation to define normal payload data.

4. If you are defining normal payload data, specify whether the payload data is mandatory or optional by
selecting or unselecting the Mandatory check box. (The Mandatory check box is not visible if you are
defining correlation payload data, as it is always mandatory.)

5. In the Type section, specify the appropriate type information for the payload data, depending on the
process data it will be mapped to.

Deleting a Process
You can delete a process and decide whether to delete referenced processes.

Procedure

1. Do one of the following:

● Right-click the process in the Project Explorer, and select Delete.

● Highlight the process and select Edit > Delete.

● Highlight the process and press Delete:

2. If the process you are deleting is referenced in the parent package (for example, you are deleting a sub-
process), a dialog is displayed:

● If you are sure that you want to invalidate the process that is referring the the process you are
deleting, click Yes.

● If you do not want to delete the process, click No.

3. If the process you are deleting is not referenced in the parent package, it is still possible that it is
referenced by a process in a different package. TIBCO Business Studio cannot validate against this
however and a dialog is displayed:

● If you are sure that processes in different packages do not reference the process you are deleting,
click Yes.
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● If you do not want to delete the process, click No.

It is also possible to delete a process by deleting the XPDL file of the package that
contains the process in Windows Explorer. This will delete all processes in that package.
If you delete a package in Windows Explorer while TIBCO Business Studio is open, you
must refresh the Project Explorer to see an updated view of the workspace.

Using the Dependency Viewer
Use the Dependency Viewer to show an interactive, graphical representation of your project's file
dependencies.

Procedure

1. Right-click a resource in Project Explorer (for example, a project, a BOM file, or a form file) and select
View Dependencies.

2. The Dependency Viewer displays the dependencies.

For example, right-clicking the easyAsInsurance_Process.xpdl file shows references from the form
files to the XPDL file and references from the XPDL file to the easyAsInsurance.bom (business object
model) and easyAsInsuranceOrganizationModel.om (organization model).

You can select different views in the Dependency Viewer to make these relationships clearer:

To focus on a resource, do one of the following:

● Select the resource in the Project Explorer.

● Right-click the resource in Dependency Viewer and choose Focus on or Focus on Resource name.

● Click the  button.

To reset the layout and refresh the contents of the viewer, click .
To show everything in the workspace, including resources which are not related to the resource you

have focused on, click .

To break the link between the Project Explorer and the Dependency Viewer, click . Doing
this means that resources that you select in the Project Explorer are not focused in the
Dependency Viewer.

To highlight resources that are referenced from the resource you are focusing on, click . In the
following graph, the easyAsInsurance_Process.xpdl file references easyAsInsurance.bom (Business
Object Model) and easyAsInsuranceOrganizationModel.om (Organization Model).
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To highlight resources that have a reference to the resource on which you are focused, click . In the
following graph, a number of form files reference the easyAsInsurance_Process.xpdl file.

To show all the resources which are part of the relationship graph of the focused resource (that is, all the
resources which are directly or indirectly related to focused node), click .

Finding Cyclic Dependencies
The Dependency Viewer highlights any connections that are part of a cycle.

A simple example of a cyclic dependency is where Project A refers to Project B, which refers back to Project
A.

Procedure

1. Display the list of projects.

2. Selecting every resource as the focus using the Dependency Viewer, check for cyclic connections. You
can identify these by this connection:

For a given resource, get the list of resources it depends on and make each of these the focus in
Dependency Viewer, and check for cyclic dependencies.

Creating Extended Attributes
Extended attributes can be used to add extra information to the schema.

Extended attributes are as follows:

● XML
 For example, an XSD file used by a web service.

● Plain text
 For example, Supply Chain Management (SCM) metrics and best practices.

You can also add extended attributes when creating a new Process or Process Interface as
described in Creating a Business Process .

Procedure

1. Click the Extended tab.
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This tab is only available on the Properties view for objects that support extended attributes.

2. Click Add to add a new extended attribute.

3. Modify the following:

● Name
 Provide a Name for the attribute (you cannot include spaces in the name).

● Value
 Add any text for the Value.

● Escape Body
 Select this check box if you want the parser to interpret the contents of the body attribute as text
rather than XML (you do not want the parser to interpret symbols such as < or >). If you are
entering XML, do not select this checkbox so the parser can validate the body attribute.

● Body
 Enter whatever text or XML you want to make up the body of the attribute.

4. Save the package that contains the process.

Project Reference Creation
Project references can be created either explictitly in the project properties or automatically (subject to user
confirmation), when you select an object from outside the current Project.

● Explicitly: see Creating References in the Project Properties).

● Automatically: see Creating Project References in a Selection Dialog).

Creating References in the Project Properties
You can create a reference from one Project to another in the project properties.

Procedure

1. Right-click the project, select Properties, and highlight Project References:
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2. In this dialog, select any projects that you want to refer to from the selected project.

Creating Project References in a Selection Dialog
Project references can automatically be created when an object from outside the project is selected.

Procedure

1. For example, when defining a sub-process call, you select from a list of all the sub-processes in the
workspace:
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2. If the selected sub-process is not part of the project in which the sub-process call is located, a message is
displayed asking if you want to add the project (which contains the selected sub-process) as a reference
project. Click Yes to create a reference to the project that contains the sub-process.

Assets
Assets include XPDL package files, WSDL files, documents, business object models, and so on that relate to
the project, and they are usually stored in special folders under the project.

See "Assets" in TIBCO Business Studio Concepts.

Quality Process Business Assets
TIBCO Business Studio provides assets to support quality processes or methodologies.

To include quality process templates,:

● Create a project to contain the templates. See Creating a New Quality Process Project

● Refer to Using Quality Processes in Your Project to associate a quality project with another project.

Creating a New Quality Process Project

You can create a new quality process project.

1. Select New > Project , expand Business Modeling, select Quality Process Project, and click Next.

2. Enter a project name. Either accept the default location for the project (your workspace) or de-select the
Use default location checkbox and click Browse to select a different location.

3. Click Next. In the resulting dialog, you can either create an empty quality archive project (into which
you can copy your own template), or select Prince2 templates:

4. If you used the Prince2 templates, they are used to create the project:

If you created an empty project, copy the files and folders for your quality process.
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Using Quality Processes in Your Project
You can associate a quality process project with other project types in order to keep the documents expected
by your quality team with other project assets.

Procedure

1. Create a project, selecting Business Assets as one of the asset types to be included in the project.

2. When prompted, specify the quality process project containing the correct templates (or accept the
default).

Result

Alternatively, after creating a project you can add business assets by selecting a standard folder and then
Special Folders > Other > Use as Business Assets. When prompted, specify the quality process project
containing the correct templates (or accept the default).

Adding Ad-hoc Assets
Ad-hoc assets include Microsoft Office documents and image files not recognized as project management
assets.

Procedure

1. Add business assets by right-clicking and selecting New > Folder or New > File , and selecting the
appropriate Parent Folder.

2. To view the folder or files you have created, go to the Navigator view. In the Navigator view, you can
also drag files and folders to different locations.

Enabling and Disabling Special Folders
Special Folders are folders in the Project Explorer that are reserved for storing specific types of assets.
Special folders can be enabled or disabled in TIBCO Business Studio.

See "Special Folders" in TIBCO Business Studio Concepts.

● Disable a special folder by highlighting it in the Project Explorer, right-clicking, and selecting Special
Folders > Do not use as SpecialFolderType

The example uses the special folder for business processes as an example, however the special
folders for other asset types are enabled and disabled in the same manner.

● Disable the packages folder by highlighting the Process Packages folder in the Project Explorer and
selecting Special Folders > Do not use as Process Packages Folder, which results in a view of the
package like this:

● Conversely, you can enable the use of the special packages folder by highlighting the packages folder in
the Project Explorer and selecting Special Folders > Use as Process Packages Folder. This results in a
view of the package like this:
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Changing and Refactoring Project Lifecycle Settings
Project Lifecycle settings can be changed or refactored in TIBCO Business Studio.

See Changing and Refactoring Project Lifecycle Settings.

See Refactoring Lifecycle Settings.

See "Project Lifecycle" in TIBCO Business Studio Concepts.

Changing Project Lifecycle Settings
You can change project lifecycle settings (such as a project version).

Procedure

1. Right-click the project and select Properties and Lifecycle. This dialog is displayed:

2. Enter the new settings and click OK.
Any new project artifacts will be created with the new settings. For example, if you changed the version,
new process packages will be created with the new version. If there are project artifacts that were
created with the previous settings that you want to update to the new settings, continue with 
Refactoring Lifecycle Settings.

Refactoring Lifecycle Settings
The lifecycle settings of project artifacts (such as process packages or organization models) can be changed
to match the settings of the parent project.

Procedure

1. Right-click the project and select Refactor > Project Lifecycle ... A dialog is displayed that shows any
project artifacts that can be refactored. When you select an artifact the settings that can be changed are
displayed.
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In this example, the project has the version 2.0.0.qualifier and the organization model was created
with the version 1.0.0.qualifier (you can also refactor other settings such as status if they have
changed).

2. To refactor the version of the organization model to match the version of the project, click OK.

Process Fragments
TIBCO Business Studio provides predefined fragments in the folder BPMN Process Fragments.

Also see "Process Fragments" in TIBCO Business Studio Concepts.

Migrating Fragments from Previous Versions
Any fragments that you created in previous versions of TIBCO Business Studio must be migrated to the
current version, but the predefined fragments that TIBCO Business Studio provides do not need to be
migrated because they are available in the current version.

Procedure

1. Select File > Import > General > Existing Fragments Projects into Workspace , and click Next.

2. In the Import dialog, click Browse to select the directory where your fragments are located.

3. Select the fragments that you want to migrate, and click Finish.

Using the Predefined Fragments
You can use one of the predefined fragments.

Procedure

1. Open the process.
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2. Make sure that the Fragments view is visible. If it is not, select Window > Show View > Fragments .

3. In the Fragments view, there is a treeview that looks similar to the Project Explorer. This is the Fragment
Explorer. Expand BPMN Process Fragments folder. This contains categories of BPMN process
fragments.

4. Expand the category that contains the fragment you want to use.

5. Select the fragment.

6. Drag the fragment onto the process.

You can also use the Copy and Paste menu options either by right-clicking or by selecting
from the Edit menu.

Creating Custom Fragments
If a portion of your process is one that you are likely to reuse in other processes, you can capture the useful
part of the process and save it as a custom fragment.

Create a new category by either right-clicking BPMN Process Fragments in the Fragment Explorer and
selecting New > New Category or by clicking the Create New Category button ( ).

Procedure

1. Double-click in the name field of the newly added category and enter a name:

2. Do the following:
a) Holding down the Ctrl key, select the activities and sequence flows in the process that comprise the

fragment.
b) Copy and paste the fragment into the Fragments view:
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Importing Custom Fragments
You can import custom fragments from an archive file or a .bsProject folder.

Procedure

1. Create an archive file that contains the .bsProjects folder from your workspace. This folder contains
your custom fragments.

2. The recipient of the archive file can then import it. To do this, select File > Import > General > Existing
Fragments Projects into Workspace , and click Next.

3. In the Import dialog, select the Select archive file check box and click Browse to select the archive file
that contains the fragments you want to import.

4. Click Finish. The fragments are imported into the current workspace.

Result

Alternatively, to import from the .bsProject folder, select File > Import > General > Existing Fragments
Projects into Workspace, and click Next. In the Import dialog, select the Select root directory check box
and click Browse to select the location of the .bsProject folder from the file system. Click Finish. The
fragments are imported into the current workspace.

Source Control
You can use Subversion with TIBCO Business Studio to provide source control to manage your projects and
processes.

See Using Subversion with TIBCO Business Studio

See Creating a Project from an Existing Project in Source Control

See Browsing SVN Repositories

See Deletion of Projects from SVN Repositories

The MKS source control system adds a project.pj file to every folder in the project.

Using Subversion with TIBCO Business Studio
Subclipse is an Eclipse plug-in that adds Subversion to the Eclipse environment, and is bundled with
TIBCO Business Studio.

This topic assumes that you or your Subversion administrator have installed an SVN server (see http://
subversion.tigris.org/).

Procedure

● Right-click an existing project that contains items you wish to source control. Select Team > Share
Project . Obtain the URL for the Repository Location from your Subversion administrator.

Creating a Project from an Existing Project in Source Control
You can create a project from an existing project in source control.

Procedure

1. Select File > Import . The Import wizard is displayed.

2. Expand SVN and select Checkout projects from SVN and click Next.
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3. Set up the repository with the assistance of your Subversion administrator, (this should point to the
parent directory to the one containing the project folder) and click Next.

4. Select the project folder and click Next.

5. Select the method for checking out the project and click Next.

6. Either use the default workspace or click Browse to check out the project elsewhere.

7. Click Finish. The project is checked out to your workspace.

We recommend that you import or export individual projects, and do not attempt to import or
export the workspace.

Browsing SVN Repositories
You can browse SVN repositories.

Procedure

1. Select Window > Open Perspective > Other .

2. Select SVN Repository Exploring.

3. This opens a perspective from which you can browse SVN repositories. For example:

Deletion of Projects from SVN Repositories
To delete a project that is in Subversion, use a tool such as Tortoise SVN, the command line interface to
Subversion, or a web-based tool.

Design Considerations for Process Migration
A process instance can only migrate to a new version of a process when certain criteria become satisfied.

These are automatically identified by TIBCO Business Studio at design-time, but you should be aware of
the points described in Migration Point Restrictions.

Migration Point Viewing
Valid migration points in a process are denoted by an icon next to the task in the Process Modeler, and by
process diagram annotations which allow identification of individual activities as migration points as and
when they are viewed in the diagram.

You can increase or decrease the visibility of these icons by hovering over the icon and using the selections
(shown in the screenshot below).
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Each selection you make is additional to those you have made before. For example, when you select a data
field then all the activities that reference that data field are highlighted in the process diagram. If you then
also select the Highlight Activities With Scripts option, then only the activities that reference the data field
and have scripts are highlighted.

To clear selections, click in the Process Editor window again, and it will go back to its default setting, which
is to show migration points.

You can also choose to highlight migration points by selecting Highlight Migration Point Activities from the
drop-down toolbar.

Migration Point Restrictions
You should be aware of a number of restrictions when designing your process to be sure that it can migrate
correctly.

● The task name is used to identify a migration point. This means that all tasks must have names.

By default, gateways do not have names. This means that you must specify a name for all
gateways in your process if you want them to be valid migration points.

Note that:

— task names must not be duplicated.

— task names in source and destination process templates must be the same.

● Migration cannot be performed on pageflow processes. Pageflow processes are short-lived processes
whose data is not persisted, therefore migration should not be required.

● For a user task, migration should be set before the user task is scheduled. Migration does not happen if
the changes are made after the user task is OFFERED to a user.

● Valid migration points are points of the process template where a single process thread executes.
Therefore, a task that starts a parallel path is a valid migration point but any tasks that follow are not
until those paths are rejoined.

● Part of a process that does not appear to be a parallel flow may be treated as a parallel flow. A primary
example of this is receive tasks without inflows and any sort of task boundary event. If the flows out of
these tasks are not merged back into the process then everything after that point is treated as a parallel
flow. This is because without an explicit merge back into the flow then there is an implicit merge at the
end of the process (hence all other activities on those flows are counted as "in-parallel" with the receive
task).
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● Any tasks inside embedded sub processes cannot be migration points, but the embedded sub process
itself may be a migration point. See Embedded Sub-Processes. Migration takes place before starting the
sub process.

● These events cannot be migration points:

— start events

— events placed on the boundaries of tasks.

See Events.

● Tasks that follow these gateways are not valid migration points:

— Inclusive

— Complex

— Parallel

● Tasks following tasks that have Timer events placed on their boundary with Continue Task on Timeout
selected are not valid migration points:

● Tasks following tasks with multiple instance loops with ordering set to Parallel and flow conditions that
are set to One are not valid migration points. This is equivalent to an exclusive gateway, and means that
only the completion of the first activity instance causes flow to continue.

● BPM Validation Configuration on the Resource properties tab of a process is used to suppress problems
markers for the ’No migration point activities in the process’ Problem. It gives you the choice of
validation, suppressing the error until the next process flow change, or suppressing the error until a
manual reactivation via Resource properties.

● Migration points cannot be set on an event handler flow but it is possible to modify an event handler
flow which can then be triggered after a process migration from a migration point set somewhere on the
main flow.

● Event handlers (and other incoming message activities) are automatically re-initialized during process
migration. This means that they will be re-activated using the new values for correlation data.

● When adding an ad-hoc event to a new process version, the initializer for the ad-hoc event must be
defined as the migration point or come after the migration point in order for the ad-hoc event to be
available after process migration. If the initializer is in a part of the process that has already been
executed before migration, the ad-hoc event will not take effect in process instances that have been
migrated.

● Migration is delayed with an audit message if the event handler thread is not complete. The migration
will complete once all outstanding event handler threads have been completed.

● When you add a new ad-hoc activity, and then upgrade and migrate, you must define an initializer for
the activity. This could actually be the migration point itself.

Comparison of Different Versions of a Process Package
You can compare the local Process Package you are working on with another version.

This can be used to identify:

● any changes you have made since the last time you saved that Process Package. See Performing a Two-
way Compare.

● any changes made by another user in the Subversion copy since you last checked it out. See Use of the
Process Package Comparison Editor with a Two-way Compare.

This ability to show a comparison graphically is also available for Task Libraries.

See Source Control for more information using source control to manage your processes.
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Performing a Two-way Compare
You can compare your current local copy of the Process Package with a previous local revision.

Procedure

1. Select the Process Package .xpdl file in Project Explorer, and right-click it.

2. Select Team > Show Local History . This will show you a list of your revisions to the file.

3. Select the previous revision you are interested in comparing with your current version, and right-click
Compare Current with Local.

The default is to keep local history available for 7 days. If you need to see more history than
this, select Window > Preferences > General > Workspace > Local History and edit the
settings.

4. You can then compare the file you selected with your current local copy. The Process Package
Comparision Editor is displayed showing you a tree of elements that are different in the two files. This
is a two-way compare. In the Process Package Structure Compare window at the top of the screen,
expand the Process Package and select the level you are interested in (for example, Activities).

The left/right revision views are populated with the tree structure of the different descendents of that
element.The differences in your local copy will be shown in the left-hand column.

Use of Process Package Comparison Editor with Two-way Compare
These notes will help you interpret the results of a two-way compare. The screenshot below shows you an
example of a two-way compare.
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● The following icons indicate changes in a two-way compare:

As no common ancestor is available for comparison, all differences are treated as if changes were made
on the left hand revision):

A green [+] (with no indication of direction) indicates elements that appear in the left
hand revision that do not appear in the right hand revision.

A green [-] (with no indication of direction) indicates elements that appear in the right
hand revision that do not appear in the left hand revision.

Items that do not have an icon by them are changed in either the left or right hand revision, or both (or
have added, deleted or changed descendents).

● If you hover the cursor over the relevant icon, tooltip pop-ups will let you know that the information
was added to the left or deleted to the right - so you may have added something, or the other version
may have deleted something.

In a two-way compare is it not possible to identify which version the change was made in.

● In the Comparison view, you see Information elements (as indicated by the  icon. These elements are
always shown regardless of whether there are any differences in the data that they represent. This is to
give you a context for given elements and usually will contain the 2 or 3 major configurations for that
element (such as task type, name and so on).

● Internal Properties (found at the level below a task, for example) is used to group a number of smaller
changes made as the result of your main change/s under one heading. You are unlikely to need to

examine these, but if you do want to see them in more detail select the  button above and to the right
of the left/right content view.

● The central section of the comparison view shows connection lines between correlating objects on the
left and right side. These include icons according to what the difference is (and on the side of the
connection line where the change that caused the difference was made). The lines are colour coded to
indicate the type of change that they represent (red=conflicting change, green=addition or deletion, blue
= existing element changed).

Performing a Three-way Compare
A three-way compare is used to compare your changes to a Process Package with those of another user, as
well as with the original (common ancestor) file on which both are based.

Typically, you might want to do this if another user checked a process package out of Subversion when you
did, and they made changes and checked them back in. When you go to check your own version back in,
Subversion identifies a potential conflict. To identify areas which the other user has changed and decide
whether to adopt their changes and abandon yours, or overwrite them with your own, you can do a three-
way compare.

Three-way compare is only available once a synchronize has been performed on the file (or its project).
Synchronize is performed automatically for any file when it is committed to Subversion (to ensure that no
conflicts exist with another user's changes).

See Source Control for information about using source control to control your project information.

To do a three-way compare (when you have checked a project file out of the source repository and made
changes and saved them - and another user has done the same and commited their changes):
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Procedure

1. Attempt to commit your changes in the Team Synchronizing perspective.

You will discover that your changes conflict with those of another user and you will not be able to
commit your changes until you have rectified this.

2. Select Open in Compare Editor to identify whether you want to adopt the changes from the other user,
or commit your own changes instead.

Use of Process Package Comparison Editor with Three-way Compare
These notes will help you interpret the results of a three-way compare.

● The following icons indicate changes in a three-way compare:

A blue left-pointing arrow containing [+] indicates an element added in the right
hand revision (as compared with the common ancestor).

A blue left-pointing arrow containing [-] indicates an element removed in the right
hand revision (as compared with the common ancestor).

A plain blue left-pointing arrow indicates an element changed in the right hand
revision (as compared with the common ancestor).

A grey right-pointing arrow containing [+] indicates an element added in the left
hand revision (as compared with the common ancestor).

A grey right-pointing arrow containing [-] indicates an element removed in the left
hand revision (as compared with the common ancestor).

A plain grey right-pointing arrow indicates an element changed in the left hand
revision (as compared with the common ancestor).

Red arrows pointing both ways indicate a conflict: the element or its descendents
were changed in both the left hand revision and the right hand revision.

● If you hover the cursor over the relevant icon, tooltip pop-ups will let you know that the information
was added to the left or deleted to the right - so you may have added something, or the other version
may have deleted something.

In a three-way compare, you can distinguish whether an additional element was caused by an addition
by someone else or a deletion by you. This is because the comparison can check whether the additional
element existed in the common ancestor, and if it did not, then you will know whether you have
changed it or whether it was another user.

● In the Comparison view, you see Information elements (as indicated by the  icon. These elements are
always shown regardless of whether there are any differences in the data that they represent. This is to
give you a context for given elements and usually will contain the 2 or 3 major configurations for that
element (such as task type, name and so on).

● Internal Properties (found at the level below a task, for example) is used to group a number of smaller
changes made as the result of your main change/s under one heading. You are unlikely to need to

examine these, but if you do want to see them in more detail select the  button above and to the right
of the left/right content view.
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● The central section of the comparison view shows connection lines between correlating objects on the
left and right side. These include icons according to what the difference is (and on the side of the
connection line where the change that caused the difference was made). The lines are colour coded to
indicate the type of change that they represent (red=conflicting change, green=addition or deletion, blue
= existing element changed).

Documentation
You can create documentation and artifacts from within TIBCO Business Studio.

Letters sometimes get truncated from task labels while exporting documentation. To avoid this, you can
add a period (.) to the end of the label.

See Creating Documentation from within TIBCO Business Studio

See Creating Documentation from the Command Line

See Generating Documentation On Demand

See Viewing Documentation

Creating Documentation From Within TIBCO Business Studio

You can create documentation from within TIBCO Business Studio.

1. You can do one of the following:

● Right click on a model resource (for example: an .xpdl, .bom or .om file).

● Right click on a project.

● Right click on a 'special' folder.

2. You can do one of the following:

● If you selected a model resource or the whole project, select Export > Documentation.
● If you selected a 'special' folder, select Export > Export > Documentation.

3. One of the following will happen:

● If you selected a model resource in step 1, it is selected in the wizard (you can change the selection
here if required).

● If you selected the entire project or a 'special' folder in step 1 all possible resources are selected in
the wizard.)

4. You have the option to select the destination for the documentation files.

● The default location for generation is <ProjectPath> > Documentation > * Model Documentation.

● The default for the Index page is <ProjectPath > > Documentation.

You can specify a location outside the workspace. In this case, the location must exist or an
error will appear in the wizard)

5. Click Finish to generate documentation for the selected model file(s) and generate an index page
containing overview information for the selected files(s).

Creating Documentation from the Command Line

You can create documentation from the command line.

1. Close the workspace that contains the project for which you want to generate documentation.
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2. Navigate to the directory that contains the TIBCO Business Studio executable file. For example:
   C:\Program Files\TIBCO\BusinessStudio

3. Open a command window.

4. Enter a command line including specification of:

● Workspace
● Project name
● Output location

This will generate documentation for the selected file(s) and also an index page.

An example of command line invocation would be:
TIBCOBusinessStudio.exe -application com.tibco.xpd.resources.ui.documentation -data 
<workspace> -projectName <project name> -outputPath <output path>

If you do not want to see the TIBCO Business Studio splash screen then provide an extra argument (-
noSplash) with the above command as:
TIBCOBusinessStudio.exe -application com.tibco.xpd.resources.ui.documentation -data 
<workspace> -projectName <project name> -outputPath <output path> -noSplash

Generating Documentation On Demand

You can generate documentation on demand from your local filesystem, without requiring a workspace or
TIBCO Business Studio project.

To do this, you require a supported file type (.maa) on the local filesystem. An .maa file is a way of
compressing a TIBCO Business Studio project.

To create an .maa file, in the Project Explorer in TIBCO Business Studio, go to your project, and select the
Documentation folder. Then right click to select Export > Archive File . When naming the file, give it the
suffix .maa.

To generate documentation on demand do one of the following when opening an .maa file:

● If the file is already associated with the Documentation tool, double-click the desired file within file
system explorer.

● If the file is not already associated with the Documentation tool, right click on the file and choose "Open
With.." and point to the Documentation tool (<Business Studio Home>/studio-doc.exe).

The command line generates documentation in the same path as the .maa file for the selected file(s) and also
an index page.

If an output path is provided in the <Business Studio Home>/studio-doc.ini the documentation is generated
in the path provided. To add an output path, add the following to the beginning of the studio-doc.ini file:
-outputPath
<OutputPath>

Viewing Documentation

You can view documentation you have created from TIBCO Business Studio.

1. Export the documentation as described in Creating Documentation from within TIBCO Business Studio.

2. If you created the documentation from within TIBCO Business Studio:

● In the Project Explorer, expand Documentation.
● Right-click the HTML file for the package and select Open With > Web Browser.

If you created the documentation from the command line:
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● Navigate to the directory where you created the HTML file and open it in a web browser.

● If you created the HTML file in a directory in your workspace, you can refresh the Project Explorer,
right-click the HTML file for the package and select Open With > Web Browser.

3. Note that the sections of the documentation are hyper linked as well as the image of the process (for
example, clicking a task displays the section that describes that task).

See "Deploying BPM Applications" in the TIBCO ActiveMatrix BPM - BPM Deployment guide for more
information.

Emailing Processes
The XPDL package files and the processes contained within can be sent using email.

To send a Process:

1. In the Project Explorer, find the name of the package that contains the process you want to send.

2. Attach the package file to the email message using a method such as copy and paste or drag and drop.

If you receive a Process:

Get the Process into TIBCO Business Studio as follows:

Be careful of overwriting existing packages with the same name.

● Save the attachment directly into your workspace and refresh the Project Explorer.

The default workspace location is C:\Documents and Settings\username\workspace.
However, you may have selected an alternate location when you first started TIBCO Business
Studio.

● Save the attachment to a file then do one of the following:

— Drag the package file from Windows Explorer into a packages folder in the Project Explorer in
TIBCO Business Studio.

— In Windows Explorer, press Ctrl+C to copy it, return to TIBCO Business Studio, and press Ctrl+V to
paste it into the Project Explorer, into a process packages folder.

Creating your Email template files

Procedure

1. In Project Explorer, navigate to the project you want to add the Email template to.

2. Right-click on the project and select New > Folder and name your folder.

3. Right-click on the folder you created, and select Special Folders > Use as Presentation Resources
Folder .

4. Right-click the Presentation Resources folder you created, and select New > File and create the files you
require.

Result

Alternatively:

● Right-click Presentation Resources > New > File, and create the files you require.
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If you create the files you require elsewhere, copy and paste them by copying them and then right-clicking
on Presentation Resources (or your new Presentation Resources folder) and selecting Paste Paste.

This email template will be available to this project only. If you attempt to access it from another project,
you will receive a validation error, as the files contained are not available outside this project.

Applying the Email template to a Project

Procedure

1. From the project, right-click Properties > Presentation Channels . Select the checkbox Enable project
specific settings.

● or select Window > Preferences > Presentation Channels, and click Configure Project Specific
Settings... Select the project you want to configure and click OK.

2. Expand Default Channel and select Openspace Email.

3. Click in the Value field for mailTemplateLocation, and you will see the picker:

4. Use the picker, to navigate to the HTML file you created in the Presentation Resources folder, and click
OK.

5. Click Apply.

Result

Next time you push an email, it will use this template.

Email templates are scoped to one project only. If the template is applied on the workspace level, then all
relevant projects should have the specified custom template files available inside them. It is then
recommended to overwrite the workspace Presentation Channel definition on the project level when the
custom email template needs to be provided.

Creating an Alternative Email Template
You can create your own email template which can contain organization-specific information, with your
own logos and corporate style.

After deployment it can be used as the default email template for any Push Destination using the
Openspace Email channel type.

The files you can use to create your email template are as follows:

● HTML file (Mandatory) This contains the information about what you want the email to contain. It
typically includes:

— a reference to the .css file as its stylesheet. This can be included using an html line similar to the
following:
<link rel="stylesheet" type="text/css" href="cid:Easycss" />

— references to any of the graphics files contained in the cid.properties file (referred to by their cid:
identifier, prefaced by ’cid:’) , for example:
<img src="cid:cidOne"/>

refers to NewProductLogo.png in the example in cid.properties above. Referring to them in this
way means they can by shown externally as part of the email when the html file is used to create an
email after deployment.

— the content you want to include in the email.

This html can contain any of the following tokens, each of which will be replaced by an actual value
at runtime;
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%%token.workItemUrl%% URL of the work item.

%%token.workItemId%% The id of the work item.

%%token.entityName%% The entity name who requires push
notifications as defined in the
Organizational Model.

%%token.mailDate%% The date and time the pushed mail
message was sent.

%%token.mailFrom%% The name of the sender of the pushed
mail message.

%%token.mailSubject%% The subject line for the pushed mail
message.

%%token.mailTo%% The user/s who the pushed mail
message is sent to.

%%token.mailCc%% The user/s who the pushed mail
message is copied to.

%%token.mailBcc%% The user/s who the pushed mail
message is blind-copied to.

%%token.hostIPAddress%% The IP address of the host.

%%token.hostMachineName%% The host machine name.

%%token.baseurl%% The base URL.

● CSS (Cascading Style Sheet) file This is a stylesheet file, typically for your organization, which contains
standard information such as banners or background colors, that you want to be in every email you
send.

● graphics you are referencing from the cid.properties file, which would then be used by the html file.
These must be available locally, and can either be in the same directory (Presentation Resources), or in a
sub-directory.

● cid.properties This allows you to reference any graphics files you have available locally (in
the same directory, or a subdirectory) which you want to be used when you push the work
item (which then sends an email to notify the user of the work item). It is specifically used
for embedded images / css in emails, rather than providing the option of external calls.

● Each filename will have a cid:<name identifier which allows it to be accessed remotely as
well as locally. For example, the cid.properties file might contain lines such as the
following, where cidOne is the cid: identifier for NewProductLogo.png when you reference
it later in the HTML file:
cidOne:NewProductLogo.png
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Import and Export of Projects

You can import existing projects, MAA files and archive files into TIBCO Business Studio, and export
projects from it to archive files, MAA files, a work data model, or file systems.

TIBCO recommends that you import or export individual projects, and do not attempt to import or export
the workspace.

Importing Existing Studio Projects into Workspace
You can import a project into the workspace.

Procedure

1. From the File menu, select Import, and you see the Select page of the Import dialog.

2. Expand the General folder, select Existing Studio Projects into Workspace and click Next..

TIBCO recommends that you use the Existing Studio Projects into Workspace and not the
Existing Projects into Workspace option, as it will only import the files you require.

3. Do one of the following:

● Click on the Browse button for Select root directory: to locate other projects that are somewhere on
the file system (for instance, in another workspace).

● Check the radio button for Select archive file: and click on the Browse button to see projects that
have already been archived which you may want to import.

4. Select the project you want to import, and click Open. The project is now selected..

This does not work if there is already a project of the same name in the workspace.

5. Select the Copy projects into workspace checkbox and click Finish. The project is now imported and
appears in Project Explorer.

Importing Existing Modelled Application Archive (MAA) Files into Workspace
You can import existing Modelled Application Archive (MAA) files into the workspace.

Procedure

1. From the File menu, select Import, and you see the Select page of the Import dialog.

2. Expand the General folder, select Existing MAA into Workspace and click Next.

3. Do one of the following:

● Click on the Browse button for Select root directory for MAA files: to locate other MAA files that
are somewhere on the file system (for instance, in another workspace). This can be used to import
multiple MAA files in one single go.

● Check the radio button for Select MAA file: and click on the Browse button to see MAA files that
have already been archived which you may want to import. This is used to import one single MAA
file at a time.

4. Select the MAA file you want to import, and click Open. The MAA file is now selected.

This does not work if there is already a project of the same name in the workspace.

5. Click Finish. The MAA file is now imported and appears in Project Explorer.
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You can create an MAA file in TIBCO Business Studio for Analysts, save it and then import it
as an existing MAA into TIBCO Business Studio. You can then work on the projects it contains
and save it, and export it to MAA, and then access it again from TIBCO Business Studio for
Analysts.

When importing an MAA created in TIBCO Business Studio for Analysts there is no
destination set on the project and therefore you must set this before you use the project. You
can do this in the following ways:

● Right-click on the project and select Properties > Lifecycle and select the appropriate
destination environment.

● Right-click on the project and select Refactor > Project Lifecycle... to apply the destination
to each process.

Importing Archive Files into Workspace
You can import an archived project into the workspace.

Procedure

1. From the File menu, select Import, and you see the Select page of the Import dialog.

2. Expand the General folder, select Archive File and click Next.
3. In the From archive file: field, use the Browse button to locate the archive file you want to import.

4. In the Into folder: field, use the Browse button to identify the folder into which you want to import the
file. This can be one of your existing projects. You can choose whether to check the Overwrite existing
resources without warning checkbox.

5. Click Finish. The archive file is now imported into the location you have identified.

Importing Nimbus Process Diagrams
Nimbus Process Diagrams can be imported into into an existing TIBCO Business Studio project.

In order to be imported into TIBCO Business Studio, Nimbus Process Diagrams must be exported from the
Nimbus Control application using the Export To Business Studio option in the Nimbus Process Map editor
(or Export Simplified XML in previous versions of Nimbus). See the TIBCO Nimbus Control
documentation for more details.

Procedure

1. Right-click at the process package level of an open project and select Import > Import Nimbus Process
Diagram(s) .

Alternatively, from the File menu, select Import, and from the Select page of the Import dialog expand
the Business Process Management folder, select Nimbus Process Diagram(s) and click Next. This
method will involve additional pages to those in the process below, which are explained in the wizard.

2. On the Import Nimbus Process Diagram(s) page, in the From Directory: field, enter the directory
where you saved your Nimbus Process Diagrams, or use the Browse button to find it.

3. The Nimbus Process Diagrams in the directory you selected appear on the right hand side. Select the
one(s) you require

4. In the Into folder: field, enter the directory in which you want to place the Nimbus Process Diagrams.

5. The Validate Import Files screen shows the validation status of Nimbus Process Diagram files. If the
files are valid (in the expected simplified XML export format and containing only Nimbus simple
diagrams) click Finish. If the files are not valid, you will not be able to finish and need to go back and
re-export the files from Nimbus Control as simplified XML.

61

TIBCO Business Studio™ Modeling Guide



6. The Nimbus Process Diagram files are now imported into the Process Packages folder you specified in 
step 4.

Equivalences between Nimbus Process Diagrams and TIBCO Business Studio BPMN
Processes

Nimbus Export File Process Package (xpdl File)

Process Diagram Business Process per diagram

● One pool and one lane for all activities.

● Diagram documentation URL is added to the
process (visible on the Description property
tab) and to each individual task sourced from
that diagram.

Task Type
● Activity Type:

— Creates a sub-process task for a Nimbus
drill-down activity.

— Parameter mappings are created where the
data created for start/end connections in
the drill-down process have equivalent
named data in the calling process diagram.

— If drill-down activities reference Nimbus
diagrams in other export files then these
should be imported either at the same time
or prior to the referencing file (if you do
not do this, you will get a broken reference
and a validation problem that you then
will have to resolve manually).

● If a non-drill-down activity has a resource then
it is a User Task.

● If a specific Activity Type is selected then an
equivalent BPMN type (Manual, User,
Service,Script, Send, Receive, Reference, Call
Sub-Process, Embedded Sub-Process, Event
Sub-Process) is created.

● If an activity has no resource then it is an
Abstract Task with no resource.

Activity Notes

(Notes bubble)

Text annotation attached to task.

Activity Commentary Start of Task Description.
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Nimbus Export File Process Package (xpdl File)

Statement Links Appended to Task Description (for example,
statements of required compliance with
standards).

Diagram URL
● Added to each task sourced from a given

diagram.

● It is provided in the Process Description
Documentation URL and Activity Description
Documentation URL, and as an activity tooltip
popup including the Documentation URL as a
clickable hyperlink. See Activity Properties for
more information on the Documentation URL.

● You can browse to the original Nimbus
Diagram and documentation.

Activity Resource
● One package participant per unique named

resource.

● User tasks are assigned participant(s) for the
activity resource(s).

Connections
● Treats connections both as routing between

activities and as incoming/outgoing data.

● Multiple connections in the same direction,
between the same Nimbus activities, are
collapsed into a single connection.

● All start connections (connection without
source object) are connected to a single start
event implying that all data is passed and all
connections happen at the start of a process.

● All end connections (connection without a
target object) are connected to a single end
event.
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Nimbus Export File Process Package (xpdl File)

Start/End Connection Label
● For each unique start/end connection label a

formal parameter is created.

● The uniqueness of labels is based only on their
alphanumeric content (white space and
symbols are ignored) and is case-insensitive.

● The formal parameter mode is set according to
whether the label appears on a start connection
(In) or end connection (Out) or both (In-Out).

● All formal parameters are associated in the
start-event activity interface data.

Connection Between Activities Label
● For each unique label that only appears on

connections between activities (not on start/end
connections) a data field is created.

All Connection Labels
● As the connection labels are treated as process

data, interface data associations are added to
user tasks for the data identified by its
incoming / outgoing connections.

● The interface data mode is set according to
whether the label appears on an incoming
connection (In) or outgoing connection (Out) or
both (In-Out).
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Nimbus Export File Process Package (xpdl File)

Connection Commentary
● Added to formal parameter / data field

description

— For multiple connections with equivalent
labels, all commentaries are added.

● Added to sequence flow description.

— For multiple connections between same
activities all commentaries are added.

Exporting TIBCO Business Studio Projects to Archive File
You can export a project from Project Explorer to an archive file.

Procedure

1. In your workspace, make sure you have the project you would like to export selected, and from the File
menu, select Export. You see the Select page of the Export dialog:

2. Expand the General tab, select Studio Projects to Archive and click Next.

3. Select the project you want to archive from the list of projects available. Enter a location in the To
archive file: box. You can use the Browse button to see existing archive files, and either use one of these
or create a new one.

4. A number of archive options are available. Either accept the default settings or adjust them to your
requirements, and click Finish.
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Exporting Projects to a File System
You can export a project from Project Explorer to a file system.

Procedure

1. In your workspace, make sure you have the project you would like to export selected, and from the File
menu, select Export. You see the Select page of the Export dialog:

2. Expand the General tab, select File System and click Next.

3. Browse to the place you wish to save the files and click Finish.

Exporting Projects to Modelled Application Archive (MAA)
You can export a project or multiple projects from Project Explorer to a Modelled Application Archive
(MAA) file.

Procedure

1. From the File menu, select Export > General > Studio Projects to MAA . You see the Export page of the
Modelled Application Archive (MAA)Export Wizard.

2. Select the project or projects you want to export to MAA, and the location you want to export them to
and click Finish. The default project location is Exports/MAA for each project.

Exporting Projects to a Work Data Model
You can export a project to a Work Data Model.

Procedure

1. Select the project in Project Explorer, and right-click Export > Work Data Model Export .

2. The Work Data Model Export Wizard displays. Click Finish to accept the selection of this project, and
the location where the Export will be placed (by default this is in the Exports folder under the project).

Result

For each Work Data Model, TIBCO Business Studio creates a date-time sub-folder to reflect the state of the
exported project at the particular export time.
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Activities

An activity represents work that a company or organization performs using business processes.

See "Activities" in TIBCO Business Studio Concepts.

Creating References
You can create references using the Reference Task gadget, or in the Properties view.

Creating a Reference with the Reference Task Gadget
A gadget is a graphical tool that allow you to easily create references.

Procedure

1. Place a reference task on the diagram.

2. Select the reference task.

3. Drag the Reference Taskgadget to the task to which you want to refer.

If the task to which you want to refer is not in the visible area of the Process Editor, drag the
gadget to the right-hand edge of the Process Editor. After a short pause, the Process Editor
scrolls to the right. Alternatively, select Diagram > Zoom Out until you can see the task to
which you want to refer.

4. Once you create a reference, you can click the Reference Taskgadget to go to the referenced task, or
drag the Reference Taskgadget to create more references:
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Creating a Reference in the Properties View
To create a reference to another task on the General tab of the Properties view for the task, complete the
Referenced Task field by clicking the picker and selecting a task from the list:

After you have a created a task reference, clicking Go To selects the target of the reference task and brings it
into the visible part of the Process Editor (it also displays the Properties view for the task). To return to the
previously-selected task, click  on the toolbar.

Using Request Response Operation with Send and Receive Tasks
To configure a process to receive a request-response message from an external application, and then to
reply to the request, use message events, send and receive tasks, or a combination thereof.

For example:

In this example, because the send task is configured as a reply to the receive task in the Properties view:
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For more information about using message events, see Message Event Implementation.

Creating Scripts
All types of task can have scripts that write information to a destination-specific system. User tasks can
have scripts that are run for example, when the work item is opened or closed.

The Scripts tab allows you to add text that describes these scripts. It is the task of the solution engineer to
translate the outline of the script into a scripting language supported by the selected destination
environment.

Procedure

1. Click the task to which you want to add a script.

2. In the Properties view for the task, click the Scripts tab.

3. The Scripts available are divided into two sets, Process Manager Scripts and Work Manager Scripts.
Open the set you require (if one set is not available to you for this task, it will be grayed out)

4. Click the tab for the desired type of script. Any tabs that have scripts defined have a script icon before
the script name. Tabs with no script defined have an empty script icon. So in the example above, a script
is defined for the Initiate Script and Cancel Script tab.

5. Select Free Text from the Script Defined As list. Describe your script in the area provided. For more
information about how the various types of scripts are implemented, see the appropriate
implementation guide.

Result

You can highlight tasks in a process that contain scripts. Click in the Process Editor for the process. On the

toolbar, you will see a button: 

Click on this to see the dropdown, and select Highlight Activities with Scripts.

This will highlight all activities in a process that contain scripts, and all other activities will be grayed out.
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User Tasks and Pageflow Processes
In addition to creating a standalone pageflow process, you can do other actions from a user task to select or
create a pageflow process.

● Select an existing pageflow process.
● Create a pageflow process that is referenced from the selected user task.
In the runtime environment, the pageflow process is run when the work item associated with the user task
is opened.

When you right-click a user task, the Pageflow menu provides these options:

● Open
 Select this option to open the associated pageflow process in the Process Editor (if a pageflow process
has already been selected for the task).

● Synchronize Parameters
 Select this option if you have made changes to the parameters in the user task, and want the changes
reflected in the corresponding parameters in the associated pageflow process (see Synchronizing
Parameters With a Pageflow Process).

● Generate
 Select this option to generate a new pageflow process that will be associated with this user task. The
parameters associated with the user task are replicated for the pageflow process.

● Use Existing
 Opens the Select Form dialog from which you can select an existing pageflow process.

● Delete
 Deletes the reference from the user task to the pageflow process. The pageflow process itself is not
affected.

Selecting a Pageflow Process
If you have already created a pageflow process, you can select it from a user task.

Procedure

1. Select the user task.

2. Do one of the following:

● On the General tab for the user task, select the Pageflow option and click the picker to display the
Select Pageflow Process dialog.

Expand the projects to select a pageflow process and click OK.
● Right-click the user task and select Pageflow > Use Existing to display the Select Pageflow Process

dialog. Expand the projects to select a pageflow process and click OK.

3. The Pageflow field is automatically completed with a URL that points to the pageflow process (relative
to the Forms special folder). You can open the pageflow process by clicking Open Pageflow Process.

70

TIBCO Business Studio™ Modeling Guide



Creating a Pageflow Process From a User Task
You can create a pageflow process from a user task.

Procedure

1. Select the user task to which you want to associate a pageflow.

2. Right-click and select Pageflow > Generate . The New Pageflow Process dialog is displayed.

3. Confirm the data that you want to associate with the pageflow process and click Next:

● User Task Interface Data
 Select from the process data specified on the Interface tab of the user task. If no explicit process
data is selected on the Interface tab, all process data is available.

● Other Available Process Data
 Select from the process data that is not associated with the user task.

The parameters that you associate with the pageflow process are available to user task
forms after the pageflow process is created.

4. Enter the Label of the process. If you want to use a template to create the process, select the template
and click Finish to create the pageflow process or Next to specify additional options.

Synchronizing Parameters With a Pageflow Process
When a pageflow process is first generated from a user task, a dialog is displayed that allows you to create
the pageflow process with its own set of parameters (either replicating the existing data fields and
parameters of the user task, or a subset thereof).

User tasks in the pageflow process can display forms that utilize these parameters.

If you add or remove new parameters to the user task in the parent process (after the pageflow process is
generated), you can update the list of user task parameters that are known to the pageflow process as
follows:

Procedure

1. Right click the user task, and select Pageflow > Synchronize Parameters . The Synchronize Pageflow
Parameters With User Task dialog is displayed:
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2. Confirm the changes and click Finish. For example, if parameters have been added to the pageflow
process but not the user task, synchronizing deletes them from the pageflow process. If parameters have
been added to or removed from the user task, synchronizing adds or removes the corresponding
parameters in the pageflow.

Result

After synchronizing, the parameters in the Project Explorer listed for the pageflow process should be
identical to the parameters listed for the parent process.

Mandatory Parameters and Pageflow Processes
When a pageflow process has a mandatory parameter, that parameter must have a value before the
pageflow can be considered complete.

This is different to sub-process parameters, where the mandatory flag controls whether mapping to the
parameter is required or optional.

This means that a pageflow process and associated user task are expected to have the same data available.
As a result, mandatory pageflow parameters are mandatory in all user task forms within the pageflow.
However, if this is not the desired behavior, explicitly associate the parameter with the user task in the
pageflow and de-select the mandatory flag.

Resource Patterns and Work Distribution
A number of patterns are available to model how you want work to be distributed to resources. Resources
are the people who carry out the work, and are represented in TIBCO Business Studio by participants. How
these patterns are interpreted depends on your runtime environment, which may not support all the
patterns.

See "Resource Patterns and Work Distribution" in TIBCO Business Studio Concepts.
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Specifying Separation of Duties
Specify that tasks should be considered separate by using the right-click menu on the Process Editor.

Procedure

1. Select the user or manual tasks that you want performed by separate resources (use the Ctrl or Shift
keys to select multiple tasks).

2. Right-click and select Resource Patterns > Create a > Separation of Duties > Group .

3. If you have not already done so, you must assign participants to the tasks.

4. The selected tasks are displayed on the Resources tab in the Properties view:

To see other task groups, click the See all task groups(s) in the process link on the Resources
tab. This displays the Task Groups tab for the process. This shows task groups of which this
task is a member.

Specifying tasks that should be considered separate using the Resources tab

Specify that tasks should be considered separate on the Resources tab for the task.

If you have already set up a task group, the Resources tab shows the groups to which the selected task
belongs.

Procedure

1. Click the Resources tab and expand the Separation of Duties section.

Click the  button to create a new task group. The Select Tasks dialog is displayed.
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2. Select the tasks that you want to include in the group and click OK.

3. Once you have selected the task group members, you can also use the following buttons:

●  Use this button to add or remove tasks to and from the group.

●  Use this button to either delete tasks for the group or delete the group.

To see other task groups, click the See all task groups(s) in the process link on the
Resources tab. This displays the Task Groups tab for the process. This shows task groups
of which this task is a member.

Specifying tasks that should be considered separate using the Task Groups Tab

Specify that tasks should be considered separate on the Task Groups tab for the process. If you have
already set up a task group, the Task Groups tab shows the groups contained in the selected process.

Procedure

1. Select the process in the Project Explorer and click the Task Groups tab.

Click the  button to create a new task group. The Select Tasks dialog is displayed.
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2. Select the tasks that you want to include in the group and click OK.

3. Once you have selected the task group members, you can also use the following buttons:

●  Use this button to add or remove tasks to and from the group.

●  Use this button to either delete tasks for the group or delete the group.

Specifying Tasks That Should be Part of a Retain Familiar Group
Specify tasks that should be part of a Retain Familiar group using the right-click menu on the Process
Editor.

Procedure

1. Select the user or manual tasks that you want to include in the group (use the Ctrl or Shift keys to select
multiple tasks).

2. Right-click and select Resource Patterns > Create a Retain Familiar Group .

3. If you have not already done so, you must assign participants to the tasks.

4. The selected tasks are displayed on the Resources tab in the Properties view:
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To see other task groups, click the See all task groups(s) in the process link on the Resources
tab. This displays the Task Groups tab for the process. This shows task groups of which this
task is a member.

Specifing that tasks should be part of a Retain Familiar group using the Resources tab

Specify that tasks should be part of a Retain Familiar group on the Resources tab for the task. If you have
already set up a task group, the Resources tab shows the groups to which the selected task belongs.

Procedure

1. Click the Resources tab and expand the Retain Familiar section.

Click the  button to create a new task group. The Select Tasks dialog is displayed.

2. Select the tasks that you want to include in the group and click OK.

3. Once you have selected the task group members, you can also use the following buttons:
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●  Use this button to add or remove tasks to and from the group.

●  Use this button to either delete tasks for the group or delete the group.

To see other task groups, click the See all task groups(s) in the process link on the
Resources tab. This displays the Task Groups tab for the process. This shows task groups
of which this task is a member.

Specifing that tasks should be part of a Retain Familiar group using the Task Groups Tab

Specify that tasks should be considered separate on the Task Groups tab for the process. If you have
already set up a task group, the Task Groups tab shows the groups contained in the selected process.

Procedure

1. Select the process in the Project Explorer and click the Task Groups tab.

Click the  button to create a new task group. The Select Tasks dialog is displayed.

2. Select the tasks that you want to include in the group and click OK.

3. Once you have selected the task group members, you can also use the following buttons:

●  Use this button to add or remove tasks to and from the group.

●  Use this button to either delete tasks for the group or delete the group.
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Chained Execution- Multiple Parallel Paths in a Chaining Group
When multiple parallel paths exist in a chaining group, items will be chained in the order they are
scheduled, and not the order of process flow.

For example:

In the example above, User Task 1 or User Task 2 would be performed first. Both would appear in the
relevant user's work list. If User Task 1 was opened first then on completion User Task 2 would be
performed (it would be the only user task in the chained group available at that point). It is likely that
whilst User Task 2 is completed that User Task 3 would be scheduled. This would be performed and then
User Task 4 would be performed last. The user tasks would therefore be performed in scheduled order and
not according to the connections between the user tasks.
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Controlling Flow in a Process

This section describes some of the common tasks that you perform using TIBCO Business Studio to control
flow in a process.

See "Flows", "Loops" and "Gateways" in TIBCO Business Studio Concepts.

Creating a Standard Loop
A standard loop is indicated by a symbol.

Click the Loops tab to set the details of the loop:

Set the following parameters as appropriate for the loop you want to create:

● Test Time
 Select either Before or After. The Before option is equivalent to the programming construct "while":
the expression is evaluated before the activity is performed, and therefore if the expression evaluates to
False, the activity is not performed. The After option corresponds to the programming construct "Do:
while": the expression is evaluated after the activity has been performed, guaranteeing that the activity
is performed at least once.

● Loop Maximum
 Optionally specify an integer to control the maximum number of times the activity is performed. In
the event of conflict between Loop Maximum and the result of the Javascript defined under Script
Defined As, the Loop Maximum will override the script calculation.

● Script Defined As
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 Select one of the following options:

— Free Text
  Allows you to describe how you would like the loop to be tested if you prefer to leave the specific
implementation of the loop expression to someone else.

A BPMN warning is generated if you leave the script area blank. To remove the
warning, enter a text description of the intended script implementation.

— JavaScript
 Allows you to enter JavaScript that will be evaluated for the loop expression.

— Unspecified
 Allows you to specify that there is no expression or description for this loop.

Creating a Multi-Instance Loop
A multi-instance loop is indicated by one of two symbols:

● Parallel multi-instance loop:

● Sequential multi-instance loop:

 

 
Click the Loops tab to set the details of the loop:

Set the following parameters as appropriate for the loop you want to create:

Ordering

Select either Sequential or Parallel ordering. The Sequential option causes the instances of the activity to
occur in succession rather than at the same time. The Parallel option causes the instances of the activity to
occur at the same time.

Flow Condition

This property can be used to mimic the functions of a gateway. Select one of the following options:

● All (perform outgoing flow when all instances complete)  The outgoing flow is processed once after all
activity instances have completed.
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● One (perform outgoing flow once when first instance completes)  The outgoing flow is processed
when the first activity instance completes (existing instances can still be completed but the outgoing
flow is not processed when they complete).

● No Condition (perform outgoing flow for each completed instance)  The outgoing flow is processed
for every activity instance as it completes.

● Complex (behavior defined by Complex Flow Condition)  The outgoing flow is processed for each
instance for which the Complex Flow Condition tab evaluates to true.

Scripts for Multi-Instance

Select Free Text for the Script Defined As field if you want to describe how you would like the loop to be
tested, and prefer to leave the specific implementation of the loop expression to someone else. You can also
select Unspecified if there is currently no condition or description for the loop.

Depending on the destination environment you have selected, JavaScript may be available as an option.
Use this option if you want to enter JavaScript that will be evaluated for the loop expression.

There are three tabs on which you can specify scripts:

Loop Expression
 Specify either a script that evaluates to an integer or a description of the desired script.

Complex Flow Condition
This expression is evaluated if you selected Complex as the Flow Condition.

Additional Instances Expression  
This expression is used for control-flow pattern WCP-15 (additional activity instances may be required at
runtime) when you only need to add instances when the task is complete.
See the table "Supported Control Flow Patterns" in the "Workflow Patterns Reference" appendix of the
TIBCO ActiveMatrix BPM - BPM Concepts guide. If you need to add instances while the task is in progress,
see Adding Additional Instances to a Multi-instance Loop While the Task is Still in Progress.

The additional instances script is evaluated after the last instance completes. If the script evaluation calls
for additional instances, they will be done and the script will be evaluated again once the last additional
instance completes.

If an Additional Instances Expression is specified then this expression must eventually evaluate to zero so
no more instances occur.

Adding Additional Instances to a Multi-instance Loop While the Task is Still in
Progress

This implements control-flow pattern WCP-15—see the table "Supported Control Flow Patterns" in the
"Workflow Patterns Reference" appendix of the TIBCO ActiveMatrix BPM - BPM Concepts guide.

If you have a multi-instance user task and a loop which allows you to generate multiple copies of that task,
if you have concurrent copies of the multi-instance user task, each with multiple instances, and then "add
additional activity instances", the additional instances are added to every copy of the multi-instance user
task.

To do this, you need to execute a script somewhere on a parallel path whilst the loop task is active. The
script can add instances to the loop task using an expression similar to the following:

Process.addActivityLoopAdditionalInstances ("OrderStock",1);

which contains a string for the name of the task (in this example, OrderStock), and an integer for the
number of additional instances required (in this example, 1)..
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If you wish to add additional instances to a dynamic sub-process task, you need to pre-populate the array
that is chosen as the runtime identifier field with the name or names of the sub-process implementation that
you wish to add, as well as any associated arrays used to provide input into the dynamic sub-process. See 
Creating Dynamic Sub-Processes .

You can also add additional instances to a loop in the loop task itself, but only in the task Complete script.

In this example, the task Add parts to order would order an additional item each time it was used.

This workflow pattern specifies that multiple instances of an activity should be created, each instance being
synchronized and able to run concurrently.

See the table “Supported Control Flow Patterns” in the “Workflow Patterns Reference” appendix of the
TIBCO ActiveMatrix BPM - BPM Concepts guide. Note that:

● The number of instances required is known and specified at design time.
● Each task instance has access to all the process data (data fields, parameters, and so on).
● All the instances must be complete before the next task is started.
The following process has three activities:

There can be multiple instances of the Each Direct Debit task. This is indicated on the General tab of the
Properties view:
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The details are specified on the Loops tab:

The Parallel ordering setting and All flow condition means that the activity instances will be performed at
the same time and will be synchronized. The number of instances is set to 3 on the right side of the
Properties view.

Configuring a Task as Automatic Ad-Hoc
The automatic ad-hoc activity allows you to define one or more standalone tasks (with no incoming /
outgoing flow) in a business process that are executed zero or more times during the lifetime of a process
instance. An automatic ad-hoc activity is executed when it becomes enabled by any of the initializer
activities being processed and the transition of the given precondition from false to true.

This feature is not available for pageflows.

You can have a number of ad-hoc activities in a process. Their preconditions determine if and when they
are executed.

Procedure

1. Check the Ad-hoc Activity Marker on the General tab of the properties on a User task or Call Sub-
Process task.

2. Click on Ad-Hoc Configuration Properties. The Ad-Hoc Configuration tab opens.
3. General: optionally select Interrupt main process until completion.

This pauses the main process flow, resuming on completion of the ad-hoc activity. It does not stop you
processing currently active work items or sub-processes, event sub-processes or other ad-hoc activities.
However note that data will not be returned to the process instance until it re-activates.

4. Check Automatic Invocation.
5. Access: in addition to defining whether users have the ability to cancel an ad-hoc activity using a

system action (see System Actions Reference in TIBCO Business Studio Concepts), optionally it is possible
to define whether a user can cancel a specific ad-hoc activity by specifying Organization privileges that
the user must possess.

6. Enablement and Execution: Define the condition under which the activity is enabled and executed
automatically.
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● Initializer Activities: (optional) Select one or more Initializer Activities which are activities which
are in the same process. This activity needs to complete before the precondition is evaluated. This
can be useful for ensuring that the the precondition is not evaluated until the data referenced is
initialized.

● Precondition: Set an optional precondition script that controls enablement of the ad-hoc activity.

For Automatic ad-hoc activity, at least one Enablement condition should be specified: that
is, either the Initializer Activities or the Precondition script must be specified (both can be
specified).

The condition must be a boolean expression which evaluates to true. The condition has to
go from true > false > true in order to retrigger so you must reset the result of the
expression to false before it can become true again.

Configuring a Task as Manual Ad-Hoc
The manual ad-hoc activity allows you to define one or more standalone tasks (with no incoming /
outgoing flow) in a business process that are executed zero or more times during the lifetime of a process
instance. An ad-hoc activity only becomes available for manual invocation when it is enabled via the
preconditions and the user holds the necessary privileges to start and cancel that activity.

This feature is not available for pageflows.

You can have a number of ad-hoc activities in a process. Their preconditions determine when they become
available for execution by permitted users.

Procedure

1. Check the Ad-hoc Activity Marker on the General tab of the properties on a User task or Call Sub-
Process task.

2. Click on Ad-Hoc Configuration Properties. The Ad-Hoc Configuration tab opens.

3. General: optionally select Interrupt main process until completion.
This pauses the main process flow, resuming on completion of the ad-hoc activity. It does not stop you
processing currently active work items or sub-processes, event sub-processes or other ad-hoc activities.
However note that data will not be returned to the process instance until it re-activates.

4. Check Manual Invocation.

5. Optionally check Allow multiple invocations. If you check this, you can manually invoke the activity
more than once after it has been enabled.

6. Access: in addition to defining whether users have the ability to cancel an ad-hoc activity using a
system action (see System Actions Reference in TIBCO Business Studio Concepts), optionally it is possible
to define whether a user can cancel a specific ad-hoc activity by specifying Organization privileges that
the user must possess.

7. Enablement: Define the condition under which the activity is enabled and executed automatically.

● Initializer Activities: (optional) Select one or more Initializer Activities which are activities which
are in the same process. The precondition is not evaluated until one of these has completed.

● Precondition: Set an optional precondition script that controls enablement of the ad-hoc activity.
The automatic ad-hoc activity is invoked every time the precondition is changed from false to true.
So the activity may be invoked many times.

For manual ad-hoc activities, specifying enablement is optional, so it not mandatory to specify
either the initializer activity or the precondition script.
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The condition must be a boolean expression which evaluates to true. The condition has to go
from true > false > true in order to retrigger so you must reset the result of the expression to
false before it can become true again.

Refactoring Ad-Hoc Activities
You can refactor one or multiple ad-hoc user tasks into a sub-process.

You might want to do this with an ad-hoc user task, as certain actions are not available to you on the ad-hoc
user task. However, once you refactor one or multiple user tasks into a reusable sub-process, more actions
are available. For example, you can add a deadline to a user task within an ad-hoc reusable sub-process, but
not to an ad-hoc user task.

Note that when refactoring a single ad-hoc user task, the re-usable sub-process will inherit the ad-hoc
configuration. When refactoring multiple ad-hoc user tasks the re-usable sub-process will contain multiple
user tasks which retain their ad-hoc configuration.

Procedure

1. Select an ad-hoc user task (or multiple ad-hoc user tasks), right-click and select Refactor > Extract Into
New Sub-Process.

2. Follow the steps in the wizard to refactor. The ad-hoc user task or tasks will now be a reusable sub-
process.

Exclusive Event Based Gateway Example
An example of an Exclusive Decision/Merge (XOR) Event Based Gateway that provides an example for
workflow process pattern 16, Deferred Choice.

Workflow process pattern 16, Deferred Choice, states:

A point in a process where one of several branches is chosen based on interaction with the operating
environment. Prior to the decision, all branches represent possible future courses of execution. The decision
is made by initiating the first task in one of the branches i.e. there is no explicit choice but rather a race
between different branches. After the decision is made, execution alternatives in branches other than the
one selected are withdrawn.
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The state remains on the Exclusive Event Based Gateway until a signal or message is caught, or the timer
expires.

When the event occurs, the state is pulled from the Gateway to the relevant task, and this removes other
paths from possible operation.

It is possible to have multiple paths, with various timers, messages and signals, but the Gateway only
actions the first event to occur.
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Events

This section describes some of the common tasks that you perform using BPMN events.

See "Events" in TIBCO Business Studio Concepts.

Creating References Between Throw and Catch Events
As an alternative to creating references between throw and catch events in the Properties view, TIBCO
Business Studio provides graphical tools called gadgets that allow you to easily create references.

The example in this section shows throw and catch signal events, but the same procedure applies to all
throw and catch events.

Procedure

1. Place the throw and catch events on the diagram.

2. Select the throw event.

3. Drag the event reference gadget to the desired catch event.

4. Once you link a throw and catch event, you can click the event reference gadget to go to the catch event,
or drag the event reference gadget to select additional catch events:

Timer Event Rescheduling
You can reschedule the timeouts of timer events on user tasks (including the work item deadline). This can
be achieved by selecting timers to reschedule from a non-cancelling signal event on the same user task.

Timer events that have already timed-out will not be rescheduled.

A catch signal event attached to a user task, that is configured as Continue task when signal is caught
allows selection of timer events to reschedule one of the following:

● all

● The Timer currently set as Activity deadline

● one or more explicitly selected timers

When a timer event is selected for reschedule in any one of the above ways then the user must define a
reschedule timer script on the timer event's General properties tab.
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In the example below, the process has a user task with two timers, Deadline and Nudge. When "Unexpected
Delay" is triggered, the Allow_User_More_Time signal is thrown and this explicitly reschedules the
Deadline timer by adding an extra day to the current Deadline timeout.

The Properties page for Catch: Allow User More Time looks like this:

The Properties page for Deadline looks like this:

Configuring Timer Event Scripts
You can specify that a script is executed for a start timer event or an intermediate timer event (either inflow
or on a task boundary).

For example, the following intermediate timer event has been placed on a task boundary:
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In the Properties view, you can choose a script type from the Script Defined As list:

Depending on the destination environments selected, there can be other script types in the Script Defined
As list.

Select one of the script types:

● Free Text
 If you want to leave the implementation of the script for the solution designer, you can select Text and
use this area provided to describe the desired behavior for the script.

● Constant Period
 This allows you to specify the timeout period after the event is initiated using the following time units:
Years, Months, Weeks, Days, Hours, Minutes, Seconds, Micro Seconds.

● JavaScript
 This script type allows you to enter JavaScript statements in the space provided. For more
information, see the appropriate implementation guide.

The JavaScript script type is not available in the Business Analysis capability.

● Unspecified
 This means that no description or script is supplied.

Catch Signal Events
In BPMN, when an event on the boundary of a task is triggered, the task is cancelled and the alternative
flow from that event is followed.

For example:
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In this example, if the signal event is triggered, the task to which it is attached is cancelled and the sequence
flow to Task 2 is followed.

Throw and Catch Signal Events
With throw/catch signal events, an in-flow signal event broadcasts a signal, and if there is an active task with
a signal event on the task boundary, that event "catches" the signal, and generally follows the exception
path.

Signal events can be local or global. See "Signalling" in the TIBCO Business Studio BPM Concepts Guide.

Local signal events can be used for triggering event handlers, task cancellations and to halt and resume
parallel flows.

Global signal events are thrown and caught across process instances allowing processes to collaborate
with each other. They are only available for an event sub-process/handler. See "Signalling" in the TIBCO
Business Studio BPM Concepts Guide for information about defining signal correlation data that will identify
the process instance waiting for the global signal.

● Catch Global Signals have event handler controls similar to those of catch message event handlers and
the behavior is the same as that of catch message event handlers.

● You can drag and drop a global signal onto a process to create throw / catch events.

● A catch signal can cancel the task it is attached to or, for user tasks, can allow the task to continue. If they
are set to "continue" they cannot have an outgoing flow but they can map data into the task that they are
attached to and also reschedule timers attached to the same task.

A Signal is transient: when it is thrown, if there is nothing to catch it at that moment, it is discarded. It is not
stored for later use.
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You may specify a signal name with a throw signal event. With a catch signal event, a signal name is
optional:

● If a catch signal event has no signal name specified, it catches any thrown signals in the process (while
the task it is attached to is active).

● If a catch signal event has a signal name specified, it only catches signal events that throw the named
signal.

When you specify signal names in the Properties view for signal events, you can use content assist. This
means for example, that if you have entered SIGNAL1 for a throw signal event, when you specify the
signal name for the catch signal event you can press Ctrl+Space and the available signal names are
displayed from which you can select one.

You can define whether you want to update a scheduled work item from a non-cancelling signal event.
Select from a pair of radio buttons directly beneath the signal name from the Properties view of a catch
signal event attached to a task boundary:

● Cancel task when signal caught
● Continue task when signal caught

Use the Map from Signal tab to map from the throw-signal's payload data (listed in its interface tab) to
the data associated with the attached user task.

See the example in Message Event Handlers in Business Processes which demonstrates the use of event
handlers and non-cancelling signal events to update work item data.

A signal end event functions like any other inflow signal event, except that when one fires, if there are
more tasks that need to complete as the result of an exception flow, the outstanding tasks complete; if there
are no more tasks that need to be completed, the process ends.

Throw and Catch Error Events
An error event attached to a task boundary can be set to catch any error, or errors thrown by the task to
which it is attached.

For example:

● when attached to a web service task, you can configure the catch error event to catch any WSDL fault
associated with the web service operation that is invoked by the service task.

● when attached to an email service task, you can configure the catch error event to catch emails when the
email server is unavailable:
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When attached to a call sub-process activity or an embedded sub-process task, the event can catch errors
thrown by any of the following:

● Activities within the sub-process.

● End error events

● Process interface error events (if the call sub-process activity references a process interface rather than a
process)

● Any other error throwing activity executed within the sub-process (including its sub-process tasks). This
includes activities whose errors cannot be caught directly by attaching the error event (for example,
throw message intermediate event and end event that invokes a one way message).

Configuring Error Events
Error events are configured in the Properties view.

For a catch error event, you can do the following:

● Catch All Errors
 (default) Catches any error thrown by any event.

● Catch Named Errors
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 To do this, click Select Error and select the Select Unspecific Error By Name Only checkbox. The
dialog lists the catchable error codes. Select the error codes that you want to catch. This configures the
event to catch the selected error from any activity.

● Catch Specific Errors from Specific Activities
 Click Select Error and deselect the Select Unspecific Error By Name Only checkbox. The dialog lists
events and activities that throw error codes. Expand the desired event or activity to catch a specific
error thrown by a specific activity. For example:

● Catch Specific WSDL Fault
 WSDL faults are caught in the same ways as other errors (either named WSDL faults, or specific errors
from a specific service task). For example:
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In this example, the catch error event is attached to the service task. The error is thrown by a process in
a different project (see Creating References in the Project Properties).
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Fixing Invalid Error Events
After configuring a catch error event, the event that throws the error code is deleted, invalidating the catch
error event as shown in the Properties view.

Other causes of invalid error events include:

● The event is detached from the task.

● The activity no longer throws the given error.

● The activity that throws a specific selected error is no longer processed as a result of the task the to
which the event is attached.

To fix the error event, click Select Error. If possible TIBCO Business Studio identifies the closest match to
the originally selected error code. Select an error code and click OK.

Error Data Mapping
You can map error parameters to process data from the Map From Error tab.

For example:

The process data available on the right side of the tab is either all data or a subset of data as specified on the
selection on Interface tab.

The content of the left side of the Map From Error tab depends on the configuration of the General tab:

● Catch All / Catch Named Errors
 Only the automatically provided error code can be used for mapping as shown in the previous
example. Typically, this error code is mapped to a process text data field or parameter for display to the
user. At run time, the text data field or parameters is populated with the error code name when the
error is caught.

● Catch Specific Error Thrown By Sub-Process End Error Event
 All parameters with a mode of Out or In/Out that are associated with the throw error end event (on
the Interface tab) are displayed for mapping:
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● Catch Specific WSDL Fault
 WSDL fault message parameters are displayed on the left side and can be mapped as normal.

Compensation Events Configuration
Compensation events are used to reverse the effect of previously executed tasks.

For example:

In this example, if the credit/debit fails, a compensation event is thrown. The target of the event is the
Credit Acct task, which catches the error and proceeds with the Re-credit Acct task. In the Properties view
for the Throw Compensation end event, you can press Ctrl+Space to see a list of tasks from which you can
select the target of the compensation. Alternatively, you can compensate all previously executed tasks by
not specifying a target for the compensation:
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Message Event Implementation
TIBCO Business Studio supports the following Message Exchange Patterns (MEPs):

MEP Description How to Model

Receive one-way
request from
external
application

The process receives a message from
an external application and does not
send a response.

● Start message event (if the process is
started upon receipt of the message)

● Intermediate catch message event

● Receive task

See To Receive a One-Way Request
Operation .

Send one-way
request to external
application

The process sends a message to an
external application but expects no
response.

● End message event

● Intermediate throw message event

● Send task

See To Send a One-Way Request
Operation and Creating References .

Receive request-
response message
from an external
application

The process receives a request
response message from the external
application, and replies to the request.

● Start message event

● Intermediate catch message event, or

● Receive task

paired with

● Message end event

● Intermediate throw message event, or

● Send Task

See To Receive a Request-Response
Operation and Using Request
Response Operation with Send and
Receive Tasks .

Send request-
response message
to an external
application

A client (service consumer) sends a
request message to the web service
(service supplier).

The web service (service supplier)
returns a response message to the
client (service consumer).

The web service may optionally return
a fault message in the event of an error.

Service task.

Whether a message event performs a one-way operation or is part of a request-response operation is
configured on the Properties view for the events.
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To Receive a One-Way Request Operation
To configure an event to receive a one-way request operation, use either a start message event or a catch
message event.

The solution designer is responsible for configuring the event (for example, selecting a web service and
mapping the input parameters to the process).

A receive task can be used in place of a catch message event .

To Send a One-Way Request Operation
To configure an event to perform a one-way operation, use either a end message event or a throw message
event.

In the Properties view, ensure that Send One Way Request is selected:

● Throw message events are set to send one-way requests by default.

● A send task can be used in place of a throw message event.

To Receive a Request-Response Operation
There are several options for receiving a request-response operation.

For example, a message start event can be paired with a message end event as follows:

In this example, the end message event is configured as follows:
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End message events are set to reply to upstream requests by default. In addition, if there is only one
upstream request (for example, a start message event), the end event is automatically configured to reply to
that request.

A send task can also be paired with a start message event as follows:

The tasks between the request and reply parts of the process should complete quickly enough that they do
not cause the service calling the process to timeout. For this reason, avoid putting user tasks or manual
tasks in between the request and reply parts of the process.

Event Handlers
Event Handlers are supported in Business processes and Pageflow processes. You can use event handlers to
execute a flow that is separate from the main flow of the process (for instance to update process data used
by the main flow).

See "Event Handlers" in the TIBCO Business Studio Concepts Guide. See also "Event Sub-Processes" in the
TIBCO Business Studio Concepts Guide

Signal Event Handlers
An event handler flow can be triggered from within the same process instance using signal events. The
signal event handler flow can be executed asynchronously or synchronously with the invoking flow (the
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invoking flow generally waits at the throw-signal event for the completion of the event handler flow before
continuing). This allows process designers to define and re-use complex sets of repeatable activities.

This could be especially useful when considering the additional tasks and exception handling that are
required by global data updates because each update on a single piece of global data could involve several
tasks (one to do the update, plus exception handling if the update fails). Therefore if many updates are
performed on global data, then the process could soon become very cluttered with global data handling
activities reducing the visibility of the actual business process tasks. Use of the signal event handler could
greatly reduce this type of problem by allowing the process designer to implement the set of tasks to
update a global data item and handle exceptions only once and re-use that from many places in the process.

The catch signal event Properties tab contains Event Handler configuration controls (which are shown only
when the catch signal is an event handler (with no incoming flow).

The default setting is Wait at the invoking signal until event handler flow is complete. This setting
controls whether the throw signal's outgoing flow is processed after the event handler flow. If you unset
this flag it can be processed without waiting.

Note that:

● Signal event handlers can also be used within embedded sub-processes. Place the signal event handler
inside the embedded sub-process. This will ensure that the embedded sub-process local data is in scope
of the signal event handler flow.

● Signal event handlers can be used within pageflow processes.

● Case data signal event handlers allow a process to subscribe to a particular case object that the process
uses. The process will then be notified if that case object is modified, and can take appropriate action to
respond to the change. See "Notifying a Process That a Case Object It Uses Has Been Modified" in the
TIBCO ActiveMatrix BPM Case Data User's Guide for more information.

Using the Cancellation Event Handler
You can execute a cancellation event handler flow (only one per process) to manage the cancellation of a
process and its sub-processes.

Procedure

1. How to cancel a sub-process task: Attach a catch intermediate event to a call sub-process task in your
main process, with a trigger type of Catch Signal. The Catch Action should be Cancel task when signal
caught.
Alternatively, you cancel a process sub-process task with a task boundary event as follows:
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Message:

Timer:

Trigger:

The tree of subprocess instances that were instantiated from a sub-process task are cancelled from the
bottom up. If the sub-processes need to execute compensation actions to close down gracefully they can
do so using Cancellation Event handlers.

2. The Sub-Process Cancellation event handler: Add activities to perform any actions required prior to
the final sub-process cancellation. A common pattern would be to use throw-catch compensation as in
the example below, where there is an intermediate catch event with trigger type Catch Compensation on
each task in the a sub-process which requires compensation events. Compensation events execute their
actions if only when the the task they're attached to has been executed, thus there is not a need to
manually conditionalize compensating tasks depending on progress throw the main process flow.

Cancel event handlers are only executed for process-driven cancellation (not for user/API-
driven process cancellations).

The cancel event handler does not have to trigger compensation event handlers. It may either
generate signal events into the main part of the process or just perform the compensatory
actions directly.
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● The sub-process can also invoke another sub-process (and so on) with more cancel event
handlers.

● There does not have to be a cancel event handler in each sub-process if it is not required.

● Cancellation event handlers will not be executed when a process instance is cancelled
through Process Manager API, either from an external application or from the Openspace
client.

● If a cancellation event handler fails then you will receive an audit event and should be able
to recover from an halted state.

Event Handlers in Pageflows
You could use the event handler to update the process data. Another way to use it would be to add to the
runtime identifier array and associated input mapping arrays to add instances to a dynamic sub-process
invocation.

In this example, a pageflow process is used to manage an order request. The event handler is used to
update exchange rate information regularly. This updated exchange rate information is then used as input
to the task Issue Invoice.
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Message/Global Signal Event Handlers in Business Processes
Message event handlers allow you to process a separate flow in an existing process instance via a web-
service operation. As with any incoming message activity, correlation to a process instance has to be
configured.

Catch Global Signals have event handler controls similar to those of catch message event handlers and the
behavior is the same as that of catch message event handlers.

Blocking and Non-Blocking Message Handlers

You can configure what happens when an event handler is triggered prior to completion of the flow from a
previous triggered instance.

They can be one of the following:

● Blocking: The Serialize concurrent flows for this event handler option means that further event
triggers are queued until an existing event handler flow completes (unless the main process flow
completes).

● Non-blocking: The Allow concurrent flows for this event handler option means that if the event is
triggered multiple times, the flow from each can be processed in parallel.

The configuration options are shown under Event Handler on the following screenshot:

Initalizing Event Handlers

You can specify a list of activities after which the event handler will be initialized (or reset if already
initialized). You need to do this because if the value of correlation data associated with the event handler is
changed during the life of the process then existing event handlers will not be triggered according to the
new correlation data value unless they are initialized.

You also need to do this if the initial correlation values are set in the complete script of the message start
event or any other script activity, as opposed to initializing on the message start event mapper.

You will also need to do this if the correlation data required for the event handler is not explicitly initiated
in mapping on all process start activities (otherwise the event handler will be initialized when correlation
data may not yet have been set).

Select initalizers for the event handler using the Initalizers: selection under Event Handler (see screenshot
above). You can select any task, embedded-sub-process or event activity (except those attached to task
boundary, or events that are themselves event handlers). This includes activities on event handler outgoing
flows.

If you do not specify any activities then the event handler will initialize during processing of the first start-
activity but before the start-activity's Complete script. For this to happen one of the following must happen:
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● The correlation data associated with each event handler must be initialized in correlation data mappings
in each start activity.

● For any event handlers in processes with non-message start activities (such as sub-processes) you must
explicitly state the activities after which the event handler(s) are initialized. Once any activities are
explicitly stated in this way, then the event handler will only be initialized after those activities
complete .

Even if the correlation data is initialized in the Complete script of a start activity, if you wish an event
handler to initialize correctly you must use this method of explicitly stating the initialize-after activities
on each event handler (that is, if the event handler is to be initialized at start of a process instance then
the start activity must be explicitly stated).

Example: Using Event Handlers in a Business Process

The following simple example covers updating work item data using an event handler and a non-cancelling
signal event.

In this example, a business process is used to manage a request. The event handler is used to update
information related to the request . This updated information is then used as input via a non-cancelling
signal event to the task Register Request.

Migration and Upgrade when using Event Handlers
There are certain issues regarding event handlers that you should be aware of when migrating and
upgrading.

Migration:

See Design Considerations for Process Migration for information on process migration considerations when
using event handlers.

Upgrade:

Adding, deleting or modifying event handlers from which web-service operations are generated affect the
interface and therefore prevent upgrade, but subsequent event handler changes are valid. See "Application
Upgrade" in the TIBCO Business Studio BPM Implementation Guide for more guidelines.
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Process Data

This section describes how to use data that is used in processes such as data fields, parameters, and
participants.

Adding Data Fields or Parameters to a Package or Process
You can add data fields or parameters to a package or process in two different ways, in the Properties view
provided when the Parameters or Data Fields folder is selected in Project Explorer (this method is better if
you need to create several data fields or parameters) or using the wizard to create one at a time.

See "Data Fields and Parameters" in the TIBCO Business Studio Concepts Guide.

You can add data fields or parameters to a package or process:

● in the Properties view table provided when the Parameters or Data Fields folder is selected in Project
Explorer (this method is better if you need to create several data fields or parameters).

See Using the Properties View to Create a New Data Field or Parameter

● using the wizard to create one at a time.

See Using the Wizards to Create a New Data Field or Parameter

See Associating Participants with Activities for information on how to highlight all the tasks in a process
that have a particular data field or parameter assigned to them.

See Constraints on Field or Parameter Values

Using the Properties View to Create a New Data Field or Parameter
You can create a new data field or parameter in the Properties view.

Procedure

1. In the Project Explorer, expand the package or process where you want to add a data field or parameter.

If the Data Fields folder is empty under a package, it will be hidden by default. This is because the
preferred usage is to define Data Fields at the Process level.

If you want to show the Data Fields folder under a package, regardless of whether it is empty
or not, then you need to go to Project Explorer, and click the View Menu icon in the top right
corner, then select Customize View. You can then deselect BPM Package Data Fields on the
list of filters which are set.

2. As appropriate, click Data Fields or Parameters folder in the Project Explorer. If you need to add a Data
Field at the Package level, select New > Data Field as described in Using the Wizards to Create a New
Data Field or Parameter . The Properties view is displayed.

3. Click the plus icon. A new data field or parameter is added. As appropriate, modify the properties.

Using the Wizards to Create a New Data Field or Parameter
You can create a new data field or parameter using the wizards provided:

Procedure

1. In the Project Explorer, expand the package or process where you want to add a data field or parameter.

2. As appropriate, right-click Data Fields or Parameters and select New > Data Field or New >
Parameter . The New Data Field or New Parameter dialog is displayed.
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If you start this wizard from the File > New menu, the first dialog is the project and package
dialog, where you must specify a valid project and package. This dialog is not displayed if you
right-click at the process level to start the dialog; however you can click Back to display it.

3. Specify a label for the data field or parameter; you cannot specify leading or trailing spaces.

4. For parameters, specify the following:
Option Description

Mandatory (Parameter only) Select this checkbox to specify that the parameter must be present when
the process is started.

Read Only  Select this checkbox to specify that the value of the data field or parameter cannot be
modified after it is created.

Mode  (Parameter only) Select whether the parameter will be an input (In) output (Out) or both
(In/Out).

The parameters specified on the Interface tab for a user task are from the
perspective of the form, not the user. This means that input parameters are sent
to the form by the process, not the user. Output Parameters are sent to the form
by the user.

You must provide an input mapping when the process is called as a
subprocess.

5. Specify the type of data field or parameter you want to create:
Option Description

Basic Type  If you select this type, you can choose from Text, Decimal, Integer, Boolean, Date,
Time, Date Time or Performer. For more information about using performer data
types, see the appropriate implementation guide.

If you need to create a Text field of unlimited length, ensure that the Length
field is empty. If you wish to limit the number of characters enter the
appropriate numeric value.

The value of unmapped Basic Type parameters have the following defaults:

● Text: null

● Boolean : false

● Integer/Decimal : 0

● Date / Time / DateTime : now (time of process instance creation)

Initial Value For data fields, you can optionally specify an Initial Value by clicking in the provided
text entry area and entering a value. For arrays, you can add more than one value. You

can add rows by clicking the  button. You can also delete rows by clicking the 
button.

Allowed
Values

For parameters, you can optionally specify the permitted input values (values that
may be supplied by application starting an instance of the process). You can add rows

by clicking the  button. You can also delete rows by clicking the  button.

Declared
Type

This option allows you to select from the declared types that you have already
defined.

External
Reference

Allows you to refer to a business object defined in the Business Object Modeler.
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6. Select whether you want the data field or parameter to be an array. Selecting the Array checkbox creates
an array of the Basic Type that is selected. For example, if you select the Array checkbox and Text, you
are defining the data field or parameter as an array of Text values.

7. Click Finish to create the data field or parameter, or click Next to specify a documentation URL,
description, or extended attributes.

8. The Documentation Url and Description fields allow you to specify supplementary information about
the data field or parameter that you have created.

9. The Extended dialog allows you to specify extended attributes.

The parameter that you created appears in the Project Explorer.

Constraints on Field or Parameter Values
If you place any constraint on the possible values of a data field or a parameter of any Basic Type, that
constraint is ignored at runtime. This is because BPM’s Process Engine cannot enforce these constraints.

This section applies only if one of the destinations for your process is set as BPM.

For example:

● If an Integer or Decimal field has its Length set to 9, a warning is displayed that format restrictions are
not enforced, and at runtime you can still assign a value with more than 9 digits.

● If a Decimal field has Decimal Places set to 2, a warning is displayed that format restrictions are not
enforced, and at runtime you can still assign a value with 3 decimal places.

● If a Text type data field has its Length set to 50, you can still assign a value with more than 50 characters.

Note that in the case of the Text field, no warning is displayed.

You can produce the same effect as limiting the value of the field or parameter by using a BOM data type
defined with the restricted values you need.

Adding Data Fields to an Activity
You can create a new data field for an activity:

Procedure

1. Select the activity for which you want to create a data field.

2. On the Properties view, click Data Fields.

Activities that do not support activity-level data fields (such as gateways) do not have a Data
Fields tab on their Properties view.

A validation error is displayed if you define a data field for an activity on the Data Fields tab,
but the destination environment selected for the parent process does not support activity-level
data fields for that activity type.

Click . A new data field is added.

3. Modify the data field’s properties as appropriate.

Result

You can only assign a value to an activity-level data field by using the Scripts tab on the activity. See the
appropriate implementation guide for more information.
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● The process begins with a start message event (the process is started upon receipt of a one-way message
from an external web service). The business analyst decides whether elements within the incoming data
from the web service can be used to uniquely identify instances of this process. If the incoming data can
be used to identify the process (later on in the process when there are incoming messages), the business
analyst creates a correlation data field (for example, OrderRef), and associates it with the start event on
the Interface tab.

● After the user task, the receive task (Receive Authorization) waits for the correct incoming
authorization. To do this, the business analyst associates the OrderRef correlation data field with the
Receive Authorization task. When an incoming message is received, the incoming data is compared to
the correlation data to make sure that it applies to that process instance.

After creating correlation data fields, and associating them with the relevant events or tasks, the correlation
data must be mapped with the incoming data. This is the job of the solution designer. For more
information, see the appropriate implementation guide.

Creating Correlation Data
Correlation data must be used to ensure that each incoming message is received by the process instance to
which it applies. You can create correlation data fields in a number of ways.

See "Correlation Data" in the TIBCO Business Studio Concepts Guide.

You can create correlation data fields in the following ways:

● using the Properties view table provided when the Correlation Data folder is selected in Project
Explorer (this method is recommended if you need to create several data fields or parameters).

● using the wizard available either from the Project Explorer or from the File menu.

● refactoring an existing data field into a correlation data field (right-click the data field and select
Convert to Correlation Data).

● copying a data field and pasting it under the Correlation Data folder in the Project Explorer.

Creating Correlation Data Using the Properties View

Procedure

1. In the Project Explorer, expand the package or process where you want to add a correlation data field.

2. Click Correlation Data in the Project Explorer.

The Properties view is displayed.

Click . A new correlation data field is added.

As appropriate, modify the properties.

To prevent accidental reassignment of correlation data fields, they are set to read-only by
default. If you want to assign a value to correlation data that does not come from an incoming
message, deselect the Read Only checkbox.
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Result

See Associating Correlation Data with an Event or Task to assign correlation data to a start message event,
catch message event, or receive task.

Creating Correlation Data Using the Wizard

Procedure

1. In the Project Explorer, expand the package or process where you want to add a data field or parameter.

2. Right-click Correlation > Data and select New > Correlation Data . The New Data Field dialog is
displayed.

If you start this wizard from the File > New menu, the first dialog is the project and package
dialog, where you must specify a valid project and package. This dialog is not displayed if you
right-click at the process level to start the dialog; however you can click Back to display it.

Result

For information about how to complete the remainder of the fields in the wizard pages, see Using the
Wizards to Create a New Data Field or Parameter (the properties of a correlation data field are exactly like
those of a standard data field).

The correlation data that you created appears in the Project Explorer.

If a correlation data field has data that you want to continue to use in your process, but that you no longer
want to use for correlation, you can convert the correlation data field to a "standard" data field, by right-
clicking it and selecting Convert Correlation Data to Data Field.

See Associating Correlation Data with an Event or Task to assign correlation data to a start message event,
catch message event, or receive task.

Associating Process Data with Events and Tasks
There are many reasons to associate process data with tasks or events. For example, data field needs to be
displayed in a form or a process cannot be started unless a particular parameter is passed to a start event.

Using Drag and Drop to Associate a Data Field or Parameter with an Activity

You can drop process data onto a blank part of the process to create a new user task with the associated
process data. For more information, see Using Participants to Create Tasks .

Procedure

1. In the Project Explorer, click the data field or parameter you want to associate with your activity,
holding down the mouse button, drag the pointer to the user task and release the mouse button.

You can select multiple data fields or parameters for drag and drop operations using the Ctrl
(for single selection) or Shift (to select a range) keys.

2. A menu is displayed with the following options:

● Add Data To View And Assign
 Selecting this option adds the process data as an In/Out parameter on the Interface tab. This
means that in the runtime environment, users will be able to display the associated form to view
the field and also to assign new values to it.
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● Add Data To View
 Selecting this option adds the process data as an In parameter on the Interface tab. This means
that in the runtime environment, users will be able display the associated form to view the field,
however they can not assign new values to it.

● Add Data To Assign  
Selecting this option adds the process data as an Out parameter on the Interface tab. This means
that in the runtime environment, users will be able display the associated form to assign new
values to the field.

Using the Interface Tab to Associate a Data Field or Parameter with an Activity

Procedure

1. Select the event or task.

2. In the Properties view, click the Interface tab.

3. Select whether you want the visibility of the event or task to be private or public - see Setting Event and
Task Visibility (Private and Public).

4. Choose between the following:

● Select the checkbox No interface data association required if you do not want to associate process
data with the event or task. This will delete any associations that already exist.

Usually if no data is explicitly associated with an event or task, then all available data is
implicitly associated. Selecting this option prevents this, which can be useful for example
when you wish to define an incoming message event with no parameters, even though
the process already has formal parameters for other reasons.

● Click  to select the process data that you want to associate with the event or task. The Select
Data Field or Formal Parameter dialog displays the list of available process data:
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● By default all process data is available to a task. When you explicitly associate process
data with an event or task, only the process data you associate with the event or task
can be used by that task.

● The process data displayed depends on what type of event or task is selected. Most
events and tasks can have both data fields and formal parameters associated with
them, however receive tasks and events of type None can have only formal
parameters associated with them. End events of type Message can only have formal
parameters if the selected WSDL has both input and output parameters.

5. The process data you select is added to the table of data. Select whether you want the data to be
mandatory.

The mandatory setting on the Interface tab for a formal parameter overrides the mandatory
setting in the Properties view for the formal parameter. This allows complete freedom in
designing the process - you can define a formal parameter as mandatory in one place in a
process, and optional in another.

Use the space provided if you want to add an optional usage description of the process data. Selected
parameters also display their mode (In, Out, or In/Out). You can change the mode by selecting from the
drop-down list.

Associating Correlation Data with an Event or Task
Catch message events and receive tasks must have correlation data associated with them. Message start
events can optionally have correlation data.

For more information about correlation data, see "Correlation Data" in TIBCO Business Studio Concepts.

If you are configuring a message start event, and do not want to use correlation data with the event, select
the No correlation data initialization required check box in the Correlation Data section of the Interface
tab. If you select this check box, you must ensure that correlation data is initialized (for example, using a
script) before it is required in the process.

By default, all correlation data is associated with an event or task, but you can explicitly associate only
selected correlation data as described here.

Note that if there are no active process instances that match the correlation data when the message is
received, the default behavior is to not reply to the message until a process instance that matches the
correlation data become available (you can also set an optional correlation timeout period (see step 6
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below)). However, you can also specify that if a process instance with matching correlation data is not
found, to immediately reply to the message. This is accomplished using the Correlate Immediately option --
see Specifying Correlate Immediately.

Procedure

1. In the Process Editor, select the event or receive task.

2. Select the Interface tab.

If the Interface tab does not display the Correlation Data section, make sure that the event or
task you have selected is one of the types listed previously. Other types of events or tasks do
not require correlation data and therefore do not display this section on the Interface tab.

3. In the Correlation Data section, click .

4. On the Select Data Field dialog, select the correlation data you want to associate with the event or task,
then click OK.

5. In the Correlation Data section, select the mode of the correlation data.

Depending on the type of event or task, TIBCO Business Studio provides appropriate defaults.
For example, start message events are usually where correlation data is initialized, so the
default mode for start message events is Initialize.

● Correlate - (Intermediate Catch Message Event and Receive Task only)  The specified incoming data is
compared to that of existing process instances to ascertain the target of the request.

● Initialize - Specifies that the correlation data is expected to receive its value from the incoming
data. For a start message event, a process instance is started, then the correlation data field is
initialized with a value from the incoming data.

● Join - (Start Event or Received Tasks without incoming flow only)  Causes the correlation data (mapped
from the input data) to be compared to the correlation data for any existing process instances. If no
matching process instances are found, a new process instance is started. If the correlation data
matches that of an existing process instance, the request is directed to that instance (a new process
instance is not started).

6. Optional: If you want to configure the timeout of the correlation event, click the Resource tab. Expand
Correlation Timeout and define the timeout you require. The correlation timeout is calculated from the
time the BPM receives the message.

You may want to configure the timeout of the correlation event to avoid a problem of either:

● an event that should correlate to an earlier process instance that does not correlate, sits
waiting and then correlates with a later process instance with the same correlation data.

● an event that does not correlate immediately and waits in a queue, potentially
permanently, using up resources unnecessarily.

Specifying Correlate Immediately
The Correlate Immediately option causes an immediate reply to a message if there are no active process
instances with matching correlation data when the message is received.

A process instance with matching correlation data may not be available because the process instance does
not exist, or because it is currently halted or suspended. In these situations, specifying the Correlate
Immediately option results in:

● A response is immediately returned to the sender indicating that no process instance with matching
correlation data was found, or that matching process instances were found but are in a non-running
state (halted or suspended).
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● Correlation will still occur at a later time when the process instance with matching correlation data is
available and running.

Any customer-developed user interfaces receiving the response is required to interpret the additional
response information in order to inform the end user that the update has been received and will be
processed later when the process instance is active.

Procedure

1. In the Process Editor, select the event or receive task.

2. Select the General tab.

3. In the Implementation Details section, select the Correlate Immediately check box.

Setting Event and Task Visibility (Private and Public)
The visibility of an event or task (whether it is private or public) controls whether process information (such
as required parameters) is available to an external process or application.

Setting the visibility to public results in a subset of events or steps that are then available to external
processes or applications.

The runtime effect of this setting is entirely destination specific.

For each event or task, you can specify a list of expected input fields (on the Interface tab), and define the
URL of the document describing the purpose of the public event or task (on the Description tab).

By default, events and tasks in a process are private; in a process interface, they are public. If you want to
change the visibility of an event or task:

Procedure

1. Select the event or task.

2. On the Interface tab, select the visibility (Private or Public).

Click  to add parameters to the event or task. Use the Mandatory checkbox to specify parameters
that must be present.

3. (Optional) Select the Description tab. Enter a URL that provides documentation describing how the
event or task is used.

Using Process Data to Create Tasks
If you have created data fields or parameters, you can drag them to a blank area of a process to
automatically create a user task.

Procedure

1. In the Project Explorer, click the data field or parameter, and holding down the mouse button drag the
pointer to a blank part of the process and release the mouse button:

You can select multiple data fields or parameters for drag and drop operations using the Ctrl
(for single selection) or Shift (to select a range) keys.

2. A menu is displayed with three options:

● Create User Task To View And Assign Data
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 Selecting this option creates a user task with the process data as an In/Out parameter on the
Interface tab. This means that in the runtime environment, users will be able to display the
associated form to view the field and also to assign new values to it.

● Create User Task To View Data
 Selecting this option creates a user task with the process data as an In parameter on the Interface
tab. This means that in the runtime environment, users will be able display the associated form to
view the field, however they can not assign new values to it.

● Create User Task To Assign Data  
Selecting this option creates a user task with the process data as an Out parameter on the
Interface tab. This means that in the runtime environment, users will be able display the
associated form to assign new values to the field.

Creating a Participant
Participants are used to identify who or what performs an activity.

See "Participants" in the TIBCO Business Studio Concepts Guide.

Procedure

1. In the Project Explorer, expand the package where you want to add a participant.

2. Right-click Participants and select New > Participant . The New Participant dialog is displayed.

3. Click the Back button if you need to change either the name of the Project and Package where the
participant will be created. If you want to change either, click the Project or Package button.

Participants can be created at either the package level or at the process level. Creating them at the
package level is recommended as it enables them to be shared amongst processes. Select the Process
checkbox and specify a process if you want to create the participant at the process level.

If the Participants folder is empty at the Process level, it will be hidden by default. This is
because the preferred usage is to define Participants at the Package level.

4. Click Next.

5. Specify the Label and Name of the participant (either a basic type, or an external reference as described
previously in this section) and click Finish.

● To create a basic type, select Basic Type and choose from Role, Organization_Unit, Human,
System and Organization Model Query, and click Finish.

If you select the Organization Model Query button, you can then enter the Organization Model
Query Script in Resource Query Language (RQL) using a script or expression in the General tab of
the Properties view. This is evaluated when a referencing task is executed at run-time, so the actual
participant is resolved and the activity dispatched and offered to the participant. A query could
resolve to a participant in the package/process or to an entity in the organizational model.

● To create an external reference to an organization model, select External Reference, and click the
picker to select a type from the organization model.

Choose a type from those shown in Matching Items, or key in the first few characters of the name
you are looking for in the field under Select type(s)(? = any character, * = any string and choose
from those shown. Click OK.

The participant that you created appears in the Project Explorer.
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● You can import participants from other projects. At the process package level, right-
click and select Import Participants Wizard. You can then select which project/s you
wish to import participants from.

● All external references to participants from within the same project must be to the
same major version of the organization model. However, you can reference different
minor or micro versions of the model. For example, if you have included a reference to
a participant in version 1.0.0.qualifier of the organization model, and the model
subsequently changes, you could reference a participant in version 1.1.0.qualifier, but
not version 2.0.0.qualifier.

Associating Participants with Activities
You can associate a participant with an activity to identify who or what performs the activity. You can do
this either by dragging and dropping the participant onto the activity or in the Properties view for the
activity.

Using Drag and Drop to associate a participant with an activity

You can drag a participant onto an activity.

Procedure

1. Expand participants in the Project Explorer.

2. Click the participant you want to associate with your activity, holding down the mouse button, drag the
pointer to the activity and release the mouse button.

● You can select multiple participants for drag and drop operations using the Ctrl (for single
selection) or Shift (to select a range) keys.

● You can also select as a participant a data field or formal parameter of the type Performer.

3. A menu is displayed with two options:
Option Description

Add Task Participant(s)  Selecting this option adds the participants to any existing participants for
the activity.

Set Task Participant(s)  Selecting this option clears any existing participants associated with the
activity, before setting the participants to those you selected.

Using Properties View to associate a participant with an activity

You can associate a participant with an activity.

Procedure

1. In the Process Editor, highlight the desired activity.

2. Either:

● In the Properties view, click the picker.
● Right-click the activity, and select Participant.

The Select Participants dialog is displayed.

3. Highlight participants you want to select and click Add to move them to the Selection column. When
you have finished selecting Participants, click OK.
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● You can select multiple participants by pressing either the Ctrl (for single selection) or
Shift (to select a range) keys while making your selection.

● The wildcard ? returns all matching participants. Use the * wildcard to restrict the results
(for example, *2 to return all Participants ending in 2. Note that the wildcard * by itself
does not return any results; it only works in conjunction with a string.

● You an also select as a participant a data field of the type Performer.

4. The participants you selected are displayed in the Properties view and also when you hover the pointer
over the activity in the Process Editor.

Highlighting Participants

You can see what tasks a participant is assigned to by using highlighting.

Procedure

1. Click in the Process Editor for the process.

On the toolbar, you will see a button: 

2. Click on this to see the dropdown, and select Enable Highlighting.

Alternatively, you can select Diagram > Highlighting > Enable Highlighting.

3. Select the participant in Process Explorer, and in the Process Editor the tasks which use this participant
will be highlighted (framed with green lines). Other tasks in the process will be grayed out.

This behavior also applies to data fields and parameters.

Result

Highlights are cumulative.

● If you select more than one participant, data field or parameter in Project Explorer, only tasks which
reference all of those selected will be highlighted.

● If you select "Activities With Scripts" followed by "Process Message API Activities" then the diagram
objects highlighted will be process message API activities that have scripts.

The current highlight filter is shown when you use the Process Editor mouse-over tooltip.

Highlights are removed when anything other than the highlighted diagram objects are selected.
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Exporting Participants to an Organization Model
You can create an organization model based on the participants in a process package, or a number of
process packages..

● Process packages with errors cannot be selected as the basis for organization model creation.

● Processes must contain only one pool, but can have many lanes.

● If a process package references another process package, the referenced process package is
automatically selected.

Procedure

1. Right-click the XPDL package file in the Project Explorer and select Refactor > To Organization Model .

2. In the resulting dialog, select the process packages that you want to refactor into an organization model,
and click Finish:

3. A message indicates that the process packages were correctly refactored:

The existing participants are changed from basic types to external references to the organization model.

Participants to Organization Model Mapping
The following table shows how participants that are not referenced in a process appear in the exported
organization model.

Process Participant Type Organization Model Object

Human Position in default organization model unit

Organization unit Top-level organization unit

Role Top-level group

System Ignored

The following table shows how participants that are referenced in the process (for example, in a user task)
appear in the exported organization model.

Process Participant Type Organization Model Object

Human participant Position in organization unit (unit is named after the
lane in the original process)

Organization unit Organization unit within an organization unit (the
containing unit is named after the lane in the original
process)

Role Top-level group

System Ignored
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Using Participants to Create Tasks
If you have participants, you can drag them to a blank area of a process to automatically create several
types of task:

Procedure

1. In the Project Explorer, click the participant, and holding down the mouse button drag the pointer to a
blank part of the process and release the mouse button.

You can select multiple participants for drag and drop operations using the Ctrl (for single
selection) or Shift (to select a range) keys.

2. A menu is displayed with the following options:

● Create User Task For Participant(s)
 Selecting this option creates a user task with the selected participants.

● Create Service Task For Participant(s)
 Selecting this option creates a service task with the selected participants.

● Create Manual Task For Participant(s)  
Selecting this option creates a manual task with the selected participants.

● Other Task Types
 This submenu contains more task types that you can create from a participant.

Deletion of Data Fields Parameters Participants and Type Declarations
You can delete a project object such as a data field, parameter, participant, or type declaration by right-
clicking it in the Project Explorer and selecting Delete.

However, if the project object has been associated with another object such as an activity or a sequence flow,
the following message is displayed:

If you click Yes, the project object (in this example, a data field) is deleted, but it will still be referenced in
XPDL for the project, which can cause problems. If you click No, the project object is not deleted. You can
then go to the Properties view and examine the references to that object:
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In this example, the data field is referenced in the service task RequestForAppointment and in the user task
ShowAppointmentDetails. Click Go To to show that task in the Process Editor.

Creating a Dynamic Organization Participant
The Organization Units and Positions within a Dynamic Organization may be assigned to Process
Participants - known as Dynamic Organization Participants.

See "Dynamic Organization Participants" in the TIBCO Business Studio Concepts Guide

Procedure

1. In the Project Explorer, expand the package where you want to add a participant.

2. Right-click Participants and select New > Participant . The New Participant dialog is displayed.

3. Specify the Label and Name of the participant.

4. To create an external reference to a dynamic organization model, select External Reference, and click
the picker to select a type from the dynamic organization model. Choose a type from those shown in
Matching Items, or key in the first few characters of the name you are looking for in the field under
Select type(s)(? = any character, * = any string and choose from those shown. Click OK.The dynamic
organization participant that you created appears in the Project Explorer.

5. Click Finish

What to do next

When a Dynamic Organization Participant is assigned to a task you need to provide information to identify
the correct instance of the Dynamic Organization to use to resolve this participant. See Dynamic
Organization Identifier Mapping to identify the correct instance of the Dynamic Organization in which the
participant will be found at runtime.
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Auditing Process Data
By default, process data does not appear in the audit trail (that is, in the Event Viewer) for a process
instance. But you can configure a process so that certain data fields appear in the audit trail.
This capability makes use of the process data to work item attributes mapping facility that is available in
ActiveMatrix BPM. For example, the following shows process data in the Event Viewer that has been
mapped to Attributes 3 and 8.

If a work list facade has been defined, and display labels were assigned to Attributes 3 and 8, the labels
would be shown in the Event Viewer rather than "Attribute3" and "Attribute8". For more information, see 
Creating a Work List Facade.

The Event Viewer displays audit entries across all processes on the system, and therefore it is usual that
specific attributes are used for the same data items across all processes. For example, you might want to
consistently use Attribute2 for the value of 'Order Id'. Creating and sharing the same work list facade
project across all BPM applications on the system can help to achieve this consistency.

To configure your system to show process data in the Event Viewer, you must:

● Enable auditing of process data -- see Enable Auditing of Process Data

● Map process data fields to the desired work item attributes -- see Mapping Process Data to be Audited

Enable Auditing of Process Data
To be able to audit process data (that is, view process data in the Event Viewer), you must enable it in the
ec-probe-rules.xml file on the server.
The work item attributes are not included in audit data (that is, in the Event Viewer) by default for
performance reasons.

Procedure

1. Open the ec-probe-rules.xml file.
This file is located in the following directory on the machine on which ActiveMatrix BPM is installed:

CONFIG_HOME/bpm/bpm_app_name/configuration

where:
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● CONFIG_HOME is the root directory for ActiveMatrix BPM runtime files. This can be specified
during installation.

On Windows systems, this defaults to:

C:\ProgramData\amx-bpm\tibco\data

On UNIX systems, this defaults to:

/opt/tibco/data

● bpm_app_name is the name of the ActiveMatrix BPM application, which can be specified during
installation.

This defaults to:

amx.bpm.app

2. Locate genericAttributes:

3. Comment out the line that contains genericAttributes:
It should now appears as follows:

4. Save and close the ec-probe-rules.xml file.

What to do next

Map process data fields to the desired work item attributes -- see Mapping Process Data to be Audited.

Mapping Process Data to be Audited
For process data to appear in the Event Viewer, you must map process data fields to the desired work item
attributes.
This mapping process is the same as the process for mapping data fields to work item attributes when
creating a work list facade - see Creating a Work List Facade. If you have defined a work list facade, and
you map process data fields to attributes for which you have specified a display label in the facade, those
custom labels also appear in the Event Viewer for the process data entries.

Procedure

1. In TIBCO Business Studio, open your process and select it in the Process Editor.

2. In the Properties view, select the Work Resource tab, then expand Work Item Attribute / Audit Event
Data Attribute Mappings.
This displays all of the data fields defined for the process (in the left column) and all of the work item
attributes (in the right column). For example:
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If you have a work list facade defined, the list of attributes in the right column shows the display labels
for those attributes that were mapped to data fields in the facade.

3. Map the data fields that you want to appear in the Event Viewer to attributes that are of the same data
type.
For example:

As shown in this illustration, data fields can be mapped to multiple attributes, if desired.

Note that if you map a data field to an attribute of a smaller size, a warning marker is shown that
indicates this:

This may result in data shown in the Event Viewer being truncated to the length of the attribute. For
information about the type and size of each work item attribute, see the "Work Item Attributes" topic in
the TIBCO Business Studio Process Modeling Concepts guide.

Result

The example shown above results in the value in the Contact Name field appearing in Attribute8, and the
value in the Issue Description field appearing in Attribute3 and Attribute10 in the Event Viewer. For
example:

122

TIBCO Business Studio™ Modeling Guide



Note that this example also illustrates the result of mapping a data field to an attribute whose length is not
sufficient to hold the entire value entered in the data field. In this example, the Issue Description field was
mapped to an attribute (Attribute10) that is 20 characters in length. Since the value entered in the Issue
Description field exceeds 20 characters, the value shown in the Event Viewer is truncated. Since it is
truncated, the value shown in the Event Viewer is prefixed with *nn*, where nn is the number of characters
that were entered into the data field.
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Sub-Processes

This section describes how to work with sub-processes in TIBCO Business Studio.

Creating Call Sub-Processes
There are several different ways of creating a call to a sub-process:

You can create a call to a sub-process:

● By refactoring objects in your process (see Creating a New Embedded Sub-Process).

● By dragging a process from the Project Explorer and dropping it onto your process (described in this
section).

● Using the call sub-process activity tool from the palette (see Refactoring Activities into a Sub-Process).

If you modify a sub-process (for example, by adding a parameter) and that sub-process is
referenced by a main process in a different package, validation in the main process does not
occur until you save the sub-process package.

Creating a Call Sub-Process Activity Call Using Drag and Drop

Procedure

1. Expand the Project Explorer to locate the process that you want to be the sub-process.

2. Click the intended sub-process, holding down the mouse button, drag the pointer to the calling process
(open in the Process Editor), and release the mouse button.

You can select multiple processes for drag and drop operations using the Ctrl key.

3. If you are dropping more than one process, a menu is displayed with two options:

● Create Sub-Process Task Sequence
 Selecting this option allows you to create sub-process tasks connected by sequence flow. A dialog
is displayed to allow you to control the order of the tasks: Use the Move Up and Move Down
buttons or drag and drop to control the order of the tasks. When you are finished, click OK to
place the tasks.

● Create Unsequenced Sub-Process Tasks
 Selecting this option places the tasks in the process without a connecting sequence flow.

Creating a call sub-process call using the palette

Procedure

1. In the Process Editor, select the call sub-process tool.

2. Click in the process where you want to place the activity that calls the sub-process.

3. On the Properties view for the activity, browse for the process you want to call as a sub-process.

If the process you select is not in the current project, you are prompted to create a project
reference.
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Call Sub-Process Example
The following example demonstrates how a top-level process could use sub-processes in an insurance
environment.

Each of the activities in the process calls sub-processes that are executed in the runtime environment. For
example, the sub-process called from the Claims Management activity could look like this:

Note the following about this sub-process:

● The Validate Policy sub-process can be re-used. For example, when a customer calls to renew their
policy, the first step of the Renewal Process could be to confirm that they have an existing policy. The
Validate Policy Activity could be re-used for this purpose in the Renewal process.

● The Process Claimant activity has a Loop Activity Marker, that indicates that the activity is repeated for
each Claimant.

● The actual sub-process called by the Assess Liability activity is a manual Process. However, the to be sub-
process (planned for the future), could be implemented as an automatic process that consists of a series
of questions used to determine liability. Simulation could be used to demonstrate the performance and
cost-savings of migrating the Assess Liability activity to an automatic process.

Expanding a Sub-Process
You can expand a sub-process associated with an activity.

An activity that calls a sub-process looks like this:
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To expand the sub-process associated with this activity, either click the plus symbol, or do the following:

Procedure

1. In the Process Editor, select the activity that calls the sub-process.

2. In the Properties view, select the General tab.

3. Click Open Sub-Process:

4. The sub-process opens in the Process Editor.

Configuring a Sub-Process
You can configure the sub-process invocation mode, and whether it should execute immediately or be
queued.

Use the Lifecycle option, on the General tab in the Properties view to select the invocation mode from the
following:

● Synchronous

● Asynchronous Attached

● Asynchronous Detached

For definitions of the different types of invocations, see "Synchronous and Asynchronous Sub-Process
Invocations" in TIBCO Business Studio™ Concepts Guide. There are a number of restrictions that will be
indicated via validation problem markers.

You can access the process-id of the new process instance as a sub-process output mapping. This is
mappable to a string-typed field or parameter.

You cannot map from sub-process output parameters when invoking asynchronously because the invoking
process does not wait for the sub-process to complete and return.

Use the Lifecycle option, on the General tab in the Properties view to select whether the sub-process
should execute immediately or whether its start request should be queued.

● Select Schedule Start Request to set the initial priority for the queued sub-process start request and the
tasks within that using the options in the Priority radio buttons.

● Select Start Immediately to set the priority of the task within the process in the process Resource tab.
See Prioritizing a Scheduled Reuseable Sub-Process.

● Specify whether sub-process instances should suspend and resume when the parent process is
suspended or resumed by selecting or deselecting the Suspend/Resume Sub-Process With Parent
Process check box.
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Prioritizing a Scheduled Call Sub-Process
Call sub-processes configured to Schedule Start Request are started with the default priority at which a
main process is started.

This means they may be queued behind a large number of main processes already waiting to be executed.
In this case you may want to prioritize call sub-processes in a process.

Procedure

● Use the drop-down from the Priority field from the Resource tab for the call sub-process. Set one of the
following priorities:

Invoking a Sub-Process Asynchronously
You can create asynchronous sub-processes from a process to allow you to run sub-processes independent
of the main process, when you are not concerned if they complete before the main process.
See "Synchronous and Asynchronous Sub-Process Invocations" in TIBCO Business Studio™ Concepts Guide.

Procedure

1. Create the main process containing a call sub-process activity.

2. On the Properties for the call-sub-process activity, use the Lifecycle option, on the General tab in the
Properties view to select Asynchronous invocation mode.

3. Click on the  sign on the call sub-process activity to open the asynchronous sub-process in a new
window.

4. Create the content of your asynchronous sub-process.
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Embedded Sub-Processes
To create an embedded sub-process, refactor one or more objects in your process

See Creating a New Embedded Sub-Process.

If you want to use the chained execution resource pattern, you can do so by selecting the Chained
Execution check box in the Properties view for the embedded sub-process. For more information, see 
Chained Execution- Multiple Parallel Paths in a Chaining Group .

Adding Local Data Fields
You can add data fields that are local to a sub-process (they are not used in the process that contains the
embedded sub-process).

By default, activities in the embedded sub-process have access to all local data and process data. However,
using the Interface tab, a subset of data can be selected.

Procedure

1. Click the Data Fields tab in the Properties view for the embedded sub-process.

2. At the right of the Data Fields tab, click the plus sign to add local data fields. The properties of the data
fields that you create are the same as for process data (see Adding Data Fields or Parameters to a
Package or Process).

Local data fields are not displayed in the Project Explorer.

For example:

In this example, the data fields Status, Status2, Status3, and Field are local to the embedded sub-
process. On the Interface tab for activities within the embedded sub-process, you can access the local
data as well as the process data:
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In this case the address data fields (process data) and the local data defined on the Data Fields tab are
both available.

You can quickly create an embedded sub-process that has local data by using the fragment
BPMN Process Fragments > Basic Fragments > Embedded Sub-Process with Data Fields. For
more information about fragments, see Creating Call Sub-Processes .

Local Data Fields in Loops

When using local data fields in loops, the value taken by the local data field during each iteration depends
on the type of loop.

Multi-instance loop

Each instance of a multi-instance loop has a separate instance of the local data field, allowing parallel loops
to execute without interfering with each other. However, the local data fields cannot be used in the loop
expression.

Standard loop

The local data field is shared between all instances of a standard loop. It can be used to pass data between
instances, and can be used in the loop conditional script.

You cannot initialize a local data field prior to the first "Before" condition test.

For both multi-instance and standard loops, the task initiate script runs just before executing the task for
each iteration of the loop.
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Creating a New Embedded Sub-Process
You can create a new embedded sub-process by refactoring existing objects into an embedded sub-process.

Procedure

1. Select the objects that you want to put in the embedded sub-process. For example:

2. Right-click and select Refactor > Move into New Embedded Sub-Process .

3. Complete the dialog as follows:
a) Enter a name for the embedded sub-process that you want to create.
b) Select the New Sub-Process is a transaction checkbox if you want the new sub-process to become a

transaction and therefore be under transaction control (see User Tasks and Pageflow Processes).
c) Select the Insert start event in new sub-process and Insert end event in new sub-process

checkboxes to control whether start and end events are added to the refactored sub-process.

4. Click Finish. The objects that you selected are placed within a new embedded sub-process (with start
and end events if those options were selected):

Refactoring Activities into a Sub-Process
You can create a new call sub-process activity and sub-process by extracting existing objects.

Procedure

1. Select the objects that you want to put in the sub-process. For example:
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In this example, the two user tasks have the following parameters (two data fields and one formal
parameter):

The user tasks also have a participant associated with them.

Select all three tasks.

2. Right-click and select Refactor > Extract into New Sub-Process .

3. Because the data fields and participants are only referenced in this activity (and not used by any other
activities), the following message is displayed:

● For the participant, TIBCO Business Studio gives you the option of either moving this participant
into the sub-process, or duplicating the participant in both the parent process and the sub-process.

● If you select the data fields, they are moved into the sub-process.
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● If you do not select the data fields, they are created as formal parameters in the sub-process (and
mapped to those formal parameters).

4. Complete the dialog as follows:
a) Enter a name for the sub-process that you want to create.
b) Select the New Sub-Process is a transaction checkbox if you want the new sub-process to become a

transaction and therefore be under transaction control (see User Tasks and Pageflow Processes).
c) Select the Insert start event in new sub-process and Insert end event in new sub-process

checkboxes to control whether start and end events are added to the refactored sub-process.
5. Click Finish. The objects that you selected are copied to the new sub-process and the selected objects are

replaced with a task that calls the call sub-process.

If you chose to create formal parameters for the data fields, you can see them in the Project Explorer,
under the sub-process:

In addition, if you click the task in the parent process that calls the sub-process and go to the Properties
view, you can see the mappings that have been created between data fields and formal parameters of
the parent process and the formal parameters created in the sub-process. For example:
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Result

Notes on Refactoring Objects into Sub-Processes:

● Formal parameters in the parent process are created as formal parameters in the sub-process. They are
mapped according to their mode as defined in the process API.

● If a data field is referenced only in the selection that you are refactoring, you have the option of moving
or copying it. Data fields that are copied into the sub-process are created as formal parameters and
mapped. Data fields that are moved into the sub-process are created as data fields. By default, data fields
are moved. In order to copy them as formal parameters, you must uncheck the selection boxes on the
dialog.

● If a data field is referenced in one or more of the tasks you select for refactoring but is also referenced
elsewhere, it is automatically copied into the sub-process as a formal parameter.

● A mapping is created between data fields and formal parameters of the sub-process and any
corresponding formal parameters that are created in the sub-process. You can view this mapping by
selecting the task that calls the sub-process and clicking the Map To Sub-Process and Map From Sub-
Process tabs in the Properties view.

Changes in Process Logic:

When refactoring objects into a call sub-process, you can potentially change the logic of the process flow.

Consider the following process:

In this process, flow proceeds from User Task 1 to the gateway without necessarily waiting for Task A to
finish. If User Task 1 and Task A are refactored into a sub-process, an end event is inserted into the sub-
process, effectively synchronizing the flow. TIBCO Business Studio prompts you to confirm this change to
the process:
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Inline Sub-Process Content
This option creates an embedded sub-process from a call sub-process activity. The reason for making a call
sub-process inline is that in some cases the tasks in the sub-process execute relatively quickly and the
overhead of invoking a sub-process can be comparatively high.

Refactoring a Call Sub-Process into an Embedded Sub-Process

You can refactor a call sub-process activity into an embedded sub-process.

Procedure

1. Right-click the call sub-process activity, and select Refactor > Inline > Sub-Process Content .

Only a single level of a process hierarchy can be made inline at a time. If the sub-process you
want to make inline contains a sub-process task, after refactoring, it will be brought into the
embedded sub-process as a sub-process task. (the refactor does not extend into additional
levels of the process hierarchy).

2. The sub-process called by the selected task is analyzed, and a dialog is displayed with the results:

● If there are no problems with the refactoring operation, a dialog is displayed. Select Inline into
Embedded Sub-Process and click Finish.

● If there are problems with the refactoring, but the problems can be resolved by making the sub-
process inline, a dialog is displayed showing the problems:
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The possible problems displayed in this dialog are similar to those for process package
optimization, except that some of these problems that are not resolvable for package
optimization are resolvable by refactoring into an embedded sub-process (such as those
reported in the previous dialog).

Also, problems dealing with nesting of sub-processes are not applicable because manual
refactoring affects only a single level of sub-process hierarchy at a time.

You can see the location of each problem by highlighting it. If you select all of the problems in this
dialog, the Finish button is enabled and you can refactor the sub-process.

● If there are problems that cannot be resolved by refactoring, a dialog similar to the following is
displayed:
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Because t he errors cannot be resolved, click Cancel, resolve the problems manually, and retry the
refactoring.

3. If the sub-process was able to be refactored, its contents are placed in an embedded sub-process,
however the sub-process that was made inline is not removed.

Result

The following are potential consequences of a refactoring. For more information, see Inline Sub-Process in
Detail :

● References to sub-process parameters in the sub-process content are swapped for the calling process
data fields that are mapped to them.

● Sub-process data fields and unmapped parameters are copied up to the calling process and renamed
with a sequence number if the data field or parameter already exists in the calling process.

● Sub-process participants are copied to the calling process (if they do not already exist).

● Type declarations referenced by data copied up from the sub-process are copied to the package of the
calling process only if the sub-process is in a different package.

● If the sub-process implements a process interface (see Process Interfaces ), the start or intermediate
events that implement interface-defined events are changed so that they are no longer flagged as such.

Inline Sub-Process in Detail
This section describes in detail what happens when you use an inline sub-process (including its parameters,
participants, and so on).
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Data Fields and Mapped Parameters
References to parameters in sub-processes are replaced according to the parameter mapping.

For example, consider the parameter mapping to the following sub-process:

The data field CustRef in the parent process is mapped to RefNum in the sub-process. In the sub-process,
the parameter RefNum is used by the single user task:

After refactoring as an inline sub-process, the user task is brought into the main process with RefNum as its
parameter.

Every effort is made to ensure that when a sub-process is inlined, it is semantically the same as if it were not
in-lined. However, not every potential scenario can be catered for.

For example, if the same calling-process field is used in the parameter mappings for two parallel call sub-
process activities, the calling-process field will now be used in-parallel in the two sets of sub-process
contents that were moved up into the calling-process. This may have undesired effects.

Sub-Process Data Fields and Unmapped Formal Parameters
Sub-process data fields and unmapped formal parameters are moved up to the calling process after
refactoring. In order to preserve the original semantics of the sub-process, any data fields or unmapped
formal parameters in the sub-process that also exist in the calling-process are renamed (each new instance
of the same named data is suffixed with a sequence number). Any references to the renamed sub-process
data are updated when the sub-process activities and flows are moved up to the calling process.

Package-level data fields are not included in this behavior unless the sub-process is in a different package to
the calling process.

For example: A sub-process has a data field called CustomerField which its activities use internally. The
calling process also has a field called CustomerField which it uses internally.

When the sub-process is in-lined, the sub-process CustomerField is copied into the calling-process as
CustomerField2. All references to CustomerField in sub-process activities and flows are replaced with
references to CustomerField2.
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Multiple Calls to a Sub-Process

This rule also applies when several sub-processes are called from a single process. If the sub-processes have
the same data fields names, then each invocation will cause separate, sequence-numbered instances of data
fields in the calling process when they are made inline.

For example: There are two calls to the same inline sub-process from a single calling process. The sub-
process has a field called CustomerField.

The copy of sub-process activities and flows ‘moved up’ in place of one call sub-process activity will
operate on CustomerField and the other will operate on CustomerField2.

Field Name Conflicts

This rule also applies when inline sub-processes are nested, and have conflicting field names.

For example: The calling-process (MainProcess) calls an inline sub-process (SubProcess) which in turn calls
a nested inline sub-process (SubSubProcess).

Each process has a field called CustomerField.

● SubSubProcess is in-lined into SubProcess so that its instance of CustomerField becomes
CustomerField2 in SubProcess.

● SubProcess now has 2 fields, CustomerField and CustomerField2. When this is in-lined into
MainProcess CustomerField in SubProcess is dealt with first (alphabetically) and is therefore renamed as
CustomerField2 in MainProcess.

● Now when the SubProcess field CustomerField2 is subsequently copied into MainProcess, a
CustomerField2 already exists so it is renamed as CustomerField3.

Sub-Process Participants And Type Declarations
Participants are moved up to the calling process if the calling process does not already have a participant
with the same name. If the Participant already exists in the calling process, references to the sub-process
participant are exchanged for references to the calling process participant in the sub-process content that is
moved up.

Similarly, type declarations (that are referenced by sub-process data fields and unmapped formal
parameters) are moved up to the calling process if the calling process does not already have a type
declaration with the same name. Otherwise, the calling-process type declaration is used.

Event Sub-Processes
An event sub-process executes an internal sub-process when an event is triggered. You can use event sub-
processes within business processes and pageflows.

See also Event Handlers in TIBCO Business Studio Concepts.

Collapsed:
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Expanded:

Event sub-processes and event handlers provide similar functionality. See Event Handlers in TIBCO
Business Studio Concepts.

Note the following when using event sub-processes:

● A process can contain zero or more event sub-processes of any supported type or configuration.

● Each event sub-process must start with a single start event.

● There is no in-process communication between event sub-processes (sequence flow, signals etc).

You can use event sub-processes with the following start events:

● Event Sub-Processes placed in a Business process: Message Start Event and Signal Start Event

● Event Sub-Processes placed in a Pageflow : Signal Start Event and Type None Start Event

Business processes support interrupting/non-interrupting event sub-processes.

Pageflows support non-interrupting event sub-processes. They do not support interrupting event sub-
processes.

This is defined on the start event of the event sub-process by checking Interrupt Process Flow or Continue
Process Flow. This affects the process as follows:

Interrupt Process Flow:

An interrupting event sub-process start event has a solid border.

.

● The main process flow is suspended until completion of the event sub-process.

● This does not affect the processing and completion of individual activities that are already in progress
related to the process instance. However, those activities' outgoing flow is not processed until the event
sub-process completes.

● This does not affect the processing of other event handler flows, event sub-processes and ad-hoc
activities.

● This does not affect the processing of activities in active reusable sub-processes.

● Incoming events, submits, sub-process completions and so on in the main process are preserved but
ignored until the event sub-process has completed.

Continue Process Flow :

A non-interrupting event sub-process start event has a dashed border.

● The main process flow is not suspended during processing of the event sub-process.

● All activity can continue as normal.
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Creating Dynamic Sub-Processes
A dynamic sub-process can be created by modifying a call sub-process activity.

See "Dynamic Sub-Processes" in TIBCO Business Studio Concepts.

Procedure

1. Create a process interface that specifies the start event and its input/output parameters. Each process
that is to be invoked from the dynamic sub-process task must implement the same process interface. See 
See "Process Interfaces" in TIBCO Business Studio Concepts..

2. Create one or more call sub-process activities in your process.

3. From the General tab for each call sub-process activity:
a) Using the picker, select the process interface created in step 1.
b) In the Runtime Identifier Field select a formal parameter or data field using the picker. This must be

a text field or an array. Arrays can be used for multi-instance sub-process tasks where potentially
different sub-processes are required for each instance of the same task.

4. Initialize the Runtime Identifier Field. For example, for a multi-instance sub-process task you could
create a Script task before it to populate the array data field with a sub-process name element for each
task instance. For a single instance sub-process task simply set the runtime identifier field to the
required sub-process name in a script prior to the task.

For a sub-process implementation which resides in an external sub-process library., you could use a
script something like the script shown in the following illustration:

5. In the call sub-process activity, map data to and from the called process (to pass data between the
process and sub-process):

● Map the input to the interface in Map To Sub-Process.

● Map the output from the interface in Map From Sub-Process.

For example:
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Automatically Passing Different Data To and From Sub-Process Instances
If the call sub-process activity is multi-instance (or loop) it is possible to automatically pass different data to
and from each separate sub-process instance.

Inputting Different Data To Each Sub-Process Instance

Procedure

1. Specify an array data field that matches the type of a non-array sub-process/interface input parameter.

2. In a script prior to the sub-process task, populate this array data field with different data for each sub-
process instance. For example:

● appointmentTypeArray.set(0, "X-Ray");

● appointmentTypeArray.set(1, "PlasterDept");

● appointmentTypeArray.set(2, "Physio");

3. In the "Map to Sub-Process" property tab, map the array data field to the non-array sub-process/
interface parameter. The sub-process invoked from each instance of the task will receive the list element
corresponding to the instance index of that task (see ’getActivityLoopIndex()’ in the ’Process Scripting’
appendix of the TIBCO ActiveMatrix BPM Business Data Services guide for more information). For
example:

● The first instance (activity loop index=0) will receive the data "X-Ray" into its "appointmentType"
parameter.

● The second instance (activity loop index=1) will receive the data "PlasterDept" into its
"appointmentType" parameter.

● The third instance (activity loop index=2) will receive the data "Physio" into its "appointmentType"
parameter.

Returning Different Data From Each Sub-Process Instance

Procedure

1. Specify an array data field that matches the type of a non-array sub-process/interface output parameter.
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2. In the "Map From Sub-Process" property tab, map the output parameter to that array field.

At runtime the array field will be populated with the return data from each sub-process instance. The
list element index will correspond to the activity loop index from which the sub-process instance was
invoked.

For example, if the sub-process returned an integer parameter "ReturnParam" with value "X-OK" when
passed "X-Ray", "PL-OK" when passed "PlasterDept" and "PH-OK" when passed "Physio", and you
mapped this to an array data field "ReturnArrayField", then:

● ReturnArrayField.get(0) will be "X-OK"

● ReturnArrayField.get(1) will be "PL-OK"

● ReturnArrayField.get(2) will be "PH-OK"

Result

The way that this data is passed behaves in the same way for multi-instance statically defined sub-process
tasks (tasks that reference an actual sub-process at design time).

Control of the Flow in Dynamic Sub-Processes

The flow of processing within dynamic sub-processes can be controlled using the facilities for controlling
flow in a process.

See Controlling Flow in a Process.

In particular you can specify whether mutiple instances of the sub-processes should be performed
sequentially or in parallel by using the Ordering and Flow Condition fields of the Call Sub-Process
activity. See Creating a Standard Loop for more details.

You can also add additional instances to the loop while the sub-process is running, using a script on a
parallel procesing path. For details, see Adding Additional Instances to a Multi-Instance Loop Task Whilst
the Task is in Progress.

Correcting Validation Errors
Any problems that result from validation are shown in the Problems view.

To correct the problem do one of the following:

● Right-click the problem and select Quick Fix (if enabled for the current problem). The gives you the
option of having TIBCO Business Studio correct the problem for you.

● Double-click the problem or right-click the problem and select Go To. This displays the Process in the
Process Editor, highlighting the offending object and allowing you to manually correct the problem.

Setting the Validation Preferences
You can customize the validation that is performed in the Process Editor. Specifically, for each validation
error you can specify its severity level as Error, Warning, Info, or Ignore.

Procedure

1. Select Window > Preferences .

2. Expand Process Editor and select Errors/Warnings. The following dialog is displayed:
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3. If you want to change the severity level for a Process Editor problem, select from the drop-down list.
When you have finished, click Apply to effect any changes you have made.

You can downgrade the severity of BPMN errors, however some TIBCO Business Studio errors
are not displayed because downgrading them would allow processes to be deployed that
would be invalid in the runtime environment.

4. The following dialog is displayed:
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● Click Yes to revalidate your workspace. Depending on the size of the workspace and the number of
errors, there is a delay while the revalidation occurs.

● Click No to revalidate your workspace later. The revalidation will take place when the concept file
next changes or is saved, or when you explicitly request a rebuild of the project or workspace.

● Click Cancel if you do not wish to apply your changes.

At the top of the dialog there is a drop-down list that allows you to select either BPMN or
Simulation.

Configuring the Problems View
You can configure the appearance and display of the Problems view.

Procedure

1. Select items from the menu in the upper right of the Problems view:

2. Select Configure Contents to filter the problems that are displayed:
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Result

Two configurations are provided by default, All Errors and Warnings on Selection. You can create and
save your own configurations. You also can reduce the number of errors displayed by selecting a different
scope. For example, by choosing Selected element only as the scope in conjunction with the All Errors
configuration, you will see all errors for the selected element only rather than for all elements in the
workspace.

By default, problems in the Problems view are grouped by severity of the problems. However, you can
change this using the Group By menu option. For example, to arrange the Problems by their type, select
Group By > Plug-in Problem Type. You can also add or remove types in the previous Configure Contents
dialog.

Making a Sub-Process Call to a Process Interface
There are two different ways of creating a call to a process interface.

● By dragging a process interface from the Project Explorer and dropping it onto your process.

● Using the call sub-process tool from the palette.

Creating a Call Sub-Process Call using Drag and Drop

Procedure

1. Expand the Project Explorer to locate the process interface that you want to implement.

2. Click the process interface, holding down the mouse button, drag the pointer to the calling process
(open in the Process Editor), and release the mouse button.
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You can select multiple processes for drag and drop operations using the Ctrl key.

3. If you are dropping more than one process interface, a menu is displayed with two options:

● Create Sub-Process Task Sequence
 Selecting this option allows you to create sub-process tasks connected by sequence flow. A dialog
is displayed to allow you to control the order of the tasks: Use the Move Up and Move Down
buttons to control the order of the tasks. When you are finished, click OK to place the tasks.

● Create Unsequenced Sub-Process Tasks
 Selecting this option places the tasks in the process without a connecting sequence flow.

Creating a Call Sub-Process Call Process Interface using the Palette

Procedure

1. In the Process Editor, select the call sub-process tool.

2. Click in the process where you want to place the activity that calls the sub-process.

3. On the Properties view for the activity, browse for the process interface you want to call as a sub-
process.

If the process interface you select is not in the current project, you are prompted to create a
project reference:
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Process Interfaces

Optionally, you can create a process interface with one or more message events. This creates an abstract
WSDL file that is stored in a folder named Generated Services:

You can then call this abstract WSDL file in a service task, or optionally add the concrete implementation
details to the WSDL file.

Using the Process Interface Editor, you can modify the interface to add events or parameters:

Once created, a process interface can be used by several different processes. If a process is created using a
process interface, all the events and parameters specified in the interface must be present in a process that
implements that interface. You can add additional events or parameters, but removing any of those
required by the process interface will invalidate the process.

If you have additional parameters that are local to a process that implements a process interface, you can
move the parameters into the process interface by right-clicking the parameter and selecting Move
Parameter to Interface:

This option is only available for processes that implement a process interface in the same package, and only
for parameters that do not have problems in the Problems view.

If you create a process using a process interface, the process that you create inherits the events and
parameters created in the interface. For example, a message event in a process created using a process
interface displays the following properties:
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If you cannot see the right-hand side of the following dialog, switch to the Solution Design capability using
the following menu or click Provide Implementation Details.

See "Process Interfaces" in TIBCO Business Studio Concepts.

Creating a Process Interface
You can create a process interrface from Project Explorer.

Procedure

1. Select File > New > Other .

2. Expand Business Modeling > Business Process Modeling , select Process Interface, and click Next.

3. Enter a name for the process interface you are creating and click Next.

4. Enter a description for the process interface you are creating and click Next.

5. Select the intended destination environments for the process interface and click Finish. The Process
Interface editor is displayed. Use this to add or remove start events, intermediate events, and
parameters.

6. Enter any extended attributes and click Next.

Creating Error Events
Error events are created in the Project Explorer.

Procedure

1. Create a process interface.

2. In the Project Explorer, under the process interface, expand an event. For example:
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3. Right-click Errors and select New > Error . The following dialog is displayed:

4. Enter a name for the error code and click Finish. The error code you created is displayed in the Project
Explorer, and in the Process Interface Editor:

Continue with Error Codes and Process Interfaces to see how these error codes are used in processes
created from a process interface with error codes.

Modification of a Process Interface
You can modify a process interface using the Process Interface editor, however any changes made cause
validation errors in processes that have already implemented the interface.

For example:

To correct this problem, ensure that the changes made to the process interface are reflected in any processes
that have already implemented the interface.

Creating a Service Process Interface
A service process interface allows the dynamic selection of service processes at runtime. A service process
interface specifies the deployment target, events and their parameters that must be present in the service
processes created using that service process interface. At runtime, any of the service processes that
implement the interface may be chosen based on the data available at that time.

You can only use service process interfaces with service processes.

Using the Service Process Interface Editor, you can add the deployment targets, events and parameters you
require. You must specify a deployment target. You can choose either:

● the process engine

● the pageflow engine

The deployment target you choose depends on whether you are invoking your service processes from
business processes or pageflow processes.

Once created, a service process interface can be used by several different service processes. If a service
process is created using a service process interface, the deployment target, the events and parameters
specified in the interface must be present in a service process that implements the interface. You can add
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additional events or parameters, but removing any of those required by the interface invalidates the service
process.

If you do have additional parameters that are local to a service process that implements a service process
interface, you can move the parameters into the service process interface by right-clicking the parameter
and selecting Move Parameter to Interface. However, this option is only available for service processes that
implement a service process interface in the same package, and for parameters that do not have any
problems in the Problems view.

If you create a service process using a service process interface, the service process that you create inherits
the deployment target, events and parameters created in the interface.

Procedure

1. In the Project Explorer, select the package where you want to create your service process interface, right-
click and select New > Service Process Interface.

2. Enter the Label of the service process interface and select Next.

3. In Description, add optional text that describes the process, an optional URL that links to
documentation about the process, and select Next.

The Documentation URL field is intended for design-time collaboration; it is not displayed in
the runtime environment.

4. (Optional) In Destinations, select a destination environment. This controls the validation that TIBCO
Business Studio performs when you save the service process interface.
You must set an appropriate destination environment on the service process interface if you want to
avoid error messages and warnings associated with modelling constructs that cannot be executed in
your runtime environment.

● The exact destination environments that are displayed depend on the edition of TIBCO
Business Studio that you have installed.

● The specific destination components that make up a destination environment can be
viewed by selecting Window > Preferences, and selecting Destinations.

● If you select BPM, the Process will be validated against TIBCO ActiveMatrix BPM 3.x.

● If you select Simulation, processes created under this project will be validated for
simulation in TIBCO Business Studio as well as for BPMN correctness.

If you do not select a destination environment, basic BPMN validation is performed.

You can change or select the destination environment after the process is completed on the Destinations
tab of the Service Process Interface Properties.

5. (Optional) In Extended, add any optional supplemental information to the XPDL for the process.

6. Select Finish.
The Service Process Interface editor is displayed. Use this to configure the deployment target for the
service process interface and add or remove start events, intermediate events, and parameters.

7. Once you have created your service process interface, you must configure the deployment engine that
you want the service process interface to be deployed to.
When you create a service process interface, the deployment target is automatically set to Deploy to
Process Run-time so, if you want your service process interface to deploy to the pageflow engine, you
must select Deploy to Pageflow Run-time in the General tab of the Properties view. Add any start
events, intermediate events, and parameters and select Save.

There are other tabs available in the Properties view for service processes. See Process
Properties for more information.
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Error Codes and Process Interfaces
When a process implements a process interface that has error codes, the error codes can be used to throw
either WSDL fault messages from a message-based process, or errors thrown by a sub-process.

For example, consider the following process interface:

This process interface has a start event, an error code (WSDL error), and two parameters, Account and
Balance.

When you create a process from this interface, it creates the following:

The default sequence flow from the gateway replies to the start event. The conditional sequence flow from
the gateway throws an error with the code WSDL error.

The process with more tasks looks like this:
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The process flow is as follows:

● The process is started upon receipt of a message that contains an account.

● The database task looks up the account in the database to verify if it is valid.

● If the account is valid, another database task gets the balance, and the balance and account number are
sent as output.

If the account is not valid the error code is thrown.

The following example shows how the previous "get balance" example could be implemented as a sub-
process (in this case, the process interface has normal start and end events rather than start message and
end message events):

In this case, the sub-process throws an error, and in the calling process the error is dealt with:
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The catch error event is configured to catch the error thrown from the sub-process:
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Business Object Modeler Tasks

The business object model is where you define in business terms the Classes, Attributes, Primitive Types,
Operations, Associations, and so on that describe your business.

There are a number of common tasks that you perform using the Business Object Modeler in TIBCO
Business Studio.

You can use quick-find (Ctrl+F) in the project explorer to find existing business object model entities and
select them in the project explorer.

When you have created a business object model, you can search for business object model diagram
elements within it using quick-find (Ctrl-F) within the diagram, and entering the initial characters of the
name you are searching for. Double-click the element you are shown in the search to go to its location in the
diagram.

Creating an Analysis Project with a Business Object Model
You can create an Analysis project with a Business Object Model.

Procedure

1. Select File > New > Project .

2. In the New Project dialog, select Analysis Project , and click Next.

3. Enter a Project name and click Next.

This accepts default values for ID, Location, Version, Status and Destination Environments.
For more details about these fields and about the New Project dialog, see the TIBCO Business
Studio Modeling User’s Guide.

4. In the Asset Type Selection dialog, you can see that Business Objects is selected. Select any other Asset
Types you want to include in your Project. Click Next.

5. The Business Object Model dialog is displayed. (Depending on what options you selected at the
previous dialog, you may see other dialogs first, for example to configure the organization model.)

By default the Create initial Business Object Model field is checked. Accept this default setting. (If you
want to create a Concept Model, select that radio button instead. See Adding a Child Diagram to a
Business Object Model for more about concept models.). Click Finish.

6. If you are not already in the BPM Modeling (or Modeling) perspective, you are prompted to switch to
BPM Modeling. Click Yes to switch perspective.

7. In the Project Explorer you can see that a new Project has been created with a folder for the business
object models:

Result

By default, the Business Object Model name is prefixed by the domain name, as set in Window >
Preferences > User Profile.
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Creating a Business Object Model in an Existing Project
You can create a business object model in an existing project.

Procedure

1. In the Project Explorer, right-click the Business Objects folder and select New > Business Object
Model .

2. Name the business object model.

If you rename a business object model that has not been saved, any changes you have made
will be lost.

Click Finish on this dialog to create a business object model with default settings. Click Next
to modify the default project settings and create a business object model using a template, or a
concept model. Select a template from those available and click Finish.

3. In the Project Explorer you can confirm that the business object model has been created.

By default, the Business Object Model name is prefixed by the domain name, as set in
Window > Preferences > User Profile.

4. To apply a UML Profile to a business object model, see Applying a UML Profile to a Business Object
Model.

5. To apply stereotypes to a Model, see Applying Stereotypes to Business Objects.

Creation of a Model by Import
As an alternative to using the Business Object Modeler to create a business object model, you can import a
model in any one of several formats, and TIBCO Business Studio will automatically convert it to a business
object model.

You can import:

● An existing business object model from a database;

● A Unified Modeling Language (UML) model,

● An XML Schema Definition (XSD) file,

● A Web Services Description Language (WSDL) file

TIBCO Business Studio translates the imported XSD or WSDL file into a business object model. This is
especially useful if, for example, you have already generated UML models or XSDs that contain
information that you want to incorporate in your business object model.

The way that import works with regards to imports and includes is as follows:

● If MyXSD1 imports MyXSD2 (each have different namespaces), upon import each XSD file becomes a
separate business object model.

● If MyXSD1 includes MyXSD2 (they share the same namespace), only one business object model is
created.
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Importing a Business Object Model from a Database
You can import a Business Object Model from a database.

Procedure

1. Make sure that a database connection profile for the database that you require has been set up, as
described in the implementation guide for your destination platform.

2. If TIBCO Business Studio does not connect automatically to the database, connect as also described in
the implementation guide for your destination platform.

3. Start the database import wizard using one of the following methods:

● Right-click the Business Objects folder, and select Import > Database.

● Select File > Import > Business Object Modeler > Database.

4. The Import from Database dialog is displayed. It lists any databases that have been found.

5. Select the database required from the list displayed and click Next.

6. The Select BOM destination location dialog is displayed. This enables you to specify where the imported
business object model should be created.

The Business Objects folder of the current project is selected as the default location, You can change this,
and you can specify a name for the imported file. Specify the values you want.

7. You can now either click Finish, to import all tables in the database, or click Next to specify what to
import.

8. If you click Next, the Database Tables dialog is displayed. By default, all the tables in the database are
selected. Select or deselect database tables as you require, and then click Finish. The selected tables from
the database are imported to the location you specified, and a business object model is created from
them.

Result

When a model is imported from a database:

● Each database table is mapped to a Class in the Business Object Modeler.

● Each column in a table is mapped to an Attribute in a business object model Class.

● If foreign key constraints are present in the imported tables, an Association is created between the
Classes that represent the tables. Even if more than one foreign key constraint is present in the same
table, one Association is created.

Importing Existing UML Models into the Business Object Modeler
You can import existing UML models into the Business Object modeler.

Procedure

1. Start the import wizard using one of the following methods:

● Right-click the Business Objects folder, and select Import > UML Model.
● Select File > Import > Business Object Modeler > UML Model.

2. The Import UML Model dialog is displayed:
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Click the Browse button to select the From Directory where you have stored the UML model. Any UML
models that are found are displayed.

In this example, the UML model C:\Data\corporate.uml is selected.

3. Browse to select the Business Objects folder into which you want to import the model.

Select the Overwrite existing resources without warning checkbox if you know you want to replace an
existing model with the one you are importing; otherwise TIBCO Business Studio prompts you to
confirm whether to overwrite the existing model.

4. Click Finish. The Model is imported into the folder that you specified.

Importing XML Schema Files
You can import XML schema files.

Procedure

1. Start the import wizard using one of the following methods:

● Right-click the Business Objects folder, and select Import > XSD Schema.

● Select File > Import > Business Object Modeler > XSD Schema.

2. The Import XSD Schema dialog is displayed:

● Click the Browse button to select the directory that contains the XSD file that you want to import.
Then select the folder, and the specific XSD files you want to import. For example:
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● Click the Browse button to select the folder into which you want to import the XSD file. This must
be a Business Object Model special folder.

3. Click Finish. Depending on the size of the XSD file, there is a pause while TIBCO Business Studio
converts the file to a business object model. When the business object model has been created, check the
Problems view for errors or warnings. For more information about how XSD files are converted to
TIBCO Business Studio objects, see Business Object Model Mappings to XML Schema.

Importing WSDL Files
You can import WSDL files.

Procedure

1. Start the import wizard using one of the following methods:

● Right-click the Business Objects folder, and select Import > WSDL .

● Select File > Import > Business Object Modeler > WSDL.

2. The Import WSDL dialog is displayed:

● Click the Browse button to select the directory that contains the WSDL file that you want to import.
Then select the folder, and the specific WSDL files you want to import. For example:

● Click the Browse button to select the folder into which you want to import the WSDL file. This
must be a Business Object Model special folder.

3. Click Finish. Depending on the size of the WSDL file, there is a pause while TIBCO Business Studio
converts the file to a business object model. When the business object model has been created, check the
Problems view for errors or warnings.

For more information about how WSDL files are converted to TIBCO Business Studio objects, see 
Business Object Model Mappings to XML Schema.

Business Object Model Editor
You can add objects to your business object model or concept model, and edit them, using the Business
Object Model Editor.
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Adding Diagram Nodes to a Business Object Model
To create a business object model, you add diagram nodes (Package, Class, Attribute, Primitive Type and
Operation) and connect them with Connections (Generalization, Association, Aggregation, and
Composition).

You can add diagram nodes and connections in any of the following ways:

● Using the tools on the diagram editor’s palette. The palette contains tools that enable you to add a
diagram node or a connection either by selecting the required tool in the palette and dragging and
dropping on to the diagram, or by clicking on the tool in the palette and then clicking on the diagram.

If there is a stereotype already applied to your business object mode, the palette contains additional
tools to create business objects with the stereotype already applied to them. See Applying Stereotypes to
Business Objects for more detail about stereotypes.

● Using the pop-up icons. If you hover your mouse over the empty area of the diagram, or over a Package,
a pop-up containing icons appears. Move your cursor on to one of these icons to display label as shown
in the following illustration, and then click to create a new node of that type in the diagram.

Similarly, hovering the mouse over a Class displays icons for Attribute and Operation.

● Using the Project Explorer. You can add new diagram nodes (such as adding a new Package, Class, or
Attribute) using right-click menus in the Project Explorer. For example, to add a new Class, you can
expand the Project Explorer, select the business object model, and right-click Add Child > Class.

The Project Explorer menus list the objects appropriate to the context. For example, if you select a Class
and right-click Add Child, the following menu is displayed:

Adding Packages
Packages can be used as containers to organize Classes in your model.

Procedure

1. In the Business Object Modeler palette, select the Package tool, drag it over an empty part of the
diagram canvas and drop it. This places the Package in the model:
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Alternatively you can select the tool and click on the empty part of the business object model diagram.

2. Enter a name for the Package and if necessary, resize it to give yourself more room in which to place
Classes.

3. Note that you can nest Packages. For example:

The Properties view for the Package lists any Classes and Packages that it contains (see 
Package Properties ).The Properties view for the Package lists any Classes and Packages that it
contains (see Package Properties )

4. To apply a UML Profile to a Package, see Applying a UML Profile to a Business Object Model.

5. To apply stereotypes to a Package, see Applying Stereotypes to Business Objects.

Opening a Diagram Editor for a Package
If you double-click on a Package header, a new Business Object Model Editor window opens, showing only
the contents of that Package. This may be useful if the main editor is too crowded to see the contents of a
Package clearly.

You may need to re-arrange the contents of the Package in the new editor to make them all clearly visible. If
so, start by right-clicking on a blank area of the editor and select the Arrange All option.
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The illustration shows a Package Editor window opened on a package named points, in a hypothetical
business object model.

This editor is an exact window on the main Business Object Model Editor; any changes made in one
window are reflected in the other.

Click the shortcut icon  on the badge to return to the main editor.

Adding Classes Attributes and Operations
You can add classes, attributes and operations to your Business Object Model.

Procedure

1. Using the Class tool, place a Class on the model and name it.

2. Using the Attribute tool, place Attributes within the Class.

3. In the Properties view for each Attribute, select the Type and specify whether there can be multiple
values for the Attribute (whether it is an array). (See "Attributes" in TIBCO Business Studio Concepts for
more information about attribute types and multiplicity). When you specify multiplicity values in the
Properties view for Attributes, you can use content assistance. Press Ctrl + space in the field and the
available multiplicity values are displayed.

To apply restrictions to your Primitive Type, click the Resource tab and expand Restrictions.

4. Using the Operations tool, place Operations within the Operations Compartment in the lower section of
the Class graphic.

5. In the Properties view for each Operation, specify the return value type and any parameters or
parameter types.

6. In the Properties View for each Class, Attribute or Operation, click the Stereotypes tab to apply any
stereotypes you want to apply. See Applying Stereotypes to Business Objects for more information.
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Adding Primitive Types
To add a Primitive Type to your business object model, use the Primitive Type tool, drag and drop a
Primitive Type on the model and name it.

When you create a Primitive Type, it is always created with a standard type of Text. To select another
standard type for the Primitive Type:

Procedure

1. In the Properties View for the Primitive Type, select the General tab.

2. Click the picker to display the Select Type dialog. To display a list of the available types you can set,
type ? in the Select Type(s) field. A list of the available standard types is displayed.

3. From the Matching Items box, select a standard type and click OK.

Result

To apply stereotypes to the Primitive Type, click the Stereotypes tab. See Applying Stereotypes to Business
Objects for more information.

To apply restrictions to your Primitive Type, click the Resource tab and expand Restrictions.

Connections
Connections indicate the relationships between Classes and include Generalization, Association,
Aggregation, and Composition.

See Creating a Generalization between Two Classes

See Creating an Association between Two Classes

See Aggregation and Composition

Creating a Generalization between Two Classes
You can create a generalization between two classes. The generalization relationship indicates that one of
the two related Classes is a more general form of the other (an "is a" relationship).

Procedure

1. Click the Generalization tool on the Palette.

2. Drag from the Class that is the Derived Class to the Class that will be the Super Class. For example, if
you want to indicate that a Patient is a person:
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You can also create a Generalization by clicking Select to populate the Inherits From field on
the Properties view of the Class.

3. In the Properties View for each Association, click the Stereotypes tab to apply any stereotypes you want
to apply. See Applying Stereotypes to Business Objects for more information.

Creating an Association between Two Classes
You can create an association between two classes. An association is a relationship between two classes.

Procedure

1. Click the Association tool on the Palette.

2. Drag from one Class to the other. This creates a bi-directional Association. You can change the direction
of the Association by selecting from the Navigability drop-down list in the Properties view. You can
also change the Source or Destination of the Association in the Properties view.

A bi-directional Association shows both the Source and Destination on the business object
model. A uni-directional Association shows only the Destination.

You can also set the Multiplicity of each end of the Association by selecting from the Source Role
Multiplicity and Target Role Multiplicity drop-down lists in the Properties view.

3. In the Properties View for each Association, click the Stereotypes tab to apply any stereotypes you want
to apply. See Applying Stereotypes to Business Objects for more information.

Aggregation and Composition
Aggregation and Composition are created in the same way as an Association and share the same
properties. The only difference is the meaning and appearance of the Connection.

See Creating an Association between Two Classes.
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Adding Text to a Model
You can add a note or text to your business object model to describe the business object model or to add any
supporting explanations to the diagram nodes.

When adding text or a note, press Ctrl + Enter to start a new line.

To add a note

● Right-click on the Business Object Model Editor and select Add > Note.

● In the Business Object Modeler palette, select the Note tool in the upper part of the palette.

●

Then click on the Business Object Model Editor.

You can also select Text or Note Attachment from this menu. The icon for the tool changes to
show the item you have selected.

A Note is displayed where you can enter any text you require. Use the Note Attachment option to draw a
line connecting a Note to the Class it comments on.

To add text

● Right-click on the Business Object Model Editor and select Add > Text.
● In the Business Object Modeler palette, select the Text tool in the upper part of the palette and then click

on the Business Object Model Editor.

A Text box is displayed where you can enter any text you require.

Adding a Child Diagram to a Business Object Model
You can add a child diagram to a Business Object Model, to allow you to reuse part of a parent diagram,
and focus on that part of the diagram.

Procedure

1. From the Diagrams folder under the Business Object Model file in Project Explorer, select Add Child >
Diagram .

You can also make this selection from the Business Objects folder ( New > Other > Other > Diagram ,
and you will then be asked which Business Object Model to use), or from the .bom file: New > Diagram
or New > Other > Other > Diagram .
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2. From the New Business Object Model Diagram wizard, name the child diagram, and select the elements
of the Business Object Model which you want to include in your new diagram.

The elements you can include in your diagram are Class, Primitive Type and Enumeration.
Packages are not available for you to include.

3. Click Finish. Using the elements selected above, your child diagram looks like this:

Adding Elements to the Child Diagram
To add elements to a child diagram after you have created it, you can drag and drop Class, Primitive Type
or Enumeration elements from the parent Business Object Model model in Project Explorer (you can drag
and drop from other Business Object Models but then you can only create copies or subclasses).

Drag the element, and when you drop it, you will see a dropdown menu:

● To create a view of the element in this diagram, select Create View. This means that you can see the
element in this diagram, as well as in the main (parent) Business Object Model diagram.

● To make a new copy of the element in the diagram select Copy Elements. In this case, a new copy of the
element will appear in this diagram, and also in the main (parent) Business Object Model diagram

● (when dragging and dropping a Class) To create a subclass of the selected class, select Create
Subclasses. In this case, the subclass will appear in this diagram, and also in the main (parent) Business
Object Model diagram.

You can also use the Palette to add Elements, Children, and Relationships to the diagram, by dragging and
dropping the elements from the palette onto the child diagram. When you do this, the elements are new
elements, and will appear in the child diagram and also in the main (parent) Business Object Model
diagram.

Deleting Elements from the Child Diagram
You can delete elements in the child diagram from either the diagram or the model.

Procedure

● Select the element, and select Delete from Diagram or Delete from Model.

● If you select Delete from Diagram, the elements will only be deleted from this child diagram.

● If you select Delete from Model, the element will be deleted from the child diagram and also from
the main (parent) Business Object Model diagram.

Result

You can also delete the element using the Delete key. This has the same action as Delete from Diagram, that
is, only the graphical view is deleted.
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Concept Models
A concept model is a business object model with the addition of a UML Profile. Therefore many of the tasks
that you need to perform when creating a concept model are the same as the tasks you perform when
creating a business object model.

You can migrate existing concept models and create new concept models in the Business Object Modeler.

Migrating Concept Models
You can migrate concept models that have been created in earlier versions of TIBCO Business Studio.

Procedure

1. Copy the Package that the contains the concept model into the Project Explorer or select File > Import ,
expand General, select Existing Projects into the Workspace, and follow the instructions in the wizard
to import the Project.

2. Right-click the concept model you want to migrate and select Migrate Concept Model to Current
Version.

3. In the Problems view for the concept model that you migrated, an error message is displayed: Problems
while loading the file. Possible version problems. Right-click and select Quick Fix. When you have
resolved the problems, you can open the concept model in the Business Object Modeler.

You can correct several migration problems at once from the Quick Fix dialog by clicking Find
Similar Problems, selecting them, and clicking OK to apply the fix. The number of similar
problems found depends on the filtering that you have set up in the Problems view.

Creating an Analysis Project with a Concept Model
You can create an Analysis project with a concept model in the same way that you create an Analysis
project with a Business Object Model.

See Creating an Analysis Project with a Business Object Model.

In the Business Object Model dialog, check the Concept Model radio button instead of the Business Object
Model button.

Creating a Concept Model in an Existing Project
You can create a concept model in an existing project from Project Explorer.

Procedure

1. In the Project Explorer, right-click the Business Objects folder and select New > Concept Model .

2. Name the concept model and click Finish.

Alternatively, if you select New > Business Object Model and click Next at the first dialog of
the Create Business Object Model wizard, you can select the option to create a concept
model. See Creating a Business Object Model in an Existing Project .

In the Project Explorer you can confirm that the concept model has been created:
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Adding Diagram Nodes to a Concept Model

Many of the tasks you need to perform when adding diagram nodes to a concept model are the same as the
tasks you need to perform when adding diagram nodes to a business object model.

Packages

For information on creating Packages, see Adding Packages.

Concepts and Attributes.

Although a Class is called a Concept in a concept model, the steps for creating a Concept are the same as for
creating a Class in a business object model.

Operations are not available in a concept model.

For information on creating Concepts and Attributes, see Adding Classes Attributes and Operations.

Domain Values

In a concept model, Attributes can have Domain Values. To specify Domain Values for Attributes, do the
following:

● Click the Domain Values tab in the Properties view to add any values that the Attribute could have.

For more information about the Properties view for Attributes, see Association Class Properties.

Primitive Types

For more information on creating Primitive Types, see Adding Primitive Types.

Connections

For more information about creating connections between objects in a concept model, see Creating
Connections on page 252.

Models
There are various shortcuts you can use when creating your Business Object or concept models.

Copying Diagram Nodes Between Models
You can copy Packages, Classes, Attributes and Primitive Types between models.

The business object models can be in the same project or in different projects. To copy business objects
between projects you must create a project reference between the two projects.

Procedure

1. In the Project Explorer, expand the business object model that contains the diagram nodes you want to
copy.

2. Open the business object model that you want to copy the diagram nodes to.

3. Drag the diagram node to the Business Object where you want to add or create a new object. A menu is
displayed in the new model asking what you want to do with the new object. The menu that is
displayed depends on the type of business object you have copied. An example is shown below:
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If the business object models are in the same project the item is copied to the new model. If the models
are in different projects, a Project Reference message is displayed. Click Yes to create the project
reference or No if you do not want to create the project reference. If you click Yes, the object is copied to
the new model.

Model Organization Tools
Some models are simple to follow but larger and more complex models are more difficult to read. The
Business Object Modeler provides tools to make models easier to understand.

Icon Command Description

Apply the applicable
appearance properties of
the first selected shape to
the other selected shapes

Applies the applicable appearance properties of the first selected
shape to the other selected shapes.

Select All Selects all business objects in the Model.

Select All Shapes Selects all shapes in the selected Package.

Select All Connectors Selects all connections in the selected Package

Arrange All Arranges all the business objects in the Model so that they are
evenly spaced.

Arrange Selection Arranges the business objects in the Model that you have selected
so that they are evenly spaced.

Align Left Aligns the selected business objects to the left of the Model.

Align Centre Aligns the selected business objects to the centre of the Model.

Align Right Aligns the selected business objects to the right of the Model.

168

TIBCO Business Studio™ Modeling Guide



Icon Command Description

Align Top Aligns the selected business objects to the top of the Model.

Align Middle Aligns the selected business objects to the middle of the Model.

Align Bottom Aligns the selected business objects to the bottom of the Model.

Autosize Automatically sizes the selected business objects to the smallest
size.

All Connector Labels Displays all connector labels in the Model

No Connector Labels Displays no connector labels in the Model.

All Compartments Displays all the compartments within a selected Class.

No Compartments Only displays the name of a selected Class. Attributes and
Operations are not displayed.

UML Profiles
You can apply UML profiles that have been created elsewhere to your business object model. Once your
UML profile is available to your business object model, you can use it to apply stereotypes to the various
business objects in your business object model

Your business object model must already exist before you can apply UML profiles and stereotypes to
it.

Once you have applied a UML profile to your business object model, you should not change it. This is
because any changes you make to the UML profile could adversely affect your business object model.

Applying a UML Profile to a Business Object Model
You can apply a UML profile to a Business Object Model.

Procedure

1. To use an existing UML profile, copy the file that contains the UML profile to your Business Objects
folder in the Project Explorer. The UML profile is displayed as follows:

2. Select the Properties View for the Model or Package that you want to apply a UML profile to.

3. Select the Profiles tab.

4. Click the picker to display the Select Type dialog. To display a list of the available profiles you can apply
to the Package, type ? in the Select Type(s) field. A list of the available profiles is displayed.

5. From the Matching Items box, select a profile and click Add.
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6. Click OK to close the dialog.

Applying Stereotypes to Business Objects
You can apply stereotypes to all the business objects in your business object model. You can apply as many
UML profiles to a model or Package as you require.

You can apply the UML profile to the business object model or Package first, or it can be applied
automatically when you apply a stereotype to an object.

The UML profile must exist in the BOM Special Folder (normally the Business Objects folder for your
project). The Select Type(s) dialog used to apply stereotypes will then display all the available stereotypes
in that profile. If you select a stereotype from a profile that has not yet been applied to the business object
model or Package, the profile will automatically be applied when you click OK to apply a stereotype.

Procedure

1. In your business object model, select the Properties View for the business object that you want to apply
stereotypes to.

2. Click the Stereotypes tab.

3. Click the picker to display the Select Type(s) dialog. To display a list of the available stereotypes that
you can apply, type ? in the Select Type(s) field.

4. From the Matching Items box, select a stereotype and click Add.

5. Click OK to close the dialog.

6. To edit your stereotypes, select the Properties View for the diagram node which has the stereotype
applied to it and click the Resource tab. The Stereotype is displayed in the Resource tab.

Exporting Business Object Model Documentation
You can export a business object model to HTML output for documentation purposes.

Procedure

1. Select File > Export . The Export dialog is displayed.

2. Expand the Business Process Management folder, select Documentation, and click Next.

3. Drill-down through the Project and Business Object folder to select the specific business object model
for which you wish to export documentation.

4. Select a destination for the export by either:

● Selecting Project (to put the export in the Documentation sub-directory within your Project
directory), or

● Selecting Path: and clicking Browse... to specify a directory for the export.

5. Click Finish.

6. The Business Object Model Documentation is saved to the location you specified. See Viewing Business
Object Model Documentation for more information.
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Viewing Business Object Model Documentation
You can view Business Object Model documentation in a web browser.

Procedure

1. Export the documentation as described in Exporting Business Object Model Documentation.

2. In the Project Explorer, expand the Documentation sub-directory within your Project directory; or if
you exported the documentation to another destination, navigate to that destination folder.

3. Right-click the HTML file for the package and select Open With > Web Browser .

Export of Business Object Models to XML Schema or WSDL Files
You can export a business object model to XML Schema Definition (XSD) or WSDL files, perhaps for
compatibility with other applications that support those formats.

For more information about how business object models are converted to XSD files see Business Object
Model Mappings to XML Schema.

For information on specifying whether the business object model should be validated for export as an XML
Schema or a WSDL file, see Setting Generation Preferences and Business Object Model Mappings to WSDL.

If you want to define which elements to export as top-level elements when you export to XSD, go to the
Properties page for a user-defined BOM, and on the Exports tab you will see XML Schema Export Options.
This will show the elements available in your BOM, and you can select those you want to ’Export to XSD
Top Level Element’ in subsequent XML Schema exports.

Exporting Business Object Models to XML Schema Files
You can export Business Object Models to XML Schema files.

Procedure

1. Start the export wizard using one of the following methods:

● Right-click the Business Objects folder, and select Export > XML Schema.

● Select File > Export > Other > XML Schema.

2. The XML Schema dialog is displayed. Select the business object models that you want to export, and
select a destination for the XSD file (either in the /Exports/XML Schema directory in the project, or in a
different path). The Exports folder is created if it does not yet exist and shown in the Project Explorer.

3. Click Finish. The XSD files are generated in the specified location. A separate XSD file is created for
each package in the business object model.

Exporting Business Object Models to WSDL Files
You can export a business object model to a WSDL. The export procedure is very similar to that for
exporting to XSD; the business object model is first converted to XSD format and then the XSD file is
converted to WSDL format.

Procedure

1. Start the export wizard using one of the following methods:

● Right-click the Business Objects folder, and select Export > WSDL.

● Select File > Export > Other > WSDL.
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2. The Export WSDL dialog is displayed. Select the business object models that you want to export, and
select a destination for the WSDL file (either in the /Exports/WSDL directory in the project, or in a
different path). The Exports folder is created if it does not yet exist and shown in the Project Explorer.

3. Click Finish. The WSDL files are generated in the specified location.

Exporting a Class to XML Schema File
You can export a specific class to an XML Schema file without exporting the entire business object model of
which it is a part.

Any objects on which that class has a dependency - for example, any attributes or operations it contains -
will be exported with it. This dependency is worked out recursively, so that any dependencies of the
dependencies, and so on, are also exported.

Procedure

1. Right-click on the representation of the class in the business object model diagram editor, and select
Export > XML Schema .

2. The XML Schema dialog is displayed. Check the selection and change it if necessary. Select a destination
for the XSD file (either in the /Exports/XML Schema directory in the project, or in a different path). The
Exports folder is created if it does not yet exist and shown in the Project Explorer.

If you check the Preserve Schemas checkbox, the export process will try to preserve the structure of the
schema by creating a separate XSD file for each package that is included in the export. If you do not
check that box, the export process flattens out all packages into one XSD file.

3. Click Finish. The XSD files are generated in the specified location.

Exporting a Class to WSDL Format
You can export a specific class to an WSDL file.

Any objects on which that class has a dependency - for example, any attributes or operations it contains -
will be exported with it. This dependency is worked out recursively, so that any dependencies of the
dependencies, and so on, are also exported.

Procedure

1. Right-click on the representation of the class in the business object model diagram editor, and select
Export > Export to WSDL .

2. The WSDL dialog is displayed. Check the selection and change it if necessary. Select a destination for
the WSDL file (either in the /Exports/WSDL directory in the project, or in a different path). The Exports
folder is created if it does not yet exist and shown in the Project Explorer.

If you check the Preserve Schemas checkbox, the export process will try to preserve the structure of the
schema by creating a separate WSDL file for each package that is included in the export. If you do not
check that box, the export process flattens out all packages into one WSDL file.

3. Click Finish. The WSDL files are generated in the specified location.

Setting Diagram Preferences
You can customize the appearance of the Business Object Modeler.

Procedure

1. Select Window > Preferences .
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2. Expand Diagram and Business Object Model Diagram.

● Clicking Appearance displays a dialog that allows you to change the color of fonts, backgrounds,
fill colors, and so on.

● Clicking Connections displays a dialog that allows you to change the line style of the Connections
in the Business Object Modeler (for example, Associations, Generalizations, and so on).

● Clicking Pathmaps displays a dialog that allows you to specify path variables to modeling artifacts
that you might want to use in your business object model.

There are two more options Printing and Ruler and Grid. Even though these options are
not displayed directly under BOM Diagram, they apply only to the Business Object
Modeler, and not to the Process Modeler.

● Clicking Printing displays a dialog that allows you to specify the print settings for your business
object models (for example, orientation, page size and the margins).

● Clicking Ruler and Grid displays a dialog that allows you to specify whether or not the ruler or
grid is displayed when defining business object models in the Business Object Modeler.

Result

Any changes you apply affect new objects only. To change the appearance of existing objects, select the
object then use the Appearance tab in the Properties view or the options on the Diagram menu.

Setting the Validation Preferences
You can customize the validation that is performed on the business object models that you create.
Specifically, you can specify its severity level as Error, Warning, Info, or Ignore.

Procedure

1. Select Window > Preferences .

2. Expand Business Object Modeler and select Errors/Warnings. The following dialog is displayed:

173

TIBCO Business Studio™ Modeling Guide



3. If you want to change the severity level for a business object model problem, select from the drop-down
list. When you have finished, click OK to make the changes and close the window, or Apply to put into
effect any changes you have made and keep the dialog open.

4. The following Error/Warning Settings Changed dialog is displayed:

● Click Yes to revalidate your workspace. Depending on the size of the workspace and the number of
errors, there is a delay while the revalidation occurs.

This rebuilds every Project in the workspace. This could cause the deployment of any
Projects that are set to deploy automatically on save.

● Click No to revalidate your workspace later. The revalidation will take place when the business
object file next changes or is saved, or when you explicitly request a rebuild of the project or
workspace.

● Click Cancel if you do not wish to apply your changes.
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Setting Generation Preferences
You can specify whether TIBCO Business Studio should automatically validate business object models to
check whether they are correctly formed for export as XSD or WSDL files.

Procedure

1. Select Window > Preferences .

2. Expand Business Object Modeler and select Business Object Model Generator. The following dialog
is displayed:

3. If you want to make any changes, check or uncheck the appropriate boxes under the XSD Generation
Options and WSDL Generation Options headings. When you have finished, click OK to make the
changes and close the window, or Apply to put into effect any changes you have made, and keep the
dialog open.

Result

These options have the following effects:

● If you check Validate generated output against XSD Schema, TIBCO Business Studio automatically
runs the XSD validation rules for any business object model that you try to export in XML Schema
format. If the model does not meet these validation rules, the XML Schema files are still created, so that
you can examine them to diagnose the problem, but an error is generated.

● If you check Validate generated output against WSDL Schema, TIBCO Business Studio automatically
runs the WSDL validation rules for any business object model that you try to export in WSDL format.
The model must meet both these validation rules and the XSD validation rules - because the process of
exporting to WSDL includes an initial export to XSD, as described in Exporting Business Object Models
to WSDL Files - if it is to be exported to WSDL. If the model does not meet these validation rules, the
WSDL files are still created, so that you can examine them to diagnose the problem, but an error is
generated.

See XSD Export Validation Rules for the XSD and WSDL validation rules.
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Note that for either XML Schema or WSDL files to be validated, you must either:

● Have no destination environment selected for the process,

● Have at least one valid destination environment selected for the process.

If you have selected only environments that are not valid for XSD export (such as Simulation), then no
validation or export will be performed.

See Correcting Validation Errors and Setting the Validation Preferences for more details.
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Business Object Model Mappings to XML Schema

This section describes how XML Schema Definition (XSD) files and business objects are mapped to each
other during import and export, and how business object models are validated for export to XSD formats.

Import Mappings - XSD to Business Object Model
An XML schema document (XSD) can be imported into TIBCO Business Studio to create a Business Object
Model. This section describes the mappings between the original XSD constructs and the resulting Business
Object Model constructs.

See Importing XML Schema Files.

In addition to creating UML elements in the Business Object Model, the original XSD information is also
stored internally as stereotypes defined within a custom UML profile. This information is used if the
Business Object Model originating from an XML schema import is re-exported as XSD so that the exported
schema can be reconstructed to be logically equivalent to the original without loss of information (see 
Export Mappings). Note however, that this information exists only until the user makes a change to the
model of the newly created Business Object Model. At this point the user will be presented with the
following dialog:

Clicking OK will remove the profile containing the original XSD information. Subsequent export of this
Business Object Model to XML Schema will follow the mappings for a "user-defined" Business Object
Model outlined in Export Mappings.

Target Namespace

The schema ExampleSchema.xsd with the following namespace information:
<schema xmlns=http://www.w3.org/2001/XMLSchema targetNamespace="http://www.example.org/
ExampleSchema"
 mlns:tns="http://www.example.org/ExampleSchema" elementFormDefault="qualified">
</schema>

Creates a Business Object Model called ExampleSchema.bom with the following:

Included Schemas

XML schemas can include other schema of the same target namespace. Included schemas are merged into a
single Business Object Model.
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Imported Schemas

If ExampleSchema.xsd has the following <import> construct:
<import namespace="http://www.example.org/ImportedSchema" 
schemaLocation="ImportedSchema.xsd"/>

Then in addition to ExampleSchema.bom another BOM is generated called
org.example.imported.schema.bom with the following details

XSD SimpleType
XML Schema SimpleType constructs are mapped directly to a Business Object Model PrimitiveType.

Basic SimpleType

XML Schema SimpleType constructs are mapped directly to a Business Object Model PrimitiveType.

For example:
<simpleType name="SimpleType2">
 <restriction base="string" />
</simpleType>

Maps to:

XML schema to Business Object Model data type mappings are described in section Data Type Mappings.

SimpleType that Extends Another SimpleType

The following XML schema construct:
<simpleType name="SimpleType3">
 <restriction base="tns:SimpleType2" />
</simpleType>
<simpleType name="SimpleType2">
 <restriction base="string" />
</simpleType>

Maps to:
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Note that SimpleType3 extends (generalizes) SimpleType2.

Annotation within SimpleType

The following XML schema construct:
<simpleType name="SimpleTypeAnnot">
 <annotation>
  <documentation>Annotation to a SimpleType</documentation>
 </annotation>
  <restriction base="integer"></restriction>
</simpleType>

Maps to:

The text contained within the <documentation> tag will be visible in the Description tab of the Business
Object Model PrimitiveType property sheet.

XSD Complex Type
XML Schema ComplexType constructs are mapped directly to a Business Object Model Class. Element and
attribute constructs within the ComplexType will map to Business Object Model attributes with multiplicity
dependent on context (see examples below).

ComplexType with Attributes and Sequence of Elements

The following XML schema construct:
<complexType name="Address">
 <sequence>
  <element name="firstName" type="string" />
  <element name="lastName" type="string" />
  <element name="firstLineAdress" type="string" />
  <element name="city" type="string" />
  <element name="region" type="string" />
<element name="postcode" type="string" />
 </sequence>
 <attribute name="id" type="integer" />
</complexType>

Maps to:
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Note that <element> constructs, in the absence of any maxOccurs and minOccurs facets, map by default to a
Business Object Model attribute with multiplicity of 1. The <attribute> construct will always map to a
Business Object Model attribute with multiplicity 0..1, reflecting the optional nature of an XSD attribute.

ComplexType with Element of Type ComplexType

The following XML schema construct:
<complexType name="BankCustomer">
 <sequence>
  <element name="id" type="integer" />
  <element name="name" type="string"></element>
  <element name="account" type="tns:Account" />
 </sequence>
</complexType>
<complexType name="Account">
 <sequence>
  <element name="number" type="integer" />
 </sequence>
</complexType>

Maps to:
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In this example, Account is a ComplexType and hence represented as a Class on the Business Object Model.
The BankCustomer Class, subsequently, has a composition relationship with Account representing the
"account" <element>.

ComplexType with SimpleContent

The following XML schema construct:
<simpleType name="SimpleType">
 <restriction base="string">
 </restriction>
</simpleType>
<complexType name="ComplexType">
 <simpleContent>
  <extension base="tns:simpleType" />
 </simpleContent>
</complexType>

Maps to:

Note that the <simpleContent> construct maps to a Class attribute with multiplicity 0..1. The anonymous
nature of the <simpleType> construct meant that the Business Object Model had to assign the name "value"
to its attribute.

ComplexType with ComplexContent Extension

The following XML schema construct:
<complexType name="Person">
 <sequence>
  <element name="name" type="string"></element>
 </sequence>
</complexType>
<complexType name="Customer">
 <complexContent>
 <extension base="tns:Person">
 <sequence>
  <element name="id" type="string"></element>
 </sequence>
 </extension>
 </complexContent>
</complexType>

Maps to:
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The Business Object Model creates a Generalization relationship between the Customer and Person Classes.

ComplexType with ComplexContent Restriction

The following XML schema construct:
<complexType name="shoppingBasket">
 <sequence>
  <element name="productId" type="positiveInteger"   maxOccurs="unbounded"/>
 </sequence>
</complexType>
<complexType name="basketCapped">
 <complexContent>
 <restriction base="tns:shoppingBasket">
 <sequence>
  <element name="productId" type="positiveInteger" maxOccurs="5" />
 </sequence>
 </restriction>
 </complexContent>
</complexType>

Maps to:
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Note that the multiplicity of productId in the basketCapped class is represented by a 1..n, that is, more
restrictive that the shoppingBasket class productId that has unbounded multiplicity.

Anonymous ComplexType

The following XML schema construct:
<complexType name="Ct1">
 <sequence>
  <element name="Elem">
  <complexType>
 <sequence>
  <element name="anon" type="string"></element>
 </sequence>
  </complexType>
  </element>
 </sequence>
</complexType>

Maps to:

The anonymous ComplexType within the "elem" element means "elem" is represented as a Class on the
Business Object Model, with an assigned name of "ElemType". The containment of "ElemType" within "ct1"
is represented by a Composition relationship.

Annotation within ComplexType

The <documentation> information in the following XML schema constructs will be visible in the
Description tab of the Business Object Model PrimitiveType property sheet.

The following XML schema construct:
<complexType name="ComplexTypeAnnot">
 <annotation>
 <documentation>Annotation to a ComplexType</documentation>
 </annotation>
</complexType>

Maps to:
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ComplexType with Mixed Construct

The following XML schema construct:
<xs:complexType name="Car" mixed="true">
  <xs:sequence>
    <xs:element name="colour" type="xs:string" />
  </xs:sequence>
</xs:complexType>

Maps to:

ComplexContent with Mixed Construct

The following XML schema construct:
<xs:complexType name="Car">
                        <xs:complexContent mixed="true">
                                    <xs:extension base="SuperCar">
                                                <xs:sequence>
                                                            <xs:element name="engine" 
type="xs:string"/>
                                                </xs:sequence>
                                    </xs:extension>
                        </xs:complexContent>
            </xs:complexType>

Maps to:
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A mixed complex content can only exist if it extends another complex type that is also labelled as mixed.

See http://www.w3.org/TR/xmlschema11-1/#dcl.ctd.ctcc.common

It is not valid for the mixed construct on complex type and complex content to be different.

XSD Global Elements
XML schema global elements and attributes do not translate directly into Business Object Model (i.e. UML)
data. However, they do need to be represented by some means so that they can be reconstructed in
exported XML schema, if the Business Object Model originated from an XML schema import.

Simple Element and Attribute Type

The following XML schema construct:
<schema>
 <element name="TestStringData" type="string"></element>
</schema>

Maps to Business Object Model Primitive Type:

A stereotype is applied to the "TestStringData" PrimitiveType identifying it as a XSD global element.

Element of Complex Type

The following XML schema construct:
<element name="PersonElement" type="Person"></element>
<complexType name="Person">
 <sequence>
  <element maxOccurs="1" minOccurs="1" name="name">
  <simpleType>
  <restriction base="string">
  <maxLength value="50"></maxLength>
  </restriction>
  </simpleType>
  </element>
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 </sequence>
</complexType>

Maps to a Business Object Model Class representing the Person ComplexType:

Maps to:

The global element "PersonElement" is not represented directly on the Business Object Model diagram.
Instead, the Class "Person" has a stereotype applied to it that stores data representing all the global
elements in the original schema that were of this type.

Top Level Enumeration Elements

The following XML schema construct:
<element name="topElement" type="SubAccountType"></element>
<simpleType name="SubAccountType">
 <restriction base="string">
 <enumeration value="Cash"></enumeration>
 <enumeration value="Margin"></enumeration>
 <enumeration value="Income"></enumeration>
 <enumeration value="Short"></enumeration>
 <enumeration value="DVP/RVP"></enumeration>
 <enumeration value="Dividend"></enumeration>
 </restriction>
</simpleType>

Maps to a Business Object Model Class representing the SubAccountType ComplexType:

The appropriate stereotype information represents the global element "topElement".

Export Mappings
There will be differences in the exact nature of the export transformation depending on the origin of the
Business Object Model.

This will depend on whether it:

● was created as a new Business Studio asset.

● originated from an XML Schema import.

If it originated from an XML Schema import, the exported Business Object Model will create XML schema
logically equivalent to the original imported schema, using the information stored as stereotypes in an
internal UML profile. However, this is dependent on the user not having changed the Business Object
Model after the import, in which case the profile information will have been discarded.
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The examples described in this section are for user-defined Business Object Models only.

Business Object Model Mappings to XML Schema describes the XML schema constructs that result from the
original Business Object Model constructs.

Export of Business Object Models to XML Schema or WSDL Files describes how Business Object Models
can be exported to XML Schema (XSD) files.

Primitive Type
Business Object Model primitive types are translated to XSD simple types. The simple types’ base
restriction is set to the xsd data type corresponding to the original Business Object Model data type.

These mappings are defined in Data Type Mappings.

For example:

Transforms to: 
<xsd:simpleType id="_5_yrABpLEeChWL2te4gBZg" name="PrimitiveType1">
    <xsd:restriction base="xsd:string">
      <xsd:maxLength value="50"/>
    </xsd:restriction>
  </xsd:simpleType>

Class
This section describes Business Object Model classes.

Complex Type

A Business Object Model Class is transformed into an XSD ComplexType.

For example:

Transforms to:
  <xsd:complexType id="_Q8fQQBpMEeChWL2te4gBZg" name="Class1"/>

Complex Type - Class with Attributes

Business Object Model attributes contained within a Class are transformed into XSD elements within a
sequence contained within the ComplexType created to represent the Class.

For example:
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Transforms to:
  <xsd:complexType id="_oyUc8BpMEeChWL2te4gBZg" name="Class2">
    <xsd:sequence>
      <xsd:element id="_pSM24BpMEeChWL2te4gBZg" maxOccurs="1" minOccurs="0" 
name="attribute1">
        <xsd:simpleType>
          <xsd:restriction base="xsd:string">
            <xsd:maxLength value="50"/>
          </xsd:restriction>
        </xsd:simpleType>
      </xsd:element>
      <xsd:element id="_ppTIQBpMEeChWL2te4gBZg" default="false" maxOccurs="1" 
minOccurs="0"
          name="attribute2">
        <xsd:simpleType>
          <xsd:restriction base="xsd:boolean"/>
        </xsd:simpleType>
      </xsd:element>
      <xsd:element id="_sVEK8BpMEeChWL2te4gBZg" maxOccurs="1" minOccurs="0" 
name="attribute3">
        <xsd:simpleType>
          <xsd:restriction base="xsd:int">
            <xsd:totalDigits value="10"/>
          </xsd:restriction>
        </xsd:simpleType>
      </xsd:element>
    </xsd:sequence>
</xsd:complexType>

Enumeration
A Business Object Model Enumeration is transformed into an XSD SimpleType.

For example:

Transforms to:
<xsd:simpleType id="_-xfC8BpMEeChWL2te4gBZg" name="COLORS">
    <xsd:restriction base="xsd:string">
      <xsd:enumeration value="RED"/>
      <xsd:enumeration value="GREEN"/>
      <xsd:enumeration value="BLUE"/>
    </xsd:restriction>

Model

The name of the UML Model construct (which forms the base package of the Business Object Model), is
used to define the target namespace of the exported XML schema, and the name of the XML schema file.

For example a file called example.Business Object Model:
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Transforms to file com.example.businessobjectmodel1.xsd with the following namespace information:
<xsd:schema
    xmlns="http://example.com/businessobjectmodel1" xmlns:tns1="http://example.com/
businessobjectmodel1"
    xmlns:xsd="http://www.w3.org/2001/XMLSchema" targetNamespace="http://example.com/
businessobjectmodel1">
  <xsd:annotation>
    <xsd:documentation>BOMORIGIN::/p1/Business Objects/BusinessObjectModel1.bom</
xsd:documentation>
  </xsd:annotation>
</xsd:schema>

Package
For each Business Object Model Package encountered during the export transformation, a new separate
XSD file will be created. Similar to the UML Construct, the Package name is used to define the XSD
filename and target namespace.

If the following package exists in the Model com.example.businessobjectmodel1:

Then two schema files will be generated:

● com.example.businessobjectmodel1.xsd (as above)
● A separate xsd file will be generated to represent the package called:

com.example.businessobjectmodel1.comexamplewwwstockcheck.xsd

with the following namespace information:
<xsd:schema
 xmlns="http://example.com/businessobjectmodel1/comexamplewwwstockcheck"
  xmlns:tns1="http://example.com/businessobjectmodel1/comexamplewwwstockcheck"
  xmlns:xsd="http://www.w3.org/2001/XMLSchema"
  targetNamespace="http://example.com/businessobjectmodel1/comexamplewwwstockcheck">
 <xsd:annotation>
  <xsd:documentation>BOMORIGIN::/p1/Business Objects/BusinessObjectModel1.bom</
xsd:documentation>
  </xsd:annotation>
</xsd:schema>

Furthermore, the com.example.businessobjectmodel1.xsd schema will contain an <import> construct
referencing com.example.businessobjectmodel1.comexamplewwwstockcheck.xsd

that is:
<xsd:schema xmlns="http://example.com/businessobjectmodel1"
  xmlns:tns2="http://example.com/businessobjectmodel1"
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 xmlns:tns1="http://example.com/businessobjectmodel1/comexamplewwwstockcheck"
 xmlns:xsd="http://www.w3.org/2001/XMLSchema" targetNamespace="http://example.com/
businessobjectmodel1">
  <xsd:annotation>
  <xsd:documentation>BOMORIGIN::/p1/Business
 Objects/BusinessObjectModel1.bom</xsd:documentation>
  </xsd:annotation>
  <xsd:import
 namespace="http://example.com/businessobjectmodel1/comexamplewwwstockcheck"
 schemaLocation="com.example.businessobjectmodel1.comexamplewwwstockcheck.xsd" />
</xsd:schema>

Relationships
Currently, only two Business Object Model relationships are supported for XML schema export, namely
Generalizations and Compositions.

Generalization

A Class may generalize another Class:

Transforms to:
  <xsd:complexType id="_sJ1ZEBpREeChWL2te4gBZg" name="Customer">
    <xsd:complexContent>
      <xsd:extension base="tns1:Person"/>
    </xsd:complexContent>
  </xsd:complexType>
  <xsd:complexType id="_so-MIBpREeChWL2te4gBZg" name="Person"/>

A Primitive Type may generalize another Primitive Type.
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Transforms to:
  <xsd:simpleType id="_Gf-mYBpSEeChWL2te4gBZg" name="BaseType">
    <xsd:restriction base="xsd:string">
      <xsd:maxLength value="50"/>
    </xsd:restriction>
  </xsd:simpleType>
  <xsd:simpleType id="_GpqG0BpSEeChWL2te4gBZg" name="ExtendedType">
    <xsd:restriction base="tns1:BaseType">
      <xsd:maxLength value="50"/>
    </xsd:restriction>
  </xsd:simpleType>

Composition 

The following composition construct:

Transforms to:
  <xsd:complexType id="_7-Eb8BpTEeChWL2te4gBZg" name="Customer">
    <xsd:sequence>
      <xsd:element id="_DkCHxBpUEeChWL2te4gBZg" maxOccurs="1" minOccurs="1" 
name="address"
          type="Address"/>
    </xsd:sequence>
  </xsd:complexType>
  <xsd:complexType id="_8PfjIBpTEeChWL2te4gBZg" name="Address"/>
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Data Type Mappings
Data type mappings can be XML Schema to Business Object Model Import Mappings or Business Object
Model to XML Schema Export Mappings.

XML Schema to Business Object Model Import Mappings
During the import process XML Schema data types (defined at http://www.w3.org/TR/xmlschema-2/) are
mapped to the existing primitive Business Object Model data types with appropriate restrictions. In many
cases there is no direct mapping and consequently the closest match is made.

XSD data type Mapping to Business Object Model primitive type

xsd:gDay Text

The following pattern is used to ensure valid formatting:
\-\-\-(0[1-9]|[12][0-9]|3[01])(|Z|[+-](0[0-9]|[1][0-3]):
(0[0-9]|[12345][0-9]))

xsd:gMonth Text

The following pattern is used to ensure valid formatting:

\-\-(0[1-9]|[1][0-2])(|Z|[+-](0[0-9]|[1][0-3]):(0[0-9]|[12345][0-9]))

xsd:gMonthDay Text

The following pattern is used to ensure valid formatting:

\-\-(0[1-9]|[1][0-2])\-(0[1-9]|[12][0-9]|3[01])(|Z|[+-](0[0-9]|[1][0-3]):
(0[0-9]|[12345][0-9]))

xsd:gYear Text

The following pattern is used to ensure valid formatting:

(\-\d{4,}|\d{4,})(|Z|[+-](0[0-9]|[1][0-3]):(0[0-9]|[12345][0-9]))

xsd:gYearMonth Text

The following pattern is used to ensure valid formatting:

(\-\d{4,}|\d{4,})(|Z|[+-](0[0-9]|[1][0-3]):(0[0-9]|[12345][0-9]))\-(0[1-9]|[1]
[0-2])(|Z|[+-](0[0-9]|[1][0-3]):(0[0-9]|[12345][0-9]))

xsd:IDREF Text

The following pattern is used to ensure valid formatting:

[\i-[:]][\c-[:]]*

xsd:IDREFS Text

A stereotype is used to indicate the original IDREFS type, but no pattern is
enforced.

xsd:language Text

The following pattern is used to ensure valid formatting:

([a-zA-Z]{2}|[iI]-[a-zA-Z]+|[xX]-[a-zA-Z]{1,8})(-[a-zA-Z]{1,8})*
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XSD data type Mapping to Business Object Model primitive type

xsd:Name Text

The following pattern is used to ensure valid formatting:

\i\c*

xsd:NCName Text

The following pattern is used to ensure valid formatting:

[\i-[:]][\c-[:]]*

xsd:NMTOKEN Text

A stereotype is used to indicate the original NMTOKEN type. The
following pattern is used to ensure valid formatting:

\c+

xsd:NMTOKENS Text

A stereotype is used to indicate the original NMTOKENS type, but no
pattern is enforced.

xsd:normalizedString Text

The following pattern is used to ensure that tab, linefeed and return
characters are replaced by spaces:

[^\t\n\r]+

xsd:QName Text

The following pattern is used to ensure valid formatting:

([\\i-[:]][\\c-[:]]*:)?[\\i-[:]][\\c-[:]]*

xsd:string Text

xsd:ENTITY Text.

The following pattern is used to ensure valid formatting:

[\i-[:]][\c-[:]]

xsd:anyType This is mapped to a non-typed attribute or primitive type.

xsd:anySimpleType This is mapped to a non-typed attribute or primitive type.

xsd:token Text

The following pattern is used to ensure valid formatting:

\c+([ ]\c+)*

xsd:boolean Boolean

xsd:base64Binary Text
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XSD data type Mapping to Business Object Model primitive type

xsd:hexBinary Attachment

The following pattern is used to ensure valid formatting:

([0-9a-fA-F][0-9a-fA-F])*

xsd:byte Integer

The following pattern is used to ensure valid formatting:

minInclusive = -128
maxInclusive = 127

xsd:unsignedByte Integer

The following restrictions are applied:

minInclusive = 0
maxInclusive = 255

xsd:integer Integer

A stereotype is used to indicate the original xsd:integer type.

xsd:long A Fixed Integer subtype of the Integer primitive type.

The following restrictions are applied:

minInclusive = -9223372036854775808
maxInclusive = 9223372036854775807

xsd:negativeInteger Fixed Integer

The following restrictions are applied:

maxInclusive = -1

xsd:nonNegativeInteger Fixed Integer

The following restrictions are applied:

minInclusive = 0

xsd:nonPositiveInteger Fixed Integer

The following restrictions are applied:

maxInclusive = 0

xsd:positiveInteger Fixed Integer

The following restrictions are applied:

minInclusive = 1

xsd:short Integer

The following restrictions are applied:

minInclusive = -32768
maxInclusive = 32767
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XSD data type Mapping to Business Object Model primitive type

xsd:unsignedInt Fixed Integer

The following restrictions are applied:

minInclusive = 0
maxInclusive = 4294967295

xsd:unsignedLong Fixed Integer

The following restrictions are applied:

minInclusive = 0
maxInclusive = 18446744073709551615

xsd:unsignedShort Fixed Integer

The following restrictions are applied:

minInclusive = 0
maxInclusive = 65535

xsd:int A Signed Integer subtype of the Integer primitive type.

The following restrictions are applied:

minInclusive = -2147483648
maxInclusive = 2147483647

xsd:float A Floating Point subtype of the Decimal primitive type.

The following restrictions are applied:

minInclusive = -3.4028235E38
maxInclusive = 3.4028235E38

xsd:double A Fixed Point subtype of the Decimal primitive type.

The following restrictions are applied:

minInclusive = -1.7976931348623157E308
maxInclusive = 1.7976931348623157E308

xsd:anyURI URI

xsd:date Date

xsd:time Time

xsd:dateTime DateTime

xsd:duration Duration

xsd:ID Text

The following pattern is used to ensure valid formatting:

[\i-[:]][\c-[:]]*

(Note that this is the same pattern as for xsd:NCName.)
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XSD data type Mapping to Business Object Model primitive type

xsd:mixed Boolean

Business Object Model to XML Schema Export Mappings

Business Object
Model Primitive Type Mapping to XML Schema data type

Boolean xsd:boolean

Date xsd:date

Date Time xsd:dateTime

Date Time and Time
Zone

xsd:dateTime

The following pattern is used to ensure valid formatting:

.+T.+(Z|[+-].+)

Decimal xsd:double

xsd:decimal

Duration xsd:duration

ID xsd:string

The following pattern is used to ensure valid formatting:

[\i-[:]][\c-[:]]*

Integer xsd:int

xsd:integer

Object xsd:any

Text xsd:string

The following restrictions are applied:

maxLength value="50"

Time xsd:time

URI xsd:anyURI

Round-trip Export
Note that the original XSD data types are preserved on export if the Business Object Model has not been
modified by the user and hence the XSD Notation profile is still applied.
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XSD Export Validation Rules
If you have specified that business object models should be validated for export to XSD or to WSDL, the
following rules are applied.

Rule Severity

Class cannot contain multiple ID attributes Error

Enum Literal does not match the required regular expression Error

Enumeration must contain a subset of Enumeration Literals as Enumeration Error

Class contains a duplicate attribute name Error

Primitive Type default value will be lost on transformation Warning

The current Destination ignores default values for Primitive Types Warning

Operations are ignored for the current Destination(s) Warning

Only Generalization and unidirectional composition are supported Error

Invalid Package name Error

Association Classes are not supported Error

constraint exceeded Error

Attribute default value exceeds Max Text Length Error

Attribute lower limit exceeds upper limit Error

Attribute lower limit exceeds default value Error

Attribute default value exceeds upper limit Error

Attribute lower limit value length exceeds max number length Error

Attribute upper limit value length exceeds max number length Error

Attribute default value length exceeds max number length Error

Attribute lower limit value has more decimal places than the maximum defined Error

Attribute upper limit value has more decimal places than the maximum defined Error

Attribute default value has more decimal places than the maximum defined Error

Attribute default value does not conform to defined pattern Error

Attribute's number of decimal places exceeds number length Error
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Rule Severity

Cyclic Dependency has been detected for this resource Error

Classifier exports to top level element and name cannot end with "Element" Error

PrimitiveType cannot be set to type Object Error

More that one attribute of type Object exists in Class hierarchy Error

Attribute type must be set Error

Cannot generalize a Classifier with XSD Notation attribute "final" Error

An attribute of type Object xsd:any must be the last in the parent's list of attributes Error

Attribute preceding Object xsd:any must have equivalent max and min multiplicity
values

Error

Attribute following Object xsd:any must have equivalent max and min multiplicity
values

Error

Object type multiplicity must be fixed if container Class is generalized Error

Setting Generation Preferences.

XSD Import Restrictions
The following XSD constructs are not supported by Business Object Model import.

When importing XML Schema the files are scanned to ensure the following elements do not occur. If they
do, an error is shown and the transformation cannot take place:

Unsupported Elements

● xsd:key

● xsd:keyref

● xsd:list

● xsd:redefine

● xsd:unique

Unsupported Built-in Datatypes

● xsd:NOTATION
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Business Object Model Mappings to WSDL

The name of the Business Object Model file is derived from the target namespace of the WSDL.

A Business Object Model generated from a WSDL represents:

● Each <wsdl:portType> construct as a UML class.

● The <wsdl:operation> construct as a UML operation.

● The <wsdl:schema> constructs used to define data types in <wsdl:message> constructs as Business
Object Model entities according to mapping rules defined in Business Object Model Mappings to XML
Schema.

Worked Example
The following WSDL generates a Business Object Model file called com.example.example1.bom.:
<?xml version="1.0" encoding="UTF-8"?>
<wsdl:definitions xmlns:tns1="http://example.com/example1"
 xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/" xmlns:xsd="http://www.w3.org/2001/
XMLSchema"
 targetNamespace="http://example.com/example1">
 <wsdl:types>
  <xsd:schema targetNamespace="http://example.com/example1">
   <xsd:complexType name="Person">
    <xsd:sequence>
     <xsd:element name="firstName" type="xsd:string" />
     <xsd:element name="lastName" type="xsd:string" />
     <xsd:element name="id" type="xsd:string" />
     <xsd:element name="category" type="xsd:string" />
    </xsd:sequence>
   </xsd:complexType>
  </xsd:schema>
 </wsdl:types>
 <wsdl:message name="myOutputMessage">
  <wsdl:part name="person" type="tns1:Person" />
 </wsdl:message>
 <wsdl:message name="myInputMessage">
  <wsdl:part name="lastName" type="xsd:string" />
  <wsdl:part name="id" type="xsd:boolean" />
 </wsdl:message>
 <wsdl:portType name="GetPersonData">
  <wsdl:operation name="my_operation">
   <wsdl:input message="tns1:myInputMessage" name="myInputMessage" />
   <wsdl:output message="tns1:myOutputMessage" name="myOutputMessage" />
  </wsdl:operation>
  </wsdl:portType>
</wsdl:definitions>

The Business Object Model file contains the following Business Object Model entities:

Note the following:

● The GetPersonData class represents the <wsdl:portType> construct in the original WSDL.

● The <wsdl:operation name=”my_operation”> construct is represented by the “my_operation” UML
operation in class GetPersonData.
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● The <wsdl:input> and <wsdl:output> constructs are represented by the input and return parameter
type respectively, of the ”my_operation” UML operation. The <wsdl:message> and <wsdl:part>
constructs are used to set the input and return parameter types.

● The embedded schema’s complexType “Person” results in the UML Class Person. If the target
namespace of the embedded schema had been different from the WSDL’s, or if it had been from an
imported schema, then a new, separate Business Object Model would have been created.

WSDL Import Restrictions
Importing a WSDL to create a Business Object Model is not supported in certain circumstances.

● The WSDL to be imported has more than one output part. Business Object Model operations can have
only one return type.

● The XML schema has import restrictions, as outlined in XSD Import Restrictions.
● The WSDL is invalid.

In each of these cases the import does not complete and a dialog is displayed summarizing the error.

Export Mappings – Business Object Model to WSDL
Exporting a Business Object Model to a WSDL file has a number of results.

It generates:

● A port type for every Class within the Business Object Model that has at least one operation.
● Within each port type, a WSDL operation corresponding to each Class operation.
● An output message corresponding to the return type of each Business Object Model operation.
● An input message for each input parameter of the Business Object Model operation.
● An embedded XML schema generated following the transformation rules described in Export

Mappings.

For example the following Business Object Model Class:

Maps to the following WSDL constructs:
<?xml version="1.0" encoding="UTF-8"?>
<wsdl:definitions
    xmlns:tns1="http://example.com/businessobjectmodel" xmlns:wsdl="http://
schemas.xmlsoap.org/wsdl/"
    xmlns:xsd="http://www.w3.org/2001/XMLSchema" targetNamespace="http://example.com/
businessobjectmodel">
  <wsdl:types>
    <xsd:schema targetNamespace="http://example.com/businessobjectmodel">
      <xsd:annotation>
        <xsd:documentation>BOMORIGIN::/p1/Business Objects/BusinessObjectModel.bom</
xsd:documentation>
      </xsd:annotation>
      <xsd:complexType id="_4SxvkAbDEeCEXKKc2dARYw" name="MyClass1"/>
      <xsd:element name="MyClass1Element" type="tns1:MyClass1"/>
    </xsd:schema>
  </wsdl:types>
  <wsdl:message name="MyClass1_operation1_outputMessage">
    <wsdl:part name="operation1_outputPart" type="xsd:boolean"/>

200

TIBCO Business Studio™ Modeling Guide



  </wsdl:message>
  <wsdl:message name="MyClass1_operation1_inputMessage">
    <wsdl:part name="inputParam1" type="xsd:string"/>
    <wsdl:part name="inputParam2" type="xsd:string"/>
  </wsdl:message>
  <wsdl:portType name="MyClass1">
    <wsdl:operation name="operation1">
      <wsdl:input message="tns1:MyClass1_operation1_inputMessage" 
name="operation1_inputMessage"/>
      <wsdl:output message="tns1:MyClass1_operation1_outputMessage" 
name="operation1_outputMessage"/>
    </wsdl:operation>
  </wsdl:portType>
</wsdl:definitions>

Note that if a Business Object Model operation contains a parameter that is not a default primitive type,
then the exported WSDL includes the appropriate XML schema so that the operation can refer to this
schema.
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Troubleshooting

This section describes some issues encountered when working with TIBCO Business Studio and their
possible solutions.

In previous versions of TIBCO Business Studio, TIBCO recommended disabling in-memory validation by
deselecting Project > Build Automatically as a way of achieving performance gains. Because of
performance enhancements with this version of TIBCO Business Studio, this is no longer necessary and is
not desirable as it causes problems resolving references.

Application Upgrade Issue
This describes a workaround to an issue which occurs when TIBCO Business Studio 3.5.3 projects that have
corresponding processes deployed to a TIBCO ActiveMatrix BPM 1.3 runtime are upgraded to new
software versions.

When these projects are imported into TIBCO Business Studio 3.5.4 and redeployed to an upgraded TIBCO
ActiveMatrix BPM 2.0 runtime, the XML schemas derived from the Business Object Models are
regenerated. The regenerated schemas are then incorporated into WSDLs generated from business
processes.

When the project DAAs are deployed to the TIBCO ActiveMatrix BPM 2.0 runtime, the User Application
upgrade process performs a checksum comparison on the new TIBCO Business Studio 3.5.4 WSDLs and the
previously deployed TIBCO Business Studio 3.5.3 WSDLs to determine whether there have been any
changes to the process interfaces. However, these checksum comparisons fail because of the regenerated
schema changes, not because of any interface changes, and deployment fails.

Workaround

Procedure

1. Start TIBCO Business Studio 3.5.4 with a new workspace.

2. Switch off auto-build (select Project and de-select Build Automatically).

3. Select Window > Preferences > Business Object Modeler > Business Object Model Generator , and
ensure that the WSDL and XSD Export/Generation preference options are unchecked.
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4. Import old (TIBCO Business Studio 3.5.3) projects one at a time using Import > Existing Projects into
Workspace (that is, Eclipse importer) Do not use the Existing Studio Projects into Workspace option.
Ensure that the Copy projects to workspacecheckbox is ticked.

5. For each imported project, right-click and open Properties. Uncheck the Builders BOM to XSD
Builderand WSDL Generator Builderand click OK.

6. Select Projectand Build Automaticallyand wait for the builds to finish.

7. Resolve errors such as 'project needs migrating’ or ’special folder missing' using quick-fixes in the
Problems view.

8. Generate the DAAs for projects.

9. Deploy the DAAs (which will upgrade the existing application).

Default Channels are Unavailable
The default presentation channels are unavailable if the default channel is not enabled.

Procedure

1. Select the project in the Project Explorer, and click File > Properties .

2. In the navigation pane on the left side of the Properties dialog, click Presentation Channels.

3. Verify that the Enable project specific settings checkbox is checked.

Submenus Selection not Available when you Switch Workspace
Sometimes when you click on File > Switch Workspace > submenus are displayed, but then you cannot
select anything since no focus is available on submenus.

If this occurs, try again. Click back on File > Switch Workspace > submenus, and then focus is available and
you can select the intended option.

Manual Deletion of Presentation Resources Special Folder Problem
If you manually delete the Presentation Resources special folder from a project and then try to generate a
DAA, DAA generation fails with an error similar to the one below:
org.eclipse.core.runtime.CoreException: Project 'Sanity-Hotfix' is missing a special 
folder of kind 'presentation'. Please invoke the asset configuration quick fix from 
the Problems view.
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Applying the quick fix in this situation will not work. You must manually create a folder and set it as a
Presentation Resources special folder and retry generating the DAA.

Refactoring When Importing from Studio for Analysts into Studio for
Designers

For projects imported from "Studio for Analysts" into "Studio for Designers", the destination (that is, BPM)
specific validators and other features are not applicable This is because the destination cannot be set in
Studio for Analysts, and therefore is not set when you import the project.

For example, you will not have the JavaScript option on sequence flows (it is not applicable in Studio for
Analysts, and therefore is not available after import).

In this case, after import:

Procedure

1. Open the project properties and set the applicable destination (for example, BPM) on the 'Lifecycle'
page.

2. Right-click on the project Refactor > Project Lifecycle .

Result

Although the JavaScript option is available for scripts after refactoring, you still need to manually select it.

Failures in Linux Version 7 when TIBCO Business Studio uses the SWT
Internal Browser

There are failures in Linux Version 7 (OEL7, CentOS 7, RHEL 7) when TIBCO Business Studio uses the SWT
internal browser (used for BPM Live Dev, Email Service Task, TIBCO Product Help view) and an error
message is displayed.

You will see the following error:

When you click OK you see the following error message.
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To fix this you must install 64-Bit XULRunner 1.9.2. You need to download this from the Mozilla nightly
builds site: http://ftp.mozilla.org/pub/mozilla.org/xulrunner/nightly/2012/03/2012-03-02-03-32-11-
mozilla-1.9.2/

1. Extract the contents of the tar file by entering the following command: tar -xvif tar-file-name

2. To make the new XULRunner version available, update the TIBCO Business Studio .ini file and add
the following Java VM arguments (vmargs) in the file: -
Dorg.eclipse.swt.browser.XULRunnerPath=pathto-XULRunner.

● Note: This update applies to a specific instance of TIBCO Business Studio. If the instance of TIBCO
Business Studio was installed for an individual user, the update only applies to that user. If TIBCO
Business Studio was installed as a shared instance that is used by multiple users, the update applies
to all users of the shared instance.

● The following procedure makes the new version available to all users on the system:

— As user root, extract the XULRunner runtime directory to a location that is accessible to all
users, for example, /usr/lib/xulrunner-1.9.2.

— From the XULRunner directory, enter the following command:./xulrunner --register-
global

● The following procedure makes the new version available to an individual user

— Extract the XULRunner runtime directory to the home directory of the user.

— From the XULRunner directory, enter the following command:./xulrunner --register-user

Registering XULRunner persists across the system and TIBCO Business Studio
restarts.

3. Restart TIBCO Business Studio and confirm that the issues have been resolved.

Importing Projects
These sections cover issues when importing projects.

See Importing Projects into your Workspace which were Created in a Previous Version of TIBCO Business
Studio.

See Importing Projects from Subversion.

Importing Projects into your Workspace which were Created in a Previous Version of
TIBCO Business Studio

When you import projects into your workspace which were created in a previous version of TIBCO
Business Studio, they may show a problem marker by the project name in Project Explorer. This occurs
when a newer version of TIBCO Business Studio has different project configuration and/or file format
requirements. The normal validation and build of projects will be disabled until this problem is fixed.

Select the project, and click Ctrl +1. You can then select one quick fix to automatically migrate the entire
project (including all the BOM & XPDL files) to the current version, and clean (Project > Clean) and build it
(Project > Build Project).

If you try to open an individual package within the project before you migrate the project, you will see a
message similar to the following (you will also see a migration validation error in the Problems view for an
old XPDL):
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Select Yes and the quick fix will be applied to migrate the whole project.

Importing Projects from Subversion
When you import projects from Subversion, they may throw a number of validation errors.

This is expected behavior. When you apply the "missing special folder" resolution this will cause a full
project build, which means that the missing generated BOMs will be generated and all problems resolved.

When you committ the project to Subversion, any folder or file that is marked as "derived" will not be
committed and therefore these resolved special folders will not be committed and this means you will
receive the error again.

It is usually good practice to run a clean build on projects checked out of Subversion.

Disabling Flow Validation to prevent lockups in the User Interface
TIBCO ActiveMatrix BPM Complex processes (with flows that are ultimately invalid for ActiveMatrix BPM
deployment) can cause the flow-analyzer to take a very long time, which can in turn lock up the user
interface. Use the workarounds described in this topic to avoid this problem.

This problem is especially likely after converting iProcess XPDL to ActiveMatrix BPM XPDL.

● Optionally switch off migration point decoration for a given process or the whole process-package (to
prevent lock ups in the user interface). From the process, select Resource > BPM User Interface
Configuration > Migration Point Decorations. Select Show or Hide.

This can be done at process and/or process-package level. If you set to Hide on either a process or its
parent package then no migration point decoration (and hence flow analysis) is performed, thus
improving performance.

● Temporarily switch off process flow analysis (for an individual process or the whole package) so you
can work on the process up until the point that you need to fix the process flow so that it is suitable for
ActiveMatrix BPM. From the process, select Resource > BPM Validation Configuration > Process flow
analysis and validation.

The option to further highlight migration point activities using the process editor highlighter toolbar
dropdown is also removed when migration point decorations are hidden.

This can be set on a process package and / or individual processes (if set on a package then flow
validation will be disabled for all processes regardless of their own setting).

Choose from the following 3 options:

● Validate Returns process flow validation to normal.

● Suppress until manual reactivation via Advanced properties Switches off process flow validation
altogether until reactivated here or via the quick fix for "Process flow validation has been disabled
rule".

● Suppress until next process flow change Switches off process flow validation until the user makes a
change that affects the process flow (such as delete/add activities or move/add /remove sequence
flows etc.)
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Business Data Project Deployment
When you create a Business Data Project it contains a BOM which you then deploy as part of the project. If
you subsequently change the BOM contained in that project, then export the .DAA and deploy the process
project that references it, you get an error (because the process references a new version of Business Data
Project).

The error you receive is similar to the following:

AMXAdminTask] 22 Jan 2014 17:18:58 ERROR - Failed to add Application

'com.example.providerAndConsumer'

[AMXAdminTask] 22 Jan 2014 17:18:58 ERROR - 22/01/14 17:18 - TIBCO-AMX-ADMIN-012391:

Follower application component com.example.providerAndConsumer/

ProcessAsServiceProcessFlow requires capability

com.tibco.amf.sca.model.componenttype.impl.RequiredCapabilityImpl@2aff38ad (id:

com.tibco.bx.capability.implementation.bx, version: 1.0.0, type: factory,

dependencyName: null, dependencyErrorMessage: null, dependencyErrorCode: null) but the

target application does not provide it.

What to do if a URL does not open in the default internal browser
If a URL does not open in the default internal browser, change the TIBCO Business Studio preference to use
the extrernal browser as the default.

When you select the hyperlink for Documentation URL (on the Description tab of the Properties view for a
process artefact) on Nimbus imports within TIBCO Business Studio for Analysts on Linux 64 (SUSE), it
throws a ssl bad certificate error.

Use the TIBCO Business Studio preferences (Window > Preferences... > General > Web Browser and select
Use external web browser radio button) to point to an external browser rather than the default internal
browser.

HTTP Request/Reply on Correlation
When a process has a correlating incoming request with a reply (i.e. message triggered after process
instance started) and it is possible that the incoming request activity is not in-progress and waiting for the
message arrival then the server HTTP request layer thread will be blocked waiting for the process to reach
that request activity. This can eventually result in all threads being blocked.

This can happen when messages are received for process instances that are already complete or that have
not reached the request activity (or may not for a long period).

To avoid this situation it is recommended that an incoming request timeout is applied to the incoming
request / reply activities in the process package.

If the process has completed or not reached the Event/Receive task then the server HTTP request layer will
wait and block the thread.

If you have an in-flow incoming Request/Reply message activity that may be triggered when the process
has completed or has not reached the activity, on the package properties, select the Resource tab, and for
BPM Runtime Configuration add a value to Incoming Request Timeout (seconds).

Alternatively consider re-architecting to use a different pattern. For example:

● An in-only Incoming Request Activity such as a receive task with in-only parameters, followed
downstream by a Send-One-Way message activity that invokes a web service provided by the request-
originating application.
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Third-Party Source Control System (MKS) Adding project.pj Files
In certain (special) folder types like Service Descriptors, TIBCO Business Studio validates against
having duplicate file names in the same folder type in different projects that reference each other. The MKS
source control system adds a project.pj file to every folder in the workspace. Therefore you end up with
two referencing project service descriptor folders containing the same file and a problem marker is raised.

This can be avoided by configuring TIBCO Business Studio to ignore project.pj files.

From the project, select Properties > Resource > Resource Filters > Add. Make the selections shown in the
screenshot below and select OK.

Locally Imported WSDLs Java Linkage Error
A Java Linkage error displays when performing certain operations if you import a TIBCO ActiveMatrix
BPM Public WSDL into a Business Studio project and deploy it to your ActiveMatrix BPM installation.

A Java Linkage error may occur, if you:

● import a ActiveMatrix BPM WSDL into your Business Studio™ project and deploy the process to your
ActiveMatrix BPM installation and

● increment the version number of the Business Studio project so that the version number of the imported
ActiveMatrix BPM WSDL is higher than the version number of the WSDL distributed with ActiveMatrix
BPM.

This is because, importing a ActiveMatrix BPM WSDL locally and deploying it to ActiveMatrix BPM causes
you to install another package with the same name to your ActiveMatrix BPM installation, but with
different version numbers.

If any of your BPM applications match the scenario described above, when you try to perform any of the
following:

● start tibcohost with -clearCache

● start tibcohost in resolve mode

● apply any hot fixes
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a java.lang.LinkageError: loader constraint violation: loader (instance of org/eclipse/
osgi/internal/baseadaptor/DefaultClassLoader) previously initiated loading for a

different type with name "com/tibco/n2/common/api/exception/ErrorLine error displays.

This is because when ActiveMatrix BPM performs these operations, ActiveMatrix BPM looks for packages
with a specific name and automatically chooses the packages with the highest version number for a given
major version number. For example, for packages with a major version number of 1, ActiveMatrix BPM
picks the highest version of 1.x.x.x. In other words, ActiveMatrix BPM is selecting the packages from the
locally imported WSDL rather than the WSDLs distributed with ActiveMatrix BPM.

If you have any BPM applications that match the scenario above, you can use the following table to check
the version numbers of the WSDL distributed with the release of ActiveMatrix BPM you are using and so,
check to see if the problem may occur.

TIBCO ActiveMatrix BPM Release WSDLs Version number

1.2.0 1.1.0.003

1.3.0 1.1.0.003

2.0.0 1.2.0.003

2.1.0 1.2.0.003

2.2.0 1.5.0.001

3.0.0 1.5.0.001

3.0.0 (with com.tibco.bds.api installed)

If you have imported the BDS WSDL
distributed with TIBCO ActiveMatrix
BPM Version 3.0.0, the version number
is lower than earlier versions of the
WSDLs distributed with TIBCO
ActiveMatrix BPM.

1.0.0.018

A Business Studio project version number is in the format major.minor.micro.qualifier, for example, 1.0.0.1.
Note that:

● If the major version number of the WSDL distributed with your Business Studio project is different from
the major version number of the WSDL distributed with ActiveMatrix BPM, then the problem does not
occur. In other words, you can change the major version number of the Business Studio project to any
number other than "1" and the problem will not occur.

● If your Business Studio project version number uses a qualifier (for example, the version number is in
the format x.x.x.qualifier) then this is interpreted by ActiveMatrix BPM as a higher number than any
other micro version number. In other words, a version number of 1.2.0.qualifier is interpreted as higher
than 1.2.0.003, and so the problem may occur.

If you have Business Studio projects in production that match the scenario described, please contact TIBCO
Support if you need to perform any of the following:

● start tibcohost with -clearCache

● start tibcohost in resolve mode

● apply any hot fixes

209

TIBCO Business Studio™ Modeling Guide



Organization Model

This section describes how to create a basic Organization Model using the Organization Modeler in TIBCO
Business Studio.

Organization Model Creation
An Organization Model must be contained within a project that contains an Organization Model special
folder.

You can create an Organization Model in the following ways:

● Create a new Organization Model Project (or Analysis Project or BPM Developer Project, which by
default create an Organization Model and corresponding special folder);

● Add an Organization Model and corresponding special folder to an existing project.

Creating a Project Containing an Organization Model
You can create an Organization Model in a new project.

Procedure

1. Select File > New > > Organization Model Project .

You can also select File > New > Analysis Project or File > New > BPM Developer Project and
create a project containing an Organization Model as well as other assets.

2. The New Project wizard is displayed. Enter a name for your project in the Project name field and click
Next.

This accepts default values for Location, Id, Version, Status and Destination Environments.

3. In the Asset Type Selection dialog, ensure that the Organization Model box is checked. Click Next.

4. In the Organization Model dialog, ensure that Create initial Organization Model is checked. In the
Filename field, enter a name for the Special Folder for Organization Models, or use the one provided by
default. Click Finish.

Leave the Create default schema types box checked to use the delivered schema.

Check the Apply default Organization Type to Organization box if you want the
Organization Type delivered in the default schema to be applied to the initial organization
created. If not, leave it unchecked.

See Creating a Schema for further details.

5. If you are not already in the BPM Modeling (or Modeling) perspective, you are prompted to switch to
BPM Modeling. Click Yes to switch perspective.

Adding an Organization Model in an Existing Project
You can add an Organization Model to an existing project but you must first create a special folder.

Procedure

1. Right-click the project where you want to add the Organization Model and select New > Folder . The
New Folder dialog is displayed.

2. In the Folder Name field, type a relevant folder name. Click Finish to close the dialog.
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3. Right-click the Organization folder and select Special Folders > Other > Use as Organization Models
Folder . If you right-click on the Organization folder now, the option to create a new Organization
Model is available.

Creating a Schema
The Organization Schema is contained in the Organization Model file (named by default organization.om,
where organization is the name of the organization for which you are creating the Organization Model).

Procedure

1. To create the default schema, when you are creating an organization model, either as part of creating a
new project or separately, ensure that you leave the Create default schema types checkbox selected.

If you select the Apply default Organization Type to Organization checkbox, the default Organization
Type (called Public Company) from the default schema is applied to the initial Organization that is
automatically created as part of this Organization Model. If you leave this checkbox empty, the Standard
Organization Type is not applied.

Note that if you do not select Create default schema types, the Apply default Organization Type to
Organization checkbox is not available:

2. Click Finish. The default schema is created.

Using Your Own Schema Types
You can use your own schema types by following the procedure described for creating a schema, but
without selecting the Create default schema checkbox.

See Creating a Schema.

Procedure

1. To use your own schema type, when you are creating an organization model, either as part of creating a
new project or separately, ensure that you uncheck the Create default schema types checkbox.

Note that if you do not select Create default schema types, the Apply default Organization Type to
Organization checkbox is not available so the Standard Organization Type is not applied:

2. Click Finish. Your own schema type is created.

The schema created does not include the standard types provided with the default schema. The only
type created is one Resource type, the Human Resource Type.

Unlike the Human Resource Type created in the default schema, this one has no attributes
defined.

Result

The following illustration shows what is visible in the Project Explorer when you have created a non-
default schema:
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Creation Types in the Schema
If you are building your own schema, you need to create the types that make it up.

If you are using the default schema provided, you can create new types to add to the schema in the same
way as you would for a new schema.

You can also modify the types provided. This enables you to extend the default schema provided by setting
up additional attributes to define more closely the elements that make up the organization you wish to
model.

Creating a Location Type

You can create a location type in a schema.

Procedure

1. In the Project Explorer, expand the Schema folder for your Organization Model.

2. In the Schema folder, right-click Location Types and select Add Child > Location Type . A new
Location Type is created.

3. Click the General tab in the Properties view. In the Label box, type the name of the Location Type.

Click the Attributes tab. Click  to add an attribute. Type in the name and select a type for the
Attribute from the Type drop-down list. See "Attributes" in TIBCO Business Studio Concepts for more
information about the types you can specify. You can also add a default value for the Attribute,
depending on your requirements.

Click  to remove attributes.

Creating an Organization Type

You can create an Organization type in a schema.

Procedure

1. In the Project Explorer, expand the Schema folder for your Organization Model.

2. In the Schema folder, right-click Organization Types and select Add Child > Organization Type . A
new Organization Type is created.

3. Click the General tab in the Properties view. In the Label box, type the name of the Organization Type.

4. To add an Organization Unit as a member to the Organization Type:

a) In the Unit Members box, click  . Type the name of the member in the Label field.
b) To specify that the member should be of a particular Organization Unit Type, click on the Type field

and then click the  button that then becomes available.
c) The Select Type dialog is displayed. Click on the Organization Unit Type you require, and the click

OK.

5. In the Multiplicity field, type in the multiplicity you want.

Click  to remove Organization elements.

Click the Attributes tab. Click  to add an attribute. Type in the name and select a type for the
Attribute from the Type drop-down list. See "Attributes" in TIBCO Business Studio Concepts for more
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information about the types you can set for attributes. You can also add a default value for the Attribute,
depending on your requirements.

Click  to remove attributes.

Creating an Organization Unit Type

You can create an Organization Unit type in a schema.

Procedure

1. In the Project Explorer, expand the Schema folder for your Organization Model.

2. In the Schema folder, right-click Organization Unit Types and select Add Child > Organization Unit
Type . A new Organization Unit Type is created.

3. Click the General tab in the Properties view. In the Label box, type the name of the Organization Unit
Type.

4. To add another Organization Unit as a member to the Organization Unit Type:

a) In the Unit Members box, click  . Type the name of the member in the Label field.
b) To specify that the member should be of a particular Organization Unit Type, click on the Type field

and then click the  button that then becomes available.
c) The Select Type dialog is displayed. Click on the Organization Unit Type you require, and the click

OK.

5. In the Multiplicity field, type in the multiplicity you want.

6. To add a Position as a member to the Organization Unit Type:

a) In the Position Members box, click  . Type the name of the member in the Label field.
b) To specify that the member should be of a particular Position Type, click on the Type field and then

click the  button that then becomes available.
c) The Select Type dialog is displayed. Click on the Position Type you require, and the click OK.

7. In the Multiplicity field, type in the multiplicity you want.

Click  to remove Position and Unit elements.

Click the Attributes tab. Click  to add an attribute. Type in the name and select a type for the
Attribute from the Type drop-down list. See "Attributes" in TIBCO Business Studio Concepts for more
information about the types you can specify for Attributes. You can also add a default value for the
Attribute, depending on your requirements.

Click  to remove attributes.

Creating a Position Type

You can create a Position typein a schema.

Procedure

1. In the Project Explorer, expand the Schema folder for your Organization Model.

2. Right-click Organization and select Add Child > Position Type . A new Position Type is created.

3. Click the General tab in the Properties view. In the Label box, type the name of the Position Type.
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Click the Attributes tab. Click  to add an attribute. Type in the name and select a type for the
Attribute from the Type drop-down list. See "Attributes" in TIBCO Business Studio Concepts for more
information about the types you can specify. You can also add a default value for the Attribute,
depending on your requirements.

Click  to remove attributes.

Creating an Organization Unit Relationship Type

You can create an Organization unit relationship typein a schema.:

Procedure

1. In the Project Explorer, expand the Schema folder for your Organization Model.

2. In the Schema folder, right-click Organization Unit Relationship Types and select Add Child >
Organization Unit Relationship Type . A new Organization Unit Relationship Type is created.

3. Click the General tab in the Properties view. In the Label box, type the name of the Organization Unit
Relationship Type.

Click the Attributes tab. Click  to add an attribute. Type in the name and select a type for the
Attribute from the Type drop-down list. See "Attributes" in TIBCO Business Studio Concepts for more
information about the types you can specify. You can also add a default value for the Attribute,
depending on your requirements.

Click  to remove attributes.

Creating a Resource Type

You can create a resource type in a schema.

Procedure

1. In the Project Explorer, expand the Schema folder for your Organization Model.

2. In the Schema folder, right-click Resource Types and select Add Child > Resource Type . A new
Resource Type is created.

3. Click the General tab in the Properties view. In the Label box, type the name of the Resource Type.

Click the Attribute tab. Click  to add an attribute. Type in the name and select a type for the
Attribute from the Type drop-down list. See "Attributes" in TIBCO Business Studio Concepts for more
information about the types you can specify. You can also add a default value for the Attribute,
depending on your requirements.

Click  to remove attributes.

Organization Modeler Diagram Editors
Organization Modeler provides two graphical editors for producing organization diagrams:

● An Organization Model Editor for the root Organization Model diagram
● An Organization Editor for the diagrams of each Organization included in the Model

The Organization Model Editor shows a high-level view of the organization or organizations that you have
created.
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The following example shows an Organization Model diagram which includes two organizations, one
being your own organization and the second a representation of an external organization with which your
organization has dealings, in this case an outsourcing company.

The Organization Model Editor opens when you:

● Double-click on an Organization Model .om file in the Project Explorer,

● Right-click on an Organization Model .om file in the Project Explorer, and select Open or Open With >
Organization Model Diagram Editing ,

● From the Organization Editor displaying any Organization in that Organization Model, click on the
shortcut arrow that is displayed on the badge.

●

The Organization Editor shows a more detailed view of one Organization, including the Organization Units
and Positions that it includes, and the relationships between them.
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The Organization Editor opens:

● Automatically for the default Organization that is created when you create a new Organization Model
Diagram,

● When you double-click on the header part of the representation of an Organization in the Organization
Model Editor,

● When you double-click on an Organization in the Project Explorer,

● From the Organization Model Editor, when you click on the shortcut arrow that is displayed on the
representation of each Organization within the model.

●

Adding Objects in Organization Modeler Diagrams
You can add objects to Organization Modeler diagrams in several ways.

● Using the tools on the diagram editor’s palette

● Using the pop-up icons
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● Using the context menu

● Using the Project Explorer

To add Objects in Organization Modeler Diagrams using the Palette

To add an object to an organization diagram, you can use the tools provided on the diagram editor’s palette.

In the Organization Model Editor, the following tools are always available in the palette:

● Organization

● Association

If you have applied a Schema to your organization model, and it contains any Organization Types, tools for
adding these will also be available. For example, if you have used the standard Schema but added a new
Organization Type to it, both the Standard Organization Type and the additional one will be available in the
palette, as in the following illustration.

In the Organization Editor, the following tools are always available in the palette:

● Organization Unit

● Position

● Hierarchy
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● Association

Additional tools are available if you have applied a Schema to your organization model. If you have
applied the Standard Organization Type to the Organization, the palette contains the following tools for the
elements that are defined in that Standard Organization Type:

● Head Unit

● Member Unit

● Manager Position

● Member Position

Note that the Sub Unit element is not available from the palette.

Similarly, if the Organization that you are editing has a different or modified Type applied, tools are
included in the palette for the elements that are defined for that Type. The following illustration shows an
example. Here an Organization is used that has two Organization Unit Types defined.
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The availability of these tools on the palette is dynamic; if you add a new Type to the Schema, it is
immediately made available on the palette.

To use any of these tools, you can either:

● Select the required tool and drag and drop on to the diagram, or

● Click on the required tool in the palette to select it, and click on the diagram.

Where you should drop, or click, depends on the object you are adding:

● For Organization and Organization Unit (including Types of Organization Unit), use the empty part of
the diagram.

● For Position (including Types of Position), drop into or click on the position compartment of an
Organization Unit - that is, the empty space below the title bar.

● For Hierarchy or Association, drop into or click on the Organization Unit where the connection is to
start from, and drag the connection to the Organization Unit where it is to end.

When you add an Organization, Organization Unit, or Position object, the Label field on the title bar is
automatically selected. Enter a name for the object.

To add Objects in Organization Modeler Diagrams using the Pop-up Icons

You can add objects to an organization diagram using the pop-up icons that are available.

If you hover your mouse over the empty area of the diagram, an icon appears. In the Organization Model
Editor, this is the Add Organization icon. Move your cursor on to the icon to display the Add Organization
label as shown in the following illustration, and then click to create a new Organization in the diagram.

In the Organization Editor, hovering your mouse in the empty area produces the Add Organization Unit
icon, which works in the same way as the Add Organization icon. Similarly, hovering your mouse over the
Position compartment of an Organization Unit displays the Add Position icon, as shown in the following
illustration.

You can add a connection between two objects in a diagram by clicking and dragging one of the handles
that are displayed when you hover your cursor over the object. Click the handle and drag to the object to
which you want to connect, as shown in the following illustration.
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This process creates a Hierarchy. If you want a non-hierarchical connection, you can change it to an
Association as described in Hierarchy and Association Properties .

To add Objects in Organization Modeler Diagrams using the Context Menu

You can add objects to the organization diagram by right-clicking in the Organization Editor and selecting
the object you require from the context menu that is displayed.

If you right-click on the background of the Organization Editor, you can select:

● An Organization Unit with no Type defined;
● If the Organization has the Standard Organization Type set, a Head Unit, Member Unit, or Sub Unit;

● If the Organization is set to another Type of Organization defined in the Schema, an Organization Unit
of any of the Types defined for that Organization Type.

If you right-click on an Organization Unit in the diagram, you can select:

● A Position with no Type defined;
If the Organization Unit has an Organization Unit Type set, a Position of any of the Types defined for that
Unit Type.
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Adding Objects in Organization Modeler Diagrams using the Project Explorer

You can add objects to the diagram editor from the Project Explorer.

1. Select the parent in the Project Explorer.
2. Right-click on the parent and selecting Add Child.
For example, to add an untyped Organization Unit you would right-click on the parent Organization and
select Add Child > Organization Unit . If you are using the Schema, the choices displayed will include not
just the basic Organization Unit but the Types of Organization Unit available.

Adding Notes and Labels
You can add notes or text labels to the organization diagram.

Procedure

● Do one of the following:

● Right-click on an object in the editor and select Add Note from the pop-up context menu,

● Right-click on the background in the editor and select Add - > Note or Add - > Text from the pop-
up context menu,

● In the Organization Editor palette, select the Note tool in the upper part of the palette.

● Click on the Organization Editor.

You can also select Text or Note Attachment from this menu. The icon for the tool changes
to show the item you have selected.

Result

The following illustration shows a note being used to add explanation to an Association. A note attachment
is drawn between the note and the object with which it is associated.
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Tailoring the Appearance of Organization Modeler Diagrams
You can change the level of detail that the Organization Modeler diagrams display.

In the overview diagram, each Organization is by default shown including all the Organization Units that
make it up, and the Hierarchies and Associations that link them. To hide the detail, click on the downward-
pointing arrowhead that is shown in the corner when you select the Organization.

This action hides the contents of the Organization, and displays the collapsed version shown below.

A solid right-pointing arrowhead is now displayed in place of the downward-pointing one when the
Organization is selected. Clicking on this restores the display of the Organization’s contents.

In the Organization Editor, the same arrowheads appear in Organization Units, and you can use them to
hide or to display the Positions defined within those Organization Units.

Also in the Organization Editor, you can choose to display or to hide the hierarchy of Organization Units
that depend on the selected unit. The following illustration shows an excerpt from an organization
diagram, with several Organization Units dependent on the Call Center unit.

If you click on the small minus sign in the title bar of the Call Center, the display changes to the following
collapsed view.

Click on the plus sign to restore the hierarchical view.

You can also:

● use the options in the Diagram menu to arrange the objects on the diagram editor screen,

● right-click on the background of the diagram and select Arrange All to make the diagram more ordered.
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Creating an Organization Model
The Organization Model is contained in a file called name.om, where name is typically the name of the
entity for which you are creating the Organization Model. An Organization Model can contain more than
one Organization.

Procedure

1. In the Project Explorer, select the Organization folder in the project where you want to create your
Organization Model.

2. Right-click the Organization folder or the OrganizationModel.om folder and select New >
Organization Model .

3. The Create Organization Model Diagram wizard is displayed.

Make sure that the Create default schema types box is checked.

The folder you selected should be displayed in the Create Organization Model Diagram wizard. You
can use the folder you selected or select a different folder, depending on your requirements. However, it
must be a special folder of the Organization type.

4. In the File name: field, type the name you want to apply to your Organization Model, followed by the
suffix .om. Click Finish.

Result

The Organization Editor is displayed, representing the single default Organization created in the
Organization Model. This information is displayed in the badge in the top left hand corner of the editor.
You can navigate to the parent Organization Model editor by clicking on the shortcut arrow in the badge.

The Organization Model is also displayed in the Project Explorer view.
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You can use quick-find (Ctrl+F) in the project explorer to find existing organization model entities and
select them in the project explorer.

When you have created an organization model, you can search for organization model diagram elements
using quick find (Ctrl-F) within the diagram, and entering the initial characters of the name you are
searching for. Double-click on the element you are shown in the search to go to its location in the diagram.

Creating an Organization
You can create an Organization within your Organization Model.

Prerequisites

See "Organizations" in the TIBCO Business Studio Concepts Guide.

See Creating an Organization Model

If you want to create an organization that is likely to be replicated elsewhere - for example a Branch which
consists of a similar structure in a number of geographical locations - then you might want to consider
creating a Dynamic Organization. See "Dynamic Organizations" in the TIBCO Business Studio Concepts
Guide.

Procedure

1. Activate the Organization Model Editor for your Organization Model.

2. Select the Organization tool in the Organization Model Editor palette, and click on the empty part of the
Organization Model editor. This places an Organization in the Model.

You can alternatively expand the Organization Model in the Project Explorer. Right-click
Organizations and select Add Child > Organization. A new Organization is created.

If you want to use a template of a typical public company as a starting point for your own
organization, right-click Organizations and select Add Child > Public Company. This
provides you with a number of sample department types which you can edit and add to your
company (Department, Business Unit, Team) and Positions already defined for Manager and
Member which you can also edit.

3. At this point the Label field of the Organization is automatically selected. Enter the label you require.
The Name field is automatically filled with the same text as the Label, but without any internal spaces.
For example, if you put Head Office in the Label field, the Name will be HeadOffice.

4. If the Properties View is not already displayed, right-click the organization you just created and select
Show Properties View. The Properties View is displayed.

For a complete description of all the properties you can configure for an Organization, see 
Organization Properties .

5. In the Purpose field on the General tab, and on the Description tab, you can enter some text to describe
the purpose of the Organization and/or any supporting explanations, depending on your requirements.

Next to the Type field, click  to display the Select Type dialog. This enables you to change the type
for the Organization, depending on your requirements.

Next to the Location field, click  to display the Select Type dialog. This enables you to specify a
Location for the Organization, depending on your requirements.

6. If you have assigned a Type to the Organization, the Attribute Values tab is displayed. Any attributes
that are defined for this type of Organization are displayed here. Click the Value field next to each
defined attribute to display a list of available values for that attribute.
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The Attribute Values tab is available only if you have previously applied a Type .

What to do next

When you have created an organization, you can model it to contain a structure using Organization Units
and Dynamic Organization Units which can be connected using Hierarchy links.

Association links are not supported in the runtime model. If you create an association a warning is
displayed.

Creating a Dynamic Organization
You can create a Dynamic Organization within your Organization Model. A Dynamic Organization is an
organization pattern that can be referenced from a number of different Organizations.

See "Dynamic Organizations" in the TIBCO Business Studio Concepts Guide

Procedure

1. Activate the Organization Model Editor for your Organization Model.

2. Select the Dynamic Organization tool in the Organization Model Editor palette, and click on the empty
part of the Organization Model editor. This places a Dynamic Organization in the Model.

You can alternatively expand the Organization Model in the Project Explorer. Right-click
Organizations and select Add Child > Dynamic Organization. A new Dynamic Organization
is created.

3. At this point the Label field of the Dynamic Organization is automatically selected. Enter the label you
require. The Name field is automatically filled with the same text as the Label, but without any internal
spaces. For example, if you put Head Office in the Label field, the Name will be HeadOffice.

4. In the Purpose field on the General tab, and on the Description tab, you can enter some text to describe
the purpose of the Organization and/or any supporting explanations, depending on your requirements.

5. If you have assigned a Type to the Organization, the Attribute Values tab is displayed. Any attributes
that are defined for this type of Organization are displayed here. Click the Value field next to each
defined attribute to display a list of available values for that attribute.

The Attribute Values tab is available only if you have previously applied a Type.

What to do next

Once you have created a Dynamic Organization, you can open it and model it by adding organization units
and positions. See Creating a Dynamic Organization Unit.
The Properties sections of the Dynamic Organization is the same as that of an Organization but has an
additional tab for the Dynamic Organization Identifiers. Dynamic Organization Identifiers are arbitrary
strings that you can define. They will have values assigned at runtime to identify an instance of the
Dynamic Organization. The Dynamic Organization participant in a process that references an organization
entity within this Dynamic Organization requires a mapping between process data (which will provide the
values for the identifiers at runtime) and these identifiers. See Dynamic Organization Identifier Mapping .

Creating an Organization Unit
You can create an Organization Unit within your Organization.

Procedure

1. In the Organization Model editor, double-click on the organization in which you want to place an
Organization Unit. The Organization Editor for that organization is opened.
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2. Select the Organization Unit tool in the Organization Modeler palette, and click on the empty part of the
Organization diagram. This places an Organization Unit in the Organization.

3. At this point the Label field of the Organization Unit is automatically selected. Enter the label you
require. The Name field is automatically filled with the same text as the Label, but without any internal
spaces.

4. If the Properties View is not already displayed, right-click the organization Unit you just created and
select Show Properties View. The Properties View is displayed.

For a complete description of all the properties you can configure for an Organization Unit,
see Organization Unit Properties .

5. In the Purpose field on the General tab, and on the Description tab, you can enter some text to describe
the purpose of the Organization Unit and/or any supporting explanations, depending on your
requirements.

6. If you are using the default schema, or if you have created your own schema and defined any
Organization Unit Types, you can assign a Type to this Organization Unit by selecting it in the Element
field.

Next to the Location field, click  to display the Select Type dialog. This enables you to specify a
Location Type for the Organization.

To specify start and end dates for the Organization Unit, click  next to the date fields to display the
calendars.

7. If you have applied a Type to the Organization Unit, the Attribute Values tab is displayed. Any
attributes that are defined for this type of Organization Unit are displayed here. Click the Value field
next to each defined attribute to display a list of available values for that attribute.
See "Attributes" in TIBCO Business Studio Concepts for more information about attributes.

Click the Privileges tab. Click  to display the Select Type dialog. This enables you to specify the
Privileges for the position. See "Capabilities and Privileges" in TIBCO Business Studio Concepts for more
information about Privileges.

Creating a Dynamic Organization Unit
You can create a Dynamic Organization Unit within your Organization. This can be used to reference a
Dynamic Organization. This in turn will allow you to model a repeating organization pattern such as a
Branch in an organization.

Prerequisites

See Creating an Organization.

See Creating a Dynamic Organization.

Procedure

1. In the Organization Model editor, double-click on the organization in which you want to place a
Dynamic Organization Unit. The Organization Editor for that organization is opened.

2. Select the Dynamic Organization Unit tool in the Organization Modeler palette, and click on the empty
part of the Organization diagram. This places a Dynamic Organization Unit in the Organization.

3. At this point the Label field of the Dynamic Organization Unit is automatically selected. The Name field
is automatically filled with the same text as the Label, but without any internal spaces. The Label and
Name are derived from the root organization unit of the referenced Dynamic Organization. This is not
editable.
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4. If the Properties View is not already displayed, right-click the Dynamic Organization Unit you just
created and select Show Properties View. The Properties View is displayed.

What to do next

Dynamic Organization Identifiers are arbitrary strings that will be defined on a Dynamic Organization by
the user. These strings will have values assigned at runtime to identify an instance of the Dynamic
Organization. The Dynamic Organization participant in a process that references an organization entity
within this Dynamic Organization has a mapping between process data (which will provide the values for
the identifiers at runtime) and these identifiers.

Dynamic Organization Identifier Mapping
When a Dynamic Organization Participant is assigned to a task you need to identify the correct instance of
the Dynamic Organization to use to resolve this participant at runtime. This is done using Dynamic
Organization Identifiers which are mapped to process data.

The mappings are between the process data and the Dynamic Organization Identifiers of the referenced
Dynamic Organization (not the Dynamic Organization).

Procedure

1. In the business process, select the Work Resource tab, and expand Dynamic Organization Identifer
Mappings... .

2. Map your process data (data fields and parameters) to a Dynamic Organization Identifier (which you
set up when you created the Dynamic Organization Model). See "Dynamic Organizations" in TIBCO
Business Studio Concepts and "Creating a Dynamic Organization" in TIBCO Business Studio Modeling
User's Guide .

What to do next

A Dynamic Organization declares its Identifier Fields. These are arbitrary fields that are used to uniquely
identify a generated instance of the Dynamic Organization at runtime.

When a Dynamic Organization is assigned to an Extension Point, those Identifier Fields must be mapped/
assigned to named LDAP Attributes. This is done after deployment.

A generated instance of a Dynamic Organization takes its Identifier values from those named Attributes; of
the LDAP Entry from which it originates.

A Dynamic Organization Participant carries values for the Dynamic Organization Identifiers. These values
are derived from process data (data fields and parameters) mapped to those Dynamic Organization
Identifiers. With this information the User Task can identify the instance of the Dynamic Organization in
which the Participant can be found.
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Creating a Position
You can create a Position within your Organization Unit.

Procedure

1. Select the Position tool in the Organization Modeler palette, and click on the Organization Unit where
you want to create the Position.

2. At this point the Label field of the Position is automatically selected. Enter the label you require. The
Name field is automatically filled with the same text as the Label, but without any internal spaces.

3. If the Properties View is not already displayed, right-click the Position you just created and select Show
Properties View. The Properties View is displayed.

For a complete description of all the properties you can configure for an Position, see Position
Properties .

4. In the Purpose field on the General tab, and on the Description tab, you can enter some text to describe
the purpose of the Organization and/or any supporting explanations, depending on your requirements.

5. If you are using the default schema, or if you have created your own schema and defined any Position
Types, you can assign a Type to this Position by selecting it in the Element field.

Next to the Location field, click  to display the Select Type dialog. This enables you to specify a
Location for the Position.

To specify start and end dates for the Organization, click  next to the date fields to display the
calendars.

6. If you have applied a Type to the Position, the Attribute Values tab is displayed. Any attributes that are
defined for this type of Position are displayed here. Click the Value field next to each defined attribute
to display a list of available values for that attribute.
See "Attributes" in TIBCO Business Studio Concepts for more information about attributes.

Click the Capabilities tab. Click  to display the Select Type dialog. This enables you to specify the
Capabilities for the Position. See "Capability and Privilege" in TIBCO Business Studio Concepts for more
information about capabilities.

7. Do the same for the Privileges tab.

Creating a Group
You can create a group within your Organization Model.

Procedure

1. In the Project Explorer, expand the folder for your Organization Model.

2. Right-click the Groups folder and select Add Child > Group . Right-click the Group and select Rename.
Type the label of the Group you wish to create. The Name field is automatically filled with the same text
as the Label, but without any internal spaces.

To add a sub-group, right-click on the group where you want to create your sub-group and
select Add Child > Group.

3. If the Properties View is not already displayed, right-click the Group you just created and select Show
Properties View. The Properties View is displayed.

For a complete description of all the properties you can configure for an Group, see Group
Properties .
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4. In the Purpose field on the General tab, and on the Description tab, you can enter some text to describe
the purpose of the Organization and/or any supporting explanations, depending on your requirements.

Click the Capabilities tab. Click  to display the Select Type dialog. This enables you to specify the
Capabilities for the position. See "Capability and Privilege" in TIBCO Business Studio Concepts for more
information about capabilities.

5. Do the same for the Privileges tab.

Creating Capabilities
You can add Capabilities to your Organization Model.

Procedure

1. In the Project Explorer, expand the folder for your Organization Model.

2. You can either:

● Right-click the Capabilities folder and select Add Child > Capability. A new Capability is created.

● Right-click on a Category and select Add Child > New Capability. A new Capability is created.

3. Right-click on the Capability you just created and select Rename.

4. Type the label of the Capability you wish to create. The Name field is automatically filled with the same
text as the Label, but without any internal spaces.

5. If the Properties View is not already displayed, right-click the Capability you just created and select
Show Properties View. The Properties View is displayed.

For a complete description of all the properties you can configure for a Capability, see 
Capability Properties .

6. Click the General tab.

7. You can specify a type for your capability by doing the following:
a) Select the Has qualifier checkbox. The Show qualifier ... option is displayed.
b) Click the Show qualifier ... option. The Qualifier tab is displayed.
c) Click the Qualifier tab. In the Type field, select an available type from the drop-down list.
d) If required, specify a default value for the qualifier.

See "Capabilities and Privileges" in TIBCO Business Studio Concepts for more information on the types
you can specify.

8. In the Purpose field on the General tab, and on the Description tab, you can enter some text to describe
the purpose of the Privilege and/or any supporting explanations, depending on your requirements.

Creating Capability Categories
You can add Capability Categories to your Capabiliites in your Organization Model.

Procedure

1. In the Project Explorer, expand the folder for your Organization Model.

2. Right-click the Capabilities folder and select Add Child > Capability Category . A new Category is
created.

3. Right-click on the Category you just created and select Rename.

4. Type the label of the Category you wish to create. The Name field is automatically filled with the same
text as the Label, but without any internal spaces.
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For a complete description of all the properties you can configure for a Category, see 
Capability Category and Privilege Category Properties .

Creating Privileges
You can add Privileges to your Organization Model.

Procedure

1. In the Project Explorer, expand the folder for your Organization Model.

2. You can either:

● Right-click the Privileges folder and select Add Child > New Privilege. A new Privilege is created.

● Right-click on a Category and select Add Child > New Privilege. A new Privilege is created.

3. Right-click on the Privilege you just created and select Rename.

4. Type the label of the Privilege you wish to create. The Name field is automatically filled with the same
text as the Label, but without any internal spaces.

5. If the Properties View is not already displayed, right-click the Privilege you just created and select
Show Properties View. The Properties View is displayed.

For a complete description of all the properties you can configure for a Privilege, see Privilege
Properties .

6. Click the General tab.

7. You can specify a type for your privilege by doing the following:
a) Select the Has qualifier checkbox. The Show qualifier ... option is displayed.
b) Click the Show qualifier ... option. The Qualifier tab is displayed.
c) Click the Qualifier tab. In the Type field, select an available type from the drop-down list.
d) If required, specify a default value for the qualifier. See "Capability and Privilege" in TIBCO Business

Studio Concepts for more information on the types you can specify.

Organization model deployments to the same major version are always additive.

This means that changes in the qualifier value of privileges will reflect every previous value
you set. So if you set the qualifier for Position ’Tester’ with Privilege ’All’ to 10 and deploy
the organization model, and then change the qualifier to 11 and redeploy it (as a different
minor version) , Position 'Tester' now has two assignments of privilege 'All'; one with a
qualifier of 10, and with a qualifier of 11.

8. In the Purpose field on the General tab, and on the Description tab, you can enter some text to describe
the purpose of the Privilege and/or any supporting explanations, depending on your requirements.

Creating Privilege Categories
You can add Privilege Categories to your Privileges in your Organization Model.

Procedure

1. In the Project Explorer, expand the folder for your Organization Model.

2. Right-click the Privileges folder and select Add Child > Privilege Category . A new Category is created.

3. Right-click on the Category you just created and select Rename.

4. Type the label of the Category you wish to create. The Name field is automatically filled with the same
text as the Label, but without any internal spaces.
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For a complete description of all the properties you can configure for a Category, see 
Capability Category and Privilege Category Properties .

Creating a Location
You can create a Location for an Organization Model.

Procedure

1. In the Project Explorer, expand the folder for your Organization Model.

2. Right-click the Locations folder and select Add Child > Location .

3. Right-click the Location and select Rename.

4. Type the label of the Location you wish to create. The Name field is automatically filled with the same
text as the Label, but without any internal spaces.

5. If the Properties View is not already displayed, right-click the Location you just created and select
Show Properties View. The Properties View is displayed.

For a complete description of all the properties you can configure for a Location, see Location
Properties .

6. In the Purpose field on the General tab, and on the Description tab, you can enter some text to describe
the purpose of the Location and/or any supporting explanations, depending on your requirements.

Next to the Type field, click  to display the Select Type dialog. This enables you to change the type
for the Location, depending on your requirements.

To specify start and end dates for the Location, click  next to the date fields to display the calendars.

7. If you have assigned a Type to the Location, the Attribute Values tab is displayed. Any attributes that
are defined for the Type are displayed here. Click the Value field next to each defined attribute to
display a list of available values for that attribute.
See "Attributes" in TIBCO Business Studio Concepts for more information about attributes.

Creating a Resource
You can create a Resource for your Organization Model.

Procedure

1. In the Project Explorer, expand the folder for your Organization Model.

2. Right-click the Resources folder and select Add Child > Resource . A new Resource is created.

3. Right-click the Resource and select Rename.

4. Type the label of the Resource you wish to create. The Name field is automatically filled with the same
text as the Label, but without any internal spaces.

5. If the Properties View is not already displayed, right-click the Resource you just created and select
Show Properties View. The Properties View is displayed.

For a complete description of all the properties you can configure for a Resource, see Resource
Properties .

6. In the Purpose field on the General tab, and on the Description tab, you can enter some text to describe
the purpose of the Resource and/or any supporting explanations, depending on your requirements.

Next to the Type field, click  to display the Select Type dialog. This enables you to change the type
for the Resource, depending on your requirements.
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7. If you have assigned a Type to the Resource, the Attribute Values tab is displayed. Any attributes that
are defined for the Type are displayed here. Click the Value field next to each defined attribute to
display a list of available values for that attribute.
See "Attributes" in TIBCO Business Studio Concepts for more information about attributes.

Creating Queries
You can create a Query for an Organization Model.

Procedure

1. In the Project Explorer, expand the folder for your Organization Model.

2. Right-click the Queries folder and select Add Child > Organization Query . A new Organization
Query is created.

3. Right-click the Query and select Rename.

4. Type the label of the Query you wish to create. The Name field is automatically filled with the same text
as the Label, but without any internal spaces.

5. On the General tab of the Properties View, select either Free Text or RQL from the dropdown list in the
Script Defined As field. An input field is displayed.

6. Type the Query into the Describe Organization Model Query field. You can either enter free text that
will describe to the solution designer what you intend the query to accomplish, or use the structure of
RQL to enter a query that will be validated by TIBCO Business Studio.

Using a Schema in an Organization Model
This is an overview of the steps required to create the example shown as a Schema and then use it in an
Organization Model.

An example of an organization unit that you may want to model as a Schema is shown below.
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Procedure

1. Create a project. On the Organization Model dialog of the New Project wizard, uncheck the Create
default schema types field.

The Schema for this project will therefore contain only those types that you define.

2. Create the following types in the Organization Schema:

● An Organization Type called Call Center. See Creating an Organization Type.

● Organization Unit Types called Home, Life, Travel and Motor. See Creating an Organization Unit
Type.

● A Position Type called Manager. See Creating a Position Type.

● A Position Type called Customer Services Representative. See Creating a Position Type.

3. For the Call Center Organization Type, specify the Home, Life, Motor and Travel Organization Unit
Types as Organization elements.

4. For the Home, Life, Travel and Motor Organization Units, specify the Manager and Customer Service
> Representatives as Position Elements.

5. Create an Organization Model. Ensure that you uncheck the Create default schema checkbox.

233

TIBCO Business Studio™ Modeling Guide



6. Create an Organization within that Organization Model.

7. On the General tab in Properties view, change the Type of the Organization you have just created from
a Standard Organization Type to the Call Center Type.

8. In the Organization diagram editor, right-click on the empty canvas. The context menu that pops up
enables you to select Home, Life, Motor and Travel Organization Units, as shown below. You can also
select an untyped Organization Unit.

9. Create either a Home, Life, Travel or Motor Organization Unit.

10. If you right click on the Organization Unit you created, the Manager and Customer Service
Representative Positions are displayed, as shown below.

Exporting Organization Model Documentation
You can export an organization model to files in HTML format for documentation purposes.

Procedure

1. Select File > Export . The Export dialog is displayed.

2. Expand the Business Process Management folder, select Documentation, and click Next.

3. Drill-down through the Project and Organization folder to select the specific organization model for
which you wish to export documentation. By default all documentation within the project you are
working in is selected. Deselect documentation you do not require.

4. Select a destination for the export by either:

● Selecting Project (to put the export in the Documentation sub-directory within your Project
directory), or

● Selecting Path: and clicking Browse... to specify a directory for the export.

5. Click Finish.

6. The Organization Model documentation is saved to the location you specified. See Viewing
Organization Model Documentation for more information.

234

TIBCO Business Studio™ Modeling Guide



Viewing Organization Model Documentation
You can view organization model documentation.

Procedure

1. Export the documentation as described in Exporting Organization Model Documentation.

2. In the Project Explorer, expand the Documentation > Organization Model sub-directory within your
Project directory; or if you exported the documentation to another destination, navigate to that
destination folder.

3. Right-click the exported file for the package and select Open With > Default Editor .

235

TIBCO Business Studio™ Modeling Guide



Reference

This section describes the major parts of the TIBCO Business Studio user interface, including the
perspectives and views that are provided.

Project Explorer View
The Project Explorer view shows a view of the project in which you can view and create projects, packages,
processes and assets such as services and so on. In contrast to the Navigator view (available within the
Resource Perspective) the Project Explorer view shows a contextual view of the Project.

For example, the following shows both the Navigator and Project Explorer views of the same Project.

To see this view, select Window > Show View > Project Explorer, or Window > Show View > Other, then
expand the General folder and select Project Explorer.

You can also use the search facility to locate workspace elements in the Project Explorer view such as
processes, package names, and process interfaces by pressing Ctrl+F or the search toolbar button in the
Project Explorer view. For more information, see Tools for Finding Objects in a Diagram.

Problems View
The Problems view is where the software displays warnings, errors and messages about the resources used
in your Project.

To see this view, select Window > Show View > Problems, or Window > Show > View > Other, then
expand the General folder and select Problems.

The Problems view also displays error messages that result from validation of your process. When you save
your process, it is validated for BPMN correctness and for deployment or export to the selected destination
environments.

For information about correcting problems, see Correcting Validation Errors.
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Outline View
The Outline View allows you to focus on specific areas of a large process.

To see this view, select Window > Show View > Outline. By positioning the mouse pointer over the shaded
area and holding the left mouse button down, you can reposition the shaded area of the Outline View and
thus see different parts of the process.

Fragments View
The Fragments view allows you to store selected objects from your process and reuse them in a different
process. You can also select predefined process fragments and use them in your process:

To see this view, select Window > Show View > Fragments. The buttons in the upper right of the view
allow you to do the following:

 - Copy a diagram fragment to the clipboard in preparation for pasting it onto a Process.

 - Edit fragment/category properties such as the Name and Description.

 - Create a custom fragment category in which to store your fragments.

 - Paste a fragment from clipboard into the Fragments view or into the process.

 - Delete a fragment or category.
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Process Modeler Properties View
The Properties View shows you detailed information about the currently selected object and allows you to
specify the characteristics of an object.

The Business Process Modeling Notation (BPMN) complete set is supported by the Properties View. For
example, if you are creating a gateway in your process diagram, you can select the type of gateway you
want in the Properties View:

To see this view, select Window > Show View > Properties or Window > Show View > Other , then expand
the General folder and select Properties. To view property information, you must have an object selected.

Properties related to simulation are only present when Simulation is selected as the destination
environment.

Properties related to the implementation of a process (for example, the Input To Service and Output From
Services tabs for service tasks) are described in the appropriate implementation guide.

Labels and Names

When using the Business Analysis capability, process objects such as data fields, task names, and so on,
have labels that may contain spaces or non-alphanumeric characters.

With the Solution Design capability selected, the Label as well as the Name is displayed. For example:

The Name is usually made up of the Label without whitespace or special characters. If you migrate a
process from an earlier version, the migration XSLT creates Labels from the Name. The Name is used for
referencing items where whitespace or special characters are restricted (for example, scripts and
expressions). The Label is used for on-screen display.

If the Name has not been modified from the default, it automatically changes to match the Label when the
Label is changed.
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Process Properties

Process Property Reference

Tab Property Description

General Label Label associated with the process. You can change the label if
necessary.

Process Interface Lists the location and name of the process interface implemented
by the selected process. Specifying a process interface allows the
dynamic selection of sub-processes at runtime. For more
information, see Process Interfaces .

Inline Sub-
Process:

Select the Inline sub-process during Process Package
Optimization checkbox so that at runtime, the objects such as
activities and events contained in the call sub-process are brought
into the top-level process and executed there, rather than by
making a call to the sub-process.

References Lists any processes or tasks that use the selected process, and the
contexts in which the data is used. For example, if you select a call
sub-process, the process and task that use the call sub-process are
displayed. Click Go To to display the referencing object. This field
helps prevent deleting a process that is used in another. Note,
however that a process may be used by other packages, and these
references cannot be displayed in this field.

Description Optional textual description of the activity.

Documentation
URL

The Documentation URL controls allow you to launch a web
browser for the given URL (you can use the actual Documentation
URL:label or the browser button).

The browser is opened either in TIBCO Business Studio (in the
editor pane) or in an external browser according to the user
defined settings (Preferences > General > General).

Destinations Enter the target environment for the process. When you save the
process, validation is performed according to this setting:

● All processes are validated for BPMN - additionally, other
destinations can be selected to validate processes for use in
specific environments

● If you select BPM, the Process will be validated against TIBCO
ActiveMatrix BPM 3.x.

● If you select Simulation, processes created under this project
will be validated for simulation in TIBCO Business Studio as
well as for BPMN correctness.

● If you do not select a destination environment, basic BPMN
validation will be performed.
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Tab Property Description

Work
Resource

Resources... You can specify the Initial Priority, which indicates the relative
urgency with which the item should be completed. You can edit
this from the Default setting, to be one of the values below, with
Higher (400) being the one which would be processed first.

● Higher (400)

● High (300)

● Default

● Normal (200)

● Low (100)

Separation Of
Duties

(Manual and user
tasks)

Allows you to specify that certain manual or user tasks must be
executed by different resources at runtime. For more information,
see Specifying Separation of Duties.

Retain Familiar
(Manual and user
tasks)

Tasks within a Retain Familiar task group will, by preference, be
offered to the same user.

Calendar
Reference

Allows you to choose a calendar reference alias (content assist will
show references which already exist), or pick a Runtime Identifier
field that will provide the Calendar Reference alias at runtime.

Participants Provides the Label, Name, Type, and External Reference for all
participants used in the process.

Parameters Provides information about all parameters defined in the process.

Data Fields Provides information about all data fields defined in the process.

240

TIBCO Business Studio™ Modeling Guide



Tab Property Description

Appearance Connection
Routing

The connection routing style is used to change the appearance of
entry and exit connections on activities such as events and
gateways.

The connection routing style can be one of the following:

● MultiEntry/Exit Point(default). This means that connection
points are to/from the same activity side, and are automatically
spaced out from the centre of that side.

● Single Entry/Exit Point.This means that all extry and exit
points are amalgamated into one entry point and one exit point
on each side of an activity.

● Uncentered On Tasks. This means that entry and exit points
on task activities are automatically positioned towards the
corners when the source/target object is not in-line. This is the
equivalent default from earlier versions of TIBCO Business
Studio.

With all the above styles, it is still possible to manually set a
specific entry / exit point by dragging the end of a connection to
the required position on an activity's border (rather than the center
of the object).

Extended Extended attributes can be used to add extra information to the
schema. Click Add to add a new extended attribute.

Modify the following:

● Name - provide a name for the attribute (you cannot include
spaces in the name).

● Value- add any text for the value.

● Escape Body- Select this checkbox if you want the parser to
interpret the contents of the body attribute as text rather than
XML (you do not want the parser to interpret symbols such as
< or >). If you are entering XML, do not select this checkbox so
the parser can validate the body attribute.

● Body- enter whatever text or XML you want to make up the
body of attribute.

Resource BPM Fault
Configuration

System Error
Action

BPM only:

This configures how an instance of this process behaves at runtime
if an executing activity encounters an unexpected error condition:

● (server defined default)- use system wide default behavior
(see "Configuring Error Handling Behavior for Process
Instances" in the TIBCO ActiveMatrix BPM Administrator’s
Guidefor how to define this).

● Halt- process instance halts. You can then use Openspace,
Workspace or the BPM API to investigate/fix the problem.

● Error- process instance fails immediately and cannot be
resumed.
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Tab Property Description

BPMN
Extensions

Allows you to enter duration values for the process as per BPMN.
How these durations are used is dependent on how they are
implemented in a particular destination environment.

BPM Validation
Configuration...

This is used to suppress problem markers for the ’No migration
point activities in the process’ Problem. It gives you the choice of
validation, suppressing the error until the next process flow
change, or suppressing the error until a manual reactivation via
Resource properties.

Case Action Properties

Case Action Reference

Tab Property Description

General Label Label associated with the case action. You can change the label if
necessary.

Case Action Select Case class that this action applies to...: Case Class: Allows
you to select the case class to which the case action applies.

Select Case States that this action is visible for...: Once a case
class has been selected this provides selection of the case state
attribute values that the case action should be visible for at
runtime. All States switches off the case state value filter. Specific
States enables selection of case states using checkboxes.

● No Case State Set means that the case action will be visible
when none of the defined case states are set for a particular
case.

● Other states displayed are the values defined for the Case State
enumeration for the selected class.

Select the privileges required to use this action... Provides
selection of one or more organization model privileges that a
resource must have to be able to see and use the case action at
runtime. If no privileges are selected then all resources can see and
use the case action.

Process Interface Lists the location and name of the process interface implemented
by the selected case action. Specifying a process interface allows
the dynamic selection of sub-processes at runtime. For more
information, see Process Interfaces .

References Lists any processes or tasks that use the selected case action, and
the contexts in which the data is used. Click Go To to display the
referencing object. This field helps prevent deleting a case action
that is used elsewhere. Note, however that a case action may be
used by other packages, and these references cannot be displayed
in this field.
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Tab Property Description

Description Optional textual description of the activity.

Documentation
URL

The Documentation URL controls allow you to launch a web
browser for the given URL (you can use the actual Documentation
URL: label or the browser button).

The browser is opened either in TIBCO Business Studio (in the
editor pane) or in an external browser according to the user
defined settings (Preferences > General > General).

Destinations Enter the target environment for the case action. When you save
the case action, validation is performed according to this setting:

● All case actions are validated for BPMN - additionally, other
destinations can be selected to validate the case action for use
in specific environments

● If you select BPM, the case action will be validated against
TIBCO ActiveMatrix BPM 3.x.

● If you select Simulation, case actions created under this project
will be validated for simulation in TIBCO Business Studio as
well as for BPMN correctness.

● If you do not select a destination environment, basic BPMN
validation will be performed.

Participants Provides the Label, Name, Type, and External Reference for all
participants used in the case action.

Parameters Provides information about all parameters defined in the case
action.

When a case action is auto-generated from a case class,
then you auto-create a case reference parameter with the
mode set to IN.

Data Fields Provides information about all data fields defined in the case
action.

When a case action is auto-generated from a case class,
you auto-create some data fields.
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Tab Property Description

Appearance Connection
Routing

The connection routing style is used to change the appearance of
entry and exit connections on activities such as events and
gateways.

The connection routing style can be one of the following:

● MultiEntry/Exit Point(default). This means that connection
points are to/from the same activity side, and are automatically
spaced out from the centre of that side.

● Single Entry/Exit Point.This means that all extry and exit
points are amalgamated into one entry point and one exit point
on each side of an activity.

● Uncentered On Tasks. This means that entry and exit points
on task activities are automatically positioned towards the
corners when the source/target object is not in-line. This is the
equivalent default from earlier versions of TIBCO Business
Studio.

With all the above styles, it is still possible to manually set a
specific entry / exit point by dragging the end of a connection to
the required position on an activity's border (rather than the center
of the object).

Extended Extended attributes can be used to add extra information to the
schema. Click Add to add a new extended attribute.

Modify the following:

● Name - provide a name for the attribute (you cannot include
spaces in the name).

● Value- add any text for the value.

● Escape Body- Select this checkbox if you want the parser to
interpret the contents of the body attribute as text rather than
XML (you do not want the parser to interpret symbols such as
< or >). If you are entering XML, do not select this checkbox so
the parser can validate the body attribute.

● Body- enter whatever text or XML you want to make up the
body of attribute.
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Tab Property Description

Resource BPM Fault
Configuration

System Error
Action

BPM only:

This configures how an instance of this case action behaves at
runtime if an executing activity encounters an unexpected error
condition:

● (server defined default)- use system wide default behavior
(see "Configuring Error Handling Behavior for Process
Instances" in the TIBCO ActiveMatrix BPM Administrator’s
Guide for how to define this).

● Halt- process instance halts. You can then use Openspace,
Workspace or the BPM API to investigate/fix the problem.

● Error- process instance fails immediately and cannot be
resumed.

Activity Properties

Activity Property Reference

Tab Property Description

General Label Label for the activity that will be displayed on the
diagram.

Activity Markers Select from Standard Loop, Multiple Instance Loop,
or Ad-Hoc. For more information, see User Tasks and
Pageflow Processes .

Participants Specify the participant responsible for this activity (see 
Creating a Participant ).

Activity Type For example, Task, User Task, Service Task, and so on,
(see Creating References ). If you select Call Sub-
Process Activity, you must browse to locate the sub-
process.
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Tab Property Description

● No Form URL

● User Defined Form

● Form

● Pageflow

Configure the user task as follows:

● No Form URL
 Select this option if you do not want to display a
form for the user task.

● User Defined Form
 Select this option if you want to use the Form
Identifier field to point to a specific URI (for
example, if you authored a form outside of
TIBCO Business Studio). Manually enter the URI.
TIBCO Business Studio cannot validate the URI,
so ensure it is correct. If you select this option but
do not specify a URI, upon export a standard
form is created.

● Form
 Use this option if you have created a form using
TIBCO Business Studio Forms. Either
automatically create a form (in which case the
Form field is completed automatically) or browse
to select a form from a Forms special folder.

● Pageflow
 Select this option if you want the user task to call
a pageflow. Browse to select a pageflow process.
When deployed, the specified pageflow process is
run when the work item associated with the user
task is opened.

Reference Task

(Activities of type
Reference Task)

Select one of the following and browse to select the
name of the task that is referenced from the currently
selected task.

● Reference Task Library Task
● Reference Local Task

Is a transaction

(Activities of type
Embedded Sub-Process)

Select the New Sub-Process is a transaction checkbox
if you want the new sub-process to become a
transaction and therefore be under transaction control
(see User Tasks and Pageflow Processes ).

Chained Execution

(Activities of type Call
Sub-Process or
Embedded Sub-Process)

Specifies that the selected sub-process implements the
chained execution resource allocation pattern (see 
Creating a New Embedded Sub-Process ).

Sub-Process location

(Activities of type call
sub-process)

Sub-Process location is populated with the path to the
Sub-Process name that you select.
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Tab Property Description

Sub-Process name

(Activities of type call
sub-process)

Browse to select the Sub-Process name.

Runtime Identifier
Field

(Activities of type call
sub-process)

Specify the field that will be used in the runtime
process engine to dynamically select a sub-process that
implements a process interface. For more information,
see Process Interfaces .

Lifecycle

(Activities of type call
sub-process)

Use this to configure whether the sub-process should
execute immediately or whether its start request
should be queued.

If you select Schedule Start Request, then you set the
initial priority for the sub-process start and the tasks
within that using the options in the Priority drop-
down.

If you select Start Immediately then you can still set
the priority of the task within the process in the
process Work Resource tab.

You can specify whether sub-process instances should
suspend and resume when the parent process is
suspended or resumed by selecting or deselecting the
Suspend/Resume With Parent Process tickbox.

● No form

● Default form

● Workspace form

● External form

● Other

Specify the form to be used.

If you select Default form or Workspace form, you can
click Preview to see a preview of the form layout.

Description Optional textual description of the activity.

Documentation URL The Documentation URL controls allow you to launch
a web browser for the given URL (you can use the
actual Documentation URL: label or the browser
button).

The browser is opened either in TIBCO Business
Studio (in the editor pane) or in an external browser
according to the user defined settings (Preferences>
General>Web Browser).

The activity tooltip popup includes the Documentation
URL as a clickable hyperlink to launch the URL in a
browser.
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Tab Property Description

Interface (all task
types except
Reference)

Visibility Specify the visibility of an event or task (whether it is
private or public). Public events or tasks publish
information (such as required parameters) to an
external process or application. Private events or tasks
to publish any information to external applications.

Reschedule work item:

(User tasks)

Overwrite Data Already Modified In Work Item is
unset by default. Check it to overwrite data already
modified in a work item when you reschedule a user
task.

This is the same as the setting available on the Map
From Signal tab for a catch signal which reschedules a
task.

Parameters Allows you to select the data fields or parameters that
the task requires as input and output.

By default all process data is available to a task. When
you explicitly associate process data with an Event or
task, only that process data is associated with the event
or task. After you add data fields, you can control
whether it is an input parameter, output parameter, or
both by setting its Mode (to In, Out, or In/Out). You
can also specify whether the process data is
mandatory. For more information, see Associating
Process Data with Events and Tasks

Note that for user tasks, inbound and outbound
parameters are from the perspective of the form, not
the user. This means that inbound parameters are sent
to the form by the process, not the user. outbound
parameters are sent to the form by the user. For more
information, see the appropriate implementation
guide.

Data Fields Provides information about all data fields defined in
the activity.

Work Resource Participants

(Manual and user tasks
only)

This is the same as the Participant specified on the
General tab.

Initial Priority (Manual
and user tasks only)

Specifies a relative priority for the work item. The
affect and meaning of this setting is destination specific
(refer to appropriate implementation guide).

Distribution Strategy

(Message events and user
tasks only)

Allows you to specify a resource allocation pattern. For
more information, see Resource Patterns and Work
Distribution .
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Tab Property Description

Re-offer Work Item
Strategy...

Allows you to govern the behavior when you open an
offered work item and then close or cancel the work
item to place it back in the work item list. You can
choose to 'Re-offer On Close' or 'Re-offer On Cancel'.

Piling (Manual and user
tasks only)

Separation of Duties

(Manual and user tasks)

Allows you to specify that certain manual or user tasks
must be executed by different resources at runtime. For
more information, see Specifying Separation of Duties .

Retain Familiar
(Manual and user tasks)

Scripts Allows you to add text that describes various types of
scripts that you want added to a task. It is the task of
the solution engineer to translate the outline of the
script into a scripting language supported by the
selected destination environment. For more
information about implementing scripts, see the
appropriate implementation guide.

Map To Sub-Process

(Activities of type
call sub-process)

Use this section to create a mapping from an actual
parameter (data field or parameter) into the formal
parameters of the sub-process. Create a mapping by
clicking a parameter, dragging to the destination
parameter, then releasing the mouse button.

Data References Grouped by Data Contains a table with a row for each referenced data
field, along with a list of the contexts in which it is
used.

Grouped by Reference
Context

Contains a table with a row for each context along with
the data which is referenced.

Map From Sub-
Process

(Activities of type
call sub-process)

Use this section to create a mapping from a formal
parameter of a sub-process to an actual parameter
(data field or parameter). Create a mapping clicking a
parameter, dragging to the destination parameter, then
releasing the mouse button.

Appearance Line Color Click the button next to Color to select the line color
for the border of the selected activity. Click Set As
Default For Type to apply your current color settings
to any new activities of that type that you place on the
process. You can revert to the default color settings by
clicking Restore Factory Settings.
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Tab Property Description

Fill Color Click the button next to Color to select the fill color for
the selected activity. Click Set As Default For Type to
apply your current color settings to any new activities
of that type that you place on the process. You can
revert to the default color settings by clicking Restore
Factory Settings.

Task Icon Select a valid image file for the Studio project if one is
available.

Extended See the description of the Extended tab for the Process
Properties .

Resource BPMN Extensions Allows you to enter duration values for the task as per
BPMN. How these durations are used is dependent on
how they are implemented in a particular destination
environment.

Correlation Timeout
(for Receive task with
incoming flow)

Set the following to configure the timeout for
correlation events:

1. Days

2. Hours

3. Minutes

4. Seconds

These settings are used to configure the mimimum
number of days/hours/minutes/seconds before the
timeout occurs.
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Tab Property Description

Dynamic Sub-process
Task...(Dynamic sub-
process tasks)

Allow Unqualified Sub-
Process Identification

False: Sub-process names provided in the Runtime
Identifier Field must be fully qualified unless they are
located in the same XPDL package. Full qualification
means /project/Process Packages/
PkgName.xpdl.MyProcessName.

True: allow unqualified sub-process names to be used
even if they are located outside of the XPDL package
(when they will be dynamically discovered at
runtime).

When an unqualified sub-process is
provided in the Runtime Identifier Field, the
process manager will look for the process in
the following locations:

● The same deployed XPDL package.

● Any XPDL package in the same deployed
project.

● Any XPDL package in any deployed
project.

The first matching named process will be
used. If there are multiple processes with the
same name in any one of these locations (i.e.
the sub-process identification is ambiguous)
then it will result in a runtime exception that
will halt the process instance.

Gateway Properties

Gateway Property Reference

Tab Property Description

General Label Label for the gateway that will be displayed
on the diagram.

Gateway type Choose the type of gateway.

Discriminator Type

(Complex Gateway)

Allows you to select a structured
discriminator.

Parallel Split Name

(Complex Gateway)

Allows you to specify the name of the
upstream parallel gateway that this complex
gateway is handling.

Incoming Paths

(Complex Gateway)

Specifies how many input Sequence flows
are required before the output sequence
flow is followed.
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Tab Property Description

Description Optional textual description of the gateway.

Data References Grouped By Data Contains a table with a row for each item of
referenced process data, along with a list of
the contexts in which it is used.

Grouped By Reference
Context...

Contains a table with a row for each context
along with the process data which is
referenced.

Appearance See the description of the Appearance tab
for the Activity Properties .

Extended See the description of the Extended tab for
the Process Properties .

Resource Shows properties and values for the
gateway.

Sequence Flow Properties

Sequence Flow Property Reference

Tab Property Description

General Label Label for the flow that will be displayed on the
diagram.

Type Choose the type of Sequence Flow.

Description Optional textual description of the Sequence
Flow.

Data References Grouped By Data Contains a table with a row for each item of
referenced process data, along with a list of the
contexts in which it is used.

Grouped by Reference
Context

Contains a table with a row for each context
along with the process data which is referenced.

Appearance See the description of the Appearance tab for the 
Activity Properties .

Extended See the description of the Extended tab for the 
Process Properties .

Resource Shows properties and values for the sequence
flow.
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Event Properties

Event Property Reference

Tab Property Description

General Label Label for the event that will be displayed on the
diagram.

Trigger Type (for Start or
Intermediate events) or
Result Type (for End
events)

You specify the trigger for a Start or
Intermediate event and the result for an End
event. The properties displayed on this page
depend on the Trigger Type or Result Type you
have selected. For more information about the
types of events, see Events .

Catch Action (for catch
signal intermediate events
only)

Select either Cancel task when signal caught or
Continue task when signal caught. When you
select the latter, you can select between the
following Reschedule Task Timer Events:

● None No timer events are rescheduled when
signal arrives.

● All All timer events attached to same task are
rescheduled when signal arrives.

● Deadline The timer event set as the activity
deadline; note this is evaluated at runtime
rather that statically when this option is
selected (so that if the deadline timer event is
changed, this still works).

● Select... One or more timer events can be
manually selected.

Catch Error Code (for
catch error intermediate
events only)

Set to one of the following, depending on what
error codes you want caught:

● Catch All
 The event catches any error thrown by any
event.

● Catch By Name
 The event catches an error of the specified
name, thrown by any activity.

● Catch Specific
 The event catches a specific error thrown
by a specific activity.

Description Optional textual description of the Event.

Interface See description for Activity Properties .
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Tab Property Description

Scripts See description for Activity Properties .

Data References Grouped By Data Contains a table with a row for each item of
referenced process data, along with a list of the
contexts in which it is used.

Grouped by Reference
Context

Contains a table with a row for each context
along with the process data which is referenced.

Map From Error (for
catch error intermediate
events only)

Use this section to create a mapping from error
parameters to process data fields or parameters.

Map From Signal(for
catch signal intermediate
events only)

Use this section to create a mapping from signal
parameters to process data fields or parameters.

Appearance See the description of the Appearance tab for the 
Activity Properties .

Extended See the description of the Extended tab for the 
Process Properties .

Resource Correlation Timeout (for
catch message intermediate
events only)

Set the following to configure the timeout for
correlation events:

1. Days

2. Hours

3. Minutes

4. Seconds

These settings are used to configure the
mimimum number of days/hours/minutes/
seconds before the timeout occurs.

Lane Properties

Lane Property Reference

Tab Property Description

General Label Label for the lane that will be displayed on the diagram.

Appearance See the description of the Appearance tab for the Activity
Properties .

Extended See the description of the Extended tab for the Process
Properties .

Resource This tab may contain destination-specific properties.

254

TIBCO Business Studio™ Modeling Guide



Cheat Sheets View
When you first start TIBCO Business Studio, a Welcome Cheat Sheet is displayed. You can view TIBCO
Cheat Sheets and other Cheat Sheets by selecting Help > Cheat Sheets and selecting from the list.

Process Editor
The Process Editor is where you create your business process. It includes a Palette that contains the tools
you use to create your Process.

Palette
You can create your Process using the tools on the palette. The Business Process Modeling Notation
(BPMN) core set is supported by the palette, which contains the following tools:

Palette Tool Reference

Palette Item Description

 Select
Allows you to select objects.

 Marquee Allows you to select several objects by drawing a box around them.

Favorites Displays some of the most common process objects. You can
customize the Favorites drawer by right-clicking it and selecting
Customize.

Connections Allows you to connect objects:

● Sequence flow shows the order of objects in the process.

● Conditional sequence flow is followed based on the evaluation of a
condition.

● Default sequence flow is followed if other conditions evaluate to
false.

● Message flow indicate the flow of messages between objects in
separate Pools or between Pools.

● Association either connects flow and non-flow objects or specifies
the compensation task for a compensation event on a task
boundary.

Start Events Indicates the beginning of the process as None, Message, Timer,
Conditional, Multiple, or Signal.
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Palette Item Description

Catch Intermediate Events Catches a "throw" event. The following Types are available: None,
Message, Timer, Conditional, Link, Signal, Multiple, Error,
Compensation, and Cancel.

Throw Intermediate Events Throws an event. The following Types are available: Message,
Compensation, Signal, Multiple and Link.

End Events Indicates the end of the process. The following types are available:
None, Message, Multiple, Error, Compensation, Cancel, Signal, and
Terminate.

Tasks Tasks of the following types: Abstract, User, Manual, Service, Script,
Send, Receive, Reference, Call Sub-Process, Embedded Sub-Process,
Event Sub-Process.

For more information, see Activities.

Gateways Controls the flow of the process with the following types of gateways:
Exclusive (Data), Parallel, Exclusive (Event), Inclusive, and Complex.

Artifacts Allows you to enhance the process with Text Annotations, Data
Objects, Groups, Pools, and Lanes.

Alignment Tools
For easier alignment of objects in the Process Editor, you can select either or both of the Grid or Alignment
Guides options.

● Diagram > Grid - This allows you to align objects to a grid.
● Diagram > Alignment Guides - As you move objects in a Process Editor, a blue line appears when the

center of two objects coincide.
You can also align objects that you have selected by choosing options from the Diagram > Alignment
menu. For example, if you have two Activities selected, you can align them horizontally on their centers by
selecting Diagram > Alignment > Align Middle. Alternatively you can use the alignment buttons on the
toolbar that correspond to the menu options.
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Business Object Modeler Properties View
This section describes the major parts of the TIBCO Business Studio Business Object Modeler User Interface
(UI).

In Eclipse, a Perspective includes the views and set of editors that you commonly use for a specific type of
work. TIBCO has created several TIBCO Business Studio perspectives that include the views and editors
you commonly use when creating business processes. The Business Object Modeler and its associated views
are part of the BPM Modeling Perspective. For more information about parts of the BPM Modeling
Perspective that are not related to the Business Object Modeler, see the TIBCO Business Studio Modeling
User’s Guide.

The Properties View shows you detailed information about the currently selected object and allows you to
specify the characteristics of an object.

Package Properties

Tab Property Description

General Name Name of the Package. You can re-name the
Package here by entering a new name.

Description Area in which you can enter text to describe the
Package or any supporting explanations.

Profiles Profiles Lists the UML profiles that have been applied to
this package.

Clicking the picker displays the Select Type dialog
from which you can add or remove profiles.

Applied Profiles The name of the applied profile.

Location The location of the file that contains the applied
profile.

Stereotypes Lists the stereotypes that have been applied to this
package.

Clicking the picker displays the Select Type dialog
from which you can add or remove stereotypes.

Applied Stereotype The name of the stereotype.

Profile The name of the profile that contains the
stereotype.

Location The location of the file that contains the
stereotype.

Export XML Schema Export Options Lists the available elements and allows selection
of which to export as top level elements in the
XML Schema.

Resource Property
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Tab Property Description

Value The name of the package.

Class Properties

Tab Property Description

General Name Name of the Class. You can re-name the Class here
by entering a new name.

Superclass In object oriented terms, the Super Class provides
attributes which are inherited by any Derived
Classes.

Clicking the picker displays the Select Type dialog
from which you can select a Class to form the
SuperClass. Click Clear to remove a SuperClass.

Description Area in which you can enter text to describe the
Class or any supporting explanations.

Attributes Lists the Attributes that belong to the Class,
including its Name, Type, Multiplicity (whether
there can be several of the Attribute), and
Stereotypes (whether any stereotypes have been
applied). You can add additional Attributes by

clicking  . You can delete an Attribute by

selecting it and clicking  .
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Tab Property Description

Summary Lists the Case Class attributes that will be
included in the Summary description of the Case
that is displayed in Openspace.

You can add additional Attributes by clicking  .
You can delete an Attribute by selecting it and

clicking  .

The Case Identifier and Case State are
automatically included (and cannot be removed).
If you wish to add additional attributes, then they
must have:

● Multiplicity no more than 1

● An attribute of a primitive type (for example,
Integer, Text) or enumeration

The order in which the attributes are
listed in the Summary screen is the
default order they will be displayed in
Openspace, or returned over the
Summary interface at runtime.

Operations Lists the Operations that belong to the Class,
including its Name, Return Type, Multiplicity
(whether there can be several of the Operation),
Arguments and Stereotypes (whether any
stereotypes have been applied). You can add

additional Operations by clicking  . You can
delete an Operation by selecting it and clicking

 .

Stereotypes Lists the stereotypes that have been applied to this
class.

Clicking the picker displays the Select Stereotype
dialog from which you can add or remove
stereotypes.

Applied Stereotype The name of the stereotype.

Profile The name of the profile that contains the
stereotype.

Location The location of the file that contains the
stereotype.
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Tab Property Description

Appearance Fonts and Colors Enables you to change the font type and size of the
text on your business object model. You can also
change the weight and color of both the text and
the business objects in the business object model.

Lines and Arrows Enables you to change the appearance of lines and
arrows in your business object model. This is
currently deselected.

Gradient Enables you to change the gradient of colors for
your business objects in the business object model.

Resource Property

Value The name of the class.

Attribute Properties

Tab Property Description

General Name Name of the Attribute. You can re-name the
Attribute here by entering a new name.

Multiplicity Allows you to select whether multiple copies of an
Attribute are permitted. See "Attributes" in the
TIBCO Business Studio Concepts Guide for
information on the values you can set.

Type Select the type of data you expect the Attribute to
contain. See "Attributes" in the TIBCO Business
Studio Concepts Guide for information on the types
an Attribute can have.

Clicking the picker displays the Select Type dialog
from which you can change the type of an

attribute. Click  to remove a type.

Description Area in which you can enter text to describe the
Attribute or any supporting explanations.

Stereotypes Lists the stereotypes that have been applied to this
package.

Clicking the picker displays the Select Type dialog
from which you can add or remove stereotypes.

Applied Stereotype The name of the stereotype.

Profile The name of the profile that contains the
stereotype.

Location The location of the file that contains the stereotype.
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Tab Property Description

Resource Property

Restrictions Expand this to specify any restrictions for the
Attribute. For example, you can specify a default
value, or maximum length, depending on the type
of your Attribute.

Value The name of the Attribute.

Operation Properties

Tab Property Description

General Name Name of the Operation. You can re-name the
Operation here by entering a new name.

Return Type Select the type of data you want the return value of
the Operation to return. See "Operations" in the
TIBCO Business Studio Concepts Guide for
information on Operations.

Clicking the picker displays the Select Type dialog
from which you can select the type of an attribute.
Click Clear to remove a type.

Multiplicity Allows you to set a multiplicity value for the
Operation. For example, using the drop-down list
you can select 0..1, 1..0, 1..*, and so on.

Arguments Lists the Arguments that you can specify for an
Operation, including its Name and Type. You can

add additional Arguments by clicking  . You
can delete an Argument by selecting it and clicking

 .

Description Area in which you can enter text to describe the
Operation or any supporting explanations.

Stereotypes Lists the stereotypes that have been applied to this
package.

Clicking the picker displays the Select Type dialog
from which you can add or remove stereotypes.

Applied Stereotype The name of the stereotype.

Profile The name of the profile that contains the
stereotype.

Location The location of the file that contains the stereotype.
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Tab Property Description

Resource Property

Value The name of the Operation.

Primitive Type Properties

Tab Property Description

General Name Name of the Primitive Type. You can re-name
the Primitive Type here by entering a new name.

Superclass In object oriented terms, the Superclass provides
attributes which are inherited by any Derived
Classes.

Clicking the picker displays the Select Type
dialog from which you can select a Type to form
the Superclass for the Primitive Type. Click
Clear to clear a Superclass.

Description Area in which you can enter text to describe the
Primitive Type or any supporting explanations.

Stereotypes Lists the stereotypes that have been applied to
this package.

Clicking the picker displays the Select Type
dialog from which you can add or remove
stereotypes.

Applied Stereotype The name of the stereotype.

Profile The name of the profile that contains the
stereotype.

Location The location of the file that contains the
stereotype.

Appearance Fonts and Colors Enables you to change the font type and size of
the text on your business object model. You can
also change the weight and color of both the text
and the business objects in the business object
model.

Lines and Arrows Enables you to change the appearance of lines
and arrows in your business object model. This
is currently deselected.

Gradient Enables you to change the gradient of colors for
your business objects in the business object
model.
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Tab Property Description

Resource Property

Restrictions Expand this to specify any restrictions for the
Primitive Type. For example, you can specify a
default value, or maximum length, depending
on the type of your Primitive Type.

Value The name of the Primitive Type.

Enumeration Properties

Tab Property Description

General Name Name of the Enumeration. You can re-name the
Enumeration here by entering a new name.

Superclass In object oriented terms, the Superclass provides
attributes which are inherited by any Derived
Classes.

Clicking the picker displays the Select Type dialog
from which you can select a Class to form the
Superclass. Click Clear to remove a Superclass.

Description Area in which you can enter text to describe the
Enumeration or any supporting explanations.

Enum Literals

Stereotypes Lists the stereotypes that have been applied to this
Enumeration.

Clicking the picker displays the Select Type dialog
from which you can add or remove stereotypes.

Applied Stereotype The name of the stereotype.

Profile The name of the profile that contains the
stereotype.

Location The location of the file that contains the stereotype.

Appearance Fonts and Colors Enables you to change the font type and size of the
text on your business object model. You can also
change the weight and color of both the text and
the business objects in the business object model.

Lines and Arrows Enables you to change the appearance of lines and
arrows in your business object model. This is
currently deselected.
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Tab Property Description

Gradient Enables you to change the gradient of colors for
your business objects in the business object model.

Resource Property

Value The name of the Enumeration.

Enumeration Literal Properties

Tab Property Description

General Name Name of the Enumeration Literal. You can re-name
the Enumeration Literal here by entering a new
name.

Value Single: The value of the enumeration literal. The
format of the value entered here depends on the
data type of which the enumeration containing
this enumeration literal is a generalization.

Range: is not supported.

Description Area in which you can enter text to describe the
Enumeration Literal or any supporting
explanations.

Stereotypes Lists the stereotypes that have been applied to this
Enumeration Literal.

Clicking the picker displays the Select Type dialog
from which you can add or remove stereotypes.

Applied Stereotype The name of the stereotype.

Profile The name of the profile that contains the
stereotype.

Location The location of the file that contains the stereotype.

Resource Property

Value The name of the Enumeration Literal.
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Generalization Properties

Tab Property Description

General Specific Identifies the specific Class in the Generalization
relationship. This is read-only.

The generalization relationship indicates that, of
the two related Classes, one is a more general
form of the other and one is a more specific form.
For example, a Doctor is a more specific form of
the general form Person.

General Identifies the general Class in the generalization
relationship. This is read-only.

The generalization relationship indicates that, of
the two related Classes, one is a more general
form of the other and one is a more specific form.
For example, a Doctor is a more specific form of
the general form Person.

Description Area in which you can enter text to describe the
Generalization or any supporting explanations.

Stereotypes Lists the stereotypes that have been applied to
this package.

Clicking the picker displays the Select Type
dialog from which you can add or remove
stereotypes.

Applied Stereotype The name of the stereotype.

Profile The name of the profile that contains the
stereotype.

Location The location of the file that contains the
stereotype.

Appearance Fonts and Colors Enables you to change the font type and size of
the text of the labels on your connections on your
business object model. You can also change the
weight and color of the connections.

Routing Enables you to determine how the connections
are routed in the model. For example, you can
choose to make the connections avoid
obstructions to make the model easier to read.

Lines and Arrows Enables you to change the appearance of lines
and arrows in your business object model. This is
currently deselected.
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Tab Property Description

Jump Links If you have connections that cross over each other
in your model, specify jump links so that the
connections jump over each other.

Smoothness Enables you to change the smoothness of the
connections.

Resource Property

Value The name of the Generalization Property.

Association Aggregation Composition Properties

Tab Property Description

General Name Name of the Association, Aggregation or
Composition. You can re-name the connection
here by entering a new name.

Navigability Select the direction of the connection from the
drop-down list either Bi-directional or
ClassName1

to ClassName2.

Aggregation Kind Specifies the Aggregation kind from the Source
Class to the target Class. You can choose one of
the following Aggregation kinds:

● None - no Aggregation is used.

● Aggregation - An aggregate connection is
used.

● Composition - A composite connection is
used.

See "Relationships" in the TIBCO Business Studio
Concepts Guide for more information about these
connections.

Description Area in which you can enter text to describe the
Association, Aggregation or Composition and
any supporting explanations.

Stereotypes Applied Stereotypes The name of the stereotype.

Profile The name of the profile that contains the
stereotype.

Location The location of the file that contains the
stereotype.
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Tab Property Description

Appearance Fonts and Colors Enables you to change the font type and size of
the text of the labels on your connections on your
business object model. You can also change the
weight and color of the connections.

Routing Enables you to determine how the connections
are routed in the model. For example, you can
choose to make the connections avoid
obstructions to make the model easier to read.

Lines and Arrows Enables you to change the appearance of lines
and arrows in your business object model. This is
currently deselected.

Jump Links If you have connections that cross over each
other in your model, specify jump links so that
the connections jump over each other.

Smoothness Enables you to change the smoothness of the
connections.

Resource Property

Value The name of the Association/Aggregation/
Composition Property

Association Class Properties

Tab Property Description

General Name Name of the Association Class. You can re-name
the Association Class here by entering a new
name.

Superclass In object oriented terms, the Super Class provides
attributes which are inherited by any Derived
Classes.

Clicking the picker displays the Select Type dialog
from which you can select a Class to form the
SuperClass. Click Clear to remove a SuperClass.

Description Area in which you can enter text to describe the
Association Class or any supporting explanations.

Stereotypes Apply/Unapply Stereotypes Lists the stereotypes that have been applied to this
Association Class.

Clicking the picker displays the Select Stereotype
dialog from which you can add or remove
stereotypes.
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Tab Property Description

Applied Stereotypes The name of the stereotype.

Profile The name of the profile that contains the
stereotype.

File The path to the file that contains the stereotype.

Appearance Fonts and Colors Enables you to change the font type and size of the
text on your business object model. You can also
change the weight and color of both the text and
the business objects in the business object model.

Resource Stereotypename where
Stereotypename is the name of
any applied stereotypes.

If a stereotype is applied, the name of the
stereotype is displayed here. Expand this to edit
any properties of the stereotype.

General The name of the Association Class.

Superclass In object oriented terms, the Super Class provides
attributes which are inherited by any Derived
Classes.

Clicking the picker displays the Select Type dialog
from which you can select a Class to form the
SuperClass. Click Clear to remove a SuperClass.

Organization Modeler Properties View
This section of the help describes the major parts of the TIBCO Business Studio Organization Modeler User
Interface (UI).

In Eclipse, a Perspective includes the views and set of editors that you commonly use for a specific type of
work. TIBCO has created several TIBCO Business Studio perspectives that include the views and editors
you commonly use when creating business processes. The Organization Modeler and its associated views
are part of the BPM Modeling Perspective.

For more information about parts of the BPM Modeling Perspective that are not related to the Organization
Modeler, see the TIBCO Business Studio Modeling User’s Guide.

The Properties View shows you detailed information about the currently selected object and allows you to
specify the characteristics of an object.

Organization Model Properties describes the Properties that are available for the elements in an
Organization Model.

Organization Model Properties

Tab Property Description

General Label The displayed name of the Organization Model. You can
re-name the Organization Model here by entering a new
name.
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Tab Property Description

Name The internal name. This defaults to the same value as the
Label, but with any internal spaces removed.

Version The version of the Organization Model. This defaults to
the version specified when the project was created, which
in turn defaults to 1.0.0.qualifier. You can retain this or
enter a different version for the Organization Model in the
standard Eclipse form of:
      major.minor.micro.qualifier

There is a limit of 6 on the number of organization model
versions supported.

Changes to the version of the Organization Model do not
directly affect other project artifacts, such as process
packages. However, all references within a project must be
to the same major version of the Organization Model.

At run-time, the Organization Model Versionfield in the
Organization Browser in Workspace displays only the first
digit of this version number, that is the major version.

Author The username that created the Organization Model.

The name of the author can be defined in the User Name:
field on Window > Preferences > User Profile. If no user is
defined there, it uses the default user system property.

Date Created The date the Organization Model was created.

Privileges -
Assigned

Privilege The name of the Privilege associated with this
Organization Model. Click the picker to open the Select
Type dialog to add or remove a Privilege.

Qualifier Value You can enter qualifying information here if required. See
"Capabilities and Privileges" in TIBCO Business Studio
Concepts Guide for more information about qualifications.
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Tab Property Description

System
Actions

Name The name of the system action.

If you associate one or more privileges with a system
action, they are listed on the lines below that action. Click

 to expand the display and show the privileges, and

click  to collapse the display.

Click  to assign a privilege to a system action. The
Select Type dialog is displayed, enabling you to add or
remove a privilege. You can also remove a privilege by

selecting it and clicking  .

Click  to move the privilege up the list, or  to
move it down. These icons are only available if there is
more than one privilege attached to a system action.

Qualifier Value If a privilege has qualifying information specified, this
column lists the value of the qualifier.

Click  to reset the value of a qualifier to the default
value defined for it.

Resource Property
Value

Displays the Label and Name of the Organization Model.
You can edit the values from this tab by clicking on the
Value field.

Organization Properties

Tab Property Description

General Label The displayed name of the Organization. You can re-
name the Organization here by entering a new name.

The default name of the Organization Model will be used
here, which is Organization1. To change the default,
select Window > Preferences > User Profile and edit the
Organization Name field.

Name The internal name. This defaults to the same value as the
Label, but with any internal spaces removed.

Type The type for the Organization. This can be the Standard
Organization Type, for example or may be a type that
you have defined yourself. See "Schemas" in the TIBCO
Business Studio Concepts Guide for more information about
types.

Clicking the picker displays the Select Type dialog from
which you can add or remove Organization Types.
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Tab Property Description

Allocation Method One of Random or Round Robin. Determines how work
is allocated.

Purpose Area in which you can enter text to describe the purpose
of the Organization.

Dates Enables you to specify start and end dates for the
Organization. Click the picker next to the date fields to
display the calendars.

Location The location for the Organization. Click the picker next to
the Location field to select it.

Units Label The name of any Organization Units that are defined as

being children of this Organization. Click  to add an
Organization Unit. You can delete an Organization Unit

by selecting it and clicking  .

Type
Location
Start Date
End Date

The characteristics of the Organization Unit named by
Label. These are display-only.

Appearance Fonts and Colors

Lines and Arrows

Resource Property
Value

Displays the Label and Name of the Organization. You
can edit the values from this tab by clicking on the Value
field.

Dynamic Organization Properties

Tab Property Description

General Label The displayed label of the Dynamic Organization. You
can re-name the Dynamic Organization here by entering
a new label.

The default label of the Dynamic Organization Model
will be used here, which is Dynamic Organization 1.

Name The internal name. This defaults to the same value as the
Label, but with any spaces and special characters
removed.

Purpose Area in which you can enter text to describe the purpose
of the Dynamic Organization.
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Tab Property Description

Dynamic Org
Identifiers

Label The displayed label of the Dynamic Organization
Identifier.

Name The internal name. This defaults to the same value as the
Label, but with any spaces and special characters
removed.

Units Label The label of any Organization Units that are defined as

being children of this Organization. Click  to add a
Organization Unit. You can delete a Organization Unit by

selecting it and clicking  .

Name The internal name. This defaults to the same value as the
Label, but with any spaces and special characters
removed.

Type The characteristics of the Dynamic Organization Unit
named by Label. These are display-only.

Location The location for the Dynamic Organization. Click the
picker next to the Location field to select it.

Appearance Fonts and Colors

Lines and Arrows

Resource Property
Value

Displays the Label and Name of the Dynamic
Organization. You can edit the values from this tab by
clicking on the Value field.

Organization Unit Properties

Tab Property Description

General Label The displayed name of the Organization Unit. You can
re-name the Organization Unit here by entering a new
name.

Name The internal name. This defaults to the same value as the
Label, but with any internal spaces removed.

Member of If you are using the default schema, or if you have
created your own schema and defined any Organization
Unit Types, you can assign a Type to this Organization
Unit by selecting it in the Member of field.

Allocation Method One of Random or Round Robin. Determines how work
is allocated.
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Tab Property Description

Purpose Area in which you can enter text to describe the purpose
of the Organization Unit.

Dates Enables you to specify start and end dates for the
Organization Unit. Click the picker next to the date fields
to display the calendars.

Location The location for the Organization Unit. Click the picker
next to the Location field to select it.

Units Label The name of any Organization Units lower in the
hierarchy that are defined as being children of this

Organization Unit. Click  to add an Organization
Unit. You can delete an Organization Unit by selecting it

and clicking  .

Type
Location
Start Date
End Date

The characteristics of the Organization Unit named by
Label. These are display-only.

Positions Label The name of any Positions that are defined as being

children of this Organization Unit. Click  to add a
Position. You can delete a Position by selecting it and

clicking  .

Type
Location
Start Date
End Date

The characteristics of the Position named by Label. These
are display-only.

Privileges -
Assigned

Privilege The name of the Privilege you want to specify for this
Organization Unit. Click the picker to open the Select
Type dialog to add or remove a Privilege.

Qualifier Value You can enter qualifying information here if required. See
"Capabilities and Privileges" in the TIBCO Business Studio
Concepts Guide for more information about qualifications.
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Tab Property Description

System
Actions

Name The name of the system action.

If you associate one or more privileges with a system
action, they are listed on the lines below that action. Click

 to expand the display and show the privileges, and

click  to collapse the display.

Click  to assign a privilege to a system action. The
Select Type dialog is displayed, enabling you to add or
remove a privilege. You can also remove a privilege by

selecting it and clicking  .

Click  to move the privilege up the list, or  to
move it down. These icons are only available if there is
more than one privilege attached to a system action.

Qualifier Value If a privilege has qualifying information specified, this
column lists the value of the qualifier.

Click  to reset the value of a qualifier to the default
value defined for it.

Appearance Fonts and Colors

Lines and Arrows

Gradient

Resource Property
Value

Displays the Label and Name of the Organization Unit.
You can edit the values from this tab by clicking on the
Value field.

Dynamic Organization Unit Properties

Tab Property Description

General Label The displayed label of the Dynamic Organization Unit.
The label and name are derived from the root
organization unit of the referenced dynamic
organization. You cannot change this value.

Name The internal name. This defaults to the same value as the
Label, but with any internal spaces removed. The label
and name are derived from the root organization unit of
the referenced dynamic organization. You cannot change
this value.

Dynamic Organization The name of the Dynamic Organization that this
Dynamic Organization Unit references.
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Tab Property Description

Appearance Fonts and Colors

Lines and Arrows

Gradient

Resource Property
Value

Displays the Label and Name of the Dynamic
Organization Unit. Read-only.

Hierarchy and Association Properties
.

Tab Property Description

General Label The displayed name of the Hierarchy or Association. You
can re-name the Hierarchy or Association here by
entering a new name.

Name The internal name. This defaults to the same value as the
Label, but with any internal spaces removed.

Type The type for the Hierarchy or Association. This can be an
Organization Unit Relationship Type, for example or may
be a type that you have defined yourself. See "Schemas"
in the TIBCO Business Studio Concepts Guide for more
information about types.

Clicking the picker displays the Select Type dialog from
which you can add or remove Types.

Is Hierarchical This checkbox determines whether the connection is a
Hierarchy or an Association. If this is checked, the
connection is a Hierarchy; if unchecked, it is an
Association. You can change the type of connection by
checking or unchecking this box.

Purpose Area in which you can enter text to describe the purpose
of the Hierarchy or Association.

Dates Enables you to specify start and end dates for the
Hierarchy or Association. Click the picker next to the
date fields to display the calendars.

Appearance

Resource Property
Value

Displays the Label and Name of the Hierarchy or
Association, and the From and To values. You can edit
the values from this tab by clicking on the Value field.

From The Organization Unit the relationship runs from. In a
Hierarchical relationship, this is the unit at the higher
level of the hierarchy.
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Tab Property Description

To The Organization Unit the relationship runs to. In a
Hierarchical relationship, this is the unit at the lower
level of the hierarchy.

Position Properties

Tab Property Description

General Label The displayed name of the Position. You can re-name the
Position here by entering a new name.

Name The internal name. This defaults to the same value as the
Label, but with any internal spaces removed.

Position Type If you are using the default schema, or if you have created
your own schema and defined any Position Types, you can
assign a Type to this Position by selecting it in the Element
field.

Allocation Method One of Random or Round Robin. Determines how work is
allocated.

Number Enter the ideal number of people there should be in this
Position within the Organization Unit.

Purpose Area in which you can enter text to describe the purpose of
the Position.

Dates Enables you to specify start and end dates for the Position.
Click the picker next to the date fields to display the
calendars.

Location The location for the Position.

Clicking the picker displays the Select Type dialog from
which you can add or remove Locations.

Capabilities -
Assigned

Capability The name of the Capability you want to specify for this
Position. Click the picker to open the Select Type dialog to
add or remove a Capability.

Qualifier Value You can enter qualifying information here if required. See
"Capabilities and Privileges" in the TIBCO Business Studio
Concepts Guide for more information about qualifications.

Privileges -
Assigned

Privilege The name of the Privilege you want to specify for this
Position. Click the picker to open the Select Type dialog to
add or remove a Privilege.

Qualifier Value You can enter qualifying information here if required. See
"Capabilities and Privileges" in the TIBCO Business Studio
Concepts Guide for more information about qualifications.
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Tab Property Description

Organization
Resources

Label Shows any Resources allocated to the Position.

Click  to add a Resource. You can delete a Resource by

selecting it and clicking  .

System Actions Name The name of the system action.

If you associate one or more privileges with a system action,

they are listed on the lines below that action. Click  to

expand the display and show the privileges, and click  to
collapse the display.

Click  to assign a privilege to a system action. The Select
Type dialog is displayed, enabling you to add or remove a
privilege. You can also remove a privilege by selecting it and

clicking  .

Click  to move the privilege up the list, or  to move it
down. These icons are only available if there is more than one
privilege attached to a system action.

Qualifier Value If a privilege has qualifying information specified, this
column lists the value of the qualifier.

Click  to reset the value of a qualifier to the default value
defined for it.

Description Description Area in which you can enter text to describe the Position or
any supporting explanations.

Resource Property
Value

Displays the Label and Name properties of the Position. You
can edit the values from this tab by clicking on the Value field.

Group Properties

Tab Property Description

General Label The displayed name of the Group. You can re-name the Group
here by entering a new name.

Name The internal name. This defaults to the same value as the
Label, but with any internal spaces removed.

Allocation Method One of Random or Round Robin. Determines how work is
allocated.

Purpose Area in which you can enter text to describe the purpose of
the Group.
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Tab Property Description

Capabilities -
Assigned

Capability The name of the Capability you want to specify for this
Group. Click the picker to open the Select Type dialog to add
or remove a Capability.

Qualifier Value You can enter qualifying information here if required. See
"Capabilities and Privileges" in the TIBCO Business Studio
Concepts Guidefor more information about qualifications.

Privileges -
Assigned

Privilege The name of the Privilege you want to specify for this Group.
Click the picker to open the Select Type dialog to add or
remove a Privilege.

Qualifier Value You can enter qualifying information here if required. See
"Capabilities and Privileges" in the TIBCO Business Studio
Concepts Guide for more information about qualifications.

Groups Label Shows any sub-Groups that are part of the Group.

Click  to add a Group. You can delete a Group by selecting

it and clicking  .

Organization
Resources

Label Shows any Resources allocated to the Group.

Click  to add a Resource. You can delete a Resource by

selecting it and clicking  .

System Actions Name The name of the system action.

If you associate one or more privileges with a system action,

they are listed on the lines below that action. Click  to

expand the display and show the privileges, and click  to
collapse the display.

Click  to assign a privilege to a system action. The Select
Type dialog is displayed, enabling you to add or remove a
privilege. You can also remove a privilege by selecting it and

clicking  .

Click  to move the privilege up the list, or  to move it
down. These icons are only available if there is more than one
privilege attached to a system action.

Qualifier Value If a privilege has qualifying information specified, this column
lists the value of the qualifier.

Click  to reset the value of a qualifier to the default value
defined for it.
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Tab Property Description

Description Description Area in which you can enter text to describe the Group or any
supporting explanations.

Resource Property
Value

Displays the Label and Name of the Group. You can edit the
values from this tab by clicking on the Value field.

Capability Category and Privilege Category Properties

Tab Property Description

General Label The displayed name of the Category. You can re-name the
Category here by entering a new name.

Name The internal name. This defaults to the same value as the
Label, but with any internal spaces removed.

Capabilities
or
Privileges

Lists the Capabilities or Privileges that are members of this
category.

Resource Property
Value

Displays the Label and Name of the Category. You can edit the
values from this tab by clicking on the Value field.

Capability Properties
.

Tab Property Description

General Label The displayed name of the Capability. You can re-name the
Capability here by entering a new name.

Name The internal name. This defaults to the same value as the
Label, but with any internal spaces removed.

Has qualifier Select this option if you want to add qualifying information to
a Capability or Privilege. See "Capabilities and Privileges" in
the TIBCO Business Studio Concepts Guide for more information
about qualifications.

If this check box is selected the Show qualifier .. link is
enabled. Click Show qualifier .. or click on the Qualifier tab
title to display the Qualifier tab. This enables you to specify a
data type for your qualifying information.

Purpose Area in which you can enter text to describe the purpose of
the Capability.

Category Shows the Category of which this Capability is a member.
Click the picker to open the Select Type dialog to add or
remove a Category.
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Tab Property Description

Description Description Area in which you can enter text to describe the Capability or
any supporting explanations.

Resource Property
Value

Displays the Label and Name of the Capability. You can edit
the values from this tab by clicking on the Value field.

Privilege Properties

.

Tab Property Description

General Label The displayed name of the Privilege. You can re-name the
Privilege here by entering a new name.

Name The internal name. This defaults to the same value as the
Label, but with any internal spaces removed.

Has qualifier Select this option if you want to add qualifying information to
a Capability or Privilege. See "Capabilities and Privileges" in
the TIBCO Business Studio Concepts Guide for more information
about qualifications.

If this check box is selected the Show qualifier .. link is
enabled. Click Show qualifier .. or click on the Qualifier tab
title to display the Qualifier tab. This enables you to specify a
data type for your qualifying information.

Purpose Area in which you can enter text to describe the purpose of
the Privilege.

Category Shows the Category of which this Privilege is a member. Click
the picker to open the Select Type dialog to add or remove a
Category.

Qualifier Label The displayed name of the Qualifier.

Name The internal name. This defaults to the same value as the
Label, but with any internal spaces removed.

Type From the Type drop-down list, select a data type for the
qualifying information. See "Capabilities and Privileges" in the
TIBCO Business Studio Concepts Guide for more information
about the data types that qualifying information can have.

Default Value You can specify a default value for the Qualifier here.

Description Description Area in which you can enter text to describe the Privilege or
any supporting explanations.

Resource Property
Value

Displays the Label and Name of the Privilege. You can edit the
values from this tab by clicking on the Value field.
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Location Properties

.

Tab Property Description

General Label The displayed name of the Location. You can re-name the
Location here by entering a new name.

Name The internal name. This defaults to the same value as the
Label, but with any internal spaces removed.

Type The type for the Location. This can be the Standard Location
Type, for example or may be a type that you have defined
yourself. See "Schemas" in the TIBCO Business Studio Concepts
Guide for more information about types.

Clicking the picker displays the Select Type dialog from which
you can add or remove Location Types.

Allocation Method One of Random or Round Robin. Determines how work is
allocated.

Purpose Area in which you can enter text to describe the purpose of
the Location.

Dates Enables you to specify start and end dates for the Location.
Click the picker next to the date fields to display the
calendars.

Description Description Area in which you can enter text to describe the Location or
any supporting explanations.

Resource Property
Value

Displays the Label and Name of the Location. You can edit the
values from this tab by clicking on the Value field.

Resource Properties

Tab Property Description

General Label The displayed name of the Resource. You can re-name the
Resource here by entering a new name

Name The internal name. This defaults to the same value as the
Label, but with any internal spaces removed.

Type The type for the Resource. This can be the Human Resource
Type, for example, or may be a type that you have defined
yourself. See "Schemas" in the TIBCO Business Studio Concepts
Guide for more information about types.

Clicking the picker displays the Select Type dialog from which
you can add or remove Resource Types.
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Tab Property Description

Purpose A field in which you can enter text for a brief description of
the purpose of the Resource.

Dates Enables you to specify start and end dates for the Resource.
Click the picker next to the date fields to display the
calendars.

Attribute Values Label The name of any attributes that are defined for this type of
Resource are displayed here.

Value Click the Value field next to each defined attribute to display a
list of available values for that attribute. See "Attributes" in the
TIBCO Business Studio Concepts Guide for more information
about attributes.

Description Description Area in which you can enter text to describe the Resource or
any supporting explanations.

Resource Property
Value

Displays the Label and Name of the Resource. You can edit
the values from this tab by clicking on the Value field.

Organization Query Properties

Tab Property Description

General Label The displayed name of the Query. You can re-name the Query
here by entering a new name

Name The internal name. This defaults to the same value as the
Label, but with any internal spaces removed.

Script defined as Whether the query is entered in free text or in Resource Query
Language (RQL). Defaults to Unspecified when a query is
created.

Resource Property
Value

Displays all the properties of the Query. You can edit the
values from this tab by clicking on the Value field.

Properties View for the Organization Schema
A number of Properties are available for the elements in an Organization Schema: Organization Type,
Organization Unit Type, Position Type, Location Type, Organization Unit Relationship Type, Resource
Type.

Organization Type Properties

Tab Property Description

General Label The displayed name of the Organization Type. You can
re-name the Organization Type here by entering a new
name.
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Tab Property Description

Name The internal name. This defaults to the same value as the
Label, but with any internal spaces removed.

Resource Property
Value

Displays the Label and Name of the Organization Type.
You can edit the values from this tab by clicking on the
Value field.

Organization Unit Type

Tab Property Description

General Label The displayed name of the Organization Unit Type. You
can re-name the Organization Unit Type here by entering
a new name.

Name The internal name. This defaults to the same value as the
Label, but with any internal spaces removed.

Resource Property
Value

Displays the Label and Name of the Organization Unit
Type. You can edit the values from this tab by clicking on
the Value field.

Position Type Properties

Tab Property Description

General Label The displayed name of the Position Type. You can re-name the
Position Type here by entering a new name.

Name The internal name. This defaults to the same value as the
Label, but with any internal spaces removed.

Resource Property
Value

Displays the Label and Name of the Position Type. You can
edit the values from this tab by clicking on the Value field.

Location Type Properties

Tab Property Description

General Label The displayed name of the Location Type. You can re-name
the Location Type here by entering a new name.

Name The internal name. This defaults to the same value as the
Label, but with any internal spaces removed.

Resource Property
Value

Displays the Label and Name of the Location Type. You can
edit the values from this tab by clicking on the Value field.
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Organization Unit Relationship Type Properties

Tab Property Description

General Label The displayed name of the Organization Unit Relationship
Type. You can re-name the Organization Unit Relationship
Type here by entering a new name.

Name The internal name. This defaults to the same value as the
Label, but with any internal spaces removed.

Resource Property
Value

Displays the Label and Name of the Organization Unit
Relationship Type. You can edit the values from this tab by
clicking on the Value field.

Resource Type Properties

Tab Property Description

General Label The displayed name of the Resource Type. You can re-name
the Resource Type here by entering a new name.

Name The internal name. This defaults to the same value as the
Label, but with any internal spaces removed.

Attributes Label The name of any attributes that you want to define for this
Resource Type. See "Attributes" in the TIBCO Business Studio
Concepts Guide for more information about attributes.

This tab lists all attributes that are associated with this
Resource Type and also all that are associated with its parent,
its parent’s parent, and any other Resource Types in the chain
of inheritance.

Click  to add an attribute. You can delete an attribute by

selecting it and clicking  .

Type One Resource Type in the schema must be defined as the
Human Resource Type, for compatibility purposes once the
Organization is exported. It cannot be deleted from the
Schema.

This text is displayed on the General tab of the Human
Resource Type. The Type is therefore still identifiable as the
Human Resource Type even if you change its label and name.

Resource Property
Value

Displays all the properties of the Resource. You can edit the
values from this tab by clicking on the Value field.
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Human Durable and Consumable Resource Types

One Resource Type must always be the Human Resource, whether or not you have used the default
Schema. If your Schema retains the default Schema, then in addition one resource type must have the
Durable Resource property, and one the Consumable Resource property. If you select Resource Types in
the Project Explorer, the General tab in the Properties View displays a matrix showing which type has
which property.

The Resource Type with one of these properties does not have to have the corresponding name. In this
example some of the Types have been renamed:

You can change the assignment of these attributes by checking boxes in this matrix - for example, you could
check Durable Resource in the Construction machinery line. If you do this, the corresponding box in the
Building line would automatically be unchecked: there must be one, and only one Resource Type with each
attribute.
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Tips and Tricks

This section contains tips for working with the TIBCO Business Studio user interface.

Process Editor
There are a number of tips for using the Process Editor.

I can’t see the palette. Make sure you are in the Process Editor and that the palette is
expanded (click the arrow to the right, top of the scroll bar).

I have a large diagram that is
difficult to view. How can I find a
specific task?

Press Ctrl+F and enter the name or a partial name in the resulting
dialog. A list of search results is displayed. Clicking one of the
results displays it in the Process Editor.

How can I create several objects of
the same type using the palette?

Press the Ctrl key while adding the objects to your Process. For
example, if you want to create several Sequence Flows, press and
hold the Ctrl key while clicking the Flow tool and adding the
Sequence Flows.

How do I align objects in the
Process Editor?

There are two features that allow you to better align objects in the
Process Editor - Grid and Alignment Guides. These are both
available from the Diagram menu when using the Process Editor.
Grid allows you to snap objects to the grid lines, and Alignment
Guides shows a centering line when you have aligned two
objects.

With several objects selected in the Process Editor you can also
select options from the Diagram > Alignmentmenu to control the
vertical and horizontal alignment of the objects.

I’m using Grid alignment in the
Process Editor and I want to place
an object without using the Grid.

Pressing the Alt key while moving an object allows you to
position it between grid lines.

I want to see a larger view of my
Process.

You can expand the Process Editor to fill your screen by double-
clicking its title bar or pressing Crtl+M. You can temporarily
display the Properties view by double-clicking any diagram
element. The Properties view will be hidden again when you click
on the diagram.

How can I easily resize an Activity
in the Process Editor?

Pressing the Ctrl key while resizing one side of an object
automatically resizes the opposite side as well.

I can’t get my Sequence Flows to
look right.

Occasionally when you reposition a Sequence Flow several times
you create too many bendpoints and make the flow illegible. To
restore a Sequence Flow, click the flow and select Reset
Bendpoints.

How can I create bendpoints when I
draw a Sequence Flow?

Whilst holding down the left mouse button and positioning the
Sequence Flow, right-click to add a bendpoint.

I can’t get a Sequence Flow to dock
where I want it to dock.

Sequence Flows are docked at the nearest docking point rather
than where you attempt to dock them. Try repositioning the
middle of the Sequence Flow to change the docking point.

286

TIBCO Business Studio™ Modeling Guide



How can I position Sequence Flows
using the keyboard?

Highlight the Sequence Flow, the press the Period key (.) to move
along the bendpoints. With a bendpoint highlighted, use the
arrow keys to position them and change the shape of the flow.
When you are done, press the Return key.

How can I email someone a Process
I am working on?

Send them the XPDL Package file that contains the Process.
Locate the Package file name in the Project Explorer. The Package
file is stored in your workspace (by default this is C:\Documents
and Settings\ username

\workspace).

A task label is truncated in the
Process Editor - how can I show the
whole label?

Set the zoom level to width or height and all letters become
visible in the Process Editor

Alternatively, you can add a period (.) to the end of the label.

Business Object Model Editor
There are a number of tips relating to the Business Object Model Editor:

How can I quickly create a
connection between two Classes?

Make sure you are in the Business Object Modeler and that the
Palette is expanded (click the arrow to the right, top of the scroll
bar). If you click a Class, the following symbols are displayed on
its border:

You can drag either of these to another Class. The following menu
is displayed from which you can choose the type of connection
you want to create:

How can I quickly add Attributes to
a Class?

Click the Class. The following symbol is displayed:

● Clicking  adds an Attribute to the selected Class.

● Clicking  adds an Operation to the selected Class.

Workbench
There are a number of tips relating to the Eclipse Workbench:

How can I quickly change
Perspectives?

There are buttons in the upper right of the screen so you can
change between perspectives. You can also do this using Ctrl+F8.

My windows are a mess. How can I
reset them?

Select Window > Reset Perspective. This restores the current
Perspective to its default.
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How can I switch to a different
workspace?

Select File > Switch Workspace and browse for the location of the
workspace. Note that after you select a workspace and click OK,
TIBCO Business Studio must restart before you can access the
new workspace.

After starting TIBCO Business
Studio, I get the following error
message:
Unable to read workbench 
state. workbench UI layout 
will be reset

This error occurs because a UI element (for example, editor, view,
or perspective) that was displayed at the close of the last TIBCO
Business Studio session is no longer available. This error usually
indicates a change in the installation environment (a product has
been removed or upgraded), and can safely be ignored.

How can I navigate to other views
while in full screen mode?

When a view or editor is expanded to fill the window, Eclipse
provides several buttons around the border of the screen that
allow you to display other views in addition to the expanded
view of the Process. For example, the following buttons are
displayed around the border of the screen:

Problems View
There are a number of tips relating to the Problems view:

How can I correct validation errors? Either:

● Right-click the problem and select Quick Fix (if enabled for
the current problem). This gives you the option of having
TIBCO Business Studio automatically correct the problem for
you.

- or -

● If no quick fix is available, Double-click the problem or right-
click the problem and select Go To. This displays the Process
in the Process Editor, highlighting the offending object and
allowing you to manually correct the problem.

In the Problems view I see not only
problems for my Process/Project,
but problems for all Processes/
Projects.

From the menu in the upper right of the Problems view, select
Configure Contents. This allows you to customize the problems
display. For example, you can select options to display problems
for the selected resource only, or for any resource in the same
Project.
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TIBCO Documentation and Support Services

How to Access TIBCO Documentation

Documentation for TIBCO products is available on the TIBCO Product Documentation website, mainly in
HTML and PDF formats.
The website is updated frequently and is more current than any other documentation included with the
product.

Product-Specific Documentation

The following documentation for TIBCO Business Studio is available on the TIBCO Business Studio
Product Documentation page:

● TIBCO Business Studio™ Release Notes

● TIBCO Business Studio™ Concepts

● TIBCO Business Studio™ Modeling User's Guide

● TIBCO Business Studio™ - Analyst Edition User's Guide

● TIBCO Business Studio™ - BPM Implementation

● TIBCO Business Studio™ Forms User's Guide

● TIBCO Business Studio™ Simulation User's Guide

● TIBCO Business Studio™ Customization

● TIBCO Business Studio™ - Analyst Edition Installation

● TIBCO Business Studio™ - BPM Edition Installation

● TIBCO Business Studio™ iProcess to BPM Conversion

How to Contact TIBCO Support

Get an overview of TIBCO Support. You can contact TIBCO Support in the following ways:

● For accessing the Support Knowledge Base and getting personalized content about products you are
interested in, visit the TIBCO Support website.

● For creating a Support case, you must have a valid maintenance or support contract with TIBCO. You
also need a user name and password to log in to TIBCO Support website. If you do not have a user
name, you can request one by clicking Register on the website.

How to Join TIBCO Community

TIBCO Community is the official channel for TIBCO customers, partners, and employee subject matter
experts to share and access their collective experience. TIBCO Community offers access to Q&A forums,
product wikis, and best practices. It also offers access to extensions, adapters, solution accelerators, and
tools that extend and enable customers to gain full value from TIBCO products. In addition, users can
submit and vote on feature requests from within the TIBCO Ideas Portal. For a free registration, go to 
TIBCO Community.
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Legal and Third-Party Notices

SOME TIBCO SOFTWARE EMBEDS OR BUNDLES OTHER TIBCO SOFTWARE. USE OF SUCH
EMBEDDED OR BUNDLED TIBCO SOFTWARE IS SOLELY TO ENABLE THE FUNCTIONALITY (OR
PROVIDE LIMITED ADD-ON FUNCTIONALITY) OF THE LICENSED TIBCO SOFTWARE. THE
EMBEDDED OR BUNDLED SOFTWARE IS NOT LICENSED TO BE USED OR ACCESSED BY ANY
OTHER TIBCO SOFTWARE OR FOR ANY OTHER PURPOSE.

USE OF TIBCO SOFTWARE AND THIS DOCUMENT IS SUBJECT TO THE TERMS AND CONDITIONS
OF A LICENSE AGREEMENT FOUND IN EITHER A SEPARATELY EXECUTED SOFTWARE LICENSE
AGREEMENT, OR, IF THERE IS NO SUCH SEPARATE AGREEMENT, THE CLICKWRAP END USER
LICENSE AGREEMENT WHICH IS DISPLAYED DURING DOWNLOAD OR INSTALLATION OF THE
SOFTWARE (AND WHICH IS DUPLICATED IN THE LICENSE FILE) OR IF THERE IS NO SUCH
SOFTWARE LICENSE AGREEMENT OR CLICKWRAP END USER LICENSE AGREEMENT, THE
LICENSE(S) LOCATED IN THE “LICENSE” FILE(S) OF THE SOFTWARE. USE OF THIS DOCUMENT IS
SUBJECT TO THOSE TERMS AND CONDITIONS, AND YOUR USE HEREOF SHALL CONSTITUTE
ACCEPTANCE OF AND AN AGREEMENT TO BE BOUND BY THE SAME.

This document is subject to U.S. and international copyright laws and treaties. No part of this document
may be reproduced in any form without the written authorization of TIBCO Software Inc.

TIBCO, the TIBCO logo, the TIBCO O logo, Enterprise Message Service, Business Studio, and ActiveMatrix
are either registered trademarks or trademarks of TIBCO Software Inc. in the United States and/or other
countries.

Java and all Java based trademarks and logos are trademarks or registered trademarks of Oracle and/or its
affiliates.

All other product and company names and marks mentioned in this document are the property of their
respective owners and are mentioned for identification purposes only.

This software may be available on multiple operating systems. However, not all operating system platforms
for a specific software version are released at the same time. See the readme.txt file for the availability of
this software version on a specific operating system platform.

THIS DOCUMENT IS PROVIDED “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR
IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

THIS DOCUMENT COULD INCLUDE TECHNICAL INACCURACIES OR TYPOGRAPHICAL ERRORS.
CHANGES ARE PERIODICALLY ADDED TO THE INFORMATION HEREIN; THESE CHANGES WILL
BE INCORPORATED IN NEW EDITIONS OF THIS DOCUMENT. TIBCO SOFTWARE INC. MAY MAKE
IMPROVEMENTS AND/OR CHANGES IN THE PRODUCT(S) AND/OR THE PROGRAM(S) DESCRIBED
IN THIS DOCUMENT AT ANY TIME.

THE CONTENTS OF THIS DOCUMENT MAY BE MODIFIED AND/OR QUALIFIED, DIRECTLY OR
INDIRECTLY, BY OTHER DOCUMENTATION WHICH ACCOMPANIES THIS SOFTWARE, INCLUDING
BUT NOT LIMITED TO ANY RELEASE NOTES AND "READ ME" FILES.

This and other products of TIBCO Software Inc. may be covered by registered patents. Please refer to
TIBCO's Virtual Patent Marking document (https://www.tibco.com/patents) for details.

Copyright © 2004-2022. TIBCO Software Inc. All Rights Reserved.
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