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Getting Started with Simulation

The TIBCO Business Studio simulation features allow you to simulate a Process that has been developed in
TIBCO Business Studio to identify areas of the Process that can be improved such as bottlenecks and areas
of high cost or reduced service levels.

For example, if Service Level Agreements (SLAs) are not being consistently met, you can re-engineer your
processes to correct this, thus improving customer satisfaction and increasing customer retention.
Simulation can also perform a vital role in implementing the Six Sigma methodology for continuous
improvement of processes.

Overview of Simulation
The diagram in this topic summarizes the TIBCO Business Studio approach to simulation.

See Simulating Business Processes.
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Concepts and Definitions

This section defines concepts and terminology related to the TIBCO Business Studio simulation feature.

Activity-Based Costing
Activity-based costing refers to the practice of building up total 'transaction costs' or 'process costs' from the
costs of the individual Activity that make up the Process. This can be useful in Business Process
Outsourcing situations where a supplier may be paid and have SLAs evaluated on a per transaction basis.

The way this is expressed in TIBCO Business Studio is by assigning a Participant to an Activity. You then
assign the Participant a unit cost, and the Activity a duration. TIBCO Business Studio calculates the Activity
cost (the Activity duration multiplied by the Participant unit cost) and displays this on the Simulation tab
of the Properties view of the Activity.

You can generate different reports from the simulation that include activity-based costing data, including
participant cost, activity cost and end-to-end process cost (see Creating and Viewing a Simulation Report).

Destination Environment
The intended environment in which you want the process to run (for example, BPM or Simulation). You can
select this on the Destinations tab of the Properties view of a Process. The setting selected affects the
validation performed on the Process and consequently the errors or warnings that are displayed in the
Problems view.

Because of the requirements of different destination environments, a Process that is valid for one
destination is not necessarily valid for another.

Scenario
A scenario in TIBCO Business Studio consists of the complete set of data used by TIBCO Business Studio to
simulate a Process (for example, the number of Participants, weightings on transitions and so on), the
Process amd Simulation results.

You can make several copies of the Package that contains the Process. This allows you to change the
simulation data or the Process itself and compare the simulation results.

Service Level Agreement (SLA)
This refers to a contract between a provider of a service and a user of that service that specifies the level of
service required during the term of their agreement. Often it also stipulates penalties incurred for not
meeting the agreed upon levels of service.

Simulation
Simulation is an abstraction of reality made possible by making assumptions about the real Process.
Simulation can then be run to identify areas of the Process that can be improved such as bottlenecks and
areas of high cost or delay.

Simulation is by nature an empirical science harnessing the business knowledge and user experience to
correctly identify significant factors in the real process.

Simulation Time
Simulation time represents the passage of time during a simulation and accrues based on the durations of
the Activities in the Process.

You can specify the Date/Time that you want the simulation to begin as well as the speed at which
simulation time passes on Simulation Control View.
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Simulation time is equivalent to a 37.5 hour work week and excludes weekends. This relates to Participant
utilization in that a Participant that is working a full week is considered to be utilized at 100%.
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Tasks

This section describes some of the common tasks that you perform using the TIBCO Business Studio
simulation feature.

Simulating Business Processes
TIBCO Business Studio has simulation capabilities that make it possible to test and refine business
processes before implementation. Simulation is an abstraction of reality made possible by making
assumptions about the real Process.

All Activities in your Process must be assigned a duration for simulation purposes and the Participants
who perform the Activities assigned unit costs. As a result, metrics such as the cost of an Activity (the
Activity duration multiplied by the Participant unit cost) can be calculated.

There is no concept of sub-processes in simulation. If you want to simulate a sub-process, you can either
assign it a duration and build this into the entire duration for the process, or you can separate it out as a
process, and simulate it individually.

Simulation can then be run to identify areas of the Process that can be improved such as bottlenecks and
areas of high cost or delay.

Define the As Is Process
The first step in simulation is to create a model of the current business process using the TIBCO Business
Studio modeling features. The model represents a business view of the process as it exists. In some cases
processes might be informal. TIBCO Business Studio allows you to take a holistic view of these disparate
processes.

When creating the TIBCO Business Studio Process, each time a different person, group, role, or system does
something, an Activity is added to the Process.

Activities may be triggered by events such as the receipt of an email, phone call or workflow item, and may
involve making a judgement on the presented facts and performing an action (such as entering data to a
computer system, phoning someone in the same or different organization, and so on).

Prepare the Simulation
To prepare a Process for simulation, you must do a number of steps. If you have historical data from an
actual business process, you can use this as input to the simulation.

For more information see Using Historical Data for Activity Duration.

Assign Activity Duration

As part of simulating the execution of a Process, specify the duration of each Activity in the Process. For
example, the duration of support telephone calls might be normally distributed with an average of five ±
two minutes.

Procedure

1. In the Process Editor, select the Activity.

2. In the Properties view, click the Simulation tab.

3. Choose a Duration Distribution, typically one of the following:

● Constant - choose this distribution for Activities that never vary in duration. For example, a
questionnaire might be designed such that it always takes 10 minutes to complete (or rather the
variation is so small that it can be considered constant).
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● Normal - choose this distribution for Activities which follow a bell curve (you specify the Mean
and Standard Deviation). For example, phone calls in a call center might follow a standard
distribution (68% of all phone calls are 4-6 minutes in duration).

●

4. Choose a Time Unit:

● Month

● Day

● Hour

● Minute

● Second

5. Enter the Value for the duration.

Add the Participants and Associate them with Activities

All Activities in a Process must have a Participant for simulation purposes. The Participant identifies who
or what performs an Activity. For example, 20 call center staff answering enquiries, giving quotes and
taking applications and 10 claim handlers processing claims.

In addition to the Participants involved in an Activity, there are broadly two types of resource associated
with an Activity:

● blocking resources - a resource that delays the Process when not available (for example, a person needed
to do a job)

● non-blocking resources - a resource that doesn’t delay the Process, but contribute to costs (for example,
the cost of the phone system)

Currently in TIBCO Business Studio you cannot associate non-blocking resources (such as computer time)
with an Activity.

To add Participants and associate them with Activities, see the TIBCO Business Studio Modeling User’s Guide.

Assign Unit Costs to Participants

To simulate the cost of an Activity, you must define the cost of the Participants. This could include costs
such as salaries, telephone costs for call centers or travel costs for sales people.

Procedure

1. In the Project Explorer, select the Participant.

2. In the Properties view, click the Simulation tab.

3. Enter the Number Of People/Machines for the Participant. For example, if the Participant is a field
engineer and two are required, enter 2 here.
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4. Enter the Cost Per Unit and the Unit. For example, 30 per Hour.

Add the Data Fields and Associate them with Activities (optional)

Create the Data Fields used in the Process and associate them with the Activities.

For more information, see the TIBCO Business Studio Modeling User’s Guide.

Set the Number of Simulation Cases

The default number of cases for simulation is 100. You can change this number.

Procedure

1. In the Process Editor, highlight the Start event.

2. In the Properties view, click the Simulation tab.

3. Specify the Number of Cases you want to run during simulation. Avoid specifying extremely large
numbers as this can make simulation time-consuming.

Result

You must also specify a distribution for the interval of case starts, typically one of the following:

● Constant - choose this distribution for case starts that never vary such as the closing of accounts (which
happens for example, at the end of every month, quarter and year).

● Uniform - choose this distribution for cases that have an equal probability of starting over a given range
(for which you can specify a maximum or minimum value). For example, if an audit by a government
regulator has an equal chance of happening on any day of the year, select a uniform distribution with 0
and 365 as minimum and maximum values:

●

● Exponential - use this distribution of for examples such as the following:

We had 100,000 claims last year. There are 525,948 minutes in a year, so we received a claim every 5.26
minutes. The interval between claims arrivals is expressed by a negative exponential distribution:

9
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Set Up Looping Strategies

If there are any loops in your Process (where a Sequence Flow returns to a previous Activity in the Process),
you must determine a strategy that allows TIBCO Business Studio to break out of the loop during
simulation.

See Simulating Loops in Processes.

Run the Simulation of the As Is Process

Procedure

1. Ensure that Simulation is selected as the Destination Environment:
a) Select the Process in the Project Explorer.
b) Go to the Properties view and click the Destinations tab.
c) Select Simulation as the Destination Environment.

2. Save the Package that contains the Process.

When you save the Package, validation is performed on the Process to ensure that it can be simulated.
Any problems are shown in the Problems view.

To correct a problem do one of the following:

● Right-click the problem and select Quick Fix (if enabled for the current problem). This gives you
the option of having TIBCO Business Studio automatically correct the problem for you.

● Right-click the problem and select Show in Process Editor. This displays the Process in the Process
Editor, allowing you to manually correct the problem.

3. Optional - Set the Simulation Date/Time. By default, this is the current system date/time, but you can set
the desired simulation time using the drop-down calendar and by entering a time value.

4. Right-click the Process and select Run As > Run Simulation . If prompted, click Yes to switch to the
Simulation Perspective.

In the Simulation Control view, click  to start the simulation.
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5. The Simulation Control view shows the simulation progress and the Simulation Results view displays
updated simulation data about the cost of the Activities, and so on. The default number of cases for
simulation is 100, however this can be configured (see Set the Number of Simulation Cases).

View the Simulation Progress

While a simulation is running, you can view information about its progress:

● The Simulation Control view shows a running total of the number of minutes in Simulation Time. If the
simulation is running too slowly or quickly, you can adjust the Simulation Speed in this view.

● The Simulation Results view continuously updates as the simulation runs, displaying simulation data
about the Cases, Participants and Activities.

● The Process displays a visual indication of the number of Observed Cases, Current Queue Size,
Activity Delay and Participant Utilization % as the simulation progresses:

The indication of case totals becomes red if the number of cases passing through an Activity
exceed the total number of cases (for example because of looping).

Interpret the Results of Simulation
After running a simulation, the Simulation Results view shows information about cases, partiipants and
activities.

● Cases - a summary of the simulation, including the number of cases started and finished as well as case
times (average, minimum and maximum).

● Participants - information about Participants. For example:

●

● Activities - information about the cost of Activities, distribution into queues, wait times, and so on.

For more information, see Simulation Results View.

You can also view this information by exporting the simulation data to an HTML report. See Creating and
Viewing a Simulation Report.

At this stage, the goal is to ensure that the "as is" process has sufficient detail to adequately reflect reality.
One way of checking this is to compare the results of the simulation to any real data that is available. For
example, a call center might have data about average call times, or the time it takes to resolve a problem.

After you have re-worked the model, re-run the simulation as needed.

Optimize or Re-Engineer the Process
After simulating the "as is" Process, you must decide whether minor changes to the original Process can
achieve the desired results, or if the Process must be re-engineered.

Optimizing the Process

If minor changes are all that is need to the original Process, you can work on that directly.

Identify bottlenecks/areas for improvement in the Process. For example, long queues or extreme idle times
for Participants might be cause for concern.
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Create a "To Be" Process

If you decide to re-engineer your process, the "to be" Process represents an alternative to the current
process. One approach is to create several "to be" Processes, simulate them and choose the best one. You can
either create a new Process or modify a copy of the "as is" Process and prepare it for simulation as described
in Prepare the Simulation.

By changing properties in the Process such as the number of Participants or by changing the Process itself,
you can re-run the simulation and see the effect of your changes.

Simulate the "To Be" or Optimized Process

Run the simulation in the same way as you simulated the "as is" Process. The goal of this is to get results
that you can compare to the results of the "as is" Process.

Examine the Results of Simulation

Compare the "as is" Process to the "to be" or optimized Process. One of the ways you can do this is by using
the Simulation Report view (see Comparing Simulations).

When comparing Processes you should keep in mind what has changed between the Processes. For
example, if you are comparing two Processes that are identical except for the number of Participants
assigned to an Activity, it is easy to explain the different simulation results. However when comparing two
radically different Processes it can be difficult to identify what accounts for varying simulation results.

Identify any areas where the Process could be improved, re-work the Process and re-run the simulation as
needed.

Build a Business Case for a Process

As a result of simulations in TIBCO Business Studio, you should be able to either optimize or re-engineer a
Process to demonstrate substantial cost-savings. However, there is usually a cost associated changing
existing Processes. This cost must be balanced against the case for change.

For example, suppose that simulations of the "as is" Processes of a support center show that the problem
reporting area of the support web site is under utilized. Furthermore, simulations of "to be" Processes show
substantial savings could be made by handling 50 percent more support enquiries via the web site.

However, there are costs associated with realizing the promised savings. Customers must be encouraged to
use the web site to report problems if any savings are to be made, so an investment must be made in raising
customer awareness. Support staff would be under utilized in proportion to the increased usage of the web
site, so they must be better utilized, perhaps by taking on outside business from other companies.

Simulating Loops in Processes

When simulating a Process you should avoid infinite loops. If you create a loop without a Simulation
Control, TIBCO Business Studio reports this as an error in the Problems view and you cannot perform
simulation until you correct this..

TIBCO Business Studio supports looping in simulation when the loop is created using a Sequence Flow.
However, a Loop Activity Marker is not supported for simulation.

1. Click the Activity in the loop for which you want to add a simulation control. In the Properties view,
click the Simulation Control tab.

You must add a simulation control to at least one Activity in the loop; otherwise TIBCO
Business Studio generates an error in the Problems view.

2. Click simulation control to add a Simulation control strategy.

3. There are three strategies from which you can select to break out of the loop:

● Max Loop Count - after the specified number of times through it. You must enter the Max Loop
Count (the number of times you want cases to follow the loop).
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● Max Elapse Time - after the specified amount of simulation time has elapsed. You must specify a
Time Unit and Value.

● Normal Distribution - based on a normal distribution of times through it. You must enter a Min
Loop Count and Max Loop Count upon which to base the distribution.

4. For each strategy, you must specify the following:

● Decision Activity - This informs TIBCO Business Studio which Flow Object will be used to decide
whether to end the loop.

● To Activity - This informs TIBCO Business Studio which Activity to proceed with once the loop is
finished.

5. Save the Package containing the Process.

6. Highlight the Process, right-click and select Run As > Run Simulation .

7. You should see that the Process breaks out of any loops using the strategy that you specified.

If you have not created the Simulation control strategy correctly TIBCO Business Studio reports this in the
Problems view and you cannot perform simulation until the problem is corrected.

Using Historical Data for Activity Duration

The following was deferred in V1.1

TIBCO Business Studio allows you to specify the interval of case starts using mathematical distributions.
For example, in a manufacturing environment, a new work piece might arrive on a conveyor belt every five
minutes. When simulating this in TIBCO Business Studio, on the simulation properties of the Process, select
a Distribution of CONSTANT and specify five minutes.

However for more complex simulations, deciding which distribution to use can be difficult. Furthermore
real data often exists that is ideal to use. TIBCO Business Studio allows you to import case start data from
an Excel spreadsheet. In addition to the data about the interval and timing of case starts, you can import
simulation parameters and parameter values.

Using imported data for parameters and parameter values can have unintended effects on Gateways and
weightings later in the Process. For example, suppose a Process has two Gateways: one that uses imported
historical data and one later in the Process that does not. Any weightings assigned to the first Gateway are
ignored and the flow is taken from the actual imported data. The flow at the next gateway is generated
from the weighting set in the simulation parameters (for example, 50:50), but because it is randomly
generated and receiving actual data that is not random, the distribution after simulation may not be 50:50.

Create the Import File

The first step is to obtain the data you want to import. The format of the file that you use for the import is as
follows:

● Excel spreadsheet - The first row of cells corresponds to the parameter names. Each column under the
first row represents the parameter values you wish to import.

Should we specify that the parameter names have underscores as formal parameters can’t have spaces?

Import the Data

To import historical case data, do the following:

Procedure

1. Right-click the Package that contains your Process and select New > Other .

2. Expand BPM and select Historical Case Data.

13

TIBCO Business Studio™ Simulation Guide



3. Select the appropriate file type (Excel or Text File) and click Next.

4. Browse for the file and click Load, then click Next.

The simulation parameters are displayed as columns and each column displays the parameter values.

Select the parameters you want to import and click Finish. This creates a file with the
extension .realdata.

Associate the Imported Data with the Start Event

5. Go to the Properties view of the Start event and click the Simulation tab.

6. Set the Number of Cases.

If you set the number of cases to more than are contained in your imported data, only the
Time simulation parameter is used. If you set the number of cases to equal to or less than the
number of cases in your imported data, both the Time and any other parameters are used.

7. Select EMPIRICAL as the Distribution.

8. Browse to select the .realdata file that was created from your imported simulation data.

9. Right-click the Process and select Prepare Simulation. This automatically generates the names for the
simulation parameters and the values. These can be seen by highlighting the Process and in the
Properties view clicking the Simulation tab.

You must rename the simulation Parameters so they match the imported data you want to use.

Any simulation parameter that does not correspond to a parameter in the imported data
follows the default Sequence Flow from a Gateway.

Run the Simulation

10. Run the simulation as normal. Note that the Start time in the Simulation Control view corresponds to
the first value of the Time simulation that you imported and that the distribution of other parameters is
taken from the imported data.As part of setting up a Process for simulation, you specify the duration of
the Activities in the Process using a mathematical distribution (for example, Normal distribution).
Alternatively, TIBCO Business Studio allows you to import any real historical data (for example, from
log files) that you have about activity duration.

11. Create an Excel spreadsheet with the data that you want to import. The first row of cells corresponds to
the parameter names. Each column under the first row represents the parameter values you wish to
import. For example:

In this example, the parameter Existing Customer? can have the values Yes or No.

Note the following requirements for the spreadsheet that you use for data import:

● The spreadsheet must have columns for Activity Name and Duration (though not
necessarily with those names).

● You can include any number of other columns for import, but be careful to avoid stray data
in columns that you do not plan to import.

● Data from the first worksheet is imported; other worksheets are ignored.
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12. To import the spreadsheet containing your historical data, right-click the Process and select Import.

13. Select Historical Case Data (Activity Duration).

14. The names of the Project, Package and Process are displayed. Click Next.

15. Either click Browse or Browse Workspace to locate the Excel file. Press the Tab key (this activates the
Next button). Click Next.

16. The Select Parameters dialog is displayed.

● Select the parameter that represents the Activity Name.

● Select the parameter that represents the Activity Duration.

● In the Map Activity Names: section, map the Activities in the spreadsheet to those in the Process.

Click Next.

17. The next dialog allows you to map any parameters not already used in the previous dialog onto
Activities in the Process. Click Next.

18. For each Activity, there are three options for where the duration data is taken:

● use the data specified in the process rather than the imported data - do not select the Activity.

● use the imported data to create a normal distribution - select the Activity, but select IGNORED.
● use the imported data, depending on a parameter setting - select the Activity and select the

Parameter that will be used to determine which values to use.

Clicking on each row gives the values, average duration and deviation from the average.

19. Click Finish.

20. The Simulation Properties view for Activities for which the duration is taken from the imported data
show information about the parameter names and values. For example:

Controlling Sequence Flow from a Gateway
You can control flow from a Gateway by creating a Parameter and values to be used as in a Rule. On a
conditional Sequence Flow exiting the Gateway, you can specify that the Sequence Flow is followed only
when values for that Parameter match the expression specified in the Rule.

Procedure

1. To create the parameter, under the Process, right-click Parameters and select New Parameter.

2. Click Next to accept the default Project, Package and Process.

3. Enter the Name of the Parameter and its Type.

4. Click Finish to save the Parameter.
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5. To add values to the parameters, highlight the Process and in the Properties view, click the Simulation
tab.

6. Highlight the Parameter that you created, and click Add Value....

7. A new value with the name "New Value" is added under the Parameter. Double-click the name to
rename the value.

You can also remove values by selecting them and clicking Remove...

If you change an existing Parameter that is associated with a Gateway, you must also specify a
new value for the conditional Sequence Flow (as described in the following task).

8. To associate thw gateway with the parameter, open the Process and click the Rule Parameter tab.

9. Enter the name of the Parameter that you created earlier.

Instead of entering the name of the Parameter, you can use an Eclipse feature called Content
Assist. Hold down the Ctrl key and press the spacebar. This allows you to select from the
available Parameters.

10. To specify a value for the conditional sequence flow, highlight the Conditional Sequence Flow leaving
the Gateway.

11. In the Properties view, click the Rule tab. This allows you to create an expression using your Parameter
and values. For example:

This shows that this Sequence Flow is only traversed when the isPaperworkCorrect Parameter has the
value Wrong receipts. Any cases with other values for this Parameter will follow the default Sequence
Flow.

Monitoring SLAs
TIBCO Business Studio allows you to set Service Level Agreement (SLA) thresholds for Activity Delay and
Participant Utilization. When you simulate the Process, TIBCO Business Studio displays visual cues when
these thresholds are exceeded.

Procedure

1. Open the Process.

2. Click an Activity for which you want to specify a maximum delay. In the Properties view, specify the
Maximum Delay SLA.

3. In the Project Explorer, click a Participant for whom you want to specify a utilization. In the Properties
view for the Participant, enter the Minimum Utilization SLA (%) and the Maximum Utilization SLA
(%).

While it is possible to require that a Participant is 100% utilized, in practice this is rarely the
case because of holidays, ancillary tasks, sickness and so on.

4. Simulate the Process. The SLA information is displayed next to the Activity in the third and fourth
columns. For example:
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The color of the bar is red in the third column because the SLA is not being met. In some cases the
threshold is displayed in red, but the bar is green like this:

This means that the threshold was exceeded, but the overall utilization was within the SLA.

Comparing Simulations
Often you want to compare the results of a simulation with another set of results, for example if you are fine
tuning a Process or if you are making a business case for changing an existing Process. TIBCO Business
Studio provides a Simulation Report view that allows you to do this.

Procedure

1. Select the set of results that you want to compare. Either:

● In the Project Explorer, right-click the Process for which you want to compare results and select
Compare Simulation Results. This opens the Simulation Report view with the results associated
with the Process.

● In the Project Explorer, expand the Simulation folder and its sub-folders and select the
relevant .sim files that were created when you simulated the process (for example,
2006-03-11_15-56-38.sim).

The filename of the simulation results file is automatically generated. It is easier to keep
track of several simulation results files if you rename them to use more meaningful names
by selecting the file and Refactor > Rename.

Select the two sets of results that you want to compare.

2. There are two pre-defined report types that you can use to create your reports:

● Case Cost-Time Analysis - shows charts and tables that display such information as the minimum,
average and maximum case times for each experiment.

● Participant Utilization - shows charts that display idle time for the Participants in the process.

3. Select a report type and click Display Report. For more information about the Reports that are
generated, see Compare Simulation Results View.
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Creating and Viewing a Simulation Report
You can create a report in HTML format that contains the results of a simulation.

The report contains the following:

● Cases - a summary of the simulation

● Participants - information about Participants (for example, idle time)

● Activities - information about the cost of Activities, distribution into queues, wait times, and so on.

From the Simulation Results view, click  in the upper right of the view.

Procedure

1. In the Simulation Report view, you can view the report.

2. The HTML file of the report is also saved to the Simulation folder where the Project is located.

Designing Custom Reports
TIBCO Business Studio allows you to create your own custom reports with the Eclipse Business Intelligence
and Reporting Tools (BIRT). BIRT is an open source, Eclipse-based reporting system that allows you to
produce HTML and PDF reports.

The reports displayed in the Compare Simulation Results View are examples of BIRT reports provided by
TIBCO.

BIRT is provided with TIBCO Business Studio, and you can use it to design and run your report. For more
information refer to the Eclipse BIRT documentation. When you design your report, make sure to use .sim
files as a data source (.sim files are XML files that contain the results of simulation comparison in TIBCO
Business Studio).

This section describes how to create a new BIRT report for use in the Compare Simulation Results editor.
This report is a simple table. To create the report follow these steps:

● Obtaining a Data Source

● Creating a New Report

● Creating the Data Source

● Create the Data Set

● Creating the Report Parameters

● Creating a Table to Display the Data

● Importing the Report

For more information about the different types of reports that you can create, refer to the Eclipse BIRT
documentation.

Obtaining a Data Source
To create a new BIRT report, you will need a sample XML data source file. Even though it has the same file
extension, this is not the same as the .sim result files.

You can obtain a sample data source using either of the following methods:

● In the Compare Simulation Results view, generate a BIRT report with one of the built-in reports. This
generates a data file current workspace\.metadata\.plugins\com.tibco.xpd.simulation.compare
\.temp\results.sim.
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● Alternatively, locate the file Studio\3.7\studio-addins\eclipse\plugins
\com.tibco.xpd.simulation.compare_version.jar. Open it in WinZip and extract the file
sample.sim.

Creating a New Report
After you have obtained a sample data source file, create the report.

Procedure

1. Locate a folder in the Project Explorer to store the new BIRT report.

2. Right-click the folder and select New > Other .

In the New wizard expand Business Intelligence and Reporting Tools, select Report, and click Next.

3. Enter a file name for the report using the .rptdesign file extension, then click Finish to start with a
blank report.

4. The Report editor opens with the new report and you are prompted to change to the Report Design
perspective.

Creating the Data Source
To access data for a BIRT report, you must use a BIRT data source. A BIRT data source is an object that
contains connection parameters.

Before creating a data source or multiple sources for your first reports, consider the issues of project and
resource organization. If you plan to reuse a data source in multiple report projects, you can create that data
source in a library and reuse that data source from the library. The advantage of this approach is that
updates to the BIRT data source in the library are subsequently available to all reports that use the library.

Use the Data Explorer, as described in this section, to create and manage BIRT data sources. BIRT Report
Designer supports using multiple data sources for the report design. The data sources can be of different
types. For example, you can use data from an RDBMS database and data from a flat file repository in the
same report design. In this example, the data is extracted from the sample XML data source file.

Procedure

1. In the Data Explorer view, right-click Data Sources and select New Data Source.

2. Select XML Data Source, enter a name for the data source, and click Next.
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3. Select the sample data source file (obtained in Obtaining a Data Source):
a) Click Browse (to the right of the upper text entry field).
b) In the Open dialog, change the Files of type filter from *.xml to *.*.
c) Select the sample data source file (obtained in Obtaining a Data Source), and click Finish.

4. In the Data Explorer view, double-click the newly created data source in the and select Property
Binding.

In the XML Data Source File field, enter params["sourcexml"] and click OK.

The parameter (params["sourcexml"]) is passed to the report at runtime.
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Create the Data Set
A data set identifies the data to retrieve from the data source.

Procedure

1. In the Data Explorer view, right-click Data Sets and select New Data Set.
2. Enter a name for the data set and click Next.
3. In the Sample XML Settings dialog, click Next to accept the default settings.
4. On the Row Mapping dialog, select Participant, and click the central arrow button to set the XPath

expression. Accept the default XPath expression in the resulting dialog and click OK:

5. The Row Mapping dialog should look like this:

6. Click Next.
7. In the Column Mapping dialog, select the participant Name, AverageIdle, and AverageBusy, accepting

the default column mapping for each. The dialog should look like this:
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8. Click Finish.

The Edit Data Set dialog is displayed, allowing you to further define the data set. Click OK to accept the
default values.

Creating the Report Parameters
Create a parameter to point to the sample XML data source file for the report.

Procedure

1. In the Data Explorer view, right-click Report Parameters and select New Parameter.

2. Give the parameter the name sourcexml then click OK.

Creating a Table to Display the Data
In this task, create a table to display the data from the data set that you created previously. You start by
inserting a table element, then you insert data elements in the table.

Procedure

1. In the Report Design perspective, select Window > Show View > Palette .

2. From the Palette, drag a table element onto the report. Click OK in the following dialog to create a three
column table:
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3. Return to the Data Explorer (select Window > Show View > Data Explorer ).
4. Drag the Name from the Data Explorer to the detail row of the first column of the table:

5. Similarly drag AverageIdle and AverageBusyTime to the detail rows of the second and third columns.
The header rows are filled in automatically and the table looks like this:

Importing the Report

Procedure

1. Select Window > Preferences , and then select Simulation > Report > Management .
2. Click Import.

You can also import a simulation comparison report by selecting the File > Import > Business
Process Management > Simulation Comparison report menu.

3. Give the report a name, use the Browse Workspace button to locate the report file, and click OK.
4. The newly-created report now appears in the Compare Simulation Results view.
5. Select the report, select some simulation results files (.sim files), and click the Display Report button in

the Compare Simulation Results view. For example:

6. The report can be edited, and the new data set is available to use in charts and tables that are added to
the report. The actual results file is substituted in and used for the data set when the report is run. For
more information about changing the report, refer to the BIRT documentation.
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Editing the Report
With the report added to your workspace and available in the Compare Simulation Results view, you can
customize the report to suit your needs.

Procedure

1. Edit the report in the Report Design view.

2. Save the report.

3. Click the Display Report button in the Compare Simulation Results view to see the effect of your
changes on a report generated from real data.

Customizing Simulation Preferences
You can customize the annotation selections, report management, and validation that is performed for
simulation. For validation errors you can specify its severity level as Error, Warning, Info, or Ignore.

Procedure

1. Select Window > Preferences .

2. Select Simulation. The following dialog is displayed:

This allows you to control whether you are prompted to confirm changing the perspective when you
run simulation. If desired, change the setting and click Apply.

3. Expand Simulation and click Annotation Selection. The following dialog is displayed:

This allows you to customize the annotations that are displayed when the Process is being simulated.
For an explanation of these annotations see View the Simulation Progress. If desired, change the settings
and click Apply.

4. Expand Simulation and click Report Management. The following dialog is displayed:

24

TIBCO Business Studio™ Simulation Guide



This dialog allows you to edit, delete or import reports to be used with simulation. For more
information see Designing Custom Reports.

5. Expand Process Editor and select Errors/Warnings. From the drop-down list, select Simulation. The
following dialog is displayed:

6. If you want to change the severity level for a Simulation problem, select from the drop-down list. When
you have finished, click Apply to effect any changes you have made.

7. The following dialog is displayed:

● Click Yes to revalidate your workspace. Depending on the size of the workspace and the number of
errors, there is a delay while the revalidation occurs.

● Click No to revalidate your workspace later. The revalidation will take place when the concept file
next changes or is saved, or when you explicitly request a rebuild of the project or workspace.

● Click Cancel if you do not wish to apply your changes.
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Reference

This section of the help describes the major parts of the TIBCO Business Studio user interface that are
related to simulation.

In Eclipse, a Perspective includes the views and set of editors that you commonly use for a specific type of
work. TIBCO has created several TIBCO Business Studio perspectives that include the views and editors
you commonly use when creating and simulating business processes. This section describes the views
contained in the Simulation Perspective.

Simulation Control View
This view contains a toolbar that allows you to pause, resume or stop a running simulation.

It also shows the following:

● Process name - name of the Process used to run the simulation.

● Simulation speed - a slider for increasing or decreasing the rate at which the simulation executes.

● Simulation progress - a visual representation of the number of simulation cases run against the number
of cases to be run.

● Simulation time - the number of minutes that have elapsed since the start of the simulation.

● Start time - the date/time (in simulated, not real time) that you want the simulation to begin (once the
simulation starts you cannot modify the Start time).

● Current time - the date/time the simulation finishes (Start time + Elapsed time)

Simulation Results View
This view shows simulation data about running and completed simulations. It displays information about
the cost of Activities such as the average cost, minimum and maximum cost and so on:

Cases

Property Meaning

Started Cases The number of cases started. This is configured on the Simulation
properties of the Start event.

Finished Cases The number of cases completed. When the simulation runs to
completion, this should equal the number of cases started.

Average Case Time The average time it takes to complete a case. The time unit is
configured on the Simulation properties of the Start event.

Min. Case Time The fastest that a case was processed.

Max. Case Time The longest a case took to be processed.

Average Cost The average cost of a Case in the Process (based on the Participant
Costs and Activity Durations).

Min. Cost The lowest cost case of the simulation run.

Max. Cost The highest cost case of the simulation run.
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Property Meaning

Cumulative Cost The total cost of all the cases in the simulation run.

Participants

Property Meaning

Name Name of the Participant.

Count Number of Participants (specified on the Simulation properties of the
Participant).

Current Idle Count Number of Idle Participants (for example, if you pause the simulation
before it finishes).

Average Idle Count Average number of idle Participants.

Average Idle Time Average amount of time the Participant spent not handling a case.

Activities

Property Meaning

Name Name of the Activity.

Processed Cases Number of cases processed by this Activity.

Current Queue Size Number of cases currently queued for this Activity.

Max Queue Size The maximum number of cases that were queued for this Activity.

Average Queue Size The average number of cases that were queued for this Activity.

Average Wait The average time a case spends queued.

Average Cost The average cost of an Activity (calculated using the cost of the
Participant and the time spent on the Activity).

Min Cost The lowest Activity cost.

Max Cost The highest Activity cost.

Cumulative Cost The total cost of the Activity to that point in the simulation (calculated
by multiplying the average cost times the number of cases).

Simulation Report View

This view displays an HTML report of a simulation run. To view a report, you must first create one (see 
Creating and Viewing a Simulation Report).
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Simulation Properties View
When you display a Process in TIBCO Business Studio and click in the white area of the Lane, the
Properties view for the Process itself is displayed. Click the Simulation tab, and you can view information
about the simulation data for the Process.

For example:

This shows that the gateway g1 has two output Sequence Flows (Id 3 and Id 4) and that one will pass 67.1%
of the cases and the other 32.9%. The percentages are calculated automatically based on the weighting that
you enter.

The weighting can either be:

● a number related to the total number of cases you want to simulate. For example of a total of 100 cases
the weighting could be specified as 67:33.

● based upon a known weighting regardless of the total number of cases, as illustrated in the previous
example, where the weighting is 200:98.

In either case, the weighting is simply converted to a percentage of the total weighting and used by the
simulation engine.

The simulation parameters in the Simulation Properties view do not necessarily correspond exactly to the
Process itself. For example, if you delete a Gateway or a Sequence Flow from your Process, the simulation
parameters for these objects are retained in the Simulation Properties view. This is because you may still
want to manipulate these parameters for the purposes of simulation.

You can delete simulation parameters that are no longer relevant to your Process by right-clicking them and
selecting Delete. If you mistakenly delete a parameter that is still needed for simulation, TIBCO Business
Studio re-creates this parameter when you re-run the simulation, however the parameter is re-created with
the default weighting (any weighting changes you have made are lost).

Compare Simulation Results View
This view allows you to create comparisons based on one or more sets of simulation results.

For example:
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The following sections discuss the comparison tools.

Case Cost-Time Analysis
This comparison tool shows information about the time it takes for a case to complete (the cycle time) and
also about the cost of cases.

Name Description

Case Cycle Time Comparison This is a bar chart that shows the minimum, average and maximum
case cycle times. This is useful if you are modifying a Process with the
goal of reducing one of these measures (for example, a call center that
wants to reduce the average time each call takes).

Case Time Comparison to
Process

This table shows the average case time for each simulation and
displays the percent change against the first Process that you selected.

Case Cost Comparison This bar chart shows the minimum, average and maximum cost for
cases. This case cost is calculated based upon the activities performed,
their duration and the cost of the Participant performing the activities.
This chart can be useful if you are trying to achieve a reduction in case
costs, for example by reducing the Activity duration or the cost of
Participants.

Case Cost Comparison to
Process

This table shows the average case costs for each simulation and the
percent change against the first Process that you selected.

Average Cost/Time
Comparison

This graph compares the average cost and time of each simulation.
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Participant Utilization
This comparison tool shows how much time is spent idle by all the Participants in a simulation and by each
Participant.

Name Description

Resource Idle Time Report This chart shows how much time is spent idle by Participants in each
simulation.

Participant Idle Times by
Experiment

This section displays a pie chart showing idle time for each Participant.

Simulation Data
Simulation Data is added to a Process using the Simulation tab on the Activity Properties view, the Start
Event Properties view and the Participant Properties view.

See Assign Activity Duration.

See Assign Unit Costs to Participants.

See Set the Number of Simulation Cases.
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TIBCO Documentation and Support Services

How to Access TIBCO Documentation

Documentation for TIBCO products is available on the TIBCO Product Documentation website, mainly in
HTML and PDF formats.
The website is updated frequently and is more current than any other documentation included with the
product.

Product-Specific Documentation

The following documentation for TIBCO Business Studio is available on the TIBCO Business Studio
Product Documentation page:

● TIBCO Business Studio™ Release Notes

● TIBCO Business Studio™ Concepts

● TIBCO Business Studio™ Modeling User's Guide

● TIBCO Business Studio™ - Analyst Edition User's Guide

● TIBCO Business Studio™ - BPM Implementation

● TIBCO Business Studio™ Forms User's Guide

● TIBCO Business Studio™ Simulation User's Guide

● TIBCO Business Studio™ Customization

● TIBCO Business Studio™ - Analyst Edition Installation

● TIBCO Business Studio™ - BPM Edition Installation

● TIBCO Business Studio™ iProcess to BPM Conversion

How to Contact TIBCO Support

Get an overview of TIBCO Support. You can contact TIBCO Support in the following ways:

● For accessing the Support Knowledge Base and getting personalized content about products you are
interested in, visit the TIBCO Support website.

● For creating a Support case, you must have a valid maintenance or support contract with TIBCO. You
also need a user name and password to log in to TIBCO Support website. If you do not have a user
name, you can request one by clicking Register on the website.

How to Join TIBCO Community

TIBCO Community is the official channel for TIBCO customers, partners, and employee subject matter
experts to share and access their collective experience. TIBCO Community offers access to Q&A forums,
product wikis, and best practices. It also offers access to extensions, adapters, solution accelerators, and
tools that extend and enable customers to gain full value from TIBCO products. In addition, users can
submit and vote on feature requests from within the TIBCO Ideas Portal. For a free registration, go to 
TIBCO Community.
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Legal and Third-Party Notices

SOME TIBCO SOFTWARE EMBEDS OR BUNDLES OTHER TIBCO SOFTWARE. USE OF SUCH
EMBEDDED OR BUNDLED TIBCO SOFTWARE IS SOLELY TO ENABLE THE FUNCTIONALITY (OR
PROVIDE LIMITED ADD-ON FUNCTIONALITY) OF THE LICENSED TIBCO SOFTWARE. THE
EMBEDDED OR BUNDLED SOFTWARE IS NOT LICENSED TO BE USED OR ACCESSED BY ANY
OTHER TIBCO SOFTWARE OR FOR ANY OTHER PURPOSE.

USE OF TIBCO SOFTWARE AND THIS DOCUMENT IS SUBJECT TO THE TERMS AND CONDITIONS
OF A LICENSE AGREEMENT FOUND IN EITHER A SEPARATELY EXECUTED SOFTWARE LICENSE
AGREEMENT, OR, IF THERE IS NO SUCH SEPARATE AGREEMENT, THE CLICKWRAP END USER
LICENSE AGREEMENT WHICH IS DISPLAYED DURING DOWNLOAD OR INSTALLATION OF THE
SOFTWARE (AND WHICH IS DUPLICATED IN THE LICENSE FILE) OR IF THERE IS NO SUCH
SOFTWARE LICENSE AGREEMENT OR CLICKWRAP END USER LICENSE AGREEMENT, THE
LICENSE(S) LOCATED IN THE “LICENSE” FILE(S) OF THE SOFTWARE. USE OF THIS DOCUMENT IS
SUBJECT TO THOSE TERMS AND CONDITIONS, AND YOUR USE HEREOF SHALL CONSTITUTE
ACCEPTANCE OF AND AN AGREEMENT TO BE BOUND BY THE SAME.

This document is subject to U.S. and international copyright laws and treaties. No part of this document
may be reproduced in any form without the written authorization of TIBCO Software Inc.

TIBCO, the TIBCO logo, the TIBCO O logo, Enterprise Message Service, Business Studio, and ActiveMatrix
are either registered trademarks or trademarks of TIBCO Software Inc. in the United States and/or other
countries.

Java and all Java based trademarks and logos are trademarks or registered trademarks of Oracle and/or its
affiliates.

All other product and company names and marks mentioned in this document are the property of their
respective owners and are mentioned for identification purposes only.

This software may be available on multiple operating systems. However, not all operating system platforms
for a specific software version are released at the same time. See the readme.txt file for the availability of
this software version on a specific operating system platform.

THIS DOCUMENT IS PROVIDED “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR
IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

THIS DOCUMENT COULD INCLUDE TECHNICAL INACCURACIES OR TYPOGRAPHICAL ERRORS.
CHANGES ARE PERIODICALLY ADDED TO THE INFORMATION HEREIN; THESE CHANGES WILL
BE INCORPORATED IN NEW EDITIONS OF THIS DOCUMENT. TIBCO SOFTWARE INC. MAY MAKE
IMPROVEMENTS AND/OR CHANGES IN THE PRODUCT(S) AND/OR THE PROGRAM(S) DESCRIBED
IN THIS DOCUMENT AT ANY TIME.

THE CONTENTS OF THIS DOCUMENT MAY BE MODIFIED AND/OR QUALIFIED, DIRECTLY OR
INDIRECTLY, BY OTHER DOCUMENTATION WHICH ACCOMPANIES THIS SOFTWARE, INCLUDING
BUT NOT LIMITED TO ANY RELEASE NOTES AND "READ ME" FILES.

This and other products of TIBCO Software Inc. may be covered by registered patents. Please refer to
TIBCO's Virtual Patent Marking document (https://www.tibco.com/patents) for details.

Copyright © 2004-2022. TIBCO Software Inc. All Rights Reserved.
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