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Introduction to TIBCO Business Studio - BPM
Edition

TIBCO Business Studio™ - BPM Edition can be installed using the Studio for Designers
installation.

For more information, see TIBCO Business Studio - BPM Edition Installation.

Studio for Designers

Studio for Designers provides a project-based view and enables the solution designer to
add details to and manage the processes at a project level. This installation is suited to
users who are more comfortable with developer tools, and who need access to all files

related to the project.

To launch TIBCO Business Studio - BPM Edition as a solution designer, go to Start > TIBCO
> Studio for Designers 5.x.

Creating a Project Package and Process

You can create a new TIBCO Business Studio project, package and process are part of the
same procedure using a template.

o Note:

 If you have processes that you created using previous versions of TIBCO
Business Studio, you must migrate them to the current version as
described in Migration of Projects Created in Previous Versions.

» This topic describes how to create a project, and at the same time create a
package and process using a template. You can however, perform each
operation separately.

Procedure
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1. Go to File > New > BPM Process Project.

2. Complete the New BPM Process Project dialog as follows:

Field Description

Project Enter a descriptive name for the project.

name

Location Either accept the default location for the project (your workspace) or de-

select the Use default location checkbox and click Browse to select a
different location.

Click Finish on this dialog (or on any of the subsequent dialog) to create a project
with the settings you have made to that point. Click Next to modify the default
project settings and create a process using a template.

3. In the Business Processes dialog, enter the name of the folder that you want to
designate for Business Processes.

Under Package Details, you can accept the preselected checkbox and either enter a
file name or accept the default file name.

By default, when you create a project, TIBCO Business Studio creates a package and
process as well. The default packages Folder is called Process Packages and the
default packages file is ProcessPackage.xpdl. Either accept the default names or
rename the packages file and folder. Click Finish if you are done, or Next to specify
more options.

4. The Package Information dialog is displayed. Either accept the default properties of
the package, or modify them as necessary and click Finish if you are done, or Next to
specify more options.

e Package Label

Descriptive label for the package. Defaults to the same name as the file name
of the package and is used for purposes such as simulation reports.

e Author
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Username of the user who created the package.

Note: The name of the author can be defined in the User Name:
field on Window > Preferences > User Profile. If no user is
defined there, it uses the default user system property.

e Created

Displays the date/time that the package was created.

e Description

Text description of the package.

¢ Documentation Location

URL or file name of any supporting documentation.

e Language

Provides context for user-visible language in processes. For example,
annotations in a process might be in a language or character set unfamiliar
to the user of the process. Use this field to specify the language used. Note
that this field is informational; it does not change any system or TIBCO
Business Studio-specific language settings.

5. The Select Template dialog allows you to create a process using a template. Select a
template from those available and click Finish if you are done, or Next to specify
more options.

6. The Set Special Folders dialog displays the default special folders. Either accept the
default names or enter your own names and click Finish.

The newly-created package, process, and project are displayed in the Project
Explorer. For more information about the Project Explorer, see Project Explorer View.

Process Editing

There are a number of common tasks and shortcuts to help you use the Process Editor to
create processes.

See Gadgets for an Object
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See Adding Objects Using the Palette

See Using an Object’s Gadget to Connect Objects

See Using Connection Tools on the Palette to Connect Objects
See Selecting Objects

See Tools for Finding Objects in a Diagram

See Customizing Palette Favorites

For additional information, see Tips and Tricks.

Gadgets for an Object

A gadget is a user interface aid that allows you to easily create sequence flows or other
links between obijects.

When an object is selected, initially one gadget of each applicable type is displayed, and if
multiple gadgets of a particular type are available, these are displayed when the mouse
cursor is moved over the first.

For example, if a task is selected, the Create Connection gadget is visible to the lower
right of the task:

Task

-

|f Drag-drop ko create new u:u:unnection.|

Gadgets that can be used to designate references to other objects can be used to designate
a reference (drag-drop gadget onto target object) or go-to a currently referenced object.

These gadgets are provided:

. Cycle Object Type Gadget - Change the activity type by cycling through the
different types.

. Create Connection Gadget - Create sequence flows to existing object or create and
connect to new object.

. Link Event Gadget - Designate a throw and catch link event pair.
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. Signal Event Gadget - Designate a throw and catch signal event pair.

Note: You can control the display of gadgets using the toolbar tool, or the Show
Click/Drag Gadgets drop-down list from the Diagram toolbar:

Diagram Project Window Help
Alignment > b 0w

=" Show Print Margins

H Grid

% Alignment Guides

== Animate Outgoing Connections

roduct (CreateProduct) # [& Produc

5 Highlighting >
O Show Click/Drag Gadgets > Cycle Object Type Gadget
& Zoom In Ctrl+= @ Create Connection Gadget
& Zoom Out Cirls- @ Link Event Gadget

IULEsS TatKayes © Signal Event Gadget

A gadget is a user interface aid that allows you to easily create sequence flows or other
links between obijects.

» To add an object, click the Create Connection gadget, and drag-and-drop it in a lane
content area or embedded sub-process content area.

A popup menu is displayed showing a selection of applicable main object types that
can be created (available types governed by the source object and drop location).

You can also drag onto an existing sequence flow, and the object is inserted onto the
sequence flow. If the target flow is not to or from the selected object then a new flow
is added to the new object.

] =R§I Create Task B

) b ® Create Gateway

[ @ Create Event

O Create End Event —

[ Create Annotation
[ Create Daka Object
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Adding Objects Using the Palette

You can use the palette to add objects (for example, a task).

Note: When you first start TIBCO Business Studio, if the palette is not visible,
expand it by clicking the Show Palette button to the right of the window:

[

Show Palette button ——» _j A

| P

Show Paletke

Procedure
1. Click the appropriate tool in the palette. If an object has more than one type (for
example, a task can be a service task, or user task, and so on), each type has a tool
on the palette. For example:

“* Palette ¥ ¥l Tasks -0
s

&> Favorites

— Connections

O Start Events

@ Catch Intermediate Events

@ Throw Intermediate Events
OEnd Events

JTasks ®
O & &
= o)
<& Gateways &
® @ © o @

[H Artifacts ®
C D

I
[
£

Click another tool to display the available sub-types. For example, click the Gateway
tool to see the different types of gateways; this closes the currently open tool drawer
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if more space is required to open the new tool drawer. To change this behavior and
cause the available tasks to remain open, click the Pin Open button ).

° Tip:
* To add more than one object of the same type, hold down the Ctrl
key.

e You can customize certain palette preferences by selecting
Customize from the right-click menu on the palette. This allows you
to define preferences such as the default tool drawer states on editor
startup. There is also a Favorites drawer that you can customize (see
Customizing Palette Favorites).

Position the pointer on the process at the place where you want to place the object.
The pointer changes shape:

2. Click process to add the object.

Result

Tip: You can also drag-and-drop from the palette. So, select an item on the
palette and drag-and-drop it to where you require it in the process.

Using an Object’s Gadget to Connect Objects

You can connect objects in the process by creating a sequence flow using the Create
Connection gadget, but a similar procedure applies to all connection types.

Procedure
1. Select the object. For example:

&
¢

|:rJJ Drag-drop ko creake new u:u:unneu:ti-:un.|

2. Drag the Create Connection gadget to connect to another object. For example:
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3. If you add more connections or references, additional gadgets are added. These are
only visible if you position the mouse over the visible gadget. For example:

—n User Task --—@
)

%) ] S " .

Click to go to target of outgoing connection: User Task 3 User T
Drag-drop to create new outgoing connection, =

In this example, there is a Create Connection gadget for each outgoing sequence
flow. Clicking a gadget selects the referenced or connected object in the Process
Editor (for example, clicking the gadget attached to a reference task selects the
referenced task).

Using Connection Tools on the Palette to Connect
Objects

To connect two objects with sequence flow, use the Sequence Flow tool.

Procedure
1. Click the Sequence Flow tool.

2. Position the pointer over the object that is the source of the sequence flow.

The pointer changes shape:

3. Draw the sequence flow using one of these methods:

» Click the source object, then position the pointer over the target of the
sequence flow. If you are satisfied with the shape of the flow, click the target.

e Click the source object, holding down the mouse button, drag the pointer to the
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target object and release the mouse button.

° Tip: While drawing the sequence flow, you can add bend points by
right-clicking or pressing the spacebar as you create the flow.

° Tip: You can also drag-and-drop from the palette. So, select an item
on the palette and drag-and-drop it to where you require it in the
process.

° Tip: When you connect objects, as the default the sequence flows use
Multi Entry/Exit Point connection routing (meaning that there are
multiple separate lines from the entry or exit point to those objects
they are connected to. You can tailor this behavior, by selecting the
process, and from the Properties tab, select the Appearance tab. You
can then select from these connection routing styles:

e Multi Entry/Exit Point
 Single Entry/Exit Point

e Uncentered on tasks

Once you have selected a different connection routing style, the
diagram is reformatted to use this selection.

Selecting Objects

You can select objects using the Select tool on the palette or the Marquee tool.

e Using the Select tool on the palette. Hold down Ctrl to add single objects to the
selection or Shift to select a range of objects.

» Using the Marquee tool. This allows you to drag a rectangle around all the objects
that you want to select.

Tools for Finding Objects in a Diagram

TIBCO Business Studio provides different tools to find objects in a diagram.
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* To find an object on a process, press Ctrl+F or click the icon on the toolbar. In the
resulting dialog box enter the name or partial name of the object you are looking for.

For example:

| P« o D
E corelogic

" Task - PoolfLane =t

In this example the only task that starts with "c" is a script task called coreLogic.
Clicking on the task displays it in the Process Editor.

* You can find workspace elements such as processes, package names, and process
interfaces by pressing Ctrl+F or the search toolbar button in the Project Explorer
view. For example:

& Tut o o | «—— Theamow buttons allow you to
select the next or previous item

Tutorial 1 Selution.xpdl in the list, You can also double-

[=3) Tutarial 1 Selution.xpdl click or press Enter to select

[72] Tutorial 2 Solution.spd| items in the list.

[ Tutorial 2 Solution, xpd|
78] Tutorial 3 Selution.xpdl
78] Tutorial 3 Solution.pd|
@ Tutorial 5 Solution. xpdl
72 Tutorial 5 Selution.xpdl

This button allows you to

File - jProcess Modeling Tutorial ... Packages/Tutorial 1 Solution.xpdl 15 | <+—— restrict the types of items
you wart to search far.

* You can also find a business object model package, class, primitive types and
enumerations, as well as organization models, by pressing Ctrl+F or the Find toolbar
button in the Project Explorer view.

* You can also find items using the first characters from the start of each capitalized
word (CamelCase searching). For example, "BP" returns a file called
BankPayment.wsdl.

The wildcard ? returns all elements. Use the * wildcard to restrict the results (for example,
*2 to return all matches ending in 2). Note that the wildcard * by itself does not return any
results; it only works in conjunction with a string.

Customizing Palette Favorites

The palette contains a drawer labeled Favorites that contains some of the most commonly
used objects., which you can customize by adding or removing objects.
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© & O
O &8 &=
®* & —

Procedure
1. Right-click in the Favorites drawer, and select Customize.

-
& Customize Palette

[ Toals [Z» Favorites
ESYF = orites Mame:
—* Connections

O Skart Events

@ Catch Intermediate Events
(&) Throw Intermediate Events Favourite Tools: Use

O End Evertts right-click/Customize to show and hide
[ Tasks [ Hide

[ <> Gateways
[ artifacts

| Favorites

Descripkion:

Cpen drawer at skark-up
Fin drawer open at skark-up

H Zancel H Apply

2. Expand the Favorites item in the Customize Palette dialog box.

3. Select an object and use the Hide check box to display or hide the object in the
Favorites drawer:
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i

& Customize Palette

@ Message Stark Event

E Timer Start Event
Conditional Start Event
@ Multiple Start Event

; @ Signal Skart Event

@ Catch Intermediate Event

Favarites

() By o

E

O Start Event

MName:

| Skart Event

Descripkion:

Intriggered skark

[ |Hide
@ Catch Message Inkermedi
@ Catch Timer Intermediate
@ Catch Conditional Interme
B Catch Link Intermediate £ 3
Al i -]
L (0] ] [ Zancel ] [ Apply
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Projects

This section describes how to work with projects in TIBCO Business Studio.

BPM applications comprise of projects that contain different asset types required for the
application.

There are various project types available in TIBCO Business Studio - BPM Edition.

Projects allow encapsulation and segregation of the related aspects of your application.
They also allow the re-use of processes, data, and so on.

You can import existing projects into TIBCO Business Studio and export projects from it.
See Import and Export of Projects.

Migration of Projects Created in Previous
Versions

Projects created in previous versions of TIBCO Business Studio might need to be migrated
to the current version before they can be opened, depending on how you import them.

e To migrate a project created in a Studio version prior to v5.x, you must import using
File > Import > Existing Studio Projects into Workspace.

Use the import dialog box to successfully guide you through importing your projects
in the correct sequence.

You cannot checkout your existing projects directly from a version control system.
See Importing Pre-Version 5.x Projects into TIBCO Business Studio - BPM Edition
Version 5.x.

* If you are importing a project from SVN, then you might be unable to access all files
in the imported project until you have reviewed the Problems view and resolved the
problem covering migration using the Quick Fix provided.

Alternatively, if there is a problem marker on the project in the Project Explorer view,
press Ctrl+1 and look for the Problem
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"Project 'xxx' is of an older version and needs to be migrated."
Select the "Migrate the Project" quick fix in the popup.

If you are importing a single file, then you might need to migrate this file using the
Quick Fix available.

If you are importing a project created in a newer version of TIBCO Business Studio,
you can see a problem marker (for example, "Project 'xxx' was created by (or
migrated to) a newer version of the product and should not be used with this
version"). Install a newer version of TIBCO Business Studio if that is appropriate or
return to an earlier version of the product/project.

Import and Export of Projects

You can import existing projects, MAA files and archive files into TIBCO Business Studio,
and export projects from it to archive files, MAA files, a work data model, or file systems.

Note: TIBCO recommends that you import or export individual projects, and do
not attempt to import or export the workspace.

Importing Existing Studio Projects into Workspace

You can import a project into the workspace.

Procedure

1.

From the File menu, select Import, and you see the Select page of the Import dialog
box.

Expand the General folder, select Existing Studio Projects into Workspace and click
Next.

Note: TIBCO recommends that you use the Existing Studio Projects into
Workspace and not the Existing Projects into Workspace option, as it
only imports the files you require.

Do one of the following:
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e Click on the Browse button for Select root directory: to locate other projects
that are somewhere on the file system (for instance, in another workspace).

e Check the radio button for Select archive file: and click on the Browse button
to see projects that have already been archived which you might want to
import.

4. Select the project you want to import, and click Open. The project is now selected.

Note: This does not work if there is already a project of the same name in
the workspace.

5. Select the Copy projects into workspace check box and click Finish. The project is
now imported and appears in Project Explorer.

Importing Existing Modelled Application Archive
(MAA) Files into Workspace

You can import existing Modelled Application Archive (MAA) files into the workspace.

Procedure
1. From the File menu, select Import, and you see the Select page of the Import dialog
box.

2. Expand the General folder, select Existing MAA into Workspace and click Next.

3. Do one of the following:

e Click on the Browse button for Select root directory for MAA files: to locate
other MAA files that are somewhere on the file system (for instance, in another
workspace). This can be used to import multiple MAA files in one single go.

» Check the radio button for Select MAA file: and click on the Browse button to
see MAA files that have already been archived which you might want to import.
This is used to import one single MAA file at a time.

4. Select the MAA file you want to import, and click Open. The MAA file is now selected.
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Note: This does not work if there is already a project of the same name in
the workspace.

5. Click Finish. The MAA file is now imported and appears in Project Explorer.

o Note: You can create an MAA file in TIBCO Business Studio for Analysts,
save it and then import it as an existing MAA into TIBCO Business Studio.
You can then work on the projects it contains and save it, and export it to
MAA, and then access it again from TIBCO Business Studio for Analysts.

o Note: When importing an MAA created in TIBCO Business Studio for
Analysts there is no destination set on the project and therefore you must
set this before you use the project. You can do this in the following ways:

» Right-click on the project and select Properties > Lifecycle and
select the appropriate destination environment.

» Right-click on the project and select Refactor > Project Lifecycle...
to apply the destination to each process.

Importing Archive Files into Workspace

You can import an archived project into the workspace.

Procedure
1. From the File menu, select Import, and you see the Select page of the Import dialog
box.

2. Expand the General folder, select Archive File and click Next.

3. In the From archive file: field, use the Browse button to locate the archive file you
want to import.

4. In the Into folder: field, use the Browse button to identify the folder into which you
want to import the file. This can be one of your existing projects. You can choose
whether to check the Overwrite existing resources without warning check box.

5. Click Finish. The archive file is now imported into the location you have identified.
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Importing Nimbus Process Diagrams

Nimbus Process Diagrams can be imported into an existing TIBCO Business Studio project.

o Note: In order to be imported into TIBCO Business Studio, Nimbus Process

Diagrams must be exported from the Nimbus Control application using the
Export To Business Studio option in the Nimbus Process Map editor (or Export
Simplified XML in previous versions of Nimbus). See the TIBCO Nimbus Control
documentation for more details.

Procedure

1.

Right-click at the process package level of an open project and select Import >
Import Nimbus Process Diagram(s).

Alternatively, from the File menu, select Import, and from the Select page of the
Import dialog box expand the Business Process Management folder, select Nimbus
Process Diagram(s) and click Next. This method involves additional pages to those
in the process below, which are explained in the wizard.

On the Import Nimbus Process Diagram(s) page, in the From Directory: field, enter
the directory where you saved your Nimbus Process Diagrams, or use the Browse
button to find it.

The Nimbus Process Diagrams in the directory you selected appear on the right-hand
side. Select the one(s) you require

In the Into folder: field, enter the directory in which you want to place the Nimbus
Process Diagrams.

The Validate Import Files screen shows the validation status of Nimbus Process
Diagram files. If the files are valid (in the expected simplified XML export format and
containing only Nimbus simple diagrams) click Finish. If the files are not valid, you
cannot finish and must go back and re-export the files from Nimbus Control as
simplified XML.

The Nimbus Process Diagram files are now imported into the Process Packages folder
you specified in step 4.
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Equivalences between Nimbus Process Diagrams and
TIBCO Business Studio BPMN Processes

Nimbus Export  Process Package (xpdl File)
File

Process Business Process per diagram
Diagram

e One pool and one lane for all activities.

e Diagram documentation URL is added to the process (visible on the
Description property tab) and to each individual task sourced from
that diagram.

Task Type e Activity Type:

° Creates a sub-process task for a Nimbus drill-down activity.

1
AddNew ° Parameter mappings are created where the data created for
Starter
start/end connections in the drill-down process have
equivalent named data in the calling process diagram.

o If drill-down activities reference Nimbus diagrams in other
export files then these should be imported either at the same
time or prior to the referencing file (if you do not do this, you
get a broken reference and a validation problem that you then
have to resolve manually).

¢ If a non-drill-down activity has a resource then it is a User Task.

 |If a specific Activity Type is selected then an equivalent BPMN type
(Manual, User, Service, Script, Send, Receive, Reference, Call Sub-
Process, Embedded Sub-Process, and Event Sub-Process) is created.

e If an activity has no resource then it is an Abstract Task with no
resource.

Activity Notes Text annotation attached to task.
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Nimbus Export
File

(Notes bubble)

Activity
Commentary

Statement
Links

Diagram URL

Activity
Resource

Connections

Start/End
Connection
Label

Process Package (xpdl File)

Start of Task Description.

Appended to Task Description (for example, statements of required
compliance with standards).

» Added to each task sourced from a given diagram.

e |tis provided in the Process Description Documentation URL and
Activity Description Documentation URL, and as an activity tooltip
popup including the Documentation URL as a clickable hyperlink.
See Activity Properties for more information on the Documentation
URL.

e You can browse to the original Nimbus Diagram and documentation.

e One package participant per unique named resource.

e User tasks are assigned participant(s) for the activity resource(s).

e Treats connections both as routing between activities and as
incoming/outgoing data.

e Multiple connections in the same direction, between the same
Nimbus activities, are collapsed into a single connection.

e All start connections (connection without source object) are
connected to a single start event implying that all data is passed and
all connections happen at the start of a process.

¢ All end connections (connection without a target object) are
connected to a single end event.

e For each unique start/end connection label a formal parameter is
created.

e The uniqueness of labels is based only on their alphanumeric
content (white space and symbols are ignored) and is case-
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Nimbus Export
File

Connection
Between
Activities Label

3 2
Local Data
tActivity

W

Second A

All Connection
Labels

Process Package (xpdl File)

insensitive.

e The formal parameter mode is set according to whether the label
appears on a start connection (In) or end connection (Out) or both

(In-Out).

BRI [E Probicrs | 75 Fragments | W Daia Souwee Epiover] i Hisny|

% Business Process

General Label MName Mandat... Rea.. Mode
Descrigtion Eu Data In Datain [ Tl in
Destinations £ Data Out DsteOist [+ ] o

e All formal parameters are associated in the start-event activity

interface data.

e For each unique label

that only appears on connections between

activities (not on start/end connections) a data field is created.

CliPropaties 220 12 Problems| " Fragmants|

i Dt Source Explorer| (i History|

"% Business Process
| :
Label
1@ Local Data

:Gumd
i

Narne
Locailiats L1

Read_. Type
Tet

¢ As the connection labels are treated as process data, interface data
associations are added to user tasks for the data identified by its

incoming / outgoing c

onnections.

e The interface data mode is set according to whether the label
appears on an incoming connection (In) or outgoing connection

(Out) or both (In-Out).
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Nimbus Export  Process Package (xpdl File)

.
File
First Activity

= Properties i3 [Z{ Problems | ®5 Fragments ¥ Data Source Explorer

O Task

General Visibility: | @ Private () Public

Description ~ Parameters

. Interface Select a subset of data that is accessible for this activity.

Diata Fields [T Mo interface data association required.

Work Resource Process Data Name  Mode  Mandatory

Scripts % Dataln In

Data References @ Local Data Out

. . . .

Connection * Added to formal parameter / data field description
Commentary

° For multiple connections with equivalent labels, all
commentaries are added.

* Added to sequence flow description.

° For multiple connections between the same activities all
commentaries are added.

Exporting TIBCO Business Studio Projects to Archive
File

You can export a project from Project Explorer to an archive file.

Procedure

1. In your workspace, make sure you have the project you would like to export selected,
and from the File menu, select Export. You see the Select page of the Export dialog
box:

2. Expand the General tab, select Studio Projects to Archive and click Next.

3. Select the project you want to archive from the list of projects available. Enter a
location in the To archive file: box. You can use the Browse button to see existing
archive files, and either use one of these or create a new one.

4. A number of archive options are available. Either accept the default settings or adjust
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them to your requirements, and click Finish.

ioix

Archive file

Export resources to an archive file on theI:ucaI file system, |

=

D:pd Jcom.example, businessobjectmodel ;I =] .config
Dg Basic Samples X project
D@ CustomerServices

D@ EasyasExtendedOMSolution

D@ niewtest
#-[J2 warkingmadel -

Filter Types. .. | Select Al Deselect Al
Ta archive file: IC:'l,data'l,Archive'l,newarchive.zip j Browse. .. |

Options

' Save in zip Format *' Create directary structure For Files

" Save in kar format " Create only selected directorias

V¥ Compress the contents of the File

@ < Back Mext = | Finish I Cancel

Exporting Projects to a File System

You can export a project from Project Explorer to a file system.

Procedure
1. In your workspace, make sure you have the project you would like to export selected,
and from the File menu, select Export. You see the Select page of the Export dialog.

2. Expand the General tab, select File System and click Next.

3. Browse to the place you wish to save the files and click Finish.

Exporting Projects to Modelled Application Archive
(MAA)

You can export a project or multiple projects from Project Explorer to a Modelled
Application Archive (MAA) file.
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Procedure
1. From the File menu, select Export > General > Studio Projects to MAA. You see the
Export page of the Modelled Application Archive (MAA) Export Wizard.

2. Select the project or projects you want to export to MAA, and the location you want
to export them to and click Finish. The default project location is Exports/MAA for
each project.

Project Lifecycle

The project lifecycle consists of the following phases:
» Generating test deployment artifacts
» Deploying the generated artifacts
» Deploying production artifacts
e Creating a new draft

For more information about the project lifecycle phases, see the Project Lifecycle topic in
the TIBCO Business Studio™ - BPM Edition Application Designer's Guide.

Changing Project Lifecycle Settings

You can change project lifecycle settings in TIBCO Business Studio - BPM Edition.

ﬂ' Properties for ProcessDeveloperTutorialSolutions O .
type filter text Lifecycle o - - -

Resource

Builders [[:H | com.example.processdevelopertutorialsolutions

Business Object Modeler .

. Version: 1.0 Increment Major Version
Documentation - _
Form Designer After incrementing the major version, and

deploying this project, existing projects that
depend on it will not use the new version until
they are re-exported and deployed.

Lifecycle
Presentation Channels
Project Facets

Praject Natures Increment the major version only if you need

to make changes to this project that are not

Project References backward-compatible,

Run/Debug Settings
Task Tags

User Profile
Validation

Status: 'B Draft
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In the left pane, expand Form Designer, and select Lifecycle, which contains the following
fields:

Id - The unique project identifier which is used by cross-project reference in design time
and runtime.

Note: If you change the project ID after deploying it to a runtime environment,
then it appears to be an entirely different project than the already deployed one
(as far as existing deploy projects that reference it are concerned). So, caution
should be taken when changing project IDs.

Increment Major Version - To edit a project that makes it incompatible with existing
projects that depend on it, you must increment the major version before you can deploy it.
This can be achieved by using the Increment Major Version button.

Project References

When an asset in one project (for example, a business process) uses an asset in another
project (for example, a business data type), then a dependency reference is created
between those projects.

You can view your project dependencies using the dependency view (see Using the Projects
Dependency Viewer).

Editing Project References

When you select an asset type in one project (for example, a participant) that uses an asset
type in another project (for example, org model item), a project reference (from the BPM
project to the org model project) is required and created automatically when the reference
is first established.

To edit or remove a project reference, perform the following steps:
Procedure

1. Right-click the project, select Properties, and highlight Project References:

2. In this dialog box, select or deselect any referenced projects as required.
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Assets

Assets include XPDL package files, WSDL files, documents, business object models, and so
on that relate to the project, and are usually stored in special folders under the project.

For more information, see "Assets" in the TIBCO® BPM Enterprise Concepts Guide.

Adding Ad-hoc Assets

Ad-hoc assets include Microsoft Office documents and image files not recognized as project
management assets.

Procedure

1. Add business assets by right-clicking and selecting New > Folder or New > File, and
selecting the appropriate Parent Folder.

2. To view the folder or files you have created, go to the Navigator view. In the
Navigator view, you can also drag files and folders to different locations.

Using the Projects Dependency Viewer

Use the Dependency Viewer to show an interactive, graphical representation of your
project's file dependencies.

Procedure

1. Right-click a resource in Project Explorer (for example, a project, a BOM file, or a form
file) and select View Dependencies.

2. The Dependency Viewer displays the dependencies.

For example, right-clicking the easyAsInsurance_Process.xpdl file shows references
from the form files to the XPDL file and references from the XPDL file to the
easyAsInsurance.bom (business object model) and
easyAsInsuranceOrganizationModel.om (organization model).
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[E] UserTask.form [E] CreateClaim.form [E] PayClaim.form [E] IncidentDetails.form [E] ContinuaWithClaim.form [E] UserTask.form

- —_— 1 —_— 1
178 casyAsinsurance Processopdl |
(L8] SRy RS nevrenee Trocess e §
| 1 I

easyAsinsurance.bom easyAsinsuranceQrganizationModel.om

o Note: You can select different views in the Dependency Viewer to make
these relationships clearer:

[ET]
(L]

|¢::-'::h'|f*."'="§j

4

To focus on a resource, do one of the following:

» Select the resource in the Project Explorer.

» Right-click the resource in the Dependency Viewer and choose Focus on or
Focus on Resource name.

« Click the % button.

To reset the layout and refresh the contents of the viewer, click .

To show everything in the workspace, including resources which are not related to

44

®
T

the resource you have focused on, click

o Note: To break the link between the Project Explorer and the Dependency

Viewer, click -] Doing this means that resources that you select in the
Project Explorer are not focused in the Dependency Viewer.

To highlight resources that are referenced from the resource you are focusing on,

click . In the following graph, the easyAsInsurance_Process.xpdl file references
easyAsInsurance.bom (Business Object Model) and
easyAsInsuranceOrganizationModel.om (Organization Model).

[E] UserTask.form ] CreateClaim.form ] PayClaim.form [E] IncidentDetails.form [ ContinueWithClaim form [E] UserTask.form

P p—— 1
113 casyAsinsurance Processapdl 1!
e =

o
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To highlight resources that have a reference to the resource on which you are

focused, click EI In the following graph, a number of form files reference the

easyAsInsurance_Process.xpdl file.

L= e | CreateClaim.form | = PayClaim form | st ey - | Userfaskform |
""""" e e A
easy zat;

To show all the resources which are part of the relationship graph of the focused
resource (that is, all the resources which are directly or indirectly related to focused

node), click [22].

Finding Cyclic Dependencies
The Dependency Viewer highlights any connections that are part of a cycle.

A simple example of a cyclic dependency is where Project A refers to Project B, which refers
back to Project A.

Procedure
1. Display the list of projects.

2. Selecting every resource as the focus using the Dependency Viewer, check for cyclic
connections. You can identify these by this connection:

X >

For a given resource, get the list of resources it depends on and make each of these
the focus in Dependency Viewer, and check for cyclic dependencies.

Enabling and Disabling Special Folders

Special Folders are folders in the Project Explorer that are reserved for storing specific
types of assets. Special folders can be enabled or disabled in TIBCO Business Studio.

See the "Special Folders" topic in the TIBCO® BPM Enterprise Concepts Guide.

» Disable a special folder by highlighting it in the Project Explorer, right-clicking, and
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selecting Special Folders > Do not use as SpecialFolderType

Note: The example uses the special folder for business processes as an
example, however the special folders for other asset types are enabled and
disabled in the same manner.

» Disable the packages folder by highlighting the Process Packages folder in the
Project Explorer and selecting Special Folders > Do not use as Process Packages
Folder, which results in a view of the package as follows:

== Process Packages
@ MyProcessPackage, xpdl

» Conversely, you can enable the use of the special packages folder by highlighting the
packages folder in the Project Explorer and selecting Special Folders > Use as
Process Packages Folder. This results in a view of the package as follows:

= Process Packages
= @ MyProcessPackage
= MyProcessPac
i) Data Fields
8 Participant

] Tvpe Decla
9‘8 Processes

Source Control

You can use Subversion with TIBCO Business Studio to provide source control to manage
your projects and processes. For more information, see the following topics:

e Using Subversion with TIBCO Business Studio
» Creating a Project from an Existing Project in Source Control
e Browsing SVN Repositories

» Deletion of Projects from SVN Repositories

Caution: The MKS source control system adds a project.pj file to every folder
in the project.
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Using Subversion with TIBCO Business Studio

Subclipse is an Eclipse plug-in that adds Subversion to the Eclipse environment, and is
bundled with TIBCO Business Studio.

Note: In this topic, it is assumed that the user or the Subversion administrator
have installed an SVN server.

Procedure
1. Right-click an existing project that contains items you wish to source control. Select
Team > Share Project. Obtain the URL for the Repository Location from your
Subversion administrator.

Creating a Project from an Existing Project in
Source Control

You can create a project from an existing project in source control.

Procedure
1. Go to File > Import to open the Import wizard.

2. Expand SVN, select Checkout projects from SVN and click Next.

3. Set up the repository with the assistance of your Subversion administrator, (the
repository should point to the parent directory that has the project folder) and click
Next.

4. Select the project folder and click Next.
5. Select the method for checking out the project and click Next.

6. Either use the default workspace or click Browse to check out the project in a
different location.

7. Click Finish. The project is checked out to your workspace.
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Note: Ensure that you import or export individual projects, and do not
attempt to import or export the workspace.

Browsing SVN Repositories

You can browse SVN repositories as follows:

Procedure
1. Select Window > Open Perspective > Other.

2. Select SVN Repository Exploring.

3. This opens a perspective from which you can browse SVN repositories. For example:

E‘i SWN Repository X SN Annotate

- I_] hitkp: ffgrp-ron: 6588) svn-usersftrunkfSalutionPlat
+-[= metadata
-2 Basic Samples
.project 3552
|Z| HiringPackage. xpdl 2591
|Z| OfficeProcedures, xpdl 2591
|Z| SimulationPackage . xpdl 2391

Deletion of Projects from SVN Repositories

To delete a project that is in Subversion, use a tool such as Tortoise SVN, the command
line interface to Subversion, or a web-based tool.
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BPM Packages and Processes

This section describes how to work with packages and processes in TIBCO Business Studio.

Creating a Package

You can create a package as part of creating a project or independent of project creation.

See Creating a Project Package and Process.

Procedure

1.

Right-click the Process Package folder under which you want to create the package
and select New > Process Package.

If you want to change the Packages Folder under which the package is created, click
Browse or enter an existing folder name.

Enter the name of the File or accept the default file name. The file name must have
.xpd1l as the extension. Click Next.

The Package Information dialog box shows the name of the package and its default
properties (for a full explanation, see step 10 in Creating a Project Package and
Process).

Either accept the default properties of the package, or modify them as necessary.
Then, click Finish to create a process using the default template, or click Next to
create a process using a different template.

By default, a process is created with start and end events connected by sequence
flow. The Select Template dialog box allows you to create a process using a different
template. Select a template from those available and click Finish.

Result
The newly-created packages and any processes that you elected to create are displayed in
the Project Explorer.
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o Note: TIBCO Business Studio restricts the number of open editors to 8 by default

to avoid adverse performance issues. To edit this setting, go to Window >
Preferences > General > Editors and under Close editors automatically, edit
the value for Number of opened editors before closing.

Copying a Package

You can copy a package into the same project, or into a different project in your

workspace.
Procedure
1. In the Project Explorer, highlight the package file you want to copy.
2. Press Ctrl+C to copy the package.
3. Open the project into which you want to copy the package.
4. Select the folder into which you want to copy the package (for example, the Process
Packages folder).
5. Press Ctrl+V to paste the package. If copying the package within the same project,

you are prompted to enter a new name. If copying the package to a different project
when a package of that name already exists, you are prompted to overwrite the file.

o Note: After copying a package, errors similar to this are displayed in the
Problems view:

| €3 ¥PDL 2.0 : The following files have duplicate process IDs: fmond/Process Packages/ProcessPackage., xpdl |

To correct this, right-click the problem, and select Quick Fix. Accept the
suggested fix for this problem to resolve the duplicate IDs.

Creating a Business Process

You can create a Process and its containing package and Project in one operation or you
can create a business process.

See Creating a Project Package and Process.
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Procedure
1. Before creating a process, you must create a project and a package to contain your
process.

2. In the Project Explorer, select the package you created, right-click and select New >
Business Process.

3. The New Business Process wizard is displayed.

o Note: If you start this wizard from the File > New menu, the first dialog is
the Project and Package dialog, where you must specify a valid project and
package. This dialog is not displayed if you right-click at the package level
to start the dialog; however, you can click Back to display it if necessary.

4. Enter the Label of the process. To use a template to create the process, select the
template and click Next. This example shows one of the basic templates (a task
sequence).
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#) New Business Process 0 X
New Process Wizard
Mew Process Wizard

Label: |ProcessDe\re\operTuturia\So\utiuns-Process?. |

Name: | ProcessDeveloperTutorialSolutionsProcess2 |

v [ Business Process Templates A foifol
v [[fy Basic Templates
DS Embedded Sub-process
59 Timeout Task
DS Task with Annotation
B9 AStart and End
DS Task with Data Object
D'S Embedded Sub-process
DS Task Sequence
B9 split Conditional
DS Task with Compensatior Tazk 1 Tazk ?
B9 Split Parallel
DS Pool and Lane
v [ Extemnal Systems
DS Get Set Data in Different
v [ Process Templates

D'S Simple Process
DS Simple Workflow Proce:
D'S Start and End v
{ >
® < Back Next > Cancel

In addition to the process templates, you can select a process interface as the basis
for your new process. This creates a process with the necessary events, parameters
that are specified in the process interface.

5. In the Description dialog, add optional text that describes the process, an optional
URL that links to documentation about the process, and click Next.

6. In the Destinations dialog, select the Destination Environment (optional).

7. The Extended dialog is displayed. This allows you to add optional supplemental
information to the XPDL for the process. For more information see Creating Extended
Attributes.

8. Click Finish.

9. The process that you created is displayed in the Process Editor. When you first start
the Process Editor, the palette (on the right side of the diagram) might collapse; if so,
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expand it:

O *process (process) i1

=l =)

<2 Palette

A

(> Favorites.

O® 00 == & & —
—+ Connections

— o

-
Start Event End Event () Start Events

O ®

(2 Catch Intermediate Events

© @0 9 0@ 8 @
(&) Throw Intermediate Events

(0 End Events

([ Tasks

@ F = o

You can expand this window to fill your screen by double-clicking the title bar (in this
example, the area labeled Process2).

The Process Editor provides a Pool and Lane that you can rename if you plan on
using pools and lanes (see Controlling Flow in a Process). You add elements of your
business process using the Palette.

Creating a Pageflow Process

A pageflow is a sequence of tasks that defines the flow of form pages which, a user must
work through before submitting a work item.

You can create a Process and its containing package and Project in one operation or create
a pageflow process.

See Creating a Project Package and Process.

Procedure

1. Before creating a pageflow process, you must create a project and a package to
contain your process.

2. In the Project Explorer, select the package you created, right-click and select New >
Pageflow Process.

3. The New Pageflow Process wizard is displayed.
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o Note: If you start this wizard from the File > New menu, the first dialog
box is the Project and Package dialog box, where you must specify a valid
project and package. This dialog box is not displayed if you right-click at
the package level to start the dialog box. However, you can click Back to

display it if necessary.

Enter the Label of the process. If you want to use a template to create the process,
select the template and click Next.

In addition to the process templates, you can select a process interface as the basis
for your new pageflow process. This creates a process with events and parameters
that are specified in the process interface.

_oix]
New Process Wizard CH]—:]

Mew Process Wizard

Marme: |Pr0cessPackageProcess

-

E@ Pageflow Process Templates Q. | 2 |
=] {Ea Basic Templates
----- User Task

----- Invoke Business Process
i Start and End
‘%' Process Interfaces
@ ‘WelcomeUsersImplementSolution
@ EasyAsExtendedOMSolution

q I_>ILI

(7) < Back | Mext = | Finish I Cancel |

4. In the Description dialog box, add optional text that describes the process, an
optional URL that links to documentation about the process, and click Next.

Note: The Documentation URL field is intended for design-time
collaboration; it is not displayed in the runtime environment.

5. The Extended dialog box is displayed. This allows you to add optional supplemental
information to the XPDL for the process.
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6. Click Finish.

7. The process that you created is displayed in the Process Editor:

Stark End

When you first start the Process Editor, the palette (on the right side of the diagram)
might collapse; if so, expand it. You can expand this window to fill your screen by
double-clicking the title bar. A pageflow process has a different default color scheme
from a business process.

o Note: Pageflows do not contain pools or lanes.

Creating a Case Action Process

You can either create a new case action or generate one directly from a case class.
Template case action processes are provided that allow you to view or update the contents
of a case object, but you can modify these templates to provide whatever functionality you
need for a particular case class.

Note: You can generate a Case Action from a Case Class definition in the
Business Object Model (BOM) editor.

Before you begin

Before creating a case action, you must create/import a business data project with a case
class and add a case state attribute to that case class. You must also create/import a BPM
project and have a package to contain your case action.

Procedure
1. In the Project Explorer, select the package you created, right-click and select New >
Case Action.

You can also create a case action from context menus on the case class in the BOM.

TIBCO Business Studio™ - BPM Edition Modeling Guide



47 | BPM Packages and Processes

2. The Case Action wizard is displayed. Enter a Label and Name for the Case Action.

3. (optional) On the Case Class selector, Select a Case Class type from a Business
Object Model to select the Case Class that this action applies to.

If you do not set this here, you can set it from the Properties for the Case Action
when you have created the case action using the wizard.

4. Select a template for the case action from View Case Action Process or Update
Case Action Process.

5. Set the Destination to BPM and other properties as required.
6. Click Finish.

7. The case action that you created is displayed in the Process Editor. For example,

View Case Action process:
B
Wiew Case

=1

Leckup Case
Srant

j Lockup
Failed

Generating Case Actions from Case Classes

You can generate a Case Action from a Case Class definition in the BOM editor.

Procedure
1. Right-click on a Case Class in the BOM and select Generate Case Action.

2. Select one of the following actions:

» To View Case Data: Fetches the data for the case reference provided by
Openspace and shows that data to the user in a form.

» To Update Case Data: Fetches the data for the case reference provided by
Openspace and shows that data to the user in a form. The user can change that
data and the case object is subsequently updated.

3. From the Generate Case Action dialog box, open the project and Process Packages
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where you want to place the xpdl. You can also select an existing xpdl. Click Finish.

The case action is generated with the appropriate template (View Case Data or
Update Case Data) and you can edit it to meet your needs.

View Case Data:

View Case

Update Case Data:

El‘

_Lookup Case

Start

End Event

Failed

Creating a Service Process

You can create a service process and its containing package and project in one operation
or create a service process only and add it to existing package/project.

See Creating a Project Package and Process.

A video called Modeling a Service Process is available that shows how to model a typical
service process.

As service processes should be of short duration and have only one function, some activity
types are not supported in service processes.
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Activity Type Description

User tasks No direct user interaction with a service process is supported.
Manual ad-hoc activities No direct user interaction with a service process is supported.
Event sub-processes This could result in unacceptably long pauses and, as service
responding to externally processes can be invoked from both pageflows and business
sourced signals/incoming services, this feature is disabled for service processes. Event
request events and inter- sub-processes for internal process signals are supported.

process signals

Attached Sub-process calls Service processes can only synchronously invoke other service
to non-service process types  processes. However, they can asynchronously invoke
conventional stateful business processes.

Non-boundary timers Timers that pause rather than monitor the execution of a
thread of a service process are not supported.

When modeling a service process, you must specify a deployment target. You can deploy
service processes to either:

* the process engine
 the pageflow engine

The deployment target you choose depends on whether you are invoking your service
processes from business processes or pageflow processes. When you create a service
process, the service process is set to deploy to the process engine by default.

Procedure
1. Before creating a service process, you must create a project and a package to contain
your process.

2. In the Project Explorer, under Process Packages, select the package you created, or
Processes within an existing package, right-click and select New > Service Process.

The New Service Process wizard is displayed.

3. Enter the Label of the process. You can change the label on the General tab in the
Properties view if necessary. If you want to use a predefined template to create the
service process, select the template and select Next.
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In addition to the service process templates, you can select a service process
interface as the basis for your new service process. This creates a service process
with the deployment target, events and parameters that are specified in the service
process interface. Specifying a service process interface allows the dynamic selection
of service processes at runtime. See Service Process Interfaces.

4. In the Description dialog box, add optional text that describes the process, an
optional URL that links to documentation about the process, and click Next.

Note: The Documentation URL field is intended for design-time
collaboration; it is not displayed in the runtime environment.

5. The Extended dialog box is displayed. This allows you to add optional supplemental
information to the XPDL for the process.

6. Select Finish.
The service process that you created is displayed in the Process Editor.

When you first start the Process Editor, the palette (on the right side of the diagram)
might collapse; if so, expand it. You can expand this window to fill your screen by
double-clicking the title bar. A service process has a different default color scheme
from other processes.

o Note: Service processes do not contain pools or lanes.

7. Once you have created your service process, you must configure the deployment
target that you want the service process to be deployed to.

When you create a service process, the deployment target is automatically set to
Deploy to Process Run-time so, if you want your service process to deploy to the
pageflow engine, you must select Deploy to Pageflow Run-time in the General tab
of the Properties view.

o Note: There are other tabs available in the Properties view for service
processes. For more information, see Process Properties.

TIBCO Business Studio™ - BPM Edition Modeling Guide



51 | BPM Packages and Processes

Refactoring Service Processes and Service Process
Interfaces

You can convert an existing business, pageflow or sub-process into a service process or,
alternatively, a service process into a business, pageflow or sub-process. You can also
refactor a service process interface into a process interface, and vice versa.

Right-click the business, pageflow or sub-process you want to convert and select Convert
to service process. In the same way, you can convert a service process to a business
process or pageflow process.

You can also refactor a service process interface into a process interface by right-clicking a
service process interface and selecting Convert to Process Interface. Similarly, you can
convert a process interface into a service process interface by selecting a process interface
and selecting Convert to Service Process Interface . When you convert a process
interface into a service process interface, the deployment target is automatically set to
Deploy to Process Run-time so, if you want your converted service process interface to
implement service processes deployed to the pageflow engine, you must go back and
configure this in the service process interface after conversion.

Activities
An activity represents work that a company or organization performs using business

processes.

See "Activities" in the TIBCO® BPM Enterprise Concepts Guide.

Creating Scripts

All types of tasks can have scripts that write information to a destination-specific system.
User tasks can have scripts that are run, for example, when the work item is opened or
closed.

On the Scripts tab, you can add text that describes these scripts. The solution engineer
translates the outline of the script into a scripting language supported by the selected
destination environment.
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Procedure

1.
2.

Click the task to which you want to add a script.

In the Properties view for the task, click the Scripts tab.

The Scripts available are divided into two sets, Process Manager Scripts and Work

Manager Scripts. Open the set you require (if one set is not available to you for this
task, it is disabled).

[ Task

General
Description
Interface

Data Fields
Work Resource
g Scripts

Data References
Appearance
Extended

Resource

v P

4

[T Properties 52 |[%] Problems 09, Fragments

5]
=]

Initiate S(ript] E Complete Script| i Timeout S(ript| E Cancel Script

Describe Initiated Script:
if (data.FullName != null) {

}

Script executed by the process engine on initiation of the activity.  5cript Defined As: | JavaScript v

data.FullName = data.Forename + " "

+ data.Surname;

Work Manager Scripts

E Schedule Script E Reschedule Script E Open Script E Close Script E Submit Script

Script to execute when Work Manager schedules the work item.  Script Defined As: | Unspecified  »

4. Click the tab for the desired type of script. Any tabs that have scripts defined have a
script icon before the script name. Tabs with no defined script have an empty script
icon. In the image, a script is defined for the Initiate Script and Cancel Script tab.

5.

Select Free Text from the Script Defined As list. Describe your script in the area
provided. For more information about how the various types of scripts are
implemented, see the appropriate implementation guide.
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Result

o Note: You can highlight tasks in a process that contains scripts. Click the Process
Editor for the process. The Enable/Disable highlighting button is displayed on
the toolbar.

Click the Enable/Disable highlighting button ) to see the drop-down list, and
select Highlight Activities with Scripts.

ﬁ Highlight Ackivities \With Scripks
"-E Process Message APL Activities

“—+iZ_onditional Seguence Flow

W Enable Highlighting
W Enable Highlight Animation

This option highlights all activities in a process that contain scripts, and all other
activities are grayed out.

User Tasks and Pageflow Processes

In addition to creating a standalone pageflow process, you can do other actions from a
user task to select or create a pageflow process.

o Select an existing pageflow process.
» Create a pageflow process that is referenced from the selected user task.

In the runtime environment, the pageflow process is run when the work item associated
with the user task is opened.

When you right-click a user task, the Pageflow menu provides these options:
e Open

Select this option to open the associated pageflow process in the Process Editor
(if a pageflow process has already been selected for the task).

e Synchronize Parameters

Select this option if you have made changes to the parameters in the user task,
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and want the changes reflected in the corresponding parameters in the associated
pageflow process (see Synchronizing Parameters With a Pageflow Process).

¢ Generate

Select this option to generate a new pageflow process that can be associated with
this user task. The parameters associated with the user task are replicated for the
pageflow process.

e Use Existing

Opens the Select Form dialog box from which you can select an existing pageflow
process.

¢ Delete

Deletes the reference from the user task to the pageflow process. The pageflow
process itself is not affected.

Selecting a Pageflow Process

If you have already created a pageflow process, you can select it from a user task.

Procedure
1. Select the user task.

2. Do one of the following:

» On the General tab for the user task, select the Pageflow option and click the
picker to display the Select Pageflow Process dialog box.

i@ Pageflow: | | 1
Cpen Pageflow

Expand the projects to select a pageflow process and click OK.

» Right-click the user task and select Pageflow > Use Existing to display the
Select Pageflow Process dialog box. Expand the projects to select a pageflow
process and click OK.

3. The Pageflow field is automatically completed with a URL that points to the
pageflow process (relative to the Forms special folder). You can open the pageflow
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process by clicking Open Pageflow Process.

Creating a Pageflow Process from a User Task

You can create a pageflow process from a user task.

Procedure
1. Select the user task to which you want to associate a pageflow.

2. Right-click and select Pageflow > Generate. The New Pageflow Process dialog box is
displayed.

=

& New Pageflow Process

Select Parameters For Pageflow

Confirm data to pass ko [ from new Pageflow,

SR PIEER | I<cr Tack Interface Data
@ lastMarme
: @ Firsthame

=[] & Other Available Process Data
] @ Reference

3. Confirm the data that you want to associate with the pageflow process and click
Next:
e User Task Interface Data

Select from the process data specified on the Interface tab of the user task.
If no explicit process data is selected on the Interface tab, all process data is

available.

e Other Available Process Data

Select from the process data that is not associated with the user task.

° Tip: The parameters that you associate with the pageflow process
are available to user task forms after the pageflow process is

created.

4. Enter the Label of the process. If you want to use a template to create the process,
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select the template and click Finish to create the pageflow process or Next to specify
additional options.

Synchronizing Parameters with a Pageflow Process

When a pageflow process is first generated from a user task, a dialog box is displayed that
allows you to create the pageflow process with its own set of parameters (either replicating
the existing data fields and parameters of the user task, or a subset thereof).

User tasks in the pageflow process can display forms that utilize these parameters.

If you add or remove new parameters to the user task in the parent process (after the
pageflow process is generated), you can update the list of user task parameters that are
known to the pageflow process as follows:

Procedure

1. Right click the user task, and select Pageflow > Synchronize Parameters. The
Synchronize Pageflow Parameters With User Task dialog box is displayed:

& Synchronize Pageflow Parameters With User Task |:|[E|rg|

Synchronize Pageflow Parameters Summary

Synchronize Pageflow Parameters With User Task Interface Data.

Parameters to be added to the Pageflow {andfar assacisted with start event):

approval (approval)

Parameters to be modified in the Pageflow;

Parameters to be remaoved From the Pageflow:

S

[ Finish |[ Cancel ]

2. Confirm the changes and click Finish. For example, if parameters have been added to
the pageflow process but not the user task, synchronizing deletes them from the
pageflow process. If parameters have been added to or removed from the user task,
synchronizing adds or removes the corresponding parameters in the pageflow.
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Result
After synchronizing, the parameters in the Project Explorer listed for the pageflow process
should be identical to the parameters listed for the parent process.

Mandatory Parameters and Pageflow Processes

When a pageflow process has a mandatory parameter, that parameter must have a value
before the pageflow can be considered complete.

This is different to sub-process parameters, where the mandatory flag controls whether
mapping to the parameter is required or optional.

This means that a pageflow process and associated user task are expected to have the
same data available. As a result, mandatory pageflow parameters are mandatory in all user
task forms within the pageflow. However, if this is not the desired behavior, explicitly
associate the parameter with the user task in the pageflow and de-select the mandatory
flag.

Resource Patterns and Work Distribution

A number of patterns are available to model how you want work to be distributed to
resources. Resources are the people who carry out the work, and are represented in TIBCO
Business Studio by participants. How these patterns are interpreted depends on your
runtime environment, which might not support all the patterns.

See the "Resource Patterns and Work Distribution" topic in the TIBCO® BPM Enterprise
Concepts Guide.

Specifying Separation of Duties
Specify that tasks should be considered separate by using the right-click menu on the

Process Editor.

Procedure
1. Select the user or manual tasks that you want performed by separate resources (use
the Ctrl or Shift keys to select multiple tasks).
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2. Right-click and select Resource Patterns > Create a > Separation of Duties >
Group.

3. If you have not already done so, you must assign participants to the tasks.

4. The selected tasks are displayed on the Resources tab in the Properties view:

Note: To see other task groups, click the See all task groups(s) in the
process link on the Resources tab. This displays the Task Groups tab for
the process. This shows task groups of which this task is a member.

HE] [ iSeparate User Task & User Task 2!
% UserTask.
% UserTaskz

Specifying tasks that should be considered separate using
the Resources tab
Specify that tasks should be considered separate on the Resources tab for the task.

If you have already set up a task group, the Resources tab shows the groups to which the
selected task belongs.

Procedure
1. Click the Resources tab and expand the Separation of Duties section.

Click the button to create a new task group. The Select Tasks dialog box is
displayed.
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-
M sSelect Tasks

Select a type (7 = any character, * = any strin -+ —Eiackion

| | | QUserTask - ProcessPackage/Proces:

Matching items:

g_a ManualTask - ProcessPackage/Processes/Proce
QUserTask
%UserTaskZ
%UserTaskS

< | » < - | >

| platfarm:jresource/Tes. . es{ProcessPackage. xpdl platForm:fresour, . cessPackage. xpd

Ik ] [ Cancel

2. Select the tasks that you want to include in the group and click OK.

3. Once you have selected the task group members, you can also use the following
buttons:

* Use this button to add or remove tasks to and from the group.

* Use this button to either delete tasks for the group or delete the group.

o Note: To see other task groups, click the See all task groups(s) in
the process link on the Resources tab. This displays the Task
Groups tab for the process. This shows task groups of which this task
is a member.

TIBCO Business Studio™ - BPM Edition Modeling Guide



60 | BPM Packages and Processes

Specifying tasks that should be considered separate using
the Task Groups Tab

Specify that tasks should be considered separate on the Task Groups tab for the process.
If you have already set up a task group, the Task Groups tab shows the groups contained
in the selected process.

Procedure
1. Select the process in the Project Explorer and click the Task Groups tab.

Click the button to create a new task group. The Select Tasks dialog box is
displayed.

-
7 Select Tasks

Select a type (¥ = any character, * = any strin -+ S

| | | %UserTask - ProcessPackage/Proces:

Matching items:

ga ManualTask - ProcessPackage/Processes)Proce
%UserTask
%UserTaskz
%UserTaskS

Remove

Clear

l » < | 3

platForm: fresourcefTes, . .esfProcessPackage. <pdl D'?FFD"I'I'I:.!'VES_D'TIF- . -C_ESSPaCkﬂQE:XDd'_

[ ok ] [ Cancel

2. Select the tasks that you want to include in the group and click OK.

3. Once you have selected the task group members, you can also use the following
buttons:
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* Use this button to add or remove tasks to and from the group.

* Use this button to either delete tasks for the group or delete the group.

Specifying Tasks That Should be Part of a Retain Familiar
Group

Specify tasks that should be part of a Retain Familiar group using the right-click menu on
the Process Editor.

Procedure
1. Select the user or manual tasks that you want to include in the group (use the Ctrl or
Shift keys to select multiple tasks).

2. Right-click and select Resource Patterns > Create a Retain Familiar Group.
3. If you have not already done so, you must assign participants to the tasks.

4. The selected tasks are displayed on the Resources tab in the Properties view:

o Note: To see other task groups, click the See all task groups(s) in the
process link on the Resources tab. This displays the Task Groups tab for
the process. This shows task groups of which this task is a member.

+ Retain Familiar...

Tasks within a Retain Familiar task group will, by preference
user, Groups this kaskis a member of, .,

| @ [TJiRetain User Task 3 & User Task & User Task 2
% Fallowup
% TakeDetails
% Logrequest

Specifying that tasks should be part of a Retain Familiar
group using the Resources tab

Specify that tasks should be part of a Retain Familiar group on the Resources tab for the
task. If you have already set up a task group, the Resources tab shows the groups to which
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the selected task belongs.

Procedure
1. Click the Resources tab and expand the Retain Familiar section.

Click the button to create a new task group. The Select Tasks dialog box is
displayed.

-
M Select Tasks

Select a type (7 = anw character, * = any strin w S

| | | %UserTask - ProcessPackage/Proces:

Matching items:

gﬁ ManualTask - ProcessPackage/Processes/Proce
QUserTask
%UserTaskz
%UserTaskS

Remove

Clear

< | > < - | >

| platfarm:jresource/Tes. ..es{ProcessPackage. xpdl _ platform: fresour. . cessPackage. xpd|

Ik ] [ Cancel

2. Select the tasks that you want to include in the group and click OK.

3. Once you have selected the task group members, you can also use the following
buttons:

* Use this button to add or remove tasks to and from the group.

* Use this button to either delete tasks for the group or delete the group.
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ﬁ Note: To see other task groups, click the See all task groups(s) in
the process link on the Resources tab. This displays the Task
Groups tab for the process. This shows task groups of which this task
is @ member.

Specifying that tasks should be part of a Retain Familiar
group using the Task Groups Tab

Specify that tasks should be considered separate on the Task Groups tab for the process.
If you have already set up a task group, the Task Groups tab shows the groups contained
in the selected process.

Procedure
1. Select the process in the Project Explorer and click the Task Groups tab.

Click the button to create a new task group. The Select Tasks dialog box is
displayed.
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-
M sSelect Tasks

Select a type (7 = any character, * = any strin -+ —Eiackion

| | | -“QLIserTask - ProcessPackage/Proces:

Matching items:

ia ManualTask - ProcessPackage/Processes/Proce
%UserTask
%UserTaskZ
%UserTaskS

¢ | » < | »

platform: /resource/Tes., . . esfProcessPackage, xpdl platForm: fresour, . cessPackage. xpdl

Ik ] [ Cancel

2. Select the tasks that you want to include in the group and click OK.

3. Once you have selected the task group members, you can also use the following
buttons:

* Use this button to add or remove tasks to and from the group.

* Use this button to either delete tasks for the group or delete the group.

Chained Execution - Multiple Parallel Paths in a
Chaining Group

When multiple parallel paths exist in a chaining group, items are chained in the order they
are scheduled, and not the order of process flow.

For example:
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Embedded Sub-Process E|

——0

End Event

fr B
©— B | | B
| | ;
Start Event User Task 1 | User Task 3

G, JO I, |

| User Task 2 | UserTask4

In the example above, User Task 1 or User Task 2 would be performed first. Both would
appear in the relevant user's work list. If User Task 1 was opened first then on completion
User Task 2 would be performed (it would be the only user task in the chained group
available at that point). It is likely that whilst User Task 2 is completed that User Task 3
would be scheduled. This would be performed and then User Task 4 would be performed
last. The user tasks would therefore be performed in scheduled order and not according to
the connections between the user tasks.

Events

This section describes some of the common tasks that you perform using BPMN events.

See the "Events" topic in the TIBCO® BPM Enterprise Concepts Guide.

Creating References Between Throw and Catch Events

As an alternative to creating references between throw and catch events in the Properties
view, TIBCO Business Studio provides graphical tools called gadgets that allow you to
easily create references.

The example in this section shows throw and catch signal events, but the same procedure
applies to all throw and catch events.

Procedure

1. Place the throw and catch events on the diagram.

2. Select the throw event.
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rJ

3. Drag the event reference gadget to the desired catch event.

Be—3p-

4. Once you link a throw and catch event, you can click the event reference gadget to
go to the catch event, or drag the event reference gadget to select additional catch
events:

A Click bo go to signal catcher:
Drag-drop to select additional signal cakcher,

Timer Event Rescheduling

You can reschedule the timeouts of timer events on user tasks (including the work item
deadline). This can be achieved by selecting timers to reschedule from a non-cancelling
signal event on the same user task.

o Note: Timer events that have already timed-out are not rescheduled.

A catch signal event attached to a user task, that is configured as Continue task when
signal is caught allows selection of timer events to reschedule one of the following:

e all
e The Timer currently set as Activity deadline
» one or more explicitly selected timers

When a timer event is selected for reschedule in any one of the above ways then the user
must define a reschedule timer script on the timer event's General properties tab.

In the example below, the process has a user task with two timers, Deadline and Nudge.
When "Unexpected Delay" is triggered, the Allow_User_More_Time signal is thrown and
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this explicitly reschedules the Deadline timer by adding an extra day to the current
Deadline timeout.

Stot Process Data End Event

=5
I @ I
Pl ( : “\_-.. -

Catch: Deaglline  Muglge
Allow_User_More_Time

o T 1o

Send 'Nudge' To

User End Event 2

©) -®
Unexpected Throw
Delay Allow_User_More_Time

Cancelled End Event 3

The Properties page for Catch: Allow User More Time looks like this:

Label: tatch: Allow_User_More_Time
Mame:  CatchAllow_User_More Time

Trigger Type: _Catch Signal

o
Signal Mame:  Allow_User_More_Time

Catch Action: () Cancel task when signal caught @ Continue task when signal caught
Reschedule Task Timer Events
() None
@ Al
() Deadline

@ Selected Timer Events...  Deadline E]

The Properties page for Deadline looks like this:

Label:  Deadline » Initial Timer Script

MName: Deadline * Reschedule Timer Script
Trigger Type: | Catch Timer - Script Defined As: | Constant Period =
[l Use as activity deadline Durations Relative To: (7) Reschedule Time @ Current Timeout
@ Withdraw Task On Timeout () Continue Task On Timeout Specify timeout as offset from event initiation:
@ Date and/or Time () Cycle A g +| Hours: 0 2
Months: 0 = Minutes: 0 =
Description:
Weeks: 0 =| Seconds: 0 =
Days: 1 2 Micro Seconds: 0 =
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Configuring Timer Event Scripts

You can specify that a script is executed for a start timer event or an intermediate timer
event (either inflow or on a task boundary).

For example, the following intermediate timer event has been placed on a task boundary:

Task

In the Properties view, you can choose a script type from the Script Defined As list:

Note: Depending on the destination environments selected, there can be other
script types in the Script Defined As list.

Script Defined As: |Text " |

Constant Period

Scripk:

Select one of the script types:

e Free Text

If you want to leave the implementation of the script for the solution designer,
you can select Text and use this area provided to describe the desired behavior for

the script.

e Constant Period

This allows you to specify the timeout period after the event is initiated using the
following time units: Years, Months, Weeks, Days, Hours, Minutes, Seconds, Micro

Seconds.

e JavaScript
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This script type allows you to enter JavaScript statements in the space provided.
For more information, see the appropriate implementation guide.

Note: The JavaScript script type is not available in the Business
Analysis capability.
e Unspecified

This means that no description or script is supplied.

Catch Signal Events

In BPMN, when an event on the boundary of a task is triggered, the task is canceled and
the alternative flow from that event is followed.

For example:

Start Event End Event

In this example, if the signal event is triggered, the task to which it is attached is canceled
and the sequence flow to Task 2 is followed.

Throw and Catch Signal Events

With throw/catch signal events, an in-flow signal event broadcasts a signal, and if there is
an active task with a signal event on the task boundary, that event "catches" the signal,
and generally follows the exception path.

Signal events can be local or global.
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Local signal events can be used for triggering event handlers, task cancellations and to
halt and resume parallel flows.

Global signal events are thrown and caught across process instances allowing processes
to collaborate with each other. They are only available for an event sub-process/handler.

* You can drag-and-drop a global signal onto a process to create throw / catch events.

» A catch signal can cancel the task it is attached to or, for user tasks, can allow the
task to continue. If they are set to "continue" they cannot have an outgoing flow but
they can map data into the task that they are attached to and also reschedule timers
attached to the same task.

A Signal is transient: when it is thrown, if there is nothing to catch it at that moment, it is
discarded. It is not stored for later use.

Task 1

Throw Signal
Ewent

Task 2 completed
before Task 1 {i.e
before signal
Ehrown)

Signal

Cakch
enk

Evwd

Signial Thrown
whilst Task 2 in
progress

You might specify a signal name with a throw signal event. With a catch signal event, a
signal name is optional:

* If a catch signal event has no signal name specified, it catches any thrown signals in
the process (while the task it is attached to is active).

 If a catch signal event has a signal name specified, it only catches signal events that
throw the named signal.
When you specify signal names in the Properties view for signal events, you can use
content assist. This means for example, that if you have entered SIGNAL1 for a throw
signal event, when you specify the signal name for the catch signal event you can
press Ctrl+Space and the available signal names are displayed from which you can
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select one.

You can define whether you want to update a scheduled work item from a non-cancelling
signal event. Select from a pair of radio buttons directly beneath the signal name from the
Properties view of a catch signal event attached to a task boundary:

e Cancel task when signal caught

e Continue task when signal caught

Use the Map from Signal tab to map from the throw-signal's payload data (listed in
its interface tab) to the data associated with the attached user task.

See the example in Incoming Request/Global Signal Event Handlers in Business
Processes which demonstrates the use of event handlers and non-cancelling signal
events to update work item data.

A signal end event functions like any other inflow signal event, except that when one fires,
if there are more tasks that need to complete as the result of an exception flow, the
outstanding tasks complete; if there are no more tasks that need to be completed, the
process ends.

Throw and Catch Error Events

An error event attached to a task boundary can be set to catch any error, or errors
generated by the task to which it is attached.

Example:

» When attached to a web service task, you can configure the catch error event to
catch any WSDL fault associated with the web service operation that is invoked by
the service task.

» When attached to an email service task, you can configure the catch error event to
catch emails when the email server is unavailable:
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M Select Error To Catch } _ 10| x| bee (sara

Select an error thrown by a specific activity, .

[" Select Unspecific Error By Mame Snly

= @ Email Elas'vi-:e Task«Service Task:=
B EMAIL_ATTACHMENT FILE_NOT FOLND
""" EMAIL_SEND_COMMUMICATION_ERROR

EMAIL_SERVER_UMNAYAILABLE

EMAIL_LINEMNOWMN_HOST

EMAIL_UMKNOWN_RECIPIENT |
L

: L=
1 Thrown By: Email Service Task<Service Task: ELice (
E ¥

iy Erfor |
(7] Ik, I Zancel |

When attached to a call sub-process activity or an embedded sub-process task, the event
can catch errors thrown by any of the following events:

e Activities within the sub-process

e End error events

» Process interface error events (if the call sub-process activity references a process
interface rather than a process)

» Any other error throwing activity executed within the sub-process (including its sub-

process tasks). This includes activities whose errors cannot be caught directly by
attaching the error event.

Configuring Error Events

Error events are configured in the Properties view.

= Properties 52 [2 Problems | DF Fragmerits |

(O Intermediate Event

| =] General Label: | |
Descripkion

Marne: |

Interface
: Trigger Type: | Catch Errar

|
Scripks

Map Fram Errar Catch Error Code: | <Cakch &l | [Select Error... ] [Catch all ]
Appearance

Extended

. .ﬁ.civanced

=
[C1n s u]

Thrawn By ‘ <Ay Ackivity =
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In case of a catch error event, perform the following actions:

e Catch All Errors

(default) Catches any error thrown by any event.

e Catch Named Errors

To do this, click Select Error and select the Select Unspecific Error By Name
Only check box. The dialog box lists the catchable error codes. Select the error
codes that you want to catch. This configures the event to catch the selected error
from any activity.

e Catch Specific Errors from Specific Activities

Click Select Error and deselect the Select Unspecific Error By Name Only check
box. The dialog box lists events and activities that throw error codes. Expand the

desired event or activity to catch a specific error thrown by a specific activity. For
example:

r

N Select Error To Catch I;'E'E'

Select an error thrown by a specific activiky, ..

[ ]5elect Unspecific Errar By Mame only

= Embedded Sub-Process
=-(9) <Errar End Event =
: M Errorz
= G Service Task

1 Thrown By: Embedded Sub-Process | <Error End Event s

-r.':’} [ (0] 4 ] [ Cancel
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e Catch Specific REST Service Fault

REST service faults are caught in the same ways as other errors (either named
REST service faults, or specific errors from a specific service task). For example:

GET Customer

4 Select Error To Catch O *

] Select an error thrown by a specific activity...

[ Select an unspecific error by name only

v ‘%& GET Customer
N 404 (Unkown Customer)

i Thrown By: GET Customer

® Cancel

Error Data Mapping

You can map error parameters to process data from the Map From Error tab.

Example:

fe=| Properties 7 _[z; Problemsiog Fragments |

O Intermediate Event

General | Map Error Parameters to Process Fields | Parameters. ., Script Grammar: | Jav
Description _ \ 4ERRORCODE) D o l @ ErrRet (ErrRet)
Interface % Mew Script.., i@ Field2 (Field2)
Scripts : i@ Field3 (Field3)
= Map From Ertor @ Field4 (Field4)

The process data on the right side of the tab is either all data or a subset of data as
specified on the selection on the Interface tab.
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The content of the left side of the Map From Error tab depends on the configuration of the
General tab:

o Catch All / Catch Named Errors

Only the automatically provided error code can be used for mapping as shown in
the previous example. Typically, this error code is mapped to a process text data
field or parameter for display to the user. At run time, the text data field or
parameters is populated with the error code name when the error is caught.

» Catch Specific Error Thrown By Sub-Process End Error Event

All parameters with a mode of Out or In/Out that are associated with the throw
error end event (on the Interface tab) are displayed for mapping:

[3_, Problems OF Fragments @ Data Source Explorer | =] Properties 537
O Intermediate Event
General Map Errar Parameters to Process Fields | Parameters. .. Scripk Gramrat: |JavaScript
Lesaiton 1 A Error Code ($ERRORCODE) ® & Enderrl (EndErr1y
Interface I 2 Mew Script,.. f EndErrZ (EndErrZ)
Scripts f EndErrl (EndErrl) ========== (@ Addressi (Addressi)
e .Map From Error & EndErtz (EndErrz) @ Addressz (address2)
T e—— @ Address3 (ddress3)

- @~ @ ErrorReturn (ErrorReturn)
Extended - [ :

| = (@ Field2 (Field2)
Adwanced

e Catch Specific REST Service Fault

REST service fault payload parameters are displayed on the left side and can be
mapped as normal.

Compensation Events Configuration

Compensation events are used to reverse the effect of previously executed tasks.

For example:
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Skart Event

O——-

SLCcess

End Event:

Thiow

Re-creﬂ't Ak

Campensation

In this example,

if the credit/debit fails, a compensation event is thrown. The target of the

event is the Credit Acct task, which catches the error and proceeds with the Re-credit

Acct task. In the

Properties view for the Throw Compensation end event, you can press

Ctrl+Space to see a list of tasks from which you can select the target of the compensation.

Alternatively, you can compensate all previously executed tasks by not specifying a target
for the compensation:

£ Properties 53

() End Event

Descripkion
Scripks
..ﬁ.ppearance
Extended

..ﬁ.dvanced

| 7] General Label:

Result Type: | Compensation

(% Problems | Df: Fragments |

| Throw Compensation

Select specific task to compensate {no selection = compensate alli;

o
|

Credit Acck
Debit Acck
Re-credit Acck

Send/Receive Request Event Implementation

TIBCO Business Studio supports the following Message Exchange Patterns (MEPs).

MEP

Description How to Model

Receive a one-way request  The process receives an incoming Start request event (if the

from an external
application

request via the business process APl process is started on
from an external application and receipt of the request)
does not send a response.
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(Continued)
MEP Description How to Model
For more information, see the Receive task
Controlling flow from an external
application.

Send a one-way request to  The process sends a message to an  Send task

an external application external application but expects no
response.
Send a request-response A client (service consumer) sends a Service task
message to an external request message to the web service
application (service supplier).

The web service (service supplier)
returns a response message to the
client (service consumer).

The web service might optionally
return a fault message in the event
of an error.

Whether a message event performs a one-way operation or is part of a request-response
operation is configured on the Properties view for the events.

Event Handlers

Event Handlers are supported in Business processes and Pageflow processes. You can use
event handlers to execute a flow that is separate from the main flow of the process (for
instance to update process data used by the main flow).

See the "Event Handlers" and "Event Sub-Processes" topics in the TIBCO® BPM Enterprise
Concepts Guide.

Signal Event Handlers

An event handler flow can be triggered from within the same process instance using signal
events. The signal event handler flow can be executed asynchronously or synchronously
with the invoking flow (the invoking flow generally waits at the throw-signal event for the
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completion of the event handler flow before continuing). This allows process designers to
define and re-use complex sets of repeatable activities.

o Note: This could be especially useful when considering the additional tasks and
exception handling that are required by global data updates because each
update on a single piece of global data could involve several tasks (one to do
the update, plus exception handling if the update fails). Therefore, if many
updates are performed on global data, then the process could soon become very
cluttered with global data handling activities reducing the visibility of the actual
business process tasks. Use of the signal event handler could greatly reduce this
type of problem by allowing the process designer to implement the set of tasks
to update a global data item and handle exceptions only once and re-use that
from many places in the process.

End Event
= Handlary, Handler
Thread °, Thread Again

[ Task [ @
P i
Start Event R Imvoke, Invoke

Can be Synchronous or Asynchronous (i.e. wait for end of
_q &vent handler flow or FireAnd-Forget)

Signal Event End Event z

Handler

The catch signal event Properties tab contains Event Handler configuration controls (which
are shown only when the catch signal is an event handler (with no incoming flow).

The default setting is Wait at the invoking signal until event handler flow is complete.
This setting controls whether the throw signal's outgoing flow is processed after the event
handler flow. If you unset this flag it can be processed without waiting.

Note that:

 Signal event handlers can also be used within embedded sub-processes. Place the
signal event handler inside the embedded sub-process. This ensures that the
embedded sub-process local data is in scope of the signal event handler flow.

 Signal event handlers can be used within pageflow processes.
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e Case data signal event handlers allow a process to subscribe to a particular case
object that the process uses. The process then is notified if that case object is
modified, and can take appropriate action to respond to the change.

Using the Cancellation Event Handler

You can execute a cancellation event handler flow (only one per process) to manage the
cancellation of a process and its sub-processes.

Procedure

1. How to cancel a sub-process task: Attach a catch intermediate event to a call sub-
process task in your main process, with a trigger type of Catch Signal. The Catch
Action should be Cancel task when signal caught.

Alternatively, you cancel a process sub-process task with a task boundary event as

follows:

Timer:
Signal:

r—

==

Pocl
Lane

-/

Start Event

a

Do Some Operations And
Cancel Claim

Throw:
Cancel Claim

Erlnit\aliali

ze Claim
Amount

FH—0

End Event

Do Claim
Computaticns

= '
Lafich:
Cancel| Claim

End Event 2

| Properties i3

| General
Description

Data Fields
Scripts

Map From Signal

Data References

A

Ei‘u Problems | 25 Fragments & Data Source Explorer

(O Intermediate Event

Label: tatch:CanceICIaim
Mame:  CatchCancelClaim

Trigger Type: | Catch Signal

il
Signal Name: Cancel Claim

Catch Action: @ Cancel task when signal caught () Continue task when signal caught
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The tree of sub-process instances that were instantiated from a sub-process task are
canceled from the bottom up. If the sub-processes need to execute compensation
actions to close down gracefully they can do so using Cancellation Event handlers.

2. The Sub-Process Cancellation event handler: Add activities to perform any actions
required prior to the final sub-process cancellation. A common pattern would be to
use throw-catch compensation as in the example below, where there is an
intermediate catch event with trigger type Catch Compensation on each task in the
sub-process, which requires compensation events. Compensation events execute
their actions if only when the task they're attached to has been executed. Thus, there
is not a need to manually conditionalize compensating tasks depending on progress
through the main process flow.

o Note: Cancel event handlers are only executed for process-driven
cancellation (not for user/API-driven process cancellations).

o Note: The cancel event handler does not have to trigger compensation
event handlers. It might either generate signal events into the main part of
the process or just perform the compensatory actions directly.

=) Do &Do some
Computation2 user

Start Event End Event

I;_'I‘Do

Computation

Compehsation
Event2

i
i
i a Compen
. | sate for(Do
2 =
8 somgdiser
a2 &Com pen
sate for(Do
somgdiser
y SIE)F:E "“@ ™

Claim | Computations Do End Event 2
Cancelled compensation
of performed
tasks as the
claim was
cancelled

-

= Properties 22 B_ Problems| &5 Fragments ¥ Data Source Explorer

W
%

(O Intermediate Event

| General Label:  Catch Compensation Eventl
Description

Data Fields

Mame:  CatchCompensationEventl

Trigger Type: | Catch Compensation
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o Note:

» The sub-process can also invoke another sub-process (and so on)
with more cancel event handlers.

e There does not have to be a cancel event handler in each sub-
process if it is not required.

e Cancellation event handlers are not executed when a process
instance is canceled through Process Manager API, either from an
external application or from the Openspace client.

 If a cancellation event handler fails, then you receive an audit event
and should be able to recover from a halted state.

Event Handlers in Pageflows

You could use the event handler to update the process data. Another way to use it would
be to add to the runtime identifier array and associated input mapping arrays to add
instances to a dynamic sub-process invocation.

==
Ilpdate Exchange
Intermediate 4 R ates 2 End Event 2
Ewvent
— Collect Payment —
Skart Event COrder Request Dk ails Issue Invoice End Event

In this example, a pageflow process is used to manage an order request. The event handler
is used to update exchange rate information regularly. This updated exchange rate
information is then used as input to the task Issue Invoice.

Incoming Request/Global Signal Event Handlers in Business
Processes

Incoming request event handlers allow you to process a separate flow in an existing
process instance via a runtime process REST API call. As with any incoming request activity,
correlation to a process instance is done using the runtime process instance ID.
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o Note: Catch Global Signals have event handler controls similar to those of catch
incoming request event handlers and the behavior is the same as that of catch
incoming request event handlers.

Blocking and Non-Blocking Incoming Request Handlers

You can configure what happens when an event handler is triggered prior to completion of
the flow from a previous triggered instance.

The following configuration options are available:

» Blocking: The Serialize concurrent flows for this event handler option means that
further event triggers are queued until an existing event handler flow completes
(unless the main process flow completes).

* Non-blocking: The Allow concurrent flows for this event handler option means
that if the event is triggered multiple times, the flow from each can be processed in
parallel.

The configuration options are shown under Event Handler in the following image:

() Intermediate Event
I

|| General Label: | Event Handler|

Description Mame: |EventHandler

Inkerface

Data Fields rEvent Handler

Input Ta Pracess {2} Serialize concurrent Flows For this event handler

Scripts 2 allow concurrent Flows For this event handler

Data References Intitializers:

Aippearance StartEvent | EI

Exvtandad

Initializing Event Handlers

For global signal event handlers, you must specify a list of activities after which the event
handler can be initialized (or reset if already initialized). You need to do this because if the
value of correlation data associated with the event handler is changed during the life of the
process then existing event handlers are not triggered according to the new correlation
data value unless they are initialized.
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Select initializers for the event handler using the Initializers: selection under Event
Handler (as shown in the image). You can select any task, embedded-sub-process or event
activity (except those attached to task boundary, or events that are themselves event
handlers). This includes activities on event handler outgoing flows.

If you do not specify any activities then the event handler initializes during processing of
the first start-activity, but before the start-activity's Complete script. For this to happen one
of the following conditions must be met:

e The correlation data associated with each event handler must be initialized in
correlation data mappings in each start activity.

* You must explicitly state the activities after which the event handler(s) are initialized.
Once any activities are explicitly stated in this way, then the event handler is only
initialized after those activities complete.

Even if the correlation data is initialized in the complete script of a start activity, if
you wish an event handler to initialize correctly you must use this method of
explicitly stating the initialize-after activities on each event handler (that is, if the
event handler is to be initialized at start of a process instance then the start activity
must be explicitly stated).

Example: Using Event Handlers in a Business Process

The following example illustrates the process of updating work item data using an event
handler and a non-canceling signal event.

In this example, a business process is used to manage a request. The event handler is used
to update information related to the request. This updated information is then used as
input via a non-canceling signal event to the task Register Request.
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£y

Register Request
Mew Request uz:\\

Catch local
signal
reschedules
work item
with updated
data

o

Update Data Throw local
Global Signal update data
Received signal

Migration and Upgrade when using Event Handlers

There are certain issues regarding event handlers that you should be aware of when

migrating and upgrading.

Migration:

See Design Considerations for Process Migration for information on process migration

considerations when using event handlers.

Upgrade:

Adding, deleting or modifying event handlers from which web-service operations are
generated affect the interface and therefore prevent upgrade, but subsequent event

handler changes are valid.

Event Sub-Processes

An event sub-process executes an internal sub-process when an event is triggered. You can
use event sub-processes within business processes and pageflows.
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Collapsed form:

! Event Sub-Process =

' & Update '
i @ invoice data ]

Mew data
1 global signal d
received :

Expanded form:

Note: Event sub-processes and event handlers provide similar functionality. See
the "Event Handlers" topic in the TIBCO® BPM Enterprise Concepts Guide.

Ensure the following details when using event sub-processes:

A process can contain zero or more event sub-processes of any supported type or
configuration.

e Each event sub-process must start with a single start event.

 There is no in-process communication between event sub-processes (sequence flow,
signals and so on).

You can use event sub-processes with the following start events:

e Event Sub-Processes placed in a Business process: Incoming Request Start Event and
Signal Start Event

» Event Sub-Processes placed in a Pageflow: Signal Start Event and Type None Start
Event
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Business processes support interrupting/non-interrupting event sub-processes.

o Note: Pageflows support non-interrupting event sub-processes. They do not
support interrupting event sub-processes.

This is defined on the start event of the event sub-process by checking Interrupt Process
Flow or Continue Process Flow. This affects the process as follows:

Interrupt Process Flow:
o Note: An interrupting event sub-process start event has a solid border.

e The main process flow is suspended until completion of the event sub-process.

» This does not affect the processing and completion of individual activities that are
already in progress related to the process instance. However, those activities'
outgoing flow is not processed until the event sub-process completes.

» This does not affect the processing of other event handler flows, event sub-processes
and ad-hoc activities.

» This does not affect the processing of activities in active reusable sub-processes.

e Incoming events, submits, sub-process completions and so on in the main process
are preserved but ignored until the event sub-process has been completed.

Continue Process Flow:
o Note: A non-interrupting event sub-process start event has a dashed border.

e The main process flow is not suspended during processing of the event sub-process.

 All activity can continue as normal.

Sub-Process Call Tasks

This section describes how to work with sub-processes in TIBCO Business Studio.
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Creating Call Sub-Processes

There are several different ways of creating a call to a sub-process:

You can create a call to a sub-process:

» By refactoring objects in your process (see Creating a New Embedded Sub-Process).
» By dragging a process from the Project Explorer and dropping it onto your process
(described in this section).

e Using the call sub-process activity tool from the palette (see Refactoring Activities
into a Sub-Process).

o Note: If you modify a sub-process (for example, by adding a parameter)
and that sub-process is referenced by a main process in a different
package, validation in the main process does not occur until you save the

sub-process package.

Creating a Call Sub-Process Activity Call Using drag-and-drop

Procedure
1. Expand the Project Explorer to locate the process that you want to be the sub-

process.

2. Click the intended sub-process, holding down the mouse button, drag the pointer to
the calling process (open in the Process Editor), and release the mouse button.

Note: You can select multiple processes for drag-and-drop operations
using the Ctrl key.

3. If you are dropping more than one process, a menu is displayed with two options:

e Create Sub-Process Task Sequence

Selecting this option allows you to create sub-process tasks connected by
sequence flow. A dialog box is displayed to allow you to control the order of
the tasks: Use the Move Up and Move Down buttons or drag-and-drop to
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control the order of the tasks. When you are finished, click OK to place the
tasks.

e Create Unsequenced Sub-Process Tasks

Selecting this option places the tasks in the process without a connecting
sequence flow.

Creating a call sub-process call using the palette

Procedure
1. In the Process Editor, select the call sub-process tool.

2. Click in the process where you want to place the activity that calls the sub-process.

3. On the Properties view for the activity, browse for the process you want to call as a
sub-process.

Note: If the process you select is not in the current project, you are
prompted to create a project reference.

Call Sub-Process Example

The following example demonstrates how a top-level process could use sub-processes in
an insurance environment.

8 i 8
O—b notification of loss M Claims management —DO

2] (=

Each of the activities in the process calls sub-processes that are executed in the runtime
environment. For example, the sub-process called from the Claims management activity
could look like this:
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O—

gg Validate

Policy
[

gg Hssess
liability | )
[
End Event
%Pmcess
claimant

Note the following about this sub-process:

e The Validate Policy sub-process can be re-used. For example, when a customer calls
to renew their policy, the first step of the Renewal Process could be to confirm that
they have an existing policy. The Validate Policy Activity could be re-used for this
purpose in the Renewal process.

e The Process claimant activity has a Loop Activity Marker, that indicates that the

activity is repeated for each Claimant.

e The actual sub-process called by the Assess liability activity is a manual Process.
However, the to be sub-process (planned for the future), could be implemented as an
automatic process that consists of a series of questions used to determine liability.
Simulation could be used to demonstrate the performance and cost-savings of
migrating the Assess liability activity to an automatic process.

Expanding a Sub-Process

You can expand a sub-process associated with an activity.

An activity that calls a sub-process looks like this:

gg Hszess

iability
H
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To expand the sub-process associated with this activity, either click the plus symbol, or do
the following:

Procedure
1. In the Process Editor, select the activity that calls the sub-process.

2. In the Properties view, select the General tab.

3. Click Open Sub-Process:

Irwocakion of Sub-Process: (Open Sub-Process )

Sub-Process location: | MyProcessPackagel . xpdl

Sub-Process name:; My Process...

4. The sub-process opens in the Process Editor.

Configuring a Sub-Process

You can configure the sub-process invocation mode, and whether it should execute
immediately or be queued.

Use the Lifecycle option, on the General tab in the Properties view to select the invocation
mode from the following:

e Synchronous
» Asynchronous Attached
¢ Asynchronous Detached

For definitions of the different types of invocations, see "Synchronous and Asynchronous
Sub-Process Invocations" in TIBCO® BPM Enterprise Concepts Guide. There are a number of
restrictions that are indicated via validation problem markers.

You can access the process-id of the new process instance as a sub-process output
mapping. This is mappable to a string-typed field or parameter.

o Note: You cannot map from sub-process output parameters when invoking
asynchronously because the invoking process does not wait for the sub-process
to complete and return.

Use the Lifecycle option, on the General tab in the Properties view to select whether the
sub-process should execute immediately or whether its start request should be queued.
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» Select Schedule Start Request to set the initial priority for the queued sub-process
start request and the tasks within that using the options in the Priority radio
buttons.

» Select Start Immediately to set the priority of the task within the process in the
process Resource tab. See Prioritizing a Scheduled Reusable Sub-Process.

o Specify whether sub-process instances should suspend and resume when the parent
process is suspended or resumed by selecting or deselecting the Suspend/Resume
Sub-Process With Parent Process check box.

= Lifecycle...

Invocation Mode: @ Synchronous () Asynchronous Detached () Asynchronous Attached

Start Scheduling: (@ Start Immediately () Schedule Start Request

Inherit From Parent process

Low (100)

Mormal (200) (default for main processes)
High (200} (pricritize over rmain processes)
Higher (400)

Custorn (100-400):

Suspension: Suspend/Resume Sub-Process With Parent Process

Prioritizing a Scheduled Call Sub-Process

Call sub-processes configured to Schedule Start Request are started with the default
priority at which a main process is started.

This means they might be queued behind a large number of main processes already
waiting to be executed. In this case you might want to prioritize call sub-processes in a
process.

Procedure

1. Use the drop-down from the Priority field from the Resource tab for the call sub-
process. Set one of the following priorities:
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Priority: Higher {400}

High {300} {prioritize over main processes)
Inhetit From Parent process
Mormal (2007 (defaulk for main processes)
Low (100}

Invoking a Sub-Process Asynchronously

You can create asynchronous sub-processes from a process to allow you to run sub-
processes independent of the main process, when you are not concerned if they complete

before the main process.
See the "Synchronous and Asynchronous Sub-Process Invocations" topic in the TIBCO® BPM

Enterprise Concepts Guide.

Procedure
1. Create the main process containing a call sub-process activity.

2. On the Properties for the call-sub-process activity, use the Lifecycle option, on the
General tab in the Properties view to select Asynchronous invocation mode.

3. Click on the [ sign on the call sub-process activity to open the asynchronous sub-
process in a new window.

4. Create the content of your asynchronous sub-process.

Embedded Sub-Processes

To create an embedded sub-process, refactor one or more objects in your process

See Creating a New Embedded Sub-Process.
o Note: If you want to use the chained execution resource pattern, you can do so
by selecting the Chained Execution check box in the Properties view for the

embedded sub-process. For more information, see Chained Execution- Multiple
Parallel Paths in a Chaining Group.
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Adding Local Data Fields

You can add data fields that are local to a sub-process (they are not used in the process
that contains the embedded sub-process).

By default, activities in the embedded sub-process have access to all local data and
process data. However, using the Interface tab, a subset of data can be selected.

Procedure

1. Click the Data Fields tab in the Properties view for the embedded sub-process.

2. At the right of the Data Fields tab, click the plus sign to add local data fields. The
properties of the data fields that you create are the same as for process data (see
Adding Data Fields or Parameters to a Package or Process).

o Note: Local data fields are not displayed in the Project Explorer.

For example:

[;_L, Problems c}r; Fragments ﬁ Daka Source Explorer | = Properties 3

(] Embedded Sub-Process

General | | Label Mame Read Only Tvpe Length

Diescription || @ Status Skatus D Teut e

O Data Fields I8 Skatusz Statusz D Deciral Number 10

corit @ Status3 Status3 Text 50
Sl @ Field Field ¥ Text 50

Appearance |

In this example, the data fields Status, Status2, Status3, and Field are local to the
embedded sub-process. On the Interface tab for activities within the embedded sub-
process, you can access the local data as well as the process data:
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&

& Select Data Field or. Formal Parameter

Select a bvpe (* = anv character, * = any string): w

Matching items:

@ Address1 (Address1) - ProcessPackage/Embed/Data
@ Addressz (Addressz)

@ Address3 (Address3)

@ Field (Field)

(@ status (Status)

i@ Stakuse (Stakusz)

(@ Statuss (Status3)

Selection:

Remove

Clear

< | B

JEmbedded]Pracess Packages/ProcessPackage. xpdl

2] [ 0K H Cancel ]

In this case the address data fields (process data) and the local data defined on the
Data Fields tab are both available.

° Tip: You can quickly create an embedded sub-process that has local data
by using the fragment BPMN Process Fragments > Basic Fragments >
Embedded Sub-Process with Data Fields. For more information about
fragments, see Creating Call Sub-Processes.

Local Data Fields in Loops

When using local data fields in loops, the value taken by the local data field during each
iteration depends on the type of loop.

Multi-instance loop

Each instance of a multi-instance loop has a separate instance of the local data field,
allowing parallel loops to execute without interfering with each other. However, the local
data fields cannot be used in the loop expression.
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Standard loop

The local data field is shared between all instances of a standard loop. It can be used to
pass data between instances, and can be used in the loop conditional script.

Note: You cannot initialize a local data field prior to the first "Before" condition
test.

Note: For both multi-instance and standard loops, the task initiate script runs
just before executing the task for each iteration of the loop.

Creating a New Embedded Sub-Process

You can create a new embedded sub-process by refactoring existing objects into an
embedded sub-process.

Procedure
1. Select the objects that you want to put in the embedded sub-process. For example:

Skart Eventi E End Event

2. Right-click and select Refactor > Move into New Embedded Sub-Process.
3. Complete the dialog box as follows:
a. Enter a name for the embedded sub-process that you want to create.

b. Select the New Sub-Process is a transaction check box if you want the new
sub-process to become a transaction and therefore be under transaction
control (see User Tasks and Pageflow Processes).

c. Select the Insert start event in new sub-process and Insert end event in
new sub-process check boxes to control whether start and end events are
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added to the refactored sub-process.

4. Click Finish. The objects that you selected are placed within a new embedded sub-
process (with start and end events if those options were selected):

Skart Event

Indepe

Pr

End Event

Refactoring Activities into a Sub-Process

You can create a new call sub-process activity and sub-process by extracting existing

objects.

Procedure

1. Select the objects that you want to put in the sub-process. For example:

Skart Event:

End Event

In this example, the two user tasks have the following parameters (two data fields

and one formal parameter):
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[ Task
General wisibility: (8 Private O Public
Farm
— * Paramelers

Descripkion

Select a subset of data that is accessible For this activity,
ZZ. Interface . . ]

O o interface data association required.
Data Fields

Process Data Name | Mode | Mandator
Resource =
e = Paraml In M
hs @ DF1 In f Out [l

Data References @ DF2 In | Out |:|

The user tasks also have a participant associated with them.

Select all three tasks.
2. Right-click and select Refactor > Extract into New Sub-Process.

3. Because the data fields and participants are only referenced in this activity (and not
used by any other activities), the following message is displayed:
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 Refactor As Reusable Sub-Process

Canfirm configurations and resalve problems.

[#] @ Move data field 'DF1' to new sub-process (else map to sub-process formal parameter)
O Mave data field 'DF2' ta new sub-process (else map to sub-process Formal parameter)
=-[#] & Move all referenced participants to new sub-process (else duplicate)
& Move participant MyParticipant’ ko new sub-process (else duplicate)

These data fields are referenced only in the selected objects.

- Check box ko mave data Fields to new sub-process.
- Uncheck box ko create as formal parameter in news sub-process and map original Field ko it,

|
|
(=PI ®Y e all referenced data Fizlds bo new sub-proce: s duplicake)

|
|
) < Bark Ficich
\2) < Back Mext = Finish Cancel

» For the participant, TIBCO Business Studio gives you the option of either moving
this participant into the sub-process, or duplicating the participant in both the
parent process and the sub-process.

» |If you select the data fields, they are moved into the sub-process.

» If you do not select the data fields, they are created as formal parameters in the
sub-process (and mapped to those formal parameters).

4. Complete the dialog box follows:
a. Enter a name for the sub-process that you want to create.

b. Select the New Sub-Process is a transaction check box if you want the new
sub-process to become a transaction and therefore be under transaction
control (see User Tasks and Pageflow Processes).

TIBCO Business Studio™ - BPM Edition Modeling Guide



99 | BPM Packages and Processes

c. Select the Insert start event in new sub-process and Insert end event in
new sub-process check boxes to control whether start and end events are
added to the refactored sub-process.

5. Click Finish. The objects that you selected are copied to the new sub-process and the
selected objects are replaced with a task that calls the call sub-process.

Skart Event End Exvent

Indepegﬁnt Sub-
Process

If you chose to create formal parameters for the data fields, you can see them in the
Project Explorer, under the sub-process:

li_'l QS Reusable Sub-Process (ReusableSubProcess)
; {_j Correlation Data
=~ & Parameters
% DF1 (DF1)
= DF2 (DF2)
: : 'Ep Paraml {Paraml)
() Data Fields
= %—a Participants
S8 MyParticipant (MyParticipant)

In addition, if you click the task in the parent process that calls the sub-process and
go to the Properties view, you can see the mappings that have been created between
data fields and formal parameters of the parent process and the formal parameters
created in the sub-process. For example:

E Properties 82 [g_\ProbIems'DgFragments. ;% =750

[ Reusable Sub-Process

General

. E, Map To Sub-Process

IMap From Sub-Process

Appearance

| Map Fields to Formal Parameters

Seripk Grammar: |JavaScript .

Description Itype filter text i Itype filker kext i
Interface 00 Mew Script.. @ & DF1 (DFL)
Data Fields & Param1 (Param1) ® H o &, OFz (DF2)
Sc.ripts || @ DF1{DF1} ® ®- & parami (Parami)
~ (@ DFZ (DFZ) ®
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| Properties &4 [3_\ Problems_D{EFragments' G B - S

[ Reusable Sub-Process

E .Ge.nerai : Map Formal Parameters o Fields Scripk Grarnmar: 'Ia'-.-'a'fn:ri i v
| Description 1 %type filter ket i i_t}f'E?._ﬁ.l.tf.r..E?fEi_!
Jilretiace |00 New Soript., - Param! (Parami)

Data Fields &% DF1 (DF1) @ @~ @ DF1(DF1)

 Seripts 1| & Drz(DF2) ® @ (@ DF2(DF2)

Map To Sub-Process

| {.‘ Map From Sub-Process

Appearance

Result
Notes on Refactoring Objects into Sub-Processes:

e Formal parameters in the parent process are created as formal parameters in the
sub-process. They are mapped according to their mode as defined in the process API.

 If a data field is referenced only in the selection that you are refactoring, you have
the option of moving or copying it. Data fields that are copied into the sub-process
are created as formal parameters and mapped. Data fields that are moved into the
sub-process are created as data fields. By default, data fields are moved. In order to
copy them as formal parameters, you must deselect the selection boxes on the dialog
box.

 If a data field is referenced in one or more of the tasks you select for refactoring but
is also referenced elsewhere, it is automatically copied into the sub-process as a
formal parameter.

* A mapping is created between data fields and formal parameters of the sub-process
and any corresponding formal parameters that are created in the sub-process. You
can view this mapping by selecting the task that calls the sub-process and clicking
the Map To Sub-Process and Map From Sub-Process tabs in the Properties view.

Changes in Process Logic:

When refactoring objects into a call sub-process, you can potentially change the logic of
the process flow.

Consider the following process:
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B

ser Task 1

Task & % %
ser Task 2 ser Task 3

&

End Event

Skark Event

In this process, flow proceeds from User Task 1 to the gateway without necessarily waiting
for Task A to finish. If User Task 1 and Task A are refactored into a sub-process, an end
event is inserted into the sub-process, effectively synchronizing the flow. TIBCO Business
Studio prompts you to confirm this change to the process:
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& Refactor As Independent Sub-Process

Confirrn configurations and resclve problems.

= @ Multiple Entry | Exit Path issues {must be confirmed before you can continue)

[ ROk Lo imply join of multiple exit path ob ee highlighted Flows and objects in imag
=-F] & Move all referenced participants to new sub-process (else duplicate)

[18 move participant 'HR' ta new sub-process (else duplicate)

< [—

The refactor would cause an implied join of these objects on sub-process completion, This constitutes
a change in the pracess Flaw,

Check the box only if you wish accept this change and continue.

(A)R]

) < Back Mext = ] I Finish ] [ Caneel

Inline Sub-Process Content

This option creates an embedded sub-process from a call sub-process activity. The reason
for making a call sub-process inline is that in some cases the tasks in the sub-process
execute relatively quickly and the overhead of invoking a sub-process can be comparatively
high.

Refactoring a Call Sub-Process into an Embedded Sub-Process

You can refactor a call sub-process activity into an embedded sub-process.

Procedure
1. Right-click the call sub-process activity, and select Refactor > Inline > Sub-Process
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Content.

o Note: Only a single level of a process hierarchy can be made in line at a
time. If the sub-process you want to make inline contains a sub-process
task, after refactoring, it is brought into the embedded sub-process as a
sub-process task (the refactor does not extend into additional levels of the
process hierarchy).

2. The sub-process called by the selected task is analyzed, and a dialog box is displayed
with the results:

» If there are no problems with the refactoring operation, a dialog box is
displayed. Select Inline into Embedded Sub-Process and click Finish.

» |If there are problems with the refactoring, but the problems can be resolved by
making the sub-process inline, a dialog box is displayed showing the problems:
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ﬁ Note: The possible problems displayed in this dialog box are similar
to those for process package optimization, except that some of these
problems that are not resolvable for package optimization are
resolvable by refactoring into an embedded sub-process (such as
those reported in the previous dialog box).

M Refactor: Inline Sub-Process Contents

Select Options / Yiew Problems

@ Zurrent configuration of sub-process and independent sub-process task requires
that the content is in-lined into an embedded sub-process,

=[] Inline Into Embedded Sub-Process
|:|°8 The sub-process start event has multiple outgoing sequence Flows
DC’S The sub-process end event has multiple incoming sequence Flows

This problem can be resolved by selecting toinline into an Embedded Sub-Process

Zancel

Also, problems dealing with nesting of sub-processes are not
applicable because manual refactoring affects only a single level of
sub-process hierarchy at a time.

You can see the location of each problem by highlighting it. If you select all of
the problems in this dialog box, the Finish button is enabled and you can
refactor the sub-process.

» If there are problems that cannot be resolved by refactoring, a dialog box
similar to the following is displayed:
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-
™ Refactor: Inline Sub-Process Contents

Select Options / View Problems

@ Zannot inline sub-process content because of problems that cannok be
automatically resolved,

Zannot inline sub-process content because of irresolvable problems. ..
[18 The sub-process has multiple poals

There Are Problems That Cannot Be Automatically Resalved

Cancel

Because the errors cannot be resolved, click Cancel, resolve the problems
manually, and retry the refactoring.

3. If the sub-process was able to be refactored, its contents are placed in an embedded
sub-process, however the sub-process that was made inline is not removed.
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Result

Note: The following are potential consequences of a refactoring. For more
information, see Inline Sub-Process in Detail:

o References to sub-process parameters in the sub-process content are
swapped for the calling process data fields that are mapped to them.

» Sub-process data fields and unmapped parameters are copied up to the
calling process and renamed with a sequence number if the data field or
parameter already exists in the calling process.

» Sub-process participants are copied to the calling process (if they do not
already exist).

» Type declarations referenced by data copied up from the sub-process are
copied to the package of the calling process only if the sub-process is in a
different package.

 If the sub-process implements a process interface (see Process Interfaces),
the start or intermediate events that implement interface-defined events
are changed so that they are no longer flagged as such.

Inline Sub-Process in Detail

This section describes in detail what happens when you use an inline sub-process
(including its parameters, participants, and so on).

Data Fields and Mapped Parameters

References to parameters in sub-processes are replaced according to the parameter
mapping.

For example, consider the parameter mapping to the following sub-process:

[ Independent Sub-Process

General Map Fields to Formal Parameters Script Grammar: | Javascri
Extended 0 Mew Script... -._’-——/___—‘—.-' = ReFhurm
%, Map To Sub-Process @ EEEEE - e

The data field CustRef in the parent process is mapped to RefNum in the sub-process. In
the sub-process, the parameter RefNum is used by the single user task:
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2

Start Event User Task End Event

£

= Properties &3 [L Problems Dr Ciagram Fragments

(] Task

FE— visibility: (%) Private () Public

Description | pata:

% Interface .F;rcu:ess Daka Mame rode
4= RefUm In J Quk

Fesource

After refactoring as an inline sub-process, the user task is brought into the main process
with RefNum as its parameter.

o Note: Every effort is made to ensure that when a sub-process is in lined, it is
semantically the same as if it were not in-lined. However, not every potential
scenario can be catered for.

For example, if the same calling-process field is used in the parameter mappings
for two parallel call sub-process activities, the calling-process field now can be
used in-parallel in the two sets of sub-process contents that were moved up into
the calling-process. This might have undesired effects.

Sub-Process Data Fields and Unmapped Formal Parameters

Sub-process data fields and unmapped formal parameters are moved up to the calling
process after refactoring. In order to preserve the original semantics of the sub-process,
any data fields or unmapped formal parameters in the sub-process that also exist in the
calling-process are renamed (each new instance of the same named data is suffixed with a
sequence number). Any references to the renamed sub-process data are updated when the
sub-process activities and flows are moved up to the calling process.

o Note: Package-level data fields are not included in this behavior unless the sub-
process is in a different package to the calling process.
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For example: A sub-process has a data field called CustomerField which its activities use
internally. The calling process also has a field called CustomerField which it uses internally.

When the sub-process is in-lined, the sub-process CustomerField is copied into the calling-
process as CustomerField2. All references to CustomerField in sub-process activities and
flows are replaced with references to CustomerField2.

Multiple Calls to a Sub-Process

This rule also applies when several sub-processes are called from a single process. If the
sub-processes have the same data fields names, then each invocation causes separate,
sequence-numbered instances of data fields in the calling process when they are made
inline.

For example: There are two calls to the same inline sub-process from a single calling
process. The sub-process has a field called CustomerField.

The copy of sub-process activities and flows ‘moved up’ in place of one call sub-process
activity operate on CustomerField and the other operate on CustomerField2.

Field Name Conflicts

This rule also applies when inline sub-processes are nested, and have conflicting field
names.

For example: The calling-process (MainProcess) calls an inline sub-process (SubProcess)
which in turn calls a nested inline sub-process (SubSubProcess).

Each process has a field called CustomerField.

e SubSubProcess is in-lined into SubProcess so that its instance of CustomerField
becomes CustomerField2 in SubProcess.

* SubProcess now has 2 fields, CustomerField and CustomerField2. When this is in-
lined into MainProcess CustomerField in SubProcess is dealt with first (alphabetically)
and is therefore renamed as CustomerField2 in MainProcess.

* Now when the SubProcess field CustomerField2 is subsequently copied into
MainProcess, a CustomerField2 already exists so it is renamed as CustomerField3.
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Sub-Process Participants and Type Declarations

Participants are moved up to the calling process if the calling process does not already
have a participant with the same name. If the Participant already exists in the calling
process, references to the sub-process participant are exchanged for references to the
calling process participant in the sub-process content that is moved up.

Similarly, type declarations (that are referenced by sub-process data fields and unmapped
formal parameters) are moved up to the calling process if the calling process does not
already have a type declaration with the same name. Otherwise, the calling-process type
declaration is used.

Creating Dynamic Sub-Processes

A dynamic sub-process can be created by modifying a call sub-process activity.

See the "Dynamic Sub-Processes" topic in the TIBCO® BPM Enterprise Concepts Guide.

Procedure

1. Create a process interface that specifies the start event and its input or output
parameters. Each process that is to be invoked from the dynamic sub-process task
must implement the same process interface. See Process Interfaces.

2. Create one or more call sub-process activities in your process.
3. From the General tab for each call sub-process activity:
a. Using the picker, select the process interface created in step 1.

b. In the Runtime Identifier Field select a formal parameter or data field using the
picker. This must be a text field or an array. Arrays can be used for multi-
instance sub-process tasks where potentially different sub-processes are
required for each instance of the same task.

D Is A Transackion
Imvocation of Sub-Process: (Open Sub-Process )
Sub-Process location:

Sub-Process name: BookAppointmentInterface (BookAppaointmentInkerface)
Funkime Identifier Field: | ProcessIdentifierar |:

4. Initialize the Runtime Identifier Field. For example, for a multi-instance sub-process
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task you could create a Script task before it to populate the array data field with a
sub-process name element for each task instance. For a single instance sub-process

task simply set the runtime identifier field to the required sub-process name in a
script prior to the task.

For a sub-process implementation which resides in an external sub-process library.,
you could use a script something like the script shown in the following illustration:

Script Defined As: | Javascript  w

Describe Task Script:

if (data.type == "one") {

data.runtimeID = "/APPE/Process Packages/APE.xpdl.APEEProcess";
} else if (data.type == "one") {
| data.runtimeID = "/APPE/Process Packages/APE.xpdl.APEEProcess2”;
¥

5. In the call sub-process activity, map data to and from the called process (to pass
data between the process and sub-process):

e Map the input to the interface in Map To Sub-Process.

e Map the output from the interface in Map From Sub-Process.

For example:

] Properties &3 [& Problems OE Fragments} m Data Source Explorerw ‘%3 - K 7
(] Reusable Sub-Process
General Map Fields ko Formal Parameters Script Grarmmar: | Java5y
Description |type filker text bype filker text
Interface 30 Mew Script... = @~ & pddressFirstLine {AddressFirstline)
DataFields || @ Addressistline (Address1stline) b ] Qﬁ(, ApptTime (ApptTirne)
Loops | © ApptTimedrr (ApptTimedrr) [] @ o Dept (Dept)
| ® BloodTestAppointment (BloodTestAppai * ﬁ, FHarme (FMarme)
x o T | @ BloodTestComments (BloodTestCommer * ﬁ, Gender (Gender)
= Map To Sub-Process | © @ Complaint {Complaint) - E, LMame (LMame)
Map From Sub-Process || . @ Deptarr (Deptarr) [ * @ '§> Postcode (Postcode)
Appearance || o @ Field (Field)
Extended || @ Fieldz (Field2)
advanced || 7 @ FMame (FMame) @
""" @ Gender (zender) @
""" @ LMame {LMame) @
""" @ MeedBloodTest (MeedBloodTest)
""" @ NeedxRay (Meed¥Ray) b
""" @ PostCode (PastCode) ®
""" @ Processldentifierar (Processldentifierar v |
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Automatically Passing Different Data to and from Sub-
Process Instances

If the call sub-process activity is multi-instance (or loop) it is possible to automatically pass
different data to and from each separate sub-process instance.

Inputting Different Data to Each Sub-Process Instance

Procedure

1. Specify an array data field that matches the type of a non-array sub-process/interface
input parameter.

2. In a script prior to the sub-process task, populate this array data field with different
data for each sub-process instance. For example:

e appointmentTypeArray.set(0, "X-Ray");
e appointmentTypeArray.set(l, "PlasterDept");
e appointmentTypeArray.set(2, "Physio");
3. In the "Map to Sub-Process" property tab, map the array data field to the non-array
sub-process/interface parameter. The sub-process invoked from each instance of the

task receives the list element corresponding to the instance index of that task. For
example:

» The first instance (activity loop index=0) receives the data "X-Ray" into its
"appointmentType" parameter.

e The second instance (activity loop index=1) receives the data "PlasterDept" into
its "appointmentType" parameter.

e The third instance (activity loop index=2) receives the data "Physio" into its
"appointmentType" parameter.

Returning Different Data from Each Sub-Process Instance

Procedure

1. Specify an array data field that matches the type of a non-array sub-process/interface
output parameter.
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2. In the "Map From Sub-Process" property tab, map the output parameter to that array
field.

At runtime, the array field is populated with the return data from each sub-process
instance. The list element index corresponds to the activity loop index from which
the sub-process instance was invoked.

For example, if the sub-process returned an integer parameter "ReturnParam" with
value "X-OK" when passed "X-Ray", "PL-OK" when passed "PlasterDept" and "PH-OK"
when passed "Physio", and you mapped this to an array data field
"ReturnArrayField", then:

e ReturnArrayField.get(0) is "X-OK"
e ReturnArrayField.get(1) is "PL-OK"
e ReturnArrayField.get(2) is "PH-OK"

Result
The way that this data is passed behaves in the same way for multi-instance statically
defined sub-process tasks (tasks that reference an actual sub-process at design time).

Control of the Flow in Dynamic Sub-Processes

The flow of processing within dynamic sub-processes can be controlled using the facilities
for controlling flow in a process.

See Controlling Flow in a Process.

In particular you can specify whether multiple instances of the sub-processes should be
performed sequentially or in parallel by using the Ordering and Flow Condition fields of
the Call Sub-Process activity. See Creating a Standard Loop for more details.

You can also add additional instances to the loop while the sub-process is running, using a
script on a parallel processing path. For details, see Adding Additional Instances to a Multi-
Instance Loop Task Whilst the Task is in Progress.

Making a Sub-Process Call to a Process Interface

There are two different ways of creating a call to a process interface.

» By dragging a process interface from the Project Explorer and dropping it onto your
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process.

» Using the call sub-process tool from the palette.

Creating a Call Sub-Process Call using drag-and-drop

Procedure
1. Expand the Project Explorer to locate the process interface that you want to
implement.

2. Click the process interface, holding down the mouse button, drag the pointer to the
calling process (open in the Process Editor), and release the mouse button.

Note: You can select multiple processes for drag-and-drop operations
using the Ctrl key.

3. If you are dropping more than one process interface, a menu is displayed with two
options:
e Create Sub-Process Task Sequence

Selecting this option allows you to create sub-process tasks connected by
sequence flow. A dialog box is displayed to allow you to control the order of
the tasks: Use the Move Up and Move Down buttons to control the order of
the tasks. When you are finished, click OK to place the tasks.

* Create Unsequenced Sub-Process Tasks

Selecting this option places the tasks in the process without a connecting
sequence flow.

Creating a Call Sub-Process Call Process Interface using the
Palette

Procedure
1. In the Process Editor, select the call sub-process tool.

2. Click in the process where you want to place the activity that calls the sub-process.
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3. On the Properties view for the activity, browse for the process interface you want to
call as a sub-process.

o Note: If the process interface you select is not in the current project, you
are prompted to create a project reference:

Controlling Flow in a Process

This section describes some of the common tasks that you perform using TIBCO Business
Studio to control flow in a process.

See "Flows", "Loops", and "Gateways" topics in the TIBCO® BPM Enterprise Concepts Guide.

Controlling Flow with Sequence Flows and
Gateways

A sequence flow links one activity with another. A process follows the sequence flow when
its entry condition is met. Standard and unconditional flows are activated when the source
activity of the flow is completed.

Conditional sequence flow (for example, from an exclusive OR gateway) is activated if the
condition is True when evaluated.

» For exclusive split gateways, only the first flow whose condition is True is followed,
otherwise the default flow is followed.

» For inclusive split gateways, all flows whose condition is True are followed.
Otherwise, if no condition is True, then the default flow is followed.

To rejoin split flows, you can link multiple sequence flows into a single join gateway.

» A parallel join gateway follows its outgoing flow when all incoming flows have been
followed.

» An exclusive join gateway repeatedly follows its outgoing flow for every incoming
flow (so it is mainly used to join exclusive conditionally split flows).

* An inclusive join gateway can be configured to follow its outgoing flow upon certain
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patterns of the incoming flow.

Creating a Standard Loop

A standard loop is indicated by a symbol.

akark

() «—)— Standard loop
symbaol

Froblerms Diagram Fragments

| Task
Marne: | Service Task
[v] standard Loop
Activity Markers: i
[ Imuitiple Instance Loop

Click the Loops tab to set the details of the loop:

(] Task

eneral E\;anhd-liiitoenl:-mp |BeFu:nre {loop while condition is true) LI Seript Defined As:
m Loop Maximum: | |

Interface

Data Fields

Q Loops

Set the following parameters as appropriate for the loop you want to create:

e Test Time

Select either Before or After. The Before option is equivalent to the programming
construct "while": the expression is evaluated before the activity is performed, and
therefore if the expression evaluates to False, the activity is not performed. The
After option corresponds to the programming construct "Do: while": the
expression is evaluated after the activity has been performed, guaranteeing that
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the activity is performed at least once.

e Loop Maximum

Optionally specify an integer to control the maximum number of times the activity
is performed. In the event of conflict between Loop Maximum and the result of
the JavaScript defined under Script Defined As, the Loop Maximum overrides the
script calculation.

e Script Defined As

Select one of the following options:

° Free Text

Allows you to describe how you would like the loop to be tested if you
prefer to leave the specific implementation of the loop expression to
someone else.

Note: A BPMN warning is generated if you leave the script area
blank. To remove the warning, enter a text description of the
intended script implementation.

o JavaScript
Allows you to enter JavaScript that is evaluated for the loop expression.
° Unspecified

Allows you to specify that there is no expression or description for this loop.

Creating a Multi-Instance Loop

A multi-instance loop is indicated by one of two symbols:

e Parallel multi-instance loop:

©

Service Task

e Sequential multi-instance loop:
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Service Task

Click the Loops tab to set the details of the loop:

] Task
zeneral rdering: |Sequential LI Scripks For Multi Instance:
Description Flows Condition: | Ne Candition (perform autgaing flow for each = | [LDDP Expression | Camples: Flow Can

all (perform outgoing Flow when all instances complete) Ast |Unspecified =
Inkerface

(perform oubgoing How once when first instance completes

Diata Fields e on (perForm aukgoing Flow For &2 arnolete |
() Loops Complex (behawor defined b Camples: Flow Condltlonlj

Set the following parameters as appropriate for the loop you want to create:

Ordering

Select either Sequential or Parallel ordering. The Sequential option causes the instances
of the activity to occur in succession rather than at the same time. The Parallel option
causes the instances of the activity to occur at the same time.

Flow Condition

This property can be used to mimic the functions of a gateway. Select one of the following
options:

e All (perform outgoing flow when all instances complete) The outgoing flow is
processed once after all activity instances have completed.

» One (perform outgoing flow once when first instance completes) The outgoing
flow is processed when the first activity instance completes (existing instances can
still be completed but the outgoing flow is not processed when they complete).

* No Condition (perform outgoing flow for each completed instance) The outgoing
flow is processed for every activity instance as it completes.

o Complex (behavior defined by Complex Flow Condition) The outgoing flow is
processed for each instance for which the Complex Flow Condition tab evaluates to
true.
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Scripts for Multi-Instance

Select Free Text for the Script Defined As field if you want to describe how you would like
the loop to be tested, and prefer to leave the specific implementation of the loop
expression to someone else. You can also select Unspecified if there is currently no
condition or description for the loop.

Note: Depending on the destination environment you have selected, JavaScript
might be available as an option. Use this option if you want to enter JavaScript
that can be evaluated for the loop expression.

There are three tabs on which you can specify scripts:

Loop Expression

Specify either a script that evaluates to an integer or a description of the desired script.
Complex Flow Condition
This expression is evaluated if you selected Complex as the Flow Condition.

Additional Instances Expression

This expression is used for control-flow pattern WCP-15 (additional activity instances
might be required at runtime) when you only need to add instances when the task is
complete.

If you need to add instances while the task is in progress, see Adding Additional
Instances to a Multi-instance Loop While the Task is Still in Progress.

The additional instances script is evaluated after the last instance completes. If the
script evaluation calls for additional instances, they can be done and the script can be
evaluated again once the last additional instance completes.

o Note: If an Additional Instances Expression is specified then this expression
must eventually evaluate to zero so no more instances occur.

Adding Additional Instances to a Multi-instance
Loop While the Task is Still in Progress

This implements control-flow pattern WCP-15.
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o Note: If you have a multi-instance user task and a loop which allows you to
generate multiple copies of that task, if you have concurrent copies of the multi-
instance user task, each with multiple instances, and then "add additional
activity instances", the additional instances are added to every copy of the
multi-instance user task.

To do this, you need to execute a script somewhere on a parallel path whilst the loop task
is active. The script can add instances to the loop task using an expression similar to the
following:

Process.addActivityLoopAdditionallnstances ("OrderStock",1);

which contains a string for the name of the task (in this example, OrderStock), and an
integer for the number of additional instances required (in this example, 1).

o Note: If you wish to add additional instances to a dynamic sub-process task, you
need to pre-populate the array that is chosen as the runtime identifier field with
the name or names of the sub-process implementation that you wish to add, as
well as any associated arrays used to provide input into the dynamic sub-
process. See Creating Dynamic Sub-Processes.

You can also add additional instances to a loop in the loop task itself, but only in the task
Complete script.

In this example, the task Add parts to order would order an additional item each time it
was used.
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7N
+ Order Stock (&)
Process Throw Signal
Order = Event
& Add Parts
To Order
[
Catch[pignal
Event
End Event 2
v
< >
[C] Properties % |[2]] Problems OF Fragments I = =9
O Task
General
Description 1\ Initiate Script | =] Complete Script j Timeout Script j Cancel Script
Interface Script executed by the process engine on completion of the activity.  Script Defined As: JavaScrij
Data Fields Describe Completed Script:
Work Resource bpm.process.addActivityloopAdditionalInstances("OrderStock™, 1);
E Scripts

This workflow pattern specifies that multiple instances of an activity should be created,
each instance being synchronized and able to run concurrently.

Note that:

e The number of instances required is known and specified at design time.

e Each task instance has access to all the process data (data fields, parameters, and so

on).
 All the instances must be complete before the next task is started.

The following process has three activities:

Process Direck

Each Digsgt Debit
Dehit Requesk liﬁ:

Skart Event Confirm Debits End Event

There can be multiple instances of the Each Direct Debit task. This is indicated on the
General tab of the Properties view:
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[L- Praoblems DE’:Fragments = Properties 3

(] Task
|=| General Label: |Ea|:h Direct Debit |
Description
Bitiviky Markers: Standard Loop [#]Multiple Instance Loop
Interface ¥ O P [Multip R
Loops Participants: | | E] [Clear ]
RESOUNCE | pctivity Type:  |User Task |
Scripks
The details are specified on the Loops tab:
[%: Problems rOE Fragments rﬁ Data Source Explarer rﬂ Properties &3 O |§_|_|g| =
[ Task
m Ordeting: |Parallel LI Scripks For Mulki Instance;
Description Flow Condition: |F\II (perform outgoing Flow when all instances Ll Loop Expression ]w
Interface Script Defined As:
Daka Fields Describe nurber of instances to pe
D Loops 3
Resource

The Parallel ordering setting and All flow condition means that the activity instances are

performed at the same time and are synchronized. The number of instances is set to 3 on
the right side of the Properties view.

Configuring a Task as Automatic Ad-Hoc

The automatic ad-hoc activity allows you to define one or more standalone tasks (with no
incoming / outgoing flow) in a business process that are executed zero or more times
during the lifetime of a process instance. An automatic ad-hoc activity is executed when it

becomes enabled by any of the initializer activities being processed and the transition of
the given precondition from false to true.

o Note: This feature is not available for pageflows.

You can have a number of ad-hoc activities in a process. Their preconditions determine if
and when they are executed.

Procedure

1. Check the Ad-hoc Activity Marker on the General tab of the properties on a User task
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or Call Sub-Process task.
2. Click on Ad-Hoc Configuration Properties. The Ad-Hoc Configuration tab opens.

3. General: optionally select Interrupt main process until completion.

This pauses the main process flow, resuming on completion of the ad-hoc activity. It
does not stop you processing currently active work items or sub-processes, event
sub-processes or other ad-hoc activities. However, note that data is not returned to
the process instance until it re-activates.

4. Check Automatic Invocation.

5. Access: in addition to defining whether users have the ability to cancel an ad-hoc
activity using a system action (see System Actions Reference in TIBCO® BPM
Enterprise Concepts Guide), optionally it is possible to define whether a user can
cancel a specific ad-hoc activity by specifying Organization privileges that the user
must possess.

6. Enablement and Execution: Define the condition under which the activity is enabled
and executed automatically.

 Initializer Activities: (optional) Select one or more Initializer Activities which are
activities which are in the same process. This activity needs to complete before
the precondition is evaluated. This can be useful for ensuring that the
precondition is not evaluated until the data referenced is initialized.

e Precondition: Set an optional precondition script that controls enablement of
the ad-hoc activity.

o Note: For Automatic ad-hoc activity, at least one Enablement
condition should be specified: that is, either the Initializer Activities
or the Precondition script must be specified (both can be specified).

o Note: The condition must be a Boolean expression which evaluates
to true. The condition has to go from true > false > true in order to re-
trigger so you must reset the result of the expression to false before it
can become true again.

TIBCO Business Studio™ - BPM Edition Modeling Guide



123 | BPM Packages and Processes

Configuring a Task as Manual Ad-Hoc

The manual ad-hoc activity allows you to define one or more standalone tasks (with no
incoming / outgoing flow) in a business process that are executed zero or more times
during the lifetime of a process instance. An ad-hoc activity only becomes available for
manual invocation when it is enabled via the preconditions and the user holds the
necessary privileges to start and cancel that activity.

o Note: This feature is not available for pageflows.

You can have a number of ad-hoc activities in a process. Their preconditions determine
when they become available for execution by permitted users.

Procedure

1.

Check the Ad-hoc Activity Marker on the General tab of the properties on a User task
or Call Sub-Process task.

Click Ad-Hoc Configuration Properties. The Ad-Hoc Configuration tab is displayed.

General: optionally select Interrupt main process until completion.

This pauses the main process flow, resuming on completion of the ad-hoc activity. It
does not stop you processing currently active work items or sub-processes, event
sub-processes or other ad-hoc activities. However note that data is not returned to
the process instance until it re-activates.

Check Manual Invocation.

Optionally check Allow multiple invocations. If you check this, you can manually
invoke the activity more than once after it has been enabled.

Access: in addition to defining whether users have the ability to cancel an ad-hoc
activity using a system action (see the "System Actions Reference" topic in the
TIBCO® BPM Enterprise Concepts Guide), optionally it is possible to define whether a
user can cancel a specific ad-hoc activity by specifying Organization privileges that
the user must possess.

Enablement: Define the condition under which the activity is enabled and executed
automatically.

 Initializer Activities: (optional) Select one or more Initializer Activities which are
activities which are in the same process. The precondition is not evaluated until
one of these has been completed.
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» Precondition: Set an optional precondition script that controls enablement of
the ad-hoc activity. The automatic ad-hoc activity is invoked every time the
precondition is changed from false to true. So the activity might be invoked
many times.

o Note: For manual ad-hoc activities, specifying enablement is optional, so it
not mandatory to specify either the initializer activity or the precondition
script.

o Note: The condition must be a Boolean expression which evaluates to
true. The condition has to go from true > false > true in order to re-trigger
so you must reset the result of the expression to false before it can
become true again.

Refactoring Ad-Hoc Activities

You can refactor one or multiple ad-hoc user tasks into a sub-process.

o Note:

You might want to do this with an ad-hoc user task, as certain actions are not
available to you on the ad-hoc user task. However, once you refactor one or
multiple user tasks into a reusable sub-process, more actions are available. For
example, you can add a deadline to a user task within an ad-hoc reusable sub-
process, but not to an ad-hoc user task.

Note that when refactoring a single ad-hoc user task, the reusable sub-process
inherits the ad-hoc configuration. When refactoring multiple ad-hoc user tasks

the reusable sub-process contains multiple user tasks which retain their ad-hoc
configuration.

Procedure
1. Select an ad-hoc user task (or multiple ad-hoc user tasks), right-click and select
Refactor > Extract Into New Sub-Process.

2. Follow the steps in the wizard to refactor. The ad-hoc user task or tasks now is a
reusable sub-process.
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Exclusive Event Based Gateway Example

An example of an Exclusive Decision/Merge (XOR) Event Based Gateway that provides an

example for workflow process pattern 16, Deferred Choice.

Workflow process pattern 16, Deferred Choice, states:

A point in a process where one of several branches is chosen based on interaction with the
operating environment. Prior to the decision, all branches represent possible future
courses of execution. The decision is made by initiating the first task in one of the branches
i.e. there is no explicit choice but rather a race between different branches. After the
decision is made, execution alternatives in branches other than the one selected are

withdrawn.
- =
= [Nl=l
&WPNG
Timeout
Start Event Timer 3 End parallel
minutes path on timer
& WPP16
w @ Signal Caught 4’@
e 'R - Catch Signal End parallel
o || = Exclusive Event
Gatew, path on
ateway .
signal
&WPP‘IG & WPP
Throw a Signal @ Signal Thrown 4’0
Throw Signal End this flow
-
[ Properties &3 &
<> Gateway
|~ General Label: | Exclusive Event Gateway
Description Name: | ExclusiveEventGateway
Data References
T Gateway type: (O Exclusive Decision/Merge (XOR) Data Based
Extended (O Inclusive Decision/Merge (OR)
Resource (®) Exclusive Decision/Merge (XOR) Event Based
(0 Complex Decision/Merge
() Parallel Fork/loin (AND)

The state remains on the Exclusive Event Based Gateway until a signal is caught, or the

timer expires.

When the event occurs, the state is pulled from the Gateway to the relevant task, and this

removes other paths from possible operation.
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Note: It is possible to have multiple paths, with various timers and signals, but
the Gateway only actions the first event to occur.

Controlling Flow from an External Application

You can control the flow of a process from an external application using incoming request
events and tasks. You can trigger these events or tasks by an external application using the
Process sendEvent REST API.

With Incoming request events and tasks, you can perform the following functions:

» Pause a process flow until you receive the incoming request using an in-flow event or
task.

» Cancel a long running task such as a user task, or sub-process, that is in progress by
attaching the incoming request event to a task boundary.

 Start a parallel event handler flow in the process by creating an event sub-process
with an incoming request start event.

The Process REST API triggers an incoming request event or task. With this API, the process
instance ID or incoming business data can be used to identify the specific process instance
on which you can trigger the incoming request.

Correlating Incoming Requests

You can trigger an incoming request event or task using the Process REST API. You can use
the process instance ID or correlation data to identify the specific process instance on
which you can trigger the request using your own business data. The incoming request is
only triggered on a single process.

o Note: The Business data method of correlation is currently not supported for
Incoming Request Event-handlers and Event Sub-Processes.

To use business data for correlating incoming requests with individual process instances,
the process must have one or more correlation data fields whose value uniquely identifies
an individual process instance. This correlation data can then be associated with an
incoming request event or task in its interface property configuration. By default, all
correlation data is associated implicitly.
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When you invoke the process REST API to trigger an incoming request without a process
instance ID, the correlation data field values supplied in the request payload are matched
to the correlation data values in an existing process instance. The incoming request is then
triggered in that process instance.

You must ensure that the correlation data is set with the appropriate value in each process
instance before the incoming request event or task is initialized.

Process Data

This section describes how to use data that is used in processes such as data fields,
parameters, and participants.

Adding Data Fields or Parameters to a Package or
Process

You can add data fields or parameters to a package or process in two different ways, in the
Properties view provided when the Parameters or Data Fields folder is selected in Project
Explorer (this method is better if you need to create several data fields or parameters) or
using the wizard to create one at a time.

See "Data Fields and Parameters" in the TIBCO® BPM Enterprise Concepts Guide.
You can add data fields or parameters to a package or process:

* in the Properties view table provided when the Parameters or Data Fields folder is
selected in Project Explorer (this method is better if you need to create several data
fields or parameters).

See Using the Properties View to Create a New Data Field or Parameter

e using the wizard to create one at a time.

See Using the Wizards to Create a New Data Field or Parameter

Note: See Associating Participants with Activities for information on how to
highlight all the tasks in a process that have a particular data field or parameter
assigned to them.

See Constraints on Field or Parameter Values
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Using the Properties View to Create a New Data
Field or Parameter

You can create a new data field or parameter in the Properties view.

Procedure
1. In the Project Explorer, expand the package or process where you want to add a data
field or parameter.

If the Data Fields folder is empty under a package, it is hidden by default. This is
because the preferred usage is to define Data Fields at the Process level.

o Note: If you want to show the Data Fields folder under a package,
regardless of whether it is empty or not, then you need to go to Project
Explorer, and click the View Menu icon in the top right corner, then select
Customize View. You can then deselect BPM Package Data Fields on the
list of filters which are set.

2. As appropriate, click the Data Fields or Parameters folder in the Project Explorer. If
you need to add a Data Field at the Package level, select New > Data Field as
described in Using the Wizards to Create a New Data Field or Parameter. The
Properties view is displayed.

3. Click the plus icon. A new data field or parameter is added. As appropriate, modify
the properties.

Using the Wizards to Create a New Data Field or
Parameter

You can create a new data field or parameter using the wizards provided:

Procedure
1. In the Project Explorer, expand the package or process where you want to add a data
field or parameter.
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2. As appropriate, right-click Data Fields or Parameters and select New > Data Field
or New > Parameter. The New Data Field or New Parameter dialog box is displayed.

o Note: If you start this wizard from the File > New menu, the first dialog
box is the project and package dialog box, where you must specify a valid
project and package. This dialog box is not displayed if you right-click at
the process level to start the dialog box. however, you can click Back to
display it.

3. Specify a label for the data field or parameter; you cannot specify leading or trailing

spaces.

4. For parameters, specify the following:

Option

Mandatory

Read Only

Mode

Description

(Parameter only) Select this check box to specify that the parameter
must be present when the process is started.

Select this check box to specify that the value of the data field or
parameter cannot be modified after it is created.

(Parameter only) Select whether the parameter is an input (In) output
(Out) or both (In/Out).

Note: The parameters specified on the Interface tab for a user task
are from the perspective of the form, not the user. This means that
input parameters are sent to the form by the process, not the user.
Output Parameters are sent to the form by the user.

Note: You must provide an input mapping when the process is
called as a subprocess.

5. Specify the type of data field or parameter you want to create:
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Option

Basic Type

Initial Value

Allowed
Values

Declared
Type

External
Reference

Description

If you select this type, you can choose from Text, Decimal, Integer,
Boolean, Date, Time, Date Time or Performer. For more information
about using performer data types, see the appropriate implementation
guide.

Note: If you need to create a Text field of unlimited length, ensure
that the Length field is empty. If you wish to limit the number of
characters enter the appropriate numeric value.

Note: The value of unmapped Basic Type parameters has the
following defaults:

e Text: null
e Boolean: false
¢ Integer/Decimal: 0

* Date / Time / DateTime: now (time of process instance
creation)

For data fields, you can optionally specify an Initial Value by clicking in
the provided text entry area and entering a value. For arrays, you can
add more than one value. You can add rows by clicking the button.

You can also delete rows by clicking the button.

For parameters, you can optionally specify the permitted input values
(values that might be supplied by application starting an instance of the
process). You can add rows by clicking the button. You can also

delete rows by clicking the button.

This option allows you to select from the declared types that you have
already defined.

Allows you to refer to a business object defined in the Business Object
Modeler.

6. Select whether you want the data field or parameter to be an array. Selecting the

TIBCO Business Studio™ - BPM Edition Modeling Guide



131 | BPM Packages and Processes

Array check box creates an array of the Basic Type that is selected. For example, if
you select the Array check box and Text, you are defining the data field or parameter
as an array of Text values.

7. Click Finish to create the data field or parameter, or click Next to specify a
documentation URL, description, or extended attributes.

8. The Documentation URL and Description fields allow you to specify supplementary
information about the data field or parameter that you have created.

9. The Extended dialog box allows you to specify extended attributes.

The parameter that you created appears in the Project Explorer.

Constraints on Field or Parameter Values

If you place any constraint on the possible values of a data field or a parameter of any
Basic Type, that constraint is ignored at runtime. This is because BPM’s Process Engine
cannot enforce these constraints.

Note: This section applies only if one of the destinations for your process is set
as BPM.

For example:

 If an Integer or Decimal field has its Length set to 9, a warning is displayed that
format restrictions are not enforced, and at runtime you can still assign a value with
more than 9 digits.

 If a Decimal field has Decimal Places set to 2, a warning is displayed that format
restrictions are not enforced, and at runtime you can still assign a value with 3
decimal places.

 If a Text type data field has its Length set to 50, you can still assign a value with
more than 50 characters.

A Warning: Note that in the case of the Text field, no warning is displayed.

You can produce the same effect as limiting the value of the field or parameter by using a
BOM data type defined with the restricted values you need.
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Adding Data Fields to an Activity

You can create a new data field for an activity as follows:

Procedure
1. Select the activity for which you want to create a data field.

2. On the Properties view, click Data Fields.

o Note: Activities that do not support activity-level data fields (such as
gateways) do not have a Data Fields tab on their Properties view.

A validation error is displayed if you define a data field for an activity on
the Data Fields tab, but the destination environment selected for the
parent process does not support activity-level data fields for that activity

type.

Click the Add icon . A new data field is added.

3. Modify the data field’s properties as per your requirements.

Result

Note: You can only assign a value to an activity-level data field by using the
Scripts tab on the activity. See the appropriate implementation guide for more
information.

Creating Correlation Data

Correlation data must be used to ensure that each global signal is received by the process
instance to which it applies. It can also be used for certain incoming request events and
tasks instead of process instance ID to identify the process instance to which the incoming

request applies.
You can create correlation data fields in the following ways:

 using the Properties view table provided when the Correlation Data folder is
selected in Project Explorer (this method is recommended if you need to create
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several data fields or parameters).
 using the wizard available either from the Project Explorer or from the File menu.

 refactoring an existing data field into a correlation data field (right-click the data field
and select Convert to Correlation Data).

e copying a data field and pasting it under the Correlation Data folder in the Project
Explorer.

Creating Correlation Data Using the Properties View

Procedure

1. In the Project Explorer, expand the package or process where you want to add a
correlation data field.

2. Click Correlation Data in the Project Explorer.

The Properties view is displayed.

Click . A new correlation data field is added.

£ properties 23 |_$__ Problerms or Fragments

© correlation Data

O Data Fields Length Decimal Places Array External Reference Type Declaration
Advanced 50 T |:| MA R

As appropriate, modify the properties.

Creating Correlation Data Using the Wizard

Procedure

1. In the Project Explorer, expand the package or process where you want to add a data
field or parameter.

2. Right-click Correlation > Data and select New > Correlation Data. The New Data
Field dialog box is displayed.

TIBCO Business Studio™ - BPM Edition Modeling Guide



134 | BPM Packages and Processes

o Note: If you start this wizard from the File > New menu, the first dialog
box is the project and package dialog box, where you must specify a valid
project and package. This dialog box is not displayed if you right-click at
the process level to start the dialog box. However, you can click Back to
display it.

Result

For information about how to complete the remainder of the fields in the wizard pages, see
Using the Wizards to Create a New Data Field or Parameter (the properties of a correlation
data field are exactly like those of a standard data field).

The correlation data that you created appears in the Project Explorer.

° Tip: If a correlation data field has data that you want to continue to use in your
process, but that you no longer want to use for correlation, you can convert the
correlation data field to a "standard" data field, by right-clicking it and selecting
Convert Correlation Data to Data Field.

Associating Process Data with Events and Tasks

There are many reasons to associate process data with tasks or events. For example, data
field needs to be displayed in a form or a process cannot be started unless a particular
parameter is passed to a start event.

Using drag-and-drop to Associate a Data Field or
Parameter with an Activity

o Note: You can drop process data onto a blank part of the process to create a
new user task with the associated process data. For more information, see Using
Participants to Create Tasks.

Procedure
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1. In the Project Explorer, click the data field or parameter you want to associate with
your activity, holding down the mouse button, drag the pointer to the user task and
release the mouse button.

o Note: You can select multiple data fields or parameters for drag-and-drop
operations using the Ctrl (for single selection) or Shift (to select a range)
keys.

2. A menu is displayed with the following options:

e Add Data To View And Assign

Selecting this option adds the process data as an In/Out parameter on the
Interface tab. This means that in the runtime environment, users are able to
display the associated form to view the field and also to assign new values to
it.

» Add Data To View

Selecting this option adds the process data as an In parameter on the
Interface tab. This means that in the runtime environment, users are able to
display the associated form to view the field, however they cannot assign
new values to it.

e Add Data To Assign

Selecting this option adds the process data as an Out parameter on the
Interface tab. This means that in the runtime environment, users are able to
display the associated form to assign new values to the field.

Using the Interface Tab to Associate a Data Field or
Parameter with an Activity

Procedure
1. Select the event or task.

2. In the Properties view, click the Interface tab.
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3. Select whether you want the visibility of the event or task to be private or public -
see Setting Event and Task Visibility (Private and Public).

Appearance

4. Choose between the following:

» Select the check box No interface data association required if you do not
want to associate process data with the event or task. This deletes any
associations that already exist.

e Click to select the process data that you want to associate with the event or

task. The Select Data Field or Formal Parameter dialog box displays the list of
available process data:
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Note:
» By default, all process data is available to a task. When you
explicitly associate process data with an event or task, only the
process data you associate with the event or task can be used

by that task.
r — 2
 Select Data Field or, Formal Parameter |__I@
Select a bype (7 = any character, * = any string); » Sl
| | | @ custMame (custMame) - SettleVendor Ao
Matching items: @ custld {custld) - SettlevendorAccount)s
(@ accountMumber {accountMumber) - SettleYendorhoc
i arnourkToPay (amountToPay)
@ anyDiscrepancies (anyDiscrepancies)
@ appointmentDateTime (appointmentDateTime)
@ custld (custld)
@ custMame {custMarme)
@ referencePaymentId (referencePaymentId)
@ sortCode (sortCode)
< » < >
IWendorExample/Process P... SettleYendorfcoount, xpd| fwendarExample/Pro.. Mendoraccount, xpdl
':'.3:' [ o] 4 ] [ Cancel ]

» The process data displayed depends on what type of event or
task is selected. Most events and tasks can have both data
fields and formal parameters associated with them, however
receive tasks and events of type None can have only formal
parameters associated with them.

5. The process data you select is added to the table of data. Select whether you want
the data to be mandatory.

o Note: The mandatory setting on the Interface tab for a formal parameter
overrides the mandatory setting in the Properties view for the formal
parameter. This allows complete freedom in designing the process - you
can define a formal parameter as mandatory in one place in a process, and
optional in another.

Use the space provided if you want to add an optional usage description of the
process data. Selected parameters also display their mode (In, Out, or In/Out). You
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can change the mode by selecting from the drop-down list.

Setting Event and Task Visibility (Private and Public)

The visibility of an event or task (whether it is private or public) controls whether process
information (such as required parameters) is available to an external process or
application.

Setting the visibility to public results in a subset of events or steps that are then available
to external processes or applications.

o Note: The runtime effect of this setting is entirely destination specific.

For each event or task, you can specify a list of expected input fields (on the Interface tab),
and define the URL of the document describing the purpose of the public event or task (on
the Description tab).

By default, events and tasks in a process are private; in a process interface, they are public.
If you want to change the visibility of an event or task:

Procedure
1. Select the event or task.

2. On the Interface tab, select the visibility (Private or Public).

Click to add parameters to the event or task. Use the Mandatory check box to
specify parameters that must be present.

3. (Optional) Select the Description tab. Enter a URL that provides documentation
describing how the event or task is used.

Using Process Data to Create Tasks

» Create User Task To View And Assign Data

Selecting this option creates a user task with the process data as an In/Out
parameter on the Interface tab. This means that in the runtime environment, users
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are able to display the associated form to view the field and also to assign new
values to it.

e Create User Task To View Data

Selecting this option creates a user task with the process data as an In parameter
on the Interface tab. This means that in the runtime environment, users are able

to display the associated form to view the field, however they cannot assign new

values to it.

» Create User Task To Assign Data

Selecting this option creates a user task with the process data as an Out parameter
on the Interface tab. This means that in the runtime environment, users are able
to display the associated form to assign new values to the field.

Creating a Participant

Participants are used to identify who or what (a REST end-point or an e-mail server)
performs an activity.

For more information, see the "Participants" topic in the TIBCO® BPM Enterprise Concepts
Guide.

Procedure
1. In the Project Explorer, expand the package where you want to add a participant.

2. Right-click Participants, click New and then, select Participant. The New Participant
dialog box is displayed.

3. Click the Back button to change either the name of the Project or Package where
the participant is created. If you want to change any one of the names, click the
Project or Package button respectively.

Participants can be created at either the package level or at the process level.
Creating them at the package level is recommended which ensures that they are
shared among processes. Select the Process check box and specify a process if you
want to create the participant at the process level.
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Note: If the Participants folder is empty at the Process level, it is hidden
by default. This is because the preferred usage is to define Participants at
the Package level.

Click Next.

4. Specify the Label and Name of the participant (either a Basic Type, or an External
Reference as previously described in this section) and click Finish.

To create a basic type participant, select Basic Type and choose from the
System and Organization Model Query radio buttons, and click Finish.

If you select the Organization Model Query radio button, you can then enter
the Organization Model Query Script in Resource Query Language (RQL) by using
a script or expression on the General tab of the Properties view. This is
evaluated when a referencing task is executed at run-time, so the actual
participant is resolved and the activity dispatched and offered to the
participant. A query could resolve to a participant in the package/process or to
an entity in the organizational model.

To create an external reference to an organization model, select External
Reference, and click the Select a reference icon to select a type from the
organization model.

Choose a type from those shown in Matching items, or enter the first few
characters of the name you are looking for in the field under Select type(s)(? =
any character, * = any string) and choose from those shown. Click OK.

The participant that you created appears in the project explorer.
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ﬁ Note:

* You can import participants from other projects. At the process
package level, right-click and select Import Participants
Wizard. You can then select which project/s you wish to import
participants from.

» All external references to participants from within the same
project must be to the same major version of the organization
model. However, you can reference different minor or micro
versions of the model. For example, if you have included a
reference to a participant in version 1.0.0.qualifier of the
organization model, and the model subsequently changes, you
could reference a participant in version 1.1.0.qualifier, but not
version 2.0.0.qualifier.

Associating Participants with Activities

You can associate a participant with an activity to identify who or what performs the
activity. You can do this either by dragging and dropping the participant onto the activity
or in the Properties view for the activity.

Using drag-and-drop to associate a participant with an
activity

You can drag a participant onto an activity.

Procedure
1. Expand participants in the Project Explorer.

2. Click the participant you want to associate with your activity, holding down the
mouse button, drag the pointer to the activity and release the mouse button.

TIBCO Business Studio™ - BPM Edition Modeling Guide



142 | BPM Packages and Processes

o Note:

* You can select multiple participants for drag-and-drop operations
using the Ctrl (for single selection) or Shift (to select a range) keys.

* You can also select as a participant a data field or formal parameter
of the type Performer.

3. A menu is displayed with two options:

Option Description

Add Task Selecting this option adds the participants to any existing participants
Participant(s) for the activity.

Set Task Selecting this option clears any existing participants associated with
Participant(s) the activity, before setting the participants to those you selected.

Using the Properties View to associate a participant with an
activity

You can associate a participant with an activity.

Procedure
1. In the Process Editor, highlight the desired activity.

2. Either:
* In the Properties view, click the picker.
» Right-click the activity, and select Participant.
The Select Participants dialog box is displayed.

3. Highlight participants you want to select and click Add to move them to the
Selection column. When you have finished selecting Participants, click OK.
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° Tip:
* You can select multiple participants by pressing either the Ctrl (for
single selection) or Shift (to select a range) keys while making your

selection.

e The wildcard ? returns all matching participants. Use the * wildcard
to restrict the results (for example, *2 to return all Participants
ending in 2. Note that the wildcard * by itself does not return any
results; it only works in conjunction with a string.

* You can also select a data field of the type Performer as a
participant.

4. The participants you selected are displayed in the Properties view and also when you
hover the pointer over the activity in the Process Editor.

Highlighting Participants

You can see what tasks a participant is assigned to by using highlighting.

Procedure
1. Click in the Process Editor for the process.

On the toolbar, you can see a button:
2. Click this to see the drop-down list, and select Enable Highlighting.

- - % -0 -G

1= Highlight Activities \With Scripts

"—E Process Message APT Activities

<= Conditional Sequence Flow

W Enable Highlighting
o Enable Highlight Animation

Alternatively, you can select Diagram > Highlighting > Enable Highlighting.

3. Select the participant in Process Explorer, and in the Process Editor the tasks which
use this participant are highlighted (framed with green lines). Other tasks in the
process are grayed out.

This behavior also applies to data fields and parameters.
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] oy | [ oy |.

lDispIay Message ] [ Call Customer J

Result
Highlights are cumulative.

* If you select more than one participant, data field or parameter in Project Explorer,
only tasks which reference all of those selected are highlighted.

 If you select "Activities With Scripts" followed by "Migration Point Activities" then the
diagram objects highlighted are migration point activities that have scripts.

The current highlight filter is shown when you use the Process Editor mouse-over tooltip.

Highlights are removed when anything other than the highlighted diagram objects are
selected.

Using Participants to Create Tasks

If you have participants, you can drag them to a blank area of a process to automatically
create several types of task:

Procedure
1. In the Project Explorer, click the participant, and holding down the mouse button
drag the pointer to a blank part of the process and release the mouse button.

Note: You can select multiple participants for drag-and-drop operations
using the Ctrl (for single selection) or Shift (to select a range) keys.

2. A menu is displayed with the following options:

e Create User Task For Participant(s)

Selecting this option creates a user task with the selected participants.

e Create Service Task For Participant(s)
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Selecting this option creates a service task with the selected participants.

e Create Manual Task For Participant(s)

Selecting this option creates a manual task with the selected participants.

e Other Task Types

This submenu contains more task types that you can create from a
participant.

Deletion of Data Fields Parameters Participants and Type
Declarations

You can delete a project object such as a data field, parameter, participant, or type
declaration by right-clicking it in the Project Explorer and selecting Delete.

However, if the project object has been associated with another object such as an activity
or a sequence flow, the following message is displayed:

-
 Deleting Referenced Data

one of more selecked fieldsfparameters are currently referenced by

9
\{J‘) objects/Flows in processes,

This may invalidate the process concerned,

Are wou sure you wish o deleke them?

If you click Yes, the project object (in this example, a data field) is deleted, but it still is
referenced in XPDL for the project, which can cause problems. If you click No, the project
object is not deleted. You can then go to the Properties view and examine the references to

that object:
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= Properties &0 [Z_L, Problems D{r Fragrments

(& Data Field
|| General Label: | appointmentDateTime
Description Mame: |appuintmentDateTime
Advanced
* Type..

Extended

Read Cnly: [

(%) Basic Type Set a basic type:

Length:

() External Reference Decimal Places:
|:| array

¢ Initial ¥alue(s)...

= 08 SettlevendorcctProcess
=) Tasks | Events
G RequestForappaintment
% ShowAppoinkmentDetails

In this example, the data field is referenced in the service task RequestForAppointment
and in the user task ShowAppointmentDetails. Click Go To to show that task in the
Process Editor.

Creating a Dynamic Organization Participant

The Organization Units and Positions within a Dynamic Organization might be assigned to
Process Participants - known as Dynamic Organization Participants.

See the "Dynamic Organization Participants" topic in TIBCO® BPM Enterprise Concepts Guide

Procedure
1. In the Project Explorer, expand the package where you want to add a participant.

2. Right-click Participants and select New > Participant. The New Participant dialog
box is displayed.

3. Specify the Label and Name of the participant.
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4. To create an external reference to a dynamic organization model, select External
Reference, and click the picker to select a type from the dynamic organization
model. Choose a type from those shown in Matching Items, or key in the first few
characters of the name you are looking for in the field under Select type(s)(? = any
character, * = any string) and choose from those shown. Click OK. The dynamic
organization participant that you created appears in the Project Explorer.

5. Click Finish.

What to do next

When a Dynamic Organization Participant is assigned to a task you need to provide
information to identify the correct instance of the Dynamic Organization to use to resolve
this participant. See Dynamic Organization Identifier Mapping to identify the correct
instance of the Dynamic Organization in which the participant can be found at runtime.

Auditing Process Data

By default, process data does not appear in the audit trail (that is, in the Event Viewer) for
a process instance. But you can configure a process so that certain data fields appear in
the audit trail.

This capability makes use of the process data to work item attributes mapping facility that
is available in TIBCO Business Studio - BPM Edition. For example, the following shows
process data in the Event Viewer that has been mapped to Attributes 3 and 8.

R 20141013 141128 Completed work item ‘RepResponce’ of ‘CSCallbackProcess’ | Clind Hill BRM_WORKITENM_EX_COMPLETE_WORK_ITI
@ 2014-10-13 14:11:28 Completed task ‘RepResponce’ of 'CSCallbackProcess’ with I[ Clin Hll BX_INSTANCE_TASKS_COMPLETED
[é 2014-10-13 14:11:20 {n} Crested task 'SalesDepartmentReview' of 'CSCallbackProces: Clint Hill BX_INSTANCE_TASKS_CREATED
[ 20141013 14:11:29 Scheduled work item *SalesDeparimentRevien’ of 'CSCallbac Clint Hill BRM_WORKITEM_SCHEDULED
() 2014-10-13 14:11:28 Applied work group patterms for work item Ciliné Hill BRM_WORKSROUP_EX_APPLY_PATTERNS
4

ltems 41-B0of 74. Pege 3o0f4 [ <

@] BX_INSTANCE_TASKS_COMPLETED - Event Attributes

Type || Name & Value [ Type | Compenent

[ Applicstion activity instance 1D purm: 00120 String Comron Meta Data
| | Application activity moded ID _dPFrd4F8zEd-KgJmyMNEwEow String Common Meta Dats
] Application activity name RepResponce String Commaon Meta Dats
[ Application name com.example.cscallback String Common Meta Dsts
[ Adtributed Meed info about new CSR application. String Common Meta Dsts
[ Adtributes Ricky Bobbie String Zommon Meta Dats
[ Compaonent ID BX String Logging Framawork
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If a work list facade has been defined, and display labels were assigned to Attributes 3 and
8, the labels would be shown in the Event Viewer rather than "Attribute3" and "Attribute8".
For more information, see Creating a Work List Facade.

o Note: The Event Viewer displays audit entries across all processes on the
system, and therefore it is usual that specific attributes are used for the same
data items across all processes. For example, you might want to consistently use
Attribute2 for the value of 'Order Id'". Creating and sharing the same work list
facade project across all BPM applications on the system can help to achieve
this consistency.

To configure your system to show process data in the Event Viewer, you must map process
data fields to the desired work item attributes. For more information, see Mapping Process
Data to be Audited.

Mapping Process Data to be Audited

For process data to appear in the Event Viewer, you must map process data fields to the
desired work item attributes.

This mapping process is the same as the process for mapping data fields to work item
attributes when creating a work list facade - see Creating a Work List Facade. If you have
defined a work list facade, and you map process data fields to attributes for which you
have specified a display label in the facade, those custom labels also appear in the Event
Viewer for the process data entries.

Procedure
1. In TIBCO Business Studio, open your process and select it in the Process Editor.

2. In the Properties view, select the Work Resource tab, then expand Work Item
Attribute / Audit Event Data Attribute Mappings.

This displays all of the data fields defined for the process (in the left column) and all
of the work item attributes (in the right column). For example:
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+ Work Item Attribute [ Audit Event Data Attribute Mappings...

Map process data to be automatically assigned to user task work item attributes and process audit event data attributes.

Jtype filter text

™ show Only Mapped Content

| Jtype filter text

i, & Contact Name (Contactiame)

% Contact Phone (ContactPhone)

5 Issue Description {IssueDescription)
% Issue Details (IssueDetails)

@ Resolution Description (ResolutionDescription)
@ Resolution Details (ResolutionDetails)
(@ Review Notes (ReviewNotes)

(D) attribute1 :

attribute :
attribute3 :
attribute4 :
attributes :
attributes :
attribute? :
attributed
attributed
attribute 10
attribute11

attribute15

8 attribute16 :

attribute12 :
attribute13 :
attribute 14 :

Integer
Text
Text
Text
Decimal
DateTime
DateTime

Text
1 Text

1 Text
1 Text
Text
Text
Text
: Integer
Decimal

| v

If you have a work list facade defined, the list of attributes in the right column shows
the display labels for those attributes that were mapped to data fields in the facade.

3. Map the data fields that you want to appear in the Event Viewer to attributes that are

of the same data type.

For example:

w Work Item Attribute / Audit Event Data Attribute Mappings...

Map process data to be automatically assigned to user task work item attributes and process audit event data atiributes.

|type filter text

[ show Only Mapped Content

1 = Contact Mame (ContactMame) L
- "E» Contact Phone (ContactPhone)

= Izsue Description (IssueDescription)
= Izsue Details (IssueDetails)

@ Close (Close)

- (@ Resolution Description (ResolutionDescription)
g @ Resolution Details (ResclutionDetails)

(@ Review Notes (ReviewNotes)

||ty'pe filter text
- (1) attributel : Integer -
b attribute : Text
I attribute3 : Text

(@ attributed : Text
i attribute5 : Decdmal

) attributet : DateTime

] : DateTime

: Text

2 : Text
Wl attribute10 : Text
I attribute11 : Text

- (@ attribute1? : Text

As shown in this illustration, data fields can be mapped to multiple attributes, if

desired.

Note that if you map a data field to an attribute of a smaller size, a warning marker is

shown that indicates this:

(@ attributes : Text
@ attribute10 : Text
U attribute11 : Text

g

|Work Manager : Size criteria of mapped formal parameter 'atribute 10" and data 'IssueDescription’ do not match - this may resultin loss of data.

(@ attribute13 : Text
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This might result in data shown in the Event Viewer being truncated to the length of
the attribute. For information about the type and size of each work item attribute,
see the "Work Item Attributes" topic in the TIBCO Business Studio Process Modeling
Concepts guide.

Result

The example shown above results in the value in the Contact Name field appearing in
Attribute8, and the value in the Issue Description field appearing in Attribute3 and
Attributel0 in the Event Viewer. For example:

(@) 2014-10-12 12:26:40 Created task "Start of 'CSCallbackProcess' with D 'pym:0ai2: Clint Hil ExX_INSTANCE_TASKS_CREATED
@ 2014-10-13 13:25:48 @ Complsted tssk Start of GSCallbackProcess' witn ID' pum:0a Cint Kl BX_INSTANCE TASKS COMPLETED
=3 2014-10-13 13-25.60 Crested task ‘RepResponce’ of 'CSCallbackProcess' with 1D Clint Hll BX_INSTANCE_TASKS_CREATED
[ 2014-10-1313:2550 Scheduled work item 'RepResponce’ of 'CSCallbackProcess” | Clint Hill ERM_WORKITEM_SCHEDULED

() 2014-10-12 12:25:50 Applied work group patterns for wark item Clint Hl ERM_WORKEROUP_EX_APFLY_PAT
() 2014-10-13 13:31:38 Applied work group patterns for work item Clint Hl BRM_WORKEROUP_EX_APPLY_PAT
) 2014-10-1313:31:26 Allocated wark item 'RepResponce’ of 'CSCallbackProcess' ([ Clint Hill ERM_WORKITEM_ALLOCATED_TO
£

ltems 1- 20 of 43. Page 1083 [

& BX_INSTANCE_TASKS_COMPLETED - Event Attributes

Type || Mame & value Type | Component

[ Application activity instance 1D pvm:001iZe String Common Mesz Dats
[ Application activity model ID _cYjsiviBzEd-KaJmNEwWSow String Common Mefa Data
(- Apolication activity name Start String Common hMeta Diats
i Apolication name com.example.cscallback String Comman Mesa Data
[ Adribute10 "36"Meed info about String Common Meta Data
— Affributed Meed info about new CSR application. String Commaon Meta Dista
[ Affributed Ricky Bobbie String Common Meta Diata
- Companent ID Bx String Logging Framewaork

Note that this example also illustrates the result of mapping a data field to an attribute
whose length is not sufficient to hold the entire value entered in the data field. In this
example, the Issue Description field was mapped to an attribute (Attributel0) that is 20
characters in length. Since the value entered in the Issue Description field exceeds 20
characters, the value shown in the Event Viewer is truncated. Since it is truncated, the
value shown in the Event Viewer is prefixed with *nn*, where nn is the number of
characters that were entered into the data field.
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Process Interfaces

You can create a process interface that describes present start and error events that any
sub-process that implements the interface must conform to. In this way, a main process
dynamically decides which sub-process to use at runtime as it guarantees the required
parameters and known potential errors via the sub-process interface.

See Creating Dynamic Sub-Processes.

= EE Generated Services
=% ProcessPackagezz . wsdl
€ Pracessinterface

fa=-=]

Using the Process Interface Editor, you can modify the interface to add events or
parameters:

0'8 Process 08 Process Interface &3 =

°8 Process Interface

General Information Start Events

This section decribes the general information about this Specify events that can be used to start implementations of
process inkerface, this interface,

Marmne: Process Interface () Shart Everl Mew
Description:

Formal Parameters Intermediate Events

Specify the Formal parameters used by events in this Specify in-flow events that can be triggered in

interface, implementations of this interface

¢§>Parameter e Mew

Once created, a process interface can be used by several different processes. If a process is
created using a process interface, all the events and parameters specified in the interface
must be present in a process that implements that interface. You can add additional events
or parameters, but removing any of those required by the process interface invalidates the
process.
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° Tip: If you have additional parameters that are local to a process that
implements a process interface, you can move the parameters into the process

interface by right-clicking the parameter and selecting Move Parameter to
Interface:

This option is only available for processes that implement a process interface in

the same package, and only for parameters that do not have problems in the
Problems view.

If you create a process using a process interface, the process that you create inherits the
events and parameters created in the interface. For example, a start event in a process
created using a process interface displays the following properties:

v Business analysis

v Solution Design

=] =l
Ti T
()
Standard
interface start
event
<
[ ] Properties =2 Problems 2% Fragments
() Start Ewvent
Genceral Label: Standard interface start event
Description Implements Method: | Standardinterfacestartevent
Interface
Data Fields
=

Creating a Process Interface

You can create a process interface from Project Explorer.

Procedure
1. Go to File > New > Other.

2. Expand Business Modeling > Business Process Modeling, select Process Interface,
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and click Next.
3. Enter a name for the process interface you are creating and click Next.
4. Enter a description for the process interface you are creating and click Next.

5. Enter any extended attributes and click Next.

Creating Error Events

Error events are created in the Project Explorer.

Procedure
1. Create a process interface.

2. In the Project Explorer, under the process interface, expand an event. For example:

= ‘1'&;‘ Process Interfaces
=] "k. My Inkerface
s & Parameters
=) Start Events
B0 B
: “ M Errars
: @ Intermediate Events

3. Right-click Errors and then, select New > Error. The following dialog box is
displayed:

® End Event =13
N

End Event

Error Event for a Inkerface Event

Error Code: | Error |

4. Enter a name for the error code and click Finish. The error code you created is
displayed in the Project Explorer, and in the Process Interface Editor:
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V“( Process ntefacss
V‘ﬁ SHandard Invice procesing inteace (Standarl
X Parameters
v () StartEvens
v () Standad neface sttt vent (tancaeinetacetetevent)

v N o

N Sub-Process Ermr

Continue with Error Codes and Process Interfaces to see how these error codes are
used in processes created from a process interface with error codes.

Modification of a Process Interface

You can modify a process interface using the Process Interface editor, however any
changes made cause validation errors in processes that have already implemented the
interface.

For example:

@ BPMN 1 : ProcessInterface musk enable all destinations enabled by the implemented processes, (F‘rocess)

®) EPMN 1 : The methods described in the process interface has ka be implemented in the implementing Process, (Processw
@ BPMN 1 : Transactional Sub-Processes must have a single Start, single None End Event and 0-n Cancel End Events (Process Ei

To correct this problem, ensure that the changes made to the process interface are
reflected in any processes that have already implemented the interface.

Creating a Service Process Interface

A service process interface allows the dynamic selection of service processes at runtime. A
service process interface specifies the deployment target, events and their parameters that
must be present in the service processes created using that service process interface. At
runtime, any of the service processes that implement the interface might be chosen based
on the data available at that time.

o Note: You can only use service process interfaces with service processes.

Using the Service Process Interface Editor, you can add the deployment targets, events and
parameters you require. You must specify one of the following deployment targets:

* the process engine

» the pageflow engine
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The deployment target you choose depends on whether you are invoking your service
processes from business processes or pageflow processes.

Once created, a service process interface can be used by several different service
processes. If a service process is created using a service process interface, the deployment
target, the events and parameters specified in the interface must be present in a service
process that implements the interface. You can add additional events or parameters, but
removing any of those required by the interface invalidates the service process.

If you do have additional parameters that are local to a service process that implements a
service process interface, you can move the parameters into the service process interface
by right-clicking the parameter and selecting Move Parameter to Interface. However, this
option is only available for service processes that implement a service process interface in
the same package, and for parameters that do not have any problems in the Problems
view.

If you create a service process using a service process interface, the service process that
you create inherits the deployment target, events and parameters created in the interface.

Procedure

1. In the Project Explorer, select the package where you want to create your service
process interface, right-click and select New > Service Process Interface.

2. Enter the Label of the service process interface and select Next.

3. In Description, add optional text that describes the process, an optional URL that
links to documentation about the process, and select Next.

Note: The Documentation URL field is intended for design-time
collaboration; it is not displayed in the runtime environment.

4. (Optional) In Destinations, select a destination environment.

5. (Optional) In Extended, add any optional supplemental information to the XPDL for
the process.

6. Select Finish.

The Service Process Interface editor is displayed. Use this to configure the
deployment target for the service process interface and add or remove start events,
intermediate events, and parameters.

7. Once you have created your service process interface, you must configure the
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deployment engine that you want the service process interface to be deployed to.

When you create a service process interface, the deployment target is automatically
set to Deploy to Process Run-time so, if you want your service process interface to
deploy to the pageflow engine, you must select Deploy to Pageflow Run-time in the
General tab of the Properties view. Add any start events, intermediate events, and
parameters and select Save.

o Note: There are other tabs available in the Properties view for service
processes. See Process Properties for more information.

Error Codes and Process Interfaces

The following example shows how a "get balance" example could be implemented as a
sub-process.

The process flow is as follows:

The process is started upon receipt of a start event that contains an account.
The REST service task looks up the account in the database to verify if it is valid.

If the account is valid, another REST service task gets the balance, and the balance
and account number are sent as output.

If the account is not valid, an error code is generated.

Balance

Standard End Event
interface start

event

Throw Error:
Sub-Process
Error

In this case, the sub-process generates an error, and in the calling process the error is
resolved.
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Start Event End Event

Reject Request

The catch error event is configured to detect the error thrown from the sub-process.

= Properties 52 [;_\ Problems | OF Fragments | E Data Source Explorer.

() Intermediate Event

|| General Label: |
Description

Mame: |
Interface

Trigger Type: |Catch Errar
Scripks

Map From Error Catch Error Code; ‘ N Inwalidacct
GRREAANGS Thrown By: ‘@ Call GetBal |/ BalSub f <Error End Event
Extended

Deleting a Process

You can delete a process and decide whether to delete referenced processes.

Procedure
1. Do one of the following:

Right-click the process in the Project Explorer, and select Delete.
e Highlight the process and select Edit > Delete.

e Highlight the process and press Delete:

2. If the process you are deleting is referenced in the parent package (for example, you

are deleting a sub-process), a dialog box is displayed:

If you are sure that you want to invalidate the process that is referring the
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process you are deleting, click Yes.

e If you do not want to delete the process, click No.

3. If the process you are deleting is not referenced in the parent package, it is still
possible that it is referenced by a process in a different package. TIBCO Business
Studio cannot validate against this however and a dialog box is displayed:

» If you are sure that processes in different packages do not reference the process
you are deleting, click Yes.

e If you do not want to delete the process, click No.

o Note: It is also possible to delete a process by deleting the XPDL file
of the package that contains the process in Windows Explorer. This
deletes all processes in that package. If you delete a package in
Windows Explorer while TIBCO Business Studio is open, you must
refresh the Project Explorer to see an updated view of the workspace.

Creating Extended Attributes

Extended attributes can be used to add extra information to the schema.

Extended attributes are as follows:

e XML

For example, an XSD file used by a web service.
e Plain text

For example, Supply Chain Management (SCM) metrics and best practices.

o Note: You can also add extended attributes when creating a new
Process or Process Interface as described in Creating a Business

Process.

Procedure
1. Click the Extended tab.
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o Note: This tab is only available on the Properties view for objects that
support extended attributes.

1 Properties £33 [S_\ Problems OE: Diagram Fragments
() start Event
General Extended Attributes Marme MewAttribube 1
Description Hewdttributel |:
Yalue
Intetface Escape Body [l
Scripts B; dy
Appearance -
[ Extendec
Diown
Advanced

2. Click Add to add a new extended attribute.
3. Modify the following:
¢ Name
Provide a Name for the attribute (you cannot include spaces in the name).

Value

Add any text for the Value.

Escape Body

Select this check box if you want the parser to interpret the contents of the
body attribute as text rather than XML (you do not want the parser to
interpret symbols such as < or >). If you are entering XML, do not select this
check box so the parser can validate the body attribute.

Body

Enter whatever text or XML you want to make up the body of the attribute.

4. Save the package that contains the process.
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Email Presentation Resources

Creating your Email template files

Procedure
1. In Project Explorer, navigate to the project you want to add the Email template to.

2. Right-click on the project and select New > Folder and name your folder.

3. Right-click on the folder you created, and select Special Folders > Use as
Presentation Resources Folder.

4. Right-click the Presentation Resources folder you created, and select New > File and
create the files you require.

Result
Alternatively:

» Right-click Presentation Resources > New > File, and create the files you require.

o Note: If you create the files you require elsewhere, copy and paste them by
copying them and then right-clicking Presentation Resources (or your new
Presentation Resources folder) and selecting Paste.

o Note: This email template is available only to this project. If you attempt to
access it from another project, you receive a validation error, as the files
contained are not available outside this project.

Applying the Email template to a Project

Procedure
1. From the project, right-click Properties > Presentation Channels. Select the check
box Enable project specific settings.
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» or select Window > Preferences > Presentation Channels, and click Configure
Project Specific Settings... Select the project you want to configure and click
OK.

2. Expand Default Channel and select Openspace Email.
3. Click in the Value field for mailTemplateLocation, and you can see the picker:

4. Use the picker, to navigate to the HTML file you created in the Presentation
Resources folder, and click OK.

5. Click Apply.

Result
Next time you push an email, it uses this template.

o Note: Email templates are scoped to one project only. If the template is applied
on the workspace level, then all relevant projects should have the specified
custom template files available inside them. It is then recommended to
overwrite the workspace Presentation Channel definition on the project level
when the custom email template needs to be provided.

Creating an Alternative Email Template

You can create your own email template which can contain organization-specific
information, with your own logos and corporate style.

After deployment it can be used as the default email template for any Push Destination
using the Openspace Email channel type.

The files you can use to create your email template are as follows:

e HTML file (Mandatory) This contains the information about what you want the email
to contain. It typically includes:

° areference to the .css file as its stylesheet. This can be included using an html
line similar to the following:

<link rel="stylesheet" type="text/css" href="cid:Easycss" />
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° references to any of the graphics files contained in the cid.properties file
(referred to by their cid: identifier, prefaced by ’cid:’), for example:

<img src="cid:cidOne"/>

refers to NewProductLogo.png in the example in cid.properties above.
Referring to them in this way means they can be shown externally as part of
the email when the html file is used to create an email after deployment.

° the content you want to include in the email.

This html can contain any of the following tokens, each of which is replaced by
an actual value at runtime;

%%token

%%token

%%token.

%%token.

%%token.

%%token.

%%token.

%%token.

.workItemUr1%%

.workItemId%%

entityName2%%

mailDate%%

mai LFrom%%

mailSubject%%

mailTo%%

mailCc%%

URL of the work item.

The id of the work item.

The entity name who requires push
notifications as defined in the Organizational

Model.

The date and time the pushed mail message
was sent.

The name of the sender of the pushed mail
message.

The subject line for the pushed mail message.

The user/s who the pushed mail message is
sent to.

The user/s who the pushed mail message is
copied to.
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%%token.mailBcci% The user/s who the pushed mail message is
blind-copied to.

%%token.hostIPAddress%% The IP address of the host.
%%token.hostMachineName%% The host machine name.
%%token.baseur1%% The base URL.

e CSS (Cascading Style Sheet) file This is a stylesheet file, typically for your
organization, which contains standard information such as banners or background
colors, that you want to be in every email you send.

 graphics you are referencing from the cid.properties file, which would then be
used by the html file. These must be available locally, and can either be in the same
directory (Presentation Resources), or in a sub-directory.

o Note:

o cid.properties This allows you to reference any graphics files you
have available locally (in the same directory, or a subdirectory)
which you want to be used when you push the work item (which
then sends an email to notify the user of the work item). It is
specifically used for embedded images / css in emails, rather than
providing the option of external calls.

° Each file name has a cid: <name identifier which allows it to be
accessed remotely as well as locally. For example, the cid.properties
file might contain lines such as the following, where cidone is the
cid: identifier for NewProductLogo.png when you reference it later in
the HTML file:

cidOne:NewProductlLogo.png

Correcting Validation Errors

Any problems that result from validation are shown in the Problems view.
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To correct the problem, do one of the following:

» Right-click the problem and select Quick Fix (if enabled for the current problem).
This gives you the option of having TIBCO Business Studio correct the problem for
you.

» Double-click the problem or right-click the problem and select Go To. This displays
the Process in the Process Editor, highlighting the offending object and allowing you
to manually correct the problem.

Setting the Validation Preferences

You can customize the validation that is performed in the Process Editor. Specifically, for
each validation error you can specify its severity level as Error, Warning, Info, or Ignore.

Procedure
1. Go to Window > Preferences.

2. Expand Process Editor and select Errors/Warnings. The following dialog box is
displayed:
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3. If you want to change the severity level for a Process Editor problem, select from the
drop-down list. When you have finished, click Apply to effect any changes you have
made.
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o Note: You can downgrade the severity of BPMN errors, however some
TIBCO Business Studio errors are not displayed because downgrading
them would allow processes to be deployed that would be invalid in the
runtime environment.

4. The following dialog box is displayed:

® Error/Warning Settings Changed

The ErrarWarning settings have changed, A full revalidation is required For
\‘:/ changes to take effect, which may take some kime. Do the Full resvalidation
[y {ultiFy

[ Yes H Mo ” Cancel ]

* Click Yes to re-validate your workspace. Depending on the size of the workspace
and the number of errors, there is a delay while the re-validation occurs.

e Click No to re-validate your workspace later. The re-validation takes place when
the concept file next changes or is saved, or when you explicitly request a
rebuild of the project or workspace.

» Click Cancel if you do not wish to apply your changes.

Note: At the top of the dialog box there is a drop-down list that
allows you to select either BPMN or Simulation.

Configuring the Problems View

You can configure the appearance and display of the Problems view.

Procedure
1. Select items from the menu in the upper right of the Problems view:
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e
Shio »
Group By 4
Sork By L4

Mew Problems View

Configure Conkents, .,

Colurmns, ..
Preferences

2. Select Configure Contents to filter the problems that are displayed:

Result

# Configure Contents

Configurations: * Scope

All Errors
Warnings on Selection

(3) Cn any element

O On any element in same project

() on selected element anly

() on selected element and its children

() On working set; Window Working Set

= Description:

Drescripkion | conkains w | |

where severity is: [¥]Error [ ]warning [ Info

~ Types

AP Problems ~
APT Problems

At Buildfile Problem i

EIRT Wiewer Problem

EFMN Prablems

DTD Prablem

Driver Prablems

Duplicate Resource Problems

() Match all configurations [1 FrF Prablem

O

£

[ Ok H Cancel ]

Two configurations are provided by default, All Errors and Warnings on Selection. You
can create and save your own configurations. You also can reduce the number of errors
displayed by selecting a different scope. For example, by choosing Selected element only
as the scope in conjunction with the All Errors configuration, you can see all errors for the
selected element only rather than for all elements in the workspace.

By default, problems in the Problems view are grouped by severity of the problems.
However, you can change this using the Group By menu option. For example, to arrange
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the Problems by their type, select Group By > Plug-in Problem Type. You can also add or
remove types in the previous Configure Contents dialog box.

Design Considerations for Process Migration

A process instance can only migrate to a new version of a process when certain criteria
become satisfied.

These are automatically identified by TIBCO Business Studio at design-time, but you should
be aware of the points described in Migration Point Restrictions.

Migration Point Viewing

Valid migration points in a process are denoted by an icon next to the task in the Process
Modeler, and by process diagram annotations which allow identification of individual
activities as migration points as and when they are viewed in the diagram.

You can increase or decrease the visibility of these icons by hovering over the icon and
using the selections (shown in the screen capture below).

Migration Paoint Ackivity.
An existing process-instance can migrate to the
niew version of the process upon reaching this

Skart Event ackivity,
= Decrease Visibiity = Increase Visibility

Pinc i

Each selection you make is additional to those you have made before. For example, when
you select a data field then all the activities that reference that data field are highlighted in
the process diagram. If you then also select the Highlight Activities With Scripts option,
then only the activities that reference the data field and have scripts are highlighted.

=
Q'JI&H*J%'G'%'J
& Highlight: Migration Paint Activities
E Highlight Activities With Scripks

'3.1. Process Message APT Activities

aT

<—+Conditional Sequence Flow

w Enable Highlighting
W Enable Highlight &nimation
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To clear selections, click in the Process Editor window again, and it goes back to its default
setting, which is to show migration points.

You can also choose to highlight migration points by selecting Highlight Migration Point
Activities from the drop-down toolbar.

Migration Point Restrictions

You should be aware of a number of restrictions when designing your process to be sure
that it can migrate correctly.

» The task name is used to identify a migration point. This means that all tasks must
have names.

o Note: By default, gateways do not have names. This means that you must
specify a name for all gateways in your process if you want them to be
valid migration points.

Note that:
° task names must not be duplicated.
° task names in source and destination process templates must be the same.

» Migration cannot be performed on pageflow processes. Pageflow processes are short-
lived processes whose data is not persisted, therefore migration should not be
required.

» For a user task, migration should be set before the user task is scheduled. Migration
does not happen if the changes are made after the user task is OFFERED to a user.

» Valid migration points are points of the process template where a single process
thread executes. Therefore, a task that starts a parallel path is a valid migration point
but any tasks that follow are not until those paths are rejoined.

» Part of a process that does not appear to be a parallel flow might be treated as a
parallel flow. A primary example of this is to receive tasks without inflows and any
sort of task boundary event. If the flows out of these tasks are not merged back into
the process then everything after that point is treated as a parallel flow. This is
because without an explicit merge back into the flow then there is an implicit merge
at the end of the process (hence all other activities on those flows are counted as "in-
parallel" with the receive task).
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* Any tasks inside embedded sub processes cannot be migration points, but the
embedded sub process itself might be a migration point. See Embedded Sub-
Processes. Migration takes place before starting the sub process.

* These events cannot be migration points:
° start events

o events placed on the boundaries of tasks.

See Events.
o Tasks that follow these gateways are not valid migration points:
° Inclusive
o Complex
o Parallel

o Tasks following tasks that have Timer events placed on their boundary with
Continue Task on Timeout selected are not valid migration points:

» Tasks following tasks with multiple instance loops with ordering set to Parallel and
flow conditions that are set to One are not valid migration points. This is equivalent
to an exclusive gateway, and means that only the completion of the first activity
instance causes flow to continue.

» BPM Validation Configuration on the Resource properties tab of a process is used to
suppress problems markers for the ’No migration point activities in the process’
Problem. It gives you the choice of validation, suppressing the error until the next
process flow change, or suppressing the error until a manual reactivation via
Resource properties.

» Migration points cannot be set on an event handler flow but it is possible to modify
an event handler flow which can then be triggered after a process migration from a
migration point set somewhere on the main flow.

» Event handlers (and other incoming request activities) are automatically re-initialized
during process migration. This means that they are re-activated using the new values
for correlation data.

» When adding an ad-hoc event to a new process version, the initializer for the ad-hoc
event must be defined as the migration point or come after the migration point in
order for the ad-hoc event to be available after process migration. If the initializer is
in a part of the process that has already been executed before migration, the ad-hoc
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event does not take effect in process instances that have been migrated.

» Migration is delayed with an audit message if the event handler thread is not
complete. The migration completes once all outstanding event handler threads have
been completed.

e When you add a new ad-hoc activity, and then upgrade and migrate, you must define
an initializer for the activity. This could actually be the migration point itself.

Comparison of Different Versions of a Process
Package

You can compare the local Process Package you are working on with another version.
This can be used to identify:

e any changes you have made since the last time you saved that Process Package. See
Performing a Two-way Compare.

e any changes made by another user in the Subversion copy since you last checked it
out. See Use of the Process Package Comparison Editor with a Two-way Compare.

Note: This ability to show a comparison graphically is also available for Task
Libraries.

See Source Control for more information using source control to manage your processes.

Performing a Two-way Compare

You can compare your current local copy of the Process Package with a previous local
revision.

Procedure
1. Select the Process Package .xpdl file in Project Explorer, and right-click it.

2. Select Team > Show Local History. This option shows you a list of your revisions to
the file.
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3. Select the previous revision you are interested in comparing with your current
version, and right-click Compare Current with Local.

o Note: The default is to keep local history available for 7 days. If you need
to see more history than this, select Window > Preferences > General >
Workspace > Local History and edit the settings.

4. You can then compare the file you selected with your current local copy. The Process
Package Comparison Editor is displayed showing you a tree of elements that are
different in the two files. This is a two-way compare. In the Process Package
Structure Compare window at the top of the screen, expand the Process Package and
select the level you are interested in (for example, Activities).

The left/right revision views are populated with the tree structure of the different
descendants of that element. The differences in your local copy are shown in the left-
hand column.

Use of Process Package Comparison Editor with
Two-way Compare

These notes help you interpret the results of a two-way compare. The screen capture
below shows you an example of a two-way compare.
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» The following icons indicate changes in a two-way compare:

As no common ancestor is available for comparison, all differences are treated as if
changes were made on the left-hand revision):

A green [+] (with no indication of direction) indicates elements that appear in the
left-hand revision that do not appear in the right-hand revision.

A green [-] (with no indication of direction) indicates elements that appear in the
right-hand revision that do not appear in the left-hand revision.

Items that do not have an icon by them are changed in either the left or right hand
revision, or both (or have added, deleted or changed descendants).

If you hover the cursor over the relevant icon, tooltip pop-ups let you know that the
information was added to the left or deleted to the right - so you might have added
something, or the other version might have deleted something.
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In a two-way compare it is not possible to identify which version the change was
made in.

* In the Comparison view, you see Information elements (as indicated by the icon.
These elements are always shown regardless of whether there are any differences in
the data that they represent. This is to give you a context for given elements and
usually contain the 2 or 3 major configurations for that element (such as task type,
name and so on).

* Internal Properties (found at the level below a task, for example) is used to group a
number of smaller changes made as the result of your main change/s under one
heading. You are unlikely to need to examine these, but if you do want to see them

in more detail select the 1= button above and to the right of the left/right content
view.

* The central section of the comparison view shows connection lines between
correlating objects on the left and right side. These include icons according to what
the difference is (and on the side of the connection line where the change that
caused the difference was made). The lines are color coded to indicate the type of
change that they represent (red = conflicting change, green = addition or deletion,
blue = existing element changed).

Performing a Three-way Compare

A three-way compare is used to compare your changes to a Process Package with those
of another user, as well as with the original (common ancestor) file on which both are
based.

Typically, you might want to do this if another user checked a process package out of
Subversion when you did, and they made changes and checked them back in. When you go
to check your own version back in, Subversion identifies a potential conflict. To identify
areas which the other user has changed and decide whether to adopt their changes and
abandon yours, or overwrite them with your own, you can do a three-way compare.

o Note: Three-way compare is only available once a synchronize has been
performed on the file (or its project). Synchronize is performed automatically for
any file when it is committed to Subversion (to ensure that no conflicts exist
with another user's changes).
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See Source Control for information about using source control to control your project
information.

To do a three-way compare (when you have checked a project file out of the source
repository and made changes and saved them - and another user has done the same and
committed their changes):

Procedure
1. Attempt to commit your changes in the Team Synchronizing perspective.

You might discover that your changes conflict with those of another user and you
cannot commit your changes until you have rectified this.

2. Select Open in Compare Editor to identify whether you want to adopt the changes
from the other user, or commit your own changes instead.

Use of Process Package Comparison Editor with
Three-way Compare

These notes help you interpret the results of a three-way compare.

» The following icons indicate changes in a three-way compare:

A blue left-pointing arrow containing [+] indicates an element added in the right-
hand revision (as compared with the common ancestor).

=

A blue left-pointing arrow containing [-] indicates an element removed in the
right-hand revision (as compared with the common ancestor).

@

A plain blue left-pointing arrow indicates an element changed in the right-hand
revision (as compared with the common ancestor).

E

A gray right-pointing arrow containing [+] indicates an element added in the left-
hand revision (as compared with the common ancestor).

@

A gray right-pointing arrow containing [-] indicates an element removed in the
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left-hand revision (as compared with the common ancestor).

A plain gray right-pointing arrow indicates an element changed in the left-hand
revision (as compared with the common ancestor).

Red arrows pointing both ways indicate a conflict: the element or its descendants
were changed in both the left-hand revision and the right-hand revision.

« If you hover the cursor over the relevant icon, tooltip pop-ups let you know that the
information was added to the left or deleted to the right - so you might have added
something, or the other version might have deleted something.

In a three-way compare, you can distinguish whether an additional element was
caused by an addition by someone else or a deletion by you. This is because the
comparison can check whether the additional element existed in the common
ancestor, and if it did not, then you can know whether you have changed it or
whether it was another user.

In the Comparison view, you see Information elements (as indicated by the icon.
These elements are always shown regardless of whether there are any differences in
the data that they represent. This is to give you a context for given elements and
usually contain the 2 or 3 major configurations for that element (such as task type,
name and so on).

 Internal Properties (found at the level below a task, for example) is used to group a
number of smaller changes made as the result of your main change/s under one
heading. You are unlikely to need to examine these, but if you do want to see them

in more detail select the i button above and to the right of the left/right content
view.

e The central section of the comparison view shows connection lines between
correlating objects on the left and right side. These include icons according to what
the difference is (and on the side of the connection line where the change that
caused the difference was made). The lines are color coded to indicate the type of
change that they represent (red = conflicting change, green = addition or deletion,
blue = existing element changed).
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Process Fragments

TIBCO Business Studio provides predefined fragments in the folder BPMN Process
Fragments.

Also see the "Process Fragments" topic in the TIBCO® BPM Enterprise Concepts Guide.

Migrating Fragments from Previous Versions

Any fragments that you created in previous versions of TIBCO Business Studio must be
migrated to the current version, but the predefined fragments that TIBCO Business Studio
provides do not need to be migrated because they are available in the current version.

Procedure
1. Go to File > Import > General > Existing Fragments Projects into Workspace, and
click Next. In the Import dialog box, click Browse to select the directory where your
fragments are located.

2. Select the fragments that you want to migrate, and click Finish.

Using the Predefined Fragments

You can use one of the predefined fragments.

Procedure
1. Open the process.

2. Make sure that the Fragments view is visible. If it is not, select Window > Show View
> Fragments.

3. In the Fragments view, there is a navigation tree that looks similar to the Project
Explorer. This is the Fragment Explorer. Expand BPMN Process Fragments folder.
This contains categories of BPMN process fragments.

4. Expand the category that contains the fragment you want to use.
5. Select the fragment.

6. Drag the fragment onto the process.
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Tip: You can also use the Copy and Paste menu options either by right-
clicking or by selecting from the Edit menu.

Creating Custom Fragments

If a portion of your process is one that you are likely to reuse in other processes, you can
capture the useful part of the process and save it as a custom fragment.

Create a new category by either right-clicking BPMN Process Fragments in the Fragment
Explorer and selecting New > New Category or by clicking the Create New Category

button ().

Procedure
1. Double-click in the name field of the newly added category and enter a name:

Properties | Problems ':E:Iiagr'arn Fragments X

=] % BPMM Process Fragments
IR} Basic Fragments
% External Systems

3y Frags

2. Do the following:

a. Holding down the Ctrl key, select the activities and sequence flows in the
process that comprise the fragment.

b. Copy and paste the fragment into the Fragments view:

=l Properties [3_1, Problems c:',tEfFragrnenI:s &3

= [y BPMN Process Fragments New Fragment

@) Basic Fragrments

- Process Templates
O.? Case-working process
OQ CIM Main process - =

OQ CIM Main process Irvvoke Bank WS

OQ Simple Integration Process
m';' Simple Process
Df_;f Sirnple WorkFlow Process
Df_;f Start and End

==Y My Frags
oo

&g "1l Fragment
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Importing Custom Fragments

You can import custom fragments from an archive file or a .bsProject folder.

Procedure
1. Create an archive file that contains the .bsProjects folder from your workspace. This
folder contains your custom fragments.

2. The recipient of the archive file can then import it. To do this, go to File > Import >
General > Existing Fragments Projects into Workspace, and click Next.

3. In the Import dialog box, select the Select archive file check box and click Browse
to select the archive file that contains the fragments you want to import.

4. Click Finish. The fragments are imported into the current workspace.

Result

o Note: Alternatively, to import from the .bsProject folder, go to File > Import >
General > Existing Fragments Projects into Workspace, and click Next. In the
Import dialog box, select the Select root directory check box and click Browse
to select the location of the .bsProject folder from the file system. Click Finish.
The fragments are imported into the current workspace.
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Business Object Models

The business object (data) model is where you define in business terms the Classes,
Attributes, Primitive Types, Operations, Associations, and so on that describe your business

data.

There are a number of common tasks that you perform using the Business Object Modeler
in TIBCO Business Studio.

o Note: You can use quick-find (Ctrl+F) in the project explorer to find existing
business object model entities and select them in the project explorer.

When you have created a business object model, you can search for business
object model diagram elements within it using quick-find (Ctrl-F) within the
diagram, and entering the initial characters of the name you are searching for.
Double-click the element you are shown in the search to go to its location in the
diagram.

Business Object Model Creation

A Business Data project contains Business Object Models within the Business Objects
folder.

When you create a new Business Data Project (File > New > Business Data Project), the
initial Business Object Model (.bom) asset is created.

You can add more business object models to describe other aspects of your business data
by creating additional business object model assets in this folder. You can also organize
your business data into a discrete hierarchy of reusable business data projects.
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Creation of a Model by Import

As an alternative to using the Business Object Modeler to create a business object model,
you can import it to a Unified Modeling Language (UML) model and TIBCO Business Studio
automatically converts it to a business object model.

Importing Existing UML Models into the Business
Object Modeler

You can import existing unified modeling language (UML) models into the Business Object
modeler.

Procedure
1. Start the import wizard using one of the following methods:

» Right-click the Business Objects folder, and select Import > UML Model.
e Go to File > Import > Business Object Modeler > UML Model.

2. The Import UML Model dialog box is displayed:
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"ﬂ' Import UML Model ;Iglﬂ -

Import UrL Model
Import the selected Files. S:E
Fram Direckary: IC:'I,Data j Browse. .. |

= # carporate. uml

Select All | Unselect all |

Into Folder: |Easy.¢\sll'Business Ohjects Browse, ., |

Opkions
’]_ Crverwribe existing resources without warning

7 Finish I Cancel |

Click the Browse button to select the From Directory where you have stored the
UML model. Any UML models that are found are displayed.

In this example, the UML model c:\Data\corporate.uml is selected.

3. Browse to select the Business Objects folder into which you want to import the
model.

Select the Overwrite existing resources without warning check box if you know
you want to replace an existing model with the one you are importing; otherwise
TIBCO Business Studio prompts you to confirm whether to overwrite the existing
model.

4. Click Finish. The Model is imported into the folder that you specified.
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Business Object Model Editor

You can add objects to your business object model or concept model, and edit them, using
the Business Object Model Editor.

Adding Diagram Nodes to a Business Object Model

To create a business object model, you add diagram nodes (Package, Class, Attribute,
Primitive Type and Operation) and connect them with Connections (Association and
Composition).

You can add diagram nodes and connections in any of the following ways:

e Using the tools on the diagram editor’s palette. The palette contains tools that
enable you to add a diagram node or a connection either by selecting the required
tool in the palette and dragging and dropping on to the diagram, or by clicking on
the tool in the palette and then clicking on the diagram.

If there is a stereotype already applied to your business object mode, the palette
contains additional tools to create business objects with the stereotype already
applied to them. See Applying Stereotypes to Business Objects for more detail about
stereotypes.

e Using the pop-up icons. If you hover your mouse over the empty area of the diagram,
or over a Package, a pop-up containing icons appears. Hover over these icons to
display label as shown in the following illustration, and then click to create a new
node of that type in the diagram.

& B

Similarly, hovering the mouse over a Class displays icons for Attribute and Operation.

» Using the Project Explorer. You can add new diagram nodes (such as adding a new
Package, Class, or Attribute) using right-click menus in the Project Explorer. For
example, to add a new Class, you can expand the Project Explorer, select the
business object model, and right-click Add Child > Class.

The Project Explorer menus list the objects appropriate to the context. For example,
if you select a Class and right-click Add Child, the following menu is displayed:
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El@ Business Objects
El--- EusinessobjectMadel.bom
El-- com.example, businessobjectmodel

W= o Child d © Athribute

o Dperation

Renarne

=| Copy

b=l

Paste
¥ Delete

=] Show Properties Wiew

Adding Classes and Attributes

You can add classes and attributes to your Business Object Model.

Procedure

1. Using the Class tool, place a Class on the model and name it.

2. Using the Attribute tool, place Attributes within the Class.

3. In the Properties view for each Attribute, select the Type and specify whether there
can be multiple values for the Attribute (whether it is an array). (See "Attributes" in
the TIBCO® BPM Enterprise Concepts Guide for more information about attribute types
and multiplicity). When you specify multiplicity values in the Properties view for
Attributes, you can use content assistance. Press Ctrl+Space in the field and the
available multiplicity values are displayed.

To apply restrictions to your Primitive Type, click the Resource tab and expand
Restrictions.

4. Using the Operations tool, place Operations within the Operations Compartment in
the lower section of the Class graphic.

5. In the Properties view for each Operation, specify the return value type and any
parameters or parameter types.

6. In the Properties View for each Class, Attribute or Operation, click the Stereotypes

tab to apply any stereotypes you want to apply. See Applying Stereotypes to
Business Objects for more information.
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Adding Primitive Types

To add a Primitive Type to your business object model, use the Primitive Type tool, drag-
and-drop a Primitive Type on the model and name it.

fext

[ | PostCode |

When you create a Primitive Type, it is always created with a standard type of Text. To
select another standard type for the Primitive Type:

Procedure
1. In the Properties View for the Primitive Type, select the General tab.

2. Click the picker to display the Select Type dialog box. To display a list of the
available types you can set, type ? in the Select Type(s) field. A list of the available
standard types is displayed.

3. From the Matching Items box, select a standard type and click OK.

Result

To apply stereotypes to the Primitive Type, click the Stereotypes tab. See Applying
Stereotypes to Business Objects for more information.

To apply restrictions to your Primitive Type, click the Resource tab and expand
Restrictions.

Connections

Connections indicate the relationships between Classes and include Association and
Composition.

See Creating an Association between Two Classes

See Composition
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Creating an Association between Two Classes

You can create an association between two classes. An association is a relationship
between two classes.

Procedure
1. Click the Association tool on the Palette.

2. Drag from one Class to the other. This creates a bi-directional Association. You can
change the direction of the Association by selecting from the Navigability drop-down
list in the Properties view. You can also change the Source or Destination of the
Association in the Properties view.

Note: A bi-directional Association shows both the Source and Destination
on the business object model. A Unidirectional Association shows only the
Destination.

You can also set the Multiplicity of each end of the Association by selecting from the
Source Role Multiplicity and Target Role Multiplicity drop-down lists in the
Properties view.

3. In the Properties View for each Association, click the Stereotypes tab to apply any
stereotypes you want to apply. See Applying Stereotypes to Business Objects for
more information.

Composition

Compositions are created in the same way as an Association and share the same
properties. The only difference is the meaning and appearance of the Connection.

See Creating an Association between Two Classes.

Adding Text to a Model

You can add a note or text to your business object model to describe the business object
model or to add any supporting explanations to the diagram nodes.
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o Note: When adding text or a note, press Ctrl+Enter to start a new line.

To add a note

e Right-click on the Business Object Model Editor and select Add > Note.

 In the Business Object Modeler palette, select the Note tool in the upper part of the
palette.

I e Palette [
[T @ -
[ Elements L"'E el

Jr'-.ll:ul:e - Create a Nl:ute|
Packag =

Then, click the Business Object Model Editor.

Note: You can also select Text or Note Attachment from this menu. The
icon for the tool changes to show the item you have selected.

== Palette [

[ & &[0
[==Element » | Moke
Pack: = Text

i
B Class 4 IMaoke Atkachment

A Note is displayed where you can enter any text you require. Use the Note Attachment
option to draw a line connecting a Note to the Class it comments on.

To add text

e Right-click on the Business Object Model Editor and select Add > Text.

* In the Business Object Modeler palette, select the Text tool in the upper part of the
palette and then click on the Business Object Model Editor.

A Text box is displayed where you can enter any text you require.
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Models

You can use various methods to create your Business Object or concept models.

Copying Diagram Nodes Between Models

You can copy Classes, Attributes, and Primitive Types between models.

The business object models can be in the same project or in different projects. To copy
business objects between projects, you must create a project reference between the two

projects.

To copy business objects between projects, follow these steps:

Procedure

1. In the Project Explorer, expand the business object model that contains the diagram

nodes you want to copy.

2. Open the business object model that you want to copy the diagram nodes to.

3. Drag the diagram node to the Business Object where you want to add or create a

new object. A menu is displayed in the new model that prompts you to specify what

action to take for the new object. The menu that is displayed depends on the type of
business object you have copied. The following example displays the menu based on
the type of business object:

= 12 Medical Insurance
= @ Business Objects
= Medicallnsurance. bom )
= d5] medicalinsurance

E-{dh primitiveTypes = Doctarvisit = Doctor
=] .Patlentm o patientID : PatientlD 1 1 @ participatingDaoctar : Tesd
® = Clac'lm " & rcondition : Text | )
£} Deductsble o wici .
@ wisitType : Text
#-= Dactor cloctor
#-E Dactorvisit - — - @ (Creake Properky
&3 patient ¢ createClaim(visithotes) : Claim F 7 set as superclass _d
#-= persan 1
= 1&; MyAnalysisProject
=¥ Business Objects soUrcebacto
= * BusinessObjectMadell. barm 1 clairn
=4 businessobjectmodel1 — o = 1

<

B Classz

= Properties 52

If the business object models are in the same project, the item is copied to the new
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Model Organization Tools

model. If the models are in different projects, a Project Reference message is
displayed. Click Yes to create the project reference or click No. If you click Yes, the
object is copied to the new model.

Some models are simple to follow but larger and more complex models are more difficult
to read. The Business Object Modeler provides tools to make models easier to understand.

Icon

Command

Apply the applicable appearance
properties of the first selected shape to
the other selected shapes

Select All

Select All Shapes

Select All Connectors

Arrange All

Arrange Selection

Align Left

Align Center

Align Right

Description

Applies the applicable appearance
properties of the first selected shape to
the other selected shapes.

Selects all business objects in the Model.

Selects all shapes in the selected
Package.

Selects all connections in the selected
Package

Arranges all the business objects in the
Model so that they are evenly spaced.

Arranges the business objects in the
Model that you have selected so that
they are evenly spaced.

Aligns the selected business objects to
the left of the Model.

Aligns the selected business objects to
the center of the Model.

Aligns the selected business objects to
the right of the Model.
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Icon Command Description

Align Top Aligns the selected business objects to
the top of the Model.

Align Middle Aligns the selected business objects to
the middle of the Model.

Align Bottom Aligns the selected business objects to
the bottom of the Model.

Autosize Automatically sizes the selected business
objects to the smallest size.

All Connector Labels Displays all connector labels in the Model

No Connector Labels Displays no connector labels in the
Model.

All Compartments Displays all the compartments within a

selected Class.

No Compartments Only displays the name of a selected
Class. Attributes and Operations are not
displayed.

Applying Stereotypes to Business Objects

You can apply stereotypes to all the business objects in your business object model. You
can apply as many UML profiles to a model or Package as you require.

You can apply the UML profile to the business object model or a package first, or it can be
applied automatically when you apply a stereotype to an object.

The UML profile must exist in the BOM Special Folder (typically, the Business Objects
folder for your project). The Select Type(s) dialog box is used to apply stereotypes and then
display all the available stereotypes in that profile. If you select a stereotype from a profile
that has not yet been applied to the business object model or Package, the profile is
automatically applied when you click OK to apply a stereotype.

TIBCO Business Studio™ - BPM Edition Modeling Guide



191 | Business Object Models

Procedure
1.

In your business object model, select Properties View for the business object that
you want to apply the stereotypes to.

On the Stereotypes tab, click the picker to display the Select Type(s) dialog box.

Type ? in the Select Type(s) dialog box to display a list of the available stereotypes
that you can apply.

From the Matching items box, select a stereotype and click Add.

Click OK to close the dialog box.

To edit your stereotypes, select Properties View for the diagram node which has the
stereotype applied to it and click the Resource tab. The Stereotype is displayed in
the Resource tab.

Setting Diagram Preferences

You can customize the appearance of the Business Object Modeler by following these

steps:

Procedure
1. Go to Window > Preferences.

2. On the Preferences window, expand Diagram and then, expand Business Object
Model Diagram. The following options are displayed:

Appearance: Displays a dialog box where you can change the color of fonts,
backgrounds, fill colors, and so on.

Connections: Displays a dialog box where you can change the line style of the
Connections in the Business Object Modeler (for example, Associations).

Pathmaps: Displays a dialog box where you can specify path variables to
modeling artifacts that you might want to use in your business object model.

Printing: Displays a dialog box where you can specify the print settings for your
business object models (for example, orientation, page size and the margins).

Ruler and Grid: Displays a dialog box where you can specify whether or not the
ruler or grid is displayed when defining business object models in the Business
Object Modeler.
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Note: The Printing and Ruler and Grid options apply only to the
Business Object Modeler and not to the Process Modeler.

Result

Any changes you apply only affect the new objects. To change the appearance of existing
objects, select the object then, use the Appearance tab in Properties view or the options
on the Diagram menu.

Setting the Validation Preferences

You can customize the validation that is performed on the business object models that you
create. You can specify its severity level as Error, Warning, Info, or Ignore.

You can customize the validation preferences by following these steps:

Procedure
1. Go to Window > Preferences.

2. Expand Business Object Modeler and select Errors/Warnings. The following dialog
box is displayed:
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¢ Preferences

type filter text Errors/Warnings Eroivy
» General o i
» Ant BPM v
7 Business Object Modeler Select severity levels for the following problems:

Diagram + Configurable Process Manager Rules
» Documentation

Form Designer The derived element name ‘<names' for WSDL message- | Emar -~ ~
» Help The element/type name '<name>" for WSDL message-pa | Warning v
 Install/Update -

i The element/type schema namespace "<name>" for WSDI v
» Plug-in Development Type Declaration externally referencing BOM Class is currs | Emar - v

Presentation Channels
v Process Modeler
Automap Rules
Errors/Warnings
» Run/Debug
» Team
» TIBCO BPM General

TIRCO Help .
) TIBCO JavaScript v |Restore Defaults | Apply

@' Y% Apply and Close Cancel

3. To change the severity level for a business object model problem, select Error,
Warning, Info, or Ignore from the drop-down list.

4. After making the selection, click Apply to apply the changes while keeping the dialog
box open. Alternatively, click Apply and Close to save the changes and close the
dialog box.

5. The following Error/Warning Settings Changed dialog box is displayed:
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7

'e' The Error/Warning settings have changed. A full revalidation is required for changes to
° 4

Error/Warning Settings Changed

take effect, which may take some time. Do the full revalidation now?

Yes No Cancel

Click Yes to re-validate your workspace. Depending on the size of the workspace
and the number of errors, there is a delay while the re-validation occurs.

Note: This rebuilds every Project in the workspace. It might result in
the deployment of any Projects that are configured to deploy up
when they are saved.

Click No to re-validate your workspace later. The re-validation takes place when
the business object file next changes or is saved, or when you explicitly request
a rebuild of the project or workspace.

Click Cancel to override your changes.
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Organization Model

This section describes how to create a basic Organization Model using the Organization
Modeler in TIBCO Business Studio.

Organization Model Creation

An Organization Model must be contained within a project that contains an Organization
Model special folder.

You can create an Organization Model in the following way:

» Create a new Organization Model Project (which by default creates an Organization
Model and corresponding special folder).

Creating a Project Containing an Organization
Model

You can create an Organization Model in a new project.

Procedure
1. Go to File > New > Organization Model Project.

Note: You can also select File > New > Analysis Project or File > New >
BPM Developer Project and create a project containing an Organization
Model as well as other assets.

2. The New Project wizard is displayed. Enter a name for your project in the Project
name field and click Next.

o Note: This accepts default values for Location, Id, Version, and Status.
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3. In the Asset Type Selection dialog box, ensure that the Organization Model box is
checked. Click Next.

4. In the Organization Model dialog box, ensure that Create initial Organization Model
is checked. In the file name field, enter a name for the Special Folder for
Organization Models, or use the one provided by default. Click Finish.

o Note: Leave the Create default schema types box checked to use the
delivered schema.

Check the Apply default Organization Type to Organization box if you
want the Organization Type delivered in the default schema to be applied
to the initial organization created. If not, leave it unchecked.

See Creating a Schema for further details.

5. If you are not already in the BPM Modeling (or Modeling) perspective, you are
prompted to switch to BPM Modeling. Click Yes to switch perspective.

Adding an Organization Model in an Existing Project

You can add an Organization Model to an existing project. However, you must first create a
special folder.

Procedure
1. Right-click the project where you want to add the Organization Model and select New
> Folder. The New Folder dialog box is displayed.

2. In the Folder Name field, type the appropriate folder name. Click Finish to close the
dialog box.

3. Right-click the Organization folder and select Special Folders > Other > Use as
Organization Models Folder. If you right-click on the Organization folder now, the
option to create a new Organization Model is available.

Creating a Schema

The Organization Schema is contained in the Organization Model file (named by default
organization.om, where organization is the name of the organization for which you are
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creating the Organization Model).

Procedure
1. To create the default schema, when you are creating an organization model, either as
part of creating a new project or separately, ensure that you leave the Create
default schema types check box selected.

If you select the Apply default Organization Type to Organization check box, the
default Organization Type (called Public Company) from the default schema is
applied to the initial Organization that is automatically created as part of this
Organization Model. If you leave this check box empty, the Standard Organization
Type is not applied.

Note that if you do not select Create default schema types, the Apply default
Organization Type to Organization check box is not available:

2. Click Finish. The default schema is created.

Using Your Own Schema Types

You can use your own schema types by following the procedure described for creating a
schema, but without selecting the Create default schema check box.

See Creating a Schema.

Procedure
1. To use your own schema type, when you are creating an organization model, either
as part of creating a new project or separately, ensure that you deselect the Create
default schema types check box.

Note that if you do not select Create default schema types, the Apply default
Organization Type to Organization check box is not available so the Standard
Organization Type is not applied:

2. Click Finish. Your own schema type is created.

The schema created does not include the standard types provided with the default
schema. The only type created is one Resource type, the Human Resource Type.
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o Note: Unlike the Human Resource Type created in the default schema, this
one has no attributes defined.

Result
The following illustration shows what is visible in the Project Explorer when you have
created a non-default schema:

=-158] Schema

E Location Types
% Qrganization Types
% Croanization Unit Relationship Types

----- @ Organization Unit Types

ﬁ; Position Types
=] Resource Types

----- EI Human Resource Type (HumanResourceType)

Creation Types in the Schema

If you are building your own schema, you need to create the types that make it up.

If you are using the default schema provided, you can create new types to add to the
schema in the same way as you would for a new schema.

You can also modify the types provided. You can extend the default schema provided by
setting up additional attributes to define more closely the elements that make up the
organization you wish to model.

Creating a Location Type

You can create a location type in a schema.

Procedure
1. In the Project Explorer, expand the Schema folder for your Organization Model.

2. In the Schema folder, right-click Location Types and select Add Child > Location
Type. A new Location Type is created.

3. Click the General tab in the Properties view. In the Label box, type the name of the
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Location Type.

Click the Attributes tab. Click to add an attribute. Type in the name and select a
type for the Attribute from the Type drop-down list. See the "Attributes" topic in the
TIBCO® BPM Enterprise Concepts Guide for more information about the types you can
specify. You can also add a default value for the Attribute, depending on your
requirements.

Click to remove attributes.

Creating an Organization Type

You can create an Organization type in a schema.

Procedure

1.
2.

In the Project Explorer, expand the Schema folder for your Organization Model.

In the Schema folder, right-click Organization Types and select Add Child >
Organization Type. A new Organization Type is created.

Click the General tab in the Properties view. In the Label box, type the name of the
Organization Type.

To add an Organization Unit as a member to the Organization Type:

a. In the Unit Members box, click . Type the name of the member in the Label
field.

b. To specify that the member should be of a particular Organization Unit Type,
click on the Type field and then click the button that then becomes
available.

c. The Select Type dialog box is displayed. Click on the Organization Unit Type
you require, and then click OK.

In the Multiplicity field, type in the multiplicity you want.
Click to remove Organization elements.

Click the Attributes tab. Click to add an attribute. Type in the name and select a
type for the Attribute from the Type drop-down list. See the "Attributes" topic in the
TIBCO® BPM Enterprise Concepts Guide for more information about the types you can
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set for attributes. You can also add a default value for the Attribute, depending on
your requirements.

Click to remove attributes.

Creating an Organization Unit Type

You can create an Organization Unit type in a schema.

Procedure
1. In the Project Explorer, expand the Schema folder for your Organization Model.

2. In the Schema folder, right-click Organization Unit Types and select Add Child >
Organization Unit Type. A new Organization Unit Type is created.

3. Click the General tab in the Properties view. In the Label box, type the name of the
Organization Unit Type.

4. To add another Organization Unit as a member to the Organization Unit Type:

a. In the Unit Members box, click . Type the name of the member in the Label
field.

b. To specify that the member should be of a particular Organization Unit Type,
click on the Type field and then click the L] button that then becomes
available.

c. The Select Type dialog box is displayed. Click on the Organization Unit Type
you require, and then click OK.

5. In the Multiplicity field, type in the multiplicity you want.
6. To add a Position as a member to the Organization Unit Type:
a. In the Position Members box, click . Type the name of the member in the
Label field.

b. To specify that the member should be of a particular Position Type, click on the
Type field and then click the button that then becomes available.

c. The Select Type dialog box is displayed. Click on the Position Type you require,
and then click OK.
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7.

In the Multiplicity field, type in the multiplicity you want.
Click to remove Position and Unit elements.

Click the Attributes tab. Click to add an attribute. Type in the name and select a
type for the Attribute from the Type drop-down list. See the "Attributes" topic in the
TIBCO® BPM Enterprise Concepts Guide for more information about the types you can
specify for Attributes. You can also add a default value for the Attribute, depending
on your requirements.

Click to remove attributes.

Creating a Position Type

You can create a Position type in a schema.

Procedure

1.

2.

In the Project Explorer, expand the Schema folder for your Organization Model.

Right-click Organization and select Add Child > Position Type. A new Position Type
is created.

Click the General tab in the Properties view. In the Label box, type the name of the
Position Type.

Click the Attributes tab. Click to add an attribute. Type in the name and select a
type for the Attribute from the Type drop-down list. For more information about the
types you can specify, see the "Attributes" topic in the TIBCO® BPM Enterprise
Concepts Guide. You can also add a default value for the Attribute, depending on your
requirements.

Click to remove attributes.

Creating an Organization Unit Relationship Type

You can create an Organization unit relationship type in a schema.:

Procedure

1.

In the Project Explorer, expand the Schema folder for your Organization Model.
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2. In the Schema folder, right-click Organization Unit Relationship Types and select
Add Child > Organization Unit Relationship Type. A new Organization Unit
Relationship Type is created.

3. Click the General tab in the Properties view. In the Label box, type the name of the
Organization Unit Relationship Type.

Click the Attributes tab. Click to add an attribute. Type in the name and select a
type for the Attribute from the Type drop-down list. For more information about the
types you can specify, see the "Attributes" topic in the TIBCO® BPM Enterprise
Concepts Guide. You can also add a default value for the Attribute, depending on your
requirements.

Click to remove attributes.

Creating a Resource Type

You can create a resource type in a schema.

Procedure
1. In the Project Explorer, expand the Schema folder for your Organization Model.

2. In the Schema folder, right-click Resource Types and select Add Child > Resource
Type. A new Resource Type is created.

3. Click the General tab in the Properties view. In the Label box, type the name of the
Resource Type.

Click the Attribute tab. Click to add an attribute. Type in the name and select a
type for the Attribute from the Type drop-down list. See the "Attributes" topic in the
TIBCO® BPM Enterprise Concepts Guide for more information about the types you can
specify. You can also add a default value for the Attribute, depending on your
requirements.

Click to remove attributes.

Organization Modeler Diagram Editors

Organization Modeler provides two graphical editors for producing organization diagrams:
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e An Organization Model Editor for the root Organization Model diagram

» An Organization Editor for the diagrams of each Organization included in the Model

The Organization Model Editor shows a high-level view of the organization or organizations

that you have created.

The following example shows an Organization Model diagram which includes two
organizations, one being your own organization and the second a representation of an
external organization with which your organization has dealings, in this case an

outsourcing company.

EasyAsOrganization Model

Author:  TIBCO Software Inc. i

Yersion:  1.0.0.qualifier
Public Company

Created: 16/12/10 11:27
Modified: 16/12/10 11:38
& I Easyas Organization

-

-

| di Internal Systems

Public Comparny
& T Outsourcing Inc,

|@ IT Contracting

-

The Organization Model Editor opens when you:

» Double-click on an Organization Model .om file in the Project Explorer,

 Right-click on an Organization Model .om file in the Project Explorer, and select Open
or Open With > Organization Model Diagram Editing,

* From the Organization Editor displaying any Organization in that Organization Model,
click on the shortcut arrow that is displayed on the badge.

Putlic Cormpany
% =, Easyas Organization

*

Ehow Organization diagramr
— |

The Organization Editor shows a more detailed view of one Organization, including the
Organization Units and Positions that it includes, and the relationships between them.
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. ﬁcusmmer Ser_ ﬁF‘deuct Dievelopm
EH ----- H

- g Call Center
8 Manager
8 Custormer Services Representative
g Horme g Life
& Home Manager 8 Life Manager
& Home Customer Services Representative 8 Life Customer Services Representative
&8 Travel g6 Mator
& Travel Manager & Motor Manager
& Travel Customer Services Representative 8 Motor Customer Services Representative

The Organization Editor opens:

e Automatically for the default Organization that is created when you create a new
Organization Model Diagram,

» When you double-click on the header part of the representation of an Organization in
the Organization Model Editor,

e When you double-click on an Organization in the Project Explorer,

e From the Organization Model Editor, when you click on the shortcut arrow that is
displayed on the representation of each Organization within the model.

EasyAsOrganization Model

athor:  TIBCO Software Inc. ]
Yersion:  1.0.0.qualifier I@
Created: 16/12/10 11:27
mMaodified: 16/12/10 11:38

Putific Cormparny
@ =, Easyas Organization

Ehow Crganization diagraml- -
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Adding Objects in Organization Modeler Diagrams

You can add objects to Organization Modeler diagrams in several ways.
» Using the tools on the diagram editor’s palette
e Using the pop-up icons
» Using the context menu

e Using the Project Explorer

To add Objects in Organization Modeler Diagrams using
the Palette

To add an object to an organization diagram, you can use the tools provided on the
diagram editor’s palette.

In the Organization Model Editor, the following tools are always available in the palette:

e Organization 2% Palette 3
m o=
= Modes 0
=5, Organization
* Association (= Links <0
.~ Bssociation

If you have applied a Schema to your organization model, and it contains any Organization
Types, tools for adding these are also available. For example, if you have used the standard
Schema but added a new Organization Type to it, both the Standard Organization Type
and the additional one is available in the palette, as in the following illustration.
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e Palette [
Rcicim
[== Modes £
% Organizakion
[=% Links 40
- Association
[ Twped DOrganizations £

5 Standard Organization Type

o, External OrganizationType

In the Organization Editor, the following tools are always available in the palette:

Organization Unit
Position
Hierarchy

Association

¢ Palstte I>
W OLoO mr
=~ Modes Ere)
@ Crganization Unit
& Position

[~ Links 40
I Hierarchy

- Bssociation

Additional tools are available if you have applied a Schema to your organization model. If
you have applied the Standard Organization Type to the Organization, the palette contains
the following tools for the elements that are defined in that Standard Organization Type:

Head Unit

Member Unit

Manager Position

Member Position

Lo Palette - [

NeE=E

[~ Modes - 40
éb Organization Unik
8 Position
[=% Links 4
[ Hierarchy
- Assoiation

[~ Home Organiz,.. <o
ffig Head Linit
fig Member Unit
%8 Manager Pasition

% Member Position
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o Note: Note that the Sub Unit element is not available from the palette.

Similarly, if the Organization that you are editing has a different or modified Type applied,
tools are included in the palette for the elements that are defined for that Type. The
following illustration shows an example. Here an Organization is used that has two
Organization Unit Types defined.

== Palette [>

[ &L~

[ Modes £0
@ Organization Lnit
&8 Position

[ Links £0
[ Hierarchy
- Association

[==Home 40
% Harme

[ Life 40
ffigLife

The availability of these tools on the palette is dynamic; if you add a new Type to the
Schema, it is immediately made available on the palette.

To use any of these tools, you can either:

e Select the required tool and drag-and-drop on to the diagram, or

» Click on the required tool in the palette to select it, and click on the diagram.
Where you should drop, or click, depends on the object you are adding:

» For Organization and Organization Unit (including Types of Organization Unit), use
the empty part of the diagram.

» For Position (including Types of Position), drop into or click on the position
compartment of an Organization Unit - that is, the empty space below the title bar.

» For Hierarchy or Association, drop into or click on the Organization Unit where the
connection is to start from, and drag the connection to the Organization Unit where
it is to end.
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When you add an Organization, Organization Unit, or Position object, the Label field on the
title bar is automatically selected. Enter a name for the object.

To add Objects in Organization Modeler Diagrams using
the Pop-up Icons

You can add objects to an organization diagram using the pop-up icons that are available.

If you hover your mouse over the empty area of the diagram, an icon appears. In the
Organization Model Editor, this is the Add Organization icon. Move your cursor on to the
icon to display the Add Organization label as shown in the following illustration, and then
click to create a new Organization in the diagram.

i

fdd Organization

In the Organization Editor, hovering your mouse in the empty area produces the Add
Organization Unit icon, which works in the same way as the Add Organization icon.
Similarly, hovering your mouse over the Position compartment of an Organization Unit
displays the Add Position icon, as shown in the following illustration.

&

g Product Development

g PnsitiDnCDmpartment|
)

You can add a connection between two objects in a diagram by clicking and dragging one
of the handles that are displayed when you hover your cursor over the object. Click the
handle and drag to the object to which you want to connect, as shown in the following
illustration.
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o Note: This process creates a Hierarchy. If you want a non-hierarchical
connection, you can change it to an Association as described in Hierarchy and
Association Properties.

g Customer Services  «o & Product Marketing
—0

pouble-dick to show related elements, click and drag ko create a connection.]

To add Objects in Organization Modeler Diagrams using
the Context Menu

You can add objects to the organization diagram by right-clicking in the Organization
Editor and selecting the object you require from the context menu that is displayed.

If you right-click on the background of the Organization Editor, you can select:
* An Organization Unit with no Type defined;

* If the Organization has the Standard Organization Type set, a Head Unit, Member
Unit, or Sub Unit;

Add ¥
éh Crganization Unik
B Head Unit
% Member nit
File 3
Edit 4
Delete From Model
'SE. Select L4
o2 arrange al
Filters r
Wig L4
i+] Foom ]
| Show Propetties Yiew
Properties
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 If the Organization is set to another Type of Organization defined in the Schema, an
Organization Unit of any of the Types defined for that Organization Type.

If you right-click on an Organization Unit in the diagram, you can select:
* A Position with no Type defined;

If the Organization Unit has an Organization Unit Type set, a Position of any of the Types
defined for that Unit Type.

Member Uit |
8 Product Marketing
[~ |
i1 ) Add Mote

- & Position
B sub Unit
‘B Manager Position
% Member Position

Adding Objects in Organization Modeler Diagrams using
the Project Explorer

You can add objects to the diagram editor from the Project Explorer.

1. Select the parent in the Project Explorer.

2. Right-click the parent and select Add Child.

For example, to add an untyped Organization Unit you would right-click on the parent
Organization and select Add Child > Organization Unit. If you are using Schema, the
choices displayed include not just the basic Organization Unit but the Types of
Organization Unit available.

Adding Notes and Labels

You can add notes or text labels to the organization diagram.

Procedure
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1. Do one of the following:

e Right-click on an object in the editor and select Add Note from the pop-up
context menu,

e Right-click on the background in the editor and select Add - > Note or Add - >
Text from the pop-up context menu,

e In the Organization Editor palette, select the Note tool in the upper part of the

palette.
e Palette [
NEEI=E
= Elements L@ 4
JNDI:E - Create a I"-Ju:ute|
Packag =

» Click on the Organization Editor.

Result

Note: You can also select Text or Note Attachment from this menu.
The icon for the tool changes to show the item you have selected.

-2 Palette

[:= Element

Pack:

= class

[ @G+

v | Mote

|=| Texk

i Mote Attachment

The following illustration shows a note being used to add explanation to an Association. A
note attachment is drawn between the note and the object with which it is associated.

Pre-sales support

|@Cusb:umer Services |
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Tailoring the Appearance of Organization Modeler
Diagrams

You can change the level of detail that the Organization Modeler diagrams display.

In the overview diagram, each Organization is by default shown including all the
Organization Units that make it up, and the Hierarchies and Associations that link them. To
hide the detail, click on the downward-pointing arrowhead that is shown in the corner
when you select the Organization.

This action hides the contents of the Organization, and displays the collapsed version
shown below.

4] == Easyhs
b Units ...

A solid right-pointing arrowhead is now displayed in place of the downward-pointing one
when the Organization is selected. Clicking on this restores the display of the
Organization’s contents.

In the Organization Editor, the same arrowheads appear in Organization Units, and you can
use them to hide or to display the Positions defined within those Organization Units.

Also, in the Organization Editor, you can choose to display or to hide the hierarchy of
Organization Units that depend on the selected unit. The following illustration shows an
excerpt from an organization diagram, with several Organization Units dependent on the
Call Center unit.

TIBCO Business Studio™ - BPM Edition Modeling Guide



213 | Organization Model

- dgcall center
g Hame diLife
8 Manager 8 Manager
8 Custormer Service Representative 8 Custorner Service Representative
g Travel g Motor
8 Manager 8 Manager
8 Custormer Service Representative 8 Customer Service Representative

If you click on the small minus sign in the title bar of the Call Center, the display changes
to the following collapsed view.

+ ggcall Center

Click on the plus sign to restore the hierarchical view.

You can also:

 use the options in the Diagram menu to arrange the objects on the diagram editor
screen,

e right-click on the background of the diagram and select Arrange All to make the
diagram more ordered.

Creating an Organization Model

The Organization Model is contained in a file called name.om, where name is typically the
name of the entity for which you are creating the Organization Model. An Organization
Model can contain more than one Organization.

Procedure
1. In the Project Explorer, select the Organization folder in the project where you
want to create your Organization Model.

2. Right-click the Organization folder or the OrganizationModel.om folder and select
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New > Organization Model.

3. The Create Organization Model Diagram wizard is displayed.
Make sure that the Create default schema types box is checked.

The folder you selected should be displayed in the Create Organization Model
Diagram wizard. You can use the folder you selected or select a different folder,
depending on your requirements. However, it must be a special folder of the
Organization type.

4. In the File name: field, type the name you want to apply to your Organization Model,
followed by the suffix .om. Click Finish.

Result

The Organization Editor is displayed, representing the single default Organization created
in the Organization Model. This information is displayed in the badge in the top left-hand
corner of the editor. You can navigate to the parent Organization Model editor by clicking
on the shortcut arrow in the badge.

%EasyAsOrganizationModel.om#Organization &3 el ]
B ;I o Palette b
i = Organization N

Model: EasyAsOrganizationiadel 51 LRAL -

Type: - none set- (= Modes =
- & Organization Unik
& Position

(= Links 40
[ Higrarchy |

- Association

The Organization Model is also displayed in the Project Explorer view.

ElCS Cirganization
Elﬁ Easyhs OrganizationModel, am
El Easyhs OrganizationiMadel (EasyAsOrganizationMadel)
& Zapabilities
@ Garaups
E Locations
{% COrganizations
% Privileges
B Queties
=] Resources
Schema
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o Note: You can use quick-find (Ctrl+F) in the project explorer to find existing
organization model entities and select them in the project explorer.

When you have created an organization model, you can search for organization
model diagram elements using quick find (Ctrl-F) within the diagram, and
entering the initial characters of the name you are searching for. Double-click on
the element you are shown in the search to go to its location in the diagram.

Creating an Organization

You can create an Organization within your Organization Model.

Before you begin
See the "Organizations" topic in the TIBCO® BPM Enterprise Concepts Guide.

See Creating an Organization Model

o Note:

If you want to create an organization that is likely to be replicated elsewhere -
for example a Branch which consists of a similar structure in a number of
geographical locations - then you might want to consider creating a Dynamic
Organization. See the "Dynamic Organizations" topic in the TIBCO® BPM
Enterprise Concepts Guide.

Procedure
1. Activate the Organization Model Editor for your Organization Model.

2. Select the Organization tool in the Organization Model Editor palette, and click on
the empty part of the Organization Model editor. This places an Organization in the
Model.

Note: You can alternatively expand the Organization Model in the Project
Explorer. Right-click Organizations and select Add Child > Organization.
A new Organization is created.
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o Note: If you want to use a template of a typical public company as a
starting point for your own organization, right-click Organizations and
select Add Child > Public Company. This provides you with a number of
sample department types which you can edit and add to your company
(Department, Business Unit, Team) and Positions already defined for
Manager and Member which you can also edit.

3. At this point the Label field of the Organization is automatically selected. Enter the
label you require. The Name field is automatically filled with the same text as the
Label, but without any internal spaces. For example, if you put Head Office in the
Label field, the Name is HeadOffice.

4. If the Properties View is not already displayed, right-click the organization you just
created and select Show Properties View. The Properties View is displayed.

Note: For a complete description of all the properties you can configure
for an Organization, see Organization Properties.

5. In the Purpose field on the General tab, and on the Description tab, you can enter
some text to describe the purpose of the Organization and/or any supporting
explanations, depending on your requirements.

Next to the Type field, click [ to display the Select Type dialog box. You can change
the type for the Organization, depending on your requirements.

Next to the Location field, click L] to display the Select Type dialog box. You can
specify a Location for the Organization, depending on your requirements.

6. If you have assigned a Type to the Organization, the Attribute Values tab is
displayed. Any attributes that are defined for this type of Organization are displayed
here. Click the Value field next to each defined attribute to display a list of available
values for that attribute.

Note: The Attribute Values tab is available only if you have previously
applied a Type.

What to do next
When you have created an organization, you can model it to contain a structure using
Organization Units and Dynamic Organization Units which can be connected using
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Hierarchy links.

o Note: Association links are not supported in the runtime model. If you create an
association a warning is displayed.

Creating a Dynamic Organization

You can create a Dynamic Organization within your Organization Model. A Dynamic
Organization is an organizational pattern that can be referenced from a number of different
Organizations.

See "Dynamic Organizations" topic in the TIBCO® BPM Enterprise Concepts Guide

Procedure
1. Activate the Organization Model Editor for your Organization Model.

2. Select the Dynamic Organization tool in the Organization Model Editor palette, and
click on the empty part of the Organization Model editor. This places a Dynamic
Organization in the Model.

Note: You can alternatively expand the Organization Model in the Project
Explorer. Right-click Organizations and select Add Child > Dynamic
Organization. A new Dynamic Organization is created.

3. At this point the Label field of the Dynamic Organization is automatically selected.
Enter the label you require. The Name field is automatically filled with the same text
as the Label, but without any internal spaces. For example, if you put Head Office in
the Label field, the Name is HeadOffice.

4. In the Purpose field on the General tab, and on the Description tab, you can enter
some text to describe the purpose of the Organization and/or any supporting
explanations, depending on your requirements.

5. If you have assigned a Type to the Organization, the Attribute Values tab is
displayed. Any attributes that are defined for this type of Organization are displayed
here. Click the Value field next to each defined attribute to display a list of available
values for that attribute.
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Note: The Attribute Values tab is available only if you have previously
applied a Type.

What to do next

Once you have created a Dynamic Organization, you can open it and model it by adding
organization units and positions. See Creating a Dynamic Organization Unit.

The Properties section of the Dynamic Organization is the same as that of an Organization
but has an additional tab for the Dynamic Organization Identifiers. Dynamic Organization
Identifiers are arbitrary strings that you can define. They have values assigned at runtime
to identify an instance of the Dynamic Organization. The Dynamic Organization participant
in a process that references an organization entity within this Dynamic Organization
requires a mapping between process data (which provides the values for the identifiers at
runtime) and these identifiers. See Dynamic Organization Identifier Mapping.

Creating an Organization Unit

You can create an Organization Unit within your Organization.

Procedure
1. In the Organization Model editor, double-click on the organization in which you want
to place an Organization Unit. The Organization Editor for that organization is
opened.

2. Select the Organization Unit tool in the Organization Modeler palette, and click on
the empty part of the Organization diagram. This places an Organization Unit in the
Organization.

3. At this point the Label field of the Organization Unit is automatically selected. Enter
the label you require. The Name field is automatically filled with the same text as the
Label, but without any internal spaces.

4. If the Properties View is not already displayed, right-click the organization Unit you
just created and select Show Properties View. The Properties View is displayed.
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5.

Note: For a complete description of all the properties you can configure
for an Organization Unit, see Organization Unit Properties.

In the Purpose field on the General tab, and on the Description tab, you can enter
some text to describe the purpose of the Organization Unit and/or any supporting
explanations, depending on your requirements.

If you are using the default schema, or if you have created your own schema and
defined any Organization Unit Types, you can assign a Type to this Organization Unit
by selecting it in the Element field.

Next to the Location field, click L] to display the Select Type dialog box. You can
specify a Location Type for the Organization.

To specify start and end dates for the Organization Unit, click =] next to the date
fields to display the calendars.

If you have applied a Type to the Organization Unit, the Attribute Values tab is
displayed. Any attributes that are defined for this type of Organization Unit are
displayed here. Click the Value field next to each defined attribute to display a list of
available values for that attribute.

See the "Attributes" topic in the TIBCO® BPM Enterprise Concepts Guide for more
information about attributes.

Click the Privileges tab. Click to display the Select Type dialog box. You can
specify the Privileges for the position. See the "Capabilities and Privileges" topic in
the TIBCO® BPM Enterprise Concepts Guide for more information about Privileges.

Creating a Dynamic Organization Unit

You can create a Dynamic Organization Unit within your Organization. This can be used to
reference a Dynamic Organization. This in turn allows you to model a repeating
organizational pattern such as a Branch in an organization.

Before you begin
See Creating an Organization.

See Creating a Dynamic Organization.
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Procedure
1. In the Organization Model editor, double-click on the organization in which you want
to place a Dynamic Organization Unit. The Organization Editor for that organization is
opened.

2. Select the Dynamic Organization Unit tool in the Organization Modeler palette, and
click on the empty part of the Organization diagram. This places a Dynamic
Organization Unit in the Organization.

3. At this point the Label field of the Dynamic Organization Unit is automatically
selected. The Name field is automatically filled with the same text as the Label, but
without any internal spaces. The Label and Name are derived from the root
organization unit of the referenced Dynamic Organization. This is not editable.

4. If the Properties View is not already displayed, right-click the Dynamic Organization
Unit you just created and select Show Properties View. The Properties View is
displayed.

What to do next

Dynamic Organization Identifiers are arbitrary strings that are defined on a Dynamic
Organization by the user. These strings have values assigned at runtime to identify an
instance of the Dynamic Organization. The Dynamic Organization participant in a process
that references an organization entity within this Dynamic Organization has a mapping
between process data (which provides the values for the identifiers at runtime) and these
identifiers.

Dynamic Organization Identifier Mapping

When a Dynamic Organization Participant is assigned to a task you need to identify the
correct instance of the Dynamic Organization to use to resolve this participant at runtime.
This is done using Dynamic Organization Identifiers which are mapped to process data.

o Note: The mappings are between the process data and the Dynamic
Organization Identifiers of the referenced Dynamic Organization (not the
Dynamic Organization).

Procedure
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1. In the business process, select the Work Resource tab, and expand Dynamic
Organization Identifier Mappings....

~ Dynamic Organization [dentifier Mappings...
Map Process Data to the Identifiers for referenced Dynamic Organizations
type filter text [] Show Only Mapped Content type filter text

& Parameter (Parameter) gy Dynamic Organizationl (DynamicOrganizationl)
& Parameter2 (Parameter?)

@ Field (Field)

@ Field2 (Field2)

2. Map your process data (data fields and parameters) to a Dynamic Organization
Identifier (which you set up when you created the Dynamic Organization Model). See
the "Dynamic Organizations" topic in the TIBCO® BPM Enterprise Concepts Guide and
"Creating a Dynamic Organization" in the TIBCO Business Studio™ - BPM Edition
Modeling Guide.

What to do next

A Dynamic Organization declares its Identifier Fields. These are arbitrary fields that are
used to uniquely identify a generated instance of the Dynamic Organization at runtime.

When a Dynamic Organization is assigned to an Extension Point, those Identifier Fields
must be mapped/assigned to named LDAP Attributes. This is done after deployment.

A generated instance of a Dynamic Organization takes its Identifier values from those
named Attributes; of the LDAP Entry from which it originates.

A Dynamic Organization Participant carries values for the Dynamic Organization Identifiers.
These values are derived from process data (data fields and parameters) mapped to those
Dynamic Organization Identifiers. With this information the User Task can identify the
instance of the Dynamic Organization in which the Participant can be found.

Creating a Position

You can create a Position within your Organization Unit.

Procedure

1. Select the Position tool in the Organization Modeler palette, and click on the
Organization Unit where you want to create the Position.

2. At this point the Label field of the Position is automatically selected. Enter the label
you require. The Name field is automatically filled with the same text as the Label,
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but without any internal spaces.

3. If the Properties View is not already displayed, right-click the Position you just
created and select Show Properties View. The Properties View is displayed.

Note: For a complete description of all the properties you can configure
for a Position, see Position Properties.

4. In the Purpose field on the General tab, and on the Description tab, you can enter
some text to describe the purpose of the Organization and/or any supporting
explanations, depending on your requirements.

5. If you are using the default schema, or if you have created your own schema and
defined any Position Types, you can assign a Type to this Position by selecting it in
the Element field.

Next to the Location field, click [ to display the Select Type dialog box. You can
specify a Location for the Position.

To specify start and end dates for the Organization, click next to the date fields to
display the calendars.

6. If you have applied a Type to the Position, the Attribute Values tab is displayed. Any
attributes that are defined for this type of Position are displayed here. Click the Value
field next to each defined attribute to display a list of available values for that
attribute.

See the "Attributes" topic in the TIBCO® BPM Enterprise Concepts Guide for more
information about attributes.

Click the Capabilities tab. Click [ to display the Select Type dialog box. You can
specify the Capabilities for the Position. See the "Capability and Privilege" topic in
the TIBCO® BPM Enterprise Concepts Guide for more information about capabilities.

7. Do the same for the Privileges tab.

Creating a Group

You can create a group within your Organization Model.

Procedure
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1. In the Project Explorer, expand the folder for your Organization Model.

2. Right-click the Groups folder and select Add Child > Group. Right-click the Group
and select Rename. Type the label of the Group you wish to create. The Name field
is automatically filled with the same text as the Label, but without any internal
spaces.

o Note: To add a sub-group, right-click on the group where you want to
create your sub-group and select Add Child > Group.

3. If the Properties View is not already displayed, right-click the Group you just created
and select Show Properties View. The Properties View is displayed.

Note: For a complete description of all the properties you can configure
for a Group, see Group Properties.

4. In the Purpose field on the General tab, and on the Description tab, you can enter
some text to describe the purpose of the Organization and/or any supporting
explanations, depending on your requirements.

Click the Capabilities tab. Click [ to display the Select Type dialog box. You can
specify the Capabilities for the position. See the "Capability and Privilege" topic in
the TIBCO® BPM Enterprise Concepts Guide for more information about capabilities.

5. Do the same for the Privileges tab.

Creating Capabilities

You can add Capabilities to your Organization Model.

Procedure
1. In the Project Explorer, expand the folder for your Organization Model.

2. You can either:

» Right-click the Capabilities folder and select Add Child > Capability. A new
Capability is created.

e Right-click on a Category and select Add Child > New Capability. A new
Capability is created.
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3.
4.

8.

Right-click on the Capability you just created and select Rename.

Type the label of the Capability you wish to create. The Name field is automatically
filled with the same text as the Label, but without any internal spaces.

If the Properties View is not already displayed, right-click the Capability you just
created and select Show Properties View. The Properties View is displayed.

Note: For a complete description of all the properties you can configure
for a Capability, see Capability Properties.

Click the General tab.

You can specify a type for your capability by doing the following:
a. Select the Has qualifier check box. The Show qualifier ... option is displayed.
b. Click the Show qualifier ... option. The Qualifier tab is displayed.

c. Click the Qualifier tab. In the Type field, select an available type from the
drop-down list.

d. If required, specify a default value for the qualifier.

For more information on the types you can specify, see the "Capabilities and
Privileges" topic in the TIBCO® BPM Enterprise Concepts Guide.

In the Purpose field on the General tab, and on the Description tab, you can enter
some text to describe the purpose of the Privilege and/or any supporting
explanations, depending on your requirements.

Creating Capability Categories

You can add Capability Categories to your Capabilities in your Organization Model.

Procedure

1.
2.

In the Project Explorer, expand the folder for your Organization Model.

Right-click the Capabilities folder and select Add Child > Capability Category. A
new Category is created.

Right-click on the Category you just created and select Rename.

Type the label of the Category you wish to create. The Name field is automatically
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filled with the same text as the Label, but without any internal spaces.

Note: For a complete description of all the properties you can configure
for a Category, see Capability Category and Privilege Category Properties.

Creating Privileges

You can add Privileges to your Organization Model.

Procedure

1.
2.

In the Project Explorer, expand the folder for your Organization Model.

You can either:

e Right-click the Privileges folder and select Add Child > New Privilege. A new
Privilege is created.

» Right-click on a Category and select Add Child > New Privilege. A new
Privilege is created.

Right-click on the Privilege you just created and select Rename.

Type the label of the Privilege you wish to create. The Name field is automatically
filled with the same text as the Label, but without any internal spaces.

If the Properties View is not already displayed, right-click the Privilege you just
created and select Show Properties View. The Properties View is displayed.

Note: For a complete description of all the properties you can configure
for a Privilege, see Privilege Properties.

Click the General tab.

You can specify a type for your privilege by doing the following:
a. Select the Has qualifier check box. The Show qualifier ... option is displayed.
b. Click the Show qualifier ... option. The Qualifier tab is displayed.

c. Click the Qualifier tab. In the Type field, select an available type from the
drop-down list.
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d. If required, specify a default value for the qualifier. For more information on the
types you can specify, see the "Capability and Privilege" topic in the TIBCO®
BPM Enterprise Concepts Guide.

o Note: Organization model deployments to the same major version
are always additive.

This means that changes in the qualifier value of privileges reflect
every previous value you set. So, if you set the qualifier for Position
‘Tester’ with Privilege ’All’ to 10 and deploy the organization model,
and then change the qualifier to 11 and redeploy it (as a different
minor version), Position 'Tester' now has two assignments of
privilege 'All'; one with a qualifier of 10, and with a qualifier of 11.

8. In the Purpose field on the General tab, and on the Description tab, you can enter
some text to describe the purpose of the Privilege and/or any supporting
explanations, depending on your requirements.

Creating Privilege Categories

You can add Privilege Categories to your Privileges in your Organization Model.

Procedure
1. In the Project Explorer, expand the folder for your Organization Model.

2. Right-click the Privileges folder and select Add Child > Privilege Category. A new
Category is created.

3. Right-click on the Category you just created and select Rename.

4. Type the label of the Category you wish to create. The Name field is automatically
filled with the same text as the Label, but without any internal spaces.

Note: For a complete description of all the properties you can configure
for a Category, see Capability Category and Privilege Category Properties.
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Creating a Location

You can create a Location for an Organization Model.

Procedure

1.
2.
3.

In the Project Explorer, expand the folder for your Organization Model.
Right-click the Locations folder and select Add Child > Location.
Right-click the Location and select Rename.

Type the label of the Location you wish to create. The Name field is automatically
filled with the same text as the Label, but without any internal spaces.

If the Properties View is not already displayed, right-click the Location you just
created and select Show Properties View. The Properties View is displayed.

Note: For a complete description of all the properties you can configure
for a Location, see Location Properties.

In the Purpose field on the General tab, and on the Description tab, you can enter
some text to describe the purpose of the Location and/or any supporting
explanations, depending on your requirements.

Next to the Type field, click to display the Select Type dialog box. You can change
the type for the Location, depending on your requirements.

To specify start and end dates for the Location, click LJ next to the date fields to
display the calendars.

If you have assigned a Type to the Location, the Attribute Values tab is displayed.
Any attributes that are defined for the Type are displayed here. Click the Value field
next to each defined attribute to display a list of available values for that attribute.

See "Attributes" topic in the TIBCO® BPM Enterprise Concepts Guide for more
information about attributes.

Creating a Resource

You can create a Resource for your Organization Model.
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Procedure
1. In the Project Explorer, expand the folder for your Organization Model.

2. Right-click the Resources folder and select Add Child > Resource. A new Resource
is created.

3. Right-click the Resource and select Rename.

4. Type the label of the Resource you wish to create. The Name field is automatically
filled with the same text as the Label, but without any internal spaces.

5. If the Properties View is not already displayed, right-click the Resource you just
created and select Show Properties View. The Properties View is displayed.

Note: For a complete description of all the properties you can configure
for a Resource, see Resource Properties.

6. In the Purpose field on the General tab, and on the Description tab, you can enter
some text to describe the purpose of the Resource and/or any supporting
explanations, depending on your requirements.

Next to the Type field, click to display the Select Type dialog box. You can change
the type for the Resource, depending on your requirements.

7. If you have assigned a Type to the Resource, the Attribute Values tab is displayed.
Any attributes that are defined for the Type are displayed here. Click the Value field
next to each defined attribute to display a list of available values for that attribute.

See the "Attributes" topic in the TIBCO® BPM Enterprise Concepts Guide for more
information about attributes.

Creating Queries

You can create a Query for an Organization Model.

Procedure
1. In the Project Explorer, expand the folder for your Organization Model.

2. Right-click the Queries folder and select Add Child > Organization Query. A new
Organization Query is created.
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3. Right-click the Query and select Rename.

4. Type the label of the Query you wish to create. The Name field is automatically filled
with the same text as the Label, but without any internal spaces.

5. On the General tab of the Properties View, select either Free Text or RQL from the
drop-down list in the Script Defined As field. An input field is displayed.

Advanced

T Properties &3

R
=] General
————— Mam

[S_\ Problems] 08 Fragments] E Daka Source Explorerw

? Organization Query

Label:

Organizationigueryl
Organizationigueryl

Script Defined fs: |RGL Ll

Describe Organization Model Query

orgqunit (name="LifeClaims") .position (hame="CustowerServiceRepresentativelLife”)

6. Type the Query into the Describe Organization Model Query field. You can either
enter free text that describes to the solution designer what you intend the query to
accomplish, or use the structure of RQL to enter a query that can be validated by
TIBCO Business Studio.

Using a Schema in an Organization Model

This is an overview of the steps required to create the example shown as a Schema and
then use it in an Organization Model.

An example of an organization unit that you might want to model as a Schema is shown

below.
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Procedure
1. Create a project. On the Organization Model dialog box of the New Project wizard,
deselect the Create default schema types field.

The Schema for this project therefore contains only those types that you define.
2. Create the following types in the Organization Schema:
e An Organization Type called Call Center. See Creating an Organization Type.

e Organization Unit Types called Home, Life, Travel and Motor. See Creating an
Organization Unit Type.

e A Position Type called Manager. See Creating a Position Type.

e A Position Type called Customer Services Representative. See Creating a
Position Type.

3. For the Call Center Organization Type, specify the Home, Life, Motor and Travel
Organization Unit Types as Organization elements.

[;_g Problems (DS Fragments (w Data Source Explorer (ﬁ Properties &3 s

%=, Organization Type

SRR |
Label: | Call Cenker
|~ | General
ame | Callcenter

Attributes

Advanced Lahel | Type |
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ﬁMotor

ﬁTravel

HaLire

c

Pl | % |4

00 e o=

Unit Elements:

4. For the Home, Life, Travel and Motor Organization Units, specify the Manager and
Customer Service > Representatives as Position Elements.
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5. Create an Organization Model. Ensure that you deselect the Create default schema
check box.

6. Create an Organization within that Organization Model.

7. On the General tab in Properties view, change the Type of the Organization you have
just created from a Standard Organization Type to the Call Center Type.

8. In the Organization diagram editor, right-click on the empty canvas. On the context
menu that pops up, you can select Home, Life, Motor and Travel Organization Units,
as shown below. You can also select an untyped Organization Unit.

= UniComm Call Center

Model: UniComm B Add G

Type: Call Center dig Organization Urit
Pag Life 4
@ Mokor s
@ Travel s
P48 Home r

9. Create either a Home, Life, Travel or Motor Organization Unit.

10. If you right click on the Organization Unit you created, the Manager and Customer
Service Representative Positions are displayed, as shown below.
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Global Signal Definitions

Global Signal projects define the signals that you can send and receive across multiple
processes and the data payload that they carry. You define a Global Signal Definition
project to define global signals, which can be referenced from multiple projects.

You can define more than one Global Signal Definition project if desired.

Procedure
1. Go to File > New > Global Signal Definition Project. Enter the project name and
select the BPM destination environment. Click Next.

2. Accept the default settings (including the selection of Create initial Global Signal
Definition and click Finish.

The Global Signal Definition project is created, with an initial Global Signal. You can
then define the payload data to be associated with the global signal. See Creating
Payload Data for Global Signals.

On the Properties tab for the Global Signal, define the correlation timeout setting.
The default setting is Correlate Immediately. You can change this to Timeout
Signal After: n seconds.

o Note: It is possible to deploy a process with global signal events without
deploying the Global Signal Definition project. However, if you do this,
then the process halts with an error at runtime. You should deploy the
Global Signal Definition Project before you deploy processes which contain
global signal events.

Creating Payload Data for Global Signals

You can define either normal or correlation payload data for global signals.
Normal payload data is simply process data that is passed from the throw signal event to

the catch signal event.
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Correlation payload data is used to match waiting catch signal event process instances to
specified process instances.

For example, a catch global signal might have a correlation payload parameter of 'Invoice
Number'. When the catch is initiated, the current value of 'Invoice Number' for that process
instance becomes the 'key' on which the signals are matched. The throw global signal
maps a value to the 'Invoice Number' correlation payload parameter, and the system finds
the corresponding process instance for the catch global signal that was initiated with that
same value.

After defining the payload data in your global signal definition project using the procedure
below, the global signal throw and catch events in your process map to this payload data.
On the throw signal event, use Map To Signal to map process data to the defined payload
data. On the catch signal event, use Map From Signal to map from the defined payload
data to process data. For more information, see Throw and Catch Signal Events.

o Note: Correlation data payload changes are not permitted on global signal
definition project upgrade. Therefore, signal correlation parameters cannot be
changed unless the major version is changed. You must take care to ensure that
only valid changes are made. If you upgrade a global signal definition project,
any changes you have made to a BOM class referenced by a payload data
parameter are not validated against.

Procedure

1. On the Global Signals panel, select the global signal you want to add payload data
for.

2. On the Payload Data panel, select PayloadData.

3. On the Properties pane General tab, use the Use for Signal Correlation selection to
specify whether you are defining normal or correlation payload data, as follows:

o Select Use for Signal Correlation to define correlation payload data.

» Deselect Use for Signal Correlation to define normal payload data.

4. If you are defining normal payload data, specify whether the payload data is
mandatory or optional by selecting or deselecting the Mandatory check box. (The
Mandatory check box is not visible if you are defining correlation payload data, as it
is always mandatory.)

5. In the Type section, specify the appropriate type information for the payload data,
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depending on the process data it is mapped to.
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Work List Facades

The Work List Facade allows you to optionally declare the design-time definition of a set of
display labels for the predefined work item attribute set. The display label set is contained

in the Work List Facade.
See the "Work Item Attributes" topic in the TIBCO® BPM Enterprise Concepts Guide.

Procedure
1. Go to File > New > Work List Facade Project.

2. Enter the project name.

3. Click Finish.

o Note: If you have deleted the Work List Facade file for any reason, you can
add a new Work List Facade file. From the Work List Facade Special Folder
select New > Work List Facade. However, multiple Work List Facade files
are not allowed.

What to do next
Now go to the work list facade editor to define the display names of your work list
attributes. See Setting the Display Label for Work Item Attributes.

Setting the Display Label for Work Item
Attributes

The work list facade editor is a table editor that allows you to optionally set the display
label for any of the predefined set of 40 work item attributes.

Display labels are used throughout the organization.

Procedure
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1. When you create a Work List Facade project, the Work Item Attributes table opens.
If it is not already open, select WorkListFacade.wlf from your Work List Facade
project.

2. Add values to the Display Label column.

Work Item Attributes
Physical Work Itern Attribute Name Type (Length) Display Label
(L) attributel Integer (10) Phone number
i@ attribute? Text (64) Mame
@ attributed Text (04) Address linel
@ attributed Text (64) Address line 2
8 attributes Decimal (10,2)
L attributed DateTime
(5 attribute? DateTime
(@ attributed Text (20)
@ attributed Text (20)
(AL attributel N Texwt (2

You can add as many or as few display values as you want. When you use the Work
List Facade Editor as described in the "Work Item Attributes" topic in the TIBCO® BPM
Enterprise Concepts Guide, to add values, the attributes with display values appear at
the top of the list of attributes wherever they appear in the user interface.

The attribute name and type column are read-only. Only the Display Label can be
edited. The Display Labels have length restriction of 64 characters.

What to do next
When you have completed your display labels, deploy the Work List Facade project.

If you need to change your display labels at any time, edit them as described and redeploy
the Work List Facade project.

Mapping Process Data to Work Item Attributes

You can map process data to work item attributes to allow automatic work item attribute
assignment on all user tasks which implicitly or explicitly reference the mapped process
data. This can be done to avoid the use of scripts to achieve the same result.

Procedure
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1. On the Work Resource tab of the Business Process, expand Work Item Attribute

Mappings.

The left column shows all data fields defined for the process. The right column lists
the 40 work item attributes available, with those with defined display labels at the
top of the list. When there is no Work List Facade file in the Workspace scope, the
Work Item Attributes are sorted by the numeric values in their name. See Setting the
Display Label for Work Item Attributes

. Map a data field to an attribute.

For example, Field could be mapped to the Name attribute. Do this for all data fields
you would like to map to attributes.

= Work Item Attribute Mappings

Map process data to work item attributes (for automatic werk item attribute assignment on all user tasks)

type filter text [7] Show Only Mapped Content type filter text
@ Field (Field) L ® @ Address linel (attribute3) : Text -
@ Field2 (Field2) ® B @ Address line 2 (attributed) : Tet ||

L] @ Mame (attribute?) : Text

Each user task in the process, with the mapped process data associated, contains
the script equivalent to the mappings defined here.

Note: If you use the Work Manager script from the Scripts tab for a user
task, you can only use the physical attribute names (attribute 1, attribute
2, and so on) which appear in content assist and not the display names.
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Troubleshooting

This section describes some issues encountered when working with TIBCO Business Studio
and their possible solutions.

o Note: In previous versions of TIBCO Business Studio, TIBCO recommended
disabling in-memory validation by deselecting Project > Build Automatically as
a way of achieving performance gains. Because of performance enhancements
with this version of TIBCO Business Studio, this is no longer necessary and is not
desirable as it causes problems resolving references.

Default Channels are Unavailable

The default presentation channels are unavailable if the default channel is not enabled.

Procedure
1. Select the project in the Project Explorer, and click File > Properties.

2. In the navigation pane on the left side of the Properties dialog box, click
Presentation Channels.

3. Ensure that the Enable project specific settings check box is checked.

Importing Projects
For more information about importing projects, see the following topics:

e Previous Version 5.x Projects not Imported Correctly

» Importing Projects into your Workspace which were Created in a Previous Version of
TIBCO Business Studio

e Importing Projects from Subversion
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Previous Version 5.x Projects not Imported Correctly

The following validation error is displayed if the project is imported without using the
correct import wizard or checked out from a source control system:

Older BPM related projects must be imported using Import Studio Projects or MAA
Projects (delete and re-import the project)

You must perform a one-time migration by importing the project using Importing Existing
Studio Projects into Workspace or Importing Existing Modelled Application Archive (MAA)
Files into Workspace .

Importing Projects into your Workspace which were
Created in a Previous Version of TIBCO Business
Studio

When you import projects into your workspace which were created in a previous version of
TIBCO Business Studio, they might show a problem marker by the project name in Project

Explorer. This occurs when a newer version of TIBCO Business Studio has different project

configuration and/or file format requirements. The normal validation and build of projects

are disabled until this problem is fixed.

Select the project, and click Ctrl + 1. You can then select one quick fix to automatically
migrate the entire project (including all the BOM & XPDL files) to the current version, and
clean (Project > Clean) and build it (Project > Build Project).

3 Project "ChainingSolution’ is of an older version and needs ko be migrated

1 quick fizx available For this problem. ..
= Migrake the Project

If you attempt to open an individual package within the project before you migrate the
project, an error message similar to the following message is displayed:

x

y This model cannot be lnaded as the project needs to be migrated to the latest
\V version, Would wou like to migrate project now?

TIBCO Business Studio™ - BPM Edition Modeling Guide



241 | Troubleshooting

You can also see a migration validation error in the Problems view for an old XPDL.

Select Yes and the quick fix is applied to migrate the whole project.

Checkout Projects from Subversion

When you import projects from Subversion, they might generate a number of validation
errors.

This is an expected behavior. When you apply the "missing special folder" resolution, it can
produce a full project build, which means that the missing generated BOMs are generated
and all problems are resolved.

When you commit the project to Subversion, any folder or file that is marked as "derived"
is not committed. As a result, these resolved special folders are not committed and the
error might reoccur.

It is a good practice to run a clean build on projects checked out of Subversion.

Disabling Flow Validation to prevent lockups in
the User Interface

TIBCO Business Studio - BPM Edition complex processes (with flows that are ultimately
invalid for TIBCO Business Studio - BPM Edition deployment) can cause the flow-analyzer
to take a very long time to analyze, which might lock the user interface. Follow the
workarounds described in this topic to prevent this issue.

Note: This issue can occur after converting iProcess XPDL to TIBCO Business
Studio - BPM Edition XPDL.

» Alternatively, switch off migration point decoration for a given process or the whole
process-package (to prevent lock ups in the user interface). From the process, select
Resource > BPM User Interface Configuration > Migration Point Decorations.
Select Show or Hide.

This can be done at process and/or process-package level. If you set the Hide option
on either a process or its parent package then no migration point decoration (and
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hence flow analysis) is performed, thus improving performance.

e Temporarily switch off process flow analysis (for an individual process or the whole
package) so you can work on the process up until the point that you need to fix the
process flow so that it is suitable for TIBCO Business Studio - BPM Edition. From the
process, select Resource > BPM Validation Configuration > Process flow analysis
and validation.

The option to further highlight migration point activities using the process editor
highlighter toolbar drop-down is also removed when migration point decorations are
hidden.

This can be set on a process package and / or individual processes (if set on a
package then flow validation is disabled for all processes regardless of their own
setting).

Choose one of the following options:
° Validate Returns process flow validation to normal.

o Suppress until manual reactivation via Advanced properties Switches off
process flow validation altogether until reactivated here or via the quick fix for
"Process flow validation has been disabled rule".

o Suppress until next process flow change Switches off process flow validation
until the user makes a change that affects the process flow (such as delete/add
activities or move/add /remove sequence flows and so on.)

What to do if a URL does not open in the
default internal browser

If a URL does not open in the default internal browser, change the TIBCO Business Studio
preference to use the external browser as the default.

When you select the hyperlink for Documentation URL (on the Description tab of the
Properties view for a process artifact) on Nimbus imports within TIBCO Business Studio for
Analysts on Linux 64 (SUSE), it throws a ssl bad certificate error.

Use the TIBCO Business Studio preferences (Window > Preferences... > General > Web
Browser and select Use external web browser radio button) to point to an external
browser rather than the default internal browser.

TIBCO Business Studio™ - BPM Edition Modeling Guide



243 | Reference

Reference

This section describes the major parts of the TIBCO Business Studio user interface,
including the perspectives and views that are provided.

Project Explorer View

The Project Explorer view shows a view of the project in which you can view and create
projects, packages, processes and assets such as services and so on. In contrast to the
Navigator view (available within the Resource Perspective) the Project Explorer view shows

a contextual view of the Project.

For example, the following shows both the Navigator and Project Explorer views of the

same Project.

*Projeck Explorer

* = .bsDiagramFragments
= B Samples
# 2 IpeMadulesOut
= = Packages
[ﬂ TomPackage, xpdl
* L= Services

Fin *Project Explorer X Mavigator = |
iy =T
=

= & samples -
= 3 packages
= @ TomPackage. xpdl
= 134 MyProcessPackage
) Data Fields
8 Participants
[C] Type Declarations
O8 processes
® 3 services
= %8 bactinn

opd|

To see this view, go to Window > Show View > Project Explorer, or Window > Show
View > Other, then expand the General folder and select Project Explorer.
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You can also use the search facility to locate workspace elements in the Project Explorer
view such as processes, package names, and process interfaces by pressing Ctrl+F or the
search toolbar button in the Project Explorer view. For more information, see Tools for
Finding Objects in a Diagram.

Problems View

The Problems view is where the software displays warnings, errors and messages about the
resources used in your Project.

To see this view, go to Window > Show View > Problems, or Window > Show > View >
Other, then expand the General folder and select Problems.

The Problems view also displays error messages that result from validation of your process.
When you save your process, it is validated for BPMN correctness and for deployment or
export to the selected destination environments.

For information about correcting problems, see Correcting Validation Errors.

Outline View

The Outline View allows you to focus on specific areas of a large process.

To see this view, go to Window > Show View > Outline. By positioning the mouse pointer
over the shaded area and holding the left mouse button down, you can reposition the
shaded area of the Outline View and thus see different parts of the process.
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B= -~ .0 -
o= Outline &2

Area of the Procass that
is shown in the Process
Editar.

Remainder of Process
(not visible in the
Process Editor).

Fragments View

The Fragments view allows you to store selected objects from your process and reuse them
in a different process. You can also select predefined process fragments and use them in

your process:

Catagory

Buttons for working
with fragments

Fragment
Explorer

Fragment

To see this view, go to Window > Show View > Fragments. The buttons in the upper right
of the view allow you to do the following:

- Copy a diagram fragment to the clipboard in preparation for pasting it onto a

Process.

- Edit fragment/category properties such as the Name and Description.
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- Create a custom fragment category in which to store your fragments.

I:I - Paste a fragment from clipboard into the Fragments view or into the process.

- Delete a fragment or category.

Process Modeler Properties View

The Properties View shows you detailed information about the currently selected object
and allows you to specify the characteristics of an object.

A partial set of the Business Process Modeling Notation (BPMN) is supported by the
Properties View. For example, if you are creating a gateway in your process diagram, you
can select the type of gateway you want in the Properties View:

£ Properties 527 .__E; Problems | D(I: Fragments}ﬁ Data Source Explu:nrer-g = | K .
<> Gateway

._I General  Llabek Is Paperwork Correct? [¥] Show 'X' Marker
D.ESC‘.‘_P""U“_ | Name: IsPaperworkCorrect

Data References

AllJP.E;la.\ncem T Gateway type: @ Exclusive Decision/Merge (XOR) Data Based

T ) Inclusive Decision/Merge (OR)

e T (71 Bxclusive Decision/Merge (XOR} Event Based

Resource

() Complex Decision/Merge
i Parallel Fork/Join (AND)

To see this view, go to Window > Show View > Properties or Window > Show View >
Other, then expand the General folder and select Properties. To view property
information, you must have an object selected.

Note: Properties related to the implementation of a process (for example, the
Input To Service and Output From Services tabs for service tasks) are
described in the appropriate implementation guide.

Labels and Names

The Name is usually made up of the Label without white space or special characters. The
Name is used for referencing items where white space or special characters are restricted
(for example, scripts, and expressions). The Label is used for on-screen display.
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If the Name has not been modified from the default, it automatically changes to match the

Label when the Label is changed.

Process Properties

Process Property Reference

Tab Property

General Label

Process Interface

Inline Sub-
Process:

References

Description

Documentation
URL

Description

Label associated with the process. You can change the
label if necessary.

Lists the location and name of the process interface
implemented by the selected process. Specifying a
process interface allows the dynamic selection of sub-
processes at runtime. For more information, see
Process Interfaces.

Select the Inline sub-process during Process Package
Optimization check box so that at runtime, the objects
such as activities and events contained in the call sub-
process are brought into the top-level process and
executed there, rather than by making a call to the sub-
process.

Lists any processes or tasks that use the selected
process, and the contexts in which the data is used. For
example, if you select a call sub-process, the process
and task that use the call sub-process are displayed.
Click Go To to display the referencing object. This field
helps prevent deleting a process that is used in another.
However, a process might be used by other packages
and these references cannot be displayed in this field.

Optional textual description of the activity.
The Documentation URL controls allow you to launch a

web browser for the given URL (you can use the actual
Documentation URL: label or the browser button).
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Tab

Work
Resource

Participants

Parameters

Property

Resources...

Separation Of
Duties

(Manual and user
tasks)

Retain Familiar
(Manual and user
tasks)

Calendar
Reference

Description

The browser is opened either in TIBCO Business Studio
(in the editor pane) or in an external browser according
to the user defined settings (Preferences > General >
General).

You can specify the Initial Priority, which indicates the
relative urgency with which the item should be
completed. You can edit this from the Default setting, to
be one of the values below, with Higher (400) being the
one which would be processed first.

» Higher (400)
« High (300)
e Default
e Normal (200)
e Low (100)
Allows you to specify that certain manual or user tasks

must be executed by different resources at runtime. For
more information, see Specifying Separation of Duties.

Tasks within a Retain Familiar task group, by
preference, be offered to the same user.

Allows you to choose a calendar reference alias
(content assist shows references which already exist), or
pick a Runtime Identifier field that provides the
Calendar Reference alias at runtime.

Provides the Label, Name, Type, and External Reference
for all participants used in the process.

Provides information about all parameters defined in
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Tab Property

Data Fields

Appearance Connection
Routing

Extended

Description
the process.

Provides information about all data fields defined in the
process.

The connection routing style is used to change the
appearance of entry and exit connections on activities
such as events and gateways.

The connection routing style can be one of the
following:

e MultiEntry/Exit Point (default). This means that
connection points are to/from the same activity
side, and are automatically spaced out from the
center of that side.

» Single Entry/Exit Point. This means that all entry
and exit points are amalgamated into one entry
point and one exit point on each side of an
activity.

* Uncentered On Tasks . This means that entry
and exit points on task activities are
automatically positioned towards the corners
when the source/target object is not in-line. This
is the equivalent default from earlier versions of
TIBCO Business Studio.

With all the above styles, it is still possible to manually
set a specific entry / exit point by dragging the end of a
connection to the required position on an activity's
border (rather than the center of the object).

Extended attributes can be used to add extra
information to the schema. Click Add to add a new
extended attribute.

Modify the following:

e Name - provide a name for the attribute (you
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Tab Property

Resource BPM Fault
Configuration

System Error
Action

BPMN Extensions

BPM Validation
Configuration...

Description

cannot include spaces in the name).
* Value - add any text for the value.

e Escape Body - Select this check box if you want
the parser to interpret the contents of the body
attribute as text rather than XML (you do not
want the parser to interpret symbols such as < or
>). If you are entering XML, do not select this
check box so the parser can validate the body
attribute.

e Body - enter whatever text or XML you want to
make up the body of attribute.

BPM only:

This configures how an instance of this process behaves
at runtime if an executing activity encounters an
unexpected error condition:

» (server defined default) - use system wide
default behavior.

e Halt - process instance halts. You can then use
Openspace or the BPM API to investigate/fix the
problem.

e Error - process instance fails immediately and
cannot be resumed.

Allows you to enter duration values for the process as
per BPMN. How these durations are used is dependent
on how they are implemented in a particular
destination environment.

This is used to suppress problem markers for the ’No
migration point activities in the process’ Problem. It
gives you the choice of validation, suppressing the error
until the next process flow change, or suppressing the
error until a manual reactivation via Resource
properties.
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Case Action Properties

Case Action Reference

Tab Property Description

General Label Label associated with the case action. You can change
the label if necessary.

Case Action Select Case class that this action applies to...: Case
Class: Allows you to select the case class to which the
case action applies.

Select Case States that this action is visible for...:
Once a case class has been selected this provides
selection of the case state attribute values that the case
action should be visible for at runtime. All States
switches off the case state value filter. Specific States
enables selection of case states using check boxes.

¢ No Case State Set means that the case action is
visible when none of the defined case states are
set for a particular case.

» Other states displayed are the values defined for
the Case State enumeration for the selected class.

Select the privileges required to use this action...
Provides selection of one or more organization model
privileges that a resource must have to be able to see
and use the case action at runtime. If no privileges are
selected then all resources can see and use the case
action.

Process Interface  Lists the location and name of the process interface
implemented by the selected case action. Specifying a
process interface allows the dynamic selection of sub-
processes at runtime. For more information, see
Process Interfaces.

References Lists any processes or tasks that use the selected case
action, and the contexts in which the data is used. Click
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Tab Property Description

Go To to display the referencing object. This field helps
prevent deleting a case action that is used elsewhere.
Note, however that a case action might be used by
other packages, and these references cannot be
displayed in this field.

Description Optional textual description of the activity.
Documentation The Documentation URL controls allow you to launch a
URL web browser for the given URL (you can use the actual

Documentation URL: label or the browser button).

The browser is opened either in TIBCO Business Studio
(in the editor pane) or in an external browser according
to the user defined settings (Preferences > General >
General).

Participants Provides the Label, Name, Type, and External Reference
for all participants used in the case action.

Parameters Provides information about all parameters defined in
the case action.

Note: When a case action is auto-generated from a
case class, then you auto-create a case reference
parameter with the mode set to IN.

Data Fields Provides information about all data fields defined in the
case action.

Note: When a case action is auto-generated from a
case class, you auto-create some data fields.

Appearance Connection The connection routing style is used to change the
Routing appearance of entry and exit connections on activities
such as events and gateways.

The connection routing style can be one of the
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Tab

Extended

Property

Description

following:

e MultiEntry/Exit Point (default). This means that
connection points are to/from the same activity
side, and are automatically spaced out from the
center of that side.

» Single Entry/Exit Point. This means that all entry
and exit points are amalgamated into one entry
point and one exit point on each side of an
activity.

e Uncentered On Tasks . This means that entry
and exit points on task activities are
automatically positioned towards the corners
when the source/target object is not in-line. This
is the equivalent default from earlier versions of
TIBCO Business Studio.

With all the above styles, it is still possible to manually
set a specific entry / exit point by dragging the end of a
connection to the required position on an activity's
border (rather than the center of the object).

Extended attributes can be used to add extra
information to the schema. Click Add to add a new
extended attribute.

Modify the following:

e Name - provide a name for the attribute (you
cannot include spaces in the name).

* Value - add any text for the value.

e Escape Body - Select this check box if you want
the parser to interpret the contents of the body
attribute as text rather than XML (you do not
want the parser to interpret symbols such as < or
>). If you are entering XML, do not select this
check box so the parser can validate the body
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Tab Property

Resource BPM Fault
Configuration

System Error
Action

Activity Properties

Activity Property Reference

Tab Property
General Label
Activity Markers

Participants

Activity Type

Description

attribute.

e Body - enter whatever text or XML you want to
make up the body of attribute.

BPM only:

This configures how an instance of this case action
behaves at runtime if an executing activity encounters
an unexpected error condition:

» (server defined default) - use system wide
default behavior.

e Halt - process instance halts. You can then use
Openspace or the BPM API to investigate/fix the
problem.

e Error - process instance fails immediately and
cannot be resumed.

Description

Label for the activity that is displayed on the diagram.
Select from Standard Loop, Multiple Instance Loop, or
Ad-Hoc. For more information, see User Tasks and

Pageflow Processes.

Specify the participant responsible for this activity (see
Creating a Participant).

For example, Task, User Task, Service Task, and so on.

If you select Call Sub-Process Activity, you must
browse to locate the sub-process.
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Tab Property
e No Form
URL

e User
Defined
Form

e Form

e Pageflow

Chained
Execution

(Activities of type
Call Sub-Process
or Embedded

Description

Configure the user task as follows:

e No Form URL

Select this option if you do not want to display
a form for the user task.

e User Defined Form

Select this option if you want to use the Form
Identifier field to point to a specific URI (for
example, if you authored a form outside of
TIBCO Business Studio). Manually enter the
URI. TIBCO Business Studio cannot validate
the URI, so ensure it is correct. If you select
this option but do not specify a URI, upon
export a standard form is created.

e Form

Use this option if you have created a form
using TIBCO Business Studio Forms. Either
automatically create a form (in which case the
Form field is completed automatically) or
browse to select a form from a Forms special
folder.

» Pageflow

Select this option if you want the user task to
call a pageflow. Browse to select a pageflow
process. When deployed, the specified
pageflow process is run when the work item
associated with the user task is opened.

Specifies that the selected sub-process implements the
chained execution resource allocation pattern (see
Creating a New Embedded Sub-Process).
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Tab

Description

Property
Sub-Process)

Sub-Process
location

(Activities of type

call sub-process)

Sub-Process
name

(Activities of type
call sub-process)

Runtime Identifier
Field

(Activities of type
call sub-process)

Lifecycle

(Activities of type
call sub-process)

Documentation

Description

Sub-Process location is populated with the path to the
Sub-Process name that you select.

Browse to select the Sub-Process name.

Specify the field that is to be used in the runtime
process engine to dynamically select a sub-process that
implements a process interface. For more information,
see Process Interfaces.

Use this to configure whether the sub-process should
execute immediately or whether its start request should
be queued.

If you select Schedule Start Request, then you set the
initial priority for the sub-process start and the tasks
within that using the options in the Priority drop-down.

If you select Start Immediately, then you can still set
the priority of the task within the process in the process
Work Resource tab.

You can specify whether sub-process instances should
suspend and resume when the parent process is
suspended or resumed by selecting or deselecting the
Suspend/Resume With Parent Process check box.

Optional textual description of the activity.

The Documentation URL controls allow you to launch a
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Tab Property Description

URL web browser for the given URL (you can use the actual
Documentation URL: label or the browser button).

The browser is opened either in TIBCO Business Studio
(in the editor pane) or in an external browser according
to the user defined settings (Preferences > General >
Web Browser).

The activity tooltip popup includes the Documentation
URL as a clickable hyperlink to launch the URL in a

browser.
Interface (all Visibility Specify the visibility of an event or task (whether it is
task types private or public). Public events or tasks publish
except information (such as required parameters) to an
Reference) external process or application. Private events or tasks

to publish any information to external applications.

Reschedule work ~ Overwrite Data Already Modified In Work Item is

item: unset by default. Check it to overwrite data already
modified in a work item when you reschedule a user
(User tasks) task

This is the same as the setting available on the Map
From Signal tab for a catch signal which reschedules a
task.

Parameters Allows you to select the data fields or parameters that
the task requires as input and output.

By default, all process data is available to a task. When
you explicitly associate process data with an Event or
task, only that process data is associated with the event
or task. After you add data fields, you can control
whether it is an input parameter, output parameter, or
both by setting its Mode (to In, Out, or In/Out). You can
also specify whether the process data is mandatory. For
more information, see Associating Process Data with
Events and Tasks.
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Tab

Data Fields

Work
Resource

Property

Participants

(Manual and user
tasks only)

Initial Priority
(Manual and user
tasks only)

Distribution
Strategy

(user tasks only)

Re-offer Work
Item Strategy...

Piling (Manual
and user tasks

only)

Separation of
Duties

(Manual and user
tasks)

Description

Note that for user tasks, inbound and outbound
parameters are from the perspective of the form, not
the user. This means that inbound parameters are sent
to the form by the process, not the user. outbound
parameters are sent to the form by the user. For more
information, see the appropriate implementation guide.

Provides information about all data fields defined in the
activity.

This is the same as the Participant specified on the
General tab.

Specifies a relative priority for the work item. The affect
and meaning of this setting are destination specific
(refer to appropriate implementation guide).

Allows you to specify a resource allocation pattern. For
more information, see Resource Patterns and Work
Distribution.

Allows you to govern the behavior when you open an
offered work item and then close or cancel the work
item to place it back in the work item list. You can

choose to 'Re-offer On Close' or 'Re-offer On Cancel'.

Allows you to specify that certain manual or user tasks
must be executed by different resources at runtime. For
more information, see Specifying Separation of Duties.
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Tab Property Description

Retain Familiar
(Manual and user

tasks)

Scripts Allows you to add text that describes various types of
scripts that you want added to a task. It is the task of
the solution engineer to translate the outline of the
script into a scripting language supported by the
selected destination environment. For more information
about implementing scripts, see the appropriate
implementation guide.

Map To Sub- Use this section to create a mapping from an actual

Process parameter (data field or parameter) into the formal

. parameters of the sub-process. Create a mapping by

(Activities of . . L

type call sub- clicking a parameter, d‘raggmg to the destination
parameter, then releasing the mouse button.

process)

Data Grouped by Data  Contains a table with a row for each referenced data

References field, along with a list of the contexts in which it is used.

Grouped by Contains a table with a row for each context along with
Reference Context the data which is referenced.
Map From Use this section to create a mapping from a formal
Sub-Process parameter of a sub-process to an actual parameter

(data field or parameter). Create a mapping clicking a
parameter, dragging to the destination parameter, then
releasing the mouse button.

(Activities of
type call sub-
process)

Appearance Line Color Click the button next to Color to select the line color for
the border of the selected activity. Click Set As Default
For Type to apply your current color settings to any
new activities of that type that you place on the
process. You can revert to the default color settings by
clicking Restore Factory Settings.
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Tab

Extended

Resource

Property

Fill Color

Task Icon

BPMN Extensions

Dynamic Sub-
process Task...
(Dynamic sub-
process tasks)

Allow Unqualified
Sub-Process
Identification

Description

Click the button next to Color to select the fill color for
the selected activity. Click Set As Default For Type to
apply your current color settings to any new activities of
that type that you place on the process. You can revert
to the default color settings by clicking Restore Factory
Settings.

Select a valid image file for the Studio project if one is
available.

See the description of the Extended tab for the Process
Properties.

Allows you to enter duration values for the task as per
BPMN. How these durations are used is dependent on
how they are implemented in a particular destination

environment.

False: Sub-process names provided in the Runtime
Identifier Field must be fully qualified unless they are
located in the same XPDL package. Full qualification
means /project/Process
Packages/PkgName . xpd1l.MyProcessName.

True: allow unqualified sub-process names to be used
even if they are located outside of the XPDL package
(when they are dynamically discovered at runtime).
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Tab

Gateway Properties

Property

Gateway Property Reference

Tab

General

Property
Label
Gateway type
Discriminator

Type

(Complex
Gateway)

Parallel Split
Name

(Complex
Gateway)

Description

Note:

When an unqualified sub-process is provided in the
Runtime Identifier Field, the process manager looks
for the process in the following locations:

e The same deployed XPDL package.

e Any XPDL package in the same deployed
project.

* Any XPDL package in any deployed project.

The first matching named process is used. If there
are multiple processes with the same name in any
one of these locations (i.e. the sub-process
identification is ambiguous) then it results in a
runtime exception that can halt the process instance.

Description
Label for the gateway that is displayed on the diagram.
Choose the type of gateway.

Allows you to select a structured discriminator.

Allows you to specify the name of the upstream parallel
gateway that this complex gateway is handling.
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Tab

Description

Data
References

Appearance

Extended

Resource

Property

Incoming Paths

(Complex
Gateway)

Grouped By
Data

Grouped By
Reference
Context...

Description

Specifies how many input Sequence flows are required
before the output sequence flow is followed.

Optional textual description of the gateway.

Contains a table with a row for each item of referenced
process data, along with a list of the contexts in which it
is used.

Contains a table with a row for each context along with
the process data which is referenced.

See the description of the Appearance tab for the Activity

Properties.

See the description of the Extended tab for the Process
Properties.

Shows properties and values for the gateway.

Sequence Flow Properties

Sequence Flow Property Reference

Tab

General

Description

Data

Property

Label

Type

Grouped By

Description

Label for the flow that is to be displayed on the diagram.
Choose the type of Sequence Flow.

Optional textual description of the Sequence Flow.

Contains a table with a row for each item of referenced
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Tab Property

References Data
Grouped by
Reference
Context

Appearance

Extended

Resource

Event Properties

Event Property Reference

Tab Property
General Label

Trigger Type
(for Start or
Intermediate
events) or
Result Type
(for End events)

Catch Action
(for catch signal
intermediate
events only)

Description

process data, along with a list of the contexts in which it is
used.

Contains a table with a row for each context along with the
process data which is referenced.

See the description of the Appearance tab for the Activity
Properties.

See the description of the Extended tab for the Process
Properties.

Shows properties and values for the sequence flow.

Description
Label for the event that is displayed on the diagram.

You specify the trigger for a Start or Intermediate event
and the result for an End event. The properties displayed
on this page depend on the Trigger Type or Result Type
you have selected. For more information about the types
of events, see Events.

Select either Cancel task when signal caught or
Continue task when signal caught. When you select the
latter, you can select between the following Reschedule
Task Timer Events:

* None No timer events are rescheduled when signal
arrives.

TIBCO Business Studio™ - BPM Edition Modeling Guide



264 | Reference

Tab

Description
Interface
Scripts

Data
References

Property

Catch Error
Code (for catch
error
intermediate
events only)

Grouped By
Data

Grouped by

Description
o All All timer events attached to same task are
rescheduled when signal arrives.

e Deadline The timer event set as the activity
deadline; note this is evaluated at runtime rather
than statically when this option is selected (so that
if the deadline timer event is changed, this still
works).

» Select... One or more timer events can be
manually selected.
Set to one of the following, depending on what error

codes you want caught:

e Catch All

The event catches any error thrown by any
event.

e Catch By Name

The event catches an error of the specified
name, thrown by any activity.

e Catch Specific

The event catches a specific error thrown by a
specific activity.

Optional textual description of the Event.

See description for Activity Properties.

See description for Activity Properties.

Contains a table with a row for each item of referenced
process data, along with a list of the contexts in which it

is used.

Contains a table with a row for each context along with
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Tab Property Description

Reference the process data which is referenced.

Context
Map From Use this section to create a mapping from error
Error (for catch parameters to process data fields or parameters.
error
intermediate

events only)

Map From Use this section to create a mapping from signal
Signal (for parameters to process data fields or parameters.
catch signal
intermediate

events only)

Appearance See the description of the Appearance tab for the Activity
Properties.

Extended See the description of the Extended tab for the Process
Properties.

Lane Properties

Lane Property Reference

Tab Property Description

General Label Label for the lane that is displayed on the diagram.

Appearance See the description of the Appearance tab for the Activity
Properties.

Extended See the description of the Extended tab for the Process
Properties.

Resource This tab might contain destination-specific properties.
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Cheat Sheets View

When you first start TIBCO Business Studio, a Welcome Cheat Sheet is displayed. You can
view TIBCO Cheat Sheets and other Cheat Sheets by selecting Help > Cheat Sheets and
selecting from the list.

Process Editor

The Process Editor is where you create your business process. It includes a Palette that
contains the tools you use to create your Process.

Palette

You can create your Process using the tools on the palette. The Business Process Modeling
Notation (BPMN) core set is supported by the palette, which contains the following tools:

Palette Tool Reference

Palette Item

IE Select
Marquee

Favorites

I:::I '\k:ﬂl‘l O
== fom
® @

Connections

-

— Ok

Description

Allows you to select objects.

Allows you to select several objects by drawing a box around them.

Displays some of the most common process objects. You can customize the
Favorites drawer by right-clicking it and selecting Customize.

Allows you to connect objects:
» Sequence flow shows the order of objects in the process.

» Conditional sequence flow is followed based on the evaluation of a
condition.

e Default sequence flow is followed if other conditions evaluate to
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Palette Item

Start Events

Catch
Intermediate
Events

© 6 & ©
@ @ 8

Throw
Intermediate
Events

End Events

(OO
®@ @@

Tasks

o @

g 0
B Ko

Gateways

® @® O
o @

Artifacts

Description

false.

e Association either connects flow and non-flow objects or specifies the
compensation task for a compensation event on a task boundary.

Indicates the beginning of the process as None or Signal.

Catches a "throw" event. The following Types are available: Incoming
Request, Timer, Link, Signal, Error, Compensation, and Cancel.

Throws an event. The following Types are available: Compensation, Signal,
and Link.

Indicates the end of the process. The following types are available: None,
Error, Compensation, Cancel, Signal, and Terminate.

Tasks are of the following types: Abstract, User, Service, Script, Send,
Receive, Call Sub-Process, Embedded Sub-Process, and Event Sub-Process.

For more information, see Activities.

Controls the flow of the process with the following types of gateways:
Exclusive (Data), Parallel, Exclusive (Event), Inclusive, and Complex.

Allows you to enhance the process with Text Annotations, Data Objects, and
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Palette Item Description

Groups.

L O &

Alignment Tools

For easier alignment of objects in the Process Editor, you can select either or both of the
Grid or Alignment Guides options.

e Diagram > Grid - This allows you to align objects to a grid.

e Diagram > Alignment Guides - As you move objects in a Process Editor, a blue line
appears when the center of two objects coincide.

You can also align objects that you have selected by choosing options from the Diagram >
Alignment menu. For example, if you have two Activities selected, you can align them
horizontally on their centers by selecting Diagram > Alignment > Align Middle.
Alternatively, you can use the alignment buttons on the toolbar that correspond to the
menu options.

Business Object Modeler Properties View

This section describes the major parts of the TIBCO Business Studio Business Object
Modeler User Interface (Ul).

In Eclipse, a Perspective includes the views and set of editors that you commonly use for a
specific type of work. TIBCO has created several TIBCO Business Studio perspectives that
include the views and editors you commonly use when creating business processes. The
Business Object Modeler and its associated views are part of the BPM Modeling
Perspective. For more information about parts of the BPM Modeling Perspective that are
not related to the Business Object Modeler, see the TIBCO Business Studio™ - BPM Edition
Modeling Guide.

The Properties View shows you detailed information about the currently selected object
and allows you to specify the characteristics of an object.
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Package Properties

Tab

General

Description

Profiles

Stereotypes

Export

Resource

Property

Name

Profiles

Applied
Profiles

Location

Applied
Stereotype

Profile
Location
XML Schema
Export
Options

Property

Value

Description

Name of the Package. You can rename the Package here by
entering a new name.

Enter text to describe the Package or any supporting
explanations.

Lists the UML profiles that have been applied to this
package.

Clicking the picker displays the Select Type dialog box from
which you can add or remove profiles.

The name of the applied profile.

The location of the file that contains the applied profile.

Lists the stereotypes that have been applied to this
package.

Clicking the picker displays the Select Type dialog box from
which you can add or remove stereotypes.

The name of the stereotype.

The name of the profile that contains the stereotype.
The location of the file that contains the stereotype.

Lists the available elements and allows selection of which
to export as top-level elements in the XML Schema.

The name of the package.
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Class Properties

Tab Property Description

General Name Name of the Class. You can rename the Class here by
entering a new name.

Superclass In object-oriented terms, the Super Class provides attributes
which are inherited by any Derived Classes.

Clicking the picker displays the Select Type dialog box from
which you can select a Class to form the SuperClass. Click
Clear to remove a SuperClass.

Description Enter text to describe the Class or any supporting
explanations.

Attributes Lists the Attributes that belong to the Class, including its
Name, Type, Multiplicity (whether there can be several of
the Attribute), and Stereotypes (whether any stereotypes
have been applied). You can add additional Attributes by
clicking . You can delete an Attribute by selecting it and

clicking [

Summary Lists the Case Class attributes that are included in the
Summary description of the Case that is displayed in

Openspace.
You can add additional Attributes by clicking . You can

delete an Attribute by selecting it and clicking [].
The Case Identifier and Case State are automatically

included (and cannot be removed). If you wish to add
additional attributes, then they must have:

e Multiplicity no more than 1

e An attribute of a primitive type (for example, Integer,
Text) or enumeration
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Tab Property Description

Note: The order in which the attributes are listed in the
Summary screen is the default order they are displayed
in Openspace, or returned over the Summary interface at
runtime.

Operations Lists the Operations that belong to the Class, including its
Name, Return Type, Multiplicity (whether there can be
several of the Operation), Arguments and Stereotypes
(whether any stereotypes have been applied). You can add
additional Operations by clicking . You can delete an

Operation by selecting it and clicking | x].

Stereotypes List of stereotypes that have been applied to this class.

Clicking the picker displays the Select Stereotype dialog box
from which you can add or remove stereotypes.

Applied The name of the stereotype.

Stereotype

Profile The name of the profile that contains the stereotype.

Location The location of the file that contains the stereotype.
Appearance Fonts and You can change the font type and size of the text on your

Colors business object model. You can also change the weight and

color of both the text and the business objects in the
business object model.

Lines and You can change the appearance of lines and arrows in your
Arrows business object model. This is currently deselected.
Gradient You can change the gradient of colors for your business

objects in the business object model.

Resource Property
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Tab Property

Value

Description

The name of the class.

Attribute Properties

Tab Property
General Name
Multiplicity
Type
Description
Stereotypes
Applied
Stereotype
Profile

Description

Name of the Attribute. You can rename the Attribute here
by entering a new name.

Specifying multiple copies of an Attribute are permitted.
See the "Attributes" topic in the TIBCO® BPM Enterprise
Concepts Guide for information on the values you can set.

Select the type of data you expect the Attribute to contain.
See the "Attributes" topic in the TIBCO® BPM Enterprise
Concepts Guide for information on the types an Attribute
can have.

Clicking the picker displays the Select Type dialog box from

which you can change the type of an attribute. Click
to remove a type.

Enter text to describe the Attribute or any supporting
explanations.

List of stereotypes that have been applied to this package.
Clicking the picker displays the Select Type dialog box from
which you can add or remove stereotypes.

The name of the stereotype.

The name of the profile that contains the stereotype.
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Tab Property
Location
Resource Property

Restrictions

Value

Description

The location of the file that contains the stereotype.

Expand this to specify any restrictions for the Attribute. For
example, you can specify a default value, or maximum
length, depending on the type of your Attribute.

The name of the Attribute.

Primitive Type Properties

Tab Property
General Name
Superclass
Description
Stereotypes
Applied
Stereotype

Description

Name of the Primitive Type. You can rename the Primitive
Type here by entering a new name.

In object-oriented terms, the Superclass provides attributes
which are inherited by any Derived Classes.

Clicking the picker displays the Select Type dialog box from
which you can select a Type to form the Superclass for the
Primitive Type. Click Clear to clear a Superclass.

Enter text to describe the Primitive Type or any supporting
explanations.

List of stereotypes that have been applied to this package.

Clicking the picker displays the Select Type dialog box from
which you can add or remove stereotypes.

The name of the stereotype.
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Tab

Appearance

Resource

Property

Profile

Location

Fonts and
Colors

Lines and
Arrows

Gradient

Property

Restrictions

Value

Description
The name of the profile that contains the stereotype.
The location of the file that contains the stereotype.

You can change the font type and size of the text on your
business object model. You can also change the weight and
color of both the text and the business objects in the
business object model.

You can change the appearance of lines and arrows in your
business object model. This is deselected by default.

You can change the gradient of colors for your business
objects in the business object model.

Expand this to specify any restrictions for the Primitive
Type. For example, you can specify a default value, or
maximum length, depending on the type of your Primitive

Type.

The name of the Primitive Type.

Enumeration Properties

Tab

General

Description

Property

Name

Description

Name of the Enumeration. You can rename the Enumeration
here by entering a new name.

Enter text to describe the Enumeration or any supporting
explanations.
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Tab Property Description
Enum Literals

Stereotypes List of stereotypes that have been applied to this
Enumeration.

Clicking the picker displays the Select Type dialog box from
which you can add or remove stereotypes.

Applied The name of the stereotype.

Stereotype

Profile The name of the profile that contains the stereotype.

Location The location of the file that contains the stereotype.
Appearance Fonts and You can change the font type and size of the text on your

Colors business object model. You can also change the weight and

color of both the text and the business objects in the
business object model.

Lines and You can change the appearance of lines and arrows in your
Arrows business object model. This is currently deselected.
Gradient You can change the gradient of colors for your business

objects in the business object model.
Resource Property

Value The name of the Enumeration.

Enumeration Literal Properties

Tab Property Description

General Name Name of the Enumeration Literal. You can rename the
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Tab Property Description
Enumeration Literal here by entering a new name.

Value Single: The text value of the enumeration literal.

Range: is not supported.

Description Area in which you can enter text to describe the
Enumeration Literal or any supporting explanations.

Stereotypes Lists the stereotypes that have been applied to this
Enumeration Literal.

Clicking the picker displays the Select Type dialog box from
which you can add or remove stereotypes.

Applied The name of the stereotype.

Stereotype

Profile The name of the profile that contains the stereotype.

Location The location of the file that contains the stereotype.
Resource Property

Value The name of the Enumeration Literal.

Association Composition Properties

Tab Property Description

General Name Name of the Association or Composition. You can rename
the connection here by entering a new name.

Navigability Select the direction of the connection from the drop-down
list either Bi-directional or ClassNamel
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Tab

Description

Stereotypes

Appearance

Resource

Property

Applied
Stereotypes

Profile
Location

Fonts and
Colors

Routing

Lines and
Arrows

Jump Links

Smoothness
Property

Value

Description
to ClassName?2.

Enter text to describe the Association or Composition and
any supporting explanations.

The name of the stereotype.

The name of the profile that contains the stereotype.

The location of the file that contains the stereotype.

You can change the font type and size of the text of the
labels on your connections on your business object model.
You can also change the weight and color of the
connections.

You can determine how the connections are routed in the
model. For example, you can choose to make the
connections avoid obstructions to make the model easier

to read.

You can change the appearance of lines and arrows in your
business object model. This is currently deselected.

If you have connections that overlap in your model, specify
jump links so that the connections jump over each other.

You can change the smoothness of the connections.

The name of the Association/Composition Property
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Organization Modeler Properties View

This section of the help describes the major parts of the TIBCO Business Studio
Organization Modeler User Interface (Ul).

In Eclipse, a Perspective includes the views and set of editors that you commonly use for a
specific type of work. TIBCO has created several TIBCO Business Studio perspectives that
include the views and editors you commonly use when creating business processes. The
Organization Modeler and its associated views are part of the BPM Modeling Perspective.

For more information about parts of the BPM Modeling Perspective that are not related to
the Organization Modeler, see the TIBCO Business Studio™ - BPM Edition Modeling Guide.

The Properties View shows you detailed information about the currently selected object
and allows you to specify the characteristics of an object.

Organization Model Properties describes the Properties that are available for the elements
in an Organization Model.

Organization Model Properties

Tab Property Description

General Label The displayed name of the Organization Model. You can rename
the Organization Model here by entering a new name.

Name The internal name. This defaults to the same value as the Label,
but with any internal spaces removed.

Version The version of the Organization Model. This defaults to the
version specified when the project was created, which in turn
defaults to 1.0.0.qualifier. You can retain this or enter a
different version for the Organization Model in the standard
Eclipse form of:

major.minor.micro.qualifier

There is a limit of 6 on the number of organization model
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Tab Property Description

versions supported.

Changes to the version of the Organization Model do not directly
affect other project artifacts, such as process packages.
However, all references within a project must be to the same
major version of the Organization Model.

At run-time, the Organization Model Version field in the
Organization Browser in Workspace displays only the first digit
of this version number, that is the major version.

Author The username that created the Organization Model.

The name of the author can be defined in the User Name: field
on Window > Preferences > User Profile. If no user is defined
there, it uses the default user system property.

Date The date the Organization Model was created.

Created
Privileges - Privilege The name of the Privilege associated with this Organization
Assigned Model. Click the picker to open the Select Type dialog box to

add or remove a Privilege.

Qualifier You can enter qualifying information here if required. See the
Value "Capabilities and Privileges" topic in the TIBCO® BPM Enterprise
Concepts Guide for more information about qualifications.

System Name The name of the system action.

Actions ) o ) .
If you associate one or more privileges with a system action,

they are listed on the lines below that action. Click to

expand the display and show the privileges, and click to
collapse the display.

Click S to assign a privilege to a system action. The Select
Type dialog box is displayed, enabling you to add or remove a
privilege. You can also remove a privilege by selecting it and
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Tab

Resource

Property

Qualifier
Value

Property
Value

Description

clicking

Click

¥

ﬂ to move the privilege up the list, or

&

to move it

down. These icons are only available if there is more than one
privilege attached to a system action.

If a privilege has qualifying information specified, this column
lists the value of the qualifier.

Click

A
7

defined for it.

to reset the value of a qualifier to the default value

Displays the Label and Name of the Organization Model. You can
edit the values from this tab by clicking on the Value field.

Organization Properties

Tab

General

Property

Label

Name

Type

Description

The displayed name of the Organization. You can rename the
Organization here by entering a new name.

The default name of the Organization Model is used here,
which is Organizationl. To change the default, select Window
> Preferences > User Profile and edit the Organization
Name field.

The internal name. This defaults to the same value as the
Label, but with any internal spaces removed.

The type for the Organization. This can be the Standard
Organization Type, for example or might be a type that you
have defined yourself. See the "Schemas" topic in the TIBCO®
BPM Enterprise Concepts Guide for more information about
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Tab

Units

Appearance

Resource

Property

Allocation
Method

Purpose

Dates

Location

Label

Type
Location
Start Date
End Date

Fonts and
Colors

Lines and
Arrows

Property
Value

Description

types.
Clicking the picker displays the Select Type dialog box from

which you can add or remove Organization Types.

One of Random or Round Robin. Determines how work is
allocated.

Enter text to describe the purpose of the Organization.

You can specify start and end dates for the Organization.
Click the picker next to the date fields to display the
calendars.

The location for the Organization. Click the picker next to the
Location field to select it.

The name of any Organization Units that are defined as being
children of this Organization. Click to add an

Organization Unit. You can delete an Organization Unit by

selecting it and clicking [ %],

The characteristics of the Organization Unit named by Label.
These are display-only.

Displays the Label and Name of the Organization. You can
edit the values from this tab by clicking on the Value field.
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Dynamic Organization Properties

Tab

General

Dynamic Org
Identifiers

Units

Appearance

Property

Label

Name

Purpose

Label

Name

Label

Name

Type

Location

Fonts and
Colors

Description

The displayed label of the Dynamic Organization. You can
rename the Dynamic Organization here by entering a new
label.

The default label of the Dynamic Organization Model is used
here, which is Dynamic Organization 1.

The internal name. This defaults to the same value as the
Label, but with any spaces and special characters removed.

Area in which you can enter text to describe the purpose of
the Dynamic Organization.

The displayed label of the Dynamic Organization Identifier.
The internal name. This defaults to the same value as the
Label, but with any spaces and special characters removed.

The label of any Organization Units that are defined as being
children of this Organization. Click to add an Organization

Unit. You can delete an Organization Unit by selecting it and

clicking [ 3¢].

The internal name. This defaults to the same value as the
Label, but with any spaces and special characters removed.

The characteristics of the Dynamic Organization Unit named
by Label. These are display-only.

The location for the Dynamic Organization. Click the picker
next to the Location field to select it.
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Tab

Resource

Property

Lines and
Arrows

Property
Value

Description

Displays the Label and Name of the Dynamic Organization.
You can edit the values from this tab by clicking on the Value
field.

Organization Unit Properties

Tab

General

Units

Property

Label

Name

Member of

Allocation
Method

Purpose

Dates

Location

Label

Description

The displayed name of the Organization Unit. You can
rename the Organization Unit here by entering a new name.

The internal name. This defaults to the same value as the
Label, but with any internal spaces removed.

If you are using the default schema, or if you have created
your own schema and defined any Organization Unit Types,
you can assign a Type to this Organization Unit by selecting it

in the Member of field.

One of Random or Round Robin. Determines how work is
allocated.

Enter text to describe the purpose of the Organization Unit.
You can specify start and end dates for the Organization Unit.
Click the picker next to the date fields to display the

calendars.

The location for the Organization Unit. Click the picker next
to the Location field to select it.

The name of any Organization Units lower in the hierarchy
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Tab

Positions

Privileges -
Assigned

System
Actions

Property

Type
Location
Start Date
End Date

Label

Type
Location
Start Date
End Date

Privilege

Qualifier
Value

Name

Description

that are defined as being children of this Organization Unit.
Click to add an Organization Unit. You can delete an

Organization Unit by selecting it and clicking .

The characteristics of the Organization Unit named by Label.
These are display-only.

The name of any Positions that are defined as being children
of this Organization Unit. Click to add a Position. You can

delete a Position by selecting it and clicking [ x].

The characteristics of the Position named by Label. These are
display-only.

The name of the Privilege you want to specify for this
Organization Unit. Click the picker to open the Select Type
dialog box to add or remove a Privilege.

You can enter qualifying information here if required. See the
"Capabilities and Privileges" topic in the TIBCO® BPM
Enterprise Concepts Guide for more information about
qualifications.

The name of the system action.

If you associate one or more privileges with a system action,
they are listed on the lines below that action. Click to

expand the display and show the privileges, and click to
collapse the display.

Click m to assign a privilege to a system action. The Select
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Tab

Appearance

Resource

Property

Qualifier
Value

Fonts and
Colors

Lines and
Arrows

Gradient

Property
Value

Description

Type dialog box is displayed, enabling you to add or remove
a privilege. You can also remove a privilege by selecting it

¥

and clicking

Click ﬂ to move the privilege up the list, or % to move it
down. These icons are only available if there is more than
one privilege attached to a system action.

If a privilege has qualifying information specified, this column
lists the value of the qualifier.

Click < to reset the value of a qualifier to the default value
defined for it.

Displays the Label and Name of the Organization Unit. You
can edit the values from this tab by clicking on the Value
field.

Dynamic Organization Unit Properties

Tab

General

Property

Label

Description

The displayed label of the Dynamic Organization Unit. The
label and name are derived from the root organization unit
of the referenced dynamic organization. You cannot
change this value.
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Tab

Appearance

Resource

Property

Name

Dynamic
Organization

Fonts and
Colors

Lines and
Arrows

Gradient

Property Value

Description

The internal name. This defaults to the same value as the
Label, but with any internal spaces removed. The label and
name are derived from the root organization unit of the
referenced dynamic organization. You cannot change this
value.

The name of the Dynamic Organization that this Dynamic
Organization Unit references.

Displays the Label and Name of the Dynamic Organization
Unit. Read-only.

Hierarchy and Association Properties

Tab

General

Property

Label

Name

Type

Description

The displayed name of the Hierarchy or Association. You
can rename the Hierarchy or Association here by entering a
new name.

The internal name. This defaults to the same value as the
Label, but with any internal spaces removed.

The type for the Hierarchy or Association. This can be an
Organization Unit Relationship Type, for example or might
be a type that you have defined yourself. See the
"Schemas" topic in the TIBCO® BPM Enterprise Concepts
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Tab

Appearance

Resource

Property

Is Hierarchical

Purpose

Dates

Property Value

From

To

Description

Guide for more information about types.

Clicking the picker displays the Select Type dialog box from
which you can add or remove Types.

This check box determines whether the connection is a
Hierarchy or an Association. If this is checked, the
connection is a Hierarchy; if unchecked, it is an Association.
You can change the type of connection by checking or
unchecking this box.

Enter text to describe the purpose of the Hierarchy or
Association.

You can specify start and end dates for the Hierarchy or
Association. Click the picker next to the date fields to
display the calendars.

Displays the Label and Name of the Hierarchy or
Association, and the From and To values. You can edit the
values from this tab by clicking on the Value field.

The Organization Unit the relationship runs from. In a
Hierarchical relationship, this is the unit at the higher level
of the hierarchy.

The Organization Unit the relationship runs to. In a

Hierarchical relationship, this is the unit at the lower level
of the hierarchy.
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Position Properties

Tab

General

Capabilities -
Assigned

Property

Label

Name

Position Type

Allocation

Method

Number

Purpose

Dates

Location

Capability

Qualifier
Value

Description

The displayed name of the Position. You can rename the
Position here by entering a new name.

The internal name. This defaults to the same value as the
Label, but with any internal spaces removed.

If you are using the default schema, or if you have created

your own schema and defined any Position Types, you can
assign a Type to this Position by selecting it in the Element
field.

One of Random or Round Robin. Determines how work is
allocated.

Enter the ideal number of people there should be in this
Position within the Organization Unit.

Enter text to describe the purpose of the Position.

You can specify start and end dates for the Position. Click
the picker next to the date fields to display the calendars.

The location for the Position.

Clicking the picker displays the Select Type dialog box from
which you can add or remove Locations.

The name of the Capability you want to specify for this
Position. Click the picker to open the Select Type dialog
box to add or remove a Capability.

You can enter qualifying information here if required. See
the "Capabilities and Privileges" topic in the TIBCO® BPM
Enterprise Concepts Guide for more information about
qualifications.

TIBCO Business Studio™ - BPM Edition Modeling Guide



289 | Reference

Tab Property Description
Privileges - Privilege The name of the Privilege you want to specify for this
Assigned Position. Click the picker to open the Select Type dialog

box to add or remove a Privilege.

Qualifier You can enter qualifying information here if required. See

Value the "Capabilities and Privileges" topic in the TIBCO® BPM
Enterprise Concepts Guide for more information about
qualifications.

Organization Label Shows any Resources allocated to the Position.

Resources
Click to add a Resource. You can delete a Resource by

selecting it and clicking .

System Actions  Name The name of the system action.
If you associate one or more privileges with a system
action, they are listed on the lines below that action. Click
to expand the display and show the privileges, and
click to collapse the display.

Click N to assign a privilege to a system action. The
Select Type dialog box is displayed, enabling you to add or
remove a privilege. You can also remove a privilege by

#

selecting it and clicking

Click i to move the privilege up the list, or 2 to move
it down. These icons are only available if there is more
than one privilege attached to a system action.

Qualifier If a privilege has qualifying information specified, this
Value column lists the value of the qualifier.
Click & to reset the value of a qualifier to the default

value defined for it.
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Tab

Description

Resource

Group Properties

Tab

General

Capabilities -
Assigned

Privileges -
Assigned

Property

Description

Property
Value

Property

Label

Name

Allocation

Method

Purpose

Capability

Qualifier
Value

Privilege

Description

Enter text to describe the Position or any supporting
explanations.

Displays the Label and Name properties of the Position.
You can edit the values from this tab by clicking on the
Value field.

Description

The displayed name of the Group. You can rename the
Group here by entering a new name.

The internal name. This defaults to the same value as the
Label, but with any internal spaces removed.

One of Random or Round Robin. Determines how work is
allocated.

Area in which you can enter text to describe the purpose of
the Group.

The name of the Capability you want to specify for this
Group. Click the picker to open the Select Type dialog box
to add or remove a Capability.

You can enter qualifying information here if required. See
the "Capabilities and Privileges" topic in the TIBCO® BPM
Enterprise Concepts Guide for more information about
qualifications.

The name of the Privilege you want to specify for this

Group. Click the picker to open the Select Type dialog box
to add or remove a Privilege.
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Tab Property Description
Qualifier You can enter qualifying information here if required. See
Value the "Capabilities and Privileges" topic in the TIBCO® BPM

Enterprise Concepts Guide for more information about
qualifications.

Groups Label Shows any sub-Groups that are part of the Group.

Click to add a Group. You can delete a Group by

selecting it and clicking .

Organization Label Shows any Resources allocated to the Group.

Resources
Click to add a Resource. You can delete a Resource by

selecting it and clicking .

System Actions  Name The name of the system action.
If you associate one or more privileges with a system

action, they are listed on the lines below that action. Click
to expand the display and show the privileges, and

click to collapse the display.

Click LY to assign a privilege to a system action. The
Select Type dialog box is displayed, enabling you to add or
remove a privilege. You can also remove a privilege by

¥

selecting it and clicking

Click i to move the privilege up the list, or 2 to move
it down. These icons are only available if there is more
than one privilege attached to a system action.

Qualifier If a privilege has qualifying information specified, this
Value column lists the value of the qualifier.
Click & to reset the value of a qualifier to the default
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Tab Property

Description Description

Resource Property
Value

Description
value defined for it.

Area in which you can enter text to describe the Group or
any supporting explanations.

Displays the Label and Name of the Group. You can edit
the values from this tab by clicking on the Value field.

Capability Category and Privilege Category

Properties
Tab Property
General Label
Name

Capabilities or
Privileges

Resource Property
Value

Description

The displayed name of the Category. You can rename the
Category here by entering a new name.

The internal name. This defaults to the same value as the
Label, but with any internal spaces removed.

Lists the Capabilities or Privileges that are members of this
category.

Displays the Label and Name of the Category. You can edit the
values from this tab by clicking on the Value field.

Capability Properties

Tab Property

General Label

Description

The displayed name of the Capability. You can rename the
Capability here by entering a new name.
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Tab

Description

Resource

Privilege Properties

Tab

General

Property

Name

Has qualifier

Purpose

Category

Description

Property
Value

Property

Label

Name

Description

The internal name. This defaults to the same value as the
Label, but with any internal spaces removed.

Select this option if you want to add qualifying information
to a Capability or Privilege. See "Capabilities and Privileges"
in the TIBCO® BPM Enterprise Concepts Guide for more
information about qualifications.

If this check box is selected, the Show qualifier .. link is
enabled. Click Show qualifier .. or click on the Qualifier tab
title to display the Qualifier tab. You can specify a data type
for your qualifying information.

Area in which you can enter text to describe the purpose of
the Capability.

Shows the Category of which this Capability is a member.
Click the picker to open the Select Type dialog box to add or

remove a Category.

Area in which you can enter text to describe the Capability
or any supporting explanations.

Displays the Label and Name of the Capability. You can edit
the values from this tab by clicking on the Value field.

Description

The displayed name of the Privilege. You can rename the
Privilege here by entering a new name.

The internal name. This defaults to the same value as the
Label, but with any internal spaces removed.
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Tab

Qualifier

Description

Resource

Property

Has qualifier

Purpose

Category

Label

Name

Type

Default Value

Description

Property
Value

Description

Select this option if you want to add qualifying information
to a Capability or Privilege. See the "Capabilities and
Privileges" topic in the TIBCO® BPM Enterprise Concepts
Guide for more information about qualifications.

If this check box is selected the Show qualifier .. link is
enabled. Click Show qualifier .. or click on the Qualifier tab
title to display the Qualifier tab. You can specify a data type
for your qualifying information.

Enter text to describe the purpose of the Privilege.

Shows the Category of which this Privilege is a member.
Click the picker to open the Select Type dialog box to add or
remove a Category.

The displayed name of the Qualifier.

The internal name. This defaults to the same value as the
Label, but with any internal spaces removed.

From the Type drop-down list, select a data type for the
qualifying information. See the "Capabilities and Privileges"
topic in the TIBCO® BPM Enterprise Concepts Guide for more
information about the data types that qualifying information
can have.

You can specify a default value for the Qualifier here.

Enter text to describe the Privilege or any supporting
explanations.

Displays the Label and Name of the Privilege. You can edit
the values from this tab by clicking on the Value field.
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Location Properties

Tab Property

General Label

Name

Type

Allocation
Method

Purpose

Dates
Description Description

Resource Property
Value

Resource Properties

Tab Property

General Label

Description

The displayed name of the Location. You can rename the
Location here by entering a new name.

The internal name. This defaults to the same value as the
Label, but with any internal spaces removed.

The type for the Location. This can be the Standard Location
Type, for example or might be a type that you have defined

yourself. See the "Schemas" topic in the TIBCO® BPM
Enterprise Concepts Guide for more information about types.

Clicking the picker displays the Select Type dialog box from
which you can add or remove Location Types.

One of Random or Round Robin. Determines how work is
allocated.

Enter text to describe the purpose of the Location.

You can specify start and end dates for the Location. Click
the picker next to the date fields to display the calendars.

Enter text to describe the Location or any supporting
explanations.

Displays the Label and Name of the Location. You can edit
the values from this tab by clicking on the Value field.

Description

The displayed name of the Resource. You can rename the
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Tab

Attribute
Values

Description

Resource

Property

Name

Type

Purpose

Dates

Label

Value

Description

Property
Value

Description
Resource here by entering a new name

The internal name. This defaults to the same value as the
Label, but with any internal spaces removed.

The type for the Resource. This can be the Human Resource
Type, for example, or might be a type that you have defined
yourself. See the "Schemas" topic in the TIBCO® BPM

Enterprise Concepts Guide for more information about types.

Clicking the picker displays the Select Type dialog box from
which you can add or remove Resource Types.

A field in which you can enter text for a brief description of
the purpose of the Resource.

You can specify start and end dates for the Resource. Click
the picker next to the date fields to display the calendars.

The name of any attributes that are defined for this type of
Resource are displayed here.

Click the Value field next to each defined attribute to display
a list of available values for that attribute. See the
"Attributes" topic in the TIBCO® BPM Enterprise Concepts
Guide for more information about attributes.

Area in which you can enter text to describe the Resource or
any supporting explanations.

Displays the Label and Name of the Resource. You can edit
the values from this tab by clicking on the Value field.
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Organization Query Properties

Tab Property

General Label

Name

Script
defined as

Resource Property
Value

Description

The displayed name of the Query. You can rename the Query
here by entering a new name

The internal name. This defaults to the same value as the Label,
but with any internal spaces removed.

Whether the query is entered in free text or in Resource Query

Language (RQL). Defaults to Unspecified when a query is created.

Displays all the properties of the Query. You can edit the values
from this tab by clicking on the Value field.

Properties View for the Organization Schema

A number of Properties are available for the elements in an Organization Schema:
Organization Type, Organization Unit Type, Position Type, Location Type, Organization Unit
Relationship Type, Resource Type.

Organization Type Properties

Tab Property

General Label
Name

Resource Property
Value

Description

The displayed name of the Organization Type. You can rename
the Organization Type here by entering a new name.

The internal name. This defaults to the same value as the Label,
but with any internal spaces removed.

Displays the Label and Name of the Organization Type. You can
edit the values from this tab by clicking on the Value field.
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Organization Unit Type

Tab Property Description
General Label The displayed name of the Organization Unit Type. You can
rename the Organization Unit Type here by entering a new
name.
Name The internal name. This defaults to the same value as the Label,

but with any internal spaces removed.

Resource Property Displays the Label and Name of the Organization Unit Type. You
Value can edit the values from this tab by clicking on the Value field.

Position Type Properties

Tab Property Description

General Label The displayed name of the Position Type. You can rename the
Position Type here by entering a new name.

Name The internal name. This defaults to the same value as the Label,
but with any internal spaces removed.

Resource Property Displays the Label and Name of the Position Type. You can edit
Value the values from this tab by clicking on the Value field.

Location Type Properties

Tab Property Description

General Label The displayed name of the Location Type. You can rename the
Location Type here by entering a new name.
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Tab Property Description

Name The internal name. This defaults to the same value as the Label,
but with any internal spaces removed.

Resource Property Displays the Label and Name of the Location Type. You can edit
Value the values from this tab by clicking on the Value field.

Organization Unit Relationship Type Properties

Tab Property Description
General Label The displayed name of the Organization Unit Relationship Type.
You can rename the Organization Unit Relationship Type here by

entering a new name.

Name The internal name. This defaults to the same value as the Label,
but with any internal spaces removed.

Resource Property Displays the Label and Name of the Organization Unit

Value Relationship Type. You can edit the values from this tab by
clicking on the Value field.

Resource Type Properties

Tab Property Description

General Label The displayed name of the Resource Type. You can rename the
Resource Type here by entering a new name.

Name The internal name. This defaults to the same value as the Label,
but with any internal spaces removed.

Attributes Label The name of any attributes that you want to define for this
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Tab Property Description

Resource Type. See the "Attributes" topic in the TIBCO® BPM
Enterprise Concepts Guide for more information about attributes.

This tab lists all attributes that are associated with this
Resource Type and also all that are associated with its parent,
its parent’s parent, and any other Resource Types in the chain
of inheritance.

Click to add an attribute. You can delete an attribute by

selecting it and clicking .

Type One Resource Type in the schema must be defined as the
Human Resource Type, for compatibility purposes once the
Organization is exported. It cannot be deleted from the Schema.

This text is displayed on the General tab of the Human
Resource Type. The Type is therefore still identifiable as the
Human Resource Type even if you change its label and name.

| 2] Resource Type
.J ‘General * Label: Staff Resource Type

Attributes MName: StaffResourceType

__85"-_'_“_'_5_‘?_ This is the human resource type.

Resource Property Displays all the properties of the Resource. You can edit the
Value values from this tab by clicking the Value field.

Human Durable and Consumable Resource Types

One Resource Type must always be the Human Resource, whether or not you have used
the default Schema. If your Schema retains the default Schema, then in addition one
resource type must have the Durable Resource property, and one the Consumable
Resource property. If you select Resource Types in the Project Explorer, the General tab
in the Properties View displays a matrix showing which type has which property.

Resource Types

Jngg;al Label Name Human Resource Durable Resource Consumable Resource
ST %] Human Resource Type %% HumanResourceType |:| |:|
|| B Consumable Resource Type %% ConsumableResourceType 0 |

=] Durable Resource Type %7 DurableResourceType |:|
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The Resource Type with one of these properties does not have to have the corresponding
name. In this example some of the Types have been renamed:

Resource Types
._IGeneraI Label Name Hurnan Resource Durable Resource Cansumable Resource
Resource | Staff Resource Type %7 StaffResourceType |:| D
S | | 2% Consumable Resource Type %% ConsumableResourceType il ]
|| B Building % Building O 0
Con;truction Machinery E‘ ConstructionMachinery D D

You can change the assignment of these attributes by checking boxes in this matrix - for
example, you could check Durable Resource in the Construction machinery line. If you
do this, the corresponding box in the Building line would automatically be unchecked:

there must be one, and only one Resource Type with each attribute.
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Tips and Tricks

This section contains tips for working with the TIBCO Business Studio user interface.

Process Editor

There are a number of tips for using the Process Editor.

| can’t see the
palette.

| have a large
diagram that is
difficult to view.
How can | find a
specific task?

How can | create
several objects of
the same type using
the palette?

How do | align
objects in the
Process Editor?

I’m using Grid
alignment in the
Process Editor and |

Make sure you are in the Process Editor and that the palette is
expanded (click the arrow to the right, top of the scroll bar).

Press Ctrl+F and enter the name or a partial name in the resulting
dialog box. A list of search results is displayed. Clicking one of the
results displays it in the Process Editor.

Press the Ctrl key while adding the objects to your Process. For
example, if you want to create several Sequence Flows, press and hold
the Ctrl key while clicking the Flow tool and adding the Sequence
Flows.

There are two features that allow you to better align objects in the
Process Editor - Grid and Alignment Guides. These are both available
from the Diagram menu when using the Process Editor. Grid allows
you to snap objects to the grid lines, and Alignment Guides shows a
centering line when you have aligned two objects.

With several objects selected in the Process Editor you can also select
options from the Diagram > Alignment menu to control the vertical
and horizontal alignment of the objects.

Pressing the Alt key while moving an object allows you to position it
between grid lines.
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want to place an
object without using
the Grid.

| want to see a
larger view of my
Process.

How can | easily
resize an Activity in
the Process Editor?

| can’t get my
Sequence Flows to
look right.

How can | create
bendpoints when |
draw a Sequence
Flow?

| can’t get a
Sequence Flow to
dock where | want it
to dock.

How can | position
Sequence Flows
using the keyboard?

A task label is
truncated in the
Process Editor - how
can | show the
whole label?

You can expand the Process Editor to fill your screen by double-clicking
its title bar or pressing Ctrl+M. You can temporarily display the
Properties view by double-clicking any diagram element. The
Properties view is hidden again when you click on the diagram.

Pressing the Ctrl key while resizing one side of an object automatically
resizes the opposite side as well.

Occasionally when you reposition a Sequence Flow several times you
create too many bend points and make the flow illegible. To restore a
Sequence Flow, click the flow and select Reset Bendpoints.

Whilst holding down the left mouse button and positioning the
Sequence Flow, right-click to add a bend point.

Sequence Flows are docked at the nearest docking point rather than
where you attempt to dock them. Try repositioning the middle of the
Sequence Flow to change the docking point.

Highlight the Sequence Flow, then press the Period key (.) to move
along the bend points. With a bend point highlighted, use the arrow
keys to position them and change the shape of the flow. When you are
done, press the Return key.

Set the zoom level to width or height and all letters become visible in
the Process Editor.

Alternatively, you can add a period (.) to the end of the label.
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Business Object Model Editor

There are a number of tips relating to the Business Object Model Editor:

How can | quickly Make sure you are in the Business Object Modeler and that the Palette
create a connection is expanded (click the arrow to the right, top of the scroll bar). If you
between two click a Class, the following symbols are displayed on its border:
Classes?
——a
e

You can drag either of these to another Class. The following menu is
displayed from which you can choose the type of connection you want
to create:

/" Create Association

/? Create Generalization

How can | quickly Click the Class. The following symbol is displayed:
add Attributes to a
Class? =

e Clicking =1 adds an Attribute to the selected Class.

« Clicking[“] adds an Operation to the selected Class.

Workbench

There are a number of tips relating to the Eclipse Workbench:

How can | quickly  There are buttons in the upper right of the screen so you can change
change between perspectives. You can also do this using Ctrl+F8.
Perspectives?

My windows are a  Go to Window > Reset Perspective. This restores the current

mess. How can | Perspective to its default.
reset them?
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How can | switch
to a different
workspace?

After starting
TIBCO Business
Studio, | get the
following error
message:

Unable to
read
workbench
state.
workbench
UI layout
will be
reset

How can |
navigate to other
views while in full
screen mode?

Go to File > Switch Workspace and browse for the location of the
workspace. Note that after you select a workspace and click OK, TIBCO
Business Studio must restart before you can access the new workspace.

This error occurs because a Ul element (for example, editor, view, or
perspective) that was displayed at the close of the last TIBCO Business
Studio session is no longer available. This error usually indicates a
change in the installation environment (a product has been removed or
upgraded), and can safely be ignored.

When a view or editor is expanded to fill the window, Eclipse provides
several buttons around the border of the screen that allow you to display
other views in addition to the expanded view of the Process. For
example, the following buttons are displayed around the border of the

screen:
e [ @& 99
[ \‘\ Displays the
Restores the Displays the Displays the Diagram
default window Properties Problems Fragments
layout view view view

Problems View

There are a number of tips relating to the Problems view:

How can | correct
validation errors?

Either:

 Right-click the problem and select Quick Fix (if enabled for
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the current problem). This gives you the option of having
TIBCO Business Studio automatically correct the problem
for you.

_or-

 If no quick fix is available, Double-click the problem or
right-click the problem and select Go To. This displays the
Process in the Process Editor, highlighting the offending
object and allowing you to manually correct the problem.

In the Problems view | From the menu in the upper right of the Problems view, select
see not only problems for  Configure Contents. This allows you to customize the problems
my Process/Project, but display. For example, you can select options to display problems
problems for all for the selected resource only, or for any resource in the same
Processes/Projects. Project.
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TIBCO Documentation and Support Services

For information about this product, you can read the documentation, contact TIBCO
Support, and join TIBCO Community.

How to Access TIBCO Documentation

Documentation for TIBCO products is available on the Product Documentation website,
mainly in HTML and PDF formats.

The Product Documentation website is updated frequently and is more current than any
other documentation included with the product.

Product-Specific Documentation

The documentation for this product is available on the TIBCO Business Studio™ - BPM
Edition Product Documentation page.

How to Contact Support for TIBCO Products

You can contact the Support team in the following ways:

e To access the Support Knowledge Base and getting personalized content about
products you are interested in, visit our product Support website.

e To create a Support case, you must have a valid maintenance or support contract
with a Cloud Software Group entity. You also need a username and password to log
in to the product Support website. If you do not have a username, you can request
one by clicking Register on the website.

How to Join TIBCO Community

TIBCO Community is the official channel for TIBCO customers, partners, and employee
subject matter experts to share and access their collective experience. TIBCO Community
offers access to Q&A forums, product wikis, and best practices. It also offers access to
extensions, adapters, solution accelerators, and tools that extend and enable customers to
gain full value from TIBCO products. In addition, users can submit and vote on feature
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requests from within the TIBCO Ideas Portal. For a free registration, go to
TIBCO Community.
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Legal and Third-Party Notices

SOME CLOUD SOFTWARE GROUP, INC. (“CLOUD SG”) SOFTWARE AND CLOUD SERVICES EMBED,
BUNDLE, OR OTHERWISE INCLUDE OTHER SOFTWARE, INCLUDING OTHER CLOUD SG SOFTWARE
(COLLECTIVELY, “INCLUDED SOFTWARE”). USE OF INCLUDED SOFTWARE IS SOLELY TO ENABLE THE
FUNCTIONALITY (OR PROVIDE LIMITED ADD-ON FUNCTIONALITY) OF THE LICENSED CLOUD SG
SOFTWARE AND/OR CLOUD SERVICES. THE INCLUDED SOFTWARE IS NOT LICENSED TO BE USED OR
ACCESSED BY ANY OTHER CLOUD SG SOFTWARE AND/OR CLOUD SERVICES OR FOR ANY OTHER
PURPOSE.

USE OF CLOUD SG SOFTWARE AND CLOUD SERVICES IS SUBJECT TO THE TERMS AND CONDITIONS
OF AN AGREEMENT FOUND IN EITHER A SEPARATELY EXECUTED AGREEMENT, OR, IF THERE IS NO
SUCH SEPARATE AGREEMENT, THE CLICKWRAP END USER AGREEMENT WHICH IS DISPLAYED WHEN
ACCESSING, DOWNLOADING, OR INSTALLING THE SOFTWARE OR CLOUD SERVICES (AND WHICH IS
DUPLICATED IN THE LICENSE FILE) OR IF THERE IS NO SUCH LICENSE AGREEMENT OR CLICKWRAP
END USER AGREEMENT, THE LICENSE(S) LOCATED IN THE “LICENSE” FILE(S) OF THE SOFTWARE. USE
OF THIS DOCUMENT IS SUBJECT TO THOSE SAME TERMS AND CONDITIONS, AND YOUR USE HEREOF
SHALL CONSTITUTE ACCEPTANCE OF AND AN AGREEMENT TO BE BOUND BY THE SAME.

This document is subject to U.S. and international copyright laws and treaties. No part of this
document may be reproduced in any form without the written authorization of Cloud Software
Group, Inc.

TIBCO, the TIBCO logo, the TIBCO O logo, Business Studio, and TIBCO Business Studio are either
registered trademarks or trademarks of Cloud Software Group, Inc. in the United States and/or other
countries.

All other product and company names and marks mentioned in this document are the property of
their respective owners and are mentioned for identification purposes only. You acknowledge that all
rights to these third party marks are the exclusive property of their respective owners. Please refer to
Cloud SG’s Third Party Trademark Notices (https://www.cloud.com/legal) for more information.

This document includes fonts that are licensed under the SIL Open Font License, Version 1.1, which is
available at: https://scripts.sil.org/OFL

Copyright (c) Paul D. Hunt, with Reserved Font Name Source Sans Pro and Source Code Pro.

Cloud SG software may be available on multiple operating systems. However, not all operating
system platforms for a specific software version are released at the same time. See the “readme” file
for the availability of a specific version of Cloud SG software on a specific operating system platform.
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THIS DOCUMENT IS PROVIDED “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR
IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

THIS DOCUMENT COULD INCLUDE TECHNICAL INACCURACIES OR TYPOGRAPHICAL ERRORS. CHANGES
ARE PERIODICALLY ADDED TO THE INFORMATION HEREIN; THESE CHANGES WILL BE INCORPORATED
IN NEW EDITIONS OF THIS DOCUMENT. CLOUD SG MAY MAKE IMPROVEMENTS AND/OR CHANGES IN
THE PRODUCT(S), THE PROGRAM(S), AND/OR THE SERVICES DESCRIBED IN THIS DOCUMENT AT ANY
TIME WITHOUT NOTICE.

THE CONTENTS OF THIS DOCUMENT MAY BE MODIFIED AND/OR QUALIFIED, DIRECTLY OR
INDIRECTLY, BY OTHER DOCUMENTATION WHICH ACCOMPANIES THIS SOFTWARE, INCLUDING BUT
NOT LIMITED TO ANY RELEASE NOTES AND "README" FILES.

This and other products of Cloud SG may be covered by registered patents. For details, please refer
to the Virtual Patent Marking document located at https://www.cloud.com/legal.

Copyright © 2015-2024. Cloud Software Group, Inc. All Rights Reserved.
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