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About the Getting Started Guide

This guide contains tutorials that are designed to familiarize you with a representational
set of activities you might use to develop an application. By referring to these simple
tutorials, you can understand how to use TIBCO BusinessWorks™ Container Edition within
each phase of the project life cycle.

These tutorials illustrate the basic activities for creating an application, building and testing
a simple REST service, and basic information on deploying the Administration sample
applications using the provided scripts.

For more information, see one of the following topics:

e REST Service Tutorial: Walks you through the steps to build and test a simple REST
Service using TIBCO BusinessWorks Container Edition and the Swagger Ul.

o REST Reference Tutorial: Shows you how to create a simple REST Invoke to an
existing REST Service defined by a Swagger specification.

The Orientation section introduces you to the TIBCO Business Studio for BusinessWorks
development environment. Before you continue, read the TIBCO BusinessWorks Container
Edition Concepts guide to familiarize yourself with the TIBCO BusinessWorks Container
Edition concepts and terminology.

TIBCO BusinessWorks™ Container Edition Getting Started
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Orientation

TIBCO BusinessWorks Container Edition is an integration product suite for enterprise, web,
and mobile applications.

TIBCO Business Studio for BusinessWorks allows you to create services and integrate
applications using a visual, model-driven development environment, and then deploy them
in the TIBCO BusinessWorks Container Edition runtime environment.

Design

Manage Build

Deploy Test

This product uses Eclipse-based graphical user interface (GUI) provided by TIBCO Business
Studio for BusinessWorks to define business processes and generate deployable artifacts in
the form of archive files. These deployable artifacts can be:

e deployed and run in the product runtime, and

e managed using the administration command line console or bwadmin, or the web-
based Admin Ul.

For information about developing applications and TIBCO Business Studio for
BusinessWorks, see the following guides in the documentation set:

e Application Development
» Palette References

e Samples

TIBCO BusinessWorks™ Container Edition Getting Started
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TIBCO Business Studio™ for BusinessWorks™

TIBCO Business Studio for BusinessWorks is the design-time IDE (based on Eclipse) where
you create and test your processes.

You use TIBCO Business Studio for BusinessWorks for end-to-end application development.
You can create new services, orchestrate business process, and integrate applications in a
short time. A model-driven development approach is supported, with a rich set of palettes
for process design. These palettes can be used to visually create and test business
processes that connect to various technologies such as a database, messaging servers, and
so on.

TIBCO Business Studio for BusinessWorks is installed as part of TIBCO BusinessWorks
Container Edition.

To open TIBCO Business Studio for BusinessWorks:

e On Unix: Run the TIBCO Business Studio for BusinessWorks executable located in the
$TIBCO_HOME/studio/<version>/eclipse/ directory.

e On Windows: Click Start > All Programs > TIBCO > TIBCO_HOME > TIBCO Business
Studio <version_number> > Studio for Designers

On the Workspace Launcher dialog, accept the default workspace or browse to create a
new workspace, and click OK.

When TIBCO Business Studio for BusinessWorks starts, the default development
environment, a workbench, is displayed.

For more information, see the Application Development guide.

Application Development

Applications solve integration problems of varying complexity. Using TIBCO Business Studio
for BusinessWorks, applications can be developed using an application-oriented integration
style or a service-oriented integration style. How you design your application's integration
style depends on the following factors:

e Speed of integration
e Data abstraction

» Richness of operation primitives

TIBCO BusinessWorks™ Container Edition Getting Started
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e Typical endpoints

For more information about an application's integration style and other application design
considerations, see "Application Design Considerations" in the TIBCO BusinessWorks
Container Edition Application Development guide.

Processes allow you to implement business logic that can obtain and manage the flow of
information in an enterprise between a source and different destinations. In process-driven
design, the business processes or integration flows are first realized and captured. For
more information about process design, see "Process Design Considerations" in the TIBCO
BusinessWorks Container Edition Application Development guide.

Processes developed in TIBCO Business Studio for BusinessWorks are saved in an
application module. Application modules are equivalent to projects and are saved to
folders on the disk. The TIBCO Business Studio for BusinessWorks workspace contains one
or more application modules.

» An application module contains one or more packages

» A package contains one or more processes, which in turn are main processes or
subprocesses

» A process is stored as a single file with a . bwp extension

An application module contains a special folder called Processes. This folder contains the
user created processes. In addition, an application module also contains folders to store
WSDL files, schemas, and shared resources. The Processes folder is shown below.

+ © com.tibco.bw.samplesbooks —-)I Application Module

4 g Processes
+ # com.tibcobw.samplesbooks ——)| BW Package |
& Books.bwp

@ EVENiShVW]  e—

4 @ com.tibco.bw.samples.books.db
@ BooksDB.bwp
& EventsDB.bwp

o Note: A package should follow the Java naming convention.

Processes are designed in the Process Editor. Activities and shared resources help you
rapidly design business processes. An activity is the individual unit of work in a process.
There are multiple ways to add an activity to a process: from the right-click menu on the
Process Editor, from the palettes, and from the File Explorer or Project Explorer. To add
an activity from the palette, select it and drop it on the Process Editor.
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8 | Orientation

Implemented services are shown as chevrons on the left side of the Process Editor.
References that are invoked are shown on the right side of the Process Editor. For a
simple process, services and references are optional.

Web Services

Web services are application components that communicate using open standard
protocols. You can develop SOAP-based web services using the Generate Concrete WSDL
Wizard. The wizard generates a WSDL file and the appropriate response activities. You can
develop REST-based web services using the REST Service Wizard in TIBCO BusinessWorks
Container Edition.

Select a WSDL file in the Project Explorer and drop it on the Process Editor to implement
a web service. Dropping the WSDL file displays a menu for creating services or
implementing operations. Response activities are automatically generated.

To create a REST service, select a path under the .json file in the Service Descriptors
folder and drop it on the Process Editor to implement a web service. When you drop the
path, it displays a menu with an option to create a service or a reference.

Shared Resources

Shared resources are configurations that are shared among activities. These are resources
such as database, JMS and HTTP connections, and connections to other servers. Resources
are added to special folders in the Project Explorer. The following image shows these
folder in the Project Explorer.

TIBCO BusinessWorks™ Container Edition Getting Started
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Shared Resources Folders in Project Explorer

[ty Project Explorer 2 BE%|&4# =0

4 [ tibco.bwee.sample.binding.rest.BookStore
. <z Processes
4 [ Service Descriptors
> 2 Books.wsdl
» 22 BooksDBService.wsdl
> A Eventsawsdl
> & EventsDBService.wsdl
» & ModuleActivator.wsdl
4 {2 Resources
» # tibco.bwcesample.binding.rest.BookStare
4 g Schemas
> [S Books.xsd
> [8] BooksSchema.xsd
> [8] Eventsxsd
> [8] EventsSchema.xsd
> [s] RESTSchema.xsd
> & Module Descriptors
b build.properties
. @ tibco.bwce.sample.binding.rest.BookStore.application

The following types of folders for shared resources can exist in a project.
» Resources: Contains shared resources used by activities in a process.
¢ Schemas: Stores XSD (schema) files.

e Service Descriptors: Stores WSDL and JSON files.

Cheat Sheet

A quick reference help is available in the form of cheat sheets for few common tasks in
TIBCO Business Studio for BusinessWorks.

Open a cheat sheet using any one of the following ways:

e On the Welcome page, click the Quick Start link. If you open TIBCO Business Studio
for BusinessWorks in a new workspace, the Welcome screen is displayed. If you open
TIBCO BusinessWorks™ Container Edition in an existing workspace, open the
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Welcome page by using Help > Welcome.

& Welcome =

&3
First Steps : Workbench
Samples
TIBCO Business Studio for
BusinessWorks({TM)
Click a sampla belaw to imgort the projectinto your
‘workspace. See the Reference page for Information about ol'd p s
the sample and instructions an how ta run it S EIOCC SHny
Demonstrates a simple order
: = : processing service with File and XML
@ REST Bookstore - Basic Sdaaa:
) Demonstrates how to use REST APT
methads to add and retrieve book
data that is stored m a file.
Call Process
2 Demonstrates how ta invoke one
@ REST Bookstore - Database BW process from another.
Q‘L Demonstrates how to use REST APT
mithods to add, retrieve, update, -
and delete book data that is stored % Fault Handling
in 3 database. Demonstrates how to catch faults

using scopes and fault handlers.

@ REST Authorization Policy
Demonstrates how to use an
authonzabion policy with a REST
service. More Samples...

== Invoke Java

b Installing New Plugins...

Demonstrates how to call custom
Java code from a BW process,

% Quick Start Enab!tle Guided User
Experience...
Go through Quick Start guide per
(Cheatsheets) to leamn to use TIBCO
Business Studio for Businessworks
quickdy.

e Click Help > Cheat Sheets.

Cheat sheets are available for the following tasks:
e Adding unit testing to a project.
e Creating a basic SOAP application.
» Creating an application using Java Invoke.
e Configuring a JMS connection and creating a JMS send message application.
e Configuring a JBDC connection using custom driver.
e Developing a REST API to expose a SOAP service.
e Exposing a SOAP service via REST API.

e Using security policies in a project.
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REST Support

The REST Service wizard is used to build RESTful services.

Note: When you create a REST service, make sure to edit the Default Host field
in the HTTP Connection Resource to reflect the actual host name. By default, the
Default Host field is set to localhost.

REST Service Wizard

Create a new REST Resource [—-“’P

Configure the REST Service implementation.

Resource Name: Resource

Summary: Summary about the new REST service.

Resource Service Patlt  /resource

Type of Resource: @) Collection ) Single
Resource Definition:
Operations: POST [[|GET [|PUT [C] DELETE

Developing a RESTful service is a simple three-step process:

1. Name the REST resource.
2. Choose the resource definition (the XSD schema).
3. Choose the REST operations to implement.

The input and output messages for the operations are automatically generated along with
a Response activity. An HTTP shared resource is also generated with the default
configuration. You can then add activities and implement the business logic for each
operation in the process.

TIBCO BusinessWorks™ Container Edition Getting Started
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REST Documenter and Tester

A REST documenter and tester is automatically generated for a REST resource. Refer to
0SGi commands to List REST URLs in the REST Implementation guide. The documentation
is based on the Swagger specification and is rendered using the Swagger Ul.

Swagger Ul

4 swagger http://bookstoreapp test. com:80/swagger/swagger json _ Explore

tibco.bwce.sample.binding.rest.BookStore.application

Books ShowfHide | List Operations = Expand Operations

1book/{ISBN}

=l /book/{ISBN}

TN vookise

(2 /book/{ISBN}/events
2@l /books

Gl /books

Events

This Swagger based interface provides a convenient and quick way to:
e View REST endpoints and operations implemented by the REST resource service.
e Examine the inputs and outputs for each operation in JSON format.
e Enable Input fields to specify JSON or XML input for each operation.

» Invoke an operation and receive a live response for the input supplied.

Discovering APl Models from TIBCO Business Studio
for BusinessWorks

To view the APIs that reside on your local machine or on a remote server, use the API
Explorer view in the TIBCO Business Studio for BusinessWorks.

Before you begin
For the API Explorer to, discover the APIs residing on a remote server, the remote server
must be up and running.

TIBCO BusinessWorks™ Container Edition Getting Started
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You can set up the locations to which you want the API Explorer to connect and look for
the APIs. To do so, follow the steps below.

Procedure

1. In TIBCO Business Studio for BusinessWorks, go to the API Explorer view.

2.

In the API Explorer tab, click the View Menu downward-facing triangle icon (=!) and
select Settings.

The Settings dialog is displayed.

The registries for the TIBCO BusinessWorks™ Container Edition - APl Modeler and the
samples folder installed on your local machine are configured and appear in the API
registry configurations box by default. In this dialog, you can specify how the
discovered APIs appear in the API Explorer:

* API Presentation - specifies how the APIs appear in the API Explorer

Flat - displays the APIs as a flat list with each API's version number displayed
next to its name in parenthesis. If there are multiple versions of the same API,
each version is shown as a separate API, hence multiple APIs with the same
name but different version numbers.

Hierarchical - displays every API as a hierarchy of APl name label with version
number folder under it and the actual APl under the version folder. If there are
multiple versions for an API, each version is listed in its own separate folder
under the APl name label.

Latest Version - displays only the latest version of the API, even though there
are multiple versions available.

Group by API registry - groups the APIs according to the registry from which
they were discovered

API registry configurations - displays the list of API registries that are
currently configured in your TIBCO Business Studio for BusinessWorks
installation.

Select the API registry checkboxes to display the APIs.

You can edit an existing registry by clicking the Edit button, delete the registry
configuration by clicking Remove, or changing the order in which the registries show
up in the API Explorer by using the Up and Down button. These button get activated
when you click on an API registry name.

3. Click New to add a new registry.

TIBCO BusinessWorks™ Container Edition Getting Started
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4. In the Create new API Registry client configuration dialog do the following:

a. Enter a name for the API registry that you are mapping to in the Name text
box.

b. Select the Local radio button to map a location where the APIs are stored on
your local machine's hard drive and navigate to the location using the Browse
button. Alternatively, select the Remote radio button if you want to map to a
remote server that contains the APIs and enter the URL for the server in the
URL text box.

5. Click Finish.

You should now see the APIs displayed in the API Explorer in the format that you
specified in the Settings dialog. Expanding an APl show you its version, the resource
path, and the operations to perform on that resource.

Note: Organizations can have multiple owners, and a list of owners is
displayed in the Edit API Registry client configuration page.

The API Explorer view has the following quick-access buttons that you can use to
format the way the APIs are listed:

@ Refresh
Expand All

Collapse All

° ||_1|

Group by API Registry

API Presentation

API Registries. Selecting a registry from this dropdown list toggles
between displaying and hiding the registry in the APl Explorer.

Use the search filter that appears at the bottom of the API Explorer view to search
for APl names that match the string that you enter in the Filter text box. You can
search by typing in the version number, the full APl name, or a full word within an
APl name. Wildcards are not supported. The search is case insensitive.

TIBCO BusinessWorks™ Container Edition Getting Started
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Importing an APl Model into your Workspace

The APIs that are discovered from local and remote servers are displayed in the API
Explorer tab of the TIBCO BusinessWorks Container Edition. You can use these APIs in your
project by importing them into the Service Descriptors folder of the project. The .json file

for the API gets copied into the application module.
To import the APIs from the API Explorer into your project follow these steps.

Procedure
1. Right-click on one or more APl names in the APl Explorer and select Import.

The Import API dialog opens.

2 O 5
Import API
Create a new project and import API to the new project.

(®) Create a new project and import API to the new project.

QO Import to project: Browse...
API list to import:
API Select All
TIBCO Cloud Integration PetStore Sample (1.1) Deselect All
@ < Back | Next > | Finish Cancel

Every APl you selected in the API Explorer is listed in this dialog. If an API has
multiple versions, all versions are listed. By default, all APIs listed here are selected.

You can deselect APIs that you do not want to import by clearing its checkbox.

2. Select the appropriate action and click Next.

Option Description

Select the radio button to import the API into an existing

Import to project
project and browse to the project using the Browse

TIBCO BusinessWorks™ Container Edition Getting Started
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Option Description
button.

Create a new project and To create a new project and import the APl into that

import API to the new project select the radio button.
project
API list to import Select the API or the appropriate version of the APl when

there are multiple versions of the API available.

The Change Swagger name dialog opens.

2 O X

Change Swagger name

Change swagger file names and import to project

Original File Name New File Name

TIBCO Cloud Integration PetStore Sample_1.1.json | TIBCO Cloud Integration PetStore Sample_1.1

@ < Back | Next > | Finish Cancel

Change the swagger file name if required. Click Next.
The New BusinessWorks Application Module dialog opens.

3. Create a new application module with appropriate details and click Finish.

You should see the API(s) under the Service Descriptors folder of the project. You
can create sub-folders under the Service Descriptors folder and drag-and-drop APIs
into them if you prefer to organize the APIs into a meaningful folder structure.

As an alternative to the above procedure, you can also drag and drop the API from
the API Explorer into the project's Service Descriptors folder.

TIBCO BusinessWorks™ Container Edition Getting Started
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o Note: APIs that were created using a Swagger file must be implemented
exactly as defined by the Swagger file. TIBCO BusinessWorks Container
Edition allows you to only view the parameters and operations that are
defined in the Swagger file. You cannot create any new parameters or
operations for such applications.

Creating an XML Schema for a Swagger File

TIBCO Business Studio for BusinessWorks supports the creation of an XML schema for an

imported Swagger 2.0 or a Swagger 3.0 file.
You can create an XML schema for a Swagger 2.0 or a Swagger 3.0 files in one of two ways

described below.

Before you begin

A Swagger 2.0 or a Swagger 3.0 file must exist in the Service Descriptors folder of the
project. Ensure to import the Swagger file into the Service Descriptors folder before you
follow these steps:

Procedure
1. Drop the Swagger file on the right side of the canvas to create a REST service
binding. This action generates an XML schema for the Swagger file under the
Schemas folder. The XML schema file has the same name as the Swagger file.

Or

2. Right-click the Swagger file in the Service Descriptors folder and select Refactor >
Generate XSD Schema.

e To see which XML schema is related to the Swagger file, right-click the Swagger
file and select Refactor > Open XSD Schema.

* If you have multiple Swagger files all of which contain a definition for the same
object, the definition for the object in all the Swagger files must be identical.

 If you have multiple Swagger files with one file (a master file) containing a
super set of definitions contained in the other files, generate an XSD file from
the master Swagger file that contains the super set, and create links to the
other files in the master Swagger file. If you create a link to the super set file in
one of the subset files and then create an XSD from the subset file, then the
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XSD contains only those elements that are common to both files. It does not
contain elements for definitions that exist only in the super set file.

Consuming a REST Endpoint in TIBCO Business
Studio for BusinessWorks

Create a REST Reference binding to consume a REST endpoint.

Note: You cannot edit the REST reference binding configuration for APIs that are
imported from a source external to TIBCO Business Studio for BusinessWorks.

Before you begin

Swagger APl documents must be imported into the project's Service Descriptors folder.
This gives you the ability to expand and collapse endpoints, operations, parameters, and
response codes in the Project Explorer.

To consume a REST API that exists in the Service Descriptors of the project, do the
following:

Procedure

1. Expand the Swagger file in the Service Descriptors special folder to view the
endpoints, operations, parameters, and response codes.

2. Drag an endpoint on the right side of the canvas to create a REST reference binding.

This creates a cloud shaped icon with a right facing arrow. The cloud is an indication
that it is a REST reference whereas the arrow within the cloud indicates that it is a
binding. Since the binding is within a cloud, it is an indication that it is a REST
binding. You cannot convert a REST binding to a SOAP binding or the opposite way.

Note: When you create a REST reference for the service, make sure to edit
the Default Host field in the HTTP Client Resource to reflect the actual
host name. By default, the Default Host field is set to localhost.

3. Drag and drop an operation from the REST reference binding on to the canvas.

This creates an Invoke activity, which is pre-configured to invoke the operation. It

TIBCO BusinessWorks™ Container Edition Getting Started
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also creates an HTTP Client Shared Resource with the host name and port number.
The configuration for these entities is copied from the Swagger document from which
you created the reference binding. The reference consists of the name of the API as
well as the operations that it supports.

When invoking a POST or PUT method, you must provide the request string in the
Input tab. To do so, click the column next to item under postRequest in XPath
Expression and provide the request string in the dropdown box.

4. Test the configured process using the TIBCO Business Studio for BusinessWorks
debugger.

Synchronizing the Imported REST APl Models in
TIBCO Business Studio for BusinessWorks

If a REST service developer has made changes to the service API after creating the service,
the changes needs to be propagated to all the places where the service is used. You can
check for updates to a Swagger file that has been imported into TIBCO Business Studio for
BusinessWorks. The icon to the left of the Swagger file in the Project Explorer in the
TIBCO Business Studio for BusinessWorks displays an indication that the file has been
modified in its original location and the local copy of the file is not in synchronization with
it source.

You can check for differences between the original Swagger file and its copy that was
created when importing it into the TIBCO Business Studio for BusinessWorks. You can also
compare the differences between the two and update your local copy if need be. To do so,
follow these steps:

Procedure
1. Right-click the Swagger file under Service Descriptors in the Project Explorer.

2. Select Remote Interface.

The Check for Differences menu option checks for differences between the imported
copy and its original.

The Compare Differences menu option first checks for differences between the
imported copy of the Swagger file and its original. If there is a difference, the file
appears in the Synchronize tab and if you double-click it there it displays the two
files side by side with the differences highlighted.
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The Update Local Copy menu item updates the copy of the file in your workspace to
match its original. It also regenerates the schema.

Note: No changes are performed for processes that have already been
created.

Archive Files

After completing an application module, you must define an application to build a
deployment archive file. An application defines all the processes, properties, and resources
that must be included in the archive file. By default, all processes are included.

To create an archive, choose one of the following:

* Right-click the project in the Project Explorer and choose Export > Studio Projects
to Archive. The Export Project dialog is displayed.

Export Project Dialog

TIBCO BusinessWorks™ Container Edition Getting Started
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- _;
dExport Project LE X
-
“ Archive File

Export resources to an archive file on the local file system.

@‘ tibco.bw.sample.binding.rest.B{:-c:-kStore|
ﬁ tibco.bw.sample.binding.rest. BookStore.application

lSeIect All l lDeseIect All l ‘ Select Referenced Projects‘ ‘ Select Referencing Projects

To Archive File: c\tmp\tibco.bw.sample.binding.rest.BookStare.zip E]
Options
(@ Save in zip format (U Save in tar format

[¥] Compress the contents of the file

@ l

gnish || cancel |

» Drag the project from the Project Explorer and drop it on a folder in the File
Explorer.

Drag and Drop Project to File explorer

TIBCO BusinessWorks™ Container Edition Getting Started
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5 Project Explorer 2 E Rl "0

¥ tibco.bw.sample.binding soap.http.BookStore.application

Drag the application from
the Project Explorer

| File Explorer % - @ Module| £ Outline] & n JLI®~ =0
= C\BW_6.2.0\bw\6.2\samples -
& binding
= rest
= Basic
books.json
readme.link =

1. tibco.bw.sample.binding.restBasiczip Drop itinthe file
explorer to create

T Boolctore the archive file
= spap
tibco.bw.sample.binding.soap.http.BookStore.application_1.0.0.ear | ¥|
& bw5
& core =

In both scenarios, the archive file is created with all required processes, properties, and
resources. In the first scenario, you can name the archive file, select the format, and select
the resources to include. In the second scenario, the archive is created for you in the
format appropriate for your operating environment. All required elements are included.

Debugger

TIBCO Business Studio™ for BusinessWorks™ debugger is used to test processes during the
process development stage. Starting the debugger brings up the Debug perspective. This
perspective can be used to set breakpoints, steps through processes, examine job
variables, and activity input/output at each step.
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Debug Perspective

%5 Debug 2 G BusinessWorksJobs} 4 Sewers} %% [ CEal
4 4= BWApplication [BusinessWorks Application]
42| <launched > BWEclipseDomain_BWEclipseAppSpace_BWEclipseAppNode_Main @localhost:9090
i C\BW_6.2.0\tibcojre64\1.7.0\bin\javaw.exe (Sep 11, 2014 8:26:07 AM)

The Console view displays the messages and errors returned by the runtime.

Console View

G Console 22 &) Tasks | Properties i Base64 String Decoder  Process Launcher - S8 ~0-rir= 0

BWA pplicati k i 1] (Usersjdutta/BWCE V32 itibcojrefdf 1.7.0/bindjava (Sep 30, 2015, 2:21:11 PM)
| cem.tibeo.thor, frwk - TIBOD BusinessWorks Comtainer Edition version 1.8.8, build XX, 2015-99-28

f1:18.891 INFD [moin] com.tibeo.thor frmk.Depleyer - Storted by BusinessStudio.

:rg.springfranemark beans. TypeConver terelegate FindDefaultEditar

‘cam.sun.beans .editers ErunEditer] found through deprecoted glebel PrapertyEditorManoger Follback - consider using o more issloted form of registratioa, e.g. on the BeamNrapper/Bed
»rg.springfranessrk.beons. TypeConwer terelegate findDefoultEditor

“tam.sun.beans_editers . EnunEditer] found through deprecated glebol PropertyEditorManoger fallback - consider using o mere isslated form of registration, e.g. on the Beanlropper/Bed
ary.sprinul vk Beans, TypeCuneer berDelvgube TindDefuul

“com, sun.beans . editors, EnumEditor] found through depro
srg. springfromemork beans, TypeConver terOelegate findDefa
“com, sun. beans . edi tors, EnunEditor] found through deprec
srg.sprinaframeserk, beons, TypeConver terfelegate FindDe
“com, sun. beans . editors, EnurEditor] found through deprocoted globol PropertyEditorMansger follback - consider using o more isoloted form of registrotion, ©.g. on the EeonNrappersEm
| com.tibce.bw. frwk, engine. BWEnging - TIBCO-AW-FRNK-32Q082: &N Engine [Moin] storted successfully.

wark Event Dispotcher; Eguinax {ontainer; TR03752c-bO67-@015-143d-bfe5cdli5ddan] com, tibco, ther, frak, Depleyer - TIBCO-THOR-FAWK-39@481; Started 05G1 Framemsork of AppMode [BMEclips:
wark Event Dispotcher; Equinax Containgr; 7@03752c-b367-0015-143d-bfoScdds0dan] com, tibco, ther. frak. Application - TIBCO-THOR-FRWK-392018: Doploying BW Application [tibco, bwce.sam
18-7] com. tibco.thor. Frwk. Application - TIBCO-THOR-FRWK-300810: BW Agolication [tibeo.bwee.semple.binding. rest.BeokStore.opplicotion:1.0] 1s impaired.

wwaork Event Dispotcher: Eguinox Contalner: T@0375Zc-b2G7-@015-143d-bfeScaasddae]l com.tibco,thor.frak.Application - Started by BusinessStudie. [anoring .enabled settings.

Sxecutord] com.tiboo. thor, frwk.dpplication - TIBCO-THOR-FRNK-38@021: ALl Application dependercies are reselved for Applicotion [tibco.bmce.sample.binding.rest.BookStore.application
=211 con. kiboo.ther. frak.Applicetion - TIBCO-THOR-FRWK-308@06: Started BN Application [tibo.bwee sevple.binding. rest.BookStore.spplicotien:1.0]

PropertyEditorManager fallback - consider using o more iscloted form of registrotion, @.g. on the BeonWrappers/Es:

PropertyEditarManoger follback - consider using a more isoloted form of registrotion, ©.g. on the BeanNrapper/Se:

Start the debugger with the Run > Debug command. To stop the debugger, press the Stop
icon on the Debug perspective toolbar:
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Stop Icon in Debug Perspective

% Debug 32 & BusinessWorksJobs} ) Sewers} % ()&3 | S| | e|[ET "0
4 4= BWApplication [BusinessWorks Application] -
42| <launched > BWEclipseDomain_BWEclipseAppSpace_BWEclipseAppNode_Main @localhost:9090
s C\BW_6.2.0\tibcojre64\1.7.0\bin\javaw.exe (Sep 11, 2014 8:26:07 AM)

Runtime

You can run applications in TIBCO Business Studio for BusinessWorks and test them in a
runtime environment, which consists of a domain, an AppSpace, and an AppNode on your
local machine. These runtime entities were created when you installed TIBCO
BusinessWorks Container Edition. For more information about runtime entities, see the
TIBCO BusinessWorks Container Edition Concepts guide.

To run an application in TIBCO Business Studio for BusinessWorks, choose the Run > Run
command. (Applications can also be run with the Run > Run Configurations command.
This option enables you to manage and open the run configurations.) The Run command
opens the Console view where progress messages and errors are displayed.

Console View

= Console &2 ’ZTaskﬂ =] Propertieﬂ ' Process Launcher]  IE EEEEE R
BWApplication [BusinessWorks Application] C\BW_6.2.0\tibcojre64',1.7.0\bin\javaw.exe (Sep 11, 2014 8:26:07 AM)

b8:26:14.555 INFO [Start Level Event Dispatcher] com.tibco.thor.frwk - TIBCO ActiveMatrix BusinessWorks version 6.+
©8:26:19.158 INFO [Start Level Event Dispatcher] com.tibco.thor.frwk.Deployer - Started by BusinessStudio.

<>@BWEclipseAppNode> ©8:26:25.393 INFO [Component Resolve Thread (Bundle 293)] com.tibco.bw.frwk.engine.BWEngine -
088:26:25.631 INFO [Framework Event Dispatcher] com.tibco.thor.frwk.Deployer - TIBCO-THOR-FRWK-300801: Started 0SGi
©8:26:25.802 INFO [Framework Event Dispatcher] com.tibco.thor.frwk.Application - TIBCO-THOR-FRWK-300018: Deploying
©8:26:25.929 INFO [Framework Event Dispatcher] com.tibco.thor.frwk.Application - TIBCO-THOR-FRWK-300019: BW Applic:
98:26:29.044 INFO [Job_Executorl] com.tibco.thor.fruk.Application - TIBCO-THOR-FRWK-300021: All Application depend:
098:26:41.618 INFO [Job_Executorl] com.tibco.thor.frwk.Application - TIBCO-THOR-FRWK-30@006: Started BW Application

< | [ 3

Click the Businessworks Jobs view in the top left to see the jobs created for the process.
To stop the current job, click the Stop button [ on the Console view toolbar.
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From the Console view, you can use OSGi commands to monitor the running AppNode
and gather metrics about your application. For information about OSGi commands, press
Enter in the Console view to display the <>@BWEc1lipseAppNode> prompt. Type help to
get a list of commands.

The scope is indicated along with the command. Commands with the scope bw return
information about the running application. Type a command name followed by -h for
information about the command. For example, the command help bw:dsr returns:

dsr - Diagnoses Shared Resource -dissues
scope: bw
parameters:
String Partial or full name of a Shared Resource. Case is
ignored.

Changing Help Preferences

By default, documentation access from TIBCO Business Studio™ for BusinessWorks™ is
online, through the TIBCO Product Documentation website that contains the latest version
of the documentation. Check the website frequently for updates. To access the product
documentation offline, download the documentation to a local directory or an internal web
server and then change the help preferences in TIBCO Business Studio for BusinessWorks.

Before you begin
Before changing the help preferences to access documentation locally or from an internal
web server, download the documentation.

1. Go to https://docs.tibco.com/
2. In the Search field, enter TIBCO ActiveMatrix BusinessWorks™ and press Enter.

3. Select the TIBCO ActiveMatrix BusinessWorks™ product from the list. This opens the
product documentation page for the latest version.

4. Click Download All.

5. A compressed .zip file containing the latest documentation is downloaded to your
web browser's default download location.

6. Copy the .zip file to a local directory or to an internal web server and unzip the file.

To point to a custom location:

TIBCO BusinessWorks™ Container Edition Getting Started


https://docs.tibco.com/
https://docs.tibco.com/

26 | Orientation

Procedure
1. Perform one of the following steps in TIBCO Business Studio for BusinessWorks based
on your operating system:

e On Windows OS: Click Window > Preferences
e On macOS: Click TIBCO Business Studio > Preferences.
2. In the Preferences dialog, click BusinessWorks > Help.

3. Click Custom Location, and then browse to the html directory in the folder where
you extracted the documentation or provide the URL to the html directory on your
internal web server.

4. Click Apply, and then click OK.
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REST Service Tutorial

The REST Bookstore sample lets you explore the REST tooling in TIBCO Business Studio for
BusinessWorks. You can import this sample into TIBCO Business Studio for BusinessWorks
through File Explorer and examine the project and the solution implemented by it.

The processes in the sample implement different aspects of a bookstore, such as adding
books, deleting a book, and getting a list of books or a single book by ISBN. For more
information about the sample, see "Using REST to Manage Books for a Bookstore" in the
TIBCO BusinessWorks Container Edition Samples guide. This tutorial walks you through the
steps to build an additional REST service for the sample and test it in the debugger. You
can use the Swagger Ul to invoke the operations for the REST resource.

Prerequisites

» Access to a locally running PostgreSQL database.

e The latest version of Google Chrome.

Creating a Service Instance of Cloud Foundry
managed PostgreSQL Database Service

To bind an application to a managed PostgreSQL service already running in your Cloud
Foundry environment complete the following steps:

Procedure
1. In your Cloud Foundry environment, run:

cf services

2. Run
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cf create-service postgresql default postgres

Importing a Process Package

These steps show how to create a new process package.

Procedure

1.

Open TIBCO Business Studio for BusinessWorks.

Open the Design perspective by clicking the icon in the upper right.

Click the File Explorer tab. If the tab is not visible, click Window > Show View >
Other > FileSystem > File Explorer and click OK.

Click File > Switch Workspace and select or open a clean new workspace.

In the samples directory, select cloudfoundry > binding > rest > Bookstore and
double-click tibco.bwce.sample.binding.rest.BookStore.zip.

This opens the project in the Project Explorer.

In the Project Explorer, expand the tibco.bwce.sample.binding.rest.BookStore
project.

You can also import the sample using the File > Import > General > Existing Studio
Projects into Workspace > Select Archive File > Browse option.

The project is displayed in the Project Explorer panel on the left.

[?5 Project Explorer &2
4 [ tibco.bwee.sample binding.rest. BookStore
4 3 Processes
> H# tibco.bwce.sample.binding.restbookstore

- H tibco.bwcesample.binding.rest.bookstore.db

Expand the folders in the project to see all the project processes and resources. Refer
to the Application Development guide for information about the folder structure.
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[25 Project Explorer &

4 [ tibco.bwee.sample.binding.rest BookStore
4 <3 Processes
> # tibco.bwce.sample.binding.rest.bookstore
- # tibco.bweesample.binding.rest bookstore.db
4 [ Service Descriptors
» 2 Books.wsdl
» 22 BooksDBService.wsdl|
» &2 Events.wsdl
> & EventsDBService.wsdl
» 42 ModuleActivatorwsdl
4 g Resources
> 7 tibco.bwee.sample.binding.rest.BookStore
4 (g Schemas
- [S] Books.xsd
>[5 BooksSchema.xsd
» [5] Events.xsd
+ [8] EventsSchema.xsd
~ [8] RESTSchema.xsd
» & Module Descriptors
& build.properties

10. Expand Processes and then expand tibco.bwce.sample.binding.rest.bookstore.db.

The BooksDB.bwp process is displayed.

o Note: bwp is a BusinessWorks process.

[t5 Project Explorer &2

4 [ tibco.bwee.sample.binding rest. BookStare
4 <3 Processes
- tibco.bwce.sample.binding.restbookstore
4 # tibco.bwce.sample.binding restbookstore.db
. & BooksDB.bwp
> &5 EventsDB.bwp

11. Double-click BooksDB.bwp.
The BusinessWorks process comprises:
» Green chevron on the left indicates the service details.
e addBooks, getAl1Books, and other operations implemented by this process.

e Each operation is implemented separately.
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83 *Books.bwp 8@] |

tibco.bwce.sample.binding.rest.bookstore.Books |

B o - _ LN L)
2] Books/post | wlE = o JSenvice i JSenice

2] addBooks
g 2] getAllBooks
® 0 | 2 getBookByISBN
addBooks postOut 2] updateBook
2] get 2] deleteBook

2] getRecentBooks

2] put
2] delete <

Servicel

2] getAllEvents
4‘1@ Exception ) — 2] addEvents

(= 2] Books/aet =) 2] getEventByID

|7/ 2] Book/get =)} 2] updateEvent

| & 2] Book/put [EE)] 2] deleteEvent

(L= 2] Book/delete ) 2] getEventByISBN
\'. = 2] Book1/get I/

12. Double-click an operation to display the process for example, BooksPersist >
addBooks.

a. In the addBooks operation, a JDBC activity is seen.
b. The activity is repeated using a ForEach group.
c. addBooksOut represents the Reponse to the web service request.

13. To add a new process package named tibco.bwce.sample.rest, right-click on
Processes in the Project Explorer and select New > BusinessWorks Package.
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(=

Project...

=

File
Folder
SQL File

BusinessWorks Package
BusinessWorks Process

BusinessWorks REST Resource

R mLn

BusinessWaorks Sub Process

(=

Example...

™

L

COther... Ctri+M

|

14. In the BusinessWorks Package screen, specify tibco.bwce.sample.rest in the Name
field.

15. Click Finish and verify that the new package tibco.bwce.sample.rest has been
added in the Project Explorer.

Building a REST Service

This section details how to build a REST service.

Before you begin
The tibco.bw.sample.binding.rest.BookStore sample is loaded in the Project Explorer.

Procedure

1. To define a REST Resource named MyBooks, select
tibco.bw.sample.binding.rest.BookStore > New > BusinessWorks REST Resource.

The REST Service Wizard window is displayed.
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#) REST Service Wizard O 5

Create a new REST Resource

Configure the REST Service implementation.

Resource Name: Resource

Summary: ‘ Resource service ‘

Resource Service Pat ‘ Jresource

Resource Definition: ‘ Browse
posT [ JGer [ ]put []DELETE []PATCH
Operations: [ JopTiONS [_]HEAD
Add Custom Operation
Implementation Data: (® Structured () Opaque
@ < Back Next > | Finish | Cancel

2. Specify the following values in the REST Service Wizard window.
a. Resource Name: MyBooks
b. Summary: Summary about the new REST service. (default)
c. Resource Service Path: Auto-filled

d. Resource Definition: Select Browse > Schemas > Books.xsd > Books in the
Select Schema Element Declaration window.

e. Operations: Select POST and GET checkboxes.
f. Implementation Data: Accept the default value of Structured.

3. Click Finish.

This creates a new process MyBooks.bwp process is opened in the Process Editor.
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[&5 Project Explorer &

E&|b P = O

v & Processes

> & Books.bwp
» & Events.bwp

> @ MyBooks.bwp
» @ Restinvoke.bwp

» & Service Descriptors

> 1 Resources

> 1@ Schemas

> & Module Descriptors
& build.properties

~ [l tibco.bw.sample.binding.rest.BookStore [AppSpace]

~ g tibco.bw.sample.binding.rest.bookstore

» & Invoke_Client.bwp

> tibco.bw.sample.binding.rest.bookstore.db

> % tibco.bw.sample.binding.rest.BookStore.application [AppSpace]

4. Open the tibco.bw.sample.binding.rest.bookstore.db package in the Project
Explorer and select the BooksDB.bwp process. Drag it to the Process Editor and
drop it on the implemented POST operation.

A menu is displayed with two options: Create Invoke Activity and Create Reference

and Wire Process.

tiheo bw samnle hindina rest hookstare MuBaoaks

«-& oo
|'E-’J_m¥bnﬂksﬁpﬂsl.| s
® 2]
B Create Invoke Activity
_ = (reate Reference and Wire Process
[E-’J_mg.cbnniﬁﬁgeﬂ el
® 2]
getOut

5. Select Create References and Wire Process.
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The references are added to the process. The purple chevron indicates the service
and its operations that can be referenced by the process.

| tihca bw samnle hindina rest honokstare MvBoaks |
o T vi “ul il
/|'¢—]:3!: ooks/oost) wE = BooksDB
' ' 2] addBooks
® a © | @ getAlBooks
postOut 2] getBookByISBN
#]lupdateBook
\ / 2] deleteBook
.?-J_mybouksigeﬂ *Hv 2] getRecentBooks
® a o # getBooksByPri..
getOut
iy S

6. To update the POST process to invoke the appropriate external service operation:

a. Click the addBooks operation.

b. Select and drag the operation to the left of the postOut activity and drop it. An
Invoke process activity is created.

postOut

[3‘] Mybooks/post |

addBooks

00150

7. Click the newly added activity. Select the icon and connect addBooks to
postOut.

#] M}rl::lcu:uks.-"pnst]

ma

addBooks postOut

8. Click the getAllBooks operation and select, drag, and drop the operation to the left
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of the getOut activity in the OUT process.
9. Connect getAllBooks to getOut.

| 2] Mybooks/get |

a E
getfllBooks getOut

10. Save your changes.
11. Click the addBooks activity and select Properties > Input.

12. Expand the data tree in the Data Source pane to locate the Book element.

f Problems | = Properties &2 . (®) Reference - online} =] Console] o @mE 8| Q&Y =0
addBooks (Invoke)
General
e — Data Source] Function5| Cons‘[ants‘ XPath Expression il
. - [ item @ addBooks-input
___ El Book — operationRequest
Input m ABE isbn? & parameters
Output ABt name? [E operationReque
Bt description? B Book* =
ABL authorName' ABE sbn?
= A releaseDate? BBt name?
10 vintage? Bt descriptio
10 signed? A8t quthorNa.
0.0 price? & releaseDa T
L [7 httpHeaders 110 vintage?
- ¥ signed? A

13. Drag the Book element from the left to the Book* element on the right.

14. In the pop-up window, select Make a Copy of each " Book" and click Finish.

The Input tab looks like this:
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15.
16.

17.

11

¥ vintage?
10 signed?
0.0 price?

i [ httpHeaders

-

ABC description?
AEE authorName’
] releaseDate?

= operationRegu
% Book - [Cop $post/item/tns1:Book

W@ Reference - online} EConsoleW #lo@rmm 2 |@dMET =0
E1 addBooks (Invoke)
General
Descripti Data Source] Functions‘Constants‘ XPath Expression
scription

§ - 4 [ jtem 5= addBooks-input

Conversations .
4|El Book| =— [] operationRequest

Input — ABL isbn? ——— [ parameters
Output ABL name?

Save your changes.

Click the postOut activity and open the Properties > Input tab. Expand the post
activity and drag the Book™* element from left to right.

In the pop-up window, select the For each option and click Next. Click Finish on the
Auto-Map window. The Properties > Input tab looks similar to this:

Data Sourcel Functions| Constantsl

b §d §_processContext
4 5% Spost
a [ item
a [Z] Books
» B Book*
[ [ httpHeaders

% addBooks-input

= [ addBooksRequest
e—— [ parameters

[=] addBocksRequest

¥ Book - [Copy-0f]

XPath Expression

Spost/item/tnsl:Books/tnsl:Book

18. Click getAllBooks and select Properties > Input.

19.

In the XPath Expression pane, add a dummy value to the input element, such as,
"Get All Books". The input must be in quotes.

H £, Problems | =l Properties £ . (3 Reference - nnllne] 2 Consolsﬂ

—
R EE-

B getAllBooks (Invoke)

General

Tz Data Source‘ Functlunsl Constantsl

. $* §_processContext
Conversations -

$4 $get
Input

Output

2 getAllBooks-input
~— [ operationRequest1
«—— [ parameters
[El operationRequestl
Bt in

XPath Expression

"Get all books"

20. Click the getOut activity in the Process Editor, and select the Properties > Input
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tab. Expand the getAllBooks activity and choose Book* to map the Book™ element
from left to right. In the pop-up window, choose Make a Copy of each " Book" and
click Finish. The tab looks similar to this:

| Data Source | Functions | Constants
5 $% §_processContext
> S* Sget
4 5% SgethlBooks
4 [ parameters
a [E] operationResponse

S getOut-input
~—— [ getResponse
e—— [ item
= — [ Books
B Book - [Copy-Of]

> [E] Book*

XPath Expression

SgetAllBooks/parameters/tns2:operationResponse/tnsl:Book

Result
Your project is complete without any errors.

Testing the REST Service in Cloud Foundry

You can now test the REST service using the built-in tester and the Swagger UL.

Procedure
1. In the Project Explorer, expand the

tibco.bwce.sample.binding.rest.BookStore.application process and expand the

Package Unit > Properties folder.

2. In the Properties window, expand the

tibco.bwce.sample.binding.rest.BookStore.application and set the default
Application Profile to PCF as shown in the next image. The bracketed profile in the

column head is the one that is selected:

% tibco.bwce.sample.binding.rest BookStore.application 52
= Properties

Properties
Property Configurations

New Property | New Group New Profile | | Set as Default

Properties [PCF] local

¥ Application
~ @ tibco.bwee.sample.bind

gt dbDriver

At dbURL

= dbPassword
fikt dbUserName

org.postgresgl.Driver
#postgres.credentials.DB_URL#
#postgres.credentials.DB_PASSWORD#
#postgres.credentials.DB_USERNAME#

org.postgresgl.Driver
jdbcpostgresql://54.67.121....

........

bwuser
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w

Expand the Package Unit and select Overview.
4. In the Overview window, select Export Application for Deployment.

5. Enter the location of your EAR file (this would be the same directory as the
manifest.yml file).

6. In your Cloud Foundry environment, navigate to the directory containing your EAR.

7. Run

cf push -f manifest.yml

If the application deploys successfully, a routable URL is available.

8. Open the Google Chrome browser and open http://<BWCE-APP-URL>/swagger. Click
Books or Events to see the operations. Click MyBooks to see the REST service
operations you just added. See the section called Testing the POST and GET
Operations for information.

£} swagger http://bookstoreapp. test.com: 80/swagger/swagger json Explore

tibco.bwce.sample.binding.rest.BookStore.application

Books ShowHide | List Operations | Expand Operations

/book/{ISBN}

PRl book/{ISBN}

BN mookigseny

[C3 /book/{ISBN}/events
<o /books

Ll /books

Events ShowHide | List Operations Expand Operations

[ Base UrRL: , aPI vErsIoN: 1.0 ]

9. Expand the Books and Events headers, and test out the operations as listed below.

Result

Click Books or Events in the Swagger Ul to view the following operations for Books and
Events:

Books
e Post books

e GET books
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e GET book by ISBN

e PUT book by ISBN

e DELETE book by ISBN
Events

e POST Events
GET Events

GET Event by EventID

PUT Event by EventID

DELETE Event by EventID

GET books returns an output similar to the following:

{
"Book": [
{
"isbn": "0061122416",
"name": "The Alchemist",
"description": "Every few decades a book is published that changes
the lives of its readers forever. The Alchemist is such a book",
"authorName": "Paul Coelho",
"releaseDate": "2006-04-25",
"vintage": true,
"signed": true,
"price": 11.9

"isbn": "0071450149",

"name": "The Power to Predict",

"description": "How Real Time Businesses Anticipate Customer
Needs, Create Opportunities, and Beat the Competition",

"authorName": "Vivek Ranadive",

"releaseDate": "2006-01-26",

"vintage": false,

"signed": true,

"price": 15.999

GET books by ISBN returns an output similar to the following for ISBN 0061122416:
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{
"isbn": "0061122416",
"name": "The Alchemist",
"description": "Every few decades a book 1is published that changes
the lives of its readers forever. The Alchemist is such a book",
"authorName": "Paul Coelho",

"releaseDate": "2006-04-25",
"vintage": true,

"signed": true,

"price": 11.9

Testing the POST and GET Operations

An available RESTful service displays the GET operation in the Swagger Ul. The POST
operation is tested using the JSON service. It is important to test these operations by doing
some simple tasks. This section explains how to test the POST and GET operations you just
added.

Procedure
1. Click MyBooks. It expands and displays the POST and GET operations.

2. Click the POST icon to display its details.

Provide values for the Books parameter.

3

4. Click the Try it out! button.

5. Now click the GET icon to display its details.
6

. Click the Try it out! button.

The response displays a list of books returned by the REST service from the database.
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Request URL
http://localhost:8123/mybooks/
Response Body
-
‘ =
"Book™: [ =
{ I
"isbn": "@385537859",
"name": "Inferno”,
"description”: “Robert Langdon returns in Dan Brown's latest fast paced action thirller™,
"authorName™: "Dan Brown™,
"releaseDate": "2813-85-14+85:38",
"vintage": false,
"signed™: true,
"price”: 14.89
b
i
"isbn": "@399103421",
"name”: "The Godfather™,
"description": "The Godfather is an epic story of a New York's top mafia family, loyalty, and how men of honor live in thei
"authorName™: "Mario Puzo",
"releaseDate": "1969-83-18+85:38",
"wintase™: true. 3l
] . | 3

Testing the REST Service in OpenShift

You can deploy the REST service in OpenShift environment and test by using the built-in
tester and the Swagger Ul.

Before you begin
Ensure that the OpenShift environment is set up to deploy the application.

Procedure
1. In the Project Explorer, expand the
tibco.bwce.sample.binding.rest.BookStore.application process and expand the
Package Unit > Properties folder.

2. In the Properties window, expand the
tibco.bwce.sample.binding.rest.BookStore.application and set the default
Application Profile to Docker as shown in the following image:
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o o W

10.

Properties
Property Configurations

MNew Property | MNew Group Mew Profile | | Set as Default

Properties [docker] local
& Application
~ g tibco.bwcesample.bind
REt dbDriver org.postgresgl.Driver org.postgresql.Driver
ABt dbURL #DB_URL% jdbc:postgresgl://54.67.121....
& dbPassword #DB_PASSWORD#
B dblUserName #DB_USERNAME# bwuser

Expand the Package Unit and select Overview.
In the Overview window select Export Application for Deployment.
In your Docker environment, navigate to the directory containing your EAR file.

To login to the OpenShift environment, run the following command:

oc login <OpenShift_Server URL>

If the project is not created, create an OpenShift project by running the following
command:

oCc new-project <PROJECT _NAME>

To build an application docker image, run the following command:

docker build -t <APPLICATION_NAME>

To tag an application docker image with your docker repository, run the following
command:

docker tag <APPLICATION_IMAGE_NAME><DOCKER_REPOSITORY_NAME>/<APPLICATION_IMAGE
NAME>

To push a docker image to the docker repository, run the following command.
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11.

docker push <DOCKER_REPOSITORY_NAME>/<APPLICATION_IMAGE_NAME>

Note: Here the docker hub registry is used to push the docker image. You
can push images to OpenShift internal registry or any other public registry.

To use the OpenShift configuration file (YAML or JSON) and push the application on
OpenShift, run the following command.

oc create -f <MANIFEST_FILENAME>

apiVersion: vl
kind: Service
Hmetadata:
name: restapp
H labels:
E app: [restapp
Hepec:
type: LoadBalancer
ports:
- port:
targetPort:
selector:
app: restapp

5 L i

apiversion: vl
kind: ReplicationController
Hmetadata:
- name: restapp
Hepec:
replicas:
selector:
app: restapp
template:
metadata:
name: restapp
labels:

H
- app: restapp
H spec:
H
H

L o s

containers:
- name: restapp
image: <DOCKER_REPOSITORY_NAME)/(APPLICATION_IMAGE_NAME)
imagePullPolicy: Always
env:
- name: BW LOGLEVEL
value: ERROR
- name: DB URL
value: <supported database>://<username:password>@<machine:port>/<database name>
name: DB USERNAME
value: <username>
- name: DB PASSWORD
value: <password>
ports:

£ L. s L, L L W
]

- containerPort:
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12. To create a route for application, run the following command.

OC expose service <APPLICATION_SERVICE_NAME>

C:\Users\rubirada\Downloads>oc expose service restboostore

route "restboostore” exposed

13. To view the route of an application, run the following command:

oc get route

C:\Users\rubirada\Downloads>oc get route
NAME HOST/PORT SERVICES PORT TERMINATION  WILDCARD

jms-consul jms-consul-test.os.tibcopcf110.com jms-consul 8080 Nonhe
restboostore resthoostore-test.os.tibcopcf110.com restboostore app None

14. Open the Google Chrome browser and open http://ROUTABLE_URL/swagger.

@ http://bookstoreapp. test. com:80/swagger/swagger json

tibco.bwce.sample.binding.rest.BookStore.application

Show/Hide  List Operations = Expand Operations

/book/{ISBN}
[ /book/{ISBN}
/book/{ISBN}
G /book/{ISBN}/events P

/books

m
@ Q
dABBAH:E

/books |

15. In the Swagger Ul, click Books or Events to see the operations and then click
MyBooks to see the REST service operations you just added. For more information,
see Testing the POST and GET Operations.

16. Expand the Books and Events headers, and test the operations as follows.

Result

In the Swagger Ul, click Books or Events to view the following operations for the Books
and Events headers:

Books
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POST books

GET books

GET book by ISBN

PUT book by ISBN

DELETE book by ISBN
Events

e POST Events

GET Events

GET Event by EventID

PUT Event by EventID

DELETE Event by EventID

GET books returns the following similar output:

{
"Book": [
{
"isbn": "0061122416",
"name": "The Alchemist",
"description": "Every few decades a book 1is published that changes
the lives of its readers forever. The Alchemist is such a book",
"authorName": "Paul Coelho",
"releaseDate": "2006-04-25",
"vintage": true,
"signed": true,
"price": 11.9

"isbn": "0071450149",

"name": "The Power to Predict",

"description": "How Real Time Businesses Anticipate Customer
Needs, Create Opportunities, and Beat the Competition",

"authorName": "Vivek Ranadive",

"releaseDate": "2006-01-26",

"vintage": false,

"signed": true,

"price": 15.999
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GET books by ISBN returns the following similar output for ISBN 0061122416:

{
"isbn": "0061122416",
"name": "The Alchemist",
"description": "Every few decades a book is published that changes
the lives of its readers forever. The Alchemist is such a book",
"authorName": "Paul Coelho",

"releaseDate": "2006-04-25",
"vintage": true,

"signed": true,

"price": 11.9

Troubleshooting

You may encounter some errors while executing or running the process. The following are
some of the possible errors you may encounter and their resolutions.

Error Encountered Resolution

The REST Swagger Ul page is not  Verify that the application has started and that you are

visible. accessing the correct URL.

Problem markers are visible in Clean the project by invoking Project > Clean or by
the project. switching to a clean new workspace.

The database and database Ensure that the Cloud Foundry PostgreSQLService is
tables are not created. configured correctly.
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REST Reference Tutorial

The REST reference tutorial shows you how to create a simple REST Invoke to an existing
REST Service defined by a Swagger specification.

You cannot convert REST reference to SOAP or vice versa.

Before you begin
The REST service which you want to consume has to be deployed in your Cloud Foundry
environment.

Creating a New Application

1. Open TIBCO Business Studio for BusinessWorks.
2. Open the Design perspective by clicking the Design icon in the upper right corner.

3. Click File > New > Other > BusinessWorks > BusinessWorks Application Module
and click Next.

4. Enter in the Project Name text box. Do not change the remaining default settings.
Click Finish. This creates a new application module with an empty process.

Obtaining the REST Service Swagger File

o Note: The REST service for which you want to obtain the Swagger file must be
running. In this example the
tibco.bwce.sample.binding.rest.BookStore.application should be deployed in

your Cloud Foundry environment.

To obtain a Swagger file for a REST service, do the following:

1. Append swagger to the routable URL to access the Swagger doc. The format is
http://<routable url>/swagger.

2. Enter http://<routable url>/swagger/swagger.json in the browser and copy
entire JSON file to Books.json file.
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Importing the JSON File into your Project

1.

In the Project Explorer, expand tibco_bwce_sample_binding_rest application
module.

Right-click Service Descriptors and select Import > Import... > General > File
System and click Next.

In the File system dialog, click the Browse button and browse to the location of the
Books.json file.

Select the checkbox next to Books.json in the left pane and click Finish.

Creating the REST Reference

1.

In the Project Explorer, expand the tibco_bwce_sample_binding_rest Service
Descriptors folder completely .

Select the /books under Books.json and drag and drop it to the right side of the
process in the Process Editor. The references are added to the process. The purple
chevron indicates the service and its operations.

B % £ v=0 tibco.bwee.samp tibco.bwce.sam. tibco.bwce.samp Books.bwp MyBooks.bwp (@ *Process.bwp 22 "4 =g

'%cha‘hwce.samp‘!.bmdmg.res{-soold(o'e tibeo bwee. sample. binding rest.bookstoreconsumption Process o ‘
v 3 tibco.bwee.sample. binding.rest. o

(5 *Project Explorer 12

mple.binding.rest.BookStoreConsumption

ce.sample.binding.rest i T 1
T 1 3 Create Service

ess.bwp

» @ InvokeBookStore.bwp e
v & Service Descriptors -
v [= BookStore.json =S

¥ <no basePath>

» 4 /book/{ISBN}
» 1 /book/{ISBN}/events

i build.properties
» & tibco.bwee.sample.binding. rest. k
» f tibeo.bwee.sample.binding. soap. http.StockQuoteClient

In the Process Editor, right-click Add Activity > General Activities > Timer.
Optionally, you can configure the Sleep activity with IntervalinMillisec as 3000 in a
similar manner and connect the Timer with Sleep.

Drag the get operation under the purple chevron and drop it on the right of Timer
activity (or Sleep if configured) and connect the Timer activity with the get activity.

Drag the post operation under the purple chevron and drop it on the right of the get
activity , connect the get activity with the post activity .

Right-click the get activity select Show Properties View.
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10.

11.
12.
13.

14.

15.

16.
17.

18.

In the Properties view, select the Input tab and click Show Check and Repair icon
in the icon bar on the upper right corner of the Properties view.

Select the checkbox under Fix and click OK.

Click Show Check and Repair icon again. Select the checkbox under Fix and click
OK.

Select the post activity and right click and select Show Properties View. In the
Properties View, select the Input tab and select Data Source tab.

Expand $getin the Data Source tab completely.
In the XPath Expression pane, expand the post-input completely.

Drag and drop Book* from the Data Source tab to the Book* under post-input in the
XPath Expression pane.

In the Drop dialog, select Make a copy of each "book" radio button and click
Finish.

Click Show Check and Repair icon in the icon bar on the upper right corner of the
Properties view.

Select the checkbox under Fix and click OK.

Click Show Check and Repair icon again. Select the checkbox under Fix and click
OK.

In the Project Explorer, select Books.json under Service Descriptors of tibco_
bwce_sample_binding_rest_basic application module, and right click Open With >
Text Editor and locate the "host" attribute. Make a note of the host name and port
number.
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{
"swagger” : "2.8",
"info" : {
"wersion" : "1.8",
"title" : "Summary about the new REST service.”,
"description” : "Summary about the new REST service.™
>
"host" : "localhost:B8886",
“basePath™ : "/",
"schemes" : [ "http" 1.
"consumes”™ : [ “"application/json” 1.
“produces”™ : [ “"application/json” 1.
"paths™ : {
"/books™ 1 {
"post™ : {
"description™ : ™",
“operationId” : ™ .
“consumes” : [ "application/json” 1,
"produces” : [ "application/json” 1,
"parameters” : [ {
"name™ : "body”™,
"in" : “"body™,
"description” : ""
"schema" : {
"$ref” : "#/definitions/Books”
I
"required” : true,
"allowMultiple™ : false
T
"responses” : |
"aea" o {
"description™ : "a Books to be returned”,
"schema" : {
"gref” : "#/definitions/Books™
}
}
}

h

19.
application module completely.

20. Double-click HttpClientResource.httpClientResource.

21.
the Books. json file you obtained in step 18 above.

Expand the Resources folder under the tibco_bwce_sample_binding_rest_basic

In the HTTP Client section, change the Default Host and Default Port to the values in

* HTTP Client

Implementation Library

Apache HttpComponents(Supported by HTTP and REST) JiEd

Disable Connection Pocling: ] E
Maximum Total Connections: 200 = E‘ Idle Connection Timeout (ms): a = E
Maximum Total Connections Per Host/Route: 20 2 E‘ Stale Check: ] E

| Default Host: [AB¢ localhost -l st @ Default Port: (1238080 -l|s @
Thread Pool B @

22. Click File > Save All.

Testing the REST Reference

You can now test the REST service using the built-in tester and the Swagger Ul. To do so

follow these steps:

1. Click Run > Debug Configuration.

2. In the left pane of the Debug Configuration wizard, expand BusinessWorks
Application and select BWApplication.
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3. Click the Applications tab and then click Deselect All if you have multiple
applications. Select the checkboxes next to tibco_bw_sample_binding_rest_basic_

6.

application.

Click Debug. This runs the sample in debug mode. The Console view is opened and
shows engine messages similar to: Started BW Application [ tibco_bwce_sample_

binding_rest_basic_application:1.0]

In the Debug view, expand BWApplication [BusinessWorks Application] >
<launched> BWEclipseAppNode > tibco_bwce_sample_binding_rest_Process and

select get.

In the JobData view, you can see the job data of the get activity.

4§ Debug 2 |9, BusinessWorks Jobs 4 Servers

4 5| BWApplication [BusinessWorks Application]
4 {fﬂ <launched> BWEclipsefAppNede @localhost:9091
4 @ tibco_bw_sample_binding_rest.Process [bw(a100] - (Viewed job)
(@ Timer [bw001g0.3] - (Done)
= Sleep [bw001g0.4] - (Done)
get [bw001g0.5] - (Done)
post [bw001g0.6] - (Done)
» {58 tibco_bw_sample_binding_rest_basic.Client [bw0a101] - (Completed)
» £33 tibco_bw_sample_binding_rest_basic.Baoks [bw0al02] - {Completed)
b @ tibco_bw_sample_binding_rest_basic.Books [bw0al03] - (Completed)

b @ tibco_bw_sample_binding_rest_basic.Books [bw0al04] - (Completed)

[elE =5

get

Input
Qutput
Fault

All

ts [, Job Data 2 B = B8
MName Value
4 get-input.httpHeaders <tnsL:httpHeaders xmins:tnsl="http://tns.tibco.com/bw/
Accept
Accept-Charset
Accept-Encoding

Content-Type
Content-Length
Cennection
Cookie
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TIBCO Documentation and Support Services

For information about this product, you can read the documentation, contact TIBCO
Support, and join TIBCO Community.

How to Access TIBCO Documentation

Documentation for TIBCO products is available on the Product Documentation website,
mainly in HTML and PDF formats.

The Product Documentation website is updated frequently and is more current than any
other documentation included with the product.

Product-Specific Documentation

The following documentation for this product is available on the TIBCO BusinessWorks™
Container Edition page:

e TIBCO BusinessWorks™ Container Edition Release Notes

e TIBCO BusinessWorks™ Container Edition Installation

e TIBCO BusinessWorks™ Container Edition Application Development

e TIBCO BusinessWorks™ Container Edition Application Monitoring and Troubleshooting
e TIBCO BusinessWorks™ Container Edition Bindings and Palettes Reference

e TIBCO BusinessWorks™ Container Edition Concepts

e TIBCO BusinessWorks™ Container Edition Error Codes

e TIBCO BusinessWorks™ Container Edition Getting Started

e TIBCO BusinessWorks™ Container Edition Migration

e TIBCO BusinessWorks™ Container Edition Performance Benchmarking and Tuning
e TIBCO BusinessWorks™ Container Edition REST Implementation

e TIBCO BusinessWorks™ Container Edition Refactoring Best Practices

e TIBCO BusinessWorks™ Container Edition Samples
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How to Contact Support for TIBCO Products

You can contact the Support team in the following ways:

e To access the Support Knowledge Base and getting personalized content about
products you are interested in, visit our product Support website.

e To create a Support case, you must have a valid maintenance or support contract
with a Cloud Software Group entity. You also need a username and password to log
in to the our product Support website. If you do not have a username, you can
request one by clicking Register on the website.

How to Join TIBCO Community

TIBCO Community is the official channel for TIBCO customers, partners, and employee
subject matter experts to share and access their collective experience. TIBCO Community
offers access to Q&A forums, product wikis, and best practices. It also offers access to
extensions, adapters, solution accelerators, and tools that extend and enable customers to
gain full value from TIBCO products. In addition, users can submit and vote on feature
requests from within the TIBCO Ideas Portal. For a free registration, go to

TIBCO Community.
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Legal and Third-Party Notices

SOME CLOUD SOFTWARE GROUP, INC. (“CLOUD SG”) SOFTWARE AND CLOUD SERVICES EMBED,
BUNDLE, OR OTHERWISE INCLUDE OTHER SOFTWARE, INCLUDING OTHER CLOUD SG SOFTWARE
(COLLECTIVELY, “INCLUDED SOFTWARE”). USE OF INCLUDED SOFTWARE IS SOLELY TO ENABLE THE
FUNCTIONALITY (OR PROVIDE LIMITED ADD-ON FUNCTIONALITY) OF THE LICENSED CLOUD SG
SOFTWARE AND/OR CLOUD SERVICES. THE INCLUDED SOFTWARE IS NOT LICENSED TO BE USED OR
ACCESSED BY ANY OTHER CLOUD SG SOFTWARE AND/OR CLOUD SERVICES OR FOR ANY OTHER
PURPOSE.

USE OF CLOUD SG SOFTWARE AND CLOUD SERVICES IS SUBJECT TO THE TERMS AND CONDITIONS
OF AN AGREEMENT FOUND IN EITHER A SEPARATELY EXECUTED AGREEMENT, OR, IF THERE IS NO
SUCH SEPARATE AGREEMENT, THE CLICKWRAP END USER AGREEMENT WHICH IS DISPLAYED WHEN
ACCESSING, DOWNLOADING, OR INSTALLING THE SOFTWARE OR CLOUD SERVICES (AND WHICH IS
DUPLICATED IN THE LICENSE FILE) OR IF THERE IS NO SUCH LICENSE AGREEMENT OR CLICKWRAP
END USER AGREEMENT, THE LICENSE(S) LOCATED IN THE “LICENSE” FILE(S) OF THE SOFTWARE. USE
OF THIS DOCUMENT IS SUBJECT TO THOSE SAME TERMS AND CONDITIONS, AND YOUR USE HEREOF
SHALL CONSTITUTE ACCEPTANCE OF AND AN AGREEMENT TO BE BOUND BY THE SAME.

This document is subject to U.S. and international copyright laws and treaties. No part of this
document may be reproduced in any form without the written authorization of Cloud Software
Group, Inc.

TIBCO, the TIBCO logo, the TIBCO O logo, ActiveMatrix BusinessWorks, ActiveSpaces, Business Studio,
TIBCO Business Studio, TIBCO Designer, Enterprise Message Service, Hawk, Rendezvous, and TIBCO
Runtime Agent are either registered trademarks or trademarks of Cloud Software Group, Inc. in the
United States and/or other countries.

Java and all Java based trademarks and logos are trademarks or registered trademarks of Oracle
and/or its affiliates.

All other product and company names and marks mentioned in this document are the property of
their respective owners and are mentioned for identification purposes only. You acknowledge that all
rights to these third party marks are the exclusive property of their respective owners. Please refer to
Cloud SG’s Third Party Trademark Notices (https://www.cloud.com/legal) for more information.

This document includes fonts that are licensed under the SIL Open Font License, Version 1.1, which is
available at: https://scripts.sil.org/OFL

Copyright (c) Paul D. Hunt, with Reserved Font Name Source Sans Pro and Source Code Pro.
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Cloud SG software may be available on multiple operating systems. However, not all operating
system platforms for a specific software version are released at the same time. See the “readme” file
for the availability of a specific version of Cloud SG software on a specific operating system platform.

THIS DOCUMENT IS PROVIDED “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR
IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

THIS DOCUMENT COULD INCLUDE TECHNICAL INACCURACIES OR TYPOGRAPHICAL ERRORS. CHANGES
ARE PERIODICALLY ADDED TO THE INFORMATION HEREIN; THESE CHANGES WILL BE INCORPORATED
IN NEW EDITIONS OF THIS DOCUMENT. CLOUD SG MAY MAKE IMPROVEMENTS AND/OR CHANGES IN
THE PRODUCT(S), THE PROGRAM(S), AND/OR THE SERVICES DESCRIBED IN THIS DOCUMENT AT ANY
TIME WITHOUT NOTICE.

THE CONTENTS OF THIS DOCUMENT MAY BE MODIFIED AND/OR QUALIFIED, DIRECTLY OR
INDIRECTLY, BY OTHER DOCUMENTATION WHICH ACCOMPANIES THIS SOFTWARE, INCLUDING BUT
NOT LIMITED TO ANY RELEASE NOTES AND "README" FILES.

This and other products of Cloud SG may be covered by registered patents. For details, please refer
to the Virtual Patent Marking document located at https://www.tibco.com/patents.

Copyright © 2015-2023. Cloud Software Group, Inc. All Rights Reserved.
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