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registered trademarks or trademarks of TIBCO Software Inc. in the United States and/or other
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Edition (J2EE), and all Java-based trademarks and logos are trademarks or registered trademarks of
Oracle Corporation in the U.S. and other countries.
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respective owners and are mentioned for identification purposes only.

THIS SOFTWARE MAY BE AVAILABLE ON MULTIPLE OPERATING SYSTEMS. HOWEVER, NOT
ALL OPERATING SYSTEM PLATFORMS FOR A SPECIFIC SOFTWARE VERSION ARE RELEASED
AT THE SAME TIME. SEE THE README FILE FOR THE AVAILABILITY OF THIS SOFTWARE
VERSION ON A SPECIFIC OPERATING SYSTEM PLATFORM.

THIS DOCUMENT IS PROVIDED “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS
OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

THIS DOCUMENT COULD INCLUDE TECHNICAL INACCURACIES OR TYPOGRAPHICAL
ERRORS. CHANGES ARE PERIODICALLY ADDED TO THE INFORMATION HEREIN; THESE
CHANGES WILL BE INCORPORATED IN NEW EDITIONS OF THIS DOCUMENT. TIBCO
SOFTWARE INC. MAY MAKE IMPROVEMENTS AND/OR CHANGES IN THE PRODUCT(S)
AND/OR THE PROGRAM(S) DESCRIBED IN THIS DOCUMENT AT ANY TIME.

THE CONTENTS OF THIS DOCUMENT MAY BE MODIFIED AND/OR QUALIFIED, DIRECTLY OR
INDIRECTLY, BY OTHER DOCUMENTATION WHICH ACCOMPANIES THIS SOFTWARE,
INCLUDING BUT NOT LIMITED TO ANY RELEASE NOTES AND "READ ME" FILES.

Copyright © 2015-2016 TIBCO Software Inc. All rights reserved.
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TIBCO Documentation and Support Services

Documentation for this and other TIBCO products is available on the TIBCO Documentation site. This
site is updated more frequently than any documentation that might be included with the product. To
ensure that you are accessing the latest available help topics, please visit:

https://docs.tibco.com

Product-Specific Documentation

Documentation for TIBCO products is not bundled with the software. Instead, it is available on the
TIBCO Documentation site at https://docs.tibco.com/products/tibco-activematrix-businessworks-plug-
in-for-amqp. To directly access documentation for this product from the file system, double-click the
following file:

TIBCO_HOME/release_notes/TIB_bwpluginamqp_version_docinfo.html

where TIBCO_HOME is the top-level directory in which TIBCO products are installed.

On Windows, the default TIBCO_HOME is C:\Program Files\tibco\bw6.

On UNIX systems, the default TIBCO_HOME is /opt/tibco/bw6.

The following documents for this product can be found in the TIBCO Documentation site:

● TIBCO ActiveMatrix BusinessWorks Plug-in for AMQP Installation

● TIBCO ActiveMatrix BusinessWorks Plug-in for AMQP User’s Guide

● TIBCO ActiveMatrix BusinessWorks Plug-in for AMQP Release Notes

The following documents provide additional information and can be found in the TIBCO
Documentation Library:

● TIBCO ActiveMatrix BusinessWorks documentation

● TIBCO Enterprise Administrator User's Guide

How to Contact TIBCO Support

For comments or problems with this manual or the software it addresses, contact TIBCO Support:

● For an overview of TIBCO Support, and information about getting started with TIBCO Support,
visit this site:

http://www.tibco.com/services/support

● If you already have a valid maintenance or support contract, visit this site:

https://support.tibco.com

Entry to this site requires a user name and password. If you do not have a user name, you can
request one.

How to Join TIBCO Community

TIBCO Community is an online destination for TIBCO customers, partners, and resident experts. It is a
place to share and access the collective experience of the TIBCO community. TIBCO Community offers
forums, blogs, and access to a variety of resources. To register, go to the following web address:

https://community.tibco.com
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Product Overview

Advanced Message Queuing Protocol (AMQP) is an open standard for passing business messages
between applications or organizations. This protocol is used to connect systems, provide business
processes with the information they require, and reliably transmit instructions to achieve the goals of
applications.

By using this plug-in, you can send messages to or receive messages from an AMQP broker queue. In
addition, you can also use this plug-in to subscribe to messages from an AMQP broker queue.

The following figure describes the relationship among an AMQP broker, TIBCO ActiveMatrix
BusinessWorks™ Plug-in for AMQP, and TIBCO ActiveMatrix BusinessWorks™.

The following list describes each item and the relationship between them in the previous figure.

● The AMQP broker is a server. You can use TIBCO ActiveMatrix BusinessWorks Plug-in for AMQP
to communicate with the AMQP broker.

● TIBCO ActiveMatrix BusinessWorks Plug-in for AMQP plugs into TIBCO ActiveMatrix
BusinessWorks and is connected to an AMQP broker.

● TIBCO ActiveMatrix BusinessWorks is an easy-to-use integration product suite for enterprise
applications.

● TIBCO Business Studio™ consists of a graphical user interface (GUI) used by TIBCO ActiveMatrix
BusinessWorks with the plug-ins to design business processes, and the process engine used to
execute those processes.

● TIBCO® Enterprise Administrator provides a centralized administrative interface to manage and
monitor the plug-in applications deployed in an enterprise.
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Getting Started

This tutorial is designed for beginners who want to use TIBCO ActiveMatrix BusinessWorks Plug-in for
AMQP in TIBCO Business Studio.

All configuration operations are performed in TIBCO Business Studio. See TIBCO Business Studio
Overview to get familiar with TIBCO Business Studio.

A basic procedure of using TIBCO ActiveMatrix BusinessWorks Plug-in for AMQP includes:

1. Creating a Project

2. Creating an AMQP Connection

3. Configuring a Process

4. Testing a Process

5. Deploying an Application

Creating a Project
The first task for using the plug-in is creating a project. After creating a project, you can add resources
and processes.

An Eclipse project is an application module configured for TIBCO ActiveMatrix BusinessWorks. An
application module is the smallest unit of resources that is named, versioned, and packaged as part of
an application.

Procedure

1. Start TIBCO Business Studio using one of the following ways:

● Microsoft Windows: click Start > All Programs > TIBCO > TIBCO_HOME > TIBCO Business
Studio version_number > Studio for Designers.

● Mac OS and Linux: run the TIBCO Business Studio executable file located in the TIBCO_HOME/
studio/version_number/eclipse directory.

2. From the menu, click File > New > BusinessWorks Resources to open the BusinessWorks Resource
wizard.

3. In the "Select a wizard" dialog, click BusinessWorks Application Module and click Next to open
the New BusinessWorks Application Module wizard.

4. In the Project dialog, configure the project that you want to create:
a) In the Project name field, enter a project name.
b) By default, the created project is located in the workspace current in use. If you do not want to

use the default location for the project, clear the Use default location check box and click Browse
to select a new location.

c) Use the default version of the application module, or enter a new version in the Version field.
d) Keep the Create empty process and Create Application check boxes selected to automatically

create an empty process and an application when creating the project.
e) Select the Use Java configuration check box if you want to create a Java module.

A Java module provides the Java tooling capabilities.
f) Click Finish to create the project.

Result

The project with the specified settings is displayed in the Project Explorer view.
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Creating an AMQP Connection
After creating a project, you have to create an AMQP Connection shared resource to create a connection
between the plug-in and the AMQP server. With this shared resource, you can share the AMQP
connection at runtime between different AMQP activities within a process.

Prerequisites

The AMQP Connection shared resource is available at the Resources level. Ensure that you have
created a project, as described in Creating a Project.

Procedure

1. Expand the created project in the Project Explorer view.

2. Right-click the Resources folder and click New > AMQP Connection to open the AMQP
Connection wizard.

3. The resource folder, package name, and resource name of the AMQP connection are provided by
default. If you do not want to use the default configurations, change them accordingly. Click Finish
to open the AMQP Connection editor.

4. Configure the AMQP Connection shared resource in the AMQP Connection editor.
See AMQP Connection regarding the configuration fields.

5. Click Test Connection to validate the connection.
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Configuring a Process
After creating a project, an empty process is created. You can add activities to the empty process to
complete a task, such as sending a message.

Prerequisites

Ensure that you have created an empty process when creating a project. See Creating a Project for more
details.

Procedure

1. In the Project Explorer view, click the created project and open the empty process from the
Processes folder.

2. Select activities from the Palette view and drop them in the Process editor.
For example, select and drop the Timer activity from the General Activities palette, and the
AMQPSendMessage activity from the AMQP palette.

3. Drag the  icon to create a transition between the added activities.

4. Configure the added AMQP activity, as described in AMQP Palette.

An AMQP connection is required when configuring the AMQP activities. See Creating an
AMQP Connection for more details on how to create an AMQP connection.

5. Click File > Save to save the process.
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Testing a Process
After configuring a process, you can test the process to check whether the process completes your task.

Prerequisites

Ensure that you have configured a process, as described in Configuring a Process.

Procedure

1. On the toolbar, click  Debug > Debug Configurations.

2. Click BusinessWorks Application > BWApplication in the left panel.
By default, all the applications in the current workspace are selected in the Applications tab. Ensure
that only the application you want to debug is selected in the Applications tab in the right panel.

3. Click Debug to test the process in the selected application.
TIBCO Business Studio changes to the Debug perspective. The debug information is displayed in
the Console view.

4. In the Debug tab, expand the running process and click an activity.

5. In the upper-right corner, click the Job Data tab, and then click the Output tab to check the activity
output.
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Deploying an Application
After testing, if the configured process works as expected, you can deploy the application that contains
the configured process into a runtime environment, and then use the bwadmin utility to manage the
deployed application.

Before deploying an application, you must generate an application archive, which is an enterprise
archive (EAR) file that is created in TIBCO Business Studio. See TIBCO Business Studio Overview to get
familiar with TIBCO Business Studio.

Deploying an application involves the following tasks:

1. Uploading an application archive

2. Deploying an application archive

3. Starting an application

See TIBCO ActiveMatrix BusinessWorks Administration for more details on how to deploy an application.

TIBCO Business Studio Overview
TIBCO Business Studio is an Eclipse-based integration development environment that is used to
design, develop, and test ActiveMatrix BusinessWorks applications.

TIBCO Business Studio provides a workbench in which you can create, manage, and navigate resources
in your workspace. A workspace is the central location on your machine where all data files are stored.

The workbench consists of:

1. Menu: contains menu items such as File, Edit, Diagram, Navigate, Search, Project, Run, Window,
and Help.

2. Toolbar: contains buttons for frequently used commands such as New , Save , Enable/

Disable Business Studio Capabilities , Create a new BusinessWorks Application Module ,

Create a new BusinessWorks Shared Module , Debug , Run , and so on.
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3. Perspective: contains an initial set and layout of views that are required to perform a certain task.
TIBCO Business Studio launches the Modeling perspective by default. You can change the
perspective from the menu Window > Open Perspective > Perspective_Name.

4. View: displays resources. For example, the Project Explorer view displays the ActiveMatrix
BusinessWorks applications, modules, and other resources in your workspace, and the Properties
view displays the properties for the selected resource. You can open a view from the menu Window
> Show View > View_Name.

5. Editor: provides a canvas to configure, edit, or browse a resource. Double-click a resource in a view
to open the appropriate editor for the selected resource. For example, double-click an ActiveMatrix
BusinessWorks process (Process.bwp) in the Project Explorer view to open the process in the editor.

6. Palette: contains a set of widgets and a palette library. A palette groups activities that perform similar
tasks and provide quick access to activities when you configure a process.
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AMQP Connection

The AMQP Connection shared resource contains all the necessary parameters that have to be
configured when you use TIBCO ActiveMatrix BusinessWorks Plug-in for AMQP to connect to the
AMQP server. The AMQP Connection shared resource is used by all the activities in the AMQP palette.

General

The following table lists the fields in the General panel:

Field
Module
Property? Description

Package No The name of the package where the shared resource is added.

Name No The name to be displayed as the label for the shared resource
in the process.

Description No A short description for the shared resource.

AMQP Connection Resource Configuration

The following table lists the fields in the AMQP Connection Resource Configuration panel:

Field
Module
Property? Description

BrokerType No Specifies which broker is used for the connection.
Available brokers are listed as follows:

● Qpid-1-0
● RabbitMQ-0-9
● ActiveMQ-1-0

The default broker is Qpid-1-0.

HostPort Yes The host name or IP address.

VirtualHost Yes The virtual host that specifies the namespace for
entities, such as exchanges and queues.

This field is available only when Qpid-1-0 or
RabbitMQ-0-9 is selected from the Broker
Type list.

Username Yes The user name that you use to get access to the AMQP
server.

Password Yes The password that you use to get access to the AMQP
server.
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Field
Module
Property? Description

ConnectionTimeout(msec) Yes Specifies how long in milliseconds the connection
remains active if no action is performed.

The default value is 3000.

Connection Recovery No If this check box is selected, the connection between the
plug-in and the RabbitMQ server is automatically
recovered after the connection is interrupted.

Retry Interval (msec) Yes Specifies the time period in milliseconds between
successive attempts made to establish an interrupted
connection again.

The default value is 6000.

This field is available only when
ActiveMQ-1-0 or Qpid-1-0 is selected from
the Broker Type list and the Connection
Recovery check box is selected.

Retry Attempts Yes Specifies the times to attempt to establish a connection
after the connection was interrupted.

The default value is 6000.

This field is available only when
ActiveMQ-1-0 or Qpid-1-0 is selected from
the Broker Type list and the Connection
Recovery check box is selected.

NetworkRecoveryInterval(
msec)

Yes Specifies the time period in milliseconds between
successive attempts made to establish an interrupted
connection again.

The default value is 6000.

This field is available only when
RabbitMQ-0-9 is selected from the Broker
Type list and the Connection Recovery check
box is selected.

Test Connection No Click this button to validate the connection.

SSL

The following table lists the fields in the SSL panel:
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Field
Module
Property? Description

Confidentiality No If you want to choose an existing SSL Client shared resource
or create one, select this check box. This shared resource
contains specified SSL information for connection to an
AMQP broker.

See TIBCO ActiveMatrix BusinessWorks documentation for
more details.

SSL Client No Select an SSL Client shared resource to establish a connection
between the plug-in and the specified AMQP broker.
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AMQP Palette

A palette groups the activities that connect to the same external applications together. The AMQP
palette is added to TIBCO Business Studio after installing TIBCO ActiveMatrix BusinessWorks Plug-in
for AMQP.

The AMQP palette contains the following activities:

● AMQPGetMessage

● AMQPReceiveMessage

● AMQPSendMessage

AMQPGetMessage
You can use the AMQPGetMessage activity to retrieve messages from a specified queue.

General

The following table describes the configurations in the General tab of the AMQPGetMessage activity.

Field
Module
Property? Description

Name No Specifies a name of the activity displayed in the process.
The default value is AMQPGetMessage.

Connection Yes
Click  to select an AMQP Connection shared resource.
The AMQP Connection shared resource creates a
connection between the plug-in and an AMQP server.

If no matching AMQP Connection shared resources are
found, click Create Shared Resource to create one. See 
Creating an AMQP Connection for more details.

Queue Name Yes Enter the name for the queue from which the message is
received.

Message Type No Select one of the following message types:

● TextMessage: the message is in the String format.

● BytesMessage: the message is in the Byte stream
format.

● Simple: the message does not have message body.
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Field
Module
Property? Description

Acknowledge Mode No Select one of the following acknowledge modes:

● Auto: the message is automatically acknowledged
when being received.

● Client: the message is acknowledged after being
received by the Confirm activity.

Ensure that the message can be confirmed
when you use the Client mode. If the
message is not confirmed before the process
instance ends, the message is kept as
Unacked status and is still in the queue.

The default value is Auto.

Description

In the Description tab, you can add a short description for the AMQPGetMessage activity.

Output

The following table describes the output elements in the Output tab of the AMQPGetMessage activity.

Output Item Data Type Description

UserProperties Complex The message header consists of the following user
properties:

● name (a String value): the name of the user property.

● type: the property data type. The valid data types
include String, Number, and Boolean.

● value (a String value): the value of the user property.

If the property data type is Boolean, any other
value except for true or True or TRUE is
considered false.
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Output Item Data Type Description

MessageProperties Complex The message properties are listed as follows:

● deliveryMode (a Boolean value): the delivery mode of
the messages. If the value is set to true, the messages
are stored before forwarding. If the value is set to false,
the messages are not stored before forwarding. In this
case, if the transmission failed, the messages might be
lost.

● messageID (a String value): the message ID of the
received message.

● timestamp (an Integer value): the time when the
message is sent to the queue.

● expiration (an Integer value): the time of the message
remains active (in milliseconds).

For Qpid-1-0 and ActiveMQ-1-0, displays
the point in time of the expiration. For
RabbitMQ, displays the active time length.

● priority (an Integer value): the delivery priority of the
message.

● type (a String value): the event type or command type
the message represents.

body String/Byte The message body of the received message:

● If TextMessage is selected from the Message Type list of
the General tab, the message is in the String format.

● If BytesMessage is selected from the Message Type list
of the General tab, the message is in the String format.

If Simple is selected from the Message Type list
of the General tab, the body field is unavailable.

Fault

The following table describes the error schema elements in the Fault tab of the AMQPGetMessage
activity.

Error Schema Element Description

AMQPPluginException This error message is displayed when the plug-in captures any
exception related to the process of sending a message to an AMQP
broker.

AMQPConnectionException This error message is displayed when any exception about the
connection problem occurs in the process of sending a message to
an AMQP broker.
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AMQPReceiveMessage
You can start a process with the AMQPReceiveMessage activity. The process is triggered when the
plug-in receives a message from a specified AMQP broker queue.

General

The following table lists the configurations in the General tab of the AMQPReceiveMessage activity.

Field
Module
Property? Description

Name No The name of the activity displayed in the process.
The default value is AMQPReceiveMessage.

Connection Yes
Click  to select an AMQP Connection shared
resource. The AMQP Connection shared resource
creates a connection between the plug-in and an
AMQP server.

If no matching AMQP Connection shared
resources are found, click Create Shared Resource
to create one. See Creating an AMQP Connection
for more details.

Queue Name Yes Enter the name for the queue from which the
message is received.

Message Type No Select one of the following message types:

● TextMessage: the message is in the string
format.

● BytesMessage: the message is in the byte
stream format.

● Simple: the message does not have message
body.

Acknowledge Mode No Select one of the following acknowledge modes:

● Auto: the message is automatically
acknowledged when being received.

● Client: the message is acknowledged after
being received by the Confirm activity.

Ensure that the message can be
confirmed when you use the Client
mode. If the message is not
confirmed before the process instance
ends, the message is kept as Unacked
status and is still in the queue.

The default value is Auto.
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Description

In the Description tab, you can add a short description for the AMQPReceiveMessage activity.

Advanced

The following table describes the configurations in the Advanced tab of the AMQPReceiveMessage
activity.

Field
Module
Property? Description

Sequence Key No This field contains an XPath expression that specifies the
order in which the process runs. Process instances with
sequencing keys that have the same value are executed
sequentially in the order in which the process instances
are created.

See the TIBCO ActiveMatrix BusinessWorks
documentation for more details.

Custom Job Id No This field contains an XPath expression that specifies a
custom job ID for every job in the process instance.

See the TIBCO ActiveMatrix BusinessWorks
documentation for more details.

Conversations

In the Conversations tab, you can click the Add New Conversation  icon to initiate a conversation.
A conversation represents two or more related message exchanges in the same process that are
correlated by the BusinessWorks engine.

Output

The following table describes the output elements in the Output tab of the AMQPReceiveMessage
activity.

Output Item Data Type Description

UserProperties Complex The message header consists of the following user
properties:

● name (a String value): the name of the user property.

● type: the property data type. The valid data types
include String, Number, Boolean.

● value (a String value): the value of the user property.

If the property data type is Boolean, any other
value except for true or True or TRUE is
considered false.
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Output Item Data Type Description

MessageProperties Complex The message properties are listed as follows:

● deliveryMode (a Boolean value): the delivery mode of
the messages. If the value is set to true, the messages
are stored before forwarding. If the value is set to false,
the messages are not stored before forwarding. In this
case, if the transmission failed, the messages might be
lost.

● messageID (a String value): the message ID of the
received message.

● timestamp (an Integer value): the time when the
message is sent to the queue.

● expiration (an Integer value): the time of the message
remains active (in milliseconds).

For Qpid-1-0 and ActiveMQ-1-0, displays
the point in time of the expiration. For
RabbitMQ, displays the active time length.

● priority (an Integer value): the delivery priority of the
message.

● type (a String value): the event type or command type
the message represents.

body String/Byte The message body of the received message:

● If TextMessage is selected from the Message Type list of
the General tab, the message is in the String format.

● If BytesMessage is selected from the Message Type list
of the General tab, the message is in the String format.

If Simple is selected from the Message Type list
of the General tab, the body field is unavailable.

AMQPSendMessage
You can use the AMQPSendMessage activity to send messages to a specified destination.

General

The following table describes the configurations in the General tab of the AMQPSendMessage activity.

Field
Module
Property? Description

Name No The name of the activity displayed in the process. The default
value is AMQPSendMessage.
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Field
Module
Property? Description

Connection Yes
Click  to select an AMQP Connection shared resource.
The AMQP Connection shared resource creates a connection
between the plug-in and an AMQP server.

If no matching AMQP Connection shared resources are
found, click Create Shared Resource to create one. See 
Creating an AMQP Connection for more details.

Protocol Version No Select the AMQP protocol version. For this release, AMQP
protocol 1.0 (AMQP-1-0) is supported with Qpid-1-0 or
ActiveMQ-1-0 broker; and AMQP protocol 0.9 (AMQP-0-9) is
supported with RabbitMQ-0-9 broker.

The default value is AMQP-1-0.

Queue Name Yes Enter the queue name to which the message is published.

This field is unavailable when RabbitMQ-0-9 is
selected from the BrokerType list of the used
AMQP Connection shared resource.

Exchange Type No The type of the exchange. The valid types are listed as
follows:

● direct
● topic
● fanout
● headers

This field is only available when RabbitMQ-0-9 is
selected from the BrokerType list of the used
AMQP Connection shared resource.

Exchange Name Yes The name of the exchange.

This field is only available when RabbitMQ-0-9 is
selected from the BrokerType list of the used
AMQP Connection shared resource.

Routing Key Yes The routing key of the exchange. This field is only required
when direct or topic is selected as the exchange type.

This field is only available when RabbitMQ-0-9 is
selected from the BrokerType list of the used
AMQP Connection shared resource.
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Field
Module
Property? Description

Message Type No Select one of the following message types:

● TextMessage: the message is in the string format.

● BytesMessage: the message is in the byte stream format.

● Simple: the message does not have message body.

User Properties No Right-click inside the User Properties text box and click the

Add Parameter  icon to add a user property. To delete a

user property, click the Delete  icon.

Specify the following fields in this text box:

● name (a String value): the name of the user property.

● type: the property data type. The valid data types include
String, Number, Boolean.

● value (a String value): the value of the user property.

If the property data type is Boolean, any other
value except for true or True or TRUE is
considered false.

Description

In the Description tab, you can add a short description for the AMQPSendMessage activity.

Advanced

The following table describes the configurations in the Advanced tab of the AMQPSendMessage
activity.

Field
Module
Property? Description

Delivery Mode No Select one of the following delivery modes:

● Persistent: the messages are stored before forwarding.

● Non-Persistent: the messages are not stored before
forwarding. If the transmission failed, the messages might
be lost.

Expiration(msec) No Corresponds to the Expiration property that specifies how
long the message remains active (in milliseconds). The
default value is 0, which means the message remains active
permanently.
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Field
Module
Property? Description

Priority No Specifies the priority of the message. The value ranges from 0
to 9.

The default value is 4.

Type Yes Specifies the event type or command type this message
represents.

Input

The following table describes the input elements in the Input tab of the AMQPSendMessage activity.

The values entered in the following fields must be entered in single quotation marks (' '), or double
quotation marks (" ").

Input Item Data Type Description

name String Enter the name of the user property.

The value entered in this field overwrites the value
entered in the User Properties field of the General
tab.

type String Enter one of the following types for the user property:

● Boolean

● Number

● String

The value entered in this field overwrites the value entered in
the User Properties field of the General tab.

value String Enter the value of the user property.

The value entered in this field overwrites the value entered in
the User Properties field of the General tab.

deliveryMode String Right-click this element and click Enumerations to select one
of the following delivery modes for the message, or enter the
value in this field:

● Persistent

The message is stored and forwarded.

● Non-Persistent

The message is not stored and might be lost due to
transmission failure.

The value entered in this field overwrites the item selected
from the Delivery Mode list of the Advanced tab.
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Input Item Data Type Description

messageID String Enter the message ID for the message, such as "ID:
1234567891A".

If you leave this field blank, a random message ID is given.

expiration Integer Enter the expiration value of the message.

The value entered in this field overwrites the value entered in
the Expiration(msec) field of the Advanced tab.

priority Integer Enter the priority level for sending the message.

The value entered in this field overwrites the value entered in
the Priority field of the Advanced tab.

type String Enter the type for the message.

The value entered in this field overwrites the value entered in
the Type field of the Advanced tab.

body String/Byte The message body of the received message:

● If TextMessage is selected from the Message Type list of
the General tab, the message is in the String format.

● If BytesMessage is selected from the Message Type list of
the General tab, the message is in the String format.

If Simple is selected from the Message Type list of
the General tab, the body field is unavailable.

Output

The following table describes the output elements in the Output tab of the AMQPSendMessage activity.

Output Item Data Type Description

sendResult Boolean The result after sending the message. If the message is
successfully sent, the value is true.

Fault

The following table describes the error schema elements in the Fault tab of the AMQPSendMessage
activity.

Error Schema Element Description

AMQPPluginException This error message is displayed when the plug-in captures any
exception related to the process of sending a message to an AMQP
broker.

AMQPConnectionException This error message is displayed when any exception occurs about
the connection problem that is in the process of sending a message
to an AMQP broker.
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Working with the Sample Project

The plug-in packages three sample projects with the installer. The sample projects show how TIBCO
ActiveMatrix BusinessWorks Plug-in for AMQP works.

After installing the plug-in, you can locate the sample file in the TIBCO_HOME/bw/palettes/amqp/
version_number/samples directory. This sample file contains three projects:

● ActiveMQ_1-0

This project shows how to use the ActiveMQ_1-0 broker to get, receive, and send messages.

● QPID_1-0

This project shows how to use the QPID_1-0 broker to get, receive, and send messages.

● RabbitMQ_0-9

This project shows how to use the RabbitMQ_0-9 broker to get, receive, and send messages.

Importing the Sample Projects
Before running the project, you must import the sample projects to TIBCO Business Studio.

Procedure

1. Start TIBCO Business Studio using one of the following ways:

● Microsoft Windows: click Start > All Programs > TIBCO > TIBCO_HOME > TIBCO Business
Studio version_number > Studio for Designers.

● Mac OS and Linux: run the TIBCO Business Studio executable file located in the TIBCO_HOME/
studio/version_number/eclipse directory.

2. From the menu, click File > Import.

3. In the Import window, expand the General folder and select the Existing Studio Projects into
Workspace item. Click Next.

4. Click Browse next to the Select archive file field to select the example.zip file. Click Finish.
The example.zip file is located in the TIBCO_HOME/bw/palettes/amqp/version_number/samples
directory.

Result

The sample projects are imported to TIBCO Business Studio.
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Configuring the AMQP Connection
Configuring the AMQP Connection shared resource is essential for the plug-in to establish a connection
to the AMQP server.

Prerequisites

Ensure that you have imported the sample projects, as described in Importing the Sample Projects.

Procedure

1. In the Project Explorer view, expand Project_name > Resources > bundle_name.

2. Double-click AMQPConnectionResource.amqpconnectionResource.

3. In the AMQP Connection editor, configure each field accordingly.
See AMQP Connection for more details.

4. Click Test Connection to validate the connection.

5. On the toolbar, click the Save  icon to save your changes.

Running the Sample Project
The sample projects show how to use the plug-in to get, receive, and send messages by using
ActiveMQ-1-0, Qpid-1-0 and RabbitMQ-0-9 brokers.

Prerequisites

Ensure that you have configured the AMQP Connection shared resource, as described in Configuring
the AMQP Connection.

Procedure

1. In the Project Explorer view, click Project_name > Module Descriptors resource, and then double-
click Components.

2. By default, all the processes are listed in the Components editor. Select the process that you do not

want to run and click the remove selected component  icon.
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3. On the toolbar, click the Save  icon to save your changes.

4. From the menu, click Run > Run Configurations to run the selected process.

5. In the Run Configurations dialog, expand BusinessWorks Application, and then click
BWApplication.

6. In the right panel, click the Applications tab, and select the check box next to Exemple_name.

7. Click Run to run the selected process.

8. Click the Terminate  icon to stop the process.
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Managing Logs

When an error occurs, check logs to trace and troubleshoot the plug-in exceptions.

By default, error logs are displayed in the Console view when you run a process in debug mode. You
can change the log level of the plug-in to trace different messages and export logs to a file. Different log
levels correspond to different messages, as described in Log Levels.

Log Levels
Different log levels include different information.

The plug-in supports the following log levels.

Log Level Description

Debug Indicates a developer-defined tracing message.

Info Indicates normal plug-in operations. No action is required. A tracing message
tagged with Info indicates that a significant processing step is reached, and
logged for tracking or auditing purposes. Only info messages preceding a
tracking identifier are considered as significant steps.

Error Indicates that an unrecoverable error occurred. Depending on the severity of
the error, the plug-in might continue with the next operation or might stop.

Setting Up Log Levels
You can configure a different log level for the plug-in and plug-in activities to trace different messages.

If you do not configure any log levels, the plug-in uses the default log level of TIBCO ActiveMatrix
BusinessWorks. The default log level is Error.

Procedure

1. Navigate to the TIBCO_HOME/bw/version_number/config/design/logback directory and open
the logback.xml file.

2. Add the following node in the BusinessWorks Palette and Activity loggers area to specify a log
level for the plug-in:
<logger name="com.tibco.bw.palette.amqp.runtime">
   <level value="DEBUG"/>
</logger>

The value of the level element can be Error, Info, or Debug.

If you set the log level to Debug, the input and output for the plug-in activities are also
displayed in the Console view. See Log Levels for more details regarding each log level.

3. Optional: Add different nodes in the BusinessWorks Palette and Activity loggers area to specify
different log levels for the activities and shared resources.
For the AMQP Connection shared resource, add the following node:
<logger name="com.tibco.bw.sharedresource.amqp.runtime">
   <level value="DEBUG"/>
</logger>
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For the AMQPReceiveMessage activity, add the following node:
<logger name="com.tibco.bw.palette.amqp.runtime.receive.AmqpReceiveEventSource">
   <level value="DEBUG"/> 
</logger>

For the AMQPSendMessage activity, add the following node:
<logger name="com.tibco.bw.palette.amqp.runtime.send.AmqpSendActivity">
   <level value="DEBUG"/>
</logger>

For the AMQPGetMessage activity, add the following node:
<logger name="com.tibco.bw.palette.amqp.runtime.getamqp.AmqpGetMessageActivity"> 
   <level value="DEBUG"/> 
</logger>

The activities that are not configured with specific log levels use the log level configured
for the plug-in.

4. Save the file.

Exporting Logs to a File
You can update the logback.xml file to export plug-in logs to a file.

Procedure

1. Navigate to the TIBCO_HOME/bw/version_number/config/design/logback directory and open
the logback.xml file.

After deploying an application in TIBCO Enterprise Administrator, navigate to the
TIBCO_HOME/bw/version_number/domains/domain_name/appnodes/space_name/

node_name directory to find the logback.xml file.

2. Add the following node to specify the file where the log is exported:
<appender name="FILE" class="ch.qos.logback.core.FileAppender">
   <file>c:/bw6-amqp.log</file>
      <encoder>
        <pattern>%d{HH:mm:ss.SSS} [%thread] %-5level %logger{36}-%msg%n</pattern>
      </encoder>
</appender>

The value of the file element is the absolute path of the file that stores the exported log.

3. Add the following node to the root node at the bottom of the logback.xml file:
<root level="DEBUG">
   <appender-ref ref="STDOUT"/>
   <appender-ref ref="FILE"/>
</root>

4. Save the file.
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Error Codes

The following table lists error codes, detailed explanation of each error, and where applicable, ways to
solve different errors.

Error Code and Error
Message Role Category Description Solution

ERROR_OCCURED_RE
TRIEVE_RESULT.errorC
ode=500002

IOException occurred

while retrieving XML

Output for activity

[{0}].

errorRole BW-Plug-in Occurs when an
activity retrieves an
XML output.

None.

ERROR_OCCURED_IN
VOKE_EXECUTE_MET
HOD.errorCode=500003

Exception occurred

while invoking

execute method for

activity [{0}].

errorRole BW-Plug-in Occurs when an
activity invokes an
execute method.

None.

ERROR_OCCURED_PRI
ORITY.errorCode=50000
4

The provided

priority: {0} is

invalid in AMQP,

valid values are

from 0 to 9.

errorRole BW-Plug-in The provided priority
is invalid in AMQP.

Specify a valid
priority value.

ERROR_OCCURED_GE
NERATE_URL.errorCod
e=500006

Error occurred while

attempting to

generate URL.

errorRole BW-Plug-in Occurs when the
plug-in generates a
URL.

None.

AMQP_SEND_ERROR.e
rrorCode=500007

Error occurred while

attempting to send a

message {0}.

errorRole BW-Plug-in Occurs when an
activity sends a
message.

None.
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Error Code and Error
Message Role Category Description Solution

AMQP_DEBUG_INFOR
MATION.errorCode=500
008

Error occurred while

attempting to parse

plain URL.

errorRole BW-Plug-in Occurs when an
activity parses a plain
URL.

None.

ERROR_OCCURED_GE
T_XML_FROM_SERIAL
IZED_OBJECT.errorCod
e=500009

Error occurred while

attempting to get

XML Output from

serialized object.

errorRole BW-Plug-in Occurs when an
activity gets an XML
output from serialized
object.

None.

ERROR_OCCURED_GE
T_MESSAGE_CONTEN
T.errorCode=500010

Error occurred while

attempting to get

message content:

{0}.

errorRole BW-Plug-in Occurs when an
activity gets a
message content.

None.

ERROR_OCCURED_ST
ART_CONNECTION.er
rorCode=500011

Error occurred while

attempting to start

javax.jms.Connection

: {0}.

errorRole BW-Plug-in Occurs when a
javax.jms.connection
is started.

None.

ERROR_OCCURED_ST
OP_CONNECTION.erro
rCode=500012

Error occurred while

attempting to stop

javax.jms.Connection

: {0}.

errorRole BW-Plug-in Occurs when a
javax.jms.connection
is stopped.

None.

ERROR_OCCURED_CL
OSE_CONNECTION.err
orCode=500013

Error occurred while

attempting to close

javax.jms.Connection

: {0}.

errorRole BW-Plug-in Occurs when a
javax.jms.connection
is closed.

None.
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Error Code and Error
Message Role Category Description Solution

ERROR_OCCURED_GE
NERATE_CONNECTIO
N_FILE.errorCode=5000
14

Error occurred while

attempting to

generate connection

file: {0}.

errorRole BW-Plug-in Occurs when the
plug-in generates a
connection file.

None.

ERROR_OCCURED_CR
EATE_CONNECTION.e
rrorCode=500015

Error occurred while

attempting to create

connection: {0}.

errorRole BW-Plug-in Occurs when the
plug-in creates a
connection.

None.

ERROR_OCCURED_INI
TIALIZE_CONNECTIO
NFACTORY.errorCode=
500016

Error occurred while

attempting to

initialize a

connection factory:

{0}.

errorRole BW-Plug-in Occurs when the
plug-in initializes a
connection factory.

None.

ERROR_OCCURED_CR
EATE_TEXT_MESSAGE
.errorCode=500017

Error occurred while

attempting to create

text message from

Session.

errorRole BW-Plug-in Occurs when the
plug-in creates a text
message from a
session.

None.

ERROR_OCCURED_RE
CEIVE_MESSAGE.error
Code=500018

Error occurred while

receive message:

{0}.

errorRole BW-Plug-in Occurs when an
activity receives a
message.

None.

ERROR_OCCURED_INI
TIALIZE_CHANNEL.er
rorCode=500019

Error occurred while

attempting to

initialize channel :

{0}.

errorRole BW-Plug-in Occurs when the
plug-in initializes a
channel.

None.
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Error Code and Error
Message Role Category Description Solution

ERROR_OCCURED_CL
OSE_CHANNEL.errorC
ode=500020

Error occurred while

attempting to close

channel.

errorRole BW-Plug-in Occurs when the
plug-in closes a
channel.

None.

ERROR_OCCURED_FIL
E_NOT_FIND.errorCod
e=500021

Error occurred while

attempting to find

file {0}.

errorRole BW-Plug-in Occurs when the
plug-in finds a file.

None.

ERROR_OCCURED_INI
TIALIZE_BROKER_TYP
E.errorCode=500022

Error occurred while

attempting to

initialize Broker

type.

errorRole BW-Plug-in Occurs when the
plug-in initializes a
broker type.

None.

ERROR_OCCURED_CL
OSE_CHANNEL_TIME
OUT.errorCode=500023

Timeout error

occurred while

attempting to close

channel.

errorRole BW-Plug-in A timeout error
occurs when closing a
channel.

None.

ERROR_OCCURED_CR
EATE_CONNECTION_
TIMEOUT.errorCode=50
0024

Timeout error

occurred while

attempting to create

new connection.

errorRole BW-Plug-in A timeout error
occurs when creating
a new connection.

None.

ERROR_OCCURED_US
ER_PROPERTY_INVALI
D.errorCode=500025

Data type and value

mismatch error

occurred for user

property name: {0}.

errorRole BW-Plug-in The data type and
value do not match
the user property
name.

None.
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Error Code and Error
Message Role Category Description Solution

ERROR_OCCURED_SE
ND_MESSAGE_UNKN
OWN.errorCode=500026

Error occurred while

attempting to send

message for unknown

issues: {0}.

errorRole BW-Plug-in Occurs when an
activity sends a
message for unknown
issues.

None.

ERROR_OCCURED_SE
ND_MESSAGE_INVALI
D_DESTINATION.error
Code=500027

Invalid Queue name:

{0} detected. Please

provide valid Queue

name.

errorRole BW-Plug-in The provided queue
name is invalid.

Specify a Provide a
valid queue name.

ERROR_OCCURED_SE
ND_MESSAGE_INVALI
D_DESTINATION.error
Code=500028

Error occurred while

attempting to create

queue name: {0}.

errorRole BW-Plug-in Occurs when the
plug-in creates a
queue name.

None.

ERROR_OCCURED_SE
ND_MESSAGE_INVALI
D_DESTINATION.error
Code=500029

Error occurred while

attempting to get

queue name.

errorRole BW-Plug-in Occurs when the
plug-in gets a queue
name.

None.

ERROR_OCCURED_SE
ND_MESSAGE_INVALI
D_DESTINATION.error
Code=500030

The provided

delivery mode: {0}

is invalid in AMQP,

valid values should

be Persistent or

Non-Persistent.

errorRole BW-Plug-in The provided delivery
mode is invalid.

Specify a valid
delivery mode.
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Error Code and Error
Message Role Category Description Solution

ERROR_OCCURED_SE
ND_MESSAGE_INVALI
D_DESTINATION.error
Code=500031

Error occurred while

attempting to close

session.

errorRole BW-Plug-in Occurs when the
plug-in closes a
session.

None.
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