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Important Information

SOME TIBCO SOFTWARE EMBEDS OR BUNDLES OTHER TIBCO SOFTWARE. USE OF SUCH
EMBEDDED OR BUNDLED TIBCO SOFTWARE IS SOLELY TO ENABLE THE FUNCTIONALITY (OR
PROVIDE LIMITED ADD-ON FUNCTIONALITY) OF THE LICENSED TIBCO SOFTWARE. THE
EMBEDDED OR BUNDLED SOFTWARE IS NOT LICENSED TO BE USED OR ACCESSED BY ANY
OTHER TIBCO SOFTWARE OR FOR ANY OTHER PURPOSE.

USE OF TIBCO SOFTWARE AND THIS DOCUMENT IS SUBJECT TO THE TERMS AND
CONDITIONS OF A LICENSE AGREEMENT FOUND IN EITHER A SEPARATELY EXECUTED
SOFTWARE LICENSE AGREEMENT, OR, IF THERE IS NO SUCH SEPARATE AGREEMENT, THE
CLICKWRAP END USER LICENSE AGREEMENT WHICH IS DISPLAYED DURING DOWNLOAD
OR INSTALLATION OF THE SOFTWARE (AND WHICH IS DUPLICATED IN THE LICENSE FILE)
OR IF THERE IS NO SUCH SOFTWARE LICENSE AGREEMENT OR CLICKWRAP END USER
LICENSE AGREEMENT, THE LICENSE(S) LOCATED IN THE “LICENSE” FILE(S) OF THE
SOFTWARE. USE OF THIS DOCUMENT IS SUBJECT TO THOSE TERMS AND CONDITIONS, AND
YOUR USE HEREOF SHALL CONSTITUTE ACCEPTANCE OF AND AN AGREEMENT TO BE
BOUND BY THE SAME.

ANY SOFTWARE ITEM IDENTIFIED AS THIRD PARTY LIBRARY IS AVAILABLE UNDER
SEPARATE SOFTWARE LICENSE TERMS AND IS NOT PART OF A TIBCO PRODUCT. AS SUCH,
THESE SOFTWARE ITEMS ARE NOT COVERED BY THE TERMS OF YOUR AGREEMENT WITH
TIBCO, INCLUDING ANY TERMS CONCERNING SUPPORT, MAINTENANCE, WARRANTIES,
AND INDEMNITIES. DOWNLOAD AND USE THESE ITEMS IS SOLELY AT YOUR OWN
DISCRETION AND SUBJECT TO THE LICENSE TERMS APPLICABLE TO THEM. BY PROCEEDING
TO DOWNLOAD, INSTALL OR USE ANY OF THESE ITEMS, YOU ACKNOWLEDGE THE
FOREGOING DISTINCTIONS BETWEEN THESE ITEMS AND TIBCO PRODUCTS.

This document contains confidential information that is subject to U.S. and international copyright laws
and treaties. No part of this document may be reproduced in any form without the written
authorization of TIBCO Software Inc.

TIBCO and Two-Second Advantage are either registered trademarks or trademarks of TIBCO Software
Inc. in the United States and/or other countries.

Enterprise Java Beans (EJB), Java Platform Enterprise Edition (Java EE), Java 2 Platform Enterprise
Edition (J2EE), and all Java-based trademarks and logos are trademarks or registered trademarks of
Oracle Corporation in the U.S. and other countries.

All other product and company names and marks mentioned in this document are the property of their
respective owners and are mentioned for identification purposes only.

THIS SOFTWARE MAY BE AVAILABLE ON MULTIPLE OPERATING SYSTEMS. HOWEVER, NOT
ALL OPERATING SYSTEM PLATFORMS FOR A SPECIFIC SOFTWARE VERSION ARE RELEASED
AT THE SAME TIME. SEE THE README FILE FOR THE AVAILABILITY OF THIS SOFTWARE
VERSION ON A SPECIFIC OPERATING SYSTEM PLATFORM.

THIS DOCUMENT IS PROVIDED “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS
OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

THIS DOCUMENT COULD INCLUDE TECHNICAL INACCURACIES OR TYPOGRAPHICAL
ERRORS. CHANGES ARE PERIODICALLY ADDED TO THE INFORMATION HEREIN; THESE
CHANGES WILL BE INCORPORATED IN NEW EDITIONS OF THIS DOCUMENT. TIBCO
SOFTWARE INC. MAY MAKE IMPROVEMENTS AND/OR CHANGES IN THE PRODUCT(S)
AND/OR THE PROGRAM(S) DESCRIBED IN THIS DOCUMENT AT ANY TIME.

THE CONTENTS OF THIS DOCUMENT MAY BE MODIFIED AND/OR QUALIFIED, DIRECTLY OR
INDIRECTLY, BY OTHER DOCUMENTATION WHICH ACCOMPANIES THIS SOFTWARE,
INCLUDING BUT NOT LIMITED TO ANY RELEASE NOTES AND "READ ME" FILES.

Copyright © 2017 TIBCO Software Inc. ALL RIGHTS RESERVED.
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TIBCO Documentation and Support Services

How to Access TIBCO Documentation

Documentation for TIBCO products is available on the TIBCO Product Documentation website, mainly
in HTML and PDF formats.

The TIBCO Product Documentation website is updated frequently and is more current than any other
documentation included with the product. To access the latest documentation, visit https://
docs.tibco.com.

Product-Specific Documentation

The following documents for this product can be found on the TIBCO Documentation site:

● TIBCO ActiveMatrix BusinessWorks™ Plug-in for Amazon SQS and SNS Installation.

● TIBCO ActiveMatrix BusinessWorks™ Plug-in for Amazon SQS and SNS User's Guide.

● TIBCO ActiveMatrix BusinessWorks™ Plug-in for Amazon SQS and SNS Release Notes.

How to Contact TIBCO Support

You can contact TIBCO Support in the following ways:

● For an overview of TIBCO Support, visit http://www.tibco.com/services/support.

● For accessing the Support Knowledge Base and getting personalized content about products you are
interested in, visit the TIBCO Support portal at https://support.tibco.com.

● For creating a Support case, you must have a valid maintenance or support contract with TIBCO.
You also need a user name and password to log in to https://support.tibco.com. If you do not have a
user name, you can request one by clicking Register on the website.

How to Join TIBCO Community

TIBCO Community is the official channel for TIBCO customers, partners, and employee subject matter
experts to share and access their collective experience. TIBCO Community offers access to Q&A forums,
product wikis, and best practices. It also offers access to extensions, adapters, solution accelerators, and
tools that extend and enable customers to gain full value from TIBCO products. In addition, users can
submit and vote on feature requests from within the TIBCO Ideas Portal. For a free registration, go to 
https://community.tibco.com.
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Installation Overview

You can install TIBCO ActiveMatrix BusinessWorks™ Plug-in for Amazon SQS and SNS either by using
TIBCO Universal Installer or an update site.

● TIBCO Universal Installer

You can install the plug-in by using TIBCO Universal Installer, which provides three installation
modes.

For more information, see Using TIBCO Universal Installer.

● Update Site

You can install the plug-in from within TIBCO Business Studio™ using the public update site
maintained by TIBCO or using a local update site managed by your organization.

For more information, see Using Update Site.

Install the plug-in into an existing installation environment where TIBCO ActiveMatrix BusinessWorks
is already installed. The installation environment of TIBCO ActiveMatrix BusinessWorks is referred to
as TIBCO_HOME. On Microsoft Windows, the default value of TIBCO_HOME is C:\Program Files
\tibco\bw6.
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Installation Requirements

Before you run the installer, ensure that your system meets all the hardware and software requirements
and you have appropriate privileges to run the installer.

Installation Account
To install on Microsoft Windows, Linux, or on Mac OS, you must have appropriate privileges.
Privileges differ for various platforms.

Use the same installer account to install all TIBCO ActiveMatrix BusinessWorks products.

Platform Account Privileges

Microsoft Windows Only users with administrator privileges can install the plug-in. If you
do not have administrator privileges, the installer automatically exits.

To install the product on a network drive, ensure that the account used
for installation has permission to access the network drive.

Linux Any type of user, regular user (non-root) and super-user (root), can
perform the installation on Linux.

A graphic environment such as CDE or X Windows is required to run
the installer in GUI mode.

Mac OS Any type of user, regular user (non-root) and super-user (root), can
perform the installation on Mac OS.

System Requirements
Ensure that your system meets the hardware and software requirements before installing the plug-in.

Platform

Before you run the installer, ensure that the appropriate platform is supported. See the readme file for
information regarding supported operating system platforms, versions, and the required patches.

Disk Space

The installer requires some space in the temporary directory before installation, and additional space in
the temporary directory to run the installer. Ensure that sufficient space is available in the directory that
you want to use as the installation environment (TIBCO_HOME).

When installing the product, avoid running other processes that use disk space in the installation
environment directory. If another process uses disk space while the installer is copying files, the
installer might fail and display a failure message.

Software

Ensure that you have installed the required software before you run the installer. See the readme file for
supported products and versions.

The following table lists the useful TIBCO products:
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Software Description

TIBCO ActiveMatrix
BusinessWorks™

Required.

ActiveMatrix BusinessWorks™ supports your integration project
throughout the project life cycle. It includes a common graphical user
interface for configuration, process design, and deployment.

TIBCO® Enterprise
Administrator

Optional.

TIBCO Enterprise Administrator consists of a TIBCO Enterprise
Administrator server, a web user interface for the server, and a shell
interface, with which you can manage the applications that you create
in TIBCO Business Studio™.
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Using TIBCO Universal Installer

TIBCO Universal Installer provides three modes to install TIBCO ActiveMatrix BusinessWorks™ Plug-
in for Amazon SQS and SNS .

Installer Overview
You can use TIBCO Universal Installer to install and uninstall TIBCO ActiveMatrix BusinessWorks™
Plug-in for Amazon SQS and SNS .

If this is your first time using TIBCO Universal Installer to install the plug-in, it is good practice to
review the following topics before the installation:

● Installation Modes

● Installation Environment

● Installation Components

If a previous version of the plug-in is already installed in the TIBCO_HOME where the new version is
to be installed, you must uninstall the previous version before installing the new version.

Installation Modes
You can run TIBCO Universal Installer in GUI, console or silent mode. Each mode is supported on all
platforms.

GUI Mode

In GUI mode, the installer displays panels where you can select a product, product location, and so on.
To invoke the installer in GUI mode, double-click the executable file.

Console Mode

In console mode, you can run the installer on a command line. This is useful if your machine does not
have a GUI environment.

Silent Mode

In silent mode, the installer installs the product without prompting you for information. The installer
uses either default or custom settings that are saved in a response file.

Installation Environment
An installation environment isolates product installations. A product installed into one installation
environment cannot access components in the other installation environments.

An installation environment is the top level installation directory for TIBCO products. An installation
environment consists of the following properties:

● Directory

Identifies the directory where the product is installed.

● Name

Identifies the name of the folder where the product is installed.
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Installation Components
Different installation components are associated with different functions. Using TIBCO Universal
Installer, you can select installation components during the installation.

Installation components are grouped into different installation profiles. One installation profile is
associated with one or more installation components. When you select a profile, the components
grouped to the selected profile are installed. By default, the Typical installation profile is selected,
therefore, all the installation components are installed.

The following installation components are available for the plug-in:

Component Description

TIBCO ActiveMatrix
BusinessWorks™ Plug-in for
Amazon SQS and SNS

This component includes the palettes, shared resources, and
samples that show how the plug-in interacts with TIBCO
ActiveMatrix BusinessWorks™ . You can configure your own
business process in TIBCO Business Studio™ with an Eclipse user
interface.

This component cannot be installed alone without the
runtime component.

TIBCO ActiveMatrix
BusinessWorks™ Plug-in for
Amazon SQS and SNS
Runtime

This component passes and converts data to and from vendor
applications. The parameters of data exchange are stored in projects
that are created using the plug-in palette.

Installation
When using TIBCO Universal Installer, you can install the plug-in in GUI, console or silent mode.

Ensure that your system meets all the requirements described in the Installation Requirements section.

The plug-in must be installed into an existing installation environment where TIBCO ActiveMatrix
BusinessWorks™ is installed. Stop all running processes in the installation environment before the
installation.

Installing in GUI Mode
In GUI mode, the installer prompts you for information regarding the installation environment,
installation profile and other installation information.

Procedure

1. Open the physical media or download the installation package from the TIBCO eDelivery site
(https://edelivery.tibco.com).
To download the installation package, a user name and password are required. If you do not have a
user name and password, contact TIBCO Technical Support.

2. Extract the content of the installation package to a temporary directory.

3. Use the extracted installation package to start the installation in one of the following ways:

● On Microsoft Windows, double-click TIBCOUniversalInstaller.exe.

● On Linux, run TIBCOUniversalInstaller-platform_acronym.bin.

● On Mac OS, double-click TIBCOUniversalInstaller-mac.command.
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4. In the Welcome dialog, click Next.

5. In the License Agreement dialog, read through the license agreement and click I accept the terms of
the license agreement. Click Next.

6. In the TIBCO Installation Home dialog, click Use an existing TIBCO_HOME to select an existing
installation environment where TIBCO ActiveMatrix BusinessWorks is installed. Click Next.
See Installation Environment for more details.

7. In the Installation Profile Selection dialog, select an installation profile to specify the installation
components to be installed or select the Customize Installation check box to select the installation
components. Click Next.
For more information, refer Installation Components.

8. In the Pre-Install Summary dialog, review the list of products selected for the installation. Click
Install.

9. In the Post Install Summary dialog, review the list of the installation information. Click Finish to
complete the installation process and exit the installer.

Installing in Console Mode
In console mode, you can run the installer on a command line.

Procedure

1. Open the physical media or download the installation package from the TIBCO eDelivery site
(https://edelivery.tibco.com).
To download the installation package, a user name and password are required. If you do not have a
user name and password, contact TIBCO Technical Support.

2. Extract the content of the package to a temporary directory.

3. On a command line, navigate to the temporary directory to which you extracted the installation
package.

4. Run the following command to start the installation:

● On Microsoft Windows: TIBCOUniversalInstaller.cmd -console
● On Linux: ./TIBCOUniversalInstaller-platform_acronym.bin -console
● On Mac OS: ./TIBCOUniversalInstaller-mac.command -console

5. Respond to the messages on the command line.
The installation options are the same as GUI Mode. See Installing in GUI Mode for more details.

6. When the installation is completed, press Enter to exit the installer.

Installing in Silent Mode
In silent mode, you can run the installer without user input by pointing the installer to an existing
response file.

A default response file named TIBCOUniversalInstaller_bwpluginawsm_version.silent is
packaged with TIBCO Universal Installer. Before launching the silent installation, you have to edit the
response file with information about your environment. It is good practice to make a copy of the default
response file, and then edit that file and use it for the installation.

● If you invoke the installer with the -silent argument, the installer reads the input from default
response file.

● If you invoke the installer with the -silent -V responseFile=<filename> argument, the installer
reads the input from the specified response file.

11

TIBCO ActiveMatrix BusinessWorks™ Plug-in for Amazon SQS and SNS Installation

https://edelivery.tibco.com


Procedure

1. Open the physical media or download the package from the TIBCO eDelivery site (https://
edelivery.tibco.com).
To download the installation package, a user name and password are required. If you do not have a
user name and password, contact TIBCO Technical Support.

2. Extract the content of the package to a temporary directory and open the
TIBCOUniversalInstaller_bwpluginawsm_version.silent file.

3. Update the response file directly or make a copy of the response file first, and then update the
copied file.

4. On the command line, navigate to the temporary directory where you have extracted the
installation package.

5. Enter the following command to start the installation:

● On Microsoft Windows: TIBCOUniversalInstaller.cmd -silent [-V
responseFile="filename"]

● On Linux: TIBCOUniversalInstaller-platform_acronym.bin -silent [-V
responseFile="filename"]

● On Mac OS: TIBCOUniversalInstaller-mac.command -silent [-V
responseFile="filename"]

If you copy the response file to another directory, not the temporary directory containing
the installer, you have to provide the absolute path of the response file.

Uninstallation
You can uninstall the plug-in in GUI or console mode when using TIBCO Universal Installer.

Before uninstalling the plug-in, stop all running processes in the installation environment. If the
response file is not in the temporary directory containing the installer, you have to provide absolute
path of the response file.

Uninstalling in GUI Mode
You can uninstall all the products or specific products from a selected TIBCO_HOME when using TIBCO
Universal Installer to uninstall the plug-in in GUI mode.

Procedure

1. Navigate to the TIBCO_HOME/tools/universal_installer directory.

2. Use one of the following ways to start the uninstallation:

● On Microsoft Windows, double-click TIBCOUniversalInstaller.exe.

● On Linux, run TIBCOUniversalInstaller-platform_acronym.bin.

● On Mac OS, double-click TIBCOUniversalInstaller-mac.command.

3. In the TIBCO Installation Manager dialog box, select Uninstall Products from a TIBCO Home
Location.

4. From the TIBCO Home Location list, select the TIBCO_HOME where the product is installed. Click
Next.

5. In the Welcome dialog box, click Next.
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6. In the Uninstallation Type dialog box, select an uninstallation option and click Next.

● Custom Uninstall

You can select the products to be removed.

● Typical Uninstall

You cannot select the products. All the products in the selected TIBCO_HOME will be removed.

7. If you select Custom Uninstall in Step 6, select the check box next to the product to be uninstalled
in the Product Uninstall Selection dialog box. Click Next.

8. In the Pre-Uninstall Summary dialog box, review the product to be uninstalled. Click Uninstall.

9. In the Post Uninstall Summary dialog box, click Finish to complete the uninstallation process and
exit the installer.

10. If you have uninstalled all the softwares in the selected TIBCO_HOME, delete the folders in the
installation environment and user home.

Uninstalling in Console Mode
If you are not working in a GUI environment, you can uninstall the software in console mode.

Procedure

1. On a command line, navigate to the TIBCO_HOME/tools/universal_installer directory.

2. Run the following command to start the uninstallation:

● Microsoft Windows: TIBCOUniversalInstaller.exe -console

● Linux: ./TIBCOUniversalInstaller-platform_acronym.bin -console

● Mac OS: ./TIBCOUniversalInstaller-mac.command -console

3. Respond to the messages on the command line.
The uninstallation options are the same as GUI mode. See Uninstalling in GUI Mode for more
details.

4. When the uninstallation is completed, press Enter to exit the installer.
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Using Update Site

You can install the plug-in by using a public update site or a local update site.

Installing the Plug-in by Using a Public Update Site
You can install TIBCO ActiveMatrix BusinessWorks™ Plug-in for Amazon SQS and SNS from within
TIBCO Business Studio™ using the public update site maintained by TIBCO.

Prerequisites

The software package must be available on the update site, http://update.tibco.com/eclipse/bw/
version (where the version at the end of the address reflects the version of BusinessWorks you are
using). Typically, the package name has the format <plugin_name>_<version>_p2installer.zip.

Procedure

1. Start TIBCO Business Studio if it has not already been started.

● On Microsoft Windows, click Start > All Programs > TIBCO > TIBCO_HOME > TIBCO
Business Studio version_number > Studio for Designers.

● On Linux or Mac OS, run the TIBCO Business Studio executable located in the TIBCO_HOME/
studio/version_number/eclipse directory.

2. From the menu, select Help > Install New Software to open Eclipse Update Manager.

3. In the Install dialog box, enter the URL of the public update site, http://update.tibco.com/
eclipse/bw/version, in the Work with field.
You can save the URL by adding it to the list of available software sites using the TIBCO Business
Studio menu Window > Preferences > Install/Update > Available Software Sites.

4. From the list of available plug-ins, select the plug-in you want to install. Click Next.

You can select more than one plug-in from the list to install multiple plug-ins at the same
time.

5. In the Install Details dialog box, review the components you want to install. Click Next.

6. In the Review Licenses dialog box, review the licenses, and click I accept the terms of the license
agreement.

7. Click Finish to start the installation.

What to do next

After installing the software, restart TIBCO Business Studio. This restart is necessary for the software to
install completely.

Installing the Plug-in by Using a Local Update Site or Directory
You can install TIBCO ActiveMatrix BusinessWorks™ Plug-in for Amazon SQS and SNS from within
TIBCO Business Studio™ by using a local site or the directory maintained by your organization.

Prerequisites

Ensure that the software package is downloaded from the TIBCO download site and stored in an
appropriate location, such as a local update site or a directory. Typically, the package name has the
format <plugin_name>_<version>_p2installer.zip.
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Procedure

1. Start TIBCO Business Studio if it has not already been started.

● On Microsoft Windows, click Start > All Programs > TIBCO > TIBCO_HOME > TIBCO
Business Studio version_number > Studio for Designers.

● On Linux or Mac OS, run the TIBCO Business Studio executable located in the TIBCO_HOME/
studio/version_number/eclipse directory.

2. From the menu, select Help > Install New Software to open Eclipse Update Manager.

3. In the Install dialog box, click Add to add a new update site you want to work with.

Only one update site can be added at a time. Repeat the following steps to add multiple
repositories that contain the downloaded software packages.

You can manage the list of software sites using the TIBCO Business Studio menu Window >
Preferences > Install/Update > Available Software Sites.
a) In the Add Repository dialog box, click Archive and locate the Eclipse plug-in installation

package you want to install, and then click Open.
The selected plug-in installation package is added to the Location field.

b) Provide a name for the repository. For example, specify the name as TIBCO Plugin Update
Site for <plug-in>. Click OK.
The plug-in installation package is added to the list of available software in the Install dialog
box.

4. In the Install dialog box, select the plug-in you want to install. Click Next.

If there is more than one plug-in in the dialog box, you can select multiple plug-ins to
install at the same time.

5. In the Install Details dialog box, review the components you want to install. Click Next.

6. In the Review Licenses dialog box, review the licenses, and click I accept the terms of the license
agreement.

7. Click Finish to start the installation.

What to do next

After installing the software, restart TIBCO Business Studio. This restart is necessary for the software to
install completely.

Uninstalling the Plug-in
You can uninstall TIBCO ActiveMatrix BusinessWorks™ Plug-in for Amazon SQS and SNS from Eclipse
Update Manager.

Procedure

1. Open TIBCO Business Studio™ by using one of the following ways:

● Microsoft Windows: Click Start > All Programs > TIBCO > TIBCO_HOME > TIBCO Business
Studio version_number > Studio for Designers.

● Linux or Mac OS: Run the TIBCO Business Studio executable located in the TIBCO_HOME/
studio/version_number/eclipse directory.

2. From the menu, click Help > Install New Software to open Eclipse Update Manager.

3. In the Available Software dialog, click the already installed link.
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4. On the Installed Software tab, select the product to be uninstalled and click Uninstall.

5. In the Uninstall Details dialog box, review the product to be uninstalled. Click Finish.

6. When you are prompted to restart TIBCO Business Studio, click Restart Now.
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Installation Logging

If you encounter problems with the installation, first ensure that your system meets all requirements.
Next, check the installer log for potential problems.

The installer log file, tibco_universal_installer.username_install.log, is available in the
following locations:

● On Microsoft Windows: C:\Users\username\.TIBCO\install_timestamp

● On Linux: user_home_dir/.TIBCO/install_timestamp

● On Mac OS: Users/user_home_dir/.TIBCO/install_timestamp

The installer log file captures the following information:

● Detailed information regarding the user that invoked the installer, host name, operating system
details, and so on

● List of assemblies installed

● Information related to the Ant scripts run by the installer

To change the location of the installer log file, specify the option -V logFile="myLogFile" when you
run the installer.
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