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Installation Overview
You can install TIBCO ActiveMatrix BusinessWorks™ Plug-in for Snowflake either by using
the TIBCO Universal Installer or an update site.

l Installing by Using the TIBCO Universal Installer

You can install the plug-in by using the TIBCO Universal Installer, in the following
modes: GUI, console, and silent. To skip to the procedure, see Installation Modes and
Procedures.

l Installing by Using an Update Site

You can install the plug-in from within TIBCO Business Studio™ for BusinessWorks™
by using the public update site maintained by TIBCO, using a local update site
managed by your organization, or BusinessWorks Plug-ins Manager.

The plug-in must be installed into an existing installation environment where TIBCO
ActiveMatrix BusinessWorks™ is already installed. The installation environment of
ActiveMatrix BusinessWorks™ is referenced as TIBCO_HOME.

Note:
l If a previous version of the plug-in is already installed in TIBCO_HOME

where the new version is to be installed, you must uninstall the previous
version before installing the new version.

l TIBCO recommends that you use the same mode for uninstallation that
you used for installing the plug-in. Using different methods for installation
and uninstallation might cause some problems during uninstallation.
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Installation Requirements
Before you install the plug-in, ensure that your system meets all the hardware and
software requirements and you have appropriate privileges to run the installer.

Installation Account and Permission
Requirements
To install on Microsoft Windows, Linux, or macOS, you must have appropriate privileges.
Privileges differ for various platforms.

Note: Use the same installer account to install all ActiveMatrix BusinessWorks
products.

Platform Account Privileges

Microsoft
Windows

Only users with administrator privileges can install the plug-in. If you do not
have administrator privileges, the installer automatically exits.

To install the product on a network drive, ensure that the account used for
installation has permission to access the network drive.

Linux Any type of user, regular (non-root) user and super-user (root), can install on
Linux.

A graphic environment such as CDE or X Windows is required to run the
installer in GUI mode.

macOS Any type of user, regular (non-root) user and super-user (root), can install on
macOS.
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System Requirements
Ensure that your system meets the hardware and software requirements before installing
the plug-in. 

Platform
Before you run the installer, ensure that the appropriate platform is supported. For
information about supported operating system platforms, versions, and the required
patches, see the Readme file.

Disk Space
The installer requires some space in the local directory before installation, and additional
space in the local directory to run the installer. Ensure that sufficient space is available in
the directory that you want to use as the installation environment (TIBCO_HOME).

Note: While installing the product, avoid running other processes that use disk
space in the installation environment directory. If another process uses disk
space while the installer is copying files, the installer might fail and display a
failure message.

Software Requirements
Ensure that you have installed the required software before you run the installer. For
information about supported products and versions, see the Readme file.

The following table lists required and optional TIBCO products:

https://docs.tibco.com/dyno/bwpluginsnowflake/6.3.0/TIB_bwpluginsnowflake_6.3.0_readme.txt
https://docs.tibco.com/dyno/bwpluginsnowflake/6.3.0/TIB_bwpluginsnowflake_6.3.0_readme.txt
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Software Description

TIBCO ActiveMatrix
BusinessWorks™

Required.

ActiveMatrix BusinessWorks supports your integration project
throughout the project life cycle. It includes a common graphical user
interface for configuration, process design, and deployment.

TIBCO® Enterprise
Administrator

Optional.

TIBCO Enterprise Administrator consists of a TIBCO Enterprise
Administrator server, a web user interface for the server, and a shell
interface, with which you can manage the applications that you create in
TIBCO Business Studio for BusinessWorks.
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Installing by Using the TIBCO Universal
Installer
You can install the ActiveMatrix BusinessWorks™ Plug-in for Snowflake by using the TIBCO
Universal Installer, in the following modes: GUI, console, and silent.

Ensure that your system meets all the requirements described in the Installation
Requirements section.

Note: The plug-in must be installed in the same installation environment where
ActiveMatrix BusinessWorks is installed. Stop all running processes in the
installation environment before the installation.

Using the TIBCO Universal Installer, you can select the installation environment and the
installation component.

If you are using the TIBCO Universal Installer for the first time to install the plug-in, review
the following topics before the installation:

l Installation Environment

l Installation Components and Profiles

l Installation Modes and Procedures

Installation Environment
An installation environment isolates product installations. A product installed in one
installation environment cannot access components in other installation environments.

An installation environment is the top-level installation directory for TIBCO products. An
installation environment consists of the following properties:
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Property Description

Directory Identifies the directory where the product is installed.

TIBCO_HOME It is the top-level installation directory for TIBCO products.

Name Identifies the name of the folder where the product is installed.

Installation Components and Profiles
Different installation components are associated with different functions. Using the TIBCO
Universal Installer, you can select installation components during the installation.

Installation components are grouped into different installation profiles. One installation
profile is associated with one or more installation components. When you select a profile,
the components grouped to the selected profile are installed. By default, the Typical
installation profile is selected, therefore, all the installation components are installed.

The following installation components are available for the plug-in:

Component Description

TIBCO ActiveMatrix
BusinessWorks™
Plug-in for
Snowflake Design

This component includes the palettes, shared resources, and samples
that show how the plug-in interacts with ActiveMatrix BusinessWorks.
You can configure your own business process in TIBCO Business Studio
for BusinessWorks with an Eclipse user interface.

Note: This component cannot be installed alone without the runtime
component.

TIBCO ActiveMatrix
BusinessWorks™
Plug-in for
Snowflake
Runtime

This component passes and converts data to and from vendor
applications. The parameters of data exchange are stored in projects
that are created by using the plug-in palette.
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Installation Modes and Procedures
You can run the TIBCO Universal Installer in GUI, console, or silent mode. Each mode is
supported on all platforms. Ensure that your system meets all the requirements described
in Installation Requirements.

Note: The plug-in must be installed in an existing installation environment where
ActiveMatrix BusinessWorks is installed. Stop all running processes in the
installation environment before the installation.

Installation
Mode

Description Reference

GUI In GUI mode, the installer contains panels where you can
select a product, product location, and so on. To invoke the
installer in GUI mode, double-click the executable file.

Installing in
GUI Mode

Console In console mode, you can run the installer on a command
line. This is useful if your machine does not have a GUI
environment.

Installing in
Console
Mode

Silent In silent mode, the installer installs the product without
prompting you for information. The installer uses either
default or custom settings that are saved in a response file.

Installing in
Silent Mode

Installing in GUI Mode
In GUI mode, the installer prompts you for information regarding the installation
environment, installation profile, and other installation information.

Before you begin
1. Ensure that ActiveMatrix BusinessWorks is already installed. The plug-in must be

installed in the same installation environment where ActiveMatrix BusinessWorks is
installed.

2. Download the installation package from TIBCO eDelivery. To download the

https://edelivery.tibco.com/
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installation package, the TIBCO account credentials (username and password) are
required. If you do not have a username and password, contact TIBCO Support.

3. Extract the content of the package to a local directory.

4. Stop all running processes in the installation environment.

Procedure
1. Navigate to the directory where you extracted the package.

2. To start the installation, run the executable file of the TIBCO Universal Installer for
the required platform.

3. On the Welcome page of the installation wizard, click Next.

4. Accept the license agreement and click Next.

5. On the Installation Profile Selection page, select Use an existing TIBCO_HOME and
choose the installation environment where ActiveMatrix BusinessWorks is installed
and then click Next. For more information, see Installation Environment.

6. On the Installation Profile Selection page, select an installation profile to specify the
installation components to be installed. Or select the Customize Installation
checkbox to select the installation components. Click Next. For more information, see
Installation Components and Profiles.

7. In the Snowflake JDBC Jar dialog, click Browse to provide the absolute path of the
Snowflake JDBC driver. The required JAR file name must be snowflake-jdbc-<ver>.jar.
Click Next.

8. On the Pre-Install Summary page, review the information and click Next.

9. On the Post-Install Summary page, review the installation details and click Finish.

What to do next
Open TIBCO Business Studio for BusinessWorks and create a project to start using the plug-
in. For more information, see the TIBCO ActiveMatrix BusinessWorks™ Plug-in for Snowflake
User Guide.

Installing in Console Mode
In console mode, you can run the installer from the command line. The installer prompts
for values on a console window and you can move through the installation by responding

http://www.tibco.com/services/support


TIBCO ActiveMatrix BusinessWorks™ Plug-in for Snowflake Installation

12 | Installing by Using the TIBCO Universal Installer

to the prompts.

Before you begin
1. Ensure that ActiveMatrix BusinessWorks is already installed. The plug-in must be

installed in the same installation environment where ActiveMatrix BusinessWorks is
installed.

2. Download the installation package from TIBCO eDelivery. To download the
installation package, the TIBCO account credentials (username and password) are
required. If you do not have a username and password, contact TIBCO Support.

3. Extract the content of the package to a local directory.

4. Stop all running processes in the installation environment.

Procedure
1. On a command line, navigate to the local directory where you extracted the

installation package.

2. To start the installation, run the following command:

<TIBCO Universal Installer executable file> -console

3. Respond to the messages on the command line.

The installation options are the same as GUI mode. For more information, see
Installing in GUI Mode.

4. When the installation is completed, press Enter to exit the installer.

What to do next
Open TIBCO Business Studio for BusinessWorks and create a project to start using the plug-
in. For more information, see the TIBCO ActiveMatrix BusinessWorks™ Plug-in for Snowflake
User Guide.

Installing in Silent Mode
In silent mode, you can run the installer without user input by pointing the installer to an
existing response file. A default response file named TIBCOUniversalInstaller_bwpluginsnowflake_
<version>.silent is packaged with the TIBCO Universal Installer. Before launching the silent

https://edelivery.tibco.com/
http://www.tibco.com/services/support
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installation, you must edit the response file with the information about your environment.
It is recommended to make a copy of the default response file then edit that file and use it
for the installation.

• If you invoke the installer with the -silent argument, the installer reads the input from
the default response file.

• If you invoke the installer with the -silent -V responseFile=<filename> argument, the
installer reads the input from the specified response file.

Before you begin
1. Ensure that ActiveMatrix BusinessWorks is already installed. The plug-in must be

installed in the same installation environment where ActiveMatrix BusinessWorks is
installed.

2. Download the installation package from TIBCO eDelivery. To download the
installation package, the TIBCO account credentials (username and password) are
required. If you do not have a username and password, contact TIBCO Support.

3. Extract the content of the package to a local directory.

4. Stop all running processes in the installation environment.

Procedure
1. On the command line, navigate to the local directory where you extracted the

installation package.

2. To start the installation, run the following command:

<TIBCO Universal Installer executable file> -silent -V responseFile="<my_response_filename>"

Note: If you copy the response file to another directory, not the local
directory containing the installer, then provide the absolute path of the
response file.

What to do next
Open TIBCO Business Studio for BusinessWorks and create a project to start using the plug-
in. For more information, see the TIBCO ActiveMatrix BusinessWorks™ Plug-in for Snowflake
User Guide.

https://edelivery.tibco.com/
http://www.tibco.com/services/support


TIBCO ActiveMatrix BusinessWorks™ Plug-in for Snowflake Installation

14 | Installing by Using an Update Site

Installing by Using an Update Site
You can install the plug-in in the following ways. For details about installation procedures,
see the Installation guide provided with the respective plug-in.

Installation
method

Description Reference

Public update
site

You can install the plug-in from within TIBCO
Business Studio for BusinessWorks by using the
public update site.

Installing the Plug-
in by Using the
Public Update Site

Local update site
or directory

You can install the plug-in from within TIBCO
Business Studio for BusinessWorks by using a local
update site or a shared directory managed by your
organization.

Installing the Plug-
in by Using a Local
Update Site or
Directory

BusinessWorks
Plug-ins Manager

You can install the plug-in from within TIBCO
Business Studio for BusinessWorks using the
BusinessWorks Plug-ins Manager.

Installing the Plug-
in by Using
BusinessWorks
Plug-ins Manager

Installing the Plug-in by Using the Public
Update Site
You can install plug-ins from within TIBCO Business Studio for BusinessWorks by using the
public update site maintained by TIBCO.

Before you begin
Ensure that design time is supported for your operating system platform.

Procedure
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1. Depending on the platform applicable to your plug-in, start TIBCO Business Studio
for BusinessWorks:

Platform Step

Microsoft
Windows

Click Start > All Programs > TIBCO > TIBCO_HOME > TIBCO Business
Studio <studio_version> > Studio for Designers

Linux or
macOS

Run the TIBCO Business Studio for BusinessWorks executable file in the
TIBCO_HOME/studio/<studio_version>/eclipse directory.

For the list of platforms supported by your plug-in, see the Readme file.

2. On the menu bar, click Help > Install New Software to open the installation wizard.

3. On the Install page, in the Work with field, enter the URL of the public update site,
http://update.tibco.com/eclipse/bw/<version>. Here the two-digit bw-version at the
end of the address reflects the version of your ActiveMatrix BusinessWorks you are
using.

You can save the URL by adding it to the list of available software sites using the
TIBCO Business Studio for BusinessWorks menu Window > Preferences >
Install/Update > Available Software Sites.

4. From the list of available plug-ins, select the plug-in you want to install. Click Next.

Note: You can select more than one plug-in from the list to install multiple
plug-ins at the same time.

5. On the Install Details page, review the components you want to install. Click Next.

6. On the Review Licenses page, review and accept the license agreement.

7. To start the installation, click Finish.

What to do next
Restart TIBCO Business Studio for BusinessWorks to verify that the plug-in is installed
successfully.

https://docs.tibco.com/dyno/bwpluginsnowflake/6.3.0/TIB_bwpluginsnowflake_6.3.0_readme.txt
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Installing the Plug-in by Using a Local Update
Site or Directory
You can install ActiveMatrix BusinessWorks Plug-in for Snowflake from within TIBCO
Business Studio for BusinessWorks by using a local site or directory maintained by your
organization.

Before you begin
l Ensure that you downloaded the software package from the TIBCO download site

and stored it in an appropriate location, such as a local update site or a directory.
The default package name has the TIB_<plugin_name>_<version>_p2installer.zip format.

l Ensure that design time is supported for your operating system platform.

Procedure
1. Depending on the platform applicable to your plug-in, start TIBCO Business Studio

for BusinessWorks:

Platform Step

Microsoft
Windows

Click Start > All Programs > TIBCO > TIBCO_HOME > TIBCO Business
Studio <studio_version> > Studio for Designers

Linux or
macOS

Run the TIBCO Business Studio for BusinessWorks executable file in the
TIBCO_HOME/studio/<studio_version>/eclipse directory.

For the list of platforms supported by your plug-in, see the Readme file.

2. On the menu bar, click Help > Install New Software to open the installation wizard.

3. On the Install page, click Add to add an update site you want to work with.

Note: You can add only one update site at a time. Repeat the following
steps to add multiple repositories that contain the downloaded software
packages.

a. In the Add Repository dialog, click Local or Archive to locate the plug-in

https://docs.tibco.com/dyno/bwpluginsnowflake/6.3.0/TIB_bwpluginsnowflake_6.3.0_readme.txt
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installation package you want to install, and then click OK.

b. The selected plug-in installation package is added to the Location field. Click
OK. The plug-in installation package is added to the list of available software
on the Install page.

4. On the Install page, select the plug-in you want to install. Click Next.

Note: You can select more than one plug-in from the list to install multiple
plug-ins at the same time.

5. On the Install Details page, review the components you want to install. Click Next.

6. On the Review Licenses page, review and accept the license agreement.

7. To start the installation, click Finish.

What to do next
Restart TIBCO Business Studio for BusinessWorks to verify that the plug-in is installed
successfully.

Installing the Plug-in by Using BusinessWorks
Plug-ins Manager
You can install the plug-in from within TIBCO Business Studio for BusinessWorks by using
BusinessWorks Plug-ins Manager. TIBCO recommends that you use the same mode for
installing and uninstalling the plug-in.

BusinessWorks Plug-ins Manager is not supported for Migration profile.

Before you begin
To install the plug-in by using the plug-ins manager, read the following considerations:

l You must have version 6.7.0 or later of ActiveMatrix BusinessWorks.

l Ensure that design time is supported for your operating system platform.

The software package must be available at the update site:

http://update.tibco.com/eclipse/bw/<version>
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Here, the bw-version at the end of the address reflects the version of ActiveMatrix
BusinessWorks you are using.

Procedure
1. Depending on the platform applicable to your plug-in, start TIBCO Business Studio

for BusinessWorks:

Platform Step

Microsoft
Windows

Click Start > All Programs > TIBCO > TIBCO_HOME > TIBCO Business
Studio <studio_version> > Studio for Designers

Linux or
macOS

Run the TIBCO Business Studio for BusinessWorks executable file in the
TIBCO_HOME/studio/<studio_version>/eclipse directory.

For the list of platforms supported by your plug-in, see the Readme file.

2. Open BusinessWorks Plug-ins Manager in one of the following ways:

l On the menu bar, click Help > BusinessWorks Plug-ins Manager.

l When a process is open, in the Palette section (right pane), click the Plug-ins
Manager icon .

The BusinessWorks Plug-ins Manager dialog opens, listing all the plug-ins available on
the public update site.

To open the documentation of a plug-in, on the plug-in tile, click the View
documentation icon or right-click and select the relevant option.

https://docs.tibco.com/dyno/bwpluginsnowflake/6.3.0/TIB_bwpluginsnowflake_6.3.0_readme.txt
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3. In the BusinessWorks Plug-ins Manager dialog, select one or more plug-ins that you
want to install, and then click Install.

The list of plug-ins is displayed based on your selection of options on the Options
tab.

4. In the Install wizard, perform the following steps:

a. On the Install page, confirm that the required plug-ins are selected for
installation and click Next.

b. On the Install Details page, review the plug-in details and click Next.

c. To continue, accept the terms of agreement and click Finish.

What to do next
Restart TIBCO Business Studio for BusinessWorks to verify that the plug-in is installed
successfully.
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Postinstallation Tasks
This section provides information about all postinstallation steps for the plug-in to be
compatible with TIBCO ActiveMatrix BusinessWorks™ Administration.

TIBCO ActiveMatrix BusinessWorks™ Administration Compatibility

Before deploying and running an application containing the plug-in, ensure that the
following configuration exists in the TIBCO_HOME/bw/<version>/bin/bwappnode.tra file.

java.property.javax.xml.datatype.DatatypeFactory=com.sun.org.apache.xerces.internal.jaxp.datat
ype.DatatypeFactoryImpl

Note: If a change is made in the bwappnode_<node_name>.tra file where the existing
appnodes are currently running, then restart the appnodes after making the
change (for the change to take effect).
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Adding the Plug-in to TIBCO BusinessWorks
Container Edition
To add the plug-in to TIBCO BusinessWorks™ Container Edition, you must perform the
following steps:

Procedure
1. Open the physical media or download the TIB_bwpluginsnowflake_version_buildnumber_

bwce-runtime.zip installation package from the TIBCO eDelivery site.

To download the installation package, a user name and password are required. If you
do not have a user name and password, contact TIBCO Technical Support.

2. Copy the com.tibco.tpshell.snowflake.jdbc_version-number.xxx wrapper folder present in the
bwce_home/palettes/snowflake/ver/runtime/plugins directory, and place this folder in the
resources/addons/jars folder for creating the image or buildpack on docker or cloud
foundry.

3. Add the .zip file to TIBCO BusinessWorks™ Container Edition at run time.

For the procedure, see the following section in TIBCO BusinessWorks™ Container
Edition Application Development:

Platform Reference

Cloud
Foundry
platform

"The TIBCO BusinessWorks™ Container Edition Buildpack"

Docker or
Docker-
based
platforms

"Creating the TIBCO BusinessWorks™ Container Edition Application
Docker Image"

https://edelivery.tibco.com/
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Updating Snowflake JDBC drivers
Snowflake JDBC drivers are updated and released frequently, when you get a newer
version of JDBC driver from Snowflake, you can replace the installed older version
Snowflake JDBC driver in your installation environment using the snowflakejdbcupdate utility
which is located in the BW_HOME/bw/palettes/snowflake/<version>/bin directory.

Before you begin
l Ensure the new version of Snowflake JDBC driver .jar file is present on your local

computer.

l Shutdown all TIBCO Business Studio for BusinessWorks and Snowflake plug-in
applications.

Procedure
1. Navigate to the bin folder where the plug-in is installed. For example,

C:\tibco\bw\palettes\snowflake\version_number\bin.

2. On the command line enter the following commands:

l On Windows: snowflakejdbcupdate.exe

l On Linux: ./snowflakejdbcupdate

l On mac OS: ./snowflakejdbcupdate

3. On executing the command, the following message is displayed: Please specify
absolute path of the snowflake JDBC jar

4. Specify the absolute path of the snowflake-jdbc-<version>.jar

A BUILD SUCCESSFUL message appears, which indicates the Snowflake JDBC driver is
updated successfully.

5. If updating the Snowflake JDBC driver in a deployed environment, further steps are
required so that the update is successful.

Set the bw.appnode.clean.config.folder.on.startup property as true in the config.ini file of
appnode.
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What to do next
Restart TIBCO Business Studio for BusinessWorks and Snowflake Plug-in applications.
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Uninstalling by Using the TIBCO Universal
Installer
You can uninstall the plug-in using the TIBCO Universal Installer, in the following modes:
GUI, console, and silent.

Note:
l TIBCO recommends that you use the same mode for uninstallation that

you used for installing the plug-in. Using different methods for installation
and uninstallation might cause some problems during uninstallation.

l Before uninstalling the plug-in, stop all running processes in the
installation environment.

l Uninstalling in GUI Mode

l Uninstalling in Console Mode

l Uninstalling in Silent Mode

Uninstalling in GUI Mode
You can uninstall all the products or specific products from a selected TIBCO_HOME when
using the TIBCO Universal Installer to uninstall the plug-in in GUI mode.

Note:
l TIBCO recommends that you use the same mode for uninstallation that

you used for installing the plug-in. Using different methods for installation
and uninstallation might cause some problems during uninstallation.

l Before uninstalling the plug-in, stop all running processes in the
installation environment.

Procedure
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1. Navigate to the TIBCO_HOME/tools/universal_installer directory.

2. Run the executable file of the TIBCO Universal Installer for the required platform.

3. On the TIBCO Installation Manager page, select Uninstall Products from a TIBCO
Home Location.

4. From the TIBCO Home Location list, select the TIBCO_HOME where the product is
installed. Click Next.

5. On the Welcome page, click Next.

6. On the Uninstallation Type page, select an uninstallation option and click Next.

Option Description

Custom
Uninstall

You can select the products to be removed.

Typical
Uninstall

You cannot select the products. All the products in the selected TIBCO_
HOME are removed.

7. If you select Custom Uninstall in the Custom Uninstall, select the checkbox next to
the product to be uninstalled in the Product Uninstall Selection page. Click Next.

8. On the Pre-Uninstall Summary page, review the product to be uninstalled. Click
Uninstall.

9. On the Post-Uninstall Summary page, click Finish to complete the uninstallation
process and exit the installer.

10. If you have uninstalled all the software in the selected TIBCO_HOME, delete the
folders in the installation environment and user home.

What to do next
After you have uninstalled all the software in the selected TIBCO_HOME, delete the residual
folders (if any) in the installation environment and user home.
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Uninstalling in Console Mode
If you are not working in a GUI environment, you can uninstall the software in console
mode.

Note:
l TIBCO recommends that you use the same mode for uninstallation that

you used for installing the plug-in. Using different methods for installation
and uninstallation might cause some problems during uninstallation.

l Before uninstalling the plug-in, stop all running processes in the
installation environment.

Procedure
1. On a command line, navigate to the TIBCO_HOME/tools/universal_installer directory.

2. To start the uninstallation, run the following command:

<TIBCO Universal Installer executable file -console

3. Respond to the messages on the command line.

The uninstallation options are the same as GUI mode. For more information, see
Uninstalling in GUI Mode.

4. When the uninstallation is completed, press Enter to exit the installer.

Uninstalling in Silent Mode
In silent mode, you can uninstall the product from the command line.
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Note:
l TIBCO recommends that you use the same mode for uninstallation that

you used for installing the plug-in. Using different methods for installation
and uninstallation might cause some problems during uninstallation.

l Before uninstalling the plug-in, stop all running processes in the
installation environment.

Before you begin
1. Navigate to the local directory where you extracted the installation package.

2. Copy the TIBCOUniversalInstaller_bwpluginsnowflake_<version>.silent response file to the
TIBCO_HOME/tools/universal_installer directory, rename the file to mysilent.silent file and
remove the existing entries in mysilent.silent file.

3. Add the following parameters to the mysilent.silent file by using the <entry
key="keyname">keyvalue</entry> syntax:

<entry key="uninstallProductID">bwpluginname</entry>
<entry key="uninstallProductVersion">6.x.x/entry>
<entry key="uninstallTIBCOHome">c:/tibco</entry>

Procedure
1. Navigate to the TIBCO_HOME/tools/universal_installer directory.

2. Run the following command:

<TIBCO Universal Installer executable file> -silent -V responseFile="<my_response_filename>"

Note: If you copy the response file to another directory, not the local
directory containing the installer, then provide the absolute path of the
response file.

3. You can also use the command-line options to override the value in the silent file.
The following options are supported:

l -V uninstallTIBCOHome="<TIBCO_HOME path>"

l -V uninstallProductID="<productID>"
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l -V uninstallProductVersion="<product version>"

l -V uninstallAllProducts="true"

Command-Line
Options

Description

uninstallTIBCOHome The path to the TIBCO_HOME where you want to run the
uninstaller. This value is validated before the uninstallation
can proceed in silent mode.

uninstallProductID The ID of the product that you want to uninstall as defined in
the feature config or _installInfo xml file. A wildcard "*" can be
used to uninstall all products. The uninstallAllProducts="true"
option must be used to uninstall all products.

uninstallProductVersion The version of the product that you specified with the
uninstallProductID value. If not specified, all versions matching
the uninstallProductID are removed.

uninstallAllProducts This option must be used in addition to setting
uninstallProductID="*" in the silent file to uninstall all products.
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Uninstalling by Using an Update Site
You can uninstall the plug-in in the following ways. For details about uninstallation
procedures, see the Installation guide provided with the respective plug-in.

Uninstallation
method

Description Reference

Uninstall using
the public
update site

You can uninstall the plug-in from within
TIBCO Business Studio for BusinessWorks by
using the public update site.

Uninstalling the Plug-in
by Using the Public
Update Site or Local
Update Site

Uninstall using
BusinessWorks
Plug-ins Manager

You can uninstall the plug-ins from within
TIBCO Business Studio for BusinessWorks by
using the BusinessWorks Plug-ins Manager.

Uninstalling the Plug-in
by Using BusinessWorks
Plug-ins Manager

Uninstalling the Plug-in by Using the Public
Update Site or Local Update Site
You can uninstall the plug-in from within TIBCO Business Studio for BusinessWorks by
using the public update site maintained by TIBCO.

Note: TIBCO recommends that you use the same mode for uninstallation that
you used for installing the plug-in. Using different methods for installation and
uninstallation might cause some problems during uninstallation.

Before you begin
Depending on the platform applicable to your plug-in, start TIBCO Business Studio for
BusinessWorks:
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Platform Step

Microsoft
Windows

Click Start > All Programs > TIBCO > TIBCO_HOME > TIBCO Business Studio
<studio_version> > Studio for Designers

Linux or
macOS

Run the TIBCO Business Studio for BusinessWorks executable file in the TIBCO_
HOME/studio/<studio_version>/eclipse directory.

For the list of platforms supported by your plug-in, see the Readme file.

Procedure
1. On the menu bar, select Help > About TIBCO Business Studio for BusinessWorks.

2. Click Installation Details.

The TIBCO Business Studio for BusinessWorks(TM) Installation Details dialog is
displayed.

3. Select the plug-in to uninstall and click Uninstall.

4. On the Uninstall Details page, review the items to uninstall and click Finish.

What to do next
Restart TIBCO Business Studio for BusinessWorks to verify that the plug-in is uninstalled
successfully.

Uninstalling the Plug-in by Using
BusinessWorks Plug-ins Manager
You can uninstall the plug-in from within TIBCO Business Studio for BusinessWorks by
using BusinessWorks Plug-ins Manager.

Note: TIBCO recommends that you use the same mode for uninstallation that
you used for installing the plug-in. Using different methods for installation and
uninstallation might cause some problems during uninstallation.

https://docs.tibco.com/dyno/bwpluginsnowflake/6.3.0/TIB_bwpluginsnowflake_6.3.0_readme.txt
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Before you begin
Depending on the platform applicable to your plug-in, start TIBCO Business Studio for
BusinessWorks:

Platform Step

Microsoft
Windows

Click Start > All Programs > TIBCO > TIBCO_HOME > TIBCO Business Studio
<studio_version> > Studio for Designers

Linux or
macOS

Run the TIBCO Business Studio for BusinessWorks executable file in the TIBCO_
HOME/studio/<studio_version>/eclipse directory.

For the list of platforms supported by your plug-in, see the Readme file.

Procedure
1. On the menu bar, click Help > BusinessWorks Plug-ins Manager.

Optionally, click the Plug-ins Manager icon in the Palette section.

The BusinessWorks Plug-ins Manager dialog opens, listing all the plug-ins available on
the public update site.

2. On the Options tab, select the Show only installed plug-ins checkbox and select the
plug-ins to uninstall.

3. Click Uninstall.

The Uninstall Details dialog is displayed.

https://docs.tibco.com/dyno/bwpluginsnowflake/6.3.0/TIB_bwpluginsnowflake_6.3.0_readme.txt
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4. In the Uninstall Details dialog, review the components to uninstall.

5. To start the plug-ins uninstallation, click Finish.

What to do next
Restart TIBCO Business Studio for BusinessWorks to verify that the plug-in is uninstalled
successfully.
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Troubleshooting Installation
If you encounter problems with the installation or uninstallation, first ensure that your
system meets all the requirements. Then, check the installer log for potential problems.

Depending on the platform applicable to your plug-in, select the location of the installer
log file. The installer log file, tibco_universal_installer.username_install.log, is available at the
following locations:

Platform Location

Microsoft Windows C:\Users\username\.TIBCO\install_timestamp

Linux user_home_dir/.TIBCO/install_timestamp

macOS Users/user_home_dir/.TIBCO/install_timestamp

The installer log file captures the following information:

l Detailed information regarding the user that invoked the installer, host name,
operating system details, and so on

l List of installed assemblies

l Information related to the Ant scripts run by the installer

To change the location of the installer log file, specify the -V logFile="myLogFile" option when
you run the installer.
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TIBCO Documentation and Support Services
For information about this product, you can read the documentation, contact TIBCO
Support, and join TIBCO Community.

How to Access TIBCO Documentation

Documentation for TIBCO products is available on the Product Documentation website,
mainly in HTML and PDF formats.

The Product Documentation website is updated frequently and is more current than any
other documentation included with the product.

Product-Specific Documentation

The documentation for this product is available on the TIBCO ActiveMatrix BusinessWorks™
Plug-in for Snowflake Product Documentation page.

How to Contact Support for TIBCO Products

You can contact the Support team in the following ways:

l To access the Support Knowledge Base and getting personalized content about
products you are interested in, visit our product Support website.

l To create a Support case, you must have a valid maintenance or support contract
with a Cloud Software Group entity. You also need a username and password to log
in to the product Support website. If you do not have a username, you can request
one by clicking Register on the website.

How to Join TIBCO Community

TIBCO Community is the official channel for TIBCO customers, partners, and employee
subject matter experts to share and access their collective experience. TIBCO Community
offers access to Q&A forums, product wikis, and best practices. It also offers access to
extensions, adapters, solution accelerators, and tools that extend and enable customers to
gain full value from TIBCO products. In addition, users can submit and vote on feature

https://docs.tibco.com/
https://docs.tibco.com/
https://docs.tibco.com/products/tibco-activematrix-businessworks-plug-in-for-snowflake
https://docs.tibco.com/products/tibco-activematrix-businessworks-plug-in-for-snowflake
https://support.tibco.com/
https://support.tibco.com/
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requests from within the TIBCO Ideas Portal. For a free registration, go to
TIBCO Community.

https://ideas.tibco.com/
https://community.tibco.com/
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Legal and Third-Party Notices
SOME CLOUD SOFTWARE GROUP, INC. (“CLOUD SG”) SOFTWARE AND CLOUD SERVICES EMBED,
BUNDLE, OR OTHERWISE INCLUDE OTHER SOFTWARE, INCLUDING OTHER CLOUD SG SOFTWARE
(COLLECTIVELY, “INCLUDED SOFTWARE”). USE OF INCLUDED SOFTWARE IS SOLELY TO ENABLE THE
FUNCTIONALITY (OR PROVIDE LIMITED ADD-ON FUNCTIONALITY) OF THE LICENSED CLOUD SG
SOFTWARE AND/OR CLOUD SERVICES. THE INCLUDED SOFTWARE IS NOT LICENSED TO BE USED OR
ACCESSED BY ANY OTHER CLOUD SG SOFTWARE AND/OR CLOUD SERVICES OR FOR ANY OTHER
PURPOSE.

USE OF CLOUD SG SOFTWARE AND CLOUD SERVICES IS SUBJECT TO THE TERMS AND CONDITIONS
OF AN AGREEMENT FOUND IN EITHER A SEPARATELY EXECUTED AGREEMENT, OR, IF THERE IS NO
SUCH SEPARATE AGREEMENT, THE CLICKWRAP END USER AGREEMENT WHICH IS DISPLAYED WHEN
ACCESSING, DOWNLOADING, OR INSTALLING THE SOFTWARE OR CLOUD SERVICES (AND WHICH IS
DUPLICATED IN THE LICENSE FILE) OR IF THERE IS NO SUCH LICENSE AGREEMENT OR CLICKWRAP
END USER AGREEMENT, THE LICENSE(S) LOCATED IN THE “LICENSE” FILE(S) OF THE SOFTWARE. USE
OF THIS DOCUMENT IS SUBJECT TO THOSE SAME TERMS AND CONDITIONS, AND YOUR USE HEREOF
SHALL CONSTITUTE ACCEPTANCE OF AND AN AGREEMENT TO BE BOUND BY THE SAME.

This document is subject to U.S. and international copyright laws and treaties. No part of this
document may be reproduced in any form without the written authorization of Cloud Software
Group, Inc.

TIBCO, the TIBCO logo, the TIBCO O logo, ActiveMatrix BusinessWorks, Business Studio, and TIBCO
Business Studio are either registered trademarks or trademarks of Cloud Software Group, Inc. in the
United States and/or other countries.

All other product and company names and marks mentioned in this document are the property of
their respective owners and are mentioned for identification purposes only. You acknowledge that all
rights to these third party marks are the exclusive property of their respective owners. Please refer to
Cloud SG’s Third Party Trademark Notices (https://www.cloud.com/legal) for more information.

This document includes fonts that are licensed under the SIL Open Font License, Version 1.1, which is
available at: https://scripts.sil.org/OFL

Copyright (c) Paul D. Hunt, with Reserved Font Name Source Sans Pro and Source Code Pro.

Cloud SG software may be available on multiple operating systems. However, not all operating
system platforms for a specific software version are released at the same time. See the “readme” file
for the availability of a specific version of Cloud SG software on a specific operating system platform.

https://www.cloud.com/legal
https://scripts.sil.org/OFL
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THIS DOCUMENT IS PROVIDED “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR
IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

THIS DOCUMENT COULD INCLUDE TECHNICAL INACCURACIES OR TYPOGRAPHICAL ERRORS. CHANGES
ARE PERIODICALLY ADDED TO THE INFORMATION HEREIN; THESE CHANGES WILL BE INCORPORATED
IN NEW EDITIONS OF THIS DOCUMENT. CLOUD SG MAY MAKE IMPROVEMENTS AND/OR CHANGES IN
THE PRODUCT(S), THE PROGRAM(S), AND/OR THE SERVICES DESCRIBED IN THIS DOCUMENT AT ANY
TIME WITHOUT NOTICE.

THE CONTENTS OF THIS DOCUMENT MAY BE MODIFIED AND/OR QUALIFIED, DIRECTLY OR
INDIRECTLY, BY OTHER DOCUMENTATION WHICH ACCOMPANIES THIS SOFTWARE, INCLUDING BUT
NOT LIMITED TO ANY RELEASE NOTES AND "README" FILES.

This and other products of Cloud SG may be covered by registered patents. For details, please refer
to the Virtual Patent Marking document located at https://www.cloud.com/legal.

Copyright © 2020-2024. Cloud Software Group, Inc. All Rights Reserved.

https://www.cloud.com/legal
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