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Important Information

SOME TIBCO SOFTWARE EMBEDS OR BUNDLES OTHER TIBCO SOFTWARE. USE OF SUCH
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OTHER TIBCO SOFTWARE OR FOR ANY OTHER PURPOSE.
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CONDITIONS OF A LICENSE AGREEMENT FOUND IN EITHER A SEPARATELY EXECUTED
SOFTWARE LICENSE AGREEMENT, OR, IF THERE IS NO SUCH SEPARATE AGREEMENT, THE
CLICKWRAP END USER LICENSE AGREEMENT WHICH IS DISPLAYED DURING DOWNLOAD
OR INSTALLATION OF THE SOFTWARE (AND WHICH IS DUPLICATED IN THE LICENSE FILE)
OR IF THERE IS NO SUCH SOFTWARE LICENSE AGREEMENT OR CLICKWRAP END USER
LICENSE AGREEMENT, THE LICENSE(S) LOCATED IN THE “LICENSE” FILE(S) OF THE
SOFTWARE. USE OF THIS DOCUMENT IS SUBJECT TO THOSE TERMS AND CONDITIONS, AND
YOUR USE HEREOF SHALL CONSTITUTE ACCEPTANCE OF AND AN AGREEMENT TO BE
BOUND BY THE SAME.

This document contains confidential information that is subject to U.S. and international copyright laws
and treaties. No part of this document may be reproduced in any form without the written
authorization of TIBCO Software Inc.

TIBCO, Two-Second Advantage, TIBCO ActiveMatrix BusinessWorks, TIBCO Business Studio, TIBCO
Enterprise Administrator, and TIBCO ActiveMatrix BusinessWorks Plug-in for Workday are either
registered trademarks or trademarks of TIBCO Software Inc. in the United States and/or other
countries.

Enterprise Java Beans (EJB), Java Platform Enterprise Edition (Java EE), Java 2 Platform Enterprise
Edition (J2EE), and all Java-based trademarks and logos are trademarks or registered trademarks of
Oracle Corporation in the U.S. and other countries.

All other product and company names and marks mentioned in this document are the property of their
respective owners and are mentioned for identification purposes only.

THIS SOFTWARE MAY BE AVAILABLE ON MULTIPLE OPERATING SYSTEMS. HOWEVER, NOT
ALL OPERATING SYSTEM PLATFORMS FOR A SPECIFIC SOFTWARE VERSION ARE RELEASED
AT THE SAME TIME. SEE THE README FILE FOR THE AVAILABILITY OF THIS SOFTWARE
VERSION ON A SPECIFIC OPERATING SYSTEM PLATFORM.

THIS DOCUMENT IS PROVIDED “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

THIS DOCUMENT COULD INCLUDE TECHNICAL INACCURACIES OR TYPOGRAPHICAL
ERRORS. CHANGES ARE PERIODICALLY ADDED TO THE INFORMATION HEREIN; THESE
CHANGES WILL BE INCORPORATED IN NEW EDITIONS OF THIS DOCUMENT. TIBCO
SOFTWARE INC. MAY MAKE IMPROVEMENTS AND/OR CHANGES IN THE PRODUCT(S)
AND/OR THE PROGRAM(S) DESCRIBED IN THIS DOCUMENT AT ANY TIME.

THE CONTENTS OF THIS DOCUMENT MAY BE MODIFIED AND/OR QUALIFIED, DIRECTLY OR
INDIRECTLY, BY OTHER DOCUMENTATION WHICH ACCOMPANIES THIS SOFTWARE,
INCLUDING BUT NOT LIMITED TO ANY RELEASE NOTES AND "READ ME" FILES.

Copyright © 2014-2016 TIBCO Software Inc. All rights reserved.

TIBCO Software Inc. Confidential Information
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TIBCO Documentation and Support Services

Documentation for this and other TIBCO products is available on the TIBCO Documentation site. This
site is updated more frequently than any documentation that might be included with the product. To
ensure that you are accessing the latest available help topics, please visit:

https://docs.tibco.com

Product-Specific Documentation

Documentation for TIBCO products is not bundled with the software. Instead, it is available on the
TIBCO Documentation site. To directly access documentation for this product, double-click the
following file:

TIBCO_HOME/release_notes/TIB_bwpluginworkday_version_docinfo.html

where TIBCO_HOME is the top-level directory in which TIBCO products are installed. On Windows,
the default TIBCO_HOME is C:\Program Files\tibco. On UNIX systems, the default TIBCO_HOME
is /opt/tibco.

The following documents for this product can be found on the TIBCO Documentation site:

● TIBCO ActiveMatrix BusinessWorks Plug-in for Workday Installation
● TIBCO ActiveMatrix BusinessWorks Plug-in for Workday User’s Guide
● TIBCO ActiveMatrix BusinessWorks Plug-in for Workday Release Notes

How to Contact TIBCO Support

For comments or problems with this manual or the software it addresses, contact TIBCO Support:

● For an overview of TIBCO Support, and information about getting started with TIBCO Support,
visit this site:

http://www.tibco.com/services/support

● If you already have a valid maintenance or support contract, visit this site:

https://support.tibco.com

Entry to this site requires a user name and password. If you do not have a user name, you can
request one.

How to Join TIBCOmmunity

TIBCOmmunity is an online destination for TIBCO customers, partners, and resident experts. It is a
place to share and access the collective experience of the TIBCO community. TIBCOmmunity offers
forums, blogs, and access to a variety of resources. To register, go to the following web address:

https://www.tibcommunity.com
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Product Overview

TIBCO ActiveMatrix BusinessWorks™ Plug-in for Workday provides several web services
implemented by Workday cloud applications, and bridges TIBCO ActiveMatrix BusinessWorks™ and
Workday cloud applications.

Workday is a leading provider of unified enterprise cloud applications for human resources and
finance. Workday delivers various on-demand cloud-based applications designed for the way people
work in organizations, and provides a comprehensive approach to manage and synchronize work-
related data within your organization. A number of companies, ranging from medium-sized businesses
to large enterprises, have selected Workday to make their human capital management and financial
management more efficient. Workday cloud applications provide the following enterprise services:

● Human resources
● Notification
● Payroll
● Staffing
● Financial management
● Time tracking
● Procurement
● Employee expense management

For more information, visit the Workday website: http://www.workday.com.

You can use TIBCO ActiveMatrix BusinessWorks Plug-in for Workday to invoke the following web
services implemented by Workday cloud applications:

● Human resources
● Payroll
● Staffing

You can also use the notification processes to listen to user data changes on Workday cloud
applications. For more information, see Working with Notification Processes.

The plug-in developed on the basis of Workday Web Service (WWS) version 26.0 contains the Workday
palette, which includes the WorkdayInvoke Activity.
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Getting Started

This tutorial is designed for the beginners who want to use TIBCO ActiveMatrix BusinessWorks Plug-
in for Workday in TIBCO Business Studio™.

All the operations are performed in TIBCO Business Studio. See TIBCO Business Studio Overview to
get familiar with TIBCO Business Studio.

A basic procedure of using TIBCO ActiveMatrix BusinessWorks Plug-in for Workday includes:

1. Creating a Project

2. Downloading a WSDL File

3. Configuring a Process

4. Testing a Process

5. Deploying an Application

Creating a Project
The first task using the plug-in is creating a project. After creating a project, you can add resources and
processes.

An application module is an Eclipse project configured for TIBCO ActiveMatrix BusinessWorks. An
application module is the smallest unit of resources that is named, versioned, and packaged as part of
an application.

Procedure

1. Start TIBCO Business Studio using one of the following ways:

● Microsoft Windows: click Start > All Programs > TIBCO > TIBCO_HOME > TIBCO Business
Studio version_number > Studio for Designers.

● Mac OS and Linux: run the TIBCO Business Studio executable file located in the TIBCO_HOME/
studio/version_number/eclipse directory.

2. From the menu, click File > New > BusinessWorks Resources to open the BusinessWorks Resource
wizard.

3. In the "Select a wizard" dialog, click BusinessWorks Application Module and click Next to open
the New BusinessWorks Application Module wizard.

4. In the Project dialog, configure the project that you want to create:
a) In the Project name field, enter a project name.
b) By default, the created project is located in the workspace current in use. If you do not want to

use the default location for the project, clear the Use default location check box and click Browse
to select a new location.

c) Use the default version of the application module, or enter a new version in the Version field.
d) Keep the Create empty process and Create Application check boxes selected to automatically

create an empty process and an application when creating the project.
e) Select the Use Java configuration check box if you want to create a Java module.

A Java module provides the Java tooling capabilities.
f) Click Finish to create the project.

Result

The project with the specified settings is displayed in the Project Explorer view.
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Downloading a WSDL File
After creating a project, you have to download a WSDL file by using the Workday tool to connect to
inbound operations implemented by Workday.

Prerequisites

Ensure that you have created a project, as described in Creating a Project.

Use the WSDL files that are downloaded with your own account. The value of the location attribute
in the soapbind:address element in the WSDL file must contain the host URL, so the WorkdayInvoke
activity works correctly.

Procedure

1. Right-click the project that you just created in the Project Explorer view, and select Workday Tools
> Download WSDL.

2. In the Download WSDL dialog, enter the URL that the WSDL file is located in the WSDL URL field.

The Workday download tool supports the HTTP and HTTPS protocols. The HTTPS
protocol does not support self-signed HTTPS website.

3. Optional: If you have downloaded the WSDL file from the Workday website and want to access the
WSDL file in your intranet, select the Authentication check box to authenticate your right to access
the intranet where the WSDL file is saved. Enter the values in the User Name and Password fields
to access the intranet.

4. Click OK.

5. In the Download WSDL dialog, click OK to download the WSDL file. Click OK when the download
is completed.
The WSDL file is downloaded under Project_Name > Service Descriptors.

6. From the menu, click Project > Clean to clean the project. In the Clean dialog, click OK.
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Configuring a Process
After creating a project, an empty process is created. You can add activities to the empty process to
complete a task. For example, invoke a Workday web service.

Prerequisites

Ensure that you have created an empty process when Creating a Project, and downloaded the
corresponding Workday WSDL file when Downloading a WSDL File.

Procedure

1. In the Project Explorer view, click the created project and open the empty process from the
Processes folder.

2. From the General Activities palette, select and drop a Timer activity to the process editor. From the
Workday palette, select and drop a WorkdayInvoke activity to the process editor.

3. Drag the  icon to create a transition between the added activities.

4. Configure the added WorkdayInvoke activity, as described in WorkdayInvoke Activity.
After configuring the WorkdayInvoke activity, the shared resources and module properties are
automatically generated.

5. Expand Module Descriptors > Module Properties to update the module properties used in the
project.

6. Optional: In the Project Explorer view, expand Project_Name > Resources > project_name.wday to
edit the following shared resources:

● HTTP Client Shared Resource
● SSL Client Shared Resource
● Keystore Provider Shared Resource

These shared resources can be used by all modules.

7. Optional: Expand Resources > project_name.wday.Module_Name to edit the Identity Provider
Shared Resource.
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8. Click File > Save All to save the project.

Testing a Process
After configuring a process, you can test the process to check if the process completes your task.

Prerequisites

Ensure that you have configured a process when Configuring a Process.

Procedure

1. On the toolbar, click  Debug > Debug Configurations.

2. Click BusinessWorks Application > BWApplication in the left panel.
By default, all the applications in the current workspace are selected in the Applications tab. Ensure
that only the application you want to debug is selected in the Applications tab in the right panel.

3. Click Debug to test the process in the selected application.
TIBCO Business Studio changes to the Debug perspective. The debug information is displayed in
the Console view.

4. In the Debug tab, expand the running process and click an activity.

5. In the upper-right corner, click the Job Data tab, and then click the Output tab to check the activity
output.

Deploying an Application
After testing, if the configured process works as expected, you can deploy the application that contains
the configured process into a runtime environment, and then use the bwadmin utility to manage the
deployed application.

Before deploying an application, you must generate an application archive, which is an enterprise
archive (EAR) file that is created in TIBCO Business Studio.
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Deploying an application involves the following tasks:

1. Uploading an application archive

2. Deploying an application archive

3. Starting an application

See TIBCO ActiveMatrix BusinessWorks Administration for more details about how to deploy an
application.

If policies are used in your project, complete the tasks in Enabling the Governance Agent using the
Admin UI to enable governance agent in TIBCO ActiveMatrix BusinessWorks Administration.

TIBCO Business Studio Overview
TIBCO Business Studio is an Eclipse-based integration development environment that is used to
design, develop, and test ActiveMatrix BusinessWorks applications.

TIBCO Business Studio provides a workbench in which you can create, manage, and navigate resources
in your workspace. A workspace is the central location on your machine where all data files are stored.

The workbench consists of:

1. Menu: contains menu items such as File, Edit, Diagram, Navigate, Search, Project, Run, Window,
and Help.

2. Toolbar: contains buttons for frequently used commands such as New , Save , Enable/
Disable Business Studio Capabilities , Create a new BusinessWorks Application Module ,
Create a new BusinessWorks Shared Module , Debug , Run , and so on.

3. Perspective: contains an initial set and layout of views that are required to perform a certain task.
TIBCO Business Studio launches the Modeling perspective by default. You can change the
perspective from the menu Window > Open Perspective > Perspective_Name.

4. View: displays resources. For example, the Project Explorer view displays the ActiveMatrix
BusinessWorks applications, modules, and other resources in your workspace, and the Properties
view displays the properties for the selected resource. You can open a view from the menu Window
> Show View > View_Name.
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5. Editor: provides a canvas to configure, edit, or browse a resource. Double-click a resource in a view
to open the appropriate editor for the selected resource. For example, double-click an ActiveMatrix
BusinessWorks process (MortgageAppConsumer.bwp) in the Project Explorer view to open the
process in the editor.

6. Palette: contains a set of widgets and a palette library. A palette groups activities that perform
similar tasks, and provides quick access to activities when configuring a process.
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HTTP Client Shared Resource

You can use the HTTP Client shared resource to create an HTTP connection to invoke the Workday
web services.

General

In the General panel, you can specify the general information of the HTTP Client shared resource.

The following table lists the configurations in the General panel of the HTTP Client shared resource:

Field
Module
Property? Description

Package No The name of the package where the new shared resource is added.

Name No The name to be displayed as the label for the shared resource in
the process.

Description No A short description for this shared resource.

HTTP Client

In the HTTP Client panel, you can specify the connection pooling, detailed connection configurations,
default host and port, and so on.

The following table lists the configurations in the HTTP Client panel of the HTTP Client shared
resource:

Field
Module
Property? Description

Implementation
Library

No The implementation library to be used:

● Apache Commons(Supported by HTTP and SOAP): must
be used for SOAP binding.

● Apache HttpComponents(Supported by HTTP and REST):
must be used for REST binding.

The default value is Apache Commons(Supported by HTTP
and SOAP).

Use Apache Commons(Supported by HTTP and
SOAP) for Workday.

Disable
Connection
Pooling

Yes The single or multi-threaded connection manager to be used.

This check box is not selected by default.

Maximum Total
Connections

Yes The maximum number of simultaneous active connection that
this resource instance uses. Increase the value for the
application that creates many long-lived connections.

The default value is 200.
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Field
Module
Property? Description

Idle Connection
Timeout (ms)

Yes Keep-alive time in milliseconds for idle HTTP connection in the
persistent connection pool.

Maximum Total
Connections Per
Host/Route

Yes The maximum number of simultaneous active connections to
the same host or on the same route that this resource instance
uses.

The default value is 20.

This number cannot be greater than the value in the
Maximum Total Connections field.

Stale Check Yes The stale connection check.

Selecting this check box determines whether the stale
connection check is to be used or not. Not using the stale
connection check can result in slight performance improvement
at the risk of getting an I/O error, when executing a request
over a connection that has been closed at the server side.

Default Host Yes The name of the host that accepts the incoming requests.

For machines that have only one network card, the default local
host specifies the current machine. For machines with more
than one network card, this field specifies the host name of the
card used to accept the incoming HTTP requests.

Default Port Yes The port number on which to invoke outgoing HTTP requests.

Thread Pool No A queue of threads available to run a queue of tasks.

Thread pools are used to improve performance when executing
large numbers of asynchronous tasks by reducing each task
invocation overhead, provide a means of bounding, and
managing the resources consumed when executing a collection
of tasks.

Advanced

In the Advanced panel, you can specify timeout, retry, HTTP proxy, and so on.

The following table lists the configurations in the Advanced panel of the HTTP Client shared resource:

Field
Module
Property? Description

Socket
Timeout (ms)

Yes The amount of time in milliseconds to wait for data transfer before
disconnecting the socket.

Connection
Timeout (ms)

Yes The amount of time in milliseconds to wait for the HTTP server to
respond.
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Field
Module
Property? Description

Accept
Redirect

Yes HTTP redirects followed by the HTTP method.

Select this check box when client connection receives the redirect
responses from server like moved permanently, moved
temporarily, temporary redirect, and so on.

This check box is not selected by default.

Retry Count Yes The maximum number of retry attempts for connecting to the
server if an exception occurs.

Use Single
Cookie Header

Yes A single non-repeating Cookie header element to be used.

Select this check box if multiple name/value pairs must be sent in
a single non-repeating Cookie header element for outgoing HTTP
requests.

This check box is not selected by default.

Use Non-
Preemptive
Authentication

Yes Non-preemptive authentication to be used.

Select this check box if you want to use non-preemptive
authentication.

This check box is not selected by default.

HTTP Proxy No The HTTP proxy server to be used to gain access outside of a
firewall.

Security

In the Security panel, you can specify timeout, retry, HTTP proxy, and so on.

The following table lists the configurations in the Security panel of the HTTP Client shared resource:

Field
Module
Property? Description

Authentication No The authentication of messages to be used.

Authentication can be performed with user names and passwords.

Identity Provider: provides user name and password credentials
encapsulated in an Identity Provider shared resource. Select this
check box activates the Identity Provider shared resource.

This check box is not selected by default.

This function is only supported in TIBCO ActiveMatrix
BusinessWorks.
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Field
Module
Property? Description

Confidentiality No Encryption or decryption of messages to be used.

Select this check box when encrypting or decrypting messages.
When you select this check box, the SSL Client Configuration
field is displayed.

This check box is selected by default.

SSL Client
Configuration

No SSL parameters for the HTTP Client shared resource.

This field is only displayed when you select the Confidentiality
check box.

For details, see SSL Client Shared Resource.
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SSL Client Shared Resource

You can specify SSL parameters for the HTTP Client shared resource.

General

In the General panel, you can specify the general information of the SSL Client shared resource.

The following table lists the configurations in the General panel of the SSL Client shared resource:

Field
Module
Property? Description

Package No The name of the package where the new shared resource is added.

Name No The name to be displayed as the label for the shared resource in
the process.

Description No A short description for this shared resource.

Basic SSL Client Configuration

In the Basic SSL Client Configuration panel, you can specify the basic configurations of the SSL Client
shared resource.

The following table lists the configurations in the Basic SSL Client Configuration panel of the SSL
Client shared resource:

Field
Module
Property? Description

Keystore
Provider as
Trust Store

No The name of a keystore provider resource instance that maintains
a keystore that confirms an identity.

For details, see Keystore Provider Shared Resource.

Enable Mutual
Authentication

No Authentication of the client to the server in the SSL connection.

Select this check box when authenticating messages.

When you select this check box, the configurations of identity
provider fields are displayed.

This check box is not selected by default.

Identity Store
Provider

No The name of keystore provider resource that maintains a keystore
used to assert an identity.

This field is only displayed when you select the Enable Mutual
Authentication check box.

For details, see Identity Provider Shared Resource.

Key Alias
Name

Yes The name of the alias used to access the identity.

This field is only displayed when you select the Enable Mutual
Authentication check box.

16

TIBCO ActiveMatrix BusinessWorks™ Plug-in for Workday User’s Guide



Field
Module
Property? Description

Key Alias
Password

Yes The password for the alias.

This field is only displayed when you select the Enable Mutual
Authentication check box.

Advanced SSL Client Configuration

In the Advanced SSL Client Configuration panel, you can specify the advanced configurations of the
SSL Client shared resource.

The following table lists the configurations in the Advanced SSL Client Configuration panel of the SSL
Client shared resource:

Field
Module
Property? Description

SSL Security
Provider

Yes Optional. The SSL security provider.

SSL Protocol No The SSL protocol to be used in the SSL connection:

● TLSv1
● TLSv1.1
● TLSv1.2
● SSLv3: it is not good practice to use this protocol.

Selecting a protocol implies the support of higher versions.

The default value is TLSv1.

SSL Cipher
Class

No The number of bits in the key used to encrypt data:

● No Exportable Ciphers
● All Ciphers
● At Least 128 Bit
● More Than 128 Bit
● At Least 256 Bit
● FIPS Ciphers
● Explicit Ciphers

The greater the number of bits in the key (cipher strength), the
more possible key combinations and the longer it takes to break
the encryption.

The default value is At Least 128 Bit.
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Field
Module
Property? Description

Explicit Cipher
List

Yes A list of ciphers.

Use the Java Secure Socket Extension (JSSE) format for ciphers
names.

This field is only displayed when you select Explicit Ciphers from
the SSL Cipher Class list.

Verify Remote
Host Name

No The verification of the name on the certificate of the server against
the host name of the server.

If the host name of the server is different than the name on the
certificate, the SSL connection fails. The name on the certificate can
be verified against another name by specifying the value in the
Expected Remote Hostname field.

This check box is not selected by default.

When you select this check box, the Expected Remote Hostname
field is displayed.

Expected
Remote
Hostname

Yes Optional. The expected name of the remote host.

This field is only displayed when you select the Verify Remote
Host Name check box.
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Keystore Provider Shared Resource

You can use the Keystore Provider shared resource to provide an access to a keystore.

General

In the General panel, you can specify the general information of the Keystore Provider shared resource.

The following table lists the configurations in the General panel of the Keystore Provider shared
resource:

Field
Module
Property? Description

Package No The name of the package where the new shared resource is added.

Name No The name to be displayed as the label for the shared resource in
the process.

Description No A short description for this shared resource.

Keystore

In the Keystore panel, you can specify the provider, URL, password, type of the keystore, and refresh
interval.

The following table lists the configurations in the Keystore panel of the Keystore Provider shared
resource:

Field
Module
Property? Description

Provider No The name of the keystore provider:

● SUN
● IBMJCE

The default value is SUN.

URL Yes The location of the external keystore.

For example, on Windows, the default value is C:/temp/certs/
workday.jks.

You have to generate your own .jks file.

Password Yes The password for the keystore file.

Type No The type of the keystore:

● JCEKS
● JKS
● PKCS#12

The default value is JKS.
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Field
Module
Property? Description

Refresh
Interval

Yes Refresh interval, greater than 0. If the keystore provider is
accessed after the refresh interval has expired:

● The refresh timer is reset to zero.
● The operations on the keystore provider are performed on the

refreshed copy.

The default value is 3600000.

20

TIBCO ActiveMatrix BusinessWorks™ Plug-in for Workday User’s Guide



Identity Provider Shared Resource

You can reference the Identity Provider shared resource from the WSS Consumer policy resource to
provide Username token based credential mapping with fixed credential mechanism.

General

In the General panel, you can specify the general information of the Identity Provider shared resource.

The following table lists the configurations in the General panel of the Identity Provider shared
resource:

Field
Module
Property? Description

Package No The name of the package where the new shared resource is added.

Name No The name to be displayed as the label for the shared resource in the
process.

Description No A short description for this shared resource.

Identity Provider

In the Identity Provider panel, you can specify the user name and password to access the Workday
web services.

The following table lists the configurations in the Identity Provider panel of the Identity Provider
shared resource:

Field
Module
Property? Description

Username Yes The user name to access the Workday web services.

Password Yes The password to access the Workday web services.
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WSS Consumer Policy Resource

You can use the WSS Consumer policy resource to enforce confidentiality, integrity, timestamp, and
credential mapping.

General Configurations

You can specify the general information of the WSS Consumer policy resource.

The following table lists the general configurations of the WSS Consumer policy resource:

Field
Module
Property? Description

Package No The name to be displayed as the label of the policy resource
package.

Name No The name of the policy resource.

Description No A description of the policy resource.

Shared Resource for WSS Processing

In the Shared Resource for WSS Processing panel, you can specify the WSS Authentication shared
resource.

The following table lists the configuration in the Shared Resource for WSS Processing panel of the
WSS Consumer policy resource:

Field
Module
Property? Description

WSS Authentication No The WSS Authentication shared resource that the WSS
Consumer policy references.

This function is only supported in TIBCO
ActiveMatrix BusinessWorks.

Service Provider Details

In the Service Provider Details panel, you can specify parameters in the Confidentiality tab, the
Integrity tab, the Timestamp tab, and the Credential Mapping tab.

Confidentiality

In the Confidentiality tab, you can configure the policy for an outbound request to be encrypted and
an inbound response to be decrypted at its endpoint.

The following table lists the configurations in the Confidentiality tab:
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Field Description

Encrypt Request The outbound request required to be encrypted.

When you select this check box, you can configure the
following parameters:

● Trust Provider: select a Trust Provider shared resource.
● Key Alias: specify a key alias.
● Algorithm Suite: specify the algorithm suite required for

performing cryptographic operations with symmetric or
asymmetric key based security tokens. An algorithm suite
specifies actual algorithms and allowed key lengths.

The default value is Basic128. You can also select a
different algorithm suite from the list.

● Encrypt Parts: select the Body or Header check box, or
both.

The Body check box is selected by default.

Decrypt Response The inbound response required to be decrypted.

Integrity

In the Integrity tab, you can sign an outbound request and verify the signature of an inbound response.

The following table lists the configurations in the Integrity tab:
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Field Description

Sign Request The outbound request required to be signed.

When you select this check box, you can configure the
following parameters:

● Subject Provider: select a Subject Provider shared
resource.

● Digest Algorithm for Signature: select a digest algorithm
for signature.

The algorithm takes as input a message of arbitrary length
and produces as output a 128-bit "fingerprint" or "message
digest" of the input.

The default value is SHA-256. You can also select a
different type from the list.

● Algorithm Suite: specifies the algorithm suite required for
performing cryptographic operations with symmetric or
asymmetric key based security tokens. An algorithm suite
specifies actual algorithms and allowed key lengths.

The default value is Basic128. You can also select a
different algorithm suite from the list.

● Sign Parts: select the Body or Header check box, or both.

The Body check box is selected by default.

Verify Signature on Response The signature of an inbound response required to be verified.

Select an option from the Verify parts that are Signed list:

● Entire message

● Message header

● Message body

Timestamp

In the Timestamp tab, you can insert a timestamp in an outbound request and verify a timestamp in
the inbound response.

The following table lists the configurations in the Timestamp tab:

Field Description

Set Timestamp on Request Time-to-live in seconds for an outbound request. You can
specify this value in the Specify Time-To-Live Value (sec)
field.

Verify Timestamp on Response The timestamp to be verified in the inbound response.
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Credential Mapping

In the Credential Mapping tab, you can select either Username token credential mapping or SAML
token credential mapping to map credentials to the outbound request.

The following table lists the configurations in the Credential Mapping tab:

Field Description

No Credentials Credential mapping is not enforced.

Username Token based
Credential Mapping

Two options can be selected for the credential mechanism:

● Fixed: specify an Identity Provider resource in the Identity
Provider field.

This check box is selected by default.
● Conditional: specify the types of users your application

maps credentials for. You can choose to map credentials
for authenticated users with roles, authenticated users,
and anonymous users.

Credentials are mapped for authenticated users if the
request comes from an authenticated service. Credentials
are mapped for anonymous users if the request comes
from unauthenticated service.

● Role based Identity Providers: type roles for
authenticated users and associate an identity provider
with each role. You can reuse the same identity
provider for multiple roles.

● Authenticated Identity Provider: select an Identity
Provider shared resource for authenticated users.

● Anonymous Identity Provider: specify an identity
provider for anonymous users to access your secure
application. If you do not want anonymous users to
access, do not specify an identity provider.

Application logic can also affect how
credentials are mapped for anonymous
users. For example, application logic might
require that anonymous requests are
redirected to specific entry points. If an
anonymous request is directed to an
enforced entry point, the request is rejected.
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Field Description

SAML Token based Credential
Mapping

The following parameters can be configured for the SAML
token based credential mapping:

● SAML Token Profile: select a token type, either SAML 1.1
Token 1.1 or SAML 2.0 Token 1.1.

● Sign SAML Assertion: if you select this option, specify a
subject provider, a digest algorithm for signature, and an
algorithm suite.

● SAML Issuer Name: type a SAML issuer name.
● SAML Assertion Validity: select SAML Assertion

Validity (forever) to ensure that the SAML assertion is
valid indefinitely. Optionally, you can enter a value in the
Specify Validity Period (sec) field to specify the number
of seconds the SAML assertion is valid.
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Workday Palette

The Workday palette only includes the WorkdayInvoke activity.

WorkdayInvoke Activity
You can use the WorkdayInvoke activity to perform a distinct function by invoking a predefined
operation.

General

In the General tab, you can specify the name of the activity in the process, and select an operation you
want to perform in the module.

The following table lists the configurations in the General tab of the WorkdayInvoke activity:

Field
Module
Property? Description

Name No The name to be displayed as the label for the activity in the
process.

Module Name No The name of a module you want to access.

Each module is predefined with multiple operations of
various categories. Every module corresponds to a particular
web service implemented by Workday.

ActiveMatrix BusinessWorks Plug-in for Workday supports
the following modules:

Human_Resources
The Human_Resources module integrates multiple
categories of operations that expose Workday human
capital management business services data, including
employee, contingent worker and organization
information.

Payroll
The Payroll module integrates multiple categories of
operations that expose Workday payroll business services
data.

Staffing
The Staffing module integrates multiple categories of
operations that expose Workday human capital
management business services and data. These services
pertain to staffing transactions for both employees and
contingent workers, such as bringing employees and
contingent workers on board.

After selecting the module name, the shared resources and
module properties of the WorkdayInvoke activity are
automatically generated.
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Field
Module
Property? Description

Operation Filter No The category of an operation.

If you select Select All from the Operation Filter list, all
operations on the selected module become available in the
Select Operation list.

Select Operation No The operation to be performed.

Description

In the Description tab, you can enter a short description for the WorkdayInvoke activity.

Advanced

In the Advanced tab, you can specify the WorkdayInvoke activity timeout in seconds.

The following table lists the configurations in the Advanced tab of the WorkdayInvoke activity:

Field
Module
Property? Description

Activity Timeout
(seconds)

Yes The WorkdayInvoke activity timeout in seconds. You can either
select a preset timeout or specify a custom timeout in seconds.

The preset timeout options are: Default Timeout, 30, 60, and 120
seconds.

Conversations

In the Conversations tab, you can click Add New Conversation  to initiate a conversation. A
conversation represents two or more related message exchanges in the same process that are correlated
by the BusinessWorks engine.

See TIBCO ActiveMatrix BusinessWorks Application Development for more details about how to use
conversation.

Input

In the Input tab, you can specify the required input of the activity depending on the specific operation
type you select in the General tab.

The following table lists the input elements in the Input tab of the WorkdayInvoke activity:

Input Item Data Type Description

input

message

complex The input message of the operation. This element contains all
the input message information for the operation.

Output

In the Output tab, the output of the activity varies depending on the specific operation type you select
in the General tab.

The following table lists the output elements in the Output tab of the WorkdayInvoke activity:
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Output Item Data Type Description

output

message

complex The output message for the operation. This element contains all
the output message information for the operation.

Fault

In the Fault tab, you can find the error information of the WorkdayInvoke activity.

The following table lists error schema elements in the Fault tab of the WorkdayInvoke activity:

Error Schema
Element

Data
Type Description

ActivityTimeOutException

msg String Displays the error message.

msgCode String Displays the error code.

Validation_Fault

Message String Displays the validation error message.

Detail_Message String Displays the details of the validation error message.

Xpath String Displays the XML path of specific nodes in an XML document.

Processing_Fault

Detail_Message String Displays the details of the processing error message.
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Working with Notification Processes

You can use the notification processes to listen to user data changes on Workday cloud applications.

You can use the notification processes to listen to various user events triggered on a specified record in
Workday cloud applications, for example, the add, update records, along with other user events.

Before you use the notification processes, you must complete the following operations:

● Configure the notification processes to actively listen on a server with a public IP address to receive
notification messages sent from Workday cloud applications.

For example, a server hosted in a DMZ on a public network, or a server on a public cloud with a
public IP address. You can set the configurations with the module properties.

See Running the Notification Processes for more details.
● Set the value in the Notification URL field in the External Endpoints area to the actual server

address and port on the Workday cloud platform to ensure the Workday applications can send
notification messages to the exact server host.

See Adding Notification URL Information to Workday Cloud Applications for more details.
● Configure the HTTP communication mode between the notification processes and the Workday

applications for receiving user event notification messages for the notification processes.

To monitor data changes on Workday cloud applications, you have to complete the following tasks:

1. Importing the Notification Project

2. Downloading the Notification WSDL File

3. Running the Notification Processes

4. Adding Notification URL Information to Workday Cloud Applications

Importing the Notification Project
Before running the notification project, you must import the project to TIBCO Business Studio.

Procedure

1. Start TIBCO Business Studio using one of the following ways:

● Microsoft Windows: click Start > All Programs > TIBCO > TIBCO_HOME > TIBCO Business
Studio version_number > Studio for Designers.

● Mac OS and Linux: run the TIBCO Business Studio executable file located in the TIBCO_HOME/
studio/version_number/eclipse directory.

2. From the menu, click File > Import.

3. In the Select dialog, expand the General folder and select the Existing Studio Projects into
Workspace item. Click Next.

4. In the Import Projects dialog, click Browse next to the Select archive file field to locate the
notification project. Click Finish.
The notification project is located in the TIBCO_HOME/bw/palettes/workday/version_number/
studio_projects_archive directory.

Result

The notification project is imported to TIBCO Business Studio.
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Downloading the Notification WSDL File
After importing the notification project, you have to download the notification WSDL file from
Workday.

Prerequisites

Ensure that you have imported the notification project, as described in Importing the Notification
Project.

Use the WSDL files that are downloaded with your own account. The value of the location attribute
in the soapbind:address element in the WSDL file must contain the host URL, so the WorkdayInvoke
activity works correctly.

Procedure

1. Right-click the notification project that you just imported in the Project Explorer view, and select
Workday Tools > Download WSDL.

2. In the Download WSDL dialog, enter the URL that the WSDL file is located in the WSDL URL field.
Download the notification WSDL file for the notification processes.

The Workday download tool supports the HTTP and HTTPS protocols. The HTTPS
protocol does not support self-signed HTTPS website.

3. Optional: If you have downloaded the WSDL file from the Workday website and want to access the
WSDL file in your intranet, select the Authentication check box to authenticate your right to access
the intranet where the WSDL file is saved. Enter the values in the User Name and Password fields
to access the intranet.

4. Click OK.

5. In the Download WSDL dialog, click OK to download the WSDL file. Click OK when the download
is completed.
The WSDL file is downloaded under Project_Name > Service Descriptors.
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6. From the menu, click Project > Clean to clean the project. In the Clean dialog, click OK.

Running the Notification Processes
After importing the notification project and downloading the notification WSDL file, you can run the
processes to see how the notification project works.

Prerequisites

Ensure that you have imported the notification project to TIBCO Business Studio, as described in 
Importing the Notification Project, and downloaded the notification WSDL file from the Workday
website, as described in Downloading the Notification WSDL File.

Procedure

1. In the Project Explorer view, click Module Descriptors > Module Properties to update the module
properties used in the notification project.

Ensure that the host and port are consistent with the actual public IP address that you use
as the server.

2. In the Project Explorer view, click Resources >
companyname.bw.palette.workday.sample.notification. Double-click the following shared
resources and XML files to edit:

● HTTPConnectorResource.httpConnResource
● WssProvider_AuthenticationProvider.authxml
● WssProvider_WSSAuthProvider.wssResource
● XmlUsers.xml

The user name and password must be consistent with the configurations in the External
Endpoints area on the Workday cloud platform.

See HTTP Connector in TIBCO ActiveMatrix BusinessWorks Bindings and Palettes Reference, and policy
in TIBCO ActiveMatrix BusinessWorks Concepts for more details.

3. Create a new project that includes a new process to receive and process the notification message,
which is sent by the process in the imported project.

See Running the Notification Sample Processes for an example.

The project name must be consistent with the basic structure of the componentName
property of the imported process. For example:
companyname.bw.palette.workday.sample.notification.serviceprovider.

The host must be consistent with the HTTP connector configurations in the imported
project, and the port must be different.

4. Download the notification WSDL file for this new project.
See Downloading the Notification WSDL File for more details.

5. On the toolbar, click the  icon to save your changes.

6. From the menu, click Run > Run Configurations to run the two processes.

7. In the "Create, manage, and run configurations" dialog, expand BusinessWorks Application and
click BWApplication. In the right panel, click the Applications tab, ensure that the check boxes next
to the two processes are selected.

8. Click Run to run the processes.
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Adding Notification URL Information to Workday Cloud Applications
After running the notification processes on a server with a public IP address, you must add server
information to Workday cloud applications.

Workday cloud applications can send an event notification message to TIBCO ActiveMatrix
BusinessWorks Plug-in for Workday to inform the plug-in of any data change in Workday.

Prerequisites

Ensure that you have run the notification processes in TIBCO Business Studio, as described in Running
the Notification Processes.

Procedure

1. Log on to the Workday website as an administrator.

2. Navigate to the Edit Subscriptions page.

3. On the Edit Subscriptions page, find the External Endpoints area, ensure that you complete the
following operations:

● Do not select the Disable Endpoint check box.
● Enter the actual IP address and port number of the server, plus the endpoint URI of the

notification process as the value in the Notification URL field.
● Enter the values in the Notification User Name and Notification Password fields to the same

values as in the XmlUsers.xml file.

4. Click OK.
The notification URL of the external endpoint connecting to Workday cloud applications is
updated. Therefore, after the notification processes start and any data change occurs in Workday
cloud applications, a notification message is sent to the notification processes which are installed on
the server with a public IP address.
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Working with Sample Projects

The plug-in packages four sample projects with the installer. The sample projects show how TIBCO
ActiveMatrix BusinessWorks Plug-in for Workday works.

After installing the plug-in, you can locate the sample projects in the TIBCO_HOME/bw/palettes/
workday/version_number/samples directory. This sample directory contains subdirectories that
contain processes. Each process corresponds to a task.

● CreateEditNamedProfessorship

This project shows how to use TIBCO ActiveMatrix BusinessWorks Plug-in for Workday to create
and edit a named professorship in Workday cloud application.

● GetUpdateEmployeeInfo

This project shows how to use TIBCO ActiveMatrix BusinessWorks Plug-in for Workday to retrieve
and update employee information, and receive the updated information from Workday cloud
application.

● Notification

This project shows how to listen to various user events triggered on a specified record in Workday
cloud application.

● PutGetWorkerTaxTreaty

This project shows how to use TIBCO ActiveMatrix BusinessWorks Plug-in for Workday to add tax
treaty data to Workday cloud application, and retrieve the data from Workday cloud application.

To use the sample projects, you have to complete the following tasks:

1. Importing the Sample Project

2. Downloading the Required WSDL Files

3. You can run the following processes:

● Running the Example Processes
● Running the Notification Sample Processes

Importing the Sample Project
Before running the project, you must import the sample project to TIBCO Business Studio.

Procedure

1. Start TIBCO Business Studio using one of the following ways:

● Microsoft Windows: click Start > All Programs > TIBCO > TIBCO_HOME > TIBCO Business
Studio version_number > Studio for Designers.

● Mac OS and Linux: run the TIBCO Business Studio executable file located in the TIBCO_HOME/
studio/version_number/eclipse directory.

2. From the menu, click File > Import.

3. In the Select dialog, expand the General folder and select the Existing Studio Projects into
Workspace item. Click Next.

4. In the Import Projects dialog, click Browse next to the Select archive file field to locate the sample.
Click Finish.
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The sample projects are located in the TIBCO_HOME/bw/palettes/workday/version_number/
samples directory. Samples are included in different directories within this main directory:

● CreateEditNamedProfessorship

● GetUpdateEmployeeInfo

● Notification

● PutGetWorkerTaxTreaty

Result

The GetUpdateEmployeeInfo sample is imported to TIBCO Business Studio.

Downloading the Required WSDL Files
After importing the sample project, you have to download the required WSDL files from Workday.

Prerequisites

Ensure that you have imported the sample project, as described in Importing the Sample Project.

Use the WSDL files that are downloaded with your own account. The value of the location attribute
in the soapbind:address element in the WSDL file must contain the host URL, so the WorkdayInvoke
activity works correctly.

Procedure

1. Right-click the sample that you just imported in the Project Explorer view, and select Workday
Tools > Download WSDL.

2. In the Download WSDL dialog, enter the URL that the WSDL file is located in the WSDL URL field.
Download the human resources WSDL file for the CreateEditNamedProfessorshipProcess.bwp and
GetUpdateEmployeeInfoProcess.bwp, the notification WSDL file for the notification processes, and
payroll WSDL file for the PutGetWorkerTaxTreatyProcess.bwp.
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The Workday download tool supports the HTTP and HTTPS protocols. The HTTPS
protocol does not support self-signed HTTPS website.

3. Optional: If you have downloaded the WSDL file from the Workday website and want to access the
WSDL file in your intranet, select the Authentication check box to authenticate your right to access
the intranet where the WSDL file is saved. Enter the values in the User Name and Password fields
to access the intranet.

4. Click OK.

5. In the Download WSDL dialog, click OK to download the WSDL file. Click OK when the download
is completed.
The WSDL file is downloaded under Project_Name > Service Descriptors.

6. From the menu, click Project > Clean to clean the project. In the Clean dialog, click OK.

Running the Example Processes
After importing the sample project and downloading the required WSDL files, you can run the
processes to see how TIBCO ActiveMatrix BusinessWorks Plug-in for Workday works.

Prerequisites

Ensure that you have imported the sample project to TIBCO Business Studio, as described in Importing
the Sample Project, and downloaded the required WSDL files from the Workday website, as described
in Downloading the Required WSDL Files.

Procedure

1. In the Project Explorer view, click Module Descriptors > Module Properties to update the module
properties used in the example project.

Some common properties are used for all modules in the example project, such as the host
and port of the HTTP Client shared resource, and the URL and password of the Keystore
Provider shared resource. For each module, you can also configure the user name and
password of the Identity Provider shared resource, and the endpoint URI used for
transport.

2. On the toolbar, click the  icon to save your changes.

3. From the menu, click Run > Run Configurations to run the selected process.

4. In the "Create, manage, and run configurations" dialog, expand BusinessWorks Application and
click BWApplication. In the right panel, click the Applications tab, select the check box next to
companyname.bw.palette.workday.sample.Sample_Name.application.

5. Click Run to run the process.

6. Click the  icon to stop the process.

Running the Notification Sample Processes
After importing the sample project and downloading the required WSDL file, you can run the
processes to see how the notification project works.

Prerequisites

Ensure that you have imported the sample project to TIBCO Business Studio, as described in Importing
the Sample Project, and downloaded the required WSDL file from the Workday website, as described
in Downloading the Required WSDL Files.
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Procedure

1. In the Project Explorer view, complete the following operations to update the module properties
used in the notification project:

● Click companyname.bw.palette.workday.sample.notification > Module Descriptors > Module
Properties.

Ensure that the host and port are consistent with the actual public IP address that you
use as the server.

● Click companyname.bw.palette.workday.sample.notification.serviceprovider > Module
Descriptors > Module Properties.

Ensure that the host is consistent with the actual public IP address that you use as the
server, and the port must be different.

2. In the Project Explorer view, click Resources >
companyname.bw.palette.workday.sample.notification. Double-click the following shared
resources and XML files to edit:

● HTTPConnectorResource.httpConnResource
● WssProvider_AuthenticationProvider.authxml
● WssProvider_WSSAuthProvider.wssResource
● XmlUsers.xml

The user name and password must be consistent with the configurations in the External
Endpoints area on the Workday cloud platform.

See HTTP Connector in TIBCO ActiveMatrix BusinessWorks Bindings and Palettes Reference, and policy
in TIBCO ActiveMatrix BusinessWorks Concepts for more details.

3. On the toolbar, click the  icon to save your changes.

4. From the menu, click Run > Run Configurations to run the two processes.

5. In the "Create, manage, and run configurations" dialog, expand BusinessWorks Application and
click BWApplication. In the right panel, click the Applications tab, select the
companyname.bw.palette.workday.sample.notification.application and
companyname.bw.palette.workday.sample.notification.serviceprovider.application check boxes
to run the two notification processes.

6. Click Run to run the processes.
The processes run successfully only after adding the URL information to Workday cloud
applications, see Adding Notification URL Information to Workday Cloud Applications for more
details.
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