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Introduction

Intended Audience
This document is intended for users who wish to use TIBCO Foresight programs with XML
data.

TIBCO Foresight Products that work with XML

Note: TIBCO Foresight products can use XML on the Windows platforms only.

Program What you can do For more information, see …

TIBCO Foresight®
EDISIM® 6.7 or later
(Standards Editor, Doc
Builder, EDISIM®
Validator)

Import, create,
edit, print
schemas and DTDs

Validate XML data

Create
documentation

Foresight® EDISIM®’s Documentation
directory:

l TIBCO Foresight® EDISIM® Standards
Editor User Guide

l TIBCO Foresight® EDISIM® Document
Builder User Guide

l TIBCO Foresight® EDISIM® Validator User
Guide

TIBCO Foresight® HIPAA
Validator® Desktop
Desktop

Validate XML data See in TIBCO Foresight® EDISIM® Validator User
Guide Foresight® HIPAA Validator Desktop’s
Doc directory

TIBCO Foresight®
Instream® (validate,
Document Splitter)

Validate XML data

Split into good

Foresight® Instream’s Doc directory:

l TIBCO Foresight® Instream® Validation
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Program What you can do For more information, see …

and bad data Technical Manual

l TIBCO Foresight® Instream® Document
Splitter

Overview
You can:

l Import a schema or DTD into Foresight EDISIM Standards Editor, where you can edit
it, including adding business rules.

l Validate XML data against the schema or DTD in Foresight EDISIM Validator, Foresight
HIPAA Validator Desktop, or Foresight Instream.

l Split good from bad data with Document Splitter.

Since XML is not firmly based on standards the way EDI is, you will notice differences in
how it is implemented in TIBCO Foresight products:

l EDI has guidelines, XML has schemas and DTDs.

l You must have Foresight EDISIM to use XML at TIBCO Foresight. It creates a TIBCO
Foresight “guideline” (STD file) from the schema or DTD.

l Foresight EDISIM Standards Editor imports, edits, and exports schemas and DTDs.
Any valid schema or DTD will work.

l In Foresight EDISIM, XML enumerated values are stored in application value lists
rather than code lists.

l You can create a schema or DTD from scratch in Foresight EDISIM but it is currently
much easier to create it another way and then import it.

l APF files are honored by XML validations.

l Foresight Instream validates and splits XML under Windows only.

l Foresight HIPAA Validator Desktop’s Library does not work with XML guidelines.

l Some XML resources
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o http://www.w3schools.com/xml/default.asp

XML tutorial

o http://www.w3schools.com/schema/default.asp

Schema tutorial

o http://www.w3.org/XML/Schema

Schema reference

o http://www.xml.com/axml/testaxml.htm .

Annotated XML specification

Demos
For a complete list of demos, see TIBCO Foresight® Instream® Index of TIBCO Foresight
Validation Demo Files.

Program Data file Validate with …

Foresight EDISIM XML_PO_f.xml

XML_PO_g.xml

in EDISIM’s Samples directory

XML_PO_F

XML_PO_G

(use EDISIM Validator)

Foresight HIPAA
Validator Desktop

XML_PO_f.xml

in HIPAA Validator Desktop’s
DemoData directory

XML_PO_F

Foresight HIPAA
Validator Desktop

XML_275.txt

in HIPAA Validator Desktop’s
DemoData directory

Start with 275_X151

Select XHL7 when it reaches the
Bin segment

Program Script Output

Foresight Instream V_XML_PO

in the Scripts directory of

XML_PO_f_Results.txt

or XML_PO_Results.txt
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Program Data file Validate with …

Instream in Instream’s Output directory

Foresight Instream
(HIPAA)

V_DS_XML_split_PO

ValidationHighlighter_XML

Various files in the Output
directory of Instream

Validation Highlighter ValidationHighlighter_XML

in the Scripts directory of
Instream

XML_PO_f.html

or XML_PO.html

in the Output directory of
Instream

TIBCO Foresight®
Translator

T_837I_4010_to_XML_and_back 837Iclean_edi.txt

837Iclean_xml.xml

In Translator’s Output directory

Tutorial
This tutorial will walk you through the most basic steps in editing a schema and validating
XML data with it.

Importing the Schema into EDISIM
1. Open EDISIM Standards Editor.

2. Choose File > Import > Import XML Schema and open it.

3. Go to EDISIM’s Samples directory and choose XML_PO_f.xsd.

4. In the Import Standard box, use XML_PO_f and click OK.

5. Set up the version.

To do this, expand the SCHEMA line and notice that the root element is called PO.

In TIBCO Foresight XML guidelines, we use the name of the root element as the
version.
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Choose File > Properties > General tab and type PO for Version (it will initially have
VRI, which is just a placeholder):

Editing the Schema in TIBCO Foresight EDISIM
1. Expand the PO element and select the PO_NUMBER element:
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2. In the bottom pane, enter the Purchase Order Number for Description and change its
Minimum Occurrences to 1 to indicate that it must be used.

3. Select PO_DATE in the top pane. In the bottom pane, enter the Purchase Order Date
for its Description, and add this Length and Pattern:

The pattern can be anything from the full set of regular expressions. This one means
that it can contain only digits. See the Help menu for more examples.

4. Acceptable XML data values are called enumerations. These go in application values
lists rather than in the code value pane.

Right-click on BT_COUNTRY and choose Application Values… .

Set up the application value list like this:

Click Attach. This requires that the value for this element always be the US.
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5. Under ORDERS > Group, set the Min to 1 in the top pane for

LINE_ITEM

PROD_QTY

PROD_UNITS

UNIT_PRICE

PROD_NUM

This means that these are required.

6. We want to ensure that we get either a BT_NAME or a ST_NAME.

Set up a variable on the first one.

Right-click on BT_NAME.

Capture the contents in a variable called BILLNAME:
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Click OK

7. Right-click on the other element in the condition, ST_NAME, and set up this variable:

Close and re-open the business rules dialog and click NEW:

Make these selections in the When to Run Rule area:

Select DisplayErrorByNumber in the What Rule to Run dropbox, and set this up to
display an error message if the elements don’t exist. (If the grid doesn’t appear, click
the Text button.)
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Click OK twice.

8. Save.

See TIBCO Foresight® Instream® Business Rules for more information.

Validating data with TIBCO Foresight EDISIM
Validator or TIBCO Foresight HIPAA Validator
Desktop
You can now validate XML data using XML_PO_f.

1. Click the Foresight EDISIM Validator toolbar button within Standards Editor:

This opens the Foresight EDISIM Validator, which is installed in Foresight EDISIM’s Bin
directory.

(If you want to use Foresight HIPAA Validator Desktop instead, copy XML_PO_f.std
from Foresight EDISIM’s User Files\Public Guidelines directory to Foresight HIPAA
Validator Desktop’s Database directory and then open Desktop. You may have the
Foresight HIPAA Validator Desktop toolbar button in Standards Editor.)

2. Choose File > Open, navigate to Foresight EDISIM’s Samples directory, and select
XML_PO_f.xml.

3. In the Select Standard box, choose our XML guideline XML_PO_f
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4. When the validation completes, click on the blue errors at the top and look at the
XML data in the bottom pane to see where the error occurred:

The USA is not valid. The application value list specified a value of the US.

PROD_NUM appears twice and it is only allowed once

Validating data with TIBCO Foresight Instream
Guideline XML_PO_f is already installed in the Database directory of Foresight Instream.

1. Move the existing installed directory from the Database directory of Foresight
Instream, to use the guideline which you have created.

2. Copy the desired directory from EDISIM's User Files\Public Guidelines.

3. Go to the Scripts directory of Foresight Instream and view the contents of the XML_
PO_F script.

Notice that the guideline parameter is

-xgXML_PO_F. The –xg indicates an XML guideline.

4. Close the script and execute it.

5. Go to the Output directory of Foresight Instream and view the contents of XML_PO_
f_Results.txt. Notice the error detailed in the EDTL record and the following EMSG
record. These records are described in the TIBCO Foresight® Instream® Validation
Technical Manual in the Doc directory of Foresight Instream.

Printing Guideline Documentation
To create formatted documentation:

1. Open Foresight EDISIM Document Builder.

2. Choose File > Open Standard, choose XML_PO_f, and click OK.

3. Click Print Preview:
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4. Click in the document to see the various levels of magnification and use the scroll
bar to see the entire page.

5. Use the Next Page button to see other pages.

6. Click Close to close Print Preview.

7. Close Document Builder.

See Printing DTDs and schemas.
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Using Standards Editor with Schemas and
DTDs

Importing a Schema or DTD
To import:

1. Open Standards Editor.

2. To import a schema, choose File > Import > Import XML Schemaand open it. To
import a DTD, choose File > Import > Import XML DTD and open it.

3. Navigate to the schema or DTD file and then choose Open.

During the import, the Standards Editor saves it as an STD file in EDISIM’s User
Files\Public Guidelines directory.

If the schema has to import or include elements, the referenced schemas will be imported
as part of the master schema that contains them – if they are available to Foresight EDISIM.

You can then edit it or:

l Use Foresight EDISIM Validator to validate XML data.

l Use Foresight HIPAA Validator Desktop or Foresight Instream to validate XML data.

l Use Docsplitter to split an XML file into good and bad XML data files.

Opening a Schema or DTD
If you have already imported your schema or DTD into EDISIM, you can open it just as you
do any other guideline:

1. Open Standards Editor.

2. Choose File > Open and choose the User Guidelines tab.



TIBCO Foresight® EDISIM® Using XML

16 | Using Standards Editor with Schemas and DTDs

3. Select the guideline and click Open.

Top Pane
The Standards Editor top pane for an XML guideline looks similar to the top pane for an
EDI guideline in that it has a Dictionary Section and a local SCHEMA or DTD section (like a
Set or Message).

Column Contents

Key

Group Available in group elements to define the order and requirement of elements it
contains. SCHEMA or DTD order indicators that define the order in which the
child elements can occur:

Group – Use only in the dictionary when defining a complex type. Defines this
as a group of elements.

All - Child elements can appear in any order; each child element can occur 0 or
1 time.

Choice – Only one of the child elements can occur.

Seq - Child elements must appear in the sequence in which they are listed.

Type The element’s type. If it is a built-in XML type, it is preceded with a colon.

Examples:

:date

:integer

If it is from one of the Types dictionaries, it does not have the colon. To
change the type, click on it in the top pane, or use the bottom detail pane’s
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Column Contents

Type field or Change Type button.

Use This column is not used for XML guidelines.

Min The minOccurs occurrence indicator: the element must occur at least this
many times at this location in the data

0 means the element is optional and can be left out of the data altogether.

Any other number means it must be used at least that many times.

Max The maxOccurs occurrence indicator: the element cannot appear any more
than this number of times at this location in the data.

>1 means unbounded

Indicators These abbreviations are visual cues to characteristics such as level notes,
business rules, code values, and other items that do not always appear on the
screen. For a list, search for “indicators” in TIBCO Foresight® EDISIM® Standards
Editor User Guide.

Bottom Pane

Details View Pane
The Details View pane can be floating or docked. By default, the pane appears docked at
the bottom of the Standards Editor window.  Single click the top bar of the pane and drag
the pane to a new position. Double click the top bar of the pane to toggle between its
most recent floating and docked positions. Size and position are saved when you exit the
guideline.

Not all fields appear for every object in the top pane.



TIBCO Foresight® EDISIM® Using XML

18 | Using Standards Editor with Schemas and DTDs

Field Contents

Description For your use.

ID For your use.

Reference This element points to another item for its definition.

To identify the item to which it points, click the Change Type button
at the end of the Type field, choose Reference, and use the drop-
down list.

Type Same as Type column in the top pane. You can type in the type, or
use the Change Type button at the end of the line.

For more details, see Types.

Length For data that must be a fixed length. An integer that specifies the
exact number of digits or characters for the value.

Min Length An integer that specifies the minimum length for the value.

Max Length An integer greater than 0 that specifies the maximum length for the
value.

Pattern An optional regular expression to describe the sequence of characters
that are acceptable in the value. Use this instead of the application
value list regular expressions unless you need to use an application
value list to enforce literal values or multiple patterns.

Abstract This element is abstract, meaning it cannot be used in the data.
Instead, it should be replaced by a member of its substitution group.

If this is a type, declaring it abstract requires the use of another type
that is derived from it.

Nullable The element must be present in the data but can be empty.

Substitution Group The current element may be substituted for the element entered here.
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Field Contents

Form Optional. Determines whether this item has to be qualified with the
namespace prefix. Default is the value of the elementFormDefault
attribute of the schema element. Not available for elements directly
under the schema element.

Block Determines whether other elements can be substituted for this one.

Final Only used on elements that have the schema element as a parent.
Sets the default value of the final attribute.

Minimum
Occurrences

Same as Min column in the top pane.

Maximum
Occurrences

Same as the Max column in the top pane.

Default Value For optional elements, this value will be assumed if the element
appears in the data without a value. If the element is not in the data
at all, then the default value is ignored.

Does not apply to the required elements, since the XML must contain
a value.

For attributes, this value applies even when the attribute is missing in
the data.

Fixed Value If the XML data includes this element or attribute, it must contain this
value. If the XML omits this element or attribute, this value will be
assumed.

Edit Notes Add level notes to this item. These are for your own use and can
optionally print in Doc Builder.

Edit Rules Add business rules to this item. Please see TIBCO Foresight® Instream®
Business Rules.
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Code Values Pane
The Code Values pane is not used for XML. The XML equivalent, enumerations, should be
put into an application values list and attached to the element.

Cross Reference Pane
Cross-referencing is not available with XML data.

Editing a Schema or DTD
After importing, you can edit it much like you would any EDI guideline.

SCHEMA Section
The local SCHEMA or DTD section contains the global elements.

Each object has a Type field that identifies that object’s base type if it has one. The basic
w3c schema types all start with a colon: :string, :TOKEN, etc. You can define others under
Dictionary Objects.

In the top pane, open the root element SCHEMA to see the elements and columns that
describe them.
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Values
Enumerations define a list of acceptable values. The Code Values tab is not used with XML
data since the data does not necessarily conform to EDI limitations for codes.

Instead, use any of these with simple elements or attributes:

l Application value lists to enforce specific values

l The Pattern field in the bottom pane to enforce a pattern

l Business rules like CodeLookup > FindUserCode

Application Value Lists

This is one way to enforce literal values and patterns (regular expressions). This operates
exactly like application values when using EDI data. Please see Application Value Lists in
TIBCO Foresight® EDISIM® Standards Editor User Guide. They are best for values that do not
change much.

Pattern field

The bottom Detail pane contains a Pattern field where you can type in any regular
expression to enforce a pattern. For example, to require that the value start with TC and be
followed by digits, you would type this:

^TC[0-9]+

Please see Regular Expressions in TIBCO Foresight® EDISIM® Standards Editor User Guide for
examples and details.

Business rules to enforce values

Many extended business rules enforce values: List > ListCheck rules, CodeLookup >
FindUserCode, etc.

Example

This rule checks an external list of values in a separate file, and returns an error message if
the current value is not in the list:
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The list called Stcountry would be in a file designated by the UserTable entry in Foresight
EDISIM’s or Foresight Instream’s $Dir.ini.  Please see TIBCO Foresight® EDISIM® Business
Rules for details.

Types

Creating a Type

The Dictionary lets you create types in:

l The Simple Types Dictionary, which contains Simple Types and Global Attributes, and

l The Complex Types Dictionary, which contains Complex Types and Attribute Groups

You can create new types in the dictionary and then use them in the SCHEMA. For elements
that are used more than once, this is a good alternative to simply adding them directly in
the SCHEMA.

It also lets you edit the type in one place (the dictionary) and have it affect all places where
it is used as a type in the SCHEMA.

Example - Simple Type

Create a simple type PHONE_NUM in the dictionary and then use it twice in the schema.

1. Open Dictionary Objects at the top and click Simple Types.



TIBCO Foresight® EDISIM® Using XML

23 | Using Standards Editor with Schemas and DTDs

2. Select Edit > Create a new item … > Schema Simple Type and fill out the box like
this:

Close the box.

3. Click in the Type column for PHONE_NUM and select :string from the dropdown list.

4. Click on another line in the top pane, and then click again on PHONE_NUM to refresh
the bottom pane.

5. Fill out the bottom pane like this:
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6. Return to the SCHEMA and click BT_ADDR1:

7. Choose Edit > Add item > Schema Element and fill out the box like this.

PHONE_NUM will be at the bottom of the drop-down list after the built-in types.

There is no colon at the beginning of a type that you create.

Finish adding the element.

8. Add ST_PHONE_NUM after BT_PHONE_NUM

Example - Complex Type

Create a complex type CONTACT in the dictionary and then use it in the schema.
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1. Under Dictionary Objects, click Simple Types and create this type in the Simple
Types dictionary:

NAME Type :string Min 3 Max 20

2. Under Dictionary Objects, click Complex Types.

3. Select Edit > Create a new item … > Schema Complex Type and fill out the box
like this:

Close the box.

4. Save.

5. With CONTACT selected, choose Edit > Add item … > Schema Element and add this
simple element:

6. Highlight ContactName and add this after:
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7. Save.

Now use this type in the SCHEMA:

1. Click ST_COUNTRY in the SCHEMA and choose Edit > Add item > Schema Element.

2. Fill out the box like this:

3. Save.

4. Expand CONTACT_PERSON in the SCHEMA to see this:



TIBCO Foresight® EDISIM® Using XML

27 | Using Standards Editor with Schemas and DTDs

Notice the Italic ContactName and ContactPhone, indicating that these are being
supplied from the Complex Types dictionary.

You can use this type as often as you’d like. It is the same as having a local complex
group that contains NAME and PHONE, only you can maintain it centrally from the
dictionary.

Changing an Element’s Type

You can change an element’s type by:

l Clicking (or double-clicking, depending on your preferences) on its type in the top
pane:

l Or, by clicking the Change type button at the end of the Type field in the Detail pane:

l This displays the Change Element Type dialog:
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Where:

Selected
Item

Name and type of the current element. Parentheses at the end of the
type line contain one of these:

Complex Selected type has child elements.

ComplexContent Selected type contains data and has child
elements.

Simple Type Selected type contains data.

Type Select a type:

None Deletes the type from the element.

Simple Drop-down list offers all built-in simple types or those
from your Simple Types dictionary.
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Complex Drop-down list offers all complex types from your
Complex Types dictionary.

Reference Drop-down list offers all types defined elsewhere in
the document

Keep
children

Save the current child elements and add the one(s) from the selected
type. Available if you have child elements that are local (See Localizing an
element.)

Discard
children

Delete the current child elements and add the one(s) from the selected
type. Available if you have child elements that are local (See Localizing an
element.)

Localizing an Element
If an element uses a complex type from the dictionary, its children will display in Italic in
the top pane. In this example, the ST_ADDR1 complex element in the SCHEMA has a type of
ST_ADDR12 – which you can see in the Complex Types dictionary.

STR_ADDR1 is simply pointing to the dictionary element for its subordinate structure.
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To remind you that it refers to a dictionary type, the Standards Editor displays the
subordinates StreetAddr1 and StreetAddr2 i Italic font.

You cannot change anything in ST_ADDR1 in the schema. Changes must be made in the
dictionary, and they then will be reflected in all schema places where that element type is
used.

If you want to make changes that are local to just one place in the schema, you can
“localize” the complex element:

1. Right-click on the complex element that is using the dictionary type.

2. Choose Localize.

The subordinates are no longer in Italic and the type is in parentheses – indicating
that it was based on the type shown, but is no longer attached to it.

You can now edit the element in the SCHEMA. It will not affect any other location. If
there are other dictionary types within this element, they remain attached to their
complex types unless you localize them.

To re-attach a localized element to its dictionary element, right-click on it and choose
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Localize.

Reference Example
In this example, PO_DATE under KAVER850g has Reference selected in the detail pane so
that it uses the definition of DATES under SCHEMA:

PO_DATE’s Type is set up like this:
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Business Rules
In the business rules dialog, you can define variables with XML:

You can also use all of these buttons with XML:

With XML, you can use these features of the business rules dialog:

External routines you can use with XML

Rule Use with XML?

Reserved variables

    Current_Date ü

    Current_Delim

    Current_Element ü

    Current_ ErrCount ü

    Current_LoopCount
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External routines you can use with XML

Rule Use with XML?

    Current_LoopKey

    Current_Row and Next_Row ü

    Current_Time ü

GLOBAL_FILENAME

GLOBAL_FILEPATHNAME

    Using reserved variables in a message ü

BusinessRules.CCI

    CCIInit

    CCICollect

    CCIAnalyze

BusinessRules.CodeLookup

    FindCode ü

    FindCodeWithDate ü

    FindUserCode ü

    FindUserCodeWithDate ü

    ValidateZipState ü

BusinessRules.CustRec



TIBCO Foresight® EDISIM® Using XML

34 | Using Standards Editor with Schemas and DTDs

External routines you can use with XML

Rule Use with XML?

    DefineCustomRec ü

    OutputCustomRec ü

    RemoveCustomRecord ü

BusinessRules.DateTime

    CheckDateInRange ü

    CompareDate ü

    DateCalc ü

GetGMTDateTime ü

    ValidateDateTimeUN and ValidateDateTimeX12

BusinessRules.DBServer

    DBExecute ü

    DBQuery ü

InvokeWebService ü

BusinessRules.Exits

    ClearExits

    KeepOrder

    SetCompositePreExit

    SetElementPostExit
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External routines you can use with XML

Rule Use with XML?

    SetLoopPostExit

    SetLoopPostInstanceExit

    SetSegmentPreExit

    UserExitWithoutWait

    UserExitWithWait

BusinessRules.List

    ClearList ü

    InList ü

    ListCheck ü

    ListContig ü

    ListCount ü

    ListGetVar ü

    ListInsert ü

    ListMinMax ü

BusinessRules.Looping

    ForEach ü

    Next ü

    ExitLoop ü
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External routines you can use with XML

Rule Use with XML?

BusinessRules.ODBC

    Setting up your ODBC Connection String ü

    DBOpen ü

    DBClose ü

    DBQuery ü

    DBExecute ü

BusinessRules.Run

    RunAlways

    RunNoData

BusinessRules.Substitute

    DeleteSegment

    InsertSegment

    MakeKey

    Substitute

    SubstituteFind

    SubstituteReplace

BusinessRules.Utilities

    AppendString ü
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External routines you can use with XML

Rule Use with XML?

BuildString ü

    ChangeCase ü

    ChangeElmAttribute

    CheckFormat ü

    CreateFSUID ü

    DisplayErrorByNumber ü

    FindString ü

    GetToken ü

    Identify ü

    IdentifierLookup

    InsertIdentifier

Match ü

MatchApplList

    Normalize ü

    Numbers ü

    OracleLookup and OracleLookupWithDate ü

OutputCTX

    ReplaceChars ü
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External routines you can use with XML

Rule Use with XML?

    ReplaceString ü

    SetCheckCTT and SetCheckCTTCount

    SetIdentifier

    SubString ü

    Trim ü

TrimWhitespace ü

BusinessRules.Variable

SetLocalVariable

    SetVar ü

    AddVar ü

Divide ü

    DumpVars ü

    Balance ü

CompareNstring ü

    CompareNumeric ü

    CompareString and CompareStringNoCase ü

    Clear ü

    ClearLocalVariable ü
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External routines you can use with XML

Rule Use with XML?

    FileTable Rules ü

GetInfo ü

    GetLength ü

GetValueFromSegment

IsAlpha ü

IsAlphaNum ü

IsNum ü

SaveCurrentSegment

CheckCTT

CheckDigit

    X12 234-235 CheckDigit

    EDIFACT 3039-3055 CheckDigit

    Other CheckDigit options

    User Defined check digit

DateTime ü

FSVBExit.DisplayMessage

ProductUtilities
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Business Rules that Do Not Apply to XML
Additionally, these do not work with XML files:

*Set Usage/Status

*Use Application Value List

*Use Code Set

ICD Business Rules (HIPAA Only)

Lookahead Business Rules

Properties
To set the properties for an XML guideline, use one of these:

l Choose File > Properties > XML Schema

l Use the properties toolbar button:

l Use the Properties button on the Save dialog

The XML Schema tab looks like this:
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Field Contents

Target
Namespace

Namespace for this schema. For your own use. TIBCO Foresight products do
not use this field.

Schema ID ID for this schema. For your own use. TIBCO Foresight products do not use
this field.

Schema
Version

Version for your own use. TIBCO Foresight products do not use this field.

Element Form
Default

Determines the default Form setting for elements in your schema: must they
be qualified by the target namespace?

If set to Default in the Properties dialog, then the default setting for XML will
be used.

Attribute Form Determines the default Form setting for attributes in your schema: they
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Field Contents

Default must be qualified by the target namespace?

If set to Default here, then the default setting for XML will be used.

Block Default Determines the default Block setting for your schema: elements with which
derivations should be blocked from replacing this element.

If set to Default here, then the default setting for XML will be used.

Final Default Determines the default Final setting for your schema: how can this element
be derived?

If set to Default here, then the default setting for XML will be used.

Other
Namespaces

Other namespaces used to qualify elements in this schema

Exporting a schema or DTD
To export the current schema to an .xsd file:

Note: For HL7 document, if the Full Enveloping option is checked, then the
exported XML schema contains outer HL7 envelope segments.



TIBCO Foresight® EDISIM® Using XML

43 | Using Standards Editor with Schemas and DTDs

Procedure
1. Save the changes.

2. Choose File > Export > Export Current Guideline > To Schema or To DTD.

3. Choose the filename and location.

SEF
EDISIM stores guidelines in a public domain format called SEF in two ways:

l You can export an XML guideline in SEF format by using Export < Export Current
Guideline < To SEF.

l When you import a schema or DTD into EDISIM, it is stored as a file with the
extension STD in EDISIM’s User Files\Public Guidelines directory. This file is also in
SEF format.
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The SEF format that captures schema information has expanded from its earlier formats. If
you use EDISIM’s SEF files in other applications, please contact TIBCO Foresight technical
support.
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Printing DTDs and schemas

Printing formatted guideline documentation
EDISIM Document Builder will print formatted guideline documentation for XML schemas
and DTDs that have been imported into Standards Editor.

Because of the nature of XML, the Doc Builder output has been adjusted and does not
match the Doc Builder EDI output exactly.

Doc Builder example page 1

Doc Builder example page 2
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Many Doc Builder profile settings apply to XML guidelines.

Profile Tab Setting

Formatting All work with XML

Fonts All work with XML

Usage Indicators Most do not apply to XML

Element indicator for Must Use affects the “segment table”

Shading Shading works for Level Notes
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Profile Tab Setting

Transaction Items Does not apply to XML

Segment Items Does not apply to XML

Element Items Does not apply to XML

Segment Usage Notes Does not apply to XML

Element Usage Notes Does not apply to XML

Global Items Level Notes

Printing a text report
You can print your current XML guideline in tabular or CSV format right from the Standards
Editor.

1. Open the schema.

2. Choose File > Print.

3. Choose the options that you want:

l Indentation prints an indented tabular report.

l Comma Separated Fields creates a CSV file suitable for importing into a
spreadsheet or other application. If this is not selected, you will get a tabular
text report.

l The other selections determine the content of the output
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4. After clicking OK, you can use the Save As… and Print buttons at the bottom right.
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Using TIBCO Foresight EDISIM Validator with
XML

Before you validate XML
For XML validation, you must first import the corresponding schema into Foresight EDISIM
so that it will be put into the Foresight EDISIM database in the form of an STD file and
become available during validation.

TIBCO Foresight programs that validate XML
These TIBCO Foresight products validate XML:

Foresight
EDISIM
Validator

This program is the most convenient way to validate XML since it is installed as
part of Foresight EDISIM 6.0 and later. It will validate your XML data without
copying files anywhere.

Foresight
HIPAA
Validator
Desktop

Copy the XML guideline’s STD file from Foresight EDISIM’s User Files\Public
Guidelines directory to Foresight HIPAA Validator Desktop’s Database
directory. You can then use the Foresight HIPAA Validator Desktop and validate
XML against that guideline.

Foresight
Instream

Copy the XML guideline’s STD file from Foresight EDISIM’s User Files\Public
Guidelines directory to Foresight Instream’s Database directory. You can then
use Foresight Instream to validate XML against that guideline

The rest of this section describes how to validate with Foresight EDISIM Validator.
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Opening TIBCO Foresight EDISIM Validator
To open Foresight EDISIM Validator, use one of these methods:

l From the Standards Editor, click the toolbar icon for Foresight EDISIM Validator:

or or  (depending on the Foresight EDISIM version).

l From the Start menu, select Programs > FORESIGHT > EDISIM > Validator.

l From Windows Explorer, go to Foresight EDISIM’s Bin directory and double-click on
Validtr.exe.

Validating XML data
You can validate XML with:

l Foresight EDISIM validator (data correction not available for XML)

l Foresight HIPAA Validator Desktop (data correction not available for XML)

l Foresight Instream (and optionally use trading partner automation - see TIBCO
Foresight® Instream® Trading Partner Automation.)

Validating with TIBCO Foresight EDISIM Validator
1. Open Foresight EDISIM Validator.

2. Open an XML file:

o Choose File > Open.

o Navigate to the file. You can see some XML files in Foresight EDISIM’s Samples
directory.

As an XML example, you can choose XML_PO_f.xml.

3. Choose the XML guideline that defines how the data should look.

If you are validating XML_PO_f, choose XML_PO_F.

4. Click OK.
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5. Click OK when the analysis is complete.

You can also use trading partner automation to select guideline and profile for XML
validations. See TIBCO Foresight® Instream® Trading Partner Automation.

Viewing the results
The top pane contains diagnostic messages and the bottom pane contains the EDI
segments or XML elements.

1. Click on the first line in the top pane.

The corresponding line in the data is highlighted in the bottom pane.

2. Use your cursor keys to move down line by line in the top pane, noticing what
happens in the bottom pane.

3. When you click on a blue line (an error), the bottom pane highlights the location of
the error.
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4. Continue scrolling down and looking at each message

Creating an HTML report of XML validation
results
You can create an HTML report from your XML validation. Please see TIBCO Foresight®
Instream® Validation Highlighter.
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Splitting XML data
XML splitting is available on Windows platforms only.

Docsplitter on Windows can split XML at any complex element that repeats.

For example: you can split at ORDERS or TOTALLINES, which are complex elements and
have a Max of greater than 1.

XML splitting Demo
V_DS_XML_split_PO in the Scripts directory of Foresight Instream.
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INI file for splitting XML data
XML splitting is controlled by the Docsplitter INI file.

[Split Point] section

It looks like this:

[Split Point]
Xml=PO|PO/ORDERS

The format is:

[Split Point]
Xml=ns:rootelem|PathToSplit

where

[Split Point] Literal Text

XML= Literal Text

ns:rootelem|PathToSplit The prefix ns: with the root element followed by a vertical bar
and then the path from the root element to the split point, with
each element separated by a slash

Note: The prefix ns: is optional and is used only when it is set up in the schema.

Example 1

The root element is PO and the split point is at the ORDERS complex element:
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The INI file will contain this:

[Split Point]

Xml=PO|PO/ORDERS

This INI file will cause the XML data to split at the bold lines if an error is encountered
within an ORDERS element:

<?xml version="1.0" standalone="yes"?>
<PO>
<PURCHAGTNAME>ARTHUR JONES</PURCHAGTNAME>
<PO_NUMBER>76766541</PO_NUMBER>
<PO_DATE>19970905</PO_DATE>
<REQSHIP>19971201</REQSHIP>
<ORDERS>
<LINE_ITEM>1</LINE_ITEM>
<PROD_QTY>1000</PROD_QTY>
<PROD_UNITS>EA</PROD_UNITS>
<UNIT_PRICE>0.04</UNIT_PRICE>
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<PROD_NUM>2837645985</PROD_NUM>
<PROD_DESC>BOOT EYELETS</PROD_DESC>
</ORDERS>
<ORDERS>
<LINE_ITEM>2</LINE_ITEM>
<PROD_QTY>40</PROD_QTY>
<PROD_UNITS>CA</PROD_UNITS>
<UNIT_PRICE>54.00</UNIT_PRICE>
<PROD_NUM>SAL3337465</PROD_NUM>
<PROD_DESC>SOLE RESIN</PROD_DESC>
</ORDERS>

Example 2

The path is complex element LINEITEM within ORDERS:

The INI file will contain this:

[Split Point]
Xml=PO|PO/ORDERS/LINEITEM

[Summary Point] section

You can include an optional [Summary Point] section to display a count of the number of
split points in the file.

The format is:

[Summary Point]

Xml="element"

Where:
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[Summary Point] Literal text.

Xml= Literal text.

"<element>" An element to hold the count.

Example 3

This INI file says the split point is the ORDERS element and the TOTAL element should
contain a count of the ORDERS elements in the file. The TOTAL element here is reporting
10 ORDERS in the file:

Guideline and APF changes for splitting XML
data
No changes are needed to the XML guideline or the validation profile (APF).
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Docsplitter command line for splitting XML data
The command line is similar to the Docsplitter command line for splitting EDI data, with
these considerations:

-i The i parameter is required and must point to a validation detail results file that was
created by validating with an XML guideline.

-s The s parameter is required and must point to a Docsplitter INI file that contains, as a
minimum, a [Split Point] section with an XML line. See INI file for splitting XML.

For an example, please see V_DS_XML_split_PO in the Scripts directory of Foresight
Instream.

For details about the Docsplitter command line, see TIBCO Foresight® Instream® Document
Splitter.
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TIBCO Documentation and Support Services
For information about this product, you can read the documentation, contact Support, and
join TIBCO Community.

How to Access TIBCO Documentation

Documentation for TIBCO products is available on the Product Documentation website,
mainly in HTML and PDF formats.

The Product Documentation website is updated frequently and is more current than any
other documentation included with the product.

Product-Specific Documentation

The documentation for this product is available on the TIBCO Foresight® EDISIM®
Documentation page.

How to Contact Support for TIBCO Products

You can contact the Support team in the following ways:

l To access the Support Knowledge Base and getting personalized content about
products you are interested in, visit our product Support website.

l To create a Support case, you must have a valid maintenance or support contract
with a Cloud Software Group entity. You also need a username and password to log
in to the product Support website. If you do not have a username, you can request
one by clicking Register on the website.

How to Join TIBCO Community

TIBCO Community is the official channel for TIBCO customers, partners, and employee
subject matter experts to share and access their collective experience. TIBCO Community
offers access to Q&A forums, product wikis, and best practices. It also offers access to
extensions, adapters, solution accelerators, and tools that extend and enable customers to
gain full value from TIBCO products. In addition, users can submit and vote on feature

https://docs.tibco.com/
https://docs.tibco.com/
https://docs.tibco.com/products/tibco-foresight-edisim-latest
https://docs.tibco.com/products/tibco-foresight-edisim-latest
https://support.tibco.com/
https://support.tibco.com/
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requests from within the TIBCO Ideas Portal. For a free registration, go to
TIBCO Community.

https://ideas.tibco.com/
https://community.tibco.com/
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Legal-and-Third-Party-Notices
SOME CLOUD SOFTWARE GROUP, INC. (“CLOUD SG”) SOFTWARE AND CLOUD SERVICES EMBED,
BUNDLE, OR OTHERWISE INCLUDE OTHER SOFTWARE, INCLUDING OTHER CLOUD SG SOFTWARE
(COLLECTIVELY, “INCLUDED SOFTWARE”). USE OF INCLUDED SOFTWARE IS SOLELY TO ENABLE THE
FUNCTIONALITY (OR PROVIDE LIMITED ADD-ON FUNCTIONALITY) OF THE LICENSED CLOUD SG
SOFTWARE AND/OR CLOUD SERVICES. THE INCLUDED SOFTWARE IS NOT LICENSED TO BE USED OR
ACCESSED BY ANY OTHER CLOUD SG SOFTWARE AND/OR CLOUD SERVICES OR FOR ANY OTHER
PURPOSE.

USE OF CLOUD SG SOFTWARE AND CLOUD SERVICES IS SUBJECT TO THE TERMS AND CONDITIONS
OF AN AGREEMENT FOUND IN EITHER A SEPARATELY EXECUTED AGREEMENT, OR, IF THERE IS NO
SUCH SEPARATE AGREEMENT, THE CLICKWRAP END USER AGREEMENT WHICH IS DISPLAYED WHEN
ACCESSING, DOWNLOADING, OR INSTALLING THE SOFTWARE OR CLOUD SERVICES (AND WHICH IS
DUPLICATED IN THE LICENSE FILE) OR IF THERE IS NO SUCH LICENSE AGREEMENT OR CLICKWRAP
END USER AGREEMENT, THE LICENSE(S) LOCATED IN THE “LICENSE” FILE(S) OF THE SOFTWARE. USE
OF THIS DOCUMENT IS SUBJECT TO THOSE SAME TERMS AND CONDITIONS, AND YOUR USE HEREOF
SHALL CONSTITUTE ACCEPTANCE OF AND AN AGREEMENT TO BE BOUND BY THE SAME.

This document is subject to U.S. and international copyright laws and treaties. No part of this
document may be reproduced in any form without the written authorization of Cloud Software
Group, Inc.

TIBCO, the TIBCO logo, the TIBCO O logo, and EDISIM are either registered trademarks or trademarks
of Cloud Software Group, Inc. in the United States and/or other countries.

All other product and company names and marks mentioned in this document are the property of
their respective owners and are mentioned for identification purposes only. You acknowledge that all
rights to these third party marks are the exclusive property of their respective owners. Please refer to
Cloud SG’s Third Party Trademark Notices (https://www.cloud.com/legal) for more information.

This document includes fonts that are licensed under the SIL Open Font License, Version 1.1, which is
available at: https://scripts.sil.org/OFL

Copyright (c) Paul D. Hunt, with Reserved Font Name Source Sans Pro and Source Code Pro.

Cloud SG software may be available on multiple operating systems. However, not all operating
system platforms for a specific software version are released at the same time. See the “readme” file
for the availability of a specific version of Cloud SG software on a specific operating system platform.

https://www.cloud.com/legal
https://scripts.sil.org/OFL
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THIS DOCUMENT IS PROVIDED “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR
IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

THIS DOCUMENT COULD INCLUDE TECHNICAL INACCURACIES OR TYPOGRAPHICAL ERRORS. CHANGES
ARE PERIODICALLY ADDED TO THE INFORMATION HEREIN; THESE CHANGES WILL BE INCORPORATED
IN NEW EDITIONS OF THIS DOCUMENT. CLOUD SG MAY MAKE IMPROVEMENTS AND/OR CHANGES IN
THE PRODUCT(S), THE PROGRAM(S), AND/OR THE SERVICES DESCRIBED IN THIS DOCUMENT AT ANY
TIME WITHOUT NOTICE.

THE CONTENTS OF THIS DOCUMENT MAY BE MODIFIED AND/OR QUALIFIED, DIRECTLY OR
INDIRECTLY, BY OTHER DOCUMENTATION WHICH ACCOMPANIES THIS SOFTWARE, INCLUDING BUT
NOT LIMITED TO ANY RELEASE NOTES AND "README" FILES.

This and other products of Cloud SG may be covered by registered patents. For details, please refer
to the Virtual Patent Marking document located at https://www.cloud.com/legal.

Copyright © 1991-2025. Cloud Software Group, Inc. All Rights Reserved.

https://www.cloud.com/legal
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