The advisory reports that the client program no longer holds a lock.
Details
For background information, see
Locks.
Diagnosis
- Another client process has stolen the lock.
- This client process disconnected from the persistence service. All locks are invalid.
Actions
Request the lock again.
Fields
| Field
|
Description
|
| name
|
LOCK_LOST
|
| reason
|
TIB_ADVISORY_REASON_LOCK_STOLEN
TIB_ADVISORY_REASON_LOCK_LOST_ON_DISCONNECT
|
| lock_name
|
The string value of this field contains the name of the lock that was stolen or lost.
|
Copyright © Cloud Software Group, Inc. All rights reserved.