How to Edit Data Connection Properties


Note: Only data connections and connection data sources that are embedded can be edited within the context of the analysis. For connections that are shared in the library, use the Manage Data Connections tool instead.

However, all data connections and connection data sources can be embedded, if desired. Click on the Embed in Analysis button in the Data Connection Settings dialog and the Embed in Connection button in the Data Source Settings dialog if you still have to edit data connection properties within the analysis:

If a data connection is embedded in the analysis, it can also be edited directly from the Data canvas.

To reach the Data Connection Settings dialog:

  1. On the menu bar, select Data > Data connection properties.

  2. In the Connections list, click to select the data connection that you want to edit.

  3. Click Settings....

    Response: The Data Connection Settings dialog is displayed.

To reach the Data Source Settings dialog:

  1. On the menu bar, select Data > Data connection properties.

  2. In the Connections list, click select the data connection that you want to edit.

  3. Click Settings....

    Response: The Data Connection Settings dialog is displayed.

  4. On the Data Source tab, click Settings....

    Response: The Data Source Settings dialog is displayed.

To add views to an embedded data connection:

  1. On the menu bar, select Data > Data connection properties.

  2. In the Connections list, click to select the data connection that you want to add views to.

  3. Click Settings....
    Response: The Data Connection Settings dialog is opened.

  4. On the General tab, click Edit....

    Response: The Views in Connection dialog is opened.

  5. In the Available tables in database list, double-click on the tables you want to be able to work with in Spotfire.

    Response: The tables are moved to the Views in connection list.

    Comment: Click on an item in the Views in connection list to see the columns in the selected view. You can clear the check box for columns you want to exclude from the view and, hence, any data tables built on this view.

    Comment: If the Available tables in database does not show all the tables in the database, you can click on the Edit Tables button to open the Select Database Tables dialog where you can add more tables. This may require a higher level of database permissions.

  6. In the Data Connection Settings dialog, click OK, and you will be prompted to include the added views as new data tables in your analysis. Select the check box Add as new data table for the views you want to include in your analysis.

  7. When you are done, click OK.

    Response: The added views are shown in the Data tables views list.

  8. Click OK.

Note: If you want to add a new data table from a connection that has already been added to your analysis, after you have added new views to the connection, open the Files and data flyout and, on the Recommended tab, click the connection name listed under Data connections in current analysis.

To remove views from an embedded data connection:

  1. On the menu bar, select Data > Data connection properties.

  2. In the Connections list, click to select the connection you want to remove data tables from .

  3. Click Settings....

    Response: The Data Connection Settings dialog is opened.

  4. On the General tab, click Edit....

    Response: The Views in Connection dialog is opened.

  5. In the Views in connection list, click on a view you want to remove.

    Comment: You can also hide sub-tables in the list by clearing their corresponding check box.

  6. Click on the < Remove button.

    Response: The view is removed from the Views in connection list.

  7. Repeat for each view you want to remove.

  8. When you are done, click OK.

    Response: If the removed views are used to create data tables in the analysis, you will be prompted to remove the data tables or to confirm that they will become empty.

  9. Click OK twice to close the Data Connection Settings dialog and the Data Connection Properties dialog.

Note: You can remove data tables at any time using Data > Data table properties. This will not affect the views available in the connection, and all views in the connection can be used to add data tables again from the Files and data flyout by opening your connection listed under Data connections in current analysis.

To edit the data source configuration of an embedded data connection:

If you need to change any settings regarding how the connection to the data source is made, you can reach the Data Source Settings dialog for each connection from the Data Connection Properties dialog. For example, you may need to switch from a test environment to a production environment. However, make sure not to change the connection settings unless necessary, since visualizations using the selected data connection will become invalid if the data source connection fails.

  1. On the menu bar, select Data > Data connection properties.

  2. In the Connections list, click select the data connection that you want to edit.

  3. Click Settings....

    Response: The Data Connection Settings dialog is displayed.

  4. On the Data Source tab, click Settings....

    Response: The Data Source Settings dialog is displayed.

  5. On the Login tab, click on the Edit button to the right of the Data source field.

    Response: The connection dialog for the selected data connection is opened.

  6. Make the desired changes in the dialog and click OK when done.

    Response: The data connection is updated with the changes. Note that some types of changes need to be followed by a Refresh Schema operation (see below) and possibly also an update of the available data tables.

To update login information:

If you have skipped to log in when opening an analysis, or if you need to update an expired password in an analysis, you can reach the Data Source Settings dialog for each connection from the Data Connection Properties dialog.

  1. On the menu bar, select Data > Data connection properties.

  2. In the Connections list, click select the data connection that you want to edit.

  3. Click Settings....

    Response: The Data Connection Settings dialog is displayed.

  4. On the Data Source tab, click Settings....

    Response: The Data Source Settings dialog is displayed.

  5. On the Login tab, click on the Login button to the right of the Data source field.

    Response: The login dialog is opened.

  6. Enter your login information and click OK.

    Response: The data connection is updated with the changes.

Refreshing data:

To refresh data from the database, open the Data Connection Properties dialog, and click on the data connection of interest in the Connections list.

Tip: You can also reload a data source node in a data table from the Data canvas. See Embedded or Linked Data? for more information.

To edit a custom query:

  1. Go to the Data Connection Settings dialog for the data connection containing the view based on a custom query, as described at the top of the page.

  2. Click Edit.

  3. In the Views in Connection dialog, select the custom query table you wish to edit and then click Custom Query > Edit Custom Query.

See also:

Data Connection Settings – General

Data Connection Settings – Data Source

Data Connection Settings – Cache Settings