How to Work with Data Connections and their Data Sources in the Library


Select  Tools > Manage Data Connections to create, move and edit data connections and connection data sources in the library.

Tip: You can also save an embedded data source to the library from the Data Connection Settings dialog.

  1. Select Tools > Manage Data Connections.

  2. Select Add New > Data Source and choose the selected data source type from the list.

  3. Depending on which type of data source you have selected you need to specify a different number of settings. Provide the requested information, connect to the data source, select a database and click OK.

  4. Comment: For a description of the different options, see the details information for the selected data source type.

    Response: The Data Source Settings dialog is displayed.

  5. If desired, add a Description.

  6. If desired, modify the Credentials settings.

  7. Click Save.

  8. Response: The Save as Library Item dialog is displayed.

  9. Select where in the library to save the new data source.

  10. Type a descriptive Name for the data source.

  11. If desired, type some keywords that can help other library users understand what it is.

  12. If desired, modify the Folder Permissions.

  13. Click Save.

Tip: You can also save an embedded data connection to the library from the Data Connection Settings dialog.

  1. Select Tools > Manage Data Connections.

  2. Select Add New > Data Connection and choose the selected data connection type from the list.

  3. Comment: You can also add a new Connection from Data Source in Library. If this is the case, you will select a data source, login and then continue from step 4.

  4. Depending on which type of data connection you have selected you need to specify a different number of settings. Fill in the requested information, connect to the data source, select a database and click OK.

  5. Comment: For a description of the different options, see the details information for the selected data source type.

    Response: If the connection type is a relational database you will see the Views in Connection dialog. (For OLAP systems you will instead see the Data Selection in Connection dialog and step 4 will be slightly different.)

  6. In the Available tables in database list, double-click on the tables you want to work with in Spotfire.

  7. Response: The tables are moved to the Views in connection list.

    Comment: Click on a view in the Views in connection list to see the columns in the view. You can clear the check box for columns you want to exclude from the view.

    Comment: If the Available tables in database does not show all the tables in the database, you can click on the Edit Tables... button to open the Select Database Tables dialog where you can add more tables. This may require a higher level of database permissions.

  8. If desired, you can specify that a certain view should be available as external data only, or as imported data only. Right-click on the bold view name and select Load Method and the desired option. Repeat for other views.

  9. When you are done, click OK.

  10. Response: The added data tables are shown in the Data table views list.

  11. Click Save.

  12. Response: The Save as Library Item dialog is displayed.

  13. Select where in the library to save the new data source.

  14. Type a descriptive Name for the data source.

  15. If desired, type some keywords that can help other library users understand what it is.

  16. If desired, modify the Folder Permissions.

  17. Click Save.

  1. Select File > Add Data Tables....

  2. Response: The Add Data Tables dialog is displayed.

  3. Click Add > Connection To > Shared Connection in Library.

  4. Tip: If you know the name of the connection you can type the name in the search field of the Add menu and it will directly show up in the list, under the header Shared Connection in Library.

    Response: The Select Data Connection dialog is opened.

  5. Browse to the connection of interest and click OK when it has been selected.

  6. In the Add Data Tables dialog, select which of the views in the data connection you want to add as new data tables by clearing or selecting the check boxes.

  7. For each new table, choose the Load method; whether to Import data or Keep data external (in-db analysis), and optionally, specify whether to load data on demand.

  8. Click OK.

  9. Optionally: Click File > Save As > Library Item to save the analysis in the library.

  1. Select Tools > Manage Data Connections.

  2. Select the connection of interest and click Edit.

  3. Response: The Data Connection Settings dialog is displayed.

  4. Make the required changes and save the data connection.

  1. Select Tools > Manage Data Connections.

  2. Select the data source of interest and click Edit.

  3. Response: The Data Source Settings dialog is displayed.

  4. Make the required changes and save the data source.

See also:

Example: Moving a Shared Data Source from Test to Production

Details on Manage Data Connections