Embedded or Linked Data?


When you are about to save an analysis, you should decide whether data should be stored in the analysis, or whether it should be updated when the source data is updated.

For in-memory data there are two different options available: Linked or Embedded. Which to choose depends on the data you use and who the end users of the analysis are; and also what data sources they have access to. The linked option allows a bigger flexibility, because it allows you to select different data loading settings for different parts of a data table. Therefore, the linked option is most of the times the preferred solution.

Note: In-database data can never be embedded because it is always fetched directly from the database. See Data Overview and Working With In-Database Data for more information about external data.

Linked data with the Data loading settings Always new data or New data when possible, as well as embedded data from sources that are possible to reload will be updated when clicking on the Reload Data button on the toolbar, . However, linked data sources that have the Data loading set to Stored data will not be reloaded using this procedure. They can only be reloaded manually, as described below (provided that the source is available).

Note: Reloading all data tables may take a long time if one or more data tables are very big. If data is saved linked, you can select exactly which part of a data table to reload instead, see below.

Loading or Reloading Linked Data

When you save data linked, you have the option to specify that data from different sources should have different loading behaviors. For example, this makes it possible to always get the latest data from a Salesforce.com instance, each time an analysis is opened, whereas target data from a local file can be stored in the analysis and only be updated should the targets change.

  1. If the Data panel is not open, click the Data button, data_panel_i.png.

  2. Click the Expand data panel for tools and details button, data_expand_data_panel_for_tools_and_details_i.png.

  3. In the Data table view, click Source view.

  4. Click on the node of interest in the graphical view.

  5. Click on the lower part of the node (the part with a different shade).
    data_showing_the_data_loading_pop-over.png

  6. Comment: Note that if you have selected to embed the final data table at the top level, you will not have access to data loading settings for the original nodes. In that case, you must change the Store data setting in Data Table Properties to Linked (individual settings per source) before this becomes possible. If this option is unavailable, a full reload of the embedded data table may sometimes restore the possibility to change this setting. However, some type of nodes, where the source data is unavailable, cannot have any other setting than Stored data, and will therefore not have access to the pop-over.

  7. In the Data loading pop-over, make your selection between Always new data, New data when possible or Stored data. See the information in the pop-over for details about the various options.

You can, at any time, reload the data from a linked source manually, as long as the source is available.

  1. If the Data panel is not open, click the Data button, data_panel_i.png.

  2. Click the Expand data panel for tools and details button, data_expand_data_panel_for_tools_and_details_i.png.

  3. In the Data table view, click Source view.

  4. Click on the node of interest in the graphical view.

  5. Click on the lower part of the node (the part with a different shade).
    data_showing_the_data_loading_pop-over.png

  6. In the Data loading pop-over, click Reload data, data_reload_data_button_in_pop-over.png.

  7. Response: The data is reloaded.

    Comment: If the data source is unavailable you will not be able to reload the data.

Reloading Embedded Data

When you save data embedded, you cannot reload different parts of the data table separately, as in the linked case. However, the Reload/Refresh options in the toolbar and in the Data Table Properties dialog can be used to reload data from the original data source, provided that this source is available. This means that the embedded data may not necessarily be fixed and unchanged during the lifetime of an analysis. If a reload is done, then the latest data from the original source is fetched into the analysis. Hence, the analysis will contain a snapshot of the data from the latest time of refresh and save. Simply opening an analysis with embedded data will not cause a reload of the data.

Note: This procedure will reload all parts of the selected data table that have access to the original source, except for linked sources configured to use Stored data. Those sources can only be updated manually from within the Source view in the expanded data panel.

  1. Select Edit > Data Table Properties.

  2. Click on the data table you wish to reload.

  3. Click Refresh Data. and select whether to refresh with prompt or without prompt.

    Comment: With Prompt allows you to edit transformations or import settings before the refresh whereas Without Prompt uses the latest settings.

  4. Comment: The Refresh Data button may be unavailable for some of your data tables, see below.

Restrictions on Data Reload

If you have an embedded data table with data from the clipboard, or, if you have frozen some columns in an embedded data table, the data table cannot be reloaded at all.

Note: If it is important that the analysis should contain specific data, then you might want to break the link to the original source to prevent others from refreshing data unintentionally.

Calculated Columns

Calculated columns can be cached in the analysis file, even when the main data table is linked, as long as the Data loading setting is Stored data. The values in the calculated columns are then based on the values from the most recent refresh of the ordinary data columns. When an analysis is opened, ordinary data columns may be refreshed from their data sources (if they are linked). Only those calculated columns where the original data has changed will then be recalculated. The next time the analysis is saved, the new values in the calculated columns are cached in the DXP file. You can switch off the caching of calculated columns in the General tab of the Data Table Properties dialog in order to always recalculate the calculated columns and reduce the file size of the analysis file.

If a calculated column uses a time dependent function, such as DateTimeNow(), it will always be recalculated when the file is opened, even for embedded data tables.

See also:

Save Overview

Details on Data Loading Settings

Reapplying Markings when Reloading Data