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Important Information

SOME TIBCO SOFTWARE EMBEDS OR BUNDLES OTHER TIBCO SOFTWARE. USE OF SUCH
EMBEDDED OR BUNDLED TIBCO SOFTWARE IS SOLELY TO ENABLE THE FUNCTIONALITY
(OR PROVIDE LIMITED ADD-ON FUNCTIONALITY) OF THE LICENSED TIBCO SOFTWARE. THE
EMBEDDED OR BUNDLED SOFTWARE IS NOT LICENSED TO BE USED OR ACCESSED BY ANY
OTHER TIBCO SOFTWARE OR FOR ANY OTHER PURPOSE.

USE OF TIBCO SOFTWARE AND THIS DOCUMENT IS SUBJECT TO THE TERMS AND
CONDITIONS OF A LICENSE AGREEMENT FOUND IN EITHER A SEPARATELY EXECUTED
SOFTWARE LICENSE AGREEMENT, OR, IF THERE IS NO SUCH SEPARATE AGREEMENT, THE
CLICKWRAP END USER LICENSE AGREEMENT WHICH IS DISPLAYED DURING DOWNLOAD
OR INSTALLATION OF THE SOFTWARE (AND WHICH IS DUPLICATED IN THE LICENSE FILE)
OR IF THERE IS NO SUCH SOFTWARE LICENSE AGREEMENT OR CLICKWRAP END USER
LICENSE AGREEMENT, THE LICENSE(S) LOCATED IN THE “LICENSE” FILE(S) OF THE
SOFTWARE. USE OF THIS DOCUMENT IS SUBJECT TO THOSE TERMS AND CONDITIONS, AND
YOUR USE HEREOF SHALL CONSTITUTE ACCEPTANCE OF AND AN AGREEMENT TO BE
BOUND BY THE SAME.

This document contains confidential information that is subject to U.S. and international copyright laws
and treaties. No part of this document may be reproduced in any form without the written
authorization of TIBCO Software Inc.

TIBCO, Two-Second Advantage, TIBCO Spotfire, TIBCO Spotfire Server, TIBCO Spotfire Web Player,
TIBCO Spotfire Statistics Services, TIBCO Enterprise Runtime for R, TIBCO Spotifre S+, and TIBCO
Spotfire Automation Services are either registered trademarks or trademarks of TIBCO Software Inc. in
the United States and/or other countries.

All other product and company names and marks mentioned in this document are the property of their
respective owners and are mentioned for identification purposes only.

THIS SOFTWARE MAY BE AVAILABLE ON MULTIPLE OPERATING SYSTEMS. HOWEVER, NOT
ALL OPERATING SYSTEM PLATFORMS FOR A SPECIFIC SOFTWARE VERSION ARE RELEASED
AT THE SAME TIME. SEE THE README FILE FOR THE AVAILABILITY OF THIS SOFTWARE
VERSION ON A SPECIFIC OPERATING SYSTEM PLATFORM.

THIS DOCUMENT IS PROVIDED “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

THIS DOCUMENT COULD INCLUDE TECHNICAL INACCURACIES OR TYPOGRAPHICAL
ERRORS. CHANGES ARE PERIODICALLY ADDED TO THE INFORMATION HEREIN; THESE
CHANGES WILL BE INCORPORATED IN NEW EDITIONS OF THIS DOCUMENT. TIBCO
SOFTWARE INC. MAY MAKE IMPROVEMENTS AND/OR CHANGES IN THE PRODUCT(S)
AND/OR THE PROGRAM(S) DESCRIBED IN THIS DOCUMENT AT ANY TIME.

THE CONTENTS OF THIS DOCUMENT MAY BE MODIFIED AND/OR QUALIFIED, DIRECTLY OR
INDIRECTLY, BY OTHER DOCUMENTATION WHICH ACCOMPANIES THIS SOFTWARE,
INCLUDING BUT NOT LIMITED TO ANY RELEASE NOTES AND "READ ME" FILES.

Copyright © 1996-2014 TIBCO Software Inc. ALL RIGHTS RESERVED.

TIBCO Software Inc. Confidential Information

TIBCO Spotfire® Connector for Oracle® Essbase Installation and Configuration Manual



Contents
TIBCO Spotfire Documentation and SUPPOIT SEIVICES ..ttt ittt ittt tiieriinettnnectnsecenssens 4
1T 5 T 1 [0 o AP 5
PrEIEQUISITES . . ettt ettt e ettt e e e e e e e e e e e e e e 5
0] T 5
Installing the TIBCO Spotfire CONMNECION .. i v ittt ittt it iiette e eeneeneeneenaenesaseansonnanans 6
Deploying the TIBCO Spotfire Connector SPK FIleS 10 @ SEIVEr .. ...t 6
Updating Clients with the Connector PaCKages . . ...ttt et et 7
Updating TIBCO Spotfire Webh PIaYer . . ... ...ttt e e e e ettt 7
Updating TIBCO Spotfire AULOMALION SEIVICES .. ...ttt ettt et e e e et e e e et e e et e e aeaes 7
Updating Automation ServiCes With DLLS ... ...ttt e e ettt et et e e ettt aaeennans 8
ACCESS RIGNES o ittt it it it it it ittt ettt teeeneeneeneeneenneossoneoneeneenesnesansnnannns 10
ASSIGNING the LICENSE . .ttt et e ettt e et e e ettt et et e e e e e e 10
Access to the TIBCO SpPOtfire CONMNECTON . oottt ittt ittt ittt iate i taneetnnseenesonnesonnesenns 11
Adding a Shared Data Connection to the Library . .........o i e e e 11
Adding a Local Data Connection t0 @an ANAIYSIS . .. ...ttt e et e e 11
Installing Oracle EssbaseClient on ClieNt COMPULEIS ... vttt ittt ittt it tte e enneenaaneenanns 12
Creating Environment Variables . . ... ... e e e ettt et e e e e 12

TIBCO Spotfire® Connector for Oracle® Essbase Installation and Configuration Manual



TIBCO Spotfire Documentation and Support Services

All TIBCO documentation is available on the TIBCO Documentation site, which can be found here:

https://docs.tibco.com
Product-Specific Documentation
The following documents for this product can be found in the TIBCO Documentation Library:

e TIBCO Spotfire” Deployment and Administration Manual

e TIBCO Spotfire Server Installation and Configuration Manual

e TIBCO Spotfire® Automation Services Installation and Deployment Manual
e TIBCO Spotfire® Web Player Installation Manual

 TIBCO Spotfire® Connector for Oracle® Essbase License Agreement

» TIBCO Spotfire® Connector for Oracle® Essbase Release Notes

How to Contact TIBCO Support

For comments or problems with this manual or the software it addresses, contact TIBCO Support as
follows:

e For an overview of TIBCO Support, and information about getting started with TIBCO Support,
visit this site:

http://www.tibco.com/services/support

e If you already have a valid maintenance or support contract, visit this site:
https://support.tibco.com

Entry to this site requires a user name and password. If you do not have a user name, you can
request one.

How to Join TIBCOmMmunity

TIBCOmmunity is an online destination for TIBCO customers, partners, and resident experts. It is a
place to share and access the collective experience of the TIBCO community. TIBCOmmunity offers
forums, blogs, and access to a variety of resources. To register, go to:

http://www.tibcommunity.com
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Introduction

The TIBCO Spotfire® Connector for Oracle® Essbase allows users to easily connect to an Oracle®
Essbase multi-dimensional online analytical processing (OLAP) server and analyze data from one or
more databases in Spotfire.

Use this document to install and configure the product.

Prerequisites

Roles

You must meet the following prerequisites before you start the connector installation.
* You must have a working installation of TIBCO Spotfire”. See http://support.spotfire.com/sr.asp for
the required version.

¢ You must have access to a running TIBCO Spotfire Server that Spotfire can connect to. (Installing a
TIBCO Spottfire Server is described in the TIBCO Spotfire Server Installation and Configquration Manual.)

* Each client computer or Spotfire Web Player server to run the Spotfire Connector for Oracle Essbase
must have access to the EssbaseClient C AP], as described in Installing oracle EssbaseClient on
Client Computers.

¢ At least one Oracle Essbase instance (64-bit) must be available.

For more information about the system requirements of Spotfire, see http://support.spotfire.com/sr.asp.

TIBCO Spotfire” defines different roles for installing, configuring, and administering the different
components of the system.

The roles for administering Spotfire connectors are described as follows:

Role Description

Spottire Server Responsible for installing and configuring the Spotfire Server (or servers)
Administrator and the Spotfire database. How to perform these tasks is described in the
TIBCO Spotfire Server Installation and Configuration Manual.

Spotfire Admin Responsible for setting up users and groups in the Spotfire system,
assigning licenses and preferences to the Spotfire groups, setting up the
Spotfire Library, and deploying Spotfire software packages to the Spotfire
Server. How to perform these tasks is described in the TIBCO Spotfire
Deployment and Administration Manual.

These roles can be assigned to different persons or to the same person. The person or persons assuming
the roles must be familiar with each area of knowledge.
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Installing the TIBCO Spotfire Connector

As Spotfire Admin, you must perform a number of steps to set up the Spotfire Connector for Oracle
Essbase. The first step is unzipping the package and reviewing the documentation.

Procedure

Unzip the downloaded Spotfire Connector for Oracle Essbase package, TIB_spc-
oracleess_3.2.0_win.zip, to a folder on your local disk.

The zip archive includes this PDF document, release notes and the deployment files
AdapterEssbase.spk and FormsAdapterEssbase. spk.

Deploying the TIBCO Spotfire Connector SPK Files to a Server
Use the Spotfire Server Administration Console to deploy the SPK files.

& ‘ All SPK files must be deployed to the server.

Procedure

10.

11.

Open the Administration Console located at http://spotserver: port/spotfire/ (where
spotserver is the name of a Spotfire Server and port is the port number, if other than the default)
in a web browser.

Log in as a Spotfire Administrator.
Select the Deployment tab.

In Deployment areas, select the Deployment Area Name, which specifies where to deploy the
connector.

& For more information about deployment areas, see the TIBCO Spotfire Deployment and
Administration Manual.

To the right of the Software packages area, click Add.
Response: The Add to Deployment dialog is displayed.
Click Browse, and then browse to the file AdapterEssbase. spk.

Click Open, and then click OK in the Add to Deployment dialog to upload and add the file to the
distribution.

Response: The list of software packages is updated with the contents of the file.
Repeat Step 5 to Step 7 for the next SPK file.

Click Validate to ensure the deployment is consistent with the current version.
Click Save to save and publish the deployment.

Response: The Save Deployment dialog is displayed.

Type a version number and a description for the deployment and click OK.

& ‘ For more information, see the online help for the Administration Console.
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Updating Clients with the Connector Packages

When the SPK files have been deployed to the Spotfire Server, you must perform some additional steps
to update the Spotfire clients. These steps must be performed on all computers running Spotfire.

As a Spotfire Server Administrator with responsibility to upgrade a Spotfire Automation Services
& server, you must perform these steps to obtain the DLLs that must be copied to the Spotfire
Automation Services server.

Procedure

1. Exit Spotfire.

2. Restart Spotfire and log in as usual to the server and the deployment area where you deployed the
connector packages. Spotfire notifies you that new packages are deployed on the server. Accept the
updates to download and install the new packages by clicking Update Now.

Updating TIBCO Spotfire Web Player

To make the TIBCO Spotfire® Connector work on a Spotfire Web Player server, you must update the
configuration with information about the connector.

Procedure
1. Provide server access to the EssbaseClient C AP], as described in the Installing Oracle EssbaseClient

on Client computers. Install Oracle EssbaseClient as described in Step 1.

2. Create environment variables as described in Creating Environment Variables.

& ‘ Make sure that they are specified as System variables and not as User variables.
3. Locate the web.config file in the webroot folder.
For example, C:\Program Files\TIBCO\Spotfire Web Player\[version number]\webroot.

4. Open the web. config file, and in it, find the section
<Spotfire.Dxp.Data.Access.Adapters.Settings>.

5. If the connector is not available in the <value><adapters> subsection, add an item like the
fOllOWing example: <adapter name="Spotfire.EssbaseAdapter" mode="Prompt" />

where the mode is set to the type of authentication that you want to use. The authentication types
are described in the TIBCO Spotfire® Web Player Installation and Configuration Manual.

6. Restart the computer to ensure that IIS picks up the new system variables.
What to do next

Run the webupdate.bat tool to upgrade the Spotfire Web Player server with the new packages, as
described in the TIBCO Spotfire Web Player Installation and Configuration Manual.

Updating TIBCO Spotfire Automation Services

To make the TIBCO Spotfire® connector work on a Spotfire Automation Services server, you must
perform the following;:

Procedure

1. Provide server access to the EssbaseClient C AP as described in Installing Oracle EssbaseClient on
Client computers. Install Oracle EssbaseClient as described in Step 1.
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2. Create environment variables as described in Creating Environment Variables.
& ‘ Make sure that they are specified as System variables and not as User variables.

3. Locate the file AddIns.xml in the webroot\bin folder.

Forexanqﬂe,c:\Program Files\TIBCO\Automation Services\[version number]\webroot
\bin.

4. In the <AddInRegistry> subsection, add the following item: <AddIn
FullTypeName="Spotfire.Dxp.Data.Adapters.Essbase.EssbaseAdapterAddIn,
Spotfire.Dxp.Data.Adapters.Essbase.AddIn" />

5. Restart the computer to ensure that IIS picks up the new system variables.

Copy the downloaded connector DLLs/files from the client to the Spotfire Automation Services
server. For more details about how to update Spotfire Automation Services, see Updating
Automation Services with DLLs.

Updating Automation Services with DLLs

Before you can use the connector, you must update the Automation Services server with the connector
DLLs.

Prerequisites
Complete the steps in Updating Clients with the Connector Packages.

Procedure

1. On the client computer, locate the Modules folder for your Spotfire installation.
By default, the Modules folder includes the hidden attribute. The path is usually one of the
following:
. C:\Program Files\TIBCO\Spotfire\[version number]\Modules
. C:\Program Files (x86)\TIBCO\Spotfire\[version number]\Modules

2. Locate the folder called Spotfire Oracle Essbase Connector_ xx.x.xxxx.xxxx.(The connector
folder with the word Forms is used only by the Spotfire Professional Client and not by Spotfire
Automation Services.)

The TIBCO Spotfire” Connector for Oracle Essbase creates these folders under the Modules folder
when the client is updated with connector packages.

3. Copy the following files from the folder:

e Spotfire.Dxp.Data.Adapters.Essbase.AddIn.dll
e Spotfire.Dxp.Data.Adapters.Essbase.Internal.dll
e Spotfire.Dxp.Data.Adapters.Essbase.dll

e Spotfire.Dxp.Data.Adapters.EssbaseNative64.dl1l
& ‘ 32-bit systems are not supported.

e Spotfire.Dxp.Data.Adapters.Essbase.Client.exe
4. Log in to the Automation Services server (either locally or through a remote desktop session).

5. Open the Automation Services webroot folder and then open the bin folder.

Forexanqﬂe,C:\Program Files\TIBCO\Automation Services\[version number]\webroot
\bin.
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6. Paste the copied DLLs in the webroot\bin folder.
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Access Rights

You can specify access rights to the Oracle Essbase data.

In TIBCO Spotfire® the access rights to the data from the connector is controlled by the following two
things:

¢ The data source authentication. (See the Help for your data source for more information.)

¢ The licenses enabled for the end user groups.

Assigning the License

The license assignment for TIBCO Spotfire® Connector for Oracle Essbase gives access to the Oracle
Essbase Connection dialog. Enable or disable this license for groups of users by following these steps.

Procedure

1. Log into TIBCO Spotfire® as a user with Administration privileges.
2. Select Tools > Administration Manager .

3. Click the Groups and Licenses tab and select the group for which to enable or disable the Oracle
Essbase license.

& ‘ Licenses are always assigned to groups, not to individual users.

4. On the Licenses tab, click Edit.

5. Assign the license by selecting the checkbox for the TIBCO Spotfire Connectors license group, and
the checkbox for the underlying Oracle Essbase function. Disable the license by clearing the
checkboxes.

6. Repeat Step 3 through Step 5 for all groups that should or should not have access to the Oracle
Essbase Connector functionality.
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Access to the TIBCO Spotfire Connector

After you have installed and configured the connector, you can set up connections to the Oracle
Essbase data in two different ways.

You can either:

¢ Add a shared connection to the library and use it in one or more analyses.
* Add alocal connection directly to the analysis.

If the steps in Updating TIBCO Spotfire Web Player were performed on the Spotfire Web Player server,
and an analysis using a connection has been set up, then users of the Spotfire Web Player can connect to
the Oracle Essbase data directly.

Adding a Shared Data Connection to the Library
Procedure
1. Select Tools > Manage Data Connections .
2. Click Add New, and then select Data Connection > Oracle Essbase.
What to do next

The shared data connection can then be used in an analysis by selecting Add > Connection To > Shared
Connection in Library from the Add Data Tables dialog. See the TIBCO Spotfire User’s Guide for more
information about using the Add Data Tables dialog.

Adding a Local Data Connection to an Analysis

Procedure

1. Click File > Add Data Tables .
2. Inthe Add Data Tables dialog, select one or multiple data sources to be added in a single step.

For users with access to the function, the Oracle Essbase option appears in the Add drop-down list
in the dialog.

See the TIBCO Spotfire User’s Guide for more information about using the Add Data Tables dialog.
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Installing Oracle EssbaseClient on Client computers

Prerequisites

Ensure that you have access to the appropriate Oracle Essbase Client installer and unzip any zipped
files on your computer. (For example, ClientInstallers-11122.zip.)

For more information about the supported Oracle Essbase versions, see http://support.spotfire.com/

sr.asp.

Procedure

1. In the extracted archive, locate the EssbaseClient directory containing the installation program
EssbaseClient.exe

2. Double-click EssbaseClient.exe.

3. Select the appropriate language and continue.

4. In the installer pane, click Next.

5. Make a note of the destination folder. (You need it for creating the appropriate environment
variables.) Click Next.

6. In the Custom Setup pane, ensure that both Essbase Client and Essbase Client C API are selected
to be installed before you click Next.
& The Essbase Client C AP is not selected by default. You must select it manually.

7. Click Install, and then click Finish when the installation is completed.

In the Installed Programs list of the Control Panel, you can find a listing for Oracle”

& Hyperion Essbase Client. Use this entry if you must uninstall Oracle Essbase. Also,
remember to remove the created environment variables listed in Creating Environment
Variables.

Creating Environment Variables

You must set up the required environment variables to access the C APL

&

The environment variables must be exactly as specified, and they must point to the correct paths. Make
sure no additional blank spaces are added.

Procedure

1. Open the System Properties of your computer. (On Windows 7 this is reached from Control Panel
> All Control Panel Items > System , Advanced system settings.)

2. On the Advanced tab, click Environment Variables.

3. On client computers, under System variables, click New, and then create the variable EPMHOME and

set its value to the home path for the Oracle Enterprise Management System. (For example, C:
\oracle\Middleware\EPMSysteml1R1.)

This home path contains the directories bin, bin-32, common, and products.

We recommend always using System variables, if possible. For TIBCO Spotfire® Web
& Player and Spotfire Automation Services servers, the environment variables must be
defined as System variables
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Create the variable ARBORPATH and set it to the destination folder chosen in the installer. (For
exanqﬂe,C:\oracle\Middleware\EPMSystemllRl\products\Essbase\EssbaseClient(Or
%EPMHOMEY%\products\Essbase\EssbaseClient).)

Create the variable ESSBASEPATH and set it to0 %ARBORPATH%.

Add the following to the PATH variable (or create the PATH variable): ¥ARBORPATH%\bin ; %EPMHOMEY%
\bin;

& ‘ 32-bit systems are not supported.
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