Working with Cubes in TIBCO Spotfire®

Software Release
February 2016
Contents

Figures ............................................................................................ 5
Introduction ....................................................................................... 6
  What is a Cube? .................................................................................. 6
  What are Measures? .......................................................................... 6
  What is a Dimension? ...................................................................... 7
  What is a Hierarchy? ....................................................................... 7
  Icon Descriptions .......................................................................... 8
  Cube Queries .................................................................................. 8
Large OLAP Hierarchies in Spotfire .................................................. 9
  Configuring a Cube Hierarchy to be Loaded on Request ................. 9
  Hierarchy Filters Loaded on Request ............................................. 10
Common Operations on Cubes and their Spotfire Equivalent ............. 10
Combining OLAP Data and Other Data in the Same Analysis ............ 11
  Defining a New Relation Between a Relational Data Table and a Cube Data Source Using Keys ........ 11
  Creating Column Matches Based on Keys to View Cube Data in the Same Visualization as Other Data .... 12
In-database Cubes in Spotfire ............................................................ 14
  Data Selection in Connection ......................................................... 15
  Limiting Data ................................................................................. 18
Microsoft SQL Server Analysis Services ......................................... 20
  Dimensions and Attributes ............................................................. 20
  Measure Groups ........................................................................... 20
  Hierarchies .................................................................................. 20
  Named Sets .................................................................................. 21
  Microsoft SQL Server Analysis Services Cubes in Spotfire ............ 21
  Adding In-db Data from Microsoft SQL Server Analysis Services .... 21
  Importing Data from Microsoft SQL Server Analysis Services ....... 23
  Settings for Microsoft SQL Server Analysis Services Connection .... 24
Oracle Essbase .................................................................................. 25
  Hierarchical Measures ................................................................. 25
  Adding In-database Data from Oracle Essbase .............................. 25
  Importing Data from Oracle Essbase ............................................ 27
  Spotfire for Oracle Smart View Users ......................................... 28
    Minimizing the Strain on the Oracle Essbase Database ................ 29
  Settings for Oracle Essbase Connection ....................................... 30
SAP BW ............................................................................................. 32
  InfoProviders ............................................................................... 32
  Business Explorer (BEx) Queries ................................................ 32
  Variables ...................................................................................... 32
Key Figures ................................................................. 33
Characteristics ............................................................. 33
Dimensions .................................................................. 33
Adding In-database Data from SAP BW ......................... 33
Importing Data from SAP BW ........................................ 34
Settings for SAP BW Connection .................................... 36

Data Import ................................................................ 38
Limit the Number of Dimensions .................................. 38
Data Import Best Practices .......................................... 39
Known Limitations ....................................................... 39

Creating a Shared Data Connection in the Library ......... 40
Figures

Geographical hierarchy example. ................................................................. 7
Cross table visualization in Spotfire. .................................................... 28
Introduction

This guide contains information that can be useful if you are working with cube data in TIBCO Spotfire®.

What is a Cube?

An OLAP (Online Analytical Processing) cube is a multi-dimensional representation of data. The OLAP cube consists of a set of measures (or facts) and a number of dimensions. Dimensions organize the data for a user in relation to an area of interest, such as customers, stores, or geographies. Dimensions are usually hierarchical in nature. Measures (facts) reside in the intersections between the dimensions. As such, the measures or facts are aggregated by the cube itself (either beforehand, or, they are dynamically calculated).

This differs from relational databases where the measures or facts are stored in the database table and you apply aggregation methods when the database table is queried.

Cube Example

In the schematic image above, the sides of the cube could be said to represent different dimensions and the cell contains the associated measure.

As a simplification, if side 1 represents product type, side 2 is a time unit, and side 3 is region, then the cube could be queried in several different ways: the yellow plane could mean "Show sales per product for different years.,” the pink plane could mean "Show sales per product in different regions.” and the blue plane "Show sales per region for different years."

In Spotfire, an OLAP cube is represented as a table. If you are new to Spotfire, a good starting visualization to use is the cross table visualization (also known as a spreadsheet).

What are Measures?

Measures is a general name for measurements, metrics or facts which are of interest in the data analysis. Measures are mostly numerical in nature. Examples of measures are sales, quantity, accounts, and so on.

A measure value is computed for a given point or cell by aggregating the data corresponding to the respective dimension intersection for the cell.
In Spotfire, each measure is represented as a column. Such a column is generally what you would put on the value axis of a visualization. Since measures are calculated by the OLAP cube you cannot change the aggregation method for measures in Spotfire.

In SAP BW, measures are referred to as 'Key Figures'.

**What is a Dimension?**

Dimensions organize the data in relation to an area of interest. Dimensions can be things like customers, stores, or geographies, and they are usually hierarchical in nature.

Different OLAP cube systems see dimensions differently. Some systems see dimensions as a container for related area of interests (for example, where the Customer dimension contains Occupation and Gender hierarchies), whereas other systems see dimensions as hierarchies. For systems that see dimensions as hierarchical, each dimension implicitly becomes a hierarchy.

In Spotfire, dimensions cannot be put in a visualization. They are a way to organize related data and can be seen in the Data panel and in the Views in Connection dialog, as a means of finding relevant data. Instead, it is the hierarchies that are used on axes in Spotfire visualizations.

SAP BW distinguishes between 'Key Figures' and 'Characteristics'. Key figures become measures in Spotfire, and all characteristics will be found in the 'Characteristics' dimension.

In Oracle Essbase, all dimensions are hierarchical in nature. In Spotfire, the Essbase dimensions are all shown as hierarchies.

**What is a Hierarchy?**

A hierarchy defines a set of parent-child relationships. Typically, a parent member belongs to a more general concept than its children and the parent member "summarizes" its children. Parent members can further be aggregated as the children of other parents.

A hierarchy can also be viewed as a set of mappings from a set of low-level concepts to higher-level, more general, concepts. Each concept is given a name – its level name. The levels are ordered so that a "more general" level precedes a "less general" level.

Each concept or level consists of a set of values. The level values are called members. Each member has a name and a key where the key is guaranteed to be unique.

As an example, consider a 'Geography' hierarchy that has the concepts of 'Country' and 'City', where 'Country' is more general than City. That is, the 'Geography' hierarchy has two levels 'Country' and 'City', where the 'Country' level precedes the 'City' level. There are two members; 'US' and 'Germany', who belong to the 'Country' level and four members 'Boston' (whose parent is 'US'), 'Hamburg' (whose parent is Germany), 'Berlin' (whose parent is Germany), and 'Berlin' (whose parent is US), who belong to the 'City' level.

*Geographical hierarchy example.*
Hierarchies are commonly referred to as categories in Spotfire. That is, hierarchies are generally what you would put on the categorical axis of a visualization. A hierarchy with only one (1) level is represented as a column in Spotfire. A hierarchy with more than one level is represented as a hierarchy in Spotfire.

**Icon Descriptions**

Different types of data are shown with a different icon in order to help you to quickly understand what you see.

The icons are used in many different places in Spotfire. For example, when you create a new connection, the icons are visible in the Data Selection in Connection dialog where you can specify which data to include in the connection. The icons are also visible in the data panel when the connection has been created and the data made available in Spotfire.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>🏠</td>
<td>Cube</td>
</tr>
<tr>
<td>∑</td>
<td>Measure</td>
</tr>
<tr>
<td>⬛️</td>
<td>Dimension</td>
</tr>
<tr>
<td>{}</td>
<td>Sets</td>
</tr>
<tr>
<td>🌟</td>
<td>Hierarchy</td>
</tr>
<tr>
<td>🌟🌟🌟</td>
<td>Hierarchy level 1</td>
</tr>
<tr>
<td>🌟🌟</td>
<td>Hierarchy level 2</td>
</tr>
<tr>
<td>🌟🌟🌟</td>
<td>Hierarchy level 3</td>
</tr>
<tr>
<td>🌟🌟🌟🌟</td>
<td>Hierarchy level 4</td>
</tr>
<tr>
<td>🌟🌟🌟🌟🌟</td>
<td>Hierarchy level 5</td>
</tr>
<tr>
<td>🌟🌟🌟🌟🌟🌟</td>
<td>Hierarchy level 5+, used for all levels above level 5.</td>
</tr>
</tbody>
</table>

**Cube Queries**

When working with in-database cube data, Spotfire creates MDX (MultiDimensional eXpression) queries that are sent to the cube query engine to get results back.

In an MDX query, all hierarchies in the cube matter, even if they are not specified in the query. If a hierarchy is not specified in a query, then the default member of that hierarchy is used. You can view this as an implicit slicing of the cube on the default member. The default member is usually a member that denotes “all possible items”, but this is not always the case.

For example, if you have a cube that contains one measure (‘Sales’) and two hierarchies (‘Time’ and ‘Countries’) and you use Sales on one axis and Time on another axis in a visualization. The result you will get back is Sales over Time for all countries. If you are using a currency dimension or hierarchy, it is not uncommon that the default member is a specific currency and not "all currencies". That means that you will get the value (e.g., Sales) for the currency that is the default currency. If this is not what you want, then you should ask your cube administrator to change the default member in the cube (only
possible in Microsoft SQL Server Analysis Services), or, provide a Spotfire filter for the currency hierarchy, where you can select which currency to display.

If you do not see any data in your visualizations, it could be that no data has been aggregated for the combination of default member or members and the specified hierarchies in the cube. A potential remedy to this situation is to explicitly slice or dice the cube by applying the appropriate Spotfire filter for the hierarchy or hierarchies where default members are used.

Theoretically, you could split a query enough to return the actual values from the underlying data warehouse, but the cube would still consider the query as aggregated.

Large OLAP Hierarchies in Spotfire

When you are analyzing external cube data in Spotfire, you may encounter situations when a hierarchy filter takes a really long time to load, or even fails to load. This happens because the filter is populated in advance by reading the hierarchy outline from the cube. If the hierarchy is large (with many different levels and categories), the loading of all values at once may even cause problems for the cube data source itself.

If you notice that the creation of a filter takes an unreasonably long time, or, if you know that your cube contains a very large hierarchy, you can configure the hierarchy to be loaded on request in the filter, instead of loading the entire hierarchy at once.

Configuring a Cube Hierarchy to be Loaded on Request

These steps describe how a cube hierarchy can be configured to be loaded on request, so that large OLAP hierarchies can be handled in Spotfire.

This configuration must be done separately for each large hierarchy in the cube data connection.

In this example, an embedded data connection to a Microsoft SQL Server Analysis Services cube is used as an example, but you can use the same steps to configure hierarchies from any cube data source.

Procedure

1. Select File > Add Data Tables.
2. Click Add > Connection To > Microsoft SQL Server Analysis Services.
3. Specify the Server you want to connect to.
4. Click Connect.
5. Select the Cube of interest.
6. Click OK.
7. In the Data Selection in Connection dialog, click on the object of interest in the left pane, then click Add >.
8. In the Data selection in connection list, locate the large hierarchy that you want to load on request and right-click on it.
9. From the pop-up menu, select Load Values on Request.
10. Repeat steps 8 and 9 for all hierarchies that you want to load on request.
11. When you are done with the data connection configuration, click OK.
    The connection is added to the Data tables list in the Add Data Tables dialog.
12. Make sure Keep data table external is selected under Load method.
13. Click OK in the Add Data Tables dialog.

Result

When creating a filter for the hierarchy, the values in the filter will be loaded on request.
You can edit a previously created embedded data connection by selecting **Edit > Data Connection Properties**, clicking **Settings** and then clicking **Edit**. A data connection saved in the library is edited by selecting **Tools > Manage Data Connections**, browsing to the connection in the library and clicking **Edit**.

**Hierarchy Filters Loaded on Request**

When the connection has been configured to load values on request, the hierarchy filter will query the cube for the currently shown values only, and a new query is sent to the cube each time a new category is expanded.

When hierarchies are loaded on request, the filter cannot display the search field that is otherwise available. You may also see progress indications for each category you expand, as new values are fetched from the external source.

Hierarchy filters from external cube sources will include an (All) check box and the setting that indicates that a category is only partially selected will be turned on by default. These settings can be switched off in the Filtering Scheme Properties dialog.

**Common Operations on Cubes and their Spotfire Equivalent**

Some common operations on cubes have a corresponding action in the Spotfire environment.

<table>
<thead>
<tr>
<th>Operation</th>
<th>Explanation</th>
<th>Corresponding Spotfire Equivalent</th>
</tr>
</thead>
<tbody>
<tr>
<td>Slicing</td>
<td>Slicing is the act of picking a subset of a cube by choosing a single value for one of its dimensions.</td>
<td>In Spotfire, slicing is done by bringing up a filter for the hierarchy and selecting one value. The fastest way of doing this for a multi-level hierarchy is to bring up the hierarchy filter, select the single value, right-click and choose <strong>Deselect Other Values</strong>.</td>
</tr>
<tr>
<td>Dicing</td>
<td>Dicing is the act of picking specific values from dimensions.</td>
<td>Dicing is done by bringing up filters for the hierarchies in question and selecting the specific values in those hierarchies.</td>
</tr>
<tr>
<td>Drill-down and Drill-up</td>
<td>Drill-down and drill-up are used to navigate among levels of data ranging from the most summarized (up) to the most detailed (down).</td>
<td>This is done by selecting the hierarchy that the levels belong to on a categorical axis and moving the hierarchy slider to the left (drill-up) or to the right (drill-down).</td>
</tr>
<tr>
<td>Operation</td>
<td>Explanation</td>
<td>Corresponding Spotfire Equivalent</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Rotating/Pivoting</td>
<td>Rotating (or Pivoting) is the act of changing the dimensional orientation of a report or page display. For example, a rotating operation may consist of swapping the rows and columns, or by moving one of the row dimensions to the column dimension.</td>
<td>In Spotfire, rotating is done by moving the hierarchies to a different categorical axis.</td>
</tr>
<tr>
<td>Nesting (of multi-dimensional columns and rows)</td>
<td>Nesting is a display technique used to show the results of multiple hierarchies on a column or row. The column or row labels will display the extra dimensionality of the output by nesting the labels describing the members of each hierarchy.</td>
<td>Nesting in Spotfire is done by selecting the hierarchies &quot;in nesting order&quot; on a given categorical axis. The leftmost hierarchy is the top of the nesting and the rightmost hierarchy is at the bottom of the nesting.</td>
</tr>
</tbody>
</table>

**Combining OLAP Data and Other Data in the Same Analysis**

Hierarchy values in a cube have both a caption and key. The key will always be unique, but the caption can be the same as for another hierarchy value. The key can be used for identifying a value. When you visualize data from an in-database cube in Spotfire, you may encounter cases where you cannot separate multiple instances of a value from each other (for example, when there are more than one city in the world with the same name (i.e., caption), like the case with Paris, France and Paris, Texas) in a visualization. In that case, you probably want to match values based on the keys, rather than on the values themselves. This is done by selecting the KeyOf method on the matching column of the cube directly.

When you want to combine cube data and other data (for example, data from a relational database) you must have a column that matches the cube's KeyOf values in the relational data. The keys can often be exported from the cube to provide good matching.

If a KeyOf-value is missing in a cube, an error message will be displayed in the visualization that shows the cube data. In the details for the error it will be indicated that an error occurred in the external data source. For example, this could occur if you configure a relation between a cube and a data table coming from another external system, and the data in the other system contains the key Hannover whereas the cube key is called Hanover. When Hannover is used in cube database queries, no key is found and an error is shown.

**Defining a New Relation Between a Relational Data Table and a Cube Data Source Using Keys**

If you have data in a cube data source and want to be able to use this data to retrieve details about a certain value from a relational data source on demand, or if you simply want to be able to propagate markings from the cube data source to visualizations based on the relational source, you may want to define a relation between the two data tables.

**Prerequisites**

You must have a data table based on a cube data source and one data table from a relational source available in the analysis.
Procedure

1. Select Edit > Data Table Properties.
2. Go to the Relations tab.
3. Click on Manage Relations.
4. In the Manage Relations dialog, select the data table to Show relations for.
5. Click New.
6. Select the cube data table you want to connect to from the Left data table drop-down list and the relational data table from the Right data table drop-down list.
7. Select the column containing the identifiers in the Left column and Right column drop-down lists.
8. Provided that the cube data source is on the left, under Left method, select the KeyOf method.
   Comment: This specifies that the match should be done using the cube key of that identifier and not the actual value.
9. Click OK to close all dialogs.

Result

The relational data table and the cube data table are now related.

When you are using a cube hierarchy on an axis in a visualization you will automatically see the caption and not the key. To explicitly show the keys in your visualizations, you need to set up a custom expression.

Creating Column Matches Based on Keys to View Cube Data in the Same Visualization as Other Data

If you have two columns with the same dimension values in a cube data source as well as in a relational data source and you want to display the data in the same visualization you may need to apply the KeyOf method to match the values.

Prerequisites

You must have a data table based on a cube data source and one data table from a relational source available in the analysis.

Procedure

1. Select Edit > Data Table Properties.
2. Go to the Column Matches tab.
3. In the Data tables list, select the cube data source.
4. Click New.
5. In the New Match dialog, select the other data table of interest under Right data table.
6. Make sure the columns with the matching information are selected in the Left matching column and Right matching column selectors.
7. Open the column selector for the cube column under Left Matching column and select Methods to open the menu.
   Comment: It is not possible to use KeyOf as a transformation, it must be applied directly as a method on the matching column.
8. Click OK to close all dialogs.
Result

You can now show data from both the cube data and the relational data in the same visualization.

When you are using a cube hierarchy on an axis in a visualization you will automatically see the caption and not the key. To explicitly show the keys in your visualizations, you need to set up a custom expression.
In-database Cubes in Spotfire

Because cube data is already aggregated from the start, aggregations are not performed by Spotfire when working with in-db cube data. All aggregations that need to be done (if any) are pushed down to the cube query engine. Instead, Spotfire can be used as a way to display the related combinations of measures and hierarchies configured by the cube administrator.

By taking advantage of the natural structure of the cube you can make sure that you are viewing relevant data. The free-dimensionality of Spotfire does otherwise allow you to make combinations of measures and dimensions from the cube that do not always make sense, or lead to "The expression is not valid"- messages in the visualizations.

Each time you change what is shown on the axes in a visualization based on in-db cube data, or make a selection in a hierarchy filter or a check box filter, a request is sent to the cube to provide the selected data. This means that if you make many changes in Spotfire, many requests may be sent to the database instead of just the request for the final selection.

Spotfire uses a delay of about one second in order to see if there are any additional selections made in a filter before sending the request to the database. This means that you should try to make coherent changes in filtering in a steady pace and not pause for too long while selecting various check boxes. If you pause for more than about a second, the current filter selection will be sent to the cube which will start to provide the requested data. Making additional changes to the filter will send an additional request to the database, causing a higher workload on the database, as the first request might still be running.
Data Selection in Connection

When you define a new data connection you get the option to select which cube data should be included in the connection. If the data is going to be imported it is important to limit the data as much as possible, since too large selections cannot be imported.
The cube structure is shown below. Make selections or search to limit what is shown.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>The cube structure is shown below. Make selections or search to limit what is shown.</td>
<td>The left pane shows the structure of the cube you have selected in the previous connection dialog. If you have connected to Microsoft SQL Server Analysis Services, then you will have the option to select a single measure group using a drop-down list. For all cubes it is possible to locate items containing specific words in the cube or query by typing some text in the search field. When you have located the data of interest, click to select it in the left pane, then click Add &gt;. Note that you can only select full hierarchies and not parts of a hierarchy when moving it to the Data Selection in Connection field. There, it is possible to limit data further using the Limit Data options. See Icon Descriptions for more information about what the icons in the list mean. Double-clicking on an item will expand/collapse the item in the list if possible, or, if it is a leaf node, add the item to the right pane.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Add &gt;</td>
<td>Adds the data selected in the left list to the <strong>Data selection in connection</strong> list.</td>
</tr>
<tr>
<td>&lt; Remove</td>
<td>Removes the selected data from the <strong>Data selection in connection</strong> list.</td>
</tr>
<tr>
<td><strong>Data selection in connection</strong></td>
<td>Lists the data that you have added from the cube. Type some text in the search field to locate specific words in the field.</td>
</tr>
<tr>
<td></td>
<td>Dimensions (columns or hierarchies) that can be used to limit the data in the selection may be shown in blue text, depending on the settings in the dialog.</td>
</tr>
<tr>
<td></td>
<td>You can right-click on a dimension in the field to open the pop-up menu where you can reach the <strong>Limit Data</strong> option.</td>
</tr>
<tr>
<td></td>
<td>Columns or hierarchies that have been used to limit the data may be indicated by the addition of the text (Limited), depending on the settings in the dialog.</td>
</tr>
<tr>
<td></td>
<td>See <strong>Icon Descriptions</strong> for more information about what the icons in the list mean.</td>
</tr>
<tr>
<td></td>
<td>Double-clicking on an item will expand/collapse the item in the list if possible, or, if it is a leaf node, remove the item from the right pane.</td>
</tr>
<tr>
<td></td>
<td>You can specify that the data in the connection should be available as external data only, or as imported data only, using the pop-up menu.</td>
</tr>
<tr>
<td></td>
<td>Right-click on the cube in this list and select <strong>Load Method &gt; External Data Only (In-database)</strong> or <strong>Load Method &gt; Imported Data Only (In-memory)</strong>.</td>
</tr>
<tr>
<td></td>
<td>You can also specify that a large hierarchy should load values on request only here.</td>
</tr>
<tr>
<td></td>
<td>See <strong>Large OLAP Hierarchies in Spotfire</strong> for more information.</td>
</tr>
<tr>
<td>[ ]</td>
<td>Displays a menu where you can handle limiting of data in the current selection.</td>
</tr>
<tr>
<td></td>
<td>It is always recommended to limit the data as much as possible if you intend to import data from the connection into Spotfire.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Limit Data</td>
<td>Opens the Limit Data dialog where you can further limit the data for the currently selected column in the Data selection in connection list. Note that it is only possible to limit dimensions, since measures are calculated based on the selected dimensions. You can select whether or not to indicate columns or hierarchies that can be limited using the indicate limitations menu to the right.</td>
</tr>
<tr>
<td>Remove Limitation</td>
<td>Removes the limitation previously specified for the currently selected dimension column or hierarchy.</td>
</tr>
<tr>
<td>Remove All Limitations</td>
<td>Removes all limitations from the selected data.</td>
</tr>
<tr>
<td>:</td>
<td>Displays the indicate limitations menu where you can handle indications related to data limiting in the Data selection in connection field. Indications may help you see which columns can be limited and/or which columns have been limited, but they can also be removed completely to get a cleaner user interface.</td>
</tr>
<tr>
<td>No Indications</td>
<td>Removes all indications.</td>
</tr>
<tr>
<td>Indicate All Columns Possible to Limit</td>
<td>Shows all columns or hierarchies that are possible to limit in a blue color.</td>
</tr>
<tr>
<td>Indicate All Limited Columns</td>
<td>Appends the word (Limited) to all columns or hierarchies that have been limited.</td>
</tr>
<tr>
<td>Estimate Import Size</td>
<td>Opens a dialog where you can get an estimate of the size of the current selection. The size of the selected data is important when you are going to import the data into Spotfire for in-memory analysis. See Importing Data from Cubes for more information. The values you get when doing an estimate depends on the system you use and on the data in the cube. You can use the numbers to learn whether or not this type of selection is possible to import from your system. If you try an import and it fails, make sure the estimated import size is lower the next time you try to import data. If the estimation takes a long time it often, but not always, means that the selection is too big to import.</td>
</tr>
</tbody>
</table>

**Limiting Data**

When specifying what data to work with in the Data Selection in Connection dialog, you also have the possibility to limit further on dimensions. Single sublevels in hierarchies can be selected or deselected. Limiting the dimension to view only the required data is of particular interest when you intend to import your cube data, since too large amounts of data cannot be imported from the cube. Some data sources may also have limits on the number of cells which you may import.

If you are using SAP BW BEx queries, data has already been limited due to the selections in the BEx query, so further limiting is often unnecessary. Make sure that you do not filter out all data by selecting values that have already become invalid by the selection of BEx variables.
**Procedure**

1. Select to add a data connection from a cube data source and provide all the necessary input for the connection to the data source.
   For more information about specific system settings, see the section about the system of interest in this user’s guide.

2. In the Data Selection in Connection dialog, add the interesting data to the **Data selection in connection** list to the right.

3. In the Data Selection in Connection dialog, click on the column or hierarchy to limit in the **Data selection in connection** list.

4. Click ⬤ and select **Limit Data**.

5. In the Limit Data dialog, clear the check boxes for those categories that you do not want to include in your selection.
   You can also right-click in the dialog to display a pop-up menu where you can **Select All Values** or **Deselect Other Values** (clears the check boxes for all values except for the value you right-clicked on).

6. Click **OK**.
Microsoft SQL Server Analysis Services

If you have access to data in a Microsoft SQL Server Analysis Services system, you can use the Microsoft SQL Server Analysis Services Connector in Spotfire to connect to your OLAP cube.

When you configure a connection to a Microsoft SQL Server Analysis Services cube, you can choose whether to analyze data in-database or to import it into your analysis. Note that you need to install a driver on your computer to get access to the Microsoft SQL Server Analysis Services connector. See the system requirements at http://support.spotfire.com/sr_spotfire_dataconnectors.asp to find the correct driver.

Dimensions and Attributes

Dimensions organize data with relation to an area of interest, for example, time, product, customer, region, etc. An attribute is a kind of categorization.

For each dimension, you can be interested in a number of different dimension attributes. For example, the 'Product' dimension may be investigated with regard to the attributes 'Product.Color' or 'Product.Model'. These attributes can also be organized into multi-level hierarchies.

Measure Groups

Measure groups are used to associate dimensions with measures.

A cube includes measures in measure groups, business logic, plus a collection of dimensions that give context for evaluating the numerical data that a measure provides.

Both measures and measure groups are an essential component of a cube. A cube cannot exist without at least one of each.

Spotfire allows you to select a single measure group in the Data Selection in Connection dialog, which can help you limiting the data from the cube:

Note that if you select a dimension belonging to another measure group you will automatically also include that measure group in the selection and the measure group will also be visible in the Data panel. (However, you will not get the measures from that measure group, only selected measures.)

Most of the times, you will probably only be interested in analyzing data from a single measure group, but there may be exceptions. It is important to know what you are doing if you are working with cube data in Spotfire. For example, if data is selected from two different, unrelated measure groups you might end up with empty visualizations.

Hierarchies

Hierarchies are used to organize measures that are contained in a cube. In Spotfire, attribute hierarchies and single-level user hierarchies are represented as columns, whereas multi-level hierarchies are represented as hierarchies.

In Microsoft SQL Server Analysis Services, attributes are, by default, organized into two-level hierarchies consisting of a leaf level and an optional 'All' level. The All level contains a single member – the All member – which represents the aggregated value of the attribute's members across the related measures. Note that if the hierarchy is non-aggregatable, the All level is not created.
Henceforth, this structure is called an attribute hierarchy, to distinguish it from a user hierarchy. A user hierarchy is a user-defined hierarchy of attributes that is used in Microsoft SQL Server Analysis Services to organize the members of a dimension into a hierarchical structure that provide navigation (drill-down, drill-up) paths, by which users can browse the data. The positions of members within the hierarchy are controlled by the order of the attributes in the hierarchy’s definition. Each attribute in the hierarchy definition constitutes a level in the hierarchy.

Attribute hierarchies are represented as a single column in Spotfire, containing the leaf level members and an implicit All member (if defined). The All member is not visible as a column value in Spotfire.

User hierarchies are represented as hierarchies in Spotfire unless the user hierarchy is a single level (1 level) hierarchy. Then the hierarchy is represented as a column in Spotfire.

**Named Sets**

Named sets return a data set based on a defined logic. They are primarily used to create data sets that are often requested from the cube.

There are two types of named sets – static named sets and dynamic named sets.

Spotfire currently only supports named sets that return a certain single level in a user hierarchy or an attribute hierarchy (i.e., a 1-level hierarchy). That is, Spotfire can only handle results that can be seen as a single column.

Static named sets are evaluated once during creation – they are never re-evaluated. Dynamic named sets, on the other hand, are evaluated each time a query references it and is evaluated in a current context. For example, a dynamic set may show the Top 50 customers. This dynamic set could either be displayed over different countries in the world, or within a single country, when using standard cube reporting tools.

When you are working with dynamic named sets in Spotfire, the content of a dynamic named set column depends on the current context, that is, it depends on the current limitations and filtering. Therefore, the axis expression must be evaluated after the current filtering is applied, when dynamic sets are used in visualizations.

This is different from how axes traditionally are evaluated in Spotfire, but the ‘evaluate after’-setting is applied automatically when you are placing a dynamic named set column on an axis. See Details on Advanced Settings help section in TIBCO Spotfire User’s Guide (available under Help > Help Topics) for more information about axis evaluation settings.

If you limit the selected data to male customers only, and use a set showing Top 50 customers, you will get the top 50 male customers. If limitations make the number of available male customers lower than 50, then this is the number you will end up with. All of these calculations are handled by the cube.

If you are going to import data from a Microsoft SQL Server Analysis Services cube, and named sets are included in the selection, the sets will be used to limit the data retrieved on import and to calculate the measures. For example, if the selection of data to import contains data from Germany and France, and a Top 50 customers set is used in the import, the Top 50 customers from Germany and France are imported. Filtering out Germany from the imported data may result in less than 50 values, because the set will now show only those customers that were imported from France. The same selection of data when working in-database will add the set as a dimension and the filtering will let you see the Top 50 values from France.

**Microsoft SQL Server Analysis Services Cubes in Spotfire**

Normally, you would use measures on axes where actual values are to be displayed, such as, on the value axis of a bar chart, or as cell values in a cross table. Dimension columns, that is, attribute hierarchies and user hierarchies, can be used to split the viewed data into smaller subsets on categorical axes.
When looking at cube data in the data panel you have the possibility to select one measure group and one related dimension at a time, which may help you selecting suitable options on the axes. The whole cube is treated as a single data table in Spotfire when you analyze it in-database.

There are also other implications of working with cube data. Since the measures are defined by the context of a dimension, it is not possible to create filters for measures.

When importing cube data, all cube aggregations are lost. Hierarchies are imported down to the leaf level and measure values for that level are retrieved. See Data Import more information.

**Adding In-db Data from Microsoft SQL Server Analysis Services**

Follow the steps below to add a connection with in-database data to Microsoft SQL Server Analysis Services.

**Procedure**

1. Select **File > Add Data Tables**.
   The Add Data Tables dialog is opened.

2. Click **Add > Connection To > Microsoft SQL Server Analysis Services**.
   The Microsoft SQL Server Analysis Services Connection dialog is opened.

3. Specify the **Server** you want to connect to.

4. Click **Connect**.
   Spotfire connects to the specified server, and the databases that are available on the server are listed in the **Database** name drop-down list.

5. Select the **Database** of interest.

6. Select the **Cube** of interest.

7. Click **OK**.
   The Data Selection in Connection dialog is opened.

8. Click to select data of interest in the panel to the left.
   Click on the top level to select the entire cube.
   Limit what is shown in the panel by selecting a single measure group, or by typing a search term in the search field.
   Double-click on a collapsed item to expand it, or double-click on a leaf node to send it to the **Data selection in connection** list.

9. Click **Add >** to move the selected data to the **Data selection in connection** field.

10. If desired, you can limit the selected data further by right-clicking on a dimension and selecting **Limit Data**.
    This way, you can filter out certain values of the dimension to only include values of interest. For example, you can select data from a single country only. Note that it is not possible to limit measures, only dimensions, since the cube calculates the measures in the context of the selected dimensions.

11. If desired, you can specify that the data in this connection should be available as external data only, or as imported data only. Right-click on the bold view name and select **Load Method** and the desired option.

12. When you are done with the data selection, click **OK**.
    The connection with the selected cube is added to the **Data tables** list in the Add Data Tables dialog.

13. Specify a descriptive **Name** for the connection.

14. Make sure the data table, and not the connection, is selected in the **Data tables** list and, under **Load method**, click **Keep data table external**.
15. Click **OK**.
   A connection to Microsoft SQL Server Analysis Services has now been added to the analysis, and a default visualization is opened in Spotfire.

**Importing Data from Microsoft SQL Server Analysis Services**

Follow the steps below to import data from a Microsoft SQL Server Analysis Services cube.

**Procedure**

1. Select **File > Add Data Tables**. The Add Data Tables dialog opens.
2. Click **Add > Connection To > Microsoft SQL Server Analysis Services**. The Microsoft SQL Server Analysis Services Connection dialog opens.
3. Specify the **Server** you want to connect to.
4. Click **Connect**. Spotfire connects to the specified server, and the cubes that are available on that server are listed in the **Cube** drop-down list.
5. Select the **Database** of interest.
6. Select the **Cube** of interest.
7. Click **OK**. The **Data Selection in Connection** dialog opens.
8. If you want to limit your import to data from a single measure group, select the measure group of interest in the drop-down list.
   You can also type any text in the search field to find objects containing that text only.
9. Click on the object of interest in the left pane, then click **Add >**. See **Icon Descriptions** for information about what the different objects represent. If you select the cube icon, you will get all data in the cube. When it comes to hierarchies, you always have to add the entire hierarchy to the list, but you can use the **Limit Data** button to filter out higher levels of detail in the hierarchy from the actual selection at a later stage. You can repeat this step as many times as you want to add more data to the selection.
   The selected data is added to the **Data selection in connection** list.
10. Dimension columns and hierarchies can be further limited by clicking on the selected column or hierarchy in the **Data selection in connection** list and then clicking on the button with a filter funnel and selecting **Limit Data**. The Limit Data dialog opens.
11. Clear the check boxes for categories that you want to remove from the selection.
12. Click **OK** to close the Limit Data dialog.
13. When you are done with your data selection it is recommended to click the **Estimate Import Size** button to get a hint on whether this selection will be possible to import or not.
   The calculation may take a while. No measures are taken into account in the calculation, so if you have added many measures, you may be unable to import the selection even if the estimated number of rows and columns is small. The estimated import size may be of help if an import should fail. Then, the next time you try to import data from that cube, you should try to make sure that the estimated size is smaller than the previous time.
14. When you are done with the data selection, click **OK**. The connection is added to the **Data tables** list in the Add Data Tables dialog.
15. Make sure the data table, and not the connection, is selected in the **Data tables** list and, under **Load method**, click **Import data table**.
16. Click **OK** in the Add Data Tables dialog.

**Result**

If the data selection was small enough, the data is imported.

Do all of the data selection work in a shared data connection and save it to the library instead of adding it to the analysis directly. This way you can reuse the work you have done later, or share your selections with others.

- During import, sets are applied once. This means that selection of multiple sets with no intersecting data will result in a data table without any data.
- PKIs are not supported.

**Settings for Microsoft SQL Server Analysis Services Connection**

Use this dialog to connect to Microsoft SQL Server Analysis Services.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Server</strong></td>
<td>The name of the server where your data is located. To include a port number, add it directly after the name preceded by colon. To include an instance name, add it directly after the server name preceded by backslash. Example with port number: myDatabaseServer:1234 Example with instance name: MyDatabaseServer\InstanceName</td>
</tr>
<tr>
<td><strong>Connect</strong></td>
<td>Connects you to the specified server and populates the lists of available databases and cubes. Microsoft SQL Server Analysis Services only supports Windows authentication.</td>
</tr>
<tr>
<td><strong>Database</strong></td>
<td>Select the database of interest from the drop-down list.</td>
</tr>
<tr>
<td><strong>Cube</strong></td>
<td>Select the cube of interest from the drop-down list.</td>
</tr>
</tbody>
</table>
Oracle Essbase

If you have access to data in an Oracle Essbase system, you can use the Oracle Essbase connector in Spotfire to connect to your OLAP cube.

When you configure a connection to an Oracle Essbase cube, you can choose whether to analyze data in-database or to import it into your analysis. Note that you need to install a driver on your computer to get access to the Oracle Essbase connector. See the system requirements at http://support.spotfire.com/sr_spotfire_dataconnectors.asp to find the correct driver.

Measures must be located in the dimension that is the tagged account dimension to be recognized as a measure in Spotfire.

Hierarchical Measures

In Oracle Essbase, measures can be organized in hierarchies, in contrast to other cube data sources.

When the data source structure is shown in Spotfire, a measure that is also a parent is shown both as a folder and as a separate measure, which is slightly different compared to what the structure looks like in the Oracle Essbase Administration Services user interface.

Example of Structure

Adding In-database Data from Oracle Essbase

You can add a data connection to Oracle Essbase to an analysis and select to analyze the data in-database.

Procedure

1. Select File > Add Data Tables.
The Add Data Tables dialog opens.

2. Click **Add > Connection To > Oracle Essbase**.
   The Oracle Essbase Connection dialog opens.

3. Specify the **Server** you want to connect to.

4. Enter your credentials in the **Username** and **Password** text fields.

5. Click **Connect**.
   Spotfire will connect to the specified server, and retrieve the names of the available applications.

6. From the **Application** drop-down list, select the application of interest.

7. Specify which database in the selected application you want to work with.

8. In the **Alias table** drop-down list, select from which table the member names should be retrieved.
   An alias table maps the original member name to a more user friendly name, or they could contain long or short versions of a name.

9. Optionally, select the check box **Show both the member name and the alias**.
   The member name and alias name will be shown in the user interface, separated by comma.

10. Click **OK**.
    The **Data Selection in Connection** dialog opens.

11. In the left pane, click on the object of interest, and then click **Add >**.
    See **Icon Descriptions** for information about what the different objects represent. If you select the cube icon, you will get all data in the cube. When it comes to hierarchies, you always have to add the entire hierarchy to the list, but you can use the **Limit Data** button to filter out higher levels of detail in the hierarchy from the actual selection at a later stage. You can repeat this step as many times as you want, to add more data to the selection.
    The selected data is added to the **Data selection in connection** list.

12. Dimension columns and hierarchies can be further limited by clicking on the selected column or hierarchy in the **Data selection in connection** list and then clicking on the button with a filter funnel and selecting **Limit Data**.
    The Limit Data dialog opens.

13. Clear the check boxes for categories that you want to remove from the selection.

14. Click **OK** to close the Limit Data dialog.

15. When you are done with the data selection, click **OK**.
    The connection is added to the **Data tables** list in the Add Data Tables dialog.

16. Make sure the data table, and not the connection, is selected in the **Data tables** list and, under **Load method**, click **Keep data table external**.

17. Click **OK** in the Add Data Tables dialog.

**Result**

The external data table is shown in the Data panel.

---

Do all of the data selection work in a shared data connection and save it to the library instead of adding it to the analysis directly. This way you can reuse the work you have done later, or share your selections with others.
Importing Data from Oracle Essbase

When you want to import data from an Oracle Essbase cube, it important to limit the selected data as much as possible.

Procedure

1. Select File > Add Data Tables.
   The Add Data Tables dialog opens.
2. Click Add > Connection To > Oracle Essbase.
   The Oracle Essbase Connection dialog opens.
3. Specify the Server you want to connect to.
4. Enter your credentials in the Username and Password text fields.
5. Click Connect.
   Spotfire will connect to the specified server, and retrieve the names of the available applications.
6. From the Application drop-down list, select the application of interest.
7. Specify which database in the selected application you want to work with.
8. In the Alias table drop-down list, select from which table the member names should be retrieved.
   An alias table maps the original member name to a more user friendly name, or they could contain long or short versions of a name.
9. Optionally select the check box Show both the member name and the alias.
   The member name and alias name will be shown in the UI separated by comma.
10. Click OK.
    The Data Selection in Connection dialog opens.
11. In the left pane, click on the object of interest, and then click Add >.
    See Icon Descriptions for information about what the different objects represent. If you select the cube icon, you will get all data in the cube. When it comes to hierarchies, you always have to add the entire hierarchy to the list, but you can use the Limit Data button to filter out higher levels of detail in the hierarchy from the actual selection at a later stage. You can repeat this step as many times as you want to add more data to the selection.
    The selected data is added to the Data selection in connection list.
12. Dimension columns and hierarchies can be further limited by clicking on the selected column or hierarchy in the Data selection in connection list and then clicking on the button with a filter funnel and selecting Limit Data.
    The Limit Data dialog opens.
13. Clear the check boxes for categories that you want to remove from the selection.
14. Click OK to close the Limit Data dialog.
15. When you are done with your data selection it is recommended to click the Estimate Import Size button to get a hint on whether this selection will be possible to import or not.
    The calculation may take a while. No measures are taken into account in the calculation, so if you have added many measures, you may be unable to import the selection even if the estimated number of rows and columns is small. The estimated import size may be of help if an import should fail. Then, the next time you try to import data from that cube, you should try to make sure that the estimated size is smaller than the previous time.
16. When you are done with the data selection, click OK.
    The connection is added to the Data tables list in the Add Data Tables dialog.
17. Make sure the data table, and not the connection, is selected in the Data tables list and, under Load method, click Import data table.
18. Click **OK** in the Add Data Tables dialog.

**Result**

If the data selection was small enough, the data is imported.

Do all of the data selection work in a shared data connection and save it to the library instead of adding it to the analysis directly. This way you can reuse the work you have done later, or share your selections with others.

**Spotfire for Oracle Smart View Users**

If you are an Oracle Smart View user who is accustomed to do ad-hoc analysis, that is, if you are using Microsoft Excel spreadsheets with Smart View functionality for selecting members from a cube, there are a number of things you should think about when doing analysis in TIBCO Spotfire.

When doing ad-hoc analysis in Excel, you often start off with all dimensions as columns, and a single measure on the row. No data is shown until you explicitly refresh the spreadsheet. If you are familiar with your working cube, you might also be used to the free-form mode, where you type member names directly into the cells and thereby slice your cube. In Spotfire, there is no free-form mode editing. Because Spotfire is interactive, you do not have to refresh your spreadsheet explicitly – the spreadsheet is automatically updated as you go.

The equivalent to the Excel spreadsheet in Spotfire is the cross table visualization. When you create a cross table visualization, Spotfire will suggest a measure as well as a dimension/hierarchy in the initial cross table. You should also see the Data panel, which shows you the available dimensions/hierarchies and measures (if the Data panel is not shown, click the **Data** button in the toolbar).

**Cross table visualization in Spotfire.**

Because there is no free-form mode editing in Spotfire, you should *not* start off by dragging all hierarchies to the visualization and go from there. Instead, you select what measures or accounts to show in the cells by selecting the appropriate measure in the lower horizontal axis selector in the cross table (or by dragging the appropriate measure from the Data panel to the axis selector). Also, in Spotfire, there is no explicit pivot operation. Instead, you select what dimension members to show on the vertical axis by selecting or dragging the dimension to the vertical axis selector. Similarly, you select which dimension members should be shown on the horizontal axis by selecting or dragging the dimension to the upper horizontal axis selector.

Note that you can have multiple dimensions on each axis. Those dimensions then become nested. Also note that multiple measures can be selected on the lower horizontal axis (value axis), but in that case "pivoting" is not possible.
In Spotfire, you slice your cube through filtering. That is, in the Data panel, you click on the filter icon next to the dimension you want to slice. This brings up an appropriate filter in which you select the member for that dimension. Repeat this for each dimension that should be sliced.

![Filter Icon](image)

The best way to slice a hierarchy (to select a single member in a hierarchy filter) is to do the following:

1. Locate the member to slice by in the hierarchy filter by expanding the appropriate part of the hierarchy (click on the plus-signs before the parents to expand).
2. Right-click on the member to slice by and select Deselect Other Values from the pop-up menu.

If you want to continuously see how the filters are defined, you can click on the Filter button on the toolbar. This brings up the Filters panel, in which all filters are displayed. You can modify the filter from within this panel, as well as from the Data panel. In the Data panel, you click on the filter icon next to the dimension you want to see or modify the filtering for to display the filter.

Often, the visualization will not show any data until all members to slice by have been specified (filtered) correctly. It is also common that query performance is bad until the cube has been sliced. Therefore, it might be better to define all the slicers before configuring the visualization correctly (by selecting the correct measures and dimensions on the axes).

### Minimizing the Strain on the Oracle Essbase Database

This topic provides some tips on how to put minimum strain on your Essbase database. You can mimic the workflow from Smart View use in Excel by first removing all visualizations, then filtering (slicing) the data, and finally, configuring your visualization.

**Mimic the workflow where you configure your visualization or spreadsheet and then refresh to see results, using these steps:**

**Procedure**

1. Remove all visualizations in the Spotfire analysis.
2. Define the slicers that are needed by filtering the appropriate dimensions in the Data panel.
   - When you define your slicer member in a hierarchy filter you:
     a) Locate and select the slicer member in the filter for the hierarchy.
     b) Right-click on the slicer member and select Deselect Other Values from the pop-up menu.
3. Create the visualization (spreadsheet) by clicking the Cross Table button in the toolbar.
4. Specify your measures and dimensions on the various axes in the cross table (spreadsheet).

**Result**

The cube data is ready to be analyzed.
If you always want to view a cross table when you create a new Spotfire analysis, you can make the cross table your default visualization (the visualization that is shown when you bring in new data). To do that, select **Tools > Options**, go to the **Document** page, and set **Initial visualization when loading data** to **Cross Table**. If you want the filter panel to be automatically displayed, you can select the **Filters panel open by default** check box in the same dialog.

**Settings for Oracle Essbase Connection**

Use this dialog to connect to Oracle Essbase.

![Oracle Essbase Connection dialog](Image)

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Server</td>
<td>The name of the server where your data is located. Add the port number directly after the name preceded by colon. Example: myDatabaseServer:1234</td>
</tr>
<tr>
<td>Username</td>
<td>The username you wish to use when logging into the Oracle Essbase database.</td>
</tr>
<tr>
<td>Password</td>
<td>The password for the specified username.</td>
</tr>
<tr>
<td>Connect</td>
<td>Connects you to the specified server and populates the lists of available applications and databases.</td>
</tr>
<tr>
<td>Application</td>
<td>Select the application of interest from the drop-down list.</td>
</tr>
<tr>
<td>Database</td>
<td>Select the database of interest from the drop-down list.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Alias table</td>
<td>Allows you to select which alias table to get the names from. An alias table maps the original member name to a more user friendly name, or they could contain long or short versions of a name. Select 'Do not use aliases' to get the original member names.</td>
</tr>
<tr>
<td>Show both member name and alias</td>
<td>Select this check box to show both the member name and an alias name in the UI, separated by comma. For example, you could show both a product ID and the product name like this: PNO2345, Fruit drink</td>
</tr>
</tbody>
</table>
SAP BW

If you have access to data in an SAP BW system, you can use the SAP BW connector in Spotfire to connect to your OLAP cube.

When you configure a connection to an SAP BW cube, you can choose whether to analyze data in-database or to import it into your analysis. Note that you need to install a driver on your computer to get access to the SAP BW connector. See the system requirements at http://support.spotfire.com/sr_spotfire_dataconnectors.asp to find the correct driver.

The SAP BW connector does not support SAP BW network hierarchies.

InfoProviders

InfoProviders are the reportable entities in SAP BW, for example, InfoCubes and MultiProviders.

InfoCubes

InfoCubes are multidimensional models in SAP BW. In Spotfire, the InfoCubes become cubes (that is, data tables). Standard InfoCubes are self-contained data sets for particular business subjects or processes, such as sales, lost deals, and plans. They consist of dimensions, characteristics, key figures and navigational attributes.

MultiProviders

Because each InfoCube normally only supports an individual business subject or process, there is a need to create reports where data from different processes are joined. MultiProviders are used for this purpose. They exist as a logical definition only, so they do not physically store any data. MultiProviders are also frequently used in cases where a single InfoCube would become very large due to high data volume. MultiProviders also become cubes (that is, data tables) in Spotfire.

Business Explorer (BEx) Queries

SAP BW users can create Business Explorer (BEx) queries in the BEx Query Designer. BEx queries are intended to provide the end users with queries for reporting and analysis in SAP BW. In Spotfire each BEx query becomes a cube.

For a BEx query to be visible in Spotfire, the query has to be configured to allow external access by OLE DB for OLAP. This is done by selecting the Allow External Access to this Query by OLE BD for OLAP check box in the Extended tab in the Query Properties for the query in the BEx Query Designer application.

When you select a SAP BW BEx query in Spotfire, you may have to specify desired values for predefined variables. The specified values will be used to limit the selected data. Once the BEx variables have been specified, you cannot change them.

Even if the BEx query has allowed you to filter out some values for a column or hierarchy, you will see the full range of values from the source if you click Limit Data in the Data Selection in Connection dialog. This means that if you are not careful, you may select values in the Limit Data dialog that are already filtered out by the BEx query, and the resulting selection will be empty. This is also applicable when filtering in Spotfire.

Variables

Variables act as parameters to a Business Explorer (BEx) query. They are filled with values and processed at query runtime.

For example, you might have a BEx query that reports sales for the year 2014. When new data for 2015 becomes available, you do not want to change the year to 2015, but rather want the end user of the query to select which year the query should be executed for.
In that case, you modify (parameterize) the query so that it uses a variable for the year. Then, the end user can specify the year of interest by selecting a value for that variable when the Spotfire analysis is opened.

Variables are globally available, so that once they are defined, they are available for use in any BEx query. However, not all variables are available to Spotfire. The underlying SAP BW driver does not return any Text variables. In addition, only variables that have the processing types Manual Entry or Default Value are returned by the driver. Hierarchy and Hierarchy Node variables are not supported by Spotfire.

**Key Figures**

Key figures are numeric values, quantities, dates or times.

For example, typical key figures are sales revenue, or, quantity sold. That is, key figures are the measures of the cube and the are found under 'Key Figures' in the Spotfire Data panel.

**Characteristics**

A characteristic usually denotes a business entity that is being evaluated or measured by a key figure. Characteristics can be either attributes or hierarchies. Attributes are further broken down into display attributes and navigation attributes.

SAP BW hierarchies are represented as hierarchies in Spotfire. Navigation attributes are represented as columns in Spotfire. Display attributes are currently not available in Spotfire.

Navigation attributes can be used in BEx queries for drilling and filtering and are thus visible to Spotfire (in the context of the BEx query).

Navigation attributes appear as display attributes in the context of an InfoCube and are therefore not visible in Spotfire in that context. If you need to access these attributes in Spotfire, the workaround is to create a BEx query based on the InfoCube, and expose the navigation attributes in the BEx query.

**Dimensions**

In SAP BW, dimensions are groupings of logically related characteristics.

However, not all characteristics belong to a dimension, so Spotfire does not show these dimensions. Instead, all characteristics are found under the 'Characteristics' dimension in Spotfire.

**Adding In-database Data from SAP BW**

Follow the steps below to add a connection with in-database data to SAP BW.

**Procedure**

1. Select File > Add Data Tables.
   The Add Data Tables dialog is opened.
2. Click Add > Connection To > SAP BW.
   The SAP BW Connection dialog is opened.
3. Specify the Server you want to connect to, and which Client and System number to use.
4. In the Language field, enter the language code corresponding to the language used in your data.
5. Select the Authentication method to use when logging in to the database.
6. If you selected SAP BW authentication, enter your username and password.
7. Click Connect.
   Spotfire will connect to the specified server, and retrieve the names of the available catalogs, cubes, and BEx queries.
8. In the **Catalog** drop-down list, you can narrow down the amount of listed cubes. Cubes containing BEx queries are listed, but you can also select (All cubes) if you do not want to narrow down the selection.

9. In the **Cube or query** drop-down list, select the cube or query of interest.
   If a name is preceded by a dollar sign ($) in the drop-down list, it is a cube, otherwise it is a BEx query.

10. Click **OK**.
    If you selected a BEx query with variables, the SAP BW Variables dialog opens. Variables listed as **Mandatory** must be defined if no default has been specified already. Variables listed as **Mandatory not initial** must always be defined. Double-click on each variable to open the **Define Value** dialog, where you can select values for the variables, and then click **OK** to close the dialog. And when you have specified all necessary variable values, click **OK** in the SAP BW Variables dialog.
    The **Data Selection in Connection** dialog opens.

11. Click on the object of interest in the left pane, then click **Add >**.
    See **Icon Descriptions** for information about what the different objects represent. If you select the cube icon, you will get all data in the cube. When it comes to hierarchies, you always have to add the entire hierarchy to the list, but you can use the **Limit Data** button to filter out higher levels of detail in the hierarchy from the actual selection at a later stage. You can repeat this step as many times as you want to add more data to the selection.
    The selected data is added to the **Data selection in connection** list.

12. Dimension columns and hierarchies can be further limited by clicking on the selected column or hierarchy in the **Data selection in connection** list and then clicking on the button with a filter funnel and selecting **Limit Data**.
    The Limit Data dialog opens.

13. Clear the check boxes for categories that you want to remove from the selection.

14. Click **OK** to close the Limit Data dialog.

15. When you are done with the data selection, click **OK**.
    The connection is added to the **Data tables** list in the Add Data Tables dialog.

16. Make sure the data table, and not the connection, is selected in the **Data tables** list and, under **Load method**, click **Keep data table external**.

17. Click **OK** in the Add Data Tables dialog.

**Result**

The external data table is shown in the Data panel.

Do all of the data selection work in a shared data connection and save it to the library instead of adding it to the analysis directly. This way you can reuse the work you have done later, or share your selections with others.

**Importing Data from SAP BW**

Follow the steps below to import data from a SAP BW cube.

**Procedure**

1. Select **File > Add Data Tables**.
   The Add Data Tables dialog is opened.

2. Click **Add > Connection To > SAP BW**.
   The SAP BW Connection dialog is opened.
3. Specify the **Server** you want to connect to, and which **Client** and **System number** to use.
4. In the **Language** field, enter the language code corresponding to the language used in your data.
5. Select the **Authentication method** to use when logging in to the database.
6. If you selected **SAP BW authentication**, enter your username and password.
7. Click **Connect**.
   Spotfire will connect to the specified server, and retrieve the names of the available catalogs, cubes, and BEx queries.
8. In the **Catalog** drop-down list, you can narrow down the amount of listed cubes. Cubes containing BEx queries are listed, but you can also select (All cubes) if you do not want to narrow down the selection.
9. In the **Cube or query** drop-down list, select the cube or query of interest.
   If a name is preceded by a dollar sign ($) in the drop-down list, it is a cube, otherwise it is a BEx query.
10. Click **OK**.
   If you selected a BEx query with variables, the SAP BW Variables dialog opens. Variables listed as **Mandatory** must be defined if no default has been specified already. Variables listed as **Mandatory not initial** must always be defined. Double-click on each variable to open the **Define Value** dialog, where you can select values for the variables, and then click **OK** to close the dialog. And when you have specified all necessary variable values, click **OK** in the SAP BW Variables dialog.
   The **Data Selection in Connection** dialog opens.
11. Click on the object of interest in the left pane, then click **Add >**.
   See **Icon Descriptions** for information about what the different objects represent. If you select the cube icon, you will get all data in the cube. When it comes to hierarchies, you always have to add the entire hierarchy to the list, but you can use the **Limit Data** button to filter out higher levels of detail in the hierarchy from the actual selection at a later stage. You can repeat this step as many times as you want to add more data to the selection.
   The selected data is added to the **Data selection in connection** list.
12. Dimension columns and hierarchies can be further limited by clicking on the selected column or hierarchy in the **Data selection in connection** list and then clicking on the button with a filter funnel and selecting **Limit Data**.
   The Limit Data dialog opens.
13. Clear the check boxes for categories that you want to remove from the selection.
14. Click **OK** to close the Limit Data dialog.
15. When you are done with your data selection it is recommended to click the **Estimate Import Size** button to get a hint on whether this selection will be possible to import or not.
   The calculation may take a while. No measures are taken into account in the calculation, so if you have added many measures, you may be unable to import the selection even if the estimated number of rows and columns is small. The estimated import size may be of help if an import should fail. Then, the next time you try to import data from that cube, you should try to make sure that the estimated size is smaller than the previous time.
16. When you are done with the data selection, click **OK**.
   The connection is added to the **Data tables** list in the Add Data Tables dialog.
17. Make sure the data table, and not the connection, is selected in the **Data tables** list and, under **Load method**, click **Import data table**.
18. Click **OK** in the Add Data Tables dialog.

**Result**

If the data selection was small enough, the data is imported.
Do all of the data selection work in a shared data connection and save it to the library instead of adding it to the analysis directly. This way you can reuse the work you have done later, or share your selections with others.

- SAP BW has a built-in limit of 1M cells when it comes to import, so try to make sure the number of selected cells is less than this number.
- It is not possible to import multiple characteristics that belong to the same dimension.

**Settings for SAP BW Connection**

Use this dialog to connect to SAP BW.

![SAP BW Connection dialog](image)

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Server</td>
<td>The name of the server where your data is located.</td>
</tr>
<tr>
<td></td>
<td>The server can be identified in the following ways:</td>
</tr>
<tr>
<td></td>
<td>- By IP address. For example: 192.0.2.1</td>
</tr>
<tr>
<td></td>
<td>- By IP address, but including a SAProuter string. For example: /H/198.51.100.1/S/3299/H/203.0.113.1/H/CPCB701</td>
</tr>
<tr>
<td></td>
<td>- By name in the domain. For example: my-sap-bw.mycompany.com</td>
</tr>
<tr>
<td>Client</td>
<td>The SAP BW client number.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>System number</td>
<td>The SAP BW system number.</td>
</tr>
<tr>
<td>SNC partner name</td>
<td>The Secure Network Communication (SNC) partner name which is required when using single sign-on.</td>
</tr>
<tr>
<td>Language</td>
<td>Use this field to specify the language used in your data. Refer to official SAP documentation for a complete list of supported language codes.</td>
</tr>
<tr>
<td>Authentication</td>
<td>The authentication method to use when logging into the database. Choose from Windows authentication and SAP BW authentication.</td>
</tr>
<tr>
<td>Windows authentication</td>
<td>When using Windows authentication, that is Kerberos, the access token of the logged in user will be used. Users that have been given the appropriate access rights to SAP BW will be able to connect and read data. Domain credentials are not stored in the analysis file.</td>
</tr>
<tr>
<td>SAP BW authentication</td>
<td>With database authentication the authentication is done using a database user. Database credentials can be stored, unencrypted, as part of the analysis file, using a setting in the Data Source Settings dialog. If credentials are found in the analysis file they will be used to automatically authenticate against the database. If no credentials or credentials profiles are found in the analysis file all who open the file will be prompted for database credentials. Note that there will be no prompting for credentials if the credentials embedded in the analysis file fail.</td>
</tr>
<tr>
<td>Username</td>
<td>The username you wish to use when logging into the SAP BW cube or query.</td>
</tr>
<tr>
<td>Password</td>
<td>The password for the specified username.</td>
</tr>
<tr>
<td>Connect</td>
<td>Connects you to the specified server and populates the lists of available catalogs and cubes below.</td>
</tr>
<tr>
<td>Catalog</td>
<td>Select the catalog of interest from the drop-down list. You can choose among (All cubes) and cubes containing BEx queries.</td>
</tr>
<tr>
<td>Cube or query</td>
<td>Select the cube or BEx query of interest from the drop-down list. If the catalog selected is (All cubes), only cube names are shown here; if the catalog selected is a cube, only its BEx queries and the cube itself will be included here. If a name is preceded by a dollar sign ($) in the drop-down list, it is a cube, otherwise it is a BEx query.</td>
</tr>
</tbody>
</table>
Data Import

When you add data tables from a data connection, you have the option to either keep the data table external or to import it into the Spotfire data engine and use it in-memory.

When you are importing cube data into Spotfire you will actually flatten the cube into a single data table, which means that some features that you have access to when working with an in-database cube are lost and you may see different results when aggregating your imported data in Spotfire compared to what you get when the external system does all the aggregation. Spotfire does not import aggregated data, only leaf nodes that then can be aggregated using the Spotfire aggregation methods.

If you are interested in all of the data from an OLAP (Online Analytical Processing) cube, it is probably a better idea to use an in-database connection, while import is mainly intended for small subsections of the cube data.

Limit the Number of Dimensions

If you intend to import data from a cube into Spotfire there are a number of things that you must remember.

First of all, the full cube may be enormous, so it is recommended to always limit the dimensions to import to those that are absolutely necessary only, to reduce data explosion as much as possible. If a cube like the one shown to the left below is imported into Spotfire, you will get the table shown to the right. The visualizations you set up will then decide how to aggregate the measures from the resulting table.

When an imported cube data table is aggregated (for example, with the default Sum aggregation), the available leaf values are simply summarized when you show a categorical value of a higher level (e.g. the Sum(Sales) for France from the table above). However, in the in-db cube, it is the external system that decides what an aggregation means, which may include other aggregation methods, data that was not included in the import, and so on, which may produce a completely different result.

As an example of the importance of limiting the data as much as possible prior to import, imagine a cube with the following number of values for different dimensions.

Department: 10
Product: 5000
Currency: 20
Business Unit: 1000
Scenario: 10
Account: 100
Bringing in the entire cube would result in a cross-joined table with the following number of columns:

\[10 \times 5000 \times 20 \times 1000 \times 10 \times 100 = 1 \times 10^{12}\]

As you can see, the amount of data very quickly explodes with the number of dimensions used, especially if each dimension contains many different values. Take care not to overload the data source by combining too many dimensions.

**Data Import Best Practices**

To get the most out of your data, follow these recommendations for import of data from cubes.

- Limit the data to import as much as possible by selecting only the necessary dimensions and measures in the Data Selection in Connection dialog.
- Limit data further by clearing check boxes for undesired categories in the selected data in the Limit Data dialog.
- Click **Estimate Import Size** to try to evaluate whether import is possible before you try to import a data selection.

**Known Limitations**

- On-demand is not supported for cube data sources (neither for imported cubes nor for in-database cubes).
- In contrast to data connections from relational data sources, selections for cube data connections always result in a single data table.
- You cannot switch from an imported configuration to an in-database configuration in a cube data connection, the way you can with relational data sources, or vice versa. However, you can always replace a data table based on a cube data connection with another data table.
- When cube hierarchies have been added to a connection, the hierarchies in Spotfire will not be updated when the data connection is edited. However, you can always recreate new hierarchies manually.
- Import of large amounts of data may not work. If you try to import and it fails, edit the connection and limit the selected dimensions and/or categories some more.
- The estimation of the expected import size is only an approximation and cannot give any definitive information regarding whether or not an import will work. If the estimation takes a long time it often, but not always, means that the result of the selection is too big to import.
- If multiple instances of one leaf value exist you may get different behavior between imported data and in-db data, since the imported data may have lost hierarchical information required in order to distinguish the leaf values from each other. For example, there is more than one city called Berlin in the world and after an import, all of those cities will be clumped together into one group in the flattened data table, unless you make sure to always include full hierarchies on all axes.
- You will always get the leaf nodes for those branches in the hierarchies you select. This means that you can only select full hierarchies, not single columns from a hierarchy.
Creating a Shared Data Connection in the Library

If you want to be able to use a data connection in multiple analyses or share it with other users, you can create a data connection item in the library.

**Procedure**

1. In the Spotfire Windows client, select Tools > Manage Data Connections.
2. In the Manage Data Connections dialog, select Add New > Data Connection and choose the selected data connection type from the list.
   The connection configuration dialog for the selected data source opens.
3. Provide all the necessary input for the connection to the data source and specify which data to include.
   For more information about specific system settings, see the section about the system of interest in this user's guide.
4. Save the connection to the library.