TIBCO Spotfire® Connector for Teradata Aster

Software Release 3.0
April 2014
SOME TIBCO SOFTWARE EMBEDS OR BUNDLES OTHER TIBCO SOFTWARE. USE OF SUCH EMBEDDED OR BUNDLED TIBCO SOFTWARE IS SOLELY TO ENABLE THE FUNCTIONALITY (OR PROVIDE LIMITED ADD-ON FUNCTIONALITY) OF THE LICENSED TIBCO SOFTWARE. THE EMBEDDED OR BUNDLED SOFTWARE IS NOT LICENSED TO BE USED OR ACCESSED BY ANY OTHER TIBCO SOFTWARE OR FOR ANY OTHER PURPOSE.

USE OF TIBCO SOFTWARE AND THIS DOCUMENT IS SUBJECT TO THE TERMS AND CONDITIONS OF A LICENSE AGREEMENT FOUND IN EITHER A SEPARATELY EXECUTED SOFTWARE LICENSE AGREEMENT, OR, IF THERE IS NO SUCH SEPARATE AGREEMENT, THE CLICKWRAP END USER LICENSE AGREEMENT WHICH IS DISPLAYED DURING DOWNLOAD OR INSTALLATION OF THE SOFTWARE (AND WHICH IS DUPLICATED IN THE LICENSE FILE) OR IF THERE IS NO SUCH SOFTWARE LICENSE AGREEMENT OR CLICKWRAP END USER LICENSE AGREEMENT, THE LICENSE(S) LOCATED IN THE “LICENSE” FILE(S) OF THE SOFTWARE. USE OF THIS DOCUMENT IS SUBJECT TO THOSE TERMS AND CONDITIONS, AND YOUR USE HEREOF SHALL CONSTITUTE ACCEPTANCE OF AND AN AGREEMENT TO BE BOUND BY THE SAME.

This document contains confidential information that is subject to U.S. and international copyright laws and treaties. No part of this document may be reproduced in any form without the written authorization of TIBCO Software Inc.

TIBCO, Two-Second Advantage, TIBCO Spotfire, TIBCO Spotfire Server, TIBCO Spotfire Web Player, TIBCO Spotfire Statistics Services, TIBCO Enterprise Runtime for R, TIBCO Spotifre S+, and TIBCO Spotfire Automation Services are either registered trademarks or trademarks of TIBCO Software Inc. in the United States and/or other countries.

All other product and company names and marks mentioned in this document are the property of their respective owners and are mentioned for identification purposes only.

THIS SOFTWARE MAY BE AVAILABLE ON MULTIPLE OPERATING SYSTEMS. HOWEVER, NOT ALL OPERATING SYSTEM PLATFORMS FOR A SPECIFIC SOFTWARE VERSION ARE RELEASED AT THE SAME TIME. SEE THE README FILE FOR THE AVAILABILITY OF THIS SOFTWARE VERSION ON A SPECIFIC OPERATING SYSTEM PLATFORM.

THIS DOCUMENT IS PROVIDED “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

THIS DOCUMENT COULD INCLUDE TECHNICAL INACCURACIES OR TYPOGRAPHICAL ERRORS. CHANGES ARE PERIODICALLY ADDED TO THE INFORMATION HEREIN; THESE CHANGES WILL BE INCORPORATED IN NEW EDITIONS OF THIS DOCUMENT. TIBCO SOFTWARE INC. MAY MAKE IMPROVEMENTS AND/OR CHANGES IN THE PRODUCT(S) AND/OR THE PROGRAM(S) DESCRIBED IN THIS DOCUMENT AT ANY TIME.

THE CONTENTS OF THIS DOCUMENT MAY BE MODIFIED AND/OR QUALIFIED, DIRECTLY OR INDIRECTLY, BY OTHER DOCUMENTATION WHICH ACCOMPANIES THIS SOFTWARE, INCLUDING BUT NOT LIMITED TO ANY RELEASE NOTES AND “READ ME” FILES.

Copyright © 1996-2014 TIBCO Software Inc. ALL RIGHTS RESERVED.

TIBCO Software Inc. Confidential Information
# Contents

TIBCO Spotfire Documentation and Support Services .............................................................. 4

Introduction .......................................................................................................................... 5
  Prerequisites ...................................................................................................................... 5
  Roles ................................................................................................................................. 5

Installing the TIBCO Spotfire Connector ............................................................................ 6
  Deploying the TIBCO Spotfire Connector SPK Files to a Server ........................................ 6
  Updating Clients with the Connector Packages ................................................................. 7
  Updating TIBCO Spotfire Web Player ................................................................................. 7
  Updating TIBCO Spotfire Automation Services ................................................................. 7
    Updating Automation Services with DLLs ......................................................................... 8

Access Rights ...................................................................................................................... 9
  Assigning the License ......................................................................................................... 9

Access to the TIBCO Spotfire Connector ............................................................................ 10
  Adding a Shared Data Connection to the Library .............................................................. 10
  Adding a Local Data Connection to an Analysis .............................................................. 10
TIBCO Spotfire Documentation and Support Services

All TIBCO documentation is available in the TIBCO Documentation Library, which can be found here:
https://docs.tibco.com

Product-Specific Documentation

The following documents for this product can be found in the TIBCO Documentation Library:

- TIBCO Spotfire® Deployment and Administration Manual
- TIBCO Spotfire Server Installation and Configuration Manual
- TIBCO Spotfire® Automation Services Installation and Deployment Manual
- TIBCO Spotfire® Web Player Installation Manual
- TIBCO Spotfire® Connector for Teradata Aster® License Agreement
- TIBCO Spotfire® Connector for Teradata Aster® Release Notes

How to Contact TIBCO Support

For comments or problems with this manual or the software it addresses, contact TIBCO Support as follows:

- For an overview of TIBCO Support, and information about getting started with TIBCO Support, visit this site:
  http://www.tibco.com/services/support

- If you already have a valid maintenance or support contract, visit this site:
  https://support.tibco.com
  Entry to this site requires a user name and password. If you do not have a user name, you can request one.

How to Join TIBCOMMunity

TIBCOMMunity is an online destination for TIBCO customers, partners, and resident experts. It is a place to share and access the collective experience of the TIBCO community. TIBCOMMunity offers forums, blogs, and access to a variety of resources. To register, go to:
http://www.tibcommunity.com
Introduction

The TIBCO Spotfire® Connector for Teradata Aster® allows users to easily connect to a Teradata Aster® database and analyze data from one or more databases in Spotfire.

Use this document to install and configure the product.

Prerequisites

You must meet the following prerequisites before you start the connector installation.

- You must have a working installation of TIBCO Spotfire®. See http://support.spotfire.com/sr.asp for the required version.
- You must have access to a running TIBCO Spotfire Server that Spotfire can connect to. (Installing a TIBCO Spotfire Server is described in the TIBCO Spotfire Server Installation and Configuration Manual.)
- Each client computer or Spotfire Web Player server to run the Spotfire Connector for Teradata Aster must also have access to the Teradata Aster ADO.NET driver as described in the system requirements for Spotfire. See http://support.spotfire.com/sr.asp.
- At least one Teradata Aster instance must be available.

Roles

TIBCO Spotfire® defines different roles for installing, configuring, and administering the different components of the system.

The roles for administering Spotfire connectors are described as follows:

<table>
<thead>
<tr>
<th>Role</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Spotfire Server Administrator</td>
<td>Responsible for installing and configuring the Spotfire Server (or servers) and the Spotfire database. How to perform these tasks is described in the TIBCO Spotfire Server Installation and Configuration Manual.</td>
</tr>
<tr>
<td>Spotfire Admin</td>
<td>Responsible for setting up users and groups in the Spotfire system, assigning licenses and preferences to the Spotfire groups, setting up the Spotfire Library, and deploying Spotfire software packages to the Spotfire Server. How to perform these tasks is described in the TIBCO Spotfire Deployment and Administration Manual.</td>
</tr>
</tbody>
</table>

These roles can be assigned to different persons or to the same person. The person or persons assuming the roles must be familiar with each area of knowledge.
Installing the TIBCO Spotfire Connector

As Spotfire Admin, you must perform a number of steps to set up the Spotfire Connector for Teradata Aster. The first step is unzipping the package and reviewing the documentation.

Procedure

- Unzip the downloaded Spotfire Connector for Teradata Aster package, TIB_spc-tera_as_3.0.0_win.zip, to a folder on your local disk.

  The zip archive includes this PDF document, release notes and the deployment files AdapterTeradataAster.spk and FormsAdapterTeradataAster.spk.

Deploying the TIBCO Spotfire Connector SPK Files to a Server

Use the Spotfire Server Administration Console to deploy the SPK files.

Procedure

1. Open the Administration Console located at http://spotserver:port/spotfire/ (where spotserver is the name of a Spotfire Server and port is the port number, if other than the default) in a web browser.
2. Log in as a Spotfire Administrator.
3. Select the Deployment tab.
4. In Deployment areas, select the Deployment Area Name, which specifies where to deploy the connector.
   - For more information about deployment areas, see the TIBCO Spotfire Deployment and Administration Manual.
5. To the right of the Software packages area, click Add.
   - Response: The Add to Deployment dialog is displayed.
6. Click Browse, and then browse to the file AdapterTeradataAster.spk.
7. Click Open, and then click OK in the Add to Deployment dialog to upload and add the file to the distribution.
   - Response: The list of software packages is updated with the contents of the file.
8. Repeat Step 5 to Step 7 for the next SPK file.
9. Click Validate to ensure the deployment is consistent with the current version.
10. Click Save to save and publish the deployment.
   - Response: The Save Deployment dialog is displayed.
11. Type a version number and a description for the deployment and click OK.
   - For more information, see the online help for the Administration Console.
Updating Clients with the Connector Packages

When the SPK files have been deployed to the Spotfire Server, you must perform some additional steps to update the Spotfire clients. These steps must be performed on all computers running Spotfire.

As a Spotfire Server Administrator with responsibility to upgrade a Spotfire Automation Services server, you must perform these steps to obtain the DLLs that must be copied to the Spotfire Automation Services server.

Procedure

1. Exit Spotfire.
2. Restart Spotfire and log in as usual to the server and the deployment area where you deployed the connector packages. Spotfire notifies you that new packages are deployed on the server. Accept the updates to download and install the new packages by clicking Update Now.

Updating TIBCO Spotfire Web Player

To make the TIBCO Spotfire® Connector work on a Spotfire Web Player server, you must update the configuration with information about the connector.

Procedure

1. Provide the server access to the required drivers as described in the system requirements at http://support.spotfire.com/sr.asp.
2. Locate the web.config file in the webroot folder.
   
   For example, C:\Program Files\TIBCO\Spotfire Web Player\[version number]\webroot.
3. Open the web.config file, and in it, find the section
   
4. If the connector is not available in the <value><adapters> subsection, add an item like the following example: <adapter name="Spotfire.TeradataAsterAdapter" mode="Prompt" />
   
   where the mode is set to the type of authentication that you want to use. The authentication types are described in the TIBCO Spotfire® Web Player Installation and Configuration Manual.
5. Restart the computer to ensure that IIS picks up the new system variables.

What to do next

Run the webupdate.bat tool to upgrade the Spotfire Web Player server with the new packages, as described in the TIBCO Spotfire Web Player Installation and Configuration Manual.

Updating TIBCO Spotfire Automation Services

To make the TIBCO Spotfire® connector work on a Spotfire Automation Services server, you must perform the following:

Procedure

1. Provide the server access to the required drivers as described in the system requirements at http://support.spotfire.com/sr.asp.
2. Locate the file AddIns.xml in the webroot\bin folder.
   
   For example, C:\Program Files\TIBCO\Automation Services\[version number]\webroot\bin.
3. In the <AddInRegistry> subsection, add the following item: <AddIn
   FullTypeNames="Spotfire.Dxp.Data.Adapters.TeradataAster.TeradataAsterAdapterAddIn,

4. Restart the computer to ensure that IIS picks up the new system variables.

5. Copy the downloaded connector DLLs/files from the client to the Spotfire Automation Services
   server. For more details about how to update Spotfire Automation Services, see Updating
   Automation Services with DLLs.

### Updating Automation Services with DLLs

Before you can use the connector, you must update the Automation Services server with the connector
DLLs.

#### Prerequisites

Complete the steps in Updating Clients with the Connector Packages.

#### Procedure

1. On the client computer, locate the Modules folder for your Spotfire installation.
   
   By default, the Modules folder includes the hidden attribute. The path is usually one of the
   following:
   
   - C:\Program Files\TIBCO\Spotfire\[version number]\Modules
   - C:\Program Files (x86)\TIBCO\Spotfire\[version number]\Modules

2. Locate the folder called Spotfire Teradata Aster Connector. (The connector folder with the
   word Forms is used only by the Spotfire Professional Client and not by Spotfire Automation
   Services.)

   The TIBCO Spotfire® Connector for Teradata Aster creates these folders under the Modules folder
   when the client is updated with connector packages.

3. Copy the following files from the folder:
   

4. Log in to the Automation Services server (either locally or through a remote desktop session).

5. Open the Automation Services webroot folder and then open the bin folder.

   For example, C:\Program Files\TIBCO\Automation Services\[version number]\webroot
   \bin.

6. Paste the copied DLLs in the webroot\bin folder.
Access Rights

You can specify access rights to the Teradata Aster data.
In TIBCO Spotfire® the access rights to the data from the connector is controlled by the following two things:

- The data source authentication. (See the Help for your data source for more information.)
- The licenses enabled for the end user groups.

Assigning the License

The license assignment for TIBCO Spotfire® Connector for Teradata Aster gives access to the Teradata Aster Connection dialog. Enable or disable this license for groups of users by following these steps.

Procedure

1. Log into TIBCO Spotfire® as a user with Administration privileges.
2. Select Tools > Administration Manager.
3. Click the Groups and Licenses tab and select the group for which to enable or disable the Teradata Aster license.
   
   | Licenses are always assigned to groups, not to individual users.

4. On the Licenses tab, click Edit.
5. Assign the license by selecting the checkbox for the TIBCO Spotfire Connectors license group, and the checkbox for the underlying Teradata Aster function. Disable the license by clearing the checkboxes.
6. Repeat Step 3 through Step 5 for all groups that should or should not have access to the Teradata Aster Connector functionality.
Access to the TIBCO Spotfire Connector

After you have installed and configured the connector, you can set up connections to the Teradata Aster data in two different ways.

You can either:

- Add a shared connection to the library and use it in one or more analyses.
- Add a local connection directly to the analysis.

If the steps in Updating TIBCO Spotfire Web Player were performed on the Spotfire Web Player server, and an analysis using a connection has been set up, then users of the Spotfire Web Player can connect to the Teradata Aster data directly.

Adding a Shared Data Connection to the Library

Procedure

1. Select Tools > Manage Data Connections.
2. Click Add New, and then select Data Connection > Teradata Aster.

What to do next

The shared data connection can then be used in an analysis by selecting Add > Connection To > Shared Connection in Library from the Add Data Tables dialog. See the TIBCO Spotfire User’s Guide for more information about using the Add Data Tables dialog.

Adding a Local Data Connection to an Analysis

Procedure

1. Click File > Add Data Tables.
2. In the Add Data Tables dialog, select one or multiple data sources to be added in a single step.

   For users with access to the function, the Teradata Aster option appears in the Add drop-down list in the dialog.

   See the TIBCO Spotfire User’s Guide for more information about using the Add Data Tables dialog.