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1 Introduction 
1.1 Introduction 

Welcome to TIBCO Spotfire®! 
TIBCO Spotfire makes it easy for you to access, analyze and create dynamic reports on your 
data. It delivers immediate value whether you are a market researcher, a sales representative, a 
scientist or a process engineer by letting you quickly identify trends and patterns in your critical 
business data. 
Spotfire can access data in a number of places such as on your desktop or in a network file 
system. It can even access your data if it is located in remote databases, without you having to 
involve your IT department each time you wish to ask a new question. 
Spotfire lets you filter your data interactively, and gives you answers instantly. It also lets you 
rapidly create clear and concise, yet sleek and colorful visualizations in the form of bar charts, 
cross tables, scatter plots and many more valuable tools that will help you respond to events that 
affect your business.   
And finally, Spotfire lets you share your results. Static reports can be limiting to good business 
in this fast-paced world of data, and Spotfire allows you to create dynamic reports that help you 
to ask new questions, as well as be able to quickly turn your reports into instant presentations to 
show to your colleagues and customers. 
  
Note: This user's manual contains information about all functionality that can be used within 
the Spotfire end user environment. If you do not have access to all licenses, some tools 
described in this help will be unavailable. For more information on how to get access to the full 
range of functionality, please visit the website http://spotfire.tibco.com/support. 

1.2 The User Interface 
The image below shows some of the main parts of the TIBCO Spotfire® user interface. 
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1. Visualizations 
Visualizations are the key to analyzing data in Spotfire. A variety of visualization types can be 
used to provide the best view of the data: 

• Tables 
• Cross Tables 
• Graphical Tables 
• Bar Charts 
• Line Charts 
• Combination Charts 
• Pie Charts 
• Scatter Plots 
• 3D Scatter Plots 
• Map Charts 
• Treemaps 
• Heat Maps 
• Parallel Coordinate Plots 
• Summary Tables 
• Box Plots 

Different types of visualizations can be shown simultaneously. They can be linked to each 
other, and may or may not be updated dynamically when the corresponding filters on the page 
are manipulated (see below). 
Visualizations can be made to reflect many dimensions of data by letting values control visual 
attributes such as size, color, shape, etc. 

2. Text areas 
You can type text in text areas, explaining what is seen in the different visualizations. This can 
be particularly useful if you are creating analytic applications for other users. Text areas can 
also include several different types of controls, allowing you to filter, perform actions or make 
selections to view particular types of data, etc. 

3. Filters 
By adjusting filters, you can reduce the data seen in the visualizations to "drill down" to the 
things that interest you. Filters are powerful tools that quickly let you see various aspects of 
your data and make discoveries. 
Filters appear in several forms, and you can select the type of filter device that best suits your 
needs (for example, check boxes, sliders, etc). When you manipulate a filter by moving a slider 
or by selecting a check box, all linked visualizations are immediately updated to reflect the new 
selection of data. By default, all new visualizations on a page will be limited by the filtering 
scheme used on the page. However, the filtering scheme can be changed for each visualization 
separately. 

4. Details-on-Demand 
The Details-on-Demand window can be used to show the exact values of a row or a group of 
rows. By clicking an item in a visualization, or marking several items by clicking and dragging 
with the mouse around them, you can see the numerical values and textual data they represent 
directly in the Details-on-Demand window. 

1.3 Logging In 
When you start TIBCO Spotfire a login dialog appears. Enter your Username and Password, 
and click on the Login button to start Spotfire. If you select the Save my login information 
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check box, you will automatically be logged in when you start Spotfire in the future. Logging 
into Spotfire will let you access the joint library and other collaboration features. 
If the Save my login information check box has been selected, but you later want to reach this 
dialog again, you can force it to be shown by using the TIBCO Spotfire (show login dialog) 
option, reached via the Start menu > All Programs > TIBCO. 

 
If you are working on a large company with multiple TIBCO Spotfire Servers, you may 
occasionally also need to change the server you are connecting to via the drop-down list. New 
servers can be added to the list by clicking on the Manage Servers... link. 

Connecting via Proxy Server 
If you are connecting via a proxy server, you may need to change your security settings in 
Internet Explorer prior to logging into Spotfire. See the Microsoft Internet Explorer help for 
more information. Prior to logging into Spotfire, make sure that the Spotfire Server start page 
can be accessed by browsing to http://<hostname>/spotfire/. 

Downloading Updates 
Spotfire will automatically check for updates on your Spotfire Server that apply to you. If you 
have a network connection to the Spotfire Server, and there are updates available, you will be 
notified of this and can select whether to install them right away or at a later time. 
You can get a look at the contents of the available updates by clicking on the View updates link 
in the notification dialog. 

Working Offline 
If you are on a plane or just happen to not be connected to the network where your Spotfire 
Server is located, you can work with Spotfire offline. Almost all of the functionality of Spotfire 
works fine without a connection to the server. Library access, however, does not, nor can you 
access information links to databases. To work offline, simply click the Work Offline button in 
the login dialog. With some licenses of Spotfire, you do need to connect to your Spotfire Server 
at least once a month to be able to continue to work offline. 

Updates and Working Offline 
If you have more than one server, and one of them has provided you with updates, this server 
must be selected in the login screen for those updates to be available, even if you choose to 
work offline. 
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1.4 Logging In Details 
1.4.1 Details on Manage Servers 

► To reach the Manage Servers dialog: 
1. In the Login dialog of TIBCO Spotfire, click on the Manage Servers... link. 

 

Option Description 

Available TIBCO 
Spotfire servers 

Lists all previously added Spotfire servers, which you can select to log 
into. 

Add... Opens the Add Server dialog, where you can add new Spotfire servers 
to the list. 

Edit... Opens the Edit Server dialog, where you can edit the address and area 
of the selected Spotfire server. 

Delete Deletes the selected server from the list of Available TIBCO Spotfire 
servers. 

Server details Lists information about the selected Spotfire server, such as its address, 
area and authentication type. 

1.4.2 Details on Add/Edit Server 
► To reach the Add Server dialog: 

1. In the Login dialog of TIBCO Spotfire, click on the Manage Servers... link. 
2. In the Manage Servers dialog, click Add.... 
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► To reach the Edit Server dialog: 
1. In the Login dialog of TIBCO Spotfire, click on the Manage Servers... link. 
2. In the Manage Servers dialog, click to select a server, then click Edit.... 

 

Option Description 

TIBCO Spotfire 
server address 

This is where the web address to the new server should be specified. 
Contact your TIBCO Spotfire Administrator for this type of 
information. 

Area Specifies whether the connection should be made to the Production 
area or to the Test area on the specified server. The Production area is 
normally the preferred option for all common users. The Test area is 
basically reserved for developers and test pilots of new deployments. 

1.4.3 Details on Change Password 
This dialog is available when your server has been set up to use Spotfire Database 
authentication only. It is not available in offline mode. If your Spotfire Server has been set up to 
use any other authentication mechanism this dialog will not be available at all. 

► To reach the Change Password dialog: 
1. Select Tools > Change Password.... 
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Option Description 

Username Shows the name of the currently logged in user. 

Current password Type the current password for the logged in user. 

New password Type the new password for the logged in user. 

Confirm new 
password 

Retype the password to ensure it is correct. 
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2 Loading Data 
2.1 Loading Data Overview 

You can load data into TIBCO Spotfire from a number of different sources: by pasting from the 
clipboard, by opening simple text files, Microsoft Excel files, SAS files, a database or an 
information link (a predefined connection to a shared data source). You may also have access to 
additional file sources if such have been set up by your company. 
You reach the different ways to load data via the File menu. 
If more than one data table is needed in your analysis, you can add them using Add Data Tables 
or Add On-Demand Data Table. 

Limiting What Data to Load 
When the data source contains large amounts of data, it may take a long time to retrieve all data 
and the application could also be perceived as less responsive to different actions. You may also 
want to restrict some data from certain users. When you are working with information links it is 
possible to limit what data to open in different analyses in a number of different ways 
(combinations are also possible): 

Method Use when? Define where? 

Add On-
Demand Data 
Table 

When you want the data in your 
analysis to dynamically change with 
some predefined condition. For 
example, when setting up a details 
visualization dependent on the 
marking or filtering in another data 
table. 
Another example is when you want 
one information link to return 
different data for different analysis 
files, in which case you could use 
the on-demand data table as the 
only data table in the analysis (with 
a document property as input). 

On-demand data tables are added to 
your analysis in TIBCO Spotfire by 
selecting File > Add On-Demand 
Data Table and specifying the input 
conditions that should control 
loading. 
See On-Demand Overview for 
more information. 
Note: You can only specify a single 
fixed value as input to on-demand 
loading, so if you need to retrieve 
multiple values from a certain 
column you will have to make sure 
that the information link is set up to 
use a multiple selection prompt 
rather than using it as an on-
demand data table. 

Prompted 
Information 
Links 

When the source data amount is 
huge, but the end users of the 
information link are allowed to 
determine what data to bring in for 
analysis themselves. 
Can in some cases be replaced by 
an on-demand data table. 

Prompts are defined in Information 
Designer, Information Link tab, 
Prompts section. 

Personalized 
Information 
Links 

When you want the data source to 
return only information applicable 
for a certain user name (via a 
lookup table) or for a specified 
group. 

Personalized information links are 
set up on a filter or column element 
in Information Designer using the 
%CURRENT_USER% or 
%CURRENT_GROUPS% syntax. 
See Personalized Information Links 
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for more information. 

Parameterized 
Information 
Links 

When you want the data source to 
return only information applicable 
for a certain user or group in a more 
flexible way than with personalized 
information links. 

Parameters are created in 
Information Designer (for example, 
as a part of an expression set on a 
column or filter) but their properties 
and definitions are defined using 
the API. 
By using a parameterized 
information link and a 
configuration block, it is possible to 
create an analysis with different 
input parameters (e.g., to be used 
by an On-Demand data table) for 
different groups of users. See 
Parameterized Information Links 
for more information. 

  

2.2 Open File 
2.2.1 Opening an Analysis File 

If a colleague has created an analysis file (a DXP file) and either sent it to you in an email, or, 
given you a link to the Library where the file is located, double-clicking on the file will open it. 
To open a file from within TIBCO Spotfire, see below. 

► To open an analysis file: 
1. Click on the Open button on the toolbar, or select File > Open.... 
2. Browse to the analysis file of interest and click Open. 

Note: SFS files created with TIBCO Spotfire DecisionSite, opened in TIBCO Spotfire 
will not retain any visualizations created in DecisionSite, and the file will be opened as 
if it was a standard Spotfire Text Data Format file. Note that SFS files cannot be 
opened from the Library. 

2.2.2 Opening a Text File 
This option is used when delimited text files, such as CSV or TXT files, are opened in Spotfire. 

► To open a text file: 
1. Click on the Open button on the toolbar, or select File > Open.... 
2. Browse to the text file of interest and click Open. 
3. Look at the Data preview and make sure that the format of your data looks OK. 
4. If necessary, change any settings required to obtain the desired result. 

Comment: For detailed information about the various settings, see Import Settings or 
Import Settings - Advanced. 

5. Click on Refresh. 
Response: The Data preview field is updated to show how data will be imported with 
the current settings. 

6. When you are satisfied, click OK. 
Comment: For information about adding more data tables to the analysis, see How to 
Insert Multiple Data Tables to the Analysis. 
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Note: If a delimited text file is pasted into Spotfire, the Import Settings dialog will not 
be displayed. The default settings will be used during import. 
Note: SFS files created with Spotfire DecisionSite, opened in Spotfire will not retain 
any visualizations created in DecisionSite, and the file will be opened as if it was a 
standard Spotfire Text Data Format file. Note that SFS files cannot be opened from the 
Library. 

2.2.3 Opening an Excel File 
Microsoft Excel files (XLSX or XLS) stored using Microsoft Office Excel 2000 or later can be 
opened in Spotfire. 

► To open an Excel file: 
1. Click on the Open button on the toolbar, or select File > Open.... 
2. Browse to the Excel file of interest and click Open. 
3. Select the Worksheet to import. 

Comment: If you cannot see all worksheets available in the file at this step, try saving 
and closing the file in Excel before you open it in Spotfire. 

4. Look at the Data preview and make sure that the format of your data looks OK. 
5. If necessary, change any settings required to obtain the desired result. 

Comment: For detailed information about the various settings, see Excel Import. 
6. Click on Refresh. 

Response: The Data preview field is updated. 
7. When you are satisfied, click OK. 

Comment: For information about adding more data tables to the analysis, see How to 
Insert Multiple Data Tables to the Analysis. 

2.2.4 Opening a SAS File 
Note: To be able to open SAS data files (*.sas7bdat, *.sd2) directly into TIBCO Spotfire, the 
SAS Providers for OLE DB 9.1.3 or later must first be installed on the client machine (see 
http://spotfire.tibco.com/sr for more information). *.sd7 files can also be opened provided that 
they first are renamed to *.sas7bdat. 

► To open a SAS file: 
1. Click on the Open button on the toolbar, or select File > Open.... 
2. Browse to the SAS file of interest and click Open. 
3. Select the columns to import by clicking on them in the Available columns list and 

then click Add >. 
4. Comment: To select all columns click Add All. For multiple selection, press Ctrl and 

click on the desired columns. 
5. Select whether you want to Map data to TIBCO Spotfire compatible types or not. 
6. Select whether you want to Use Description as column name once imported into 

TIBCO Spotfire. 
Comment: For detailed information about the various settings, see SAS Data Import. 

7. Click OK. 
Comment: For information about adding more data tables to the analysis, see How to 
Insert Multiple Data Tables to the Analysis. 

http://spotfire.tibco.com/sr
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2.2.5 Details 

2.2.5.1 Details on Excel Import 

► To reach the Excel Import dialog: 
1. Select File > Open.... 
2. Browse to a Microsoft Excel file and click Open. 

 

Option Description 

Worksheet Select the worksheet containing the data you wish to import. 
Note: If you cannot see all worksheets available in the file, try saving 
and closing the file in Excel before you open it in Spotfire. 

Refresh Updates the Data preview field to reflect any changes made to the 
settings. 

Ignore empty rows Select the check box to skip empty rows during import. 

Data preview Shows how the file will be interpreted, given the specified settings. 

     Name Double-click on a column name to edit the name. 

     Type Change the type for a column by clicking on the arrow and selecting 
the new type from the drop-down menu. The available data types are: 
String, Integer, Real, Currency, Date, Time, DateTime, TimeSpan, 
LongInteger, SingleReal and Boolean. If an inapplicable data type is 
selected, the data in the preview will be displayed in italics once you 
have clicked on the Refresh button. 

     Included Clear the check box to ignore a specific column upon import. 

  
The drop-down list available on each row contains the following options: 
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Option Description 

Name row Select this option on the row or rows that will be used to specify the 
column names in the imported data. 

Type row Select this option on the row that will be used to specify the data types. 

Data row Select this option for all data rows that you wish to import. 

Ignore Select this option for rows that should be ignored during import. 

2.2.5.2 Details on Import Settings 

► To reach the Import Settings dialog: 
1. Select File > Open.... 
2. Browse to a delimited text file and click Open. 

 

Option Description 

Separator 
character 

Allows you to specify which character to interpret as separator 
character. 
Individual fields (column names, type strings, and values) are 
delimited by separator characters—usually commas, semicolons or 
tabs. Spotfire automatically makes a guess to determine the separator 
character, but you can change to a different separator character if 
necessary. 

Culture Allows you to change the culture (the language-related regional 
settings for formatting information, such as time, currency, or dates) 
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from which the data originates. 

Encoding Allows you to change the encoding used to interpret the data. 

Advanced... Opens the Import Settings - Advanced dialog, where additional 
settings can be changed. 

Refresh Updates the Data preview field to reflect any changes made to the 
settings in this dialog or the Import Settings - Advanced dialog. 

Data preview Shows how the file will be interpreted, given the specified settings. 

     Name Double-click on a column name to edit the name. 

     Type Change the type for a column by clicking on the arrow and selecting 
the new type from the drop-down menu. The available data types are: 
String, Integer, Real, Currency, Date, Time, DateTime, TimeSpan, 
LongInteger, SingleReal and Boolean.  If an inapplicable data type is 
selected, the data in the preview will be displayed in italics once you 
have clicked on the Refresh button. 

     Included Clear the check box to ignore a specific column upon import. 

  
The drop-down list available on each row contains the following options: 

Option Description 

Name row Select this option on the row or rows that will be used to specify the 
column names in the imported data. 

Type row Select this option on the row that will be used to specify the data types. 

Data row Select this option for all data rows that you wish to import. 

Ignore Select this option for rows that should be ignored during import. 
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2.2.5.3 Details on Import Settings - Advanced 

► To reach the Import Settings - Advanced dialog: 
1. Select File > Open.... 
2. Browse to a delimited text file and click Open. 
3. In the Import Settings dialog, click Advanced.... 

 

Option Description 

Comment row 
beginning 

Allows you to ignore all rows beginning with a specific character 
sequence. For example, if "#" is used as in the example above, all rows 
beginning with # will be set as Comment rows and will be ignored 
during import. 

Set number of 
columns 

Allows you to specify a fixed number of columns to import. This could 
be smaller or greater than the number of columns available in the 
beginning of the text file. For example, in a data table where 50 
columns are present for the first 100 rows and 60 columns for the 
following rows, it could be useful to set this option to 60 and, hence, 
import all available data. 

Minimum number 
of columns allowed 

Ignores rows where the number of available values is less than the 
specified number. If the data table contains comments or texts in the 
middle of the data, this option can be set to, for example, 5, and only 
rows with values in at least five columns will be imported. 

Interpret as null 
(missing value) 

Allows you to specify a string that should be interpreted as null (a 
missing data value). 

Start reading data 
from row 

Allows you to leave out a specified number of rows. For example, if 
your data contains a header of ten rows which should be ignored 
during import, this option should be set to 11. 
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Name for columns 
with no name rows 

Specifies the default naming of columns for data tables without any 
specified name rows. The suffix "{0}" will automatically be added if 
you do not type it yourself and it means that all columns will receive a 
number after the specified name. For example, "Column {0}" will 
result in the columns "Column 1", "Column 2", "Column 3", etc. 

Concatenate 
multiple name 
rows 

Specifies how multiple name rows will be concatenated. For example, 
the default value for three name rows, "{0}, {1}, {2}", will separate 
the name parts of the different name rows with a comma and a space. 
If the commas are removed, "{0} {1} {2}", only a space will separate 
the name parts. 

Replace missing 
name fields 

Allows you to replace a missing name (or a part of a name if multiple 
name rows are used) by one of the following methods: 
None - leaves a name part blank. If no other name rows contribute to 
the name, the "Name for columns with no name rows" specified above 
will be used for that particular column. 
From left - takes the name or name part from the column on the left 
and uses it as a name or name part. 
By string - replaces missing names or name parts with the specified 
string. 

Has quote 
character 

Specifies whether or not the data table contains quote characters. 

Quote character Specifies the quote character. 

Quote escape Specifies how quote characters should be escaped. 

Allow newline 
characters in 
quoted fields 

Specifies whether or not newline characters will be allowed within a 
quoted field. 

Default Returns all settings in the Import Settings - Advanced dialog to the 
default values. 
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2.2.5.4 Details on SAS Data Import 

► To reach the SAS Data Import dialog: 
1. Select File > Open.... 
2. Browse to a SAS data file (*.sas7bdat or *.sd2) and click Open. 

 

Option Description 

Available columns Lists all columns available in the SAS file. 
Click a column name in the list to select it. To select more than one 
column, press Ctrl and click the column names in the list. Then click 
Add > to send the selected column to the Selected columns field. 

Selected columns Lists all columns that will be imported into Spotfire. 

Add > Sends the columns selected in the Available columns list to the 
Selected columns list. 

< Remove Removes the selected columns from the Selected columns list and 
sends them back to the Available columns list. 

Add All Adds all available columns to the Selected columns list. 

Remove All Removes all columns from the Selected columns list. 

Map data to 
TIBCO Spotfire 
compatible types 

Select this option to map the data to data types available in TIBCO 
Spotfire. If this check box is cleared, the SAS formatting will be 
unchanged. 

Use Description as 
column name (if 
available) 

Select this option to specify whether to use the SAS description as the 
column name once imported into TIBCO Spotfire. If this check box is 
cleared, the column name used in the SAS file will be kept after 
import. 
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2.3 Open from Library 
2.3.1 Opening Files from the Library 

The library provides publishing capabilities for all of your analysis materials, so you can share 
data with your colleagues. The library can be used directly from Spotfire by anyone who has at 
least read privileges. 

► To open a file from the library: 
1. Select File > Open From > Library.... 

Comment: You can also add data from the library using either of the Add Data Table 
tools, or the Replace Data Table tool. 

2. Navigate through the folders, and select the analysis file you want to open. 
Response: Information about the selected analysis file is displayed to the right of the 
list of folders and files. 
Comment: Which library folders you have access to is controlled by group privileges. 
Contact your Spotfire administrator if you cannot reach all the necessary data. 
Comment: SFS files created with Spotfire DecisionSite cannot be opened in Spotfire 
from the library. However, local SFS files can be opened using File > Open..., but in 
that case no visualizations or settings from the SFS file are retained. 
Comment: To limit the amount of items shown in the list, you can select Analysis File 
from the Show items of type drop-down. 

3. Click Open. 
Note: You can also search for a file in the library by entering a file name, or part of a 
file name in the search field in the upper right corner in the dialog, and then pressing 
Enter. All the files and folders matching your search string will then be listed. See 
Searching the Library for more information about search expressions. 

Files published in the library can also be accessed directly by users of Spotfire Web Player by 
clicking on a link to the analysis in an email or on a website. 
Tip: Right-click in the library tree to display a pop-up menu where you can delete or edit the 
properties of previously added files and folders. You can also copy the URL to an analysis and 
open the analysis in the Web Player or send the link to a colleague. 

2.3.2 Opening an Information Link 
Information links are predefined database queries, specifying the columns to be loaded, and any 
filters needed to reduce the size of the data table prior to visualization. They are organized into 
different folders in the library. Which folders in the library are available to you depends on how 
your permissions have been set by the administrator. Information links are defined using Tools 
> Information Designer. 

► To open an information link: 
1. Select File > Open From > Library.... 
2. Navigate through the folders, and select the information link you want to open. 

Response: Information about the information link is displayed to the right of the list of 
folders and files. 
Comment: Which Library folders you have access to is controlled by group privileges. 
Contact your Spotfire administrator if you cannot reach all the necessary data. 
Comment: To limit the amount of items shown in the list, you can select Information 
Link from the Show items of type drop-down. 

3. Click Open. 
Response: The information link is opened into Spotfire. If the information link 
contains prompted steps, you have to respond to these first. 
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Note: You can also search for an item in the library by entering its name, or part of the 
name in the search field in the upper right corner in the dialog, and then pressing enter. 
All the files, information links and folders matching your search string will then be 
listed. See Searching the Library for detailed information about library search. 

2.3.3 Searching the Library 
You can search for library items in the Open from Library dialog, in the Library Administration 
tool and in Information Designer. 
Searching for a text string will by default look for matching text in the title and keywords of 
the items in the library. You can use wildcards and boolean operators to search for parts and 
combinations of words. For a listing of the basic search syntax, see Searching in TIBCO 
Spotfire. 

Library specific search: 

Keyword Example Function 

title:<word in 
title> 

title:sales Locates library items with the 
specified word (or part of word) 
somewhere in the title. 

created_by: 
<username> 

created_by:admin 
  
created_by::admin 

Locates library items created by a 
certain user. 
In the first example, all items 
modified by any users beginning with 
admin will be found. In the second 
example, only items modified by the 
user 'admin' will be found. 

modified_by: 
<username> 

modified_by:admin Locates library items modified by a 
certain user. 

item_type:<type> 
or 
type:<type> 

item_type:datasource Locates items of a specific type. The 
available types are: column, filter, 
join, procedure, query (=information 
link) folder, dxp (= TIBCO Spotfire 
analysis file), datasource, datafunction 
and colorscheme. 

item_id::<GUID> 
or 
id::<GUID> 

item_id::dac3cd8c-47ec-454a-
a8f2-691c60ece052 

Locates a specific library item based 
on its unique identifier. 

depends_on 
(<expression>) 

depends_on(item_id::538bcde4-
7212-475f-a348-
5bb41ba39c41) 
  
depends_on(Sales) 

Locates all items that depend on a 
specific element. 
  

required_by 
(<expression>) 

required_by(item_id::6f6dc7e0-
57bd-11d7-5ac0-
0010ac110132) 

Locates all items that are required by 
another item. If the GUID in the 
example to the left belongs to an 
information link, the search will find 
all columns, filters, etc. that are 
included in that information link. 
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modified modified:"2 days ago" 
modified:"a week ago" 
modified:>"an hour ago" 
modified:today 
modified:<"this month" 
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
modified::>created 
  
  
modified:"2009-02-
01T18:27:55CEST" 

It is possible to search for items that 
have been modified during a specified 
time span, relative to today. There are 
two different ways of describing 
relative dates and times: 
1) State the number of time parts ago 
in a string surrounded by quotes. The 
available time parts are seconds, 
minutes, hours, days, weeks, months 
and years. For example, search for 
modified:<"6 months ago". The given 
number of time units will be 
subtracted from the current time in the 
search. 
2) State the time period to look back 
at using either of the keywords; today, 
yesterday, "this week", "this month", 
"this year". Note that you need quotes 
around all keywords consisting of 
more than one word. In this type of 
search, the last part of the date or time 
is "reset" (the time gets set to zero, the 
day of the month gets set to 1 etc.). 
The start day of a week is dependent 
on your server locale. For a en-US 
locale the first day of the week would 
be Sunday. 
Modified, created and accessed can 
also be used in comparisons with each 
other. The  example to the left locates 
all items that have been modified after 
their creation. 
Modified can also be used together 
with a timestamp of ISO 8601 format 
("yyyy-MM-dd'T'HH:mm:ssz") to 
find items modified at a specific time. 

created created:>"this week" 
created:<"2 weeks ago" 
  
  
  
  
  
created:>"2009-02-
01T18:27:55CEST" 
  
  

It is possible to search for items that 
have been created during a specified 
time span, relative to today. See 
details regarding the allowed time 
spans under "modified" above. 
Modified, created and accessed can be 
used in comparisons with each other. 
Created can also be used together 
with a timestamp of ISO 8601 format 
("yyyy-MM-dd'T'HH:mm:ssz") to 
find items created at a certain time. 

accessed accessed:>"this month" 
accessed:<"2 weeks ago" 
  
  

It is possible to search for items that 
have been accessed during a specified 
time span, relative to today. See 
details regarding the allowed time 
spans under "modified" above. 
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accessed:null 
  
accessed:>"2009-02-
01T18:27:55CEST" 

Modified, created and accessed can be 
used in comparisons with each other. 
Accessed can also be used together 
with a timestamp of ISO 8601 format 
("yyyy-MM-dd'T'HH:mm:ssz") to 
find items accessed at a certain time. 
The example accessed:null finds all 
items that have never been accessed. 
The last example finds all items that 
have been accessed after the first of 
February 2009. 

::> modified::>created Used to finds items strictly greater 
than the expression following the 
operator. 
For example, finds all items that have 
been modified after their creation. 

::< accessed::<modified Used to finds items strictly less than 
the expression following the operator. 
For example, finds all items that have 
been modified after they were last 
accessed. 

parent_id:: 
<folder GUID> 

parent_id::538bcde4-7212-
475f-a348-5bb41ba39c41 

Locates all items located in the 
specified folder. 

format_version: 
<string or null> 

format_version:null Locates all items of a specified format 
version. For example, all items which 
have no format version specified can 
be found. 

content_size: 
<byte> 

content_size:>10000 
content_size:>500KB 
content_size:<2MB 

Locates all items of a specific byte 
size. In the first example, all items 
larger than 10000 bytes are found. 
If nothing else is specified, the 
number is interpreted as bytes, but 
you can specify content sizes in KB, 
MB or GB as well. 

 

Analysis files: 
When searching for analysis files, there are a number of search parameters that may help you 
locating a specific group of analyses. If you want to locate analysis files only, add type:dxp to 
the search expression. 

Keyword Example Function 

description description:sales 
  
type:dxp description:sales 

Locates all items 
containing the 
specified word 
in their 
description. 
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Locates all 
analysis files 
containing the 
specified word 
in their 
description. 

keywords keywords:sales 
  
type:dxp keywords:sales 

Locates all items 
containing the 
specified 
keyword. 
Locates all 
analysis files 
containing the 
specified 
keyword. 

AllowWebPlayerResume: 
<true or false> 

AllowWebPlayerResume:true If true, locates 
all analysis files 
that allow 
personalized 
views for all 
web player 
users. 

EmbedAllSourceData: 
<true or false> 

EmbedAllSourceData:true If true, locates 
all analysis files 
that embed all 
source data. 
(Override and 
embed all data 
check box 
selected.) 

OnDemandInformationLinks: 
<GUID> 

OnDemandInformationLinks:* 
  
  
OnDemandInformationLinks:c45618c3-
b7ac-43aa-bafe-e14f39fd4bb7 

The first 
example locates 
all analyses that 
use on-demand 
data tables. 
You can also 
specify a GUID 
to locate all 
analyses that use 
a specific 
information link 
as an on-demand 
data table. 

AllTablesEmbedded: 
<true or false> 

AllTablesEmbedded:true If true, locates 
all analysis files 
that only have 
embedded data 
tables. 
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Information Model elements: 
If you want to locate information model elements of a specific type only, add type:column (or 
filter, join, procedure, query, folder or datasource) to the search expression. 
 

Keyword Example Function 

description description:sales 
  
type:query description:sales 

Locates all items containing the 
specified word in their description. 
Locates all information links containing 
the specified word in their description. 

column column:Sales 
  
column::Sales 

Locates all items referring to a source 
column with the specified name. 
The source column could be referred to 
in the conditions or groupings of a 
column element, a filter condition, a 
join condition or the join condition of a 
procedure. 

table table:SalesandCost Locates all items referring to a source 
table or stored procedure with the 
specified name. 
This could be referred to in the 
conditions or groupings of a column 
element, a filter condition, the condition 
or target tables of a join or in the source 
procedure or join condition of a 
procedure. 

schema schema:dbo Locates all items referring to a source 
schema with the specified name. 
This could be referred to in the 
conditions or groupings of a column 
element, a filter condition, the condition 
or target tables of a join or in the source 
procedure or join condition of a 
procedure. 

catalog catalog:Sales Locates all elements referring to a 
source catalog with the specified name. 
This could be referred to in the 
conditions or groupings of a column 
element, a filter condition, the condition 
or target tables of a join or in the source 
procedure or join condition of a 
procedure. 

datatype datatype:integer Locates all columns of the specified 
data type (integer, real, string, date, 
time, datetime, clob or blob). 

parameter 
  

parameter:MinSales 
parameter:* 

Locates information links using the 
specified parameter. 

<property_name>:  "my.prop":* Custom properties in any information 
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<property_value> 
   
  

model element are searchable using the 
same syntax. 
However, note that the property name 
must by quoted if it contains a '.' 
delimiter. 

Combinations of keywords: 
You can combine many of the keywords described above to create more advanced search 
expressions. For example: 
type:query depends_on(type:column salary) - searches for information links that contains a 
column named salary 
type:query depends_on(column:salary) - searches for information links that contains an 
element that refers to a data source column named salary 
required_by(type::query InformationLinkName) - shows the elements used by the 
information link with the name InformationLinkName. 
(not (required_by(type:dxp))) and type:query - searches for information links that are not 
used by any analysis file in the library. 

► To search for items in the Open from Library dialog: 
Depending on where you are searching, you may get different search results. Analyses and 
information links are shown when searching in the Open from Library dialog, not any 
information model elements or data sources, etc. 

1. Navigate to the top folder of the structure you want to perform the search in. If you 
want to search the entire library, navigate to the library root. 

2. Type the text you want to search for in the search field at the top right corner of the 
dialog. 

3. Click on the search button with a magnifying glass. 
Response: The dialog will switch to a Search Results view. 

4. The items matching your search criteria will be displayed in the list. To return to the 
normal folder view, click the Back to folder link. 

► To search for items in the Library Administration tool: 
1. Navigate to the top folder of the structure you want to perform the search in. If you 

want to search the entire library, navigate to the library root. 
2. Type the text you want to search for in the search field at the top right corner of the 

Library Administration tool. 
3. Click on the Search button. 

Response: The Library Administration tool will switch to a Search Result view. Note: 
Searching for data sources does not include searching for database entities like 
catalogs, schemas or tables. It is only the database instance itself that can be located 
via search. 

4. The items matching your search criteria will be displayed in the list. To return to the 
normal folder view, click the Back to folder link. 

► To search for items in Information Designer: 
Depending on where you are searching, you may get different search results. Information model 
elements, information links and data sources are shown when searching in Information 
Designer, not any analyses, etc. 

1. Type the text you want to search for in the search field at the top of the Elements tree. 

2. Click on the search button with a magnifying glass, . 
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Response: The search results are displayed. Note: Searching for data sources does not 
include searching for database entities like catalogs, schemas or tables. It is only the 
database instance itself that can be located via search. 

3. The items matching the search result are shown in the list. To return to the normal 
folder view, click the Clear Search... link. 

► To use search expressions in custom RSS feeds: 
You can create a customized RSS feed showing the latest changes to the library items you are 
interested in by appending a library search expression to a URL. 
Use the following syntax to create your own feed: 
http://<server>/spotfire/library[/path/to/something/interesting]?rss[&search=<search_expression
>] 
The path and  search parameters are optional. If you only specify 
http://myspotfireserver/spotfire/library?rss, the feed will return the 20 most recently modified 
files in the library. You can also add a max-results section if you want to limit the number of 
results shown, see example below. 
Examples: 
http://myspotfireserver/spotfire/library?rss&search=content_size:>500KB 
http://myspotfireserver/spotfire/library?rss&search=created_by::admin 
http://myspotfireserver/spotfire/library?rss&max-results=10&search=title:sales 

► To use search expressions in tibcospotfire links: 
You can incorporate a search expression in a tibcospotfire link in order to directly populate the 
Open from Library dialog with some suitable analyses or information links. See Links to 
Analyses in the Library for more information about links. The links are a list of keys and value 
pairs. The key and value are separated using colon, :, and each key and value pair are also 
separated with colons: 
tibcospotfire:<key1>:<value1>:<key2>:<value2>...<keyN>:<valueN> 
  
The following keys and values are allowed: 
Search: <search expression> with optional parameters. 
OrderBy : Title | Modified | Created | Accessed | ContentSize | Description 
MaxResult: <positive integer> 
SortDirection: Ascending | Descending 
  
The values should be encoded using the following pattern: 

Value Encoded to: 
: \: 

" \' 

\ \\ 

Examples: 
tibcospotfire:search:*:OrderBy:Modified:SortDirection:Descending:MaxResult:20 
tibcospotfire:search:modified\:<\'3 days ago'\:OrderBy:Modified:SortDirection:Descending 
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2.3.4 Edit Properties 

2.3.4.1 Details on Edit Properties - General 
This dialog is used to edit the properties for an item in the library. It can be reached by right-
clicking on the item of interest in any view representing the library structure and selecting Edit 
Properties... from the pop-up menu. In the Library Administration tool, it is reached when 
clicking on the Edit... link for the Selected Item. 

 
To edit the properties of an item you must have Browse + Access + Modify permissions to the 
folder it is placed in.  

Option Description 

Name The name of the library item. The following characters are not 
accepted in titles: 
\ / : * ? " < > | $ & + = @ # % ; , { [ ] } ^ ' ~ ´ 

Description A description of the library item. 

Keywords Allows you to add keywords which can be used for finding the item in 
the library. Keywords are separated by a semicolon. 
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2.3.4.2 Details on Edit Properties - Document 

 

Option Description 

Remember 
personalized view 
for each Web 
Player user 

Select this check box if you want to allow users to continue where they 
left off from one time to another when working on the analysis in the 
Web Player. For example, a user can open the analysis in the Web 
Player, change the view (by filtering out some data, for instance), close 
the analysis, and then open the analysis again with the same filter 
settings. 
Note: To make sure this works completely, it is necessary to define 
key columns for all the data tables in the analysis even if they are 
embedded.  

Allow users to add 
new bookmarks  

The ability to add and modify bookmarks can be restricted on two 
levels: the user licenses and the property settings on an analysis level. 
This check box determines the analysis level settings based on the 
users' library folder permissions. 
Clear the check box if you do not want anyone to be able to add 
bookmarks to the analysis. 
Select the check box to allow some or all users to add bookmarks and 
specify the permitted level using the drop-down list: 
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Private bookmarks only (all users) – allows all users to add private 
bookmarks but no public bookmarks are allowed. 
Private (all users), public (write permissions needed) – allows all 
users to add private bookmarks but only users with Modify folder 
permissions or higher will be able to make bookmarks public. 
Private and public bookmarks (write permissions needed) – allows 
only users with Modify folder permissions or higher to add any 
bookmarks. 
Private and public bookmarks (all users) – allows all users to add 
both private and public bookmarks. 

Select preview 
image 

Select whether or not to show a preview image for this analysis when 
browsing for analyses in the library.  
Automatically - sets the preview image to a snapshot of the active 
page when saving the analysis to the library. 
Manually - allows you to manually select a previously saved image. 
(No preview) - use this option to prevent any preview image from 
being shown in the library. 

Browse... When Select preview image has been set to Manually you can browse 
for an image to use in the preview. 

Current preview 
image 

Displays the currently selected preview image. If Select preview image 
has been set to Automatically and the analysis has not yet been saved 
to the library, then no preview will be visible. However, once saved to 
the library the active page when saving will be used as a preview 
image. 

2.4 Open Database 
2.4.1 Open from Database Overview 

By default, Spotfire can connect to several external data source types using the following 
drivers: ODBC, OLE DB, OracleClient and SQLClient. OLE DB UDL files can also be opened 
directly using File > Open.... Other external data sources may also be available depending on 
your installed data providers. 

► General data connection recommendations: 
1. Preferably, use Information Services and create an information link to retrieve your 

data. 
2. If you need to use SqlServer, use the SqlClient Data Provider. 
3. If you need to use Oracle, install the Oracle Data Provider for .NET (ODP.NET) on all 

machines that need to reach the database. It is faster and better than the default data 
provider for Oracle. 

4. It is not recommended to use the OracleClient Data Provider because is at least twice 
as slow at retrieving data (compared to the other options) and even slower at retrieving 
metadata. 

5. Use OleDb rather than ODBC, since ODBC only refers to a local registry connection 
string (one on each machine), which means it will be hard to administer. For OleDb the 
connection string is saved within the file. One advantage with ODBC is that you can 
change the connection string in a single place for one computer. 
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2.4.2 Opening Data from a Database 
See Open from Database Overview for some tips on what connections to use. 

► To open data using SQLClient: 
1. Select File > Open From > Database.... 

Response: The Open Database dialog is displayed. 
2. Click to select SqlClient Data Provider as Data source type. 
3. Click Configure.... 

Response: The Configure Data Source Connection dialog is displayed. 
4. Enter the SQL server name. 
5. Specify whether to Use Windows Authentication or Use SQL Server 

Authentication. 
6. If you are using SQL Server Authentication, type a Username and Password in the 

fields provided. 
7. If you want to connect to a remote database, Select or enter a database name. 

Comment: Select a database from the drop-down list or type the name in the field. 
8. If you instead have a local database file you want to connect to, select Attach to 

database file, and Browse for the local file. Type a logical name to associate with the 
database file. 

9. Click OK. 
Response: The Specify Tables and Columns dialog is displayed. 

10. Select the Tables, views and columns you wish to import. 
Comment: If desired you can edit the SQL statement directly, or load a previously 
saved SQL file with a more complex SQL statement. 

11. Click OK. 
Response: Data is loaded into Spotfire. 

► To open data using OLE DB: 
Note: UDL files can be opened directly using File > Open.... 

1. Select File > Open From > Database.... 
Response: The Open Database dialog is displayed. 

2. Click to select OleDb Data Provider as Data source type. 
3. Click Configure.... 

Response: The Configure Data Source Connection dialog is displayed. 
4. Type or paste a connection line. 

Comment: This should normally be provided by your database administrator. 
5. Click OK. 

Response: The Connection string field in the Open Database dialog is updated with the 
information entered in the previous step. 

6. Click OK. 
Response: The Specify Tables and Columns dialog is displayed. 

7. Select the Tables, views and columns you wish to import. 
Comment: If desired you can edit the SQL statement directly, or load a previously 
saved SQL file with a more complex SQL statement. 

8. Click OK. 
Response: Data is loaded into Spotfire. 
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► To open data using ODBC: 
Note: To learn how to set up a data source, please refer to the database vendor's documentation 
and the Windows documentation on ODBC. It might be necessary to install ODBC driver 
software particular to the database used before being able to utilize the ODBC option. 

1. Select File > Open From > Database.... 
Response: The Open Database dialog is displayed. 

2. Click to select Odbc Data Provider as Data source type. 
3. Click Configure.... 

Response: The Configure Data Source Connection dialog is displayed. 
4. Select a System or user data source name from the drop-down list. 

Comment: The data sources available here are the ones previously defined in Windows 
ODBC Data Source Administrator, found under Control Panel > Administrative Tools 
> Data Sources (ODBC). Contact your database administrator if you are missing any 
information. 

5. If the data source is password protected, type a Username and Password in the fields 
provided. 

6. Click OK. 
Response: The Connection string field in the Open Database dialog is updated with the 
information entered in the previous step. 

7. Click OK. 
Response: The Specify Tables and Columns dialog is displayed. 

8. Select the Tables, views and columns you wish to import. 
Comment: If desired you can edit the SQL statement directly, or load a previously 
saved SQL file with a more complex SQL statement. 

9. Click OK. 
Response: Data is loaded into Spotfire. 

► To open data using OracleClient: 
Note: To be able to use the OracleClient data provider, you need to have Oracle Client installed 
on your computer. 

1. Select File > Open From > Database.... 
Response: The Open Database dialog is displayed. 

2. Click to select OracleClient Data Provider as Data source type. 
3. Click Configure.... 

Response: The Configure Data Source Connection dialog is displayed. 
4. Type or paste the Oracle server name. 
5. If the data source is password protected, type a Username and Password in the fields 

provided. 
6. Click OK. 

Response: The Connection string field in the Open Database dialog is updated with the 
information entered in the previous step. 

7. Click OK. 
Response: The Specify Tables and Columns dialog is displayed. 

8. Select the Tables, views and columns you wish to import. 
Comment: If desired you can edit the SQL statement directly, or load a previously 
saved SQL file with a more complex SQL statement. 

9. Click OK. 
Response: Data is loaded into Spotfire. 
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2.4.3 Details 

2.4.3.1 Details on Open Database 

► To reach the Open Database dialog: 
1. Select File > Open From > Database.... 

 

Option Description 

Data source type Lists the available data source types. 

Connection string Shows the connection string specified for the selected data source type. 
If no connection has been defined yet you can do that by clicking 
Configure.... 

Configure... Opens the Configure Data Source Connection dialog for the respective 
data source type: ODBC, OLE DB, OracleClient, SQLClient or a 
custom provider. 

2.4.3.2 Configure Data Source Connection - SQLClient 

► To reach the Configure Data Source Connection dialog: 
1. Select File > Open From > Database.... 
2. In the Open Database dialog, click to select the SqlClient Data Provider. 
3. Click Configure.... 
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Option Description 

SQL server name The name of the SQL server where your data is located. 

Refresh Refreshes the list of available SQL servers to include a recently added 
SQL server name. 

Use Windows 
Authentication 

Select this option if you can use your normal Windows username and 
password to log into the SQL Server. 

Use SQL Server 
Authentication 

Select this option if the SQL server requires you to log in using a 
different username and password. 

   Username The username you wish to use when logging into the SQL server. 

   Password The password for the specified username. 

Allow saving 
credentials 

Select this option to allow saving of your credentials. 

Select or enter a 
database name 

The name of the database where your data is located. 

Attach to a 
database file 

Select this option if you have a local database file you want to connect 
to. 
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Browse Browse for the database file. 

Logical name Specify a logical name to be associated with the database file. 

2.4.3.3 Configure Data Source Connection - OLE DB 
An OLE DB data provider allows native access to data, such as an SQL Server or an Oracle 
database. Using an OLE DB data provider, Spotfire can retrieve data from a wide variety of 
data sources, not just relational databases. The connection string provided should specify the 
OLE DB driver that is designed to work with your data. 
The following providers are included with the Microsoft data access components: 
Microsoft Jet 3.51 OLE DB Provider 
OLE DB Provider for Oracle 
OLE DB Provider for SQL Server 
OLE DB Provider for ODBC Drivers 
Note: For more information about OLE DB providers, see the OLE DB Programmer's 
Reference. This documentation is available in the Microsoft Data Access SDK. For more 
information about advanced initialization properties, see the documentation provided with your 
OLE DB provider. 

► To reach the Configure Data Source Connection dialog: 
1. Select File > Open From > Database.... 
2. In the Open Database dialog, click to select the OleDb Data Provider. 
3. Click Configure.... 

 

Option Description 

Connection string Should provide information about which OLE DB driver to use, which 
data source to connect to, etc. The connection string would normally 
be acquired from your database administrator. 

Allow saving 
credentials 

Select this option to allow saving of your credentials. 

2.4.3.4 Configure Data Source Connection - ODBC 
ODBC (Open Database Connectivity) allows you to import data from virtually any kind of 
database commercially available. 
To learn how to set up an ODBC data source, please refer to the database vendor's 
documentation and the Windows documentation on ODBC. It might be necessary to install 
ODBC driver software particular to the database used before being able to utilize the ODBC 
option. 

► To reach the Configure Data Source Connection dialog: 
1. Select File > Open From > Database.... 
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2. In the Open Database dialog, click to select the Odbc Data Provider. 
3. Click Configure.... 

 

Option Description 

System or user 
data source name 

Select this option to connect to a system or user data source. 
The data sources available here are the ones previously defined in 
Windows ODBC Data Source Administrator, found under Control 
Panel > Administrative Tools > Data Sources (ODBC). Contact your 
database administrator if you are missing any information. 

Refresh Refreshes the list of defined data sources to include a currently added 
system or user data source name. 

File data source Select this option to connect to a file data source. 

Browse... Opens a dialog where you can browse to locate the DSN file of 
interest. 

Username The username you wish to use when logging into the selected data 
source. 

Password The password for the specified username. 

Allow saving 
credentials 

Select this option to allow saving of your credentials. 

2.4.3.5 Configure Data Source Connection - OracleClient 

► To reach the Configure Data Source Connection dialog: 
1. Select File > Open From > Database.... 
2. In the Open Database dialog, click to select the OracleClient Data Provider. 
3. Click Configure.... 
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Option Description 

Oracle server 
name 

The net service name for the Oracle instance where your data are 
located. The net service name can be found either in the local 
tnsnames.ora file, on an Oracle Names server, or, it can depend on 
your configuration of the Oracle Native Naming Adapters for your 
system. 

Username The username you wish to use when logging into the Oracle server. 

Password The password for the specified username. 

Allow saving 
credentials 

Select this option to allow saving of your credentials. 

2.4.3.6 Configure Data Source Connection - Custom .NET 
Provider 

You can also open other types of databases if other .NET providers are installed on your 
system. How these connections are configured is highly depending on the provider, and these 
examples might not look like the ones installed on your system. 

► To reach the Configure Data Source Connection dialog: 
1. Select File > Open From > Database.... 
2. In the Open Database dialog, click to select the Data Provider of interest. 
3. Click Configure.... 
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Option Description 

Misc Lists properties for your connection. (What properties are visible 
depends on the provider you are using.) Edit the properties by typing in 
the right-hand column. 

Connection string Displays the connection string that is the result of what you have 
entered in the various fields above. 

Allow saving 
credentials 

Select this option to allow saving of your credentials. 

Note that what properties are shown is dependent on your connection provider. Some provider 
might for instance have no visible properties at all, and instead present a login window when 
you open the data source: 
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2.5 Replace Data 
2.5.1 Replacing Data 

In Spotfire it is possible to reuse the visualizations, calculations and setup from a previously 
created document with new data, as long as the new data is reasonably similar to the old data. 
This is useful when creating an analysis for, say, sales figures for a certain month. You create a 
full analysis using the data from January, set up visualizations, calculations, etc., and save the 
file. When the sales figures for February are available, you can open the same file again, and 
replace the data from January with the data from February, and the visualizations will be 
updated. This of course requires that the data table for February is structured in the same way as 
for January, using the same column names and format. 

► To replace data in a document: 
1. Select File > Replace Data Table.... 

Response: The Replace Data Table - Select Data Table dialog is displayed. 
2. Select the data table you wish to replace. 
3. Determine whether to replace it with a New data table or a New data table loaded on 

demand. 
Comment: You can replace data with new data from a file, from an information link, 
from a database, from the clipboard or from an existing data table in the analysis. Only 
information links can be loaded on demand. 

4. Click OK. 
5. Select the source type for the new data table. 
6. If the selected data type is anything other than the clipboard, click Browse... to specify 

the source. 
Response: Depending on which option you have selected, you are provided with some 
means to choose what data to open. See Opening a Text File, Opening an Excel File, 
Opening a SAS File, Opening an Information Link, or Opening Data from a Database 
for more information about each alternative. 
Apply transformations (optional). 

7. Click OK. 
8. If the new data table contains columns that match the columns in the old data table 

completely, the document is immediately updated to use the new data. However, if not 
all columns used in the document could be replaced automatically by columns in the 
new data table, you will be presented with the Replace Data - Match Columns dialog. 
Here, you are able to match columns from the current data table with columns from the 
new data table. If there are missing columns remaining after you have matched 
columns, the Replace Data - Missing Columns dialog is shown. The dialog will state 
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all mismatches that still occur. Make a note of these and click Close. The data are 
replaced, but there may be a need for you to make some manual fixes to make sure all 
visualizations are displayed as you intended. 

9. If necessary, update any visualizations, calculations or hierarchies that were broken 
when the data was replaced. 

2.5.2 Details on Replace Data Table - Select Data Table 

 

Option Description 

Select data table to 
replace 

Specifies which data table to replace. 

Replace with   

   New data table Allows you to select a file, an information link, a database, the 
clipboard or an existing data table in your analysis as the source for 
your new data table. 

   New data table 
loaded on demand 

Allows you to replace your data table with an information link which is 
loaded on demand. See Loading Data on Demand for more 
information. 

2.5.3 Details on Replace Data Table - Select Source 
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Option Description 

Select source type   

  File Allows you to add a data table from a file. 

  Information Link Allows you to add a data table from an information link. 

  Database Allows you to add a data table from any supported database. 

  Clipboard Allows you to add a data table from the clipboard. 

  Existing data table 
in my analysis 

Allows you to add a data table from the current analysis. 

Location Shows the path and file name of the selected file. 

Browse... Opens a dialog where you can select which file, information link, 
database, etc., to open. 

Show 
transformations 

Expands the dialog and allows you to apply transformations on the 
data table you want to add. For more information, see the Show 
transformations dialog. 

2.5.4 Details on Replace Data - Match Columns 
This dialog is displayed when data have been replaced in your current document, but all 
columns used in the document could not be replaced automatically by columns in the new data 
table. It allows you to match columns from the current data table with columns from the new 
data table. 
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Option Description 

From current data Lists the columns in the current data table that could not be replaced 
automatically. Click here to select the column you wish to match with 
a column from the new data, then click Match Selected. 

From new data Lists the columns in the new data table that has not been matched to 
columns from the current data table. Click here to select the column 
you wish to match with a column from the current data, then click 
Match Selected. 

Match Selected Matches the selected columns from the current data table and the new 
data table. 

Matched columns Lists all column pairs that have been selected for matching. 

Unmatch All Unmatches all the matched columns, including the automatically 
matched columns. 

Unmatch Selected Unmatches selected columns from the Matched columns list. 

Cancel Cancels the replace data table operation. 
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2.5.5 Details on Replace Data - Missing Columns 
This dialog is displayed when you have replaced or reloaded the data in your current document, 
but some columns are missing in the new data table. The data is still replaced, but some 
visualizations and hierarchies in the document may need to be manually adjusted. 

 

Option Description 

Missing columns Lists columns that were available in the old data table, but are missing 
in the new data table. 

Invalid calculated 
columns (manual 
updates required) 

Lists columns that were calculated using a column that was available 
in the old data table, but is missing in the new data table. This means 
that the calculation of the column fails. 
You can edit the calculated column in Spotfire by selecting Edit > 
Column Properties; then click to select the column in the Columns 
and hierarchies list and click Edit... in the lower part of the General 
tab. Or, you can simply remove the erroneous column from the 
document (Delete in Column Properties). 

Invalid hierarchies 
(manual updates 
required) 

Lists any hierarchies that were created using a column that was 
available in the old data table, but is missing in the new data table. This 
means that the hierarchy can no longer be used, until it is manually 
updated to use a different column. Hierarchies can be edited by right-
clicking on the filter and selecting Edit Hierarchy.... 
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2.6 Transform Data 
2.6.1 Transforming Data 

Sometimes the data you want to analyze in Spotfire is not in the most appropriate format and 
may contain errors. It may therefore be necessary to perform modifications on the data before 
importing it in order to get the best results from the analysis. 
  
There are several methods that can be used to transform your data before importing it into the 
analysis file. 
  
Calculate and replace column allows you to replace a column in the data table with a calculated 
column. 
Calculate new column allows you to add a calculated column to the data table. 
Change column names allows you to change the name of one or more of the columns in the data 
table. 
Change data types allows you to change the data type for one or more of the columns in the data 
table. 
Data function allows you to use a previously registered data function as a transformation step. 
Exclude columns allows you to exclude one or more of the columns from the data table. 
Normalization allows you to normalize the data prior to addition of the data table. 
Pivot allows you to pivot the data - to change the data table from a tall/skinny to a short/wide 
format. 
Unpivot allows you to unpivot the data - to change the data table from a short/wide to a 
tall/skinny format. 
Note: Additional transformations may be available to you if these have been added locally. 

► To transform data 
1. Select File > Add Data Tables... or File > Add On-Demand Data Table.... 

If you already have an analysis open, you can also choose: 
File > Replace Data Table...  
Insert > Columns from External Data...  
Insert > Rows from External Data... 

2. Select source type. 
3. Browse for the file if needed. 
4. Click Show transformations. 
5. Add the transformations you want to perform on your data. 
6. Click OK to import the transformed data to the analysis. 

2.6.2 Pivoting Data 
A pivot transformation is one way to transform data from a tall/skinny format to a short/wide 
format. The data is distributed into columns usually aggregating the values. This means that 
multiple values from the original data end up in the same place in the new data table. 

Example: 
The example below shows a pivot transformation on a very simple data set. In the original data 
table, there are three columns and four rows. Each row contains one of two department stores, A 
or B; a product, TV or DVD; and a numerical value for the number of sales. The data table 
might look like this if a new row is added after each day. 
However, perhaps we are more interested in knowing how many units of each product are sold 
in each store on an average day. 
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After pivoting the data table, using the aggregation method "average" on the numerical values 
for the two products, we get a new data table. This data table has just two rows, one for each 
store. The layout of the table has gone from tall/skinny to short/wide. Had there been more 
products in the data table the difference would be even more pronounced. In the new data table, 
it is easy to see the number of products being sold in each store on an average day. The first row 
tells us that on any given day in department store A, 3 TVs are sold, but no DVDs. In 
department store B, however, an average day might see 6 TVs and 8 DVDs sold. 

 

Example: 
In this example, we have a larger data set, with data from an imagined company that produces 
small machinery parts. These parts have measurements for width, height and thickness. The 
parts have three different holes in them. There are also measurements for the diameter of these 
holes, and a measurement for a possible small offset from where they are supposed to be. 
In the original data table, which contains measurements for samples of all parts, we can see 
which of the company's three factories—A, B or C—have produced the parts, and we can see 
on which date the parts were shipped, which batch they belong to as well as all the 
measurements for the parts. 
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What we are really interested in knowing is how good the three different factories are at 
producing these parts. If we deliver the parts to different customers who have different demands 
for the accuracy of the holes in the part, we want to know which factory should supply which 
customer with parts. We then pivot the data to get one row for each factory, and to get 
minimum, maximum and average values for the different measurements of the parts. 
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After importing the data to Spotfire, we can start analyzing it. By filtering the data, we can set 
the minimum and maximum allowed measurements for the diameter and offset of the holes in 
the part. 

 
In the analysis, we can see that if the most important criterion is that the diameter is not too 
small, A is the factory that should supply parts to the most demanding customers. 
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2.6.3 Unpivoting Data 
An unpivot transformation is one way to transform data from a short/wide to a tall/skinny 
format. When the data types of source columns differ, the varying data is converted to a 
common data type so the source data can be part of one single column in the new data set. 

Example: 
The example below shows an unpivot transformation on a very simple data set. In the original 
data table, there are three columns and four rows. Each row contains a city, a morning 
temperature and an evening temperature for each city. 
While this is certainly useful, we want to determine the average temperature of all the cities for 
all times of day. 
After unpivoting the data, we have one row for each measurement and can easily get an average 
value for the Temperature column in the analysis after the data has been imported. 
Note: Observe that the morning temperatures were given as integers and the evening 
temperatures as real numbers. In the unpivoted data table, these values must have the same data 
type to be used in the same column. Integers are therefore changed to real numbers (changing 
the real number temperatures to integers, while still somewhat compatible in this case, would 
have resulted in a loss of information). 

 

Example: 
In this example, we have a larger data set containing data on the sales of entrance tickets for a 
museum. The original data table shows data for each of the five ticket counters (desks) and the 
number of tickets they have sold to adults, children and senior citizens each day. 
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However, at this point, rather than needing to know which counter sold how many tickets to 
whom, we are more interested in analyzing our ticket sales in general. Therefore, we unpivot 
the data, combining the Desk columns into one, which we name "Desk" and merging all ticket 
sales to another column, which we name "Tickets". 
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After importing the data into Spotfire, we can start analyzing it. 
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Looking at the analysis, we can now see that Thursdays are the days when we sell the least 
amount of tickets, and that the second and third quarters is the time of year when the museum 
sells the least amount of tickets. 
  

2.6.4 Normalizing Data 

2.6.4.1 Normalizing Columns 
A number of normalization methods can be written as expressions or used as a transformation 
step when adding data tables. See the links at the end of this topic for a description of the theory 
behind each method. 
In the expression examples below, the following values are used: 
Columns: E and A, where E is the column to normalize and A is a baseline column. 
Percentile value: P 

Normalize by mean 
[E] / Avg([E]) 
[E] * Avg([A]) / Avg([E]) 

Normalize by trimmed mean 
[E] / TrimmedMean([E], P) 
[E] * TrimmedMean([A], P) / TrimmedMean([E], P) 

Normalize by percentile 
[E] / Percentile([E], P) 
[E] * Percentile([A], P) / Percentile([E], P) 

Scale between 0 and 1 
If( Max([E]) = Min([E]), 0.5, ([E] – Min([E]) / (Max([E]) – Min([E])) ) 

Subtract the mean 
[E] – Avg([E]) 

Subtract the median 
[E] – Median([E]) 

Normalization by signed ratio 
If( [E] > [A], [E] / [A], -[A] / [E]) 

Normalization by log ratio 
Log10( [E] / [A] ) 

Normalization by log ratio in standard deviation units 
Log10( [E] / [A] ) / StdDev(Log10( [E] / [A] )) 

Z-score calculation 
([E] – Avg([E])) / StdDev([E]) 

Normalize by standard deviation 
[E] / StdDev([E]) 
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2.6.4.2 Details 

2.6.4.2.1 Normalization by Mean  
Assume that there are n rows with seven variables (columns), A, B, C, D, E, F and G, in the 
data. We use variable E as an example in the calculations below. The remaining variables in the 
rows are normalized in the same way. 

Without rescaling (Baseline variable = None) 
The normalized value of ei for variable E in the ith row is calculated as: 

 
where 
p = the number of records used to calculate the mean 

Rescaling by a baseline variable 
If we select variable A as baseline variable, the normalized value of ei for variable E in the ith 
row is calculated as: 

 
where 
p = the number of rows used to calculate the mean 
aj = the value for variable A in the jth record 

2.6.4.2.2 Normalization by Trimmed Mean  
The trimmed mean for a variable is based on all values except a certain percentage of the lowest 
and highest values for that variable. This removes the effect of outliers during the 
normalization. If the trim value is set to 10% then the highest 5% of the values and the lowest 
5% of the values are excluded from the calculated mean. 
Assume that there are n rows with seven variables, A, B, C, D, E, F and G, in the data. We use 
variable E as an example in the calculations below. The remaining variables in the rows are 
normalized in the same way. 

Without rescaling (Baseline variable = None) 
The normalized value of ei for variable E in the ith row is calculated as: 

 
where 
T = the set of rows left after trimming 
p = the number of rows in T. 

Rescaling by a baseline variable 
If we select variable A as baseline variable, the normalized value of ei for variable E in the ith 
row is calculated as: 



Loading Data 

49 

 
where 
T = the set of rows left after trimming 
p = the number of rows in T 
aj = the value for variable A in the jth row. 

2.6.4.2.3 Normalization by Percentile  
Assume that there are n rows with seven variables, A, B, C, D, E, F and G, in the data. We use 
variable E as an example in the calculations below. The remaining variables in the rows are 
normalized in the same way. 

Without rescaling (Baseline variable = None) 
The normalized value of ei for variable E in the ith record is calculated as: 

 
where 
qE,P% = the value that P% of the values for variable E—among the selected rows—are less than 
or equal to 
P = the percentile value that you specify when you normalize the data. 

Rescaling by a baseline variable 
If we select variable A as baseline variable, the normalized value of ei for variable E in the ith 
row is calculated as: 

 
where 
qA,P% = the value that P % of the values for variable A—among the selected rows—are less than 
or equal to 
qE,P% = the value that P % of the values for variable E—among the selected rows—are less than 
or equal to 
P = the percentile value that you specify when you normalize the data. 

2.6.4.2.4 Normalization by Scaling Between 0 and 1  
Assume that there are n rows with seven variables, A, B, C, D, E, F and G, in the data. We use 
variable E as an example in the calculations below. The remaining variables in the rows are 
normalized in the same way. 
The normalized value of ei for variable E in the ith row is calculated as: 

 
where 
Emin = the minimum value for variable E 
Emax = the maximum value for variable E 
If Emax is equal to Emin then Normalized (ei) is set to 0.5. 
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2.6.4.2.5 Normalization by Subtracting the Mean  
Assume that there are n rows with seven variables, A, B, C, D, E, F and G, in the data. We use 
variable E as an example in the calculations below. The remaining variables in the rows are 
normalized in the same way. 
The normalized value of ei for variable E in the ith row is calculated as: 

 
where 
n = the total number of rows in the data. 

2.6.4.2.6 Normalization by Subtracting the Median  
Assume that there are n rows with seven variables, A, B, C, D, E, F and G, in the data. We use 
variable E as an example in the calculations below. The remaining variables in the rows are 
normalized in the same way. 
The normalized value of ei for variable E in the ith row is calculated as: 

 
where 
Emedian = the median of variable E. 
The median of a set of values is the middle value when the values are sorted from lowest to 
highest. If the number of values is even, the median is the average of the two middle values. 

2.6.4.2.7 Normalization by Signed Ratio  
Assume that there are n rows with seven variables, A, B, C, D, E, F and G, in the data. We use 
variable E as an example in the calculations below. All target variables are normalized in the 
same way. 
If we select A as baseline variable, the normalized value of ei for variable E in the ith record is 
calculated as: 

 

if ei > ai 

 

if ei < ai 

where 
ai = the value for variable A in the ith row. 

2.6.4.2.8 Normalization by Log Ratio  
Assume that there are n rows with seven variables, A, B, C, D, E, F and G, in the data. We use 
variable E as an example in the calculations below. All target variables are normalized in the 
same way. 
If we select A as baseline variable the normalized value of ei for variable E in the ith row is 
calculated as: 

 
where 
ai = the value for variable A in the ith row. 
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2.6.4.2.9 Normalization by Log Ratio in Standard Deviation Units  
Assume that there are n rows with k variables, A, B, C, D, E, F and G, in the data. We use 
variable E as an example in the calculations below. All target variables are normalized in the 
same way. 
If we select A as baseline variable the normalized value of ei for variable E in the ith row is 
calculated as: 

 
where 
std = the standard deviation 
ai = the value for variable A in the ith row. 

2.6.4.2.10 Normalization by Z-score  
Assume that there are five rows with the IDs A, B, C, D and E, each row containing n different 
variables (columns). We use record E as an example in the calculations below. The remaining 
rows are normalized in the same way. 
The normalized value of ei for row E in the ith column is calculated as: 

 
where 

 

 
If all values for row E are identical—so the standard deviation of E (std(E)) is equal to zero—
then all values for row E are set to zero. 

2.6.4.2.11 Normalization by Standard Deviation 
Assume that there are five rows with the IDs A, B, C, D and E, each row containing n different 
variables (columns). We use record E as an example in the calculations below. The remaining 
rows are normalized in the same way. 
The normalized value of ei for row E in the ith column is calculated as: 

 
where 
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If all values for row E are identical—so the standard deviation of E (std(E)) is equal to zero—
then all values for row E are set to zero. 
  

2.6.5 Details 

2.6.5.1 Details on Show Transformations 
Transformations can be applied in dialogs that add data, such as in the Add Data Tables dialog, 
the Add On-Demand Data Table dialog, or, in the Insert columns or rows from external data 
tools. Click on Show transformations to display the controls described below. 

 

Option Description 

Hide 
transformations 

Hides the transformation part of the dialog. Can be shown again by 
clicking the "Show transformations" button displayed when the 
lower part of the dialog is hidden. 

Transformations Lists the available transformations. Select one by clicking on it in the 
list. 

Add... Opens a new dialog for the chosen transformation where you specify 
all settings needed for the transformation before it is performed. 
When the transformation has been completed, it will appear in the 
list on the left-hand side. 

Preview Opens a new dialog with a preview of the data with the added 
transformations. 

Edit... Opens a new dialog that allows you to edit the settings for the latest 
transformation added. 
Note: If an earlier transformation is marked in the list, this button is 
grayed out. 

Remove Removes the latest transformation added. 
Note: If an earlier transformation is marked in the list, this button is 
grayed out. 
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2.6.5.2 Details on Preview 

 

Option Description 

Preview after step Lists the transformations you have added so far. Select one of these 
steps in the transformation chain, or the original data table to see in the 
preview how your data has changed with each transformation. 

Data Table tab Shows the Data Table preview tab. This tab shows how the data table 
looks after each transformation. 

Data Table 
Properties tab 

Shows the Data Table Properties preview tab. This tab shows a list of 
all data table properties that have been defined for the data table after 
each transformation, and the values of these data table properties. 
There are two columns in the list, one with all properties and one with 
the corresponding values. 

Column Properties 
tab 

Shows the Column Properties preview tab. This tab shows a list of the 
values of all column properties for all columns in the data table after 
each transformation. In the list, there is a column for each property, 
and all columns in the data table are represented by a row. 

2.6.5.3 Details on Pivot Data 
Pivot Data can be used to transform data from a tall/skinny to a short/wide format when adding 
or replacing data tables. Tip: You can replace a data table with a transformed version of itself. 

► To reach the Pivot Data dialog: 
1. Select File > Add Data Tables... or File > Add On-Demand Data Table... and add 

the data of interest. 
If you already have an analysis open, you can also choose: 
File > Replace Data Table...  
Insert > Columns from External Data... 
or Insert > Rows from External Data... 

2. Click Show transformations. 
3. Select Pivot from the drop-down list and click Add..... 
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Option Description 

Row identifiers Each unique value in the chosen identity column or hierarchy produces 
a row in the generated table. 
If you choose more than one column, the new table will have a 
separate row for each unique combination of values in the chosen 
columns. 

Column titles 
(%C) 

Each unique value in the chosen category column or hierarchy 
produces a new column for each aggregation method in the generated 
data table. 
Selecting more than one column means that the new data table will 
have a separate column for each unique combination of values in the 
chosen columns. 
The column titles are used in the column naming pattern, see below. 

Values (%V) and 
aggregation 
methods (%M) 

The column from which the data values are calculated. The values in 
the generated data table are computed according to the method selected 
under Aggregation in the column selector menu (for example, 
Average). A list of aggregation methods can be found on the Statistical 
Functions page. 
Note: Except for the methods found on the statistical functions page, 
the method Count() can be used. It includes all values, including empty 
values, and therefore returns the total number of rows in the column. 
Note: If you are certain that each combination of Identity and Category 
has a unique value, then you can select the Aggregation: None which 
will not apply any aggregation of the data. However, the pivot will fail 
if you select None, and each combination of Identify and Category is 
not unique. 
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Column naming 
pattern 

You can select how the pivoted columns should be named. By default 
the predefined option is: 
Method(Value) for Column 
You can also create a custom naming scheme for your pivoted 
columns. 
By clicking the drop down list, you can choose from the recently used 
names. 

Transfer columns 
(%T) and 
aggregation 
methods (%A) 

This option allows you to include an overall average, or any other 
aggregation method listed on the Statistical Functions page, of a 
particular measurement, for each row in the generated table. 
Note: Except for the methods found on the statistical functions page, 
the method Count() can be used. It includes all values, including empty 
values, and therefore returns the total number of rows in the column. 

Transfer column 
naming pattern 

You can select how the transfer columns should be named. By default 
the predefined option is: 
Aggregation(TransferValue) 
By clicking the drop down list, you can choose from the recently used 
names. 

Sample Gives you a sample of what the resulting data table will look like. 
Note: Uses the first 100 rows from the data table, so there might be 
some differences between the sample and the resulting data table. 

2.6.5.4 Details on Unpivot Data 
Unpivot Data can be used to transform data from a short/wide to a tall/skinny format when 
adding or replacing data tables. Tip: You can replace a data table with a transformed version of 
itself. 

► To reach the Unpivot Data dialog: 
1. Select File > Add Data Tables... or File > Add On-Demand Data Table... and add 

the data of interest. 
If you already have an analysis open, you can also choose: 
File > Replace Data Table...  
Insert > Columns from External Data... 
or Insert > Rows from External Data... 

2. Click Show transformations. 
3. Select Unpivot from the drop-down list and click Add..... 
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Option Description 

Available columns The columns available for use in the unpivot operation. 
Click a column name in the list to select it. To select more than one 
column, press Ctrl and click the column names in the list. Use one of 
the Add > buttons to send the selected column to either the Columns to 
transform or Columns to pass through field, see below. You can 
narrow down the list of available columns by typing a part of a name 
in the "Type to search" field. You can also enter an expression in the 
field, using the rules described on the Searching in TIBCO Spotfire 
page. 

Add > Moves the selected columns from the Available columns field to the 
field next to the button. 

< Remove Removes a column and brings it back to the Available columns field. 

Remove All Removes all columns from the selected columns fields. 

Columns to pass 
through 

The selected columns containing information that should be transferred 
to the unpivoted data set without any transformation. This could be ID 
columns, categorical information such as Region, Priority etc. 
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Columns to 
transform 

The selected columns containing the values that you wish to combine 
into a single column. The column names of these columns will be used 
as category values in the resulting new category column. Typically, 
this might be a number of columns containing the same type of data, 
such as sales figures for different years. 

Category column 
name (contains 
transformed 
column names) 

Type a column name that summarizes the information provided in the 
columns that you have selected to transform. For instance, "Year" 
could be used when sales figures for several different years are to be 
combined to a single column. 

Data type Allows you to set the data type of the category column name, if several 
are possible. 

Value column 
name 

Type a column name that shows what type of information is included 
in the new value column. For instance, "Sales" would be a good name 
for a column containing sales figures for several different years. 

Data type Allows you to set the data type of the value column name, if several 
are possible. 

Include empty 
values 

Select this check box to transfer empty values to the unpivoted data 
view. If the check box is cleared, all records containing empty values 
will be discarded. 

Sample Gives you a preview of what the resulting data table will look like. 
Note: Uses the first 100 rows from the data table, so there might be 
some differences between the sample and the resulting data table. 

2.6.5.5 Details on Calculate and Replace Column 
This dialog is used to calculate a new column and replace a column in a data table with the new, 
calculated column. It is reached as a transformation step when adding or replacing data tables. 
Tip: You can replace a data table with a transformed version of itself. 

► To reach the Calculate and Replace Column dialog: 
1. Select File > Add Data Tables... or File > Add On-Demand Data Table... and add 

the data of interest. 
If you already have an analysis open, you can also choose: 
File > Replace Data Table...  
Insert > Columns from External Data... 
or Insert > Rows from External Data... 

2. Click Show transformations. 
3. Select Calculate and replace column from the drop-down list and click Add..... 
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Option Description 

Column to replace Lists all available columns in the selected data table. Select the 
column you want to replace by clicking on it. 

Available columns Shows all available columns. Select a column by clicking on it in the 
list and then click on the Insert Columns button, or double-click on 
the column to send it to the Expression field. You can narrow down 
the list of available columns by typing a part of a name in the "Type 
to search" field. You can also enter an expression in the field, using 
the rules described on the  
Searching in TIBCO Spotfire page. Press Ctrl or Shift to select 
multiple columns. 

Insert Columns Inserts the selected columns in the Expression field. 

Available 
properties for 
column 

Shows all properties that you can use in the calculation of a new 
column. The column properties are specific to the column selected in 
the Available columns list to the left. 
Select a property by clicking on it in the list and then click on the 
Insert Properties button, or double-click on the property to send it to 
the Expression field. The property will automatically be inserted as a 
value in this context. 
See Properties in Expressions for more information. 
You can narrow down the list of available properties by using the 
search field. 

Insert Properties Inserts the properties selected in the Available properties for column 
list at the current cursor position in the Expression field. 

Category Select a category of functions to limit the choices in the Function list: 
All functions 
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Binning functions 
Conversion functions 
Date and Time functions 
Logical functions 
Math functions 
Operators 
Property functions 
Ranking functions 
Spatial functions 
Statistical functions 
Text functions 

Function Select a function by clicking on it in the list and then click on the 
Insert Function button, or double-click on the function to send it to the 
Expression field. You can narrow down the list by typing a part of a 
name in the field where it says "Type to search". 

Description Shows a brief description of the selected function. For more detailed 
descriptions, see the Functions chapter. 

Insert Function Inserts the selected function in the Expression field. 

Expression This is the text field in which you build your expression. You can 
insert columns and functions from the lists or enter text as in any 
standard text editor. 

Recent expressions Displays the ten expressions you have most recently created. You can 
select one of these and click the Insert button to insert the expression 
into the Expression field. 

Insert Inserts the selected Recent expression into the Expression field. This 
will replace the entire content of the Expression field. 

Resulting 
expression 

Of interest when preprocessor functions (such as ${PropertyName}) 
are used in the expression only. Displays the expression after all 
occurrences of the property have been replaced with its current value 
or values. 

Column name Type a name for the calculated column. 

Sample result Displays the result of applying the current expression to the first row 
of the data table. Note that if aggregating functions (such as, "Count") 
are used in the expression, only the first 100 rows will be used in the 
sample calculation. 
If this field shows an error there is a problem with the expression. 
Moving the mouse pointer over the red exclamation mark next to the 
Expression field will display an explanation of what is wrong. 

Type Shows the data type of the calculated column. 

Formatting... Opens the Formatting dialog, where you can change the formatting of 
the calculated column. 
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2.6.5.6 Details on Calculate New Column 
This dialog is used to calculate a new column in a transformation step when adding or replacing 
data tables. 

► To reach the Calculate New Column dialog: 
1. Select File > Add Data Tables... or File > Add On-Demand Data Table... and add 

the data of interest. 
2. Click Show transformations. 
3. Select Calculate new column from the drop-down list and click Add..... 

 

Option Description 

Available columns Shows all available columns. Select a column by clicking on it in the 
list and then click on the Insert Columns button, or double-click on 
the column, to send it to the Expression field. You can narrow down 
the list of available columns by typing a part of a name in the "Type 
to search" field. You can also enter an expression in the field, using 
the rules described on the  
Searching in TIBCO Spotfire page. Press Ctrl or Shift to select 
multiple columns. 

Insert Columns Inserts the selected columns in the Expression field. 

Available 
properties for 
column 

Shows all properties that you can use in the calculation of a new 
column. The column properties are specific to the column selected in 
the Available columns list to the left. 
Select a property by clicking on it in the list and then click on the 
Insert Properties button, or double-click on the property to send it to 
the Expression field. The property will automatically be inserted as a 
value in this context. 
See Properties in Expressions for more information. 
You can narrow down the list of available properties by using the 
search field. 
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Insert Properties Inserts the properties selected in the Available properties for column 
list at the current cursor position in the Expression field. 

Category Select a category of functions to limit the choices in the Function list: 
All functions 
Binning functions 
Conversion functions 
Date and Time functions 
Logical functions 
Math functions 
Operators 
Property functions 
Ranking functions 
Spatial functions 
Statistical functions 
Text functions 

Function Select a function by clicking on it in the list and then click on the 
Insert Function button, or double-click on the function to send it to 
the Expression field. You can narrow down the list by typing a part of 
a name in the field where it says "Type to search". 

Description Shows a brief description of the selected function. For more detailed 
descriptions, see the Functions chapter. 

Insert Function Inserts the selected function in the Expression field. 

Expression This is the text field in which you build your expression. You can 
insert columns and functions from the lists or enter text as in any 
standard text editor. 

Recent expressions Displays the ten expressions you have most recently created. You can 
select one of these and click the Insert button to insert the expression 
into the Expression field. 

Insert Inserts the selected Recent expression into the Expression field. This 
will replace the entire content of the Expression field. 

Resulting 
expression 

Of interest when preprocessor functions (such as ${PropertyName}) 
are used in the expression only. Displays the expression after all 
occurrences of the property have been replaced with its current value 
or values. 

Column name Type a name for the calculated column you want to add. 

Sample result Displays the result of applying the current expression to the first row 
of the data table. Note that if aggregating functions (such as, "Count") 
are used in the expression, only the first 100 rows will be used in the 
sample calculation. 
If this field shows an error there is a problem with the expression. 
Moving the mouse pointer over the red exclamation mark next to the 
Expression field will display an explanation of what is wrong. 

Type Shows the data type of the new calculated column. 
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Formatting... Opens the Formatting dialog where you can change the formatting of 
the new, calculated column. 

2.6.5.7 Details on Data Function - Transformation 
This dialog is used to select which function in the library to use as a transformation. Only those 
data functions that use a data table as input and output parameters will be available for 
selection. 

► To reach the Data Function - Transformation dialog: 
1. Select File > Add Data Tables... or File > Add On-Demand Data Table... and add 

the data of interest. 
2. Click Show transformations. 
3. Select Data function from the drop-down list and click Add..... 

 
Click to select a keyword in the Keywords list that matches the type of data function you are 
looking for. You can further limit the number of data functions shown by typing some text in 
the search field. This limits the data functions visible to the ones matching the current search 
expression. For more information about valid search expressions, see Searching in TIBCO 
Spotfire. 

2.6.5.8 Details on Normalization 
Normalization can be used as a transformation step when adding or replacing data tables. Tip: 
You can replace a data table with a transformed version of itself. 

► To reach the Normalization dialog: 
1. Select File > Add Data Tables... or File > Add On-Demand Data Table... and add 

the data of interest. 
If you already have an analysis open, you can also choose: 
File > Replace Data Table...  
Insert > Columns from External Data... 
or Insert > Rows from External Data... 

2. Click Show transformations. 
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3. Select Normalization  from the drop-down list and click Add.... 

 

Option Description 

Result options   

   Add columns Click this radio button to add new normalized columns to the resulting 
data table. The old columns will also be kept. 

   Replace selected 
columns 

Click this radio button to replace the old columns with the new, 
normalized ones. 

Available columns Lists the columns available in the selected data source. 

Add > Moves the columns selected in the Available columns list to the 
Selected columns list. 

< Remove Removes the selected columns from the Selected columns list. 

Remove All Removes all columns form the Selected columns list. 

Move Up Moves the selected column in the Selected columns list up one step. 

Move Down Moves the selected column in the Selected columns list down one step. 

Selected columns Lists the columns that are selected to be normalized. 

Method Specifies the normalization method to use. See Normalizing Columns 
and the theory section for each method for further information about 
the various methods. 
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Baseline column Specifies the baseline column to use (in some normalization methods 
only). 

Percentage Specifies the percentage value (P) to use when normalizing by 
percentile or by trimmed mean. 

Description Shows a brief description of the currently selected normalization 
method. 

Column names 
setting 

Specifies how the naming of the normalized columns should be 
handled. You can either add the word "Normalized:" to the column 
name of the original columns or use the expression (normalization 
equation) as a column name. 
If you have selected to replace columns you will also get a third option 
where you can keep the current column names. 

2.6.5.9 Details on Exclude Columns 
This dialog is reached as a transformation step when adding or replacing data tables. 

► To reach the Exclude Columns dialog: 
1. Select File > Add Data Tables... or File > Add On-Demand Data Table... and add 

the data of interest. 
2. Click Show transformations. 
3. Select Exclude columns from the drop-down list and click Add..... 
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Option Description 

Include Shows all included columns. You can narrow down the list of available 
columns by typing a part of a name in the "Type to search" field. You 
can also enter an expression in the field, using the rules described on 
the Searching in TIBCO Spotfire page. Press Ctrl or Shift to select 
multiple columns. 

Add > Adds the selected columns to the Exclude list. 

< Remove Removes the selected columns from the Exclude list. 

Remove All Removes all columns from the Exclude list. 

Exclude Lists all columns you have chosen to exclude. 

Preview Shows how many columns you have chosen to include and gives you a 
preview of what the data will look like after the completion of this 
transformation. 

2.6.5.10 Details on Change Column Names 
Change Column Names can be used as a transformation step when adding or replacing data 
tables. Tip: You can replace a data table with a transformed version of itself. 

► To reach the Change Column Names dialog: 
1. Select File > Add Data Tables... or File > Add On-Demand Data Table... and add 

the data of interest. 
If you already have an analysis open, you can also choose: 
File > Replace Data Table...  
Insert > Columns from External Data... 
or Insert > Rows from External Data... 

2. Click Show transformations. 
3. Select Change column names from the drop-down list and click Add..... 
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Option Description 

Available columns Shows all available columns. You can narrow down the list of 
available columns by typing a part of a name in the "Type to search" 
field. You can also enter an expression in the field, using the rules 
described on the  
Searching in TIBCO Spotfire page. Press Ctrl or Shift to select 
multiple columns. 

Add > Adds the selected columns to the Columns to rename list. 

< Remove Removes the selected columns from the Columns to rename list. 

Remove All Removes all columns from the Columns to rename list. 

Columns to rename Lists the columns you have selected to rename and shows you the 
name ([%C]) that can be used to apply the same function on all 
columns in the Expression field. 

Function Select a function by clicking on it in the list and then click on the 
Insert button, or double-click on the function to send it to the 
Expression field. 

Description Shows a brief description of the selected function. For more detailed 
descriptions, see the Text functions page. 

Insert > Inserts the selected function in the Expression field. 
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Expression This is the text field in which you build your expression on how to 
rename columns. You can insert functions from the lists or enter text 
as in any standard text editor. Many of the functions require you to 
type either the name of the column you want to rename or the 
common name given by the Columns to rename list. 

New column names Shows the renamed columns. 

2.6.5.11 Details on Change Data Types 
Change Data Types can be used as a transformation step when adding or replacing data tables. 
Tip: You can replace a data table with a transformed version of itself. 

► To reach the Change Data Types dialog: 
1. Select File > Add Data Tables... or File > Add On-Demand Data Table... and add 

the data of interest. 
If you already have an analysis open, you can also choose: 
File > Replace Data Table...  
Insert > Columns from External Data... 
or Insert > Rows from External Data... 

2. Click Show transformations. 
3. Select Change data types from the drop-down list and click Add..... 
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Option Description 

Available columns Shows all available columns. If the data type has been changed for a 
column, the new data type will appear under "New Data Type". If not, 
that field will be empty for that column. You can narrow down the list 
of available columns by typing a part of a name in the "Type to search" 
field. You can also enter an expression in the field, using the rules 
described on the Searching in TIBCO Spotfire page. Press Ctrl or Shift 
to select multiple columns. 

New data type Allows you to choose which data type you want a selected column to 
have. 

Sample value Shows one sample value from the chosen column with the new data 
type applied. 

Formatting Opens the Formatting dialog where you can change the formatting of 
the column with the new data type. 

Reset All Resets the data types of all columns. 

Preview Shows a preview of what the data will look like after the completion of 
this transformation. 

2.7 Missing File 
2.7.1 Details on Missing File 

This dialog is shown when you open a linked analysis file in which the file path to one or more 
of the source files is no longer correct. 

 

Option Description 

The following file 
could not be found 

Shows the name and path to the file that the linked analysis file is 
trying to open. 

What do you want 
to do? 

  

   Search for the 
missing file 

Select this option to open the Search for Missing File dialog and 
automatically search for the file on your local computer or on the 
network. 
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   Browse for the 
missing file 

Select this option to manually browse for the missing file. Use this 
option if the source file used by the linked analysis file has been 
renamed. 

   Use the file 
found in the same 
directory as the 
analysis 

Spotfire has found a file in the same directory as the analysis file with 
the same name as the linked source file. Use this option if you know 
that this is the file. 

2.7.2 Details on Search for Missing File 

 

Option Description 

Search for the file 
named 

Shows the file name of the missing file. This cannot be changed, 
hence, you cannot specify to use a file that has been renamed, or has 
changed file type. 

Look in Displays the path to the folder in which the search will be performed. 

Browse... Opens the Browse for Folder dialog, where you can select a different 
folder, on your local computer or on a network, in which to perform 
the search. 

Search Now Starts the search, in the specified folder. 

Stop Search Stops a search. 

Name Lists the name of all files that match the search. This is always the 
same as the file name at the top of the dialog. 

In Folder Lists the path to the file. 

Size Lists the size of the file. 

Modified Lists the date when the file was last modified. 
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2.8 Column Properties 
2.8.1 How to Edit Column Properties 

Column properties are any type of metadata available for the columns (and, in some cases, also 
for hierarchies) in your data table. For example, this could be the name or number of decimals 
of a column, the data type, an optional description of the column content, or, a customized sort 
order for a string column. All properties can be viewed, and some can be edited, by selecting 
Edit > Column Properties. 

► To change a column name: 
1. Select Edit > Column Properties. 
2. If you have more than one data table in the document, select the Data table to work 

on. 
3. Locate the column of interest by scrolling in the list or by typing a search expression in 

the field provided. 
4. Click to select the column. 
5. On the General tab, type a new name in the Name field. 
6. Click OK. 

► To change the formatting of a column: 
1. Select Edit > Column Properties. 
2. If you have more than one data table in the document, select the Data table to work 

on. 
3. Locate the column of interest by scrolling in the list or by typing a search expression in 

the field provided. 
4. Click to select the column. 
5. On the Formatting tab, click to select a Category. 
6. Make any changes desired. See Column Properties - Formatting for more information 

about the various options. 
Comment: For example, to change the number of decimals displayed for a Real 
column, click Number. Then change the Decimal places to the desired number. 

7. Click OK. 

► To create a custom sort order for a string column: 
1. Select Edit > Column Properties. 
2. If you have more than one data table in the document, select the Data table to work 

on. 
3. Locate the string column of interest by scrolling in the list or by typing a search 

expression in the field provided. 
4. Click to select the column. 
5. On the Sort Order tab, click to select Custom sort order. 
6. Click Configure.... 

Response: The Custom Sort Order dialog is displayed. 
7. Move the values up or down in the Value order list, to create the desired sort order. 
8. Click OK to close the Custom Sort Order dialog. 
9. Click OK. 

► To delete a column from the data table: 
1. Select Edit > Column Properties. 
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2. If you have more than one data table in the document, select the Data table to work 
on. 

3. Locate the column of interest by scrolling in the list or by typing a search expression in 
the field provided. 

4. Click to select the column. 
5. Click Delete. 

Comment: You can hide columns from separate visualizations using the appropriate 
page in the Visualization Properties dialog without actually deleting the column. 
Likewise, you can hide filters that you do not wish to use in the Organize Filters 
dialog. 

► To edit the link template for hyperlinks in tables: 
It is possible to display the text in a table as clickable hyperlinks by setting the renderer for a 
column to Link Renderer. Setting a template in Column Properties provides a default suggestion 
for the Link Renderer. The default template is "http://{$}/", where {$} represents the value 
from the table cell. 

1. Select Edit > Column Properties. 
2. If you have more than one data table in the document, select the Data table to work 

on. 
3. Locate the column of interest by scrolling in the list or by typing a search expression in 

the field provided. 
4. Click to select the column. 
5. On the Column Properties tab, scroll down to locate the Link Template property and 

click to select it. 
6. Click Edit Value.... 

Response: The Edit Value dialog is displayed. 
7. Type a new template for the format of the links. 

Comment: For example, "http://www.{$}.com". 
8. Click OK to close the Edit Value dialog. 
9. Click OK. 

► To create a hierarchy: 
If two or more columns are hierarchically related to each other, you can create a hierarchy that 
can be used instead of the separate columns when filtering or using the categories on axes or to 
specify other properties. 

1. Select Edit > Column Properties. 
2. Click Insert > Hierarchy.... 
3. If you have more than one data table in the document, select the Data table to work 

on. 
Comment: Hierarchies can only be created with columns from the same data table. 

4. Select the columns that should be a part of the hierarchy from the Available columns 
list. 

5. Click Add >. 
6. Make sure that the columns are listed in the Hierarchy list from the least granular to 

the most granular category. For example, Continent - Country - City. 
7. Type a Hierarchy name. 
8. Click OK to close the Insert Hierarchy dialog. 
9. Click OK. 
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2.8.2 Details on Column Properties - General 
Metadata about the columns and hierarchies is handled in the Column Properties dialog. Here, it 
is possible to view information about the origin of columns, descriptions on columns, min and 
max values within a column, etc. See Column Properties Descriptions for more information 
about the default properties. All columns in the data view have the same set of column 
properties, but a property may have undefined values for some columns. 

► To reach the Column Properties dialog: 
1. Select Edit > Column Properties. 
2. Click on the General tab. 

 

Top part of dialog 

Option Description 

Data table Only available when more than one data table is available in the 
analysis. Specifies the data table that you are currently viewing 
column properties for. 

Columns and 
hierarchies 

Lists all columns and hierarchies available in the data table. You 
can narrow down the list of available columns by typing a part of a 
name in the "Type to search" field. You can also enter an 
expression in the field, using the rules described on the Searching 
in TIBCO Spotfire page. 

Insert   

     Calculated Column Opens the Insert Calculated Column dialog, where you can create a 
new column from an expression. 
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     Binned Column Opens the Insert Binned Column dialog, where you can group the 
values of a column into a smaller number of bins (groups). 

     Hierarchy Opens the Insert Hierarchy dialog, where you can create a 
hierarchy (an ordered structure) by combining columns with each 
other. 

Delete Removes the selected column or hierarchy from the data table. 

General tab 

Option Description 

Name The name of the column or hierarchy used in the application. 

Description An optional description of the column. 

Data type The data type of the column. 

Column Information Displays additional information about the column or hierarchy, 
such as how it was created. 

Edit... Available for calculated columns, binned columns or hierarchies 
only. Opens the dialog where the column was created, so that the 
expression can be modified. 

Freeze Column Locks the column so that it cannot be edited anymore, and any 
replace data operations will not attempt to recalculate this column. 

2.8.3 Details on Column Properties - Formatting 
This dialog lets you format values on column level. If you change settings for a specific column 
or hierarchy in this dialog the new settings will be used for that specific column or hierarchy 
everywhere in the analysis from then on. 
For general information about formatting, see Formatting Overview. 

► To reach the Column Properties dialog: 
1. Select Edit > Column Properties. 
2. Click on the Formatting tab. 
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Top part of dialog 

Option Description 

Data table Only available when more than one data table is available in the 
analysis. Specifies the data table that you are currently viewing 
column properties for. 

Columns and 
hierarchies 

Lists all columns and hierarchies available in the data table. You 
can narrow down the list of available columns by typing a part of a 
name in the "Type to search" field. You can also enter an 
expression in the field, using the rules described on the Searching 
in TIBCO Spotfire page. Click on the column or hierarchy to 
format it. Formatting options can be set for more than one column 
or hierarchy at a time, provided that all columns are of the same 
type. 

Insert   

     Calculated Column Opens the Insert Calculated Column dialog, where you can create a 
new column from an expression. 

     Binned Column Opens the Insert Binned Column dialog, where you can group the 
values of a column into a smaller number of bins (groups). 

     Hierarchy Opens the Insert Hierarchy dialog, where you can create a 
hierarchy (an ordered structure) by combining columns with each 
other. 

Delete Removes the selected column or hierarchy from the data table. 
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Formatting tab 

Option Description 

Category Lists the available categories for the selected column or hierarchy. 
Each category in this list has separate settings. What categories are 
available depends on the data type of the selected column. See 
Formatting Settings for a full description of all possible options. 

Apply formatting 
from column 

  

   Data table Specifies the data table containing the column from which you 
want to apply formatting. 

   Column Lists all columns of the same type as the selected column, from 
which it is possible to reuse the formatting. 

Apply Formatting Applies the formatting from the column selected in the drop-down 
list. 

2.8.4 Details on Column Properties - Properties 
► To reach the Column Properties dialog: 

1. Select Edit > Column Properties. 
2. Click on the Properties tab. 
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Top part of dialog 

Option Description 

Data table Only available when more than one data table is available in the 
analysis. Specifies the data table that you are currently viewing 
column properties for. 

Columns and 
hierarchies 

Lists all columns and hierarchies available in the data table. You 
can narrow down the list of available columns by typing a part of a 
name in the "Type to search" field. You can also enter an 
expression in the field, using the rules described on the Searching 
in TIBCO Spotfire page. 

Insert   

     Calculated Column Opens the Insert Calculated Column dialog, where you can create a 
new column from an expression. 

     Binned Column Opens the Insert Binned Column dialog, where you can group the 
values of a column into a smaller number of bins (groups). 

     Hierarchy Opens the Insert Hierarchy dialog, where you can create a 
hierarchy (an ordered structure) by combining columns with each 
other. 

Delete Removes the selected column or hierarchy from the data table. 

Properties tab 

Option Description 

Property Name Lists all properties currently available for the selected column. If 
you have defined custom properties for the column, these properties 
are also listed here. 

Value Lists the value of each property for the selected column (when 
applicable). 

New... Opens the New Property dialog, where custom column properties 
can be defined. Custom column properties are added to all columns 
in the analysis, including those in other data tables. 

Edit... Opens the Edit Property dialog, where the value and the default 
value of a custom column property can be edited. 
Note: If other settings than the value or the default value are 
wrong, you need to delete the custom property and create a new 
one instead. 

Delete Deletes the selected custom property. The custom column property 
is deleted from all columns in the analysis. 
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2.8.5 Details on Column Properties - Sort Order 
► To reach the Column Properties dialog: 

1. Select Edit > Column Properties. 
2. Click on the Sort Order tab. 

 

Top part of dialog 

Option Description 

Data table Only available when more than one data table is available in the 
analysis. Specifies the data table that you are currently viewing 
column properties for. 

Columns and 
hierarchies 

Lists all columns and hierarchies available in the data table. You 
can narrow down the list of available columns by typing a part of a 
name in the "Type to search" field. You can also enter an 
expression in the field, using the rules described on the Searching 
in TIBCO Spotfire page. 

Insert   

     Calculated Column Opens the Insert Calculated Column dialog, where you can create a 
new column from an expression. 

     Binned Column Opens the Insert Binned Column dialog, where you can group the 
values of a column into a smaller number of bins (groups). 

     Hierarchy Opens the Insert Hierarchy dialog, where you can create a 
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hierarchy (an ordered structure) by combining columns with each 
other. 

Delete Removes the selected column or hierarchy from the data table. 

Sort Order tab 

Option Description 

Standard sort order 
for data type 

Use this option to apply the standard sort order for the data type of 
the selected column. For example, this means that a string column 
will be sorted alphabetically. Below is an example of how strings 
containing digits and non-alphanumeric characters will be sorted: 
a# 
a1 
a20 
a3 
b1 

Natural string sort Use this option to apply natural string sort order to the selected 
column. This means that a string column will be sorted 
alphabetically. Below is an example of how strings containing 
digits and non-alphanumeric characters will be sorted: 
a1 
a3 
a20 
a# 
b1 

Custom sort order Use this option to specify a different sort order. For example, a 
column containing months could be sorted by the actual order of 
months as in the example in the image above. 

Configure... Opens the Custom Sort Order dialog, where the desired sort order 
can be specified. 

Sample Displays a sample of how the column will be sorted using the 
current settings. 

Apply sort order from 
column 

To be able to apply a sort order from another column, there must be 
some matching values in the two columns. If the column with the 
sort order you want to apply for example contains months, the 
column you want to sort must contain some of the months. This 
means that you cannot use a column with months sorted 
alphabetically to sort a column with names alphabetically. 

Data table Specifies the data table containing the column from which you 
wish to copy a sort order. 

Column Select a column from the drop-down list to copy a sort order from 
another column. 

Apply Sort Order Applies the sort order from the chosen column to the currently 
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selected column. 

2.8.6 Column Properties Descriptions 
The following column properties are available by default: 

Option Description 

Name [Persistent, user visible, user editable, searchable.] 
The name is a trimmed and unique identifier for the 
column. It is used as the display name for the column in 
the UI. 

DataType 
  

[Persistent, user visible, searchable.] 
The type of the values in the column. The API type of 
this property is Spotfire.Data.DataType, but the name of 
the type is displayed in the UI. 

ExternalName [Persistent, user visible, searchable.] 
The name of the column in the original data source. The 
purpose of this property is to allow column matching for 
linked data and add/replace data operations. This 
property always has a non-null value, even if the name 
and the external name are identical. 

ExternalId [Persistent, user visible, searchable.] 
The globally unique id of the column, if available from 
the data source. Available for many columns imported 
via information links, but not all. The property is invalid 
if the column has no external id. 

ColumnType [Persistent, user visible, searchable.] 
The type of column. The API type of this property is an 
enum, but it is displayed by name in the UI. The 
following are the mutually exclusive column types: 
• Static - physical data retrieved from a data source. 
• Calculated - a column created using the Insert 
Calculated Column tool. 
• Binned - a column created using the Insert Binned 
Column tool. 
• Annotation - an annotation column containing tags. 
• Result - output result from a calculation such as 
clustering. 
• Frozen - a Calculated/Binned/Annotation/Result 
column that has been frozen and behaves like a static 
column. 
This property is user-editable in the sense that non-static 
columns can be frozen. 

IsValid [Persistent, user visible, searchable.] 
True if the column expression is valid. The property 
itself is valid only for calculated and binned columns, 
and the property value is false if there is a dangling 
reference in the column expression. 
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IsIndexed [Persistent, user visible, searchable.] 
True if the column is indexed, i.e., if the distinct values 
have been identified and sorted. 

DistinctValueCount [Calculated, user visible, searchable.] 
The number of distinct valid values in the column. The 
property is valid only if the column is indexed. 

RowCount [Calculated, user visible.] 
The number of rows in the column (equal value for all 
columns in a data view). 

ValidRowCount [Calculated, user visible, searchable.] 
The number of valid rows in the column. The property is 
valid for all columns, even if not indexed. 

InvalidRowCount [Calculated, user visible, searchable.] 
The number of invalid rows in the column. The property 
is valid for all columns, even if not indexed. 

MinValue [Calculated, user visible, searchable.] 
The smallest value in the column, as defined by the 
comparer. The property is valid for all columns that have 
at least one valid value, even if the column is not 
indexed. 

MaxValue [Calculated, user visible, searchable.] 
The largest value in the column, as defined by the 
comparer. The property is valid for all columns that have 
at least one valid value, even if the column is not 
indexed. 

MinNumericValue [Calculated, user visible, searchable.] 
The smallest numeric value in a column. (All column 
values have a numeric representation.) The property is 
valid even for a non-indexed column, as long as there is 
at least one valid value. 

MaxNumericValue [Calculated, user visible, searchable.] 
The largest numeric value in a column. The property is 
valid even for a non-indexed column, as long as there is 
at least one valid value. 

Expression [Calculated, user visible.] 
For calculated columns only. Displays the expression 
used to calculate the column. 

DerivedExpression [Calculated, user visible.] 
For calculated columns only. Displays the expression 
used to calculate the column after the pre-processor 
values have been evaluated. 

Origin [Persistent, user visible, searchable.] 
A text string that describes where the column comes 
from. Typically set by a data source, or by a tool for a 
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result column. 

Description [Persistent, user visible, user editable, searchable.] 
A description of the column entered by the user as an 
annotation. 

LinkTemplate A link template used to create links to a website from the 
values in a table. For example, the link template can be 
"http://www.{$}.com", where "{$}" represents the data 
value from the column. 

DefaultContinuousColorScheme The name of the default continuous color scheme that 
will be used when continuous coloring is applied to this 
column. If no color scheme is specified, or if the 
specified color scheme is not available, the Spotfire 
Continuous color scheme will be used. 

DefaultCategoricalColorScheme The name of the default categorical color scheme that 
will be used when categorical coloring is applied to this 
column. If no color scheme is specified, or the specified 
color scheme is not available, the Spotfire Categorical 
color scheme will be used. 

ContentType Each column may have a specified content type. 
Renderers use this property as input to know what to 
display. Use the form toplevel/subtype, for example, 
text/plain or image/jpg. 
For Geometry columns the content type should be set to 
application/x-wkb if you want to show the geometry 
information as images. 
If you are using TIBCO Spotfire Lead Discovery to 
display chemical structures from an SDFile then the 
content type should be set to chemical/x-mdl-molfile for 
the molfile column. 
Note: Do not use a space when specifying the content 
type. 

Keywords [Persistent, user visible, searchable.] 
Keywords defined on the column element can be used 
when searching for columns with the following syntax: 
Keywords:<desired keyword>. For example, 
Keywords:Sales. 

Note that column properties that are being calculated from the values in the column should not 
be used directly in any subsequent calculations. For example, they should not be used as input 
parameters for data functions, property controls or action controls in the text area, nor as On-
Demand loading parameters. Instead, it is recommended that the corresponding values are being 
calculated using expressions: 

Column Property Corresponding Expression 
DistinctValueCount UniqueCount(...) 

RowCount Count() 

ValidRowCount Count(...) 

InvalidRowCount Count() - Count(...) 
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MinValue Min(...) 

MaxValue Max(...) 

MinNumericValue Real(Min(...)) 

MaxNumericValue Real(Max(...)) 

2.8.7 Details 

2.8.7.1 Details on Insert Hierarchy 
Predefined hierarchies can be set up when two or more columns are somehow related to each 
other. For example, a hierarchy can add structure to columns containing Country, State and 
City. The predefined hierarchies allow you to quickly change the level of detail in a 
visualization by using the hierarchy sliders, or, when you wish to combine two or more filters to 
a more structured hierarchy filter. 
Note: The number of allowed nodes in a hierarchy with more than one level is limited to 100 
000. If you try to create a hierarchy with more nodes, you will simply receive a hierarchy with 
one value, (All). If this should happen, edit the hierarchy and remove the column with too many 
unique values from the hierarchy. 

► To reach the Insert Hierarchy dialog: 
1. Select Edit > Column Properties. 
2. Click on the Insert button and select Hierarchy... from the menu. 

 

Option Description 

Data table Only available when more than one data table is present in the analysis 
and the dialog has been opened via the main menu. Specifies the data 
table where the hierarchy will be inserted. 

Available columns Lists all columns that can be used to create a hierarchy. 

Add > Adds the column selected in the Available columns list to the 
Hierarchy. 
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< Remove Removes the selected column from the Hierarchy and sends it back to 
the Available Columns list. 

Move Up Moves the selected column up in the Hierarchy. 

Move Down Moves the selected column down in the Hierarchy. 

Hierarchy (least 
detailed on top) 

Lists the columns that will be part of the new hierarchy. Start with the 
least granular category and continue to add more and more granular 
categories to the list. 

Hierarchy name Type a name to define the new hierarchy. 

2.8.7.2 Details on Custom Sort Order 

► To reach the Custom Sort Order dialog: 
1. Select Edit > Column Properties. 
2. Click to select the column you wish to modify the sort order for in the Columns and 

hierarchies list. 
3. Go to the Sort Order tab. 
4. Click on the Custom sort order radio button and click Configure.... 

Note: Custom sort order is only available for string columns. 

 

Option Description 

Value order Lists the available values in the current sort order. Move values up and 
down in the list to rearrange the sort order. 
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Move Up Click on a value and then click Move Up to move the value up in the 
list. 

Move Down Click on a value and then click Move Down to move the value down in 
the list. 

Move First Click on a value and then click Move First to move the selected value 
to the top of the list. 

Move Last Click on a value and then click Move Last to move the selected value 
to the bottom of the list. 

Reverse Reverses the current sort order. 

Reset Reverts to the default sort order (alphabetically sorted strings or string 
valued date parts). 

2.8.7.3 Details on New/Edit Column Property 
It is possible to add custom column properties to the columns in the analysis. These can be used 
when you create reference lines in visualizations, or be a part of an expression. See Using 
Properties in the Analysis for some examples. 

► To reach the New Property dialog: 
1. Select Edit > Column Properties. 
2. Click on the Properties tab. 
3. Click New.... 

 

Option Description 

Property name Specifies the name of the custom column property. 

Data type Specifies the data type of the property. 

Description Optional. A description of the intended use of the property. 

Default value Shows the default value of the property. If the value is cleared (set to 
empty) for a specific column then that column property will 
automatically revert to use the default value. 
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Note: The only thing you can change using Edit Property is the value of the selected column, 
the default value and the description. If other settings are wrong, you need to delete the custom 
property and create a new one instead. 

 

Option Description 

Property name Specifies the name of the column property. 

Data type Specifies the data type of the property. 

Description Optional. A description of the intended use of the property. 

Default value Shows the default value of the property. 
Note: Changing the default value will change both the value for all 
new columns as well as for those columns that are currently using the 
old default value. 

Edit... Opens the Edit Value dialog, where the description and the default 
value can be changed. 

Value Shows the value of the property. 

2.8.7.4 Details on Edit Value 
This dialog is shown when editing the default values for a property in the Edit Property dialog. 
For example, this could be the default value and the description of a column property. 
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If the Edit Value dialog is opened from the Document Properties dialog, then only the 
description field will be available. 

Option Description 

Property value [Only available for column properties and data table properties.] 
Allows you to specify a value for the selected property. 

Description Allows you to edit the description of the property. 

 

2.8.7.5 Details on Select Visible Properties 

► To reach the Select Visible Properties dialog: 
1. Select Edit > Column Properties. 
2. Right-click in the Columns and hierarchies list in the top part of the Column Properties 

dialog. 
3. Select More.... 

 

Option Description 

Visible properties Lists all properties available for the columns in this data table. Select 
the check box of a property to show it in the Columns and hierarchies 
list. Clear the check box to hide the property from the list. 

2.9 Data Table Properties 
2.9.1 How to Edit Data Table Properties 

The dialog found under Edit > Data Table Properties contains settings that apply to the data 
tables used in the analysis. For example, you can define which data table to use as default when 
creating new visualizations, set up sharing routines, or define how data should be stored when 
saving the analysis. To learn more about using multiple data tables, see Data Tables Overview. 
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► To change the default data table to use when creating new 
visualizations: 
1. Select Edit > Data Table Properties. 
2. Click on the data table to use in the Data tables list. 

Comment: New data tables are added by selecting File > Add Data Tables... or File > 
Add On-Demand Data Table.... 

3. Click on the Set as Default button to the right of the Data tables list. 
4. Click OK. 

Response: All new visualizations created from here on will use the specified data table. 
Comment: To change the data table used in an already-created visualization, right-
click on the visualization and select Properties from the pop-up menu, then go to the 
Data page. 

► To define a new relation between two data tables: 
1. See To define a new relation. 

► To add a new data table property: 
1. Select Edit > Data Table Properties. 
2. Go to the Properties tab. 
3. Click on the New... button. 

Response: The New Property dialog is opened. 
4. Enter a name for the new property. 
5. Select a data type for the new property. 
6. Enter a value to use as default value for the property. 
7. Click OK. 

Response: The new property is added to the list of available properties. 
Comment: New properties can also be created on most places where you can use them. 
For example, by right-clicking in the Available properties for column list in the 
expression dialogs. 

2.9.2 Details on Data Table Properties - General 
► To reach the Data Table Properties dialog: 

1. Select Edit > Data Table Properties. 
2. Click on the General tab. 
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Option Description 

Data tables Lists the data tables available within the document. The names of the 
data tables in this list are the names that will be shown in the data table 
selectors, in the legends of visualizations, etc. 
You cannot have two data tables with identical names in the same 
analysis. 

Rename... Allows you to change the display name of the selected data table. 

Refresh Data Reloads the data from the source. This is a way to refresh the data 
while analyzing, without having to reload the entire file. 
Tip: If you want to reload multiple data tables simultaneously, you can 
instead select File > Reload Data on the main menu. 
Note: If a data table is loaded on demand or calculated using a data 
function you need to click OK in the Data Table Properties dialog to 
actually start the data refresh. 

Delete Removes the selected data table from the analysis. Any visualizations 
that use the deleted data table will become invalid. 

Set as Default Sets the selected data table to be the default data table. This means that 
the selected data table will be used when new visualizations are 
created. 
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You can always change the data table to use in a specific visualization 
from the Data page in Visualization Properties or from the Data table 
selector in the legend. 

Store Data Defines how you want data from the selected data table to be stored 
when saving the analysis. 

   Embedded in 
analysis 

Use this option to embed the data from the selected data table in the 
analysis. By embedding all data in the analysis file it will be self-
contained with data. This allows you to share the analysis with others 
who do not have access to the same databases you do, or who need to 
use their laptops offline while traveling. 

   Linked to source Use this option to link the data from the selected data table to the 
original data sources. This is useful when data is updated or changed 
from time to time. For example, if you create an analysis file that gets 
its data from a database that is updated each night, then the linked 
option allows you to open the analysis file and have it automatically 
show the latest numbers. It will still use the visualizations and settings 
you already set up, but base them on the updated data. Also, data might 
take up lots of space so you might not want to embed a copy of a large 
data table if you can access it from another data source. 
Note: Make sure that all people who are going to use the analysis also 
have permissions to access the linked data. If you use this option to 
create an analysis file which is linked to a source file on your local 
computer, other people might not be able to open the file. 

      Prompt for 
new settings before 
loading 

Select this check box if you want to see the import settings or any 
available prompt steps for the selected data table when you open the 
analysis. If the check box is cleared, the last used settings will be 
applied. 

Key columns for 
linked data 

If specified, lists the columns that have been specified to define an 
identifier for all rows in the selected data table. 
Key columns are used to uniquely identify rows when markings, tags 
or bookmarks are saved with a linked data source. 

Edit... Opens the Select Key Columns dialog where you can specify the 
columns to use to create a unique identifier for all rows in the selected 
data table. 

Type of data Displays the type of data source. 

Settings... If applicable, opens a dialog where the data source settings can be 
modified. If the data table is the result of a calculation (for example, a 
data relationships calculation), then the dialog for calculating the data 
table is opened again. For information links that are loaded on demand, 
the load method settings can be changed. 

2.9.3 Details on Data Table Properties - Source 
Information 
► To reach the Data Table Properties dialog: 

1. Select Edit > Data Table Properties. 
2. Click on the Source Information tab. 
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Option Description 

Data tables Lists the data tables available within the document. The names of the 
data tables in this list are the names that will be shown in the data table 
selectors, in the legends of visualizations, etc. 
You cannot have two data tables with identical names in the same 
analysis. 

Rename... Allows you to change the display name of the selected data table. 

Refresh Data Reloads the data from the source. This is a way to refresh the data 
while analyzing, without having to reload the entire file. 
Tip: If you want to reload multiple data tables simultaneously, you can 
instead select File > Reload Data on the main menu. 
Note: If a data table is loaded on demand or calculated using a data 
function you need to click OK in the Data Table Properties dialog to 
actually start the data refresh. 

Delete Removes the selected data table from the analysis. Any visualizations 
that use the deleted data table will become invalid. 

Set as Default Sets the selected data table to be the default data table. This means that 
the selected data table will be used when new visualizations are 
created. 



Loading Data 

91 

You can always change the data table to use in a specific visualization 
from the Data page in Visualization Properties or from the Data table 
selector in the legend. 

Source Displays information about the origin of the data table together with 
any transformations or other modifications that have been applied to 
the original source data. 
If the source is a file, then the file name and path are shown. For an 
information link, the source origin shown is the name of the 
information link, and for a database, it is the data source name given 
when adding the data table. 

Copy to Clipboard Copies the information under Source so that you can paste it in another 
application. 

2.9.4 Details on Data Table Properties - Relations 
► To reach the Data Table Properties dialog: 

1. Select Edit > Data Table Properties. 
2. Click on the Relations tab. 
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Option Description 

Data tables Lists the data tables available within the document. The names of the 
data tables in this list are the names that will be shown in the data table 
selectors, in the legends of visualizations, etc. 
You cannot have two data tables with identical names in the same 
analysis. 

Rename... Allows you to change the display name of the selected data table. 

Refresh Data Reloads the data from the source. This is a way to refresh the data 
while analyzing, without having to reload the entire file. 
Tip: If you want to reload multiple data tables simultaneously, you can 
instead select File > Reload Data on the main menu. 
Note: If a data table is loaded on demand or calculated using a data 
function you need to click OK in the Data Table Properties dialog to 
actually start the data refresh. 

Delete Removes the selected data table from the analysis. Any visualizations 
that use the deleted data table will become invalid. 

Set as Default Sets the selected data table to be the default data table. This means that 
the selected data table will be used when new visualizations are 
created. 
You can always change the data table to use in a specific visualization 
from the Data page in Visualization Properties or from the Data table 
selector in the legend. 

Related data 
tables 

Lists all other data tables which have been specified to have a relation 
to the selected data table. 

Manage 
Relations... 

Opens the Manage Relations dialog where you can add, edit or remove 
relations between data tables. 

Relations color Displays the color used to distinguish the data tables related to this data 
table from other, unrelated data tables. 

2.9.5 Details on Data Table Properties - Properties 
On the Properties tab it is possible to specify custom data table properties which are applicable 
throughout the document. The data table properties can be used inside expressions using Insert 
Column from Expression or Custom Expressions. 

► To reach the Data Table Properties dialog: 
1. Select Edit > Data Table Properties. 
2. Click on the Properties tab. 
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Option Description 

Data tables Lists the data tables available within the document. The names of the 
data tables in this list are the names that will be shown in the data table 
selectors, in the legends of visualizations, etc. 
You cannot have two data tables with identical names in the same 
analysis. 

Rename... Allows you to change the display name of the selected data table. 

Refresh Data Reloads the data from the source. This is a way to refresh the data 
while analyzing, without having to reload the entire file. 
Tip: If you want to reload multiple data tables simultaneously, you can 
instead select File > Reload Data on the main menu. 
Note: If a data table is loaded on demand or calculated using a data 
function you need to click OK in the Data Table Properties dialog to 
actually start the data refresh. 

Delete Removes the selected data table from the analysis. Any visualizations 
that use the deleted data table will become invalid. 

Set as Default Sets the selected data table to be the default data table. This means that 
the selected data table will be used when new visualizations are 
created. 
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You can always change the data table to use in a specific visualization 
from the Data page in Visualization Properties or from the Data table 
selector in the legend. 

Available 
properties 

Lists all properties currently available for the selected data table. For 
example, any transformations applied when adding the data table will 
be visible here. When data tables have been added using information 
links, the Keywords and Description defined in Information Designer 
will also be displayed. 
If you have defined custom properties for the data table, then these 
properties are also listed here. 

New... Opens a dialog where you can add new data table properties to the 
document. 

Edit... Opens a dialog where you can edit the selected data table property. 

Delete Deletes the selected property. 

2.9.6 Details on Data Table Properties - Sharing Routines 
When you publish analyses to the TIBCO Spotfire Library, many persons may access the same 
analysis file simultaneously and, hence, access the same data source by using TIBCO Spotfire 
Web Player. If desired, the loaded data can be shared between concurrent users from the TIBCO 
Spotfire Web Player server cache. Sharing data reduces the need for the server to reload the 
same data and can improve the performance of the server. Since TIBCO Spotfire cannot know 
when the original data sources have been updated and need to be reloaded, the settings on the 
Sharing Routines tab allows you to specify an update schedule that can match the actual times 
when your databases or network files are updated. 

► To reach the Data Table Properties dialog: 
1. Select Edit > Data Table Properties. 
2. Click on the Sharing Routines tab. 
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Option Description 

Data tables Lists the data tables available within the document. The names of the 
data tables in this list are the names that will be shown in the data table 
selectors, in the legends of visualizations, etc. 
You cannot have two data tables with identical names in the same 
analysis. 

Rename... Allows you to change the display name of the selected data table. 

Refresh Data Reloads the data from the source. This is a way to refresh the data 
while analyzing, without having to reload the entire file. 
Tip: If you want to reload multiple data tables simultaneously, you can 
instead select File > Reload Data on the main menu. 
Note: If a data table is loaded on demand or calculated using a data 
function you need to click OK in the Data Table Properties dialog to 
actually start the data refresh. 

Delete Removes the data table from the analysis. Any visualizations that use 
the deleted data table will become invalid. 

Set as Default Sets the selected data table to be the default data table. This means that 
the selected data table will be used when new visualizations are 
created. 
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You can always change the data table to use in a specific visualization 
from the Data page in Visualization Properties or from the Data table 
selector in the legend. 

Share data 
between 
concurrent users 
of TIBCO Spotfire 
Web Player 

  

   No, always load 
new data 

Use this option to always load new data. Note that this can put a very 
high load on the server, if many end users are accessing files from the 
Library simultaneously. 

   Yes, but refresh 
data if older than 
X full hours 

Use this option to share data and only refresh if the data are older than 
the specified number of hours. 
When someone accesses linked data for a certain data table, the update 
schedule is checked and the data pool is investigated to see if any data 
with the same timestamp are available. For example, if the time is 
09.35 am when the person accesses the analysis file and the update 
schedule has been set to refresh data every hour, then the timestamp 
will be set to 09.00. If any other person has loaded the data between 
09.00 and 09.35, then there will be cached data available which will be 
shared with the new person. If not, then new data are loaded. 

   Yes, but refresh 
data every [day or 
day of the week] at 
[time] 

Use this option to share data and only refresh once every day or on a 
specified day every week, at the specified time. 
See above for information about how data are loaded. 

   Yes, always 
share when 
possible 

Use this option to always attempt to share data. 
In this case, the data are presumed never to be changed. 

Note: This tab is only relevant if a Web Player server has been installed. 

2.9.7 Details 

2.9.7.1 Details on Select Key Columns 
This dialog is used to define key columns for a data table in an analysis. The key columns are 
used to uniquely identify all rows in the data table. You should specify key columns if you want 
to be able to see the markings that were active when saving the file, or if you want any specified 
tags or bookmarks to be able to be reapplied when reopening the analysis file.  

► To reach the Select Key Columns dialog: 
1. Select Edit > Data Table Properties. 

Comment: You can also reach the Data Table Properties dialog from the third step of 
the Save as Library Item wizard by clicking on the Edit... button. 

2. On the General tab, click to select the data table of interest. 
3. Click on the Edit... button next to the Key columns for linked data field. 
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Option Description 

Limit available 
columns to 

From this drop-down list you can limit the available columns to choose 
from. Options are: 
Columns with unique values for all rows (Recommended) 
Since these columns have unique values for all rows, it is likely that 
they are good choices for determining a unique identifier for each 
tagged row. 
Columns of appropriate data types 
This option only shows columns with INTEGER or STRING data 
types, since these are more likely to provide unique identifiers. 
All columns 
This option shows all columns. 

Available columns Select which columns to use when identifying keys for the tagged or 
marked rows. 
Each tagged or marked row must be determined by a unique 
combination of values in the specified columns. For each row with a 
tag or a marking in your current analysis, the values for the specified 
columns are noted in the saved analysis file, and when the analysis file 
is opened again rows matching those criteria will be tagged or marked 
again. 
This means that if a new row has been added to the data table that also 
matches a criterion for a tag or a marking, the tag or marking is not 
unique and therefore invalid. Neither the new row nor the original row 
that was tagged, will receive any tag. 

Selected columns These are the columns that will be used when identifying keys for the 
tagged rows. 

Add > Select a column from the Available columns list and click Add > to 
move it to the Selected columns list. 

< Remove Select a column from the Selected columns list and click < Remove to 
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move it to the Available columns list. 

Remove All Removes all columns from the Selected columns list. 

2.9.7.2 Details on Load Method 
This dialog is reached by clicking on the Settings... button in the Data Table Properties dialog 
for a data table that originates from an information link which has been specified to load data on 
demand. 

 

Option Description 

All data at once Click this radio button to load all data immediately. 

Data on demand Click this radio button to load data on demand only. If this option is 
selected you need to specify what parameters will be used to control 
the on-demand loading. 

Define input for 
parameters that 
should control 
loading 

This is where you select what will affect the loading of data from the 
perspective of the information link. All columns and parameters 
available in the selected information link are listed. Click to select the 
parameter in the list and click Define Input... to specify a condition 
that must be fulfilled for any data to be loaded. 
Any required prompts or parameters that were specified upon the 
creation of the information link will be listed as Required parameters 
in this field. This means that you must specify input handling of these 
parameters to be able to load any on-demand data at all. 

Define Input... Opens the Define Input dialog where you can specify how the selected 
parameter will be connected to the on-demand data. 

Clear Input Removes the previously added input from the selected parameter. 
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Load 
automatically 

Select this check box if the on-demand data should be loaded 
automatically each time the specified input conditions are changed. If 
the check box is cleared the visualization can be manually updated 
using the refresh icon, , in the visualization title bar. 
A data table set to load automatically will switch to manual update if 
cyclic dependencies are detected in the analysis. 

Allow caching Select this check box to allow caching of data. This may speed up the 
process when loading new subsets of data. However, if the underlying 
information link data are updated during the current TIBCO Spotfire 
session you may end up with different results for a specific set of input 
values depending on whether or not the current selection is stored in 
the cache. You should always clear the check box if you know that the 
underlying data may be updated during your current session. 

 

2.9.7.3 Details on Manage Relations 
This dialog is used to manage relations between both new and previously added data tables in 
your analysis. 

► To reach the Manage Relations dialog: 
1. Select Edit > Data Table Properties. 
2. Go to the Relations tab. 
3. Click on Manage Relations.... 
4. Comment: You can also reach the Manage Relations dialog from the Data page of the 

Map Chart Visualization Properties, or from the Add Data Tables or the Add On-
Demand Data Table dialogs. 

 

Option Description 

Show relations for Select the data table whose relations you wish to view, or select All 
data tables to view all relations in the document. 

Relations Lists all relations for the selected data table or all relations in the 
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document, depending on your selection above. 
Note: If one or more relations have become invalid, these will appear 
in red. 

New... Opens the New Relation dialog where you can define a new relation 
between two data tables. 

Edit... Opens the Edit Relation dialog where you can edit the relation selected 
in the Relations list. 

Delete Removes the selected relation from the Relations list. 

2.9.7.4 Details on New/Edit Data Table Property 
It is possible to add data table properties to the data tables in the analysis. These can be used as 
parts of an expression and can help you classify different types of data tables. 

► To reach the New Property dialog: 
1. Select Edit > Data Table Properties. 

Comment: The New Property dialog is also available by right-clicking in the Available 
properties list in the Insert Calculated Column and Custom Expression dialogs, as well 
as from the dialogs used when adding property controls to a text area. 

2. Click on the Properties tab. 
3. Click New.... 

 

Option Description 

Property name Specifies the name of the data table property. 

Data type Specifies the data type of the property. 

Description Optional. A description of the intended use of the property. 

Default value Shows the default value of the property. Data table and Column 
properties have default values. If the value is cleared (set to empty) for 
a specific data table then that data table property will automatically 
revert to use the default value. 
To change the value for a specific data table, click to select it in the list 
and then click Edit.... 
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► To reach the Edit Property dialog: 
1. Select Edit > Data Table Properties. 

Comment: The Edit Property dialog is also available by right-clicking in the Available 
properties list in the Insert Calculated Column and Custom Expression dialogs, as well 
as from the dialogs used when adding property controls to a text area. 

2. Click on the Properties tab. 
3. Click to select the property you wish to edit in the list of available properties. 
4. Click Edit.... 

 

Option Description 

Property name Specifies the name of the data table property. 

Data type Specifies the data type of the property. 

Description Optional. A description of the intended use of the property. 

Default value Displays the default value of the property. 
Note: If you change the default value, it will be set as the default value 
for both new data tables and already created data tables. 

Edit... Opens the Edit Value dialog where the default value and description 
can be specified. 

Value Shows the value of the property. 
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3 Adding Data 
3.1 Insert Calculated Column 
3.1.1 What is a Calculated Column? 

Occasionally, the columns included in a data table do not allow you to perform all necessary 
operations, or to create the visualizations needed to fully explore the data table. However, in 
many cases the necessary information can be computed from existing columns by using the 
mathematical and logical expressions provided by the Insert Calculated Column tool. 
Note: A calculated column is treated like any other column and its contents are static during all 
further analysis. If you want to use expressions that change during filtering of your data table, 
you should instead use custom expressions that are defined where you need them (for example, 
select Custom Expression... from the right-click menu on the axis selector). 

3.1.2 How to Insert a Calculated Column 
TIBCO Spotfire supports two different types of expressions: Insert Calculated Column, which 
creates a new column in the data table, and Custom Expression, which is used to dynamically 
modify the expression used on an axis or to define a setting. Both types of expressions are 
created with a similar user interface. 

► To insert a calculated column in the data table: 
Select Insert > Calculated Column.... 

1. If you have more than one data table in the document, select the Data table to work 
on. 

2. Specify a suitable expression by either typing it directly into the Expression text field, 
or by selecting columns, properties and functions from the list. 
An example of an expression could be: [Exports m$]/[Population]. 
Comment: You can always modify the expression by editing the text in the Expression 
field, using cut-and-paste, or by typing text. For a detailed description of the 
expression language, see General Syntax and other topics under Expression Language. 
For details on the syntax to use when adding properties, see Properties in Expressions. 

3. Verify that the result seems reasonable by looking at the Sample result field. 
Comment: If an error message is shown, there is a problem with the expression. Go 
back and modify the expression until the desired result is achieved. 

4. If desired, you can change the Formatting of the new column. 
5. Type a Column name for the new column. 
6. Click OK. 

Response: The expression is now evaluated for each row in the data table and a new 
column is created. A filter will appear with the name of the new column you created. 

Tip: If you have previously created a suitable expression, you may select it from the Recent 
expressions list and click the Insert button. 

► To reach the Custom Expression dialog: 
1. Right-click on a column selector on an axis, in a Visualization Properties dialog, or in 

the Legend, to display the menu. 
2. Select Custom Expression.... 

Comment: See How to Insert a Custom Expression for more information. 
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3.1.3 Details on Insert Calculated Column 
TIBCO Spotfire supports two different types of expressions: Insert Calculated Column, which 
creates a new column in the data table, and Custom Expression, which is used to dynamically 
modify the expression used on an axis or to define a setting. Both types of expressions are 
created with a similar user interface. 

► To reach the Insert Calculated Column dialog: 
Select Insert > Calculated Column.... 
  

 

Option Description 

Data table Only available when more than one data table is present in the 
analysis and the dialog has been opened via the main menu. 
Specifies the data table where the calculated column will be 
inserted. 

Available columns Shows all columns that you can use in the calculation of a new 
column. 
Select a column by clicking on it in the list and then click on the 
Insert Columns button, or double-click on the column to send it to 
the Expression field. Press Ctrl or Shift to select multiple columns. 
You can narrow down the list of available columns by typing a part 
of a name in the "Type to search" field. You can also enter an 
expression in the field using the rules described on the Searching in 
TIBCO Spotfire page. 

Insert Columns Inserts the columns selected in the Available columns list at the 
current cursor position in the Expression field. 

Available properties 
for column 

Shows all properties that you can use in the calculation of a new 
column. You can narrow down the list of available properties by 
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using the search field. The column properties shown are specific to 
the column selected in the Available columns list to the left. 
Select a property by clicking on it in the list and then click on the 
Insert Properties button; or double-click on the property to send it to 
the Expression field. The property will automatically be inserted as 
text. However, there may be occasions where you need to insert the 
property as a function to receive the desired result. See Properties in 
Expressions for more information. Use the pop-up menu in this field 
to select how to insert the property or type the correct syntax 
manually. 
If you want to define a new property to use in the expression, right-
click in the Available properties field and select New > [Property 
Type] Property... from the pop-up menu. You can also edit or 
delete custom properties by using the pop-up menu. 

Insert Properties Inserts the properties selected in the Available properties for column 
list at the current cursor position in the Expression field. 

Category Select a category of functions to limit the choices in the Function 
list: 
All functions 
Binning functions 
Conversion functions 
Date and Time functions 
Logical functions 
Math functions 
Operators 
Property functions 
Ranking functions 
Spatial functions 
Statistical functions 
Text functions 

Function Select a function by clicking on it in the list and then click on the 
Insert Function button, or double-click on the function to send it to 
the Expression field. 
Type a search string in the text field to limit the number of items in 
the Functions list. 
You can also click on any function and type the first letter of the 
desired function name to jump to a specific location in the list. 

Description Shows a brief description of the selected function. For more detailed 
descriptions, see the Expression Language chapter. 

Insert Function Inserts the selected function at the current cursor position in the 
Expression field. 

Expression This is the text field in which you build your expression. You can 
insert columns and functions from the lists, or enter text as in any 
standard text editor. 
Cut/Copy/Paste works in the field using standard 
Ctrl+X/Ctrl+C/Ctrl+V. 
Also, it is possible to undo/redo the last action by pressing Ctrl+Z. 
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Recent expressions Displays the ten expressions you have most recently created. You 
can select one of these and click the Insert button to insert the 
expression into the Expression field. 

Insert Inserts the selected Recent expression into the Expression field. This 
will replace the entire content of the Expression field. 

Resulting expression Of interest when preprocessor functions (such as ${PropertyName}) 
are used in the expression only. Displays the expression after all 
occurrences of the property have been replaced with its current value 
or values. 

Column name The name of the new calculated column. 

Sample result Displays the result of applying the current expression to the first row 
of the data table. Note that if aggregating functions (such as, 
"Count") are used in the expression, only the first 100 rows will be 
used in the sample calculation. 
If this field shows an error there is a problem with the expression. 
Moving the mouse pointer over the red exclamation mark next to the 
Expression field will display an explanation of what is wrong. 

Type The type of the new calculated column. 

Formatting... Opens the Formatting dialog, where you can change the formatting 
of the new calculated column. 

3.1.4 Expression Language 

3.1.4.1 General Syntax 

Column references 
Accessing columns is done by enclosing the column name in "[" and "]" characters (square 
brackets). The brackets are needed when the column name contains characters other than letters, 
digits or _ (underscore). They are also required when the column name is the same as a function 
name, or when the column name begins with a digit. If a column name contains any square 
brackets then they must be escaped. Escaping of brackets is performed by adding extra brackets 
before and after the bracket: "[" and "]]". For example, if the column name is [Name], it would 
be written as [[Name]]] in an expression. 
If the column name has no special character or whitespace, or is not also a function name, it can 
be entered without brackets. 
Examples:   
Column1 
[Column1] 
[Binned Column1] 
[1] 
[!@#$%^&*()[\]]\\] 
Constants are converted to columns, so even if a method says that the argument has to be a 
column, it is acceptable to use a constant. 

Case sensitivity 
• Variables, functions and keywords are case insensitive: SUM(C1) = Sum(C1) = 

sum(C1) 
• Column name references are case sensitive. 
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• Method call names are case insensitive. All methods which are defined in the add-in 
framework can be used. See later sections for information about the different methods 
supported. 

Expression results 
An expression describes how a new column should be calculated. The newly created column 
will have the same number of rows as all the other columns in the data table. The default null 
handling behavior is that operations on null return null. This means that if a new column is 
calculated as [Column A]*2 and there are empty values on some rows in Column A, then the 
new column will have empty values on those rows as well. 
Multiple columns are normally separated with a comma. If multiple expressions are used the AS 
keyword can be used to rename the expressions in the custom expression dialog. See examples 
below. 

Categorical expressions, NEST and CROSS 
In custom expressions, categorical and hierarchical columns and expressions are written 
between angles, "<>". When more than one category is available within the expression, which 
combinations of categories to show must also be specified. This is done using the keywords 
NEST (which shows all actual combinations of values in the data) or CROSS (which will show 
all possible combinations of the values, including combinations that currently hold no data). All 
columns in the expression must be separated by "nest" or "cross" instead of a comma, and 
mixing the two combination options is not permitted. 
For example, if we have a data table containing some sales data for each month during two 
years, but the data for February is missing for one year, the different options will give the 
following results: 
Nest: 

 
Since there are no data available for February 2001, there will not be a bar (nor a placeholder 
for a bar) there. This visualization is set up using the All values in data (nest) option in the 
Advanced Settings dialog, reached from the category axis property page for the visualization. It 
corresponds to the custom expression: <[Year] NEST [Month]> 
Cross: 
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When the CROSS option is selected, all possible combinations of the categories are displayed. 
This means that there will be a placeholder for the February column for 2001, even though there 
is no data available for February. The All possible values (cross) option has been selected in 
the Advanced Settings dialog and the corresponding custom expression would be: <CROSS 
[Year] CROSS [Month]> 
(The first CROSS is optional.) 

Examples of expressions: 
[Column1] 
[Column1], [Column2] 
[Column1] AS [My first column], [Column2] AS [My second column] 
<[Category column 1]> 
<[Category column 1] nest [Category column 2]> 
<[Category column 1] cross [Category column 2] cross [Category column 3]> 
123.23 
39+12*3 
-(1-2) 
cast (power(2,2) as integer) 
null 
case Column1 when 10 then 'ten' else 'not ten' end 
case when 1 < 3 or 3 < 2 then 10 else 32 end 
case when Column1 is not error then Column1 else Column2 end 

3.1.4.2 Operators 

3.1.4.2.1 Data Types 
The available data types are: 

• Integer 
• LongInteger 
• Real 
• SingleReal 
• Currency 
• Date 



TIBCO Spotfire 4.0.2 - User's Manual 

108 

• DateTime 
• Time 
• TimeSpan 
• Boolean 
• String 
• Binary 

All data formats except Currency (Decimal) use a binary floating-point number representation 
of the values. This means that some calculations which should result in an even number may be 
displayed as a number which needs to be rounded off, due to the nature of the base-two 
calculation. When more calculations are performed after one another, errors can accumulate and 
may become a problem. 

Data Type Description 
Integer Integer values are written as a sequence of digits, possibly prefixed by a + 

or - sign. The integer values that can be specified range from -2147483648 
to 2147483647. If used where a decimal value was expected, the integer 
values are automatically converted to decimal values. 
Note: Hexadecimal values can be used in custom expressions and in 
calculated columns. They cannot be used when opening data. Hexadecimal-
formatted values have a size limitation of 8 characters. 
Examples:   
0 
101 
-32768 
+55 
0xff            = 255 
0x7fffffff            = 2147483647 
0x80000000       = -2147483648 

LongInteger LongInteger can be used if the range for the standard Integer is not enough 
for your needs. It ranges from -9223372036854775808 
to 9223372036854775807. LongInteger cannot be converted to Real 
without precision loss, but it can be converted to Currency without precision 
loss. 
Note: Hexadecimal values can be used in custom expressions and in 
calculated columns. They cannot be used when opening data. 
Examples: 
2147483648 
0x7FFFFFFFFFFFFFFF = -9223372036854775808 
0x8000000000000000 = 9223372036854775807 

Real Real values are written as standard floating point numbers with a period for 
a decimal point and no thousands separator. The real values that can be 
specified range from -8.98846567431157E+307 to 
8.98846567431157E+307. 
The number of significant digits that can be shown is limited to 15, even 
though 16 can be used in calculations. 
Math operations on real values which produce results that cannot be 
represented by the real data type generate numeric errors. In the resulting 
data table, these special cases will be filtered out and replaced by null. 
Examples:   
0.0 
0.1 
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10000.0 
-1.23e-22 
+1.23e+22 
1E6 

SingleReal SingleReal values are written as standard floating point numbers with lower 
precision and range than Real. SingleReal occupies 50% less memory than 
Real. The SingleReal values that can be specified range from -
1.7014117E+38 to 1.7014117E+38. 
The number of significant digits that can be shown is limited to 7, even 
though 8 can be used in calculations. 
SingleReal can be converted to Real with minor precision loss. 

Currency Currency constants are written as integer or real constants with an 'm' suffix. 
The data format behind the currency type is decimal. The decimal data 
format uses the base 10 in its calculations, which means that the round-off 
errors that may occur when doing binary calculations can be avoided with 
this format. However, this also means that heavy calculations take a longer 
time. 
The number of significant digits that can be shown for a currency value is 
28 (29 can be used in calculations). Currency values that can be specified 
range from -39614081257132168796771975168 to 
39614081257132168796771975168. 
Currency columns cannot be used in data functions. 

Date A date and time format depending on the locale on your computer. Dates 
from January 1, 1583 and forward are supported. 
Examples: 
6/12/2006 
June 12 
June, 2006 
Note that the Date format is not directly supported by Spotfire Statistics 
Services. See also How to Use Data Functions. 

DateTime A date and time format depending on the locale on your computer. Dates 
from January 1, 1583 and forward are supported. 
Examples: 
6/12/2006 
Monday, June 12, 2006 1:05 PM 
6/12/2006 10:14:35 AM 

Time A date and time format depending on the locale on your computer. 
Examples: 
2006-06-12 10:14:35 
10:14 
10:14:35 
Note that the Time format is not directly supported by Spotfire Statistics 
Services. See also How to Use Data Functions. 

TimeSpan TimeSpan is a value describing the difference between two dates. 
It has 5 possible fields: 
Days 
1. Min: -10675199 
2. Max: 10675199 
Hours 
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1. Min: 0 
2. Max: 23 
Minutes 
1. Min: 0 
2. Max: 59 
Seconds 
1. Min: 0 
2. Max: 59 
Fractions (decimals of seconds) 
1. Up to three decimals, i.e., the precision is 1 ms. 
TimeSpan values can be displayed on a compact form: [-]d.h:m:s.f ([-
]days.hours:minutes:seconds.fractions) or written out with words or 
abbreviations for each available field. Some of the descriptive forms can be 
localized. 
Total min: -10675199.02:48:05.477 
Total max: 10675199.02:48:05.477 

Boolean True and false. Booleans are used to represent true and false values returned 
by comparison operators and logical functions. 
The display values can be localized. 
Examples:   
true 
false 
1 < 5 

String String values are surrounded by double quotes or single quotes. Escaping is 
performed by entering the delimiter symbol twice in a row (i.e., '' or ""). A 
string value can contain any sequence of UNICODE characters. A double 
quote cannot be used within the string unless it is escaped. Backslash is 
used to escape special characters, so it too must be escaped. 
The basic escaping rules are that only the characters defined below can be 
used after a \; everything else will generate an error. 
Examples:   
"Hello world" 
"25""23" 
"1\n2\n" 
"C:\\TEMP\\image.png" 

Binary May contain any type of data, encoded in binary form. 
Examples: 
Images 
Chemical structure information 

  

Escape 
sequence 

Result 

\uHHHH Any Unicode character expressed as four hexadecimal characters, 0-
F. 

\DDD A character in the range 0-255 expressed as three octal digits, 0-7. 

\b \u0008: backspace (BS) 

\t \u0009: horizontal tab (HT) 
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\n \u000a: linefeed (LF) 

\f \u000c: form feed (FF) 

\r \u000d: carriage return (CR) 

\\ \u005c: backslash \ 

Conversion to other data types 
The data types supported in expressions are the same types as are supported in the data model. 
Converting a value from one data type to another is called casting. 
Implicit casting to real is performed when integer columns are used in calculations and the 
result is a non-integer. If the result is an integer but larger than the limit for the Integer data 
type, it will be implicitly cast to a LongInteger. Integers can also be implicitly cast to a 
Currency. For example, if an Integer and a Currency column are added, then the result will be a 
Currency column. 
You may also end up with a Currency when the result from a LongInteger exceeds the 
LongInteger limit. This is because a LongInteger cannot be cast to Real without the risk of 
losing precision. All operations using TimeSpan (except a simple TimeSpan casting) will return 
a DateTime. For any other conversions, you need to use the Conversion Functions to calculate 
new columns or use in custom expressions. Binary objects cannot be cast to any other data 
types. 
Conversion of the data types for several columns simultaneously can be done using the Change 
Data Types transformation tool. Transformations can be done on existing data tables via the 
Add Data Tables dialog or the Replace Data Table dialog. 

 

3.1.4.2.2 Operators 

Operator Description 
 - Arg1 Negates the argument. The argument and the result are of type real. 

Arg1 + Arg2 Adds the two arguments. See operator & for string concatenation. 

Arg1 – Arg2 Subtracts Arg2 from Arg1. 

Arg1 * Arg2 Multiplies the two arguments. The arguments and the result are of type 
real or decimal. 

Arg1 / Arg2 Divides Arg1 by Arg2. The arguments and the result are of type real or 
decimal. Division by zero results in an error. 
  
Examples:   
7/2   -> 3.5 
0/0   -> #NA 
-1/0  -> #NA 

Arg1 & Arg2 Appends Arg2 to the end of Arg1. The arguments can be of any type, 
but are converted to strings. The result is of type string. See also 
function Concatenate. 
  
Examples: 
"April " & (20+1) & "st"    -> "April 21st" 
null & "Ape"                      -> #Error 

Arg1 % Arg2 Returns the remainder of the division of Arg1 by Arg2. The arguments 
and the result are of type real or decimal. Null and error are propagated 
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to the result column. 
  
Example: 
3.5 % 2.5 -> 1.00 

Arg1^Arg2 Returns Arg1 raised to the Arg2 power. 
  
Example: 
2.5^3 
[Value Column]^2 

Arg1 < Arg2 Operator which can be a part of an IF or a CASE statement. Returns 
true if Arg1 is less than Arg2. The arguments can be of any type, but 
must both be of the same type. The result is of type boolean. If any 
argument is null, the result is null. The function is defined for 
comparing normal numbers to each other. Other combinations result in 
errors or null. 
  
Examples: 
If( 1 < 2, "true", "false" )         -> true 
Case when 2 < 1 then "true" else "false" end  -> false 
If(1<null, "true", "false")         -> (Empty) 
If(1 < 1/0, "true", "false")        -> #NA 
If(1/0 < 1/0, "true", "false")    -> #NA 
If(-1/0 < 1/0, "true", "false")   -> #NA 
If(1< 0/0, "true", "false")         -> #NA 

Arg1 > Arg2 Operator which can be a part of an IF or a CASE statement. Returns 
true if Arg1 is greater than Arg2. The arguments are of type real and the 
result is of type boolean. See operator < for the definition of valid 
arguments. 

Arg1 <= Arg2 Operator which can be a part of an IF or a CASE statement. Returns 
true if Arg1 is less than or equal to Arg2. The arguments are of type real 
and the result is of type boolean. See operator < for the definition of 
valid arguments. 

Arg1 >= Arg2 Operator which can be a part of an IF or a CASE statement. Returns 
true if Arg1 is greater than or equal to Arg2. The arguments are of type 
real and the result is of type boolean. See operator < for the definition 
of valid arguments. 

Arg1 = Arg2 Operator which can be a part of an IF or a CASE statement. Returns 
true if Arg1 is equal to Arg2. The arguments can be of any type, but 
must both be of the same type. The result is of type boolean. If any 
argument is null, the result is null. For arguments of type real, see 
operator < for the definition of valid arguments. 
  
Examples: 
If(1 = 2, "true", "false" )                                            -> false 
Case when 2 = 2 then "true" else "false" end     -> true 
If("Hello" = "hello", "true", "false" )       -> false 
If("" = null, "true", "false" )                      -> (Empty) 
If(null = null, "true", "false" )                  -> (Empty) 

Arg1 <> Arg2 Operator which can be part of an 'IF' or a 'CASE' statement. Returns 
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true if Arg1 is not equal to Arg2. The arguments can be of any type, but 
must both be of the same type. The result is of type boolean. If any 
argument is null, the result is null. For arguments of type real, see 
operator < for the definition of valid arguments. 

Arg1 ~= Arg2 
  

Operator which can be part of an 'IF' or a 'CASE' statement. The 
arguments can be of any type, but will be treated as string columns. 
Returns true if the Arg2 regular expression string matches the Arg1 
string. 
  
Some characters, like for instance the backslash character "\", need to 
be escaped to work when using calculated columns. See literature about 
regular expression language elements, e.g., on MSDN, for more 
information. 
  
Examples: 
If( "aab" ~= "a+" , "true", "false" )           -> true 
Case when "aba" ~= ".a+$" then "true" else "false" end   -> true 

And(Arg1, ...) Operator which can be part of an 'If' or 'Case' statement. It has two 
boolean expressions as arguments and returns true if both expressions 
are true. 
  
Examples: 
If( 1 < 2 and 2 < 3, "true", "false" ) 
Case when false and true then "true" else "false" end 

Not(Arg1) Operator which can be part of an 'If' or 'Case' statement. It negates the 
boolean expression given as argument. 
  
Examples: 
If( not 1 < 2, "true", "false" ) 
Case when not true then "true" else "false" end 

Or(Arg1, ...) Operator which can be part of an 'If' or 'Case' statement. It has two 
boolean expressions as arguments and returns true if one of the 
expressions is true. 
  
Examples: 
If( 1 < 2 or 2 < 3, "true", "false" ) 
Case when false or true then "true" else "false" end 

3.1.4.2.3 Operator Precedence 
Below is a table showing the hierarchy of operators with the highest precedence operator shown 
first. 
Expressions inside parentheses are evaluated first; nested parentheses are evaluated from the 
innermost parentheses to the outer. 
Operators in the same row in the chart have equal precedence 

Operators Type Order of Evaluation 
( ) Parentheses left to right 

- + Unary minus and plus right to left 

http://msdn.microsoft.com/en-us/library/az24scfc(VS.71).aspx
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* / % Multiplicative left to right 

+ - Additive left to right 

& Concatenation left to right 

< > <= >= Relational left to right 

= <> Equality left to right 

3.1.4.3 Functions 

3.1.4.3.1 Functions Overview 
Select which types of Functions you are interested in: 
Binning functions 
Conversion functions 
Date and Time functions 
Logical functions 
Math functions 
OVER functions 
Property functions 
Ranking functions 
Spatial functions 
Statistical functions 
Text functions 
  

3.1.4.3.2 Binning Functions 

Function Description 

BinByDateTime Creates a binned column based on a natural date, datetime or time 
hierarchy. 
The first argument is the Date, Time or DateTime column to bin. 
The second argument is the definition of the levels in the 
hierarchy. The hierarchy levels should be written in the form of a 
string containing the desired date parts, separated by dots, for 
example "Year.Quarter.Month". The third argument is the 
pruning level which specifies the level of the hierarchy to display. 
If you write a custom expression based on a BinByDateTime 
expression you will see a column selector with all levels of the 
specified hierarchy available, but with the hierarchy slider handle 
positioned at the specified pruning level. 
  
Valid arguments for Arg2 are combinations of: 
'year' or 'yy' - The year. 
'quarter' or 'qq' - The quarter. 
'month' or 'mm' - The month. 
'day of year' or 'dy' - The day of year. 
'day' or 'dd' - The day. 
'week' or 'wk' - The week. 
'day of week' or 'dw' - The weekday. 
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'hour' or 'hh' - The hour. 
'minute' or 'mi' - The minute. 
'second' or 'ss' - The second. 
'millisecond' or 'ms' - The millisecond. 
  
Example: 
BinByDateTime([Column],"Year.Quarter.Month.Day",2) 
  
For a date column called Order Date, the expression above would 
result in the column selector and hierarchy slider shown below: 

 
Pruning level 0 would set the slider handle to the year position, 1 
would mean the quarter, 2 the month, and 3 the day. 

BinByEvenDistribution Creates a binned column where each bin has the same number of 
unique values as the others. The last bin may have more unique 
values than the others. The first argument is the column to bin 
and the second argument is the number of bins. Null values will 
have a null bin value and error values will have an error bin 
value. 
  
Example: 
BinByEvenDistribution([Column], 5) 
BinByEvenDistribution(Rank([Column])*Count() + RowId(), 3) 

BinByEvenIntervals Creates a binned column where the value range is divided into 
equal intervals. The first argument is the column to bin and the 
second argument is the number of bins. 
  
Example: 
BinByEvenIntervals([Column], 5) 

BinBySpecificLimits Creates a binned column with specific limits for the bins. The 
first argument is the column to bin and the following arguments 
are the limits for the bins. All rows which have values larger than 
the largest limit will have the same bin value. Null values will 
have a null bin value, error values will have an error bin value. 
  
Example: 
BinBySpecificLimits([Column], 1, 2, 3, 10) 

BinByStdDev Creates a binned column where the values are divided into bins 
depending on the values distance from the mean, measured in 
standard deviations. The first argument is the column to bin and 
the following arguments are the number of standard deviations to 
show from the mean. The standard deviation arguments should be 
given in ascending order and all values should be positive. 
  
Example: 
BinByStdDev([Column], 0.5, 1) 
This will create a binning for: 
<= -1 standard deviation 
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-1 standard deviation 
-0.5 standard deviation 
0.5 standard deviation 
1 standard deviation 
> 1 standard deviation 

BinBySubstring Creates a binned column based on beginning or end of value. The 
first argument is the string column to bin and the following is the 
number of characters in the substring. If the second argument is 
negative the substring starts from the end of the value. 
  
Examples: 
BinBySubstring([Column], -4) 
BinBySubstring(String([Integer Column]), 1) 

3.1.4.3.3 Conversion Functions 

Function Description 
Cast(Arg1 as type) Casts any expression to any type (except Null/Undefined). 

Null values and error values are propagated. Casting performed for 
different types of input and output types results in different outputs. 
See Cast Method for more information. 
  
Example: 
Cast([IntegerColumn] as Currency) 

Boolean(Arg1) Converts the column or value to a Boolean. 
  
Example: 
Boolean([Column]) 

Currency(Arg1) Converts the column or value to a Currency. 
  
Example: 
Currency([Column]) 

Date(Arg1, ..., Arg3) Converts the column or values to a Date. If a single argument is 
used, Arg1 can be of type String or DateTime. If a String is 
specified, the date must be written in a format that Spotfire can 
recognize. Additionally, all parts of the date (year, month and day) 
must be present. See examples below. If a DateTime is specified, the 
time part is removed. 
If three integer arguments are given, then the first argument is the 
year, the second is the month and the third is the day of the month. 
See also Date and Time functions. 
  
Examples: 
Date("2003-03-21")                        -> 3/21/2003 
Date("3/21/03")                               -> 3/21/2003 
Date("10")                                        -> (Empty) 
Date(null)                                         -> (Empty) 
Date("2003-03-21 11:37:00")       -> 3/21/2003 
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Date(2003,03, 21)                          -> 3/21/2003 
(The output formats available are dependent on your current locale.) 

DateTime(Arg1, 
Arg2,..., Arg7) 

Converts the column or values to a DateTime. If a single argument 
is used, Arg1 can be of type String or Date. If a String is specified, 
the date must be written in a format that Spotfire can recognize. 
Additionally, at least all parts of the date (year, month and day) must 
be present. If a Date is specified, the time part is set to 00:00:00 
(12:00:00 AM). 
If seven integer arguments are given, then the first argument is the 
year, the second is the month, the third is the day of the month, the 
fourth is the hour, the fifth is the minute, the sixth is the second and 
the seventh argument is the millisecond. 
See also Date and Time functions. 
  
Examples: 
DateTime("2003-03-21 11:37:00")    -> 3/21/2003 11:37:00 AM 
DateTime("10")                                      -> (Empty)   
DateTime(null)                                       -> (Empty) 
DateTime("2003-03-21")                      -> 2003-03-21 00:00:00 
DateTime(2003, 03, 21, 11, 37, 00)   -> 2003-03-21 11:37:00 
(The output formats available depend on your current locale.) 

Integer(Arg1) Converts the column or value to an integer number. If the 
conversion fails, an error is returned. Arg1 can be of type integer, 
real or string, and the result is of type integer. Real numbers are 
truncated, i.e., only the integer part is used. 
  
Examples: 
Integer("-123")       -> -123 
Integer(-2.99)        -> -2 
Integer("0%")         -> (Empty) 
Integer(1e20)        -> (Empty) 
Integer(null)           -> (Empty) 

LongInteger(Arg1) Converts the column or value to a LongInteger. 
  
Example: 
LongInteger([Column]) 

Real(Arg1) Converts the column or value to a real number. If the conversion 
fails, an error is returned. Arg1 can be of type integer, real or string, 
and the result is of type real. 
  
Examples: 
Real(1.23)      -> 1.23 
Real(2)            -> 2 
Real("0%")      -> (Empty) 
Real(null)        -> (Empty) 

SE(Arg1, Arg2) Substitutes errors. Returns Arg1 if it is not an error, Arg2 otherwise. 
Arg1 and Arg2 can be of any type, but both must be of the same type 
or null. The result is of the same type as the arguments. 
  
A common usage is to substitute errors in a column. If Arg1 is a 
column, Arg2 can be either a value of the same type as the contents 
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of the column or a column with the same content type. If Arg2 is 
also a column, the error in Arg1 will be replaced with the value from 
the same row in Arg2. 
  
Examples: 
SE(1, 2)          -> 1 
SE(null, 2)      -> (Empty) 
SE(0/0, 2)       -> 2 
SE([Column], 1) -> 1 (if error in column) 
SE([Column1], [Column2]) -> (value from Column2 if error in 
Column1) 

SingleReal(Arg1) Converts the column or value to a SingleReal. 
  
Example: 
SingleReal([Column]) 

SN(Arg1, Arg2) Substitutes null values. Returns Arg1 if it is not null, Arg2 
otherwise. Arg1 and Arg2 can be of any type, but both must be of 
the same type or null. The result is of the same type as the 
arguments. 
  
A common usage is to substitute null values in a column. If Arg1 is 
a column, Arg2 can be either a value of the same type as the 
contents of the column or a column with the same content type. If 
Arg2 is also a column, the error in Arg1 will be replaced with the 
value from the same row in Arg2. 
  
Examples: 
SN(1, 2)        -> 1 
SN(null, 2)    -> 2 
SN(0/0, 2)     -> #NA 
SN([Column], 1) -> 1 (if null value in column) 
SN([Column1], [Column2]) -> (value from Column2 if null value in 
Column1) 

String(Arg1) Converts the column or value to a string. This conversion never fails 
except if Arg1 is null. Arg1 can be of any type and the result is of 
type string. 
  
Examples: 
String(1.23)     -> "1.23" 
String(null)      -> (Empty) 

Time(Arg1, Arg2,..., 
Arg4) 

Converts the column or values to a time. If the conversion fails, an 
error is returned. If a single argument is used, Arg1 can be of type 
String or DateTime.  If a String is specified, the time must be written 
in a format that Spotfire can recognize. Additionally, both the hour 
and the minute must be specified. See examples below. If a 
DateTime is specified, the date part is removed. 
If four integer arguments are given, then the first argument is the 
hour, the second is the minute, the third is the second and the fourth 
is the millisecond. 
See also Date and Time functions. 
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Examples: 
Time("11:37:00")                         -> 11:37:00 
Time("10")                                    -> (Empty) 
Time (null)                                    -> (Empty) 
Time(11, 30, 20, 4)                       ->11:30:20 
(The output formats available depend on your current locale.) 

TimeSpan(Arg1, 
Arg2,...Arg5)) 

Creates a TimeSpan from a column or values. If a single argument is 
given, the input column can be of type String or TimeSpan. If a 
String is specified, TimeSpan must be written in the format "[-
]d.h:m:s.ms". 
If five arguments are given, then the first argument is the days, the 
second is the hours, the third is the minutes, the fourth is the seconds 
and the fifth is the milliseconds. The first four arguments are 
integers, the last is a real number. 
  
Examples: 
TimeSpan([Column]) 
TimeSpan("247.5:17:11.5002") 
TimeSpan(247, 05, 17, 11, 500.2) 

3.1.4.3.4 Cast Method 
This is an overview of what will happen when a column is cast from one data type to another. 

Input Output 

  Integer Real Decimal Date/DateTime/Time String Binary 

Integer Same 
value. 

 Value 
cast to 
real. 

Value 
converted 
to decimal 
if it fits in 
the limit. 
Null 
otherwise. 

Date* value is created using 
the integer value as ticks. 

Formatted 
using 
input 
formatter. 

Null. 

Real Integer 
part of 
real value 
is it fits in 
the limit. 
Null 
otherwise. 

 Same 
value. 

Value 
converted 
to decimal 
if it fits in 
the limit. 
Null 
otherwise. 

Date* value is created using 
the integer part of the value 
as ticks. 

Formatted 
using 
input 
formatter. 

Null. 

Decimal Integer 
part of 
decimal 
value is it 
fits in the 
limit. 
Null 
otherwise. 

Decimal 
value 
rounded 
to Real if 
it fits, null 
otherwise. 

Same 
value. 

Date* value is created using 
the integer part of the value 
as ticks. 

Formatted 
using 
input 
formatter. 

Null. 

Date/DateTime/Time Number 
of ticks if 

Number 
of ticks 

Number of 
ticks 

Same value. Formatted 
using 

Null. 
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it fits in 
the limit. 
Null 
otherwise. 

converted 
to real. 

converted 
decimal if 
it fins in 
the limit. 
Null 
otherwise. 

input 
formatter. 

String Try to 
parse 
using 
output 
formatter. 
Null if it 
failed to 
parse. 

Try to 
parse 
using 
output 
formatter. 
Null if it 
failed to 
parse. 

Try to 
parse using 
output 
formatter. 
Null if it 
failed to 
parse. 

Try to parse using output 
formatter. Null if it failed to 
parse. 

Same 
value. 

Null. 

Binary Null. Null.  Null. Null. Null. Same 
value. 

* Date, DateTime or Time. 

3.1.4.3.5 Date and Time Functions 

Function Description 
DateAdd(Arg1, Arg2, 
(Arg3)) 

Adds an interval to a Date, Time or a DateTime. The method can 
add either a TimeSpan or an integer representing a specified date 
or time part (e.g., a number of days). 
  
If a TimeSpan is to be added, two arguments are needed: a 
DateTime column and a TimeSpan column. 
  
If an integer value is to be added to a date or time part, three 
arguments are used: Arg1 is a string describing which part to add. 
Arg2 is a number which contains the number of parts to add. Arg3 
is the Date, Time or DateTime column. 
  
Valid arguments for Arg1 are: 
'year' or 'yy' - The year. 
'quarter' or 'qq' - The quarter. 
'month' or 'mm' - The month. 
'day' or 'dd' - The day. 
'week' or 'wk' - The week. 
'hour' or 'hh' - The hour. 
'minute' or 'mi' - The minute. 
'second' or 'ss' - The second. 
'millisecond' or 'ms' - The millisecond. 
  
Examples: 
DateAdd([Date Column], [TimeSpan Column]) 
DateAdd('year', 2, [Date Column]) 
DateAdd('month', 1, [Date Column]) 
 



Adding Data 

121 

DateDiff(Arg1, Arg2, 
(Arg3)) 

Calculates the difference between two Date, Time or DateTime 
columns. The result is presented either as a TimeSpan or as a real 
value representing a specified time part (e.g., number of days). 
  
If two arguments are used (a start date column and a stop date 
column) the result will be a TimeSpan value displaying the total 
difference. 
  
If three arguments are used, the first argument should be the part 
to compare. The second argument is the start date column and the 
third argument is the stop date column. The result of the operation 
is a real value. 
  
Valid arguments for Arg1 are: 
'year' or 'yy' - The year. 
'quarter' or 'qq' - The quarter. 
'month' or 'mm' - The month. 
'day' or 'dd' - The day. 
'week' or 'wk' - The week. 
'hour' or 'hh' - The hour. 
'minute' or 'mi' - The minute. 
'second' or 'ss' - The second. 
'millisecond' or 'ms' - The millisecond. 
  
Example: 
DateDiff([Order Date], [Delivery Date]) 
DateDiff('day', [Order Date], [Delivery Date]) 
 

DatePart(Arg1, Arg2) Returns a specified part of a Date, Time or DateTime. Arg1 is a 
string describing which part of the date to get and Arg2 is the 
Date, Time or DateTime column. 
  
Valid arguments for Arg1 are: 
'year' or 'yy' - The year. 
'quarter' or 'qq' - The quarter. 
'month' or 'mm' - The month. 
'day of year' or 'dy' - The day of year. 
'day' or 'dd' - The day. 
'year and week' or 'yywk' - The year and week. 
'week' or 'wk'  - The week. 
'day of week' or 'dw' - The weekday. 
'hour' or 'hh' - The hour. 
'minute' or 'mi' - The minute. 
'second' or 'ss' - The second. 
'millisecond' or 'ms' - The millisecond. 
  
Example: 
DatePart('year', [Date Column]) 
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DateTimeNow() Returns the current system time. 
  
Example: 
DateTimeNow() 

Day(Arg1) Extracts the day of month from a Date or DateTime column. The 
result is an integer between 1 and 31. 
  
Example: 
Day([Date Column])       

DayOfMonth(Arg1) Extracts the day of month from a Date or DateTime column. The 
result is an integer between 1 and 31. 
  
Example: 
DayOfMonth([Date Column])       

DayOfWeek(Arg1) Extracts the day of week from a Date or DateTime column. The 
underlying data of the new column is an integer between 0 and 6, 
but regional settings determine the start of week as well as the 
formatted output. 
  
Example: 
DayOfWeek([Date Column]) 

DayOfYear(Arg1) Extracts the day of year for a Date or DateTime column. Returns 
an integer between 1 and 366. 
  
Example: 
DayOfYear([Date Column]) 

Days(Arg1) Returns the number of days for a TimeSpan as an integer between 
-10675199 and 10675199. 
  
Example: 
Days([TimeSpan Column]) 

Hour(Arg1) Extracts the hour from a DateTime or Time column. Returns an 
integer between 0 and 23. 
  
Example: 
Hour([Time Column]) 

Hours(Arg1) Returns the number of hours for a TimeSpan as an integer 
between 0 and 23. 
  
Example: 
Hours([TimeSpan Column]) 

Millisecond(Arg1) Extracts the millisecond from a DateTime or Time column. 
Returns an integer between 0 and 999. 
  
Example: 
Millisecond([Time Column]) 
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Milliseconds(Arg1) Returns the number of milliseconds for a TimeSpan as a real 
value between 0.0 and 999.0. 

Minute(Arg1) Extracts the minute from a DateTime or Time column. Returns an 
integer between 0 and 59. 
  
Example: 
Minute([Time Column]) 

Minutes(Arg1) Returns the number of minutes for a TimeSpan as an integer 
between 0 and 59. 
  
Example: 
Minutes([TimeSpan Column]) 

Month(Arg1) Extracts the month from a Date or DateTime column. The 
underlying data of the new column is an integer between 1 and 12, 
but regional settings determine the formatted output. 
  
Example: 
Month([Date Column]) 

Quarter(Arg1) Extracts the quarter from a Date or DateTime column. The 
underlying data of the new column is an integer between 1 and 4, 
but regional settings determine the formatted output. 
  
Example: 
Quarter([Date Column]) 

Second(Arg1) Extracts the second from a DateTime or Time column. Returns an 
integer between 0 and 59. 
  
Example: 
Second([Time Column]) 

Seconds(Arg1) Returns the number of seconds for a TimeSpan as an integer 
between 0 and 59. 
  
Example: 
Seconds([TimeSpan Column]) 

TotalDays(Arg1) Returns the number of days for a TimeSpan as a real value 
expressed in whole days and fractional days. 
  
Example: 
TotalDays([TimeSpan Column]) 

TotalHours(Arg1) Returns the number of hours for a TimeSpan as a real value 
expressed in whole and fractional hours. 
  
Example: 
TotalHours([TimeSpan Column]) 

TotalMilliseconds(Arg1) Returns the number of milliseconds for a TimeSpan as a real 
value expressed in whole and fractional milliseconds. 
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Example: 
TotalMilliseconds([TimeSpan Column]) 

TotalMinutes(Arg1) Returns the number of minutes for a TimeSpan as a real value 
expressed in whole and fractional minutes. 
  
Example: 
TotalMinutes([TimeSpan Column]) 

TotalSeconds() Returns the number of seconds for a TimeSpan as a real value 
expressed in whole and fractional seconds. 
  
Example: 
TotalSeconds([TimeSpan Column]) 

Week(Arg1) Extracts the week from a Date or DateTime column as an integer 
between 1 and 54, where the first week of year is dependent on 
the regional settings. 
  
Example: 
Week([Date Column]) 

Year(Arg1) Extracts the year from a Date or DateTime column. The result is 
of type Integer. 
  
Example: 
Year([Date Column]) 

YearAndWeek(Arg1) Extracts the year and week from a Date or DateTime column. 
Returns an integer (Year*100 + Week number), for example, the 
date 2005-10-13 will return 200541. 
  
Example: 
YearAndWeek([Date Column]) 

 

3.1.4.3.6 Logical Functions 

Function Description 
Case The case statement has two different forms. 

  
Simple: 
case Arg1 when Arg2 then Arg3 else Arg4 end 
The Arg1 expression is evaluated and when Arg1 is equal to Arg2 
then Arg3 is returned. Multiple when/then expressions can be 
entered and are evaluated in left to right order. 
  
Searched: 
case when Arg1 then Arg2 else Arg3 end 
Returns Arg2 if Arg1=true, and Arg3 if Arg1=false. Multiple 
when/then expressions can be entered and are evaluated in left to 
right order. 
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Example: 
case when 1 < 2 then "a" when 1 < 3 then "b" else "c" end 
case [Column] when 3 then "a" when 2 then "b" else "c" end 

If(Arg1,Arg2,Arg3) Returns Arg2 if Arg1=true, and Arg3 if Arg1=false. Arg1 is of type 
boolean, usually the result of a comparison. Arg2 and Arg3 can be of 
any type, but must both be of the same type or null. 
  
Examples: 
If([Count] > 3, "many", "few") 
If(true, null, null)                        -> (Empty) 
If(true, 1, null)                            -> 1 
If(false, null, 2)                          -> 2 
If(null, 1, 2)                                 -> #Error 
If(1 < 2, "Small", "Big")             -> Small 
If([Column] Is Null,"0","has value") 
If([Column] Is Error,"error","has value") 

Is Error Used within an If- or Case- statement, to determine whether or not 
an expression yields an error. 
  
Example: 
If([Column] Is Error, "value was error", "value was not error") 
  
If an expression contains errors, you can use the SE function to 
substitute the error with the specified value. 

Is Not Error Used within an If- or Case- statement, to determine whether or not 
an expression yields an error. 
  
Example: 
If([Column] Is Not Error, "r;value was not error", "r;value was 
error") 
  
If an expression contains errors, you can use the SE function to 
substitute the error with the specified value. 

Is Not Null Used within an If- or Case- statement, to determine whether or not 
an expression yields an empty value (null value). 
  
Example: 
If([Column] Is Not Null, "value was not null", "value was null") 
  
If an expression contains empty values (null values), you can use the 
SN function to substitute the null values with the specified value. 

Is Null Used within an If- or Case- statement, to determine whether or not 
an expression yields an empty value (null value). 
  
Example: 
If([Column] Is Null, "value was null", "value was not null") 
  
If an expression contains empty values (null values), you can use the 
SN function to substitute the null values with the specified value. 
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3.1.4.3.7 Math Functions 

Function Description 
Abs(Arg1) Returns the absolute value of Arg1. The argument and the result are 

of type real. 

ACos(Arg1) Returns the arccosine of Arg1 as an angle expressed in radians in the 
interval [0 ,π ]. Arg1 must be in the interval [-1.0, 1.0], otherwise 
#NA is returned. The argument and the result are of type real. 

ASin(Arg1) Returns the arcsine of Arg1 as an angle expressed in radians in the 
interval [- π /2 , π /2]. Arg1 must be in the interval [-1.0, 1.0], 
otherwise #NA is returned. The argument and the result are of type 
real. 

ATan(Arg1) Returns the arctangent of Arg1 as an angle expressed in radians in 
the interval [-π /2 , π /2]. The argument and the result are of type 
real. 

Ceiling(Arg1) Rounds Arg1 up to the nearest natural number. The argument and 
the result are of type real. 
  
Examples:   
Ceiling(1.01)      -> 2.0 
Ceiling(-1.99)     -> -1.0 

Cos(Arg1) Returns the cosine of Arg1 where Arg1 is an angle expressed in 
radians. The argument and the result are of type real. 

Exp(Arg1) Returns e (2.718281...) raised to the Arg1 power. The argument and 
the result are of type real. 

Floor(Arg1) Rounds Arg1 down to the nearest natural number. The argument and 
the result are of type real. 
  
Examples: 
Floor(1.99)      -> 1.0 
Floor(-1.01)     -> -2.0 

Ln(Arg1) Returns the natural logarithm of Arg1. The arguments and the result 
are of type real. If Arg1 is negative, the result is a #NA error. If 
Arg1 is zero, the result is also #NA. 

Log(Arg1, Arg2) Returns the logarithm of Arg1 expressed in the base specified by 
Arg2. Equivalent to Ln(Arg1)/Ln(Arg2). The arguments and the 
result are of type real. See function Ln for the definition of valid 
arguments. 

Log10(Arg1) Returns the 10-based logarithm of Arg1. Equivalent to 
Ln(Arg1)/Ln(10). The arguments and the result are of type real. See 
function Ln for the definition of valid arguments. 

Mod(Arg1, Arg2)       Returns the reminder of the division of Arg1 by Arg2, The 
arguments and the result are of type real. If Arg2 is 0, the result is a 
 #NA error. 
Mod(Arg1, Arg2) is defined as: 
Arg1 – Arg2*Floor(Arg1/Arg2) 
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PI() Returns the numerical constant π . 
The result is of type real. 

Power(Arg1, Arg2) Returns Arg1 raised to the Arg2 power. The arguments and the 
result are of type real. 
  
Examples: 
Power(10, 3)    -> 1000 
Power(10, -3)   -> 0.001 
Power(0, 0)       -> 1 

Rand(Arg1) Returns a random real number between 0.0 and 1.0. 
The integer argument is a constant seed value that is used to 
initialize the random number generator. It also assures that the same 
values are generated if the column is recalculated. 
The seed value cannot be a column reference. 
  
Example: 
Rand(147) 

RandBetween(Arg1, 
Arg2, Arg3) 

Returns a random integer number within the specified range. 
The first and the second arguments set the range for the random 
numbers. These arguments can be constant values or integer column 
references. 
The third argument is a constant seed value that is used to initialize 
the random number generator. It also assures that the same values 
are generated if the column is recalculated. 
The seed value cannot be a column reference. 
Example: 
RandBetween(100, -100, 147) 
RandBetween(0, [Column 1], 147) 
RandBetween([Column 1], [Column 2], 37) 

Product(Arg1, ...) Product is available under Statistical Functions. 
Returns the product of the arguments. The arguments and the result 
are of type real. Null arguments are ignored and do not contribute to 
the product. 
  
Examples: 
Product(-1)                 -> -1 
Product(1.5, -2, 3)     -> -9 
Product(1, null, 3)      -> 3 
Product(null)              -> (Empty) 

Round(Arg1, Arg2) Rounds Arg1 to the number of decimal places specified by Arg2. 
The arguments and the result are of type real, but for Arg2, only the 
integer part is used. Note that Arg2 can be negative to round to even 
10s, 100s, etc. 0.5 is rounded upwards to a number with higher 
magnitude (ignoring the sign). 
  
Examples: 
Round(PI(), 3)      -> 3.142 
Round(-0.5, 0)     -> -1 
Round(25, -1)      -> 30 
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Sin(Arg1) Returns the sine of Arg1 where Arg1 is an angle expressed in 
radians. The argument and the result are of type real. 

Sqrt(Arg1) Returns the square root of Arg1. The argument and the result are of 
type real. If Arg1 is negative, the result is a #NA error. 

Sum(Arg1, ...) Sum is available under Statistical Functions. 
Returns the sum of the arguments. Null arguments are ignored and 
do not contribute to the sum. 
Examples: 
Sum(-1)                -> -1 
Sum (1.5, -2, 3)   -> 2.5 
Sum (1, null, 3)   -> 4 
Sum (null)            -> (Empty) 

Tan(Arg1) Returns the tangent of Arg1 where Arg1 is an angle expressed in 
radians. The argument and the result are of type real. 

3.1.4.3.8 OVER Functions 
The OVER functions are used to determine how data should be sliced, for example, relative to 
time periods. For more information, see OVER in Custom Expressions and Advanced Custom 
Expressions. 

Option Description 

All Uses all the nodes in the referenced hierarchy. This can be useful when 
intersecting the current node with more than one hierarchy. For 
example, you can show the relative sales of different product 
categories for each month. 
  
Examples: 
Sum([Sales]) / Sum([Sales]) OVER (Intersect(All([Axis.Color]), 
[Axis.X])) 
Sum([Sales]) / Sum([Sales]) OVER (All([Axis.X])) * 100 

AllNext Uses all nodes, including the current, to the end of the level. 
  
Example: 
Sum([Sales]) OVER (AllNext([Axis.X])) 

AllPrevious Uses all nodes, including the current, from the start of the level. This 
can be used to calculate the cumulative sum. 
  
Examples: 
Sum([Sales]) OVER (AllPrevious([Axis.X])) 
Sum([Sales]) OVER (Intersect(Parent([Axis.X]), 
AllPrevious([Axis.X]))) 

Intersect Returns the intersected rows from nodes in different hierarchies. See 
also AllPrevious and All. 
  
Example: 
Intersect(Parent([Axis.X]), All([Axis.Color]), Parent([Axis.Rows]), ...) 
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LastPeriods Includes the current node and the n - 1 previous nodes. This can be 
used to calculate moving averages. 
  
Example: 
Sum([Sales]) OVER (LastPeriods(3, [Axis.X]))/3 

Next Compares the current node with the next node on the same level in the 
hierarchy. If there is no next node, that is, if the current node is the last 
node for the current level, the resulting subset will not contain any 
rows. 
  
Example: 
Sum([Sales]) - Sum([Sales]) OVER (Next([Axis.X])) 

NextPeriod Uses the next node which has the next value on the same level as the 
current node. If there is no next node, that is, if the current node is the 
last node for the current level, the resulting subset will not contain any 
rows. 
  
Example: 
Sum([Sales]) OVER (NextPeriod([Axis.X])) 

ParallelPeriod Uses the previous parallel node with the same value on the same level 
as the current node. For example, this can be used to compare sales 
results for each month with the corresponding months the previous 
year. 
  
Example: 
Sum([Sales])-Sum([Sales]) OVER (ParallelPeriod([Axis.X])) 

Parent Uses the parent subset of the current node. If the node does not have a 
parent, all rows are used as the subset. 
  
Examples: 
Sum([Sales]) / Sum([Sales]) OVER (Parent([Axis.Color])) 
Sum([Sales]) / Sum([Sales]) OVER (Parent([Axis.X])) * 100 

Previous Uses the previous node on the same level as the current node to 
compare the result of the current node with the previous one. If there is 
no previous node, that is, if the current node is the first node for the 
current level, the resulting subset will not contain any rows. 
  
Example: 
Sum([Sales]) - Sum([Sales]) OVER (Previous([Axis.X])) 

PreviousPeriod Uses the previous node which has the previous value on the same level 
as the current node. If there is no previous node, that is, if the current 
node is the first node for the current level, the resulting subset will not 
contain any rows. 
  
Example: 
Sum([Sales]) OVER (PreviousPeriod([Axis.X])) 



TIBCO Spotfire 4.0.2 - User's Manual 

130 

3.1.4.3.9 Property Functions 

Function Description 

$csearch Selects a number of columns from a data table using a limiting 
search expression. The first argument is a data table and the second 
argument is a string that contains the search expression determining 
which column names should be returned. The function returns a list 
of the (unescaped) column names from the data table that match the 
search expression. 
Examples: 
$csearch([Data Table],"*") 
-> Returns a list of all values in the data table called Data Table. 
$csearch([Data Table], "Col*") 
-> Returns a list of all values in the data table Data Table beginning 
with "Col", e.g., Column 1, Column 2, etc. 

$esc Replaces "]" in column names with "]]" and encloses the escaped 
column names in "[" and "]". The argument is a property value or a 
property function that starts with a dollar sign ($). See Properties in 
Expressions for more information. 
Examples: 
$esc(${PropertyName}) 
-> Returns the property value as a column name (within [ and ]). 
$esc($csearch([Data Table], "Col*")) 
-> Returns a list of all columns in the data table Data Table 
beginning with "Col", e.g., [Column 1], [Column 2], etc. 

$map Maps a list-valued property to a single string. The first argument is a 
template to use for each value in the list and the second argument is 
a specification of how the list values should be connected in the 
resulting expression. See Properties in Expressions for more 
information. 
Examples: 
$map("sum([${PropertyName}])", ",") 
-> Returns a comma separated list of the sum of the columns 
included in the list-valued property, e.g., sum([Column 
1]),sum([Column 2]) 
<$map("[${PropertyName}]", " NEST")> 
-> Returns a nested categorical hierarchy using the columns 
included in the list-valued property, e.g., <[Column 1] 
NEST[Column 2]> 

BaseRowID Returns a unique identifier for each calculated row in the 
visualization. This identifier is selected from identifiers calculated 
on the Data Table.  This value may change when filtering or 
marking is performed. 
Example: 
BaseRowId() 

ColumnProperty The first argument is a column and the second argument is the 
column property name, presented as a string. Returns the value of 
the named column property from the column. The column property 
value cannot be a list and the column property has to exist before 
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creating the expression. 
Custom column properties can be specified using Edit > Column 
Properties, Properties tab, New-button. 
Example: 
ColumnProperty([Column], "Description") 

DataTableProperty Returns the value of the data table property. The argument to the 
method is the name of the data table property, presented as a string. 
Example: 
DataTableProperty("Table.CreationDate") 

DocumentProperty Returns the value of the document property. Custom document 
properties can be specified under Edit > Document Properties, 
Properties tab. Document properties can be used throughout the 
entire document. 
The argument to the method is the name of the document property, 
presented as a string. 
Example: 
DocumentProperty("Extension.NumberOfBins") 

RowID Returns a unique identifier for each calculated row in the 
visualization.  This identifier will not change when filtering or 
marking is performed. 
Example: 
RowId() 

3.1.4.3.10 Ranking Functions 

Function Description 

DenseRank(Arg1, 
Arg2, Arg3...) 

Returns an integer value ranking of the values in the selected 
column. The first argument is the column to be ranked. 
An optional argument is a string determining whether to use an 
ascending (default) or a descending ranking. For the highest value 
to retrieve rank 1, use the argument "desc", for the lowest value to 
retrieve rank 1, use "asc". 
Ties are given the same rank value and the highest ranking number 
equals the number of unique values in the column. 
Additional column arguments (optional) can be used when the 
column should be split into separately ranked categories. 
Examples: 
DenseRank([Sales]) 
DenseRank([Sales], "desc", [Region]) 

Rank(Arg1, Arg2, 
Arg3...) 

Returns an integer value ranking of the values in the selected 
column. The first argument is the column to be ranked. 
An optional argument is a string determining whether to use an 
ascending (default) or a descending ranking. For the highest value 
to retrieve rank 1, use the argument "desc", for the lowest value to 
retrieve rank 1, use "asc". 
Ties are given rank values depending on optional argument values: 
"ties.method=minimum" (default), 
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"ties.method=maximum", or 
"ties.method=first". 
See More about ranking ties below for more information about the 
available arguments. 
Additional column arguments (optional) can be used when the 
column should be split into separately ranked categories. 
Examples: 
Rank([Sales]) 
Rank([Sales], "desc", [Region]) 
Rank([Sales], "ties.method=first") 

RankReal(Arg1, Arg2, 
Arg3...) 

Returns a real value ranking of the values in the selected column. 
The first argument is the column to be ranked. 
An optional argument is a string determining whether to use an 
ascending (default) or a descending ranking. For the highest value 
to retrieve rank 1, use the argument "desc", for the lowest value to 
retrieve rank 1, use "asc". 
Ties are given rank values depending on optional argument values: 
"ties.method=minimum" (default), 
"ties.method=maximum", 
"ties.method=first", or 
"ties.method=average". 
See More about ranking ties below for more information about the 
available arguments. The average ties method is used when 
calculating data relationships using Spearman R. 
Additional column arguments (optional) can be used when the 
column should be split into separately ranked categories. 
  
Examples: 
RankReal([Sales]) 
RankReal([Sales], "desc", [Region]) 
RankReal([Sales], "ties.method=average") 

More about ranking ties: 
With the functions Rank and RankReal, you can add an optional ties method argument 
depending how you want equal values to be ranked: 

Argument Description 

"ties.method=minimum" Gives all ties the smallest rank value of the tie values. 

"ties.method=maximum" Gives all ties the largest rank value of the tie values. 

"ties.method=first" Gives the first found tie value the lowest rank value, and 
continues with the following rank value for the next tie. 

"ties.method=average" Gives all ties the average of the rank values for all ties. 

  
Example: 
When a list is to be ranked, its values are first of all sorted. Then, the sorted values are assigned 
a rank value depending on the order in the sorted list. What rank is given to a tie value depends 
on the ties method. Empty values are left empty and do not receive any rank. 
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List of 
values 

Rank with 
"ties.method=minimum" 

Rank with 
"ties.method=maximum" 
  

Rank with 
"ties.method=first" 

Rank with 
"ties.method=average" 
  

1 1 1 1 1 

2 2 3 2 2.5 

3 4 4 4 4 

2 2 3 3 2.5 

(Empty) (Empty) (Empty) (Empty) (Empty) 

5 5 5 5 5 
If DenseRank was used, the resulting rank values in the example would be 1 2 3 4. 

3.1.4.3.11 Spatial Functions 
The spatial functions are used to transform data so that it can be used to set up map charts in 
TIBCO Spotfire. If the map information is included in a Shape file, none of this is necessary. 
However, if you have geographic information in some other type of BLOB column containing 
WKB (Well-Known Binary) data, then this information needs to be extracted into seven 
different columns: Geometry, XMax, XMin, YMax, YMin, XCenter and YCenter. The 
Geometry column is the original, binary column. 
The bounding box for a geometry is called the envelope. It is specified by the four coordinates 
XMax, XMin, YMax and YMin. XCenter and YCenter specifies the center of the geometry. 
These coordinate columns can be calculated from the binary WKB column using the spatial 
functions with the binary WKB column as an argument. In order for the map chart to identify 
these columns they must also have the required property values (same as the column names 
listed above) set on the mapchart.columntypeid property. This is automatically done when the 
spatial functions below are applied. 
See also Configuration of Geographical Data for Map Charts. 

Function Description 

WKBEnvelopeXCenter(Arg1) Calculates the X center of the geometry envelope and sets 
the XCenter value on the mapchart.columntypeid property. 
The argument is a binary WKB column. 
  
Example: 
WKBEnvelopeXCenter([WKB]) 

WKBEnvelopeXMin(Arg1) Calculates the X min of the geometry envelope and sets the 
XMin value on the mapchart.columntypeid property. The 
argument is a binary WKB column. 
  
Example: 
WKBEnvelopeXMin([WKB]) 

WKBEnvelopeXMax(Arg1) Calculates the X max of the geometry envelope and sets the 
XMax value on the mapchart.columntypeid property. The 
argument is a binary WKB column. 
  
Example: 
WKBEnvelopeXMax([WKB]) 

WKBEnvelopeYCenter(Arg1) Calculates the Y center of the geometry envelope and sets 
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the YCenter value on the mapchart.columntypeid property. 
The argument is a binary WKB column. 
  
Example: 
WKBEnvelopeYCenter([WKB]) 

WKBEnvelopeYMin(Arg1) Calculates the Y min of the geometry envelope and sets the 
YMin value on the mapchart.columntypeid property. The 
argument is a binary WKB column. 
  
Example: 
WKBEnvelopeYMin([WKB]) 

WKBEnvelopeYMax(Arg1) Calculates the Y max of the geometry envelope and sets the 
YMax value on the mapchart.columntypeid property. The 
argument is a binary WKB column. 
  
Example: 
WKBEnvelopeYMax([WKB]) 

3.1.4.3.12 Statistical Functions 

Function Description 
Avg(Arg1, ...) Returns the average (arithmetic mean) of the arguments. 

The arguments and the result are of type real. If one 
argument is given, then the result is the average of all rows. 
If more than one argument is given, then the result is the 
average for each row. Null arguments are ignored and do 
not contribute to the average. 
Examples: 
Avg([Column]) 
Avg(2,-3,4)            -> 1 
Avg(-1)                   -> -1 
Avg(1.5, -2, 3.5)   -> 1 
Avg(1, null, 3)       -> 2 
Avg(null)               -> (Empty) 

ChiDist(Arg1) Returns the (upper tail) chi-square p-value of the argument. 
Example: 
ChiDist(x, deg_freedom) 
ChiDist(7.377759, 2) =0.025 

ChiInv(Arg1) Returns the (upper tail) chi-square quantile value of the 
argument. 
Example: 
ChiInv(p, deg_freedom) 
ChiInv(0.025, 2) =7.377759 

Count(Arg1) 
  

Calculates the number of non-empty values in the argument 
column, or, if no argument is specified, the total number of 
rows. 
Example: 
Count([Column]) 
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Covariance(Arg1, Arg2) Calculates the covariance of two columns given as 
arguments. 
Example: 
Covariance([Column1], [Column2]) 

FDist(Arg1) Returns the upper tail F p-value of the argument. 
Example: 
FDist(x, deg_freedom1, deg_freedom2) 
FDist(6.936728, 1, 10) =0.025 

FInv(Arg1) Returns the upper tail F quantile value of the argument. 
Example: 
FInv(p, deg_freedom1, deg_freedom2) 
FInv(0.025, 1, 10) =6.936728 

First(Arg1) Returns the first valid value based on the physical order of 
the rows of data in the argument column. 
Example: 
First([Column]) 

GeometricMean() Calculates the geometric mean value. If any input value is 
negative then the result will be "Empty". If any input value 
is equal to zero then the result will be zero. 
Example: 
GeometricMean([Sales]) 

IQR(Arg1) Calculates the value difference Q3-Q1, or, the 75th 
percentile minus the 25th percentile. IQR is also referred to 
as the H-spread. 
Example: 
IQR([Column]) 

L95(Arg1) Calculates the lower endpoint of the 95% confidence 
interval. 
Example: 
L95([Column]) 

Last(Arg1) Returns the last valid value based on the physical order of 
the rows of data in the argument column. 
Example: 
Last([Column]) 

LAV(Arg1) Calculates the lower adjacent value. 
Example: 
LAV([Column]) 

LIF(Arg1) Calculates the lower inner fence. This is the threshold 
located at Q1 – (1.5*IQR). 
Example: 
LIF([Column]) 

LOF(Arg1) Calculates the lower outer fence. This is the threshold 
located at Q1 – (3*IQR). 
Example: 
LOF([Column]) 
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Max(Arg1, ...) Calculates the maximum value. If one argument is given, 
then the result is the maximum for the entire column. If 
more than one argument is given, then the result is the 
maximum for each row. The argument and the result are of 
type real. Null arguments are ignored. 
Examples: 
Max([Column]) 
Max(-1)                 -> -1 
Max (1.5, -2, 3)    -> 3 
Max (1, null, 3)     -> 3 
Max (null)              -> (Empty) 

MeanDeviation(Arg1, ...) Calculates the mean deviation value (average absolute 
deviation, AAD). If one argument is given, then the result is 
the mean deviation of all rows. If more than one argument 
is given, then the result is the mean deviation for each row. 
Examples: 
MeanDeviation([Column]) 
MeanDeviation(2,-3,4)         -> 2.67 

Median(Arg1) Calculates the median of the argument. If one argument is 
given, then the result is the median of all rows. If more than 
one argument is given, then the result is the median for each 
row. 
Examples: 
Median([Column]) 
Median(2,-3,4) 

MedianAbsoluteDeviation(Arg1, 
...) 

Calculates the median absolute deviation value (MAD). If 
one argument is given, then the result is the median 
absolute deviation of all rows. If more than one argument is 
given, then the result is the median absolute deviation for 
each row. 
Examples: 
MedianAbsoluteDeviation([Sales]) 
MedianAbsoluteDeviation(2,-3,4) 

Min(Arg1, ...) Calculates the minimum value. If one argument is given, 
then the result is the minimum for the entire column. If 
more than one argument is given, then the result is the 
minimum for each row. The argument and the result are of 
type real. Null arguments are ignored. 
Examples: 
Min([Column]) 
Min(-1)                 -> -1 
Min (1.5, -2, 3)    -> -2 
Min (1, null, 3)    -> 1 
Min (null)             -> (Empty) 

NormDist(Arg1) Returns the (upper tail) normal p-value of the argument. If 
you do not specify them yourself, the default is mean=0 and 
standard deviation=1. 
Example: 
NormDist(x, mean, standard_dev) 
NormDist(1.96) =0.025 
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NormInv(Arg1) Returns the (upper tail) normal quantile value of the 
argument. If you do not specify them yourself, the default is 
mean=0 and standard deviation=1. 
Example: 
NormInv(p, mean, standard_dev) 
NormInv(0.025) =1.96 

Outliers(Arg1) Outer value count. Calculates the count of values that are 
greater than the upper adjacent value or lower than the 
lower adjacent value. 
Example: 
Outliers([Column]) 

P10(Arg1) The 10th percentile is the value at which 10 percent of the 
data values are equal to or lower than the value. 
Example: 
P10([Column]) 

P90(Arg1) The 90th percentile is the value at which 90 percent of the 
data values are equal to or lower than the value. 
Example: 
P90([Column]) 

PctOutliers(Arg1) Outer value percentile. Calculates the percent of values that 
are greater than the upper adjacent value or lower than the 
lower adjacent value. 
Example: 
PctOutliers([Column]) 

Percentile(Arg1, Arg2) The percentile is the value at which a certain percent of the 
data values are equal to or lower than the value. The first 
argument is the column to analyze and the second argument 
is the percent. 
Example: 
Percentile([Column], 15.0) 

Product(Arg1, ...) Calculates the product of the values. If one argument is 
given, then the result is the product of the entire column. If 
more than one column is given, then the result is the 
product of each row. 
Example: 
Product([Column]) 
Product(1,2,3) 

Q1(Arg1) Calculates the first quartile. 
Example: 
Q1([Column]) 

Q3(Arg1) Calculates the third quartile. 
Example: 
Q3([Column]) 

Range(Arg1) The range between the largest and the smallest value in the 
column. 
The result will be presented as a real or a timespan, 
depending on the data type of the argument. 
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Example: 
Range([Column]) 

StdDev(Arg1) Calculates the standard deviation. 
Example: 
StdDev([Column]) 

StdErr(Arg1) Calculates the standard error. 
Example: 
StdErr([Column]) 

Sum(Arg1, ...) Calculates the sum of the values. If one argument is given, 
then the result is the sum of the entire column. If more than 
one column is given, then the result is the sum of each row. 
Examples: 
Sum(-1)                -> -1 
Sum (1.5, -2, 3)   -> 2.5 
Sum (1, null, 3)   -> 4 
Sum (null)            -> (Empty) 

TDist(Arg1) Returns the (upper tail) t p-value of the argument. 
Example: 
TDist(x, deg_freedom) 
TDist(4.302653, 2) =0.025 

TInv(Arg1) Returns the (upper tail) t quantile value of the argument. 
Example: 
TInv(p, deg_freedom) 
TInv(0.025, 2) =4.302653 

TrimmedMean(Arg1, Arg2) Calculates the trimmed mean value (trimmed average). The 
first argument is the column to analyze and the second 
argument is, in percent, how many values to exclude from 
the calculation. If the trim value is set to 10%, then the 
highest 5%  and the lowest 5% of the values are excluded 
from the calculated mean. 
Example: 
TrimmedMean([Sales], 10) 

U95(Arg1) Calculates the upper endpoint of the 95% confidence 
interval. 
Example: 
U95([Column]) 

UAV(Arg1) Calculates the upper adjacent value. 
Example: 
UAV([Column]) 

UIF(Arg1) Calculates the upper, inner fence. This is the threshold 
located at Q3 + (1.5*IQR). 
Example: 
UIF([Column]) 

UniqueCount(Arg1) Calculates the number of unique, non-empty values in the 
argument column. 
Example: 
UniqueCount([Column]) 
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UOF(Arg1) Calculates the upper, outer fence. This is the threshold 
located at Q3 + (3*IQR). 
Example: 
UOF([Column]) 

ValueForMax(Arg1, Arg2) Returns the value of column 2 for the maximum value of 
column 1. 
Example: 
ValueForMax([Column 1], [Column 2]) 

ValueForMin(Arg1, Arg2) Returns the value of column 2 for the minimum value of 
column 1. 
Example: 
ValueForMin([Column 1], [Column 2]) 

Var(Arg1) Calculates the variance. 
Example: 
Var([Column]) 

WeightedAverage(Arg1, Arg2) Calculates the weighted average of two columns. Arg1 is 
the weight column and Arg2 is the value column. 
Example: 
WeightedAverage([Column1],[Column2]) 

 

3.1.4.3.13 Text Functions 

Function Description 
~= Can be part of an 'If' or 'Case' statement. Returns true if the Arg2 

regular expression string matches the Arg1 string. 
  
Examples: 
If( "aab" ~= "a+" , "true", "false" ) 
Case when "aba" ~= ".a+$" then "true" else "false" end 
 

Concatenate(Arg1, ...) Concatenates (appends) all the arguments into a string. If one 
argument is given, then the result is the concatenation of all 
rows. If more than one argument is given, then each row is 
concatenated. The arguments can be of any type, but are 
converted to strings. The result is of type string. Null arguments 
are ignored. 
  
Examples: 
Concatenate("April ", 20+1, "st")       -> "April 21st" 
Concatenate(null, "Ape")                   -> "Ape" 
Concatenate (null, null)                     -> (Empty) 
 

Find(Arg1, Arg2) Returns the 1-based index of the first occurrence of the string 
Arg1 in Arg2. If not found, 0 is returned. The search is case-
sensitive. The arguments are of type string and the result is of 
type integer. If Arg1 is the empty string, 0 is returned. 
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Examples: 
Find("lo", "Hello")   -> 4 
Find("a", "Hello")    -> 0 
Find("", "Hello")      -> 0 
Find("", null)            -> (Empty) 
If(Find("Pri 1", [Col1])>0, "Important", "Not important") 

Left(Arg1, Arg2) Returns the first Arg2 characters of the string Arg1. Arg1 and the 
result are of type string. Arg2 is of type real, but only the integer 
part is used. If Arg2 > the length of Arg1, the whole string is 
returned. If Arg2 is negative, an error is returned. 
  
Examples: 
Left("Daddy", 3.99)     -> "Dad" 
Left("Daddy", 386)      -> "Daddy" 
Left("Daddy", -1)         -> (Empty) 

Len(Arg1) Returns the length of Arg1. Arg1 is of type string and the result 
is of type integer. 
  
Examples: 
Len("Hello")      -> 5 
Len(null)            -> (Empty) 

Lower(Arg1) Returns Arg1 converted to lowercase. Arg1 and the result are of 
type string. 

Mid(Arg1, Arg2, Arg3) Returns the substring of Arg1 starting at index Arg2 with a 
length of Arg3 characters. Arg1 and the result are of type string. 
Arg2 and Arg3 are of type real, but only the integer part is used. 
If Arg2 > Len(Arg1), an empty string is returned. Else, if 
Arg2+Arg3 > Len(Arg1), Arg3 is adjusted to 1+Len(Arg1)-Arg2. 
If either of Arg2 or Arg3 is negative or if Arg2 is zero, an error is 
returned. 
  
Examples: 
Mid("Daddy", 2, 3)            -> "add" 
Mid("Daddy", 386, 4)       -> "" 
Mid("Daddy", 4, 386)       -> "dy" 
Mid("Daddy", -1, 2)          -> (Empty) 
Mid("Daddy", 2, -1)          -> (Empty) 

MostCommon(Arg1) Returns the most common value of the specified column. If 
several values are equally common, the first one will be used. 
  
Example: 
MostCommon([Column]) 

NameDecode(Arg1) Replaces all substring codes with decoded characters. 
Column names in TIBCO Spotfire are stored as UTF-16 encoded 
strings, while variable names in TIBCO Spotfire Statistics 
Services are built from 8-bit ASCII characters matching [.0-9a-
zA-Z] or ASCII strings enclosed in grave accents. Thus, the 
column names that are sent to TIBCO Spotfire Statistics Services 
must be encoded. Column names received from TIBCO Spotfire 
Statistics Services are automatically decoded by the built-in data 
functions output handlers. This function can be used to decode 
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results that have not been automatically decoded. 
  
Example: 
NameDecode("Column %02D") 

NameEncode(Arg1) Encodes characters in the string so that the string only contains 
characters matching the regular expression [.0-9a-zA-Z]. 
  
Column names in TIBCO Spotfire are stored as UTF-16 encoded 
strings, while variable names in TIBCO Spotfire Statistics 
Services are built from 8-bit ASCII characters matching [.0-9a-
zA-Z]. Thus, the column names that are sent to TIBCO Spotfire 
Statistics Services must be encoded. This is done automatically 
when sending data to TIBCO Spotfire Statistics Services via the 
built-in data functions input handlers. If you need to provide 
column name input by some other means (e.g., via a document 
property) you may need to use this function to encode the 
column names before applying the data function. 
  
Example: 
NameEncode("Column £") 

Repeat Repeats a string a specified number of times. 
  
Example: 
Repeat("Hello", 2)        -> "HelloHello" 

Right(Arg1, Arg2) Returns the last Arg2 characters of the string Arg1. Arg1 and the 
result are of type string. Arg2 is of type real, but only the integer 
part is used. If Arg2 > the length of Arg1, the whole string is 
returned. If Arg2 is negative, an error is returned. 
  
Examples: 
Right("Daddy", 3.99)     -> "ddy" 
Right("Daddy", 386)      -> "Daddy" 
Right("Daddy", -1)         ->  (Empty) 

RXReplace(Arg1, Arg2, 
Arg3, Arg4) 
  

Replaces a substring according to a regular expression. Search 
for the Arg2 regular expression in Arg1 and replace it with Arg3. 
Arg4 specifies the options for the replacement: 
"g" specifies that if Arg2 matches more than once then all 
matches should be substituted. 
"i" specifies that the comparison should be case insensitive. 
"s", for single-line mode, specifies that the dot (.) matches every 
character (instead of every character except newline). 
  
Some characters, like for instance the backslash character "\", 
need to be escaped to work when using calculated columns. See 
literature about regular expression language elements, e.g., on 
MSDN, for more information. 
  
Example: 
RXReplace("Hello", "L+", "LL", "i")            -> "HeLLo" 
RXReplace("3 Minor", "(\\d).*", "$1", "")    -> 3 

http://msdn.microsoft.com/en-us/library/az24scfc(VS.71).aspx
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RXReplace("change\\slashdirection","\\\\","/","")                 -> 
change/slashdirection 
  
(In the last example, the backslash needs to be escaped twice; 
once for the Spotfire string and once for the regular expression.) 

Substitute(Arg1, Arg2, 
Arg3) 
  

Replaces all occurrences of Arg2 in Arg1 with Arg3. The search 
is case sensitive. 
  
Example: 
Substitute("Test","t","ting")                -> "Testing" 

Trim(Arg1) Removes whitespace characters from the beginning and end of a 
string. 
  
Example: 
Trim(" Example ")                               ->"Example" 

UniqueConcatenate(Arg1) 
  

Concatenates the unique values converted to strings. The values 
are ordered according the comparator. 
  
Example: 
UniqueConcatenate([Column]) 

Upper(Arg1) Returns Arg1 converted to uppercase. Arg1 and the result are of 
type string. 
  
Example: 
Upper("hello")      ->"HELLO" 

  

3.1.4.4 Errors and Empty Values 
An expression is considered valid if it is syntactically correct and all function, operator and 
column references can be resolved. If an expression is not valid, it cannot be evaluated. This 
will be indicated in the Sample result field as "#Error", or similar. 
When evaluating an expression, some operations produce errors or null values. Each function 
and operator can choose how to handle arguments that are errors or null. The default behavior is 
to propagate the first error or null value that is encountered. So, if a function takes two 
arguments and the first is null and the second is an error, the default behavior is to return null. 
Functions that handle errors and null in other ways are explained in their Descriptions. 

Errors 
For operations on arguments of type real, the result is sometimes not defined. This produces a 
#NA (Not Applicable) error. For example, this could happen if the result of an operation is 
greater than the maximum real number. 
If the argument for a function (or operator) is invalid, an error is also produced. For example, 
functions expecting an index might produce an error because the index is negative and 
conversion functions produce an error if the argument cannot be converted. 
The SE(Arg1, Arg2) function can be used to substitute errors with a certain value, for example 
null or 0. 
When generating a result data table from the expression, errors are converted to null. Wrap the 
expression with a call to the SN(Arg1, Arg2) function to override this behavior. 
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Error Example Description 
NA 0/0 

sqrt(-1) 
NA, Not Applicable, means that the result is 
undefined. 

Negative 
Argument 

Left("Hello", -1) 
Mid("Hello", 0, 1) 

Invalid argument. In this case because length must 
be positive and position cannot be zero. 

(Empty) Real("Hello") Conversion failed. 

(Empty) 
Empty values are usually only generated when a column value from the data table is missing or 
by explicitly writing null in the expression. Results that are null, are displayed as "(Empty)". 
The SN(Arg1, Arg2) function can be used to substitute null with a certain value, for example, 0. 

3.1.4.5 Details on Formatting 
This dialog lets you format values on column level. If you change settings for a specific column 
or hierarchy in this dialog the new settings will be used for that specific column or hierarchy 
everywhere in the analysis from then on. 
For general information about formatting, see Formatting Overview. 

► To reach the Formatting dialog: 
1. Right-click on a filter in the filters panel and select Format Values... from the pop-up 

menu, or, in the Insert Calculated Column dialog, click on the Formatting button. 
Comment: The same functionality is also available in the Formatting tab of the 
Column Properties dialog (Edit  > Column Properties). 

 

Option Description 

Category Lists the available formatting categories for the selected column or 
hierarchy. Each category in this list has separate settings. What 
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categories are available depends on the data type of the selected 
column. See Formatting Settings for a full description of all 
possible options. 

Apply formatting 
from column 

  

   Data table Specifies the data table containing the column from which you 
want to apply formatting. 

   Column Lists all columns of the same type as the selected column, from 
which it is possible to reuse the formatting. 

Apply Formatting Applies the formatting from the column selected in the drop-down 
list. 

3.1.4.6 Format String 
If the format you want to use cannot be created with the given settings, the custom format string 
allows you to create your own formats using a code explained in the examples below. 
The special characters allow you to multiply, divide, separate numbers, etc. Other characters are 
printed out in the resulting data. 

Custom Numeric Format Strings 
Special characters: 

Character Description 

0 Always returns a value for the position it is written in. If there is no 
number in its place in the data, 0 (zero) will be used. 

# Returns values if there are numbers in its place in the data. 
If used to the left of the decimal point, all digits are returned even if 
there is one # in the format string and three digits in the data. 
If used to the right of the decimal point, the same number of digits are 
returned as there are # to the right of the decimal point, and the number 
gets rounded up or down. 
See example below. 

, If used before a decimal point, divide the number in the data by 1000. 
Note: A difference from Excel is that Excel allows for "," as divider 
after the decimal point as well. 

% Multiplies the number by 100 and inserts a "%" in the number in the 
location it is written in the format string. 

. Decimal point. 
Note: If no decimal point is used and there are decimals in the value 
you apply the format string on, the value gets rounded up or down. 

; Used to divide a format string if different formats are to be used for 
positive numbers, negative numbers and 0 (zero). 
  
If no semicolon is used, the format string is used for all numbers. 
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If one semicolon is used, it divides the format string like this: 
String for positive numbers and zero;String for negative numbers 
  
If two semicolons are used, they divide the format string like this: 
String for positive numbers;String for negative numbers;String for 
zero 

\ If a "\" is added before a special character that character will not 
modify the number, the character will only be added to the value. 

Examples: 
Note: All these examples use the number 12345.67 as the value from the data. 

Format string Result 

# #### 1 2346 

#.# 12345.7 

#.000 12345.670 

#,.# 12.3 

#,,.## .01 

#% 1234567% 

#\% 12345.67% 

$# $12346 

#.##E+0 1.23E+4 

#.#;(#.#) 12345.7 
Note: Had the number been negative, the result would be: 
(12345.7) 

23 23 

See literature about custom numeric format strings, for example, on MSDN, for more 
information. 

Custom DateTime Format Strings 
Below are some examples of custom format strings for datetime formats. See literature about 
custom datetime format strings, such as that on MSDN, for more information. 

Character Description 

yy Returns the year, measured as a number between 0 and 99. 

yyyy Returns the year as a four-digit number. 

M Returns the month, measured as a number between 1 and 12, with one 
or two digits depending on the value. 

MM Returns the month with two digits, measured as a number between 1 
and 12. This means that June will be written as '06', when this format 

http://msdn2.microsoft.com/en-us/library/0c899ak8(vs.71).aspx
http://msdn.microsoft.com/en-us/library/8kb3ddd4.aspx
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string is applied. 

MMM Returns the abbreviated name of the month. For example, 'Jun'. 

MMMM Returns the full name of the month. For example, 'June'. 

d Returns the day of the month, measured as a number between 1 and 
31, with one or two digits depending on the value. 

dd Returns the day of the month with two digits, measured as a number 
between 1 and 31. This means that the 6th of a month will be written 
as '06', when this format string is applied. 

ddd Returns the abbreviated name of the day of the week. For example, 
'Fri'. 

dddd Returns the full name of the day of the week. For example, 'Friday'. 

h Returns the hour using a 12-hour clock, with one or two digits 
depending on the value. 

hh Returns the hour using a 12-hour clock, with two digits. This means 
that 6 o'clock will be written as '06', when this format string is applied. 

H Returns the hour using a 24-hour clock, with one or two digits 
depending on the value. 

HH Returns the hour using a 24-hour clock, with two digits. This means 
that 6 o'clock in the morning will be written as '06' and 6 o'clock in the 
evening will be written as '18', when this format string is applied. 

m Returns the minute with one or two digits, depending on the value. 

mm Returns the minute with two digits. This means that six minutes will be 
written as '06', when this format string is applied. 

s Returns the second with one or two digits, depending on the value. 

ss Returns the second with two digits. This means that six seconds will be 
written as '06', when this format string is applied. 

f Returns the tenths of a second. 

ff Returns the hundredths of a second. 

fff Returns the milliseconds. 

tt Returns the AM/PM designator. 

: Returns the time separator. 

/ Returns the date separator. 

You can also add any custom string value, but if any of the specifier characters are included in 
the string, they need to be escaped by a backslash (\). 
Examples: 
Note: All the examples below use the following value from the data: Friday, October 16, 2009, 
at 25 minutes past three in the afternoon. 
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Format string Result 

dd\t\h o\f MMMM 
yyyy 

16th of October 2009 

MMM d yyyy, 
HH:mm 

Oct 16 2009, 15:25 

\year: YY, 
\mon\t\h: MM, 
\da\y: dd 

year: 09, month: 10, day: 16 

hh:mm tt 03:25 PM 

m \minu\te\s pa\s\t 
h, MMM d 

25 minutes past 3, Oct 16 

Custom TimeSpan Format Strings 
There are five different data values included in the TimeSpan format: day, hour, minute, second 
and fractions of seconds. These can be combined to a suitable format using a format string built 
by the following specifier characters: 

Character Description 

d Returns the number of days. 

h Returns the number of hours with one or two digits, depending on the 
value. 

hh Returns the number of hours with two digits. This means that six hours 
will be written as '06', when this format string is applied. 

m Returns the number of minutes with one or two digits, depending on 
the value. 

mm Returns the number of minutes with two digits. This means that six 
minutes will be written as '06', when this format string is applied. 

s Returns the number of seconds with one or two digits, depending on 
the value. 

ss Returns the number of seconds with two digits. This means that six 
seconds will be written as '06', when this format string is applied. 

f Returns the fractions of seconds. You can also add a number between 
1 and 3 after the 'f', defining how many decimals will be shown. If no 
number has been specified, three numbers will be shown, if available. 

Between each specifier character, you need to supply some kind of separator. This could be a 
custom string value, but if any of the specifier characters are included in the string, they need to 
be escaped by a backslash (\). You can also include an initial and a conclusive string. 
Examples: 
Note: All the examples below use the following value from the data:  -5 days, 7 hours, 11 
minutes 3.1234 seconds. 
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Format string Result 

d.h:m:s.f -5.7:11:3.123 

d.hh:mm:ss.f2 5.07:11:03.12 

Ti\me\span i\s d 
\day\s 

Timespan is -5 days 

d \day\s h \hour\s 
m \minute\s s 
\secon\d\s 

-5 days 7 hours 11 minutes 3 seconds 

f s m h d 123 3 11 7 -5 

3.1.4.7 Properties 

3.1.4.7.1 Properties in Expressions 
There are three types of properties available in TIBCO Spotfire: document properties, data table 
properties and column properties. All of these can be used in expressions that control one or 
many settings. The properties can be interpreted in two different ways, either as actual values or 
as text values that can be used instead of column names or measures. 

Insert as Text 
When you want to use a string property in an expression where it should be interpreted as a 
column name or a measure you must use a specific syntax. The name of the property should be 
enclosed in the following: “${“ and “}”. So, for a document property this could look something 
like: ${MyProperty}. For a data table property, the first part should be the data table name 
within the symbols specified above, followed by a period and the property name also within 
curly brackets: ${My Data Table}.{MyProperty}. For a column property, the column name is 
also required: ${My Data Table}.{Column Name}.{MyProperty}. 

Property call in 
expression 

Description 

${MyProperty} Denotes the document property named MyProperty. 

${My Data 
Table}.{MyProperty} 
                            

Denotes the data table property named MyProperty defined 
for the data table "My Data Table". 

${My Data Table}.{Column 
Name}.{MyProperty} 

Denotes the column property named MyProperty defined 
for the column "Column Name" in the data table "My Data 
Table". 

$map("template", 
"concatenation string") 

The $map() function is used to map list-valued properties to 
a single string. The first argument is a template to use for 
each value in the list and the second argument is a 
specification of how the list values should be connected in 
the resulting expression. 
See List-Valued Properties (Multiple Select) below for 
more information. 
Examples: 
$map("sum([${PropertyName}])", ",") 
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<$map("[${PropertyName}]", " NEST")> 

$esc(expression) Replaces "]" in column names with "]]" and encloses the 
escaped column names in "[" and "]". The argument is an 
expression which could be a property value or a property 
function that starts with a dollar sign ($). 
Examples: 
$esc(${MyProperty}) 
$esc("$csearch([Data Table], "Col*")") 

$csearch([Data Table], 
"search string") 

The $csearch() function is used to select a number of 
columns from a data table using a limiting search 
expression. The first argument is a data table and the second 
argument is a string that contains the search expression 
determining which column names should be returned. The 
function returns a list of the (unescaped) column names 
from the data table that match the search expression. 
Examples: 
$csearch([Data Table],"*") 
$csearch([Data Table], "Col*") 

When the $ sign is encountered in an expression, the property will be replaced by its 
corresponding value before the actual expression is evaluated (a preprocessing step). This 
means that if you type an expression like: sum(${Property1}) -${Property1}-${Property2}, and 
the value of Property1 is the column name Column1, and the value of Property2 is Column2, 
then the resulting expression will be: sum([Column1]) -[Column1]-[Column2]. 
If you do not want the property value to be interpreted as a column name but as a literal string 
value, you should put the property call within quotation marks. For example, if you have a 
property called "MyProperty" with the value "MyValue", the expression ${MyProperty} would 
return the resulting expression MyValue, where a column called "MyValue" is retrieved. 
However, the expression "${MyProperty}" would return the text string "MyValue" instead. If 
the string value consists of several words (e.g., "My Value"), then you should use $esc() or put 
brackets around the property expression in order to return a column: [${MyProperty}]. See 
General Syntax for more information about column names. 
Note that it is very important to use the correct syntax for the expression at all times. Otherwise 
you may end up with a different result than you expected. If a property is inserted as a column 
where the expression expected a string, the first value of the specified column will be retrieved. 
For string columns, the result may be a valid expression, but for a column of another data type, 
you may receive an error. 
If a property is inserted using the Insert Properties button in the Insert Calculated Column 
dialog or in the Custom Expression dialog, the property will automatically be added using the 
text (preprocessor) syntax. 
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You can also right-click on the property in the Available properties for column field and select 
Insert as Text from the pop-up menu. 
If a property containing a column name is to be used on an axis, there is a shortcut called Set 
from Property available from the pop-up menu on the column selectors. If any changes to the 
automatically added syntax are required, you must use the Custom Expression dialog to modify 
the expression. Right-click on the column selector and select Remove All if you want to remove 
the property expression from the axis. 
A property can also be used to specify an aggregation measure. For example, you can define a 
property called MyMeasure with the default value "sum". If such a property is to be used in an 
expression you need to manually add parentheses and arguments for the measure in the 
expression where it is used. You can then create a property selector in a text area displaying a 
list of fixed aggregation measures that you want to be available in an axis expression and let 
web player users change the axis expression using the property selector. 
Since string properties inserted as text in most cases will be interpreted as column names, you 
may encounter situations where you do not achieve the expected result when creating a custom 
expression. If the string property is to be interpreted as a value (e.g., in conditional expressions) 
it needs to be surrounded by quotation marks. For example, if you want to replace the string 
"ProductA" used in an axis expression condition such as 
Sum(if(([Product])=("ProductA"),[Quantity],null)) with a document property, then the 
document property needs to be surrounded by quotation marks in order to make the expression 
work: 
Sum(if ( [Product] = "${MyProduct}",[Quantity],null)) 
You can also insert the property as a function rather than as text in order to retrieve the same 
results (see also Insert as Value below): 
Sum(if ( [Product] = DocumentProperty("MyProduct"),[Quantity],null)) 

Insert as Value 
When the value of a property is to be part of an expression, the recommendation is to use the 
standard property functions: ColumnProperty(), DataTableProperty() and DocumentProperty() 
to encapsulate the property name. For example, use this syntax to write an expression with a 
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document property holding an exchange rate times a value column expressed in some currency 
to be converted: 
DocumentProperty("ExchangeRate")*[Value Column] 
Note that the property name should always be written within quotation marks when property 
functions are applied. If you want a property to be interpreted as a value, you should right-click 
on the property in the Available properties for column field and select Insert as Value from the 
pop-up menu. 

 
You can of course also manually edit the syntax for the property. 

List-Valued Properties (Multiple Select) 
Multiple-select properties, or list-valued properties, are based on a list of values instead of a 
single value. They can be created when defining a list box (multiple select) property control. A 
list-valued property cannot be used in all places where a regular single-valued property can be 
applied, but it is an effective way to specify multiple columns on an axis. 

 
List-valued properties often require some additional manual work when used in expressions. 
However, you will in most cases get a hint of what the expression should look like in the current 
context when inserting the property using the Insert Properties button. 
When a list-valued property is added as text to a custom expression (for example, on a 
continuous axis like the Y-axis in a Line Chart or the value axis in a Bar Chart) the syntax will 
be something like $map("sum([${PropertyName}])", ","). In this example, the default 
aggregation is set to "sum", so if you want to use a different aggregation you need to manually 
edit the expression. The concatenation string is set to a comma, which means that each list value 
should be interpreted as a separate column. If the PropertyName property contains a list with 
three columns: "ColumnA", "ColumnB" and "ColumnC", the resulting expression after 
expansion is sum([ColumnA]),sum([ColumnB]),sum([ColumnC]). If the concatenation string is 
changed to a "+", then the axis would show the sum of the values from all columns included in 
the list: sum([ColumnA])+sum([ColumnB])+sum([ColumnC]). 
For a categorical axis, such as the X-axis in a Line Chart or the category axis in a Bar Chart, 
you want to display a hierarchy rather than some calculated values. The map expression must 
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then use angle brackets, "<>", and either NEST or CROSS to define what combinations to 
show. For example: 
<$map("[${PropertyName}]", " NEST")> 
See General Syntax for more information about the NEST and CROSS alternatives. 
Note: As always when setting up expressions with multiple columns, you need to make sure 
that the columns you use are of the same type and that they match the rest of the expression. For 
example, you cannot mix categorical and continuous columns on some axes, nor can you use 
categorical columns in an expression using any type of aggregation. 

More Expression Examples 
If nothing else is stated, the expression examples below assume that you have a data table called 
Data Table containing three integer columns called "Column 1", "Column 2", and "Sales". 

Requested 
result 

Expression example Resulting 
expression 

Sum all integer 
columns in the 
data table called 
Data Table. 

$map("sum([$csearch([Data 
Table],"datatype:int")])","+") 

sum([Column 
1])+sum([Column 
2])+sum([Sales]) 

Return a list of all 
columns in the 
data table called 
Data Table. 

$csearch([Data Table],"*") Column1,Column 2,Sales 

Return an escaped 
column name from 
a property 
(MyProperty) with 
the value "Column 
name with bracket 
(])". 

$esc(${MyProperty}) [Column name with bracket 
(]])] 

Use a list-valued 
property 
expression as input 
to a data function. 
In the example, the 
property 
MyListProperty 
contains three 
column names: 
Column 1, Column 
2, and Sales. 

$map("[Data 
Table].[${MyListProperty}]", ",") 

[Data Table].[Column 
1],[Data Table].[Column 
2],[Data Table].[Sales] 

Use multiple 
columns on an axis 
where one of the 
columns is 
retrieved via a 
property control. 
In the examples, 
the property 
MyProperty has 
the value Column 

[Column 1],[${MyProperty}] 
or 
<[Column 1] NEST [${MyProperty}]> 
or 
Sum([Column 1]), 
Sum(${MyProperty}]) 
etc. 

[Column 1],[Column 2] 
or 
<[Column 1] NEST 
[Sales]> 
or 
Sum([Column 1]), 
Sum(Column 2]) 
etc. 
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2. 

Change the display 
name of multiple 
columns on an axis 
using a list-valued 
property. 
In the example, the 
property 
MyListProperty 
contains three 
column names: 
Column 1, Column 
2 and Sales. 

$map("Sum([${MyListProperty}]) as 
[${MyListProperty}]", ",") 
  
  
  
All list-valued properties in the 
expression must be of the same size. 

Sum([Column 1]) as 
[Column 1],Sum([Column 
2]) as [Column 
2],Sum([Sales]) as [Sales] 

3.1.4.7.2 Troubleshooting Property Expressions 
Since properties can be inserted and interpreted in two different ways, there may be occasions 
where a seemingly correct expression does not work as expected. The following messages may 
be encountered when inserting properties in the Expression field of the Custom Expression 
dialog or the Insert Calculated Column dialog. 
Some of the problems may also occur if you add a property to an axis using Set from Property 
and the expression does not match the axis. In that case, you need to right-click and go to the 
Custom Expression dialog to manually change your expression. Try to identify your problem 
using the table below. 

Error text for 
the 
expression 
field 

Expression 
example 

Possible errors Solution 

The expression is 
not complete. 
  
or 
  
The expression is 
empty. 
  
or 
  
The expression 
cannot be 
evaluated. 

${MyProperty} When a property is 
inserted to an expression 
using double-click or by 
clicking on the Insert 
Properties button, it is 
inserted as text. 
With this syntax, Spotfire 
will try to interpret a string 
property value as a 
column name or a part of 
an expression rather than 
as a value. 

If you want to use the value of the 
string property, put quotation marks 
around the expression: 
"${MyProperty}" 
You can also right-click on the 
property in the Available properties 
for column list and select Insert as 
Value from the pop-up menu instead : 
DocumentProperty("MyProperty") 
  
If the property is supposed to hold a 
column name, but the column name 
contains space characters, you need to 
put "[" and "]" characters around the 
property expression. You can also use 
the $esc() function that both escapes 
any "]" characters and converts the 
property string to a column: 
$esc(${MyProperty}) 
If the property is added using Set 
from Property, you will automatically 
get the escaped version of the 
expression. 
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The expression is 
not complete. 

Concatenate("My first 
string", 
${EmptyProperty}) 

If a string property 
inserted as text is empty 
then it cannot be 
interpreted as a column 
and Spotfire will not see 
that the second argument 
in this example is there at 
all. 

If you want to use the value of the 
string property, put quotation marks 
around the expression: 
Concatenate("My first string", 
"${EmptyProperty}") 
You can also right-click on the 
property in the Available properties 
for column list and select Insert as 
Value from the pop-up menu instead : 
Concatenate("My first string", 
DocumentProperty("EmptyPropert
y")) 
  
If you want to use the content of a 
column in the concatenation, you 
should put '[' and ']' characters around 
the property to make sure the property 
is interpreted as a column (or use 
$esc() as described above). 
Concatenate("My first string", 
[${EmptyProperty}]) 

Invalid type for 
function call 
'DocumentProperty' 

DocumentProperty(M
yProperty) 

The property name should 
always be written within 
quotation marks when 
property functions are 
applied. Quotation marks 
are automatically added if 
you use the Insert as Value 
shortcut from the pop-up 
menu. 

Put quotation marks around the 
property name: 
DocumentProperty("MyProperty") 

Expected 'End of 
expression' but 
found ',' on line 1 
character 12 
  
or 
  
The expression is 
not valid 

$map("sum([${MyList
Property}])", ",") 
  

When list-valued 
properties are used on an 
axis you need to map the 
list-valued properties to a 
single string. The 
expression must contain a 
template to use for each 
value in the list (e.g., an 
aggregation measure) and 
also a specification of how 
the list values should be 
connected in the resulting 
expression. 
The default expression 
obtained when first 
inserting the property is 
suitable for continuous 
axes where a simple 
listing of the columns 
included in the list-valued 
property is desired. In all 
other cases it must be 
manually modified. 

Depending on what you want to 
display you need to modify the default 
expression somewhat differently. 
If a simple listing of column names is 
desired (e.g., if you want to show 
multiple columns on a bar chart value 
axis), then the expression in the 
example works fine. If you want to 
use an aggregation measure other than 
"sum" simply replace "sum" in the 
expression. 
If the list of columns is to be shown 
on a categorical axis, you need to 
modify the default expression to 
something like this: 
<$map("[${MyListProperty}]", 
"NEST")> 
Categorical expressions must be 
surrounded by angle brackets, "<>", 
and you must also specify how 
different combinations of categories 
should be handled. 
Also, the current selection of columns 
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  in the list-valued property may be a 
mixture of continuous and categorical 
columns. Make sure that only 
columns of the same type are included 
in the property list. 
There are also more cases where the 
expression needs to be modified. See 
the section List-Valued Properties 
(Multiple Select) under Properties in 
Expressions for more information. 

Expected ':' but 
found '3' on line 1 
character 5 

${TimeSpanProperty} If you try to use a 
TimeSpan, Date, Time or 
DateTime property in an 
expression, the expression 
language will not be able 
to interpret it correctly 
without some manual 
editing. 
First, it needs quotation 
marks around the property 
name. This will interpret 
the property as a string 
and you will be able to get 
rid of the error. Second, 
you need to use one of the 
conversion functions in 
order to actually interpret 
the value as a TimeSpan, 
Date, Time or DateTime. 

Put quotation marks around the 
property name and use the 
corresponding conversion function: 
TimeSpan("${TimeSpanProperty}") 
You can also right-click on the 
property in the Available properties 
for column list and select Insert as 
Value from the pop-up menu instead : 
TimeSpan(DocumentProperty("Ti
meSpanProperty")) 

{Table is undefined 
in ${{Table} 

${{Table}}.{MyProper
ty} 

If a name contains right 
curly bracket (}) it needs 
to be escaped by a 
backslash character (\). 

To access the data table property 
MyProperty in a data table that is 
named "{Table}" one must write 
${{Table\}}.{MyProperty}. 

More about $esc and $csearch: 
$esc(expression) 
The $esc() function is used to escape "]" which normally denotes the end of a column from 
column names and adds "[" and "]" to the column name. The brackets are required for column 
names containing space characters to be interpreted as columns. $esc() can be used together 
with the $csearch() function. The argument is an expression which could be a property value or 
a property function that starts with a dollar sign ($). 
For example, let the data table "A Data Table" have three columns called "Column 1","Column 
2[example]", and "Sales".  The expression $esc($csearch([A Data Table], "Col*")) returns a list 
with two elements—the strings "[Column 1]" and "[Column 2[example]]]". 
$csearch([Data Table], "search string") 
The $csearch() function is used to produce a "filtered" list of column names. It allows you to 
select a number of columns from a data table using a limiting search expression. This function 
is likely to be used together with the $map() function. The first argument is a data table and the 
second argument is a string that contains the search expression to be used to determine what 
column names should be returned. The function returns a list of (unescaped) column names 
contained in the data table that fulfills the search expression. 
For example, let the data table "A Data Table" have three columns called "Column 1", "Column 
2", and "Sales". The expression $csearch([A Data Table], "Col*") returns a list with two 
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elements—the strings "Column 1" and "Column 2". If the property MyTable contains the string 
[A Data Table] and the property MyA contains the string "Col*" then $csearch(${MyTable}, 
"${MyA}") will return the same result. 
$csearch together with $map() and $esc() can produce column lists or calculations based on 
columns from list-valued properties. For example, $map("sum($esc($csearch(${MyTable}, 
"*")))", "+") is expanded to sum([Column 1])+sum([Column 2])+sum([Sales]) since the search 
expression * will return all columns in the table. The $esc() function is necessary if you want 
the strings in the list to be interpreted as columns and the column names contain space 
characters. 
Note: $csearch() is primarily intended to be used in visualization axis expressions or included 
in data function argument expressions. While $csearch() is looking at all columns in a data 
table, including any calculated columns, it is less suitable for use in calculated columns. If used 
in a calculated column, cyclic dependencies may occur. 

3.2 Insert Binned Column 
3.2.1 What is Binning? 

Binning is a way to group a number of more or less continuous values into a smaller number of 
"bins". For example, if you have data about a group of people, you might want to arrange their 
ages into a smaller number of age intervals. Numeric columns can also be temporarily grouped 
by right-clicking on a column selector and clicking Auto-bin Column. 

Example: 
The data table contains information about a number of persons. 

 
By binning the age of the people into a new column, data can be visualized for the different age 
groups instead of for each individual. 
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3.2.2 How to Use Binning 
► To use the binning tool: 

1. Select Insert > Binned Column.... 
2. If you have more than one data table in the document, select the Data table to work 

on. 
3. Select a Column to bin. 
4. Select a Bin method: 

Specific Limits 
Allows you to explicitly enter values, separated by semicolons, of the limits to use for 
each bin. 
Even Intervals 
Allows you to specify the desired number of bins and divides the value range into 
equal intervals. 
Even Distribution of Unique Values 
Allows you to specify the desired number of bins and divides the bins so that each one 
contains an equal number of unique values. 
Based on Standard Deviation 
Allows you to divide the range into sections as described by the selected standard 
deviation multipliers. 
Substring 
Allows you to group the values by the first or last characters in the column to be 
binned. 

5. Type a New column name for the binned column. 
6. Click OK. 

3.2.3 Details on Insert Binned Column 
► To reach the Insert Binned Column dialog: 
Select Insert > Binned Column.... 
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Option Description 

Data table Only available when more than one data table is present in the analysis 
and the dialog has been opened via the main menu. 
Specifies the data table where the binned column will be inserted. 

Column Displays the available columns on which you can perform binning. It 
is possible to search for columns by typing in the field provided when 
the drop-down list is expanded. The values from the selected column 
will be sorted into several bins or categories based on your selections. 

Specific limits Allows you to explicitly enter the values of the limits to use for each 
bin. 
  
Enter the values you wish to use for the limits of your bins and 
separate them with a semicolon. For example, typing "20;30;40" will 
result in the  following bins: 
x<=20 
20<x<=30 
30<x<=40 
40<x 

Even intervals Allows you to specify the desired number of bins and divides the value 
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range into equal intervals. 
  
This method works for all data types except string. The current data 
range is divided up into the specified number of bins. Empty values 
will be empty in the new column, and when loading data tables from 
external sources (linked data), new values will be placed inside one of 
the available bins. 

Even distribution 
of unique values 

Allows you to specify the desired number of bins and divides the bins 
so that each one contains an equal number of unique values. 
  
The suggested division works for all data types and is made so that the 
bins each contain an equal number of unique values. Extra values are 
placed in the final bins, so if you have four values and you want three 
bins with one value in each bin, your final value will be placed in the 
third bin. Empty values will be empty in the new column, and when 
loading data tables from external sources (linked data) the bin ranges 
will be modified to fit the new data range. 

Based on standard 
deviation 

Divides the range into sections as described by the selected standard 
deviation multipliers. 
  
This method works for numeric columns only. The range is divided 
into sections as described by the selected standard deviation 
multipliers. Bins are created using any of the standard deviations +/- 
0.5, 1, 2, 3, 6. In the example below, the range is divided into the 
following six subsections (µ denoting the average value for the column 
and s the corresponding standard deviation): 
lower limit -> (µ-3s) 
(µ-3s) -> (µ-s) 
(µ-s) -> µ 
µ -> (µ+s) 
(µ+s) -> (µ+3s) 
(µ+3s) -> upper limit 
Empty values will be empty in the new column, and when loading data 
tables from external sources (linked data) the standard deviation will 
be recalculated. 

Substring Groups the rows by the first or last characters of the values in the 
column to be binned. The exact number of characters to take into 
account must be supplied. 
Example: 
Suppose the column to be binned contains family names, beginning 
with Adams and ending with Winter. To bin the rows according to the 
first letter in the name, use the Substring option considering one 
character from the beginning. Bin names are generated from the 
substring, and if Ignore case is used, the bin names are all formatted as 
upper case. 
  
Empty values will be empty in the new column, and when loading data 
tables from external sources (linked data) the new values will be 
placed in suitable bins, taking the substrings into consideration. 

New column name The name of the new, binned column. 
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3.2.4 The Binning Slider 
When using a numeric column for the X-axis in a visualization (the category axis in a bar 
chart), you sometimes may want to bin the values to compare segments of the data to each 
other. One very handy tool to help you dynamically do this is the binning slider. 
The bar chart below shows the average purchases of a customer group, where each bar 
represents the age of the customers. 

 
By right-clicking on the category axis selector, and selecting Auto-bin Column, the bars are 
automatically binned. In the example below there are five bins, which means all customers 
between 0 to 29 are gathered in the first bar, customers between 30 to 41 in the second bar, and 
so on. 

 
As you see there is a small slider with a handle just above the axis selector. This is the binning 
slider. By dragging this horizontally, you can alter the number of bins dynamically. In the 
example below, the slider has been set to show 20 bins. 
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3.3 Insert Columns from External Data 
3.3.1 How to Insert Columns from External Data 

► To insert columns from external file: 
1. Select Insert > Columns from External Data.... 
2. If you have more than one data table in the document, select the Data table to work 

on. 
3. Click the File radio button. 
4. Type a Location or click on Browse... to locate the file with additional data. 

Response: If the selected file is a text file, the Import Settings dialog is displayed. If 
the selected file is an Excel file, the Excel Import dialog is displayed. 
Apply transformations (optional). 

5. Click Next >. 
Comment: If you want the columns to be matched automatically, go straight to step 11. 
Response: The second dialog of the wizard is displayed. 

6. Click on the Match All Possible button, or manually select one column from current 
data and one from new data and click Match Selected. Repeat if necessary. 
Comment: The columns used for matching should together create a unique identifier 
for all rows. 

7. Click Next >. 
Response: The third dialog of the wizard is displayed. 

8. Select the check boxes for all columns that you wish to add from the new data. 
9. Select a Join method to determine which rows to keep from both data tables. 

Comment: Note that selecting an inner join may result in that no data remains in 
TIBCO Spotfire, if no matching rows are found. 

10. Click Finish. 
Response: The selected columns are added to your data table. 

► To insert columns from an information link: 
1. Select Insert > Columns from External Data.... 
2. If you have more than one data table in the document, select the Data table to work 

on. 
3. Click the Information Link radio button. 
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4. Click on Browse... to locate the information link with additional data. 
Response: The Open Information Link dialog is displayed. 

5. In the tree structure to the left, click to select the information link of interest and then 
click Open. 

6. Apply transformations (optional). 
7. Click Next >. 

Comment: If you want the columns to be matched automatically, go straight to step 12. 
Response: The second dialog of the wizard is displayed. 

8. Click on the Match All Possible button, or manually select one column from current 
data and one from new data and click Match Selected. Repeat if necessary. 
Comment: The columns used for matching should together create a unique identifier 
for all rows. 

9. Click Next >. 
Response: The third dialog of the wizard is displayed. 

10. Select the check boxes for all columns that you wish to add from the new data. 
11. Select a Join method to determine which rows to keep from both data tables. 

Comment: Note that selecting an inner join may result in that no data remains in 
TIBCO Spotfire, if no matching rows are found. 

12. Click Finish. 
Response: The selected columns are added to your data table. 

► To insert columns from a database: 
1. Select Insert > Columns from External Data.... 
2. If you have more than one data table in the document, select the Data table to work 

on. 
3. Click the Database radio button. 
4. Click on Browse... to locate the database with additional data. 

Response: The Open Database dialog is displayed. 
5. Follow the instructions for the desired data source type under Opening Data from a 

Database. 
6. Apply transformations (optional). 
7. Click Next >. 

Comment: If you want the columns to be matched automatically, go straight to step 12. 
Response: The second dialog of the wizard is displayed. 

8. Click on the Match All Possible button, or manually select one column from current 
data and one from new data and click Match Selected. Repeat if necessary. 
Comment: The columns used for matching should together create a unique identifier 
for all rows. 

9. Click Next >. 
Response: The third dialog of the wizard is displayed. 

10. Select the check boxes for all columns that you wish to add from the new data. 
11. Select a Join method to determine which rows to keep from both data tables. 

Comment: Note that selecting an inner join may result in that no data remains in 
TIBCO Spotfire, if no matching rows are found. 

12. Click Finish. 
Response: The selected columns are added to your data table. 
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3.3.2 Details on Insert Columns from External Data - 
Select Destination 

This step is only visible if you have more than one data table open in the document. 

 

Option Description 

Add columns to 
data table 

Specifies which data table to add columns to. 

Next > Continues to the next step of the wizard where the data source to add 
data from is selected. 
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3.3.3 Details on Insert Columns from External Data - 
Select Source 

 

Option Description 

Add columns from   

  File Allows you to add columns from files. 

  Information Link Allows you to add columns from information links. 

  Database Allows you to add columns from any supported database. 

  Clipboard Allows you to add columns from the clipboard. 

  Existing data table 
in my analysis 

Allows you to add columns from the current analysis. 

Location Shows the path and file name of the selected file. 

Browse... Opens a dialog where you can select which file, information link, or 
database to open. 

Show transformations Expands the dialog and allows you to apply transformations on the 
columns you want to add. For more information, see the Show 
transformations dialog. 

Next > Continues to the next step of the wizard where the matching 
columns are selected. 

Finish Automatically matches all columns with the same external ID or, of 
subordinate importance, the same name. The columns that were not 
used in the matching are also added to the data table. 
Note: If you have columns with identical names that do not contain 
the same identifiers, this option might result in that no data is 
added. In that case, it is probably better to use the Next > button 
(see above), and match on columns that contain correct identifiers. 
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3.3.4 Details on Insert Columns from External Data - 
Match Columns 

 

Option Description 

From current data Lists all columns in the current data. Click here to select the column 
you wish to match against a column from the new data, then click 
Match Selected. 

From new data Lists all columns in the new data. Click here to select the column you 
wish to match against a column from the current data, then click Match 
Selected. 

Match Selected Sends the selected column pair (From current data and From new data) 
to the Matched columns list. 

Match All Possible Sends all column pairs that have the same external ID or, of 
subordinate importance, columns with the same name to the Matched 
columns list. 

Matched columns Lists all column pairs that have been selected for matching. 

Unmatch Selected Removes the selected column pair from the Matched columns list. 

Unmatch All Removes all column pairs from the Matched columns list. 

Next > Continues to the next step of the wizard where the columns to add and 
the join method are selected. 
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Finish Adds all available columns that were not used in the matching to the 
data table using a left outer join. 

3.3.5 Details on Insert Columns from External Data - 
Import 

 

Option Description 

Columns to add 
from new data 

Lists all columns in the new data that can be added to the current data 
table. Only columns that have not been used in a matching in the 
previous step are available. Select the check box for all columns you 
wish to add. 

Select All Selects the check boxes for all available columns. 

Clear All Clears the check boxes for all available columns. 

Join method   

  Left outer Data will be kept (and columns added) only for rows that are available 
in the current data table. If additional rows exist in the new data, they 
will not be added to the current data table. 

  Full outer Data will be kept (and columns added) for all rows available in any of 
the data tables. If additional rows exist in the new data, they will be 
added to the current data table. 

  Inner Data will be kept (and columns added) only for rows that are available 
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in both the current and the new data. If the new data contains fewer 
rows than the current data table, rows will be removed from the current 
data table after this operation. 

  Right outer Data will be kept (and columns added) only for rows that are available 
in the new data. If the new data contains fewer rows than the current 
data table, rows will be removed from the current data table after this 
operation. 

Finish Adds the selected columns to the selected data table in Spotfire. 

3.4 Insert Rows from External Data 
3.4.1 How to Insert Rows from External Data 

► To insert rows from external file: 
1. Select Insert > Rows from External Data.... 
2. If you have more than one data table in the document, select the Data table to work 

on. 
3. Click the File radio button. 
4. Type a Location or click on Browse... to locate the file with additional data. 

Response: If the selected file is a text file, the Import Settings dialog is displayed. If 
the selected file is an Excel file, the Excel Import dialog is displayed. 
Apply transformations (optional). 

5. Click Next >. 
Comment: If you want the rows to be matched automatically, go straight to step 11. 
Response: The second dialog of the wizard is displayed. 

6. Click on the Match All Possible button, or manually select one column from current 
data and one from new data and click Match Selected. Repeat if necessary. 
Comment: The columns used for matching should together create a unique identifier 
for all rows. 

7. Click Next >. 
Response: The third dialog of the wizard is displayed. 

8. If the new data contains more columns than the original data table, you may add the 
new columns by selecting their check boxes. 

9. If desired, you can add information about the origin of new rows to a specified column. 
Comment: Update existing column is only relevant when rows have been previously 
added to the document. 

10. Click Finish. 
Response: The selected columns are added to your data table. 

► To insert rows from information link: 
1. Select Insert > Rows from External Data.... 
2. If you have more than one data table in the document, select the Data table to work 

on. 
3. Click the Information Link radio button. 
4. Click on Browse... to locate the information link with additional data. 

Response: The Open Information Link dialog is displayed. 
5. In the tree structure to the left, click to select the information link of interest and then 

click Open. 
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6. Apply transformations (optional). 
7. Click Next >. 

Comment: If you want the rows to be matched automatically, go straight to step 12. 
Response: The second dialog of the wizard is displayed. 

8. Click on the Match All Possible button, or manually select one column from current 
data and one from new data and click Match Selected. Repeat if necessary. 
Comment: The columns used for matching should together create a unique identifier 
for all rows. 

9. Click Next >. 
Response: The third dialog of the wizard is displayed. 

10. If the new data contains more columns than the original data table, you may add the 
new columns by selecting their check boxes. 

11. If desired, you can add information about the origin of new rows to a specified column. 
Comment: Update existing column is only relevant when rows have been previously 
added to the document. 

12. Click Finish. 
Response: The selected columns are added to your data table. 

► To insert rows from a database: 
1. Select Insert > Rows from External Data.... 
2. If you have more than one data table in the document, select the Data table to work 

on. 
3. Click the Database radio button. 
4. Click on Browse... to locate the database with additional data. 

Response: The Open Database dialog is displayed. 
5. Follow the instructions for the desired data source type under Opening Data from a 

Database. 
6. Apply transformations (optional). 
7. Click Next >. 

Comment: If you want the rows to be matched automatically, go straight to step 12. 
Response: The second dialog of the wizard is displayed. 

8. Click on the Match All Possible button, or manually select one column from current 
data and one from new data and click Match Selected. Repeat if necessary. 
Comment: The columns used for matching should together create a unique identifier 
for all rows. 

9. Click Next >. 
Response: The third dialog of the wizard is displayed. 

10. If the new data contains more columns than the original data table, you may add the 
new columns by selecting their check boxes. 

11. If desired, you can add information about the origin of new rows to a specified column. 
Comment: Update existing column is only relevant when rows have been previously 
added to the document. 

12. Click Finish. 
Response: The selected columns are added to your data table. 
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3.4.2 Details on Insert Rows from External Data - Select 
Destination 

This step is only visible if you have more than one data table open in the document. 

 

Option Description 

Add rows to data 
table 

Specifies which data table to add rows to. 

Next > Continues to the next step of the wizard where the data source to add 
data from is selected. 
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3.4.3 Details on Insert Rows from External Data - Select 
Source 

 

Option Description 

Add rows from   

  File Allows you to add rows from files. 

  Information Link Allows you to add rows from information links. 

  Database Allows you to add rows from any supported database. 

  Clipboard Allows you to add rows from the clipboard. 

  Existing data table 
in my analysis 

Allows you to add rows from the current analysis. 

Location Shows the path and file name of the selected file. 

Browse... Opens a dialog where you can select which file, information link, or 
database to open. 

Show 
transformations 

Expands the dialog and allows you to apply transformations on the 
rows you want to add. For more information, see the Show 
transformations dialog. 

Next > Continues to the next step of the wizard where the matching 
columns are selected. 

Finish Automatically matches all columns with the same external ID or, of 
subordinate importance, the same name. The columns that were not 
used in the matching are also added to the data table. 
Note: If you have columns with identical names that do not contain 
the same identifiers, this option might result in that no data is added. 
In that case, it is probably better to use the Next > button (see 
above), and match on columns that contain correct identifiers. 
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3.4.4 Details on Insert Rows from External Data - Match 
Columns 

 

Option Description 

From current data Lists all columns in the current data. Click here to select the column 
you wish to match against a column from the new data, then click 
Match Selected. 

From new data Lists all columns in the new data. Click here to select the column you 
wish to match against a column from the current data, then click Match 
Selected. 

Match Selected Sends the selected column pair (From current data and From new data) 
to the Matched columns list. 

Match All Possible Sends all column pairs that have the same external ID or, of 
subordinate importance, columns with the same name to the Matched 
columns list. 

Matched columns Lists all column pairs that have been selected for matching. 

Unmatch Selected Removes the selected column pair from the Matched columns list. 

Unmatch All Removes all column pairs from the Matched columns list. 

Next > Continues to the next step of the wizard where it is possible to 
determine if additional columns should be included and whether or not 
to use a column to identify the origin of new rows. 
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Finish Adds all available new rows and includes data from any new columns 
that were not used in the matching. 

3.4.5 Details on Insert Rows from External Data - 
Additional Settings 

 

Option Description 

Include additional 
columns from the 
new data 

Lists all columns in the new data that can be added to the current data 
table. Only columns that have not been used in a matching in the 
previous step are available. Select the check box for all columns you 
wish to add. 

Select All Selects the check boxes for all available columns. 

Clear All Clears the check boxes for all available columns. 

Identify origin of 
new rows 

Select the check box if you want to use a column with information 
about the origin of the new (and the original) rows. 

  Create new 
column 

Use this option if you have not previously added any rows and created 
a "column of origin". 

  Update existing 
column 

Use this option when you add rows from many different sources and 
want to update a previously added "column of origin". 

Column name The column name of the "column of origin". 
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Value for new 
rows 

The value you want to tag all new rows with. 

Value for original 
rows 

The value you want to tag all original rows with. This option is only 
available when you create a new column. Once a "column of origin" 
has been created, all previously added values will be kept when the 
column is updated. 

Finish Adds the selected rows and (optionally) columns to the specified data 
table in Spotfire. 

3.5 Add Data Tables 
3.5.1 How to Insert Multiple Data Tables into the Analysis 

Data can be added to the analysis in several different ways: as new columns, as new rows or as 
new data tables. Adding data as separate data tables is useful if the new data are unrelated to the 
previously opened data table or if the new data are in a different format (pivoted vs. unpivoted). 
If you have a visualization made from a particular data table which has filtering and marking 
that you would like to apply to visualizations made from another data table, then you must 
define a relation between the two tables. For a relation to be useful, you need to have one or 
more key columns (identifier columns) available in both data tables, and use these to define 
which rows in the first data table will correspond to rows in the second data table. If you need 
more than one key column to set up a unique identifier, you must add one relation for each 
identifier column. 
Note: The map chart is the only visualization where you can use different data tables in the 
same visualization. If you need to bring data from different data sources together in any other 
single visualization, use the Insert Columns from External Data or Insert Rows from External 
Data tool instead. 

► To add new data tables to the analysis: 
1. Select File > Add Data Tables.... 

Response: The Add Data Tables dialog is displayed. 
2. Click Add and select the type of data to add from the drop-down list. 

Comment: You can add data tables from files, information links, databases, the 
clipboard, data functions or from current data tables within your analysis. You may 
also have access to other sources if they have been set up by your administrators. 
Response: Depending on your selection you will be presented with a dialog where you 
can specify which file, information link, etc., to add. If you need more information on 
specific data sources, see Opening a Text File, Opening an Excel File, Opening a SAS 
File, Opening an Information Link or Opening Data from a Database. 

3. Select the source data and specify any required settings. 
4. If desired, type a new Data table name. 
5. Apply transformations (optional). 
6. If you want to add more data tables, repeat steps 2-5 for each data table. 
7. Determine whether or not the new data tables will be related to each other or to 

previously added data tables. If a relation is necessary, click Manage Relations... and 
specify the relation. 
Comment: See To define a new relation below for more information. Remember that 
you need to define a relation if the new data table is to be used to create details 
visualizations for the previously added data tables. 

8. Click OK. 
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Response: The new data tables are incorporated into the analysis and are ready to be 
used. 

Note: If you want to add a new data table that is loaded on demand you should instead use the 
File > Add On-Demand Data Table option. See Loading Data on Demand for more 
information. 

► To define a new relation: 
1. In the Add Data Tables dialog, click Manage Relations.... 

Response: The Manage Relations dialog is displayed. 
2. Click on New.... 

Response: The New Relation dialog is displayed. 
3. Select the two data tables you want to connect from the Left data table and Right 

data table drop-down lists. 
4. Select the columns containing the identifiers from the Left column and Right column 

drop-down lists. 
5. If desired, you can apply a Left method or Right method to modify the values of one 

or both columns. 
Comment: For example, if the identifiers are written in uppercase letters in one of the 
data tables and in lowercase letters in the other, you can use the Lower method on the 
uppercase column and change the letters to lowercase. 
Response: The result of the method application is shown in the Sample field. 

6. Click OK. 
Tip: You can always go back and edit relations as well as create new ones using the Data Table 
Properties dialog. 

3.5.2 Details 

3.5.2.1 Details on Add Data Tables 
Use this dialog to add one or more data tables to your analysis. You can also apply one or more 
transformation steps before adding the new data table. 
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Option Description 

Data tables Lists all data tables that you have selected to add to the analysis, 
along with information about their origin and any transformations. 

Add   

  Files... Allows you to add a data table from a file. 

  Information Link... Allows you to add a data table from an information link. 

  Database... Allows you to add a data table from any supported database. 

  Clipboard Allows you to add a data table from the clipboard. 

  Data Function... Allows you to add a data table from a data function. 

  From Analysis Allows you to add a data table from the current analysis. For 
example, you may want to pivot or otherwise transform the data in 
an already existing data table, but you also want to keep the original 
data in the analysis. 

Remove Removes the selected data table from the list. 

Name Allows you to change the name of the selected data table. 

Show 
transformations 

Expands the dialog and allows you to apply transformations on the 
data table you want to add. For more information, see Details on 
Show Transformations. 

Manage Relations... Opens the Manage Relations dialog where you can specify how the 
new data tables are related to each other or any previously loaded 
data tables in your analysis. 

3.5.2.2 Details on Manage Relations 
This dialog is used to manage relations between both new and previously added data tables in 
your analysis. 

► To reach the Manage Relations dialog: 
1. Select Edit > Data Table Properties. 
2. Go to the Relations tab. 
3. Click on Manage Relations.... 
4. Comment: You can also reach the Manage Relations dialog from the Data page of the 

Map Chart Visualization Properties, or from the Add Data Tables or the Add On-
Demand Data Table dialogs. 



TIBCO Spotfire 4.0.2 - User's Manual 

176 

 

Option Description 

Show relations for Select the data table whose relations you wish to view, or select All 
data tables to view all relations in the document. 

Relations Lists all relations for the selected data table or all relations in the 
document, depending on your selection above. 
Note: If one or more relations have become invalid, these will appear 
in red. 

New... Opens the New Relation dialog where you can define a new relation 
between two data tables. 

Edit... Opens the Edit Relation dialog where you can edit the relation selected 
in the Relations list. 

Delete Removes the selected relation from the Relations list. 

3.5.2.3 Details on New/Edit Relation 
This dialog is used to define a relation between two data tables. 
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Option Description 

Left data table Lists all data tables currently available in the analysis. Select one of the 
data tables for which you wish to define a relation. 

Right data table Lists all data tables currently available in the analysis. Select the data 
table you wish to relate to the previously selected left data table. If you 
reached this dialog via an add data table procedure, then the new data 
tables will be the only ones available here. 

Left column Lists all columns available in the left data table. Select the column to 
be used in the matching of rows. 

Right column Lists all columns available in the right data table. Select the column to 
be used in the matching of rows. 

Left method If desired, modifies the content of the selected left column according to 
the selected method. What methods are available depends on the data 
type of the selected column. For example, for a string column it is 
possible to use the methods "Lower" or "Upper" to convert the strings 
to lowercase or uppercase, respectively. 

Right method If desired, modifies the content of the selected right column according 
to the selected method. What methods are available depends on the 
data type of the selected column. For example, for a string column it is 
possible to use the methods "Lower" or "Upper" to convert the strings 
to lowercase or uppercase, respectively. 

Sample value Displays the resulting first value of the selected left or right column 
after any specified methods have been applied. 

3.5.2.4 Details on Browse for Data Table 
This dialog is shown when you have selected to add a data table or additional columns or rows 
from an existing data table, and you have more than one data table available in the analysis. 

 
Select the data table from which you wish to add or replace data using the drop-down list. 

3.5.2.5 Details on Data Function - Select Input 
This dialog allows you to define how the input parameters of the selected data function should 
be handled when adding data tables. It is necessary to specify a mapping of all required 
parameters to Spotfire in order to use the data function. 

► To reach the Data Function - Select Input dialog: 
1. Select File > Add Data Tables.... 

Response: The Add Data Tables dialog is displayed. 
2. Select Add > Data Functions.... 

Response: The Data Functions - Select Function dialog is displayed. 
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3. Click to select the function of interest from the list, then click OK. 
Comment: If no previously added data are available in your document, you will only 
be able to select data functions with values as input. 

 

Option Description 

Refresh function 
automatically 

Select this check box to update the results from the data function 
automatically each time the input settings are changed. If the check 
box is cleared, a manual refresh is needed in order for any updates to 
take effect. 
A data function set to load automatically will switch to manual update 
if cyclic dependencies are detected in the analysis. 

Input parameters Lists all input parameters that have been defined for the selected data 
function. Select an input parameter in this list to edit its settings. 

Input handler Lists all possible input handlers for the selected input parameter. 
Depending on which input handler you select in this list, a different set 
of settings is available to the lower right in the dialog. 

[Input handler 
settings] 

See the table below. 

OK Adds the selected data function to the Add Data Tables dialog. 

Input Handler Settings 
Note that which input handlers are available depends on the type of input parameter that is 
selected (Value, Column or Table). You will not be able to select from all of the input handlers 
described below when specifying the input for a selected parameter. 

Option Description 

Column   

   Data table Allows you to select the data table from which to retrieve the 



Adding Data 

179 

input column. 

   Column Allows you to specify which column to use as input from the 
selected data table. 

   Limit by Use a combination of filtering and markings to limit the 
calculations to rows matching the specified settings only. If more 
than one option is selected, then calculations will be performed 
for rows matching the intersection of the selected filtering and 
markings only. 
Leave both the Filtered rows and the Marked rows check boxes 
blank to base calculations on all rows. 

      Filtered rows Select this check box to limit the calculations to rows remaining 
after filtering with the specified filtering scheme. 

      Marked rows Select this check box to limit the calculations to rows marked by 
the selected markings. 
If more than one marking is available in your analysis, you need 
to determine which marking or markings to control the 
calculation. If more than one marking is selected, then 
calculations will be performed for rows matching the intersection 
of the markings. 

Columns   

   Data table Allows you to select the data table from which to retrieve the 
input columns. 

   Columns Lists the selected input columns. Click Select Columns... to 
change columns. 

   Select Columns... Opens a dialog where you can specify which columns to include 
as input to the function. 

   Limit by See a description of the options under Column above. 

Expression   

   Data table Allows you to select the data table to evaluate the expression 
against. 

   Expression Displays the expression. 

   Edit... Opens the Edit Expression dialog where you can specify an 
expression. 

   Limit by See a description of the options under Column above. 

Value   

   Value Allows you to type an input value in the text box. 

Document property   

   Property Allows you to select a document property to use as input. Use the 
search field to help locate your property. 
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   New... Opens the New Property dialog where you can define a new 
document property to use as an input parameter. 

   Edit... Opens the Edit Property dialog where you can change the value of 
the selected property. 

   Delete Deletes the selected property. 

Data table property   

   Data table Allows you to select the data table to work with. 

   Property Allows you to select a data table property to use as input. Use the 
search field to help locate your property. 

   New... Opens the New Property dialog where you can define a new data 
table property to use as an input parameter. 

   Edit... Opens the Edit Property dialog where you can change the value of 
the selected property. 

   Delete Deletes the selected property. 

Column property   

   Data table Allows you to select the data table to work with. 

   Column Allows you to select which column to work with. 

   Property Allows you to select the column property you wish to use as 
input. 

   New... Opens the New Property dialog where you can define a new 
column property to use as an input parameter. 

   Edit... Opens the Edit Property dialog where you can change the value of 
the selected property. 

   Delete Deletes the selected property. 

None No input handler has been selected. This can be used for optional 
input parameters. If the input parameter is required, you must 
specify a different input handler to be able to continue. 
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3.6 Add On-Demand Data Table 
3.6.1 On-Demand Overview 

When an information link is to be added to the analysis as a new data table, you have the option 
to either load all data at once, or to load data on demand only. Your analysis can benefit from 
on-demand loading when you have access to massive amounts of data, but you only need to 
work with some parts of the data at a time. When setting up an on-demand data table you can 
specify conditions based on one or more other data tables to control what to load. You can also 
start by letting an on-demand data table be the first (or only) data table in the analysis if its input 
is defined by a document property. 

 

3.6.2 Loading Data on Demand 
Select File > Add On-Demand Data Table... to load data on demand. 
The on-demand loading of information links can be controlled by specifying one or more 
conditions that need to be met for data to be loaded. See Example of Marking Controlled On-
Demand Details Visualization and Example of Property Controlled On-Demand Data for 
examples of how to configure the on-demand loading in those cases. 
Conditions can be set in a number of different ways. For example, they could be determined by 
the value of a property or an expression, or by the values of the filtered or marked rows in a 
column from another data table. If the selected information link has been set up with required 
prompts or parameters, then these will automatically be required parameters for the on-demand 
loading and you must specify a condition using the Define Input button for each required 
parameter. 
If desired, you can apply a transformation to the data prior to loading. While the transformation 
will be performed on the data corresponding to the condition only, you may gain some 
performance by doing the transformation here rather than conditioning the entire information 
link directly. 
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Examples of Conditions 

What to 
control  
on-demand 
loading 

How to set it up 

Marking in another 
data table. 

1. Click to select the column of interest from the Define input for 
parameters that should control loading list. 
2. In the Define Input dialog, set Input for the selected parameter to 
Values from column. 
3. Select the Data table from the analysis where you want to mark 
data. 
4. Select the Column from the selected data table to match against the 
column in the information link. 
5. Select to Limit by Marked rows by selecting the check box. 

Filtering in another 
data table. 

1. Click to select the column of interest from the Define input for 
parameters that should control loading list. 
2. In the Define Input dialog, set Input for the selected parameter to 
Values from column. 
3. Select the Data table from the analysis where you want to mark 
data. 
4. Select the Column from the selected data table to match against the 
column in the information link. 
5. Select to Limit by Filtered rows by selecting the check box. 

A range of values 
defined by the min 
and max values 
from the current 
marking or filtering, 
for a selected 
column. 

1. Click to select the column of interest from the Define input for 
parameters that should control loading list. 
2. In the Define Input dialog, set Input for the selected parameter to 
Range from column. 
3. Select the Data table from the analysis where you want to mark 
data. 
4. Select the Column from the selected data table to match against the 
column in the information link. 
5. Select to Limit by Marked rows or Filtered rows by selecting the 
corresponding check box. 

A document 
property value. 

1. Click to select the column/parameter of interest from the Define 
input for parameters that should control loading list. 
2. In the Define Input dialog, set Input for the selected parameter to 
Values (fixed/properties/expression). 
3. Click the Property radio button. 
4. Click Select... and specify which document property to use in the 
dialog that opens. 

An expression. 1. Click to select the column/parameter of interest from the Define 
input for parameters that should control loading list. 
2. In the Define Input dialog, set Input for the selected parameter to 
Values (fixed/properties/expression). 
3. Click the Expression radio button. 
4. Click Edit... and specify your custom expression. 
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All values over (or 
under) a certain 
limit, e.g., Sales > 
1000. 

1. Click to select the column/parameter of interest from the Define 
input for parameters that should control loading list. 
2. In the Define Input dialog, set Input for the selected parameter to 
Range (fixed/properties/expression). 
3. In the field of interest (e.g., Min) click the Fixed value radio button. 
4. Type the value of interest in the field or click Select... to pick a 
value from the available values in the column. 

The data retrieved for the on-demand data table can be based on a combination of all of the 
examples above. 
Note: Special attention is needed when setting up an on-demand data table dependent on 
nothing but a parameter defined within a configuration block (a text file which configures the 
initial state of an analysis, see Spotfire Technology Network). An on-demand data table must 
always have at least one input defined for the parameter in the Add On-Demand Data Table 
dialog. Since configuration block parameters will automatically be assigned to document 
properties (if they exist and have the appropriate data type), a document property may act as a 
bridge between a configuration block parameter and a parameter in an information link. If 
another input is defined, such as a column filter, no such bridge is required and the parameter 
from the configuration block will be used automatically. 
  

3.6.3 Example of Marking Controlled On-Demand Details 
Visualization 

If you have selected to load data on demand, and specified a marking that should control what 
data to be loaded you will end up with the following scenario: 
When you mark items in a visualization that uses the specified marking, the data for the on-
demand data table is updated. The update can either be done automatically each time you 
change the marking, or manually by clicking on the refresh button displayed when the marking 
is changed. 
This way, you can create a master visualization in which to specify the item of interest and a 
details visualization where more information about the marked item is loaded from the database 
only when requested. 

► To set up a marking controlled on-demand data table: 
When one identifier column in the first data table is matched by an identifier column in the on-
demand data table, the on-demand data table should be set up using the following steps: 

1. Select File > Add On-Demand Data Table.... 
Response: The Select Information Link dialog is displayed. 

2. Browse to the information link holding the desired data and select it in the list. 
3. Click OK. 

Response: The Add On-Demand Data Table dialog is displayed. 
4. If desired, change the Data table name for the new on-demand data table. 
5. In the Define input for parameters that should control loading list, click to select 

the column in the information link that contains the identifiers. 
6. Click Define Input.... 

Response: The Define Input dialog is displayed. 
7. In the Input for the selected parameter list, select Values from column. 
8. Select the Data table used by the master visualization. 
9. Select the Column containing identifiers in the master data table. 
10. Make sure that the Marked rows check box is selected and that only the check box for 

the marking used in the main visualization is selected. 

http://stn.spotfire.com/stn/Tasks/CreatingConfigurationBlock.aspx?usterms=configuration+block&uscat=0,1,2,3
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Comment:  You might also want to add a relation between the two data tables, so the 
marked rows from the master data table also become marked in the on-demand data 
table visualizations. This can be done directly in the Add On-Demand Data Table or 
later in the Data Table Properties dialog. See Data Table Properties - Relations for 
more information. 

11. Click OK to close the Define Input dialog. 
12. Use the Load automatically check box to determine whether to reload data as soon as 

the input conditions change or using a manual update only. 
Comment: This setting can be changed later on in the Data Table Properties dialog. 

13. Click OK. 
Response: The on-demand data table is loaded and a default visualization is created. 
The data shown in any visualization based on the on-demand data table will depend on 
what is marked in the master visualization. 

Example of on-demand-loaded data table with manual update: 
Click on an item in the master visualization: 

 
The refresh button of the visualization based on the on-demand-loaded data table appears in the 
title bar. (If nothing was marked from the beginning, the on-demand visualization will be empty 
until the first refresh.) Click on refresh. 

 
The visualization is updated to show details about the marked item: 
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Clicking on a different item in the master visualization once again displays the refresh button. 
  

 
Click refresh to update the on-demand visualization to use the new marking: 

 

3.6.4 Example of Property Controlled On-Demand Data 
The data that is to be loaded on demand can be controlled in a number of ways. See Loading 
Data on Demand for more information. The example below uses a property control in a text 
area to select which data to display in a bar chart based on an on-demand data table. 
In this example, we first assume that we have a data table containing a string column called 
"Type" which lists a number of different product types loaded in the analysis. We also assume 
that there is an information link with some additional data available, which also contains a 
"Type" column. See Creating an Information Link if you need information about how to set up 
information links. 



TIBCO Spotfire 4.0.2 - User's Manual 

186 

► To add an on-demand data table using input from a document 
property value: 
1. Select File > Add On-Demand Data Table.... 

Response: The Select Information Link dialog is displayed. 
2. Browse to the information link holding the desired data and select it in the list. 
3. Click OK. 

Response: The Add On-Demand Data Table dialog is displayed. 
4. If desired, change the Data table name for the new on-demand data table. 
5. In the Define input for parameters that should control loading list, click to select 

the column containing the product types. 
6. Click Define Input.... 

Response: The Define Input dialog is displayed. 
7. In the Input for the selected parameter list, select Values 

(fixed/properties/expression). 
8. Click on the Property radio button. 
9. Click Select.... 

Response: The Select Property dialog is displayed. 
10. If no suitable property is available, click New... in the Document Properties tab. 

Response: The New Property dialog is displayed. 
11. Define a string property using one of the available product types as default value. For 

example, create a string property called "Type" with the value "Apples". 
12. Click OK in all dialogs. 

Response: The on-demand data table is loaded using the limiting default value and a 
visualization is displayed. In the example below, the visualization shown is a bar chart 
displaying the sum of sales for Apples in four different regions. 

 

► To add a property control for changing the document property 
to a text area: 
1. Create or activate a text area. 

2. Click on the Toggle Edit Mode button, , in the title bar of the text area. 
3. Type some descriptive text to help other users understand what the control will do. 

4. Click on the Insert Property Control button, , and select which type of control to 
add. In this example we will add a drop-down list. 
Response: The Property Control dialog is displayed. 

5. Select the previously specified document property. 
6. Select Set property value through: Unique values in column. 
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7. Select the Data table to be the first data table in the analysis (not the on-demand data 
table). 

8. Select the "Type" Column. 
9. If desired, limit the values to be displayed in the drop-down list using a search 

expression. 
Comment: Only those values matching the search expression will be shown in the 
control. See Searching in TIBCO Spotfire for more information about valid search 
expressions. 

10. Click OK. 
Response: The property control is added to the text area. 

11. Click on the Toggle Edit Mode button again to exit the edit mode. 
You can now use the property control to change which product type to look at in the 
visualization. If Load automatically has been selected in the on-demand settings, the 
visualization will be updated each time the property is changed via the control. If Load 
automatically has not been selected, a refresh button will be displayed in the title bar of the 
visualization each time the input is changed. 

 
  

3.6.5 Details 

3.6.5.1 Details on Add On-Demand Data Table 
This dialog is used when you want to add a data table where data are loaded only when 
requested. You can specify what input to control the loading in a number of different ways. 

► To reach the Add On-Demand Data Table dialog: 
1. Select File > Add On-Demand Data Table.... 
2. Browse to the information link holding the desired data and select it in the list. 
3. Click OK. 



TIBCO Spotfire 4.0.2 - User's Manual 

188 

 

Option Description 

Source Lists the path and name of the selected information link. 

Browse... Allows you to select a different information link. 

Data table name Allows you to specify a name for the new on-demand data table. 

Define input for 
parameters that 
should control 
loading 

This is where you select what will affect the loading of data from the 
perspective of the information link. All columns and parameters 
available in the selected information link are listed. Click to select the 
parameter in the list and click Define Input... to specify a condition 
that must be fulfilled for any data to be loaded. 
For example, this is where you specify that the marking based on a 
certain column from one data table will limit what is shown in the on-
demand data table. If you would like to retrieve only data for a certain 
Region as shown in the picture above, you would select Region in this 
list and click Define Input to specify that only those rows 
corresponding to the set condition (e.g., marked rows in the data table 
"Sales Data") should be retrieved. 
Any required prompts or parameters that were specified upon the 
creation of the information link will be listed as Required parameters 
in this field. This means that you must specify input handling of these 
parameters to be able to load any on-demand data at all. 

Define Input... Opens the Define Input dialog where you can tie the selected 
parameter to a value or a range. 

Clear Input Removes the previously added input definition from the selected 
column or parameter. 

Load automatically Select this check box if the on-demand data should be loaded 
automatically each time the specified input conditions are changed. If 
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the check box is cleared the visualization can be manually updated 
using the refresh icon, , in the visualization title bar. 
A data table set to load automatically will switch to manual update if 
cyclic dependencies are detected in the analysis. 

Allow caching Select this check box to allow caching of data. This may speed up the 
process when loading new subsets of data. However, if the underlying 
information link data are updated during the current TIBCO Spotfire 
session you may end up with different results for a specific set of input 
values depending on whether or not the current selection is stored in 
the cache. You should always clear the check box if you know that the 
underlying data may be updated during your current session. 

Show 
transformations 

Expands the dialog and allows you to apply transformations on the 
data table you want to add. For more information, see the Show 
transformations topic. 

Manage 
Relations... 

Opens the Manage Relations dialog where you can define how the on-
demand data table should be related to other data tables in your 
analysis. 
If you want marked rows in one data table to also show up as marked 
in the other data table, then adding a relation is necessary. 

3.6.5.2 Details on Define Input 
This dialog is used to tie the selected parameter to a specified value or a range from the 
perspective of the analysis. 

► To reach the Define Input dialog: 
1. Select File > Add On-Demand Data Table.... 
2. Browse to the information link holding the desired data and select it in the list. 
3. Click OK. 
4. Select the parameter for which you want to create a condition and click Define 

Input.... 
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Option Description 

Selected parameter Shows the name of the parameter that was selected in the 
Add On-Demand Data Table dialog in a previous step. 

Input for the selected 
parameter 

Allows you to select whether to retrieve the input for the 
parameter from values or a range. See a description of the 
various options below. 

   Values from column Use this option to set the conditions for the parameter from 
the values in a column already in the analysis. The data 
retrieved for the on-demand data table can be based on 
filtered or marked rows, or a combination of both. See below 
for details. 
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   Range from column Use this option to set the conditions for the parameter from 
the range of a column already in the analysis. The resulting 
range will be the min and the max values from the selected 
column. 

   Values 
(fixed/properties/expression) 

Use this option if you want to specify fixed values or 
connect the parameter to a property. You can also calculate 
the values with an expression. 

   Range 
(fixed/properties/expression) 

Use this option if you want to specify a fixed range or 
connect the parameter range to properties. You can also 
calculate the values with an expression. 
Note: This option can also be used to set a single limit for a 
range, either an upper or a lower limit, such as loading only 
"Sales < 100". 

  

Values from column/Range from column settings 

 

Option Description 

Data table Select the data table where the column of interest is located. 

Column Select the column from which the input values should be picked. 

Limit by Use a combination of filtering and markings to limit the loaded data to 
rows matching the specified settings only. If more than one option is 
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selected then data will be retrieved for rows matching the intersection 
of the selected filtering and markings only. 
Leave both the Filtered rows and the Marked rows check boxes blank 
to retrieve data for all rows. 

   Filtered rows Select this check box to retrieve data for values remaining after 
filtering with the specified filtering scheme. 

   Marked rows Select this check box to retrieve data for values marked by the selected 
markings. 
If more than one marking is available in your analysis you need to 
determine which marking or markings to control the loading. If more 
than one marking is selected, then data will be retrieved for rows 
matching the intersection of the markings. 

   Number of 
identifiers to limit 
data loading to 

Available for the Values from column option only. 
Use this check box to determine whether the on-demand data should be 
loaded regardless of how many identifiers have been marked or 
whether there should be a limit to how many identifiers one can 
retrieve data for. 
The purpose of this option is to be able to limit the amount of data 
loaded from the server. If more identifiers than the specified number 
are marked and this check box has been selected, the data table will be 
empty. 
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Values (fixed/properties/expression) settings 

 

Option Description 

Fixed value Select this option to type a value to use as input for the parameter. 

   Select... Opens the Select Value dialog where you can pick a value available in 
the selected column element to use as a fixed value. This may be 
helpful when you are uncertain of which values are valid for the 
specified information link. 
The button will not be available if your information link is 
parameterized. 
If the selected parameter is a date or a datetime column, you will be 
able to select a date by clicking on the calendar icon instead, . 

Property Select this option to tie the parameter value to a property value. 
Property values can easily be changed if you add a property control to 
a text area. See Using Properties in the Analysis for more information. 

   Select... Opens the Select Property dialog where you can specify a property to 
tie to the selected parameter. 

Expression Select this option if you need to perform some calculation to obtain the 
desired input parameter value. For example, if the input is to be 
affected by multiple columns and properties, these can be defined in an 
expression. 
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   Edit... Opens the Edit Expression dialog where you can specify the expression 
to control the input parameter. 

Limit by Use a combination of filtering and markings to limit the loaded data to 
rows matching the specified settings only. If more than one option is 
selected then data will be retrieved for rows matching the intersection 
of the selected filtering and markings only. 
Leave both the Filtered rows and the Marked rows check boxes blank 
to retrieve data for all rows. 

   Filtered rows Select this check box to retrieve data for values remaining after 
filtering with the specified filtering scheme. 

   Marked rows Select this check box to retrieve data for values marked by the selected 
markings. 
If more than one marking is available in your analysis you need to 
determine which marking or markings to control the loading. If more 
than one marking is selected, then data will be retrieved for rows 
matching the intersection of the markings. 

   Number of 
identifiers to limit 
data loading to 

Use this check box to determine whether the on-demand data should be 
loaded regardless of how many identifiers have been marked or 
whether there should be a limit to how many identifiers one can 
retrieve data for. 
The purpose of this option is to be able to limit the amount of data 
loaded from the server. If more identifiers than the specified number 
are marked and this check box has been selected, the visualization will 
be empty. 

Include empty 
values 

Select this check box to also include rows that do not contain any data 
for the specified column. 
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Range (fixed/properties/expression) settings 

  

Option Description 

Fixed value Select this option to type a value to use as input for the parameter. 

   Select... Opens the Select Value dialog where you can pick a value available in 
the selected column element to use as a fixed value. This may be 
helpful when you are uncertain of which values are valid for the 
specified information link. 
The button will not be available if your information link is 
parameterized. 
If the selected parameter is a date or a datetime column, you will be 
able to select a date by clicking on the calendar icon instead, . 

Property Select this option to tie the parameter value to a property value. 
Property values can easily be changed if you add a property control to 
a text area. See Using Properties in the Analysis for more information. 

   Select... Opens the Select Property dialog where you can specify a property to 
tie to the selected parameter. 

Expression Select this option if you need to perform some calculation to obtain the 
desired input parameter value. For example, if the input is to be 
affected by multiple columns and properties, these can be defined in an 
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expression. 

   Edit... Opens the Edit Expression dialog where you can specify the 
expression to control the input parameter. 

   Base on Displays whether the calculations will be based on All values, Filtered 
values or Marked values. 

   Settings... Select this option to define whether to base the calculations on All 
values, Filtered values or Marked values. 

Include empty 
values 

Select this check box to also include rows that do not contain any data 
for the specified column. 

It is not necessary to specify both a min and a max input value for a range, one is sufficient. 

3.6.5.3 Details on Select Value 
This dialog is used to select a fixed value to control the input of an on-demand loaded data 
table. 

 
The Available values list shows all unique values in the selected information link column 
element. Click to select the value to use. Use the search field to limit the values shown to one 
matching the search expression. See Searching in TIBCO Spotfire for more information. 
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3.6.5.4 Details on Select Property 
This dialog is used to specify a property that will contain a parameter value for an action control 
or an on-demand information link parameter. 

Document Properties 

 

Option Description 

Select property Select the property you want to tie to the parameter value from the list. 
You can type an expression in the search field to limit the number of 
displayed properties. If no suitable properties are available, you can 
create a new one by clicking New.... 

New... Opens a dialog where you can specify a new document property. 

Edit... Opens a dialog where you can edit the selected document property. 

Delete Deletes the selected document property. 
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Data Table Properties 

 

Option Description 

Data table Allows you to select the data table to work with. 

Select property From the list, select the property you want to tie to the parameter value. 
You can type an expression in the search field to limit the number of 
displayed properties. If no suitable properties are available, you can 
create a new one by clicking New.... 

New... Opens a dialog where you can specify a new data table property. 

Edit... Opens a dialog where you can edit the selected data table property. 

Delete Deletes the selected data table property. 
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Column Properties 

 

Option Description 

Data table Allows you to select the data table to work with. 

Column Allows you to select the column to add a new property to. 

Select property From the list, select the property you want to tie to the parameter value. 
You can type an expression in the search field to limit the number of 
displayed properties. If no suitable properties are available, you can 
create a new one by clicking New.... 

New... Opens a dialog where you can specify a new column property. 

Edit... Opens a dialog where you can edit the selected column property. 

Delete Deletes the selected column property. 
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3.6.5.5 Details on Settings 

 

Option Description 

Limit by Use a combination of filtering and markings to limit the loaded data to 
rows matching the specified settings only. If more than one option is 
selected then data will be retrieved for rows matching the intersection 
of the selected filtering and markings only. 
Leave both the Filtered rows and the Marked rows check boxes blank 
to retrieve data for all rows. 

   Filtered rows Select this check box to retrieve data for values remaining after 
filtering with the specified filtering scheme. 

   Marked rows Select this check box to retrieve data for values marked by the selected 
markings. 
If more than one marking is available in your analysis you need to 
determine which marking or markings to control the loading. If more 
than one marking is selected, then data will be retrieved for rows 
matching the intersection of the markings. 
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3.6.5.6 Details on Select Information Link 
This dialog is used to specify which information link to load when adding a data table to the 
analysis. 

 
Navigate through the folders, and select the information link you want to use. Information about 
the selected information link is displayed to the right of the list of folders and information links. 
Which library folders you have access to is controlled by group privileges. Contact your 
Spotfire administrator if you cannot reach all the necessary information links. 
You can search for an information link in the library by entering a name, or part of a name in 
the search field in the upper right corner in the dialog, and then pressing Enter. All information 
links and folders matching your search string will then be listed. See Searching the Library for 
more information about search expressions. 
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4 Visualizations 
4.1 Table 
4.1.1 What is a Table? 

The table in TIBCO Spotfire works much like any other table you might be familiar with. It 
presents the data as a table of rows and columns, and is used to see details and compare values. 
By clicking on a row you mark it, and by dragging the mouse pointer over several rows you can 
mark more than one row. 
You can sort the rows in the table according to different columns by clicking on the column 
headers, or filter out unwanted rows by using the filters. 

 
All visualizations except the map chart can be set up to show data limited by one or more 
markings in other visualizations only (details visualizations). They can also be limited by one or 
more filterings. Another alternative is to set up a visualization without any filtering at all. See 
Limiting What is Shown in Visualizations for more information. 

4.1.2 How to Use the Table 
► To change column order: 

1. Click on a column header and drag that column to the desired position. 
Comment: You can also right-click on a column header and select Move First or 
Move Last from the pop-up menu. 
Comment: You can also go to the Columns page in the Properties dialog and click on 
a column in the Selected columns list and then click Move Up or Move Down to 
change the order of the columns. 

► To change the column width: 
1. Place the mouse pointer at the right edge of the column header you want to resize 

(indicated by a thin line). The cursor changes into a cross with arrows. 
2. Adjust the width by holding down the mouse button and moving the mouse 

horizontally. 
Comment: You can also right-click on the column heading and select Column Width... 
from the menu that appears. Enter the width in number of pixels and click OK. 
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► To remove columns: 
1. Right-click on a column header and select Remove. 

► To add columns: 
1. Right-click on the table and select Properties. 
2. Select the Columns page in the dialog. 
3. Select the columns you want to insert from the Available columns list. 
4. Click Add >. 

Response: The column is inserted to the right of all previously added columns. 
Comment: Click on a column in the Selected columns list and then click Move Up or 
Move Down to change the order of the columns. 

5. Click Close. 

► To apply coloring: 
See Coloring in Tables to learn how to set up coloring for tables specifically. See Coloring 
Overview if you want to learn more about coloring in general. 

► To freeze certain columns when scrolling horizontally: 
In a table with many columns you often need to scroll horizontally. However, there may be 
certain columns you want to see regardless of scrolling. This is achieved by freezing one or 
more columns. 

1. Move the columns you want to freeze to the left side of the table. 
2. Right-click on a column heading and select Properties. 
3. Select the Appearance page of the dialog. 
4. Specify the Number of frozen columns you want, counting from the left-hand side of 

the table. 
5. Click Close. 

► To show text as hyperlinks: 
1. It is possible to show the contents of a column as clickable links. To do this, right-click 

on the table visualization and select Properties. 
2. Select the Columns tab. 
3. Select the column you want to contain links. 
4. Select Link from the Renderer drop down list. 
5. Click Settings... 
6. Specify the settings in the Link Renderer Settings dialog and click OK. 
7. Click Close. 

► To sort the rows: 
1. Click on the header of the first column you wish to sort the data by. 

Comment: Click once again on the column header to toggle between Ascending and 
Descending row order. 

2. Press Shift and click on another column header to make a subsequent sort according to 
the values in that column. 

3. Repeat step 2 on other columns as many times as you like. 
Comment: You can also right-click in the table and open the Properties dialog. On the 
Sort Order tab, you can specify up to three columns to sort by. 
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► To mark rows: 
To mark a single row: 
Either click on the row with the mouse, or use the up/down arrow keys on your keyboard. 
To mark several separate rows: 
Hold the Ctrl key and click on each row you want to add to the marked selection. You can also 
hold the Ctrl key and use the up/down arrow keys on your keyboard to highlight other rows and 
then press space to mark them as well. 
To mark a range of rows: 
Press the mouse button and drag the pointer over the table to mark all the rows under the 
selection. You can also mark the first row of your intended selection, hold the Shift key, and use 
the up/down arrow keys on the keyboard to expand the selection of marked rows. 
To change the marked rows' color: 
Select Edit > Document Properties, and then change the marked items' color. 

► To change row height: 
1. Right-click on the table visualization. 
2. Select Row Height and a number from the list. 

Comment: Specifying the number 2 will make the row twice as high as the standard 
height, and so on. 
OR 

3. Select Other... 
4. Enter a number in the Properties page. 
5. Click Close. 

Response: All rows in the table visualization change height. 
Note: This can also be done in the Details-on-Demand. 

► To copy a cell: 
1. Right-click in the cell with the content you want to copy. 
2. Depending on the content of the cell, different things can be copied. For example a text 

column lets you copy the text from the cell by selecting Value and for a column with 
links you can choose to copy either the displayed text or the actual link. 
Note: This can also be done in the Details-on-Demand. 

► To create a new table: 
1. Click on the New Table button on the toolbar, . 

Comment: You can also select Insert > New Visualization > Table from the menu. 
Response: A table showing all available columns is created. 

2. Adjust the table to display the columns and sort order of your choice. 
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4.1.3 Images in Tables 
It is possible to show images in the cells of a table visualization. A Spotfire analysis or 
information link can contain a data table with images that will be shown in the column in the 
table visualization. 

 
If the column values are on the form of a URL you can also retrieve images from another 
location. Use Image from URL as the selected Renderer to display linked images. 
 Another way of including pictures in the table visualization is if the column is a virtual column, 
collecting the images from a remote data source. For more information on virtual columns, see 
the Virtual Columns page. 

Renderer 
The images must be drawn using a renderer. All columns can be shown as an image depending 
on the renderer, but the most common data type for images is binary data. If a binary column 
containing images has been set to use the wrong renderer, "[...]" will be shown in the cells of the 
column. It is then possible to change the renderer manually. 

► To change renderer for a specific column in a table 
visualization: 
1. Right-click on the table visualization and select Properties. 
2. Select the Columns tab. 
3. Select the column containing the images. 
4. Select Image from the Renderer drop down list. 
5. Click Close. 

It is also possible to change the default renderer for different content types from the Tools > 
Options menu. This will affect all future table visualizations, and can be useful if you know 
that you always want a certain column with a specific content type to be rendered the same way. 
For more information, see the Renderer Settings dialog. 

Row height 
By default, the height of the rows in the table visualization may not be suited for showing 
images. It is therefore possible to manually change the height of the rows. 

► To change row height: 
1. Right-click on the table visualization. 
2. Select Row Height and a number from the list. 

Comment: Specifying the number 2 will make the row twice as high as the standard 
height, and so on. 
OR 

3. Select More.... 
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4. Enter a number in the Properties page. 
5. Click Close. 

Response: All rows in the table visualization change height. 

Copy the image 
It is possible to copy the images from the table. To do this, right-click on the cell with the image 
and select Copy Cell > Image. 
Note: If the table contains images, these will not be exported if the table is exported to a text 
file or a Microsoft Excel file. 

4.1.4 Virtual Columns 
It is possible to include data in a table visualization (or in labels and tooltips of some other 
visualizations) that is not part of the original data table. A virtual column connects to a remote 
data source and collects data from there. This can be useful if, for example, a large quantity of 
data is stored in a database and the Spotfire analysis file would be too large if the data was 
included. The virtual columns can contain plain text but a more common use might be if the 
collected data were to consist of images or other large files. 
Note: A virtual column type needs to be registered programmatically. Virtual columns are not 
available by default. 

Differences between virtual columns and regular columns 
In the context of the table visualization, there are no major differences except that you cannot 
sort by the virtual column. However, the virtual column is only part of the table visualization 
and not part of the data table. This means that: 

• No filter will be created for the virtual column. 
• No export of the underlying data table will include the virtual column. To export the 

data, the visualization, and not the data table, must be chosen. Copy will wait until the 
value has been collected in the virtual column and then copy the value. 

• Settings, such as changing the column's name, are not managed from Edit > Column 
Properties, but from the Virtual Columns tab in the properties page for the table 
visualization. 

• The virtual column will not be available for selection on axes in the other visualization 
types. 

The virtual column may take some time to load, especially if the column contains images. 
However, the column will not be loaded all at once. It is possible to start working with the 
column and the contents will be loaded as you scroll down in the table. 
Note: The remote data source from where the virtual column is retrieved may require you to 
enter a username and password. 
  

4.1.5 Table Properties 

4.1.5.1 Table Properties 
The Table Properties dialog consists of several pages: 

• General 
• Data 
• Appearance 
• Fonts 
• Columns 
• Virtual Columns 
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• Colors 
• Sorting 
• Legend 

► To reach the Table Properties dialog: 
1. Right-click on the table visualization. 
2. Select Properties from the pop-up menu. 
3. Comment: You can also click on the table visualization to make it active and then 

select Edit > Visualization Properties. 

4.1.5.2 Table Properties - General 

 

Option Description 

Title The title of the visualization. 
Tip: Double-click on the title bar of the visualization for a shortcut to 
this field. 

Show title bar Specifies whether or not to show the visualization title. 

Description A description of the visualization. This description can optionally be 
shown in the legend and/or in the visualization. 

Show description 
in visualization 

Specifies whether or not to show the description in the visualization. 
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4.1.5.3 Table Properties - Data 

 

Option Description 

Data table Specifies the data table on which the visualization will work. 

Marking Specifies the marking (that is, the color and relationships to other 
marked items) that will be used to mark items in this visualization. 

Limit data using 
markings 

Lists the available markings that can be used to limit what is shown in 
this visualization. This means that the visualization only displays data 
that has been marked in other visualizations. 
If more than one marking is selected, you can choose how the data in 
the markings should be combined. 

New... Opens the New Marking dialog where you can specify a new marking. 
The color and name of a previously created marking is edited in the 
Document Properties dialog. 

Rows must be 
included in 

Specifies how the data in the markings should be combined if you 
have selected to limit the data by more than one marking. 

   All markings 
(AND) 
   

Use this option if you want this visualization to show the intersection 
of the markings selected in Limit data using markings. This can be 
used if you have two visualizations with different markings and want 
to see which markers are present in both markings. This visualization 
will then show only the data that has been marked using both of the 
selected markings. 

   Any marking 
(OR) 
    

Use this option if you want this visualization to show the union of the 
markings selected in Limit data using markings.  
This can be used if you have two visualizations with different 
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markings and want to see which markers are present in either of the 
two markings. This visualization will then show data that has been 
marked using either of the selected markings. 

Limit data using 
filterings 

Defines how different filtering schemes in the analysis should affect 
this visualization. 
Select Use the current filtering from the page if you want the 
visualization to always utilize the filtering scheme that is used on the 
page where the visualization is located. If you move the visualization 
to a new page, then the visualization will automatically start reacting 
on the filtering scheme that is used on the new page.  
Select a specific filtering scheme from the list if you want the 
visualization to always use that filtering scheme. Moving the 
visualization to another page with a different filtering scheme will not 
affect this setting. 
If you select to limit data using more than one filtering scheme, the 
intersection of the filterings will be used. This means that the 
visualization will show only the data that is made visible by all of the 
filtering schemes. 

New... Opens the New Filtering Scheme dialog where you can specify a new 
filtering scheme. 
The color and name of a previously created filtering scheme is edited 
in the Document Properties dialog. 

Limit data using 
expression 

You can limit what data should be available for a certain visualization 
using an expression. If you have defined a limiting expression, it will 
be displayed here. 

Edit... Opens the Limit Data Using Expression dialog where you can define a 
boolean expression to use for limiting the data in this visualization. 
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4.1.5.4 Table Properties - Appearance 

 

Option Description 

Header row height 
(number of lines) 

Specifies the height of the header row in number of lines. 

Data row height 
(number of lines) 

Specifies the height of all data rows in number of lines. 

Number of frozen 
columns 

Specifies how many columns on the left-hand side will be frozen, that 
is, not scroll out of sight when the scroll bar is moved to the right. 

Show cell borders Specifies whether or not cell borders should be visible between the 
cells in the table. 

Allow table data 
export in Web 
Player 

Specifies whether or not a Web Player user is allowed to export the 
data from the table. 
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4.1.5.5 Table Properties - Fonts 

 

Option Description 

Settings for Lists all items for which you can change the font settings. Click to 
select an item in the list to change the font settings for that text in the 
visualization. Press Ctrl and click on more items to change the settings 
for multiple items simultaneously. 

Font Specifies the font to use for the selected items. 

Font style Specifies the font style to use for the selected items. 

Size Specifies the font size to use for the selected items. 
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4.1.5.6 Table Properties - Columns 

 

Option Description 

Available columns Lists all columns in the data table available for selection. 

[Type to search] Type a search string to limit the number of items in the Available 
columns list. It is possible to use the wildcard character * in the search. 
See Searching in TIBCO Spotfire for more information. 

Selected columns Lists the columns selected to be displayed in the table. 

Add > Adds the columns selected in the Available columns list to the 
Selected columns list. 

< Remove Removes the selected columns from the Selected columns list and 
sends them back to the Available columns list. 

Remove All Removes all columns from the Selected columns list. 

Move Up Moves the selected column up in the Selected columns list. The order 
of the columns in this list determines the order of the columns in the 
table. 

Move Down Moves the selected column down in the Selected columns list. The 
order of the columns in this list determines the order of the columns in 
the table. 

Renderer Lists the available renderers for the chosen column. Which renderers 
are available is determined by the content type of the column. 

Add new columns 
automatically 

Select the check box to make sure that any new columns added to the 
selected data table are also automatically added to the table 
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visualization. 
New columns can appear when refreshing an information link, 
calculating new columns, etc. 

Settings... Opens the settings dialog for the chosen renderer. 

4.1.5.7 Table Properties - Virtual Columns 

 

Option Description 

Available virtual 
columns 

Lists the available virtual columns. 

Add Lets you add virtual columns. 

Edit... Opens the edit dialog for the chosen virtual column. 

Remove Removes the chosen virtual column. 

Display name Type the name to be displayed for the chosen virtual column. 
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4.1.5.8 Table Properties - Colors 

 

Option Description 

Color scheme 
groupings 

Lists all the currently added color scheme groupings. In table 
visualizations, a color scheme is always applied to a color scheme 
grouping, which can contain one or more columns. Click on a 
grouping in the list to select it and see its defined color scheme in the 
lower part of the dialog. By default, no coloring is applied when you 
create a new table. This means that the list is empty, and no color 
scheme is shown in the lower part of the dialog. To apply coloring, 
you must add one or more color scheme groupings and define color 
schemes for them. To learn more about color scheme groupings and 
coloring in tables, see Coloring in Tables. 

Add Opens a menu which lets you add a new color scheme grouping. The 
menu option Color Scheme Grouping... opens the Add Color Scheme 
Grouping dialog, in which you can select which columns to include in 
the new grouping. You can also give the grouping a descriptive name. 
The menu also lists each of the columns in the table. Select a column 
from the list to create a grouping containing only that column. 
Note: A grouping can only contain columns with values of the same 
data type. The exception being the five numeric data types Integer, 
LongInteger, Real, SingleReal, and Currency which can be added to 
the same grouping. 

Edit... Opens the Edit Color Scheme Grouping dialog which lets you modify 
the selected grouping. 

Remove Removes the selected color scheme grouping from the list. 
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Color mode Specifies in which color mode to set up the color scheme. Which 
modes are available depend on the columns in the selected color 
scheme grouping. For groupings containing continuous columns, you 
can select one of the following color modes: Gradient, Segments, 
Fixed, or Unique values. For categorical columns, you can select 
either Unique values or Fixed color mode. To learn more about the 
color modes, see Color Modes Overview. 

One scale per Specifies whether there should be one separate scale for each column 
in the color scheme grouping, or if one common scale should apply to 
all the columns. 

 
[Color Schemes 
menu] 

Opens a menu where you can select an already existing color scheme 
and apply it to the visualization, or apply the current color scheme to 
another visualization in the analysis. 

   From 
Visualization 

Lets you select a color scheme from another visualization in the 
analysis. Only color schemes applicable to the columns in the current 
color scheme grouping will be listed. 

   Document Color 
Schemes 

Lets you select a color scheme that has previously been saved within 
the analysis. Only color schemes applicable to the columns in the 
current color scheme grouping will be listed. This menu option is only 
available if one or more document color schemes already exist. 

   [Predefined color 
schemes] 

Lists a number of predefined color schemes. Only available for color 
scheme groupings containing continuous columns. For a full 
description of the predefined color schemes, see Predefined Color 
Schemes. 
Tip: To facilitate setting up a new color scheme, you can open a 
predefined color scheme with a similar appearance, and then adjust it 
to suit your needs. 

   Open from 
Library... 

Opens the Open from Library dialog where you can select a color 
scheme that has previously been saved to the library. 

   Open from File... Opens a dialog where you can select a previously saved color scheme. 

   Save As Lets you save a color scheme as a library item, a local file or a 
document color scheme. 
Library Item – Opens the Save as Library Item dialog, where you can 
specify a location in the library and a file name to save the currently 
open color scheme for later reuse. 
File – Opens a dialog where you can specify a location and a file name 
to save your currently open color scheme locally on your computer for 
later reuse. 
Document Color Scheme – Opens the Save as Document Color 
Scheme dialog, where you can specify a name and save the currently 
open color scheme for later reuse within the analysis. 

   Apply to 
Visualizations... 

Opens the Apply to Visualizations dialog where you can select other 
visualizations (within the analysis) that you want to apply the current 
color scheme to. Only visualizations with compatible color schemes 
are listed. 
Note: If you apply a color scheme to a table, cross table, or heat map, 
the coloring will not take effect immediately. The color scheme will be 
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added as an empty color scheme grouping, and you must select which 
columns or axis values to include in the grouping by opening the Edit 
Color Scheme Grouping dialog. 

[Color scheme area] The area in the lower part of the dialog shows the current color 
scheme. That is, the colors and values currently used for the selected 
color scheme grouping. You can modify color schemes in numerous 
ways to give the visualization the appearance you prefer. The color 
scheme area will look different, and have different available settings, 
depending on the characteristics of the columns in the color scheme 
grouping, as well as the selected color mode. To learn more about 
color schemes and color modes, see Color Schemes Overview and 
Color Modes Overview respectively. 

Add Point Available for continuous columns only. Adds a new anchor point to 
the color scheme. 

Delete Point Available for continuous columns only. Deletes the selected anchor 
point. 

Add Rule... Opens the Add Rule dialog where you can define a rule that functions 
as an exception to the rest of the defined color scheme. A rule has 
higher priority than the rest of the color scheme. For example, you can 
define a rule to give the top five items in your data a different color 
than the rest of the items. If you add many rules to a color scheme, the 
rules are prioritized from top to bottom. Which rule types are available 
depends on the characteristics of the columns in the color scheme 
grouping. See Details on Add/Edit Rule for full descriptions of the rule 
types. 

Reset Resets the selected color scheme to the one that was in effect when the 
visualization was created. Any added rules will be removed. Which 
color scheme should be used by default when you create a new 
visualization is defined in the Visualization page of the Options 
dialog. 
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4.1.5.9 Table Properties - Sorting 

 

Option Description 

Sort by Specifies the primary column you wish to sort the rows by. 

Then by Specifies the secondary and tertiary columns you wish to sort the rows 
by. 

Ascending Sorts the rows from the lowest to the highest value in the selected 
column. 

Descending Sorts the rows from the highest to the lowest value in the selected 
column. 

Note: You cannot sort by a virtual column. 
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4.1.5.10 Table Properties - Legend 

 

Option Description 

Show legend Specifies whether or not the docked legend should be shown in the 
visualization. 

Position Specifies which side of the visualization the legend should be 
positioned: the right-hand side or the left-hand side. 

Display the 
following legend 
items 

Specifies what will be shown in the legend.  
By clearing a check box you will completely hide that item from the 
legend. You can also select to show or hide parts of the legend 
information using the check boxes under Settings for the selected item 
in the list, see below. 

Settings Defines how the selected legend item should be displayed. The 
available options vary between legend items. 

   Show title Use this option to show or hide the title for the selected item. The title 
is typically what is displayed above an axis selector or similar: 

 

   Show axis 
selector 

Select this option to show or hide the axis selector for the selected 
item.  
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4.1.5.11 Details on Column Width 

► To reach the Column Width dialog: 
1. In a table visualization, right-click on the column header that you wish to change. 
2. Select Column Width... from the pop-up menu. 

 

Option Description 

Column width Specifies the width of the selected column in number of pixels. 
Tip: You can also drag the column headers to change the width of 
columns. 

4.2 Cross Table 
4.2.1 What is a Cross Table? 

A cross table is a two-way table consisting of columns and rows. It is also known as a pivot 
table or a multi-dimensional table. Its greatest strength is its ability to structure, summarize and 
display large amounts of data. Cross tables can also be used to determine whether there is a 
relation between the row variable and the column variable or not. 
Optionally, the cross table can display grand totals for columns, rows, or for the whole measure. 
It can also display subtotals for columns, 

Example: 
Below is a cross table showing sales figures for different types of fruits and vegetables. 
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The same data displayed in a regular table takes up far more space and it is much more difficult 
to get an overview: 

 
All visualizations except the map chart can be set up to show data limited by one or more 
markings in other visualizations only (details visualizations). They can also be limited by one or 
more filterings. Another alternative is to set up a visualization without any filtering at all. See 
Limiting What is Shown in Visualizations for more information. 

4.2.2 How to Use the Cross Table 
► To set up the cross table: 

1. Select a filter that represents the column you want to add to your cross table. 
2. Drag that filter into the cross table. 

Response: Three drop-targets appear. 

 
3. Drop the filter onto the drop-target you want. The first will place the column on the 

vertical axis, the second will place the column on the horizontal axis, and the third will 
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use the column as the actual numeric values inside the cross-table. 
Note: You can also drag-and-drop the filters to the column selectors. This way you can 
set up hierarchies, which is a very powerful feature in a cross table. 

► To display grand totals for rows or columns: 
1. Right-click in the cross table to display the pop-up menu. 
2. Select Grand Total for Columns or Grand Total for Rows. 

Response: The selected grand total is displayed in the cross table. 
Comment: You can also make these selections from the Appearance page of the Cross 
Table Properties. 

► To display subtotals for columns: 
To display subtotals in the cross table, the vertical axis must be set up as a hierarchy with at 
least two levels. 

1. Right-click in the cross table to open the pop-up menu. 
2. Select Subtotals for Columns. 

Response: A submenu is opened. It lists the columns and/or hierarchies currently on 
the vertical axis of the cross table. The options All and None are also available. 

3. Select a column (or level in a hierarchy) for which you want to show subtotals. Select 
All to display subtotals for all the columns (or hierarchical levels) on the vertical axis 
of the cross table. 
Response: The selected subtotals are displayed in the cross table. 
Comment: You can also make these selections from the Column Subtotals page of the 
Cross Table Properties. 

► To apply coloring: 
See Coloring in Cross Tables and Heat Maps to learn how to set up coloring for cross tables 
specifically. See Coloring Overview if you want to learn more about coloring in general. 

► To change the column width: 
1. Place the mouse pointer at the right edge of the column header you want to resize. The 

cursor changes into a cross with arrows. 
2. Adjust the width by holding down the mouse button and moving the mouse 

horizontally. 
Comment: All value columns will be set to the new size. They cannot be specified 
separately. 
Note: You can also right-click on the cross table, and select Resize Cells to Fit from 
the pop-up menu. This will set the value columns to the smallest width possible, where 
all values are still visible. 

► To sort the cross table: 
1. Click on the column title or row title by which you wish to sort the cross table. 
2. Click again to sort in descending order and a third time to return to the default sort 

order. 
Comment: When you are sorting a cross table, you always work within the last 
category of a hierarchy. See Cross Table Properties -  Sorting for an example. 

► To mark the cells in an entire cross table category: 
1. Press Alt on the keyboard and click on the category title of interest. 

Comment: Clicking on the first category in a hierarchy will mark all rows or columns 
within this category. Clicking on the last category will only mark the rows or columns 
in that particular category. 
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► To create a new cross table: 
1. Click on the New Cross Table button on the toolbar, . 

Comment: You can also select Insert > New Visualization > Cross Table from the 
menu. 
Response: A first attempt to set up a suitable cross table is made by the application. 

2. Adjust the cross table to display the categories and measures of your choice. 

4.2.3 Formatting in the Cross Table 
It is possible to format the values in the cross table on any of the axes. You can format the 
values either by opening the Formatting page of the Properties dialog, or by right-clicking 
directly in the cross table. The example below illustrates how formatting can be applied to a 
cross table. 

Example: 
The cross table below shows the sum of sales (Sum(Sales)) for fruits and vegetables for the 
years 2001, 2002, and 2003. The horizontal axis has the two columns Category and Type. The 
column Category contains the two axis values Fruit and Vegetables, and the column Type 
contains the values Apples, Bananas, Pears, Cucumber, Lettuce, and Tomatoes. 

 
To format all the values for 2001 as currency, right-click on the row header 2001, choose 
Formatting and then select currency from the pop-up menu. The values in that row will be 
updated instantly with the new setting. To format the row containing the values for 2003, go 
through the same steps. The resulting cross table is shown below. 

 
Note: To select another currency than $ you must open the properties dialog. 
You can go through the same steps again to format the values for 2002. However, if you format 
the values for the Apples column instead, all the previous formatting settings will be reset, as 
seen in the cross table below. 

 
Only the values in the column Apples are now formatted as currency, because you can only 
format values in one direction and at one level at a time. This means that if you format the 
values for Vegetables, then the values in Apples will be reset, as seen in the cross table below. 

 
You can move a measure from one axis to another without losing the formatting settings you 
have defined. This means that if you were to move the column Category from the horizontal 
axis to the vertical axis, all the values for the Vegetables would still be formatted as currency. 
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If you right-click on any of the cells that are not row or column headers in the cross table and 
select a formatter, all the values in the cross table will get the new formatting settings. 
However, if you add another column to the cell values axis it will only be possible to format on 
cell values. In the cross table below, Sum(Cost) was added to the cell values axis, and the 
column Type was removed. 

 
It is no longer possible to format only the values for an individual year, nor the values only for 
Fruit or Vegetables. If you right-click on any of those header cells in the cross table, the pop-up 
menu will not provide any formatting options to choose from. However, you can still format the 
values on Sum(Sales) and Sum(Cost). If you right-click on one of the two header cells for 
Sum(Cost) and set formatting to currency, the cross table will look like the one below. 

 
To learn more about additional formatting options for the cross table see Cross Table Properties 
- Formatting. For general information about formatting, see Formatting Overview. 

4.2.4 Cross Table Properties 

4.2.4.1 Cross Table Properties 
The Cross Table Properties dialog consists of several pages: 

• General 
• Data 
• Appearance 
• Column Subtotals 
• Formatting 
• Fonts 
• Axes 
• Colors 
• Sorting 
• Legend 

► To reach the Cross Table Properties dialog: 
1. Right-click on the cross table visualization. 
2. Select Properties from the pop-up menu. 
3. Comment: You can also click on the cross table visualization to make it active and 

then select Edit > Visualization Properties. 
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4.2.4.2 Cross Table Properties - General 

 

Option Description 

Title The title of the visualization. 
Tip: Double-click on the title bar of the visualization for a shortcut to 
this field. 

Show title bar Specifies whether or not to show the visualization title. 

Description A description of the visualization. This description can optionally be 
shown in the legend and/or in the visualization. 

Show description 
in visualization 

Specifies whether or not to show the description in the visualization. 
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4.2.4.3 Cross Table Properties - Data 

 

Option Description 

Data table Specifies the data table on which the visualization will work. 

Marking Specifies the marking (that is, the color and relationships to other 
marked items) that will be used to mark items in this visualization. 

Limit data using 
markings 

Lists the available markings that can be used to limit what is shown 
in this visualization. This means that the visualization only displays 
data that has been marked in other visualizations. 
If more than one marking is selected, you can choose how the data in 
the markings should be combined. 

New... Opens the New Marking dialog where you can specify a new 
marking. 
The color and name of a previously created marking is edited in the 
Document Properties dialog. 

Rows must be 
included in 

Specifies how the data in the markings should be combined if you 
have selected to limit the data by more than one marking. 

   All markings 
(AND) 
   

Use this option if you want this visualization to show the intersection 
of the markings selected in Limit data using markings. This can be 
used if you have two visualizations with different markings and want 
to see which markers are present in both markings. This visualization 
will then show only the data that has been marked using both of the 
selected markings. 

   Any marking 
(OR) 

Use this option if you want this visualization to show the union of the 
markings selected in Limit data using markings.  
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    This can be used if you have two visualizations with different 
markings and want to see which markers are present in either of the 
two markings. This visualization will then show data that has been 
marked using either of the selected markings. 

Limit data using 
filterings 

Defines how different filtering schemes in the analysis should affect 
this visualization. 
Select Use the current filtering from the page if you want the 
visualization to always utilize the filtering scheme that is used on the 
page where the visualization is located. If you move the visualization 
to a new page, then the visualization will automatically start reacting 
on the filtering scheme that is used on the new page.  
Select a specific filtering scheme from the list if you want the 
visualization to always use that filtering scheme. Moving the 
visualization to another page with a different filtering scheme will not 
affect this setting. 
If you select to limit data using more than one filtering scheme, the 
intersection of the filterings will be used. This means that the 
visualization will show only the data that is made visible by all of the 
filtering schemes. 

New... Opens the New Filtering Scheme dialog where you can specify a new 
filtering scheme. 
The color and name of a previously created filtering scheme is edited 
in the Document Properties dialog. 

Limit data using 
expression 

You can limit what data should be available for a certain visualization 
using an expression. If you have defined a limiting expression, it will 
be displayed here. 

Edit... Opens the Limit Data Using Expression dialog where you can define 
a boolean expression to use for limiting the data in this visualization. 
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4.2.4.4 Cross Table Properties - Appearance 

 

Option Description 

Show cell borders Specifies whether or not cell borders should be visible between the 
cells in the cross table. 

Allow table data 
export in Web 
Player 

Specifies whether or not a Web Player user is allowed to export the 
data from the cross table. 

Grand total for 
columns 

Specifies whether or not the selected aggregation measure (for 
example, the sum) of all values in a column should be displayed 
without consideration for the categories creating the rows of the cells. 
See note below for details on the calculation. 

Grand total for 
rows 

Specifies whether or not the selected aggregation measure (for 
example, the sum) of all values in a row should be displayed without 
consideration for the different column categories. 
See note below for details on the calculation. 

Note: The aggregated value for grand totals is not calculated on the values shown in the cross 
table, but on the underlying row values. For example, if "Average" is used as aggregation 
measure, the grand total average of a column is calculated on the rows the column is based on 
and not on the values shown in the cross table. 
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4.2.4.5 Cross Table Properties - Column Subtotals 

 

Option Description 

Show subtotals for Lists the columns and/or hierarchies on the vertical axis of the cross 
table. Select the ones you wish to display subtotals for. 
A subtotal is a partial summarization of the values in a column and can 
be displayed if the vertical axis is set up as a hierarchy with at least two 
levels. The aggregated subtotal value is calculated using the selected 
aggregation measure, and is displayed for each category and at each 
hierarchy level. 
Note: The aggregated value for subtotals is not calculated on the 
values shown in the cross table, but on the underlying row values. For 
example, if "Average" is used as aggregation measure, the subtotal 
average of a column is calculated on the rows the column is based on 
and not on the values shown in the cross table. 
Note: Custom expressions with OVER statements should be used 
carefully in cross tables with subtotals. The subtotals depend on the 
statement the same way the cell values do, and some OVER statements 
may therefore result in subtotal values that seem unexpected at first 
glance. See OVER in Custom Expressions to learn more about using 
the OVER statement. 

All Selects all the columns in the list. Subtotals will be displayed for all the 
columns and/or hierarchical levels on the vertical axis of the cross 
table. 

None Deselects all the columns in the list. No subtotals will be displayed in 
the cross table. 
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Display subtotals   

   Before values Places the subtotal values before the cell values on each level in the 
hierarchy of the vertical axis. 

   After values Places the subtotal values after the cell values on each level in the 
hierarchy of the vertical axis. 

4.2.4.6 Cross Table Properties - Formatting 

 

Option Description 

Format by Lists the alternatives by which it is possible to format the values in the 
cross table. The drop-down list contains the columns that are visible on 
the horizontal and vertical axes of the cross table. It also contains the 
alternative (Cell Values) which lets you format the values for each 
measure. Select the alternative you wish to format by to see the axis 
values available for that alternative. When you change from one 
alternative to another in the drop-down list, all the previous formatting 
settings in the cross table will be reset. 

Axis values Lists the values on the selected axis, as well as the current formatting 
category used for each value. Click on the alternative that you want to 
format. You can select more than one value if you want to apply the 
same formatting to them. Only the cell values in the selected columns 
or rows will be affected. If you select (Cell Values), the Axis values 
list will contain all columns and aggregation methods used on the cell 
values axis. If the cell values axis contains more than one column, 
formatting will always be applied to cell values and Format by will be 
grayed out, as seen below: 
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The cell values axis contains both Sum(Sales) and Sum(Cost), and the 
Format by drop-down list is grayed out. 

Reset Resets the formatting for the selected axis values according to the 
settings defined on column level. If no column formatting has been set, 
axis formatting settings defined in the Options dialog will be used. If no 
settings have been specified in the Options dialog, the default settings 
for the visualization type will be used. 

Category Lists the available formatting categories for the selected axis value. 
Each category in this list has separate settings. Which categories are 
available depends on the data type of the selected axis value. See 
Formatting Settings for a full description of all possible options. 

Note: These settings affect only the current visualization. For general information about 
formatting, see Formatting Overview. See also Formatting in the Cross Table to learn more 
about how you can change formatting settings in the cross table. 

4.2.4.7 Cross Table Properties - Fonts 

 

Option Description 

Settings for Lists all items for which you can change the font settings. Click to 
select an item in the list to change the font settings for that text in the 
visualization. Press Ctrl and click on more items to change the settings 
for multiple items simultaneously. 
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Font Specifies the font to use for the selected items. 

Font style Specifies the font style to use for the selected items. 

Size Specifies the font size to use for the selected items. 

4.2.4.8 Cross Table Properties - Axes 

 

Option Description 

Horizontal Specifies the column or hierarchy that should be used to define the 
column titles in the cross table. 

Settings... Opens the Advanced Settings dialog, where you can change the 
category mode to determine which combinations of categories to show. 
(In a cross table, the axes are always categorical and the scale mode 
cannot be changed.) 
Note: If All values in data (nest) or All possible values (cross) are 
selected, all available categories, even empty ones, will be shown in 
the cross table regardless of filtering. 

Vertical Specifies the column or hierarchy that should be used to define the row 
titles in the cross table. 

Settings... See above. 

Cell values Specifies the column or hierarchy that should be used to define the 
actual values in the cross table. 
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4.2.4.9 Cross Table Properties - Colors 

 

Option Description 

Color by Lists the alternatives by which it is possible to color the cross table. 
The drop-down list contains the columns that are visible on the 
horizontal and vertical axes of the cross table. It also contains the 
alternative (Cell Values) which lets you color the cross table by the 
column on the cell values axis. Select the alternative you wish to color 
by to set up a color scheme and see the available color scheme 
groupings for that alternative. If the cell values axis contains more 
than one column, you can only color by (Cell values) and the Color by 
drop-down list will be grayed out. 

Color scheme 
groupings 

Lists the currently available color scheme groupings for the selected 
column. In cross tables, a color scheme is always applied to a color 
scheme grouping. A default color scheme grouping named Numeric is 
always available for each of the columns in the cross table. Before any 
new color scheme groupings have been added, the default grouping 
contains all the values in the selected column. Click on a grouping in 
the list to select it and see its defined color scheme in the lower part of 
the dialog. To learn more about color scheme groupings and coloring 
in cross tables, see Coloring in Cross Tables and Heat Maps. 

Add Opens a menu which lets you add a new color scheme grouping. The 
menu option Color Scheme Grouping... opens the Add Color Scheme 
Grouping dialog, in which you can select values in the selected 
column to include in the new grouping. You can also give the 
grouping a descriptive name. The menu also lists all the values in the 
selected column as separate menu options. If you select one of these 
values from the menu, a grouping containing only that value will be 
added. 
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Edit... Opens the Edit Color Scheme Grouping dialog which lets you modify 
an existing grouping. You cannot edit the default grouping named 
Numeric. 

Remove 
(Remove) 

Removes the selected color scheme grouping from the list. You cannot 
remove the default grouping named Numeric. 

Color mode 
(Color mode) 

Specifies in which color mode to set up the color scheme. You can 
select one of the following color modes: Gradient, Segments, Fixed, or 
Unique values. To learn more about the color modes, see Color Modes 
Overview. 

One scale per 
(One scale per) 

Specifies whether there should be one separate scale for each axis 
value in the selected color scheme grouping, or if one single scale 
should apply to the entire grouping. 

 
[Color Schemes 
menu] 

Opens a menu where you can select an already existing color scheme 
and apply it to the visualization, or apply the current color scheme to 
another visualization in the analysis. 

   From 
Visualization 

Lets you select a color scheme from another visualization in the 
analysis. Only color schemes applicable to the current color scheme 
grouping will be listed. 

   Document Color 
Schemes 

Lets you select a color scheme that has previously been saved within 
the analysis. Only color schemes applicable to the current color 
scheme grouping will be listed. This menu option is only available if 
one or more document color schemes already exist. 

    [Predefined color 
schemes] 

Lists a number of predefined color schemes. For a full description of 
the predefined color schemes, see Predefined Color Schemes. 
Tip: To facilitate setting up a new color scheme, you can open a 
predefined color scheme with a similar appearance, and then adjust it 
to suit your needs. 

   Open from 
Library... 

Opens the Open from Library dialog where you can select a color 
scheme that has previously been saved to the library. 

   Open from File... Opens a dialog where you can select a previously saved color scheme. 

   Save As Lets you save a color scheme as a library item, a local file or a 
document color scheme. 
Library Item – Opens the Save as Library Item dialog, where you can 
specify a location in the library and a file name to save the currently 
open color scheme for later reuse. 
File – Opens a dialog where you can specify a location and a file name 
to save your currently open color scheme locally on your computer for 
later reuse. 
Document Color Scheme – Opens the Save as Document Color 
Scheme dialog, where you can specify a name and save the currently 
open color scheme for later reuse within the analysis. 

   Apply to 
Visualizations... 

Opens the Apply to Visualizations dialog where you can select other 
visualizations (within the analysis) that you want to apply the current 
color scheme to. Only visualizations with compatible color schemes 
are listed. 
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Note: If you apply a color scheme to a table, cross table, or heat map, 
the coloring will not take effect immediately. The color scheme will be 
added as an empty color scheme grouping, and you must select which 
columns or axis values to include in the grouping by opening the Edit 
Color Scheme Grouping dialog. 

[Color scheme area] The area in the lower part of the dialog shows the current color 
scheme. That is, the colors and values currently used for the selected 
color scheme grouping. You can modify color schemes in numerous 
ways to give the visualization the appearance you prefer. The color 
scheme area will look different, and have different available settings, 
depending on the characteristics of the color scheme grouping, as well 
as the selected color mode. To learn more about color schemes and 
color modes, see Color Schemes Overview and Color Modes 
Overview respectively. 

Add Point Adds a new anchor point to the color scheme. 

Delete Point Deletes the selected anchor point. 

Add Rule... Opens the Add Rule dialog where you can define a rule that functions 
as an exception to the rest of the defined color scheme. A rule has 
higher priority than the rest of the color scheme. For example, you can 
define a rule to give the top five items in your data a different color 
than the rest of the items. If you add many rules to a color scheme, the 
rules are prioritized from top to bottom. Which rule types are available 
depends on the characteristics of the color scheme grouping. See 
Details on Add/Edit Rule for full descriptions of the rule types. 

Reset Resets the selected color scheme to the one that was in effect when the 
visualization was created. Any added rules will be removed. Which 
color scheme should be used by default when you create a new 
visualization is defined in the Visualization page of the Options 
dialog. 

 

4.2.4.10 Cross Table Properties - Sorting 
Tip: Sorting is easily done by clicking directly on a column title or row title in the cross table 
visualization. 
When you are sorting a cross table, you always work on the last node of a hierarchy. For 
example, if the cross table shows sales figures for different types of fruits and vegetables, as in 
the example under What is a Cross Table?, and you click on the Apples leaf node, only the cell 
values within the Fruit >> Apples hierarchy will affect the sorting. You cannot sort on the entire 
Fruit category while subcategories are being displayed. 
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Option Description 

Sort rows by Select the cross table column title by which you wish to sort. 

Ascending Sorts the cross table by the selected column title in ascending order. 

Descending Sorts the cross table by the selected column title in descending order. 

Show only 
top/bottom 

Select this check box if you want to display a limited number of rows 
per category in the cross table. If you select ascending sort order, the 
rows with the bottom values will be shown. If you select descending 
sort order, the rows with the top values will be shown. 

   Indicate hidden 
rows 

Select this check box if you want to get an indication that some rows 
in the cross table are not displayed when the Show only top/bottom 
check box has been selected. A row with three dots in each cell will 
be added to indicate this. 

Sort columns by Select the row title you wish to sort the columns by in the cross table. 

Ascending Sorts the cross table by the selected row in ascending order. 

Descending Sorts the cross table by the selected row in descending order. 

Show only 
top/bottom 

Select this check box if you want to display a limited number of 
columns per category in the cross table. If you select ascending sort 
order, the columns with the bottom values will be shown. If you 
select descending sort order, the columns with the top values will be 
shown. 

   Indicate hidden 
columns 

Select this check box if you want to get an indication that some 
columns in the cross table are not displayed when the Show only 
top/bottom check box has been selected. A column with three dots in 
each cell will be added to indicate this. 
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4.2.4.11 Cross Table Properties - Legend 

 

Option Description 

Show legend Specifies whether or not the docked legend should be shown in the 
visualization. 

Position Specifies which side of the visualization the legend should be 
positioned: the right-hand side or the left-hand side. 

Display the 
following legend 
items 

Specifies what will be shown in the legend.  
By clearing a check box you will completely hide that item from the 
legend. You can also select to show or hide parts of the legend 
information using the check boxes under Settings for the selected item 
in the list, see below. 

Settings Defines how the selected legend item should be displayed. The 
available options vary between legend items. 

   Show title Use this option to show or hide the title for the selected item. The title 
is typically what is displayed above an axis selector or similar: 

 

   Show axis 
selector 

Select this option to show or hide the axis selector for the selected item.  
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4.3 Graphical Table 
4.3.1 What is a Graphical Table? 

A graphical table is a summarizing visualization designed to provide a lot of information at one 
glance. It can be set up to show columns with dynamic items such as sparklines, calculated 
values or conditional icons. One value is shown for each row as specified on the Rows axis. 

 
You can add any number of dynamic items to a graphical table. Each dynamic item column uses 
its own axis expression and it can also be filtered and limited by markings separately. This way, 
you can show both the total values for some calculated value and the currently filtered values 
simultaneously. See Limiting What is Shown in Visualizations for more information. 
When a hierarchical structure is used on the Rows axis, the graphical table is grouped into 
sections and sorting can be performed within each section by clicking on a column header. 
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4.3.2 How to Use the Graphical Table 
► To add columns to a graphical table: 

1. Right-click on the graphical table to display the pop-up menu. 
2. Select Properties. 
3. Go to the Axes page. 
4. Click on Add and select the type of item of interest from the drop-down menu. 

Response: A Settings dialog for the new item is displayed and a new column is shown 
in the graphical table. 
Comment: Note that each item added to a graphical table has its own settings. 

5. Make the necessary changes to the settings dialog so that the new column shows the 
information you want. 

6. When you are done, click Close. 
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► To change column order: 
Click on a column header and drag that column to the desired position. 
Comment: The row header column cannot be moved. 

► To change the column width: 
1. Place the mouse pointer at the right edge of the column header you want to resize 

(indicated by a thin line).  
Response: The cursor changes into a double-arrow. 

2. Adjust the width by holding down the mouse button and moving the mouse 
horizontally. 

► To remove a column: 
1. Right-click on the graphical table to display the pop-up menu. 
2. Select Properties. 
3. Go to the Axes page. 
4. In the Columns list, click to select the item you want to remove. 
5. Click Remove. 
6. When you are done, click Close. 

► To create a new graphical table: 

1. Click on the New Graphical Table button on the toolbar, . 
Comment: You can also select Insert > New Visualization > Graphical Table from 
the menu. 
Response: A table showing one column is created. You can change which item type to 
be used as default under Tools > Options > Graphical Table. 

2. Adjust the table to display the items of your choice. 

► To sort the rows: 
1. Click on the header of the column you wish to sort the data by. You can sort by 

columns containing calculated values and icons (based on the underlying calculation). 
Comment: Click again on the column header to sort descending. Click once again to 
return to the original sort order. 
Comment: If a hierarchy is used on the row axis, then sorting will be performed within 
each category only. 

► To change row height: 
1. Right-click on the graphical table to display the pop-up menu. 
2. Select Properties. 
3. Go to the Appearance page. 
4. Increase the Additional row spacing (in pixels). 

Comment: The row heights are automatically increased if the font size is increased. 
The Additional row spacing setting only needs adjustment if you want to add a few 
more pixels between the rows. 

5. Click Close. 

► To copy marked rows: 
1. Mark the rows of interest in the graphical table. 
2. Right-click and select Copy from the pop-up menu. 

Response: Information about the marked rows is copied to the clipboard. For 
sparklines, the start point and end point Y-axis values are copied. For calculated values 
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the actual values are copied. For icons, any applied rules are displayed on the form of 
the shape and the specified HTML color code.  

4.3.3 Graphical Table Properties 

4.3.3.1 Graphical Table Properties 
The Graphical Table Properties dialog consists of several pages: 

General 
Data 
Appearance 
Fonts 
Axes 
Legend 

► To reach the Graphical Table Properties dialog: 
1. Click on the graphical table visualization to make it active and then select Edit > 

Visualization Properties. 

4.3.3.2 Graphical Table Properties - General 

 

Option Description 

Title The title of the visualization. 
Tip: Double-click on the title bar of the visualization for a shortcut to 
this field. 

Show title bar Specifies whether or not to show the visualization title. 

Description A description of the visualization. This description can optionally be 
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shown in the legend and/or in the visualization. 

Show description 
in visualization 

Specifies whether or not to show the description in the visualization. 

4.3.3.3 Graphical Table Properties - Data 

 

Option Description 

Data table Specifies the data table on which the visualization will work. 

Marking Specifies the marking (that is, the color and relationships to other 
marked items) that will be used to mark items in this visualization. 

Limit data using 
markings 

Lists the available markings that can be used to limit what is shown in 
this visualization. This means that the visualization only displays data 
that has been marked in other visualizations. 
If more than one marking is selected, you can choose how the data in 
the markings should be combined. 

New... Opens the New Marking dialog where you can specify a new marking. 
The color and name of a previously created marking is edited in the 
Document Properties dialog. 

Rows must be 
included in 

Specifies how the data in the markings should be combined if you have 
selected to limit the data by more than one marking. 

   All markings 
(AND) 
   

Use this option if you want this visualization to show the intersection of 
the markings selected in Limit data using markings. This can be used if 
you have two visualizations with different markings and want to see 
which markers are present in both markings. This visualization will 
then show only the data that has been marked using both of the selected 
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markings. 

   Any marking 
(OR) 
    

Use this option if you want this visualization to show the union of the 
markings selected in Limit data using markings.  
This can be used if you have two visualizations with different markings 
and want to see which markers are present in either of the two 
markings. This visualization will then show data that has been marked 
using either of the selected markings. 

Limit data using 
filterings 

Defines how different filtering schemes in the analysis should affect 
this visualization. 
Select Use the current filtering from the page if you want the 
visualization to always utilize the filtering scheme that is used on the 
page where the visualization is located. If you move the visualization to 
a new page, then the visualization will automatically start reacting on 
the filtering scheme that is used on the new page.  
Select a specific filtering scheme from the list if you want the 
visualization to always use that filtering scheme. Moving the 
visualization to another page with a different filtering scheme will not 
affect this setting. 
If you select to limit data using more than one filtering scheme, the 
intersection of the filterings will be used. This means that the 
visualization will show only the data that is made visible by all of the 
filtering schemes. 

New... Opens the New Filtering Scheme dialog where you can specify a new 
filtering scheme. 
The color and name of a previously created filtering scheme is edited in 
the Document Properties dialog. 

Limit data using 
expression 

You can limit what data should be available for a certain visualization 
using an expression. If you have defined a limiting expression, it will be 
displayed here. 

Edit... Opens the Limit Data Using Expression dialog where you can define a 
boolean expression to use for limiting the data in this visualization. 
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4.3.3.4 Graphical Table Properties - Appearance 

 

Option Description 

Show   

   Header row Specifies whether or not the column headers at the top of the graphical 
table should be visible. 
Tip: If you want to show or hide a specific column header, instead of 
the entire row of headers, open the Settings dialog for the column of 
interest, go to the General page and then select or clear the check box 
Show name in header. 

   Row header 
name 

Specifies whether or not the row header name should be visible. 
This is the left-most header in the header row, displayed above the 
column containing the row headers in the graphical table. By default, 
the row header name is the name of the column on the row axis. If the 
row axis has a hierarchy of columns, then the row header name is the 
column at the lowest level in the hierarchy. 

   Cell borders Specifies whether or not cell borders should be visible in the graphical 
table. 

   Only the first n 
rows 

Select this check box if you want to display a limited number of rows 
in the graphical table. Note that the sort order in the graphical table 
affects which rows are shown. 

      Indicate 
hidden rows 

Select this check box if you want to get an indication that some rows in 
the graphical table are not displayed when the Only the first n rows 
check box has been selected. A row with three dots in each cell will be 
added to indicate this. 
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Additional row 
spacing (in pixels) 

Specifies how many extra pixels should be added to each row.  
Note: The row heights are automatically increased if the font size is 
increased. The Additional row spacing setting only needs adjustment if 
you want to add a few more pixels between the rows. 

4.3.3.5 Graphical Table Properties - Fonts 

 

Option Description 

Settings for Lists all items for which you can change the font settings. Select an 
item in the list to change the font settings for that text in the 
visualization. Press Ctrl and click on more items to change the settings 
for multiple items simultaneously. 

Font Specifies the font to use for the selected items. 

Font style Specifies the font style to use for the selected items. 

Size Specifies the font size to use for the selected items. 
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4.3.3.6 Graphical Table Properties - Axes 

 

Option Description 

Rows Specifies the column or hierarchy that should be used to define the 
rows in the graphical table. 

   Settings... Opens the Advanced Settings dialog, where you can change the 
category mode to determine which combinations of categories to show. 

Columns Lists the columns currently shown in the graphical table. 

Add Displays a menu where you can select which dynamic item to add to 
the graphical table. Once you make your selection, the selected item 
will be added to the Columns list, and a dialog where you can specify 
settings to use for that column will open. 

Settings... Opens the Settings dialog for the selected column. 

Remove Removes the selected column from the graphical table. 

Move up Moves the selected column up in the Columns list. The order of the 
columns in this list determines the order of the columns in the 
graphical table. 

Move down Moves the selected column down in the Columns list. The order of the 
columns in this list determines the order of the columns in the 
graphical table. 
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4.3.3.7 Graphical Table Properties - Legend 

 

Option Description 

Show legend Specifies whether or not the docked legend should be shown in the 
visualization. 

Position Specifies which side of the visualization the legend should be 
positioned: the right-hand side or the left-hand side. 

Display the 
following legend 
items 

Specifies what will be shown in the legend.  
By clearing a check box you will completely hide that item from the 
legend. You can also select to show or hide parts of the legend 
information using the check boxes under Settings for the selected item 
in the list, see below. 

Settings Defines how the selected legend item should be displayed. The 
available options vary between legend items. 

   Show title Use this option to show or hide the title for the selected item. The title 
is typically what is displayed above an axis selector or similar: 

 

   Show axis 
selector 

Select this option to show or hide the axis selector for the selected item.  



Visualizations 

247 

 

4.3.3.8 Sparkline 

4.3.3.8.1 What are Sparklines? 
Sparklines are small, simple line graphs traditionally used for displaying trends or variations of 
some variable: 

 
They can be displayed in the context of a graphical table or, separately, in a text area. The 
general idea of sparklines is that they can be included directly where they are needed, in tables 
or text, in order to provide context to a value. Sparklines can be set up to change with filtering 
like any traditional Spotfire visualization or they can be locked to show  fixed values, using the 
Data page in the Sparkline Settings dialog. 
  

4.3.3.8.2 How to Use Sparklines 
Sparklines can be shown both separately in a text area or be included as a column in a graphical 
table. The behavior of the sparkline is quite similar in both places, but some differences exist. 
Therefore, this list of step instructions has been split into three different sections: General 
information applicable to both instances, Graphical table specific information and Text area 
specific information. 

General information 

► To add actions to be performed when clicking on the sparkline: 
1. Open the Sparkline Settings dialog and go to the Actions page. 
2. Select the Perform action on click check box. 
3. Click on Settings.... 

Response: The Action Settings dialog is displayed. 
4. Type a good Description explaining what will happen when clicking on the sparkline. 

Comment: The description can be shown in the tooltip for the sparkline. 
5. Add the desired actions and click OK. 

Graphical table specific information 
When sparklines are included in a graphical table, the settings for the sparkline column 
normally control a number of separate sparkline graphs, one for each value in the graphical 
table row axis. 

► To lock the sparkline column so it does not react to filtering: 
1. Open the Sparkline Settings dialog and go to the Data page. 
2. Make sure that the Specify separate data limiting radio button is selected. 
3. Clear all check boxes under Limit data using filterings. 

Comment: You can also select one specific filtering scheme and keep from modifying 
any of the filters in it. 
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4. Click Close or OK. 
Response: The sparkline shows all data, regardless of any filtering. 

► To add a sparkline column to a graphical table: 
1. Right-click on the graphical table to display the pop-up menu. 
2. Select Properties. 
3. Go to the Axes page. 
4. Click on Add and select Sparkline from the drop-down menu. 

Response: A Sparkline Settings dialog is displayed and a new sparkline column is 
shown in the graphical table. 
Comment: Note that each sparkline column added to a graphical table has its own 
settings. 

5. On the Axes page of the Sparkline Settings dialog, select the column, hierarchy or 
expression to define the X-axis and Y-axis of the sparkline. 

6. On the General page, change the Name to be shown in the graphical table. 
Comment: You can hide the name form the graphical table by clearing the Show name 
in header check box. (The entire header row of the graphical table can also be hidden 
from the Appearance tab of the Graphical Table Properties.) 

7. If desired, make other changes to the default sparkline settings, such as changing the 
filtering scheme on the Data page, adding an action or displaying start point and end 
point Y-axis values. 

8. When you are done, click Close. 

► To change the column header for a sparkline column: 
1. Open the Sparkline Settings dialog and go to the General page. 
2. Type a new Name for the column. 
3. Make sure that the Show name in header check box is selected. 
4. Click Close. 

► To hide the column name from a graphical table: 
Open the Sparkline Settings dialog and go to the General page. 

1. Clear the Show name in header check box. 
Comment: The entire header row of the graphical table can be hidden from the 
Appearance tab of the Graphical Table Properties. 

2. Click Close. 

► To change the scale for a sparkline column in a graphical table: 
1. Open the Sparkline Settings dialog and go to the Axes page. 
2. Click to select whether to use One scale for all sparklines or Multiple scales. 

Comment: Use One scale for all sparklines if you want to show the Y-axis values for 
all sparklines in this column presented using the same scale. Use Multiple scales to 
maximize the Y-axis variation within each sparkline. 

3. Click Close. 

► To display Y-axis start point/end point values for the sparkline: 
1. Open the Sparkline Settings dialog and go to the Values page. 
2. Select the Start point and/or End point check box. 

Response: The values are shown in the visualization. 
3. If desired, change how much space to use for the values by modifying the Y-axis 

values width. 
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Comment: This setting does not change the total width of the column. To increase the 
total column width, place the mouse pointer at the right edge of the column header you 
want to resize and adjust the width by holding down the mouse button and moving the 
mouse horizontally. 

Text area specific information 
When a sparkline is used in a text area it behaves slightly different from when it is included in a 
graphical table. For example, you will not get instant feedback to your setting changes since the 
sparkline does not show up until you leave the edit mode. However, the placement of the edit 
box tells you where in the text area the sparkline will show up. 

► To lock the sparkline so it does not react to filtering: 
1. Open the Sparkline Settings dialog and go to the Data page. 
2. Clear all check boxes under Limit data using filterings. 

Comment: You can also select one specific filtering scheme and keep from modifying 
any of the filters in it. 

3. Click Close or OK. 
Response: The sparkline shows all data, regardless of any filtering. 

► To add a sparkline to a text area: 
1. Create a text area where you want the sparkline to reside. 

2. Click on the Toggle Edit Mode button, , in the text area title bar to make sure that 
the text area is in edit mode. 
Comment: You can also right-click and select Edit Text Area from the pop-up menu. 

3. Type some descriptive text in the text area regarding what the sparkline will show. 

4. Click on the Insert Dynamic Item button, , and select the Sparkline option. 
Response: The Sparkline Settings dialog is displayed. 

5. On the Axes page, select the column, hierarchy or expression to define the X-axis and 
Y-axis of the sparkline. 
Comment: If desired, make other changes to the default sparkline settings, such as 
changing the filtering scheme on the Data page, adding an action or displaying start 
point and end point Y-axis values. 

6. Click OK. 

► To resize the sparkline in a text area: 
1. Click on the Toggle Edit Mode button, , in the text area title bar to make sure that 

the text area is in edit mode. 
Response: The outline of the sparkline is shown as a gray box. 

2. Click on the gray edit box to select it and drag either of the corners to resize the box. 

3. Click on the Toggle Edit Mode button, , in the text area title bar again, or click 
outside the text area in any other visualization to leave the Edit mode. 
Response: The final result is shown in the text area. 
Comment: You can always reset the size of the sparkline to the original size if you 
change your mind. Just open the Format Control dialog by right-clicking on the gray 
box, click on the Reset button and then OK, and the size will be reset. 

► To display Y-axis start point/end point values for the sparkline: 
1. Click on the Toggle Edit Mode button, , in the text area title bar to make sure that 

the text area is in edit mode. 
2. Open the Sparkline Settings dialog and go to the Appearance page. 
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3. Select the Start point and/or End point check box. 
4. Click OK. 

5. Click on the Toggle Edit Mode button, , in the text area title bar again, or click 
outside the text area in any other visualization to leave the Edit mode. 
Response: The values are shown next to the sparkline. 
Comment: The values are not visible in edit mode. The gray edit box only indicates the 
size of the actual sparkline. 

4.3.3.8.3 Sparkline Settings 
The Sparkline Settings dialog consists of several pages: 

• General 
• Data 
• Appearance 
• Formatting 
• Axes 
• Actions 
• Tooltip 

► To reach the Sparkline Settings dialog from a graphical table: 
1. Right-click on the sparkline column in a graphical table visualization. 
2. Select Properties from the pop-up menu. 
3. If the Sparkline Settings dialog is not opened directly, go to the Axes page in the 

Graphical Table Properties dialog, select the Sparkline column you want to modify and 
click Settings.... 

► To reach the Sparkline Settings dialog from a text area: 
1. Click on the Toggle Edit Mode button, , in the text area title bar, to make sure that 

the text area is in Edit Mode. 
Comment: You can also right-click and select Edit Text Area from the pop-up menu. 

2. Double-click on the gray edit box representing the desired sparkline in the text area. 
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4.3.3.8.4 Sparkline Settings - General 

 

Option Description 

Name The name of the sparkline. If the sparkline is included in a graphical 
table, then this name is the column header which can be shown or 
hidden using the check box below. Otherwise, the name is simply used 
to identify this particular sparkline column on the Axes page of the 
graphical table or in Edit-mode in a text area. 

Show name in 
header 

[Only applicable when the sparkline is part of a graphical table.] 
Shows or hides the column header. 
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4.3.3.8.5 Sparkline Settings - Data 

 

Sparkline in Graphical Table 
When the sparkline is used in a graphical table the selection of data table and marking is already 
done in the Graphical Table Properties - Data page, so these options are not available here. 
Instead you will get the choice to inherit the data limiting settings or to use separate data 
limiting: 

Option Description 

Data limiting   

Use data limiting 
from graphical table  

Use this option to inherit the data limiting settings from the 
graphical table. 

Specify separate data 
limiting 

Use this option if you want to specify other limitations for the 
sparkline column than you have set up for the graphical table. 

 

Sparkline in Text Area 
When a sparkline is used in a text area you must specify the data table to work on. 

Option Description 

Data table Specifies the data table on which the visualization will work. 

Marking [Not applicable for sparklines in text area.] 
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All Sparklines 

Option Description 

Limit data using 
markings 

Lists the available markings that can be used to limit what is shown 
in this dynamic item. This means that the dynamic item only 
displays data that has been marked in other visualizations. 
If more than one marking is selected, you can choose how the data 
in the markings should be combined. 

New... Opens the New Marking dialog where you can specify a new 
marking. 
The color and name of a previously created marking is edited in the 
Document Properties dialog. 

Rows must be 
included in 

Specifies how the data in the markings should be combined if you 
have selected to limit the data by more than one marking. 

   All markings (AND) 
   

Use this option if you want this dynamic item to show the 
intersection of the markings selected in Limit data using markings. 
This can be used if you have two visualizations with different 
markings and want to see which markers are present in both 
markings. This dynamic item will then show only the data that has 
been marked using both of the selected markings. 

   Any marking (OR) 
    

Use this option if you want this dynamic item to show the union of 
the markings selected in Limit data using markings.  
This can be used if you have two visualizations with different 
markings and want to see which markers are present in either of the 
two markings. This dynamic item will then show data that has been 
marked using either of the selected markings. 

Limit data using 
filterings 

Defines how different filtering schemes in the analysis should 
affect this dynamic item. 
Select Use the current filtering from the page if you want the 
dynamic item to always utilize the filtering scheme that is used on 
the page where the dynamic item is located. If you move the 
dynamic item to a new page, then the dynamic item will 
automatically start reacting on the filtering scheme that is used on 
the new page.  
Select a specific filtering scheme from the list if you want the 
dynamic item to always use that filtering scheme. Moving the 
dynamic item to another page with a different filtering scheme will 
not affect this setting. 
If you select to limit data using more than one filtering scheme, the 
intersection of the filterings will be used. This means that the 
dynamic item will show only the data that is made visible by all of 
the filtering schemes. 

New... Opens the New Filtering Scheme dialog where you can specify a 
new filtering scheme. 
The color and name of a previously created filtering scheme is 
edited in the Document Properties dialog. 

Limit data using 
expression 

You can limit what data should be available for a certain dynamic 
item using an expression. If you have defined a limiting expression, 
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it will be displayed here. 

Edit... Opens the Limit Data Using Expression dialog where you can 
define an expression to use for limiting the data in this dynamic 
item. 

4.3.3.8.6 Sparkline Settings - Appearance 

 

Option Description 

Show Y-axis 
values for 

  

   Start point Select this check box to display the first Y-axis value for a sparkline. 

   End point Select this check box to display the last Y-axis value for a sparkline. 

Y-axis values 
width 

[Only available when the sparkline is used in a graphical table.] 
Allows you to specify how many pixels of the total sparkline width to 
use for the start point or end point values. The total sparkline width can 
be controlled by dragging the column header edges with the mouse. 
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4.3.3.8.7 Sparkline Settings - Formatting 

 

Option Description 

Axes Displays how the Y-axis start point and end point values is formatted. 

Reset Resets the formatting for the selected axis values according to the 
settings defined on column level. If no column formatting has been set, 
axis formatting settings defined in the Options dialog will be used. If 
no settings have been specified in the Options dialog, the default 
settings for the visualization type will be used. 

Category Lists the available formatting categories for the selected axis. Each 
category in this list has separate settings. Which categories are 
available depends on the data type of the selected axis. See Formatting 
Settings for a full description of all possible options. 
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4.3.3.8.8 Sparkline Settings - Axes 

 

Option Description 

X-axis Specifies the column or hierarchy to be displayed on the X-axis. 

Settings... Opens the Advanced Settings dialog, where you can change the scale 
mode from categorical to continuous, and vice versa, as well as 
changing the category mode to determine which combinations to show. 

Y-axis Specifies the column or hierarchy to be displayed on the Y-axis. 

Y-axis scale [Only applicable when the sparkline is part of a graphical table.] 

   One scale for all 
sparklines 

Use this option if you want to show the Y-axis values for all sparklines 
in the graphical table presented using the same scale. 

   Multiple scales 
  

Use this option to show the Y-axis values for all sparklines using 
different scales. For example, use it if the data for several categories 
are of very different magnitudes, and you are interested in seeing the 
trends for each category rather than how the curves behave relative to 
each other. 
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4.3.3.8.9 Sparkline Settings - Actions 

 

Option Description 

Perform action on 
click 

Select the check box to specify an action that should happen when 
clicking on the sparkline. Actions include operations like going to 
another page, applying a bookmark, a data function or executing a 
script.  

Settings... Opens the Action Settings dialog where you can specify what should 
happen when clicking on this sparkline. 
In the graphical table, the action is specified for the whole item 
column. However, if the action is based on a script, then you may 
obtain different results depending on which cell you click on. See 
Action Script Examples for more information. 
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4.3.3.8.10 Sparkline Settings - Tooltip 

 

Option Description 

Display the 
following values 

Specifies what will be shown in the tooltip. 

Move Up Moves the selected value up in the list and, hence, up in the tooltip. 

Move Down Moves the selected value down in the list and, hence, down in the 
tooltip. 

Tooltip format   

   Value names and 
values 

Shows the tooltip content in a format where the selected column name, 
hierarchy or custom expression is displayed. For example, Year: 2003, 
Type: Cucumber, etc. 

   Visualization 
properties and 
values 

Shows the tooltip content in a format where the visualization property 
for each value is displayed. For example, X: 2003, Color: Cucumber, 
etc. 
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4.3.3.9 Calculated Value 

4.3.3.9.1 What are Calculated Values? 
Calculated values are values derived from some kind of aggregated expression, similar to the 
data shown in cross tables. They can be displayed in the context of a graphical table or, 
separately, in a text area. 

 
The general idea of calculated values is that they can be included directly where they are 
needed, in tables or text, in order to provide information at a glance. Calculated values can be 
set up to change with filtering like any traditional Spotfire visualization or they can be locked to 
show  fixed values, using the Data page in the Calculated Value Settings dialog. 
By adding rules that control the color and font style you can make sure that a value stands out 
when it falls outside the specified limits: 

 
  

4.3.3.9.2 How to Use Calculated Values 
Calculated Values can be shown both separately in a text area or be included as a column in a 
graphical table. The behavior of the calculated value is quite similar in both places, but some 
differences exist. Therefore, this list of step instructions has been split into three different 
sections: General information applicable to both instances, Graphical table specific information 
and Text area specific information. 

General information 

► To add actions performed when clicking on the calculated value: 
1. Open the Calculated Value Settings dialog and go to the Actions page. 
2. Select the Perform action on click check box. 
3. Click on Settings.... 

Response: The Action Settings dialog is displayed. 
4. Type a good Description explaining what will happen when clicking on the calculated 

value. 
Comment: The description can be shown in the tooltip for the calculated value. 

5. Add the desired actions and click OK. 

► To add a rule for the color or font style: 
Calculated values do not require any rules at all, but they can be used to emphasize a certain 
value using a color or a different font style. 

1. Open the Calculated Value Settings dialog and go to the Values page. 
2. Click Add Rule.... 

Response: The Add Rule dialog is displayed. 
3. Define the Rule type to apply. 
4. Set the Value for the rule. 
5. Specify the Color and Font style to use when the rule is applied. 
6. Click OK. 
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Comment: You can add more than one rule. If you add many rules, the rules are 
prioritized from top to bottom, for each row. None of the rules further down in the list 
will be considered once a rule higher up in the list has been applied. You can click and 
drag a rule in the Rules list to change the order. 

► To change the formatting: 
1. Open the Calculated Value Settings dialog and go to the Formatting page. 
2. Click to select the Category of your choice. For example, "Number". 

Response: The settings for the selected category are shown. 
3. Make the desired changes. For example, change the number of decimals shown. 
4. Click Close or OK. 

Graphical table specific information 
When calculated values are included in a graphical table, the settings for the calculated value 
item normally control a number of separate calculated values, one for each value in the 
graphical table row axis. 

► To lock the calculated value so it does not react to filtering: 
1. Open the Calculated Value Settings dialog and go to the Data page. 
2. Make sure that the Specify separate data limiting radio button is selected. 
3. Clear all check boxes under Limit data using filterings. 

Comment: You can also select one specific filtering scheme and keep from modifying 
any of the filters in it. 

4. Click Close or OK. 

► To add a calculated values column to a graphical table: 
1. Right-click on the graphical table to display the pop-up menu. 
2. Select Properties. 
3. Go to the Axes page. 
4. Click on Add and select Calculated Value from the drop-down menu. 

Response: A Calculated Value Settings dialog is displayed and a new calculated value 
item is shown in the graphical table. 
Comment: Note that each calculated value column added to a graphical table has its 
own settings. 

5. On the Values page, select a column, hierarchy or expression in the Calculate values 
using field. 

6. On the General page, change the Name of the new column. 
Comment: You can hide the name form the graphical table by clearing the Show name 
in header check box. (The entire header row of the graphical table can also be hidden 
from the Appearance tab of the Graphical Table Properties.) 

7. If desired, make other changes to the default settings, such as changing the filtering 
scheme on the Data page, adding an action or setting up a rule, see above. 

8. When you are done, click Close. 

► To change the column header for a calculated values column: 
1. Open the Calculated Value Settings dialog and go to the General page. 
2. Type a new Name for the column. 
3. Make sure that the Show name in header check box is selected. 
4. Click Close. 



Visualizations 

261 

► To hide the column name from a graphical table: 
Open the Calculated Value Settings dialog and go to the General page. 

1. Clear the Show name in header check box. 
Comment: The entire header row of the graphical table can be hidden from the 
Appearance tab of the Graphical Table Properties. 

2. Click Close. 

Text area specific information 
Using calculated values in a text area works slightly different from when it is included in a 
graphical table. Below are some useful tips for working with calculated values in the text area. 

► To add a calculated value to a text area: 
1. Create a text area where you want the calculated value to reside. 

2. Click on the Toggle Edit Mode button, , in the text area title bar to make sure that 
the text area is in edit mode. 
Comment: You can also right-click and select Edit Text Area from the pop-up menu. 

3. Type some descriptive text in the text area regarding what the calculated value will 
show. 

4. Click on the Insert Dynamic Item button, , and select the Calculated Value 
option. 
Response: The Calculated Value Settings dialog is displayed. 

5. On the Values page, select a column, hierarchy or expression in the Calculate values 
using field. 
Comment: If desired, make other changes to the default settings, such as changing the 
filtering scheme on the Data page, adding an action or setting up a rule, see above. 

6. Click OK. 
Response: The calculated value is now added to the text area. 

► To lock the calculated value so it does not react to filtering: 
1. Open the Calculated Value Settings dialog and go to the Data page. 
2. Clear all check boxes under Limit data using filterings. 

Comment: You can also select one specific filtering scheme and keep from modifying 
any of the filters in it. 

3. Click Close or OK. 

► To change the font, style and size of calculated values in the 
text area: 
1. Click on the Toggle Edit Mode button, , in the text area title bar. 
2. Right-click on the calculated value and select Format Control... from the pop-up 

menu. 
Response: The Format Control dialog is opened. 

3. Adjust the font settings in the dialog to change the appearance of the calculated value 
to your liking. 

4. Click OK. 
Response: The new font settings are applied to the calculated value. 

5. Click on the Toggle Edit Mode button, , in the text area title bar again. 
Response: The Edit mode is closed and you see the final result. 
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Note: The text color cannot be set using the Format Control dialog. Text color is 
instead defined by rules. See "To add a rule for the color or font style" above for more 
information. 
Note: When working with calculated values, make sure you do not unintentionally 
override any font style settings that have been defined in a rule. If you apply a font 
style (Bold and Italic) from the Format Control dialog, it will be added to the 
calculated value on top of any font style included in a rule for the calculated value. For 
example, if you select the check box for Bold in the Format Control dialog, then the 
calculated value will always be displayed as bold. A rule stating that the value should 
be displayed in bold only if the value is greater than a certain value will have no effect, 
since the calculated value is already displayed in bold. 

4.3.3.9.3 Calculated Value Settings 
The Calculated Value Settings dialog consists of several pages: 

• General 
• Data 
• Formatting 
• Values 
• Actions 
• Tooltip 

► To reach the Calculated Value Settings dialog from a graphical 
table: 
1. Right-click on the calculated value column in a graphical table visualization. 
2. Select Properties from the pop-up menu. 
3. If the Calculated Value Settings dialog is not opened directly, go to the Axes page in 

the Graphical Table Properties dialog, select the Calculated Value column you want to 
modify and click Settings.... 

► To reach the Calculated Value Settings dialog from a text area: 
1. Click on the Toggle Edit Mode button, , in the text area title bar, to make sure that 

the text area is in Edit Mode. 
Comment: You can also right-click and select Edit Text Area from the pop-up menu. 

2. Double-click on the gray edit box representing the desired calculated value in the text 
area. 
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4.3.3.9.4 Calculated Value Settings - General 

 

Option Description 

Name The name of the calculated value. If the calculated value is included in 
a graphical table, then this name is the column header which can be 
shown or hidden using the check box below. Otherwise, the name is 
simply used to identify this particular calculated value column on the 
Axes page of the graphical table or in Edit-mode in a text area. 

Show name in 
header 

[Only applicable when the calculated value is part of a graphical table.] 
Shows or hides the column header. 
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4.3.3.9.5 Calculated Value Settings - Data 

 

Calculated Value in Graphical Table 
When the calculated value is used in a graphical table the selection of data table and marking is 
already done in the Graphical Table Properties - Data page, so these options are not available 
here. Instead you will get the choice to inherit the data limiting settings or to use separate data 
limiting: 

Option Description 

Data limiting   

Use data limiting 
from graphical table  

Use this option to inherit the data limiting settings from the 
graphical table. 

Specify separate data 
limiting 

Use this option if you want to specify other limitations for the 
calculated value column than you have set up for the graphical 
table. 

Calculated Value in Text Area 
When a calculated value is used in a text area you must specify the data table to work on. 

Option Description 

Data table Specifies the data table on which the visualization will work. 

Marking [Not applicable for calculated values in text area.] 
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All Calculated Values 

Option Description 

Limit data using 
markings 

Lists the available markings that can be used to limit what is shown 
in this dynamic item. This means that the dynamic item only 
displays data that has been marked in other visualizations. 
If more than one marking is selected, you can choose how the data 
in the markings should be combined. 

New... Opens the New Marking dialog where you can specify a new 
marking. 
The color and name of a previously created marking is edited in the 
Document Properties dialog. 

Rows must be 
included in 

Specifies how the data in the markings should be combined if you 
have selected to limit the data by more than one marking. 

   All markings 
(AND) 
   

Use this option if you want this dynamic item to show the 
intersection of the markings selected in Limit data using markings. 
This can be used if you have two visualizations with different 
markings and want to see which markers are present in both 
markings. This dynamic item will then show only the data that has 
been marked using both of the selected markings. 

   Any marking (OR) 
    

Use this option if you want this dynamic item to show the union of 
the markings selected in Limit data using markings.  
This can be used if you have two visualizations with different 
markings and want to see which markers are present in either of the 
two markings. This dynamic item will then show data that has been 
marked using either of the selected markings. 

Limit data using 
filterings 

Defines how different filtering schemes in the analysis should affect 
this dynamic item. 
Select Use the current filtering from the page if you want the 
dynamic item to always utilize the filtering scheme that is used on 
the page where the dynamic item is located. If you move the 
dynamic item to a new page, then the dynamic item will 
automatically start reacting on the filtering scheme that is used on 
the new page.  
Select a specific filtering scheme from the list if you want the 
dynamic item to always use that filtering scheme. Moving the 
dynamic item to another page with a different filtering scheme will 
not affect this setting. 
If you select to limit data using more than one filtering scheme, the 
intersection of the filterings will be used. This means that the 
dynamic item will show only the data that is made visible by all of 
the filtering schemes. 

New... Opens the New Filtering Scheme dialog where you can specify a 
new filtering scheme. 
The color and name of a previously created filtering scheme is 
edited in the Document Properties dialog. 

Limit data using 
expression 

You can limit what data should be available for a certain dynamic 
item using an expression. If you have defined a limiting expression, 
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it will be displayed here. 

Edit... Opens the Limit Data Using Expression dialog where you can define 
an expression to use for limiting the data in this dynamic item. 

4.3.3.9.6 Calculated Value Settings - Formatting 

 

Option Description 

Axes Displays how the calculated value is formatted. 

Reset Resets the formatting for the calculated value according to the settings 
defined on column level. If no column formatting has been set, axis 
formatting settings defined in the Options dialog will be used. If no 
settings have been specified in the Options dialog, the default settings 
for the visualization type will be used. 

Category Lists the available formatting categories for the selected axis (value). 
Each category in this list has separate settings. Which categories are 
available depends on the data type of the selected axis. See Formatting 
Settings for a full description of all possible options. 
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4.3.3.9.7 Calculated Value Settings - Values 

 

Option Description 

Calculate values 
using 

Select the column and aggregation method to base your calculated 
value on. 

Rules Lists all defined rules.  
If you add many rules, the rules are prioritized from top to bottom. 
None of the rules further down in the list will be considered once a rule 
higher up in the list has been applied. You can click and drag a rule in 
the Rules list to change the order. 

Add Rule... Opens the Add Rule dialog where you can define a rule to control the 
color and font style for a calculated value. For example, you can define 
one rule to give the top five items in your data a particular color and 
another rule to provide a different color for all other rows. See Details 
on Add/Edit Rule for full descriptions of the rule types. 
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4.3.3.9.8 Calculated Value Settings - Actions 

 

Option Description 

Perform action on 
click 

Select the check box to specify an action that should happen when 
clicking on the calculated value. Actions include operations like going 
to another page, applying a bookmark, a data function or executing a 
script.  

Settings... Opens the Action Settings dialog where you can specify what should 
happen when clicking on this calculated value. 
In the graphical table, the action is specified for the whole item 
column. However, if the action is based on a script, then you may 
obtain different results depending on which cell you click on. See 
Action Script Examples for more information. 
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4.3.3.9.9 Calculated Value Settings - Tooltip 

 

Option Description 

Display the 
following values 

Specifies what will be shown in the tooltip. 

Move Up Moves the selected value up in the list and, hence, up in the tooltip. 

Move Down Moves the selected value down in the list and, hence, down in the 
tooltip. 

Tooltip format   

   Value names and 
values 

Shows the tooltip content in a format where the selected column name, 
hierarchy or custom expression is displayed. For example, Year: 2003, 
Type: Cucumber, etc. 

   Visualization 
properties and 
values 

Shows the tooltip content in a format where the visualization property 
for each value is displayed. For example, X: 2003, Color: Cucumber, 
etc. 
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4.3.3.9.10 Details on Add/Edit Rule 
Use these dialogs to define or edit a color rule for a calculated value. This will make sure 
certain values stand out with a specific color or formatting. 

► To reach the Add/Edit Rule dialog: 
1. In the Calculated Value Settings dialog, go to the Values page. 
2. Click on the Add Rule... button to add a rule. To edit an existing rule, double-click on 

the rule of interest in the list. 

 

Option Description 

Rule type Specifies which rule type to add. See below for descriptions of all 
available rule types. 

Value Defines the value or values the rule should apply to. The available 
options depend on the rule type selected. See Details on Point/Value 
Menu for descriptions of all the options in this menu. 

Color Specifies the color to use for the rule. 

Font style Specifies the font style to use for the rule. You can show calculated 
values using Regular, Bold or Italic font style. 

  

Available rule types: 

Rule Type Description 

Top Sets the top number of items to the selected appearance. Specify the 
number of items to affect in the Value field. 
Note: In some cases more than the defined number of items may be 
affected by a rule. For example, if the rule states that the top three 
items should be yellow, and four items represent the highest value, 
then all four of these items will become yellow. 

Bottom Sets the bottom number of items to the selected appearance. Specify 
the number of items to affect in the Value field. 
Note: In some cases more than the defined number of items may be 
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affected by a rule. For example, if the rule states that the bottom three 
items should be yellow, and four items represent the lowest value, then 
all four of these items will become yellow. 

Between Sets all the items representing values between the two specified values 
to the selected appearance. Specify the values in the two Value fields. 

Equal to Sets all the items representing values that are equal to the specified 
value to the selected appearance. 

Not equal to Sets all the items representing values that are not equal to the specified 
value to the selected appearance. 

Greater than Sets all the items representing values greater than the specified value to 
the selected appearance. 

Greater than or 
equal to 

Sets all the items representing values greater than or equal to the 
specified value to the selected appearance. 

Less than Sets all the items representing values less than the specified value to 
the selected appearance. 

Less than or equal 
to 

Sets all the items representing values less than or equal to the specified 
value to the selected appearance. 

Boolean 
expression 

Lets you define a boolean expression. All the items for which the 
expression is true will get the specified appearance. See To add a 
boolean expression as a rule for a description. To learn more about 
custom expressions in general, see Custom Expressions Introduction. 
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4.3.3.10 Icon 

4.3.3.10.1 What are Icons? 
Icons are small, simple images traditionally used for displaying trends or variations of some 
variable. They can be displayed in the context of a graphical table or, separately, in a text area. 
In the example below, the icons are used in a graphical table to show the top, bottom and 
intermediate sales region of some fictive product: 

 
The general idea of icons is that they can be included directly where they are needed, in tables 
or text, in order to provide information at a glance. Icons can be set up to change with filtering 
like any traditional Spotfire visualization or they can be locked to show  fixed values, using the 
Data page in the Icon Settings dialog. 
  

4.3.3.10.2 How to Use Icons 
Icons can be shown both separately in a text area or be included as a column in a graphical 
table. The behavior of the icon is quite similar in both places, but some differences exist. 
Therefore, this list of step instructions has been split into three different sections: General 
information applicable to both instances, Graphical table specific information and Text area 
specific information. 

General information 

► To add actions performed when clicking on the icon: 
1. Open the Icon Settings dialog and go to the Actions page. 
2. Select the Perform action on click check box. 
3. Click on Settings.... 

Response: The Action Settings dialog is displayed. 
4. Type a good Description explaining what will happen when clicking on the icon. 

Comment: The description can be shown in the tooltip for the icon. 
5. Add the desired actions and click OK. 

► To add a rule defining the color and shape: 
Icons need at least one defined rule for anything to be visible. It is the rules that determine what 
to display and when. 

1. Open the Icon Settings dialog and go to the Icons page. 
2. Click Add Rule.... 

Response: The Add Rule dialog is displayed. 
3. Define the Rule type to apply. 
4. Set the Value for the rule. 
5. Specify the Color and Shape to use when the rule is applied. 
6. Click OK. 

Comment: You can add more than one rule. If you add many rules, the rules are 
prioritized from top to bottom. You can click and drag a rule in the Rules list to change 
the order. 
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Graphical table specific information 
When icons are included in a graphical table, the settings for the icon column normally control a 
number of separate icons, potentially one for each value in the graphical table row axis. 

► To lock the icon column so it does not react to filtering: 
1. Open the Icon Settings dialog and go to the Data page. 
2. Make sure that the Specify separate data limiting radio button is selected. 
3. Clear all check boxes under Limit data using filterings. 

Comment: You can also select one filtering scheme and keep from modifying any of 
the filters in it. 

4. Click Close or OK. 

► To add an icons column to a graphical table: 
1. Right-click on the graphical table to display the pop-up menu. 
2. Select Properties. 
3. Go to the Axes page. 
4. Click on Add and select Icon from the drop-down menu. 

Response: An Icon Settings dialog is displayed and a new icon column is shown in the 
graphical table. 
Comment: Note that each icon column added to a graphical table has its own settings. 

5. On the Icons page, select a column, hierarchy or expression in the Calculate icons 
using field. 

6. Define one or more rules (see above) to control what icons to show and when. 
7. On the General page, change the Name of the new column. 

Comment: You can hide the name form the graphical table by clearing the Show name 
in header check box. (The entire header row of the graphical table can also be hidden 
from the Appearance tab of the Graphical Table Properties.) 

8. If desired, make other changes to the default settings, such as changing the filtering 
scheme on the Data page, adding an action, etc. 

9. When you are done, click Close. 

► To change the column header for an icon column: 
1. Open the Icon Settings dialog and go to the General page. 
2. Type a new Name for the column. 
3. Make sure that the Show name in header check box is selected. 
4. Click Close. 

► To hide the column name from a graphical table: 
Open the Icon Settings dialog and go to the General page. 

1. Clear the Show name in header check box. 
Comment: The entire header row of the graphical table can be hidden from the 
Appearance tab of the Graphical Table Properties. 

2. Click Close. 

Text area specific information 
When a icon is used in a text area it behaves slightly different from when it is included in a 
graphical table. For example, you will not get instant feedback to your changes since the icon 
does not show up until you leave the edit mode. However, the placement of the edit box tells 
you where in the text area the icon will show up. 
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► To lock the icon so it does not react to filtering: 
1. Open the Icon Settings dialog and go to the Data page. 
2. Clear all check boxes under Limit data using filterings. 

Comment: You can also select one filtering scheme and keep from modifying any of 
the filters in it. 

3. Click Close or OK. 

► To add an icon to a text area: 
1. Create a text area where you want the icon to reside. 

2. Click on the Toggle Edit Mode button, , in the text area title bar to make sure that 
the text area is in edit mode. 
Comment: You can also right-click and select Edit Text Area from the pop-up menu. 

3. Type some descriptive text in the text area regarding what the icon will show. 

4. Click on the Insert Dynamic Item button, , and select the Icon option. 
Response: The Icon Settings dialog is displayed. 

5. On the Icons page, select a column, hierarchy or expression in the Calculate icons 
using field. 

6. Define one or more rules (see above) to control what icons to show and when. 
Comment: If desired, make other changes to the default settings, such as changing the 
filtering scheme on the Data page, adding an action, etc. 

7. Click OK. 

► To change the size of the icon in a text area: 
1. Click on the Toggle Edit Mode button, , in the text area title bar to make sure that 

the text area is in edit mode. 
Response: The outline of the icon is shown as a gray box. 

2. Click on the gray edit box to select it and drag either of the corners to resize the box. 
Comment: The size slider within the Icons page of the Icon Settings dialog can only 
resize the icon within the current edit box. If the slider is set to Max, then the edit box 
limit will be the limit of the icon. If the slider is set to Min, then the icon will be small, 
even if the edit box is made larger. Hence, it is recommended that the slider in the 
Settings dialog is used only for fine tuning the size of really small icons. 

3. Click on the Toggle Edit Mode button, , in the text area title bar again. 
Response: The Edit mode is closed and you see the final result. 
Comment: You can always reset the size of the icon to the original size if you change 
your mind. Just open the Format Control dialog by right-clicking on the gray box, click 
on the Reset button and then OK, and the size will be reset. 

4.3.3.10.3 Icon Settings 
The Icon Settings dialog consists of several pages: 

• General 
• Data 
• Icons 
• Actions 
• Tooltip 

► To reach the Icon Settings dialog from a graphical table: 
1. Right-click on the icon column in a graphical table visualization. 
2. Select Properties from the pop-up menu. 



Visualizations 

275 

3. If the Icon Settings dialog is not opened directly, go to the Axes page in the Graphical 
Table Properties dialog, select the Icon column you want to modify and click 
Settings.... 

► To reach the Icon Settings dialog from a text area: 
1. Click on the Toggle Edit Mode button, , in the text area title bar, to make sure that 

the text area is in Edit Mode. 
Comment: You can also right-click and select Edit Text Area from the pop-up menu. 

2. Double-click on the gray edit box representing the desired icon in the text area. 
  

4.3.3.10.4 Icon Settings - General 

 

Option Description 

Name The name of the icon. If the icon is included in a graphical table, then 
this name is the column header which can be shown or hidden using 
the check box below. Otherwise, the name is simply used to identify 
this particular icon column on the Axes page of the graphical table or 
in Edit-mode in a text area. 

Show name in 
header 

[Only applicable when the icon is part of a graphical table.] 
Shows or hides the column header. 
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4.3.3.10.5 Icon Settings - Data 

 

Icon in Graphical Table 
When the icon is used in a graphical table the selection of data table and marking is already 
done in the Graphical Table Properties - Data page, so these options are not available here. 
Instead you will get the choice to inherit the data limiting settings or to use separate data 
limiting: 

Option Description 

Data limiting   

Use data limiting from 
graphical table  

Use this option to inherit the data limiting settings from the 
graphical table. 

Specify separate data 
limiting 

Use this option if you want to specify other limitations for the icon 
column than you have set up for the graphical table. 

Icon in Text Area 
When an icon is used in a text area you must specify the data table to work on. 

Option Description 

Data table Specifies the data table on which the visualization will work. 

Marking [Not applicable for icons in text area.] 
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All Icons 

Option Description 

Limit data using 
markings 

Lists the available markings that can be used to limit what is 
shown in this dynamic item. This means that the dynamic item 
only displays data that has been marked in other visualizations. 
If more than one marking is selected, you can choose how the data 
in the markings should be combined. 

New... Opens the New Marking dialog where you can specify a new 
marking. 
The color and name of a previously created marking is edited in 
the Document Properties dialog. 

Rows must be included 
in 

Specifies how the data in the markings should be combined if you 
have selected to limit the data by more than one marking. 

   All markings (AND) 
   

Use this option if you want this dynamic item to show the 
intersection of the markings selected in Limit data using 
markings. This can be used if you have two visualizations with 
different markings and want to see which markers are present in 
both markings. This dynamic item will then show only the data 
that has been marked using both of the selected markings. 

   Any marking (OR) 
    

Use this option if you want this dynamic item to show the union 
of the markings selected in Limit data using markings.  
This can be used if you have two visualizations with different 
markings and want to see which markers are present in either of 
the two markings. This dynamic item will then show data that has 
been marked using either of the selected markings. 

Limit data using 
filterings 

Defines how different filtering schemes in the analysis should 
affect this dynamic item. 
Select Use the current filtering from the page if you want the 
dynamic item to always utilize the filtering scheme that is used on 
the page where the dynamic item is located. If you move the 
dynamic item to a new page, then the dynamic item will 
automatically start reacting on the filtering scheme that is used on 
the new page.  
Select a specific filtering scheme from the list if you want the 
dynamic item to always use that filtering scheme. Moving the 
dynamic item to another page with a different filtering scheme 
will not affect this setting. 
If you select to limit data using more than one filtering scheme, 
the intersection of the filterings will be used. This means that the 
dynamic item will show only the data that is made visible by all of 
the filtering schemes. 

New... Opens the New Filtering Scheme dialog where you can specify a 
new filtering scheme. 
The color and name of a previously created filtering scheme is 
edited in the Document Properties dialog. 

Limit data using 
expression 

You can limit what data should be available for a certain dynamic 
item using an expression. If you have defined a limiting 
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expression, it will be displayed here. 

Edit... Opens the Limit Data Using Expression dialog where you can 
define an expression to use for limiting the data in this dynamic 
item. 

4.3.3.10.6 Icon Settings - Icons 

 

Option Description 

Calculate icons 
using 

Select the column and aggregation method to base your icon calculations 
on. 

Rules Lists all defined rules. 
If you add many rules, the rules are prioritized from top to bottom. None 
of the rules further down in the list will be considered once a rule higher 
up in the list has been applied. You can click and drag a rule in the Rules 
list to change the order. 

Add Rule... Opens the Add Rule dialog where you can define a rule to control when 
a row should display a certain icon. For example, you can define one rule 
to give the top five items in your data a particular icon and another rule 
to provide a different icon for all other rows. See Details on Add/Edit 
Rule for full descriptions of the rule types. 

Icon size Controls the size of the icon within the current boundaries. If icons are 
used within a graphical table, then the max size is limited by the row 
height of the graphical table. If an icon is added to a text area, then the 
max size is limited by the size of the gray edit box. That size can be 
modified by dragging the edit box of the icon when in edit mode. 

Alignment [Only applicable when icons are used in a graphical table.] 
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Aligns the icon header and the icons to the Left, Right or Center in the 
graphical table column. 

4.3.3.10.7 Icon Settings - Actions 

 

Option Description 

Perform action on 
click 

Select the check box to specify an action that should happen when 
clicking on the icon. Actions include operations like going to another 
page, applying a bookmark, a data function or executing a script.  

Settings... Opens the Action Settings dialog where you can specify what should 
happen when clicking on this icon. 
In the graphical table, the action is specified for the whole item 
column. However, if the action is based on a script, then you may 
obtain different results depending on which cell you click on. See 
Action Script Examples for more information. 
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4.3.3.10.8 Icon Settings - Tooltip 

 

Option Description 

Display the 
following values 

Specifies what will be shown in the tooltip. 

Move Up Moves the selected value up in the list and, hence, up in the tooltip. 

Move Down Moves the selected value down in the list and, hence, down in the 
tooltip. 

Tooltip format   

   Value names and 
values 

Shows the tooltip content in a format where the selected column name, 
hierarchy or custom expression is displayed. For example, Year: 2003, 
Type: Cucumber, etc. 

   Visualization 
properties and 
values 

Shows the tooltip content in a format where the visualization property 
for each value is displayed. For example, X: 2003, Color: Cucumber, 
etc. 
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4.3.3.10.9 Details on Add/Edit Rule 
Use these dialogs to define or edit an icon rule.  

► To reach the Add/Edit Rule dialog: 
1. In the Icon Settings dialog, go to the Icons page. 
2. Click on the Add Rule... button to add a rule. To edit an existing rule, double-click on 

the rule of interest in the list. 

 

Option Description 

Rule type Specifies which rule type to add. See below for descriptions of all 
available rule types. 

Value Defines the value or values the rule should apply to. The available 
options depend on the rule type selected. See Details on Point/Value 
Menu for descriptions of all the options in this menu. 

Color Specifies the color of the icon. 

Shape Specifies the shape of the icon. 

  

Available rule types: 

Rule Type Description 

Top Adds an icon of the selected appearance to the rows of the top number 
of items. Specify the number of items to affect in the Value field. 
Note: In some cases more than the defined number of items may be 
affected. For example, if the rule states that the top three items should 
be indicated using a yellow star, and four items represent the highest 
value, then all four of these items will get the yellow star. 

Bottom Adds an icon of the selected appearance to the rows of the bottom 
number of items. Specify the number of items to affect in the Value 
field. 
Note: In some cases more than the defined number of items may be 
affected. For example, if the rule states that the bottom three items 



TIBCO Spotfire 4.0.2 - User's Manual 

282 

should be indicated using a red star, and four items represent the 
lowest value, then all four of these items will get the red star. 

Between Adds an icon of the selected appearance to all the items representing 
values between the two specified values. Specify the values in the two 
Value fields. 

Equal to Adds an icon of the selected appearance to all the items representing 
values that are equal to the specified value. 

Not equal to Adds an icon of the selected appearance to all the items representing 
values that are not equal to the specified value. 

Greater than Adds an icon of the selected appearance to all the items representing 
values greater than the specified value. 

Greater than or 
equal to 

Adds an icon of the selected appearance to all the items representing 
values greater than or equal to the specified value. 

Less than Adds an icon of the selected appearance to all the items representing 
values less than the specified value. 

Less than or equal 
to 

Adds an icon of the selected appearance to all the items representing 
values less than or equal to the specified value. 

Boolean 
expression 

Lets you define a boolean expression. All the items for which the 
expression is true will get the an icon of the selected appearance. See 
To add a boolean expression as a rule for a description. To learn more 
about custom expressions in general, see Custom Expressions 
Introduction. 
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4.4 Bar Chart 
4.4.1 What is a Bar Chart? 

A bar chart is a way of summarizing a set of categorical data (continuous data can be made 
categorical by auto-binning). The bar chart displays data using a number of bars, each 
representing a particular category. The height of each bar is proportional to a specific 
aggregation (for example the sum of the values in the category it represents). The categories 
could be something like an age group or a geographical location. It is also possible to color or 
split each bar into another categorical column in the data, which enables you to see the 
contribution from different categories to each bar or group of bars in the bar chart. 

Example: 
The bar chart below shows the total sum of sales for fruits and vegetables over three years. 

 
The bars are colored by the Category column, which contains two values: Fruit and Vegetables. 
You can also view these color categories side-by-side as in the bar chart below. Right-click in 
the visualization and select Side-by-Side Bars from the pop-up menu to get this appearance. 

 
Another way to get a similar appearance is to add the column Category to the category axis to 
create a hierarchy on that axis. See Hierarchies to learn more about multiple columns on an 
axis. 
If you prefer the bars to be displayed horizontally, right-click in the visualization and select 
Horizontal Bars from the pop-up menu. 
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Note that in some cases the category axis is referred to as X-axis, and the value axis is referred 
to as Y-axis. This is the case in some lines and curves, for example, as well as in OVER 
statements in custom expressions. 
All visualizations except the map chart can be set up to show data limited by one or more 
markings in other visualizations only (details visualizations). They can also be limited by one or 
more filterings. Another alternative is to set up a visualization without any filtering at all. See 
Limiting What is Shown in Visualizations for more information. 

4.4.2 How to Use the Bar Chart 
► To apply coloring: 

1. In the Filters panel, click and hold the left mouse button on the filter representing the 
column you want to color by. 
Comment: Coloring is also available in the Visualization Properties dialog. The color 
of marked items is changed under Edit > Document Properties. 

2. Drag the filter to the center of the visualization. 
Response: Drop targets appear in the middle of the visualization. 

3. Release the mouse button on the Color target. 
Response: The bars are colored with one color for each category in the selected 
column. 
Comment: To learn more about coloring in Spotfire, see Coloring Overview. 

► To sort the bar chart: 
1. Right-click in the visualization to display the pop-up menu. 
2. Select Properties. 
3. Go to the Appearance page. 
4. Select the Sort bars by value check box. 

Response: The bars are sorted according to the summarized value for each bar. 
Comment: Go to the Category Axis page in the Visualization Properties dialog and 
select Reverse scale if you want the reversed order of the bars. 

► To change orientation of the bars: 
1. Right-click in the bar chart to display the pop-up menu. 
2. Select Vertical Bars or Horizontal Bars depending on the current orientation of the 

bars. 
Response: The orientation of the bars is now changed according to your selection. 
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► To change the aggregation type: 
1. Click on the axis selector on the value axis. This is where it says Sum([Column 

Name]), Count(...), or similarly. 
Response: A drop-down menu appears. 

2. Select Aggregation > and a new aggregation measure from the submenu. 
Comment: You can also right-click on the axis selector and select Custom 
Expression... from the menu to create your own expression. 
Response: The bar chart is updated to show the new information. 

► To auto-bin a continuous category axis: 
If you have a column containing values that can be interpreted as continuous values, such as an 
"Age" column, but you want to display bars for a number of age groups instead, you can use the 
auto-binning function. 

1. Put the desired continuous column on the category axis. 
2. Right-click on the column selector and select Auto-bin Column from the pop-up 

menu. 
Response: Spotfire automatically creates a number of bins in which the values are 
placed. 

3. If desired, use the binning slider to change the number of bins used in the visualization. 
Comment: You can also right-click on the column selector and select Number of 
Bins... to enter an exact number of bins on the category axis. 

► To use multiple columns on the value axis: 
This is an example of how to use two columns on the value axis. Each column will be 
represented by a bar. 

1. Click on the arrow next to the plus sign on the value axis. 
2. Select a new column from the menu. 

Comment: A column can also be dragged and dropped from the filters panel. 
3. Select (Column Names) in the category axis column selector. 

Response: The two bars appear on the category axis. 
Comment: For more information on (Column Names), see the Non-Column Selections 
page. 

► To split stacked bars: 
This is an example of how you can split the bars in a visualization to display side-by-side bars 
instead of stacked bars. 

1. Create a bar chart with one numerical column on the value axis (e.g., Sales), one 
categorical column on the category axis (e.g., Year), and one categorical column to 
color by (e.g., Category). 
Response: A stacked bar chart with the sum of the numerical column (Sales) per 
category axis category (Year) is displayed. 

2. Right-click and select Side-by-Side Bars from the pop-up menu. 
3. Response: Each color category is now presented as a separate bar. 

Comment: You could also have kept the Stacked bars option and added the color 
category column to the category axis instead, in order to produce a similar result. 

► To show each bar segment as a percentage of the total bar: 
This is an example of how you can present all stacked bars as 100% high and show the 
segments in each bar as a percentage of the entire bar. 

1. Create a bar chart with one numerical column on the value axis (e.g., Sales), one 
categorical column on the category axis (e.g., Year), and one categorical column to 
color by (e.g., Category). 
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Response: A stacked bar chart with the sum of the numerical column (Sales) per 
category axis category (Year) is displayed. 

2. Right-click and select 100% Stacked Bars from the pop-up menu. 
Response: All bars are now 100% and the percentage of each segment can be shown in 
a tooltip by hovering with the mouse pointer over the segment. 
Comment: You can also display the segment values or percentage by adjusting the 
Labels settings in the Visualization Properties dialog. 

► To mark bars or bar segments: 
• Click on a bar or bar segment to mark it. 

Comment: Press Ctrl and click to add more bars or bar segments. 
• Click and drag with the mouse to draw a rectangle over interesting items. 

Response: All bars or bar segments touched by the rectangle will be marked. 
• Place the mouse pointer in the area of the scale labels and then click and drag with the 

mouse along the axis. 
Response: A rectangle is drawn across the visualization so that you can mark all bars 
whose heights are between two specified axis values. 
Comment: Only those bars with the top part of the bar included within the axis-
marking rectangle will be marked. This allows you to select bars with heights within a 
specific span. You cannot mark bar segments using axis-marking. 
To learn more about marking, see Marking in Visualizations. 

► To add a reference line to the bar chart: 
1. Right-click on the visualization to display the pop-up menu. 
2. Select Properties. 
3. Go to the Lines & Curves page. 
4. Select the check box for any of the default lines or click on Add to define a new 

horizontal or vertical line. 
Comment: You can only add lines to the category axis when it is in continuous mode. 
Right-click on the scale labels and select Continuous Scale from the pop-up menu. 

► To add a curve fit to the bar chart: 
1. Right-click on the visualization to display the pop-up menu. 
2. Select Properties. 
3. Go to the Lines & Curves page. 
4. Click on Add and select a suitable curve fit from the drop-down menu. 

Comment: You can select from a number of predefined curve fits, or define your own 
curve using Curve Draw. See Curve Fit Models for more information about the 
different options. 

5. Once the curve has been created, you can change its settings on the Lines & Curves 
page. Some of the curve settings are also available from the pop-up menu in the 
visualization. 

► To add multiple scales: 
1. Right-click on the value axis and select Multiple Scales from the pop-up menu. 

Comment: By default, you will get one scale for each color that is defined under Color 
By. 

2. You can also go to the Value Axis page in the Visualization Properties dialog and click 
the Multiple scales radio button. This is also where you can change the settings for the 
different scales as well as define which side of the bar chart a certain scale should be 
located. 
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Comment: If you are using values from different columns on the various scales, you 
can also use drag and drop to move columns from one side to another. 

► To add error bars to the bar chart: 
1. Right-click in the visualization to display the pop-up menu. 
2. Select Properties. 
3. Go to the Error Bars page. 
4. In the Visible error bars list, select the column or measure to use, and select the check 

box next to it. 
Response: The settings for the selected column or measure will be displayed in the 
lower part of the dialog. 
Comment: Only columns and measures with numerical values are listed. 

5. To define an upper error, choose a column or measure in the Upper error column 
selector. To define a lower error, choose a column or measure in the Lower error 
column selector. 
Response: The defined error bars appear in the visualization. See the Error Bars page 
in the Bar Chart Properties for more information about the settings. To learn more 
about error bars in general, see Error Bars. 
Note: Error bars cannot be added to bar charts with percentage scaling. Therefore, 
stacked bar charts and bar charts where all bars have maximum height cannot be 
combined with error bars. 

► To create a new bar chart: 
1. Click on the New Bar Chart button on the toolbar, . 

Comment: You can also select Insert > New Visualization > Bar Chart from the 
menu. 
Response: A first attempt to set up a suitable bar chart is made by the application. 

2. Adjust the bar chart to display the categories and measures of your choice. 
Comment: For more information about how to change what to show on the two axes, 
see Column Selectors. 

4.4.3 Bar Chart Properties 

4.4.3.1 Bar Chart Properties 
The Bar Chart Properties dialog consists of several pages: 

• General 
• Data 
• Appearance 
• Formatting 
• Fonts 
• Category Axis 
• Value Axis 
• Colors 
• Labels 
• Tooltip 
• Legend 
• Trellis 
• Lines & Curves 
• Error Bars 
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► To reach the Bar Chart Properties dialog: 
1. Right-click on the bar chart visualization. 
2. Select Properties from the pop-up menu. 
3. Comment: You can also click on the bar chart visualization to make it active and then 

select Edit > Visualization Properties. 

4.4.3.2 Bar Chart Properties - General 

 

Option Description 

Title The title of the visualization. 
Tip: Double-click on the title bar of the visualization for a shortcut to 
this field. 

Show title bar Specifies whether or not to show the visualization title. 

Description A description of the visualization. This description can optionally be 
shown in the legend and/or in the visualization. 

Show description 
in visualization 

Specifies whether or not to show the description in the visualization. 
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4.4.3.3 Bar Chart Properties - Data 

 

Option Description 

Data table Specifies the data table on which the visualization will work. 

Marking Specifies the marking (that is, the color and relationships to other 
marked items) that will be used to mark items in this visualization. 

Limit data using 
markings 

Lists the available markings that can be used to limit what is shown in 
this visualization. This means that the visualization only displays data 
that has been marked in other visualizations. 
If more than one marking is selected, you can choose how the data in 
the markings should be combined. 

New... Opens the New Marking dialog where you can specify a new marking. 
The color and name of a previously created marking is edited in the 
Document Properties dialog. 

Rows must be 
included in 

Specifies how the data in the markings should be combined if you have 
selected to limit the data by more than one marking. 

   All markings 
(AND) 
   

Use this option if you want this visualization to show the intersection of 
the markings selected in Limit data using markings. This can be used if 
you have two visualizations with different markings and want to see 
which markers are present in both markings. This visualization will 
then show only the data that has been marked using both of the selected 
markings. 

   Any marking 
(OR) 
    

Use this option if you want this visualization to show the union of the 
markings selected in Limit data using markings.  
This can be used if you have two visualizations with different markings 
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and want to see which markers are present in either of the two 
markings. This visualization will then show data that has been marked 
using either of the selected markings. 

Limit data using 
filterings 

Defines how different filtering schemes in the analysis should affect 
this visualization. 
Select Use the current filtering from the page if you want the 
visualization to always utilize the filtering scheme that is used on the 
page where the visualization is located. If you move the visualization to 
a new page, then the visualization will automatically start reacting on 
the filtering scheme that is used on the new page.  
Select a specific filtering scheme from the list if you want the 
visualization to always use that filtering scheme. Moving the 
visualization to another page with a different filtering scheme will not 
affect this setting. 
If you select to limit data using more than one filtering scheme, the 
intersection of the filterings will be used. This means that the 
visualization will show only the data that is made visible by all of the 
filtering schemes. 

New... Opens the New Filtering Scheme dialog where you can specify a new 
filtering scheme. 
The color and name of a previously created filtering scheme is edited in 
the Document Properties dialog. 

Limit data using 
expression 

You can limit what data should be available for a certain visualization 
using an expression. If you have defined a limiting expression, it will be 
displayed here. 

Edit... Opens the Limit Data Using Expression dialog where you can define a 
boolean expression to use for limiting the data in this visualization. 
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4.4.3.4 Bar Chart Properties - Appearance 

 

Option Description 

Orientation   

   Vertical bars Use this option to display the bars in the visualization vertically. 

   Horizontal bars Use this option to display the bars in the visualization horizontally. 

Layout   

   Side-by-side bars Use this option to place bars from the color category side-by-side 
instead of stacked on top of each other. The effect is similar to what 
you get if you add the color category column to the category axis 
together with the current category axis column. 

   Stacked bars Use this option to keep color categories stacked on top of each other. 

   100% stacked 
bars 

Use this option to set the heights of all bars to 100%. The size of the 
bar segments represents how much of the percentage of the total sum 
for the group is constituted of the sums of the values in the category. 
The exact percentage of each category can be seen in the tooltip 
displayed when hovering with the mouse pointer over a bar segment. 

Bar width Drag the slider to modify the width of the bars. 

Show shadows 
indicating the 
unfiltered data 

Shows a gray shadow behind all visible bars, indicating the height of 
the bar if all filters are reset and all data is available. 

Sort bars by value Sorts all bars from the highest to the lowest bar. The bars are resorted 
when filtering is applied. 
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Time series   

   Compensate for 
missing values 

Select this check box if you are using a Date, Time or DateTime 
column somewhere in the visualization and you need to perform some 
calculation where a required time period is missing. For example, if 
you have created a visualization showing cumulative sums and there 
are missing data for some categories, selecting this check box will 
produce a bar of the same size as the previous bar instead of showing 
no bar at all. See Working With Time Hierarchies for more 
information. 
Enabling this setting will temporarily add new rows with empty values 
for the missing periods so that they can be used in the calculation. 

4.4.3.5 Bar Chart Properties - Formatting 

 

Option Description 

Axes Displays which column and category are currently being used on each 
of the two axes in the bar chart. Click on the one you want to change 
the settings for. If the columns on the axes are of the same type, you 
can set formatting for both axes at the same time. 

Reset Resets the formatting for the selected axis values according to the 
settings defined on column level. If no column formatting has been set, 
axis formatting settings defined in the Options dialog will be used. If 
no settings have been specified in the Options dialog, the default 
settings for the visualization type will be used. 

Category Lists the available formatting categories for the selected axis. Each 
category in this list has separate settings. Which categories are 
available depends on the data type of the selected axis. See Formatting 
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Settings for a full description of all possible options. 

Note: These settings affect only the current visualization. For general information about 
formatting, see Formatting Overview. 

4.4.3.6 Bar Chart Properties - Fonts 

 

Option Description 

Settings for Lists all items for which you can change the font settings. Click to 
select an item in the list to change the font settings for that text in the 
visualization. Press Ctrl and click on more items to change the settings 
for multiple items simultaneously. 

Font Specifies the font to use for the selected items. 

Font style Specifies the font style to use for the selected items. 

Size Specifies the font size to use for the selected items. 
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4.4.3.7 Bar Chart Properties - Category Axis 

 

Option Description 

Columns Specifies the column or hierarchy to be displayed on the category axis. 

Settings... Opens the Advanced Settings dialog, where you can change the scale 
mode from categorical to continuous, and vice versa, as well as 
changing the category mode to determine which combinations to 
show. 

Range   

   Min Determines the lower value of the axis range. Leave the field blank to 
automatically adjust the range to the currently lowest value in the 
filtered data. 

   Max Determines the upper value of the axis range. Leave the field blank to 
automatically adjust the range to the currently highest value in the 
filtered data. 

   Set to Current 
Range 

Allows you to set the axis range to the currently filtered values. 
  

   Include origin Available for continuous axes only. Always includes the coordinates 
(0, 0) in the visualization, regardless of filtering. 

   Show zoom slider Shows a zoom slider that you can manually manipulate to view only 
the interesting bars in the bar chart. 

Show gridlines Specifies whether or not gridlines should be visible. 
Comment: This refers to vertical gridlines in a vertical bar chart, and 
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horizontal gridlines in a horizontal bar chart. 

Scale labels   

   Show labels Specifies whether or not scale labels should be visible. 

      Horizontally Shows scale labels horizontally. 

      Vertically Shows scale labels vertically. 

      Max number of 
labels 

Select the check box to specify a maximum number of scale labels to 
be shown. Limiting the number of labels can improve readability on 
axis scales with many values. 

Scale   

   Log scale Available for continuous axes only. Changes the scale from a linear 
scale to a logarithmic base 10 scale [log10 (x)]. 

   Reverse scale Reverses the current sort order, so that the lowest value is displayed at 
the top of the scale. 

4.4.3.8 Bar Chart Properties - Value Axis 

One value axis with a single scale 

 

Option Description 

Columns Specifies the column or hierarchy to be displayed on the value axis. 

Settings... [Not available in this visualization.] 
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One axis with a 
single scale 

Use this option if you want to show the values from a single column 
on the value axis, or if you have multiple columns that can be 
presented using the same scale. 

Multiple scales Use this option to show two value axes (left and right) with two or 
more different scales. For example, use it if you want to display two 
columns of very different magnitudes in the same visualization. 

Range   

   Min Determines the lower value of the axis range. Leave the field blank to 
automatically adjust the range to the currently lowest value in the 
filtered data. 

   Max Determines the upper value of the axis range. Leave the field blank to 
automatically adjust the range to the currently highest value in the 
filtered data. 

   Set to Current 
Range 

Allows you to set the axis range to the currently filtered values. 
  

   Include origin Available for continuous axes only. Always includes the coordinates 
(0, 0) in the visualization, regardless of filtering. 

   Show zoom slider Shows a zoom slider that you can manually manipulate to view only 
the interesting segments of the bar chart. 

Show gridlines Specifies whether or not gridlines should be visible. 
Comment: This refers to vertical gridlines in a horizontal bar chart, 
and horizontal gridlines in a vertical bar chart. 

Scale labels   

   Show labels Specifies whether or not scale labels should be visible. 

      Horizontally Shows scale labels horizontally. 

      Vertically Shows scale labels vertically. 

      Max number of 
labels 

Select the check box to specify a maximum number of scale labels to 
be shown. Limiting the number of labels can improve readability on 
axis scales with many values. 

Scale   

   Reverse scale Reverses the current sort order on the scale. 
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Multiple scales 

 

Option Description 

Columns Specifies the column or hierarchy to be displayed on the value axis. 

Settings... [Not available in this visualization.] 

One axis with a 
single scale 

Use this option if you want to show the values from a single column 
on the value axis, or if you have multiple columns that can be 
presented using the same scale. 

Multiple scales Use this option to show two value axes (left and right) with two or 
more different scales. For example, use it if you want to display two 
columns of very different magnitudes in the same visualization. 

Individual scaling   

   For each color Use this option to display one scale for each category used to color the 
markers by. For example, if you put two different columns on the 
value axis (for example, Oil Production and BNP), you can use the 
"(Column Names)" option to color by and click this radio button to 
display one scale for Oil Production and one for BNP. 
Do not use this option if you need to color by a large number of 
different categories. 
Note that you should apply true categorical coloring before using this 
option. If you use a continuous column on the color axis, you may end 
up with a different result than the expected. This applies even if the 
continuous color mode looks "categorical" at first sight. 
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   For each trellis 
panel 

Use this option to display one scale for each trellis panel. 

Zoom   

   Show zoom slider Shows a zoom slider that you can manually manipulate to view only 
the interesting segments of the bar chart. 

   Show gridlines Specifies whether or not gridlines should be visible. 
Comment: This refers to vertical gridlines in a horizontal bar chart, 
and horizontal gridlines in a vertical bar chart. 

Scale labels   

   Show labels Specifies whether or not scale labels should be visible. 

      Horizontally Shows scale labels horizontally. 
Note: Only available for individual scaling for each trellis panel. 

      Vertically Shows scale labels vertically. 
Note: Only available for individual scaling for each trellis panel. 

      Max number of 
labels 

Select the check box to specify a maximum number of scale labels to 
be shown. Limiting the number of labels can improve readability on 
axis scales with many values. 

Individual scale 
settings 

  

[Drop-down list] Select the scale for which you wish to change the settings. Select All 
scales to change settings for all scales simultaneously. 

Scale Range... Opens the Scale Range dialog where you can specify the range of the 
selected scale, and also determine whether or not to include the origin 
(0,0). 

Position Specifies which side of the visualization the scales should be 
positioned. The available alternatives vary depending on whether the 
bars are displayed vertically or horizontally. 

   Left value axis Select this option to place the selected scale on the left-hand side of 
the visualization in a vertical bar chart. 

   Right value axis Select this option to place the selected scale on the right-hand side of 
the visualization in a vertical bar chart. 

   Bottom value 
axis 

Select this option to place the selected scale at the bottom of the 
visualization in a horizontal bar chart. 

   Top value axis Select this option to place the selected scale on top of the visualization 
in a horizontal bar chart. 

Reverse scale Reverses the current sort order on the scale. 
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4.4.3.9 Bar Chart Properties - Colors 

 

Option Description 

Columns Specifies the column or hierarchy to color by. 

Settings Opens the Advanced Settings dialog where you can change the scale 
mode for the selected column or hierarchy from continuous to 
categorical and vice versa, as well as changing the category mode to 
determine which combinations to show. 

Color mode Specifies in which color mode to set up the color scheme. Which 
modes are available depends on whether the scale is in categorical or 
continuous mode. For columns in continuous scale mode, you can 
select one of the following color modes: Gradient, Segments, or 
Fixed. For columns in categorical scale mode, you can select either 
Categorical or Fixed color mode. To learn more about the color 
modes, see Color Modes Overview. 

One scale per Specifies whether there should be one separate scale per trellis panel 
for trellised bar charts, or if one scale should apply to the entire 
visualization. Only applicable to columns in continuous scale mode. 

 
[Color Schemes 
menu] 

Opens a menu where you can select an already existing color 
scheme and apply it to the visualization, or apply the currently open 
color scheme to another visualization in the analysis. 

   From Visualization Lets you select a color scheme from another visualization in the 
analysis. Only color schemes that are applicable to the current color 
scheme will be listed. 
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   Document Color 
Schemes 

Lets you select a color scheme that has previously been saved within 
the analysis. Only color schemes that are applicable to the current 
color scheme will be listed. This menu option is only available if 
one or more document color schemes already exist. 

   [Predefined color 
schemes] 

Lists a number of predefined color schemes. Available for columns 
in continuous scale mode only. For a full description of the 
predefined color schemes, see Predefined Color Schemes. 
Tip: To facilitate setting up a new color scheme, you can open a 
predefined color scheme with a similar appearance, and then adjust 
it to suit your needs. 

   Open from 
Library... 

Opens the Open from Library dialog where you can select a color 
scheme that has previously been saved to the library. 

   Open from File... Opens a dialog where you can select a previously saved color 
scheme. 

   Save As Lets you save a color scheme as a library item, a local file or a 
document color scheme. 
Library Item – Opens the Save as Library Item dialog, where you 
can specify a location in the library and a file name to save the 
currently open color scheme for later reuse. 
File – Opens a dialog where you can specify a location and a file 
name to save your currently open color scheme locally on your 
computer for later reuse. 
Document Color Scheme – Opens the Save as Document Color 
Scheme dialog, where you can specify a name and save the currently 
open color scheme for later reuse within the analysis. 

   Apply to 
Visualizations... 

Opens the Apply to Visualizations dialog where you can select other 
visualizations (within the analysis) that you want to apply the 
current color scheme to. Only visualizations with compatible color 
schemes are listed. 
Note: If you apply a color scheme to a table, cross table, or heat 
map, the coloring will not take effect immediately. The color 
scheme will be added as an empty color scheme grouping, and you 
must select which columns or axis values to include in the grouping 
by opening the Edit Color Scheme Grouping dialog. 

[Color scheme area] The area in the lower part of the dialog shows the current color 
scheme. That is, the colors and values currently used in the 
visualization. You can modify color schemes in numerous ways to 
give the visualization the appearance you prefer. The color scheme 
area will look different, and have different available settings, 
depending on the characteristics of the column used to color the 
visualization by, as well as the selected color mode. To learn more 
about color schemes and color modes, see Color Schemes Overview 
and Color Modes Overview respectively. 

Add Point Available for continuous columns only. Adds a new anchor point to 
the color scheme. 

Delete Point Available for continuous columns only. Deletes the selected anchor 
point. 
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Add Rule... Opens the Add Rule dialog where you can define a rule that 
functions as an exception to the rest of the defined color scheme. A 
rule has higher priority than the rest of the color scheme. For 
example, you can define a rule to give the top five items in your data 
a different color than the rest of the items. If you add many rules to a 
color scheme, the rules are prioritized from top to bottom. Which 
rule types are available depends on the characteristics of the column 
or hierarchy used to color the visualization by. See Details on 
Add/Edit Rule for full descriptions of the rule types. 

Reset Resets the color scheme to the one that was in effect when the 
visualization was created. Any added rules will be removed. Which 
color scheme should be used by default when you create a new 
visualization is defined in the Visualization page of the Options 
dialog. 

 

4.4.3.10 Bar Chart Properties - Labels 

 

Option Description 

Show labels for Determines whether to show labels on all bars (All), bars containing 
marked rows only (Marked rows), or not to show any labels at all 
(None). 

Types of labels Determines whether to show labels on the Complete bar and/or on 
Bar segments only. For bar segments you can also specify whether 
you want the value of the bar segment or the bar segments' percentage 
of the total value to be shown. 
Note that bar segment labels are only drawn if they fit within the bar 
segment. If no labels are shown, try increasing the bar width, using a 
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smaller font for the label, or removing some bar percentage decimals. 

Label orientation Determines whether to display the labels horizontally or vertically. 

Max number of 
labels on complete 
bars 

Specifies the maximum number of labels to be shown. If the number is 
smaller than the available number of bars, the labels will be equally 
distributed along the category axis. 

Bar percentage 
decimals 

Specifies the number of decimals to show when 100% bars are used. 
Note: Bar percentage is only visible when you have selected the option 
All bars should have maximum height on the Appearance page, and 
it gives relevant information only when the bars are colored by a 
column or hierarchy. The number specified here will also affect the 
number of decimals shown for bar segments in the tooltip. 

4.4.3.11 Bar Chart Properties - Tooltip 

 

Option Description 

Display the 
following values 

Specifies what will be shown in the tooltip. 

Add... Opens the Add Tooltip Value dialog, where you can add the content 
from another column, hierarchy, or any custom expression to be 
shown in the tooltip. You can also use images in tooltips. See 
Highlighting in Visualizations for more information. 

Edit... Opens the Edit Tooltip Value dialog, where you can change the 
information to be shown in the tooltip. 

Delete Deletes the selected value from the list. 
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Move Up Moves the selected value up in the list and, hence, up in the tooltip. 

Move Down Moves the selected value down in the list and, hence, down in the 
tooltip. 

Tooltip format   

   Value names and 
values 

Shows the tooltip content in a format where the selected column name, 
hierarchy or custom expression is displayed. For example, Year: 2003, 
Type: Cucumber, etc. 

   Visualization 
properties and 
values 

Shows the tooltip content in a format where the visualization property 
for each value is displayed. For example, Category axis: 2003, Color: 
Cucumber, etc. 

4.4.3.12 Bar Chart Properties - Legend 

 

Option Description 

Show legend Specifies whether or not the docked legend should be shown in the 
visualization. 

Position Specifies which side of the visualization the legend should be 
positioned: the right-hand side or the left-hand side. 

Display the 
following legend 
items 

Specifies what will be shown in the legend.  
By clearing a check box you will completely hide that item from the 
legend. You can also select to show or hide parts of the legend 
information using the check boxes under Settings for the selected item 
in the list, see below. 

Settings Defines how the selected legend item should be displayed. The 
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available options vary between legend items. 

   Show title Use this option to show or hide the title for the selected item. The title 
is typically what is displayed above an axis selector or similar: 

 

   Show axis 
selector 

Select this option to show or hide the axis selector for the selected item.  

 

4.4.3.13 Bar Chart Properties - Trellis 

 

Option Description 

Rows and columns Splits the visualization into different panels for all categories 
in the selected column or hierarchy. The number of values in 
the specified column or hierarchy controls the number of 
panels to be displayed in each row, column or page, 
respectively. 

   Rows A row with trellis panels will be created for each value in the 
selected column or hierarchy. 
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   Columns A column with trellis panels will be created for each value in 
the selected column or hierarchy. 

   Pages A new page with trellis panels will be created for each value in 
the selected column or hierarchy. Scroll down in the 
visualization to see the next page. 

Panels Splits the visualization into different panels for all categories 
in the selected column or hierarchy, without binding any 
dimensions to either rows or columns. This means that the 
number of actual values in the column to split by does not 
control the number of shown rows or columns in any way. 
The number of panels that should be visible on each page is 
instead specified using the Max number of rows and Max 
number of columns controls below. 

   Split by Specifies the column or hierarchy to define the categories by 
which the visualization should be split. 

   Manual layout Select the check box to manually specify the number of rows 
and columns that should be visible without scrolling. If the 
check box is cleared, the application will automatically specify 
the number of rows and columns. 

   Max number of rows Specifies the maximum number of panels that should be 
visible on each page. 

   Max number of columns Specifies the maximum number of panels that should be 
visible on each page. 

Settings... Opens the Advanced Settings dialog, where you can change 
the category mode to determine which combinations to show. 
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4.4.3.14 Bar Chart Properties - Lines & Curves 

 

First part of the dialog 

Option Description 

Visible lines and 
curves 

Lists the currently added lines and curves. If a checkmark is shown in 
the check box, then that reference line is shown in the visualization. 
Clear the check box to hide a line or curve. 
New lines and curves can be added to this list by clicking on the Add 
button; see below. 

Add Displays a menu where you can select which type of line or curve to 
add to the list of available lines and curves, and in some cases, opens a 
dialog where you can specify settings to use for that line or curve. 
For more information about the different curve types, see Curve Fit 
Models. 

Edit... Opens a dialog where you can change the settings for the selected line 
or curve (when applicable). 

Remove Removes the selected line or curve from the list of available lines and 
curves. 

More   

   Duplicate Duplicates the currently selected line or curve. This can be particularly 
useful if you want to add one static curve that is calculated on the 
whole data set (select the Update curve manually check box) and 
another one that is changed upon filtering (default). 
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   Export Curve Fit 
Result... 

Opens a dialog where you can choose to export the curve fit result for 
the selected curve to a text file or to Microsoft® Excel®. The text file 
can be either a regular tab separated text file, or a Spotfire Text Data 
Format file, which contains a bit more information about the columns 
(types, etc.). The Excel file can be either an XLS file or an XLSX file. 

Settings 

Option Description 

Appearance Determines the color, style and width of lines and curves, as well as 
the color, style and size of points. 

Place in Select whether to place the line, curve or point in the Foreground or 
Background of the visualization. 

Transparency Determines the transparency of the selected line, curve or point. That 
is, the degree to which the markers can be seen through it. The 
transparency is strongly connected to the color. 

Label and Tooltip Opens a dialog where you can determine what information to show in 
the label and/or tooltip for the selected line, curve or point. 

Included in axis 
range 

Sets the automatic zooming so that the line, curve or point is always 
shown, even if it lies far from the currently filtered values. 

Update manually Select the check box to "freeze" the line or curve so that it is not 
automatically recalculated upon filtering. You can update the line or 
curve by clicking the Update button below or by right-clicking in the 
visualization and selecting Update Lines and Curves and clicking on 
the one you want to update. 
Note: Not applicable for points. 

Update When a line or curve has been specified to be manually updated, use 
this button to perform the update. 

One per Determines whether to show one line or curve per Color and/or Trellis 
panel. 
Note: Not applicable for points. 
Note that you should apply true categorical coloring before using the 
color option. If you use a continuous column on the color axis, you 
may end up with a different result than the expected. This applies even 
if the continuous color mode looks "categorical" at first sight. 

Note: Whenever there is a reference to X or Y in lines or curves for a bar chart, X always refers 
to the category axis while Y refers to the value axis. 
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4.4.3.15 Bar Chart Properties - Error Bars 

 

Option Description 

Visible error bars Lists the numerical columns and measures that you can define error 
bars for in the visualization. If a check mark is shown in the check box, 
then error bars for that column or measure are visible in the 
visualization. Clear the check box to hide the error bars for a column or 
measure. 
Note: No error bars will be visible in the visualization until an upper or 
lower error has been defined. 

Settings Shows the settings for the selected column or measure. 

   Upper error Specifies the column and aggregation method, or custom expression to 
use for the upper error bars. 
Note: The chosen column or measure must have numerical values. 

   Lower error Specifies the column and aggregation method, or custom expression to 
use for the lower error bars. 
Note: The chosen column or measure must have numerical values. 

   Color   

      Same as bar Choose this option if you want an error bar to have the same color as 
the bar. 
Note: For positive bars, the lower error bar will be invisible if this 
option is selected, and for negative bars, the upper error bar will be 
invisible. 

      Custom Choose this option if you want to use a custom color for the error bars. 
Click on the drop-down list to show the palette and select a different 
color. 
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   Show end caps Specifies whether or not orthogonal lines should be displayed at the 
end of the error bars. 

   Include error 
bars in axis range 

Sets the automatic zooming so that the error bars are always visible. 

Note: The upper and lower errors refer to the underlying data. This means that if you use 
reversed scales in a visualization, the error bars will also be reversed. For example, for a vertical 
bar chart with reversed value axis, the upper error bar will be displayed below the bar. It also 
means that when the bars are displayed horizontally, an upper error will be displayed to the 
right of the bar. 

4.5 Line Chart 
4.5.1 What is a Line Chart? 

Line charts are ideal for showing trends over time. A standard example would be how the stock 
value for a certain company develops over time on the stock market. However, it does not 
necessarily need to be time along the X-axis. Any data that behaves like a function with respect 
to the variable on the X-axis can be plotted. Line charts emphasize time flow and rate of change 
rather than the amount of change. 
You can select parts of a line by clicking and dragging with the mouse. If one node in the line is 
included when you drag, that node will be marked. If two or more adjacent nodes are included, 
the line between the nodes will also be marked, but if there are nodes in between which are not 
included, only the separate nodes will be marked. You can select several nodes in different parts 
of the line by pressing Ctrl and click and drag with the mouse. By pressing Alt, the entire line 
is marked if you click and drag, just as it is if you simply click once anywhere on the line. 

Example: 
Below is a line chart showing the sum of sales for two different product categories over several 
years. The line chart has one color (one line) per product category. 

 
When several different years are available it may also be useful to trellis the data by year to 
display the variation during the years separately: 
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Multiple scales can also be used on the Y-axis, when you want to compare several lines with 
significantly different value ranges. 

Step lines 
The line chart can also be used as a step chart, where the lines are drawn in incremental steps 
rather than as straight lines between each value. 
Step charts are especially useful when changes occur at certain times but the values remain 
more or less stable between changes.  

 
Changing into step mode is done by selecting the Draw as step lines check box on the 
Appearance page of the Line Chart Properties dialog. 
All visualizations except the map chart can be set up to show data limited by one or more 
markings in other visualizations only (details visualizations). They can also be limited by one or 
more filterings. Another alternative is to set up a visualization without any filtering at all. See 
Limiting What is Shown in Visualizations for more information. 

4.5.2 How to Use the Line Chart 
► To apply coloring (split in categories): 

1. In the filters panel, click and hold down the left mouse button on the filter representing 
the column that you want to color by. 
Comment: Coloring is also available in the Visualization Properties dialog. The color 
of marked items is changed under Edit > Document Properties. 

2. Drag the filter to the center of the visualization. 
Response: Drop targets appear in the middle of the visualization. 

3. Release the mouse button on the Color target. 
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Response: The lines are colored with one color for each category in the selected 
column. If the lines have not been previously split by adding a Line By column, the 
lines will be split according to the color categories. 
Comment: To learn more about coloring in Spotfire, see Coloring Overview. 

► To mark parts of the line: 
1. Click and drag with the mouse around the part of the line you want to mark. 

Response: If one node in the line is included when you drag, that node will be marked. 
If two or more adjacent nodes are included, the line between the nodes will also be 
marked, but if there are nodes in between which are not included, only the separate 
nodes will be marked. 
Comment: You can select several nodes in different parts of the line by pressing Ctrl 
and click and drag with the mouse. 

► To mark the entire line: 
1. Click once anywhere on the line. 

OR 
2. Press Shift and click and drag with the mouse over the line. 

► To use multiple columns on one axis: 
This is an example of how to use two columns on the Y-axis. Each column will be represented 
by a colored line. 

1. Click on the arrow next to the plus sign on the axis of your choice. 
2. Select a new column from the menu. 

Comment: A column can also be dragged and dropped from the filters panel. 
3. Select (Column Names) in the Color By drop down list. 

Response: The lines are colored with one color for each column. 
Comment: For more information on (Column Names), see the Non-Column Selections 
page. 

► To split lines without coloring: 
1. In the filters panel, click and hold down the left mouse button on the filter representing 

the column that you want to split by. 
Comment: The Line By setting is also available in the Properties dialog. 

2. Drag the filter to the center of the visualization. 
Response: Drop targets appear in the middle of the visualization. 

3. Release the mouse button on the Line By target. 
Response: The lines are split into one line for each category in the selected column, 
unless coloring has already split the lines in a more granular way. 
Comment: It is also possible to combine a Line By action with a Color By, so that the 
lines are split by one category and colored by another. 

► To add a reference line to the line chart: 
1. Right-click on the visualization to display the pop-up menu. 
2. Select Properties. 
3. Go to the Lines & Curves page. 
4. Select the check box for any of the default lines or click on Add to define a new 

horizontal or vertical line. 
Comment: You can only add lines to the X-axis when it is in continuous mode. Right-
click on the scale labels and select Continuous Scale from the pop-up menu. 
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► To add multiple scales: 
1. Right-click on the Y-axis and select Multiple Scales from the pop-up menu. 

Comment: By default, you will get one scale for each color that is defined under Color 
By. 

2. You can also go to the Y-axis page in the Visualization Properties dialog and click the 
Multiple scales radio button. This is also where you change the settings for the 
different scales and determine whether a certain scale should be located on the left or 
the right Y-axis. 
Comment: If you are using values from different columns on the various scales, you 
can also use drag and drop to move columns from one side to another. 

► To add a curve fit to the line chart: 
1. Right-click on the visualization to display the pop-up menu. 
2. Select Properties. 
3. Go to the Lines & Curves page. 
4. Click on Add and select a suitable curve fit from the drop-down menu.. 

Comment: You can select from a number of predefined curve fits, or define your own 
curve using Curve Draw. See Curve Fit Models for more information about the 
different options. 

5. Once the curve has been created, you can change its settings on the Lines & Curves 
page. Some of the curve settings are also available from the pop-up menu in the 
visualization. 

► To add error bars to the line chart: 
1. Right-click in the visualization to display the pop-up menu. 
2. Select Properties. 
3. Go to the Error Bars page. 
4. In the Visible error bars list, select the column or measure to use, and select the check 

box next to it. 
Response: The settings for the selected column or measure will be displayed in the 
lower part of the dialog. 
Comment: Only columns and measures with numerical values are listed. 

5. To define an upper error, choose a column or measure in the Upper error column 
selector. To define a lower error, choose a column or measure in the Lower error 
column selector. 
Response: The defined error bars appear in the visualization. 
Comment: Error bars can only be used on numerical values. 
Note: Error bars cannot be added to line charts with percentage scaling. Therefore, line 
charts using individual scaling for each line cannot be combined with error bars. 

► To create a new line chart: 
1. Click on the New Line Chart button on the toolbar, . 

Comment: You can also select Insert > New Visualization > Line Chart from the 
menu. 
Response: A first attempt to set up a suitable line chart is made by the application. 

2. Adjust the line chart to display the categories and measures of your choice. 
Comment: For more information about how to change what to show on the two axes, 
see Column Selectors. 
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4.5.3 Line Chart Properties 

4.5.3.1 Line Chart Properties 
The Line Chart Properties dialog consists of several pages: 

• General 
• Data 
• Appearance 
• Formatting 
• Fonts 
• X-axis 
• Y-axis 
• Line By 
• Colors 
• Labels 
• Tooltip 
• Legend 
• Trellis 
• Lines & Curves 
• Error Bars 

► To reach the Line Chart Properties dialog: 
1. Right-click on the line chart visualization. 
2. Select Properties from the pop-up menu. 
3. Comment: You can also click on the line chart visualization to make it active and then 

select Edit > Visualization Properties. 
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4.5.3.2 Line Chart Properties - General 

 

Option Description 

Title The title of the visualization. 
Tip: Double-click on the title bar of the visualization for a shortcut to 
this field. 

Show title bar Specifies whether or not to show the visualization title. 

Description A description of the visualization. This description can optionally be 
shown in the legend and/or in the visualization. 

Show description 
in visualization 

Specifies whether or not to show the description in the visualization. 
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4.5.3.3 Line Chart Properties - Data 

 

Option Description 

Data table Specifies the data table on which the visualization will work. 

Marking Specifies the marking (that is, the color and relationships to other 
marked items) that will be used to mark items in this visualization. 

Limit data using 
markings 

Lists the available markings that can be used to limit what is shown in 
this visualization. This means that the visualization only displays data 
that has been marked in other visualizations. 
If more than one marking is selected, you can choose how the data in 
the markings should be combined. 

New... Opens the New Marking dialog where you can specify a new marking. 
The color and name of a previously created marking is edited in the 
Document Properties dialog. 

Rows must be 
included in 

Specifies how the data in the markings should be combined if you have 
selected to limit the data by more than one marking. 

   All markings 
(AND) 
   

Use this option if you want this visualization to show the intersection of 
the markings selected in Limit data using markings. This can be used if 
you have two visualizations with different markings and want to see 
which markers are present in both markings. This visualization will 
then show only the data that has been marked using both of the selected 
markings. 

   Any marking 
(OR) 
    

Use this option if you want this visualization to show the union of the 
markings selected in Limit data using markings.  
This can be used if you have two visualizations with different markings 
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and want to see which markers are present in either of the two 
markings. This visualization will then show data that has been marked 
using either of the selected markings. 

Limit data using 
filterings 

Defines how different filtering schemes in the analysis should affect 
this visualization. 
Select Use the current filtering from the page if you want the 
visualization to always utilize the filtering scheme that is used on the 
page where the visualization is located. If you move the visualization to 
a new page, then the visualization will automatically start reacting on 
the filtering scheme that is used on the new page.  
Select a specific filtering scheme from the list if you want the 
visualization to always use that filtering scheme. Moving the 
visualization to another page with a different filtering scheme will not 
affect this setting. 
If you select to limit data using more than one filtering scheme, the 
intersection of the filterings will be used. This means that the 
visualization will show only the data that is made visible by all of the 
filtering schemes. 

New... Opens the New Filtering Scheme dialog where you can specify a new 
filtering scheme. 
The color and name of a previously created filtering scheme is edited in 
the Document Properties dialog. 

Limit data using 
expression 

You can limit what data should be available for a certain visualization 
using an expression. If you have defined a limiting expression, it will be 
displayed here. 

Edit... Opens the Limit Data Using Expression dialog where you can define a 
boolean expression to use for limiting the data in this visualization. 
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4.5.3.4 Line Chart Properties - Appearance 

 

Option Description 

Line width Specifies the width of the lines in the line chart. 

Show markers Determines whether or not markers should be displayed for the axis 
values.  

   Marker size Use the slider to increase or decrease the size of the markers. 

Draw as step lines  Select this check box if you want the lines to be drawn in incremental 
steps rather than as straight lines directly between each value. 

Break lines on 
empty values 

Determines whether lines should be broken or remain connected when 
an empty value is found in the data used to create the line. 

Time series   

   Compensate for 
missing values 

Select this check box if you are using a Date, Time or DateTime 
column somewhere in the visualization and you need to perform some 
calculation where a required time period is missing. For example, if 
you have created a visualization showing cumulative sums and there 
are missing data for some categories, selecting this check box will 
produce a value of the same size as the previous value instead of 
interpolating between the values. See Working With Time Hierarchies 
for more information. 
Enabling this setting will temporarily add new rows with empty values 
for the missing periods so that they can be used in the calculation. 
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4.5.3.5 Line Chart Properties - Formatting 

 

Option Description 

Axes Displays which column and category are currently being used on each 
of the two axes in the line chart. Click on the one you want to change 
the settings for. If the columns on the axes are of the same type, you 
can set formatting for both axes at the same time. If you use multiple 
scales in the visualization, each of the different scales on the Y-axis 
will appear in the list, and you can apply formatting to them 
individually. 

Reset Resets the formatting for the selected axis values according to the 
settings defined on column level. If no column formatting has been set, 
axis formatting settings defined in the Options dialog will be used. If 
no settings have been specified in the Options dialog, the default 
settings for the visualization type will be used. 

Category Lists the available formatting categories for the selected axis. Each 
category in this list has separate settings. Which categories are 
available depends on the data type of the selected axis. See Formatting 
Settings for a full description of all possible options. 

Note: These settings affect only the current visualization. For general information about 
formatting, see Formatting Overview. 
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4.5.3.6 Line Chart Properties - Fonts 

 

Option Description 

Settings for Lists all items for which you can change the font settings. Click to 
select an item in the list to change the font settings for that text in the 
visualization. Press Ctrl and click on more items to change the settings 
for multiple items simultaneously. 

Font Specifies the font to use for the selected items. 

Font style Specifies the font style to use for the selected items. 

Size Specifies the font size to use for the selected items. 
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4.5.3.7 Line Chart Properties - X-axis 

 

Option Description 

Columns Specifies the column or hierarchy to be displayed on the X-axis. 

Settings... Opens the Advanced Settings dialog, where you can change the scale 
mode from categorical to continuous, and vice versa, as well as 
changing the category mode to determine which combinations to 
show. 

Range   

   Min Determines the lower value of the axis range. Leave the field blank to 
automatically adjust the range to the currently lowest value in the 
filtered data. 

   Max Determines the upper value of the axis range. Leave the field blank to 
automatically adjust the range to the currently highest value in the 
filtered data. 

   Set to Current 
Range 

Allows you to set the axis range to the currently filtered values. 
  

   Include origin Available for continuous axes only. Always includes the coordinates 
(0, 0) in the visualization, regardless of filtering. 

   Show zoom slider Shows a zoom slider that you can manually manipulate to view only 
the interesting parts of the line chart. 

   Show gridlines Specifies whether or not vertical gridlines should be visible. 
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Scale labels   

   Show labels Specifies whether or not scale labels should be visible. 

      Horizontally Shows scale labels horizontally. 

      Vertically Shows scale labels vertically. 

      Max number of 
labels 

Select the check box to specify a maximum number of scale labels to 
be shown. Limiting the number of labels can improve readability on 
axis scales with many values. 

Scale   

   Log scale Available for continuous axes only. Changes the scale from a linear 
scale to a logarithmic base 10 scale [log10 (x)]. 

   Reverse scale Reverses the current sort order, so that the lowest value is displayed at 
the top of the scale. 

4.5.3.8 Line Chart Properties - Y-axis 

One Y-axis with a single scale 

 

Option Description 

Columns Specifies the column or hierarchy to be displayed on the Y-axis. 

Settings... [Not available in this visualization.] 

One axis with a 
single scale 

Use this option if you want to show the values from a single column 
on the Y-axis, or if you have multiple columns that can be presented 
using the same scale. 
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Multiple scales Use this option to show two Y-axes (left and right) with two or more 
different scales. For example, use it if you want to display two 
columns of very different magnitudes in the same visualization. 

Range   

   Min Determines the lower value of the axis range. Leave the field blank to 
automatically adjust the range to the currently lowest value in the 
filtered data. 

   Max Determines the upper value of the axis range. Leave the field blank to 
automatically adjust the range to the currently highest value in the 
filtered data. 

   Set to Current 
Range 

Allows you to set the axis range to the currently filtered values. 

   Include origin Available for continuous columns only. Always includes the 
coordinates (0, 0) in the visualization, regardless of filtering. 

   Show zoom slider Shows a zoom slider that you can manually manipulate to view only 
the interesting segments of the line chart. 

Show gridlines Specifies whether or not horizontal gridlines should be visible. 

Scale labels   

   Show labels Specifies whether or not scale labels should be visible. 

      Horizontally Shows scale labels horizontally. 

      Vertically Shows scale labels vertically. 

      Max number of 
labels 

Select the check box to specify a maximum number of scale labels to 
be shown. Limiting the number of labels can improve readability on 
axis scales with many values. 

Scale   

   Log scale Changes the scale from a linear scale to a logarithmic base 10 scale 
[log10 (x)]. 

   Reverse scale Reverses the current sort order, so that the lowest value is displayed at 
the top of the scale. 
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Multiple scales 

 

Option Description 

Columns Specifies the column or hierarchy to be displayed on the Y-axis. 

Settings... [Not available in this visualization.] 

One axis with a 
single scale 

Use this option if you want to show the values from a single column 
on the Y-axis, or if you have multiple columns that can be presented 
using the same scale. 

Multiple scales Use this option to show two Y-axes (left and right) with two or more 
different scales. For example, use it if you want to display two 
columns with values of very different magnitudes in the same 
visualization. 

Individual scaling   

   For each color Use this option to display one scale for each category used to color the 
markers by. For example, if you put two different columns on the Y-
axis (like Oil Production and BNP), you can use the "(Column 
Names)" option to color by and click this radio button to display one 
scale for Oil Production and one for BNP. 
Do not use this option if you need to color by a large number of 
different categories. 
Note that you should apply true categorical coloring before using this 
option. If you use a continuous column on the color axis, you may end 
up with a different result than the expected. This applies even if the 
continuous color mode looks "categorical" at first sight. 
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   For each trellis 
panel 

Use this option to display one scale for each trellis panel. 

   For each line Use this option to display individual scales for each line defined by the 
"Line by" and/or the "Color by" settings. 
The lines will be normalized so that all lines are shown on a scale with 
the actual value expressed as a percentage of the maximum value for 
each line. 

Zoom   

   Show zoom slider Shows a zoom slider that you can manually manipulate to view only 
the interesting segments of the line chart. 

   Show gridlines Specifies whether or not horizontal gridlines should be visible. 

Scale labels   

   Show labels Specifies whether or not scale labels should be visible. The scale labels 
are always displayed horizontally when multiple scales are shown. 

   Horizontally Shows scale labels horizontally. 
Note: Only available for individual scaling for each trellis panel. 

   Vertically Shows scale labels vertically. 
Note: Only available for individual scaling for each trellis panel. 

      Max number of 
labels 

Select the check box to specify a maximum number of scale labels to 
be shown. Limiting the number of labels can improve readability on 
axis scales with many values. 

Individual scale 
settings 

  

[Drop-down list] Select the scale for which you wish to change the settings. Select All 
scales to change settings for all scales simultaneously. 

Scale Range... Opens the Scale Range dialog where you can specify the range of the 
selected scale, and also determine whether or not to include the origin 
(0,0). 

Position Specifies which side of the visualization the scales should be 
positioned. 

   Left Y-axis Select this option to place the selected scale on the left-hand side of 
the visualization. 

   Right Y-axis Select this option to place the selected scale on the right-hand side of 
the visualization. 

Log scale Changes the scale from a linear scale to a logarithmic base 10 scale 
[log10 (x)]. 

Reverse scale Reverses the current sort order, so that the lowest value is displayed at 
the top of the scale. 
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4.5.3.9 Line Chart Properties - Line By 

 

Option Description 

Show one line for 
each 

Specifies the column or hierarchy by which the lines should be split. 
Note: If the lines are being colored by a column or hierarchy with 
more categories than the one selected here, there will be no visible 
effect from this operation, since the coloring has already split the lines 
more granularly. 

Currently also 
split by the 
following 
properties 

Displays information about what other properties currently contribute 
to a splitting of the lines. 
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4.5.3.10 Line Chart Properties - Colors 

 

Option Description 

Columns Specifies the column or hierarchy to color by. 

Settings Opens the Advanced Settings dialog where you can change the scale 
mode for the selected column or hierarchy from continuous to 
categorical and vice versa, as well as changing the category mode to 
determine which combinations to show. 

Color mode Specifies in which color mode to set up the color scheme. Which 
modes are available depends on whether the scale is in categorical or 
continuous mode. For columns in continuous scale mode, you can 
select one of the following color modes: Gradient, Segments, or Fixed. 
For columns in categorical scale mode, you can select either 
Categorical or Fixed color mode. To learn more about the color 
modes, see Color Modes Overview. 

One scale per Specifies whether there should be one separate scale per trellis panel 
for trellised line charts, or if one scale should apply to the entire 
visualization. Only applicable to columns in continuous scale mode. 

 
[Color Schemes 
menu] 

Opens a menu where you can select an already existing color scheme 
and apply it to the visualization, or apply the currently open color 
scheme to another visualization in the analysis. 

   From 
Visualization 

Lets you select a color scheme from another visualization in the 
analysis. Only color schemes that are applicable to the current color 
scheme will be listed. 
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   Document Color 
Schemes 

Lets you select a color scheme that has previously been saved within 
the analysis. Only color schemes that are applicable to the current 
color scheme will be listed. This menu option is only available if one 
or more document color schemes already exist. 

   [Predefined color 
schemes] 

Lists a number of predefined color schemes. Available for columns in 
continuous scale mode only. For a full description of the predefined 
color schemes, see Predefined Color Schemes. 
Tip: To facilitate setting up a new color scheme, you can open a 
predefined color scheme with a similar appearance, and then adjust it 
to suit your needs. 

   Open from 
Library... 

Opens the Open from Library dialog where you can select a color 
scheme that has previously been saved to the library. 

   Open from File... Opens a dialog where you can select a previously saved color scheme. 

   Save As Lets you save a color scheme as a library item, a local file or a 
document color scheme. 
Library Item – Opens the Save as Library Item dialog, where you can 
specify a location in the library and a file name to save the currently 
open color scheme for later reuse. 
File – Opens a dialog where you can specify a location and a file name 
to save your currently open color scheme locally on your computer for 
later reuse. 
Document Color Scheme – Opens the Save as Document Color 
Scheme dialog, where you can specify a name and save the currently 
open color scheme for later reuse within the analysis. 

   Apply to 
Visualizations... 

Opens the Apply to Visualizations dialog where you can select other 
visualizations (within the analysis) that you want to apply the current 
color scheme to. Only visualizations with compatible color schemes 
are listed. 
Note: If you apply a color scheme to a table, cross table, or heat map, 
the coloring will not take effect immediately. The color scheme will be 
added as an empty color scheme grouping, and you must select which 
columns or axis values to include in the grouping by opening the Edit 
Color Scheme Grouping dialog. 

[Color scheme area] The area in the lower part of the dialog shows the current color 
scheme. That is, the colors and values currently used in the 
visualization. You can modify color schemes in numerous ways to 
give the visualization the appearance you prefer. The color scheme 
area will look different, and have different available settings, 
depending on the characteristics of the column used to color the 
visualization by, as well as the selected color mode. To learn more 
about color schemes and color modes, see Color Schemes Overview 
and Color Modes Overview respectively. 

Add Point Available for continuous columns only. Adds a new anchor point to 
the color scheme. 

Delete Point Available for continuous columns only. Deletes the selected anchor 
point. 

Add Rule... Opens the Add Rule dialog where you can define a rule that functions 
as an exception to the rest of the defined color scheme. A rule has 
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higher priority than the rest of the color scheme. For example, you can 
define a rule to give the top five items in your data a different color 
than the rest of the items. If you add many rules to a color scheme, the 
rules are prioritized from top to bottom. Which rule types are available 
depends on the characteristics of the column or hierarchy used to color 
the visualization by. See Details on Add/Edit Rule for full descriptions 
of the rule types. 

Reset Resets the color scheme to the one that was in effect when the 
visualization was created. Any added rules will be removed. Which 
color scheme should be used by default when you create a new 
visualization is defined in the Visualization page of the Options 
dialog. 

4.5.3.11 Line Chart Properties - Labels 

 

Option Description 

Show in labels   

   Line identifier Displays labels showing the categories used to create each line (by 
coloring or line by). 

   Individual values Displays labels showing the values for all points used to create the line. 

Show labels for Determines whether to show labels with on all lines (All), lines 
containing marked rows only (Marked rows), or not to show any 
labels at all (None). 

Max number of 
labels 

Specifies the maximum number of labels to be shown. 
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4.5.3.12 Line Chart Properties - Tooltip 

 

Option Description 

Display the 
following values 

Specifies what will be shown in the tooltip. 

Add... Opens the Add Tooltip Value dialog, where you can add the content 
from another column, hierarchy, or any custom expression to be 
shown in the tooltip. You can also use images in tooltips. See 
Highlighting in Visualizations for more information. 

Edit... Opens the Edit Tooltip Value dialog, where you can change the 
information to be shown in the tooltip. 

Delete Deletes the selected value from the list. 

Move Up Moves the selected value up in the list and, hence, up in the tooltip. 

Move Down Moves the selected value down in the list and, hence, down in the 
tooltip. 

Tooltip format   

   Value names and 
values 

Shows the tooltip content in a format  where the selected column 
name, hierarchy or custom expression is displayed. For example, Year: 
2003, Type: Cucumber, etc. 

   Visualization 
properties and 
values 

Shows the tooltip content in a format where the visualization property 
for each value is displayed. For example, X: 2003, Color: Cucumber, 
etc. 
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4.5.3.13 Line Chart Properties - Legend 

 

Option Description 

Show legend Specifies whether or not the docked legend should be shown in the 
visualization. 

Position Specifies which side of the visualization the legend should be 
positioned: the right-hand side or the left-hand side. 

Display the 
following legend 
items 

Specifies what will be shown in the legend.  
By clearing a check box you will completely hide that item from the 
legend. You can also select to show or hide parts of the legend 
information using the check boxes under Settings for the selected item 
in the list, see below. 

Settings Defines how the selected legend item should be displayed. The 
available options vary between legend items. 

   Show title Use this option to show or hide the title for the selected item. The title 
is typically what is displayed above an axis selector or similar: 

 

   Show axis 
selector 

Select this option to show or hide the axis selector for the selected item.  
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4.5.3.14 Line Chart Properties - Trellis 

 

Option Description 

Rows and columns Splits the visualization into different panels for all categories 
in the selected column or hierarchy. The number of values in 
the specified column or hierarchy controls the number of 
panels to be displayed in each row, column, or page, 
respectively. 

   Rows A row with trellis panels will be created for each value in the 
selected column or hierarchy. 

   Columns A column with trellis panels will be created for each value in 
the selected column or hierarchy. 

   Pages A new page with trellis panels will be created for each value in 
the selected column or hierarchy. Scroll down in the 
visualization to see the next page. 

Panels Splits the visualization into different panels for all categories 
in the selected column or hierarchy, without binding any 
dimensions to either rows or columns. This means that the 
number of actual values in the column to split by does not 
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control the number of shown rows or columns in any way. 
The number of panels that should be visible on each page is 
instead specified using the Max number of rows and Max 
number of columns controls below. 

   Split by Specifies the column or hierarchy to define the categories by 
which the visualization should be split. 

   Manual layout Select the check box to manually specify the number of rows 
and columns that should be visible without scrolling. If the 
check box is cleared, the application will automatically specify 
the number of rows and columns. 

   Max number of rows Specifies the maximum number of panels that should be 
visible on each page. 

   Max number of columns Specifies the maximum number of panels that should be 
visible on each page. 

Settings... Opens the Advanced Settings dialog where you can change the 
category mode to determine which combinations to show. 

4.5.3.15 Line Chart Properties - Lines & Curves 
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First part of the dialog 

Option Description 

Visible lines and 
curves 

Lists the currently added lines and curves. If a checkmark is shown in 
the check box, then the reference line is shown in the visualization. 
Clear the check box to hide a line or curve. 
New lines and curves can be added to this list by clicking on the Add 
button; see below. 

Add Displays a menu where you can select which type of line or curve to 
add to the list of available lines and curves, and in some cases, opens a 
dialog where you can specify settings to use for that line or curve. 
For more information about the different curve types, see Curve Fit 
Models. 

Edit... Opens a dialog where you can change the settings for the selected line 
or curve (when applicable). 

Remove Removes the selected line or curve from the list of available lines and 
curves. 

More   

   Duplicate Duplicates the currently selected line or curve. This can be particularly 
useful if you want to add one static curve that is calculated on the 
whole data set (select the Update curve manually check box) and 
another one that is changed upon filtering (default). 

   Export Curve Fit 
Result... 

Opens a dialog where you can choose to export the curve fit result for 
the selected curve to a text file or to Microsoft® Excel®. The text file 
can be either a regular tab separated text file, or a Spotfire Text Data 
Format file, which contains a bit more information about the columns 
(types, etc.). The Excel file can be either an XLS file or an XLSX file. 

Settings 

Option Description 

Appearance Determines the color, style and width of lines and curves, and the 
color, style and size of points. 

Place in Select whether to place the line, curve or point in the Foreground or 
Background of the visualization. 

Transparency Determines the transparency of the selected line, curve or point. That 
is, the degree to which the markers can be seen through it. The 
transparency is strongly connected to the color. 

Label and Tooltip Opens a dialog where you can determine what information to show in 
the label and/or tooltip for the selected line, curve or point. 

Included in axis 
range 

Sets the automatic zooming so that the line, curve or point is always 
shown, even if it lies far from the currently filtered values. 

Update manually Select the check box to "freeze" the line or curve so that it is not 
automatically recalculated upon filtering. You can update the line or 
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curve by clicking the Update button below or by right-clicking in the 
visualization and selecting Update Lines and Curves and clicking on 
the one you want to update. 
Note: Not applicable for points. 

Update When a line or curve has been specified to be manually updated, use 
this button to perform the update. 

One per Determines whether to show one line or curve per Color, Trellis panel 
and/or line. 
Note: Not applicable for points. 
Note that you should apply true categorical coloring before using the 
color option. If you use a continuous column on the color axis, you 
may end up with a different result than the expected. This applies even 
if the continuous color mode looks "categorical" at first sight. 

4.5.3.16 Line Chart Properties - Error Bars 

 

Option Description 

Visible error bars Lists the numerical columns and measures that you can define error 
bars for in the visualization. If a check mark is shown in the check box, 
then error bars for that column or measure are visible in the 
visualization. Clear the check box to hide the error bars for a column or 
measure. 
Note: No error bars will be visible in the visualization until an upper or 
lower error has been defined. 

Settings Shows the settings for the selected column or measure. 
Note: If you use multiple Y-axes in the line chart you can define 
different error bars for the axes. However, all the defined vertical error 
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bars will share the same settings for Color, Show end caps, and Include 
error bars in axis range. For example, you cannot set one vertical error 
bar to be blue, and another vertical error bar to be yellow in the same 
line chart. This also applies to using multiple measures on a Y-axis 
with a single scale. 

   Upper error Specifies the column and aggregation method, or custom expression to 
use for the upper error bars. 
Note: The chosen column or measure must have numerical values. 

   Lower error Specifies the column and aggregation method, or custom expression to 
use for the lower error bars. 
Note: The chosen column or measure must have numerical values. 

   Color   

      Same as line Choose this option if you want an error bar to have the same color as 
the line. 

      Custom Choose this option if you want to use a custom color for the error bars. 
Click on the drop-down list to show the palette and select a different 
color. 

   Show end caps Specifies whether or not orthogonal lines should be displayed at the 
end of the error bars. 

   Include error 
bars in axis range 

Sets the automatic zooming so that the error bars are always visible. 

Note: The upper and lower errors refer to the underlying data. This means that if you use 
reversed scales in a visualization, the error bars will also be reversed. For example, for a line 
chart with reversed Y-axis, the upper error bar will be displayed below the line. 
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4.6 Combination Chart 
4.6.1 What is a Combination Chart? 

The combination chart is a visualization that combines the features of the bar chart and the line 
chart. The combination chart displays the data using a number of bars and/or lines, each of 
which represent a particular category. A combination of bars and lines in the same visualization 
can be useful when comparing values in different categories, since the combination gives a clear 
view of which category is higher or lower. An example of this can be seen when using the 
combination chart to compare the projected sales with the actual sales for different time periods. 

Series 
Similarly to the function of Color by in other visualizations, Series by in the combination chart 
is a way to divide the data into slices. The difference is that the slices in the combination chart, 
called series, can be defined as bars or lines as well as being colored separately. That is, each 
series in the combination chart will be represented by a line or a set of bars in the visualization. 

Example: 
The example below contains two series: the bars represent the projected sales for each month in 
a year and the line represents the actual sales for the same months. Series by is set to (Column 
Names) since both series should be shown on the Y-axis. For more information on (Column 
Names), see the Non-Column Selections page. 

 
Multiple scales can also be used on the Y-axis when you want to compare several lines and bars 
with significantly different value ranges. 

 
All visualizations except the map chart can be set up to show data limited by one or more 
markings in other visualizations only (details visualizations). They can also be limited by one or 
more filterings. Another alternative is to set up a visualization without any filtering at all. See 
Limiting What is Shown in Visualizations for more information. 
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4.6.2 How to Use the Combination Chart 
► To apply series (split in categories): 

1. In the Filters panel, click and hold down the left mouse button on the filter 
representing the column that you want to split by series. 
Comment: Series by is also available in the Visualization Properties dialog. 

2. Drag the filter to the center of the visualization. 
Response: Drop targets appear in the middle of the visualization. 

3. Release the mouse button on the Series target. 
Comment: If you want to use multiple columns on the Y-axis, and set each of these as 
a series, you should select to series by (Column Names) in the legend or the 
Visualization Properties dialog. 

► To switch between bars and lines: 
1. Click on the bar or line symbol next to the series in the legend and select Show as 

Bars or Show as Line. 
OR 

2. Right-click on the visualization and select Properties from the pop-up menu. 
3. Go to the Series page, select a series and define it as bars or a line. 

Comment: It is also possible to right-click on the visualization and select Show All as 
Bars or Show All as Lines to set all series to bars or lines. 

► To mark bars or lines: 
1. Click once on a line or a bar to mark the line or bar. 

Comment: If you have stacked bars, only the bar segment will be marked. 
OR 

2. Click and drag with the mouse to mark all bar segments, bars and parts of lines 
included in the selection. 
Comment: You can select items in different parts of the visualization by pressing Ctrl 
and clicking and dragging with the mouse. 

► To sort the combination chart: 
1. Right-click on the visualization and select Properties from the pop-up menu. 
2. Go to the Appearance page. 
3. Select a series to sort the X-axis by. 

► To change the aggregation type: 
1. Click on the axis selector on the Y-axis. This is where it says Sum([Column Name]), 

Count(...), or similar. 
Response: A drop-down menu is displayed. 

2. Select Aggregation > and a new aggregation measure from the submenu. 
Comment: You can also select Custom Expression... from the menu and create your 
own expression. 
Response: The combination chart is updated to show the new information. 

► To use multiple columns on one axis: 
This is an example of how to use two columns on the Y-axis. The columns will be represented 
by a line or a set of bars. 
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1. Click on the arrow next to the plus sign on the axis of your choice. 
2. Select a new column from the menu. 

Comment: A column can also be dragged and dropped from the filters panel. 
3. Select (Column Names) in the Series by column selector. 

Comment: For more information on (Column Names), see the Non-Column Selections 
page. 
Response: The columns are represented by a line or a set of bars in the combination 
chart. 

► To add multiple scales: 
1. Right-click on the Y-axis and select Multiple Scales from the pop-up menu. 

Comment: By default, you will get one scale for each color that is defined under Series 
by. 

2. You can also go to the Y-axis page in the Visualization Properties dialog and click the 
Multiple scales radio button. This is also where you change the settings for the 
different scales and determine whether a certain scale should be located on the left or 
the right Y-axis. 
Comment: If you are using values from different columns on the various scales, you 
can also use drag and drop to move columns from one side to another. 

► To add a reference line to the combination chart: 
1. Right-click on the visualization and select Properties from the pop-up menu. 
2. Go to the Lines & Curves page. 
3. Select the check box for any of the default lines or click on Add to define a new line. 

Comment: You can only add lines to the X-axis when it is in continuous mode. Right-
click on the scale labels and select Continuous Scale from the pop-up menu. 

► To add a curve fit to the combination chart: 
1. Right-click on the visualization and select Properties from the pop-up menu. 
2. Go to the Lines & Curves page. 
3. Click on Add and select a suitable curve fit from the drop-down menu. 

Comment: You can select from a number of predefined curve fits, or define your own 
curve using Curve Draw. See Curve Fit Models for more information about the 
different options. 

4. Once the curve has been created, you can change its settings on the Lines & Curves 
page. Some of the curve settings are also available from the pop-up menu in the 
visualization. 

► To create a new combination chart: 

1. Click on the New Combination Chart button on the toolbar, . 
Comment: You can also select Insert > New Visualization > Combination Chart 
from the menu. 
Response: A first attempt to set up a suitable combination chart is made by the 
application. 

2. Adjust the combination chart to display the categories and measures of your choice. 
Comment: For more information about how to change what to show on the two axes, 
see Column Selectors. 
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4.6.3 Combination Chart Properties 

4.6.3.1 Combination Chart Properties 
The Combination Chart Properties dialog consists of several pages: 

• General 
• Data 
• Appearance 
• Formatting 
• Fonts 
• X-axis 
• Y-axis 
• Series 
• Labels 
• Tooltip 
• Legend 
• Trellis 
• Lines & Curves 

► To reach the Combination Chart Properties dialog: 
1. Right-click on the combination chart visualization. 
2. Select Properties from the pop-up menu. 

Comment: You can also click on the combination chart visualization to make it active 
and then select Edit > Visualization Properties. 

4.6.3.2 Combination Chart Properties - General 
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Option Description 

Title The title of the visualization. 
Tip: Double-click on the title bar of the visualization for a shortcut to 
this field. 

Show title bar Specifies whether or not to show the visualization title. 

Description A description of the visualization. This description can optionally be 
shown in the legend and/or in the visualization. 

Show description 
in visualization 

Specifies whether or not to show the description in the visualization. 

4.6.3.3 Combination Chart Properties - Data 

 

Option Description 

Data table Specifies the data table on which the visualization will work. 

Marking Specifies the marking (that is, the color and relationships to other marked 
items) that will be used to mark items in this visualization. 

Limit data using 
markings 

Lists the available markings that can be used to limit what is shown in 
this visualization. This means that the visualization only displays data 
that has been marked in other visualizations. 
If more than one marking is selected, you can choose how the data in the 
markings should be combined. 

New... Opens the New Marking dialog where you can specify a new marking. 
The color and name of a previously created marking is edited in the 
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Document Properties dialog. 

Rows must be 
included in 

Specifies how the data in the markings should be combined if you have 
selected to limit the data by more than one marking. 

   All markings 
(AND) 
   

Use this option if you want this visualization to show the intersection of 
the markings selected in Limit data using markings. This can be used if 
you have two visualizations with different markings and want to see 
which markers are present in both markings. This visualization will then 
show only the data that has been marked using both of the selected 
markings. 

   Any marking 
(OR) 
    

Use this option if you want this visualization to show the union of the 
markings selected in Limit data using markings.  
This can be used if you have two visualizations with different markings 
and want to see which markers are present in either of the two markings. 
This visualization will then show data that has been marked using either 
of the selected markings. 

Limit data using 
filterings 

Defines how different filtering schemes in the analysis should affect this 
visualization. 
Select Use the current filtering from the page if you want the 
visualization to always utilize the filtering scheme that is used on the 
page where the visualization is located. If you move the visualization to 
a new page, then the visualization will automatically start reacting on the 
filtering scheme that is used on the new page.  
Select a specific filtering scheme from the list if you want the 
visualization to always use that filtering scheme. Moving the 
visualization to another page with a different filtering scheme will not 
affect this setting. 
If you select to limit data using more than one filtering scheme, the 
intersection of the filterings will be used. This means that the 
visualization will show only the data that is made visible by all of the 
filtering schemes. 

New... Opens the New Filtering Scheme dialog where you can specify a new 
filtering scheme. 
The color and name of a previously created filtering scheme is edited in 
the Document Properties dialog. 

Limit data using 
expression 

You can limit what data should be available for a certain visualization 
using an expression. If you have defined a limiting expression, it will be 
displayed here. 

Edit... Opens the Limit Data Using Expression dialog where you can define a 
boolean expression to use for limiting the data in this visualization. 
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4.6.3.4 Combination Chart Properties - Appearance 

 

Option Description 

Sort x-axis by Selecting (None) sorts the contents of the visualization by the 
natural sort order of the column chosen on the X-axis. However, you 
can also sort the visualization by any of the Series you have created 
in the combination chart. 

Bars   

   Layout   

      Side-by-side bars Use this option to place bars from the series category side-by-side 
next to each other instead of stacked on top of each other. 

      Stacked bars Use this option to keep series categories stacked on top of each 
other. 

   Bar width Drag the slider to modify the width of the bars. 

Lines   

   Line width Specifies the width of the lines in the combination chart. 

   Show line markers Determines whether or not markers should be displayed for the axis 
values. The slider can be used to increase or decrease the size of the 
markers. 

   Break lines on 
empty values 

Determines whether lines should be broken or remain connected 
when an empty value is found in the data that was used to create the 
line. 
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Time series   

   Compensate for 
missing values 

Select this check box if you are using a Date, Time or DateTime 
column somewhere in the visualization and you need to perform 
some calculation where a required time period is missing. For 
example, if you have created a visualization showing cumulative 
sums and there are missing data for some categories, selecting this 
check box will produce a bar or line value of the same size as the 
previous bar or line value instead of showing no value at all. See 
Working With Time Hierarchies for more information. 
Enabling this setting will temporarily add new rows with empty 
values for the missing periods so that they can be used in the 
calculation. 

4.6.3.5 Combination Chart Properties - Formatting 

 

Option Description 

Axes Displays the column and category currently being used on each of the 
two axes in the combination chart. Click on the one you want to change 
the settings for. If the columns on the axes are of the same type, you 
can set formatting for both axes at the same time. If you use multiple 
scales in the visualization, each of the different scales on the Y-axis 
will appear in the list and you can apply formatting to them 
individually. 

Reset Resets the formatting for the selected axis values according to the 
settings defined on column level. If no column formatting has been set, 
axis formatting settings defined in the Options dialog will be used. If 
no settings have been specified in the Options dialog, the default 
settings for the visualization type will be used. 
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Category Lists the available formatting categories for the selected axis. Each 
category in this list has separate settings. Which categories are 
available depends on the data type of the selected axis. See Formatting 
Settings for a full description of all possible options. 

Note: These settings affect only the current visualization. For general information about 
formatting, see Formatting Overview. 

4.6.3.6 Combination Chart Properties - Fonts 

 

Option Description 

Settings for Lists all items for which you can change the font settings. Click to 
select an item in the list to change the font settings for that text in the 
visualization. Press Ctrl and click on more items to change the settings 
for multiple items simultaneously. 

Font Specifies the font to use for the selected items. 

Font style Specifies the font style to use for the selected items. 

Size Specifies the font size to use for the selected items. 
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4.6.3.7 Combination Chart Properties - X-axis 

 

Option Description 

Columns Specifies the column or hierarchy to be displayed on the X-axis. 

Settings... Opens the Advanced Settings dialog where you can change the scale 
mode from categorical to continuous and vice versa, as well as 
changing the category mode to determine which combinations to 
show. 

Range   

   Min Determines the lower value of the axis range. Leave the field blank to 
automatically adjust the range to the lowest value currently in the 
filtered data. 

   Max Determines the upper value of the axis range. Leave the field blank to 
automatically adjust the range to the highest value currently in the 
filtered data. 

   Set to Current 
Range 

Allows you to set the axis range to the currently filtered values. 

   Include origin Available for continuous axes only. Always includes the coordinates 
(0, 0) in the visualization, regardless of filtering. 

   Show zoom slider Shows a zoom slider that you can manually manipulate to view only 
those parts of the combination chart you are interested in. 

   Show gridlines Specifies whether or not vertical gridlines should be visible. 
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Scale labels   

   Show labels Specifies whether or not scale labels should be visible. 

      Horizontally Shows scale labels horizontally. 

      Vertically Shows scale labels vertically. 

      Max number of 
labels 

Select the check box to specify a maximum number of scale labels to 
be shown. Limiting the number of labels can improve readability on 
axis scales with many values. 

Scale   

   Log scale Available for continuous axes only. Changes the scale from a linear 
scale to a logarithmic base 10 scale [log10 (x)]. 

   Reverse scale Reverses the current sort order, so that the lowest value is displayed at 
the top of the scale. 

 

4.6.3.8 Combination Chart Properties - Y-axis 

One Y-axis with a single scale 

 

Option Description 

Columns Specifies the column or hierarchy to be displayed on the Y-axis. 

Settings... [Not available in this visualization.] 
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One axis with a 
single scale 

Use this option if you want to show the values from a single column 
on the Y-axis, or if you have multiple columns that can be presented 
using the same scale. 

Multiple scales Use this option to show two Y-axes (left and right) with two or more 
different scales. For example, use it if you want to display two 
columns of very different magnitudes in the same visualization. 

Range   

   Min Determines the lower value of the axis range. Leave the field blank to 
automatically adjust the range to the lowest value currently in the 
filtered data. 

   Max Determines the upper value of the axis range. Leave the field blank to 
automatically adjust the range to the highest value currently in the 
filtered data. 

   Set to Current 
Range 

Allows you to set the axis range to the currently filtered values. 

   Include origin Available for continuous columns only. Always includes the 
coordinates (0, 0) in the visualization, regardless of filtering. 

   Show zoom slider Shows a zoom slider that you can manually manipulate to view only 
those parts of the combination chart you are interested in. 

Show gridlines Specifies whether or not horizontal gridlines should be visible. 

Scale labels   

   Show labels Specifies whether or not scale labels should be visible. 

      Horizontally Shows scale labels horizontally. 

      Vertically Shows scale labels vertically. 

      Max number of 
labels 

Select the check box to specify a maximum number of scale labels to 
be shown. Limiting the number of labels can improve readability on 
axis scales with many values. 

Scale   

   Reverse scale Reverses the current sort order, so that the lowest value is displayed at 
the top of the scale. 
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Multiple scales 

 

Option Description 

Columns Specifies the column or hierarchy to be displayed on the Y-axis. 

Settings... [Not available in this visualization.] 

One axis with a 
single scale 

Use this option if you want to show the values from a single column 
on the Y-axis, or if you have multiple columns that can be presented 
using the same scale. 

Multiple scales Use this option to show two Y-axes (left and right) with two or more 
different scales. For example, use it if you want to display two 
columns with values of very different magnitudes in the same 
visualization. 

Individual scaling   

   For each color Use this option to display one scale for each category used to color the 
markers by. For example, if you put two different columns on the Y-
axis (like Oil Production and BNP), you can use the (Column Names) 
option to color by and click this radio button to display one scale for 
Oil Production and one for BNP. 
Do not use this option if you need to color by a large number of 
different categories. 
Note that you should apply true categorical coloring before using this 
option. If you use a continuous column on the color axis, you may end 
up with a different result than the expected. This applies even if the 
continuous color mode looks "categorical" at first sight. 
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   For each trellis 
panel 

Use this option to display one scale for each trellis panel. 

Zoom   

   Show zoom slider Shows a zoom slider that you can manually manipulate to view only 
those parts of the combination chart you are interested in. 

   Show gridlines Specifies whether or not horizontal gridlines should be visible. 

Scale labels   

   Show labels Specifies whether or not scale labels should be visible. The scale labels 
are always displayed horizontally when multiple scales are shown. 

   Horizontally Shows scale labels horizontally. 
Note: Only available for individual scaling for each trellis panel. 

   Vertically Shows scale labels vertically. 
Note: Only available for individual scaling for each trellis panel. 

      Max number of 
labels 

Select the check box to specify a maximum number of scale labels to 
be shown. Limiting the number of labels can improve readability on 
axis scales with many values. 

Individual scale 
settings 

  

   [Drop-down list] Select the scale for which you wish to change the settings. Select All 
scales to change settings for all scales simultaneously. 

   Scale Range... Opens the Scale Range dialog where you can specify the range of the 
selected scale, and also determine whether or not to include the origin 
(0, 0). 

   Position Specifies which side of the visualization the scales should be 
positioned. 

      Left Y-axis Select this option to place the selected scale on the left-hand side of 
the visualization. 

      Right Y-axis Select this option to place the selected scale on the right-hand side of 
the visualization. 

   Reverse scale Reverses the current sort order so that the lowest value is displayed at 
the top of the scale. 
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4.6.3.9 Combination Chart Properties - Series 

 

Option Description 

Series by Select the column to set series by. 
Note: If you have more than one column on the Y-axis, you need to 
series by (Column Names) to be able to display all columns in the 
same visualization. 

Settings... Opens the Advanced Settings dialog where you can change the scale 
mode for the selected column or hierarchy from continuous to 
categorical and vice versa, as well as changing the category mode to 
determine which combinations to show. 

Series Lists the series in the combination chart. Select a series to be able to 
apply changes to it. 

Type Select whether the series should be displayed as bars or as a line. 

Color Specify a color for the selected series. 
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4.6.3.10 Combination Chart Properties - Labels 

 

Option Description 

Show labels for Determines whether to show labels on all bars and lines (All), bars and 
lines containing marked rows only (Marked rows), or not to show any 
labels at all (None). 

Bars   

   Show bar labels Determines whether or not to show labels for the bars in the 
visualization. 

   Label 
orientation 

Determines whether to display the labels horizontally or vertically. 

Show line marker 
labels 

Determines whether or not to show labels for the line markers in the 
visualization. 

Max number of 
labels 

Specifies the maximum number of labels to be shown. 
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4.6.3.11 Combination Chart Properties - Tooltip 

 

Option Description 

Display the 
following values 

Specifies what will be shown in the tooltip. 

Add... Opens the Add Tooltip Value dialog, where you can add the content 
from another column, hierarchy, or any custom expression to be 
shown in the tooltip. You can also use images in tooltips. See 
Highlighting in Visualizations for more information. 

Edit... Opens the Edit Tooltip Value dialog, where you can change the 
information to be shown in the tooltip. 

Delete Deletes the selected value from the list. 

Move Up Moves the selected value up in the list and, hence, up in the tooltip. 

Move Down Moves the selected value down in the list and, hence, down in the 
tooltip. 

Tooltip format   

   Value names and 
values 

Shows the tooltip content in a format where the selected column name, 
hierarchy or custom expression is displayed. For example, Year: 2003, 
Type: Cucumber, etc. 

   Visualization 
properties and 
values 

Shows the tooltip content in a format where the visualization property 
for each value is displayed. For example, X: 2003, Color: Cucumber, 
etc. 
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4.6.3.12 Combination Chart Properties - Legend 

 

Option Description 

Show legend Specifies whether or not the docked legend should be shown in the 
visualization. 

Position Specifies which side of the visualization the legend should be 
positioned: the right-hand side or the left-hand side. 

Display the 
following legend 
items 

Specifies what will be shown in the legend.  
By clearing a check box you will completely hide that item from the 
legend. You can also select to show or hide parts of the legend 
information using the check boxes under Settings for the selected item 
in the list, see below. 

Settings Defines how the selected legend item should be displayed. The 
available options vary between legend items. 

   Show title Use this option to show or hide the title for the selected item. The title 
is typically what is displayed above an axis selector or similar: 

 

   Show axis 
selector 

Select this option to show or hide the axis selector for the selected item.  
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4.6.3.13 Combination Chart Properties - Trellis 

 

Option Description 

Rows and columns Splits the visualization into different panels for all categories 
in the selected column or hierarchy. The number of values in 
the specified column or hierarchy controls the number of 
panels to be displayed in each row, column, or page, 
respectively. 

   Rows A row with trellis panels will be created for each value in the 
selected column or hierarchy. 

   Columns A column with trellis panels will be created for each value in 
the selected column or hierarchy. 

   Pages A new page with trellis panels will be created for each value in 
the selected column or hierarchy. Scroll down in the 
visualization to see the next page. 

Panels Splits the visualization into different panels for all categories 
in the selected column or hierarchy, without binding any 
dimensions to either rows or columns. This means that the 
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number of actual values in the column to split by does not 
control the number of shown rows or columns in any way. 
The number of panels that should be visible on each page is 
instead specified using the Max number of rows and Max 
number of columns controls below. 

   Split by Specifies the column or hierarchy to define the categories by 
which the visualization should be split. 

   Manual layout Select the check box to manually specify the number of rows 
and columns that should be visible without scrolling. If the 
check box is cleared, the application will automatically specify 
the number of rows and columns. 

   Max number of rows Specifies the maximum number of panels that should be 
visible on each page. 

   Max number of columns Specifies the maximum number of panels that should be 
visible on each page. 

Settings... Opens the Advanced Settings dialog where you can change the 
category mode to determine which combinations to show. 

4.6.3.14 Combination Chart Properties - Lines & Curves 
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First part of the dialog 

Option Description 

Visible lines and 
curves 

Lists the currently added lines and curves. If a checkmark is shown in 
the check box, then the reference line is shown in the visualization. 
Clear the check box to hide a line or curve. 
New lines and curves can be added to this list by clicking on the Add 
button; see below. 

Add Displays a menu where you can select which type of line or curve to 
add to the list of available lines and curves, and in some cases, opens a 
dialog where you can specify settings to use for that line or curve. 
For more information about the different curve types, see Curve Fit 
Models. 

Edit... Opens a dialog where you can change the settings for the selected line 
or curve (when applicable). 

Remove Removes the selected line or curve from the list of available lines and 
curves. 

More   

   Duplicate Duplicates the currently selected line or curve. This can be particularly 
useful if you want to add one static curve that is calculated on the 
whole data set (select the Update curve manually check box) and 
another one that is changed upon filtering (default). 

   Export Curve Fit 
Result... 

Opens a dialog where you can choose to export the curve fit result for 
the selected curve to a text file or to Microsoft® Excel®. The text file 
can be either a regular tab separated text file, or a Spotfire Text Data 
Format file, which contains a bit more information about the columns 
(types, etc.). The Excel file can be either an XLS file or an XLSX file. 

Settings 

Option Description 

Appearance Determines the color, style and width of lines and curves, and the 
color, style and size of points. 

Place in Select whether to place the line, curve or point in the Foreground or 
Background of the visualization. 

Transparency Determines the transparency of the selected line, curve or point. That 
is, the degree to which the markers can be seen through it. The 
transparency is strongly connected to the color. 

Label and Tooltip Opens a dialog where you can determine what information to show in 
the label and/or tooltip for the selected line, curve or point. 

Included in axis 
range 

Sets the automatic zooming so that the line, curve or point is always 
shown, even if it lies far from the currently filtered values. 

Update manually Select the check box to "freeze" the line or curve so that it is not 
automatically recalculated upon filtering. You can update the line or 
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curve by clicking the Update button below or by right-clicking in the 
visualization and selecting Update Lines and Curves and clicking on 
the one you want to update. 
Note: Not applicable for points. 

Update When a line or curve has been specified to be manually updated, use 
this button to perform the update. 

One per Determines whether to show one line or curve per Color and/or Trellis 
panel. 
Note: Not applicable for points. 
Note that you should apply true categorical coloring before using the 
color option. If you use a continuous column on the color axis, you 
may end up with a different result than the expected. This applies even 
if the continuous color mode looks "categorical" at first sight. 
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4.7 Pie Chart 
4.7.1 What is a Pie Chart? 

Pie charts are circle graphs divided into sectors, each pie sector displaying the size of some 
related piece of information. Pie charts are used to show the relative sizes of the parts of a 
whole. 

Example: 

 
All visualizations except the map chart can be set up to show data limited by one or more 
markings in other visualizations only (details visualizations). They can also be limited by one or 
more filterings. Another alternative is to set up a visualization without any filtering at all. See 
Limiting What is Shown in Visualizations for more information. 
  

4.7.2 How to Use the Pie Chart 
► To set which column represents the size of the sectors: 

In the Filters panel, click and hold down the left mouse button on the filter 
representing the column you want to represent the size of the sectors. 

1. Drag the filter to the center of the visualization. 
Response: Drop targets appear in the middle of the visualization. 

2. Release the mouse button on the sector size drop target. 
Response: The sectors are adjusted so that the size is according the corresponding 
values of the column. 
From the Legend, click on the Sector Size by button, and select Aggregation. 
Select whether you want each sector size to be the sum or average (or other type of 
aggregation) of the selected column. 

► To sort the sectors of the pie chart: 
1. Right-click on the visualization to display the pop-up menu. 
2. Select Properties. 
3. Go to the Appearance page. 
4. Select the Sort sectors by size check box. 
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► To create a new pie chart: 
1. Click on the New Pie Chart button on the toolbar, . 

Comment: You can also select Insert > New Visualization > Pie Chart from the 
menu. 
Response: A first attempt to set up a suitable pie chart is made by the application. 

2. Adjust the pie chart to display the data of your choice. 

4.7.3 Pie Chart Properties 

4.7.3.1 Pie Chart Properties 
The Pie Chart Properties dialog consists of several pages: 

• General 
• Data 
• Appearance 
• Fonts 
• Colors 
• Size 
• Labels 
• Tooltip 
• Legend 
• Trellis 

► To reach the Pie Chart Properties dialog: 
1. Right-click on the pie chart visualization. 
2. Select Properties from the pop-up menu. 

Comment: You can also click on the pie chart visualization to make it active and then 
select Edit > Visualization Properties. 
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4.7.3.2 Pie Chart Properties - General 

 

Option Description 

Title The title of the visualization. 
Tip: Double-click on the title bar of the visualization for a shortcut to 
this field. 

Show title bar Specifies whether or not to show the visualization title. 

Description A description of the visualization. This description can optionally be 
shown in the legend and/or in the visualization. 

Show description 
in visualization 

Specifies whether or not to show the description in the visualization. 
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4.7.3.3 Pie Chart Properties - Data 

 

Option Description 

Data table Specifies the data table on which the visualization will work. 

Marking Specifies the marking (that is, the color and relationships to other 
marked items) that will be used to mark items in this visualization. 

Limit data using 
markings 

Lists the available markings that can be used to limit what is shown in 
this visualization. This means that the visualization only displays data 
that has been marked in other visualizations. 
If more than one marking is selected, you can choose how the data in 
the markings should be combined. 

New... Opens the New Marking dialog where you can specify a new marking. 
The color and name of a previously created marking is edited in the 
Document Properties dialog. 

Rows must be 
included in 

Specifies how the data in the markings should be combined if you have 
selected to limit the data by more than one marking. 

   All markings 
(AND) 
   

Use this option if you want this visualization to show the intersection of 
the markings selected in Limit data using markings. This can be used if 
you have two visualizations with different markings and want to see 
which markers are present in both markings. This visualization will 
then show only the data that has been marked using both of the selected 
markings. 

   Any marking 
(OR) 
    

Use this option if you want this visualization to show the union of the 
markings selected in Limit data using markings.  
This can be used if you have two visualizations with different markings 
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and want to see which markers are present in either of the two 
markings. This visualization will then show data that has been marked 
using either of the selected markings. 

Limit data using 
filterings 

Defines how different filtering schemes in the analysis should affect 
this visualization. 
Select Use the current filtering from the page if you want the 
visualization to always utilize the filtering scheme that is used on the 
page where the visualization is located. If you move the visualization to 
a new page, then the visualization will automatically start reacting on 
the filtering scheme that is used on the new page.  
Select a specific filtering scheme from the list if you want the 
visualization to always use that filtering scheme. Moving the 
visualization to another page with a different filtering scheme will not 
affect this setting. 
If you select to limit data using more than one filtering scheme, the 
intersection of the filterings will be used. This means that the 
visualization will show only the data that is made visible by all of the 
filtering schemes. 

New... Opens the New Filtering Scheme dialog where you can specify a new 
filtering scheme. 
The color and name of a previously created filtering scheme is edited in 
the Document Properties dialog. 

Limit data using 
expression 

You can limit what data should be available for a certain visualization 
using an expression. If you have defined a limiting expression, it will be 
displayed here. 

Edit... Opens the Limit Data Using Expression dialog where you can define a 
boolean expression to use for limiting the data in this visualization. 
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4.7.3.4 Pie Chart Properties - Appearance 

 

Option Description 

Sort sectors by 
size 

This option sorts the sectors of the pie chart, so that the largest sector is 
placed next to the second largest sector, and so forth. 
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4.7.3.5 Pie Chart Properties - Fonts 

 

Option Description 

Settings for Lists all items for which you can change the font settings. Click to 
select an item in the list to change the font settings for that text in the 
visualization. Press Ctrl and click on more items to change the settings 
for multiple items simultaneously. 

Font Specifies the font to use for the selected items. 

Font style Specifies the font style to use for the selected items. 

Size Specifies the font size to use for the selected items. 
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4.7.3.6 Pie Chart Properties - Colors 

 

Option Description 

Columns Specifies the column or hierarchy to color by. Pie charts can only be 
colored by categories, therefore continuous columns will be auto-
binned. See What is Binning? to learn more about binned columns. 

Settings Opens the Advanced Settings dialog. The upper part of the dialog is 
grayed out, because it concerns scale mode, which cannot be changed 
for pie charts. In the lower part you can change the category mode to 
determine which combinations to show. 

Color mode Specifies in which color mode to set up the color scheme. You can 
select either Categorical or Fixed color mode. To learn more about the 
color modes, see Color Modes Overview. 

One scale per Not applicable to pie charts. Available for continuous columns only. 

 
[Color Schemes 
menu] 

Opens a menu where you can select an already existing color scheme 
and apply it to the visualization, or apply the currently open color 
scheme to another visualization in the analysis. 

   From 
Visualization 

Lets you select a color scheme from another visualization in the 
analysis. Only color schemes that are applicable to the current color 
scheme will be listed. 

   Document Color 
Schemes 

Lets you select a color scheme that has previously been saved within 
the analysis. Only color schemes that are applicable to the current 
color scheme will be listed. This menu option is only available if one 
or more document color schemes already exist. 
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   Open from 
Library... 

Opens the Open from Library dialog where you can select a color 
scheme that has previously been saved to the library. 

   Open from File... Opens a dialog where you can select a previously saved color scheme. 

   Save As Lets you save a color scheme as a library item, a local file or a 
document color scheme. 
Library Item – Opens the Save as Library Item dialog, where you can 
specify a location in the library and a file name to save the currently 
open color scheme for later reuse. 
File – Opens a dialog where you can specify a location and a file name 
to save your currently open color scheme locally on your computer for 
later reuse. 
Document Color Scheme – Opens the Save as Document Color 
Scheme dialog, where you can specify a name and save the currently 
open color scheme for later reuse within the analysis. 

   Apply to 
Visualizations... 

Opens the Apply to Visualizations dialog where you can select other 
visualizations (within the analysis) that you want to apply the current 
color scheme to. Only visualizations with compatible color schemes 
are listed. 
Note: If you apply a color scheme to a table, cross table, or heat map, 
the coloring will not take effect immediately. The color scheme will be 
added as an empty color scheme grouping, and you must select which 
columns or axis values to include in the grouping by opening the Edit 
Color Scheme Grouping dialog. 

[Color scheme area] The area in the lower part of the dialog shows the current color 
scheme. That is, the colors and values currently used in the 
visualization. You can modify color schemes in numerous ways to 
give the visualization the appearance you prefer. The color scheme 
area will look different, and have different available settings, 
depending on the characteristics of the column used to color the 
visualization by, as well as the selected color mode. To learn more 
about color schemes and color modes, see Color Schemes Overview 
and Color Modes Overview respectively. 

Add Point Not applicable to pie charts. Available for continuous columns only. 

Delete Point Not applicable to pie charts. Available for continuous columns only. 

Add Rule... Opens the Add Rule dialog where you can define a rule that functions 
as an exception to the rest of the defined color scheme. A rule has 
higher priority than the rest of the color scheme. For example, you can 
define a rule to give the top five items in your data a different color 
than the rest of the items. If you add many rules to a color scheme, the 
rules are prioritized from top to bottom. Which rule types are available 
depends on the characteristics of the column or hierarchy used to color 
the visualization by. See Details on Add/Edit Rule for full descriptions 
of the rule types. 

Reset Resets the color scheme to the one that was in effect when the 
visualization was created. Any added rules will be removed. Which 
color scheme should be used by default when you create a new 
visualization is defined in the Visualization page of the Options 
dialog. 
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4.7.3.7 Pie Chart Properties - Size 

 

Option Description 

Sector size by Specifies a column or hierarchy whose categories will determine the 
size of the pie sectors. This is always an aggregated measure. 

Pie size Specifies the absolute pie size within the visualization area. 

Pie size by Sizes the pies according to the values in the specified column. Only 
relevant when there are more than one pie available (via trellising). 

Scale Determines what scale to use for the size of the pie. Only relevant 
when there are more than one pie available (via trellising). 

   From min to 
max 

Assigns the maximum pie size to the highest value, and the minimum 
pie size to the lowest value. For instance, if the minimum and 
maximum data values are -9 and 11 the pie sizes could be like the 
following: 

 
This mode is useful when you want to visualize differences. 

      Min limit: 
      Max limit: 

The minimum and maximum limits that should be mapped to the pie 
size. By default, they are set to "Automatic". This means that the pie 
size will adapt during filtering. If the scale is set to "From min to max", 
the current minimum value will have the minimum pie size, and the 
current maximum value will have the maximum pie size. It is 
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comparable to automatic zooming on the X- or Y-axis. 
It is possible to lock max limit and/or min limit to a specific value by 
selecting "Value" in the drop-down list and entering a value. Data 
values that are lower than the minimum value or higher than the 
maximum value will not get a size and are not drawn. By setting the 
lower value to 0, negative values can be removed. By specifying both a 
high and low value, the auto-scaling behavior is turned off. 

   From 0 to max 
  absolute value 

This mode is useful when you want to compare the magnitude of 
measures. By letting the value 0 map to pie size 0, and the maximum 
value to the maximum pie size, it is possible to compare the diameter 
of pie and say "a" is twice as big as "b". So with this scale the values 
50 and 100 would be rendered like this: 

 
Note: The size is scaled symmetrically around 0 with absolute 
numbers. That is, if your highest value is 10 and your lowest is -20, the 
size of the pie at 10 will be 50 percent of the maximum pie size. 

      Max: The absolute limit that should be mapped to the pie size. By default, it 
is set to "Automatic". This means that the marker size will adapt during 
filtering. The value 0 will have the minimum pie size and the highest 
absolute value in the visualization will have the maximum pie size. 
It is possible to lock this to a specific value by selecting "Value" in the 
drop-down list and entering a value. Data values that have a larger 
absolute value than the set value will get the same size as the maximum 
value. 
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4.7.3.8 Pie Chart Properties - Labels 

 

Option Description 

Show in labels Specifies what information to show in the labels for the pie sectors. 

   Sector 
percentage 

Displays labels showing the percentage of the total that each sector 
represents. 

   Sector value Displays the value of the sector. For example, sum of sales for apples, 
if the sector size is defined by sum of sales and the color is defined by 
fruit or vegetable type. 

   Sector category Displays the category defining the sector. For example, "apples", if the 
sector color is defined by fruit or vegetable type. 

Label position Specifies whether the labels should be placed Inside pie or Outside 
pie. 

Show labels for Determines whether to show labels for all pie sectors (All), pie sectors 
containing marked rows only (Marked rows), or not to show any 
labels at all (None). 

Max number of 
labels 

Specifies the maximum number of labels to be shown. 

Sector percentage 
threshold 

Excludes the labels for the sectors whose percentage falls below the 
specified threshold value. 

Sector percentage 
decimals 

Specifies the number of decimals to display for the percentage value. 
The number specified here will also affect the number of decimals 
shown for pie sectors in the tooltip. 
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4.7.3.9 Pie Chart Properties - Tooltip 

 

Option Description 

Display the 
following values 

Specifies what will be shown in the tooltip. 

Add... Opens the Add Tooltip Value dialog, where you can add the content 
from another column, hierarchy, or any custom expression to be 
shown in the tooltip. You can also use images in tooltips. See 
Highlighting in Visualizations for more information. 

Edit... Opens the Edit Tooltip Value dialog, where you can change the 
information to be shown in the tooltip. 

Delete Deletes the selected value from the list. 

Move Up Moves the selected value up in the list and, hence, up in the tooltip. 

Move Down Moves the selected value down in the list and, hence, down in the 
tooltip. 

Tooltip format   

   Value names and 
values 

Shows the tooltip content in a format where the selected column name, 
hierarchy or custom expression is displayed. For example, Year: 2003, 
Type: Cucumber, etc. 

   Visualization 
properties and 
values 

Shows the tooltip content in a format where the visualization property 
for each value is displayed. For example, X: 2003, Color: Cucumber, 
etc. 
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4.7.3.10 Pie Chart Properties - Legend 

 

Option Description 

Show legend Specifies whether or not the docked legend should be shown in the 
visualization. 

Position Specifies which side of the visualization the legend should be 
positioned: the right-hand side or the left-hand side. 

Display the 
following legend 
items 

Specifies what will be shown in the legend.  
By clearing a check box you will completely hide that item from the 
legend. You can also select to show or hide parts of the legend 
information using the check boxes under Settings for the selected item 
in the list, see below. 

Settings Defines how the selected legend item should be displayed. The 
available options vary between legend items. 

   Show title Use this option to show or hide the title for the selected item. The title 
is typically what is displayed above an axis selector or similar: 

 

   Show axis 
selector 

Select this option to show or hide the axis selector for the selected item.  
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4.7.3.11 Pie Chart Properties - Trellis 

 

Option Description 

Rows and columns Splits the visualization into different panels for all categories 
in the selected column or hierarchy. The number of values in 
the specified column or hierarchy controls the number of 
panels to be displayed in each row, column, or page, 
respectively. 

   Rows A row with trellis panels will be created for each value in the 
selected column or hierarchy. 

   Columns A column with trellis panels will be created for each value in 
the selected column or hierarchy. 

   Pages A new page with trellis panels will be created for each value in 
the selected column or hierarchy. Scroll down in the 
visualization to see the next page. 

Panels Splits the visualization into different panels for all categories 
in the selected column or hierarchy, without binding any 
dimensions to either rows or columns. This means that the 
number of actual values in the column to split by does not 



Visualizations 

373 

control the number of shown rows or columns in any way. 
The number of panels that should be visible on each page is 
instead specified using the Max number of rows and Max 
number of columns controls below. 

   Split by Specifies the column or hierarchy to define the categories by 
which the visualization should be split. 

   Manual layout Select the check box to manually specify the number of rows 
and columns that should be visible without scrolling. If the 
check box is cleared, the application will automatically specify 
the number of rows and columns. 

   Max number of rows Specifies the maximum number of panels that should be 
visible on each page. 

   Max number of columns Specifies the maximum number of panels that should be 
visible on each page. 

Settings... Opens the Advanced Settings dialog where you can change the 
category mode to determine which combinations to show. 

 

  



TIBCO Spotfire 4.0.2 - User's Manual 

374 

4.8 Scatter Plot 
4.8.1 What is a Scatter Plot? 

Scatter plots are used to plot data points on a horizontal and a vertical axis in the attempt to 
show how much one variable is affected by another. Each row in the data table is represented by 
a marker whose position depends on its values in the columns set on the X and Y axes. 
A third variable can be set to correspond to the color or size of the markers, thus adding yet 
another dimension to the plot.   
The relationship between two variables is called their correlation. If the markers are close to 
making a straight line in the scatter plot, the two variables have a high correlation. If the 
markers are equally distributed in the scatter plot, the correlation is low, or zero. However, even 
though a correlation may seem to be present, this might not always be the case. Both variables 
could be related to some third variable, thus explaining their variation, or, pure coincidence 
might cause an apparent correlation. 

Example: 
In the scatter plot below, sales is plotted against cost for a number of different products (colored 
by product), to display a low positive correlation. 

 
Each product can be shown separately using trellising: 

 
The scatter plot can also be used together with aggregation (for example, Sum or Average) by 
using the setting Marker By. In this case, the values for a certain category are bundled together 
to display a single marker for each category. The aggregated markers can also be sized by the 
count of items within each category, or by any other column. 
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Example: 
The markers now show the Sum of Sales for each product, as you can see on the axis selector 
for the Y-axis. 

 
Multiple scales can also be used on the Y-axis, when you want to compare several markers with 
significantly different value ranges. 
Labels can be used in visualizations to identify and describe markers and the data associated 
with them. 

Example: 
In the scatter plot below, labels show which category each of the marked markers belongs to. 

 
In a scatter plot, you can interact with the labels and move them using drag-and-drop 
operations. Click on a label to mark the corresponding marker, and mouseover a label to 
highlight both the label and the marker. If you move a label, it will stay in the new position until 
you reset the label positions from the right-click menu in the visualization. If you select to show 
labels for all markers, the labels will be visible for all markers at all times. You can also select 
to show labels for marked markers only. Labels will then appear every time you mark one or 
many markers. To add labels and/or change label settings, open the Labels page of the Scatter 
Plot Properties dialog. 
You can change the shapes of the markers to add another dimension to the visualization, or to 
get a view that better suits your data. For example, you can have the marker shapes correspond 
to the different values in a column, or display the markers as pie charts. Another option is to use 
tiled markers. This means that all the markers will have the same size, and be displayed in a 
grid-like layout as seen in the example below. 
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Example: 

 
This example shows the results of an experiment conducted on an assay plate consisting of 96 
wells. Each marker in the scatter plot represents a well on the assay plate, and the markers’ 
colors represent the results of the experiment for each of the wells on the plate. Using this setup 
to copy the actual layout of the assay plate is a way to enhance the readability of the data. It 
becomes easy to notice that the well represented by the marker G2 stands out compared to the 
other wells. Labels are always centered and displayed directly on tiled markers. Therefore, they 
cannot be moved around as is otherwise possible in a scatter plot. 
Note: If you use tiled markers, and the axes’ scales have a large number of values, then the 
markers may become too small to be seen. The reason for this is that the grid layout makes it 
necessary for each value on the scales to have a unique position, even if no marker is located at 
each of these allocated positions. Therefore, with a large number of values on the scale, the 
markers must become very small to fit in the grid. 
All visualizations except the map chart can be set up to show data limited by one or more 
markings in other visualizations only (details visualizations). They can also be limited by one or 
more filterings. Another alternative is to set up a visualization without any filtering at all. See 
Limiting What is Shown in Visualizations for more information. 

4.8.2 How to Use the Scatter Plot 
► To apply coloring: 

1. In the filters panel, click and hold down the left mouse button on the filter representing 
the column that you want to color by. 
Comment: Coloring is also available in the Visualization Properties dialog. The color 
of marked items is changed under Edit > Document Properties. 

2. Drag the filter to the center of the visualization. 
Response: Drop targets appear in the middle of the visualization. 

3. Release the mouse button on the Color target. 
Response: The markers are colored with one color for each category in the selected 
column. 
Comment: To learn more about coloring in Spotfire, see Coloring Overview. 

► To shape markers by a column: 
1. In the filters panel, click and hold down the left mouse button on the filter representing 

the column that you want to shape by. 
Comment: Shape is also available in the Properties dialog. 

2. Drag the filter to the center of the visualization. 
Comment: Drop targets appear in the middle of the visualization. 
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3. Release the mouse button on the Shape by target. 
Response: The markers are shaped with one shape for each category in the selected 
column. 
Comment: In the Shape page of the Properties dialog you can also change the fixed 
shape, or select pies as shape. To use pies, you must first aggregate the markers, as 
described below. 

► To aggregate markers: 
1. Right-click in the scatter plot to display the pop-up menu. 
2. Select Properties. 

Comment: If the Legend is visible, the Marker by property may also be changed there. 
3. Click to display the Marker By page. 
4. Select a column to group the markers by under Show one marker for each. You can 

also select Remove to get the option (None) on the Marker By selector. If (None) is 
selected then the number of markers shown will depend on other properties only, such 
as which columns are selected on the axes or used to color by. None is often a good 
alternative if you intend to use pies as shape. 
Response: The markers are grouped so that a single marker is shown for each category 
in the selected column. 
Comment: Select (Row Number) to remove the aggregation and show one marker for 
each row. 

► To use multiple columns on one axis: 
This is an example of how to use two columns on the Y-axis. Each column will be represented 
by a set of colored markers. 

1. Click on the arrow next to the plus sign on the axis of your choice. 
2. Select a new column from the menu. 

Comment: A column can also be dragged and dropped from the filters panel. 
3. Select (Column Names) in the Color By drop down list. 

Response: The markers are colored with one color for each column. 
Comment: For more information on (Column Names), see the Non-Column Selections 
page. 

► To add multiple scales: 
1. Right-click on the Y-axis and select Multiple Scales from the pop-up menu. 

Comment: By default, you will get one scale for each color that is defined under Color 
By. 

2. You can also go to the Y-axis page in the Visualization Properties dialog and click the 
Multiple scales radio button. This is also where you change the settings for the 
different scales and determine whether a certain scale should be located on the left or 
the right Y-axis. 
Comment: If you are using values from different columns on the various scales, you 
can also use drag and drop to move columns from one side to another. 

► To add a reference line to the scatter plot: 
1. Right-click on the visualization to display the pop-up menu. 
2. Select Properties. 
3. Go to the Lines & Curves page. 
4. Select the check box for any of the default lines or click on Add to define a new 

horizontal or vertical line. 
Comment: You can only add lines to the axes when they are in continuous mode. 
Right-click on the scale labels and select Continuous Scale from the pop-up menu. 
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► To add a curve fit to the scatter plot: 
1. Right-click on the visualization to display the pop-up menu. 
2. Select Properties. 
3. Go to the Lines & Curves page. 
4. Click on Add and select a suitable curve fit from the drop-down menu. 

Comment: You can select from a number of predefined curve fits, or define your own 
curve using Curve Draw. See Curve Fit Models for more information about the 
different options. 

5. Once the curve has been created, you can change its settings on the Lines & Curves 
page. Some of the curve settings are also available from the pop-up menu in the 
visualization. 

► To add error bars to the scatter plot: 
1. Right-click in the visualization to display the pop-up menu. 
2. Select Properties. 
3. Go to the Error Bars page. 
4. In the Visible error bars list, select the column or measure to use, and select the check 

box next to it. 
Response: The settings for the selected column or measure will be displayed in the 
lower part of the dialog. 
Comment: Only columns and measures with numerical values are listed. 

5. To define an upper error, choose a column or measure in the Upper error column 
selector. To define a lower error, choose a column or measure in the Lower error 
column selector. 
Response: The defined error bars appear in the visualization. 
Comment: Error bars can only be used on numerical values. 

► To display images in labels: 
This is an example of how you can use a binary column containing image information to label 
the markers in a scatter plot. You can of course use regular text labels or a number of other 
settings instead. See the Scatter Plot Properties - Labels page for more information about your 
available labeling options. 

1. Right-click in the visualization to display the pop-up menu. 
2. Select Properties. 
3. Go to the Labels page. 
4. Select the column containing images under Label by. 

Comment: This example assumes that you have the images available as a binary 
column in your current data table. If you intend to retrieve images via an information 
link you need to select an identifier column instead, and then use a suitable transform 
to map the ID to the requested image. 

5. Determine whether to Show labels for All rows, Marked rows or None. 
6. If desired, modify the Max number of labels to limit the amount of shown labels 

further. 
7. (If required, select a Transform to convert the selected column values to another form 

of output. See the comment on step 4.) 
8. Make sure that Show as is set to Image (or whatever the type of output is that you 

wish to display). 
Comment: If you are running TIBCO Spotfire Lead Discovery and select a Structure 
Column as the transform then you would typically select a structure renderer here 
instead. 

9. If desired, change the Size of the labels by dragging the slider. 
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► To display images in tooltips: 
This is an example of how you can use a binary column containing image information in the 
tooltip shown when hovering with the mouse pointer over the markers in a scatter plot. You can 
of course use regular text tooltips instead. See the Scatter Plot Properties - Tooltip page for 
more information about your available tooltip options. 

1. Right-click in the visualization to display the pop-up menu. 
2. Select Properties. 
3. Go to the Tooltip page. 
4. Click Add.... 

Response: The Add Tooltip dialog is displayed. 
5. Select the Column containing images. 

Comment: This example assumes that you have the images available as a binary 
column in your current data table. If you intend to retrieve images via an information 
link you need to select an identifier column instead, and then use a suitable transform 
to map the ID to the requested image. 

6. If desired, change the display Name. 
7. (If required, select a Transform to convert the selected column values to another form 

of output. See the comment on step 5.) 
8. Make sure that Show as is set to Image (or whatever the type of output is that you 

wish to display). 
Comment: If you are running TIBCO Spotfire Lead Discovery and select a Structure 
Column as the transform then you would typically select a structure renderer here 
instead. 

9. If desired, change the Size of the labels by dragging the slider. 
10. Select whether or not to Include value name in tooltip. 
11. Click OK. 

► To create a new scatter plot: 
1. Click on the New Scatter Plot button on the toolbar, . 

Comment: You can also select Insert > New Visualization > Scatter Plot from the 
menu. 
Response: A first attempt to set up a suitable scatter plot is made by the application. 

2. Adjust the scatter plot to display the measures of your choice. 
Comment: For more information about how to change what to show on the two axes, 
see Column Selectors. 

4.8.3 Scatter Plot Properties 

4.8.3.1 Scatter Plot Properties 
The Scatter Plot Properties dialog consists of several pages: 

• General 
• Data 
• Appearance 
• Formatting 
• Fonts 
• X-axis 
• Y-axis 
• Colors 
• Size 
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• Shape 
• Labels 
• Tooltip 
• Legend 
• Trellis 
• Line Connection 
• Marker By 
• Lines & Curves 
• Error Bars 

► To reach the Scatter Plot Properties dialog: 
1. Right-click on the scatter plot visualization. 
2. Select Properties from the pop-up menu. 

Comment: You can also click on the scatter plot visualization to make it active and 
then select Edit > Visualization Properties. 

4.8.3.2 Scatter Plot Properties - General 

 

Option Description 

Title The title of the visualization. 
Tip: Double-click on the title bar of the visualization for a shortcut to 
this field. 

Show title bar Specifies whether or not to show the visualization title. 

Description A description of the visualization. This description can optionally be 
shown in the legend and/or in the visualization. 
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Show description 
in visualization 

Specifies whether or not to show the description in the visualization. 

4.8.3.3 Scatter Plot Properties - Data 

 

Option Description 

Data table Specifies the data table on which the visualization will work. 

Marking Specifies the marking (that is, the color and relationships to other 
marked items) that will be used to mark items in this visualization. 

Limit data using 
markings 

Lists the available markings that can be used to limit what is shown in 
this visualization. This means that the visualization only displays data 
that has been marked in other visualizations. 
If more than one marking is selected, you can choose how the data in 
the markings should be combined. 

New... Opens the New Marking dialog where you can specify a new marking. 
The color and name of a previously created marking is edited in the 
Document Properties dialog. 

Rows must be 
included in 

Specifies how the data in the markings should be combined if you have 
selected to limit the data by more than one marking. 

   All markings 
(AND) 
   

Use this option if you want this visualization to show the intersection of 
the markings selected in Limit data using markings. This can be used if 
you have two visualizations with different markings and want to see 
which markers are present in both markings. This visualization will 
then show only the data that has been marked using both of the selected 
markings. 
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   Any marking 
(OR) 
    

Use this option if you want this visualization to show the union of the 
markings selected in Limit data using markings.  
This can be used if you have two visualizations with different markings 
and want to see which markers are present in either of the two 
markings. This visualization will then show data that has been marked 
using either of the selected markings. 

Limit data using 
filterings 

Defines how different filtering schemes in the analysis should affect 
this visualization. 
Select Use the current filtering from the page if you want the 
visualization to always utilize the filtering scheme that is used on the 
page where the visualization is located. If you move the visualization to 
a new page, then the visualization will automatically start reacting on 
the filtering scheme that is used on the new page.  
Select a specific filtering scheme from the list if you want the 
visualization to always use that filtering scheme. Moving the 
visualization to another page with a different filtering scheme will not 
affect this setting. 
If you select to limit data using more than one filtering scheme, the 
intersection of the filterings will be used. This means that the 
visualization will show only the data that is made visible by all of the 
filtering schemes. 

New... Opens the New Filtering Scheme dialog where you can specify a new 
filtering scheme. 
The color and name of a previously created filtering scheme is edited in 
the Document Properties dialog. 

Limit data using 
expression 

You can limit what data should be available for a certain visualization 
using an expression. If you have defined a limiting expression, it will be 
displayed here. 

Edit... Opens the Limit Data Using Expression dialog where you can define a 
boolean expression to use for limiting the data in this visualization. 
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4.8.3.4 Scatter Plot Properties - Appearance 

 

Option Description 

Jittering Jittering is an option that displaces the visualization items randomly 
in the display window, thereby making overlapping markers visible. 

   X Specifies the amount of jittering to use in the horizontal direction. 

   Y Specifies the amount of jittering to use in the vertical direction. 

   Use the same 
amount of jittering 
for both X and Y 

Select this check box to connect the jittering sliders in both directions 
to each other. 
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4.8.3.5 Scatter Plot Properties - Formatting 

 

Option Description 

Axes Displays which column and category are currently being used on each 
of the two axes in the scatter plot. Click on the one you want to change 
the settings for. If the columns on the axes are of the same type, you 
can set formatting for both axes at the same time. If you use multiple 
scales in the visualization, each of the different scales on the Y-axis 
will appear in the list, and you can apply formatting to them 
individually. 

Reset Resets the formatting for the selected axis values according to the 
settings defined on column level. If no column formatting has been set, 
axis formatting settings defined in the Options dialog will be used. If 
no settings have been specified in the Options dialog, the default 
settings for the visualization type will be used. 

Category Lists the available formatting categories for the selected axis. Each 
category in this list has separate settings. Which categories are 
available depends on the data type of the selected axis. See Formatting 
Settings for a full description of all possible options. 

Note: These settings affect only the current visualization. For general information about 
formatting, see Formatting Overview. 
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4.8.3.6 Scatter Plot Properties - Fonts 

 

Option Description 

Settings for Lists all items for which you can change the font settings. Click to 
select an item in the list to change the font settings for that text in the 
visualization. Press Ctrl and click on more items to change the settings 
for multiple items simultaneously. 

Font Specifies the font to use for the selected items. 

Font style Specifies the font style to use for the selected items. 

Size Specifies the font size to use for the selected items. 



TIBCO Spotfire 4.0.2 - User's Manual 

386 

4.8.3.7 Scatter Plot Properties - X-axis 

 

Option Description 

Columns Specifies the column or hierarchy to be displayed on the X-axis. 

Settings... Opens the Advanced Settings dialog, where you can change the scale 
mode from categorical to continuous and vice versa, as well as 
changing the category mode to determine which combinations to 
show. 

Range   

   Min Determines the lower value of the axis range. Leave the field blank to 
automatically adjust the range to the currently lowest value in the 
filtered data. 

   Max Determines the upper value of the axis range. Leave the field blank to 
automatically adjust the range to the currently highest value in the 
filtered data. 

   Set to Current 
Range 

Allows you to set the axis range to the currently filtered values. 
  

   Include origin Available for continuous axes only. Always includes the coordinates 
(0, 0) in the visualization, regardless of filtering. 

   Show zoom slider Shows a zoom slider that you can manually manipulate to view only 
the interesting markers in the scatter plot. 

Show gridlines Specifies whether or not vertical gridlines should be visible. 
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Scale labels   

   Show labels Specifies whether or not scale labels should be visible. 

      Horizontally Shows scale labels horizontally. 

      Vertically Shows scale labels vertically. 

      Max number of 
labels 

Select the check box to specify a maximum number of scale labels to 
be shown. Limiting the number of labels can improve readability on 
axis scales with many values. 

Scale   

   Log scale Changes the scale from a linear scale to a logarithmic base 10 scale 
[log10 (x)]. 

   Reverse scale Reverses the current sort order, so that the lowest value is displayed at 
the top of the scale. 

4.8.3.8 Scatter Plot Properties - Y-axis 

One Y-axis with a single scale 

 

Option Description 

Columns Specifies the column or hierarchy to be displayed on the Y-axis. 

Settings... Opens the Advanced Settings dialog where you can change the scale 
mode from categorical to continuous and vice versa, as well as 
changing the category mode to determine which combinations to 
show. 
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One axis with a 
single scale 

Use this option if you want to show the values from a single column 
on the Y-axis or if you have multiple columns that can be presented 
using the same scale. 

Multiple scales Use this option to show two Y-axes (left and right) with two or more 
different scales. For example, use it if you want to display two 
columns of very different magnitudes in the same visualization. 

Range   

   Min Determines the lower value of the axis range. Leave the field blank to 
automatically adjust the range to the currently lowest value in the 
filtered data. 

   Max Determines the upper value of the axis range. Leave the field blank to 
automatically adjust the range to the currently highest value in the 
filtered data. 

   Set to Current 
Range 

Allows you to set the axis range to the currently filtered values. 

   Include origin Available for continuous columns only. Always includes the 
coordinates (0, 0) in the visualization, regardless of filtering. 

   Show zoom slider Shows a zoom slider that you can manually manipulate to view only 
the interesting segments of the scatter plot. 

Show gridlines Specifies whether or not horizontal gridlines should be visible. 

Scale labels   

   Show labels Specifies whether or not scale labels should be visible. 

      Horizontally Shows scale labels horizontally. 

      Vertically Shows scale labels vertically. 

      Max number of 
labels 

Select the check box to specify a maximum number of scale labels to 
be shown. Limiting the number of labels can improve readability on 
axis scales with many values. 

Scale   

   Log scale Changes the scale from a linear scale to a logarithmic base 10 scale 
[log10 (x)]. 

   Reverse scale Reverses the current sort order so that the lowest value is displayed at 
the top of the scale. 
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Multiple scales 

 

Option Description 

Columns Specifies the column or hierarchy to be displayed on the Y-axis. 

Settings... Opens the Advanced Settings dialog where you can change the scale 
mode from categorical to continuous and vice versa, as well as 
changing the category mode to determine which combinations to 
show. 

One axis with a 
single scale 

Use this option if you want to show the values from a single column 
on the Y-axis or if you have multiple columns that can be presented 
using the same scale. 

Multiple scales Use this option to show two Y-axes (left and right) with two or more 
different scales. For example, use it if you want to display two 
columns with values of very different magnitudes in the same 
visualization. 

Individual scaling   

   For each color Use this option to display one scale for each category used to color the 
markers by. For example, if you put two different columns on the Y-
axis (for example, Oil Production and BNP), you can use the 
"(Column Names)" option to color by and click this radio button to 
display one scale for Oil Production and one for BNP. 
Do not use this option if you need to color by a large number of 
different categories. 
Note that you should apply true categorical coloring before using this 
option. If you use a continuous column on the color axis, you may end 
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up with a different result than the expected. This applies even if the 
continuous color mode looks "categorical" at first sight. 

   For each trellis 
panel 

Use this option to display one scale for each trellis panel. 

Zoom   

   Show zoom slider Shows a zoom slider that you can manually manipulate to view only 
the interesting segments of the scatter plot. 

Show gridlines Specifies whether or not horizontal gridlines should be visible. 

Scale labels   

   Show labels Specifies whether or not scale labels should be visible. The scale labels 
are always displayed horizontally when multiple scales are shown. 

   Horizontally Shows scale labels horizontally. 
Note: Only available for individual scaling for each trellis panel. 

    Vertically Shows scale labels vertically. 
Note: Only available for individual scaling for each trellis panel. 

      Max number of 
labels 

Select the check box to specify a maximum number of scale labels to 
be shown. Limiting the number of labels can improve readability on 
axis scales with many values. 

Individual scale 
settings 

  

[Drop-down list] Select the scale for which you wish to change the settings. Select All 
scales to change settings for all scales simultaneously. 

Scale Range... Opens the Scale Range dialog where you can specify the range of the 
selected scale, and also determine whether or not to include the origin 
(0, 0). 

Position Specifies which side of the visualization the scales should be 
positioned. 

   Left Y-axis Select this option to place the selected scale on the left-hand side of 
the visualization. 

   Right Y-axis Select this option to place the selected scale on the right-hand side of 
the visualization. 

Log scale Changes the scale from a linear scale to a logarithmic base 10 scale 
[log10 (x)]. 

Reverse scale Reverses the current sort order, so that the lowest value is displayed at 
the top of the scale. 
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4.8.3.9 Scatter Plot Properties - Colors 

 

Option Description 

Columns Specifies the column or hierarchy to color by. 

Settings Opens the Advanced Settings dialog where you can change the scale 
mode for the selected column or hierarchy from continuous to 
categorical and vice versa, as well as changing the category mode to 
determine which combinations to show. 

Color mode Specifies in which color mode to set up the color scheme. Which 
modes are available depends on whether the scale is in categorical or 
continuous mode. For columns in continuous scale mode, you can 
select one of the following color modes: Gradient, Segments, or Fixed. 
For columns in categorical scale mode, you can select either 
Categorical or Fixed color mode. To learn more about the color 
modes, see Color Modes Overview. 

One scale per Specifies whether there should be one separate scale per trellis panel 
for trellised scatter plots, or if one scale should apply to the entire 
visualization. Only applicable to columns in continuous scale mode. 

 
[Color Schemes 
menu] 

Opens a menu where you can select an already existing color scheme 
and apply it to the visualization, or apply the currently open color 
scheme to another visualization in the analysis. 

   From 
Visualization 

Lets you select a color scheme from another visualization in the 
analysis. Only color schemes that are applicable to the current color 
scheme will be listed. 
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   Document Color 
Schemes 

Lets you select a color scheme that has previously been saved within 
the analysis. Only color schemes that are applicable to the current 
color scheme will be listed. This menu option is only available if one 
or more document color schemes already exist. 

   [Predefined color 
schemes] 

Lists a number of predefined color schemes. Available for columns in 
continuous scale mode only. For a full description of the predefined 
color schemes, see Predefined Color Schemes. 
Tip: To facilitate setting up a new color scheme, you can open a 
predefined color scheme with a similar appearance, and then adjust it 
to suit your needs. 

   Open from 
Library... 

Opens the Open from Library dialog where you can select a color 
scheme that has previously been saved to the library. 

   Open from File... Opens a dialog where you can select a previously saved color scheme. 

   Save As Lets you save a color scheme as a library item, a local file or a 
document color scheme. 
Library Item – Opens the Save as Library Item dialog, where you can 
specify a location in the library and a file name to save the currently 
open color scheme for later reuse. 
File – Opens a dialog where you can specify a location and a file name 
to save your currently open color scheme locally on your computer for 
later reuse. 
Document Color Scheme – Opens the Save as Document Color 
Scheme dialog, where you can specify a name and save the currently 
open color scheme for later reuse within the analysis. 

   Apply to 
Visualizations... 

Opens the Apply to Visualizations dialog where you can select other 
visualizations (within the analysis) that you want to apply the current 
color scheme to. Only visualizations with compatible color schemes 
are listed. 
Note: If you apply a color scheme to a table, cross table, or heat map, 
the coloring will not take effect immediately. The color scheme will be 
added as an empty color scheme grouping, and you must select which 
columns or axis values to include in the grouping by opening the Edit 
Color Scheme Grouping dialog. 

[Color scheme area] The area in the lower part of the dialog shows the current color 
scheme. That is, the colors and values currently used in the 
visualization. You can modify color schemes in numerous ways to 
give the visualization the appearance you prefer. The color scheme 
area will look different, and have different available settings, 
depending on the characteristics of the column used to color the 
visualization by, as well as the selected color mode. To learn more 
about color schemes and color modes, see Color Schemes Overview 
and Color Modes Overview respectively. 

Add Point Available for continuous columns only. Adds a new anchor point to 
the color scheme. 

Delete Point Available for continuous columns only. Deletes the selected anchor 
point. 

Add Rule... Opens the Add Rule dialog where you can define a rule that functions 
as an exception to the rest of the defined color scheme. A rule has 
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higher priority than the rest of the color scheme. For example, you can 
define a rule to give the top five items in your data a different color 
than the rest of the items. If you add many rules to a color scheme, the 
rules are prioritized from top to bottom. Which rule types are available 
depends on the characteristics of the column or hierarchy used to color 
the visualization by. See Details on Add/Edit Rule for full descriptions 
of the rule types. 

Reset Resets the color scheme to the one that was in effect when the 
visualization was created. Any added rules will be removed. Which 
color scheme should be used by default when you create a new 
visualization is defined in the Visualization page of the Options 
dialog. 

 

4.8.3.10 Scatter Plot Properties - Size 

 
Note: The settings on this page are not available when the scatter plot is set up with tiled 
markers. There are no size settings to apply to tiled markers since they have the same size by 
definition. Go to the Shape page to change marker shapes. 

Option Description 

Marker size Increases or decreases the overall size of all markers. 

Size by Specifies a column or hierarchy whose categories will determine the 
size of the markers. 
The aggregation options on the drop-down menu are only available if 
the markers in the scatter plot have been aggregated by setting the 
Marker By option to something other than (Row Number). 
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Scale Determines what scale to use for the size of the markers. 

From min to max Assigns the maximum marker size to the highest value, and the 
minimum marker size to the lowest value. For instance, if the 
minimum and maximum data values are -9 and 11 the marker sizes 
could be like the following: 

 
This mode is useful when you want to visualize differences. 

  Min limit: 
  Max limit: 

The minimum and maximum limits that should be mapped to the 
marker size. By default, they are set to "Automatic". This means that 
the marker size will adapt during filtering. If the scale is set to "From 
min to max", the current minimum value will have the minimum 
marker size, and the current maximum value will have the maximum 
marker size. It is comparable to automatic zooming on the X or Y axes. 
It is possible to lock the max limit and/or min limit to a specific value 
by selecting "Value" in the drop-down list and entering a value. Data 
values that are lower than the minimum value or higher than the 
maximum value will get the same size as the minimum and maximum 
value respectively. By specifying both a high and low value, the auto-
scaling behavior is turned off. 

From 0 to max 
absolute value 

This mode is useful when you want to compare the magnitude of 
measures. By letting the value 0 map to marker size 0, and the 
maximum value to the maximum marker size, it is possible to compare 
the diameter of markers and say "a" is twice as big as "b". With this 
scale the values 50 and 100 would be rendered like this: 

 
Note: The size is scaled symmetrically around 0 with absolute 
numbers. That is, if your highest value is 10 and your lowest is -20, the 
size of the marker at 10 will be 50 percent of the maximum marker 
size. 

  Max: The absolute limit that should be mapped to the marker size. By 
default, it is set to "Automatic". This means that the marker size will 
adapt during filtering. The value 0 will have the minimum marker size 
and the highest absolute value in the visualization will have the 
maximum marker size. 
It is possible to lock this to a specific value by selecting "Value" in the 
drop-down list and entering a value. Data values that have a larger 
absolute value than the set value will get the same size as the 
maximum value. 
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4.8.3.11 Scatter Plot Properties - Shape 

 

Option Description 

Fixed shape Select this option to use the same, fixed shape on all markers. 
Select which shape to use from the Shape drop-down list under 
Shape definition. 

     Shape Defines which shape to use for all markers. 

Shape by column values Select this option to use different shapes for the categories in a 
specified column or hierarchy. Which column or hierarchy to use, 
as well as which shape should represent which category, is 
specified under Shape definition. 
Note: A default set of shapes is used when automatically 
assigning shapes to categories. When there are more categories 
than available shapes in the default set, shapes will be recycled. 

     Columns Specifies the column or hierarchy containing the categories you 
wish to present using different shapes. 

     Settings... Opens the Advanced Settings dialog where you can change the 
category mode to determine which combinations to show. 

     Shape scheme Lists the categories in the selected column or hierarchy, and the 
shapes that have been assigned to each of these categories. 
Note: The set of shapes that is used by default in the scheme does 
not include all the available shapes. You can, however, always 
change to the shapes of your choice manually. Click on a shape 
in the scheme to display all the available shapes and make your 
selection. 
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Tiled markers Select this option to display the markers as tiles. The markers 
will be rectangularly shaped, have the same size, and be 
displayed in a grid-like layout. 
Note: When you use tiled markers the settings in the Size page 
will be disabled since the markers have the same size. 

Pies Select this option to use pies instead of markers. 
Note: The Pies option is only available when the scatter plot is 
aggregated. Scatter plots are not aggregated by default. To enable 
the Pies alternative you need either to set Marker By to (None) or 
to use the column by which you want to aggregate on the Marker 
By selector. 

      Sector size by Determines the numeric column that should provide the sizes of 
the pie sectors. 
Note: Which categories the pie sectors should represent is 
defined in the Colors page. 

      Show in labels Specifies what information to show in the labels for the pie 
sectors. 

         Sector value Displays the value of the sector. For example, sum of sales for 
apples, if the sector size is defined by sum of sales and the color 
is defined by fruit or vegetable type. 

         Sector category Displays the category defining the sector. For example, "apples", 
if the sector color is defined by fruit or vegetable type. 

         Sector percentage Displays labels showing the percentage of the total that each 
sector represents. 

            Threshold Excludes the labels for the sectors whose percentage falls below 
the specified threshold value. 

            Decimals Specifies the number of decimals to display for the percentage 
value. The number specified here will also affect the number of 
decimals shown for pie sectors in the tooltip. 

      Label position Specifies whether the labels will be located Inside or Outside the 
pie sectors. 

      Sort sectors by size Sorts the pie sectors by size. 
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4.8.3.12 Scatter Plot Properties - Labels 

 

Option Description 

Label by Specifies the column or hierarchy whose values should be presented as 
labels in the visualization. 

Show labels for Determines whether to show labels on all markers (All), marked 
markers only (Marked rows), or not to show any labels at all (None). 

Max number of 
labels 

Specifies the maximum number of labels to be shown. If the number is 
smaller than the available number of markers, the labels will be equally 
distributed. 
Note: This setting is not available when the markers are tiled. Go to the 
Shape page if you want to change marker shapes. 

Center labels on 
items 

Places the label right on top of the marker instead of drawing a line 
from the marker to the label, which is the default behavior. This can be 
a way to use your own images as markers. 
Note: This setting is not available when the markers are tiled. Go to the 
Shape page if you want to change marker shapes. 

Show empty 
labels 

Shows labels that have no content. 
Note: This setting is not available when the markers are tiled. Go to the 
Shape page if you want to change marker shapes. 

Display options These settings are used when you choose to display anything other than 
plain text in your labels. For example, the labels could contain web 
links or images.   

   Get content 
from 

[Only visible if at least one virtual column producer is available.] 
Your company may have set up some type of virtual column producers 
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that can take the values from the selected column and transform them in 
one way or another to produce a desired output. For example, if you 
have access to TIBCO Spotfire Lead Discovery you can select Structure 
Column here, in order to show molecular structures from an information 
link in the labels. 
For embedded images in the current data table, or when fetching data 
via a URL, you should leave this setting at (Selected column). 

   Settings... If the selected source has some settings available, you can reach those 
by clicking on the Settings button. For example, this is where you 
would specify which information link to retrieve structures from when 
using TIBCO Spotfire Lead Discovery. 

   Show as Allows you to decide how the data in the selected column should be 
interpreted. 
For example, use Text for plain text labels. Use Image if there are 
binary images in your data that you want to use as labels. Use Link if 
the text should be interpreted as a web link. Use Image from URL if 
the image is picked from a web resource location. You may need to 
change the Link or Image from URL Renderer Settings by clicking on 
the Settings... button and modifying the link syntax so that it fits your 
current data. Once the URL to the image has been correctly specified 
you can see images in the labels. 

 
Use Geometry if your data is a shape file and you want to show the 
geometrical shapes in the labels. 
If a TIBCO Spotfire Lead Discovery structure column is used to label 
by, then you would select a renderer for displaying structure images 
here. 

   Settings... If the selected Show as method has some settings available that can be 
modified, you can reach them by clicking on the Settings button. For 
example, this could be Link Renderer Settings or Image from URL 
Renderer Settings for a web link, Geometry Renderer Settings or some 
structure renderer settings. 

   Size Available if the selected label output is some kind of image. Increases 
or decreases the size of the labels. 
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4.8.3.13 Scatter Plot Properties - Tooltip 

 

Option Description 

Display the 
following values 

Specifies what will be shown in the tooltip. 

Add... Opens the Add Tooltip Value dialog, where you can add the content 
from another column, hierarchy, or any custom expression to be 
shown in the tooltip. You can also use images in tooltips. See 
Highlighting in Visualizations for more information. 

Edit... Opens the Edit Tooltip Value dialog, where you can change the 
information to be shown in the tooltip. 

Delete Deletes the selected value from the list. 

Move Up Moves the selected value up in the list and, hence, up in the tooltip. 

Move Down Moves the selected value down in the list and, hence, down in the 
tooltip. 

Tooltip format   

   Value names and 
values 

Shows the tooltip content in a format where the selected column name, 
hierarchy or custom expression is displayed. For example, Year: 2003, 
Type: Cucumber, etc. 

   Visualization 
properties and 
values 

Shows the tooltip content in a format where the visualization property 
for each value is displayed. For example, X: 2003, Color: Cucumber, 
etc. 
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4.8.3.14 Scatter Plot Properties - Legend 

 

Option Description 

Show legend Specifies whether or not the docked legend should be shown in the 
visualization. 

Position Specifies which side of the visualization the legend should be 
positioned: the right-hand side or the left-hand side. 

Display the 
following legend 
items 

Specifies what will be shown in the legend.  
By clearing a check box you will completely hide that item from the 
legend. You can also select to show or hide parts of the legend 
information using the check boxes under Settings for the selected item 
in the list, see below. 

Settings Defines how the selected legend item should be displayed. The 
available options vary between legend items. 

   Show title Use this option to show or hide the title for the selected item. The title 
is typically what is displayed above an axis selector or similar: 

 

   Show axis 
selector 

Select this option to show or hide the axis selector for the selected item.  
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4.8.3.15 Scatter Plot Properties - Trellis 

 

Option Description 

Rows and columns Splits the visualization into different panels for all categories 
in the selected column or hierarchy. The number of values in 
the specified column or hierarchy controls the number of 
panels to be displayed in each row, column, or page, 
respectively. 

   Rows A row with trellis panels will be created for each value in the 
selected column or hierarchy. 

   Columns A column with trellis panels will be created for each value in 
the selected column or hierarchy. 

   Pages A new page with trellis panels will be created for each value in 
the selected column or hierarchy. Scroll down in the 
visualization to see the next page. 

Panels Splits the visualization into different panels for all categories 
in the selected column or hierarchy, without binding any 
dimensions to either rows or columns. This means that the 
number of actual values in the column to split by does not 
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control the number of shown rows or columns in any way. 
The number of panels that should be visible on each page is 
instead specified using the Max number of rows and Max 
number of columns controls below. 

   Split by Specifies the column or hierarchy to define the categories by 
which the visualization should be split. 

   Manual layout Select the check box to manually specify the number of rows 
and columns that should be visible without scrolling. If the 
check box is cleared, the application will automatically specify 
the number of rows and columns. 

   Max number of rows Specifies the maximum number of panels that should be 
visible on each page. 

   Max number of columns Specifies the maximum number of panels that should be 
visible on each page. 

Settings... Opens the Advanced Settings dialog where you can change the 
category mode to determine which combinations to show. 

4.8.3.16 Scatter Plot Properties - Line Connection 

 

Option Description 

Draw a separate 
line per value in 

Specifies the column or hierarchy containing the categories to use for 
line connection. Markers of the same category will be connected with 
each other to form a separate line. If no column or hierarchy is 
specified here, all markers will be connected with each other. 
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Order each line by Specifies the order in which markers are connected. If no column or 
hierarchy is specified here, the markers will be ordered by row index 
(the order of the rows in the original data table). 

Color Specifies how colors will be assigned to the lines. 

   Same as marker Choose this option if you want the lines to have the same color as the 
markers they are a connection between. If a line connects markers with 
different colors, the color of the line will be a fusion of the two colors. 
For example, when a blue marker is connected with a yellow marker 
the line between them will be green. 

   Custom Choose this option if you want to use a single custom color for the 
lines. Click on the drop-down list to show the color selector where you 
can choose a different color. 

Width Specifies the width of the lines. 

Place in Select whether the lines should be placed in the foreground or 
background of the markers they are connecting. 

Show arrows to 
indicate order 

Specifies whether or not there should be arrows along the lines to 
indicate the order. 

4.8.3.17 Scatter Plot Properties - Marker By 

 

Option Description 

Show one 
marker for each 

If you select (Row Number) here, then each row in the data table will be 
displayed as a separate marker in the visualization, even if several 
markers have identical values for the X-axis and Y-axis, and therefore are 
located at the exact same coordinates. These markers will be drawn on 
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top of each other. 
You can, however, select to combine markers (known as aggregation) so 
that each marker shows for example the sum of all rows that have 
something in common. 
For example, if you have Continent on the X-axis and Sales on the Y-
axis, then each individual sales number for each continent would be 
displayed as a marker (below). 

 
However, if you set Marker by = Year, then the sum of sales for each 
year will be displayed as a marker for each continent. 

 

Currently also 
split by the 
following 
properties 

Displays information about what other properties currently contribute to a 
splitting of the markers. 
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4.8.3.18 Scatter Plot Properties - Lines & Curves 

 

First part of the dialog 

Option Description 

Visible lines and 
curves 

Lists the currently added lines and curves. If a check mark is shown in 
the check box, then the line or curve is shown in the visualization. 
Clear the check box to hide a line or curve. 
New lines or curves can be added to this list by clicking on the Add 
button; see below. 

Add Displays a menu where you can select which type of line or curve to 
add to the list of available lines and curves, and in some cases, opens a 
dialog where you can specify settings to use for that line or curve. 
For more information about the different curve types, see Curve Fit 
Models. 

Edit... Opens a dialog where you can change the settings for the selected line 
or curve (when applicable). 

Remove Removes the selected line or curve from the list of available lines and 
curves. 

More   

   Duplicate Duplicates the currently selected line or curve. This can be particularly 
useful if you want to add one static curve that is calculated on the 
whole data set (select the Update curve manually check box) and 



TIBCO Spotfire 4.0.2 - User's Manual 

406 

another one that is changed upon filtering (default). 

   Export Curve Fit 
Result... 

Opens a dialog where you can choose to export the curve fit result for 
the selected curve to a text file or to Microsoft® Excel®. The text file 
can be either a regular tab separated text file, or a Spotfire Text Data 
Format file, which contains a bit more information about the columns 
(types, etc.). The Excel file can be either an XLS file or an XLSX file. 

Settings 

Option Description 

Appearance Determines the color, style and width of lines and curves, and the 
color, style and size of points. 

Place in Select whether to place the line, curve or point in the Foreground or 
Background of the visualization. 

Transparency Determines the transparency of the selected line, curve or point. That 
is, the degree to which the markers can be seen through it. The 
transparency is strongly connected to the color. 

Label and Tooltip Opens a dialog where you can determine what information to show in 
the label and/or tooltip for the selected line, curve or point. 

Included in axis 
range 

Sets the automatic zooming so that the line, curve or point is always 
shown, even if it lies far from the currently filtered values. 

Update manually Select the check box to "freeze" the line or curve so that it is not 
automatically recalculated upon filtering. You can update the line or 
curve by clicking the Update button below or by right-clicking in the 
visualization and selecting Update Lines and Curves and clicking on 
the one you want to update. 
Note: Not applicable for points. 

Update When a line or curve has been specified to be manually updated, use 
this button to perform the update. 

One per Determines whether to show one line or curve per Color, Trellis panel, 
and/or Shape. 
Note: Not applicable for points. 
Note that you should apply true categorical coloring before using the 
color option. If you use a continuous column on the color axis, you 
may end up with a different result than the expected. This applies even 
if the continuous color mode looks "categorical" at first sight. 



Visualizations 

407 

4.8.3.19 Scatter Plot Properties - Error Bars 

 

Option Description 

Visible error bars Lists the numerical columns and measures that you can define error 
bars for in the visualization. If a check mark is shown in the check box, 
then error bars for that column or measure are visible in the 
visualization. Clear the check box to hide the error bars for a column or 
measure. 
Note: No error bars will be visible in the visualization until an upper or 
lower error has been defined. 

Settings Shows the settings for the selected column or measure. 
Note: If you use multiple Y-axes in the scatter plot you can define 
different error bars for the axes. However, all the defined vertical error 
bars will share the same settings for Color, Show end caps, and Include 
error bars in axis range. For example, you cannot set one vertical error 
bar to be blue, and another vertical error bar to be yellow in the same 
scatter plot. This also applies to using multiple measures on a Y-axis 
with a single scale. 

   Upper error Specifies the column and aggregation method, or custom expression to 
use for the upper error bars in the visualization. 
Note: The chosen column or measure must have numerical values. 
Note: For horizontal error bars in a scatter plot with non-reversed 
scales, the upper error refers to the error bar on the right hand side of 
the marker. 

   Lower error Specifies the column and aggregation method, or custom expression to 
use for the lower error bars in the visualization. 
Note: The chosen column or measure must have numerical values. 
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Note: For horizontal error bars in a scatter plot with non-reversed 
scales, the lower error refers to the error bar on the left-hand side of the 
marker. 

   Color   

      Same as 
marker 

Choose this option if you want an error bar to have the same color as 
the marker. 

      Custom Choose this option if you want to use a custom color for the error bars. 
Click on the drop-down list to show the palette and select a different 
color. 

   Show end caps Specifies whether or not orthogonal lines should be displayed at the 
end of the error bars. 

   Include error 
bars in axis range 

Sets the automatic zooming so that the error bars are always visible. 

Note: The upper and lower errors refer to the underlying data. This means that if you use 
reversed scales in a visualization, the error bars will also be reversed. For example, for a scatter 
plot with reversed Y-axis, the upper error bar will be displayed below the marker. With reversed 
X-axis in the scatter plot, the upper error will be displayed on the left-hand side. 
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4.9 3D Scatter Plot 
4.9.1 What is a 3D Scatter Plot? 

3D scatter plots are used to plot data points on three axes in the attempt to show the relationship 
between three variables. Each row in the data table is represented by a marker whose position 
depends on its values in the columns set on the X, Y, and Z axes. 
A fourth variable can be set to correspond to the color or size of the markers, thus adding yet 
another dimension to the plot. 
The relationship between different variables is called correlation. If the markers are close to 
making a straight line in any direction in the three-dimensional space of the 3D scatter plot, the 
correlation between the corresponding variables is high. If the markers are equally distributed in 
the 3D scatter plot, the correlation is low, or zero. However, even though a correlation may 
seem to be present, this might not always be the case. The variables could be related to some 
fourth variable, thus explaining their variation, or pure coincidence might cause an apparent 
correlation. 
You can change how the 3D scatter plot is viewed by zooming in and out as well as rotating it 
by using the navigation controls located in the top right part of the visualization. 
Note: The 3D scatter plot is not supported in TIBCO Spotfire Web Player. It is still possible to 
open an analysis with a 3D scatter plot in the web player, but the 3D scatter plot will not be 
shown. 

Example: 
In the 3D scatter plot below, sales, cost, and year are plotted against each other for a number of 
different products (colored by product). 

 
Each category can be shown separately using trellising. In the example below, the markers are 
colored by product, and trellised by category: 
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The 3D scatter plot can also be used together with aggregation (for example, Sum or Average) 
by using the setting Marker By. In this case, the values for a certain category are bundled 
together to display a single marker for each category as seen in the example below. The 
aggregated markers can also be sized by the count of items within each category, or by any 
other column. 

Example: 

 
Labels can be used in visualizations to identify and describe markers and the data associated 
with them. 
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Example: 
In the 3D scatter plot below, labels show which category each of the marked markers belongs 
to. 

 
All visualizations except the map chart can be set up to show data limited by one or more 
markings in other visualizations only (details visualizations). They can also be limited by one or 
more filterings. Another alternative is to set up a visualization without any filtering at all. See 
Limiting What is Shown in Visualizations for more information. 

4.9.2 How to Use the 3D Scatter Plot 
► To apply coloring: 

1. In the Filters panel, click and hold down the left mouse button on the filter 
representing the column that you want to color by. 
Comment: Coloring is also available in the Visualization Properties dialog. The color 
of marked items is changed under Edit > Document Properties. 

2. Drag the filter to the center of the visualization. 
Response: Drop targets appear in the middle of the visualization. 

3. Release the mouse button on the Color target. 
Response: The markers are colored with one color for each category in the selected 
column. 
Comment: To learn more about coloring in Spotfire, see Coloring Overview. 
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► To shape markers by a column: 
1. In the filters panel, click and hold down the left mouse button on the filter representing 

the column that you want to shape by. 
Comment: Shape is also available in the Properties dialog. 

2. Drag the filter to the center of the visualization. 
Response: Drop targets appear in the middle of the visualization. 

3. Release the mouse button on the Shape by target. 
Response: The markers are shaped with one shape for each category in the selected 
column. 
Comment: In the Shape page of the Properties dialog you can change the shape you 
want to use for each category. 

► To aggregate markers: 
1. Right-click in the 3D scatter plot to display the pop-up menu. 
2. Select Properties. 
3. Click to display the Marker By page. 
4. Select a column to group the markers by under Show one marker for each. 

Response: The markers are grouped so that a single marker is shown for each category 
in the selected column. 
Comment: If the Legend is visible, the Marker By property may also be changed there. 

► To create a new 3D scatter plot: 
1. Click on the New 3D Scatter Plot button on the toolbar, . 

Comment: You can also select Insert > New Visualization > 3D Scatter Plot from 
the menu. 
Response: A first attempt to set up a suitable 3D scatter plot is made by the 
application. 

2. Adjust the 3D scatter plot to display the measures of your choice. 
Comment: For more information about how to change what to show on the three axes, 
see Column Selectors. 

Zooming and navigating in the 3D scatter plot: 
Located at the top right of the visualization are a number of buttons that you can use to zoom 
and navigate in the visualization. 

Button Shortcut Description 

 

Press and hold the Shift key and the right 
mouse button simultaneously while moving 
the mouse up. 

Zoom in. 

 

Press and hold the Shift key and the right 
mouse button simultaneously while moving 
the mouse down. 

Zoom out. 

 

Press and hold the Ctrl key and the right 
mouse button simultaneously while moving 
the mouse to the right. 

Rotate right. 

 

Press and hold the Ctrl key and the right 
mouse button simultaneously while moving 
the mouse to the left. 

Rotate left. 
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Press and hold the Ctrl key and the right 
mouse button simultaneously while moving 
the mouse up. 

Rotate up. 

 

Press and hold the Ctrl key and the right 
mouse button simultaneously while moving 
the mouse down. 

Rotate down. 

 

  Reset navigation. 

You can also use the mouse wheel to zoom in or out. To reset zoom and navigation to the 
default values, click on the Reset Navigation button, or right-click in the visualization and select 
Reset Navigation. 

Resizing markers in the 3D scatter plot: 
You can use keyboard shortcuts to resize markers in the 3D scatter plot: 

Shortcut Description 

Press and hold down the Ctrl key and the plus (+) key 
simultaneously until the markers have the desired size. 

Increase size of markers. 

Press and release the plus key repeatedly while pressing 
the Ctrl key. 

Increase size of markers. 

Press and hold the Ctrl key and the minus (-) key 
simultaneously. 

Decrease size of markers. 

Press and release the minus key repeatedly while 
pressing the Ctrl key. 

Decrease size of markers. 

Press and hold down the Ctrl key while rotating the 
mouse wheel. 

Resize markers. 

Yet another way to resize the markers is to open the Size page of the Properties dialog and use 
the slider control. 

4.9.3 3D Scatter Plot Properties 

4.9.3.1 3D Scatter Plot Properties 
The 3D Scatter Plot Properties dialog consists of several pages: 

• General 
• Data 
• Appearance 
• Formatting 
• Fonts 
• X-axis 
• Y-axis 
• Z-axis 
• Colors 
• Size 
• Shape 
• Labels 
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• Tooltip 
• Legend 
• Trellis 
• Marker By 

► To reach the 3D Scatter Plot Properties dialog: 
1. Right-click on the 3D scatter plot visualization. 
2. Select Properties from the pop-up menu. 

Comment: You can also click on the 3D scatter plot visualization to make it active and 
then select Edit > Visualization Properties. 

4.9.3.2 3D Scatter Plot Properties - General 

 

Option Description 

Title The title of the visualization. 
Tip: Double-click on the title bar of the visualization for a shortcut to 
this field. 

Show title bar Specifies whether or not to show the visualization title. 

Description A description of the visualization. This description can optionally be 
shown in the legend and/or in the visualization. 

Show description 
in visualization 

Specifies whether or not to show the description in the visualization. 

Note: You can open an analysis containing a 3D scatter plot in the web player, but you will be 
informed that the visualization cannot be shown in the web player. 
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4.9.3.3 3D Scatter Plot Properties - Data 

 

Option Description 

Data table Specifies the data table on which the visualization will work. 

Marking Specifies the marking (that is, the color and relationships to other 
marked items) that will be used to mark items in this visualization. 

Limit data using 
markings 

Lists the available markings that can be used to limit what is shown in 
this visualization. This means that the visualization only displays data 
that has been marked in other visualizations. 
If more than one marking is selected, you can choose how the data in 
the markings should be combined. 

New... Opens the New Marking dialog where you can specify a new marking. 
The color and name of a previously created marking is edited in the 
Document Properties dialog. 

Rows must be 
included in 

Specifies how the data in the markings should be combined if you have 
selected to limit the data by more than one marking. 

   All markings 
(AND) 
   

Use this option if you want this visualization to show the intersection of 
the markings selected in Limit data using markings. This can be used if 
you have two visualizations with different markings and want to see 
which markers are present in both markings. This visualization will 
then show only the data that has been marked using both of the selected 
markings. 

   Any marking 
(OR) 
    

Use this option if you want this visualization to show the union of the 
markings selected in Limit data using markings.  
This can be used if you have two visualizations with different markings 
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and want to see which markers are present in either of the two 
markings. This visualization will then show data that has been marked 
using either of the selected markings. 

Limit data using 
filterings 

Defines how different filtering schemes in the analysis should affect 
this visualization. 
Select Use the current filtering from the page if you want the 
visualization to always utilize the filtering scheme that is used on the 
page where the visualization is located. If you move the visualization to 
a new page, then the visualization will automatically start reacting on 
the filtering scheme that is used on the new page.  
Select a specific filtering scheme from the list if you want the 
visualization to always use that filtering scheme. Moving the 
visualization to another page with a different filtering scheme will not 
affect this setting. 
If you select to limit data using more than one filtering scheme, the 
intersection of the filterings will be used. This means that the 
visualization will show only the data that is made visible by all of the 
filtering schemes. 

New... Opens the New Filtering Scheme dialog where you can specify a new 
filtering scheme. 
The color and name of a previously created filtering scheme is edited in 
the Document Properties dialog. 

Limit data using 
expression 

You can limit what data should be available for a certain visualization 
using an expression. If you have defined a limiting expression, it will be 
displayed here. 

Edit... Opens the Limit Data Using Expression dialog where you can define a 
boolean expression to use for limiting the data in this visualization. 
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4.9.3.4 3D Scatter Plot Properties - Appearance 

 

Option Description 

Show navigation 
controls 

Specifies whether or not to show the navigation controls in the 
visualization. 

Jittering Jittering is an option that displaces the visualization items randomly in 
the display window, thereby making overlapping markers visible. 

   X Specifies the amount of jittering to use in the X direction. 

   Y Specifies the amount of jittering to use in the Y direction. 

   Z Specifies the amount of jittering to use in the Z direction. 

   Use the same 
amount of jittering 
for X, Y and Z 

Select this check box to connect the jittering sliders in both directions 
to each other. 
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4.9.3.5 3D Scatter Plot Properties - Formatting 

 

Option Description 

Axes Displays which column and category are currently being used on each 
of the three axes in the 3D scatter plot. Click on the one you want to 
change the settings for. If the columns on the axes are of the same type, 
you can set formatting for two or all of the axes at the same time. 

Reset Resets the formatting for the selected axis values according to the 
settings defined on column level. If no column formatting has been set, 
axis formatting settings defined in the Options dialog will be used. If 
no settings have been specified in the Options dialog, the default 
settings for the visualization type will be used. 

Category Lists the available formatting categories for the selected axis. Each 
category in this list has separate settings. Which categories are 
available depends on the data type of the selected axis. See Formatting 
Settings for a full description of all possible options. 

Note: These settings affect only the current visualization. For general information about 
formatting, see Formatting Overview. 
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4.9.3.6 3D Scatter Plot Properties - Fonts 

 

Option Description 

Settings for Lists all items for which you can change the font settings. Click to 
select an item in the list to change the font settings for that text in the 
visualization. Press Ctrl and click on more items to change the settings 
for multiple items simultaneously. 

Font Specifies the font to use for the selected items. 

Font style Specifies the font style to use for the selected items. 

Size Specifies the font size to use for the selected items. 
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4.9.3.7 3D Scatter Plot Properties - X-axis 

 

Option Description 

Columns Specifies the column or hierarchy to be displayed on the X-axis. 

Settings... Opens the Advanced Settings dialog, where you can change the scale 
mode from categorical to continuous and vice versa, as well as 
changing the category mode to determine which combinations to 
show. 

Range   

   Min Determines the lower value of the axis range. Leave the field blank to 
automatically adjust the range to the currently lowest value in the 
filtered data. 

   Max Determines the upper value of the axis range. Leave the field blank to 
automatically adjust the range to the currently highest value in the 
filtered data. 

   Set to Current 
Range 

Allows you to set the axis range to the currently filtered values. 

   Include origin Available for continuous axes only. Always includes the coordinates 
(0, 0) in the visualization, regardless of filtering. 

   Show zoom slider Shows a zoom slider that you can manually manipulate to view only 
the interesting markers in the 3D scatter plot. 

   Show gridlines Specifies whether or not gridlines should be visible on the X-axis. 
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Scale labels   

   Show labels Specifies whether or not scale labels should be visible. 

      Horizontally Specifies that scale labels are shown horizontally. 
Note: In the 3D scatter plot you cannot change this setting. 

      Vertically This alternative is inactive, since it is not possible to change this 
setting in the 3D scatter plot. 

Scale   

   Log scale Changes the scale from a linear scale to a logarithmic base 10 scale 
[log10 (x)]. 

   Reverse scale Reverses the current sort order, so that the lowest value is displayed at 
the top of the scale. 

  

4.9.3.8 3D Scatter Plot Properties - Y-axis 

 

Option Description 

Columns Specifies the column or hierarchy to be displayed on the Y-axis. 

Settings... Opens the Advanced Settings dialog where you can change the scale 
mode from categorical to continuous and vice versa, as well as 
changing the category mode to determine which combinations to 
show. 
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Range   

   Min Determines the lower value of the axis range. Leave the field blank to 
automatically adjust the range to the currently lowest value in the 
filtered data. 

   Max Determines the upper value of the axis range. Leave the field blank to 
automatically adjust the range to the currently highest value in the 
filtered data. 

   Set to Current 
Range 

Allows you to set the axis range to the currently filtered values. 

   Include origin Available for continuous columns only. Always includes the 
coordinates (0, 0) in the visualization, regardless of filtering. 

   Show zoom slider Shows a zoom slider that you can manually manipulate to view only 
the interesting segments of the 3D scatter plot. 

   Show gridlines Specifies whether or not gridlines should be visible on the Y-axis. 

Scale labels   

   Show labels Specifies whether or not scale labels should be visible. 

      Horizontally Specifies that scale labels are shown horizontally. 
Note: In the 3D scatter plot you cannot change this setting. 

      Vertically This alternative is inactive, since it is not possible to change this 
setting in the 3D scatter plot. 

Scale   

   Log scale Changes the scale from a linear scale to a logarithmic base 10 scale 
[log10 (x)]. 

   Reverse scale Reverses the current sort order so that the lowest value is displayed at 
the top of the scale. 
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4.9.3.9 3D Scatter Plot Properties - Z-axis 

 

Option Description 

Columns Specifies the column or hierarchy to be displayed on the Z-axis. 

Settings... Opens the Advanced Settings dialog where you can change the scale 
mode from categorical to continuous and vice versa, as well as 
changing the category mode to determine which combinations to 
show. 

Range   

   Min Determines the lower value of the axis range. Leave the field blank to 
automatically adjust the range to the currently lowest value in the 
filtered data. 

   Max Determines the upper value of the axis range. Leave the field blank to 
automatically adjust the range to the currently highest value in the 
filtered data. 

   Set to Current 
Range 

Allows you to set the axis range to the currently filtered values. 

   Include origin Available for continuous columns only. Always includes the 
coordinates (0, 0) in the visualization, regardless of filtering. 

   Show zoom slider Shows a zoom slider that you can manually manipulate to view only 
the interesting segments of the 3D scatter plot. 

   Show gridlines Specifies whether or not horizontal gridlines should be visible. 
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Scale labels   

   Show labels Specifies whether or not scale labels should be visible. 

      Horizontally Specifies that scale labels are shown horizontally. 
Note: In the 3D scatter plot you cannot change this setting. 

      Vertically This alternative is inactive, since it is not possible to change this 
setting in the 3D scatter plot. 

Scale   

   Log scale Changes the scale from a linear scale to a logarithmic base 10 scale 
[log10 (x)]. 

   Reverse scale Reverses the current sort order so that the lowest value is displayed at 
the top of the scale. 

4.9.3.10 3D Scatter Plot Properties - Colors 

 

Option Description 

Columns Specifies the column or hierarchy to color by. 

Settings Opens the Advanced Settings dialog where you can change the scale 
mode for the selected column or hierarchy from continuous to 
categorical and vice versa, as well as changing the category mode to 
determine which combinations to show. 

Color mode Specifies in which color mode to set up the color scheme. Which 
modes are available depends on whether the scale is in categorical or 
continuous mode. For columns in continuous scale mode, you can 
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select one of the following color modes: Gradient, Segments, or Fixed. 
For columns in categorical scale mode, you can select either 
Categorical or Fixed color mode. To learn more about the color 
modes, see Color Modes Overview. 

One scale per Specifies whether there should be one separate scale per trellis panel 
for trellised 3D scatter plots, or if one scale should apply to the entire 
visualization. Only applicable to columns in continuous scale mode. 

 
[Color Schemes 
menu] 

Opens a menu where you can select an already existing color scheme 
and apply it to the visualization, or apply the currently open color 
scheme to another visualization in the analysis. 

   From 
Visualization 

Lets you select a color scheme from another visualization in the 
analysis. Only color schemes that are applicable to the current color 
scheme will be listed. 

   Document Color 
Schemes 

Lets you select a color scheme that has previously been saved within 
the analysis. Only color schemes that are applicable to the current 
color scheme will be listed. This menu option is only available if one 
or more document color schemes already exist. 

   [Predefined color 
schemes] 

Lists a number of predefined color schemes. Available for columns in 
continuous scale mode only. For a full description of the predefined 
color schemes, see Predefined Color Schemes. 
Tip: To facilitate setting up a new color scheme, you can open a 
predefined color scheme with a similar appearance, and then adjust it 
to suit your needs. 

   Open from 
Library... 

Opens the Open from Library dialog where you can select a color 
scheme that has previously been saved to the library. 

   Open from File... Opens a dialog where you can select a previously saved color scheme. 

   Save As Lets you save a color scheme as a library item, a local file or a 
document color scheme. 
Library Item – Opens the Save as Library Item dialog, where you can 
specify a location in the library and a file name to save the currently 
open color scheme for later reuse. 
File – Opens a dialog where you can specify a location and a file name 
to save your currently open color scheme locally on your computer for 
later reuse. 
Document Color Scheme – Opens the Save as Document Color 
Scheme dialog, where you can specify a name and save the currently 
open color scheme for later reuse within the analysis. 

   Apply to 
Visualizations... 

Opens the Apply to Visualizations dialog where you can select other 
visualizations (within the analysis) that you want to apply the current 
color scheme to. Only visualizations with compatible color schemes 
are listed. 
Note: If you apply a color scheme to a table, cross table, or heat map, 
the coloring will not take effect immediately. The color scheme will be 
added as an empty color scheme grouping, and you must select which 
columns or axis values to include in the grouping by opening the Edit 
Color Scheme Grouping dialog. 
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[Color scheme area] The area in the lower part of the dialog shows the current color 
scheme. That is, the colors and values currently used in the 
visualization. You can modify color schemes in numerous ways to 
give the visualization the appearance you prefer. The color scheme 
area will look different, and have different available settings, 
depending on the characteristics of the column used to color the 
visualization by, as well as the selected color mode. To learn more 
about color schemes and color modes, see Color Schemes Overview 
and Color Modes Overview respectively. 

Add Point Available for continuous columns only. Adds a new anchor point to 
the color scheme. 

Delete Point Available for continuous columns only. Deletes the selected anchor 
point. 

Add Rule... Opens the Add Rule dialog where you can define a rule that functions 
as an exception to the rest of the defined color scheme. A rule has 
higher priority than the rest of the color scheme. For example, you can 
define a rule to give the top five items in your data a different color 
than the rest of the items. If you add many rules to a color scheme, the 
rules are prioritized from top to bottom. Which rule types are available 
depends on the characteristics of the column or hierarchy used to color 
the visualization by. See Details on Add/Edit Rule for full descriptions 
of the rule types. 

Reset Resets the color scheme to the one that was in effect when the 
visualization was created. Any added rules will be removed. Which 
color scheme should be used by default when you create a new 
visualization is defined in the Visualization page of the Options 
dialog. 
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4.9.3.11 3D Scatter Plot Properties - Size 

 

Option Description 

Marker size Increases or decreases the overall size of all markers. 

Size by Specifies a column or hierarchy whose categories will determine the 
size of the markers. 
The aggregation options on the drop-down menu are only available if 
the markers in the 3D scatter plot have been aggregated by setting the 
Marker By option to something other than (Row Number). 

Scale Determines what scale to use for the size of the markers. 

From min to max Assigns the maximum marker size to the highest value and the 
minimum marker size to the lowest value. For instance, if the 
minimum and maximum data values are -9 and 11 the marker sizes 
might look as follows: 

 
This mode is useful when you want to visualize differences. 

  Min limit: 
  Max limit: 

The minimum and maximum limits that should be mapped to the 
marker size. By default, they are set to "Automatic". This means that 
the marker size will adapt during filtering. If the scale is set to "From 
min to max", the current minimum value will have the minimum 
marker size, and the current maximum value will have the maximum 
marker size. It is comparable to automatic zooming on the axes. 
It is possible to lock the max limit and/or min limit to a specific value 
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by selecting "Value" in the drop-down list and entering a value. Data 
values that are lower than the minimum value or higher than the 
maximum value will get the same size as the minimum and maximum 
value respectively. By specifying both a high and low value, the auto-
scaling behavior is turned off. 

From 0 to max 
absolute value 

This mode is useful when you want to compare the magnitude of 
measures. By letting the value 0 map to marker size 0, and the 
maximum value to the maximum marker size, it is possible to compare 
the diameter of markers and say "a" is twice as big as "b". With this 
scale the values 50 and 100 would be rendered like this: 

 
Note: The size is scaled symmetrically around 0 with absolute 
numbers. That is, if your highest value is 10 and your lowest is -20, the 
size of the marker at 10 will be 50 percent of the maximum marker 
size. 

  Max: The absolute limit that should be mapped to the marker size. By default 
it is set to "Automatic". This means that the marker size will adapt 
during filtering. The value 0 will have the minimum marker size and 
the highest absolute value in the visualization will have the maximum 
marker size. 
It is possible to lock this to a specific value by selecting "Value" in the 
drop-down list and entering a value. Data values that have a larger 
absolute value than the set value will get the same size as the 
maximum value. 
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4.9.3.12 3D Scatter Plot Properties - Shape 

 

Option Description 

Fixed Select this option to use the same, fixed shape on all markers. The 
shape is selected from the drop-down list. 

By column Select this option to use different shapes for the categories in a 
specified column or hierarchy. When there are more categories 
than available shapes, shapes will be recycled. Select which 
column to shape the markers by in the drop-down list. 

     Settings... Opens the Advanced Settings dialog where you can change the 
category mode to determine which combinations to show. 

     Shape scheme Click on a shape to change it to a different one. 
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4.9.3.13 3D Scatter Plot Properties - Labels 

 

Option Description 

Label by Specifies the column or hierarchy whose values you want presented as 
labels in the visualization. 

Show labels for Determines whether to show labels on all markers (All), marked 
markers only (Marked rows), or not to show any labels at all (None). 

Max number of 
labels 

Specifies the maximum number of labels to be shown. If the number is 
smaller than the available number of markers, the labels will be equally 
distributed. 
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4.9.3.14 3D Scatter Plot Properties - Tooltip 

 

Option Description 

Display the 
following values 

Specifies what will be shown in the tooltip. 

Add... Opens the Add Tooltip Value dialog, where you can add the content 
from another column, hierarchy, or any custom expression to be 
shown in the tooltip. You can also use images in tooltips. See 
Highlighting in Visualizations for more information. 

Edit... Opens the Edit Tooltip Value dialog, where you can change the 
information to be shown in the tooltip. 

Delete Deletes the selected value from the list. 

Move Up Moves the selected value up in the list and up in the tooltip. 

Move Down Moves the selected value down in the list and down in the tooltip. 

Tooltip format   

   Value names and 
values 

Shows the tooltip content in a format where the selected column name, 
hierarchy or custom expression is displayed. For example, Year: 2003, 
Type: Cucumber, etc. 

   Visualization 
properties and 
values 

Shows the tooltip content in a format where the visualization property 
for each value is displayed. For example, X: 2003, Color: Cucumber, 
etc. 
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4.9.3.15 3D Scatter Plot Properties - Legend 

. 

Option Description 

Show legend Specifies whether or not the docked legend should be shown in the 
visualization. 

Position Specifies which side of the visualization the legend should be 
positioned: the right-hand side or the left-hand side. 

Display the 
following legend 
items 

Specifies what will be shown in the legend.  
By clearing a check box you will completely hide that item from the 
legend. You can also select to show or hide parts of the legend 
information using the check boxes under Settings for the selected item 
in the list, see below. 

Settings Defines how the selected legend item should be displayed. The 
available options vary between legend items. 

   Show title Use this option to show or hide the title for the selected item. The title 
is typically what is displayed above an axis selector or similar: 

 

   Show axis 
selector 

Select this option to show or hide the axis selector for the selected item.  
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4.9.3.16 3D Scatter Plot Properties - Trellis 

 

Option Description 

Rows and columns Splits the visualization into different panels for all categories in the 
selected column or hierarchy. The number of values in the 
specified column or hierarchy controls the number of panels to be 
displayed in each row, column, or page, respectively. 

   Rows A row with trellis panels will be created for each value in the 
selected column or hierarchy. 

   Columns A column with trellis panels will be created for each value in the 
selected column or hierarchy. 

   Pages A new page with trellis panels will be created for each value in the 
selected column or hierarchy. Scroll down in the visualization to 
see the next page. 

Panels Splits the visualization into different panels for all categories in the 
selected column or hierarchy without binding any dimensions to 
either rows or columns. This means that the number of actual 
values in the column to split by does not control the number of 
shown rows or columns in any way. 
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The number of panels that should be visible on each page is instead 
specified using the Max number of rows and Max number of 
columns controls below. 

   Split by Specifies the column or hierarchy to define the categories by which 
the visualization should be split. 

   Manual layout Select the check box to manually specify the number of rows and 
columns that should be visible without scrolling. If the check box is 
cleared, the application will automatically specify the number of 
rows and columns. 

   Max number of 
rows 

Specifies the maximum number of panels that should be visible on 
each page. 

   Max number of 
columns 

Specifies the maximum number of panels that should be visible on 
each page. 

Settings... Opens the Advanced Settings dialog where you can change the 
category mode to determine which combinations to show. 

4.9.3.17 3D Scatter Plot Properties - Marker By 

 

Option Description 

Show one 
marker for 
each 

If you select (Row Number) here, then each row in the data table will be 
displayed as a separate marker in the visualization even if several markers 
have identical values for the X-axis, Y-axis, and Z-axis and are located at 
the exact same coordinates. These markers will be drawn on top of each 
other. 
You can, however, select to combine markers (known as aggregating) so 
that each marker shows the sum of all rows that have something in 
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common. 
For example, if you have Continent on the X-axis, Year on the Y-axis and 
Sales on the Z-axis, then each individual sales number for each continent, 
and each individual year would be displayed as a marker (below). 

 
However, if you set Marker By = Year, then the sum of sales for each year 
will be displayed as a marker for each continent. 

 

Currently also 
split by the 
following 
properties 

Displays information about what other properties currently contribute to a 
splitting of the markers. 
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4.10 Map Chart 
4.10.1 What is a Map Chart? 

There are three kinds of map charts in TIBCO Spotfire: maps with interactive shapes, maps 
with markers or pies, and image backgrounds with markers or pies. 
Below is an example of a map chart with interactive shapes, where each shape represents a state 
in the United States. Each shape in the map is a separate item, and you can interact with those 
items the same way you do with items in any other visualization. 

 
The interactive shapes can be one of three geometry types: polygons, lines, or points. When 
polygons are used, as in the example above, the shapes constitute different areas in the map, and 
these areas will be filled with color. How to color the shapes is defined in the Colors page of the 
visualization properties, or in the legend. When lines or points are used, the interactive shapes 
are the actual lines or points. The color you define in the Colors page will be the color of the 
lines or points. Examples of when maps with lines as interactive shapes could be useful are 
maps showing highways or a street grid. Below is an example of a map chart with interactive 
shapes, where each shape represents a highway. 

 
Which geometry type is used in a map is defined in the map data before you load it into your 
analysis, and this cannot be changed in Spotfire. If the map data comes from an ESRI shape file, 
you can open the Properties tab of the Data Table Properties dialog to see which geometry type 
a map has if you are uncertain. 
In a map with markers or pies, the map areas are not interactive. Instead, markers or pies are 
positioned in the different areas. In the example below, the map shows the same geographical 
area as in the first example, and is also divided into states. But instead of the states being 
interactive, a marker is placed in each of the states, and you can interact with the markers just as 
you do with markers in other visualizations. 
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To set up a map with interactive shapes, or a map with markers or pies, you need a data table 
containing map data, such as from an ESRI shape file. You can use other types of sources than 
shape files, but that requires some manual configuration. To learn how to use a non-shape file, 
or to set up information links with map information, see Configuration of Geographical Data for 
Map Charts. 
If you want the shapes in a map with interactive shapes to be colored by a data table other than 
the map data table, the two data tables must contain columns that can be matched to each other; 
State or City, for example. When you have set up a relation between the two data tables using 
these columns, you can color the shapes by a column in the other data table. 
Similarly, if you want the markers in a map with markers or pies to be colored by another data 
table than the map data table, you must set up a relation between the two data tables. Or, if the 
data table for markers or pies has columns containing coordinates, you can use these to position 
the markers or pies in their correct locations on the map. 
A third way to set up a map chart is to use a background image and then position markers or 
pies on top of that image. This works similarly to the map with markers or pies, but with the 
difference that you do not need to have map data in a data table in order to set it up. However, 
for the markers to be placed correctly in geographical positions, the data table must contain X 
and Y coordinates. Below is an example of a map chart where the background is a map image 
of a part of North America. On top of the background image are markers pointing out cities in 
the United States. 

 
You can zoom and pan in a map using the navigation controls to the right of the map. Click on 
the small arrow icon on the map chart title bar (shown on mouse over) to show or hide the 
navigation controls. The example below shows the same map chart as in the first example, but it 
has been zoomed in to show only some of the states. To learn more, see Zooming and 
navigating in the map chart. 
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Labels can be used in the map chart to identify and describe markers or interactive shapes. In 
the example above, labels with the state names have been added to the map. Open the Labels 
page of the Map Chart Properties if you want to modify the labels settings. You can also move 
the labels to other positions in the map using drag and drop. To learn more about labels in 
different map types, see How to Use the Map Chart. 
A map chart can be used to show other than geographical data. The example below displays 
different types of failures on a wafer, a semi-conductor material used to manufacture 
microchips. 

 
The background is an image representing the wafer. The markers in the visualization represent 
the chips on the wafer, and are placed on the background the same way they are placed on the 
actual wafer. The colors and labels indicate the six different types of manufacturing failures that 
have occurred on this wafer. Copying the actual layout of the wafer is a way to enhance the 
readability of the data. To be able to view the data this way, you need to use tiled markers. This 
means that all the markers have the same size, and are displayed in a grid-like layout. Go to the 
Shape page in the Map Chart Properties to change to tiled markers. 
Note: If you use tiled markers, and the axes’ scales have a large number of values, then the 
markers may become too small to be seen. The reason for this is that the grid layout makes it 
necessary for each value on the scales to have a unique position, even if no marker is located at 
each of these allocated positions. Therefore, with a large number of values on the scale, the 
markers must become very small to fit in the grid. 
All visualizations except the map chart can be set up to show data limited by one or more 
markings in other visualizations only (details visualizations). They can also be limited by one or 
more filterings. Another alternative is to set up a visualization without any filtering at all. See 
Limiting What is Shown in Visualizations for more information. 
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4.10.2 How to Use the Map Chart 
► To create a new map chart: 

1. Click on the New Map Chart button on the toolbar, . 
Comment: You can also select Insert > New Visualization > Map Chart from the 
menu. 
Response: A visualization area is created for the map chart. 

2. Right-click in the visualization to display the pop-up menu and select Properties. 
Response: The Properties dialog is displayed. 

3. Go to the Data page to select map type and to set up the map chart. 
Comment: See the appropriate section below to learn how to set up the different map 
types. 

► To set up a map with interactive shapes: 
1. Create a map chart. 
2. Right-click in the visualization to display the pop-up menu and select Properties. 

Response: The Properties dialog is displayed. 
3. Go to the Data page. 
4. Select Map with interactive shapes from the Map type drop-down list. 
5. Select a data table containing map data. 

Comment: If a map data table has not already been added, click Add... to open the Add 
Data Table dialog where you can browse for a data table to use, such as an ESRI shape 
file. If you are not using a shape file, some manual configuration is needed. To learn 
how to do this, see Configuration of Geographical Data for Map Charts. 
Response: The map is displayed in the visualization area. 

6. Under Related data table for coloring, select a data table of interest. 
Comment: To be able to color by another data table than the map data table, the other 
data table must be related to the map data table. 

7. If a relation has already been defined, the colored map is now displayed in the 
visualization. If no relation is defined, or if you want to edit an existing relation, 
continue to step 8. 

8. Click the Manage Relations... button. 
Response: The Manage Relations dialog is opened. 

9. To create a new relation, click on the New... button to open the New Relation dialog. 
To edit an existing relation, click on the Edit... button to open the Edit Relation dialog. 

10. In the Left data table drop-down list, select the same data table that you selected under 
Related data table for coloring. 

11. In the Right data table drop-down list, select the map data table. 
12. In the Left column and the Right column drop-down lists, select columns that make up 

a valid relation between the two data tables. For instance, columns in both data tables 
describing the same regions, such as state or country names. 

13. Click OK. 
14. Click OK in the Manage Relations dialog. 

Response: The map is colored by a column in the related data table. To change which 
column to color the map by, go to the Colors page. 

15. Comment: To learn more about coloring in Spotfire, see Coloring Overview. 
16. To change the appearance of the map, go to the Appearance page. 
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► To set up a map with markers or pies: 
1. Create a map chart. 
2. Right-click in the visualization to display the pop-up menu and select Properties. 

Response: The Properties dialog is displayed. 
3. Go to the Data page. 
4. Select Map with markers or pies from the Map type drop-down list. 
5. Select a data table containing map data. 

Comment: If a map data table has not already been added, click Add... to open the Add 
Data Table dialog where you can browse for a data table to use, such as an ESRI shape 
file. 
Response: The map is displayed in the visualization area. 

6. Under Data table for markers or pies, select a data table of interest. 
7. Under Draw markers or pies using, select whether to use Relation or Coordinate 

columns to match the map data table to the data table for markers or pies. 
Comment: If you want to use a relation, you must set up a relation to make the 
Relation option available. 

8. To set up a relation, or to edit an existing relation, go through steps 9 to 15. To use an 
existing relation, go to step 16. To use coordinate columns, go through steps 17 to 19. 

9. Click the Manage Relations... button. 
Response: The Manage Relations dialog is opened. 

10. To create a new relation, click on the New... button to open the New Relation dialog. 
To edit an existing relation, click on the Edit... button to open the Edit Relation dialog. 

11. In the Left data table drop-down list, select the same data table that you selected under 
Related data table for coloring. 

12. In the Right data table drop-down list, select the map data table. 
13. In the Left column and the Right column drop-down lists, select columns that make up 

a valid relation between the two data tables. For instance, columns in both data tables 
describing the same regions, such as state or country names. 

14. Click OK. 
15. Click OK in the Manage Relations dialog. 
16. Select the Relation radio button. 

Response: Markers or pies are displayed in the map according to the positions given in 
the specified relation. 

17. Select the Coordinate columns radio button. 
18. In the X column drop-down list, select the X coordinate column. 
19. In the Y column drop-down list, select the Y coordinate column. 

Response: Markers or pies are displayed in the map according to the positions given in 
the coordinate columns. 

20. To change from markers to pies, or vice versa, go to the Shape page. To change the 
appearance of the map, go to the Appearance page. 

► To set up a map using a background image with markers or 
pies: 
1. Create a map chart. 
2. Right-click in the visualization to display the pop-up menu and select Properties. 

Response: The Properties dialog is displayed. 
3. Go to the Data page. 
4. Select Background image with markers or pies from the Map type drop-down list. 
5. Click on Browse... to locate the interesting image file. 
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Comment: You can use a vector file (EMF, WMF) or an image file (BMP, GIF, TIFF, 
JPG, PNG, etc.). 
Response: The image is shown in the visualization area. 

6. Under Data table for markers or pies, select a data table. 
7. Select X column and Y column from the drop-down lists. 
8. Click on the Position Settings... button to open the Position Settings dialog where you 

can adjust the image position relative to the data in the X and Y columns. 
Comment: If you do not have the exact coordinates of the map limits, you can locate a 
few known landmarks in the map and adjust the X and Y High and Low values until 
the corresponding markers are positioned on the correct landmarks. 

9. When done, click OK. 
10. To change from markers to pies, or vice versa, go to the Shape page. 

Zooming and navigating in the map chart: 
Located at the top right of the visualization are a number of buttons that you can use to zoom 
and navigate in the visualization. 

Button Shortcut Description 

 

Press and hold the Shift key and the right 
mouse button simultaneously while moving 
the mouse up. 

Zoom in. 

 

Press and hold the Shift key and the right 
mouse button simultaneously while moving 
the mouse down. 

Zoom out. 

  Press and hold the Shift + Ctrl + Alt keys and 
the left mouse button simultaneously, while 
drawing a rectangle with the mouse pointer. 

Zoom in on a rectangular 
area of a map. 

 

Press and hold the Ctrl key and the right 
mouse button simultaneously to grab the map 
and move it in any direction. 

Pan right. 

 

-"- Pan left. 

 

-"- Pan up. 

 

-"- Pan down. 

 

  Reset navigation. 

You can also use the mouse wheel to zoom in or out.  To reset navigation to the default values, 
click on the Reset Navigation button or right-click in the visualization and select Reset 
Navigation. 

Resizing markers and pies in the map chart: 
You can use keyboard shortcuts to resize markers and pies in a map chart: 

Shortcut Description 

Press and hold down the Ctrl key and the plus (+) key 
simultaneously until the markers or pies have the desired 
size. 

Increase size of markers or pies. 
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Press and release the plus key repeatedly while pressing 
the Ctrl key. 

Increase size of markers or pies. 

Press and hold the Ctrl key and the minus (-) key 
simultaneously. 

Decrease size of markers or pies. 

Press and release the minus key repeatedly while 
pressing the Ctrl key. 

Decrease size of markers or pies. 

Press and hold down the Ctrl key while rotating the 
mouse wheel. 

Resize markers or pies. 

 You can also go into the Size page of the Properties dialog and use the slider control. 

Labels in different map types 
Labels can be used in any map type to identify and describe the markers, pies, or interactive 
shapes. Most settings related to labels are defined in the Labels page of the Map Chart 
Properties. In maps with markers or pies, you can click on a label to mark the corresponding 
marker, and mouseover a label to highlight both the label and the marker. In a map with a large 
amount of labels it can sometimes be useful to move the labels to other positions to make sure 
as many of the labels as possible are visible. This is done using drag and drop, and works 
slightly differently depending on the map type, as described below. In maps with interactive 
shapes, you can hover with the mouse pointer over a map shape to view its corresponding label 
if the label is hidden due to lack of space. 

► To add labels to a map chart: 
1. Right-click in the visualization to display the pop-up menu and select Properties. 

Response: The Properties dialog is displayed. 
2. Go to the Labels page. 
3. Select the column to Label by. 

Response: Labels are displayed in the map. 
Comment: When a map with interactive shapes is used, the column to label by must 
always come from the same data table as the column to color by. The data table used 
for coloring is specified on the Data page. 

4. Specify whether to Show labels for All, Marked rows or None. 
Comment: If the map chart uses markers or pies you can change the Max number of 
labels, or select one or more of the check boxes to Center labels on items or Show 
empty labels. You can also specify Display options and get content from an image 
column, another source or apply some kind of transformation (if any transformations 
are available). 

► To move labels in a map chart with interactive shapes: 
1. Right-click in the visualization to display the pop-up menu and select Edit Label 

Positions. 
Response: The label editing is enabled. 

2. Click on the label you wish to move and drag it to its new position. 
3. When you are done, right-click on the visualization and select Edit Label Positions 

again to leave the label editing mode. 
Comment: You can get all original label positions back by right-clicking and selecting 
Reset Label Positions. 

► To move labels in a map with markers or pies: 
1. Click on the label you wish to move and drag it to a new position. 
2. Response: The label is moved to the new position. 
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Comment: You can get all original label positions back by right-clicking and selecting 
Reset Label Positions. 
Comment: When tiled markers are used, labels cannot be moved to other positions 
since they are always centered and displayed directly on the markers. 

4.10.3 Map Chart Properties 

4.10.3.1 Map Chart Properties 
The Map Chart Properties dialog consists of several pages: 

• General 
• Data 
• Appearance 
• Fonts 
• Colors 
• Size 
• Shape 
• Labels 
• Tooltip 
• Legend 
• Trellis 
• Line Connection 
• Marker By 

► To reach the Map Chart Properties dialog: 
1. Right-click on the map chart visualization. 
2. Select Properties from the pop-up menu. 
3. Comment: You can also click on the map chart visualization to make it active and then 

select Edit > Visualization Properties. 
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4.10.3.2 Map Chart Properties - General 

 

Option Description 

Title The title of the visualization. 
Tip: Double-click on the title bar of the visualization for a shortcut to 
this field. 

Show title bar Specifies whether or not to show the visualization title. 

Description A description of the visualization. This description can optionally be 
shown in the legend and/or in the visualization. 

Show description 
in visualization 

Specifies whether or not to show the description in the visualization. 
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4.10.3.3 Map Chart Properties - Data 
There are three types of maps in Spotfire and depending on the map you choose, the settings 
you need to define will be different. 

Map with interactive shapes 

 

Option Description 

Map type Decides what kind of map to use. Depending on which map type you 
choose, the available map settings will be different. 

Map settings The available settings for the chosen map type. 

   Map data table Specifies the data table to draw the map from. 

   Add... Opens a dialog where you can select the data table of interest. For 
example, an ESRI shape file (.SHP). 

   Auto-zoom If the check box is selected, the visualization is automatically zoomed 
in on the filtered shapes. 
Note: To be able to zoom and pan using the navigation controls or 
keyboard shortcuts, Auto-zoom must be deselected. 

   Related data 
table for coloring 

Specifies the data table that the coloring of the map should be based 
on. This is also the data table from which information will be shown in 
the Details-on-Demand window when shapes are marked in the map. 
Note: You can use the map data table to color by, but to color by 
another data table, a valid relation must exist between the two data 
tables. 
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   Manage 
Relations... 

Opens the Manage Relations dialog where you can add, edit or remove 
relations between data tables. 

Marking Settings   

   Marking Specifies the marking (the color and relationships to other marked 
items) that will be used to mark items in this visualization. 

   New... Opens the New Marking dialog where you can specify a new marking. 
The color of a previously created marking is edited in the Document 
Properties dialog. 

   Limit data 
shown in 
visualization using 
markings 

Lists the available markings that can be used to limit what is shown in 
this visualization. This means that the visualization only displays data 
that has been marked in other visualizations. 
If more than one marking is selected, the resulting visualization shows 
the intersection of the markings. 
This can be used if you have two visualizations with different 
markings and want to see which markers are present in both markings. 
Create a third visualization and set the data to be limited by both 
markings to see the common markers. 

Note: To set up a map chart using a non-shape file, see Configuration of Geographical Data for 
Map Charts. 
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Map with markers or pies 

 

Option Description 

Map type Decides what kind of map to use. Depending on which map type you 
choose, the available map settings will be different. 

Map settings The available settings for the chosen map type. 

   Map data table Specifies the data table to draw the map background from. 

   Add... Opens a dialog where you can select the data table of interest. 

   Data table for 
markers or pies 

Specifies the data table that the markers or pies in the map chart 
should be based on. This is also the data table from which information 
will be shown in the Details-on-Demand window when the markers or 
pies are marked in the map. 

   Manage 
relations... 

Opens the Manage Relations dialog where you can add, edit or remove 
relations between data tables. 

   Draw markers or 
pies using 

Decides whether the markers or pies in the map chart should be drawn 
by using a relation between columns in two data tables or by 
specifying coordinate columns. 
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      Relation Select this option to use an already defined relation between columns 
in the map data table and the data table for markers or pies. 

      Coordinate 
columns 

Use this option to specify columns in the data table that should be used 
on the X-axis and the Y-axis of the visualization. 

   Auto-zoom If the check box is selected, the visualization is automatically zoomed 
in on the filtered values. 
Note: To be able to zoom and pan using the navigation controls or 
keyboard shortcuts, Auto-zoom must be deselected. 

Marking Settings   

   Marking Specifies the marking (the color and relationships to other marked 
items) that will be used to mark items in this visualization. 

   New... Opens the New Marking dialog where you can specify a new marking. 
The color of a previously created marking is edited in the Document 
Properties dialog. 

   Limit data shown 
in visualization 
using markings 

Lists the available markings that can be used to limit what is shown in 
this visualization. This means that the visualization only displays data 
that has been marked in other visualizations. 
If more than one marking is selected, the resulting visualization shows 
the intersection of the markings. 
This can be used if you have two visualizations with different 
markings and want to see which markers are present in both markings. 
Create a third visualization and set the data to be limited by both 
markings to see the common markers. 
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Background image with markers or pies 

 

Option Description 

Map type Decides what kind of map to use. Depending on which map type you 
choose, the available map settings will be different. 

Map settings The available settings for the chosen map type. 

   Background 
image file 

Specifies the image to use as a background. Both vector files (EMF, 
WMF) and image files (BMP, GIF, PNG, etc.) can be used. 

   Browse... Opens a dialog where you can select the file of interest. 

   Position settings Opens a dialog where you can specify the location of the markers or 
pies relative to the position of the background image. 

   Data table for 
markers or pies 

Specifies the data table that the markers or pies in the map chart 
should be based on. This is also the data table from which information 
will be shown in the Details-on-Demand window when the markers or 
pies are marked in the map. 

   X column Use this option to specify a column in the data table that should be 
used on the X-axis of the visualization. 

   Y column Use this option to specify a column in the data table that should be 
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used on the Y-axis of the visualization. 

   Auto-zoom If the check box is selected, the visualization is automatically zoomed 
in on the filtered values. 
Note: To be able to zoom and pan using the navigation controls or 
keyboard shortcuts, Auto-zoom must be deselected. 

Marking Settings   

   Marking Specifies the marking (the color and relationships to other marked 
items) that will be used to mark items in this visualization. 

   New... Opens the New Marking dialog where you can specify a new marking. 
The color of a previously created marking is edited in the Document 
Properties dialog. 

   Limit data shown 
in visualization 
using markings 

Lists the available markings that can be used to limit what is shown in 
this visualization. This means that the visualization only displays data 
that has been marked in other visualizations. 
If more than one marking is selected, the resulting visualization shows 
the intersection of the markings. 
This can be used if you have two visualizations with different 
markings and want to see which markers are present in both markings. 
Create a third visualization and set the data to be limited by both 
markings to see the common markers. 

 

4.10.3.4 Map Chart Properties - Appearance 
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Option Description 

Show navigation 
controls 

Specifies whether or not the navigation controls should be visible in 
the visualization. 

Map Settings to apply to the map. 
Note: These settings are disabled for map charts using a background 
image with markers or pies. 

   Fill color Defines which color to fill the different areas of the map with. This is 
only available for maps with markers or pies with polygon shapes. 

   Border color Defines the color to use for the border surrounding the areas in the 
map. This is available for maps with interactive shapes, and maps with 
markers or pies. 
Note: In a map with markers or pies where the map consists of lines or 
points rather than areas, the color to apply to them is decided by the 
border color as well. 

   Border weight Defines the thickness of the borders of the areas in the map. If the map 
consists of lines rather than areas, the border weight decides the line 
thickness. If the map consists of points, the border weight decides their 
sizes. Border weight is available for maps with interactive shapes, and 
maps with markers or pies. 

Markers or pies Settings to apply to markers or pies in the visualization. 
Note: These settings are disabled for maps with interactive shapes, 
since no markers or pies are available in those maps. 

   Jittering Jittering is an option that displaces the visualization items randomly in 
the display window, thereby making overlapping records visible. 

      X Specifies the amount of jittering to use in the horizontal direction. 

      Y Specifies the amount of jittering to use in the vertical direction. 

      Use the same 
amount of jittering 
for both X and Y 

Select this check box to connect the jittering sliders in both directions 
to each other. 
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4.10.3.5 Map Chart Properties - Fonts 

 

Option Description 

Settings for Lists all items for which you can change the font settings. Click to 
select an item in the list to change the font settings for that text in the 
visualization. Press Ctrl and click on more items to change the settings 
for multiple items simultaneously. 

Font Specifies the font to use for the selected items. 

Font style Specifies the font style to use for the selected items. 

Size Specifies the font size to use for the selected items. 
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4.10.3.6 Map Chart Properties - Colors 

 
Note: The settings on this page concern the related data table for coloring when you use a map 
with interactive shapes. When you use a map or image background with markers or pies, the 
settings on this page concern the data table for markers or pies. 

Option Description 

Columns Specifies the column or hierarchy to color by. 

Settings Opens the Advanced Settings dialog where you can change the scale 
mode for the selected column or hierarchy from continuous to 
categorical and vice versa, as well as changing the category mode to 
determine which combinations to show. 

Color mode Specifies in which color mode to set up the color scheme. Which 
modes are available depends on whether the scale is in categorical or 
continuous mode. For columns in continuous scale mode, you can 
select one of the following color modes: Gradient, Segments, Fixed, 
or Unique values. For columns in categorical scale mode, you can 
select either Categorical or Fixed color mode. To learn more about 
the color modes, see Color Modes Overview. 

One scale per Specifies whether there should be one separate scale per trellis panel 
for trellised map charts, or if one scale should apply to the entire 
visualization. Only applicable to columns in continuous scale mode. 

 
[Color Schemes 
menu] 

Opens a menu where you can select an already existing color 
scheme and apply it to the visualization, or apply the currently open 
color scheme to another visualization in the analysis. 

   From Visualization Lets you select a color scheme from another visualization in the 
analysis. Only color schemes that are applicable to the current color 
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scheme will be listed. 

   Document Color 
Schemes 

Lets you select a color scheme that has previously been saved within 
the analysis. Only color schemes that are applicable to the current 
color scheme will be listed. This menu option is only available if 
one or more document color schemes already exist. 

   [Predefined color 
schemes] 

Lists a number of predefined color schemes. Available for columns 
in continuous scale mode only. For a full description of the 
predefined color schemes, see Predefined Color Schemes. 
Tip: To facilitate setting up a new color scheme, you can open a 
predefined color scheme with a similar appearance, and then adjust 
it to suit your needs. 

   Open from 
Library... 

Opens the Open from Library dialog where you can select a color 
scheme that has previously been saved to the library. 

   Open from File... Opens a dialog where you can select a previously saved color 
scheme. 

   Save As Lets you save a color scheme as a library item, a local file or a 
document color scheme. 
Library Item – Opens the Save as Library Item dialog, where you 
can specify a location in the library and a file name to save the 
currently open color scheme for later reuse. 
File – Opens a dialog where you can specify a location and a file 
name to save your currently open color scheme locally on your 
computer for later reuse. 
Document Color Scheme – Opens the Save as Document Color 
Scheme dialog, where you can specify a name and save the currently 
open color scheme for later reuse within the analysis. 

   Apply to 
Visualizations... 

Opens the Apply to Visualizations dialog where you can select other 
visualizations (within the analysis) that you want to apply the 
current color scheme to. Only visualizations with compatible color 
schemes are listed. 
Note: If you apply a color scheme to a table, cross table, or heat 
map, the coloring will not take effect immediately. The color 
scheme will be added as an empty color scheme grouping, and you 
must select which columns or axis values to include in the grouping 
by opening the Edit Color Scheme Grouping dialog. 

[Color scheme area] The area in the lower part of the dialog shows the current color 
scheme. That is, the colors and values currently used in the 
visualization. You can modify color schemes in numerous ways to 
give the visualization the appearance you prefer. The color scheme 
area will look different, and have different available settings, 
depending on the characteristics of the column used to color the 
visualization by, as well as the selected color mode. To learn more 
about color schemes and color modes, see Color Schemes Overview 
and Color Modes Overview respectively. 

Add Point Available for continuous columns only. Adds a new anchor point to 
the color scheme. 

Delete Point Available for continuous columns only. Deletes the selected anchor 
point. 
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Add Rule... Opens the Add Rule dialog where you can define a rule that 
functions as an exception to the rest of the defined color scheme. A 
rule has higher priority than the rest of the color scheme. For 
example, you can define a rule to give the top five items in your data 
a different color than the rest of the items. If you add many rules to a 
color scheme, the rules are prioritized from top to bottom. Which 
rule types are available depends on the characteristics of the column 
or hierarchy used to color the visualization by. See Details on 
Add/Edit Rule for full descriptions of the rule types. 

Reset Resets the color scheme to the one that was in effect when the 
visualization was created. Any added rules will be removed. Which 
color scheme should be used by default when you create a new 
visualization is defined in the Visualization page of the Options 
dialog. 

4.10.3.7 Map Chart Properties - Size 

 
Note: The settings on this page are not available for maps with interactive shapes, or when the 
map chart is set up with tiled markers. Maps with interactive shapes do not have any markers to 
apply any size settings to, and tiled markers have the same size by definition. To change map 
type, go to the Data page. To change marker shapes, go to the Shape page. 

Option Description 

Marker size Increases or decreases the overall size of all markers. 

Size by Specifies a column or hierarchy whose categories will determine the 
size of the markers. 
The aggregation options on the drop-down menu are only available if 
the markers in the map chart have been aggregated by setting the 
Marker By option to something other than (Row Number). 
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Scale Determines the scale to use for the size of the markers. 

From min to max Assigns the maximum marker size to the highest value, and the 
minimum marker size to the lowest value. For instance, if the 
minimum and maximum data values are -9 and 11 respectively, the 
marker sizes could be like the following: 

 
This mode is useful when you want to visualize differences. 

  Min limit: 
  Max limit: 

The minimum and maximum limits that should be mapped to the 
marker size. By default, they are set to "Automatic". This means that 
the marker size will adapt during filtering. If the scale is set to "From 
min to max", the current minimum value will have the minimum 
marker size, and the current maximum value will have the maximum 
marker size. It is comparable to automatic zooming on the X or Y axes. 
It is possible to lock the max limit and/or min limit to a specific value 
by selecting "Value" in the drop-down list and entering a value. Data 
values that are lower than the minimum value or higher than the 
maximum value will get the same size as the minimum and maximum 
value respectively. By specifying both a high and low value, the auto-
scaling behavior is turned off. 

From 0 to max 
absolute value 

This mode is useful when you want to compare the magnitude of 
measures. By letting the value 0 map to marker size 0, and the 
maximum value to the maximum marker size, it is possible to compare 
the diameter of markers and say "a" is twice as big as "b". With this 
scale the values 50 and 100 would be rendered like this: 

 
Note: The size is scaled symmetrically around 0 with absolute 
numbers. That is, if your highest value is 10 and your lowest is -20, the 
size of the marker at 10 will be 50 percent of the maximum marker 
size. 

  Max: The absolute limit that should be mapped to the marker size. By 
default, it is set to "Automatic". This means that the marker size will 
adapt during filtering. The value 0 will have the minimum marker size 
and the highest absolute value in the visualization will have the 
maximum marker size. 
It is possible to lock this to a specific value by selecting "Value" in the 
drop-down list and entering a value. Data values that have a larger 
absolute value than the set value will get the same size as the 
maximum value. 
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4.10.3.8 Map Chart Properties - Shape 

 
Note: The settings on this page are not available for maps with interactive shapes, since those 
maps do not have any markers to apply any shape settings to. 

Option Description 

Fixed shape Select this option to use the same, fixed shape on all markers. 
Select which shape to use from the Shape drop-down list under 
Shape definition. 

     Shape Defines which shape to use for all markers. 

Shape by column values Select this option to use different shapes for the categories in a 
specified column or hierarchy. Which column or hierarchy to use, 
as well as which shape should represent which category, is 
specified under Shape definition. 
Note: A default set of shapes is used when automatically 
assigning shapes to categories. When there are more categories 
than available shapes in the default set, shapes will be recycled. 

     Columns Specifies the column or hierarchy containing the categories you 
wish to present using different shapes. 

     Settings... Opens the Advanced Settings dialog where you can change the 
category mode to determine which combinations to show. 

     Shape scheme Lists the categories in the selected column or hierarchy, and the 
shapes that have been assigned to each of these categories. 
Note: The set of shapes that is used by default in the scheme does 
not include all the available shapes. You can, however, always 
change to the shapes of your choice manually. Click on a shape 
in the scheme to display all the available shapes and make your 
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selection. 

Tiled markers Select this option to display the markers as tiles. The markers 
will be rectangular, have the same size, and be displayed in a 
grid-like layout. 
Note: When you use tiled markers the settings in the Size page 
will be disabled since the markers have the same size. 

Pies Select this option to use pies instead of markers. 

   Sector size by Determines the numeric column that should provide the sizes of 
the pie sectors. 
Note: Remember to specify an aggregation method (for example, 
sum) for this column if you want each category selected under 
Colors to be summarized. 

      Show in labels Specifies what information to show in the labels for the pie 
sectors. 

         Sector value      Displays the value of the sector. For example, sum of sales for 
apples, if the sector size is defined by sum of sales and the color 
is defined by fruit or vegetable type. 

         Sector category Displays the category defining the sector. For example, "apples", 
if the sector color is defined by fruit or vegetable type. 

         Sector percentage Displays labels showing the percentage of the total that each 
sector represents. 

            Threshold Excludes the labels for the sectors whose percentage falls below 
the specified threshold value. 

            Decimals Specifies the number of decimals to display for the percentage 
value. The number specified here will also affect the number of 
decimals shown for pie sectors in the tooltip. 

      Label position Specifies whether the labels will be located Inside or Outside the 
pie sectors. 

      Sort sectors by size Sorts the pie sectors by size. 
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4.10.3.9 Map Chart Properties - Labels 

 

Option Description 

Label by Specifies the column or hierarchy whose values should be presented as 
labels in the visualization. 
When a map with interactive shapes is used, the column to label by 
must always come from the same data table as the column to color by. 
The data table used for coloring is specified on the Data page. 

Show labels for Determines whether to show labels on all markers (All), marked 
markers only (Marked rows), or not to show any labels at all (None). 

Max number of 
labels 

Specifies the maximum number of labels to be shown. If the number is 
smaller than the available number of markers, the labels will be 
equally distributed. 
Note: This setting is not available when the markers are tiled. Go to 
the Shape page if you want to change marker shapes. 

Center labels on 
items 

Places the label right on top of the marker instead of drawing a line 
from the marker to the label, which is the default behavior. This can be 
a way to use your own images as markers. 
Note: This setting is not available when the markers are tiled. Go to 
the Shape page if you want to change marker shapes. 

Show empty labels Shows labels that have no content. 
Note: This setting is not available when the markers are tiled. Go to 
the Shape page if you want to change marker shapes. 

Display options [Available when the Map type is set to Background image with 
markers or pies or Map with markers and pies only.] 
These settings are used when you choose to display anything other 
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than plain text in your labels. For example, the labels could contain 
web links or images.   

   Get content from [Only visible if at least one virtual column producer is available.] 
Your company may have set up some type of virtual column producers 
that can take the values from the selected column and transform them 
in one way or another to produce a desired output. For example, if you 
have access to TIBCO Spotfire Lead Discovery you can select 
Structure Column here, in order to show molecular structures from an 
information link in the labels. 
For embedded images in the current data table, or when fetching data 
via a URL, you should leave this setting at (Selected column). 

   Settings... If the selected source has some settings available, you can reach them 
by clicking on the Settings button. For example, this is where you 
would specify which information link to retrieve structures from when 
using TIBCO Spotfire Lead Discovery. 

   Show as Allows you to decide how the data in the selected column should be 
interpreted. 
For example, use Text for plain text labels. Use Image if there are 
binary images in your data that you want to use as labels. Use Link if 
the text should be interpreted as a web link. Use Image from URL if 
the image is picked from a web resource location. You may need to 
change the Link or Image from URL Renderer Settings by clicking on 
the Settings... button and modifying the link syntax so that it fits your 
current data. 
Use Geometry if your data is a shape file and you want to show the 
geometrical shapes in the labels. 
If a TIBCO Spotfire Lead Discovery structure column is used to label 
by, then you would select a renderer for displaying structure images 
here. 

   Settings... If the selected Show as method has some settings available that can be 
modified, you can reach them by clicking on the Settings button. For 
example, this could be Link Renderer Settings or Image from URL 
Renderer Settings for a web link, Geometry Renderer Settings or some 
structure renderer settings. 

   Size Available if the selected label output is some kind of image. Increases 
or decreases the size of the labels. 
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4.10.3.10 Map Chart Properties - Tooltip 

 

Option Description 

Display the 
following values 

Specifies what will be shown in the tooltip. 

Add... Opens the Add Tooltip Value dialog, where you can add the content 
from another column, hierarchy, or any custom expression to be 
shown in the tooltip. You can also use images in tooltips. See 
Highlighting in Visualizations for more information. 

Edit... Opens the Edit Tooltip Value dialog, where you can change the 
information to be shown in the tooltip. 

Delete Deletes the selected value from the list. 

Move Up Moves the selected value up in the list and, hence, up in the tooltip. 

Move Down Moves the selected value down in the list and, hence, down in the 
tooltip. 

Tooltip format   

   Value names and 
values 

Shows the tooltip content in a format where the selected column name, 
hierarchy or custom expression is displayed. For example, Year: 2003, 
Type: Cucumber, etc. 

   Visualization 
properties and 
values 

Shows the tooltip content in a format where the visualization property 
for each value is displayed. For example, X: 2003, Color: Cucumber, 
etc. 
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4.10.3.11 Map Chart Properties - Legend 

 

Option Description 

Show legend Specifies whether or not the docked legend should be shown in the 
visualization. 

Position Specifies which side of the visualization the legend should be 
positioned: the right-hand side or the left-hand side. 

Display the 
following legend 
items 

Specifies what will be shown in the legend.  
By clearing a check box you will completely hide that item from the 
legend. You can also select to show or hide parts of the legend 
information using the check boxes under Settings for the selected item 
in the list, see below. 

Settings Defines how the selected legend item should be displayed. The 
available options vary between legend items. 

   Show title Use this option to show or hide the title for the selected item. The title 
is typically what is displayed above an axis selector or similar: 

 

   Show axis 
selector 

Select this option to show or hide the axis selector for the selected item.  
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4.10.3.12 Map Chart Properties - Trellis 

 

Option Description 

Rows and columns Splits the visualization into different panels for all categories 
in the selected column or hierarchy. The number of values in 
the specified column or hierarchy controls the number of 
panels to be displayed in each row, column, or page, 
respectively. 

   Rows A row with trellis panels will be created for each value in the 
selected column or hierarchy. 

   Columns A column with trellis panels will be created for each value in 
the selected column or hierarchy. 

   Pages A new page with trellis panels will be created for each value in 
the selected column or hierarchy. Scroll down in the 
visualization to see the next page. 

Panels Splits the visualization into different panels for all categories 
in the selected column or hierarchy, without binding any 
dimensions to either rows or columns. This means that the 
number of actual values in the column to split by does not 
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control the number of shown rows or columns in any way. 
The number of panels that should be visible on each page is 
instead specified using the Max number of rows and Max 
number of columns controls below. 

   Split by Specifies the column or hierarchy to define the categories by 
which the visualization should be split. 

   Manual layout Select the check box to manually specify the number of rows 
and columns that should be visible without scrolling. If the 
check box is cleared, the application will automatically specify 
the number of rows and columns. 

   Max number of rows Specifies the maximum number of panels that should be 
visible on each page. 

   Max number of columns Specifies the maximum number of panels that should be 
visible on each page. 

Settings... Opens the Advanced Settings dialog where you can change the 
category mode to determine which combinations to show. 

 

4.10.3.13 Map Chart Properties - Line Connection 

 
Note: The settings on this page are not available for maps with interactive shapes, since those 
maps do not have any markers to apply line connection settings for. 

Option Description 

Draw a separate 
line per value in 

Specifies the column or hierarchy containing the categories to use for 
line connection. Markers of the same category will be connected with 
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each other to form a separate line. If no column or hierarchy is 
specified here, all markers will be connected with each other. 

Order each line by Specifies the order in which markers are connected. If no column or 
hierarchy is specified here, the markers will be ordered by row index 
(the order of the rows in the original data table). 

Color Specifies how colors will be assigned to the lines. 

   Same as marker Choose this option if you want the lines to have the same color as the 
markers they are a connection between. If a line connects markers with 
different colors, the color of the line will be a fusion of the two colors. 
For example, when a blue marker is connected with a yellow marker 
the line between them will be green. 

   Custom Choose this option if you want to use a single custom color for the 
lines. Click on the drop-down list to show the color selector where you 
can choose a different color. 

Width Specifies the width of the lines. 

Place in Select whether the lines should be placed in the foreground or 
background of the markers they are connecting. 
Tip: Change the transparency of the markers on the Appearance page 
if you want to be able to see the lines through the markers when the 
lines are placed in the background. 

Show arrows to 
indicate order 

Specifies whether or not there should be arrows along the lines to 
indicate the order. 

4.10.3.14 Map Chart Properties - Marker By 
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Note: The settings on this page are not available for maps with interactive shapes, since those 
maps do not have any markers. 

Option Description 

Show one marker 
for each 

Specifies the column or hierarchy containing the categories by which 
the markers should be split. 

Currently also 
split by the 
following 
properties 

Displays information about what other properties currently contribute 
to a splitting of the markers. 

4.10.3.15 Details on Add Data Table 
This dialog is used to add map data to a map chart visualization. 

► To reach the Add Data Table dialog: 
1. Create a map chart. 
2. Right-click in the visualization to display the pop-up menu and select Properties. 

Response: The Properties dialog is displayed. 
3. Go to the Data page. 
4. Select Map with interactive shapes from the Map type drop-down list. 
5. Click Add.... 

Comment: If you are not using a shape file, some manual configuration of the data will 
be needed before you can use it as a map. To learn how to do this, see Configuration of 
Geographical Data for Map Charts. 

 

Option Description 

Select source type   

  File Allows you to add a data table from a file. 
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  Information Link Allows you to add a data table from an information link. 

  Database Allows you to add a data table from any supported database. 

  Clipboard Allows you to add a data table from the clipboard. 

  Existing data table 
in my analysis 

Allows you to add a data table from the current analysis. 

Location Shows the path and filename of the selected file. 

Browse... Opens a dialog where you can select which file, information link, 
database, etc., to open. 

Data table name Allows you to type a suitable name for the new data table. 

Show 
transformations 

Expands the dialog and allows you to apply transformations on the 
data table you want to add. For more information, see the Show 
transformations topic. 

Manage Relations... Opens the Manage Relations dialog where you can specify how the 
new data table is related to any previously loaded data tables in your 
analysis. 

4.10.3.16 Details on Position Settings 

► To reach the Position Settings dialog: 
1. In the Visualization Properties dialog of the Map Chart, go to the Data page. 
2. Select Background image with markers or pies as map type. 
3. Select a background image. 
4. Click Position Settings.... 

 

Option Description 

Position Specifies the location of the markers relative to the position of the map 
image. Type different values for Y High, Y Low, X High and X Low 
to move the markers so that they are placed on their correct positions 
on the map. 

Reset Returns to the default position, which is specified by the max and min 
values of the selected coordinate columns. 
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Save positions for 
this image 

Select this check box if you want the application to remember the 
positions you have defined for the current background image. The 
positions will be kept when you change data table, X and Y columns, 
or shape type of the markers as long as the background image is not 
changed. 

4.10.4 Configuration of Geographical Data for Map Charts 
When Shape files are opened in TIBCO Spotfire they are automatically configured so that maps 
with interactive shapes can be displayed. However, there may be times when some manual 
work is needed before the data can be used in a map with interactive shapes. The binary 
geometry data needs to be extracted to six coordinate columns and the columns also need to be 
assigned the proper value on the mapchart.columntypeid property: Geometry, XMax, XMin, 
YMax, YMin, XCenter and YCenter. 

► To set up non-shape file WKB data: 
When the geographical data is located in a Well-Known Binary (WKB) column, but not 
originating from a Shape file, you can manually create the required coordinate columns using 
the Spatial functions in the Insert Calculated Column tool. 

1. Click Insert > Calculated Column.... 
2. In the Functions section, select the Spatial functions category. 
3. Select the first spatial function, WKBEnvelopeXCenter and click Insert Function. 
4. Select the WKB column from the Available columns list and click Insert Columns. 
5. Type a suitable column name (e.g., XCenter) and click OK. 

Response: The XCenter column is created and the correct property value is set on the 
mapchart.columntypeid property. 

6. Repeat steps 3 to 5 with the other five functions. 
7. Now, create a Map Chart and use the data table with the newly created columns as the 

Map data table in the Data page of the Visualization Properties dialog. 

► To set up an information link with map information: 
When the geographical data is located in a database and an information link is used to retrieve 
the data, you need to perform the following steps at the creation of the column elements if you 
want the end users of the information link to be able to create map charts without further 
configuration: 

1. If you only have a binary WKB column, you can use TIBCO Spotfire to create the 
necessary coordinate columns. Placing the coordinate columns in the server database 
from the beginning makes it a lot easier to use the geographical data later on. The 
Geometry column should be of type BLOB and the coordinate columns should be of 
type Real. 

2. Properties are specified at the creation of the column elements in Information 
Designer, on the Column Element tab. For each column element, expand the Properties 
field, click Add... and create the property mapchart.columntypeid. In the Value field, 
type Geometry, XMax, XMin, YMax, YMin, XCenter or YCenter, depending on 
which column you are defining. 

3. Save the column elements. 
If you want to be able to view the Geometry column as images in a Table visualization, the 
ContentType column property needs to be set to application/x-wkb. For a table visualization 
created before you added the ContentType property to display the shapes from the Geometry 
column, click Edit > Visualization Properties and go to the Columns page to change the 
renderer. 
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4.11 Treemap 
4.11.1 What is a Treemap? 

Treemaps are ideal for displaying large amounts of hierarchically structured (tree-structured) 
data. The space in the visualization is split up into rectangles that are sized and ordered by a 
quantitative variable. 
The levels in the hierarchy of the treemap are visualized as rectangles containing other 
rectangles. Each set of rectangles on the same level in the hierarchy represents a column or an 
expression in a data table. Each individual rectangle on a level in the hierarchy represents a 
category in a column. For example, a rectangle representing a continent may contain several 
rectangles representing countries in that continent. Each rectangle representing a country may in 
turn contain rectangles representing cities in these countries. You can create a treemap 
hierarchy directly in the visualization, or use an already defined hierarchy. To learn more, see 
the section To Create a Treemap Hierarchy. 
A number of different algorithms can be used to determine how the rectangles in a treemap 
should be sized and ordered. The treemap in Spotfire uses a squarified algorithm. 
The rectangles in the treemap range in size from the top left corner of the visualization to the 
bottom right corner, with the largest rectangle positioned in the top left corner and the smallest 
rectangle in the bottom right corner. For hierarchies, that is, when the rectangles are nested, the 
same ordering of the rectangles is repeated for each rectangle in the treemap. This means that 
the size, and thereby also position, of a rectangle that contains other rectangles is decided by the 
sum of the areas of the contained rectangles. 

Example: 
Below is a treemap where the rectangles represent cities and are sized and colored by the 
column Sales. In this case, the aggregation method Sum was selected for the Sales column. This 
treemap only contains data on one level. 

 
The sizes and positions of the rectangles, as well as the coloring, indicate that Casablanca and 
Cannes have the highest total sum of sales, while Hong Kong and Bangalore have the lowest. 
To compare sum of sales for entire countries or continents, you can add other levels to the 
treemap hierarchy without losing the information about the individual cities. In the treemap 
below, the columns Country and Continent were added to the treemap hierarchy. 
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The rectangles are now nested. Each rectangle that represents a continent consists of rectangles 
representing countries within that continent. Each rectangle that represents a country consists of 
rectangles representing cities in that country. It is still possible to see which individual cities has 
the highest sum of sales, but it is now also easy to see that Africa is the continent with the 
highest total sum of sales, and that Asia is the continent with the lowest total sum of sales. Since 
the rectangles are now nested, the rectangles are not in the same positions anymore. However, 
each level of the hierarchy is still organized according to the squarified algorithm. For example, 
the size of the rectangle representing India is decided by the sum of the areas of the two 
rectangles representing Calcutta and Bangalore. The size of the rectangle representing Asia is in 
turn decided by the sum of the areas of the rectangles representing China and India. 
To take a closer look at a certain part of the treemap, you can navigate from a higher hierarchy 
level to a lower one. Click on the hierarchy header of the level you want to navigate to. In the 
example below, the treemap is shown as it appears when you navigate down to the country level 
India. 

 
The uppermost hierarchy header now displays the hierarchy levels from the top level to the 
level you are currently viewing. To navigate upwards in the hierarchy, click on the level you 
want to navigate to. 
You can hide both the hierarchy headers and the labels in the treemap at any time from the 
right-click menu of the visualization. 
All visualizations except the map chart can be set up to show data limited by one or more 
markings in other visualizations only (details visualizations). They can also be limited by one or 
more filterings. Another alternative is to set up a visualization without any filtering at all. See 
Limiting What is Shown in Visualizations for more information. 

4.11.2 How to Use the Treemap 
► To apply coloring: 

1. In the Filters panel, click and hold the left mouse button on the filter representing the 
column you want to color by. 
Comment: Coloring is also available in the Visualization Properties dialog. The color 
of marked items is changed under Edit > Document Properties. 

2. Drag the filter to the center of the visualization. 
Response: Drop targets appear in the middle of the visualization. 

3. Release the mouse button on the Color target. 
Response: The rectangles in the treemap will be colored according to the chosen 
column. 
Comment: To learn more about coloring in Spotfire, see Coloring Overview. 

► To create a treemap hierarchy: 
1. In the legend, click on the column selector for Hierarchy to open the menu. 

Comment: The hierarchy settings can also be defined on the Hierarchy page of the 
Visualization Properties dialog. 

2. Select the column you want to use as the top level of the treemap hierarchy. 
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Response: The treemap will instantly be divided into rectangles representing the 
categories in the chosen column. 

3. Click on the column selector with a plus sign next to the previously used column 
selector. 

4. From the menu, select the column that you want to use as the next level in the treemap 
hierarchy. 
Response: Rectangles representing the categories in the chosen column will be added 
inside the rectangles of the level immediately above in the treemap hierarchy. 

5. Repeat steps 3 and 4 for every level that you want to add to the treemap hierarchy. 
Comment: You can add columns to the treemap hierarchy and change the order of the 
hierarchy levels by using drag-and-drop in the legend. To learn more, see Drag-and-
Drop. 
Note: You can also use a preconfigured hierarchy as a treemap hierarchy by creating a 
hierarchy in the Column Properties dialog, or by creating a hierarchy from the filters 
panel. For more information about creating hierarchies in TIBCO Spotfire, see How to 
Edit Column Properties and Creating a Hierarchy Filter. 

► To navigate to different levels in a treemap: 
1. Right-click in the treemap to display the pop-up menu. 
2. From the pop-up menu, select Navigate To. 
3. Select the hierarchy level you want to navigate to. 

Comment: If the hierarchy headers are visible, you can also click on a hierarchy header 
to navigate to that level. 
Note: You can navigate upwards in a hierarchy by clicking on a category from the path 
of levels in the uppermost header of the treemap. To go to the top level, click (All). 

► To create a new treemap: 
1. Click on the New Treemap button on the toolbar, . 

Comment: You can also select Insert > New Visualization > Treemap from the 
menu. 
Response: A first attempt to set up a suitable treemap is made by the application. 

2. Adjust the treemap to display the data of your choice. 

4.11.3 Treemap Properties 

4.11.3.1 Treemap Properties 
The Treemap Properties dialog consists of several pages: 

• General 
• Data 
• Fonts 
• Colors 
• Size 
• Hierarchy 
• Labels 
• Tooltip 
• Legend 
• Trellis 
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► To reach the Treemap Properties dialog: 
1. Right-click on the treemap visualization. 
2. Select Properties from the pop-up menu. 

Comment: You can also click on the treemap visualization to make it active and then 
select Edit > Visualization Properties. 

4.11.3.2 Treemap Properties - General 

 

Option Description 

Title The title of the visualization. 
Tip: Double-click on the title bar of the visualization for a shortcut to 
this field. 

Show title bar Specifies whether or not to show the visualization title. 

Description A description of the visualization. This description can optionally be 
shown in the legend and/or in the visualization. 

Show description 
in visualization 

Specifies whether or not to show the description in the visualization. 
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4.11.3.3 Treemap Properties - Data 

 

Option Description 

Data table Specifies the data table on which the visualization will work. 

Marking Specifies the marking (that is, the color and relationships to other 
marked items) that will be used to mark items in this visualization. 

Limit data using 
markings 

Lists the available markings that can be used to limit what is shown in 
this visualization. This means that the visualization only displays data 
that has been marked in other visualizations. 
If more than one marking is selected, you can choose how the data in 
the markings should be combined. 

New... Opens the New Marking dialog where you can specify a new marking. 
The color and name of a previously created marking is edited in the 
Document Properties dialog. 

Rows must be 
included in 

Specifies how the data in the markings should be combined if you have 
selected to limit the data by more than one marking. 

   All markings 
(AND) 
   

Use this option if you want this visualization to show the intersection of 
the markings selected in Limit data using markings. This can be used if 
you have two visualizations with different markings and want to see 
which markers are present in both markings. This visualization will 
then show only the data that has been marked using both of the selected 
markings. 

   Any marking 
(OR) 
    

Use this option if you want this visualization to show the union of the 
markings selected in Limit data using markings.  
This can be used if you have two visualizations with different markings 
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and want to see which markers are present in either of the two 
markings. This visualization will then show data that has been marked 
using either of the selected markings. 

Limit data using 
filterings 

Defines how different filtering schemes in the analysis should affect 
this visualization. 
Select Use the current filtering from the page if you want the 
visualization to always utilize the filtering scheme that is used on the 
page where the visualization is located. If you move the visualization to 
a new page, then the visualization will automatically start reacting on 
the filtering scheme that is used on the new page.  
Select a specific filtering scheme from the list if you want the 
visualization to always use that filtering scheme. Moving the 
visualization to another page with a different filtering scheme will not 
affect this setting. 
If you select to limit data using more than one filtering scheme, the 
intersection of the filterings will be used. This means that the 
visualization will show only the data that is made visible by all of the 
filtering schemes. 

New... Opens the New Filtering Scheme dialog where you can specify a new 
filtering scheme. 
The color and name of a previously created filtering scheme is edited in 
the Document Properties dialog. 

Limit data using 
expression 

You can limit what data should be available for a certain visualization 
using an expression. If you have defined a limiting expression, it will be 
displayed here. 

Edit... Opens the Limit Data Using Expression dialog where you can define a 
boolean expression to use for limiting the data in this visualization. 
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4.11.3.4 Treemap Properties - Fonts 

 

Option Description 

Settings for Lists all items for which you can change the font settings. Click to 
select an item in the list to change the font settings for that text in the 
visualization. Press Ctrl and click on more items to change the settings 
for multiple items simultaneously. 

Font Specifies the font to use for the selected items. 

Font style Specifies the font style to use for the selected items. 

Size Specifies the font size to use for the selected items. 
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4.11.3.5 Treemap Properties - Colors 

 

Option Description 

Columns Specifies the column or hierarchy to color by. 

Color mode Specifies in which color mode to set up the color scheme. You can 
select one of the following color modes: Gradient, Segments, Fixed, or 
Unique values. To learn more about the color modes, see Color Modes 
Overview. 

One scale per Specifies whether there should be one separate scale per trellis panel 
for trellised treemaps, or if one scale should apply to the entire 
visualization. 

 
[Color Schemes 
menu] 

Opens a menu where you can select an already existing color scheme 
and apply it to the visualization, or apply the currently open color 
scheme to another visualization in the analysis. 

   From 
Visualization 

Lets you select a color scheme from another visualization in the 
analysis. Only color schemes that are applicable to the current color 
scheme will be listed. 

   Document Color 
Schemes 

Lets you select a color scheme that has previously been saved within 
the analysis. Only color schemes that are applicable to the current 
color scheme will be listed. This menu option is only available if one 
or more document color schemes already exist. 

   [Predefined color 
schemes] 

Lists a number of predefined color schemes. For a full description of 
the predefined color schemes, see Predefined Color Schemes. 
Tip: To facilitate setting up a new color scheme, you can open a 
predefined color scheme with a similar appearance, and then adjust it 
to suit your needs. 
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   Open from 
Library... 

Opens the Open from Library dialog where you can select a color 
scheme that has previously been saved to the library. 

   Open from File... Opens a dialog where you can select a previously saved color scheme. 

   Save As Lets you save a color scheme as a library item, a local file or a 
document color scheme. 
Library Item – Opens the Save as Library Item dialog, where you can 
specify a location in the library and a file name to save the currently 
open color scheme for later reuse. 
File – Opens a dialog where you can specify a location and a file name 
to save your currently open color scheme locally on your computer for 
later reuse. 
Document Color Scheme – Opens the Save as Document Color 
Scheme dialog, where you can specify a name and save the currently 
open color scheme for later reuse within the analysis. 

   Apply to 
Visualizations... 

Opens the Apply to Visualizations dialog where you can select other 
visualizations (within the analysis) that you want to apply the current 
color scheme to. Only visualizations with compatible color schemes 
are listed. 
Note: If you apply a color scheme to a table, cross table, or heat map, 
the coloring will not take effect immediately. The color scheme will be 
added as an empty color scheme grouping, and you must select which 
columns or axis values to include in the grouping by opening the Edit 
Color Scheme Grouping dialog. 

[Color scheme area] The area in the lower part of the dialog shows the current color 
scheme. That is, the colors and values currently used in the 
visualization. You can modify color schemes in numerous ways to 
give the visualization the appearance you prefer. The color scheme 
area will look different, and have different available settings, 
depending on the characteristics of the column used to color the 
visualization by, as well as the selected color mode. To learn more 
about color schemes and color modes, see Color Schemes Overview 
and Color Modes Overview respectively. 

Add Point Adds a new anchor point to the color scheme. 

Delete Point Deletes the selected anchor point. 

Add Rule... Opens the Add Rule dialog where you can define a rule that functions 
as an exception to the rest of the defined color scheme. A rule has 
higher priority than the rest of the color scheme. For example, you can 
define a rule to give the top five items in your data a different color 
than the rest of the items. If you add many rules to a color scheme, the 
rules are prioritized from top to bottom. Which rule types are available 
depends on the characteristics of the column or hierarchy used to color 
the visualization by. See Details on Add/Edit Rule for full descriptions 
of the rule types. 

Reset Resets the color scheme to the one that was in effect when the 
visualization was created. Any added rules will be removed. Which 
color scheme should be used by default when you create a new 
visualization is defined in the Visualization page of the Options 
dialog. 
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4.11.3.6 Treemap Properties - Size 

 

Option Description 

Size by Specifies a column whose categories will determine the size of the 
rectangles in the treemap. 
Note: Since items with negative values have no size and cannot be 
shown, it is not advisable to size by a column that could contain 
negative values. 
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4.11.3.7 Treemap Properties - Hierarchy 

 

Option Description 

Hierarchy Specifies which columns to use in the treemap hierarchy. The order 
specified here determines the order of the levels in the treemap 
hierarchy. 
For example, Continent - Country - City, where Continent will be the 
highest level, and City the lowest. 
Tip: Instead of adding separate columns to set up a treemap hierarchy, 
you can use a previously defined hierarchy. To learn more about 
creating hierarchies, see How to Edit Column Properties and Creating a 
Hierarchy Filter. 
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4.11.3.8 Treemap Properties - Labels 

 

Option Description 

Show hierarchy 
headers 

Specifies whether or not to show hierarchy headers in the treemap. 
That is, if the column name for each level in the hierarchy should be 
visible as headers in the treemap. 

Show labels Specifies whether or not to show labels in the rectangles at the lowest 
level of the treemap hierarchy. 
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4.11.3.9 Treemap Properties - Tooltip 

 

Option Description 

Display the 
following values 

Specifies what will be shown in the tooltip. 

Add... Opens the Add Tooltip Value dialog, where you can add the content 
from another column, hierarchy, or any custom expression to be 
shown in the tooltip. You can also use images in tooltips. See 
Highlighting in Visualizations for more information. 

Edit... Opens the Edit Tooltip Value dialog, where you can change the 
information to be shown in the tooltip. 

Delete Deletes the selected value from the list. 

Move Up Moves the selected value up in the list and, hence, up in the tooltip. 

Move Down Moves the selected value down in the list and, hence, down in the 
tooltip. 

Tooltip format   

   Value names and 
values 

Shows the tooltip content in a format where the selected column name, 
hierarchy or custom expression is displayed. For example, Year: 2003, 
Type: Cucumber, etc. 

   Visualization 
properties and 
values 

Shows the tooltip content in a format where the visualization property 
for each value is displayed. For example, X: 2003, Color: Cucumber, 
etc. 
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4.11.3.10 Treemap Properties - Legend 

 

Option Description 

Show legend Specifies whether or not the docked legend should be shown in the 
visualization. 

Position Specifies which side of the visualization the legend should be 
positioned: the right-hand side or the left-hand side. 

Display the 
following legend 
items 

Specifies what will be shown in the legend.  
By clearing a check box you will completely hide that item from the 
legend. You can also select to show or hide parts of the legend 
information using the check boxes under Settings for the selected item 
in the list, see below. 

Settings Defines how the selected legend item should be displayed. The 
available options vary between legend items. 

   Show title Use this option to show or hide the title for the selected item. The title 
is typically what is displayed above an axis selector or similar: 

 

   Show axis 
selector 

Select this option to show or hide the axis selector for the selected item.  
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4.11.3.11 Treemap Properties - Trellis 

 

Option Description 

Rows and columns Splits the visualization into different panels for all categories in the 
selected column or hierarchy. The number of values in the specified 
column or hierarchy controls the number of panels to be displayed in 
each row, column, or page, respectively. 

   Rows A row with trellis panels will be created for each value in the selected 
column or hierarchy. 

   Columns A column with trellis panels will be created for each value in the 
selected column or hierarchy. 

   Pages A new page with trellis panels will be created for each value in the 
selected column or hierarchy. Scroll down in the visualization to see 
the next page. 

Panels Splits the visualization into different panels for all categories in the 
selected column or hierarchy, without binding any dimensions to either 
rows or columns. This means that the number of actual values in the 
column to split by does not control the number of shown rows or 
columns in any way. 
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The number of panels that should be visible on each page is instead 
specified using the Max number of rows and Max number of columns 
controls below. 

   Split by Specifies the column or hierarchy to define the categories by which the 
visualization should be split. 

   Manual layout Select the check box to manually specify the number of rows and 
columns that should be visible without scrolling. If the check box is 
cleared, the application will automatically specify the number of rows 
and columns. 

   Max number of 
rows 

Specifies the maximum number of panels that should be visible on 
each page. 

   Max number of 
columns 

Specifies the maximum number of panels that should be visible on 
each page. 

Settings... Opens the Advanced Settings dialog where you can change the 
category mode to determine which combinations to show. 

4.12 Heat Map 
4.12.1 What is a Heat Map? 

The easiest way to understand a heat map is to think of a table or spreadsheet which contains 
colors instead of numbers. The default color gradient sets the lowest value in the heat map to 
dark blue, the highest value to a bright red, and mid-range values to light gray, with a 
corresponding transition (or gradient) between these extremes. Heat maps are well-suited for 
visualizing large amounts of multi-dimensional data and can be used to identify clusters of rows 
with similar values, as these are displayed as areas of similar color. 

Example: 
The example below illustrates how the values in the table are displayed as color gradients in the 
heat map cells. 

 

Data in short/wide format: 
Like in other visualizations, highlighting and marking in the heat map are applied to one or 
more rows in the underlying data table. In the example below, the data is in short/wide format, 
and each row in the data table corresponds to a row in the heat map. 
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The Y-axis in this heat map is set up with the column Test, while the X-axis is set to (None). 
For the individual cell values in the heat map, the columns Time 1, Time 2, and Time 3 are 
selected. Cell value columns are always aggregated unless the Y-axis is set to (Row Number). 
This is because the data table may contain many rows with the same name, and the values in 
these rows must then be aggregated to one single value to be displayed in the heat map. 
Average is the default aggregation. With data in short/wide format, this is a common way to set 
up a heat map. 

Data in tall/skinny format: 
If the data is in tall/skinny format instead, each data table row will correspond to a single cell in 
the heat map, as seen in the example below. 

  
As in the previous example, the column Test is selected on the Y-axis. But in this case, the 
column Time is selected on the X-axis, and the cell values are set to the single column Result. 
The content of the data is the same as in the example with data in short/wide format, but the 
format of the data makes it necessary to set up the heat map in a different way. 
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Dendrograms 
It is often useful to combine heat maps with hierarchical clustering, which is a way of arranging 
items in a hierarchy based on the distance or similarity between them. The result of a clustering 
calculation is presented either as the distance or the similarity between the clustered items 
depending on the selected distance measure. See Distance Measures Overview and the detailed 
description for each measure for further information. To learn more about hierarchical 
clustering in general, see Overview of Hierarchical Clustering Theory. You can cluster both 
rows and columns in the heat map. The result of a hierarchical clustering calculation is 
displayed in a heat map as a dendrogram, which is a tree-structure of the hierarchy. Row 
dendrograms show the distance (or similarity) between rows and which nodes each row belongs 
to as a result of the clustering calculation. Column dendrograms show the distance (or 
similarity) between the variables (the selected cell value columns). The example below shows a 
heat map with a row dendrogram where the distance between the rows were calculated. 

 
As a result of the clustering calculation, the rows in the heat map have been reordered to 
correspond to the cluster calculation. Test A and Test E are placed in the same cluster. Test F 
and Test B are placed together in another cluster, and this cluster forms another cluster together 
with Test C. Test D is not included in any of those clusters. This indicates that Test A and Test 
E are closer to each other than what they are to Test F, Test B, Test C, or Test D. It also 
indicates that Test D is the one that is the most distant to any of the other rows. See 
Dendrograms and Clustering to learn more about this. 
All visualizations except the map chart can be set up to show data limited by one or more 
markings in other visualizations only (details visualizations). They can also be limited by one or 
more filterings. Another alternative is to set up a visualization without any filtering at all. See 
Limiting What is Shown in Visualizations for more information. 

4.12.2 How to Use the Heat Map 
► To add a dendrogram: 

1. Right-click in the visualization to display the pop-up menu. 
2. Select Properties. 
3. Go to the Dendrograms page. 
4. Select dendrogram type in the Settings for drop-down list. 
5. Select the Show row dendrogram or Show column dendrogram check box 

depending on the dendrogram type you selected in the previous step. 
Response: The settings for the selected dendrogram become available in the bottom 
part of the dialog. 

6. Click the Calculated hierarchical clustering radio button. 
Comment: To use an already existing dendrogram instead, click the Imported radio 
button, select which dendrogram to use from the data table selector, and continue to 
step 12. 

7. Click the Settings... button. 
Response: The Edit Clustering Settings dialog is opened. 

8. Select the Clustering method, Distance measure, and Ordering weight from the 
drop-down lists. 
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Comment: To learn more about the possible clustering settings, see Clustering 
Methods Overview, Distance Measures Overview, and Ordering Weight. 

9. Select how to replace empty values from the Empty value replacement Method 
drop-down list. 
Comment: For descriptions of the available replacement methods, see Details on Edit 
Clustering Settings. 

10. If you want to normalize the values in the heat map, select a Normalization Method 
from the drop-down list. 
Comment: To learn more about normalization methods, see Normalizing Columns. 

11. When done, click OK to close the dialog. 
12. For the dendrogram to show the correct clustering data, you must update it. Click the 

Automatically radio button if you want updates to appear automatically every time a 
setting is changed. If you want to control when the dendrogram is updated, click the 
Manually radio button, and then the Update button. 
Response: The dendrogram is displayed in the visualization. 
Comment: You can change the placement of the dendrogram under Position. 

► To apply coloring: 
See Coloring in Cross Tables and Heat Maps to learn how to set up coloring for heat maps 
specifically. See Coloring Overview if you want to learn more about coloring in general. 

► To create a new heat map: 
1. Click on the New Heat Map button on the toolbar, . 

Comment: You can also select Insert > New Visualization > Heat Map from the 
menu. 
Response: A first attempt to set up a suitable heat map is made by the application. 

2. Adjust the heat map to display the data of your choice. 

4.12.3 Dendrograms and Clustering 
A dendrogram is a tree-structured graph used in heat maps to visualize the result of a 
hierarchical clustering calculation. The result of a clustering is presented either as the distance 
or the similarity between the clustered rows or columns depending on the selected distance 
measure. See Distance Measures Overview and the detailed description for each measure for 
further information about the available distance measures. You can perform hierarchical 
clustering on an existing heat map by opening the Dendrograms page of the Visualization 
Properties. You can also use the Hierarchical Clustering tool to cluster with a data table as the 
input. To learn more about hierarchical clustering and heat maps, see Overview of Hierarchical 
Clustering Theory and What is a Heat Map? respectively. Note that only numeric columns will 
be included when clustering. 

Row Dendrograms 
The row dendrogram shows the distance or similarity between rows and which nodes each row 
belongs to, as a result of clustering. An example of a row dendrogram is shown below. 
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The individual rows in the clustered data are represented by the right-most nodes, the leaf 
nodes, in the row dendrogram. Each node in the dendrogram represents a cluster of all rows that 
lie to the right of it in the dendrogram. The left-most node in the dendrogram is therefore a 
cluster that contains all rows. The vertical dotted line is the pruning line, which can be dragged 
sideways in the dendrogram. The values next to the pruning line indicate the number of clusters 
starting from the current position of the line, as well as the calculated distance or similarity at 
that position. In the example above, the calculated distance is 1.59, and there are three clusters 
starting at the position of the pruning line. The upper two, indicated by pink circles, contain two 
or more rows, while the lower cluster contains only one individual row. 

Column Dendrograms 
The column dendrogram is drawn in the same way as the row dendrogram, but shows the 
distance or similarity between the variables (the cell value columns). 

 
At the position of the pruning line in the above example, there are two clusters. The left-most 
cluster contains two columns, while the right-most cluster contains only one individual column. 
The calculated distance is 6.08. 

Interacting with the dendrogram 
The dendrogram makes it easy to highlight and mark in the heat map. You can mouseover the 
dendrogram to highlight clusters and their corresponding cells in the heat map. You can click to 
mark a cluster. This will also mark the corresponding cells in the heat map, as in the example 
below. The tooltip displays information about the cluster. 

 

Clustering 
As mentioned, a dendrogram is added to the heat map when clustering is performed. A new 
column is also added to the data table, and made available in the filters panel. The cluster 
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column is dynamic, and the position of the pruning line decides its content. The example below 
shows what the cluster column and cluster filter would look like for the row dendrogram above. 

 
The cluster column contains unique identifiers for the cluster nodes corresponding to the 
position of the pruning line. In the example above, two cluster nodes are identified. Test B, Test 
C, and Test F belong to the cluster node with identifier 3, while Test A and Test E belong to the 
cluster node with identifier 5. The third identifier, *6, is a leaf node, containing Test D. The 
cluster column makes it possible to filter out entire clusters at a time. You can also use it to 
color or trellis other visualizations by. 
Note: If you add a column dendrogram to a heat map that is set up with multiple cell value 
columns, then the cluster column cannot show any cluster IDs. This means that the cluster 
column cannot be used for filtering, or to color or trellis other visualizations by. Also, the 
column dendrogram will not be fully interactive. For instance, it may not be possible to use the 
dendrogram to highlight or mark in the heat map. However, you can still move the pruning line 
to see the calculated distance or similarity, as well as the number of clusters. 

4.12.4 Importing/Exporting Dendrograms 
All dendrograms in TIBCO Spotfire can be represented by a data table. This makes it possible 
to use various clustering methods and statistical calculations, other than those included in the 
Edit Clustering Settings dialog. For example, you can use TIBCO Spotfire Statistics Services to 
execute a custom made S-PLUS or R script, which performs a clustering with a method of your 
choice. More specifically, you can make use of any calculation that can order leaves in a 
hierarchical fashion. The result from such a procedure would be a data table, which you can add 
to the analysis, and then import to the heat map and use for displaying a dendrogram. 
You can also export a dendrogram from a heat map, view the resulting data table, make 
modifications, and import it back to the heat map - in effect modifying the dendrogram. 
Another reason for exporting a dendrogram to a data table, and later importing it again, is 
performance. If you have a really large data set, and perform a clustering method on it, the 
calculations could take some time. If you have run a clustering method once, which is used in a 
dendrogram, you can export it and later import it without having to run the clustering again. 
The data table representation of a dendrogram used in TIBCO Spotfire must adhere to a certain 
format. This format is described below. 

► To export a dendrogram: 
1. Right-click in the visualization to display the pop-up menu. 
2. Select Properties. 
3. Go to the Dendrograms page. 
4. Under Source, click the Export button. 

Response: The Export Dendrogram dialog is opened. 
5. Enter a name for the exported dendrogram data table. 

Comment: Each data table must have a unique name. If a data table with the same 
name already exists, a number in parenthesis will be added at the end of the name. For 
example "My Row Dendrogram (2)". 

6. Click OK. 
Response: A data table is added to the analysis. 
If you want to export this data table to use outside of TIBCO Spotfire, use the File > 
Export > Data... function, and select to export the data table you just created. 
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► To import a dendrogram: 
1. Select File > Add Data Tables... to add the dendrogram data table to the analysis. 
2. Right-click in the heat map visualization to display the pop-up menu. 
3. Select Properties. 
4. Go to the Dendrograms page. 
5. Under Source, select the Imported radio button. 
6. Use the column selector to pick the data table you want to use for the dendrogram. 

Comment: The data table must be formatted according to the correct specifications 
(see below). 
Response: The imported data table is used to draw the dendrogram. 

Dendrogram Data Table Format 
As stated above, a dendrogram can be imported and used in the heat map via a data table. This 
data table must follow a certain format. Most importantly, the column headers must be named 
exactly as seen below, and have the appropriate type: 

• NodeID (integer) 
• ParentID (integer) 
• PruningLevel (integer) 
• Height (numeric) 
• LeafOrder (integer) 
• + one or more Leaf Identifier Columns 

 
In this table, each row corresponds to a node in the dendrogram and its associated attributes. In 
the dendrogram below, the NodeID of each node has been indicated by a number. 

 
NodeID 
The NodeID provides a unique number for each node in the dendrogram. 
  
ParentID 
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Combined with the NodeID, the ParentID determines the hierarchy of the dendrogram. For each 
NodeID, the corresponding ParentID states which node is its parent. For example, node 2 has 
the parent 6, which in turn has parent 7, which in turn has parent 10, which in turn has parent -1. 
Since -1 is not present in the NodeID column, that means -1 is a root node. Note that there can 
be several root nodes. Every unique ParentID that does not match a NodeID will be interpreted 
as a root node. 
  
PruningLevel 
The PruningLevel is additional information, needed to interpret prunings as cluster columns. 
From a PruningLevel, the system finds the associated closest node in a pruning perspective as 
follows: Think of all rows as branches. Prune all branches < PruningLevel. Then you will have 
a set of remaining nodes. Then remove all nodes whose parent is among the remaining nodes. 
In the example above, this means: 

• Prune at level 0  ->  One node (10) will be found. 
• Prune at level 1  ->  Two nodes (7, 9) will be found. 
• Prune at level 2  ->  Four nodes (0, 5, 6, 8) will be found. 
• Prune at level 3  ->  Six nodes (0, 1, 2, 3, 4, 5) will be found, all leaves. 

Height 
The Height determines the position of the node. For a row dendrogram as in the example above, 
this means the horizontal position relative the edge of the heat map. In the example, all leaves 
have height 0, thus they begin closest to the heat map. Each parent must have an increasing 
value, as they come closer to the root of the dendrogram. 
At first glance, the height of each node might not mean much. But there are ways of making this 
attribute take on more meaning. For example, by using TIBCO Spotfire Statistics Services to 
calculate a dendrogram, you can assign values to the height of each node, that indicates how 
well each node correlates to its cluster. For example, a short height could indicate that the node 
correlates well, whereas a longer height could indicate that the node is an outlier. 

 
  
LeafOrder 
Each row that is a leaf, must have a LeafOrder number. These numbers state the order of the 
leaves. Nodes that are not leaves have an empty value. 
  
Additional leaf identifier column(s) 
Additional columns in the dendrogram data table are leaf identifier columns. In the example 
above, there is only one identifier column, but it is quite possible to have several. The leaf 
identifier columns are used to match and sort the heat map. 
  
Concerning R: 
R is available under separate open source software license terms and is not part of TIBCO 
Spotfire.  As such, R is not within the scope of your license for TIBCO Spotfire. R is not 
supported, maintained, or warranted in any way by TIBCO Software Inc.  Download and use of 
R is solely at your own discretion and subject to the free open source license terms applicable to 
R. 



TIBCO Spotfire 4.0.2 - User's Manual 

492 

4.12.5 Heat Map Properties 

4.12.5.1 Heat Map Properties 
The Heat Map Properties dialog consists of several pages: 

• General 
• Data 
• Fonts 
• Cell Values 
• X-axis 
• Y-axis 
• Colors 
• Sorting 
• Tooltip 
• Legend 
• Trellis 
• Dendrograms 

► To reach the Heat Map Properties dialog: 
1. Right-click on the heat map visualization. 
2. Select Properties from the pop-up menu. 

Comment: You can also click on the heat map visualization to make it active and then 
select Edit > Visualization Properties. 

4.12.5.2 Heat Map Properties - General 
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Option Description 

Title The title of the visualization. 
Tip: Double-click on the title bar of the visualization for a shortcut to 
this field. 

Show title bar Specifies whether or not to show the visualization title. 

Description A description of the visualization. This description can optionally be 
shown in the legend and/or in the visualization. 

Show description 
in visualization 

Specifies whether or not to show the description in the visualization. 

4.12.5.3 Heat Map Properties - Data 

 

Option Description 

Data table Specifies the data table on which the visualization will work. 

Marking Specifies the marking (that is, the color and relationships to other 
marked items) that will be used to mark items in this visualization. 

Limit data using 
markings 

Lists the available markings that can be used to limit what is shown in 
this visualization. This means that the visualization only displays data 
that has been marked in other visualizations. 
If more than one marking is selected, you can choose how the data in 
the markings should be combined. 

New... Opens the New Marking dialog where you can specify a new marking. 
The color and name of a previously created marking is edited in the 
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Document Properties dialog. 

Rows must be 
included in 

Specifies how the data in the markings should be combined if you have 
selected to limit the data by more than one marking. 

   All markings 
(AND) 
   

Use this option if you want this visualization to show the intersection of 
the markings selected in Limit data using markings. This can be used if 
you have two visualizations with different markings and want to see 
which markers are present in both markings. This visualization will 
then show only the data that has been marked using both of the selected 
markings. 

   Any marking 
(OR) 
    

Use this option if you want this visualization to show the union of the 
markings selected in Limit data using markings.  
This can be used if you have two visualizations with different markings 
and want to see which markers are present in either of the two 
markings. This visualization will then show data that has been marked 
using either of the selected markings. 

Limit data using 
filterings 

Defines how different filtering schemes in the analysis should affect 
this visualization. 
Select Use the current filtering from the page if you want the 
visualization to always utilize the filtering scheme that is used on the 
page where the visualization is located. If you move the visualization to 
a new page, then the visualization will automatically start reacting on 
the filtering scheme that is used on the new page.  
Select a specific filtering scheme from the list if you want the 
visualization to always use that filtering scheme. Moving the 
visualization to another page with a different filtering scheme will not 
affect this setting. 
If you select to limit data using more than one filtering scheme, the 
intersection of the filterings will be used. This means that the 
visualization will show only the data that is made visible by all of the 
filtering schemes. 

New... Opens the New Filtering Scheme dialog where you can specify a new 
filtering scheme. 
The color and name of a previously created filtering scheme is edited in 
the Document Properties dialog. 

Limit data using 
expression 

You can limit what data should be available for a certain visualization 
using an expression. If you have defined a limiting expression, it will be 
displayed here. 

Edit... Opens the Limit Data Using Expression dialog where you can define a 
boolean expression to use for limiting the data in this visualization. 
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4.12.5.4 Heat Map Properties - Fonts 

 

Option Description 

Settings for Lists all items for which you can change the font settings. Click to 
select an item in the list to change the font settings for that text in the 
visualization. Press Ctrl and click on more items to change the settings 
for multiple items simultaneously. 

Font Specifies the font to use for the selected items. 

Font style Specifies the font style to use for the selected items. 

Size Specifies the font size to use for the selected items. 
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4.12.5.5 Heat Map Properties - Cell Values 

 

Option Description 

Columns Specifies the columns that should be used to define the actual values in 
the individual cells of the heat map. 
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4.12.5.6 Heat Map Properties - X-axis 

 

Option Description 

Columns Specifies the column or hierarchy to be displayed on the X-axis. 

Settings Opens the Advanced Settings dialog where you can change the scale 
mode from categorical to continuous and vice versa, as well as 
changing the category mode to determine which combinations to 
show. 

Range   

   Min Not applicable to heat map visualizations. Available for continuous 
axes only. 

   Max Not applicable to heat map visualizations. Available for continuous 
axes only. 

   Set to current 
range 

Not applicable to heat map visualizations. Available for continuous 
axes only. 

   Include origin Not applicable to heat map visualizations. Available for continuous 
axes only. 

   Show zoom slider Shows a zoom slider which you can manually manipulate to view only 
those cells in the heat map you are interested in. 

   Show gridlines Specifies whether or not vertical gridlines should be visible. 

   Reverse scale Reverses the current sort order so that the lowest value is displayed on 
the right-hand side of the scale. 
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Scale labels   

   Show labels Specifies whether or not scale labels should be visible. 

      Horizontally Shows scale labels horizontally. 

      Vertically Shows scale labels vertically. 

      Max number of 
labels 

Select the check box to specify a maximum number of scale labels to 
be shown. Limiting the number of labels can improve readability on 
axis scales with many values. 

   Position   

      Top Select this option to place the X-axis scale labels on top of the heat 
map. 

      Bottom Select this option to place the X-axis scale labels at the bottom of the 
heat map. 

4.12.5.7 Heat Map Properties - Y-axis 

 

Option Description 

Columns Specifies the column or hierarchy to be displayed on the Y-axis. 

Settings Opens the Advanced Settings dialog where you can change the scale 
mode from categorical to continuous and vice versa, as well as 
changing the category mode to determine which combinations to 
show. 
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Range   

   Min Not applicable to heat map visualizations. Available for continuous 
axes only. 

   Max Not applicable to heat map visualizations. Available for continuous 
axes only. 

   Set to current 
range 

Not applicable to heat map visualizations. Available for continuous 
axes only. 

   Include origin Not applicable to heat map visualizations. Available for continuous 
axes only. 

   Show zoom slider Shows a zoom slider which you can manually manipulate to view only 
those cells in the heat map you are interested in. 

   Show gridlines Specifies whether or not horizontal gridlines should be visible. 

   Reverse scale Reverses the current sort order so that the lowest value is displayed at 
the top of the scale. 

Scale labels   

   Show labels Specifies whether or not scale labels should be visible. 

      Horizontally Shows scale labels horizontally. 

      Vertically Shows scale labels vertically. 

      Max number of 
labels 

Select the check box to specify a maximum number of scale labels to 
be shown. Limiting the number of labels can improve readability on 
axis scales with many values. 

   Position   

      Left Select this option to place the Y-axis scale labels on the left-hand side 
of the heat map. 

      Right Select this option to place the Y-axis scale labels on the right-hand 
side of the heat map. 
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4.12.5.8 Heat Map Properties - Colors 

 

Option Description 

Color by Lists the alternatives by which it is possible to color the heat map. The 
drop-down list contains the columns that are visible on the horizontal 
and vertical axes of the heat map. It also contains the alternative (Cell 
Values) which lets you color the heat map by the column on the cell 
values axis. Select the alternative you wish to color by to set up a color 
scheme and see the available color scheme groupings for that 
alternative. If the cell values axis contains more than one column, you 
can only color by (Cell values) and Color by drop-down list will be 
grayed out. 

Color scheme 
groupings 

Lists the currently available color scheme groupings for the selected 
column. In heat maps, a color scheme is always applied to a color 
scheme grouping. A default color scheme grouping named Numeric is 
always available for each of the columns in the heat map. Before any 
new color scheme groupings have been added, the default grouping 
contains all the values in the selected column. Click on a grouping in 
the list to select it and see its defined color scheme in the lower part of 
the dialog. To learn more about color scheme groupings and coloring 
in heat maps, see Coloring in Cross Tables and Heat Maps. 

Add Opens a menu which lets you add a new color scheme grouping. The 
menu option Color Scheme Grouping... opens the Add Color Scheme 
Grouping dialog, in which you can select values in the selected 
column to include in the new grouping. You can also give the 
grouping a descriptive name. The menu also lists all the values in the 
selected column as separate menu options. If you select one of these 
values from the menu, a grouping containing only that value will be 
added. 
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Edit... Opens the Edit Color Scheme Grouping dialog which lets you modify 
an existing grouping. You cannot edit the default grouping named 
Numeric. 

Remove Removes the selected color scheme grouping from the list. You cannot 
remove the default grouping named Numeric. 

Color mode Specifies in which color mode to set up the color scheme. You can 
select one of the following color modes: Gradient, Segments, Fixed, or 
Unique values. To learn more about the color modes, see Color Modes 
Overview. 

One scale per Specifies whether there should be one separate scale for each axis 
value, or if one scale should apply to the entire color scheme grouping. 
You can also select to use one scale for each trellis panel for trellised 
heat maps, as well as one scale for each trellis panel and each axis 
value in the trellis panel. 

 
[Color Schemes 
menu] 

Opens a menu where you can select an already existing color scheme 
and apply it to the visualization, or apply the currently open color 
scheme to another visualization in the analysis. 

   From 
Visualization 

Lets you select a color scheme from another visualization in the 
analysis. Only color schemes applicable to the current color scheme 
grouping will be listed. 

   Document Color 
Schemes 

Lets you select a color scheme that has previously been saved within 
the analysis. Only color schemes applicable to the current color 
scheme grouping will be listed. This menu option is only available if 
one or more document color schemes already exist. 

   [Predefined color 
schemes] 

Lists a number of predefined color schemes. For a full description of 
the predefined color schemes, see Predefined Color Schemes. 
Tip: To facilitate setting up a new color scheme, you can open a 
predefined color scheme with a similar appearance, and then adjust it 
to suit your needs. 

   Open from 
Library... 

Opens the Open from Library dialog where you can select a color 
scheme that has previously been saved to the library. 

  Open from File... Opens a dialog where you can select a previously saved color scheme. 

   Save As Lets you save a color scheme as a library item, a local file or a 
document color scheme. 
Library Item – Opens the Save as Library Item dialog, where you can 
specify a location in the library and a file name to save the currently 
open color scheme for later reuse. 
File – Opens a dialog where you can specify a location and a file name 
to save your currently open color scheme locally on your computer for 
later reuse. 
Document Color Scheme – Opens the Save as Document Color 
Scheme dialog, where you can specify a name and save the currently 
open color scheme for later reuse within the analysis. 

   Apply to 
Visualizations... 

Opens the Apply to Visualizations dialog where you can select other 
visualizations (within the analysis) that you want to apply the current 
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color scheme to. Only visualizations with compatible color schemes 
are listed. 
Note: If you apply a color scheme to a table, cross table, or heat map, 
the coloring will not take effect immediately. The color scheme will be 
added as an empty color scheme grouping, and you must select which 
columns or axis values to include in the grouping by opening the Edit 
Color Scheme Grouping dialog. 

[Color scheme area] The area in the lower part of the dialog shows the current color 
scheme. That is, the colors and values currently used for the selected 
color scheme grouping. You can modify color schemes in numerous 
ways to give the visualization the appearance you prefer. The color 
scheme area will look different, and have different available settings, 
depending on the characteristics of the color scheme grouping, as well 
as the selected color mode. To learn more about color schemes and 
color modes, see Color Schemes Overview and Color Modes 
Overview respectively. 

Add Point Adds a new anchor point to the color scheme. 

Delete Point Deletes the selected anchor point. 

Add Rule... Opens the Add Rule dialog where you can define a rule that functions 
as an exception to the rest of the defined color scheme. A rule has 
higher priority than the rest of the color scheme. For example, you can 
define a rule to give the top five items in your data a different color 
than the rest of the items. If you add many rules to a color scheme, the 
rules are prioritized from top to bottom. Which rule types are available 
depends on the characteristics of the color scheme grouping. See 
Details on Add/Edit Rule for full descriptions of the rule types. 

Reset Resets the color scheme to the one that was in effect when the 
visualization was created. Any added rules will be removed. Which 
color scheme should be used by default when you create a new 
visualization is defined in the Visualization page of the Options 
dialog. 
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4.12.5.9 Heat Map Properties - Sorting 

 

Option Description 

Sort by Specifies which column to sort the heat map by. 

   Ascending Sorts the heat map by the selected column title in ascending order. 

   Descending Sorts the heat map by the selected column title in descending order. 
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4.12.5.10 Heat Map Properties - Tooltip 

 

Option Description 

Display the 
following values 

Specifies what will be shown in the tooltip. 

Add... Opens the Add Tooltip Value dialog, where you can add the content 
from another column, hierarchy, or any custom expression to be 
shown in the tooltip. 

Edit... Opens the Edit Tooltip Value dialog, where you can change the 
expression or the name to be shown in the tooltip. 

Delete Deletes the selected value from the list. 

Move Up Moves the selected value up in the list as well as up in the tooltip. 

Move Down Moves the selected value down in the list as well as down in the 
tooltip. 

Tooltip format   

   Value names and 
values 

Shows the tooltip content in a format where the selected column name, 
hierarchy or custom expression is displayed. For example, Year: 2003, 
Type: Cucumber, etc. 

   Visualization 
properties and 
values 

Shows the tooltip content in a format where the visualization property 
for each value is displayed. For example, X: 2003, Color: Cucumber, 
etc. 
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4.12.5.11 Heat Map Properties - Legend 

 

Option Description 

Show legend Specifies whether or not the docked legend should be shown in the 
visualization. 

Position Specifies which side of the visualization the legend should be 
positioned: the right-hand side or the left-hand side. 

Display the 
following legend 
items 

Specifies what will be shown in the legend.  
By clearing a check box you will completely hide that item from the 
legend. You can also select to show or hide parts of the legend 
information using the check boxes under Settings for the selected item 
in the list, see below. 

Settings Defines how the selected legend item should be displayed. The 
available options vary between legend items. 

   Show title Use this option to show or hide the title for the selected item. The title 
is typically what is displayed above an axis selector or similar: 

 

   Show axis 
selector 

Select this option to show or hide the axis selector for the selected item.  
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4.12.5.12 Heat Map Properties - Trellis 

 

Option Description 

Rows and columns Splits the visualization into different panels for all categories in the 
selected column or hierarchy. The number of values in the specified 
column or hierarchy controls the number of panels to be displayed in 
each row, column, or page, respectively. 

   Rows A row with trellis panels will be created for each value in the selected 
column or hierarchy. 

   Columns A column with trellis panels will be created for each value in the 
selected column or hierarchy. 

   Pages A new page with trellis panels will be created for each value in the 
selected column or hierarchy. Scroll down in the visualization to see 
the next page. 

Panels Splits the visualization into different panels for all categories in the 
selected column or hierarchy, without binding any dimensions to either 
rows or columns. This means that the number of actual values in the 
column to split by does not control the number of shown rows or 
columns in any way. 
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The number of panels that should be visible on each page is instead 
specified using the Max number of rows and Max number of columns 
controls below. 

   Split by Specifies the column or hierarchy to define the categories by which the 
visualization should be split. 

   Manual layout Select the check box to manually specify the number of rows and 
columns that should be visible without scrolling. If the check box is 
cleared, the application will automatically specify the number of rows 
and columns. 

   Max number of 
rows 

Specifies the maximum number of panels that should be visible on 
each page. 

   Max number of 
columns 

Specifies the maximum number of panels that should be visible on 
each page. 

Settings... Opens the Advanced Settings dialog where you can change the 
category mode to determine which combinations to show. 

4.12.5.13 Heat Map Properties - Dendrograms 
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Option Description 

Settings for Select whether to define settings for a row dendrogram or a 
column dendrogram. The controls in the rest of the dialog are 
adapted to the dendrogram type you choose. 

   Update Click this button to update the dendrogram. 

   Show row/column 
dendrogram 

Select this check box to make the dendrogram visible in the 
visualization. When this check box is selected the controls in 
the lower part of the dialog are available. 
Note: To make the dendrogram visible the first time, it must be 
updated. Click the Update button, or choose automatic updates. 

Source   

   Calculated hierarchical 
clustering 

Choose this option if you want the dendrogram to be drawn 
based on a hierarchical clustering calculation. 

      Settings... Opens the Edit Clustering Settings dialog where you can define 
which distance measure, clustering method, and ordering 
weight to use for the clustering calculation. You can also define 
a normalization method and a method to use for replacing 
empty values. 
Note: If you change the settings and have chosen to update the 
dendrogram manually, you will need to do so afterwards. 
To learn more about hierarchical clustering, see Overview of 
Hierarchical Clustering Theory. To learn more about 
normalization, see Normalizing Columns. 

      Export... Opens the Export Dendrogram dialog where you can specify a 
name for the exported dendrogram. 

   Imported Choose this option if you want to use a dendrogram from a 
previously performed clustering. 

Update dendrogram   

   Manually Use this option if you want to control when the dendrogram is 
updated. You must update each time you have changed any 
clustering settings. Otherwise the dendrogram will not be valid. 

   Automatically Use this option if you want the dendrogram to be updated 
automatically when you change any clustering settings. 

Position Defines on which side of the heat map the dendrogram should 
be placed. 

   Top Places the dendrogram above the heat map. Available for 
column dendrograms. 

   Bottom Places the dendrogram below the heat map. Available for 
column dendrograms. 

   Left Places the dendrogram to the left of the heat map. Available for 
row dendrograms. 



Visualizations 

509 

   Right Places the dendrogram to the right of the heat map, Available 
for row dendrograms. 

Appearance   

   Use log scale Changes the scale from a linear scale to a logarithmic base 10 
scale [log10 (x)]. 

   Show pruning line Specifies whether or not to show a pruning line in the 
dendrogram. 

   Pruning line color Specifies the color to use for the pruning line in the 
dendrogram. 

   First alternating cluster 
color 

Specifies the first color to use for the clusters when pruning in 
the dendrogram. 

   Second alternating 
cluster color 

Specifies the second color to use for the clusters when pruning 
in the dendrogram. 

4.12.5.14 Details on Edit Clustering Settings 

► To reach the Edit Clustering Settings dialog from the Heat Map 
Properties dialog: 
1. In the Visualization Properties dialog of the heat map, go to the Dendrograms page. 
2. Under Settings for, select either Row dendrogram or Column Dendrogram from the 

drop-down list. 
3. Select the check box Show row dendrogram or Show column dendrogram 

depending on the kind of dendrogram you selected in the drop-down list. 
Response: The settings for the selected dendrogram become active in the bottom part 
of the dialog. 

4. Under Source, click the Calculated hierarchical clustering radio button. 
5. Click Settings.... 

► To reach the Edit Clustering Settings dialog from the 
Hierarchical Clustering dialog: 
1. From the Tools menu, select Hierarchical Clustering.... 

Response: The Hierarchical Clustering dialog is opened. 
2. Select the check box Cluster rows or Cluster columns depending on the kind of 

dendrogram you want to create. 
3. Click the corresponding Settings... button. 
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Option Description 

Clustering method Specifies the clustering method to use for calculating the similarity 
between clusters. 

Distance measure Specifies which distance measure to use for the clustering calculation. 

Ordering weight Specifies the ordering weight to use for the clustering calculation. 

Empty value 
replacement 

  

   Method Defines how empty values in the data set should be replaced in the 
clustering calculation. 
Constant value – replaces the value by a constant number. 
Column average – returns the average of the corresponding column 
values. If the column contains only empty values, they will be replaced 
by 0, since it is not possible to calculate an average. 
Row average – replaces the value by the average value of the entire 
row. If the row contains only empty values, they will be replaced by 0, 
since it is not possible to calculate an average. 
Row interpolation – sets the missing value to the interpolated value 
between the two neighboring values in the row. 

   Replace with Specifies the constant value to replace all empty values by when using 
the Constant value replacement method. 
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Normalization   

   Method Specifies the normalization method to use. See Normalizing Columns 
and the detailed description for each method for further information 
about the various methods. 

   Percentage Specifies the percentage value to use when normalizing by percentile 
or by trimmed mean. 

Note: If you select Ward's method as the clustering method, the distance measure will 
automatically be set to Half square Euclidean distance. No other distance measure can be used 
with Ward's method. 

4.12.5.15 Details on Export Dendrogram 

► To reach the Export Dendrogram dialog: 
1. In the Visualization Properties dialog of the heat map, go to the Dendrograms page. 
2. Under Settings for, select either Row dendrogram or Column Dendrogram from the 

drop-down list. 
3. Select the check box Show row dendrogram or Show column dendrogram 

depending on the kind of dendrogram you selected in the drop-down list. 
Response: The settings for the selected dendrogram become active in the bottom part 
of the dialog. 
Under Source, click the Calculated hierarchical clustering radio button. 
Click the Export... button. 

 

Option Description 

Data table name Type a name for the exported dendrogram. 
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4.13 Parallel Coordinate Plot 
4.13.1 What is a Parallel Coordinate Plot? 

A parallel coordinate plot maps each row in the data table as a line, or profile. Each attribute of 
a row is represented by a point on the line. This makes parallel coordinate plots similar in 
appearance to line charts, but the way data is translated into a plot is substantially different. 
Consider, for example, a data table where a laboratory has measured the amount of various 
carbohydrates contained in various fruit and vegetables. 

 
For each food type, it is now possible to plot a profile of how the carbohydrates are distributed. 
The technicians in the laboratory can now see which food types are similar to each other in 
carbohydrate distribution, by comparing the profiles to each other. This is where the parallel 
coordinate plot is really useful, to compare profiles in order to find similarities. 

 
The values in a parallel coordinate plot are always normalized. This means that for each point 
along the X-axis, the lowest value in the corresponding column is set to 0% and the highest 
value in that column is set to 100% along the Y-axis. The scale of the various columns is totally 
separate, so do not compare the height of the curve in one column to the height of the curve in 
another column. 
This becomes more apparent when looking at another example. This data table contains 
information about some models of computer monitors. As you see, the data in the various 
columns are of completely different types and totally incomparable to each other. They are 
however, perfect for a parallel coordinate plot, which normalizes the data in each column and 
simply plots the lowest value as 0% and the highest as 100%. 

 
This gives us a profile for each computer monitor, which we can compare to the other profiles, 
and try to spot a monitor that fits our needs. 



Visualizations 

513 

 
Perhaps we think that the Sazozi 14p monitor (the orange marked profile) is a good buy, since it 
has a medium sized screen, it is a new flat screen, it has an average warranty period, and seems 
to cost a bit but not in the very highest price range. 
All visualizations except the map chart can be set up to show data limited by one or more 
markings in other visualizations only (details visualizations). They can also be limited by one or 
more filterings. Another alternative is to set up a visualization without any filtering at all. See 
Limiting What is Shown in Visualizations for more information. 

4.13.2 How to Use the Parallel Coordinate Plot 
► To set up a new parallel coordinate plot: 

1. Click on the New Parallel Coordinate Plot button on the toolbar, . 
Comment: You can also select Insert > New Visualization > Parallel Coordinate 
Plot from the menu. 
Response: A first attempt to set up a suitable parallel coordinate plot is made by the 
application. 

2. Adjust the parallel coordinate plot to display the columns of your choice, by right-
clicking in the visualization and selecting Properties. 

3. Select Columns. 
4. Add/Remove the columns you want to appear on the X-axis. 
5. Click Close. 

► To apply coloring: 
1. In the Filters panel, click and hold down the left mouse button on the filter 

representing the column that you want to color by. 
Comment: Coloring is also available in the Visualization Properties dialog. The color 
of marked items is changed under Edit > Document Properties. 

2. Drag the filter to the center of the visualization. 
Response: Drop targets appear in the middle of the visualization. 

3. Release the mouse button on the Color target. 
Response: The lines are colored with one color for each category in the selected 
column. If the lines have not been previously split by adding a Line By column, the 
lines will be split according to the color categories. 
Comment: To learn more about coloring in Spotfire, see Coloring Overview. 
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4.13.3 Parallel Coordinate Plot Properties 

4.13.3.1 Parallel Coordinate Plot Properties 
The Parallel Coordinate Plot Properties dialog consists of several pages: 

• General 
• Data 
• Appearance 
• Formatting 
• Fonts 
• Scale Labels 
• Columns 
• Colors 
• Labels 
• Tooltip 
• Legend 
• Trellis 
• Line By 

► To reach the Parallel Coordinate Plot Properties dialog: 
1. Right-click on the Parallel Coordinate Plot Properties visualization. 
2. Select Properties from the pop-up menu. 

Comment: You can also click on the parallel coordinate plot visualization to make it 
active and then select Edit > Visualization Properties. 

4.13.3.2 Parallel Coordinate Plot Properties - General 
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Option Description 

Title The title of the visualization. 
Tip: Double-click on the title bar of the visualization for a shortcut to 
this field. 

Show title bar Specifies whether or not to show the visualization title. 

Description A description of the visualization. This description can optionally be 
shown in the legend and/or in the visualization. 

Show description 
in visualization 

Specifies whether or not to show the description in the visualization. 

4.13.3.3 Parallel Coordinate Plot Properties - Data 

 

Option Description 

Data table Specifies the data table on which the visualization will work. 

Marking Specifies the marking (that is, the color and relationships to other 
marked items) that will be used to mark items in this visualization. 

Limit data using 
markings 

Lists the available markings that can be used to limit what is shown in 
this visualization. This means that the visualization only displays data 
that has been marked in other visualizations. 
If more than one marking is selected, you can choose how the data in 
the markings should be combined. 

New... Opens the New Marking dialog where you can specify a new marking. 
The color and name of a previously created marking is edited in the 
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Document Properties dialog. 

Rows must be 
included in 

Specifies how the data in the markings should be combined if you have 
selected to limit the data by more than one marking. 

   All markings 
(AND) 
   

Use this option if you want this visualization to show the intersection of 
the markings selected in Limit data using markings. This can be used if 
you have two visualizations with different markings and want to see 
which markers are present in both markings. This visualization will 
then show only the data that has been marked using both of the selected 
markings. 

   Any marking 
(OR) 
    

Use this option if you want this visualization to show the union of the 
markings selected in Limit data using markings.  
This can be used if you have two visualizations with different markings 
and want to see which markers are present in either of the two 
markings. This visualization will then show data that has been marked 
using either of the selected markings. 

Limit data using 
filterings 

Defines how different filtering schemes in the analysis should affect 
this visualization. 
Select Use the current filtering from the page if you want the 
visualization to always utilize the filtering scheme that is used on the 
page where the visualization is located. If you move the visualization to 
a new page, then the visualization will automatically start reacting on 
the filtering scheme that is used on the new page.  
Select a specific filtering scheme from the list if you want the 
visualization to always use that filtering scheme. Moving the 
visualization to another page with a different filtering scheme will not 
affect this setting. 
If you select to limit data using more than one filtering scheme, the 
intersection of the filterings will be used. This means that the 
visualization will show only the data that is made visible by all of the 
filtering schemes. 

New... Opens the New Filtering Scheme dialog where you can specify a new 
filtering scheme. 
The color and name of a previously created filtering scheme is edited in 
the Document Properties dialog. 

Limit data using 
expression 

You can limit what data should be available for a certain visualization 
using an expression. If you have defined a limiting expression, it will be 
displayed here. 

Edit... Opens the Limit Data Using Expression dialog where you can define a 
boolean expression to use for limiting the data in this visualization. 
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4.13.3.4 Parallel Coordinate Plot Properties - Appearance 

 

Option Description 

Line width Specifies the width of the lines in the parallel coordinate plot. 

Break lines on 
empty values 

Determines whether lines should be broken or remain connected when 
an empty value is found in the data used to create the line. 

Show column 
zoom slider 

Shows a zoom slider that you can manually manipulate to view only 
the interesting columns in the parallel coordinate plot. 
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4.13.3.5 Parallel Coordinate Plot Properties - Formatting 

 

Option Description 

Selected columns Lists the columns visible in the parallel coordinate plot as well as the 
formatting category currently being used on each of the columns. Click 
on the one you want to change the settings for. If the columns on the 
axes are of the same type, you can set formatting for both axes at the 
same time. 

Reset Resets the formatting for the selected axis values according to the 
settings defined on column level. If no column formatting has been set, 
axis formatting settings defined in the Options dialog will be used. If 
no settings have been specified in the Options dialog, the default 
settings for the visualization type will be used. 

Category Lists the available formatting categories for the selected column. Each 
category in this list has separate settings. Which categories are 
available depends on the data type of the selected column. See 
Formatting Settings for a full description of all possible options. 

Note: You can only see formatting for the column that is currently visible on the scale. 
Note: These settings affect only the current visualization. For general information about 
formatting, see Formatting Overview. 
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4.13.3.6 Parallel Coordinate Plot Properties - Fonts 

 

Option Description 

Settings for Lists all items for which you can change the font settings. Click to 
select an item in the list to change the font settings for that text in the 
visualization. Press Ctrl and click on more items to change the settings 
for multiple items simultaneously. 

Font Specifies the font to use for the selected items. 

Font style Specifies the font style to use for the selected items. 

Size Specifies the font size to use for the selected items. 
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4.13.3.7 Parallel Coordinate Plot Properties - Scale Labels 

 

Option Description 

Left scale 
(percentage) 

Defines the properties of the scale labels on the left Y-axis. 

Right scale 
(selected column) 

Defines the properties of the scale labels on the right Y-axis. This axis 
shows the values of the column that has been selected by clicking on 
its column name on the X-axis in the visualization. 

Columns Defines the properties of the scale labels displaying the names of the 
columns included in the visualization. 

[For each scale 
above] 

  

     Show labels Specifies whether or not scale labels should be displayed on this axis. 
Click the radio button to display the labels Horizontally or Vertically. 

     Max number of 
labels 

Specifies the maximum number of scale labels to be shown on this 
axis. 
Select the check box that is available for the right scale settings if you 
want to specify a maximum number of scale labels to be shown. 
Limiting the number of labels can improve readability on an axis scale 
with many values. 

     Show gridlines Specifies whether or not gridlines should be shown for this axis. 
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4.13.3.8 Parallel Coordinate Plot Properties - Columns 

 

Option Description 

Available columns Lists all columns in the data table which are available for selection. 

Selected columns Lists the columns selected to be displayed in the parallel coordinate 
plot, as well as the selected aggregation method used on each column 
(if any aggregation has been specified). 

Add > Adds the columns selected in the Available columns list to the 
Selected columns list. 

< Remove Removes the selected columns from the Selected columns list and 
sends them back to the Available columns list. 

Remove All Removes all columns from the Selected columns list. 

Move Up Moves the selected column up in the Selected columns list. The order 
of the columns in this list determines the order of the Y-axes in the 
parallel coordinate plot. 

Move Down Moves the selected column down in the Selected columns list. The 
order of the columns in this list determines the order of the Y-axes in 
the parallel coordinate plot. 

Aggregation Click on one or more columns in the Selected columns list to make this 
option available. Specifies the aggregation method to use for the 
selected column. 

Auto-bin column Click on one or more columns in the Selected columns list to make this 
option available. Select the check box to temporarily group the values 
of a numeric column into a specified number of categorical bins. 
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Note: To create a new column with binned values, see How to Use 
Binning instead. 

Number of bins Click on one or more columns in the Selected columns list to make this 
option available. Specifies the number of bins into which the values of 
a numeric column should be grouped. 

4.13.3.9 Parallel Coordinate Plot Properties - Colors 

 

Option Description 

Columns Specifies the column or hierarchy to color by. 

Settings Opens the Advanced Settings dialog where you can change the scale 
mode for the selected column or hierarchy from continuous to 
categorical and vice versa, as well as changing the category mode to 
determine which combinations to show. 

Color mode Specifies in which color mode to set up the color scheme. Which 
modes are available depends on whether the scale is in categorical or 
continuous mode. For columns in continuous scale mode, you can 
select one of the following color modes: Gradient, Segments, Fixed, or 
Unique values. For columns in categorical scale mode, you can select 
either Categorical or Fixed color mode. To learn more about the color 
modes, see Color Modes Overview. 

One scale per Specifies whether there should be one separate scale per trellis panel 
for trellised parallel coordinate plots, or if one scale should apply to 
the entire visualization. Only applicable to columns in continuous 
scale mode. 
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[Color Schemes 
menu] 

Opens a menu where you can select an already existing color scheme 
and apply it to the visualization, or apply the currently open color 
scheme to another visualization in the analysis. 

   From 
Visualization 

Lets you select a color scheme from another visualization in the 
analysis. Only color schemes that are applicable to the current color 
scheme will be listed. 

   Document Color 
Schemes 

Lets you select a color scheme that has previously been saved within 
the analysis. Only color schemes that are applicable to the current 
color scheme will be listed. This menu option is only available if one 
or more document color schemes already exist. 

   [Predefined color 
schemes] 

Lists a number of predefined color schemes. Available for columns in 
continuous scale mode only. For a full description of the predefined 
color schemes, see Predefined Color Schemes. 
Tip: To facilitate setting up a new color scheme, you can open a 
predefined color scheme with a similar appearance, and then adjust it 
to suit your needs. 

   Open from 
Library... 

Opens the Open from Library dialog where you can select a color 
scheme that has previously been saved to the library. 

   Open from File... Opens a dialog where you can select a previously saved color scheme. 

   Save As Lets you save a color scheme as a library item, a local file or a 
document color scheme. 
Library Item – Opens the Save as Library Item dialog, where you can 
specify a location in the library and a file name to save the currently 
open color scheme for later reuse. 
File – Opens a dialog where you can specify a location and a file name 
to save your currently open color scheme locally on your computer for 
later reuse. 
Document Color Scheme – Opens the Save as Document Color 
Scheme dialog, where you can specify a name and save the currently 
open color scheme for later reuse within the analysis. 

   Apply to 
Visualizations... 

Opens the Apply to Visualizations dialog where you can select other 
visualizations (within the analysis) that you want to apply the current 
color scheme to. Only visualizations with compatible color schemes 
are listed. 
Note: If you apply a color scheme to a table, cross table, or heat map, 
the coloring will not take effect immediately. The color scheme will be 
added as an empty color scheme grouping, and you must select which 
columns or axis values to include in the grouping by opening the Edit 
Color Scheme Grouping dialog. 

[Color scheme area] The area in the lower part of the dialog shows the current color 
scheme. That is, the colors and values currently used in the 
visualization. You can modify color schemes in numerous ways to 
give the visualization the appearance you prefer. The color scheme 
area will look different, and have different available settings, 
depending on the characteristics of the column used to color the 
visualization by, as well as the selected color mode. To learn more 
about color schemes and color modes, see Color Schemes Overview 
and Color Modes Overview respectively. 
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Add Point Available for continuous columns only. Adds a new anchor point to 
the color scheme. 

Delete Point Available for continuous columns only. Deletes the selected anchor 
point. 

Add Rule... Opens the Add Rule dialog where you can define a rule that functions 
as an exception to the rest of the defined color scheme. A rule has 
higher priority than the rest of the color scheme. For example, you can 
define a rule to give the top five items in your data a different color 
than the rest of the items. If you add many rules to a color scheme, the 
rules are prioritized from top to bottom. Which rule types are available 
depends on the characteristics of the column or hierarchy used to color 
the visualization by. See Details on Add/Edit Rule for full descriptions 
of the rule types. 

Reset Resets the color scheme to the one that was in effect when the 
visualization was created. Any added rules will be removed. Which 
color scheme should be used by default when you create a new 
visualization is defined in the Visualization page of the Options 
dialog. 

 

4.13.3.10 Parallel Coordinate Plot Properties - Labels 

 

Option Description 

Show in labels   

   Line identifier Displays labels showing the categories used to create each line (by 
coloring or line by). 
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   Individual values Displays labels showing the values for all points used to create the line. 

Show labels for Determines whether to show labels on all lines (All), lines containing 
marked rows only (Marked rows), or not to show any labels at all 
(None). 

Max number of 
labels 

Specifies the maximum number of labels to be shown. 

4.13.3.11 Parallel Coordinate Plot Properties - Tooltip 

 

Option Description 

Display the 
following values 

Specifies what will be shown in the tooltip. 

Add... Opens the Add Tooltip Value dialog, where you can add the content 
from another column, hierarchy, or any custom expression to be 
shown in the tooltip. You can also use images in tooltips. See 
Highlighting in Visualizations for more information. 

Edit... Opens the Edit Tooltip Value dialog, where you can change the 
information to be shown in the tooltip. 

Delete Deletes the selected value from the list. 

Move Up Moves the selected value up in the list and, hence, up in the tooltip. 

Move Down Moves the selected value down in the list and, hence, down in the 
tooltip. 
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Tooltip format   

   Value names and 
values 

Shows the tooltip content in a format where the selected column name, 
hierarchy or custom expression is displayed. For example, Year: 2003, 
Type: Cucumber, etc. 

   Visualization 
properties and 
values 

Shows the tooltip content in a format where the visualization property 
for each value is displayed. For example, X: 2003, Color: Cucumber, 
etc. 

4.13.3.12 Parallel Coordinate Plot Properties - Legend 

 

Option Description 

Show legend Specifies whether or not the docked legend should be shown in the 
visualization. 

Position Specifies which side of the visualization the legend should be 
positioned: the right-hand side or the left-hand side. 

Display the 
following legend 
items 

Specifies what will be shown in the legend.  
By clearing a check box you will completely hide that item from the 
legend. You can also select to show or hide parts of the legend 
information using the check boxes under Settings for the selected item 
in the list, see below. 

Settings Defines how the selected legend item should be displayed. The 
available options vary between legend items. 

   Show title Use this option to show or hide the title for the selected item. The title 
is typically what is displayed above an axis selector or similar: 
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   Show axis 
selector 

Select this option to show or hide the axis selector for the selected item.  

 

4.13.3.13 Parallel Coordinate Plot Properties - Trellis 

 

Option Description 

Rows and columns Splits the visualization into different panels for all categories 
in the selected column or hierarchy. The number of values in 
the specified column or hierarchy controls the number of 
panels to be displayed in each row, column, or page, 
respectively. 

   Rows A row with trellis panels will be created for each value in the 
selected column or hierarchy. 

   Columns A column with trellis panels will be created for each value in 
the selected column or hierarchy. 
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   Pages A new page with trellis panels will be created for each value in 
the selected column or hierarchy. Scroll down in the 
visualization to see the next page. 

Panels Splits the visualization into different panels for all categories 
in the selected column or hierarchy, without binding any 
dimensions to either rows or columns. This means that the 
number of actual values in the column to split by does not 
control the number of shown rows or columns in any way. 
The number of panels that should be visible on each page is 
instead specified using the Max number of rows and Max 
number of columns controls below. 

   Split by Specifies the column or hierarchy to define the categories by 
which the visualization should be split. 

   Manual layout Select the check box to manually specify the number of rows 
and columns that should be visible without scrolling. If the 
check box is cleared, the application will automatically specify 
the number of rows and columns. 

   Max number of rows Specifies the maximum number of panels that should be 
visible on each page. 

   Max number of columns Specifies the maximum number of panels that should be 
visible on each page. 

Settings... Opens the Advanced Settings dialog where you can change the 
category mode to determine which combinations to show. 

4.13.3.14 Parallel Coordinate Plot Properties - Line By 
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Option Description 

Show one line for 
each 

Specifies the column or hierarchy by which the lines should be split. 
Note: If the lines are being colored by a column or hierarchy with 
more categories than the one selected here, there will be no visible 
effect from this operation, since the coloring has already split the lines 
more granularly. 

Currently also 
split by the 
following 
properties 

Displays information about what other properties currently contribute 
to a splitting of the lines. 
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4.14 Summary Table 
4.14.1 What is a Summary Table? 

The summary table is a visualization that summarizes statistical information about data in table 
form. The information is based on one data table in TIBCO Spotfire. You can, at any time, 
choose which measures you want to see (such as mean, median, etc.), as well as the columns on 
which to base these measures. As you change the set of filtered rows, the Summary Table 
automatically updates the values displayed to reflect the current selection. 

 
All visualizations except the map chart can be set up to show data limited by one or more 
markings in other visualizations only (details visualizations). They can also be limited by one or 
more filterings. Another alternative is to set up a visualization without any filtering at all. See 
Limiting What is Shown in Visualizations for more information. 
  

4.14.2 How to Use the Summary Table 
► To set up the summary table: 

1. Select the filters that represent the columns you want to add to your summary table. 
2. Drag that filters into the summary table. 

Response: Two drop-targets are displayed. 
  

3. Drop the filters onto the leftmost drop-target, . This will show measures for all 
of the selected columns in the summary table. 

4. Optionally, if you want separate statistics for different subsets of data, select the 
desired categorical column from the filters panel and drop it onto the categorization 

drop-target, . This column should not contain a large number of unique values, 
since it will be used to split the selected columns into categories. 
Comment: You can also use the Columns page of the Visualization Properties dialog to 
set up the summary table. 
Note: If a calculated column is added in Spotfire, it will automatically be included in 
the summary table. 

► To sort the summary table: 
1. Click on the header for the measure by which you wish to sort the summary table. 

Response: The columns are sorted in an ascending order by that measure.  If 
categorization is applied, the values for the different categories are sorted within each 
column. 
Comment: Click again to sort in a descending order, and click once more to return to 
the original sort order. 

► To change the order of the measures in the summary table: 
1. Right-click on a measure header and select Properties. 
2. Select the Statistical measures page in the dialog. 
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3. Select the measure you wish to move and click Move Up or Move Down. Repeat for 
other measures until you obtain the desired order. 
Comment: You can also right-click on a column header and select Move First or 
Move Last from the pop-up menu. 

► To remove measures: 
1. Right-click on a measure header and select Remove. 

Response: The measure is removed from the table. 

► To add measures: 
1. Right-click on the summary table and select Properties. 
2. Select the Statistical measures page in the dialog. 
3. Select the measures you want to insert from the Available measures list. 
4. Click Add >. 

Response: The measure is inserted to the right of all previously added measures. 
Comment: Click on a measure in the Selected measures list and then click Move Up or 
Move Down to change the order of the measures. 

5. Click Close. 

► To change the measure column width: 
1. Place the mouse pointer at the right edge of the measure header you want to resize. The 

cursor changes into a cross with arrows. 
2. Adjust the width by holding down the mouse button and moving the mouse 

horizontally. 
Comment: You can also right-click on the desired header and select Column Width... 
from the pop-up menu, if you want to specify a column width in number of pixels. 

► To create a new summary table: 
1. Click on the New Summary Table button on the toolbar, . 

Comment: You can also select Insert > New Visualization > Summary Table from 
the menu. 
Response: A first attempt to set up a suitable summary table is made by the 
application. 

2. Adjust the summary table to display the columns and measures of your choice. 

4.14.3 Summary Table Properties 

4.14.3.1 Summary Table Properties 
The Summary Table Properties dialog consists of several pages: 

• General 
• Data 
• Appearance 
• Fonts 
• Columns 
• Sorting 
• Statistical Measures 
• Legend 
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► To reach the Summary Table Properties dialog: 
1. Right-click on the summary table visualization. 
2. Select Properties from the pop-up menu. 

Comment: You can also click on the summary table visualization to make it active and 
then select Edit > Visualization Properties. 

  

4.14.3.2 Summary Table Properties - General 

 

Option Description 

Title The title of the visualization. 
Tip: Double-click on the title bar of the visualization for a shortcut to 
this field. 

Show title bar Specifies whether or not to show the visualization title. 

Description A description of the visualization. This description can optionally be 
shown in the legend and/or in the visualization. 

Show description 
in visualization 

Specifies whether or not to show the description in the visualization. 
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4.14.3.3 Summary Table Properties - Data 

 

Option Description 

Data table Specifies the data table on which the visualization will work. 

Marking Specifies the marking (that is, the color and relationships to other marked 
items) that will be used to mark items in this visualization. 

Limit data using 
markings 

Lists the available markings that can be used to limit what is shown in 
this visualization. This means that the visualization only displays data 
that has been marked in other visualizations. 
If more than one marking is selected, you can choose how the data in the 
markings should be combined. 

New... Opens the New Marking dialog where you can specify a new marking. 
The color and name of a previously created marking is edited in the 
Document Properties dialog. 

Rows must be 
included in 

Specifies how the data in the markings should be combined if you have 
selected to limit the data by more than one marking. 

   All markings 
(AND) 
   

Use this option if you want this visualization to show the intersection of 
the markings selected in Limit data using markings. This can be used if 
you have two visualizations with different markings and want to see 
which markers are present in both markings. This visualization will then 
show only the data that has been marked using both of the selected 
markings. 

   Any marking 
(OR) 
    

Use this option if you want this visualization to show the union of the 
markings selected in Limit data using markings.  
This can be used if you have two visualizations with different markings 
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and want to see which markers are present in either of the two markings. 
This visualization will then show data that has been marked using either 
of the selected markings. 

Limit data using 
filterings 

Defines how different filtering schemes in the analysis should affect this 
visualization. 
Select Use the current filtering from the page if you want the 
visualization to always utilize the filtering scheme that is used on the 
page where the visualization is located. If you move the visualization to 
a new page, then the visualization will automatically start reacting on the 
filtering scheme that is used on the new page.  
Select a specific filtering scheme from the list if you want the 
visualization to always use that filtering scheme. Moving the 
visualization to another page with a different filtering scheme will not 
affect this setting. 
If you select to limit data using more than one filtering scheme, the 
intersection of the filterings will be used. This means that the 
visualization will show only the data that is made visible by all of the 
filtering schemes. 

New... Opens the New Filtering Scheme dialog where you can specify a new 
filtering scheme. 
The color and name of a previously created filtering scheme is edited in 
the Document Properties dialog. 

Limit data using 
expression 

You can limit what data should be available for a certain visualization 
using an expression. If you have defined a limiting expression, it will be 
displayed here. 

Edit... Opens the Limit Data Using Expression dialog where you can define a 
boolean expression to use for limiting the data in this visualization. 



Visualizations 

535 

4.14.3.4 Summary Table Properties - Appearance 

 

Option Description 

Show cell borders Specifies whether or not cell borders should be visible between the 
cells in the summary table. 

Allow table data 
export in Web 
Player 

Specifies whether or not a Web Player user is allowed to export the 
data from the summary table. 
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4.14.3.5 Summary Table Properties - Fonts 

 

Option Description 

Settings for Lists all items for which you can change the font settings. Click to 
select an item in the list to change the font settings for that text in the 
visualization. Press Ctrl and click on more items to change the settings 
for multiple items simultaneously. 

Font Specifies the font to use for the selected items. 

Font style Specifies the font style to use for the selected items. 

Size Specifies the font size to use for the selected items. 
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4.14.3.6 Summary Table Properties - Columns 

 

Option Description 

Available columns Lists all columns in the data table available for selection. 

[Type to search] Type a search string to limit the number of items in the Available 
columns list. It is possible to use the wildcard character * in the search. 
See Searching in TIBCO Spotfire for more information. 

Selected columns Lists the columns selected to be displayed in the summary table. 
Note: If a calculated column is added in Spotfire, it will automatically 
be included in the Selected columns list. 

Add > Adds the columns selected in the Available columns list to the 
Selected columns list. 

< Remove Removes the selected columns from the Selected columns list and 
sends them back to the Available columns list. 

Remove All Removes all columns from the Selected columns list. 

Move Up Moves the selected column up in the Selected columns list. The order 
of the columns in this list determines the order of the columns in the 
table. 

Move Down 
  

Moves the selected column down in the Selected columns list. The 
order of the columns in this list determines the order of the columns in 
the table. 

Add new columns 
automatically 

Select the check box to make sure that any new columns added to the 
selected data table are also automatically added to the summary table 
visualization. 
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New columns can appear when refreshing an information link, 
calculating new columns, etc.  

Categorization If selected, specifies a categorical column by which each column 
should be split in the summary table. For example, a column called 
Sales might be interesting to split by the different product categories to 
view Sum of sales for fruits and vegetables separately. 

Settings... Opens the Advanced Settings dialog, where you can change the 
category mode to determine which combinations to show. 
Note: If All values in data (nest) or All possible values (cross) are 
selected, all possible combinations, even empty ones, will be shown 
regardless of filtering. 

4.14.3.7 Summary Table Properties - Sorting 

 

Option Description 

Sort by Specifies the measure you wish to sort the rows by. 

Ascending Sorts the rows from the lowest to the highest value. If categorization is 
applied, the values for the different categories are sorted within each 
column. 

Descending Sorts the rows from the highest to the lowest value. If categorization is 
applied, the values for the different categories are sorted within each 
column. 
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4.14.3.8 Summary Table Properties - Statistical Measures 

 

Option Description 

Available 
measures 

Lists all measures available for selection. 

Selected measures Lists the measures selected to be displayed in the table. 

Add > Adds the measures selected in the Available measures list to the 
Selected measures list. 

< Remove Removes the selected measures from the Selected measures list and 
sends them back to the Available measures list. 

Remove All Removes all measures from the Selected measures list. 

Move Up Moves the selected measures up in the Selected measures list. The 
order of the measures in this list determines the order of the measures 
in the table. 

Move Down Moves the selected measures down in the Selected measures list. The 
order of the measures in this list determines the order of the measures 
in the table. 
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4.14.3.9 Summary Table Properties - Legend 

 

Option Description 

Show legend Specifies whether or not the docked legend should be shown in the 
visualization. 

Position Specifies which side of the visualization the legend should be 
positioned: the right-hand side or the left-hand side. 

Display the 
following legend 
items 

Specifies what will be shown in the legend.  
By clearing a check box you will completely hide that item from the 
legend. You can also select to show or hide parts of the legend 
information using the check boxes under Settings for the selected item 
in the list, see below. 

Settings Defines how the selected legend item should be displayed. The 
available options vary between legend items. 

   Show title Use this option to show or hide the title for the selected item. The title 
is typically what is displayed above an axis selector or similar: 

 

   Show axis 
selector 

Select this option to show or hide the axis selector for the selected item.  
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4.14.4 Statistical Measures Overview  
TIBCO Spotfire contains several visualizations and tools which calculate various measures. For 
a description of each measure, see the corresponding section. 
Note: For measures where a large statistical selection is needed, the result from a calculation 
may vary with the number of available values. 
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4.15 Box Plot 
4.15.1 What is a Box Plot? 

Box plots are graphical tools to visualize key statistical measures, such as median, mean and 
quartiles. 
A single box plot can be used to represent all the data. It is also possible to visualize separate 
statistics for subsets by selecting a column for the X-axis. 
The individual box plot is a visual aid to examining key statistical properties of a variable. The 
diagram below shows how the shape of a box plot encodes these properties. The range of the 
vertical scale is from the minimum to the maximum value of the selected column, or, to the 
highest or lowest of the displayed reference points. 

 
Which reference points should be shown in the box plot is selected in the Properties dialog. 
There, it is also possible to change the shape and color of each reference point. The shape of 
outside values cannot be changed. For details of each measure, see Statistical measures. 
The axis selectors control which column is mapped to which axis. See Column Selectors for 
more information about how they work. 
The Y-axis should be set to the column or columns on which the statistical measures should be 
based. 
The X-axis can be set to any column. However, since a separate plot will be drawn for each 
unique value, the column or hierarchy should not contain too many unique values. To 
summarize the data in a single plot, select (None) on the X-axis. If multiple columns are used 
on the Y-axis, '(Column Names)' must be used either on the X-axis or in one of the trellis 
options. 
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All visualizations except the map chart can be set up to show data limited by one or more 
markings in other visualizations only (details visualizations). They can also be limited by one or 
more filterings. Another alternative is to set up a visualization without any filtering at all. See 
Limiting What is Shown in Visualizations for more information. 
  

4.15.2 How to Use the Box Plot 
► To add a distribution histogram: 

1. Right-click on the box plot visualization and select Properties from the pop-up menu. 
2. Go to the Appearance page. 
3. Select the Show distribution check box. 

Response: A histogram displaying the distribution is shown for each box. 

► To apply coloring: 
1. In the Filters panel, click and hold the left mouse button on the filter representing the 

column that you want to color by. 
Comment: Coloring is also available in the Visualization Properties dialog. The color 
of marked items is changed under Edit > Document Properties. 

2. Drag the filter to the center of the visualization. 
Response: Drop targets appear in the middle of the visualization. 

3. Release the mouse button on the X-axis target, or on either of the trellis targets. 
Comment: To color by a column you need to use the same column to split the boxes 
either on the X-axis or by trellising. 

4. Drag the same filter to the Color target. 
Response: The boxes are colored with one color for each category in the selected 
column. 
Comment: To learn more about coloring in Spotfire, see Coloring Overview. 

► To add or remove reference points: 
1. Right-click on the box plot visualization and select Properties from the pop-up menu. 
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2. Go to the Reference Points page. 
3. To add more reference points, select the check boxes for the interesting features. 
4. To remove a reference point, clear its check box. 

► To change the appearance of reference points: 
1. Right-click on the box plot visualization and select Properties from the pop-up menu. 
2. Go to the Reference Points page. 
3. Click on the reference point of interest to select it. 

Comment: Clicking twice on the same reference point will select or clear its check 
box; hence, it will change whether the reference point will be shown in the 
visualization or not. 

4. Change the Color or Shape for the selected reference point. 

► To add a reference line to the box plot: 
1. Right-click on the visualization to display the pop-up menu. 
2. Select Properties. 
3. Go to the Lines & Curves page. 
4. Select the check box for any of the default lines or click on Add to define a new 

horizontal or vertical line. 

► To add a curve fit to the box plot: 
1. Right-click on the visualization to display the pop-up menu. 
2. Select Properties. 
3. Go to the Lines & Curves page. 
4. Click on Add and select a suitable curve fit from the drop-down menu.. 

Comment: You can select from a number of predefined curve fits or define your own 
curve using Curve Draw. See Curve Fit Models for more information about the 
different options. 

5. Once the curve has been created, you can change its settings on the Lines & Curves 
page. Some of the curve settings are also available from the pop-up menu in the 
visualization. 

► To show comparison circles: 
1. Right-click on the visualization to display the pop-up menu. 
2. Select Properties. 
3. Go to the Appearance page. 
4. Select the Show comparison circles check box. 

► To create a new box plot: 
1. Click on the New Box Plot button on the toolbar, . 

Comment: You can also select Insert > New Visualization > Box Plot from the menu. 
Response: A first attempt to set up a suitable box plot is made by the application. 

2. Adjust the box plot to display the categories and measures of your choice. 
Comment: For more information about how to change what to show on the two axes, 
see Column Selectors. 

4.15.3 What are Comparison Circles? 
The drawing of comparison circles is a way to display whether or not the mean values for 
various categories (boxes in the box plot) are significantly different from each other. The circles 
are drawn with their centers at the mean value for the box to which it corresponds. 
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If the circles for different groups do not overlap, the means of the two groups are generally 
significantly different. If the circles have a large overlap, the means are not significantly 
different. 

 
In the example above, the sum of sales is shown for a number of different fruits and vegetables. 
The box for Pears has been marked, which is also indicated in the corresponding comparison 
circle. The marked comparison circle is shown with a darker border and a transparent fill. By 
looking at the comparison circles or the little relation indicator at the bottom of the visualization 
area (circled in red on the image), one can see that the sum of sales for Lettuce does not display 
a significantly different group mean, whereas the group means for all other fruits and vegetables 
are significantly different from that of Pears. The square in the relation indicator indicates the 
marked box and the lines in the relation indicator extend to any boxes that are not significantly 
different from the marked one. 
You can also highlight a comparison circle by highlighting its box plot or vice versa. The 
highlighted comparison circle is drawn with a double lined border: 

 
Tip: You can resize the area containing the comparison circles by placing the mouse pointer 
over the vertical line separating the circles from the box plots and dragging the handle to the 
desired position. 
  

4.15.4 Box Plot Properties 

4.15.4.1 Box Plot Properties 
The Box Plot Properties dialog consists of several pages: 

• General 
• Data 
• Appearance 
• Formatting 
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• Fonts 
• X-axis 
• Y-axis 
• Reference Points 
• Colors 
• Tooltip 
• Legend 
• Trellis 
• Statistics Table 
• Lines & Curves 

► To reach the Box Plot Properties dialog: 
1. Right-click on the box plot visualization. 
2. Select Properties from the pop-up menu. 

Comment: You can also click on the box plot visualization to make it active and then 
select Edit > Visualization Properties. 

4.15.4.2 Box Plot Properties - General 

 

Option Description 

Title The title of the visualization. 
Tip: Double-click on the title bar of the visualization for a shortcut to 
this field. 

Show title bar Specifies whether or not to show the visualization title. 

Description A description of the visualization. This description can optionally be 
shown in the legend and/or in the visualization. 
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Show description 
in visualization 

Specifies whether or not to show the description in the visualization. 

4.15.4.3 Box Plot Properties - Data 

 

Option Description 

Data table Specifies the data table on which the visualization will work. 

Marking Specifies the marking (that is, the color and relationships to other 
marked items) that will be used to mark items in this visualization. 

Limit data using 
markings 

Lists the available markings that can be used to limit what is shown in 
this visualization. This means that the visualization only displays data 
that has been marked in other visualizations. 
If more than one marking is selected, you can choose how the data in 
the markings should be combined. 

New... Opens the New Marking dialog where you can specify a new marking. 
The color and name of a previously created marking is edited in the 
Document Properties dialog. 

Rows must be 
included in 

Specifies how the data in the markings should be combined if you have 
selected to limit the data by more than one marking. 

   All markings 
(AND) 
   

Use this option if you want this visualization to show the intersection of 
the markings selected in Limit data using markings. This can be used if 
you have two visualizations with different markings and want to see 
which markers are present in both markings. This visualization will 
then show only the data that has been marked using both of the selected 
markings. 
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   Any marking 
(OR) 
    

Use this option if you want this visualization to show the union of the 
markings selected in Limit data using markings.  
This can be used if you have two visualizations with different markings 
and want to see which markers are present in either of the two 
markings. This visualization will then show data that has been marked 
using either of the selected markings. 

Limit data using 
filterings 

Defines how different filtering schemes in the analysis should affect 
this visualization. 
Select Use the current filtering from the page if you want the 
visualization to always utilize the filtering scheme that is used on the 
page where the visualization is located. If you move the visualization to 
a new page, then the visualization will automatically start reacting on 
the filtering scheme that is used on the new page.  
Select a specific filtering scheme from the list if you want the 
visualization to always use that filtering scheme. Moving the 
visualization to another page with a different filtering scheme will not 
affect this setting. 
If you select to limit data using more than one filtering scheme, the 
intersection of the filterings will be used. This means that the 
visualization will show only the data that is made visible by all of the 
filtering schemes. 

New... Opens the New Filtering Scheme dialog where you can specify a new 
filtering scheme. 
The color and name of a previously created filtering scheme is edited in 
the Document Properties dialog. 

Limit data using 
expression 

You can limit what data should be available for a certain visualization 
using an expression. If you have defined a limiting expression, it will be 
displayed here. 

Edit... Opens the Limit Data Using Expression dialog where you can define a 
boolean expression to use for limiting the data in this visualization. 
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4.15.4.4 Box Plot Properties - Appearance 

 

Option Description 

Box width Specifies the width of all box plots. 

Jittering outer 
values 

Displaces outside values and far out values to reveal overlapping. 
Move the slider to change the level of jittering. 

Marker size Specifies the size of all outer values. 

Show distribution Specifies whether or not the distribution of values should be shown as 
a histogram: 

 

Show 95% 
confidence interval 
of the mean 

Select the check box to display the confidence interval in the box plot 
as a black line next to the box. 

Show comparison 
circles 

Select the check box to display comparison circles in the box plot 
visualization. See What are Comparison Circles? for more information. 

Alpha level The level at which the difference between groups would be significant. 
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Use relative scale Sets the max and the min for all box plots to 100% and 0%, 
respectively. 

Show cell borders 
in statistics table 

Specifies whether or not cell borders should be visible in the statistics 
table. 

4.15.4.5 Box Plot Properties - Formatting 

 

Option Description 

Axes Displays which column and category are currently being used on the 
Y-axis in the box plot. 

Reset Resets the formatting for the selected axis values according to the 
settings defined on column level. If no column formatting has been set, 
axis formatting settings defined in the Options dialog will be used. If 
no settings have been specified in the Options dialog, the default 
settings for the visualization type will be used. 

Category Lists the available formatting categories for the selected axis. Each 
category in this list has separate settings. Which categories are 
available depends on the data type of the selected axis. See Formatting 
Settings for a full description of all possible options. 

Note: These settings affect only the current visualization. For general information about 
formatting, see Formatting Overview. 
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4.15.4.6 Box Plot Properties - Fonts 

 

Option Description 

Settings for Lists all items for which you can change the font settings. Click to 
select an item in the list to change the font settings for that text in the 
visualization. Press Ctrl and click on more items to change the settings 
for multiple items simultaneously. 

Font Specifies the font to use for the selected items. 

Font style Specifies the font style to use for the selected items. 

Size Specifies the font size to use for the selected items. 
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4.15.4.7 Box Plot Properties - X-axis 

 

Option Description 

Columns Specifies the column or hierarchy to be displayed on the X-axis. 

Settings... Opens the Advanced Settings dialog, where you can change the 
category mode to determine which combinations to show. In a box 
plot, the X-axis is always categorical. 
Note: If All values in data (nest) or All possible values (cross) are 
selected, all boxes, even empty ones, will be shown regardless of 
filtering. The All possible values (cross) option may result in 
combinations that are practically impossible and will always remain 
empty. 

Show zoom slider Shows a zoom slider that you can manually manipulate to view only 
the interesting boxes in the box plot. 

Reverse scale Reverses the current sort order, so that the lowest value is displayed at 
the top of the scale. 
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4.15.4.8 Box Plot Properties - Y-axis 

 

Option Description 

Columns Specifies the column or hierarchy to be displayed on the Y-axis. 

Settings... [Not available on this axis, since it is always continuous.] 

Range   

   Min Determines the lower value of the axis range. Leave the field blank to 
automatically adjust the range to the currently lowest value in the 
filtered data. 

   Max Determines the upper value of the axis range. Leave the field blank to 
automatically adjust the range to the currently highest value in the 
filtered data. 

   Set to Current 
Range 

Allows you to set the axis range to the currently filtered values. 
  

   Include origin Available for continuous axes only. Always includes the coordinates 
(0, 0) in the visualization, regardless of filtering. 

   Show zoom slider Shows a zoom slider that you can manually manipulate to view only 
the interesting segments of the box plot. 

Show gridlines Specifies whether or not vertical gridlines should be visible. 

Scale labels   

   Show labels Specifies whether or not scale labels should be visible. 
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      Horizontally Shows scale labels horizontally. 

      Vertically Shows scale labels vertically. 

      Max number of 
labels 

Select the check box to specify a maximum number of scale labels to 
be shown. Limiting the number of labels can improve readability on 
axis scales with many values. 

Scale   

   Reverse scale Reverses the current sort order, so that the lowest value is displayed at 
the top of the scale. 

4.15.4.9 Box Plot Properties - Reference Points 

 

Option Description 

Show real data 
points in box plot 

  

   Color Specifies the color of the selected reference point (the reference point 
on which you have clicked in the Show real data points in box plots 
list). 

   Shape Specifies the shape of the selected reference point (the reference point 
on which you have clicked in the Show real data points in box plots 
list). 
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Show abstraction 
of data ranges in 
box plot 

  

   Color Specifies the color of the selected reference point (the reference point 
on which you have clicked in the Show abstraction of data ranges in 
box plots list). All lines are white by default, and inverted to blue (or 
the selected box plot color) when outside the box. 

   Shape Specifies the shape of the selected reference point (the reference point 
on which you have clicked in the Show abstraction of data ranges in 
box plots list). 

4.15.4.10 Box Plot Properties - Colors 

 

Option Description 

Columns Specifies the column or hierarchy to color by. 

Settings Opens the Advanced Settings dialog where you can change the scale 
mode for the selected column or hierarchy from continuous to 
categorical and vice versa, as well as changing the category mode to 
determine which combinations to show. 

Color mode Specifies in which color mode to set up the color scheme. Which 
modes are available depends on whether the scale is in categorical or 
continuous mode. For columns in continuous scale mode, you can 
select one of the following color modes: Gradient, Segments, Fixed, or 
Unique values. For columns in categorical scale mode, you can select 
either Categorical or Fixed color mode. To learn more about the color 
modes, see Color Modes Overview. 
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One scale per Specifies whether there should be one separate scale per trellis panel 
for trellised box plots, or if one scale should apply to the entire 
visualization. Only applicable to columns in continuous scale mode. 

 
[Color Schemes 
menu] 

Opens a menu where you can select an already existing color scheme 
and apply it to the visualization, or apply the currently open color 
scheme to another visualization in the analysis. 

   From 
Visualization 

Lets you select a color scheme from another visualization in the 
analysis. Only color schemes that are applicable to the current color 
scheme will be listed. 

   Document Color 
Schemes 

Lets you select a color scheme that has previously been saved within 
the analysis. Only color schemes that are applicable to the current 
color scheme will be listed. This menu option is only available if one 
or more document color schemes already exist. 

   [Predefined color 
schemes] 

Lists a number of predefined color schemes. Available for columns in 
continuous scale mode only. For a full description of the predefined 
color schemes, see Predefined Color Schemes. 
Tip: To facilitate setting up a new color scheme, you can open a 
predefined color scheme with a similar appearance, and then adjust it 
to suit your needs. 

   Open from 
Library... 

Opens the Open from Library dialog where you can select a color 
scheme that has previously been saved to the library. 

   Open from File... Opens a dialog where you can select a previously saved color scheme. 

    Save As Lets you save a color scheme as a library item, a local file or a 
document color scheme. 
Library Item –- Opens the Save as Library Item dialog, where you 
can specify a location in the library and a file name to save the 
currently open color scheme for later reuse. 
File –- Opens a dialog where you can specify a location and a file 
name to save your currently open color scheme locally on your 
computer for later reuse. 
Document Color Scheme –- Opens the Save as Document Color 
Scheme dialog, where you can specify a name and save the currently 
open color scheme for later reuse within the analysis. 

   Apply to 
Visualizations... 

Opens the Apply to Visualizations dialog where you can select other 
visualizations (within the analysis) that you want to apply the current 
color scheme to. Only visualizations with compatible color schemes 
are listed. 
Note: If you apply a color scheme to a table, cross table, or heat map, 
the coloring will not take effect immediately. The color scheme will be 
added as an empty color scheme grouping, and you must select which 
columns or axis values to include in the grouping by opening the Edit 
Color Scheme Grouping dialog. 

[Color scheme area] The area in the lower part of the dialog shows the current color 
scheme. That is, the colors and values currently used in the 
visualization. You can modify color schemes in numerous ways to 
give the visualization the appearance you prefer. The color scheme 
area will look different, and have different available settings, 
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depending on the characteristics of the column used to color the 
visualization by, as well as the selected color mode. To learn more 
about color schemes and color modes, see Color Schemes Overview 
and Color Modes Overview respectively. 

Add Point Available for continuous columns only. Adds a new anchor point to 
the color scheme. 

Delete Point Available for continuous columns only. Deletes the selected anchor 
point. 

Add Rule... Opens the Add Rule dialog where you can define a rule that functions 
as an exception to the rest of the defined color scheme. A rule has 
higher priority than the rest of the color scheme. For example, you can 
define a rule to give the top five items in your data a different color 
than the rest of the items. If you add many rules to a color scheme, the 
rules are prioritized from top to bottom. Which rule types are available 
depends on the characteristics of the column or hierarchy used to color 
the visualization by. See Details on Add/Edit Rule for full descriptions 
of the rule types. 

Reset Resets the color scheme to the one that was in effect when the 
visualization was created. Any added rules will be removed. Which 
color scheme should be used by default when you create a new 
visualization is defined in the Visualization page of the Options 
dialog. 

4.15.4.11 Box Plot Properties - Tooltip 

 

Option Description 

Display the Specifies what will be shown in the tooltip. 
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following values 

Add... Opens the Add Tooltip Value dialog, where you can add the content 
from another column, hierarchy, or any custom expression to be 
shown in the tooltip. You can also use images in tooltips. See 
Highlighting in Visualizations for more information. 

Edit... Opens the Edit Tooltip Value dialog, where you can change the 
information to be shown in the tooltip. 

Delete Deletes the selected value from the list. 

Move Up Moves the selected value up in the list and, hence, up in the tooltip. 

Move Down Moves the selected value down in the list and, hence, down in the 
tooltip. 

Tooltip format   

   Value names and 
values 

Shows the tooltip content in a format where the selected column name, 
hierarchy or custom expression is displayed. For example, Year: 2003, 
Type: Cucumber, etc. 

   Visualization 
properties and 
values 

Shows the tooltip content in a format where the visualization property 
for each value is displayed. For example, X: 2003, Color: Cucumber, 
etc. 

4.15.4.12 Box Plot Properties - Legend 

 

Option Description 

Show legend Specifies whether or not the docked legend should be shown in the 
visualization. 
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Position Specifies which side of the visualization the legend should be 
positioned: the right-hand side or the left-hand side. 

Display the 
following legend 
items 

Specifies what will be shown in the legend.  
By clearing a check box you will completely hide that item from the 
legend. You can also select to show or hide parts of the legend 
information using the check boxes under Settings for the selected item 
in the list, see below. 

Settings Defines how the selected legend item should be displayed. The 
available options vary between legend items. 

   Show title Use this option to show or hide the title for the selected item. The title 
is typically what is displayed above an axis selector or similar: 

 

   Show axis 
selector 

Select this option to show or hide the axis selector for the selected item.  

 

4.15.4.13 Box Plot Properties - Trellis 
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Option Description 

Rows and columns Splits the visualization into different panels for all categories 
in the selected column or hierarchy. The number of values in 
the specified column or hierarchy controls the number of 
panels to be displayed in each row, column, or page, 
respectively. 

   Rows A row with trellis panels will be created for each value in the 
selected column or hierarchy. 

   Columns A column with trellis panels will be created for each value in 
the selected column or hierarchy. 

   Pages A new page with trellis panels will be created for each value in 
the selected column or hierarchy. Scroll down in the 
visualization to see the next page. 

Panels Splits the visualization into different panels for all categories 
in the selected column or hierarchy, without binding any 
dimensions to either rows or columns. This means that the 
number of actual values in the column to split by does not 
control the number of shown rows or columns in any way. 
The number of panels that should be visible on each page is 
instead specified using the Max number of rows and Max 
number of columns controls below. 

   Split by Specifies the column or hierarchy to define the categories by 
which the visualization should be split. 

   Manual layout Select the check box to manually specify the number of rows 
and columns that should be visible without scrolling. If the 
check box is cleared, the application will automatically specify 
the number of rows and columns. 

   Max number of rows Specifies the maximum number of panels that should be 
visible on each page. 

   Max number of columns Specifies the maximum number of panels that should be 
visible on each page. 

Settings... Opens the Advanced Settings dialog where you can change the 
category mode to determine which combinations to show. 
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4.15.4.14 Box Plot Properties - Statistics Table 

 

Option Description 

Available 
measures 

Lists all statistical measures which can be shown in the statistics table. 

Selected measures Lists the statistical measures selected to be displayed in the statistics 
table. 

Add > Adds the measures selected in the Available measures list to the 
Selected measures list. 

< Remove Removes the selected statistical measures from the Selected measures 
list and sends them back to the Available measures list. 

Remove All Removes all statistical measures from the Selected measures list. 

Move Up Moves the selected measures up in the Selected measures list. The 
order of the measures in this list determines the order of the measures 
in the statistics table. 

Move Down Moves the selected measures down in the Selected measures list. The 
order of the measures in this list determines the order of the measures 
in the statistics table. 

Sort by Specifies the measure by which you wish to sort the rows. 
Note: If trellising is applied, then this setting is ignored, since it is not 
possible to sort the measures for trellised categories. 

Ascending Sorts the measures from the lowest to the highest value. 



TIBCO Spotfire 4.0.2 - User's Manual 

562 

Descending Sorts the measures from the highest to the lowest value. 

 

4.15.4.15 Box Plot Properties - Lines & Curves 

 

First part of the dialog 

Option Description 

Visible lines and 
curves 

Lists the currently added lines and curves. If a checkmark is shown in 
the check box, then the reference line is shown in the visualization. 
Clear the check box to hide a line or curve. 
New lines and curves can be added to this list by clicking on the Add 
button; see below. 

Add Displays a menu where you can select which type of line or curve to 
add to the list of available lines and curves, and in some cases, opens a 
dialog where you can specify settings to use for that line or curve. 
For more information about the different curve types, see Curve Fit 
Models. 

Edit... Opens a dialog where you can change the settings for the selected line 
or curve (when applicable). 

Remove Removes the selected line or curve from the list of available lines and 
curves. 
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More   

   Duplicate Duplicates the currently selected line or curve. This can be particularly 
useful if you want to add one static curve that is calculated on the 
whole data set (select the Update curve manually check box) and 
another one that is changed upon filtering (default). 

   Export Curve Fit 
Result... 

Opens a dialog where you can choose to export the curve fit result for 
the selected curve to a text file or to Microsoft® Excel®. The text file 
can be either a regular tab separated text file, or a Spotfire Text Data 
Format file, which contains a bit more information about the columns 
(types, etc.). The Excel file can be either an XLS file or an XLSX file. 

Settings 

Option Description 

Appearance Determines the color, style and width of lines and curves, and the 
color, style and size of points. 

Place in Select whether to place the line, curve or point in the Foreground or 
Background of the visualization. 

Transparency Determines the transparency of the selected line, curve or point. That 
is, the degree to which the markers can be seen through it. The 
transparency is strongly connected to the color. 

Label and Tooltip Opens a dialog where you can determine what information to show in 
the label and/or tooltip for the selected line, curve or point. 

Included in axis 
range 

Sets the automatic zooming so that the line, curve or point is always 
shown, even if it lies far from the currently filtered values. 

Update manually Select the check box to "freeze" the line or curve so that it is not 
automatically recalculated upon filtering. You can update the line or 
curve by clicking the Update button below or by right-clicking in the 
visualization and selecting Update Lines and Curves and clicking on 
the one you want to update. 
Note: Not applicable for points. 

Update When a line or curve has been specified to be manually updated, use 
this button to perform the update. 

One per Determines whether to show one line or curve per Color and/or Trellis 
panel. 
Note: Not applicable for points. 
Note that you should apply true categorical coloring before using the 
color option. If you use a continuous column on the color axis, you 
may end up with a different result than the expected. This applies even 
if the continuous color mode looks "categorical" at first sight. 

4.15.4.16 Details on Alpha Level 
This dialog is shown when you have selected to specify a different alpha level for the 
comparison circles, other than the predefined options. 
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Option Description 

Specify alpha level 
(between 0,0001 
and 0,999) 

The level at which the difference between groups would be significant. 
See Comparison Circles Algorithm for more information. 

4.15.5 Statistical Measures Overview  
TIBCO Spotfire contains several visualizations and tools which calculate various measures. For 
a description of each measure, see the corresponding section. 
Note: For measures where a large statistical selection is needed, the result from a calculation 
may vary with the number of available values. 

4.15.6 Comparison Circles Algorithm 
The drawing of comparison circles is a way to display whether or not the group means for all 
pairs are significantly different from each other. The Tukey-Kramer method is used for the 
calculation. Each group (each box plot) gets a circle where the center of the circle is aligned 
with the group mean value. The radius of the circle, ri, is calculated as follows: 

 
where 

• MSE is the mean standard error (the pooled sample variance) for each box: 

 
• v is the degrees of freedom: 

 
• nj is the number of records in the group (count) 
• K is the number of groups 

• where q* is the critical value and q is the upper alpha quantile of 
the Studentized range distribution with K groups and v degrees of freedom. The alpha 
level is specified in the Visualization Properties dialog. For details on how the quantile 
is calculated, see Statistical Measures Overview. The value of q is calculated and 
updated each time the filtering of the axis is changed. 

If the circles for different groups do not overlap (or that the external angle of intersection is less 
than 90 degrees) the means of the two groups are generally significantly different. If the circles 
have a large overlap, the means are not significantly different. 
The explanation to why the overlap defines whether or not group means are significant can be 
deduced with the Pythagorean Theorem. 
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Comparison circles Mathematical 
expression 

Interpretation 

 

 

The groups are 
significantly 
different. 

 

 

Borderline 
significantly 
different. 



TIBCO Spotfire 4.0.2 - User's Manual 

566 

 

 

The groups are not 
significantly 
different. 

  

References 
http://lib.stat.cmu.edu/general/qprob 
Sall, J. (1992), "Graphical Comparison of Means" Statistical Computing and Statistical 
Graphics Newsletter, 3, pages 27-32. 
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4.16 Text Area 
4.16.1 How to Use the Text Area 

The text area is not a visualization as such, but it can be placed within a page just like a bar 
chart or scatter plot. The text area is where you can provide text, images and links or buttons 
that you think are helpful for other users opening your analysis. You can provide information on 
the purpose of a page, or maybe state the observations you have made so that other people can 
verify or comment on your findings. See Visualization Layout for more information on how to 
position the text area in a page. 
There are several different types of content you can add to a text area: 

• Text - text can be formatted to your liking, by changing the font, color, alignment, etc. 
You can also add links leading to an external web page. 

• Images - images can be inserted into the text area in GIF, BMP, PNG or JPG format. 
Regular images are added using Insert Image, but you can also add images that behave 
like action controls when clicking on them, see below. 

• Action controls - you can add links, buttons or images that perform a certain action or 
series of actions to the text area. For example, an action link can switch to a different 
page or apply a bookmark. It can also refresh a data function calculation or run a 
script. This could be very handy if you intend to share your analysis with other people. 
You could, for example, write instructions in a text area, and include links to any 
operations you want them to perform, such as: "...and when you are done filtering, 
refresh the calculation." And clicking on the link would launch a predefined data 
function calculation. 

• Property controls - you can add a number of different items that control the values of 
selected properties. This could be drop-down lists, list boxes or sliders with predefined 
values. You can also add manual input fields where anything can be entered, or you 
could simply add a label displaying the value of a specified property. 

• Filters - if you only want to display a few filters in your analysis, you can add those 
filters to a text area and save screen estate by closing the filters panel. Filters in the text 
area can also be set up to use a different filtering scheme than the one used on the rest 
of the page. This could be useful if you have selected to limit one or more 
visualizations on a page by some other filtering scheme than the one used on the page. 

• Dynamic items - dynamic items are small "visualizations" that can live within a text 
area or in a graphical table. When included in a text area they represent an aggregated 
view of some data. For example, this could be a calculated value displaying the total 
sum of sales. The dynamic items can be set up to respond to the page filtering, some 
other filtering or no filtering. They can also be limited by markings in other 
visualizations, similar to details visualizations. Currently, the available dynamic items 
are sparklines, calculated values and icons. 

► To insert a text area on a page: 
1. Click on the New Text Area button on the toolbar, . 

Comment: You can also select Insert > New Text Area from the menu. 
Response: A blank text area is created. 

► To edit the text area: 
1. Click on the Toggle Edit Mode button, , in the text area title bar. 

Comment: You can also right-click in the text area and select Edit Text Area from the 
pop-up menu. 
Response: The Text Area edit mode is toggled on and off. 
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2. You can now type text directly in the text area, or add any type of dynamic controls by 
clicking on the corresponding button in the text area toolbar. 
Comment: See Text Area Edit Mode for more information about the available tools. 
Double-clicking on a control while the text area is in edit mode opens the 
corresponding dialog for editing. 

3. To edit the title and set whether or not to show the title bar, right-click and select 
Properties from the pop-up menu. 

4. Click on the toggle edit mode button again when you are finished. 

► To add an image to the text area: 
1. Click on the Toggle Edit Mode button, , in the text area title bar. 

2. Click on the Insert Image button, . 
Response: A dialog is opened where you can browse to the image of your choice. 

3. Select an image and click Open. 
Comment: You can also copy and paste an image from another application. 
Note: If you want to use the image as an action control you should follow the steps 
below instead. 

► To add a property control to the text area: 
1. Click on the Toggle Edit Mode button, , in the text area title bar. 

2. Click on the Insert Property Control button, , and select which type of control to 
add. 
Comment: You can choose from a number of different controls. 
Response: The Property Control dialog is displayed. There you can select which 
property to work on and determine which options will be available for selection. 

3. Now you can use the property in the analysis, such as on a visualization axis, for 
example. Each time the property control is changed, all visualizations that use the 
property will be updated. 
Note: Make sure that you type some information explaining what the property control 
will actually do if the analysis is going to be opened by other users (for example, in 
TIBCO Spotfire Web Player). 

See Using Properties in the Analysis for examples of how you can use property controls. 

► To add a web link to the text area: 
1. Click on the Toggle Edit Mode button, , in the text area title bar. 

2. Click on the Insert Web Link button, . 
Response: The Insert Web Link dialog is displayed. 

3. Type a Text to display. 
Comment: If you had previously selected a text, then this text is already present in the 
dialog. 

4. Type or paste a web address in the Address field. 
Comment: This could be either an ordinary web address, a mailto link opening an 
empty email for a specified person or a tibcospotfire link to a related analysis. 

5. Click OK. 

► To add a bookmark button, link or image action control to the 
text area: 
1. Click on the Toggle Edit Mode button, , in the text area title bar. 
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2. Click on the Insert Action Control button, . 
Response: The Action Control dialog is displayed. 

3. Click on Actions in the left-hand panel. 
Comment: On this page, you can add multiple actions to a single control, but you can 
also choose to add a single action, such as a bookmark or a page shift. 

4. Type a Display text to be shown in the text area. 
5. Select a Control type: Button, Link or Image. 
6. In the Available actions list, click on the plus sign to expand the Bookmarks group. 
7. Click to select the bookmark you wish to add, then click on Add. 

Comment: You can also double-click on the bookmark to add it to the Selected actions 
list. 
Comment: If you wish to add more items to the action control, select them in the 
Available actions list and click Add. 

8. Click OK. 

► To add a page-switch button, link or image action control to the 
text area: 
1. Click on the Toggle Edit Mode button, , in the text area title bar. 

2. Click on the Insert Action Control button, . 
Response: The Action Control dialog is displayed. 

3. Click on Actions in the left-hand panel. 
Comment: On this page, you can add multiple actions to a single control, but you can 
also choose to add a single action, such as a bookmark or a page shift. 

4. Type a Display text to be shown in the text area. 
5. Select a Control type: Button, Link or Image. 
6. In the Available actions list, click on the plus sign to expand the Pages and 

Visualizations group. 
7. Click to select the page to which you wish to switch, then click on Add. 

Comment: If you wish to add more items to the action control, select them in the 
Available actions list and click Add. 

8. Click OK. 

► To add a multiple actions button, link or image action control to 
the text area: 

You can add multiple actions from the Actions page to a single button or link. However, it is 
not possible to mix actions from different pages (actions, scripts and data functions) in one 
action control. 

1. Click on the Toggle Edit Mode button, , in the text area title bar. 

2. Click on the Insert Action Control button, . 
Response: The Action Control dialog is displayed. 

3. Click on Actions in the left-hand panel. 
4. Type a Display text to be shown in the text area. 
5. Select a Control type: Button, Link or Image. 
6. In the Available actions list, click on the plus sign to expand the group of interest. 
7. Click to select the action you wish to add, then click on Add. 
8. Repeat steps six and seven to add more actions. 
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Comment: The actions will be performed in the order from top to bottom of the 
Selected actions list. It is possible to rearrange the actions in the list by clicking on 
them and selecting Move Up or Move Down. 

9. Click OK. 

► To add a script button, link or image action control to the text 
area: 
1. Click on the Toggle Edit Mode button, , in the text area title bar. 

2. Click on the Insert Action Control button, . 
Response: The Action Control dialog is displayed. 

3. Click on Script in the left-hand panel. 
4. Type a Display text to be shown in the text area. 
5. Select a Control type: Button, Link or Image. 
6. In the Available scripts list, click on the script of interest. 

Comment: To define a new script, click New.... For more information regarding 
scripts, see Using Scripts in the Text Area. 

7. Click on each parameter (if there are any) in the Necessary input for the selected 
script field and specify the Input for the selected parameter. 
Comment: If the script needs some kind of input values, then these must be specified 
before the script can be executed. Examples of input could be a text value or a 
specification of a visualization or a page to work with. 

8. When all script parameters have been defined, click OK. 
Response: The action control is added to the text area. 

9. Click on the Toggle Edit Mode button, , in the text area title bar, to turn off the Edit 
mode. 

► To add a data function button, link or image action control to the 
text area: 

Once executed in the document, data functions can also be refreshed by an action link or button 
in a text area. This can be a way to make it easier for other users of the analysis to find and use 
the data function. For example, if the data function has been set up to work with filtered rows, 
many people can access the analysis, filter to their special area of interest and click on a button 
to receive calculation results relevant for them. 

1. Create an analysis where the data function can be used and run the data function from 
the Insert menu as described in How to Use Data Functions. 
Comment: This is done in order to make the current document aware of the data 
function. 

2. Create a text area and enter edit mode by clicking on the Toggle Edit Mode button, . 

3. Click on the Insert Action Control button, . 
Response: The Action Control dialog is displayed. 

4. Click on Data Function in the left-hand pane. 
5. Type a Display text to use on the button or link. 
6. Select the Control type to use: Button, Link or Image. 
7. Click to select the data function of interest from the Available data functions list. 

Comment: Only data functions that have been executed from within the current 
document and do not use automatic refresh will be available. 

8. Click OK. 
Response: The button or link is added to the text area. 
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► To add a filter to the text area: 
1. Click on the Toggle Edit Mode button, , in the text area title bar. 

2. Click on the Insert Filter button, . 
Response: The Insert Filter dialog is displayed. 

3. Select the filtering scheme to use from the Filtering scheme drop-down list. 
4. Select which filter to insert by clicking on it in the Filter list. 
5. Click OK. 

6. Click on the Toggle Edit Mode button, , in the text area title bar, to turn off the Edit 
mode. 
Response: The filter is added to the text area. 

► To add a sparkline, a calculated value or an icon to the text area: 
1. Click on the Toggle Edit Mode button, , in the text area title bar. 

2. Click on the Insert Dynamic Item button, , and select which item to add. 
Response: The Settings dialog for the selected item is displayed and the dynamic item 
is added to the text area. For sparklines and icons, a gray edit box representing the 
placement and size of the dynamic item is shown in the text area. The name and type 
of the dynamic item is displayed in the edit box to help identifying those items. 

3. Make the necessary changes to set up the dynamic item the way you want it. 
Comment: See How to Use Sparklines, How to Use Calculated Values or How to Use 
Icons for more details. 

4. Click OK. 
Response: The settings dialog is closed. 

5. Click on the Toggle Edit Mode button, , in the text area title bar, to turn off the Edit 
mode. 
Response: The item is shown in the text area. 

► To change the font, style and size of text in the text area: 
To change the appearance of text that is typed directly in the text area and web links, use the 
text area toolbar. Other texts, such as the texts included in property controls, action controls, or 
dynamic items are modified from the Format Control dialog. Which settings are available in the 
dialog depends on the type of control or item. Note that text in filters and sliders cannot be 
edited. 

1. Click on the Toggle Edit Mode button, , in the text area title bar. 
2. Right-click on the control or item of interest, and select Format Control... from the 

pop-up menu. 
Response: The Format Control dialog is opened. 

3. Adjust the settings in the dialog to your liking. 
4. Click OK. 

Response: The new settings are applied to the selected control or item. 

5. Click on the Toggle Edit Mode button, , in the text area title bar, to turn off the Edit 
mode. 
Response: The Edit mode is closed and you see the final result. 
Note: When working with calculated values, make sure you do not unintentionally 
override any font style settings that have been defined in a rule. 
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► To change the size of a sparkline or an icon in the text area: 
1. Click on the Toggle Edit Mode button, , in the text area title bar. 

Response: The outline of the sparkline or icon is shown as a gray box. 
2. Click on the gray edit box to select it and drag either of the corners to resize the box. 

Comment: The size slider within the Icons page of the Icon Settings dialog can only 
resize the icon within the current edit box. 

3. Click on the Toggle Edit Mode button, , in the text area title bar again. 
Response: The Edit mode is closed and you see the final result. 
Comment: You can always reset the size of the sparkline or icon to the original size if 
you change your mind. Just open the Format Control dialog by right-clicking on the 
gray box, click on the Reset button and then OK, and the size will be reset. 

► To change the size of filters and controls in the text area: 
1. Click on the Toggle Edit Mode button, , in the text area title bar. 
2. Click on the control (if it is a filter, click on the gray edit box representing the filter) to 

select it and drag either of the corners to resize the box. 

Comment: Filters cannot be resized in the vertical direction, only the width will be 
changed. 

3. Click on the Toggle Edit Mode button, , in the text area title bar again. 
Response: The Edit mode is closed and you see the final result. 
Comment: You can always reset the size of the filter or control to the original size if 
you change your mind. Just open the Format Control dialog by right-clicking on the 
filter or control, click on the Reset button and then OK, and the size will be reset. 

► To change the default font, style and size for the text area: 
The default font is used in the property controls and on action buttons. 

1. Select Tools > Options. 
Response: The Options dialog is displayed. 

2. Click on Fonts. 
3. Under Settings for, click to select Text area content. 
4. Select a Font. 
5. Select a Size. 
6. Click OK. 

Response: Property controls and action buttons in all new text areas will use the new 
default font. Note that previously created text areas in your document will not be 
affected by this change.  
Comment: To apply the font settings to already existing texts, you can click on the 
Apply to Document... button to open the Apply Font Settings to Document dialog. The 
dialog allows you to update the text styles in all visualizations on one or more pages at 
the same time. Using this dialog to adjust the fonts in the analysis will override any 
settings you may have made directly in a visualization.  

► To use the 3.0 text area: 
In TIBCO Spotfire 3.1, a new version of the text area was created in order to allow the use of 
property controls and script actions in the text area. However, the function links to tools 
previously available in the text area can no longer be added to a version 3.1 text area. If you 
need that type of functionality, for example, to use some of the tools of the TIBCO Spotfire 
Connector for Pipeline Pilot, you can revert to using 3.0 text areas in your document. 

1. Select Tools > Options. 
Response: The Options dialog is displayed. 
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2. Click on Compatibility. 
3. Select the Use 3.0 text area check box. 

Comment: Note that while this check box is selected you cannot add script action 
controls and property controls in new text areas. See the 3.0 Text Area help section for 
an explanation of the available functionality. 

4. Click OK. 
Response: All new text areas created in the document will be of the 3.0 version. Note 
that previously created text areas in your document will not be affected by this change. 
This means that you can create documents where some text areas use the old style and 
some use the new style. 

► To migrate content between different text area versions: 
If you use an analysis file created before version 3.1, then the text area will be of the old 3.0 
style. You cannot convert a text area from one text area version to another directly, but it is 
possible to use the check box described above to switch between the versions when creating 
new text areas. This way, you can create a new text area, copy the text and images used in the 
first version and paste it in a text area of the other version. 

4.16.2 Text Area Edit Mode 
The text area can only be edited when the Toggle Edit Mode button, , in the visualization 
title bar has been clicked, or, when Edit Text Area has been selected from the pop-up menu. 
When in edit mode, you will see a toolbar at the top of the text area where a number of options 
are available: 

Option Description 

 

Cuts the selected object from the current position, to be pasted 
somewhere else. 

 

Copies the selected object. 

 

Pastes the selected object in the text area. 

Font Specifies the font of the text. 

Size Specifies the font size of the text. 

 

Sets the selected text to boldface. 

 

Sets the selected text to italics. 

 

Underlines the selected text. 

 

Opens the Color dialog where you can specify the text color. 

 

Aligns the selected paragraph to the left of the text area. 

 

Aligns the selected paragraph to the center of the text area. 

 

Align the selected paragraph to the right of the text area. 
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Creates a numbered list of the selected paragraph. 

 

Creates a bulleted list of the selected paragraph. 

 

Removes the indent characters from the selected text. 

 

Indents the text of the selected paragraph. 

 

Opens a dialog where you can browse to locate an image to insert. 
Including images can be very costly to memory, so it is recommended to 
keep images small. 

 

Opens the Insert Web Link dialog where you can type or paste the link to 
any website which might be of interest for the analysis. 
You can also use this button to add a mailto link opening a new message 
in your standard email client, or a tibcospotfire link which links to a 
different analysis. 
  
Examples: 
http://www.tibco.com 
mailto:person@example.com?subject=Test 
tibcospotfire:server:http\://myspotfireserver/:analysis:/Data/My Analysis 

 

Removes the web link but leaves the text intact. 

 

Opens the Insert  Filter dialog where you can select a filter to add to the 
text area. 

 

Opens the Action Control dialog where you can insert an action link or 
button which applies a bookmark, switches page or runs a script, etc. 

 

Opens the Property Control dialog where you can insert input fields, 
drop-down lists, list boxes, etc., which can easily change the values of 
custom properties. 

 

Allows you to insert a dynamic item (a sparkline, a calculated value or 
an icon) into the text area. 

To change the name of the Text Area, or to show or hide the title bar, right-click on the text area 
and select Properties. 

4.16.3 Using Properties in the Analysis 
Properties can control one or many settings by being applied in custom expressions. For 
example, a document property can be used to specify a column name. This property can then be 
used to define what is shown on one or more visualization axes, either directly or as a part of a 
custom expression. By using a property instead of simply placing the column name directly on 
the axes, you only need to change a single value (the property value) in order to change all axes 
where the property is used. Adding a property control that can change the property value further 
simplifies the update process. 
Since the property controls are available in Spotfire Web Player, this also gives the Web Player 
users a possibility to change the axes of visualizations. Property expressions can also be used to 
define a line or a curve. If a property used in expressions is updated, the property will be 
updated in all currently used locations. 
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► To use a document property to control column selection on an 
axis: 
1. Create one or more visualizations. 
2. Right-click on the axis selector for the axis of interest and select Set from Property... 

from the pop-up menu. 
Response: The Set from Property dialog is displayed. 

3. In the Select the property to use list, click to select the property of interest. 
Comment: If you have not previously created a property, click New... to define a new 
property. Note that this type of property can only be of the data type String. 

4. Click OK. 
Response: The visualization axis uses the default value of the property. 

► To use a document property as a part of a multiple columns 
custom expression: 

When properties are added to a custom expression using the Insert Properties button they are by 
default inserted as text. However, you may need to manually edit the expression syntax. For 
more information about the different syntaxes see Properties in Expressions. 

1. Create one or more visualizations. 
2. Right-click on the axis selector for the axis of interest and select Custom 

Expression... from the pop-up menu. 
Response: The Custom Expression dialog is displayed. 

3. In the list of Available properties, right-click on the property of interest. 
Comment: If you have not previously created a property, you can right-click in the 
Available properties list and select New > Document Property... to define a new 
property. Note that the data type of this type of property must be String. 
Response: A pop-up menu is displayed. 

4. Select Insert as Text from the pop-up menu. 
Response: The property is added to the expression using the text syntax. For example, 
${MyProperty}. 

5. You can add more properties to the expression by repeating the steps above. To 
interpret each property as one column, you also need to separate the properties with a 
comma: 
${MyProperty}, ${MyProperty2}, ${MyProperty3} 

6. If desired, you can edit the expression for more complex calculations. For just a simple 
property-controlled multiple columns axis, click OK. 
Response: The visualization axis uses the default value of the properties. 

► To add a drop-down list that changes a property holding a 
column name: 
1. Create a text area where you want the control to reside. 

2. Click on the Toggle Edit Mode button, , in the text area title bar. 
Comment: You can also right-click and select Edit Text Area from the pop-up menu. 

3. Type some descriptive text in the text area regarding what the control will do. 
Comment: This can be important to help other users of the analysis file understand 
what will happen when they change the selection of the control. 

4. Click on the Insert Property Control button, , and select the Drop-down list 
option. 
Response: The Property Control dialog is displayed. 

5. Click to select the property of interest in the Select property list. 



TIBCO Spotfire 4.0.2 - User's Manual 

576 

Comment: Use the search field if you cannot find your property. You can also specify 
a new property by clicking New.... 

6. Select Set property value through: Column selection. 
Comment: This will create a drop-down list control where you can choose from a 
number of columns in the data table. 
Response: The Settings part of the dialog will show the settings needed for the Column 
selection option. 

7. If more than one data table is available in the analysis, select the Data table to work 
on. 
Response: The columns from the selected data table are shown in the Selectable 
columns list. 

8. If you do not want all columns to be available in your drop-down list, type a search 
expression that displays only the columns of interest. 
Comment: For example, use "datatype:integer" to show integer columns only, use 
"datatype:real" to show real columns only, use "A or B" to show columns beginning 
with the letters A or B only, etc. You can also search for a particular column property. 
The Select Columns dialog is a shortcut to creating column properties and selecting 
columns based on these properties. For example, use "included.column:true" if you 
have added a custom column property called included.column with the default value 
false and the value true for those columns you want to be available. See also Searching 
in TIBCO Spotfire for more information about valid search expressions. 
Response: Only the columns matching the search expression will be visible in the 
Property Control dialog, and, therefore, only those columns will be available in the 
resulting drop-down list. 

9. Click OK. 
Response: The drop-down list is added to the text area. 

Column selection allows you to choose from a list of columns. There are also several other 
definitions available: Unique values in column allows you to choose from the unique values 
available in a specified column. Expressions can be any type of custom expression. Fixed 
values uses a list of predefined values. Numerical range is used to set a range of numbers from 
min to max, each step increased by a specified interval. 

► To use a property expression to define a curve: 
A property can either be a string expression in itself, or it can be used as a variable in a custom 
expression. This step instruction assumes that the property contains a string which is an 
expression. 

1. In the visualization where you want to add the curve, right-click and select Properties. 
Response: The Visualization Properties dialog is displayed. 

2. Click Lines & Curves. 
3. Click Add and select Curve Draw. 

Comment: Properties can also be used when defining straight lines or in the 
expressions for curves from data table. 
Response: The Curve Draw dialog is displayed. 

4. Call the property containing the expression in the Curve expression field using the 
Text syntax: For example, ${CurveExpression} . 
Comment: The document property curve.expression could in this example hold a value 
such as "2+3*x".  The expression could also contain other properties. For example, 
"2+DocumentProperty("ExpressionConstant")*x". Note that the syntax for calling a 
property differs when calling it to retrieve the value of the property. See Properties in 
Expressions for more information regarding the different syntaxes. 

5. Click OK. 
Response: The curve is shown in the visualization. 
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► To add an input field which updates a document property: 
1. Create a text area where you want the input field to reside. 

2. Click on the Toggle Edit Mode button, , in the text area title bar. 
Comment: You can also right-click and select Edit Text Area from the pop-up menu. 
Response: The text area becomes possible to edit. 

3. Type some descriptive text in the text area regarding what the control will do. 
Comment: This can be important to help other users of the analysis file understand 
what will happen when they change the text in the input field. 

4. Click on the Insert Property Control button, , and select the Input field option. 
Response: The Property Control dialog is displayed. 

5. Click to select the property of interest in the Select property list. 
Comment: Use the search field if you cannot find your property. You can also specify 
a new property by clicking New.... 

6. Click OK. 
Response: The input field is added to the text area. 
Comment: You need to exit the edit mode to use the input field. 
Comment: This type of input field works well together with a button or a link that 
performs some type of action. For example, a button that updates a visualization title 
as described in Using Scripts in the Text Area. 

4.16.4 Using Scripts in the Text Area 
You can define your own scripts in TIBCO Spotfire by adding action controls in a text area. 
The scripts are written in IronPython and they allow you to incorporate simple actions or tools 
into your analysis without having to deploy complete AddIns to the server. The scripts have full 
access to the Spotfire API. 
To be able to create analyses containing IronPython scripts, you need to belong to the group 
"Script Author" and have the license function “Author Scripts” under “TIBCO Spotfire 
Extensions” enabled. Select Tools > Administration Manager to make the necessary changes, 
or contact your Spotfire Administrator to do it for you. 

► To add a script action link or button to the text area: 
1. Click on the Toggle Edit Mode button, , in the Text Area title bar. 

2. Click on the Insert Action Control button, . 
Response: The Action Control dialog is displayed. 

3. Click on Script in the left-hand panel. 
4. Type a Display text to be shown in the text area. 
5. Select a Control type: Link or Button. 
6. In the Available scripts list, click on the script of interest. 

Comment: To define a new script, see Example scripts below. 
7. Click on each parameter (if there are any) in the Necessary input for the selected 

script field and specify the Input for the selected parameter. 
Comment: If the script needs some kind of input values, then these must be specified 
before the script can be executed. Examples of input could be a text value or a 
specification of a visualization or a page to work with. 

8. When all script parameters have been defined, click OK. 
Response: The action control is added to the text area. 

9. Click on the Toggle Edit Mode button, , in the text area title bar to turn off the Edit 
mode. 
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Example scripts: 
Below are more details about how to create and use a few example scripts in TIBCO Spotfire. 
These steps can also serve as instructions for how you should work when creating your own 
scripts. 

► To create the "Change visualization title" script: 

1. In a text area in Edit mode, click on the Insert Action Control button, . 
Response: The Action Control dialog is displayed. 

2. Click on Script in the left-hand panel. 
3. Click New.... 

Response: The New Script dialog is displayed. 
4. Type the Script name: Change visualization title. 
5. In the Script field, type or paste your script: 

visual.Title = title 

6. Click Add.... 
Comment: You need to specify the type of the parameters used in the script. 
Response: The Add Script Parameter dialog is displayed. 

7. In the Name field, type title. 
Comment: This is the string parameter containing the visualization title. 

8. From the Type drop-down list, select String. 
Comment: The title must be a string which can be defined either by a simple text 
value, a string property or an expression. 

9. If desired, add a Debug value which can be used for testing the script. 
10. Click OK. 

Response: The "title" parameter is added to the Script parameters list. 
11. Click Add... again, to define the second parameter. 

Response: The Add Script Parameter dialog is displayed. 
12. In the Name field, type visual and select Visualization as the Type. 

Comment: This parameter is used to point out which visualization to change the title 
on. 
Select a Debug value visualization to use when testing the script. 

13. Click OK. 
Response: The "visual" parameter is added to the Script parameters list. 

14. If desired, test the script by clicking Run Script. 
Response: The selected visualization title is updated with the Debug value provided in 
the Add Script Parameter dialog. Click Undo in the New Script dialog to revert to the 
old title. 

15. Click OK to close the New Script dialog. 
Response: The script is added to the Available scripts list in the Action Control dialog 
and the defined parameters are shown in the Necessary input for the selected script list 
(as long as the script is selected in the Available scripts list). 

16. Continue with To use the "Change visualization title" script below. 
Tip: To change the title of the active visualization, use the following script: 
Document.ActiveVisualReference.Title = title 
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► To use the "Change visualization title" script: 
1. Define a display text and a control type as described in "To add a script action link or 

button to the text area". 
2. Make sure that the "Change visualization title" script is selected. 
3. Click on the first parameter, title, in the Necessary input for the selected script list. 

Response: The Input for the selected parameter settings for title become available. 
4. Determine whether to define the title using a predefined Value, a Property or an 

Expression. 
Comment: In this example, we will assume that the title is specified using a Property. 

5. Click Select Property.... 
Response: The Select Property dialog is displayed. 

6. On the Document Property tab, click New.... 
Comment: If a suitable property is already available, you can select it in the list and go 
to step 10. 
Response: The New Property dialog is displayed. 

7. Type a suitable Property name, for example, visualization.title. 
8. From the Data type drop-down list, select String. 

Comment: The title must be a string. 
9. Type a Value to be the first (default) value of the property. For example, My 

Visualization Title. 
10. Click OK. 

Response: The new property is selected in the Select Property dialog. 
11. Click OK. 

Response: The Property field in the Action Control dialog is updated to show the 
expression syntax for the property you just defined. 

12. Click OK. 
Response: The action control is added to the text area. 

13. Click on the Toggle Edit Mode button, , in the text area title bar, to turn off the Edit 
mode. 

14. Test the action control by clicking on it in the text area. 
The property controlling the visualization title could in turn be modified using a property 
control (for example, an input field) in the text area. See Using Properties in the Analysis for 
examples of how you can add property controls. 
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► To create the "Change filtering scheme" script: 
1. In a text area, click on the Insert Action Control button. 

Response: The Action Control dialog is displayed. 
2. Click on Script in the left-hand panel. 
3. Click New.... 

Response: The New Script dialog is displayed. 
4. Type the Script name: Change filtering scheme. 
5. In the Script field, type or paste your script: 

from Spotfire.Dxp.Application.Filters import FilterPanel 
 
# Get hold of the filters panel for the current page. 
panels = Document.ActivePageReference.Panels 
# The return value and out parameters are returned as a tuple 
# in IronPython and can be bound with pattern matching. 
(found, filterPanel) = panels.TryGetPanel[FilterPanel]() 
 
# Find the filtering selection named "Filters2" 
# and set it as current. 
for filteringScheme in Document.FilteringSchemes: 
   filteringSelection = filteringScheme.FilteringSelectionReference 
   if filteringSelection.Name == "Filters2": 
       filterPanel.FilteringSchemeReference = filteringScheme 

Comment: The included example script expects to find a filtering scheme called 
"Filters2" and changes the filtering scheme of the active page to the Filters2 filtering 
scheme. 

6. Click OK to close the New Script dialog. 
Response: The script is added to the Available scripts list in the Action Control dialog. 

7. Continue with To use the "Change filtering scheme" script below. 

► To use the "Change filtering scheme" script: 
1. Define a display text and a control type as described in To add a script action link or 

button to the text area above. 
2. Make sure that the Change filtering scheme script is selected. 
3. Click OK. 

Response: The action control is added to the text area. 
Comment: This script requires no input from the end users, but if there is no "Filters2" 
filtering scheme in the analysis, then nothing will happen when the action control is 
clicked. 

4. Click on the Toggle Edit Mode button, , in the Text Area title bar, to turn off the 
Edit mode. 

5. Test the action control by clicking on it in the text area. 
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4.16.5 IronPython Example Scripts 
This topic lists a number of example scripts that can be executed by clicking on action links or 
buttons in the text area. See Using Scripts in the Text Area for more examples and detailed 
instructions on how to add scripts to a text area. 

Refresh of calculations, on-demand data and data functions: 
# Example script that refreshes a table driven by 
# a calculation, a data function 
# or an information link loaded on demand. 
# The script takes a parameter "table" of type DataTable 
 
if table.IsRefreshable and table.NeedsRefresh: 
   table.Refresh() 

Add columns from an SBDF file to a data table in the current 
document: 
# This script adds columns from an sbdf file to a data table 
# in the current document. 
# 
# Four arguments are expected: 
#   table - The data table in the current document 
#           that columns will be added to. 
#   path - The path to the sbdf file with columns to add. 
#   ColumnNameInTable - A column in the data table. 
#   ColumnNameInFile - A matching column in the sbdf file. 
# The columns are used to join new data to the current data. 
 
from Spotfire.Dxp.Data.Import import SbdfFileDataSource 
from Spotfire.Dxp.Data import AddColumnsSettings, JoinType, 
DataColumnSignature, DataType 
 
# Create the join condition map. The column with the name 
# specified in ColumnNameInTable from the current data table 
# will be joined with ColumnNameInFile in the sbdf file. 
 
columnInTable = DataColumnSignature(table.Columns[ColumnNameInTable]) 
columnInFile = DataColumnSignature(ColumnNameInFile, DataType.String) 
joinConditionMap = {columnInTable : columnInFile} 
 
ignoredCols = [ ] 
settings = AddColumnsSettings( joinConditionMap, JoinType.InnerJoin, 
ignoredCols) 
ds = SbdfFileDataSource(path) 
table.AddColumns(ds, settings) 

Use a specific visualization ("Visual") as input and then change the 
X-axis of the visualization: 
# Sets the value of the XAxis Expression of a visual. 
# This script expects two arguments: 
#   visual - The visual to the set the X-axis expression on. 
#   expression - The expression to set. 
 
from Spotfire.Dxp.Application.Visuals import VisualContent 
 
# Get the content of the visual. Use the most general type 
# so that the script works for all VisualContent classes that 
# have an X-axis property. 
vc = visual.As[VisualContent]() 
 
vc.XAxis.Expression = expression 
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Tip: If the expression parameter is tied to a string property value, you can use a property 
control (e.g., a drop-down list) with a number of predefined expression alternatives to create an 
analysis where complex expressions can be assigned to visualization axes in an easy way. 
  

4.16.6 Action Script Examples 
Actions can be defined on all dynamic items in a graphical table or in a text area. Below is an 
example of what you can do by setting up an IronPython script action on two dynamic items of 
the type calculated value in a graphical table. 

Configure Details Visualization Example 
This example uses a fictive data table containing sales and cost for a number of products in the 
different states of USA. The graphical table has been set up to show all states on the Rows axis 
and two dynamic items of the type calculated value have been added, displaying the sum of 
sales and the sum of cost, respectively: 

 
Another visualization, a line chart, has been set up to show either the sum of sales or the sum of 
cost for the marked state in the graphical table over the time, thus displaying the details behind 
the total sum for each state. In contrast to a standard details visualization controlled by the 
marking, this visualization will display different data depending on which cell you click on; 
clicking in the Sales column will show the sales for that state and clicking in the cost column 
will show the cost.  
This is done using an action script on the columns in the graphical table which sets what to 
show on the Y-axis and automatically limits the line chart by a boolean expression set to display 
data for the state of the clicked row in the graphical table only. The title of the details 
visualization is also updated by the script: 
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► To add the action to the graphical table columns: 
1. Open the Calculated Value Settings dialog for the first column and go to the Actions 

page. 
2. Select the Perform action on click check box. 
3. Click on Settings.... 

Response: The Action Settings dialog is displayed, providing you with the same 
options as when inserting action controls in the text area. 

4. Go to the Script page. 
5. Click New.... 
6. Type a Script name (for example, "Configure Details Visualization"). 
7. Type a Description (for example, "Configures a visualization to show details of a 

graphical table cell.") 
8. Copy the script below and paste it into the Script field. 

Comment: Note that the example script assumes that a column called "State" is 
available in the data table. 

9. Click Add.... 
10. Type the Name detailsVis, as expected by the script. 
11. Let the Type be a Visualization and select the line chart to use as the details 

visualization from the list. 
12. Click OK in all dialogs to close them. 
13. Add the defined script to the other column as well, to be able to show either Sales or 

Cost details in the line chart. 
Script: 
# This script is intended to be run as an action on a 
# Calculated Value miniature visualization in a graphical 
# table. 
# 
# It expects one Visualization argument, detailsVis, and 
# it configures the specified visualization to show details 
# for the clicked cell. 
# 
# When executed as an action in a graphical table, 
# the variable Context is bound to an instance of 
# MiniatureVisualizationActionContext (see API documentation). 
 
from Spotfire.Dxp.Application.Visuals import VisualContent 
 
# This script assumes that the row axis of the Graphical Table 
# is configured with one column: State. 
# 
# Get the miniature visualization and the value of the row 
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# axis hierarchy (the state column) for the clicked cell: 
 
clickedMiniVis = Context.Visualization 
state = Context.HierarchyPathValues[0] 
 
# Get the content of the visual that shall be configured to 
# show details. Use the most general type so that the script 
# works for all VisualContent classes that have a Y-axis 
# property. This works well for a Line Chart, for instance. 
 
vc = detailsVis.As[VisualContent]() 
 
# Configure the Title and YAxis of the details visualization: 
 
vc.YAxis.Expression = clickedMiniVis.ValueAxis.Expression 
detailsVis.Title = clickedMiniVis.Title + " for " + state 
 
# Limit the data of the details visualization to only use 
# data for the selected state: 
 
vc.Data.WhereClauseExpression = "State = \"" + state + "\"" 

  

4.16.7 Details 

4.16.7.1 Details on Action Control 
This dialog is used for adding or editing action links or buttons in a text area. The action 
controls can open TIBCO Spotfire tools that work on the range of filtered or marked data, apply 
bookmarks, or navigate to a certain page or visualization in the analysis. Multiple actions can be 
performed in just one click. It is also possible to add your own custom actions using the 
IronPython scripting functionality, or to refresh data function calculations. 

► To reach the Action Control dialog: 
1. Click on the Toggle Edit Mode button, , in the text area title bar. 

Comment: You can also right-click in the text area and select Edit Text Area from the 
pop-up menu. 

2. In the Text Area toolbar, click on the Insert Action Control button. 

Actions 
Select this option to insert an action which includes displaying or hiding panels, performing 
various operations on marked rows, applies bookmarks or switches pages. 
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Option Description 

Display text The text that will be displayed for the link or on the button. 

Control type Specifies whether to use a button, link or an image to execute the 
action. 

Image Enabled if the control type selected above is an image. Displays the 
path to the selected image. 

   Browse... Opens a dialog where you can browse to an image to use as the action 
control. Clicking on the image in the text area will execute the 
specified actions. 

Available actions Lists all actions that can be included in a multiple action link, grouped 
by type. Click on the plus sign to expand a group. Click on an action (a 
function, a bookmark or a page) to select it. 
Comments about bookmarks: 
For bookmark components, the active visualization always takes 
precedence over the active page. 
The filter settings of the active filtering scheme are changed, including 
the setting determining how related data tables are affected by each 
other's filtering. 
The markings component of a bookmark takes the analysis back to the 
state all markings had when the bookmark part was captured. If a 
marking has been removed, that marking is simply ignored. 
Comments about marked rows: 
The marking applied when adding any of the Marked Rows functions 
is the one used by the active data table. The active data table is the one 
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used by the visualization that was active before clicking on the text 
area. If the marking for the active visualization is set to (None), 
nothing will happen when clicking on the link. 

Add Adds the selected action to the Selected actions list. 

Remove Removes the selected action from the Selected actions list. 

Selected actions 
(applied in top-
bottom order) 

Lists the added actions in the order that they will be performed. 

Settings... Opens the Settings dialog for the action selected in the Selected actions 
list (when applicable). 

Move Up Moves the selected action up in the list. 

Move Down Moves the selected action down in the list. 

Script 
Select this option to insert a link or a button that executes a script when clicked.   

 

Option Description 

Display text The text that will be displayed for the link or on the button. 

Control type Specifies whether to use a button, link or an image to execute the 
action. 

Image Enabled if the control type selected above is an image. Displays the 
path to the selected image. 
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   Browse... Opens a dialog where you can browse to an image to use as the 
action control. Clicking on the image in the text area will execute 
the specified actions. 

Available scripts Lists all currently defined scripts. 
The Remark field can contain information about whether a script is 
trusted or not. All scripts that you have created yourself will be 
trusted. As are all scripts that are included in analyses that have 
been published to and opened from the library. However, if you 
should receive an analysis file containing a script directly from 
another person, the script will be listed as "Not trusted". This does 
not mean that the script necessarily contains any unsafe material, 
but you should determine whether you trust the script or not by 
inspecting it in the Edit Script dialog. By clicking OK in the Edit 
Script dialog, the script will be regarded as created by you and it 
will therefore be trusted. 

New... Opens the New Script dialog where you can define a new script. 

Import... Opens a dialog where you can select an analysis file from which to 
import all available scripts. 

Edit... Opens the Edit Script dialog where you can edit the selected script 
or its parameters. 

Delete Deletes the selected script. 

Necessary input for 
the selected script 

Lists all parameters that have been defined for the selected script. 
Click on a parameter to modify the input. Different parameter 
types have different input settings. 

   Value Click this radio button if you want to type a value to use as input 
for the selected parameter. 

   Property Click this radio button to associate the selected parameter with a 
property. 

   Select Property... Opens the Select Property dialog where you can specify which 
property to get the input to the script from. 

   Expression Click this radio button to calculate the value for the selected 
parameter via an expression. 

   Edit Expression... Opens the Edit Expression dialog where you can specify an 
expression using columns, properties and functions. 

   Select visualization Select the visualization in the current analysis that you want to 
associate with the selected script parameter. 

   Select page Select the page in the current analysis that you want to associate 
with the selected script parameter. 

   Select data table Select the data table in the current analysis that you want to 
associate with the selected script parameter. 



TIBCO Spotfire 4.0.2 - User's Manual 

588 

Data Function 
Select this option to insert a link or button that refreshes a previously executed data function 
when clicked. 

 

Option Description 

Display text The text that will be displayed for the link or on the button. 

Control type Specifies whether to use a button, link or an image to execute the 
action. 

Image Enabled if the control type selected above is an image. Displays the 
path to the selected image. 

   Browse... Opens a dialog where you can browse to an image to use as the action 
control. Clicking on the image in the text area will execute the 
specified actions. 

Available data 
functions 

Lists all data functions that have been executed within the current 
analysis and that do not use the Refresh function automatically feature. 
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4.16.7.2 Details on Bookmark Filter Settings 

► To reach the Bookmark Filter Settings dialog: 
1. Right-click in a text area and select Edit Text Area from the pop-up menu. 

2. Click on the Insert Action Control button, . 
3. In the Action Control dialog, click on Actions in the left-hand panel. 
4. On the Actions page, add one or more Filter settings actions from the Bookmarks part 

of the Available actions list to the Selected actions list. 
5. Select a Filter settings action in the Selected actions list and then click on Settings.... 

 

Option Description 

Filter settings 
apply method 

  

   Set all filters Applies the exact filter settings for the active filtering scheme, as 
stored in the bookmark. 

   Set only adjusted 
filters 

Keeps everything as it is in the filters panel except for those filters that 
were changed in the bookmark, which are updated. 

   Mark filtered 
rows 

Uses the filter condition from the bookmark to mark rows in the 
analysis, but leaves the filtering exactly as it was before applying the 
bookmark. 

4.16.7.3 Details on Panel Visibility Settings 

► To reach the Panel Visibility Settings dialog: 
1. Right-click in a text area and select Edit Text Area from the pop-up menu. 

2. Click on the Insert Action Control button, . 
3. In the Action Control dialog, click on Actions in the left-hand panel. 
4. On the Actions page, add one or more Functions from the View folder to the Selected 

actions list. 
5. Select one of the newly added functions in the Selected actions list and then click on 

Settings.... 
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Option Description 

Visibility of [Panel 
Name] 

  

   Show The selected panel is shown when clicking on the action link or button. 

   Hide The selected panel is hidden when clicking on the action link or button. 

Apply to all pages Select the check box to apply the change to all pages. Clear the check 
box to only change the visibility on the active page. 

 

4.16.7.4 Details on New/Edit Script 
It is possible to add your own custom actions using IronPython scripts. The resulting action 
control is launched from a text area. See Using Scripts in the Text Area and IronPython 
Example Scripts for more information. 

► To reach the New Script dialog: 
1. Click on the Toggle Edit Mode button, , in the Text Area title bar. 

Comment: You can also right-click in the text area and select Edit from the pop-up 
menu. 

2. In the Text Area toolbar, click on the Insert Action Control button, . 
3. Click on Script in the left-hand panel. 
4. Click New.... 
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Option Description 

Script name The name of the script as you want it to be displayed in the Available 
scripts list of the Action Control dialog. 

Description An optional description of what the script does. 

Script The field for typing the script in IronPython. 
The font settings for the script field can be changed using Tools > 
Options, Fonts page and selecting Expression and script editor. 

Script parameters Lists any defined parameters to be used by the script. 

Add... Opens the Add Script Parameter dialog where you can define new 
parameters to use with the script. 

Edit... Opens the Edit Script Parameter dialog where you can edit the selected 
parameter. 
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Remove Removes the selected parameter. 

Run Script Allows you to test the script by running it in the document, without 
your having to close this dialog. Any objects marked by print in the 
script definition will be shown in the Output list below. 

Undo Undoes the Run Script operation so that any results are removed from 
the document. 

Output Lists all objects marked up with "print" in the script definition. 
For example, if you have a script parameter called "title", you can 
display its debug value by typing "print title" in the Script field. 

4.16.7.5 Details on Add/Edit Script Parameter 
This dialog is used to define script parameters for scripts in action controls. 

► To reach the Add Script Parameter dialog: 
1. Click on the Toggle Edit Mode button, , in the Text Area title bar. 

Comment: You can also right-click in the text area and select Edit from the pop-up 
menu. 

2. In the Text Area toolbar, click on the Insert Action Control button. 
3. Click on Script in the left-hand panel. 
4. Click New...or select an existing script and click Edit.... 

Response: The New Script or Edit Script dialog is displayed. 
5. Click Add.... 

 

Option Description 

Name Type the name of the parameter as it is defined in the script. 
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Description An optional description of what this parameter is used for. 

Type Select the type of parameter. The type can be a simple data type such 
as a text string, an integer, etc., or it can be a visualization, page or 
data table in the current analysis. 

Debug value The debug value settings vary with the type of input parameter. When 
a visualization is selected, you specify a visualization from your 
current analysis to use as debug value. When a page is selected, you 
specify a page as debug value. When a data table is selected, you 
specify a data table. 
For the options available when selecting any of the standard data types, 
see below. 

   Value Use this option to specify a value of the selected type to use when 
debugging the script. 

   Property Use this option to specify a property of the selected type to use when 
debugging the script. 

   Select Property... Opens the Select Property dialog where you can select a property to tie 
to the script parameter. 

   Expression Use this option to calculate the debug value for the parameter via an 
expression. 

   Edit 
Expression... 

Opens the Edit Expression dialog where you can specify an expression 
using columns, properties and functions. 

4.16.7.6 Details on Action Settings 
This dialog is used for adding or editing actions to be performed when clicking on a dynamic 
item in a graphical table or a text area. The actions can open TIBCO Spotfire tools that work on 
the range of filtered or marked data, apply bookmarks, or navigate to a certain page or 
visualization in the analysis, the same things that are available for Action Controls. Multiple 
actions can be performed in just one click. It is also possible to add your own custom actions 
using the IronPython scripting functionality, or to refresh data function calculations. 

► To reach the Action Settings dialog from a graphical table: 
1. Right-click on the dynamic item column for which to add or edit an action in a 

graphical table visualization. 
2. Select Properties from the pop-up menu. 
3. If the Settings dialog for your selected dynamic item is not opened directly, go to the 

Axes page in the Graphical Table Properties dialog, select the column you want to 
modify and click Settings.... 

4. Go to the Actions page and click Settings.... 

► To reach the Action Settings dialog from a text area: 
1. Click on the Toggle Edit Mode button, , in the text area title bar, to make sure that 

the text area is in Edit Mode. 
Comment: You can also right-click and select Edit Text Area from the pop-up menu. 

2. Right-click on the gray edit box representing the desired dynamic item in the text area. 
3. Select Edit Control... from the pop-up menu. 
4. Go to the Actions page and click Settings.... 
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Actions 
Select this option to insert an action which includes displaying or hiding panels, performing 
various operations on marked rows, applies bookmarks or switches pages. 

 

Option Description 

Description A text that can be shown in the tooltip when hovering with the mouse 
pointer over the item connected to the action.  
By typing a good description you can help other users of the analysis 
understand what will happen when clicking on the item. 

Available actions Lists all actions that can be included in a multiple action link, grouped 
by type. Click on the plus sign to expand a group. Click on an action (a 
function, a bookmark or a page) to select it. 
Comments about bookmarks: 
For bookmark components, the active visualization always takes 
precedence over the active page. 
The filter settings of the active filtering scheme are changed, including 
the setting determining how related data tables are affected by each 
other's filtering. 
The markings component of a bookmark takes the analysis back to the 
state all markings had when the bookmark part was captured. If a 
marking has been removed, that marking is simply ignored. 
Comments about marked rows: 
The marking applied when adding any of the Marked Rows functions 
is the one used by the active data table. The active data table is the one 
used by the visualization that was active before clicking on the text 
area. If the marking for the active visualization is set to (None), 
nothing will happen when clicking on the link. 
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Add Adds the selected action to the Selected actions list. 

Remove Removes the selected action from the Selected actions list. 

Selected actions 
(applied in top-
bottom order) 

Lists the added actions in the order that they will be performed. 

Settings... Opens the Settings dialog for the action selected in the Selected actions 
list (when applicable). 

Move Up Moves the selected action up in the list. 

Move Down Moves the selected action down in the list. 

Script 
Select this option to insert an action that executes a script when clicked. For script examples, 
see IronPython Example Scripts or  Action Script Examples.  

 

Option Description 

Description A text that can be shown in the tooltip when hovering with the 
mouse pointer over the item connected to the action.  
By typing a good description you can help other users of the 
analysis understand what will happen when clicking on the item. 

Available scripts Lists all currently defined scripts. 
The Remark field can contain information about whether a script is 
trusted or not. All scripts that you have created yourself will be 
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trusted. As are all scripts that are included in analyses that have 
been published to and opened from the library. However, if you 
should receive an analysis file containing a script directly from 
another person, the script will be listed as "Not trusted". This does 
not mean that the script necessarily contains any unsafe material, 
but you should determine whether you trust the script or not by 
inspecting it in the Edit Script dialog. By clicking OK in the Edit 
Script dialog, the script will be regarded as created by you and it 
will therefore be trusted. 

New... Opens the New Script dialog where you can define a new script. 

Import... Opens a dialog where you can select an analysis file from which to 
import all available scripts. 

Edit... Opens the Edit Script dialog where you can edit the selected script 
or its parameters. 

Delete Deletes the selected script. 

Necessary input for 
the selected script 

Lists all parameters that have been defined for the selected script. 
Click on a parameter to modify the input. Different parameter 
types have different input settings. 

   Value Click this radio button if you want to type a value to use as input 
for the selected parameter. 

   Property Click this radio button to associate the selected parameter with a 
property. 

   Select Property... Opens the Select Property dialog where you can specify which 
property to get the input to the script from. 

   Expression Click this radio button to calculate the value for the selected 
parameter via an expression. 

   Edit Expression... Opens the Edit Expression dialog where you can specify an 
expression using columns, properties and functions. 

   Select visualization Select the visualization in the current analysis that you want to 
associate with the selected script parameter. 

   Select page Select the page in the current analysis that you want to associate 
with the selected script parameter. 

   Select data table Select the data table in the current analysis that you want to 
associate with the selected script parameter. 
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Data Function 
Select this option to insert an action that refreshes a previously executed data function when 
clicked. 

 

Option Description 

Description A text that can be shown in the tooltip when hovering with the mouse 
pointer over the item connected to the action.  
By typing a good description you can help other users of the analysis 
understand what will happen when clicking on the item. 

Available data 
functions 

Lists all data functions that have been executed within the current 
analysis and that do not use the Refresh function automatically feature. 
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4.16.7.7 Details on Select Property 
This dialog is used to specify a property that will contain a parameter value for an action control 
or an on-demand information link parameter. 

Document Properties 

 

Option Description 

Select property Select the property you want to tie to the parameter value from the list. 
You can type an expression in the search field to limit the number of 
displayed properties. If no suitable properties are available, you can 
create a new one by clicking New.... 

New... Opens a dialog where you can specify a new document property. 

Edit... Opens a dialog where you can edit the selected document property. 

Delete Deletes the selected document property. 
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Data Table Properties 

 

Option Description 

Data table Allows you to select the data table to work with. 

Select property From the list, select the property you want to tie to the parameter value. 
You can type an expression in the search field to limit the number of 
displayed properties. If no suitable properties are available, you can 
create a new one by clicking New.... 

New... Opens a dialog where you can specify a new data table property. 

Edit... Opens a dialog where you can edit the selected data table property. 

Delete Deletes the selected data table property. 
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Column Properties 

 

Option Description 

Data table Allows you to select the data table to work with. 

Column Allows you to select the column to add a new property to. 

Select property From the list, select the property you want to tie to the parameter value. 
You can type an expression in the search field to limit the number of 
displayed properties. If no suitable properties are available, you can 
create a new one by clicking New.... 

New... Opens a dialog where you can specify a new column property. 

Edit... Opens a dialog where you can edit the selected column property. 

Delete Deletes the selected column property. 

 

4.16.7.8 Details on Property Control 
This dialog is used to define a control device in the text area that can change the content of a 
property in an easy way. See Using Properties in the Analysis for examples of possible areas of 
application. For more information about how to set the options to be shown in a control, see the 
description for each control below. For a general description of search expressions, see 
Searching in TIBCO Spotfire. 
You cannot display more than 1000 values in a property control. However, you should try keep 
down the number of available values as much as possible in order to make the control easier to 
use. 



Visualizations 

601 

► To reach the Property Control dialog: 
1. Click on the Toggle Edit Mode button, , in the text area title bar. 

Comment: You can also right-click in the text area and select Edit Text Area from the 
pop-up menu. 

2. In the Text Area toolbar, click on the Insert Property Control button and select which 
type of control to add. 

 

Option Description 

Control type Displays the type of property control that you have selected to add. 
You can choose from: 
Label - shows the current value of the selected property in the text 
area: 

 
The label can also be used with binary properties. This means that you 
can use it to display images as well as text. 
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Input field - adds a text box where you can type a new value for the 
property: 

 
Input field (multiple lines) - adds a text box where you can type new 
values for a string property with multiple lines: 

 
The Input field (multiple select) control can only be used with string 
properties. 
Drop-down list -  adds a drop-down list, where the property value can 
be changed by selecting among predefined options: 

 
List box - adds a list box, where the property value can be changed by 
selecting among predefined options: 

 
List box (multiple select) - adds a list box, where the property value 
can be changed by selecting several predefined options: 

 
The List box (multiple select) control can only be used with multiple 
line string properties. 
Slider -  adds a slider where the property values can be changed by 
moving the slider: 

 
The current property value is displayed in a label above the slider. 

Document 
Properties 

  

   Select property Click to select which property that the property control should change. 

   New... Opens the New Property dialog where you can define a new property 
which the property control should change. 

   Edit... Allows you to edit the first (default) value to use on the selected 
property. 

   Delete Deletes the selected document property. 

Data Table 
Properties 

  

   Data table Select the data table of interest. 

   Select property Click to select which property that the property control should change. 
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   New... Opens the New Property dialog where you can define a new property 
which the property control should change. 

   Edit... Allows you to edit the first (default) value to use on the selected 
property. 

   Delete Deletes the selected data table property. 

Column 
Properties 

  

   Data table Select the data table of interest. 

   Column Select the column of interest. 

  Select property Click to select which property that the property control should change. 

   New... Opens the New Property dialog where you can define a new property 
which the property control should change. 

   Edit... Allows you to edit the first (default) value to use on the selected 
property. 

   Delete Deletes the selected column property. 

Set property value 
through 

Allows you to specify how the property value should be selected: 
Column selection - displays a list of columns to select from. 
Unique values in column - displays a list of values picked from a 
column. 
Expressions - displays a list of values obtained via more or less 
complex calculations. 
Fixed values - displays a list of values that you define yourself. 
Numerical range - displays a range of values from min to max using a 
specified value interval. 

Settings See the settings for each method below. 
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Column selection 
Displays a list of columns from which you can select a column. The columns shown can be 
either all columns in the data table or a specified selection of columns. 

 

Option Description 

Data table  Select the data table from which to pick columns. 

Selectable columns Lists all columns that will be available for selection in the property 
control. If not all columns in the data table should be available, you 
can type an expression to limit which columns to show. Expressions 
can limit the available columns to ones of a certain data type, like 
"DataType:Integer" or simple conditions using the column names or 
the beginning of the names to show, e.g., only columns beginning with 
A: "A". For more information about possible search expressions, see 
Searching in TIBCO Spotfire. 

Include (None) 
alternative 

Adds the alternative (None) to the list of available options. 

Constraints... [Available for multiple select list boxes only.] 
Opens the Selection Constraints dialog where you can determine 
whether or not there should be a min or a max number of selections 
possible in the list box. 

Select Columns... Opens the Select Columns dialog where you can hand-pick the 
columns you want to show in the control. The selected columns will 
receive the same boolean column property value and a search 
expression matching this value will automatically be added to the 
Selectable columns field above. 
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Unique values in column 
 Displays a list of the unique values available in a column. See Example of Property Controlled 
On-Demand Data for an example using this type of property control. 

 

Option Description 

Data table Select the data table from which to pick columns. 

Column Select the column containing the values that should be available for 
selection. 

Selectable values Lists all values that will be available for selection in the property 
control. If not all values in the column should be available, you can 
type an expression to limit which values to show. Expressions can 
limit the available values to show, e.g., only values beginning with A: 
"A". For more information about possible search expressions, see 
Searching in TIBCO Spotfire. 

Include (None) 
alternative 

Adds the alternative (None) to the list of available options. 

Constraints... [Available for multiple select list boxes only.] 
Opens the Selection Constraints dialog where you can determine 
whether or not there should be a min or a max number of selections 
possible in the list box. 
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Expressions 
Available for string properties only. Displays a list of values obtained via more or less complex 
calculations. The expressions option provides a list of strings that can be used as expressions on 
an axis, or to define curves, etc. It is a special case of the fixed values option, and can only be 
used with string properties. 

 
In the example above, each option has been tied to another (numerical) property which in turn 
can be changed using other property controls. 
It is possible to copy and paste items in the list using the pop-up menu or Ctrl+C and Ctrl+V. 

Option Description 

Display name Lists a display name for each option that the end users of the control 
should see. 

Expression Lists the expressions that define each option. 

Add... Opens the Custom Expression dialog where you can define an 
expression to calculate the value. The name you select for your 
expression will be the Display name that the end users of the property 
control will see. 

Edit... Opens the Custom Expression dialog so you can edit the expression of 
the selected option. 

Remove Removes the selected option. 

Move Up Moves the selected option up one step. 

Move Down Moves the selected option down one step. 

Include (None) 
alternative 

Adds the alternative (None) to the list of available options. 

Constraints... [Available for multiple select list boxes only.] 
Opens the Selection Constraints dialog where you can determine 
whether or not there should be a min or a max number of selections 
possible in the list box. 
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Fixed values 
Displays a list of values that you define yourself. The display name used in the control can be 
different from the actual value of the alternative. 

 
It is possible to copy and paste items in the list using the pop-up menu or Ctrl+C and Ctrl+V. 

Option Description 

Display name Type a display name for each option that the end users of the control 
should see. 

Value Type a value for each option. 

Add Adds a new row where you can type a new option. 

Remove Removes the selected option. 

Move Up Moves the selected option up one step. 

Move Down Moves the selected option down one step. 

Include (None) 
alternative 

Adds the alternative (None) to the list of available options. 

Constraints... [Available for multiple select list boxes only.] 
Opens the Selection Constraints dialog where you can determine 
whether or not there should be a min or a max number of selections 
possible in the list box. 
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Numerical range 
Displays a range of values from min to max using a specified value interval. Can be used with 
numerical properties only. 

 

Option Description 

Min Allows you to specify the min value of the numerical range. 

Max Allows you to specify the max value of the numerical range. 

Value interval Allows you to specify the interval between the tick marks in the slider. 
For example, with a range from 1-10 and an interval of 1, you will be 
able to change the slider in steps of one: 

 
If the value interval is increased to 3, the number of tick marks will be 
fewer and the property will increase its value by three for each step. 

 
If the max number and the interval steps do not break even, there will 
be a shorter interval between the last available values. 

Show min and 
max labels 

Clear the check box to remove the labels for the max and min values of 
the control and just keep the current property value above the control. 
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4.16.7.9 Details on Select Columns 
This dialog is used when you cannot limit the available columns for a property control using a 
simple enough search expression. It allows you to hand-pick the columns you want to show and 
it stores the selection as a boolean column property. All of the selected columns will receive the 
value "True" on this property and the remaining columns will receive the value "False". 

 

Option Description 

Store selection in 
this column 
property 

Allows you to select a boolean column property where the selection 
can be stored. 

New... Opens the New Property dialog where you can define a new column 
property in which to store the selection. 

Available columns Lists all columns in the specified data table that have not yet been 
selected. 

Add > Adds the columns selected in the Available columns list to the Selected 
columns list. 

< Remove Removes the selected columns from the Selected columns list. 

Remove All Removes all columns from the Selected columns list. 

Selected columns Lists all columns that have currently been selected. These columns will 
receive the value "True" on the specified column property. 
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4.16.7.10 Details on Selection Constraints 
This dialog is available from the Property Control dialog when you have selected to add a List 
box (multiple select) control. 

 

Option Description 

Define min 
number of 
selections 

Allows you to specify a minimum number of selections that are 
required in the List box (multiple select) control. This means that if 
you set the min number of selections to 1, there must always be at least 
one item selected in the list box control. 

Define max 
number of 
selections 

Allows you to specify a maximum number of selections allowed in the 
list box control. It will not be possible to select more than the specified 
max number of selections. 
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4.16.7.11 Details on Insert Filter 
This dialog is used to add a filter to a text area. 

 

Option Description 

Filtering scheme [Only available if more than one filtering scheme have been defined in 
the document.] 
Allows you to select the filtering scheme to affect with the filter. 

Filter Allows you to select which filter to insert into the text area. Click to 
select the filter to insert. 

 

4.16.7.12 Details on Format Control 
Use this dialog to change the font settings for, or reset the size of, filters, controls or items in the 
text area. Which settings are available in the dialog depends on the type of selected control or 
item. 

► To reach the Format Control dialog: 
1. Click on the Toggle Edit Mode button, , in the text area title bar. 

Comment: You can also right-click and select Edit Text Area from the pop-up menu. 
Right-click on the control or item you want to format. 
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Select Format Control... from the pop-up menu. 

 

Option Description 

Font Specifies the font to use for the selected control or item. 

Font size Specifies the font size to use for the selected control or item. 

Text color Specifies the color to use for the text in the selected control or item. 

Italic Specifies whether or not the text in the selected control or item should 
be in italic font style. 

Bold Specifies whether or not the text in the selected control or item should 
be in bold font style. 
  

Control size Resets the size of the selected control or item to its original size. 
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4.16.7.13 Text Area Properties - General 

 

Option Description 

Title The title of the text area. 
Tip: Double-click on the title bar of the text area for a shortcut to this 
field. 

Show title bar Specifies whether or not to show the title bar. 

Include 
configuration in 
bookmark 

Specifies whether or not the current configuration of this particular 
text area should be included when capturing bookmarks. For example, 
if you are currently creating a guided analysis for other people and you 
are adding bookmarks to be used as action links in the text area, you 
probably do not want to capture the current content in your text area 
while this is under construction. If that is the case, this check box 
should be cleared. 
On the other hand, if you want to create an action link which actually 
alters the information in the text area, then the check box should be 
selected when capturing the bookmark. 

4.16.7.14 Text Area Pop-up Menus 
Right-clicking in the text area, when not in edit mode, displays the following menu: 

Option Description 

Edit Text Area Toggles the edit mode for the text area on and off. 

Copy Available if anything is selected only. Copies the selected object. 

Select All Selects all content in the text area. 
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Duplicate 
Visualization 

Duplicates the active text area including any text, images, links and 
controls. 

Close Closes the text area. 

Properties Opens the Text Area Properties dialog where you can change the title 
of the text area and show or hide the title bar. 

  
When the text area is in edit mode, some more alternatives are shown: 

Option Description 

Edit Text Area Toggles the edit mode for the text area on and off. 

Cut Cuts the selected object from the current position, to be pasted 
somewhere else. 

Copy Copies the selected object. 

Paste Pastes the selected object in the text area. 

Delete Deletes the selected object. 

Select All Selects all text, images and links in the text area. 

Edit Control... Available when right-clicking on a control only. Allows you to edit the 
action control or property control you right-clicked on. 

Duplicate 
Visualization 

Duplicates the active text area including any text, images, links and 
controls. 

Close Closes the text area. 

Properties Opens the Text Area Properties dialog where you can change the title 
of the text area and show or hide the title bar. 

4.16.8 3.0 Text Area 

4.16.8.1 How to Use the 3.0 Text Area 
In TIBCO Spotfire 3.1, a new version of the text area was created in order to allow the use of 
property controls and script actions in the text area. See How to Use the Text Area for 
information about the new text area. However, for compatibility reasons, you can go back to use 
the 3.0 version of the text area instead. 

► To use the 3.0 text area: 
1. Select Tools > Options. 
2. Go to the Compatibility page. 
3. Select the Use 3.0 text area check box. 

Response: All new text areas created in the document will be of the 3.0 version. Note 
that previously created text areas in your document will not be affected by this change. 

The text area is not a visualization as such, but it can be placed within a page just like a bar 
chart or scatter plot. The text area is where you can provide text, images and links that you think 
are helpful for people opening your analysis. You can provide information on the purpose of a 
page, or maybe state the insights you have made so that other people can verify or comment on 
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your findings. See Visualization Layout for more information on how to position the text area in 
a page. 
There are three types of content you can add to a text area: 

• Text - text can be formatted to your liking, by changing the font, color, alignment, etc.. 
• Images - images can be imported into the text area in GIF, BMP, PNG or JPG format. 
• Links - you can add links to the text area. These come in some different forms - links 

can lead to an external web page or be "function links" or "action links" within TIBCO 
Spotfire. A function link is a link that when clicked launches a tool or feature of 
TIBCO Spotfire. These are very handy if you intend to share your analysis with other 
people. You can then write instructions in a text area, and include links to any 
operations you want them to perform, for example, "...and when you are done filtering, 
Export your results to PowerPoint." which would launch the Export to PowerPoint 
tool. Action links can perform simple actions, like switching to a different page or 
applying a bookmark, but they can also contain a whole series of actions. 

► To insert a 3.0 text area on a page: 
1. Click on the New Text Area button on the toolbar, . 

Comment: You can also select Insert > New Text Area from the menu. 
Response: A blank text area is created. 

► To edit the 3.0 text area: 
1. Right-click in the text area and select Edit Text Area from the pop-up menu. 

Comment: When the text area is active you can also select Edit > Visualization 
Properties. 
Response: The Edit Text Area dialog is displayed. 

2. Edit the Title and type whatever you want in the text field. 
Comment: See Edit Text Area (3.0) for more information about the available tools. 

3. Click OK. 

► To add a function link to the 3.0 text area: 
1. Right-click on the text area and select Edit Text Area from the pop-up menu. 

2. Click on the Insert/Edit Link button, . 
Response: The Insert Link dialog is displayed. 

3. Click on Function in the left-hand panel. 
Comment: On this page, you can add links that open tools, exports data or images. 
Only one function per link is allowed. To add a link that applies a bookmark or 
changes page, see below. 

4. Type a Display text to be shown in the text area. 
5. Click on the function in the list which you wish to be performed when clicking on the 

link. 
Comment: Click on the plus sign to expand the tree. Only the leaf nodes in the tree can 
be selected as a function. 
Note: Clicking the link in the Edit Text Area page opens the Edit Link dialog. To be 
able to follow the link, you have to click the link from the actual text area. 

6. Click OK. 

► To add a web link to the 3.0 text area: 
1. Right-click in the text area and select Edit Text Area from the pop-up menu. 

2. Click on the Insert/Edit Link button, . 
Response: The Insert Link dialog is displayed. 
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3. Click on Web Page in the left-hand panel. 
Comment: On this page, you can add links to external web pages which open in a 
separate web browser. To add a link that applies a bookmark or changes page, see 
below. 

4. Type a Display text to be shown in the text area. 
5. Type or paste a web address in the Web page field. 

Note: If you leave the Display text field empty, the actual web address you type into 
the Web page field will be the displayed text. 
Note: Clicking the link in the Edit Text Area page opens the Edit Link dialog. To be 
able to follow the link, you have to click the link from the actual text area. 

6. Click OK. 

► To add a bookmark link to the 3.0 text area: 
1. Right-click in the text area and select Edit Text Area from the pop-up menu. 

2. Click on the Insert/Edit Link button, . 
Response: The Insert Link dialog is displayed. 

3. Click on Actions in the left-hand panel. 
Comment: On this page, you can add multiple actions to a single link, but you can also 
choose to add a single action, such as a bookmark or a page shift. 

4. Type a Display text to be shown in the text area. 
5. In the Available actions list, click on the plus sign to expand the Bookmarks group. 
6. Click to select the bookmark you wish to add, then click on Add. 

Comment: You can also double-click on the bookmark to add it to the Selected actions 
list. 
Comment: If you wish to add more items to the action link, select them in the 
Available actions list and click Add. 
Note: Clicking the link in the Edit Text Area page opens the Edit Link dialog. To be 
able to follow the link, you have to click the link from the actual text area. 

7. Click OK. 

► To add a page-switch link to the 3.0 text area: 
1. Right-click in the text area and select Edit Text Area from the pop-up menu. 

2. Click on the Insert/Edit Link button, . 
Response: The Insert Link dialog is displayed. 

3. Click on Actions in the left-hand panel. 
Comment: On this page, you can add multiple actions to a single link, but you can also 
choose to add a single action, such as a bookmark or a page shift. 

4. Type a Display text to be shown in the text area. 
5. In the Available actions list, click on the plus sign to expand the Pages and 

Visualizations group. 
6. Click to select the page to which you wish to switch, then click on Add. 

Comment: If you wish to add more items to the action link, select them in the 
Available actions list and click Add. 
Note: Clicking the link in the Edit Text Area page opens the Edit Link dialog. To be 
able to follow the link, you have to click the link from the actual text area. 

7. Click OK. 

► To add a multiple actions link to the 3.0 text area: 
1. Right-click in the text area and select Edit Text Area from the pop-up menu. 

2. Click on the Insert/Edit Link button, . 
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Response: The Insert Link dialog is displayed. 
3. Click on Actions in the left-hand panel. 
4. Type a Display text to be shown in the text area. 
5. In the Available actions list, click on the plus sign to expand the group of interest. 
6. Click to select the action you wish to add, then click on Add. 
7. Repeat steps five and six to add more actions. 

Comment: The actions will be performed in the order from top to bottom of the 
Selected actions list. It is possible to rearrange the actions in the list by clicking on 
them and selecting Move Up or Move Down. 
Note: Clicking the link in the Edit Text Area page opens the Edit Link dialog. To be 
able to follow the link, you have to click the link from the actual text area. 

8. Click OK. 

4.16.8.2 Edit Text Area (3.0) 

 

Option Description 

Title Specifies the title of the text area. 

Show title bar Specifies whether or not to show the title. 

 

Opens the Insert Link dialog where you can insert a function link, a 
link to a web page or a bookmark, etc. 

 

Removes the selected link but leaves the text intact. 

 

Opens the Insert Image dialog where you can browse locate an image 
to insert. 
Images are restricted to 1024x1024 pixels at the most. Including 
images can be very costly to memory, so it is recommended to keep 
images small. 

 

Cuts the selected object from the current position, to be pasted 
somewhere else. 

 

Copies the selected object. 



TIBCO Spotfire 4.0.2 - User's Manual 

618 

 

Pastes the selected object in the text area. 

 

Sets the selected text to boldface. 

 

Sets the selected text to italics. 

 

Opens the Color dialog where you can specify the text color. 

Font Specifies the font of the text. 

Font Size Specifies the font size of the text. 

 

Creates a bulleted list of the selected paragraph. 

 

Creates a numbered list of the selected paragraph. 

 

Aligns the selected paragraph to the left of the text area. 

 

Aligns the selected paragraph to the center of the text area. 

 

Align the selected paragraph to the right of the text area. 

 

Indents the text of the selected paragraph. 

 

Removes the indent characters from the selected text. 

4.16.8.3 3.0 Edit Text Area Pop-up Menu 
Right-clicking in the Edit Text Area dialog displays the following menu: 

Option Description 

Cut Cuts the selected object from the current position, to be pasted 
somewhere else. 

Copy Copies the selected object. 

Paste Pastes the selected object in the text area. 

Delete Deletes the selected object. 

Select All Selects all text, images and links in the text area. 

Insert Link Opens the Insert Link dialog where you can insert a function link, a 
link to a web page or a bookmark, etc. 

Edit Link Available when right-clicking on a link only. Opens the Insert Link 
dialog with the link properties available for editing. 

Select Link Available when right-clicking on a link only. Selects the link. 

Copy Link Available when right-clicking on a link only. Copies the link. 

Remove Link Available when right-clicking on a link only. Removes the link but 
leaves the text intact. 
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4.16.8.4 Details on Insert Image (3.0 Text Area) 

 

Option Description 

Image The name of the image file is displayed here. 
Images are restricted to 1024x1024 pixels at the most. Including 
images can be very costly to memory, so it is recommended to keep 
images small. 

Browse Click this button to browse for an image file. You can import images in 
GIF, BMP, PNG or JPG format. 

 

4.16.8.5 Details on Insert Link (3.0 Text Area) 
This dialog is used for adding links to a text area, or editing existing links in a text area. The 
links can be either web links to an external web page, or function links that open various 
TIBCO Spotfire tools, that work on the range of filtered or marked data, that applies bookmarks 
or switches page in the analysis. It is also possible to insert multiple action links, which perform 
several different actions in just one click. 

► To reach the Insert Link dialog: 
1. Right-click in the text area and select Edit Text Area from the pop-up menu. 

2. In the Edit Text Area dialog, click on the Insert/Edit Link button, . 

Actions 
Select this option to insert a multiple action link, or to apply a bookmark or a switch page 
operation. 
Note: Functions are not available in TIBCO Spotfire Web Player and function links will be 
indicated as broken to those users. 
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Option Description 

Display text The text that will be displayed for the link. 

Available actions Lists all actions that can be included in a multiple action link, grouped 
by type. Click on the plus sign to expand a group. Click on an action (a 
function, a bookmark or a page) to select it. 
Comments about bookmarks: 
For bookmark components, the active visualization always takes 
precedence over the active page. 
The filter settings of the active filtering scheme are changed, including 
the setting determining how related data tables are affected by each 
other's filtering. 
The markings component of a bookmark takes the analysis back to the 
state all markings had when the bookmark part was captured. If a 
marking has been removed, that marking is simply ignored. 
Comments about marked rows: 
The marking applied when adding any of the Marked Rows functions 
is the one used by the active data table. The active data table is the one 
used by the visualization that was active before clicking on the text 
area. If the marking for the active visualization is set to (None), 
nothing will happen when clicking on the link. 

Add Adds the selected action to the Selected actions list. 

Remove Removes the selected action from the Selected actions list. 

Selected actions Lists the added actions in the order that they will be performed. 
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Settings... Opens the Settings dialog for the action selected in the Selected actions 
list (when applicable). 

Move Up Moves the selected action up in the list. 

Move Down Moves the selected action down in the list. 

Function 
Select this option to insert a function link. A function link is a link that when clicked launches a 
tool or feature of TIBCO Spotfire. Examples of available functions are different save and export 
alternatives, handling of marked or filtered rows, the launching of statistical tools, such as K-
means clustering, etc. For applying a bookmark or switching page, you need to go to the 
Actions page. 
Note: Functions are not available in TIBCO Spotfire Web Player and function links will be 
indicated as broken to those users. 

 

Option Description 

Display text The text that will be displayed for the link. 

Function Select the function of TIBCO Spotfire that you want the link to 
perform in the list. 
Note: For applying a bookmark or switching page, you need to go to 
the Actions page, even if you just want to add that single action to the 
link. 
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Web Page 
Select this option to insert a link to a web page. The web page will be opened in an external web 
browser. 

 

Option Description 

Display text The text that will be displayed for the link. 

Web page Enter the URL to the web page. 

Open Link   Allows you to test the web link by opening the URL in a web browser 
window. 

4.17 Details on General Dialogs 
4.17.1 Details on Add/Edit Tooltip Value 

Use these dialogs to choose additional values to be displayed in the tooltips for the active 
visualization.  

► To reach the Add/Edit Tooltip Value dialog: 
1. In the Visualization Properties dialog, go to the Tooltip page. 
2. Click on the Add... button to add a tooltip value. To edit a tooltip value, select the 

value of interest from the list, then click on Edit.... Only the tooltip values that you 
have added to the list yourself can be edited or deleted. 
Note: Adding/editing tooltip values is not applicable to table visualizations. 
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Option Description 

Column Select the column or expression you wish to be visible in the tooltip. 

Name Type a name to be presented with the value in the tooltip. The column 
or expression selected above will be used as a default name if nothing 
else is entered. (To exclude the name completely from the tooltip, clear 
the Include value name in tooltip check box below instead.) 

Get content from [Only visible if at least one virtual column producer is available.] 
Your company may have set up some type of virtual column producers 
that can take the values from the selected column and transform them 
in one way or another to produce a desired output. For example, if you 
have access to TIBCO Spotfire Lead Discovery you can select 
Structure Column here, in order to show molecular structures from an 
information link in the labels. 
For embedded images in the current data table, or when fetching data 
via a URL, you should leave this setting at (Selected column). 

Settings... If the selected source has some settings available, you can reach those 
by clicking on the Settings button. 
For example, this is where you would specify which information link 
to retrieve structures from when using TIBCO Spotfire Lead 
Discovery. 

Show as Allows you to select how the data in the selected column should be 
interpreted. 
For example, use Text for plain text labels. Use Image if there are 
binary images in your data that you want to use as labels. Use Link if 
the text should be interpreted as a web link. Use Image from URL if 
the image is picked from a web resource location. You may need to 
change the Link or Image from URL Renderer Settings by clicking on 
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the Settings... button and modifying the link syntax so that it fits your 
current data. 
Use Geometry if your data is a shape file and you want to show the 
geometrical shapes in the labels. 
If a TIBCO Spotfire Lead Discovery structure column is used to label 
by, then you would select a renderer for displaying structure images 
here. 

Settings... If the selected Show as method has some settings available that can be 
modified, you can reach them by clicking on the Settings button. For 
example, this could be Link Renderer Settings or Image from URL 
Renderer Settings for a web link, Geometry Renderer Settings or some 
structure renderer settings. 

Size Available if the selected tooltip value is some kind of image. Increases 
or decreases the size of the image. 

Include value 
name in tooltip 

Select this check box if you do want to include the name of the 
selected value along with the value itself. Clear the check box to show 
the resulting value only (for example, an image). 

4.17.2 Details on Advanced Settings 
► To reach the Advanced Settings dialog: 

1. In the Visualization Properties dialog, go to the page of interest (for example, X-axis, 
Y-axis, Trellis...). 

2. Click on the Settings... button next to the column selector of the property of interest. 
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Option Description 

Axis mode Specifies whether the column or hierarchy should be 
treated as continuous or categorical. 

   Continuous Select this option for numerical columns when you want 
the values to be treated as continuous, numerical values. 
This option is not available for properties that are always 
categorical (like string columns). 

   Categorical Select this option when you want the values to be seen as 
categories rather than numerical values. 
For example, if you have the years 2001, 2002 and 2003 in 
a column, you would probably like to treat the different 
values as categories rather than numbers. 

      Categories Determines how to display the categories. 

         Show filtered values Select this option to display values currently available after 
any filtering operations only. This means that those 
categories that are visible will change when filtering and 
that categories currently without any values will be hidden 
from the visualization. 

         Show filtered range Select this option to hide empty categories on both ends of 
the currently visible range. This means that those 
categories that are visible will change when filtering, and 
that empty categories within the currently visible range 
will remain visible. 

         Show all values Select this option to keep all categories visible even if data 
for some categories have been filtered out. 

Show/Hide hierarchy options For hierarchical categories only, but not available for Date, 
Time or DateTime hierarchies. 
Shows or hides the options used to specify how hierarchies 
should be built, that is, which combinations of the different 
categories should be available. 

Specify how to combine 
column values in the 
hierarchy 

Specifies how many categories will be available, e.g., on 
an axis or in a list of colors in the legend. 

   Use actual combinations in 
data only (nest) 

Use this option to display all combinations available in the 
data. For more information about the nest and cross 
alternatives, see General Syntax. 

   Use all possible 
combinations (cross) 

Use this option to display all possible combinations, even 
showing categories that are currently not included in the 
data. 
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4.17.3 Details on Scale Range 
This dialog is available for visualizations with multiple scales and allows you to specify the 
range that you want to show for the specified scale. 

► To reach the Scale Range dialog: 
1. In the Visualization Properties dialog, go to the axis page that displays the multiple 

scales settings. 
2. From the drop-down list under Individual scale settings, select which scale to define 

scale range for. You can also select All scales to set the same range for all the scales. 
3. Click on Scale Range... to the right of the drop-down list. 

 

Option Description 

Min Leave the field blank (Automatic) to let the application automatically 
adjust the scale range after the currently lowest value used on the axis. 

Max Leave the field blank (Automatic) to let the application automatically 
adjust the scale range after the currently highest value used on the axis. 

Set to Current 
Range 

Allows you to set the scale range to the currently filtered values. 

Include origin Available for continuous columns only. Always includes the 
coordinates (0, 0) in the visualization, regardless of filtering. 

If a range has been specified, further filtering will not affect the range of the selected scale. 
However, when all values belonging to a certain scale have been filtered out, the scale will 
become hidden. 

4.17.4 Details on Select Columns 
Use this dialog when you need to select more than a few columns simultaneously from a 
column selector, either on an axis of a visualization, in the legend, or in a dialog. 

► To reach the Select Columns dialog: 
1. Click on the column selector of interest to open the drop-down list. 
2. Click on Select Columns.... 
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(In places where you are only allowed to specify a single column the Add > button will be 
replaced by a Set > button and no Move Up/Move Down buttons will be available.) 

Option Description 

Available columns Lists all columns and hierarchies available for selection. 

[Type to search] Type a search string to limit the number of items in the Available 
columns list. It is possible to use the wildcard character * in the search. 
See Searching in TIBCO Spotfire for more information. 

Selected columns Lists the columns selected to be used in this particular location, as well 
as the selected aggregation method used on each column (if any 
aggregation has been specified) . Click on a column in this list to 
display additional settings for that column. 

Add > Adds the columns selected in the Available columns list to the Selected 
columns list. 

< Remove Removes the selected columns from the Selected columns list. 

Remove All Removes all columns from the Selected columns list. 

Move Up Moves the selected column up in the Selected columns list. The order 
of the columns in this list determines the order of the hierarchy. 

Move Down Moves the selected column down in the Selected columns list. The 
order of the columns in this list determines the order of the hierarchy. 

Aggregation Click on one or more columns in the Selected columns list to make this 
option available. Specifies the aggregation method to use for the 
selected column. 

Auto-bin column Click on one or more columns in the Selected columns list to make this 
option available. Select this check box to temporarily bin a continuous 
column and create an Auto-bin slider. 
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Note: To create a new column with binned values, see How to Use 
Binning instead. 

Number of bins Specifies the starting number of bins to use in the binning. This number 
can be changed by dragging the auto-bin slider in the visualization (if 
the column selectors of all included columns fits in the window). 

Level 

 
Click on a hierarchy in the Selected columns list to make this option 
available. Specifies which level of the hierarchy to use. 

4.17.5 Details on Limit Data Using Expression 
You can limit what data should be available for a certain visualization using an expression. This 
way, you can set a "hard filter" on a visualization to make sure that certain values are never 
included in the calculations behind the visualization, regardless of any filtering in the Filters 
panel. For example, you can make sure that one visualization only shows data for a certain state 
by adding the expression similar to [State]="Nevada". See also Limiting What is Shown in 
Visualizations. 

► To reach the Limit Data Using Expression dialog: 
1. Click on the visualization for which you want to limit the data using an expression to 

make it active. 
2. Select Edit > Visualization Properties. 
3. Go to the Data page. 
4. At the bottom of the page, next to Limit data using expression, click on Edit.... 
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Option Description 

Available columns Shows all columns that you can use in the calculation of a new 
column. 
Select a column by clicking on it in the list and then click on the 
Insert Columns button, or double-click on the column to send it to 
the Expression field. Press Ctrl or Shift to select multiple columns. 
You can narrow down the list of available columns by typing a part 
of a name in the "Type to search" field. You can also enter an 
expression in the field using the rules described on the Searching in 
TIBCO Spotfire page. 

Insert Columns Inserts the columns selected in the Available columns list at the 
current cursor position in the Expression field. 

Available properties 
for column 

Shows all properties that you can use in the calculation of a new 
column. You can narrow down the list of available properties by 
using the search field. The column properties shown are specific to 
the column selected in the Available columns list to the left. 
Select a property by clicking on it in the list and then click on the 
Insert Properties button; or double-click on the property to send it to 
the Expression field. The property will automatically be inserted as 
text. However, there may be occasions where you need to insert the 
property as a function to receive the desired result. See Properties in 
Expressions for more information. Use the pop-up menu in this field 
to select how to insert the property or type the correct syntax 
manually. 
If you want to define a new property to use in the expression, right-
click in the Available properties field and select New > [Property 
Type] Property... from the pop-up menu. You can also edit or 
delete custom properties by using the pop-up menu. 

Insert Properties Inserts the properties selected in the Available properties for column 
list at the current cursor position in the Expression field. 

Category Select a category of functions to limit the choices in the Function 
list: 
All functions 
Binning functions 
Conversion functions 
Date and Time functions 
Logical functions 
Math functions 
Operators 
Property functions 
Ranking functions 
Spatial functions 
Statistical functions 
Text functions 

Function Select a function by clicking on it in the list and then click on the 
Insert Function button, or double-click on the function to send it to 
the Expression field. 
Type a search string in the text field to limit the number of items in 
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the Functions list. 
You can also click on any function and type the first letter of the 
desired function name to jump to a specific location in the list. 

Description Shows a brief description of the selected function. For more detailed 
descriptions, see the Expression Language chapter. 

Insert Function Inserts the selected function at the current cursor position in the 
Expression field. 

Expression This is the text field in which you build your expression. You can 
insert columns and functions from the lists, or enter text as in any 
standard text editor. In this context, the expression must be of type 
"Boolean", since it will be used as a filter. 
Cut/Copy/Paste works in the field using standard 
Ctrl+X/Ctrl+C/Ctrl+V. 
Also, it is possible to undo/redo the last action by pressing Ctrl+Z. 

Recent expressions Displays the ten expressions you have most recently created. You 
can select one of these and click the Insert button to insert the 
expression into the Expression field. 

Insert Inserts the selected Recent expression into the Expression field. This 
will replace the entire content of the Expression field. 

Resulting expression Of interest when preprocessor functions (such as ${PropertyName}) 
are used in the expression only. Displays the expression after all 
occurrences of the property have been replaced with its current value 
or values. 

4.17.6 Details on Link Renderer Settings 
► To reach the Link Renderer Settings dialog: 
In the Table Properties Columns page, click to select a column that uses the Link Renderer, then 
click Settings... . 
OR 
Click Settings... in the Scatter Plot Properties or Map Chart Properties Labels page, or in the 
Add Tooltip dialog, when Show as: Link has been chosen. 
OR 
Click Settings... in the Add/Edit Default Renderer dialog when the Link Renderer has been 
chosen. 

  
Note: If you apply renderer settings from the visualization properties, the settings are applied to 
that visualization only. If you apply renderer settings from the Add/Edit Default Renderer 
dialog, the settings are applied to all new visualizations. 
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Example: 
If the link is entered as the example in the dialog, http://www.domain.com/{$}.html the result 
would be: 

Cell value URL 

a http://www.domain.com/a.html 

b http://www.domain.com/b.html 

c http://www.domain.com/c.html 

d http://www.domain.com/d.html 

e http://www.domain.com/e.html 

 

4.17.7 Details on Image from URL Renderer Settings 
► To reach the Image from URL Renderer Settings dialog: 
In the Table Properties Columns page, click to select a column that uses the Image from URL 
Renderer, then click Settings... . 
OR 
Click Settings... in the Scatter Plot Properties or Map Chart Properties Labels page, or in the 
Add Tooltip dialog, when Show as: Image from URL has been chosen. 
OR 
Click Settings... in the Add/Edit Default Renderer dialog when the Image from URL Renderer 
has been chosen. 
  
Note: If you apply renderer settings from the visualization properties, the settings are applied to 
that visualization only. If you apply renderer settings from the Add/Edit Default Renderer 
dialog, the settings are applied to all new visualizations. 
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Examples: 
If the images are available on the internet and the link is entered as the example in the dialog, 
http://www.domain.com/{$}.png the result would be: 

Cell value URL 

a http://www.domain.com/a.png 

b http://www.domain.com/b.png 

c http://www.domain.com/c.png 

d http://www.domain.com/d.png 

e http://www.domain.com/e.png 

If the requested images reside on a company network location you could also specify the path to 
the folder: 
Q:\MyCompany\Images\{$} 
Note: Since local network paths may be unavailable to other users, the recommended procedure 
is to use a URL rather than a local network path when publishing analyses to the library. 

Width and Height 
If the website allows, you can also specify the width and height of the rendered image (in 
pixels): http://MyCompany.com/Images/{$}/image?width={$width}&height={$height} 
If $width and $height are included in the link template, the image will be rendered using the 
width and height specified by your current table row height/column width, or, in the case of 
labels or tooltips, by the size set using the size slider. If not included, the default size will be 
rendered and changing the size will simply enlarge or shrink the default image. 

4.17.8 Details on Geometry Renderer Settings 
► To reach the Geometry Renderer Settings dialog: 
In the Table Properties Columns page, click to select a column that uses the Geometry 
Renderer, then click Settings... . 
OR 
Click Settings... in the Scatter Plot Properties or Map Chart Properties Labels page, or in the 
Add Tooltip dialog, when Show as: Geometry has been chosen. 
OR 
Click Settings... in the Add/Edit Default Renderer dialog when the Geometry Renderer has 
been chosen. 
  
Note: If you apply renderer settings from the visualization properties, the settings are applied to 
that visualization only. If you apply renderer settings from the Add/Edit Default Renderer 
dialog, the settings are applied to all new visualizations. 
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Option Description 

Fill color Defines which color to fill the different geometries with. 

Border color Defines the color to use for the border surrounding the geometries. 

Border weight Defines the thickness of the borders of the geometries. 
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5 Using Visualizations 
5.1 Interacting with Visualizations 
5.1.1 Marking in Visualizations 

The purpose of marking items (for example, a bar segment, a pie sector, a line, or a marker) or 
rows in a visualization may be to view details for the item, or to distinguish rows in order to tag, 
copy, delete, or in other ways manipulate them. Marked rows are given an identifying color in 
all visualizations. However, if the analysis contains multiple markings (see below), only 
visualizations using the same marking as the one you modify will be affected. 
Note: If markings are to be reapplied after reloading linked data, you need to specify key 
columns that can be used to uniquely identify the rows in each data table. See Details on Select 
Key Columns for more information. 

► To mark a single item: 
1. Click on the item. 

Response: The marked item is given a different color. Related visualizations are also 
updated so that items where the marked item is included are set to the marked color. 
Note: Marking a pie or a bar is equivalent to marking all the rows that are included in 
that pie or bar. 

► To mark one or more items in a visualization: 
1. Click and drag with the mouse to draw a rectangle enclosing the interesting items. 

Comment: You can also mark a section on an axis to include all items within that 
section, see below. 
Comment: If you want to mark several items that are spread out in the visualization so 
that they cannot be enclosed by a rectangular shape, you can use lasso marking instead. 
Press and hold down the Alt key and draw a shape of any form to enclose the items of 
interest. 
Note: Lasso marking cannot be applied to table visualizations. 

► To mark one or more items using axis-marking: 
1. In a visualization with axes, you can mark items by placing the mouse pointer in the 

area of the scale labels and then click and drag with the mouse along the axis. 
Response: A rectangle is drawn across the visualization so that you can mark all values 
between two specified axis values. 
Comment: Marking along the value axis in the bar chart is slightly different than 
normal rectangle marking; Only those bars with the top part of the bar included within 
the axis-marking rectangle will be marked. This allows you to select bars with heights 
within a specific span. 

► To add more items to the marked set: 
1. Press and hold Ctrl. 
2. Click on items you want to add, one by one. Alternatively, click and drag with the 

mouse around several items (while still pressing Ctrl). 
Comment: To add more items using the lasso marking technique, press and hold both 
Ctrl and Alt when you draw a shape to enclose the items you want to add to the 
marked set. 
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► To change the color for marked items: 
1. Select Edit > Document Properties. 
2. Click on the Markings tab. 
3. Click on the marking of interest and then click on Edit..... 
4. Change the color and click OK. 
5. Click OK to close the Document Properties dialog. 

Comment: If multiple markings are used within the analysis, you can switch between 
these in the legend or visualization properties of all visualizations. 

► Unmarking: 
• Unmark all data by selecting Edit > Marked Rows > Unmark. Alternatively, you can 

unmark everything by clicking on an empty area of any visualization, except the tables. 
• Re-marking any marked items while Ctrl is pressed will unmark them. 
• Click to mark a new item. If Ctrl is not pressed, only the new item will be marked. 

► To display labels for marked items: 
1. Open the Properties dialog for the visualization. 

Comment: This is done by right-clicking on the visualization and selecting Properties 
from the pop-up menu. 

2. Click on the Labels page in the list on the left. 
Response: The Labels page is displayed. Note that not all visualizations support labels. 

3. Select a column to Label By. 
4. Click the Show labels for: Marked rows radio button. 
5. Click Close. 

Comment: If you want to use an image in the label you may need to apply some other 
settings as well. See the Labels property page for your specific visualization for more 
information. For example, Scatter Plot Properties - Labels. 

► To filter to marked rows: 
You can use marked items in a visualization to filter to data. 

1. Make sure you have marked the items you want to filter to in the analysis. 
2. Right-click in the visualization and select Marked Rows > Filter To. 

Response: Only the marked items remain visible, all other items are filtered out. A new 
column called "Filtered to at..." with the two values Yes and No is also created in the 
data table, as well as a corresponding check box filter. 
Comment: The new column and filter make it easy to toggle between viewing all items 
or only the marked items. There is always just one column for filtered to items in the 
same data table. If you mark items and select Filter To again, the existing column will 
be updated with the new selection. 

► To filter out marked rows: 
You can use marked items in a visualization to filter out data. 

1. Make sure you have marked the items you want to filter out in the analysis. 
2. Right-click in the visualization and select Marked Rows > Filter Out. 

Response: The marked items are filtered out in the visualization. A new column called 
"Filtered out at..." with the two values Yes and No is also created in the data table, as 
well as a corresponding check box filter. 
Comment: The new column and filter make it easy to toggle between viewing all items 
or only the unmarked items. There is always just one column for filtered out items in 
the same data table. If you mark additional items and select Filter Out again, the 
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additional filtered out items will be added to the previously created column. You 
cannot remove items from the created column. 

Using the Keyboard and Mouse to Mark Rows 
Using combinations of keyboard and mouse interaction, you can perform more advanced 
marking. The most common keyboard interaction is to hold down the Ctrl key while clicking 
and dragging the mouse over a set of items to add these to an already existing marking. You can 
also "step" between items using the arrow keys on the keyboard. 
Below is a list of all the keyboard and mouse interaction you can use to mark items. 

Action Description 

Mouseover item Highlight item. 

Click on item Mark clicked item and unmark all other items.   

Ctrl + click on item Toggle mark for clicked item. Leave other items as is. 

Shift + click Useful in table visualizations, where you mark all items between the 
previously marked item and the clicked item. All other items are 
unmarked. 

Ctrl + Shift + click Useful in table visualizations, where you mark all items between the 
clicked item and the previously marked item. Other items are left as 
is. 

Alt + click Press Alt and click on a column header or row header in the cross 
table to mark the entire column or row. 

Click and drag Mark items within the drawn rectangle and unmark all other items. 
When you start to drag, a transparent rectangle is shown indicating 
the area to be marked. 

Alt + click and drag Mark items within the drawn area of any shape and unmark all other 
items. When you press Alt and start to drag, a transparent shape is 
shown indicating the area to be marked. This marking technique, 
lasso marking, is useful when the items you want to mark cannot be 
enclosed within a rectangle because of the way they are spread out in 
the visualization. 
Note: Lasso marking is not applicable to table visualizations. 

Ctrl + click and 
drag 

If none of the items in the drawn rectangle are marked, they are 
added to the marked items. 
If all items in the rectangle are marked, they are unmarked. 
If some items in the rectangle are marked and some not, the behavior 
differs between table visualizations and other visualizations. In tables 
and cross tables, marked items are unmarked, and unmarked items 
are marked. For all other visualizations the marked items will stay 
marked and the unmarked items will be added to the marked items. 

Ctrl + Alt + click 
and drag 

If none of the items in the drawn area are marked, they are added to 
the marked items. 
If all items in the area are marked, they are unmarked. 
If some items in the area are marked and some not, the marked items 
will stay marked and the unmarked items will be added to the marked 
items. 
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Note: Lasso marking is not applicable to table visualizations. 

Shift + click and 
drag 

Marks the entire line in a line chart if the drawn rectangle contains 
parts of the line. 

Up/Down/Left/Right 
Arrow key 

Mark the first item above/below/left/right of the previously marked 
item and unmark all other items. 

Shift + 
Up/Down/Left/Right 
Arrow key 

Extend the set of marked items up/down/left/right, unless the next 
item is already marked. If the item is already marked, unmark the 
previously marked item. 

Ctrl + 
Up/Down/Left/Right 

Move highlight up/down/left/right. 

Space Mark the highlighted item. Unmark other items. 

Ctrl + Space Toggle mark for highlighted item. Keep other items as is. 

Multiple markings 
A marking is what identifies marked rows in the data tables of an analysis. If you have multiple 
data tables in your analysis, you may want to use different markings for the different data 
tables. For example, if two data tables are completely unrelated to each other it may be a good 
idea to use different markings with different marking colors for those two data tables. This 
would lessen the risk of interpreting the marked data in the two data tables as being related to 
each other. 
If the data tables are related, the marked rows can be propagated using the specified key relation 
between the data tables, provided that the same marking is used. Setting a marking in one data 
table does not affect the marking of unrelated data tables. Each analysis can hold multiple 
markings and each marking has its own marking color. One or more markings can be used to 
limit what data is displayed in a visualization. 

► To define a new marking: 
1. Select Edit > Document Properties. 

Comment: You can also define new markings from the Data page of any Visualization 
Properties dialog. 
Go to the Markings tab. 

2. Click on the New... button next to the Available Markings list. 
3. Specify a Color for the new marking. 
4. Specify a Name. 
5. Click OK. 

► To change what marking to use for a specific visualization: 
1. Right-click on the visualization and select Properties from the pop-up menu. 
2. Go to the Data page. 
3. Use the drop-down list to select a different Marking. 

Comment: The Marking selector may also be shown in the legend. 

5.1.2 Highlighting in Visualizations 
When you move the mouse pointer over an item (for example, a bar segment, a pie sector, a 
line, or a marker) in a visualization, a tooltip appears displaying details about the highlighted 
item. The tooltip displays a few items by default, but it can also be configured to show 
information from additional columns or expressions. 
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► To highlight an item: 
1. Point to the item of interest. 

Response: A tooltip will appear with information about the selected item. For example, 
in a stacked bar chart you will get information about the category that the segment 
represents as well as the height of that specific segment. 

► To change what is displayed in the tooltip: 
1. Open the Properties dialog for the visualization. 

Comment: This is done by right-clicking on the visualization and selecting Properties 
from the pop-up menu. 

2. Click on the Tooltip page in the list on the left. 
Response: The Tooltip page is displayed. 

3. Select the check boxes for the values you want to show in the tooltip, and clear the 
check boxes for values you do not want to show. 

4. If desired, click on the Add... button to create expressions or add other columns whose 
values you want to show in the tooltip. 
Response: The Add Tooltip Value dialog is displayed. 
Comment: See "To display images in the tooltip" below for more information about 
using images in tooltips. 

5. Select the column or expression of interest. 
6. Type a Name to display. 

Comment: This is the text that will be shown together with the expression value in the 
tooltip, and also what will be shown in the list of available tooltip values. 

7. Click OK. 
Response: The Add Tooltip Value dialog is closed and the newly added value is shown 
in the Tooltip property page. 

8. Click Close. 
Response: The Properties dialog is closed. 

Note: In a map chart, the columns available for selection will be limited to those in the selected 
Data table for markers or pies or the Related data table for coloring, as specified on the Data 
page. You cannot use the Map data table if this is another data table than those mentioned 
above. 

► To display images in the tooltip: 
Most visualizations can display images from a binary image column, a shape file, or—if you 
have access to TIBCO Spotfire Lead Discovery—chemical structures in tooltips. 

1. Open the Properties dialog for the visualization. 
Comment: This is done by right-clicking on the visualization and selecting Properties 
from the pop-up menu. 

2. Click on the Tooltip page in the list on the left. 
Response: The Tooltip page is displayed. 

3. Click on the Add... button. 
Response: The Add Tooltip Value dialog is displayed. 

4. Select the Column of interest. In some cases, like when you are going to display 
linked structures, you will select an ID column here, which at a later step is mapped 
against the desired output. 

5. Type a Name to display. 
Comment: This is the text that will be shown together with the expression value in the 
tooltip, and also what will be shown in the list of available tooltip values. 

6. If you are a TIBCO Spotfire Lead Discovery user and have selected an ID column to 
be mapped against structure data in an information link, you need to select Get 
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content from: Structure Column in order to display chemical structures in the 
tooltip. 
Comment: Most people will not need to specify anything under Get content from, but 
your company may have set up other types of custom virtual column producers that 
can be selected here. 
If you have selected something other than (Selected column) under Get content from, 
you may need to click on Settings... and make some changes in the dialog. For 
example, this is where you would specify which information link to connect to when 
displaying linked structures in a tooltip. 

7. Select Show as:  [your current structure renderer, e.g., Symyx® Draw (MDL)] or one 
of the options Image, Image from URL or Geometry. This specifies the type of image 
to be rendered. 

8. If desired, change the Size of the tooltip image by moving the slider, 
9. Clear the Include value name in tooltip check box if you only want to display the 

image in the tooltip and not the name. 
10. Click OK. 

Response: The Add Tooltip Value dialog is closed and the newly added value is shown 
in the Tooltip property page. 

11. Click Close. 

► To copy tooltips for marked items: 
1. Mark the interesting visualization items (bar segments, lines, markers, etc.). 
2. Right-click on the visualization. 

Response: A pop-up menu is shown. 
3. Select Copy from the menu. 

Response:  The tooltips for the currently marked visualization items are copied to the 
clipboard. 

5.1.3 Drag-and-Drop 
TIBCO Spotfire contains rich possibilities of using drag-and-drop operations for setting up the 
visualizations. You can drag filters from the filters panel to the axes, or filters or column 
selectors to drop targets in the middle of the visualizations. These drop targets control coloring, 
trellising, size or shape, etc. All operations are undoable, so that you can try different layouts 
without being afraid of destroying anything. 

Column Selectors 
Dropping a column (a filter or a column selector) directly on a column selector will change that 
axis to use the new column instead. Dropping it next to the previous column selector will add 
another column to the axis. 

Drop Targets 
You can drag a filter from the filters panel and move it over the center of a visualization. As 
you do so, drop targets will appear as shown in the table below. By dropping the filter on, for 
example, the Color By icon, the visualization will be colored according to the column the filter 
represents. Other drop targets can be used to set different properties, such as X-axis or Trellis. If 
you want to assign several columns to one property, you can use Shift + Click or Ctrl + Click 
to select several filters at once. 
You can also drag a column selector from, for example, the legend or an axis and drop that on a 
drop target. The behavior is identical to that of dragging a filter except that the original column 
selector will be removed unless you hold down Ctrl while dragging. This behavior is the same 
if you drag the columns directly to a column selector. 
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Drop 
Target 

Visualization Description 

 

Bar chart ,scatter 
plot, 3D scatter 
plot, line chart, 
parallel 
coordinate plot, 
box plot, 
combination chart 

Changes column on the horizontal axis. In most cases this 
means the X-axis in a visualization, but in a bar chart it 
depends on the orientation of the bars. In a vertical bar 
chart, this refers to the category axis; in a horizontal bar 
chart it refers to the value axis. 

 

Bar chart, scatter 
plot, 3D scatter 
plot, line chart, 
box plot, 
combination chart 

Changes column on the vertical axis. In most cases this 
means the Y-axis of a visualization, but in a bar chart it 
depends on the orientation of the bars. In a vertical bar 
chart, this refers to the value axis; in a horizontal bar 
chart it refers to the category axis. 

 

3D scatter plot Changes column on the Z-axis in the 3D scatter plot. 

 

Bar chart, line 
chart, parallel 
coordinate plot, 
pie chart, scatter 
plot, 3D scatter 
plot, map chart, 
box plot, treemap 

Colors the visualization items by the provided column. 

 

Scatter plot, 3D 
scatter plot, map 
chart 

Changes the markers' shapes according to the values in 
the provided column. 

 

Scatter plot, 3D 
scatter plot, map 
chart 

Sizes the markers by the provided column. 

 

Line chart Splits the lines according to the values in the provided 
column, unless they have already been split by a more 
detailed coloring option. 

 

Pie chart Defines the column or hierarchy whose values will set the 
size of the pie sectors. 

 

Treemap Changes the treemap hierarchy to the provided column or 
hierarchy. 

 

Treemap Sizes and orders the rectangles in the treemap by the 
provided column. 

 

Cross table Changes the cell values of the cross table to the provided 
column. 
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Cross table, heat 
map 

Changes the vertical values (Y-axis) to the provided 
column. 

 

Cross table, heat 
map 

Changes the horizontal values (X-axis) to the provided 
column. 

 

Heat map Changes the cell values of the heat map to the provided 
column. 

 

Heat map Adds the provided column to the cell values of the heat 
map. 

 

Table, graphical 
table, summary 
table 

Shows the selected columns in the table (and removes all 
other columns from the table). 

 

Table Adds the selected columns to the table. 

 

Summary table Splits the summary table into different categories. 

 

Bar chart, line 
chart, parallel 
coordinate plot, 
pie chart, scatter 
plot, 3D scatter 
plot, map chart, 
box plot, treemap, 
combination 
chart, heat map 

Splits (trellises) the visualization into several rows, where 
the number of panels equals the number of categories in 
the column provided. 

 

Bar chart, line 
chart, parallel 
coordinate plot, 
pie chart, scatter 
plot, 3D scatter 
plot, map chart, 
box plot, treemap, 
combination 
chart, heat map 

Splits (trellises) the visualization into several columns, 
where the number of panels equals the number of 
categories in the column provided. 

 

Bar chart, line 
chart, parallel 
coordinate plot, 
pie chart, scatter 
plot, 3D scatter 
plot, map chart, 
box plot, treemap, 
combination 
chart, heat map 

Splits (trellises) the visualization into several panels, 
where the number of panels equals the number of 
categories in the column provided. 

 

Bar chart, line 
chart, parallel 

(Only available when a column selector within a 
visualization is being dragged.) 
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coordinate plot, 
pie chart, scatter 
plot, 3D scatter 
plot, map chart, 
box plot, treemap, 
combination 
chart, heat map 

Removes a previously applied condition from the 
visualization. For example, if you have dragged a filter to 
the "Color by" drop target of a visualization, but later 
want to remove the coloring, you can drag the color 
selector from the legend to this drop target. 

 

Combination 
chart 

Splits the visualization according to the values in the 
column provided. 

 

All visualizations Attaches the selected tag to the marked rows. 

5.1.4 Zoom Sliders 
By clicking on the small arrow icon in the title bar of a visualization you can turn on or off 
zoom sliders for the axes in a visualization. (The icons in the title bar are only shown when 
hovering with the mouse pointer over the title bar area.) 

 
Zoom sliders are used to get a closer look at details in your visualization. The line chart below 
shows the stock price for a certain stock, from January 2002 to December 2003. Below the chart 
is a zoom slider with its handles in the end position showing the entire span of the X-axis. 

 
Perhaps you are curious as to what happened to the stock in a narrower span of time, say from 
November 2002 to May 2003. By adjusting the handles of the zoom slider, the visualization is 
updated and zooms in on the selected span. 
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You can now grab the gray part of the zoom slider and drag it to the left or right to pan 
horizontally. If you like you can also turn on a zoom slider for the Y-axis. 

Zoom to selection 
When the zoom sliders are shown, it is also possible to press the Ctrl+Alt+Shift buttons on the 
keyboard and click and drag with the mouse around several items. This will automatically zoom 
to the selected items, without marking them. 

5.2 Column Selectors 
5.2.1 Column Selectors 

When you open data in TIBCO Spotfire and create a visualization, you can select which data 
columns should be used to determine how the visualization looks using column selectors. These 
are found in three different places: 
On the axes of a visualization, 
In the legend of a visualization, 
In dialogs. 
For the most part, column selectors behave in the same way regardless of where they are found 
in the application. Clicking on the selector brings up a list of all available columns. It is also 
possible to search for columns in a search field, or to add multiple columns by selecting Select 
Columns... For information on the syntax for searches, see the Searching in TIBCO Spotfire 
page. 
There are however, some differences between the column selectors found on the axes and the 
ones found in the legend. See Axis Selectors and Legend Selectors below to learn more. 
As mentioned, column selectors are also accessible from dialogs throughout the application. In 
the properties dialog of a visualization you can always make all the settings that you can make 
from any axis or legend selectors. From a properties dialog you can also configure more details 
than in the visualization itself. 

Axis Selectors 
Most visualizations in TIBCO Spotfire include some type of axis selectors, where you can 
change what will be shown on each axis in the visualization. 

 
The axis selectors are the same type of column selectors which are used in almost all places 
where you can select one or more columns or hierarchies to specify a property. This includes 
the Visualization Properties dialogs. Clicking on a column selector will display the columns you 
can select, together with any aggregation measures. See Non-Column Selections to learn about 
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menu alternatives which are not columns. Right-clicking on the column selector will display a 
different menu, where additional advanced options can be changed. 

► To switch column on an axis: 
1. Click on the arrow next to the name of the previously used column. 

Comment: In the example above, the arrow next to Year. 
2. Select a new column from the menu. 

Comment: All columns that are allowed on the specific axis will be shown. 
Response: The visualization is updated to use the new column. 

► To switch column on an axis using drag and drop: 
1. Select a filter in the filters panel that corresponds to the column you want to use on the 

axis. 
2. Drag that filter from the filters panel to the axis selector area. 

Response: A visual indication is shown depending on where you position the dragged 
filter. 

3. Drop the filter straight onto the axis selector. 
Response: The visualization is updated to use the new column. 

On most of the axes, you can select to display more than one column simultaneously. This will 
create a hierarchical structure on the axis, as seen below: 

 

► To add a column to an axis: 
1. Click on the arrow next to the plus sign on the axis of your choice. 
2. Select a new column from the menu. 

Response: The visualization is updated to show data from the new column as well as 
from the old one. 

3. If desired, you can rearrange the order of the current axis columns using a drag-and-
drop operation. 
Comment: See "Hierarchies" for more information. 

► To add a column to an axis using drag and drop: 
1. Select a filter in the filters panel that corresponds to the column you want to add to the 

axis. 
2. Drag that filter from the filters panel to the axis selector area. 

Response: A visual indication is shown depending on where you position the dragged 
filter. 

3. Drop the filter next to the axis selector where a thick black line appears. 
4. If desired, rearrange the order of the current axis columns using a drag-and-drop 

operation. 
Comment: See "Hierarchies" for more information. 

► To remove a column from an axis: 
1. Click on the arrow next to the name of the column you wish to remove. 
2. Select Remove from the menu. 

Response: The column is removed from the axis and from the visualization. 

► To use a custom expression on an axis: 
1. Right-click on the axis of your choice. 
2. Select Custom Expression... from the menu. 
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Comment: See How to Insert a Custom Expression for more information. 

► To change the display name on a column selector: 
1. Right-click on the column selector you want to modify. 
2. Select Custom Expression... from the menu. 
3. Under Display name, enter the name you want to display on the column selector. 
4. Click OK. 

Response: The text you entered is now displayed on the column selector. 
Comment: If the axis is set up with more than one column, you need to change the 
expression itself to modify the name. See below to learn how. 

► To change display name on a column selector with multiple 
columns: 

If you want to change the display name on an axis that is set up with more than one column, you 
need to modify the actual expression behind the axis. For example, you may have a line chart 
where the Y-axis shows one line for sum of sales, and another line for sum of gross profit. The 
column selectors would then appear as seen below: 

 
 You may want to shorten the names on the column selectors to say just Sales and Profit 
respectively. To do that, follow the steps below: 

1. Right-click on the column selector you want to modify. 
2. Select Custom Expression... from the menu. 
3. Under Expression, you will see this text string: Sum([Sales Total]), Sum([Gross 

Profit]). 
4. Now modify the text string to say this instead: Sum([Sales Total]) AS Sales, 

Sum([Gross Profit]) AS Profit. 
5. Click OK. 

Response: The display names on the two column selectors will now be Sales and 
Profit: 

 
Comment: If the lines have different colors, you may have to readjust the coloring 
manually after you have changed the display names on the column selectors. 
Comment: If you only want to change one or some of the names on an axis, just leave 
the other ones as they are. 

► To dynamically change the column used on an axis by marking 
in another visualization: 
1. Right-click on the axis of your choice. 
2. Select Column from Marked... from the menu. 

Comment: See What is Column from Marked? and Details on Column from Marked 
for more information. 

► To use a property on an axis: 
1. Right-click on the axis of your choice. 
2. Select Set from Property... from the menu. 

Comment: See Using Properties in the Analysis and Details on Set from Property for 
more information. 
Note: This is a shortcut to set a property on the axis. You can do more advanced 
settings in the Custom Expression dialog. 
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Legend Selectors 
In the legend of a visualization, there are different types of column selectors, depending on what 
kind of visualization you are currently viewing. These selectors provide dimensions to your 
visualization beyond what axis selectors can do. Right-click anywhere in the legend to open a 
menu where you can select which column selectors are to be visible in the legend. For more 
information, see Legend. 

 
Each of these options are explained in detail in the properties descriptions for each type of 
visualization. 
Note that the column selector Marker by may potentially affect how other column selectors 
can be configured. If you choose to have markers represent the contents of a column, as 
opposed to column names or row number, and the data in this column is possible to aggregate, 
the option Aggregation will activate on the appropriate column selectors. TIBCO Spotfire will 
also try to set the axis selectors to the most meaningful aggregation. See Aggregation for more 
information. 
You can select either (None) or Remove from a column selector to reset it. For example, setting 
the Size by option in a scatter plot to (None) will make all markers be the same size instead of 
having the size depend on a certain column. 
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5.2.2 Non-Column Selections 
For many visualizations, there are three special options available on the column selector menu: 
(Column Names), (Row Number), and (Row Count). The use of these options is best described 
with examples. 

Column Names 
The data table below contains sales data for a company's total business during a year, all the 
sales of fruit and vegetables for 2001. 
It has two separate columns stating the sales and cost of each transaction, and we now want to 
compare the total sum of sales to the total sum of cost. 

 
In the image below, we have set up a bar chart where the value axis shows sum of sales, and 
also sum of cost. The problem now is to decide what to show on the category axis. Normally, 
we would select a column from the column selector, and each unique value in that column 
would correspond to a bar. However, this will not help us achieve the bar chart we want now, as 
seen below. 

 
Instead, we select the (Column Names) option from the category axis selector. This means that 
we take the value column names used on the value axis, and create a bar for each of these 
names. Since the scale is the same, we can easily plot the two columns as bars beside each 
other. 
In another example where the data table contains several years, we use a line chart to see the 
trends of the sum of sales and the sum of cost over the years. Again, the Y-axis shows sum of 
sales and sum of cost, but we want the X-axis to show the years. We therefore have to set 
(Column Names) on another visualization property in order to see the two different lines. By 
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setting Color by to (Column Names) we get two lines with different colors, one for each column 
on the Y-axis. 

 

Row Number 
The second special option for the column selectors is called (Row Number). This will plot a bar 
for each row in the data table (when used on the category axis of a bar chart). As mentioned 
before, we would normally select a column from the column selector, and each unique value in 
that column would correspond to a bar. If several rows have the same identical value, these will 
be aggregated and displayed as the same bar, showing the sum or average of the included 
values. 
Selecting (Row Number) on the category axis selector will let you see each individual 
transaction (row) as an individual bar, which can be useful for spotting extreme values. 

 

Row Count 
The third special option is called (Row Count), and is used when you want a visualization to 
display the number of rows in your data table. If you select (Row Count) on the value axis of a 
bar chart, the height of each bar will show the number of rows that correspond to the selected 
column on the category axis. The bar chart below shows sales data by order date for each month 
of a year. (Row Count) was selected on the value axis, which means that the height of each bar 
shows the number of orders for each month. 
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In the example below, a cross table shows the number of sales transactions for fruit, spices, and 
vegetables in four different sales regions. Each cell in the cross table displays the total number 
of sales transactions, and in this example the rows have also been colored by (Row Count) to 
further highlight the cell values. 

 

5.2.3 What is Column from Marked? 
The Column from Marked function is a way to look up which column to assign to a column 
selector by fetching the cell value in a data table. The cell would then contain the name of the 
column you want to assign to a property in a visualization, such as what to use on the X-axis or 
what to color by. 
Use the Column from Marked function when you want to update the visualization iteratively 
and quickly set another column for the property. Once Column from Marked has been 
configured, pointing to a new cell by marking a row updates the property. If you only want to 
configure a visualization to use a certain column, you should not use the Column from Marked 
function. 

Example: 
The Data Relationships tool uses the Column from Marked function to display the results from 
the calculation. The purpose of the Data Relationships tool is to calculate the correlation 
between the columns in a table, and then find and display highly correlated columns to see what 
they look like, one plotted against the other. See What is the Data Relationships Tool? for 
information about how to perform such a calculation. 
The result from the Data Relationships tool is a new data table where each row shows the 
correlation between two columns from the original data table. The row includes the names of 
the two compared columns, and values for how well they correlate. 
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The tool creates two visualizations, one table visualization that displays the new correlation data 
table, and, in the linear regression case, one scatter plot that shows one column plotted against 
the other from the original data table. As you mark a row in the new correlation data table, the 
scatter plot is updated to display the two compared columns from that row. In this 
configuration, the X- and Y-axes of the scatter plot are configured using Column from Marked. 
That is, the names of which columns to display are fetched from the marked row in the new 
correlation data table. You change the marking by clicking on a row in the table visualization. 
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The way this is set up, you can quickly browse the correlation between columns by stepping 
through the rows in the table visualization. To update the scatter plot manually by interacting 
with the column selectors of the X- and Y-axes would take a much longer time. 

5.2.4 Details on Column from Marked 
The Column from Marked functionality allows you to create a visualization which changes 
what column is used on an axis depending on what you mark in a different visualization. This 
makes it possible to create a visualization that is connected to, say, a table visualization for 
example, in such a way that when you click on the table, the axes of the new visualization will 
change to show the values of a specified cell in the table. The cell should contain a column 
name available in the current data table. For an example of how it works, see the automatically 
created visualizations from a Data Relationships calculation. 

► To reach the Column from Marked dialog: 
1. Right-click on the axis selector of the axis of interest. 
2. Select Column from Marked... from the pop-up menu. 

Note: Once the Column from Marked functionality has been switched on, it will be used to 
continuously update the visualization until it is switched off. This means that any other 
configuration that you try to apply to the visualization will be lost each time the marking 
changes. 
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Option Description 

Data table Lists the available data tables. This is where you select the data table 
containing the column with all column names. 

Column Lists the available columns in the selected data table. Select the 
column containing all column names that should appear on this axis 
upon marking. 

Row from 
marking 

Lists the available markings. Select the marking that should define 
what is shown on this axis. If more than one item is marked, the first 
item will be used to define the value to use on the axis. 

Expression   

   Default as 
specified above 

The expression is by default set to the plain cell value as specified by 
the input fields at the top of the dialog. 
A suitable aggregation method is automatically selected depending on 
the type of axis in the visualization. The text "Sales 2004" can, thus, be 
interpreted as "[Sales 2004]"  on the Y-axis of a scatter plot, as 
"Sum([Sales 2004])" on the value axis of a bar chart and as "<[Sales 
2004]>" on a categorical category axis of a bar chart. 

   Advanced The {0} variable refers to the value defined by the three input fields in 
the dialog (the plain cell value) and the cell value is automatically 
escaped to a column expression by the addition of straight brackets. 
It is possible to extend this expression and include additional columns 
and/or apply aggregation methods. 
The expression is extended using the same syntax as custom 
expressions. 
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If additional columns are specified, these will appear as individual 
column selectors for the visualization property once the Column from 
Marked function has been applied. 
  
Examples: 
The expression "{0}, [Sales 2005]" applied on a continuous column 
containing the column names "Sales YearX" could result in "[Sales 
2004], [Sales 2005]" , "[Sales 2003], [Sales 2005]", etc., on the axis, 
depending on what year was marked. 
  
The expression "Sum({0})" would result in the expression "Sum([Sales 
2004])", hence, an aggregated, continuous column on the axis. 
  
The expression "Sum({0}) over AllPrevious([Axis.X])" would result in 
the expression "Sum([Sales 2004]) over AllPrevious([Axis.X]", hence, 
a cumulative sum on the axis. 
  
The expression "<{0}>" with a categorical column containing genders 
would result in the expression "<[Male]>" or "<[Female]>" on the 
axis, depending on what was marked. 
  
The expression "<{0} nest [Product]>" with a categorical column 
containing genders would result in the categorical hierarchy "<[Male] 
nest [Product]>" or "<[Female] nest [Product]>" on the axis, 
depending on what was marked. 

Sample Displays a sample of the currently used expression. 

5.2.5 Details on Set from Property 
This dialog is used to specify that the axis value should be picked from a string document 
property containing a column or an expression value. See Using Properties in the Analysis for 
more information. 

► To reach the Set from Property dialog: 
1. Create a visualization. 
2. Right-click on the column selector where you want to use a property. 
3. Select Set from Property... from the pop-up menu. 
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Option Description 

Select the 
property to use 

Click to select a property to use on the axis. Note that only string 
properties can be used on axes. 
The string value of the property will be interpreted as a column name 
or an expression containing column names. See Properties in 
Expressions for more information about the syntax for property 
expressions. 

New... Opens the New Property dialog where you can define a new property 
to define the axis. 
Note that you can only use string properties on axes. The property 
should contain a value that can be interpreted as a column or a column 
expression. 

Edit... Allows you to edit the first (default) value to use on the selected 
property. 

Delete Deletes the selected document property. 

5.2.6 Aggregation 
Aggregation is the grouping of data using statistical measures. For example, you could select to 
show the Sum of all Sales for a year or the Average Sale for each month. 
To use aggregation, your visualization must meet the following requirements: 
The underlying data table must contain at least one numeric column. For example, an Integer, 
Real, or Currency column. 
The visualization type must support aggregation. Some visualizations, like Tables, do not 
support any aggregation. Others can use aggregation on the coloring axis or some other axis 
only. 
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In visualizations which support aggregation  you can aggregate the data using one or more 
column selectors, for example, the axis selectors or the color selector. 
Click on an axis selector and select Aggregation to show a list of common statistical measures 
to use for aggregation. A submenu with more options is opened if you select More. You may 
also choose (None), which will remove aggregation from this axis. 

 
The different options available are statistical measures that may be used to aggregate the data 
column. For a complete list of what Statistical Measures are available in TIBCO Spotfire, see 
Statistical Measures Overview. Not all statistical measures will be available at all locations. 

Missing Aggregation Menu? 
Some visualizations, for example scatter plots, are not aggregated by default. Instead, they 
display one item per row (Marker By is set to (Row Number)) and the Aggregation menu is not 
available in the axis selector. To display the Aggregation menu you need either to set Marker 
By to (None) or to use the column by which you want to aggregate on the Marker By selector. 
An axis needs to be aggregated if you, for example, intend to display scatter plot markers as 
pies. 

5.3 Legend 
The legend can be displayed either as a temporary popover which is visible until you click 
somewhere outside it, or as a docked part of the visualization. It can be docked either to the left 
or to the right in a visualization. If the legend is hidden you can click on the Legend button in 
the visualization features menu to show it (the icons in the title bar are only shown when 
hovering with the mouse pointer over the title bar area.): 
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Use the popover when you need to use as much as possible of the screen estate for the 
visualizations themselves: 

  

The popover can be turned into a docked legend by clicking on the Dock ikon, , at the top 
right of the popover. 
Use the docked legend when the information within it is necessary  for interpreting the 
visualization at all times, or when the visualization is to be exported to another media, such as a 
PowerPoint presentation, where the popover is unavailable: 

 
The docked legend will be turned into a popover if you click on the Legend button in the title 
bar. 
By clicking on the small arrow icon in the title bar of a visualization you can show or hide the 
docked version of the legend: 
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You can also show or hide the docked legend by right-clicking on the visualization and 
selecting  Visualization Features > Legend from the pop-up menu, or by using the Legend 
page in the Visualization Properties dialog. 
Note: If the visualization becomes too small in either direction, controls such as the legend, 
zoom sliders, axis selectors, etc., are hidden and cannot be viewed until the size of the 
visualization is increased. 
The legend can present things like what parameter in the visualization is represented by each 
color. Just like for any other column selector, you can click on the column selectors in the 
legend and pick another column. In the case of coloring, you can also select multiple columns to 
color by. This means that each unique combination of the values in the columns you pick will 
get a unique color. You can change the colors used in the visualization directly from the legend. 
Click on the color box in the legend to open a color palette where you can select another color. 
Clicking on the shape icon under Shape by similarly allows you to switch shape. 

 
What information is available in the legend by default varies with the visualization type. For 
example, the legend of a pie chart will show which column determines the size of the pie 
sectors, and the legend of a scatter plot will state if a column is set to represent marker size or 
marker shape, etc. You can edit all such parameters, by clicking on the respective column 
selectors in the legend. When multiple data tables are available in the analysis, the legend for all 
new visualizations will automatically display a data table selector. 

► To specify what will be visible in the legend: 
1. In the visualization, right-click to display the pop-up menu. 
2. Select Properties. 
3. Click to display the Legend page. 
4. Select the check boxes for the items you wish to show, and clear the check boxes for 

items that should be removed from the legend.  
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5. By clicking on a legend item in the list on the Legend page the Settings group box 
becomes enabled (where applicable). Here you can select whether or not to Show title 
and Show axis selector for the selected item. 
Comment: Only legend items that can show both title and axis selector will have the 
setting available. See the description of the Visualization Properties Legend page for 
more information. 

► To change the position of the docked legend: 
1. In the visualization, right-click to display the pop-up menu. 
2. Select Properties. 
3. Click to display the Legend page. 
4. Select the Left or Right radio button.. 

5.4 Shortcuts 
► To switch to a different visualization: 
If you have set up a good layout of visualizations, but then want to change one of the 
visualizations to a different type, you can right-click on the visualization and select Switch 
Visualization To > [desired visualization]. 

► To change the title of a visualization: 
1. Double-click on the visualization title bar. 
2. Type a new Title. 
3. Click Close. 

► To hide the title bar of a visualization: 
1. Hover with the mouse pointer over the title bar of a visualization and click on the small 

arrow to the right. 

 
2. Select Title Bar. 

► To show the title bar of a visualization: 
1. Right-click on the visualization. 
2. Select Visualization Features > Title Bar from the pop-up menu. 

Comment: You can also show the title bar from the General page of the Visualization 
Properties dialog. 

► To show the legend for a visualization: 
1. If the title bar is displayed, click on the legend icon, . 

Comment: You can also right-click on the visualization and select  Visualization 
Features > Legend from the pop-up menu. 

2. If the legend is shown as a popover and you want to lock it to the visualization, click 
on the Dock button. 

► To show or hide the scale labels: 
This is applicable to visualizations with traditional axes only, such as scatter plots, line charts, 
bar charts, etc. 

1. Right-click on one of the scale labels. 
2. Select Show Labels on the pop-up menu. 
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► To change the orientation of the scale labels: 
This is applicable to visualizations with traditional axes only, such as scatter plots, line charts, 
bar charts, etc. 

1. Right-click on one of the scale labels. 
2. Select either Horizontal Labels or Vertical Labels from the pop-up menu. 

► To show or hide axis selectors: 
1. Hover with the mouse pointer over the title bar of a visualization and click on the small 

arrow to the right. 

 
2. Select X Axis Selector or Y Axis Selector from the drop-down menu. 

► To show or hide gridlines: 
This is applicable to visualizations with traditional axes only, such as scatter plots, line charts, 
bar charts, etc. 

1. Right-click on one of the scale labels. 
2. Select Show Gridlines on the pop-up menu. 

► To change an axis from continuous to categorical scale: 
This is applicable to visualizations with traditional axes only, such as scatter plots, line charts, 
bar charts, etc. 

1. Right-click on one of the scale labels. 
2. Select Categorical Scale on the pop-up menu. 

Comment: Click Continuous Scale to return. 

► To change the formatting of an axis: 
This is applicable to visualizations with traditional axes only, such as scatter plots, line charts, 
bar charts, etc. 

1. Right-click on one of the scale labels. 
2. Select Formatting and the desired format from the pop-up menu. 

► To hide empty values from a categorical time-series axis: 
This is applicable to visualizations with traditional axes only, such as scatter plots, line charts, 
bar charts, etc. 

1. Right-click on the scale labels for the categorical axis. 
2. Select Categories > Show Filtered Values from the pop-up menu. 

Comment: Show Filtered Values will only display those categories where values are 
present, and hide all categories without values. Show Filtered Range will only remove 
empty values from outside of the current range where values are present. 

5.5 Hierarchies 
5.5.1 Hierarchies 

By adding more than one column to the axis selectors, you can create a hierarchy in the 
visualization. In the example below the column Year and the column Category have been added 
to the category axis. The bar chart automatically displays a bar for each combination in the 
hierarchy - in this case the sale of fruit and vegetables per year. 
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You can change the hierarchy order, if you prefer to see the bars in another way. Drag the 
Category axis selector and drop it to the left of the Year axis selector. 

 
This causes the bar chart to change the order of the bars. As you can see below, the bars 
concerning fruit sales are now placed next to each other. Note how the hierarchy displayed in 
the labels below the bar chart corresponds to the order of the axis selectors. 

 
The order of columns can also be changed in the Visualization Properties dialog, either by drag-
and-drop, or, by right-clicking on a column selector and selecting Move Up/Move Down or 
Move Left/Move Right from the pop-up menu. 
Using predefined hierarchies, you can create even more powerful axis hierarchies and get 
access to the hierarchy slider - a tool that helps you change the level of detail in a visualization 
fast and easily. Predefined hierarchies are also necessary if you want to set up hierarchy filters. 

5.5.2 Hierarchy Slider 
As explained in the Hierarchies chapter, adding multiple columns to the column selectors 
creates a hierarchy in the visualization. However, you can also add "predefined" hierarchies to 
your column selectors. A predefined hierarchy is a hierarchy that has been set up while working 
with the data itself, or while creating a hierarchy filter in the filters panel. These hierarchies are 
even more powerful, and provide an additional feature in the visualization - the hierarchy slider. 

Example of the Hierarchy Slider 
Suppose you have a hierarchy filter called Date of Sale, which consists of a hierarchy of 
Year/Quarter/Month. 
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Drag this filter and drop it onto the axis selector of the category axis of a bar chart. This is the 
result: 

 
Since the filter was a hierarchy filter, the labels underneath the bar chart states which bars 
represent the sales for each month, but they also show which months are part of a quarter, and 
which quarters are part of a certain year. 
You will note that there is only one axis selector, unlike in the example using many columns on 
the axes to build a hierarchy, where there were several axis selectors. You will also note that 
there is a slider on top of the axis selector. This is the hierarchy slider, a tool that lets you 
change the level of detail of the visualization. If you were to drag the handle of the hierarchy 
slider one step to the left, this is what would happen to the bar chart: 

 
The bars are now automatically updated to show the total sales for each quarter, instead of for 
each month. Dragging the handle yet another step would update the bar chart to show the total 
sales for each year. 
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The hierarchy slider will appear for all predefined hierarchies. These can be geographical trees 
showing continent/country/city, or product categories and the products therein, etc. 

Time Hierarchies 
When you are working with time-series data (Date, Time or DateTime columns) you have the 
choice to either use a part of the time or date, or to set up a hierarchical structure directly. The 
hierarchical model allows you to quickly change the time resolution in your visualization. You 
simply go to the time-series column using the column selector menu, see the lower part of the 
menu and select the hierarchical structure of your choice. The hierarchy slider will be shown 
immediately. 
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Set the level of detail to show in the visualization by using the hierarchy slider as discussed 
above. See Working with Time Hierarchies for more details about how time-series data can be 
handled. 
If you instead select a single time part you will not have the hierarchy slider available in the 
visualization and the only time part available will be the one you selected: 

 

5.5.3 Working with Time Hierarchies 
Sometimes you may work with data where some category values are missing. If the 
visualizations make use of a Date, Time or DateTime column and you like to present the data in 
an aggregated form, missing data may have strange effects on your calculations. For example, 
below is a cumulative sum of sales for a few years, where data for three quarters are missing: 

 
In this example, you might want the bars for the missing quarters to be of the same size as the 
last available bar rather than completely missing. This can be accomplished by using 
Compensate for missing values via the Appearance page of the visualization. Compensate for 
missing values is available in the bar chart, line chart and combination chart. It introduces a 
gap-filling mechanism where empty values can be temporarily inserted for the missing rows. 
This way, the cumulative sum can instead show the same value as the last available bar for the 
bars with missing data: 

 
Note: Compensate for missing values only works with true Date, Time or DateTime columns. 
The check box will have no effect on a hierarchy made by putting together string values from 
different columns (such as Year, Month and Day). 
  
Data values in general can be valid values (non-null and non-error), invalid values (errors, such 
as a value of a different data type than the rest), or empty values (where the row identifier is 
there, but there is no value in the value column). There may also be completely missing 
categories. For most kinds of data, this may be difficult to handle, but time-series can be filled 
out with the missing data points, since it is always possible to calculate which time points 
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should have been available. TIBCO Spotfire can temporarily add the missing rows and fill them 
with empty values so they can be used in calculations. 
When Compensate for missing values is used, the max and min values in the time column are 
determined. Then all missing steps, depending on the time hierarchy level, are added. 
Multiple date/time parts on different axes can be combined in a visualization as long as the 
same date/time column is used. 

Categories 
When categorical time values are used in a visualization, you can control what to show using 
the Categories setting on the axis. If you want to completely hide those categories where no 
data is available (either due to filtering or to missing data) this can be done by selecting the 
Show Filtered Values setting: 

 
In the first image on this topic, there is an example of a visualization with missing values where 
no compensation for missing values has been made and the Show Filtered Range setting has 
been selected. This option will only hide empty categories on each side of the range, but not in 
the middle. There is also an option to Show All Values where the currently filtered-out values 
on the sides also remain visible. 
Change the setting in the Advanced Settings dialog or by right-clicking on the visualization axis 
and selecting Categories and one of the options from the pop-up menu. Use zoom sliders to 
work with continuous time axes. 

Mixed Hierarchies 
Mixed hierarchies with both date and/or time parts (from the same datetime column) and other 
categories are supported by treating the categories as part of the group by hierarchy. The 
combinations to show are specified in the Advanced Settings dialog or using a custom 
expression. 

Max Number of Added Rows 
If the range of the date/time column is significantly larger than the step size, a huge number of 
rows may be needed when compensating for missing values. For example, this will be the case 
when the step size is millisecond and you have dates spanning several years. For performance 
reasons a property limit is defined, determining the max number of rows that can be inserted. 
The MaxMissingTimeParts property can be changed under Edit > Document Properties, 
Properties tab. An administrator can also change this preference by going to Tools > 
Administration Manager, Preferences tab, and then clicking on DataOptimizationPreferences 
under DataOptimization and editing the MaxMissingTimeParts preference. 
Note that the limit for max number of rows to add is based on the size of the span and not on the 
actual missing values. This means that if the preference value is set too low, you may encounter 
this limit even though not that many time parts were missing in the current setup. If the message 
"Could not compensate for missing values. The document property value for 
MaxMissingTimeParts has been exceeded." is encountered, you might want to increase the 
property value, but the solution may also be to clear the Compensate for missing values check 



Using Visualizations 

665 

box or simply to try to reduce the granularity on the time series axis by using a hierarchy slider 
(if one is available). 

Marking Temporarily Added Rows 
When a visualization item based on temporarily added rows is marked it will look like a regular 
marking in the visualization. However, since no real rows are marked, this marking will not be 
propagated to any other visualizations nor to the Details-on-Demand. 

BinByDateTime 
A time hierarchy is actually built using the BinByDateTime function. This function uses three 
arguments: 1) The Date, Time or DateTime column, 2) the hierarchy definition as a string of the 
date parts separated by dots, and 3) the pruning level (meaning which level to start the hierarchy 
slider position on). For example, BinByDateTime([Column],"Year.Quarter.Month.Day",2) 

5.6 Trellis Visualizations 
Trellised visualizations enable you to quickly recognize similarities or differences between 
different categories in the data. Each individual panel in a trellis visualization displays a subset 
of the original data table, where the subsets are defined by the categories available in a column 
or hierarchy. 
For example, if you choose to trellis a visualization based on the two variables "Gender" and 
"Political affiliation", this will result in four separate panels representing the combinations 
Female-Republican, Female-Democrat, Male-Republican, and Male-Democrat. If the "Gender" 
variable is used in conjunction with another variable that has five different values, this will 
yield ten panels. From this follows that variables with a continuous distribution and a wide 
range of values (for example, Real values) should be binned before they are used to form a 
trellis visualization. Otherwise the number of panels quickly becomes unmanageable.   

Example: 
This is a standard non-trellised scatter plot: 

 
By trellising this visualization based on Gender and Political affiliation, it will look like this: 
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► To trellis a visualization: 
1. Select the visualization you want to trellis. 
2. Right-click on the visualization and select Properties. 
3. Select Trellis. 
4. Select the Rows and Columns you want to trellis by. 
5. Specify additional trellis parameters, and click Close. 

5.7 Information and Warnings 
Information Icons in Visualizations 
If there are items in a visualization that cannot be shown or might be misinterpreted because of 
some settings, an icon will appear in the title bar of that visualization. If something cannot be 
shown, a notification icon, , will appear. If there is a risk that something might be 
misinterpreted due to lack of data to calculate a curve or similar, a warning icon, , will 
appear. On mouseover, a tooltip will appear, and if you click the icon a longer description will 
appear. 

Details Link 
If you are currently running some heavy calculations, or, if there is some trouble with the 
loaded data or a calculation in the analysis, you will see a Details... link in the lower left corner 
of the TIBCO Spotfire window. 
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Click on the link to display progress information or notifications about current issues. You can 
copy alerts to the clipboard and use the information when communicating with others during 
troubleshooting of an analysis. 
  

5.8 Statistical Measures 
5.8.1 Statistical Measures Overview  

TIBCO Spotfire contains several visualizations and tools which calculate various measures. For 
a description of each measure, see the corresponding section. 
Note: For measures where a large statistical selection is needed, the result from a calculation 
may vary with the number of available values. 

5.8.2 Sum and Product 
Sum 
The sum of all values in the subset. If no categorization has been applied, then the sum will 
show the total sum of all values in each column: Sum = x1+x2+x3.... 

Product 
The product of all values in the subset. If no categorization has been applied, then the product 
will show the total product of all values in each column: Product = x1*x2*x3.... 
  

5.8.3 Average  
The mean, or average, is calculated as the sum of all values in the distribution divided by the 
number of values. 
The arithmetic mean value, , is calculated as: 

 
  

5.8.4 Count  
The Count measure gives the number of values in a column, not counting empty values. In the 
table below, Column A has a Count of 3, while Column B has a Count of 4. 

Column A Column B 

1 4 

  7 

8 3 

9 6 
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5.8.5 Unique Count 
The Unique Count measure gives the number of unique (distinct) values in a column. Empty 
values are not counted. In the table below, column A has a unique count of two and column B 
has a unique count of three. 

Column A Column B 

1 4 

  4 

1 3 

9 6 

5.8.6 Min and Max 

 

Max is the maximum (highest) value of the selected subset. 
Min is the minimum (lowest) value of the selected subset. 
Range = Max-Min. 

  

5.8.7 Median  
The median of a distribution is the value which, when the distribution is sorted, appears in the 
middle of the list. If the number of values is even, the median is computed by taking the average 
of the two middle values. 
The median is sometimes called the location of the distribution. 

5.8.8 Standard Deviation  
The standard deviation (StdDev), s, is an indication of how dispersed the probability 
distribution is about its center. It is computed as follows: 
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where 

• is the average value of the group 
• n is the number of values in the group (Count) 

If the number of values (n) is one, an error is returned. 

5.8.9 Standard Error  
The standard error (StdErr) is the standard deviation of the calculated mean. It is calculated as 
the estimated standard deviation divided by the square root of the size of the sample. 

5.8.10 Variance  
The sample variance, s2, is an indication of how dispersed the probability distribution is about 
its center. It is calculated as follows: 

 
where 

• is the average value of the group 
• n is the number of values in the group (Count) 

If the number of values (n) is one, an error is returned. 

5.8.11 Confidence Intervals  
Confidence intervals are calculated as: 

 
where 

• is the average value of the group 
• s is the sample standard deviation 
• n is the number of values in the group (Count) 

The L95 value is the lower endpoint of the confidence interval. 
The U95 value is the upper endpoint of the confidence interval. 

5.8.12 Percentiles and Quartiles 
Percentiles 
A percentile is a measure at which that percentage of the total values are the same as or below 
that measure. For example, 90% of the data values lie below the 90th percentile, whereas 10% 
of the data values lie below the 10th percentile. 

Quartiles 
Quartiles are values that divide a (part of a) data table into four groups containing an 
approximately equal number of observations. The total of 100% is split into four equal parts: 
25%, 50%, 75% and 100%. 
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The first quartile (or lower quartile), Q1, is defined as the value that has an f-value equal to 
0.25. This is the same thing as the twenty-fifth percentile. The third quartile (or upper quartile), 
Q3, has an f-value equal to 0.75. The interquartile range, IQR, is defined as Q3-Q1. 

► The percentiles and quartiles are computed as follows: 
1. The f-value of each value in the data table is computed: 

   
where i is the index of the value, and n the number of values. 

2. The first quartile is computed by interpolating between the f-values immediately below 
and above 0.25, to arrive at the value corresponding to the f-value 0.25. 

3. The third quartile is computed by interpolating between the f-values immediately 
below and above 0.75, to arrive at the value corresponding to the f-value 0.75. 

4. Any other percentile is similarly calculated by interpolating between the appropriate 
values. 

Example: 

Value f-value 

4 0 

8 0.2 

9 0.4 

11 0.6 

16 0.8 

17 1.0 

Interpolation at f-value=0.75 yields Q3=14.75. 
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5.8.13 Adjacent Values and Outliers 

 

Adjacent values 
Let IQR be the interquartile range. 
The upper adjacent value (UAV) is the largest 
observation that is less than or equal to the upper 
inner fence (UIF), which is the third quartile 
plus 1.5*IQR. 
The lower adjacent value (LAV) is the smallest 
observation that is greater than or equal to the 
lower inner fence (LIF), which is the first 
quartile minus 1.5*IQR. 
Note: If, by the above definition, the UAV is 
such that it is smaller than Q3, then it is set equal 
to Q3. Similarly, the LAV is never allowed to be 
greater than Q1. 

Outliers 
Outliers are all values that fall outside either of 
the fences. Outside values are values that fall in 
between the inner and outer fences. Far out 
values are outside the outer fence. 
The upper outer fence (UOF) is defined as the 
threshold located at Q3 + (3*IQR). The lower 
outer fence (LOF )is defined as the threshold 
located at Q1 – (3*IQR). 
The outlier percentage is the count of outliers 
divided by the total count for each category. 

  

5.8.14 Concatenate and Unique Concatenate 
The Concatenate measure appends all values in the subset into a string. 
The Unique Concatenate measure appends all unique values in the subset into a string. This 
means that each value will only be included in the string once. 

Example: 

Column A Column B Column C 

1 1 1 

1   3 

1 3 3 

With the columns from the table above, the following result would be given: 
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Column Concatenate Unique Concatenate 

A 1, 1, 1 1 

B 1, 3 1, 3 

C 1, 3, 3 1, 3 

  

5.8.15 First and Last 
First returns the first valid value based on the physical order of the rows of data in the selected 
column. 
  
Last returns the last valid value based on the physical order of the rows of data in the selected 
column. 
  

5.8.16 Geometric Mean 
The geometric mean is the nth root of the product of all values in a distribution, where n is the 
number of values. It is generally preferred over the arithmetic mean when working with 
normalized values, percentages or exponential values. It is not suitable for calculations 
including any negative values or zeros. 
The geometric mean value, G, is calculated as: 

 
  
  

5.8.17 Mean Deviation 
The mean deviation (average absolute deviation, AAD) is calculated as the mean of the absolute 
difference between a value and the mean value of the group: 

 
where 

• is the average value of the group 
• n is the number of values in the group (Count) 

  

5.8.18 Median Absolute Deviation 
The median absolute deviation (MAD) is calculated as the median of the absolute value of each 
value, xi, minus the median of x: 

 
where 

• is the median value of the group 
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The median absolute deviation is used instead of the mean deviation when the deviation value 
needs to be less affected by extreme values in the tail. This is due to the fact that the median is 
less affected by the tail values than the mean is. 
  

5.8.19 Most Common 
Returns the most common value of the selected column. If several values are equally common, 
the first one will be used. 
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6 Enhancing Visualizations 
6.1 Coloring 
6.1.1 Coloring Overview 

By coloring the items in a visualization you can add an extra dimension to your data. For 
instance, you can use colors to identify outliers in the data, or to distinguish different categories. 
In TIBCO Spotfire there are many ways to customize the coloring in your visualizations. Most 
of the coloring settings can be found on the Colors page of the Visualization Properties for each 
visualization type. Configuration of the coloring settings works in a similar way for most of the 
visualization types. However, for the table, cross table, and heat map it works in a slightly 
different way. Coloring for those visualizations is therefore described separately. 
To learn more about coloring in Spotfire, see the following sections: 
Color Schemes Overview 
Color Modes Overview 
Color Rules Overview 
Coloring in Tables, Cross Tables and Heat Maps 
  

6.1.2 Color Schemes 

6.1.2.1 Color Schemes Overview 
The entire setup of colors for a visualization is referred to as its color scheme. Which colors and 
threshold values you choose, as well as the color mode you select, are all part of a 
visualization's color scheme. The current color scheme of a visualization can be viewed in the 
legend, and on the Colors page of the Visualization Properties. This is also where you edit a 
color scheme. In the example below two scatter plots are shown. Their respective color schemes 
are displayed in the legend. 

 
The visualization on the left has a color scheme with only two colors, each representing a 
category, while the visualization on the right has a color scheme with a somewhat more 
complex configuration. While the left color scheme can be defined directly in the legend, the 
right visualization's configuration requires that you open the Visualization Properties dialog. 
The two color schemes above are in different scale modes. The one on the left is a categorical 
color scheme, which means that it is colored by a categorical column. In this case, the column 
Category contains string values. The color scheme on the right is continuous. It is colored by 
the continuous column Sales, which contains Integer values. Different scale modes also create 
different possibilities. When setting up a color scheme for a visualization, the color mode you 
choose is essential. Since the available settings differ between different color modes, each mode 
is described separately. See Color Modes Overview to learn more about how to set up color 
schemes in each of the color modes. 
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Once you have configured a color scheme, you can save and reuse it in a number of ways. For 
example, you can apply a color scheme to another visualization in the same analysis. You can 
also save a color scheme to disk for later use, or in the library to share it with other users. When 
you are about to set up a new color scheme, you can make use of one of the predefined color 
schemes as a starting point, and then modify it to your liking. 
The following sections describe how you can use and reuse color schemes in a number of ways: 
Opening a Color Scheme 
Predefined Color Schemes 
Applying a Color Scheme to Another Visualization 
Saving a Color Scheme 
  

6.1.2.2 Opening a Color Scheme 
You can open a color scheme that has previously been saved to disk or to the library. You can 
also apply a color scheme from another visualization in the analysis, or open a document color 
scheme. The color scheme must be in the same scale mode as the visualization in which you 
want to use it. 

► To open a color scheme from file: 
1. Open the Visualization Properties dialog, and go to the Colors page. 

2. Click on the Color Schemes menu icon, . 
3. Select Open from File.... 

Response: A dialog where you can browse for a previously saved color scheme is 
opened. 

4. Browse to the color scheme of interest and click Open. 
Response: If it is a gradient color scheme, the selected color scheme is applied to the 
visualization. Otherwise, the Apply Method dialog is opened, continue to step 5. 

5. Click the Colors only radio button to apply only the colors in the color scheme to the 
visualization. Click Colors matched to values if you want to match the colors in the 
color scheme to the values in the visualization. 
Comment: See Details on Apply Method for an example of how the two options work. 

6. Click OK. 
Response: The selected color scheme is applied to the visualization. 

► To open a color scheme from the library: 
1. Open the Visualization Properties dialog, and go to the Colors page. 

2. Click on the Color Schemes menu icon, . 
3. Select Open from Library.... 

Comment: The menu option Open from Library is not available if you are working 
offline (without a connection to a server). 
Response: The Open from Library dialog is opened. 

4. From the Available color schemes list, select the color scheme you want to open. 
Comment: To limit the amount of items shown in the list, you can click on a keyword 
in the panel to the left. You can also search for a color scheme by entering a file name, 
or part of a file name in the search field. 

5. Click OK. 
Response: If it is a gradient color scheme, the selected color scheme is applied to the 
visualization. Otherwise, the Apply Method dialog is opened, continue to step 6. 



TIBCO Spotfire 4.0.2 - User's Manual 

676 

6. Click the Colors only radio button to apply only the colors in the color scheme to the 
visualization. Click Colors matched to values if you want to match the colors in the 
color scheme to the values in the visualization. 
Comment: See Details on Apply Method for an example of how the two options work. 

7. Click OK. 
Response: The selected color scheme is applied to the visualization. 

► To apply a color scheme from a visualization: 
1. Open the Visualization Properties dialog, and go to the Colors page. 

2. Click on the Color Schemes menu icon, . 
Response: The Color Schemes menu is opened. 

3. Select From Visualization to open the submenu. 
Response: The submenu lists all the existing pages in the analysis. 

4. Select the page of interest to open the submenu. 
Response: The submenu lists all the color schemes used in other visualizations on that 
page. 

5. Select the color scheme you want to use. 
Response: If it is a gradient color scheme, the selected color scheme is applied to the 
visualization. Otherwise, the Apply Method dialog is opened, continue to step 6. 

6. Click the Colors only radio button to apply only the colors in the color scheme to the 
visualization. Click Colors matched to values if you want to match the colors in the 
color scheme to the values in the visualization. 
Comment: See Details on Apply Method for an example of how the two options work. 

7. Click OK. 
Response: The selected color scheme is applied to the visualization. 

► To open a document color scheme: 
1. Open the Visualization Properties dialog, and go to the Colors page. 

2. Click on the Color Schemes menu icon, . 
3. Select Document Color Schemes to open the submenu. 

Response: The submenu lists all the previously saved document color schemes in the 
analysis. 

4. Select the color scheme you want to use. 
Response: If it is a gradient color scheme, the selected color scheme is applied to the 
visualization. Otherwise, the Apply Method dialog is opened, continue to step 5. 

5. Click the Colors only radio button to apply only the colors in the color scheme to the 
visualization. Click Colors matched to values if you want to match the colors in the 
color scheme to the values in the visualization. 
Comment: See Details on Apply Method for an example of how the two options work. 

6. Click OK. 
Response: The selected color scheme is applied to the visualization. 
Note: The menu option From Visualization is only available if other visualizations 
exist in the analysis. 
Note: The menu option Document Color Schemes is only available if one or more 
document color schemes have previously been saved in the analysis. See Saving a 
Color Scheme to learn more. 
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6.1.2.3 Predefined Color Schemes 
To facilitate setting up color schemes you can open one of the predefined ones and then adjust it 
according to your preferences. Predefined color schemes are only available for color schemes 
based on a column in continuous scale mode. Which predefined schemes are available differs 
slightly depending on the data type of the column. 

► To reach the predefined color schemes: 
1. Open the Visualization Properties dialog, and go to the Colors page. 

2. Click on the Color Schemes menu icon, . 
Response: The Color Schemes menu is opened. The predefined color schemes are 
located in the middle of the menu, as seen below. 

 

Option Description 

Top n A color scheme in Segments color mode. Items representing values 
from Min to Max get a single fixed gray color, and a rule states that the 
ten items with the highest values in the data get an orange color. 

Bottom n A color scheme in Segments color mode. Items representing values 
from Min to Max get a single fixed gray color, and a rule states that the 
ten items with the lowest values in the data get an orange color. 

Above x A color scheme in Segments color mode. Items representing values 
from Min to Max get a single fixed blue color, and a rule states that the 
items representing values above average get an orange color. 
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Below x A color scheme in Segments color mode. Items representing values 
from Min to Max get a single fixed blue color, and a rule states that the 
items representing values below average get an orange color. 

2 colors A color scheme in Segments color mode. Items representing values 
from Min to Average get a blue color, and items representing values 
from average to Max get a pink color. 

3 colors A color scheme in Segments color mode. Items representing values 
from Min to Q1 get a blue color, items representing values from Q1 to 
Q3 get a pink color, and items representing values from Q3 to Max get 
a yellow color. To learn more about quartiles, see Percentiles and 
Quartiles. 

2-point gradient A color scheme in Gradient color mode with a gradient transition from 
light green to dark green between Min and Max. 

3-point gradient A color scheme in Gradient color mode. Items representing values 
from Min to 0.00 are colored with a gradient transition from red to 
white. Items representing values from 0.00 to Max are colored in a 
gradient transition from white to blue. The Min and Max points are 
defined with custom expressions to ensure that items representing 
positive values are always colored in a blue nuance, and negative 
values are always colored in a red nuance. 

Min-average-max A color scheme in Gradient color mode. Items representing values 
from Min to average are colored with a gradient transition from green 
to black. Items representing values from average to Max are colored in 
a gradient transition from black to red. 

Exclude outliers A color scheme in Gradient color mode. Items representing values 
from LIF to UIF are colored with a gradient transition from light green 
to dark green. One rule states that items representing values greater 
than UIF should be white. A second rule states that items representing 
a lower value than LIF should also be white. To learn more about 
outliers, see Adjacent Values and Outliers. 

Spotfire 
categorical 

The default color scheme for categorical columns. 

Spotfire 
continuous 

The default color scheme for continuous columns. 

  

6.1.2.4 Applying a Color Scheme to Another Visualization 
When you have set up a color scheme for a visualization, you can apply it to another 
visualization, provided that the two visualizations are colored by a column in the same scale 
mode. 

► To apply a color scheme to a visualization: 
1. Open the Visualization Properties dialog, and go to the Colors page. 

2. Click on the Color Schemes menu icon, . 
3. Select Apply to Visualizations.... 

Response: The Apply to Visualizations dialog is opened. 
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4. From the Available visualizations list, select a visualization that you want to apply the 
current color scheme to, and click Add >. 
Comment: You can select and add an entire page if you want to apply the color scheme 
to all visualizations on that page. 
Response: The selected visualization or page is added to the Selected visualizations 
list (and removed from the Available visualizations list). 
Repeat step 4 until all the visualizations you want to apply the color scheme to have 
been added to the list. 

5. If the color scheme you are about to apply is categorical you need to select an Apply 
method. Click the Colors only radio button to apply only the colors in the color 
scheme to the visualization. Click Colors matched to values if you want to match the 
colors in the color scheme to the values in the visualization. 
Comment: See Details on Apply Method for an example of how the two options work. 
Click OK. 
Response: The current color scheme is applied to the selected visualizations. 
Note: If you apply a color scheme to a table, cross table, or heat map, the coloring will 
not take effect immediately. The color scheme will be added as an empty color scheme 
grouping, and you must select which columns or axis values to include in the grouping 
by opening the Edit Color Scheme Grouping dialog. 

6.1.2.5 Saving a Color Scheme 
You can save a color scheme for later reuse or to share it with others. If you save the color 
scheme to disk or in the library, you can use it in other analyses. If you save it as a document 
color scheme, you can use it again within the analysis. A document color scheme can be 
selected for a specific visualization in the analysis from the Colors page of the visualization 
properties. You can also select it as the default color scheme to use for a specific column as well 
as for new visualizations in the analysis. See Column Properties – Properties, Column 
Properties Descriptions, and Options – Visualization to learn more about using default color 
schemes. 

► To save a color scheme as a file: 
1. Open the Visualization Properties dialog, and go to the Colors page. 

2. Click on the Color Schemes menu icon, . 
3. Select Save As > File.... 

Response: The Save Color Scheme dialog is displayed. 
4. Specify a file name and a location for the color scheme. 
5. Click Save. 

► To save a color scheme as a library item: 
1. Open the Visualization Properties dialog, and go to the Colors page. 

2. Click on the Color Schemes menu icon, . 
3. Select Save As > Library Item.... 

Comment: The menu option Library Item... is not available if you are working offline 
(without a connection to a server). 
Response: The Save as Library Item dialog is displayed. 
Comment: The path in the upper part of the dialog shows your current location in the 
folder structure of the library. 

4. Navigate to the folder where you want to save the color scheme. 
Comment: Double-click on a folder to open it. Double-click on the folder with two 
dots, "..", to move up in the folder hierarchy. Click on the New Folder button to create 
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a new folder to save your color scheme in. To modify folder permissions, click on the 
Folder Permissions... button. To learn more about permissions, see Permissions. 

5. Specify a name for the color scheme. 
6. Optionally, type one or more Keywords describing the color scheme. Other users can 

then browse color schemes using keywords when opening from the library. 
Comment: Keywords are separated by a semicolon, i.e., if you write "corporate colors; 
categorical" this will be two keywords, "corporate colors" and "categorical". 

7. Click Save. 

► To save a color scheme as a document color scheme: 
1. Open the Visualization Properties dialog, and go to the Colors page. 

2. Click on the Color Schemes menu icon, . 
3. Select Save As > Document Color Scheme.... 

Response: The Save Document Color Scheme dialog is displayed. 
4. Click the New color scheme radio button and enter a name in the text field to save as a 

new document color scheme. Select the Replace existing color scheme radio button to 
overwrite a previously saved document color scheme. Select the color scheme to 
overwrite from the drop-down list. 

5. Click OK. 
Response: The saved document color scheme is now available in the Color Schemes 
menu. 

6.1.2.6 Details 

6.1.2.6.1 Details on Open from Library 
Use this dialog to select which color scheme to apply to the current visualization. 

► To reach the Open from Library dialog: 
1. In the Visualization Properties dialog, go to the Colors page. 

2. Click on the Color Schemes menu icon, . 
3. Select Open from Library.... 

Comment: The menu option Open from Library is not available if you are working 
offline (without a connection to a server). 
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Option Description 

Keywords Select (All) to see all the available color schemes in the library. Select 
a keyword from the list to see only color schemes with that particular 
keyword. 

[Type to search] Type a search string to limit the number of items in the Available color 
schemes list. It is possible to use the wildcard character * in the search. 
See Searching in TIBCO Spotfire for more information. 

Available color 
schemes 

Lists the color schemes that apply to the selected keyword and/or 
search string. 

6.1.2.6.2 Details on Edit Document Color Schemes 
This dialog is used to rename or delete previously added document color schemes.  
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Option Description 

Available color 
schemes 

Lists all previously created document color schemes.  

Rename... Allows you to rename the selected document color scheme. 

Remove Deletes the selected document color scheme. 

6.1.2.6.3 Details on Apply to Visualizations 

► To reach the Apply to Visualizations dialog: 
1. In the Visualization Properties dialog, go to the Colors page. 

2. Click on the Color Schemes menu icon, . 
3. Select Apply to Visualizations.... 

 

Option Description 

Available 
visualizations 

Lists all the visualizations available for selection. 

Selected 
visualizations 

Lists the visualizations that have been selected, and to which the color 
scheme will be applied. 

Add > Adds the selected visualizations to the Selected visualizations list. 

< Remove Removes the selected visualizations from the Selected visualizations 
list. 
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Remove All Removes all visualizations from the Selected visualizations list. 

Apply   

   Colors only Select this option if you want only the colors in the color scheme to be 
applied to the visualization. 
Note: If the color scheme contains any rules, they will not be included. 

   Colors matched 
to values 

Select this option if you want to keep the colors matched to the values 
in the visualization, when matches exist. 

Note: See Details on Apply Method for an example of how the two Apply options work 

6.1.2.6.4 Details on Apply Method 
This dialog is shown when you apply a categorical color scheme to a visualization. It lets you 
choose how you want the colors to be matched to the values in the visualization. This is 
illustrated with an example below. 

 

Option Description 

Apply   

   Colors only Select this option if you want only the colors in the color scheme to be 
applied to the visualization. 
Note: If the color scheme contains any rules, they will not be included. 

   Colors matched 
to values 

Select this option if you want to keep the colors matched to the values 
in the visualization, when matches exist. 

Example: 
When you open a categorical color scheme, or apply a categorical color scheme to a 
visualization, you can apply the colors in two different ways. Either you apply only the colors to 
the visualization, or you match the colors to the values in the visualization. The scatter plot 
below is colored by the column Type, which contains a number of different fruits, vegetables, 
and spices. These all have their own color in the color scheme. 
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The color scheme from the scatter plot above has been applied to the two visualizations below, 
but using different application methods. 

Colors only Colors matched to values 

 

 

The visualization on the left is colored by a column containing completely different values than 
the scatter plot, in this case countries. Therefore the option Apply > Colors only was selected 
when applying the colors to the visualization. The visualization on the right is colored by a 
column that contains some of the same values from the upper scatter plot. Therefore, the option 
Apply > Colors matched to values was selected for this visualization. This ensures that those 
values the visualization has in common with the color scheme get the same colors. If the 
visualization contains values that do not exist in the color scheme, then colors from the default 
color palette will be used for those values. 
Note: If the color scheme contains any rules, they will only be included if you select Colors 
matched to values. 

6.1.2.6.5 Details on Save as Document Color Scheme 
You can save a color scheme as a document color scheme if you want to use it again within an 
analysis. See Saving a Color Scheme for more information about document color schemes. 

► To reach the Save as Document Color Scheme dialog: 
1. In the Visualization Properties dialog, go to the Colors page. 

2. Click on the Color Schemes menu icon, . 
3. Select Save As > Document Color Scheme.... 
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Option Description 

New color scheme Use this option to save a new color scheme. Type a name in the text 
field. 

Replace existing 
color scheme 

Use this option to replace a previously saved color scheme with a new 
one. Select the color scheme to overwrite from the drop-down list. 

6.1.3 Color Modes 

6.1.3.1 Color Modes Overview 
A color mode can be described as the way the colors in a color scheme are assigned to the 
values in the data. For example, you can determine whether you want the items in your 
visualization to get distinct colors representing different categories, or if you want to see a 
gradient color transition between two or more anchor points in a range of values. 
The following color modes are available in TIBCO Spotfire: 
Fixed 
Categorical 
Gradient 
Segments 
Unique values 
Which color modes are available depends on the characteristics of the column or hierarchy you 
have selected to color the visualization by. For a column in categorical scale mode you can 
select Categorical or Fixed color mode. For a column in continuous scale mode you can choose 
one of the following color modes: Gradient, Segments, Fixed, or Unique values. The data type 
in the selected column decides which scale mode the column will be set to by default, as well as 
if it is possible to change the scale mode. 
Note: In tables, cross tables, and heat maps coloring is always continuous. This means that the 
color mode Categorical is not applicable. However, you can use the color mode Unique values 
to get a categorical appearance in those visualizations. To learn more about coloring in these 
visualization types, see Coloring in Tables, Cross Tables and Heat Maps. 
  

6.1.3.2 Fixed Color Mode 
Fixed color mode is available as an option for columns in both categorical scale mode and 
continuous scale mode. In fixed mode, all items in the visualization will get a single, fixed color 
as seen in the example below. 
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Note that Fixed color mode is not the same as not selecting a column to color by. If no column 
is selected, most of the settings for the color scheme will be grayed out. The only setting you 
can change is the color of the values. In Fixed color mode, you can still add rules to the color 
scheme, and the rules will be applied to the column you have selected. In the example above, 
the scatter plot is colored by the column Sales. At this point, no rules have been added, which 
means that it looks like a scatter plot without any coloring applied to it. The example below 
shows the Colors page of the Visualization Properties for Fixed color mode. 

 

Changing the color for values 
To change the color of the items in the visualization, click on the color box to the left of All 
values or Empty values in the color scheme. This will open a color selector where you can 
select a different color. 
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Adding rules to the color scheme 
You cannot add points to the color scheme in Fixed mode. The Add Point and Delete Point 
buttons are therefore grayed out. However, as mentioned, you can add rules. A rule functions as 
an exception to the rest of the color scheme. To add a rule, click on the Add Rule... button to the 
right of the color scheme area. This will open a dialog where you can define the rule. The rule 
will be added on top of the color scheme, as seen in the example below, where a rule stating that 
all values below 15 should be yellow. 

 
If the color scheme includes more than one rule, the rules are prioritized from top to bottom. 
You can change the order of the rules by using drag-and-drop. To learn more about rules in 
color schemes, see Color Rules Overview. 

Deleting rules 
To delete a rule, click on the x to the right of the rule, or right-click on the rule and select Delete 
Rule from the menu. 

Resetting the color scheme 
To reset the color scheme to its initial state, right-click in the color scheme area to open the 
menu, and select Reset Color Scheme. The color scheme will be reset to the default state for the 
selected column. Any added rules will be removed. 
For a description of the rest of the Colors page in the Visualization Properties dialog, see the 
corresponding help section for each visualization type. 
  

6.1.3.3 Categorical Color Mode 
Categorical color mode is available for columns in categorical scale mode, and gives each value 
in the column a separate color, as seen in the example below. 

 
In the example, the scatter plot is colored by the column Type, which is a column containing 
string values representing different types of fruits and vegetables. Each of the six different types 
has its own color. The example below shows the Colors page of the Visualization Properties for 
Categorical color mode. 
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Changing the color for values 
To change the color of any of the values in the color scheme, click on the color box to the left of 
a value. A color selector will appear, and you can select a different color. 

Adding rules to the color scheme 
You cannot add points to the color scheme in Categorical mode. The Add Point and Delete 
Point buttons are therefore grayed out. However, as mentioned, you can add rules. A rule 
functions as an exception to the rest of the color scheme. The rules available in categorical 
mode are all of the kind that requires the output to be either true or false. For example, you can 
add a rule saying that all values starting with a certain letter should have a different color. To 
add a rule, click on the Add Rule... button to the right of the color scheme area. This will open a 
dialog where you can define the rule. The rule will be added at the top of the color scheme, as 
seen in the example below, where a rule states that all values starting with the letters "Ba" 
should be brown. 

 
Since the rule functions as an exception to the rest of the color scheme, the markers for 
“Bananas” (and any other values starting with “Ba”) will become brown in the visualization. If 
the color scheme includes more than one rule, the rules are prioritized from top to bottom. You 
can change the order of the rules by using drag-and-drop. To learn more about rules in color 
schemes, see Color Rules Overview. 

Deleting rules 
To delete a rule, click on the x to the right of the rule, or right-click on the rule and select Delete 
Rule from the menu. 
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Resetting the color scheme 
To reset the color scheme to its initial state, right-click in the color scheme area to open the 
menu, and select Reset Color Scheme. The color scheme will be reset to the default state for the 
selected column. Any added rules will be removed. 
For a description of the rest of the Colors page in the Visualization Properties dialog, see the 
corresponding help section for each visualization type. 

6.1.3.4 Gradient Color Mode 
Gradient color mode is available for columns in continuous scale mode. In this mode the items 
will show a color gradient between two or more anchor points as seen in the example below. 

 
In the example, the scatter plot is colored by the column Sales, which is a column containing 
integer values. The color scheme has three anchor points: Min, Average, and Max. The colors at 
these points are set to red, white, and blue respectively, which means that the color gradient 
shifts from red to white to blue. The example below shows the Colors page of the Visualization 
Properties for Gradient color mode. 
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Changing the color of anchor points 
To change the color of an anchor point, click on the color box to the left of the point. A color 
selector will appear, and you can select a different color. The coloring will be updated 
immediately in the visualization. 

Adding anchor points to the color scheme 
To add a point where you want the gradient to switch to another color, you can either click on 
the Add Point button, or double-click in the color scheme area. To specify the exact placement 
of the added point, select one of the options in the menu beside the anchor point. The example 
below shows the available options in the menu. See Details on Point/Value Menu for 
descriptions of all the options in this menu. 

 
Most of the options in the menu will add an anchor point that is relative to the current color 
scale. For example, if you select Average, the position of the anchor point will be adjusted 
automatically when you filter the data, so that it stays at average for the new range of values. 
If you select Value, you can enter an absolute value for the anchor point in the field. Keep in 
mind that this means that the value can end up outside the range of values if you filter out data 
or select another column to color by. When you have selected Value from the menu, you can 
also adjust the position of a point by dragging it vertically. 
Select the last menu option to open the Custom Expression dialog, where you can define a 
custom expression to set the anchor point. See Custom Expressions for Coloring to learn more 
about this. To get a basic understanding of custom expressions, see Custom Expressions 
Introduction. 

Adding rules to the color scheme 
You can also add rules to the color scheme in gradient mode. A rule functions as an exception 
to the rest of the color scheme. To add a rule, click on the Add Rule... button to the right of the 
color scheme area. This will open a dialog where you can define the rule. The rule will be added 
at the top of the color scheme, as seen in the example below, where a rule states that all values 
below 15 should be yellow. 

 
If the color scheme includes more than one rule, the rules are prioritized from top to bottom. 
You can change the order of the rules by using drag-and-drop. To learn more about rules in 
color schemes, see Color Rules Overview. 

Deleting points and rules 
To delete a point, select it in the color scheme and click the Delete Point button. You can also 
right-click on the point and select Delete Point from the menu. 
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To delete a rule, click on the x to the right of the rule, or right-click on the rule and select Delete 
Rule from the menu. 

Resetting the color scheme 
To reset the color scheme to its initial state, right-click in the color scheme area to open the 
menu, and select Reset Color Scheme. The color scheme will be reset to the default state for the 
selected column. Any added rules will be removed. 
For a description of the rest of the Colors page in the Visualization Properties dialog, see the 
corresponding help section for each visualization type. 
  

6.1.3.5 Segments Color Mode 
Segments color mode is available for columns in continuous scale mode. This will color the 
items representing values between two or more anchor points in fixed colors, as seen in the 
example below. 

 
In the example, the scatter plot is colored by the column Sales, which is a column containing 
integer values. The color scheme has four anchor points: Min, Average, 30, and Max. The 
colors between these points are set to blue, yellow, and red respectively. This means that items 
representing values between the Min value (8) and the average value (18) are colored blue, 
items representing values between average and 30 are colored yellow, and items representing 
values greater than 30 are colored red. 
Note: An anchor point will get its color from the segment below it on the scale. In the example 
above, this means that an item representing the value 30 will be yellow. 
The example below shows the Colors page of the Visualization Properties for the color mode 
Segments. 
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Changing the color of segments 
To change the color of a segment, click on the color box to the left of that segment. A color 
selector will appear, and you can select a different color. 

Adding anchor points to the color scheme 
To add an anchor point where you want a boundary between two segments, you can either click 
on the Add Point button, or double-click in the color scheme area. To specify the exact 
placement of the added point, select one of the options in the menu beside the anchor point. The 
example below shows the available options in the menu. See Details on Point/Value Menu for 
descriptions of all the options in this menu. 

 
Most of the options in the menu will add an anchor point that is relative to the current color 
scale. For example, if you select Average, the position of the anchor point will be adjusted 
automatically when you filter the data, so that it stays at average for the new range of values. 
If you select Value, you can enter an absolute value for the anchor point in the field. Keep in 
mind that this means that the value can end up outside the range of values if you filter out data 
or select another column to color by. When you have selected Value from the menu, you can 
also adjust the position of a point by dragging it vertically. 
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Select the last menu option to open the Custom Expression dialog, where you can define a 
custom expression to set the anchor point. See Custom Expressions for Coloring to learn more 
about this. To get a basic understanding of custom expressions, see Custom Expressions 
Introduction. 

Adding rules to the color scheme 
You can also add rules to the color scheme in Segments mode. A rule functions as an exception 
to the rest of the color scheme. To add a rule, click on the Add Rule... button to the right of the 
color scheme area. This will open a dialog where you can define the rule. The rule will be added 
at the top of the color scheme, as seen in the example below, where a rule stating that all values 
below 15 should be green. 

 
If the color scheme includes more than one rule, the rules are prioritized from top to bottom. 
You can change the order of the rules by using drag-and-drop. To learn more about rules in 
color schemes, see Color Rules Overview. 

Deleting points and rules 
To delete a point, select it in the color scheme and click the Delete Point button. You can also 
right-click on the point and select Delete Point from the menu. 
To delete a rule, click on the x to the right of the rule, or right-click on the rule and select Delete 
Rule from the menu. 

Resetting the color scheme 
To reset the color scheme to its initial state, right-click in the color scheme area to open the 
menu, and select Reset Color Scheme. The color scheme will be reset to the default state for the 
selected column. Any added rules will be removed. 
Note: A color scheme in Segments color mode may appear as if the coloring is categorical. 
However, because the column used to color by is in continuous scale mode, the coloring is also 
considered continuous. This means that if you are using multiple scales, it is not possible to set 
individual scaling per color. For lines and curves, this means that you cannot set them to one 
line or curve per color. 
For a description of the rest of the Colors page in the Visualization Properties dialog, see the 
corresponding help section for each visualization type. 
  

6.1.3.6 Unique Values Color Mode 
Unique values color mode is available for columns in continuous scale mode. It is similar to the 
Categorical color mode, and gives each unique value in the column a separate color, as seen in 
the example below. 
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In the example, the scatter plot is colored by the column Sales, which is a column containing 
integer values. Each unique value in the column has its own color. The example below shows 
the Colors page of the Visualization Properties for Unique values color mode. 

 

Changing the color for values 
To change the color of any of the values in the color scheme, click on the color box to the left of 
a value. A color selector will appear, and you can select a different color. 

Adding rules to the color scheme 
You cannot add points to the color scheme in Unique values mode, but you can add rules. A 
rule functions as an exception to the rest of the color scheme. For example, you can add a rule 
stating that the bottom three values should be yellow. In the example above, this would mean 
that the values 8, 9, and 10 would all be yellow. To add a rule, click on the Add Rule... button to 
the right of the color scheme area. This will open a dialog where you can define the rule. The 
rule will be added at the top of the color scheme as seen below. 
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If the color scheme includes more than one rule, the rules are prioritized from top to bottom. 
You can change the order of the rules by using drag-and-drop. To learn more about rules in 
color schemes, see Color Rules Overview. 

Deleting rules 
To delete a rule, click on the x to the right of the rule, or right-click on the rule and select Delete 
Rule from the menu. 

Resetting the color scheme 
To reset the color scheme to its initial state, right-click in the color scheme area to open the 
menu, and select Reset Color Scheme. The color scheme will be reset to the default state for the 
selected column. Any added rules will be removed. 
Note: A color scheme in Unique values color mode may appear as if the coloring is categorical. 
However, because the column used to color by is in continuous scale mode, the coloring is also 
considered continuous. This means that if you are using multiple scales, it is not possible to set 
individual scaling per color. For lines and curves, this means that you cannot set them to one 
line or curve per color. 
For a description of the rest of the Colors page in the Visualization Properties dialog, see the 
corresponding help section for each visualization type. 
  

6.1.3.7 Details on Point/Value Menu 
This menu is available for points in the color scheme area in the two color modes Segments and 
Gradient, as seen below. It is also available in the Add/Edit Rule dialog. 

 
Note: Most of the options in the menu will add an anchor point that is relative to the current 
color scale. For example, if you select Average, the position of the anchor point will be adjusted 
automatically when you filter the data, so that it stays at average for the new range of values. 

Option Description 

Value Select this option to specify an absolute value. Type the value of your 
choice in the field and press Enter. 
For dates, you can also click on the calendar icon, , to set a date. 
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Note: Because the value is absolute, it can end up outside the range of 
values if you filter out data or select another column to color by. 

Min Sets the value to the minimum value in the data. 

Max Sets the value to the maximum value in the data. 

Average Sets the value to the average value in the data. 

Median Sets the value to the median value in the data. 

Percent Sets the value to a percentage value. 

Percentile Sets the value to a percentile value. 

Custom 
Expression 

Select this option to define the value with a custom expression. See To 
add a custom expression as an anchor point and To add a custom 
expression as a value in a rule to learn more. To get a basic 
understanding of custom expressions, see Custom Expressions 
Introduction. 

6.1.4 Rules in Color Schemes 

6.1.4.1 Color Rules Overview 
Rules can be very useful when you are setting up color schemes for your visualizations. Rules 
function as exceptions to the rest of the color scheme. You can use them in all kinds of 
visualizations, and in any color mode. The collection of available rules is different for 
categorical columns than for continuous columns. For instance, for categorical color schemes 
you can add a rule saying that all values starting with a certain letter should have a specific 
color. For continuous color schemes, you can, among many other things, define a rule stating 
that all items representing values below a certain value should have a certain color. Or, if you 
use a date column to color by, you can set up a rule stating that items representing values 
between two specific dates should get a certain color. See Details on Add/Edit Rule for 
descriptions of all the rule types. 

Example: 
When you add a rule, it is placed at the top of the color scheme in the legend and on the Colors 
page of the Visualization Properties. It always has higher priority than the rest of the color 
scheme. If you add more than one rule, the rules will be prioritized from top to bottom. The 
example below shows a scatter plot that is colored by the column Sales, and the color scheme is 
set up in Fixed color mode. 
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The example below shows the color scheme area for the scatter plot above. 

 
Two rules have been added to the scheme. The first rule states that the items representing the 
five highest values should get a pink color. The second rule states that all values between 
average and max should get a green color. The order in which these rules are placed is essential. 
If the order had been reversed, then the Top 5 rule would not have had any effect since the other 
rule would include the items representing the five highest values as well. You can change the 
order of the rules by using drag-and-drop. You can add as many rules as you like to a color 
scheme, but a rule that does not have any effect on the visualization is not shown in the legend. 
For example, if you have filtered out all the data that was originally included in the rule, or if 
another rule overrides it, that rule will no longer be shown in the legend. 

► To add a rule to a color scheme: 
1. Open the Visualization Properties dialog, and go to the Colors page. 
2. Click on the Add Rule... button to the right of the color scheme area. 

Response: The Add rule dialog is opened. 
3. Select which rule to use from the Rule type drop-down list. 
4. In the Value field, click on the icon, , to open the menu. 
5. Select which kind of value to use in the rule. If you select the menu option Value, you 

also need to provide a value in the field. 
Note: Which options are available in the menu depends on the selected rule type. See 
Details on Point/Value Menu to learn more. 

6. Open the Color selector and select a color to use for the rule. 
7. Click OK. 

Response: The rule is added at the top of the color scheme. 

► To edit a rule: 
1. Go to the Colors page of the Visualization Properties dialog. 
2. Locate the rule of interest in the color schemes area. 
3. Right-click on the rule, and select Edit Rule.... 
4. Response: The Edit Rule dialog is opened. 
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Note: You can also double-click on the rule to open the dialog. 

► To delete a rule: 
1. Go to the Colors page of the Visualization Properties dialog. 
2. Locate the rule of interest in the color schemes area. 
3. Right-click on the rule, and select Delete Rule. 
4. Response: The rule is deleted. 

Note: You can also click on the x to the right of the rule to delete it. 

6.1.4.2 Details on Add/Edit Rule 
Use these dialogs to define or edit a color rule. See also Color Rules Overview to get an 
introduction to rules in color schemes. Note that the set of rule types available in these dialogs 
is different depending on whether the color scheme is categorical or continuous. Both sets of 
rules are described below. 

► To reach the Add/Edit Rule dialog: 
1. In the Visualization Properties dialog, go to the Colors page. 
2. Click on the Add Rule... button to add a rule. To edit an existing rule, double-click on 

the rule of interest in the list. 

 

 

Option Description 

Rule type Specifies which rule type to add. Which types are available depends on 
the data type of the column, or hierarchy that the rule is applied to. See 
below for descriptions of all available rule types. 

Value Defines the value or values the rule should apply to. The available 
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options depend on the rule type selected. See Details on Point/Value 
Menu for descriptions of all the options in this menu. 

Color Specifies the color to use for the rule. 

  

Available rule types for continuous coloring: 

Rule Type Description 

Top Colors the top number of items in the selected color. Specify the 
number of items to color in the Value field. 
Note: In some cases more than the defined number of items may be 
colored. For example, if the rule states that the top three items should 
be yellow, and four items represent the highest value, then all four of 
these items will become yellow. 

Bottom Colors the bottom number of items in the selected color. Specify the 
number of items to color in the Value field. 
Note: In some cases more than the defined number of items may be 
colored. For example, if the rule states that the bottom three items 
should be yellow, and four items represent the lowest value, then all 
four of these items will become yellow. 

Between Colors all the items representing values between the two specified 
values in the selected color. Specify the values in the two Value fields. 

Equal to Colors all the items representing values that are equal to the specified 
value in the selected color. 

Not equal to Colors all the items representing values that are not equal to the 
specified value in the selected color. 

Greater than Colors all the items representing values greater than the specified value 
in the selected color. 

Greater than or 
equal to 

Colors all the items representing values greater than or equal to the 
specified value in the selected color. 

Less than Colors all the items representing values less than the specified value in 
the selected color. 

Less than or equal 
to 

Colors all the items representing values less than or equal to the 
specified value in the selected color. 

Boolean 
expression 

Lets you define a boolean expression. All the items for which the 
expression is true will get the specified color. See To add a boolean 
expression as a rule for a description. To learn more about custom 
expressions in general, see Custom Expressions Introduction. 

Available rule types for categorical coloring: 
Note: Rules are case sensitive. This means that "Equal to Bananas" is not the same as "Equal to 
bananas". Note also that in rules you should not use quotation marks around strings. If you 
define a custom expression containing a string value, however, then quotation marks are 
necessary. 
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Rule Type Description 

Equal to Colors all the items that correspond exactly to the specified string 
value in the selected color. 

Not equal to Colors all the items that do not correspond exactly to the specified 
string value in the selected color. 

Contains Colors all the items that contain the specified string value in the 
selected color. 

Starts with Colors all the items that start with the specified string value in the 
selected color. 

Ends with Colors all the items that end with the specified string value in the 
selected color. 

Boolean 
expression 

Lets you define a boolean expression. All the items for which the 
expression is true will get the specified color. See To add a boolean 
expression as a rule for a description. To learn more about custom 
expressions in general, see Custom Expressions Introduction. 

6.1.5 Coloring in Tables, Cross Tables and Heat Maps 

6.1.5.1 Coloring in Tables, Cross Tables and Heat Maps 
Coloring is applied to tables, cross tables, and heat maps in a different way than other 
visualizations. The following two sections describe how to apply coloring to these 
visualizations. 
  

6.1.5.2 Coloring in Tables 
For a table visualization, a color scheme is always applied to a color scheme grouping. A color 
scheme grouping functions as a container for one or more columns on which you want to apply 
the same color scheme. You can add many color schemes to the same table. In fact, you can add 
as many as one color scheme per column. When you create a new table it has no coloring 
applied to it. You must add color scheme groupings with the columns you want to color, and set 
up color schemes for each of the groupings. To learn more about color schemes and how to set 
them up in different color modes, see Color Schemes Overview and Color Modes Overview 
respectively. 

Example: 
The image below shows a table with two different color schemes applied to it. 
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The color schemes are separated by a horizontal line in the legend. They are described 
separately below. 
The upper color scheme in the legend contains the two columns Category and Type, both 
containing string values. The color scheme grouping for this color scheme is called Category 
and Type, as seen below where a part of the Colors page of the Table Properties dialog is 
shown. 

 
In the upper part of the dialog, the color scheme grouping Category and Type is selected, and in 
the lower part of the dialog, its corresponding color scheme is displayed. The color scheme is in 
Unique values color mode, and each of the values in the two columns has its own color. 
The color scheme shown in the lower part of the legend contains the two columns Cost and 
Sales, which both contain integer values. The color scheme grouping for this color scheme is 
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called Cost and Sales, as seen below where a part of the Colors page of the Table Properties 
dialog is shown. 

 
In the upper part of the dialog, the color scheme grouping Cost and Sales is selected, and in the 
lower part of the dialog, its corresponding color scheme is displayed. The color scheme is in 
Gradient color mode. The two columns share the same color scheme, but the scaling is separate 
for them. This means that the three color points Min, Average, and Max are calculated per 
column. If you want to use a common scale for the columns in the grouping, select the 
alternative (None) in the One scale per drop-down list. To see the scale for a column in the 
color scheme grouping, select it in the Color scheme groupings list. If the grouping itself is 
selected, as in the example, then the scale for the first column in the grouping is displayed. 

► To add a color scheme grouping: 
1. Open the Visualization Properties dialog, and go to the Colors page. 
2. Open the Add menu and select Color Scheme Grouping.... 

Response: The Add Color Scheme Grouping dialog is opened. 
3. In the Name field, type a name to use for the new grouping. 
4. In the Available columns list, select the columns you want to include. 

Comment: A grouping can only contain columns with values of the same data type. 
The exception being the five numeric data types: Integer, LongInteger, Real, 
SingleReal, and Currency, which can be added to the same grouping. The “data type” 
in this case is called Numeric, but is a collection of these five data types rather than an 
actual data type. 

5. Click Add >. 
Response: The selected columns are added to the Selected columns list. 

6. Click OK. 
Response: The new color scheme grouping is added to the Color scheme groupings 
list. 
Comment: A column can only be included in one grouping at a time. If you add a 
column that is already included in an another color scheme grouping, the column will 
automatically be removed from the other grouping.  
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6.1.5.3 Coloring in Cross Tables and Heat Maps 
For cross tables and heat maps, a color scheme is always applied to a color scheme grouping. A 
color scheme grouping functions as a container for one or more axis values on which you want 
to apply the same color scheme. You can add many color schemes to the same cross table or 
heat map, and it is possible to color by the columns on any of the axes. However, you can only 
color a cross table and a heat map by one column at a time, and if the cell values axis contains 
more than one column, you can only color by the cell values axis. To learn more about color 
schemes and how to set them up in different color modes, see Color Schemes Overview and 
Color Modes Overview respectively. The examples below illustrate how coloring can be 
applied to cross tables and heat maps. 

Example: 
The cross table below shows the sum of sales (Sum(Sales)) for fruits and vegetables for the 
years 2001, 2002, and 2003. The horizontal axis has the two columns Category and Type. The 
column Category contains the two axis values Fruit and Vegetables, and the column Type 
contains the values Apples, Bananas, Pears, Cucumber, Lettuce, and Tomatoes. The cross table 
is colored by the column Category. 

 
When you create a new cross table, one color scheme grouping (named Numeric) is created for 
each column represented on an axis in the cross table. The default grouping contains all the axis 
values in that column. Select a column in the Color by drop-down list to see its default color 
scheme grouping. In the example below, a part of the Colors page of the Cross Table Properties 
dialog is shown. The column Category was selected in the Color by drop-down list and its 
default color scheme grouping is displayed, as well as its two axis values Fruit and Vegetables. 
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In the lower part of the dialog, the color scheme for the Numeric color scheme grouping is 
displayed. The color scheme is in Gradient color mode. The two axis values Fruit and 
Vegetables share the same color scheme, but the scaling is separate for them. This means that 
the three color points, Min, Average, and Max, are calculated per axis value. If you want to use 
a common scale for the axis values in the grouping, select the alternative (None) in the One 
scale per drop-down list. To see the scale for a column in the color scheme grouping, select it in 
the Color scheme groupings list. If the grouping itself is selected, as in the example, then the 
scale for the first column in the grouping is displayed. 

Example: 
The example below shows a cross table with the same setup as in the example above except for 
the coloring. This cross table is colored by the column Type, and has two different color 
schemes applied to it. 

 
The color schemes are separated by a horizontal line in the legend. Below is a part of the Colors 
page of the Cross Table Properties dialog for this cross table. 

 
As can be seen in the upper part of the dialog, two color scheme groupings have been added. 
The first grouping is named Fruits, and the three axis values, Apples, Bananas, and Pears, have 
been added to that grouping. This is also the color scheme displayed first in the legend above. 
The second grouping is named Vegetables, and it contains the axis values Cucumber, Lettuce, 
and Tomatoes. The Numeric color scheme grouping is empty because all the axis values in the 



Enhancing Visualizations 

705 

column Type have been added to either of the two new groupings. The default grouping cannot 
be deleted from the list of groupings. If you delete a grouping that you have added, then the axis 
values in that grouping will automatically be moved to the default grouping instead. Any added 
groupings will be shown in the list even if you change to another column to color by. The 
example below shows the Color scheme groupings list when the Color by column is set to Year. 

 
The two groupings Fruits and Vegetables are still visible, but you cannot expand them unless 
you change Color by back to the column Type. 

Example: 
Coloring in heat maps works the same way as in cross tables. The example below shows a heat 
map where the Y-axis is set to the column Test, while the X-axis is set to (None). The 
individual cell values show the average of the three columns, Time 1, Time 2, and Time 3. 

 
Below is a part of the Colors page of the Heat Map Properties dialog for the heat map above. 
The heat map is colored by (Cell Values), which is the only available option when the cell 
values axis contains more than one column. 
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► To add a color scheme grouping: 
1. Open the Visualization Properties dialog, and go to the Colors page. 
2. Open the Add menu and select Color Scheme Grouping.... 

Response: The Add Color Scheme Grouping dialog is opened. 
3. In the Name field, type a name to use for the new grouping. 
4. In the Available axis values list, select the columns you want to include. 
5. Click Add >. 

Response: The selected columns are added to the Selected axis values list. 
6. Click OK. 

Response: The new color scheme grouping is added to the Color scheme groupings 
list. 
Comment: An axis value can only be included in one grouping at a time. If you add an 
axis value that is already included in another color scheme grouping, the axis value 
will automatically be removed from the other grouping. 

  

6.1.5.4 Details on Add/Edit Color Scheme Grouping 
Use these dialogs when you want to add a new color scheme grouping or edit an existing one. 

► To reach the Add/Edit Color Scheme Grouping dialog: 
1. In the Visualization Properties dialog for a table, a cross table, or a heat map, go to the 

Colors page. 
2. To add a new grouping, open the Add menu and select Color Scheme Grouping.... To 

edit an existing grouping, select the grouping of interest from the list, then click on 
Edit.... Only groupings that you have added to the list can be edited or deleted. 

Note: If this dialog is opened from a heat map or cross table, the labels will read "Available 
axis values" and "Selected axis values" instead. This means that in the descriptions below, each 
reference to a "column" should be replaced by "axis value". 
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Option Description 

Name Type a name to use for the color scheme grouping. 

Available columns Lists all columns and hierarchies available for selection. 

Selected columns Lists the columns selected to be used in this color scheme grouping. 

Add > Adds the selected columns to the Selected columns list. 

< Remove Removes the selected columns from the Selected columns list. 

Remove All Removes all columns from the Selected columns list. 
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Note: You cannot combine columns containing different data types in the same color scheme 
grouping. The exception being the five numeric data types: Integer, LongInteger, Real, 
SingleReal, and Currency, which can be added to the same grouping. The “data type” in this 
case is called Numeric, but is a collection of these five data types rather than an actual data 
type. 

6.1.6 Custom Expressions for Coloring 
You can use custom expressions in color schemes in a few different ways and some examples 
are described below. You can define an anchor point with a custom expression, or you can use 
expressions in rules. To get a basic understanding of custom expressions, see Custom 
Expressions Introduction. To learn more about using rules in color schemes, see Color Rules 
Overview. 

► To add a custom expression as an anchor point: 
Anchor points are available when coloring continuous columns in a gradient or segments color 
mode. A custom expression can be used to determine where the breakpoint should be. 

1. Open the menu for the anchor point by clicking on the icon, . 
2. Select Custom Expression. 

Response: The Custom Expression dialog is opened. 
3. In the Available columns list, select Axis.Color, and click Insert Columns to add it 

to the expression. 
Comment: Axis.Color represents the column you have selected to color by and it is 
most of the times the only "column" in the Available columns list. In table 
visualizations you will have access to all columns. 

4. Specify the custom expression of your choice. 
Note: The output from the custom expression must be an aggregated value. 

5. Click OK to close the dialog. 
Response: The custom expression is added as the anchor point. An icon, , indicating 
that the anchor point is a custom expression, is shown in the field. 

► To add a boolean expression as a rule: 
A rule functions as an exception to the rest of the color scheme and can be specified using a 
boolean custom expression. 

1. Go to the Colors page of the Visualization Properties dialog. 
2. Click on the Add Rule... button to the right of the color scheme. 

Response: The Add Rule dialog is opened. 
3. In the Rule Type drop-down list, select Boolean expression. 
4. Click on the custom expression icon, , in the Value field. 

Response: The Custom Expression dialog is opened. 
5. Specify the custom expression of your choice. For example, use "[Axis.Color]=true" to 

color all rows with the boolean value "true" with a specified color. 
Comment: Axis.Color represents the column you have selected to color by. In table 
visualizations you will also have access to the columns themselves and you can make 
direct column comparisons, e.g., [Col1]>[Col2], in the expression. 
Note: The output from the custom expression must be a boolean value. 

6. Click OK to close the dialog. 
7. Select a Color to represent the rule. 
8. Click OK. 

Response: The rule is added to the color scheme. 
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► To add a custom expression as a value in a rule: 
The custom expression can specify a certain value at which the exception rule should take over. 

1. Go to the Colors page of the Visualization Properties dialog. 
2. Click on the Add Rule... button to the right of the color scheme. 

Response: The Add Rule dialog is opened. 
3. From the Rule type drop-down list, select the rule type you want to use. 

Comment: For example, the rule type could be "Greater than or equal to" a value 
defined by the custom expression. There are a number of different rule types to choose 
from. 

4. In the Value field, click on the icon, , to open the menu. 
5. Select Custom Expression. 

Response: The Custom Expression dialog is opened. 
6. Specify the custom expression of your choice. 

Comment: Axis.Color represents the column you have selected to color by. For 
example, if the rule type is "Greater than or equal to", then the expression 
"Avg([Axis.Color])+2*StdDev([Axis.Color])" would color all rows where the value of 
the selected color column is greater than or equal to the average value plus two 
standard deviations with the rule color. 
Note: The output from the custom expression must be an aggregated value. 

7. Click OK to close the dialog. 
8. Select a Color to represent the rule. 
9. Click OK. 

Response: The rule is added to the color scheme. 
Note: When you are setting up a custom expression with a string comparison included, 
you need to put quotation marks around the string (for example, 
[Axis.Color]="Bananas"). If you define a rule containing a string comparison, 
however, you should not use quotation marks. 

  

6.2 Limiting What is Shown in Visualizations 
When a new visualization is created, the default limitation setting is that the visualization is 
affected by the current filtering on the page where it resides. However, there are many 
alternatives for you to set up the visualization available on the Data page of the Visualization 
Properties dialog. 

► To limit a visualization by the union of two markings: 
The default when limiting data by more than one marking is that data must be available in all 
markings (intersection) to be shown in the limited visualization. However, you can change 
Rows must be included in to Any marking on the Data page. 

► To set up a visualization to use a different filtering scheme than 
the one on the page: 
1. Right-click in the visualization to display the pop-up menu. 
2. Select Properties. 
3. Go to the Data page. 
4. Under Limit data using filterings, clear the Use the current filtering scheme from 

the page check box and select a different filtering scheme instead. 
Comment: The difference between selecting the Use the current filtering scheme from 
the page option and the filtering scheme annotated with (Currently used) is that in the 
first case, the filtering scheme of the visualization will change when the filtering 
scheme of the page is changed. In the latter case, it will not. 
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Comment: It is possible to limit a visualization by more than one filtering scheme. In 
this case, the intersection of the filterings will be used. This means that the 
visualization will show only the data that is made visible by all of the filtering 
schemes.  

► To create an unfiltered visualization: 
1. Right-click in the visualization to display the pop-up menu. 
2. Select Properties. 
3. Go to the Data page. 
4. Clear all check boxes under Limit data using filterings. 

► To limit a visualization by an expression: 
If you want to display data for a special category only, you can set up a "hard filter" on the 
visualization using a boolean expression. 

1. Right-click in the visualization to display the pop-up menu. 
2. Select Properties. 
3. Go to the Data page. 
4. Next to Limit data using expression, click Edit.... 
5. Type a boolean expression in the dialog and click OK. 

Note: If you use more than one type of limiting on the Data page, then the different types of 
limiting will be combined so that the result will be Marking limiting AND Filtering limiting 
AND Expression limiting. 
  

6.3 Details Visualizations 
6.3.1 What is a Details Visualization? 

A details visualization is a special case of a limited visualization, slightly related to the Details-
on-Demand. This means that the information shown in a details visualization depends on what 
is marked in one or more other visualizations. Details visualizations can be used to set up 
analyses where you can drill down into your data in multiple steps. The marking you perform in 
one visualization (the master visualization), determines what you will see in the next 
visualization, and so on. If nothing is marked, the details visualization will not contain any data 
at all. 
In contrast to the Details-on-Demand, which is always a table, the details visualization can be 
any type of visualization and it can be placed anywhere within the page, just like any other 
visualization. 

► To create a details visualization: 
1. Load data for the master visualization and, if other data, for the details visualization. 

Comment: Note that all data tables you wish to use must be loaded, and a relation must 
have been set up between the data tables, before you create the details visualization. 
See How to Insert Multiple Data Tables into the Analysis for more information about 
how to add more data tables and define relations between them. 

2. Create the master visualization that you want to use to control the details visualization. 
Comment: This should be the visualization in which you want to be able to mark items 
and retrieve details about these items in the details visualization. 

3. Right-click in the visualization and select Create Details Visualization and the type 
of visualization to use as details visualization from the pop-up menu. 
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4. If there are more than one related data table available in your analysis, the Create 
Details Visualization dialog will appear. Select which data table to use from the 
Related data table for new visualization drop-down list. 
Comment: If no related data tables are available, the details visualization will 
automatically use the same data table as the master visualization. 

5. Click OK in the Create Details Visualization dialog. 
Response: The new details visualization appears in the analysis. 

6. Set up the new details visualization to the desired view. 
The Data page in the Visualization Properties dialog controls which markings will be used to 
limit the data shown in a visualization. Normally, no marking is selected here, but when you 
create a details visualization, the marking used by the master visualization is automatically 
selected to be limiting, and a new marking is created to enable marking in the details 
visualization. 
Tip: An already created visualization can also be converted to a details visualization by 
changing the limiting markings on the Data page. In that case, you should also make sure that 
the visualization in itself does not use the same marking as is used to limit the data shown. 

Example: 
Imagine having a master visualization showing the sales of different fruits and vegetables 
during a couple of years. The master visualization in this example is a line chart with each line 
representing a fruit or a vegetable: 

 
Then, we want to investigate the carbohydrate content of the different fruits and vegetables in a 
details visualization where only the data for the type that we clicked on is shown. 
Right-click on the master visualization and select Create Details Visualization > Bar Chart.... 
In this example, the details data comes from a different data table than the one used in the 
master visualization, but it could also be the same data table. 
This details visualization is set up to show the content of Glucose, Fructose, Maltose and 
Saccharose on the value axis and (Column Names) on the category axis. If nothing is marked in 
the master visualization, then no data is shown in the details visualization: 
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When a line is marked in the master visualization, the bar chart is updated to show data about 
that fruit or vegetable. In this example, we mark Apples, the second line from the bottom: 

 
The details visualization shows the carbohydrate content of apples: 

 
Clicking on the Bananas line will show the carbohydrate content of bananas, etc. 
A details visualization can, in turn, be used as a master visualization  for another details 
visualization, so that you can drill down deeper and deeper into your data, by marking elements 
in a series of visualizations. 
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6.3.2 Details on Create Details Visualization 
Details visualizations are limited to showing data marked in another visualization (the master 
visualization) only. See What is a Details Visualization? to learn more. The Create Details 
Visualization dialog is shown if the master visualization is based on a data table that is related 
to one or more other data tables in the analysis. You must then select which data table the 
details visualization should be based on. 

► To reach the Create Details Visualization dialog: 
1. Create a master visualization. 

Comment: This is the visualization that you want to use to control the details 
visualization. 

2. Right-click in the master visualization to display the pop-up menu. 
3. Select Create Details Visualization and determine which type of visualization you 

want to use. 
Response: The Create Details Visualization is displayed. Note that it will only appear 
if there are related data tables in the analysis. 

 

Option Description 

Related data table for 
new visualization 

Select the data table to use for the details visualization. You can 
only select from data tables that are related to the one used in 
the master visualization. 
New data tables are added via File > Add Data Tables... or 
File > Add On-Demand Data Table.... 

6.4 Custom Expressions 
6.4.1 Custom Expressions Introduction 

The ability to create custom expressions is a powerful and advanced tool in TIBCO Spotfire. 
Custom expressions allow you to create your own aggregation methods for the visualizations. 
The custom expression functionality is accessed by right-clicking on the column selector in the 
visualization and selecting the Custom Expression… option from the pop-up menu. 
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This section of the help contains the following information on how to create custom 
expressions: 

• An overview explaining what custom expressions are 
• Basic custom expressions 
• Information about the OVER keyword in custom expressions 
• Advanced custom expressions 
• How to insert a custom expression 
• Details on the Custom Expression dialog 

6.4.2 Custom Expressions Overview 
As mentioned, custom expressions are powerful and useful, but also advanced. The purpose of 
this overview is to introduce you to some basic concepts regarding custom expressions. What 
they are, how they can be used, and why they affect the visualizations the way they do. This 
overview includes some examples of how to use custom expressions, and more examples can be 
found in the following help sections: Basic Custom Expressions, OVER in Custom Expressions, 
and Advanced Custom Expressions. 

What are markers? 
Before creating custom expressions, it is vital to know what the markers in a visualization 
represent, since it makes it easier to understand why custom expressions behave the way they 
do. Particularly affected are custom expressions containing the OVER statement. See OVER in 
Custom Expressions to learn more. 
Markers are, quite simply, a representation of how you have divided your data into different 
slices. A marker can represent everything from all rows in your data to a single row, depending 
on how you have set up your visualization. These slices can, of course, be represented by not 
only markers in a scatter plot, but also segments of a bar chart or a pie chart and so on. 
In the example below, the marker contains all rows in the data. It shows the sum of all sales of 
all products for all time periods. 
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If you start slicing the data into smaller parts, the result could look like the example below, 
where each marker represents the sum of the sales for each product for each year. 

 

Setting up a visualization 
Setting up a visualization is basically deciding how the data is to be divided and how the data is 
to be aggregated over the slices. In the examples above, the aggregation method is Sum(), 
which in this case means that the total value of all sales for each product and year are summed 
up in one marker. 
The aggregation method Sum() can actually be seen as a custom expression, the only difference 
is that it is provided in the aggregation menu. When you want to use an aggregation method that 
is not listed, you can create your own using custom expressions. 
When you change the visualization, for example using the filters, the markers and scales will 
automatically update. The aggregation will automatically be revaluated based on the contents of 
each marker. This works the same way for the provided aggregation methods as well as for the 
basic custom expressions. 
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Note: If you apply <> around an expression, it becomes categorical. Similarly, you can right-
click on the axis and select Categorical Scale from the pop-up menu. If an aggregated value is 
made categorical, it will not change value when data are being filtered. 

Example 
Just to show that custom expressions and the predefined aggregations really are the same thing, 
consider the aggregation Avg(Cost), an aggregation that shows you the average cost for each 
product each year. 

 
The same visualization can be created using custom expressions. Start by right-clicking on the 
axis selector for the Y-axis and select Custom Expression... 

 
In the Custom Expression dialog, enter the expression Sum([Cost])/Count([Cost]), either by 
typing it directly in the Expression field or by inserting columns and functions from the lists, 
and click OK. 
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As you can see, the resulting visualization is the same as when you chose the aggregation 
Avg(Cost), but you have now done it yourself by creating a simple custom expression. 
Note: This is just an example to show that custom expressions work the same way as the 
predefined aggregation methods. The main purpose with the custom expressions is to create 
aggregations that are not listed, rather than to recreate the predefined ones. 

 
For more examples of custom expressions, continue to the Basic Custom Expressions page. 
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6.4.3 Basic Custom Expressions 
Now that you know what custom expressions are, it is time to look at some basic examples of 
how they can be used. 

Example 
Let us start with a simple custom expression. Consider again the visualization from the 
overview page that shows the sales of fruits and vegetables. 
This trellised bar chart shows the sum of the sales per Year and Category. 

 
It shows that the sum of the sales of all vegetables and all fruits has increased each year. 
Using a simple custom expression, Sum([Sales])/Sum([Cost]), you can see the ratio of how 
much higher the sales are compared to the cost for each category and year. 
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It is now possible to see that even though the generated sales have increased each year, the sum 
of the sales compared to the sum of the cost has mostly decreased. 

Example 
The previous example showed that the sum of the sales had decreased relative to the sum of the 
cost. If you want to see the amount of money earned for each product and year, simply subtract 
the sum of the cost from the sum of the sales using the custom expression Sum([Sales])-
Sum([Cost]). 
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Now, assume that tax has not been subtracted from the sales price, and that five percent of the 
money received from customers cannot be counted as a profit. Simply change the custom 
expression to (Sum([Sales])*0.95)-Sum([Cost]) and you have the actual profit for each product 
each year. 

 

Example 
Consider another data set with sales data for a number of stores. In this data set, each row 
represents a specific purchase made by a customer. If you want to know how much money an 
average customer spends on different product types, this bar chart does not give you the correct 
answer. 
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This is because the aggregation Avg() returns the average sales figure for each row, which 
means this is an average of the money spent on a single purchase. However, since each 
customer can make several purchases, you have to use a simple custom expression. 
Since each row in the data also contains information on which customer has made the purchase 
(and in this case all customers have unique names), the custom expression to use is:  
Sum([Sales])/UniqueCount([Buyer]) which gives you the visualization below. 

 
Note how much smaller the bar representing vegetables is compared to bar in the first 
visualization. These two charts show that people spend more money on vegetables than they do 
on fruit or spices each time they make a purchase of either category. But overall, the average 
customer spends about the same amount of money on spices that they do on vegetables, and 
much more on fruit, meaning they must make many more individual purchases of vegetables. 

Example 
This data set is a record of orders and deliveries of Cable TV and Broadband Internet 
installations for customers in different cities. The fist image shows the number of installations 
that have been performed in the different cities. The visualization is colored according to which 
installation has been performed. 
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If you are interested in analyzing the number of days it takes for the cable TV and broadband 
Internet to be delivered and installed from the day it was ordered, this can be done with a bit 
more advanced custom expression. For this, we will use the DateDiff() function, found under 
Date and Time functions in the Custom Expression dialog. This function returns the difference 
between two date columns, in this case the columns Order Date and Delivery Date. You must 
also specify which part of the date you want to compare, and in this case it is the number of 
days we are interested in. Therefore, the base of the custom expression is: 
DateDiff("day",[Order Date],[Delivery Date]). This returns the number of days from order to 
delivery for each order. The complete custom expression looks like this: 
Avg(DateDiff("day",[Order Date],[Delivery Date])), and shows the average delivery time for 
both products in each city. 

 
From this, it is possible to see that the average delivery time for cable TV in New York is much 
higher than in the other cities. 
For more advanced custom expressions, the OVER statement is often used. It is described in the 
OVER in Custom Expressions topic. 
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Hierarchies 
If you are using a predefined hierarchy (in the example called MyHierarchy) on an axis and 
select Custom Expression you will see the expression 
<PruneHierarchy([Hierarchy.MyHierarchy],0)>. This syntax must always be used when  a 
hierarchy is included in an expression. It specifies that this part of the expression is a hierarchy 
and it determines which level of the hierarchy slider to set. 0 is the leftmost level on the 
hierarchy slider, and the number of levels in the hierarchy determines how high a value you can 
specify. If the hierarchy expression is to be used together with another categorical column or 
hierarchy, each subset must be separated with NEST or CROSS, as for all categorical 
expressions. For example, <PruneHierarchy([Hierarchy.MyHierarchy],0) NEST [Another 
category column]>. 

Column Names 
If the Column Names option is used on the axis, the underlying expression will be 
<[Axis.Default.Names]>. If the Column Names expression is to be used together with another 
categorical column or hierarchy, each subset must be separated with NEST or CROSS. For 
example, <[Axis.Default.Names] NEST [Another category column]>. 
  

6.4.4 OVER in Custom Expressions 
The OVER statement is used in many of the more advanced custom expressions. To understand 
how it works, consider again how markers represent slices of your data, and that the 
visualization properties, such as color or aggregations, determine how the data is sliced. Custom 
expressions work on each of the already defined slices in the visualization. 
Note: This is the fundamental difference between OVER in custom expressions and in 
calculated columns. When you add a calculated column with OVER, OVER defines how the 
data is to be sliced. Since custom expressions work on the individual slices, OVER in custom 
expressions actually does quite the opposite. When used in Custom Expressions the OVER 
method is telling the visualization to ignore specific slices that are already built into the 
visualization . 

Example 
To demonstrate what OVER does in custom expressions, consider the data set used in the 
overview and the first basic expressions. 
This visualization shows the sum of sales for the two categories fruits and vegetables for each 
year. 
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Change Sum(Sales) on the Y-axis to the custom expression Sum([Sales]) OVER 
(All([Axis.X])). Note that the X-axis must be categorical when OVER expressions are used to 
reference it. The expression might seem a bit confusing, but the terminology used will be 
explained shortly. Now look at the resulting visualization. It has the same number of markers as 
before, but the sum of the sales is equal for all of the markers of a certain category. 

 
The sum of sales is the same because you told the aggregation to look outside of the individual 
slices. In the first visualization the sum of the sales was calculated for each year, but the OVER 
statement told the aggregation to ignore the slicing on the X-axis. This means that the method 
Sum([Sales]) simply calculated the sum of the sales for all three years. But since you defined 
the X-axis to be divided by year, the number of markers remains the same, but the value for the 
Y-axis has changed. More information on the All Method used can be found on the Advanced 
Custom Expressions page. 
It is important to note that the term used is [Axis.X] instead of the name of the column (in this 
case, Year). When using the OVER statement, you cannot refer to explicit column names, but 
you should instead use [Axis.X] or [Axis.Color], for example, to refer to the column on the X-
axis and the Color by, respectively. Since the custom expressions work on the actual slices in 
the data (in this case, markers in the visualization), allowing them to refer to columns that are 
not defined as visualization properties (for example, X-axis or Color by), would demand further 
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slicing. Therefore, the custom expressions using the OVER statement can only be defined for 
columns used as visualization properties, and refer to the properties instead of the names. This 
also allows for changing the properties on the axes or the Color by, without making the custom 
expression invalid. See Axes in Expressions for a list of what to refer to in different 
visualizations. 

Nodes 
Another way to explain the OVER statement is this tree hierarchy. 

 
A marker or slice can include all data, for instance the data for 2003, or the data for January of 
2003. Each of the slices in this hierarchy is called a node. Using the OVER statement, you can 
compare data from one node with the data of other nodes. For instance, you can compare 
January 2003 with February 2003, you can compare March 2005 with March 2004, or you can 
compare data from a single month with the data from that entire year. For more examples of 
expressions using the OVER statement, see the Advanced Custom Expressions topic. 

What to refer to in different visualization types 
An axis in a visualization can be used as a part of an OVER expression, provided that the axis is 
categorical (this can be specified in the Advanced Settings dialog). See Axes in Expressions for 
a table defining what terms to use to specify a calculation on a property. The syntax when 
referring to axes in an expression is [Axis.Axis Name]. For example, if the Axis Name is "X", 
the expression should refer to [Axis.X]. Note that the actual names to use may be different in 
two similar looking visualizations. For example, in the cross table you would refer to 
Axis.Columns whereas in a heat map you would use Axis.X for similarly set up visualizations. 

Limitations 
• It is not allowed to refer to the Color axis in the size expression in a pie chart. 

Syntax 
The syntax for the OVER statement is the same for custom expressions and calculated columns: 
<method>(<method arguments>) over (<over methods>) 

All OVER methods can be used with dot notation or as a normal function call, for example, 
[Axis.Color].Parent or Parent([Axis.Color]). If nothing else is specified, the calculations are 
always based on the current node. 
  

6.4.5 Axes in Expressions 
When creating custom expressions, you may need to refer to an axis from the visualization in 
the expression. Below is a list of the available axes for different visualization types. Some of the 
axes can be useful in OVER expressions, whereas others are only used when defining rules or 
reference lines.  
The term axis, in this context, does not only refer to the X and Y axes, but is a general term for 
the mapping of data to a dimension represented in the visualization: coloring is controlled by 
the Color axis, marker shape by the Shape axis and so on. 
The syntax when referring to axes in an expression is [Axis.Axis Name]. For example, if the 
Axis Name is "X", the expression should refer to [Axis.X]. Note that the actual names to use 
may be different in two similar looking visualizations. For example, in the cross table you 
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would refer to Axis.Columns whereas in a heat map you would use Axis.X for similarly set up 
visualizations. 
It does not make any sense to include the axis you are creating the expression for in an OVER 
expression. Instead, you would probably want to use the categorization on the X-axis or the 
Color axis when defining an OVER expression on the Y-axis. 

Axes to use in OVER expressions and other expressions: 

Visualization Axis 
(Property) 

Axis Name Used in Expression 

Cross Table Columns 
Rows 

Columns 
Rows 

Sparkline Rows 
X-axis 

Rows* 
X 

Calculated Value Rows Rows* 

Icon Rows Rows* 

Bar Chart Category axis 
Color by 

X 
Color 

Line Chart X-axis 
Color by 
Line by 
Line by + Color by 

X 
Color 
Line 
Feature 

Combination Chart X-axis 
Color 

X 
Color 

Pie Chart Color by Color 

Scatter Plot X-axis 
Y-axis 
Color by 
Marker by 
Shape by 
Label by 
Line by 

X 
Y 
Color 
Marker 
Shape 
Label 
Line 

3D Scatter Plot X-axis 
Y-axis 
Z-axis 
Color by 
Marker by 
Shape by 
Label by 

X 
Y 
Z 
Color 
Marker 
Shape 
Label 

Map Chart X-axis 
Y-axis 
Color by 
Marker by 
Shape by 
Label by 

X 
Y 
Color 
Marker 
Shape 
Label 
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Line by 
Identifier 

Line 
Identifier 

Treemap Hierarchy Hierarchy 

Heat Map X-axis 
Y-axis 

X 
Y 

Parallel Coordinate 
Plot 

Line by 
Color by 

Line 
Color 

Trellis Columns 
Rows 
Pages 
Panels 

Columns 
Rows 
Pages 
Panels 

* The Rows axis in a graphical table can be used in OVER expressions in dynamic item 
columns included in that graphical table. 
Example: 
Sum([Sales]) OVER (AllPrevious([Axis.X])) 
See OVER in Custom Expressions and Advanced Custom Expressions for more information 
about OVER expressions. 

Axes to use in rules and reference lines only: 
When defining rules (for example, for coloring, icons or calculated values) or when setting up a 
reference line in a visualization, you will define an expression directly using the value on that 
very axis. (The way to refer to the axes is slightly different in those two contexts.) 

Visualization Axis 
(Property) 

Axis Name Used in Expression 

Sparkline Y-axis Y 

Calculated Value Value Value 

Icon Icon Icon 

Bar Chart Value axis Y 

Line Chart Y-axis Y 

Combination Chart Y-axis Y 

Examples in rules: 
[Axis.Color]="West" 
[Axis.Value]> 10000 
Example in reference line: 
Avg([Y])*10 

6.4.6 Advanced Custom Expressions 
The OVER statement is used in many of the more advanced custom expressions. In this section, 
several node and time period methods are explained. 
In the examples below, a bar chart with a Year/Month hierarchy on the category axis is used, 
and in most cases it is colored by Product. 
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For some of the methods, there is more than one example and many have a more general 
illustration of how they work. 

Node methods 
Node methods can refer to other nodes relative to the current node based on the position in the 
hierarchy. 

Method Description 
Parent Method Uses the parent subset of the current node to perform the calculation. If the 

node does not have a parent, all rows are used as the subset. 
  
It can be used to show how much of the total sales each product category 
represent each month. 
Sum([Sales]) / Sum([Sales]) OVER (Parent([Axis.Color])) 

 
Note: In this example, Parent refers to what the color is set to, which is 
Product. 
  
As an additional example, if you wish to see the percentage of all sales for 
each month of each year, regardless of product category, you can create the 
following custom expression. 
Sum([Sales]) / Sum([Sales]) OVER (Parent([Axis.X])) * 100 
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Next Method Compares the current node with the next node on the same level in the 

hierarchy. 

 
If there is no next node, that is, if the current node is the last node for the 
current level, the resulting subset will not contain any rows. 
  
Sum([Sales]) - Sum([Sales]) OVER (Next([Axis.X])) 

 
If the current node is 2004.Jan, in the figure at the top of the page, 'next' in 
this case will refer to 2004.March, since 2004.February is missing in the 
data. See Next Period method for value based reference. 
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Previous 
Method 
  

Uses the previous node on the same level as the current node to compare the 
result of the current node with the previous one. 

 
  
If there is no previous node, that is, if the current node is the first node for 
the current level, the resulting subset will not contain any rows. 
  
Sum([Sales]) - Sum([Sales]) OVER (Previous([Axis.X])) 

 
All Method 
  

The All method uses all the nodes in the referenced hierarchy: 

 
This can be useful when intersecting the current node with more than one 
hierarchy. 



Enhancing Visualizations 

731 

  
In this example, the bar chart shows the relative sales of the different product 
categories for each month. 
Sum([Sales]) / Sum([Sales]) OVER (Intersect(All([Axis.Color]), [Axis.X])) 

 
Note: See the Intersect Method for information on that method. 
  
Another example is if you want to see the percentage of all sales for each 
month over the years. Regardless of product category. 
Sum([Sales]) / Sum([Sales]) OVER (All([Axis.X])) * 100 

 
All Previous 
Method 
  

Uses all nodes, including the current, from the start of the level. 

 
  
This can be used to calculate the cumulative sum. 
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Sum([Sales]) OVER (AllPrevious([Axis.X])) 

 
Tip: A basic Cumulative Sum expression can easily be created using the 
shortcut in the Aggregation menu on the axis selector. 
  
If you want to limit the cumulative sum for current year you can combine the 
All Previous Method with the Intersect Method: 
Sum([Sales]) OVER (Intersect(Parent([Axis.X]), AllPrevious([Axis.X]))) 

 
Note: See the Intersect Method for information on that method. 

All Next 
Method 

Uses all nodes, including the current, to the end of the level. 

 
Intersect 
Method 

Returns the intersected rows from nodes in different hierarchies. 
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See also the All Previous Method and the All Method for examples of how it 
works. 
Intersect(Parent([Axis.X]), All([Axis.Color]), Parent([Axis.Rows]), ...) 

Time period methods 
Time period methods can refer to other nodes relative to the current node based on the value in 
the current node and the other relative nodes. 

Method Description 
Next Period 
Method 

Uses the next node which has the next value (defined as the next value 
index) on the same level as the current node to perform the calculation. If 
there is no next node, that is, if the current node is the last node for the 
current level, the resulting subset will not contain any rows. 
Sum([Sales]) OVER (NextPeriod([Axis.X])) 

 
If the current node is 2004.Jan, in the figure at the top of the page, 
NextPeriod will return an empty subset, since February is missing. 

Previous Period 
Method 

Uses the previous node which has the previous value (defined as the 
previous value index) on the same level as the current node to perform 
the calculation. If there is no previous node, that is, if the current node is 
the first node for the current level, the resulting subset will not contain 
any rows. 
Sum([Sales]) OVER (PreviousPeriod([Axis.X])) 
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Parallel Period 
Method 
  

Uses the previous parallel node with the same value (defined as having 
the same value index) on the same level as the current node. 

 
Note: The method only looks for a node with the same value as the 
current node in the children to the previous parent node. That means that 
it only looks one level above the current node. Therefore, a hierarchy 
with year as the parent node and quarter OR month as nodes on the lower 
level will work since the nodes under each year will have the same 
values. However, a hierarchy with all three levels would not work for this 
method since the months under Q2 and Q3, for example, do not have the 
same values. 
  
This can be used to compare sales results for each month with the 
corresponding months the previous year. 
Sum([Sales])-Sum([Sales]) OVER (ParallelPeriod([Axis.X])) 

 
Last Periods 
Method 

Includes the current node and the n - 1 previous nodes (as defined by the 
each node value index). 
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This can be used to calculate moving averages. 
Sum([Sales]) OVER (LastPeriods(3, [Axis.X]))/3 

 
Note: All time period methods return the resulting visualization item subset, so the use of 
aggregation methods like average might not produce the expected result. See also Working with 
Time Hierarchies for more information about missing values in time series. 
  

6.4.7 How to Insert a Custom Expression 
TIBCO Spotfire supports two different types of expressions: Insert Calculated Column, which 
creates a new column in the data table, and Custom Expression, which is used to dynamically 
modify the expression used on an axis or to define a setting. Both types of expressions are 
created with a similar user interface. 

► To create a custom expression: 
1. Right-click on a column selector on an axis, in a Visualization Properties dialog, or in 

the Legend, to display the pop-up menu. 
Comment: You can also create custom expressions for rules and reference lines. See 
Custom Expressions for Coloring, Details on Horizontal/Vertical Line, Details on 
Curve Draw, or Details on Curve from Data Table for more information. 

2. Select Custom Expression.... 
3. Specify a suitable expression by either typing it directly into the Expression text field, 

or by selecting columns, properties and functions from the list. 
An example of an expression could be: [Exports m$]/[Population]. 
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Comment: You can always modify the expression by editing the text in the Expression 
field using cut-and-paste, or by typing text. For a detailed description of the expression 
language, see General Syntax and other topics under Expression Language in the Insert 
Calculated Column chapter. For details on the syntax to use when adding properties, 
see Properties in Expressions. 

4. Type a Display name for the expression. 
5. Click OK. 

Comment: If an error message is shown, there is a problem with the expression. Go 
back and modify the expression until the desired result is achieved. 
Response: The expression is used on the specified axis or setting. 

Tip: If you have previously created a suitable expression, you may select it from the Recent 
expressions list and click the Insert button. 

► To reach the Insert Calculated Column dialog: 
1. Select Insert > Calculated Column.... 

Comment: See How to Insert a Calculated Column for more information. 

6.4.8 Details on Custom Expression 
TIBCO Spotfire supports two different types of expressions: Insert Calculated Column, which 
creates a new column in the data table, and Custom Expression, which is used to dynamically 
modify the expression used on an axis or to define a setting. Both types of expressions are 
created with a similar user interface. 

► To reach the Custom Expression dialog: 
1. Right-click on a column selector on an axis, in a Visualization Properties dialog, or in 

the Legend, to display the pop-up menu. 
2. Select Custom Expression.... 
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Option Description 

Available columns Shows all columns that you can use in the calculation of your 
custom expression. 
Select a column by clicking on it in the list and then click on the 
Insert Columns button, or double-click on the column to send it to 
the Expression field. Press Ctrl or Shift to select multiple columns. 
You can narrow down the list of available columns by typing a part 
of a name in the "Type to search" field. You can also enter an 
expression in the field using the rules described on the Searching in 
TIBCO Spotfire page. 

Insert Columns Inserts the columns selected in the Available columns list at the 
current cursor position in the Expression field. 

Available properties 
for column 

Shows all properties that you can use in the calculation of a custom 
expression. You can narrow down the list of available properties by 
using the search field. The column properties shown are specific to 
the column selected in the Available columns list to the left. 
Select a property by clicking on it in the list and then click on the 
Insert Properties button; or double-click on the property to send it to 
the Expression field. The property will automatically be inserted as 
text. However, there may be occasions where you need to insert the 
property as a function to receive the desired result. See Properties in 
Expressions for more information. Use the pop-up menu in this field 
to select how to insert the property or type the correct syntax 
manually. 
If you want to define a new property to use in the expression, right-
click in the Available properties field and select New > [Property 
Type] Property... from the pop-up menu. You can also edit or 
delete custom properties by using the pop-up menu. 

Insert Properties Inserts the properties selected in the Available properties for column 
list at the current cursor position in the Expression field. 

Category Select a category of functions to limit the choices in the Function 
list: 
All functions 
Binning functions 
Conversion functions 
Date and Time functions 
Logical functions 
Math functions 
Operators 
Property functions 
Ranking functions 
Spatial functions 
Statistical functions 
Text functions 

Function Select a function by clicking on it in the list and then click on the 
Insert Function button, or double-click on the function to send it to 
the Expression field. 
Type a search string in the text field to limit the number of items in 
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the Functions list. 
You can also click on any function and type the first letter of the 
desired function name to jump to a specific location in the list. 

Description Shows a brief description of the selected function. For more detailed 
descriptions, see the Functions chapter. 

Insert Function Inserts the selected function at the current cursor position in the 
Expression field. 

Expression This is the text field in which you build your expression. You can 
insert columns and functions from the lists, or enter text as in any 
standard text editor. 
Cut/Copy/Paste works in the field using standard 
Ctrl+X/Ctrl+C/Ctrl+V. 
Also, it is possible to undo/redo the last action by pressing Ctrl+Z. 

Recent expressions Displays the ten expressions you have most recently created. You 
can select one of these and click the Insert button to insert the 
expression into the Expression field. 

Insert Inserts the selected Recent expression into the Expression field. This 
will replace the entire content of the Expression field. 

Resulting expression Of interest when preprocessor functions (such as ${PropertyName}) 
are used in the expression only. Displays the expression after all 
occurrences of the property have been replaced with its current value 
or values. 

Display name The name of the new expression. 

6.5 Lines & Curves 
6.5.1 Lines and Curves 

Some of the visualization types can display additional information in reference lines or several 
different types of curves. This is set up in the properties dialog of each appropriate visualization 
type. Here, the Lines and Curves page of the scatter plot properties is shown: 
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For example, you may want to show how well your data points adapt to a certain polynomial 
curve fit or to a logistic regression curve fit. 
Curve fit (regression analysis) allows you to summarize a collection of sample data points by 
fitting them to a model that will describe the data and display a curve or a straight line on top of 
a visualization. The curve is normally not a fixed curve, but rather a line that can be changed 
upon changing the input data during filtering. However, you can always select to "freeze" the 
updating of a curve and only allow it to be updated manually. 
Curve fitting can be used either to determine the parameter values of a known regression model 
or to find a model that fits the data better than other models. TIBCO Spotfire allows you to 
define your own curves, either directly from an expression or from an expression which is 
linked to a data table containing curve parameters. Note that whenever there is a reference to X 
or Y in lines or curves for a bar chart, X always refers to the category axis while Y refers to the 
value axis. 

Transformations 
The X- and Y-values used in the curve fitting are the plotted values, hence, they are affected by 
scaling. This means that if you use log scale you may want to apply a different curve fitting 
model than you would otherwise. For example, if you want to do logistic regression and have 
either log10-values or log10-scaled values on the X-axis, you should make sure to apply the 
setting "Assume that X is log10-transformed" in the Edit Curve dialog in order to obtain the 
expected results. 

Limitations on data 
Not all types of input data can be used to calculate curves using all different types of models. 
All models require: 

• more than one data point to use in the calculation 
• that not all data points have the same X- and Y-values (lie on top of each other) 



TIBCO Spotfire 4.0.2 - User's Manual 

740 

• that not all data points have the same X-value 
In addition, the logarithmic model, the power model and the logistic regression model require 
that all data points have positive X-values. The power model and the exponential model also 
require that all Y-values have the same sign (positive or negative). 
The logistic regression requires that not all data points have the same Y-value. If any of the 
above limitations occur, no curve will be drawn and a notification will be displayed in the title 
bar of the visualization. 

 
If you choose to export your calculation, any error message shown in this tooltip will also 
appear in the column "Notes" of the resulting export file. Note that this column always exists in 
the export file. If there are no errors, it will be empty. 
For more information about exporting Lines and Curves, see Lines & Curves properties of the 
appropriate visualizations. 

6.5.2 Curve Fit Models 
There are several different models available for curve fitting. See Lines and Curves for 
information about how to apply the various curves. 

Straight Line 
The straight line fit is calculated by choosing the line that minimizes the least square sum of the 
vertical distance d, of all the selected markers (see picture below) by using the following 
equation: 

 
where a is the intercept and b is the slope. 
For example, you could plot days along the X-axis and have one marker for each day. The 
distance between the markers along the X-axis is the same, thus making straight line fit 
appropriate. 
  

 

Logarithmic 
The logarithmic fit calculates the least squares fit through points by using the following 
equation: 
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where a and b are constants and ln is the natural logarithm function. This model requires that 
x>0 for all data points.  Spotfire uses a nonlinear regression method for this calculation. This 
will result in better accuracy of the calculation compared to using linear regression on 
transformed values only. 

Exponential 
The exponential fit calculates the least squares fit through points by using the following 
equation: 

 
where a and b are constants, and e is the base of the natural logarithm. 
Exponential models are commonly used in biological applications, for example, for exponential 
growth of bacteria. Spotfire uses a nonlinear regression method for this calculation. This will 
result in better accuracy of the calculation compared to using linear regression on transformed 
values only. 

Power 
The Power fit calculates the least squares fit through points by using the following equation: 

 
where a and b are constants. This model requires that x>0 for all data points, and either that all 
y>0 or all y<0. Spotfire uses a nonlinear regression method for this calculation. This will result 
in better accuracy of the calculation compared to using linear regression on transformed values 
only. 

Logistic Regression 
The logistic regression fit is a dose response ("IC50") model, also known as sigmoidal dose 
response. The four parameter logistic model is the most important one. 
Dose-response curves describe the relationship between response to drug treatment and drug 
dose or concentration. These types of curves are often semi-logarithmic, with log (drug 
concentration) on the X-axis. On the Y-axis one can show measurements of enzyme activity, 
accumulation of an intracellular second messenger or measurements of heart rate or muscle 
contraction. 
Note: The logistic regression model of Spotfire is implemented with a setting where you can 
select whether or not to assume that X is log10-transformed. The default setting is a selected 
check box, which means that if your input data is not logarithmic, you should make sure to clear 
the check box in the Edit Curve dialog. You might also want to select the Log scale check box 
on the X-axis page in the Visualization Properties dialog, to show the values on a logarithmic 
scale. 
  
Log10-transformed X-values: 
The logistic regression on logged X-values fit uses the following equation: 

 
The LoggedX50 value is interpreted as the Log10(X50). For example, if the H30+ 
concentration at IC50 has a pH of 3, then the LoggedX50 = -3. 
Note: With this model, it is the logged X50 values that are estimated and not the actual X50. 
  
Non-logarithmic X-values: 
The logistic regression fit when not assuming logged X-values uses the following equation: 
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where min and max are the lower and upper asymptotes of the curve, Hill is the slope of the 
curve at its midpoint and X50 is the x-coordinate of the inflection point (x, y). This model 
requires that x>0 for all data points and that you use at least four records to calculate the curve. 

 

Polynomial 
The polynomial curve fit calculates the least squares fit through points by using the following 
equation: 

 
where a0, a1, a2, etc., are constants. The default order is a 2nd order polynomial, but you can 
change the degree in the Edit Curve dialog. This model requires that you use at least three 
markers to calculate the curve for a 2nd order polynomial model, and four markers for a 3rd 
order polynomial, etc. 
If you have a low number of unique x-values, a polynomial curve can be calculated in an 
unlimited number of ways. This means that you may end up with a curve that does not look as 
expected. If this should happen, you probably should not apply this model to your data. 
Some of the models have been partially solved by using the LAPACK software package, see 
References. 

Gaussian 
The Gaussian curve fit calculates a bell curve suitable to describe normal distributions using the 
following equation: 

 
where A is the amplitude of the curve, E is the position of the center of the curve and G is the 
width. 
In TIBCO Spotfire, you have the possibility to let the application calculate values on the 
parameters A, E and G automatically from the available data. You can also specify one or more 
of the parameters yourself. 
  

6.5.3 Curve Fit Theory 
Generally, curve fit algorithms determine the best-fit parameters by minimizing a chosen merit 
function. In order to optimize the merit function, it is necessary to select a set of initial 
parameter estimates and then iteratively refine the merit parameters until the merit function does 
not change significantly between iterations. The Levenberg-Marquardt algorithm has been used 
for nonlinear least squares calculations in the current implementation. 
The goodness of fit is shown as an R2-value. A value of R2=1.0 indicates a perfect fit, whereas 
R2=0.0 indicates that the regression model might be unsuitable for this type of data. 
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R2 
The R2-value measures how much of the variation in the data points can be explained by the 
selected regression model: 
  

       
where 

(the regression sum of squares) 

(the residual or error sum of squares) 
  

(the total sum of squares, SST= SSE+SSR) 

and  represents the ith fitted value (calculated using the selected model) of the dependent 
variable Y. 
  

Limitations to curve fitting 
Since the calculation of the curve is an iterative process, the calculation must stop somewhere. 
In some cases, the maximum number of iterations might be reached before the best possible 
curve has been calculated. In that case, a message in the title bar of the visualization will inform 
you of this. In some cases, for example if the data is widely scattered or too few data points are 
available, the iterative process might also result in a curve that converges on a false minimum. 
When a model is applied during data analysis, it is important not only to look at the R2-value 
and how well the curve fits the current markers in the scatter plot, but also to consider what the 
curve would look like for more extreme values and determine whether the model is reasonable 
in a scientific or statistical context. The number of unique x-values must be larger than, or equal 
to, the number of degrees of freedom in order to obtain a unique curve. If the curve can be 
solved in an infinite number of ways, it is not certain that the presented curve will be relevant to 
your data. 

References 
Heath, M.T., (2002), Scientific Computing: An Introductory Survey, 2nd ed., McGraw-Hill, 
New York. 
Anderson, E., Bai, Z., Bischof, C., Blackford, S., Demmel, J., Dongarra, J., Du Croz, J., 
Greenbaum, A., Hammarling, S., McKenney, A., Sorensen, D., (1999), LAPACK Users' Guide, 
3rd ed., Society for Industrial and Applied Mathematics, Philadelphia, PA, ISBN = 0-89871-
447-8 

6.5.4 Details 

6.5.4.1 Details on Horizontal/Vertical Line 
Lines can currently be shown in the bar chart, line chart, combination chart, scatter plot and box 
plot visualizations. 
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► To reach the Horizontal Line or Vertical Line dialog: 
1. In the Visualization Properties dialog of any of the above mentioned visualizations, go 

to the Lines & Curves page. 
2. Click on Add and select to add either a horizontal or vertical line. 

Comment: Selecting a previously added horizontal or vertical line and clicking on 
Edit... also opens this dialog. 

 

Option Description 

Line position Specifies the type of line that you wish to add. 

   Fixed value Adds a straight line at the defined value for the selected axis. 

   Aggregated value Adds a straight line at the selected aggregation of values for the 
selected values. 

   Column property 
value 

Adds a straight line at the specified column property value. All 
numerical column properties, both predefined and custom properties, 
are available for selection. 

   Custom expression Adds a line at the specified custom expression. 

   Edit... Opens the Custom Expression dialog, where you can select between 
columns and functions to define your expression. 

   Use axis transform 
in line calculation 

Select this check box to apply the same axis transform, i.e., a log 
scale, to the reference line as has been previously specified on the 
page for the axis. A reversion of the axis is always applied. 
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Line name Specifies whether an Automatic line name should be created, or 
whether you instead wish to type a Custom line name. 

Note: If you change the orientation of the bars in a bar chart, any added lines will automatically 
switch orientation as well. For example, if you have added a horizontal line to a vertical bar 
chart and then switch to horizontal bars, the line will automatically become a vertical line. 
  

6.5.4.2 Details on Naming Curve 
This dialog is shown when you add or edit a Straight Line Fit, a Power Curve Fit, a Logarithmic 
Curve Fit or an Exponential Curve Fit from the Lines & Curves page of the Visualization 
Properties dialog. 
This dialog allows you to name your curve automatically or to set a custom name. The other 
Lines and Curves have additional settings. 

 

Option Description 

Curve name Specifies whether an Automatic line name should be created, or 
whether you instead wish to type a Custom line name. 

  

6.5.4.3 Details on Logistic Regression Curve Fit 
This dialog is shown when you add or edit a Logistic Regression curve fit from the Lines & 
Curves page of the Visualization Properties dialog (only available for some visualization types). 
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Option Description 

Min Allows you to specify a minimum value to be used in the calculation. 

Max Allows you to specify a maximum value to be used in the calculation. 

Assume that X is 
log10-transformed 

Select this check box if the X-axis values are log10-transformed. Clear 
the check box if the values are non-logarithmic. 

Curve name Specifies whether an Automatic curve name should be created, or 
whether you instead wish to type a Custom curve name. 

Leaving the fields blank will let the application automatically create min and max values based 
on the currently available data used for calculation. 

6.5.4.4 Details on Polynomial Curve Fit 
This dialog is shown when you add or edit a polynomial curve fit from the Lines & Curves page 
of the Visualization Properties dialog (only available for some visualization types). 

 

Option Description 

Degree Specifies the order of the polynomial to use in the curve fit. 

Curve name Specifies whether an Automatic line name should be created, or 
whether you instead wish to type a Custom line name. 
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6.5.4.5 Details on Curve Draw 

 

Option Description 

Category Select a category of functions to limit the choices in the Function list: 
Binning functions 
Conversion functions 
Date and Time functions 
Logical functions 
Math functions 
Operators 
Property functions 
Ranking functions 
Statistical functions 
Text functions 

Function Select a function by clicking on it in the list and then click on the Insert 
Function button to send it to the Curve expression field. 
Type a search string in the text field to limit the number of items in the 
Functions list. 
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You can also click on any function and type the first letter of the 
desired function name to jump to a specific location in the list. 

Description Shows a brief description of the selected function. For more detailed 
descriptions, see the Functions chapter. 

Insert Function Inserts the selected function at the current cursor position in the Curve 
expression field. 

Curve expression 
y(x): 

This is the text field in which you build your expression. You can 
insert functions from the lists, or enter text as in any standard text 
editor. 
Cut/Copy/Paste works in the field using standard 
Ctrl+X/Ctrl+C/Ctrl+V. 
It is also possible to undo/redo the last action by pressing Ctrl+Z. 

Status Displays the status of the current expression. If this field shows an 
error, there is a problem with the expression. 

Curve name Specifies whether an Automatic curve name should be created, or 
whether you instead wish to type a Custom curve name. 

6.5.4.6 Details on Curve from Data Table 
This dialog is shown when you add or edit a curve from data table from the Lines & Curves 
page of the Visualization Properties dialog (only available for some visualization types). It 
allows you to specify a custom curve expression which makes use of parameters available in a 
specified data table. 

 

Option Description 

Data table with 
curve parameters 

Lists the available data tables in the analysis. Select the data table that 
contains the curve parameters you wish to use in the definition of the 
curve. 
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Expression Type the curve expression containing the independent variable 
(normally x) and any other parameters that are defined in the selected 
data table. 
All variables in the expression, except for the independent variable, 
must have corresponding columns in the parameter table. 
Note: The columns that are used for relations between the data table 
and the parameter table cannot be used as variables in the expression 
or as result variables. 

Edit... Opens the Edit Expression dialog where you can select between 
columns and functions to define your expression. 

Columns for label 
and tooltip 

Lists the columns from the data table selected above that also should 
be used in the label and/or tooltip for the curve. You can change 
whether to display the contents from the column in the label, in the 
tooltip or in both using the Label and Tooltip dialog. 

Select... Opens the Select Columns dialog where you can select the columns 
that should be possible to use in the label and/or tooltip for a curve. 

Curve name Specifies whether an Automatic line name should be created, or 
whether you instead wish to type a Custom line name. 

6.5.4.7 Details on Line from Column Values 
Use this alternative if you want to display lines based on X and Y coordinates that already exist 
in two columns of your analysis. For example, coordinate values could be calculated from the 
input data using a statistical calculation in a data function and the output result could be 
presented as coordinate values for a curve. 
When the line is drawn from column values it is also possible to show predictive values, if these 
are available: 

 
Note that lines cannot be drawn when categorical scales are used on the axes. 



TIBCO Spotfire 4.0.2 - User's Manual 

750 

 

Option Description 

Data table with 
line values 

Lists the available data tables in the analysis. Select the data table with 
the coordinate values. 

X-values column Select the column in the data table that holds the X-axis coordinate 
values. 
(In a bar chart, this refers to the category axis coordinate values.) 

Y-values column Select the column in the data table that holds the Y-axis coordinate 
values. 
(In a bar chart, this refers to the value axis coordinate values.) 

Sorted by column If desired, select a column to sort the values by. If none is selected, the 
line is drawn in the order of appearance of all values. 

Empty values   

   Ignore (skip) 
empty values 

Click this radio button to ignore any missing values and continue the 
line using the next coordinate pair. 

   Split curve at 
empty values 

Click this radio button to split the curve once an empty value is 
encountered. 

Curve name   

  Automatic Sets an automatic name for the line. 

  Custom Allows you to set a custom name for the line by typing a name in the 
text field. 
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6.5.4.8 Details on Line from Data Table 
Use this alternative if you want to add lines to a visualization based on an existing data table in 
your analysis. A simple example is if you have a data table with number of sales for two 
different products on different dates, you can also have a data table with the minimum 
acceptable number of sales on any given day for the different products. If the data with number 
of sales is set as a visualization, you can add lines from the minimum number of sales data 
table. This gives you an easy way of seeing whether any products have fewer sales than you 
expect. 

 

Option Description 

Data table with 
line positions 

Lists the available data tables in the analysis. 

Column Select the column in the data table from which you want to create your 
reference line. 

Columns for label 
and tooltip 

Lists the columns from the data table selected above that should also 
be used in the label and/or tooltip for the line. You can change whether 
to display the contents from the column in the label, in the tooltip or in 
both using the Label and Tooltip dialog. 

Select... Opens the Select Columns dialog where you can select the columns 
that should be possible to use in a line's label and/or tooltip. 

Curve name   

  Automatic Sets an automatic name for the line. 

  Custom Allows you to set a custom name for the line by typing a name in the 
text field. 

 

  



TIBCO Spotfire 4.0.2 - User's Manual 

752 

6.5.4.9 Details on Gaussian Curve Fit 
This dialog is shown when you add or edit a Gaussian curve fit from the Lines & Curves page 
of the Visualization Properties dialog (only available for some visualization types). 

 

Option Description 

Gaussian curve 
parameters 

  

   Position (E) Allows you to specify the position of the center point for the Gaussian 
distribution curve. 

   Width (G) Allows you to specify the width of the Gaussian distribution curve. 

   Amplitude (A) Allows you to specify the altitude (height) of the Gaussian distribution 
curve. 

Curve name Specifies whether an Automatic curve name should be created, or 
whether you instead wish to type a Custom curve name. 

Leaving the curve parameter fields blank will let the application automatically create curve 
parameter values based on the currently used data. 
Note that if you specify curve parameters that are very far away from the data values, no curve 
will be drawn. 
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6.5.4.10 Details on Edit Expression 
This dialog is shown when you add or edit a curve from data table from the Lines & Curves 
page of the Visualization Properties dialog (only available for some visualization types) and you 
click Edit... in the Curve from Data Table dialog. 

 

Option Description 

Available 
variables 

Shows all variables found in the data table that you can use in the 
calculation of the curve. 
Select a column by clicking on it in the list and then click on the Insert 
Columns button, or double-click on the column to send it to the 
Expression field. Press Ctrl or Shift to select multiple columns. 

Insert Variable Inserts the variables selected in the Available variables list at the 
current cursor position in the Expression field. 

Category Select a category of functions to limit the choices in the Function list: 
Binning functions 
Conversion functions 
Date and Time functions 
Logical functions 
Math functions 
Operators 
Property functions 
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Ranking functions 
Statistical functions 
Text functions 

Function Select a function by clicking on it in the list and then click on the Insert 
Function button to send it to the Curve expression field. 
Type a search string in the text field to limit the number of items in the 
Functions list. 
You can also click on any function and type the first letter of the 
desired function name to jump to a specific location in the list. 

Description Shows a brief description of the selected function. For more detailed 
descriptions, see the Functions chapter. 

Insert Function Inserts the selected function at the current cursor position in the Curve 
expression field. 

Curve expression 
y(x): 

This is the text field in which you build your expression. You can 
insert functions from the lists, or enter text as in any standard text 
editor. 
Cut/Copy/Paste works in the field using standard 
Ctrl+X/Ctrl+C/Ctrl+V. 
Also, it is possible to undo/redo the last action by pressing Ctrl+Z. 

Status Displays the status of the current expression. If this field shows an 
error, there is a problem with the expression. 

6.5.4.11 Details on Label and Tooltip 
This dialog handles what should be shown in the label and/or tooltip of a selected line, curve or 
point. 

► To reach the Label and Tooltip dialog: 
1. In the Visualization Properties dialog of a visualization that supports lines and curves, 

go to the Lines & Curves page. 
2. Click to select the line or curve of interest in the Visible lines and curves list. 
3. Click on the Label and Tooltip... button under Settings. 
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Option Description 

Display the 
following values 

Lists the available values that can be selected to be displayed in the 
label, tooltip or both. 
For Line from Data Table and Curve from Data Table you can make 
columns from the additional data table available here while setting up 
the line or curve using the Columns for label and tooltip field. 
Select the corresponding check box to include a value in the label or 
tooltip. 

Format... Opens the Formatting dialog where you can change the value 
formatting of the values in the curve expression. 

6.6 Formatting 
6.6.1 Formatting Overview 

Formatting is giving a value meaning by adding units of measurements, thousands and decimal 
separators, and other information. Locale settings, determined by Windows Regional Settings, 
are used to determine formatting, but you can also make certain changes yourself, such as 
whether to show thousands separators or how many decimals to show. 
Formatting does not include visual properties, such as color, font, or size. 
Example: If you have Windows Regional Settings set to Swedish and select to show thousands 
separators and the numbers are in US currency, you will get formatted values such as 
$1.000.000,00. If you change your locale settings to US English, the value will be re-formatted 
into $1,000,000.00. 
Which formatting options are available depends on the data type of the value. Text cannot be 
formatted at all, while an integer has several different possibilities. An integer can, among other 
things, be formatted as a number, currency and as percentage. You can set the number of 
decimals to be displayed, as well as whether or not to use a thousands separator. Another 
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possibility is to use short number format, which is a way to shorten values to take up less space 
by replacing powers of tens with symbols. See Short Number Format to learn more. You can 
apply formatting to your data on different levels and you can access the settings in different 
ways as described below. 

Default axis formatting 
In the Options dialog you can set default formatting for data types on the visualization axes. For 
example, if you set the data type integer to be formatted as US currency ($) with two decimals, 
then each time you create a new visualization in Spotfire, values on an axis with integers will be 
displayed as US currency with two decimals. Note that these default formatting settings do not 
affect the columns or the data tables in any way, only the axes in the visualizations. 
To reach the default settings, open the Tools menu, select Options and go to the Axis 
Formatting page in the dialog. 

Column formatting 
If you want a specific column in a data table to be formatted in a certain way throughout the 
analysis, you can format values on a column level. For example, if you format a column called 
"Cost" as US currency ($) with two decimals, the values in the column "Cost" will be displayed 
as US currency with two decimals every time that column is used. These settings affect all the 
places where the column is used in the analysis, including axes in visualizations, filters, tooltips, 
etc., and changes take effect immediately. Column formatting overrides formatting on default 
axis formatting level. 
To change formatting settings on column level, open the Edit menu, select Column Properties 
and go to the Formatting tab. You can also right-click on a filter in the filters panel, and then 
select Format Values... from the menu to format on column level. 

Formatting in visualizations 
You can format values in individual visualizations. For example, if you format the values on the 
X-axis of a scatter plot as Number with no decimals, the values on the X-axis in that scatter plot 
will be instantly updated with the new formatting settings. The Y-axis in the scatter plot will not 
be affected by the new settings, and no other visualizations in the analysis will adopt the 
changes. Formatting on this level overrides settings on both the default axis level and on the 
column level. You can define formatting settings on the axes in many of the visualizations, but 
not all. Formatting on visualization level is similar in all kinds of visualizations, but the cross 
table differs slightly and is described in Formatting in the Cross Table. 
To change formatting settings on the visualization level, right-click in the visualization, select 
Properties from the pop-up menu, and then open the Formatting page. You can also right-
click directly on the scale labels of a visualization to open a pop-up menu, then select 
Formatting and the formatter you want to use for the axis. 
If you use multiple scales in a visualization, you can format each of the scales individually the 
same way you format an axis in a visualization. However, if there is more than one scale on the 
same side of an axis in a visualization, you cannot format the scales on that side separately by 
right-clicking directly on the scale. This will instead change the settings for all scales. However, 
you can still format the scales separately from the Formatting page in the properties dialog. 
No matter on which level you format, the options are the same. See Formatting Settings to get a 
full description of all the options. 
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6.6.2 Formatting Settings 

 
The image above shows the Formatting page of a Scatter Plot Properties dialog. The lower part 
of the dialog contains the formatting settings and is the same for all the dialogs where you can 
change formatting settings. The Category list displays the available categories for the selected 
axis, column or data type depending on whether you are changing formatting settings on 
visualization level, column level, or default settings level respectively. Each category in this list 
has separate settings, as shown below. What categories are available depends on the data type of 
the selected column. For general information about formatting, see Formatting Overview. 

Option Description 

General A general, non-configurable format, with a variable number of 
decimals and no thousands separator. The number is converted to 
the most compact of either fixed-point or scientific notation. A 
minus sign is always used for negative values. 
Examples: 
1 
12345 
1.23456E-6 
-12345 

Currency A number format for currencies. A currency culture may be other 
than the current culture. In this case number formatting is according 
to current culture, but currency symbol and pattern is defined by the 
specified currency culture. 
Examples: 
$ 1234.45 
¥1,234 
-1,234.45 kr 
($ 1,234.45) 
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      Decimals Specifies the number of decimals (0-15) to display. An additional 
alternative (Auto) is also available. If you select (Auto), the number 
of decimals will be different from one number to another since 
trailing zeros will not be included. 
Examples: 

1,234.560700 (Six decimals) 
1,234.560 (Three decimals) 
1,234.56 (Two decimals) 
1,234.5607 (Auto) 

      Use thousands 
separator 

Specifies whether to use a thousands separator (digit grouping 
symbol in Windows Regional Settings) or not. The grouping 
symbol cannot be explicitly specified (only through Windows 
Regional Settings). 

      Currency Specifies the currency type (kr, £, $, etc.) and placement. 

      Negative numbers Specifies the pattern used for displaying negative numbers [-1.23 or 
(1.23)]. Note:  The negative number format setting in Windows 
Regional Settings is ignored. 

      Use short number 
format 

Use this option if you want to shorten numerical values to take up 
less space. For example, 1,000 can be formatted to 1k. Select which 
symbol set to use from the drop-down list. To learn more, see Short 
Number Format. 

Percentage A percentage number format, where percentage symbol and format 
pattern is culture specific. The converted number is multiplied by 
100 in order to be presented as percentage. A minus sign is always 
used for negative values. 
Examples: 
100.00 % 
- 99 % 

      Decimals Specifies the number of decimals (0-15) to display. An additional 
alternative (Auto) is also available. If you select (Auto), the number 
of decimals will be different from one number to another since 
trailing zeros will not be included. 
Examples: 

1,234.560700 (Six decimals) 
1,234.560 (Three decimals) 
1,234.56 (Two decimals) 
1,234.5607 (Auto) 

      Use thousands 
separator 

Specifies whether to use a thousands separator (digit grouping 
symbol in Windows Regional Settings) or not. The grouping 
symbol cannot be explicitly specified (only through Windows 
Regional Settings). 

Scientific A number format for scientific notation with a fixed number of 
decimals. A minus sign is always used for negative values. 
Examples: 
1.00000E+099 
5.6E-001 
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-5.6E-001 

      Decimals Specifies the number of decimals to display (0-15). 

Number A configurable number format. 
Examples: 
1234.45 
1,234.45 
-1,234.45 
(1,234.45) 

      Decimals Specifies the number of decimals (0-15) to display. An additional 
alternative (Auto) is also available. If you select (Auto), the number 
of decimals will be different from one number to another since 
trailing zeros will not be included. 
Examples: 

1,234.560700 (Six decimals) 
1,234.560 (Three decimals) 
1,234.56 (Two decimals) 
1,234.5607 (Auto) 

      Use thousands 
separator 

Specifies whether to use a thousands separator (digit grouping 
symbol in Windows Regional Settings) or not. The grouping 
symbol cannot be explicitly specified (only through Windows 
Regional Settings). 

      Negative numbers Specifies the pattern used for displaying negative numbers [-1.23 or 
(1.23)]. Note:  The negative number format setting in Windows 
Regional Settings is ignored. 

      Use short number 
format 

Use this option if you want to shorten numerical values to take up 
less space. For example, 1,000 can be formatted to 1k. Select which 
symbol set to use from the drop-down list. To learn more, see Short 
Number Format. 

Custom A highly configurable number format, which supports custom 
format specifiers (similar to Excel). 
Examples: 
(1.234E+099) 
999,999.00 Dollars 

      Format string Allows you to specify a custom format string. For details on how 
you can write these strings, see the Format String page. 

Text A text format used for strings. It cannot be configured. 

DateTime A format which can be used to display dates, times or both dates 
and times. 

      Type Allows you to select the form on which the date and/or time should 
be displayed from a predefined list (what you will see in the list is 
dependent on the locale). 
Examples: 
• Short date: 10/16/2009 
• Long date: Friday, October 16, 2009 
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• Short time: 3:25 PM 
• Long time: 3:25:55 PM 
• Short date/short time: 10/16/2009 3:25 PM 
• Short date/long time: 10/16/2009 3:25:55 PM 
• Long date/short time: Friday, October 16, 2009 3:25 PM 
• Long date/long time: Friday, October 16, 2009 3:25:55 PM 
• Month day: October 16 
• RFC1123 : Fri, 16 Oct 2009 15:25:55 GMT 
• Sortable (ISO 8601): 2009-10-16T15:25:55 
• Year month: October, 2009 

      Custom Allows you to specify a custom format string. For details on how 
you can write these strings, see the Format String page. 
Examples: 
"d" Short date pattern 
"T" Long time pattern 
"G" General date/time pattern 

Date A format which can be used to display dates. 

      Type Allows you to select the form on which the date should be 
displayed from a predefined list (what you will see in the list is 
dependent on the locale). 
Examples: 
• 10/16/2009 
• Friday, October 16, 2009 
• October 16 
• October, 2009 
• 16/Oct/09 
• 16/Oct/2009 
• 16-Oct-09 
• 16-Oct-2009 

      Custom Allows you to specify a custom format string. For details on how 
you can write these strings, see the Format String page. 

Time A format which can be used to display times. 

      Type Allows you to select the form on which the time should be 
displayed from a predefined list (what you will see in the list is 
dependent on the locale). 
Examples: 
• Short time: 8:32 AM 
• Long time: 8:32:24 AM 

      Custom Allows you to specify a custom Time format string. For details on 
how you can write these strings, see the Format String page. 

TimeSpan A format which can be used to display time spans. 

      Type Allows you to select the form on which the time span should be 
displayed from a predefined list. 
Examples: 
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• 25 d 
• 25 d 09 h 03 m 07 s 015 ms 
• 25 days 09 hours 03 minutes 07 seconds 015 milliseconds 
• 25.9:3:7:015 
• 09:03:07.015 

      Custom Allows you to specify a custom TimeSpan format string. For details 
on how you can write these strings, see the Format String page. 

Boolean A format used to display boolean data. 

      Type Allows you to select the form on which the boolean values should 
be displayed. 
Examples: 
• True / False 
• 1 / 0 

Sample Displays a sample of what a value in the column would look like 
with the current settings applied. 

6.6.3 Format String 
If the format you want to use cannot be created with the given settings, the custom format string 
allows you to create your own formats using a code explained in the examples below. 
The special characters allow you to multiply, divide, separate numbers, etc. Other characters are 
printed out in the resulting data. 

Custom Numeric Format Strings 
Special characters: 

Character Description 

0 Always returns a value for the position it is written in. If there is no 
number in its place in the data, 0 (zero) will be used. 

# Returns values if there are numbers in its place in the data. 
If used to the left of the decimal point, all digits are returned even if 
there is one # in the format string and three digits in the data. 
If used to the right of the decimal point, the same number of digits are 
returned as there are # to the right of the decimal point, and the number 
gets rounded up or down. 
See example below. 

, If used before a decimal point, divide the number in the data by 1000. 
Note: A difference from Excel is that Excel allows for "," as divider 
after the decimal point as well. 

% Multiplies the number by 100 and inserts a "%" in the number in the 
location it is written in the format string. 

. Decimal point. 
Note: If no decimal point is used and there are decimals in the value 
you apply the format string on, the value gets rounded up or down. 
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; Used to divide a format string if different formats are to be used for 
positive numbers, negative numbers and 0 (zero). 
  
If no semicolon is used, the format string is used for all numbers. 
  
If one semicolon is used, it divides the format string like this: 
String for positive numbers and zero;String for negative numbers 
  
If two semicolons are used, they divide the format string like this: 
String for positive numbers;String for negative numbers;String for 
zero 

\ If a "\" is added before a special character that character will not 
modify the number, the character will only be added to the value. 

Examples: 
Note: All these examples use the number 12345.67 as the value from the data. 

Format string Result 

# #### 1 2346 

#.# 12345.7 

#.000 12345.670 

#,.# 12.3 

#,,.## .01 

#% 1234567% 

#\% 12345.67% 

$# $12346 

#.##E+0 1.23E+4 

#.#;(#.#) 12345.7 
Note: Had the number been negative, the result would be: 
(12345.7) 

23 23 

See literature about custom numeric format strings, for example, on MSDN, for more 
information. 

Custom DateTime Format Strings 
Below are some examples of custom format strings for datetime formats. See literature about 
custom datetime format strings, such as that on MSDN, for more information. 

Character Description 

yy Returns the year, measured as a number between 0 and 99. 

yyyy Returns the year as a four-digit number. 

http://msdn2.microsoft.com/en-us/library/0c899ak8(vs.71).aspx
http://msdn.microsoft.com/en-us/library/8kb3ddd4.aspx
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M Returns the month, measured as a number between 1 and 12, with one 
or two digits depending on the value. 

MM Returns the month with two digits, measured as a number between 1 
and 12. This means that June will be written as '06', when this format 
string is applied. 

MMM Returns the abbreviated name of the month. For example, 'Jun'. 

MMMM Returns the full name of the month. For example, 'June'. 

d Returns the day of the month, measured as a number between 1 and 
31, with one or two digits depending on the value. 

dd Returns the day of the month with two digits, measured as a number 
between 1 and 31. This means that the 6th of a month will be written 
as '06', when this format string is applied. 

ddd Returns the abbreviated name of the day of the week. For example, 
'Fri'. 

dddd Returns the full name of the day of the week. For example, 'Friday'. 

h Returns the hour using a 12-hour clock, with one or two digits 
depending on the value. 

hh Returns the hour using a 12-hour clock, with two digits. This means 
that 6 o'clock will be written as '06', when this format string is applied. 

H Returns the hour using a 24-hour clock, with one or two digits 
depending on the value. 

HH Returns the hour using a 24-hour clock, with two digits. This means 
that 6 o'clock in the morning will be written as '06' and 6 o'clock in the 
evening will be written as '18', when this format string is applied. 

m Returns the minute with one or two digits, depending on the value. 

mm Returns the minute with two digits. This means that six minutes will be 
written as '06', when this format string is applied. 

s Returns the second with one or two digits, depending on the value. 

ss Returns the second with two digits. This means that six seconds will be 
written as '06', when this format string is applied. 

f Returns the tenths of a second. 

ff Returns the hundredths of a second. 

fff Returns the milliseconds. 

tt Returns the AM/PM designator. 

: Returns the time separator. 

/ Returns the date separator. 

You can also add any custom string value, but if any of the specifier characters are included in 
the string, they need to be escaped by a backslash (\). 
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Examples: 
Note: All the examples below use the following value from the data: Friday, October 16, 2009, 
at 25 minutes past three in the afternoon. 

Format string Result 

dd\t\h o\f MMMM 
yyyy 

16th of October 2009 

MMM d yyyy, 
HH:mm 

Oct 16 2009, 15:25 

\year: YY, 
\mon\t\h: MM, 
\da\y: dd 

year: 09, month: 10, day: 16 

hh:mm tt 03:25 PM 

m \minu\te\s pa\s\t 
h, MMM d 

25 minutes past 3, Oct 16 

Custom TimeSpan Format Strings 
There are five different data values included in the TimeSpan format: day, hour, minute, second 
and fractions of seconds. These can be combined to a suitable format using a format string built 
by the following specifier characters: 

Character Description 

d Returns the number of days. 

h Returns the number of hours with one or two digits, depending on the 
value. 

hh Returns the number of hours with two digits. This means that six hours 
will be written as '06', when this format string is applied. 

m Returns the number of minutes with one or two digits, depending on 
the value. 

mm Returns the number of minutes with two digits. This means that six 
minutes will be written as '06', when this format string is applied. 

s Returns the number of seconds with one or two digits, depending on 
the value. 

ss Returns the number of seconds with two digits. This means that six 
seconds will be written as '06', when this format string is applied. 

f Returns the fractions of seconds. You can also add a number between 
1 and 3 after the 'f', defining how many decimals will be shown. If no 
number has been specified, three numbers will be shown, if available. 

Between each specifier character, you need to supply some kind of separator. This could be a 
custom string value, but if any of the specifier characters are included in the string, they need to 
be escaped by a backslash (\). You can also include an initial and a conclusive string. 
 
Examples: 
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Note: All the examples below use the following value from the data:  -5 days, 7 hours, 11 
minutes 3.1234 seconds. 

Format string Result 

d.h:m:s.f -5.7:11:3.123 

d.hh:mm:ss.f2 5.07:11:03.12 

Ti\me\span i\s d 
\day\s 

Timespan is -5 days 

d \day\s h \hour\s 
m \minute\s s 
\secon\d\s 

-5 days 7 hours 11 minutes 3 seconds 

f s m h d 123 3 11 7 -5 

6.6.4 Short Number Format 
If the values on an axis or a column are numerical, you can choose to display them in short 
number format. This means that values with many digits can be shortened to take up less space. 
For example, by using short number format you can set the number 1,000 to be displayed as 1k. 
A standard symbol set is already defined and available to use. The defined symbols in the 
standard symbol set are M for 10^6, and k for 10^3. You cannot delete or change the standard 
symbol set. However, you can add your own symbol sets and define symbols of your choice. 
As with other formatting settings, you can apply short number formatting in different ways and 
on different levels. For general information about formatting, see Formatting Overview. 

► To add a symbol set 
1. Open the Axis Formatting page in the Tools > Options dialog. 
2. Click on the Edit Symbol Sets... button. 
3. Click on the Add...  button in the upper part of the dialog. 
4. Type a name to use for the symbol set in the text field and click OK. 

Response: The new symbol set is added to the drop-down list. 
5. Click on the Add... button next to the Defined symbols list to add symbols to the 

symbol set. 
6. Enter an exponent and a symbol to replace it with. 

Response: The new Symbol is added to the list of Defined symbols. 

6.7 Error Bars 
Error bars are used to indicate the estimated error in a measurement. In other words, an error bar 
indicates the uncertainty in a value. 
In Spotfire, you can use error bars in bar charts, line charts, and scatter plots. Bar charts and line 
charts can display vertical errors. Scatter plots can display both vertical and horizontal errors. 
The image below shows all four possible error bars on a scatter plot marker. However, upper 
and lower errors refer to the underlying data. This means that if you use reversed scales in a 
visualization, or change orientation of the bars in a bar chart, the error bars will also be reversed 
or change orientation respectively. For example, for a scatter plot with a reversed Y-axis, an 
upper vertical error will be displayed below the marker instead of above the marker. For a bar 
chart with horizontal bars and non-reversed scale, an upper horizontal error will be displayed to 
the right of the bar. 



TIBCO Spotfire 4.0.2 - User's Manual 

766 

 
You can choose to show only one of the error bars, or any combination of them. 
The length of an error bar indicates the uncertainty of the value. For example, for an average 
value, a long error bar means that the concentration of the values the average was calculated on 
is low, and thus that the average value is uncertain. Conversely, a short error bar means that the 
concentration of values is high, and thus, that the average value is more certain. 
There are two different ways to set up error bars in Spotfire. For aggregated values, you can use 
one of the existing measures, such as standard error or standard deviation. The length of the 
error bars will then be calculated in Spotfire. In the example below, a bar chart shows the 
average sales for each month during one year. The statistical measure standard error was used to 
calculate the length of the upper error bars. No lower error bars were defined in this graph. 

 
The other way to define error bars is to use the values in existing data table columns. You may, 
for example, have a data table where average values and error values have already been 
calculated, as in the table below. You can then use these columns to set up the error bars. In the 
scatter plot below, the Y-axis represents the column Average, and the upper and lower errors 
represent the two columns Upper Error and Lower Error respectively. 

               
By default, error bars are drawn relative to the marker position in the visualization, but for some 
measures this may not be what you want to display. Custom expressions could be helpful in 
those cases. 
For example, if a marker represents an aggregated value such as sales average, you may want to 
display the maximum and minimum values as error bars. However, if you select the measure 
Min for the lower error, and the measure Max for the upper error, the error bars will not show 
the minimum and maximum values, since the bars are shown relative to the marker position. 
Instead, the upper error shows the average plus the maximum value, and the lower error shows 
the average minus the minimum value. To display the absolute minimum and maximum values, 
you need to use a custom expression. In this case the custom expression for the upper error 
should be Max([Sales])-Avg([Sales]), and for the lower error Avg([Sales])- Min([Sales]). 
To learn more about using custom expressions, see Custom Expressions Introduction. 
See one of the following sections to learn how to set up error bars for different visualization 
types: To add error bars to the bar chart, To add error bars to the line chart, or To add error bars 
to the scatter plot. 
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7 Pages and Layout 
7.1 Visualization Layout 

You can insert several visualizations on a page. Each new visualization will be inserted at the 
top of the page. 
Often you will want to adjust the layout of the visualizations, as you might want some to be 
larger than others, or some visualization to be placed beside another instead of above it. 

► To resize visualizations: 
1. Position the mouse pointer between the visualizations you want to resize. 
2. Response: The mouse pointer changes appearance to . 
3. Click and drag the mouse to resize the visualizations. 

Note: If the visualization becomes too small in either direction, controls such as the legend, 
zoom sliders, axis selectors, etc., are hidden and cannot be viewed until the size of the 
visualization is increased. 

Moving visualizations 
You can also change the layout of the visualizations using a drag-and-drop operation. Click on a 
visualization title and drag the mouse over another visualization. A shaded box will appear over 
a part of that visualization, and when you release the mouse the layout will be updated as shown 
below. 

► To place a visualization beside another: 
Click on the title of the bar chart and drag it onto the scatter plot. Drag it to the right side of the 
scatter plot and a shaded area will indicate that by dropping the bar chart, it will be placed to the 
right of the scatter plot. Release the mouse, and the bar chart will be placed to the right of the 
scatter plot. All the visualizations will automatically adjust to fill the entire window. 

 

► To place a visualization below another: 
Click on the title of the scatter plot and drag it onto the bar chart. Drag it to the bottom part of 
the bar chart and a shaded area will indicate that by dropping the scatter plot, it will be placed 
below the bar chart. Release the mouse, and the scatter plot will be placed below the bar chart. 
All the visualizations will automatically adjust to fill the entire window. 

 

► To switch places between two visualizations: 
Click on the title of the bar chart and drag it onto the line chart. Drag it to the center of the line 
chart and a shaded area will cover the entire line chart, indicating that by dropping the bar chart, 
the visualizations will switch places. Release the mouse, and the visualizations will switch 
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places. The window layout will stay the same since the switched visualizations take each other's 
size and position. 

 
Tip: If the title bar of a visualization has been hidden, it can be shown by right-clicking on the 
visualization and selecting Properties. On the General page, select the Show title bar check 
box. 

7.2 Arranging Visualizations 
Apart from positioning the visualizations on a page using a drag-and-drop operation, there are 
some shortcuts to apply a basic layout. 

► To arrange visualizations: 
Select View > Arrange Visualizations > ...  or click on one of the corresponding buttons on the 
toolbar. 

 

Arrange Evenly Arranges the visualizations as evenly as possible. 

 

Arrange Side-
by-side 

Arranges the visualizations side by side. 

 

Arrange 
Stacked 

Arranges the visualizations stacked on top of each other. 

 

Maximize 
Active 

Makes the active visualization as large as possible, and 
minimizes all other visualizations which are placed as 
thumbnails at the bottom of the page. 

Tip: Use Maximize Active and drag to switch visualizations in order to view one visualization 
at a time. 

7.3 Pages 
You can work with several pages in your analysis if you want to keep information about 
different topics separated, or if you simply need more space. Navigation between pages can be 
done using three different modes; titled tabs, step-by-step, or history arrows, as described 
below. 

► To add a new page to the document: 

1. Click on the New Page button on the toolbar, . 
Comment: You can also select Insert > New Page from the menu. 
Note: New pages can only be added in tab mode. 
Comment: When a new page is added, the filtering scheme and organize filters settings 
are inherited from the active page. 

Titled Tabs 
In tab mode, pages are indicated by tabs at the top of the screen, and clicking on these tabs 
switches page. You can also click on the small arrow icon to the right of the tabs to open a drop-
down list where you can switch between all pages in the analysis. Tab mode is useful when you 
want to see the titles of each page and choose in what order to look at the pages.  
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On each page, you can insert one or many visualizations, and arrange these as you like. Perhaps 
you want to see both a table and a bar chart next to each other on one page to compare details, 
and then be able to switch pages to see a pie chart. When in tab mode, you can change the order 
of your pages using drag-and-drop. 

► To change page title: 
1. Right-click on a page tab. 
2. Select Rename Page... from the pop-up menu. 
3. Type a new name for the page. 
4. Click OK. 

Step-by-Step 
You can also select to show the pages as numeric links instead of tabs. This is called Step-by-
Step mode. Step-by-Step mode is useful when the order of the pages is important and you want 
to present your analysis as a guided flow. 

 
The pages are now reached by clicking on the numbered links or the Previous/Next links. This 
is useful if you want to create a guided analysis and share it with other colleagues, and you 
intend for your colleagues to go through the analysis in a certain order. 

History arrows 
If you want to set up your own navigation in the analysis you can select Page Navigation > 
History Arrows. This will give you a similar look as in the step-by-step case, but all links will 
be hidden. 

 
When this option is selected you can keep pages in the analysis that are not shown to Web 
Player users at all. All connections between the available pages must then be separately 
specified using actions in the text area or on dynamic items in graphical tables. The page history 
arrows to the left of the page name makes it possible to return to a previously visited page. 

► To change the page navigation mode: 
1. Right-click in the area containing the tabs or links. 
2. Select Page Navigation > Step-by-Step or Titled Tabs or History Arrows from the 

pop-up menu. 
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Filtering in different pages 
You can specify whether or not filtering on one page will affect the visualizations on a different 
page by using the same or different filtering schemes on the pages. You can also specify which 
filters will be visible on each page using the Organize Filters dialog. The filtering scheme of 
new pages is inherited from the active page, but it can be changed by displaying the filtering 
scheme menu in the Filters panel. 

Showing and hiding panels 
The visibility of all panels such as the filters panel, and the bookmarks panel is controlled per 
page. For each page, you can switch on or off the panels of interest by clicking on their 
corresponding toolbar button (and clicking Dock if the panel is in popover mode) or by 
selecting it from the View menu. The panel visibility of new pages is inherited from the active 
page. 

7.4 Cover Page 
7.4.1 Cover Page 

The cover page is a page meant to serve as an introduction to your analysis. It contains a text 
area in which you can enter information about the purpose of your analysis as well as other 
useful information, before you share your analysis with your colleagues. If desired, it can 
be automatically created each time you make a new document, see below. If you are creating a 
guided analysis in step-by-step mode, and have selected to use a cover page, this should be the 
first page in the sequence of links. 

 

► To change whether or not to create a cover page in new 
documents: 
1. Select Tools > Options.... 
2. Go to the Document page. 
3. Clear or select the Create cover page for new analysis check box. 

► To edit text in the cover page: 
1. Right-click in the cover page. 
2. Select Edit from the pop-up menu. 
3. Type text in the text area. 
4. Right-click and select Edit again, to leave the edit mode. 

► To change the cover page name: 
1. Right-click on the Cover Page tab. 
2. Select Rename Page... from the pop-up menu. 
3. Type a new name for the cover page. 
4. Click OK. 



Pages and Layout 

771 

7.4.2 Text Area Edit Mode 
The text area can only be edited when the Toggle Edit Mode button, , in the visualization 
title bar has been clicked, or, when Edit Text Area has been selected from the pop-up menu. 
When in edit mode, you will see a toolbar at the top of the text area where a number of options 
are available: 

Option Description 

 

Cuts the selected object from the current position, to be pasted 
somewhere else. 

 

Copies the selected object. 

 

Pastes the selected object in the text area. 

Font Specifies the font of the text. 

Size Specifies the font size of the text. 

 

Sets the selected text to boldface. 

 

Sets the selected text to italics. 

 

Underlines the selected text. 

 

Opens the Color dialog where you can specify the text color. 

 

Aligns the selected paragraph to the left of the text area. 

 

Aligns the selected paragraph to the center of the text area. 

 

Align the selected paragraph to the right of the text area. 

 

Creates a numbered list of the selected paragraph. 

 

Creates a bulleted list of the selected paragraph. 

 

Removes the indent characters from the selected text. 

 

Indents the text of the selected paragraph. 

 

Opens a dialog where you can browse to locate an image to insert. 
Including images can be very costly to memory, so it is recommended to 
keep images small. 

 

Opens the Insert Web Link dialog where you can type or paste the link to 
any website which might be of interest for the analysis. 
You can also use this button to add a mailto link opening a new message 
in your standard email client, or a tibcospotfire link which links to a 
different analysis. 
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Examples: 
http://www.tibco.com 
mailto:person@example.com?subject=Test 
tibcospotfire:server:http\://myspotfireserver/:analysis:/Data/My Analysis 

 

Removes the web link but leaves the text intact. 

 

Opens the Insert  Filter dialog where you can select a filter to add to the 
text area. 

 

Opens the Action Control dialog where you can insert an action link or 
button which applies a bookmark, switches page or runs a script, etc. 

 

Opens the Property Control dialog where you can insert input fields, 
drop-down lists, list boxes, etc., which can easily change the values of 
custom properties. 

 

Allows you to insert a dynamic item (a sparkline, a calculated value or 
an icon) into the text area. 

To change the name of the Text Area, or to show or hide the title bar, right-click on the text area 
and select Properties. 

7.5 Details-on-Demand 
7.5.1 What is the Details-on-Demand? 

The Details-on-Demand display the actual values of marked items in the active visualization. If 
you mark a bar in a bar chart, all the rows of data included in that bar are presented. Marking a 
record in a scatter plot might only display information about a single row of data. 
You can view and manage Details-on-Demand in a popover, in a docked panel, or as a floating 

window. Click on the Details-on-Demand button, , on the toolbar, or select View > Details-
on-Demand to open Details-on-Demand. They will open in the mode they were opened last 
time you had them open. The image below shows the Bookmarks popover with three added 
bookmarks. 
The Details-on-Demand works just like any other table—you can click on column headings to 
sort the presented details, drag and drop column headings to change the order, and change the 
width of the columns by moving the mouse over the column separator line and dragging. 
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If more than one data table is available within the analysis, a color stripe showing the relations 
color for the active data table is shown on the right hand side of the Details-on-Demand.  
Note: For analyses with multiple data tables, settings for the Details-on-Demand must be 
defined in the Details-on-Demand properties dialog for each data table. 

7.5.2 Details-on-Demand Properties 

7.5.2.1 Details-on-Demand Properties 
The Details-on-Demand Properties dialog consists of several pages: 

• Appearance 
• Fonts 
• Columns 
• Virtual Columns 
• Sorting 

► To reach the Details-on-Demand Properties dialog: 
1. Right-click on the Details-on-Demand. 
2. Select Properties from the pop-up menu. 

Note: For analyses with multiple data tables, settings for the Details-on-Demand must be 
defined in the Details-on-Demand properties dialog for each data table. 
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7.5.2.2 Details-on-Demand Properties - Appearance 

 

Option Description 

Header row height 
(number of lines) 

Specifies the height of the header row in number of lines. 

Data row height 
(number of lines) 

Specifies the height of all data rows in number of lines. 

Number of frozen 
columns 

Specifies how many columns on the left-hand side will be frozen, that 
is, not scroll out of sight when the scroll bar is moved to the right. 

Show cell borders Specifies whether or not cell borders should be visible between the 
cells in the table. 

Allow table data 
export in Web 
Player 

Specifies whether or not Web Player users should be able to export 
data from the Details-on-Demand table. If you do not have the 
appropriate license you cannot change this setting. Contact your 
Spotfire administrator if you have questions regarding licenses. 

Column 
orientation 

Specifies whether the columns should be displayed side-by-side 
(Vertical) in the Details-on-Demand or stacked (Horizontal), so that 
each column forms a row in the Details-on-Demand. The Automatic 
option will display the result vertically ("stacked") if a single row is 
marked, otherwise the columns are oriented side-by-side. 
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7.5.2.3 Details-on-Demand Properties - Fonts 

 

Option Description 

Settings for Lists all items for which you can change the font settings. Click to 
select an item in the list to change the font settings for that text in the 
visualization. Press Ctrl and click on more items to change the settings 
for multiple items simultaneously. 

Font Specifies the font to use for the selected items. 

Font style Specifies the font style to use for the selected items. 

Size Specifies the font size to use for the selected items. 
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7.5.2.4 Details-on-Demand Properties - Columns 

 

Option Description 

Available columns Lists all columns in the data table available for selection. 

[Type to search] Type a search string to limit the number of items in the Available 
columns list. It is possible to use the wildcard character * in the search. 
See Searching in TIBCO Spotfire for more information. 

Selected columns Lists the columns selected to be displayed in the table, as well as the 
selected aggregation method used on each column (if any aggregation 
has been specified). 

Add > Adds the columns selected in the Available columns list to the 
Selected columns list. 

< Remove Removes the selected columns from the Selected columns list and 
sends them back to the Available columns list. 

Remove All Removes all columns from the Selected columns list. 

Move Up Moves the selected column up in the Selected columns list. The order 
of the columns in this list determines the order of the Y-axes in the 
table. 

Move Down Moves the selected column down in the Selected columns list. The 
order of the columns in this list determines the order of the Y-axes in 
the table. 

Renderer Lists the available renderers for the chosen column. 

Settings... Opens the settings dialog for the chosen renderer. 
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Add new columns 
automatically 

Select the check box to make sure that any new columns added to the 
selected data table are also automatically added to the Details-on-
Demand table. 
New columns can appear when refreshing an information link, 
calculating new columns, etc. 

7.5.2.5 Details-on-Demand Properties - Virtual Columns 

 

Option Description 

Available virtual 
columns 

Lists the available virtual columns. 

Add Lets you add virtual columns. 

Edit... Opens the edit dialog for the chosen virtual column. 

Remove Removes the chosen virtual column. 

Display name Type the name to be displayed for the chosen virtual column. 
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7.5.2.6 Details-on-Demand Properties - Sorting 

 

Option Description 

Sort by Specifies the primary column you wish to sort the rows by. 

Then by Specifies the secondary and tertiary columns you wish to sort the rows 
by. 

Ascending Sorts the rows from the lowest to the highest value in the selected 
column. 

Descending Sorts the rows from the highest to the lowest value in the selected 
column. 

Note: You cannot sort by a virtual column. 

7.6 Document Properties 
7.6.1 How to Edit Document Properties 

The dialog found under Edit > Document Properties contains settings that apply to the entire 
document. However, settings that affect the visualizations are found in the Properties dialog for 
a specific visualization. These dialogs are reached by clicking on the visualization of interest to 
make it active, and then selecting Edit > Visualization Properties. 
The Document Properties dialog is divided into a number of different tabs. A number of 
common procedures are listed for each tab below. 
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General 

► To update the description or keywords for an analysis: 
1. Select Edit > Document Properties. 
2. On the General tab, make the desired changes in the Description or Keywords field. 

Comment: Keywords can be used to used to enhance organization and search 
capabilities in the library. Multiple keywords are separated by semicolons.  

3. Click OK. 

► To change the page navigation: 
1. Select Edit > Document Properties. 
2. On the General tab, select whether to use Titled tabs or Step-by-step navigation, or 

to remove the page navigation controls by selecting None. 
Comment: Titled tabs will show all pages as separate tabs, which can be dragged and 
dropped to change the order of pages. Step-by-step will show pages as numbered links 
to support a specific flow throughout the analysis. Use None if you want to define your 
own page navigation using actions in text areas.  

3. Click OK. 
Response: The layout is updated. 

► To specify a particular visualization area size: 
If you are preparing an analysis for a different platform than the one you are currently using, 
you may want to lock the visualization area to a specific size. 

1. Select Edit > Document Properties. 
2. On the General tab, select the desired size under Visualization area size. 

Comment: If the desired size is not available, use the Custom size... option to specify 
an exact size in pixels. To find out the current visualization area size for a device, see 
below. An administrator can store specific sizes in the preferences to have them show 
up like any other presets in the Visualization area size drop-down list, see below. 

3. Click OK. 

► To find out the currently available visualization area size in 
TIBCO Spotfire: 

If you know that you are going to present an analysis using a particular equipment (for example, 
a large screen in a conference room) you can look up the current visualization area size on that 
device and then design your analysis so that it is optimized for that particular screen size.  

1. On the device to use, open the analysis in TIBCO Spotfire. 
2. Select Help > Support Diagnostics and Logging. 
3. Go to the Diagnostic Information tab 
4. Look at the Visualization Area Size. 

► To find out the currently available visualization area size in Web 
Player: 

You can optimize the analysis for usage in TIBCO Spotfire Web Player. For example, you may 
be designing a Web Player based dashboard to be viewed by end users with identical tablet 
devices (and identically configured web browsers). 

1. On the device to use, open the analysis in TIBCO Spotfire Web Player. 
2. Click on the arrow at the top right corner of the application, . 

Response: The Web Player menu is displayed. 
3. Select Other Tools > Current Visualization Area Size. 
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Comment: Note that the current visualization area size is dependant on what browser 
and which toolbars and items are shown in the browser, so make sure that you are 
using the same settings as will be used in the presentation. 

4. Click Close. 

► To store a fixed size configuration in the preferences: 
If you have administrative rights you can store a specific size in the preferences to have it show 
up like any other presets in the Visualization area size drop-down list of the Document 
Properties dialog. 

1. Select Tools >  Administration Manager. 
2. Go to the Preferences tab. 
3. In the Selected group list, click on the group for which to set the preferences. 
4. In the Preferences list to the right, click on the plus sign next to Application to expand 

the group. 
5. Click on ApplicationPreferences. 
6. Click Edit. 
7. Click Fixed Visualization Area Sizes. 

Response: A small button is displayed to the right of the preference. 
8. Click on the button. 

Response: The String Collector Editor is displayed. 
9. Enter the desired fixed size configurations and click OK. 

Library 

► To view the URL for an analysis in the library: 
1. Select Edit > Document Properties. 
2. Go to the Library tab. 
3. Look at the Library URL or Web Player URL field. 
4. Click OK. 

► To determine who gets to add bookmarks for an analysis: 
The creator of an analysis can specify the folder permissions required to add bookmarks in the 
Document Properties dialog.  

1. Select Edit > Document Properties. 
2. Go to the Library tab. 
3. Select an option in the Allow users to add new bookmarks drop-down list, or clear 

the check box to disable bookmarks for the analysis. 
Comment: See Details on Document Properties - Library for more information about 
the various options. 

4. Click OK. 

► To manually specify a preview image for an analysis: 
1. Select Edit > Document Properties. 
2. Go to the Library tab. 
3. Under Select preview image, select Manually. 
4. Click Browse.... 
5. Locate the image to use and click Open. 

Comment: Switching back to Automatically will change the preview image to a 
snapshot of the active page when saving to the library. Select (No preview) if you do 
not want to show a preview. 

6. Click OK. 
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Markings 

► To change the color of marked items: 
1. Select Edit > Document Properties. 
2. Go to the Markings tab. 
3. Click to select the marking color you wish to change under Available markings. 
4. Click Edit.... 
5. Change color using the drop-down list. 
6. Click OK twice. 

Response: The color of marked items is updated in all visualizations that use the 
selected marking. 
Comment: See Marking in Visualizations for more information about how you can use 
several different markings in your analysis. 

► To add a new marking: 
Sometimes, you want to be able to mark items in one visualization without changing the 
marking in the other visualizations. This is especially useful when you have more than one data 
table in the document, or, when you create details visualizations. See Marking in Visualizations 
for more information. 

1. Select Edit > Document Properties. 
Comment: You can also define new markings from the Data page of any Visualization 
Properties dialog. 
Go to the Markings tab. 

2. Click on the New... button next to the Available markings list. 
3. Specify a Color for the new marking. 
4. Specify a Name. 
5. Click OK twice. 

► To change the default marking: 
1. Select Edit > Document Properties. 
2. Go to the Markings tab. 
3. Click on the marking that you want to use as default. 
4. Click on the Set as Default button below the Available markings list. 
5. Click OK. 

Filtering Schemes 

► To show the filtering scheme menu in Filters panel: 
Sometimes, you want to be able to filter items in one visualization without changing the 
filtering in the other visualizations. By showing the filtering scheme menu in the Filters panel 
you can easily change which filtering scheme to modify. See Filtering Schemes for more 
information. 

1. Select Edit > Document Properties. 
2. Go to the Filtering Schemes tab. 
3. Select the Show filtering scheme menu in Filters panel check box. 

► To create a new filtering scheme: 
Sometimes, you want to be able to filter items in one visualization without changing the 
filtering in the other visualizations. Then it may be useful to add more than one filtering scheme 
to the analysis. See Filtering Schemes for more information. 

1. Select Edit > Document Properties. 
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2. Go to the Filtering Schemes tab. 
3. Click New.... 
4. Type a name and click OK. 

► To change the filtering scheme to use on a page: 
If you want to use different filtering schemes on different pages, an easy way to switch filtering 
schemes is to show the filtering scheme menu in the filters panel, as described below. If you 
want one or two visualizations to use a different filtering scheme only, then this can be specified 
on the Data  page of the Visualization Properties dialog. 

1. Make sure that the filtering scheme menu is visible at the top of the filters panel. 
Comment: If the filtering scheme menu has been hidden, it can be shown by selecting 
Edit > Document Properties > Filtering Schemes tab and the check box Show filtering 
scheme menu in Filters panel. 

2. Click on the filtering scheme menu. 
3. Select the desired filtering scheme. 

► To rename a filtering scheme: 
1. Select Edit > Document Properties. 
2. Go to the Filtering Schemes tab. 
3. Click to select the filtering scheme to rename in the list. 
4. Click Rename.... 
5. Type a name and click OK. 

Data Functions 

► To refresh a data function: 
If you have inserted a data function in your analysis and the underlying data has been changed 
you can update the calculation without needing to insert the data function again. 

1. Select Edit > Document Properties. 
2. Go to the Data Function tab. 
3. Click on the data function of interest. 
4. Click Refresh. 
5. Click OK. 

► To sync a data function with the library: 
If a newer version of the data function in the document is available in the library you can click 
sync to update the data function. 

1. Select Edit > Document Properties. 
2. Go to the Data Function tab. 
3. Click on the data function of interest. 
4. Click Sync. 
5. Click OK. 

Properties 

► To create a new document property: 
Document properties can be used inside expressions controlling the visualizations. See Using 
Properties in the Analysis for more information.  

1. Select Edit > Document Properties. 
2. Go to the Data Function tab. 
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3. Click on the data function of interest. 
4. Click Refresh. 
5. Click OK. 

7.6.2 Details on Document Properties - General 
The General tab of the Document Properties dialog is where you can add a description of the 
analysis and keywords to describe the content of the analysis. You can also specify what kind of 
page navigation to use in the analysis. 

► To reach the Document Properties dialog: 
1. Select Edit > Document Properties. 
2. Click on the General tab. 

General Tab 

 

Option Description 

Description An optional description of the analysis. The description could contain 
detailed information about the analysis enabling quick overviews. 

Keywords 
(separated by 
semicolons) 

Keywords specific to the content of the analysis. Keywords are 
separated by semicolons. This means that if you write "sales 
representatives; cost" it will be interpreted as two keywords, "sales 
representatives" and "cost". 
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Keywords are used to enhance organization and search capabilities. 

Page navigation Determines which type of page navigation to use in the analysis. See 
Pages to learn more about the different navigation modes. You can 
change the default page navigation for all new analyses on the 
Document page in the Tools > Options dialog. 

   Titled tabs Shows all pages as separate tabs, which can be dragged and dropped to 
change the order of the pages.  

   Step-by-step Shows all pages as numbered links to support a specific flow 
throughout the analysis.  

   History arrows Hides the page navigation, except for the page history arrows. Use this 
mode if you want to create your own flow throughout the analysis, by 
adding actions directly on the pages.  

Visualization area 
size 

Determines the size of the area where visualizations are shown. Use 
Fit to window to automatically resize the visualization area after the 
current size of the Spotfire window.  
If you are preparing an analysis for a different platform than the one 
you are currently using, you may want to lock the visualization area to 
a specific size. For example, use iPad Landscape or iPad Portrait to 
reduce the available visualization area size for each page and optimize 
the analysis for that platform.  
An administrator can Preferences > [Group] > Application > 
ApplicationPreferences > Fixed Visualization Area Sizes. 
Tip: When Custom size... is selected the current visualization area size 
is shown by default, if no other custom sizes have been used 
previously. 
Tip: The visualization area size is persisted in bookmarks so a set of 
bookmarks with different layouts can be used to switch between 
different area sizes. 

Show tooltips as 
black text on light 
background 

Select the check box if you want to display tooltips as black text on a 
light background rather than the default white text on black 
background. 

Auto-hide scroll 
bars in table 
visualizations 

Select the check box if you want scroll bars in tabular visualizations to 
be displayed only on mouse-over. If you clear the check box, then 
scroll bars will always be shown in tabular visualizations where some 
of the content does not fit on screen. 

7.6.3 Details on Document Properties - Library 
The Library tab of the Document Properties dialog is where you handle settings for how the 
document should behave in the library. This is also where you can copy links to the analysis to 
be used in other analyses, or to be provided to other people using e-mails or  

► To reach the Document Properties dialog: 
1. Select Edit > Document Properties. 
2. Click on the Library tab. 
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Library Tab 

 

Option Description 

Library URL If the analysis has been saved in the library, this URL allows you to 
open the file in TIBCO Spotfire. Copy the URL to send the link to a 
colleague. 

Web Player URL If the analysis has been saved in the library and Spotfire Web Player 
has been set up, this URL allows you to open the analysis in the Web 
Player. Copy the URL to send the link to a colleague. 

Remember 
personalized view 
for each Web 
Player user 

Select this check box if you want to allow users to continue where they 
left off from one time to another when working on the analysis in the 
Web Player. For example, a user can open the analysis in the Web 
Player, change the view (by filtering out some data, for instance), close 
the analysis, and then open the analysis again with the same filter 
settings. 
Note: To make sure this works completely, it is necessary to define 
key columns for all the data tables in the analysis even if they are 
embedded. 

Allow users to add 
new bookmarks  

The ability to add and modify bookmarks can be restricted on two 
levels: the user licenses and the property settings on an analysis level. 
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This check box determines the analysis level settings based on the 
users' library folder permissions. 
Clear the check box if you do not want anyone to be able to add 
bookmarks to the analysis. 
Select the check box to allow some or all users to add bookmarks and 
specify the permitted level using the drop-down list: 
Private bookmarks only (all users) – allows all users to add private 
bookmarks but no public bookmarks are allowed. 
Private (all users), public (write permissions needed) – allows all 
users to add private bookmarks but only users with Modify folder 
permissions or higher will be able to make bookmarks public. 
Private and public bookmarks (write permissions needed) – allows 
only users with Modify folder permissions or higher to add any 
bookmarks. 
Private and public bookmarks (all users) – allows all users to add 
both private and public bookmarks. 

Select preview 
image 

Select whether or not to show a preview image for this analysis when 
browsing for analyses in the library.  
Automatically - sets the preview image to a snapshot of the active 
page when saving the analysis to the library. 
Manually - allows you to manually select a previously saved image. 
(No preview) - use this option to prevent any preview image from 
being shown in the library. 

Browse... When Select preview image has been set to Manually you can browse 
for an image to use in the preview. 

Current preview 
image 

Displays the currently selected preview image. If Select preview image 
has been set to Automatically and the analysis has not yet been saved 
to the library, then no preview will be visible. However, once saved to 
the library the active page when saving will be used as a preview 
image. 

7.6.4 Details on Document Properties - Markings 
The Markings tab of the Document Properties dialog is where you specify which data table and 
marking to use as default when new visualizations are created. You can also add, edit or remove 
markings. 

► To reach the Document Properties dialog: 
1. Select Edit > Document Properties. 
2. Click on the Markings tab. 
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Markings Tab 

 

Option Description 

Available 
markings 

Lists all markings available in the document. A marking is what 
specifies the color of marked items from one or more data tables. 

New... Opens a dialog where you can specify the name and color of the new 
marking. 

Edit... Opens a dialog where you can change the name and color of the 
selected marking. 

Delete Deletes the selected marking. If any visualizations use the deleted 
marking, they will be set to not allow marking. This can be changed on 
the Data page of the Visualization Properties dialog for each 
visualization concerned. 

Set as Default Sets the selected marking to be the default marking, that is, the 
marking that is used when new visualizations are created. 
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7.6.5 Details on Document Properties - Filtering Schemes 
► To reach the Document Properties dialog: 

1. Select Edit > Document Properties. 
2. Click on the Filtering Schemes tab. 

 

Option Description 

Show filtering 
scheme menu in 
Filters panel 

Select this check box to show the filtering scheme menu in the filters 
panel. You need to display this menu if you are to change the filtering 
scheme used on a page. However, when sending the finished document 
to a coworker for further analysis, you may want to hide the menu in 
order to save space in the filters panel and to reduce the risk of 
changing the filtering schemes by mistake. 

Available filtering 
schemes 

Lists all filtering schemes that have been defined in the document. 

New... Opens a dialog where you can add a new filtering scheme. 

Rename... Allows you to change the name of the selected filtering scheme. 

Delete Deletes the selected filtering scheme. 
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Note: You can create multiple different filtering schemes in the document. The filtering scheme 
can be specified per page or per visualization and it can be the same or different for different 
pages and visualizations. See Filtering Schemes for more information. 

7.6.6 Details on Document Properties - Data Functions 
Once a data function has been executed  in an analysis it will be available for editing in the Data 
Functions tab of the Document Properties dialog. This is where you can change the input and 
output handlers, or refresh the calculation if anything has changed. 

► To reach the Document Properties dialog: 
1. Select Edit > Document Properties. 
2. Click on the Data Functions tab. 

 

Option Description 

Available data 
functions 

Lists all data functions that have been used in the current analysis. 
Note that if a previously used data function has been replaced by a 
subsequent data function and all outputs from the first data function 
has been removed, then the first data function will no longer remain in 
this list. 

Edit... Opens a dialog where you can edit the input parameters of the selected 
data function. The output cannot be changed here. Execute the data 
function again if you need to change some output parameter settings. 
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Refresh Refreshes the data function calculation, so that any changes to the input 
values are reflected in the output results. 
Note: You need to click OK in the Document Properties dialog to 
actually start the data refresh. 

Sync Makes the document use an updated version of the function definition 
if a newer version is available in the library. 
Note that synchronizing is only possible for data functions that have 
been saved to the library and executed via Insert > Data Functions. The 
Sync button will be unavailable for data functions run from the 
Register Data Functions Dialog. If the analysis is expected to have a 
long life span, it is recommended to only keep saved data functions in 
the analysis, so that they can be updated. 

Delete Deletes the selected data function. 

  

7.6.7 Details on Document Properties - Properties 
On the Properties tab it is possible to specify document properties, which are applicable 
throughout the document. For example, this could be a currency rate which can be used in 
calculations on several different columns. The document properties can be used inside 
expressions, using Insert Calculated Column or Custom Expressions, or, in reference lines in 
visualizations. You can also add property controls to a text area for an easy way of changing the 
property value. See Using Properties in the Analysis for more information. 

► To reach the Document Properties dialog: 
1. Select Edit > Document Properties. 
2. Click on the Properties tab. 
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Option Description 

Property Name Lists all properties that are currently available in the document. 
MaxMissingTimeParts – Allows you to specify the maximum number 
of missing time parts that should be allowed to be replaced using the 
Compensate for missing values setting, available on the Appearance 
tab of some visualizations. See Working with Time Hierarchies for 
more information. 
If you have defined custom properties for the document, these 
properties are also listed here. 

Value Lists the values of the defined document properties. 

New... Opens a dialog where you can add new document properties to the 
document. 

Edit... Opens a dialog where you can edit the selected document property. 

Delete Deletes the selected property. 

7.6.8 Details on New/Edit Document Property 
Custom document properties can be used throughout the analysis. For example, this could be a 
currency exchange rate which can be used in calculations on several different columns. 
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Document properties can be used inside expressions, using Insert Calculated Column or Custom 
Expressions, or, in reference lines in visualizations. You can also add property controls  to a text 
area, for an easy way of changing the property value. See Using Properties in the Analysis for 
more information. 

► To reach the New Property dialog: 
1. Select Edit > Document Properties. 

Comment: The New Property dialog is also available by right-clicking in the Available 
properties list in the Insert Calculated Column and Custom Expression dialogs, as well 
as from the dialogs used when adding property controls to a text area. 

2. Click on the Properties tab. 
3. Click New.... 

 

Option Description 

Property name Specifies the name of the custom document property. 

Data type Specifies the type of the property. 

Description Optional. A description of the intended use of the property. 

Value Specifies the value of the property. 

► To reach the Edit Property dialog: 
1. Select Edit > Document Properties. 

Comment: The Edit Property dialog is also available by right-clicking in the Available 
properties list in the Insert Calculated Column and Custom Expression dialogs, as well 
as from the dialogs used when adding property controls to a text area. 

2. Click on the Properties tab. 
3. Click to select the property you wish to edit in the list of available properties. 
4. Click Edit... 
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Option Description 

Property name Specifies the name of the custom document property. 

Data type Specifies the type of the property. 

Description Optional. A description of the intended use of the property. 

Edit... Opens the Edit Value dialog where you can edit the description of the 
property. 

Value Specifies the value of the property. 

Note: The only thing you can change using Edit Property is the description and the value of the 
selected property. If other settings are wrong, you need to delete the custom property and create 
a new one instead. 

7.7 Setting Defaults 
7.7.1 How to Specify Default Values 

Sometimes, you may want to reuse settings from one time to another. For example, you may 
want to specify that the marked items color should always be red when you start TIBCO 
Spotfire, or that the default visualization should be a table. This is done in the Options dialog. 
The default values you set are also saved for your profile on the server, so your default settings 
will be available even if you are using a different computer. 
An administrator can also configure which settings should be default for certain user groups on 
the server. If you are a member of such a group, these defaults will take effect for you, unless 
you have made an active choice and set your own default value in the Options dialog. 

► To reach the Options dialog: 
1. Select Tools > Options.... 
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7.7.2 Options 

7.7.2.1 Options - Application 

  

Option Description 

Show welcome 
screen when no file 
is loaded 

Select this option to display the welcome screen when starting TIBCO 
Spotfire without a file loaded. 

Number of recent 
files in File menu 

Specifies how many of the most recently used files that should be 
shown in the File menu. 

Toolbars Select which toolbars should be visible when TIBCO Spotfire is 
started. Changes here take effect the next time TIBCO Spotfire is 
started. 

Language Select which language should be used for TIBCO Spotfire when it is 
started. This setting affects the language used in the application, but 
not in the data itself. Language settings for the data are controlled by 
the Column Properties. Changes here take effect the next time TIBCO 
Spotfire is started. 

Renderer 
Settings... 

Opens the Renderer Settings dialog that sets the default renderer for 
different content types. This is applicable when displaying links, 
images, geometries, etc. in table visualizations or as labels or tooltips. 

Animations Select this check box to enable smooth animations in the visualizations 
when data are filtered and visualizations are modified. Clear the check 
box if you experience performance problems when modifying the 
visualizations, to get a slight performance boost. This setting takes 
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effect immediately. 

Hardware 
acceleration 

Select this option to enable hardware graphics acceleration. You 
should only disable the option if you experience odd problems relating 
to graphics in TIBCO Spotfire. If disabling this option alleviates the 
problem, you may have some problems with your graphics card or its 
software drivers. Try updating these and see if you can enable 
hardware acceleration again, as this greatly improves performance of 
TIBCO Spotfire. This setting takes effect immediately. 

Anti-aliased lines 
and markers 

Only available when Hardware acceleration has been switched off. 
Select this check box to render smooth lines and markers using anti-
aliasing. Clearing the check box may increase the performance of the 
visualization rendering. 

Set as Default 
Spotfire Version 

Click on this button to make sure that Spotfire analysis files are opened 
using the current version of TIBCO Spotfire when double-clicked in 
your Windows environment or opened via links to the library. 
Registering a default version is only necessary if you are running 
several different versions of TIBCO Spotfire on your computer (e.g., a 
gold version and a beta version). 

Reset Resets all properties on this page to the default values. 
Note that an administrator can configure which settings should be 
default for certain user groups on the server. If you are a member of 
such a group, the options on this page will be set to these defaults 
when you press the Reset button. 

 

7.7.2.2 Options - Fonts 
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Option Description 

Settings for Lists all items for which you can change the font settings. Click to 
select an item in the list to change the settings for that text in the 
visualization. Press Ctrl and click on more items to change the settings 
for multiple items simultaneously. 

Font Specifies the font to use for the selected items. 

Font style Specifies the font style to use for the selected items. 

Size Specifies the font size to use for the selected items. 

Apply to 
Document... 

Opens the Apply Font Settings to Document dialog which allows you 
to update the text styles for the selected items in all visualizations on 
one or more pages at the same time. Note that this will override any 
font settings you may have made directly in a visualization. 

Reset Resets all properties on this page to the default values. 
Note that an administrator can configure which settings should be 
default for certain user groups on the server. If you are a member of 
such a group, the options on this page will be set to these defaults 
when you press the Reset button. 

7.7.2.3 Options - Document 
These settings generally take effect when you open new data and create a new document in 
TIBCO Spotfire. 

 



Pages and Layout 

797 

Option Description 

Initial visualization 
when loading data  

Select which visualization should be the default visualization to 
appear when loading new data. 
Note: When you load map data into Spotfire, the initial visualization 
is always a map chart. 

Create cover page 
for new analysis 

Select whether or not a cover page should be created by default when 
creating a new analysis. 

Filters panel open 
by default 

Select whether or not the filters panel should be open when creating a 
new analysis. 

Details-on-Demand 
open by default 

Select whether or not the Details-on-Demand should be open when 
creating a new analysis. 

List box filter size 
(number of rows 
shown) 

Type or click to the number of rows you want to display in the list 
box filter. 

Show tooltips as 
black text on light 
background 

Select the check box if you want to display tooltips as black text on a 
light background rather than the default white text on black 
background. 

Auto-hide scroll 
bars in table 
visualizations 

Select the check box if you want scroll bars in tabular visualizations 
to be displayed only on mouse-over. If you clear the check box, then 
scroll bars will always be shown in tabular visualizations where some 
of the content does not fit on screen. 

Page navigation Select whether to use Titled tabs, Step-by-step mode or no page 
navigation as default when creating a new analysis. SeePages and 
What is a Guided Analysis? to learn more about working with the 
different navigation modes. 

   Titled tabs Shows all pages as separate tabs, which can be dragged and dropped 
to change the order of the pages.  

   Step-by-step Shows all pages as numbered links to support a specific flow 
throughout the analysis. 

   History arrows Hides the page navigation, except for the page history arrows. Use 
this mode if you want to create your own flow throughout the 
analysis, by adding actions directly on the pages. 

Default marking 
color 

Select which color should be used for marked items as default. 

Reset Resets all properties on this page to the default values. 
Note that an administrator can configure which settings should be 
default for certain user groups on the server. If you are a member of 
such a group, the options on this page will be set to these defaults 
when you press the Reset button. 
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7.7.2.4 Options - Visualization 
These settings take effect when creating a new visualization. 

 

Option Description 

Visualization title 
visible by default 

Select whether or not the title bar for new visualizations should be 
visible by default. 

Visualization 
description visible by 
default 

Select whether or not the description for new visualizations should 
be visible by default. 

Gridlines visible by 
default 

Select whether or not gridlines should be visible in new 
visualizations (where applicable) by default. 

Zoom for axes Select whether zooming should be automatic or require the use of 
manual zoom sliders, when creating a new visualization. 

Tooltip format Select whether the tooltip should show "Value names and values" 
or "Visualization properties and values". Generally speaking, the 
first option means that the tooltip will show the column names and 
corresponding values for the highlighted row. The second option 
means that the tooltip will show the name of the properties (rather 
than the corresponding columns) and the values. 
Example "Value names and values": 
Product: Bananas 
Month: March 
Sales: 3300 
Example "Visualization properties and values": 
Color: Bananas 
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X: March 
Y: 3300 

Default fixed color Select which color should be used as the fixed color in all 
visualizations. 

Default categorical 
color scheme 

Select which scheme should be the default categorical color 
scheme for all visualizations. If the color scheme is categorical, 
only the colors from the color scheme will be used in the 
visualizations. No values will be matched between the color 
scheme and the visualizations. And if the selected color scheme 
contains any rules, they will not be included. 
Note: Changing the default color scheme will not affect any 
already existing visualizations. The new default scheme will only 
be used in visualizations created after the change. 

Default continuous 
color scheme 

Select which scheme should be the default continuous color 
scheme for all visualizations. If the color scheme is categorical, 
only the colors from the color scheme will be used in the 
visualizations. No values will be matched between the color 
scheme and the visualizations. And if the selected color scheme 
contains any rules, they will not be included. 
Note: Changing the default color scheme will not affect any 
already existing visualizations. The new default scheme will only 
be used in visualizations created after the change. 

Reset Resets all properties on this page to the default values. 
Note that an administrator can configure which settings should be 
default for certain user groups on the server. If you are a member 
of such a group, the options on this page will be set to these 
defaults when you press the Reset button. 

7.7.2.5 Options - Axis Formatting 
These settings take effect when creating a new visualization and affect only the axes in 
visualizations. For general information about formatting, see Formatting Overview. 
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Option Description 

Default axis 
formatting 

Defines the default settings that should be used for the axes. 
Note: Settings are applied to visualizations created after the settings 
are made. Already existing visualizations will not be affected. 

   Data type Defines which data type the formatting should be applied to. 

   Category Lists the available categories for the selected data type. Each category 
in this list has separate settings. What categories are available depends 
on the data type. See Formatting Settings for a full description of all 
possible options. 

Short number 
format 

Short number format lets you format values with many digits to take 
up less space on the axis. For example, by using short number format 
you can set 1,000 to be displayed as 1k. You can define your own sets 
of symbols to use as short number format, but a standard symbol set is 
already defined. To learn more, see Short Number Format. 

   Edit Symbol 
Sets... 

Opens a dialog where you can edit or add symbol sets to use when you 
apply short number format. 
Note: It is not possible to edit or delete the Standard symbol set. 

Reset Resets all properties, except added symbol sets, on this page to the 
default values. Symbol sets must be deleted manually by opening the 
Edit Symbol Sets dialog. 
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7.7.2.6 Options - Table 

 

Option Description 

Legend visible by 
default 

Specifies whether or not the legend should be open when creating a 
new table. 

Header row height Specifies the height of the header row in number of lines. 

Data rows height Specifies the height of all data rows in number of lines. 

Number of frozen 
columns 

Specifies the number of columns on the left-hand side to be frozen, 
that is, they will not scroll out of sight when the scroll bar is moved to 
the right. 

Show cell borders Specifies whether or not cell borders should be visible in the table. 

Allow table data 
export in Web 
Player 

Specifies whether or not a Web Player user is allowed to export the 
data from the table. 

Add new columns 
automatically 

Select the check box to change the default setting so that any new 
columns in a data table are also automatically added to table 
visualizations using that data table. 

Reset Resets all properties on this page to the default values. 
Note that an administrator can configure which settings should be 
default for certain user groups on the server. If you are a member of 
such a group, the options on this page will be set to these defaults 
when you press the Reset button. 
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7.7.2.7 Options - Cross Table 

 

Option Description 

Legend visible by 
default 

Specifies whether or not the legend should be open when creating a 
new cross table. 

Show cell borders Specifies whether or not cell borders should be visible in the cross 
table. 

Grand total for 
columns 

Specifies whether or not the sum of all values in a column should be 
displayed. 

Grand total for 
rows 

Specifies whether or not the sum of all values in a row should be 
displayed. 

Allow table data 
export in Web 
Player 

Specifies whether or not a Web Player user is allowed to export the 
data from the cross table. 

Display subtotals   

   Before values Places the subtotal values before the cell values on each level in the 
hierarchy of the vertical axis. 

   After values Places the subtotal values after the cell values on each level in the 
hierarchy of the vertical axis. 

Reset Resets all properties on this page to the default values. 
Note that an administrator can configure which settings should be 
default for certain user groups on the server. If you are a member of 
such a group, the options on this page will be set to these defaults 
when you press the Reset button. 
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7.7.2.8 Options - Graphical Table 

 

Option Description 

Legend visible by 
default 

Specifies whether or not the legend should be open when creating a 
new bar chart. 

Initial column 
when inserting 
new graphical 
table 

Specifies the default column type to show up initially when inserting a 
new graphical table visualization. 

Show   

   Header row Specifies whether or not the column headers at the top of the graphical 
table should be visible. 
Tip: If you want to show or hide a specific column header, instead of 
the entire row of headers, open the Settings dialog for the column of 
interest, go to the General page and then select or clear the check box 
Show name in header. 

   Row header 
name 

Specifies whether or not the row header name should be visible. 
This is the left-most header in the header row, displayed above the 
column containing the row headers in the graphical table. By default, 
the row header name is the name of the column on the row axis. If the 
row axis has a hierarchy of columns, then the row header name is the 
column at the lowest level in the hierarchy. 

   Cell borders Specifies whether or not cell borders should be visible in the graphical 
table. 

   Only the n first 
rows 

Select this check box if you want to display a limited number of rows 
in the graphical table. Note that the sort order in the graphical table 
affects which rows are shown. 
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Additional row 
spacing (in pixels) 

Specifies how much extra space should be added to the cells for each 
row. 

Reset Resets all properties on this page to the default values. 
Note that an administrator can configure which settings should be 
default for certain user groups on the server. If you are a member of 
such a group, the options on this page will be set to these defaults 
when you press the Reset button. 

7.7.2.9 Options - Bar Chart 

 

Option Description 

Legend visible by 
default 

Specifies whether or not the legend should be open when creating a 
new bar chart. 

Orientation Specifies whether the bars should be displayed horizontally or 
vertically by default. 

Bar width Drag the slider to modify the width of the bars. 

Label orientation Specifies whether labels should be displayed horizontally or vertically 
by default. 

Reset Resets all properties on this page to the default values. 
Note that an administrator can configure which settings should be 
default for certain user groups on the server. If you are a member of 
such a group, the options on this page will be set to these defaults 
when you press the Reset button. 
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7.7.2.10 Options - Line Chart 

 

Option Description 

Legend visible by 
default 

Specifies whether or not the legend should be open when creating a 
new line chart. 

Line width Specifies the width of the lines in the line chart. 

Show markers Determines whether or not markers should be displayed for the axis 
values. 

Marker size Increases or decreases the overall size of the markers. 

Break lines on 
empty values 

Determines whether lines should be broken or remain connected when 
an empty value is found in the data used to create the line. 

Reset Resets all properties on this page to the default values. 
Note that an administrator can configure which settings should be 
default for certain user groups on the server. If you are a member of 
such a group, the options on this page will be set to these defaults when 
you press the Reset button. 
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7.7.2.11 Options - Combination Chart 

 

Option Description 

Legend visible 
by default 

Specifies whether or not the legend should be open when creating a new 
combination chart. 

Default series 
type 

Specifies whether the default type of new series should be bars or lines. 

Bars   

   Bar width Drag the slider to modify the width of the bars. 

   Label 
orientation 

Specifies whether labels should be displayed horizontally or vertically by 
default. 

Lines   

   Line width Specifies the width of the lines in the combination chart. 

   Show line 
markers 

Determines whether or not markers should be displayed on the lines for 
the axis values. 

   Marker size Drag the slider to modify the overall size of the markers. 

   Break lines on 
empty values 

Determines whether lines should be broken or remain connected when an 
empty value is found in the data that was used to create the line. 

Reset Resets all properties on this page to the default values. 
Note that an administrator can configure which settings should be default 
for certain user groups on the server. If you are a member of such a group, 
the options on this page will be set to these defaults when you press the 
Reset button. 
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7.7.2.12 Options - Pie Chart 

 

Option Description 

Legend visible by 
default 

Specifies whether or not the legend should be open when creating a 
new pie chart. 

Sector value Displays the value of the sector as a label. For example, sum of  sales 
for apples, if the sector size is defined by sum of sales and the color is 
defined by fruit or vegetable type. 

Sector category Displays the category defining  the sector as a label. For example, 
"apples", if the sector color is defined by fruit or vegetable type. 

Sector percentage Displays labels showing the percentage of the total that each sector 
represents. 

Threshold Excludes labels whose percentage falls below a given threshold. 

Decimals Specifies the number of decimals to display for the percentage value. 
The number specified here will also affect the number of decimals 
shown for pie sectors in the tooltip. 

Reset Resets all properties on this page to the default values. 
Note that an administrator can configure which settings should be 
default for certain user groups on the server. If you are a member of 
such a group, the options on this page will be set to these defaults 
when you press the Reset button. 
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7.7.2.13 Options - Scatter Plot 

 

Option Description 

Legend visible by 
default 

Specifies whether or not the legend should be open when creating a 
new scatter plot. 

Default fixed 
shape 

Defines which shape to use for all markers as default. 

Sector value Displays the value of the sector as a label. For example, sum of sales 
for apples, if the sector size is defined by sum of sales and the color is 
defined by fruit or vegetable type. 

Sector category Displays the category defining the sector as a label. For example, 
"apples", if the sector color is defined by fruit or vegetable type. 

Sector percentage Displays labels showing the percentage of the total that each sector 
represents. 

Threshold Excludes labels whose percentage falls below a given threshold. 

Decimals Specifies the number of decimals to display for the percentage value. 
The number specified here will also affect the number of decimals 
shown for pie sectors in the tooltip. 

Reset Resets all properties on this page to the default values. 
Note that an administrator can configure which settings should be 
default for certain user groups on the server. If you are a member of 
such a group, the options on this page will be set to these defaults 
when you press the Reset button. 
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7.7.2.14 Options - 3D Scatter Plot 

 

Option Description 

Legend visible by 
default 

Specifies whether or not the legend should be open when creating a 
new 3D scatter plot. 

Show navigation 
controls 

Specifies whether or not the navigation controls should be visible when 
a new 3D scatter plot is created. 

Default fixed 
shape 

Defines which shape to use for all markers as default. 
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7.7.2.15 Options - Map Chart 

 

Option Description 

Legend visible by 
default 

Specifies whether or not the legend should be open when creating a 
new map chart. 

Show navigation 
controls 

Specifies whether or not the navigation controls should be visible when 
creating a new map chart. 

Default fixed 
shape (when 
markers are used) 

Defines which shape to use for all markers as default. 

Sector value Displays the value of the sector as a label. For example, sum of  sales 
for apples, if the sector size is defined by sum of sales and the color is 
defined by fruit or vegetable type. 

Sector category Displays the category defining the sector as a label. For example, 
"apples", if the sector color is defined by fruit or vegetable type. 

Sector percentage Displays labels showing the percentage of the total that each sector 
represents. 

Threshold Excludes labels whose percentage falls below a given threshold. 

Decimals Specifies the number of decimals to display for the percentage value. 
The number specified here will also affect the number of decimals 
shown for pie sectors in the tooltip. 

Reset Resets all properties on this page to the default values. 
Note that an administrator can configure which settings should be 
default for certain user groups on the server. If you are a member of 
such a group, the options on this page will be set to these defaults 
when you press the Reset button. 
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7.7.2.16 Options - Treemap 

 

Option Description 

Legend visible by 
default 

Specifies whether or not the legend should be open when creating a 
new treemap. 

Show hierarchy 
headers 

Specifies whether or not the hierarchy headers should be shown when 
creating a new treemap. 

Show labels Specifies whether or not labels should be displayed when a new 
treemap is created. 

Reset Resets all properties on this page to the default values. 
Note that an administrator can configure which settings should be 
default for certain user groups on the server. If you are a member of 
such a group, the options on this page will be set to these defaults when 
you press the Reset button. 
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7.7.2.17 Options - Heat Map 

 

Option Description 

Legend visible by 
default 

Specifies whether or not the legend should be open when creating a 
new heat map. 

One color scale per 
axis value 

Specifies whether or not there should be one separate color scale for 
each axis value, or if one scale should apply to the entire 
visualization when creating a new heat map. 

Dendrogram colors   

   Pruning line color Specifies the color to use for the pruning line in the dendrogram. 

   First alternating 
cluster color 

Specifies the first color to use for the clusters when pruning in the 
dendrogram. 

   Second alternating 
cluster color 

Specifies the second color to use for the clusters when pruning in the 
dendrogram. 

Reset Resets all properties on this page to the default values. 
Note that an administrator can configure which settings should be 
default for certain user groups on the server. If you are a member of 
such a group, the options on this page will be set to these defaults 
when you press the Reset button. 
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7.7.2.18 Options - Parallel Coordinate Plot 

 

Option Description 

Legend visible by 
default 

Specifies whether or not the legend should be open when creating a 
new parallel coordinate plot. 

Line width Specifies the width of the lines in the parallel coordinate plot. 

Break lines on 
empty values 

Determines whether lines should be broken or remain connected when 
an empty value is found in the data used to create the line. 

Reset Resets all properties on this page to the default values. 
Note that an administrator can configure which settings should be 
default for certain user groups on the server. If you are a member of 
such a group, the options on this page will be set to these defaults when 
you press the Reset button. 
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7.7.2.19 Options - Summary Table 

 

Option Description 

Legend visible by 
default 

Specifies whether or not the legend should be open when creating a 
new summary table. 

Show cell borders Specifies whether or not cell borders should be visible in the summary 
table. 

Allow table data 
export in Web 
Player 

Specifies whether or not a Web Player user is allowed to export the 
data from the summary table. 

Add new columns 
automatically 

Select the check box to change the default setting so that any new 
columns in a data table are also automatically added to summary table 
visualizations using that data table. 

Reset Resets all properties on this page to the default values. 
Note that an administrator can configure which settings should be 
default for certain user groups on the server. If you are a member of 
such a group, the options on this page will be set to these defaults 
when you press the Reset button. 
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7.7.2.20 Options - Box Plot 

 

Option Description 

Legend visible by 
default 

Specifies whether or not the legend should be open when creating a 
new box plot. 

Box width Specifies the width of all box plots. 

Marker size Specifies the size of all outer values. 

Show distribution Specifies whether or not the distribution of values should be shown as 
a histogram. 

Show 95% 
confidence interval 

Select the check box to display the confidence interval in the box plot 
as a black line next to the box. 

Show comparison 
circles 

Select the check box to display comparison circles in the box plot 
visualization. See What are Comparison Circles? for more information. 

Alpha level The level at which the difference between groups would be significant. 

Show cell borders 
in statistics table 

Specifies whether or not cell borders should be visible in the statistics 
table of the box plot. 

Reference Points... Opens a dialog where you can specify the shape and color of the 
reference points to show by default in the box plot. 

Statistics Table... Opens a dialog where you can specify what measures to show in the 
statistics table (if any), as well as the sorting to apply. 

Reset Resets all properties on this page to the default values. 
Note that an administrator can configure which settings should be 
default for certain user groups on the server. If you are a member of 
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such a group, the options on this page will be set to these defaults 
when you press the Reset button. 

7.7.2.21 Options - Data Functions 

 

Option Description 

TIBCO Spotfire 
Statistics Services 

  

   Default Use this option to connect to the default Spotfire Statistics Services 
server set up by the administrator. 

   Custom URL Use this option to run data functions using an alternative instance of 
Spotfire Statistics Services. For example, while you are developing 
new data functions you can use Spotfire Statistics Services Local 
Adapter to test your scripts. 
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7.7.2.22 Options - Compatibility 

 

Option Description 

Use 3.0 text area In TIBCO Spotfire 3.1, the text area was changed from its old behavior 
in order to be able to add property controls and script action controls. 
However, the function links to tools previously available in the text 
area could no longer be added to a text area. 
Select this option if you want to be able to create text areas which 
behave as they did in TIBCO Spotfire 3.0 and older. All new text areas 
within the document will then use the 3.0 style and functionality. 
Note that while this check box is selected you cannot add script action 
controls and property controls in new text areas. Clear the check box to 
create new text areas that include the 3.1 functionality. 
No text areas previously created within the document will be affected 
by the change, only the newly created ones. This means that you can 
create documents where some text areas use the old style and some use 
the new style. See also How to Use the Text Area. 

Use 3.2 bookmark 
panel 

In TIBCO Spotfire 3.3, a new version of the bookmarks functionality 
was created in order to allow the capturing of visualization properties 
along with the previously available settings for page, filtering, 
marking, etc. (See What are Bookmarks? for information about the 
new bookmarks.) However, for compatibility reasons, you can go back 
to using the 3.2 version of the bookmarks instead. 
Select this option if you want to use the bookmarks panel that was 
available in TIBCO Spotfire 3.2 and older. 
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7.7.2.23 Details 

7.7.2.23.1 Details on Renderer Settings 
The Renderer Settings dialog is used to set default values to use when displaying links, images, 
geometries, etc. in table visualizations or as labels or tooltips. 

► To reach the Renderer Settings dialog: 
1. Click Tools > Options.... 
2. Select the Application tab. 
3. Click Renderer Settings.... 

 

Option Description 

Content Type Lists the content types with a specified default renderer. 

Default Renderer Lists the default renderers associated with the different content types. 

Add... Opens the Add/Edit Default Renderer dialog, which lets you add a new 
default renderer for a content type. 

Edit... Opens the Add/Edit Default Renderer dialog, which lets you edit the 
default renderer for the selected content type. 

Remove Removes the selected default renderer. 

7.7.2.23.2 Details on Add/Edit Default Renderer 
This dialog allows you to specify a default renderer for a particular content type. 

► To reach the Add/Edit Default Renderer dialog: 
1. Click Tools > Options.... 
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2. Select the Application tab. 
3. Click Renderer Settings.... 
4. Click Add... (or click Edit... if an existing renderer is selected). 

 

Option Description 

Content type Enter the content type for which you want to add a default renderer. 
Use the form toplevel/subtype, for example, text/html or image/jpg. 
For Geometry columns the content type should be set to application/x-
wkb if you want to show the geometry information as images. 
If you are using TIBCO Spotfire Lead Discovery to display chemical 
structures from an SDFile then the content type should be set to 
chemical/x-mdl-molfile for the molfile column. 
Note: Do not use a space when specifying the content type. 

Default renderer Select a default renderer from the list. 

Settings... If applicable, opens the Settings dialog for the selected renderer: 
Link Renderer Settings 

Image from URL Renderer Settings 
Geometry Renderer Settings 

7.7.2.23.3 Details on Apply Font Settings to Document 
This dialog allows you to update multiple text styles in all visualizations on one or more pages 
at the same time. Using this dialog to adjust the fonts in the analysis will override any settings 
you may have made directly in a visualization. 

► To reach the Apply Font Settings to Document dialog: 
1. Select Tools > Options.... 
2. Go to the Fonts page. 
3. In the Settings for list, select the items for which you want to change the font settings. 
4. Adjust the Font, Font style and Size settings to your liking. 
5. Click on Apply to Document.... 
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Option Description 

Apply settings for 
selected items to 

  

   All pages Use this option to apply the new font settings on all the pages in the 
analysis. 

   Current page Use this option to apply the new font settings to the current page in the 
analysis only. 

   These pages only Use this option to apply the new font settings to selected pages in the 
analysis. Press Ctrl and click to select more that one page. 

7.7.2.23.4 Details on Edit Symbol Sets 
This dialog is used to define a new symbol set to use as a short number format. 

► To reach the Edit Symbol Sets dialog: 
1. Select Tools > Options.... 
2. Go to the Axis Formatting page. 
3. Click on Edit Symbol Sets.... 
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Option Description 

Symbol set Specifies which symbol set to edit. 

   Add... Opens a dialog where you can enter a name to use for the new symbol 
set. 

   Remove Removes the selected symbol set. 
Note: The symbol set Standard cannot be removed. 

Name Displays the name of the selected symbol set. 

   Rename... Opens a dialog where you can enter a new name to use for the symbol 
set. 

Defined symbols Lists all the symbols, and their corresponding factors, that are defined 
for the selected symbol set. The symbols are sorted by factor. 

   Add... Opens a dialog where you can define a new symbol. 

   Edit... Opens a dialog where you can edit a symbol. Click on a symbol to 
select and edit it. 

   Remove Removes the selected symbol from the list. 

7.7.2.23.5 Details on Add/Rename Symbol Set 
This dialog is used when naming a new symbol set or renaming an already existing symbol set. 

► To reach the Add Symbol Set/Rename Symbol Set dialogs: 
1. Select Tools > Options.... 
2. Go to the Axis Formatting page. 
3. Click on Edit Symbol Sets.... 
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4. Click on Add... next to the drop-down list to add a new symbol set. To rename an 
existing symbol set, select the symbol set you wish to rename from the drop-down list, 
then click on Rename.... 

 

 

Option Description 

Name Type a name to use for the symbol set. 

7.7.2.23.6 Details on Add/Edit Symbol 
These dialogs are used to define a new symbol or edit an existing symbol, to use as a short 
number format. 

► To reach the Add/Edit Symbol dialog: 
1. Select Tools > Options.... 
2. Go to the Axis Formatting page. 
3. Click on Edit Symbol Sets.... 

Response: The Edit Symbol Sets dialog is opened. 
4. In the Symbol set drop-down list, select the symbol set of interest. 

Response: The current symbols in the selected symbol set are displayed in the Defined 
symbols list. 
Comment: You cannot add symbols to or edit symbols in the Standard symbol set. 

5. To add a new symbol to the selected symbol set, click on Add... to the right of the 
Defined symbols list. To edit an existing symbol, select the symbol you wish to edit in 
the Defined symbols list, then click on Edit.... 
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Option Description 

Exponent Defines the power of 10 you want to replace with a symbol when using 
the short number formats. To replace 10^3 (1,000) with the symbol k, 
enter 3 in the field. The number 1,000 will then be displayed as 1k, and 
the number 1,250 will be displayed as 1.25k. 

Symbol Defines which symbol to replace the exponent with. 
Note: You cannot use any numerical values as symbols. 

 

7.7.2.23.7 Details on Reference Points 
This dialog is used to specify default settings for the reference points shown in new box plots. 

► To reach the Reference Points dialog: 
1. Select Tools > Options.... 
2. Go to the Box Plot page. 
3. Click on Reference Points.... 
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Option Description 

Show real data 
points in box plot 

  

   Color Specifies the color of the selected reference point (the reference point 
on which you have clicked in the Show real data points in box plots 
list). 

   Shape Specifies the shape of the selected reference point (the reference point 
on which you have clicked in the Show real data points in box plots 
list). 

Show abstraction 
of data ranges in 
box plot 

  

   Color Specifies the color of the selected reference point (the reference point 
on which you have clicked in the Show abstraction of data ranges in 
box plots list). 

   Shape Specifies the shape of the selected reference point (the reference point 
on which you have clicked in the Show abstraction of data ranges in 
box plots list). 

7.7.2.23.8 Details on Statistics Table 
This dialog is used to specify default settings for the statistics table shown in new box plots. 

► To reach the Statistics Table dialog: 
1. Select Tools > Options.... 
2. Go to the Box Plot page. 
3. Click on Statistics Table.... 
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Option Description 

Available 
measures 

Lists all statistical measures which can be shown in the statistics table. 

Selected measures Lists the statistical measures selected to be displayed in the statistics 
table. 

Add > Adds the measures selected in the Available measures list to the 
Selected measures list. 

< Remove Removes the selected statistical measures from the Selected measures 
list and sends them back to the Available measures  list. 

Remove All Removes all statistical measures from the Selected measures list. 

Move Up Moves the selected measures up in the Selected measures list. The 
order of the measures in this list determines the order of the measures 
in the statistics table. 

Move Down Moves the selected measures down in the Selected measures list. The 
order of the measures in this list determines the order of the measures 
in the statistics table. 

Sort by Specifies the measure by which you wish to sort the rows. 

Ascending Sorts the measures from the lowest to the highest value. 

Descending Sorts the measures from the highest to the lowest value. 
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7.8 Panels and Popovers 
In TIBCO Spotfire, some functionality can be reached through panels that can be shown either 
at all times or on demand only. The state of a panel is remembered per page, so you can use one 
state on one page and another on the next page. 
By default, the Filters panel and Details-on-Demand are shown as docked panels to the right 
and the Tags panel, the Lists panel and the Collaboration panel will be shown to the left in the 
main window, if displayed. Bookmarks are shown in a popover by default. However, all panels 
can be shown in three different states: as docked panels,as popovers or as floating windows. 
The legend of all visualizations is a special case which can be shown in a docked state or as a 
popover only; it cannot be unattached to a floating window like the other panels and popovers. 
See Legend for more information. 
No matter what state is used to display the panel, the content will always be remembered. 

Docked Panels 
Docked panels may be preferred when you interact with the content of the panel often, or, when 
you need to see the content at all times. For example, if you need to view the current state of the 
filters in the filters panel. Docked panels can be moved to the left, right or bottom part of the 
Spotfire window using drag-and-drop. 

► To move docked panels inside the TIBCO Spotfire main window: 
1. Click on the title bar of the panel you want to move. 
2. Drag the panel to its new position. 

If no other panels are displayed where you want to place your panel, simply drag it to the edge 
of the main window and a shaded area will show you where the panel will be displayed. If there 
is no shaded area you will not be able to drop the panel in that position. 
If one or more panels are already displayed where you want to place your panel, the shaded area 
will help you decide the order of the panels. 

Popovers 
Popovers are useful when the screen estate is limited and you only need a short interaction with 
the controls within the panel. For example, if you want to apply a bookmark and then continue 
with your analysis. 
You can never display more than one popover at a time. 

► To undock a panel into a popover: 
Click the Undock icon, , in the top right corner of the panel. The panel will change into a 
popover, located below its corresponding button in the toolbar.  
You can click on the title of the popover and drag it to another position, temporarily. The 
popover will remain open on this position as long as you work within it. However, the next time 
the popover is opened it will be located below its corresponding toolbar button again. 

► To turn a popover into a docked panel: 
Click the Dock icon, , in the top right corner of the popover. You can also double-click on 
the header of the popover to dock it. 

Floating Windows 
Floating windows can be used if you want to move that particular panel outside of the main 
Spotfire window. For example, if you want to keep the Collaboration panel open on a different 
screen. 



Pages and Layout 

827 

► To undock a panel into a floating window: 
Double-click the title bar of the panel you want to undock. 
Once undocked you can move the floating window by clicking the title bar and drag it to where 
you want it displayed. 

► To reposition floating windows: 
Double-click on the title bar of the floating window to return it to the same position in the 
TIBCO Spotfire main window it was previously undocked from. 
Note: Clicking the cross in the title bar will close the floating window. To bring back a hidden 
window, select View > and the name of the panel, or click the corresponding button on the 
toolbar. 

 

Filters 

 

Details-on-Demand 

 

Tags 

 

Bookmarks 

 

Lists 

 

Collaboration 
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8 Filters 
8.1 What is a Filter? 

Filters are used to narrow down the selection of data shown in the visualizations. For example, a 
filter could be adjusted so that data is only shown for a certain range of dates or for a certain 
number of food products. When you manipulate a filter, you can instantly see how the current 
setting affects the visible data in the visualizations. 
When you load data into Spotfire, each column in the data table is automatically represented by 
a filter. The initial type of filter depends on the type of data in the column, but you can right-
click on any filter and change the type if you like. 
You can view and manage filters in a popover, in a docked panel, or as a floating window. See 

Panels and Popovers for more information. Click on the Filters button on the toolbar, , or 
select View > Filters to show or hide Filters. The Filters panel or popover will open in the 
mode it was opened the last time you had it open. The visibility of Filters is controlled per page, 
and the Filters visibility of new pages is inherited from the active page. The image below shows 
Filters as a docked panel with the different filter types. 
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Number Filter Type 

1 Range Filter 

2 Item Filter 

3 Radio Button Filter 

4 Check Box Filter 

5 Text Filter 

6 List Box Filter 

7 Hierarchy Filter 
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Note: Binary columns are not represented by filters. 
When more than one data table is available in the analysis, data table headers are automatically 
displayed above the filters. The active data table is indicated by bold typeface and a color stripe. 
Related data tables are indicated by stripes of the same color to the left of the filters, as seen in 
the image below. 

 
Visualizations also get a color stripe in the title bar, indicating which data table the visualization 
is based on, when more than one data table is available in the analysis. The image below shows 
a bar chart title bar with a blue color stripe indicating that the bar chart is based on the same 
data table as the filters in the image above. 

 
Once a filter has been manipulated, you can right-click on it and select Reset Filter to return 
the filter to its original state (all values selected). Selecting Reset All Filters, either from the 
pop-up menu in the filters panel, on the toolbar, or from the Edit menu, returns all filters in the 
active filtering scheme to their original state. Note that resetting filters will only affect 
modifications related to filtering of the data. For example, if you have cleared any check boxes 
in a check box filter, or narrowed down the range of values in a range filter. Other changes, 
such as renaming a filter, changing the filter type or scale, will not be affected. 
When Filters are in a popover or a docked panel, you can get a quick overview of which filters 
have been modified by hovering over the Filters heading: 

 
The filters currently modified are shown together with their settings in a tooltip. 
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8.2 Filter Types 
8.2.1 Range Filter 

The range filter lets you narrow down the data shown to a range of values.  

 

► Interacting with the range filter: 
Use the left and right handles on the range filter to change the lower and upper limit of the 
range. Click and drag a handle to set it to the desired upper or lower limit. Only rows with 
values within the range will remain visible in the visualization. 
You can also use the keyboard to adjust the range when the filter device is active. The left and 
right arrow keys will move the lower limit, and up and down arrow keys will move the upper 
limit. 
Labels above the slider display the exact current range. Double-click on a label, enter a value in 
the field, and press Enter, if you want to set the range to a specific value: 

 
Click and drag the middle part of the slider to move the range sideways.  

 
This provides a powerful way of sweeping over different "slices" of a data table. Observing the 
reactions of the other filters to such a sweep can give some interesting clues to correlation 
between parameters in the data table. 
If the range filter shows dates, you can click on the calendar icon, , to set a date for the slider. 
An important feature of the range filter is that the values are distributed on a linear scale 
according to the values of the data. Thus, if values are unevenly distributed, this will be 
reflected in the range filter. 
Note: This is not the case with item filters, where values are distributed at even intervals along 
the range of the slider, regardless of the actual numeric values. 

► Narrowing the range filter span to the currently filtered data: 
1. A lighter shade at either end of the slider indicates that currently there is no data 

visible in that part of the range because other filters in the analysis have filtered out 
those rows: 

 
Double-click on the center of the range filter. 

Response: The range filter is now adjusted, showing only the effective range: 
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► Filtering the data range: 
Sometimes you might wish to filter the data in a column using a smaller range than the full 
range of the column. If so, you can set a range filter to encompass only a smaller range. 

1. The original range filter span is 1 to 500.   

 
2. Move the drag box to narrow down the selection.   

 
3. Right-click on the range filter to bring up the pop-up menu. 
4. Select Filtering Scheme Properties. 

Response: The Filtering Scheme Properties dialog is opened. 
5. Under Filter settings, select Data range: Specific. 
6. Click on the Range from Filtered button. 
7. Click OK.   

Response: The range filter expands to its full width, but with the range 296 to 500. 
Three dots are displayed to indicate that the range is not the original full range.   

 

► Setting the data range without filtering: 
You can also set the data range in the Filtering Scheme Properties dialog without filtering out 
any data beforehand. 

1. Right-click on the range filter to bring up the pop-up menu. 
2. Select Filtering Scheme Properties. 

Response: The Filtering Scheme Properties dialog is opened. 
3. Under Filter settings, select Data range: Specific. 
4. Enter Min and Max values in the provided fields. 
5. Click OK. 

Response: The range filter is displayed at its full width, but ranging between the values 
you provided in the Min and Max fields. Three dots are displayed to indicate that the 
range is not the original full range. 

► Changing the scale: 
If the values of a column are unevenly distributed, you may want to change the scale used on 
the range slider to get better granularity when moving the slider handles. A column with many 
low values but only a few high values can benefit from using a Log10 scale. The scale setting 
does not alter the data in any way, just how the values are distributed along the slider. 

1. Right-click on the range filter to bring up the pop-up menu. 
2. Select Filtering Scheme Properties. 

Response: The Filtering Scheme Properties dialog is opened. 
3. Under Filter settings, select Scale: Log10. 
4. Click OK. 

Response: See example below. 
Example: A column with many low values but only a few high values. 
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The image above shows the filter with Original scale – the middle of the slider 
represents the value 250. 

 
The image above shows the filter with Log10 Scale – the middle of the slider 
represents the value 26. It is now easy to set the left handle to specific low values. 
Note: Resetting a range filter by selecting Reset Filter from the right-click menu only 
affects the range of values in the filter. This means that if the scale has been set to 
Log10, it will not be changed back to Original. 

8.2.2 Item Filter 
The item filter is used to select a single item at a time, and lets you easily step between nearby 
items.  

 
Drag the slider to a new position, or click on the arrows at the edges of the slider, to step 
through the values. The item filter can also be adjusted with the arrow keys when the filter is 
active: the left and right arrow keys move the slider one step in either direction, the Home key 
sets it to show (All), and the End key sets it to show (None). By double-clicking on the label 
above the slider you can type in a value to set, and the slider will snap to that value when you 
press Enter. 

 
The example above shows the values of an item filter and the special cases at the edges. When 
the slider is set to the very first position to the left (All), it does not filter anything, thus, all 
items are shown. When the slider is set to (None) everything is filtered out, showing nothing. If 
the data table contains empty values, the (Empty) position will select these. 

8.2.3 Radio Buttons 
In a radio button filter, each value is represented by a radio button.  

 
The radio buttons are mutually exclusive, that is, only one of the alternatives in the filter can be 
set at a time. However, an (All) option is always present, letting you select all values. A (None) 
option is also available, letting you filter out all the values, showing nothing. If there are empty 
values present, a radio button named (Empty) will be available. Selecting this radio button will 
filter to the empty values. 
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Values that have been filtered out by other filters are indicated with grey text. If you select a 
radio button that is grayed out, nothing will be shown in the visualizations since that value has 
been filtered out already. 
When the filter is active, you can use the arrow keys on the keyboard to change the selected 
radio button. 
For columns containing more than 500 values, radio buttons cannot be used as the filter type. 

8.2.4 Check Boxes 
In a check box filter, each unique value in the column is represented by a check box. One or 
several check boxes may be selected or cleared to determine which values are to appear in the 
visualizations. 

 
If there are empty values present, a check box called "Empty" will be available, letting you filter 
to those values. 
Values that have been filtered out by other filters are indicated with gray text. 
When the filter is active, you can use the arrow buttons and the spacebar on the keyboard to 
select and clear check boxes. 
For quick selecting or clearing of all the values, right-click on the filter, and select Reset Filter 
to select all the check boxes, or Deselect All Values from the pop-up menu. 
For columns containing more than 500 values, check boxes cannot be used as the filter type. 

8.2.5 Text Filter 
The text filter lets you type a string of text, and any values that do not match the entered string 
are filtered out. As you type the string, the visualization is continuously updated with the values 
that begin with the current substring. 

 
For example, consider a column with all the months of the year, January, February, March, ... , 
December. 

Typed in Text Filter Filtered rows 
j January, June, July 

ju June, July 

jun June 

june June 

• The text filter is not case-sensitive. 
• A blank space between two search words will result in rows containing both words. 
• Search for june OR may to find rows containing either of those months. 
• Use *son to search for rows ending in "son" (Anderson, Jamesson, etc.), and use *sun* 

to search for rows containing the letters "sun" somewhere (Sunday, Asunder, etc.). 
• Use quotation marks "sample batch alpha" to search for exact phrases. 
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• Searching Date, Time and DateTime: Date and time can be formatted and displayed 
in a multitude of ways. When searching for date or time, always search using the same 
syntax as displayed in the document. The separators between year, month, day will be 
treated as word separators. 
For example, suppose dates are displayed in a table visualization in the YYYY-MM-
DD notation. 
Searching for 05 would match dates such as:  2005-05-27 or 1998-12-05. 
Searching for *05 would match dates such as: 2005-12-30 or 1997-05-22 or 1879-10-
05. 
Searching for 04-2 would match dates such as: 1998-04-21 or 2005-04-29. 
Time can sometimes be displayed using a notation with colon, for example: 11:45pm 
or 23:45. 
The colon is a protected keyword, which means that to search for such a time you need 
to enclose the time within quotation marks:  "23:45".  Just searching for 23:45 without 
the quotation marks will not provide any matches. 

• Searching Currency: Depending on how a column of currency values is presented, it 
can have various symbols before or after the digits. When searching, do not enter these 
symbols, just search for the value. For example, a searching for 550 would find $550, 
£550 or 500kr. 

For a listing of more search alternatives, see Searching in TIBCO Spotfire. 

8.2.6 List Box Filter 
The list box filter is used to select a few values from a very long list of values present in the 
column. 

 
Select items in the list to filter to those items. Press Ctrl or Shift and click to select multiple 
values. If you click on the first alternative in the list, (All), no filter is applied, and all values are 
shown. 
You can narrow down the list of values by typing a string of text in the search field above the 
list. The values that do not match the string are removed from the list. As you type the string, 
the list is continuously updated with the values that match the current substring. For list box 
filters in the text area, you need to press enter to search. By narrowing down the list, you can 
more easily find the values of interest, but this does not affect the applied filtering in any way. 
To apply filtering you must select values from the list. You can also enter an expression in the 
field to narrow down the list, using the rules described in Searching in TIBCO Spotfire. 
Remove the text string from the search field to make all the values reappear in the list. 
The grey indicator on the right hand side of the filter shows where your selected values are 
located in the whole list. On mouseover, a tooltip appears, showing how many values have been 
selected in the list. If fewer than six values are selected, you also see those values in the tooltip. 
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8.2.7 Hierarchy Filter 

8.2.7.1 What is a Hierarchy Filter? 
A hierarchy filter is a filter type that shows hierarchical data in an expandable tree view. Good 
examples of data that can be used in a hierarchy filter are date and time information, or 
geographical data such as continents/countries/cities. The examples below illustrate those two 
uses of hierarchy filters. 

Hierarchy filter from a date column 
In this example, a column with various dates is shown as a check box filter. This column is used 
to create a hierarchy filter, grouping the dates into Year/Quarter/Month, instantly providing a 
better overview. 

 
In this case, you go from a linear series of dates that you can only manipulate on the most 
granular level, to a view that groups the dates from the column into a hierarchy you decide. You 
can select to show the dates as Year/Quarter/Month or Year/Month/Day or 
Year/Month/Week/Day or any other configuration you want. 

Hierarchy filter from different but related columns  
With date information, you often only need the data from one single column to create the 
hierarchy filter. However, for other data it might not be so easy for Spotfire to instantly 
understand they have a hierarchical order. In this case you can set up a new hierarchy filter by 
combining several related columns into a hierarchy. Such data can be geographical data as 
mentioned above, or perhaps product information such as Market Category/Product 
Category/Product. 
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In this example, we see three separate columns (Continent, Country, City) originally displayed 
as three separate check box filters. These are then combined into one hierarchy filter, creating a 
structure that is easier to work with. 
In order to combine many columns into a hierarchy filter, there must be an inherent hierarchy in 
the data. The data in the example above looks like this: 

 
To learn how to create a hierarchy filter, see Creating a Hierarchy Filter. 

8.2.7.2 Creating a Hierarchy Filter 
Creating a hierarchy filter is done by combining a selection of columns or date categories into a 
hierarchy. Note that combining columns into a hierarchy filter will not automatically remove all 
other filters representing the same columns—this must be done manually, if desired. 

► To combine several columns into a hierarchy filter: 
1. Right-click anywhere in the Filters panel. 
2. Select Insert Hierarchy.... 

Response: The Insert Hierarchy dialog appears. 
3. If more than one data table is available in the analysis, specify which Data table to 

work on. 
4. Select the columns you want to include in your hierarchy filter from the Available 

columns list, and click Add >. 
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Response: The columns appear in the Hierarchy list. 
5. Select a column in the Hierarchy list, and use the Move Up and Move Down buttons to 

position it correctly in the hierarchy. 
Comment: The least granular category should be placed at the top of the list. For 
example, Continent above Country above City. 

6. Enter a name for the new hierarchy in the Hierarchy name field. 
7. Click OK. 

Response: The new hierarchy filter appears at the bottom of the list of filters (for the 
specified data table) in the filters panel. 

Note: Creating a hierarchy with a very large number of nodes may take a long time. It may also 
result in a hierarchy filter with too many check boxes to be practically useful. Use the Filtering 
Scheme Properties or the Column Properties to edit the hierarchy and remove the column with 
too many unique values if this should happen. 

► To create a hierarchy filter from a date column: 
1. Right-click anywhere in the Filters panel. 
2. Select Insert Hierarchy.... 

Response: The Insert Hierarchy dialog appears. 
3. Select the Data table containing the desired date column. 
4. In the Available columns list, the date column has several sub-categories: 

 
5. Select the sub-categories you want to include in your hierarchy filter from the 

Available columns list, and click Add >. 
Response: The sub-categories appear in the Hierarchy list. 

6. Remove unwanted entries from the Hierarchy list by selecting them and clicking < 
Remove. Most often you will not want to include the actual Date column in the 
hierarchy filter, only a selection of its sub-categories. 

7. Select an entry in the Hierarchy list, and use the Move Up and Move Down buttons to 
position it correctly in the hierarchy. 
Comment: The least granular category should be placed at the top of the list. For 
example, Year above Quarter above Month. 

8. Enter a name for the new hierarchy in the Hierarchy name field. 
9. Click OK. 

Response: The new hierarchy filter appears at the bottom of the list of filters (for the 
specified data table) in the filters panel. 
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8.3 Filters Panel 
8.3.1 Searching for Filters 

When using a data table with many columns, you often have just as many filters. Sometimes it 
can be hard to find the filter you wish to manipulate by scrolling through the filters panel. A 
quick way to find a certain filter is to use the search function at the top of the filters panel. 
Note: The filter search will not display filters that have been explicitly hidden. To search 
among all filters, you must first show them all. This can be done by clicking on the Show all 
link at the bottom of the filters panel. 

► To search for a filter: 
1. Type a search expression in the search field at the top of the filters panel. 

 
2. Any filters with names that do not match this are hidden from the filters panel. As you 

enter text, the filters panel is continuously updated with the filters whose names begin 
with the current substring. 

3. To show all filters again, just clear the search box. 
You can use wildcards and boolean operators to search for parts and combinations of words. 
For a listing of the basic search syntax, see Searching in TIBCO Spotfire. 

Filters specific search: 
• Type status:modified to find all filters which have been modified. 
• Type datatable:<datatablename> where <datatablename> for example could be 

"Sales Data", to find all filters for a specific data table if you have several in your 
analysis. Type a part of a name or use quotation marks to search for explicit data table 
names. 

8.3.2 Changing Filter Name 
Changing a filter name is the same thing as changing the name of the corresponding column in 
the data table. 

► To change a column name: 
1. Right-click on a filter. 
2. Select Rename... from the pop-up menu. 
3. Type a new name for the column. 
4. Click OK. 

Response: The filter (and the corresponding column in the data table) now has the new 
name.  

You can also change the name of a column from the Column Properties dialog. In this dialog 
you can also make other adjustments to the column. For example, change the sort order of the 
categories in a column, or change the formatting settings.  

8.3.3 Showing and Hiding Filters 
When using a data table with many columns, you often have just as many filters. If you are only 
interested in manipulating some of these, you can hide unwanted filers so that they do not 
appear in the filters panel. The corresponding columns in the data table are of course still 
present. The showing and hiding of filters is made per page. 



TIBCO Spotfire 4.0.2 - User's Manual 

840 

► To hide a filter: 
1. Right-click on a filter in the page of interest. 
2. Select Hide Filter. 

Response: The filter is hidden and is not seen in the filters panel. 

► To show hidden filters: 
When one or more filters have been hidden on a page, the following link is displayed at the 
bottom of the filters panel: 

 
Click on the Show all link to display all filters. 
To show only a few of many hidden filters, you can do so from the Organize Filters dialog. 
Follow the steps below to learn how to do this: 

1. Right-click anywhere in the filters panel. 
2. Select Organize Filters.... 

Response: The Organize Filters dialog is displayed. 
3. Find the filter you want to show in the Visible data tables, groups and filters list. 
4. Select the check boxes corresponding to the filters you want to make visible. 

Click OK. 
Comment: The changes made in the Organize Filters dialog only affect the active page. 
If you want to show these filters on more pages you need to repeat these steps for all 
pages where you want to display the filter. A shortcut for showing/hiding filters on 
multiple pages is to right-click and use the Apply Filter Organization feature. Note that 
when the active filter organization is applied to other pages, the complete filter 
organization is copied, including the visibility and sorting of groups and filters. 

8.3.4 Moving and Sorting Filters 
You can change the order of the filters in the filters panel, either by moving them as you like, or 
by sorting them in alphabetical order. 

► To move a filter: 
1. Click on a filter and drag it to another position in the filters panel. 

Response: A horizontal black line appears, indicating where the filter will be placed. 
2. Drop the filter where you want to place it. 

Comment: You can only move a filter within the data table group that it belongs to, not 
to another data table. 

► To sort the filters and groups: 
1. In the filters panel, right-click somewhere inside the data table group that you want to 

sort. Avoid clicking inside a filter group since that will allow you to sort only the 
filters in that group. 

2. Select Sort Filters and Groups from the pop-up menu. 
3. Select whether you want to sort the filters and groups in Ascending or Descending 

alphabetical order. 
Response: The filters and groups within the selected data table group is sorted 
according to you selection. Note that it is only the actual filter groups that are sorted; 
filters within a filter group will not be sorted. To filter within a filter group, see below. 

► To sort the filters within filter groups: 
1. In the filters panel, right-click on the filter group that you want to sort. 
2. Select Sort Filters from the pop-up menu. (If you click on the filter group heading, 

select Sort Filters In Group from the menu). 
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3. Select whether you want to sort the filters in Ascending or Descending alphabetical 
order. 
Response: The filters in the selected filter group are sorted according to you selection. 

8.3.5 Grouping Filters 
To make it easier to get an overview of the filters, you can create groups in the filters panel, and 
place certain filters in these. You can only group filters that belong to the same data table. You 
can then expand or collapse various groups to only work with the filters you want for the 
moment. Groups can be hidden if you do not want them for a while, and you can also sort the 
filters in a certain group alphabetically. The groups are specified per page. 

► To create a new group: 
1. Right-click in the filters panel on the page of interest. 

Comment: If multiple data tables are used in the document, the group will be placed 
within the data table where the filter you right-clicked on belongs. 

2. Select New Group... from the pop-up menu. 
Response: The New Group dialog is opened. 

3. Enter a name for the new group. 
4. Click OK. 

Response: The new filter group is added to the filters panel in the position where you 
right-clicked. 

► To move filters into a group: 
1. Click and drag a filter, and drop it on the header of a group. 

or 
2. Right-click on a filter, select Move to Group from the pop-up menu and select a 

group. 
Comment: Select New Group from the menu to create a new group and move the filter 
to that group. Select (No Group) to move the filter out of the group. 

► To hide a group: 
1. Right-click on the header of the filter group you want to hide. 
2. Select Hide Group from the pop-up menu. 

► To show a hidden group: 
1. Right-click anywhere in the filters panel. 
2. Select Organize Filters... from the pop-up menu. 

Response: The Organize Filters dialog is opened. 
3. Select the check box of the group you want to make visible. 
4. Click OK. 

Response: The selected filter group is now shown in the filters panel. 
Comment: The changes made in the Organize Filters dialog only affect the active page. 
If you want to show the group on more pages you need to repeat these steps for all 
pages where you want the group to be displayed. A shortcut for adding a group to 
multiple pages is to right-click and use the Apply Filter Organization feature. Note that 
when the active filter organization is applied to other pages, the complete filter 
organization is copied, including the visibility and sorting of individual filters. 

► To sort the filters in a group: 
1. Right-click on the header of the group you want to sort. 
2. Select Sort Filters In Group from the pop-up menu. 
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3. Select whether you want to sort the filters in Ascending or Descending alphabetical 
order. 
Response: The filters in the selected filter group are sorted according to you selection. 

8.3.6 Filters Panel Properties 

8.3.6.1 Filters Panel Properties 
What you see in the filters panel depends on two different collections of settings, controlled via 
two dialogs: 

• Filtering Scheme Properties - Determines the types and specific settings for the filters 
in a filtering scheme. Note that the settings for a filtering scheme can affect filters on 
several different pages (all pages and visualizations that use that filtering scheme). 

• Organize Filters – Controls which filters should be visible on each page, as well as the 
sorting and grouping of the filters. These settings only affect the page on which you 
opened the dialog. If you want to reuse the filter organization from a page, you can 
right-click in the filters panel on that page and select Apply Filter Organization... and 
the page on which you want to apply the filter organization. 

When a new page is created, the filtering scheme and filter organization is inherited from the 
active page. 

► To reach the Filtering Scheme Properties dialog: 
1. Right-click on the filters panel on a page that is using the filtering scheme whose 

properties you wish to change. 
2. Select Filtering Scheme Properties from the pop-up menu. 

► To reach the Organize Filters dialog: 
1. Right-click on the filters panel on the page you wish to change the filter organization 

for. 
2. Select Organize Filters... from the pop-up menu. 

8.3.6.2 Details on Filtering Scheme Properties 
In the Filtering Scheme Properties dialog you can view and change the settings for the filters in 
a filtering scheme. The different filter types have slightly different settings as described below. 
The properties specified for a filter in this dialog affect all pages and visualizations where the 
current filtering scheme is used. 
Note: The visibility and order of filters within a data table group are instead handled per page, 
using the Organize Filters dialog. 

► To reach the Filtering Scheme Properties dialog: 
1. Right-click in the Filters panel on a page where the filtering scheme of interest is used. 
2. From the pop-up menu, select Filtering Scheme Properties. 
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Option Description 

Data table Specifies which data table to work with. 

[Type to search 
filters] 

If the list of filters is long, you can enter a search expression here to 
limit the list to show only filters that match your search. 

[Filter list] Lists all the filters in the selected data table. Click on a column header 
to sort the list according to the values in that column. 

Column name Displays the name of the currently selected column in the list. This is 
also the name of the filter. 

Rename... Opens the Rename Column dialog where you can change the name of 
the selected column. 
Note: This will change the name of the filter, as well as all the 
instances of the column throughout the analysis. 

Filter type Specifies the type of the selected filter. 

Filter settings 
[Range Filter] 

When selecting a range filter, you can modify the Data range and 
Scale. 
Select either Automatic data range (default) or Specific data range. 
If you selected Specific, you can either click the Range from Filtered 
button to set the data range to what the range slider is currently set to, 
or, you can manually enter a Min and Max value in the fields. 
You can also select whether the scale should be Original or Log10 
from the drop-down menu. 

Filter settings 
[Hierarchy Filter] 

When selecting a hierarchy filter, you can modify the hierarchy by 
clicking on the Edit button that appears inside the Filter settings area. 
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Filter settings 
[List Box Filter] 

When selecting a list box filter, you can modify the appearance of the 
filter. The check box "Show search field" allows you to set if the 
search field is displayed in the filter or not. You can set the number of 
rows shown in the filter by typing a number or setting the number with 
the arrows. 

Note: Most of the settings in this dialog, such as renaming a filter, changing the filter type or 
range filter scale, will not be affected when you select Reset Filter or Reset All Filters from the 
right-click menu in the Filters panel. Resetting a filter only affects modifications related to 
filtering of the data; for example, clearing any check boxes in a check box filter, or narrowing 
down the range of values in a range filter. 

8.3.6.3 Details on Organize Filters 
The Organize Filters dialog handles the visibility, grouping, and sorting of the filters on the 
active page. 
Note: The filter type and settings for a specific filter are instead handled by the Filtering 
Scheme Properties dialog. 

► To reach the Organize Filters dialog: 
1. Right-click in the Filters panel on the page of interest. 
2. From the pop-up menu, select Organize Filters.... 

Comment: You can also select Edit > Organize Filters... from the main menu to display 
the Organize Filters dialog for the active page. 

 

Option Description 

Visible data tables, 
groups and filters 

This list shows all filters, groups and data tables in the document. The 
check boxes can be selected to show/hide the filters from the filters 
panel. The order of the filters in this list also represents the order they 
occur in the filters panel. 
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Rename... Select a filter or group, and click this button to rename it. Note that 
renaming a filter also renames the column that the filter is based on. 

New Group... Click this button to create a new group. 

Delete Select a group, and click this button to delete it. 

Move Up Select a filter, group, or data table, and click this button to move it up 
in the list. This list represents the order the filters are displayed in the 
filters panel. Filters and groups cannot be moved to a different data 
table. 

Move Down Select a filter, group, or data table, and click this button to move it 
down in the list. This list represents the order the filters are displayed 
in the filters panel. Filters and groups cannot be moved to a different 
data table. 

Move First Select a filter, group, or data table, and click this button to move it to 
the top of the list. 

Move Last Select a filter, group, or data table, and click this button to move it to 
the bottom of the list. 

Sort In the drop-down menu, select either Ascending or Descending order 
to sort all items in the list. 

Select All Makes all filters, groups and data tables visible. 

Clear All Hides all filters, groups and data tables. 

 

8.3.6.4 Details on New Group 

► To reach the New Group dialog: 
1. Right-click in the filters panel on the page of interest. If the analysis contains multiple 

data tables, make sure to click inside the data table in which you want to place the new 
group. 

2. Select New Group... from the pop-up menu. 
OR 

3. Open the Organize Filters dialog. 
4. Under Visible data tables, groups and filters, select in which data table you want to 

create a new filter group. 
5. Click on New Group.... 
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Option Description 

Name Specify the name for the new group as it will be presented in the filters panel. 
Tip: If you want a group to be available on more than one page, you can right-
click on the page and select Apply Filter Organization... from the pop-up menu. 
The filter organization, such as which filters are shown or hidden as well as the 
order of data tables, groups and filters in the filters panel will be copied to all of 
the selected pages when this function is used. New pages automatically inherit the 
filter organization from the active page. 

8.3.6.5 Details on Rename Column 

► To reach the Rename Column dialog: 
1. Right-click on the filter representing the column you want to rename. 
2. Select Rename... from the pop-up menu. 

OR 
3. Open the Filtering Scheme Properties dialog.  
4. In the list of columns, select the column you want to rename. 
5. Click on Rename.... 

 

Option Description 

Name Specify a new name for the column. 
Note: The filters use the same name as the columns, so renaming a 
filter will also change the column name in all other instances as well. 

8.3.6.6 Details on Rename Group 

 

Option Description 

Name Specify a new name for the group, as it should be presented in the 
filters panel. 
Note: The group names are specified per page, so if you want the same 
name to be used on several different pages, it may be a good idea to 
first change the group name and then use the Duplicate Page feature to 
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create the other pages. When a page is duplicated, all settings in the 
filters panel are inherited from the old page. 
You can also right-click in the filters panel of the page containing the 
correct group name and select Apply Filter Organization.... In that 
case, the complete filter organization, including which filters are 
shown or hidden as well as the order of data tables, groups and filters 
in the filters panel will be copied to all of the selected pages. 

8.3.6.7 Details on Apply Filter Organization 
The Apply Filter Organization functionality allows you to reuse the layout you have created on 
one page and apply it on one or several other pages. 

► To reach the Apply Filter Organization dialog: 
1. In the Filters panel, right-click to display the pop-up menu. 
2. Select Apply Filter Organization.... 

Comment: You can also select Edit > Apply Filter Organization... from the main menu. 

 
Click to select all pages to which you wish to apply the filter organization from the active page. 

8.4 Filtering Schemes 
One of the main strengths of TIBCO Spotfire is the ability it gives you to filter your data, hence, 
to control what data shall be visible and used in some calculations. This means that you can 
show/hide data for specific categories, change the time range to look at, step through a sequence 
of values one at a time, etc. 
You have the possibility to add your own filtering schemes, which can be applied to the analysis 
per page or per visualization. This gives you the complete freedom to control which pages and 
visualizations will affect each other. You can set up the filtering schemes to work on any 
combination of visualizations and/or pages in your analysis. For example, you can keep all the 
visualizations on all the pages related by using the same filtering scheme for all of them, or, you 
can choose to specify different filtering schemes for all the visualizations in an analysis, or any 
combination in between these two extremes. See Limiting What is Shown in Visualizations to 
learn how to set up a visualization to use a different filtering scheme than the filtering scheme 
used on the page. 
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The filter type is a part of the filter settings in a filtering scheme. This and other filter settings 
are controlled via the Filtering Scheme Properties. It is reached via the right-click menu in the 
filters panel. The selection of which filters are visible on a page is, in contrast, specified per 
page, via the Organize Filters option on the right-click menu. 

► To create a new filtering scheme: 
1. Select Edit > Document Properties. 
2. Go to the Filtering Schemes tab. 
3. Click New.... 
4. Type a name and click OK. 

► To change the filtering scheme to use on a page: 
1. Make sure that the filtering scheme menu is visible at the top of the filters panel. 

Comment: If the filtering scheme menu has been hidden, it can be shown by selecting 
Edit > Document Properties > Filtering Schemes tab and the check box Show filtering 
scheme menu in Filters panel. 

2. Click on the filtering scheme menu. 
3. Select the desired filtering scheme. 

  

8.5 Filtering in Related Data Tables 
When you have multiple data tables that are related to each other in your analysis, and the data 
tables do not include exactly the same rows, you may want to handle filtering in the related data 
tables in different ways, depending on whether you are interested in the filtered rows or the 
filtered out rows. To help show the difference between the three options available, we use an 
example with two related data tables, DT1 and DT2. Both DT1 and DT2 contain rows that are 
not available in the other data table (pink and yellow), but they also contain common rows 
(blue): 

 
A = Rows in DT1 that are not available in DT2. 
B = Rows in DT1 that are available in DT2, but have been filtered out. 
C = Rows in DT1 that are available in DT2 and included in the currently filtered rows of DT2. 
F = The filtered rows (rows remaining after filtering) in DT2. 
  



Filters 

849 

When the filtering management for DT2 is specified (from the DT1 data table header) the 
different options will give the following results: 

Include Filtered Rows Only 
The first option will make all row that are only present in DT1 disappear from the visualizations 
using DT1, since only the rows that are currently filtered in DT2 will be included. Hence, this 
option keeps only those rows that are present in both data tables (and have not been filtered 
out). 
In the example above, this means that only the rows in C will remain after filtering in DT2. 

Exclude Filtered Out Rows 
The second option will remove those rows that have been filtered out from DT2 from all 
visualizations using DT1. Hence, this option keeps those rows that are filtered in DT2 as well as 
the additional rows from DT1. 
In the example above, this means that A and C will remain after filtering in DT2. 

Ignore Filtering 
The third option is to ignore any filtering done in the related data table completely. This way, all 
rows that are available in the current data table will remain available. 
In the example above, this means that A, B and C will all remain after filtering in DT2. 
  
Note that you need to specify how each table should respond to filtering in all other related 
tables separately, to be certain of what will be shown in the visualizations after filtering. 

► To change the way filtering in a related data table affects a data 
table: 
1. Go to the Filters panel and locate the data table header for the data table of interest. 

2. Click on the Filtering in related data tables icon, . 
Response: A drop-down menu is shown, where all related data tables are available. 
Note: If a relation has become invalid, the icon will turn red. 

3. Select the data table for which you want to change how filtering should affect the 
current data table, and select one of the options Include Filtered Rows Only, Exclude 
Filtered Out Rows or Ignore Filtering. 
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9 Tags 
9.1 What are Tags? 

Tags are annotations that can be attached to marked rows. Each row can only contain a single 
tag from each tag collection, but the document can contain many tag collections simultaneously. 
A tag collection is basically a column containing a set of different tags, or annotations. Each tag 
collection is represented by a new column in the data table and can be used for filtering the data, 
just like any other column. Tags can only be attached to rows from a single data table, but the 
same tag collection and tag names can be used for multiple data tables. 
Tags are similar to Lists, but Tags are specific to the current analysis, while with Lists you work 
with the same collection of lists all the time, from one session to the next. Combining the 
functionality from Tags and Lists can be very useful. You can create lists from tag collections, 
and you can create tag collections from lists. This means that Lists can be a way to transfer 
knowledge from one analysis to another, while Tags can be a way to use lists within an analysis. 
See What are Lists? to learn more. 
You can view and manage Tags in a popover, in a docked panel, or as a floating window. See 
Panels and Popovers 

for more information. Click on the Tags button on the toolbar, , or select View > Tags to 
open Tags. The Tags panel or popover will open in the mode it was opened the last time you 
had it open. The image below shows the docked Tags panel with two tag selections. 

 
When more than one data table is available in the analysis, another level with the name of the 
data table is added to the tags panel. When attaching tags to marked rows, the active 
visualization defines which marking to get the marked rows from. 
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Note: If tags are to be reapplied after reloading linked data, you need to specify key columns 
that can be used to uniquely identify the rows in each data table. See Details on Select Key 
Columns for more information. 

9.2 How to Work with Tags 
Note: If tags are to be reapplied after reloading linked data, you need to specify key columns 
that can be used to uniquely identify the rows in each data table. See Details on Select Key 
Columns for more information. 

► To create a new tag collection: 
1. If Tags are not already visible, select View > Tags. 
2. If you have more than one data table in the document, click to select the data table 

where you want to add the tag collection. 

3. Click on the New Tag Collection button, . 
4. Type a Name for the tag collection. 

Comment: This name will also be used as column name when the tag collection is 
viewed as a column in visualizations. 

5. Optionally, type a Description with details about the tag collection. 
6. Click New.... 
7. Type a Tag name. 
8. Click OK. 

Response: The tag is added to the Tags list in the New Tag Collection dialog. 
9. Repeat steps 6 to 8 until you have added all tags that you want to include in this tag 

collection. 
10. Click OK. 

Response: The Tags are updated to display the new tag collection and its content. 

► To attach tags to marked rows: 
1. If Tags are not already visible, select View > Tags. 
2. In a visualization, mark the rows that you wish to tag. 

Comment: You can only attach one tag at a time. 
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3. Select the tag you want to apply. 

4. Click on the Attach Tag to Marked Rows button, . 
Comment: You can also drag the desired tag to the center of the visualization and drop 
it on the attach tag drop target. 
Response: The marked rows are annotated with the selected tag. 

5. Mark a new set of rows and repeat steps 3 to 4 until you have attached all tags that you 
want. 

► To mark all rows with a specific tag: 
1. If Tags are not already visible, select View > Tags. 
2. Make sure that a visualization using the desired data table and marking is active. 
3. Right-click on the tag of interest. 
4. Select Mark Tagged Rows in Active Visualization from the pop-up menu. 

Response: The rows with the selected tag are marked. 
Comment: You can also double-click on a tag to mark all rows with that tag 
immediately. 

► To mark all rows without a tag in a data table: 
1. If Tags are not already visible, select View > Tags. 
2. Make sure that a visualization using the desired data table and marking is active. 
3. Right-click on the Untagged item of the desired data table and tag collection. 
4. Select Mark Rows without Tags from the pop-up menu. 

Response: The untagged rows are marked. 

► To add the rows with a specific tag to the marked set: 
1. If Tags are not already visible, select View > Tags. 
2. Make sure that a visualization using the desired data table and marking is active. 
3. Press Ctrl on the keyboard while double-clicking on a tag. 

Response: The rows attached with that tag are added to the currently marked set. 

► To find rows with a specific tag within a previously marked set: 
1. If Tags are not already visible, select View > Tags. 
2. Make sure that a visualization using the desired data table and marking is active. 
3. Press Alt on the keyboard while double-clicking on a tag. 

Response: Only the rows that were previously marked AND also have the specified tag 
will remain marked. 

► To delete a tag or a tag collection: 
1. If Tags are not already visible, select View > Tags. 
2. Click on the tag or tag collection you wish to delete. 

3. Click on the Delete button, . 
Response: A confirmation message is displayed. 

4. Click OK. 

► To remove all tags for a specific tag collection: 
1. If Tags are not already visible, select View > Tags. 
2. For the desired data table, right-click on the tag collection item. 
3. Select Remove All Tags from the pop-up menu. 

Response: A confirmation message is displayed. 
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4. Click OK. 
Response: All tags are removed for that specific tag collection (in the specific data 
table). 

► To remove all tags from marked rows: 
1. If Tags are not already visible, select View > Tags. 
2. Make sure that a visualization using the desired data table is active and that the rows 

from which you wish to remove tags are marked. 
3. Right-click on the Untagged item of the desired data table and tag collection. 
4. Select Remove Tags from Marked Rows from the pop-up menu. 

Response: All tags from the specific tag collection are removed from the marked rows. 
Comment: You can also drag the Untagged item and drop it on the drop target in the 
visualization. 

► To remove a specific tag from all rows: 
1. If Tags are not already visible, select View > Tags. 
2. For the desired data table, right-click on the tag that you want to remove from all rows. 

Comment: If you have more than one data table in your analysis and the same tag is 
available in more than one data table, you need to make sure that you right-click on the 
tag in the actual data table of interest. This command works regardless of which data 
table is active. 

3. Select Remove Tag from All Rows from the pop-up menu. 
Response: The selected tag is removed from all rows in the specific data table. 

9.3 Details 
9.3.1 Details on New Tag Collection 

► To reach the New Tag Collection dialog: 
1. If the tags panel is not already visible, select View > Tags. 

2. Click on the New Tag Collection button, . 



TIBCO Spotfire 4.0.2 - User's Manual 

854 

 

Option Description 

Name The name of the annotation column that will be added to the data table. 

Description Optional. A description of the tag collection and its contents. 

Tags Lists the tags that belong to the current tag collection. New tags are 
added to the list using New.... 

New... Opens the New Tag dialog, where new tags can be added to the 
collection. 

Edit... Opens the Edit Tag dialog, where the name of the selected tag can be 
edited. 

Delete Removes a tag from the tag collection. 

Move Up Moves the tag up in the Tags list. 

Move Down Moves the tag down in the Tags list. 

9.3.2 Details on New Tag 
► To reach the New Tag dialog: 

1. Make sure that a tag collection has been created. 
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2. In the New/Edit Tag Collection dialog, click New..., or, in the tags panel, select the tag 

collection of interest and click on the New Tag button, . 

 

Option Description 

Tag name Type the text that you want to use as an annotation on a marked set of 
rows. 

9.3.3 Details on Edit Tag Collection 
► To reach the Edit Tag Collection dialog: 

1. If Tags are not already visible, select View > Tags. 

2. Select the tag collection of interest and click on the Edit button, . 

 

Option Description 

Name The name of the annotation column that will be added to the data table. 
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Description Optional. A description of the tag collection and its contents. 

Tags Lists the tags that belong to the current tag collection. New tags are 
added to the list using New.... 

New...  Opens the New Tag dialog, where new tags can be added to the 
collection. 

Edit... Opens the Edit Tag dialog, where the name of the selected tag can be 
edited. 

Delete Removes a tag from the tag collection. 

Move Up Moves the tag up in the Tags list. 

Move Down  Moves the tag down in the Tags list. 

9.3.4 Details on Edit Tag 
► To reach the Edit Tag dialog: 

1. Make sure that a tag collection has been created. 
2. In the New/Edit Tag Collection dialog, click Edit..., or, in the tags panel, select the tag 

of interest and click on the Edit button, . 

 

Option Description 

Tag name Type the text that you want to use as an annotation on a marked set of 
rows. 

9.3.5 Tags Pop-up Menus 
There are different options available depending on which type of object you right-click on in the 
tags panel. 

Data Table: 
This pop-up menu is reached by right-clicking on a data table in Tags: 

Option Description 

New Tag 
Collection... 

Opens the New Tag Collection dialog where you can define a name 
and description for a new tag collection. You can also define which 
tags should be available in the new tag collection. 

Tag Collection: 
This pop-up menu is reached by right-clicking on a tag collection in the tags panel. 
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Option Description 

New Tag 
Collection... 

Opens the New Tag Collection dialog where you can define a name 
and description for a new tag collection. You can also define which 
tags should be available in the new tag collection. 

New Tag... Opens the New Tag dialog where you can specify a new tag within this 
tag collection. 

Edit Tag 
Collection... 

Opens the Edit Tag Collection dialog where you can change the name 
and description of the tag collection. You can also define which tags 
should be available in the tag collection. 

Delete Tag 
Collection 

Deletes the tag collection and its corresponding column from the data 
table. 

Remove All Tags Removes all tags in this tag collection from all rows in the data table. 

    

Tag: 
This pop-up menu is reached by right-clicking on a tag in the tags panel. 

Option Description 

Attach Tag to 
Marked Rows 

Attaches the tag to the marked rows in the active visualization (only 
available when the active visualization is based on the same data table 
as the tag). 
If some the marked rows already have a different tag from this tag 
collection  attached you will be able choose whether to attach the tag 
to rows without a tag only, or to remove the old tag and attach the tag 
to all marked rows. 

Remove Tag from 
Marked Rows 

Removes the selected tag from the set of marked rows. 

Mark Tagged 
Rows in Active 
Visualization 

Marks all rows that are tagged with the selected tag in the active 
visualization (only available when the active visualization is based on 
the same data table as the tag). 

New Tag... Opens the New Tag dialog where you can specify a new tag within this 
tag collection. 

Edit Tag... Opens the Edit Tag dialog where you can change the name of the tag. 

Edit Tag 
Collection... 

Opens the Edit Tag Collection dialog where you can change the name 
and description of the tag collection. You can also define which tags 
should be available in the tag collection. 

Delete Tag Deletes the specified tag from the tag collection. All rows that had the 
tag attached will be untagged. 

Remove Tag from 
All Rows 

Removes this specific tag from all rows (within this tag collection). 
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Untagged: 
This pop-up menu is reached by right-clicking on an Untagged item in the tags panel. 

Option Description 

Mark Rows 
without Tags 

Marks all rows which currently has no tag attached for this tag 
collection. 

Remove Tags 
from Marked 
Rows 

Removes all tags in the current tag collection from the set of marked 
rows. 
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10 Bookmarks 
10.1 What are Bookmarks? 

Bookmarks are snapshots of the state of an analysis. Add a bookmark to your analysis to be able 
to return to a state where you found something interesting when you marked or filtered out 
certain items. A bookmark can be applied at any time, allowing you to quickly return to a 
previously created view of the data. You can also share your insights with others by making 
your bookmarks available to other users, or by sending links to the bookmarks.  
One of the most important uses of bookmarks is that they can be included as links in a text area. 
This helps you create guided analyses where the recipient of your analysis can click on action 
links or buttons to quickly move through several different views of the analysis. 
A bookmark can capture one or more of the following: specific rows you have marked, active 
pages and visualizations, and even specific filtering that you have applied. A bookmark also 
contains information about visualization properties such as what column was used on an axis, 
what column was used to color by, etc., as well as any custom property values you have used on 
the active page. You decide what should be included in a captured state, but a bookmark that is 
added without making any adjustments will automatically include all those parts in the 
bookmark. It can be worth noting that a bookmark never recreates any removed visualizations 
or pages. Neither will any added pages or visualizations be removed when a bookmark is 
applied. 
You can view and manage bookmarks in a popover, in a docked panel, or as a floating window. 
See Panels and Popovers for more information. Click on the Bookmarks button on the toolbar, 

, or select View > Bookmarks to open Bookmarks. The Bookmarks panel or popover will 
open in the mode it was opened the last time you had it open. The image below shows the 
Bookmarks popover with three added bookmarks. 

 
Note: If bookmarks are to be reapplied after reloading linked data, you need to specify key 
columns that can be used to uniquely identify the rows in each data table. See Details on Select 
Key Columns for more information. 

Private and Public Bookmarks 
Bookmarks can be either private or public. Only you can see your private bookmarks, while 
public bookmarks are visible to all users of the analysis. An icon showing a single person 
indicates that a bookmark is private, and an icon with multiple people indicates that a bookmark 
is public. When adding a new bookmark, it is private by default. If you want to make it 
available to other users, you can right-click on the bookmark and select Public Bookmark from 
the menu. As seen in the popover above, private bookmarks are listed before public bookmarks. 
The bookmarks are also sorted in chronological order with the bookmark that was last updated 
at the top of the list. 
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Share Bookmarks 
You can copy and share URLs pointing to specific bookmark states of an analysis. If a 
bookmark is private, it is still possible to send a URL including the private bookmark to a 
colleague in order to share that bookmark. See To create a URL to an analysis with a bookmark 
to learn how to do this. There are three different link types you can use, and which one to 
choose depends on the software available to the receiver of the link. See Bookmarks Pop-up 
Menu and Links to Analyses in the Library for more information about the link types. As 
mentioned earlier, you can also include bookmarks (both private and public) in an action control 
in a text area to make it available to other people. See To add a bookmark or bookmark part to a 
link, button or image in a text area to learn how to do this. Note that before you can copy and 
share links to bookmarks, the analysis must be published to the library. Before that, all 
bookmarks are stored locally, and have no link associated with them. 

Indicators 
There are a couple of indicators that let you know when you may want to pay attention to the 
bookmarks. 
If bookmarks are added or updated while you do not have the popover or panel open, the 

bookmarks button in the toolbar will indicate this with a green arrow: . Click on the button 
to view the updates. This will make the arrow disappear. 
If a bookmark becomes invalid, for example if the active page in the bookmark has been 
deleted, a red error provider is shown as seen below. 

 
Point to the error provider to see a tooltip with information about why the bookmark has 
become invalid. 

Permissions 
You can always apply any bookmarks that are visible to you in an analysis, but the ability to 
add and modify bookmarks can be restricted on two levels: 

• Library folder permissions – The creator of an analysis can specify the folder 
permissions required to add bookmarks in the Document Properties dialog. See Details 
on Document Properties – Library for a list of the available alternatives. To learn more 
about folder permissions in the library, see Permissions. 

• Licenses – Which license you have determines whether or not you will be able to add 
bookmarks to analyses. 

Limitations on Bookmarks 
• Bookmarks cannot capture filtering which is created using Marked Rows > Filter To. 
• It may not be possible to apply all parts of a bookmark if there are significant changes 

to the underlying data. 
• If data is refreshed, bookmarks can only reapply markings provided that key columns 

have been configured for that data table. 
• Bookmarks are saved per user, per document. If your Web Player is configured for 

“impersonation” in order to allow multiple users to log in anonymously, these users all 
impersonate a single user profile, so any private bookmarks captured by one user will 
be visible to all the other users under the same user profile. 
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10.2 How to Use Bookmarks 
Note: If bookmarks are to be reapplied after reloading linked data, you need to specify key 
columns that can be used to uniquely identify the rows in each data table. See Details on Select 
Key Columns for more information. 

► To add a new bookmark: 
1. If Bookmarks are not already visible, select View > Bookmarks, or press CTRL+B 

on the keyboard. 
Comment: Press Ctrl+Shift+B to open the Add Bookmark Special dialog where you 
can select to add partial bookmarks. To learn more about the different parts, see 
Details on Add Bookmark Special. 

2. Type a name for the bookmark in the text field. 

3. Click on the Capture Bookmark button, , next to the name field. 
Response: The bookmark is added to the analysis. 

► To apply a bookmark: 
1. If Bookmarks are not already visible, select View > Bookmarks, or press CTRL+B 

on the keyboard. 
2. Double-click on the bookmark of interest, or click on the menu arrow for the 

bookmark of interest and then select Apply from the menu. 
Comment: Bookmarks can also be added to action controls (links, buttons or images) 
in a text area or as actions on dynamic items in a graphical table. In that case, clicking 
on the action control will apply the bookmark. 
Comment: You can also choose to apply just a part of the bookmark by selecting 
Apply Special from the menu. See Bookmarks Pop-up Menu to learn more about the 
different bookmark parts. For Filter Settings, you can select a few different apply 
methods from the pop-up menu. 

► To add a bookmark or bookmark part action to a link, button or 
image in a text area: 
1. Make sure that you have created a bookmark according to the steps above. 

2. Create a text area by clicking on the New Text Area button, . 
Response: An empty text area is displayed. 

3. Right-click on the text area and select Edit Text Area from the pop-up menu. 
4. Type any explaining text in the text field, and where you want the bookmark-link to be 

placed, click on the Insert Action Control button, . 
Response: The Action Control dialog is displayed. 

5. On the Actions page, type a Display text to be used as the link or button text in the 
text area. 

6. Select the Control type from the drop-down list: Link, Button, or Image. 
7. In the Available actions list, click on the plus sign next to Bookmarks to expand the 

list, and then click on the desired bookmark. 
Comment: To add only a part of the bookmark, click on the plus-sign next to the 
bookmark of interest to expand the list, and then click on the bookmark part you want 
to add. 

8. Click Add. 
Response: The bookmark is added to the Selected actions list. 
Comment: If desired, you can add more actions to the same link. 

9. Click OK. 
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Response: The action control is added to the text area. 
10. Exit the text area edit mode to test the action control. 

► To create a URL to an analysis with a bookmark: 
1. If Bookmarks are not already visible, select View > Bookmarks, or press CTRL+B 

on the keyboard. 
2. Click on the menu arrow for the bookmark from which you want to create a URL. 
3. Select Copy Bookmark URL and choose one of the link types from the menu. 

Comment: To learn more about the different link types and when to use each of them, 
see Links to Analyses in the Library. 
Response: The link to the bookmark is copied to the clipboard and you can now paste 
it into, for example, an email or a web page. 

► To update a bookmark: 
1. If Bookmarks are not already visible, select View > Bookmarks, or press CTRL+B 

on the keyboard. 
2. Click on the menu arrow for the bookmark you wish to update and select Update 

Bookmark from the menu. 
Response: The bookmark parts available in the bookmark are updated with the current 
analysis settings. 

► To delete a bookmark: 
1. If Bookmarks are not already visible, select View > Bookmarks, or press CTRL+B 

on the keyboard. 
2. Click on the menu arrow for the bookmark you wish to delete. 
3. Select Delete from the menu. 

Response: The bookmark is removed from the analysis. 

► To use the 3.2 bookmarks panel: 
For compatibility reasons, you can go back to use the 3.2 version of the bookmarks, this is 
possible using the following steps. 

1. Select Tools > Options. 
2. Go to the Compatibility page. 
3. Select the Use 3.2 bookmark panel check box. 
4. Click OK. 

Response: The next time you open the bookmarks panel, it will use the 3.2 style and 
behavior. (If the new bookmarks panel is open, you need to close it and reopen to see 
the change.) 
Comment: See How to Use 3.2 Bookmarks and What are 3.2 Bookmarks? to learn 
more about 3.2 bookmarks. 

► To convert 3.2 bookmarks to new bookmarks: 
If an older analysis containing bookmarks is opened in TIBCO Spotfire 3.3 or later, and you are 
using the new Bookmarks popover or panel, a link will be shown at the bottom of the popover 
or panel. Click Convert to transform all old-type bookmarks to the new type. If you want to 
display the old bookmarks without converting them, you can go to Tools > Options, 
Compatibility page and select the Use 3.2 bookmark panel check box. Clear the check box to 
see the new type bookmarks. 
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10.3 Bookmarks Example Scenarios 
The concept of Bookmarks has many potential usages and usage goals. The list below presents 
some possible scenarios where bookmarks can be useful. 

 
  

The example flows in this section aim to describe how private and public bookmarks work 
across clients and between different users. 

Private bookmarks – available to a user regardless of client used: 

 

User A captures a private 
bookmark (A1) in TIBCO 
Spotfire and saves the 
analysis to the library. 

User A opens the analysis 
using the Web Player. The 
analysis is opened in the saved 
state and private bookmark A1 
is available. User A captures 
another private bookmark 
(A2). 

User B opens the 
analysis using the 
Web Player. The 
analysis is opened in 
the saved state. No 
bookmark is 
available. 

  
Private bookmarks can be used to save settings (an analysis state) from one occasion to another, 
in order to avoid repetitive work every time you open up an analysis. You can also use private 
bookmarks to capture an interesting state that later can be revisited, to analyze previously 
captured insights by sharing states with others or comparing them with other states in order to 
understand how different parameters (settings) affect the result. 
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Public bookmarks – available to all users of an analysis regardless 
of client used: 

 

User A captures private 
bookmark A1 and public 
bookmark A3 in TIBCO 
Spotfire and saves the 
analysis to the library. 

User A opens the analysis 
using the Web Player. The 
analysis is opened in the saved 
state and both private 
bookmark A1 and public 
bookmark A3 are available. 
User A captures another 
private bookmark (A2). 

User B opens the 
analysis using the 
Web Player. The 
analysis is opened in 
the saved state. 
Public bookmark A3 
is available. 

  
Public bookmarks can be used as starting points for end users of an analysis. The captured states 
may guide users to interesting aspects in an analysis, or they might be used for navigation as an 
alternative to pages or links. By sharing captured states with other users you may also induce 
discussions of the insights made during analysis. 

Private and public bookmarks as building blocks in action links: 

 

User A captures a private bookmark (A1) 
in TIBCO Spotfire and ties it to an action 
link, then saves the analysis to the library. 

User B opens the analysis using the Web 
Player. The action link sets bookmark state. 
No bookmark is available to user B. 
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User A captures a public bookmark (A2) in 
TIBCO Spotfire and ties it to an action 
link, then saves the analysis to the library. 

User B opens the analysis using the Web 
Player. The action link sets bookmark state. 
Bookmark A2 is available. 

  
Both private and public bookmarks can be used as building blocks in action links/buttons when 
setting up a guided analysis for other users. The action links/buttons typically guide users to 
insights or relevant starting points in the analysis. This also enables a way to include some 
restricted interaction possibilities in the application and a possibility to hide controls such as the 
filters panel. 

Send private bookmark to colleague: 

 

User A captures private bookmarks (A1 & A2) 
in the Web Player and wants to inform a 
colleague about insights captured in A1. 

User B clicks link in email, which 
opens the analysis in the Web Player. 
The analysis is opened in A1 state. No 
bookmark is available. 

  
A private bookmark can be used to pass on a captured insight to a specific colleague or group of 
colleagues only. This can easily be done by sending a URL that points to an analysis in a 
particular (bookmark) state. 

Send public bookmark to colleague: 

 

User A captures public bookmarks (A3 & A4) in 
the Web Player and wants to inform a colleague 
about insights captured in A3. 

User B opens the analysis using the 
Web Player. The analysis is opened 
in A3 state. Both A3 and A4 are 
available. 

  
Public bookmarks can also be referred to directly using a link. 



TIBCO Spotfire 4.0.2 - User's Manual 

866 

Offline collaboration: 

 

User A captures a private bookmark (A1) in 
TIBCO Spotfire and ties it to an action link, then 
saves the file and sends it to a colleague. 

User B opens the analysis in TIBCO 
Spotfire. The action link sets the 
bookmark state. No bookmark is 
available to user B so A1 cannot be 
updated by user B. 

  
  

 

User A captures a public bookmark (A2) in 
TIBCO Spotfire and ties it to an action link, then 
saves the file and sends it to a colleague. 

User B opens the analysis in TIBCO 
Spotfire. The action link sets the 
bookmark state. Bookmark A2 is 
available. 

10.4 Bookmarks Pop-up Menu 
Right-click on a bookmark to bring up the pop-up menu. You can always apply any bookmarks 
that are visible to you in an analysis, but whether or not you can add new bookmarks, or update, 
delete and otherwise modify existing ones depends on permissions defined by the creator of the 
analysis as well as your licenses. See Permissions to learn more. 

Option Description 

Apply Sets the analysis to the state defined by the bookmark. 

Apply Special Allows you to apply only a part of a bookmark. Select one or more of 
the following parts: 
Page Layout and Visualizations – Applies the same layout and setup 
of the visualizations as when the bookmark was captured. This 
includes all specified visualization properties. For example, selections 
on the axes of a visualization, coloring, formatting, and which 
visualization features are shown or hidden. 
Active Page – Sets the active page to the page that was active when 
the bookmark was captured. 
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Active Visualization – Sets the active visualization to the visualization 
that was active when the bookmark was captured. 
Filter Settings – Sets the filtering and filter types to those used when 
the bookmark was captured. You need to select Set all filters, Set only 
adjusted filters, or Mark filtered rows from the submenu. See below 
for a description of these alternatives. 
Filter Organization – Sets the layout of the filters panel (sort order, 
filter groups, hidden filters) to the same as when the bookmark was 
captured. 
Markings – Marks the items that were marked in the visualizations 
when the bookmark was captured. Note that you can only apply this 
part of a bookmark if you use the same marking in the visualizations as 
when the bookmark was captured. 
Properties – Applies any editable document, data table, and column 
properties used on the active page, as well as any property values 
referred to in a property control. 

Rename Allows you to change the name of the selected bookmark. 

Copy Bookmark 
URL 

Allows you to copy and share URLs pointing to a specific bookmark 
state for an analysis. Select one of the link types listed below. See 
Links to Analyses in the Library for more information about the 
different link types. Note that Copy Bookmark URL is only available 
when the bookmark has been stored in the library. 

   Direct TIBCO 
Spotfire URL 

Copies the URL for the analysis at the state of the selected bookmark, 
so that a link can be used to open the analysis directly using TIBCO 
Spotfire Professional. Select this option if you want to send your 
insights to a fellow analyst working in TIBCO Spotfire. 

   Web Player URL Copies the URL for the analysis at the state of the selected bookmark, 
so that a link can be used to open the analysis using TIBCO Spotfire 
Web Player. Select this option if you know that your target audience 
all use TIBCO Spotfire Web Player. 

   Redirect Page 
for Unknown 
Clients 

Copies a link to a redirect page where the end users of the link can 
choose whether they want to open the analysis using TIBCO Spotfire 
Professional or the Web Player. Select this option if you do not know 
what type of clients are available for the audience of the link or if you 
do know that some of the people have access to TIBCO Spotfire 
Professional and some have only the TIBCO Spotfire Web Player. For 
example, use this option to publish a URL in a blog post which can be 
read by people from many departments and at different positions in 
your company. 

Private Bookmark Makes the selected bookmark private. 

Public Bookmark Makes the selected bookmark public. 

Save as Private 
Bookmark 

Creates a private copy of the selected bookmark. 

Update Bookmark Updates the bookmark to the current state in the analysis. Note that if 
you have captured a partial bookmark, only the parts included in the 
original bookmark will be updated. 

Delete Deletes the selected bookmark. 
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Filter Settings Submenu 

Option Description 

Set All Filters Applies the exact filter settings for the active filtering scheme, as 
stored in the bookmark. 

Set Only Adjusted 
Filters 

Keeps everything as it is in the filters panel except for those filters that 
were changed in the bookmark, which are updated. 

Mark Filtered 
Rows 

Uses the filter condition from the bookmark to mark rows in the 
analysis, but leaves the filtering exactly as it was before applying the 
bookmark. 

10.5 Details on Add Bookmark Special 
This dialog allows you to select exactly which bookmark parts to include in your bookmark. 

 

Option Description 

Name The name of the bookmark. 

Include Select the bookmark parts you want to capture in your bookmark. 
Page Layout and Visualizations – Captures the layout and the setup 
of the visualizations on the active page. This includes all specified 
visualization properties. For example, selections on the axes of a 
visualization, coloring, formatting, and which visualization features are 
shown or hidden. 
Active Page – Captures which page is active when the bookmark is 
captured. 
Active Visualization – Captures which visualization is active when the 
bookmark is captured. 
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Filter Settings – Captures the filtering and filter types used on the 
active page. 
Filter Organization – Captures the layout of the filters panel (sort 
order, filter groups, hidden filters). 
Markings – Captures which items are marked in the visualizations in 
the bookmark. Note that the active marking for a visualization is 
included in the Page Layout and Visualizations bookmark part. 
Properties – Captures any editable document, data table, and column 
properties used on the active page, as well as any property values 
referred to in a property control. 

Select All Click this button to select all check boxes. 

Deselect All Click this button to clear all check boxes. 

10.6 3.2 Bookmarks 
10.6.1 What are 3.2 Bookmarks? 

In TIBCO Spotfire 3.3, a new version of the bookmarks functionality was created in order to 
allow the capturing of visualization properties along with the previously available settings for 
page, filtering, marking, etc. See What are Bookmarks? for information about the new 
bookmarks. However, for compatibility reasons, you can go back to use the 3.2 version of the 
bookmarks instead. 

► To use the 3.2 bookmarks panel: 
1. Select Tools > Options. 
2. Go to the Compatibility page. 
3. Select the Use 3.2 bookmark panel check box. 

Response: The next time you open the bookmarks panel it will use the 3.2 style and 
behavior. (If the new bookmarks panel is open you need to close it and reopen to see 
the change.) 

► To convert 3.2 bookmarks to new bookmarks: 
If an older analysis containing bookmarks is opened in TIBCO Spotfire 3.3 or later, and you are 
using the new Bookmarks popover or panel, a link will be shown at the bottom of the popover 
or panel. Click Convert to transform all old-type bookmarks to the new type. If you want to 
display the old bookmarks without converting them, you can go to Tools > Options, 
Compatibility page and select the Use 3.2 bookmark panel check box. Clear the check box to 
see the new type bookmarks. 

Description of 3.2 Bookmarks 
Bookmarks are snapshots of the state of an analysis, which can be applied at any time, allowing 
you to return to a previously created view of the data.  A bookmark can update one or more of 
the following: what rows to be marked, the page and visualization to be active and what 
filtering to be applied. The bookmarks can optionally be sorted into different folders. 
One of the most important uses of bookmarks is that they can be included as links in a text area. 
This helps you to create guided analyses where the recipient of your analysis file can click on 
action links to quickly move through several different views of the analysis. 
Bookmarks are managed in the bookmarks panel, which can be displayed by clicking on the 

Bookmarks button on the toolbar, , or by selecting View > Bookmarks. The visibility of 
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the bookmarks panel is controlled per page. The panel visibility of new pages is inherited from 
the active page. 

 
If a bookmark becomes invalid, for example if the active page in the bookmark has been 
deleted, a red error provider is shown: 

 
Tip: The 3.2 bookmarks do not save the state of visualization properties, such as what column 
to use on an axis, what column to color by, etc. If you want to guide a user through visualization 
of different states, duplicate the visualization and create one visualization for each state instead. 
The duplicates can be moved by dragging and dropping on different pages, if desired. 
  

10.6.2 How to Use 3.2 Bookmarks 
In TIBCO Spotfire 3.3, a new version of the bookmarks functionality was created in order to 
allow the capturing of visualization properties along with the previously available settings for 
page, filtering, marking, etc. See What are Bookmarks? for information about the new 
bookmarks. However, for compatibility reasons, you can go back to use the 3.2 version of the 
bookmarks instead. 

► To use the 3.2 bookmarks panel: 
1. Select Tools > Options. 
2. Go to the Compatibility page. 
3. Select the Use 3.2 bookmark panel check box. 

Response: The next time you open the bookmarks panel it will use the 3.2 style and 
behavior. (If the new bookmarks panel is open you need to close it and reopen to see 
the change.) 

► To convert 3.2 bookmarks to new bookmarks: 
If an older analysis containing bookmarks is opened in TIBCO Spotfire 3.3 or later, and you are 
using the new Bookmarks popover or panel, a link will be shown at the bottom of the popover 
or panel. Click Convert to transform all old-type bookmarks to the new type. If you want to 
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display the old bookmarks without converting them, you can go to Tools > Options, 
Compatibility page and select the Use 3.2 bookmark panel check box. Clear the check box to 
see the new type bookmarks. 

► To add a new 3.2 bookmark: 
1. Click on the Capture Bookmark button, , on the toolbar or in the bookmarks panel. 
2. Type a Name for the bookmark. 
3. Optionally, type a Description with details about the bookmark. 
4. Click OK. 

Response: The bookmark is added to the bookmarks panel and it can be used when 
adding links to a text area. 

► To apply a 3.2 bookmark: 
1. If the bookmarks panel is not already visible, select View > Bookmarks. 
2. In the bookmarks panel, double-click on the bookmark of interest or click on the 

bookmark of interest and then click on the Apply button, . 
Comment: Bookmarks can also be added to links or buttons in a text area. In that case, 
clicking on the link or button in the text area will apply the bookmark. 
Comment: You can also choose to apply just a part of the bookmark by clicking on one 
of the bookmark components and then click Apply. For the filter settings component, 
you can select a few different apply methods from the pop-up menu. 

► To add a 3.2 bookmark to a link or button in a text area: 
1. Make sure that you have created a bookmark according to the steps above. 

2. Create a text area by clicking on the New Text Area button, . 
Response: An empty text area is displayed. 

3. Right-click on the text area and select Edit Text Area from the pop-up menu. 
4. Type any explaining text in the text field, and where you want the bookmark-link to be 

placed, click on the Insert Action Control button, . 
Response: The Action Control dialog is displayed. 

5. On the Actions page, type a Display text to be used as the link or button text in the 
text area. 

6. Select the Control type from the drop-down list: Link or Button. 
7. In the Available actions list, click on the plus-sign next to Bookmarks to expand the 

list, and then click on the desired bookmark. 
8. Click Add. 

Response: The bookmark is added to the Selected actions list. 
Comment: If desired, you can add more actions to the same link. 

9. Click OK. 
Response: The link or button is added to the text area. 

10. Exit the text area edit mode to test the link or button. 

► To update a 3.2 bookmark: 
1. If the bookmarks panel is not already visible, select View > Bookmarks. 
2. Right-click on the bookmark you wish to update and select Update... from the pop-up 

menu. 
Response: A dialog asking you if you are sure you want to update the bookmark is 
displayed. 

3. Click OK. 
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Response: The bookmark components available in the bookmark are updated with the 
current analysis settings. 
Comment: It is normally recommended to update complete bookmarks instead of 
separate bookmark components. If you still choose to update a separate part of the 
bookmark, note that there may be some deviations between what is shown and what is 
actually applied. For example, the active visualization always takes precedence before 
the active page, so if the active visualization is on a different page than the one 
currently specified by the bookmark component, you will not end up on the page 
currently set as a bookmark component. 

► To delete a 3.2 bookmark: 
1. If the bookmarks panel is not already visible, select View > Bookmarks. 
2. Click on the bookmark you wish to delete. 

3. Click on the Delete button, . 

► To organize 3.2 bookmarks into folders: 
1. If the bookmarks panel is not already visible, select View > Bookmarks. 

2. Click on the Create New Folder button, . 
Response: The New Folder dialog is displayed. 

3. Type a Folder name and click OK. 
4. Use drag-and-drop to move bookmarks and folders between folders. 

  

10.6.3 Details 

10.6.3.1 Details on New Folder (3.2 Bookmarks) 
If your analysis contains many 3.2 bookmarks, they can be arranged in separate folders to help 
locate specific bookmarks in the bookmarks panel. 

► To create a new folder: 
1. In the Bookmarks panel, click on the Create New Folder button, . 

Response: The New Folder dialog is displayed. 
2. Type a name for the new folder. 

Comment: You can rename a previously created folder by right-clicking on it in the 
bookmark panel and selecting Edit... from the pop-up menu. 

 

Option Description 

Folder name Specifies the name of the new folder. 
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10.6.3.2 Details on Capture Bookmark (3.2 Bookmarks) 

► To reach the Capture Bookmark dialog: 
1. Click on the Capture Bookmark button, , on the toolbar or in the Bookmarks 

panel. 

 

Option Description 

Name The name of the bookmark. 

Description Optional. A description of the bookmark and its contents. 

  

10.6.3.3 Details on Edit Bookmark (3.2 Bookmarks) 

► To reach the Edit Bookmark dialog: 
1. If the Bookmarks panel is not already visible, select View > Bookmarks. 

2. In the Bookmarks panel, click on the Edit button, . 
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Option Description 

Name The name of the bookmark. 

Description Optional. A description of the bookmark and its contents. 

Created by Shows the username who created the bookmark in the first place. 

Created Shows the date when the bookmark was created. 

Modified Shows the date when the bookmark was last modified. 

Note: To update the settings of a previously added bookmark, right-click on the bookmark in 
the Bookmark Panel and select Update.... This will update the selected bookmark components 
with the current settings. 
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11 Lists 
11.1 What are Lists? 

Lists represent captured knowledge from one or many data sources. For example, you may have 
identified a number of transactions where the sum of cost was high. You can then create a list 
containing the rows representing these transactions. This will make it easier to access the 
interesting items for further analysis based on the findings. See Creating Lists, to learn more 
about adding new lists. 
Lists are available from one session to the next and are automatically saved when you modify 
them. Lists are similar to Tags, but with Lists you work with the same collection of lists all the 
time, while Tags are specific to the current analysis. Combining the functionality from Lists and 
Tags can be very useful. You can create tag collections from lists, and you can create lists from 
tag collections. This means that Lists can be a way to transfer knowledge from one analysis to 
another, while Tags can be a way to use lists within an analysis. See What are Tags? and 
Creating Tag Collections from Lists to learn more. 
You can view and manage lists in a popover, in a docked panel, or as a floating window. See 
Panels and Popovers 

for more information. Click on the Lists button on the toolbar, , or select View > Lists to 
open Lists. The Lists panel or popover will open in the mode it was opened the last time you 
had it open. The image below shows the docked Lists panel. 
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The Lists panel user interface 

 

Number Description 

1 Toolbar 

2 Identifier Selector 

3 Lists 

4 List Items 

5 Search Field 

Toolbar 
The toolbar, consisting of buttons and a menu, is located in the upper part of the panel. You can 
perform most of the actions in the Lists panel from the toolbar. 
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Identifier selector 
The identifier column selector is where you select which column in the data set to use as the 
identifier. You can choose the identifier from any column that contains any of the following 
types: string, integer, longinteger, or date. In the example above, the column "Number" was 
selected. It contains values representing ID numbers of sales transactions. The values in the 
chosen column are the ones that are displayed as list items when you select one or more lists. 

Lists 
The collection of lists has a hierarchical structure where the top level, named "Lists", cannot be 
removed. In the example above, five lists have been added on the level below the top level. Two 
of them, "High Cost Transactions" and "High Sales Transactions" contain three sublists each. 
You can expand and collapse lists with sublists by clicking on the +/- sign to the left of the list 
name. The number of items in a list is displayed to the right of the name. In the example above, 
the selected list (highlighted in blue) "High Cost Transactions" does not contain any list items 
itself, but its sublists do, as can be seen in the parentheses beside the sublists' names: Fruit (6), 
Spices (4), and Vegetables (10). To view the items of a list, click on the list to select it. The 
items will then be displayed in the lower part of the panel. To learn more about selecting lists, 
see Selecting Lists and List Items. 

List items 
In the lower part of the panel, the list items of the selected lists are displayed. In the example 
above, the items of the "High Cost Transactions" list are displayed. To learn more about how to 
select lists and items, see Selecting Lists and List Items. 

Search field 
You can search lists, list items, and annotations by entering a text string in the search field. To 
learn more about searching in the Lists panel, see Searching the Lists Panel. 

Read-only mode 
As mentioned, you always work with the same list collection. This means that if more than one 
instance of Spotfire is open, you can only modify lists and items in one of these instances. The 
Lists panel will be in read-only mode in the other Spotfire instances. This is indicated by the 

read-only button, , on the toolbar. Click on the button to update the Lists panel view in case 
it was modified in the other instance. When a read-only instance of the Lists panel becomes 

available for editing again you must click the button, , before you can make any changes. 
  

11.2 How to Use Lists 
11.2.1 Selecting Lists and List Items 

To select a list or item of interest, click on it. To select many lists or items, press Ctrl or Shift 
while clicking. You can also use Ctrl + click to deselect lists or items. 
You can choose whether to show or hide all sublist items of a selected list. In the example 
below, the panel to the left shows the selected list’s items, but not the sublists’ items. The panel 
to the right displays the selected list’s items as well as the sublists’ items. 
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► To show/hide sublist items: 
1. On the Lists toolbar, select Menu > Show All Sublists. 

Response: All the items in the sublists of the selected list or lists are displayed in the 
lower part of the panel. 

  

11.2.2 Marking Items in Visualizations 
You can mark items in visualizations by interacting with lists or list items in the panel. 

► To mark items in visualizations: 
1. Make sure you have selected the correct identifier column in the drop-down list. 
2. Select the lists or list items of interest in the Lists panel. 
3. On the Lists toolbar, select Menu > Mark Items. 

Response: The items corresponding to the selected lists or list items are marked in the 
visualizations. 
Comment: You can also double-click on a list or list item to mark the corresponding 
items in the visualizations. 

► To mark items automatically: 
1. On the Lists toolbar, select Menu > Mark Automatically. 

Response: When you click on a list or list item, the corresponding rows will now 
become marked automatically. 
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11.2.3 Creating Lists 
You can create new lists in two ways. One way is to mark items in a visualization and make a 
new list based on these. Another way is to add a list from list logic, which means that you create 
a new list by comparing existing lists using boolean operators. This lets you determine which 
list items are present or not in a certain combination of lists. The result of the comparison is 
then added as a new list in the Lists panel. 

► To add a list from marked items: 
1. If Lists are not already visible, select View > Lists. 
2. Select a list under which you want the new list to be added. To learn more about how 

to select lists and list items, see Selecting Lists and List Items. 
3. In the visualization, mark the items you want to include in the new list. 
4. Right-click in the visualization to display the pop-up menu. 
5. Select Marked Rows to open the submenu. 
6. Select New List from Marked.... 

Response: The New List from Marked dialog is opened. 
7. In the Name field, type a name to use for the list. 
8. Optionally, select a column to group the list by. 

Comment: If you select to group the list by a column, then the new list will have 
sublists, one sublist for each value in the column. 

9. Click OK. 
Response: The new list is added as a sublist in the selected list. If more than one list is 
selected, the new list will be added on the hierarchical level below the closest common 
parent of the two lists. 

Example: 

 
In the example above, two lists which are not on the same hierarchical level are selected. If you 
add a list from these selections, the new list will be added to the level just beneath the closest 
common parent of the selected lists; in this case, High Cost Transactions. If the two selected 
lists are on the same hierarchical level, the new list will be added on the same level as the 
selected lists. 

► To add a list from List Logic: 
1. If Lists are not already visible, select View > Lists. 
2. Optionally, select the lists you want to compare in the Lists panel. 

3. Click on the New List from List Logic button on the Lists panel toolbar, . 
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Response: The New List from List Logic dialog is opened. If you selected one or more 
lists in the panel before opening the dialog, the check boxes corresponding to these 
lists will be selected in the dialog. 

4. Type a Name to use for the list in the provided text field. 
5. In the Lists to use list, choose which lists to compare by selecting the corresponding 

check boxes. 
Comment: When you select a list, all its sublists are automatically included in the 
selection. Clear the check boxes for the sublists you do not want to include. 

6. Under Include items appearing, select one of the three methods of logical operation 
to use when comparing the previously selected lists. 
Comment: You can select either In all lists (AND), In any list (OR), or ONLY in this 
list. If you select ONLY in this list, you need to select a list in the drop-down menu. 

7. When done, click OK to close the dialog. 
Response: The new list is added in the Lists panel. Note that lists created from List 
Logic are always added to the top level in the list hierarchy. 

11.2.4 Modifying Lists 
You can modify existing lists in a number of ways, which are described below. For more 
information, see separate sections about Importing Lists and Items and Exporting Lists and 
Items. 

Rearranging the lists and items 
Use drag and drop to change the order of lists and/or list items in the Lists panel. You can move 
several lists or items at a time. Just select the ones of interest and drag them to the desired 
location. 

Sorting list items 
To sort the items in a list, right-click on that list and select Sort List Items from the pop-up 
menu. If a list contains sublists, you will need to sort each sublist separately. 

► To add marked items to a list: 
You can add items to an existing list by marking rows in a visualization. 

1. If Lists are not already visible, select View > Lists. 
2. Select the list to which you want to add items. 

Comment: You can only add items to one list at a time. To learn more about how to 
select lists, see Selecting Lists and List Items. 

3. In the visualization, mark the items of interest. 
4. Right-click in the visualization to display the pop-up menu. 
5. Select Marked Rows > Add Marked to List.... 

Response: The marked rows are added as items to the selected list. The added items 
are selected in the lower part of the panel to make it easier to see which ones were 
added. 

► To remove marked rows from a list: 
You can remove items from an existing list by marking rows in a visualization. 

1. If Lists are not already visible, select View > Lists. 
2. Select the list from which you want to remove items. 

Comment: You can only remove items from one list at a time. To learn more about 
how to select lists, see Selecting Lists and List Items. 

3. In the visualization, mark the rows of interest. 
4. Right-click in the visualization to display the pop-up menu. 
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5. Select Marked Rows > Remove Marked from List.... 
Response: Items that correspond to the marked rows and are present in the selected list 
are removed from that list. 
Comment: Items in sublists will not be removed. 

► To delete lists or list items: 
1. If Lists are not already visible, select View > Lists. 
2. Right-click on the list or item you want to delete. 
3. Select Delete from the pop-up menu. 
4. Click Yes in the dialog that opens. 

Response: The selected list (including any sublists) or list item is removed. 
Comment: Alternatively, you can select the lists or items you wish to delete and press 
the Delete key. 

► To cut, copy, and paste in the panel: 
1. If Lists are not already visible, select View > Lists. 
2. Click on the list or item you want to cut or copy. 

Comment: Press Ctrl and click to select multiple objects in the Lists panel. 
3. Right-click to open the pop-up menu. 
4. Select Cut or Copy. 

Response: The selected object is placed on the clipboard. If you selected Cut, the 
selected object is also removed from the panel. 

5. Right-click on the list to which you want to paste the contents of the clipboard. 
6. Select Paste from the pop-up menu. 

Response: The list or list item is pasted into the selected location in the Lists panel. 
Tip: List items can also be pasted into tools outside of Spotfire, such as a text editor. 

  

11.2.5 Importing Lists and Items 
You can import lists or list items previously exported from TIBCO Spotfire or TIBCO Spotfire 
DecisionSite. List files exported from Spotfire have the extension .lists, while list files from 
DecisionSite have the extension .srp or .xml. List item files always have the extension .lst when 
exported from either Spotfire or DecisionSite. 

► To import lists: 
1. If Lists are not already visible, select View > Lists. 
2. In the panel, select the list to which you want to add the imported list. 

Comment: You can only import to one list at a time. To learn more about how to select 
lists and list items, see Selecting Lists and List Items. 

3. Open the Menu, and select Import > Lists.... 
4. In the Import Lists dialog, locate the list file of interest. 
5. Click Open. 

Response: The imported lists appear in the specified location in the Lists panel. 

► To import list items: 
1. If Lists are not already visible, select View > Lists. 
2. In the panel, click to select the list to which you want to add the imported list items. 

Comment: You can only import to one list at a time. 
3. Open the Menu, and select Import > List Items.... 
4. In the Import List Items dialog, locate the list item file of interest. 
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5. Click Open. 
Response: The imported list items appear in the specified location in the Lists panel. 

11.2.6 Exporting Lists and Items 
You can export lists or list items to a file. When you export an entire list, the structure is kept 
exactly as it appears in the Lists panel or popover, including any sublists. You can export many 
lists to the same file. Exported lists get the file extension .lists. 
When you export individual list items, the items will be listed in the exported file with no 
structure from the original list preserved. This means that if you export all the list items from a 
list with sublists, you will be unable to see which sublist the individual items belonged to. 
Exported list item files get the extension .lst. 

► To export lists: 
1. If Lists are not already visible, select View > Lists. 
2. Select the list or lists you want to export. Sublists are automatically included when you 

click on a list header. 
Comment: To select more than one list, press Ctrl and click on the lists to include. To 
learn more about how to select in the Lists panel, see Selecting Lists and List Items. 

3. Open the Menu, and select Export > Selected Lists.... 
4. Specify a file name and a location where you want to save the list or lists. 
5. Click Save. 

Response: The file is saved to the specified location. 

► To export list items: 
1. If Lists are not already visible, select View > Lists. 
2. Select the list or lists in the upper part of the Lists panel. 
3. In the lower part of the Lists panel, select the list items you want to export. 

Comment: To select more than one list or item, press Ctrl and click on the lists or 
items to include. See Selecting Lists and List Items to learn more. 

4. Open the Menu, and select Export > Selected List Items.... 
5. Specify a file name and a location where you want to save the list items file. 
6. Click Save. 

Response: The items or lists are saved as an LST file at the specified location. 

11.2.7 Creating Tag Collections from Lists 
You can create tag collections from one or more lists. Tag collections created from Lists work 
in the same way as those created in the Tags panel. To learn more about tags, see What are 
Tags? 

► To create a new tag collection: 
1. If Lists are not already visible, select View > Lists. 
2. Select the lists you want to include in the new tag collection. 

3. Click the Create Tag Collection button, , on the Lists toolbar. 
Response: A new tag collection, named Lists Tag Collection, is added to the tag panel. 
A corresponding column is also added to the data table. 

Note: Tag collections have flat structures. This means that if you create a tag collection from 
lists containing sublists, their hierarchical structure will not be preserved in the tag collection. 
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11.2.8 Searching the Lists Panel 
You can search for lists, list items, and annotations by entering a search string in the search field 
located at the bottom of the Lists panel or popover. 

 
Searching for a simple text string, as in the example above, will by default look for matching 
text in the names of lists and list items. You can use wildcards and boolean operators to search 
for parts and combinations of words. For a listing of the basic search syntax, see Searching in 
TIBCO Spotfire. See below for a listing of search properties specific to Lists. 
When you search for a specific word or combination of words, the results will be the list or lists 
that contain your search terms. The matching lists will be bolded in the upper part of the panel 
as in the example below. 

 
If you were searching for individual list items, click on the bolded lists to see those list items 
that match your search. You can use the arrow buttons on the right-hand side of the search field 
to step through the search matches. 

Lists specific search: 

Keyword Example Function 

<text string> fruit Locates lists and list items with the 
specified word (or word part) in the 
name. 

name:<name of 
list or list item> 

name:apple 
  
name::apple 

Locates lists and list items with the 
specified word in the name. 
The first example will return all lists and 
list items containing your search string, 
such as “Apple”, “apples”, “apples and 
bananas”, and so on. 
The second example will return only 
lists and list items which match your 
search string exactly. 

list:<name of 
list> 

list:fruit Locates lists with the specified word (or 
word part) somewhere in the name. 

lists:<number of 
lists> 

lists:2 
  
lists:>2 

Locates lists that contain the specified 
number of sublists. Note that a sublist 
will only count as one list even if that 
sublist itself contains sublists. 
The first example will return lists 
containing exactly two sublists, while 
the second example will return lists with 
two sublists or more. 
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item:<name of 
list item> 

item:apple Locates lists that contain list items with 
the specified word (or word part) 
somewhere in the name. 

items:<number 
of list items> 

items:14 
  
items:<14 

Locates lists that contain the specified 
number of list items. Note that the 
number of items is always calculated on 
individual lists. 
The first example will return lists 
containing exactly 14 items, while the 
second example will return lists with 14 
items or fewer. 

annotation: 
<content of 
annotation> 

annotation:important Locates lists or list items with an 
annotation containing the specified 
words. 
Note: If the annotation has a specified 
name, you need to use the search 
property described below instead. 

<annotation 
name>:<content 
of annotation> 

"sum of sales":"below 8,000" Locates lists or list items with the 
specified annotation name and where 
the annotation contains the specified 
words. Note that you must provide the 
entire annotation name and enclose it in 
quotation marks. 

type:<type of 
wanted search 
matches> 

type:list 
type:item 

The first example will locate all the lists 
in the panel. The second example will 
locate all the list items. 
This search property is especially useful 
in combination with other search 
properties. For example: 
type:list AND annotation:important 
This will find all the lists where the 
annotation contains the word 
"important". 

► To display the search field: 
1. On the Lists toolbar, click on the Toggle Search Field button, . 

OR 
2. Select Menu > Search.... 

Response: The search field is displayed at the bottom of the Lists panel or popover. 

► To hide the search field: 
1. On the Lists toolbar, click on the Toggle Search Field button, . 

OR 

2. To the right of the search field, click on the Hide Search Field button,  . 
Response: The search field is hidden. 

You can also perform a search based on marked items in a visualization. This is a way to find if 
any of the items that you have marked in a visualization are also included in any of the lists in 
the lists collection. 
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► To search for marked items in lists: 
1. Mark the items of interest in a visualization. 
2. Right-click in the visualization to display the pop-up menu. 
3. Select Marked Rows > Search Marked in Lists. 

Response: The matching lists are bolded in the upper part of the panel. In the search 
field, a search string corresponding to the marked rows will be displayed, as seen 
below. 

 

11.2.9 Working with Annotations 
You can add annotations to both lists and list items. To view annotations, hover with the mouse 
pointer over the list or list item of interest. A tooltip with the annotations will appear, as seen in 
the example below. 

 
The tooltip shows the name of the list, "High Cost Transactions", followed by the annotation 
text. "Sum of Cost" is the name of the annotation, but specifying a name is optional. If you add 
many annotations to the same list or list item, the annotations will be listed vertically after each 
other in the tooltip. It is possible to search for lists and list items with a particular annotation. 
See Searching the Lists Panel to learn more about how to search for lists with annotations. 

► To add a new annotation: 
1. If Lists are not already visible, select View > Lists. 
2. Right-click on the list or list item to which you want to add an annotation. 
3. Select List Properties or List Item Properties from the pop-up menu. 

Response: Depending on whether you clicked on a list or a list item, either the List 
Properties dialog, or the List Item Properties dialog is opened. 

4. Click on the New... button. 
Response: The New Annotation dialog is opened. 

5. Enter the annotation in the Annotation text field. 
Comment: Press Ctrl + Enter to get a line break in the annotation text. 

6. Optionally, enter a name in the Name field. 
7. When done, click OK. 

Response: The annotation is added to the Annotations list. 
8. To add more annotations to the same list or list item, repeat steps 4 to 7, and click OK 

when done. 
Response: The annotations are added to the selected list or list item. 

► To edit an annotation: 
1. If Lists are not already visible, select View > Lists. 
2. Right-click on the list or list item with the annotation you want to modify. 
3. Select List Properties or List Item Properties from the pop-up menu. 

Response: Depending on whether you clicked on a list or a list item, either the List 
Properties dialog, or the List Item Properties dialog is opened. 
Select the annotation you want to edit in the Annotations list. 

4. Click on the Edit... button. 
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Response: The Edit Annotation dialog is opened. 
5. Make the desired changes in the Annotation and Name fields. 
6. When done, click OK. 

Response: The annotation is updated in the Annotations list. 
7. To edit other annotations for the same list or list item, repeat steps 4 to 7, and click OK 

when done. 
Response: The annotations for the selected list or list item are updated. 

► To remove an annotation: 
1. If Lists are not already visible, select View > Lists. 
2. Right-click on the list or list item with the annotation you want to remove. 
3. Select List Properties or List Item Properties from the pop-up menu. 

Response: Depending on whether you clicked on a list or a list item, either the List 
Properties dialog, or the List Item Properties dialog is opened. 

4. Select the annotation you want to remove in the Annotations list. 
5. Click on the Delete button. 

Response: The annotation is removed from the Annotations list. 
6. To remove more annotations for the same list or list item, repeat steps 4 and 5. 
7. Click OK when done to close the dialog. 

11.3 Details 
11.3.1 Details on New List from Marked 

► To reach the New List from Marked dialog: 
1. If Lists are not already visible, select View > Lists. 
2. Make sure the items you want to include in the list are marked in the visualizations, 

and select a location for the new list. 
Comment: See Selecting Lists and List Items to learn more about how to specify a 
location for the new list. 

3. Click the New List from Marked button, , on the Lists toolbar. 

 

Option Description 

Name The name of the new list. 

Group list by Specifies a column to group the items in the list by. The new list will 
be divided into a number of sublists; one sublist for each value in the 
selected column. 
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11.3.2 Details on New List from List Logic 
► To reach the New List from List Logic dialog: 

1. If Lists are not already visible, select View > Lists. 

2. Click the New List from List Logic button, , on the Lists toolbar. 

 

Option Description 

Name The name of the new list. 

Lists to use Displays the available lists. Select the lists from which you want to 
create a new list. 

Include items 
appearing 

  

   In all lists (AND) Creates a new list containing only those items present in all of the 
selected lists. 

   In any list (OR) Creates a new list containing all items present in any of the selected 
lists. Each item will appear only once in the new list, even if that item 
is present in several of the selected lists. 

   ONLY in this list Creates a new list containing only those items present in the list that 
has been selected in the drop-down list, and not any of the other lists. 
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11.3.3 Details on List/List Item Properties 
► To reach the List/List Item Properties dialog: 

1. If Lists are not already visible, select View > Lists. 
2. Right-click on the list or list item of interest. 
3. From the pop-up menu, select List Properties or List Item Properties. 

 

 

Option Description 

Name The name of the list or list item as it will be displayed in the Lists 
panel. 

Annotations Lists the annotations, if any, for the list or list item. 

New... Opens the New Annotation dialog, where you can define new 
annotations for the list or item. 

Edit... Opens the Edit Annotation dialog where you can edit the selected 
annotation. 

Delete Removes the selected annotation from the list or item. 
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11.3.4 Details on New/Edit Annotation 
► To reach the New/Edit Annotation dialog: 

1. If Lists are not already visible, select View > Lists. 
2. Right-click on the list or list item of interest. 
3. From the pop-up menu, select List Properties or List Item Properties. 

Response: Depending on whether you clicked on a list or a list item, either the List 
Properties dialog, or the List Item Properties dialog is opened. 
To create a new annotation, click on the New... button. To edit an existing annotation, 
select the annotation to edit in the Annotations list, and then click on the Edit... 
button. 

 

 

Option Description 

Annotation The contents of the annotation. 

Name An alias for the annotation can be entered here. This is optional. 
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12 Collaboration 
12.1 Collaboration Panel 
12.1.1 What is the Collaboration Panel? 

The collaboration panel is a tool that allows you to view web pages in Spotfire. This is useful, 
for instance, if you use some kind of web based collaboration tool, such as tibbr®, a 
communication and collaboration tool designed for the workplace, enabling users to collaborate 
by participating in communication threads about different subjects. 

 
You can configure the Collaboration to go to different URLs on different pages in the analysis, 
thus making it possible to follow several different subjects within a single analysis. 
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12.1.2 How to Use the Collaboration Panel 
► To show and hide the Collaboration Panel: 

1. Click the Collaboration Panel icon, , in the status bar or select View > 
Collaboration. 
Response: The Collaboration Panel will be shown or hidden. 

► To configure the Collaboration Panel: 
1. In the Collaboration Panel, click the configure icon in the bottom left corner.  

Response: The Configure Collaboration Panel dialog will open. 
2. Type or paste the URL of interest in the dialog. 

Comment: The Collaboration Panel is configured per page in the analysis, so you can 
link the Collaboration Panel on different pages to different URLs. 

3. Click OK. 

12.1.3 Details on Configure Collaboration Panel 
To configure the Collaboration Panel, you can enter a URL to a web page that TIBCO Spotfire 
will show in the Collaboration Panel. 
In TIBCO Spotfire, the Collaboration Panel will run an instance of the Internet Explorer 
rendering engine installed on the machine to parse content. 
In TIBCO Spotfire Web Player, the Collaboration Panel will open in an iframe and use the same 
rendering function available to the rest of the Web Player. If the Collaboration Panel is used in 
both TIBCO Spotfire and the Web Player, this could potentially lead to differences in html 
rendering between different web browser versions. 
Note: The Collaboration Panel is configured per page in the analysis, so you can link the 
Collaboration Panel on different pages to different URLs. 

 

Option Description 

URL Type or paste the URL to the web page of interest here. 

 
  



TIBCO Spotfire 4.0.2 - User's Manual 

892 

Example: 
You can use the collaboration panel to integrate with tibbr®. For example, you may want to 
follow and post to a certain tibbr subject thread and show that thread in the collaboration panel. 
To show a tibbr subject thread in the collaboration panel, the URL should be in the following 
format: 
http(s)://<tibbr server>/a/gadgets/subject_messages.html?id=<subject>&name=<subject> 
where <tibbr server> and <subject> should be replaced by your tibbr server and subject of 
choice. Also note that you need to use http or https depending on what the tibbr server 
configuration requires.  
For example, if your tibbr server is called mytibbrserver, and you have a subject called 
SpotfireTibbrDemo, the URL will appear as below: 
https://mytibbrserver.com/a/gadgets/subject_messages.html?id=SpotfireTibbrDemo&name=Sp
otfireTibbrDemo 
See the tibbr®, tibbr Service, tibbr Community, and tibbr Community Service – Installation and 
Configuration manual for a list of other tibbr gadgets. 

12.2 Share 
12.2.1 What is the Share Menu? 

The Share menu allows you to quickly share your analyses with other people you are 
collaborating with. If you are using tibbr in your organization, you can post messages with 
images of the analysis you are working with to the tibbr® flow. Your company may also have 
added other collaboration tools, besides tibbr®, to the Share menu. 
Right click on a visualization, on a bookmark, or on a page title to access the Share menu. 
Depending on what you have clicked upon you will see different options on the menu. 

 

Option Description 

Share   

   Page to tibbr® [When right-clicking on a page title.] 
Opens the Share to tibbr® dialog so that the selected page can be 
shared to tibbr. 
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   Bookmark to 
tibbr® 

[When right-clicking on a bookmark.] 
Opens the Share to tibbr® dialog so that the selected bookmark can be 
shared to tibbr. 

   Visualization to 
tibbr® 

[When right-clicking on a visualization.] 
Opens the Share to tibbr® dialog so that the selected visualization can 
be shared to tibbr. 

Tip: To follow tibbr® flows from within TIBCO Spotfire, you can configure the Collaboration 
Panel to view different tibbr® subjects. 

12.2.2 Details on Login to tibbr® 
To be able to log into a tibbr® server, the Spotfire tibbr® host preference must be set by a 
Spotfire Administrator. This preference is found under Application > tibbr® in the 
Preferences tab in the Spotfire Administration Manager. Enter the hostname without http://, 
for instance tibbrserver. 

 

Option Description 

Username Your login name on the tibbr® server. 

Password Your password on the tibbr® server. 

tibbr host The hostname of the tibbr® server. 
Note: This cannot be changed. Instead, this is a preference set by the 
Spotfire Administrator. See above. 

12.2.3 Details on Share to tibbr® 
tibbr® is a communication and collaboration tool designed for the workplace, enabling users to 
collaborate by participating in communication threads about different subjects. 
If you use tibbr® to collaborate with your colleagues, you may want to share your Spotfire 
analyses with them. Specifically, you can share pages, visualizations, and bookmarks. 

► To reach the Share to tibbr® dialog: 
1. Right click on a page title, in a visualization, or on a bookmark and select Share > 

Page/Visualization/Bookmark to tibbr®. 
Response: If this is the first time you share to tibbr® during this Spotfire session, you 
will be prompted to log into the tibbr® server. See Details on Login to tibbr. 
Otherwise, you will be directly presented with the dialog below: 
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Option Description 

Subjects Type the tibbr® subject to which to post here. If you start writing 
something you will be presented with a list of available subjects, 
starting with that letter,  to choose from. 
Note: If you do not enter a subject, you will post to your own wall. 

Message Type a message to post to tibbr here. 

Include link to 
analysis 

Select this option to include a link to the Web Player version of the 
analysis. 
Note: This option will only be available if the analysis is stored in the 
library and the Web Player is installed and configured. Otherwise, only 
the Preview image will be shown. 

Preview This is a preview of the image that will be posted to tibbr. 
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13 Tools 
13.1 Find 
13.1.1 Find 

The find tool is a fast way to find contents in your data, navigate in the analysis, and to perform 
actions found in the menus of Spotfire. It consists of a text field where you enter a search string 
and a list of results for the search. 

 

► To reach the Find dialog: 
1. Press Ctrl+F. 

OR 
2. Select Tools > Find.... 

Searchable categories 
• Go to Page - If there are several pages in the analysis, select a page from the list to go 

to it. 
• Go to Visualization - Select a visualization to go to the relevant page in the analysis 

and highlight the visualization. 
• Tag Marked Rows With - If you have created tags in the Tags panel, select a tag in 

the list to add the marked values in the visualization to that tag. 
• Perform Action - Select an action to perform it. 
• Add Values To Marking - Mark a selected subset from the data table. If all the values 

are already marked, they will be unmarked by this. If there are multiple data tables, 
each table with matching data will get a separate category with the name of the data 
table added. Select All matching values to mark all the matching values in a specific 
column or in the entire data table. If there are more than 1000 matching values for a 
column, the individual values will not be listed, just the All matching values option. 

• Open File - Lists recently used files; select one to open it. 

Example 
When text is entered in the search field, all matching actions, parts of the analysis, and subsets 
of the data are returned. Some additional examples of what can be entered in the search field 
are: 

• If nothing is entered, the latest executed actions from find are listed. 
• y:sales will list all visualizations with Sales on the y-axis. 
• sales category:page will only list all pages with "sales" in the title. Category: can be 

used with all the categories listed above; type part of the category's name after the 
colon. 
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Syntax 
You can also use logical expressions in your search strings. For information on the syntax for 
searches, see the Searching in TIBCO Spotfire page. 
  

13.1.2 Searching in TIBCO Spotfire 
There are many places in TIBCO Spotfire where you can search for different items. For 
example, you can search for filters, analyses in the library or elements used to build information 
links in the Information Designer. All of the available search fields use the same basic search 
syntax, which is presented below. For more information regarding search of a specific item, see 
the links at the bottom of this page. 

Basic Rules 
• By default, a search will match against all words in the name, description or keywords. 

Searching for Apple will match every item that includes words that start with Apple, 
and will match items with the values "Apples are tasty" and "This is an apple". 

• Search matches the beginning of all words. For example, ple will match Plenty and 
Plexiglas but not Apple. 

• Search is not case-sensitive. 
• Boolean AND is implicit when words in the search expression are separated by space. 

For example, Apple Banana will match anything where a word starts with Apple and 
another word starts with Banana. 

Keyword Example Function 

* *ple 
*ple* 

Finds items with a word ending in ple. 
Finds items where a word contains ple. 

Quotation 
marks 

"A Green Apple" Finds items where the word starts with 
the phrase "A Green Apple". 

Double 
quotation 
marks 

"9"" nails" Finds items where the word starts with 
9" nails. Add a second double quote to 
escape a literal quote. 

AND Apple AND Fruit Finds items with a word that starts with 
Apple and another word that starts with 
Fruit. 

OR Apple OR Banana Finds items that include a word that 
starts with Apple or Banana. 

NOT Ban NOT *ana Finds items that have a word that starts 
with Ban but does not end with ana. 
For example, Bangles and Banned 
would be found, but Banana would not. 

( ) Apple and (Banana or Pear) Used to group items in Boolean 
searches. See below for more 
information about searching for text 
within parentheses. 

Quoted 
keywords 

"and"    "or"    "not" Finds strings that are protected 
keywords. Just typing and in the search 
field will not find anything since the 
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word and is a protected keyword. If you 
need to search for the word "and", you 
must use quotation marks around it. 

: DataType:Integer [Not applicable for row search.] 
The colon is used to search for item 
attributes. In this example it finds 
columns where the column property 
DataType has a word that starts with 
Integer. 
Almost any property can be used in the 
search, including custom properties. See 
Column Properties Descriptions for 
information about the available default 
column properties. 

:: Name::Apple 
  
  
  
  
  
DataType::Date 

[Not applicable for row search.] 
Finds items where the exact value of the 
property Name is Apple. In this 
example, an item named only Apple 
would match, but an item named Apple 
from Spain would not. 
If you want to search for the Date data 
type, and not get any hits on DateTime 
columns, use :: instead of a single 
colon. 

:< DistinctValueCount:<10 [Not applicable for row search.] 
Finds columns with less than or equal to 
10 unique values. 

:> RowCount:>10 [Not applicable for row search.] 
Finds columns with more than or equal 
to 10 values. 

Null, Empty 
or not 
existing 
column 
property. 

Tag:null  or 
 DistinctValueCount:null 
  
  
  
Keywords:null 

[Not applicable for row search.] 
Finds all items with no Tags or if the 
column property DistinctValueCount 
does not exist. 
  
Finds all items with no keywords. 

Logical precedence 
Search expressions are evaluated from left to right for logical operators with the same 
precedence. For example, the search expression: 
Apple Banana or Pear 
will be evaluated as   
(("Apple") AND (("Banana") OR ("Pear"))) 
  
Tip: If you cannot find what you are looking for, try adding more wildcards. For example, to 
locate a filter called "Sales ($)" , enter the search expression "Sales ($*", to avoid interpreting 
the text within the parenthesis as a Boolean expression. 
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13.2 Data Relationships 
13.2.1 What is the Data Relationships Tool? 

The Data Relationships tool is used for investigating the relationships between different column 
pairs. The tool always works on the currently filtered data. The Linear regression and the 
Spearman R options allow you to compare numerical columns, the Anova option will help you 
determine how well a category column categorizes values in a (numerical) value column, the 
Kruskal-Wallis option is used to compare sortable columns to categorical columns, and the Chi-
square option helps you to compare categorical columns. 
For each combination of columns, the tool calculates a p-value, representing the degree to 
which the first column predicts values in the second column. A low p-value indicates a probable 
strong connection between two columns. 
The resulting table displays the p-value for each combination of Y and X columns. The table is 
sorted by p-value. Clicking on a column heading will sort the rows according to that column. 

Example: 
Consider the following data table, which lists a few attributes of a group of people: 
  
Eye color, Gender, Height (m), Weight (kg), Age 
blue, female, 1.65, 62.7, 29 
blue, female, 1.50, 57.0, 31 
blue, female, 1.69, 64.2, 18 
blue, male, 1.58, 63.2, 31 
green, male, 1.76, 70.4, 44 
green, male, 1.82, 72.8, 26 
green, male, 1.92, 76.8, 33 
green, female, 1.54, 61.6, 39 
green, female, 1.76, 70.4, 22 
brown, female, 1.67, 66.8, 34 
brown, female, 1.47, 58.8, 41 
brown, male, 1.69, 71.0, 23 
brown, male, 1.78, 74.8, 35 
brown, male, 1.83, 76.9, 20 
brown, female, 1.62, 87, 62 
blue, male, 1.87, 86.5, 23 
brown, male, 1.76, 92, 65 
brown, male, 1.62, 59, 13 
green, female, 1.70, 59, 32 

► To test if there is a relationship between numerical columns: 
1. Select Tools > Data Relationships.... 

Response: The Data Relationships dialog is displayed. 
2. Select Linear Regression (numerical vs numerical) as the comparison method. 
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3. Send all Available Y-columns to the Selected Y-columns list by clicking on them in 
the list and then click on Add >. 

 
4. Send all Available X-columns to the Selected X-columns list by clicking on them in 

the list and then click on Add >. 

 
5. Click OK. 

Response: A new data relationships table is created, together with a scatter plot based 
on the marked row in the table. 

 
The scatter plot shows the Y and X column from the currently marked row in the data 
relationships table. Since Height vs. Weight got the lowest p-value of all columns investigated, 
this column pair is listed first in the data relationships table, and is marked by default. Not 
surprisingly, it appears as if there is a correlation between the Height and Weight of the test 
persons. 
By clicking on a different row in the data relationships table, the scatter plot changes to display 
the new column pair: 
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The p-value for Age vs. Height is quite high and according to the scatter plot, there does not 
seem to be any significant correlation between those two columns in the current data. 
  

13.2.2 How to Use Data Relationships 
► To calculate Data Relationships: 

1. Select Tools > Data Relationships.... 
Response: The Data Relationships dialog is displayed and all available columns are 
listed in the Available columns field. 

2. Type a Comparison name or use the default name Data Relationships. 
3. Select the Comparison method you wish to use, depending on the type of columns 

that you want to compare. 
Comment: Choose from Linear regression (numerical vs numerical), Spearman R 
(numerical vs numerical), Anova (numerical vs categorical), Kruskal-Wallis 
(sortable vs categorical) and Chi-square (categorical vs categorical). 

4. Move the desired columns into the two fields Selected Y-columns and Selected X-
columns. 
Comment: Select columns from Available Y-columns and Available X-columns and 
click on the corresponding Add > button. You must select at least one column for the 
Y-columns field and one for the X-columns field. Click < Remove to move a column 
back to the list of available columns. 

5. Click OK. 
Response: A new page with the specified comparison name is created, showing a data 
relationships table and a scatter plot (for linear regression), a cross table (for chi-
square) or a box plot (for Anova and Kruskal-Wallis). 
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► To use the Data Relationships table to control the other 
visualization: 
1. In the data relationships table, click on the column pair you are interested in. 

Response: The visualization under the table is updated to show the currently marked 
columns on its axes.   

► To update the Data Relationships table: 
If you filter your data after performing a data relationships calculation, the p-values in the table 
will no longer reflect the current selection in your other visualizations, and the Refresh 
calculation icon will turn red. 

1. Click on the Refresh calculation icon to the left of the Data Relationships table, . 
Response: The Data Relationships table is updated to show calculated values for the 
currently filtered data. 

► To change the number of measures shown in the table: 
1. Right-click on the Data Relationships table. 
2. Select Properties from the pop-up menu. 
3. Select the Columns page in the dialog. 
4. Add or remove columns from the Selected columns list by using the Add > or < 

Remove buttons. 
Comment: Click on a column in the Selected columns list and then click Move Up or 
Move Down to change the order of the columns. 

5. Click Close. 

► To sort the data relationships table: 
1. Click on the column header by which you want to sort the table. 

Response: The table is sorted in ascending order. 
Comment: Click on the column heading again to sort in descending order. Note the 
small arrow beside the column title, showing the sort order. 

► To rearrange the horizontal order of the table: 
1. Place the mouse pointer on a table header. 
2. Drag the header to the desired position. 

► To adjust the column width: 
1. Place the mouse pointer on the separator between two column headers. 
2. Click-and-drag the separator to the desired position. 

Comment: You can also right-click on the column header and select Column Width... 
from the pop-up menu to specify a column width in number of pixels. 
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13.2.3 Details on Data Relationships 

 

Option Description 

Data table Specifies the data table on which the calculation will be performed. 

Calculation name The name that will be displayed on the new page, created by the data 
relationships calculation. 

Comparison 
method 

The method by which you wish to compare the columns. Choose from 
Linear regression (numerical vs numerical), Spearman R 
(numerical vs numerical), Anova (numerical vs categorical), 
Kruskal-Wallis (sortable vs categorical) and Chi-square 
(categorical vs categorical). 

Available Y-
columns 

The columns available for use on the Y-axis in the calculation. 
Click a column name in the list to select it. To select more than one 
column, press Ctrl and click the column names in the list. Use the Add 
> button to send the selected columns to the Selected Y-columns field, 
see below. 

Add > Moves the selected columns from the Available Y-columns field to the 
Selected Y-columns field. 
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< Remove Removes the selected columns from the Selected Y-columns field. 

Remove All Removes all columns from the Selected Y-columns field. 

Selected Y-
columns 

The selected columns that you wish to compare against the columns 
below. 

Available X-
columns 

The columns available for use on the X-axis in the calculation. 
Click a column name in the list to select it. To select more than one 
column, press Ctrl and click the column names in the list. Use the Add 
> button to send the selected columns to the Selected X-columns field, 
see below. 

Add > Moves the selected columns from the Available X-columns field to the 
Selected X-columns field. 

< Remove Removes the selected columns from the Selected X-columns field. 

Remove All Removes all columns from the Selected X-columns field. 

Selected X-
columns 

The selected columns. Categorical columns should typically not 
contain too many unique values. If more than 1000 unique values are 
available in a selected column, the resulting data relationships table for 
the Anova, Kruskal-Wallis and Chi-square options will display an 
error. 

13.2.4 Data Relationships Column Descriptions 
The Data Relationships table displays a number of different measures for the different types of 
calculations. A description of the statistics available is found below: 

All calculations 

Option Description 

Y (numerical/categorical) The name of the Y column concerned. 

X (numerical/categorical) The name of the X column concerned. 

p-value The calculated p-value, representing the degree to which the 
first column predicts values in the second column. A low p-
value indicates a probable strong connection between two 
columns. 

n The number of valid pairs. 

Linear regression 

Option Description 

FStat The F-statistic calculated according to [Ref. Arnold]. 

RSq The squared correlation value. 

R The correlation value. 
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Df The degrees of freedom = the number of non-empty rows in the column pair - 2. 

Spearman R 

Option Description 

FStat The F-statistic calculated according to [Ref. Lehmann]. 

Rank R 
sqared 

The square of rank R. 

Rank R The correlation of the ranked values of the X and Y columns. 

Df The degrees of freedom = the number of non-empty rows in the column - 2. 

  

Anova 

Option Description 

FStat The F-statistic. See Anova algorithm for more information. 

S2Btwn The sum of squares between groups. 

S2Wthn The sum of squares within groups. 

dfBtwn The degree of freedom between groups. 

dfWthn The degree of freedom within groups. 

Kruskal-Wallis 

Option Description 

H-stat The H-statistic. See Kruskal-Wallis algorithm for more information. 

Df The degrees of freedom = k-1, where k is the number of categories. 

Chi-square 

Option Description 

Chi2-stat The Chi2-statistic, which is a direct relationship between the observed and the 
expected values. 

Df The degrees of freedom = (I-1)(J-1) where I is the number of unique values in 
the first column and J is the number of unique values in the second column. 

13.2.5 Data Relationships Error Codes 
If your data contain empty values or errors, or if filtering has reduced the number of valid rows 
too much, the data relationships calculation may result in errors for specific cells in the table. 
The available error codes are described below: 
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Error Code Description 

#No valid pairs There were no valid rows to calculate on. This may occur if you have 
filtered out too many rows, or if the two compared columns have a 
different set of valid rows on which to perform the calculation only. 

#Only one valid 
pair 

There were not enough valid rows to perform a calculation. See above. 

#Only two valid 
pairs 

There were not enough valid rows to perform a calculation. The 
number of valid pairs must be larger than two. See '#No valid pairs' 
above. 

#Only one unique 
value for column 
'{0}'   

This happens if the number of unique values equals one. 

#More than 1000 
unique values for 
categorical column 
'{0}' 

Categorical data relationships methods, i.e., Anova, Kruskal-Wallis 
and Chi-square, cannot be used on columns where the number of 
unique values is larger than 1000. In that case, the number of 
categories to split by becomes too large. 

#All values unique 
 for column '{0}' 

Categorical data relationships methods, i.e., Anova, Kruskal-Wallis 
and Chi-square, cannot be used if you only have a single value within 
each category. 

13.2.6 Theory and Methods 

13.2.6.1 Overview of Data Relationships Theory  
The Data Relationships tool calculates a probability value (p-value) for any combination of 
columns. This p-value can be used to determine whether or not the association between the 
columns is statistically significant. 

• Linear regression 
• Spearman R 
• Anova 
• Kruskal-Wallis 
• Chi-square 

Linear regression 
(For a mathematical description of linear regression, see Data Relationships Linear regression 
algorithm.) 
The linear regression option is used to calculate an F-test investigating whether the independent 
variable X predicts a significant proportion of the variance of the dependent variable Y. 
Linear regression, or the "least squares" method, works by minimizing the sum of the square of 
the vertical distances of the points from the regression line and obtain a correlation coefficient. 
The correlation coefficient can take values between -1 and +1. If there is a perfect negative 
correlation, then R=-1; if there is a perfect positive correlation, then R=+1. If R=0, then there is 
no correlation at all and the two columns are completely independent of each other. 
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Spearman R 
(For a mathematical description of Spearman R, see Data Relationships Spearman R algorithm.) 
The Spearman R option is used to calculate a nonparametric equivalent of the correlation 
coefficient. It is used on occasions when the variables can be ranked. Since it is only the rank of 
the values that is interesting in the calculation, Spearman R can be used even if the underlying 
distribution family is unknown, provided that each row can be assigned a rank. Similar to 
Linear regression, the correlation coefficient can take values between -1 and +1. 

Anova 
(For a mathematical description of Anova, see Data Relationships Anova algorithm.) 
Anova means Analysis of Variance. The Anova option is used for investigating how well a 
category column categorizes a value column. For each combination of category column and 
value column, the tool calculates a p-value, representing the degree to which the category 
column predicts values in the value column. A low p-value indicates a probable strong 
connection between two columns. 
Consider the following scatter plot representing data about eight subjects: gender (male/female), 
owns car (yes/no), income ($), and height (cm). Income is plotted on the horizontal axis, and 
height on the vertical. 

 
Blue markers represent car owners, red markers represent non-car owners. Squares represent 
male subjects, circles female subjects. If we perform an Anova calculation with gender and car 
as category columns, and income and height as value columns, the result will be four p-values 
as follows. 

Value column Category column p-value 

Height Car 0.00464 

Income Gender 0.047 

Height Gender 0.433 

Income Car 0.519 

A low p-value indicates a higher probability that there is a connection between category and 
value column. In this case, Height and Car seem closely related, while Income and Car are not. 
We can verify this by examining the scatter plot. 
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See Requirements on input data for data relationships for more information about what data to 
use with this tool. 

Kruskal-Wallis 
(For a mathematical description of the Kruskal-Wallis test, see Data Relationships Kruskal-
Wallis algorithm.) 
The Kruskal-Wallis option is used to compare independent groups of sampled data. It is the 
nonparametric version of one-way Anova and is a generalization of the Wilcoxon test for two 
independent samples. The test uses the ranks of the data rather than their actual values to 
calculate the test statistic. This test can be used as an alternative to the Anova, when the 
assumption of normality or equality of variance is not met. 

Chi-square 
(For a mathematical description of the chi-square calculation, see Data Relationships Chi-
square independence test algorithm.) 
The chi-square option is used to compare observed data with the data that would be expected 
according to a specific hypothesis (for example, the null-hypothesis which states that there is no 
significant difference between the expected and the observed result). The chi-square is the sum 
of the squared difference between observed and expected data, divided by the expected data in 
all possible categories. A high chi-square statistic indicates that there is a large difference 
between the observed counts and the expected counts. 
From the chi-square statistic it is possible to calculate a p-value. This value is low if the chi-
square statistic is high. Generally, a probability of 0.05 or less is considered to be a significant 
difference. 

13.2.6.2 Data Relationships Linear Regression Algorithm  
The Linear Regression option calculates the p-value under the assumption that there are no 
empty values in the data table. 
Note: If there are empty values in the data table, the data table will first be reduced to the rows 
containing values for both the first and the second column. 
Let n be the total number of values and denote by (xi, yi), i = 1, ..., n the set of data points to fit a 
straight line 

. 

The least square estimates of  and  are: 

 
  

 
The p-value is then calculated from the F-distribution where the F-statistic is calculated with the 
sum of squares between the estimated line and the total mean of the yi's having one degree of 
freedom as numerator and the residual sum of squares divided by the number of degrees of 
freedom (n-2) as denominator. 

References: 
Arnold, Steven F., The Theory of Linear Models and Multivariate Analysis. 
Rice, John A., Mathematical Statistics and Data Analysis, 2nd ed. pp 509. 
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13.2.6.3 Data Relationships Spearman R algorithm 
The Spearman R option calculates the p-value under the assumption that there are no empty 
values in the data table. 
Note: If there are empty values in the data table, the data table will first be reduced to the rows 
containing values for both the first and the second column. 
The Spearman R calculation is a nonparametric comparison based on the ranks of the 
observations, rather than on the values themselves. This test can be used as an alternative to the 
Linear Regression, when the assumption of normality or equality of variance is not met. For 
example, this is useful on occasions where outliers contribute too much to the calculations in a 
parametric test. 
Spearman R can be calculated in several different ways depending on whether or not ties are 
common in the data table , that is, if several values are identical and thus have the same rank. 
Since it is quite common with ties in general data analysis, TIBCO Spotfire uses an algorithm 
where these can be handled. When ties occur, they are all given the mean of the ranks that they 
would have had if they had not been exactly identical (see Ranking Functions, 
"ties.method=average"). 
The correlation value is calculated according to: 

 
where 
N = the number of valid pairs of measurements (xi, yi), 
fk= the number of ties in the kth group of ties among the Y-column values 
and 
gm= the number of ties in the mth group of ties among the X-column values. 
  
The test statistic, FStat is then: 
  

 
where 
rs

2= RSq = the squared correlation value. 
In TIBCO Spotfire, the Spearman t method has then been applied to calculate the p-values. This 
method has been chosen in order to allow the same calculation method to be used at all times 
and with an acceptable performance. The Spearman exact method is not suitable for cases with 
a lot of ties in the data. The Spearman Monte-Carlo method is suitable for any type of data, but 
when a lot of p-values are to be calculated then this method has too low performance. 

References: 
Lehmann, E. L., Nonparametrics: Statistical Methods based on Ranks (1975), p. 297 – 303. 
Kendall, M., Rank Correlation Methods (1948), p. 37-54. 
  

13.2.6.4 Data Relationships Anova Algorithm  
The Anova option computes the difference between groups by comparing the mean values of 
the data in each group. The results are obtained by testing the null hypothesis; the hypothesis 
that there is no difference between the means of the groups. More formally, the p-value is the 
probability of the actual or a more extreme outcome under the null-hypothesis. 
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Note: If there are empty values in the data table, the data table will first be reduced to the rows 
containing values for both the first and the second column. 
 

► For each combination of category and value column, a p-value 
is computed as follows: 
1. Rows are grouped according to their value in the category column. 
2. The total mean value of the value column is computed. 

  
3. The mean within each group is computed. 
4. The difference between each value and the mean value for the group is calculated and 

squared. 
5. The squared difference values are added. The result is a value that relates to the total 

deviation of rows from the mean of their respective groups. This value is referred to as 
the sum of squares within groups, or S2Wthn. 

6. For each group, the difference between the total mean and the group mean is squared 
and multiplied by the number of values in the group. The results are added. The result 
is referred to as the sum of squares between groups, or S2Btwn. 

 
7. The two sums of squares are used to obtain a statistic for testing the null hypothesis, 

the so called F-statistic. The F-statistic is calculated as: 
 

 
where dfBtwn (degree of freedom between groups) equals the number of groups minus 
1, and dfWthn (degree of freedom within groups) equals the total number of values 
minus the number of groups. 

8. The F-statistic is distributed according to the F-distribution (commonly presented in 
mathematical tables/handbooks). The F-statistic, in combination with the degrees of 
freedom and an F-distribution table, yields the p-value. 

The p-value is the probability of the actual or a more extreme outcome under the null-
hypothesis. The lower the p-value, the larger the difference. 
Note: A very small p-value may also arise if an effect is tiny but the sample sizes are large. 
Similarly, a higher p-value can arise if the effect is large but the sample size is small. This is 
because the hypothesis tests whether the effect is zero or not. 

Reference: 
Arnold, Steven F., The Theory of Linear Models and Multivariate Analysis. 

13.2.6.5 Data Relationships Kruskal-Wallis Algorithm 
The Kruskal-Wallis option calculates the p-value under the assumption that there are no empty 
values in the data table. 
Note: If there are empty values in the data table, the data table will first be reduced to the rows 
containing values for both the first and the second column. 
The Kruskal-Wallis test can be seen as the nonparametric version of a one-way Anova. The test 
uses the ranks of the data rather than their actual values to calculate the test statistic. This test 
can be used as an alternative to the Anova, when the assumption of normality or equality of 
variance is not met. 
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For k groups of observations, all N observations are combined into one large sample, the result 
is sorted from smallest to largest values and ranks are assigned, assigning ties (when values 
occur more than once) the same rank. 
Now, after regrouping the observations, the sum of the ranks are calculated in each group. The 
test statistic, H, is then: 

 
  
k = number of categories 
N = number of cases in the sample 
Ni = number of cases in the ith category 

= average of the ranks in the ith category 
Tj = ties for the jth unique rank 
m = number of unique ranks 
A p-value can be calculated from the test statistic by referring the value of H to a table with the 
chi-square distribution with k-1 degrees of freedom. This can be used to test the hypothesis that 
all k population distributions are identical. 

Example: 
For the following data table, the different parameters used in the test are as follows: 

Data table Parameters 

Category Value Rank Ties 

A 1 1 1 

A 3 2.5 2 

A 3 2.5 

B 5 5.5 2 

B 5 5.5 

B 4 4 1 

k = 2 
N = 6 
NA= 3 
NB= 3 

=2 

=5 

T1= 1 
T2= 2 
T3= 2 
T4= 1 
m = 4 
H = 4.091 
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Reference: 
Lehmann, E. L., Nonparametrics: Statistical Methods based on Ranks (1975), p. 204 – 210. 
  

13.2.6.6 Data Relationships Chi-square Independence Test 
Algorithm 

The Chi-square option calculates the p-value under the assumption that there are no empty 
values in the data table. 
Note: If there are empty values in the data table, the data table will first be reduced to the rows 
containing values for both the first and the second column. 
Let n be the total number of values and denote by I the number of unique values in the first 
column and by J the number of unique values in the second column. Also for i = 1, ..., I let ni be 
the number of occurrences of the ith unique value and for j = 1, ..., J, let nj be the number of 
occurrences of the jth unique value. If we now let nij denote the number of rows containing the 
ith unique value in the first column and the jth unique value in the second column, the Pearson's 
chi-square statistic is: 

 
with (I-1)(J-1) degrees of freedom. 
The p-value is then calculated from the chi-square distribution with (I-1)(J-1) degrees of 
freedom. 

Reference: 
Rice, John A., Mathematical Statistics and Data Analysis, 2nd ed., p 489-491. 

13.2.6.7 Requirements on Input Data for Data Relationships 

Experimental design 
In this tool, a one-way layout of Anovas has been employed. This means that the experimental 
design should be of the type where the outcome of a single continuous variable is compared 
between different groups. The tool cannot be used to analyze experiments where two or more 
variables vary together. 
Tip: You can create a new column using the Concatenate function (or '&') of the Insert 
Calculated Column tool (Insert > Calculated Column...) if you want to analyze two or more 
variables together. 

Distribution of data 
The Anova and Linear regression comparisons assume the following: 

• The data is approximately normally distributed. 
• The variances of the separate groups, or the variances of the errors in the case of linear 

regression, are approximately equal. 
If the data do not fulfill these conditions, the Anova and Linear Regression comparisons may 
produce unreliable results. In this case, it may be more valid to use a Kruskal-Wallis or 
Spearman R comparison instead. 
Note: If more than one test is performed at the same time, then it is more likely that there will 
be at least one p-value less than 0.05 than in the case where only one test is performed. A 
guideline of when to reject the hypothesis is then "Reject the hypothesis if the p-value is less 
than 0.05 divided by the number of tests". This is called the Bonferroni method for multiple 
tests. 
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13.3 K-means Clustering 
13.3.1 How to Perform a K-means Clustering 

The K-means Clustering tool cannot be used unless you have created a suitable line chart to 
base the calculation on. For example, you cannot use multiple Y-axes scales or an X-axis which 
is both continuous and binned when performing a K-means clustering. See below for more 
information about how to set up the line chart. 

► To cluster data: 
1. Create a line chart visualization by clicking on the New Line Chart button on the 

toolbar. 
Comment: The tool uses the lines specified in a line chart to define the data for the 
calculation. 

2. Make sure that all values that should be included in the calculation are selected on the 
Y-axis. 

3. If more than one column is selected on the Y-axis, make sure that (Column Names) is 
selected on the X-axis. 
Comment: (Column Names) is an option that treats the names of the columns selected 
on the Y-axis as separate categories. 

4. Use Line By, Color By or Trellis By to split the lines according to at least one column, 
in order to create multiple lines. 
Comment: See examples on how to split lines on How to Use the Line Chart. If you 
want to create one line for each individual row, one of these options must be set to 
define a unique identifier for all rows. "(Row Number)" is a fictive column 
representing the row index of all rows and can be used for this purpose. 

5. Select Tools > K-means Clustering.... 
Response: The K-means Clustering dialog is displayed. 

6. Make sure that the line chart you just created is selected under Line chart to work on. 
7. Select whether to Create new result column or Update existing result column. 

Comment: Update existing is only available when you have previously performed a K-
means clustering during this analysis. 

8. Select a Distance measure to use in the calculation. 
Comment: For more information see Correlation or Euclidean distance. 

9. Specify the Max number of clusters that you wish to create. 
Comment: The actual number of clusters may be smaller than the specified maximum. 

10. Click OK. 
Response: A result column is created, specifying a cluster ID for each individual row 
(line). 
Comment: Note that the result column is based on a snapshot of the line chart from the 
moment of performing the calculation and it may become invalid when any additional 
filtering is applied. 
Note: When opening an analysis file in which data has been saved linked to, any result 
columns generated by the clustering operation are dynamically re-evaluated, based on 
the new data. 
Note: If the input line chart is trellised, the column or expression used to trellis by will 
be moved to the Line By setting upon running a K-means clustering. This is done in 
order to keep the original lines in the line chart after presenting the K-means result in 
trellis panels. 
Tip: If you do not want to be able to overwrite the result column by consecutive 
clusterings, or when saving an analysis file with linked data, you can turn it into a 
static column by performing the following: Select Edit > Column Properties. Click 
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on the result column to select it, and then click on the Freeze Column button in the 
lower part of the General tab. 

13.3.2 Details on K-means Clustering 
K-means clustering is an algorithm for partitioning a data table into subsets (clusters), in such a 
way that the members of each cluster are relatively similar. 
The K-means clustering in TIBCO Spotfire is based on a line chart visualization which has been 
set up either so that each line corresponds to one row in the root view of the data table, or, if the 
line chart is aggregated, so that there is a one to many mapping between lines and rows in the 
root view. The clustering is initialized using data centroid based search, using unit weights, and 
correlation or Euclidean distance as the distance measure. The clustering is always performed 
on filtered rows. If you wish all rows to be included in the clustering you need to reset all filters 
prior to clustering. The columns the clustering operation should be based on are specified in the 
line chart that is used as starting point. 
If "break on empty" is not active, empty values will be replaced using row (line) interpolation, 
similar to what is shown in the visualization. If "break on empty" is active, any rows (lines) 
containing empty values shall be excluded from the clustering operation. 
Note: If the input line chart is trellised, the column or expression used to trellis by will be 
moved to the Line By setting upon running a K-means clustering. This is done in order to keep 
the original lines in the line chart after presenting the K-means result in trellis panels. 

► To reach the K-means Clustering dialog: 
1. Make sure you have set up a line chart according to the steps in How to Perform a Line 

Similarity Comparison. 
2. Select Tools > K-means Clustering.... 

 

Option Description 

Line chart to work 
on 

Select the line chart on which you want to base the calculation from the 
drop-down list. 

Result column 
options 

  

   Create new Use this option to create a new K-means clustering result column. 
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   Update existing Use this option to update a previously added result column. Only 
available when at least one clustering result column has been added 
earlier. 

Distance measure Select the distance measure to base the similarity calculation on. See 
Distance measures for more information. 

Max number of 
clusters 

The maximum number of clusters that you want to calculate (some 
may turn out empty and will in that case not be displayed). 

References: 
Mirkin, B. (1996) Mathematical Classification and Clustering, Nonconvex Optimization and Its 
Applications Volume 11, Pardalos, P. and Horst, R., editors, Kluwer Academic Publishers, The 
Netherlands. 
MacQueen, J. (1967). Some methods for classification and analysis of multivariate 
observations. In Le Cam, L. M. and Neyman, J., editors, Proceedings of the Fifth Berkeley 
Symposium on Mathematical Statistics and Probability. Volume I: Statistics, pages 281-297. 
University of California Press, Berkeley and Los Angeles, CA. 
Hair, J.F.Jr., Anderson, R.E., Tatham, R.L., Black, W.C. (1995) Multivariate Data Analysis, 
Fourth Edition, Prentice Hall, Englewood Cliffs, New Jersey. 

13.4 Line Similarity 
13.4.1 How to Perform a Line Similarity Comparison 

Note: The Line Similarity tool cannot be used unless you have created a suitable line chart to 
base the calculation on. For example, you cannot use multiple Y-axes scales or an X-axis which 
is both continuous and binned when performing a line similarity comparison. See below for 
more information about how to set up the line chart. 

► To perform a line similarity comparison: 
1. Create a line chart visualization by clicking on the New Line Chart button on the 

toolbar, . 
Comment: The tool uses the lines specified in a line chart to define the data for the 
calculation. 

2. Make sure that all values that should be included in the calculation are selected on the 
Y-axis. 

3. If more than one column is selected on the Y-axis, make sure that (Column Names) is 
selected on the X-axis. 
Comment: (Column Names) is an option that treats the names of the columns selected 
on the Y-axis as separate categories. 

4. Use Line By, Color By or Trellis By to split the lines according to at least one column, 
in order to create multiple lines. 
Comment: See examples on how to split lines on How to Use the Line Chart. If you 
want to create one line for each individual row, one of these options must be set to 
define a unique identifier for all rows.  "(Row Number)" is a fictive column 
representing the row index of all rows and can be used for this purpose. 

5. If desired, mark one or more lines to use as the master line against which the search 
will be performed. 

6. Select Tools > Line Similarity.... 
Comment: You can also right-click in the line chart and select Line Similarity... from 
the pop-up menu. 
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Response: The Line Similarity dialog is displayed. 
7. Make sure that the line chart you just created is selected under Line chart to work on. 
8. Select whether to Create new result columns or Update existing result columns. 

Comment: Update existing is only available when you have previously performed a 
line similarity comparison during this analysis. 

9. Select a Distance measure to use in the calculation. 
Comment: For more information see Correlation or Euclidean distance. 

10. Select whether to use a master line Based on marked lines or on a Custom shape. 
Comment: Marked lines create a master line which is the average of all marked lines. 
With the custom alternative, you can select a master line from a number of predefined 
line shapes. 
Comment: If the currently marked lines contain empty values they cannot be used to 
create a master line, and the custom alternative will automatically be selected. 

11. Click OK. 
Response: Two new columns are added to the data table (and two new filters 
representing the columns are shown in the filters panel). 
Comment: Note that the result columns are based on a snapshot of the line chart from 
the moment of performing the calculation and they may become invalid when any 
additional filtering is applied. 

Tip: If you do not want to be able to overwrite the result columns by consequent calculations, 
or when saving an analysis file with linked data, you can turn them into static columns by 
performing the following: Select Edit > Column Properties. Click on a result column to select 
it, and then click on the Freeze Column button in the lower part of the General tab. 

13.4.2 Details on Line Similarity 
The Line Similarity tool is used to compare the lines in a line chart to a selected master line. As 
a result, two new columns are generated. The first is a similarity column, where the similarity to 
the master line is presented for each individual row (line). The second is a rank column, where 
the line most similar to the master line receives the rank 1. Correlation or Euclidean distance is 
used as the distance measure. 
If "break on empty" is not active, empty values will be replaced using row (line) interpolation, 
similar to what is shown in the visualization. If "break on empty" is active, any rows (lines) 
containing empty values shall be excluded from the line similarity calculation. 

► To reach the Line Similarity dialog: 
1. Make sure you have set up a line chart according to the steps in How to Perform a Line 

Similarity Comparison. 
2. Select Tools > Line Similarity.... 
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Option Description 

Line chart to work 
on 

Specifies which line chart will be used in the calculation (if there are 
more than one suitable line chart in the document). 

Result column 
options 

  

   Create new Use this option to create new line similarity result columns. Create a 
new (calculation) is marked by default. Specify a name for the group, 
to which the two created columns belong.   

   Update existing Use this option to update previously added result columns. Only 
available when at least one line similarity has been calculated earlier. 

Distance measure Select the distance measure to base the similarity calculation on. See 
Distance measures for more information. 

Master line   

   Based on 
marked lines 

Use this option to search for lines as similar to the marked lines as 
possible. 

   Custom Use this option to search for lines as similar to the shape selected in the 
drop-down list as possible. 
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13.5 Hierarchical Clustering 
13.5.1 What is the Hierarchical Clustering Tool? 

The Hierarchical Clustering tool groups rows and/or columns in a data table and arranges them 
in a heat map visualization with a dendrogram (a tree graph) based on the distance or similarity 
between them. When using the hierarchical clustering tool, the input is a data table, and the 
result is a heat map with dendrograms. You can also initiate hierarchical clustering on an 
existing heat map from the Dendrograms page of the Heat Map Properties. See How to Use the 
Heat Map to learn more. 

► To perform a clustering with the Hierarchical Clustering tool: 
1. Select Tools > Hierarchical Clustering.... 

Response: The Hierarchical Clustering dialog is displayed. 
2. If the analysis contains more than one data table, select a Data table to perform the 

clustering calculation on. 
3. Click Select Columns.... 

Response: The Select Columns dialog is displayed. 
4. Select the columns you want to include in the clustering, and then click OK to close 

the dialog. 
5. Select the Cluster rows check box if you want to create a row dendrogram. 
6. Click the Settings... button to open the Edit Clustering Settings dialog. 
7. Select a Clustering method. 

Comment: For more information on clustering methods, see Clustering Methods 
Overview. 

8. Select a Distance measure. 
Comment: For more information on distance measures, see Distance Measures 
Overview. Distances exceeding 3.40282e+038 cannot be represented. 

9. Select Ordering weight to use in the clustering calculation. 
Comment: For more information see Ordering Weight. 

10. Select an Empty value replacement Method from the drop-down list. 
Comment: The available replacement methods are described in Details on Edit 
Clustering Settings. 

11. Select a Normalization Method to use in the clustering calculation. 
Comment: For more information, see Normalizing Columns. 

12. Click OK. 
13. Select the Cluster columns check box if you want to create a column dendrogram. 
14. Go through steps 6 to 12 to define settings for the column dendrogram. 
15. Click OK. 

Response: The hierarchical clustering calculation is performed, and a heat map 
visualization with the specified dendrograms is created. A cluster column is also added 
to the data table and made available in the filters panel. 
Comment: See Dendrograms and Clustering to learn more about dendrograms and 
cluster columns. 

  

13.5.2 Details on Hierarchical Clustering 
► To reach the Hierarchical Clustering dialog: 

1. Open the Tools menu. 



TIBCO Spotfire 4.0.2 - User's Manual 

918 

2. Select Hierarchical Clustering.... 

 

Option Description 

Data table Lists the data tables currently available in the analysis. Select the data 
table for which you want to perform a clustering calculation. 

Columns   

   Select Columns... Click to open the Select Columns dialog, where you can select which 
columns to include in the clustering calculation. 

Cluster rows Select this check box to perform clustering on the rows in the data 
table. 

   Settings... Opens the Edit Clustering Settings dialog where you can define which 
clustering method, distance measure, and ordering weight to use for 
the clustering calculation. You can also define a normalization method 
and a method to use for replacing empty values. 
To learn more about hierarchical clustering, see Overview of 
Hierarchical Clustering Theory. To learn more about normalization, 
see Normalizing Columns. 

Cluster columns Select this check box to perform clustering on the columns in the data 
table. 

   Settings... Opens the Edit Clustering Settings dialog where you can define which 
clustering method, distance measure, and ordering weight to use for 
the clustering calculation. You can also define a normalization method 
and a method to use for replacing empty values. 
To learn more about hierarchical clustering, see Overview of 
Hierarchical Clustering Theory. To learn more about normalization, 
see Normalizing Columns. 
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13.5.3 Theory and Methods 

13.5.3.1 Overview of Hierarchical Clustering Theory 
Hierarchical clustering arranges items in a hierarchy with a treelike structure based on the 
distance or similarity between them. The graphical representation of the resulting hierarchy is a 
tree-structured graph called a dendrogram. In Spotfire, hierarchical clustering and dendrograms 
are strongly connected to heat map visualizations. You can cluster both rows and columns in the 
heat map. Row dendrograms show the distance or similarity between rows, and which nodes 
each row belongs to as a result of clustering. Column dendrograms show the distance or 
similarity between the variables (the selected cell value columns). The example below shows a 
heat map with a row dendrogram. 

 
You can perform hierarchical clustering in two different ways: by using the Hierarchical 
Clustering tool, or by performing hierarchical clustering on an existing heat map visualization. 
If you use the Hierarchical clustering tool, a heat map with a dendrogram will be created. To 
learn more about heat maps and dendrograms, see What is a Heat Map? and Dendrograms and 
Clustering. 

Algorithm 
The algorithm used for hierarchical clustering in Spotfire is a hierarchical agglomerative 
method. For row clustering, the cluster analysis begins with each row placed in a separate 
cluster. Then the distance between all possible combinations of two rows is calculated using a 
selected distance measure. The two most similar clusters are then grouped together and form a 
new cluster. In subsequent steps, the distance between the new cluster and all remaining clusters 
is recalculated using a selected clustering method. The number of clusters is thereby reduced by 
one in each iteration step. Eventually, all rows are grouped into one large cluster. The order of 
the rows in a dendrogram are defined by the selected ordering weight. The cluster analysis 
works the same way for column clustering. 
Note: Only numeric columns will be included when clustering. 

13.5.3.2 Distance Measures 

13.5.3.2.1 Distance Measures Overview 
The following measures can be used to calculate the distance or similarity between rows or 
columns: 

• Correlation 
• Cosine Correlation 
• Tanimoto Coefficient 
• Euclidean Distance 
• City Block Distance 
• Square Euclidean Distance 
• Half Square Euclidean Distance 

The term dimension is used in all distance measures. The concept of dimension is simple if we 
are describing the physical position of a point in three dimensional space when the positions on 
the x, y and z axes refer to the different dimensions of the point. However, the data in a 



TIBCO Spotfire 4.0.2 - User's Manual 

920 

dimension can be of any type. If, for example, you describe a group of people by their height, 
their age and their nationality, then this is also a three dimensional system. For a row (or 
column), the number of dimensions is equal to the number of variables in the row (or column). 
Note: The result from a cluster calculation will be presented either as the similarity between the 
clustered rows or columns, or as the distance between them. Euclidean distance, City block 
distance, Square Euclidean distance, and Half square Euclidean distance will present the 
distance between the rows or columns. The results from Correlation, Cosine correlation, and 
Tanimoto coefficient, on the other hand, are presented as similarity between the rows or 
columns. 
Note: When used in clustering, the similarity measures Correlation, Cosine correlation, and 
Tanimoto coefficient may be transformed so that they are always greater than or equal to zero 
(using 1 – similarity value). 
  

13.5.3.2.2 Correlation 
The correlation between two points, a and b, with k dimensions is calculated as: 

 
where 

 

 

 
This correlation is called Pearson Product Momentum Correlation, simply referred to as 
Pearson's correlation or Pearson's r. It ranges from +1 to -1 where +1 is the highest correlation. 
Complete opposite points have correlation -1. 

 

a and b are identical, which 
means they have maximum 
correlation. 

 

a and b are perfectly mirrored, 
which means they have the 
maximum negative correlation. 

13.5.3.2.3 Cosine Correlation 
The Cosine correlation between two points, a and b, with k dimensions is calculated as: 

 
where 
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The cosine correlation ranges from +1 to -1 where +1 is the highest correlation. Complete 
opposite points have correlation -1. 

Comparison between Cosine correlation and Correlation 
The difference between Cosine correlation and Correlation is that the average value is 
subtracted in Correlation. In the example below, the Cosine correlation will be +1 between any 
combination of points a, b, and c, but it will be slightly less than that between point d and any of 
the other points (+0.974). However, the regular Correlation will be +1 between any of the 
points, including point d. 

 

13.5.3.2.4 Tanimoto Coefficient 
The Tanimoto coefficient between two points, a and b, with k dimensions is calculated as: 

 
The Tanimoto similarity is only applicable for a binary variable, and for binary variables the 
Tanimoto coefficient ranges from 0 to +1 (where +1 is the highest similarity). 

13.5.3.2.5 Euclidean Distance 
The Euclidean distance between two points, a and b, with k dimensions is calculated as: 

 
The Euclidean distance is always greater than or equal to zero. The measurement would be zero 
for identical points and high for points that show little similarity. 
The figure below shows an example of two points called a and b. Each point is described by 
five values. The dotted lines in the figure are the distances (a1-b1), (a2-b2), (a3-b3), (a4-b4) and 
(a5-b5) which are entered in the equation above. 
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13.5.3.2.6 City Block Distance 
The City block distance between two points, a and b, with k dimensions is calculated as: 

 
The City block distance is always greater than or equal to zero. The measurement would be zero 
for identical points and high for points that show little similarity. 
The figure below shows an example of two points called a and b. Each point is described by 
five values. The dotted lines in the figure are the distances (a1-b1), (a2-b2), (a3-b3), (a4-b4) and 
(a5-b5) which are entered in the equation above. 

 
In most cases, this distance measure yields results similar to the Euclidean distance. Note, 
however, that with City block distance, the effect of a large difference in a single dimension is 
dampened (since the distances are not squared). 
The name City block distance (also referred to as Manhattan distance) is explained if you 
consider two points in the xy-plane. The shortest distance between the two points is along the 
hypotenuse, which is the Euclidean distance. The City block distance is instead calculated as 
the distance in x plus the distance in y, which is similar to the way you move in a city (like 
Manhattan) where you have to move around the buildings instead of going straight through. 

13.5.3.2.7 Square Euclidean Distance and Half Square Euclidean 
Distance 
The Square Euclidean distance between two points, a and b, with k dimensions is calculated as 

 
The Half Square Euclidean distance between two points, a and b, with k dimensions is 
calculated as 

 
The half square Euclidean distance is always greater than or equal to zero. The measurement 
would be zero for identical points and high for points that show little similarity. 
The figure below shows an example of two points called a and b. Each point is described by 
five values. The dotted lines in the figure are the distances (a1-b1), (a2-b2), (a3-b3), (a4-b4) and 
(a5-b5) which are entered in the equation above. 
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13.5.3.3 Clustering Methods 

13.5.3.3.1 Clustering Methods Overview 
Hierarchical clustering starts by calculating the distance between all possible combinations of 
two rows or columns using a selected distance measure. These calculated distances are then 
used to derive the distance between all clusters that are formed from the rows or columns during 
the clustering. You can select one of the following clustering methods: 

• UPGMA 
• WPGMA 
• Single Linkage 
• Complete Linkage 
• Ward's Method 

  

13.5.3.3.2 UPGMA 
UPGMA stands for Unweighted Pair-Group Method with Arithmetic mean. 
Assume that there are three clusters called C1, C2 and C3 including n1, n2 and n3 number of rows 
or columns. Clusters C2 and C3 are aggregated to form a new single cluster called C4. 
The distance between cluster C1 and the new cluster C4 is calculated as: 

 
where 

 

 
 

13.5.3.3.3 WPGMA 
WPGMA stands for Weighted Pair-Group Method with Arithmetic mean. 
Assume that there are three clusters called C1, C2 and C3 including n1, n2 and n3 number of rows. 
Clusters C2 and C3 are aggregated to form a new single cluster called C4. 
The distance between cluster C1 and the new cluster C4 is calculated as: 

 
 

13.5.3.3.4 Single Linkage 
This method is based on minimum distance. To calculate the distance between two clusters, 
each possible combination of two rows (or columns) between the two clusters is compared. The 
distance between the clusters is the same as the distance between the two rows (or columns) in 
the clusters that are least distant. 
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Assume that there are three clusters called C1, C2 and C3. Clusters C2 and C3 are aggregated to 
form a new single cluster called C4. The distance between cluster C1 and the new cluster C4 is 
calculated as: 

 

13.5.3.3.5 Complete Linkage 
This method is based on maximum distance and can be thought of as the opposite of Single 
linkage. To calculate the distance between two clusters, each possible combination of two rows 
(or columns) between the two clusters is compared. The distance between the two clusters is the 
same as the distance between the two rows (or columns) in the clusters that are most distant. 
Assume that there are three clusters called C1, C2 and C3. Clusters C2 and C3 are aggregated to 
form a new single cluster called C4. The distance between cluster C1 and the new cluster C4 is 
calculated as: 

 

13.5.3.3.6 Ward's Method 
Ward's method means calculating the incremental sum of squares. Half square Euclidean 
distance is the only distance measure that can be used with this clustering method. Therefore 
the distance measure is automatically set to Half square Euclidean distance when Ward's 
method is selected. 
Assume that there are three clusters called C1, C2 and C3 including n1, n2 and n3 number of rows 
(or columns). Clusters C2 and C3 are aggregated to form a new single cluster called C4. 
The distance between cluster C1 and the new cluster C4 in the example above is calculated as: 

 
where 

 

 

 
 

13.5.3.4 Ordering Weight 
The ordering weight controls in what vertical order the rows are displayed in the row 
dendrogram. For column dendrograms it controls the horizontal order of the columns. The two 
subclusters within a cluster (there are always exactly two subclusters) are weighted and the 
cluster with the lower weight is placed above (to the left of) the other cluster. The weight can be 
any one of the following: 

• Input average rank of the rows (or columns). This is the order of the rows (or 
columns) during import to Spotfire. 

• Average value of the rows (or columns). For example, a row a with 5 dimensions 
would have the average (a1+a2+a3+a4+a5 )/5. The average for a row a with k 
dimensions is calculated as 
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Calculating the weight of a cluster 
To calculate the weight w3 of a new cluster C3 formed from two subclusters C1 and C2 with a 
weight of w1and w2, and each containing n1 and n2 rows, you use the following expression: 

 

13.5.3.5 Hierarchical Clustering References 

Hierarchical clustering 
Mirkin, B. (1996) Mathematical Classification and Clustering, Nonconvex Optimization and Its 
Applications Volume 11, Pardalos, P. and Horst, R., editors, Kluwer Academic Publishers, The 
Netherlands. 
Sneath, P., Sokal, R. R. (1973) Numerical taxonomy, Second Edition, W. H. Freeman, San 
Francisco. 

General information about clustering 
Hair, J.F.Jr., Anderson, R.E., Tatham, R.L., Black, W.C. (1995) Multivariate Data Analysis, 
Fourth Edition, Prentice Hall, Englewood Cliffs, New Jersey. 

13.6 Data Functions 
13.6.1 What are Data Functions? 

Data functions are calculations based on S-PLUS or R that you make available in the TIBCO 
Spotfire environment. Once a function has been defined and saved in the Spotfire library using 
the Register Data Functions dialog, it can be applied at many different places in an analysis. For 
example, it can be used as a transformation step when you add or replace data tables. It can also 
be a separate tool that is run from the Insert menu. 
S-PLUS or R data functions can be defined from either an existing function in the 
corresponding Spotfire Statistics Services package repository or by writing a script directly in 
the Register Data Functions dialog. During the set-up of a data function, a number of input and 
output parameters can be specified. 
Concerning R: 
To use R functionality with TIBCO Spotfire, you must configure TIBCO Spotfire® Statistics 
Services with an R engine. For more information on setting up Spotfire Statistics Services or 
your Spotfire Statistics Services Local Adapter using R, please read the TIBCO Spotfire 
Statistics Services Installation and Administration Guide or the README file included with the 
Statistics Services Local Adapter. (Other 3rd party calculation tools can be added using the 
TIBCO Spotfire API.) 
R is available under separate open source software license terms and is not part of TIBCO 
Spotfire.  As such, R is not within the scope of your license for TIBCO Spotfire. R is not 
supported, maintained, or warranted in any way by TIBCO Software Inc.  Download and use of 
R is solely at your own discretion and subject to the free open source license terms applicable to 
R. 

Example 1: 
A simple conversion of the values in a column from degrees Celsius to degrees Fahrenheit. This 
is of course just as easy to accomplish using the Insert Calculated Column tool, but it serves as 
an example simple enough to show input and output parameter handling in more detail. 
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► To create and run an S-PLUS script data function: 
1. Assume that the data table in TIBCO Spotfire contains a column with temperatures 

expressed in degrees Celsius. 
2. First, select Tools > Register Data Functions.... 
3. Choose the Type S-PLUS script from the drop-down list and define the script that will 

perform the conversion on the Script tab: 
# Define the convertTemperature function: 
convertTemperature <- function(x) 
{ 
  x*(9/5) + 32 
} 
# Run the function to produce the output: 
out <- convertTemperature(x); 

4. Define the Input parameter x as a column with the allowed data types Integer and Real. 

 
Tip: You can select the parameter in the Script tab and use the pop-up menu option 
Input Parameter... to reach the Input Parameter dialog directly. 

5. Define the Output parameter out as a column. 

 
Tip: You can select the parameter in the Script tab and use the pop-up menu option 
Output Parameter... to reach the Output Parameter dialog directly. 
Note that the output display name will not be propagated to the output column name. 
The column name is always the output specified by the S-PLUS script. 

6. Save the data function to the library, as Temperature converter. 
7. To connect the input and output parameters to your current data in TIBCO Spotfire and 

run the calculation, select Insert > Data Function.... 
Comment: You need to have some data loaded in TIBCO Spotfire to use this 
functionality. 

8. Click on the Temperature converter data function and click OK. 
9. In the Data Functions - Parameters dialog, specify that the input parameter x should be 

a column and select the data table and column to convert. 
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10. Click on the Output tab and specify that the output parameter out should be handled as 
a column. 

 
11. Click OK. 

The data function calculation is performed and a new column is added to the data table. You 
can change the parameter settings or refresh the calculation later by selecting Edit > Document 
Properties, Data Functions tab. 

Example 2: 
If the function to use is a Principal Component Analysis (PCA) calculation, the input would be 
a number of numerical data columns retrieved from the current data in TIBCO Spotfire and, 
optionally, a parameter specifying the percent variation to be preserved by the principal 
components. The output would include three new data tables (scores, loadings and 
eigenvalue/explained variance table) and a scalar indicating the number of principal 
components generated. 
  

13.6.2 How to Use Data Functions 
Data functions can be used to enhance the functionality of TIBCO Spotfire in many ways. 
Below are a few examples of where and how data functions can be defined and applied. Note 
that you or your admin must first set the address to TIBCO Spotfire Statistics Services or 
TIBCO Spotfire Statistics Services Local Adapter as explained below. See also What are Data 
Functions? 

► To register an S-PLUS function in Spotfire: 
1. When a function that you want to use from within TIBCO Spotfire has been defined 

and saved to your package repository in Spotfire Statistics Services, you need to write 
down or remember its name, together with the names of all required input and output 
parameters. 

2. In TIBCO Spotfire, select Tools > Register Data Functions.... 
Response: The Register Data Functions dialog is displayed. 

3. From the Type drop-down list, select S-PLUS function. 
4. In the S-PLUS packages field, type the exact name of the package where the function 

is located in the Spotfire Statistics Services package repository. (This is only necessary 
if there is more than one function bearing the same name in the repository, or the 
packages are not loaded automatically.) 

5. In the S-PLUS function name field, type the exact name of the function of interest, as 
it was defined in the Spotfire Statistics Services package repository. 
Comment: TIBCO Spotfire will not be able to locate the function in the Spotfire 
Statistics Services package repository unless the name is exactly the same. 

6. If desired, type a new Description of the function. 
7. On the Input Parameters tab, add all required input parameters. 
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Comment: How the input parameters should be handled is defined upon execution of 
the data function. 

8. If necessary, move the input parameters so that the order in the list reflects the order in 
which the input parameters should be retrieved. 

9. On the Output Parameters tab, add all required output parameters. 
Comment: How the output parameters should be handled is defined upon execution of 
the data function. 

10. Save the data function. 
Comment: You can specify keywords upon saving that will help in locating the 
function in the library at a later stage. 
Response: The registered data function is saved in the library. 

11. Click Close. 
Comment: The data function can now be added to an analysis by running it from the 
Insert menu (see below). 
The same steps would be used if the function was instead created using R. 

► To map and execute a previously registered data function from 
the Insert menu: 
1. In TIBCO Spotfire, select Insert > Data Function.... 

Response: The Data Functions - Select Function dialog is displayed. 
2. Optionally, click on a Keyword or use the search field to limit the number of shown 

functions in the dialog. 
Comment: For more information about search expressions, see Searching in TIBCO 
Spotfire. 
Response: Only the functions whose names match the keyword or search expression 
are shown in the dialog. 

3. Click to select the desired function. 
4. Click OK. 

Response: The Data Functions - Parameters dialog is displayed. 
5. Specify whether or not to Refresh function automatically. 

Comment: If the check box is selected a new calculation will be performed each time 
the input parameters change. If the check box is cleared, you need to refresh the data 
function manually. 

6. Specify what to do with the input or output parameters and then click OK. 
Comment: For a description of the available input and output handlers, see Details on 
Data Functions - Parameters. 
Response: The function is executed. Depending on how the output parameters were set 
up, you may get a new or updated data table, new columns or rows, or an updated data 
table or document property, which can be used to control a variety of settings in your 
analysis. A Details... link with progress information  will be available in the lower left 
part of the TIBCO Spotfire window. Click on the link for more information. 

Note: Time and Date formats are not directly supported by Spotfire Statistics Services. When 
sending this type of input to Spotfire Statistics Services you will get the data back in a 
DateTime (TimeDate) format where a default date or time part has been appended to the 
original data. Columns with the data type Currency cannot be used in data functions. 

► To refresh a data function from a text area: 
Once executed in the document, data functions can also be refreshed by clicking on an action 
link or button in a text area. This can be a way to make it easier for other users of the analysis to 
find and use the data function. For example, if the data function has been set up to work with 
filtered rows, many people can access the analysis, filter to their special area of interest and 
click on a button to receive calculation results relevant for them. 
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1. Create an analysis where the data function can be used and run the data function from 
the Insert menu as described above. 
Comment: This is done in order to make the current document aware of the data 
function. 

2. Create a text area and enter edit mode by clicking on the Toggle Edit Mode button, 

. 

3. Click on the Insert Action Control button, . 
Response: The Action Control dialog is displayed. 

4. Click on Data Function in the left-hand pane. 
5. Type a Display text to use on the button or link. 
6. Select the Control type to use: Button or Link. 
7. Click to select the data function of interest from the Available data functions list. 

Comment: Only those data functions that have been executed from within the current 
document and do not use automatic refresh will be available. 

8. Click OK. 
Response: The button or link is added to the text area. 

► To use the result from a data function to draw a line in a 
visualization: 

Data functions can be used to calculate new data which can be used to do such things as 
drawing a line in a visualization. This can be accomplished in a variety of ways, but the steps 
below describe an example where the data function result is presented as two new columns 
containing coordinate values. 

1. Define and execute a data function which uses the current data columns as input and 
performs a calculation before the new resulting columns are added to the data table. 
Response: The data function is added to the document, and the result columns are 
added to the data table. 

2. Create a visualization which can display lines and curves, such as, a scatter plot. 
Comment: Line from Column Values cannot draw curves over categorical axes, so 
make sure that the value columns on both axes are continuous. 

3. Right-click in the visualization and select Properties. 
Comment: You can also select Edit > Visualization Properties from the main menu. 
Response: The Visualization Properties dialog is displayed. 

4. Click on Lines & Curves. 
5. Click Add and select Line from Column Values.... 

Comment: This is the option to use if the data results are located in one X-values and 
one Y-values column. If the results from the data function are presented as curve 
parameters you should use Curve from Data Table instead, and if a curve equation is 
calculated, use Curve Draw. 
Response: The Line from Column Values dialog is displayed. 

6. Select the Data table with line values. 
Comment: This should be the data table where the result columns were added. 

7. Select the X-values column. 
8. Select the Y-values column. 
9. If desired, select a Sorted by column, to specify a different sort order. 
10. Specify whether to Ignore (skip) empty values or to Split curve at empty values. 
11. Specify whether to use an Automatic or a Custom curve name. 
12. Click OK. 

Response: The curve is added to the visualization. 



TIBCO Spotfire 4.0.2 - User's Manual 

930 

► To change settings for a saved data function in an analysis: 
1. Select Edit > Document Properties. 

Response: The Document Properties dialog is displayed. 
2. Click on the Data Functions tab. 

Response: All data functions that have been executed in the analysis are shown in the 
Available data functions list. 

3. Click to select the function of interest in the Available data functions list. 
4. Click Edit.... 

Comment: To simply update the data function using the same settings as last time, 
click Refresh. 
Comment: Use the Sync button to update the data function with any changes done to 
the data function in the library. 
Response: The Data Functions - Parameters dialog is displayed. 

5. If desired, change whether or not to Refresh function automatically. 
6. Change the Input parameter settings and click OK. 

Comment: You cannot change the Output parameter settings from here. If this is 
required, you must execute the data function from the Insert menu again. 
Response: The data function is updated using the new settings. 

► To change the address to Spotfire Statistics Services: 
The address to Spotfire Statistics Services is normally specified by the TIBCO Spotfire 
administrator, on a group level. This step instruction shows how an administrator can change 
the address for a user group. It is also possible to use a local calculation engine (see below). 

1. Login to  TIBCO Spotfire as a user with administration rights. 
2. Select Tools > Administration Manager. 

Response: The Administration Manager is displayed. 
3. Click on the Preferences tab. 
4. Click on the group of interest in the Selected group list. 

Response: The preferences and configuration sets for the selected group are displayed. 
5. On the Preferences tab, click on the plus sign next to TIBCO Spotfire Statistics 

Services to expand that group. 
6. Click on StatisticsServices in the TIBCO Spotfire Statistics Services group. 

Response: The currently specified S-PLUS URL and R URL are shown. 
7. For the implementation of your choice, click Edit. 

Response: The Edit Preferences dialog is displayed. 
8. Type or paste a new URL for Spotfire Statistics Services. 
9. Click OK. 
10. Click Close. 

► To use an alternative calculation engine, e.g., TIBCO Spotfire® 
Statistics Services Local Adapter: 
1. Select Tools > Options. 

Response: The Options dialog is displayed. 
2. Go to the Data Functions page. 
3. Click the Custom URL radio button. 
4. Type the address to the local calculation engine. 
5. Click OK. 
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► To delete a saved data function from the library: 
If you have administrative rights, you can delete and edit the name, description and keywords of 
a data function using the Library Administration tool. 

1. Select Tools > Library Administration. 
Response: The Library Administration dialog is displayed. 

2. Click to select the data function of interest. 
Comment: You can use the search field at the top right corner of the dialog to help in 
locating the data function. (Use 'type:datafunction' as the search expression in the 
search field to find all data functions.) See Searching the Library for more information 
about search expressions. 

3. Click on the Delete button at the top of the dialog. 
Response: A dialog asking you if you are sure you want to delete the data function is 
displayed. Click Yes and the data function is removed. 

4. Click Close. 

► To edit the name, description or keywords of a saved data 
function in the library: 

If you have administrative rights you can delete and edit the name, description and keywords of 
a data function using the Library Administration tool. 

1. Select Tools > Library Administration. 
Response: The Library Administration dialog is displayed. 

2. Click to select the data function of interest. 
Comment: You can use the search field at the top right corner of the dialog to help in 
locating the data function. (Use 'type:datafunction' as the search expression in the 
search field to find all data functions.) See Searching the Library for more information 
about search expressions. 

3. Click on the Edit... link next to the Selected Item header in the lower part of the 
dialog. 
Response: The Edit Properties dialog for the selected data function is displayed. 

4. Change the properties for the data function and click OK. 
5. Click Close. 

► To recreate a deleted result column: 
If you run a data function which creates one or more columns and you then delete one of the 
result columns from the analysis, the lost column will remain gone when refreshing the data 
function. In order to recreate the lost column you must run the data function from the Insert 
menu once again. 

13.6.3 Details 

13.6.3.1 Details on Register Data Functions 
The Register Data Functions dialog is used to set up which S-PLUS or R functions in your 
Spotfire Statistics Services package repository should be available for end users of TIBCO 
Spotfire. Once a function has been registered, it is available from the library and can be used in 
any analysis. 

► To reach the Register Data Functions dialog: 
1. Select Tools > Register Data Functions.... 
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Option Description 

New Function Clears all text fields and list views in the dialog so you can start 
defining a new data function. 

Open Allows you to open a previously saved data function from the library 
for further configuration. 

Save Saves an edited data function to the library. 

Save As Opens the Save as Library Item dialog where you can specify a name 
and a location in the library where you want the data function to be 
saved. 

Run Opens the Data Functions - Parameters dialog so that you can specify 
settings for the input and output parameters and execute the current 
data function. This is mostly meant as a shortcut for testing the data 
function before it is saved to the library. Run the saved data function 
using Tools > Data Function...  before saving the analysis in order to 
be able to synchronize the data function with any updates in the library 
in the future. See also Document Properties - Data Functions. 

Name Displays the name of the data function when it has been saved to the 
library. If the function has not yet been saved, this field will be empty. 

Type Allows you to select what type of function to use. The types available 
will depend on which calculation engine you have access to. For 
predefined functions, select S-PLUS or R function. To define a new 
script, select S-PLUS or R script. 
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S-PLUS/R 
packages 

Optional. Allows you to specify any packages in the Spotfire Statistics 
Services package repository that are being used by your current data 
function. 
For example, if you want to create a data function based on a 
predefined statistical S-PLUS function, you need to provide the name 
of the package in the S-PLUS repository where this function is located 
(e.g., stat). 
If more than one package is required, separate the package names with 
semicolons. 

S-PLUS/R 
function name 

[Available for S-PLUS/R functions only, not for scripts.] 
This is where you type the function name as it has been defined in 
Spotfire Statistics Services. 

Description Optional but recommended. A description of the function. This 
description is stored in the library and can help the end users of the 
data function to select the proper function. 

Allow caching Select this check box to allow calculations to be reused if the same 
subset of input values has been calculated before. 
Clear this check box if some of the input data comes from somewhere 
else than your current analysis and you want a new calculation from 
Spotfire Statistics Services each time input data are changed (even for 
changes into something that has already been computed before). Input 
data are often changed when the input is depending on filtered values, 
marked values or a property value. 
For example, if the data function includes a random number generator, 
you will probably not want to cache a previously generated random 
number but instead calculate a new one for each refresh of the data 
function. Another example is a data function that includes the current 
date or time. 

Script tab 
Only available for script type data functions. To change to a script type data function, click on 
the Type drop-down list above and select S-PLUS script or R script. 

 
Here you can type or paste any script in the specified script type language. 
The font settings for the script tab can be changed using Tools > Options, Fonts page and 
selecting Expression and script editor. 
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Input Parameters tab 

 

Option Description 

Parameters Lists all input parameters that have been mapped using the Input 
Parameter dialog. 

Add... Opens the Input Parameter dialog. 

Edit... Opens the Input Parameter dialog with the selected input parameter 
and its current settings available for editing. 

Remove Removes the selected input parameter from the list. 

Move Up Moves the selected input parameter up one step. The order of the input 
parameters in this list determines the order in which the input 
parameters should be retrieved. 

Move Down Moves the selected input parameter down one step. 

Output Parameters tab 

 

Option Description 

Parameters Lists all output parameters that have been mapped using the Output 
Parameter dialog. 

Add... Opens the Output Parameter dialog. 
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Edit... Opens the Output Parameter dialog with the selected output parameter 
and its current settings available for editing. 

Remove Removes the selected output parameter from the list. 

Move Up Moves the selected output parameter up one step. Use this button to 
place the most important output parameters at the top of the list. 

Move Down Moves the selected output parameter down one step. 

  

13.6.3.2 Details on Input Parameter 

 

Option Description 

Input parameter 
name 

The name of the parameter as it has been referred to in the function or 
script. 

Display name The name of the parameter as you want it to be displayed to the end 
users. 

Type The input type, which can be Value, Column or Table. This defines 
whether the input parameter can be one or more columns, or just a 
single value. 

Allowed data types Specifies which data types are supported by this input parameter. 
Select the check box for all data types that you want to allow. 
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All Click All to select all data types. 

Numeric Click Numeric to select all numeric data types. 

None Click None to clear all check boxes. Then select one or more data 
types to continue. 

Description Optional. Can contain more information about the input parameter. 

Required 
parameter 

Select this check box to make the parameter required when calling the 
function. If the check box is cleared, the parameter is optional and the 
function should be able to work without it. 

13.6.3.3 Details on Output Parameter 

 

Option Description 

Result parameter 
name 

The name of the parameter as it has been referred to in the function or 
script. 

Display name The name of the parameter as you want it to be displayed to the end 
users. 

Type The output type, which can be Value, Column or Table. This defines 
whether the output parameter can be one or more columns, or just a 
single value. 

Description Optional. Can contain more information about the output parameter. 
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13.6.3.4 Details on Save as Library Item 
This dialog is reached when you have selected to save a new item (e.g., a data function or a 
color scheme) in the library. 

 

Option Description 

Library path 
(Upper part of the 
dialog) 

Shows the path from the library root folder down to the folder 
where you are currently located in the library. You can navigate 
upwards in the folder structure by clicking on the name of a folder 
that you want to navigate to. 

Folder contents list 
(Middle part of the 
dialog) 

Lists all the folders and files in the folder you are currently 
located in. 

Name The name of the item as it will be displayed in the library. It is 
important that the title is informative with regard to what the item 
actually does. 
Note: The name can be 256 characters at most, and the following 
characters are not supported: 
\ / : * ? " < >  |  

Keywords (separated 
by semicolons) 

Keywords specific to the content of the item. Keywords are 
separated by a semicolon, i.e., if you write "temperature 
conversion; Fahrenheit" this will be two keywords, "temperature 
conversion" and "Fahrenheit". 
Keywords are used to group data functions in the Data Functions - 
Select Data Function dialog. A data function will appear in 
several different groups if it has multiple keywords. 
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New Folder... Opens the New Folder dialog where you can specify a new folder. 

Folder Permissions... Opens a dialog where you can change the folder permissions. 

13.6.3.5 Details on Data Functions - Select Function 
This dialog is used to select which data function in the library to execute. The data functions are 
organized by the keywords entered while saving them to the library. A data function can appear 
in several different groups if it has multiple keywords. Data functions without keywords are 
only placed in the default (All) group. 

► To reach the Data Functions - Select Function dialog: 
1. Open the analysis in which to apply the data function. 
2. Select Insert > Data Function.... 

 
Click to select a keyword in the Keywords list that matches the type of data function you are 
looking for. You can further limit the number of data functions shown by typing some text in 
the search field. This limits the data functions visible to the ones matching the current search 
expression. For more information about valid search expressions, see Searching in TIBCO 
Spotfire. 

13.6.3.6 Details on Data Functions - Parameters 
This dialog allows you to define how the input and output parameters of the selected data 
function should be handled. It is necessary to specify a mapping of all required parameters to 
Spotfire in order to use the data function. 
If you have reached the dialog from the Document Properties - Data Functions dialog then any 
previously executed output cannot be changed. When a data function already has been executed, 
only the input parameters and previously unspecified output parameters are available. Execute 
the data function from the Insert menu again if you need to change some of the other output 
parameter settings. 
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► To reach the Data Functions - Parameters dialog: 
1. Open the analysis in which to apply the data function. 
2. Select Insert > Data Function.... 
3. Click to select the function of interest from the list, then click OK. 

Input tab 

 

Option Description 

Name Lists the name of the selected data function. 

Refresh function 
automatically 

Select this check box to update the results from the data function 
automatically each time the input settings are changed. If the check 
box is cleared, a manual refresh is needed in order for any updates to 
take effect. 
A data function set to load automatically will switch to manual update 
if cyclic dependencies are detected in the analysis. 

Input parameters Lists all input parameters that have been defined for the selected data 
function. Select an input parameter in this list to edit its settings. 

Input handler Lists all possible input handlers for the selected input parameter. 
Depending on which input handler you select in this list, a different set 
of settings is available to the lower right in the dialog. 

[Input handler 
settings] 

See the table below. 

OK Executes the selected data function. 
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Input handler settings 
Note that which input handlers are available depends on the type of input parameter that is 
selected (Value, Column or Table). You will not be able to select from all of the input handlers 
described below when specifying the input for a selected parameter. 

Option Description 

Column   

   Data table Allows you to select the data table from which to retrieve the 
input column. 

   Column Allows you to specify which column to use as input from the 
selected data table. 

   Limit by Use a combination of filtering and markings to limit the 
calculations to rows matching the specified settings only. If more 
than one option is selected then calculations will be performed for 
rows matching the intersection of the selected filtering and 
markings only. 
Leave both the Filtered rows and the Marked rows check boxes 
blank to base calculations on all rows. 

      Filtered rows Select this check box to limit the calculations to rows remaining 
after filtering with the specified filtering scheme. 

      Marked rows Select this check box to limit the calculations to rows marked by 
the selected markings. 
If more than one marking is available in your analysis you need to 
determine which marking or markings to control the calculation. 
If more than one marking is selected, then calculations will be 
performed for rows matching the intersection of the markings. 

Columns   

   Data table Allows you to select the data table from which to retrieve the 
input columns. 

   Columns Lists the selected input columns. Click Select Columns... to 
change columns. 

   Select Columns... Opens a dialog where you can specify which columns to include 
as input to the function. 

   Limit by See a description of the options under Column above. 

Expression   

   Data table Allows you to select the data table to evaluate the expression 
against. 

   Expression Displays the expression. 

   Edit... Opens the Edit Expression dialog where you can specify an 
expression. 

   Limit by See a description of the options under Column above. 
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Value   

   Value Allows you to type an input value in the text box. 

Document property   

   Property Allows you to select a document property to use as input. Use the 
search field to help locate your property. 

   New... Opens the New Property dialog where you can define a new 
document property to use as an input parameter. 

   Edit... Opens the Edit Property dialog where you can change the value of 
the selected property. 

   Delete Deletes the selected property. 

Data table property   

   Data table Allows you to select the data table to work with. 

   Property Allows you to select a data table property to use as input. Use the 
search field to help locate your property. 

   New... Opens the New Property dialog where you can define a new data 
table property to use as an input parameter. 

   Edit... Opens the Edit Property dialog where you can change the value of 
the selected property. 

   Delete Deletes the selected property. 

Column property   

   Data table Allows you to select the data table to work with. 

   Column Allows you to select which column to work with. 

   Property Allows you to select the column property you wish to use as 
input. 

   New... Opens the New Property dialog where you can define a new 
column property to use as an input parameter. 

   Edit... Opens the Edit Property dialog where you can change the value of 
the selected property. 

   Delete Deletes the selected property. 

None No input handler has been selected. This can be used for optional 
input parameters. If the input parameter is required, you must 
specify a different input handler to be able to continue. 

  



TIBCO Spotfire 4.0.2 - User's Manual 

942 

Output parameters tab 

 

Option Description 

Name Lists the name of the selected data function. 

Refresh function 
automatically 

Select this check box to automatically update the results from the data 
function each time the input settings are changed. If the check box is 
cleared, a manual refresh is needed in order for any updates to take 
effect. 

Output parameters Lists all output parameters that have been defined for the selected data 
function. Select an output parameter in this list to edit its settings. 

Output handler Lists all possible output handlers for the selected output parameter. 
Depending on which output handler you select in this list, a different 
set of settings will become available in the lower right portion of the 
dialog. 

[Output handler 
settings] 

See the table below. 

OK Executes the selected data function. 
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Output handler settings 
Note that which output handlers are available depends on the type of output parameter that is 
selected (Value, Column or Table). You will not be able to select from all of the output handlers 
described below when specifying the output for a selected parameter. 

Option Description 

Data table   

   Create a new data 
table 

Allows you to create a new data table with the name specified in 
the text field. 

   Replace existing data 
table 

Allows you to replace a previously added data table by selecting it 
from the drop-down list. 

Columns   

   Data table Allows you to select a data table where the result columns should 
be placed. 

   Map to input rows Allows you to specify how the resulting values should be added to 
the data table. For example, if you have chosen to calculate results 
for filtered values only, you will probably want to add the results 
to those rows that were filtered when the calculation was 
performed. 

   Replace columns on 
update 

Select this check box if you want the results to update the 
columns in the data table rather than adding new columns for each 
calculation. 

Rows   

   Data table Allows you to select a data table destination where the resulting 
rows should be placed. 

    Replace rows on 
update 

Select this check box if you want the results to update existing 
rows in the specified data table rather than adding new rows for 
each refresh. 

Document property   

   Property Allows you to specify which document property to update using 
the output from the data function. 

   New... Opens the New Property dialog where you can define a new 
document property to use as an output parameter. Note that a 
property created at this point will not be of any specified data 
type, and the property will not be created until the data function 
has successfully finished its execution. 

   Edit... Opens a dialog where you can change the name of a newly 
created property. Note that you cannot edit properties that have 
been created before entering the Data Functions - Parameters 
dialog. 

   Delete Deletes the selected property. (Newly created properties only.) 
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Data table property   

   Data table Allows you to specify which data table the property is associated 
with. 

   Property Allows you to specify which data table property to update using 
the output from the data function . 

   New... Opens the New Property dialog where you can define a new data 
table property to use as an output parameter. Note that a property 
created at this point will not be of any specified data type, and the 
property will not be created until the data function has 
successfully finished its execution. 

   Edit... Opens a dialog where you can change the name of a newly 
created property. Note that you cannot edit properties that have 
been created before entering the Data Functions - Parameters 
dialog. 

   Delete Deletes the selected property. (Newly created properties only.) 

Column property   

   Data table Allows you to specify which data table the property is associated 
with. 

   Column Allows you to specify which column the property is associated 
with. 

   Property Allows you to specify which column property to update using the 
output from the data function. 

   New... Opens the New Property dialog where you can define a new 
column property to use as an output parameter. Note that a 
property created at this point will not be of any specified data 
type, and the property will not be created until the data function 
has successfully finished its execution. 

   Edit... Opens a dialog where you can change the name of a newly 
created property. Note that you cannot edit properties that have 
been created before entering the Data Functions - Parameters 
dialog. 

   Delete Deletes the selected property. (Newly created properties only.) 

None No output handler has been selected. Use this option when the 
data function is set up with many output parameters and there is 
one output parameter that you do not want to use in the current 
calculation. 
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13.6.3.7 Details on Select Columns 
This dialog allows you to select a number of columns on which to base the selected 
calculations. 

 

Option Description 

Available columns Lists all columns available for selection. 

[Type to search] Type a search string to limit the number of items in the Available 
columns list. It is possible to use the wildcard character * in the search. 
See Searching in TIBCO Spotfire for more information. 

Selected columns Lists the columns selected to be used in this particular location. 

Add > Adds the columns selected in the Available columns list to the Selected 
columns list. 

< Remove Removes the selected columns from the Selected columns list. 

Remove All Removes all columns from the Selected columns list. 

Move Up Moves the selected column up in the Selected columns list. The order 
of the columns in this list determines the order of the columns in the 
temporary data table to be used in calculations. 

Move Down Moves the selected column down in the Selected columns list. The 
order of the columns in this list determines the order of the columns in 
the temporary data table to be used in calculations. 

13.6.3.8 Details on TIBCO Spotfire Statistics Services Login 
This dialog is shown when the TIBCO Spotfire Statistics Services administrator has turned on 
Authentication and you try to execute a data function. Enter your credentials and click Login. 
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Option Description 

Username Type your TIBCO Spotfire Statistics Services username. 

Password Type your TIBCO Spotfire Statistics Services password. 

URL The URL to TIBCO Spotfire Statistics Services that you are trying to 
connect to. 

13.6.4 Data Type Mapping 
Data dimensions 

TIBCO Spotfire data S-PLUS / R data 
Value Vector  of length 1 (list for timeDate) 

Column Vector (list for timeDate) 

Data table data.frame 

Data types sent and received via S-PLUS / R data functions 

TIBCO Spotfire data 
type 

Class (mode)  for S-PLUS / R data 
type 

Integer integer (numeric) 

Real numeric (numeric) 

SingleReal single (numeric)   --  not supported with R 

String - encoded as UTF-16 character (character) --  encoded as ISO8859-1 

Date timeDate (list) 

Time timeDate (list) 

DateTime timeDate (list) 

Boolean logical (logical) 

Binary raw (raw)  -- only supported for a single value 

• A timeDate value received from S-PLUS / R is always stored as DateTime in TIBCO 
Spotfire. 
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• S-PLUS / R factors are sent from TIBCO Spotfire Statistics Services as strings. 
• Other data types than the ones described above are not supported. 

Support for invalid values 
All numeric invalid values in TIBCO Spotfire are represented as NAs in S-PLUS / R. There is 
no special support for invalid values of other types; they become valid default values in S-PLUS 
/ R. 

Calling conventions for functions 
The names of the data function input arguments must match the names of the S-PLUS / R 
function arguments. 
For functions that return only one value (not a list of values), the single data function output 
parameter will be matched to the value. 
For functions returning a list of values, the data function output parameters must match the 
names of the list elements. 
  
Concerning R: 
R is available under separate open source software license terms and is not part of TIBCO 
Spotfire.  As such, R is not within the scope of your license for TIBCO Spotfire. R is not 
supported, maintained, or warranted in any way by TIBCO Software Inc.  Download and use of 
R is solely at your own discretion and subject to the free open source license terms applicable to 
R. 
  

13.6.5 Name Encoding for Column Names Sent to Spotfire 
Statistics Services 

Column names in TIBCO Spotfire are stored as UTF-16 encoded strings, while variable names 
in TIBCO Spotfire Statistics Services are built from 8-bit ASCII characters matching [.0-9a-zA-
Z]. Thus, the column names that are sent to TIBCO Spotfire Statistics Services must be 
encoded. This is done automatically when sending data to TIBCO Spotfire Statistics Services 
via the built-in data functions input handlers. If you need to provide column name input by 
some other means (e.g., via a document property) you may need to use the NameEncode 
function manually, in order to encode the column names prior to applying the data function. 
Decoding may be necessary to interpret column names when the result from a data function is a 
text report about the columns. Use the NameDecode function to decode results that have not 
been automatically decoded by Spotfire output handlers. 
NameDecode (and NameEncode) can be written as an S-PLUS script for ASCII and ISO-8859-
1 characters. 
Code UTF-16 to 0-9a-ZA-Z and . 
Let 0-9, a-z, A-Z be the digits in a 62-base system. Cast 16-bit characters to unsigned short 
integers and write those integers in the 62-base system. Example; '£' is casted to 162, this is 
coded to '02C'. Let .. be the starting tag for a coded character. 
The code range will be ..001 to ..h31 (where h31 is equal to 65635 in the 62-base system). 

Code  examples: 
NameEncode("Column.2") = "Column.2" 
NameEncode("Column 2") = "Column..00w2" 
NameEncode("Column £") = "Column..00w..02D" 
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13.7 Information Designer 
13.7.1 What is the Information Designer? 

The Information Designer is a tool for setting up data sources and creating and opening 
information links. An information link is a database query specifying the columns to be loaded 
and any filters needed to narrow down the data table prior to creating visualizations in TIBCO 
Spotfire. In Information Designer, information links are created from building blocks such as 
columns and filters using joins, calculations and aggregations. 
The Elements tree in Information Designer is a representation of the folder structure in the 
library. The permissions for each folder specify which databases and elements should be 
available for different users or groups when creating information links. Folder permissions can 
be specified in the Information Designer, but the main permission handling is done with the 
Library Administration tool. 
Once information links have been created in Information Designer, they can be opened by any 
user who has the appropriate licenses, allowing users who may not have knowledge of SQL or 
the underlying database structures to be able to execute advanced database queries. 
Information links are opened by selecting File > Open From > Library.... 
Note that neither the Information Designer, nor the resulting information links are available 
when you are working offline. 
  

13.7.2 General Workflow 
This is the general workflow for using Information Designer: 

1. Set up the data sources 
Enter the information required to connect to the databases which will be accessed through 
Information Designer. 

2. Create folders for storing elements and set permissions 
The library is a hierarchical structure where data sources, elements and information links can be 
organized into folders. Given that the library is also used for storing analysis files, it could be 
worthwhile to spend some time thinking over a suitable structure.   
Different groups of users are given different levels of access to data.  

3. Combine tables by creating joins 
If you want to work with data from different tables, you first need to create joins. 

4. Define column elements from available data sources 
Define the column elements to be shown when creating information links. These columns can 
be taken directly from tables in one or more databases. They can also be calculated, filtered or 
otherwise modified. 

5. Create filter elements to limit the data retrieved 
Create filter elements with descriptive names to be applied when creating information links. 

6. Create information links 
Create information links that retrieve data from one or more databases and share them with your 
colleagues. 
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13.7.3 General Guidelines for Setting Up an Information 
Model 

The Information Model (IM) concept aims to supply each end user with the data they need, with 
a minimum of effort and confusion.  Consequently, when building an IM, it is important to 
understand who the end users are and what data they require for their work. 
Who are the end users? 
Permissions are set on the folder level. Finding groups of users who work on related data will 
give you a good clue about the folder structure you should implement. Do not give all users 
access to everything - this will only cause confusion. 
What data do they need? 
What information is needed? How much data can users handle in a single request? Are there 
any commonly used threshold values? Answering these questions will guide you in setting up 
the correct joins, columns and filters. 
Will users build their own information links? 
Some end users will want to use the column and filter elements that you design, and assemble 
their own information links using Information Designer. Others will be less experienced, or may 
perform repetitive tasks. For these you should consider preparing complete information links in 
advance. 
Tip: If your data source contains well-ordered data you can right-click on the data source and 
select Create Default Information Model... in order to quickly set up a simple information 
model. 

13.7.4 Icon Explanations  
In the Elements tree, the following icons may appear. Click on a link in the table below to find 
out more about each element type. In the Data sources tree only the items belonging to a 
database are visible. 

Icon Element type 

 

Folder 

 

Information link 

 

Filter 

 

Boolean column 

 String column 

 Integer column or LongInteger column 

 Real, ShortReal or Currency column 

 

Date column 

 

DateTime column 

 

Time column 

 

Procedure 

 

Binary Large Object 

 

Character Large Object 



TIBCO Spotfire 4.0.2 - User's Manual 

950 

 

Join 

 

Database instance. 

 

Database link/catalog - a link to another database. 

 
Schema - a collection of tables and/or procedures. 

 

Table - a set of columns. 

 

Table alias. You can create a duplicate reference to a database table from 
Information Designer. This duplicate is called a Table Alias. 

 Unknown column. 
Must be set manually to one of the accepted column types (above) before it can 
be saved as a column element. 

13.7.5 Fundamental Concepts  
The Information Designer in TIBCO Spotfire requires no prior knowledge of query languages 
such as SQL. However, it is important to understand a few terms and concepts as they are used 
in this product: 

• Information links 
• Column elements 
• Filter elements 
• Folders 
• Procedures 

13.7.6 Information Links 

13.7.6.1 Information Links 
An information link is a structured request for data which can be sent to the database. These 
specifications include one or more columns, and may include one or more filters. 
Stated in plain English, an information link could be: "Fetch the Name, Address and 
Phone_number for employees that pass the filter High_Income." 
Information links can also be used to limit what data to open in an analysis in a number of 
different ways. See Loading Data Overview for a summary of the various methods. 

13.7.6.2 Editing Information Links 

13.7.6.2.1 Creating an Information Link  
Information Designer allows you to create information links. The building blocks are column-, 
filter- and procedure elements that have been set up by you or the database administrator. 

► To create an information link: 
1. Click New and select Information Link. 

Response: An Information Link tab is opened. 
2. In the Elements tree, select the column or filter element that you want to include. You 

can also include procedures. 
Comment: If the Elements tree is not visible in the left-hand pane, click on the 
Elements tab to display it. Click the + symbol to expand a folder. You can select 
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multiple elements simultaneously by pressing Ctrl and clicking on the elements of 
interest, or by pressing Shift and clicking on the first and last element in a list. 

3. Click Add >. 
Response: The selected element is added to the Elements list on the Information Link 
tab. 
Comment: To remove an item from the information link, select the item and click < 
Remove. 

4. If the selected elements come from more than one data source table, you need to 
specify a Join path. This means that you must create all joins needed to link all data 
tables together and you must also specify these in the Join path section on the 
Information Link tab. 

5. In the Description field, type some text describing the purpose of the information link. 
This is optional. 

6. If you want to filter the data, open the Filters section and follow the instructions under 
Adding Hard Filters. 

7. If you want to add prompts (run-time filtering), open the Prompts section and follow 
the instructions under Adding Prompts. 

8. Optionally, you can also choose to specify any Conditioning, Parameters or 
Properties that are needed for your information link. See Information Link Tab for 
more information. 

9. Click Save. 
Response: The Save As dialog appears. 

10. In the folder tree, select where you want the information link to be saved. 
11. In the Name field, type a name for the information link. 
12. Click Save. 

Response: The new information link is added to the library. It can now be accessed by 
other users. 

Tip: You can test the information link directly by clicking on Open Data. 
Tip: You can view and edit the SQL behind the information link by clicking SQL.... 

13.7.6.2.2 Modifying an Information Link  
If you have Browse + Access + Modify permission to a folder, you can edit existing 
information links in that folder. 

► To modify an information link: 
1. In the Elements tree, double-click on the information link you wish to edit.  

Response: The content of the information link is opened in a new Information Link 
tab. 

2. Edit the link in the Information Link tab by adding or removing elements or by 
changing the filtering or prompting for a column. 

3. Open the modified link by clicking Open Data or save it by clicking Save. 
Comment: Replace the old information link by choosing the same name and folder 
location as the old link. Type a new name (or put the link in another folder) to keep 
both the old and the modified information links. 

Note: Some characters are forbidden in the element names and file system of TIBCO Spotfire 
3.0 and forward: /\*"?:<>| 
Old information models with element names containing these characters can be imported. 
However, you cannot edit and resave elements using their old names if they contain forbidden 
characters. 
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13.7.6.2.3 Deleting an Information Link  

► To delete an information link from the Information Model: 
1. In the Elements tree, right-click on the information link you wish to delete.  
2. Select Delete from the pop-up menu. 

Response: A dialog appears, prompting you to confirm that you want to delete the link. 
3. Click OK. 

13.7.6.2.4 Adding Hard Filters  
Hard filters are set up as you define the information link and are saved with the link. This means 
that they cannot be reused in other links. Also, hard filters can only specify a range or a list of 
values, and are therefore less complex than filter elements. 

► To add hard filters for a column: 
1. Create an information link. 
2. Go to the Filters section on the Information Link tab for that information link. 
3. Click Add. 

Response: The Add Column dialog is displayed. 
4. Select the column for which you wish to add a hard filter from the drop-down list. 
5. Click OK. 

Response: The column is added to the Filters list. 
6. Repeat steps 3 to 5 add filters for more columns. 
7. For each column, use the Filter Type drop-down list to select whether to filter by 

range or by values. 
Comment: Filtering by range means entering the upper and lower limits of the desired 
range. Filtering by values means entering the exact values that you want to include in 
the returned data, separated by semicolon. 

8. Set the upper and lower limits (range) in the Min Value and Max Value fields, or type 
the desired values, separated with semicolons in the Values field. You can also type 
?param_name in the Values field to use a parameter as the filter for the chosen 
column, where param_name is the name to identify the parameter by. 
Comment 1: Limits are inclusive. In other words, if the lower limit is set to 1000, the 
value 1000 will be included in the data table. 
Comment 2: When setting upper and lower limits on columns of type String, 'A' is 
considered to come before 'AA', and 'S' comes before 'Smith'. This means that the 
name 'Smith' will not be present when choosing names from 'D' to 'S'. The order of 
characters is standard ASCII. 

Tip: When entering values for filtering you are allowed to use wildcard characters. These are: 

* Matches any characters (example: '*mber' would return the following months: 
September, November and December). 

? Matches any single character (example: '???ember' would only return the months 
November and December). 

13.7.6.2.5 Adding Prompts  
An alternative to setting filter conditions in the Filters section (see Adding Hard Filters) is to 
configure your information link to prompt for filter values as the columns are retrieved. This 
way you do not have to specify filter conditions in advance. The data table will be pared down 
before the next column in sequence is processed (unless you have specified prompt groups to 
treat the columns as independent). See Prompted Information Link Example for further 
information. 
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► To enable prompts: 
1. Create a new information link or modify an existing link. 
2. On the Information Link tab, go to the Prompts section. 
3. Click Add. 

Response: The Add Column dialog is displayed. 
4. Select the column for which you wish to add a prompt from the drop-down list. 
5. Click OK. 

Response: The column is added to the Prompts list. 
6. Repeat steps 3 to 5 add prompts for more columns. 
7. For each column, use the Prompt Type drop-down list to select how you want to be 

prompted for filter conditions during data retrieval. 
Comment: Selecting Values will let you enter a list of values to include. Range will let 
you specify a range of values. Multiple selection will present a list of available values 
from which you can select multiple values. Single selection will present a list of 
available values from which you can select a single value. 

8. Save the information link, or open it. 
Note: When opening a prompted information link, the prompts will appear in the order that the 
columns appear in the Information Link tab. You can use the Move Up and Move Down buttons 
to move columns up or down. (Filter elements are always applied before any prompts, 
regardless of order.) 
Tip: When entering values for filtering you are allowed to use wildcard characters. These are: 

* Matches any characters (example: '*mber' would return the following months: 
September, November and December). 

? Matches any single character (example: '???ember' would only return the months 
November and December). 

13.7.6.2.6 Using Prompt Groups  
The default behavior of prompted information links is that each subsequent step lists values 
based on earlier selections (See Prompted Information Link Example). However, if you are 
working against a STAR schema database the procedure may require multiple joins since the 
elements queried for the prompts can only be joined by also joining over the large fact table in 
the STAR schema. This may result in very long times passing between each prompt. To avoid 
the long prompt times, it may be useful to treat the various elements as independent and avoid 
filtering upon each prompt step. This can be accomplished by using prompt groups. 

► To use prompt groups to make elements independent: 
1. Create a new information link or modify an existing link. 
2. In the Information Link tab, go to the Prompts section. 
3. Click on Groups.... 

Response: The Prompt Groups dialog is displayed. 
4. For each element, specify a prompt group by clicking on the number to the right of the 

column name. 
Comment: All column elements belonging to the same prompt group will depend on 
each other and, hence, filtering will be performed between each prompt step for these 
elements. Elements belonging to a different prompt group will be independent of all 
filtering made within a different prompt group. Note that setting columns or filters as 
independent may result in no data returned from the information link. 

5. Save the information link, or open it. 
Note: By specifying a separate prompt group for an element no previous selections in the 
prompt steps will be reflected in the listing for this (independent) element. Neither will any of 
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the selections made in the prompt step for the independent element be reflected in later prompt 
steps (regardless of whether the later prompt steps are independent or not). 

13.7.6.2.7 Adding Procedures 
Procedures are added to an information link in the same way as any other elements such as a 
column or a filter. You select them from the Elements tree and click Add >. The procedure icon 
looks like this:  

Priority of Execution: 
You can include column elements, filter elements and procedure elements in the same 
information link. These will be executed in a certain priority order when the information link is 
executed: 

• All pre-update procedures will execute in top-down order. The procedure is executed 
before any data is retrieved. No data is expected from the pre-update procedure, and no 
join is performed. Any prompting will occur in the top-down order. 

• All query procedures and column elements will execute in top-down order. The 
procedures run as a part of the data retrieval. Data from the procedures are joined with 
the rest of the columns. Any prompting will occur in the top-down order. 

• All post-update procedures will execute in top-down order. The procedure is 
executed after the data has been retrieved. No data are expected from the post-update 
procedure, and no join is performed. Any prompting will occur in the top-down order. 

Note that the order of the elements in the user interface only has significance for the elements of 
the same "priority class". A pre-update procedure will always execute before a query procedure 
regardless if that pre-update procedure is placed at the bottom of the list. 

13.7.6.2.8 Parameterized Information Links 
Using parameterized information links you can set up a data source to return only information 
applicable for a certain user or group. Depending on which user is logged in and accesses the 
information link, or, for example from where the user accesses the information link, different 
subsets of the data will be available. 
The concept is similar to the personalized information links, but more general, and in need of 
API configurations to work properly. While the parameters are created in Information Designer, 
their properties and definitions are defined in the API. 
A parameterized information link is an information link that contains a number of parameters. 
In Information Designer, you define these parameters with a name and a type, and can use the 
parameters when creating various elements in the information link. To be able to open a 
parameterized information link in Spotfire, the values for these parameters must be provided. 
How is determined in the API. 

Why use parameters? 
Parameters can be used if you, for example, wanted to set up the Web Player from an external 
source. If the Web Player is integrated into a portal or similar, the contents of the analysis can 
be defined by parameters. The values of these parameters can then be defined by another 
application in the portal, or by settings the users have applied in other parts of the portal. 
Another example is if you wanted to create an analysis file but then be able to easily create 
different versions of it for different users. You can then set up a template file using 
parameterized information links, and from that file, and using the API, create different files with 
different parameter values. 
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Where can parameters be included? 

Element 
Type Parameterized Property 

Column Column calculation. 
Aggregate column key expression. 
Filter condition. 

Filter Filter condition. 

Procedure Input parameter default value. 

Information 
Link 

Static filter. 
Edited SQL (Pre-updates, Query, Post-updates). 

Data Source Open session commands. 
Close session commands. 

Examples: 
For filter condition expressions, parameters can be used as the condition for the selected 
columns. 

 
  
In the SQL editor, you can set parameters directly. 
  

FROM 
   "Sales"."dbo"."SalesandCost" S1 
WHERE 
   (S1."Sales" > ?MinSales) 

Note: If you alter parameters in the SQL code, the changes will override the parameter settings 
made elsewhere, such as the filter part of the information link tab. 

Syntax 
The syntax of the naming of the parameterized information links is: 
?param_name 
Where "?" indicates that it is a parameter and param_name is the name the parameter is 
identified by. 
Note: The parameter name should start with a letter from A-Z or a-z and can contain the 
following characters: a-z, A-Z, 0-9, _ and '.'. 
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13.7.6.2.9 Editing a Parameter 

► To edit a parameter: 
1. Make sure the information link of interest is opened on an Information Link tab. 
2. Click Parameters. 
3. Select the parameter you want to edit. 

Comment: You may need to click Refresh to be able to see the parameter, Note that if 
you have edited the SQL of the information link, the altered SQL code overrides the 
parameters settings in the user interface and a parameter that was added in, for 
example, the filters section of the information link tab will not be visible. 

4. Click Edit... 
Response: The Edit Parameter dialog is displayed. 

5. Change Data type and/or Value type. 
6. Click OK. 

  

13.7.6.2.10 Personalized Information Links 
Using personalized information links you can set up a data source to return only information 
applicable for a certain user or group. Depending on which user is logged in and accesses the 
information link, different subsets of the data will be available. For example, you could set up 
an information link that detects whether the user retrieving data is a member of the sales force 
for Europe, Asia or the US and only return data for that continent. 
Below are two examples of personalized information links. The first will retrieve data 
depending on which user is logged in, the second depending on which groups that user is a 
member of. 

User Name via Lookup Table 
Scenario: You want to set up an information link to a data table showing sales made by all the 
sales people in the company. However, depending on which person from the sales department 
accesses an analysis using this information link, only the sales figures pertaining to that single 
user should be retrieved. 
First, take a look at the Sales table containing the total sales of every person in the sales force. 

Order ID Employee ID Product Sale ($) 
1 101 Cornflakes 100 

2 150 Soda 550 

3 244 Cornflakes 160 

4 101 Mineral water 400 

5 101 Soda 120 

6 339 Mineral water 200 

 Then you must create a "Lookup Table" on the data source, that matches the Employee ID to 
the actual Spotfire Username for each person logging into the TIBCO Spotfire Server. 

 Spotfire Username Employee ID 
mikesmith 101 

lauraclarke 150 

sarahdonovan 244 

malcolmreynolds 339 
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Next, you create a Filter or Column element that constrains the "Spotfire Username" column to 
only return values for the currently logged in user. (In the example below, a new, restricted 
column element is created by adding the personalized condition as a hard filter on the column 
element. This is the column element that will be used in the information link.) 

 
  
An example of the resulting SQL for the user malcolmreynolds  would be: 
 "LookupTable"."Spotfire Username" = 'malcolmreynolds'. 
Finally, you create a Join between the Sales table and the Lookup table—joining the Employee 
ID columns. 
Add the restricted column element (or the filter element) to an information link, together with 
any other columns of interest and save it. The information link is now ready to be used and will 
only retrieve data for the currently logged in user. 
  

Group Membership 
Scenario: You want to set up an information link to a data table showing sales made by all the 
sales people in the company. However, depending on which person from the sales department 
accesses an analysis using this information link, only the sales figures pertaining to the region 
that sales person is assigned to should be retrieved. For example, if a sales person is working in 
the East region, she should only be allowed to see sales figures made in that region (by any 
person). 
The Spotfire Administrator has created groups on the Spotfire Server named SalesForce-East, 
SalesForce-West, SalesForce-South, and SalesForce-North. Each sales person is a member of 
one or more of these. 
Note: You can also create a Lookup table, just as in the first example, in which you assign 
various users or groups to categories that match your Sales table. That way you do not need to 
create superfluous groups on the Spotfire Server if groups with matching names are not already 
available. 
You then take a look at the Sales table containing the total sales of every person in the sales 
force. 

 Order 
ID 

Employee 
ID 

Region Product Sale ($) 

1 101 SalesForce-East Cornflakes 100 

2 150 SalesForce-West Soda 550 

3 244 SalesForce-North Cornflakes 160 

4 101 SalesForce-East Mineral water 400 

5 101 SalesForce-East Soda 120 

6 339 SalesForce-East Mineral water 200 
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Next, you add a Filter or Column element that constrains the "Region" column so that it only 
returns values if the currently logged in user is a member of a group with that exact name. (In 
the example below, a new, restricted column element is created by adding the personalized 
condition as a hard filter on the column element. This is the column element that will be used in 
the information link.) 

 
An example of the resulting SQL for a user belonging to the SalesForce-East and the 
SalesForce-North groups would be:  "SalesTable"."Region" = ('SalesForce-East','SalesForce-
North'). 
Add the restricted column element (or the filter element) to an information link, together with 
any other columns of interest and save it. The information link is now ready to be used and will 
only retrieve data for groups that the currently logged in user is a member of. 

Syntax 
The syntax for the personalized information link parameters is: 
%CURRENT_USER% 
and 
%CURRENT_GROUPS% 
  

13.7.6.2.11 Editing the SQL of an Information Link  
Information links are created using the Information Designer. However, sometimes there may 
be situations where complex SQL queries are needed that cannot be generated by Information 
Designer and the elements in the information model. An example might be to retrieve 
information from relational databases or databases with complex schemas, where queries 
generated by Information Designer are not fast enough and need tuning to reach an acceptable 
performance. For those purposes the possibility to manipulate the generated SQL of an 
information link has been introduced. 

► To modify the SQL of an information link: 
1. Make sure the information link of interest is opened on an Information Link tab. 
2. Click SQL.... 

Response: The Edit SQL dialog is displayed. 
3. Select the Data source that you want to work with from the drop-down list. 

Comment: Complex information links may contain elements from several different 
data sources. You can only edit the SQL part of the query that belongs to a single data 
source at a time. After you have saved your first changes you can switch to another 
data source to edit the rest of the SQL. 

4. To edit Pre-Updates, Query or Post-Updates, click the corresponding radio button. 
Comment: Use Query to modify the SELECT statement of the information link. Use 
Pre-Updates or Post-Updates to add new statements or scripts to be run before or 
after the data retrieval. 

5. Edit the SQL statement (or add Pre- or Post-Updates) in the Modified SQL text box. 
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Comment: You can compare the changes that you have made in the Modified SQL to 
the Original SQL at all times. Multiple SQL statements are allowed as long as they 
are separated with a semicolon and new line (except the last statement in sequence). 
Comment: You can use parameters in your SQL statements (and in your Pre- and Post-
updates). 
Note: If you alter parameters in the SQL code, the changes will override the parameter 
settings made in, for example, the filter part of the information link tab. 

6. Click OK when you are finished. 
Comment: If you change your mind and want to start over with the original SQL, click 
Reset to Original. 

Note: The modified SQL is not validated before execution. For this reason, you should not: 
• alter the name of a column (the AS-part of SELECT xxx AS yyy) 
• alter the number of columns returned 
• alter the datatype of columns returned 
• alter the order of columns returned 
• remove <temporary_result_#> from the FROM-clause in information links that go 

against multiple data sources 
• remove the trailing WHERE <conditions>, as it will be replaced by any conditions 

applied at runtime 

13.7.6.2.12 Selecting Join Path 
When you are using columns from more than one table in the same information link you have to 
specify a join path between all used tables. If multiple joins are created, you can specify which 
joins will be the default ones. The default joins will be presented in the join path field when the 
Suggest Joins button is clicked (if they are suitable for the current information link). 
However, sometimes you may want to specify a different join path for an information link. 
Let's say the default join path between Table 1 and Table 4 is via Table 3 and the joins 
TABLE1.ID=TABLE3.ID and TABLE3.NAME=TABLE4.NAME. 

 
For a certain information link this is not what you want, instead you wish to configure the link 
to join via Table 2 using the joins TABLE1.ID=TABLE2.ID and 
TABLE2.COST=TABLE4.COST. 
This can be done in the Join Path section for the information link by simply selecting the 
desired joins instead of the suggested ones. 
 

► To Select a Join Path: 
1. Go to the Join Path section on the information link tab. 
2. Select a join from the Joins tree that you wish to use and click Add. 
3. Response: The new join is added to the Selected Joins list. 
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4. Repeat step 2 for any additional joins. 
5. Click Save to save the information link. 

Comment: The Selected Joins will be saved with the information link, and will always 
be used when retrieving data via the information link. 

Note: When executing an information link against several data sources, all subqueries are run 
first and then the main query, joining all subresults. This means that the joins in the main query 
are performed after all joins in the subqueries. 

13.7.6.3 Opening Information Links 

13.7.6.3.1 Opening Information Links from Information Designer  
Once defined, information links are normally opened by selecting File > Open From > 
Library.... However, you can also open information links from within Information Designer. 
This can be useful while creating the information link, or if you need to make some minor 
adjustments to the original information link. 

► To execute an information link from Information Designer: 
1. Create a new information link or edit an existing link (see Modifying an Information 

Link). 
Comment: You can also right-click in the Elements tree and select Open Data... from 
the pop-up menu. 

2. Click Open Data. 
Response: The query is executed, and the data is shown in TIBCO Spotfire. If the 
information link includes prompted filters, one or more dialogs will appear before the 
data is loaded. See Using Prompts for details. 

13.7.6.3.2 Using Prompts  

► To specify filter parameters during retrieval: 
1. Open an information link that contains prompts. 

Response: The system will begin to retrieve data. For each column with a prompt (see 
Adding Prompts) a dialog will appear, asking you to specify the filter conditions for 
this column. 

2. Enter the filter conditions that you want to apply. 
Comment: If you are using the Multiple selection or Single selection prompt methods, 
then you will find that only values that have not been eliminated by previous filter 
conditions (in the same prompt group) are shown. 

3. Click Next >, or Finish when you have come to the last column. 
Response: The data is retrieved and displayed in TIBCO Spotfire. 

Note: Dialogs are displayed in the order the columns appear in the Information Link tab. In 
other words, the first column for which a prompt has been added will be the first to display a 
dialog. 
 

13.7.6.3.3 Prompted Information Link Example  
Information links may include more than one column with prompts. In this case each filter will 
reduce the data table, so that subsequent prompts may present fewer values. (This can be 
overridden by using prompt groups.) Consider the following example: 
This is the data as it would look if no filters were being applied: 
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Name Salary Location 

Prompt: None Range Multiple selection 

Miller 1300 New York 

King 1400 New York 

Clark 700 New York 

Ford 1100 Dallas 

Adams 900 Dallas 

Scott 1300 Dallas 

Jones 1200 Dallas 

James 800 Chicago 

Turner 1000 Chicago 

As the information link is opened, Salary will be filtered first (the order is set in the Information 
Link tab). 

 
The user enters the limits 1100 to 1300. After the first filter, the following remains: 

Name Salary Location 

Prompt: None Range Multiple selection 

Miller 1300 New York 

Ford 1100 Dallas 

Scott 1300 Dallas 

Jones 1200 Dallas 

Several rows, including all Chicago employees, have been filtered out. This means that when 
the Location filter is shown, Chicago will not be presented as an option: 

 

13.7.6.3.4 Using Current Filter Settings as a Filter 
When opening information links with columns prompted for values (see Adding Prompts) it is 
possible to use the visual capabilities of TIBCO Spotfire to set these values. 

► To use the current visualization for filter definition: 
1. Open a suitable data table in TIBCO Spotfire. 
2. Choose a subset either by filtering or by marking rows. 
3. Open an information link that contains prompts. 
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4. When the Open Information Link dialog for the desired column appears, click Get 
Values.... 
Response: The Column Values dialog is displayed. 

5. From the Column drop-down list, select the column (in the visualized data table) from 
which you want to get the values. 

6. Click All rows, Filtered rows or Marked rows, depending on which values you want 
to use. 

7. Click OK. 
8. In the Open Information Link dialog, click Next > (or Finish if this is the last 

prompted column). 
9. Repeat steps 4 to 8 for each prompted column. 

Response: The data is loaded and displayed in a visualization. 

13.7.6.4 Transforming the Data 

13.7.6.4.1 Eliminating Duplicates  
Eliminating duplicates means removing all duplicate rows from the returned data table. By 
duplicates we mean rows where all fields are identical to all fields of another row. Consider the 
following example: 

Before removing duplicates 

Name Income 
Smith 1200 

Jones 700 

Banks 700 

Smith 1200 

Smith 900 
 

After removing duplicates 

Name Income 
Smith 1200 

Jones 700 

Banks 700 

Smith 900 
 

► To eliminate duplicates: 
1. Create a new information link or edit an existing link (see Modifying an Information 

Link). 
2. In the Information Link tab, go to the Conditioning section. 
3. Click Distinct. 
4. Open or save the information link. 

Response: Duplicate rows will be removed from the data table returned by this 
information link when it is opened. 

13.7.6.4.2 Pivoting Data in Information Designer  
Pivoting is a method of rearranging rows into columns. This flexibility allows you to rotate row 
and column headings around the core data. In general, pivoting is used to be able to carry out 
visual analyses on data that originally reside in a tall/skinny format. Pivoting may also be used 
to create more filters in the filters panel by splitting a column into several other columns. 

► To pivot data: 
1. Create a new information link or edit an existing link (see Modifying an Information 

Link). 
2. In the Information Link tab, go to the Conditioning section. 
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3. Select Pivot as conditioning type. 
4. Click Edit.... 

Response: The Pivot Conditioning dialog opens. 
5. In the Identity section, click Add... to select the columns that you want to use to 

identify rows. 
Comment: Each unique value in the chosen identity column produces a row in the 
generated table. 

6. In the Category section, click Add... to select the columns that you want to use for 
generating new columns in the new table. 
Comment: Each unique value in the chosen category column produces a new column 
in the generated table. 

7. In the Values section, click Add... to select the column that you want to aggregate. 
Comment: The column from which the data is pulled. The values in the generated table 
are computed according to the method selected under Aggregation method in the Add 
Column dialog. 

8. Type a Column name expression to use for naming the pivoted columns. 
9. In the Other columns section, click Add... to select any other columns that you want 

to include in the new table. 
10. Click OK. 

Response: The Pivot dialog is closed. 
11. Open or save the information link. 

Response: The data will be pivoted when the information link is opened. 

13.7.6.4.3 Example of Pivoting in Information Designer 
Pivoting a data table means changing it from a tall/skinny format to a short/wide format. 
Consider the following tall/skinny table, based on a series of temperature measurements: 

City Month Temp 

London February 4 

New York February 6 

London May 16 

New York May 19 

London August 28 

New York August 26 

London November 13 

New York November 11 

  
As we add more observations, the table grows taller, but remains three columns wide. While 
useful during data collection, this format may not be appropriate for certain types of 
calculations or visualizations. For example, the entities that interest us are the different cities, so 
we may want a representation with a single row for each city. 
Pivoting this table produces the following (note that avg(Temp) is the average of a single cell): 
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City avg(Temp) 
for February 

avg(Temp) 
for May 

avg(Temp) 
for August 

avg(Temp) 
for 
November 

London 4 16 28 13 

New York 6 19 26 11 

  
Each city is now represented by a single row. The following steps have been performed during 
the pivoting: 

• A row has been created for each unique value in City. 
• A column has been created for each unique value in Month. 
• A value from Temp has been entered for each cell in the resulting grid. 

The following settings were made in the Pivot Conditioning dialog to produce this result: 
• Identity: City 
• Category: Month 
• Values: Temp 

13.7.6.4.4 Example of Pivoting with Aggregation in Information Designer 
Note: To understand this example, it is recommended to read Example of Pivoting first. 
Apart from changing format from tall/skinny to short/wide, pivoting can be used to create a 
more compact table. Consider the following table, based on a series of temperature 
measurements: 

City Month Day Temp 

London February 1 5 

London February 15 8 

London May 1 15 

London May 15 22 

New York February 1 9 

New York February 15 7 

New York May 1 18 

New York May 15 24 

  
Tall/Skinny=>Short/Wide conversion lets us pivot and aggregate this table, producing the 
following: 

City avg(Temp) for February avg(Temp) for May 

London 6.5 18.5 

New York 8 21 
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A smaller table has been created, summarizing the original table. The following settings were 
made in the Pivot Conditioning dialog to produce this result: 

• Identity: City 
• Category: Month 
• Values: Temp 

13.7.7 Data Sources 

13.7.7.1 Data Sources Overview 
Data sources are the physical units from which data can be retrieved, usually databases. 
Connecting to a database requires technical know-how not always found among end users. 
Therefore, Information Designer lets the administrator make all the required settings in 
advance, including database name, username, password, etc. This information becomes part of 
elements and items in the library so that when an end user executes an information link, the 
connection to any required databases can be established automatically and invisibly. 
User authentication to the data source can be made in two ways. The first way is to set up the 
authentication while creating the data source connection. In this case, all users connect with the 
same credentials. This is a simple way to authenticate users when everyone has the same 
permissions to the data source. Further limitation of the access to a data source can be applied 
by placing the data source within a folder with limited permissions for some users or groups. 
For more information, see Setting Folder Permissions. 
The other way is to require authentication each time a connection is used. This is useful when a 
more detailed security model is required. Using user authentication, row level security can be 
obtained. The credentials can either be supplied by the user or by a plug-in when running an 
information link against this data source. A plug-in minimizes the number of times one has to 
log into the TIBCO Spotfire environment, leaving it up to the plug-in to deliver the data source 
credentials. Without a plug-in, users will have to supply their data source credentials in a 
prompt. Credentials can be cached in the data source so that users are prompted only once for 
each session. 
The layout and handling of the data sources affect most other actions involving the creation of 
information links. Therefore, it is most valuable to do a proper planning before starting to work 
on the layout. Modifications to the data sources after the structure has been set up in the library 
and information links have been defined will probably mean that some manual work is needed 
to make sure all information links are still functional. 

13.7.7.2 Creating a Data Source 

► To create a new data source: 
1. On the Start tab, click Setup Data Source. 

Response: A Data Source tab is displayed. 
2. In the Name field, type the name of the new data source. 
3. Specify the Type of the data source. 
4. Modify the Connection URL. 
5. Type a Username and Password that gives access to the data source. 
6. Select whether a user must be authenticated when accessing the data source. 

Response: If this option is selected, authentication is required when accessing this 
connection, either by the user or by a plug-in. If not selected, the credentials supplied 
above will be used for all users. Even if user authentication is selected, Username and 
Password must be supplied since they are used by Information Designer. 

7. Enter any additional configuration settings. 
8. Click Save. 
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Note: If you are connecting to a non-writable data source (for example, SAS/SHARE or 
ODBC) you must clear the Allow writing in temporary tables check box. 
Note: For SAS/SHARE and ODBC data sources, both Min and Max No of connections should 
be set to 0 in order to disable connection pooling. The same holds for other data sources that do 
not support pooled connection since there is no valid ping command. 

13.7.7.3 Modifying a Data Source 

► To modify an existing data source: 
1. In the Data Sources tree or in the Elements tree, double-click on the data source you 

wish to edit.  
Response: The data source settings are shown in a new Data Source tab. 

2. Change any fields. 
3. Click Save. 

Response: The data source is updated. 
Note: Some characters are forbidden in the element names and file system of TIBCO Spotfire 
3.0 and forward: /\*"?:<>| 
Old information models with data source names containing these characters can be imported. 
However, you cannot edit and resave data sources using their old names if they contain 
forbidden characters. 

13.7.7.4 Removing a Data Source 

► To remove a reference to a database: 
1. In the Data Sources tree, right-click on the data source you wish to delete.  
2. Select Delete from the pop-up menu. 

Response: A dialog appears, prompting you to confirm that you want to delete the data 
source. 

13.7.7.5 Creating a Table Alias in Information Designer 
You can create a duplicate reference to a database table from Information Designer. This 
duplicate is called a Table Alias, and references the very same data, only using an alias. This 
can be useful in certain cases, most often when in need of a self join within a table (below). 

► To create a table alias: 
1. Select a table on the Data Sources tab. 
2. Right-click the table and select Create Table Alias. 

 

 
3. Type a name for the table alias and click OK. 

Response: A table alias of the table is created. 

Self Joins 
A self join is a join from a table to itself. In Information Designer this is implemented by using 
a table alias. 
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ID Name Manager 
1 Sarah 2 

2 Mike 3 

3 Carla Null 

4 Vincent 2 

5 Adrian 3 

  
The above database table lists a number of employees at a company, and specifies who the 
manager of each employee is. Carla is the head of the department. Mike and Adrian report 
directly to Carla, whereas Sarah and Vincent report to Mike. 
In order to produce a list where the ID stated in the Manager column is replaced by a name (see 
below), we would need a self join in the table. The table needs to look up the ID column in 
itself. 

Name Manager 
Sarah Mike 

Mike Carla 

Carla   

Vincent Mike 

Adrian Carla 

  
This is done by first creating a Table Alias of the table, and then creating a join between the 
table and its alias: 
WHERE TABLE.ID=TABLE_ALIAS1.MANAGER 
  

13.7.8 Folders 

13.7.8.1 Folders Overview  

 

Folders are used to organize information links and other elements such as filters, 
columns and joins in the library. The hierarchical structure of the folders can be 
seen in the Elements tab of Information Designer, and they have the same 
collapsible and expandable behavior as folders in any tree structure. The folder 
structure in the library is independent of the physical location of data, so it is 
possible to combine elements from several different data sources in one folder. 
A folder may contain other folders. For example, a department may have a 
folder, within which each research group has its own subfolder. If you have 
administrative rights, you can control which users have access to specific folders.  
Folder permissions can be changed directly in the Information Designer by 
editing each folder, or by using the Library Administration tool. With TIBCO 
Spotfire 3.0 and forward it is also possible to place data sources within folders 
and, hence, control which users should have access to a certain data source 
through its folder permissions. 
The export and import of folders and their content is handled by the Library 
Administration tool. 
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13.7.8.2 Creating a New Folder in Information Designer 
To be able to save column and filter elements, you must first create a folder in the library. This 
can be done either in Information Designer or by using the Library Administration tool. 

► To create a new folder in Information Designer: 
1. Click New and select Folder. 

Response: The New Folder dialog is displayed. 
2. In the Name field, type the name of the new folder. 
3. In the Description field, type your own description of this folder (optional). 
4. If desired, you can add Keywords to help locate the folder when searching in the 

library. 
5. Click OK. 

Response: The folder is added to the library. 
Comment: If you want to change the permissions for the new folder, follow the 
instructions under Setting Folder Permissions. 

13.7.8.3 Setting Folder Permissions  
Access rights to different data sources, elements and information links in the library are 
specified on a folder level. If you have administrator rights, you can give users or groups which 
have been set up using the Administration Manager tool different levels of access to your 
folders. The folder permissions can also be changed in the Library Administration tool. 

► To set permissions for a folder in Information Designer: 
1. Create a new folder or edit an existing one. 
2. In the Elements tree, right-click on the folder of interest. 
3. Select Folder Permissions... from the pop-up menu. 

Response: The Library Folder Permissions dialog is displayed. 
4. Select whether or not you want the folder to Inherit permissions from parent folder 

by selecting or clearing the check box. 
If you choose to inherit permissions then you cannot specify any more details. Click 
OK and you are done. 
If you choose to set explicit permissions then proceed to the next step. 
Response: When the check box is cleared, the fields displaying the available groups 
and the different levels of permission become available. The previously inherited 
permissions are shown to give you a template to start working from. 

5. Use the drop-down list below the search field to select whether to Search users, 
Search groups or Search users/groups. 

6. In the search field, type a search expression to display  users or groups of interest and 
click Search. 
Tip: You can use wild cards, or asterisks (*), to simplify the search. For example, use 
* to display all users and groups, or append it to a word to display all users and groups 
beginning with that word. Example: Group4* will find Group41, Group421 and so on. 
  

7. Click to select the appropriate users or groups in the list and then click the > button of 
the permission level they should receive. 

8. Repeat steps 5 through 7 until you have added all the users and groups to the 
permission levels you want. 
Comment: To remove a user or group from a permission level, select it and click the < 
button for that permission level. 

9. Once you have selected the users or groups of interest, click OK. 
Response: The folder will be updated with the new permissions. 
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Note: What licenses are enabled for a certain user or group can also limit the functionality 
available for that user or group. 

13.7.8.4 Editing a Folder 

► To change the name and description of a folder: 
1. In the Elements tree, right-click on the folder that you want to edit. 

Response: A pop-up menu is displayed. 
2. Select Edit Properties... from the pop-up menu. 

Response: The Edit Properties dialog is opened with the information for the selected 
folder. 

3. Modify the desired fields. 
4. Click OK. 

Note: You can only edit the properties of folders where you have sufficient permissions. 
Note: Some characters are forbidden in the element names and file system of TIBCO Spotfire 
3.0 and forward: /\*"?:<>| 
Old information models with element names containing these characters can be imported. 
However, you cannot edit and resave elements using their old names if they contain forbidden 
characters. 

13.7.8.5 Deleting a Folder  

► To delete a folder and all its contents: 
1. In the Elements tree, right-click on the folder that you want to delete. 

Response: A pop-up menu is displayed. 
2. Select Delete from the pop-up menu. 

Response: The folder and all its content are deleted from the library. 
Note: You can only delete folders to which you have sufficient permissions. 

13.7.8.6 Moving a Folder  

► To move a folder and all its contents: 
1. In the Elements tree, drag the folder you wish to move and drop it on a different 

folder. 
Response: The folder and all its contents are moved to the new location. 

13.7.9 Joins 

13.7.9.1 Joins Overview  
Joins are used to define how rows in different tables relate to one another. Normally an 
identifier column in one table maps to a similar column in another table. This allows 
information links to draw values from two or more different tables. When column elements 
from two or more data tables are to be retrieved within the same information link you must 
always include a join path at the creation of the information link. Joins can also be set up 
between tables in different data sources. 
In the Elements tree, joins are represented by this icon:  
From a technical point of view, join elements can be placed anywhere in the tree structure. The 
Suggest Joins button on the Information Link tab helps you to find suitable joins for the 
currently used elements. However, you might want to place joins where they can easily be 
found. Just like filter and column elements, join elements are under permission control. This 
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means that you must make sure that the folder where the joins are located is accessible to all 
users and groups that need to create their own information links. 

13.7.9.2 Creating a Join in Information Designer  
If you want to combine columns from two disparate data sources, for example if one field is in a 
different table than the rest of the information, you need to create a join between two tables. 

► To create a join: 
1. Click New and select Join. 

Response: A Join Element tab is opened. 
2. In the Data Sources tree, select the first column to include in the join operation. 
3. Click Add >. 

Response: The selected column is added to the Source columns list on the Join 
Element tab. 

4. Select the second column to include in the join operation. 
5. Click Add >. 
6. Optionally, repeat steps 4 and 5 for any additional columns to be included in the join. 
7. Select a join operator from the Condition drop-down list, to specify how the two 

tables should be joined. 
Comment: There are two basic types of joins that can be done between tables: inner 
joins and outer joins. An inner join will return rows for which only the matching fields 
in both tables are equal. An outer join will return all the rows (including NULL values) 
from one table, and only the matching rows from the other table. If none of the default 
join options is suitable for your purposes, use the Freehand Join option to specify the 
join conditions manually. 

8. Select the Target tables using the two drop-down lists. 
Comment: This is necessary when more than two tables are involved in defining the 
join. See also Freehand joins. 

9. In the Description field, type your own description of the join. 
10. Sometimes you may want to create more than one join between the same two tables. In 

such a situation, you may want to make one of the joins a default join that most 
information links should use. The default join is displayed when clicking on the 
Suggested Joins button in the Information Link Join Path field. If you want the join 
you are currently creating to be the default one, select the check box Default join. 

11. Click Save or Save As... to specify the name and the folder to save the join in. 
Response: The join is added to the library and can be seen in the selected folder in the 
Elements tree. 

13.7.9.3 Freehand Joins in Information Designer 
In many situations, a join can be defined using one of the operators in the Condition drop-down 
list. However, it may sometimes be desirable to use more complex conditions, such as: 

• %1 = 2 * %2 (mathematical calculation prior to comparison) 
• %1 = %3 AND %4 = %2 (an intermediate table used to set up the join) 

In the latter case, it is important to select which tables to join - the tables in which %1 and %2 
occur. The other columns included in the join condition, %3 and %4, are found in an 
intermediate table. No join is created between this table and the other two. 

Example: 
In the following tables, we want to create a join that links T1 and T3. In this way, we will be 
able to query the database for, say, the address of the person who earns 1400. To achieve this, 
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T2 is used as intermediate table. The tables T1 and T3 should be selected from the Target 
tables' drop-down lists (see Creating a Join). The join, again, is defined as: 
%1 = %3 AND %4 = %2 

T1 

Name 
(%1) 

Salary 

John 1000 

Steve 1400 

Lisa 1200 
 

T2 

Name 
(%3) 

Number 
(%4) 

John 1 

Steve 2 

Lisa 3 
 

T3 

Number 
(%2) 

Address 

1 Boston 

2 Stockholm 

3 Tokyo 
 

13.7.9.4 Editing a Join in Information Designer 

► To edit a join: 
1. In the Elements tree, double-click on the join that you want to edit. 

Response: The join is displayed in a Join Element Tab. 
2. Modify the desired fields. 
3. Click Save or Save As.... 

Note: Some characters are forbidden in the element names and file system of TIBCO Spotfire 
3.0 and forward: /\*"?:<>| 
Old information models with element names containing these characters can be imported. 
However, you cannot edit and resave elements using their old names if they contain forbidden 
characters. 

13.7.9.5 Deleting a Join in Information Designer 

► To delete a join: 
1. In the Elements tree, right-click on the join that you want to delete. 

Response: A pop-up menu is displayed. 
2. Select Delete from the pop-up menu. 

Response: The join is deleted from the information model and its icon is removed from 
the Elements tree. 

13.7.9.6 Creating a Table Alias in Information Designer 
You can create a duplicate reference to a database table from Information Designer. This 
duplicate is called a Table Alias, and references the very same data, only using an alias. This 
can be useful in certain cases, most often when in need of a self join within a table (below). 

► To create a table alias: 
1. Select a table on the Data Sources tab. 
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2. Right-click the table and select Create Table Alias. 
 

 
3. Type a name for the table alias and click OK. 

Response: A table alias of the table is created. 

Self Joins 
A self join is a join from a table to itself. In Information Designer this is implemented by using 
a table alias. 

ID Name Manager 
1 Sarah 2 

2 Mike 3 

3 Carla Null 

4 Vincent 2 

5 Adrian 3 

  
The above database table lists a number of employees at a company, and specifies who the 
manager of each employee is. Carla is the head of the department. Mike and Adrian report 
directly to Carla, whereas Sarah and Vincent report to Mike. 
In order to produce a list where the ID stated in the Manager column is replaced by a name (see 
below), we would need a self join in the table. The table needs to look up the ID column in 
itself. 

Name Manager 
Sarah Mike 

Mike Carla 

Carla   

Vincent Mike 

Adrian Carla 

  
This is done by first creating a Table Alias of the table, and then creating a join between the 
table and its alias: 
WHERE TABLE.ID=TABLE_ALIAS1.MANAGER 
  

13.7.10 Column Elements 

13.7.10.1 Column Elements Overview  
Column elements in an information link may refer to multiple tables in different databases. 
However, with Information Designer, columns are represented as if they were located in the 
same spreadsheet, regardless of the physical location of the data. 
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In a TIBCO Spotfire context, columns are entities that can be assigned to the axes of a 
visualization. For example, data from a fruit company may include fruit type, sales and cost: 

 
All information in a relational database is represented explicitly as values in tables, composed 
of rows (records) and columns (fields). 
Column elements created in Information Designer can be based on several database columns. 
For example, a column element can be calculated as the sum of the values in two different 
columns. The underlying columns can reside in the same database table, in different tables, or 
even on different databases. 
Columns can be defined with built-in column filters that are automatically applied when the 
column is retrieved. You can also add a personalized or a parameterized column filter condition 
that limits data depending on the currently logged in user, see Personalized Information Links 
and Parameterized Information Links. Columns can also be set up to include aggregated data. 
In the Information Designer, columns are represented by these icons: 

 Real, SingleReal or Currency column 

 Integer or LongInteger column 

 String column 

 

Boolean column 

 

Date column 

 

DateTime column 

 

Time column 

 

BLOB (binary large object) column 

 

CLOB (character large object) column 

 Unknown column (in the Data Sources tree only). 
Must be set manually to one of the accepted column types (above) before it can 
be saved as a column element. 

13.7.10.2 Creating a Column Element in Information Designer 

► To add a column: 
1. Click New and select Column. 

Response: A Column Element tab is opened. 
2. In the Data Sources tree, select the column (leaf node) that you want to include. 
3. Click Add >. 

Response: The selected element is added to the Source columns list on the Column 
Element tab. 
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Comment: Repeat this step if you need to include more data to calculate your column 
element. 

4. If you want the column to be calculated, type the expression in the Expression field. 
Comment: For instance, if you have added two numerical columns you could calculate 
the sum by entering "%1+%2". More 

5. Select the Data type of the column element. 
Comment: It is recommended that you use conversion functions for mapping columns. 
See notes below. 

6. In the Description field, type your own description of the column. 

7. In the Filter section, click  to show the filtering controls. More 

8. In the Aggregation section, click  to show the aggregation controls. More 

9. In the Properties section, click  to show the column properties controls. More 
10. Click Save. 

Response: The column is saved in the library and is shown with an icon denoting its 
type in the Elements tree. 

Note: If the column in the database is of the type Real, and you want to create a column 
element of the type Integer, then set the Data type (step 5 above) to Integer. Similarly, if the 
column in the database is of the type Unknown, you must manually choose an appropriate type 
before the column can be saved. It is also strongly recommended that you use a conversion 
function (for example ROUND) in the Expression field (step 4 above). Look for descriptions of 
available conversion functions in the manual for your database. 

13.7.10.3 Creating Multiple Column Elements in Information 
Designer 

The Multiple Columns tab can be used if you want to create many column elements in one 
operation. 
Note: Whole databases and schemas cannot be added, only columns and tables are available. 

► To add multiple columns to the information model: 
1. Click New and select Multiple Columns. 

Response: A Multiple Column Elements tab is opened. 
2. In the Data Sources tree, select the column (leaf node) or table that you want to 

include. 
3. Click Add >. 

Response: The selected column is added to the Source columns list. If a table was 
selected, all columns in the table will be added to the list on the Multiple Column 
Element tab. 
Comment: Repeat this step if you want to include more data columns. 

4. Click on an element in the Source columns list and change its name by typing in the 
Column element name field (or go to step 8 to add the columns using the default 
settings). 
Comment: This step is not necessary unless you want to change the name or 
description of the element. 

5. If desired, change the description of each column element. 
Comment: The description is metadata on the column which can be used in search 
expressions inside TIBCO Spotfire. 

6. Click Create Columns.... 
Response: The Create Multiple Columns dialog is displayed. 

7. Click to select the folder where you wish to store the column elements. 
8. Click Create Columns. 
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Response: The columns are stored in the specified folder in the library. Columns of 
type Unknown will be mapped to the data type String when they are added through the 
Multiple Columns tab. The data type can be changed later by editing each column 
element. 

13.7.10.4 Editing a Column in Information Designer 

► To edit a column: 
1. In the Elements tree, double-click on the column element you wish to edit.  

Response: A Column Element tab is displayed. 
2. Modify the desired fields. 
3. Click Save to save/update the column, or click Save As... to create a copy. 

Comment: Use Save As... if you want to keep the old column definition unchanged. 
Note: Some characters are forbidden in the element names and file system of TIBCO Spotfire 
3.0 and forward: /\*"?:<>| 
Old information models with element names containing these characters can be imported. 
However, you cannot edit and resave elements using their old names if they contain forbidden 
characters. 

13.7.10.5 Deleting a Column in Information Designer 

► To delete a column: 
1. In the Elements tree, right-click on the column element you wish to delete.  

Response: A pop-up menu is displayed. 
2. Select Delete from the pop-up menu. 

Response: The column is deleted from the information model. 

13.7.10.6 Calculating a Column in Information Designer 

► To calculate a column: 
1. Start by adding at least one column from the Data Sources tree. 
2. If you want a column to be calculated, type an expression in the Expression field, for 

example %1+%2, or AVG(%1). 

3. Click on  next to the respective section to access functions for aggregating data, or 
for creating a built-in filter. 

4. If desired, type a Description. 
5. Click Save or Save As.... 

13.7.10.7 Defining a Column Filter in Information Designer 
Column filters are automatically applied when the column is retrieved. Such filters, unlike 
filters that are defined and saved as separate elements (filter elements), cannot be disabled by 
the user. 
Column filters are defined while the column element is being created. The following steps 
should be taken in addition to what is described in Creating a Column Element. 

► To define a column filter: 
1. In the Filter section, click  to show the filtering controls. 
2. In the Data Sources tree, select a column and then click the Add > button to add the 

column to use in the filter expression. 
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Comment: Repeat this step if you need to include more columns in your filter 
expression. 

3. In the Expression field, define a filter condition based on the chosen column or 
columns. For example, %1<2000, or if you are using two columns, %1<%2. 
Comment: To combine conditions, use the AND or OR operators, for example 
%1>2000 AND %2<1000. 
Comment: You can also add a personalized filter expression that limits data depending 
on the currently logged in user. See Personalized Information Links for more 
information. 
Comment: You can also add a parameterized filter expression. See Parameterized 
Information Links for more information. 

4. Write a clear description of how the column is filtered. This is important, since the user 
will not be able to disable the filter when using this column element. 

Note: When an information link is executed, aggregation is always applied before the filter. 

13.7.10.8 Date and Time Columns in Information Designer 
A data source may provide date and time information as DATE columns. This format can be 
mapped to a DATE, a TIME or a DATETIME data type when a column element is created in 
Information Designer (see Creating a Column Element). 

► To find the number of days between two DATE columns: 
1. From the Data Sources tree, select two columns of type DATE. 
2. In the Expression field, type the expression %1 - %2. 

Comment: By selecting only one column, you can also find the elapsed number of days 
from today, using the expression sysdate - %1 if you are running against an Oracle 
data source. 

3. Set the Data type to Integer. 

► To generate a Spotfire Date column from a DATE column: 
1. From the Data Sources tree, select a column of type DATE. 
2. Set the Data type to Date. 

Note: Any SQL arithmetic expression may be entered into the Expression field. However, you 
need to make sure to use the correct syntax since no validation will be performed. Also note that 
different databases may have different syntaxes. 

13.7.10.9 Working with Aggregation 

13.7.10.9.1 Using Aggregation in Information Designer 

► To calculate average values: 
1. Click New and select Column. 
2. Click to select a value column in the Data Sources tree, for example a Sales column. 
3. Click the topmost Add > button. 
4. In the Expression field, type:  

 
AVG(%1) 
  
Comment: AVG is the average function.  

5. Click  next to Group By to show the controls determining over which column the 
aggregation will be made. 

6. Click New to add an empty group by expression. 
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7. Click to select the column to group by in the Data Sources tree, for example a Type 
column. 

8. Click Add > in the Group By Settings section. 
9. Click Save. 

Response: The resulting column will consist of the average of the value column, for 
each value in the group by column. Using the example columns above it would be a 
column containing the average sales for each type of product. 

Tip: Rather than hard coding the columns to aggregate over, you may consider marking the 
column as Drillable. The column will then be aggregated over any other columns retrieved in 
the same information link.  
Note: When an information link is executed, aggregation is always applied before a column 
filter. 

13.7.10.9.2 Aggregating Over Many Columns in Information Designer 
There may be situations where it is necessary to use more than one column to group by when an 
aggregated column is calculated. In the following table, for example, we can compare the salary 
of each employee with the average salary of employees at the same department and job. 

 
To produce this table, we must define the Average Salary column with two group by 
expressions: Job and Department. 

► To use multiple group by expressions: 
1. Select a value column from the Data Sources tree, for example Salary. 
2. Click the topmost Add > button. 
3. In the Expression field, type:  

 
AVG(%1) 
  
Comment: AVG is the average function.  

4. In the Group By section, click  to show the group by controls. 
5. Click New to add a new Group by expression. 
6. From Data Sources, select the first column to group by (for example Job). 
7. Click Add > in the Settings field. 
8. Click New to add a second Group by expression. 
9. Select the second column to group by (for example Department). 
10. Click Add >. 
11. Click Save. 
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Response: The resulting column will consist of the average of the value column, for 
each value in the group by columns. 

Note: It would not have been possible to produce the table above using the Drillable option. If 
the Average Salary column element had been drillable, it would have appeared identical to the 
Salary column, since the Employee Name and Salary columns would also have been used to 
group by. 

13.7.10.9.3 Using Drillable  
When creating an aggregated column, it is possible to specify group by expressions determining 
over which categories the aggregation should be made. This is done from the Column Element 
tab, in the Group By section. 
It is also possible to ignore the Group By settings, by selecting the Drillable check box. This 
way the column will always be aggregated over all other columns being retrieved in the same 
information link. The following table illustrates this. Average Salary Drillable is calculated 
using the AVG function. No group by expressions have been specified, and instead the Drillable 
check box has been selected. 

 
As we see above, the average salary is computed for each value in Job. We could just as well 
have defined a salary column explicitly aggregated over Job. However, by using the Drillable 
option, we can now retrieve a different set of columns and still get a useful answer: 

 
In this table, the Average Salary Drillable column displays the average salary for the clerks 
from each department instead of a combined value for all clerks. 

13.7.11 Filter Elements 

13.7.11.1 Filter Elements Overview  
Filters are conditions that limit the amount of data returned by an information link. For 
example, a filter could set the conditions "X > 10 AND Y < 100". There are three ways of 
filtering data when working with information links: 

 

Filter elements appear in the Elements tree of 
Information Designer. They can be added to any 
information link, just like column elements. See 
Creating an information link to find out how to 
include a filter element. 
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Hard filters are set up as you define the 
information link, and are saved with the link. This 
means that they cannot be reused in other links. 
Also, hard filters can only specify a range or a list 
of values, and so are less versatile than filter 
elements. See Adding Hard Filters for more 
details. 

 

Prompts are also set up when you create an 
information link. However, the actual conditions 
are entered by the person running the information 
link only when the link is opened (executed). For 
each column that has been set up like this, a 
dialog will appear allowing the user to enter 
threshold values or select individual values. See 
Adding Prompts for more details. 

Filters correspond to the WHERE clauses in SQL, and are used to specify that only certain rows 
of a table shall be retrieved from the data source, based on the criteria described in the filtering 
condition. 
Filter elements can be applied as required by the person creating information links. In the 
Elements tree, they are represented by this icon:  

13.7.11.2 Creating a Filter Element  
This topic describes how to create filters as separate elements. These can be applied as required 
by the person creating information links. See Defining a Column Filter for information on how 
to add a filter as part of a column definition. 

► To create a filter: 
1. Click New and select Filter. 

Response: A Filter Element tab is opened. 
2. In the Data Sources tree, select the column to use in the filter condition. 
3. Click Add >. 

Response: The selected column is added to the Source columns list on the Filter 
Element tab. 
Comment: Repeat this step if you need to include more columns in your filter 
expression. 

4. Define a filter expression with the chosen columns, for example %1>=2000, or if you 
are using two columns, %1<%2. See Relational Operators for more information on 
defining expressions. 
Comment: You can also add a personalized filter expression that limits data depending 
on the currently logged in user. See Personalized Information Links for more 
information. 
Comment: You can also add a parameterized filter expression. See Parameterized 
Information Links for more information. 

5. In the Description field, type your own description of the filter. 
6. Click Save. 

Response: The Save As dialog is displayed. 
7. Click to select the folder where you wish to save the filter element. 
8. Click Save. 

Response: The filter element is saved in the library. 
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13.7.11.3 Editing a Filter in Information Designer 

► To edit a filter element: 
1. In the Elements tree, double-click on the filter that you want to edit. 

Response: The name of the filter and filter conditions are shown on a Filter Element 
tab and enabled for editing. 

2. Modify the desired fields. 
3. Click Save or Save As.... 

Note: Some characters are forbidden in the element names and file system of TIBCO Spotfire 
3.0 and forward: /\*"?:<>| 
Old information models with element names containing these characters can be imported. 
However, you cannot edit and resave elements using their old names if they contain forbidden 
characters. 

13.7.11.4 Deleting a Filter in Information Designer 

► To delete a filter: 
1. In the Elements tree, right-click on the filter that you want to delete. 

Response: A pop-up menu is displayed. 
2. Select Delete from the pop-up menu. 

Response: The filter is deleted from the library. 

13.7.11.5 Relational Operators 
The following operators can be used in filters: 

= Equal 

<> or != Not Equal 

< Less Than 

> Greater Than 

<= Less Than or Equal To 

>= Greater Than or Equal To 

• Generally, with text columns, it is best to use = or !=. 
• Make sure that any text that appears in the statement is surrounded by single quotes ('). 
• To combine multiple conditions, use the AND or OR operators, for example %1>2000 

AND %2<1000. 

13.7.12 Procedures 

13.7.12.1 Procedures Overview 

Database Procedures 
A database procedure is a set of SQL statements that can be stored in the database. Once this 
has been done, clients do not need to keep reissuing the individual statements but can refer to 
the database procedure instead. 
Database procedures can be useful in many situations: 
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• When multiple client applications are written in different languages or work on 
different platforms, but need to perform the same database operations. 

• Some institutes, like banks, where security is important, use database procedures for all 
common operations. This provides a consistent and secure environment, and 
procedures can ensure that each operation is properly logged. In such a setup, 
applications and users would not get any access to the database tables directly, but can 
only execute specific database procedures. 

• Database procedures can provide improved performance because less information 
needs to be sent between the server and the client. However, this increases the load on 
the database server system because more of the work is done on the server side and 
less is done on the client (application) side. Take this into consideration if many client 
machines (such as Web servers) are serviced by only one or a few database servers. 

• Database procedures also allow you to have libraries of functions in the database 
server. This is a feature shared by modern application languages that allow such design 
internally, for example, by using classes. 

Database Procedures in Information Designer 
Using Information Designer you select pre-made database procedures and configure these to be 
accessible in information links. These information links are available to the TIBCO Spotfire 
users to retrieve or manipulate data. 
In Information Designer you select a database procedure from your available data sources, and 
define which input parameters that the procedure should prompt for, and any potential resulting 
columns and joins. 
Then you configure a complete information link with one or more combinations of procedures 
and columns from other tables. 

The Three Kinds of Procedures 
Information Designer defines three kinds of procedures: 

• Pre-update procedure - this procedure does not return any data, it only performs an 
operation on one or more databases. All pre-update procedures in an information link 
will always be executed before any query procedure. 

• Query procedure - just like a database table, this procedure returns data. 
• Post-update procedure - this procedure does not return any data, it only performs an 

operation on one or more databases. All post-update procedures in an information link 
will always be executed after any query procedure. 

Note: If using Oracle stored procedures that return data, Information Designer only support 
procedures that return data of the type REF CURSOR (also known as Table Function). 
  

13.7.12.2 Creating a Pre- or Post-procedure 

► To Create a Pre-update or Post-update procedure: 
1. Click New and select Procedure. 

Response: A Procedure Element tab is opened. 
2. In the Data Sources tree, click on the database procedure you wish to use. 
3. Click Select. 

Response: The database procedure is added to the tab. Information Designer analyzes 
the database procedure and makes a guess as to whether it is a pre-update procedure or 
a query procedure (it never sets post-procedure by default). 



TIBCO Spotfire 4.0.2 - User's Manual 

982 

 
4. Select the Procedure type: Pre-update procedure or Post-update procedure. 

Comment: Pre-update procedures are always executed first in an information link. 
Post-update procedures are always executed last in an information link. 

5. If the database procedure requires any Input Parameters, their name and type are 
displayed. 

 
6. Select whether the input parameter should receive a Default Value by typing a value 

(of the appropriate type) in the input field. If not, leave the field blank. 
Comment: Type ?param_name to use a parameter as the default value, where 
param_name is the name to identify the parameter by. Note: If you use a parameter for 
the default value, you must choose Prompt: None. See Parameterized Information 
Links for more information. 

7. Select whether you want the end user to be prompted for a single value, multiple 
values, or not at all, from the Prompt drop-down list. 
Comment: If you select multiple values, the end user will be allowed to enter several 
values. The procedure will run once for each of these values in an iterative loop. For 
more information, see Multiple Value Procedure Prompts. 

8. If you want to allow the input parameter to be Null, select the Permit Null check box. 
Example 1: Type a Default value and set prompt to None. This means that the 
specified default value will always be used as input parameter. 
Example 2: Leave Default value empty, select Permit Null and Single value prompt. 
This will cause the end user to be prompted for a value. If the end user does not enter a 
value in the prompt, Null will be used. 
Example 3: Leave Default value empty, leave Permit Null empty and Single value 
prompt. This will cause the end user to be prompted for a value. If the end user does 
not enter a value in the prompt, an error message will appear since Null is not allowed. 
Comment: You cannot select the combination: No Default value, Not allow Permit 
Null and No Prompt, since this is a paradox. 

9. In the Description field, type your own description of the procedure. 
10. Click Save. 

Response: The Save As dialog is displayed. 
Click to select the folder where you wish to save the procedure element. 

11. Click Save. 
Response: The procedure is saved in the selected folder, and will be denoted with the 

 icon. Note that the procedure object will be visible to the end user in the list of 
information links. You can also make larger, more complex information links using the 
procedure when creating an information link in Information Designer. 
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13.7.12.3 Creating a Query Procedure 

► To Create a Query procedure: 
1. Click New and select Procedure. 

Response: A Procedure Element tab is opened. 
2. In the Data Sources tree, click on the database procedure you wish to use. 
3. Click Select. 

Response: The database procedure is added to the tab. Information Designer analyzes 
the database procedure and makes a guess as to whether it is a pre-update procedure or 
a query procedure (it never sets post-procedure by default). 

 
4. Select the Procedure type: Query. 
5. In the Description field, type your own description of the procedure. 
6. If the database procedure requires any Input Parameters, their name and type are 

displayed. 

 
7. Select whether the input parameter should receive a Default Value by typing a value 

(of the appropriate type) in the input field. If not, leave the field blank. 
Comment: Type ?param_name to use a parameter as the default value, where 
param_name is the name to identify the parameter by. Note: If you use a parameter for 
the default value, you must choose Prompt: None. See Parameterized Information 
Links for more information. 

8. Select whether you want the end user to be prompted for a single value or not at all, 
from the Prompt drop-down list. 

9. If you want to allow the input parameter to be Null, select the Permit Null check box. 
Example 1: Type a Default value and set prompt to None. This means that the 
specified default value will always be used as input parameter. 
Example 2: Leave Default value empty, select Permit Null and Single value prompt. 
This will cause the end user to be prompted for a value. If the end user does not enter a 
value in the prompt, Null will be used. 
Example 3: Leave Default value empty, leave Permit Null empty and Single value 
prompt. This will cause the end user to be prompted for a value. If the end user does 
not enter a value in the prompt, an error message will appear since Null is not allowed. 
Comment: You cannot select the combination: No Default value, Not allow Permit 
Null and No Prompt, since this is a paradox. 

10. Expand the Result Columns section. 
11. Either keep the Include all result columns check box selected, or clear the check box 

and click Add... to specify your own result columns. If the check box is selected, go to 
step 15, otherwise continue with step 12. 
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12. In the Original name field, enter the exact name of a column the database procedure 
returns. This name is specified in the actual database procedure, so you have to know 
this beforehand. 

13. Type a Display name to use when the result column is opened in TIBCO Spotfire. 
14. Select the Data type the resulting column should have. 
15. If you want to specify a join between the database procedure and another table, use the 

Join section. 
Comment: Joining is necessary if you intend to use the result columns from this 
procedure together with column elements from another data table in an information 
link. You can only specify one join. 

16. Join columns can be added from three different sources: 
* From the Data Sources tree. This option is similar to selecting join columns at the 
creation of join elements. Click on a column in the Data Sources tree (or click on the 
column under its data source in the Elements tree) and then select the From Data 
Sources Tree option in the Add drop-down list. 
* From a previously specified Result Column. Any result columns that have been 
defined will be listed directly in the Add drop-down list. 
* From a New Result Column. The third option is used if you want to join over a result 
column from the procedure but you do not want to use it as output when retrieving 
data. 
Click Add and select an option from the drop-down list. 

17. Repeat step 16 for another join column. Normally, you will have one column from the 
data sources tree and one result column in the join. 

18. Select a Condition from the drop-down list. 
Comment: There are two basic types of joins that can be done between tables: inner 
joins and outer joins. An inner join will return rows for which only the matching fields 
in both tables are equal. An outer join will return all the rows (including NULL values) 
from one table, and only the matching rows from the other table.  See also Freehand 
Joins. 

19. Click Save. 
Response: The Save As dialog is displayed. 

20. Click to select the folder where you wish to save the procedure element. 
21. Click Save. 

Response: The procedure is saved in the selected folder, and will be denoted with the 
 icon. Note that the procedure object will be visible to the end user in the list of 

information links. You can also make larger, more complex information links using the 
procedure when creating an information link in Information Designer. 

13.7.12.4 Editing a Procedure 

► To edit a procedure: 
1. In the Elements tree, double-click on the procedure that you want to edit. 

Response: The procedure is loaded on a Procedure Elements tab and enabled for 
editing. 

2. Modify the desired fields. 
3. Click Save or Save As.... 

Note: Some characters are forbidden in the element names and file system of TIBCO Spotfire 
3.0 and forward: /\*"?:<>| 
Old information models with element names containing these characters can be imported. 
However, you cannot edit and resave elements using their old names if they contain forbidden 
characters. 
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13.7.12.5 Deleting a Procedure 

► To delete a procedure: 
1. In the Elements tree, right-click on the procedure that you want to delete. 

Response: A pop-up menu is displayed. 
2. Select Delete from the pop-up menu. 

Response: The procedure is deleted from the library. 

13.7.12.6 Multiple Value Procedure Prompts 
If a list is used as input for a pre- or post-update procedure, the procedure is run as many times 
as the number of values in the list. If lists of different lengths are used at the same time, one of 
two things will happen depending on the length of the lists. 
  

Example 1: 
If one of the lists contains only one value, that value will be distributed to the values of the 
other list. 
  
List X: [1,2,3] 
List Y: [A       ] 
  
Result: First call procedure with parameters: 1,A 
Then: 2,A 
Then: 3,A 
  

Example 2: 
If both lists contain more than one value, the values of the shorter list will be distributed to the 
values of the longer list, and null will be added to the remaining values. 
  
List X: [1,2,3] 
List Y: [A, B  ] 
  
Result: 1,A 
2,B 
3,null 
  
A query procedure does not accept a list as input, only a single value. 
  

13.7.13 User Interface Details 

13.7.13.1 Elements Tree 
The Elements tree displays the data access layer (the information model) in the library as a 
folder structure including all available information links, column elements, filter elements and 
joins. All elements can be sorted into different folders. Click the plus (+) and minus (-) next to a 
folder icon to expand the folder and browse the tree. Click on the desired element to select it. It 
is possible to drag an element from one place to another. Right-clicking on an element opens a 
pop-up menu where you can edit the selected element, validate information links, etc. 
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Use the Search field to locate folders or elements in the tree. The search field automatically 
searches for the name and keywords of the elements, but you can also search for other 
properties using the following syntax: <property name>:<value>. See Searching in TIBCO 
Spotfire and Searching the Library for more information regarding search. Click on Clear 
Search to return to the full Elements tree. 
Note: Searching for data sources does not include searching for database entities like catalogs, 
schemas or tables. It is only the database instance itself that can be located via search. 

 
Tip: You can also press the * key on the numeric keypad to expand all nodes at the highest 
unexpanded level below the selected folder. 

13.7.13.2 Icon Explanations  
In the Elements tree, the following icons may appear. Click on a link in the table below to find 
out more about each element type. In the Data sources tree only the items belonging to a 
database are visible. 

Icon Element type 

 

Folder 

 

Information link 

 

Filter 

 

Boolean column 

 String column 
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 Integer column or LongInteger column 

 Real, ShortReal or Currency column 

 

Date column 

 

DateTime column 

 

Time column 

 

Procedure 

 

Binary Large Object 

 

Character Large Object 

 

Join 

 

Database instance. 

 

Database link/catalog - a link to another database. 

 
Schema - a collection of tables and/or procedures. 

 

Table - a set of columns. 

 

Table alias. You can create a duplicate reference to a database table from 
Information Designer. This duplicate is called a Table Alias. 

 Unknown column. 
Must be set manually to one of the accepted column types (above) before it can 
be saved as a column element. 

13.7.13.3 Data Sources Tree 
The data sources tree lists all currently defined data sources and their content. Click the plus (+) 
and minus (-) next to a data source icon to expand/collapse the data source. Click on the desired 
element to select it. Right-clicking on an item opens a pop-up menu where you can edit the 
selected data source, create multiple column elements etc. 
Tip: You can also press the * key on the numeric keypad to expand all nodes at the highest 
unexpanded level below the selected node. 
Use the Search field to search for the name, description and keywords of a database. Click on 
Clear Search to return to the full Data Sources tree. 
Note: Searching for data sources does not include searching for database entities like catalogs, 
schemas or tables. It is only the database instance itself that can be located via search. 
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Icon Item Description 

 

Database instance The name of the database instance. 

 

Database link / 
Catalog 

A link to another database. 

 Schema The owner or database administrator that has set up the 
different tables. 

 

Table A set of columns. 

, ... Column The column has an icon that denotes the column type. See 
Column Elements Overview for a description of the 
different column icons. 

 

Table Alias You can create a duplicate reference to a database table 
from Information Designer. This duplicate is called a table 
alias. 
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13.7.13.4 Tabs 

13.7.13.4.1 Start Tab 
When Information Designer is started, the Start tab is visible. From here, you can reach all 
functions of the Information Designer. Each link in the start tab opens a separate tab where you 
can perform the various tasks. 
Tip: Close a tab by clicking on the x symbol on the top right hand side of the tab page. You can 
also click on the tab with the middle mouse button or mouse wheel in order to close it. 
Tip: You can right-click on any tab in Information Designer to display a pop-up menu which 
allows you to navigate to any of your current tabs or to close all tabs simultaneously. You can 
also locate the currently edited element in the Elements tree. 

Option Description 

Create 
Information Link 

Opens an Information Link tab. You can have multiple information 
link tabs open at the same time. 

Create Elements Column - Opens a Column Element tab where you can define a 
column element which shall be a part of the information model and, 
hence, available when creating information links. 
Multiple Columns - Opens a Multiple Column Elements tab where 
many column elements can be defined simultaneously. 
Filter - Opens a Filter Element tab where a column filter can be 
defined. 
Procedure - Opens a Procedure Element tab where a stored procedure 
can be defined. 

Create Join Opens a Join Element tab where you can define a join between 
columns from different tables. 

Setup Data Source Opens a Data Source tab where you can specify a data source that 
should be available for creating elements. 
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13.7.13.4.2 Information Link Tab 
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Option Description 

Add > Adds the element selected in the Elements tree to the information link. 

< Remove Removes the selected element from the link. 

Elements Lists all elements currently included in the information link. Clear the 
Retrieve check box to prevent a column from being loaded. (Filter 
conditions will still affect the amount of data loaded.) 

Move Up Moves the selected element up in the list. 

Move Down Moves the selected element down in the list. 

Edit Opens the Column Element tab for the selected element so that it can be 
edited. 

SQL... Opens the Edit SQL dialog where you can view and edit the SQL that the 
current information link is generating. 

Save As... Displays the Save As dialog which saves the configuration currently shown 
in the information link tab into a new information link. 

Save Saves the information link. 

Open Data Executes the currently selected data as an information link and retrieves the 
data into Spotfire. 

  

 

Option Description 

Add > Adds the selected join from the Elements tree to the Selected joins list. 

< Remove Removes the selected join from the Selected joins list. 

Selected joins Lists the joins that will be used in the join path between the tables in the 
information link. 

Suggest Joins If any joins have been specified between the tables currently used in the 
information link, clicking this button will automatically add one or more 
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suitable joins to the Selected joins list. If a default join has been specified, 
then this join will be used if possible. 

Join data 
source 

If more than one join database have been defined during the setup of the 
server, then you can select where the joining should take place here. 

  

 

Option Description 

Description An optional description of the contents of the information link. This can be 
helpful for end users of the information link when searching for information 
links in the library. 

  

 

Option Description 

Column The names of added columns to filter on. 

Filter Type Select Range or Values to specify how the filtering conditions will be set. 

Values List the required values (separated by semicolons) for a values filter. 
Type ?param_name to use a parameter as the filter for the chosen column, 
where param_name is the name to identify the parameter by. 

Min Value Type the lower range value for a range filter in this field. 

Max Value Type the higher range value for a range filter in this field. 

Add Opens the Add Column dialog where you can select a column to filter on. 

Remove Removes the selected column from the Filters section. 

  



Tools 

993 

 

Option Description 

Column The names of added columns to prompt. 

Prompt Type Select what kind of selections should be available in the prompt when the 
link is opened. 
Values lets you enter your own list of values to include. This prompt type 
should only be used if all end users of the information link know which 
values are valid for the column. 
Range lets you specify a range of values. This prompt type is suitable for 
numerical or Date/DateTime/Time columns when a sustained range of 
numbers or time periods are to be retrieved. 
Multiple selection presents a list of available values from which you can 
select multiple values. This type of prompt can be used even if the end users 
of the information link have no previous knowledge of the data. 
Single selection presents a list of available values from which you can 
select a single value only. This type of prompt can be used even if the end 
users of the information link have no previous knowledge of the data. 
See also Details on Open Information Link. 

Mandatory Select this check box to make it mandatory to select values in the prompt. It 
is not possible to clear the check box if Single selection has been chosen. 
For non-mandatory prompts the end user can leave the prompt step dialog 
untouched in order to retrieve all data for that step. 

Max 
Selections 

Type the maximum number of selections allowed. It is not possible to 
specify a maximum number of selections if Single selection or Range has 
been chosen. 

Add Opens the Add Column dialog where you can select a column on which to 
add a prompt. 

Remove Removes the selected column from the Prompts section. 

Move Up Click to move an element up. This is used to control the order of the 
columns with prompts. Filter elements are always applied before prompts 
regardless of order. 

Move Down Click to move an element down. 

Groups... Opens the Prompt Groups dialog where you can specify different prompt 
groups for different prompts, making elements independent from each other. 
This is used to improve the performance of information links when 
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retrieving data from STAR schema databases. See Using Prompt Groups for 
more information. 

  

 

Option Description 

None No conditioning. 

Distinct Removes all duplicate rows (rows where all fields are identical) from the 
returned data table. 

 Pivot Allows you to transform your data from a tall/skinny format to a short/wide 
format by rotating row and column headings around the core data. Select 
which columns to work on by clicking Edit.... 

Edit... Opens the Pivot Conditioning dialog. 

  

 

Option Description 

Parameter 
Name 

Lists the names of all added parameters. Note: You have to click Refresh 
for parameters to appear in the list the first time you display the list after 
creating a parameter. 
If a parameter is not listed even after clicking Refresh, you may have 
created a parameter containing unsupported characters. See Parameterized 
Information Links for more information. It is also possible that you have 
edited the SQL of the information link. In that case, the altered SQL code 
overrides the parameters settings in the user interface. 

Data Type Lists the data type of all added parameters. 

Value Type Lists the value type of all added parameters. 

Edit... Opens the Edit Parameter dialog which lets you edit the selected parameter 
in the list. 

Refresh Refreshes the list of parameters. Note: You have to click Refresh for 
parameters to appear in the list the first time you display the list after 
creating a parameter. 
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Option Description 

Property 
name 

Shows the names of custom properties defined for this information link. 
Custom properties are metadata that can be used when searching in the 
Library by using the following syntax: <Property name>:<Value>. For 
example, MyCompany.Property:Property1. 

Value Shows the value of each custom property. 

Add... Opens the Add Information Link Property dialog where custom properties 
can be defined. 

Edit... Opens the Edit Information Link Property dialog. 

Delete Deletes the selected property. 

 

13.7.13.4.3 Column Element Tab 
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Option Description 

Add > Select a column from the Data Sources tree and click on this button 
to include it in the new column. 

< Remove Deletes the selected column from the composition. 

Source columns Lists all source columns that will be included in the calculation of 
the new column element. 

Expression To perform any calculation on the column, enter the expression in 
this text field. 

Data type Specifies the data type of the column. 

  

 

Option Description 

Description An optional description of the column element. 

  
  

 

Option Description 

Add > Select a column from the Data Sources tree and click on this button to 
include it in the filter. 

< Remove Removes the selected column from the composition. 

Expression In this field, enter an expression containing the selected column or columns. 
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The Group by section is only important if you have specified some type of aggregation in the 
Expression field at the top of the page. When an aggregation has been defined, you can select 
the categories to group by here. See Using Aggregation in Information Designer for more 
information. 

Option Description 

Group by expressions Lists the group by expressions specified using the source columns 
selected under Settings and any calculations done in the Expression 
field. 

New Adds a new, empty expression to the Group by expressions list. 

Delete Deletes the selected expression from the Group by expressions list. 

Add > Adds the columns selected in the Data Sources tree to the Source 
columns list, where it can be used in a group by expression. 

< Remove Deletes the selected column from the Source columns list. 

Source columns Lists the columns that are to be used in the expression determining 
what to group by. 

Expression Enter an expression here to define what  to group by. 

Drillable Select the check box if you want the column to group by all other 
columns that are included together with this column element in an 
information link. See Using Drillable for more information. 
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Option Description 

Property name Shows the names of custom properties defined for this column. 
Custom properties are metadata that can be used when searching for 
columns using the following syntax: <Property name>:<Value>. For 
example, MyCompany.Property:Property1. 
Custom column properties can also be used for drawing lines in some 
of the visualizations. 

Value Shows the value of each custom property. 

Add... Opens the Add Column Property dialog where custom properties can 
be defined. 

Edit... Opens the Edit Column Property dialog. 

Delete Deletes the selected property. 
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13.7.13.4.4 Multiple Column Elements Tab 

 

Option Description 

Add > Select one or more tables or columns from the Data Sources tree, and 
then click this button to include the columns as new column elements in 
the library. 

< Remove Deletes the selected columns from the Source columns list. 

< Remove All Removes all columns from the Source columns list. 

Column element 
name 

The name of the column to be saved as it will be displayed in the 
Elements tree once imported to the library. Click on a column element 
name to edit the text. 

Source column 
name 

Displays the source name of the selected column element. 

Type Displays the data type of the selected column element. 

Path Displays the path to the column in the data sources tree. 

Selected column 
description 

A short (optional) description of the purpose of the column. (Click on a 
column element in the Source columns list to edit the description of that 
column.) 

Create 
Columns... 

Creates the columns and adds them to the library, after you specify their 
location in the Create Multiple Columns dialog. 
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13.7.13.4.5 Filter Element Tab 

 

Option Description 

Add > Select a column from the Data Sources tree, and then click this button to 
include it in the filter. 

< Remove Deletes the selected column from the composition. 

Condition In this field, enter a condition containing the selected column or 
columns. 

Description A short (optional) description of the purpose of the filter. 

Save As Click Save As to create a copy of the filter element. 

Save Click Save to save or update the filter. 
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13.7.13.4.6 Procedure Element Tab 

 

Option Description 

Select Select a database procedure from the Data Sources tree, and then click this 
button to include it. 

Procedure type Information Designer defines three kinds of procedures: 
Pre-update procedure - this procedure does not return any data, it only 
performs an operation on one or more databases. All pre-update 
procedures in an information link will always be executed before any 
query procedure. 
Query procedure - just like a database table this procedure returns data. 
Post-update procedure - this procedure does not return any data, it only 
performs an operation on one or more databases. All post-update 
procedures in an information link will always be executed after any query 
procedure. 

Save As... Click Save As to create a copy of a procedure. 

Save Click Save to save or update the procedure. 

Run Runs the procedure. 
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Option Description 

Description A short description of the purpose of the procedure. 

  

 

Option Description 

Name States the name of the input parameters detected in the database 
procedure. 

Type States the type of the input parameters detected in the database procedure. 

Default Value If the input parameter should receive a default value, type a value (of the 
appropriate type) in the input field. If not, leave the field blank. 
Type ?param_name to use a parameter as the default value, where 
param_name is the name to identify the parameter by. 
Note: If you use a parameter for the default value, you must choose 
Prompt: None. 

Permit Null Select this check box if you want to allow the input parameter to be Null. 

Prompt Select whether you want the end user to be prompted for a single value, 
multiple values or not at all, from the Prompt drop-down list box. 
Comment: If you select multiple values, the end user will be allowed to 
enter several values. The procedure will run once for each of these values 
in an iterative loop. For more information, see Multiple Value Procedure 
Prompts. 
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Option Description 

Include all 
result columns 

Select this check box to include all columns from the procedure. Clear 
the check box if you like to specify the result columns yourself. 

Add This button becomes available when the Include all result columns check 
box is cleared. Click on the button to add a new row in the result columns 
list on the right. A dialog is opened where you can enter the Original 
name and Display name of the result column, as well as specify its data 
type. 

Delete Deletes the selected result column. 

Original Name In the Original Name field, the exact name of a column the database 
procedure returns should be entered. This name is specified in the actual 
database procedure, so you have to know this before adding the result 
column. 

Display Name Enter a descriptive Display Name for the resulting column. This is the 
name the end user will see when columns have been imported to TIBCO 
Spotfire. 

Type Select the Type the resulting column should have. 

  

 
  

Option Description 

Add Displays a drop-down list containing columns from three different 
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sources: 
* From Data Sources Tree. This option is similar to selecting join 
columns at the creation of join elements. Click on a column in the Data 
Sources tree (or click on the column under its data source in the Elements 
tree) and then select the From Data Sources Tree option in the Add drop-
down list. 
* Previously specified Result Columns. Any result columns that have 
been defined above will be listed directly in the Add drop-down list. 
* New Result Column.... The third option is used if you want to join over 
a result column from the procedure but you do not want to use it as output 
when retrieving data. 
Select a column from either source to include it in the join. 

Remove Removes a column from the Join columns list. 

Join columns Lists the name of the columns you wish to join. 
This may be one of the columns specified in the Result Columns section, 
but can also be another procedure column as long as it is available from 
the database procedure result (for example an ID column). It also lists the 
columns you have added from the Data Sources tree. 

Condition Select one of the alternatives to specify which type of join to use. 
An inner join will return rows for which only the matching fields in both 
tables are equal. An outer join will return all the rows (including NULL 
values) from one table, and only the matching rows from the other table. 

Freehand You can also specify your own join definition by typing directly in the 
freehand field. See Freehand Joins for more information. 

  

13.7.13.4.7 Join Element Tab  
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Option Description 

Add > Select a column from the Data Sources tree, and then click this 
button to include it in the join. 

< Remove Removes a column from the list of columns included in the join. 

Join columns Lists the columns that should be included in the join. 

Condition Select one of the alternatives to specify which type of join to use. 
An inner join will return rows for which only the matching fields in 
both tables are equal. An outer join will return all the rows (including 
NULL values) from one table, and only the matching rows from the 
other table. 

Freehand Select this option to specify your own join definition. 

Target tables Select one table from each drop-down list. If you are only using two 
columns in the join, then you cannot alter the default choices. If more 
than two columns are included in the join condition (for example, an 
intermediate table), then it is important to select the two tables that 
are to be joined. 

Default join Select this check box if you want this join to be the default one if two 
different joins between the same tables exist. The default join is the 
one that is suggested in the Join path field when defining an 
information link, if the Suggest Joins button is clicked. 

Description A free-text description of the join. 

Save As Click Save As to create a copy of the join element. 

Save Click Save to save or update the join. 

13.7.13.4.8 Data Source Tab  
All data sources that have been defined and you have access to are listed in the Data Sources 
tree and also in the Elements tree. By placing a data source in a folder, you can specify which 
users will have permission to access the data therein. Right-click on a data source and select 
Edit from the pop-up menu to modify a previously added data source. 
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Option Description 

Name The name of the data source, as you want it to appear in the Data 
Sources tree and in the Elements tree. 

Type Type of database. For example, choose from Oracle and SQL Server 
through JTDS or DataDirect. If more databases have been set up, they 
will appear in this list. See TIBCO Spotfire Server – Installation and 
Configuration Manual for details on setting up connections to other 
databases. 

Connection URL URL of the database. The format of this URL depends on the type of 
database. Change the placeholders in the default URL so that it links to 
your selected database. 

No of 
connections 

Min is the minimum number of database connections created for a given 
data source. 
Max is the maximum number of database connections created for a 
given data source. There can never be more connections open at a given 
moment than the specified max number. 
Note: If you use SAS/SHARE, ODBC or other data sources that do not 
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support pooled connections (i.e., there is no valid ping command), set 
both min and max to 0. 

Username Username for the data source. 

Password Password for the data source. 

User 
authentication 

Use individual usernames to authenticate users when running 
information links. By default, this will prompt the user for credentials 
when running the information link against this data source for the first 
time. Optionally, you can develop a custom plug-in and use it to retrieve 
the credentials. 
Note: If you are using Kerberos Delegation for database connections be 
sure to select this check box. 

Credentials 
timeout (hours) 

The number of hours to save credentials so that an end user does not 
have to login again when making multiple connections to the same data 
source. If no number is specified, the credentials will need to be 
specified again after 24 hours. 
Data source credentials caching is done on both the TIBCO Spotfire 
client as well as on the TIBCO Spotfire Server. 
On the client, data source credentials are cached for the duration of the 
TIBCO Spotfire session. This means that once a user has authenticated 
against a data source those credentials will be cached on the client side 
until the client is closed. Once the user has authenticated against a 
particular data source he/she will not be prompted for credentials for that 
data source for the remainder of the client session. 
In addition, data source credentials are also cached on the TIBCO 
Spotfire server. On the server, data source credentials are stored on a per 
user, per data source basis. Credentials can be stored from a minimum of 
36 seconds (0.01 hours) up to a full week. 
Once authenticated a user will not be prompted for data source 
credentials during this time even if the client is restarted. 
The server side credentials caching uses what is called a moving window 
for the timeout of the cached credentials. Hence, if a credential is used 
the caching period will be reset to the maximum timeout period. 

Allow writing in 
temporary tables 

Allows the Information Services to create temporary tables in this data 
source. This is needed when running information links that join data 
from several data sources or have a large number of filter values. 
To guarantee full compatibility between Information Services and Oracle 
databases, it is recommended that the compatible setting in init.ora (for 
the databases) is set to: compatible=8.1.0.0.0 

Open session 
commands 

Commands executed when acquiring a database connection from the 
connection pool or creating a new connection if pooled connections are 
not supported. 
Can be used, for example, to authorize a user in an Oracle VPD context. 
  
Example: 
exec set_vpd_user(%CURRENT_USER%) 

Close session 
commands 

Commands executed when returning a database connection to the 
connection pool or closing a connection if pooled connections are not 
supported. 
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Can be used, for example, to clear an authorized user in an Oracle VPD 
context. 
  
Example: 
exec set_vpd_user(") 

Connection 
initialization 

Command executed when initializing a database connection. 

Fetch size The maximum number of values in each block of data retrieved from the 
database. Used for performance tuning. In general, use higher values for 
physically distant databases. Use lower values when the number of users 
is high. Entering the value zero will make the JDBC driver use its default 
value. 

Batch size The maximum number of values in each block of data sent to the 
database. Used for performance tuning. In general, use higher values for 
geographically distant databases. Use lower values when the number of 
users is high. Entering the value zero will make the JDBC driver use its 
default value. 

Save As Click Save As to save a copy of the data source. 

Save Click Save to save or update the data source. 

13.7.13.5 Details 

13.7.13.5.1 Pop-up Menus 

Elements: 
This pop-up menu is reached by right-clicking on an element in the Elements tree: 

Option Description 

Open Data [Only available when right-clicking on an information link.] 
Imports data into TIBCO Spotfire. 

Edit... Opens the tab used to edit the selected element (Information 
Link, Join, Column, Filter, Procedure or Data source). 

Edit Properties... Opens the Edit Properties dialog where you can change the name 
and description of the selected item. You can also add keywords 
for improving the chances of finding the correct elements when 
searching the library. 

New > [Only available when right-clicking on a folder.] 
Provides a shortcut entry to the Create Element options, opening 
a new tab were the new element can be specified. 

Delete Removes the selected element from the library. 

Refresh Refreshes the content of the currently selected folder. 

Refresh All Refreshes the entire tree. 
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Find All References [Only available when right-clicking on a column, filter, 
procedure or join element.] 
Opens a Find Results tab where all references to the selected 
element are listed. (For example, all information links where a 
certain column element is included.) 

Validate Validates the content of the selected element and opens a 
Validation Result dialog or a tab with information about errors 
and/or warnings. 

Copy ID Copies the GUID of the selected element to the clipboard. 

Folder Permissions... [Only available when right-clicking on a folder.] 
Opens the Library Folder Permissions dialog where you can 
change the permissions for all users or groups to the selected 
folder. 

Data Sources: 
This pop-up menu is reached by right-clicking in the Data sources tree or on a data source in the 
Elements tree: 

Option Description 

Edit... Opens the tab used to edit the selected data source. 

Edit Properties... [Only available when right-clicking on a data source.] 
Opens the Edit Properties dialog where you can change the name 
and description of the selected data source. You can also add 
keywords describing the data source. 

Create Default 
Information Model... 

Allows you to specify a location and automatically create a 
default set of elements and information links based on the 
selected data source, catalog, schema or table. See also Details 
on Create Default Information Model Settings. 

Create Column 
Elements 

[Only available when right-clicking on a table.] 
Opens a Multiple Column Elements tab with the content of the 
table already added to the Source columns list. 

Create Table Alias [Only available when right-clicking on a table.] 
Opens a dialog where you can specify a name for the table alias 
and appends a copy of the selected table to the data source. See 
Creating a Table Alias for more information. 

Delete [Only available when right-clicking on a data source or a table 
alias.] 
Removes the selected data source or table alias from the library. 

Refresh Refreshes the content of the currently selected instance. 

Refresh All Refreshes the entire Data sources tree. 

Find All References Opens a Find Results tab where all references to the selected 
instance are listed. (For example, all elements referring to a 
column from a certain database table.) 
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Validate [Only available when right-clicking on a data source.] 
Validates the content of the selected data source and opens a 
Validation Result dialog or a tab with information about errors 
and/or warnings. 

Copy ID [Only available when right-clicking on a data source.] 
Copies the GUID of the selected data source to the clipboard. 

Tab titles: 
This pop-up menu is reached by right-clicking on the tab title of the Start tab or any other open 
tabs on the right-hand side of Information Designer. 

Option Description 

Close Closes the currently active tab. 

Close All but This Closes all tabs except the currently active tab and the Start tab. 

Locate in Tree Locates the currently active tab in the Elements tree. 

[Titles of open tabs] Allows you to quickly navigate to any of the currently open tabs. 

13.7.13.5.2 Details on Edit SQL  

 

Option Description 

Data source Displays the data sources used by the current information link in a drop-
down list. You can only edit the SQL of one data source at a time. 

Pre-Updates Click this radio button to enter statements to be executed before the data 
retrieval. For example, this could be a call to a stored procedure or 
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statements such as 'CREATE TABLE' or 'INSERT'. 

Query Click this radio button to display and modify the SQL of the information 
link. 

Post-Updates Click this radio button to enter statements to be executed after the data 
retrieval. For example, 'DROP TABLE'. 

Modified SQL Modify the SQL of the information link in this text box. Multiple SQL 
statements are allowed in pre-updates and post-updates as long as they 
are separated with double new lines. 
Note: If you alter parameters in the SQL code, the changes will override 
any parameter settings made elsewhere, such as in the filter part of the 
information link tab. 

Original SQL Displays the original SQL of the information link so that you can 
immediately see the differences that you have made upon your 
modification. 

Reset to Original Resets the Modified SQL to the SQL originally created in the 
information link. 
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13.7.13.5.3 Pivot Conditioning in Information Designer 

 

Option Description 

Identity Each unique value in the chosen identity column produces a row in the 
generated table. 
If you choose more than one column, then the new table will have a 
separate row for each unique combination of values in the chosen 
columns. 

Other columns Each unique value in the chosen category column produces a new 
column in the generated table. 
Selecting more than one column  means that the new table will have a 
separate column for each unique combination of values in the chosen 
columns. 

Values The column from which the data is pulled. The values in the generated 
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table are computed according to the method selected under Aggregation 
(for example, Average). 
Note: If you are certain that each combination of Identity and Category 
has a unique value, then you can select the Aggregation: None which 
will not apply any aggregation of the data. However, the pivot will fail if 
you select None, and each combination of Identify and Category is not 
unique. 

   Column name 
expression 

You can select how the pivoted columns should be named. By default 
the predefined option is: 
  Method(Value) for Column 
You can also create a custom naming scheme for your pivoted columns. 

Other columns This option allows you to include an overall average of a particular 
measurement, for each row in the generated table. 

13.7.13.5.4 Details on Prompt Groups 
Prompt groups are used to specify which prompts should be dependent of each other, and which 
should not. 

 

Option Description 

Element Lists all elements currently available in the information link. 

Group By entering the same group number for two columns you specify that 
these columns should be dependent of each other, but not by columns 
from a different prompt group. 

13.7.13.5.5 Details on Add Column 
This dialog is shown when you have selected to add a filter or a prompt to an information link. 
It is also used to select columns when you want to apply a Pivot conditioning. Columns that 
have been added to the information link are available in the drop-down list. 
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Option Description 

Select column Specifies which of the column elements should be used in this 
particular place. 

Aggregation 
method 

Specifies the aggregation method to use for the column. 
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13.7.13.5.6 Details on the Save As Dialog 

 

Option Description 

Search Type a search expression to limit the tree view below the search field 
so that it shows folders and elements matching the search expression 
only. 

Clear Search... [Link available only after a search has been performed.] 
Click on the link to clear the search and return to view the full 
Elements tree. 

[Elements tree or 
search results] 

Click to select the folder where you want to save the element. 

Name The name of the element to be saved/edited. 

Description A short description of the purpose of the element. 

Save Click Save to save or update the element. 

Note: Some characters are forbidden in the element names and file system of TIBCO Spotfire 
3.0 and forward: /\*"?:<>| 
Old information models with element names containing these characters can be imported. 
However, you cannot edit and resave elements using their old names if they contain forbidden 
characters. 
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13.7.13.5.7 Details on Create Multiple Columns 

 

Option Description 

Place columns in Click on the folder in the tree where you want the new column 
elements to be created. 

Search Type a search expression to limit the tree view below the search field 
so that it shows folders and elements matching the search expression 
only. 

Clear Search... [Link available only after a search has been performed.] 
Click on the link to clear the search and return to view the full 
Elements tree. 

Create Columns Creates the column elements in the specified folder. 

 

13.7.13.5.8 Details on Add/Edit Column Property 
Custom properties are metadata that can be used when searching for columns using the 
following syntax: <Property name>:<Value>. For example, IncludedColumn:True. 
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Option Description 

Property name Specifies the name of the custom property. 

Value Allows you to specify a value for the selected property. 

13.7.13.5.9 Details on Add/Edit Information Link Property 
Custom properties are metadata that can be used when searching in the library by using the 
following syntax: <Property name>:<Value>. For example, DataTableType:On-Demand or 
DataTableType:"Additional Data Table". Information link properties are transformed to data 
table properties when the information link is opened in an analysis. 
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Option Description 

Property name Specifies the name of the custom property. 

Value Allows you to specify a value for the selected property. 

13.7.13.5.10 Details on Open Information Link 
The Open Information Link dialog appears when an information link is being opened, and a 
column is encountered that has been set up with a prompt (a run-time filter). The dialog may 
take various forms depending on the type of prompt selected. 
Note: If the prompt step not is marked as mandatory by the person setting up the information 
link, then clicking Finish or Next > will automatically retrieve all available values for that step. 
However, if you make any changes to the dialog, such as selecting the Include empty values for 
this step check box, then the step is seen as modified and you will only retrieve the values 
actually selected in the dialog. This applies to all prompt types except Single selection. 

Values 

 

Option Description 

Enter values Type column values that you want to use as a constraint and separate them 
by pressing ENTER. 
Type * to retrieve all possible values. 

Get Values... Use this button to set the column filter by fetching values from loaded data 
tables in TIBCO Spotfire. Opens the Column Values dialog. 

Include empty 
values for this 
step 

Select this check box to also include rows that do not contain any data for 
this column. 
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Range 

 

Option Description 

Lower limit Type the lower limit for the values of the column. 

Upper limit Type the upper limit for the values of the column. 

Include 
empty values 
for this step 

Select this check box to also include rows that do not contain any data for 
this column. 



TIBCO Spotfire 4.0.2 - User's Manual 

1020 

Multiple selection 

 

Option Description 

Select values Select individual values for the column by clicking the entries in the list. To 
select consecutive values, click the first item, press and hold down SHIFT, 
and then click the last item. To select multiple entries that are not 
consecutive, press and hold down CTRL, and then click each item. 

Include empty 
values for this 
step 

Select this check box to also include rows that do not contain any data for 
this column (and consequently are unavailable in the list). 
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Single selection 

 

Option Description 

Select one 
value 

Select a single value for the column by clicking on it in the list. 

Include 
empty values 
for this step 

Select this check box to also include rows that do not contain any data for 
this column (and consequently are unavailable in the list). 
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13.7.13.5.11 Details on Column Values 

► To reach the Column Values dialog: 
1. Open an Information Link with prompts. 
2. When the Open Information Link dialog for the desired column appears, click Get 

Values.... 

 

Part Description 

Table Select a data table from the drop-down list. 

Column Shows the available columns in the selected data table. Select a 
column by clicking on it in the list. You can narrow down the list 
of available columns by typing a part of a name in the "Type to 
search" field. 

All rows Gets values from all rows available in the entire data table, 
regardless of filtering. 

Filtered rows Gets values from the rows remaining after the current filtering 
(using the filtering scheme on the active page) only. 

Marked rows, defined 
by: 

Gets values from the rows marked in the visualizations (using the 
specified marking) only, regardless of filtering. 
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13.7.13.5.12 Details on Edit Parameter 

 

Option Description 

Name Shows the name of the parameter you want to edit. 

Data type Lists the different data types available for your parameter. Select one 
from the list to change the data type your parameter expects the values 
it receive to be in. 

Value type   

  Single value Choose single value if the parameter is supposed to receive just one 
value. 

  Array Choose array if the parameter is supposed to receive several values. 

13.7.13.5.13 Details on Missing Parameter Value 
If you have the correct license, this dialog is shown when you open a parameterized information 
link or file and for some reason the value of a parameter has not been supplied. You can use this 
dialog to type a value for that parameter. 

 
Note: If the parameter expects an array as input (multiple values) and the values come from a 
string column that has commas within the values (e.g., last name and first name in a name 
column)  the syntax to use is "Smith, John", "Williams, Peter", and so on. Any comma that is 
not within quote signs will be interpreted as the end of a value. 
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13.7.13.5.14 Details on Missing Information Link 
This dialog is shown if an analysis with data linked to an information link is opened and the 
information link is missing. 

 

Option Description 

Copy GUID Copies the GUID of the information link to the clipboard. The GUID is 
a unique identifier for the information link that remain the same if the 
name of the information link is changed. This can be useful for support 
or an administrator if the information link cannot be found. 

Open analysis 
anyway 

Opens the analysis without the missing information link. 

Browse for the 
missing 
information link 

Opens a dialog that lets you browse or search for the missing 
information link. 
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13.7.13.5.15 Details on Create Default Information Model Settings 
This dialog allows you to specify a description and keywords for all elements created by the 
Create Default Information Model menu option. This type of information can be used to 
identify all elements created by this operation at a later stage. It also lets you specify how to 
handle any name conflicts with existing elements. 

 

Option Description 

Description An optional description of the data. The description could 
contain detailed information about the data enabling quick 
overviews. 

Keywords Keywords specific to the data. Keywords are separated by 
semicolons. This means that if you write "sales 
representatives; cost" it will be interpreted as two keywords, 
"sales representatives" and "cost". 
Keywords are used to enhance organization and search 
capabilities. 

If a created item has the 
same name as an existing 
item 

  

   Automatically assign a 
new name to the created 
item 

Appends a number, e.g., (2), to the name of the new item. 

   Replace existing item Replaces all existing items. 

   Keep existing item Keeps all existing items and adds only those items that 
previously did not exist. 
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13.7.13.5.16 Details on Select Destination Folder 
This dialog is used to specify where to place the new default information model. 

 
Navigate through the folders, and select the folder where you want the new elements and 
information links to be created. Information about the selected folder is displayed to the right of 
the list of folders. Which library folders you have access to is controlled by group privileges. 
Contact your Spotfire administrator if you cannot reach all the necessary folders. 
You can search for a folder in the library by entering a name, or part of a name in the search 
field in the upper right corner in the dialog, and then pressing Enter. All folders matching your 
search string will then be listed. See Searching the Library for more information about search 
expressions. 

13.7.13.5.17 Data Source Login Dialog 
This dialog is displayed when the data source administrator has selected to use data source 
authentication (the User authentication check box on the Data Source Tab in Information 
Designer). 
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Option Description 

Username The username for the specified data source. 

Password The password for the specified data source. 

Data source The data source that you are trying to connect to. 

13.7.13.5.18 Details on Edit Properties 
This dialog is used to edit the properties for an item in the library. It can be reached by right-
clicking on the item of interest in the Information Designer tree structure and selecting Edit 
Properties... from the pop-up menu. 

 
To edit the properties of an item you must have Browse + Access + Modify permissions to the 
folder it is placed in. 

Option Description 

Name The name of the library item. The following characters are not 
accepted in titles: 
\ / : * ? " < > | $ & + = @ # % ; , { [ ] } ^ ' ~ ´ 

Description A description of the library item. 

Keywords Allows you to add keywords which can be used for finding the item in 
the library. Keywords are separated by a semicolon. 
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13.7.14 Tips and Examples 

13.7.14.1 Understanding Filters in Information Designer 
There are two ways to control filtering in Information Designer. One is to create separate filter 
elements. These will appear as icons, and allow the end user to apply them in an information 
link at will. The other method is to associate a filter directly to the column. This means that 
when the column element is used in an information link, the column filter is automatically 
applied. 
Use column filters (hard filters) only when there is no reason to believe the user will ever want 
to use the column without a filter. Make sure the column description makes it clear to the user 
that a filter is being applied. 
Use filter elements when you want to give users the option to use or not use the filter. Again, 
remember to write a good description of the filter. 

13.7.14.2 When to Use Prompt Groups  
Prompt groups can be used to treat elements (columns or filters) as independent from elements 
in other prompt groups during the opening of prompted information links. The default behavior 
of prompted information links is that each subsequent step lists values based on earlier 
selections. However, if you are working against, for example, a STAR schema database the 
procedure may require multiple joins since the elements queried for the prompts are linked only 
by the large fact table in the STAR schema. 
By assigning an element to a different prompt group no previous selections in the prompt steps 
will be reflected in the listing for the independent element. Neither will any of the selections 
made in the prompt step for the independent element be reflected in later prompt steps 
(regardless of whether the later prompt steps are independent or not). It may also be of interest 
to specify a different prompt group for an element that is not prompted, for example, a column 
with a hard filter. 

Example: 
Say that you have information about your employees and their salaries stored in a STAR 
schema database with a layout similar to the one below: 

 
Now, you want to retrieve information about the salary of your employees in the Chicago 
office, with the possibility to filter using DeptNo and Gender upon running the information link. 
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► These are the steps you would perform to retrieve this type of 
information: 
1. Create an information link by adding all the interesting columns to the Information 

Link tab. 
2. In the Filters section, add the Location column. 
3. Select Values as Filter Type. 
4. Type Chicago in the Values text field. 

  
5. In the Prompts section, add the DeptNo and Gender columns. 
6. Select suitable Prompt type options (for example, Multiple selection)) for the DeptNo 

and Gender columns. 
7. Click Groups... and enter a different prompt group for the Location column. 

  
By making Location independent you avoid having to join to the large fact table for each 
prompt. When the information link is opened you will first be prompted to choose a DeptNo. 
Instead of going through the large fact table to the Location table and filter out all values except 
the ones for Chicago, you will see all values in the DeptNo column. For the next prompt step 
the much quicker connection between DeptNo and Gender is used directly, thus improving the 
performance of the information link. 
Note: When Location is made independent you will see all possible values in the prompt step 
for DeptNo even though some of them perhaps are inapplicable due to the hard filter setting 
Chicago on the Location column. 

  
This means that if all employees in the Chicago office belong to department number 30, you 
might accidentally select number 20 in the prompt step for DeptNo with the result that no data 
is retrieved from the server. 
  
If no prompt group changes had been made, the hard filter on Chicago would have been applied 
prior to the first prompting step and DeptNo 30 would have been the only one displayed in the 
prompt list: 
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In this case, the risk of selecting wrong data in a prompt step is minimized. 

13.7.14.3 Replacing Null  
Sometimes a column returns null values. By using the Oracle SQL function NVL, null values 
can be replaced with another value. 
Note: The following example only applies to data retrieved from an Oracle database. 

► To modify a column to replace null values with 0 (zero): 
1. Right-click on the column in the Elements tree. 
2. Select Edit from the pop-up menu. 
3. In the Expression field, type:  

 
NVL(%1,0) 

4. Click Save. 
Note: Sometimes a null value has a meaning different from zero, such as "value unknown". 
Make sure you understand how the data is meant to be interpreted before replacing values! 

13.7.14.4 Limiting the Number of Records Returned  
The Oracle pseudo column ROWNUM makes it possible to use a filter to control the number of 
rows returned by an information link. In the example below, only the first ten rows are to be 
retrieved. 
Note: The following example only applies to data retrieved from an Oracle database 

.  

► To create a filter that limits the number of rows returned by an 
information link: 
1. Click New and select Filter. 

Response: A Filter Element tab is opened. 
2. In the Expression field, type:  

 
ROWNUM < 11 
  

3. Type a suitable Description. 
4. Click Save. 
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13.7.14.5 Concatenating Strings  
The Oracle SQL function CONCAT lets you create a column by concatenating strings from 
different tables. 
Note: The following example only applies to data retrieved from an Oracle database. 

► To combine strings from two different tables into a single 
column element: 

 
1. Click New and select Column. 

Response: A Column Element tab is opened. 
2. In the Data Sources tree, select the first column (Region in the example above). 
3. Click Add >. 

Response: The selected element is added to the Source columns list on the Column 
Element tab. 

4. Select the second column (State in the example above). 
5. Click Add >. 
6. In the Expression field, enter:  

 
concat ( concat (%1, ' '), %2) 
  

7. Select String from the Data type drop-down list. 
8. Type a suitable Description. 
9. Click Save. 

13.7.14.6 Aggregate Functions 
Aggregate functions summarize the values in a column. Below are some examples of aggregate 
functions that can be used when retrieving data from an Oracle database. Please see the 
documentation for your own database for more information. 
Note: The following functions only apply to data retrieved from an Oracle database: 

Function Description 

SUM (%1) total of all the rows in column %1, given that the 
column is numeric 

AVG (%1) average of column %1 

MAX (%1) largest figure in column %1 

MIN (%1) smallest figure in column %1 

COUNT(%1) number of rows in column %1 
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CORR(%1,%2) coefficient of correlation of columns %1 and %2 

COVAR_POP(%1,%2) population covariance of columns %1 and %2 

COVAR_SAMP(%1,%2) sample covariance of columns %1 and %2 

REGR_SLOPE(%1,%2) slope of the line described by columns %1 and %2 

REGR_INTERCEPT(%1,%2) y-intercept of the regression line described by columns 
%1 and %2 

REGR_COUNT(%1,%2) integer that is the number of non-null number pairs 
used to fit the regression line 

REGR_R2(%1,%2) coefficient of determination (also called "R-squared" or 
"goodness of fit") for the regression 

REGR_AVGX(%1,%2) average of the independent variable (%2) of the 
regression line 

REGR_AVGY(%1,%2) average of the dependent variable (%1) of the 
regression line 

REGR_SXX(%1,%2) computed as: 
REGR_COUNT(%1, %2) * VAR_POP(%2) 

REGR_SYY(%1,%2) computed as: 
REGR_COUNT(%1, %2) * VAR_POP(%1) 

REGR_SXY(%1,%2) computed as: 
REGR_COUNT(%1, %2) * COVAR_POP(%1, %2) 

STDDEV(%1) sample standard deviation of column %1 

STDDEV_POP(%1) 
computes the population standard deviation of column 
%1 and returns the square root of the population 
variance 

STDDEV_SAMP(%1) 
computes the cumulative sample standard deviation of 
column %1 and returns the square root of the sample 
variance 

VAR_POP(%1) population variance of column %1 

VAR_SAMP(%1) sample variance of column %1 

VARIANCE(%1) variance of column %1 

13.7.14.7 Examples of Generated SQL 

13.7.14.7.1 SQL - Filters  
In this example we will define a column element with a filter. The column should only return 
sales transactions above 10000. 
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Save the column element with the name High Sales. 
The column element defined above will result in the following SQL when executed as part of an 
information link: 

SELECT 
   S1."Sales" AS "HIGHSALES" 
FROM 
   "Sales"."dbo"."SalesandCost" S1 
WHERE 
   (S1."Sales" > 10000) 
   AND <conditions> 

13.7.14.7.2 SQL - GROUP BY  
In the following example, we will use aggregation to calculate the average profit that our 
company made for a number of products, in order to locate our best product. We are assuming 
that the database provides the columns containing the price we got from the buyers at each 
transaction (Sales) and the price our company paid for the raw material (Cost) at that time. We 
also have a column containing the type of the product sold at each transaction (Type). 
Define a column element called "Average Profit" as follows: 
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We must also define a column element "Type" from Type which returns the product type. 
If we define an information link using these three columns, the following SQL will be generated 
(notice the GROUP BY clause): 

SELECT 
   tmp1."AVERAGEPROFIT", 
   E1."TYPE" AS "TYPE" 
FROM 
   "Sales"."dbo"."SalesandCost" S1 
      SELECT 
         AVG(E1."Sales" - E1."Cost") AS 
"AVERAGEPROFIT", 
         E1."TYPE" AS col1 
      FROM 
        "Sales"."dbo"."SalesandCost" S1 
      GROUP BY 
         E1."TYPE" 
   ) tmp1 
WHERE 
   (E1."TYPE" = tmp1.col1) 
   AND <conditions> 
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13.7.14.7.3 SQL - Subqueries  
Information Designer supports subqueries (inner SQL). In this example we will demonstrate 
how to retrieve all sales transactions greater than the average. 

 
We create a new column "High Sales Transactions" with the following filter expression: 

%1 > (Select avg(Sales) from 
Sales.dbo.SalesandCost) 

Note: Be careful to include all brackets or it will not work! 
The column element defined above will result in the following SQL when executed as part of an 
information link (notice that the WHERE clause includes the sub query from the filter 
condition): 

SELECT 
   S1."Sales" AS "HIGHSALESTRANSACTIONS" 
FROM 
   "Sales"."dbo"."SalesandCost" S1 
WHERE 
   (S1."Sales" >( 
      Select 
         avg(Sales) 
      from 
         Sales.dbo.SalesandCost 
   )) 
   AND <conditions> 
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13.7.14.8 PL/SQL Functions 
In the following example, we will retrieve sales information for employees in both USD and 
EUR. One way of doing this is to write a function in SQLplus that performs the calculation: 

CREATE FUNCTION money_converter 
( amount IN NUMBER) 
  RETURN NUMBER IS 
  return_val NUMBER (10,2) := 0; 
  BEGIN 
    return_val := amount * 0.75; 
    Return (return_val); 
  END; 
/ 

The sales in USD is used as input, and the output is a value that is 0.75 times smaller. Store the 
function in the SDP_ADMIN schema (or elsewhere if a different administrator username is 
used) to make it accessible by Information Designer. 
Now create a column element with the name "Sales (EUR)" as follows: 

 
Also create a column element "Type" with product types, and "Sales (USD)" with the original 
sales values. 
When an information link with these three columns is executed from Information Designer, the 
generated SQL looks something like this: 

SELECT 
   S1."Type" AS "Type", 
   S1."Sales" AS "SALESUSD", 
   money_converter(S1."Sales") AS "SALESEUR" 
FROM 
   "Sales"."dbo"."SalesandCost" S1 
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13.8 Library Administration 
13.8.1 Introduction 

The TIBCO Spotfire system features a library. Using the Spotfire library, people can publish 
and share all their analysis material, information links, data sources, etc. The Spotfire library 
contains a folder structure where you can set permissions on folder level. 
While most Spotfire users can open and save files to the library from the normal Open and Save 
dialogs in TIBCO Spotfire, the Library Administration tool lets certain users access the library 
in a more administrative role. The Library Administration tool lets you structure the library and 
its contents. You can copy and move files and folders, create new folders and build folder 
structures. You can set permissions for folders so that only certain users are allowed access to 
certain parts of the library. If you want, you can also import content into the library, or export 
parts of the library to file. 
To access the Library Administration tool you must have enabled the license feature Library 
Administration included in the TIBCO Spotfire Administrator license. Note that this license 
does not affect the actual permissions set for the various folders in the library, it only enables a 
user to open the Library Administration tool. 
To have full control over the library you must be a member of the Library Administrator 
group that is always present in the Spotfire system. Members of this group will override any 
permission levels in the library and have full control of the entire library. Members of this group 
are also the only ones allowed to create, delete and change permissions for top level folders in 
the library. 

13.8.2 Permissions 
Permissions 
Permissions are always set on folders, never on items. 
There are four levels of permissions that can be set for a folder in the library: 

• Access - The user or group is allowed to execute information links that are placed in 
the folder, but is not allowed to browse the contents or open analysis files. 

• Browse + Access - The user or group is allowed to access and browse the folder 
contents. The user can open and use items found in such folders, but not save or 
modify them. 

• Browse + Access + Modify - The user or group is allowed to browse and access the 
contents of the folder and also modify items or save new items. The user can also 
create new subfolders. 

• Full Control - The user or group is allowed to access and browse the folder, modify 
and save items, and also change permissions for the folder and its contents. 

The Library Administrator Group 
There is a group called Library Administrator that is always present in the Spotfire system. 
Members of this group will override any permission levels in the library, and have full control 
of the entire library. By default, members of this group are also the only ones allowed to create, 
delete and change permissions for top level folders. 

Inheritance 
By default, a subfolder inherits the permissions of its parent folder. This holds true for entire 
chains of subfolders in the library. However, if you have Full Control of a folder, you can edit 
the permissions for it and specify the exact permissions that you want it to have. When explicit 
permissions are set for a folder, the inheritance from the parent folder (or any folder higher up 
in the hierarchy) is completely severed. 
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It is important to note that for a user to be able to browse the contents of a folder, he must also 
have Browse + Access permission for the parent folder, and its parent folder, and so on all the 
way to the top level of the library. If the Browse + Access permission is removed for a folder in 
the hierarchy, the user cannot browse to any folders further down that folder structure regardless 
of the permissions set for such folders. 

13.8.3 Creating a New Folder 
To create a new folder you must have Browse + Access + Modify permissions in the folder 
where you want the new folder to appear. 

► To create a new folder: 
1. Navigate to the folder in which you want to create a new folder. 
2. Click on the New Folder button. 

Response: The New Folder dialog appears. 
3. Enter a Name for the folder. 

Comment: The following characters are not accepted in folder titles: \ / : * ? " < > | $ & 
+ = @ # % ; , { [ ] } ^ ' ~ ´ 

4. Optionally, enter a Description for the folder. 
5. Optionally, enter Keywords for the folder. These should be separated with semicolons. 
6. Click OK. 

Note: The new folder will by default inherit the permissions from its parent folder. 
  

13.8.4 Deleting an Item 
To delete items you must have Browse + Access + Modify permissions for the folder they are 
placed in. If you want to delete a folder, you must have Browse + Access + Modify permissions 
for all subfolders in the underlying folder structure. 

► To delete an item using the Library Administration tool: 
1. Select the items and folders to delete by clicking on them. You can use Ctrl or Shift to 

multi-select. 
2. Click on the Delete button. 
3. When prompted, confirm that you want to delete the selected items by clicking OK. 

Tip: You can also right-click an item in the library tree and select Delete from the pop-up 
menu. The pop-up menu is also available in the Open from Library and Save as Library Item 
dialogs. 
It is possible to have access to the Library Administration tool without being a member of the 
Library Administrator group. To get access to the Library Administration tool, the license called 
TIBCO Spotfire Administrator, as well as the license feature called Library Administration 
below it, must be enabled. 

13.8.5 Moving an Item 
To move items you must have Browse + Access + Modify permissions for both the source 
folder and the destination folder. If you want to move a folder, you must also have Browse + 
Access + Modify permissions for the entire underlying folder structure of the source folder. 

► To move an item: 
1. Select the items or folders to move. 

Comment: You can multi-select using Ctrl or Shift. 
2. Click the Move icon. 
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Response: The Select Destination Folder dialog appears. 
3. Select a destination folder. 
4. Click OK. 
5. Select how you want to handle any potential name conflicts, and click OK. 

Comment: Read more about how to handle conflicts in How Are Conflicts Resolved? 
The moved folders will keep any permissions explicitly set for them. If a folder is set 
to inherit its permissions, then it will inherit its permissions from the new parent folder 
after it has been moved. 

13.8.6 Copying an Item 
To copy items you must have Browse + Access + Modify permissions for both the source folder 
and the destination folder. If you want to copy a folder, you must also have Browse + Access + 
Modify permissions for the entire underlying folder structure of the source folder. 

► To copy an item: 
1. Select the items or folders to move. 

Comment: You can multi-select using Ctrl or Shift. 
2. Click the Copy icon. 

Response: The Select Destination Folder dialog appears. 
3. Select a destination folder. 
4. Click OK. 
5. Select how you want to handle any potential name and conflicts, and click OK. 

Comment: Read more about how to handle conflicts in How Are Conflicts Resolved? 
The copied folders will keep any permissions explicitly set for them. If a folder is set to inherit 
its permissions, then the new copy will inherit its permissions from the new parent folder after it 
has been copied. 
Folders or items that replace other folders or items will take on the identity of the destination 
folder or item, which means that references to the destination item or folder will continue to 
work but references to the moved folder will be broken.  

13.8.7 Importing to Library 
To import any content into the library from file, you must be a member of the Library 
Administrator group. 
Note: Before importing content into the library, you should always make a backup of your 
existing library by using the Export function. Read more about this in Exporting from Library. 
Note: When information model elements are being imported, the elements should not be 
accessed from the library or from Information Designer until after the import has been 
completed. If the import takes place on a server used by others, it is recommended either that no 
external access is allowed during the import, or that the information model is temporarily 
imported into a folder with no access permissions for other users. After the import has been 
performed, the permissions for the import folder can be changed, or the resulting elements can 
be moved to another place in the library. 

► To import content into the library from file: 
1. Click on the Import button. 

Response: The Import dialog appears. 
2. Click Browse. 

Response: The Select File to Import dialog opens. 
3. Select the file you want to import, and click OK. 

Comment: You can only import zip archives containing appropriate library content. It 
is not possible to import a single analysis. Also, such zip archives must be placed in a 
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specific folder (or in its sub-folders) on a specific machine. This folder is called the 
"Shared Disk Location" and is set from the TIBCO Spotfire Configuration Console. In 
an environment with only one TIBCO Spotfire Server, this folder is by default located 
on the TIBCO Spotfire Server machine in the folder <server installation 
directory>/tomcat/application-data/library. In an environment with more than one 
Spotfire Server, one of them is dedicated to hold Library exports. See the TIBCO 
Spotfire Server - Installation and Configuration Manual for more information about 
how to set this up. 
In the Import items of type drop-down list, select whether or not you want to limit the 
import to only include certain types of items. 

4. Select if you want to Include permissions if such are stored in the file. If you do not 
include any permissions, the imported items will inherit the permissions of the 
destination folder. 

5. Select Ignore empty directories if you do not want to import any empty library 
folders. 

6. Select how you want to handle any potential name and/or GUID conflicts. 
Comment: Read more about how to handle conflicts in How Are Conflicts Resolved? 

7. Click OK. 
Response: The Select Destination Folder dialog appears. 

8. Select a folder to import to, and click OK. 
Response: The Library Import status dialog appears. 

9. Click Refresh to update the status messages in the dialog. 
10. Click Close when the Log states Import done. 

  

13.8.8 Exporting from Library 
To export a folder and its contents to file you must be a member of the Library Administrator 
group. 
The folder and its contents will be saved as a zip archive. This zip archive will be placed in a 
specific folder (or in its subfolders) on a specific machine. This folder is called the "Shared 
Disk Location" and is set from the TIBCO Spotfire Configuration Console. In an environment 
with only one TIBCO Spotfire Server, this folder is by default located on the TIBCO Spotfire 
Server machine in the folder <server installation directory>/tomcat/application-data/library/. In 
an environment with more than one Spotfire Server, one of them is dedicated to hold Library 
exports. See the TIBCO Spotfire Server - Installation and Configuration Manual for more 
information about how to set this up. 

► To export a folder: 
1. Select the folder to export. 
2. Click the Export icon. 

Response: The Export dialog appears. 
3. Enter a name for the file that will be created. 
4. In the Export items of type drop-down list, select if you want to limit the export to 

only include certain types of items. 
5. Select whether to Include permissions or not. 
6. Click OK. 

Response: The Library Export status dialog appears. 
Click Refresh to update the status messages in the dialog. 

7. Click Close when the Log states Export done. 
Note: Make sure that all dependencies (columns, filters, etc.) needed by the exported elements 
are included in the exported folder. 
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13.8.9 Searching the Library 
You can search for library items in the Open from Library dialog, in the Library Administration 
tool and in Information Designer. 
Searching for a text string will by default look for matching text in the title and keywords of 
the items in the library. You can use wildcards and boolean operators to search for parts and 
combinations of words. For a listing of the basic search syntax, see Searching in TIBCO 
Spotfire. 
 

Library specific search: 

Keyword Example Function 

title:<word in 
title> 

title:sales Locates library items with the 
specified word (or part of word) 
somewhere in the title. 

created_by: 
<username> 

created_by:admin 
  
created_by::admin 

Locates library items created by a 
certain user. 
In the first example, all items 
modified by any users beginning with 
admin will be found. In the second 
example, only items modified by the 
user 'admin' will be found. 

modified_by: 
<username> 

modified_by:admin Locates library items modified by a 
certain user. 

item_type:<type> 
or 
type:<type> 

item_type:datasource Locates items of a specific type. The 
available types are: column, filter, 
join, procedure, query (=information 
link) folder, dxp (= TIBCO Spotfire 
analysis file), datasource, datafunction 
and colorscheme. 

item_id::<GUID> 
or 
id::<GUID> 

item_id::dac3cd8c-47ec-454a-
a8f2-691c60ece052 

Locates a specific library item based 
on its unique identifier. 

depends_on 
(<expression>) 

depends_on(item_id::538bcde4-
7212-475f-a348-
5bb41ba39c41) 
  
depends_on(Sales) 

Locates all items that depend on a 
specific element. 
  

required_by 
(<expression>) 

required_by(item_id::6f6dc7e0-
57bd-11d7-5ac0-
0010ac110132) 

Locates all items that are required by 
another item. If the GUID in the 
example to the left belongs to an 
information link, the search will find 
all columns, filters, etc. that are 
included in that information link. 
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modified modified:"2 days ago" 
modified:"a week ago" 
modified:>"an hour ago" 
modified:today 
modified:<"this month" 
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
modified::>created 
  
  
modified:"2009-02-
01T18:27:55CEST" 

It is possible to search for items that 
have been modified during a specified 
time span, relative to today. There are 
two different ways of describing 
relative dates and times: 
1) State the number of time parts ago 
in a string surrounded by quotes. The 
available time parts are seconds, 
minutes, hours, days, weeks, months 
and years. For example, search for 
modified:<"6 months ago". The given 
number of time units will be 
subtracted from the current time in the 
search. 
2) State the time period to look back 
at using either of the keywords; today, 
yesterday, "this week", "this month", 
"this year". Note that you need quotes 
around all keywords consisting of 
more than one word. In this type of 
search, the last part of the date or time 
is "reset" (the time gets set to zero, the 
day of the month gets set to 1 etc.). 
The start day of a week is dependent 
on your server locale. For a en-US 
locale the first day of the week would 
be Sunday. 
Modified, created and accessed can 
also be used in comparisons with each 
other. The  example to the left locates 
all items that have been modified after 
their creation. 
Modified can also be used together 
with a timestamp of ISO 8601 format 
("yyyy-MM-dd'T'HH:mm:ssz") to 
find items modified at a specific time. 

created created:>"this week" 
created:<"2 weeks ago" 
  
  
  
  
  
created:>"2009-02-
01T18:27:55CEST" 
  
  

It is possible to search for items that 
have been created during a specified 
time span, relative to today. See 
details regarding the allowed time 
spans under "modified" above. 
Modified, created and accessed can be 
used in comparisons with each other. 
Created can also be used together 
with a timestamp of ISO 8601 format 
("yyyy-MM-dd'T'HH:mm:ssz") to 
find items created at a certain time. 

accessed accessed:>"this month" 
accessed:<"2 weeks ago" 
  
  

It is possible to search for items that 
have been accessed during a specified 
time span, relative to today. See 
details regarding the allowed time 
spans under "modified" above. 
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accessed:null 
  
accessed:>"2009-02-
01T18:27:55CEST" 

Modified, created and accessed can be 
used in comparisons with each other. 
Accessed can also be used together 
with a timestamp of ISO 8601 format 
("yyyy-MM-dd'T'HH:mm:ssz") to 
find items accessed at a certain time. 
The example accessed:null finds all 
items that have never been accessed. 
The last example finds all items that 
have been accessed after the first of 
February 2009. 

::> modified::>created Used to finds items strictly greater 
than the expression following the 
operator. 
For example, finds all items that have 
been modified after their creation. 

::< accessed::<modified Used to finds items strictly less than 
the expression following the operator. 
For example, finds all items that have 
been modified after they were last 
accessed. 

parent_id:: 
<folder GUID> 

parent_id::538bcde4-7212-
475f-a348-5bb41ba39c41 

Locates all items located in the 
specified folder. 

format_version: 
<string or null> 

format_version:null Locates all items of a specified format 
version. For example, all items which 
have no format version specified can 
be found. 

content_size: 
<byte> 

content_size:>10000 
content_size:>500KB 
content_size:<2MB 

Locates all items of a specific byte 
size. In the first example, all items 
larger than 10000 bytes are found. 
If nothing else is specified, the 
number is interpreted as bytes, but 
you can specify content sizes in KB, 
MB or GB as well. 

Analysis files: 
When searching for analysis files, there are a number of search parameters that may help you 
locating a specific group of analyses. If you want to locate analysis files only, add type:dxp to 
the search expression. 

Keyword Example Function 

description description:sales 
  
type:dxp description:sales 

Locates all items 
containing the 
specified word 
in their 
description. 
Locates all 
analysis files 
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containing the 
specified word 
in their 
description. 

keywords keywords:sales 
  
type:dxp keywords:sales 

Locates all items 
containing the 
specified 
keyword. 
Locates all 
analysis files 
containing the 
specified 
keyword. 

AllowWebPlayerResume: 
<true or false> 

AllowWebPlayerResume:true If true, locates 
all analysis files 
that allow 
personalized 
views for all 
web player 
users. 

EmbedAllSourceData: 
<true or false> 

EmbedAllSourceData:true If true, locates 
all analysis files 
that embed all 
source data. 
(Override and 
embed all data 
check box 
selected.) 

OnDemandInformationLinks: 
<GUID> 

OnDemandInformationLinks:* 
  
  
OnDemandInformationLinks:c45618c3-
b7ac-43aa-bafe-e14f39fd4bb7 

The first 
example locates 
all analyses that 
use on-demand 
data tables. 
You can also 
specify a GUID 
to locate all 
analyses that use 
a specific 
information link 
as an on-demand 
data table. 

AllTablesEmbedded: 
<true or false> 

AllTablesEmbedded:true If true, locates 
all analysis files 
that only have 
embedded data 
tables. 
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Information Model elements: 
If you want to locate information model elements of a specific type only, add type:column (or 
filter, join, procedure, query, folder or datasource) to the search expression. 
 

Keyword Example Function 

description description:sales 
  
type:query description:sales 

Locates all items containing the 
specified word in their description. 
Locates all information links containing 
the specified word in their description. 

column column:Sales 
  
column::Sales 

Locates all items referring to a source 
column with the specified name. 
The source column could be referred to 
in the conditions or groupings of a 
column element, a filter condition, a 
join condition or the join condition of a 
procedure. 

table table:SalesandCost Locates all items referring to a source 
table or stored procedure with the 
specified name. 
This could be referred to in the 
conditions or groupings of a column 
element, a filter condition, the condition 
or target tables of a join or in the source 
procedure or join condition of a 
procedure. 

schema schema:dbo Locates all items referring to a source 
schema with the specified name. 
This could be referred to in the 
conditions or groupings of a column 
element, a filter condition, the condition 
or target tables of a join or in the source 
procedure or join condition of a 
procedure. 

catalog catalog:Sales Locates all elements referring to a 
source catalog with the specified name. 
This could be referred to in the 
conditions or groupings of a column 
element, a filter condition, the condition 
or target tables of a join or in the source 
procedure or join condition of a 
procedure. 

datatype datatype:integer Locates all columns of the specified 
data type (integer, real, string, date, 
time, datetime, clob or blob). 

parameter 
  

parameter:MinSales 
parameter:* 

Locates information links using the 
specified parameter. 

<property_name>:  "my.prop":* Custom properties in any information 
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<property_value> 
   
  

model element are searchable using the 
same syntax. 
However, note that the property name 
must by quoted if it contains a '.' 
delimiter. 

Combinations of keywords: 
You can combine many of the keywords described above to create more advanced search 
expressions. For example: 
type:query depends_on(type:column salary) - searches for information links that contains a 
column named salary 
type:query depends_on(column:salary) - searches for information links that contains an 
element that refers to a data source column named salary 
required_by(type::query InformationLinkName) - shows the elements used by the 
information link with the name InformationLinkName. 
(not (required_by(type:dxp))) and type:query - searches for information links that are not 
used by any analysis file in the library. 

► To search for items in the Open from Library dialog: 
Depending on where you are searching, you may get different search results. Analyses and 
information links are shown when searching in the Open from Library dialog, not any 
information model elements or data sources, etc. 

1. Navigate to the top folder of the structure you want to perform the search in. If you 
want to search the entire library, navigate to the library root. 

2. Type the text you want to search for in the search field at the top right corner of the 
dialog. 

3. Click on the search button with a magnifying glass. 
Response: The dialog will switch to a Search Results view. 

4. The items matching your search criteria will be displayed in the list. To return to the 
normal folder view, click the Back to folder link. 

► To search for items in the Library Administration tool: 
1. Navigate to the top folder of the structure you want to perform the search in. If you 

want to search the entire library, navigate to the library root. 
2. Type the text you want to search for in the search field at the top right corner of the 

Library Administration tool. 
3. Click on the Search button. 

Response: The Library Administration tool will switch to a Search Result view. Note: 
Searching for data sources does not include searching for database entities like 
catalogs, schemas or tables. It is only the database instance itself that can be located 
via search. 

4. The items matching your search criteria will be displayed in the list. To return to the 
normal folder view, click the Back to folder link. 

► To search for items in Information Designer: 
Depending on where you are searching, you may get different search results. Information model 
elements, information links and data sources are shown when searching in Information 
Designer, not any analyses, etc. 

1. Type the text you want to search for in the search field at the top of the Elements tree. 

2. Click on the search button with a magnifying glass, . 
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Response: The search results are displayed. Note: Searching for data sources does not 
include searching for database entities like catalogs, schemas or tables. It is only the 
database instance itself that can be located via search. 

3. The items matching the search result are shown in the list. To return to the normal 
folder view, click the Clear Search... link. 

► To use search expressions in custom RSS feeds: 
You can create a customized RSS feed showing the latest changes to the library items you are 
interested in by appending a library search expression to a URL. 
Use the following syntax to create your own feed: 
http://<server>/spotfire/library[/path/to/something/interesting]?rss[&search=<search_expression
>] 
The path and  search parameters are optional. If you only specify 
http://myspotfireserver/spotfire/library?rss, the feed will return the 20 most recently modified 
files in the library. You can also add a max-results section if you want to limit the number of 
results shown, see example below. 
Examples: 
http://myspotfireserver/spotfire/library?rss&search=content_size:>500KB 
http://myspotfireserver/spotfire/library?rss&search=created_by::admin 
http://myspotfireserver/spotfire/library?rss&max-results=10&search=title:sales 

► To use search expressions in tibcospotfire links: 
You can incorporate a search expression in a tibcospotfire link in order to directly populate the 
Open from Library dialog with some suitable analyses or information links. See Links to 
Analyses in the Library for more information about links. The links are a list of keys and value 
pairs. The key and value are separated using colon, :, and each key and value pair are also 
separated with colons: 
tibcospotfire:<key1>:<value1>:<key2>:<value2>...<keyN>:<valueN> 
  
The following keys and values are allowed: 
Search: <search expression> with optional parameters. 
OrderBy : Title | Modified | Created | Accessed | ContentSize | Description 
MaxResult: <positive integer> 
SortDirection: Ascending | Descending 
  
The values should be encoded using the following pattern: 

Value Encoded to: 
: \: 

" \' 

\ \\ 

Examples: 
tibcospotfire:search:*:OrderBy:Modified:SortDirection:Descending:MaxResult:20 
tibcospotfire:search:modified\:<\'3 days ago'\:OrderBy:Modified:SortDirection:Descending 
  

13.8.10 Editing Properties 
To edit the properties of an item you must have Browse + Access + Modify permissions for the 
folder it is placed in. You can edit the Name, Description and Keywords for all types of library 
items. For analyses it is also possible to edit some document-specific properties. 
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► To edit properties: 
1. Select the item you want to edit properties for. 
2. Click on the Edit... link for the Selected Item. 

Response: The Edit Properties dialog is displayed. 
3. Enter a Name for the item. 

Comment: The following characters are not accepted in names: \ / : * ? " < > | $ & + = 
@ # % ; , { [ ] } ^ ' ~ ´ 

4. Optionally, enter a Description for the folder. 
5. Optionally, enter Keywords for the folder. These should be separated with semicolon. 
6. Optionally, for an analysis file, make any changes to the properties on the Document-

tab. 
7. Click OK. 

  

13.8.11 Editing Folder Permissions 
To edit the permissions that are set for a folder, you must have Full Control permission for the 
folder.  

► To edit folder permissions: 
1. Select the folder you want to edit permissions for. 
2. Click on the Edit... link to the right of the Permissions for Current Folder title. 

Response: The Folder Permissions dialog appears. 
3. Select whether you want the folder to inherit permissions from its parent folder, or if 

you want to specify explicit permissions for it. Do this by selecting/deselecting the 
Inherit permissions from parent folder check box. 
If you choose to inherit permissions then you cannot specify any more details. Click 
OK and you are done. 
If you choose to set explicit permissions then proceed to the next step. 

4. When you clear the Inherit permissions from parent folder check box, the 
permissions the folder used to inherit are set explicitly. This gives you a template to 
work from if you want to remove certain permissions or perhaps add some. 
In the search field, type in the name of the user or group you want to add permissions 
for. 
Tip: You can use wild cards (that is, asterisks "*"), to simplify the search. For 
example, use a wild card to display all users and groups, or append it to a word to 
display all users and groups beginning with that word. Example: Group4* will find 
Group41, Group421 and so on.   

5. Using the drop-down selector below the search field, select if you want to search only 
for Groups, only for Users or both Users and Groups. 

6. Click Search. 
Response: The users and/or groups matching the search criteria are displayed in the list 
to the left. 

7. Select the appropriate users/groups in the list and click the > button of the permission 
level they should receive. 

8. Repeat steps 4 through 7 until you have added all the users and groups to the 
permissions level you want. 

9. To remove a user or group from a permission level, select it and click the < button for 
that permission level. 

10. Click OK. 
Response: The folder will be updated with the new permissions. 
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13.8.12 Copying URLs 
Items in the library such as analysis files have a unique URL. By copying this URL and pasting 
it into a web browser, you can open that file in TIBCO Spotfire or perhaps save the file to disk. 
Also, if you have a TIBCO Spotfire Web Player server connected to your library, a second URL 
is available for each analysis file. By copying this to a web browser, the analysis will be opened 
in the TIBCO Spotfire Web Player running in your web browser. 

► To copy a URL and open in TIBCO Spotfire: 
1. Click on an analysis file to select it in the Library Administration window. 

Response: Under the Link to Selected Item heading,  a URL is displayed. 
2. Right-click on the URL and select Copy. 
3. Open a web browser and paste the URL into the address field. 

Response: The analysis is opened in a new instance of TIBCO Spotfire. 

► To copy a Web Player URL and open in TIBCO Spotfire Web 
Player: 
1. Click on an analysis file to select it in the Library Administration window. 

Response: Under the Link to Selected Item heading, a Web Player URL is displayed. 
2. Right-click on the Web Player URL and select Copy. 
3. Open a web browser and paste the URL into the address field. 

Response: The analysis is opened in TIBCO Spotfire Web Player. 

► To copy a URL for unknown clients: 
If you want to send a link to a larger audience where you do not know whether they have access 
to TIBCO Spotfire or just the Web Player, you can use a link to a redirect page instead. 

1. Right-click on an analysis file or information link in the Library Administration 
window. 

2. Select Copy TIBCO Spotfire URL > Server Redirect Page for Unknown Clients 
from the pop-up menu. 
Response: A URL leading to a redirect page is copied to your clipboard. Here, each 
user can select whether to open the analysis in TIBCO Spotfire, TIBCO Spotfire Web 
Player or to Download the analysis file. 

  

13.8.13 How Are Conflicts Resolved? 
Items and folders in the library are identified by two things: their name and a unique identifier 
(GUID). Several items can have the same name provided that they are not located in the same 
folder, but every item will always have a unique identifier. This identifier is used in external 
references to the item, such as a link to an analysis file that you can send to a colleague. If your 
colleague clicks the link, she can open the analysis file in TIBCO Spotfire. Here is an example 
of such a link: 
http://spotfireserver:8080/spotfire/library?guid=2d89e46f-3b15-463a-b581-96d3dfb41742 

Copy and Move 
When you copy or move an item to a folder where an identically named item is already present, 
you must decide how to handle this conflict. 

• Automatically rename copied item - this will append a "(2)" to the name of the file 
you copied. 

• Replace existing item - this will replace the existing item with the one you copied. 
• Keep existing item - this will keep the existing item. 
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Import 
If an imported item has the same name or GUID as an existing item there will be a conflict. 
There are three options for how to handle this. These options are explained in detail below. 

• Automatically assign new name or GUID to imported item 
• Replace existing item 
• Keep existing item 

The following images explain in detail how various conflicts are handled. This is 
primarily important for library administrators about to import content into the library, 
since one should be aware of the result if there are conflicts on GUIDs or names. Each 
section starts with an image showing the task performed, and then the result is shown 
for each of the three options. 

Name Conflict Resolution 
Import Folder A from Library 1 to Library 2 
  

 
  
Automatically rename copied item 
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Replace existing item 

 
  
Keep existing item 
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GUID Conflict Resolution 
Import Folder A from Library 1 to Library 2 

 
  
Automatically assign new name or GUID to imported item 

 
  
Replace existing item 
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 Keep existing item 

 
  
 

Name and GUID Conflict Resolution 
Import Folder A from Library 1 to Library 2 
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Automatically assign new name or GUID to imported item 

 
  
Replace existing item 
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Keep existing item 
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14 Creating a Guided Analysis 
14.1 What is a Guided Analysis? 

There may be times when you want to create and share an analysis file with other people and 
have them perform their own analysis on it. You might want to set up the analysis file to load 
particular data and show certain visualizations, but also provide instructions for other people on 
how to use the document. There might be a specific order a person should go through the pages, 
and detailed instructions on what to look for and which filters are relevant to manipulate on 
each page. To aid in this, there are a number of things you can do in TIBCO Spotfire to set up a 
guided flow through your document. 
When the recipients of your analysis file open it, they will be guided through the analysis as per 
your instructions, but be able to do their own filtering and look closer at any noteworthy aspects 
they find interesting. This allows you to set up a generic analysis covering a subject such as 
sales over the entire United States, but instruct the recipients to filter down to the state they 
work in. 
Some methods you can use to make your analysis guided are: 

• Create a cover page. 
• Write instructions in text areas. 
• Place links or buttons leading to relevant tools, pages or views in the text areas. 
• Switch to step-by-step mode or define your own page navigation through actions using 

history arrows navigation mode. 
• Use customized filtering schemes. 
• Keep in mind the intended end users’ level of data access. 

Create a cover page 
Show the cover page for your document and explain the purpose of the analysis on this page. 
Tell the recipients what kind of data are included in the analysis, and the possible results to look 
for. When you save the analysis file, before sharing it with your colleagues, make sure the cover 
page is active so that the analysis file will open showing that page first. 

Write instructions in text areas 
You might want several pages in your document. The first page might display a map chart of 
the United States showing overall sales results. The second page might have a bar chart 
comparing the sales and expenditures across the different states. The third page might show 
sales figures for each individual salesperson. 
It is recommended that each page include a text area in which you provide some explanatory 
text about what the page shows and its purpose. Give the reader some instructions on what 
filters are relevant to manipulate, and perhaps mention that they can mark interesting items in 
the visualization and see more information about those items in the Details-on-Demand 
window. For example, on the second page with the bar chart comparing states' sales and 
expenditures – you could ask the recipients to select the radio button that filters down to the 
state they work in. 
Tip: To more easily indicate which filter you want users to manipulate, right-click on the filter, 
select Copy, then open the text area, and Paste the image of the filter there along with your 
instructions. 
The use of property controls in the text area may be a great help when creating analyses for 
other people. Just remember to add instructions regarding any constrictions for the control and 
inform about the purpose of the control using regular text. 
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Place links or buttons to relevant tools or views in the text areas 
In some cases, it might be relevant for the recipients to use a tool or an option from the menu 
bar. Instead of writing an instruction for them to click on File > Export > PowerPoint..., you can 
create a link or a button in the text area that performs this action when clicked. The instruction 
you write in the text area can be simpler, like "When you are satisfied with the results, click this 
link to place a snapshot in PowerPoint." Links and buttons are a very powerful way to allow 
even casual users of TIBCO Spotfire to perform analysis of data in a fast and easy manner. 
Links or buttons can also include bookmarks that show a specific view of the data, thus 
explaining the steps that have led you to a particular conclusion. Using custom properties to 
define the visualizations, and property controls that allow the end users to easily change the 
property values can further simplify the analysis procedure for many people. 

Use step-by-step or history arrows page navigation 
When you want to emphasize that the recipients of your analysis file should step through the 
pages in a certain order, you should change the page navigation from titled tabs to step-by-step 
navigation. This means that the pages will instead be shown as numeric links, together with a 
Previous and Next link, above the visualization area. The recipient of the analysis file will then 
start on the cover page, if you have selected to show it, or on the first real page. By clicking 
Next, the user will step through each page in order, performing the analysis described in the text 
areas along the way. 
This can be very powerful since, by default, the filtering done on one page affects all other 
pages as well. You can therefore create a procedural flow wherein the first page allows the 
recipient to filter out unwanted data by looking at one visualization. Then he can proceed to the 
next page, where he continues to drill down into the data, filtering out more unwanted rows 
which he might see using another visualization, and so on. 
You can also select Page Navigation > History Arrows and define your own navigation flow 
using actions in text areas or in graphical tables. This way, clicking on an item directly on the 
pages will be the only way to move forward within the analysis. However, the page history 
arrows located above the visualizations will always make it possible to return to a previously 
visited page. 

Use customized filtering schemes 
By default, the filter settings are the same for every page in the document, and they will stay the 
same until you start changing the filtering schemes. The filtering schemes give you complete 
control and complete freedom to decide which pages of your guided analysis should affect one 
another and which should not. You can keep the same filtering scheme for all pages, create a 
different one for each page, or assign the same filtering scheme to two or more pages. 
Applying different filtering schemes can be useful if your guided analysis consists of several 
separate analyses originating from the same data table. When two pages use the same filtering 
scheme, the filtering performed on one page is propagated to the second page and vice versa. If 
they use different filtering schemes the filtering on each page only affects that very page. 
For example, you can create one page where State is the only activated filter, permitting the 
recipients to click through and compare sales for the states without being bothered with any 
other filters. (If you want to, you can also use organize filters to hide all unused filters.) On the 
next page, you can apply a different filtering scheme relevant to another analysis of the sales 
data and so on. 

Keep in mind the intended end users’ level of data access 
Always make sure the end users of your guided analysis have access to the same data sources as 
you do. Permissions to analyses and information links are handled using the Library 
Administration tool. See also Preparing Analyses for the TIBCO Spotfire Web Player. You may 
also consider adding prompt steps that could limit the available data for each end user. If 
prompts should be shown each time the analysis is loaded, then this should be specified in the 
Data Table Properties dialog before saving the analysis to the library. 
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15 Multiple Data Tables 
15.1 How to Insert Multiple Data Tables into the 

Analysis 
Data can be added to the analysis in several different ways: as new columns, as new rows or as 
new data tables. Adding data as separate data tables is useful if the new data are unrelated to the 
previously opened data table or if the new data are in a different format (pivoted vs. unpivoted). 
If you have a visualization made from a particular data table which has filtering and marking 
that you would like to apply to visualizations made from another data table, then you must 
define a relation between the two tables. For a relation to be useful, you need to have one or 
more key columns (identifier columns) available in both data tables, and use these to define 
which rows in the first data table will correspond to rows in the second data table. If you need 
more than one key column to set up a unique identifier, you must add one relation for each 
identifier column. 
Note: The map chart is the only visualization where you can use different data tables in the 
same visualization. If you need to bring data from different data sources together in any other 
single visualization, use the Insert Columns from External Data or Insert Rows from External 
Data tool instead. 

► To add new data tables to the analysis: 
1. Select File > Add Data Tables.... 

Response: The Add Data Tables dialog is displayed. 
2. Click Add and select the type of data to add from the drop-down list. 

Comment: You can add data tables from files, information links, databases, the 
clipboard, data functions or from current data tables within your analysis. You may 
also have access to other sources if they have been set up by your administrators. 
Response: Depending on your selection you will be presented with a dialog where you 
can specify which file, information link, etc., to add. If you need more information on 
specific data sources, see Opening a Text File, Opening an Excel File, Opening a SAS 
File, Opening an Information Link or Opening Data from a Database. 

3. Select the source data and specify any required settings. 
4. If desired, type a new Data table name. 
5. Apply transformations (optional). 
6. If you want to add more data tables, repeat steps 2-5 for each data table. 
7. Determine whether or not the new data tables will be related to each other or to 

previously added data tables. If a relation is necessary, click Manage Relations... and 
specify the relation. 
Comment: See To define a new relation below for more information. Remember that 
you need to define a relation if the new data table is to be used to create details 
visualizations for the previously added data tables. 

8. Click OK. 
Response: The new data tables are incorporated into the analysis and are ready to be 
used. 

Note: If you want to add a new data table that is loaded on demand you should instead use the 
File > Add On-Demand Data Table option. See Loading Data on Demand for more 
information. 
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► To define a new relation: 
1. In the Add Data Tables dialog, click Manage Relations.... 

Response: The Manage Relations dialog is displayed. 
2. Click on New.... 

Response: The New Relation dialog is displayed. 
3. Select the two data tables you want to connect from the Left data table and Right 

data table drop-down lists. 
4. Select the columns containing the identifiers from the Left column and Right column 

drop-down lists. 
5. If desired, you can apply a Left method or Right method to modify the values of one 

or both columns. 
Comment: For example, if the identifiers are written in uppercase letters in one of the 
data tables and in lowercase letters in the other, you can use the Lower method on the 
uppercase column and change the letters to lowercase. 
Response: The result of the method application is shown in the Sample field. 

6. Click OK. 
Tip: You can always go back and edit relations as well as create new ones using the Data Table 
Properties dialog. 

15.2 How to Handle Multiple Data Tables in One 
Analysis 

When you set up an analysis in TIBCO Spotfire, you may want to be able to visualize data from 
more than one data table. Adding other data tables is fairly easy; just select File > Add Data 
Tables... and use the Add button to select the data source of interest. See How to Insert Multiple 
Data Tables to the Analysis for more information. However, if you choose to bring in a lot of 
data tables, you may find it difficult to keep track of which data tables are related and which are 
not. Therefore, TIBCO Spotfire will add some extra visual hints when more than one data table 
is available. 
You can always get a collected view of all data tables in the analysis by selecting Edit > Data 
Table Properties. 

► To see which data table is used by a certain visualization: 
Data from different data tables cannot be used in the same visualization; not even if they are 
related (with some exception for map charts). Each visualization can be specified to show data 
from any data table. 

1. Look for the data table selector in the legend of the visualization. 

 
Comment: When a new data table is added, the default visualization created will 
normally show the legend with the data table selector visible. However, any old 
visualizations created before the second data table was added will not display their data 
table selectors automatically. 

2. If you cannot see the data table selector in the legend, right-click in a white area of the 
legend and select Data table. 

3. Alternatively, in the Visualization Properties dialog you can go to the Data page and 
directly see which data table is being used, or, you can go to the Legend page and 
display the legend and the data table selector by selecting the appropriate check boxes. 
Comment: You can switch to a different data table from the menu on the data table 
selector. 
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► To view information about the active data table: 
The status bar at the bottom of the TIBCO Spotfire application window displays information 
about the data table used by the active visualization (the visualization that was last clicked 
upon). 

 
The information displayed is: 

• the current number of filtered rows, 
• the total number of rows in the data table (but if the data table is loaded on demand, 

then the number of currently loaded rows is shown), 
• the number of marked rows, 
• the number of available columns, 
• the name of the active data table. 

► To see which visualizations are related: 
1. Look at the color stripe on the left-hand side of the title bar for the visualizations. 

Visualizations using the same data table or related data tables will display the same 
color on the color stripe. 
Comment: The true color of the color stripe is only visible for the active visualization 
and any related visualizations. All unrelated visualizations are shown with a gray color 
stripe until activated. 

2. Click to activate a visualization using an unrelated data table. 
Response: The visualizations working on the new data table get their relations color 
shown and the previously colored visualizations become gray. 

► To differentiate two data tables in the filters panel: 
The filters from one data table are always grouped within a single data table group, which can 
be expanded or collapsed in the filters panel. Filters cannot be moved from one data table group 
to another. 

1. Look at the color stripe on the left-hand side of the filters. 
Comment: Filters belonging to the same data table are marked with the same color 
stripe. The color used is identical to the color of visualizations that use the same data 
table. Only the filters belonging to the data table used by the active visualization or any 
related data table show their true color. Other filters have a gray color stripe. This is 
regardless of how filtering in related data tables has been specified (whether the 
filtering in related data tables affects the filtering in another data table or not). 

2. Click to activate a visualization using an unrelated data table. 
Response: The filters working on the new data table get their relations color shown and 
the previously colored filters become gray. 

► To see which data tables are related: 
When more than one data table is available, a color stripe is added to the data table group and 
its subgroups and filters in the filters panel. If two data tables are related, they will have the 
same color in the filters panel. The currently active data table is written in bold typeface. 
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In the image above, the two data tables "Sales Data" and "Sugar Content" are related to each 
other (and the active visualization uses Sales Data), whereas the "Stores" data table is unrelated 
to the others. You can also check the relations between data tables in the Data Table Properties 
dialog: 

1. Select Edit > Data Table Properties. 
2. Go to the Relations tab. 
3. Click on each data table and look at the Relations color at the lower part of the dialog. 

All related data tables will have the same relations color. All related data tables are 
also listed under Related data tables. 
Comment: The relations color is used in the title bars of the visualizations as well as in 
the filters panel and in the Details-on-Demand. You can change the Relations color for 
all related data tables by selecting a different color from the drop-down list. 

► To change the way filtering in a related data table affects a data 
table: 
1. Go to the filters panel and locate the data table header for the data table of interest. 

Comment: Note that you need to specify how each table should respond to filtering in 
all other related tables separately, to be certain of what will be shown in the 
visualizations after filtering. 

2. Click on the Manage relations icon, . 
Response: A drop-down menu is shown, where all related data tables are available. 

3. Select the data table for which you want to change how the  filtering should affect the 
current data table, and select one of the following options: Include Filtered Rows 
Only, Exclude Filtered Out Rows or Ignore Filtering. 
Comment: See Filtering in Related Data Tables for more information about the 
different options. 

15.3 Data Tables Overview 
With TIBCO Spotfire is possible to load more than one data table within a single analysis. 
Below is a short description of the different concepts used when handling multiple data tables. 
A data table is either data loaded from an external source, or data created within the application. 
It has one or more columns and zero or more rows. 
Data tables loaded from an external source can be linked or embedded. Linked data tables can 
be loaded completely into the application, but if the source is an information link they can also 
be configured to load data on demand only. 
Data tables can be related to each other, using primary and/or foreign keys (key columns), but 
they can also be unrelated. When data tables are related, any marking or filtering in one data 
table may be propagated to the other related data tables, but data from multiple data tables 
cannot be used in a single visualization. 
Tip: If you want to use data from different sources in a single visualization, you should use the 
Insert Columns from External Data or Insert Rows from External Data tools to add the data to 
the existing data table, rather than defining another data table with a relation to the first data 
table. 
On-Demand Data Table 
On-demand data tables are data tables to which only rows related to marked rows in other, 
related, data table are loaded. Changing the marking means changing the "demand", i.e., that 
more, fewer or other rows are loaded into the data table. On-demand data tables can be used by 
Details Visualizations, and only data from information links can be loaded on demand. 
As a means of helping you keep track of which data tables are related, a stripe of color will be 
added to the left of the filters in the filters panel when more than one data table is available. 
Filters from related data tables (which may affect each other when they are manipulated) all 
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have the same color. Also, the visualizations that use related data tables will show the same 
color in the title bar, if it is displayed. 
Note: You can specify whether or not filtering in a data table should affect what is shown in 
visualizations used by other, related data tables. The default setting is to ignore filtering in 
related data tables. See Filtering in Related Data Tables for more information. 

► To add a new data table: 
1. See How to Insert Multiple Data Tables to the Analysis. 

► To delete a data table: 
1. Select Edit > Data Table Properties. 
2. Click on the data table you wish to remove from the analysis. 
3. Click on Delete. 

► To rename a data table: 
1. Select Edit > Data Table Properties. 
2. Click on the data table you wish to rename. 
3. Click on Rename.... 
4. Type a new data table name and click OK. 

► To reload a data table: 
1. Select Edit > Data Table Properties. 
2. Click on the data table you wish to reload. 
3. Click Refresh Data. 

Comment: The Refresh Data button may be unavailable for some of your data tables. 
For example, this happens if  you have added rows or columns to an embedded data 
table, or if you have frozen some columns in an embedded data table. In that case the 
data table cannot be reloaded. 

► To reload all data tables: 
Note: Reloading all data tables may take a long time if one or more data tables are very big. 

1. Click on the Reload Data button on the toolbar, . 

► To set up an on-demand data table: 
1. Select File > Add On-Demand Data Table.... 
2. Specify an information link to use and click OK. 
3. Define what type of input will control the on-demand loading. 

Comment: For more details see Loading Data on Demand and Details on Define Input. 
4. Click OK. 

► To update a visualization using an on-demand data table 
manually: 
1. When the marking controlling the on-demand data table is changed, a red refresh 

button is shown on the title bar of the visualization. 
Comment: If the title bar has been hidden, right-click on the visualization and select 
Properties. On the General page, select the Show title bar check box. 

2. Click on the refresh button, . 

► To replace a data table: 
1. See Replacing Data. 
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► To recalculate a data table: 
1. When the filtering behind a calculated data table is changed, a red refresh button is 

shown on the title bar of the visualization. 
Comment: If the title bar has been hidden, right-click on the visualization and select 
Properties. On the General page, select the Show title bar check box. 

2. Click on the refresh button, . 

► To save data tables: 
All data tables currently in the analysis will be saved in the document when saving an analysis 
file. See Saving an Analysis File or Saving an Analysis File in the Library for more 
information. 

► To export data from a data table: 
1. See Exporting Data. 

► To prompt for settings each time an analysis file is loaded: 
1. Select Edit > Data Table Properties. 
2. Click Linked to source. 
3. Select Prompt for new settings before loading. 
4. Click OK. 

Comment: You can also change this setting when you save your analysis. Click the 
Edit button in the Save dialog or in the third step of the Save as Library Item wizard. 
This will open the Data Table Properties dialog. 

► To filter a data table: 
1. In the Filters panel, locate the data table header for the data table of interest. 
2. Use the filters to modify what is shown in the visualizations using the specified data 

table (and, optionally, in other related data tables). 

► To use a data table in a visualization: 
1. Click on the data table selector in the legend of the visualization and select the data 

table of interest. 
Comment: See How to Handle Multiple Data Tables in One Analysis for more 
information. 

  

15.4 Examples 
15.4.1 Master-Detail Visualizations 

This is an example of multi-step Master-Detail visualizations. The visualizations in this 
example are based on the same data table and show different levels of detail. However, the 
visualizations could just as well be based on data from different data tables. Marking in one 
visualization defines the data of the next visualization, making it possible to drill down in level 
of detail. 
Note: Related visualizations (as the Master-Detail case) can be placed on different pages in a 
visualization. This means that markings in a visualization that is not visible for the moment can 
affect the analysis that you are looking at. If a visualization is empty, it may be because it is 
based on markings from another visualization. Go to the master visualization and mark an item 
to display information in the details visualization. 
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Note: The Details-on-Demand displays information about the marked rows from the active 
visualization; it could be either the master or the details visualization. 
In this example the master visualization shows Sales per Year. If you mark a year, for example, 
2003, in the master visualization, data will be displayed in the details visualization. This details 
visualization shows Sales per Category (fruit and vegetables) for 2003. 

 
Marking an item in the next visualization, Sales per Category, can also be setup to display an 
even more detailed visualization. Below, another visualization has been created, where marking 
the category "vegetables" in Sales per Category displays a more limited visualization; in this 
case the percentage of sales per type (cucumber, lettuce and tomato) in that category for 2003. 

 
This image shows three different visualizations displaying different aspects of the same data 
table. 
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15.4.2 Independent Data Tables 
This is an example of independent data tables. These two visualizations are placed on the same 
page, but they are not related to each other. The visualizations correspond to separate data 
tables. Marking or filtering in one visualization will not affect the other when they are 
independent. The Details-on-Demand displays information about the marked item in the active 
visualization. Color stripes are used to indicate what visualization, filter and Details-on-Demand 
that are related. 
In this example, the bar chart shows the sum of sales for different types of fruits and vegetables. 
The scatter plot shows the content of fructose and glucose for different types of fruits and 
vegetables. 

 
  

15.4.3 Multiple Related Data Tables 
This is an example of multiple related data tables. The visualizations are based on different data 
tables that are related. Marking items in one visualization will mark the corresponding items in 
the related visualizations. Filtering data in one data table may filter the related data in the other 
data tables. The relation between the data tables is set up in TIBCO Spotfire. Visualizations that 
are related share the same color in the color stripe to the left in the visualization. Filters 
belonging to related data tables also share the same color stripe. 
Note: Related visualizations can be placed on different pages in an analysis. This means that 
markings that are not visible for the moment can affect the analysis that you are looking at. 
In this case, two data tables with information about fruit and vegetables are related. The scatter 
plot shows the amount of glucose and fructose for different types of fruits and vegetables, while 
the bar chart shows the sum of sales for the same types of fruits and vegetables. Marking an 
item in the scatter plot, in this case the one with the highest level of fructose (Apples), will mark 
the Sum(Sales) for Apples in the Bar Chart. 
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15.4.4 Insert Columns from External Data - Example 
By inserting columns or rows from external data, it is possible to combine data from different 
sources into a single data table that can be used in a visualization.   
In this example, a data table with information about the cost and sales for different kinds of 
fruits and vegetables (Table 1) has been joined together with an external data table with 
information about the content of Glucose, Fructose, Maltose and Saccharose (Table 2) per fruit 
and vegetables. In this case, two columns from the external data have been added, Glucose and 
Fructose (Table 3). 

Table 1 

 

Table 2 
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Table 3 
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16 Saving and Exporting 
16.1 Saving 
16.1.1 Save Overview 

When an analysis has been set up (or when you are in the process of creating an analysis), you 
need to determine how to save your document. If the analysis is intended to be used by a larger 
audience you probably want to save it as a library item. Once in the library your colleagues can 
easily access the analysis. When more than one person is going to use the analysis, you always 
need to make sure that any linked data sources are available to all end users. See Preparing 
Analyses for TIBCO Spotfire Web Player for some useful tips. 
If the analysis is to be used by a smaller number of people you could instead save it as a regular 
file. 
If you are working with an analysis in the library and you make some changes that you do not 
want to save in the original file, you can use one of the Save Copy As alternatives instead. 
  

16.1.2 Saving an Analysis File 
You can save your analysis as a DXP file. All visualizations, filter settings and other work you 
have done will be saved in the file so you can continue working with the analysis just as you left 
off. 
Depending on from where you opened the data in the analysis, you may encounter some 
different options when saving an analysis file. These options are described in the procedure 
below. 

► To save an analysis file: 
1. Select File > Save As... > File.... 

Response: Provided that there is some linked data in the analysis the Save dialog is 
displayed, showing the current settings for the data tables in the analysis file. 
Otherwise, go to step 6. 

2. If you want to keep the settings, go to step 5. If you want to change the settings, click 
on the Edit... button. 
Response: The Data Table Properties dialog is displayed. Here you can choose whether 
to embed the data in the analysis or keep it linked to the original sources. 
Comment: "Embedded in analysis" incorporates the data in the analysis file itself. 
"Linked to original data source" keeps one or more data tables in the analysis file 
linked to the data sources. This reduces the file size and allows you to keep 
visualizations and settings even though raw data is updated or changed. 
Comment: If you want all data to be embedded in the analysis, you can also select the 
check box Override these settings and embed all data, and then go to step 5. 

3. If you select linked data, click on the Edit... button if you want to select key columns, 
and then click OK when done. 
Comment: You should select key columns if you want to be able to see the markings 
that were active when saving the file, or if you want any specified tags or bookmarks 
to be able to be reapplied when reopening the analysis file. Make sure to select 
columns that uniquely identify all rows in the data table. 

4. Click OK when you are done configuring the data table properties. 
5. Click OK in the Save dialog. 
6. Specify a file name and a location for the analysis file and click Save. 
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Tip: You can define your preferred settings for each data table in the analysis from the Data 
Table Properties dialog at any time while working on your analysis. This way you will not have 
to define those settings when saving the analysis, which makes the save procedure quicker. 

► To save a copy of an analysis file: 
If you want to save a backup copy of the analysis you are working on, without modifying the 
original file, you can use the Save Copy As option instead. 

1. Select File > Save Copy As... > File.... 
Response: Provided that there is some linked data in the analysis the Save dialog is 
displayed, showing the current settings for the data tables in the analysis file. 
Otherwise, go to step 6. 

2. If you want to keep the settings, go to step 5. If you want to change the settings, click 
on the Edit... button. 
Response: The Data Table Properties dialog is displayed. Here you can choose whether 
to embed the data in the analysis or keep it linked to the original sources. 
Comment: "Embedded in analysis" incorporates the data in the analysis file itself. 
"Linked to original data source" keeps one or more data tables in the analysis file 
linked to the data sources. This reduces the file size and allows you to keep 
visualizations and settings even though raw data is updated or changed. 
Comment: If you want all data to be embedded in the analysis, you can also select the 
check box Override these settings and embed all data, and then go to step 5. 

3. If you select linked data, click on the Edit... button if you want to select key columns, 
and then click OK when done. 
Comment: You should select key columns if you want to be able to see the markings 
that were active when saving the file, or if you want any specified tags or bookmarks 
to be able to be reapplied when reopening the analysis file. Make sure to select 
columns that uniquely identify all rows in the data table. 

4. Click OK when you are done configuring the data table properties. 
5. Click OK in the Save dialog. 
6. Specify a file name and a location for the analysis file and click Save. 

Response: The copy is saved to the specified location. Note that you will continue to 
have the original analysis open and any further changes will be made to that analysis 
and not to your copy. 

16.1.3 Details on Save 
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Option Description 

Settings for data 
tables in analysis 

Lists the save settings for every data table in the analysis. 

Edit... Opens the Data Table Properties dialog where you can change the save 
settings. 
Note that it is particularly important that the save settings are correct 
when you are preparing analyses for other people. See Data Table 
Properties - General for more information. 

Override these 
settings and 
embed all data 

Select this option if you want to embed the data when saving instead of 
using the settings listed in the upper part of the dialog. 

16.1.4 Saving an Analysis File in the Library 
Using the Library, you and your colleagues can collaborate on the same analysis, keeping 
everyone up to date. When publishing your document, your current analysis is stored as a DXP 
file in the Library. Files in the Library can also be opened by your colleagues who run TIBCO 
Spotfire Web Player. If this is the intended use of the file, see the chapter Preparing Analyses 
for TIBCO Spotfire Web Player to be aware of the limitations on the files available to Web 
Player users. 
The Open from Library functionality is not available if you are working offline (without a 
connection to a server). 

► To save an analysis file in the Library: 
1. Select File > Save As... > Library Item.... 

Response: The Save as Library Item dialog is opened. 
Comment: The path in the upper part of the dialog shows your current location in the 
folder structure of the library. 

2. Navigate to the folder where you want to save the analysis file. 
Comment: Double-click on a folder to open it, double-click on the uppermost folder 
with two dots next to it to move up in the folder structure, click on the New Folder 
button to create a new folder to save your analysis file in. 

3. Specify a Name for the analysis file. 
4. Click Next >. 
5. Optionally, type a Description for the analysis file. 
6. Optionally, type one or more Keywords specific to the content of the analysis. 

Comment: Keywords are separated by a semicolon, i.e., if you write "primary 
screening;quality" this will be two keywords, "primary screening" and "quality". 

7. Click Next >. 
Response: The settings for the data tables in the analysis are shown. 

8. If you want to keep the settings, go to step 14. If you want to change the settings, click 
on the Edit... button. 
Response: The Data Table Properties dialog opens. 
Comment: If you want all data to be embedded in the analysis, you can also select the 
check box Override these settings and embed all data, and then go to step 14. An 
Administrator may change the default setting of this check box, or force embedding of 
data when saving to library, using preference settings. This may be desired in order to 
make sure that all data are available to all users of the library. The preference settings 
are reached in the Administration Manager, Preferences tab under Application > 
LibraryPreferences. 
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9. On the General tab, you can choose for every data table in the analysis whether to 
embed the data in the analysis or keep it linked to the original sources. 
Comment: "Embedded in analysis" incorporates the data in the analysis file itself. 
"Linked to original data source" keeps one or more data tables in the analysis file 
linked to the data sources. This reduces the file size and allows you to keep 
visualizations and settings even though raw data is updated or changed. 

10. If you select linked data, click on the Edit... button if you want to select key columns, 
and then click OK when done. 
Comment: You should select key columns if you want to be able to see the markings 
that were active when saving the file, or if you want any specified tags or bookmarks 
to be able to be reapplied when reopening the analysis file. Make sure to select 
columns that uniquely identify all rows in the data table. 
To set up the routines for sharing linked data, click on the Sharing Routines tab. 
For each data table, specify how data should be shared and/or refreshed by clicking the 
appropriate radio button. 
Comment: This step is only available when a TIBCO Spotfire Web Player server has 
access to the Library where you are publishing the analysis. 
Click OK when you are done configuring the data table properties. 

11. Click Finish. 
Response: The document is published and the confirmation dialog for the wizard is 
displayed. 

12. The confirmation dialog includes hyperlinks to the Library folder containing the 
analysis you just published, which you can click on to view the final result. You can 
also click Copy Link to copy a link to the clipboard, or Send Email to launch your 
email program with the links included in the mail. 

13. Click Close. 
Tip: Right-click in the library tree to display a pop-up menu where you can delete or edit the 
properties of previously added files and folders. 
It is also possible to delete and edit files in the library via the Library Administration tool. You 
do not have to be  a member of the Library Administrator group to use the tool. To get access to 
the Library Administration tool the license called TIBCO Spotfire Administrator, as well as the 
license feature Library Administration below it, must be enabled. 

► To save a copy of an analysis in the library: 
If you want to save a backup copy of the analysis you are working on, without modifying the 
original file, you can use the Save Copy As option instead. 

1. Select File > Save Copy As... > Library Item.... 
Response: The Save Copy as Library Item dialog is opened. 
Comment: The path in the upper part of the dialog shows your current location in the 
folder structure of the library. 

2. Navigate to the folder where you want to save the copy of the analysis. 
Comment: Double-click on a folder to open it, double-click on the uppermost folder 
with two dots next to it to move up in the folder structure, click on the New Folder 
button to create a new folder to save your analysis file in. 

3. Specify a Name for the analysis file. 
4. Click Next >. 
5. Optionally, type a Description for the analysis file. 
6. Optionally, type one or more Keywords specific to the content of the analysis. 

Comment: Keywords are separated by a semicolon, i.e., if you write "primary 
screening;quality" this will be two keywords, "primary screening" and "quality". 

7. Click Next >. 
Response: The settings for the data tables in the analysis are shown. 
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8. If you want to keep the settings, go to step 14. If you want to change the settings, click 
on the Edit... button. 
Response: The Data Table Properties dialog opens. 
Comment: If you want all data to be embedded in the analysis, you can also select the 
check box Override these settings and embed all data, and then go to step 14. 

9. On the General tab, you can choose for every data table in the analysis whether to 
embed the data in the analysis or keep it linked to the original sources. 
Comment: "Embedded in analysis" incorporates the data in the analysis file itself. 
"Linked to original data source" keeps one or more data tables in the analysis file 
linked to the data sources. This reduces the file size and allows you to keep 
visualizations and settings even though raw data is updated or changed. 

10. If you select linked data, click on the Edit... button if you want to select key columns, 
and then click OK when done. 
Comment: You should select key columns if you want to be able to see the markings 
that were active when saving the file, or if you want any specified tags or bookmarks 
to be able to be reapplied when reopening the analysis file. Make sure to select 
columns that uniquely identify all rows in the data table. 
To set up the routines for sharing linked data, click on the Sharing Routines tab. 
For each data table, specify how data should be shared and/or refreshed by clicking the 
appropriate radio button. 
Comment: This step is only available when a TIBCO Spotfire Web Player server has 
access to the Library where you are publishing the analysis. 
Click OK when you are done configuring the data table properties. 

11. Click Finish. 
Response: The copy is published and the confirmation dialog for the wizard is 
displayed. Note that you will continue to have the original analysis open and any 
further changes will be made to that analysis and not to your copy. 

12. The confirmation dialog includes hyperlinks to the Library folder containing the 
analysis you just published, which you can click on to view the final result. You can 
also click Copy Link to copy a link to the clipboard, or Send Email to launch your 
email program with the links included in the mail. 

13. Click Close. 

16.1.5 Preparing Analyses for TIBCO Spotfire Web Player 
When an analysis file is saved to the library, it becomes available to use in Spotfire Web Player. 
Spotfire Web Player is a web browser-based version of Spotfire for viewing and exploring 
prepared analyses.   
You can choose to copy the link to the web player analysis from the final step of the Save to 
Library wizard and paste the link, in an email or similar, to share the information with 
colleagues and give access to the analysis. 
Any analysis can be published to the library and opened with Spotfire Web Player, but there are 
a few things to keep in mind that can make things easier for the Spotfire Web Player users. 
First, consider how familiar your target audience is with the visualized data. The familiarity of 
the target audience may affect the instructions required as well as the setup of the analysis. For 
example, you may need to change the visibility of some filters for a certain audience. Second, 
bear in mind that all users of the analysis may not have access to the same data sources. 

► Tips when preparing analyses for TIBCO Spotfire Web Player: 
1. Use the text areas to write instructions about the analysis and how it is set up. For 

instance, if master-detail visualizations are used, try to explain their relationship. 
2. Use informative titles for the visualizations. 
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3. The overview of data will be improved if you hide filters that are not relevant for the 
visualizations in the analysis. For an explanation of how to hide filters, see Showing 
and Hiding Filters. 

4. When using links or buttons in the text area, try to write instructions so that the 
information is helpful, even if the links should happen to become temporarily 
unavailable. 

5. Consider whether all users of the analysis have access to all of the original data 
sources. If not, you may need to save some data tables embedded in the analysis, rather 
than linked to the original data sources. See Permissions for information about how 
permissions are handled in the library. There may also be user authentication 
limitations directly on the data source itself. Talk to your Spotfire Administrator or 
data manager to understand how the permissions for different user groups have been 
set up within your company. 

6. It is not possible to view the 3D Scatter Plot in Spotfire Web Player. Also note that 
some custom visualizations may not be shown. The analysis can still be opened in 
Spotfire Web Player, but the visualizations that are not supported will not be shown. 

7. Consider whether or not Web Player users should be allowed to export data from 
tables. Make the appropriate settings on the Appearance page of the Table Properties, 
Cross Table Properties, Summary Table Properties, and/or Details-on-Demand 
Properties. 

8. Consider whether or not Web Player users should be able to open a personalized view 
of the analysis and/or be allowed to add bookmarks. Open the Document Properties 
dialog to change these settings. 

Design for the intended platform 
If you know that your end users will view an analysis using a particular equipment or with a 
specific browser you can look up the current visualization area size on that device and then 
design your analysis so that it is optimized for that particular screen size. Note that the current 
visualization area size is dependant on what browser and which toolbars and items are shown in 
the browser, so make sure that you are using the same settings when creating the analysis. 
  
Tips when designing for a smaller screen size: 

a. Remove all things that do not fit the small screen size. 
b. Use Tools > Options > Fonts to globally resize the important font categories to fit the 

intended display. 
c. Resize and move around the contents of the analysis. 
d. Remove legends, axis selectors, etc., if they are not needed.  
e. Use the popover mode rather than panels for filters, bookmarks and lists. 

  
If you want to set up an analysis that works both on a desktop computer with a large screen and 
also on a projector you can use bookmarks to switch between the different sizes and layouts. 
The sizes for the projector and the large screen desktop computer can be stored by an 
administrator in the preferences. 

► To use bookmarks for adapting an analysis to different screen 
sizes: 
1. Set up an analysis that works well on your large screen with the intended fixed size 

preset. Configure all text areas to Include configuration in bookmark. 
2. When the document is finished, add a bookmark named something like "Large screen 

desktop computer". 
a. Switch to the fixed size preset for the projector, and make updates to make the analysis 

work on a projector: 
a. Change the size of text areas and fonts. 
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b. Change font sizes for titles, axis labels, etc., using Tools > Options, Fonts page and 
Apply to Document. 
c. Update the layout, remove unnecessary legends, etc. 

3. When the projector version of the analysis is finished, add a bookmark named 
"Projector". 

4. Save the analysis. 
The analysis is now adapted both to a projector and to a large screen desktop computer. 

16.1.6 Links to Analyses in the Library 
Once an analysis has been published to the library, you can reach it or share it using a number 
of different link types. A bookmark URL can be included to guide other people to an interesting 
aspect or starting point in an analysis. See the table below for an overview of the link types 
available. 

Link type Description Retrieve 
where? 

Use 
when or 
where? 

Direct 
TIBCO 
Spotfire 
URL 
  

Opens the analysis in your default version of 
TIBCO Spotfire Professional. 
  
Example: 
tibcospotfire:server:http\:// 
myspotfireserver/:analysis:/ 
Data/My Analysis 

By right-
clicking on 
an analysis in 
the Library 
Administrator 
and Library 
Open/Save 
dialogs. 
  
In the 
Document 
Properties 
dialog. 

Anywhere 
where you 
know the end 
users of the 
link have 
access to 
TIBCO 
Spotfire 
Professional 
and you want 
to open the 
analysis in a 
new instance 
of TIBCO 
Spotfire. 
  

-"- 
(with a 
bookmark) 

Can include a bookmark, if copied from the 
Bookmarks popover. 
  
Example: 
tibcospotfire:server:http\:// 
myspotfireserver/:analysis:/ 
Data/My Analysis:bookmark: 
7c0669f2-9701-44d4-96b3-7 
fefd9e129fa 

From the 
Bookmarks 
popover 
(Web Player 
and 
Professional) 

-"- 

-"- 
(pointing to 
server but 
not analysis) 

Point a TIBCO Spotfire client to a certain 
TIBCO Spotfire server. 
  
Example: 
tibcospotfire:server:http\:// 
myspotfireserver/ 

Manually 
edited. 

You can also 
use this type 
of link to 
point the end 
users to a 
specific 
server 
without 
determining 
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which 
analysis to 
open. 

-"- 
(with pre-
configured 
library 
search) 

Opens TIBCO Spotfire Professional with a pre-
configured library search. 
  
Example: 
tibcospotfire:search:modified 
\:<\'3 days ago\':OrderBy:Modified: 
SortDirection:Descending 

Manually 
edited. 

When you 
know the end 
users of the 
link have 
access to 
TIBCO 
Spotfire 
Professional 
and you want 
to give them 
easy access 
to a number 
of analyses 
or 
information 
links 
selected 
through a 
library 
search. 
(The 
example 
displays all 
analysis files 
and 
information 
links that 
have been 
modified 
within the 
last three 
days.) 
See 
Searching 
the Library 
for more 
information 
about 
available 
search 
expressions. 

-"- 
(with a 
configuration 
block) 

Opens the analysis with a configuration block. 
  
Example: 
tibcospotfire:server:http\:// 
myspotfireserver/:analysis:/Data/ 
My Analysis:configurationBlock:SetFilter 
(columnName=\'User\',values={\'jsmith\'}); 

Manually 
edited. 

See the 
Spotfire 
Technology 
Network for 
information 
about 
configuration 
blocks. 
 

http://stn.spotfire.com/stn/Tasks/CreatingConfigurationBlock.aspx?usterms=configuration+block&uscat=0,1,2,3
http://stn.spotfire.com/stn/Tasks/CreatingConfigurationBlock.aspx?usterms=configuration+block&uscat=0,1,2,3
http://stn.spotfire.com/stn/Tasks/CreatingConfigurationBlock.aspx?usterms=configuration+block&uscat=0,1,2,3
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Server 
Redirect 
Page for 
Unknown 
Clients 

Opens a web page where you can select 
whether to open the analysis in Web Player, in 
TIBCO Spotfire, or to download the analysis. 
  
Example: 
http://myspotfireserver/spotfire/ 
redirect?analysis=/Data/ 
My%20Analysis 

By right-
clicking on 
an analysis in 
the Library 
Administrator 
and Library 
Open/Save 
dialogs. 
  
  

When you do 
not know 
whether the 
end users of 
the link want 
to open the 
analysis in 
Web Player, 
in TIBCO 
Spotfire, or 
to download 
the analysis. 
For example, 
when 
publishing a 
URL in a 
blog post or 
sending an 
email with 
the URL to 
people from 
many 
departments 
that have 
access to 
different 
Spotfire 
solutions. 

Redirect 
Page for 
Unknown 
Clients 

Opens a web page where you can select 
whether to open the analysis with a bookmark 
in Web Player or in TIBCO Spotfire. 
  
Example: 
http://myspotfireserver/spotfire/ 
redirect?analysis=/Data/ 
My%20Analysis&bookmark= 
7c0669f2-9701-44d4-96b3-7 
fefd9e129fa 

From the 
Bookmarks 
popover (in 
TIBCO 
Spotfire 
Professional) 

When the 
intended 
audience 
may have 
access to 
either the 
Web Player 
or TIBCO 
Spotfire and 
you want to 
include a 
bookmark in 
the link. 
For example, 
when 
publishing a 
URL in a 
blog post or 
sending an 
email with 
the URL to 
people from 
many 
departments 
that have 
access to 
different 
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Spotfire 
solutions. 

Web Player 
URL 
  

Opens the analysis in TIBCO Spotfire Web 
Player. 
  
Example: 
http://mywebclient/SpotfireWeb/ 
ViewAnalysis.aspx?file=/Data/ 
My%20Analysis 

By right-
clicking on 
an analysis in 
the Library 
Administrator 
and Library 
Open/Save 
dialogs. 
  
In the 
Document 
Properties 
dialog. 

When you 
want the 
recipients of 
the link to 
open the 
analysis 
directly in 
the Web 
Player. 

-"- 
(with a 
bookmark) 

Can include a bookmark, if copied from the 
Bookmarks popover. 
  
Example: 
http://mywebclient/SpotfireWeb/ 
ViewAnalysis.aspx?file=/Data/ 
My%20Analysis&bookmark= 
a444c142-b411-4130-aee5 
-db36e5bc1ac9 

From the 
Bookmarks 
popover 
(Web Player 
and 
Professional) 

-"- 

-"- 
(with a 
configuration 
block) 

Opens the analysis in the Web Player with a 
configuration block. 
  
Example: 
http://mywebclient/SpotfireWeb/ 
ViewAnalysis.aspx?file=/Data/ 
My%20Analysis&configurationBlock=SetFilter 
(columnName%3D%22User 
%22%2Cvalues%3D%7B%22 
jsmith%22%7D)%3B 

Manually 
edited. 

See the 
Spotfire 
Technology 
Network for 
information 
about 
configuration 
blocks. 

The TIBCO Spotfire protocol handler is registered on all Windows client machines running 
TIBCO Spotfire 3.3 or later, which means that links can be used in emails, web pages, etc., to 
directly open analyses. The default version of TIBCO Spotfire to use when opening 
tibcospotfire links can be set under Tools > Options, Application. 
A tibcospotfire link to another analysis can be added to the text area. When an end user of the 
analysis clicks on the link, the link will be re-written so that the linked analysis will be opened 
in TIBCO Spotfire Professional for persons using that client and in TIBCO Spotfire Web Player 
for others, depending on context . 

http://stn.spotfire.com/stn/Tasks/CreatingConfigurationBlock.aspx?usterms=configuration+block&uscat=0,1,2,3
http://stn.spotfire.com/stn/Tasks/CreatingConfigurationBlock.aspx?usterms=configuration+block&uscat=0,1,2,3
http://stn.spotfire.com/stn/Tasks/CreatingConfigurationBlock.aspx?usterms=configuration+block&uscat=0,1,2,3
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16.1.7 Details on Save to Library 

16.1.7.1 Save as Library Item - Step 1 

 

Option Description 

Library path 
(Upper part of the 
dialog) 

Shows the path from the library root folder down to the folder 
where you are currently located in the library. You can navigate 
upwards in the folder structure by clicking on the name of a folder 
that you want to navigate to. 

Folder contents list 
(Middle part of the 
dialog) 

Lists all the folders and files in the folder you are currently 
located in. 

Name The name of the analysis as it will be displayed in the library. It is 
important that the title is informative with regard to what the 
analysis actually does. 
Note: The name can be 256 characters at most, and the following 
characters are not supported: 
\ / : * ? " < > |  

New Folder... Opens the New Folder dialog where you can specify a new folder. 

Folder Permissions... Opens a dialog where you can change the folder permissions. 
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16.1.7.2 Save as Library Item - Step 2 

 

Option Description 

Name The name of the analysis as it will be displayed in the Library. This is 
the name you provided in the previous step. 

Description An optional description of the functions of the analysis. The 
description could contain detailed information about the analysis 
enabling quick overviews. 

Keywords 
(separated by 
semicolons) 

Keywords specific to the content of the analysis. Keywords are 
separated by a semicolon, i.e., if you write "sales representatives; cost" 
this will be two keywords, "sales representatives" and "cost". 
Keywords are used to enhance organization and search capabilities. 
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16.1.7.3 Save as Library Item - Step 3 

 

Option Description 

Settings for data 
tables in analysis 

Lists the save settings for every data table in the analysis. 
Note: It is particularly important that the save settings are correct when 
you are preparing analyses for other people. If you save an item with 
the data table linked to an original source that is saved locally on your 
computer, it will not be possible for other users to open it from the 
library. To make the item available, select to embed the data. See also 
Preparing Analyses for TIBCO Spotfire Web Player. 

Edit... Opens the Data Table Properties dialog where you can change the save 
settings. 
Note that prompted information links do not display the prompt each 
time the analysis is loaded by default. If you want to display the 
prompt step, then the Prompt for new settings before loading check box 
in the Data Table Properties dialog should be selected. See Data Table 
Properties - General for more information. 

Override these 
settings and 
embed all data 

Select this option if you want to embed all data when saving, instead of 
using the settings listed in the upper part of the dialog. 
Note: An Administrator may change the default setting of this check 
box, or force embedding of data when saving to library, using 
preference settings. This may be desired in order to make sure that all 
data are available to all users of the library. The preference settings are 
reached in the Administration Manager, Preferences tab under 
Application > LibraryPreferences. 
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16.1.7.4 Save as Library Item - Published 

 

Option Description 

Location for the 
file in the Library 

Click on the link to open the Library folder containing your published 
analysis. 

Copy Link Copies the library location link to the clipboard for later use. Using the 
link, the analysis can easily be referenced in email discussions or from 
web pages or portals. 

The Analysis can 
be accessed with 
the TIBCO 
Spotfire Web 
Player from 

Click on the link to open the analysis in TIBCO Spotfire Web Player. 

Copy Link Copies the TIBCO Spotfire Web Player link to the clipboard for later 
use. Using the link, the analysis can easily be referenced in email 
discussions or from web pages or portals. Using the links retrieved 
with Copy Link, analyses can be accessed from any web environment 
using the URL and name supplied. 

Send Email If your default email client is Microsoft Outlook, clicking on this 
button will launch a new email containing the URLs to the analysis and 
other relevant information. 
Note: It may also work with other email clients, but Microsoft Outlook 
is the only supported client. 

Close Closes the notification dialog. 
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16.1.7.5 Details on Edit Properties - General 
This dialog is used to edit the properties for an item in the library. It can be reached by right-
clicking on the item of interest in any view representing the library structure and selecting Edit 
Properties... from the pop-up menu. In the Library Administration tool, it is reached when 
clicking on the Edit... link for the Selected Item. 

 
To edit the properties of an item you must have Browse + Access + Modify permissions to the 
folder it is placed in.  

Option Description 

Name The name of the library item. The following characters are not 
accepted in titles: 
\ / : * ? " < > | $ & + = @ # % ; , { [ ] } ^ ' ~ ´ 

Description A description of the library item. 

Keywords Allows you to add keywords which can be used for finding the item in 
the library. Keywords are separated by a semicolon. 
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16.1.7.6 Details on New Folder 
This dialog is used to create a new folder in the library. It can be reached whenever you attempt 
to save something in the Library by clicking New Folder. 

 
To create a new folder you must have Browse + Access + Modify permissions in the folder 
where you want the new folder to appear. The new folder will by default inherit the permissions 
from its parent folder. 
When you create a new folder you can specify: 

• Name 
• Description 
• Keywords 

The following characters are not accepted in titles: 
\ / : * ? " < > | $ & + = @ # % ; , { [ ] } ^ ' ~ ´ 
Keywords are separated by a semicolon. 

16.2 Export Image 
16.2.1 Exporting an Image 

You can export any visualization as an image and save it to disk. 

► To export a visualization as an image: 
1. Make sure the visualization you want to export is active. 
2. Select File > Export > Image.... 
3. Response: The Export Image dialog appears. 
4. Specify a file name and a location for the file. 
5. Select the image format you want. 
6. Click Save. 

Tip: You can also select Edit > Copy Special > Visualization Image... to copy the active 
visualization. 
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16.3 Export Data 
16.3.1 Exporting Data 

You can export data from TIBCO Spotfire and save as a text file, a TIBCO Spotfire Binary 
Data Format file (see below) or a Microsoft Excel file. The text file can be either a regular tab 
separated text file, or a Spotfire Text Data Format file. The Excel file can be either an XLS file 
or an XLSX file. 
Note: Data from a visualization can only be exported to an Excel file if the visualization is a 
table. 

► To export data from a visualization: 
1. Select File > Export > Data.... 
2. Click the Visualization radio button. 
3. Select the visualization to base the new data file on from the drop-down list. 

Comment: You can export all or marked data from a table, cross table or a summary 
table, or the marked data from any other visualization. You can also select to export 
the data currently shown in the Details-on-Demand. 

4. If both options are available for the selected visualization, select whether to export: 
Data for all items - the rows remaining after the current filtering. 
Data for marked items - the currently marked rows. Note that all marked rows will be 
exported, even if they are filtered out. 
Comment: The Data for all items option is only available if you have selected a table, a 
cross table, a summary table, or the Details-on-Demand in the Visualization drop-
down list. Data for marked items is only available if there are marked items in the 
analysis. 

5. Click OK. 
6. Specify a file name and a location for the file in the Save As dialog. 
7. Click Save. 

Comment: You can export the data to a text file, to an Excel file, to a TIBCO Spotfire 
Text Data Format file (*.stdf) or to a TIBCO Spotfire Binary Data Format file (*.sbdf). 
See below for more information. 

► To export data from a data table: 
1. Select File > Export > Data.... 
2. Click the Data table radio button. 
3. In the drop-down list, select which data table to export data from. 
4. Select what data to export: 

All rows - the entire data table regardless of all filtering. 
Filtered rows - the rows remaining after the current filtering by the specified filtering 
scheme. 
Marked rows - the rows marked in the visualizations using the specified marking. 
Note that all marked rows will be exported, even if they are filtered out. 

5. Click OK. 
6. Specify a file name and a location for the data file in the Save As dialog. 
7. Click Save. 

Comment: You can export the data to a text file, to an Excel file, to a TIBCO Spotfire 
Text Data Format file (*.stdf) or to a TIBCO Spotfire Binary Data Format file (*.sbdf). 
See below for more information. 

The TIBCO Spotfire Binary Data Format stores the data and metadata from your analysis in 
binary form. It can be used to greatly increase the performance when working with linked data 
in TIBCO Spotfire. 
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The TIBCO Spotfire Text Data Format also includes metadata. For example, the data types of 
the columns are saved, so you do not need to specify any import settings when opening files of 
this data format in TIBCO Spotfire. If you select the TIBCO Spotfire Text Data Format (*.txt) 
you will be able to open the file in older versions of TIBCO Spotfire (before 3.1) and in TIBCO 
Spotfire DecisionSite, but you will not get all functionality of the Spotfire Text Data Format. 

16.3.2 Details on Export Data 
► To reach the Export Data dialog: 

1. Select File > Export > Data.... 

 

Option Description 

Export data from Allows you to select whether to export data based on a visualization or 
on a data table. 

   Visualization 
    

Select this option to export data based on one of the visualizations in 
the active page, including the Details-on-Demand (if visible). 
Note: Data from a visualization can only be exported to an Excel file 
if the visualization is a table. 
You can export the data to a text file, to an Excel file, to a TIBCO 
Spotfire Text Data Format file (*.stdf) or to a TIBCO Spotfire Binary 
Data Format file (*.sbdf). See below for more information. 

      Data for all 
items 
      

Only available for tables, cross tables and summary tables. Exports all 
data in the selected visualization, the way it looks right now. This 
means that only the data remaining after the current filtering will be 
exported. 

      Data for 
marked items 
      

Exports data for the marked items in the selected visualization. Note 
that all marked rows will be exported, even if they are filtered out. 
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   Data table 
   

Select this option to export data based on one of the data tables in the 
document. 
You can export the data to a text file, to an Excel file, to a TIBCO 
Spotfire Text Data Format file (*.stdf) or to a TIBCO Spotfire Binary 
Data Format file (*.sbdf). See below for more information. 

      All rows 
      

Exports all rows available in the entire data table, regardless of 
filtering. 

      Filtered rows 
      

Exports the rows remaining after the current filtering (using the 
filtering scheme on the active page) only. 

      Marked rows, 
defined by 
      

Exports the rows marked in the visualizations (using the specified 
marking) only, regardless of filtering. 

The TIBCO Spotfire Binary Data Format stores the data and metadata from your analysis in 
binary form. It can be used to greatly increase the performance when working with linked data 
in TIBCO Spotfire. 
The TIBCO Spotfire Text Data Format also includes metadata. For example, the data types of 
the columns are saved, so you do not need to specify any import settings when opening files of 
this data format in TIBCO Spotfire. If you select the TIBCO Spotfire Text Data Format (*.txt) 
you will be able to open the file in older versions of TIBCO Spotfire (before 3.1) and in TIBCO 
Spotfire DecisionSite, but you will not get all functionality of the Spotfire Text Data Format. 

16.4 Export to PowerPoint 
16.4.1 Exporting to Microsoft PowerPoint 

In order to export to PowerPoint, you need to have Microsoft® PowerPoint® installed on your 
computer. 

► To export to PowerPoint: 
1. Select File > Export > To Microsoft® PowerPoint®.... 

Response: The Export to Microsoft® PowerPoint® dialog is opened. 
2. Adjust to your preferred settings in the dialog. 
3. Click Export. 

Response: If you chose to export to a new presentation, PowerPoint is started and the 
selected visualizations are shown in a new presentation. If you chose to export to an 
open presentation, the selected visualizations are appended as new slides in an open 
presentation. 

Comment: See Details on Export to Microsoft PowerPoint for more information about the 
various export options. 

16.4.2 Details on Export to Microsoft PowerPoint 
► To reach the Export to Microsoft® PowerPoint® dialog: 

1. Select File > Export > To Microsoft® PowerPoint®.... 
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Option Description 

Export what Defines which parts of the analysis to export. 

   Active visualization 
    

Exports the active visualization in the analysis to a single slide in 
PowerPoint. 
Note: Tables and trellised visualizations may be extended to more 
than one slide. 

   Active page 
    

Exports all the visualizations on the active page in the analysis to 
a single slide in PowerPoint. 

   Active page (new 
page for each 
visualization) 
    

Exports all the visualizations on the active page in the analysis to 
one or more slides in PowerPoint. Each visualization on the active 
page will be exported to a new slide in the PowerPoint 
presentation. 
Note: Tables and trellised visualizations may be extended to more 
than one slide. 

   All pages 
  

Exports all the visualizations on all the pages in the analysis. Each 
page will be exported to a new slide in the PowerPoint 
presentation. 

   All pages (new page 
for each visualization) 
   

Exports all the visualizations on all the pages in the analysis. Each 
visualization in the analysis will be exported to a new slide in the 
PowerPoint presentation. 
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Note: Tables and trellised visualizations may be extended to more 
than one slide. 

   Details-on-Demand 
   

Exports the Details-on-Demand to one or more slides in 
PowerPoint. Select the check box Trellis panels and table rows not 
visible on screen if you want to export all the data in Details-on-
Demand, including data that is not visible. 

   Use entire page 
  

Select this check box to fill the entire space of the PowerPoint 
slide. The visualizations or pages that you export will be redrawn 
to fit the slide orientation. This means that the proportions will not 
be preserved, and some content may be altered. 
Clear this check box if you want to export the content that is 
currently visible in the visualizations or pages in the analysis. The 
pages and/or visualizations will keep the same proportions as in 
the analysis, but will be resized to fit the PowerPoint slide 
orientation. The exported parts may become more detailed, but 
never lose any information that is visible in the analysis. 

Include   

   Visualization title 
   

Select whether or not you want the visualization titles to be 
included in the export. 

   Description 
   

Select whether or not you want visualization descriptions to be 
included in the export. The description will only be visible for 
visualizations where a description has been entered. If the 
description is visible in the legend, it will automatically be 
included in the export as a part of the legend. 
Note: If a description is long, it may be cut off if you include it as 
a part of the legend. 

   Filter settings 
   

Select whether or not you want the filter settings to be included in 
the export as textual information. Only the values of the modified 
filters will be listed. 

   Page title 
   

Select whether or not you want the page titles to be included in the 
export. 

   Trellis panels and 
table rows not visible 
on screen 
    

Select whether or not to include non-visible data in trellis panels 
and tables in the export. If a table contains too many rows to fit on 
one slide, it will be extended to the following slides. Similarly, a 
trellised visualization with many panels will be extended to the 
following slides. 
Note: Not available if you select to export Active page or All 
pages. You must select an option where each visualization is 
exported to a new slide. 

   Page footer 
   

Select the check box to enable the text field where you can enter a 
text that you want to include as a footer on each slide in the 
exported PowerPoint presentation. 

Options   

   Export to   

      A new presentation Exports the selected option to a new PowerPoint presentation. 
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      An open 
presentation 
   

Appends new slides to an open PowerPoint presentation. If 
several presentations are open, select one from the drop-down list. 

   Export as editable 
image 
  

Select this check box to export the images as enhanced meta files, 
which can be edited in Microsoft PowerPoint. If the check box is 
cleared, the images are exported in PNG format. 

16.5 Export to PDF 
16.5.1 Exporting to PDF 

In order to view an exported PDF document, you need to have a PDF reader installed on your 
computer, 

► To export to PDF: 
1. Select File > Export > To PDF.... 

Response: The Export to PDF dialog is opened. 
2. Adjust to your preferred settings in the dialog. 
3. Click Export. 
4. Specify a file name and where you want to save the PDF document. 
5. Click Save. 

Response: If you selected the check box Open in PDF reader after export, the 
resulting PDF document will be opened in your default PDF reader. 

Comment: See Details on Export to PDF for more information about the various export options. 

16.5.2 Details on Export to PDF 
► To reach the Export to PDF dialog: 

1. Select File > Export > To PDF.... 
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Option Description 

Export what Defines which parts of the analysis to export. 

   Active visualization 
    

Exports the active visualization in the analysis to a single page in 
a PDF document. 
Note: Tables and trellised visualizations may be extended to more 
than one page. 

   Active page 
  

Exports all the visualizations on the active page in the analysis to 
a single page in a PDF document. 

   Active page (new 
page for each 
visualization) 
  

Exports all the visualizations on the active page in the analysis to 
one or more pages in a PDF document. Each visualization on the 
active page will be exported to a new page in the PDF document. 
Note: Tables and trellised visualizations may be extended to more 
than one page. 

   All pages 
   (All pages) 

Exports all the visualizations on all the pages in the analysis. Each 
page will be exported to a new page in the PDF document. 

   All pages (new page 
for each visualization) 
   

Exports all the visualizations on all the pages in the analysis. Each 
visualization in the analysis will be exported to a new page in the 
PDF document. 
Note: Tables and trellised visualizations may be extended to more 
than one page. 

   Details-on-Demand Exports the Details-on-Demand to one or more pages in a PDF 
document. Select the check box Trellis panels and table rows not 
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   visible on screen if you want to export all the data in Details-on-
Demand, including data that is not visible. 

   Use entire page Select this check box to fill the entire space of the PDF page. The 
visualizations or pages that you export will be redrawn to fit the 
selected page layout. This means that the proportions will not be 
preserved, and some content may be altered. 
Clear this check box if you want to export the content that is 
currently visible in the visualizations or pages in the analysis. The 
pages and/or visualizations will keep the same proportions as in 
the analysis, but will be resized to fit the selected page layout. The 
exported parts may become more detailed, but never lose any 
information that is visible in the analysis. 

Include   

   Visualization title 
   

Select whether or not you want the visualization titles to be 
included in the export. 

   Description 
  

Select whether or not you want visualization descriptions to be 
included in the export. The description will only be visible for 
visualizations where a description has been entered. If the 
description is visible in the legend, it will automatically be 
included in the export as a part of the legend. 
Note: A long description may be cut off when you export to PDF. 

   Filter settings 
   

Select whether or not you want the filter settings to be included in 
the export as textual information. Only the values of the modified 
filters will be listed. 

   Page title 
   

Select whether or not you want the page titles to be included in the 
export. 

   Trellis panels and 
table rows not visible 
on screen 
  

Select whether or not to include non-visible data in trellis panels 
and tables in the export. If a table contains too many rows to fit on 
one page in the PDF document, it will be extended to the 
following pages. Similarly, a trellised visualization with many 
panels will be extended to the following pages. 
Note: Not available if you select to export Active page or All 
pages. You must select an option where each visualization is 
exported to a new page. 

   Page footer 
   

Select the check box to enable the text field where you can enter a 
text that you want to include as a footer on each page in the 
exported PDF document. 

Options   

   Page layout 
   

Defines the size and orientation of the pages in the resulting PDF 
document. The following alternatives are available: A4 Portrait, 
A4 Landscape, US Letter Portrait, and US Letter Landscape. 

   Open in PDF reader 
after export 
  

Select whether or not to view the resulting PDF document in a 
PDF reader after the export is carried out. 
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16.6 Export to HTML 
16.6.1 Exporting to HTML 

Export to HTML can be seen as an alternative to printing a paper report of your analysis. By 
exporting to HTML instead of printing, the report can be viewed in a web browser. The settings 
for export to HTML are similar to the print settings. For example, you can choose paper size 
and orientation. Exporting to HTML always results in one single HTML document. For 
example, if you export all the pages in an analysis, the result will be one single HTML 
document where the pages from the analysis are placed after each other vertically. To learn 
more about the various export options, see Details on Export to HTML. 

► To export to HTML: 
1. Select File > Export > To HTML.... 
2. Response: The Export to HTML dialog is opened. 
3. Adjust to your preferred settings in the dialog. 
4. Click Export. 
5. Specify a file name and where you want to save the files. 
6. Click Save. 

Response: If you selected the check box Open in web browser after export, the 
resulting HTML document will be opened in your default web browser. 

16.6.2 Details on Export to HTML 
► To reach the Export to HTML dialog: 

1. Select File > Export > To HTML.... 
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Option Description 

Export what Defines which parts of the analysis to export. 

   Active visualization 
    

Exports the active visualization in the analysis. 

   Active page 
    

Choose this option if you want to export only the active page in 
the analysis. 

   Active page (new 
page for each 
visualization) 
    

Exports all the visualizations on the active page in the analysis. 
The visualizations on the active page will be placed after each 
other vertically in the HTML document. 

   All pages Exports all the visualizations on all the pages in the analysis. The 
pages in the analysis will be placed after each other vertically in 
the HTML document. 

   All pages (new page 
for each visualization) 
   

Exports all the visualizations on all the pages in the analysis. The 
visualizations in the analysis will be placed after each other 
vertically in the HTML document. 

   Details-on-Demand 
   

Exports the Details-on-Demand. Select the check box Trellis 
panels and table rows not visible on screen if you want to export 
all the data in Details-on-Demand, including data that is not 
visible. 

   Use entire page 
   

Select this check box to fill the entire space of the target page. The 
visualizations or pages that you export will be redrawn to fit the 
selected page layout. This means that the proportions will not be 
preserved, and some content may be altered. 
Clear this check box if you want to export exactly what is 
currently visible in the visualizations or pages in the analysis. The 
pages and/or visualizations will keep the same proportions as in 
the analysis, but will possibly be resized to fit the selected page 
layout. 

Include   

   Visualization title 
    

Select whether or not you want the visualization titles to be 
included in the export. 

   Description 
  

Select whether or not you want visualization descriptions to be 
included in the export. The description will only be visible for 
visualizations where a description has been entered. If the 
description is visible in the legend, it will automatically be 
included in the export as a part of the legend. 
Note: A long description may be cut off when you export to 
HTML. 

   Filter settings 
    

Select whether or not you want the filter settings to be included in 
the export as textual information. Only the values of the modified 
filters will be listed. 

   Page title Select whether or not you want the page titles to be included in the 
export. 
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   Trellis panels and 
table rows not visible 
on screen 

Select whether or not to include non-visible data in trellis panels 
and tables in the export. If a table contains too many rows to fit on 
one page, it will be extended to the next page. Similarly, a 
trellised visualization with many panels will be extended to the 
following pages. 
Note: A page in this case refers to the selection you make in the 
Page layout drop-down list. 
Note: Not available if you select to export Active page or All 
pages. You must select an option where each visualization is 
exported to a new page. 

   Page footer Select the check box to enable the text field where you can enter a 
text that you want to include as a footer in the export. 

Options   

   Page layout Defines the size and orientation of the pages in the resulting 
HTML document. The following alternatives are available: A4 
Portrait, A4 Landscape, US Letter Portrait, and US Letter 
Landscape. 

   Open in web browser 
after export 

Select whether or not to view the resulting HTML document in a 
web browser after the export is carried out. 

16.7 Printing 
16.7.1 Printing 

You can print a single visualization, an entire page, all pages in an analysis, or the Details-on-
Demand. For more information about the various print options, see Details on Print Layout 
Options. 

► To print visualizations and pages in an analysis: 
1. Select File > Print.... 

Response: The Print Layout Options dialog is opened. 
2. Select what to print and what to include in the print-out. 
3. Click Page Setup to open a dialog where you can define the size and orientation of the 

pages in the resulting print-out. 
4. Click OK to close the Page Setup dialog when done. 
5. Optionally, click on Preview to see what the print-out will look like. 
6. Close the Print preview window. 
7. Click Print. 

Response: The Windows standard print dialog is opened. 
8. Adjust to your preferred settings in the dialog. 
9. Click Print. 

Response: The selected visualizations or pages are printed according to the specified 
settings. 

16.7.2 Details on Print Layout Options 
► To reach the Print Layout Options dialog: 

1. Select File > Print.... 
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Option Description 

Print what Defines which parts of the analysis to print. 

   Active 
visualization 

Prints the active visualization in the analysis to a single page. 
Note: Tables and trellised visualizations may be extended to more 
than one page each. 

   Active page Prints all the visualizations on the active page in the analysis to a 
single page. 

   Active page (new 
page for each 
visualization) 

Prints all the visualizations on the active page in the analysis to one or 
more pages. Each visualization on the active analysis page will be 
printed to a new page. 
Note: Tables and trellised visualizations may be extended to more 
than one page. 

   All pages 
    

Prints all the visualizations on all the pages in the analysis. Each 
analysis page will be printed to a new page. 

   All pages (new 
page for each 
visualization) 
   

Prints all the visualizations on all the pages in the analysis. Each 
visualization in the analysis will be printed to a new page. 
Note: Tables and trellised visualizations may be extended to more 
than one page. 

   Details-on-
Demand 

Prints the Details-on-Demand to one or more pages. Select the check 
box Trellis panels and table rows not visible on screen if you want to 
print all the data in Details-on-Demand, including data that is not 
visible. 

   Use entire page Select this check box to fill the entire space of the printed page. The 
visualizations or pages that you print will be redrawn to fit the selected 
page layout. This means that the proportions will not be preserved, and 
some content may be altered. 
Clear this check box if you want to print the content that is currently 
visible in the visualizations or pages in the analysis. The pages and/or 
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visualizations will keep the same proportions as in the analysis, but 
will be resized to fit the selected page layout. The printed parts may 
become more detailed, but never lose any information that is visible in 
the analysis. 

Include   

   Visualization title 
  

Select whether or not you want the visualization titles to be included in 
the print-out. 

   Description Select whether or not you want visualization descriptions to be 
included in the print-out. The description will only be visible for 
visualizations where a description has been entered. If the description 
is visible in the legend, it will automatically be included in the print-
out as a part of the legend. 
Note: A long description may be cut off when you print. 

   Filter settings Select whether or not you want the filter settings to be included in the 
print-out as textual information. Only the values of the modified filters 
will be listed. 

   Page title 
  

Select whether or not you want the page titles to be included in the 
print-out. 

   Trellis panels 
and table rows not 
visible on screen 

Select whether or not to include non-visible data in trellis panels and 
tables in the print-out. If a table contains too many rows to fit on one 
printed page, it will be extended to the following pages. Similarly, a 
trellised visualization with many panels will be extended to the 
following pages. 
Note: This option is not available if you select to print Active page or 
All pages. You must select an option where each visualization is 
printed to a new page. 

   Page footer Select the check box to enable the text field where you can enter a text 
that you want to include as a footer on each page in the resulting print-
out. 

Page Setup Opens a dialog where you can define the size and orientation of the 
pages in the resulting print-out. 

Preview Click this button to see a preview of the print-out. 

Print Click this button to view the Windows standard print dialog and select 
printer, before starting to print. 
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17 Appendix 
17.1 How to Contact Support 

If you have any questions about a TIBCO Spotfire® product, please do the following: 
• Use the built-in help function. 
• Consult the README files which are included with the product. 
• Visit the Spotfire support website, http://spotfire.tibco.com/support, where you can 

send questions to our support department. 
• On the same website, you can also get personal contact from TIBCO Spotfire Support. 

TIBCO Spotfire offers a variety of support agreements. Contact TIBCO Spotfire for more 
information about support, training, consulting agreements, and our Product Subscription 
Programs. 
  

17.2 Details on Support Diagnostics 
This dialog contains information that may be useful in contact with TIBCO Spotfire customer 
support, as well as possibilities for specifying client side logging and error reporting. 

► To reach the Support Diagnostics and Logging dialog: 
Select Help > Support Diagnostics and Logging. 
  

Product File Information Tab 
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Option Description 

Product File 
Information 

Displays detailed information about the versions of various files and 
assemblies. 

Copy Info Copies all information available in the Support Diagnostics dialog to 
the clipboard. This is often requested if you are in contact with 
Spotfire Support. 

System Info Opens the Microsoft System Information dialog, displaying additional 
information. 

Diagnostic Information Tab 

 

Option Description 

Application 
Information 

Lists the version of TIBCO Spotfire and DirectX installed on your 
computer as well as information about whether or not hardware 
acceleration is enabled. 

System 
Information 

Lists the name and version of your operative system, as well as the 
.NET version on your computer. 

Spotfire Server 
Information 

Lists the name and version of the operating system on the TIBCO 
Spotfire Server, together with other information about the server  you 
are connected to. 

TIBCO Spotfire 
Statistics Services 
for S-PLUS 

Lists information about TIBCO Spotfire Statistics Services and the 
currently used S-PLUS engine. 
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TIBCO Spotfire 
Statistics Services 
for R 

Lists information about TIBCO Spotfire Statistics Services and the 
currently used R engine. 

Copy Info Copies all information available in the Support Diagnostics dialog to 
the clipboard. This is often requested if you are in contact with 
Spotfire Support. 

System Info Opens the Microsoft System Information dialog, displaying additional 
information. 

Logging 
The logging tab settings are not available if you have created a custom log4net.config file, see 
Make this the default log level for future sessions below for more information. 

 

Option Description 

Log level Allows you to specify the log level. An increased log level may be 
useful when communicating with TIBCO Spotfire Support, while 
trying to troubleshoot TIBCO Spotfire. 

   None This is the default log level if nothing else is specified. No information 
is logged. 

   DEBUG Used to log detailed information and events when debugging the 
application. This is the log level that collects the most information. 

   INFO Used to log information regarding the progress of the application, 
including all potentially harmful situations and errors. 
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   WARN Used to discover all kinds of potentially harmful situations. 

   ERROR Used when tracking fatal and non-fatal error events. 

   FATAL Used when tracking severe error events only. 

Make this the 
default log level 
for future sessions 

Select the check box to make Spotfire remember the selected log level 
from session to session. If the check box is selected your current log 
settings will be saved in a log4net.config file. If the check box is 
cleared, then the generated config file will be deleted. The automated 
logging settings will not be available if you already have a custom 
log4net.config file in the TIBCO Spotfire AppData directory. 

Log file Shows the path to the log file. Click on the link to open the log file 
directly. 

Open Folder Opens Windows Explorer to the folder containing the log file. 

Display detailed 
error messages 
(restart required 
to take effect) 

Allows detailed error messages to be displayed. For the setting to take 
effect you need to restart your computer. 

System Info Opens the Microsoft System Information dialog, displaying additional 
information. 
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18 Glossary 
  

3D Scatter Plot 
A visualization that represents quantitative information as a point along three axes. Used to 
explore relationships. 
  

Analysis File 
The file type used for analysis files created with TIBCO Spotfire. Can be saved to disk and to 
the Library. Defines what data to include and how to present it. Can include linked or embedded 
data based on user settings when saving the file. Includes one or more pages. There can only be 
one analysis file open at a time, but it is possible to run several instances of TIBCO Spotfire 
simultaneously, and one analysis file can also contain several data tables. See also DXP File. 
  

Axis 
A line that provides a reference from which coordinates in a visualization are measured; it 
orients the visualizations and provides a frame around it. Each axis is associated with at least 
one scale. 
  

Axis Selector 
A control used to change what will be shown on each axis in the visualization. The axis selector 
is what tells you which column is assigned to the axis. See also Column Selectors. 
  

Bar 
A vertical or horizontal rectangle whose height represents a numerical value. 
  

Bar Chart 
A visualization that represents quantitative information by means of a series of vertical or 
horizontal rectangles known as bars. 
  

Bar Labels 
Words or numbers used to identify and describe a bar and data associated with it. 
  

Bar Segment 
A section of a bar that represents a subset of data that the whole bar is made up of. 
  

Bar Segment Labels 
Words or numbers used to identify and describe a bar segment and data associated with it. 
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Binning 
A way to create a categorical column from a column with continuous data. Binning is used to 
create a new column where the values of a specified column are grouped into different bins 
using a binning method. 
  

Bookmark 
A Bookmark is a snapshot of the state of an analysis, which can be applied at any time, 
allowing you to return to a previously created view of the data. 
  

Box Plot 
A visualization used for examining key statistical properties of a variable. Measures, such as 
median, mean and quartiles are displayed using boxes, whiskers and other symbols. 
  

Calculated Column 
A column that has been created from different expressions where calculations on other columns 
could be included. 
  

Calculated Value 
A dynamic item that can be included in a graphical table or in a text area. It displays the result 
of an aggregated expression. 
  

Categorical Axis 
An axis that is associated with a categorical scale. 
  

Category Axis 
The category axis is the horizontal axis in a bar chart where the bars are displayed vertically. 
When bars are displayed horizontally, the category axis is the vertical axis. 
  

Categorical Scale 
A scale on which the values have interruptions, such as values representing names, places, 
things or events. 
  

Cell 
A box or other unit on a spreadsheet or a table at the intersection of a column and a row. 
  

Check Box Filter 
A Filter used to filter out rows based on whether or not a column value is a member of a set of 
values. 
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Collaboration Panel 
A tool that can be used to view web pages in Spotfire. For instance, a web based collaboration 
tool such as tibbr®. 
  

Color Mode 
The way colors in a color scheme are assigned to the values in the data. There are five color 
modes in Spotfire: Fixed, Categorical, Gradient, Segments, and Unique Values. 
  

Color Palette 
A group of default colors you could choose from when changing a color in a color scheme. 
  

Color Scheme 
A set of colors and a definition of how they are applied to values. The definition includes 
whether the scheme is categorical or continuous, and whether colors are simply applied by 
index or by specific values. 
  

Color Scheme Grouping 
A color scheme grouping works as a container for one or more columns or axis values on which 
you want to apply the same color scheme when working with coloring in tables, cross tables, 
and heat maps. 
  

Column 
A vertical list of values in a data table. 
  

Column from Marked 
Column from marked is a way to make a visualization axis dependent on the cell value of a 
marked row of a data table related to, or unrelated to, the data table used by the visualization. 
  

Column Name 
The name of a column as displayed in the user interface. It is a normalized, trimmed, and 
unique text string. It is initially set to a tidied form of the external name, but it may be modified 
through a Rename Column operation. 
  

(Column Names) 
When more than one column is used to define the values on an axis in a visualization (for 
example, on the value axis in a bar chart), the option (Column Names) becomes available for 
selection on other axes, in the Color by column selector, in the trellising column selectors, etc. 
This option will treat the column names of the selected value columns as separate categories, so 
that if Sales and Cost are selected on the value axis, (Column Names) can be used to apply 
different colors on bars or bar segments showing Sales and Cost. 
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Column Selector 
A control used to change the column or hierarchy used to define a certain property (axis 
column, color, size, etc.) in a visualization. Column selectors can be dragged and dropped to 
change the order of dynamic hierarchies, or, to apply or remove columns from a specific 
property using drop targets in the visualizations. 
  

Combination Chart 
A visualization that combines the features of the bar chart and the line chart. It represents 
quantitative information by means of a number of bars and/or lines. 
  

Comparison Circles 
Circles in the box plot used to show whether or not the mean values for various categories are 
significantly different from each other. 
  

Continuous Axis 
An axis that is associated with a continuous scale. 
  

Continuous Scale 
A scale on which there are no interruptions between values, for example if the values are real 
numbers. 
  

Cover Page 
The cover page is the first page in an analysis. It normally contains information about the 
analysis and the person who created the analysis. If desired, a cover page can automatically be 
added when creating new analyses. 
  

Cross Table 
A cross table is a two-way table consisting of rows and columns. It is typically used to 
determine whether there is a relation between the row variable and the column variable. Each 
row and column can be summarized to a grand total. If the vertical axis is a hierarchy, subtotals 
can be displayed in the columns of the cross table. 
  

Curve Fit 
Curve fit or regression analysis allows you to summarize a collection of sample data points by 
fitting them to a model that will describe the data and display a curve or a line on top of a 
visualization. There are several different models available in Spotfire. 
  

Custom Expression 
The column selectors can, in addition to specifying one or more columns to use on an axis or to 
define a property, also be set to use a custom expression. This means that a dynamic calculation 
can be performed using more or less complex expressions, involving one or more columns, 
aggregation measures, or mathematical expressions. When a custom expression is used on an 
axis, the values on that axis are dynamically recalculated using filtered rows only. To create a 
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new column which is always based on the values of all rows, you should instead use the Insert 
Calculated Column tool. 
  

Data Relationships 
The Data Relationships tool is used for investigating the relationships between different column 
pairs, using comparison methods such as Linear regression, Spearman R, Anova, Kruskal-
Wallis or Chi-square. 
  

Data Source 
A handle to an external data source, such as a file or information link. A data source produces a 
single table of data. 
  

Data Table 
A data table in TIBCO Spotfire is defined as either data loaded from an external source, or new 
data created within the application. It has one or more columns and zero or more rows. A 
visualization is based on a single data table. 
Data tables loaded from an external source can be linked or embedded. Linked data tables can 
be loaded completely into the application, but if the source is an information link they can also 
be configured to load data on demand only. 
Data tables can be related to each other, using primary and/or foreign keys (key columns), but 
they can also be unrelated. 
  

Dendrogram 
A dendrogram is a branching diagram which represents a hierarchy of categories based on the 
degree of similarity or number of shared characteristics. 
  

Details-on-Demand 
The concept of expanding a small set of items to reveal more data behind it.   
  

Details Visualization 
A visualization where the data is limited by one or more markings. 
  

Drop Targets 
Specifically, icons in the middle of a visualization onto which filters or column selectors can be 
dropped in order to define a specific property. 
  

DXP File 
DXP is the file extension for an Analysis File. See Analysis File. 
  

Dynamic Items 
Small visualizations that can be included in a graphical table or in a text area. For example, 
sparklines, calculated values and icons. 
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Empty Values 
Empty values, or null values, are values that are missing in your data table. 
  

Error Bars 
Used in bar charts, line charts and/or scatter plots to indicate the estimated error in a 
measurement. 
  

Escape characters 
Since certain characters have a special meaning in the Spotfire expression language, you need to 
perform some actions if you are going to use those characters for other purposes, such as 
including them in column names. 
An escape character is a special character used to inform the expression language that the 
following character in a character sequence should be seen as a standard character rather than as 
an item performing its special purpose. 
  

External Column ID 
A GUID string, retrieved from an information link. May or may not be present, and may or may 
not be well-formed. 
  

External Column Name 
The original column name, exactly as it came from the data source. It is a non-null, but possibly 
empty text string. It is not trimmed or normalized, and duplicates may exist among the columns 
of a data view. 
  

Filter 
Used to reduce the amount of data to work on in TIBCO Spotfire. The same as Query Devices 
in TIBCO Spotfire DecisionSite. Filters can be either column filters, directly related to a 
column, or hierarchy filters (tree filters) which represent a hierarchy. Filters can be grouped into 
folders in the Filters panel. 
  

Filtering Scheme 
A filtering scheme is a data selection that points out what data shall be filtered (visible). Each 
analysis can hold several filtering schemes. What filtering scheme to use can be specified 
separately for each page and/or each visualization. Each filtering scheme can be used by several 
pages and visualizations. 
  

Filtered Out Rows 
The rows that have been removed after one or more filtering operations. 
  

Filtered Rows 
The rows that remain after one or more filtering operations. 
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Filters Panel 
The area where filters are shown. Adjusting the filters modifies the filtering that is used by the 
page. 
The filters panel visibility is set per page, just like the visibility of the individual filters. When 
the filtering scheme is changed for the page, the filtering showed by the filters and 
visualizations are changed, but the visibility of the filters panel and the filters therein are kept. 
  

Find 
A tool in TIBCO Spotfire that lets you search for data content, perform menu actions, and much 
more, by entering words or parts of words in a text field. 
  

Formatting 
Describes how different values in a data set should be presented, for example as text or 
currency, or how many decimals should be shown. 
  

Graphical Table 
A summarizing table visualization designed to provide a lot of information at one glance. It can 
display dynamic items such as sparklines, calculated values and icons. 
  

Gridlines 
Lines that form a grid inside a visualization to serve as a reference for the viewer. 
  

GUID 
A unique identifier for an information link that remains the same if the name of the information 
link is changed. 
  

Heat Map 
A visualization that presents data in the form of a table which contains colors instead of 
numbers. It can be used to identify clusters of similar values, as these are displayed as "areas" of 
similar color. 
  

Hierarchical Clustering 
Hierarchical clustering arranges objects in a hierarchy with a treelike structure based on the 
similarity between them. 
  

Hierarchy 
A hierarchy is defined as A) a set of ordered columns where the order defines the hierarchy, B) 
a timestamp column where it is possible to derive a natural hierarchy or C) an external 
hierarchical structure where every node maps to one or more rows in the data table through an 
identifier column. 
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Hierarchy Filter 
A filter based on a predefined hierarchy. The same thing as a tree filter. 
  

Horizontal Bars 
Bars displayed horizontally in a bar chart. You can change the orientation of the bars by right-
clicking in the visualization and selecting Horizontal Bars or Vertical Bars. 
  

Hyperlink 
A link to that will launch your default web browser when clicked on. 
  

Icon 
A dynamic item that can be included in a graphical table or in a text area. Icons are defined 
using rules. 
  

Information Link 
Information links are predefined database queries, specifying the columns to be loaded, and any 
filters needed to reduce the size of the data table prior to visualization. 
  

Item Filter 
A filter used to filter out rows based on whether or not a column value is equal to a specified 
value. The behavior is similar to a radio button filter, but the appearance is different, and it is 
more suited to selecting a value from a large number of unique values. 
  

Jittering 
An option that displaces the visualization items randomly in the display window, thereby 
making overlapping markers visible. Attention can be brought to areas where many markers 
overlap. Such regions can then be investigated further, by zooming, changing axes, etc. 
  

K-means Clustering 
A tool that helps you group rows into a defined number of clusters based on their similarity. A 
line chart is needed in order to use the tool. 
  

Label 
In a visualization, labels come in three varieties: 
1. Marker labels, showing the value of the marker. 
2. Scale labels, showing the scale of an axis. 
3. Line & Curve labels, showing the name and description of a line or curve. 

 
Legend 
Information that helps the viewer identify what the graphics in the visualization represent. 
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Library 
The Library is a space on the server where you can publish or open shared analysis files. 
  

Line By 
In a line chart, the line itself can visualize a column or a hierarchy. This is set up in the 
properties of the visualization. 
  

Line Connection 
In a scatter plot or a map chart, markers may be connected with a line to show trend or other 
relation. This is set up in the properties of the visualization. 
  

Line Chart 
A visualization that represents quantitative information by means of one or more lines. 
  

Line Labels 
Words or numbers used to identify and describe a line and the data associated with it. 
  

Line Similarity 
A tool where you can compare the similarity of different lines in a line chart against each other. 
  

Lines & Curves 
To connect or otherwise show relationship between Markers, Lines and Curves may be drawn 
on top of the visualization according to a number of models and functions. 
  

List Box Filter 
A Filter used to filter out rows based on which rows you mark in a list of all rows in a certain 
column. 
  

Lists 
Lists consist of sets of rows in your data representing captured knowledge from one or many 
data sources. You work with the same list collection from one session to the next. 
  

Map Chart 
A map chart is used to organize information visually in relation to an image or a shape file map. 
  

Marked Row 
An item in a visualization becomes marked when you click on it, or, when it is captured using 
the rectangle method (left mouse button pressed while moving pointer). Marked rows are given 
a definable color to distinguish them from the rest of the data. 
  



TIBCO Spotfire 4.0.2 - User's Manual 

1110 

Marking 
A marking identifies marked rows in the data tables of an analysis. If the data tables are related, 
the marked rows are propagated using the specified key relation between the data tables. Setting 
a marking in one data table does not affect the marking of unrelated data tables. 
Each analysis can hold multiple markings and each marking has its own marking color. One or 
more markings can be used to limit what data are displayed in a visualization. 
  

Marker 
A graphical object that represents a category. 
  

Marker Labels 
Words or numbers used to identify and describe a marker and the data associated with it. 
  

Page 
A page can be thought of as a "container" for visualizations, filters, a Details-on-Demand, etc. 
Pages make it possible to set up several sheets of visualizations that you can switch between in 
an analysis. Pages can contain visualizations and text areas that guide you through the analysis. 
Visualizations can only exist inside a page (they cannot be dragged outside even partly).  
All visualizations in an analysis can be linked, both within and between pages, but they do not 
have to be. The visualizations on a page use one or more filtering schemes, and the filtering 
schemes determine whether visualizations are linked or not. The visualizations in a page can use 
one or several data tables. 
  

Parallel Coordinate Plot 
A parallel coordinate plot is used to compare the values within a multitude of columns for a 
number of rows in the analysis. 
  

Parameterized Information Link 
The data an information link returns on different occasions or by different users may be 
parameterized, which means it depends upon for instance user input or other factors. A 
Personalized Information Link is a special case of this, where the identity of the user is used as 
a parameter in deciding which data to be returned. 
  

Personalized Information Link 
A personalized information link returns a subset of data depending on the identity of the user. 
  

Pie 
A circular graphic divided into sectors used to show the relative values of entities compared to 
each other and to the whole.   
  

Pie Chart 
A visualization composed of one or more pies. 
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Pie Labels 
Words or numbers used to describe a pie. 
  

Pie Sector 
A part of a pie that represents a subset of data of which the whole pie is made up. 
  

Pie Sector Labels 
Words or numbers used to describe a pie sector. 
  

Pivot 
A transformation used to transform data from a tall/skinny format to a short/wide format. 
  

Primary Key 
This is a set of one or more columns whose values uniquely identify every data row. By saving 
value tuples for the primary key, the application can support persistent masks and annotations 
for linked data tables. The primary key is a setting on the root view. 
  

Properties 
Properties can be compared to variables. All changeable settings in visualizations, data tables or 
documents are properties in some sense, but you can also create your own properties and use 
them to control the configuration of visualizations, calculations, or on-demand data loading. 
You can create property controls in a text area to simplify the process of changing a property 
value.  
  

Radio Button Filter 
A filter used to filter out rows based on whether or not a column value is equal to a specified 
value. The behavior is similar to an item filter, but the appearance is different, and it is more 
suited to selecting a value from a small number of values. 
  

Range Filter 
A filter used to filter out rows based on whether or not the values in a column fall between a 
certain lower and upper value. 
  

Range Filter Data Range 
The data range that the filter is operating on. 
  

Range Filter Lower Value 
All values below this limit are excluded from the filtered rows by the range filter. 
   

Range Filter Upper Value 
All values above this limit are excluded from the filtered rows by the range filter. 
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Renderer 
In a Table Visualization, how values are presented in cells depends on which renderer is used. 
  

Root View 
The default view of a data table, as it is first opened, with no modifications such as binned 
columns or filtered out data. 
  

Row 
A horizontal list of values in a data table. 
  

Scale 
A line with tick marks and labels used as a reference along an axis in a visualization. 
  

Scale Labels 
Words or numbers along a scale. 
  

Scatter Plot 
A visualization that represents quantitative information as a point along two axes. Used to 
explore relationships. 
  

Series By 
In a combination chart, it is possible to divide the data into slices, called series. Each series will 
be represented by a line or a set of bars in the visualization. 
  

Share 
A tool that can be used to quickly share parts of an analysis, such as bookmarks, visualizations, 
and pages, with others. The Share tool is reached from the right-click menu. 
  

Short Number Format 
The method of writing multiples of 10 using non-numerical characters, such as k for 1,000 and 
M for 1,000,000. 
  

Short Number Symbol 
The non-numerical character used instead of a multiple of 10, such as k or M. 
  

Sparkline 
A dynamic item that can be included in a graphical table or in a text area. It is a small simple 
line graph used for displaying trends or variations of some variable. 
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Spotfire Server 
TIBCO Spotfire Server is the server that a user of TIBCO Spotfire logs into and is able to save 
data to. 
  

Spotfire Text Data Format 
A well-defined text data format that does not require type guessing when read by TIBCO 
Spotfire or TIBCO Spotfire DecisionSite. 
  

Stacked Bar 
A set of vertical rectangles (bars) stacked on top of each other to represent a numerical value 
and how different components contributed to that numerical value. 
  

Summary Table 
A visualization that summarizes statistical information about data in table form. 
  

Symbol Set 
A collection of Short Number Symbols. 
  

Table 
A visualization with information arranged in rows and columns. 
  

Table Cell 
The intersection of a table row and a table column, where values are located. 
  

Table Column 
A vertical list of cells in a table. 
  

Table Column Header 
The title of a table column. 
  

Table Row 
A horizontal list of cells in a table. 
  

Table Row Header 
The title of a table row. 
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Tags Panel 
The area where tags are being defined and handled. 
  

Tags 
Tags are annotations which can be added to different sets of marked rows and included in an 
annotation column. 
  

Text Area 
A text area can contain information about a visualization, instructions on how to perform the 
analysis, or links which are shortcuts to specific tools in TIBCO Spotfire. In regards to the 
layout of a page, a text area is treated the same way as a visualization. 
  

Tick Marks 
Short lines drawn perpendicular to a scale and used to mark off uniform increments along that 
scale. 
  

Time Scale 
A scale consisting of units of time organized in a sequence so that intervals of equal physical 
size represent equal increments of time. 
  

Tooltip 
In addition to the ordinary tooltips that give information about buttons and controls in the user 
interface, TIBCO Spotfire also contains configurable tooltips displaying detailed information 
about the smallest items in a visualization. For example, when you hover with the mouse 
pointer over a bar segment in a bar chart, the tooltip will by default show the exact category axis 
and value axis values, as well as information about the coloring, if any split by color has been 
applied. 
  

Tree Filter (Hierarchy Filter) 
A filter based on a predefined hierarchy. 
  

Treemap 
A visualization that displays hierarchically structured data using nested rectangles. 
  

Trellis 
A Trellis is a split view of a visualization, organized by category in separate panels. 
  

Unpivot 
A transformation used to transform data from a short/wide format to a tall/skinny format. 
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URL 
A world wide web address. 
  

Value Axis 
The value axis is the vertical axis in a bar chart where the bars are displayed vertically. When 
bars are displayed horizontally, the value axis is the horizontal axis. 
  

Value Columns 
The columns used to calculate a measure based on the measure method, the dimension and the 
dimension aggregation level. 
  

Vertical Bars 
Bars displayed vertically in a bar chart. You can change the orientation of the bars by right-
clicking in the visualization and selecting Horizontal Bars or Vertical Bars. 
  

Virtual Column 
A column that is added to a table visualization by loading data from a remote source, such as a 
database. 
  

Visualization 
A representation of some data in TIBCO Spotfire. For example, a table, a bar chart, a pie chart, 
etc. A visualization displays data from one data table. The data displayed can be limited by one 
or more filtering schemes and by zero, one or several markings. A visualization shows and 
allows modification to one marking. 
  

Visualization Item 
The smallest building block of a visualization. For example, a pie sector in a pie chart, a line in 
a line chart or a cell in a table. 
  

Visualization Title 
Words or text used to identify a visualization. 
  

Web Player 
TIBCO Spotfire Web Player is the web client that can be used to view Spotfire data. You can 
export data for view in Web Player from Spotfire. 
  

X-Axis 
The horizontal axis in most 2D visualizations or the first axis in a 3D visualization. 
  

Y-Axis 
The vertical axis in most 2D visualizations or the second axis in a 3D visualization. 
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Z-Axis 
The third axis in a 3D visualization.  
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