Spotfire Server 10.10 LTS

This page lists system requirements for TIBCO Spotfire® Server version 10.10 LTS.

Changes

Spotfire Server database
  • Microsoft SQL Server 2017 on Linux is now a supported database.
  • Microsoft SQL Server 2019 on Linux is now a supported database.
  • Added a list of supported cloud service providers for the Spotfire Server database.
Operating system
  • CentOS 8 is now a supported operating system.
Web browser (for server administration/configuration pages) Microsoft Internet Explorer 11 is no longer a supported browser for accessing the Admin UI apps.

System requirements for Spotfire Server version 10.10 LTS

Hardware
Processor
  • Minimum: 2 Cores (Intel Core i3 or equivalent), 2 GHz, 64-bit
  • Recommended: 4 Cores or more (Intel Xeon E5 or equivalent), 2 GHz or higher, 64-bit
Note: x86 processors are not supported.
RAM
  • Minimum: 8 GB
  • Recommended: 16 GB or greater
Hard disk space
  • Minimum: 10 GB for a small test system.
  • Recommended: At least 30 GB to fit multiple deployment areas, information link and library content caching, library exports, and log files.
  • Caching: If the Spotfire® Server is configured to cache library content and information links, this uses additional disk space. By default, caching is enabled and the maximum cache size set to 10 GB.
Software
Operating system The following operating systems are supported:
  • Microsoft Windows Server 2019
  • Microsoft Windows Server 2016
  • Microsoft Windows Server 2012 R2
  • Microsoft Windows Server 2012
  • Red Hat Enterprise Linux 8
  • Red Hat Enterprise Linux 7
  • Red Hat Enterprise Linux 6
  • Red Hat Enterprise Linux 5
  • CentOS 8
  • SUSE Linux Enterprise Server 12
  • SUSE Linux Enterprise Server 11
Note: Only 64-bit versions of the operating systems are supported.
Spotfire Server database Oracle *:
  • Oracle 19c **
  • Oracle 18c **
  • Oracle 12c Release 2 (12.2.0.x) **
  • Oracle 12c Release 1 (12.1.0.x) **

Microsoft SQL Server ***:

  • Microsoft SQL Server 2019 ****
  • Microsoft SQL Server 2017 ****
  • Microsoft SQL Server 2016 ****
  • Microsoft SQL Server 2014 ****

PostgreSQL:

  • PostgreSQL 12
  • PostgreSQL 11
Note: The Spotfire Server database uses third-party software that must be installed prior to the TIBCO Spotfire® software installation. It is possible, but not supported, to run the database and Spotfire Server on the same computer. If you do so, refer to the database vendor for database system requirements.
Note: The size of the Spotfire Server database schema(s) is approximately 500 MB at the time of creation; there is no upper limit for the size, unless restricted by database limitations.
Oracle-specific notes

* Oracle RAC (Real Application Clusters) also supported.

* The Oracle database setting OPEN_CURSORS (default value 50) must be set to at least 500.

** Oracle XE is supported for use in non-production environments (such as evaluation, test, or development), but for production environments it is strongly recommended to use one of the recommended versions instead. Note that there are numerous known limitations in terms of maximum number of CPU cores, memory and database size (with some variations depending on the Oracle version), when using Oracle XE instead of one of the recommended versions.

Microsoft SQL Server-specific notes

*** Microsoft SQL Server has a size limit of 2 GB for BLOB storage. This means that the maximum size of any single item stored in the Spotfire library (such as an analysis file) cannot be larger than 2 GB.

*** Microsoft SQL Server AlwaysOn is also supported.

**** Microsoft SQL Server Express is supported for use in non-production environments (such as evaluation, test, or development), but for production environments it is strongly recommended to use one of the recommended Microsoft SQL Server editions instead. Note that there are numerous known limitations in terms of maximum number of CPU cores, memory and database size (with some variations depending on the SQL Server version), when using the Express edition instead of one of the recommended editions.

Cloud Service Providers managed database

It is possible to use the supported database versions listed above as managed relational database services from the major Cloud Service Providers (CSP).

Amazon Web Services:

  • Amazon RDS for Oracle
  • Amazon RDS for Microsoft SQL Server
  • Amazon RDS for PostgreSQL
  • Amazon Aurora with PostgreSQL compatibility

Azure:

  • Azure SQL Database
  • Azure Database for PostgreSQL*****
Google Cloud:
  • Cloud SQL for PostgreSQL*****

***** The created user when creating a CSP managed database account may not have the SUPERUSER privilege, thus it is not possible to create another user to the database. If that is the case, then the DBADMIN credentials must be set to the same value as SERVERDB in the create_databases script and the user creation must be disabled (in create_server_env.sql, remove or comment out the "create user" clause and the "alter database" clause).

Spotfire software Spotfire Server 10.10.x, with a Spotfire 10.10.x deployment, supports connections from Spotfire Analyst and web client 10.10.x.

Upgrades:

  • Spotfire Servers of version 7.5.x or higher can be upgraded to version 10.10.x.
  • Spotfire installed clients of version 7.5.x or higher can connect to Spotfire Server 10.10.x (with a Spotfire 10.10.x deployment) to be upgraded to Spotfire 10.10.x.

For more information about Spotfire versioning and upgrades, see https://docs.tibco.com/pub/spotfire/general/LTS/spotfire_LTS_releases.htm.

Authentication method
  • LDAP - Microsoft Active Directory
  • LDAP - The Directory Server product family (Netscape Directory Server, iPlanet Directory Server, Sun ONE Directory Server (v5), Sun Java System Directory Server (v6), Oracle Directory Server (v7)
  • Kerberos v5 for Active Directory
  • NTLMv2
  • Microsoft Windows NT Domain
  • Database table (Spotfire Server is used to both manage and store user names and passwords)
  • Custom JAAS modules using username/password credentials
  • X.509 client certificates
  • OpenID Connect
  • Custom web authentication component
Installation privileges on Windows Spotfire Server 10.10.x must be installed under a Windows user account with full administrative privileges.
Locale The server should run in an English (United States) language setting.
Web browser (for server administration/configuration pages) The following web browsers are supported:
  • Google Chrome
  • Microsoft Edge
  • Mozilla Firefox
Network IPv4 or IPv6
Node manager (optional) To run any Spotfire services (TIBCO Spotfire® Web Player, TIBCO Spotfire® Automation Services, or TIBCO® Enterprise Runtime for R - Server Edition) on a computer, the computer must first have a node manager installed. There is no separate system requirement for the node manager; this is covered by the requirements for the service.
Spotfire services (optional) The following are the supported services that can be provided through Spotfire Server:
  • Spotfire® Web Player service 10.10.x
  • Spotfire® Automation Services 10.10.x
  • TERR™ Server Edition (TERR service)
  • Spotfire® Service for Python
Note: To run Spotfire service(s) on a computer, the computer must first have a node manager installed. There are no separate system requirements for the node manager; this is covered by the requirements for the service.
Important: Do not install the TERR service on a node that contains other services. Doing so can cause the service(s) to become unresponsive.
Information Services Data Sources (optional) To use Information Services for server-side access to JDBC data sources, a driver for the corresponding data source must be installed on the server.

Some data source drivers are included out of the box with Spotfire Server. See the Spotfire Server and Environment Installation and Administration manual for more information.

Load balancer (optional) Load balancing Spotfire Servers can be achieved using Apache httpd with the mod_jk module enabled. This solution is tested and recommended.

It is also possible to use a different load balancing solution, as long as it supports session affinity, which ensures that a client communicates with the same server for the duration of the session.

Clustering (optional) Multiple Spotfire Servers can be clustered for failover and improved scalability using Apache Ignite, which is included out of the box.