Spotfire Analyst & Desktop 10.10 LTS

This page lists system requirements for TIBCO Spotfire® Analyst and TIBCO Spotfire® Desktop version 10.10 LTS.

Changes

TIBCO Spotfire Software
Only applicable for TIBCO Spotfire® Analyst
Updated supported version:
  • Connection to a TIBCO Spotfire Server 10.10.x, with a TIBCO Spotfire 10.10.x deployment, for software deployment and licensing.
Citrix (optional)

Server:

  • Added support for Citrix Virtual Apps and Desktops 7 1912 LTSR.
  • Removed support for Citrix XenApp 6.5 and Citrix XenApp 6.0.

Operating system:

  • Added support for Microsoft Windows Server 2019.
Remote Desktop Services (optional)
  • Added support for Microsoft Windows Server 2019.
  • Removed support for Microsoft Windows Server 2008 R2 (SP1 or higher).
Operating system

Windows 8 is no longer supported as the operating system. (Windows 8.1 is still supported.)

System requirements for the TIBCO Spotfire® installed clients version 10.10 LTS

Hardware
Processor
  • Minimum: 2 cores, 2 GHz
  • Recommended: 4 cores or more (Intel Core i5 or equivalent), 2+ GHz, 64-bit
RAM
  • Minimum: 4 GB
  • Recommended: 8 GB or more
Note: Large data sets can require more RAM.
Hard disk space
  • 10 GB is recommended for installation and normal use.
Display
  • Minimum: 1024x768 pixel resolution, 16-bit or 32-bit color depth
  • Recommended: 1920x1080 pixel resolution or higher, 16-bit or 32-bit color depth
Note: For functionality that requires hardware acceleration (such as the 3D plot), DirectX 9 or higher and a compatible graphics card is required.
Software
Operating system

Any of the following:

  • Microsoft Windows 10
  • Microsoft Windows 8.1
  • Microsoft Windows 7
Note: Spotfire is only optimized for use with 64-bit systems. While both 32-bit and 64-bit operating systems are supported, 64-bit is strongly recommended. Running Spotfire Analyst or Desktop on a 32-bit operating system (or in 32-bit mode) is only suitable when using in-database analytics or when analyzing small data sets.
TIBCO Spotfire software
TIBCO Spotfire® Analyst 10.10.x
Spotfire Analyst 10.10.x requires connection to a TIBCO Spotfire Server 10.10.x, with a TIBCO Spotfire 10.10.x deployment, for software deployment and licensing.
For information about what versions of existing TIBCO Spotfire Analyst installations can be upgraded to version 10.10.x by connecting to a TIBCO Spotfire Server 10.10.x, with a TIBCO Spotfire 10.10.x deployment, see the Spotfire Server system requirements.
TIBCO Spotfire® Desktop 10.10.x
Spotfire Desktop 10.10.x does not require any additional TIBCO Spotfire software, or connection to a Spotfire Server.
Installation permissions

Administrator rights are not required to install TIBCO Spotfire Analyst or Desktop.

Microsoft .NET Framework

Any of the following:

  • 4.5.x
  • 4.6.x
  • 4.7.x
  • 4.8.x
Note: If Microsoft .NET Framework version 4.5 is not installed before you run the TIBCO Spotfire Analyst or TIBCO Spotfire Desktop 10.10.x installer, the installer can (if you accept this when prompted) download and install it. If you are upgrading an existing TIBCO Spotfire Analyst installation by connecting to a TIBCO Spotfire Server with a TIBCO Spotfire 10.10.x deployment, you must have installed Microsoft .NET Framework before upgrading.
Note: Microsoft .NET Framework 4.5.2 or higher is strongly recommended, because defects in older .NET Framework 4.5.x versions have been confirmed to cause stability issues.
Note: Microsoft .NET Framework 4.5 works side by side with older .NET Framework (3.5 and earlier) versions, but performs an in-place update for .NET Framework 4.
Note: You must have administrator rights to install Microsoft .NET Framework.
TLS (Transport Layer Security) (optional)
Only applicable for TIBCO Spotfire® Analyst

The following TLS versions are supported:

  • TLS 1.1 or higher
Note: TLS is only required if you are connecting to the TIBCO Spotfire Server over HTTPS.
Note: TLS 1.1 (and/or higher versions) can be enabled in the Control Panel > Network and Internet > Internet Options > Advanced tab > Security section.
Microsoft Office (optional)

To use Spotfire functionality that integrates with Microsoft Office products, such as exporting to PowerPoint, importing data from Access, and importing data from older versions of Excel, Microsoft Office must be installed.

The following versions of Microsoft Office are supported:

  • Microsoft Office 365
  • Microsoft Office 2019, 32-bit and 64-bit versions
  • Microsoft Office 2016, 32-bit and 64-bit versions
  • Microsoft Office 2013, 32-bit and 64-bit versions
Note: It is possible to import data from Microsoft Access databases into TIBCO Spotfire Analyst or Desktop.
Connectors (optional)

If you are using Spotfire Connectors to access data in external systems, note that additional system requirements might apply, including that a data source driver for the connector typically must be installed.

For detailed information and system requirements for all connectors included in this version of Spotfire, see System Requirements for TIBCO Spotfire® Connectors.

Importing SAS data files (optional)
  • SAS Providers for OLE DB 9.22 or higher

You can import SAS data files (for information about supported file formats, see the Spotfire Analyst User's Guide for your version of Spotfire) into TIBCO Spotfire directly. You must have installed the SAS Providers for OLE DB 9.22 or higher on the computer that is running the Spotfire client.

To download SAS Providers for OLE DB, go to Downloads & Hot Fixes on https://support.sas.com (free registration on the SAS website is required).

Note: SAS Providers for OLE DB are not supported for use in the Spotfire Web Player service (the SAS driver is not thread-safe, which can cause general platform instabilities).
Note: For use with Windows 8 or 10, it is strongly recommended to use SAS Providers for OLE DB 9.43 or higher, as there are known issues with the older versions of the driver on those operating systems.
Citrix (optional)

It is supported to deploy TIBCO Spotfire Analyst or Desktop on:

Server:
  • Citrix Virtual Apps and Desktops 7 1912 LTSR (formerly XenApp)
  • Citrix XenApp 7.15
  • Citrix XenApp 7.6
Operating system:
  • Microsoft Windows Server 2019
  • Microsoft Windows Server 2016
  • Microsoft Windows Server 2012
  • Microsoft Windows Server 2012 R2
Note: The 3D Scatter Plot visualization is not supported in a Citrix environment, because the visualization requires hardware acceleration.
Remote Desktop Services (optional)

It is supported to run TIBCO Spotfire Analyst or Desktop via Windows Server Remote Desktop Services on the following operating systems:

  • Microsoft Windows Server 2019
  • Microsoft Windows Server 2016
  • Microsoft Windows Server 2012 R2
  • Microsoft Windows Server 2012
TIBCO Tibbr (optional)
  • TIBCO Tibbr 4 or higher
Python data functions (optional) If your environment requires use of a Python version other than the one bundled with Spotfire, then your installation of Python must be version 3.5 or higher. Also note that only the 64-bit versions of Python and Spotfire are supported when using Python data functions.