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1 Introduction 
1.1 Introduction 

These additional help topics provide a description of the structure display and search 
functionality available in TIBCO Spotfire Lead Discovery. TIBCO Spotfire Lead Discovery 
allows you to: 

• Open an SDFile and view its fields in the table visualization, including the molecular 
structures. 

• View SMILES strings as chemical structures in a table visualization or the Structure 
Viewer. 

• Load chemical structures from a database. 
• Export data to an SDFile. 
• Use the Structure Viewer to view chemical structures, and to create, export, and import 

 ID lists. 
• Search on structures in a database using similarity and substructure search. 
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2 Loading Data 
2.1 Opening an SDFile 

You can open an SDFile and view it in the TIBCO Spotfire table visualization. 

► To open an SDFile: 
1. Click on the Open button on the toolbar, or select File > Open.... 
2. Browse to the SDFile of interest and click Open. 

Response: You will see an initial visualization using the fields of the SDFile. 
3. If your initial visualization is not a table, create a new Table visualization. 

Response: You will see the table containing the fields of the SDFile, including the 
chemical structures.   

As with any table visualization in TIBCO Spotfire, you can: 
• Save this analysis to file or library (see the "Saving an Analysis file in the Library" 

topic of the TIBCO Spotfire online help). 
• Change the column order, column width, or row height; add, remove, sort, or mark 

rows (see the "How to Use the Table" topic of the TIBCO Spotfire online help). 
• Change the table appearance and settings using the Table Properties Dialog. 

Once your analysis in TIBCO Spotfire Lead Discovery is done, you can also export the contents 
of a table visualization to an SDFile. 
Tip: If your main purpose with TIBCO Spotfire is to view data containing structures, you can 
change the default row height in the table visualization by selecting Tools > Options and go to 
the Table page. There, change the Data row height to a suitable number. You can also change 
the default initial visualization to be a table by going to the Document page, and changing the 
Initial visualization when loading data to Table. 
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3 Exporting Data 
3.1 Exporting Data to an SDFile 

You can export data from TIBCO Spotfire Lead Discovery to an SDFile. 

► To export data from a visualization to an SDFile: 
1. Right-click on the table and select Export to SDFile.... 
2. Select whether to export all rows, marked rows or filtered rows only: 

All rows - exports every row in the data table regardless of filtering. 
Marked rows - exports the marked rows of the table only. 
Filtered rows - exports the rows remaining after filtering only. 

3. Select the Molfile structure column from the drop-down list. 
Comment: The SDFile format supports only one structure per record. You may select 
any column in the table that contains Molfile structures. The first column containing 
structures is displayed as the default choice. 

4. Use the Add >, < Remove, and Remove All buttons to select the columns to be 
exported with the structure. 

5. Use the Move Up and Move Down buttons to specify the order of columns in the 
SDFile. 

6. Click OK. 
7. In the Save As dialog, specify a filename, browse to the location where you want to 

save the file and click Save. 
Tip: You can also export data to an SDFile by selecting File > Export > Data... from the main 
menu and choosing Save as type: SDFile (*.sd;*.sdf). However, you will not be able to change 
the columns to include in the export if you use this method. 

► To export data from the Structure Viewer to an SDFile: 
1. Select the IDs you want to export in the List Content pane of the Structure Viewer 

panel or popover. 
2. Right-click on any of the selected IDs and select Export Selection to SDFile.... 
3. Select the Molfile structure column from the drop-down list. 

Comment: The SDFile format supports only one structure per record. You may select 
any column in the table that contains Molfile structures. The first column containing 
structures is displayed as the default choice. 

4. Use the Add >, < Remove, and Remove All buttons to select the columns to be 
exported with the structure. 

5. Use the Move Up and Move Down buttons to specify the order of columns in the 
SDFile. 

6. Click OK. 
7. In the Save As dialog, specify a filename, browse to the location where you want to 

save the file and click Save. 

3.2 Details on Export to SDFile 
► To reach the Export to SDFile dialog: 

1. Right-click on the table and select Export to SDFile.... 
Comment: If the table does not contain any structures, the Export to SDFile... menu 
item will be unavailable. 
OR 
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Select the IDs you want to export in the List Content pane of the Structure Viewer 
panel or popover. 
Right-click on any of the selected IDs and select Export Selection to SDFile.... 

 

Option Description 

Export Note: If you exported data from the Structure Viewer, these 
options will not be available since you have already selected 
which rows to export. 

   All rows Exports all rows in the selected data table. 

   Marked rows Exports data for the marked rows only. 

   Filtered rows Exports data for the filtered rows only. 

Molfile structure column Specify the column in the data table that contains molecular 
structures. 
Displays the available structure columns. Select the one you 
wish to export. If no structure column is available in the actual 
data set (for example, if structures are shown in a virtual 
column) you will not be able to export the structures using this 
tool. 

Available columns Lists the columns of the data table that are currently not 
selected for exporting to the SDFile. 

Columns to include in 
SDFile 

Lists the columns of the table that are currently selected for 
exporting to the SDFile. 

Add > Adds the selected column to the list of columns to include in 
the SDFile. 
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< Remove Removes the selected column from the list of columns to 
include in the SDFile and returns it to the list of available 
columns. 

Remove All Removes all columns from the list of columns to include in the 
SDFile and returns them to the list of available columns. 

Move Up Moves the selected items in the Columns to include in SDFile 
list up one step. The order of the columns in this list 
determines the order of the columns in the resulting SDFile. 

Move Down Moves the selected items in the Columns to include in SDFile 
list down one step. The order of the columns in this list 
determines the order of the columns in the resulting SDFile. 
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4 Working with Structures 
4.1 Structure Viewer 
4.1.1 What is the Structure Viewer? 

The Structure Viewer is used to: 
• View the structures marked in the visualization or to display structure search results. 
• View, create, import, and export ID lists. 

The key elements of the Structure Viewer are: 
• Toolbar and lists drop-down 
• List Content pane 
• Structure Viewer pane 
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Option Description 

1. Toolbar Contains the buttons that allow you to export, import, rename and 
delete ID lists, and to edit list settings. 

2. Lists You can select an existing list in the Lists drop-down. The Structure 
Viewer maintains a dynamic list called Marked Rows that contains the 
marked rows in the active visualization. 
The number of items in each list is displayed within parentheses after 
the name of the list. 

3. List Content 
pane 

Displays the list of identifiers for the list selected in the Lists drop-
down. The values in this pane are taken from the ID column you 
selected when opening the Structure Viewer. 

4. Structure 
Viewer pane 

Displays the chemical structures for the list selected in the Lists drop-
down. The structures in this pane are taken from the structure column 
you selected when opening the Structure Viewer, or from the results of 
a structure query. 

4.1.2 How to Use the Structure Viewer 
► To reach the Structure Viewer: 

1. Open data in TIBCO Spotfire. 

2. Click on the Structure Viewer button on the toolbar, . 
Comment: You can also select View > Structure Viewer from the menu. 
Response: The Configure Structure Connection dialog is displayed. 

3. Select the columns in the visualization containing molecular structures and identifiers. 
4. Click OK. 

Response: The Structure Viewer is displayed. 
5. Mark or highlight compounds in a visualization. 

Response: When there are no marked rows, the structure from the currently highlighted 
row in the data table is displayed in the Structure Viewer pane of the Structure Viewer, 
and its identifier is displayed in the List Content pane.  When there are marked rows, 
the structures from the marked rows are displayed in the Structure Viewer pane and 
their identifiers are displayed in the List Content pane.  When you highlight a marked 
row, its corresponding identifier and structure will be highlighted in the Viewer and 
List Content panes. 
Note: The Structure Viewer will also automatically become active when you perform a 
structure search. 

4.1.3 Structure Viewer: Toolbar 
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Button / Control Description 

 

Imports an ID list file to Structure Viewer. 

 

Exports the ID list currently selected in the Lists drop-
down to an LST file. 

 

Displays the structures with the IDs from the active ID 
list in a separate data table visualization. 
Creates a new data table containing the structures and 
IDs from the current list. If additional data is available, 
it is included in the new table. Additional data may be 
drawn from the linked rows in the active data table or 
from an information link, depending on the source of 
the list. 

 

Opens the Structure Connection dialog where you can 
re-configure the mapping of ID and structure columns 
between data tables and Structure Viewer. 

 

Opens the Manage Lists dialog where you can change 
the name and description for previously created lists, as 
well as delete lists. 

 

Displays the name of the selected list followed by the 
number of items in the list within parentheses. The 
elements of the selected list are displayed in the List 
Content and Viewer panes. Use this drop-down to 
select a different list.   

4.1.4 Structure Viewer: List Content Pane 
In the List Content pane of the Structure Viewer, you can view the identifiers of the molecular 
structures from the ID list currently selected in the Lists drop-down. This can represent: 

• The marked rows in the active data table. 
• A previously created or imported ID list. 
• The results of a structure search. 

The List Content pane displays the identifiers of the rows in the list. The identifiers are taken 
from the column you selected as the ID column when the Structure Viewer was first opened. If 
the result of a structure query is shown, the metadata supplied by the information link are used. 

 
The right-click pop-up menu of the List Content pane contains a number of options shown in 
the table below. 
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Right-click Menu 
Option 

Description 

Mark Selection in Active 
Visualization 

Marks the rows with the selected IDs in the active 
visualization. 

Create New List from 
Selection... 

Creates a new ID list from the IDs selected in the List 
Content pane. 

Export Selection to SDFile... Opens the Export to SDFile dialog where you can export the 
selected IDs to an SDFile. 

Copy IDs Copies the selected IDs to the clipboard. 

Select All Selects all IDs in the List Content pane. 

Invert Selection Inverts the selection in the List Content pane. 

Remove IDs from List Removes the selected IDs from the list in the List Content 
pane. 

Manage Lists... Opens the Manage Lists dialog where you can change the 
names and descriptions of all previously added lists. You can 
also remove unwanted lists from Structure Viewer. 

4.1.5 Structure Viewer: Structure Viewer Pane 
In the Structure Viewer pane, you can see the structures of either the marked rows of the data 
table, or of the currently active ID list. This pane also displays the structures of the search 
results after you run a Structure Search. 
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The right-click context menu of the Structure Viewer pane contains a number of options shown 
in the table below: 

Right-click Menu 
Option 

Description 

Structure Search... Displays the Structure Search dialog. 

Copy Copies information from the Structure Viewer to the Windows 
clipboard: 
Structure - copies the selected structure as a structure which can 
be edited in the structure renderer. 
Image - copies the selected structure as an image. 
Image with All Visible Structures  - copies the visible contents 
of the Structure Viewer pane as an image. 

Renderer      
  

Use this option to select the default renderer used in the Structure 
Viewer pane (see Supported Renderers for more information). 
You can also change the renderer settings in the Renderer Settings 
dialog. 

Print All - when selected, specifies that all the structures from the 
current list will be printed. 
Visible Structures - when selected, specifies that only those 
structures from the current list that are visible in the Structure 
Viewer pane will be printed. 
Print - prints the structures according to the print settings (All or 
Visible Structures). 
Print Preview - displays the Print Preview window. 

Show IDs Shows or hides the molecule IDs for the structures displayed in 
the Structure Viewer pane. 

Layout Specifies the number of columns to be shown in the Structure 
Viewer pane. 

4.1.6 Details on Configure Structure Connection 
In the Configure Structure Connection dialog, you specify the columns of the table which will 
be treated by the Structure Viewer as the columns containing structures and IDs. The structure 
connection can be different for different lists. 

► To reach the Configure Structure Connection dialog: 
  

1. Click on the Structure Viewer button on the toolbar, . 
Comment: You can also select View > Structure Viewer from the menu. 
Response: The Configure Structure Connection dialog is displayed. 

In Structure Viewer, you can also click on the Configure Structure Connection button, , to 
show the dialog again. 
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Option Description 

ID column Select the column from the data table which you want to use as the 
identifier of the structure. The values from this column will be 
displayed in the List Contents pane of the Structure Viewer panel. 
Also, the Structure Viewer will use the IDs from this column for 
creating, exporting, and importing the ID lists. 

Structure   

   Column Select a column that contains structures from those available in the 
active table visualization. The contents of this column will be rendered 
in the Structure Viewer pane. 

   Link Select an information link that contains structures from those available 
in the drop-down list. The structures from this link is what will be 
displayed in the Structure Viewer pane. The information links that are 
available here are configured using Information Designer. See the 
TIBCO Spotfire Lead Discovery - Installation Manual for more 
information. 

4.2 Working with ID Lists 
4.2.1 Working with ID lists 

The ID lists in the Structure Viewer let you keep track of groups of compounds. Each time you 
conduct a structure search, the result is added as a new list in the List Content pane of the 
Structure Viewer. All the lists that you create are stored locally and appear in the Lists drop-
down of the Structure Viewer. 
The Structure Viewer also maintains a dynamic list called "Marked Rows", which contains the 
current set of marked rows. To save the results of a structure query or the set of marked rows 
more permanently, create a new list and convert the list to a data table, or export a list file or an 
SDFile. 
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► To display the Structure Viewer: 
1. Select Tools > Structure Viewer, or, click on the Structure Viewer button on the 

toolbar, . 
Comment: Another way to launch the Structure Viewer is to perform a structure search 
by right-clicking on a table column containing structures and selecting Structure 
Search.... The Structure Viewer appears and the search results are displayed in the List 
Content and Structure Viewer panes. 
 

Action Instruction 

Create a list Do either one of: 
Perform a search using the Structure Search tool. 
Select the IDs in the current list, right-click and select Create 
New List from Selection.... 

Change list settings 
Click the Manage Lists button, , on the Structure Viewer 
toolbar. You can also right-click and select Manage Lists... 
from the pop-up menu. In the Manage Lists dialog, you can 
change the list name and description. In the Structure 
Connection dialog, reached from the Configure Structure 

Connection button, , you can re-map the ID and structure 
columns, if necessary. 

Rename a list 
Click the Manage Lists button, , on the Structure Viewer 
toolbar. You can also right-click and select Manage Lists... 
from the pop-up menu. In the Manage Lists dialog, click to 
select the list you want to rename, then click Rename. 

Export the list as an LST 
file 

Select the list in the Lists drop-down and click the Export 

button, , on the Structure Viewer toolbar. 

Import a list 
Click the Import button, , on the Structure Viewer 
toolbar and select the list file to import in the Open File 
dialog. 

Export selected IDs to an 
SDFile 

Right-click on any of the selected IDs and select Export 
Selection to SDFile... from the pop-up menu to open the 
Export to SDFile dialog. 

Display structure for a 
compound ID 

Click on one or more identifiers in the List Content pane. The 
Structure Viewer pane will display the structures 
corresponding to the selected identifiers. 

Create a new data table 
with the compounds from 
the current list 

Select the list in the Lists drop-down and click the Create 

Table button, , on the Structure Viewer toolbar. A new 
data table will be created with the ID, structure, and any 
related data for the compounds in the list. 

Mark compounds from the 
list 

In the list, select the desired identifiers. Right-click and select 
Mark Selection in Active Visualization. 
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Copy a list In the list, select the desired identifiers. Right-click and select 
Copy IDs. 

Select all identifiers in a list Right-click in the List Content pane and select Select All. 

Invert the selection in the 
list 

In the list, select the desired identifiers. Right-click and select 
Invert Selection. 

Remove identifiers from 
the list 

In the list, select the desired identifiers. Right-click and select 
Remove IDs from List. 

4.2.2 Details on Manage Lists 
In the Manage Lists dialog, you can specify the list name and description of all available lists. 

 

► To reach the Manage Lists dialog: 

1. Click the Manage Lists button, , on the Structure Viewer toolbar or right-click in 
the List Content pane and select Manage Lists.... 

Option Description 

ID Lists Lists all currently available ID Lists in Structure Viewer. 

Rename Click on a list in the ID Lists pane and then click Rename to change 
the name of the selected list. 

Delete Click on a list in the ID Lists pane and then click Delete to remove the 
selected list from the Structure Viewer. 

Description Optional. Type a description of the contents of the selected list. 
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4.2.3 New List Dialog 
New lists are automatically created when you perform a structure search. To create a new list 
from a selection in another list, use this dialog. 

► To reach the New List dialog: 
1. Make sure that the interesting IDs are selected in the List Contents pane of the 

Structure Viewer. See Working with ID Lists for more information. 
2. Right-click in the List Contents pane and select Create New List from Selection.... 

 

Option Description 

Name Type a suitable name for the new list. 

Description Optional. Type a description of the contents of the list. 

4.3 Searching Structures 
4.3.1 Searching for Compounds Using Structure Search 

The Structure Search tool allows you to perform substructure and similarity searches. See 
Details on Structure Search for more information regarding the individual search methods. The 
search returns a list of identifiers that is displayed in the Structure Viewer. 

► To search for compounds in a structure database: 
1. In the Structure Viewer or in a table visualization with structures, click to activate the 

compound on which you want to base the search. 
2. Right-click on the structure and select Structure Search... from the pop-up menu. 

Comment: You can also select Tools > Structure Search... from the main menu. 
Response: The Structure Search dialog is displayed. 

3. Select one of the alternatives under Search for. 
Comment: You can search for Substructure or Similarity. 

4. If the Parameters... button becomes available, click on it to edit the parameters 
available for the selected search method. 
Comment: If you select Similarity search, you must enter a range of similarity values 
in the Similarity Search Parameters dialog. Similarity values range from 0 (least 
similar) to 100 (most similar). 

5. If you want to import a structure from a file, click Import Structure.... 
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Response: The Open File dialog appears. Select the file you want to import and click 
Open. The structure from the file will be displayed in the Structure Search dialog. 

6. If required, click Edit.... If more than one structure editor is available, you can choose 
which editor to use from a drop-down list. 
Response: Your selected structure editor is launched. Edit the structure and click the 
button that returns the structure to Spotfire (in ChemDraw: OK, in Symyx® Draw 
(MDL): Transfer). Please refer to the documentation of your current structure editor 
for more details. 

7. Select an information link in the Search in drop-down. 
Comment: See chapter 2.4 Configuring Information Links in the TIBCO Spotfire Lead 
Discovery - Installation Manual for more information about how information links 
should be configured to be shown here. 

8. If required, limit the search to the current list of identifiers. 
Comment: This option is only available when performing the search from the Structure 
Viewer and when any list except for the Marked Rows list is selected in the Lists drop-
down of the Structure Viewer. When you start a structure search from a table 
visualization without activating the Structure Viewer, or, if the Marked Rows list is 
selected, the Data Source option will be the only one available. 

9. Specify the name for the resulting list. 
10. Click OK. 

Response: Structures in the database that match the search criteria are displayed in the 
Structure Viewer (Viewer pane). A new ID list is added and displayed in the List 
Content pane. To show the search results as a separate data table, select the search 

results list in the Lists drop-down and click the   button on the Structure Viewer 
toolbar.   

4.3.2 Details on Structure Search 
► To reach the Structure Search dialog: 

1. Select Tools > Structure Search... or right-click on a structure in a table or the 
Structure Viewer and select Structure Search... from the pop-up menu. 
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Option Description 

Search for   

   Substructure Performs a search for structures containing the specified substructure. 

   Similarity Performs a search for structures similar to the specified master 
structure. Open the Similarity Search Parameters dialog and specify a 
range of values between 0 (least similar) and 100 (most similar). 

Parameters... Launches the Parameters dialog where you can provide search 
parameters for similarity search. 

Import Structure... Launches the Open dialog where you can select a structure file to use 
in the search. 

Edit... Launches your current structure editor where you can edit the structure 
before performing the search. The same thing is achieved by double-
clicking the structure. If more than one structure editor is available, 
you can choose which editor to use from a drop-down list. 
After editing the structure and sending it back to TIBCO Spotfire, the 
Structure Search dialog is updated with the edited structure. 

Search in Specifies the information link (predefined query) to the data source in 
which the search will be performed. 
See chapter 2.4 of the TIBCO Spotfire Lead Discovery - Installation 
Manual for more information about Configuring Information Links. 
See Information Links topics in the TIBCO Spotfire online help for 
general information about information links. 
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Limit search to Allows you to limit the search to a set of identifiers from the list 
currently selected in the Lists drop-down. This option is only available 
when any (not empty) list except for the Marked Rows list is selected. 

Name of resulting 
list 

Allows you to give the resulting structure search list a name of your 
choice. 

 

4.4 Viewing Structures in Virtual Columns 
In the table visualization, you can view structures from remote data sources using virtual 
columns. You can connect to a virtual column and collect structure data from the remote data 
source both when showing structures in a table visualization and when structures are shown in 
the Structure Viewer. 

► To add a virtual column: 
1. Right-click on a table visualization and select Properties. 
2. Select Virtual Columns and click Add > Structure Column. 
3. In the Structure Column Settings dialog, select the key column - for example, the 

column that contains the IDs of the structures in your visualization. 
4. Click on Browse.... 

Response: The Open from Library dialog is displayed. 
5. Select the information link that contains the data you want to retrieve in your virtual 

columns and click Open. 
Note: Make sure that columns containing the key column data (in our example - 
structure IDs) and the data you would like to view in the virtual column (for example, 
molecular structures) are included in the information link. 

6. Click OK. 
Response: The virtual Structure column is displayed in the active table visualization. 

4.5 Viewing Structures in Labels or Tooltips 
In TIBCO Spotfire 3.3 and forward, it is possible to display structures and other images in the 
labels or tooltips of many visualizations. 

► To show structures from the loaded data in labels: 
1. Open the Properties dialog for the visualization. 

Comment: This is done by right-clicking on the visualization and selecting Properties 
from the pop-up menu. 

2. Click on the Labels page in the list on the left. 
Response: The Labels page is displayed. Note that not all visualizations support labels. 

3. Select the structure column under Label By. 
Comment: This is possible if the loaded data contains the structure information directly 
(e.g., if the loaded data is an SDFile). For example, select "Structure <MOLFILE>". If 
you want to retrieve the structures from an information link instead, see below. 

4. Specify whether to Show labels for: All or Marked rows. 
5. Make sure that Get content from is set to (Selected column). 
6. Make sure that Show as is set to your current structure renderer. For example, 

Symyx® Draw (MDL). 
7. If desired, change the Size of the structures using the slider. 
8. Click Close. 
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► To show structures from an information link in labels: 
1. Open the Properties dialog for the visualization. 

Comment: This is done by right-clicking on the visualization and selecting Properties 
from the pop-up menu. 

2. Click on the Labels page in the list on the left. 
Response: The Labels page is displayed. Note that not all visualizations support labels. 

3. Select an identifier column under Label By. 
Comment: Here you select the identifier column in your data table that will be used to 
match the identifier in the information link from which structures are to be retrieved. 

4. Specify whether to Show labels for: All or Marked rows. 
5. Select Get content from: Structure Column. 

Comment: This specifies that rather than displaying the information from the selected 
Label by column directly, the selected column will be used as an identifier when 
retrieving data from an information link. 

6. Click on the Settings... button next to Get content from. 
Response: The Structure Column Settings dialog is displayed. 

7. Make sure that the correct Key column is selected, then click Browse.... 
Response: The Open from Library dialog is displayed. 

8. Click to select the information link containing your structures and then click Open. 
Note: Make sure that columns containing the key column data (in our example - 
structure IDs) and the data you would like to view in the virtual column (for example, 
molecular structures) are included in the information link.  

9. Click OK. 
10. Make sure that Show as is set to your current structure renderer. For example, 

Symyx® Draw (MDL). 
11. Click Close. 

► To show structures from the loaded data in tooltips: 
Most visualizations can display images from a binary image column, a shape file, or chemical 
structures in tooltips. 

1. Open the Properties dialog for the visualization. 
Comment: This is done by right-clicking on the visualization and selecting Properties 
from the pop-up menu. 

2. Click on the Tooltip page in the list on the left. 
Response: The Tooltip page is displayed. 

3. Click on the Add... button. 
Response: The Add Tooltip Value dialog is displayed. 

4. Select the structure Column of interest. 
5. Type a Name to display. 

Comment: This is the text that will be shown together with the expression value in the 
tooltip, and also what will be shown in the list of available tooltip values. 

6. Make sure that Get content from is set to (Selected column). 
Comment:  
Make sure that Show as is set to your current structure renderer. For example, 
Symyx® Draw (MDL). 

7. If desired, change the Size of the tooltip image by moving the slider, 
8. Clear the Include value name in tooltip check box if you only want to display the 

image in the tooltip and not the name. 
9. Click OK. 
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Response: The Add Tooltip Value dialog is closed and the newly added value is shown 
in the Tooltip property page. 

10. Click Close. 

► To show structures from an information link in tooltips: 
Most visualizations can display images from a binary image column, a shape file, or chemical 
structures in tooltips. 

1. Open the Properties dialog for the visualization. 
Comment: This is done by right-clicking on the visualization and selecting Properties 
from the pop-up menu. 

2. Click on the Tooltip page in the list on the left. 
Response: The Tooltip page is displayed. 

3. Click on the Add... button. 
Response: The Add Tooltip Value dialog is displayed. 

4. Select an identifier Column. 
Comment: Here you select the identifier column in your data table that will be used to 
match the identifier in the information link from which structures are to be retrieved. 

5. Type a Name to display. 
Comment: This is the text that will be shown together with the expression value in the 
tooltip, and also what will be shown in the list of available tooltip values. 

6. Select Get content from: Structure Column. 
Comment: This specifies that rather than displaying the information from the selected 
Label by column directly, the selected column will be used as an identifier when 
retrieving data from an information link. 
Click on the Settings... button next to Get content from. 
Response: The Structure Column Settings dialog is displayed. 

7. Make sure that the correct Key column is selected, then click Browse.... 
Response: The Open from Library dialog is displayed. 

8. Click to select the information link containing your structures and then click Open. 
Note: Make sure that columns containing the key column data (in our example - 
structure IDs) and the data you would like to view in the virtual column (for example, 
molecular structures) are included in the information link.  

9. Click OK. 
10. Make sure that Show as is set to your current structure renderer. For example, 

Symyx® Draw (MDL). 
11. If desired, change the Size of the tooltip image by moving the slider, 
12. Clear the Include value name in tooltip check box if you only want to display the 

image in the tooltip and not the name. 
13. Click OK. 

Response: The Add Tooltip Value dialog is closed and the newly added value is shown 
in the Tooltip property page. 

14. Click Close. 
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5 Settings 
5.1 Supported Renderers 

TIBCO Spotfire Lead Discovery modules provide support for several different renderers to 
display molecular structures. See the system requirements for TIBCO Spotfire Lead Discovery 
on http://support.spotfire.com/sr.asp for more information. However, note that a few of the 
supported renderers can only be used to render structures in the table visualization and the 
Structure Viewer; they cannot be used to edit structures in the Structure Search tool. You can 
add one or more of these renderers to the list of default renderers, select any of them as default 
for a content type, and change the renderer settings. 

► To add a renderer to the list of default renderers: 
1. Select Tools > Options. 
2. Select the Application tab. 
3. Click the Renderer Settings... button. 
4. Click Add.... 

Response: The Add Default Renderer dialog is displayed. 
5. Specify the Content type and select the default renderer from the drop-down list in the 

dialog. 
Comment: You can only specify one default renderer per content type. See the table 
below for a description of content types. 

► To change the default renderer for a certain content type: 
1. Select Tools > Options. 
2. Select the Application tab. 
3. Click the Renderer Settings... button. 
4. Click to select the content type of interest and then click Edit.... 

Response: The Edit Default Renderer dialog is displayed. 
5. Select a new default renderer from the drop-down list. 

Note: The content type you enter can be an arbitrary string, but it is recommended that you use 
the MIME types defined for molfiles, CHIME strings, and SMILES strings as shown in the 
table below. 

Structure Format Content Type 

MDL molfile chemical/x-mdl-molfile 

MDL Chime string chemical/x-mdl-chime 

Daylight SMILEs string chemical/x-daylight-smiles 

► To change the renderer and/or renderer settings for the 
structures displayed in the table visualization: 
1. Right-click on a row in the table visualization and select Properties > Columns. 
2. Select the column that contains chemical structures. 
3. In the Renderer drop-down list, select the renderer to use. 
4. Click the Settings... button to change the renderer settings. 

Response: The Renderer Settings dialog for the currently used renderer is displayed. 
5. Change the renderer settings and click OK. 
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► To change the renderer used in Structure Viewer: 
1. In the Structure Viewer pane of the Structure Viewer, right-click on the structure. 
2. Select Renderer. 
3. Select the renderer to use. 

► To edit the renderer settings in Structure Viewer: 
1. In the Structure Viewer pane of the Structure Viewer, right-click on the structure. 
2. Select Renderer > Settings.... 

Response: The Renderer Settings dialog for the currently used renderer is displayed. 
3. Change the renderer settings and click OK. 

5.2 Renderer Settings 
The renderer is the program that is responsible for the display of structures in Structure Viewer, 
Structure Search and when structures are shown in a visualization. 
Note: Other structure renderers may display different type of settings, hence, the dialog you see 
may look different from the example shown here. 

 

► To reach the Structure Renderer Settings dialog from a table 
visualization with structures: 
1. Right-click on a row in the table visualization and select Properties > Columns. 
2. Select the column that contains chemical structures. 
3. Click on the Settings... button. 

► To reach the Structure Renderer Settings dialog from Structure 
Viewer: 
1. In the Structure Viewer pane of the Structure Viewer, right-click on the structure. 
2. Select Renderer > Settings.... 
3. Response: The Renderer Settings dialog for the currently used renderer is displayed. 
4. Change the renderer settings and click OK. 
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Option Description 

Structure string Select the format of the structure string. The supported formats are 
MDL molfile, MDL Chime, and Daylight SMILES. 

Show Hydrogens Changes the hydrogen display settings. 
Possible options: 
For Symyx® Draw (MDL) - Off, Hetero, Terminal, 
HeteroOrTerminal, All 
For ChemDraw - True, False 
For Accord - True, False 
For Marvin - Off, Hetero, HeteroOrTerminal, All 
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6 Glossary 
  

Column  
A vertical list of values in a data table. 
  

Column Name 
The name of a column as displayed in the user interface. It is a normalized, trimmed, and 
unique text string. It is initially set to a tidied form of the external name, but it may be modified 
through a Rename Column operation. 
  

Data Source 
A handle to an external data source, such as a file or information link. A data source produces a 
single table of data. 
  

Data Table 
A data table in TIBCO Spotfire is defined as either data loaded from an external source, or new 
data created within the application. It has one or more columns and zero or more rows. A 
visualization is based on a single data table. 
Data tables loaded from an external source can be linked or embedded. Linked data tables can 
be loaded completely into the application, but if the source is an information link they can also 
be configured to load data on demand only. 
Data tables can be related to each other, using primary and/or foreign keys (key columns), but 
they can also be unrelated. 
  

Details-on-Demand 
The concept of expanding a small set of items to reveal more data behind it.   
  

DXP File 
The file type used for analysis files created with TIBCO Spotfire. Can be saved to disk and to 
the library. Defines what data to include and how to present it. Can include linked or embedded 
data based on user settings when saving the file. Includes one or more pages. There can only be 
one analysis file open at a time, but it is possible to run several instances of TIBCO Spotfire 
simultaneously, and one analysis file can also contain several data tables. 
  

Filter 
Used to reduce the amount of data to work on in TIBCO Spotfire. The same as Query Devices 
in TIBCO Spotfire DecisionSite. Filters can be either column filters, directly related to a 
column, or hierarchy filters (tree filters) which represent a hierarchy. Filters can be grouped into 
folders in the Filters panel. 
  

ID column 
A column in the table that contains structure identifiers. 
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ID list 
A list of structure identifiers. 
  

Information Link 
Information links are predefined database queries, specifying the columns to be loaded, and any 
filters needed to reduce the size of the data table prior to visualization. 
  

Library 
The library is a space on the server where you can publish or open shared analysis files. 
Information links and the elements used to create information links are also stored in the library. 
  

Marked Row 
An item in a visualization becomes marked when you click on it, or, when it is captured using 
the rectangle method (left mouse button pressed while moving pointer). Marked rows are given 
a definable color to distinguish them from the rest of the data. 
  

Marked Rows list 
A dynamic list in the Structure Viewer called "Marked Rows" that contains the marked rows in 
the active visualization. 
  

Marking 
A marking identifies marked rows in the data tables of an analysis. If the data tables are related, 
the marked rows are propagated using the specified key relation between the data tables. Setting 
a marking in one data table does not affect the marking of unrelated data tables. Each analysis 
can hold multiple markings and each marking has its own marking color. One or more markings 
can be used to limit what data are displayed in a visualization. 
  

Page 
A page can be thought of as a "container" for visualizations, filters, a Details-on-Demand, etc. 
Pages make it possible to set up several sheets of visualizations that you can switch between in 
an analysis. Pages can contain visualizations and text areas that guide you through the analysis. 
Visualizations can only exist inside a page (they cannot be dragged outside even partly).  
All visualizations in an analysis can be linked, both within and between pages, but they do not 
have to be. The visualizations on a page use one or more filtering schemes, and the filtering 
schemes determine whether visualizations are linked or not. The visualizations in a page can use 
one or several data tables. 
  

Personalized Information Links 
A personalized information link returns a subset of data depending on which user is logged in. 
See more details in the TIBCO Spotfire online help. 
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Row 
A horizontal list of values in a data table. 
  

Structure Viewer 
The Structure Viewer can be used to display structures of the marked compounds in the 
visualizations. It can also be used to manage and view lists from various structure searches. 
  

Structure Search 
A tool used to search for compounds similar to or containing a specified master structure.  
  

Table 
A visualization with information arranged in rows and columns. 
  

Table Column 
A vertical list of values in a table. 
  

Table Column Header 
An area used to identify a table column. 
  

Table Row 
A horizontal list of values in a table. 
  

Table Row Header 
An area used to identify a table row. 
  

URL 
Uniform Resource Locator. (A world wide web address.) 
  

Visualization 
A representation of some data in TIBCO Spotfire. For example, a table, a bar chart, a pie chart, 
etc. A visualization displays data from one data table. The data displayed can be limited by one 
or more filtering schemes and by zero, one or several markings. A visualization shows and 
allows modification to one marking. 
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