Getting Started with TIBCO Spotfire S+® 8.2 for Windows®

November 2010

TIBCO Software Inc.
IMPORTANT INFORMATION

SOME TIBCO SOFTWARE EMBEDS OR BUNDLES OTHER TIBCO SOFTWARE. USE OF SUCH EMBEDDED OR BUNDLED TIBCO SOFTWARE IS SOLELY TO ENABLE THE FUNCTIONALITY (OR PROVIDE LIMITED ADD-ON FUNCTIONALITY) OF THE LICENSED TIBCO SOFTWARE. THE EMBEDDED OR BUNDLED SOFTWARE IS NOT LICENSED TO BE USED OR ACCESSED BY ANY OTHER TIBCO SOFTWARE OR FOR ANY OTHER PURPOSE.

USE OF TIBCO SOFTWARE AND THIS DOCUMENT IS SUBJECT TO THE TERMS AND CONDITIONS OF A LICENSE AGREEMENT FOUND IN EITHER A SEPARATELY EXECUTED SOFTWARE LICENSE AGREEMENT, OR, IF THERE IS NO SUCH SEPARATE AGREEMENT, THE CLICKWRAP END USER LICENSE AGREEMENT WHICH IS DISPLAYED DURING DOWNLOAD OR INSTALLATION OF THE SOFTWARE (AND WHICH IS DUPLICATED IN TIBCO SPOTFIRE S+® LICENSES). USE OF THIS DOCUMENT IS SUBJECT TO THOSE TERMS AND CONDITIONS, AND YOUR USE HEREOF SHALL CONSTITUTE ACCEPTANCE OF AND AN AGREEMENT TO BE BOUND BY THE SAME.

This document contains confidential information that is subject to U.S. and international copyright laws and treaties. No part of this document may be reproduced in any form without the written authorization of TIBCO Software Inc.

TIBCO Software Inc., TIBCO, Spotfire, TIBCO Spotfire S+, Insightful, the Insightful logo, the tagline "the Knowledge to Act," Insightful Miner, S+, S-PLUS, TIBCO Spotfire Axum, S+ArrayAnalyzer, S+EnvironmentalStats, S+FinMetrics, S+NuOpt, S+SeqTrial, S+SpatialStats, S+Wavelets, S-PLUS Graphlets, Graphlet, Spotfire S+ FlexBayes, Spotfire S+ Resample, TIBCO Spotfire Miner, TIBCO Spotfire S+ Server, TIBCO Spotfire Statistics Services, and TIBCO Spotfire Clinical Graphics are either registered trademarks or trademarks of TIBCO Software Inc. and/or subsidiaries of TIBCO Software Inc. in the United States and/or other countries. All other product and company names and marks mentioned in this document are the property of their respective owners and are mentioned for identification purposes only. This
software may be available on multiple operating systems. However, not all operating system platforms for a specific software version are released at the same time. Please see the readme.txt file for the availability of this software version on a specific operating system platform.

THIS DOCUMENT IS PROVIDED “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THIS DOCUMENT COULD INCLUDE TECHNICAL INACCURACIES OR TYPOGRAPHICAL ERRORS. CHANGES ARE PERIODICALLY ADDED TO THE INFORMATION HEREIN; THESE CHANGES WILL BE INCORPORATED IN NEW EDITIONS OF THIS DOCUMENT. TIBCO SOFTWARE INC. MAY MAKE IMPROVEMENTS AND/OR CHANGES IN THE PRODUCT(S) AND/OR THE PROGRAM(S) DESCRIBED IN THIS DOCUMENT AT ANY TIME.

Copyright © 1996-2010 TIBCO Software Inc. ALL RIGHTS RESERVED. THE CONTENTS OF THIS DOCUMENT MAY BE MODIFIED AND/OR QUALIFIED, DIRECTLY OR INDIRECTLY, BY OTHER DOCUMENTATION WHICH ACCOMPANIES THIS SOFTWARE, INCLUDING BUT NOT LIMITED TO ANY RELEASE NOTES AND "READ ME" FILES.

TIBCO Software Inc. Confidential Information

Reference
The correct bibliographic reference for this document is as follows:

Getting Started with TIBCO Spotfire S+® 8.2 for Windows® TIBCO Software Inc.

Technical Support
For technical support, please visit http://spotfire.tibco.com/support and register for a support account.
TIBCO SPOTFIRE S+ BOOKS

Note about Naming

Throughout the documentation, we have attempted to distinguish between the language (S-PLUS) and the product (Spotfire S+).

- “S-PLUS” refers to the engine, the language, and its constituents (that is objects, functions, expressions, and so forth).
- “Spotfire S+” refers to all and any parts of the product beyond the language, including the product user interfaces, libraries, and documentation, as well as general product and language behavior.

The TIBCO Spotfire S+® documentation includes books to address your focus and knowledge level. Review the following table to help you choose the Spotfire S+ book that meets your needs. These books are available in PDF format in the following locations:

- In your Spotfire S+ installation directory (SHOME\help on Windows, SHOME/doc on UNIX/Linux).
- In the Spotfire S+ Workbench, from the Help ➤ Spotfire S+ Manuals menu item.
- In Microsoft® Windows®, in the Spotfire S+ GUI, from the Help ➤ Online Manuals menu item.

<table>
<thead>
<tr>
<th>Information you need if you...</th>
<th>See the...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Must install or configure your current installation of Spotfire S+; review system requirements.</td>
<td>Installation and Administration Guide</td>
</tr>
<tr>
<td>Want to review the third-party products included in Spotfire S+, along with their legal notices and licenses.</td>
<td>Licenses</td>
</tr>
</tbody>
</table>
**Spotfire S+ documentation. (Continued)**

<table>
<thead>
<tr>
<th>Information you need if you...</th>
<th>See the...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Are new to the S language and the Spotfire S+ GUI, and you want an introduction to importing data, producing simple graphs, applying statistical models, and viewing data in Microsoft Excel®.</td>
<td><em>Getting Started Guide</em></td>
</tr>
<tr>
<td>Are a new Spotfire S+ user and need how to use Spotfire S+, primarily through the GUI.</td>
<td><em>User’s Guide</em></td>
</tr>
<tr>
<td>Are familiar with the S language and Spotfire S+, and you want to use the Spotfire S+ plug-in, or customization, of the Eclipse Integrated Development Environment (IDE).</td>
<td><em>Spotfire S+ Workbench User’s Guide</em></td>
</tr>
<tr>
<td>Have used the S language and Spotfire S+, and you want to know how to write, debug, and program functions from the <strong>Commands</strong> window.</td>
<td><em>Programmer’s Guide</em></td>
</tr>
<tr>
<td>Are familiar with the S language and Spotfire S+, and you want to extend its functionality in your own application or within Spotfire S+.</td>
<td><em>Application Developer’s Guide</em></td>
</tr>
<tr>
<td>Are familiar with the S language and Spotfire S+, and you are looking for information about creating or editing graphics, either from a <strong>Commands</strong> window or the Windows GUI, or using Spotfire S+ supported graphics devices.</td>
<td><em>Guide to Graphics</em></td>
</tr>
<tr>
<td>Are familiar with the S language and Spotfire S+, and you want to use the Big Data library to import and manipulate very large data sets.</td>
<td><em>Big Data User’s Guide</em></td>
</tr>
<tr>
<td>Want to download or create Spotfire S+ packages for submission to the Comprehensive S-PLUS Archive Network (CSAN) site, and need to know the steps.</td>
<td><em>Guide to Packages</em></td>
</tr>
<tr>
<td>Information you need if you...</td>
<td>See the...</td>
</tr>
<tr>
<td>---------------------------------------------------------------------------------------------</td>
<td>-------------------------------------</td>
</tr>
<tr>
<td>Are looking for categorized information about individual S-PLUS functions.</td>
<td><strong>Function Guide</strong></td>
</tr>
<tr>
<td>If you are familiar with the S language and Spotfire S+, and you need a reference for the range of statistical modelling and analysis techniques in Spotfire S+. Volume 1 includes information on specifying models in Spotfire S+, on probability, on estimation and inference, on regression and smoothing, and on analysis of variance.</td>
<td><strong>Guide to Statistics, Vol. 1</strong></td>
</tr>
<tr>
<td>If you are familiar with the S language and Spotfire S+, and you need a reference for the range of statistical modelling and analysis techniques in Spotfire S+. Volume 2 includes information on multivariate techniques, time series analysis, survival analysis, resampling techniques, and mathematical computing in Spotfire S+.</td>
<td><strong>Guide to Statistics, Vol. 2</strong></td>
</tr>
</tbody>
</table>
## CONTENTS

### Chapter 1  Quick Tour  
1

Overview  
2
Getting Data  
3
Creating a 2D Graph  
5
Performing a Linear Regression  
7
Identifying and Labeling Data Points  
10
Editing a Graph  
12
Creating a 3D Graph  
13
Viewing Objects and Databases  
16
Organizing Your Work  
18

### Chapter 2  Extended Tour  
21

Importing a File  
23
Editing Variable Names and Adding Descriptions  
25
  Variable Names  
25
  Column Descriptions  
25
Creating a 2D Graph  
26
Changing Graph Features  
27
  Axes and Labels  
27
  Plot Properties  
27
  Titles  
28
Contents

Using Trellis Graphics for Multipanel Conditioning 29
Highlighting Data Points 32
Extracting Graph Panels 33
Applying Statistical Models 35
   Summaries 35
   Linear Models 36
Doing More With Graphics 38
   Varying 2D Axes Types 38
   Creating Graphs With Multiple Axes 39
Embedding and Extracting Data in **Graph Sheets** 45
Creating a Graph Using the **Object Explorer** 46
   Editing a Plot in the **Object Explorer** 47
   Viewing Plots in Separate Panels 47
   Removing Outliers 48
Creating a 3D Graph 49
   Adding Color Draping 50
Creating PowerPoint Slides 51
Using Spotfire S+ With Microsoft Excel 52
   Creating Excel Data Inside Spotfire S+ 52
   Plotting Excel Data 53
   Analyzing Excel Data 53
Using the S-PLUS Language 56
   S-PLUS Language Basics 56
   Listing Objects 57
   Fitting a Linear Model 58
   Running a Spotfire S+ Script 58
Finding and Downloading Packages 60
Getting Help in Spotfire S+ 61
HTML Help 61
Help in the Commands and Script Windows 63

Chapter 3 Summary of Basic Procedures 65
Using Menus 66
Main Menus 66
Shortcut (Right-Click) Menus 66
Using Dialog boxes 67
The Apply Button 67
The Dialog Rollback Buttons 68
Typing and Editing in Dialog Boxes 68
Using Toolbars and Palettes 70
ToolTips 70
DataTips 71
Selecting Data 72
Using the Select Data Dialog Box 72
Using the Object Explorer 72
Importing Data 73
Selecting Variables to Plot 74
Selecting Variables in a Data Window 74
Selecting Variables in the Object Explorer 74
Creating Plots 75
Selecting Graph Objects 76

Index 79
Contents
## QUICK TOUR

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overview</td>
<td>2</td>
</tr>
<tr>
<td>Getting Data</td>
<td>3</td>
</tr>
<tr>
<td>Creating a 2D Graph</td>
<td>5</td>
</tr>
<tr>
<td>Performing a Linear Regression</td>
<td>7</td>
</tr>
<tr>
<td>Identifying and Labeling Data Points</td>
<td>10</td>
</tr>
<tr>
<td>Editing a Graph</td>
<td>12</td>
</tr>
<tr>
<td>Creating a 3D Graph</td>
<td>13</td>
</tr>
<tr>
<td>Viewing Objects and Databases</td>
<td>16</td>
</tr>
<tr>
<td>Organizing Your Work</td>
<td>18</td>
</tr>
</tbody>
</table>
OVERVIEW

TIBCO Spotfire S+ is designed to work seamlessly with the software you already use. You can import data from and export data to many sources, including spreadsheets such as Excel and Lotus, databases such as Access, analytical software such as SAS and SPSS, and the financial databases Bloomberg, LIM, and FAME. Once you have accessed your data, you can analyze and explore them.

This quick tour briefly introduces you to many of the commonly-used procedures in Spotfire S+.
GETTING DATA

In this exercise, walk through a Spotfire S+ session using some built-in sample data to help you decide which car to buy.

1. From the main menu, click **Data ▶ Select Data** to display the **Select Data** dialog box, as shown in Figure 1.1.

   ![Select Data dialog box](image)
   
   **Figure 1.1**: *The Select Data dialog box.*

2. In the **Source** group, **Existing Data** is selected by default. In the **Name** box of the **Existing Data** group, type **fuel.frame**. (Disregard the **Exclude big data objects** check box)

3. Click **OK** to load the data into a **Data** window.

   ![fuel.frame data](image)
   
   **Figure 1.2**: *The fuel.frame data.*
Chapter 1  Quick Tour

The `fuel.frame` data set consists of five data columns plus a column of row names:

- **Weight**: Automobile weight in pounds
- **Disp.**: Engine displacement in cubic inches
- **Mileage**: Mileage in miles per gallon
- **Fuel**: 100/Mileage
- **Type**: Category of vehicle (Large, Medium, Small, Compact, Sporty, Van)

Spotfire S+ contains eight column types: character, complex, double, factor, integer, logical, single, and `timeDate`. To see a DataTip displaying a column’s type, pause your cursor over the column number.

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>4</td>
<td>5</td>
<td>6</td>
</tr>
<tr>
<td>Fuel</td>
<td>Type</td>
<td>100/Mileage</td>
</tr>
<tr>
<td>3.03</td>
<td>Small</td>
<td></td>
</tr>
</tbody>
</table>

Notice that **Type** is a factor column representing *categorical* data.
CREATING A 2D GRAPH

To create a graph in Spotfire S+, select the data columns, and then click a plot button.

1. Select all the columns of fuel.frame (from Weight to Type) by clicking and dragging the mouse across the column headers.

2. On the Standard toolbar, click the 2D Plots button to open a palette of available 2D plot types.

3. Click Scatter Matrix on the Plots 2D palette.

As shown in Figure 1.5, the resulting scatterplot matrix displays each column of data against the other selected columns. For example, to see how Mileage and Fuel are related, read across from Mileage and above Fuel to see the plot. The plot shows that Mileage and Fuel are related directly. Also, you can see a strong relationship between Mileage and Weight: heavier cars have lower mileage.

Note

Spotfire S+ palettes and toolbars can be docked in place, dragged and dropped to create a floating palette, or resized by dragging an edge.
Figure 1.5: The scatterplot matrix shows a number of strong relationships.
PERFORMING A LINEAR REGRESSION

In this exercise, examine the relationship between Weight and Mileage more extensively.

1. Close the Graph Sheet containing the scatterplot matrix. (No need to save it.)

2. In the Data window, click the column header of Weight, and then CTRL-click the column header of Mileage so that both columns are highlighted.

3. Click the Linear Fit button on the Plots 2D palette.

Figure 1.6: The Linear Fit button on the Plots 2D palette.

Figure 1.7: Linear fit of Mileage vs. Weight.
As shown in Figure 1.7, this linear fit shows an obvious relationship between an increase in \textit{Weight} and a decrease in \textit{Mileage}.

To examine how vans or compact cars fit into this example, use Trellis graphics to condition \textit{Weight} and \textit{Mileage} on a third variable, \textit{Type}.

4. From the main menu, click \textbf{Window} $\Rightarrow$ \textbf{Tile Vertical} (or press \texttt{CTRL-SHIFT-V}) to tile the \textbf{Graph Sheet} and \textbf{Data} window vertically and side by side.

5. Click the \texttt{Type} column header. (With the windows tiled vertically, you might have to scroll the \textbf{Data} window to locate the \texttt{Type} column.)

6. Position your mouse pointer in the data area (not the header area) of the \texttt{Type} column; the cursor becomes a white pointer arrow. (If positioned in the column header, the cursor becomes a black down arrow.)

7. Click and drag the column to the top of the \textbf{Graph Sheet} until a rectangle marked by dashed lines appears. A boxed plus sign beneath the mouse cursor indicates that you have positioned the cursor correctly, as shown in Figure 1.8. Release the mouse button to drop the column into this rectangle and create the Trellis graph.

\begin{figure}[h]
\centering
\includegraphics[width=0.4\textwidth]{fig1_8.png}
\caption{Drag and drop to create Trellis graphs.}
\end{figure}

See Figure 1.9 for the resulting plot. Notice that the data are divided into subsamples and conditioned by \texttt{Type}. Now you can see additional relationships:

- \textit{Sporty} cars, normally assumed to be gas guzzlers, actually have among the highest mileage, along with \textit{Small} cars.
Performing a Linear Regression

- Compact and Medium cars, often touted for higher mileage, get gas mileage similar to Large cars.

Figure 1.9: A Trellis view of the fuel.frame data.
IDENTIFYING AND LABELING DATA POINTS

In this exercise, identify which cars have the best and worst mileage by labeling the data points.

1. Point the mouse cursor at any data point in the graph. A DataTip (similar to a ToolTip) appears, displaying the vehicle’s model, weight, and mileage.

2. Making sure that the Graph Sheet is in focus (so that the Graph toolbar is displayed), click the Graph Tools button on the Graph toolbar to open the Graph Tools palette, as shown in Figure 1.10.

3. Click the Label Point button on the Graph Tools palette.

Figure 1.10: The Graph Tools button on the Graph toolbar.

Figure 1.11: The Label Point button on the Graph Tools palette.
4. Click any data point. The data point is labeled with the car description (the row name) and the values of the plotted columns at that point. For example, if you click the uppermost data point in the Large cars panel, you see the following label:

<table>
<thead>
<tr>
<th>Type: Large</th>
</tr>
</thead>
<tbody>
<tr>
<td>Buick LeSabre V6</td>
</tr>
<tr>
<td>Weight = 3325.00</td>
</tr>
<tr>
<td>Mileage = 23.00</td>
</tr>
</tbody>
</table>

SHIFT-click additional points to label multiple points at once.

5. Click the Select Tool button on the Graph Tools palette and delete the labels by selecting them and pressing DELETE.

6. Change the contents of the DataTips and labels.

7. Right-click any data point in the plot and select Data to Plot from the shortcut menu.

8. In the DataTips and Point Labels group, expand the Column list.

9. Click <ROWNAME> and then CTRL-click Disp.

The model name and engine displacement are displayed in the DataTips.
EDITING A GRAPH

Imagine that you want to include your graph in a report or presentation. In that case, you might want to modify further the graph’s attributes.

In Spotfire S+, graphics are object-oriented, meaning you have complete control over every detail. You can modify graph objects using shortcut menus, dialog boxes, or the toolbar.

1. On the graph, click the x-axis title and then SHIFT-click the y-axis title to select both titles. Each axis title is surrounded by green knobs, indicating that it is selected.

2. Use the Graph toolbar to change the font size to 20.

3. Click any data point to select the plot. A single green square appears on the plot indicating that it is selected.

4. Change the plot color to red. On the Graph toolbar, click the Line Color button and select Red from the dropdown menu (see Figure 1.12).

![Figure 1.12: The Line Color button can be used to change text color as well as line color.](image)
CREATING A 3D GRAPH

Spotfire S+ offers a variety of 3D plot types for data visualization. First, load some 3D data.

1. Close all open windows and palettes. (You do not need to save any Graph Sheets.)

2. From the main menu, choose Data ▶ Select Data to display the Select Data dialog box.

3. In the Existing Data group, type galaxy in the Name box.

4. Click OK to load the data into a Data window.

The galaxy data set contains measurements of the radial velocity of a spiral galaxy measured at 323 points in the sky.

5. Select the data columns east.west, north.south, and velocity by CTRL-clicking each column header.
6. On the **Standard** toolbar, click the **3D Plots** button \[\text{button}\] to open a palette of available 3D plot types.

![3D Plots button on the Standard toolbar.](image1.png)

**Figure 1.14:** *The 3D Plots button on the Standard toolbar.*

7. Click the **3D Scatter** button \[\text{button}\] on the **Plots 3D** palette.

![3D Scatter button on the Plots 3D palette.](image2.png)

**Figure 1.15:** *The 3D Scatter button on the Plots 3D palette.*

The resulting graph is shown in Figure 1.16.

![A three-dimensional scatter plot of the galaxy data.](image3.png)

**Figure 1.16:** *A three-dimensional scatter plot of the galaxy data.*
Creating a 3D Graph

You can rotate the 3D graph interactively, both horizontally and vertically.

8. Click an empty space (but not a data point) within the plot area to select the invisible 3D workbox. Four green circles and a green triangle appear, indicating the workbox is selected.

9. Drag one of the green circles to rotate the plot horizontally. When you release the mouse, the graph is redrawn at the new perspective. You can drag the green triangle up and down to rotate the graph vertically.

10. Click one of the plotted data points to select the scatter plot. A single green box appears, indicating that the plot is selected.

11. Click the 4 Panel Rotation button on the Plots 3D palette. The resulting plot is shown in Figure 1.17.

<table>
<thead>
<tr>
<th>X Angle = 60</th>
<th>X Angle = 150</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Graph 1]</td>
<td>![Graph 2]</td>
</tr>
<tr>
<td>![Graph 3]</td>
<td>![Graph 4]</td>
</tr>
</tbody>
</table>

**Figure 1.17:** Four-panel rotation of the galaxy data.

12. To rotate the graph, select the 3D workbox in the lower left panel. All the panels rotate together so that you can view your graph from different angles.

13. Close the graph window. You do not need to save the graph.
VIEWING OBJECTS AND DATABASES

The Spotfire S+ Object Explorer is a simple but powerful interface for viewing, editing, manipulating, and organizing your S-PLUS objects.

1. Open the Object Explorer by clicking the Object Explorer button on the Standard toolbar.

The Object Explorer uses folders to organize your objects. The first time you open the Object Explorer, five default folders appear, labeled Data, Graphs, Reports, Scripts, and SearchPath (see Figure 1.19).

Use the Object Explorer to locate the two built-in data sets, fuel.frame and galaxy, that you have used in this quick tour.
2. In the left pane of the **Object Explorer**, click the plus (+) sign to the left of the **SearchPath** icon to expand the **SearchPath** folder.

3. Select the **data** subfolder in the left pane to display its contents in the right pane.

4. Scroll through the right pane to locate the sample data sets `fuel.frame` and `galaxy`.

![Object Explorer](image)

**Figure 1.20:** The contents of the **data** database displayed in the right pane.

The objects displayed in the **SearchPath** folder are Spotfire S+ databases. The first database in the search path is called the **working data** and is the database in which Spotfire S+ automatically saves the data you create and modify during a session. The remaining databases in the search path are the **system databases**, which contain all the functions and data objects that come with Spotfire S+.

The **SearchPath** folder is handy for displaying the contents of any Spotfire S+ database. By selecting a database in the left pane of the **Object Explorer**, you can view its contents in the right pane.
ORGANIZING YOUR WORK

By creating folders in the **Object Explorer**, you can organize the work you do in Spotfire S+. In this exercise, insert a new folder to “contain” those objects associated with our current analysis.

1. Deselect any selected folders or objects by clicking in the white space of the left pane of the **Object Explorer**.

2. Click the **New Folder** button on the **Object Explorer** toolbar, as shown in Figure 1.21.

![Figure 1.21: The New Folder button on the Object Explorer toolbar.](image)

3. Name the folder **Galaxy Project**.

4. Display the contents of the **data** database by selecting it in the left pane under **Search Path**.

5. In the right pane, select the **galaxy** data object by clicking its icon; then drag and drop it into the **Galaxy Project** folder you just created.

6. Click the **Graphs** folder icon to select it; the **Graph Sheet** (GS1) open in your Spotfire S+ session appears in the right pane. (Just as with any folder, you can click the plus (+) sign to the left of the **Graphs** folder icon to expand your **Graph Sheet** in the left pane.)

7. Drag and drop the GS1 object from the right pane into the **Galaxy Project** folder.
8. Select the **Galaxy Project** folder to view its contents in the right pane, as shown in Figure 1.22.

**Figure 1.22:** Use the **Object Explorer** to view and organize the contents of your session.
Chapter 1 Quick Tour
# EXTENDED TOUR

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Importing a File</td>
<td>23</td>
</tr>
<tr>
<td>Editing Variable Names and Adding Descriptions</td>
<td>25</td>
</tr>
<tr>
<td>Variable Names</td>
<td>25</td>
</tr>
<tr>
<td>Column Descriptions</td>
<td>25</td>
</tr>
<tr>
<td>Creating a 2D Graph</td>
<td>26</td>
</tr>
<tr>
<td>Changing Graph Features</td>
<td>27</td>
</tr>
<tr>
<td>Axes and Labels</td>
<td>27</td>
</tr>
<tr>
<td>Plot Properties</td>
<td>27</td>
</tr>
<tr>
<td>Titles</td>
<td>28</td>
</tr>
<tr>
<td>Using Trellis Graphics for Multipanel Conditioning</td>
<td>29</td>
</tr>
<tr>
<td>Highlighting Data Points</td>
<td>32</td>
</tr>
<tr>
<td>Extracting Graph Panels</td>
<td>33</td>
</tr>
<tr>
<td>Applying Statistical Models</td>
<td>35</td>
</tr>
<tr>
<td>Summaries</td>
<td>35</td>
</tr>
<tr>
<td>Linear Models</td>
<td>36</td>
</tr>
<tr>
<td>Doing More With Graphics</td>
<td>38</td>
</tr>
<tr>
<td>Varying 2D Axes Types</td>
<td>38</td>
</tr>
<tr>
<td>Creating Graphs With Multiple Axes</td>
<td>39</td>
</tr>
<tr>
<td>Embedding and Extracting Data in Graph Sheets</td>
<td>45</td>
</tr>
<tr>
<td>Creating a Graph Using the Object Explorer</td>
<td>46</td>
</tr>
<tr>
<td>Editing a Plot in the Object Explorer</td>
<td>47</td>
</tr>
<tr>
<td>Viewing Plots in Separate Panels</td>
<td>47</td>
</tr>
<tr>
<td>Removing Outliers</td>
<td>48</td>
</tr>
<tr>
<td>Creating a 3D Graph</td>
<td>49</td>
</tr>
<tr>
<td>Adding Color Draping</td>
<td>50</td>
</tr>
</tbody>
</table>
Chapter 2 Extended Tour

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Creating PowerPoint Slides</td>
<td>51</td>
</tr>
<tr>
<td>Using Spotfire S+ With Microsoft Excel</td>
<td>52</td>
</tr>
<tr>
<td>Creating Excel Data Inside Spotfire S+</td>
<td>52</td>
</tr>
<tr>
<td>Plotting Excel Data</td>
<td>53</td>
</tr>
<tr>
<td>Analyzing Excel Data</td>
<td>53</td>
</tr>
<tr>
<td>Using the S-PLUS Language</td>
<td>56</td>
</tr>
<tr>
<td>S-PLUS Language Basics</td>
<td>56</td>
</tr>
<tr>
<td>Listing Objects</td>
<td>57</td>
</tr>
<tr>
<td>Fitting a Linear Model</td>
<td>58</td>
</tr>
<tr>
<td>Running a Spotfire S+ Script</td>
<td>58</td>
</tr>
<tr>
<td>Finding and Downloading Packages</td>
<td>60</td>
</tr>
<tr>
<td>Getting Help in Spotfire S+</td>
<td>61</td>
</tr>
<tr>
<td>HTML Help</td>
<td>61</td>
</tr>
<tr>
<td>Help in the Commands and Script Windows</td>
<td>63</td>
</tr>
</tbody>
</table>
IMPORTING A FILE

We begin this extended example by importing data from a SAS file. If you have any windows or palettes open from the preceding tutorial, close them before continuing.

To import the data:

1. From the main menu, choose File ▶ Import Data ▶ From File. The Import From File dialog box opens, as shown in Figure 2.1.

   ![Import From File dialog box](image)

   **Figure 2.1:** The Import From File dialog box.

2. Click **Browse**, navigate to the \library\example5 folder in your TIBCO Spotfire S+ program folder, select **exenvirn.sd2** as the file to import, and click **OK**.

3. Click **OK** in the dialog box to import the data.
The exenvirn data set contains measurements on ozone concentration, solar radiation, daily maximum temperature, and wind speed on 111 days in 1973 in the New York metropolitan area.

Figure 2.2: The imported exenvirn data.
EDITING VARIABLE NAMES AND ADDING DESCRIPTIONS

**Variable Names**

Notice that the imported SAS file has variable names that are at most eight characters long. In Spotfire S+, variable names are more flexible, so in this exercise, modify the variable names before creating a graph.

1. In the **Data** window, double-click the column name for column 2 (radiatio), type **Radiation**, and then click **OK**.

2. Change the column name for column 3 from temperat to **Temperature**.

3. For consistency, change the **ozone** and **wind** column names to **Ozone** and **Wind**, respectively.

**Column Descriptions**

You can store more detailed information about your data set in column descriptions. Column descriptions are automatically used as axis titles when graphing the data.

4. Right-click anywhere in the Radiation column to display the shortcut menu for the column. Select **Properties**.

5. In the **Description** box, type **Solar Radiation (langley)**s and click **OK**.
CREATING A 2D GRAPH

You are ready to visualize the data. First, create a local regression plot of the data.

1. In the Data window, select the Radiation column and then CTRL-click to select Ozone so that both columns are highlighted. (The first column will be the x data, and the second will be the y data.)
2. Click the 2D Plots button to open the Plots 2D palette.
3. Click the Loess button on the Plots 2D palette. A locally weighted, least squares regression is calculated, and the plot is created.
4. Close the Plots 2D palette.
5. Click the maximize button in the upper right corner of the Graph Sheet.
6. Right-click any data point (or the smoothed line) and select Smooth/Sort from the plot’s shortcut menu.

Note

If you do not see a Smooth/Sort option in the shortcut menu, you probably selected another graph object. Try again, making sure you click a data point and not the plot area, an axis, or an axis label. Spotfire S+ indicates selected graphics objects with green knobs. Try clicking different parts of the graph (axis, labels, data, etc.) to see how different graph objects are highlighted with green knobs when they have been selected. See Selecting Graph Objects on page 76 for more details.

7. Try different levels of smoothing. In the Loess/Friedman Specs group, enter values between 0.1 and 0.9 in the Span box and click Apply.
8. Reset the Span to Auto and click OK.
CHANGING GRAPH FEATURES

Spotfire S+ gives you unparalleled control over every detail of your graph, right down to the thickness of the tick marks. You can control all individual line thicknesses, symbol sizes, fonts, colors, titles, tick marks, and axis labels. Additionally, you can create multiple lines of text for comments, titles, and tick labels. Superscript and subscript options are conveniently located on the Graph toolbar for quick access so editing text or equations is easy.

Axes and Labels

1. Click the $y$ axis to select it. (A square green knob appears on the center of the axis if you have properly selected it.)
2. CTRL-click the $x$ axis to select it.
3. From the main menu, choose Format $\rightarrow$ Selected Objects. The Modify All Selected Objects (if applicable) dialog box opens, displaying the Display/Scale page.
4. In the Color box, select Lt Gray.
5. In the Frame box, select With ticks.
6. Click the Grids/Ticks tab. In the Major Ticks group, in the Weight box, select 1.
7. In the Tick Position box, select In.
8. Click OK.

In the following steps, change the $y$-axis title.

9. Click once to select the axis title (green knobs surround the axis title when it is selected), and then click once more to open an in-place edit box.
10. In the text edit box, type Ozone Concentration. Do not press ENTER; rather, click outside the box to accept the change.

Plot Properties

11. Right-click any data point (or the smoothed line) and select Line from the plot’s shortcut menu. (A green knob appears at the bottom of the graph indicating the plot object is selected.)
12. In the Color box, select Black; in the Weight box, select 2.
13. Click the **Symbol** tab to display the **Symbol** page of the dialog box. In the **Style** box, select **Circle, Solid**. In the **Color** box, select **Red**.

14. Click **OK**.

**Titles**

In this section, insert a main title at the top of the graph.

15. From the main menu, choose **Insert ➤ Titles ➤ Main**.

16. In the resulting text edit box, type **The Relationship Between Radiation and Ozone**. Do not press **ENTER**; rather, click outside the title to close the text box.

Use the toolbar to change the font, font size, and color of any text objects in your graph.

17. Select the main title and use the toolbar to specify a font size of 20.

18. Click the **Line Color** button on the **Graph** toolbar and change the text color to **Blue**.

*Figure 2.3: After you change the graph, it looks like this.*

Do not close the **Graph Sheet** or **Data** window; you will use them again shortly.
Suppose you have a data set with multiple variables, and you want to see how plots of two variables change with variations in one or more conditioning variables. Trellis graphics are designed to display your data in a series of panels conditioned upon different values of one or more specified variables. Each panel contains a subset of the original data corresponding to intervals of the conditioning variables.

Most Spotfire S+ graphs can be conditioned. The data columns used for each plot and for the conditioning variable(s) must be of equal length. By default, the axis specifications and panel display attributes (for example, fill color) are identical for each panel.

Apply multipanel conditioning to our previously created loess plot.

1. Make sure that only the windows containing the exenvirn data and your Graph Sheet are open. From the main menu, choose Window ➤ Tile Vertical.

2. In the Data window, select Temperature and then CTRL-click to select Wind.

![Figure 2.4](image)

**Figure 2.4:** Temperature and Wind are dragged to the rectangular drop target at the top of the graph.
3. As illustrated in Figure 2.4, click and hold the mouse in the data area of the columns and then drag and drop them onto the rectangular drop target that appears at the top of the graph.

The resulting Trellis graph (see Figure 2.5) shows how the dependence of Ozone on Radiation varies according to levels of Wind and Temperature.

![The Relationship Between Radiation and Ozone](image)

**Figure 2.5:** Ozone concentration and solar radiation: This graph shows that radiation explains variation in ozone levels beyond that explained by wind speed and temperature.

4. Select the plot by clicking a line or symbol in any one of the panels.

5. Open the **Plots 2D** palette and click the **Linear Fit** button ![Linear Fit](image). A linear regression line replaces the loess curve in each panel, as shown in Figure 2.6. This graph suggests that high temperatures with less wind result in the strongest dependence of ozone on radiation.
Figure 2.6: A linear regression has replaced the loess curve in each panel.
HIGHLIGHTING DATA POINTS

You can highlight data points in the graph and have the same points highlighted in the Data window, as well as in other graphs.

1. To open the Graph Tools palette, click the Graph Tools button in the Graph toolbar.

2. Click the Select Data Points button.

3. Drag around a selection of points in the upper right panel of the graph.

Notice that the selected points are highlighted in both the graph and the Data window. If we had other Graph Sheets open based on these data, the points would also be highlighted in these other graphs.

4. Click an empty part of a panel to remove the selection.
It is easy to “drill down” into a Trellis graph panel using buttons on the **Graph Tools** palette.

1. Click the **Extract Panel** button on the **Graph Tools** palette.
2. Click the lower left panel of the Trellis graph. The panel is extracted and displayed as a full-sized graph, as shown in Figure 2.7.

![The Relationship Between Radiation and Ozone](image)

**Figure 2.7:** *A panel extracted from a Trellis graph.*

3. Click the **Show All Panels** button to restore the Trellis graph.
4. From the main menu, select **File** ▶ **Save As**, and then navigate to your current project folder (typically `C:\Documents and Settings\username\My Documents\Spotfire S+\Project1`). Save the multipanel plot as `mpanel.sgr`.

---

**EXTRACTING GRAPH PANELS**
5. Leave the exenvirn Data window open, but close the Graph Sheet and any open palettes.

**Note**

The data are not saved with the Graph Sheet. When the Graph Sheet is reopened, it redraws using the current data set named exenvirn. To embed the data within the Graph Sheet before saving, choose Graph ➤ Embed Data from the main menu. See the section Embedding and Extracting Data in Graph Sheets on page 45 for more details.
Spotfire S+ provides a vast array of statistical techniques, with the most widely used techniques accessible through dialog boxes launched from the Data and Statistics menus.

All techniques available on the menus are also available through the S-PLUS language. Use commands either interactively in the Commands window, or as script in a Script window. In the course of an analysis, you may find it convenient to begin by fitting a model through a handy dialog box, and then proceed to analyze the model and perform diagnostics through the flexible and powerful S language.

In this section, fit linear regression models to predict ozone using temperature, radiation, and wind.

**Summaries**

Examine the simple summaries of the exenvirn data.

1. From the main menu, choose Statistics ► Data Summaries ► Summary Statistics to display the Summary Statistics dialog box.
2. In the Data group, exenvirn appears by default in the Data Set box.
3. Click OK to display summaries for the data columns in a Report window.
4. From the main menu, choose Statistics ► Data Summaries ► Correlations to display the Correlations and Covariances dialog box.
5. In the Data group, exenvirn appears by default in the Data Set box.
6. Click OK. The correlations for the data columns are added beneath the summaries in the Report window.
7. Close the Report window (do not save it).
In this section, use the **Linear Regression** dialog box to fit a linear model predicting **Ozone** from the other variables.

1. In the **Data** window, select **Ozone**, **Radiation**, **Temperature**, and **Wind**, in that order, by dragging across the column headers.

2. From the main menu, choose **Statistics** > **Regression** > **Linear** to display the **Linear Regression** dialog box.

3. In the **Data** group, **exenvirn** appears by default in the **Data Set** box.

4. In the **Formula** box of the **Variables** group, examine the expression \( \text{Ozone} \sim \text{Radiation} + \text{Temperature} + \text{Wind} \). Listed first is the **response** variable, **Ozone**. This response was chosen because **Ozone** was the first column you selected. The **predictor** variables, shown after the tilde (~), represent the other variables in the order in which they were selected.

5. Click the **Plot** tab to display the **Plot** page.

6. In the **Plots** group, select the **Residuals vs Fit** check box.

7. Click **OK**.

The regression results appear in the **Report** window. In addition, a new **Graph Sheet** displays the diagnostic plot.

---

**Note**

The data used in this plot are embedded within the **Graph Sheet**. Subsequent changes in the **exenvirn** data set will not affect these plots.

---

**The Formula Builder**

Using the **Formula Builder**, you can describe complex regression models by selecting variables and indicating how they are used in the model. For example, you might want to add an interaction term to the model.

8. Close the **Graph Sheet** and the **Report** window and click the **Data** window, outside the selected data, to clear the selection.

9. From the main menu, choose **Statistics** > **Regression** > **Linear** to display the **Linear Regression** dialog box.
10. In the Variables group, from the dropdown list in the Dependent box, select Ozone.

11. Using CTRL-click, select Radiation, Temperature, and Wind from the dropdown list in the Independent box. Notice that the formula reflects your changes.

12. Click the Create Formula button to display the Formula dialog box.

13. In the Variable group, in the Choose Variables box, CTRL-click to select Radiation and Temperature.

14. In the Add group, click Interaction to include the interaction between radiation and temperature as a predictor.

15. Click OK to close the Formula dialog box. The formula you generated appears in the Formula box of the Linear Regression dialog box.

16. Click OK to generate the model.


18. From the main menu, choose Statistics ▶ Regression ▶ Linear to display the Linear Regression dialog box again.

19. Click the Dialog Rollback button (located at the bottom center of the dialog box page, just to the right of the Apply button) to select the previous dialog box state. The previous values for Data Set and Formula are filled in.

20. Click the Results tab to display the Results page of the dialog box.

21. In the Printed Results group, select the ANOVA Table check box. This selection provides an analysis of variance table for the linear model.

22. Click OK. The ANOVA table for the fit appears in the Report window below the regression results.

23. When you finish examining the results, close the Report window and the exenvirn Data window.
DOING MORE WITH GRAPHICS

Varying 2D Axes Types

By default, 2D plots are drawn on linear \( x \) and \( y \) axes. Sometimes it is useful to create plots using a logarithmic or probability scale on one or both axes. You can create such plots by selecting the 2D axis type from the toolbar before selecting the plot type.

1. From the main menu, choose Data ▶ Select Data to display the Select Data dialog box.
2. In the Existing Data group, type Puromycin in the Name box.
3. Click OK to load the data into a Data window.

The Puromycin data set is from a biochemical experiment testing the drug Puromycin. The column conc gives the enzyme concentration of the substrate, and vel is the initial velocity of the reaction. The state variable indicates whether or not the cell has been treated with Puromycin.

4. Select the columns conc, vel, and state by dragging the mouse across the column headers.
5. From the Standard toolbar, choose Log X from the Default 2D Axes Type dropdown list.

![Image of Standard toolbar with Default 2D Axes Type option]

**Figure 2.9:** Changing the default 2D axes type.

6. Open the Plots 2D palette and click the Color button . The treated and untreated cell observations appear in different colors.

7. Make sure the graph is not selected, and then change the Default 2D Axes Type back to Linear.

<table>
<thead>
<tr>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>The Default 2D Axes Type control specifies the default axes type. In this example, if you do not change it back to Linear, subsequent plots will be created on a log scale as well. If your graph is selected when you change the default axes type, the axes type of your selected graph will also be changed.</td>
</tr>
</tbody>
</table>

8. Close the Graph Sheet, the Data window, and the Plots 2D palette.

**Creating Graphs With Multiple Axes**

You can create plots showing different data series, with varying scales, against a single x or y variable. This is often useful in plotting revenue and profit (for example) against time. You can see at a glance whether revenue and profit are rising and falling together or if some more complicated relationship holds.

As a simple example, plot housing starts and manufacturing shipments on a time scale.

1. From the main menu, choose File ➤ Load Library to display the Load Library dialog box, as shown in Figure 2.10.
2. In the **Library Name** box, select **example5** and click **OK** to load the library.

Open the sample data set **econ.df** by using the **Object Explorer**.

3. Click the **Object Explorer** button on the **Standard** toolbar.

4. In the left pane of the **Object Explorer**, click the plus (+) sign to the left of the **SearchPath** icon.

5. Expand the **example5** folder by clicking the plus (+) sign to the left of its icon.

6. Select **econ.df** in the left pane to display its columns in the right pane. Notice that this sample data set contains two columns of class **ts** (*years* and *hstart*) and one column of class **structure** (*ship*).

7. In the left pane of the **Object Explorer**, double-click the icon to the left of **econ.df**.

![Figure 2.10: The Load Library dialog box.](image)

**Figure 2.10:** *The Load Library dialog box.*

![Figure 2.11: Data objects containing columns of certain classes must be opened in read-only mode.](image)

**Figure 2.11:** *Data objects containing columns of certain classes must be opened in read-only mode.*
8. Because econ.df contains columns of class ts and class structure, which are not supported in the Data window (see page 4), Spotfire S+ warns you that it will be opened in read-only mode. Click the **Open read-only** button to continue.

**Hint**

In read-only mode, columns in the Data window are slightly shaded.

9. With econ.df displayed in a read-only Data window, click the **Convert to Data Frame** button on the Data window toolbar, as shown in Figure 2.12.

![Figure 2.12: The Convert to Data Frame button on the Data window toolbar.](image)

10. The **Convert Object to Data Frame** dialog box is displayed, as shown in Figure 2.13.

![Figure 2.13: The Convert Object to Data Frame dialog box.](image)

11. In the **Data Frame Name** text box, type my.econ.

12. Click **OK** to convert the data object and display it in a new Data window.
13. In the my.econ Data window, select the columns years, hstart, and ship by dragging the mouse across the column headers.

14. From the main menu, choose Graph ➤ 2D Plot to display the Insert Graph dialog box.

15. Under Axes Type, select Multiple Y. Under Plot Type, select Scatter Plot (x, y1, y2, ...). Accept the default Graph Sheet, GS1, and click OK.

A plot appears with hstart plotted along the left y axis, ship along the right y axis, both plotted against years along the x axis. You could also create this plot by selecting Multiple Y as the default axes type on the main toolbar, and then clicking the Scatter button on the 2D Plots palette.

16. From the main menu, choose Insert ➤ Legend. A legend appears, along with the Legend dialog box. Click OK to dismiss the dialog box and drag the legend to the upper left of the plot. The resulting graph is shown in Figure 2.15.
Another way to show data series with varying scales is to put the series in separate panels.

17. Select the rectangular plot area defined by the axes. Change the Default 2D Axes Type on the Standard toolbar to Vary Y Panel.
The graph is redrawn, placing each plot in a separate panel, as shown in Figure 2.16. The $y$ axis is scaled separately in each panel.

18. Make sure the plot is not selected, and then change the Default 2D Axes Type back to Linear. Close the Data windows.

**Figure 2.16: Two data series with varying scales in separate panels.**
EMBEDDING AND EXTRACTING DATA IN GRAPH SHEETS

You can store the data used to create any graph within the Graph Sheet. Using this feature, you can provide a fully editable graph to friends or colleagues without also having to provide a separate data file.

Embed the my.econ data in the Graph Sheet.

1. Make sure the Graph Sheet is in focus.
2. From the main menu, choose Graph ▶ Embed Data.

You can also extract the data embedded in any Graph Sheet for further analysis or manipulation.

Extract the my.econ data we just embedded in the Graph Sheet.

3. Make sure the Graph Sheet is in focus.
4. From the main menu, choose Graph ▶ Extract Data to display the Extract Data dialog box.
5. Specify a name (such as my.econ2) for the extracted data set and click OK.
6. Close the Graph Sheet, saving it as econ.sgr.

Before proceeding, close all open windows except the Object Explorer.
CREATING A GRAPH USING THE OBJECT EXPLORER

In addition to helping you organize your objects, the Object Explorer is a handy tool for manipulating them. It can be particularly useful when creating graphs from a data set with many columns.

1. With the Object Explorer in focus and the example5 folder expanded in the left pane, double-click the icon to the left of the sample data set state.df to display the data in a Data window.

![state.df data](image)

**Figure 2.17:** The state.df data.

The state.df data set has columns showing information about states in the United States.

2. In the left pane of the Object Explorer, click the icon to the left of state.df to display its columns in the right pane.

3. Click the icon next to Income; then CTRL-click Illiteracy and then Area. Notice that these columns are now also selected in the Data window.
4. Close the Data window; in this exercise, you use the Object Explorer for graphing.

5. Open the 2D Plots palette and click the Loess button 📊.

Two loess plots are created in a Graph Sheet, both scaled to the same set of axes.

---

**Editing a Plot in the Object Explorer**

Using the Object Explorer and properties dialog boxes, you can edit any open Graph Sheet. As an example, change the format of the x axis labels.

6. With the Object Explorer in focus, expand the Graphs folder in the left pane.

7. Expand GS1 (or the graph sheet name that corresponds to the plot you just created).

8. Expand Graph2D and then click Axis2dX1, both in the left pane.

9. In the right pane of the Object Explorer, double-click Axis2DLabelX to open the X Axis Labels properties dialog box.

10. In the Label 1 group, change the Type box from Auto to Decimal and make sure Precision is set 1.

11. Click OK.

---

**Viewing Plots in Separate Panels**

Relationships between variables can be seen much more clearly if they are scaled to different y axes. One way to do this is to view the plots in separate panels, keeping the x-axis scaling the same.

12. Click a blank spot anywhere inside the axes region to select the graph.

13. Click the Graph Tools button 📊 on the Graph toolbar.

14. On the Graph Tools palette, click the Separate Panels with Varying Y Axes button 📊.

The plots now appear in two panels, stacked one over the other.
Removing Outliers

Notice that there is one data point far from the others. If you place your cursor at that point, you see that it represents Alaska. Remove this outlier from the plots.

15. Click the **Select Data Points** button on the **Graph Tools** palette.

16. In either panel, drag a rectangle around the point representing Alaska to select it.

17. From the main menu, choose **Format ▶ Exclude Selected Points**.

The loess smoothing is recalculated, and the points representing Alaska are removed from the plots, as shown in Figure 2.18.

![Figure 2.18: Separate panel plot with outlier excluded.](image-url)

18. Click the **Select Tool** button to return to the selection cursor.

19. Close all open windows and palettes.
CREATING A 3D GRAPH

In this exercise, use the data set exsurf to create a 3D plot.

1. From the main menu, choose Data ▶ Select Data to display the Select Data dialog box.
2. In the Existing Data group, type exsurf in the Name box.
3. Click OK to load the data into a Data window.

4. Now select the columns V1, V2, and V3 by dragging the mouse across the column headers.

5. Click the 3D Plots button on the Standard toolbar to open the Plots 3D palette.

6. Click the Spline Surface button on the Plots 3D palette. The resulting graph is shown in Figure 2.20.

Figure 2.19: The exsurf data.
Adding Color Draping

In this section, add color draping to the spline plot.

7. Click the maximize button in the upper right corner of the Graph Sheet.
8. Click the mesh of the surface plot to select it.
9. Click the 32 Color Surface button on the Plots 3D palette. The graph redraws with the new format, as shown in Figure 2.21.

Figure 2.20: 3D spline plot of the exsurf data.

Figure 2.21: Color draping can be done with up to 64 colors.

10. Close all open windows and palettes.
CREATING POWERPOINT SLIDES

If you have PowerPoint installed on your computer, you can automatically create a PowerPoint presentation from your Spotfire S+ graphs.

Use the graphs you saved during this tutorial to create a PowerPoint presentation.

1. Click the **PowerPoint Presentation** button on the **Standard** toolbar.

   ![PowerPoint Presentation button](image)

   **Figure 2.22:** The **PowerPoint Presentation** button on the **Standard** toolbar.

   The **Welcome** screen of the **PowerPoint Presentation Wizard** is displayed.

2. Click **Next**.

3. Click **Add Graph** to locate your graphs (**mpanel.sgr** and **econ.sgr**) and then add them to the list for your presentation.

4. Click **Next** to move to the next page of the wizard.

5. Click **Finish**.

PowerPoint opens and the graphs are inserted as slides in a new PowerPoint presentation. Note that the graphs are inserted in the order you specified in the wizard's presentation list.
Chapter 2  Extended Tour

USING SPOTFIRE S+ WITH MICROSOFT EXCEL

In addition to being able to exchange data with Microsoft Excel, you can also open Excel worksheets from directly within Spotfire S+, making your Excel data instantly available for creating graphics and performing statistical analyses.

Create a data set representing a sinusoidal function in an Excel worksheet, and then plot it and test for serial correlation using Spotfire S+.

Creating Excel Data Inside Spotfire S+

Create the data set in an Excel worksheet within Spotfire S+.

1. From the main menu, choose File ▶ New to open the New dialog box.

2. Select Microsoft Excel Worksheet and click OK.

An Excel worksheet entitled SplusBook1 appears, as shown in Figure 2.23.

3. In cell C5, type the number 1 and press ENTER.


5. On the Formula toolbar, click the Edit Formula button (marked by an equals sign). An equals sign appears in the Formula text box.

6. In the Formula text box, immediately after the equals sign, type C5+1 and press ENTER.
The number 2 appears in cell C6, and cell C7 is highlighted.

7. Select cell C6 and press CTRL-C.
8. Select cells C7 through C34 and then press CTRL-V.

Column C, rows 5 through 34, should now contain the values from 1 through 30.

9. Select cell D5.
10. On the Formula toolbar, click the Edit Formula button.
11. In the Formula text box, immediately after the equals sign, type \(3 \times \sin(C5)^2\) and press ENTER.

The number 2.12422 appears in cell D5, and cell D6 is highlighted.

12. Select cell D5 and press CTRL-C.
13. Select cells D6 through D34 and then press CTRL-V.

Column D, rows 6 through 34, should fill with values between 0 and 3, inclusive.

**Plotting Excel Data**

Create a Spotfire S+ graph from our data.

14. Select cells C5 through D34.

15. On the Standard toolbar, click the 2D Plots button to open the Plots 2D palette.

16. Click the Line button to create a line plot of the data.

Behind the scenes, a link has been created between Excel and Spotfire S+.

**Analyzing Excel Data**

Use the autogenerated link between Excel and Spotfire S+ that was just created to compute the autocorrelation function on our Excel data.

17. From the main menu, choose Statistics » Time Series » Autocorrelations to open the Autocorrelations and Autocovariances dialog box.

18. In the Object dropdown list of the Data group, select SplusBook1.Sheet1.C5.D34, which is the link object.

19. In the Variable dropdown list, select V2 and then click OK.
A Report window displays the autocorrelation matrix, and a plot is created showing that significant serial correlation appears in the series, as we would expect. See Figure 2.24.

**Figure 2.24:** The autocorrelation matrix and plot for our Excel data.

As our plot example shows, Spotfire S+ automatically creates a link whenever you select a region of an Excel worksheet and attempt to create a plot. Similarly, it automatically creates a link if you select some data and try to perform a statistical analysis.
For most purposes, these automatically created links are all you need. However, you can have more control over the link if you create it with the Link Wizard. Use the Link Wizard if you need to specify row and column names for the data you select or if you want to modify the data formats Spotfire S+ uses to display the linked data. For detailed information on using the Link Wizard, see Chapter 10, Using Spotfire S+ with Other Applications, in the User’s Guide.
USING THE S-PLUS LANGUAGE

For some analyses, it is more convenient to work with an interactive data analysis language than to maneuver through a series of dialog boxes. The Commands window provides that interactive access to the S-PLUS (splus) language.

In this section, use the Commands window to fit another linear model and perform some diagnostics.

1. Close all open windows.
2. Open the Commands window by clicking the Commands Window button on the Standard toolbar.

S-PLUS Language Basics

Everything you type in Spotfire S+ is an expression, and expressions are evaluated when you press the ENTER key. Most S-PLUS expressions are function calls since S-PLUS is a functional language. To call a function, simply type the name of the function followed by any arguments to the function enclosed in a set of parentheses. Remember that S-PLUS commands are case-sensitive.

The Commands window uses a > prompt. If you press ENTER after an expression that is syntactically incomplete, it is not evaluated immediately. Instead, Spotfire S+ prompts you to continue the expression with the + continuation prompt.

You can type several expressions on the same line by separating them with semicolons (;). Spotfire S+ evaluates each in succession when you press ENTER. A semicolon is not required at the end of each line, only between multiple expressions on a single line.

You can include comments in S-PLUS expressions by inserting them after a # symbol. Anything after the # on a line is interpreted as a comment and is not evaluated.
The result of any S-PLUS expression is an object that you can save by assigning it a name using the assignment operator `<-`. Each data set used in Spotfire S+ is represented as a S-PLUS data object of a certain class.

**Note**

The assignment operator is typed by typing a “less than” character (<) followed immediately by a hyphen (-). Be careful not to put any spaces between these two characters.

Spotfire S+ ignores most spaces, so you can include or omit spaces in typing your expressions as you prefer. However, do not place extra spaces in the name of an object, between the digits of a single number, or between the `<` and `-` in the assignment operator.

In the following examples, text appearing after the `>` symbol is to be typed at this prompt. Do not type the `>` or the first `+` at the beginning of a line.

**Listing Objects**

In this section, replicate the regression results obtained earlier using the `exenvirn` data and store them in an object named `fit.lm`.

3. At the prompt in the **Commands** window, type the following (remember that the S-PLUS language is case-sensitive):

```splus
> fit.lm <- lm(Ozone~Radiation+Temperature+Wind, + data=exenvirn)
```

4. Now, to see a brief summary for the model, type

```splus
> fit.lm
```

to display a brief summary for the model:

```
Call:
lm(formula = Ozone ~ Radiation + Temperature + Wind, + data = exenvirn)

Coefficients:
(Intercept) Radiation Temperature Wind
 -0.2973296 0.002205541 0.05004432 -0.07602195
```
Degrees of freedom: 111 total; 107 residual
Residual standard error: 0.5101592

You can extract the specific model components of fitted values, coefficients, and residuals using the specific extraction functions `fitted`, `resid`, and `coef`. For example, to extract the coefficients from `fit.lm`, use `coef` as follows:

```r
> b <- coef(fit.lm)
> b[2]
  Radiation
  0.002205541
```

### Fitting a Linear Model

When fitting the model using dialog boxes, you added one interaction term to examine the interaction between temperature and radiation in determining ozone level. Now fit a model containing interactions and explore whether the interactions are significant.

5. To fit a linear model with all two-way interactions, type

```r
> fit.int <- lm(Ozone~(Radiation+Temperature+Wind)^2,
+ data=exenvirn)
```

6. For a brief summary of the fit, type

```r
> fit.int
```

7. For a detailed summary, type

```r
> summary(fit.int)
```

8. For an F-test comparing this model to the model fit above, type

```r
> anova(fit.lm, fit.int)
```

### Running a Spotfire S+ Script

The Script window makes it easy to edit and run several lines of commands. You can copy and paste expressions from the Commands window into a Script window, and then save the script as an external (.ssc) file.

Create and run a new S-PLUS language script. Start by copying and pasting the two expressions we typed in the Commands window.

10. Select **Script File** and click **OK**.

11. Click the title bar of the **Commands** window to make it the active window.

12. Copy and paste the following two lines from the **Commands** window into the new **Script** window, being careful to exclude the > prompt as you highlight each line:

   ```
   fit.lm <- lm(Ozone ~ Radiation + Temperature + Wind, data = exenvirn)
   fit.lm
   ```

13. Click the **Run** button on the **Script** window toolbar.

The script output appears in the lower pane, as shown in Figure 2.26.

![Figure 2.26: Output displayed in the lower pane of the Script window.](image)

14. Close the **Commands** and **Script** windows (do not save script).

Notice that there is no prompt in the **Script** window. To run a script, simply click the **Run** button on the **Script** window toolbar or press F10. To run only selected commands, first highlight them, and then click the **Run** button or press F10. (If no output appears in the lower pane, choose **Options** ➤ **Text Output Routing** and select **Script Output** in both columns.)
FINDING AND DOWNLOADING PACKAGES

You can find and download publicly-available Spotfire S+ packages from http://spotfire.tibco.com/csan or another repository available to you. In this exercise, download a Spotfire S+ package from CSAN. For more information about Spotfire S+ packages, see the Guide to Spotfire S+ Packages, available from the Help ➤ Online Manuals menu item.

Before you start working with packages, make sure you have the pkgutils library installed and loaded.

1. Open the Commands window by clicking the Commands Window button on the Standard toolbar. (For more information about using the Commands window, see the Using the S-PLUS Language on page 56.)

2. In the Commands window, type `install.pkgutils(update=T)`.

3. On the menu, click File ➤ Load Library.

4. In the Library Name box, scroll until you see pkgutils. Select it, and then click OK.

Now that you have the package utilities, you can find and load packages.

5. On the menu, click File ➤ Find Packages.

6. Accept the default CSAN repository.

7. Scroll through the list and select ifultools.

8. Under Install Options, select Install Binary + Load.

If you have packages stored locally, you can browse to its repository location using this dialog.

After you have installed and loaded the binary, it appears in your search path. (See Getting Help in Spotfire S+ on page 61.)

Windows binary packages include the library and a CHM Help file. The Help file appears on the Help ➤ Available Help menu on the toolbar.
GETTING HELP IN SPOTFIRE S+

HTML Help

Online help is available for both the Spotfire S+ graphical user interface and the S-PLUS programming language. From the main menu:

- Choose **Help ▶ Available Help ▶ TIBCO Spotfire S+ Help** to access the online help for the graphical user interface.
- Choose **Help ▶ Available Help ▶ Language Reference** to access the online help for the S-PLUS programming language.

Online help in Spotfire S+ is based on Microsoft Internet Explorer and uses an HTML window to display the help files.

As shown in Figure 2.27, the HTML Help window has three main areas: the **toolbar**, the **left pane**, and the **right pane**.
Using the Toolbar  Table 2.1 lists the four main buttons on the help window toolbar (in some cases, you might see more).

Table 2.1: Help window toolbar buttons.

<table>
<thead>
<tr>
<th>Button Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hide (or Show)</td>
<td>If the button is labeled <strong>Hide</strong>, it hides the left pane. If the button is labeled <strong>Show</strong>, it shows the left pane.</td>
</tr>
<tr>
<td>Back</td>
<td>Returns to previously viewed help topic.</td>
</tr>
<tr>
<td>Forward</td>
<td>Moves to next help topic.</td>
</tr>
<tr>
<td>Print</td>
<td>Prints the current help topic.</td>
</tr>
</tbody>
</table>

Using the Left Pane  The left pane contains three tabs: the **Contents** tab, the **Index** tab, and the **Search** tab:

- The **Contents** tab organizes help topics by category so that related help files can be found easily. These categories appear as small book icons, labeled with the name of the category. To open a category, double-click the icon or label. To select a topic within the category, double-click its question-mark icon or the topic title.

- The **Index** tab lists available help topics by keyword. Keywords are typically function names for S-PLUS language functions and topic names for graphical user interface topics. Simply type in a keyword and HTML Help will find the keyword that most closely matches it. Click **Display** (or double-click the selected title) to display the help topic.

- The **Search** tab provides a full-text search for the entire help system. Simply type in a keyword, and all the help files containing that keyword are listed in a list box. Select the desired topic and click **Display** (or double-click the selected title) to display the help topic.

Using the Right Pane  The right pane contains the help topic. It usually appears with both vertical and horizontal scroll bars, but you can expand the HTML Help window to increase the width of the right pane. Many help files
are too long to be fully displayed in a single screen, so choose a convenient height for your HTML Help window and then use the vertical scroll bars to scroll through the text.

The right pane contains a search-in-topic feature. To use it:

1. Type CTRL-F to open the Find dialog box (this dialog box is a feature of HTML Help inherited from Internet Explorer).
2. Type your search string in the Find what box.
3. Click Find Next.

Help in the Commands and Script Windows

When you work in the Commands window, you can get help for any command by using the ? or help function. For example, to open the help file for anova, simply type:

\[ > \text{help(anova)} \]

or

\[ > \text{?anova} \]

To get help for a command when you are working in a Script window, highlight the command and press F1.
SUMMARY OF BASIC PROCEDURES

Using Menus 66
   Main Menus 66
   Shortcut (Right-Click) Menus 66

Using Dialog boxes 67
   The Apply Button 67
   The Dialog Rollback Buttons 68
   Typing and Editing in Dialog Boxes 68

Using Toolbars and Palettes 70
   ToolTips 70
   DataTips 71

Selecting Data 72
   Using the Select Data Dialog Box 72
   Using the Object Explorer 72

Importing Data 73

Selecting Variables to Plot 74
   Selecting Variables in a Data Window 74
   Selecting Variables in the Object Explorer 74

Creating Plots 75

Selecting Graph Objects 76
CHAPTER 3  SUMMARY OF BASIC PROCEDURES

USING MENUS

Main Menus

TIBCO Spotfire S+ menus change, depending upon the type of window currently in focus. For example, if the active window (the highlighted window) is a Data window, the menus display options useful for operating on Data windows; some Graph Sheet and programming options are absent or dimmed.

Menu options ending with a ▶ symbol display a submenu when selected. Menu options ending with an ellipsis (…) display a dialog box when selected. To cancel a menu, simply click outside the menu or press ESC.

Shortcut (Right-Click) Menus

When you click the right mouse button, a shortcut menu for the selected object is displayed. Shortcut menus contain options specific to the selected object and appear to the right or left of the mouse pointer. To close a shortcut menu without selecting an option, simply click outside the menu or press ESC.
USING DIALOG BOXES

Sometimes when you choose a menu option or click the mouse, Spotfire S+ displays a dialog box. You can use dialog boxes to specify information about a particular action.

There are two types of dialog boxes in Spotfire S+: action dialog boxes and properties dialog boxes. Action dialog boxes carry out commands, such as copying a column. Properties dialog boxes display, and allow you to modify, the properties or characteristics of the selected object.

Dialog boxes can contain multiple tabbed pages containing different options. To access a particular page, click on its tab, or press CTRL-TAB, to move from page to page. When you click OK or Apply (or press ENTER), any changes you made on any of the tabbed pages are applied to the selected object.

Most of the dialog boxes in Spotfire S+ are *modeless*: They can be moved around on the screen, and they remain open until you choose to close them. This means you can make changes in a dialog box and see the effect without closing the dialog box using the Apply button. This feature is useful when you experiment with changes to an object and want to see the effect of each change.

The Apply Button

Modeless dialog boxes have an Apply button. The Apply button acts much like the OK button, except that it does not close the dialog box. By specifying changes in a dialog box and clicking Apply (or pressing CTRL-ENTER), you can see the effect of your changes while keeping the dialog box open, so that you can make additional changes without having to reselect the dialog box.

If no changes have been made using the dialog box since it was last opened or “applied,” the Apply button is dimmed. To close the dialog box, click the Cancel button or the close button in the upper right corner of the dialog box.
Chapter 3  Summary of Basic Procedures

The Dialog Rollback Buttons

Each time you make changes to a dialog box and click **OK** or **Apply**, Spotfire S+ remembers the changes and keeps track of the final “state” of the dialog box. The **Dialog Rollback** buttons, located at the bottom center of the dialog box, let you restore a dialog box to a prior state.

You can use the buttons to scroll back through each of the prior states of a dialog box until you find the set of values you want. By clicking **OK** or **Apply**, you can restore an object to a previous state. Alternatively, you can save time by using a prior state as a starting point for further changes.

Note that **Dialog Rollback** is different from **Undo** in that rollback can be applied selectively to individual objects.

Typing and Editing in Dialog Boxes

Table 3.1 below lists the shortcut keys you can use in dialog boxes for performing the associated tasks.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move to the next option in the dialog box.</td>
<td>TAB</td>
</tr>
<tr>
<td>Move to the previous option in the dialog box.</td>
<td>SHIFT-TAB</td>
</tr>
<tr>
<td>Move between pages in a multipage dialog box.</td>
<td>CTRL-TAB</td>
</tr>
<tr>
<td>Move to a specific option and select it.</td>
<td>**ALT-<strong>underlined letter</strong> in the option name (Press again to move to the next option with the same underlined letter.)</td>
</tr>
<tr>
<td>Display a dropdown list.</td>
<td><strong>ALT-down arrow</strong></td>
</tr>
</tbody>
</table>
Table 3.1: *Shortcut keys when using dialog boxes. (Continued)*

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select an item from a list.</td>
<td>Up or down arrow to move, ALT-down arrow to close the list</td>
</tr>
<tr>
<td>Close a list without selecting any items.</td>
<td>ALT-down arrow</td>
</tr>
</tbody>
</table>
 USING TOOLBARS AND PALETTES

In addition to the Standard toolbar, which is always displayed, Spotfire S+ displays a special toolbar, depending upon the type of window that is currently open and active. For example, when a Data window is the active window, Spotfire S+ opens the Data window toolbar; when a Graph Sheet is in focus, the Graph toolbar is displayed. Toolbar buttons provide convenient shortcuts to a number of menu selections. Note that you cannot turn off the display of the Standard and special toolbars.

When you position the mouse pointer over a toolbar button, a description appears in the status bar at the bottom of the screen. Like menu options, some toolbar buttons may not be available at all times. Inactive toolbar buttons are dimmed; for example, the Undo button is dimmed if there is nothing to undo.

In addition to toolbars, several buttons display a palette of options when selected. For example, the 2D Plots button displays a palette of 2D plot types. Tool palettes remain in view until you click the toolbar button again or click the palette’s close box. Leaving a tool palette in view is convenient when you experiment with different options.

**ToolTip**

When you hover the mouse over a toolbar or palette button, helpful ToolTips appear:

To turn off this feature, choose Options ► General Settings from the main menu and clear the Enable ToolTips check box on the General page of the dialog box.
DataTips

DataTips are much like ToolTips except that they display information about data in the active **Data** window or **Graph Sheet**. For example, when you pause your mouse over a point in a scatter plot, or over the column number in a **Data** window, a DataTip displays information relevant to that point:

![DataTip Example](image)

To turn off this feature, choose **Options ▶ General Settings** from the main menu and clear the **Enable DataTips** check box on the **Data** page of the dialog box.
Chapter 3  Summary of Basic Procedures

SELECTING DATA

You can select data using either the **Select Data** dialog box or the **Object Explorer**. If you want to open the data in a **Data** window so that the data are visible as you work, the **Select Data** dialog box is simplest and fastest. If you want to work with many separate data objects with which you are already somewhat familiar, the **Object Explorer** can be much more efficient.

**Using the Select Data Dialog Box**

From the main menu, choose **Data ▶ Select Data** to display the **Select Data** dialog box. In the **Source** group, **Existing Data** is selected by default. In the **Existing Data** group, type a data object name or select a data object from the dropdown menu in the **Name** box. Click **OK** to load the data into a **Data** window.

**Using the Object Explorer**

Click the **Object Explorer** button 🗄️ on the **Standard** toolbar. To select a data object, simply click its name in either pane of the **Object Explorer**. To display the data in a **Data** window, double-click the icon to the left of the data object’s name.
IMPORTING DATA

You can import data from a file, from the leading financial databases Bloomberg, FAME, and MIM, or via an ODBC connection. ODBC connections allow you to extract data sets from enterprise databases. In all cases, there are numerous options you can specify.

For the simplest case in which you want to read an entire data file, choose File ► Import Data ► From File from the main menu. In the Import From File dialog box, navigate to the appropriate folder and select the desired file. Click OK.

For detailed information on how to import data from a financial database or via an ODBC connection, consult the User’s Guide and the online help.
SELECTING VARIABLES TO PLOT

You create a plot by selecting variables from a given data set and then choosing a plot type, either by a clicking a plot palette button or by selecting the plot type in the Insert Graph dialog box. You can select your variables in either a Data window or the Object Explorer.

Selecting Variables in a Data Window

- To select two or more contiguous variables, click and drag the mouse across the column headers.
- To select a range of variables, click the column header of the first variable, and then SHIFT-click the column header of the last variable in the range. All the variables between the variable in which you first click and the variable in which you SHIFT-click are selected.
- To select noncontiguous variables, or to select variables in a particular order, click the column header of the first variable, and then CTRL-click the column headers of the other desired variables.

Selecting Variables in the Object Explorer

- To select a range of variables, click one variable name, and then SHIFT-click another. All the variables between the variable you first click and the variable you SHIFT-click are selected.
- To select noncontiguous variables, click one variable name, and then CTRL-click one or more other variable names.
Creating Plots

CREATING PLOTS

After you select the variables to plot, click a plot palette button, or select the plot type by choosing Graph from the main menu.

For your reference, Table 3.2 below shows the plot types most commonly associated with a given number of selected variables.

**Table 3.2:** Common plots associated with a given number of variables.

<table>
<thead>
<tr>
<th>Number of Selected Variables</th>
<th>Plots</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Box, QQ normal with line, probability, probability normal with line, histogram, density, histogram density, pie, dot, bar.</td>
</tr>
<tr>
<td>2</td>
<td>QQ, probability, Pareto, scatter, line, line with scatter, line with isolated points, step, high density, curve fit (linear, polynomial, exponential, power, log 10, natural log), nonlinear curve fit, smoothing (loess, spline, robust LTS, robust MM, kernel, Friedman), Y series, grouped box, polar.</td>
</tr>
<tr>
<td>3</td>
<td>Text as symbols, grouped bar with error, 3D scatter, 3D line, 3D line with scatter, 3D scatter with dropline, 3D regression, 3D regression with scatter, bubble, color, error bar, scatterplot matrix, contour (line or filled), 3D contour (line or filled), levels, 3D surface, 3D bar, comment, Smith.</td>
</tr>
<tr>
<td>4 or more</td>
<td>XY pairs, grouped bar, stacked bar, bubble color, high-low-close, high-low-open-close, candlestick, error bar–both, vector, area, Smith.</td>
</tr>
</tbody>
</table>
SELECTING GRAPH OBJECTS

To edit graphics, first select the object to edit. In Spotfire S+, we distinguish between the Graph Sheet, the graph area, and the plot area, as illustrated in Figure 3.2.

- The Graph Sheet can best be thought of as the sheet of paper on which you draw your plots. It can contain one or more graphs. When you print, you print one or more pages of a Graph Sheet.
- The graph area refers to the rectangle surrounding the data points, axes, legends, titles, and so on.
- The plot area is the rectangular area within the graph area where the data are actually plotted.

Within the plot area, you can select the plot area, the plot itself, or any plotted element:
- To select the plot, click any plotted element (line, symbol, filled region, etc.).
- To select the plot area, click a blank area within the plot area.

Figure 3.2: A Graph Sheet depicting the graph area (gray) and plot area (center white).
Selecting Graph Objects

Figure 3.3 shows the difference in how Spotfire S+ displays the two selections.

Figure 3.3: Selecting the plot versus selecting the plot area.

To select a plot element, such as an axis, axis title, or axis label, simply click it.

Axes and axis titles are editable and selectable separately on 2D graphs. Axis labels are formatted per axis.
INDEX

Numerics

2D plots
  creating 5, 26
  editing 12
3D plots
  creating 13, 49
  editing 50
  rotating 15
3D workbox 15

A

Apply button 67
assignment operator 57
axes 27
  multiple 39
  varying 38

C

color draping 50
columns
  descriptions for 25
  types of 4
Commands window 35, 56
  getting help in 63
comments in Spotfire S+
  expressions 56
  conditioning 29
CSAN Web site 60

D
data
  embedding 34, 36, 45
  extracting 45
  importing 23, 73
  selecting 72
databases
  system 17
  working data 17
data points
  highlighting 32
  identifying and labeling 10
DataTips 4, 10, 11, 71
Data window toolbar 41
descriptions, column 25
Dialog Rollback button 37, 68
dialogs 67, 68
  specifying options in 67
  typing and editing in 68

E

embedding data 34, 36, 45
Excel, linking 52, 55
expressions, Spotfire S+
  extracting
    data 45
    graph panels 33

F

Formula Builder 36
function calls 56

G

graph panels, extracting 33
graphs
  creating
    2D 5, 26
    3D 13, 49
    using the Object Explorer 46
  editing
    2D 12
    3D 50
Index

features of, changing 27
Graph Sheets
  embedding data in 34, 36, 45
  extracting data from 45
  saving 33
Graph toolbar 10

H
help
  in the Commands window 63
  in the Script window 63
  online 61

I
importing data 23, 73

L
labels 27
libraries, loading 40
linear regression 7
linking Excel and Spotfire S+ 52, 55

M
menus
  main 66
  shortcut 66
models 35
multipanel conditioning 29

O
Object Explorer 19, 40, 46, 47, 72
  toolbar 18
objects
  organizing 18, 19
  viewing 19
online help 61
outliers 48

P
packages 60
plots
  in separate panels 47
  properties of 27
  rotating 15
Plots 2D palette 5, 7
Plots 3D palette 14
PowerPoint presentations 51
prompt
  continuation 56
  standard 56

R
regression, linear 7
rotating plots 15

S
scripts 58, 59
Script window 35, 58
  getting help in 63
  toolbar 59
search path 17, 40
shortcut menus 66
smoothing 26
S-PLUS language 56
Standard toolbar 5, 14, 16, 39, 51, 56
statistics 35

T
titles 28
toolbars 70
ToolTips 70
Trellis graphics 8, 29, 30

V
variables 75
  editing names for 25
  selecting 74

W
workbox, 3D 15
working data 17