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TIBCO SPOTFIRE S+ BOOKS

Note about Naming

Throughout the documentation, we have attempted to distinguish between the language

(S-PLUS) and the product (Spotfire S+).

*  “S-PLUS” refers to the engine, the language, and its constituents (that is objects,

functions, expressions, and so forth).

*  “Spotfire S+” refers to all and any parts of the product beyond the language, including
the product user interfaces, libraries, and documentation, as well as general product and

language behavior.

The TIBCO Spotfire S+® documentation includes books to address
your focus and knowledge level. Review the following table to help
you choose the Spotfire S+ book that meets your needs. These books
are available in PDF format in the following locations:

* In your Spotfire S+ installation directory (SHOME\help on
Windows, SHOME/doc on UNIX/Linux).

* In the Spotfire S+ Workbench, from the Help » Spotfire S+

Manuals menu item.

«  In Microsoft™ Windows®, in the Spotfire S+ GUI, from the

Help » Online Manuals menu item.
Spotfire S+ documentation.

Information you need if you...

See the...

Must install or configure your current installation
of Spotfire S+; review system requirements.

Installtion and
Administration Guide

Want to review the third-party products included
in Spotfire S+, along with their legal notices and
licenses.

Licenses
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Spotfire S+ documentation. (Continued)

Information you need if you... See the...
Are new to the S language and the Spotfire S+ Getting Started
GUI, and you want an introduction to importing Guide

data, producing simple graphs, applying statistical

- . . ®
models, and viewing data in Microsoft Excel .

Are a new Spotfire S+ user and need how to use
Spotfire S+, primarily through the GUIL

User’s Guide

Are familiar with the S language and Spotfire S+,
and you want to use the Spotfire S+ plug-in, or
customization, of the Eclipse Integrated
Development Environment (IDE).

Spotfire S+ Workbench
User’s Guide

Have used the S language and Spotfire S+, and
you want to know how to write, debug, and
program functions from the Commands window.

Programmer’s Guide

Are familiar with the S language and Spotfire S+,
and you want to extend its functionality in your
own application or within Spotfire S+.

Application
Developer’s Guide

Are familiar with the S language and Spotfire S+,
and you are looking for information about creating
or editing graphics, either from a Commands
window or the Windows GUI, or using Spotfire
S+ supported graphics devices.

Guide to Graphics

Are familiar with the S language and Spotfire S+,
and you want to use the Big Data library to import
and manipulate very large data sets.

Big Data
User’s Guide

Want to download or create Spotfire S+ packages
for submission to the Comprehensive S-PLUS
Archive Network (CSAN) site, and need to know
the steps.

Guide to Packages
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Spotfire S+ documentation. (Continued)

Information you need if you...

See the...

Are looking for categorized information about
individual S-PLUS functions.

Function Guide

If you are familiar with the S language and
Spotfire S+, and you need a reference for the
range of statistical modelling and analysis
techniques in Spotfire S+. Volume 1 includes
information on specifying models in Spotfire S+,
on probability, on estimation and inference, on
regression and smoothing, and on analysis of
variance.

Guide to Statistics,
Vol. 7

If you are familiar with the S language and
Spotfire S+, and you need a reference for the
range of statistical modelling and analysis
techniques in Spotfire S+. Volume 2 includes
information on multivariate techniques, time series
analysis, survival analysis, resampling techniques,
and mathematical computing in Spotfire S+.

Guide to Statistics,
Vol. 2
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Introduction

INTRODUCTION

TIBCO Spotfire S+ provides a plug-in, or customization, of the
Eclipse Integrated Development Environment (IDE) called the
Spotfire S+ Workbench. You can use the Spotfire S+ Workbench, the
basic Eclipse IDE features, and other third-party plug-ins for many
tasks, including:

* Manage your project files and tasks.

+ Edit your code.

*  Run Spotfire S+ commands.

+ Examine Spotfire S+ objects.

* Debug your code.

+ Track resource use, functions, variables, and expressions.
*  Troubleshoot problems with Spotfire S+ code.

* Provide source control for shared project files.

The Spotfire S+ Workbench is a stand-alone application that runs the
S-PLUS engine. When you run the Spotfire S+ Workbench, you do
not need to run any other version of Spotfire S+ (for example, the
console or traditional Windows or Java GUI).

Caution

If you run two or more simultaneous sessions of Spotfire S+ (including one or more in the
Spotfire S+ Workbench), take care to use different working directories. To use the same working
directory for multiple sessions can cause conflicts, and possibly even data corruption.

This chapter introduces the Spotfire S+ Workbench and provides
important conceptual information and definitions of terms you need
to know to use the Spotfire S+ Workbench most effectively.

+  Chapter 2 provides reference for the Spotfire S+ perspective.
*  Chapter 3 provides reference for the Debug perspective.

* Chapter 4 provides tasks for learning to use the Spotfire S+
Workbench.
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TERMS AND CONCEPTS

Before you start using the Spotfire S+ Workbench, you should
understand key terms and concepts that vary from the traditional
Spotfire S+ for Windows GUI and Spotfire S+ for UNIX Java GUI

Note

If you are using the Eclipse IDE on a UNIX platform from a Windows machine using a
Windows X-server software package, you might notice that Eclipse runs slowly, similar to the
Spotfire S+ Java GUI. See the Release Notes for more information and recommendations for
improving Ul performance.

Note

Eclipse version 3.2 or later does not support SPARC/Motif for Solaris. If you are using a version
of Solaris prior to version 10, you must install the GTK (version 2.2.4 or greater) library. For
more information about finding this library, see http://www.sun.com/software/solaris/. (This
library is included in Solaris 10.)

Table 1.1: Important terms and concepts.

Term Definition

Perspective | Defines the preferences, settings, and views for working with
Eclipse projects.

* The Spotfire S+ perspective is conceptually equivalent to
the traditional Spotfire S+ Windows GUI or UNIX Java
GUI. Use the Spotfire S+ perspective as the primary
perspective for interactive Spotfire S+ command line use.
For an example of changing the perspective, see the
section Customized Perspective Views on page 148.

* The Debug perspective provides an integrated debugging
and profiling environment, with customized views, menu
options, and behavior. For more information about using
the Debug perspective, see Chapter 3, TIBCO Spotfire S+
Workbench Debug Perspective.
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Table 1.1: Important terms and concepts. (Continued)

Term

Definition

Workspace

A physical directory on your machine that manages Spotfire
S+ Workbench resources such as projects and other options.
On your machine's hard drive, the workspace directory
contains a single Spotfire S+ .Data database and the Eclipse
.metadata database. (You should never touch these
resources.) This design is different from the association you
notice when you work in Spotfire S+ in other environments.
When you start the Spotfire S+ Workbench, you are
prompted to create or identify the workspace. See the section
The Spotfire S+ Workspace on page 12.

Project

A resource containing text files, scripts, and associated files.

The Spotfire S+ Workbench project is used for build and

version management, sharing, and resource management.
Before you begin working with any files in the Spotfire S+
Workbench, create a project. You can create a new project

by:

*  Specifying a project name and allowing Eclipse to
locate the project in the workspace directory, and
then selecting an existing directory containing
project files at an alternate location (that is, work
with the files at the specified location).

*  Specifying a project name and selecting an existing
directory containing project files.

Another important concept is that of the working project. Set a
project as the working project, which changes the working
directory to the project’s directory in your workspace and
stores data objects in the project’s .Data database. See the
section Setting the Working Project on page 151 for more
information.

Important: If you select an existing Spotfire S+ project
directory for your Workbench project, you must set that
project to be the working project to write data objects to its
.Data directory. See the section Working Projects and
Databases on page 151 for a detailed discussion. See the
section Quick Start on page 127.
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Table 1.1: Important terms and concepts. (Continued)

Term

Definition

View

A perspective’s integrated window, containing menus,
options, and commands, that display specific parts of your
data and projects and provide tools for data manipulation.
For descriptions of the Spotfire S+ perspective views, see the
section Spotfire S+ Perspective Views on page 68. For
descriptions of the Debug perspective views, see the section
Debug view on page 100. For practice exercises working with
views, see Chapter 4, TIBCO Spotfire S+ Workbench Tasks.

Editor

An integrated code/text editor that includes support for
syntax coloring, text formatting, and integration with the
other views. Analogous to the Script Editor in the traditional
Spotfire S+ GUI. For more information, see the section
Spotfire S+ Workbench Script Editor on page 57. To practice
using the Script Editor, see the section Editing Code in the
Script Editor on page 157.




Finding Help for the Workbench

FINDING HELP FOR THE WORKBENCH

The Eclipse IDE contains extensive, in-depth documentation for its
user interface. For information about basic Eclipse IDE functionality,
on the menu, see the Eclipse Workbench User Guide.

Getting If you are not familiar with the Eclipse IDE, after you start the
Started Spotfire S+ Workbench, take the first few minutes to learn the basic
. concepts and IDE layout by working through the basic tutorial in the
Tutorial P yourny 8 &
Workbench User Guide.

To view the Eclipse Getting Started tutorial

1. From the Spotfire S+ Workbench main menu, click Help »
Help Contents.

{(7) Help Contents
7 Search
Dynamic Help

Key Assist... Ctrl+5hift+L
Tips and Tricks...
Cheat Sheets...

Spoffire S+ Help

Spotfire 5+ Manuals »
Check for Updates

Install New Software...

About Spotfire S+ Workbench

Figure 1.1: Eclipse IDE Help menu.

2. In the left pane, expand the table of contents by clicking
Workbench User Guide.

3. Click Getting Started, and then click Basic tutorial.
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Figure 1.2: The Eclipse basic tutorial.

The Workbench User Guide opens in a separate window; you can toggle
S+ Workbench application and the Help

between the Spotfire
browser.

Help for
Spotfire S+ .
Functions

the

In

* In the Script Editor, highlight the function for which you

Console,
functionname is the function for which you want help.

The Spotfire S+ Workbench provides access to function help topics.

help(functionname)

type

want help, and then press F1.

* Use the Spotfire S+ Workbench menu options. In the
Script Editor, select the function for which you want help,

and then, on the menu click either:

*  Spotfire S+ » Open Spotfire S+ Help File

or

+  Help » Spotfire S+ Help
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The Spotfire If you browsed to and opened this document directly from the
S+ Workbench installation directory, you might be interested to know how you can
PDF open it directly from the Spotfire S+ Workbench user interface.

Note

Whether you are working in Windows® ora UNIX® platform, You must have access to a PDF
reader to open any of the PDFs shipped with Spotfire S+.

On the Spotfire S+ Workbench menu, click Help » Spotfire S+
Manuals » Spotfire S+ Workbench Guide. (Note that all Spotfire
S+ manuals are available from the Spotfire S+ Manuals menu,
including the Programmer’s Guide, the Application Developer’s Guide, the
Function Guide, the Big Data User’s Guide, the Guide to Packages and the
Guide to Graphics, among others.)

For more information about setting preferences, see the following
documentation:

* The section Examining Spotfire S+ Preferences on page 14.

* The section Setting the Spotfire S+ Workbench Preferences
on page 137.

* The Eclipse Workbench User Guide, available from the Spotfire
S+ Workbench menu item Help » Help Contents.

Note

For information about creating a package project using the Spotfire S+ Packages feature with the
Spotfire S+ Workbench, see the section To create a package project on page 168.
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STARTING THE SPOTFIRE S+ WORKBENCH

From Microsoft
Windows

Setting
Environment
Variables

10

The Spotfire S+ Workbench user interface is the same in both
Microsoft Windows and UNIX platforms.

In Microsoft Windows, click the Start menu P All Programs
» TIBCO » TIBCO Spotfire S+ 8.2 » TIBCO Spotfire S+
Workbench.

When you start the Spotfire S+ Workbench from the Windows Start
menu, it uses a shortcut that starts a Java virtual machine (-vm)
immediately. The Workbench supports a Java system variable,
splus.environment.vars, that can pass environment variables to the
engine for startup consumption. For example, you can set your
Spotfire S+ Workbench environment to start without printing
copyright and version infromation by setting the environment
variable S_SILENT_STARTUP=<any value>.

To use the Java system variable, create a shortcut or a .bat file that

contains the following instructions:

"SHOME\eclipse\eclipse.exe"
-vm "SHOME\java\jre\bin\javaw.exe" -vmargs
-Dsplus.shome="SHOME"
(Where SHOME is your Spotfire S+ installation location.
Note that this is the default Windows XP shortcut, as it appears in the
Spotfire S+ Workbench Properties dialog (see Figure 1.3).

To add an environment argument in Windows

1. Click Start » Program Files » TIBCO »
TIBCO Spotfire S+ 8.2.

2. Right-click Spotfire S+ Workbench.

3. In the Spotfire S+ Workbench Properties dialog, type the
following after -vmargs:

4. -Dsplus.environment.vars="VARI=argl, VARZ=arg2”

where VAR is the variable to set and arg is the argument you
are setting. For example:
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-Dsplus.environment.vars="S_LICMGRSN=WTP10987654321,

S_SILENT_STARTUP=X”

Note

The Windows startup shortcut is defined to run a command with the option to set memory heap

size: - Xmx400m.

"SHOME\eclipse\eclipse.exe" -vm "SHOME\java\jre\bin\javaw.exe"
-vmargs -Dsplus.shome="SHOME\eclipse\eclipse.exe -Xmx400m”

You can override this setting and increase the memory heap size by appending a different setting
at the end of the shortcut. (For example, change -Xmx400m to -Xmx600m at the end of the
command to set the memory heap size to 600mb.) See Figure 1.3 for an example.

2 TIBCO Spotfire S+ Workbench Properties =5

| Security | Details

Previous Versions ‘

General Shorteut

Target type: Application

Target location: eclipse

Shorteut key:  None

f TIBCO Spoffire 5+ Workbench

Target: es (eO6NTIBCO \splusB2” Xss 1280k Xmx400m
Start in: "C:M\Program Files 86\ TIBCO splus82heclipse”

Compatibility

Run: [ Normal window V]
Comment: TIBCO Spotfire 5+ Worbench program
Cpen File Location ] [ Change lcon.. ] [ Advanced... ]
Carcel Foply

Figure 1.3: Spotfire S+ Workbench Properties dialog.

From Unix In UNIX, at the command prompt, type
Splus -w
or type

Splus -workbench

11
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Setting
Environment
Variables

The Spotfire
S+ Workspace

12

Certain required environment variables are set to work with UNIX
and Linux as part of the Spotfire S+ Workbench startup script. To add
other environment variables, set them using env. For example, you
can start the Spotfire S+ Workbench with a particular license and to
start displaying no copyright and version information by using the
following:

env S_LICMGRSN=WTP10987654321 S_SILENT_STARTUP=X
Splus -w
(To set multiple environment variables, separate them with spaces. )

To extend the Java maximum memory heap size to 600MB, set the
environment variable JAVA_OPTIONS to -Xmx600m. For example:

env JAVA_OPTIONS="-Xmx600m" Splus -w

When you launch the Spotfire S+ Workbench, you see the
Workspace Launcher dialog. You must indicate the location of the
workspace.

Select a workspace

Spotfire 5+ Workbench stores your projects in a folder called a workspace.
Choose a workspace folder to use for this session.

L\ SRS C:\ Users\ kroan\workspace - Browse...
[] Use this as the default and do not ask again
[ OK ] I Cancel

Figure 1.4: The Workspace Launcher dialog.

The Spotfire S+ workspace is the directory where the Spotfire S+
workspace .Data and Eclipse .metadata databases are stored. (You
should never touch these files.) Optionally, the workspace directory
can also store your project directories. The Spotfire S+ workspace is
the default directory specified for the project's directory in the New
Project wizard. See the section Spotfire S+ New Project Wizard
on page 31 for more information. (For instruction on creating a
workspace, see the section Setting the Workspace on page 126.)
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Important

In the Spotfire S+ Workbench, you have two options for storing data
objects:

+  Using the Spotfire S+ Workbench model, where the Spotfire
S+ workspace contains a .Data directory, not individual
projects. The .Data directory can store objects for projects to
share in the workspace.

+  Using the familiar Spotfire S+ model, the working Spotfire S+
project stores its data objects to its .Data directory and replaces
the first entry in the Search Path with the project's location.
It is also the location to which relative paths are resolved.

Working projects are marked by an arrow icon, and by the
cue (working) in the navigator:

H-[= Data

Figure 1.5: The working project.

For more information about setting the Spotfire S+ working project,
see the section Setting the Working Project on page 151.

File Edit View Tools Help

COrganize « = Open Include in library = Share with + MNew folder 4= - i @
> | Searches i Name Date modified Typr *
Tracin:
9 Dsta File:
work
|| .project PRO
a workspace .
EL) census.csv Mici| =
.Data T
census.demo.ssc SPLY
.metadata p—
|| graph.setup.q QFi
Census . oF
|| mywbar. QFi
Public 9
. || Readme.td Text -
4 Windows

~ 4 [ 3

Figure 1.6: Workspace directory (in Windows) showing .Data directory,
.metadata directory, and project directories.

Notes

When you work with Spotfire S+ Workbench projects, avoid nesting projects (that is, create one
project in a subdirectory of another project).

To avoid conflicts, never work on Spotfire S+ files in the Spotfire S+ Workbench and another
Spotfire S+ interface at the same time.

13
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EXAMINING SPOTFIRE S+ PREFERENCES

The Spotfire S+ Workbench IDE defaults are set to the Spotfire S+
perspective. The preferences include project type, window
appearance, editor preferences, menu options, debugging options,
server options, and file associations. Use the Preferences dialog to
change these preferences and any other default Eclipse preferences.
To display the Preferences dialog, on the main menu, click Window
» Preferences.

You can also display the Preferences dialog for the following Spotfire

S+ Workbench views by clicking the drop-down button (= ) and
selecting Preferences from the control menu:

* Tasks view.

* Problems view.
*  Output view.

+ Console view.

You can display the Preferences dialog for the Spotfire S+
Workbench Script editor from the right-click menu (that is, right-click
the Script Editor, and from the menu, click Preferences).

Hint

Preferences dialog.

The Eclipse Workbench User Guide includes descriptions of the Eclipse options in the

File
Associations

14

For instruction on setting Spotfire S+ preferences, see the section
Setting the Spotfire S+ Workbench Preferences on page 137.

The Spotfire S+ Workbench sets defaults for the following
preferences.

Spotfire S+ recognized file types include *.q, *.r, *.ssc, and *.t.
Any of these files, associated with the Spotfire S+ Script editor, are
checked for syntax errors and scanned for task tags.
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Note that when you select the file type, its associated editors are
displayed in the Associated editors box. You can add or remove
both file types and associated editors.

| 5% Preferences

type filter text File Associations (=14 - -
O (EE See 'Content Types' for content-type based file associations.
|» Appearance ]
Compare/Patch IRLST=
Content Types @ *htm Add...
a Editors @ *html
| File Associations | *.q
|- Text Editors *r
Keys @ *shtml
I» Network Connections * cg
Perspectives 4 (%
Search
[+ Security

-

Startup and Shutdown
Web Browser
I» Workspace
Help
Install/Update
Run/Debug
Spotfire 5+
Statistics Services

> Team Associated editors:
@ Web Browser Add...
Rernove
Default

® T

Cancel

Figure 1.7: The File Associations page of the Preferences dialog.
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Spotfire S+
Workbench

options

Run code on
startup

These options control general settings for the Spotfire S+ Workbench.

5% Preferences

type filter text

4 General

> Appearance
Compare/Patch
Content Types

- Editors
Keys
Perspectives
Search

> Startup and Shutdown

> Workspace

> Help

> Run/Debug

4 | Spotfire 5+
Console
Editor
Outline
Output
Profile
Task Tags

Statistics Services
> Team

@

Spotfire S+

Spotfire 5+ Workbench options

[7] Run code on startup:

Integrate Java Graphs into the Spotfire 5+ Workbench

[7] Send Output from Run action to Console view

Spotfire S+ Package Repository:  http://spotfiretibco.com/csan R

I Restore Defaults‘ I Apply ‘

[ ok || Concer |

Figure 1.8: The Spotfire S+ Workbench Options page of the Preferences dialog.

Select this option, and then provide any code that you want the
Spotfire S+ Workbench to run when it starts up. Note that this box is
selected by default, and the Big Data library is loaded by default.

Note

If you clear the Run code on startup box, or if you do not supply the option to load the Big
Data library on startup, and then later open a project that uses the Big Data library, you could
see unexpected results when you try to perform actions. If your typical projects include large
data sets, add the code to load the Big Data library and select Run code on startup to load the

Big Data library when you start the Spotfire S+ Workbench.
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This option is selected by default. Clear this option if you do not want
Java graphs embedded in the Spotfire S+ Workbench.

With this option selected, any Java graphs created as part of your
script appear embedded in a view to the right of the folder containing
the console view by default.

Note

Jjava.graph is the default device for the Spotfire S+ Workbench.

Figure 1.9 shows the a Java graph from the Census sample, embedded
in the Spotfire S+ Workbench.

t B Tashs| Problems = 5 BB creph Window 2 23 Toen

=

[

| JJ S[E[Feg=1

Figure 1.9: Java graph embedded in the Spotfire S+ Workbench.

Note

If you have multiple graphs, and you want to display tabbed graph windows, you can set the
option from the drop-down arrow in the Graph Window. Select Graph Options P Options,
and in New Plot Action, select whether to delete, reuse, or add new pages.

Alternatively, you can set this option programmatically using the Spotfire S+ function
java.new.plot.action. See its Help file for more information.

Send Output
from Run
Action to
Console View

Select this option if you want script output to appear in the Console
view, rather than in the Output view. This option is cleared by
default: when you run code from the Script Editor, the Output view
opens and displays the results.

Note that output for code you type in the Console view always
appears in the Console view.

17
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Spotfire S+
Package
Repository

Console

Change this option to specify another location for Spotfire S+
packages. By default, this location is set to the CSAN Web site
(http://spotfire.tibco.com/csan). The preference specified in this
box populates the Repository contols in the Update Packages and
Find Packages dialogs. (Selections in these dialog boxes also appear
in the Spotfire S+ Package Repository drop-down list.)

The Console page controls settings for the Spotfire S+ Workbench

Console.

Options

S Preferences ] S

type filter text

4 General
- Appearance
Compare/Patch

Web Browser
- Workspace
- Help
- Install/Update
- Run/Debug
4 Spotfire 5+
Console
Editor
Outline
Cutput
Task Tags
Statistics Services
- Team

Console

Spotfire 5+ Console options

History Settings

Content Types [] store Console History between sessions

a4 Editors
File Associations Font Settings
- Text Editors
bodefghijkl. ..
Keys . a
Font Selection Change

- Metwork Connections \—QJ

Perspectives

Search Input Color | [HEEEE
- Security —
- Startup and Shutdown Output Color | I

Background Settings
@ System Default () Customn
Copy Settings

[[]Include Prompts in Copy action

G

I Restore Defaults ‘ I Apply

I

Cancel

Lo |

%

Figure 1.10: Console page of the Preferences dialog.
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Settings
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By default, this option is selected. It persists the commands you issue
in the Console (which then appear in the History), between sessions.
When you re-start the Spotfire S+ Workbench, click History to
display the stored entries. Entries you select in the History then
appear in the Console. Also, you can scroll up and down in the
History to display items in the Console. For more information about
using the History, see the section Examining the History on page
165. For information about setting options for the Output view, see
section Output Options on page 24.

By default, the Console displays input and output text using the
default system font as blue and red, respectively. You can change both
the font and the color.

* To set the font, click Change, and then, in the Font dialog,
select from Font, Font style, Size, and any additional font
properties to use. Note that the font changes for both input
and the output displayed in the Console.

* To set a custom font color, click the Input Color or Output
Color button, and then, in the Color picker, select a color for
the input or output.

By default, the Spotfire S+ Console uses the system default. Select
Custom Color, and then click the color button to display the Color
picker and choose a different background color.

Select if you want to include prompts (> and +) when you copy code
from either the Console.
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Editor
Editor.

| 5% Preferences

type filter text

General
Appearance
Compare/Patch
Content Types
Editors
File Associations
Text Editors
Keys
MNetwork Connections
Perspectives
Search
Security
Startup and Shutdown
Web Browser
Workspace
Help
Install/Update
Run/Debug
Spotfire 5+
Console
Editor
Outline
Output
Task Tags
Statistics Services
f Team

Editor

These options control settings for the Spotfire S+ Workbench Script

Spotfire 5+ Editor options
Syntax Highlighting

Default
Comment
Keyword

Quocted String
Dbl Queted String
Constant

Choose Color E

Hower
Evaluate expression and display v

Spotfire 5+ Format Options
Margin Column 60

User Tokens

Messages
.Random.seed
.Temporary.file.list
Step.Funct
fuelrows
last.dump

alue if engine available

[] Use Spaces for indentation | 4

Encapsulate all scope blocks with {}

Start each scope block on a new
if (xk==1)
{
print("x == 1")
1
else

line

»

’ Restore Defaults ] ’

Apply

l

®

[ ok

)|

Cancel

Figure 1.11: The Editor page of the Preferences dialog.
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Highlighting
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Specifies the colors for text and defined syntax appearing in the Script
Editor. To change the default color for any of the items listed, click
Choose Color and, from the color picker dialog, select a color.

Note

To set background color, in the Preferences dialog, select General » Editors » Text Editors,
and, in the Appearance color options box, select Background color. See the Workbench User
Guide for more information about setting general options.

User Tokens

Hover

Lists items specified for user-defined syntax highlighting.

By default, no user-defined highlighted terms are defined. Any term
you define using this option appears in the Spotfire S+ Script Editor
in the color you define in Syntax Highlighting for the option User.
To add a user-defined token, click New, and then, in the Add
Desired S-PLUS Text dialog, provide the term or source.

S* Add Desired 5-PLUS Text [ of X

@ Comma Separated Text () Cornma Separated File () 5-PLUS Command

S-PLUS Text to Highlight  census|

[ OKV\,\)J [ Cancel

Figure 1.12: Add Desired S-PLUS Text dialog.

In the Add Desired S-PLUS Text dialog, you can provide:
* Individual terms, separated by commas.
* The contents of a comma-separated file.

* The results of a S-PLUS command. (Note that Figure 1.11
shows the results of the S-PLUS command objects(), which
adds all objects in the current working project to the User
Token list.

For more information about adding user tokens, see the section
Spotfire S+ View Preferences on page 138.

Displays a tooltip when the mouse hovers over an expression. The
tooltip displays the value of the expression, if the engine is available.
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Spotfire S+ Provides control over the Spotfire S+ Workbench’s automatic code
Format Options  layout and formatting style.

Note

Changes you make to the Spotfire S+ Format Options do not affect your code until you select
from the menu Spotfire S+ » Format.

Table 1.2: Spotfire S+ Format Options.

Format Option Description

Code Line Width Sets the width of the text area, counting from
the left-most character. By default, set to 60,
making the editing space 59 characters wide.

Use Spaces for By default, cleared. If selected, the default
Indentation value is 4. If you leave this cleared, the auto-
formatting feature uses tab indents, rather
than character spaces.

Encapsulate all scope Select to enclose all of your scope blocks
blocks with {} with curly brackets ({}). Selected by default.

Start each scope block | Inserts a line break before the first line of a
on a new line scope block.

The read-only text box appearing at the bottom of the Spotfire S+
Format Options area provides an preview of your choices.
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Lists the options to display anonymous functions and functions to

watch.

r

S i L 1O it
type filter text Outline . S
i 'Iielreral Spotfire 5+ Outline options
> Hel
InSt:H.-"Update Show Ancnymous Functions in OQutline
> Run/Debug Functions to Watch
4 Spotfire 5+ setMethod =
Console setClass _
i setReplaceMethod —
Edlto.r i Remove
Outline cetls
Output setValidity
Task Tags setGeneric
Statistics Services setGroup )
. Team setGroupGeneric
setClassPrototype
’Ratore Defaults] ’ Apply ]
@j ’ ‘k ] ’ Cancel ]

%

Figure 1.13: The Outline page of the Preferences dialog.

By default, the Spotfire S+ Script Editor shows anonymous functions
in the outline.

Contains a predefined list of Spotfire S+ functions to identify in the
Outline view. You can add your own functions to this list using the
New button. You can also remove functions from the list or reorder

the list.
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Output
Options

Font Settings

Background
Settings
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The Output page controls settings for the Spotfire S+ Workbench

Output view.
S* Preferences uﬂl—J&
type filter text Output P s
> Eizel Spotfire S+ Output options
- Help
- Install/Update Font Settings
: RU”-"[_’EbUQ abcdefghiikl . . .
4 Spotfire 5+ Font Selection Change
Console
Editor _
Outline Output Color | I
Cutput
Task Tags .
Statistics Services Background Seftings
S Team @) System Default () Custom
IRestore Defaults‘ I Apply ‘
Iy
'\?,' [ oK ‘ I Cancel ‘

Figure 1.14: Output page of the Preferences dialog.

By default, the Output view displays output text using the default
system font as red. You can change both the font and the color.

+ To set the font, click Change, and then, in the Font dialog,
select from Font, Font style, Size, and any additional font

properties.

* To set a custom font color, click the Output Color button,
and then, in the Color picker, select a color for the output.

By default, the Output view uses the system default. Select Custom
Color, and then click the color button to display the Color picker
and choose a different background color.



Task Options

Statistics
Services
Options
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Lists the three pre-defined default task tags. See the section Tasks view
on page 86 for more information.

r P ™
S Preferences L o
type filter text Task Tags & - .-

) 'Iielreral Spotfire 5+ Task options

> Help

FLXME {HIGH}
ety L My
R TODO {NORMAL}
> Run/Debug XXX {LOW]

4 Spotfire 5+ Rermove
Console -
Editor P
Outline Toin
Output
Task Tags

Statistics Services
> Team
’Restore Defaults] ’ Apply ]
@j [ OK ] ’ Cancel ]
L

Figure 1.15: The Task Tags page of the Preferences dialog.

If you use TIBCO Spotfire Statistics Services, you can set preferences
for interaction between Spotfire S+ Workbench and Spotfire Statistics
Services. See the section Statistics Services view on page 76 for more
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Number of jobs

to load upon
connection
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information about its view. See the section Spotfire Statistics Services
Remote Submissions on page 178 for information about using the
Spotfire S+ Workbench with Spotfire Statistics Services.

S Preferences e N | = S
type filter text Statistics Services =1 v v
> General
MNumber of jobs to load upon connection: 10
> Help
> Install/Update MNumber of rows to retrieve to preview a data file: 10
- Run/Deb
an .e % Job return value prefic  retVal
> Spotfire 5+
Statistics Services Data preview object prefic  preview
> Uz Data summary value prefic  summary
Data file extensions:
o
cpt
csv
dat Remove
db U
dbf i
dta
i fsc Down
jnb
mat
mdb
mtw
por
prn
rec
sas7bdat
sav
sd2
sdd
ssd0l
ssd04
stc
syd
sys
tpt
bt
xls
alsx
xpt
’Restore Defaults] ’ Apply ]
@j ’ 0K ] ’ Cancel ]

Figure 1.16: the Statistics Services page of the Preferences dialog.

Set the specified list of jobs to appear in the Statistics Services view,
in the tree view Jobs folder. If the Spotfire Statistics Services server
you connect to has jobs stored, the specified job list appears, starting
with the most recent job. The default is 10. You can set this value to
any number greater than 0, up to 1,000.
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+ Ifyousetit to 0, the default of 10 is used.

+ If you specify a number larger than 1,000 or a non-numeric
character, the dialog displays an “Invalid field value” error
and the text box turns yellow. If the error text contains an
ellipsis (...), the message is truncated. Widen the dialog box to
display the entire message.

* If you change this number while you are connected to the
Spotfire Statistics Services computer, the display does not
change until you disconnect and reconnect.

+ If you run jobs in excess of this number, all jobs are displayed
until you disconnect and reconnect.

+ If you delete jobs from the list, any earlier existing jobs are
appended to the list, up to the maximum number of available
jobs or the specified number.

Number of rows If you have data stored on the Spotfire Statistics Services computer,

to retrieve to set the number of rows to display in the Output view. Note that this

preview a data number includes the row containing column names as one of the

file rows. You can set this value to any number greater than 0, up to
10,000.

+ Ifyousetit to 0, the default of 10 is used.

+ If you specify a number larger than 10,000, the dialog displays
an “Invalid field value” error and the text box turns yellow.

+ If you reset this number while you are connected to the
Spotfire Statistics Services computer, the number of rows to
preview is displayed the next time you select Preview File.
(Reconnecting is not required.

Note

The preview and summary options are run on the server, not on the client; therefore, data size
limit restrictions of 256k apply. Depending on the data type and/or the number of columns, you
might encounter size error limits, even if you specify a number of rows well below the maximum

allowed by the Workbench.
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Set a string of text to prepend to the return value information
displayed in the first line of the Output view. The string must include
only letters from the standard English character set, numbers, and
dots (.). The string cannot include spaces. The string can begin with a
letter or dot (.), but not a number. In the return value output, this
value is separated from the server name and job number by a dot. For
example, if you change this option to Sample.Return.Value:

Prefix Server name

= Sample.Return.Value.localhost.57 |

Figure 1.17: Job return value prefix, server name, and job number.

« If you specify an illegal character, the dialog displays an
“Invalid character” error and the text box turns yellow. If the
error text contains an ellipsiss (...), the message is truncated.
Widen the dialog box to display the entire message.

+ If you leave this text box blank, it uses the default of retval.

Set a string of text to prepend to the data preview information
displayed in the first line of the Output view. The string must include
only letters from the standard English character set, numbers, and
dots (.). The string cannot include spaces. The string can begin with a
letter or dot (.), but not a number. In the return value output, this
value is separated from the file name by a dot. For example, if you
change this option to Sample.Data.Preview:

Sample.Data.Preview. fuel .cov

Figure 1.18: Data preview prefix and file name.

+ If you specify an illegal character, the dialog displays an
“Invalid character” error and the text box turns yellow.

+ If you leave this text box blank, it uses the default of preview.

Set a string of text to prepend to the data summary information
displayed in the first line of the Output view. The string must include
only letters from the standard English character set, numbers, and
dots (.). The string cannot include spaces. The string can begin with a
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letter or dot (.), but not a number. In the return value output, this
value is separated from the file name by a dot. For example, if you
change this option to Sample.Summary:

| Preﬂ}J | Filen%

Sample.Summary . fusl.cav |

Figure 1.19: Summary prefix and file name.

« If you specify an illegal character, the dialog displays an
“Invalid character” error and the text box turns yellow. If the
error text contains an ellipsiss (...), the message is truncated.
Widen the dialog box to display the entire message.

+ If you leave this text box blank, it uses the default of summary.

Data file Lists the file extensions of the data types that are displayed in the

extensions Statistics Services view data repository folders. By default, this list
shows common data file types in alphabetical order. You can edit this
list to reflect the data types you work with most commonly, in the
order that you use them. The Statistics Services view filters to
display only the listed extensions in the data repository folder.

Note

The Data file extensions list does not include all file types supported by the importData
function in S-PLUS. For a complete list, see its Help file. (Hint: Type ?importData in the
Console view to display the help for the function, or access it using the Help > Spotfire S+
Help menu item.)
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Table 1.3: Data File Extension actions.

Button

Description

New

Adds a data file extension for the type of data you
have in your Spotfire Statistics Services data
repository. When you add a data type extension, it
appears at the top of the list in this dialog.

If you add an extension that is currently
unsupported by S-PLUS, S-PLUS will attempt to
read the file as ASCII text.

Remove

Removes a data file extension that you do not use,
or you do not need to see displayed. You can add
them back to the list as needed.

Up/Down

Moves the selected data file extension either up or
down the list. For example, you can use this option
to display your most-commonly used data types
first.

Restore Defaults

Restores all Statistics Services options to their
original state.
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EXAMINING THE SPOTFIRE S+ WORKBENCH GUI

Spotfire S+
New Project
Wizard

Working with
Files External to
the Project

Customized
Menus,
Toolbars, and
Dialogs

Customized
menus

After the Spotfire S+ Workbench GUI opens, and you set
preferences, spend a moment examining the user interface, including
the toolbars, menus, perspectives, and views.

* For more information about perspectives, see the section
Spotfire S+ Workbench Perspectives and Views on page 42.

*  For more information about views, see the section Examining
the Views on page 43.

When you start a new Spotfire S+ project in the Spotfire S+
Workbench, you see the New Project wizard, where you specify the
location of your project files. See the section Quick Start on page 127
for more information about specifying the project file location.

You can use the Eclipse editor to edit non-project files in the Spotfire
S+ Workbench. To open a non-project file, on the File menu, click
Open File, and then browse to the location of the file to edit. For
more information about editing files in Eclipse, see the Eclipse

Workbench User Guide.

The Spotfire S+ Workbench includes in the Eclipse GUI:
+  Customized top-level menu items.
*  Customized top-level toolbar.

+ Customized view-specific toolbars and view menus. (See the
section Control and Right-Click Menus on page 46 for more
information about the menus.)

Spotfire S+ customizes the basic Eclipse menu to provide easy access
to global Spotfire S+ control and to control debugging options.
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File Export (Spotfire S+ Package)

The Eclipse menu item File »Export contains a Spotfire S+ option
to export a Spotfire S+ package.

Select an export destination:

|type filker bext |

(= General
(= RunjDebug
== S-pLUS

(= Team

Figure 1.20: Export dialog.

Use this two-step wizard to create either a source or a binary package.
The second dialog of the wizard provides the options to specify the
package project to build, the type of package to create, and the
location to place the package. For more information on using this
wizard, see the section Building the Package on page 170.

S| Export S-PLUS Package |:||E|r‘5__<|

Export 5-PLUS Package
Export 5-PLUS Project as 5-PLUS Package

Export Package: | mypkg | [Browse... ]

Build Options
() Build Source Package
(%) Build Binary Package

Export Location: | D:Ylocal_packages v| [Browse... ]

[ Finish ] [ Cancel

Figure 1.21: The Export Spotfire S+ Package dialog.
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Spotfire S+ Menu

The Spotfire S+ menu contains the following options:
Table 1.4: Spotfire S+ menu options.

Spotfire S+

Menu

Option Description

Format Applies Spotfire S+ consistent formatting and line
indentation to the entire script.

Toggle Designates the selected text in the Script editor as a

Comment comment, or, if the selected text already is a comment,

removes the comment designation

Shift Right Moves the selected text to the right.

Shift Left Moves the selected text to the left.

Define In the Spotfire S+ Script Editor, sets the currently-
Folding selected code block as a collapsible block. A collapsible
Region region is indicated by the icon in the left margin,

and a vertical line, marking the region to collapse. A

collapsed region is indicated by the icon & .

In Windows, you can hover the mouse pointer over the
collapsed region to display the contents of the region in

a tooltip.
Run Runs the code that is currently selected. If nothing is
Selection selected, the current editor contents are run.

This menu item also appears in the right-click menu of
the Spotfire S+ Script Editor and is represented by the

Run Spotfire S+ Code button on the main Spotfire S+
Workbench toolbar.

Run Current | Runs the entire contents of the script currently open in
File the Spotfire S+ Script Editor.
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Table 1.4: Spotfire S+ menu options. (Continued)

Spotfire S+
Menu
Option

Description

Find
“function”

Finds the selected function definition and opens it for
editing.

Find looks first in files currently open in an editor, then
it looks through your workspace. Finally, it searches the
Spotfire S+ database.

If the function is not found in an editor and multiple
definitions exist in the workspace, use the resulting
dialog to indicate the proper source.

Note: Highlighting a function and typing CTRL+mouse
click also opens the selected function definition for
editing.

See the section To edit a function definition on page 159
for more information

Find
References

Locates and highlights all instances of a function call in
a workspace. Find References opens the Search view
and displays the number of times in a workspace where
the selected function is called. You can See the Eclipse
Workbench User Guide for more information about the
Search view.

See the section To find all references to a function on
page 159 for more information.

Copy to
Console

Copies the selected code and pastes it into the Console
view. See the section Copying Script Code to the
Console on page 164

Open
Spotfire S+
Help File

Opens the Spotfire S+ Language Reference to the topic
for the selected function. If you have no documented
function selected, the help function topic is displayed.
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Table 1.4: Spotfire S+ menu options. (Continued)

Spotfire S+

Menu

Option Description

Update Locates and optionally copies either source or binary
Packages (Windows") updated packages posted to the specified

repository or local folder.

If you have no packages installed, or if you have only
the latest versions of the packages, then the Packages
list box displays no results. For Type, if you select:

* Binary: you can either install or install and
load the binary package.

*  Source: you can copy the package source files
to the location of your choice. By default, the
files (and their folder structure) are copied to
your current workspace.
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Table 1.4: Spotfire S+ menu options. (Continued)

Spotfire S+
Menu
Option

Description

Find
Packages

Locates and optionally copies either source or binary
packages located in the specified repository or local
folder. (For Windows, you can download either source

or binary packages; for UNIX®, you can download
only source packages; however, you can install, install
and load, and copy source packages.)

+ If, for Type, you select Binary, you have the
option either to install or to install and load the
binary package.

+ If, for Type, you select Source, you can
download the package source files to the
location of your choice. By default, the files
(and their folder structure) are downloaded to
your current workspace.

Note that this option finds built packages only (that is,
those that are zipped or tarballed); it does not load
unbuilt package directories and their files. To open a
package to build and then install, open it as a new
project, and then build it and install it. For more
information about finding and downloading packages,
see the section Downloading Package Source Files from
a Repository on page 172

Run Menu

The Run menu varies, depending on the perspective selected. In both
the Spotfire S+ and Debug perspective, the following Spotfire S+

Workbench

options are available. (See the corresponding

descriptions for the toolbar buttons in the section The Spotfire S+
Workbench Toolbar on page 38 for more information.)

* Run Spotfire S+ Code
* Run Next Spotfire S+ Command

* Stop Spotfire S+ Code

* Toggle Spotfire S+ Debugger




Customized
Toolbars
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+ Toggle Spotfire S+ Profiler
* Toggle Spotfire S+ Warning Breakpoint
* Toggle Spotfire S+ Error Breakpoint

For more information about the Run menu options available only in
the Debug perspective, see the section Debug Run Menu Options on
page 94.

Window Menu

The Spotfire S+ Workbench preferences are available from the
Window P> Preferences menu option. See the section Examining
Spotfire S+ Preferences on page 14 for more information.

Help Menu

Reference help, conceptual help, books, and user-interface guidance
are available from the Help menu.

+ Click Spotfire S+ Help from the Help menu to display the
Spotfire S+ Language Reference topic for the help function.

* Click Spotfire S+ Manuals for a list of the PDFs that are
installed by default with your Spotfire S+ installation.

Both Spotfire S+ perspectives in the Workbench provide
customizations to the Eclipse toolbar and to view-specific toolbars.
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The Spotfire S+ Workbench Toolbar

Regardless of the displayed perspective, the Spotfire S+ Workbench
toolbar appears in the IDE.
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Figure 1.22: The Spotfire S+ Workbench toolbar.

Note

Eclipse implements a Run menu item that is different from that of Spotfire S+ Workbench
implementation. Use the Spotfire S+ Workbench Run menu item.

Use the Spotfire S+ Workbench toolbar to control running,
debugging, breaking, and profiling your code.

Table 1.5: Spotfire S+ Workbench toolbar.

Button | Description

Run Spotfire S+ Code. Click in either the Debug or the
Spotfire S+ perspective to run code that appears in the editor.
(To view the output, select the Output.)
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Table 1.5: Spotfire S+ Workbench toolbar. (Continued)

Button | Description

Run Next Spotfire S+ Command. Looks for the current
selection and runs the top-level S expression found at that
location.

Fin

If the cursor location does not match an expression exactly,
the next expression is evaluated (rather than the first one).

The output is routed to the Output, and the next expression is
selected automatically (or the first expression in the script is
selected automatically, if the expression that was just run was
the last one).

Stop Spotfire S+ Code. Click in either the Debug or the

Spotfire S+ perspective to stop running code.

Toggle Spotfire S+ Debugger. Engages the Spotfire S+

o8 debugger. (You can engage the Spotfire S+ debugger in
either the Spotfire S+ or the Debug perspectives; however, by
default, the views displaying debugging information are
visible in the Debug perspective.)

After you engage the Spotfire S+ debugger, any expression
you type in the Console, or that you run by clicking Run
Spotfire S+ Code on the toolbar, invokes the Spotfire S+
debugger.

Toggle Spotfire S+ Profiler. Engages the Spotfire S+
Profiler. (You can engage the Spotfire S+ Profiler in either the
Spotfire S+ or the Debug perspectives; however, by default,
the views displaying profiling information are visible in the
Debug perspective.)

You do not need to engage the Spotfire S+ debugger in
order to engage the Profiler. See the section Profiler on page
120 for more information.
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Table 1.5: Spotfire S+ Workbench toolbar. (Continued)

Button | Description

Toggle Spotfire S+ Warning Breakpoint. Requires that
the Spotfire S+ debugger be toggled on. Stops execution if
Spotfire S+ encounters a warning. See Table 3.7 in the section
Breakpoints view on page 113 for more information about
warning breakpoints.

Toggle Spotfire S+ Error Breakpoint. Requires that the
Spotfire S+ debugger be toggled on. Stops execution if
Spotfire S+ encounters an error. See Table 3.7 in the section
Breakpoints view on page 113 for more information about
error breakpoints.

View toolbars

For more information about individual views’ toolbars, see the
individual views’ descriptions. See the section Examining the Views
on page 43 for more information.

The Workbench features a status bar that provides important
information about the working project and the current view.

Censusicensus.demo.ssc | % Census by [ | veete Smart Insert | 1061 1

Figure 1.23: Status bar.
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Table 1.6: Spotfire S+ Workbench status bar.

Status Item Description

Show View as Fast View. An Eclipse feature.

1
&

*  Click to display a list of available views,
and then select a view to maximize it and
add its icon to the status bar.

*  Click the view’s icon in the status bar to
minimize the view. (Alternatively, click the
view’s minimize icon, in its upper right
corner, to minimize it.)

For more information, see the Eclipse Workbench
User Guide.

Current working directory and file. When the

E Script Editor has focus, this section of the status bar
ensusfrensus, demo, ssc X
displays the current file.

Working project. Displays the name of the project
that is currently set as the working project. For more
information about the working project, see the
section Working Projects and Databases on page
151.

W Census

Status indicator. When the box is labeled Busy,
ﬁ and the status indicator is filling, then code is
- currently running. When the box is clear and reads
Ready, no code is running.

File attribute. Indicates whether the file is read-

wiitahle only or writable.

Smart Insert. Toggles the insert mode. To toggle
this view, type CTRL+SHIFT+INSERT. When Smart
Insert mode is toggled off, typing aids like
automatic indentation, closing of brackets, and so
on, are not available. Smart Insert is an Eclipse
feature.

Smarkt Inserk
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Table 1.6: Spotfire S+ Workbench status bar. (Continued)

Status Item Description

Cursor position. Indicates the line and column
position of the cursor.

1061

The Spotfire S+ Workbench plug-in for Eclipse includes two
customized perspectives:

* The Spotfire S+ perspective
* The Debug perspective.

(See Table 1.1 for a short description of the perspectives.) By default,
each perspective includes Eclipse views and customized Spotfire S+
Workbench views.

You can change the perspective to suit your development style by
moving, hiding, or closing views. For more information about
customizing the views within the perspective, see the section
Customizing the Spotfire S+ Perspective Views on page 69. For
practice exercises customizing the perspective, see the section
Customized Perspective Views on page 148.

* To customize the default Spotfire S+ perspective, on the
menu, click Window P> Customize Perspective. The
Customize Perspective dialog has two pages: Shortcuts and
Commands. Each of these pages describes global changes
you can make to the perspective.

+ To save a changed perspective, click Window P> Save
Perspective As.

* To restore an unsaved perspective’s default settings, click
Window P> Reset Perspective.

*+ To open another perspective, click Window P Open
Perspective, and then select a perspective from the Select
Perspective dialog.
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Figure 1.24 shows the Spotfire S+ perspective with the views set at
their default positions.

File Edit Spotfire S+ MNavigate Search Project Run Window Help
o~ L e d Qv = = - -

E5 %% Debug [ s° Spotfire 5+

‘5. Navigater 2 =8 sample.surnames.ssc 5% soundex.ssc =8
IEE=- 1
4 =2 Soundex = =
= Data i
(= data =
= man
4 =R 5
8= out... 52 | SHist.. | 4l Sta.. | = B

R W ow [T

4 samplesumames

& Console 52 | %5 Objects| 37 Search Path | ¥ Tasks | [/ Problems | ¥ Output =g ~§~~¥ =08
Spotfire S+ Command Line
TIBCO Software Inc. Confidential Information
Copyright {(c) 1288-2010 TIBCO Scoftware Inc. ALL RIGHTS RESERVED.
i S+ Version 8.2.0 for Microsoft Windows : 2010

> soundexisample . surnames)
[1] *A261' 'A226' 'R200° 'ME00® 'El66° 'ES21° '0l65° 'OL55° 'L530° 'Z300°
[11] *z325°
>

Soundex/R/soundex.ssc @ kahanSum Ready

Figure 1.24: Spotfire S+ Workbench window, Spotfire S+ perspective.

Examining the A view is a visual component in the workbench. Views support the
Views script editor by providing alternate means of navigating through,
working with, and examining the elements of the project.

Using the standard Eclipse IDE features, you can:
*  Close a view by clicking the X icon on the view tab.

* Reposition a view by clicking its tab and dragging it to
another part of the UL

*  Set a selected view to “Fast View.” This option hides the view
to free space in the Workbench window and places a
minimized icon, which you can click to open the view, on the
status bar.

* Change the views you see in the perspective. See the section
To change the displayed views on page 149.

Most views have their own control menus. (See the section Control
and Right-Click Menus on page 46 for more information.)
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Saving views items changed in views

When you modify an item in a view, it is saved immediately.
Normally, only one instance of a particular type of view can exist in
the Workbench window.

Perspective views

The following table lists the views shown in each perspective and
indicates which views are shared by both perspectives. This section
includes descriptions for the views shared across Spotfire S+
Workbench perspectives.

Note

If you do not see one of the following Spotfire S+ specific views in the user interface, you can
display it from the menu by clicking Window » Show View P Other, and then selecting it
from the Show View list.

Table 1.7: Views in the Spotfire S+ Workbench perspectives.

Spotfire S+

Workbench Debug Description
View Name Perspective Perspective reference
Allocations X page 122
view
Breakpoints X page 113
view
Console view X X page 49
Debug view X page 100
Expressions X page 111
view
Function Calls X page 121
view
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Table 1.7: Views in the Spotfire S+ Workbench perspectives. (Continued)

Spotfire S+

Workbench Debug Description
View Name Perspective Perspective reference
History view X page 69
Navigator X X Eclipse Workbench

User Guide

Objects view X page 71
Outline view X X page 54
Output view X X page 56
Problems view X page 74
Script Editor X X page 57
Search Path X page 75
view
Statistics X page 76
Services view
Tasks view X X page 86
Variables view X page 106

Hint

Change the view layout by moving views around the IDE, or control the views displayed using
the Show View dialog. For more information, see the section To change the displayed views on
page 149.
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you right click the body of the view.

=25
=25 census {working)
= .Data
.project
EL] census.csw
risus.des

araph.setup.q
my.whar.q
B Readme. bxt
|=| Sample.scc
=-1=5 kahansum
= .Data
B Jproject
B apps. kxk
kahanaddMext_func.q
kahanSurm.g

Views contain their own control and/or right-click menus, with menu
items that act on the view display or on the type of data displayed in
the view. Menus are displayed either when you click the drop-down

button ( = ), located in the upper right corner of each view, or when

The following two images show the two types of menus in the
Navigator view. For more information about the Navigator, see the
section Navigator on page 52.

E S5-PLUS - census.demo.ssc - S-PLLUS Workbench

File Edit 5S-PLUS MNavigate Search Project Run Window Help
L Pk b T Q- oL

i census.demo.ssc B2

1 # EBig Data Cen:

Select Working Set. ..

Sork >
.
e Filkers. ..
% Link with Editar
=

10 # First source
11 =ource (paste (o
1Z =source [(paste (g
13 sep="r)

15 # Import the d:
16 census <— impo
17 S =amp.

Figure 1.25: Control menu, available via drop-down button.
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File Edit 5-PLUS Mavigate Search Project Runm '

G- [ S |

- oo < G

e ni

Go Into
Open in Mew Window

= Copy
. Faste
3 Delete
Move...
Rename

g2gImpart...
£ yExpart...

£ |Refresh
Close Project
Close Unrelated Projects

5= outline Team i
Compare With 3
Restore from Local History.,..

Properties

Source S-PLUS Files
Format 5-PLUS Files
<ing 5-PLUS Project

1

Figure 1.26: Context-sensitive menu, available via right-click in the view.

* The Script Editor has only a context-sensitive menu, available
via a right-click action. Its available options depend on the
current selection in the editor. For example, if you select text
and right-click, you have the option to cut or copy the
selection. If you select a Spotfire S+ function, you have the
option to open the Spotfire S+ Help file for that function.

The options on the Script Editor’s context-sensitive menu are
a selection of options that appear on the main menu.

* The Outline view and the Allocations view have only the
control drop-down menu.

In the following views, the right-click (context-sensitive) menu and
the control drop-down menu are identical. The control menu for each
view is described in this document in the section describing its view.
See the section Examining the Views on page 43 for more
information:

« Console view.
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Function Calls view.
History view.
Objects view.
Output view.

Search Path view.

The following views each contain two different menus:

The control menu, available from the drop-down button.

The context-sensitive menu, available via right-click in the
body of the view. The options available on the right-click
menu vary according to the item selected in the view (for
example, removing a selection, copying a selection, and so
on.) For more information about where each view appears,
see the section Perspective views on page 44.

Table 1.8: Views with different control and right-click menus.

View Location of more menu information
Breakpoints view page 113

Debug view page 102

Expressions view page 108

Navigator page 52

Problems view page 74

Statistics Services view page 76

Tasks view page 86

Variables view page 108

Each view action also has a quick-key sequence to perform an action.
(For example, to clear the text in the console, with the Console
active, type CTRL+L.)
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The following sections describe the views that are shown, by default,
in both the Spotfire S+ perspective and the Debug perspective.

The Spotfire S+ Workbench Console is an editable view, analogous
to the Commands window in the Spotfire S+ GUI Using the
Console, you can:

* Run individual Spotfire S+ commands by typing them and
pressing ENTER.

* Scroll through previous commands by pressing the UP or
DOWN arrow on the keyboard.

* Copy an individual command or blocks of commands from
the Script Editor, using the Copy to Console menu item, to
run them in the Console. (Note that you do not need to select
Paste; Copy to Console copies your selected text in the
Script Editor and pastes it into the Console.)

B console 3 Objects Search Path Output | Tasks | Froblems fna =~ =0
5-PLUS Command Line
EOUITE[PAST C\CCE,!I\'H SHURE ), FEANpPLIEESDIgOATS/ CENSUS/grapn Setup. q | ~
===

# Import the data, use the bigdata=T flag to create a bdFrame cbject
>c|:n.5u5 ¢— inportData(paste(geteny("SHOME" ),
"ssamples-bigdata‘census-census csv", s=p=""),
stringsis l‘a tors=F. blcdata T)

»names(census) - c("zipcode”. "lat®. "long". "popTotal®. paste({'male”. seq(D. 85, by
paste("fenale” ::'—r[|_1_ 85. by = 5). =ep = "."). hr usingTotal", "o
sumnary (census )
zipcode lat long popTotal
Length 33178 Min.:17962234 Min.:-176636755 HMin 0.000
Clas=s l‘ear 38830389 Mean: -91084343 Hean 8596.977 w
L4 >

Figure 1.27: Spotfire S+ Workbench Console.

+  Copy from the console to a script file. (You can also copy the
command prompts. To set this option, on the menu, click
Window P> Preferences, and on the Console/Output page,
select Include Prompts in Copy action.)
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Code Completion in the Console

The Console provides code completion assistance. When you begin
typing a function name, a list of functions matching the string appears
in a hint box.

I console 23 Objects | Cutput | Tasks | Problems |

5-PLUS Command Line
S-FLUS : Copyright {c) 1988, 2008 Insightful G
S . Copyright Insightiul Corp.
Enterpri=e Developer Version 8.1.0 for Hicros
Working data will be in C:-DOCUMENTS AND SETTI
> imp
impaorkDakta
impartObjToDF

Figure 1.28: Code completion in the Console.

After you select the function from the list and type an opening
parenthesis character, the function’s arguments appear in a hint box:

=) Consale 52

-PLUS Command Lir
S-FLUS . C
S . Copyri
Enterpri=e
Working dat

> importDatad

Figure 1.29: Function arguments available for importData, displayed as a code
completion hint.
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The function’s arguments, as shown for importData in Figure 1.29, is
displayed in the hint box until you type the closing parenthesis
character.

Note

For the code completion list, the Spotfire S+ Workbench reads the Search path on startup and
includes all functions in loaded libraries. It refreshes that list periodically.

Console control and right-click menus

The Console controls include these Eclipse options:

Pin the view in place ( 7).

Toggle between open Console views ( & ).

Open a new Console ().

The Console control menu and right-click menu are the same. You

can use the Console control menu (click = or right-click the body of
the Console) to perform the following tasks:

Clear the contents of the console.

Copy the selected text.

Cut the selected text.

Paste text from the clipboard to the console.
Find a string.

Select all text.

Save the console contents to a file.

Print the console contents.

Open the Preferences dialog to set such options as font color
and style, among others.

For exercises using the Spotfire S+ Workbench Console, see the
section Copying Script Code to the Console on page 164. For more
information about the Spotfire S+ Commands window, see Chapter
10, Using the Commands Window in the Spotfire S+ User’s Guide.
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The Navigator is a standard Eclipse view. Its drop-down (¥) control
menu is standard to Eclipse, while its right-click menu contains three
Spotfire S+-specific items, described in the following section. For
information about using the Navigator, see the Eclipse Workbench
User Guide, available from the Help » Help Contents menu.

Navigator control and right-click menus

In addition to having a drop-down control menu, the Navigator has
a right-click menu containing three Spotfire S+-specific options:

Table 1.9: Navigator Spoifire S+-specific right-click menu options.

Menu option Description

Source Parses and then evaluates each expression in the
Spotfire S+ selected project or file. (Note that if you have selected
Files the project, every file in that project is sourced.)
Format Applies Spotfire S+ consistent formatting and line
Spotfire S+ indentation to all scripts in the working project.

Files

To customize the formatting options, on the main
menu, click Window P Preferences, in the left pane,
click Spotfire S+ to expand the view, and then click
Editor. Use the Editor page to customize formatting
options. See the section To change the code formatting
options on page 144 for more instruction.
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Table 1.9: Navigator Spotfire S+-specific right-click menu options. (Continued)

Menu option Description

Toggle Available when you select a project in the Navigator.
Working The project that you set as working becomes the
Spotfire S+ current working directory, or the root to which all
Project relative paths are resolved.

The working project also becomes the first position (in
the search path, which you can see in the Search Path.
This path contains the .Data database. All objects
created as a result of running code in the Spotfire S+
Workbench are written to that .Data database
(regardless of the project the code is in).

When you toggle off (that is, clear) the selection and
have no working project, the .Data database is set to
the current workspace, and the Search Path shows the
workspace in the first position. In this case, all objects
created in any project are written to the .Data database
in the workspace and are available to any project in the
workspace.

See Figure 1.30 for an illustration. For more
information about working projects and the current
working directory, see the section Setting the Working
Project on page 151.
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Figure 1.30: Toggle Working Spotfire S+ Project shows current working project
at the top of the Search Path.

The Outline view displays an outline of the elements in the script
open in the script editor. In the Spotfire S+ Workbench, Outline view
displays functions and objects in the order they appear in the script
editor. Items that you have identified to “watch” in the Functions to
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Watch text box of the Preferences dialog appear in the Outline
view with an arrow. You can jump to the definition of a function or
object (or other structure element) by clicking it in Outline view.

0% outline 23 History| =0
W% owmow g7
----- A rensus =
----- & census,goodPop
----- & ageDist
..... s bars

----- & rensusstack

----- & ageFackor

----- & popProp

----- & MOFM.EXPrs

----- & popProph

----- & censush

----- = set.seed —
----- & clusterCensush

----- & censushPred

clusterMeans

----- & clusterCounts

----- & clusterMeansCounts _I
-

Figure 1.31: Spotfire S+ Workbench Outline view.

Note

The Outline view updates only after you save changes to its associated file, displayed in the

Script Editor.
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Outline view toolbar

The Outline view contains a toolbar that displays the following
toggle buttons:

Table 1.10: Outline view buttons.

Button Description

Hides all standard functions displayed in the Outline view.
Click again to display standard functions.

Hides all functions that you have designated to watch
s displayed in the Outline view. Click again to display the
functions.

Hides all anonymous functions displayed in the Outline
view. Click again to display the functions.

Hides all variables in the Outline view. Click again to
display the variables.

Sorts items displayed the Outline view alphabetically. Click
again to return the items to the order in which they appear
in the script.

Displays a menu showing all buttons available on the button
bar. (You can toggle these selections either using the menu,
or on the button bar.)

Outline view control menu

The Outline view control menu provides menu access to the buttons
visible on the Outline view toolbar, and to the Preferences dialog.
See the descriptions in Figure 1.10 for more information. (The
Outline view contains no right-click menu.)

The Output displays the code you run (and the results of the code
you run) when you click either Run Spotfire S+ Code on the
toolbar, or when you press F9. The text displayed in the Output is
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replaced each time you click Run Spotfire S+ Code or press F9.
That is, unlike the Console, the Output does not store and display
previously-run commands. Also unlike the Console, the Output is
not editable; however, you can select and copy lines of text in the
Output. You can also print or clear the entire contents of the Output.

Min 0.0000  Hin. 0. 0000 -
Mean: 173 6293 Hean: 157 5673
3855.0000 MHax.:23852.0000

8 fenale 85
Min 0.0000D0D Hin. : 0.00000
94 83658 Mean: 89.94133
Max. :Z666.00000 Hax.:2906.00000

housingTotal ovn Tent

Hin. ] Min o.oon Hin. : 0.00D
Mean: 3217 235 Mean: 2132 022 Mesn: 1085213
Max. 61541 .000 Max 35446 000 Max 40424 000

Figure 1.32: Spotfire S+ Workbench Output.

Output control and right-click menus

You can use the Output control menu (click ¥) to perform the
following tasks:

*  Clear the contents of the view.
*  Copy the selected text.

*  Find a string.

*  Select all text.

* Save the view contents to a file.
*  Print the view contents.

* Display the Preferences dialog to change the font color and
style.

The drop-down control menu and the right-click context-sensitive

menu are identical in the Output.

The Spotfire S+ Workbench Script Editor is a text editor displayed in
both the Spotfire S+ perspective and the Debug perspective. The
Spotfire S+ Workbench Script Editor is similar to the Script Editor in
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Spotfire S+; however, it contains additional script-authoring features
such as syntax coloring, code completion, and integration with the
other views in the IDE.

I =}
graph.setup.q 8
L0 LLLNLUELE Sole GHLHLOLieL Lee LOWo. = &l oos Lot s s Lol

N

29 # that contain "XE"™ or "H" or any other non-numeric charac

30
@ 31 pensus <- bd.filter.rows(census, "regexpr ('C[0-9148', zipcc—l‘:'
32
33 hd.data.viewer [census) ## 32,038 rows
34

35 # wvectorized way Lo remove
36 sys.time|

37 census. goodPop <- census[census[, "popTotal™] > 0,
35

¢ 39 HTODO: hd.data.viewer (census.goodPop) ## 32,165 rows
40

41 # Eliminate rows with no population count

42 sys.time|

473 census <— hd.filter.rows ilcensus, expr="popTotal >_E|ﬂ
»

Al
Figure 1.33: Spotfire S+ Workbench Script Editor.

You can run code in the Spotfire S+ Workbench Script Editor by

highlighting the code and clicking Run Spotfire S+ Code (") on
the toolbar.

Note

To interrupt code that you run from the Script Editor, either click Stop Spotfire S+ Code (on
the toolbar) or press ESC.

Text Editing Assistance

To help you write efficient, easy-to-follow scripts, the Script Editor
provides the following features:

* Displays keywords, user-defined text, and function arguments
in customizable colors. See the section Setting the Spotfire S+
Workbench Preferences on page 137.
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* Provides code completion hints, both for function names and
arguments, as shown in Figure 1.34 and 1.35.

*testfile.ssc &2

il lDII
plogis ~
plok
plot. ACF
plot. Yariogram
plot.aareg
plot. acf
plot. agnes
plot. arima
plot. augPred
plot.bdFrame
plot.bdElm w

Console | Objects E_==.E Qutput 3 Tasks | Problems

Figure 1.34: Code completion for the plot function.

*testfile.ssc_

1 plot|

Figure 1.35: Arguments displayed as part of code completion for the p1ot function.

Note

For the code completion list, the Spotfire S+ Workbench reads the Search path on startup and
includes all functions in loaded libraries. It refreshes that list periodically.

The function’s argument list, as shown in Figure 1.35, is displayed until you type the closing
parenthesis character ).

* Displays code line numbers in a column adjacent to the code.
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Provides automatic code indentation and parenthesis
matching. (See the Eclipse documentation for more
information on the editor’s standard features.)

Note

To indent selected text, first highlight the text to be indented, and then press TAB or CTRL+TAB
to shift the selected text right or left, respectively.

Activates the Script Outline view when you edit a script.

Displays task and breakpoint markers in the left margin, and a
task marker “thumb” in the right margin.

Displays the help topic for documented functions when you
select the function name, and then type F1.

Note

You can use the Eclipse editor to edit non-project files in the Spotfire S+ Workbench. To open a
non-project file, on the File menu, click Open File, and then browse to the location of the file to
edit. For more information about editing files in Eclipse, see the Eclipse Workbench User Guide.
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View integration

The Script Editor is closely integrated with the views in both the
Spotfire S+ perspective and Debug perspective. This integration
includes the following:

When you type a task keyword in the editor, it is
automatically added to the Tasks view after you save the file.
See the section Tasks view on page 86 for more information.

When you set a breakpoint, the breakpoint appears in the
margin of the Script Editor both in the Debug perspective and
the Spotfire S+ perspective. (You can also set a breakpoint in
the margin of the Script Editor in both perspectives. See the
section Setting breakpoints on page 190.)

When you make an error and save your script file, the error
shows in the Problems view. See the section To examine
problems on page 166 for more information.
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*  When you create a new object in the script, it appears in the
Outline view. To make it appear in the Objects view, you
must run the script and refresh the Objects view.

Script Editor right-click menu

The right-click menu in the Script Editor combines actions from the
Eclipse main menu, including the options available from the Spotfire
S+ menu, and the Preferences dialog.

See the section Spotfire S+ Menu on page 33 for information about
the Spotfire S+ options.

See section Setting the Spotfire S+ Workbench Preferences on page
137 for information about setting Preferences options.

(The Script Editor has no drop-down control menu.)
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COMMONLY-USED FEATURES IN ECLIPSE

The core Eclipse IDE contains many additional features that you
might find helpful in managing your projects. The following table lists
a few of these features, along with references to the Eclipse Workbench
User Guide to help you learn how to use them effectively.

Table 1.11: Eclipse Tasks and Features.

Task Eclipse Feature Description

Comparing files with | The Compare With Local History menu item
previous versions. is available from the control menu in Navigator
view. Using this feature, you can compare the
current version of the selected file with
previously-stored local versions. For more
information, see the topic “Local history” in the

Eclipse Workbench User Guide.

Replacing files with a | The Replace With Local History and Replace
previous version. With Previous from Local History menu
items are available from the control menu in
Navigator view. Using these features, you can
replace the current version of the selected file
with one of the previously-stored local versions.

Replace With Previous from Local History
displays no selection dialog; it just replaces the
file. To choose a previous state in the Local
History list, use Replace With Local History.

For more information, see the topic “Replacing a
resource with local history” in the Eclipse
Workbench User Guide.

Finding a word in a Using the Search » File menu item, you can
projectoratermina | find all occurrences of a word in a project or
Help topic. Help topic. For more information, see the topic

“File search” in the Eclipse Workbench User Guide.
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Table 1.11: Eclipse Tasks and Features. (Continued)

Task Eclipse Feature Description
Filter files in the Using the Working Sets menu option on the
Navigator view. control menu in Navigator view, you can create

subsets of files to display or hide. For more
information, see the topics “Working Sets” and
“Showing or hiding files in the Navigator view”
in the Eclipse Workbench User Guide.

View a file that is not | Use the File » Open File menu item to open a
part of your project. file that is not part of your project.

If you have a current Eclipse installation, and you want to use the
Spotfire S+ Workbench as a plug-in for that installation, you can set it
up using these steps.

To set the Spotfire S+ Workbench as an Eclipse Plug-in (Windows)

L.

In your SHOME/eclipse directory, locate the zip archive
com.insightful.splus.eclipse_3.4.zip.

Using a zip extractor tool such as WinZip, extract the contents
of the zip file into the folder above your Eclipse installation
directory. (That is, the folder containing the /eclipse folder.)

Alternately, extract the zip archive and copy the contents to
the corresponding directories under your Eclipse installation.

In the shortcut you use to start Eclipse, add the following:
-vmargs -Dsplus.shome=SHOME

where SHOME is the location of your Spotfire S+ installation.

To set the Spotfire S+ Workbench as an Eclipse Plug-in (UNIX)

L.

Follow the above instructions, using a UNIX zip utility (rather
than WinZip).

Start Eclipse, providing the command-line switches as follows:

-vmargs -Dsplus.shome=SHOME

where SHOME is the location of your Spotfire S+ installation.
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Chapter 2 The TIBCO Spotfire S+ Perspective

INTRODUCTION

TIBCO Spotfire S+ Workbench perspectives define the appearance
and behavior of the Spotfire S+ Workbench Eclipse plug-in,
including the Spotfire S+ Script Editor, views, menus, and toolbars.
The Spotfire S+ perspective combines Spotfire S+ Workbench views
and options so you can accomplish specific types of tasks and work
with specific types of resources.

+ For more information about the Spotfire S+ Debugger
perspective options and views, see Chapter 3.

* For practice instruction using the features in the Spotfire S+
perspective, as well as the Spotfire S+ Workbench and Debug
perspective, see Chapter 4, TIBCO Spotfire S+ Workbench
Tasks.

Note

You can change a perspective to suit your development style by moving, hiding, or closing
views. For more information about customizing the views within the perspective, see the section
Changing the Spotfire S+ Workbench Perspective on page 42, or see the section Customized
Perspective Views on page 148.
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SPOTFIRE S+ PERSPECTIVE VIEWS

The Spotfire S+ Workbench includes views shared across
perspectives. For a list of all views and their default perspectives, see
Table 1.7 in Chapter 1. (Chapter 1 also includes descriptions of the
shared views.)

The Spotfire S+ perspective includes default Eclipse views and
customized views. You can show or hide the customized views from
the menu by clicking Window » Show View P Other, and then
selecting the views from the list. Views in the Spotfire S+ perspective
include the following:

Table 2.1: Spotfire S+ perspective views and exercise references.

View Descriptions Practice exercises
Console view | Shared view. For a "To run copied script
description, see the section | code" on page 165.

Spotfire S+ Workbench
Console on page 49.

History For a description, see the "To examine the history"
section History on page 69. | on page 166.

Objects For a description, see the "To examine the objects"
section Objects on page 71. | on page 161.

Outline view | Shared view. For a "To examine the outline"
description, see the section | on page 160.
Outline view on page 54.

Output Shared view. For a "To run code" on page
description, see the section 166.
Output on page 56.

Problems For a description, see the "To examine problems"
view section Problems view on on page 166.
page 74.
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History

Spotfire S+ Perspective Views

Table 2.1: Spotfire S+ perspective views and exercise references. (Continued)

Services view

only for users of TIBCO

View Descriptions Practice exercises

Search Path For a description, see the "Adding a Database" on
section Search Path on page | page 153 and "Detaching
75. a Database" on page 154.

Statistics Spotfire S+ view, applicable | "Submitting a Remote

Job" on page 178.

Spotfire Statistics Services.
For a description, see the
section Statistics Services
view on page 76

"To add a task in the
script file" on page 163
and "To add a task
directly to the Tasks
view." on page 162.

Shared view. For a
description, see the section
Tasks view on page 86.

Tasks view

Both the Spotfire S+ perspective and the Debug perspective also
display the default Eclipse Navigator view, which displays project
directories and all files associated with each project. The Navigator
view and other Eclipse IDE views are described in the Eclipse

Workbench User Guide.

The default Spotfire S+ perspective settings control the views that
open by default in preset locations; however, you can customize the
view appearance, and then save the resulting perspective. See the
section Customized Perspective Views on page 148 for more
information.

The following sections describe only the views that appear by default
in only the Spotfire S+ perspective.

The History is similar to the Commands History dialog in Spotfire
S+ for Windows. The History is a scrollable list of commands that
have previously been run in the Console. (Commands that you run
by clicking Run Spotfire S+ Code or pressing F9 do not appear in
the History. See the section Output on page 56.)
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*  When you select a command in the History, the pending text
in the Console changes to the selected text. You can then
press ENTER, or you can double-click the text in the History
to execute the command. You can select only one line at a

time in the History.

* When you scroll up or down through previously-run
the Console, the corresponding command is

commands in

highlighted in

the History.

Note

In Windows, Spotfire S+ uses the key F10 to run a selected command. The Spotfire S+

Workbench uses the key F9 to run a selected command in all platforms.

outline | S 7 Histary £3 ~ =0
# Fir: ource in =o xtra f

# Imp

# Change wvariable names =o the
# First source in some extra f
censu=s <— bd.filter. rows{censu
sy=.tine(11 census . good
sy=.tins(11 census <— b
SURNATY{census)
hi=t{censu=$hou=ingTotal)
hi=t{censu=SpopTotal)
hi=t{censu=Srent)
nedian{censuszshou=ingTotal)

1 i

Figure 2.2: Spotfire S+ Workbench History

History control and right-click menus

You can use the Histo

* Select input displayed in the History and copy it to the

Console.

ry control menu (click ¥) to:

* Clear the History.
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Note

In the Preferences dialog, you can set the option to persist entries in the History between
sessions. For more information about this option, see the section Store Console History Between
Sessions on page 19. The History holds up to 150,000 lines of commands.

Objects

The drop-down control menu and the right-click context-sensitive
menu are identical in the History.

The Objects is similar to the Object Explorer in the Spotfire S+ GUIL
It displays all objects for projects associated with the workspace in
two panes: a table view and an expandable tree view (the Workbench
Object Explorer).

The two panes of the Objects are linked: when the Objects table
pane has focus, items you select in the table are highlighted in the tree
pane. When the tree pane has focus, objects you select in the tree are
also highlighted in the table pane. (If you select an object member in
the tree pane, its corresponding object is highlighted in the table
pane.)

Console mgsamPaH‘\|Ouw Tasks|PrDblems| = =0
Hame | Data Class |Storage . . | Estent |Obj. . |Date [ o E ageDist
agelist naned double El CEE] 2006.0
bars single =ingle 18 113 20060 4 bars
census bdFrame list 319... | 27033 2006.00 m
census. goodPop bdFrame list 319. 27040 2006.0| fensE
censusStack bdFrame list 115 10727 2006. 0| ) M=) consus.goodPop
graph . sstup function function 4 2279 2006.00 =
ny.vbar function function 7 4056 2006 0| B8] censusstack
+ ﬂ graph.setup
ns my.vha’
Ll \\ | +
==

Figure 2.3: Spotfire S+ Workbench Objects.

Objects control and right-click menus

You can use the Objects control menu (click ¥) to perform the
following tasks:

* Select another database.

* Refresh the view on the currently-active database.
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Remove the selected object from the currently-active
database.

Show or hide Spotfire S+ system objects, such as
.Last.value, .Data, and .Random.seed. (These objects are
hidden by default.)

Change the number of items displayed in the tree view
members.

The drop-down control menu and the right-click context-sensitive
menu are identical in the Objects.

Note

When you run code that creates objects in a Spotfire S+ script, the Objects is not automatically
refreshed to display the new objects. To refresh Objects and display newly-created objects, right-

click the Objects (or click the control menu button * ), and then from the menu, click Refresh.

Warning

If you select a large database, such as sp1us, in the Objects, it can take a long time to display the
contents in the table and tree view panes.

Objects table The Objects includes a table pane displaying a list of the names and
pane types of objects in Spotfire S+ databases. The Objects table includes
the following information about each object:
*  name
+ data class

storage mode
extent
size

creation or change date.

By default, the Spotfire S+ system objects, such as .Random.seed and
.Last.value are hidden. You can display these objects by toggling
the option on the Objects control menu.
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(tree view pane)

Spotfire S+ Perspective Views

The Objects includes an expandable tree view, the Object
Explorer. (See Figure 2.4.) Objects listed in the Object Explorer
correspond to objects in the Objects table pane.

The Object Explorer displays icons representing the type of object
or object member, along with its name as a label. (These icons are the
same icons used in the standard Spotfire S+ GUL.)

You can expand the objects to display each objects’ members. By
default, the Object Explorer displays up to 25 object members at
each expandable level. You can change this default using the Objects
context-sensitive menu item, Set Max Children.

ageDist
-- bars

b {28 o |

census,goodPop

censusStack

E| graph.setup
Mame
background. color
BODY

. whar

color,table

Figure 2.4: The Spotfire S+ Workbench Object Explorer.

+ Display the Set Max Children dialog to indicate the number
of object members to display in the Object Explorer. By
default, this option is set to 25.

M Set Max Children

Enter the maximurm number of Children:

[ o»}\%_] [ cancel

Figure 2.5: Set Max Children dialog.
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Problems view The Problems view is a standard Eclipse view that displays errors as
you edit and save code. For example, if you forget a bracket or a
quotation mark, and then save your work, the description appears as
a syntax error in the Problems view.

Note

Syntax problems appear in the Problems view only after you save the file.

If your code has a problem that is displayed in the Problems view,
and the view is not the active view, the Problems view tab title
appears as bold text.

To open the Script editor at the location of the problem, double-click
the error in the Problems view.

Consale | Objects | Search Path | Output | Tasks Em ===
1 erroe, O warnings, 0 infos
Description =~ ] Resource ] Path Ilocation |

I5: Ervors (1 item)
@ Synkax error: levels census.demo... Census line 104

Figure 2.6: Spotfire S+ Workbench Problems view showing the right-click context-
sensitive menu.

Problems view control and right-click menus

You can use the Problems view control menu (click =) to perform
the following tasks:

* Display the Sorting dialog to sort the problems displayed in
the view, either in ascending or descending order, and
according to the problems’ characteristics.

+ Display the Filters dialog to specify properties for filtering
problems.

For more information about using these dialogs, see the Eclipse

Workbench User Guide.
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You can use the Problems view right-click context-sensitive menu
(see Figure 2.6) to perform the following tasks:

* Jump to the location in the file containing the problem.

* Display the file name containing the problem in the
Navigator. (This action opens an instance of the Navigator.)

+  Copy the Problems view table to the clipboard.
* Select all entries in the table.
*  View the properties of the problem.

These menu items are standard to the Eclipse GUIL For more
information, see the Eclipse Workbench User Guide.

The Search Path displays the names and search path position of all
the attached Spotfire S+ databases.

[Console CObjects SJS«:!arcl‘iI:‘ath &3 Cutput | Tasks Problems i = |
| Search Path |

Census

bigdata
splus
stat
data
trellis
nlne3
winjava
menu
SPXML

main

D 0D O O e L R

0
1

Figure 2.7: Spotfire S+ Workbench Search Path.

The databases that are in your search path determine the objects that
are displayed in Objects. That is, if a database is in your search path,
the objects in that database appear in the Objects. See the section
Examining Objects on page 160. For more information about
working with the Search Path, see the section Changing Attached
Databases on page 153.

The first position in the Search Path shows the current working
directory, which can be either the workspace or the current path. You
can set a project to be the working project by right-clicking its name
in the Navigator, and then clicking Toggle Working Spotfire S+
Project. See the section Navigator on page 52, and the section Setting
the Working Project on page 151.
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Search Path control and right-click menus

You can use the Search Path control menu (click ) to:

Attach a library.

Attach a module.

Attach a directory.

Detach the currently-selected database in the view.

Refresh the current view.

The drop-down control menu and the right-click context-sensitive
menu are identical in the Search Path.

Note

When you use the control menu to add to (or remove from) the Search Path a library, module,
or directory, the view automatically refreshes. When you run code to add or remove a library,
module, or directory, the view is not automatically refreshed. To refresh the view, right-click the
Search Path (or click the control menu button, and then from the menu, click Refresh.

Statistics The Statistics Services view provides controls for connecting to one
p )
Services view ©or more running TIBCO Spotfire Statistics Services server(s) and
performing a variety of tasks, including:

76

Upload and download files, including data files.
Delete files, including data files.

Preview data contents and data summary information.
Upload and download packages.

View files and packages on the server.

Run jobs on the server.

View job results.

View and save to the local environment return values.
Schedule jobs.

Cancel scheduled jobs.

Monitor jobs.
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View warnings and examine log files.

View image files stored on the server (.spj, .jpg, .png, -pdf,

.wmf).

0% Outline | %] History | 44 Statistics Services 23

g B

- [7f Local Spotfire Statistics Services

4 [z T5CG Server
a = Data
4 [= appdata
(= library
= artifacts
4 = common
@ test.csv
» = tscg
- [ users
a = lobs
- |[5f 1112 (DoneWithError)
- [7f 1090 (Done)
» [= Packages

=0
N 0D

Figure 2.8: Statistics Services view.

For more information about performing these tasks, see the section
Spotfire Statistics Services Remote Submissions on page 178.

When you submit a job to the server, to get the results you expect,
remember the following:

The job you submit runs on a new S-PLUS engine instance.
The instance of the S-PLUS engine runs the job and stores the
results, and then is released. Your code must be self-
contained, depending only on objects or functions already
available on the server (that is, in a loaded Spotfire S+ library)

or part of your submitted job.

The S-PLUS engine returns only one result (the last
requested). If your job requires more than one result, store the
results in a list object, and then retrieve the returned object

containing the results.
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* If your server request produces a large data set, we
recommend that you save it in the Results directory of the
job. (This is the default location, unless you specify an
absolute path.) You can download the file from this location,
and then view the results.

Default Folders The Statistics Services view shows the folder structure for the
selected TIBCO Spotfire Statistics Services.

Table 2.2: Statistics Services view folders.

Folder Description

Data Contains files and folders for data files. You can add
individual files to this folder. To add a folder, see your server
administrator.

The types of data read by the S-PLUS engine are listed in the
help file for importData. See the section Statistics Services
Options on page 25 for information about filtering and
expanding the list of available data types.
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Table 2.2: Statistics Services view folders. (Continued)

Folder Description

Jobs Lists the jobs, in the order that they are submitted, with the
most recent jobs first. The job folder name consists of the job
ID and status (for example, 205 (Done) or 205 (Waiting)).
Job names whose folders have not been opened appear in
boldface font. You can delete completed jobs that you no
longer need, or you can interrupt jobs that are waiting to run.
All job folders include the following elements:

* Results: Contains the engine.log file and any other files
(such as graphic files) created as a result of running the
job. Double-click the file engine.log to displays its
contents in the Output view. Double-click an image file
(such as .spj) to display it in a graphics viewer.

*  Output: Displays the Output view.

* Return Value: Displays the return value in the output
window for this job. The return value consists of:

*  The string retVal.servername. jobi#, where
servername is the name of the server containing the S-
PLUS engine that ran the job, and job# is the job ID.

*  The script’s return value.

* Script: Opens a new instance of the Script Editor view
containing the contents of the script that was run for this
job.

Packages | Includes any packages installed or uploaded to Spotfire

Statistics Services. For example, if your organization uses
TIBCO Spotfire Clinical Graphics, when you expand the
Packages folder, you see the three protected packages
required to run this server: gom, graphlet, and tscg.

Any package you upload is displayed in this folder. If you
have completed and uploaded the Soundex example, you see
the unprotected package folder Soundex. (See the section
Spotfire Statistics Services Remote Submissions on page 178.)
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Statistics The Statistics Services view provides context-sensitive right-click
Services Right- menus for the services’ files and folders.
Click Menus .

Right-click a service name to:

* Remove the service. When you remove a service, it is
removed from the list, but it still appears in the Add
Service Connection Server URL drop-down list, in
case you want to reregister it later.

* Disconnect from the service. Disconnected services still
appear in the list of available services in the Statistics
Services view, but their folder structures are not visible,
and the green checkmark indicating their availability is
removed.

* Refresh the service file and folder list.
* Runajob.

*  Schedule a job.

*  Monitor service jobs.

* Examine the service properties.

4 |G My LocplSansas
. (&= Dati Rernove Service

= Jobt

> (= Pac

+ (g Sample]

Disconnect Service

Refresh

Run Job Alt+F9
Schedule Job

Menitor Jobs

Dme@f % X

Service Properties
Figure 2.9: Right-click service menu.
* Right-click a data folder in the service to perform any service-

level task, or to upload a data file.

* Right-click a data file to perform any service-level task, or to
download a file copy or delete the file. You can also preview
the data or display a summary of the data from this menu.

* Right-click a job folder to perform any service-level task, or to
interrupt a waiting job or delete a job that you no longer need.

* Right-click the Results folder to upload a file.

80



Statistics
Services view
Toolbar

Spotfire S+ Perspective Views

* Right-click a file contained in a Results folder to download or
delete the file.

* Right-click or double-click Return Value to retrieve the
return value for the specified job.

* Right-click the Packages folder in the service to perform any
service-level task, or to upload a package.

* Right-click a package folder to perform any service-level task, or
to upload, download, or delete an unprotected package. You
can also examine a package’s properties from this menu.

The Statistics Services view also displays a toolbar containing the
following buttons:

Table 2.3: Statistics Services view buttons.

Button Description

Click to display the Add Service Connection dialog. Use
this dialog to register a service. You can provide the display
name for the service, the server URL (for example: http://
myserver:8080/SplusServer), and your login credentials.

The Server URL must be unique; if you try to register a
service that is already registered, the service registrar displays
an error message.

Service connections are listed in alphabetical order,
according to the friendly Service Name you provide.

Click to collapse the entire server display tree, for all
connected servers.

Click to reconnect to the server selected in the Statistics
Services view.

Click to disconnect from the server selected in the Statistics
1§ Services view.
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Table 2.3: Statistics Services view buttons. (Continued)

Button Description

Click to display the Monitor Server Jobs view to see the
status of jobs queued on the server. Seeing the current server
workload is useful if your job is listed as Waiting.

This view also detects the service state. If the service fails, this
view closes automatically and terminates the service
connection.

This view displays properties of jobs waiting on the selected
server. Only properties of jobs that are waiting in the server
are displayed. As soon as they finish running, they are
removed from the display. (The results of finished jobs
appear in the server Jobs folder.)

Click to refresh the view of files and folders for the selected
server.

By

Click to run on the server the script that is open in the Script
- Editor.

Click to display the Schedule dialog. Use this dialog to

(0 specify a time and date for the script open in the Script Editor
h to run on the selected server. when you click OK, the job is
assigned a job ID, and it and the time and date the job is
scheduled to run is displayed in the server tree.

Statistics This section describes the dialogs providing access to an available
Services Spotfire Statistics Services server. For an example of using Spotfire
Statistics Services, see the section Spotfire Statistics Services Remote
Submissions on page 178.

Dialogs
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Add Service Connection

S* Add Service Connection o | B |
Service Name  Test Server
Server URL: http:/testingserver5:8080/5plusserver -
User Name:  janedoe
Password: sessssrsansl
Cancel

Figure 2.10:

Use this dialog to connect to Spotfire Statistics Services.
Service Name

The friendly name. This name is displayed in the Statistics Services
view.

Server URL

The URL for the server must contain the server name, the port
number and SplusServer. For example:

http://myserver:8080/SplusServer

On Microsoft Windows Vista® and Windows 7 operating systems,
the letter case for the server name must match the case of the server
name that is specified on the server, in its properties file. See your
server administrator for more information.

User Name and Password

If required, provide your credentials that the server can validate.
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Schedule Job

5% Schedule on Local Server X

Server Info

Server Time Zone  Pacific Standard Time
Current time 9/22/10 4:53 PM

Server is ahead by 0 hours 0 minutes

4 September, 2010 L4
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29 3 31 1 2 3 4
5 6 7 8 9 10 1.1
12 13 14 15 16 17 18
19 20 21 2 M4 25
% 271 28 28 W 1 2
3 4 5 6 7 8 9

8:59 PM -

( 9K | [ cancel

Figure 2.11: Schedule Job dialog.

Use this dialog to specify a future date and time to run S-PLUS code
on a server running Spotfire Statistics Services.

Server Time Zone

Indicates the time zone that the server is set to.

Current time

Lists the current time on the server.

Server is ahead/behind by

Indicates the number of hours and minutes the server time is offset by
the computer running the Spotfire S+ Workbench.

Calendar

Highlights the current day on your computer and the server day, if
different.
Time

By default, displays the current time on the server. Set the time for the
job to run. If you specify a time in the past, the job runs immediately,
on the first available S-PLUS engine.
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Monitor Server The Monitor Server Jobs view is not shown by default. You can

Jobs view display it by c.hckmg its button on the Stat1st1cs Se'rv1ces view
toolbar, or by right-clicking a running service and selecting Monitor
Jobs. The Monitor Server Jobs view displays the details of jobs in
the queue on TIBCO Spotfire Statistics Services, including:

. Job ID
* Date and time the job was submitted.
* The job’s status.
* The name of the user who submitted the job.
The name of the service where the job is running populates the tab
title.
0 Outlin | 5] Histor | 44 Statist £3 =g : :;:n;hz;;;;gy::d, FpES T Mo HEN T
+E5HO00E| =
4 [ Local Server 14
o lDcta El Console gobjacts ﬂSEarch Path ':_: Output ¥ Tasks | [£ Problems ,'5;1 Local Server i1
4|[= Jobs
(= 221 (Waiting) JobID Date Status Username
(= 220 (Waiting) m Mon Sep 13 15:07:40 PDT 2010 Running TSI-PA/kroan
(= 219 (Waiting) 220 Mon Sep 1315:07:40 PDT 2010 Running TSI-PA/kroan
(7 216 (Done) 19 Mon Sep131507:39PDT 2010 Running TSI-PAskroan
(7 215 (Done)
(7 214 (Done)
Figure 2.12: Monitor Server Jobs view.
Note

Completed jobs are removed from the Job Monitor. Look for their results in the server’s Jobs
folder. Scheduled jobs do not appear in the job monitor..
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Tasks view

The Tasks view is a standard Eclipse IDE view, which is customized

in Spotfire S+ to provide three levels of tasks:

Table 2.4: Spotfire S+ Workbench Tasks.

Task Description

FIXME Defines high-priority tasks. The
task appears with an
exclamation mark in the Tasks
view.

TODO Defines medium-priority tasks.

XXX Defines low-priority tasks.

You can change these tasks, or you can add your own custom tasks.
For more information about changing task settings, see section Task
Options on page 25, and the section To set the Spotfire S+

preferences on page 139.

(Console | Ohjsr.ts| Search Path | Output m__n-ohlem|

s = = ]
+

1 ikems

Location

Mark Completed
Delete Completed Tasks

Properties

Figure 2.13: Spotfire S+ Workbench Tasks view showing the right-click context-

sensitive menu.
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Tasks view toolbar

The Tasks view also contains a toolbar that displays the following
buttons:

Table 2.5: Tasks view buttons.

Button Description

Click to display the Add Task dialog to add a custom task.

Click to delete the selected custom task. (Note that you
cannot use this button to delete tasks identified in the script.)

Click to display the Filters dialog to specify properties for
filtering the tasks.

e

Tasks view control and right-click menus

You can use the Tasks view control menu (click ¥) to perform the
following tasks:

* Display the Sorting dialog to sort the tasks displayed in the
view, either in ascending or descending order, and according
to the tasks’ characteristics.

* Display the Filters dialog to specify properties for filtering
tasks.

You can use the standard Eclipse Tasks view right click context-
sensitive menu to:

* Add a task to the list that is not linked to a file (Displays the
Eclipse Add Task dialog).

* Open a file and display the location of a linked task in the
Script Editor.

+ Display the location of a linked task in the Navigator (opens
an instance of the Navigator).

*  Copy the Tasks view table to the clipboard.
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* Select all entries in the table.

*  Delete all tasks marked as completed (that is, containing a
check mark in the first column).

* View the properties of the task.

For more information about the basic Eclipse Tasks view, see the
Eclipse Workbench User Guide.
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Chapter 3 TIBCO Spotfire S+ Workbench Debug Perspective

INTRODUCTION

The TIBCO Spotfire S+ Workbench includes the Debug perspective,
which is based on the Eclipse standard debugging perspective.

From the Debug perspective, you can observe the run-time behavior
of your program and determine the location of semantic errors. The
Spotfire S+ debugger understands features that are built into the
Spotfire S+ programming language and its associated libraries. With
the Spotfire S+ debugger, you can break (suspend) execution of your
program to examine your code and evaluate variables.

After you have written your code and resolved any syntax errors, you
can use the Spotfire S+ debugger to correct any logic errors that keep
your code from running correctly. Using the Spotfire S+ debugger,
you can:

*  Control your code testing by setting break points, stepping
into, though, and out of code, and pausing or terminating the
process at any point using the Spotfire S+ debugger features.

* Set, disable, enable, or remove breakpoints while you are

debugging.

* View variable and expression values at breakpoints while
stepping through your code.

e Track resource allocation and function use.

Note

Because a significant amount of computation is required when you run a debugger, you should
expect to see Spotfire S+ running at a slower speed than usual when you toggle the Workbench
to Debug mode. Try this simple test for a demonstration:

1. With Debug mode off, examine the results of running:

sys.time(Im(fuel.frame))
sys.time(validate()).

2. 'Toggle on Debug mode and rerun the commands.

3. Examine the difference.
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Figure 3.1 shows the Debug
describes the options, features,

Introduction

perspective’s views. This chapter
and views included in the Debug

perspective.
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Figure 3.1: The Debug perspective.

The Debug perspective also includes a profiler, which you can use to
inspect allocated memory and functions called, including call count
and duration. For more information about the Spotfire S+ Profiler,
see the section Profiler on page 120.

* For tasks that walk you through using the Spotfire S+
debugger and profiler, see the section Chapter 4, TIBCO
Spotfire S+ Workbench Tasks.

+ For information about the Spotfire S+ perspective, see
Chapter 2, The TIBCO Spotfire S+ Perspective.

Note

You can create your own perspective that displays a combination of views from the perspectives,
or you can change the Debug perspective to suit your development style by adding, moving,
hiding, or closing views. For more information about customizing the views within the
perspective, see the section Changing the Spotfire S+ Workbench Perspective on page 42, or see

the section Customized Perspective Views on page 148.
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DEBUG PERSPECTIVE OPTIONS AND PREFERENCES

When you examine the Debug perspective, examine the Spotfire S+

Workbench toolbars, menus, default options, and preferences in the
IDE.

Note that the Spotfire S+ Workbench toolbar includes the Spotfire S+

debugger buttons (as well as the Profiler button). These buttons are
described in greater detail in Table 1.5.

El):bug- kahan5um.q - 5-PLUS Workbench E]EIE|
Fle Edk SPLUS Nenigate Search Project Run Window Help
(w56 ] k‘r hh  BT-0-Q- ¥ - I | 4% Debug | &% S-PLUS
FF Debug 52 Navigator = O | /(0= Varisbles 52 . Breakpoinks | Expressions | Function Calls | Alocations.  — 1
b= i =
= Mg debug [5-PLUIS] Name Value
= &8 s-pLUs Call N [t
=1 i kaharialues <- kahanfddiext(x{i], kahan¥aiues) @i [
= hahanSum => 3: kahanSum{S) from 1 % kahaalues Faum:in[1] Olngeorrection;in{1]10
# x [is
@ kahanSum.q 22 ) kahanaddiext_func.g = 0} 5= outline 22 iim|
## PELLULE COE AAOGED 5 W0 L. 2 e
M < lengthix) LS SR S
=] ror{i in 1:iN) = @ kshansum{x)
& ahanValues <— kahankddMext (x[1], kahanValues) A kaharvslues
2 ¥ & N
3 return (kahanValues[["sun™]])
)
v
< >
B Eorsala 7 Tasks | Output s A |
S-PLLIS Commeand Line
return(kahanValues) ~
}
» kahanSum (S )
[1] §
» kahanSum(5)
bl
o  kahanSum Ready

Figure 3.2: The Spotfire S+ Workbench toolbar.

Note

the console.

When you are in the Debug perspective, notice that the Eclipse environment displays a generic
toolbar that includes a Run button, a Debug button, and an External Tools button. These
buttons might work with other Eclipse plug-ins, but they are not intended to be used with
Spotfire S+. You can set breakpoints from the Debug view toolbar, or from several menus, and
you can run code using the Run Spotfire S+ Code button on the Spotfire S+ toolbar or from
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Setting From the menu, click Window P Preferences to open the

Preferences Preferences dialog and examine the options. (For more information
about setting preferences, see the section Examining Spotfire S+
Preferences on page 14. For more information about Eclipse
preferences, see the Eclipse Workbench User’s Guide, available from the
Help » Help Contents menu in the IDE.)

Most options in the Spotfire S+ pages of the Preferences dialog
apply to global settings in the Spotfire S+ Workbench. For example,
options controlling editor or Console text colors apply to both
perspectives. Only the Profiler page under Spotfire S+ controls
Spotfire S+ debugger behavior, and that controls only the refresh rate
for system allocations and function calls. See section Examining
Spotfire S+ Preferences on page 14 for more information.

Debug Mode To start debugging, first activate the debugger using one of the
following methods:

*  On the toolbar, click Toggle Spotfire S+ Debugger .

* On the menu, click the Run » Toggle Spotfire S+
Debugger.

*  On the keyboard, press CTRL+ALT+D.

After you activate the Spotfire S+ debugger, any expression you type
in the Console, or that you run by clicking Run Spotfire S+ Code

( » ) on the toolbar, invokes the Spotfire S+ debugger.

Note

You can set Eclipse an option to be notified that a debug session is about to begin (that is, if you
click Debug (%) and try to run a function in the Console that encounters any breakpoints).

1. From the main menu, click Windows » Preferences.
2. Expand Run/Debug and select Perspectives.

3. In the Perspectives dialog, in the Open the associated perspective when
launching group, select Prompt. Click OK.

Using this Eclipse option, you are prompted to change to the Debug perspective with the
message box shown in Figure 3.3. Clicking Yes displays the Debug perspective with the Debug
view open and the debugging started.
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Debug Run
Menu Options

94

E Confirm Perspective Switch @

\?J) This kind of launch is associated with the Debug perspective,

-

This Debug perspective is designed to support application debugging. It
incorporates views for displaying the debug stack, variables and breakpoint
managernent.

Do you want to open this perspective now?

[Iremember my decision

| Yes %7] [ Mo

Figure 3.3: The Confirm Perspective Switch message box.

When you switch to the Debug perspective, the Spotfire S+
Workbench Run menu changes to list all of the code control actions
specific to that perspective. Note that many of the options listed in
this menu are default Eclipse debugging options. For more
information about those options, see the Eclipse Workbench User
Guide. The Spotfire S+ Debugger actions are available in the Debug
perspective views.

Table 3.1: Debug perspective Run menu.

Menu item Description

Run Spotfire S+ Code Runs the code in the currently-active file,
or runs the selected code.

Run Next Spotfire S+ Runs the next available Spotfire S+
Command command.

Toggle Spotfire S+ When toggled on, engages the Spotfire S+
Debugger debugger. (You can engage the Debugger

in either the Spotfire S+ or the Debug
perspectives; however, by default, the
views displaying debugging information
are visible in the Debug perspective.)
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Table 3.1: Debug perspective Run menu. (Continued)

Menu item

Description

Toggle Spotfire S+
Profiler

When toggled on, engages the Spotfire S+
Profiler. (You can engage the Spotfire S+
Profiler in either the Spotfire S+ or the
Debug perspectives; however, by default,
the views displaying profiling information
are visible in the Debug perspective.)

You do not need to engage the debugger
in order to engage the Profiler. See the
section Profiler on page 120 for more
information.

Resume Resumes debugging when the debugger is
paused.

Suspend Suspends debugging.

Terminate Terminates debugging.

Step Into Steps into the current function by one
level

Step Over Stays at the same expression level but

steps to the next expression.

Step Return

Steps out of the current function by
one level.

Run to Line

Core Eclipse debugger option; not
implemented in Spotfire S+.

Use Step Filters

Core Eclipse debugger option; not
implemented in Spotfire S+.

Run Last Launched

Core Eclipse debugger option; not
implemented in Spotfire S+.
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Table 3.1: Debug perspective Run menu. (Continued)

Menu item

Description

Debug Last Launched

Core Eclipse debugger option; not
implemented in Spotfire S+.

Run Last Launched

Core Eclipse debugger option; not
implemented in Spotfire S+.

Debug Last Launched

Core Eclipse debugger option; not
implemented in Spotfire S+.

Run History

Core Eclipse debugger option; not
implemented in Spotfire S+.

Run As

Core Eclipse debugger option; not
implemented in Spotfire S+.

Run

Core Eclipse debugger option; not
implemented in Spotfire S+. (Use the Run
Spotfire S+ Code option at the top of the
main menu, F9, the Debug view context-
sensitive menu, or on the Debugger
toolbar.)

Debug History

In its submenu, lists the previously-
launched debugging actions. From this
list, you can select a previous

Debug As

Core Eclipse debugger option; not
implemented in Spotfire S+.

Debug

Core Eclipse debugger option; not
implemented in Spotfire S+.

External Tools

Core Eclipse debugger option; not
implemented in Spotfire S+.
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Table 3.1: Debug perspective Run menu. (Continued)

Menu item

Description

Toggle Spotfire S+
Warning Breakpoint

Requires that the Spotfire S+ debugger be
toggled on. When toggled on, stops
execution if Spotfire S+ encounters a
warning. See Table 3.7 in the section
Breakpoints view on page 113 for more
information about warning breakpoints.

Toggle Spotfire S+ Error
Breakpoint

Requires that the Spotfire S+ debugger be
toggled on. When toggled on, stops
execution if Spotfire S+ encounters an
error. See Table 3.7 in the section
Breakpoints view on page 113 for more
information about error breakpoints.

Toggle Line Breakpoint

When toggled on, removes the breakpoint
on the selected line.

Toggle Method
Breakpoint

Core Eclipse debugger option; not
implemented in Spotfire S+.

Toggle Watchpoint

Not implemented in the debugger.

Skip All Breakpoints

When selected, disregards but maintain
(that is, does not remove or disable) all
breakpoints. When this button is toggled
on, all breakpoints appear with a diagonal
slash, as shown in the button.

Remove All Breakpoints

Removes every breakpoint from files in
open projects. (This item does not remove
breakpoints from files in closed projects.)
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DEBUG PERSPECTIVE VIEWS

98

The Debug perspective includes views specific to using the debugger
and the profiler, as well as views shared across perspectives. For a list
of all views and their default perspectives, see Table 1.7 in Chapter 1.
(Chapter 1 also includes descriptions of the shared views.)

The Debug perspective includes the default Eclipse Navigator view
and customized views. Customized views in the Debug perspective
include the following:

Table 3.2: Debug perspective views and exercise references.

View Descriptions and Practice exercises
Allocations A Spotfire S+ Profiler view. For a description, see the
view section Allocations view on page 122. For practice using

this view, see the exercise in the section Examining
Resource Usage on page 199. (The Profiler views are
discussed in more detail in the section Profiler Mode on

page 121.)
Breakpoints For a description, see the section Breakpoints view on
view page 113. For practice using this view, see the exercise

in the section Setting breakpoints on page 190.

Console Shared view. For a description, see the section Spotfire
S+ Workbench Console on page 49. For practice using
this view, see the exercise in the section To run copied
script code on page 165.

Debug view For a description, see the section Debug view on page
100. For practice using this view, see the exercise in the
section Examining the call stack on page 193.

Expressions For a description, see the section Expressions view on

view page 111. For practice using this view, see the exercise
in the section Examining Variables and Expressions on
page 194
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Table 3.2: Debug perspective views and exercise references. (Continued)

View Descriptions and Practice exercises
Function A Spotfire S+ Profiler view. For a description, see the
Calls view section Function Calls view on page 121. For practice

using this view, see the exercise in the section
Examining Function Calls on page 199. (The Profiler
views are discussed in more detail in the section Profiler
Mode on page 121.)

Outline view | Shared view. For a description, see the section Outline
view on page 54. For practice using this view, see the

exercise in the section To examine the outline on page
160.

Output Shared view. For a description, see the section Output
on page 56. For practice using this view, see the exercise
in the section To run code on page 166.

Variables For a description, see the section Variables view on page

view 106. For practice using this view, see the exercise in the
section Examining Variables and Expressions on page
194.

Tasks view Shared view. For a description, see the section Tasks

view on page 86. For practice using this view, see the
exercise in the section Adding a Task to A Script on
page 161.

Additionally, the Debug perspective displays the Script Editor, which
is shared with the Spotfire S+ perspective. See the section Editor on
page 103 for more information about using the Script Editor with the
Spotfire S+ Debugger. See the section Spotfire S+ Workbench Script
Editor on page 57 for more general information about editing code in
the Script Editor.

From the Debug perspective, you can observe the run-time behavior
of your program and determine the location of semantic errors. The
Workbench debugger understands features that are built into the
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Debug view

100

Spotfire S+ programming language and its associated libraries. With
the debugger, you can break (suspend) execution of your program to
examine your code and evaluate and edit variables.

The Debug view displays the call stack of a currently-paused
expression. Clicking any level of the call stack displays in the Editor
the current function and/or the highlighted expression.

Figure 3.4 displays the Debug view, in its default position, displaying
the call stack for the kahanSum example.

ﬁDebug X3 Navigat0r| =8
U | = |z =] @ ¥

[El-% debug [3-PLUS]
=88 5-PLUS Cal
Edf‘? kahanvalues <- kahanaddMe:xt{x[i], kahanvalues)
L= kahansum = 3 kahanSumirep;1000000000.1,.... from 1

Figure 3.4: The Debug view.
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Debug view toolbar

The Debug view contains a toolbar with the following buttons for
evaluation control, in the order of their appearance, left to right:

Table 3.3: Debug view toolbar buttons.

Button Description

Remove All Terminated Launches. Clears
the call stack of all debugging sessions that
ended with a termination.

Resume. Continues to the next breakpoint.

O

Suspend. Pauses the execution as though a
breakpoint had been hit.

Ul

Terminate. Stops the execution. Similar to
ESC functionality.

Disconnect. For remote debugging. Not
implemented for Spotfire S+.

Step Into. Steps into the current function by
2 one level.
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Table 3.3: Debug view toolbar buttons. (Continued)

Button Description

Step Over. Stays at the same expression
level but steps to the next expression.

Ql

Step Return. Step out of the current function

T level.

Use Step Filters/Step Debug. This feature is
not supported in the Spotfire S+ Workbench.

Note

The feature Drop to Frame is not implemented in the Spotfire S+ Workbench.

Debug view control and right-click menus

The Debug view contains a control drop-down (¥ ) menu with one
command: View Management, which displays the View
Management page of the Eclipse Preferences dialog, in which you
can set options to open and close views automatically. This dialog is
also available from the Windows P Preferences menu. For more
information about using this menu item, see the Eclipse Workbench
User’s Guide.

You can use the Debug view right-click menu (Figure 3.5) to perform
the following tasks:

*  Copy the contents of the stack.

+ Step into the code.

+  Step over the code.

+  Step one level out of the current function.
*  Resume debugging.

*  Suspend debugging.
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* Terminate the debugging session.
* Terminate and restart the current debugging session.

* Remove from the view all previously terminated debugging
sessions.

* Terminate and remove the currently-active debugging session.
* Restart the current debugging session.
*  Terminate all debugging.

These menu items are available on the toolbar, or from the main Run
menu. For more information, see the section Debug view toolbar on
page 101 or the section Debug Run Menu Options on page 94.
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Figure 3.5: The Debug view right-click context-sensitive menu.

Editor The Debugger perspective uses the existing Spotfire S+ Workbench
editor. You can set and remove breakpoints in the Script Editor by:

* Double-clicking the margin on the left side of the screen (to
the left of the line numbers).
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* By right clicking the margin, and from the menu, select
Toggle Breakpoint.

* By using the Run » Toggle Line Breakpoint menu option.
* By pressing CTRL+SHIFT+B.

When you are debugging, if your functions call any functions in files
other than those in your workspace (including functions in a library),
you can double-click the expression in the Debug view and open a
temporary file that contains the called function. You can set
breakpoints in these functions, too.
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Figure 1: A temporary file in the debugger.

You can view functions that are not defined in your workspace in one
of the following ways:

* Double-click the Debug view.

*  Press CTRL+click in the Spotfire S+ Script Editor.

*  On the menu, click Spotfire S+ » Find
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e Press CTRL+SHIFT+F

Note

*  Breakpoints that you set in functions in your workspace are associated with function and
with the file. These breakpoints persist until you remove them.

*  Breakpoints that you set in functions outside of your workspace are associated with the
functions, and not with the temporary files. They persist until you remove them.

*  Setting breakpoints in code files in the Spotfire S+ Workbench does not affect the file if
you open it in the Spotfire S+ GUI in Windows. Breakpoints are evaluated only in the
Spotfire S+ Workbench, and only when the debugger is engaged.

*  Breakpoints can be set only on a line contained within a function definition. Lines not
contained within a function cannot have a breakpoint set.

If you close a temporary file containing a breakpoint, and then rerun your function, the functions
called by your code reopen in another temporary file, and any breakpoints you set persist.

Examining
Expression Values
in Tooltips

Using the Hover feature, you can position the mouse over an
expression in the Script Editor, and then examine the expression’s
value, which appears in a tooltip. This feature is available for all
expressions in the Script Editor, not just those where a breakpoint
appears; however, examining the value of an expression at a
breakpoint can be very useful.

You can limit the size of the expression that the Hover feature
evaluates by using the following Spotfire S+ command:

options(workbenchMaxDims=c(rows, columns))

See the section Hover on page 21 for more information.

You can enable or disable the hover tooltip feature in the Editor
options dialog from the Windows P Preferences menu. This feature
is enabled by default.

Hower

Evaluate expression and display value if engine available

S-PLUS Format Opkions

Figure 3.6: Hover option in the Editor preferences dialog.
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For practice tasks on setting breakpoints, see the section Setting
breakpoints on page 190.
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Figure 3.7: Breakpoints view and Editor.
Variables view Displays all variables in the current frame. As you debug, at each

breakpoint or step, the debugger re-evaluates the variables. At any
breakpoint or stopping point, you can review, but not edit or alter, the
variables at the current frame.

Figure 3.8 shows the Variables view with the current variable
selected. The Details pane of this view contains variable information
that would result from calling print() on the selected variable or
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expression. The Details pane is editable; you can select, cut, or copy
the contents of this pane. Editing the Details pane does not affect the

value of a variable.

K7

m\Breakpoints|Expressions|Function Calls|AIIOcations| =k [ ¥ = O
ame | alue |
@ N [1]10
I T 51 |
@ kahanvalues $sum:in[1] 2000000000, 24ngcorrection:in[1] 0
* x [1] 1000000000,1 1000000000,1 1000000000, .,
[11 3 =

ol

Figure 3.8: The Variables view.

Variables view and Expressions view toolbars

The Variables view and Expressions view contain similar toolbars to
control the view display and feature options.

Table 3.4: Variables view and Expressions view toolbar buttons.

Button

Description

Show Type Names. Select to
display the variables’ types.

+h

Show Logical Structure. This
feature is currently not supported
in the Spotfire S+ Workbench.

Collapse All Collapses the logical
structure display (which is currently
not supported in the Spotfire S+
Workbench).

Remove Selected Expressions
(Expressions view only).

Remove All Expressions
(Expressions view only).
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Variables view control and right-click menus

The Variables view and Expressions view drop-down control
menus provide additional options to control the view’s display. The
respective menus are available from the down arrow button on the
Variables or Expressions view toolbar.

Breakpoints ExDressions|Function Calls|.°.||ocations| =% 0 ¥ T O

Mame - Vertical View Orientation d
@ N ® |: | Horizontal View Crientation Detail Pane. ..
& i = e -
= Wariables Wiew Only Wrap Text in Details Pane
@ hkahanValues = | Lp -
@ x v [ Show Colurns hoo.1
Select Columins...

| | o4 Llj

Figure 3.9: The Variables view control menu.

The Variables view and Expressions view control menus include
the following options:

Table 3.5: Variables view and Expressions view control menu options.

Menu item Description

Vertical View Orientation Tiles the Details pane of the view
vertically. That is, the Details pane
appears below the Variables or
Expressions pane.

Horizontal View Orientation Tiles the Details pane of the view
horizontally. That is, the Details
pane appears beside the Variables
or Expressions pane.
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Table 3.5: Variables view and Expressions view control menu options.

Menu item Description

Variables View Only Hides the Details pane of the

Expressions View Only Variables or Expressions view.

Detail Pane Displays the Configure Details
Area dialog, which controls the
maximum number of characters to
display in the Details pane. See
Figure 3.10.

Wrap Text in Details pane Wraps the text that appears in the
Details pane.

E Configure Details Area

Maximum characters to display in details area {0 = unlimited):

[OK Cancel

Figure 3.10: Configure Details Area dialog.

Note

Figure 3.10 shows the Configure Details Area dialog, with which you can set the number of
characters to display. This option just controls the number displayed; it does not limit the number
of characters returned. To limit the number of text variables and expressions to return, use the
Spotfire S+ command options(workbenchMaxDims=c(rows, columns)). This option is useful if
you are working with a large number of text variables or expressions.

Setting this option also limits the size of the expression that the hover feature evaluates. For
example, if you are evaluating a large data object, and you hover the mouse over the expression,
if you do not set this option, Spotfire S+ tries to evaluate the expression on the spot.

The Variables view contains two right-click context-sensitive menus:

« The Variables view (Figure 3.9).
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The Details pane (Figure 3.12).

You can use the Variables view right-click context-sensitive menu to
perform the following tasks:

Mreakﬁluints | Expressions ‘ Function Calls | Allocations | £ [ Y T O
Mame | Yalue |
& N [1]10
# kahanvalues $sum:in[1] 2000000000, 2
@ x [1] 1000000000, 1 10000¢ =] Copy dariables Chrl+C
Find... Chrl+F

[1] = §§V Create Watch Expression

Select all variables in the pane.
Copy the selected variable.
Find a specified variable.

Set an expression watch for the selected variable. (When you
select this option, the selected variable is added to the
Expressions view.)

.A Change Yalue, ..

o

Figure 3.11: Variables view showing the right-click menu.

You can use the right-click context-sensitive menu in the Variables
view Details pane to perform the following tasks:
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Cut the currently-selected text.
Copy the currently-selected text.

Paste the contents of the clipboard to the cursor location in
the pane.

Select all text in the pane.
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* Find a specified string in the pane. (The Spotfire S+
Workbench does not support replacing strings in the Details
pane using the Find/Replace dialog.)

M\Breakpoints | Expressions | Function Calls | Allocations| S = El\
Iame | value ;I
@ M [1]10 2000000000, 2
@i [1]13 $correction
w# kahan¥alues $sum:in[1] 2000000000, 24ndcarn [1] O %
¥ x 1110000000 assign Yalue Chrl+5
h Content Assist Chtl+Space
Cuk Chrl4+
Copy Chrl+C
Paste Chrl4+y
A Select Al Chrl4+-4 _’ILI
Find/Replace...  Ctrl+F =5

Figure 3.12: Variables view showing the right-click menu in the Details pane.

The Expressions view displays the values of any Spotfire S+
expression. Like the Variables view, it is re-evaluated at each
evaluation pause (breakpoint or step).

Note on Expressions

An expression is any syntactical interaction that Spotfire S+ can
evaluate. Expressions persist from session to session. Spotfire S+
recognizes a wide variety of expressions, but in interactive use, the
most common are names, which return the current definition of the
named data object, and function calls, which carry out a specified
computation. Any of the following are Spotfire S+ expressions:

1:10
rnorm(5)
mean(1:10)
traceback()

If you were debugging a function, for example:

incrementByTwo <- function(x) {
* X+ 2

}
you could have an expression that evaluated:

X + 2
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at the breakpoint (denoted with the * in the above function
definition).

Note

If you leave in the Expressions view expressions that are no longer in scope for your current
debugging session, you might notice that the debugger slows significantly to evaluate the
expression that is no longer in scope. To keep the debugger from slowing down, remove
expressions that are no longer in scope for your current debugging session.

For more information about expressions, see the Programmer’s Guide,
or see the Spotfire S+ Help topic ExpressionLanguage.

The Expressions view toolbar buttons are the same as those of the
Variables view, with the addition of the Remove and Remove All
buttons. See Table 3.4 for more information.

The Expressions view contains two right-click context-sensitive
menus:

+ The Expressions view (Figure 3.13)
* The Details pane (Figure 3.12).

You can use the Expressions view right-click context-sensitive menu
to perform the following tasks:

*  Select all expressions in the pane.

+  Copy the selected expression.

* Remove the selected expression.

* Remove all expressions in the view.

* Add an expression to watch (opens the Add Watch
Expression dialog, in which you can provide an expression
and indicate whether to enable or disable it).

* Re-evaluate the expressions.
* Disable the currently-selected expression.

* Enable the currently-selected expression (if it was previously

disabled).

112



Breakpoints view

Variables
Y

Debug Perspective Views

Edit the currently-selected expression. (Opens the Edit
Watch Expression dialog, in which you can change
expression and indicate whether to enable or disable it.)

' Xpressions Function Calls|AIIOcations| Y 2k 2 | ® 5 = =0
"+" (pending) ~

Select Al Chrl4+-4
=| Copy Expressions Chrl+C
¥ Remove
“5¢ Remove All
Find... Chrl+F
.A Change Value, ..

W

§§y Add Watch Expression,..

Reevaluate Watch Expression LI _’ILI
Disable

Enable = B[ 5= outline 52 =0
Edit Watch Expression... ;I w R W " | laz -

Figure 3.13: Expressions view showing the right-click menu.

The right-click context-sensitive menu for the Details pane in the
Expressions view is the same as that of the Variables view Details
pane. See Figure 3.12 and the section Variables view control and
right-click menus on page 108 for more information.

Find a specified string in the pane. (The Spotfire S+ Workbench does
not support replacing strings in the Details pane using the Find/

Replace dialog.)
.
M\Breakpoints | Expressions | Function Calls | Allocations| £ [0 ¥ = 0
Mame | value §sum: ;I
@ M [1]10 [1] zZ0O0O000000.:2
@i [1]13 Scorrection:
@ kahanvalues $sum:in[1] 2000000000, 24ndcarn [1] O %
@ x [1710000000  pssion Yalue ChrlS
h Content Assist Chtl+Space
Cuk Chrl4+
Copy Chrl+C
Paste Chrl4+y
Select &l Chrl+a _lll
1| »
Finltl:l,:’_I‘RepIace... Chrl+F =_

Figure 3.14: Variables view showing the right-click menu in the Details pane.

The Breakpoints view displays the currently set breakpoints, which
you can organize by resources, files, working sets, or just a simple list
or type. Each breakpoint displayed in the Breakpoints view shows
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the function name (e.g., kahanAddNext), the file name (e.g.,
kahanAddNext_func.q), and the line number (e.g., [1ine 7]) where
the breakpoint occurs.

In addition to setting general user interface options, you can use the
Breakpoints view to manage breakpoint working sets and group
breakpoints. See the Eclipse Workbench User’s Guide for more
information.

Selecting a breakpoint displays in the Editor the associated file,
highlighting the breakpoint line. You can activate, disable, or delete
breakpoints from this view.

Figure 3.15 displays the Breakpoints view with the file structure
shown, and all breakpoints activated.

Function Calls | Allocations | =0

RR#A | HEERT

Figure 3.15: Breakpoints view.
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Breakpoints are the best tools to stop an evaluation and inspect the
engine's state. The Spotfire S+ Workbench supports three types of

breakpoints.

Table 3.6: Tjpes of breakpoints.

Breakpoint type

Description

Line breakpoints

Use line breakpoints to stop an evaluation at the
specified line number. To set line breakpoints,
from any perspective:

Double-click the left margin of the Spotfire S+
Editor.

Right-click the left margin of the Spotfire S+
Editor.

From the Debug perspective, Click the Run P>
Toggle Line Breakpoint menu item.

After you set a line breakpoint, you can enable or
disable it in the Breakpoints view, or by right-

clicking the breakpoint marker ( @ ) in the left
margin of the Editor.

(For more information about using the
Breakpoints view, see the section Breakpoints
view on page 113.)
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Table 3.6: Tjpes of breakpoints. (Continued)

Breakpoint type

Description

Warning breakpoints

Warning breakpoints are triggered only if the
Spotfire S+ Debugger is toggled on.

Use warning breakpoints to stop an evaluation
when a warning is generated. You can activate
warning breakpoints from any perspective by
clicking Toggle Spotfire S+ Warning
Breakpoint ( . ) on the Spotfire S+ toolbar, or
by clicking the Run P Toggle Spotfire S+
Warning Breakpoint menu item.

*  Warning breakpoints do not appear in
the Breakpoints view.

*  Warning breakpoints are not affected by
the option Skip All Breakpoints ().

Error breakpoints

Error breakpoints are triggered only if the
Spotfire S+ Debugger is toggled on.

Use error breakpoints to stop an evaluation when
an error is generated. You can activate error
breakpoints from any perspective by clicking
Toggle Spotfire S+ Error Breakpoint ( @) on
the Spotfire S+ toolbar, or by clicking the Run P>
Toggle Spotfire S+ Error Breakpoint menu
item.

*  Error breakpoints do not appear in the
Breakpoints view.

*  Error breakpoints are not affected by the
option Skip All Breakpoints (x ).
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Breakpoints view toolbar

The Breakpoints view contains a toolbar to control the view’s
display and feature options.

Button Description

Remove Selected Breakpoints. From the Breakpoints
% view, click to remove the selected breakpoint from both the
Debug view and the Breakpoints view.

Remove All Breakpoints. From the Breakpoints
% view, click to remove every breakpoint from both the
Debug view and the Breakpoints view.

Show Breakpoints Supported by Selected Target.

e When toggled off, all breakpoints are displayed. When
toggled on, the Breakpoints view displays only breakpoints
applicable to the selected debug target. For example, if you
had installed a Java package for Eclipse (not included in the
Spotfire S+ Workbench), and you were running a Java
debug session and a Spotfire S+ debug session
simultaneously, you could filter using this feature.

Go to File for Breakpoint. Click to jump to the file and
= line number containing the breakpoint currently selected in
the Breakpoints view.

Skip All Breakpoints. Click to disregard but maintain

" (that is, not remove or disable) all breakpoints. When this
button is toggled on, all breakpoints appear with a diagonal
slash, as shown in the button.
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Button Description

Expand All If the Breakpoints view is set to display

Es breakpoints in groups such as files, working sets, projects,
resources, or breakpoint types, clicking this button expands
the tree to display the breakpoints in all groups. (See Table
3.7 for more information about the group display options.)

Collapse All If the Breakpoints view is set to display
breakpoints in groups such as files, working sets, projects,
resources, or breakpoint types, clicking this button collapses
the tree to display only the top-level groups. (See Table 3.7
for more information about the group display options.)

Link With Debug View. As breakpoints are encountered,

& they are selected in the Breakpoints view.

Breakpoints view control and right-click menus

The Breakpoints view contains a control menu to control the types
and levels of resources displayed, and options for managing working
sets. See the Eclipse Workbench User’s Guide for more information
about managing working sets.

=g
RE - w|EEEY

- @ kahansum : kahansum.q [line &5 2 Breakpoink Type: oo Select Defaulk Working Set...
o3 Breakpoint Working Sets Deselect Default Warking Set
4 Files Working Sets. ..
=5 Projects
=6 Resource Working Sets
- 7 Advanced...

Figure 3.16: The Breakpoints view menu.
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The Breakpoints control menu includes the following options:

Table 3.7: Breakpoints view menu.

Menu Item Description

Group By Displays a submenu providing the following options:

*  Breakpoints. Displays only the breakpoints
in a flat list.

* Breakpoint Types. Displays breakpoints
grouped by type (Java, Spotfire S+, and so

on).

*  Breakpoint Working Sets. Displays
breakpoints grouped by identified working
sets. See (working sets section) for more
information.

»  Files. Displays breakpoints grouped by the
files containing them.

*  Projects. Displays breakpoints grouped by
the projects containing them.

* Resource Working Sets. Displays
breakpoints by the resources to which they
belong.

* Advanced. Displays the Group
Breakpoints dialog. See the Eclipse
Workbench User’s Guide for more information
about using working sets and groups.

Select Default Displays a dialog to create, select, or remove the
Working Set breakpoint working set that is your project’s default.
See the Eclipse Workbench User’s Guide for more
information about using working sets.

Deselect Default | Clears the working set that you specified in the
Working Set Select Default Working Set dialog.

Working Sets Displays the Select Working Set dialog.

You can use the Breakpoints right-click context-sensitive menu (see
Figure 3.17) for the following tasks:
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Working with
Working Sets

Console, Output,
and Outline
views

Profiler

120

*  Open the file and location for the selected breakpoint.
* Enable the selected disabled breakpoint.

* Disable selected breakpoint.

* Remove the selected breakpoint.

* Remove all breakpoints in the view.

*  Select all breakpoints in the view.

*  Copy the breakpoints to the clipboard.

R =8 5= Ereakpnints Expressions|Function Calls|AIIOcations| =0
RKEBR AN | mEET
T © ermer——n oz 1)
@
M Enatle
Disable
¥ Remove
“5¢ Remove All
Select Al Chrl4+-4
=| Copy Chrl+C
I Faste CErl
‘e’@ Export Breakpoints, .. -0 EE Outine. &3 - b
@G" Import Breakpoints, .. ;I B R R B | laz ¥
L T T S TV A W PR

Figure 3.17: The Breakpoints view displaying the right-click menu.

The Spotfire S+ Workbench provides tools to group and manage
project files and resources using working sets. Working set menus are
available in several Eclipse views, including the Breakpoints view.
For general information about using working sets, see the Eclipse

Workbench User’s Guide.

The Debugger perspective shares the Spotfire S+ Workbench
Console, Output, and Outline view. For more information about
using these views, see:

The section Spotfire S+ Workbench Console on page 49
The section Spotfire S+ Perspective Views on page 68.

The Workbench Profiler is composed of two views: the Function
Calls view and the Allocations view, which are available in the
Debug perspective. You can run the Profiler from either the Run



Profiler Mode

Profiler views

Function Calls
view
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menu or from the Toggle Spotfire S+ Profiler button (% ), located
next to the Toggle Spotfire S+ Debugger button on the Spotfire S+
Workbench toolbar. (See Figure 3.2.)

To start profiling, first activate the Spotfire S+ profiler by clicking
Toggle Spotfire S+ Profiler toolbar item, by typing CTRL+ALT+P,
or by clicking Run » Toggle Spotfire S+ Profiler on the menu.
Once the Profiler is activated, any expression you type in the
Console, or that you enter by clicking Run Spotfire S+ Code,
invokes the Profiler adds to the Function Call and Allocation views.

The Spotfire S+ Workbench Profiler includes two views to monitor
the system performance:

¢ Function Calls view
« Allocations view
These views are described in this section.

By default, the Function Calls view displays a function call tree that
reflects the engine's activity.

‘tariables | Expressions | Breakpoints SNl 5 1 Allocations

—|- parse (1 ms)
+- 1 (=1 ms)
= on.exit {<1 ms)

nargs (<1 ms)
sys,parent (<1 ms)

—|- eval (21442 ms)

R fib

+|- show {11766 ms)
+- parse (<1 ms)
+-eval (<1 ms)

Figure 3.18: Function Calls view, tree display.

Alternatively, you can display the information in a tabular view by
either of the following methods:

* Right-click the view, and from the menu, toggle Show
Function Tree
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Allocations view
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* From the Function Call menu, toggle Show Function Tree.

‘Wariables | Expressions | Ereakpoints S gyl sy 4

Allocations ¥ =0

Function |Call Count Duration (ms) | -~
- 13 17
135 3199
: 69 62
! 747 =11
I= 237 331
.C 13 93
[ 150 1247
[.4=I= 3 47
[ .data. frame 3 125
[ .default 3 0
[r 48 403
* 3 121
& 1z 78
ol 348 4904 v

Figure 3.19: Function Calls view, table display.

Function Calls menu

The Function Calls view menu displays the following options:

Table 3.8: Function Calls view menu options.

Menu option

Description

Show Function Tree

Toggle to show the function calls in a tree
view or in a tabular view. The tabular
format displays the total number of calls
and total duration of each function.

Refresh Function Calls

Forces an update of the function call tree or

table.

Reset Function Calls

Clears the function call tree or table.

Displays the number of allocations the engine has performed. It
breaks the allocations down into bytes and the basic Spotfire S+ data

types.

Allocations view menu

The Allocations view menu displays options to refresh or reset the
view, similar to the Function Calls view options. See Table 3.8 for

more information.
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Introduction

INTRODUCTION

This chapter provides the basic tasks that demonstrate using the
TIBCO Spotfire S+ Workbench. For information about basic Eclipse
IDE tasks, see the Eclipse Workbench User Guide.

This chapter includes:
General Spotfire S+ Workbench tasks, including:
*  Setting the Workspace, page 126
*  Quick Start, page 127
+ Setting the Spotfire S+ Workbench Preferences, page 137
*  Customized Perspective Views, page 148
*  Specifying Working Projects and Databases, page 151
*  Working with Spotfire S+ Project Files and Views, page 156

This chapter also includes tasks that introduce you to using the views
and features in the Spotfire S+ perspective. For more information, see
the section Spotfire S+ Workbench Projects on page 126.

Finally, this chapter includes tasks that introduce you to using the
views and features in the Debug perspective. For more information,
see the section Spotfire S+ Workbench Debugger Tasks on page 188.
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SPOTFIRE S+ WORKBENCH PROJECTS

Before you begin working with files in the Spotfire S+ Workbench,
you must set your workspace and then create a project.

Setting the When you first launch the Spotfire S+ Workbench, you are prompted
Workspace to supply the path to your Spotfire S+ workspace.

To set the workspace

1. In the Workspace Launcher dialog (Figure 4.1), specify the
directory location where the workspace .Data and .metadata
databases will be stored.

2. Indicate whether you want to be prompted in future sessions
to identify a workspace using this dialog.

Select a workspace

Spotfire 5+ Workbench stores your projects in a folder called a workspace
Choose a workspace folder to use for this session.

L\ SRS C:\ Users\ kroan\workspace

[] Use this as the default and do not ask again

Figure 4.1: The Workspace Launcher dialog.

Changing the You can switch to another workspace from within the Spotfire S+
Workspace Workbench user interface.

To open a different workspace in Spotfire S+ Workbench
1. Save your work, and then click File » Switch Workspace.

2. In the Workspace Launcher dialog, provide the new
workspace location.

Note

When you switch workspaces during a Spotfire S+ Workbench session, the current session
closes, and a new session of Spotfire S+ Workbench starts, using the new workspace location.
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3. After you set the workspace, open the workbench.

Note

On Microsoft Vista® and Microsoft Windows 7®, you must be elevated to the role of
administrator to specify the default directory as C:\Program
Files\tibco\splus82\users\yourname; however, it is not recommended that you use this
directory. By default, the workspace directory is C:\Users\yourname\workspace.

Workbench
First View

Quick Start

When you launch the workbench the first time, notice the user
interface. If you haven’t familiarized yourself with the workbench
GUI or its customization, see the section Examining the Spotfire S+
Workbench GUI on page 31.

S Spotfire 5+ - Welcome to Spotfire S+ Workbench - Spotfire S+ Workbench

Perspective

File Edit Spotfie5+ Mavigate Search Project Run Window Help

Bl B e QA - ©EN T

27 Mavigator 5 = O [E Welcome &2 =
=% 7 TIBCO Spotfire 5+ Workbench

This page helps e familiarizeyou with the TBCQ Spotfire S+ plug-in: for the Eclipse Werk
Emply Tolean more, read the sections below an i

Navigator Welcome
= Getting Help with the Spotfire 5+ Pace
g customizd Spotfir

To find more about gettng help with
s included in the Werkbench, on the Es Contents te displa;
Vo Help windou. In the Ieft pane table of cof Click Spatfire S+ Help.

To open the Spotfire 5= Workbench Uzer's Guide on the Help menu,
click Spotfire 5+ Manuals, and then click Spotfire 5+ Workbench Guide.

-

Note “ou must have a PDF reader installed te read any of the PDFs i

B Outline| ¥ statistes 21~ ST History| = B 4 i — T ——————————— R 8
+ B ) Console &1 - % Objects| 7 search Path| 55 Output| &%) Tasks| 2 Problems| — 5
Spotfire S+ Command Line -

Statistics TIBCO Software Ins. Confidentizl Info
| Copyrlgnt (C) 1982-2010 TIBCO SOLLWAL

Services TTRCO Spotfire S+ Version A.2.0 for Mi
Working data will be in C:/USERS/ KROAN/ T
|
o

i S Workepace Ready

Figure 4.2: The blank workbench.

Notice that the Console view, in the lower part of the screen by
default, looks like the standard Spotfire S+ GUI console. You can
type and run commands in the Console view. See the section Spotfire
S+ Workbench Console on page 49 for more information.

An easy way to display the Script Editor is to type an Edit
command in the Console view. For example:
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Edit(myfunc)

opens the Script Editor with the beginnings of that function
definition. Alternatively, you can create a project or a new script file.
See the section Creating a Script on page 156 for more information.

r M
S Spatfire S+ - Ci\Users\kroan\AppData\Local\ Temp\Ed021BF9.tmp - Spotfire S+ Workbench - ==
File Edit SpotfireS+ Navigate Search Project Run Window Help
il =] P E G el B A 5[ s° Spotfire 5+
& - FE - [=R - [y Resource
5 Navigator 23 = B El Welcome Ed021BF2.tmp 1 =0
= Q;é = 1 }'n’.j.'f;:r:"<— -
2 function()

3 |1
4 }

4 3

TF Outlin | 45 Statist &2 SJH‘“W =0 Bl Console 2 . %5 Objects Sj Search P| 2 Qutput | ) Tasks [ Problen| = B

7 = Spotfire 5+ Command Line = v[4v ¥
TIBCO Software Inc. Comfidential Information -
t Copyright (c) 1283-2010 TIBCO Software Inc. ALL RIGHTS RES 1l
TIECO Spotfire 5+ Version #.2.0 for Microsoft Windows : 20
fl Viorking data will be in C:/USERS/KROAN/WORKSPACE

> Edit (myfunc)
>

4 1
i I C

n* C\Users\k..021BF9.tmp | % Workspace Ready

Figure 4.3: Using Edit to open the Script Editor and create a function.

Creating a The Spotfire S+ Workbench project is a resource containing scripts

Project and associated files. You can use the project to control build, version,
sharing, and resource management. This section contains guidance
for creating a project in the workspace, adding a second project to a
workspace, adding a package project, and importing files into an
existing project.

Understanding Before you create a new project, consider the following scenarios, and
Project Options  then review the Spotfire S+ Workbench options.
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Table 4.1: Spotfire S+ Workbench project scenarios.

Scenario Spotfire S+ Workbench Option

You are starting an empty In the New Project wizard, specify a
project with no existing files. | project name and accept the default

(Note: This is the only way project directory location.

to create a project that is If your project is a package, navigate
stored in your workspace.) through the wizard using the Next button.
In the Spotfire S+ Package tab, select
Create Spotfire S+ Package structure.
Click Finish.

Your project is created as a subdirectory
in the workspace directory. (The
Navigator view displays the .Data
directory and the .project resource but
no existing project files. Do not edit these
items.)

If your project is a package, the project is
created as a subdirectory in the
workspace directory, and the package
structure and required directories are
created, as follows:

+ .Data (Contains required
subfolders and files; do not edit
this directory.)

+ data
*  man
- R

e src

In addition, a stub DESCRIPTION file
is placed in the project directory and
informational README files are created
in each directory. For more information
on package directories, see the Guide to
Packages. For more information about
creating a package project, see the section
To create a package project on page 168.
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Table 4.1: Spotfire S+ Workbench project scenarios. (Continued)

Scenario

Spotfire S+ Workbench Option

You have one or more
project(s), and you want to
work with the files at their
existing location.

In the New Project wizard, specify a
project name, clear the Use default
check box, and then browse to the
location of the project files. Spotfire S+
Workbench works with the files at the
specified location. (The Navigator view
displays the .project resource and all files
in the project directory.)

If you are importing the source files for a
package, all of the required directories
and are included in the project.

Note that the project cannot overlap other
projects and cannot be located under
your workspace.

You have an existing
project, and you want to
copy selected files to a
workspace directory (for
example, in the cases where
the files are kept at a remote
location, are read-only, or
where you do not want to
work with the original files).

In the New Project wizard, specify a
project name and accept the default
project directory location. An empty
project subdirectory is created in the
workspace directory. You can then import
your project files. See the section
Importing Files on page 131 for more
information.

Based on the scenario that applies to your project needs, In the
following sections, create an empty project, and then import the
Census project files (the third scenario described above).

To create the example census project
1. Click File » NewP> Project.

2. In the New Project dialog, select Spotfire S+ Project. Click
Next.

3. Provide the friendly project name, “Census.”

4. Accept the option Use default. This option creates the
project directory in the default workspace location.
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5. Leave Create Spotfire S+ Package Structure clear (the
default).

6. Click Finish to create the project.

rS MNew Project [_Iﬂlﬂ_hjw

S-PLUS Project

Create 5-PLUS Project. f

Project name:  Census|

Use default location

Ch\Users\kroan\workspace\Census Browse

[] Create S5-PLUS Package structure

'@:‘ < Back MNext = I Einist: I Cancel

Figure 4.4: New Project dialog.

Note

When you create a project, you see in the Navigator view the .project resource. This resource is
created by Eclipse and contains information that Eclipse uses to manage your project. You
should not edit this file.

Importing Files  In this exercise, import the Census example, one of the examples
provided with Spotfire S+.

To import files

1. With the Census project selected in the Navigator view, click
File » Import.

2. Inthe Import Select dialog, expand the General folder, and
then select File system. Click Next.
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3. In

the Import File system dialog, browse to the location of
the census project (by default, in your installation directory at

SHOME/samples/bigdata/census.)

4. Select the directory, and then click OK. The directory name
pears in the left pane, and all of the project’s files appear in

ap

the right pane.

Select the folder name in the left pane to select all files, and

then click Finish to add the files to your project.

S impor ==
File system F==N
Import rescurces from the local file system.
-
From directory: les (B86)\TIBCO\splus2\samples\bigdata\census

= census L) census.csv
census.demo.ssc
graph.setup.q
ry.vbar.q
Readme.txt

Filter Types... | elect Al | [ Deselecta |
Intc felder:  Census

Opticns

[] Owerwrite existing resources without warning
() Create complete folder structure

@ Create selected folders only

@j Mext > [ Finish ] ’ Cancel

=

Figure 4.5: Import File System dialog for Census project.

Hint

You can select just the .ssc file to import if you prefer, because the script itself references the data

in these files. For the purposes of this part of the exercise, we import all files.
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Figure 4.6 shows the Navigator with the Census project and
all its files.

census, demo,ssc
graph.setup.g
my.vbar.q

5] Readme bxt

Figure 4.6: Navigator showing Census project.

Note

Alternatively, you can copy files from a different location to your project directory in your
workspace. If you simply copy files, you must refresh the Navigator view to include the files in
your project and display them in the project file list. To refresh the view, right-click the project
name, and from the menu, click Refresh.

Loading a Library You work with Spotfire S+ code in the Workbench the same way you

Adding a Second
Project

work with it in other environments, such as the Java GUI, the
command line, or the Windows GUI To load a library, in the
Console, simply call:

library(libraryname)

Where 7ibraryname is the library to load.
For example, if you are working with Spotfire S+ packages, before
you get started, load the pkgutils library:

library(pkgutils)

In this exercise, create a project with the files for the Boston Housing
example at their existing location (the second scenario described
above), rather than importing the files into a workspace directory.
Boston Housing is an example provided in the Spotfire S+ sample
files, by default, in your installation directory at SHOME/samples/
bigdata/boston.

To add a project
1. Click File » New P Project.
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then click Next.

In the Project name text box, type “Boston Housing,” and

then clear the Use default check box.

Browse to the location of the Boston Housing sample
directory, by default in the SHOME/samples/bigdata
directory of your Spotfire S+ installation. Select the boston
directory, and then click OK. Click Finish to add the project.

2. In the New Project wizard, select Spotfire S+ Project, and

S* New Project Lo
S-PLUS Project =

Create 5-PLUS Project.

Project name:  Boston Housing

[7] Use default location
Location: C:\Program Files (x86)\TIBCO\splus&2\samples\bigdata\boston

[] Create 5-PLUS Package structure

Browse...

1

Cancel

l

Figure 4.7: New Project dialog, using boston files at their installed location.
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5. In the Navigator view, the Boston Housing project appears.
This directory contains all of the files in that sample directory
location.

U5 Mavigator &3 =0
[B&~
. 5 Boston Housing (working)
a 9 Census
a [= .Data

= _Hhelp

- = __Meta

__nonfi

1

El .project

] census.csv
census.demo.ssc
graph.setup.q
my.whar.g

El Readmett

Figure 4.8: Navigator containing two projects.

6. You won't be using this project for the remainder of this
tutorial section, so right-click the directory, and then select
Delete.

7. In the Confirm Delete Project dialog, select Do not delete
contents. (Otherwise, you will delete the sample from your
installation directory.)

8. Click Yes to remove the project.

You can copy files from an existing project to a working project by
copying their .ssc files from the original project to the working
project’s directory. Note that to see these files in your project, you
must refresh the view. To refresh the Navigator view, right-click the
project, and from the menu, click Refresh. (Restarting the Spotfire S+
Workbench does not automatically refresh the view.) Alternatively,
you can use the File » Import menu command: Specify a file
system, browse to the original location of the desired file, and then
select only that file to import. (Importing a file into a project from
another location copies that file to the project folder in your
workspace.)
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Project
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In this exercise, add another project, importing the sample files, as
you did in the section To create the example census project on page
130. This second project is the project you will use later in this chapter
to practice debugging tasks.

Follow the directions for creating a project on pages 130 to page 133,
but instead of importing the Census project, import the kahanSum
project, located in your installation directory at SHOME/samples/
kahanSum.

To add the kahanSum project

1.
2.

10.

Click File » New » Project.

In the New Project dialog, select Spotfire S+ Project. Click
Next.

Provide the friendly project name, “kahanSum.”

Accept the option Use default. This option creates the
project directory in the default workspace location.

Click Finish to create the project.

With the kahanSum project selected in the Navigator view,
click File » Import.

In the Import Select dialog, select File system, and then
click Next.

In the Import File system dialog, browse to the location of
the census project (by default, in your installation directory at
/samples/kahanSum.)

Select the directory, and then click OK. The directory name
appears in the left pane, and all of the project’s files appear in
the right pane.

Click Select All, and then click Finish to add the files to your
project.
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Figure 4.9 shows the Navigator with the kahanSum project
and all its files added to the workspace. (You will work with
this project later in this chapter.)

5. Navigator &2 =0

a E Census
a = Data
= _Hhelp
- = __Meta
__nonfi
1

El .project
EL) census.csv
census.demo.ssc
graph.setup.q
my.vbar.q
El Readmett

a (’é kahanSum (working)

- = .Data

El .project
kahanAddMext_func.q
kahanSum.q

Figure 4.9: Navigator showing kahanSum project added to the workspace.

Spotfire S+ provides customizations to the Eclipse IDE to
accommodate the specific needs of the Spotfire S+ programmer. You
can change the IDE to suit your development style, including adding,
removing, and repositioning the views, and setting the preferences.

* To review the preference options in the Preferences dialog,
see the section Examining Spotfire S+ Preferences on page 14.

* To review the views available in the Spotfire S+ Workbench,
see the section Examining the Spotfire S+ Workbench GUI
on page 31.

+ To learn more about customizing the views in the Spotfire S+
Workbench, see the section Customized Perspective Views on
page 148.

This section demonstrates setting specific preferences in the
Preferences dialog.

To set text editor options

1. On the Window menu, click Preferences.
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Spotfire S+ View
Preferences
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2. In the Preferences dialog, select General, and then click
Editors P Text Editors.

3. Review the options, including tab width (by default 4), line
numbers (by default displayed), and appearance color options
(by default, the system colors). You can set additional options
in the Spotfire S+ P Editor options dialog. See Figure 4.14
for an example.

To examine file association preferences

4. In the Preferences dialog, select General, and then click
Editors. Examine the dialog pages.

5. Click File Associations and review the file types that the
Script Editor recognizes.

('S Breferancas | (=]. | S| |
type filter text File Associations L= g v -
4 S See 'Content Types' for content-type based file associations.
Appearance e —
Compare/Patch
Content Types @ *.htm Add...
a Editors @ *.html ———
File Associations “q [ Remove |
Text Editors r
Keys @ ~.shtml
Network Connections S
Perspectives “t 1«\,
Search
Security
Startup and Shutdown
Web Browser
Workspace
Help
» Install/Update
. Run/Debug
Spotfire S+
Statistics Services
. Team Associated editors:
@ Web Browser Add...
no
@ oK | [ cancel

Figure 4.10: File Associations page.

The previous section demonstrated setting Eclipse general
preferences that the Spotfire S+ Workbench takes advantage of. The
following sections demonstrate setting preferences specific to the
Spotfire S+ Workbench views. These preferences include general
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Spotfire S+ preferences, preferences for the Console and the
Output, preferences for the Output, and preferences for defining
task tags.

To set the Spotfire S+ preferences
1. Click Spotfire S+.

2. Review the options. Make sure the bigdata library loads on
startup: check the check box Run code on startup. (The
Census example demonstrated in this chapter uses the
bigdata library.)

3. Optionally, select Send Output from Run Action to
Console, if you want your script output to appear in the
Console rather than the Output.

4 beneral Spotfire 5+ Workbench options
. Appearance
Compare/Patch Run code on startup:
Content Types
- Editors
Keys
Perspectives
Search
- Startup and Shutdown
- Workspace
- Help
- Run/Debug
4 | Spotfire 5+
Console
Editor
Outline
Output
Profile
Task Tags
Statistics Services
. Team /| Integrate Java Graphs into the Spotfire 5+ Workbench
Send Output from Run action to Console view

Spotfire S+ Package Repository:  http://spotfiretibco.com/csan R

| Restore Defaults| | Apply |

(‘?:I [ oK ] | Cancel |

Figure 4.11: Spotfire S+ Preferences page.

To store the console history between sessions

1. In the left pane tree view, click Spotfire S+ to expand, and
then click Console to display that page.
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2. In the Console page, select Store Console History
between sessions. You can use this setting to persist the
contents of the History to use later in the Console. For more
information about storing the console history and using it in
the output, see the section Console Options on page 18.

3. Optionally, change the input and/or output color or font to a
color or font of your choice. For more information about

these options, see the section Font Settings on page 19.

- Startup and Shutdown
‘Web Browser
: Workspace
> Help
> Install/Update
> Run/Debug
4 Spotfire 5+
Console
Editor
Outline
OQutput
Task Tags
Statistics Services
> Team

©

Output Color E]

Background Settings

@) System Default (0) Customn

Copy Settings
[“]Include Prompts in Copy action

(7S Preferermces ][ - e |
- e .
type filter text Console = - v
A EaeE Spotfire 5+ Console options
> Appearance
Compare/Patch History Settings
Content Types [] Store Console History between sessions
4 Editors
File Associations Font Settings
> Text Editors
bedefghijkl. . .
o on [ chenge
Font Selection Change
> Metwork Connections
Perspectives
Search Input Color E]
> Security

[ Restore Qe‘FauIts] [ Apply

]

[

OK

) {

Cancel

]

Figure 4.12: Console page.
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To add text with a user-defined h

ighlight color
1. In the left pane tree view, under Spotfire S+, click Editor to
display that page.
2. In the Editor dialog, in the Syntax Highlighting list box,
select User, and then click Choose Color.
In the Color dialog, select a color, and then click OK.
4. In the User Tokens area, click New.

In the Add Desired Spotfire S+ Text dialog, select Comma
Separated Text. In the text box, type census, and then click
OK.

S* Add Desired 5-PLUS Text l |

@ Comma Separated Text (0) Comma Separated File () S-PLUS Cornma

S-PLUS Text to Highlight  census|

[ OKV\,\)J [ Cancel

Figure 4.13: Add Desired Spotfire S+ Text dialog.

6. Note that census appears in the User Tokens list box. Click

Apply. In later exercises, when you manipulate the Census
project, you will see the string you selected highlighted in the
color you specified. You can add other user-defined terms,
including Spotfire S+ commands or the contents of a comma-
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separated file and see how it makes tracking these items
through your code easier. For more information about this
option, see the section Syntax Highlighting on page 21.

r ™
5% Preferences e Sy
type filter text Editar =1 o> o
EZar Spotfire 5+ Editor options
Help
Install/Update Syntax Highlighting User Tokens
Run/Debug
Spoffie - Defuit feenss
Console Comment
Outline Quoted String
Output Dbl Quoted String
Task Tags Constant
Statistics Services Type
Team
User
Choose Color E
Hover
Evaluate expression and display value if engine available
Spotfire 5+ Format Options
Margin Column 60
[] Use Spaces for indentation 4
Encapsulate all scope blocks with {}
Start each scope block on a new line
if (x==1) -
{
print("x == 1")
1
else
{
B print("x !=1")
1
’Restore Defaults] ’ Apply ]
@j [ QK ] ’ Cancel ]
L

Figure 4.14: Editor page with census added as highlighted user text.

To add the contents of a comma-separated file

1. Open a text editor, such as Notepad.
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Type some terms to highlight, separated by commas. For
example, if you want to highlight in your code every time the
data viewer or a graph opens, type bd.data.viewer, hist,
xyplot, bwplot, histogram, and so on.

Save the file with a convenient name and to a convenient
location (for example, C:\terms.txt).

Return to the Spotfire S+ Workbench Editor preferences
dialog, and, in the User Tokens area, click New.

In the Add Desired Spotfire S+ Text dialog, select Comma
Separated File.

Either type the file path, or click Browse and browse to the
file location.

Click OK, and notice that all of the terms in the file are added
to the User Tokens list. Figure 4.15 shows the User Tokens
list with the terms added from the file.

~User Tokens

bd, data, viewer
hiisk

svplot
bplot Remave |

histogram

Figure 4.15: User Tokens list displaying the contents of a file.

To add a Spotfire S+ command to the User Token list

L.
2.

In the User Tokens area, click New.

In the Add Desired Spotfire S+ Text dialog, select Spotfire
S+ Command.

In the Spotfire S+ Text to Highlight box, type the Spotfire
S+ command objects().

143



Chapter 4 TIBCO Spotfire S+ Workbench Tasks

4. Click OK, and notice that all of the objects in the working
project are added to the User Tokens list. Figure 4.16 shows
the updated User Tokens list.

- User Tokens

JLast,value
.Random, seed
agelist

ageFactar REmove |
bars

Census

census,goodPop

censusStack

graph.setup

kahansum

last.dump

my . wbar

Mew. ..

Figure 4.16: User Tokens list displaying working project objects.

To remove items from the User Tokens list, select them and click
Remove.

To change the code formatting options

1. In the Spotfire S+ Editor options page, review the Spotfire S+
Format Options group.

2. Select Use spaces for indentation, and notice how the
example display changes to reflect the default 4. Clear this
option, if you choose, or change the default to add more or
fewer indentation spaces.

3. Change some of the other formatting options to suit your
programming style, and then click Apply to apply any
changes to the editor.

To add a function to watch

1. In the left pane tree view, click Outline to display that page.
2. Click New.
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3. In the Add New Function to Watch dialog, add set.seed.

Click OK.
F B
5% Add New Function(s) to Watch ["‘:' = éj
@ Comma Separated Text (©) Comma Separated File (7) 5-PLUS Command
Functionis) to Watch | set.seed J. Browse...
[ oK ] ’ Cancel ]

Figure 4.17: Add New Function to Watch dialog with set. seed.

4. Review the list in the Functions to Watch dialog. Note that
set.seed has been added to the list. (Later, when you are
working with a project that uses the set.seed function, you
can see its display in the Outline view has a special icon.) For
more information about this option, see the section Functions

to Watch on page 23.
M ™
§* Preferences = 53
type filter text Outline o . S
EeTeraI Spotfire 5+ Outline options
ep . . .
Install/Update Show Anonymous Functions in Outline
Run/Debug Functions to Watch
Spotire S+ [ New. ]
Console setMethod
P setClass
Edlto.r setReplaceMethod Remove
Outline eths
Output cetls
Task Tags setValidity
Statistics Services setGeneric
Team setGroup
setGroupGeneric
setClassPrototype
’Ravtore Defaults] ’ Apply ]
@) ’ OK ] ’ Cancel ]

Figure 4.18: Outline page with set.seed added.
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To add a task to the Task Tags options
1. In the left-pane tree view, click Task Tags.
2. Click New to display the Add New Task Type dialog.

3. In the Task Name box, type a name for a new task to watch.
Set the severity to your preference, and click OK to add the

task.
S* Add New Task Type =
Task Name:  MyTag| I
Severity: [NORMAL -
[ 0K ] I Cancel ‘

Figure 4.19: Add New Task Type dialog.
4. Highlight the items to change in the Spotfire S+ Task

Options text box, or, using the New, Remove, Up, and
Down buttons, edit the available tasks. In the Script Editor,
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when you type this term, prefaced with a comment character
(#), the line is added to the Tasks view with the severity you
indicate for the custom tag.

-
5% Preferences ol S
type filter text Task Tags L=l 4 v v

Eel:eral Spotfire 5+ Task options
elp
' %650 (NOFY [ New. ]
r: E,D bp ae TODO {NORMAL} e
Spotfire 5+ KK {LOWY LS
Console
.
Editor
Output
Task Tags
Statistics Services
Team
’Restore Defaults] ’ Apply ]
® ’ 0K ] ’ Cancel ]

Figure 4.20: Task Tags page with a new task added.

5. Click OK or Apply to save your changes, or click Restore
Defaults to return the task options to their default state.

6. Click OK to save your changes.

147



Chapter 4 TIBCO Spotfire S+ Workbench Tasks

CUSTOMIZED PERSPECTIVE VIEWS

The layout of the Spotfire S+ perspective presents the Navigator
view, Outline view, Statistics Services view, and History on the left
side of the window. The Console, Objects, Search Path, Output,
Tasks view, and Problems view are tiled across the bottom of the
window. The Script Editor pane is empty.

Note

If you do not see one of the following Spotfire S+ specific views in the user interface, you can
display it from the menu by clicking Window » Show View P Other, and then selecting it
from the Show View list.

To customize the Spotfire S+ perspective

1. Click the Outline view tab and drag the view beside the
Navigator view. The Outline view now tiles with the
Navigator view.

2. Click the History tab and drag the view to the right; it now
tiles with the other views.

3. Right-click the Tasks view tab and select Fast View. The
Tasks view minimizes and appears as an icon in the window’s
status bar.
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4. Click the Output tab to select it.

S* Sample Exercise - Census/censusdemoisse - Spoffire S+ Workbench = | 5] |
File Edit SpotfireS+ MNavigate Search Project Run Window Help
B~ & ow H L h i i - - i [§ SampleBxerc.. | ™
& Na 22 N B=0 [87Hi| =0 census.demo.ssc 53 [ sample Exercise perspec
P ‘ B % 1 # Big Data Census Demo Script N
| — 2 % m
%5 Census (working) : . —
= Data 3 # Example for tt g i
. a the S-PLUS Wor
= _Hhelp N i B
= _Meta 6 # script starts by
8 _ronf 7 # wnich came frem
B 8 # combined so the new columns are ages in 5-year bins.
project g
B census.csv 10 # First source in so
census.demo.ssc 11 socurce (paste (gecenv( 3]
graph.setup.q 12 scurce (paste (gecenv(
mywbar.q 13 sep=))
[E Readmett 14
%5 kahanSum 15 # Import the data, use the bigdata=T flag to create 2 bdFrame cbject:
16 census <- importData(paste (getenv("SHOME"),
17 "/samples/bigdata/census/census.csv", sep=""),
18 stringsAsFactors=F, bigdata=T) -
< m »
%2 Objects | ¥ Search Path | ¥ Output 22 [2 Problems| B Console ¥ =8

** Engine execution output ****

“* Engine startup oukput ***s
0 Software Inc. Confidential Information
ht {c) 1988-2010 TIECO Software Inc. ALL RIGHTS RE;ER"ED

otfire S+ Version 8.1.3 for Microsoft Windows :

u\:rklng data will be in C:/PROGRAM FILES/TIBCO/ STBTS"C"BI T"‘CG DATA/ SESSIONS/ F310AC
Minimized Task
view -
< i b
1% 7 Census/census.demo.ssc % Census Ready Wr..le

Figure 4.21: Customized Spotfire S+ perspective.

5. Click Window P> Save Perspective As.

6. In the Name box, type “Sample Exercise,” and then click
OK.

The Sample Exercise perspective button appears on the toolbar:

ﬁl §7 Sample Exercise |

Figure 4.22: Sample exercise perspective button.

To change the displayed views

1. To change the views, or to display the list of available views,
on the menu, click Window » Show View.

2. From the submenu, select the view to display.
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Alternatively, if you do not see the view you want to display,
from the Show View menu, click Other, and then select a
view from the Show View dialog. For example, if you want
to display a view that is typically in the Debug perspective,
expand Debug, and then select a view from the list.

§* Show View L@ér

type filter text

- = General
- [= %DeprecatedSPlusCategory.namel
» [= Debug
- [= Help
4 [= Spotfire 5+
£ Graph H
S_'] History
%5 Objects
B Output
S_'] Search Path
4 [~ Statistics Services
|&%] Im
&) Monor Jobs
4 Statistics Services
. = Team

QK Cancel

Figure 4.23: Show View dialog.
+ If the view is not currently visible in the Ul, selecting it
displays the view and gives it focus in the UL

+ If the view is available, selecting it gives it focus in the UL

To return to the Spotfire S+ perspective default

1. Click the perspective button to the left of the Sample
Exercise button, and then click Other.

2. In the Select Perspective dialog, select Spotfire S+, and
then click OK. The perspective returns to its previous layout.

You can select other views to display in your perspective.



Working Projects and Databases

WORKING PROJECTS AND DATABASES

Setting the
Working
Project

This section describes setting working projects and changing
databases.

The Spotfire S+ Workbench provides the following ways you can
store your data objects:

* In the working project .Data, where the objects are available
only to the project.

* In the workspace .Data, where the objects are available to all
projects in the workspace.

You can change the .Data storage option at any time by setting any
project in the workspace as the working project, or toggling off the
working project option and writing data objects to the workspace
.Data database.

When you create a workspace, a .Data database is created in the
workspace, and (after you refresh the view) the workspace path
appears in the first position in the Search Path, as shown in Figure
4.24. If you specify no working project, the Spotfire S+ Workbench
writes data objects to the workspace .Data database, and the objects
in that .Data database are available to all projects in the workspace.

|Conscle CObjects SJS«:!arcl‘iI:‘ath 1 Cutput | Tasks Problems
| Search Path |

Census
bigdata
splus
stat
data
trellis
nlne3
winjava
menu
SPXML

main

D 0D O O e L R

=1

Figure 4.24: Search Path with first position set to the workspace.

When you create a project and import project files, the Spotfire S+
Workbench creates a .Data in the project, sets it as the working
project, and sets the project in the first position in the Search Path.
Any objects created are added to the working project’s .Data
database.
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To set the working project

1. Select the project to set as the working project.

2. From the main menu, click File » Toggle Working Spotfire
S+ Project. (Alternatively, in the Navigator, right-click the
project that you want to set as the working project, and from
the context sensitive menu, click Toggle Working Spotfire
S+ Project.) Figure 4.25 shows the context menu.

T Mavigator &2
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set.se
clust:

L INEERN I O R R

C. &

e

v Toggle Working Spotfire 5+ Project l}

= :
g census.demo.ssc

==
New

Go Into
Open in New Window

Copy
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Figure 4.25: Toggle Working Spotfire S+ Project on the Navigator context-

sensitive menu.
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Working Projects and Databases

The selected project is displayed as the working project. Any
objects you create are stored in the Census .Data database
until you choose another project as the working project, or
toggle off the working project, so the workspace .Data is the
database.

5. Navigator &2 =0
EE
a (’é Census (working)
a [= Data
= _Hhelp
- = __Meta

__nonfi
1

E .project
EL) census.csv
census.demo.ssc
graph.setup.q
my.vbar.q
| Readmett

1 E kahanSum

Figure 4.26: Census set as the working project.

Spotfire S+ recognizes libraries, modules, lists, and directories as
legitimate object databases. You can add and detach any of these
types of databases to the Search Path.

By default, the Search Path displays the full path of the working
database and all of the attached Spotfire S+ data libraries. Objects
existing in a recognized active database appear in the Objects.

Objects in an added database appear in Objects when you refresh the
view to that database. See the section Examining Objects on page
160.

To add a library
1. Right-click the Search Path.
2. From the right-click menu, click Add Library.

3. In the Attach Library dialog, type MASS. Clear the Attach
at top of search list check box to indicate that you want add
the library to the bottom position.
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4. Click OK and examine the Search Path for the change.

S Attach Library l =] ﬁ]

Library Name to Attach: | MASS
Attach at top of search list: %

QK ] I Cancel

Figure 4.27: Attach Library dialog.

To add a module
1. From the right-click Search Path menu, click Add Module.

2. In the Attach Module dialog, provide an installed module
name and indicate whether to add it to the first position.

3. Click OK and examine the Search Path for the change.

To add a directory
1. Right-click the Search Path.
2. From the menu, click Attach Directory.

3. In the Attach dialog, in the Directory to attach text box,
browse to the directory location.

4. In the Label text box, type Projects

5. In the Position text box, type 4.

6. Click OK and examine the Search Path. The label you
provided should appear at position 4.

Detaching a From the Search Path, you can detach a database from your current
Database session.

To detach a database
1. Inthe Search Path, right-click bigdata.
2. In the right-click menu, select Detach.

3. Examine the Search Path. The Big Data library is no longer
attached.
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Refreshing the When you refresh the view, any changes to the Search Path that

View have not been reflected in a recent change are displayed. For
example, if you add a library by calling the load function in a Spotfire
S+ script, the change is not immediately displayed in the Search
Path.

To refresh the view

1. Using the Console, reattach the Big Data library. In the
Console, type

library(bigdata, first = T)
2. Right-click the Search Path.

3. In the right-click menu, click Refresh. Notice that the Big
Data library appears as attached in the first position (position
2).
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SPOTFIRE S+ PROJECT FILES AND VIEWS

Creating a
Script

Viewing Project
Files

Removing files
from a project
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The Spotfire S+ Workbench recognizes *.ssc, *.q, *.r, and *.t files, all
file extensions common in Spotfire S+ code.

You can create a new Spotfire S+ script file, or you can import an
existing script file. The following two examples demonstrate both
techniques.

To create a new script file
1. Click File » New » Other.

2. In the Select a wizard dialog, select Spotfire S+ Script.
Click Next.

3. In the New File dialog, select the parent directory (the
Census project directory)

4. In the File name text box, type Sample.ssc.
5. Click Finish to create the file.

We won’t work with this file for this exercise, so you can either
disregard the file, or delete it from your project. Alternatively, you
can open the file, add some Spotfire S+ code, and save it in the
project.

The Navigator view displays the project files. In Windows, if you
have Microsoft Excel installed, you can open a CSV file in an
external window. In this project, only the files identified in Windows
» Preferences in the File Extensions page open in the Script editor.

Because the project script imports the data in the files from their
installation directory in Spotfire S+, you don’t need to have them all
in the project. However, removing an imported file deletes it from
your project directory, so remove individual files with care.

To remove a file from the Census project

1. In the Navigator view, open the Census project and select all
files except the .project file and census.demo.ssc.

2. Right-click the selected files, and then click Delete.



Editing Code in
the Script
Editor

Spotfire S+ Project Files and Views

3. Inthe Delete Resources dialog, click Yes to remove the files
from the project. The Navigator view should now just
display the Census Project directory, the project file, and
census.demo.ssc:

census, demo.ssc
kahansum

Figure 4.28: Navigator view after deleting files

The Spotfire S+ script is a text file that you can edit in the Script
Editor. In this exercise, just edit census.demo.ssc using the menu
items provided specifically for Spotfire S+.

To edit script code

1. In the Navigator view, double-click the file census.demo.ssc
to open it in the Script Editor and examine the script. Note
that:

* The comment text appears in the Script Editor as green.
(You can change this default color in the Preferences
dialog. See the Eclipse Workbench User Guide and the
section Setting the Spotfire S+ Workbench Preferences on
page 137 for more information.)

* Note that the term census appears in the color you
specified in the section To add text with a user-defined h
on page 141.

* The line that has focus appears highlighted.
* The line numbers appear to the left of the script text.
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2. In the second line of the file, press Enter to insert a carriage
return, and then begin typing a function name (for example,
Tibrary).

3 CEnsUS.demo, 550 O

1 # Big Data Census Demo Script
1in|

#  library

#  library.dynam

#

#

L= O 1 Y VR SN

Figure 4.29: Code completion for the 1ibrary function.

Note that as you type each character, the code completion
feature displays the function names using the character string
so far. (The code completion feature reads the Search path on
startup and displays functions from all loaded libraries. It
refreshes the list periodically.) When you see the function
name you want to use, select it from the code-completion list
and press Enter to insert it into the text editor.

Note

The code completion feature works in both the Script Editor and the Console.

3. Type the open parenthesis character, (. Code completion
displays the function’s arguments. (The arguments are
displayed until you type the closing parenthesis character.)

1 *census.dema.ssc
1 # Big D

Z library|

Figure 4.30: Code completion shows arguments for the function.

4. Delete the line you just inserted (it is not needed for the rest of
this example).

5. Scroll to the line containing the following text (around line
16), and and highlight the line and the next line:

"/samples/bigdata/census/census.csv", sep=""),
stringsAsFactors=F, bigdata=T)
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6. Click Spotfire S+ P Shift Left. The code shifts to the left.
7. Click Spotfire S+ P Format. This command formats the

entire script. Note that the formatting change you made in the
previous step has been reverted. Also note that the line
numbers for formatted functions are highlighted.

Hint

The line numbers for any line changed in your script are highlighted until the next time

you save your work.

Click Spotfire S+ » Toggle Comment to add a comment
character. Notice that the script text color changes to indicate
that the line is no longer a comment.

Repeat step 6, or type CTRL+SHIFT+# to remove the
comment.

To edit a function definition

L.

In the Script Editor, select the function whose definition you
want to edit.

Press the ctrl key and click the function again.

The function definition opens in a temporary file in the Script
Editor.

Alternatively, you can open a function for edit by right-clicking the
function name, and from the menu, click Find “functonname”. Find
searches files currently open in the Script Editor, then files in the
working project, and finally in the Spotfire S+ database for the
function definition.

Note

Any code changes you make in an editor are not recognized by Spotfire S+ until you source the

code.

To find all references to a function

L.

Right-click the function whose references you want to find.
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Examining the
Outline

Examining
Objects
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2. From the menu, click Find References.

3. Review the results in the Search view. Figure 4.31 displays
the results of running Find References on the function hist
in the Census project.

= —
S* Spotfire 5+ - Census/census.demo.ssc - Spotfire S+ Workbench — = | O ||
Eile Edit SpotfireS+ Nasvigste Search Project Run Window Help
il ok R T e W Q- R ") £ (5% Spotfire 5% e
5. Navigator 5% =8 census.demo 22 =8
| B% < - iate rows with no population count o
®S Census (working) 52 sys.time (census <— bd.filter.rows (census,
(> Data expr—"popTotal > D0"})
Elproject
census.demo.ssc 55 # Cpen the data viewer and notice that census now has 31,951 rows.
=% kahanSum 56 bd.data.viewer (census)

summary (census)

# some exploratory plots ']
= hist (censusShousingTotal) |
> nist (censusSpopTotal) fl

T M = O)|¥ &5 nist(censussrent)
= 66 median(censusShousingTotal)
W% W ow | 1A T 67 1
{a census! - i —— R
a census.goodPop = = = =
a ageDist Bl Console (45 Objects [ 81 Search Path [ ¥z Output [ &5 Tasks [[Z Problems [ 47 Search 2 =
a bars 3 Ak NIRRT Y - ot <
a censusStack S-PLUS Reference Search: hist
& ageFactor 3 Census (working)
O EECHED census.demo.ssc (4 matches)
a norm.exprs
a popProphl
a censush
= setiseed
a clusterCensusN =
o* % Census Ready

Figure 4.31: The Search view afier running Find References on hist.

The Outline view displays all of the items (objects, functions, and so
on) that are contained in the open script. Outline view is not editable.

To examine the outline

1. Examine the objects that appear in the Outline view. Note
that set.seed appears with a yellow arrow next to it, because
in the section Setting the Spotfire S+ Workbench Preferences
on page 137, you indicated that set.seed was a function to
watch.

2. Scroll through the Outline view list and highlight an object.
Note that the Script Editor scrolls to, and highlights, the line
where the object appears.

When you start a new workspace, the Objects is not populated.
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Details about your project’s objects (and all objects in your database)
will appear in the Objects. Objects is not editable; however, you can
refresh the contents, delete objects, or change the view to another
attached database. To refresh the view, right-click the Objects and
click Refresh.

To examine the objects

1. Select the Objects tab to display the objects and their details.
By default, the objects are displayed sorted by name.

2. Right-click the Objects table pane and, in the context-
sensitive menu, click bigdata. The Big Data library objects
are displayed in the Objects. (It might take a few moments to
display all of the objects.)

3. Re-sort the objects by any property displayed in the Objects
by clicking the property’s column title.

To display hidden objects

1. In the Objects, right-click the table pane to display the
context-sensitive menu.

2. Examine the menu. Note that, by default the Spotfire S+
system objects are hidden.

3. On the menu, click Hide Spotfire S+ System Objects to
clear the selection.

4. Examine the Objects table pane and tree view pane to see the
Spotfire S+ system objects in your project.

To select another object database

1. Right-click the Objects and, in the right-click menu, click
your current working directory (the directory at the top of the
list). The project objects are displayed in the Objects. (It
might take a few seconds to display all of the objects.)

The Tasks view displays outstanding project tasks. As discussed in the
section Setting the Spotfire S+ Workbench Preferences on page 137,
the indicators for task levels are stored in the Preferences dialog.
(Click Windows P> Preferences to display them.) You can add a task
in one of two ways:

+ Add the task directly to the Tasks view.
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* Add the task to the script file.

To add a task directly to the Tasks view.
1. Click the Tasks view tab to display its contents.
2. Right-click the view, and then click Add Task.

3. In the Add Task dialog, provide the description and priority
level of the task.

S% Add Task - —ne X

Description:  MyTask

Priority: Low - [[] Comnpleted

On element:

In folder:

i |@:| oK ] ’ Cancel

Figure 4.32: Add Task dialog.

4. Click OK to save and display the new task.
Console|0bjects|Search Path|0utput Mrohlems| ¢ % 7 = O

2 items

v I 4 |Descripti0n
TODO: Change this section

| Resource | Path | Location |
census,dema... Census

Figure 4.33: A generic task in the Tasks view.
A task added directly to the Tasks view displays a check box (for

marking the task complete) in the Tasks view’s first column. It does
not display a reference to a resource, a directory, or a location.
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To add a task in the script file
In the script file, select a blank line.
1. Type the following text:
#/FIXME: Change this section.
2. Save the script file.

Note that the FIXME comment appears in the Tasks view as
a high-level task, with a red exclamation mark in its second
column. The task also displays information about its resource,
directory, and line location. You can go directly to any task in
your script by double-clicking it in the Tasks view.

El Console %’i. Objects S_'I Search Path E_==.E Output V2 Tasks &3 [%1 Problems g;' Search ¥ =08
2 items

! Description Resource Path Location Type

& MyTask Unknown Task

2 FIXME: Change this section census.demo... /Census line 97 Task

Figure 4.34: A FIXME task in the Tasks view.

3. In the Script Editor, change the level of the task by changing
FIXME to TODO and save the file. Note that the
exclamation mark disappears, and the task becomes a normal
level task.

Running Code You can run your Spotfire S+ script code directly from Eclipse in two
ways, which are described in the following section.
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Script Running
Options

Copying Script
Code to the
Console
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The Spotfire S+ Workbench provides the following customized
solutions for running your scripts from either the Spotfire S+
perspective or the Debug perspective.

Table 4.2: Script Editor options for running code.

Option

Description

Copy to Console

Available from the right-click menu in the Script
Editor and from the Spotfire S+ menu, this
option copies the selected code and pastes it into
the Console. See the section Copying Script Code
to the Console on page 164.

Run Spotfire S+
Code

Available from the Run menu, by pressing F9, on
the toolbar, and from the right-click menu in the
Script Editor. This option runs the selected code
(or all code, if none is selected), and then displays
output in the Output. See the section Running
Code and Reviewing the Output on page 166 for
more information.

Run Current File

Available from the Spotfire S+ menu. This
option runs the file that is open.

Run Next Spotfire
S+ Command

Available from the Run menu and from the
Spotfire S+ Workbench toolbar. This option runs
the currently selected S expression or, if the cursor
is not exactly on an expression, the next
expression.

The Console is an editable view (in other words, you can type
commands and run them by pressing ENTER); therefore, when you
copy script contents to the Console using Copy and Paste actions,
you must include the line return, or the script will not run. This
behavior is consistent with the Spotfire S+ Commands window, in
the Spotfire S+ GUI, which also requires a line return to run code.

Also like the Spotfire S+ Commands window, the Console

concatenates the code that runs throughout your Spotfire S+

Workbench session, so you can review and save it.



Copying Script
Code from the
Console view

Examining the
History

Spotfire S+ Project Files and Views

To run copied script code

L.

From within the Census project’s script, select lines 1 - 13 in
the script. Be sure to select the line return at the end of line 13.

Right-click the code and click Copy to Console. The selected
code is copied immediately to the Console and runs. You do
not need to paste it in the Console.

Repeat steps 1 and 2 for lines 15-18.
Finally, repeat steps 1 and 2 for a few more lines.

(You can select all of the code, but if you do so, it appears in
the History as one line. By following the steps above, the
History reflects the three different calls to run the code. See
the section Examining the History on page 165 for more
information.)

You can select and copy code from the Console.

To copy just code, select the code in the console that you want
to copy, right-click the Console, and from the menu, click

Copy.

To copy code and the prompts (> and +) in the Console, set
the Window P Preferences option Include Prompts in
Copy action on the Console/Output page. After you set this
option, any lines you select and copy using the right-click
Copy action includes both code and prompts.

To copy the entire contents of the Console, right-click the
view, and on the menu, click Select All, and then right-click
again and select Copy.

This exercise uses the script code run in the section Copying Script
Code to the Console on page 164.

The History reflects the code run in the Console. Note that the
History displays each selection you make, even if it is more than one
command, on one line, and if the line extends beyond about 50
characters, the History displays an ellipse (...) to indicate more code.
To display each line of code in the History, you must run the lines
individually.
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To examine the history
1. To examine and rerun code from the History.
2. Click the History tab to give it focus.

3. Right-click the first line of code, and click Select input. The
code is copied to the Console. You must return to the
Console and press ENTER to run the code.

(Alternatively, double-click the code in the History to copy it
to the Console and run it.)

You can scroll through the individual entries in the History; as you
scroll, the selection appears in the Console. To run a selected item,
switch from the History to the Console and press ENTER at the end
of the code line.

You can run code directly from the Script Editor by using the Run
Spotfire S+ Code feature.
To run code

1. Select the Output tab.

2. In the Script Editor, select the code to run (or, to run the
whole script, select nothing), and press F9, or on the toolbar,

click RunSpotfire S+ Code.
The Output displays the run code and any Spotfire S+
messages.

To run the current expression

*  On the Spotfire S+ toolbar, click Run Next Spotfire S+
Command. The currently-selected S expression runs, and the
next expression is selected. (If the cursor location does not
match an expression exactly, the next expression is evaluated.

Introduce a programmatic problem in the script to examine the
results in the Problems view.

To examine problems

1. In the Script Editor, on line 13 of the script, remove the
closing parenthesis.
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Save the file. Note that the Problems view tab shows bold
text.

Click the Problems view tab to display the view.

Click the problem description. Note that the Script Editor
highlights the line where the code is broken.

In the Script Editor, replace the missing parenthesis and save
your file. Note that the problem disappears from the
Problems view.

The Spotfire S+ Workbench maintains a list of your projects in the
Navigator view, even after you close all associated files.

To close the project

L.
2.

Select the project to close.

Right-click the Navigator view and, from the menu, click
Close Project.

Examine the Objects and note that it still displays project or
workspace objects.

To reopen the closed project

L.
2.

Select the project.

Right-click the Navigator view and, from the menu, click
Open Project.

In the next section, examine the Debug perspective using a different
example, creating a new project. You can close the Census project at
this point, if you choose.
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PACKAGES IN THE WORKBENCH

The Spotfire S+ Workbench supports creating or using Spotfire S+
packages by providing a simple mechanism to:

Create a package project structure that includes all required
files and folders.

Find and install either package source files or binary files from
either the CSAN Web site (http://spotfire.tibco.com/csan)
or other repository.

Update either the source files or binary packages from either
the CSAN Web site or other repository.

Export a package to a specified repository, either as a source
or a binary package.

Creating a New In this exercise, create a project for the soundex example, which is
described in the Guide to Packages.

Package
Project

168

To create a package project

L.

If you have not already done so, install the package utilites.

install.pkgutils()
Click File » New» Project.

In the New Project dialog, select Spotfire S+ Project. Click
Next.

Provide the friendly project name, “Soundex.” Accept the
option Use default location. This option creates the project
directory in the default workspace location.

Select Create Spotfire S+ Package Structure.
Click Finish to create the project.

To create the package project structure, the wizard loads the
pkgutils library (if it is not loaded already), and then it calls
package.skeleton.

Click File » New P Other, and in the New dialog, select
Spotfire S+ Script. Click Next.



10.

11.
12.

13.

14.

15.

16.

17.

Packages in the Workbench

In the New File dialog, select Soundex/R as the parent
folder, and in the File name box, type soundex.ssc.

Click Finish.

In the Script Editor, define the soundex function:

"soundex"<-

function(x) {
base <- gsub("[*A-Z]", "", toupper(gsub
("ruxLoANEIN,
"t,ogsub ("L \tIF$T, "M, x))))

basecode <- gsub("[AEIOUYI", "", gsub("[RI+", "6",

gsub(ll[MN]+ll, "5", gsub(ll[L]+", ll4ll,
gsub("[DTI+"™, "3™, gsub("[CGJIKQSXZI+", "2",
gsub("[BFPVI+", ™1™, gsub("[HW]I™, "", base))))))))

sprintf("%4.4s", paste(substring(base, 1, 1),
ifelse(regexpr("~[HWAEIOUY]", base) == 1,
basecode, substring(basecode, 2)),

"000"™, sep =""))

Save the file.

Run the function by selecting the code in the Script Editor
and clicking Run.

Repeat Step 7, this time creating a script file named
sample.surnames.ssc

In the Script Editor, create the following object:

sample.surnames <- c("Ashcroft"™, "Asicroft",
"de Ta Rosa", "Del Mar"™, "Eberhard",
"Engebrethson”, "0’Brien", "Opnian", "van Lind",
"Zita"™, "Zitzmeinn™)

Save the file, and then instantiate the object by selecting the
code in the Script Editor and clicking Run.

In the Console, call the soundex function, passing in the
sample.surnames object:

soundex(sample.surnames)

Create the soundex .Rd file:
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prompt.Rd(soundex)
(Refresh the Navigator view to display the new .Rd file.)

Note that you are prompted to edit the file and save it to the
appropriate directory (that is, the man directory).

=] qlé Soundex (working)
#-[= Data
#-[= data
#-[= man
== R
sample.surnames, ssc
sounde, ssc
H (= sre
=] project
DESCRIPTION
README
e fsoundex.Rd

Figure 4.35: The Soundex project with the newly-created stub soundex.Rd.

18. Move soundex.Rd from the top level of the project to the
man subdirectory.

T Mavigator £

= Data
[ data
(== man
README
soundes.Rd
=R
sample_surnames.ssc
sounde:,ssc
- src
D .project
DESCRIPTION
README

=28 Soundex {working)
+
+

Figure 4.36: The new Soundex project.

To build this package, either as a source or a binary package.
Building the After you have created the package, you can build it using the export
Package wizard available from the Export menu option.

To build the package
1. Select the Soundex package project.
2. On the menu, click File » Export.
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3. In the Export dialog, expand the Spotfire S+ folder and
click Spotfire S+ Package. Click Next to display the Export

Figure 4.37: Exporting Soundex as a binary package.

4.

Spotfire S+ Package dialog.

5% Export Spotfire S+ Package

Export Spotfire S+ Package
Export Spotfire 5+ Project as Spotfire 5+ Package

Export Package: Soundex

Build Options
_ Build Source Package
@ Build Binary Package

Export Location:  Chlocal packages

Browse...

S [ B |
(Browse..|

~ | Browse..

@ [ <Bak | nNet> |

Finish

| [ cancel

Select either Build Source Package or Build Binary

Package.

In Export Location, specify the location to place the built

package. Click Finish to build.

Browse to the export location to see the results.

Notes

There are additional options for building and testing packages. For more information, see the

Spotfire S+ Guide to Packages.

If you have access to TIBCO Spotfire Statistics Services and you want to deploy a package to be
used on the server, you can upload your package from the Spotfire S+ Workbench. See the
section Exporting a Package to Spotfire Statistics Services on page 186.
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Downloading
Package
Source Files
from a
Repository

You can download the source files of an existing package, either from
the CSAN Web site or from another repository.

On Windows, you can use the source as a template for
another package, for example, or to just examine the code.

On UNIX® and Linux® systems, download the source to
view the source, install a package, or install and load a
package.

To download package source files

L.
2.

From the menu, click Spotfire S+ » Find Packages.

If you are using UNIX, your option for Type is source only. If
you are using Windows, select Source.

In the Find Packages dialog, select Source, and accept the
default repository (http://spotfire.tibco.com/csan).

(Note that you must have an Internet connection to see the
packages stored at CSAN.)

From the list, select the discreteChoice package.

Review the remaining dialog contents (note that you can
select a package from a local repository, if you have any
stored locally). Accept the default Project Directory (your
workspace). Click OK to download the package source.

Note

Find Packages finds built packages only (that is, those that are zipped or tarballed); it does not
load unbuilt package directories and their files, even from a local directory.

To open a package to build, open it as a new project, and then build it using Export > Spotfire
S+ Package, and then install it.
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You have downloaded the source successfully. The package project
appears in the Navigator view, where you can perform any or all of
the following tasks to examine it.

Expand the file structure and open the code files in the R
folder to examine the code. (Note that the source files for this
package were created using the .q extension.)
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+ Expand the man folder and examine the .Rd files (the source
Help files).

* Expand the data, inst, src, and test folders to see the
additional files that are included to support this package (the
package’s data sources, reference PDF, C++ code, and test
files, respectively. For more information about these folders,
see the Spotfire S+ Guide to Packages.).

+ Toggle to the package as the working project to add the
library to your Search Path. (Click File » Toggle Working
Spotfire S+ Project.)

[l console %’i. Objects S_'I Search Path &3 E_==.E Cutput ) Tasks [‘_ Proble
Search Path

discreteChoice

2 bigdata
3
4
5
3
7
g
9
10
11
12
13

=plus
=tat
data
trellis
curl
nlmel
winjawva
meEn
SPEML
pkgutil=
main

Figure 4.38: The Search Path afier setting discreteChoice as the working project.
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Downloading a
Binary Package
from a
Repository

* Instantiate the objects to see them in the Objects view.

5 spuuns a- - —
File Edit SpotfireS+ Navigate Search Project Run  Window Help
[milh g & o BT MR G R R I T - [ (s~ Spotfire S+ | 5757
‘&5 Navigator 532 =8 mde.g &2 oldClasses.q ordered.q simulators.q utilities.q =8
| B® - # probit estimation code was loosely translated from the Gauss -
B Census L M2 FUC ERACEE A ES (T
E discreteChoice (working) s1=3+ <} elsa.berkeley.edu train/ps.zip)
(= data
= inst
= man
=R = 8
mdc.q 5 mdcProbit <- function(formula, data,
oldClasses.q ; id.column = migm
ordered.q alt.column = il
simulators.q init.par il
utilities.q par.fn i
= sre cov.fn . cov.unpack”, i
= tests contzrol = mdcProbit.contzrol(...},
(l
[E] .project
[2] DESCRIPTION
[2) INDEX =
B Outlin 32 S Histor | 4% Statis =8 b
o= e of the wariable (in data) that id b
L W 22 4 the decision maker - |
© mdcProbit(formula,data,id.column,alt. ~ < i v H
® mdcProbit.control(nrep,sim.fn,sim.args = =
. X am = - = > == o)l
ol e e e e neer et e i E Console | %5 Objects &2 5] Search Path | 5z Output| &5 Tasks| [Z1 Problems| 47 Search N
@ mdcinternalxmat(var.data,id.obs,allid Mame Data Class Storage ... Exten *
@ mdc.internal.probit.awx(cov.fn, commo Hessian function function 3 E Hessian.mdc
& mdc.intemnal.omega(j.var.index) Hessian.mde function function E] o P
essian.mdcOrderet
® mdc.sim.uniform(n,d) Hessian.md. . . function function 3
® mdc.sim.antithetic(n,d) cosf.mde function function 3 coelmdc
@ mde.internal.optim(opt.out) mdc.call.c... function function 3 object
@ mdc.optim.Nelder(par,fn,gr,control,...) mdc.call.d... function function 3
® mdc.optim.BFGS(par,fn,gr,control,...) mdc.call.g... function function 3
& mdc.optim.CG(parfn.gr.control,..) mdc.call.l... function function 3 Boby
® mdc.optim.L(par.fn.gr.control, ...) mde.cov.un. .. function function 3 mdec.call.cumprob
® mdc.optim.SANN(par,fn,gr,control, ...} mdc.cumpro. .. function function 2 mdc.call.density
® mdc.cov.unpack(k nalt) «  mdc.cumpro... functieon function 2 . |28l racie call aenriions T
|< w7 » « I » n
o® discreteChoice/R/mdc.q @ discreteChoice Ready

Figure 4.39: discreteChoice package source, imported into the Spotfire S+
Workbench.

If you are working with Microsoft Windows, you can copy binary
packages from a specified repository using the Find Packages dialog.

Note

If you have installed the source from the section To download package source files on page 172,
you must delete the project before downloading the binary package.
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To download binary packages
1. From the menu, click Spotfire S+ » Find Packages.

2. For Type, select Binary (the default; for Windows only. For
UNIX, Type displays only Source).
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3. Accept the default repository
(http://spotfire.tibco.com/csan).

(Note that you must have an Internet connection to see the
packages stored at CSAN.)

4. From the list, select the discreteChoice package.
For Install Options, select Install Binary + Load.

Note

When you select Install Binary + Load, Spotfire S+ loads the library with the first argument
set to False (that is, the library is not installed in position 2 in the search path). if you want the
library in position 2, select Install Binary, and then, in the Console, call
library(discreteChoice, first=T).

6. Review the remaining dialog contents (note that you can
select a package from a local repository, if you have any
stored locally). Accept the default Project Directory (your
workspace). Click OK to install and load the binary package.

When the binary package loads successfully, the Workbench displays
the following message:

The downloaded packages are in

C:\DOCUME~1\username\LOCALS~1\Temp\di000B70.tmp\downloaded_
packages

Welcome to the discreteChoice library. For additional
information see discreteChoice.pdf in C:\Documents and
Settings\username\Application
Data\tibco\splus82_WIN386\Tibrary/discreteChoice

Note that some examples in this package use functions from
the TowDiscrepancy package
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Open the Search Path to see that the library appears in your search
path:

&l cansale %‘i. Objects S_'I Search Path &3 E_==.E Output ] Tasks [3_\ P

Search Path
1 D: ~WORKSPACE
2 bigdata
3 =plus
4 =stat
5 data
6 trellis
7 curl
a nlmel
9 winjawva
10 meEn
11 SPEHL
dizcreteChoice

13 main

Figure 4.40: discreteChoice in the search path.

Updating a If you have a downloaded a package, and a newer version is available
Package from from a repository, you can find the newer version using the Update
Package option. The Update Package dialog shows only packages
that differ from the versions that you currently have; otherwise, the
list is empty.

a Repository

S| Update Packages

Type: O Source @ Binary

Repository: | http:ffcsan.insightful.com + | |Update
Packages: | adk
calibration

Install Options
®in i

(O Install Binary + Load

Cancel

Figure 4.41: Update Packages dialog.
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To update a package

L.
2.

From the menu, click Spotfire S+ » Update Packages.

On Windows, in the Update Packages dialog, select the type
(either Source or Binary). UNIX updates only source
packages.

Select the repository where the newer package exists.

From the list, select the package to update, and then select the
Install Options:

* Install Binary
* Install Binary + Load

+ Copy Source to Project Directory
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SPOTFIRE STATISTICS SERVICES REMOTE SUBMISSIONS

Submitting a
Remote Job

178

By default, the Spotfire S+ Workbench displays the Statistics
Services view. To use this feature, you must have access to Spotfire
Statistics Services, a TIBCO service that you can use to run jobs on a
remote S-PLUS engine. See your server adminsitrator for more
information.

This section walks through
* Adding a new connection to Spotfire Statistics Services.
+ Connecting to an existing Spotfire Statistics Services server.
*  Submitting a job.
* Examining the contents of the resulting job’s folder.
*  Scheduling a job.
*  Monitoring jobs.
+ Uploading a package.
* Deleting a package.

For a description of the menu items and dialogs for this feature, see
the section Statistics Services view on page 76.

In the following example, send a job to Spotfire Statistics Services.
First, add a connection to the server. Then practice disconnecting
and reconnecting. Create a simple project with a script and send it to
Spotfire Statistics Services. Examine the results.

To add a connection

1. On the Spotfire Statistics Services view toolbar, click Add
Connection ( ¢ ).

2. In the dialog Add Service Connection, provide a friendly
name, a server URL, and your user credentials (name and
password). You are required to provide a password only if
authentication is enabled on the server. Note that your
password is persisted only for the duration of the current
Workbench session, and you must provide your credentials
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for subsequent Workbench sessions. (Alternatively, you can
provide your password in the selected Service Properties
dialog prior to connecting.)

The server URL contains the server name, port number, and
“SplusServer” (for example,
http://myserver:8080/SplusServer).

The default port is 8080. See your server administrator if you
do not know your exact server address.

S* Add Service Connection = | B
Service Name  Test Server
Server URL: http:/testingserver5:8080/5plusServer -
User Name:  janedoe

Password: ssssssnsnas

Figure 4.42: Add Server Connection dialog.

3.

Click Submit to add and connect to the server. Note that the
service name you supplied appears in the Statistics Services
view, with a folder icon decorated with a green check,

indicating the service is connected. ( ‘)

For more information about completing the dialog, see the section
Add Service Connection on page 83.

To disconnect and connect to a server

L.

After you completed the step to add a service, select its name
in the Statistics Services view. On the toolbar, click

Disconnect from a Remote Service (7 ).

Note that the service’s folder in the Statistics Services view
no longer has a green checkmark.

Select your service folder again, and on the toolbar, click

Connect to a Remote Service (=!). The service is
reconnected.
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To submit a job

L.

Create a new project called sample_scripts and make it your
working project. Create a new file, a Spotfire S+ script, in the
project and call it samplescriptl.ssc.

Copy and paste the following example code into the Script
Editor:

java.graph("mygraph.spj", format="SPJ")
show.settings()

dev.off()

* Remember that you can run jobs on Spotfire Statistics
Services only from the Script Editor, not from the
Console.

*  You can run either the entire script, or you can run only
the selected code.

In the Spotfire Statistics Services view, select the service
where you want to run the example.

In the Spotfire Statistics Services view, on the toolbar, click
Run ( g ).

Note

Make sure you click the Run button on the Statistics Services view toolbar to run your script in
the Spotfire Statistics Services S-PLUS engine. The Run button on the Workbench toolbar runs
your job in your local S-PLUS engine.
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5.

Note that the service folder expands the Jobs folder to display
the folder for the running job. When the run is done, if it has
run successfully, a green checkmark appears on the folder,
and the folder name changes from JobID (Waiting) to JobID
(Done). (This job is short, so it should run immediately.)

To examine a job

L.

Expand the job folder containing the job run in the previous
steps. Note that when you expand the folder, the label
changes from boldface to regular typeface to indicate you
have examined it.
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Expand the Results folder and examine the contents:
engine.log and mygraph.spj.

* Double-click engine.log to display its contents in the
Output view.

* Double-click mygraph.spj to display the graph resulting
from the code in a Graph Window.

Double-click Return Value. Its contents are displayed in the
Output view and includes the following:

> retVal.ComputerName.JobID

null device
1

(dev.off returns the number of the current device after the
device was shut down. By default, it is 1.)

Double-click Script. Its contents are displayed in a new Script
Editor. The script’s label bears an identifier, as follows:
scriptjob_ComputerName_JobID_scriptGUID.

The contents of the Script Editor should match the code that
you ran. You can close this script.

To schedule a job.

L.

Leave the script window open, and in the Spotfire Statistics
Services view, select your service.

In the Statistics Services view, click schedule ( @ ).

Examine the dialog for current time and date, and check the
server time zone, and if your server is running at a time
different from your computer. (If so, adjust the example
accordingly.)
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4. Leave the calendar date, but in the time spin control,
highlight the minutes and set the time to run the job 1-2
minutes ahead of the current time. ,

5% Schedule on Local Server L&J

Server Info
Server Time Zone  Pacific Standard Time

Current time 9/22/10 5:07 PM

Server is ahead by 0 hours 0 minutes

4 September, 2010 L4

Sun Mon Tue Wed Thu Fri Sat
2% 3 31 1 2 3 4
5 6 7 8 9 10 1.1
12 13 14 15 16 17 18
19 20 21 2 M 5
% 27 28 2/ 30 1

3 4 5 6 71 8

R

508 PM 2

( % | [ cancel

Figure 4.43: Job scheduled two minutes out.

4 |[=g Local Server
a = Data
> (= appdata
s = artifacts
» [ common
> (= tscg
s [ users

a = Jobs
> I3 265 (Scheduled on Wed Sep 22 17:09:00 PDT 2010)

- g 264 (Done)

Figure 4.44: Statistics Services view displaying scheduled task.

5. Examine the Statistics Services view for the information
provided in the label. The job should run quickly when the

scheduled time is reached.

Note

Scheduled jobs do not appear in the Monitor Jobs view.
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To monitor a job.

1. On the Spotfire S+ Workbench menu, click File > Open
File, and then browse to the following file:

SHOME/samples/bigdata/boston/bostonhousing.ssc.

(where SHOME is your Spotfire S+ installation directory.)

2. Click File > Save As and save this script to the
sample_scripts project.

3. In the Statistics Services view, select your Spotfire Statistics
Services, and then on the toolbar, click Monitor server jobs
( ﬂ) Note that the Monitor Jobs view opens, by default,

tabbed with the Console view, Objects view, Output view,
and so on. Also note that its tab label displays the name of
your selected Spotfire Statistics Services.

= = 19 boston.nousing.bd, exprs = "log (MEDV) ",
5% Outlin | 5] Histor | 474 Statist 2 o) Zg names = "LMEDV™)
+ =2 HEODa|
= G Local Server
. — Dsf Bl Console [%3 Objects | $1] Search Path |53 Output |2 Tasks [ [ZK Problemns [(5h LocalServer £3
- obs
%ﬂ 216 (Done) JobID  Date Status Username

- G 215 (Done)
- (g 214 (Done)
- g 213 (Done)
- g 212 (Done)
> = Packages

Figure 4.45: Momnitor Jobs view.
4. In the Statistics Services view, expand the Jobs folder for
your Spotfire Statistics Services.
5. In the Statistics Services view, click Run three times.

6. Examine the results in the Monitor Jobs view. These jobs
should finish quickly.

5 : - oy
5= Qutlin | 5] Histor [Sbstmtst 230 — D] &, ’j:j::‘z“‘f:;;gfd Sprd = Mley )ty
+FEEHO0@9
4 & Local Server T ) ) Tt
" gilt: [ Console | %% Objects | 87 Search Path | ¥ Output | &2 Tasks [[2 Problems | £ Local Server 52

(= 221 (Waiting) Job ID Date Status Username
(= 220 (Waiting) m Won Sep 13 15:07:40 PDT 2010 Running TSI-PA/kroan
& 219 (Waiting) 220 Mon Sep 13 15:07:40 PDT 2010 Running TSI-PA/kroan
& 216 (Done) 219 Mon Sep 13 15:07:39 PDT 2010 Running TSI-PA/Kroan
(&g 215 (Deone)
2/ 214 (Done)

Figure 4.46: Jobs queued in Spotfire Statistics Services, displayed in the Monitor
Jobs view.

183



Chapter 4 TIBCO Spotfire S+ Workbench Tasks

Managing Data You can upload and download files, including data files, from the

Files on Statistics Services view.

Spotfire To upload a data file

Statistics 1. Select the running service, and expand its folder.

Services 2. Select the Data folder, or one of its subfolders (depending on

where you want to store your data file).

3. Right click the folder, and from the right-click menu, select
Upload File.

4. Browse to the location of your data file. For example, browse
to:

SHOME/samples/bigdata/stocks

5. Select a file to upload (for example, cbe.csv), and then click
Open (OK on UNIX). The file is added to your Data folder.

To preview a data file and get the summary information

1. Expand the Data folder to find the file you just uploaded.
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2. Right click the file name, and from the right-click menu, click
Preview File.

o= Outlin | 8] Histor | 4ib Statist &3 =

FEE N0 O
4 [ Local Server
a = Data
> (= appdata
s = artifacts
: [ common
> = tscg
s [ users
@8 che.csv
28
» = Job
. = Pa
> (g My Lin
> (g Sampl

i)

Remove Service

Disconnect Service

Refresh

Run Job Alt+F9
Schedule Job

Menitor Jobs

Service Properties

Download File

Delete File

X I@meoOM% X

g review File

& Summary Of Data

Figure 4.47: Data right-click menu.

3. Review the contents in the Output view.

El Console %‘i. Objects S_'I Search Path E_==.E Cutput &2 \E,Tasks |_—E_ Problems
> preview.cbe.csv

DATE OFEM HIGH LOW CLOSE WVOLUME
11/01/2004 00:00:00.000 63.74 64.95 £3.47 64.76 641300
10/29/2004 00:00:00.000 62.30 64.04 £2.30 §3.90 723500
10/28/2004 00:00:00.000 62.40 62.74 61.20 62.50 500000
10/27/2004 00:00:00.000 61.45 62.61 61.40 62.60 385200
10/26/2004 00:00:00.000 61.25 61.81 60.70 §1.81 599200
10/25/2004 00:00:00.000 60.86 61.15 60.25 §61.01 7243200
10/22/2004 00:00:00.000 62.10 62.50 60.22 §1.02 620800
10/21/2004 00:00:00.000 60.29 62.26 59.85 62.05 B24500
10/20/2004 00:00:00.000 60.65 60.80 59.96 60.25 1182000

[E I I T I PV

Figure 4.48: Data preview for cbe.csv.

By default, the preview displays 10 rows, the first row
containing the column headings. The preview also includes a
line containing the data preview object prefix (preview) and
the data file name (cbe.csv, in this case). You can change both
the data preview object prefix and the number of rows to
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Exporting a
Package to
Spotfire
Statistics
Services
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preview in the Window > Preferences dialog. See the
section Statistics Services Options on page 25 for more
information.

4. Right click the data file again, and this time, select Summary
of Data.

5. Review the results in the Output view, including the data
summary value prefix (also editable in the Window >
Preferences dialog).

To download a data file

1. Right click the file a third time, and from the menu, select
Download File.

2. Browse to a location to store the file, or click Cancel.

To delete a data file

+ Right click the file in the Data directory, and from the menu
click Delete File. Click OK.

In this task, export the Soundex package that you created previously,
in the section Creating a New Package Project on page 168.

To upload a package to Spotfire Statistics Services

1. In the Statistics Services view, make sure you are connected
to the remote service. (For more information about this see
the section To add a connection on page 178.

2. In the Navigator view, select the Soundex package, which
you created as part of the exercise in the section Building the
Package on page 170.

3. Click File > Export.

4. In the Export dialog, expand Statistics Services, and then
select Spotfire S+ Package Upload.

5. Click Next.

6. In the Select server to deploy to drop-down, select your
Spotfire Statistics Services from the list.

7. Click Finish.
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8. In the Statistics Services view, for your service, expand the
Packages folder. The Soundex package should appear.

9. In the Script Editor, type Tibrary(Soundex), and run it from
the server.

10. In the Script Editor, type search(), and run it from the server.

11. In the Statistics Services view, expand the job you just ran,
and double-click Return Value. The Output view displays
the search path. Soundex should appear on the list.

Notes

*  You must have Perl version 5.8 or later to export a package.
+  Exporting as a package for Windows builds a binary.

*  The package must be in the S-PLUS engine’s INIT file on the server to be loaded and
used when the S-PLUS engine is loaded. See your server administrator if you want to
have this option set. Alternatively, before using functions in an uploaded package, type
library(packagename).

+  The package is uploaded to the server as an unprotected package. (That is, you can
delete it later.)

See the TIBCO Spotfire Guide to Packages for more information.
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SPOTFIRE S+ WORKBENCH DEBUGGER TASKS

This section describes basic tasks you will want to know how to
perform on a simple file set.

Note

If you open a file using the File » Open File menu command, and that file is not in a Spotfire
S+ Workbench project, you cannot set a breakpoint in that file.

The following instruction works with the kahanSum example, located in your SHOME/
samples/directory. To create a kahanSum project, follow the steps to create a project (see the
section Quick Start on page 127).

Kahan
Example

Opening the
Debug
Perspective

188

In numerical analysis, the Kahan summation algorithm minimizes the
error when adding a sequence of finite precision floating point
numbers. (It is also called compensated summation. This algorithm is
attributed to William Kahan.)

The Spotfire S+ Debugger example uses a simple Kahan summation
algorithm captured in two files. If you have not already done so,
create this project and import the example files. See the section
Adding the Sample Debugging Project on page 136.

The project’s two files are as follows:
+ kahanSum.q contains the function kahanSum.

+ kahanAddNext func.q contains the function, kahanAddNext,
which is called by the function kahanSum.

Before using the Workbench Debugger and Profiler, you must open
the Debug perspective. If you have closed your project in the
previous exercise and want to continue practicing using the Spotfire
S+ Debugger, first re-open your project, and open the two files in the
Script Editor. Next, change to the Debug perspective.

For a more in-depth description of the Debug perspective, see the
section Debug Perspective Options and Preferences on page 92.

To open the Debug perspective
1. On the perspective toolbar, click Open Perspective.
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2. From the menu, select Debug.

B 5-PLUS - kahanAddNest_fun<.q - 5-PLUS Workbench

i t_func.q  ksharn meady | | wrkstle B

Figure 4.49: The Open Perspective menu options.

The Debug perspective button appears to the left of the
Spotfire S+ perspective button, and the perspective changes
to the Debug perspective as shown in Figure 4.50.

=10l x|
B |3 Debug. s 5-PLUS

ns | Function Calls | Allocations | i =0

i =

Figure 4.50: Selecting the Debug perspective.

Now, you can toggle between the Spotfire S+ perspective and the
Debug perspective by clicking their respective buttons. The Debug
perspective button stays visible in this and future Spotfire S+
Workbench sessions, unless you close it by right-clicking its button
and clicking Close.

Launching the To start debugging, first activate the Spotfire S+ debugger using one
debugger of the following methods:

*  On the toolbar, click Toggle Spotfire S+ Debugger (% ).
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Setting
breakpoints

190

On the menu, click the Run » Toggle Spotfire S+
Debugger.

On the keyboard, press CTRL+ALT+D.

After you activate the debugger, any expression you type in the

Console, or that you run by clicking Run Spotfire S+ Code ( » ) on
the toolbar, invokes the debugger.

One of the most basic debugging tasks is setting a breakpoint. Set
breakpoints at locations in your code where you want to evaluate
variables. In this exercise, set the breakpoints in the Script Editor. For
a more in-depth description of the Script Editor, see section Spotfire
S+ Workbench Script Editor on page 57.

To set the breakpoints

L.

From the Project files, open the file kahanAddNext func.q
in the Script Editor. (Note that to work with the debugger,
your

Find the line in the code that reads:
correctedX <- nextX + kahanValues[["correction"]].

In the left margin, right-click to display the menu, and then
select Toggle Breakpoint. (Double-clicking the left margin
next to the code line also adds the breakpoint.)

Open the file kahanSum.q in the Script Editor.

Find the line in the code that reads:
kahanValues <- kahanAddNext(x[i], kahanValues).
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6. Repeat step 3 to put a breakpoint at this line.

kahanaddiext_func.q
T @R oISl WOl LAy Lo ;I
7 ## Calls the function, kahanlddNext, which
& ## iz stored in another file.

2

10="kahanZum™ <- function(x)

11 |

1z ## Initialize values

13 kahanWalues <- list(sum = 0.0 , correction = 0.0)

14 ## Perform the Eahan swmmation

15 N <- lengthi(x)

1a= fori{i in 1:H)

17 {

%18 kahan\fallues <— kahaniddWNext (x[i] , kahanValues)

19 ¥

20 return (kahanValues[["sum™]])

z1 1}

2Z ## Put breakpoint at kahanValues <- kahanlddNext (x[i], kahanValues)

23 ## to track wvhere corrections occur in the for() loop. L

24 -
« | 2

Figure 4.51: Breakpoint set in the kahanSum function.

Note

Setting breakpoints in code files the Spotfire S+ Workbench does not affect the file if you open it
in the Spotfire S+ GUI in Windows. Breakpoints are evaluated only in the Spotfire S+
Workbench, and only when the debugger is engaged.

To examine your breakpoints

1. Click the Breakpoints view tab. Both breakpoints you set
appear in this view.

Watiables | Expressions | ®e Ereakpoints &3 Funiction Calls|AIIOcations| =0
RR#A | HEERT

¥ @ kahanaAddiext : kahanaddiext_func.q [line: 7]

-[¥] @ kahan3um : kahanSum.q [line: 18]

Figure 4.52: kahanSum breakpoints in Breakpoints view.
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Starting
execution

192

2.

Right-click the breakpoint kahanAddNext, and from the
context-sensitive menu, click Go to File. Note that the
kahanAddNext_func.q file opens in the Script Editor, and
the line with the breakpoint is highlighted.

In the Breakpoints view, clear the check box next to the
kahanAddNext breakpoint. Note that the icon changes from a
solid circle to a blank circle in both the Breakpoints view and
in the Script file margin. This action disables the breakpoint in
future sessions but does not remove it.

Select the check box to enable the breakpoint.

On the Breakpoints view toolbar, click Skip All
Breakpoints (x). Toggling this option disregards but
maintains (that is, does not remove or disable) all breakpoints
in the Breakpoints view.

Take some time manipulating the breakpoints using the menu
options and buttons in the Breakpoints view. For a more in-
depth description of the Breakpoints view, see section
Breakpoints view on page 113.

When you have finished, re-set the breakpoints in the files as
described in the section To set the breakpoints on page 190.

Before you run the debugger, first initialize the objects and set the
output display option.

To initialize the objects

L.
2.

3.
4.

Open the file kahanAddNext_func.q in the Script Editor.
On the toolbar, click Run Spotfire S+ Code ( & ).
Repeat steps 2 and 3 for the file kahanSum.q.

In the Console, at the prompt, type the following code:
options(digits=17)

To start the debugging session

L.
2.

Engage the debugger by clicking its toolbar button ().

Click the Debug view tab to display its contents.
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3. In the Console, at the prompt, type the following code:
kahanSum(rep(1000000000.1, 10))

Examining the After you have started the debugging session, examine the UI:

cal I StaCk Bl Debug - kahanSum.q - 5-PLUS Workbench B

Fle Edt SPLUS Nawgate Search Project Fun Window Help
- & %R T i B-0-Q- ¥ [ | % Debug | &* SPLUS
G ble .
4 Dobug Mavigator = O || variables | P Bresbpoinks 1 . Expressions | Function Cabs Mlocations| )
= # % BEG”
[#] ® kahanaddMext : kahandddest_func.q [ine: 10]
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Figure 4.53: At the first breakpoint in kahanSum.

To examine the call stack
1. Note that the Script Editor highlights the breakpoint line.
2. Note that the Debug view shows the contents of the call stack.

Myavigator | =8

OB |z = k=

E-%# debug [5-PLUS]
=& 5-PLUS Call
=

Figure 4.54: The Debug view containing the call stack.

To resume debugging

1. Resume debugging by clicking the Resume button ( ).
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2.

Re-examine the Debug view, and note that the debugger
stops at the next break point: the first breakpoint in the
kahanAddNext function.

For a more in-depth description of the Debug view, see the
section Debug view on page 100.

To remove a breakpoint mid-session and resume debugging

L.

You don’t need the breakpoint in kahanAddNext, so remove it.
In the Breakpoints view, select the breakpoint for
kahanAddNext.

On the Breakpoints view toolbar, click Remove Selected
Breakpoints ( x ).

Click the Resume button again to run the debugger to the
next breakpoint. The code runs the for loop and stops at the
kahanSum breakpoint again. Observe the results in the Debug
view.

Click Resume a few more times to continue debugging to the
first calculate correction. In the next section, examine the
results of the first calculated correction.

Examining As you debug, at each breakpoint or step, the debugger re-evaluates
Variables and the variables and displays the results in the Variables view. At any

Expressions

breakpoint or stopping point, you can review, but not edit or alter, the
variables at the current frame.

For a more in-depth description of the Variables view, see the section
Variables view on page 106.

To examine the variables

1.
2.
3.
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Click the Variables view to display its contents.
In the Debug view, highlight the last line in the call stack.

Note that the Variables view displays the variables resulting
from the code run so far.
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4. Highlight a variable in the Variables view and note that its
value is displayed in the Details pane.

m\EXDressions|Breakpoints|Functi0n Calls|AIIOcations| L =

ON=[1]10
|—[1]4

1] | ol
[1] 3000000000.3000002 |
joorrection:

E.I] -1.1920925955075125e-007 Alj
A »

Figure 4.55: Variables view during debugging session.

5. On the Variables view toolbar, click the Show Type Names
button ('z ). Note that the Variables view now displays the
variable type information.

m\Expressions|Breakpoints|Function Calls|AIIOcations| =

-4 4Type=numeric{integer) - Length=1 - Extent=45 - Date=0} N =[1] 10
@ {Type=numeric{integer) - Length=1 - Extent=45 - Date=0} i=[1]4

4| | >

$3um ﬂ
[1] 3000000000.3000002

joorrection: -
A 3

Figure 4.56: Variables view showing type names for the variables.

6. Take some time examining the variables using the menu
options and buttons in the Variables view, clicking Resume
in the Debug view and watching the variables change.

You can track variable assignments in the Variables view, and you
can track variables and expressions in the Expressions view. This
section demonstrates how to track individual variable assignments
and interesting expressions.

Note on Expressions

An expression is any syntactical interaction that Spotfire S+ can
evaluate. Expressions persist from session to session. Spotfire S+
recognizes a wide variety of expressions, but in interactive use the
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most common are names, which return the current definition of the
named data object, and function calls, which carry out a specified
computation. Any of the following are Spotfire S+ expressions:

1:10
rnorm(5)
mean(1:10)
traceback()

If you were debugging a function, for example:

incrementByTwo <- function(x) {
* X+ 2

}
you could have an expression that evaluated:

X+ 2
at the breakpoint (denoted with the * in the above function
definition).

For more information about expressions, see the Programmer’s Guide,
or see the Spotfire S+ Help topic ExpressionLanguage.

To watch expressions

1. Right-click the Expressions view to display the context-
sensitive menu.

2. From the menu, select Add Watch Expression.
3. Inthe Add Watch Expression dialog, type the following:

kahanValues[["sum"]]

B Add Watch Expression - @E|

Expression:
kahanValues[ [ "=um"] ] |
[¥]Enable N

Figure 4.57: Add Watch Expression dialog with expression added.
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Add a second expression to watch:
kahanValues[["correction"]]
Click the Variables view and right-click the variable x.

On the context-sensitive menu, click Create Watch
Expressions.

The debugger returns to the Expressions view. Note that the
variable X is now on the list.

Add the following two more expressions to watch:

sum(x)
sum(x)-kahanValues[["sum"]]

The first expression provides the sum of the variable x.

The second expression provides the difference between the
sum of x and the sum of kahanValues.

Optionally, restart debugging to start evaluating the expressions from
the start, pausing to see the results between the Variables view and
the Expressions view.

Variables B Breakpoints|Function Calls|AIIOcations| =0

t oo % % T

250 "kahanvalues[["sum"]]" = [1] 1000000000, 1
¥ "kahanyalues[["correction"]]" = [1] 0

l |

[1] 7000000000, 7000017

4 o

Figure 4.58: Evaluating expressions.

Other common debugging tasks include stepping through, over, and
out of a routine’s functions. When you step through a routine, the
debugger pauses at every function and function body, giving you the
opportunity to examine the results. This feature is also used to enter
if/else statements, for loops, while loops, and other routines.
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To step into a routine

1. Click the Step Into button ( = ). Repeat to continue to step

into routines and their bodies.

2. Note that as you click Step Into, the code being evaluated is
highlighted in the Script Editor and is evaluated in the call

stack.

3. Keep stepping into the code until you come to an internal

function. (See Figure 4.59).

Because this function is not in your project files, note that the
function is displayed in a temporary file. (You can set a
breakpoint in such a function, and continue to evaluate it in

future debugging sessions.)

EIJl.‘Iaul Ed1CDODE. tmp - 5-PLUS Workbench
Fie Edt SPLUS Navigste Search Project Run Window Help

M kehansum.q [ kshanadde:t furc.g [ zdmue[?u

1f('missing(data) &£ inheritsidata, "bdFram=")) |
m <- match.call()
mimethod <- mimodel <- mix <- mpy <- HULL
=[[1]] <- as.nam={*bdlm"}
recurn(eval m, sys.parent())]

call <- watch.eall()

m <= macch.call [expand = F)

mimethod <- mimodel <- mix <- Wiy <- micontrascs <- m§... <- N
midrop.unused. levels <- T

mi[1]] <- a=.neme("model.frame)

Tasks | Oukput o &

CoDOCUME-1. .dICD0DE.tmp | ' kaharSum Ry ‘Wiritah

& W% S0 HF-0"Q- - 3 - B | 45 bebug | & SRS
Blmplen @
W pebug L Mawgator = OO |t vaniables 1 . Brekpoints | Expressons | Punction Calls | Akcations| 0
L | i . =
= T debug [5-PLUS) s Value ~
= @ saus cal N [
= o 1], hah 'Y [0
= kaharum > 3t kshanSum{Z) from 1 @ kshanVauss $aumein{1] Dirdcoenection:\n{1] 0

3
+ @ Wnlformuta,data, weiohts,subset, na.act

Figure 4.59: Stepping into a function displayed in a temporary file.
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You can also step over a function (= ), or you can step out of a

function (¢ ), using the buttons on the Debug view toolbar.

Note

If you are debugging using the Run button, rather than running a function via the Console view,
when you reach the last expression, you can find yourself in internal Spotfire S+ code. To avoid
this situation, type the name of the function and parameters in the Console view instead. See the
section Debugging Using the Run Button on page 206 for more information.

Examining You can track resource allocation usage by engaging the Spotfire S+
Resource Workbench Profiler.
Usage To track resource usage

1. On the Spotfire S+ Workbench main menu, click the Profiler

button ( % ) to toggle it on.

2. Click the Allocations view tab.

3. Examine the resource usage. Note that it is sorted
alphabetically by type. Click the Type column head; note that
the view is now sorted in reverse.

4. Click the Amount column head; note that the view is now
sorted by amount, smallest to largest.

5. Click Amount again; note that it re-sorts, largest to smallest.

6. Click the drop-down menu, and then click Reset
Allocations. Note that the table is cleared.

Examining In the next section, examine the functions used in the example. You

Function Calls can examine the functions either in an expandable tree view or in a
table view. (Make sure the Profiler is engaged by toggling on the
Profiler button on the main menu.)

To track functions used

1.

Click the Function Calls view tab.
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2.

Examine the tree. Note that after each function, in
parentheses, is the amount of time the function call took to
run.

Scroll down to the kahanAddNext function, expand the
selection, and examine the time values.

ariables Expressions|Breakpoints fllocations| — — O
[#]- Debug. deparse {156 ms) ;I

: Debug.objects {1969 ms)

Debug.deparse (10000 ms) J
hanaddrlext (15 ms)

=+ {<1 ms)

Debug.deparse (219 ms)
[+ Debug.traceback (47 ms)
[+ Debug.deparse (141 ms) =

Figure 4.60: Tiee view of the Function Calls view.

4.

Right-click the Function Calls view and click Show
Function Tree to clear it.

Examine the resulting table.

Scroll down to the kahanAddNext function and review the call
count (that is, number of times called so far) and duration.

ariables | Expressions | Breakpoints QM ﬁ fllocations| — — O
Function | Call Count | Duration {(m=) | ;I
is. matrix 9 1]
iz.na 177 102z
is.numsric 305 766
izClipboard. .. 41 109
isGensric 59 171
i=0bject 592 1655 J |
i=01dClass 32 645
isVirtualClass 32 62
javaGuiCbje. .. 9 4781

cahaniddNext g 122
kahanSum 1 1] LI

Figure 4.61: Table view of the Function Calls view.
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INTRODUCTION

This section provides information about using TIBCO Spotfire S+
code in the Workbench, and presents workarounds and solutions for
special cases you might encounter.
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“Workspace in Use” Error

“WORKSPACE IN USE” ERROR

Occasionally, when you start the Spotfire S+ Workbench, you might
see an error that the workspace is already in use when you have not
been running a Workbench session.

This problem occurs when you switch computers or versions of
UNIX, and you have changes to absolute paths to a given directory.

1. Check your computer to ensure that the path listed in the
Workspace Selection dialog exists.

2. After you set the appropriate path to an existing workspace, if
the problem persists, check for a .ock file in the
WORKSPACE/.metadata directory. Delete this file.

3. If you do not find a .lock file, check the running processes to
see if old Eclipse processes are running that point to the
workspace. End the processes and try re-starting the Spotfire
S+ Workbench.
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WORKING WITH CALLS TO SPOTFIRE S+ GUI FUNCTIONS

204

While you are working with Spotfire S+, you might encounter
libraries or sample code that include calls to Spotfire S+ GUI
functions. For example, the nSurvival library includes calls to
guiCreate and guiRemove functions in their .First.lib and
.Last.1ib objects, respectively.

To solve this problem, in .First.1ib and .Last.1ib functions, wrap
the code that creates and removes Windows GUI elements in
conditional statements. For example:

if(interactive() && platform() == "WIN386" &&
getenv("S_ECLIPSE") == "") {

jHt...Code that creates or removes Windows GUI elements...#Ht
}



View is Not Visible

VIEW IS NOT VISIBLE

If you accidentally close a view, or if the view you want to see is not
visible, on the Windows » Show View menu, select the view to
display. If the view to display is not on this list, click Other to display
the Show View dialog, and then select the folder, and then the view
to display.
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DEBUGGING USING THE RUN BUTTON

206

When you use the Run button to invoke a debug session rather than
using the Console, and you come to the last expression and click
Step, Step In, or Step Out, you can end up in internal Spotfire S+
functions that are called by your code.

This behavior occurs because any time you click Run, the expression
that Spotfire S+ runs is wrapped in a complex S expression designed
to capture parse errors, syntax errors, and so on.

To avoid finding yourself in this internal code, run the function by
typing it in the Console.



Subclipse Add-in Error with Workbench

SUBCLIPSE ADD-IN ERROR WITH WORKBENCH

If you are running the Subclipse add-in while you run the Spotfire S+

Workbench in Microsoft Windows®, you might see the following
error when you switch between projects:

"Unknown problem executing expression (interrupt?)”

It is possible to remove this problem by performing an SVN Cleanup
operation in the Workbench.
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